eBay.Service.Call Namespace

eBay .NET SDK v981 Release reference library
eBay.Service.Call Namespace
Namespaces ► eBay.Service.Call
Declaration Syntax
C# Visual Basic Visual C++
namespace eBay.Service.Call
Namespace eBay.Service.Call
namespace eBay.Service.Call
Types
All Types Classes
Icon | Type | Description
 | AddDisputeCall |
 | AddDisputeResponseCall |
 | AddFixedPriceItemCall |
 | AddItemCall |
 | AddItemFromSellingManagerTemplateCall |
 | AddItemsCall |
 | AddMemberMessageAAQToPartnerCall |
 | AddMemberMessageRTQCall |
 | AddMemberMessagesAAQToBidderCall |
 | AddOrderCall |
 | AddSecondChanceItemCall |
 | AddSellingManagerInventoryFolderCall |
 | AddSellingManagerProductCall |
 | AddSellingManagerTemplateCall |
 | AddToItemDescriptionCall |
 | AddToWatchListCall |
 | AddTransactionConfirmationItemCall |
 | CompleteSaleCall |
 | ConfirmIdentityCall |
 | DeleteMyMessagesCall |
 | DeleteSellingManagerInventoryFolderCall |
 | DeleteSellingManagerItemAutomationRuleCall |
 | DeleteSellingManagerProductCall |
 | DeleteSellingManagerTemplateAutomationRuleCall |
 | DeleteSellingManagerTemplateCall |
 | DisableUnpaidItemAssistanceCall |
 | EndFixedPriceItemCall |
 | EndItemCall |
 | EndItemsCall |
 | ExtendSiteHostedPicturesCall |
 | FetchTokenCall |
 | GetAccountCall |
 | GetAdFormatLeadsCall |
 | GetAllBiddersCall |
 | GetApiAccessRulesCall |
 | GetBestOffersCall |
 | GetBidderListCall |
 | GetCategoriesCall |
 | GetCategoryFeaturesCall |
 | GetCategoryMappingsCall |
 | GetCategorySpecificsCall |
 | GetChallengeTokenCall |
 | GetCharitiesCall |
 | GetClientAlertsAuthTokenCall |
 | GetContextualKeywordsCall |
 | GetDescriptionTemplatesCall |
 | GetDisputeCall |
 | GeteBayDetailsCall |
 | GeteBayOfficialTimeCall |
 | GetFeedbackCall |
 | GetItemCall |
 | GetItemsAwaitingFeedbackCall |
 | GetItemShippingCall |
 | GetItemTransactionsCall |
 | GetMemberMessagesCall |
 | GetMessagePreferencesCall |
 | GetMyeBayBuyingCall |
 | GetMyeBayRemindersCall |
 | GetMyeBaySellingCall |
 | GetMyMessagesCall |
 | GetNotificationPreferencesCall |
 | GetNotificationsUsageCall |
 | GetOrdersCall |
 | GetOrderTransactionsCall |
 | GetPromotionalSaleDetailsCall |
 | GetSellerDashboardCall |
 | GetSellerEventsCall |
 | GetSellerListCall |
 | GetSellerPaymentsCall |
 | GetSellerTransactionsCall |
 | GetSellingManagerAlertsCall |
 | GetSellingManagerEmailLogCall |
 | GetSellingManagerInventoryCall |
 | GetSellingManagerInventoryFolderCall |
 | GetSellingManagerItemAutomationRuleCall |
 | GetSellingManagerSaleRecordCall |
 | GetSellingManagerSoldListingsCall |
 | GetSellingManagerTemplateAutomationRuleCall |
 | GetSellingManagerTemplatesCall |
 | GetSessionIDCall |
 | GetShippingDiscountProfilesCall |
 | GetStoreCall |
 | GetStoreCategoryUpdateStatusCall |
 | GetStoreCustomPageCall |
 | GetStoreOptionsCall |
 | GetStorePreferencesCall |
 | GetSuggestedCategoriesCall |
 | GetTaxTableCall |
 | GetTokenStatusCall |
 | GetUserCall |
 | GetUserContactDetailsCall |
 | GetUserDisputesCall |
 | GetUserPreferencesCall |
 | GetVeROReasonCodeDetailsCall |
 | GetVeROReportStatusCall |
 | IssueRefundCall |
 | LeaveFeedbackCall |
 | MoveSellingManagerInventoryFolderCall |
 | PlaceOfferCall |
 | RelistFixedPriceItemCall |
 | RelistItemCall |
 | RemoveFromWatchListCall |
 | RespondToBestOfferCall |
 | RespondToFeedbackCall |
 | ReviseCheckoutStatusCall |
 | ReviseFixedPriceItemCall |
 | ReviseInventoryStatusCall |
 | ReviseItemCall |
 | ReviseMyMessagesCall |
 | ReviseMyMessagesFoldersCall |
 | ReviseSellingManagerInventoryFolderCall |
 | ReviseSellingManagerProductCall |
 | ReviseSellingManagerSaleRecordCall |
 | ReviseSellingManagerTemplateCall |
 | RevokeTokenCall |
 | SaveItemToSellingManagerTemplateCall |
 | SellerReverseDisputeCall |
 | SendInvoiceCall |
 | SetMessagePreferencesCall |
 | SetNotificationPreferencesCall |
 | SetPromotionalSaleCall |
 | SetPromotionalSaleListingsCall |
 | SetSellingManagerFeedbackOptionsCall |
 | SetSellingManagerItemAutomationRuleCall |
 | SetSellingManagerTemplateAutomationRuleCall |
 | SetShippingDiscountProfilesCall |
 | SetStoreCall |
 | SetStoreCategoriesCall |
 | SetStoreCustomPageCall |
 | SetStorePreferencesCall |
 | SetTaxTableCall |
 | SetUserNotesCall |
 | SetUserPreferencesCall |
 | ValidateChallengeInputCall |
 | ValidateTestUserRegistrationCall |
 | VerifyAddFixedPriceItemCall |
 | VerifyAddItemCall |
 | VerifyAddSecondChanceItemCall |
 | VerifyRelistItemCall |
 | VeROReportItemsCall |
2008 Microsoft Corporation. All rights reserved.


AddDisputeCall Class

AddDisputeCall Class
Namespaces ► eBay.Service.Call ► AddDisputeCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddDisputeCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddDisputeCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddDisputeCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddDisputeCall()()()() |
 | AddDisputeCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddDispute(DisputeExplanationCodeType, DisputeReasonCodeType, String, String, String) |
 | AddDispute(String, String, DisputeReasonCodeType, DisputeExplanationCodeType) | For backward compatibility with old wrappers.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddDisputeRequestType for this API call.
 | ApiResponse | Gets the AddDisputeResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DisputeExplanation | Gets or sets the DisputeExplanation of type DisputeExplanationCodeType.
 | DisputeID | Gets the returned DisputeID of type String.
 | DisputeReason | Gets or sets the DisputeReason of type DisputeReasonCodeType.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddDisputeCall

Assembly: eBay.Service (Module: eBay.Service)


AddDispute Method

AddDispute Method
Namespaces ► eBay.Service.Call ► AddDisputeCall ► AddDispute()()()()
Members
Icon | Member | Description
 | AddDispute(DisputeExplanationCodeType, DisputeReasonCodeType, String, String, String) |
 | AddDispute(String, String, DisputeReasonCodeType, DisputeExplanationCodeType) | For backward compatibility with old wrappers.


AddDispute Method (DisputeExplanation, DisputeReason, ItemID, TransactionID, OrderLineItemID)

AddDispute Method (DisputeExplanation, DisputeReason, ItemID, TransactionID, OrderLineItemID)
Namespaces ► eBay.Service.Call ► AddDisputeCall ► AddDispute(DisputeExplanationCodeType, DisputeReasonCodeType, String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public string AddDispute(
    DisputeExplanationCodeType DisputeExplanation,
    DisputeReasonCodeType DisputeReason,
    string ItemID,
    string TransactionID,
    string OrderLineItemID
)
Public Function AddDispute ( _
    DisputeExplanation As DisputeExplanationCodeType, _
    DisputeReason As DisputeReasonCodeType, _
    ItemID As String, _
    TransactionID As String, _
    OrderLineItemID As String _
) As String
public:
String^ AddDispute(
    DisputeExplanationCodeType DisputeExplanation,
    DisputeReasonCodeType DisputeReason,
    String^ ItemID,
    String^ TransactionID,
    String^ OrderLineItemID
)
Parameters
DisputeExplanation (DisputeExplanationCodeType)
DisputeReason (DisputeReasonCodeType)
ItemID (String)
TransactionID (String)
OrderLineItemID (String)


AddDispute Method (ItemID, TransactionID, DisputeReason, DisputeExplanation)

AddDispute Method (ItemID, TransactionID, DisputeReason, DisputeExplanation)
Namespaces ► eBay.Service.Call ► AddDisputeCall ► AddDispute(String, String, DisputeReasonCodeType, DisputeExplanationCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public string AddDispute(
    string ItemID,
    string TransactionID,
    DisputeReasonCodeType DisputeReason,
    DisputeExplanationCodeType DisputeExplanation
)
Public Function AddDispute ( _
    ItemID As String, _
    TransactionID As String, _
    DisputeReason As DisputeReasonCodeType, _
    DisputeExplanation As DisputeExplanationCodeType _
) As String
public:
String^ AddDispute(
    String^ ItemID,
    String^ TransactionID,
    DisputeReasonCodeType DisputeReason,
    DisputeExplanationCodeType DisputeExplanation
)
Parameters
ItemID (String)
TransactionID (String)
DisputeReason (DisputeReasonCodeType)
DisputeExplanation (DisputeExplanationCodeType)


AddDisputeCall Constructor

AddDisputeCall Constructor
Namespaces ► eBay.Service.Call ► AddDisputeCall ► AddDisputeCall()()()()
Members
Icon | Member | Description
 | AddDisputeCall()()()() |
 | AddDisputeCall(ApiContext) |


AddDisputeCall Constructor

AddDisputeCall Constructor
Namespaces ► eBay.Service.Call ► AddDisputeCall ► AddDisputeCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeCall()
Public Sub New
public:
AddDisputeCall()


AddDisputeCall Constructor (ApiContext)

AddDisputeCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddDisputeCall ► AddDisputeCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddDisputeCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddDisputeCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddDisputeCall ► ApiRequest
Gets or sets the AddDisputeRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddDisputeRequestType
    Get
    Set
public:
property AddDisputeRequestType^ ApiRequest {
    AddDisputeRequestType^ get ();
    void set (AddDisputeRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddDisputeCall ► ApiResponse
Gets the AddDisputeResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddDisputeResponseType
    Get
public:
property AddDisputeResponseType^ ApiResponse {
    AddDisputeResponseType^ get ();
}


DisputeExplanation Property

DisputeExplanation Property
Namespaces ► eBay.Service.Call ► AddDisputeCall ► DisputeExplanation
Gets or sets the DisputeExplanation of type DisputeExplanationCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeExplanationCodeType DisputeExplanation { get; set; }
Public Property DisputeExplanation As DisputeExplanationCodeType
    Get
    Set
public:
property DisputeExplanationCodeType DisputeExplanation {
    DisputeExplanationCodeType get ();
    void set (DisputeExplanationCodeType value);
}


DisputeID Property

DisputeID Property
Namespaces ► eBay.Service.Call ► AddDisputeCall ► DisputeID
Gets the returned DisputeID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string DisputeID { get; }
Public ReadOnly Property DisputeID As String
    Get
public:
property String^ DisputeID {
    String^ get ();
}


DisputeReason Property

DisputeReason Property
Namespaces ► eBay.Service.Call ► AddDisputeCall ► DisputeReason
Gets or sets the DisputeReason of type DisputeReasonCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeReasonCodeType DisputeReason { get; set; }
Public Property DisputeReason As DisputeReasonCodeType
    Get
    Set
public:
property DisputeReasonCodeType DisputeReason {
    DisputeReasonCodeType get ();
    void set (DisputeReasonCodeType value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► AddDisputeCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► AddDisputeCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► AddDisputeCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


AddDisputeResponseCall Class

AddDisputeResponseCall Class
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddDisputeResponseCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddDisputeResponseCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddDisputeResponseCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddDisputeResponseCall()()()() |
 | AddDisputeResponseCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddDisputeResponse(String, String, DisputeActivityCodeType, String, String, DateTime) | This call enables the seller to respond to an Item Not Received (INR) dispute opened by a buyer through PayPal's Purchase Protection program, or to update an Unpaid Item case. To respond to a case opened by the buyer through eBay's Resolution Center, the seller should use the Resolution Case Management API, the Case Management calls of the Post-Order API, or manage the case through the eBay Resolution Center.
 | AddDisputeResponse(String, String, DisputeActivityCodeType) | For backward compatibility with old wrappers.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddDisputeResponseRequestType for this API call.
 | ApiResponse | Gets the AddDisputeResponseResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DisputeActivity | Gets or sets the DisputeActivity of type DisputeActivityCodeType.
 | DisputeID | Gets or sets the DisputeID of type String.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageText | Gets or sets the MessageText of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ShipmentTrackNumber | Gets or sets the ShipmentTrackNumber of type String.
 | ShippingCarrierUsed | Gets or sets the ShippingCarrierUsed of type String.
 | ShippingTime | Gets or sets the ShippingTime of type DateTime.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddDisputeResponseCall


AddDisputeResponse Method

AddDisputeResponse Method
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► AddDisputeResponse()()()()
Members
Icon | Member | Description
 | AddDisputeResponse(String, String, DisputeActivityCodeType, String, String, DateTime) | This call enables the seller to respond to an Item Not Received (INR) dispute opened by a buyer through PayPal's Purchase Protection program, or to update an Unpaid Item case. To respond to a case opened by the buyer through eBay's Resolution Center, the seller should use the Resolution Case Management API, the Case Management calls of the Post-Order API, or manage the case through the eBay Resolution Center.
 | AddDisputeResponse(String, String, DisputeActivityCodeType) | For backward compatibility with old wrappers.


AddDisputeResponse Method (DisputeID, MessageText, DisputeActivity)

AddDisputeResponse Method (DisputeID, MessageText, DisputeActivity)
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► AddDisputeResponse(String, String, DisputeActivityCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void AddDisputeResponse(
    string DisputeID,
    string MessageText,
    DisputeActivityCodeType DisputeActivity
)
Public Sub AddDisputeResponse ( _
    DisputeID As String, _
    MessageText As String, _
    DisputeActivity As DisputeActivityCodeType _
)
public:
void AddDisputeResponse(
    String^ DisputeID,
    String^ MessageText,
    DisputeActivityCodeType DisputeActivity
)
Parameters
DisputeID (String)
MessageText (String)
DisputeActivity (DisputeActivityCodeType)


AddDisputeResponse Method (DisputeID, MessageText, DisputeActivity, ShippingCarrierUsed, ShipmentTrackNumber, ShippingTime)

AddDisputeResponse Method (DisputeID, MessageText, DisputeActivity, ShippingCarrierUsed, ShipmentTrackNumber, ShippingTime)
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► AddDisputeResponse(String, String, DisputeActivityCodeType, String, String, DateTime)
This call enables the seller to respond to an Item Not Received (INR) dispute opened by a buyer through PayPal's Purchase Protection program, or to update an Unpaid Item case. To respond to a case opened by the buyer through eBay's Resolution Center, the seller should use the Resolution Case Management API, the Case Management calls of the Post-Order API, or manage the case through the eBay Resolution Center.
Declaration Syntax
C# Visual Basic Visual C++
public void AddDisputeResponse(
    string DisputeID,
    string MessageText,
    DisputeActivityCodeType DisputeActivity,
    string ShippingCarrierUsed,
    string ShipmentTrackNumber,
    DateTime ShippingTime
)
Public Sub AddDisputeResponse ( _
    DisputeID As String, _
    MessageText As String, _
    DisputeActivity As DisputeActivityCodeType, _
    ShippingCarrierUsed As String, _
    ShipmentTrackNumber As String, _
    ShippingTime As DateTime _
)
public:
void AddDisputeResponse(
    String^ DisputeID,
    String^ MessageText,
    DisputeActivityCodeType DisputeActivity,
    String^ ShippingCarrierUsed,
    String^ ShipmentTrackNumber,
    DateTime ShippingTime
)
Parameters
DisputeID (String)
The unique identifier of the eBay Unpaid Item case or PayPal INR dispute. This identifier is created by eBay or PayPal upon case/dispute creation.
MessageText (String)
The text of a comment or response being posted to the case/dispute. Required when DisputeActivity is SellerAddInformation, SellerComment, or SellerPaymentNotReceived. Otherwise, this field is optional.
DisputeActivity (DisputeActivityCodeType)
The type of activity the seller plans to take on the case/dispute. The allowed value is determined by the current state of the case/dispute and whether the seller is updating an Unpaid Item case or responding to a PayPal INR dispute.
ShippingCarrierUsed (String)
The shipping carrier used to ship the item in dispute. This field is not case sensitive in the AddDisputeResponse request. Non-alphanumeric characters are not allowed. This field (along with ShipmentTrackNumber) is required if the value of DisputeActivity is set to
SellerShippedItem
.
ShipmentTrackNumber (String)
The tracking number associated with one package of a shipment. The seller is responsible for the accuracy of the shipment tracking number, as eBay only verifies that the tracking number is consistent with the numbering scheme used by the specified shipping carrier, but cannot verify the accuracy of the tracking number. This field (along with ShippingCarrierUsed) is required if the value of DisputeActivity is set to
SellerShippedItem
.
ShippingTime (DateTime)
This timestamp indicates the date and time when the item under dispute was shipped. This field is required if the value of DisputeActivity is set to
SellerShippedItem
.


AddDisputeResponseCall Constructor

AddDisputeResponseCall Constructor
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► AddDisputeResponseCall()()()()
Members
Icon | Member | Description
 | AddDisputeResponseCall()()()() |
 | AddDisputeResponseCall(ApiContext) |


AddDisputeResponseCall Constructor

AddDisputeResponseCall Constructor
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► AddDisputeResponseCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeResponseCall()
Public Sub New
public:
AddDisputeResponseCall()


AddDisputeResponseCall Constructor (ApiContext)

AddDisputeResponseCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► AddDisputeResponseCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeResponseCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddDisputeResponseCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► ApiRequest
Gets or sets the AddDisputeResponseRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeResponseRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddDisputeResponseRequestType
    Get
    Set
public:
property AddDisputeResponseRequestType^ ApiRequest {
    AddDisputeResponseRequestType^ get ();
    void set (AddDisputeResponseRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► ApiResponse
Gets the AddDisputeResponseResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeResponseResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddDisputeResponseResponseType
    Get
public:
property AddDisputeResponseResponseType^ ApiResponse {
    AddDisputeResponseResponseType^ get ();
}


DisputeActivity Property

DisputeActivity Property
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► DisputeActivity
Gets or sets the DisputeActivity of type DisputeActivityCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeActivityCodeType DisputeActivity { get; set; }
Public Property DisputeActivity As DisputeActivityCodeType
    Get
    Set
public:
property DisputeActivityCodeType DisputeActivity {
    DisputeActivityCodeType get ();
    void set (DisputeActivityCodeType value);
}


DisputeID Property

DisputeID Property
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► DisputeID
Gets or sets the DisputeID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string DisputeID { get; set; }
Public Property DisputeID As String
    Get
    Set
public:
property String^ DisputeID {
    String^ get ();
    void set (String^ value);
}


MessageText Property

MessageText Property
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► MessageText
Gets or sets the MessageText of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string MessageText { get; set; }
Public Property MessageText As String
    Get
    Set
public:
property String^ MessageText {
    String^ get ();
    void set (String^ value);
}


ShipmentTrackNumber Property

ShipmentTrackNumber Property
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► ShipmentTrackNumber
Gets or sets the ShipmentTrackNumber of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentTrackNumber { get; set; }
Public Property ShipmentTrackNumber As String
    Get
    Set
public:
property String^ ShipmentTrackNumber {
    String^ get ();
    void set (String^ value);
}


ShippingCarrierUsed Property

ShippingCarrierUsed Property
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► ShippingCarrierUsed
Gets or sets the ShippingCarrierUsed of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingCarrierUsed { get; set; }
Public Property ShippingCarrierUsed As String
    Get
    Set
public:
property String^ ShippingCarrierUsed {
    String^ get ();
    void set (String^ value);
}


ShippingTime Property

ShippingTime Property
Namespaces ► eBay.Service.Call ► AddDisputeResponseCall ► ShippingTime
Gets or sets the ShippingTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ShippingTime { get; set; }
Public Property ShippingTime As DateTime
    Get
    Set
public:
property DateTime ShippingTime {
    DateTime get ();
    void set (DateTime value);
}


AddFixedPriceItemCall Class

AddFixedPriceItemCall Class
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddFixedPriceItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddFixedPriceItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddFixedPriceItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddFixedPriceItemCall()()()() |
 | AddFixedPriceItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddFixedPriceItem(ItemType) | Defines and lists a new fixed-price listing. The main difference between AddFixedPriceItem and AddItem is that AddFixedPriceItem supports the creation of fixed-price listings only, whereas AddItem supports all listing formats. Also, only AddFixedPriceItem supports multi-variation listings and tracking inventory by SKU. AddItem does not support Variations or the InventoryTrackingMethod field.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddFixedPriceItemRequestType for this API call.
 | ApiResponse | Gets the AddFixedPriceItemResponseType for this API call.
 | AutoSetItemUUID |
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Category2ID | Gets the returned Category2ID of type String.
 | CategoryID | Gets the returned CategoryID of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DiscountReasonList | Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | (Overrides ApiCall.Execute()()()().)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | ItemID | Gets the returned ItemID of type String.
 | ListingRecommendations | Gets the returned ListingRecommendations of type ListingRecommendationsType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewUUID()()()() | Generates a universal unique identifier.
 | OutputSelector | (Inherited from ApiCall.)
 | PictureFileList |
 | ProductSuggestions | Gets the returned ProductSuggestions of type ProductSuggestionsType.
 | ResetItemUUID(ItemType) | Sets or overwrites the UUID.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SKU | Gets the returned SKU of type String.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddFixedPriceItemCall


AddFixedPriceItem Method (Item)

AddFixedPriceItem Method (Item)
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► AddFixedPriceItem(ItemType)
Defines and lists a new fixed-price listing. The main difference between AddFixedPriceItem and AddItem is that AddFixedPriceItem supports the creation of fixed-price listings only, whereas AddItem supports all listing formats. Also, only AddFixedPriceItem supports multi-variation listings and tracking inventory by SKU. AddItem does not support Variations or the InventoryTrackingMethod field.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection AddFixedPriceItem(
    ItemType Item
)
Public Function AddFixedPriceItem ( _
    Item As ItemType _
) As FeeTypeCollection
public:
FeeTypeCollection^ AddFixedPriceItem(
    ItemType^ Item
)
Parameters
Item (ItemType)
This container is used to specify all of the values and settings that define a new fixed-price listing.


AddFixedPriceItemCall Constructor

AddFixedPriceItemCall Constructor
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► AddFixedPriceItemCall()()()()
Members
Icon | Member | Description
 | AddFixedPriceItemCall()()()() |
 | AddFixedPriceItemCall(ApiContext) |


AddFixedPriceItemCall Constructor

AddFixedPriceItemCall Constructor
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► AddFixedPriceItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddFixedPriceItemCall()
Public Sub New
public:
AddFixedPriceItemCall()


AddFixedPriceItemCall Constructor (ApiContext)

AddFixedPriceItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► AddFixedPriceItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddFixedPriceItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddFixedPriceItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► ApiRequest
Gets or sets the AddFixedPriceItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddFixedPriceItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddFixedPriceItemRequestType
    Get
    Set
public:
property AddFixedPriceItemRequestType^ ApiRequest {
    AddFixedPriceItemRequestType^ get ();
    void set (AddFixedPriceItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► ApiResponse
Gets the AddFixedPriceItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddFixedPriceItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddFixedPriceItemResponseType
    Get
public:
property AddFixedPriceItemResponseType^ ApiResponse {
    AddFixedPriceItemResponseType^ get ();
}


AutoSetItemUUID Property

AutoSetItemUUID Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► AutoSetItemUUID
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoSetItemUUID { get; set; }
Public Property AutoSetItemUUID As Boolean
    Get
    Set
public:
property bool AutoSetItemUUID {
    bool get ();
    void set (bool value);
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► Category2ID
Gets the returned Category2ID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; }
Public ReadOnly Property Category2ID As String
    Get
public:
property String^ Category2ID {
    String^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► CategoryID
Gets the returned CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; }
Public ReadOnly Property CategoryID As String
    Get
public:
property String^ CategoryID {
    String^ get ();
}


DiscountReasonList Property

DiscountReasonList Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► DiscountReasonList
Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReasonList { get; }
Public ReadOnly Property DiscountReasonList As DiscountReasonCodeTypeCollection
    Get
public:
property DiscountReasonCodeTypeCollection^ DiscountReasonList {
    DiscountReasonCodeTypeCollection^ get ();
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


Execute Method

Execute Method
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► Execute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Execute()
Public Overrides Sub Execute
public:
virtual void Execute() override


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► ItemID
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; }
Public ReadOnly Property ItemID As String
    Get
public:
property String^ ItemID {
    String^ get ();
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► ListingRecommendations
Gets the returned ListingRecommendations of type ListingRecommendationsType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; }
Public ReadOnly Property ListingRecommendations As ListingRecommendationsType
    Get
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
}


NewUUID Method

NewUUID Method
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► NewUUID()()()()
Generates a universal unique identifier.
Declaration Syntax
C# Visual Basic Visual C++
public static string NewUUID()
Public Shared Function NewUUID As String
public:
static String^ NewUUID()
Return Value
A universal unique identifier of type String


PictureFileList Property

PictureFileList Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► PictureFileList
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureFileList { get; set; }
Public Property PictureFileList As StringCollection
    Get
    Set
public:
property StringCollection^ PictureFileList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► ProductSuggestions
Gets the returned ProductSuggestions of type ProductSuggestionsType.
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; }
Public ReadOnly Property ProductSuggestions As ProductSuggestionsType
    Get
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
}


ResetItemUUID Method (Item)

ResetItemUUID Method (Item)
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► ResetItemUUID(ItemType)
Sets or overwrites the UUID.
Declaration Syntax
C# Visual Basic Visual C++
public static void ResetItemUUID(
    ItemType Item
)
Public Shared Sub ResetItemUUID ( _
    Item As ItemType _
)
public:
static void ResetItemUUID(
    ItemType^ Item
)
Parameters
Item (ItemType)
The item to assign a universal unique identifier to.


SKU Property

SKU Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► SKU
Gets the returned SKU of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; }
Public ReadOnly Property SKU As String
    Get
public:
property String^ SKU {
    String^ get ();
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► AddFixedPriceItemCall ► StartTime
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}


AddItemCall Class

AddItemCall Class
Namespaces ► eBay.Service.Call ► AddItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemCall()()()() |
 | AddItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddItem(ItemType) | Base request type for the AddItem call, which is used to create a single fixed-price, auction, classified ad, or Half.com listing.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddItemRequestType for this API call.
 | ApiResponse | Gets the AddItemResponseType for this API call.
 | AutoSetItemUUID |
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Category2ID | Gets the returned Category2ID of type String.
 | CategoryID | Gets the returned CategoryID of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DiscountReasonList | Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | (Overrides ApiCall.Execute()()()().)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | ItemID | Gets the returned ItemID of type String.
 | ListingRecommendations | Gets the returned ListingRecommendations of type ListingRecommendationsType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewUUID()()()() | Generates a universal unique identifier.
 | OutputSelector | (Inherited from ApiCall.)
 | PictureFileList |
 | ProductSuggestions | Gets the returned ProductSuggestions of type ProductSuggestionsType.
 | ResetItemUUID(ItemType) | Sets or overwrites the UUID.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddItemCall


AddItem Method (Item)

AddItem Method (Item)
Namespaces ► eBay.Service.Call ► AddItemCall ► AddItem(ItemType)
Base request type for the AddItem call, which is used to create a single fixed-price, auction, classified ad, or Half.com listing.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection AddItem(
    ItemType Item
)
Public Function AddItem ( _
    Item As ItemType _
) As FeeTypeCollection
public:
FeeTypeCollection^ AddItem(
    ItemType^ Item
)
Parameters
Item (ItemType)
This container is used to specify all of the values and settings that define a new listing.


AddItemCall Constructor

AddItemCall Constructor
Namespaces ► eBay.Service.Call ► AddItemCall ► AddItemCall()()()()
Members
Icon | Member | Description
 | AddItemCall()()()() |
 | AddItemCall(ApiContext) |


AddItemCall Constructor

AddItemCall Constructor
Namespaces ► eBay.Service.Call ► AddItemCall ► AddItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemCall()
Public Sub New
public:
AddItemCall()


AddItemCall Constructor (ApiContext)

AddItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddItemCall ► AddItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddItemCall ► ApiRequest
Gets or sets the AddItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddItemRequestType
    Get
    Set
public:
property AddItemRequestType^ ApiRequest {
    AddItemRequestType^ get ();
    void set (AddItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddItemCall ► ApiResponse
Gets the AddItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddItemResponseType
    Get
public:
property AddItemResponseType^ ApiResponse {
    AddItemResponseType^ get ();
}


AutoSetItemUUID Property

AutoSetItemUUID Property
Namespaces ► eBay.Service.Call ► AddItemCall ► AutoSetItemUUID
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoSetItemUUID { get; set; }
Public Property AutoSetItemUUID As Boolean
    Get
    Set
public:
property bool AutoSetItemUUID {
    bool get ();
    void set (bool value);
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Call ► AddItemCall ► Category2ID
Gets the returned Category2ID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; }
Public ReadOnly Property Category2ID As String
    Get
public:
property String^ Category2ID {
    String^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► AddItemCall ► CategoryID
Gets the returned CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; }
Public ReadOnly Property CategoryID As String
    Get
public:
property String^ CategoryID {
    String^ get ();
}


DiscountReasonList Property

DiscountReasonList Property
Namespaces ► eBay.Service.Call ► AddItemCall ► DiscountReasonList
Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReasonList { get; }
Public ReadOnly Property DiscountReasonList As DiscountReasonCodeTypeCollection
    Get
public:
property DiscountReasonCodeTypeCollection^ DiscountReasonList {
    DiscountReasonCodeTypeCollection^ get ();
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► AddItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


Execute Method

Execute Method
Namespaces ► eBay.Service.Call ► AddItemCall ► Execute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Execute()
Public Overrides Sub Execute
public:
virtual void Execute() override


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► AddItemCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► AddItemCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► AddItemCall ► ItemID
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; }
Public ReadOnly Property ItemID As String
    Get
public:
property String^ ItemID {
    String^ get ();
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Call ► AddItemCall ► ListingRecommendations
Gets the returned ListingRecommendations of type ListingRecommendationsType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; }
Public ReadOnly Property ListingRecommendations As ListingRecommendationsType
    Get
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
}


NewUUID Method

NewUUID Method
Namespaces ► eBay.Service.Call ► AddItemCall ► NewUUID()()()()
Generates a universal unique identifier.
Declaration Syntax
C# Visual Basic Visual C++
public static string NewUUID()
Public Shared Function NewUUID As String
public:
static String^ NewUUID()
Return Value
A universal unique identifier of type String


PictureFileList Property

PictureFileList Property
Namespaces ► eBay.Service.Call ► AddItemCall ► PictureFileList
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureFileList { get; set; }
Public Property PictureFileList As StringCollection
    Get
    Set
public:
property StringCollection^ PictureFileList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Call ► AddItemCall ► ProductSuggestions
Gets the returned ProductSuggestions of type ProductSuggestionsType.
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; }
Public ReadOnly Property ProductSuggestions As ProductSuggestionsType
    Get
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
}


ResetItemUUID Method (Item)

ResetItemUUID Method (Item)
Namespaces ► eBay.Service.Call ► AddItemCall ► ResetItemUUID(ItemType)
Sets or overwrites the UUID.
Declaration Syntax
C# Visual Basic Visual C++
public static void ResetItemUUID(
    ItemType Item
)
Public Shared Sub ResetItemUUID ( _
    Item As ItemType _
)
public:
static void ResetItemUUID(
    ItemType^ Item
)
Parameters
Item (ItemType)
The item to assign a universal unique identifier to.


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► AddItemCall ► StartTime
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}


AddItemFromSellingManagerTemplateCall Class

AddItemFromSellingManagerTemplateCall Class
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddItemFromSellingManagerTemplateCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddItemFromSellingManagerTemplateCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddItemFromSellingManagerTemplateCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemFromSellingManagerTemplateCall()()()() |
 | AddItemFromSellingManagerTemplateCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddItemFromSellingManagerTemplate(Int64, DateTime, ItemType) | This is the base request type of the AddItemFromSellingManagerTemplate call, which is used to create listings based on settings contained in a Selling Manager template.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddItemFromSellingManagerTemplateRequestType for this API call.
 | ApiResponse | Gets the AddItemFromSellingManagerTemplateResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Category2ID | Gets the returned Category2ID of type String.
 | CategoryID | Gets the returned CategoryID of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | ItemID | Gets the returned ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SaleTemplateID | Gets or sets the SaleTemplateID of type Int64.
 | ScheduleTime | Gets or sets the ScheduleTime of type DateTime.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddItemFromSellingManagerTemplateCall


AddItemFromSellingManagerTemplate Method (SaleTemplateID, ScheduleTime, Item)

AddItemFromSellingManagerTemplate Method (SaleTemplateID, ScheduleTime, Item)
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► AddItemFromSellingManagerTemplate(Int64, DateTime, ItemType)
This is the base request type of the AddItemFromSellingManagerTemplate call, which is used to create listings based on settings contained in a Selling Manager template.
Declaration Syntax
C# Visual Basic Visual C++
public string AddItemFromSellingManagerTemplate(
    long SaleTemplateID,
    DateTime ScheduleTime,
    ItemType Item
)
Public Function AddItemFromSellingManagerTemplate ( _
    SaleTemplateID As Long, _
    ScheduleTime As DateTime, _
    Item As ItemType _
) As String
public:
String^ AddItemFromSellingManagerTemplate(
    long long SaleTemplateID,
    DateTime ScheduleTime,
    ItemType^ Item
)
Parameters
SaleTemplateID (Int64)
The unique identifier of the Selling Manager template that a seller is using to create a listing. Unique identifiers of Selling Manager templates can be retrieved programatically by using the GetSellingManagerInventory call.
ScheduleTime (DateTime)
This field allows the user to specify a time in the future when the listing being created becomes active. If this field is not used, the listing will become active immediately upon being created successfully. The time in this field should be specified in GMT format.
Item (ItemType)
This container is intended for specifying setting in the listing that differ from values in the Selling Manager template being used. Note: Only the following three values of ItemType may be used for a AddItemFromSellingManagerTemplate call: CategoryMappingAllowed, PaymentMethods, and PayPalEmailAddress.


AddItemFromSellingManagerTemplateCall Constructor

AddItemFromSellingManagerTemplateCall Constructor
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► AddItemFromSellingManagerTemplateCall()()()()
Members
Icon | Member | Description
 | AddItemFromSellingManagerTemplateCall()()()() |
 | AddItemFromSellingManagerTemplateCall(ApiContext) |


AddItemFromSellingManagerTemplateCall Constructor

AddItemFromSellingManagerTemplateCall Constructor
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► AddItemFromSellingManagerTemplateCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemFromSellingManagerTemplateCall()
Public Sub New
public:
AddItemFromSellingManagerTemplateCall()


AddItemFromSellingManagerTemplateCall Constructor (ApiContext)

AddItemFromSellingManagerTemplateCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► AddItemFromSellingManagerTemplateCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddItemFromSellingManagerTemplateCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddItemFromSellingManagerTemplateCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► ApiRequest
Gets or sets the AddItemFromSellingManagerTemplateRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddItemFromSellingManagerTemplateRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddItemFromSellingManagerTemplateRequestType
    Get
    Set
public:
property AddItemFromSellingManagerTemplateRequestType^ ApiRequest {
    AddItemFromSellingManagerTemplateRequestType^ get ();
    void set (AddItemFromSellingManagerTemplateRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► ApiResponse
Gets the AddItemFromSellingManagerTemplateResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddItemFromSellingManagerTemplateResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddItemFromSellingManagerTemplateResponseType
    Get
public:
property AddItemFromSellingManagerTemplateResponseType^ ApiResponse {
    AddItemFromSellingManagerTemplateResponseType^ get ();
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► Category2ID
Gets the returned Category2ID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; }
Public ReadOnly Property Category2ID As String
    Get
public:
property String^ Category2ID {
    String^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► CategoryID
Gets the returned CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; }
Public ReadOnly Property CategoryID As String
    Get
public:
property String^ CategoryID {
    String^ get ();
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► ItemID
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; }
Public ReadOnly Property ItemID As String
    Get
public:
property String^ ItemID {
    String^ get ();
}


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► SaleTemplateID
Gets or sets the SaleTemplateID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


ScheduleTime Property

ScheduleTime Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► ScheduleTime
Gets or sets the ScheduleTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ScheduleTime { get; set; }
Public Property ScheduleTime As DateTime
    Get
    Set
public:
property DateTime ScheduleTime {
    DateTime get ();
    void set (DateTime value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► AddItemFromSellingManagerTemplateCall ► StartTime
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}


AddItemsCall Class

AddItemsCall Class
Namespaces ► eBay.Service.Call ► AddItemsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddItemsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddItemsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddItemsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemsCall()()()() |
 | AddItemsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddItemRequestContainerList | Gets or sets the AddItemRequestContainer of type AddItemRequestContainerTypeCollection.
 | AddItemResponseContainerList | Gets the returned AddItemResponseContainer of type AddItemResponseContainerTypeCollection.
 | AddItems(AddItemRequestContainerTypeCollection) | Defines from one to five items and lists them on a specified eBay site.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddItemsRequestType for this API call.
 | ApiResponse | Gets the AddItemsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddItemsCall


AddItemRequestContainerList Property

AddItemRequestContainerList Property
Namespaces ► eBay.Service.Call ► AddItemsCall ► AddItemRequestContainerList
Gets or sets the AddItemRequestContainer of type AddItemRequestContainerTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public AddItemRequestContainerTypeCollection AddItemRequestContainerList { get; set; }
Public Property AddItemRequestContainerList As AddItemRequestContainerTypeCollection
    Get
    Set
public:
property AddItemRequestContainerTypeCollection^ AddItemRequestContainerList {
    AddItemRequestContainerTypeCollection^ get ();
    void set (AddItemRequestContainerTypeCollection^ value);
}


AddItemResponseContainerList Property

AddItemResponseContainerList Property
Namespaces ► eBay.Service.Call ► AddItemsCall ► AddItemResponseContainerList
Gets the returned AddItemResponseContainer of type AddItemResponseContainerTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseContainerTypeCollection AddItemResponseContainerList { get; }
Public ReadOnly Property AddItemResponseContainerList As AddItemResponseContainerTypeCollection
    Get
public:
property AddItemResponseContainerTypeCollection^ AddItemResponseContainerList {
    AddItemResponseContainerTypeCollection^ get ();
}


AddItems Method (AddItemRequestContainerList)

AddItems Method (AddItemRequestContainerList)
Namespaces ► eBay.Service.Call ► AddItemsCall ► AddItems(AddItemRequestContainerTypeCollection)
Defines from one to five items and lists them on a specified eBay site.
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseContainerTypeCollection AddItems(
    AddItemRequestContainerTypeCollection AddItemRequestContainerList
)
Public Function AddItems ( _
    AddItemRequestContainerList As AddItemRequestContainerTypeCollection _
) As AddItemResponseContainerTypeCollection
public:
AddItemResponseContainerTypeCollection^ AddItems(
    AddItemRequestContainerTypeCollection^ AddItemRequestContainerList
)
Parameters
AddItemRequestContainerList (AddItemRequestContainerTypeCollection)
Defines a single item to be listed on eBay. This container is similar to an AddItem request. Up to five of these containers can be included in one AddItems request.


AddItemsCall Constructor

AddItemsCall Constructor
Namespaces ► eBay.Service.Call ► AddItemsCall ► AddItemsCall()()()()
Members
Icon | Member | Description
 | AddItemsCall()()()() |
 | AddItemsCall(ApiContext) |


AddItemsCall Constructor

AddItemsCall Constructor
Namespaces ► eBay.Service.Call ► AddItemsCall ► AddItemsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemsCall()
Public Sub New
public:
AddItemsCall()


AddItemsCall Constructor (ApiContext)

AddItemsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddItemsCall ► AddItemsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddItemsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddItemsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddItemsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddItemsCall ► ApiRequest
Gets or sets the AddItemsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddItemsRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddItemsRequestType
    Get
    Set
public:
property AddItemsRequestType^ ApiRequest {
    AddItemsRequestType^ get ();
    void set (AddItemsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddItemsCall ► ApiResponse
Gets the AddItemsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddItemsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddItemsResponseType
    Get
public:
property AddItemsResponseType^ ApiResponse {
    AddItemsResponseType^ get ();
}


AddMemberMessageAAQToPartnerCall Class

AddMemberMessageAAQToPartnerCall Class
Namespaces ► eBay.Service.Call ► AddMemberMessageAAQToPartnerCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddMemberMessageAAQToPartnerCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddMemberMessageAAQToPartnerCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddMemberMessageAAQToPartnerCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessageAAQToPartnerCall()()()() |
 | AddMemberMessageAAQToPartnerCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddMemberMessageAAQToPartner(String, MemberMessageType) | Enables a buyer and seller in an order relationship to send messages to each other's My Messages Inboxes.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddMemberMessageAAQToPartnerRequestType for this API call.
 | ApiResponse | Gets the AddMemberMessageAAQToPartnerResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberMessage | Gets or sets the MemberMessage of type MemberMessageType.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddMemberMessageAAQToPartnerCall


AddMemberMessageAAQToPartner Method (ItemID, MemberMessage)

AddMemberMessageAAQToPartner Method (ItemID, MemberMessage)
Namespaces ► eBay.Service.Call ► AddMemberMessageAAQToPartnerCall ► AddMemberMessageAAQToPartner(String, MemberMessageType)
Enables a buyer and seller in an order relationship to send messages to each other's My Messages Inboxes.
Declaration Syntax
C# Visual Basic Visual C++
public void AddMemberMessageAAQToPartner(
    string ItemID,
    MemberMessageType MemberMessage
)
Public Sub AddMemberMessageAAQToPartner ( _
    ItemID As String, _
    MemberMessage As MemberMessageType _
)
public:
void AddMemberMessageAAQToPartner(
    String^ ItemID,
    MemberMessageType^ MemberMessage
)
Parameters
ItemID (String)
Unique identifier for the listing that is being discussed between the two order partners.
MemberMessage (MemberMessageType)
This container holds the message, and includes the subject, message body, and other details related to the message.


AddMemberMessageAAQToPartnerCall Constructor

AddMemberMessageAAQToPartnerCall Constructor
Namespaces ► eBay.Service.Call ► AddMemberMessageAAQToPartnerCall ► AddMemberMessageAAQToPartnerCall()()()()
Members
Icon | Member | Description
 | AddMemberMessageAAQToPartnerCall()()()() |
 | AddMemberMessageAAQToPartnerCall(ApiContext) |


AddMemberMessageAAQToPartnerCall Constructor

AddMemberMessageAAQToPartnerCall Constructor
Namespaces ► eBay.Service.Call ► AddMemberMessageAAQToPartnerCall ► AddMemberMessageAAQToPartnerCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageAAQToPartnerCall()
Public Sub New
public:
AddMemberMessageAAQToPartnerCall()


AddMemberMessageAAQToPartnerCall Constructor (ApiContext)

AddMemberMessageAAQToPartnerCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddMemberMessageAAQToPartnerCall ► AddMemberMessageAAQToPartnerCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageAAQToPartnerCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddMemberMessageAAQToPartnerCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddMemberMessageAAQToPartnerCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddMemberMessageAAQToPartnerCall ► ApiRequest
Gets or sets the AddMemberMessageAAQToPartnerRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageAAQToPartnerRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddMemberMessageAAQToPartnerRequestType
    Get
    Set
public:
property AddMemberMessageAAQToPartnerRequestType^ ApiRequest {
    AddMemberMessageAAQToPartnerRequestType^ get ();
    void set (AddMemberMessageAAQToPartnerRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddMemberMessageAAQToPartnerCall ► ApiResponse
Gets the AddMemberMessageAAQToPartnerResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageAAQToPartnerResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddMemberMessageAAQToPartnerResponseType
    Get
public:
property AddMemberMessageAAQToPartnerResponseType^ ApiResponse {
    AddMemberMessageAAQToPartnerResponseType^ get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► AddMemberMessageAAQToPartnerCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MemberMessage Property

MemberMessage Property
Namespaces ► eBay.Service.Call ► AddMemberMessageAAQToPartnerCall ► MemberMessage
Gets or sets the MemberMessage of type MemberMessageType.
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageType MemberMessage { get; set; }
Public Property MemberMessage As MemberMessageType
    Get
    Set
public:
property MemberMessageType^ MemberMessage {
    MemberMessageType^ get ();
    void set (MemberMessageType^ value);
}


AddMemberMessageRTQCall Class

AddMemberMessageRTQCall Class
Namespaces ► eBay.Service.Call ► AddMemberMessageRTQCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddMemberMessageRTQCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddMemberMessageRTQCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddMemberMessageRTQCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessageRTQCall()()()() |
 | AddMemberMessageRTQCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddMemberMessageRTQ(String, MemberMessageType) | The base request of the AddMemberMessageRTQ call that enables a seller to reply to a question about an active item listing.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddMemberMessageRTQRequestType for this API call.
 | ApiResponse | Gets the AddMemberMessageRTQResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberMessage | Gets or sets the MemberMessage of type MemberMessageType.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddMemberMessageRTQCall


AddMemberMessageRTQ Method (ItemID, MemberMessage)

AddMemberMessageRTQ Method (ItemID, MemberMessage)
Namespaces ► eBay.Service.Call ► AddMemberMessageRTQCall ► AddMemberMessageRTQ(String, MemberMessageType)
The base request of the AddMemberMessageRTQ call that enables a seller to reply to a question about an active item listing.
Declaration Syntax
C# Visual Basic Visual C++
public void AddMemberMessageRTQ(
    string ItemID,
    MemberMessageType MemberMessage
)
Public Sub AddMemberMessageRTQ ( _
    ItemID As String, _
    MemberMessage As MemberMessageType _
)
public:
void AddMemberMessageRTQ(
    String^ ItemID,
    MemberMessageType^ MemberMessage
)
Parameters
ItemID (String)
The unique identifier of the listing about which the question was asked. This field is not required if the request includes a RecipientID value in the MemberMessage container, and the bidder/potential buyer and seller do not have more than one listing in common between one another.
MemberMessage (MemberMessageType)
This container is used by the seller to answer the question from the bidder/potential buyer. This container includes the recipient ID of the bidder/potential buyer, the message subject, the message body (where the question is answered), and other values related to the message.


AddMemberMessageRTQCall Constructor

AddMemberMessageRTQCall Constructor
Namespaces ► eBay.Service.Call ► AddMemberMessageRTQCall ► AddMemberMessageRTQCall()()()()
Members
Icon | Member | Description
 | AddMemberMessageRTQCall()()()() |
 | AddMemberMessageRTQCall(ApiContext) |


AddMemberMessageRTQCall Constructor

AddMemberMessageRTQCall Constructor
Namespaces ► eBay.Service.Call ► AddMemberMessageRTQCall ► AddMemberMessageRTQCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageRTQCall()
Public Sub New
public:
AddMemberMessageRTQCall()


AddMemberMessageRTQCall Constructor (ApiContext)

AddMemberMessageRTQCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddMemberMessageRTQCall ► AddMemberMessageRTQCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageRTQCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddMemberMessageRTQCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddMemberMessageRTQCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddMemberMessageRTQCall ► ApiRequest
Gets or sets the AddMemberMessageRTQRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageRTQRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddMemberMessageRTQRequestType
    Get
    Set
public:
property AddMemberMessageRTQRequestType^ ApiRequest {
    AddMemberMessageRTQRequestType^ get ();
    void set (AddMemberMessageRTQRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddMemberMessageRTQCall ► ApiResponse
Gets the AddMemberMessageRTQResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageRTQResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddMemberMessageRTQResponseType
    Get
public:
property AddMemberMessageRTQResponseType^ ApiResponse {
    AddMemberMessageRTQResponseType^ get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► AddMemberMessageRTQCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MemberMessage Property

MemberMessage Property
Namespaces ► eBay.Service.Call ► AddMemberMessageRTQCall ► MemberMessage
Gets or sets the MemberMessage of type MemberMessageType.
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageType MemberMessage { get; set; }
Public Property MemberMessage As MemberMessageType
    Get
    Set
public:
property MemberMessageType^ MemberMessage {
    MemberMessageType^ get ();
    void set (MemberMessageType^ value);
}


AddMemberMessagesAAQToBidderCall Class

AddMemberMessagesAAQToBidderCall Class
Namespaces ► eBay.Service.Call ► AddMemberMessagesAAQToBidderCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddMemberMessagesAAQToBidderCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddMemberMessagesAAQToBidderCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddMemberMessagesAAQToBidderCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessagesAAQToBidderCall()()()() |
 | AddMemberMessagesAAQToBidderCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddMemberMessagesAAQToBidder(AddMemberMessagesAAQToBidderRequestContainerTypeCollection) | The base request of the AddMemberMessagesAAQToBidder call, which allows a seller to send up to 10 messages to bidders/potential buyers regarding an active listing. These potential buyers may include those who have made a Best Offer on a listing.
 | AddMemberMessagesAAQToBidderRequestContainerList | Gets or sets the AddMemberMessagesAAQToBidderRequestContainer of type AddMemberMessagesAAQToBidderRequestContainerTypeCollection.
 | AddMemberMessagesAAQToBidderResponseContainerList | Gets the returned AddMemberMessagesAAQToBidderResponseContainer of type AddMemberMessagesAAQToBidderResponseContainerTypeCollection.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddMemberMessagesAAQToBidderRequestType for this API call.
 | ApiResponse | Gets the AddMemberMessagesAAQToBidderResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddMemberMessagesAAQToBidderCall


AddMemberMessagesAAQToBidder Method (AddMemberMessagesAAQToBidderRequestContainerList)

AddMemberMessagesAAQToBidder Method (AddMemberMessagesAAQToBidderRequestContainerList)
Namespaces ► eBay.Service.Call ► AddMemberMessagesAAQToBidderCall ► AddMemberMessagesAAQToBidder(AddMemberMessagesAAQToBidderRequestContainerTypeCollection)
The base request of the AddMemberMessagesAAQToBidder call, which allows a seller to send up to 10 messages to bidders/potential buyers regarding an active listing. These potential buyers may include those who have made a Best Offer on a listing.
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseContainerTypeCollection AddMemberMessagesAAQToBidder(
    AddMemberMessagesAAQToBidderRequestContainerTypeCollection AddMemberMessagesAAQToBidderRequestContainerList
)
Public Function AddMemberMessagesAAQToBidder ( _
    AddMemberMessagesAAQToBidderRequestContainerList As AddMemberMessagesAAQToBidderRequestContainerTypeCollection _
) As AddMemberMessagesAAQToBidderResponseContainerTypeCollection
public:
AddMemberMessagesAAQToBidderResponseContainerTypeCollection^ AddMemberMessagesAAQToBidder(
    AddMemberMessagesAAQToBidderRequestContainerTypeCollection^ AddMemberMessagesAAQToBidderRequestContainerList
)
Parameters
AddMemberMessagesAAQToBidderRequestContainerList (AddMemberMessagesAAQToBidderRequestContainerTypeCollection)
An AddMemberMessagesAAQToBidderRequestContainer container is required for each message being sent to unique bidders/potential buyers. A seller can send up to 10 messages to unique bidders/potential buyers in one AddMemberMessagesAAQToBidder call.


AddMemberMessagesAAQToBidderCall Constructor

AddMemberMessagesAAQToBidderCall Constructor
Namespaces ► eBay.Service.Call ► AddMemberMessagesAAQToBidderCall ► AddMemberMessagesAAQToBidderCall()()()()
Members
Icon | Member | Description
 | AddMemberMessagesAAQToBidderCall()()()() |
 | AddMemberMessagesAAQToBidderCall(ApiContext) |


AddMemberMessagesAAQToBidderCall Constructor

AddMemberMessagesAAQToBidderCall Constructor
Namespaces ► eBay.Service.Call ► AddMemberMessagesAAQToBidderCall ► AddMemberMessagesAAQToBidderCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderCall()
Public Sub New
public:
AddMemberMessagesAAQToBidderCall()


AddMemberMessagesAAQToBidderCall Constructor (ApiContext)

AddMemberMessagesAAQToBidderCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddMemberMessagesAAQToBidderCall ► AddMemberMessagesAAQToBidderCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddMemberMessagesAAQToBidderCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


AddMemberMessagesAAQToBidderRequestContainerList Property

AddMemberMessagesAAQToBidderRequestContainerList Property
Namespaces ► eBay.Service.Call ► AddMemberMessagesAAQToBidderCall ► AddMemberMessagesAAQToBidderRequestContainerList
Gets or sets the AddMemberMessagesAAQToBidderRequestContainer of type AddMemberMessagesAAQToBidderRequestContainerTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderRequestContainerTypeCollection AddMemberMessagesAAQToBidderRequestContainerList { get; set; }
Public Property AddMemberMessagesAAQToBidderRequestContainerList As AddMemberMessagesAAQToBidderRequestContainerTypeCollection
    Get
    Set
public:
property AddMemberMessagesAAQToBidderRequestContainerTypeCollection^ AddMemberMessagesAAQToBidderRequestContainerList {
    AddMemberMessagesAAQToBidderRequestContainerTypeCollection^ get ();
    void set (AddMemberMessagesAAQToBidderRequestContainerTypeCollection^ value);
}


AddMemberMessagesAAQToBidderResponseContainerList Property

AddMemberMessagesAAQToBidderResponseContainerList Property
Namespaces ► eBay.Service.Call ► AddMemberMessagesAAQToBidderCall ► AddMemberMessagesAAQToBidderResponseContainerList
Gets the returned AddMemberMessagesAAQToBidderResponseContainer of type AddMemberMessagesAAQToBidderResponseContainerTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseContainerTypeCollection AddMemberMessagesAAQToBidderResponseContainerList { get; }
Public ReadOnly Property AddMemberMessagesAAQToBidderResponseContainerList As AddMemberMessagesAAQToBidderResponseContainerTypeCollection
    Get
public:
property AddMemberMessagesAAQToBidderResponseContainerTypeCollection^ AddMemberMessagesAAQToBidderResponseContainerList {
    AddMemberMessagesAAQToBidderResponseContainerTypeCollection^ get ();
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddMemberMessagesAAQToBidderCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddMemberMessagesAAQToBidderCall ► ApiRequest
Gets or sets the AddMemberMessagesAAQToBidderRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddMemberMessagesAAQToBidderRequestType
    Get
    Set
public:
property AddMemberMessagesAAQToBidderRequestType^ ApiRequest {
    AddMemberMessagesAAQToBidderRequestType^ get ();
    void set (AddMemberMessagesAAQToBidderRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddMemberMessagesAAQToBidderCall ► ApiResponse
Gets the AddMemberMessagesAAQToBidderResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddMemberMessagesAAQToBidderResponseType
    Get
public:
property AddMemberMessagesAAQToBidderResponseType^ ApiResponse {
    AddMemberMessagesAAQToBidderResponseType^ get ();
}


AddOrderCall Class

AddOrderCall Class
Namespaces ► eBay.Service.Call ► AddOrderCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddOrderCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddOrderCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddOrderCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddOrderCall()()()() |
 | AddOrderCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddOrder(OrderType) | The AddOrder call can be used by a seller to combine two or more unpaid, single line item orders from the same buyer into one 'Combined Invoice' order with multiple line items. Once multiple line items are combined into one order, the buyer can make one single payment for each line item in the order. If possible and agreed to, the seller can then ship multiple line items in the same shipping package, saving on shipping costs, and possibly passing that savings down to the buyer through Combined Shipping Discount rules set up in My eBay.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddOrderRequestType for this API call.
 | ApiResponse | Gets the AddOrderResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CreatedTime | Gets the returned CreatedTime of type DateTime.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | (Overrides ApiCall.Execute()()()().)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Order | Gets or sets the Order of type OrderType.
 | OrderID | Gets the returned OrderID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddOrderCall


AddOrder Method (Order)

AddOrder Method (Order)
Namespaces ► eBay.Service.Call ► AddOrderCall ► AddOrder(OrderType)
The AddOrder call can be used by a seller to combine two or more unpaid, single line item orders from the same buyer into one 'Combined Invoice' order with multiple line items. Once multiple line items are combined into one order, the buyer can make one single payment for each line item in the order. If possible and agreed to, the seller can then ship multiple line items in the same shipping package, saving on shipping costs, and possibly passing that savings down to the buyer through Combined Shipping Discount rules set up in My eBay.
Declaration Syntax
C# Visual Basic Visual C++
public string AddOrder(
    OrderType Order
)
Public Function AddOrder ( _
    Order As OrderType _
) As String
public:
String^ AddOrder(
    OrderType^ Order
)
Parameters
Order (OrderType)
The root container of the AddOrder request. In this call, the seller identifies two or more unpaid order line items from the same buyer through the TransactionArray container, specifies one or more accepted payment methods through the PaymentMethods field(s), and specifies available shipping services and other shipping details through the ShippingDetails container.


AddOrderCall Constructor

AddOrderCall Constructor
Namespaces ► eBay.Service.Call ► AddOrderCall ► AddOrderCall()()()()
Members
Icon | Member | Description
 | AddOrderCall()()()() |
 | AddOrderCall(ApiContext) |


AddOrderCall Constructor

AddOrderCall Constructor
Namespaces ► eBay.Service.Call ► AddOrderCall ► AddOrderCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddOrderCall()
Public Sub New
public:
AddOrderCall()


AddOrderCall Constructor (ApiContext)

AddOrderCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddOrderCall ► AddOrderCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddOrderCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddOrderCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddOrderCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddOrderCall ► ApiRequest
Gets or sets the AddOrderRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddOrderRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddOrderRequestType
    Get
    Set
public:
property AddOrderRequestType^ ApiRequest {
    AddOrderRequestType^ get ();
    void set (AddOrderRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddOrderCall ► ApiResponse
Gets the AddOrderResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddOrderResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddOrderResponseType
    Get
public:
property AddOrderResponseType^ ApiResponse {
    AddOrderResponseType^ get ();
}


CreatedTime Property

CreatedTime Property
Namespaces ► eBay.Service.Call ► AddOrderCall ► CreatedTime
Gets the returned CreatedTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreatedTime { get; }
Public ReadOnly Property CreatedTime As DateTime
    Get
public:
property DateTime CreatedTime {
    DateTime get ();
}


Execute Method

Execute Method
Namespaces ► eBay.Service.Call ► AddOrderCall ► Execute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Execute()
Public Overrides Sub Execute
public:
virtual void Execute() override


Order Property

Order Property
Namespaces ► eBay.Service.Call ► AddOrderCall ► Order
Gets or sets the Order of type OrderType.
Declaration Syntax
C# Visual Basic Visual C++
public OrderType Order { get; set; }
Public Property Order As OrderType
    Get
    Set
public:
property OrderType^ Order {
    OrderType^ get ();
    void set (OrderType^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Call ► AddOrderCall ► OrderID
Gets the returned OrderID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; }
Public ReadOnly Property OrderID As String
    Get
public:
property String^ OrderID {
    String^ get ();
}


AddSecondChanceItemCall Class

AddSecondChanceItemCall Class
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddSecondChanceItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddSecondChanceItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddSecondChanceItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSecondChanceItemCall()()()() |
 | AddSecondChanceItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddSecondChanceItem(String, AmountType, SecondChanceOfferDurationCodeType, String, String) | Used by the seller of an auction listing to provide a Second Chance Offer to one of that auction item's non-winning bidders. A Second Chance Offer is used by sellers whenever the seller was unable to complete the sale with the winning bidder (bidder didn't pay), or if the auction listing ended without the Reserve Price being met, or if that seller has multiple identical items for sale and wants to give other bidders a chance to purchase the item.
 | AddSecondChanceItem(String, String, String) | For backward compatibility with old wrappers.
 | AddSecondChanceItem(ItemType, String) | For backward compatibility with old wrappers.
 | AddSecondChanceItem(String, AmountType, Boolean, SecondChanceOfferDurationCodeType, String) | For backward compatibility with old wrappers.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddSecondChanceItemRequestType for this API call.
 | ApiResponse | Gets the AddSecondChanceItemResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BuyItNowPrice | Gets or sets the BuyItNowPrice of type AmountType.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | Duration | Gets or sets the Duration of type SecondChanceOfferDurationCodeType.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | (Overrides ApiCall.Execute()()()().)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item |
 | ItemID | Gets or sets the ItemID of type String.
 | ItemIDResult | Gets the returned ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | RecipientBidderUserID | Gets or sets the RecipientBidderUserID of type String.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellerMessage | Gets or sets the SellerMessage of type String.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddSecondChanceItemCall


AddSecondChanceItem Method

AddSecondChanceItem Method
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► AddSecondChanceItem()()()()
Members
Icon | Member | Description
 | AddSecondChanceItem(String, AmountType, SecondChanceOfferDurationCodeType, String, String) | Used by the seller of an auction listing to provide a Second Chance Offer to one of that auction item's non-winning bidders. A Second Chance Offer is used by sellers whenever the seller was unable to complete the sale with the winning bidder (bidder didn't pay), or if the auction listing ended without the Reserve Price being met, or if that seller has multiple identical items for sale and wants to give other bidders a chance to purchase the item.
 | AddSecondChanceItem(String, String, String) | For backward compatibility with old wrappers.
 | AddSecondChanceItem(ItemType, String) | For backward compatibility with old wrappers.
 | AddSecondChanceItem(String, AmountType, Boolean, SecondChanceOfferDurationCodeType, String) | For backward compatibility with old wrappers.


AddSecondChanceItem Method (ItemID, ListingDuration, RecipientBidderUserID)

AddSecondChanceItem Method (ItemID, ListingDuration, RecipientBidderUserID)
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► AddSecondChanceItem(String, String, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void AddSecondChanceItem(
    string ItemID,
    string ListingDuration,
    string RecipientBidderUserID
)
Public Sub AddSecondChanceItem ( _
    ItemID As String, _
    ListingDuration As String, _
    RecipientBidderUserID As String _
)
public:
void AddSecondChanceItem(
    String^ ItemID,
    String^ ListingDuration,
    String^ RecipientBidderUserID
)
Parameters
ItemID (String)
ListingDuration (String)
RecipientBidderUserID (String)


AddSecondChanceItem Method (Item, RecipientBidderUserID)

AddSecondChanceItem Method (Item, RecipientBidderUserID)
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► AddSecondChanceItem(ItemType, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void AddSecondChanceItem(
    ItemType Item,
    string RecipientBidderUserID
)
Public Sub AddSecondChanceItem ( _
    Item As ItemType, _
    RecipientBidderUserID As String _
)
public:
void AddSecondChanceItem(
    ItemType^ Item,
    String^ RecipientBidderUserID
)
Parameters
Item (ItemType)
RecipientBidderUserID (String)


AddSecondChanceItem Method (RecipientBidderUserID, BuyItNowPrice, CopyEmailToSeller, Duration, ItemID)

AddSecondChanceItem Method (RecipientBidderUserID, BuyItNowPrice, CopyEmailToSeller, Duration, ItemID)
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► AddSecondChanceItem(String, AmountType, Boolean, SecondChanceOfferDurationCodeType, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void AddSecondChanceItem(
    string RecipientBidderUserID,
    AmountType BuyItNowPrice,
    bool CopyEmailToSeller,
    SecondChanceOfferDurationCodeType Duration,
    string ItemID
)
Public Sub AddSecondChanceItem ( _
    RecipientBidderUserID As String, _
    BuyItNowPrice As AmountType, _
    CopyEmailToSeller As Boolean, _
    Duration As SecondChanceOfferDurationCodeType, _
    ItemID As String _
)
public:
void AddSecondChanceItem(
    String^ RecipientBidderUserID,
    AmountType^ BuyItNowPrice,
    bool CopyEmailToSeller,
    SecondChanceOfferDurationCodeType Duration,
    String^ ItemID
)
Parameters
RecipientBidderUserID (String)
BuyItNowPrice (AmountType)
CopyEmailToSeller (Boolean)
Duration (SecondChanceOfferDurationCodeType)
ItemID (String)


AddSecondChanceItem Method (RecipientBidderUserID, BuyItNowPrice, Duration, ItemID, SellerMessage)

AddSecondChanceItem Method (RecipientBidderUserID, BuyItNowPrice, Duration, ItemID, SellerMessage)
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► AddSecondChanceItem(String, AmountType, SecondChanceOfferDurationCodeType, String, String)
Used by the seller of an auction listing to provide a Second Chance Offer to one of that auction item's non-winning bidders. A Second Chance Offer is used by sellers whenever the seller was unable to complete the sale with the winning bidder (bidder didn't pay), or if the auction listing ended without the Reserve Price being met, or if that seller has multiple identical items for sale and wants to give other bidders a chance to purchase the item.
Declaration Syntax
C# Visual Basic Visual C++
public string AddSecondChanceItem(
    string RecipientBidderUserID,
    AmountType BuyItNowPrice,
    SecondChanceOfferDurationCodeType Duration,
    string ItemID,
    string SellerMessage
)
Public Function AddSecondChanceItem ( _
    RecipientBidderUserID As String, _
    BuyItNowPrice As AmountType, _
    Duration As SecondChanceOfferDurationCodeType, _
    ItemID As String, _
    SellerMessage As String _
) As String
public:
String^ AddSecondChanceItem(
    String^ RecipientBidderUserID,
    AmountType^ BuyItNowPrice,
    SecondChanceOfferDurationCodeType Duration,
    String^ ItemID,
    String^ SellerMessage
)
Parameters
RecipientBidderUserID (String)
This field is used to specify the bidder that is being offered the Second Chance Offer. The eBay User ID of the bidder is used in this field. Specify only one RecipientBidderUserID per call. If multiple users are specified, only the last one specified receives the offer.
BuyItNowPrice (AmountType)
The amount the offer recipient must pay to purchase the item as a Second Chance Offer. This field should only be used when the original item was listed in an eBay Motors vehicle category (or in some categories on U.S. and international sites for high-priced items, such as items in many U.S. and Canada Business and Industrial categories) and it ended unsold because the reserve price was not met. Otherwise, eBay establishes the price and no price should be submitted. The price offered to the Second Chance Offer recipient is generally the highest bid that the user made on the original listing.
Duration (SecondChanceOfferDurationCodeType)
This enumerated value indicates the length of time (in days) that the Second Chance Offer will be available to the recipient. Upon receiving the Second Chance Offer, the recipient bidder will have this many days to accept the offer before the offer expires. One of the values in SecondChanceOfferDurationCodeType must be used.
ItemID (String)
This field is used to identify the original auction listing through its unique identifier (Item ID). Upon a successful call, the Second Chance Offer will be identified by a new ItemID in the response.
SellerMessage (String)
This optional field is used to provide a message to the recipient of the Second Chance Offer. This message cannot contain HTML, asterisks, or quotes. The content in this field will be included in the Second Chance Offer email that is sent to the recipient.


AddSecondChanceItemCall Constructor

AddSecondChanceItemCall Constructor
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► AddSecondChanceItemCall()()()()
Members
Icon | Member | Description
 | AddSecondChanceItemCall()()()() |
 | AddSecondChanceItemCall(ApiContext) |


AddSecondChanceItemCall Constructor

AddSecondChanceItemCall Constructor
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► AddSecondChanceItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSecondChanceItemCall()
Public Sub New
public:
AddSecondChanceItemCall()


AddSecondChanceItemCall Constructor (ApiContext)

AddSecondChanceItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► AddSecondChanceItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddSecondChanceItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddSecondChanceItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► ApiRequest
Gets or sets the AddSecondChanceItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddSecondChanceItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddSecondChanceItemRequestType
    Get
    Set
public:
property AddSecondChanceItemRequestType^ ApiRequest {
    AddSecondChanceItemRequestType^ get ();
    void set (AddSecondChanceItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► ApiResponse
Gets the AddSecondChanceItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddSecondChanceItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddSecondChanceItemResponseType
    Get
public:
property AddSecondChanceItemResponseType^ ApiResponse {
    AddSecondChanceItemResponseType^ get ();
}


BuyItNowPrice Property

BuyItNowPrice Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► BuyItNowPrice
Gets or sets the BuyItNowPrice of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType BuyItNowPrice { get; set; }
Public Property BuyItNowPrice As AmountType
    Get
    Set
public:
property AmountType^ BuyItNowPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


Duration Property

Duration Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► Duration
Gets or sets the Duration of type SecondChanceOfferDurationCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public SecondChanceOfferDurationCodeType Duration { get; set; }
Public Property Duration As SecondChanceOfferDurationCodeType
    Get
    Set
public:
property SecondChanceOfferDurationCodeType Duration {
    SecondChanceOfferDurationCodeType get ();
    void set (SecondChanceOfferDurationCodeType value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


Execute Method

Execute Method
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► Execute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Execute()
Public Overrides Sub Execute
public:
virtual void Execute() override


Item Property

Item Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ItemIDResult Property

ItemIDResult Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► ItemIDResult
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemIDResult { get; }
Public ReadOnly Property ItemIDResult As String
    Get
public:
property String^ ItemIDResult {
    String^ get ();
}


RecipientBidderUserID Property

RecipientBidderUserID Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► RecipientBidderUserID
Gets or sets the RecipientBidderUserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientBidderUserID { get; set; }
Public Property RecipientBidderUserID As String
    Get
    Set
public:
property String^ RecipientBidderUserID {
    String^ get ();
    void set (String^ value);
}


SellerMessage Property

SellerMessage Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► SellerMessage
Gets or sets the SellerMessage of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SellerMessage { get; set; }
Public Property SellerMessage As String
    Get
    Set
public:
property String^ SellerMessage {
    String^ get ();
    void set (String^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► AddSecondChanceItemCall ► StartTime
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}


AddSellingManagerInventoryFolderCall Class

AddSellingManagerInventoryFolderCall Class
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddSellingManagerInventoryFolderCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddSellingManagerInventoryFolderCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddSellingManagerInventoryFolderCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSellingManagerInventoryFolderCall()()()() |
 | AddSellingManagerInventoryFolderCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddSellingManagerInventoryFolder(String, Int64, String) | Adds a new product folder to a user's Selling Manager account.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddSellingManagerInventoryFolderRequestType for this API call.
 | ApiResponse | Gets the AddSellingManagerInventoryFolderResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Comment | Gets or sets the Comment of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID | Gets the returned FolderID of type Int64.
 | FolderName | Gets or sets the FolderName of type String.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ParentFolderID | Gets or sets the ParentFolderID of type Int64.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddSellingManagerInventoryFolderCall


AddSellingManagerInventoryFolder Method (FolderName, ParentFolderID, Comment)

AddSellingManagerInventoryFolder Method (FolderName, ParentFolderID, Comment)
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall ► AddSellingManagerInventoryFolder(String, Int64, String)
Adds a new product folder to a user's Selling Manager account.
Declaration Syntax
C# Visual Basic Visual C++
public long AddSellingManagerInventoryFolder(
    string FolderName,
    long ParentFolderID,
    string Comment
)
Public Function AddSellingManagerInventoryFolder ( _
    FolderName As String, _
    ParentFolderID As Long, _
    Comment As String _
) As Long
public:
long long AddSellingManagerInventoryFolder(
    String^ FolderName,
    long long ParentFolderID,
    String^ Comment
)
Parameters
FolderName (String)
Name of the new Selling Manager inventory folder.
ParentFolderID (Int64)
Unique Folder ID of parent folder. If no ParentFolderID is submitted, Folder is added to root level.
Comment (String)
Contains comments that will be associated with this folder.


AddSellingManagerInventoryFolderCall Constructor

AddSellingManagerInventoryFolderCall Constructor
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall ► AddSellingManagerInventoryFolderCall()()()()
Members
Icon | Member | Description
 | AddSellingManagerInventoryFolderCall()()()() |
 | AddSellingManagerInventoryFolderCall(ApiContext) |


AddSellingManagerInventoryFolderCall Constructor

AddSellingManagerInventoryFolderCall Constructor
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall ► AddSellingManagerInventoryFolderCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerInventoryFolderCall()
Public Sub New
public:
AddSellingManagerInventoryFolderCall()


AddSellingManagerInventoryFolderCall Constructor (ApiContext)

AddSellingManagerInventoryFolderCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall ► AddSellingManagerInventoryFolderCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerInventoryFolderCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddSellingManagerInventoryFolderCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall ► ApiRequest
Gets or sets the AddSellingManagerInventoryFolderRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerInventoryFolderRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddSellingManagerInventoryFolderRequestType
    Get
    Set
public:
property AddSellingManagerInventoryFolderRequestType^ ApiRequest {
    AddSellingManagerInventoryFolderRequestType^ get ();
    void set (AddSellingManagerInventoryFolderRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall ► ApiResponse
Gets the AddSellingManagerInventoryFolderResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerInventoryFolderResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddSellingManagerInventoryFolderResponseType
    Get
public:
property AddSellingManagerInventoryFolderResponseType^ ApiResponse {
    AddSellingManagerInventoryFolderResponseType^ get ();
}


Comment Property

Comment Property
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall ► Comment
Gets or sets the Comment of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall ► FolderID
Gets the returned FolderID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; }
Public ReadOnly Property FolderID As Long
    Get
public:
property long long FolderID {
    long long get ();
}


FolderName Property

FolderName Property
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall ► FolderName
Gets or sets the FolderName of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string FolderName { get; set; }
Public Property FolderName As String
    Get
    Set
public:
property String^ FolderName {
    String^ get ();
    void set (String^ value);
}


ParentFolderID Property

ParentFolderID Property
Namespaces ► eBay.Service.Call ► AddSellingManagerInventoryFolderCall ► ParentFolderID
Gets or sets the ParentFolderID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long ParentFolderID { get; set; }
Public Property ParentFolderID As Long
    Get
    Set
public:
property long long ParentFolderID {
    long long get ();
    void set (long long value);
}


AddSellingManagerProductCall Class

AddSellingManagerProductCall Class
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddSellingManagerProductCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddSellingManagerProductCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddSellingManagerProductCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSellingManagerProductCall()()()() |
 | AddSellingManagerProductCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddSellingManagerProduct(SellingManagerProductDetailsType, Int64, SellingManagerProductSpecificsType) | The base request type of the AddSellingManagerProduct call, which is used to create a product or a group of product variations within the Selling Manager Pro system. Once a Selling Manager Pro product or production variation group is created, the product settings and product specifics can be transferred over into a Selling Manager Pro listing template with the AddSellingManagerTemplate call.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddSellingManagerProductRequestType for this API call.
 | ApiResponse | Gets the AddSellingManagerProductResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID | Gets or sets the FolderID of type Int64.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellingManagerProductDetails | Gets or sets the SellingManagerProductDetails of type SellingManagerProductDetailsType.
 | SellingManagerProductDetailsReturn | Gets the returned SellingManagerProductDetails of type SellingManagerProductDetailsType.
 | SellingManagerProductSpecifics | Gets or sets the SellingManagerProductSpecifics of type SellingManagerProductSpecificsType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddSellingManagerProductCall


AddSellingManagerProduct Method (SellingManagerProductDetails, FolderID, SellingManagerProductSpecifics)

AddSellingManagerProduct Method (SellingManagerProductDetails, FolderID, SellingManagerProductSpecifics)
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall ► AddSellingManagerProduct(SellingManagerProductDetailsType, Int64, SellingManagerProductSpecificsType)
The base request type of the AddSellingManagerProduct call, which is used to create a product or a group of product variations within the Selling Manager Pro system. Once a Selling Manager Pro product or production variation group is created, the product settings and product specifics can be transferred over into a Selling Manager Pro listing template with the AddSellingManagerTemplate call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType AddSellingManagerProduct(
    SellingManagerProductDetailsType SellingManagerProductDetails,
    long FolderID,
    SellingManagerProductSpecificsType SellingManagerProductSpecifics
)
Public Function AddSellingManagerProduct ( _
    SellingManagerProductDetails As SellingManagerProductDetailsType, _
    FolderID As Long, _
    SellingManagerProductSpecifics As SellingManagerProductSpecificsType _
) As SellingManagerProductDetailsType
public:
SellingManagerProductDetailsType^ AddSellingManagerProduct(
    SellingManagerProductDetailsType^ SellingManagerProductDetails,
    long long FolderID,
    SellingManagerProductSpecificsType^ SellingManagerProductSpecifics
)
Parameters
SellingManagerProductDetails (SellingManagerProductDetailsType)
This container is used to provide details about the Selling Manager product, such as product name, quantity available, and unit price.
FolderID (Int64)
This is the unique identifier of the folder in which the new product will be placed. This folder can be a new folder or a folder that already exists for the seller in Selling Manager Pro. If no folder is specified through this field, the new product is place into the My Products folder by default.
SellingManagerProductSpecifics (SellingManagerProductSpecificsType)
This container allows the seller to specify item specifics for a product, to create a product variation group and variation specifics, and/or to specify a listing category for the product or product variation group. A product variation group can be transferred into a listing template that can create a multiple-variation listing. The listing category can either be provided through the PrimaryCategoryID value of this call, or through the Item.PrimaryCategory.CategoryID field of the subsequent AddSellingManagerTemplate call.


AddSellingManagerProductCall Constructor

AddSellingManagerProductCall Constructor
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall ► AddSellingManagerProductCall()()()()
Members
Icon | Member | Description
 | AddSellingManagerProductCall()()()() |
 | AddSellingManagerProductCall(ApiContext) |


AddSellingManagerProductCall Constructor

AddSellingManagerProductCall Constructor
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall ► AddSellingManagerProductCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerProductCall()
Public Sub New
public:
AddSellingManagerProductCall()


AddSellingManagerProductCall Constructor (ApiContext)

AddSellingManagerProductCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall ► AddSellingManagerProductCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerProductCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddSellingManagerProductCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall ► ApiRequest
Gets or sets the AddSellingManagerProductRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerProductRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddSellingManagerProductRequestType
    Get
    Set
public:
property AddSellingManagerProductRequestType^ ApiRequest {
    AddSellingManagerProductRequestType^ get ();
    void set (AddSellingManagerProductRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall ► ApiResponse
Gets the AddSellingManagerProductResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerProductResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddSellingManagerProductResponseType
    Get
public:
property AddSellingManagerProductResponseType^ ApiResponse {
    AddSellingManagerProductResponseType^ get ();
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall ► FolderID
Gets or sets the FolderID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall ► SellingManagerProductDetails
Gets or sets the SellingManagerProductDetails of type SellingManagerProductDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; set; }
Public Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


SellingManagerProductDetailsReturn Property

SellingManagerProductDetailsReturn Property
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall ► SellingManagerProductDetailsReturn
Gets the returned SellingManagerProductDetails of type SellingManagerProductDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetailsReturn { get; }
Public ReadOnly Property SellingManagerProductDetailsReturn As SellingManagerProductDetailsType
    Get
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetailsReturn {
    SellingManagerProductDetailsType^ get ();
}


SellingManagerProductSpecifics Property

SellingManagerProductSpecifics Property
Namespaces ► eBay.Service.Call ► AddSellingManagerProductCall ► SellingManagerProductSpecifics
Gets or sets the SellingManagerProductSpecifics of type SellingManagerProductSpecificsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductSpecificsType SellingManagerProductSpecifics { get; set; }
Public Property SellingManagerProductSpecifics As SellingManagerProductSpecificsType
    Get
    Set
public:
property SellingManagerProductSpecificsType^ SellingManagerProductSpecifics {
    SellingManagerProductSpecificsType^ get ();
    void set (SellingManagerProductSpecificsType^ value);
}


AddSellingManagerTemplateCall Class

AddSellingManagerTemplateCall Class
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddSellingManagerTemplateCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddSellingManagerTemplateCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddSellingManagerTemplateCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSellingManagerTemplateCall()()()() |
 | AddSellingManagerTemplateCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddSellingManagerTemplate(ItemType, String, Int64) | The base request for the AddSellingManagerTemplate call, which is used to create a Selling Manager listing template. Each Selling Manager listing template must be associated with an existing Selling Manager product, and each product can have up to 20 listing templates associated with it.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddSellingManagerTemplateRequestType for this API call.
 | ApiResponse | Gets the AddSellingManagerTemplateResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Category2ID | Gets the returned Category2ID of type Int64.
 | CategoryID | Gets the returned CategoryID of type Int64.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ProductID | Gets or sets the ProductID of type Int64.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SaleTemplateGroupID | Gets the returned SaleTemplateGroupID of type Int64.
 | SaleTemplateID | Gets the returned SaleTemplateID of type Int64.
 | SaleTemplateName | Gets or sets the SaleTemplateName of type String.
 | SaleTemplateNameReturn | Gets the returned SaleTemplateName of type String.
 | SellingManagerProductDetails | Gets the returned SellingManagerProductDetails of type SellingManagerProductDetailsType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddSellingManagerTemplateCall


AddSellingManagerTemplate Method (Item, SaleTemplateName, ProductID)

AddSellingManagerTemplate Method (Item, SaleTemplateName, ProductID)
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► AddSellingManagerTemplate(ItemType, String, Int64)
The base request for the AddSellingManagerTemplate call, which is used to create a Selling Manager listing template. Each Selling Manager listing template must be associated with an existing Selling Manager product, and each product can have up to 20 listing templates associated with it.
Declaration Syntax
C# Visual Basic Visual C++
public long AddSellingManagerTemplate(
    ItemType Item,
    string SaleTemplateName,
    long ProductID
)
Public Function AddSellingManagerTemplate ( _
    Item As ItemType, _
    SaleTemplateName As String, _
    ProductID As Long _
) As Long
public:
long long AddSellingManagerTemplate(
    ItemType^ Item,
    String^ SaleTemplateName,
    long long ProductID
)
Parameters
Item (ItemType)
This Item container is similar to the one that is used in standard Add/Revise/Relist/Verify Item calls, with the difference being that some of the product-specific data/settings will be inherited through the Selling Manager product that is referenced in the call request, and not through this Item container. The data that is passed in this container will become part of the listing template that is created with this call.
SaleTemplateName (String)
The name of the Selling Manager listing template is provided in this field. If you don't specify a name, then the value in the Item.Title field will be used as the name instead.
ProductID (Int64)
The unique identifier of the Selling Manager product that will be associated with the listing template being created. Selling Manager Product IDs are returned in the response of a AddSellingManagerProduct call. Alternatively, the GetSellingManagerInventory call can be used to retrieve active Selling Manager products for the user's account.


AddSellingManagerTemplateCall Constructor

AddSellingManagerTemplateCall Constructor
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► AddSellingManagerTemplateCall()()()()
Members
Icon | Member | Description
 | AddSellingManagerTemplateCall()()()() |
 | AddSellingManagerTemplateCall(ApiContext) |


AddSellingManagerTemplateCall Constructor

AddSellingManagerTemplateCall Constructor
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► AddSellingManagerTemplateCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerTemplateCall()
Public Sub New
public:
AddSellingManagerTemplateCall()


AddSellingManagerTemplateCall Constructor (ApiContext)

AddSellingManagerTemplateCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► AddSellingManagerTemplateCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerTemplateCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddSellingManagerTemplateCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► ApiRequest
Gets or sets the AddSellingManagerTemplateRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerTemplateRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddSellingManagerTemplateRequestType
    Get
    Set
public:
property AddSellingManagerTemplateRequestType^ ApiRequest {
    AddSellingManagerTemplateRequestType^ get ();
    void set (AddSellingManagerTemplateRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► ApiResponse
Gets the AddSellingManagerTemplateResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerTemplateResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddSellingManagerTemplateResponseType
    Get
public:
property AddSellingManagerTemplateResponseType^ ApiResponse {
    AddSellingManagerTemplateResponseType^ get ();
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► Category2ID
Gets the returned Category2ID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long Category2ID { get; }
Public ReadOnly Property Category2ID As Long
    Get
public:
property long long Category2ID {
    long long get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► CategoryID
Gets the returned CategoryID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long CategoryID { get; }
Public ReadOnly Property CategoryID As Long
    Get
public:
property long long CategoryID {
    long long get ();
}


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ProductID Property

ProductID Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► ProductID
Gets or sets the ProductID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long ProductID { get; set; }
Public Property ProductID As Long
    Get
    Set
public:
property long long ProductID {
    long long get ();
    void set (long long value);
}


SaleTemplateGroupID Property

SaleTemplateGroupID Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► SaleTemplateGroupID
Gets the returned SaleTemplateGroupID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateGroupID { get; }
Public ReadOnly Property SaleTemplateGroupID As Long
    Get
public:
property long long SaleTemplateGroupID {
    long long get ();
}


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► SaleTemplateID
Gets the returned SaleTemplateID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; }
Public ReadOnly Property SaleTemplateID As Long
    Get
public:
property long long SaleTemplateID {
    long long get ();
}


SaleTemplateName Property

SaleTemplateName Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► SaleTemplateName
Gets or sets the SaleTemplateName of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SaleTemplateName { get; set; }
Public Property SaleTemplateName As String
    Get
    Set
public:
property String^ SaleTemplateName {
    String^ get ();
    void set (String^ value);
}


SaleTemplateNameReturn Property

SaleTemplateNameReturn Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► SaleTemplateNameReturn
Gets the returned SaleTemplateName of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SaleTemplateNameReturn { get; }
Public ReadOnly Property SaleTemplateNameReturn As String
    Get
public:
property String^ SaleTemplateNameReturn {
    String^ get ();
}


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Call ► AddSellingManagerTemplateCall ► SellingManagerProductDetails
Gets the returned SellingManagerProductDetails of type SellingManagerProductDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; }
Public ReadOnly Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
}


AddToItemDescriptionCall Class

AddToItemDescriptionCall Class
Namespaces ► eBay.Service.Call ► AddToItemDescriptionCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddToItemDescriptionCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddToItemDescriptionCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddToItemDescriptionCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddToItemDescriptionCall()()()() |
 | AddToItemDescriptionCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddToItemDescription(String, String) | The base request of the AddToItemDescription call, which is used to add additional text to an active listing's item description. Upon a successful call, the text supplied in this call will be inserted into the active listing, with a horizontal rule separating the original item description and the additional text that was added with this call.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddToItemDescriptionRequestType for this API call.
 | ApiResponse | Gets the AddToItemDescriptionResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DescriptionToAppend | Gets or sets the Description of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddToItemDescriptionCall


AddToItemDescription Method (ItemID, DescriptionToAppend)

AddToItemDescription Method (ItemID, DescriptionToAppend)
Namespaces ► eBay.Service.Call ► AddToItemDescriptionCall ► AddToItemDescription(String, String)
The base request of the AddToItemDescription call, which is used to add additional text to an active listing's item description. Upon a successful call, the text supplied in this call will be inserted into the active listing, with a horizontal rule separating the original item description and the additional text that was added with this call.
Declaration Syntax
C# Visual Basic Visual C++
public void AddToItemDescription(
    string ItemID,
    string DescriptionToAppend
)
Public Sub AddToItemDescription ( _
    ItemID As String, _
    DescriptionToAppend As String _
)
public:
void AddToItemDescription(
    String^ ItemID,
    String^ DescriptionToAppend
)
Parameters
ItemID (String)
This field is used to identify the active listing that will be updated with additional text in the item description field. The Item ID is a unique identifier for a listing.
DescriptionToAppend (String)
This field is used to specify the text that will be appended to the end of the active listing's item description. The text provided in this field must abide by the same rules/restrictions applicable to the original item description supplied at listing time. For more information on these rules and restrictions, see the Description field of ItemType.


AddToItemDescriptionCall Constructor

AddToItemDescriptionCall Constructor
Namespaces ► eBay.Service.Call ► AddToItemDescriptionCall ► AddToItemDescriptionCall()()()()
Members
Icon | Member | Description
 | AddToItemDescriptionCall()()()() |
 | AddToItemDescriptionCall(ApiContext) |


AddToItemDescriptionCall Constructor

AddToItemDescriptionCall Constructor
Namespaces ► eBay.Service.Call ► AddToItemDescriptionCall ► AddToItemDescriptionCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddToItemDescriptionCall()
Public Sub New
public:
AddToItemDescriptionCall()


AddToItemDescriptionCall Constructor (ApiContext)

AddToItemDescriptionCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddToItemDescriptionCall ► AddToItemDescriptionCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddToItemDescriptionCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddToItemDescriptionCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddToItemDescriptionCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddToItemDescriptionCall ► ApiRequest
Gets or sets the AddToItemDescriptionRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddToItemDescriptionRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddToItemDescriptionRequestType
    Get
    Set
public:
property AddToItemDescriptionRequestType^ ApiRequest {
    AddToItemDescriptionRequestType^ get ();
    void set (AddToItemDescriptionRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddToItemDescriptionCall ► ApiResponse
Gets the AddToItemDescriptionResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddToItemDescriptionResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddToItemDescriptionResponseType
    Get
public:
property AddToItemDescriptionResponseType^ ApiResponse {
    AddToItemDescriptionResponseType^ get ();
}


DescriptionToAppend Property

DescriptionToAppend Property
Namespaces ► eBay.Service.Call ► AddToItemDescriptionCall ► DescriptionToAppend
Gets or sets the Description of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string DescriptionToAppend { get; set; }
Public Property DescriptionToAppend As String
    Get
    Set
public:
property String^ DescriptionToAppend {
    String^ get ();
    void set (String^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► AddToItemDescriptionCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


AddToWatchListCall Class

AddToWatchListCall Class
Namespaces ► eBay.Service.Call ► AddToWatchListCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddToWatchListCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddToWatchListCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddToWatchListCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddToWatchListCall()()()() |
 | AddToWatchListCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddToWatchList(StringCollection, VariationKeyTypeCollection) | Adds one or more order line items to the eBay user's Watch List. An auction item or a single-variation, fixed-price listing is identified with an ItemID value. To add a specific item variation to the Watch List from within a multi-variation, fixed-price listing, the user will use the VariationKey container instead.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddToWatchListRequestType for this API call.
 | ApiResponse | Gets the AddToWatchListResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemIDList | Gets or sets the ItemID of type StringCollection.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | VariationKeyList | Gets or sets the VariationKey of type VariationKeyTypeCollection.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
 | WatchListCount | Gets the returned WatchListCount of type Int32.
 | WatchListMaximum | Gets the returned WatchListMaximum of type Int32.
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddToWatchListCall


AddToWatchList Method (ItemIDList, VariationKeyList)

AddToWatchList Method (ItemIDList, VariationKeyList)
Namespaces ► eBay.Service.Call ► AddToWatchListCall ► AddToWatchList(StringCollection, VariationKeyTypeCollection)
Adds one or more order line items to the eBay user's Watch List. An auction item or a single-variation, fixed-price listing is identified with an ItemID value. To add a specific item variation to the Watch List from within a multi-variation, fixed-price listing, the user will use the VariationKey container instead.
Declaration Syntax
C# Visual Basic Visual C++
public int AddToWatchList(
    StringCollection ItemIDList,
    VariationKeyTypeCollection VariationKeyList
)
Public Function AddToWatchList ( _
    ItemIDList As StringCollection, _
    VariationKeyList As VariationKeyTypeCollection _
) As Integer
public:
int AddToWatchList(
    StringCollection^ ItemIDList,
    VariationKeyTypeCollection^ VariationKeyList
)
Parameters
ItemIDList (StringCollection)
The ItemID of the item that is to be added to the eBay user's Watch List. The item must be a currently active item, and the total number of items in the user's Watch List (after the items in the request have been added) cannot exceed the maximum allowed number of Watch List items. One or more ItemID fields can be specified. A separate error node will be returned for each item that was not successfully added to the Watch List. The user must use either one or more ItemID values or one or more VariationKey containers, but the user may not use both of these entities in the same call.
VariationKeyList (VariationKeyTypeCollection)
This container is used to specify one or more item variations in a multi-variation, fixed-price listing that you want to add to the Watch List. The listing is identified through the ItemID value and each item variation existing within that listing is identified through a VariationSpecifics.NameValueList container. The user must use either one or more ItemID values or one or more VariationKey containers, but the user may not use both of these entities in the same call.


AddToWatchListCall Constructor

AddToWatchListCall Constructor
Namespaces ► eBay.Service.Call ► AddToWatchListCall ► AddToWatchListCall()()()()
Members
Icon | Member | Description
 | AddToWatchListCall()()()() |
 | AddToWatchListCall(ApiContext) |


AddToWatchListCall Constructor

AddToWatchListCall Constructor
Namespaces ► eBay.Service.Call ► AddToWatchListCall ► AddToWatchListCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddToWatchListCall()
Public Sub New
public:
AddToWatchListCall()


AddToWatchListCall Constructor (ApiContext)

AddToWatchListCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddToWatchListCall ► AddToWatchListCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddToWatchListCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddToWatchListCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddToWatchListCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddToWatchListCall ► ApiRequest
Gets or sets the AddToWatchListRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddToWatchListRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddToWatchListRequestType
    Get
    Set
public:
property AddToWatchListRequestType^ ApiRequest {
    AddToWatchListRequestType^ get ();
    void set (AddToWatchListRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddToWatchListCall ► ApiResponse
Gets the AddToWatchListResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddToWatchListResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddToWatchListResponseType
    Get
public:
property AddToWatchListResponseType^ ApiResponse {
    AddToWatchListResponseType^ get ();
}


ItemIDList Property

ItemIDList Property
Namespaces ► eBay.Service.Call ► AddToWatchListCall ► ItemIDList
Gets or sets the ItemID of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ItemIDList { get; set; }
Public Property ItemIDList As StringCollection
    Get
    Set
public:
property StringCollection^ ItemIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


VariationKeyList Property

VariationKeyList Property
Namespaces ► eBay.Service.Call ► AddToWatchListCall ► VariationKeyList
Gets or sets the VariationKey of type VariationKeyTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public VariationKeyTypeCollection VariationKeyList { get; set; }
Public Property VariationKeyList As VariationKeyTypeCollection
    Get
    Set
public:
property VariationKeyTypeCollection^ VariationKeyList {
    VariationKeyTypeCollection^ get ();
    void set (VariationKeyTypeCollection^ value);
}


WatchListCount Property

WatchListCount Property
Namespaces ► eBay.Service.Call ► AddToWatchListCall ► WatchListCount
Gets the returned WatchListCount of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int WatchListCount { get; }
Public ReadOnly Property WatchListCount As Integer
    Get
public:
property int WatchListCount {
    int get ();
}


WatchListMaximum Property

WatchListMaximum Property
Namespaces ► eBay.Service.Call ► AddToWatchListCall ► WatchListMaximum
Gets the returned WatchListMaximum of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int WatchListMaximum { get; }
Public ReadOnly Property WatchListMaximum As Integer
    Get
public:
property int WatchListMaximum {
    int get ();
}


AddTransactionConfirmationItemCall Class

AddTransactionConfirmationItemCall Class
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class AddTransactionConfirmationItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class AddTransactionConfirmationItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class AddTransactionConfirmationItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddTransactionConfirmationItemCall()()()() |
 | AddTransactionConfirmationItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AddTransactionConfirmationItem(String, String, String, RecipientRelationCodeType, AmountType, SecondChanceOfferDurationCodeType, String, String) | Base request of the AddTransactionConfirmationItem call, which is used to end an eBay Motors listing and creates a new Transaction Confirmation Request (TCR) for the motor vehichle, thus enabling the TCR recipient to purchase the item. You can also use this call to see if a new TCR can be created for the specified item.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the AddTransactionConfirmationItemRequestType for this API call.
 | ApiResponse | Gets the AddTransactionConfirmationItemResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Comments | Gets or sets the Comments of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | ItemIDResult | Gets the returned ItemID of type String.
 | ListingDuration | Gets or sets the ListingDuration of type SecondChanceOfferDurationCodeType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NegotiatedPrice | Gets or sets the NegotiatedPrice of type AmountType.
 | OutputSelector | (Inherited from ApiCall.)
 | RecipientPostalCode | Gets or sets the RecipientPostalCode of type String.
 | RecipientRelationType | Gets or sets the RecipientRelationType of type RecipientRelationCodeType.
 | RecipientUserID | Gets or sets the RecipientUserID of type String.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | VerifyEligibilityOnly | Gets or sets the VerifyEligibilityOnly of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddTransactionConfirmationItemCall


AddTransactionConfirmationItem Method (RecipientUserID, VerifyEligibilityOnly, RecipientPostalCode, RecipientRelationType, NegotiatedPrice, ListingDuration, ItemID, Comments)

AddTransactionConfirmationItem Method (RecipientUserID, VerifyEligibilityOnly, RecipientPostalCode, RecipientRelationType, NegotiatedPrice, ListingDuration, ItemID, Comments)
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► AddTransactionConfirmationItem(String, String, String, RecipientRelationCodeType, AmountType, SecondChanceOfferDurationCodeType, String, String)
Base request of the AddTransactionConfirmationItem call, which is used to end an eBay Motors listing and creates a new Transaction Confirmation Request (TCR) for the motor vehichle, thus enabling the TCR recipient to purchase the item. You can also use this call to see if a new TCR can be created for the specified item.
Declaration Syntax
C# Visual Basic Visual C++
public string AddTransactionConfirmationItem(
    string RecipientUserID,
    string VerifyEligibilityOnly,
    string RecipientPostalCode,
    RecipientRelationCodeType RecipientRelationType,
    AmountType NegotiatedPrice,
    SecondChanceOfferDurationCodeType ListingDuration,
    string ItemID,
    string Comments
)
Public Function AddTransactionConfirmationItem ( _
    RecipientUserID As String, _
    VerifyEligibilityOnly As String, _
    RecipientPostalCode As String, _
    RecipientRelationType As RecipientRelationCodeType, _
    NegotiatedPrice As AmountType, _
    ListingDuration As SecondChanceOfferDurationCodeType, _
    ItemID As String, _
    Comments As String _
) As String
public:
String^ AddTransactionConfirmationItem(
    String^ RecipientUserID,
    String^ VerifyEligibilityOnly,
    String^ RecipientPostalCode,
    RecipientRelationCodeType RecipientRelationType,
    AmountType^ NegotiatedPrice,
    SecondChanceOfferDurationCodeType ListingDuration,
    String^ ItemID,
    String^ Comments
)
Parameters
RecipientUserID (String)
This field is used to specify the recipient of the Transaction Confirmation Request (TCR).
VerifyEligibilityOnly (String)
This field is included and set to
true
if the seller wants to verify whether or not a new Transaction Confirmation Request (TCR) can be created for the item. If this field is included and its value set to
true
, no TCR is actually created. If this field is included and its value set to
false
, or if it is omitted, a Transaction Confirmation Request is actually created.
RecipientPostalCode (String)
This field is used to specify the postal code of the user to whom the seller is offering the Transaction Confirmation Request. This field is only required if the user does not meet the other options listed in RecipientRelationCodeType.
RecipientRelationType (RecipientRelationCodeType)
The enumeration value supplied in this field specifies the current relationship between the seller and the potential buyer. A Transaction Confirmation Request (TCR) for an item can be sent to a potential buyer who has at least one of the following criteria: is an active bidder on the auction listing; has made a Best Offer on the fixed-price listing, is an eBay user who has used the Ask Seller a Question feature, or is an eBay user whose postal code is known.
NegotiatedPrice (AmountType)
The amount in this field is the price that the seller is asking for to purchase the motor vehicle.
ListingDuration (SecondChanceOfferDurationCodeType)
The enumeration value specified in this field will control how many days that the recipient of the offer has to purchase the motor vehicle at the price listed in the NegotiatedPrice field.
ItemID (String)
This field is used to identify the eBay Motors listing using the unique identifier of the listing (ItemID).
Comments (String)
This is optional free-form string field that can be used by the seller to provide any comments or additional information about the Transaction Confirmation Item.


AddTransactionConfirmationItemCall Constructor

AddTransactionConfirmationItemCall Constructor
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► AddTransactionConfirmationItemCall()()()()
Members
Icon | Member | Description
 | AddTransactionConfirmationItemCall()()()() |
 | AddTransactionConfirmationItemCall(ApiContext) |


AddTransactionConfirmationItemCall Constructor

AddTransactionConfirmationItemCall Constructor
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► AddTransactionConfirmationItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddTransactionConfirmationItemCall()
Public Sub New
public:
AddTransactionConfirmationItemCall()


AddTransactionConfirmationItemCall Constructor (ApiContext)

AddTransactionConfirmationItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► AddTransactionConfirmationItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public AddTransactionConfirmationItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
AddTransactionConfirmationItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► ApiRequest
Gets or sets the AddTransactionConfirmationItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddTransactionConfirmationItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As AddTransactionConfirmationItemRequestType
    Get
    Set
public:
property AddTransactionConfirmationItemRequestType^ ApiRequest {
    AddTransactionConfirmationItemRequestType^ get ();
    void set (AddTransactionConfirmationItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► ApiResponse
Gets the AddTransactionConfirmationItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public AddTransactionConfirmationItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As AddTransactionConfirmationItemResponseType
    Get
public:
property AddTransactionConfirmationItemResponseType^ ApiResponse {
    AddTransactionConfirmationItemResponseType^ get ();
}


Comments Property

Comments Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► Comments
Gets or sets the Comments of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Comments { get; set; }
Public Property Comments As String
    Get
    Set
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ItemIDResult Property

ItemIDResult Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► ItemIDResult
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemIDResult { get; }
Public ReadOnly Property ItemIDResult As String
    Get
public:
property String^ ItemIDResult {
    String^ get ();
}


ListingDuration Property

ListingDuration Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► ListingDuration
Gets or sets the ListingDuration of type SecondChanceOfferDurationCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public SecondChanceOfferDurationCodeType ListingDuration { get; set; }
Public Property ListingDuration As SecondChanceOfferDurationCodeType
    Get
    Set
public:
property SecondChanceOfferDurationCodeType ListingDuration {
    SecondChanceOfferDurationCodeType get ();
    void set (SecondChanceOfferDurationCodeType value);
}


NegotiatedPrice Property

NegotiatedPrice Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► NegotiatedPrice
Gets or sets the NegotiatedPrice of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType NegotiatedPrice { get; set; }
Public Property NegotiatedPrice As AmountType
    Get
    Set
public:
property AmountType^ NegotiatedPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


RecipientPostalCode Property

RecipientPostalCode Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► RecipientPostalCode
Gets or sets the RecipientPostalCode of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientPostalCode { get; set; }
Public Property RecipientPostalCode As String
    Get
    Set
public:
property String^ RecipientPostalCode {
    String^ get ();
    void set (String^ value);
}


RecipientRelationType Property

RecipientRelationType Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► RecipientRelationType
Gets or sets the RecipientRelationType of type RecipientRelationCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public RecipientRelationCodeType RecipientRelationType { get; set; }
Public Property RecipientRelationType As RecipientRelationCodeType
    Get
    Set
public:
property RecipientRelationCodeType RecipientRelationType {
    RecipientRelationCodeType get ();
    void set (RecipientRelationCodeType value);
}


RecipientUserID Property

RecipientUserID Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► RecipientUserID
Gets or sets the RecipientUserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientUserID { get; set; }
Public Property RecipientUserID As String
    Get
    Set
public:
property String^ RecipientUserID {
    String^ get ();
    void set (String^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► StartTime
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}


VerifyEligibilityOnly Property

VerifyEligibilityOnly Property
Namespaces ► eBay.Service.Call ► AddTransactionConfirmationItemCall ► VerifyEligibilityOnly
Gets or sets the VerifyEligibilityOnly of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string VerifyEligibilityOnly { get; set; }
Public Property VerifyEligibilityOnly As String
    Get
    Set
public:
property String^ VerifyEligibilityOnly {
    String^ get ();
    void set (String^ value);
}


CompleteSaleCall Class

CompleteSaleCall Class
Namespaces ► eBay.Service.Call ► CompleteSaleCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class CompleteSaleCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class CompleteSaleCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class CompleteSaleCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompleteSaleCall()()()() |
 | CompleteSaleCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the CompleteSaleRequestType for this API call.
 | ApiResponse | Gets the CompleteSaleResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CompleteSale(String, String, FeedbackInfoType, Boolean, Boolean, ListingTypeCodeType, ShipmentType, String, String) | Enables a seller to do various tasks after the creation of a single line item or multiple line item order. Typically, this call is used after the buyer has paid for the order, but it can be called by the seller beforehand. Typical post-payment tasks available to this call include marking the order as paid, marking the order as shipped, providing shipment tracking details, and leaving feedback for the buyer.
 | CompleteSale(String, String, Boolean, Boolean, FeedbackInfoType) | For backward compatibility with old wrappers.
 | CompleteSale(String, String, Boolean, Boolean) | For backward compatibility with old wrappers.
 | CompleteSale(String, String, FeedbackInfoType, Boolean, Boolean) | For backward compatibility with old wrappers.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeedbackInfo | Gets or sets the FeedbackInfo of type FeedbackInfoType.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | ListingType | Gets or sets the ListingType of type ListingTypeCodeType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderID | Gets or sets the OrderID of type String.
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | Paid | Gets or sets the Paid of type Boolean.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Shipment | Gets or sets the Shipment of type ShipmentType.
 | Shipped | Gets or sets the Shipped of type Boolean.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | CompleteSaleCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► ApiRequest
Gets or sets the CompleteSaleRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public CompleteSaleRequestType ApiRequest { get; set; }
Public Property ApiRequest As CompleteSaleRequestType
    Get
    Set
public:
property CompleteSaleRequestType^ ApiRequest {
    CompleteSaleRequestType^ get ();
    void set (CompleteSaleRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► ApiResponse
Gets the CompleteSaleResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public CompleteSaleResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As CompleteSaleResponseType
    Get
public:
property CompleteSaleResponseType^ ApiResponse {
    CompleteSaleResponseType^ get ();
}


CompleteSale Method

CompleteSale Method
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► CompleteSale()()()()
Members
Icon | Member | Description
 | CompleteSale(String, String, FeedbackInfoType, Boolean, Boolean, ListingTypeCodeType, ShipmentType, String, String) | Enables a seller to do various tasks after the creation of a single line item or multiple line item order. Typically, this call is used after the buyer has paid for the order, but it can be called by the seller beforehand. Typical post-payment tasks available to this call include marking the order as paid, marking the order as shipped, providing shipment tracking details, and leaving feedback for the buyer.
 | CompleteSale(String, String, Boolean, Boolean, FeedbackInfoType) | For backward compatibility with old wrappers.
 | CompleteSale(String, String, Boolean, Boolean) | For backward compatibility with old wrappers.
 | CompleteSale(String, String, FeedbackInfoType, Boolean, Boolean) | For backward compatibility with old wrappers.


CompleteSale Method (ItemID, TransactionID, FeedbackInfo, Shipped, Paid)

CompleteSale Method (ItemID, TransactionID, FeedbackInfo, Shipped, Paid)
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► CompleteSale(String, String, FeedbackInfoType, Boolean, Boolean)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void CompleteSale(
    string ItemID,
    string TransactionID,
    FeedbackInfoType FeedbackInfo,
    bool Shipped,
    bool Paid
)
Public Sub CompleteSale ( _
    ItemID As String, _
    TransactionID As String, _
    FeedbackInfo As FeedbackInfoType, _
    Shipped As Boolean, _
    Paid As Boolean _
)
public:
void CompleteSale(
    String^ ItemID,
    String^ TransactionID,
    FeedbackInfoType^ FeedbackInfo,
    bool Shipped,
    bool Paid
)
Parameters
ItemID (String)
TransactionID (String)
FeedbackInfo (FeedbackInfoType)
Shipped (Boolean)
Paid (Boolean)


CompleteSale Method (ItemID, TransactionID, FeedbackInfo, Shipped, Paid, ListingType, Shipment, OrderID, OrderLineItemID)

CompleteSale Method (ItemID, TransactionID, FeedbackInfo, Shipped, Paid, ListingType, Shipment, OrderID, OrderLineItemID)
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► CompleteSale(String, String, FeedbackInfoType, Boolean, Boolean, ListingTypeCodeType, ShipmentType, String, String)
Enables a seller to do various tasks after the creation of a single line item or multiple line item order. Typically, this call is used after the buyer has paid for the order, but it can be called by the seller beforehand. Typical post-payment tasks available to this call include marking the order as paid, marking the order as shipped, providing shipment tracking details, and leaving feedback for the buyer.
Declaration Syntax
C# Visual Basic Visual C++
public void CompleteSale(
    string ItemID,
    string TransactionID,
    FeedbackInfoType FeedbackInfo,
    bool Shipped,
    bool Paid,
    ListingTypeCodeType ListingType,
    ShipmentType Shipment,
    string OrderID,
    string OrderLineItemID
)
Public Sub CompleteSale ( _
    ItemID As String, _
    TransactionID As String, _
    FeedbackInfo As FeedbackInfoType, _
    Shipped As Boolean, _
    Paid As Boolean, _
    ListingType As ListingTypeCodeType, _
    Shipment As ShipmentType, _
    OrderID As String, _
    OrderLineItemID As String _
)
public:
void CompleteSale(
    String^ ItemID,
    String^ TransactionID,
    FeedbackInfoType^ FeedbackInfo,
    bool Shipped,
    bool Paid,
    ListingTypeCodeType ListingType,
    ShipmentType^ Shipment,
    String^ OrderID,
    String^ OrderLineItemID
)
Parameters
ItemID (String)
Unique identifier for an eBay item listing. An ItemID can be paired up with a corresponding TransactionID and used in the CompleteSale request to identify a single line item order. Unless an OrderLineItemID is used to identify a single line item order, or the OrderID is used to identify a single or multiple line item order, the ItemID/TransactionID pair must be specified. For a multiple line item order, OrderID must be used. If OrderID or OrderLineItemID are specified, the ItemID/TransactionID pair is ignored if present in the same request.
TransactionID (String)
Unique identifier for an eBay order line item (transaction). The TransactionID can be paired up with the corresponding ItemID and used in the CompleteSale request to identify a single line item order. Unless an OrderLineItemID is used to identify a single line item order, or the OrderID is used to identify a single or multiple line item order, the ItemID/TransactionID pair must be specified. For a multiple line item order, OrderID must be used. If OrderID or OrderLineItemID are specified, the ItemID/TransactionID pair is ignored if present in the same request.
FeedbackInfo (FeedbackInfoType)
This container is used by the seller to leave feedback for the buyer for the order line item identified in the call request. The seller must include and specify all fields of this type, including the buyer's eBay User ID, the Feedback rating (a seller can only leave a buyer a "Positive" rating), and a comment, which helps justify the Feedback rating. The eBay User ID must match the buyer who bought the order line item, or an error will occur. An error will also occur if Feedback has already been left for the buyer (either through API or the Web flow). To determine if Feedback has already been left for an order line item, you can call GetFeedback, passing in the OrderLineItemID value in the call request.
Shipped (Boolean)
The seller includes and sets this field to true if the order has been shipped. If the call is successful, the order line item(s) are marked as Shipped in My eBay. If the seller includes and sets this field to false, the order line item(s) are marked (or remain) as Not Shipped in My eBay. If this field is not included, the shipped status of the order line item(s) remain unchanged in My eBay. If shipment tracking information is provided for an order line item through the Shipment container in the same request, the order line item is marked as shipped automatically and the Shipped field is not required.
Paid (Boolean)
The seller includes and sets this field to true if the buyer has paid for the order. If the call is successful, the order line item(s) are marked as Paid in My eBay. If the seller includes and sets this field to false, the order line item(s) are marked (or remain) as Not Paid in My eBay. If this field is not included, the paid status of the order line item(s) remain unchanged in My eBay.
ListingType (ListingTypeCodeType)
This field is required if CompleteSale is being used for a Half.com order. The value should be set to Half, which is the only applicable ListingType value for this call.
Shipment (ShipmentType)
Container consisting of shipment tracking information, shipped time, and an optional text field to provide additional details to the buyer. Setting the tracking number and shipping carrier automatically marks the item as shipped and the Shipped field is not required. (If you supply ShipmentTrackingNumber you must also supply ShippingCarrierUsed, otherwise you will get an error. To modify the shipping tracking number and/or carrier, supply the new number in ShipmentTrackingNumber or supply the value for ShippingCarrierUsed or both. The old number and carrier are deleted and the new ones are added. To simply delete the current tracking details altogether, supply empty Shipment tags. Note: Top-Rated sellers must have a record of uploading shipment tracking information (through site or through API) for at least 90 percent of their order line items (purchased by U.S. buyers) to keep their status as Top-Rated sellers. For more information on the requirements to becoming a Top-Rated Seller, see the Becoming a Top-Rated Seller and qualifying for Top-Rated Plus customer support page.
OrderID (String)
A unique identifier that identifies a single line item or multiple line item order. For a single line item order, the OrderID value is identical to the OrderLineItemID value that is generated upon creation of the order line item. For multiple line item orders, the OrderID value is created by eBay when the buyer is purchasing multiple order line items from the same seller at the same time. For multiple line item orders not going through the eBay Cart flow, a Combined Invoice order can be created by the seller through the AddOrder call. The OrderID can be used in the CompleteSale request to identify a single or multiple line item order. OrderID overrides an OrderLineItemID or ItemID/TransactionID pair if these fields are also specified in the same request.
OrderLineItemID (String)
OrderLineItemID is a unique identifier for an eBay order line item and is based upon the concatenation of ItemID and TransactionID, with a hyphen in between these two IDs. For a single line item order, the OrderLineItemID value can be passed into the OrderID field in the CompleteSale request. Unless an ItemID/TransactionID pair is used to identify a single line item order, or the OrderID is used to identify a single or multiple line item order, the OrderLineItemID must be specified. For a multiple line item order, OrderID must be used. If OrderLineItemID is specified, the ItemID/TransactionID pair are ignored if present in the same request.


CompleteSale Method (ItemID, TransactionID, Paid, Shipped)

CompleteSale Method (ItemID, TransactionID, Paid, Shipped)
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► CompleteSale(String, String, Boolean, Boolean)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void CompleteSale(
    string ItemID,
    string TransactionID,
    bool Paid,
    bool Shipped
)
Public Sub CompleteSale ( _
    ItemID As String, _
    TransactionID As String, _
    Paid As Boolean, _
    Shipped As Boolean _
)
public:
void CompleteSale(
    String^ ItemID,
    String^ TransactionID,
    bool Paid,
    bool Shipped
)
Parameters
ItemID (String)
TransactionID (String)
Paid (Boolean)
Shipped (Boolean)


CompleteSale Method (ItemID, TransactionID, Paid, Shipped, FeedbackInfo)

CompleteSale Method (ItemID, TransactionID, Paid, Shipped, FeedbackInfo)
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► CompleteSale(String, String, Boolean, Boolean, FeedbackInfoType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void CompleteSale(
    string ItemID,
    string TransactionID,
    bool Paid,
    bool Shipped,
    FeedbackInfoType FeedbackInfo
)
Public Sub CompleteSale ( _
    ItemID As String, _
    TransactionID As String, _
    Paid As Boolean, _
    Shipped As Boolean, _
    FeedbackInfo As FeedbackInfoType _
)
public:
void CompleteSale(
    String^ ItemID,
    String^ TransactionID,
    bool Paid,
    bool Shipped,
    FeedbackInfoType^ FeedbackInfo
)
Parameters
ItemID (String)
TransactionID (String)
Paid (Boolean)
Shipped (Boolean)
FeedbackInfo (FeedbackInfoType)


CompleteSaleCall Constructor

CompleteSaleCall Constructor
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► CompleteSaleCall()()()()
Members
Icon | Member | Description
 | CompleteSaleCall()()()() |
 | CompleteSaleCall(ApiContext) |


CompleteSaleCall Constructor

CompleteSaleCall Constructor
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► CompleteSaleCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CompleteSaleCall()
Public Sub New
public:
CompleteSaleCall()


CompleteSaleCall Constructor (ApiContext)

CompleteSaleCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► CompleteSaleCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public CompleteSaleCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
CompleteSaleCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


FeedbackInfo Property

FeedbackInfo Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► FeedbackInfo
Gets or sets the FeedbackInfo of type FeedbackInfoType.
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackInfoType FeedbackInfo { get; set; }
Public Property FeedbackInfo As FeedbackInfoType
    Get
    Set
public:
property FeedbackInfoType^ FeedbackInfo {
    FeedbackInfoType^ get ();
    void set (FeedbackInfoType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingType Property

ListingType Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► ListingType
Gets or sets the ListingType of type ListingTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingTypeCodeType ListingType { get; set; }
Public Property ListingType As ListingTypeCodeType
    Get
    Set
public:
property ListingTypeCodeType ListingType {
    ListingTypeCodeType get ();
    void set (ListingTypeCodeType value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► OrderID
Gets or sets the OrderID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


Paid Property

Paid Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► Paid
Gets or sets the Paid of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool Paid { get; set; }
Public Property Paid As Boolean
    Get
    Set
public:
property bool Paid {
    bool get ();
    void set (bool value);
}


Shipment Property

Shipment Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► Shipment
Gets or sets the Shipment of type ShipmentType.
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentType Shipment { get; set; }
Public Property Shipment As ShipmentType
    Get
    Set
public:
property ShipmentType^ Shipment {
    ShipmentType^ get ();
    void set (ShipmentType^ value);
}


Shipped Property

Shipped Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► Shipped
Gets or sets the Shipped of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool Shipped { get; set; }
Public Property Shipped As Boolean
    Get
    Set
public:
property bool Shipped {
    bool get ();
    void set (bool value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► CompleteSaleCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


ConfirmIdentityCall Class

ConfirmIdentityCall Class
Namespaces ► eBay.Service.Call ► ConfirmIdentityCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ConfirmIdentityCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ConfirmIdentityCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ConfirmIdentityCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfirmIdentityCall()()()() |
 | ConfirmIdentityCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ConfirmIdentityRequestType for this API call.
 | ApiResponse | Gets the ConfirmIdentityResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | ConfirmIdentity(String) | Returns the ID of a user who has gone through an application's consent flow process for obtaining an authorization token.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SessionID | Gets or sets the SessionID of type String.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UserID | Gets the returned UserID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ConfirmIdentityCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ConfirmIdentityCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ConfirmIdentityCall ► ApiRequest
Gets or sets the ConfirmIdentityRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ConfirmIdentityRequestType ApiRequest { get; set; }
Public Property ApiRequest As ConfirmIdentityRequestType
    Get
    Set
public:
property ConfirmIdentityRequestType^ ApiRequest {
    ConfirmIdentityRequestType^ get ();
    void set (ConfirmIdentityRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ConfirmIdentityCall ► ApiResponse
Gets the ConfirmIdentityResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ConfirmIdentityResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ConfirmIdentityResponseType
    Get
public:
property ConfirmIdentityResponseType^ ApiResponse {
    ConfirmIdentityResponseType^ get ();
}


ConfirmIdentity Method (SessionID)

ConfirmIdentity Method (SessionID)
Namespaces ► eBay.Service.Call ► ConfirmIdentityCall ► ConfirmIdentity(String)
Returns the ID of a user who has gone through an application's consent flow process for obtaining an authorization token.
Declaration Syntax
C# Visual Basic Visual C++
public string ConfirmIdentity(
    string SessionID
)
Public Function ConfirmIdentity ( _
    SessionID As String _
) As String
public:
String^ ConfirmIdentity(
    String^ SessionID
)
Parameters
SessionID (String)
A string obtained by making a GetSessionID call, passed in redirect URL to the eBay signin page.


ConfirmIdentityCall Constructor

ConfirmIdentityCall Constructor
Namespaces ► eBay.Service.Call ► ConfirmIdentityCall ► ConfirmIdentityCall()()()()
Members
Icon | Member | Description
 | ConfirmIdentityCall()()()() |
 | ConfirmIdentityCall(ApiContext) |


ConfirmIdentityCall Constructor

ConfirmIdentityCall Constructor
Namespaces ► eBay.Service.Call ► ConfirmIdentityCall ► ConfirmIdentityCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ConfirmIdentityCall()
Public Sub New
public:
ConfirmIdentityCall()


ConfirmIdentityCall Constructor (ApiContext)

ConfirmIdentityCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ConfirmIdentityCall ► ConfirmIdentityCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ConfirmIdentityCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ConfirmIdentityCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SessionID Property

SessionID Property
Namespaces ► eBay.Service.Call ► ConfirmIdentityCall ► SessionID
Gets or sets the SessionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SessionID { get; set; }
Public Property SessionID As String
    Get
    Set
public:
property String^ SessionID {
    String^ get ();
    void set (String^ value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Call ► ConfirmIdentityCall ► UserID
Gets the returned UserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; }
Public ReadOnly Property UserID As String
    Get
public:
property String^ UserID {
    String^ get ();
}


DeleteMyMessagesCall Class

DeleteMyMessagesCall Class
Namespaces ► eBay.Service.Call ► DeleteMyMessagesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class DeleteMyMessagesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class DeleteMyMessagesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class DeleteMyMessagesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteMyMessagesCall()()()() |
 | DeleteMyMessagesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | AlertIDList | Gets or sets the AlertIDs of type StringCollection.
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the DeleteMyMessagesRequestType for this API call.
 | ApiResponse | Gets the DeleteMyMessagesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeleteMyMessages(StringCollection, StringCollection) | Removes selected messages for a given user.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageIDList | Gets or sets the MessageIDs of type StringCollection.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | DeleteMyMessagesCall


AlertIDList Property

AlertIDList Property
Namespaces ► eBay.Service.Call ► DeleteMyMessagesCall ► AlertIDList
Gets or sets the AlertIDs of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection AlertIDList { get; set; }
Public Property AlertIDList As StringCollection
    Get
    Set
public:
property StringCollection^ AlertIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► DeleteMyMessagesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► DeleteMyMessagesCall ► ApiRequest
Gets or sets the DeleteMyMessagesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteMyMessagesRequestType ApiRequest { get; set; }
Public Property ApiRequest As DeleteMyMessagesRequestType
    Get
    Set
public:
property DeleteMyMessagesRequestType^ ApiRequest {
    DeleteMyMessagesRequestType^ get ();
    void set (DeleteMyMessagesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► DeleteMyMessagesCall ► ApiResponse
Gets the DeleteMyMessagesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteMyMessagesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As DeleteMyMessagesResponseType
    Get
public:
property DeleteMyMessagesResponseType^ ApiResponse {
    DeleteMyMessagesResponseType^ get ();
}


DeleteMyMessages Method (AlertIDList, MessageIDList)

DeleteMyMessages Method (AlertIDList, MessageIDList)
Namespaces ► eBay.Service.Call ► DeleteMyMessagesCall ► DeleteMyMessages(StringCollection, StringCollection)
Removes selected messages for a given user.
Declaration Syntax
C# Visual Basic Visual C++
public void DeleteMyMessages(
    StringCollection AlertIDList,
    StringCollection MessageIDList
)
Public Sub DeleteMyMessages ( _
    AlertIDList As StringCollection, _
    MessageIDList As StringCollection _
)
public:
void DeleteMyMessages(
    StringCollection^ AlertIDList,
    StringCollection^ MessageIDList
)
Parameters
AlertIDList (StringCollection)
This field is deprecated.
MessageIDList (StringCollection)
Contains a list of up to 10 MessageID values.


DeleteMyMessagesCall Constructor

DeleteMyMessagesCall Constructor
Namespaces ► eBay.Service.Call ► DeleteMyMessagesCall ► DeleteMyMessagesCall()()()()
Members
Icon | Member | Description
 | DeleteMyMessagesCall()()()() |
 | DeleteMyMessagesCall(ApiContext) |


DeleteMyMessagesCall Constructor

DeleteMyMessagesCall Constructor
Namespaces ► eBay.Service.Call ► DeleteMyMessagesCall ► DeleteMyMessagesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteMyMessagesCall()
Public Sub New
public:
DeleteMyMessagesCall()


DeleteMyMessagesCall Constructor (ApiContext)

DeleteMyMessagesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► DeleteMyMessagesCall ► DeleteMyMessagesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteMyMessagesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
DeleteMyMessagesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


MessageIDList Property

MessageIDList Property
Namespaces ► eBay.Service.Call ► DeleteMyMessagesCall ► MessageIDList
Gets or sets the MessageIDs of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection MessageIDList { get; set; }
Public Property MessageIDList As StringCollection
    Get
    Set
public:
property StringCollection^ MessageIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


DeleteSellingManagerInventoryFolderCall Class

DeleteSellingManagerInventoryFolderCall Class
Namespaces ► eBay.Service.Call ► DeleteSellingManagerInventoryFolderCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class DeleteSellingManagerInventoryFolderCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class DeleteSellingManagerInventoryFolderCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class DeleteSellingManagerInventoryFolderCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerInventoryFolderCall()()()() |
 | DeleteSellingManagerInventoryFolderCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the DeleteSellingManagerInventoryFolderRequestType for this API call.
 | ApiResponse | Gets the DeleteSellingManagerInventoryFolderResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeleteSellingManagerInventoryFolder(Int64) | Removes an inventory folder when a user deletes it in My eBay. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID | Gets or sets the FolderID of type Int64.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | DeleteSellingManagerInventoryFolderCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerInventoryFolderCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerInventoryFolderCall ► ApiRequest
Gets or sets the DeleteSellingManagerInventoryFolderRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerInventoryFolderRequestType ApiRequest { get; set; }
Public Property ApiRequest As DeleteSellingManagerInventoryFolderRequestType
    Get
    Set
public:
property DeleteSellingManagerInventoryFolderRequestType^ ApiRequest {
    DeleteSellingManagerInventoryFolderRequestType^ get ();
    void set (DeleteSellingManagerInventoryFolderRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerInventoryFolderCall ► ApiResponse
Gets the DeleteSellingManagerInventoryFolderResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerInventoryFolderResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As DeleteSellingManagerInventoryFolderResponseType
    Get
public:
property DeleteSellingManagerInventoryFolderResponseType^ ApiResponse {
    DeleteSellingManagerInventoryFolderResponseType^ get ();
}


DeleteSellingManagerInventoryFolder Method (FolderID)

DeleteSellingManagerInventoryFolder Method (FolderID)
Namespaces ► eBay.Service.Call ► DeleteSellingManagerInventoryFolderCall ► DeleteSellingManagerInventoryFolder(Int64)
Removes an inventory folder when a user deletes it in My eBay. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public void DeleteSellingManagerInventoryFolder(
    long FolderID
)
Public Sub DeleteSellingManagerInventoryFolder ( _
    FolderID As Long _
)
public:
void DeleteSellingManagerInventoryFolder(
    long long FolderID
)
Parameters
FolderID (Int64)
Unique ID of the folder to be deleted.


DeleteSellingManagerInventoryFolderCall Constructor

DeleteSellingManagerInventoryFolderCall Constructor
Namespaces ► eBay.Service.Call ► DeleteSellingManagerInventoryFolderCall ► DeleteSellingManagerInventoryFolderCall()()()()
Members
Icon | Member | Description
 | DeleteSellingManagerInventoryFolderCall()()()() |
 | DeleteSellingManagerInventoryFolderCall(ApiContext) |


DeleteSellingManagerInventoryFolderCall Constructor

DeleteSellingManagerInventoryFolderCall Constructor
Namespaces ► eBay.Service.Call ► DeleteSellingManagerInventoryFolderCall ► DeleteSellingManagerInventoryFolderCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerInventoryFolderCall()
Public Sub New
public:
DeleteSellingManagerInventoryFolderCall()


DeleteSellingManagerInventoryFolderCall Constructor (ApiContext)

DeleteSellingManagerInventoryFolderCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► DeleteSellingManagerInventoryFolderCall ► DeleteSellingManagerInventoryFolderCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerInventoryFolderCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
DeleteSellingManagerInventoryFolderCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerInventoryFolderCall ► FolderID
Gets or sets the FolderID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


DeleteSellingManagerItemAutomationRuleCall Class

DeleteSellingManagerItemAutomationRuleCall Class
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class DeleteSellingManagerItemAutomationRuleCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class DeleteSellingManagerItemAutomationRuleCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class DeleteSellingManagerItemAutomationRuleCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerItemAutomationRuleCall()()()() |
 | DeleteSellingManagerItemAutomationRuleCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the DeleteSellingManagerItemAutomationRuleRequestType for this API call.
 | ApiResponse | Gets the DeleteSellingManagerItemAutomationRuleResponseType for this API call.
 | AutomatedListingRule | Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
 | AutomatedRelistingRule | Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
 | AutomatedSecondChanceOfferRule | Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeleteAutomatedRelistingRule | Gets or sets the DeleteAutomatedRelistingRule of type Boolean.
 | DeleteAutomatedSecondChanceOfferRule | Gets or sets the DeleteAutomatedSecondChanceOfferRule of type Boolean.
 | DeleteSellingManagerItemAutomationRule(String, Boolean, Boolean) | Removes the association of Selling Manager automation rules to an item. Returns the remaining rules in the response. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | DeleteSellingManagerItemAutomationRuleCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► ApiRequest
Gets or sets the DeleteSellingManagerItemAutomationRuleRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerItemAutomationRuleRequestType ApiRequest { get; set; }
Public Property ApiRequest As DeleteSellingManagerItemAutomationRuleRequestType
    Get
    Set
public:
property DeleteSellingManagerItemAutomationRuleRequestType^ ApiRequest {
    DeleteSellingManagerItemAutomationRuleRequestType^ get ();
    void set (DeleteSellingManagerItemAutomationRuleRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► ApiResponse
Gets the DeleteSellingManagerItemAutomationRuleResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerItemAutomationRuleResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As DeleteSellingManagerItemAutomationRuleResponseType
    Get
public:
property DeleteSellingManagerItemAutomationRuleResponseType^ ApiResponse {
    DeleteSellingManagerItemAutomationRuleResponseType^ get ();
}


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► AutomatedListingRule
Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; }
Public ReadOnly Property AutomatedListingRule As SellingManagerAutoListType
    Get
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► AutomatedRelistingRule
Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; }
Public ReadOnly Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► AutomatedSecondChanceOfferRule
Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; }
Public ReadOnly Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
}


DeleteAutomatedRelistingRule Property

DeleteAutomatedRelistingRule Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► DeleteAutomatedRelistingRule
Gets or sets the DeleteAutomatedRelistingRule of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedRelistingRule { get; set; }
Public Property DeleteAutomatedRelistingRule As Boolean
    Get
    Set
public:
property bool DeleteAutomatedRelistingRule {
    bool get ();
    void set (bool value);
}


DeleteAutomatedSecondChanceOfferRule Property

DeleteAutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► DeleteAutomatedSecondChanceOfferRule
Gets or sets the DeleteAutomatedSecondChanceOfferRule of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedSecondChanceOfferRule { get; set; }
Public Property DeleteAutomatedSecondChanceOfferRule As Boolean
    Get
    Set
public:
property bool DeleteAutomatedSecondChanceOfferRule {
    bool get ();
    void set (bool value);
}


DeleteSellingManagerItemAutomationRule Method (ItemID, DeleteAutomatedRelistingRule, DeleteAutomatedSecondChanceOfferRule)

DeleteSellingManagerItemAutomationRule Method (ItemID, DeleteAutomatedRelistingRule, DeleteAutomatedSecondChanceOfferRule)
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► DeleteSellingManagerItemAutomationRule(String, Boolean, Boolean)
Removes the association of Selling Manager automation rules to an item. Returns the remaining rules in the response. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType DeleteSellingManagerItemAutomationRule(
    string ItemID,
    bool DeleteAutomatedRelistingRule,
    bool DeleteAutomatedSecondChanceOfferRule
)
Public Function DeleteSellingManagerItemAutomationRule ( _
    ItemID As String, _
    DeleteAutomatedRelistingRule As Boolean, _
    DeleteAutomatedSecondChanceOfferRule As Boolean _
) As SellingManagerAutoListType
public:
SellingManagerAutoListType^ DeleteSellingManagerItemAutomationRule(
    String^ ItemID,
    bool DeleteAutomatedRelistingRule,
    bool DeleteAutomatedSecondChanceOfferRule
)
Parameters
ItemID (String)
The ID of the item from which to delete automation rules.
DeleteAutomatedRelistingRule (Boolean)
If true, the automated relisting rules are removed from the item.
DeleteAutomatedSecondChanceOfferRule (Boolean)
If true, the automated second chance offer rule is removed from the item.


DeleteSellingManagerItemAutomationRuleCall Constructor

DeleteSellingManagerItemAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► DeleteSellingManagerItemAutomationRuleCall()()()()
Members
Icon | Member | Description
 | DeleteSellingManagerItemAutomationRuleCall()()()() |
 | DeleteSellingManagerItemAutomationRuleCall(ApiContext) |


DeleteSellingManagerItemAutomationRuleCall Constructor

DeleteSellingManagerItemAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► DeleteSellingManagerItemAutomationRuleCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerItemAutomationRuleCall()
Public Sub New
public:
DeleteSellingManagerItemAutomationRuleCall()


DeleteSellingManagerItemAutomationRuleCall Constructor (ApiContext)

DeleteSellingManagerItemAutomationRuleCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► DeleteSellingManagerItemAutomationRuleCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerItemAutomationRuleCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
DeleteSellingManagerItemAutomationRuleCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerItemAutomationRuleCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


DeleteSellingManagerProductCall Class

DeleteSellingManagerProductCall Class
Namespaces ► eBay.Service.Call ► DeleteSellingManagerProductCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class DeleteSellingManagerProductCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class DeleteSellingManagerProductCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class DeleteSellingManagerProductCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerProductCall()()()() |
 | DeleteSellingManagerProductCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the DeleteSellingManagerProductRequestType for this API call.
 | ApiResponse | Gets the DeleteSellingManagerProductResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeletedSellingManagerProductDetails | Gets the returned DeletedSellingManagerProductDetails of type SellingManagerProductDetailsType.
 | DeleteSellingManagerProduct(Int64) | Deletes a Selling Manager product. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ProductID | Gets or sets the ProductID of type Int64.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | DeleteSellingManagerProductCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerProductCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerProductCall ► ApiRequest
Gets or sets the DeleteSellingManagerProductRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerProductRequestType ApiRequest { get; set; }
Public Property ApiRequest As DeleteSellingManagerProductRequestType
    Get
    Set
public:
property DeleteSellingManagerProductRequestType^ ApiRequest {
    DeleteSellingManagerProductRequestType^ get ();
    void set (DeleteSellingManagerProductRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerProductCall ► ApiResponse
Gets the DeleteSellingManagerProductResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerProductResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As DeleteSellingManagerProductResponseType
    Get
public:
property DeleteSellingManagerProductResponseType^ ApiResponse {
    DeleteSellingManagerProductResponseType^ get ();
}


DeletedSellingManagerProductDetails Property

DeletedSellingManagerProductDetails Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerProductCall ► DeletedSellingManagerProductDetails
Gets the returned DeletedSellingManagerProductDetails of type SellingManagerProductDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType DeletedSellingManagerProductDetails { get; }
Public ReadOnly Property DeletedSellingManagerProductDetails As SellingManagerProductDetailsType
    Get
public:
property SellingManagerProductDetailsType^ DeletedSellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
}


DeleteSellingManagerProduct Method (ProductID)

DeleteSellingManagerProduct Method (ProductID)
Namespaces ► eBay.Service.Call ► DeleteSellingManagerProductCall ► DeleteSellingManagerProduct(Int64)
Deletes a Selling Manager product. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType DeleteSellingManagerProduct(
    long ProductID
)
Public Function DeleteSellingManagerProduct ( _
    ProductID As Long _
) As SellingManagerProductDetailsType
public:
SellingManagerProductDetailsType^ DeleteSellingManagerProduct(
    long long ProductID
)
Parameters
ProductID (Int64)
ID of the product to be deleted.


DeleteSellingManagerProductCall Constructor

DeleteSellingManagerProductCall Constructor
Namespaces ► eBay.Service.Call ► DeleteSellingManagerProductCall ► DeleteSellingManagerProductCall()()()()
Members
Icon | Member | Description
 | DeleteSellingManagerProductCall()()()() |
 | DeleteSellingManagerProductCall(ApiContext) |


DeleteSellingManagerProductCall Constructor

DeleteSellingManagerProductCall Constructor
Namespaces ► eBay.Service.Call ► DeleteSellingManagerProductCall ► DeleteSellingManagerProductCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerProductCall()
Public Sub New
public:
DeleteSellingManagerProductCall()


DeleteSellingManagerProductCall Constructor (ApiContext)

DeleteSellingManagerProductCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► DeleteSellingManagerProductCall ► DeleteSellingManagerProductCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerProductCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
DeleteSellingManagerProductCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ProductID Property

ProductID Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerProductCall ► ProductID
Gets or sets the ProductID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long ProductID { get; set; }
Public Property ProductID As Long
    Get
    Set
public:
property long long ProductID {
    long long get ();
    void set (long long value);
}


DeleteSellingManagerTemplateAutomationRuleCall Class

DeleteSellingManagerTemplateAutomationRuleCall Class
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class DeleteSellingManagerTemplateAutomationRuleCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class DeleteSellingManagerTemplateAutomationRuleCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class DeleteSellingManagerTemplateAutomationRuleCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerTemplateAutomationRuleCall()()()() |
 | DeleteSellingManagerTemplateAutomationRuleCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the DeleteSellingManagerTemplateAutomationRuleRequestType for this API call.
 | ApiResponse | Gets the DeleteSellingManagerTemplateAutomationRuleResponseType for this API call.
 | AutomatedListingRule | Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
 | AutomatedRelistingRule | Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
 | AutomatedSecondChanceOfferRule | Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeleteAutomatedListingRule | Gets or sets the DeleteAutomatedListingRule of type Boolean.
 | DeleteAutomatedRelistingRule | Gets or sets the DeleteAutomatedRelistingRule of type Boolean.
 | DeleteAutomatedSecondChanceOfferRule | Gets or sets the DeleteAutomatedSecondChanceOfferRule of type Boolean.
 | DeleteSellingManagerTemplateAutomationRule(Int64, Boolean, Boolean, Boolean) | Removes the association of Selling Manager automation rules to a template. Returns the remaining rules in the response. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SaleTemplateID | Gets or sets the SaleTemplateID of type Int64.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | DeleteSellingManagerTemplateAutomationRuleCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► ApiRequest
Gets or sets the DeleteSellingManagerTemplateAutomationRuleRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateAutomationRuleRequestType ApiRequest { get; set; }
Public Property ApiRequest As DeleteSellingManagerTemplateAutomationRuleRequestType
    Get
    Set
public:
property DeleteSellingManagerTemplateAutomationRuleRequestType^ ApiRequest {
    DeleteSellingManagerTemplateAutomationRuleRequestType^ get ();
    void set (DeleteSellingManagerTemplateAutomationRuleRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► ApiResponse
Gets the DeleteSellingManagerTemplateAutomationRuleResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateAutomationRuleResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As DeleteSellingManagerTemplateAutomationRuleResponseType
    Get
public:
property DeleteSellingManagerTemplateAutomationRuleResponseType^ ApiResponse {
    DeleteSellingManagerTemplateAutomationRuleResponseType^ get ();
}


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► AutomatedListingRule
Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; }
Public ReadOnly Property AutomatedListingRule As SellingManagerAutoListType
    Get
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► AutomatedRelistingRule
Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; }
Public ReadOnly Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► AutomatedSecondChanceOfferRule
Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; }
Public ReadOnly Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
}


DeleteAutomatedListingRule Property

DeleteAutomatedListingRule Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► DeleteAutomatedListingRule
Gets or sets the DeleteAutomatedListingRule of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedListingRule { get; set; }
Public Property DeleteAutomatedListingRule As Boolean
    Get
    Set
public:
property bool DeleteAutomatedListingRule {
    bool get ();
    void set (bool value);
}


DeleteAutomatedRelistingRule Property

DeleteAutomatedRelistingRule Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► DeleteAutomatedRelistingRule
Gets or sets the DeleteAutomatedRelistingRule of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedRelistingRule { get; set; }
Public Property DeleteAutomatedRelistingRule As Boolean
    Get
    Set
public:
property bool DeleteAutomatedRelistingRule {
    bool get ();
    void set (bool value);
}


DeleteAutomatedSecondChanceOfferRule Property

DeleteAutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► DeleteAutomatedSecondChanceOfferRule
Gets or sets the DeleteAutomatedSecondChanceOfferRule of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedSecondChanceOfferRule { get; set; }
Public Property DeleteAutomatedSecondChanceOfferRule As Boolean
    Get
    Set
public:
property bool DeleteAutomatedSecondChanceOfferRule {
    bool get ();
    void set (bool value);
}


DeleteSellingManagerTemplateAutomationRule Method (SaleTemplateID, DeleteAutomatedListingRule, DeleteAutomatedRelistingRule, DeleteAutomatedSecondChanceOfferRule)

DeleteSellingManagerTemplateAutomationRule Method (SaleTemplateID, DeleteAutomatedListingRule, DeleteAutomatedRelistingRule, DeleteAutomatedSecondChanceOfferRule)
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► DeleteSellingManagerTemplateAutomationRule(Int64, Boolean, Boolean, Boolean)
Removes the association of Selling Manager automation rules to a template. Returns the remaining rules in the response. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType DeleteSellingManagerTemplateAutomationRule(
    long SaleTemplateID,
    bool DeleteAutomatedListingRule,
    bool DeleteAutomatedRelistingRule,
    bool DeleteAutomatedSecondChanceOfferRule
)
Public Function DeleteSellingManagerTemplateAutomationRule ( _
    SaleTemplateID As Long, _
    DeleteAutomatedListingRule As Boolean, _
    DeleteAutomatedRelistingRule As Boolean, _
    DeleteAutomatedSecondChanceOfferRule As Boolean _
) As SellingManagerAutoListType
public:
SellingManagerAutoListType^ DeleteSellingManagerTemplateAutomationRule(
    long long SaleTemplateID,
    bool DeleteAutomatedListingRule,
    bool DeleteAutomatedRelistingRule,
    bool DeleteAutomatedSecondChanceOfferRule
)
Parameters
SaleTemplateID (Int64)
The ID of the template from which you want to remove automation rules. You can obtain a SaleTemplateID by calling GetSellingManagerInventory.
DeleteAutomatedListingRule (Boolean)
If true, the automated listing rules are removed from the template.
DeleteAutomatedRelistingRule (Boolean)
If true, the automated relisting rules are removed from the template.
DeleteAutomatedSecondChanceOfferRule (Boolean)
If true, the automated second chance offer rule is removed from the template.


DeleteSellingManagerTemplateAutomationRuleCall Constructor

DeleteSellingManagerTemplateAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► DeleteSellingManagerTemplateAutomationRuleCall()()()()
Members
Icon | Member | Description
 | DeleteSellingManagerTemplateAutomationRuleCall()()()() |
 | DeleteSellingManagerTemplateAutomationRuleCall(ApiContext) |


DeleteSellingManagerTemplateAutomationRuleCall Constructor

DeleteSellingManagerTemplateAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► DeleteSellingManagerTemplateAutomationRuleCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateAutomationRuleCall()
Public Sub New
public:
DeleteSellingManagerTemplateAutomationRuleCall()


DeleteSellingManagerTemplateAutomationRuleCall Constructor (ApiContext)

DeleteSellingManagerTemplateAutomationRuleCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► DeleteSellingManagerTemplateAutomationRuleCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateAutomationRuleCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
DeleteSellingManagerTemplateAutomationRuleCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateAutomationRuleCall ► SaleTemplateID
Gets or sets the SaleTemplateID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


DeleteSellingManagerTemplateCall Class

DeleteSellingManagerTemplateCall Class
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class DeleteSellingManagerTemplateCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class DeleteSellingManagerTemplateCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class DeleteSellingManagerTemplateCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerTemplateCall()()()() |
 | DeleteSellingManagerTemplateCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the DeleteSellingManagerTemplateRequestType for this API call.
 | ApiResponse | Gets the DeleteSellingManagerTemplateResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeletedSaleTemplateID | Gets the returned DeletedSaleTemplateID of type String.
 | DeletedSaleTemplateName | Gets the returned DeletedSaleTemplateName of type String.
 | DeleteSellingManagerTemplate(Int64) | Deletes a Selling Manager template. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SaleTemplateID | Gets or sets the SaleTemplateID of type Int64.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | DeleteSellingManagerTemplateCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateCall ► ApiRequest
Gets or sets the DeleteSellingManagerTemplateRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateRequestType ApiRequest { get; set; }
Public Property ApiRequest As DeleteSellingManagerTemplateRequestType
    Get
    Set
public:
property DeleteSellingManagerTemplateRequestType^ ApiRequest {
    DeleteSellingManagerTemplateRequestType^ get ();
    void set (DeleteSellingManagerTemplateRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateCall ► ApiResponse
Gets the DeleteSellingManagerTemplateResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As DeleteSellingManagerTemplateResponseType
    Get
public:
property DeleteSellingManagerTemplateResponseType^ ApiResponse {
    DeleteSellingManagerTemplateResponseType^ get ();
}


DeletedSaleTemplateID Property

DeletedSaleTemplateID Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateCall ► DeletedSaleTemplateID
Gets the returned DeletedSaleTemplateID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string DeletedSaleTemplateID { get; }
Public ReadOnly Property DeletedSaleTemplateID As String
    Get
public:
property String^ DeletedSaleTemplateID {
    String^ get ();
}


DeletedSaleTemplateName Property

DeletedSaleTemplateName Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateCall ► DeletedSaleTemplateName
Gets the returned DeletedSaleTemplateName of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string DeletedSaleTemplateName { get; }
Public ReadOnly Property DeletedSaleTemplateName As String
    Get
public:
property String^ DeletedSaleTemplateName {
    String^ get ();
}


DeleteSellingManagerTemplate Method (SaleTemplateID)

DeleteSellingManagerTemplate Method (SaleTemplateID)
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateCall ► DeleteSellingManagerTemplate(Int64)
Deletes a Selling Manager template. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public string DeleteSellingManagerTemplate(
    long SaleTemplateID
)
Public Function DeleteSellingManagerTemplate ( _
    SaleTemplateID As Long _
) As String
public:
String^ DeleteSellingManagerTemplate(
    long long SaleTemplateID
)
Parameters
SaleTemplateID (Int64)
ID of the template to be deleted. You can obtain a SaleTemplateID by calling GetSellingManagerInventory.


DeleteSellingManagerTemplateCall Constructor

DeleteSellingManagerTemplateCall Constructor
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateCall ► DeleteSellingManagerTemplateCall()()()()
Members
Icon | Member | Description
 | DeleteSellingManagerTemplateCall()()()() |
 | DeleteSellingManagerTemplateCall(ApiContext) |


DeleteSellingManagerTemplateCall Constructor

DeleteSellingManagerTemplateCall Constructor
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateCall ► DeleteSellingManagerTemplateCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateCall()
Public Sub New
public:
DeleteSellingManagerTemplateCall()


DeleteSellingManagerTemplateCall Constructor (ApiContext)

DeleteSellingManagerTemplateCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateCall ► DeleteSellingManagerTemplateCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
DeleteSellingManagerTemplateCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Call ► DeleteSellingManagerTemplateCall ► SaleTemplateID
Gets or sets the SaleTemplateID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


DisableUnpaidItemAssistanceCall Class

DisableUnpaidItemAssistanceCall Class
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class DisableUnpaidItemAssistanceCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class DisableUnpaidItemAssistanceCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class DisableUnpaidItemAssistanceCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisableUnpaidItemAssistanceCall()()()() |
 | DisableUnpaidItemAssistanceCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the DisableUnpaidItemAssistanceRequestType for this API call.
 | ApiResponse | Gets the DisableUnpaidItemAssistanceResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DisableUnpaidItemAssistance(String, String, String, String) | Enables a seller who has opted into the automated Unpaid Item Assistant mechanism to disable the Unpaid Item Assistant at the order line item level. This call can be made whether or not a Unpaid Item case exists for the order line item. If an Unpaid Item case has already been created by the Unpaid Item Assistant, it is converted to a "manual" case for the seller to manage like any other manually-created case.
 | DisputeID | Gets or sets the DisputeID of type String.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | DisableUnpaidItemAssistanceCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall ► ApiRequest
Gets or sets the DisableUnpaidItemAssistanceRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DisableUnpaidItemAssistanceRequestType ApiRequest { get; set; }
Public Property ApiRequest As DisableUnpaidItemAssistanceRequestType
    Get
    Set
public:
property DisableUnpaidItemAssistanceRequestType^ ApiRequest {
    DisableUnpaidItemAssistanceRequestType^ get ();
    void set (DisableUnpaidItemAssistanceRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall ► ApiResponse
Gets the DisableUnpaidItemAssistanceResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public DisableUnpaidItemAssistanceResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As DisableUnpaidItemAssistanceResponseType
    Get
public:
property DisableUnpaidItemAssistanceResponseType^ ApiResponse {
    DisableUnpaidItemAssistanceResponseType^ get ();
}


DisableUnpaidItemAssistance Method (ItemID, TransactionID, DisputeID, OrderLineItemID)

DisableUnpaidItemAssistance Method (ItemID, TransactionID, DisputeID, OrderLineItemID)
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall ► DisableUnpaidItemAssistance(String, String, String, String)
Enables a seller who has opted into the automated Unpaid Item Assistant mechanism to disable the Unpaid Item Assistant at the order line item level. This call can be made whether or not a Unpaid Item case exists for the order line item. If an Unpaid Item case has already been created by the Unpaid Item Assistant, it is converted to a "manual" case for the seller to manage like any other manually-created case.
Declaration Syntax
C# Visual Basic Visual C++
public void DisableUnpaidItemAssistance(
    string ItemID,
    string TransactionID,
    string DisputeID,
    string OrderLineItemID
)
Public Sub DisableUnpaidItemAssistance ( _
    ItemID As String, _
    TransactionID As String, _
    DisputeID As String, _
    OrderLineItemID As String _
)
public:
void DisableUnpaidItemAssistance(
    String^ ItemID,
    String^ TransactionID,
    String^ DisputeID,
    String^ OrderLineItemID
)
Parameters
ItemID (String)
Unique identifier for an eBay listing. A listing can have multiple order line items (transactions), but only one ItemID. To identify a specific order line item for which to disable the Unpaid Item Assistant mechanism, either an ItemID/TransactionID pair, an OrderLineItemID, or a DisputeID (if an Unpaid Item case already exists) is required in the request.
TransactionID (String)
The unique identifier of an order line item (transaction). An order line item is created once there is a commitment from a buyer to purchase an item. To identify a specific order line item for which to disable the Unpaid Item Assistant mechanism, either an ItemID/TransactionID pair, an OrderLineItemID, or a DisputeID (if an Unpaid Item case already exists) is required in the request.
DisputeID (String)
A unique identifier for an Unpaid Item case that is filed against an order line item. If an ItemID/TransactionID pair or an OrderLineItemID is used to identify an order line item, DisputeID cannot be used and will be ignored if it is included in the request.
OrderLineItemID (String)
OrderLineItemID is a unique identifier for an eBay order line item and is based upon the concatenation of ItemID and TransactionID, with a hyphen in between these two IDs. To identify a specific order line item for which to disable the Unpaid Item Assistant mechanism, either an ItemID/TransactionID pair, an OrderLineItemID, or a DisputeID is required in the request.


DisableUnpaidItemAssistanceCall Constructor

DisableUnpaidItemAssistanceCall Constructor
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall ► DisableUnpaidItemAssistanceCall()()()()
Members
Icon | Member | Description
 | DisableUnpaidItemAssistanceCall()()()() |
 | DisableUnpaidItemAssistanceCall(ApiContext) |


DisableUnpaidItemAssistanceCall Constructor

DisableUnpaidItemAssistanceCall Constructor
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall ► DisableUnpaidItemAssistanceCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisableUnpaidItemAssistanceCall()
Public Sub New
public:
DisableUnpaidItemAssistanceCall()


DisableUnpaidItemAssistanceCall Constructor (ApiContext)

DisableUnpaidItemAssistanceCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall ► DisableUnpaidItemAssistanceCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public DisableUnpaidItemAssistanceCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
DisableUnpaidItemAssistanceCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


DisputeID Property

DisputeID Property
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall ► DisputeID
Gets or sets the DisputeID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string DisputeID { get; set; }
Public Property DisputeID As String
    Get
    Set
public:
property String^ DisputeID {
    String^ get ();
    void set (String^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► DisableUnpaidItemAssistanceCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


EndFixedPriceItemCall Class

EndFixedPriceItemCall Class
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class EndFixedPriceItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class EndFixedPriceItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class EndFixedPriceItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndFixedPriceItemCall()()()() |
 | EndFixedPriceItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the EndFixedPriceItemRequestType for this API call.
 | ApiResponse | Gets the EndFixedPriceItemResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndFixedPriceItem(String, EndReasonCodeType, String) | Ends the specified fixed-price listing before the date and time at which it would normally end (per the listing duration).
 | EndingReason | Gets or sets the EndingReason of type EndReasonCodeType.
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SKU | Gets or sets the SKU of type String.
 | SKUReturn | Gets the returned SKU of type String.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | EndFixedPriceItemCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► ApiRequest
Gets or sets the EndFixedPriceItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public EndFixedPriceItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As EndFixedPriceItemRequestType
    Get
    Set
public:
property EndFixedPriceItemRequestType^ ApiRequest {
    EndFixedPriceItemRequestType^ get ();
    void set (EndFixedPriceItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► ApiResponse
Gets the EndFixedPriceItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public EndFixedPriceItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As EndFixedPriceItemResponseType
    Get
public:
property EndFixedPriceItemResponseType^ ApiResponse {
    EndFixedPriceItemResponseType^ get ();
}


EndFixedPriceItem Method (ItemID, EndingReason, SKU)

EndFixedPriceItem Method (ItemID, EndingReason, SKU)
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► EndFixedPriceItem(String, EndReasonCodeType, String)
Ends the specified fixed-price listing before the date and time at which it would normally end (per the listing duration).
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndFixedPriceItem(
    string ItemID,
    EndReasonCodeType EndingReason,
    string SKU
)
Public Function EndFixedPriceItem ( _
    ItemID As String, _
    EndingReason As EndReasonCodeType, _
    SKU As String _
) As DateTime
public:
DateTime EndFixedPriceItem(
    String^ ItemID,
    EndReasonCodeType EndingReason,
    String^ SKU
)
Parameters
ItemID (String)
Unique item ID that identifies the item listing that you want to end. In the EndFixedPriceItem request, either ItemID or SKU is required. If both are passed in and they don't refer to the same listing, eBay ignores SKU and considers only the ItemID.
EndingReason (EndReasonCodeType)
Indicates the seller's reason for ending the listing early. This field is required if the seller is ending the item early and the item did not successfully sell.
SKU (String)
The unique SKU of the item being ended. A SKU (stock keeping unit) is an identifier defined by a seller. SKU can only be used to end an item if you listed the item by using AddFixedPriceItem or RelistFixedPriceItem, and you set Item.InventoryTrackingMethod to SKU at the time the item was listed. (These criteria are necessary to uniquely identify the listing by a SKU.) In the EndFixedPriceItem request, either ItemID or SKU is required. If both are passed in and they don't refer to the same listing, eBay ignores SKU and considers only the ItemID. To remove a SKU when you revise or relist an item, use DeletedField in the revision or relist call.


EndFixedPriceItemCall Constructor

EndFixedPriceItemCall Constructor
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► EndFixedPriceItemCall()()()()
Members
Icon | Member | Description
 | EndFixedPriceItemCall()()()() |
 | EndFixedPriceItemCall(ApiContext) |


EndFixedPriceItemCall Constructor

EndFixedPriceItemCall Constructor
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► EndFixedPriceItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndFixedPriceItemCall()
Public Sub New
public:
EndFixedPriceItemCall()


EndFixedPriceItemCall Constructor (ApiContext)

EndFixedPriceItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► EndFixedPriceItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public EndFixedPriceItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
EndFixedPriceItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


EndingReason Property

EndingReason Property
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► EndingReason
Gets or sets the EndingReason of type EndReasonCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public EndReasonCodeType EndingReason { get; set; }
Public Property EndingReason As EndReasonCodeType
    Get
    Set
public:
property EndReasonCodeType EndingReason {
    EndReasonCodeType get ();
    void set (EndReasonCodeType value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► SKU
Gets or sets the SKU of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


SKUReturn Property

SKUReturn Property
Namespaces ► eBay.Service.Call ► EndFixedPriceItemCall ► SKUReturn
Gets the returned SKU of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SKUReturn { get; }
Public ReadOnly Property SKUReturn As String
    Get
public:
property String^ SKUReturn {
    String^ get ();
}


EndItemCall Class

EndItemCall Class
Namespaces ► eBay.Service.Call ► EndItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class EndItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class EndItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class EndItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndItemCall()()()() |
 | EndItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the EndItemRequestType for this API call.
 | ApiResponse | Gets the EndItemResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndingReason | Gets or sets the EndingReason of type EndReasonCodeType.
 | EndItem(String, EndReasonCodeType, String) |
 | EndItem(String, EndReasonCodeType) | For backward compatibility with old wrappers.
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellerInventoryID | Gets or sets the SellerInventoryID of type String.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | EndItemCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► EndItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► EndItemCall ► ApiRequest
Gets or sets the EndItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public EndItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As EndItemRequestType
    Get
    Set
public:
property EndItemRequestType^ ApiRequest {
    EndItemRequestType^ get ();
    void set (EndItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► EndItemCall ► ApiResponse
Gets the EndItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As EndItemResponseType
    Get
public:
property EndItemResponseType^ ApiResponse {
    EndItemResponseType^ get ();
}


EndingReason Property

EndingReason Property
Namespaces ► eBay.Service.Call ► EndItemCall ► EndingReason
Gets or sets the EndingReason of type EndReasonCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public EndReasonCodeType EndingReason { get; set; }
Public Property EndingReason As EndReasonCodeType
    Get
    Set
public:
property EndReasonCodeType EndingReason {
    EndReasonCodeType get ();
    void set (EndReasonCodeType value);
}


EndItem Method

EndItem Method
Namespaces ► eBay.Service.Call ► EndItemCall ► EndItem()()()()
Members
Icon | Member | Description
 | EndItem(String, EndReasonCodeType, String) |
 | EndItem(String, EndReasonCodeType) | For backward compatibility with old wrappers.


EndItem Method (ItemID, EndingReason)

EndItem Method (ItemID, EndingReason)
Namespaces ► eBay.Service.Call ► EndItemCall ► EndItem(String, EndReasonCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void EndItem(
    string ItemID,
    EndReasonCodeType EndingReason
)
Public Sub EndItem ( _
    ItemID As String, _
    EndingReason As EndReasonCodeType _
)
public:
void EndItem(
    String^ ItemID,
    EndReasonCodeType EndingReason
)
Parameters
ItemID (String)
EndingReason (EndReasonCodeType)


EndItem Method (ItemID, EndingReason, SellerInventoryID)

EndItem Method (ItemID, EndingReason, SellerInventoryID)
Namespaces ► eBay.Service.Call ► EndItemCall ► EndItem(String, EndReasonCodeType, String)
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndItem(
    string ItemID,
    EndReasonCodeType EndingReason,
    string SellerInventoryID
)
Public Function EndItem ( _
    ItemID As String, _
    EndingReason As EndReasonCodeType, _
    SellerInventoryID As String _
) As DateTime
public:
DateTime EndItem(
    String^ ItemID,
    EndReasonCodeType EndingReason,
    String^ SellerInventoryID
)
Parameters
ItemID (String)
EndingReason (EndReasonCodeType)
SellerInventoryID (String)


EndItemCall Constructor

EndItemCall Constructor
Namespaces ► eBay.Service.Call ► EndItemCall ► EndItemCall()()()()
Members
Icon | Member | Description
 | EndItemCall()()()() |
 | EndItemCall(ApiContext) |


EndItemCall Constructor

EndItemCall Constructor
Namespaces ► eBay.Service.Call ► EndItemCall ► EndItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemCall()
Public Sub New
public:
EndItemCall()


EndItemCall Constructor (ApiContext)

EndItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► EndItemCall ► EndItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public EndItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
EndItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► EndItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► EndItemCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


SellerInventoryID Property

SellerInventoryID Property
Namespaces ► eBay.Service.Call ► EndItemCall ► SellerInventoryID
Gets or sets the SellerInventoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SellerInventoryID { get; set; }
Public Property SellerInventoryID As String
    Get
    Set
public:
property String^ SellerInventoryID {
    String^ get ();
    void set (String^ value);
}


EndItemsCall Class

EndItemsCall Class
Namespaces ► eBay.Service.Call ► EndItemsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class EndItemsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class EndItemsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class EndItemsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndItemsCall()()()() |
 | EndItemsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the EndItemsRequestType for this API call.
 | ApiResponse | Gets the EndItemsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndItemRequestContainerList | Gets or sets the EndItemRequestContainer of type EndItemRequestContainerTypeCollection.
 | EndItemResponseContainerList | Gets the returned EndItemResponseContainer of type EndItemResponseContainerTypeCollection.
 | EndItems(EndItemRequestContainerTypeCollection) |
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | EndItemsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► EndItemsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► EndItemsCall ► ApiRequest
Gets or sets the EndItemsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public EndItemsRequestType ApiRequest { get; set; }
Public Property ApiRequest As EndItemsRequestType
    Get
    Set
public:
property EndItemsRequestType^ ApiRequest {
    EndItemsRequestType^ get ();
    void set (EndItemsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► EndItemsCall ► ApiResponse
Gets the EndItemsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public EndItemsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As EndItemsResponseType
    Get
public:
property EndItemsResponseType^ ApiResponse {
    EndItemsResponseType^ get ();
}


EndItemRequestContainerList Property

EndItemRequestContainerList Property
Namespaces ► eBay.Service.Call ► EndItemsCall ► EndItemRequestContainerList
Gets or sets the EndItemRequestContainer of type EndItemRequestContainerTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public EndItemRequestContainerTypeCollection EndItemRequestContainerList { get; set; }
Public Property EndItemRequestContainerList As EndItemRequestContainerTypeCollection
    Get
    Set
public:
property EndItemRequestContainerTypeCollection^ EndItemRequestContainerList {
    EndItemRequestContainerTypeCollection^ get ();
    void set (EndItemRequestContainerTypeCollection^ value);
}


EndItemResponseContainerList Property

EndItemResponseContainerList Property
Namespaces ► eBay.Service.Call ► EndItemsCall ► EndItemResponseContainerList
Gets the returned EndItemResponseContainer of type EndItemResponseContainerTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseContainerTypeCollection EndItemResponseContainerList { get; }
Public ReadOnly Property EndItemResponseContainerList As EndItemResponseContainerTypeCollection
    Get
public:
property EndItemResponseContainerTypeCollection^ EndItemResponseContainerList {
    EndItemResponseContainerTypeCollection^ get ();
}


EndItems Method (EndItemRequestContainerList)

EndItems Method (EndItemRequestContainerList)
Namespaces ► eBay.Service.Call ► EndItemsCall ► EndItems(EndItemRequestContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseContainerTypeCollection EndItems(
    EndItemRequestContainerTypeCollection EndItemRequestContainerList
)
Public Function EndItems ( _
    EndItemRequestContainerList As EndItemRequestContainerTypeCollection _
) As EndItemResponseContainerTypeCollection
public:
EndItemResponseContainerTypeCollection^ EndItems(
    EndItemRequestContainerTypeCollection^ EndItemRequestContainerList
)
Parameters
EndItemRequestContainerList (EndItemRequestContainerTypeCollection)


EndItemsCall Constructor

EndItemsCall Constructor
Namespaces ► eBay.Service.Call ► EndItemsCall ► EndItemsCall()()()()
Members
Icon | Member | Description
 | EndItemsCall()()()() |
 | EndItemsCall(ApiContext) |


EndItemsCall Constructor

EndItemsCall Constructor
Namespaces ► eBay.Service.Call ► EndItemsCall ► EndItemsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemsCall()
Public Sub New
public:
EndItemsCall()


EndItemsCall Constructor (ApiContext)

EndItemsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► EndItemsCall ► EndItemsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public EndItemsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
EndItemsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ExtendSiteHostedPicturesCall Class

ExtendSiteHostedPicturesCall Class
Namespaces ► eBay.Service.Call ► ExtendSiteHostedPicturesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ExtendSiteHostedPicturesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ExtendSiteHostedPicturesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ExtendSiteHostedPicturesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExtendSiteHostedPicturesCall()()()() |
 | ExtendSiteHostedPicturesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ExtendSiteHostedPicturesRequestType for this API call.
 | ApiResponse | Gets the ExtendSiteHostedPicturesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | ExtendSiteHostedPictures(StringCollection, Int32) | Gives approved sellers the ability to extend the default and ongoing lifetime of pictures uploaded to eBay.
 | ExtensionInDays | Gets or sets the ExtensionInDays of type Int32.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PictureURLList | Gets or sets the PictureURL of type StringCollection.
 | PictureURLListReturn | Gets the returned PictureURL of type StringCollection.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ExtendSiteHostedPicturesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ExtendSiteHostedPicturesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ExtendSiteHostedPicturesCall ► ApiRequest
Gets or sets the ExtendSiteHostedPicturesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ExtendSiteHostedPicturesRequestType ApiRequest { get; set; }
Public Property ApiRequest As ExtendSiteHostedPicturesRequestType
    Get
    Set
public:
property ExtendSiteHostedPicturesRequestType^ ApiRequest {
    ExtendSiteHostedPicturesRequestType^ get ();
    void set (ExtendSiteHostedPicturesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ExtendSiteHostedPicturesCall ► ApiResponse
Gets the ExtendSiteHostedPicturesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ExtendSiteHostedPicturesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ExtendSiteHostedPicturesResponseType
    Get
public:
property ExtendSiteHostedPicturesResponseType^ ApiResponse {
    ExtendSiteHostedPicturesResponseType^ get ();
}


ExtendSiteHostedPictures Method (PictureURLList, ExtensionInDays)

ExtendSiteHostedPictures Method (PictureURLList, ExtensionInDays)
Namespaces ► eBay.Service.Call ► ExtendSiteHostedPicturesCall ► ExtendSiteHostedPictures(StringCollection, Int32)
Gives approved sellers the ability to extend the default and ongoing lifetime of pictures uploaded to eBay.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ExtendSiteHostedPictures(
    StringCollection PictureURLList,
    int ExtensionInDays
)
Public Function ExtendSiteHostedPictures ( _
    PictureURLList As StringCollection, _
    ExtensionInDays As Integer _
) As StringCollection
public:
StringCollection^ ExtendSiteHostedPictures(
    StringCollection^ PictureURLList,
    int ExtensionInDays
)
Parameters
PictureURLList (StringCollection)
The URL of the image hosted by eBay Picture Services.
ExtensionInDays (Int32)
The number of days by which to extend the expiration date for the specified image.


ExtendSiteHostedPicturesCall Constructor

ExtendSiteHostedPicturesCall Constructor
Namespaces ► eBay.Service.Call ► ExtendSiteHostedPicturesCall ► ExtendSiteHostedPicturesCall()()()()
Members
Icon | Member | Description
 | ExtendSiteHostedPicturesCall()()()() |
 | ExtendSiteHostedPicturesCall(ApiContext) |


ExtendSiteHostedPicturesCall Constructor

ExtendSiteHostedPicturesCall Constructor
Namespaces ► eBay.Service.Call ► ExtendSiteHostedPicturesCall ► ExtendSiteHostedPicturesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExtendSiteHostedPicturesCall()
Public Sub New
public:
ExtendSiteHostedPicturesCall()


ExtendSiteHostedPicturesCall Constructor (ApiContext)

ExtendSiteHostedPicturesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ExtendSiteHostedPicturesCall ► ExtendSiteHostedPicturesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ExtendSiteHostedPicturesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ExtendSiteHostedPicturesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ExtensionInDays Property

ExtensionInDays Property
Namespaces ► eBay.Service.Call ► ExtendSiteHostedPicturesCall ► ExtensionInDays
Gets or sets the ExtensionInDays of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int ExtensionInDays { get; set; }
Public Property ExtensionInDays As Integer
    Get
    Set
public:
property int ExtensionInDays {
    int get ();
    void set (int value);
}


PictureURLList Property

PictureURLList Property
Namespaces ► eBay.Service.Call ► ExtendSiteHostedPicturesCall ► PictureURLList
Gets or sets the PictureURL of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureURLList { get; set; }
Public Property PictureURLList As StringCollection
    Get
    Set
public:
property StringCollection^ PictureURLList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


PictureURLListReturn Property

PictureURLListReturn Property
Namespaces ► eBay.Service.Call ► ExtendSiteHostedPicturesCall ► PictureURLListReturn
Gets the returned PictureURL of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureURLListReturn { get; }
Public ReadOnly Property PictureURLListReturn As StringCollection
    Get
public:
property StringCollection^ PictureURLListReturn {
    StringCollection^ get ();
}


FetchTokenCall Class

FetchTokenCall Class
Namespaces ► eBay.Service.Call ► FetchTokenCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class FetchTokenCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class FetchTokenCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class FetchTokenCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FetchTokenCall()()()() |
 | FetchTokenCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the FetchTokenRequestType for this API call.
 | ApiResponse | Gets the FetchTokenResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | eBayToken | Gets the returned eBayAuthToken of type String.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FetchToken(String, String) |
 | FetchToken(String) | Fetch token using SessionID(new token fetch flow).
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Overrides ApiCall.GetSecurityHeader()()()().)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationTime | Gets the returned HardExpirationTime of type DateTime.
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | RESTToken | Gets the returned RESTToken of type String.
 | SecretID | Gets or sets the SecretID of type String.
 | SessionID | Gets or sets the SessionID of type String.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | FetchTokenCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► FetchTokenCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► FetchTokenCall ► ApiRequest
Gets or sets the FetchTokenRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public FetchTokenRequestType ApiRequest { get; set; }
Public Property ApiRequest As FetchTokenRequestType
    Get
    Set
public:
property FetchTokenRequestType^ ApiRequest {
    FetchTokenRequestType^ get ();
    void set (FetchTokenRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► FetchTokenCall ► ApiResponse
Gets the FetchTokenResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public FetchTokenResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As FetchTokenResponseType
    Get
public:
property FetchTokenResponseType^ ApiResponse {
    FetchTokenResponseType^ get ();
}


eBayToken Property

eBayToken Property
Namespaces ► eBay.Service.Call ► FetchTokenCall ► eBayToken
Gets the returned eBayAuthToken of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string eBayToken { get; }
Public ReadOnly Property eBayToken As String
    Get
public:
property String^ eBayToken {
    String^ get ();
}


FetchToken Method

FetchToken Method
Namespaces ► eBay.Service.Call ► FetchTokenCall ► FetchToken()()()()
Members
Icon | Member | Description
 | FetchToken(String, String) |
 | FetchToken(String) | Fetch token using SessionID(new token fetch flow).


FetchToken Method (SecretID, SessionID)

FetchToken Method (SecretID, SessionID)
Namespaces ► eBay.Service.Call ► FetchTokenCall ► FetchToken(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public string FetchToken(
    string SecretID,
    string SessionID
)
Public Function FetchToken ( _
    SecretID As String, _
    SessionID As String _
) As String
public:
String^ FetchToken(
    String^ SecretID,
    String^ SessionID
)
Parameters
SecretID (String)
SessionID (String)


FetchToken Method (SessionID)

FetchToken Method (SessionID)
Namespaces ► eBay.Service.Call ► FetchTokenCall ► FetchToken(String)
Fetch token using SessionID(new token fetch flow).
Declaration Syntax
C# Visual Basic Visual C++
public string FetchToken(
    string SessionID
)
Public Function FetchToken ( _
    SessionID As String _
) As String
public:
String^ FetchToken(
    String^ SessionID
)
Parameters
SessionID (String)


FetchTokenCall Constructor

FetchTokenCall Constructor
Namespaces ► eBay.Service.Call ► FetchTokenCall ► FetchTokenCall()()()()
Members
Icon | Member | Description
 | FetchTokenCall()()()() |
 | FetchTokenCall(ApiContext) |


FetchTokenCall Constructor

FetchTokenCall Constructor
Namespaces ► eBay.Service.Call ► FetchTokenCall ► FetchTokenCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FetchTokenCall()
Public Sub New
public:
FetchTokenCall()


FetchTokenCall Constructor (ApiContext)

FetchTokenCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► FetchTokenCall ► FetchTokenCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public FetchTokenCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
FetchTokenCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


GetSecurityHeader Method

GetSecurityHeader Method
Namespaces ► eBay.Service.Call ► FetchTokenCall ► GetSecurityHeader()()()()
Constructs a security header from values in ApiContext.
Declaration Syntax
C# Visual Basic Visual C++
protected override CustomSecurityHeaderType GetSecurityHeader()
Protected Overrides Function GetSecurityHeader As CustomSecurityHeaderType
protected:
virtual CustomSecurityHeaderType^ GetSecurityHeader() override
Return Value
Security information of type CustomSecurityHeaderType.


HardExpirationTime Property

HardExpirationTime Property
Namespaces ► eBay.Service.Call ► FetchTokenCall ► HardExpirationTime
Gets the returned HardExpirationTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime HardExpirationTime { get; }
Public ReadOnly Property HardExpirationTime As DateTime
    Get
public:
property DateTime HardExpirationTime {
    DateTime get ();
}


RESTToken Property

RESTToken Property
Namespaces ► eBay.Service.Call ► FetchTokenCall ► RESTToken
Gets the returned RESTToken of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string RESTToken { get; }
Public ReadOnly Property RESTToken As String
    Get
public:
property String^ RESTToken {
    String^ get ();
}


SecretID Property

SecretID Property
Namespaces ► eBay.Service.Call ► FetchTokenCall ► SecretID
Gets or sets the SecretID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SecretID { get; set; }
Public Property SecretID As String
    Get
    Set
public:
property String^ SecretID {
    String^ get ();
    void set (String^ value);
}


SessionID Property

SessionID Property
Namespaces ► eBay.Service.Call ► FetchTokenCall ► SessionID
Gets or sets the SessionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SessionID { get; set; }
Public Property SessionID As String
    Get
    Set
public:
property String^ SessionID {
    String^ get ();
    void set (String^ value);
}


GetAccountCall Class

GetAccountCall Class
Namespaces ► eBay.Service.Call ► GetAccountCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetAccountCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetAccountCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetAccountCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetAccountCall()()()() |
 | GetAccountCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AccountEntries | Gets the returned AccountEntries of type AccountEntriesType.
 | AccountEntryList | Gets the [!:GetAccountResponseType.AccountEntries.AccountEntry] of type AccountEntryList.
 | AccountEntrySortType | Gets or sets the AccountEntrySortType of type AccountEntrySortTypeCodeType.
 | AccountHistorySelection | Gets or sets the AccountHistorySelection of type AccountHistorySelectionCodeType.
 | AccountID | Gets the returned AccountID of type String.
 | AccountSummary | Gets the returned AccountSummary of type AccountSummaryType.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetAccountRequestType for this API call.
 | ApiResponse | Gets the GetAccountResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BeginDate | Gets or sets the BeginDate of type DateTime.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Currency | Gets or sets the Currency of type CurrencyCodeType.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndDate | Gets or sets the EndDate of type DateTime.
 | EntriesPerPage | Gets the returned EntriesPerPage of type Int32.
 | Equals(Object) | (Inherited from Object.)
 | ExcludeBalance | Gets or sets the ExcludeBalance of type Boolean.
 | ExcludeSummary | Gets or sets the ExcludeSummary of type Boolean.
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAccount(AccountHistorySelectionCodeType, DateTime, DateTime, DateTime, PaginationType, Boolean, Boolean, Boolean, AccountEntrySortTypeCodeType, CurrencyCodeType, String) | Returns a seller's invoice data for their eBay account, including the account's summary data.
 | GetAccount(AccountHistorySelectionCodeType) | For backward compatibility with old wrappers.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasMoreEntries | Gets the returned HasMoreEntries of type Boolean.
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeConversionRate | Gets or sets the IncludeConversionRate of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | InvoiceDate | Gets or sets the InvoiceDate of type DateTime.
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PageNumber | Gets the returned PageNumber of type Int32.
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTimeFilter | Gets or sets the BeginDate and EndDate of type TimeFilter.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetAccountCall


AccountEntries Property

AccountEntries Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► AccountEntries
Gets the returned AccountEntries of type AccountEntriesType.
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntriesType AccountEntries { get; }
Public ReadOnly Property AccountEntries As AccountEntriesType
    Get
public:
property AccountEntriesType^ AccountEntries {
    AccountEntriesType^ get ();
}


AccountEntryList Property

AccountEntryList Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► AccountEntryList
Gets the [!:GetAccountResponseType.AccountEntries.AccountEntry] of type AccountEntryList.
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntryTypeCollection AccountEntryList { get; }
Public ReadOnly Property AccountEntryList As AccountEntryTypeCollection
    Get
public:
property AccountEntryTypeCollection^ AccountEntryList {
    AccountEntryTypeCollection^ get ();
}


AccountEntrySortType Property

AccountEntrySortType Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► AccountEntrySortType
Gets or sets the AccountEntrySortType of type AccountEntrySortTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntrySortTypeCodeType AccountEntrySortType { get; set; }
Public Property AccountEntrySortType As AccountEntrySortTypeCodeType
    Get
    Set
public:
property AccountEntrySortTypeCodeType AccountEntrySortType {
    AccountEntrySortTypeCodeType get ();
    void set (AccountEntrySortTypeCodeType value);
}


AccountHistorySelection Property

AccountHistorySelection Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► AccountHistorySelection
Gets or sets the AccountHistorySelection of type AccountHistorySelectionCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public AccountHistorySelectionCodeType AccountHistorySelection { get; set; }
Public Property AccountHistorySelection As AccountHistorySelectionCodeType
    Get
    Set
public:
property AccountHistorySelectionCodeType AccountHistorySelection {
    AccountHistorySelectionCodeType get ();
    void set (AccountHistorySelectionCodeType value);
}


AccountID Property

AccountID Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► AccountID
Gets the returned AccountID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string AccountID { get; }
Public ReadOnly Property AccountID As String
    Get
public:
property String^ AccountID {
    String^ get ();
}


AccountSummary Property

AccountSummary Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► AccountSummary
Gets the returned AccountSummary of type AccountSummaryType.
Declaration Syntax
C# Visual Basic Visual C++
public AccountSummaryType AccountSummary { get; }
Public ReadOnly Property AccountSummary As AccountSummaryType
    Get
public:
property AccountSummaryType^ AccountSummary {
    AccountSummaryType^ get ();
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► ApiRequest
Gets or sets the GetAccountRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetAccountRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetAccountRequestType
    Get
    Set
public:
property GetAccountRequestType^ ApiRequest {
    GetAccountRequestType^ get ();
    void set (GetAccountRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► ApiResponse
Gets the GetAccountResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetAccountResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetAccountResponseType
    Get
public:
property GetAccountResponseType^ ApiResponse {
    GetAccountResponseType^ get ();
}


BeginDate Property

BeginDate Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► BeginDate
Gets or sets the BeginDate of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime BeginDate { get; set; }
Public Property BeginDate As DateTime
    Get
    Set
public:
property DateTime BeginDate {
    DateTime get ();
    void set (DateTime value);
}


Currency Property

Currency Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► Currency
Gets or sets the Currency of type CurrencyCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType Currency { get; set; }
Public Property Currency As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType Currency {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


EndDate Property

EndDate Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► EndDate
Gets or sets the EndDate of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndDate { get; set; }
Public Property EndDate As DateTime
    Get
    Set
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}


EntriesPerPage Property

EntriesPerPage Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► EntriesPerPage
Gets the returned EntriesPerPage of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int EntriesPerPage { get; }
Public ReadOnly Property EntriesPerPage As Integer
    Get
public:
property int EntriesPerPage {
    int get ();
}


ExcludeBalance Property

ExcludeBalance Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► ExcludeBalance
Gets or sets the ExcludeBalance of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ExcludeBalance { get; set; }
Public Property ExcludeBalance As Boolean
    Get
    Set
public:
property bool ExcludeBalance {
    bool get ();
    void set (bool value);
}


ExcludeSummary Property

ExcludeSummary Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► ExcludeSummary
Gets or sets the ExcludeSummary of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ExcludeSummary { get; set; }
Public Property ExcludeSummary As Boolean
    Get
    Set
public:
property bool ExcludeSummary {
    bool get ();
    void set (bool value);
}


GetAccount Method

GetAccount Method
Namespaces ► eBay.Service.Call ► GetAccountCall ► GetAccount()()()()
Members
Icon | Member | Description
 | GetAccount(AccountHistorySelectionCodeType, DateTime, DateTime, DateTime, PaginationType, Boolean, Boolean, Boolean, AccountEntrySortTypeCodeType, CurrencyCodeType, String) | Returns a seller's invoice data for their eBay account, including the account's summary data.
 | GetAccount(AccountHistorySelectionCodeType) | For backward compatibility with old wrappers.


GetAccount Method (AccountHistorySelection)

GetAccount Method (AccountHistorySelection)
Namespaces ► eBay.Service.Call ► GetAccountCall ► GetAccount(AccountHistorySelectionCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntryTypeCollection GetAccount(
    AccountHistorySelectionCodeType AccountHistorySelection
)
Public Function GetAccount ( _
    AccountHistorySelection As AccountHistorySelectionCodeType _
) As AccountEntryTypeCollection
public:
AccountEntryTypeCollection^ GetAccount(
    AccountHistorySelectionCodeType AccountHistorySelection
)
Parameters
AccountHistorySelection (AccountHistorySelectionCodeType)


GetAccount Method (AccountHistorySelection, InvoiceDate, BeginDate, EndDate, Pagination, ExcludeBalance, ExcludeSummary, IncludeConversionRate, AccountEntrySortType, Currency, ItemID)

GetAccount Method (AccountHistorySelection, InvoiceDate, BeginDate, EndDate, Pagination, ExcludeBalance, ExcludeSummary, IncludeConversionRate, AccountEntrySortType, Currency, ItemID)
Namespaces ► eBay.Service.Call ► GetAccountCall ► GetAccount(AccountHistorySelectionCodeType, DateTime, DateTime, DateTime, PaginationType, Boolean, Boolean, Boolean, AccountEntrySortTypeCodeType, CurrencyCodeType, String)
Returns a seller's invoice data for their eBay account, including the account's summary data.
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntryTypeCollection GetAccount(
    AccountHistorySelectionCodeType AccountHistorySelection,
    DateTime InvoiceDate,
    DateTime BeginDate,
    DateTime EndDate,
    PaginationType Pagination,
    bool ExcludeBalance,
    bool ExcludeSummary,
    bool IncludeConversionRate,
    AccountEntrySortTypeCodeType AccountEntrySortType,
    CurrencyCodeType Currency,
    string ItemID
)
Public Function GetAccount ( _
    AccountHistorySelection As AccountHistorySelectionCodeType, _
    InvoiceDate As DateTime, _
    BeginDate As DateTime, _
    EndDate As DateTime, _
    Pagination As PaginationType, _
    ExcludeBalance As Boolean, _
    ExcludeSummary As Boolean, _
    IncludeConversionRate As Boolean, _
    AccountEntrySortType As AccountEntrySortTypeCodeType, _
    Currency As CurrencyCodeType, _
    ItemID As String _
) As AccountEntryTypeCollection
public:
AccountEntryTypeCollection^ GetAccount(
    AccountHistorySelectionCodeType AccountHistorySelection,
    DateTime InvoiceDate,
    DateTime BeginDate,
    DateTime EndDate,
    PaginationType^ Pagination,
    bool ExcludeBalance,
    bool ExcludeSummary,
    bool IncludeConversionRate,
    AccountEntrySortTypeCodeType AccountEntrySortType,
    CurrencyCodeType Currency,
    String^ ItemID
)
Parameters
AccountHistorySelection (AccountHistorySelectionCodeType)
This field is used by the user to control which account entries are returned. The user has options to retrieve all new account entries (since last invoice), all account entries between two specified dates, or all account entries from a specified invoice. If this field is not include
InvoiceDate (DateTime)
This field is used to retrieve all account entries from a specific invoice, which is identified through this InvoiceDate field with the timestamp of the account invoice. This field is only applicable if the AccountHistorySelection value is set to 'SpecifiedInvoice'; otherwise, this field will be ignored.
BeginDate (DateTime)
This field is used to retrieve all account entries dating back to the timestamp passed into this BeginDate field up until the timestamp passed into the EndDate field. The BeginDate value can not be set back any further than four months into the past.

The allowed date formats are YYYY-MM-DD and YYYY-MM-DD HH:mm:ss The BeginDate value must be less than or equal to the EndDate value. The user might use the same values in both fields if that user wanted to retrieve all account entries from a specific day (if YYYY-MM-DD format used) or wanted to retrieve a specific account entry (if YYYY-MM-DD HH:mm:ss format used).

This field is only applicable if the AccountHistorySelection value is set to 'BetweenSpecifiedDates'; otherwise, this field will be ignored. fiedDates' is used, both the BeginDate and EndDate must be included.
EndDate (DateTime)
This field is used to retrieve all account entries dating up to the timestamp passed into this EndDate field dating back to the timestamp passed into the BeginDate field. The EndDate value can not be set for a future date.

The allowed date formats are YYYY-MM-DD and YYYY-MM-DD HH:mm:ss The EndDate value must be more than or equal to the BeginDate value. The user might use the same values in both fields if that user wanted to retrieve all account entries from a specific day (if YYYY-MM-DD format used) or wanted to retrieve a specific account entry (if YYYY-MM-DD HH:mm:ss format used).

This field is only applicable if the AccountHistorySelection value is set to 'BetweenSpecifiedDates'; otherwise, this field will be ignored. If 'BetweenSpecifiedDates' is used, both the BeginDate and EndDate must be included.
Pagination (PaginationType)
This container is used to control how many account entries are returned on each page of data in the response. PaginationType is used by numerous Trading API calls, and the default and maximum values for the EntriesPerPage field differs with each call. For the GetAccount call, the default value is 500 (account entries) per page, and maximum allowed value is 2000 (account entries) per page.
ExcludeBalance (Boolean)
By default, the current balance of the user's account will not be returned in the call response. To retrieve the current balance of their account, the user should include the ExcludeBalance flag in the request and set its value to 'false'. The current balance on the account will be shown in the AccountSummary.CurrentBalance field in the call response.
ExcludeSummary (Boolean)
Specifies whether to return account summary information in an AccountSummary node. Default is true, to return AccountSummary.
IncludeConversionRate (Boolean)
Specifies whether to retrieve the rate used for the currency conversion for usage transactions.
AccountEntrySortType (AccountEntrySortTypeCodeType)
Specifies how account entries should be sorted in the response, by an element and then in ascending or descending order.
Currency (CurrencyCodeType)
Specifies the currency used in the account report. Do not specify Currency in the request unless the following conditions are met. First, the user has or had multiple accounts under the same UserID. Second, the account identified in the request uses the currency you specify in the request. An error is returned if no account is found that uses the currency you specify in the request.
ItemID (String)
Specifies the item ID for which to return account entries. If ItemID is used, all other filters in the request are ignored. If the specified item does not exist or if the requesting user is not the seller of the item, an error is returned.


GetAccountCall Constructor

GetAccountCall Constructor
Namespaces ► eBay.Service.Call ► GetAccountCall ► GetAccountCall()()()()
Members
Icon | Member | Description
 | GetAccountCall()()()() |
 | GetAccountCall(ApiContext) |


GetAccountCall Constructor

GetAccountCall Constructor
Namespaces ► eBay.Service.Call ► GetAccountCall ► GetAccountCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetAccountCall()
Public Sub New
public:
GetAccountCall()


GetAccountCall Constructor (ApiContext)

GetAccountCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetAccountCall ► GetAccountCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetAccountCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetAccountCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HasMoreEntries Property

HasMoreEntries Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► HasMoreEntries
Gets the returned HasMoreEntries of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreEntries { get; }
Public ReadOnly Property HasMoreEntries As Boolean
    Get
public:
property bool HasMoreEntries {
    bool get ();
}


IncludeConversionRate Property

IncludeConversionRate Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► IncludeConversionRate
Gets or sets the IncludeConversionRate of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeConversionRate { get; set; }
Public Property IncludeConversionRate As Boolean
    Get
    Set
public:
property bool IncludeConversionRate {
    bool get ();
    void set (bool value);
}


InvoiceDate Property

InvoiceDate Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► InvoiceDate
Gets or sets the InvoiceDate of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime InvoiceDate { get; set; }
Public Property InvoiceDate As DateTime
    Get
    Set
public:
property DateTime InvoiceDate {
    DateTime get ();
    void set (DateTime value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► PageNumber
Gets the returned PageNumber of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
public:
property int PageNumber {
    int get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


StartTimeFilter Property

StartTimeFilter Property
Namespaces ► eBay.Service.Call ► GetAccountCall ► StartTimeFilter
Gets or sets the BeginDate and EndDate of type TimeFilter.
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter StartTimeFilter { get; set; }
Public Property StartTimeFilter As TimeFilter
    Get
    Set
public:
property TimeFilter^ StartTimeFilter {
    TimeFilter^ get ();
    void set (TimeFilter^ value);
}


GetAdFormatLeadsCall Class

GetAdFormatLeadsCall Class
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetAdFormatLeadsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetAdFormatLeadsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetAdFormatLeadsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetAdFormatLeadsCall()()()() |
 | GetAdFormatLeadsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AdFormatLeadCount | Gets the returned AdFormatLeadCount of type Int32.
 | AdFormatLeadList | Gets the returned AdFormatLead of type AdFormatLeadTypeCollection.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetAdFormatLeadsRequestType for this API call.
 | ApiResponse | Gets the GetAdFormatLeadsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndCreationTime | Gets or sets the EndCreationTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAdFormatLeads(String, MessageStatusTypeCodeType, Boolean, DateTime, DateTime) | Retrieves sales lead information for a lead generation listing.
 | GetAdFormatLeads(String) | Retrieve sales lead information for a real estate advertisement listing. GetAdFormatLeadsRequest returns the number of leads for an ad and any contact information that the prospective buyer submitted.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeMemberMessages | Gets or sets the IncludeMemberMessages of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartCreationTime | Gets or sets the StartCreationTime of type DateTime.
 | Status | Gets or sets the Status of type MessageStatusTypeCodeType.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetAdFormatLeadsCall


AdFormatLeadCount Property

AdFormatLeadCount Property
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► AdFormatLeadCount
Gets the returned AdFormatLeadCount of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int AdFormatLeadCount { get; }
Public ReadOnly Property AdFormatLeadCount As Integer
    Get
public:
property int AdFormatLeadCount {
    int get ();
}


AdFormatLeadList Property

AdFormatLeadList Property
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► AdFormatLeadList
Gets the returned AdFormatLead of type AdFormatLeadTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadTypeCollection AdFormatLeadList { get; }
Public ReadOnly Property AdFormatLeadList As AdFormatLeadTypeCollection
    Get
public:
property AdFormatLeadTypeCollection^ AdFormatLeadList {
    AdFormatLeadTypeCollection^ get ();
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► ApiRequest
Gets or sets the GetAdFormatLeadsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetAdFormatLeadsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetAdFormatLeadsRequestType
    Get
    Set
public:
property GetAdFormatLeadsRequestType^ ApiRequest {
    GetAdFormatLeadsRequestType^ get ();
    void set (GetAdFormatLeadsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► ApiResponse
Gets the GetAdFormatLeadsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetAdFormatLeadsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetAdFormatLeadsResponseType
    Get
public:
property GetAdFormatLeadsResponseType^ ApiResponse {
    GetAdFormatLeadsResponseType^ get ();
}


EndCreationTime Property

EndCreationTime Property
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► EndCreationTime
Gets or sets the EndCreationTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndCreationTime { get; set; }
Public Property EndCreationTime As DateTime
    Get
    Set
public:
property DateTime EndCreationTime {
    DateTime get ();
    void set (DateTime value);
}


GetAdFormatLeads Method

GetAdFormatLeads Method
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► GetAdFormatLeads()()()()
Members
Icon | Member | Description
 | GetAdFormatLeads(String, MessageStatusTypeCodeType, Boolean, DateTime, DateTime) | Retrieves sales lead information for a lead generation listing.
 | GetAdFormatLeads(String) | Retrieve sales lead information for a real estate advertisement listing. GetAdFormatLeadsRequest returns the number of leads for an ad and any contact information that the prospective buyer submitted.


GetAdFormatLeads Method (ItemID)

GetAdFormatLeads Method (ItemID)
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► GetAdFormatLeads(String)
Retrieve sales lead information for a real estate advertisement listing. GetAdFormatLeadsRequest returns the number of leads for an ad and any contact information that the prospective buyer submitted.
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadTypeCollection GetAdFormatLeads(
    string ItemID
)
Public Function GetAdFormatLeads ( _
    ItemID As String _
) As AdFormatLeadTypeCollection
public:
AdFormatLeadTypeCollection^ GetAdFormatLeads(
    String^ ItemID
)
Parameters
ItemID (String)
The unique identifier of an item listed on the eBay site. Returned by eBay when the item is created. This ID must correspond to an ad format item.


GetAdFormatLeads Method (ItemID, Status, IncludeMemberMessages, StartCreationTime, EndCreationTime)

GetAdFormatLeads Method (ItemID, Status, IncludeMemberMessages, StartCreationTime, EndCreationTime)
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► GetAdFormatLeads(String, MessageStatusTypeCodeType, Boolean, DateTime, DateTime)
Retrieves sales lead information for a lead generation listing.
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadTypeCollection GetAdFormatLeads(
    string ItemID,
    MessageStatusTypeCodeType Status,
    bool IncludeMemberMessages,
    DateTime StartCreationTime,
    DateTime EndCreationTime
)
Public Function GetAdFormatLeads ( _
    ItemID As String, _
    Status As MessageStatusTypeCodeType, _
    IncludeMemberMessages As Boolean, _
    StartCreationTime As DateTime, _
    EndCreationTime As DateTime _
) As AdFormatLeadTypeCollection
public:
AdFormatLeadTypeCollection^ GetAdFormatLeads(
    String^ ItemID,
    MessageStatusTypeCodeType Status,
    bool IncludeMemberMessages,
    DateTime StartCreationTime,
    DateTime EndCreationTime
)
Parameters
ItemID (String)
The unique identifier of an item listed on the eBay site. Returned by eBay when the item is created. This ID must correspond to an ad format item.
Status (MessageStatusTypeCodeType)
Filters the leads based on their status.
IncludeMemberMessages (Boolean)
Boolean which indicates whether to return mail messages for this lead in a MemberMessage node.
StartCreationTime (DateTime)
Used with EndCreationTime to limit the returned leads for a user to only those with a creation date greater than or equal to the specified date and time.
EndCreationTime (DateTime)
Used with StartCreationTime to limit the returned leads for a user to only those with a creation date less than or equal to the specified date and time.


GetAdFormatLeadsCall Constructor

GetAdFormatLeadsCall Constructor
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► GetAdFormatLeadsCall()()()()
Members
Icon | Member | Description
 | GetAdFormatLeadsCall()()()() |
 | GetAdFormatLeadsCall(ApiContext) |


GetAdFormatLeadsCall Constructor

GetAdFormatLeadsCall Constructor
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► GetAdFormatLeadsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetAdFormatLeadsCall()
Public Sub New
public:
GetAdFormatLeadsCall()


GetAdFormatLeadsCall Constructor (ApiContext)

GetAdFormatLeadsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► GetAdFormatLeadsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetAdFormatLeadsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetAdFormatLeadsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


IncludeMemberMessages Property

IncludeMemberMessages Property
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► IncludeMemberMessages
Gets or sets the IncludeMemberMessages of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeMemberMessages { get; set; }
Public Property IncludeMemberMessages As Boolean
    Get
    Set
public:
property bool IncludeMemberMessages {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


StartCreationTime Property

StartCreationTime Property
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► StartCreationTime
Gets or sets the StartCreationTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartCreationTime { get; set; }
Public Property StartCreationTime As DateTime
    Get
    Set
public:
property DateTime StartCreationTime {
    DateTime get ();
    void set (DateTime value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Call ► GetAdFormatLeadsCall ► Status
Gets or sets the Status of type MessageStatusTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public MessageStatusTypeCodeType Status { get; set; }
Public Property Status As MessageStatusTypeCodeType
    Get
    Set
public:
property MessageStatusTypeCodeType Status {
    MessageStatusTypeCodeType get ();
    void set (MessageStatusTypeCodeType value);
}


GetAllBiddersCall Class

GetAllBiddersCall Class
Namespaces ► eBay.Service.Call ► GetAllBiddersCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetAllBiddersCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetAllBiddersCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetAllBiddersCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetAllBiddersCall()()()() |
 | GetAllBiddersCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetAllBiddersRequestType for this API call.
 | ApiResponse | Gets the GetAllBiddersResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BidList | Gets the returned BidArray of type OfferTypeCollection.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallMode | Gets or sets the CallMode of type GetAllBiddersModeCodeType.
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAllBidders(String, GetAllBiddersModeCodeType, Boolean) | This is the base request type for the GetAllBidders call, which is used to retrieve bidders from an active or recently-ended auction listing.
 | GetAllBidders(String, GetAllBiddersModeCodeType) | For backward compatibility with old wrappers.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | HighBidder | Gets the returned HighBidder of type String.
 | HighestBid | Gets the returned HighestBid of type AmountType.
 | IncludeBiddingSummary | Gets or sets the IncludeBiddingSummary of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | ListingStatus | Gets the returned ListingStatus of type ListingStatusCodeType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetAllBiddersCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► ApiRequest
Gets or sets the GetAllBiddersRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetAllBiddersRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetAllBiddersRequestType
    Get
    Set
public:
property GetAllBiddersRequestType^ ApiRequest {
    GetAllBiddersRequestType^ get ();
    void set (GetAllBiddersRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► ApiResponse
Gets the GetAllBiddersResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetAllBiddersResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetAllBiddersResponseType
    Get
public:
property GetAllBiddersResponseType^ ApiResponse {
    GetAllBiddersResponseType^ get ();
}


BidList Property

BidList Property
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► BidList
Gets the returned BidArray of type OfferTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public OfferTypeCollection BidList { get; }
Public ReadOnly Property BidList As OfferTypeCollection
    Get
public:
property OfferTypeCollection^ BidList {
    OfferTypeCollection^ get ();
}


CallMode Property

CallMode Property
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► CallMode
Gets or sets the CallMode of type GetAllBiddersModeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public GetAllBiddersModeCodeType CallMode { get; set; }
Public Property CallMode As GetAllBiddersModeCodeType
    Get
    Set
public:
property GetAllBiddersModeCodeType CallMode {
    GetAllBiddersModeCodeType get ();
    void set (GetAllBiddersModeCodeType value);
}


GetAllBidders Method

GetAllBidders Method
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► GetAllBidders()()()()
Members
Icon | Member | Description
 | GetAllBidders(String, GetAllBiddersModeCodeType, Boolean) | This is the base request type for the GetAllBidders call, which is used to retrieve bidders from an active or recently-ended auction listing.
 | GetAllBidders(String, GetAllBiddersModeCodeType) | For backward compatibility with old wrappers.


GetAllBidders Method (ItemID, CallMode)

GetAllBidders Method (ItemID, CallMode)
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► GetAllBidders(String, GetAllBiddersModeCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public OfferTypeCollection GetAllBidders(
    string ItemID,
    GetAllBiddersModeCodeType CallMode
)
Public Function GetAllBidders ( _
    ItemID As String, _
    CallMode As GetAllBiddersModeCodeType _
) As OfferTypeCollection
public:
OfferTypeCollection^ GetAllBidders(
    String^ ItemID,
    GetAllBiddersModeCodeType CallMode
)
Parameters
ItemID (String)
CallMode (GetAllBiddersModeCodeType)


GetAllBidders Method (ItemID, CallMode, IncludeBiddingSummary)

GetAllBidders Method (ItemID, CallMode, IncludeBiddingSummary)
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► GetAllBidders(String, GetAllBiddersModeCodeType, Boolean)
This is the base request type for the GetAllBidders call, which is used to retrieve bidders from an active or recently-ended auction listing.
Declaration Syntax
C# Visual Basic Visual C++
public OfferTypeCollection GetAllBidders(
    string ItemID,
    GetAllBiddersModeCodeType CallMode,
    bool IncludeBiddingSummary
)
Public Function GetAllBidders ( _
    ItemID As String, _
    CallMode As GetAllBiddersModeCodeType, _
    IncludeBiddingSummary As Boolean _
) As OfferTypeCollection
public:
OfferTypeCollection^ GetAllBidders(
    String^ ItemID,
    GetAllBiddersModeCodeType CallMode,
    bool IncludeBiddingSummary
)
Parameters
ItemID (String)
This is the unique identifier of the auction listing for which bidders are being retrieved. This auction listing can be active or recently ended. However, to retrieve bidders for an active auction listing, the only CallMode enumeration value that can be used is
ViewAll
.
CallMode (GetAllBiddersModeCodeType)
The enumeration value that is passed into this field will control the set of bidders that will be retrieved in the response. To retrieve bidders from a recently-ended auction listing, any of the three values can be used. To retrieve bidders for an active auction listing, only the
ViewAll
enumeration value can be used. These values are discussed in more detail below.
IncludeBiddingSummary (Boolean)
The user must include this field and set its value to
true
if the user wishes to retrieve the BiddingSummary container for each bidder. The BiddingSummary container consists of more detailed bidding information on each bidder.


GetAllBiddersCall Constructor

GetAllBiddersCall Constructor
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► GetAllBiddersCall()()()()
Members
Icon | Member | Description
 | GetAllBiddersCall()()()() |
 | GetAllBiddersCall(ApiContext) |


GetAllBiddersCall Constructor

GetAllBiddersCall Constructor
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► GetAllBiddersCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetAllBiddersCall()
Public Sub New
public:
GetAllBiddersCall()


GetAllBiddersCall Constructor (ApiContext)

GetAllBiddersCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► GetAllBiddersCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetAllBiddersCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetAllBiddersCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HighBidder Property

HighBidder Property
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► HighBidder
Gets the returned HighBidder of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string HighBidder { get; }
Public ReadOnly Property HighBidder As String
    Get
public:
property String^ HighBidder {
    String^ get ();
}


HighestBid Property

HighestBid Property
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► HighestBid
Gets the returned HighestBid of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType HighestBid { get; }
Public ReadOnly Property HighestBid As AmountType
    Get
public:
property AmountType^ HighestBid {
    AmountType^ get ();
}


IncludeBiddingSummary Property

IncludeBiddingSummary Property
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► IncludeBiddingSummary
Gets or sets the IncludeBiddingSummary of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeBiddingSummary { get; set; }
Public Property IncludeBiddingSummary As Boolean
    Get
    Set
public:
property bool IncludeBiddingSummary {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingStatus Property

ListingStatus Property
Namespaces ► eBay.Service.Call ► GetAllBiddersCall ► ListingStatus
Gets the returned ListingStatus of type ListingStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingStatusCodeType ListingStatus { get; }
Public ReadOnly Property ListingStatus As ListingStatusCodeType
    Get
public:
property ListingStatusCodeType ListingStatus {
    ListingStatusCodeType get ();
}


GetApiAccessRulesCall Class

GetApiAccessRulesCall Class
Namespaces ► eBay.Service.Call ► GetApiAccessRulesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetApiAccessRulesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetApiAccessRulesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetApiAccessRulesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetApiAccessRulesCall()()()() |
 | GetApiAccessRulesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiAccessRuleList | Gets the returned ApiAccessRule of type ApiAccessRuleTypeCollection.
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetApiAccessRulesRequestType for this API call.
 | ApiResponse | Gets the GetApiAccessRulesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetApiAccessRules()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetApiAccessRulesCall


ApiAccessRuleList Property

ApiAccessRuleList Property
Namespaces ► eBay.Service.Call ► GetApiAccessRulesCall ► ApiAccessRuleList
Gets the returned ApiAccessRule of type ApiAccessRuleTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccessRuleTypeCollection ApiAccessRuleList { get; }
Public ReadOnly Property ApiAccessRuleList As ApiAccessRuleTypeCollection
    Get
public:
property ApiAccessRuleTypeCollection^ ApiAccessRuleList {
    ApiAccessRuleTypeCollection^ get ();
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetApiAccessRulesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetApiAccessRulesCall ► ApiRequest
Gets or sets the GetApiAccessRulesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetApiAccessRulesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetApiAccessRulesRequestType
    Get
    Set
public:
property GetApiAccessRulesRequestType^ ApiRequest {
    GetApiAccessRulesRequestType^ get ();
    void set (GetApiAccessRulesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetApiAccessRulesCall ► ApiResponse
Gets the GetApiAccessRulesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetApiAccessRulesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetApiAccessRulesResponseType
    Get
public:
property GetApiAccessRulesResponseType^ ApiResponse {
    GetApiAccessRulesResponseType^ get ();
}


GetApiAccessRules Method

GetApiAccessRules Method
Namespaces ► eBay.Service.Call ► GetApiAccessRulesCall ► GetApiAccessRules()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccessRuleTypeCollection GetApiAccessRules()
Public Function GetApiAccessRules As ApiAccessRuleTypeCollection
public:
ApiAccessRuleTypeCollection^ GetApiAccessRules()


GetApiAccessRulesCall Constructor

GetApiAccessRulesCall Constructor
Namespaces ► eBay.Service.Call ► GetApiAccessRulesCall ► GetApiAccessRulesCall()()()()
Members
Icon | Member | Description
 | GetApiAccessRulesCall()()()() |
 | GetApiAccessRulesCall(ApiContext) |


GetApiAccessRulesCall Constructor

GetApiAccessRulesCall Constructor
Namespaces ► eBay.Service.Call ► GetApiAccessRulesCall ► GetApiAccessRulesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetApiAccessRulesCall()
Public Sub New
public:
GetApiAccessRulesCall()


GetApiAccessRulesCall Constructor (ApiContext)

GetApiAccessRulesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetApiAccessRulesCall ► GetApiAccessRulesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetApiAccessRulesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetApiAccessRulesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


GetBestOffersCall Class

GetBestOffersCall Class
Namespaces ► eBay.Service.Call ► GetBestOffersCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetBestOffersCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetBestOffersCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetBestOffersCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetBestOffersCall()()()() |
 | GetBestOffersCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetBestOffersRequestType for this API call.
 | ApiResponse | Gets the GetBestOffersResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BestOfferID | Gets or sets the BestOfferID of type String.
 | BestOfferList | Gets the returned BestOfferArray of type BestOfferTypeCollection.
 | BestOfferStatus | Gets or sets the BestOfferStatus of type BestOfferStatusCodeType.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBestOffers(String, String, BestOfferStatusCodeType, PaginationType) | This is the base request type of the GetBestOffers call. Depending on the input parameters that are used, this call can be used by a seller to retrieve all active Best Offers, all Best Offers on a specific listing, a specific Best Offer for a specific listing, or Best Offers in a specific state.
 | GetBestOffers(String) | For backward compatibility with old wrappers.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets the returned Item of type ItemType.
 | ItemBestOffersArray | Gets the returned ItemBestOffersArray of type ItemBestOffersArrayType.
 | ItemBestOffersList | Gets the returned ItemBestOffersArray of type ItemBestOffersTypeCollection.
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PageNumber | Gets the returned PageNumber of type Int32.
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetBestOffersCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► ApiRequest
Gets or sets the GetBestOffersRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetBestOffersRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetBestOffersRequestType
    Get
    Set
public:
property GetBestOffersRequestType^ ApiRequest {
    GetBestOffersRequestType^ get ();
    void set (GetBestOffersRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► ApiResponse
Gets the GetBestOffersResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetBestOffersResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetBestOffersResponseType
    Get
public:
property GetBestOffersResponseType^ ApiResponse {
    GetBestOffersResponseType^ get ();
}


BestOfferID Property

BestOfferID Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► BestOfferID
Gets or sets the BestOfferID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string BestOfferID { get; set; }
Public Property BestOfferID As String
    Get
    Set
public:
property String^ BestOfferID {
    String^ get ();
    void set (String^ value);
}


BestOfferList Property

BestOfferList Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► BestOfferList
Gets the returned BestOfferArray of type BestOfferTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection BestOfferList { get; }
Public ReadOnly Property BestOfferList As BestOfferTypeCollection
    Get
public:
property BestOfferTypeCollection^ BestOfferList {
    BestOfferTypeCollection^ get ();
}


BestOfferStatus Property

BestOfferStatus Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► BestOfferStatus
Gets or sets the BestOfferStatus of type BestOfferStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferStatusCodeType BestOfferStatus { get; set; }
Public Property BestOfferStatus As BestOfferStatusCodeType
    Get
    Set
public:
property BestOfferStatusCodeType BestOfferStatus {
    BestOfferStatusCodeType get ();
    void set (BestOfferStatusCodeType value);
}


GetBestOffers Method

GetBestOffers Method
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► GetBestOffers()()()()
Members
Icon | Member | Description
 | GetBestOffers(String, String, BestOfferStatusCodeType, PaginationType) | This is the base request type of the GetBestOffers call. Depending on the input parameters that are used, this call can be used by a seller to retrieve all active Best Offers, all Best Offers on a specific listing, a specific Best Offer for a specific listing, or Best Offers in a specific state.
 | GetBestOffers(String) | For backward compatibility with old wrappers.


GetBestOffers Method (ItemID)

GetBestOffers Method (ItemID)
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► GetBestOffers(String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection GetBestOffers(
    string ItemID
)
Public Function GetBestOffers ( _
    ItemID As String _
) As BestOfferTypeCollection
public:
BestOfferTypeCollection^ GetBestOffers(
    String^ ItemID
)
Parameters
ItemID (String)


GetBestOffers Method (ItemID, BestOfferID, BestOfferStatus, Pagination)

GetBestOffers Method (ItemID, BestOfferID, BestOfferStatus, Pagination)
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► GetBestOffers(String, String, BestOfferStatusCodeType, PaginationType)
This is the base request type of the GetBestOffers call. Depending on the input parameters that are used, this call can be used by a seller to retrieve all active Best Offers, all Best Offers on a specific listing, a specific Best Offer for a specific listing, or Best Offers in a specific state.
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection GetBestOffers(
    string ItemID,
    string BestOfferID,
    BestOfferStatusCodeType BestOfferStatus,
    PaginationType Pagination
)
Public Function GetBestOffers ( _
    ItemID As String, _
    BestOfferID As String, _
    BestOfferStatus As BestOfferStatusCodeType, _
    Pagination As PaginationType _
) As BestOfferTypeCollection
public:
BestOfferTypeCollection^ GetBestOffers(
    String^ ItemID,
    String^ BestOfferID,
    BestOfferStatusCodeType BestOfferStatus,
    PaginationType^ Pagination
)
Parameters
ItemID (String)
The unique identifier of a fixed-price or classified ad listing. If an ItemID is used by itself in the call request, all Best Offers in all states are retrieved for this listing. However, the seller can also combine ItemID and a BestOfferStatus value if that seller only wants to see Best Offers in a specific state. If a BestOfferID field is included in the call request, any ItemID value will be ignored since eBay will only search for and return the Best Offer identified in the BestOfferID field.
BestOfferID (String)
The unique identifier of a Best Offer. An identifier for a Best Offer is automatically created by eBay once a prospective buyer makes a Best Offer on a Best Offer-enabled listing. If a BestOfferID value is supplied in the call request, any ItemID or BestOfferStatus values will be ignored. Only the Best Offer identified by the BestOfferID value will be returned.
BestOfferStatus (BestOfferStatusCodeType)
This field can be used if the seller wants to retrieve Best Offers in a specific state. The typical use case for this field is when the seller wants to retrieve Best Offers in all states for a specific listing. In fact, the All value can only be used if an ItemID value is also supplied in the call request. If a BestOfferID field is included in the call request, any BestOfferStatus value will be ignored since eBay will only search for and return the Best Offer identified in the BestOfferID field.
Pagination (PaginationType)
This container can be used if the seller is expecting that the GetBestOffers call will retrieve a large number of results, so that seller wishes to view just a subset (one page of multiple pages) of those results at a time. See this container's child fields for more information on how pagination is used.


GetBestOffersCall Constructor

GetBestOffersCall Constructor
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► GetBestOffersCall()()()()
Members
Icon | Member | Description
 | GetBestOffersCall()()()() |
 | GetBestOffersCall(ApiContext) |


GetBestOffersCall Constructor

GetBestOffersCall Constructor
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► GetBestOffersCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetBestOffersCall()
Public Sub New
public:
GetBestOffersCall()


GetBestOffersCall Constructor (ApiContext)

GetBestOffersCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► GetBestOffersCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetBestOffersCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetBestOffersCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


Item Property

Item Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► Item
Gets the returned Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; }
Public ReadOnly Property Item As ItemType
    Get
public:
property ItemType^ Item {
    ItemType^ get ();
}


ItemBestOffersArray Property

ItemBestOffersArray Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► ItemBestOffersArray
Gets the returned ItemBestOffersArray of type ItemBestOffersArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersArrayType ItemBestOffersArray { get; }
Public ReadOnly Property ItemBestOffersArray As ItemBestOffersArrayType
    Get
public:
property ItemBestOffersArrayType^ ItemBestOffersArray {
    ItemBestOffersArrayType^ get ();
}


ItemBestOffersList Property

ItemBestOffersList Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► ItemBestOffersList
Gets the returned ItemBestOffersArray of type ItemBestOffersTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersTypeCollection ItemBestOffersList { get; }
Public ReadOnly Property ItemBestOffersList As ItemBestOffersTypeCollection
    Get
public:
property ItemBestOffersTypeCollection^ ItemBestOffersList {
    ItemBestOffersTypeCollection^ get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► PageNumber
Gets the returned PageNumber of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
public:
property int PageNumber {
    int get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetBestOffersCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


GetBidderListCall Class

GetBidderListCall Class
Namespaces ► eBay.Service.Call ► GetBidderListCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetBidderListCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetBidderListCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetBidderListCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetBidderListCall()()()() |
 | GetBidderListCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | ActiveItemsOnly | Gets or sets the ActiveItemsOnly of type Boolean.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetBidderListRequestType for this API call.
 | ApiResponse | Gets the GetBidderListResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | Bidder | Gets the returned Bidder of type UserType.
 | BidItemList | Gets the returned BidItemArray of type ItemTypeCollection.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTimeFrom | Gets or sets the EndTimeFrom of type DateTime.
 | EndTimeTo | Gets or sets the EndTimeTo of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBidderList(Boolean, DateTime, DateTime, String, GranularityLevelCodeType) | Retrieves all items the user is currently bidding on, and the ones they have won or purchased.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | GranularityLevel | Gets or sets the GranularityLevel of type GranularityLevelCodeType.
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UserID | Gets or sets the UserID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetBidderListCall


ActiveItemsOnly Property

ActiveItemsOnly Property
Namespaces ► eBay.Service.Call ► GetBidderListCall ► ActiveItemsOnly
Gets or sets the ActiveItemsOnly of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ActiveItemsOnly { get; set; }
Public Property ActiveItemsOnly As Boolean
    Get
    Set
public:
property bool ActiveItemsOnly {
    bool get ();
    void set (bool value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetBidderListCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetBidderListCall ► ApiRequest
Gets or sets the GetBidderListRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetBidderListRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetBidderListRequestType
    Get
    Set
public:
property GetBidderListRequestType^ ApiRequest {
    GetBidderListRequestType^ get ();
    void set (GetBidderListRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetBidderListCall ► ApiResponse
Gets the GetBidderListResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetBidderListResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetBidderListResponseType
    Get
public:
property GetBidderListResponseType^ ApiResponse {
    GetBidderListResponseType^ get ();
}


Bidder Property

Bidder Property
Namespaces ► eBay.Service.Call ► GetBidderListCall ► Bidder
Gets the returned Bidder of type UserType.
Declaration Syntax
C# Visual Basic Visual C++
public UserType Bidder { get; }
Public ReadOnly Property Bidder As UserType
    Get
public:
property UserType^ Bidder {
    UserType^ get ();
}


BidItemList Property

BidItemList Property
Namespaces ► eBay.Service.Call ► GetBidderListCall ► BidItemList
Gets the returned BidItemArray of type ItemTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection BidItemList { get; }
Public ReadOnly Property BidItemList As ItemTypeCollection
    Get
public:
property ItemTypeCollection^ BidItemList {
    ItemTypeCollection^ get ();
}


EndTimeFrom Property

EndTimeFrom Property
Namespaces ► eBay.Service.Call ► GetBidderListCall ► EndTimeFrom
Gets or sets the EndTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeFrom { get; set; }
Public Property EndTimeFrom As DateTime
    Get
    Set
public:
property DateTime EndTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


EndTimeTo Property

EndTimeTo Property
Namespaces ► eBay.Service.Call ► GetBidderListCall ► EndTimeTo
Gets or sets the EndTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeTo { get; set; }
Public Property EndTimeTo As DateTime
    Get
    Set
public:
property DateTime EndTimeTo {
    DateTime get ();
    void set (DateTime value);
}


GetBidderList Method (ActiveItemsOnly, EndTimeFrom, EndTimeTo, UserID, GranularityLevel)

GetBidderList Method (ActiveItemsOnly, EndTimeFrom, EndTimeTo, UserID, GranularityLevel)
Namespaces ► eBay.Service.Call ► GetBidderListCall ► GetBidderList(Boolean, DateTime, DateTime, String, GranularityLevelCodeType)
Retrieves all items the user is currently bidding on, and the ones they have won or purchased.
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection GetBidderList(
    bool ActiveItemsOnly,
    DateTime EndTimeFrom,
    DateTime EndTimeTo,
    string UserID,
    GranularityLevelCodeType GranularityLevel
)
Public Function GetBidderList ( _
    ActiveItemsOnly As Boolean, _
    EndTimeFrom As DateTime, _
    EndTimeTo As DateTime, _
    UserID As String, _
    GranularityLevel As GranularityLevelCodeType _
) As ItemTypeCollection
public:
ItemTypeCollection^ GetBidderList(
    bool ActiveItemsOnly,
    DateTime EndTimeFrom,
    DateTime EndTimeTo,
    String^ UserID,
    GranularityLevelCodeType GranularityLevel
)
Parameters
ActiveItemsOnly (Boolean)
Indicates whether or not to limit the result set to active items. If true, only active items are returned and the EndTimeFrom and EndTimeTo filters are ignored. If false (or not sent), both active and ended items are returned.
EndTimeFrom (DateTime)
Used in conjunction with EndTimeTo. Limits returned items to only those for which the item's end date is on or after the date-time specified. Specify an end date within 30 days prior to today. Items that ended more than 30 days ago are omitted from the results. If specified, EndTimeTo must also be specified. Express date-time in the format YYYY-MM-DD HH:MM:SS, and in GMT. (For information on how to convert between your local time zone and GMT, see Time Values Note.) This field is ignored if ActiveItemsOnly is true.
EndTimeTo (DateTime)
Used in conjunction with EndTimeFrom. Limits returned items to only those for which the item's end date is on or before the date-time specified. If specified, EndTimeFrom must also be specified. Express date-time in the format YYYY-MM-DD HH:MM:SS, and in GMT. This field is ignored if ActiveItemsOnly is true. Note that for GTC items, whose end times automatically increment by 30 days every 30 days, an EndTimeTo within in the first 30 days of a listing will refer to the listing's initial end time.
UserID (String)
The user for whom information should be returned. If provided, overrides user defined via RequesterCredentials in header.
GranularityLevel (GranularityLevelCodeType)
You can control some of the fields returned in the response by specifying one of two values in the GranularityLevel field: Fine or Medium. Fine returns more fields than the default, while setting this field to Medium returns an abbreviated set of results.


GetBidderListCall Constructor

GetBidderListCall Constructor
Namespaces ► eBay.Service.Call ► GetBidderListCall ► GetBidderListCall()()()()
Members
Icon | Member | Description
 | GetBidderListCall()()()() |
 | GetBidderListCall(ApiContext) |


GetBidderListCall Constructor

GetBidderListCall Constructor
Namespaces ► eBay.Service.Call ► GetBidderListCall ► GetBidderListCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetBidderListCall()
Public Sub New
public:
GetBidderListCall()


GetBidderListCall Constructor (ApiContext)

GetBidderListCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetBidderListCall ► GetBidderListCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetBidderListCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetBidderListCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


GranularityLevel Property

GranularityLevel Property
Namespaces ► eBay.Service.Call ► GetBidderListCall ► GranularityLevel
Gets or sets the GranularityLevel of type GranularityLevelCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public GranularityLevelCodeType GranularityLevel { get; set; }
Public Property GranularityLevel As GranularityLevelCodeType
    Get
    Set
public:
property GranularityLevelCodeType GranularityLevel {
    GranularityLevelCodeType get ();
    void set (GranularityLevelCodeType value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Call ► GetBidderListCall ► UserID
Gets or sets the UserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetCategoriesCall Class

GetCategoriesCall Class
Namespaces ► eBay.Service.Call ► GetCategoriesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetCategoriesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetCategoriesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetCategoriesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategoriesCall()()()() |
 | GetCategoriesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetCategoriesRequestType for this API call.
 | ApiResponse | Gets the GetCategoriesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CategoryCount | Gets the returned CategoryCount of type Int32.
 | CategoryList | Gets the returned CategoryArray of type CategoryTypeCollection.
 | CategoryParent | Gets or sets the CategoryParent of type StringCollection.
 | CategorySiteID | Gets or sets the CategorySiteID of type String.
 | CategoryVersionResponse | Gets the returned CategoryVersion of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetCategories(String, StringCollection, Int32, Boolean) | Retrieves the latest eBay category hierarchy for a given eBay site. Information returned for each category includes the category name and the unique ID for the category (unique within the eBay site for which categories are retrieved). A category ID is a required input when you list most items.
 | GetCategories()()()() | For backward compatibility with old wrappers.
 | GetCategoriesVersion()()()() | Call GetCategoriesVersion to retrieve the Category version for a site.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LevelLimit | Gets or sets the LevelLimit of type Int32.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumReservePrice | Gets the returned MinimumReservePrice of type Double.
 | OutputSelector | (Inherited from ApiCall.)
 | ReduceReserveAllowed | Gets the returned ReduceReserveAllowed of type Boolean.
 | ReservePriceAllowed | Gets the returned ReservePriceAllowed of type Boolean.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime | Gets the returned UpdateTime of type DateTime.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
 | ViewAllNodes | Gets or sets the ViewAllNodes of type Boolean.
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetCategoriesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► ApiRequest
Gets or sets the GetCategoriesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoriesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetCategoriesRequestType
    Get
    Set
public:
property GetCategoriesRequestType^ ApiRequest {
    GetCategoriesRequestType^ get ();
    void set (GetCategoriesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► ApiResponse
Gets the GetCategoriesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoriesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetCategoriesResponseType
    Get
public:
property GetCategoriesResponseType^ ApiResponse {
    GetCategoriesResponseType^ get ();
}


CategoryCount Property

CategoryCount Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► CategoryCount
Gets the returned CategoryCount of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int CategoryCount { get; }
Public ReadOnly Property CategoryCount As Integer
    Get
public:
property int CategoryCount {
    int get ();
}


CategoryList Property

CategoryList Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► CategoryList
Gets the returned CategoryArray of type CategoryTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryTypeCollection CategoryList { get; }
Public ReadOnly Property CategoryList As CategoryTypeCollection
    Get
public:
property CategoryTypeCollection^ CategoryList {
    CategoryTypeCollection^ get ();
}


CategoryParent Property

CategoryParent Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► CategoryParent
Gets or sets the CategoryParent of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection CategoryParent { get; set; }
Public Property CategoryParent As StringCollection
    Get
    Set
public:
property StringCollection^ CategoryParent {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


CategorySiteID Property

CategorySiteID Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► CategorySiteID
Gets or sets the CategorySiteID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategorySiteID { get; set; }
Public Property CategorySiteID As String
    Get
    Set
public:
property String^ CategorySiteID {
    String^ get ();
    void set (String^ value);
}


CategoryVersionResponse Property

CategoryVersionResponse Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► CategoryVersionResponse
Gets the returned CategoryVersion of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryVersionResponse { get; }
Public ReadOnly Property CategoryVersionResponse As String
    Get
public:
property String^ CategoryVersionResponse {
    String^ get ();
}


GetCategories Method

GetCategories Method
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► GetCategories()()()()
Members
Icon | Member | Description
 | GetCategories(String, StringCollection, Int32, Boolean) | Retrieves the latest eBay category hierarchy for a given eBay site. Information returned for each category includes the category name and the unique ID for the category (unique within the eBay site for which categories are retrieved). A category ID is a required input when you list most items.
 | GetCategories()()()() | For backward compatibility with old wrappers.


GetCategories Method

GetCategories Method
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► GetCategories()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryTypeCollection GetCategories()
Public Function GetCategories As CategoryTypeCollection
public:
CategoryTypeCollection^ GetCategories()


GetCategories Method (CategorySiteID, CategoryParent, LevelLimit, ViewAllNodes)

GetCategories Method (CategorySiteID, CategoryParent, LevelLimit, ViewAllNodes)
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► GetCategories(String, StringCollection, Int32, Boolean)
Retrieves the latest eBay category hierarchy for a given eBay site. Information returned for each category includes the category name and the unique ID for the category (unique within the eBay site for which categories are retrieved). A category ID is a required input when you list most items.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryTypeCollection GetCategories(
    string CategorySiteID,
    StringCollection CategoryParent,
    int LevelLimit,
    bool ViewAllNodes
)
Public Function GetCategories ( _
    CategorySiteID As String, _
    CategoryParent As StringCollection, _
    LevelLimit As Integer, _
    ViewAllNodes As Boolean _
) As CategoryTypeCollection
public:
CategoryTypeCollection^ GetCategories(
    String^ CategorySiteID,
    StringCollection^ CategoryParent,
    int LevelLimit,
    bool ViewAllNodes
)
Parameters
CategorySiteID (String)
This field is used if the user wants to retrieve category data for another eBay site (other than the one specified in the
X-EBAY-API-SITEID
request header). If the user wishes to retrieve category data for the US eBay Motors site, the user must set the Site ID in the
X-EBAY-API-SITEID
request header to
0
, and then set this field's value to
100
.
CategoryParent (StringCollection)
Specifies the ID of the highest-level category to return, along with its subcategories. If no parent category is specified, all categories are returned for the specified site. (Please do not pass a value of 0; zero (0) is an invalid value for CategoryParent.) To determine available category IDs, call GetCategories with no filters and use a DetailLevel value of ReturnAll. If you specify multiple parent categories, the hierarchy for each one is returned.
LevelLimit (Int32)
Specifies the maximum depth of the category hierarchy to retrieve, where the top-level categories (meta-categories) are at level 1. Retrieves all category nodes with a category level less than or equal to this value. If not specified, retrieves categories at all applicable levels. As with all calls, the actual data returned will vary depending on how you configure other fields in the request (including DetailLevel).
ViewAllNodes (Boolean)
This flag controls whether all eBay categories (that satisfy input filters) are returned, or only leaf categories (you can only list items in leaf categories) are returned. The default value is 'true', so if this field is omitted, all eBay categories will be returned. If you only want to retrieve leaf categories, include this flag and set it to 'false'. The actual data returned will vary depending on how you configure other fields in the request.


GetCategoriesCall Constructor

GetCategoriesCall Constructor
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► GetCategoriesCall()()()()
Members
Icon | Member | Description
 | GetCategoriesCall()()()() |
 | GetCategoriesCall(ApiContext) |


GetCategoriesCall Constructor

GetCategoriesCall Constructor
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► GetCategoriesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoriesCall()
Public Sub New
public:
GetCategoriesCall()


GetCategoriesCall Constructor (ApiContext)

GetCategoriesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► GetCategoriesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoriesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetCategoriesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


GetCategoriesVersion Method

GetCategoriesVersion Method
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► GetCategoriesVersion()()()()
Call GetCategoriesVersion to retrieve the Category version for a site.
Declaration Syntax
C# Visual Basic Visual C++
public string GetCategoriesVersion()
Public Function GetCategoriesVersion As String
public:
String^ GetCategoriesVersion()
Return Value
The CategoryVersion.


LevelLimit Property

LevelLimit Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► LevelLimit
Gets or sets the LevelLimit of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int LevelLimit { get; set; }
Public Property LevelLimit As Integer
    Get
    Set
public:
property int LevelLimit {
    int get ();
    void set (int value);
}


MinimumReservePrice Property

MinimumReservePrice Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► MinimumReservePrice
Gets the returned MinimumReservePrice of type Double.
Declaration Syntax
C# Visual Basic Visual C++
public double MinimumReservePrice { get; }
Public ReadOnly Property MinimumReservePrice As Double
    Get
public:
property double MinimumReservePrice {
    double get ();
}


ReduceReserveAllowed Property

ReduceReserveAllowed Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► ReduceReserveAllowed
Gets the returned ReduceReserveAllowed of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ReduceReserveAllowed { get; }
Public ReadOnly Property ReduceReserveAllowed As Boolean
    Get
public:
property bool ReduceReserveAllowed {
    bool get ();
}


ReservePriceAllowed Property

ReservePriceAllowed Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► ReservePriceAllowed
Gets the returned ReservePriceAllowed of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ReservePriceAllowed { get; }
Public ReadOnly Property ReservePriceAllowed As Boolean
    Get
public:
property bool ReservePriceAllowed {
    bool get ();
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► UpdateTime
Gets the returned UpdateTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; }
Public ReadOnly Property UpdateTime As DateTime
    Get
public:
property DateTime UpdateTime {
    DateTime get ();
}


ViewAllNodes Property

ViewAllNodes Property
Namespaces ► eBay.Service.Call ► GetCategoriesCall ► ViewAllNodes
Gets or sets the ViewAllNodes of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ViewAllNodes { get; set; }
Public Property ViewAllNodes As Boolean
    Get
    Set
public:
property bool ViewAllNodes {
    bool get ();
    void set (bool value);
}


GetCategoryFeaturesCall Class

GetCategoryFeaturesCall Class
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetCategoryFeaturesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetCategoryFeaturesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetCategoryFeaturesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategoryFeaturesCall()()()() |
 | GetCategoryFeaturesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | AllFeaturesForCategory | Gets or sets the AllFeaturesForCategory of type Boolean.
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetCategoryFeaturesRequestType for this API call.
 | ApiResponse | Gets the GetCategoryFeaturesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CategoryID | Gets or sets the CategoryID of type String.
 | CategoryList | Gets the returned Category of type CategoryFeatureTypeCollection.
 | CategoryVersion | Gets the returned CategoryVersion of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeatureDefinitions | Gets the returned FeatureDefinitions of type FeatureDefinitionsType.
 | FeatureIDList | Gets or sets the FeatureID of type FeatureIDCodeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetCategoryFeatures(String, Int32, Boolean, FeatureIDCodeTypeCollection, Boolean) | Returns information about the features that are applicable to different categories, such as listing durations, shipping term requirements, and Best Offer support.
 | GetCategoryFeatures()()()() | For backward compatibility with old wrappers.
 | GetCategoryFeaturesVersion()()()() | Call GetCategoryFeaturesVersion to retrieve the Category version for a site.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LevelLimit | Gets or sets the LevelLimit of type Int32.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SiteDefaults | Gets the returned SiteDefaults of type SiteDefaultsType.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime | Gets the returned UpdateTime of type DateTime.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
 | ViewAllNodes | Gets or sets the ViewAllNodes of type Boolean.
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetCategoryFeaturesCall


AllFeaturesForCategory Property

AllFeaturesForCategory Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► AllFeaturesForCategory
Gets or sets the AllFeaturesForCategory of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool AllFeaturesForCategory { get; set; }
Public Property AllFeaturesForCategory As Boolean
    Get
    Set
public:
property bool AllFeaturesForCategory {
    bool get ();
    void set (bool value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► ApiRequest
Gets or sets the GetCategoryFeaturesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryFeaturesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetCategoryFeaturesRequestType
    Get
    Set
public:
property GetCategoryFeaturesRequestType^ ApiRequest {
    GetCategoryFeaturesRequestType^ get ();
    void set (GetCategoryFeaturesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► ApiResponse
Gets the GetCategoryFeaturesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryFeaturesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetCategoryFeaturesResponseType
    Get
public:
property GetCategoryFeaturesResponseType^ ApiResponse {
    GetCategoryFeaturesResponseType^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► CategoryID
Gets or sets the CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


CategoryList Property

CategoryList Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► CategoryList
Gets the returned Category of type CategoryFeatureTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureTypeCollection CategoryList { get; }
Public ReadOnly Property CategoryList As CategoryFeatureTypeCollection
    Get
public:
property CategoryFeatureTypeCollection^ CategoryList {
    CategoryFeatureTypeCollection^ get ();
}


CategoryVersion Property

CategoryVersion Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► CategoryVersion
Gets the returned CategoryVersion of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryVersion { get; }
Public ReadOnly Property CategoryVersion As String
    Get
public:
property String^ CategoryVersion {
    String^ get ();
}


FeatureDefinitions Property

FeatureDefinitions Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► FeatureDefinitions
Gets the returned FeatureDefinitions of type FeatureDefinitionsType.
Declaration Syntax
C# Visual Basic Visual C++
public FeatureDefinitionsType FeatureDefinitions { get; }
Public ReadOnly Property FeatureDefinitions As FeatureDefinitionsType
    Get
public:
property FeatureDefinitionsType^ FeatureDefinitions {
    FeatureDefinitionsType^ get ();
}


FeatureIDList Property

FeatureIDList Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► FeatureIDList
Gets or sets the FeatureID of type FeatureIDCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeatureIDCodeTypeCollection FeatureIDList { get; set; }
Public Property FeatureIDList As FeatureIDCodeTypeCollection
    Get
    Set
public:
property FeatureIDCodeTypeCollection^ FeatureIDList {
    FeatureIDCodeTypeCollection^ get ();
    void set (FeatureIDCodeTypeCollection^ value);
}


GetCategoryFeatures Method

GetCategoryFeatures Method
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► GetCategoryFeatures()()()()
Members
Icon | Member | Description
 | GetCategoryFeatures(String, Int32, Boolean, FeatureIDCodeTypeCollection, Boolean) | Returns information about the features that are applicable to different categories, such as listing durations, shipping term requirements, and Best Offer support.
 | GetCategoryFeatures()()()() | For backward compatibility with old wrappers.


GetCategoryFeatures Method

GetCategoryFeatures Method
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► GetCategoryFeatures()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureTypeCollection GetCategoryFeatures()
Public Function GetCategoryFeatures As CategoryFeatureTypeCollection
public:
CategoryFeatureTypeCollection^ GetCategoryFeatures()


GetCategoryFeatures Method (CategoryID, LevelLimit, ViewAllNodes, FeatureIDList, AllFeaturesForCategory)

GetCategoryFeatures Method (CategoryID, LevelLimit, ViewAllNodes, FeatureIDList, AllFeaturesForCategory)
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► GetCategoryFeatures(String, Int32, Boolean, FeatureIDCodeTypeCollection, Boolean)
Returns information about the features that are applicable to different categories, such as listing durations, shipping term requirements, and Best Offer support.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureTypeCollection GetCategoryFeatures(
    string CategoryID,
    int LevelLimit,
    bool ViewAllNodes,
    FeatureIDCodeTypeCollection FeatureIDList,
    bool AllFeaturesForCategory
)
Public Function GetCategoryFeatures ( _
    CategoryID As String, _
    LevelLimit As Integer, _
    ViewAllNodes As Boolean, _
    FeatureIDList As FeatureIDCodeTypeCollection, _
    AllFeaturesForCategory As Boolean _
) As CategoryFeatureTypeCollection
public:
CategoryFeatureTypeCollection^ GetCategoryFeatures(
    String^ CategoryID,
    int LevelLimit,
    bool ViewAllNodes,
    FeatureIDCodeTypeCollection^ FeatureIDList,
    bool AllFeaturesForCategory
)
Parameters
CategoryID (String)
Specifies the category for which you want to retrieve the feature settings. Specify a CategoryID, set DetailLevel to ReturnAll, and set ViewAllNodes to true to return the default site settings, the overrides for the specified category, plus all the child categories that have overrides on the features they inherit. If you also set AllFeaturesForCategory to true, eBay returns the site defaults, plus all the settings for the specified category. Child category information is not returned in this case. If CategoryID is not specified, eBay returns the feature settings for the site. To return details on all categories that have overrides on the properties they inherit, set DetailLevel to ReturnAll, and set ViewAllNodes to true. If you also set AllFeaturesForCategory to true, eBay returns only the site defaults with no child category information.
LevelLimit (Int32)
A level of depth in the category hierarchy. Retrieves all category nodes with a CategoryLevel less than or equal to the LevelLimit value.
ViewAllNodes (Boolean)
You must set DetailLevel to ReturnAll in order to correctly populate the response when you set ViewAllNodes to true. In this case, eBay returns the site defaults along with all the categories that override the feature settings they inherit. Here, each Category container shows only the features that it has overridden from its parent node. If you also specify a CategoryID, eBay returns the details for that category, along with containers for each of its child categories that have feature overrides. Note that if ViewAllNodes is set to false (the default) and DetailLevel is set to ReturnAll, eBay returns only the leaf categories that have features that override the settings they inherit. In this case, the call will not return leaf categories that do not have overrides.
FeatureIDList (FeatureIDCodeTypeCollection)
Use this field if you want to know if specific features are enabled at the site or root category level. Multiple FeatureID elements can be used in the request. If no FeatureID elements are used, the call retrieves data for all features, as applicable to the other request parameters.
AllFeaturesForCategory (Boolean)
Use this switch to view all of the feature settings for a specific category. All feature settings are returned, regardless of the site default settings. This element works in conjunction with CategoryID--refer to the notes for that element for more details. If you also set FeatureID, eBay returns the status of the specified features only, for the specified category.


GetCategoryFeaturesCall Constructor

GetCategoryFeaturesCall Constructor
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► GetCategoryFeaturesCall()()()()
Members
Icon | Member | Description
 | GetCategoryFeaturesCall()()()() |
 | GetCategoryFeaturesCall(ApiContext) |


GetCategoryFeaturesCall Constructor

GetCategoryFeaturesCall Constructor
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► GetCategoryFeaturesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryFeaturesCall()
Public Sub New
public:
GetCategoryFeaturesCall()


GetCategoryFeaturesCall Constructor (ApiContext)

GetCategoryFeaturesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► GetCategoryFeaturesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryFeaturesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetCategoryFeaturesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


GetCategoryFeaturesVersion Method

GetCategoryFeaturesVersion Method
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► GetCategoryFeaturesVersion()()()()
Call GetCategoryFeaturesVersion to retrieve the Category version for a site.
Declaration Syntax
C# Visual Basic Visual C++
public string GetCategoryFeaturesVersion()
Public Function GetCategoryFeaturesVersion As String
public:
String^ GetCategoryFeaturesVersion()
Return Value
The CategoryVersion.


LevelLimit Property

LevelLimit Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► LevelLimit
Gets or sets the LevelLimit of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int LevelLimit { get; set; }
Public Property LevelLimit As Integer
    Get
    Set
public:
property int LevelLimit {
    int get ();
    void set (int value);
}


SiteDefaults Property

SiteDefaults Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► SiteDefaults
Gets the returned SiteDefaults of type SiteDefaultsType.
Declaration Syntax
C# Visual Basic Visual C++
public SiteDefaultsType SiteDefaults { get; }
Public ReadOnly Property SiteDefaults As SiteDefaultsType
    Get
public:
property SiteDefaultsType^ SiteDefaults {
    SiteDefaultsType^ get ();
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► UpdateTime
Gets the returned UpdateTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; }
Public ReadOnly Property UpdateTime As DateTime
    Get
public:
property DateTime UpdateTime {
    DateTime get ();
}


ViewAllNodes Property

ViewAllNodes Property
Namespaces ► eBay.Service.Call ► GetCategoryFeaturesCall ► ViewAllNodes
Gets or sets the ViewAllNodes of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ViewAllNodes { get; set; }
Public Property ViewAllNodes As Boolean
    Get
    Set
public:
property bool ViewAllNodes {
    bool get ();
    void set (bool value);
}


GetCategoryMappingsCall Class

GetCategoryMappingsCall Class
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetCategoryMappingsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetCategoryMappingsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetCategoryMappingsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategoryMappingsCall()()()() |
 | GetCategoryMappingsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetCategoryMappingsRequestType for this API call.
 | ApiResponse | Gets the GetCategoryMappingsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CategoryMappingList | Gets the returned CategoryMapping of type CategoryMappingTypeCollection.
 | CategoryVersion | Gets or sets the CategoryVersion of type String.
 | CategoryVersionResponse |
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetCategoryMappings(String) | Retrieves a map of old category IDs and corresponding active category IDs defined for the site to which the request is sent.
 | GetCategoryMappings()()()() | For backward compatibility with old wrappers.
 | GetCategoryMappingsVersion()()()() | Call GetCategoryMappingsVersion to retrieve the Category Mapping version for a site.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetCategoryMappingsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► ApiRequest
Gets or sets the GetCategoryMappingsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryMappingsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetCategoryMappingsRequestType
    Get
    Set
public:
property GetCategoryMappingsRequestType^ ApiRequest {
    GetCategoryMappingsRequestType^ get ();
    void set (GetCategoryMappingsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► ApiResponse
Gets the GetCategoryMappingsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryMappingsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetCategoryMappingsResponseType
    Get
public:
property GetCategoryMappingsResponseType^ ApiResponse {
    GetCategoryMappingsResponseType^ get ();
}


CategoryMappingList Property

CategoryMappingList Property
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► CategoryMappingList
Gets the returned CategoryMapping of type CategoryMappingTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryMappingTypeCollection CategoryMappingList { get; }
Public ReadOnly Property CategoryMappingList As CategoryMappingTypeCollection
    Get
public:
property CategoryMappingTypeCollection^ CategoryMappingList {
    CategoryMappingTypeCollection^ get ();
}


CategoryVersion Property

CategoryVersion Property
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► CategoryVersion
Gets or sets the CategoryVersion of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryVersion { get; set; }
Public Property CategoryVersion As String
    Get
    Set
public:
property String^ CategoryVersion {
    String^ get ();
    void set (String^ value);
}


CategoryVersionResponse Property

CategoryVersionResponse Property
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► CategoryVersionResponse
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryVersionResponse { get; }
Public ReadOnly Property CategoryVersionResponse As String
    Get
public:
property String^ CategoryVersionResponse {
    String^ get ();
}


GetCategoryMappings Method

GetCategoryMappings Method
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► GetCategoryMappings()()()()
Members
Icon | Member | Description
 | GetCategoryMappings(String) | Retrieves a map of old category IDs and corresponding active category IDs defined for the site to which the request is sent.
 | GetCategoryMappings()()()() | For backward compatibility with old wrappers.


GetCategoryMappings Method

GetCategoryMappings Method
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► GetCategoryMappings()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryMappingTypeCollection GetCategoryMappings()
Public Function GetCategoryMappings As CategoryMappingTypeCollection
public:
CategoryMappingTypeCollection^ GetCategoryMappings()


GetCategoryMappings Method (CategoryVersion)

GetCategoryMappings Method (CategoryVersion)
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► GetCategoryMappings(String)
Retrieves a map of old category IDs and corresponding active category IDs defined for the site to which the request is sent.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryMappingTypeCollection GetCategoryMappings(
    string CategoryVersion
)
Public Function GetCategoryMappings ( _
    CategoryVersion As String _
) As CategoryMappingTypeCollection
public:
CategoryMappingTypeCollection^ GetCategoryMappings(
    String^ CategoryVersion
)
Parameters
CategoryVersion (String)
A version of the category mapping for the site. Filters out data from the call to return only the category mappings for which the data has changed since the specified version. If not specified, all category mappings are returned. Typically, an application passes the version value of the last set of category mappings that the application stored locally. The latest version value is not necessarily greater than the previous value that was returned. Therefore, when comparing versions, only compare whether the value has changed.


GetCategoryMappingsCall Constructor

GetCategoryMappingsCall Constructor
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► GetCategoryMappingsCall()()()()
Members
Icon | Member | Description
 | GetCategoryMappingsCall()()()() |
 | GetCategoryMappingsCall(ApiContext) |


GetCategoryMappingsCall Constructor

GetCategoryMappingsCall Constructor
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► GetCategoryMappingsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryMappingsCall()
Public Sub New
public:
GetCategoryMappingsCall()


GetCategoryMappingsCall Constructor (ApiContext)

GetCategoryMappingsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► GetCategoryMappingsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryMappingsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetCategoryMappingsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


GetCategoryMappingsVersion Method

GetCategoryMappingsVersion Method
Namespaces ► eBay.Service.Call ► GetCategoryMappingsCall ► GetCategoryMappingsVersion()()()()
Call GetCategoryMappingsVersion to retrieve the Category Mapping version for a site.
Declaration Syntax
C# Visual Basic Visual C++
public string GetCategoryMappingsVersion()
Public Function GetCategoryMappingsVersion As String
public:
String^ GetCategoryMappingsVersion()
Return Value
The CategoryVersion.


GetCategorySpecificsCall Class

GetCategorySpecificsCall Class
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetCategorySpecificsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetCategorySpecificsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetCategorySpecificsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategorySpecificsCall()()()() |
 | GetCategorySpecificsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetCategorySpecificsRequestType for this API call.
 | ApiResponse | Gets the GetCategorySpecificsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CategoryIDList | Gets or sets the CategoryID of type StringCollection.
 | CategorySpecificList | Gets or sets the CategorySpecific of type CategoryItemSpecificsTypeCollection.
 | CategorySpecificsFileInfo | Gets or sets the CategorySpecificsFileInfo of type Boolean.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | ExcludeRelationships | Gets or sets the ExcludeRelationships of type Boolean.
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FileReferenceID | Gets the returned FileReferenceID of type String.
 | Finalize()()()() | (Inherited from Object.)
 | GetCategorySpecifics(StringCollection, DateTime, Int32, Int32, String, CategoryItemSpecificsTypeCollection, Boolean, Boolean, Boolean) |
 | GetCategorySpecifics(StringCollection) | For backward compatibility with old wrappers.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeConfidence | Gets or sets the IncludeConfidence of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LastUpdateTime | Gets or sets the LastUpdateTime of type DateTime.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MaxNames | Gets or sets the MaxNames of type Int32.
 | MaxValuesPerName | Gets or sets the MaxValuesPerName of type Int32.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | Gets or sets the Name of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | RecommendationList | Gets the returned Recommendations of type RecommendationsTypeCollection.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | TaskReferenceID | Gets the returned TaskReferenceID of type String.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetCategorySpecificsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► ApiRequest
Gets or sets the GetCategorySpecificsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetCategorySpecificsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetCategorySpecificsRequestType
    Get
    Set
public:
property GetCategorySpecificsRequestType^ ApiRequest {
    GetCategorySpecificsRequestType^ get ();
    void set (GetCategorySpecificsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► ApiResponse
Gets the GetCategorySpecificsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetCategorySpecificsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetCategorySpecificsResponseType
    Get
public:
property GetCategorySpecificsResponseType^ ApiResponse {
    GetCategorySpecificsResponseType^ get ();
}


CategoryIDList Property

CategoryIDList Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► CategoryIDList
Gets or sets the CategoryID of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection CategoryIDList { get; set; }
Public Property CategoryIDList As StringCollection
    Get
    Set
public:
property StringCollection^ CategoryIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


CategorySpecificList Property

CategorySpecificList Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► CategorySpecificList
Gets or sets the CategorySpecific of type CategoryItemSpecificsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public CategoryItemSpecificsTypeCollection CategorySpecificList { get; set; }
Public Property CategorySpecificList As CategoryItemSpecificsTypeCollection
    Get
    Set
public:
property CategoryItemSpecificsTypeCollection^ CategorySpecificList {
    CategoryItemSpecificsTypeCollection^ get ();
    void set (CategoryItemSpecificsTypeCollection^ value);
}


CategorySpecificsFileInfo Property

CategorySpecificsFileInfo Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► CategorySpecificsFileInfo
Gets or sets the CategorySpecificsFileInfo of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool CategorySpecificsFileInfo { get; set; }
Public Property CategorySpecificsFileInfo As Boolean
    Get
    Set
public:
property bool CategorySpecificsFileInfo {
    bool get ();
    void set (bool value);
}


ExcludeRelationships Property

ExcludeRelationships Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► ExcludeRelationships
Gets or sets the ExcludeRelationships of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ExcludeRelationships { get; set; }
Public Property ExcludeRelationships As Boolean
    Get
    Set
public:
property bool ExcludeRelationships {
    bool get ();
    void set (bool value);
}


FileReferenceID Property

FileReferenceID Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► FileReferenceID
Gets the returned FileReferenceID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string FileReferenceID { get; }
Public ReadOnly Property FileReferenceID As String
    Get
public:
property String^ FileReferenceID {
    String^ get ();
}


GetCategorySpecifics Method

GetCategorySpecifics Method
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► GetCategorySpecifics()()()()
Members
Icon | Member | Description
 | GetCategorySpecifics(StringCollection, DateTime, Int32, Int32, String, CategoryItemSpecificsTypeCollection, Boolean, Boolean, Boolean) |
 | GetCategorySpecifics(StringCollection) | For backward compatibility with old wrappers.


GetCategorySpecifics Method (CategoryIDList)

GetCategorySpecifics Method (CategoryIDList)
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► GetCategorySpecifics(StringCollection)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationsTypeCollection GetCategorySpecifics(
    StringCollection CategoryIDList
)
Public Function GetCategorySpecifics ( _
    CategoryIDList As StringCollection _
) As RecommendationsTypeCollection
public:
RecommendationsTypeCollection^ GetCategorySpecifics(
    StringCollection^ CategoryIDList
)
Parameters
CategoryIDList (StringCollection)


GetCategorySpecifics Method (CategoryIDList, LastUpdateTime, MaxNames, MaxValuesPerName, Name, CategorySpecificList, ExcludeRelationships, IncludeConfidence, CategorySpecificsFileInfo)

GetCategorySpecifics Method (CategoryIDList, LastUpdateTime, MaxNames, MaxValuesPerName, Name, CategorySpecificList, ExcludeRelationships, IncludeConfidence, CategorySpecificsFileInfo)
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► GetCategorySpecifics(StringCollection, DateTime, Int32, Int32, String, CategoryItemSpecificsTypeCollection, Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationsTypeCollection GetCategorySpecifics(
    StringCollection CategoryIDList,
    DateTime LastUpdateTime,
    int MaxNames,
    int MaxValuesPerName,
    string Name,
    CategoryItemSpecificsTypeCollection CategorySpecificList,
    bool ExcludeRelationships,
    bool IncludeConfidence,
    bool CategorySpecificsFileInfo
)
Public Function GetCategorySpecifics ( _
    CategoryIDList As StringCollection, _
    LastUpdateTime As DateTime, _
    MaxNames As Integer, _
    MaxValuesPerName As Integer, _
    Name As String, _
    CategorySpecificList As CategoryItemSpecificsTypeCollection, _
    ExcludeRelationships As Boolean, _
    IncludeConfidence As Boolean, _
    CategorySpecificsFileInfo As Boolean _
) As RecommendationsTypeCollection
public:
RecommendationsTypeCollection^ GetCategorySpecifics(
    StringCollection^ CategoryIDList,
    DateTime LastUpdateTime,
    int MaxNames,
    int MaxValuesPerName,
    String^ Name,
    CategoryItemSpecificsTypeCollection^ CategorySpecificList,
    bool ExcludeRelationships,
    bool IncludeConfidence,
    bool CategorySpecificsFileInfo
)
Parameters
CategoryIDList (StringCollection)
LastUpdateTime (DateTime)
MaxNames (Int32)
MaxValuesPerName (Int32)
Name (String)
CategorySpecificList (CategoryItemSpecificsTypeCollection)
ExcludeRelationships (Boolean)
IncludeConfidence (Boolean)
CategorySpecificsFileInfo (Boolean)


GetCategorySpecificsCall Constructor

GetCategorySpecificsCall Constructor
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► GetCategorySpecificsCall()()()()
Members
Icon | Member | Description
 | GetCategorySpecificsCall()()()() |
 | GetCategorySpecificsCall(ApiContext) |


GetCategorySpecificsCall Constructor

GetCategorySpecificsCall Constructor
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► GetCategorySpecificsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategorySpecificsCall()
Public Sub New
public:
GetCategorySpecificsCall()


GetCategorySpecificsCall Constructor (ApiContext)

GetCategorySpecificsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► GetCategorySpecificsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetCategorySpecificsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetCategorySpecificsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


IncludeConfidence Property

IncludeConfidence Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► IncludeConfidence
Gets or sets the IncludeConfidence of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeConfidence { get; set; }
Public Property IncludeConfidence As Boolean
    Get
    Set
public:
property bool IncludeConfidence {
    bool get ();
    void set (bool value);
}


LastUpdateTime Property

LastUpdateTime Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► LastUpdateTime
Gets or sets the LastUpdateTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastUpdateTime { get; set; }
Public Property LastUpdateTime As DateTime
    Get
    Set
public:
property DateTime LastUpdateTime {
    DateTime get ();
    void set (DateTime value);
}


MaxNames Property

MaxNames Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► MaxNames
Gets or sets the MaxNames of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int MaxNames { get; set; }
Public Property MaxNames As Integer
    Get
    Set
public:
property int MaxNames {
    int get ();
    void set (int value);
}


MaxValuesPerName Property

MaxValuesPerName Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► MaxValuesPerName
Gets or sets the MaxValuesPerName of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int MaxValuesPerName { get; set; }
Public Property MaxValuesPerName As Integer
    Get
    Set
public:
property int MaxValuesPerName {
    int get ();
    void set (int value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► Name
Gets or sets the Name of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


RecommendationList Property

RecommendationList Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► RecommendationList
Gets the returned Recommendations of type RecommendationsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationsTypeCollection RecommendationList { get; }
Public ReadOnly Property RecommendationList As RecommendationsTypeCollection
    Get
public:
property RecommendationsTypeCollection^ RecommendationList {
    RecommendationsTypeCollection^ get ();
}


TaskReferenceID Property

TaskReferenceID Property
Namespaces ► eBay.Service.Call ► GetCategorySpecificsCall ► TaskReferenceID
Gets the returned TaskReferenceID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TaskReferenceID { get; }
Public ReadOnly Property TaskReferenceID As String
    Get
public:
property String^ TaskReferenceID {
    String^ get ();
}


GetChallengeTokenCall Class

GetChallengeTokenCall Class
Namespaces ► eBay.Service.Call ► GetChallengeTokenCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetChallengeTokenCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetChallengeTokenCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetChallengeTokenCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetChallengeTokenCall()()()() |
 | GetChallengeTokenCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetChallengeTokenRequestType for this API call.
 | ApiResponse | Gets the GetChallengeTokenResponseType for this API call.
 | AudioChallengeURL | Gets the returned AudioChallengeURL of type String.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | ChallengeToken | Gets the returned ChallengeToken of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetChallengeToken()()()() | This is the base request type for the GetChallengeToken call. This call retrieves a botblock token and URLs for an image or audio clip that the user is to match. This call does not have any call-specific input parameters
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | ImageChallengeURL | Gets the returned ImageChallengeURL of type String.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetChallengeTokenCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetChallengeTokenCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetChallengeTokenCall ► ApiRequest
Gets or sets the GetChallengeTokenRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetChallengeTokenRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetChallengeTokenRequestType
    Get
    Set
public:
property GetChallengeTokenRequestType^ ApiRequest {
    GetChallengeTokenRequestType^ get ();
    void set (GetChallengeTokenRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetChallengeTokenCall ► ApiResponse
Gets the GetChallengeTokenResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetChallengeTokenResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetChallengeTokenResponseType
    Get
public:
property GetChallengeTokenResponseType^ ApiResponse {
    GetChallengeTokenResponseType^ get ();
}


AudioChallengeURL Property

AudioChallengeURL Property
Namespaces ► eBay.Service.Call ► GetChallengeTokenCall ► AudioChallengeURL
Gets the returned AudioChallengeURL of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string AudioChallengeURL { get; }
Public ReadOnly Property AudioChallengeURL As String
    Get
public:
property String^ AudioChallengeURL {
    String^ get ();
}


ChallengeToken Property

ChallengeToken Property
Namespaces ► eBay.Service.Call ► GetChallengeTokenCall ► ChallengeToken
Gets the returned ChallengeToken of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ChallengeToken { get; }
Public ReadOnly Property ChallengeToken As String
    Get
public:
property String^ ChallengeToken {
    String^ get ();
}


GetChallengeToken Method

GetChallengeToken Method
Namespaces ► eBay.Service.Call ► GetChallengeTokenCall ► GetChallengeToken()()()()
This is the base request type for the GetChallengeToken call. This call retrieves a botblock token and URLs for an image or audio clip that the user is to match.

This call does not have any call-specific input parameters
Declaration Syntax
C# Visual Basic Visual C++
public string GetChallengeToken()
Public Function GetChallengeToken As String
public:
String^ GetChallengeToken()


GetChallengeTokenCall Constructor

GetChallengeTokenCall Constructor
Namespaces ► eBay.Service.Call ► GetChallengeTokenCall ► GetChallengeTokenCall()()()()
Members
Icon | Member | Description
 | GetChallengeTokenCall()()()() |
 | GetChallengeTokenCall(ApiContext) |


GetChallengeTokenCall Constructor

GetChallengeTokenCall Constructor
Namespaces ► eBay.Service.Call ► GetChallengeTokenCall ► GetChallengeTokenCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetChallengeTokenCall()
Public Sub New
public:
GetChallengeTokenCall()


GetChallengeTokenCall Constructor (ApiContext)

GetChallengeTokenCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetChallengeTokenCall ► GetChallengeTokenCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetChallengeTokenCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetChallengeTokenCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ImageChallengeURL Property

ImageChallengeURL Property
Namespaces ► eBay.Service.Call ► GetChallengeTokenCall ► ImageChallengeURL
Gets the returned ImageChallengeURL of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ImageChallengeURL { get; }
Public ReadOnly Property ImageChallengeURL As String
    Get
public:
property String^ ImageChallengeURL {
    String^ get ();
}


GetCharitiesCall Class

GetCharitiesCall Class
Namespaces ► eBay.Service.Call ► GetCharitiesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetCharitiesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetCharitiesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetCharitiesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCharitiesCall()()()() |
 | GetCharitiesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetCharitiesRequestType for this API call.
 | ApiResponse | Gets the GetCharitiesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CampaignID | Gets or sets the CampaignID of type Int64.
 | CharityDomain | Gets or sets the CharityDomain of type Int32.
 | CharityID | Gets or sets the CharityID of type String.
 | CharityList | Gets the returned Charity of type CharityInfoTypeCollection.
 | CharityName | Gets or sets the CharityName of type String.
 | CharityRegion | Gets or sets the CharityRegion of type Int32.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Featured | Gets or sets the Featured of type Boolean.
 | Finalize()()()() | (Inherited from Object.)
 | GetCharities(String, String, String, Int32, Int32, Boolean, StringMatchCodeType, Boolean, Int64) | This is the base request type for the GetCharities call. This call is used to search for eBay for Charity nonprofit organizations. This call allows users to search for a specific nonprofit organization, or to search for multiple nonprofit organizations from a particular category and/or geographical region, or by using a search string.
 | GetCharities()()()() | to support the call with out parameters.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeDescription | Gets or sets the IncludeDescription of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MatchType | Gets or sets the MatchType of type StringMatchCodeType.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | Query | Gets or sets the Query of type String.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetCharitiesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► ApiRequest
Gets or sets the GetCharitiesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetCharitiesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetCharitiesRequestType
    Get
    Set
public:
property GetCharitiesRequestType^ ApiRequest {
    GetCharitiesRequestType^ get ();
    void set (GetCharitiesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► ApiResponse
Gets the GetCharitiesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetCharitiesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetCharitiesResponseType
    Get
public:
property GetCharitiesResponseType^ ApiResponse {
    GetCharitiesResponseType^ get ();
}


CampaignID Property

CampaignID Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► CampaignID
Gets or sets the CampaignID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long CampaignID { get; set; }
Public Property CampaignID As Long
    Get
    Set
public:
property long long CampaignID {
    long long get ();
    void set (long long value);
}


CharityDomain Property

CharityDomain Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► CharityDomain
Gets or sets the CharityDomain of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int CharityDomain { get; set; }
Public Property CharityDomain As Integer
    Get
    Set
public:
property int CharityDomain {
    int get ();
    void set (int value);
}


CharityID Property

CharityID Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► CharityID
Gets or sets the CharityID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CharityID { get; set; }
Public Property CharityID As String
    Get
    Set
public:
property String^ CharityID {
    String^ get ();
    void set (String^ value);
}


CharityList Property

CharityList Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► CharityList
Gets the returned Charity of type CharityInfoTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public CharityInfoTypeCollection CharityList { get; }
Public ReadOnly Property CharityList As CharityInfoTypeCollection
    Get
public:
property CharityInfoTypeCollection^ CharityList {
    CharityInfoTypeCollection^ get ();
}


CharityName Property

CharityName Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► CharityName
Gets or sets the CharityName of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CharityName { get; set; }
Public Property CharityName As String
    Get
    Set
public:
property String^ CharityName {
    String^ get ();
    void set (String^ value);
}


CharityRegion Property

CharityRegion Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► CharityRegion
Gets or sets the CharityRegion of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int CharityRegion { get; set; }
Public Property CharityRegion As Integer
    Get
    Set
public:
property int CharityRegion {
    int get ();
    void set (int value);
}


Featured Property

Featured Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► Featured
Gets or sets the Featured of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool Featured { get; set; }
Public Property Featured As Boolean
    Get
    Set
public:
property bool Featured {
    bool get ();
    void set (bool value);
}


GetCharities Method

GetCharities Method
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► GetCharities()()()()
Members
Icon | Member | Description
 | GetCharities(String, String, String, Int32, Int32, Boolean, StringMatchCodeType, Boolean, Int64) | This is the base request type for the GetCharities call. This call is used to search for eBay for Charity nonprofit organizations. This call allows users to search for a specific nonprofit organization, or to search for multiple nonprofit organizations from a particular category and/or geographical region, or by using a search string.
 | GetCharities()()()() | to support the call with out parameters.


GetCharities Method

GetCharities Method
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► GetCharities()()()()
to support the call with out parameters.
Declaration Syntax
C# Visual Basic Visual C++
public CharityInfoTypeCollection GetCharities()
Public Function GetCharities As CharityInfoTypeCollection
public:
CharityInfoTypeCollection^ GetCharities()


GetCharities Method (CharityID, CharityName, Query, CharityRegion, CharityDomain, IncludeDescription, MatchType, Featured, CampaignID)

GetCharities Method (CharityID, CharityName, Query, CharityRegion, CharityDomain, IncludeDescription, MatchType, Featured, CampaignID)
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► GetCharities(String, String, String, Int32, Int32, Boolean, StringMatchCodeType, Boolean, Int64)
This is the base request type for the GetCharities call. This call is used to search for eBay for Charity nonprofit organizations. This call allows users to search for a specific nonprofit organization, or to search for multiple nonprofit organizations from a particular category and/or geographical region, or by using a search string.
Declaration Syntax
C# Visual Basic Visual C++
public CharityInfoTypeCollection GetCharities(
    string CharityID,
    string CharityName,
    string Query,
    int CharityRegion,
    int CharityDomain,
    bool IncludeDescription,
    StringMatchCodeType MatchType,
    bool Featured,
    long CampaignID
)
Public Function GetCharities ( _
    CharityID As String, _
    CharityName As String, _
    Query As String, _
    CharityRegion As Integer, _
    CharityDomain As Integer, _
    IncludeDescription As Boolean, _
    MatchType As StringMatchCodeType, _
    Featured As Boolean, _
    CampaignID As Long _
) As CharityInfoTypeCollection
public:
CharityInfoTypeCollection^ GetCharities(
    String^ CharityID,
    String^ CharityName,
    String^ Query,
    int CharityRegion,
    int CharityDomain,
    bool IncludeDescription,
    StringMatchCodeType MatchType,
    bool Featured,
    long long CampaignID
)
Parameters
CharityID (String)
A unique identification number assigned to a nonprofit organization when that organization registers with the PayPal Giving Fund. If a CharityID value is used in the request, all other search filters set in the call request will be ignored, as the call will only search for the specified nonprofit organization.
CharityName (String)
This field will accept the full or partial name of a registered nonprofit organization. For example, if you pass in a value of heart, all registered nonprofit organizations with "heart" in their name may be returned in the response. If the MatchType field is used and set to
StartsWith
, the phrase "heart" must come at the beginning of the nonprofit organization's name. However, if the MatchType field is used and set to
Contains
, or is not used at all, all registered nonprofit organizations with "heart" in their name should be returned in the response. The string passed in this field is not case-sensitive.
Query (String)
This field accept any string up to 350 characters in length. The functionality of this field is similar to the CharityName field, except that the call will also search for the supplied query string within the charity's mission statement (which is returned under the Charity.Mission field in the response) as long as the IncludeDescription field is included in the call request and set to
true
. If you pass in a value of heart, all registered nonprofit organizations with "heart" in their name or in their mission statement may be returned in the response.

The string passed in this field is not case-sensitive. The MatchType field will have no effect if the Query field is used, as the MatchType field will only have an effect if a CharityName string field is included.
CharityRegion (Int32)
This field can be used to search for registered nonprofit organizations within a specified geographical region. Each geographical region will have an integer value associated with it. This integer value is what is passed in to this field.
CharityDomain (Int32)
This field can be used to search for registered nonprofit organizations within a specified charity domain or category. Each charity domain will have an integer value associated with it. This integer value is what is passed in to this field. Nonprofit organizations can be associated with multiple charity domains.
IncludeDescription (Boolean)
This field should be included and set to
true
if the Query field is used, and the user wishes to search the charity's name and its mission statement. If this field is omitted or included and set to
false
, the call will only search charity names for the specified string in the Query field.
MatchType (StringMatchCodeType)
This filter is used if the user wants to specify where to look for the string specified in the CharityName field. The enumeration value input into this field controls the type of string matching to use when a value is submitted in the CharityName field. If this field is omitted, and a CharityName string is used, this parameter value defaults to
StartsWith
.

This field is no applicable when a Query value is used.
Featured (Boolean)
This boolean field is used and set to
true
if the user wants to search for nonprofit organizations currently featured on the eBay site.
CampaignID (Int64)
Reserved for future use.


GetCharitiesCall Constructor

GetCharitiesCall Constructor
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► GetCharitiesCall()()()()
Members
Icon | Member | Description
 | GetCharitiesCall()()()() |
 | GetCharitiesCall(ApiContext) |


GetCharitiesCall Constructor

GetCharitiesCall Constructor
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► GetCharitiesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCharitiesCall()
Public Sub New
public:
GetCharitiesCall()


GetCharitiesCall Constructor (ApiContext)

GetCharitiesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► GetCharitiesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetCharitiesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetCharitiesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


IncludeDescription Property

IncludeDescription Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► IncludeDescription
Gets or sets the IncludeDescription of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeDescription { get; set; }
Public Property IncludeDescription As Boolean
    Get
    Set
public:
property bool IncludeDescription {
    bool get ();
    void set (bool value);
}


MatchType Property

MatchType Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► MatchType
Gets or sets the MatchType of type StringMatchCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public StringMatchCodeType MatchType { get; set; }
Public Property MatchType As StringMatchCodeType
    Get
    Set
public:
property StringMatchCodeType MatchType {
    StringMatchCodeType get ();
    void set (StringMatchCodeType value);
}


Query Property

Query Property
Namespaces ► eBay.Service.Call ► GetCharitiesCall ► Query
Gets or sets the Query of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Query { get; set; }
Public Property Query As String
    Get
    Set
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}


GetClientAlertsAuthTokenCall Class

GetClientAlertsAuthTokenCall Class
Namespaces ► eBay.Service.Call ► GetClientAlertsAuthTokenCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetClientAlertsAuthTokenCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetClientAlertsAuthTokenCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetClientAlertsAuthTokenCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetClientAlertsAuthTokenCall()()()() |
 | GetClientAlertsAuthTokenCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetClientAlertsAuthTokenRequestType for this API call.
 | ApiResponse | Gets the GetClientAlertsAuthTokenResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | ClientAlertsAuthToken | Gets the returned ClientAlertsAuthToken of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetClientAlertsAuthToken()()()() | This is the base request type for the GetClientAlertsAuthToken call. This call retrieves a Client Alerts token for the user, which is required when the user makes a GetUserAlerts call (Client Alerts API). a botblock token and URLs for an image or audio clip that the user is to match. This call does not have any call-specific input parameters Retrieves a token required for the GetUserAlerts call in the Client Alerts API.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationTime | Gets the returned HardExpirationTime of type DateTime.
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetClientAlertsAuthTokenCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetClientAlertsAuthTokenCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetClientAlertsAuthTokenCall ► ApiRequest
Gets or sets the GetClientAlertsAuthTokenRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetClientAlertsAuthTokenRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetClientAlertsAuthTokenRequestType
    Get
    Set
public:
property GetClientAlertsAuthTokenRequestType^ ApiRequest {
    GetClientAlertsAuthTokenRequestType^ get ();
    void set (GetClientAlertsAuthTokenRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetClientAlertsAuthTokenCall ► ApiResponse
Gets the GetClientAlertsAuthTokenResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetClientAlertsAuthTokenResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetClientAlertsAuthTokenResponseType
    Get
public:
property GetClientAlertsAuthTokenResponseType^ ApiResponse {
    GetClientAlertsAuthTokenResponseType^ get ();
}


ClientAlertsAuthToken Property

ClientAlertsAuthToken Property
Namespaces ► eBay.Service.Call ► GetClientAlertsAuthTokenCall ► ClientAlertsAuthToken
Gets the returned ClientAlertsAuthToken of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ClientAlertsAuthToken { get; }
Public ReadOnly Property ClientAlertsAuthToken As String
    Get
public:
property String^ ClientAlertsAuthToken {
    String^ get ();
}


GetClientAlertsAuthToken Method

GetClientAlertsAuthToken Method
Namespaces ► eBay.Service.Call ► GetClientAlertsAuthTokenCall ► GetClientAlertsAuthToken()()()()
This is the base request type for the GetClientAlertsAuthToken call. This call retrieves a Client Alerts token for the user, which is required when the user makes a GetUserAlerts call (Client Alerts API). a botblock token and URLs for an image or audio clip that the user is to match.

This call does not have any call-specific input parameters Retrieves a token required for the GetUserAlerts call in the Client Alerts API.
Declaration Syntax
C# Visual Basic Visual C++
public string GetClientAlertsAuthToken()
Public Function GetClientAlertsAuthToken As String
public:
String^ GetClientAlertsAuthToken()


GetClientAlertsAuthTokenCall Constructor

GetClientAlertsAuthTokenCall Constructor
Namespaces ► eBay.Service.Call ► GetClientAlertsAuthTokenCall ► GetClientAlertsAuthTokenCall()()()()
Members
Icon | Member | Description
 | GetClientAlertsAuthTokenCall()()()() |
 | GetClientAlertsAuthTokenCall(ApiContext) |


GetClientAlertsAuthTokenCall Constructor

GetClientAlertsAuthTokenCall Constructor
Namespaces ► eBay.Service.Call ► GetClientAlertsAuthTokenCall ► GetClientAlertsAuthTokenCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetClientAlertsAuthTokenCall()
Public Sub New
public:
GetClientAlertsAuthTokenCall()


GetClientAlertsAuthTokenCall Constructor (ApiContext)

GetClientAlertsAuthTokenCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetClientAlertsAuthTokenCall ► GetClientAlertsAuthTokenCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetClientAlertsAuthTokenCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetClientAlertsAuthTokenCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HardExpirationTime Property

HardExpirationTime Property
Namespaces ► eBay.Service.Call ► GetClientAlertsAuthTokenCall ► HardExpirationTime
Gets the returned HardExpirationTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime HardExpirationTime { get; }
Public ReadOnly Property HardExpirationTime As DateTime
    Get
public:
property DateTime HardExpirationTime {
    DateTime get ();
}


GetContextualKeywordsCall Class

GetContextualKeywordsCall Class
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetContextualKeywordsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetContextualKeywordsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetContextualKeywordsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetContextualKeywordsCall()()()() |
 | GetContextualKeywordsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetContextualKeywordsRequestType for this API call.
 | ApiResponse | Gets the GetContextualKeywordsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CategoryIDList | Gets or sets the CategoryID of type StringCollection.
 | ContextSearchAssetList | Gets the returned ContextSearchAsset of type ContextSearchAssetTypeCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Encoding | Gets or sets the Encoding of type String.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetContextualKeywords(String, String, StringCollection) | Retrieves top-ranked contextual eBay keywords and categories for a specified web page.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | URL | Gets or sets the URL of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetContextualKeywordsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall ► ApiRequest
Gets or sets the GetContextualKeywordsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetContextualKeywordsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetContextualKeywordsRequestType
    Get
    Set
public:
property GetContextualKeywordsRequestType^ ApiRequest {
    GetContextualKeywordsRequestType^ get ();
    void set (GetContextualKeywordsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall ► ApiResponse
Gets the GetContextualKeywordsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetContextualKeywordsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetContextualKeywordsResponseType
    Get
public:
property GetContextualKeywordsResponseType^ ApiResponse {
    GetContextualKeywordsResponseType^ get ();
}


CategoryIDList Property

CategoryIDList Property
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall ► CategoryIDList
Gets or sets the CategoryID of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection CategoryIDList { get; set; }
Public Property CategoryIDList As StringCollection
    Get
    Set
public:
property StringCollection^ CategoryIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ContextSearchAssetList Property

ContextSearchAssetList Property
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall ► ContextSearchAssetList
Gets the returned ContextSearchAsset of type ContextSearchAssetTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ContextSearchAssetTypeCollection ContextSearchAssetList { get; }
Public ReadOnly Property ContextSearchAssetList As ContextSearchAssetTypeCollection
    Get
public:
property ContextSearchAssetTypeCollection^ ContextSearchAssetList {
    ContextSearchAssetTypeCollection^ get ();
}


Encoding Property

Encoding Property
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall ► Encoding
Gets or sets the Encoding of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Encoding { get; set; }
Public Property Encoding As String
    Get
    Set
public:
property String^ Encoding {
    String^ get ();
    void set (String^ value);
}


GetContextualKeywords Method (URL, Encoding, CategoryIDList)

GetContextualKeywords Method (URL, Encoding, CategoryIDList)
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall ► GetContextualKeywords(String, String, StringCollection)
Retrieves top-ranked contextual eBay keywords and categories for a specified web page.
Declaration Syntax
C# Visual Basic Visual C++
public ContextSearchAssetTypeCollection GetContextualKeywords(
    string URL,
    string Encoding,
    StringCollection CategoryIDList
)
Public Function GetContextualKeywords ( _
    URL As String, _
    Encoding As String, _
    CategoryIDList As StringCollection _
) As ContextSearchAssetTypeCollection
public:
ContextSearchAssetTypeCollection^ GetContextualKeywords(
    String^ URL,
    String^ Encoding,
    StringCollection^ CategoryIDList
)
Parameters
URL (String)
The URL of the web page from which eBay is to extract keywords.
Encoding (String)
Web page encoding by which the URL is to be handled, such as ISO-8859-1.
CategoryIDList (StringCollection)
The ID of the category to which keywords are to be limited. Zero or more category IDs can be specified.


GetContextualKeywordsCall Constructor

GetContextualKeywordsCall Constructor
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall ► GetContextualKeywordsCall()()()()
Members
Icon | Member | Description
 | GetContextualKeywordsCall()()()() |
 | GetContextualKeywordsCall(ApiContext) |


GetContextualKeywordsCall Constructor

GetContextualKeywordsCall Constructor
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall ► GetContextualKeywordsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetContextualKeywordsCall()
Public Sub New
public:
GetContextualKeywordsCall()


GetContextualKeywordsCall Constructor (ApiContext)

GetContextualKeywordsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall ► GetContextualKeywordsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetContextualKeywordsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetContextualKeywordsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


URL Property

URL Property
Namespaces ► eBay.Service.Call ► GetContextualKeywordsCall ► URL
Gets or sets the URL of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string URL { get; set; }
Public Property URL As String
    Get
    Set
public:
property String^ URL {
    String^ get ();
    void set (String^ value);
}


GetDescriptionTemplatesCall Class

GetDescriptionTemplatesCall Class
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetDescriptionTemplatesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetDescriptionTemplatesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetDescriptionTemplatesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetDescriptionTemplatesCall()()()() |
 | GetDescriptionTemplatesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetDescriptionTemplatesRequestType for this API call.
 | ApiResponse | Gets the GetDescriptionTemplatesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CategoryID | Gets or sets the CategoryID of type String.
 | DescriptionTemplateList | Gets the returned DescriptionTemplate of type DescriptionTemplateTypeCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDescriptionTemplates(String, DateTime, Boolean) | This is the base request type for the GetDescriptionTemplates call. This call retrieves detailed information on the Listing Designer templates that are available for use by the seller.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LastModifiedTime | Gets or sets the LastModifiedTime of type DateTime.
 | LayoutTotal | Gets the returned LayoutTotal of type Int32.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MotorVehicles | Gets or sets the MotorVehicles of type Boolean.
 | ObsoleteLayoutIDList | Gets the returned ObsoleteLayoutID of type Int32Collection.
 | ObsoleteThemeIDList | Gets the returned ObsoleteThemeID of type Int32Collection.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | ThemeGroupList | Gets the returned ThemeGroup of type ThemeGroupTypeCollection.
 | ThemeTotal | Gets the returned ThemeTotal of type Int32.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetDescriptionTemplatesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► ApiRequest
Gets or sets the GetDescriptionTemplatesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetDescriptionTemplatesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetDescriptionTemplatesRequestType
    Get
    Set
public:
property GetDescriptionTemplatesRequestType^ ApiRequest {
    GetDescriptionTemplatesRequestType^ get ();
    void set (GetDescriptionTemplatesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► ApiResponse
Gets the GetDescriptionTemplatesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetDescriptionTemplatesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetDescriptionTemplatesResponseType
    Get
public:
property GetDescriptionTemplatesResponseType^ ApiResponse {
    GetDescriptionTemplatesResponseType^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► CategoryID
Gets or sets the CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


DescriptionTemplateList Property

DescriptionTemplateList Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► DescriptionTemplateList
Gets the returned DescriptionTemplate of type DescriptionTemplateTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionTemplateTypeCollection DescriptionTemplateList { get; }
Public ReadOnly Property DescriptionTemplateList As DescriptionTemplateTypeCollection
    Get
public:
property DescriptionTemplateTypeCollection^ DescriptionTemplateList {
    DescriptionTemplateTypeCollection^ get ();
}


GetDescriptionTemplates Method (CategoryID, LastModifiedTime, MotorVehicles)

GetDescriptionTemplates Method (CategoryID, LastModifiedTime, MotorVehicles)
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► GetDescriptionTemplates(String, DateTime, Boolean)
This is the base request type for the GetDescriptionTemplates call. This call retrieves detailed information on the Listing Designer templates that are available for use by the seller.
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionTemplateTypeCollection GetDescriptionTemplates(
    string CategoryID,
    DateTime LastModifiedTime,
    bool MotorVehicles
)
Public Function GetDescriptionTemplates ( _
    CategoryID As String, _
    LastModifiedTime As DateTime, _
    MotorVehicles As Boolean _
) As DescriptionTemplateTypeCollection
public:
DescriptionTemplateTypeCollection^ GetDescriptionTemplates(
    String^ CategoryID,
    DateTime LastModifiedTime,
    bool MotorVehicles
)
Parameters
CategoryID (String)
A CategoryID value can be specified if the seller would like to only see the Listing Designer templates that are available for that eBay category. This field will be ignored if the MotorVehicles boolean field is also included in the call request and set to
true
.
LastModifiedTime (DateTime)
This dateTime filter can be included and used if the user only wants to check for recently-added Listing Designer templates. If this filter is used, only the Listing Designer templates that have been added/modified after the specified timestamp will be returned in the response.

Typically, you will pass in the timestamp value that was returned the last time you refreshed the list of Listing Designer templates.
MotorVehicles (Boolean)
This boolean field should be included and set to
true
if the user would only like to see the Listing Designer templates that are available for motor vehicle categories. This field will override any CategoryID value that is specified in the call request.


GetDescriptionTemplatesCall Constructor

GetDescriptionTemplatesCall Constructor
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► GetDescriptionTemplatesCall()()()()
Members
Icon | Member | Description
 | GetDescriptionTemplatesCall()()()() |
 | GetDescriptionTemplatesCall(ApiContext) |


GetDescriptionTemplatesCall Constructor

GetDescriptionTemplatesCall Constructor
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► GetDescriptionTemplatesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetDescriptionTemplatesCall()
Public Sub New
public:
GetDescriptionTemplatesCall()


GetDescriptionTemplatesCall Constructor (ApiContext)

GetDescriptionTemplatesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► GetDescriptionTemplatesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetDescriptionTemplatesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetDescriptionTemplatesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


LastModifiedTime Property

LastModifiedTime Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► LastModifiedTime
Gets or sets the LastModifiedTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastModifiedTime { get; set; }
Public Property LastModifiedTime As DateTime
    Get
    Set
public:
property DateTime LastModifiedTime {
    DateTime get ();
    void set (DateTime value);
}


LayoutTotal Property

LayoutTotal Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► LayoutTotal
Gets the returned LayoutTotal of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int LayoutTotal { get; }
Public ReadOnly Property LayoutTotal As Integer
    Get
public:
property int LayoutTotal {
    int get ();
}


MotorVehicles Property

MotorVehicles Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► MotorVehicles
Gets or sets the MotorVehicles of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool MotorVehicles { get; set; }
Public Property MotorVehicles As Boolean
    Get
    Set
public:
property bool MotorVehicles {
    bool get ();
    void set (bool value);
}


ObsoleteLayoutIDList Property

ObsoleteLayoutIDList Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► ObsoleteLayoutIDList
Gets the returned ObsoleteLayoutID of type Int32Collection.
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection ObsoleteLayoutIDList { get; }
Public ReadOnly Property ObsoleteLayoutIDList As Int32Collection
    Get
public:
property Int32Collection^ ObsoleteLayoutIDList {
    Int32Collection^ get ();
}


ObsoleteThemeIDList Property

ObsoleteThemeIDList Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► ObsoleteThemeIDList
Gets the returned ObsoleteThemeID of type Int32Collection.
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection ObsoleteThemeIDList { get; }
Public ReadOnly Property ObsoleteThemeIDList As Int32Collection
    Get
public:
property Int32Collection^ ObsoleteThemeIDList {
    Int32Collection^ get ();
}


ThemeGroupList Property

ThemeGroupList Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► ThemeGroupList
Gets the returned ThemeGroup of type ThemeGroupTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ThemeGroupTypeCollection ThemeGroupList { get; }
Public ReadOnly Property ThemeGroupList As ThemeGroupTypeCollection
    Get
public:
property ThemeGroupTypeCollection^ ThemeGroupList {
    ThemeGroupTypeCollection^ get ();
}


ThemeTotal Property

ThemeTotal Property
Namespaces ► eBay.Service.Call ► GetDescriptionTemplatesCall ► ThemeTotal
Gets the returned ThemeTotal of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int ThemeTotal { get; }
Public ReadOnly Property ThemeTotal As Integer
    Get
public:
property int ThemeTotal {
    int get ();
}


GetDisputeCall Class

GetDisputeCall Class
Namespaces ► eBay.Service.Call ► GetDisputeCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetDisputeCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetDisputeCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetDisputeCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetDisputeCall()()()() |
 | GetDisputeCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetDisputeRequestType for this API call.
 | ApiResponse | Gets the GetDisputeResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | Dispute | Gets the returned Dispute of type DisputeType.
 | DisputeID | Gets or sets the DisputeID of type String.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDispute(String) | This is the base request type for the GetDispute call. This call retrieves the details of a seller-initiated dispute. Seller-initiated disputes include mutually-cancelled transactions and unpaid items. Note: This call does not support buyer-initiated cases created through eBay's Resolution Center. Buyer-initiated cases include Item Not Received (INR) and Significantly Not As Described (SNAD) cases. To retrieve and manage eBay Money Back Guarantee cases, the Case Management calls of the Post-Order API can be used instead.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetDisputeCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetDisputeCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetDisputeCall ► ApiRequest
Gets or sets the GetDisputeRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetDisputeRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetDisputeRequestType
    Get
    Set
public:
property GetDisputeRequestType^ ApiRequest {
    GetDisputeRequestType^ get ();
    void set (GetDisputeRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetDisputeCall ► ApiResponse
Gets the GetDisputeResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetDisputeResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetDisputeResponseType
    Get
public:
property GetDisputeResponseType^ ApiResponse {
    GetDisputeResponseType^ get ();
}


Dispute Property

Dispute Property
Namespaces ► eBay.Service.Call ► GetDisputeCall ► Dispute
Gets the returned Dispute of type DisputeType.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeType Dispute { get; }
Public ReadOnly Property Dispute As DisputeType
    Get
public:
property DisputeType^ Dispute {
    DisputeType^ get ();
}


DisputeID Property

DisputeID Property
Namespaces ► eBay.Service.Call ► GetDisputeCall ► DisputeID
Gets or sets the DisputeID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string DisputeID { get; set; }
Public Property DisputeID As String
    Get
    Set
public:
property String^ DisputeID {
    String^ get ();
    void set (String^ value);
}


GetDispute Method (DisputeID)

GetDispute Method (DisputeID)
Namespaces ► eBay.Service.Call ► GetDisputeCall ► GetDispute(String)
This is the base request type for the GetDispute call. This call retrieves the details of a seller-initiated dispute. Seller-initiated disputes include mutually-cancelled transactions and unpaid items.

Note: This call does not support buyer-initiated cases created through eBay's Resolution Center. Buyer-initiated cases include Item Not Received (INR) and Significantly Not As Described (SNAD) cases. To retrieve and manage eBay Money Back Guarantee cases, the Case Management calls of the Post-Order API can be used instead.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeType GetDispute(
    string DisputeID
)
Public Function GetDispute ( _
    DisputeID As String _
) As DisputeType
public:
DisputeType^ GetDispute(
    String^ DisputeID
)
Parameters
DisputeID (String)
The unique identifier of an seller-initiated dispute. The caller passes in this value to retrieve detailed information on a specific dispute.

Note: Buyer-initiated Money Back Guarantee cases are not supported with this call. To retrieve and manage eBay Money Back Guarantee cases, the Case Management calls of the Post-Order API can be used instead.


GetDisputeCall Constructor

GetDisputeCall Constructor
Namespaces ► eBay.Service.Call ► GetDisputeCall ► GetDisputeCall()()()()
Members
Icon | Member | Description
 | GetDisputeCall()()()() |
 | GetDisputeCall(ApiContext) |


GetDisputeCall Constructor

GetDisputeCall Constructor
Namespaces ► eBay.Service.Call ► GetDisputeCall ► GetDisputeCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetDisputeCall()
Public Sub New
public:
GetDisputeCall()


GetDisputeCall Constructor (ApiContext)

GetDisputeCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetDisputeCall ► GetDisputeCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetDisputeCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetDisputeCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


GeteBayDetailsCall Class

GeteBayDetailsCall Class
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GeteBayDetailsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GeteBayDetailsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GeteBayDetailsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeteBayDetailsCall()()()() |
 | GeteBayDetailsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GeteBayDetailsRequestType for this API call.
 | ApiResponse | Gets the GeteBayDetailsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BuyerRequirementDetailList | Gets the returned BuyerRequirementDetails of type SiteBuyerRequirementDetailsTypeCollection.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CountryDetailList | Gets the returned CountryDetails of type CountryDetailsTypeCollection.
 | CurrencyDetailList | Gets the returned CurrencyDetails of type CurrencyDetailsTypeCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DetailNameList | Gets or sets the DetailName of type DetailNameCodeTypeCollection.
 | DispatchTimeMaxDetailList | Gets the returned DispatchTimeMaxDetails of type DispatchTimeMaxDetailsTypeCollection.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | ExcludeShippingLocationDetailList | Gets the returned ExcludeShippingLocationDetails of type ExcludeShippingLocationDetailsTypeCollection.
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GeteBayDetails(DetailNameCodeTypeCollection) | This is the base request type for the GeteBayDetails call. This call retrieves the latest eBay feature-related metadata values that are supported when listing items. This metadata includes country codes, currency codes, Item Specifics thresholds, supported Return Policy values, available shipping carriers and shipping service options, and more. This call may be used to keep metadata up-to-date in your applications. In some cases, the data returned in the response will vary according to the eBay site that you use for the request.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemSpecificDetailList | Gets the returned ItemSpecificDetails of type ItemSpecificDetailsTypeCollection.
 | ListingFeatureDetailList | Gets the returned ListingFeatureDetails of type ListingFeatureDetailsTypeCollection.
 | ListingStartPriceDetailList | Gets the returned ListingStartPriceDetails of type ListingStartPriceDetailsTypeCollection.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PaymentOptionDetailList | Gets the returned PaymentOptionDetails of type PaymentOptionDetailsTypeCollection.
 | ProductDetails | Gets the returned ProductDetails of type ProductDetailsType.
 | RecoupmentPolicyDetailList | Gets the returned RecoupmentPolicyDetails of type RecoupmentPolicyDetailsTypeCollection.
 | RegionDetailList | Gets the returned RegionDetails of type RegionDetailsTypeCollection.
 | RegionOfOriginDetailList | Gets the returned RegionOfOriginDetails of type RegionOfOriginDetailsTypeCollection.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReturnPolicyDetails | Gets the returned ReturnPolicyDetails of type ReturnPolicyDetailsType.
 | ShippingCarrierDetailList | Gets the returned ShippingCarrierDetails of type ShippingCarrierDetailsTypeCollection.
 | ShippingCategoryDetailList | Gets the returned ShippingCategoryDetails of type ShippingCategoryDetailsTypeCollection.
 | ShippingLocationDetailList | Gets the returned ShippingLocationDetails of type ShippingLocationDetailsTypeCollection.
 | ShippingPackageDetailList | Gets the returned ShippingPackageDetails of type ShippingPackageDetailsTypeCollection.
 | ShippingServiceDetailList | Gets the returned ShippingServiceDetails of type ShippingServiceDetailsTypeCollection.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SiteDetailList | Gets the returned SiteDetails of type SiteDetailsTypeCollection.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | TaxJurisdictionList | Gets the returned TaxJurisdiction of type TaxJurisdictionTypeCollection.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | TimeZoneDetailList | Gets the returned TimeZoneDetails of type TimeZoneDetailsTypeCollection.
 | ToString()()()() | (Inherited from Object.)
 | UnitOfMeasurementDetailList | Gets the returned UnitOfMeasurementDetails of type UnitOfMeasurementDetailsTypeCollection.
 | UpdateTime | Gets the returned UpdateTime of type DateTime.
 | URLDetailList | Gets the returned URLDetails of type URLDetailsTypeCollection.
 | VariationDetails | Gets the returned VariationDetails of type VariationDetailsType.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GeteBayDetailsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ApiRequest
Gets or sets the GeteBayDetailsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayDetailsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GeteBayDetailsRequestType
    Get
    Set
public:
property GeteBayDetailsRequestType^ ApiRequest {
    GeteBayDetailsRequestType^ get ();
    void set (GeteBayDetailsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ApiResponse
Gets the GeteBayDetailsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayDetailsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GeteBayDetailsResponseType
    Get
public:
property GeteBayDetailsResponseType^ ApiResponse {
    GeteBayDetailsResponseType^ get ();
}


BuyerRequirementDetailList Property

BuyerRequirementDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► BuyerRequirementDetailList
Gets the returned BuyerRequirementDetails of type SiteBuyerRequirementDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public SiteBuyerRequirementDetailsTypeCollection BuyerRequirementDetailList { get; }
Public ReadOnly Property BuyerRequirementDetailList As SiteBuyerRequirementDetailsTypeCollection
    Get
public:
property SiteBuyerRequirementDetailsTypeCollection^ BuyerRequirementDetailList {
    SiteBuyerRequirementDetailsTypeCollection^ get ();
}


CountryDetailList Property

CountryDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► CountryDetailList
Gets the returned CountryDetails of type CountryDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsTypeCollection CountryDetailList { get; }
Public ReadOnly Property CountryDetailList As CountryDetailsTypeCollection
    Get
public:
property CountryDetailsTypeCollection^ CountryDetailList {
    CountryDetailsTypeCollection^ get ();
}


CurrencyDetailList Property

CurrencyDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► CurrencyDetailList
Gets the returned CurrencyDetails of type CurrencyDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyDetailsTypeCollection CurrencyDetailList { get; }
Public ReadOnly Property CurrencyDetailList As CurrencyDetailsTypeCollection
    Get
public:
property CurrencyDetailsTypeCollection^ CurrencyDetailList {
    CurrencyDetailsTypeCollection^ get ();
}


DetailNameList Property

DetailNameList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► DetailNameList
Gets or sets the DetailName of type DetailNameCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DetailNameCodeTypeCollection DetailNameList { get; set; }
Public Property DetailNameList As DetailNameCodeTypeCollection
    Get
    Set
public:
property DetailNameCodeTypeCollection^ DetailNameList {
    DetailNameCodeTypeCollection^ get ();
    void set (DetailNameCodeTypeCollection^ value);
}


DispatchTimeMaxDetailList Property

DispatchTimeMaxDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► DispatchTimeMaxDetailList
Gets the returned DispatchTimeMaxDetails of type DispatchTimeMaxDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DispatchTimeMaxDetailsTypeCollection DispatchTimeMaxDetailList { get; }
Public ReadOnly Property DispatchTimeMaxDetailList As DispatchTimeMaxDetailsTypeCollection
    Get
public:
property DispatchTimeMaxDetailsTypeCollection^ DispatchTimeMaxDetailList {
    DispatchTimeMaxDetailsTypeCollection^ get ();
}


ExcludeShippingLocationDetailList Property

ExcludeShippingLocationDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ExcludeShippingLocationDetailList
Gets the returned ExcludeShippingLocationDetails of type ExcludeShippingLocationDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ExcludeShippingLocationDetailsTypeCollection ExcludeShippingLocationDetailList { get; }
Public ReadOnly Property ExcludeShippingLocationDetailList As ExcludeShippingLocationDetailsTypeCollection
    Get
public:
property ExcludeShippingLocationDetailsTypeCollection^ ExcludeShippingLocationDetailList {
    ExcludeShippingLocationDetailsTypeCollection^ get ();
}


GeteBayDetails Method (DetailNameList)

GeteBayDetails Method (DetailNameList)
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► GeteBayDetails(DetailNameCodeTypeCollection)
This is the base request type for the GeteBayDetails call. This call retrieves the latest eBay feature-related metadata values that are supported when listing items. This metadata includes country codes, currency codes, Item Specifics thresholds, supported Return Policy values, available shipping carriers and shipping service options, and more. This call may be used to keep metadata up-to-date in your applications. In some cases, the data returned in the response will vary according to the eBay site that you use for the request.
Declaration Syntax
C# Visual Basic Visual C++
public void GeteBayDetails(
    DetailNameCodeTypeCollection DetailNameList
)
Public Sub GeteBayDetails ( _
    DetailNameList As DetailNameCodeTypeCollection _
)
public:
void GeteBayDetails(
    DetailNameCodeTypeCollection^ DetailNameList
)
Parameters
DetailNameList (DetailNameCodeTypeCollection)
One or more DetailName fields may be used to control the the type of metadata that is returned in the response. If no DetailName fields are used, all metadata will be returned in the response. It is a good idea to familiarize yourself with the metadata that can be returned with GeteBayDetails by reading through the enumeration values in DetailNameCodeType.


GeteBayDetailsCall Constructor

GeteBayDetailsCall Constructor
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► GeteBayDetailsCall()()()()
Members
Icon | Member | Description
 | GeteBayDetailsCall()()()() |
 | GeteBayDetailsCall(ApiContext) |


GeteBayDetailsCall Constructor

GeteBayDetailsCall Constructor
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► GeteBayDetailsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayDetailsCall()
Public Sub New
public:
GeteBayDetailsCall()


GeteBayDetailsCall Constructor (ApiContext)

GeteBayDetailsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► GeteBayDetailsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayDetailsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GeteBayDetailsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ItemSpecificDetailList Property

ItemSpecificDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ItemSpecificDetailList
Gets the returned ItemSpecificDetails of type ItemSpecificDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificDetailsTypeCollection ItemSpecificDetailList { get; }
Public ReadOnly Property ItemSpecificDetailList As ItemSpecificDetailsTypeCollection
    Get
public:
property ItemSpecificDetailsTypeCollection^ ItemSpecificDetailList {
    ItemSpecificDetailsTypeCollection^ get ();
}


ListingFeatureDetailList Property

ListingFeatureDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ListingFeatureDetailList
Gets the returned ListingFeatureDetails of type ListingFeatureDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ListingFeatureDetailsTypeCollection ListingFeatureDetailList { get; }
Public ReadOnly Property ListingFeatureDetailList As ListingFeatureDetailsTypeCollection
    Get
public:
property ListingFeatureDetailsTypeCollection^ ListingFeatureDetailList {
    ListingFeatureDetailsTypeCollection^ get ();
}


ListingStartPriceDetailList Property

ListingStartPriceDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ListingStartPriceDetailList
Gets the returned ListingStartPriceDetails of type ListingStartPriceDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ListingStartPriceDetailsTypeCollection ListingStartPriceDetailList { get; }
Public ReadOnly Property ListingStartPriceDetailList As ListingStartPriceDetailsTypeCollection
    Get
public:
property ListingStartPriceDetailsTypeCollection^ ListingStartPriceDetailList {
    ListingStartPriceDetailsTypeCollection^ get ();
}


PaymentOptionDetailList Property

PaymentOptionDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► PaymentOptionDetailList
Gets the returned PaymentOptionDetails of type PaymentOptionDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionDetailsTypeCollection PaymentOptionDetailList { get; }
Public ReadOnly Property PaymentOptionDetailList As PaymentOptionDetailsTypeCollection
    Get
public:
property PaymentOptionDetailsTypeCollection^ PaymentOptionDetailList {
    PaymentOptionDetailsTypeCollection^ get ();
}


ProductDetails Property

ProductDetails Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ProductDetails
Gets the returned ProductDetails of type ProductDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public ProductDetailsType ProductDetails { get; }
Public ReadOnly Property ProductDetails As ProductDetailsType
    Get
public:
property ProductDetailsType^ ProductDetails {
    ProductDetailsType^ get ();
}


RecoupmentPolicyDetailList Property

RecoupmentPolicyDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► RecoupmentPolicyDetailList
Gets the returned RecoupmentPolicyDetails of type RecoupmentPolicyDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public RecoupmentPolicyDetailsTypeCollection RecoupmentPolicyDetailList { get; }
Public ReadOnly Property RecoupmentPolicyDetailList As RecoupmentPolicyDetailsTypeCollection
    Get
public:
property RecoupmentPolicyDetailsTypeCollection^ RecoupmentPolicyDetailList {
    RecoupmentPolicyDetailsTypeCollection^ get ();
}


RegionDetailList Property

RegionDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► RegionDetailList
Gets the returned RegionDetails of type RegionDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public RegionDetailsTypeCollection RegionDetailList { get; }
Public ReadOnly Property RegionDetailList As RegionDetailsTypeCollection
    Get
public:
property RegionDetailsTypeCollection^ RegionDetailList {
    RegionDetailsTypeCollection^ get ();
}


RegionOfOriginDetailList Property

RegionOfOriginDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► RegionOfOriginDetailList
Gets the returned RegionOfOriginDetails of type RegionOfOriginDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public RegionOfOriginDetailsTypeCollection RegionOfOriginDetailList { get; }
Public ReadOnly Property RegionOfOriginDetailList As RegionOfOriginDetailsTypeCollection
    Get
public:
property RegionOfOriginDetailsTypeCollection^ RegionOfOriginDetailList {
    RegionOfOriginDetailsTypeCollection^ get ();
}


ReturnPolicyDetails Property

ReturnPolicyDetails Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ReturnPolicyDetails
Gets the returned ReturnPolicyDetails of type ReturnPolicyDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public ReturnPolicyDetailsType ReturnPolicyDetails { get; }
Public ReadOnly Property ReturnPolicyDetails As ReturnPolicyDetailsType
    Get
public:
property ReturnPolicyDetailsType^ ReturnPolicyDetails {
    ReturnPolicyDetailsType^ get ();
}


ShippingCarrierDetailList Property

ShippingCarrierDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ShippingCarrierDetailList
Gets the returned ShippingCarrierDetails of type ShippingCarrierDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierDetailsTypeCollection ShippingCarrierDetailList { get; }
Public ReadOnly Property ShippingCarrierDetailList As ShippingCarrierDetailsTypeCollection
    Get
public:
property ShippingCarrierDetailsTypeCollection^ ShippingCarrierDetailList {
    ShippingCarrierDetailsTypeCollection^ get ();
}


ShippingCategoryDetailList Property

ShippingCategoryDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ShippingCategoryDetailList
Gets the returned ShippingCategoryDetails of type ShippingCategoryDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCategoryDetailsTypeCollection ShippingCategoryDetailList { get; }
Public ReadOnly Property ShippingCategoryDetailList As ShippingCategoryDetailsTypeCollection
    Get
public:
property ShippingCategoryDetailsTypeCollection^ ShippingCategoryDetailList {
    ShippingCategoryDetailsTypeCollection^ get ();
}


ShippingLocationDetailList Property

ShippingLocationDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ShippingLocationDetailList
Gets the returned ShippingLocationDetails of type ShippingLocationDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingLocationDetailsTypeCollection ShippingLocationDetailList { get; }
Public ReadOnly Property ShippingLocationDetailList As ShippingLocationDetailsTypeCollection
    Get
public:
property ShippingLocationDetailsTypeCollection^ ShippingLocationDetailList {
    ShippingLocationDetailsTypeCollection^ get ();
}


ShippingPackageDetailList Property

ShippingPackageDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ShippingPackageDetailList
Gets the returned ShippingPackageDetails of type ShippingPackageDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageDetailsTypeCollection ShippingPackageDetailList { get; }
Public ReadOnly Property ShippingPackageDetailList As ShippingPackageDetailsTypeCollection
    Get
public:
property ShippingPackageDetailsTypeCollection^ ShippingPackageDetailList {
    ShippingPackageDetailsTypeCollection^ get ();
}


ShippingServiceDetailList Property

ShippingServiceDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► ShippingServiceDetailList
Gets the returned ShippingServiceDetails of type ShippingServiceDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceDetailsTypeCollection ShippingServiceDetailList { get; }
Public ReadOnly Property ShippingServiceDetailList As ShippingServiceDetailsTypeCollection
    Get
public:
property ShippingServiceDetailsTypeCollection^ ShippingServiceDetailList {
    ShippingServiceDetailsTypeCollection^ get ();
}


SiteDetailList Property

SiteDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► SiteDetailList
Gets the returned SiteDetails of type SiteDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public SiteDetailsTypeCollection SiteDetailList { get; }
Public ReadOnly Property SiteDetailList As SiteDetailsTypeCollection
    Get
public:
property SiteDetailsTypeCollection^ SiteDetailList {
    SiteDetailsTypeCollection^ get ();
}


TaxJurisdictionList Property

TaxJurisdictionList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► TaxJurisdictionList
Gets the returned TaxJurisdiction of type TaxJurisdictionTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection TaxJurisdictionList { get; }
Public ReadOnly Property TaxJurisdictionList As TaxJurisdictionTypeCollection
    Get
public:
property TaxJurisdictionTypeCollection^ TaxJurisdictionList {
    TaxJurisdictionTypeCollection^ get ();
}


TimeZoneDetailList Property

TimeZoneDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► TimeZoneDetailList
Gets the returned TimeZoneDetails of type TimeZoneDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public TimeZoneDetailsTypeCollection TimeZoneDetailList { get; }
Public ReadOnly Property TimeZoneDetailList As TimeZoneDetailsTypeCollection
    Get
public:
property TimeZoneDetailsTypeCollection^ TimeZoneDetailList {
    TimeZoneDetailsTypeCollection^ get ();
}


UnitOfMeasurementDetailList Property

UnitOfMeasurementDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► UnitOfMeasurementDetailList
Gets the returned UnitOfMeasurementDetails of type UnitOfMeasurementDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementDetailsTypeCollection UnitOfMeasurementDetailList { get; }
Public ReadOnly Property UnitOfMeasurementDetailList As UnitOfMeasurementDetailsTypeCollection
    Get
public:
property UnitOfMeasurementDetailsTypeCollection^ UnitOfMeasurementDetailList {
    UnitOfMeasurementDetailsTypeCollection^ get ();
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► UpdateTime
Gets the returned UpdateTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; }
Public ReadOnly Property UpdateTime As DateTime
    Get
public:
property DateTime UpdateTime {
    DateTime get ();
}


URLDetailList Property

URLDetailList Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► URLDetailList
Gets the returned URLDetails of type URLDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public URLDetailsTypeCollection URLDetailList { get; }
Public ReadOnly Property URLDetailList As URLDetailsTypeCollection
    Get
public:
property URLDetailsTypeCollection^ URLDetailList {
    URLDetailsTypeCollection^ get ();
}


VariationDetails Property

VariationDetails Property
Namespaces ► eBay.Service.Call ► GeteBayDetailsCall ► VariationDetails
Gets the returned VariationDetails of type VariationDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public VariationDetailsType VariationDetails { get; }
Public ReadOnly Property VariationDetails As VariationDetailsType
    Get
public:
property VariationDetailsType^ VariationDetails {
    VariationDetailsType^ get ();
}


GeteBayOfficialTimeCall Class

GeteBayOfficialTimeCall Class
Namespaces ► eBay.Service.Call ► GeteBayOfficialTimeCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GeteBayOfficialTimeCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GeteBayOfficialTimeCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GeteBayOfficialTimeCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeteBayOfficialTimeCall()()()() |
 | GeteBayOfficialTimeCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GeteBayOfficialTimeRequestType for this API call.
 | ApiResponse | Gets the GeteBayOfficialTimeResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EBayTime | Gets the Timestamp of type DateTime.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GeteBayOfficialTime()()()() | Gets the official eBay system time in GMT.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GeteBayOfficialTimeCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GeteBayOfficialTimeCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GeteBayOfficialTimeCall ► ApiRequest
Gets or sets the GeteBayOfficialTimeRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayOfficialTimeRequestType ApiRequest { get; set; }
Public Property ApiRequest As GeteBayOfficialTimeRequestType
    Get
    Set
public:
property GeteBayOfficialTimeRequestType^ ApiRequest {
    GeteBayOfficialTimeRequestType^ get ();
    void set (GeteBayOfficialTimeRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GeteBayOfficialTimeCall ► ApiResponse
Gets the GeteBayOfficialTimeResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayOfficialTimeResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GeteBayOfficialTimeResponseType
    Get
public:
property GeteBayOfficialTimeResponseType^ ApiResponse {
    GeteBayOfficialTimeResponseType^ get ();
}


EBayTime Property

EBayTime Property
Namespaces ► eBay.Service.Call ► GeteBayOfficialTimeCall ► EBayTime
Gets the Timestamp of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EBayTime { get; }
Public ReadOnly Property EBayTime As DateTime
    Get
public:
property DateTime EBayTime {
    DateTime get ();
}


GeteBayOfficialTime Method

GeteBayOfficialTime Method
Namespaces ► eBay.Service.Call ► GeteBayOfficialTimeCall ► GeteBayOfficialTime()()()()
Gets the official eBay system time in GMT.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime GeteBayOfficialTime()
Public Function GeteBayOfficialTime As DateTime
public:
DateTime GeteBayOfficialTime()


GeteBayOfficialTimeCall Constructor

GeteBayOfficialTimeCall Constructor
Namespaces ► eBay.Service.Call ► GeteBayOfficialTimeCall ► GeteBayOfficialTimeCall()()()()
Members
Icon | Member | Description
 | GeteBayOfficialTimeCall()()()() |
 | GeteBayOfficialTimeCall(ApiContext) |


GeteBayOfficialTimeCall Constructor

GeteBayOfficialTimeCall Constructor
Namespaces ► eBay.Service.Call ► GeteBayOfficialTimeCall ► GeteBayOfficialTimeCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayOfficialTimeCall()
Public Sub New
public:
GeteBayOfficialTimeCall()


GeteBayOfficialTimeCall Constructor (ApiContext)

GeteBayOfficialTimeCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GeteBayOfficialTimeCall ► GeteBayOfficialTimeCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayOfficialTimeCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GeteBayOfficialTimeCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


GetFeedbackCall Class

GetFeedbackCall Class
Namespaces ► eBay.Service.Call ► GetFeedbackCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetFeedbackCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetFeedbackCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetFeedbackCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetFeedbackCall()()()() |
 | GetFeedbackCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetFeedbackRequestType for this API call.
 | ApiResponse | Gets the GetFeedbackResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CommentTypeList | Gets or sets the CommentType of type CommentTypeCodeTypeCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EntriesPerPage | Gets the returned EntriesPerPage of type Int32.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeedbackDetailItemTotal | Gets the returned FeedbackDetailItemTotal of type Int32.
 | FeedbackID | Gets or sets the FeedbackID of type String.
 | FeedbackList | Gets the returned FeedbackDetailArray of type FeedbackDetailTypeCollection.
 | FeedbackScore | Gets the returned FeedbackScore of type Int32.
 | FeedbackSummary | Gets the returned FeedbackSummary of type FeedbackSummaryType.
 | FeedbackType | Gets or sets the FeedbackType of type FeedbackTypeCodeType.
 | Finalize()()()() | (Inherited from Object.)
 | GetFeedback(String, String, String, String, CommentTypeCodeTypeCollection, FeedbackTypeCodeType, PaginationType, String) | Retrieves one, many, or all Feedback records for a specific eBay user. There is a filter option in the call request to limit Feedback records to those that are received, or to those that are left for other buyers, as well as a filter option to limit Feedback records to those that are received as a buyer or seller.
 | GetFeedback()()()() | For backward compatibility with old wrappers.
 | GetFeedback(String) | For backward compatibility with old wrappers.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | PageNumber | Gets the returned PageNumber of type Int32.
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | UserID | Gets or sets the UserID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetFeedbackCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► ApiRequest
Gets or sets the GetFeedbackRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetFeedbackRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetFeedbackRequestType
    Get
    Set
public:
property GetFeedbackRequestType^ ApiRequest {
    GetFeedbackRequestType^ get ();
    void set (GetFeedbackRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► ApiResponse
Gets the GetFeedbackResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetFeedbackResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetFeedbackResponseType
    Get
public:
property GetFeedbackResponseType^ ApiResponse {
    GetFeedbackResponseType^ get ();
}


CommentTypeList Property

CommentTypeList Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► CommentTypeList
Gets or sets the CommentType of type CommentTypeCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeTypeCollection CommentTypeList { get; set; }
Public Property CommentTypeList As CommentTypeCodeTypeCollection
    Get
    Set
public:
property CommentTypeCodeTypeCollection^ CommentTypeList {
    CommentTypeCodeTypeCollection^ get ();
    void set (CommentTypeCodeTypeCollection^ value);
}


EntriesPerPage Property

EntriesPerPage Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► EntriesPerPage
Gets the returned EntriesPerPage of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int EntriesPerPage { get; }
Public ReadOnly Property EntriesPerPage As Integer
    Get
public:
property int EntriesPerPage {
    int get ();
}


FeedbackDetailItemTotal Property

FeedbackDetailItemTotal Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► FeedbackDetailItemTotal
Gets the returned FeedbackDetailItemTotal of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int FeedbackDetailItemTotal { get; }
Public ReadOnly Property FeedbackDetailItemTotal As Integer
    Get
public:
property int FeedbackDetailItemTotal {
    int get ();
}


FeedbackID Property

FeedbackID Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► FeedbackID
Gets or sets the FeedbackID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string FeedbackID { get; set; }
Public Property FeedbackID As String
    Get
    Set
public:
property String^ FeedbackID {
    String^ get ();
    void set (String^ value);
}


FeedbackList Property

FeedbackList Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► FeedbackList
Gets the returned FeedbackDetailArray of type FeedbackDetailTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailTypeCollection FeedbackList { get; }
Public ReadOnly Property FeedbackList As FeedbackDetailTypeCollection
    Get
public:
property FeedbackDetailTypeCollection^ FeedbackList {
    FeedbackDetailTypeCollection^ get ();
}


FeedbackScore Property

FeedbackScore Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► FeedbackScore
Gets the returned FeedbackScore of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int FeedbackScore { get; }
Public ReadOnly Property FeedbackScore As Integer
    Get
public:
property int FeedbackScore {
    int get ();
}


FeedbackSummary Property

FeedbackSummary Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► FeedbackSummary
Gets the returned FeedbackSummary of type FeedbackSummaryType.
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackSummaryType FeedbackSummary { get; }
Public ReadOnly Property FeedbackSummary As FeedbackSummaryType
    Get
public:
property FeedbackSummaryType^ FeedbackSummary {
    FeedbackSummaryType^ get ();
}


FeedbackType Property

FeedbackType Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► FeedbackType
Gets or sets the FeedbackType of type FeedbackTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackTypeCodeType FeedbackType { get; set; }
Public Property FeedbackType As FeedbackTypeCodeType
    Get
    Set
public:
property FeedbackTypeCodeType FeedbackType {
    FeedbackTypeCodeType get ();
    void set (FeedbackTypeCodeType value);
}


GetFeedback Method

GetFeedback Method
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► GetFeedback()()()()
Members
Icon | Member | Description
 | GetFeedback(String, String, String, String, CommentTypeCodeTypeCollection, FeedbackTypeCodeType, PaginationType, String) | Retrieves one, many, or all Feedback records for a specific eBay user. There is a filter option in the call request to limit Feedback records to those that are received, or to those that are left for other buyers, as well as a filter option to limit Feedback records to those that are received as a buyer or seller.
 | GetFeedback()()()() | For backward compatibility with old wrappers.
 | GetFeedback(String) | For backward compatibility with old wrappers.


GetFeedback Method

GetFeedback Method
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► GetFeedback()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailTypeCollection GetFeedback()
Public Function GetFeedback As FeedbackDetailTypeCollection
public:
FeedbackDetailTypeCollection^ GetFeedback()


GetFeedback Method (UserID)

GetFeedback Method (UserID)
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► GetFeedback(String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailTypeCollection GetFeedback(
    string UserID
)
Public Function GetFeedback ( _
    UserID As String _
) As FeedbackDetailTypeCollection
public:
FeedbackDetailTypeCollection^ GetFeedback(
    String^ UserID
)
Parameters
UserID (String)


GetFeedback Method (UserID, FeedbackID, ItemID, TransactionID, CommentTypeList, FeedbackType, Pagination, OrderLineItemID)

GetFeedback Method (UserID, FeedbackID, ItemID, TransactionID, CommentTypeList, FeedbackType, Pagination, OrderLineItemID)
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► GetFeedback(String, String, String, String, CommentTypeCodeTypeCollection, FeedbackTypeCodeType, PaginationType, String)
Retrieves one, many, or all Feedback records for a specific eBay user. There is a filter option in the call request to limit Feedback records to those that are received, or to those that are left for other buyers, as well as a filter option to limit Feedback records to those that are received as a buyer or seller.
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailTypeCollection GetFeedback(
    string UserID,
    string FeedbackID,
    string ItemID,
    string TransactionID,
    CommentTypeCodeTypeCollection CommentTypeList,
    FeedbackTypeCodeType FeedbackType,
    PaginationType Pagination,
    string OrderLineItemID
)
Public Function GetFeedback ( _
    UserID As String, _
    FeedbackID As String, _
    ItemID As String, _
    TransactionID As String, _
    CommentTypeList As CommentTypeCodeTypeCollection, _
    FeedbackType As FeedbackTypeCodeType, _
    Pagination As PaginationType, _
    OrderLineItemID As String _
) As FeedbackDetailTypeCollection
public:
FeedbackDetailTypeCollection^ GetFeedback(
    String^ UserID,
    String^ FeedbackID,
    String^ ItemID,
    String^ TransactionID,
    CommentTypeCodeTypeCollection^ CommentTypeList,
    FeedbackTypeCodeType FeedbackType,
    PaginationType^ Pagination,
    String^ OrderLineItemID
)
Parameters
UserID (String)
The user's eBay User ID is specified in this field. If this field is used, all retrieved Feedback data will be for this eBay user. Specifies the user whose feedback data is to be returned. If this field is omitted in the call request, all retrieved Feedback records will be for the eBay user making the call.
FeedbackID (String)
The unique identifier of a Feedback record. This field is used if the user wants to retrieve a specific Feedback record. If FeedbackID is specified in the call request, all other input fields are ignored.
ItemID (String)
Unique identifier for an eBay item listing. A listing can have multiple order line items, but only one ItemID. If ItemID is specified in the GetFeedback request, the returned Feedback record(s) are restricted to the specified ItemID. The maximum number of Feedback records that can be returned is 100.
TransactionID (String)
Unique identifier for an eBay order line item. A TransactionID can be paired up with its corresponding ItemID and used as an input filter in the GetFeedback request. If an ItemID/TransactionID pair or an OrderLineItemID value is used to retrieve a Feedback record on a specific order line item, the FeedbackType and Pagination fields (if included) are ignored.
CommentTypeList (CommentTypeCodeTypeCollection)
This field is used to retrieve Feedback records of a specific type (Positive, Negative, or Neutral) in FeedbackDetailArray. You can include one or two CommentType fields in the request. If no CommentType value is specified, Feedback records of all types are returned.
FeedbackType (FeedbackTypeCodeType)
This field is used to restrict retrieved Feedback records to those that the user left for other buyers, Feedback records received as a seller, Feedback records received as a buyer, or Feedback records received as a buyer and seller. The default value is FeedbackReceived, so if the FeedbackType field is omitted in the request, all Feedback records received by the user as a buyer and seller are returned in the response. "Feedback Left" data will not be returned in the call response.
Pagination (PaginationType)
Controls the pagination of the result set. Child elements, EntriesPerPage and PageNumber, specify the maximum number of individual feedback records to return per call and which page of data to return. Only applicable if DetailLevel is set to ReturnAll and the call is returning feedback for a UserID. Feedback summary data is not paginated, but when pagination is used, it is returned after the last feedback detail entry. Accepted values for Pagination.EntriesPerPage for GetFeedback is 25 (the default), 50, 100, and 200. If you specify a value of zero, or a value greater than 200, the call fails with an error. If you specify a value between one and twenty-four, the value is rounded up to 25. Values between 26 and 199 that are not one of the accepted values are rounded down to the nearest accepted value.
OrderLineItemID (String)
OrderLineItemID is a unique identifier for an eBay order line item and is based upon the concatenation of ItemID and TransactionID, with a hyphen in between these two IDs. An OrderLineItemID can be used as an input filter in the GetFeedback request. If an OrderLineItemID value is used to retrieve a feedback record on a specific order line item, the FeedbackType and Pagination fields (if included) are ignored.


GetFeedbackCall Constructor

GetFeedbackCall Constructor
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► GetFeedbackCall()()()()
Members
Icon | Member | Description
 | GetFeedbackCall()()()() |
 | GetFeedbackCall(ApiContext) |


GetFeedbackCall Constructor

GetFeedbackCall Constructor
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► GetFeedbackCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetFeedbackCall()
Public Sub New
public:
GetFeedbackCall()


GetFeedbackCall Constructor (ApiContext)

GetFeedbackCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► GetFeedbackCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetFeedbackCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetFeedbackCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► PageNumber
Gets the returned PageNumber of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
public:
property int PageNumber {
    int get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Call ► GetFeedbackCall ► UserID
Gets or sets the UserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetItemCall Class

GetItemCall Class
Namespaces ► eBay.Service.Call ► GetItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemCall()()()() |
 | GetItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetItemRequestType for this API call.
 | ApiResponse | Gets the GetItemResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItem(String, Boolean, Boolean, Boolean, Boolean, String, String, NameValueListTypeCollection, String, Boolean) |
 | GetItem(String) | For backward compatibility with old wrappers.
 | GetItem(String, Boolean) | For backward compatibility with old wrappers.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeCrossPromotion | Gets or sets the IncludeCrossPromotion of type Boolean.
 | IncludeItemCompatibilityList | Gets or sets the IncludeItemCompatibilityList of type Boolean.
 | IncludeItemSpecifics | Gets or sets the IncludeItemSpecifics of type Boolean.
 | IncludeTaxTable | Gets or sets the IncludeTaxTable of type Boolean.
 | IncludeWatchCount | Gets or sets the IncludeWatchCount of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets the returned Item of type ItemType.
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SKU | Gets or sets the SKU of type String.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | VariationSKU | Gets or sets the VariationSKU of type String.
 | VariationSpecificList | Gets or sets the VariationSpecifics of type NameValueListTypeCollection.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetItemCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetItemCall ► ApiRequest
Gets or sets the GetItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetItemRequestType
    Get
    Set
public:
property GetItemRequestType^ ApiRequest {
    GetItemRequestType^ get ();
    void set (GetItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetItemCall ► ApiResponse
Gets the GetItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetItemResponseType
    Get
public:
property GetItemResponseType^ ApiResponse {
    GetItemResponseType^ get ();
}


GetItem Method

GetItem Method
Namespaces ► eBay.Service.Call ► GetItemCall ► GetItem()()()()
Members
Icon | Member | Description
 | GetItem(String, Boolean, Boolean, Boolean, Boolean, String, String, NameValueListTypeCollection, String, Boolean) |
 | GetItem(String) | For backward compatibility with old wrappers.
 | GetItem(String, Boolean) | For backward compatibility with old wrappers.


GetItem Method (ItemID)

GetItem Method (ItemID)
Namespaces ► eBay.Service.Call ► GetItemCall ► GetItem(String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType GetItem(
    string ItemID
)
Public Function GetItem ( _
    ItemID As String _
) As ItemType
public:
ItemType^ GetItem(
    String^ ItemID
)
Parameters
ItemID (String)


GetItem Method (ItemID, IncludeWatchCount)

GetItem Method (ItemID, IncludeWatchCount)
Namespaces ► eBay.Service.Call ► GetItemCall ► GetItem(String, Boolean)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType GetItem(
    string ItemID,
    bool IncludeWatchCount
)
Public Function GetItem ( _
    ItemID As String, _
    IncludeWatchCount As Boolean _
) As ItemType
public:
ItemType^ GetItem(
    String^ ItemID,
    bool IncludeWatchCount
)
Parameters
ItemID (String)
IncludeWatchCount (Boolean)


GetItem Method (ItemID, IncludeWatchCount, IncludeCrossPromotion, IncludeItemSpecifics, IncludeTaxTable, SKU, VariationSKU, VariationSpecificList, TransactionID, IncludeItemCompatibilityList)

GetItem Method (ItemID, IncludeWatchCount, IncludeCrossPromotion, IncludeItemSpecifics, IncludeTaxTable, SKU, VariationSKU, VariationSpecificList, TransactionID, IncludeItemCompatibilityList)
Namespaces ► eBay.Service.Call ► GetItemCall ► GetItem(String, Boolean, Boolean, Boolean, Boolean, String, String, NameValueListTypeCollection, String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public ItemType GetItem(
    string ItemID,
    bool IncludeWatchCount,
    bool IncludeCrossPromotion,
    bool IncludeItemSpecifics,
    bool IncludeTaxTable,
    string SKU,
    string VariationSKU,
    NameValueListTypeCollection VariationSpecificList,
    string TransactionID,
    bool IncludeItemCompatibilityList
)
Public Function GetItem ( _
    ItemID As String, _
    IncludeWatchCount As Boolean, _
    IncludeCrossPromotion As Boolean, _
    IncludeItemSpecifics As Boolean, _
    IncludeTaxTable As Boolean, _
    SKU As String, _
    VariationSKU As String, _
    VariationSpecificList As NameValueListTypeCollection, _
    TransactionID As String, _
    IncludeItemCompatibilityList As Boolean _
) As ItemType
public:
ItemType^ GetItem(
    String^ ItemID,
    bool IncludeWatchCount,
    bool IncludeCrossPromotion,
    bool IncludeItemSpecifics,
    bool IncludeTaxTable,
    String^ SKU,
    String^ VariationSKU,
    NameValueListTypeCollection^ VariationSpecificList,
    String^ TransactionID,
    bool IncludeItemCompatibilityList
)
Parameters
ItemID (String)
IncludeWatchCount (Boolean)
IncludeCrossPromotion (Boolean)
IncludeItemSpecifics (Boolean)
IncludeTaxTable (Boolean)
SKU (String)
VariationSKU (String)
VariationSpecificList (NameValueListTypeCollection)
TransactionID (String)
IncludeItemCompatibilityList (Boolean)


GetItemCall Constructor

GetItemCall Constructor
Namespaces ► eBay.Service.Call ► GetItemCall ► GetItemCall()()()()
Members
Icon | Member | Description
 | GetItemCall()()()() |
 | GetItemCall(ApiContext) |


GetItemCall Constructor

GetItemCall Constructor
Namespaces ► eBay.Service.Call ► GetItemCall ► GetItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemCall()
Public Sub New
public:
GetItemCall()


GetItemCall Constructor (ApiContext)

GetItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetItemCall ► GetItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


IncludeCrossPromotion Property

IncludeCrossPromotion Property
Namespaces ► eBay.Service.Call ► GetItemCall ► IncludeCrossPromotion
Gets or sets the IncludeCrossPromotion of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeCrossPromotion { get; set; }
Public Property IncludeCrossPromotion As Boolean
    Get
    Set
public:
property bool IncludeCrossPromotion {
    bool get ();
    void set (bool value);
}


IncludeItemCompatibilityList Property

IncludeItemCompatibilityList Property
Namespaces ► eBay.Service.Call ► GetItemCall ► IncludeItemCompatibilityList
Gets or sets the IncludeItemCompatibilityList of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeItemCompatibilityList { get; set; }
Public Property IncludeItemCompatibilityList As Boolean
    Get
    Set
public:
property bool IncludeItemCompatibilityList {
    bool get ();
    void set (bool value);
}


IncludeItemSpecifics Property

IncludeItemSpecifics Property
Namespaces ► eBay.Service.Call ► GetItemCall ► IncludeItemSpecifics
Gets or sets the IncludeItemSpecifics of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeItemSpecifics { get; set; }
Public Property IncludeItemSpecifics As Boolean
    Get
    Set
public:
property bool IncludeItemSpecifics {
    bool get ();
    void set (bool value);
}


IncludeTaxTable Property

IncludeTaxTable Property
Namespaces ► eBay.Service.Call ► GetItemCall ► IncludeTaxTable
Gets or sets the IncludeTaxTable of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeTaxTable { get; set; }
Public Property IncludeTaxTable As Boolean
    Get
    Set
public:
property bool IncludeTaxTable {
    bool get ();
    void set (bool value);
}


IncludeWatchCount Property

IncludeWatchCount Property
Namespaces ► eBay.Service.Call ► GetItemCall ► IncludeWatchCount
Gets or sets the IncludeWatchCount of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeWatchCount { get; set; }
Public Property IncludeWatchCount As Boolean
    Get
    Set
public:
property bool IncludeWatchCount {
    bool get ();
    void set (bool value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► GetItemCall ► Item
Gets the returned Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; }
Public ReadOnly Property Item As ItemType
    Get
public:
property ItemType^ Item {
    ItemType^ get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetItemCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Call ► GetItemCall ► SKU
Gets or sets the SKU of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► GetItemCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


VariationSKU Property

VariationSKU Property
Namespaces ► eBay.Service.Call ► GetItemCall ► VariationSKU
Gets or sets the VariationSKU of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string VariationSKU { get; set; }
Public Property VariationSKU As String
    Get
    Set
public:
property String^ VariationSKU {
    String^ get ();
    void set (String^ value);
}


VariationSpecificList Property

VariationSpecificList Property
Namespaces ► eBay.Service.Call ► GetItemCall ► VariationSpecificList
Gets or sets the VariationSpecifics of type NameValueListTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection VariationSpecificList { get; set; }
Public Property VariationSpecificList As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ VariationSpecificList {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


GetItemsAwaitingFeedbackCall Class

GetItemsAwaitingFeedbackCall Class
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetItemsAwaitingFeedbackCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetItemsAwaitingFeedbackCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetItemsAwaitingFeedbackCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemsAwaitingFeedbackCall()()()() |
 | GetItemsAwaitingFeedbackCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetItemsAwaitingFeedbackRequestType for this API call.
 | ApiResponse | Gets the GetItemsAwaitingFeedbackResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItemsAwaitingFeedback(ItemSortTypeCodeType, PaginationType) | This is the base request type of the GetItemsAwaitingFeedback call. This call retrieves all completed order line items for which the user (buyer or seller) still needs to leave Feedback for their order partner.
 | GetItemsAwaitingFeedback(PaginationType) | For backward compatibility with old wrappers.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemsAwaitingFeedback | Gets the returned ItemsAwaitingFeedback of type PaginatedTransactionArrayType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Sort | Gets or sets the Sort of type ItemSortTypeCodeType.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetItemsAwaitingFeedbackCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► ApiRequest
Gets or sets the GetItemsAwaitingFeedbackRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetItemsAwaitingFeedbackRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetItemsAwaitingFeedbackRequestType
    Get
    Set
public:
property GetItemsAwaitingFeedbackRequestType^ ApiRequest {
    GetItemsAwaitingFeedbackRequestType^ get ();
    void set (GetItemsAwaitingFeedbackRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► ApiResponse
Gets the GetItemsAwaitingFeedbackResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetItemsAwaitingFeedbackResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetItemsAwaitingFeedbackResponseType
    Get
public:
property GetItemsAwaitingFeedbackResponseType^ ApiResponse {
    GetItemsAwaitingFeedbackResponseType^ get ();
}


GetItemsAwaitingFeedback Method

GetItemsAwaitingFeedback Method
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► GetItemsAwaitingFeedback()()()()
Members
Icon | Member | Description
 | GetItemsAwaitingFeedback(ItemSortTypeCodeType, PaginationType) | This is the base request type of the GetItemsAwaitingFeedback call. This call retrieves all completed order line items for which the user (buyer or seller) still needs to leave Feedback for their order partner.
 | GetItemsAwaitingFeedback(PaginationType) | For backward compatibility with old wrappers.


GetItemsAwaitingFeedback Method (Pagination)

GetItemsAwaitingFeedback Method (Pagination)
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► GetItemsAwaitingFeedback(PaginationType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedTransactionArrayType GetItemsAwaitingFeedback(
    PaginationType Pagination
)
Public Function GetItemsAwaitingFeedback ( _
    Pagination As PaginationType _
) As PaginatedTransactionArrayType
public:
PaginatedTransactionArrayType^ GetItemsAwaitingFeedback(
    PaginationType^ Pagination
)
Parameters
Pagination (PaginationType)


GetItemsAwaitingFeedback Method (Sort, Pagination)

GetItemsAwaitingFeedback Method (Sort, Pagination)
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► GetItemsAwaitingFeedback(ItemSortTypeCodeType, PaginationType)
This is the base request type of the GetItemsAwaitingFeedback call. This call retrieves all completed order line items for which the user (buyer or seller) still needs to leave Feedback for their order partner.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedTransactionArrayType GetItemsAwaitingFeedback(
    ItemSortTypeCodeType Sort,
    PaginationType Pagination
)
Public Function GetItemsAwaitingFeedback ( _
    Sort As ItemSortTypeCodeType, _
    Pagination As PaginationType _
) As PaginatedTransactionArrayType
public:
PaginatedTransactionArrayType^ GetItemsAwaitingFeedback(
    ItemSortTypeCodeType Sort,
    PaginationType^ Pagination
)
Parameters
Sort (ItemSortTypeCodeType)
This field allows the user to control how the order line items are returned in the response. Valid values are:

EndTime
EndTimeDescending
FeedbackLeft
FeedbackLeftDescending
FeedbackReceived
FeedbackReceivedDescending
Title
TitleDescending
UserID
UserIDDescending

The user can read the ItemSortTypeCodeType definition for more information on these sort values.
Pagination (PaginationType)
This container can be used if the user only wants to see a subset of order line item results. In this container, the user will specify the number of order line items to return per page of data, and will specify the specific page of data they want to view with each call.


GetItemsAwaitingFeedbackCall Constructor

GetItemsAwaitingFeedbackCall Constructor
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► GetItemsAwaitingFeedbackCall()()()()
Members
Icon | Member | Description
 | GetItemsAwaitingFeedbackCall()()()() |
 | GetItemsAwaitingFeedbackCall(ApiContext) |


GetItemsAwaitingFeedbackCall Constructor

GetItemsAwaitingFeedbackCall Constructor
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► GetItemsAwaitingFeedbackCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemsAwaitingFeedbackCall()
Public Sub New
public:
GetItemsAwaitingFeedbackCall()


GetItemsAwaitingFeedbackCall Constructor (ApiContext)

GetItemsAwaitingFeedbackCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► GetItemsAwaitingFeedbackCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetItemsAwaitingFeedbackCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetItemsAwaitingFeedbackCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ItemsAwaitingFeedback Property

ItemsAwaitingFeedback Property
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► ItemsAwaitingFeedback
Gets the returned ItemsAwaitingFeedback of type PaginatedTransactionArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedTransactionArrayType ItemsAwaitingFeedback { get; }
Public ReadOnly Property ItemsAwaitingFeedback As PaginatedTransactionArrayType
    Get
public:
property PaginatedTransactionArrayType^ ItemsAwaitingFeedback {
    PaginatedTransactionArrayType^ get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


Sort Property

Sort Property
Namespaces ► eBay.Service.Call ► GetItemsAwaitingFeedbackCall ► Sort
Gets or sets the Sort of type ItemSortTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemSortTypeCodeType Sort { get; set; }
Public Property Sort As ItemSortTypeCodeType
    Get
    Set
public:
property ItemSortTypeCodeType Sort {
    ItemSortTypeCodeType get ();
    void set (ItemSortTypeCodeType value);
}


GetItemShippingCall Class

GetItemShippingCall Class
Namespaces ► eBay.Service.Call ► GetItemShippingCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetItemShippingCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetItemShippingCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetItemShippingCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemShippingCall()()()() |
 | GetItemShippingCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetItemShippingRequestType for this API call.
 | ApiResponse | Gets the GetItemShippingResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DestinationCountryCode | Gets or sets the DestinationCountryCode of type CountryCodeType.
 | DestinationPostalCode | Gets or sets the DestinationPostalCode of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItemShipping(String, Int32, String, CountryCodeType) |
 | GetItemShipping(String, String) | For backward compatibility with old wrappers.
 | GetItemShipping(String, String, CountryCodeType) | For backward compatibility with old wrappers.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PickUpInStoreDetails | Gets the returned PickUpInStoreDetails of type PickupInStoreDetailsType.
 | QuantitySold | Gets or sets the QuantitySold of type Int32.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ShippingDetails | Gets the returned ShippingDetails of type ShippingDetailsType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetItemShippingCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► ApiRequest
Gets or sets the GetItemShippingRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetItemShippingRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetItemShippingRequestType
    Get
    Set
public:
property GetItemShippingRequestType^ ApiRequest {
    GetItemShippingRequestType^ get ();
    void set (GetItemShippingRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► ApiResponse
Gets the GetItemShippingResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetItemShippingResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetItemShippingResponseType
    Get
public:
property GetItemShippingResponseType^ ApiResponse {
    GetItemShippingResponseType^ get ();
}


DestinationCountryCode Property

DestinationCountryCode Property
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► DestinationCountryCode
Gets or sets the DestinationCountryCode of type CountryCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType DestinationCountryCode { get; set; }
Public Property DestinationCountryCode As CountryCodeType
    Get
    Set
public:
property CountryCodeType DestinationCountryCode {
    CountryCodeType get ();
    void set (CountryCodeType value);
}


DestinationPostalCode Property

DestinationPostalCode Property
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► DestinationPostalCode
Gets or sets the DestinationPostalCode of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string DestinationPostalCode { get; set; }
Public Property DestinationPostalCode As String
    Get
    Set
public:
property String^ DestinationPostalCode {
    String^ get ();
    void set (String^ value);
}


GetItemShipping Method

GetItemShipping Method
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► GetItemShipping()()()()
Members
Icon | Member | Description
 | GetItemShipping(String, Int32, String, CountryCodeType) |
 | GetItemShipping(String, String) | For backward compatibility with old wrappers.
 | GetItemShipping(String, String, CountryCodeType) | For backward compatibility with old wrappers.


GetItemShipping Method (ItemID, DestinationPostalCode)

GetItemShipping Method (ItemID, DestinationPostalCode)
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► GetItemShipping(String, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingDetailsType GetItemShipping(
    string ItemID,
    string DestinationPostalCode
)
Public Function GetItemShipping ( _
    ItemID As String, _
    DestinationPostalCode As String _
) As ShippingDetailsType
public:
ShippingDetailsType^ GetItemShipping(
    String^ ItemID,
    String^ DestinationPostalCode
)
Parameters
ItemID (String)
DestinationPostalCode (String)


GetItemShipping Method (ItemID, DestinationPostalCode, DestinationCountryCode)

GetItemShipping Method (ItemID, DestinationPostalCode, DestinationCountryCode)
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► GetItemShipping(String, String, CountryCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingDetailsType GetItemShipping(
    string ItemID,
    string DestinationPostalCode,
    CountryCodeType DestinationCountryCode
)
Public Function GetItemShipping ( _
    ItemID As String, _
    DestinationPostalCode As String, _
    DestinationCountryCode As CountryCodeType _
) As ShippingDetailsType
public:
ShippingDetailsType^ GetItemShipping(
    String^ ItemID,
    String^ DestinationPostalCode,
    CountryCodeType DestinationCountryCode
)
Parameters
ItemID (String)
DestinationPostalCode (String)
DestinationCountryCode (CountryCodeType)


GetItemShipping Method (ItemID, QuantitySold, DestinationPostalCode, DestinationCountryCode)

GetItemShipping Method (ItemID, QuantitySold, DestinationPostalCode, DestinationCountryCode)
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► GetItemShipping(String, Int32, String, CountryCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingDetailsType GetItemShipping(
    string ItemID,
    int QuantitySold,
    string DestinationPostalCode,
    CountryCodeType DestinationCountryCode
)
Public Function GetItemShipping ( _
    ItemID As String, _
    QuantitySold As Integer, _
    DestinationPostalCode As String, _
    DestinationCountryCode As CountryCodeType _
) As ShippingDetailsType
public:
ShippingDetailsType^ GetItemShipping(
    String^ ItemID,
    int QuantitySold,
    String^ DestinationPostalCode,
    CountryCodeType DestinationCountryCode
)
Parameters
ItemID (String)
QuantitySold (Int32)
DestinationPostalCode (String)
DestinationCountryCode (CountryCodeType)


GetItemShippingCall Constructor

GetItemShippingCall Constructor
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► GetItemShippingCall()()()()
Members
Icon | Member | Description
 | GetItemShippingCall()()()() |
 | GetItemShippingCall(ApiContext) |


GetItemShippingCall Constructor

GetItemShippingCall Constructor
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► GetItemShippingCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemShippingCall()
Public Sub New
public:
GetItemShippingCall()


GetItemShippingCall Constructor (ApiContext)

GetItemShippingCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► GetItemShippingCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetItemShippingCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetItemShippingCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


PickUpInStoreDetails Property

PickUpInStoreDetails Property
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► PickUpInStoreDetails
Gets the returned PickUpInStoreDetails of type PickupInStoreDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public PickupInStoreDetailsType PickUpInStoreDetails { get; }
Public ReadOnly Property PickUpInStoreDetails As PickupInStoreDetailsType
    Get
public:
property PickupInStoreDetailsType^ PickUpInStoreDetails {
    PickupInStoreDetailsType^ get ();
}


QuantitySold Property

QuantitySold Property
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► QuantitySold
Gets or sets the QuantitySold of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int QuantitySold { get; set; }
Public Property QuantitySold As Integer
    Get
    Set
public:
property int QuantitySold {
    int get ();
    void set (int value);
}


ShippingDetails Property

ShippingDetails Property
Namespaces ► eBay.Service.Call ► GetItemShippingCall ► ShippingDetails
Gets the returned ShippingDetails of type ShippingDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingDetailsType ShippingDetails { get; }
Public ReadOnly Property ShippingDetails As ShippingDetailsType
    Get
public:
property ShippingDetailsType^ ShippingDetails {
    ShippingDetailsType^ get ();
}


GetItemTransactionsCall Class

GetItemTransactionsCall Class
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetItemTransactionsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetItemTransactionsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetItemTransactionsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemTransactionsCall()()()() |
 | GetItemTransactionsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetItemTransactionsRequestType for this API call.
 | ApiResponse | Gets the GetItemTransactionsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItemTransactions(String, DateTime, DateTime, String, PaginationType, Boolean, Boolean, TransactionPlatformCodeType, Int32, Boolean, String) |
 | GetItemTransactions(String, TimeFilter) | For backward compatibility with old wrappers.
 | GetItemTransactions(String, DateTime, DateTime) | For backward compatibility with old wrappers.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasMoreTransactions | Gets the returned HasMoreTransactions of type Boolean.
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeContainingOrder | Gets or sets the IncludeContainingOrder of type Boolean.
 | IncludeFinalValueFee | Gets or sets the IncludeFinalValueFee of type Boolean.
 | IncludeVariations | Gets or sets the IncludeVariations of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets the returned Item of type ItemType.
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModTimeFilter | Gets or sets the ModTimeFrom and ModTimeTo of type ModTimeFilter.
 | ModTimeFrom | Gets or sets the ModTimeFrom of type DateTime.
 | ModTimeTo | Gets or sets the ModTimeTo of type DateTime.
 | NumberOfDays | Gets or sets the NumberOfDays of type Int32.
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | PageNumber | Gets the returned PageNumber of type Int32.
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | PayPalPreferred | Gets the returned PayPalPreferred of type Boolean.
 | Platform | Gets or sets the Platform of type TransactionPlatformCodeType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReturnedTransactionCountActual | Gets the returned ReturnedTransactionCountActual of type Int32.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | TransactionList | Gets the returned TransactionArray of type TransactionTypeCollection.
 | TransactionsPerPage | Gets the returned TransactionsPerPage of type Int32.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetItemTransactionsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► ApiRequest
Gets or sets the GetItemTransactionsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetItemTransactionsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetItemTransactionsRequestType
    Get
    Set
public:
property GetItemTransactionsRequestType^ ApiRequest {
    GetItemTransactionsRequestType^ get ();
    void set (GetItemTransactionsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► ApiResponse
Gets the GetItemTransactionsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetItemTransactionsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetItemTransactionsResponseType
    Get
public:
property GetItemTransactionsResponseType^ ApiResponse {
    GetItemTransactionsResponseType^ get ();
}


GetItemTransactions Method

GetItemTransactions Method
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► GetItemTransactions()()()()
Members
Icon | Member | Description
 | GetItemTransactions(String, DateTime, DateTime, String, PaginationType, Boolean, Boolean, TransactionPlatformCodeType, Int32, Boolean, String) |
 | GetItemTransactions(String, TimeFilter) | For backward compatibility with old wrappers.
 | GetItemTransactions(String, DateTime, DateTime) | For backward compatibility with old wrappers.


GetItemTransactions Method (ItemID, ModTimeFilter)

GetItemTransactions Method (ItemID, ModTimeFilter)
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► GetItemTransactions(String, TimeFilter)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection GetItemTransactions(
    string ItemID,
    TimeFilter ModTimeFilter
)
Public Function GetItemTransactions ( _
    ItemID As String, _
    ModTimeFilter As TimeFilter _
) As TransactionTypeCollection
public:
TransactionTypeCollection^ GetItemTransactions(
    String^ ItemID,
    TimeFilter^ ModTimeFilter
)
Parameters
ItemID (String)
ModTimeFilter (TimeFilter)


GetItemTransactions Method (ItemID, ModTimeFrom, ModTimeTo, TransactionID, Pagination, IncludeFinalValueFee, IncludeContainingOrder, Platform, NumberOfDays, IncludeVariations, OrderLineItemID)

GetItemTransactions Method (ItemID, ModTimeFrom, ModTimeTo, TransactionID, Pagination, IncludeFinalValueFee, IncludeContainingOrder, Platform, NumberOfDays, IncludeVariations, OrderLineItemID)
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► GetItemTransactions(String, DateTime, DateTime, String, PaginationType, Boolean, Boolean, TransactionPlatformCodeType, Int32, Boolean, String)
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection GetItemTransactions(
    string ItemID,
    DateTime ModTimeFrom,
    DateTime ModTimeTo,
    string TransactionID,
    PaginationType Pagination,
    bool IncludeFinalValueFee,
    bool IncludeContainingOrder,
    TransactionPlatformCodeType Platform,
    int NumberOfDays,
    bool IncludeVariations,
    string OrderLineItemID
)
Public Function GetItemTransactions ( _
    ItemID As String, _
    ModTimeFrom As DateTime, _
    ModTimeTo As DateTime, _
    TransactionID As String, _
    Pagination As PaginationType, _
    IncludeFinalValueFee As Boolean, _
    IncludeContainingOrder As Boolean, _
    Platform As TransactionPlatformCodeType, _
    NumberOfDays As Integer, _
    IncludeVariations As Boolean, _
    OrderLineItemID As String _
) As TransactionTypeCollection
public:
TransactionTypeCollection^ GetItemTransactions(
    String^ ItemID,
    DateTime ModTimeFrom,
    DateTime ModTimeTo,
    String^ TransactionID,
    PaginationType^ Pagination,
    bool IncludeFinalValueFee,
    bool IncludeContainingOrder,
    TransactionPlatformCodeType Platform,
    int NumberOfDays,
    bool IncludeVariations,
    String^ OrderLineItemID
)
Parameters
ItemID (String)
ModTimeFrom (DateTime)
ModTimeTo (DateTime)
TransactionID (String)
Pagination (PaginationType)
IncludeFinalValueFee (Boolean)
IncludeContainingOrder (Boolean)
Platform (TransactionPlatformCodeType)
NumberOfDays (Int32)
IncludeVariations (Boolean)
OrderLineItemID (String)


GetItemTransactions Method (ItemID, TimeFrom, TimeTo)

GetItemTransactions Method (ItemID, TimeFrom, TimeTo)
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► GetItemTransactions(String, DateTime, DateTime)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection GetItemTransactions(
    string ItemID,
    DateTime TimeFrom,
    DateTime TimeTo
)
Public Function GetItemTransactions ( _
    ItemID As String, _
    TimeFrom As DateTime, _
    TimeTo As DateTime _
) As TransactionTypeCollection
public:
TransactionTypeCollection^ GetItemTransactions(
    String^ ItemID,
    DateTime TimeFrom,
    DateTime TimeTo
)
Parameters
ItemID (String)
TimeFrom (DateTime)
TimeTo (DateTime)


GetItemTransactionsCall Constructor

GetItemTransactionsCall Constructor
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► GetItemTransactionsCall()()()()
Members
Icon | Member | Description
 | GetItemTransactionsCall()()()() |
 | GetItemTransactionsCall(ApiContext) |


GetItemTransactionsCall Constructor

GetItemTransactionsCall Constructor
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► GetItemTransactionsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemTransactionsCall()
Public Sub New
public:
GetItemTransactionsCall()


GetItemTransactionsCall Constructor (ApiContext)

GetItemTransactionsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► GetItemTransactionsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetItemTransactionsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetItemTransactionsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HasMoreTransactions Property

HasMoreTransactions Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► HasMoreTransactions
Gets the returned HasMoreTransactions of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreTransactions { get; }
Public ReadOnly Property HasMoreTransactions As Boolean
    Get
public:
property bool HasMoreTransactions {
    bool get ();
}


IncludeContainingOrder Property

IncludeContainingOrder Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► IncludeContainingOrder
Gets or sets the IncludeContainingOrder of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeContainingOrder { get; set; }
Public Property IncludeContainingOrder As Boolean
    Get
    Set
public:
property bool IncludeContainingOrder {
    bool get ();
    void set (bool value);
}


IncludeFinalValueFee Property

IncludeFinalValueFee Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► IncludeFinalValueFee
Gets or sets the IncludeFinalValueFee of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFee { get; set; }
Public Property IncludeFinalValueFee As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFee {
    bool get ();
    void set (bool value);
}


IncludeVariations Property

IncludeVariations Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► IncludeVariations
Gets or sets the IncludeVariations of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeVariations { get; set; }
Public Property IncludeVariations As Boolean
    Get
    Set
public:
property bool IncludeVariations {
    bool get ();
    void set (bool value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► Item
Gets the returned Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; }
Public ReadOnly Property Item As ItemType
    Get
public:
property ItemType^ Item {
    ItemType^ get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ModTimeFilter Property

ModTimeFilter Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► ModTimeFilter
Gets or sets the ModTimeFrom and ModTimeTo of type ModTimeFilter.
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter ModTimeFilter { get; set; }
Public Property ModTimeFilter As TimeFilter
    Get
    Set
public:
property TimeFilter^ ModTimeFilter {
    TimeFilter^ get ();
    void set (TimeFilter^ value);
}


ModTimeFrom Property

ModTimeFrom Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► ModTimeFrom
Gets or sets the ModTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeFrom { get; set; }
Public Property ModTimeFrom As DateTime
    Get
    Set
public:
property DateTime ModTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


ModTimeTo Property

ModTimeTo Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► ModTimeTo
Gets or sets the ModTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeTo { get; set; }
Public Property ModTimeTo As DateTime
    Get
    Set
public:
property DateTime ModTimeTo {
    DateTime get ();
    void set (DateTime value);
}


NumberOfDays Property

NumberOfDays Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► NumberOfDays
Gets or sets the NumberOfDays of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfDays { get; set; }
Public Property NumberOfDays As Integer
    Get
    Set
public:
property int NumberOfDays {
    int get ();
    void set (int value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► PageNumber
Gets the returned PageNumber of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
public:
property int PageNumber {
    int get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


PayPalPreferred Property

PayPalPreferred Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► PayPalPreferred
Gets the returned PayPalPreferred of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalPreferred { get; }
Public ReadOnly Property PayPalPreferred As Boolean
    Get
public:
property bool PayPalPreferred {
    bool get ();
}


Platform Property

Platform Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► Platform
Gets or sets the Platform of type TransactionPlatformCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeType Platform { get; set; }
Public Property Platform As TransactionPlatformCodeType
    Get
    Set
public:
property TransactionPlatformCodeType Platform {
    TransactionPlatformCodeType get ();
    void set (TransactionPlatformCodeType value);
}


ReturnedTransactionCountActual Property

ReturnedTransactionCountActual Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► ReturnedTransactionCountActual
Gets the returned ReturnedTransactionCountActual of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int ReturnedTransactionCountActual { get; }
Public ReadOnly Property ReturnedTransactionCountActual As Integer
    Get
public:
property int ReturnedTransactionCountActual {
    int get ();
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


TransactionList Property

TransactionList Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► TransactionList
Gets the returned TransactionArray of type TransactionTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection TransactionList { get; }
Public ReadOnly Property TransactionList As TransactionTypeCollection
    Get
public:
property TransactionTypeCollection^ TransactionList {
    TransactionTypeCollection^ get ();
}


TransactionsPerPage Property

TransactionsPerPage Property
Namespaces ► eBay.Service.Call ► GetItemTransactionsCall ► TransactionsPerPage
Gets the returned TransactionsPerPage of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int TransactionsPerPage { get; }
Public ReadOnly Property TransactionsPerPage As Integer
    Get
public:
property int TransactionsPerPage {
    int get ();
}


GetMemberMessagesCall Class

GetMemberMessagesCall Class
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetMemberMessagesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetMemberMessagesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetMemberMessagesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMemberMessagesCall()()()() |
 | GetMemberMessagesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetMemberMessagesRequestType for this API call.
 | ApiResponse | Gets the GetMemberMessagesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CreateTimeFilter | Gets or sets the StartCreationTime and EndCreationTime of type TimeFilter.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DisplayToPublic | Gets or sets the DisplayToPublic of type Boolean.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndCreationTime | Gets or sets the EndCreationTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetMemberMessages(String, MessageTypeCodeType, MessageStatusTypeCodeType, Boolean, DateTime, DateTime, PaginationType, String, String) | Retrieves a list of the messages buyers have posted about your active item listings.
 | GetMemberMessages(String, MessageTypeCodeType, MessageStatusTypeCodeType) | For backward compatibility with old wrappers.
 | GetMemberMessages(TimeFilter, MessageTypeCodeType, MessageStatusTypeCodeType) | For backward compatibility with old wrappers.
 | GetMemberMessages(DateTime, DateTime, MessageTypeCodeType, MessageStatusTypeCodeType) | For backward compatibility with old wrappers.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasMoreItems | Gets the returned HasMoreItems of type Boolean.
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MailMessageType | Gets or sets the MailMessageType of type MessageTypeCodeType.
 | MemberMessageID | Gets or sets the MemberMessageID of type String.
 | MemberMessageList | Gets the returned MemberMessage of type MemberMessageExchangeTypeCollection.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageStatus | Gets or sets the MessageStatus of type MessageStatusTypeCodeType.
 | OutputSelector | (Inherited from ApiCall.)
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SenderID | Gets or sets the SenderID of type String.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartCreationTime | Gets or sets the StartCreationTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetMemberMessagesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► ApiRequest
Gets or sets the GetMemberMessagesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMemberMessagesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetMemberMessagesRequestType
    Get
    Set
public:
property GetMemberMessagesRequestType^ ApiRequest {
    GetMemberMessagesRequestType^ get ();
    void set (GetMemberMessagesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► ApiResponse
Gets the GetMemberMessagesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMemberMessagesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetMemberMessagesResponseType
    Get
public:
property GetMemberMessagesResponseType^ ApiResponse {
    GetMemberMessagesResponseType^ get ();
}


CreateTimeFilter Property

CreateTimeFilter Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► CreateTimeFilter
Gets or sets the StartCreationTime and EndCreationTime of type TimeFilter.
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter CreateTimeFilter { get; set; }
Public Property CreateTimeFilter As TimeFilter
    Get
    Set
public:
property TimeFilter^ CreateTimeFilter {
    TimeFilter^ get ();
    void set (TimeFilter^ value);
}


DisplayToPublic Property

DisplayToPublic Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► DisplayToPublic
Gets or sets the DisplayToPublic of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayToPublic { get; set; }
Public Property DisplayToPublic As Boolean
    Get
    Set
public:
property bool DisplayToPublic {
    bool get ();
    void set (bool value);
}


EndCreationTime Property

EndCreationTime Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► EndCreationTime
Gets or sets the EndCreationTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndCreationTime { get; set; }
Public Property EndCreationTime As DateTime
    Get
    Set
public:
property DateTime EndCreationTime {
    DateTime get ();
    void set (DateTime value);
}


GetMemberMessages Method

GetMemberMessages Method
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► GetMemberMessages()()()()
Members
Icon | Member | Description
 | GetMemberMessages(String, MessageTypeCodeType, MessageStatusTypeCodeType, Boolean, DateTime, DateTime, PaginationType, String, String) | Retrieves a list of the messages buyers have posted about your active item listings.
 | GetMemberMessages(String, MessageTypeCodeType, MessageStatusTypeCodeType) | For backward compatibility with old wrappers.
 | GetMemberMessages(TimeFilter, MessageTypeCodeType, MessageStatusTypeCodeType) | For backward compatibility with old wrappers.
 | GetMemberMessages(DateTime, DateTime, MessageTypeCodeType, MessageStatusTypeCodeType) | For backward compatibility with old wrappers.


GetMemberMessages Method (CreateTimeFilter, MailMessageType, MessageStatus)

GetMemberMessages Method (CreateTimeFilter, MailMessageType, MessageStatus)
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► GetMemberMessages(TimeFilter, MessageTypeCodeType, MessageStatusTypeCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeTypeCollection GetMemberMessages(
    TimeFilter CreateTimeFilter,
    MessageTypeCodeType MailMessageType,
    MessageStatusTypeCodeType MessageStatus
)
Public Function GetMemberMessages ( _
    CreateTimeFilter As TimeFilter, _
    MailMessageType As MessageTypeCodeType, _
    MessageStatus As MessageStatusTypeCodeType _
) As MemberMessageExchangeTypeCollection
public:
MemberMessageExchangeTypeCollection^ GetMemberMessages(
    TimeFilter^ CreateTimeFilter,
    MessageTypeCodeType MailMessageType,
    MessageStatusTypeCodeType MessageStatus
)
Parameters
CreateTimeFilter (TimeFilter)
MailMessageType (MessageTypeCodeType)
MessageStatus (MessageStatusTypeCodeType)


GetMemberMessages Method (ItemID, MailMessageType, MessageStatus)

GetMemberMessages Method (ItemID, MailMessageType, MessageStatus)
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► GetMemberMessages(String, MessageTypeCodeType, MessageStatusTypeCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeTypeCollection GetMemberMessages(
    string ItemID,
    MessageTypeCodeType MailMessageType,
    MessageStatusTypeCodeType MessageStatus
)
Public Function GetMemberMessages ( _
    ItemID As String, _
    MailMessageType As MessageTypeCodeType, _
    MessageStatus As MessageStatusTypeCodeType _
) As MemberMessageExchangeTypeCollection
public:
MemberMessageExchangeTypeCollection^ GetMemberMessages(
    String^ ItemID,
    MessageTypeCodeType MailMessageType,
    MessageStatusTypeCodeType MessageStatus
)
Parameters
ItemID (String)
MailMessageType (MessageTypeCodeType)
MessageStatus (MessageStatusTypeCodeType)


GetMemberMessages Method (ItemID, MailMessageType, MessageStatus, DisplayToPublic, StartCreationTime, EndCreationTime, Pagination, MemberMessageID, SenderID)

GetMemberMessages Method (ItemID, MailMessageType, MessageStatus, DisplayToPublic, StartCreationTime, EndCreationTime, Pagination, MemberMessageID, SenderID)
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► GetMemberMessages(String, MessageTypeCodeType, MessageStatusTypeCodeType, Boolean, DateTime, DateTime, PaginationType, String, String)
Retrieves a list of the messages buyers have posted about your active item listings.
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeTypeCollection GetMemberMessages(
    string ItemID,
    MessageTypeCodeType MailMessageType,
    MessageStatusTypeCodeType MessageStatus,
    bool DisplayToPublic,
    DateTime StartCreationTime,
    DateTime EndCreationTime,
    PaginationType Pagination,
    string MemberMessageID,
    string SenderID
)
Public Function GetMemberMessages ( _
    ItemID As String, _
    MailMessageType As MessageTypeCodeType, _
    MessageStatus As MessageStatusTypeCodeType, _
    DisplayToPublic As Boolean, _
    StartCreationTime As DateTime, _
    EndCreationTime As DateTime, _
    Pagination As PaginationType, _
    MemberMessageID As String, _
    SenderID As String _
) As MemberMessageExchangeTypeCollection
public:
MemberMessageExchangeTypeCollection^ GetMemberMessages(
    String^ ItemID,
    MessageTypeCodeType MailMessageType,
    MessageStatusTypeCodeType MessageStatus,
    bool DisplayToPublic,
    DateTime StartCreationTime,
    DateTime EndCreationTime,
    PaginationType^ Pagination,
    String^ MemberMessageID,
    String^ SenderID
)
Parameters
ItemID (String)
The ID of the item the message is about. For Ask Seller a Question (ASQ) messages, either the ItemID, or a date range (specified with StartCreationTime and EndCreationTime), or both must be included. ItemID is otherwise ignored.
MailMessageType (MessageTypeCodeType)
The type of message. Note that GetMemberMessages does not return messages when this field is set to AskSellerQuestion.
MessageStatus (MessageStatusTypeCodeType)
The status of the message.
DisplayToPublic (Boolean)
If included in the request and set to
true
, only public messages (viewable in the Item listing) are returned. If omitted or set to
false
in the request, all messages (that match other filters in the request) are returned in the response.
StartCreationTime (DateTime)
Used as beginning of date range filter. If specified, filters the returned messages to only those with a creation date greater than or equal to the specified date and time. For Contact eBay Member (CEM) messages, StartCreationTime and EndCreationTime must be provided. For Ask Seller a Question (ASQ) messages, either the ItemID, or a date range (specified with StartCreationTime and EndCreationTime), or both must be included.
EndCreationTime (DateTime)
Used as end of date range filter. If specified, filters the returned messages to only those with a creation date less than or equal to the specified date and time. For Contact eBay Member (CEM) messages, StartCreationTime and EndCreationTime must be provided. For Ask Seller a Question (ASQ) messages, either the ItemID, or a date range (specified with StartCreationTime and EndCreationTime), or both must be included.
Pagination (PaginationType)
Standard pagination argument used to reduce response.
MemberMessageID (String)
An ID that uniquely identifies the message for a given user to be retrieved. Used for the AskSellerQuestion notification only.
SenderID (String)
An eBay ID that uniquely identifies a user. For GetMemberMessages, this is the sender of the message. If included in the request, returns only messages from the specified sender.


GetMemberMessages Method (TimeFrom, TimeTo, MailMessageType, MessageStatus)

GetMemberMessages Method (TimeFrom, TimeTo, MailMessageType, MessageStatus)
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► GetMemberMessages(DateTime, DateTime, MessageTypeCodeType, MessageStatusTypeCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeTypeCollection GetMemberMessages(
    DateTime TimeFrom,
    DateTime TimeTo,
    MessageTypeCodeType MailMessageType,
    MessageStatusTypeCodeType MessageStatus
)
Public Function GetMemberMessages ( _
    TimeFrom As DateTime, _
    TimeTo As DateTime, _
    MailMessageType As MessageTypeCodeType, _
    MessageStatus As MessageStatusTypeCodeType _
) As MemberMessageExchangeTypeCollection
public:
MemberMessageExchangeTypeCollection^ GetMemberMessages(
    DateTime TimeFrom,
    DateTime TimeTo,
    MessageTypeCodeType MailMessageType,
    MessageStatusTypeCodeType MessageStatus
)
Parameters
TimeFrom (DateTime)
TimeTo (DateTime)
MailMessageType (MessageTypeCodeType)
MessageStatus (MessageStatusTypeCodeType)


GetMemberMessagesCall Constructor

GetMemberMessagesCall Constructor
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► GetMemberMessagesCall()()()()
Members
Icon | Member | Description
 | GetMemberMessagesCall()()()() |
 | GetMemberMessagesCall(ApiContext) |


GetMemberMessagesCall Constructor

GetMemberMessagesCall Constructor
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► GetMemberMessagesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMemberMessagesCall()
Public Sub New
public:
GetMemberMessagesCall()


GetMemberMessagesCall Constructor (ApiContext)

GetMemberMessagesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► GetMemberMessagesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetMemberMessagesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetMemberMessagesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HasMoreItems Property

HasMoreItems Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► HasMoreItems
Gets the returned HasMoreItems of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreItems { get; }
Public ReadOnly Property HasMoreItems As Boolean
    Get
public:
property bool HasMoreItems {
    bool get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MailMessageType Property

MailMessageType Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► MailMessageType
Gets or sets the MailMessageType of type MessageTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public MessageTypeCodeType MailMessageType { get; set; }
Public Property MailMessageType As MessageTypeCodeType
    Get
    Set
public:
property MessageTypeCodeType MailMessageType {
    MessageTypeCodeType get ();
    void set (MessageTypeCodeType value);
}


MemberMessageID Property

MemberMessageID Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► MemberMessageID
Gets or sets the MemberMessageID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string MemberMessageID { get; set; }
Public Property MemberMessageID As String
    Get
    Set
public:
property String^ MemberMessageID {
    String^ get ();
    void set (String^ value);
}


MemberMessageList Property

MemberMessageList Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► MemberMessageList
Gets the returned MemberMessage of type MemberMessageExchangeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeTypeCollection MemberMessageList { get; }
Public ReadOnly Property MemberMessageList As MemberMessageExchangeTypeCollection
    Get
public:
property MemberMessageExchangeTypeCollection^ MemberMessageList {
    MemberMessageExchangeTypeCollection^ get ();
}


MessageStatus Property

MessageStatus Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► MessageStatus
Gets or sets the MessageStatus of type MessageStatusTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public MessageStatusTypeCodeType MessageStatus { get; set; }
Public Property MessageStatus As MessageStatusTypeCodeType
    Get
    Set
public:
property MessageStatusTypeCodeType MessageStatus {
    MessageStatusTypeCodeType get ();
    void set (MessageStatusTypeCodeType value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


SenderID Property

SenderID Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► SenderID
Gets or sets the SenderID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SenderID { get; set; }
Public Property SenderID As String
    Get
    Set
public:
property String^ SenderID {
    String^ get ();
    void set (String^ value);
}


StartCreationTime Property

StartCreationTime Property
Namespaces ► eBay.Service.Call ► GetMemberMessagesCall ► StartCreationTime
Gets or sets the StartCreationTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartCreationTime { get; set; }
Public Property StartCreationTime As DateTime
    Get
    Set
public:
property DateTime StartCreationTime {
    DateTime get ();
    void set (DateTime value);
}


GetMessagePreferencesCall Class

GetMessagePreferencesCall Class
Namespaces ► eBay.Service.Call ► GetMessagePreferencesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetMessagePreferencesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetMessagePreferencesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetMessagePreferencesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMessagePreferencesCall()()()() |
 | GetMessagePreferencesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetMessagePreferencesRequestType for this API call.
 | ApiResponse | Gets the GetMessagePreferencesResponseType for this API call.
 | ASQPreferences | Gets the returned ASQPreferences of type ASQPreferencesType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetMessagePreferences(String, Boolean) | Returns a seller's Ask Seller a Question (ASQ) subjects, each in its own Subject node.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeASQPreferences | Gets or sets the IncludeASQPreferences of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellerID | Gets or sets the SellerID of type String.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetMessagePreferencesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetMessagePreferencesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetMessagePreferencesCall ► ApiRequest
Gets or sets the GetMessagePreferencesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMessagePreferencesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetMessagePreferencesRequestType
    Get
    Set
public:
property GetMessagePreferencesRequestType^ ApiRequest {
    GetMessagePreferencesRequestType^ get ();
    void set (GetMessagePreferencesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetMessagePreferencesCall ► ApiResponse
Gets the GetMessagePreferencesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMessagePreferencesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetMessagePreferencesResponseType
    Get
public:
property GetMessagePreferencesResponseType^ ApiResponse {
    GetMessagePreferencesResponseType^ get ();
}


ASQPreferences Property

ASQPreferences Property
Namespaces ► eBay.Service.Call ► GetMessagePreferencesCall ► ASQPreferences
Gets the returned ASQPreferences of type ASQPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public ASQPreferencesType ASQPreferences { get; }
Public ReadOnly Property ASQPreferences As ASQPreferencesType
    Get
public:
property ASQPreferencesType^ ASQPreferences {
    ASQPreferencesType^ get ();
}


GetMessagePreferences Method (SellerID, IncludeASQPreferences)

GetMessagePreferences Method (SellerID, IncludeASQPreferences)
Namespaces ► eBay.Service.Call ► GetMessagePreferencesCall ► GetMessagePreferences(String, Boolean)
Returns a seller's Ask Seller a Question (ASQ) subjects, each in its own Subject node.
Declaration Syntax
C# Visual Basic Visual C++
public ASQPreferencesType GetMessagePreferences(
    string SellerID,
    bool IncludeASQPreferences
)
Public Function GetMessagePreferences ( _
    SellerID As String, _
    IncludeASQPreferences As Boolean _
) As ASQPreferencesType
public:
ASQPreferencesType^ GetMessagePreferences(
    String^ SellerID,
    bool IncludeASQPreferences
)
Parameters
SellerID (String)
The ID of the user to retrieve ASQ subjects for. This value must be specified in the request, but does not need to be the same user as the user making the request.
IncludeASQPreferences (Boolean)
If true, indicates that the ASQ subjects for the specified user should be returned.


GetMessagePreferencesCall Constructor

GetMessagePreferencesCall Constructor
Namespaces ► eBay.Service.Call ► GetMessagePreferencesCall ► GetMessagePreferencesCall()()()()
Members
Icon | Member | Description
 | GetMessagePreferencesCall()()()() |
 | GetMessagePreferencesCall(ApiContext) |


GetMessagePreferencesCall Constructor

GetMessagePreferencesCall Constructor
Namespaces ► eBay.Service.Call ► GetMessagePreferencesCall ► GetMessagePreferencesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMessagePreferencesCall()
Public Sub New
public:
GetMessagePreferencesCall()


GetMessagePreferencesCall Constructor (ApiContext)

GetMessagePreferencesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetMessagePreferencesCall ► GetMessagePreferencesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetMessagePreferencesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetMessagePreferencesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


IncludeASQPreferences Property

IncludeASQPreferences Property
Namespaces ► eBay.Service.Call ► GetMessagePreferencesCall ► IncludeASQPreferences
Gets or sets the IncludeASQPreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeASQPreferences { get; set; }
Public Property IncludeASQPreferences As Boolean
    Get
    Set
public:
property bool IncludeASQPreferences {
    bool get ();
    void set (bool value);
}


SellerID Property

SellerID Property
Namespaces ► eBay.Service.Call ► GetMessagePreferencesCall ► SellerID
Gets or sets the SellerID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SellerID { get; set; }
Public Property SellerID As String
    Get
    Set
public:
property String^ SellerID {
    String^ get ();
    void set (String^ value);
}


GetMyeBayBuyingCall Class

GetMyeBayBuyingCall Class
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetMyeBayBuyingCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetMyeBayBuyingCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetMyeBayBuyingCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyeBayBuyingCall()()()() |
 | GetMyeBayBuyingCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetMyeBayBuyingRequestType for this API call.
 | ApiResponse | Gets the GetMyeBayBuyingResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BestOfferList | Gets or sets the BestOfferList of type ItemListCustomizationType.
 | BestOfferListReturn | Gets the returned BestOfferList of type PaginatedItemArrayType.
 | BidAssistantList | Gets or sets the BidAssistantList of type BidAssistantListType.
 | BidAssistantListList | Gets the returned BidAssistantList of type BidGroupTypeCollection.
 | BidList | Gets or sets the BidList of type ItemListCustomizationType.
 | BidListReturn | Gets the returned BidList of type PaginatedItemArrayType.
 | BuyingSummary | Gets or sets the BuyingSummary of type ItemListCustomizationType.
 | BuyingSummaryReturn | Gets the returned BuyingSummary of type BuyingSummaryType.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeletedFromLostList | Gets or sets the DeletedFromLostList of type ItemListCustomizationType.
 | DeletedFromLostListReturn | Gets the returned DeletedFromLostList of type PaginatedItemArrayType.
 | DeletedFromWonList | Gets or sets the DeletedFromWonList of type ItemListCustomizationType.
 | DeletedFromWonListReturn | Gets the returned DeletedFromWonList of type PaginatedOrderTransactionArrayType.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FavoriteSearches | Gets or sets the FavoriteSearches of type MyeBaySelectionType.
 | FavoriteSearchesReturn | Gets the returned FavoriteSearches of type MyeBayFavoriteSearchListType.
 | FavoriteSellers | Gets or sets the FavoriteSellers of type MyeBaySelectionType.
 | FavoriteSellersReturn | Gets the returned FavoriteSellers of type MyeBayFavoriteSellerListType.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetMyeBayBuying(ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, MyeBaySelectionType, MyeBaySelectionType, MyeBaySelectionType, BidAssistantListType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, MyeBaySelectionType, Boolean) | Retrieves information regarding a user's buying activity, such as items they are watching, bidding on, have won, did not win, and have made Best Offers on.
 | GetMyeBayBuying(ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, MyeBaySelectionType, MyeBaySelectionType, MyeBaySelectionType) | For backward compatibility with old wrappers.
 | GetMyeBayBuying()()()() | For backward compatibility with old wrappers.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | HideVariations | Gets or sets the HideVariations of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | LostList | Gets or sets the LostList of type ItemListCustomizationType.
 | LostListReturn | Gets the returned LostList of type PaginatedItemArrayType.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SecondChanceOffer | Gets or sets the SecondChanceOffer of type MyeBaySelectionType.
 | SecondChanceOfferReturn | Gets the returned SecondChanceOffer of type ItemTypeCollection.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UserDefinedListList | Gets the returned UserDefinedList of type UserDefinedListTypeCollection.
 | UserDefinedLists | Gets or sets the UserDefinedLists of type MyeBaySelectionType.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
 | WatchList | Gets or sets the WatchList of type ItemListCustomizationType.
 | WatchListReturn | Gets the returned WatchList of type PaginatedItemArrayType.
 | WonList | Gets or sets the WonList of type ItemListCustomizationType.
 | WonListReturn | Gets the returned WonList of type PaginatedOrderTransactionArrayType.
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetMyeBayBuyingCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► ApiRequest
Gets or sets the GetMyeBayBuyingRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayBuyingRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetMyeBayBuyingRequestType
    Get
    Set
public:
property GetMyeBayBuyingRequestType^ ApiRequest {
    GetMyeBayBuyingRequestType^ get ();
    void set (GetMyeBayBuyingRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► ApiResponse
Gets the GetMyeBayBuyingResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayBuyingResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetMyeBayBuyingResponseType
    Get
public:
property GetMyeBayBuyingResponseType^ ApiResponse {
    GetMyeBayBuyingResponseType^ get ();
}


BestOfferList Property

BestOfferList Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► BestOfferList
Gets or sets the BestOfferList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType BestOfferList { get; set; }
Public Property BestOfferList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ BestOfferList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


BestOfferListReturn Property

BestOfferListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► BestOfferListReturn
Gets the returned BestOfferList of type PaginatedItemArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType BestOfferListReturn { get; }
Public ReadOnly Property BestOfferListReturn As PaginatedItemArrayType
    Get
public:
property PaginatedItemArrayType^ BestOfferListReturn {
    PaginatedItemArrayType^ get ();
}


BidAssistantList Property

BidAssistantList Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► BidAssistantList
Gets or sets the BidAssistantList of type BidAssistantListType.
Declaration Syntax
C# Visual Basic Visual C++
public BidAssistantListType BidAssistantList { get; set; }
Public Property BidAssistantList As BidAssistantListType
    Get
    Set
public:
property BidAssistantListType^ BidAssistantList {
    BidAssistantListType^ get ();
    void set (BidAssistantListType^ value);
}


BidAssistantListList Property

BidAssistantListList Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► BidAssistantListList
Gets the returned BidAssistantList of type BidGroupTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupTypeCollection BidAssistantListList { get; }
Public ReadOnly Property BidAssistantListList As BidGroupTypeCollection
    Get
public:
property BidGroupTypeCollection^ BidAssistantListList {
    BidGroupTypeCollection^ get ();
}


BidList Property

BidList Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► BidList
Gets or sets the BidList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType BidList { get; set; }
Public Property BidList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ BidList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


BidListReturn Property

BidListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► BidListReturn
Gets the returned BidList of type PaginatedItemArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType BidListReturn { get; }
Public ReadOnly Property BidListReturn As PaginatedItemArrayType
    Get
public:
property PaginatedItemArrayType^ BidListReturn {
    PaginatedItemArrayType^ get ();
}


BuyingSummary Property

BuyingSummary Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► BuyingSummary
Gets or sets the BuyingSummary of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType BuyingSummary { get; set; }
Public Property BuyingSummary As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ BuyingSummary {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


BuyingSummaryReturn Property

BuyingSummaryReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► BuyingSummaryReturn
Gets the returned BuyingSummary of type BuyingSummaryType.
Declaration Syntax
C# Visual Basic Visual C++
public BuyingSummaryType BuyingSummaryReturn { get; }
Public ReadOnly Property BuyingSummaryReturn As BuyingSummaryType
    Get
public:
property BuyingSummaryType^ BuyingSummaryReturn {
    BuyingSummaryType^ get ();
}


DeletedFromLostList Property

DeletedFromLostList Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► DeletedFromLostList
Gets or sets the DeletedFromLostList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType DeletedFromLostList { get; set; }
Public Property DeletedFromLostList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ DeletedFromLostList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


DeletedFromLostListReturn Property

DeletedFromLostListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► DeletedFromLostListReturn
Gets the returned DeletedFromLostList of type PaginatedItemArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType DeletedFromLostListReturn { get; }
Public ReadOnly Property DeletedFromLostListReturn As PaginatedItemArrayType
    Get
public:
property PaginatedItemArrayType^ DeletedFromLostListReturn {
    PaginatedItemArrayType^ get ();
}


DeletedFromWonList Property

DeletedFromWonList Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► DeletedFromWonList
Gets or sets the DeletedFromWonList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType DeletedFromWonList { get; set; }
Public Property DeletedFromWonList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ DeletedFromWonList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


DeletedFromWonListReturn Property

DeletedFromWonListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► DeletedFromWonListReturn
Gets the returned DeletedFromWonList of type PaginatedOrderTransactionArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedOrderTransactionArrayType DeletedFromWonListReturn { get; }
Public ReadOnly Property DeletedFromWonListReturn As PaginatedOrderTransactionArrayType
    Get
public:
property PaginatedOrderTransactionArrayType^ DeletedFromWonListReturn {
    PaginatedOrderTransactionArrayType^ get ();
}


FavoriteSearches Property

FavoriteSearches Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► FavoriteSearches
Gets or sets the FavoriteSearches of type MyeBaySelectionType.
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySelectionType FavoriteSearches { get; set; }
Public Property FavoriteSearches As MyeBaySelectionType
    Get
    Set
public:
property MyeBaySelectionType^ FavoriteSearches {
    MyeBaySelectionType^ get ();
    void set (MyeBaySelectionType^ value);
}


FavoriteSearchesReturn Property

FavoriteSearchesReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► FavoriteSearchesReturn
Gets the returned FavoriteSearches of type MyeBayFavoriteSearchListType.
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchListType FavoriteSearchesReturn { get; }
Public ReadOnly Property FavoriteSearchesReturn As MyeBayFavoriteSearchListType
    Get
public:
property MyeBayFavoriteSearchListType^ FavoriteSearchesReturn {
    MyeBayFavoriteSearchListType^ get ();
}


FavoriteSellers Property

FavoriteSellers Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► FavoriteSellers
Gets or sets the FavoriteSellers of type MyeBaySelectionType.
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySelectionType FavoriteSellers { get; set; }
Public Property FavoriteSellers As MyeBaySelectionType
    Get
    Set
public:
property MyeBaySelectionType^ FavoriteSellers {
    MyeBaySelectionType^ get ();
    void set (MyeBaySelectionType^ value);
}


FavoriteSellersReturn Property

FavoriteSellersReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► FavoriteSellersReturn
Gets the returned FavoriteSellers of type MyeBayFavoriteSellerListType.
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerListType FavoriteSellersReturn { get; }
Public ReadOnly Property FavoriteSellersReturn As MyeBayFavoriteSellerListType
    Get
public:
property MyeBayFavoriteSellerListType^ FavoriteSellersReturn {
    MyeBayFavoriteSellerListType^ get ();
}


GetMyeBayBuying Method

GetMyeBayBuying Method
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► GetMyeBayBuying()()()()
Members
Icon | Member | Description
 | GetMyeBayBuying(ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, MyeBaySelectionType, MyeBaySelectionType, MyeBaySelectionType, BidAssistantListType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, MyeBaySelectionType, Boolean) | Retrieves information regarding a user's buying activity, such as items they are watching, bidding on, have won, did not win, and have made Best Offers on.
 | GetMyeBayBuying(ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, MyeBaySelectionType, MyeBaySelectionType, MyeBaySelectionType) | For backward compatibility with old wrappers.
 | GetMyeBayBuying()()()() | For backward compatibility with old wrappers.


GetMyeBayBuying Method

GetMyeBayBuying Method
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► GetMyeBayBuying()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void GetMyeBayBuying()
Public Sub GetMyeBayBuying
public:
void GetMyeBayBuying()


GetMyeBayBuying Method (WatchList, BidList, BestOfferList, WonList, LostList, FavoriteSearches, FavoriteSellers, SecondChanceOffer)

GetMyeBayBuying Method (WatchList, BidList, BestOfferList, WonList, LostList, FavoriteSearches, FavoriteSellers, SecondChanceOffer)
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► GetMyeBayBuying(ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, MyeBaySelectionType, MyeBaySelectionType, MyeBaySelectionType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public BuyingSummaryType GetMyeBayBuying(
    ItemListCustomizationType WatchList,
    ItemListCustomizationType BidList,
    ItemListCustomizationType BestOfferList,
    ItemListCustomizationType WonList,
    ItemListCustomizationType LostList,
    MyeBaySelectionType FavoriteSearches,
    MyeBaySelectionType FavoriteSellers,
    MyeBaySelectionType SecondChanceOffer
)
Public Function GetMyeBayBuying ( _
    WatchList As ItemListCustomizationType, _
    BidList As ItemListCustomizationType, _
    BestOfferList As ItemListCustomizationType, _
    WonList As ItemListCustomizationType, _
    LostList As ItemListCustomizationType, _
    FavoriteSearches As MyeBaySelectionType, _
    FavoriteSellers As MyeBaySelectionType, _
    SecondChanceOffer As MyeBaySelectionType _
) As BuyingSummaryType
public:
BuyingSummaryType^ GetMyeBayBuying(
    ItemListCustomizationType^ WatchList,
    ItemListCustomizationType^ BidList,
    ItemListCustomizationType^ BestOfferList,
    ItemListCustomizationType^ WonList,
    ItemListCustomizationType^ LostList,
    MyeBaySelectionType^ FavoriteSearches,
    MyeBaySelectionType^ FavoriteSellers,
    MyeBaySelectionType^ SecondChanceOffer
)
Parameters
WatchList (ItemListCustomizationType)
BidList (ItemListCustomizationType)
BestOfferList (ItemListCustomizationType)
WonList (ItemListCustomizationType)
LostList (ItemListCustomizationType)
FavoriteSearches (MyeBaySelectionType)
FavoriteSellers (MyeBaySelectionType)
SecondChanceOffer (MyeBaySelectionType)


GetMyeBayBuying Method (WatchList, BidList, BestOfferList, WonList, LostList, FavoriteSearches, FavoriteSellers, SecondChanceOffer, BidAssistantList, DeletedFromWonList, DeletedFromLostList, BuyingSummary, UserDefinedLists, HideVariations)

GetMyeBayBuying Method (WatchList, BidList, BestOfferList, WonList, LostList, FavoriteSearches, FavoriteSellers, SecondChanceOffer, BidAssistantList, DeletedFromWonList, DeletedFromLostList, BuyingSummary, UserDefinedLists, HideVariations)
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► GetMyeBayBuying(ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, MyeBaySelectionType, MyeBaySelectionType, MyeBaySelectionType, BidAssistantListType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, MyeBaySelectionType, Boolean)
Retrieves information regarding a user's buying activity, such as items they are watching, bidding on, have won, did not win, and have made Best Offers on.
Declaration Syntax
C# Visual Basic Visual C++
public BuyingSummaryType GetMyeBayBuying(
    ItemListCustomizationType WatchList,
    ItemListCustomizationType BidList,
    ItemListCustomizationType BestOfferList,
    ItemListCustomizationType WonList,
    ItemListCustomizationType LostList,
    MyeBaySelectionType FavoriteSearches,
    MyeBaySelectionType FavoriteSellers,
    MyeBaySelectionType SecondChanceOffer,
    BidAssistantListType BidAssistantList,
    ItemListCustomizationType DeletedFromWonList,
    ItemListCustomizationType DeletedFromLostList,
    ItemListCustomizationType BuyingSummary,
    MyeBaySelectionType UserDefinedLists,
    bool HideVariations
)
Public Function GetMyeBayBuying ( _
    WatchList As ItemListCustomizationType, _
    BidList As ItemListCustomizationType, _
    BestOfferList As ItemListCustomizationType, _
    WonList As ItemListCustomizationType, _
    LostList As ItemListCustomizationType, _
    FavoriteSearches As MyeBaySelectionType, _
    FavoriteSellers As MyeBaySelectionType, _
    SecondChanceOffer As MyeBaySelectionType, _
    BidAssistantList As BidAssistantListType, _
    DeletedFromWonList As ItemListCustomizationType, _
    DeletedFromLostList As ItemListCustomizationType, _
    BuyingSummary As ItemListCustomizationType, _
    UserDefinedLists As MyeBaySelectionType, _
    HideVariations As Boolean _
) As BuyingSummaryType
public:
BuyingSummaryType^ GetMyeBayBuying(
    ItemListCustomizationType^ WatchList,
    ItemListCustomizationType^ BidList,
    ItemListCustomizationType^ BestOfferList,
    ItemListCustomizationType^ WonList,
    ItemListCustomizationType^ LostList,
    MyeBaySelectionType^ FavoriteSearches,
    MyeBaySelectionType^ FavoriteSellers,
    MyeBaySelectionType^ SecondChanceOffer,
    BidAssistantListType^ BidAssistantList,
    ItemListCustomizationType^ DeletedFromWonList,
    ItemListCustomizationType^ DeletedFromLostList,
    ItemListCustomizationType^ BuyingSummary,
    MyeBaySelectionType^ UserDefinedLists,
    bool HideVariations
)
Parameters
WatchList (ItemListCustomizationType)
Returns the list of items being watched by the user. Set Include to true to return the default response set.
BidList (ItemListCustomizationType)
Returns the list of items on which the user has bid. Set Include to true to return the default response set.
BestOfferList (ItemListCustomizationType)
Returns the list of items on which the user has placed best offers. Set Include to true to return the default response set.
WonList (ItemListCustomizationType)
Returns the list of items on which the use has bid. Set Include to true to return the default response set.
LostList (ItemListCustomizationType)
Returns the list of items on which the user has bid on and lost. Set Include to true to return the default response set.
FavoriteSearches (MyeBaySelectionType)
Returns the list of searches that the user has saved in My eBay. Returned only if the user has saved searches. Set Include to true to return the default response set.
FavoriteSellers (MyeBaySelectionType)
Returns the list of favorite sellers that the user has saved in My eBay. Returned only if the user has saved a list of favorite sellers. Set Include to true to return the default response set.
SecondChanceOffer (MyeBaySelectionType)
Returns the list of second chance offers made by the user. Returned only if the user has made second chance offers. Set Include to true to return the default response set.
BidAssistantList (BidAssistantListType)
This field is deprecated.
DeletedFromWonList (ItemListCustomizationType)
Returns the list of items the user has won, and subsequently deleted from their My eBay page. Set Include to true to return the default response set.
DeletedFromLostList (ItemListCustomizationType)
Returns the list of items (auctions) the user did not win and were subsequently deleted from their My eBay page. Set Include to true to return the default response set.
BuyingSummary (ItemListCustomizationType)
Returns a summary of the user's buying activity. Note: The buying summary container is not included in the response by default. To include a BuyingSummary element, add an Include field set to
true
to the request.
UserDefinedLists (MyeBaySelectionType)
Returns the user defined lists, which are lists created by the user in the eBay UI and filled with items, or sellers, or searches using the "Add to List" feature. Set Include to true to return the default response set.
HideVariations (Boolean)
If true, the Variations node is omitted for all multi-variation listings in the response. If false, the Variations node is returned for all multi-variation listings in the response. Note: If the seller includes a large number of variations in many listings, retrieving variations (setting this flag to false) may degrade the call's performance. Therefore, when this is false, you may need to reduce the total number of items you're requesting at once (by using other input fields, such as Pagination).


GetMyeBayBuyingCall Constructor

GetMyeBayBuyingCall Constructor
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► GetMyeBayBuyingCall()()()()
Members
Icon | Member | Description
 | GetMyeBayBuyingCall()()()() |
 | GetMyeBayBuyingCall(ApiContext) |


GetMyeBayBuyingCall Constructor

GetMyeBayBuyingCall Constructor
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► GetMyeBayBuyingCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayBuyingCall()
Public Sub New
public:
GetMyeBayBuyingCall()


GetMyeBayBuyingCall Constructor (ApiContext)

GetMyeBayBuyingCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► GetMyeBayBuyingCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayBuyingCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetMyeBayBuyingCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HideVariations Property

HideVariations Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► HideVariations
Gets or sets the HideVariations of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool HideVariations { get; set; }
Public Property HideVariations As Boolean
    Get
    Set
public:
property bool HideVariations {
    bool get ();
    void set (bool value);
}


LostList Property

LostList Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► LostList
Gets or sets the LostList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType LostList { get; set; }
Public Property LostList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ LostList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


LostListReturn Property

LostListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► LostListReturn
Gets the returned LostList of type PaginatedItemArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType LostListReturn { get; }
Public ReadOnly Property LostListReturn As PaginatedItemArrayType
    Get
public:
property PaginatedItemArrayType^ LostListReturn {
    PaginatedItemArrayType^ get ();
}


SecondChanceOffer Property

SecondChanceOffer Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► SecondChanceOffer
Gets or sets the SecondChanceOffer of type MyeBaySelectionType.
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySelectionType SecondChanceOffer { get; set; }
Public Property SecondChanceOffer As MyeBaySelectionType
    Get
    Set
public:
property MyeBaySelectionType^ SecondChanceOffer {
    MyeBaySelectionType^ get ();
    void set (MyeBaySelectionType^ value);
}


SecondChanceOfferReturn Property

SecondChanceOfferReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► SecondChanceOfferReturn
Gets the returned SecondChanceOffer of type ItemTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection SecondChanceOfferReturn { get; }
Public ReadOnly Property SecondChanceOfferReturn As ItemTypeCollection
    Get
public:
property ItemTypeCollection^ SecondChanceOfferReturn {
    ItemTypeCollection^ get ();
}


UserDefinedListList Property

UserDefinedListList Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► UserDefinedListList
Gets the returned UserDefinedList of type UserDefinedListTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public UserDefinedListTypeCollection UserDefinedListList { get; }
Public ReadOnly Property UserDefinedListList As UserDefinedListTypeCollection
    Get
public:
property UserDefinedListTypeCollection^ UserDefinedListList {
    UserDefinedListTypeCollection^ get ();
}


UserDefinedLists Property

UserDefinedLists Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► UserDefinedLists
Gets or sets the UserDefinedLists of type MyeBaySelectionType.
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySelectionType UserDefinedLists { get; set; }
Public Property UserDefinedLists As MyeBaySelectionType
    Get
    Set
public:
property MyeBaySelectionType^ UserDefinedLists {
    MyeBaySelectionType^ get ();
    void set (MyeBaySelectionType^ value);
}


WatchList Property

WatchList Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► WatchList
Gets or sets the WatchList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType WatchList { get; set; }
Public Property WatchList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ WatchList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


WatchListReturn Property

WatchListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► WatchListReturn
Gets the returned WatchList of type PaginatedItemArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType WatchListReturn { get; }
Public ReadOnly Property WatchListReturn As PaginatedItemArrayType
    Get
public:
property PaginatedItemArrayType^ WatchListReturn {
    PaginatedItemArrayType^ get ();
}


WonList Property

WonList Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► WonList
Gets or sets the WonList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType WonList { get; set; }
Public Property WonList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ WonList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


WonListReturn Property

WonListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayBuyingCall ► WonListReturn
Gets the returned WonList of type PaginatedOrderTransactionArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedOrderTransactionArrayType WonListReturn { get; }
Public ReadOnly Property WonListReturn As PaginatedOrderTransactionArrayType
    Get
public:
property PaginatedOrderTransactionArrayType^ WonListReturn {
    PaginatedOrderTransactionArrayType^ get ();
}


GetMyeBayRemindersCall Class

GetMyeBayRemindersCall Class
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetMyeBayRemindersCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetMyeBayRemindersCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetMyeBayRemindersCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyeBayRemindersCall()()()() |
 | GetMyeBayRemindersCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetMyeBayRemindersRequestType for this API call.
 | ApiResponse | Gets the GetMyeBayRemindersResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BuyingReminders | Gets or sets the BuyingReminders of type ReminderCustomizationType.
 | BuyingRemindersReturn | Gets the returned BuyingReminders of type RemindersType.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetMyeBayReminders(ReminderCustomizationType, ReminderCustomizationType) | This is the base request type of the GetMyeBayReminders call. This call returns the total counts for My eBay Buying and/or My eBay Selling Reminders for a user.
 | GetMyeBayReminders()()()() | For backward compatibility with old wrappers.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellingReminders | Gets or sets the SellingReminders of type ReminderCustomizationType.
 | SellingRemindersReturn | Gets the returned SellingReminders of type RemindersType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetMyeBayRemindersCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► ApiRequest
Gets or sets the GetMyeBayRemindersRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayRemindersRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetMyeBayRemindersRequestType
    Get
    Set
public:
property GetMyeBayRemindersRequestType^ ApiRequest {
    GetMyeBayRemindersRequestType^ get ();
    void set (GetMyeBayRemindersRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► ApiResponse
Gets the GetMyeBayRemindersResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayRemindersResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetMyeBayRemindersResponseType
    Get
public:
property GetMyeBayRemindersResponseType^ ApiResponse {
    GetMyeBayRemindersResponseType^ get ();
}


BuyingReminders Property

BuyingReminders Property
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► BuyingReminders
Gets or sets the BuyingReminders of type ReminderCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ReminderCustomizationType BuyingReminders { get; set; }
Public Property BuyingReminders As ReminderCustomizationType
    Get
    Set
public:
property ReminderCustomizationType^ BuyingReminders {
    ReminderCustomizationType^ get ();
    void set (ReminderCustomizationType^ value);
}


BuyingRemindersReturn Property

BuyingRemindersReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► BuyingRemindersReturn
Gets the returned BuyingReminders of type RemindersType.
Declaration Syntax
C# Visual Basic Visual C++
public RemindersType BuyingRemindersReturn { get; }
Public ReadOnly Property BuyingRemindersReturn As RemindersType
    Get
public:
property RemindersType^ BuyingRemindersReturn {
    RemindersType^ get ();
}


GetMyeBayReminders Method

GetMyeBayReminders Method
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► GetMyeBayReminders()()()()
Members
Icon | Member | Description
 | GetMyeBayReminders(ReminderCustomizationType, ReminderCustomizationType) | This is the base request type of the GetMyeBayReminders call. This call returns the total counts for My eBay Buying and/or My eBay Selling Reminders for a user.
 | GetMyeBayReminders()()()() | For backward compatibility with old wrappers.


GetMyeBayReminders Method

GetMyeBayReminders Method
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► GetMyeBayReminders()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void GetMyeBayReminders()
Public Sub GetMyeBayReminders
public:
void GetMyeBayReminders()


GetMyeBayReminders Method (BuyingReminders, SellingReminders)

GetMyeBayReminders Method (BuyingReminders, SellingReminders)
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► GetMyeBayReminders(ReminderCustomizationType, ReminderCustomizationType)
This is the base request type of the GetMyeBayReminders call. This call returns the total counts for My eBay Buying and/or My eBay Selling Reminders for a user.
Declaration Syntax
C# Visual Basic Visual C++
public RemindersType GetMyeBayReminders(
    ReminderCustomizationType BuyingReminders,
    ReminderCustomizationType SellingReminders
)
Public Function GetMyeBayReminders ( _
    BuyingReminders As ReminderCustomizationType, _
    SellingReminders As ReminderCustomizationType _
) As RemindersType
public:
RemindersType^ GetMyeBayReminders(
    ReminderCustomizationType^ BuyingReminders,
    ReminderCustomizationType^ SellingReminders
)
Parameters
BuyingReminders (ReminderCustomizationType)
This container should be included if the user wishes to retrieve the counts of My eBay Buying Reminders. Counts will only be retrieved for My eBay Buying Reminders that the user received.
SellingReminders (ReminderCustomizationType)
This container should be included if the user wishes to retrieve the counts of My eBay Selling Reminders. Counts will only be retrieved for My eBay Selling Reminders that the user received.


GetMyeBayRemindersCall Constructor

GetMyeBayRemindersCall Constructor
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► GetMyeBayRemindersCall()()()()
Members
Icon | Member | Description
 | GetMyeBayRemindersCall()()()() |
 | GetMyeBayRemindersCall(ApiContext) |


GetMyeBayRemindersCall Constructor

GetMyeBayRemindersCall Constructor
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► GetMyeBayRemindersCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayRemindersCall()
Public Sub New
public:
GetMyeBayRemindersCall()


GetMyeBayRemindersCall Constructor (ApiContext)

GetMyeBayRemindersCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► GetMyeBayRemindersCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayRemindersCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetMyeBayRemindersCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SellingReminders Property

SellingReminders Property
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► SellingReminders
Gets or sets the SellingReminders of type ReminderCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ReminderCustomizationType SellingReminders { get; set; }
Public Property SellingReminders As ReminderCustomizationType
    Get
    Set
public:
property ReminderCustomizationType^ SellingReminders {
    ReminderCustomizationType^ get ();
    void set (ReminderCustomizationType^ value);
}


SellingRemindersReturn Property

SellingRemindersReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBayRemindersCall ► SellingRemindersReturn
Gets the returned SellingReminders of type RemindersType.
Declaration Syntax
C# Visual Basic Visual C++
public RemindersType SellingRemindersReturn { get; }
Public ReadOnly Property SellingRemindersReturn As RemindersType
    Get
public:
property RemindersType^ SellingRemindersReturn {
    RemindersType^ get ();
}


GetMyeBaySellingCall Class

GetMyeBaySellingCall Class
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetMyeBaySellingCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetMyeBaySellingCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetMyeBaySellingCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyeBaySellingCall()()()() |
 | GetMyeBaySellingCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | ActiveList | Gets or sets the ActiveList of type ItemListCustomizationType.
 | ActiveListReturn | Gets the returned ActiveList of type PaginatedItemArrayType.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetMyeBaySellingRequestType for this API call.
 | ApiResponse | Gets the GetMyeBaySellingResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BidList | Gets or sets the BidList of type ItemListCustomizationType.
 | BidListReturn | Gets the returned BidList of type PaginatedItemArrayType.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeletedFromSoldList | Gets or sets the DeletedFromSoldList of type ItemListCustomizationType.
 | DeletedFromSoldListReturn | Gets the returned DeletedFromSoldList of type PaginatedOrderTransactionArrayType.
 | DeletedFromUnsoldList | Gets or sets the DeletedFromUnsoldList of type ItemListCustomizationType.
 | DeletedFromUnsoldListReturn | Gets the returned DeletedFromUnsoldList of type PaginatedItemArrayType.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetMyeBaySelling(ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, Boolean) | Retrieves information regarding the user's selling activity, such as items that the user is currently selling (the Active list), items that have bids, sold items, and unsold items.
 | GetMyeBaySelling()()()() | For backward compatibility with old wrappers.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | HideVariations | Gets or sets the HideVariations of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ScheduledList | Gets or sets the ScheduledList of type ItemListCustomizationType.
 | ScheduledListReturn | Gets the returned ScheduledList of type PaginatedItemArrayType.
 | SellingSummary | Gets or sets the SellingSummary of type ItemListCustomizationType.
 | SellingSummaryReturn | Gets the returned SellingSummary of type SellingSummaryType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | SoldList | Gets or sets the SoldList of type ItemListCustomizationType.
 | SoldListReturn | Gets the returned SoldList of type PaginatedOrderTransactionArrayType.
 | Summary | Gets the returned Summary of type MyeBaySellingSummaryType.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UnsoldList | Gets or sets the UnsoldList of type ItemListCustomizationType.
 | UnsoldListReturn | Gets the returned UnsoldList of type PaginatedItemArrayType.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetMyeBaySellingCall


ActiveList Property

ActiveList Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► ActiveList
Gets or sets the ActiveList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType ActiveList { get; set; }
Public Property ActiveList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ ActiveList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


ActiveListReturn Property

ActiveListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► ActiveListReturn
Gets the returned ActiveList of type PaginatedItemArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType ActiveListReturn { get; }
Public ReadOnly Property ActiveListReturn As PaginatedItemArrayType
    Get
public:
property PaginatedItemArrayType^ ActiveListReturn {
    PaginatedItemArrayType^ get ();
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► ApiRequest
Gets or sets the GetMyeBaySellingRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBaySellingRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetMyeBaySellingRequestType
    Get
    Set
public:
property GetMyeBaySellingRequestType^ ApiRequest {
    GetMyeBaySellingRequestType^ get ();
    void set (GetMyeBaySellingRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► ApiResponse
Gets the GetMyeBaySellingResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBaySellingResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetMyeBaySellingResponseType
    Get
public:
property GetMyeBaySellingResponseType^ ApiResponse {
    GetMyeBaySellingResponseType^ get ();
}


BidList Property

BidList Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► BidList
Gets or sets the BidList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType BidList { get; set; }
Public Property BidList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ BidList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


BidListReturn Property

BidListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► BidListReturn
Gets the returned BidList of type PaginatedItemArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType BidListReturn { get; }
Public ReadOnly Property BidListReturn As PaginatedItemArrayType
    Get
public:
property PaginatedItemArrayType^ BidListReturn {
    PaginatedItemArrayType^ get ();
}


DeletedFromSoldList Property

DeletedFromSoldList Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► DeletedFromSoldList
Gets or sets the DeletedFromSoldList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType DeletedFromSoldList { get; set; }
Public Property DeletedFromSoldList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ DeletedFromSoldList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


DeletedFromSoldListReturn Property

DeletedFromSoldListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► DeletedFromSoldListReturn
Gets the returned DeletedFromSoldList of type PaginatedOrderTransactionArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedOrderTransactionArrayType DeletedFromSoldListReturn { get; }
Public ReadOnly Property DeletedFromSoldListReturn As PaginatedOrderTransactionArrayType
    Get
public:
property PaginatedOrderTransactionArrayType^ DeletedFromSoldListReturn {
    PaginatedOrderTransactionArrayType^ get ();
}


DeletedFromUnsoldList Property

DeletedFromUnsoldList Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► DeletedFromUnsoldList
Gets or sets the DeletedFromUnsoldList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType DeletedFromUnsoldList { get; set; }
Public Property DeletedFromUnsoldList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ DeletedFromUnsoldList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


DeletedFromUnsoldListReturn Property

DeletedFromUnsoldListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► DeletedFromUnsoldListReturn
Gets the returned DeletedFromUnsoldList of type PaginatedItemArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType DeletedFromUnsoldListReturn { get; }
Public ReadOnly Property DeletedFromUnsoldListReturn As PaginatedItemArrayType
    Get
public:
property PaginatedItemArrayType^ DeletedFromUnsoldListReturn {
    PaginatedItemArrayType^ get ();
}


GetMyeBaySelling Method

GetMyeBaySelling Method
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► GetMyeBaySelling()()()()
Members
Icon | Member | Description
 | GetMyeBaySelling(ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, Boolean) | Retrieves information regarding the user's selling activity, such as items that the user is currently selling (the Active list), items that have bids, sold items, and unsold items.
 | GetMyeBaySelling()()()() | For backward compatibility with old wrappers.


GetMyeBaySelling Method

GetMyeBaySelling Method
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► GetMyeBaySelling()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void GetMyeBaySelling()
Public Sub GetMyeBaySelling
public:
void GetMyeBaySelling()


GetMyeBaySelling Method (ScheduledList, ActiveList, SoldList, UnsoldList, BidList, DeletedFromSoldList, DeletedFromUnsoldList, SellingSummary, HideVariations)

GetMyeBaySelling Method (ScheduledList, ActiveList, SoldList, UnsoldList, BidList, DeletedFromSoldList, DeletedFromUnsoldList, SellingSummary, HideVariations)
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► GetMyeBaySelling(ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, ItemListCustomizationType, Boolean)
Retrieves information regarding the user's selling activity, such as items that the user is currently selling (the Active list), items that have bids, sold items, and unsold items.
Declaration Syntax
C# Visual Basic Visual C++
public SellingSummaryType GetMyeBaySelling(
    ItemListCustomizationType ScheduledList,
    ItemListCustomizationType ActiveList,
    ItemListCustomizationType SoldList,
    ItemListCustomizationType UnsoldList,
    ItemListCustomizationType BidList,
    ItemListCustomizationType DeletedFromSoldList,
    ItemListCustomizationType DeletedFromUnsoldList,
    ItemListCustomizationType SellingSummary,
    bool HideVariations
)
Public Function GetMyeBaySelling ( _
    ScheduledList As ItemListCustomizationType, _
    ActiveList As ItemListCustomizationType, _
    SoldList As ItemListCustomizationType, _
    UnsoldList As ItemListCustomizationType, _
    BidList As ItemListCustomizationType, _
    DeletedFromSoldList As ItemListCustomizationType, _
    DeletedFromUnsoldList As ItemListCustomizationType, _
    SellingSummary As ItemListCustomizationType, _
    HideVariations As Boolean _
) As SellingSummaryType
public:
SellingSummaryType^ GetMyeBaySelling(
    ItemListCustomizationType^ ScheduledList,
    ItemListCustomizationType^ ActiveList,
    ItemListCustomizationType^ SoldList,
    ItemListCustomizationType^ UnsoldList,
    ItemListCustomizationType^ BidList,
    ItemListCustomizationType^ DeletedFromSoldList,
    ItemListCustomizationType^ DeletedFromUnsoldList,
    ItemListCustomizationType^ SellingSummary,
    bool HideVariations
)
Parameters
ScheduledList (ItemListCustomizationType)
Returns the list of items the user has scheduled to sell but whose listings have not yet opened. Set Include to
true
to return the default response set.
ActiveList (ItemListCustomizationType)
Returns the list of items the user is actively selling (the currently active listings). Set Include to
true
to return the default response set.
SoldList (ItemListCustomizationType)
Returns the list of items the user has sold. Set Include to
true
to return the default response set.
UnsoldList (ItemListCustomizationType)
Returns the list of items the user has listed, but whose listings have ended without being sold. Set Include to
true
to return the default response set.
BidList (ItemListCustomizationType)
Return the list of active items on which there are bids. Set Include to true to return the default response set.
DeletedFromSoldList (ItemListCustomizationType)
Returns the list of items the user sold, and then deleted from their My eBay page. Allowed values for DurationInDays are 0-90. Set Include to
true
to return the default response set.
DeletedFromUnsoldList (ItemListCustomizationType)
Returns the list of items the user either ended or did not sell, and subsequently were deleted them from their My eBay page. Allowed values for DurationInDays are 0-90. Set Include to
true
to return the default response set.
SellingSummary (ItemListCustomizationType)
Returns a summary of the user's buying activity. The SellingSummary is always returned by default. Add a SellingSummary element with an Include field set to false to exclude the SellingSummary from your response.
HideVariations (Boolean)
If true, the Variations node is omitted for all multi-variation listings in the response. If false, the Variations node is returned for all multi-variation listings in the response. Please note that if the seller includes a large number of variations in many listings, retrieving variations (setting this flag to
false
) may degrade the call's performance. Therefore, when this is false, you may need to reduce the total number of items you're requesting at once (by using other input fields, such as Pagination).


GetMyeBaySellingCall Constructor

GetMyeBaySellingCall Constructor
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► GetMyeBaySellingCall()()()()
Members
Icon | Member | Description
 | GetMyeBaySellingCall()()()() |
 | GetMyeBaySellingCall(ApiContext) |


GetMyeBaySellingCall Constructor

GetMyeBaySellingCall Constructor
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► GetMyeBaySellingCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBaySellingCall()
Public Sub New
public:
GetMyeBaySellingCall()


GetMyeBaySellingCall Constructor (ApiContext)

GetMyeBaySellingCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► GetMyeBaySellingCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBaySellingCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetMyeBaySellingCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HideVariations Property

HideVariations Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► HideVariations
Gets or sets the HideVariations of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool HideVariations { get; set; }
Public Property HideVariations As Boolean
    Get
    Set
public:
property bool HideVariations {
    bool get ();
    void set (bool value);
}


ScheduledList Property

ScheduledList Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► ScheduledList
Gets or sets the ScheduledList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType ScheduledList { get; set; }
Public Property ScheduledList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ ScheduledList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


ScheduledListReturn Property

ScheduledListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► ScheduledListReturn
Gets the returned ScheduledList of type PaginatedItemArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType ScheduledListReturn { get; }
Public ReadOnly Property ScheduledListReturn As PaginatedItemArrayType
    Get
public:
property PaginatedItemArrayType^ ScheduledListReturn {
    PaginatedItemArrayType^ get ();
}


SellingSummary Property

SellingSummary Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► SellingSummary
Gets or sets the SellingSummary of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType SellingSummary { get; set; }
Public Property SellingSummary As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ SellingSummary {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


SellingSummaryReturn Property

SellingSummaryReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► SellingSummaryReturn
Gets the returned SellingSummary of type SellingSummaryType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingSummaryType SellingSummaryReturn { get; }
Public ReadOnly Property SellingSummaryReturn As SellingSummaryType
    Get
public:
property SellingSummaryType^ SellingSummaryReturn {
    SellingSummaryType^ get ();
}


SoldList Property

SoldList Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► SoldList
Gets or sets the SoldList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType SoldList { get; set; }
Public Property SoldList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ SoldList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


SoldListReturn Property

SoldListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► SoldListReturn
Gets the returned SoldList of type PaginatedOrderTransactionArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedOrderTransactionArrayType SoldListReturn { get; }
Public ReadOnly Property SoldListReturn As PaginatedOrderTransactionArrayType
    Get
public:
property PaginatedOrderTransactionArrayType^ SoldListReturn {
    PaginatedOrderTransactionArrayType^ get ();
}


Summary Property

Summary Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► Summary
Gets the returned Summary of type MyeBaySellingSummaryType.
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySellingSummaryType Summary { get; }
Public ReadOnly Property Summary As MyeBaySellingSummaryType
    Get
public:
property MyeBaySellingSummaryType^ Summary {
    MyeBaySellingSummaryType^ get ();
}


UnsoldList Property

UnsoldList Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► UnsoldList
Gets or sets the UnsoldList of type ItemListCustomizationType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType UnsoldList { get; set; }
Public Property UnsoldList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ UnsoldList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


UnsoldListReturn Property

UnsoldListReturn Property
Namespaces ► eBay.Service.Call ► GetMyeBaySellingCall ► UnsoldListReturn
Gets the returned UnsoldList of type PaginatedItemArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType UnsoldListReturn { get; }
Public ReadOnly Property UnsoldListReturn As PaginatedItemArrayType
    Get
public:
property PaginatedItemArrayType^ UnsoldListReturn {
    PaginatedItemArrayType^ get ();
}


GetMyMessagesCall Class

GetMyMessagesCall Class
Namespaces ► eBay.Service.Call ► GetMyMessagesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetMyMessagesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetMyMessagesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetMyMessagesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyMessagesCall()()()() |
 | GetMyMessagesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | AlertIDList | Gets or sets the AlertIDs of type StringCollection.
 | AlertList | Gets the returned Alerts of type MyMessagesAlertTypeCollection.
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetMyMessagesRequestType for this API call.
 | ApiResponse | Gets the GetMyMessagesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets or sets the EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | ExternalMessageIDList | Gets or sets the ExternalMessageIDs of type StringCollection.
 | Finalize()()()() | (Inherited from Object.)
 | FolderID | Gets or sets the FolderID of type Int64.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetMyMessages(StringCollection, StringCollection, Int64, DateTime, DateTime, StringCollection, PaginationType, Boolean) | Retrieves information about the messages sent to a given user.
 | GetMyMessages()()()() | For backward compatibility with old wrappers.
 | GetMyMessages(StringCollection, StringCollection, Int64) | For backward compatibility with old wrappers. Used to retrieve information about the messages and alerts sent to a given user. Depending on the detail level, this information can include message and alert counts, resolution and flagged status, message and/or alert headers, and message and/or alert body text. Note that this call requires a DetailLevel in the request. Omitting the Detail Level returns an error. ItemID is not returned with this call. Use GetMemberMessages instead.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeHighPriorityMessageOnly | Gets or sets the IncludeHighPriorityMessageOnly of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageIDList | Gets or sets the MessageIDs of type StringCollection.
 | MessageList | Gets the returned Messages of type MyMessagesMessageTypeCollection.
 | OutputSelector | (Inherited from ApiCall.)
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets or sets the StartTime of type DateTime.
 | Summary | Gets the returned Summary of type MyMessagesSummaryType.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetMyMessagesCall


AlertIDList Property

AlertIDList Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► AlertIDList
Gets or sets the AlertIDs of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection AlertIDList { get; set; }
Public Property AlertIDList As StringCollection
    Get
    Set
public:
property StringCollection^ AlertIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


AlertList Property

AlertList Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► AlertList
Gets the returned Alerts of type MyMessagesAlertTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesAlertTypeCollection AlertList { get; }
Public ReadOnly Property AlertList As MyMessagesAlertTypeCollection
    Get
public:
property MyMessagesAlertTypeCollection^ AlertList {
    MyMessagesAlertTypeCollection^ get ();
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► ApiRequest
Gets or sets the GetMyMessagesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMyMessagesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetMyMessagesRequestType
    Get
    Set
public:
property GetMyMessagesRequestType^ ApiRequest {
    GetMyMessagesRequestType^ get ();
    void set (GetMyMessagesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► ApiResponse
Gets the GetMyMessagesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetMyMessagesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetMyMessagesResponseType
    Get
public:
property GetMyMessagesResponseType^ ApiResponse {
    GetMyMessagesResponseType^ get ();
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► EndTime
Gets or sets the EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


ExternalMessageIDList Property

ExternalMessageIDList Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► ExternalMessageIDList
Gets or sets the ExternalMessageIDs of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ExternalMessageIDList { get; set; }
Public Property ExternalMessageIDList As StringCollection
    Get
    Set
public:
property StringCollection^ ExternalMessageIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► FolderID
Gets or sets the FolderID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


GetMyMessages Method

GetMyMessages Method
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► GetMyMessages()()()()
Members
Icon | Member | Description
 | GetMyMessages(StringCollection, StringCollection, Int64, DateTime, DateTime, StringCollection, PaginationType, Boolean) | Retrieves information about the messages sent to a given user.
 | GetMyMessages()()()() | For backward compatibility with old wrappers.
 | GetMyMessages(StringCollection, StringCollection, Int64) | For backward compatibility with old wrappers. Used to retrieve information about the messages and alerts sent to a given user. Depending on the detail level, this information can include message and alert counts, resolution and flagged status, message and/or alert headers, and message and/or alert body text. Note that this call requires a DetailLevel in the request. Omitting the Detail Level returns an error. ItemID is not returned with this call. Use GetMemberMessages instead.


GetMyMessages Method

GetMyMessages Method
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► GetMyMessages()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void GetMyMessages()
Public Sub GetMyMessages
public:
void GetMyMessages()


GetMyMessages Method (AlertIDList, MessageIDList, FolderID)

GetMyMessages Method (AlertIDList, MessageIDList, FolderID)
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► GetMyMessages(StringCollection, StringCollection, Int64)
For backward compatibility with old wrappers. Used to retrieve information about the messages and alerts sent to a given user. Depending on the detail level, this information can include message and alert counts, resolution and flagged status, message and/or alert headers, and message and/or alert body text.

Note that this call requires a DetailLevel in the request. Omitting the Detail Level returns an error.

ItemID is not returned with this call. Use GetMemberMessages instead.
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesSummaryType GetMyMessages(
    StringCollection AlertIDList,
    StringCollection MessageIDList,
    long FolderID
)
Public Function GetMyMessages ( _
    AlertIDList As StringCollection, _
    MessageIDList As StringCollection, _
    FolderID As Long _
) As MyMessagesSummaryType
public:
MyMessagesSummaryType^ GetMyMessages(
    StringCollection^ AlertIDList,
    StringCollection^ MessageIDList,
    long long FolderID
)
Parameters
AlertIDList (StringCollection)
Contains a list of up to 10 AlertID values. When AlertID values are used as input, you must generally specify either AlertID values, or MessageID values, or both.
MessageIDList (StringCollection)
Contains a list of up to 10 MessageID values. When MessageID values are used as input, you must generally specify either AlertID values, or MessageID values, or both.
FolderID (Int64)
An ID that uniquely identifies the My Messages folder from which to retrieve alerts or messages.


GetMyMessages Method (AlertIDList, MessageIDList, FolderID, StartTime, EndTime, ExternalMessageIDList, Pagination, IncludeHighPriorityMessageOnly)

GetMyMessages Method (AlertIDList, MessageIDList, FolderID, StartTime, EndTime, ExternalMessageIDList, Pagination, IncludeHighPriorityMessageOnly)
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► GetMyMessages(StringCollection, StringCollection, Int64, DateTime, DateTime, StringCollection, PaginationType, Boolean)
Retrieves information about the messages sent to a given user.
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesSummaryType GetMyMessages(
    StringCollection AlertIDList,
    StringCollection MessageIDList,
    long FolderID,
    DateTime StartTime,
    DateTime EndTime,
    StringCollection ExternalMessageIDList,
    PaginationType Pagination,
    bool IncludeHighPriorityMessageOnly
)
Public Function GetMyMessages ( _
    AlertIDList As StringCollection, _
    MessageIDList As StringCollection, _
    FolderID As Long, _
    StartTime As DateTime, _
    EndTime As DateTime, _
    ExternalMessageIDList As StringCollection, _
    Pagination As PaginationType, _
    IncludeHighPriorityMessageOnly As Boolean _
) As MyMessagesSummaryType
public:
MyMessagesSummaryType^ GetMyMessages(
    StringCollection^ AlertIDList,
    StringCollection^ MessageIDList,
    long long FolderID,
    DateTime StartTime,
    DateTime EndTime,
    StringCollection^ ExternalMessageIDList,
    PaginationType^ Pagination,
    bool IncludeHighPriorityMessageOnly
)
Parameters
AlertIDList (StringCollection)
This container is deprecated.
MessageIDList (StringCollection)
Container consisting of one to 10 MessageID fields.
FolderID (Int64)
A unique identifier for a My Messages folder. If a FolderID is provided, only messages from the specified folder are returned in the response.
StartTime (DateTime)
The beginning of the date-range filter. Filtering takes into account the entire timestamp of when messages were sent. Messages expire after one year.
EndTime (DateTime)
The end of the date-range filter. See StartTime (which is the beginning of the date-range filter).
ExternalMessageIDList (StringCollection)
This field is currently available on the US site. A container for IDs that uniquely identify messages for a given user. If provided at the time of message creation, this ID can be used to retrieve messages and will take precedence over message ID.
Pagination (PaginationType)
Specifies how to create virtual pages in the returned list (such as total number of entries and total number of pages to return). Default for EntriesPerPage with GetMyMessages is 25.
IncludeHighPriorityMessageOnly (Boolean)
If this field is included in the request and set to True, only High Priority messages are returned in the response.


GetMyMessagesCall Constructor

GetMyMessagesCall Constructor
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► GetMyMessagesCall()()()()
Members
Icon | Member | Description
 | GetMyMessagesCall()()()() |
 | GetMyMessagesCall(ApiContext) |


GetMyMessagesCall Constructor

GetMyMessagesCall Constructor
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► GetMyMessagesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyMessagesCall()
Public Sub New
public:
GetMyMessagesCall()


GetMyMessagesCall Constructor (ApiContext)

GetMyMessagesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► GetMyMessagesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetMyMessagesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetMyMessagesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


IncludeHighPriorityMessageOnly Property

IncludeHighPriorityMessageOnly Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► IncludeHighPriorityMessageOnly
Gets or sets the IncludeHighPriorityMessageOnly of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeHighPriorityMessageOnly { get; set; }
Public Property IncludeHighPriorityMessageOnly As Boolean
    Get
    Set
public:
property bool IncludeHighPriorityMessageOnly {
    bool get ();
    void set (bool value);
}


MessageIDList Property

MessageIDList Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► MessageIDList
Gets or sets the MessageIDs of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection MessageIDList { get; set; }
Public Property MessageIDList As StringCollection
    Get
    Set
public:
property StringCollection^ MessageIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


MessageList Property

MessageList Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► MessageList
Gets the returned Messages of type MyMessagesMessageTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesMessageTypeCollection MessageList { get; }
Public ReadOnly Property MessageList As MyMessagesMessageTypeCollection
    Get
public:
property MyMessagesMessageTypeCollection^ MessageList {
    MyMessagesMessageTypeCollection^ get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► StartTime
Gets or sets the StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


Summary Property

Summary Property
Namespaces ► eBay.Service.Call ► GetMyMessagesCall ► Summary
Gets the returned Summary of type MyMessagesSummaryType.
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesSummaryType Summary { get; }
Public ReadOnly Property Summary As MyMessagesSummaryType
    Get
public:
property MyMessagesSummaryType^ Summary {
    MyMessagesSummaryType^ get ();
}


GetNotificationPreferencesCall Class

GetNotificationPreferencesCall Class
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetNotificationPreferencesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetNotificationPreferencesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetNotificationPreferencesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetNotificationPreferencesCall()()()() |
 | GetNotificationPreferencesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetNotificationPreferencesRequestType for this API call.
 | ApiResponse | Gets the GetNotificationPreferencesResponseType for this API call.
 | ApplicationDeliveryPreferences | Gets the returned ApplicationDeliveryPreferences of type ApplicationDeliveryPreferencesType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeliveryURLName | Gets the returned DeliveryURLName of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | EventPropertyList | Gets the returned EventProperty of type NotificationEventPropertyTypeCollection.
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNotificationPreferences(NotificationRoleCodeType) | Retrieves the requesting application's notification preferences. Details are only returned for events for which a preference has been set. For example, if you enabled notification for the EndOfAuction event and later disabled it, the GetNotificationPreferences response would cite the EndOfAuction event preference as Disabled. Otherwise, no details would be returned regarding EndOfAuction.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PreferenceLevel | Gets or sets the PreferenceLevel of type NotificationRoleCodeType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UserData | Gets the returned UserData of type NotificationUserDataType.
 | UserDeliveryPreferenceList | Gets the returned UserDeliveryPreferenceArray of type NotificationEnableTypeCollection.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetNotificationPreferencesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► ApiRequest
Gets or sets the GetNotificationPreferencesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationPreferencesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetNotificationPreferencesRequestType
    Get
    Set
public:
property GetNotificationPreferencesRequestType^ ApiRequest {
    GetNotificationPreferencesRequestType^ get ();
    void set (GetNotificationPreferencesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► ApiResponse
Gets the GetNotificationPreferencesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationPreferencesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetNotificationPreferencesResponseType
    Get
public:
property GetNotificationPreferencesResponseType^ ApiResponse {
    GetNotificationPreferencesResponseType^ get ();
}


ApplicationDeliveryPreferences Property

ApplicationDeliveryPreferences Property
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► ApplicationDeliveryPreferences
Gets the returned ApplicationDeliveryPreferences of type ApplicationDeliveryPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public ApplicationDeliveryPreferencesType ApplicationDeliveryPreferences { get; }
Public ReadOnly Property ApplicationDeliveryPreferences As ApplicationDeliveryPreferencesType
    Get
public:
property ApplicationDeliveryPreferencesType^ ApplicationDeliveryPreferences {
    ApplicationDeliveryPreferencesType^ get ();
}


DeliveryURLName Property

DeliveryURLName Property
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► DeliveryURLName
Gets the returned DeliveryURLName of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryURLName { get; }
Public ReadOnly Property DeliveryURLName As String
    Get
public:
property String^ DeliveryURLName {
    String^ get ();
}


EventPropertyList Property

EventPropertyList Property
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► EventPropertyList
Gets the returned EventProperty of type NotificationEventPropertyTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyTypeCollection EventPropertyList { get; }
Public ReadOnly Property EventPropertyList As NotificationEventPropertyTypeCollection
    Get
public:
property NotificationEventPropertyTypeCollection^ EventPropertyList {
    NotificationEventPropertyTypeCollection^ get ();
}


GetNotificationPreferences Method (PreferenceLevel)

GetNotificationPreferences Method (PreferenceLevel)
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► GetNotificationPreferences(NotificationRoleCodeType)
Retrieves the requesting application's notification preferences. Details are only returned for events for which a preference has been set. For example, if you enabled notification for the EndOfAuction event and later disabled it, the GetNotificationPreferences response would cite the EndOfAuction event preference as Disabled. Otherwise, no details would be returned regarding EndOfAuction.
Declaration Syntax
C# Visual Basic Visual C++
public void GetNotificationPreferences(
    NotificationRoleCodeType PreferenceLevel
)
Public Sub GetNotificationPreferences ( _
    PreferenceLevel As NotificationRoleCodeType _
)
public:
void GetNotificationPreferences(
    NotificationRoleCodeType PreferenceLevel
)
Parameters
PreferenceLevel (NotificationRoleCodeType)
Specifies the type of preferences to retrieve. For example, preferences can be associated with a user, with an application, or with events.


GetNotificationPreferencesCall Constructor

GetNotificationPreferencesCall Constructor
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► GetNotificationPreferencesCall()()()()
Members
Icon | Member | Description
 | GetNotificationPreferencesCall()()()() |
 | GetNotificationPreferencesCall(ApiContext) |


GetNotificationPreferencesCall Constructor

GetNotificationPreferencesCall Constructor
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► GetNotificationPreferencesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationPreferencesCall()
Public Sub New
public:
GetNotificationPreferencesCall()


GetNotificationPreferencesCall Constructor (ApiContext)

GetNotificationPreferencesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► GetNotificationPreferencesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationPreferencesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetNotificationPreferencesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


PreferenceLevel Property

PreferenceLevel Property
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► PreferenceLevel
Gets or sets the PreferenceLevel of type NotificationRoleCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public NotificationRoleCodeType PreferenceLevel { get; set; }
Public Property PreferenceLevel As NotificationRoleCodeType
    Get
    Set
public:
property NotificationRoleCodeType PreferenceLevel {
    NotificationRoleCodeType get ();
    void set (NotificationRoleCodeType value);
}


UserData Property

UserData Property
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► UserData
Gets the returned UserData of type NotificationUserDataType.
Declaration Syntax
C# Visual Basic Visual C++
public NotificationUserDataType UserData { get; }
Public ReadOnly Property UserData As NotificationUserDataType
    Get
public:
property NotificationUserDataType^ UserData {
    NotificationUserDataType^ get ();
}


UserDeliveryPreferenceList Property

UserDeliveryPreferenceList Property
Namespaces ► eBay.Service.Call ► GetNotificationPreferencesCall ► UserDeliveryPreferenceList
Gets the returned UserDeliveryPreferenceArray of type NotificationEnableTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEnableTypeCollection UserDeliveryPreferenceList { get; }
Public ReadOnly Property UserDeliveryPreferenceList As NotificationEnableTypeCollection
    Get
public:
property NotificationEnableTypeCollection^ UserDeliveryPreferenceList {
    NotificationEnableTypeCollection^ get ();
}


GetNotificationsUsageCall Class

GetNotificationsUsageCall Class
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetNotificationsUsageCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetNotificationsUsageCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetNotificationsUsageCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetNotificationsUsageCall()()()() |
 | GetNotificationsUsageCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetNotificationsUsageRequestType for this API call.
 | ApiResponse | Gets the GetNotificationsUsageResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets or sets the EndTime of type DateTime.
 | EndTimeReturn | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNotificationsUsage(DateTime, DateTime, String) | Retrieves usage information about platform notifications for a given application. You can use this notification information to troubleshoot issues with platform notifications. You can call this up to 50 times per hour for a given application.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MarkUpMarkDownHistoryList | Gets the returned MarkUpMarkDownHistory of type MarkUpMarkDownEventTypeCollection.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NotificationDetailsList | Gets the returned NotificationDetailsArray of type NotificationDetailsTypeCollection.
 | NotificationStatistics | Gets the returned NotificationStatistics of type NotificationStatisticsType.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets or sets the StartTime of type DateTime.
 | StartTimeReturn | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetNotificationsUsageCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► ApiRequest
Gets or sets the GetNotificationsUsageRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationsUsageRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetNotificationsUsageRequestType
    Get
    Set
public:
property GetNotificationsUsageRequestType^ ApiRequest {
    GetNotificationsUsageRequestType^ get ();
    void set (GetNotificationsUsageRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► ApiResponse
Gets the GetNotificationsUsageResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationsUsageResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetNotificationsUsageResponseType
    Get
public:
property GetNotificationsUsageResponseType^ ApiResponse {
    GetNotificationsUsageResponseType^ get ();
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► EndTime
Gets or sets the EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeReturn Property

EndTimeReturn Property
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► EndTimeReturn
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeReturn { get; }
Public ReadOnly Property EndTimeReturn As DateTime
    Get
public:
property DateTime EndTimeReturn {
    DateTime get ();
}


GetNotificationsUsage Method (StartTime, EndTime, ItemID)

GetNotificationsUsage Method (StartTime, EndTime, ItemID)
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► GetNotificationsUsage(DateTime, DateTime, String)
Retrieves usage information about platform notifications for a given application. You can use this notification information to troubleshoot issues with platform notifications. You can call this up to 50 times per hour for a given application.
Declaration Syntax
C# Visual Basic Visual C++
public void GetNotificationsUsage(
    DateTime StartTime,
    DateTime EndTime,
    string ItemID
)
Public Sub GetNotificationsUsage ( _
    StartTime As DateTime, _
    EndTime As DateTime, _
    ItemID As String _
)
public:
void GetNotificationsUsage(
    DateTime StartTime,
    DateTime EndTime,
    String^ ItemID
)
Parameters
StartTime (DateTime)
Specifies the start date and time for which notification information will be retrieved. StartTime is optional. If no StartTime is specified, the default value of 24 hours prior to the call time is used. If no StartTime is specified or if an invalid StartTime is specified, date range errors are returned in the response. For a StartTime to be valid, it must be no more than 72 hours before the time of the call, it cannot be more recent than the EndTime, and it cannot be later than the time of the call. If an invalid StartTime is specified, the default value is used.
EndTime (DateTime)
Specifies the end date and time for which notification information will be retrieved. EndTime is optional.

If no EndTime is specified, the current time (the time the call is made) is used. If no EndTime is specified or if an invalid EndTime is specified, date range errors are returned in the response. For an EndTime to be valid, it must be no more than 72 hours before the time the of the call, it cannot be before the StartTime, and it cannot be later than the time of the call. If an invalid EndTime is specified, the current time is used.
ItemID (String)
Specifies an item ID for which detailed notification information will be retrieved. ItemID is optional. If no ItemID is specified, the response will not include any individual notification details.


GetNotificationsUsageCall Constructor

GetNotificationsUsageCall Constructor
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► GetNotificationsUsageCall()()()()
Members
Icon | Member | Description
 | GetNotificationsUsageCall()()()() |
 | GetNotificationsUsageCall(ApiContext) |


GetNotificationsUsageCall Constructor

GetNotificationsUsageCall Constructor
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► GetNotificationsUsageCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationsUsageCall()
Public Sub New
public:
GetNotificationsUsageCall()


GetNotificationsUsageCall Constructor (ApiContext)

GetNotificationsUsageCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► GetNotificationsUsageCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationsUsageCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetNotificationsUsageCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MarkUpMarkDownHistoryList Property

MarkUpMarkDownHistoryList Property
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► MarkUpMarkDownHistoryList
Gets the returned MarkUpMarkDownHistory of type MarkUpMarkDownEventTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public MarkUpMarkDownEventTypeCollection MarkUpMarkDownHistoryList { get; }
Public ReadOnly Property MarkUpMarkDownHistoryList As MarkUpMarkDownEventTypeCollection
    Get
public:
property MarkUpMarkDownEventTypeCollection^ MarkUpMarkDownHistoryList {
    MarkUpMarkDownEventTypeCollection^ get ();
}


NotificationDetailsList Property

NotificationDetailsList Property
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► NotificationDetailsList
Gets the returned NotificationDetailsArray of type NotificationDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public NotificationDetailsTypeCollection NotificationDetailsList { get; }
Public ReadOnly Property NotificationDetailsList As NotificationDetailsTypeCollection
    Get
public:
property NotificationDetailsTypeCollection^ NotificationDetailsList {
    NotificationDetailsTypeCollection^ get ();
}


NotificationStatistics Property

NotificationStatistics Property
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► NotificationStatistics
Gets the returned NotificationStatistics of type NotificationStatisticsType.
Declaration Syntax
C# Visual Basic Visual C++
public NotificationStatisticsType NotificationStatistics { get; }
Public ReadOnly Property NotificationStatistics As NotificationStatisticsType
    Get
public:
property NotificationStatisticsType^ NotificationStatistics {
    NotificationStatisticsType^ get ();
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► StartTime
Gets or sets the StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeReturn Property

StartTimeReturn Property
Namespaces ► eBay.Service.Call ► GetNotificationsUsageCall ► StartTimeReturn
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTimeReturn { get; }
Public ReadOnly Property StartTimeReturn As DateTime
    Get
public:
property DateTime StartTimeReturn {
    DateTime get ();
}


GetOrdersCall Class

GetOrdersCall Class
Namespaces ► eBay.Service.Call ► GetOrdersCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetOrdersCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetOrdersCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetOrdersCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetOrdersCall()()()() |
 | GetOrdersCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetOrdersRequestType for this API call.
 | ApiResponse | Gets the GetOrdersResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CreateTimeFilter | Gets or sets the CreateTimeFrom and CreateTimeTo of type TimeFilter.
 | CreateTimeFrom | Gets or sets the CreateTimeFrom of type DateTime.
 | CreateTimeTo | Gets or sets the CreateTimeTo of type DateTime.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetOrders(StringCollection, DateTime, DateTime, TradingRoleCodeType, OrderStatusCodeType, ListingTypeCodeType, PaginationType, DateTime, DateTime, Int32, Boolean, SortOrderCodeType) |
 | GetOrders(StringCollection) | For backward compatibility with old wrappers.
 | GetOrders(TimeFilter, TradingRoleCodeType, OrderStatusCodeType) | For backward compatibility with old wrappers.
 | GetOrders(DateTime, DateTime, TradingRoleCodeType, OrderStatusCodeType) | For backward compatibility with old wrappers.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasMoreOrders | Gets the returned HasMoreOrders of type Boolean.
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeFinalValueFee | Gets or sets the IncludeFinalValueFee of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ListingType | Gets or sets the ListingType of type ListingTypeCodeType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModTimeFrom | Gets or sets the ModTimeFrom of type DateTime.
 | ModTimeTo | Gets or sets the ModTimeTo of type DateTime.
 | NumberOfDays | Gets or sets the NumberOfDays of type Int32.
 | OrderIDList | Gets or sets the OrderIDArray of type StringCollection.
 | OrderList | Gets the returned OrderArray of type OrderTypeCollection.
 | OrderRole | Gets or sets the OrderRole of type TradingRoleCodeType.
 | OrdersPerPage | Gets the returned OrdersPerPage of type Int32.
 | OrderStatus | Gets or sets the OrderStatus of type OrderStatusCodeType.
 | OutputSelector | (Inherited from ApiCall.)
 | PageNumber | Gets the returned PageNumber of type Int32.
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReturnedOrderCountActual | Gets the returned ReturnedOrderCountActual of type Int32.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | SortingOrder | Gets or sets the SortingOrder of type SortOrderCodeType.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetOrdersCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► ApiRequest
Gets or sets the GetOrdersRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetOrdersRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetOrdersRequestType
    Get
    Set
public:
property GetOrdersRequestType^ ApiRequest {
    GetOrdersRequestType^ get ();
    void set (GetOrdersRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► ApiResponse
Gets the GetOrdersResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetOrdersResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetOrdersResponseType
    Get
public:
property GetOrdersResponseType^ ApiResponse {
    GetOrdersResponseType^ get ();
}


CreateTimeFilter Property

CreateTimeFilter Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► CreateTimeFilter
Gets or sets the CreateTimeFrom and CreateTimeTo of type TimeFilter.
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter CreateTimeFilter { get; set; }
Public Property CreateTimeFilter As TimeFilter
    Get
    Set
public:
property TimeFilter^ CreateTimeFilter {
    TimeFilter^ get ();
    void set (TimeFilter^ value);
}


CreateTimeFrom Property

CreateTimeFrom Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► CreateTimeFrom
Gets or sets the CreateTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreateTimeFrom { get; set; }
Public Property CreateTimeFrom As DateTime
    Get
    Set
public:
property DateTime CreateTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


CreateTimeTo Property

CreateTimeTo Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► CreateTimeTo
Gets or sets the CreateTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreateTimeTo { get; set; }
Public Property CreateTimeTo As DateTime
    Get
    Set
public:
property DateTime CreateTimeTo {
    DateTime get ();
    void set (DateTime value);
}


GetOrders Method

GetOrders Method
Namespaces ► eBay.Service.Call ► GetOrdersCall ► GetOrders()()()()
Members
Icon | Member | Description
 | GetOrders(StringCollection, DateTime, DateTime, TradingRoleCodeType, OrderStatusCodeType, ListingTypeCodeType, PaginationType, DateTime, DateTime, Int32, Boolean, SortOrderCodeType) |
 | GetOrders(StringCollection) | For backward compatibility with old wrappers.
 | GetOrders(TimeFilter, TradingRoleCodeType, OrderStatusCodeType) | For backward compatibility with old wrappers.
 | GetOrders(DateTime, DateTime, TradingRoleCodeType, OrderStatusCodeType) | For backward compatibility with old wrappers.


GetOrders Method (CreateTimeFilter, OrderRole, OrderStatus)

GetOrders Method (CreateTimeFilter, OrderRole, OrderStatus)
Namespaces ► eBay.Service.Call ► GetOrdersCall ► GetOrders(TimeFilter, TradingRoleCodeType, OrderStatusCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection GetOrders(
    TimeFilter CreateTimeFilter,
    TradingRoleCodeType OrderRole,
    OrderStatusCodeType OrderStatus
)
Public Function GetOrders ( _
    CreateTimeFilter As TimeFilter, _
    OrderRole As TradingRoleCodeType, _
    OrderStatus As OrderStatusCodeType _
) As OrderTypeCollection
public:
OrderTypeCollection^ GetOrders(
    TimeFilter^ CreateTimeFilter,
    TradingRoleCodeType OrderRole,
    OrderStatusCodeType OrderStatus
)
Parameters
CreateTimeFilter (TimeFilter)
OrderRole (TradingRoleCodeType)
OrderStatus (OrderStatusCodeType)


GetOrders Method (CreateTimeFrom, CreateTimeTo, OrderRole, OrderStatus)

GetOrders Method (CreateTimeFrom, CreateTimeTo, OrderRole, OrderStatus)
Namespaces ► eBay.Service.Call ► GetOrdersCall ► GetOrders(DateTime, DateTime, TradingRoleCodeType, OrderStatusCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection GetOrders(
    DateTime CreateTimeFrom,
    DateTime CreateTimeTo,
    TradingRoleCodeType OrderRole,
    OrderStatusCodeType OrderStatus
)
Public Function GetOrders ( _
    CreateTimeFrom As DateTime, _
    CreateTimeTo As DateTime, _
    OrderRole As TradingRoleCodeType, _
    OrderStatus As OrderStatusCodeType _
) As OrderTypeCollection
public:
OrderTypeCollection^ GetOrders(
    DateTime CreateTimeFrom,
    DateTime CreateTimeTo,
    TradingRoleCodeType OrderRole,
    OrderStatusCodeType OrderStatus
)
Parameters
CreateTimeFrom (DateTime)
CreateTimeTo (DateTime)
OrderRole (TradingRoleCodeType)
OrderStatus (OrderStatusCodeType)


GetOrders Method (OrderIDList)

GetOrders Method (OrderIDList)
Namespaces ► eBay.Service.Call ► GetOrdersCall ► GetOrders(StringCollection)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection GetOrders(
    StringCollection OrderIDList
)
Public Function GetOrders ( _
    OrderIDList As StringCollection _
) As OrderTypeCollection
public:
OrderTypeCollection^ GetOrders(
    StringCollection^ OrderIDList
)
Parameters
OrderIDList (StringCollection)


GetOrders Method (OrderIDList, CreateTimeFrom, CreateTimeTo, OrderRole, OrderStatus, ListingType, Pagination, ModTimeFrom, ModTimeTo, NumberOfDays, IncludeFinalValueFee, SortingOrder)

GetOrders Method (OrderIDList, CreateTimeFrom, CreateTimeTo, OrderRole, OrderStatus, ListingType, Pagination, ModTimeFrom, ModTimeTo, NumberOfDays, IncludeFinalValueFee, SortingOrder)
Namespaces ► eBay.Service.Call ► GetOrdersCall ► GetOrders(StringCollection, DateTime, DateTime, TradingRoleCodeType, OrderStatusCodeType, ListingTypeCodeType, PaginationType, DateTime, DateTime, Int32, Boolean, SortOrderCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection GetOrders(
    StringCollection OrderIDList,
    DateTime CreateTimeFrom,
    DateTime CreateTimeTo,
    TradingRoleCodeType OrderRole,
    OrderStatusCodeType OrderStatus,
    ListingTypeCodeType ListingType,
    PaginationType Pagination,
    DateTime ModTimeFrom,
    DateTime ModTimeTo,
    int NumberOfDays,
    bool IncludeFinalValueFee,
    SortOrderCodeType SortingOrder
)
Public Function GetOrders ( _
    OrderIDList As StringCollection, _
    CreateTimeFrom As DateTime, _
    CreateTimeTo As DateTime, _
    OrderRole As TradingRoleCodeType, _
    OrderStatus As OrderStatusCodeType, _
    ListingType As ListingTypeCodeType, _
    Pagination As PaginationType, _
    ModTimeFrom As DateTime, _
    ModTimeTo As DateTime, _
    NumberOfDays As Integer, _
    IncludeFinalValueFee As Boolean, _
    SortingOrder As SortOrderCodeType _
) As OrderTypeCollection
public:
OrderTypeCollection^ GetOrders(
    StringCollection^ OrderIDList,
    DateTime CreateTimeFrom,
    DateTime CreateTimeTo,
    TradingRoleCodeType OrderRole,
    OrderStatusCodeType OrderStatus,
    ListingTypeCodeType ListingType,
    PaginationType^ Pagination,
    DateTime ModTimeFrom,
    DateTime ModTimeTo,
    int NumberOfDays,
    bool IncludeFinalValueFee,
    SortOrderCodeType SortingOrder
)
Parameters
OrderIDList (StringCollection)
CreateTimeFrom (DateTime)
CreateTimeTo (DateTime)
OrderRole (TradingRoleCodeType)
OrderStatus (OrderStatusCodeType)
ListingType (ListingTypeCodeType)
Pagination (PaginationType)
ModTimeFrom (DateTime)
ModTimeTo (DateTime)
NumberOfDays (Int32)
IncludeFinalValueFee (Boolean)
SortingOrder (SortOrderCodeType)


GetOrdersCall Constructor

GetOrdersCall Constructor
Namespaces ► eBay.Service.Call ► GetOrdersCall ► GetOrdersCall()()()()
Members
Icon | Member | Description
 | GetOrdersCall()()()() |
 | GetOrdersCall(ApiContext) |


GetOrdersCall Constructor

GetOrdersCall Constructor
Namespaces ► eBay.Service.Call ► GetOrdersCall ► GetOrdersCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetOrdersCall()
Public Sub New
public:
GetOrdersCall()


GetOrdersCall Constructor (ApiContext)

GetOrdersCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetOrdersCall ► GetOrdersCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetOrdersCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetOrdersCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HasMoreOrders Property

HasMoreOrders Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► HasMoreOrders
Gets the returned HasMoreOrders of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreOrders { get; }
Public ReadOnly Property HasMoreOrders As Boolean
    Get
public:
property bool HasMoreOrders {
    bool get ();
}


IncludeFinalValueFee Property

IncludeFinalValueFee Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► IncludeFinalValueFee
Gets or sets the IncludeFinalValueFee of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFee { get; set; }
Public Property IncludeFinalValueFee As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFee {
    bool get ();
    void set (bool value);
}


ListingType Property

ListingType Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► ListingType
Gets or sets the ListingType of type ListingTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingTypeCodeType ListingType { get; set; }
Public Property ListingType As ListingTypeCodeType
    Get
    Set
public:
property ListingTypeCodeType ListingType {
    ListingTypeCodeType get ();
    void set (ListingTypeCodeType value);
}


ModTimeFrom Property

ModTimeFrom Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► ModTimeFrom
Gets or sets the ModTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeFrom { get; set; }
Public Property ModTimeFrom As DateTime
    Get
    Set
public:
property DateTime ModTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


ModTimeTo Property

ModTimeTo Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► ModTimeTo
Gets or sets the ModTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeTo { get; set; }
Public Property ModTimeTo As DateTime
    Get
    Set
public:
property DateTime ModTimeTo {
    DateTime get ();
    void set (DateTime value);
}


NumberOfDays Property

NumberOfDays Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► NumberOfDays
Gets or sets the NumberOfDays of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfDays { get; set; }
Public Property NumberOfDays As Integer
    Get
    Set
public:
property int NumberOfDays {
    int get ();
    void set (int value);
}


OrderIDList Property

OrderIDList Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► OrderIDList
Gets or sets the OrderIDArray of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection OrderIDList { get; set; }
Public Property OrderIDList As StringCollection
    Get
    Set
public:
property StringCollection^ OrderIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


OrderList Property

OrderList Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► OrderList
Gets the returned OrderArray of type OrderTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection OrderList { get; }
Public ReadOnly Property OrderList As OrderTypeCollection
    Get
public:
property OrderTypeCollection^ OrderList {
    OrderTypeCollection^ get ();
}


OrderRole Property

OrderRole Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► OrderRole
Gets or sets the OrderRole of type TradingRoleCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public TradingRoleCodeType OrderRole { get; set; }
Public Property OrderRole As TradingRoleCodeType
    Get
    Set
public:
property TradingRoleCodeType OrderRole {
    TradingRoleCodeType get ();
    void set (TradingRoleCodeType value);
}


OrdersPerPage Property

OrdersPerPage Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► OrdersPerPage
Gets the returned OrdersPerPage of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int OrdersPerPage { get; }
Public ReadOnly Property OrdersPerPage As Integer
    Get
public:
property int OrdersPerPage {
    int get ();
}


OrderStatus Property

OrderStatus Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► OrderStatus
Gets or sets the OrderStatus of type OrderStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public OrderStatusCodeType OrderStatus { get; set; }
Public Property OrderStatus As OrderStatusCodeType
    Get
    Set
public:
property OrderStatusCodeType OrderStatus {
    OrderStatusCodeType get ();
    void set (OrderStatusCodeType value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► PageNumber
Gets the returned PageNumber of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
public:
property int PageNumber {
    int get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


ReturnedOrderCountActual Property

ReturnedOrderCountActual Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► ReturnedOrderCountActual
Gets the returned ReturnedOrderCountActual of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int ReturnedOrderCountActual { get; }
Public ReadOnly Property ReturnedOrderCountActual As Integer
    Get
public:
property int ReturnedOrderCountActual {
    int get ();
}


SortingOrder Property

SortingOrder Property
Namespaces ► eBay.Service.Call ► GetOrdersCall ► SortingOrder
Gets or sets the SortingOrder of type SortOrderCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public SortOrderCodeType SortingOrder { get; set; }
Public Property SortingOrder As SortOrderCodeType
    Get
    Set
public:
property SortOrderCodeType SortingOrder {
    SortOrderCodeType get ();
    void set (SortOrderCodeType value);
}


GetOrderTransactionsCall Class

GetOrderTransactionsCall Class
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetOrderTransactionsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetOrderTransactionsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetOrderTransactionsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetOrderTransactionsCall()()()() |
 | GetOrderTransactionsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetOrderTransactionsRequestType for this API call.
 | ApiResponse | Gets the GetOrderTransactionsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetOrderTransactions(ItemTransactionIDTypeCollection, StringCollection, TransactionPlatformCodeType, Boolean) |
 | GetOrderTransactions(ItemTransactionIDTypeCollection) | Retrieves information about one or more orders or one or more transactions (or both), thus displacing the need to call GetOrders and GetItemTransactions separately.
 | GetOrderTransactions(StringCollection) | Retrieves information about one or more orders or one or more transactions (or both), thus displacing the need to call GetOrders and GetItemTransactions separately.
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeFinalValueFees | Gets or sets the IncludeFinalValueFees of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemTransactionIDArrayList | Gets or sets the ItemTransactionIDArray of type ItemTransactionIDTypeCollection.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderIDArrayList | Gets or sets the OrderIDArray of type StringCollection.
 | OrderList | Gets the returned OrderArray of type OrderTypeCollection.
 | OutputSelector | (Inherited from ApiCall.)
 | Platform | Gets or sets the Platform of type TransactionPlatformCodeType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetOrderTransactionsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► ApiRequest
Gets or sets the GetOrderTransactionsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetOrderTransactionsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetOrderTransactionsRequestType
    Get
    Set
public:
property GetOrderTransactionsRequestType^ ApiRequest {
    GetOrderTransactionsRequestType^ get ();
    void set (GetOrderTransactionsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► ApiResponse
Gets the GetOrderTransactionsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetOrderTransactionsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetOrderTransactionsResponseType
    Get
public:
property GetOrderTransactionsResponseType^ ApiResponse {
    GetOrderTransactionsResponseType^ get ();
}


GetOrderTransactions Method

GetOrderTransactions Method
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► GetOrderTransactions()()()()
Members
Icon | Member | Description
 | GetOrderTransactions(ItemTransactionIDTypeCollection, StringCollection, TransactionPlatformCodeType, Boolean) |
 | GetOrderTransactions(ItemTransactionIDTypeCollection) | Retrieves information about one or more orders or one or more transactions (or both), thus displacing the need to call GetOrders and GetItemTransactions separately.
 | GetOrderTransactions(StringCollection) | Retrieves information about one or more orders or one or more transactions (or both), thus displacing the need to call GetOrders and GetItemTransactions separately.


GetOrderTransactions Method (ItemTransactionIDArrayList)

GetOrderTransactions Method (ItemTransactionIDArrayList)
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► GetOrderTransactions(ItemTransactionIDTypeCollection)
Retrieves information about one or more orders or one or more transactions (or both), thus displacing the need to call GetOrders and GetItemTransactions separately.
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection GetOrderTransactions(
    ItemTransactionIDTypeCollection ItemTransactionIDArrayList
)
Public Function GetOrderTransactions ( _
    ItemTransactionIDArrayList As ItemTransactionIDTypeCollection _
) As OrderTypeCollection
public:
OrderTypeCollection^ GetOrderTransactions(
    ItemTransactionIDTypeCollection^ ItemTransactionIDArrayList
)
Parameters
ItemTransactionIDArrayList (ItemTransactionIDTypeCollection)
An array of ItemTransactionIDs.


GetOrderTransactions Method (ItemTransactionIDArrayList, OrderIDArrayList, Platform, IncludeFinalValueFees)

GetOrderTransactions Method (ItemTransactionIDArrayList, OrderIDArrayList, Platform, IncludeFinalValueFees)
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► GetOrderTransactions(ItemTransactionIDTypeCollection, StringCollection, TransactionPlatformCodeType, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection GetOrderTransactions(
    ItemTransactionIDTypeCollection ItemTransactionIDArrayList,
    StringCollection OrderIDArrayList,
    TransactionPlatformCodeType Platform,
    bool IncludeFinalValueFees
)
Public Function GetOrderTransactions ( _
    ItemTransactionIDArrayList As ItemTransactionIDTypeCollection, _
    OrderIDArrayList As StringCollection, _
    Platform As TransactionPlatformCodeType, _
    IncludeFinalValueFees As Boolean _
) As OrderTypeCollection
public:
OrderTypeCollection^ GetOrderTransactions(
    ItemTransactionIDTypeCollection^ ItemTransactionIDArrayList,
    StringCollection^ OrderIDArrayList,
    TransactionPlatformCodeType Platform,
    bool IncludeFinalValueFees
)
Parameters
ItemTransactionIDArrayList (ItemTransactionIDTypeCollection)
OrderIDArrayList (StringCollection)
Platform (TransactionPlatformCodeType)
IncludeFinalValueFees (Boolean)


GetOrderTransactions Method (OrderIDArrayList)

GetOrderTransactions Method (OrderIDArrayList)
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► GetOrderTransactions(StringCollection)
Retrieves information about one or more orders or one or more transactions (or both), thus displacing the need to call GetOrders and GetItemTransactions separately.
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection GetOrderTransactions(
    StringCollection OrderIDArrayList
)
Public Function GetOrderTransactions ( _
    OrderIDArrayList As StringCollection _
) As OrderTypeCollection
public:
OrderTypeCollection^ GetOrderTransactions(
    StringCollection^ OrderIDArrayList
)
Parameters
OrderIDArrayList (StringCollection)
An array of OrderIDs.


GetOrderTransactionsCall Constructor

GetOrderTransactionsCall Constructor
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► GetOrderTransactionsCall()()()()
Members
Icon | Member | Description
 | GetOrderTransactionsCall()()()() |
 | GetOrderTransactionsCall(ApiContext) |


GetOrderTransactionsCall Constructor

GetOrderTransactionsCall Constructor
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► GetOrderTransactionsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetOrderTransactionsCall()
Public Sub New
public:
GetOrderTransactionsCall()


GetOrderTransactionsCall Constructor (ApiContext)

GetOrderTransactionsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► GetOrderTransactionsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetOrderTransactionsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetOrderTransactionsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


IncludeFinalValueFees Property

IncludeFinalValueFees Property
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► IncludeFinalValueFees
Gets or sets the IncludeFinalValueFees of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFees { get; set; }
Public Property IncludeFinalValueFees As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFees {
    bool get ();
    void set (bool value);
}


ItemTransactionIDArrayList Property

ItemTransactionIDArrayList Property
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► ItemTransactionIDArrayList
Gets or sets the ItemTransactionIDArray of type ItemTransactionIDTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ItemTransactionIDTypeCollection ItemTransactionIDArrayList { get; set; }
Public Property ItemTransactionIDArrayList As ItemTransactionIDTypeCollection
    Get
    Set
public:
property ItemTransactionIDTypeCollection^ ItemTransactionIDArrayList {
    ItemTransactionIDTypeCollection^ get ();
    void set (ItemTransactionIDTypeCollection^ value);
}


OrderIDArrayList Property

OrderIDArrayList Property
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► OrderIDArrayList
Gets or sets the OrderIDArray of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection OrderIDArrayList { get; set; }
Public Property OrderIDArrayList As StringCollection
    Get
    Set
public:
property StringCollection^ OrderIDArrayList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


OrderList Property

OrderList Property
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► OrderList
Gets the returned OrderArray of type OrderTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection OrderList { get; }
Public ReadOnly Property OrderList As OrderTypeCollection
    Get
public:
property OrderTypeCollection^ OrderList {
    OrderTypeCollection^ get ();
}


Platform Property

Platform Property
Namespaces ► eBay.Service.Call ► GetOrderTransactionsCall ► Platform
Gets or sets the Platform of type TransactionPlatformCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeType Platform { get; set; }
Public Property Platform As TransactionPlatformCodeType
    Get
    Set
public:
property TransactionPlatformCodeType Platform {
    TransactionPlatformCodeType get ();
    void set (TransactionPlatformCodeType value);
}


GetPromotionalSaleDetailsCall Class

GetPromotionalSaleDetailsCall Class
Namespaces ► eBay.Service.Call ► GetPromotionalSaleDetailsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetPromotionalSaleDetailsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetPromotionalSaleDetailsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetPromotionalSaleDetailsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetPromotionalSaleDetailsCall()()()() |
 | GetPromotionalSaleDetailsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetPromotionalSaleDetailsRequestType for this API call.
 | ApiResponse | Gets the GetPromotionalSaleDetailsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetPromotionalSaleDetails(Int64, PromotionalSaleStatusCodeTypeCollection) | Retrieves information about promotional sales set up by an eBay store owner (the authenticated caller).
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PromotionalSaleDetailList | Gets the returned PromotionalSaleDetails of type PromotionalSaleTypeCollection.
 | PromotionalSaleID | Gets or sets the PromotionalSaleID of type Int64.
 | PromotionalSaleStatuList | Gets or sets the PromotionalSaleStatus of type PromotionalSaleStatusCodeTypeCollection.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetPromotionalSaleDetailsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetPromotionalSaleDetailsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetPromotionalSaleDetailsCall ► ApiRequest
Gets or sets the GetPromotionalSaleDetailsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetPromotionalSaleDetailsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetPromotionalSaleDetailsRequestType
    Get
    Set
public:
property GetPromotionalSaleDetailsRequestType^ ApiRequest {
    GetPromotionalSaleDetailsRequestType^ get ();
    void set (GetPromotionalSaleDetailsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetPromotionalSaleDetailsCall ► ApiResponse
Gets the GetPromotionalSaleDetailsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetPromotionalSaleDetailsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetPromotionalSaleDetailsResponseType
    Get
public:
property GetPromotionalSaleDetailsResponseType^ ApiResponse {
    GetPromotionalSaleDetailsResponseType^ get ();
}


GetPromotionalSaleDetails Method (PromotionalSaleID, PromotionalSaleStatuList)

GetPromotionalSaleDetails Method (PromotionalSaleID, PromotionalSaleStatuList)
Namespaces ► eBay.Service.Call ► GetPromotionalSaleDetailsCall ► GetPromotionalSaleDetails(Int64, PromotionalSaleStatusCodeTypeCollection)
Retrieves information about promotional sales set up by an eBay store owner (the authenticated caller).
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleTypeCollection GetPromotionalSaleDetails(
    long PromotionalSaleID,
    PromotionalSaleStatusCodeTypeCollection PromotionalSaleStatuList
)
Public Function GetPromotionalSaleDetails ( _
    PromotionalSaleID As Long, _
    PromotionalSaleStatuList As PromotionalSaleStatusCodeTypeCollection _
) As PromotionalSaleTypeCollection
public:
PromotionalSaleTypeCollection^ GetPromotionalSaleDetails(
    long long PromotionalSaleID,
    PromotionalSaleStatusCodeTypeCollection^ PromotionalSaleStatuList
)
Parameters
PromotionalSaleID (Int64)
The ID of the promotional sale about which you want information. If you do not specify this field, then all promotional sales for the seller making the call are returned or only those promotional sales matching the specified promotional sale status filter, PromotionalSaleStatus. If PromotionalSaleID and PromotionalSaleStatus are both specified, the single promotional sale specified by ID is returned only if its status matches the specified status filter.
PromotionalSaleStatuList (PromotionalSaleStatusCodeTypeCollection)
Specifies the promotional sales to return, based upon their status. For example, specify Scheduled to retrieve only promotional sales with a Status of Scheduled. If you want to retrieve promotional sales for more than one status, you can repeat the field with an additional status value, such as Active. If this field is used together with PromotionalSaleID, the single promotional sale specified by ID is returned only if its status matches the specified status filter. If neither field is used, all of the seller's promotional sales are returned, regardless of status.


GetPromotionalSaleDetailsCall Constructor

GetPromotionalSaleDetailsCall Constructor
Namespaces ► eBay.Service.Call ► GetPromotionalSaleDetailsCall ► GetPromotionalSaleDetailsCall()()()()
Members
Icon | Member | Description
 | GetPromotionalSaleDetailsCall()()()() |
 | GetPromotionalSaleDetailsCall(ApiContext) |


GetPromotionalSaleDetailsCall Constructor

GetPromotionalSaleDetailsCall Constructor
Namespaces ► eBay.Service.Call ► GetPromotionalSaleDetailsCall ► GetPromotionalSaleDetailsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetPromotionalSaleDetailsCall()
Public Sub New
public:
GetPromotionalSaleDetailsCall()


GetPromotionalSaleDetailsCall Constructor (ApiContext)

GetPromotionalSaleDetailsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetPromotionalSaleDetailsCall ► GetPromotionalSaleDetailsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetPromotionalSaleDetailsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetPromotionalSaleDetailsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


PromotionalSaleDetailList Property

PromotionalSaleDetailList Property
Namespaces ► eBay.Service.Call ► GetPromotionalSaleDetailsCall ► PromotionalSaleDetailList
Gets the returned PromotionalSaleDetails of type PromotionalSaleTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleTypeCollection PromotionalSaleDetailList { get; }
Public ReadOnly Property PromotionalSaleDetailList As PromotionalSaleTypeCollection
    Get
public:
property PromotionalSaleTypeCollection^ PromotionalSaleDetailList {
    PromotionalSaleTypeCollection^ get ();
}


PromotionalSaleID Property

PromotionalSaleID Property
Namespaces ► eBay.Service.Call ► GetPromotionalSaleDetailsCall ► PromotionalSaleID
Gets or sets the PromotionalSaleID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long PromotionalSaleID { get; set; }
Public Property PromotionalSaleID As Long
    Get
    Set
public:
property long long PromotionalSaleID {
    long long get ();
    void set (long long value);
}


PromotionalSaleStatuList Property

PromotionalSaleStatuList Property
Namespaces ► eBay.Service.Call ► GetPromotionalSaleDetailsCall ► PromotionalSaleStatuList
Gets or sets the PromotionalSaleStatus of type PromotionalSaleStatusCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeTypeCollection PromotionalSaleStatuList { get; set; }
Public Property PromotionalSaleStatuList As PromotionalSaleStatusCodeTypeCollection
    Get
    Set
public:
property PromotionalSaleStatusCodeTypeCollection^ PromotionalSaleStatuList {
    PromotionalSaleStatusCodeTypeCollection^ get ();
    void set (PromotionalSaleStatusCodeTypeCollection^ value);
}


GetSellerDashboardCall Class

GetSellerDashboardCall Class
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellerDashboardCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellerDashboardCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellerDashboardCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerDashboardCall()()()() |
 | GetSellerDashboardCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellerDashboardRequestType for this API call.
 | ApiResponse | Gets the GetSellerDashboardResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BuyerSatisfaction | Gets the returned BuyerSatisfaction of type BuyerSatisfactionDashboardType.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellerDashboard()()()() | Retrieves a brief summary of the requester's status as an eBay seller.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PerformanceList | Gets the returned Performance of type PerformanceDashboardTypeCollection.
 | PolicyCompliance | Gets the returned PolicyCompliance of type PolicyComplianceDashboardType.
 | PowerSellerStatus | Gets the returned PowerSellerStatus of type PowerSellerDashboardType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SearchStanding | Gets the returned SearchStanding of type SearchStandingDashboardType.
 | SellerAccount | Gets the returned SellerAccount of type SellerAccountDashboardType.
 | SellerFeeDiscount | Gets the returned SellerFeeDiscount of type SellerFeeDiscountDashboardType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellerDashboardCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► ApiRequest
Gets or sets the GetSellerDashboardRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerDashboardRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellerDashboardRequestType
    Get
    Set
public:
property GetSellerDashboardRequestType^ ApiRequest {
    GetSellerDashboardRequestType^ get ();
    void set (GetSellerDashboardRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► ApiResponse
Gets the GetSellerDashboardResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerDashboardResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellerDashboardResponseType
    Get
public:
property GetSellerDashboardResponseType^ ApiResponse {
    GetSellerDashboardResponseType^ get ();
}


BuyerSatisfaction Property

BuyerSatisfaction Property
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► BuyerSatisfaction
Gets the returned BuyerSatisfaction of type BuyerSatisfactionDashboardType.
Declaration Syntax
C# Visual Basic Visual C++
public BuyerSatisfactionDashboardType BuyerSatisfaction { get; }
Public ReadOnly Property BuyerSatisfaction As BuyerSatisfactionDashboardType
    Get
public:
property BuyerSatisfactionDashboardType^ BuyerSatisfaction {
    BuyerSatisfactionDashboardType^ get ();
}


GetSellerDashboard Method

GetSellerDashboard Method
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► GetSellerDashboard()()()()
Retrieves a brief summary of the requester's status as an eBay seller.
Declaration Syntax
C# Visual Basic Visual C++
public SearchStandingDashboardType GetSellerDashboard()
Public Function GetSellerDashboard As SearchStandingDashboardType
public:
SearchStandingDashboardType^ GetSellerDashboard()


GetSellerDashboardCall Constructor

GetSellerDashboardCall Constructor
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► GetSellerDashboardCall()()()()
Members
Icon | Member | Description
 | GetSellerDashboardCall()()()() |
 | GetSellerDashboardCall(ApiContext) |


GetSellerDashboardCall Constructor

GetSellerDashboardCall Constructor
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► GetSellerDashboardCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerDashboardCall()
Public Sub New
public:
GetSellerDashboardCall()


GetSellerDashboardCall Constructor (ApiContext)

GetSellerDashboardCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► GetSellerDashboardCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerDashboardCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellerDashboardCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


PerformanceList Property

PerformanceList Property
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► PerformanceList
Gets the returned Performance of type PerformanceDashboardTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceDashboardTypeCollection PerformanceList { get; }
Public ReadOnly Property PerformanceList As PerformanceDashboardTypeCollection
    Get
public:
property PerformanceDashboardTypeCollection^ PerformanceList {
    PerformanceDashboardTypeCollection^ get ();
}


PolicyCompliance Property

PolicyCompliance Property
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► PolicyCompliance
Gets the returned PolicyCompliance of type PolicyComplianceDashboardType.
Declaration Syntax
C# Visual Basic Visual C++
public PolicyComplianceDashboardType PolicyCompliance { get; }
Public ReadOnly Property PolicyCompliance As PolicyComplianceDashboardType
    Get
public:
property PolicyComplianceDashboardType^ PolicyCompliance {
    PolicyComplianceDashboardType^ get ();
}


PowerSellerStatus Property

PowerSellerStatus Property
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► PowerSellerStatus
Gets the returned PowerSellerStatus of type PowerSellerDashboardType.
Declaration Syntax
C# Visual Basic Visual C++
public PowerSellerDashboardType PowerSellerStatus { get; }
Public ReadOnly Property PowerSellerStatus As PowerSellerDashboardType
    Get
public:
property PowerSellerDashboardType^ PowerSellerStatus {
    PowerSellerDashboardType^ get ();
}


SearchStanding Property

SearchStanding Property
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► SearchStanding
Gets the returned SearchStanding of type SearchStandingDashboardType.
Declaration Syntax
C# Visual Basic Visual C++
public SearchStandingDashboardType SearchStanding { get; }
Public ReadOnly Property SearchStanding As SearchStandingDashboardType
    Get
public:
property SearchStandingDashboardType^ SearchStanding {
    SearchStandingDashboardType^ get ();
}


SellerAccount Property

SellerAccount Property
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► SellerAccount
Gets the returned SellerAccount of type SellerAccountDashboardType.
Declaration Syntax
C# Visual Basic Visual C++
public SellerAccountDashboardType SellerAccount { get; }
Public ReadOnly Property SellerAccount As SellerAccountDashboardType
    Get
public:
property SellerAccountDashboardType^ SellerAccount {
    SellerAccountDashboardType^ get ();
}


SellerFeeDiscount Property

SellerFeeDiscount Property
Namespaces ► eBay.Service.Call ► GetSellerDashboardCall ► SellerFeeDiscount
Gets the returned SellerFeeDiscount of type SellerFeeDiscountDashboardType.
Declaration Syntax
C# Visual Basic Visual C++
public SellerFeeDiscountDashboardType SellerFeeDiscount { get; }
Public ReadOnly Property SellerFeeDiscount As SellerFeeDiscountDashboardType
    Get
public:
property SellerFeeDiscountDashboardType^ SellerFeeDiscount {
    SellerFeeDiscountDashboardType^ get ();
}


GetSellerEventsCall Class

GetSellerEventsCall Class
Namespaces ► eBay.Service.Call ► GetSellerEventsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellerEventsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellerEventsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellerEventsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerEventsCall()()()() |
 | GetSellerEventsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellerEventsRequestType for this API call.
 | ApiResponse | Gets the GetSellerEventsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTimeFilter | Gets or sets the EndTimeFrom and [!:GetSearchResultsRequestType.EndTimeTo] of type TimeFilter.
 | EndTimeFrom | Gets or sets the EndTimeFrom of type DateTime.
 | EndTimeTo | Gets or sets the EndTimeTo of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellerEvents(String, DateTime, DateTime, DateTime, DateTime, DateTime, DateTime, Boolean, Boolean, Boolean, Boolean) | Retrieves price changes, item revisions, description revisions, and other changes that have occurred within the last 48 hours related to a seller's eBay listings.
 | GetSellerEvents(TimeFilter) | For backward compatibility with old wrappers.
 | GetSellerEvents(DateTime, DateTime) | For backward compatibility with old wrappers.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | HideVariations | Gets or sets the HideVariations of type Boolean.
 | IncludeNewItem | Gets or sets the NewItemFilter of type Boolean.
 | IncludeVariationSpecifics | Gets or sets the IncludeVariationSpecifics of type Boolean.
 | IncludeWatchCount | Gets or sets the IncludeWatchCount of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemEventList | Gets the returned ItemArray of type ItemTypeCollection.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModTimeFilter | Gets or sets the ModTimeFrom and ModTimeTo of type TimeFilter.
 | ModTimeFrom | Gets or sets the ModTimeFrom of type DateTime.
 | ModTimeTo | Gets or sets the ModTimeTo of type DateTime.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTimeFilter | Gets or sets the StartTimeFrom and StartTimeTo of type TimeFilter.
 | StartTimeFrom | Gets or sets the StartTimeFrom of type DateTime.
 | StartTimeTo | Gets or sets the StartTimeTo of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | TimeTo | Gets the returned TimeTo of type DateTime.
 | ToString()()()() | (Inherited from Object.)
 | UserID | Gets or sets the UserID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellerEventsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► ApiRequest
Gets or sets the GetSellerEventsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerEventsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellerEventsRequestType
    Get
    Set
public:
property GetSellerEventsRequestType^ ApiRequest {
    GetSellerEventsRequestType^ get ();
    void set (GetSellerEventsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► ApiResponse
Gets the GetSellerEventsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerEventsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellerEventsResponseType
    Get
public:
property GetSellerEventsResponseType^ ApiResponse {
    GetSellerEventsResponseType^ get ();
}


EndTimeFilter Property

EndTimeFilter Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► EndTimeFilter
Gets or sets the EndTimeFrom and [!:GetSearchResultsRequestType.EndTimeTo] of type TimeFilter.
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter EndTimeFilter { get; set; }
Public Property EndTimeFilter As TimeFilter
    Get
    Set
public:
property TimeFilter^ EndTimeFilter {
    TimeFilter^ get ();
    void set (TimeFilter^ value);
}


EndTimeFrom Property

EndTimeFrom Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► EndTimeFrom
Gets or sets the EndTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeFrom { get; set; }
Public Property EndTimeFrom As DateTime
    Get
    Set
public:
property DateTime EndTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


EndTimeTo Property

EndTimeTo Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► EndTimeTo
Gets or sets the EndTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeTo { get; set; }
Public Property EndTimeTo As DateTime
    Get
    Set
public:
property DateTime EndTimeTo {
    DateTime get ();
    void set (DateTime value);
}


GetSellerEvents Method

GetSellerEvents Method
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► GetSellerEvents()()()()
Members
Icon | Member | Description
 | GetSellerEvents(String, DateTime, DateTime, DateTime, DateTime, DateTime, DateTime, Boolean, Boolean, Boolean, Boolean) | Retrieves price changes, item revisions, description revisions, and other changes that have occurred within the last 48 hours related to a seller's eBay listings.
 | GetSellerEvents(TimeFilter) | For backward compatibility with old wrappers.
 | GetSellerEvents(DateTime, DateTime) | For backward compatibility with old wrappers.


GetSellerEvents Method (ModTimeFilter)

GetSellerEvents Method (ModTimeFilter)
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► GetSellerEvents(TimeFilter)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection GetSellerEvents(
    TimeFilter ModTimeFilter
)
Public Function GetSellerEvents ( _
    ModTimeFilter As TimeFilter _
) As ItemTypeCollection
public:
ItemTypeCollection^ GetSellerEvents(
    TimeFilter^ ModTimeFilter
)
Parameters
ModTimeFilter (TimeFilter)


GetSellerEvents Method (ModTimeFrom, ModTimeTo)

GetSellerEvents Method (ModTimeFrom, ModTimeTo)
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► GetSellerEvents(DateTime, DateTime)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection GetSellerEvents(
    DateTime ModTimeFrom,
    DateTime ModTimeTo
)
Public Function GetSellerEvents ( _
    ModTimeFrom As DateTime, _
    ModTimeTo As DateTime _
) As ItemTypeCollection
public:
ItemTypeCollection^ GetSellerEvents(
    DateTime ModTimeFrom,
    DateTime ModTimeTo
)
Parameters
ModTimeFrom (DateTime)
ModTimeTo (DateTime)


GetSellerEvents Method (UserID, StartTimeFrom, StartTimeTo, EndTimeFrom, EndTimeTo, ModTimeFrom, ModTimeTo, IncludeNewItem, IncludeWatchCount, IncludeVariationSpecifics, HideVariations)

GetSellerEvents Method (UserID, StartTimeFrom, StartTimeTo, EndTimeFrom, EndTimeTo, ModTimeFrom, ModTimeTo, IncludeNewItem, IncludeWatchCount, IncludeVariationSpecifics, HideVariations)
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► GetSellerEvents(String, DateTime, DateTime, DateTime, DateTime, DateTime, DateTime, Boolean, Boolean, Boolean, Boolean)
Retrieves price changes, item revisions, description revisions, and other changes that have occurred within the last 48 hours related to a seller's eBay listings.
Declaration Syntax
C# Visual Basic Visual C++
public void GetSellerEvents(
    string UserID,
    DateTime StartTimeFrom,
    DateTime StartTimeTo,
    DateTime EndTimeFrom,
    DateTime EndTimeTo,
    DateTime ModTimeFrom,
    DateTime ModTimeTo,
    bool IncludeNewItem,
    bool IncludeWatchCount,
    bool IncludeVariationSpecifics,
    bool HideVariations
)
Public Sub GetSellerEvents ( _
    UserID As String, _
    StartTimeFrom As DateTime, _
    StartTimeTo As DateTime, _
    EndTimeFrom As DateTime, _
    EndTimeTo As DateTime, _
    ModTimeFrom As DateTime, _
    ModTimeTo As DateTime, _
    IncludeNewItem As Boolean, _
    IncludeWatchCount As Boolean, _
    IncludeVariationSpecifics As Boolean, _
    HideVariations As Boolean _
)
public:
void GetSellerEvents(
    String^ UserID,
    DateTime StartTimeFrom,
    DateTime StartTimeTo,
    DateTime EndTimeFrom,
    DateTime EndTimeTo,
    DateTime ModTimeFrom,
    DateTime ModTimeTo,
    bool IncludeNewItem,
    bool IncludeWatchCount,
    bool IncludeVariationSpecifics,
    bool HideVariations
)
Parameters
UserID (String)
eBay user ID for the seller whose events are to be returned. If not specified, retrieves events for the user identified by the authentication token passed in the request.

Note: Since user information is anonymous to everyone except the bidder and the seller (during an active auction), only sellers looking for information about their own listings and bidders who know the user IDs of their sellers will be able to make this API call successfully.
StartTimeFrom (DateTime)
Describes the earliest (oldest) time to use in a time range filter based on item start time. Must be specified if StartTimeTo is specified.

Either the StartTimeFrom, EndTimeFrom, or ModTimeFrom filter must be specified.

If you do not specify the corresponding To filter, it is set to the time you make the call.

For better results, the time period you use should be less than 48 hours. If 3000 or more items are found, use a smaller time range. Include a 2-minute, overlapping buffer between requests. For example, if StartTimeTo was 6:58 in a prior request, the current request should use 6:56 in StartTimeFrom (e.g., use ranges like 5:56-6:58, 6:56-7:58, 7:56-8:58).
StartTimeTo (DateTime)
Describes the latest (most recent) date to use in a time range filter based on item start time. If you specify the corresponding From filter, but you do not include StartTimeTo, the StartTimeTo is set to the time you make the call.
EndTimeFrom (DateTime)
Describes the earliest (oldest) date to use in a time range filter based on item end time. Must be specified if EndTimeTo is specified.

Either the StartTimeFrom, EndTimeFrom, or ModTimeFrom filter must be specified. If you do not specify the corresponding To filter, it is set to the time you make the call. For better results, the time range you use should be less than 48 hours. If 3000 or more items are found, use a smaller time range. Include a 2-minute, overlapping buffer between requests. For example, if EndTimeTo was 6:58 in a prior request, the current request should use 6:56 in EndTimeFrom (e.g., use ranges like 5:56-6:58, 6:56-7:58, 7:56-8:58).
EndTimeTo (DateTime)
Describes the latest (most recent) date to use in a time range filter based on item end time.

If you specify the corresponding From filter, but you do not include EndTimeTo, then EndTimeTo is set to the time you make the call.
ModTimeFrom (DateTime)
Describes the earliest (oldest) date to use in a time range filter based on item modification time. Must be specified if ModTimeTo is specified. Either the StartTimeFrom, EndTimeFrom, or ModTimeFrom filter must be specified. If you do not specify the corresponding To filter, it is set to the time you make the call. Include a 2-minute, overlapping buffer between requests. For example, if ModTimeTo was 6:58 in a prior request, the current request should use 6:56 in ModTimeFrom (e.g., use ranges like 5:56-6:58, 6:56-7:58, 7:56-8:58). For better results, the time range you use should be less than 48 hours. If 3000 or more items are found, use a smaller time range. If an unexpected item is returned (including an old item or an unchanged active item), please ignore the item. Although a maintenance process may have triggered a change in the modification time, item characteristics are unchanged.
ModTimeTo (DateTime)
Describes the latest (most recent) date and time to use in a time range filter based on the time an item's record was modified. If you specify the corresponding From filter, but you do not include ModTimeTo , then ModTimeTo is set to the time you make the call. Include a 2-minute buffer between the current time and the ModTimeTo filter.
IncludeNewItem (Boolean)
If true, response includes only items that have been modified within the ModTime range. If false, response includes all items.
IncludeWatchCount (Boolean)
Specifies whether to include WatchCount in Item nodes returned. WatchCount is the number of watches buyers have placed on the item from their My eBay accounts.
IncludeVariationSpecifics (Boolean)
Specifies whether to force the response to include variation specifics for multi-variation listings. If false (or not specified), eBay keeps the response as small as possible by not returning Variation.VariationSpecifics. It only returns Variation.SKU as an identifier (along with the variation price and other selling details). If the variation has no SKU, then Variation.VariationSpecifics is returned as the variation's unique identifier. If true, Variation.VariationSpecifics is returned. (Variation.SKU is also returned, if the variation has a SKU.) This may be useful for applications that don't track variations by SKU. Ignored when HideVariations is set to true. Note: If the seller includes a large number of variations in many listings, using this flag may degrade the call's performance. Therefore, when you use this flag, you may need to reduce the total number of items you're requesting at once. For example, you may need to use shorter time ranges in the StartTimeFrom, EndTimeFrom, or ModTimeFrom filters.
HideVariations (Boolean)
Specifies whether to force the response to hide variation details for multi-variation listings. If false (or not specified), eBay returns variation details (if any). In this case, the amount of detail can be controlled by using IncludeVariationSpecifics. If true, variation details are not returned (and IncludeVariationSpecifics has no effect). This may be useful for applications that use other calls, notifications, alerts, or reports to track price and quantity details.


GetSellerEventsCall Constructor

GetSellerEventsCall Constructor
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► GetSellerEventsCall()()()()
Members
Icon | Member | Description
 | GetSellerEventsCall()()()() |
 | GetSellerEventsCall(ApiContext) |


GetSellerEventsCall Constructor

GetSellerEventsCall Constructor
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► GetSellerEventsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerEventsCall()
Public Sub New
public:
GetSellerEventsCall()


GetSellerEventsCall Constructor (ApiContext)

GetSellerEventsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► GetSellerEventsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerEventsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellerEventsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HideVariations Property

HideVariations Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► HideVariations
Gets or sets the HideVariations of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool HideVariations { get; set; }
Public Property HideVariations As Boolean
    Get
    Set
public:
property bool HideVariations {
    bool get ();
    void set (bool value);
}


IncludeNewItem Property

IncludeNewItem Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► IncludeNewItem
Gets or sets the NewItemFilter of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeNewItem { get; set; }
Public Property IncludeNewItem As Boolean
    Get
    Set
public:
property bool IncludeNewItem {
    bool get ();
    void set (bool value);
}


IncludeVariationSpecifics Property

IncludeVariationSpecifics Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► IncludeVariationSpecifics
Gets or sets the IncludeVariationSpecifics of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeVariationSpecifics { get; set; }
Public Property IncludeVariationSpecifics As Boolean
    Get
    Set
public:
property bool IncludeVariationSpecifics {
    bool get ();
    void set (bool value);
}


IncludeWatchCount Property

IncludeWatchCount Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► IncludeWatchCount
Gets or sets the IncludeWatchCount of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeWatchCount { get; set; }
Public Property IncludeWatchCount As Boolean
    Get
    Set
public:
property bool IncludeWatchCount {
    bool get ();
    void set (bool value);
}


ItemEventList Property

ItemEventList Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► ItemEventList
Gets the returned ItemArray of type ItemTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection ItemEventList { get; }
Public ReadOnly Property ItemEventList As ItemTypeCollection
    Get
public:
property ItemTypeCollection^ ItemEventList {
    ItemTypeCollection^ get ();
}


ModTimeFilter Property

ModTimeFilter Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► ModTimeFilter
Gets or sets the ModTimeFrom and ModTimeTo of type TimeFilter.
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter ModTimeFilter { get; set; }
Public Property ModTimeFilter As TimeFilter
    Get
    Set
public:
property TimeFilter^ ModTimeFilter {
    TimeFilter^ get ();
    void set (TimeFilter^ value);
}


ModTimeFrom Property

ModTimeFrom Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► ModTimeFrom
Gets or sets the ModTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeFrom { get; set; }
Public Property ModTimeFrom As DateTime
    Get
    Set
public:
property DateTime ModTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


ModTimeTo Property

ModTimeTo Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► ModTimeTo
Gets or sets the ModTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeTo { get; set; }
Public Property ModTimeTo As DateTime
    Get
    Set
public:
property DateTime ModTimeTo {
    DateTime get ();
    void set (DateTime value);
}


StartTimeFilter Property

StartTimeFilter Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► StartTimeFilter
Gets or sets the StartTimeFrom and StartTimeTo of type TimeFilter.
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter StartTimeFilter { get; set; }
Public Property StartTimeFilter As TimeFilter
    Get
    Set
public:
property TimeFilter^ StartTimeFilter {
    TimeFilter^ get ();
    void set (TimeFilter^ value);
}


StartTimeFrom Property

StartTimeFrom Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► StartTimeFrom
Gets or sets the StartTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTimeFrom { get; set; }
Public Property StartTimeFrom As DateTime
    Get
    Set
public:
property DateTime StartTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


StartTimeTo Property

StartTimeTo Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► StartTimeTo
Gets or sets the StartTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTimeTo { get; set; }
Public Property StartTimeTo As DateTime
    Get
    Set
public:
property DateTime StartTimeTo {
    DateTime get ();
    void set (DateTime value);
}


TimeTo Property

TimeTo Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► TimeTo
Gets the returned TimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeTo { get; }
Public ReadOnly Property TimeTo As DateTime
    Get
public:
property DateTime TimeTo {
    DateTime get ();
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Call ► GetSellerEventsCall ► UserID
Gets or sets the UserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetSellerListCall Class

GetSellerListCall Class
Namespaces ► eBay.Service.Call ► GetSellerListCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellerListCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellerListCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellerListCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerListCall()()()() |
 | GetSellerListCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AdminEndedItemsOnly | Gets or sets the AdminEndedItemsOnly of type Boolean.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellerListRequestType for this API call.
 | ApiResponse | Gets the GetSellerListResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CategoryID | Gets or sets the CategoryID of type Int32.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTimeFilter | Gets or sets the EndTimeFrom and EndTimeTo of type TimeFilter.
 | EndTimeFrom | Gets or sets the EndTimeFrom of type DateTime.
 | EndTimeTo | Gets or sets the EndTimeTo of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellerList(String, UserIDArrayType, DateTime, DateTime, Int32, DateTime, DateTime, PaginationType, GranularityLevelCodeType, StringCollection, Boolean, Boolean, Int32, Boolean) | Retrieves a list of the items posted by the authenticated user, including the related item data.
 | GetSellerList()()()() | For backward compatibility with old wrappers.
 | GetType()()()() | (Inherited from Object.)
 | GranularityLevel | Gets or sets the GranularityLevel of type GranularityLevelCodeType.
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasMoreItems | Gets the returned HasMoreItems of type Boolean.
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeVariations | Gets or sets the IncludeVariations of type Boolean.
 | IncludeWatchCount | Gets or sets the IncludeWatchCount of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemList | Gets the returned ItemArray of type ItemTypeCollection.
 | ItemsPerPage | Gets the returned ItemsPerPage of type Int32.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MotorsDealerUserList | Gets or sets the MotorsDealerUsers of type UserIDArrayType.
 | OutputSelector | (Inherited from ApiCall.)
 | PageNumber | Gets the returned PageNumber of type Int32.
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReturnedItemCountActual | Gets the returned ReturnedItemCountActual of type Int32.
 | Seller | Gets the returned Seller of type UserType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SKUArrayList | Gets or sets the SKUArray of type StringCollection.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Sort | Gets or sets the Sort of type Int32.
 | StartTimeFilter | Gets or sets the StartTimeFrom and StartTimeTo of type TimeFilter.
 | StartTimeFrom | Gets or sets the StartTimeFrom of type DateTime.
 | StartTimeTo | Gets or sets the StartTimeTo of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UserID | Gets or sets the UserID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellerListCall


AdminEndedItemsOnly Property

AdminEndedItemsOnly Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► AdminEndedItemsOnly
Gets or sets the AdminEndedItemsOnly of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool AdminEndedItemsOnly { get; set; }
Public Property AdminEndedItemsOnly As Boolean
    Get
    Set
public:
property bool AdminEndedItemsOnly {
    bool get ();
    void set (bool value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► ApiRequest
Gets or sets the GetSellerListRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerListRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellerListRequestType
    Get
    Set
public:
property GetSellerListRequestType^ ApiRequest {
    GetSellerListRequestType^ get ();
    void set (GetSellerListRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► ApiResponse
Gets the GetSellerListResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerListResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellerListResponseType
    Get
public:
property GetSellerListResponseType^ ApiResponse {
    GetSellerListResponseType^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► CategoryID
Gets or sets the CategoryID of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int CategoryID { get; set; }
Public Property CategoryID As Integer
    Get
    Set
public:
property int CategoryID {
    int get ();
    void set (int value);
}


EndTimeFilter Property

EndTimeFilter Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► EndTimeFilter
Gets or sets the EndTimeFrom and EndTimeTo of type TimeFilter.
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter EndTimeFilter { get; set; }
Public Property EndTimeFilter As TimeFilter
    Get
    Set
public:
property TimeFilter^ EndTimeFilter {
    TimeFilter^ get ();
    void set (TimeFilter^ value);
}


EndTimeFrom Property

EndTimeFrom Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► EndTimeFrom
Gets or sets the EndTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeFrom { get; set; }
Public Property EndTimeFrom As DateTime
    Get
    Set
public:
property DateTime EndTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


EndTimeTo Property

EndTimeTo Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► EndTimeTo
Gets or sets the EndTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeTo { get; set; }
Public Property EndTimeTo As DateTime
    Get
    Set
public:
property DateTime EndTimeTo {
    DateTime get ();
    void set (DateTime value);
}


GetSellerList Method

GetSellerList Method
Namespaces ► eBay.Service.Call ► GetSellerListCall ► GetSellerList()()()()
Members
Icon | Member | Description
 | GetSellerList(String, UserIDArrayType, DateTime, DateTime, Int32, DateTime, DateTime, PaginationType, GranularityLevelCodeType, StringCollection, Boolean, Boolean, Int32, Boolean) | Retrieves a list of the items posted by the authenticated user, including the related item data.
 | GetSellerList()()()() | For backward compatibility with old wrappers.


GetSellerList Method

GetSellerList Method
Namespaces ► eBay.Service.Call ► GetSellerListCall ► GetSellerList()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection GetSellerList()
Public Function GetSellerList As ItemTypeCollection
public:
ItemTypeCollection^ GetSellerList()


GetSellerList Method (UserID, MotorsDealerUserList, EndTimeFrom, EndTimeTo, Sort, StartTimeFrom, StartTimeTo, Pagination, GranularityLevel, SKUArrayList, IncludeWatchCount, AdminEndedItemsOnly, CategoryID, IncludeVariations)

GetSellerList Method (UserID, MotorsDealerUserList, EndTimeFrom, EndTimeTo, Sort, StartTimeFrom, StartTimeTo, Pagination, GranularityLevel, SKUArrayList, IncludeWatchCount, AdminEndedItemsOnly, CategoryID, IncludeVariations)
Namespaces ► eBay.Service.Call ► GetSellerListCall ► GetSellerList(String, UserIDArrayType, DateTime, DateTime, Int32, DateTime, DateTime, PaginationType, GranularityLevelCodeType, StringCollection, Boolean, Boolean, Int32, Boolean)
Retrieves a list of the items posted by the authenticated user, including the related item data.
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection GetSellerList(
    string UserID,
    UserIDArrayType MotorsDealerUserList,
    DateTime EndTimeFrom,
    DateTime EndTimeTo,
    int Sort,
    DateTime StartTimeFrom,
    DateTime StartTimeTo,
    PaginationType Pagination,
    GranularityLevelCodeType GranularityLevel,
    StringCollection SKUArrayList,
    bool IncludeWatchCount,
    bool AdminEndedItemsOnly,
    int CategoryID,
    bool IncludeVariations
)
Public Function GetSellerList ( _
    UserID As String, _
    MotorsDealerUserList As UserIDArrayType, _
    EndTimeFrom As DateTime, _
    EndTimeTo As DateTime, _
    Sort As Integer, _
    StartTimeFrom As DateTime, _
    StartTimeTo As DateTime, _
    Pagination As PaginationType, _
    GranularityLevel As GranularityLevelCodeType, _
    SKUArrayList As StringCollection, _
    IncludeWatchCount As Boolean, _
    AdminEndedItemsOnly As Boolean, _
    CategoryID As Integer, _
    IncludeVariations As Boolean _
) As ItemTypeCollection
public:
ItemTypeCollection^ GetSellerList(
    String^ UserID,
    UserIDArrayType^ MotorsDealerUserList,
    DateTime EndTimeFrom,
    DateTime EndTimeTo,
    int Sort,
    DateTime StartTimeFrom,
    DateTime StartTimeTo,
    PaginationType^ Pagination,
    GranularityLevelCodeType GranularityLevel,
    StringCollection^ SKUArrayList,
    bool IncludeWatchCount,
    bool AdminEndedItemsOnly,
    int CategoryID,
    bool IncludeVariations
)
Parameters
UserID (String)
Specifies the seller whose items will be returned. UserID is an optional input. If not specified, retrieves listings for the user identified by the authentication token passed in the request. Note that since user information is anonymous to everyone except the bidder and the seller (during an active auction), only sellers looking for information about their own listings and bidders who know the user IDs of their sellers will be able to make this API call successfully.
MotorsDealerUserList (UserIDArrayType)
Specifies the list of Motors Dealer sellers for which a special set of metrics can be requested. Applies to eBay Motors Pro applications only.
EndTimeFrom (DateTime)
Specifies the earliest (oldest) date to use in a date range filter based on item end time.

Specify either an end-time range or a start-time range filter in every call request. Each of the time ranges must be a value less than 120 days.
EndTimeTo (DateTime)
Specifies the latest (most recent) date to use in a date range filter based on item end time. Must be specified if EndTimeFrom is specified.
Sort (Int32)
Specifies the order in which returned items are sorted (based on the end
dates of the item listings). Valid values:

0 = No sorting
1 = Sort in descending order
2 = Sort in ascending order
StartTimeFrom (DateTime)
Specifies the earliest (oldest) date to use in a date range filter based on item start time. Each of the time ranges must be a value less than 120 days. In all calls, at least one date-range filter must be specified (i.e., you must specify either the end time range or start time range in every request).
StartTimeTo (DateTime)
Specifies the latest (most recent) date to use in a date range filter based on item start time. Must be specified if StartTimeFrom is specified.
Pagination (PaginationType)
Contains the data controlling the pagination of the returned values. If you set a DetailLevel in this call, you must set pagination values. The Pagination field contains the number of items to be returned per page of data (per call), and the page number to return with the current call.
GranularityLevel (GranularityLevelCodeType)
Specifies the subset of item and user fields to return. See GetSellerList for a list of the fields that are returned for each granularity level. For GetSellerList, use DetailLevel or GranularityLevel in a request, but not both. For GetSellerList, if GranularityLevel is specified, DetailLevel is ignored.
SKUArrayList (StringCollection)
Container for a set of SKUs. Filters (reduces) the response to only include active listings that the seller listed with any of the specified SKUs. If multiple listings include the same SKU, they are all returned (assuming they also match the other criteria in the GetSellerList request). SKUArray can be used to retrieve items listed by the user identified in AuthToken or in UserID. Note: Listings with matching SKUs are returned regardless of their Item.InventoryTrackingMethod settings.
IncludeWatchCount (Boolean)
Specifies whether to include WatchCount in Item nodes returned. WatchCount is only returned with DetailLevel ReturnAll .
AdminEndedItemsOnly (Boolean)
Specifies whether to return only items that were administratively ended based on a policy violation.
CategoryID (Int32)
The category ID for the items retrieved. If you specify CategoryID in a GetSellerList call, the response contains only items in the category you specify.
IncludeVariations (Boolean)
If true, the Variations node is returned for all multi-variation listings in the response. Note: If the seller includes a large number of variations in many listings, using this flag may degrade the call's performance. Therefore, when you use this flag, you may need to reduce the total number of items you're requesting at once.

For example, you may need to use shorter time ranges in the EndTime or StartTime filters, fewer entries per page in Pagination, and/or SKUArray.


GetSellerListCall Constructor

GetSellerListCall Constructor
Namespaces ► eBay.Service.Call ► GetSellerListCall ► GetSellerListCall()()()()
Members
Icon | Member | Description
 | GetSellerListCall()()()() |
 | GetSellerListCall(ApiContext) |


GetSellerListCall Constructor

GetSellerListCall Constructor
Namespaces ► eBay.Service.Call ► GetSellerListCall ► GetSellerListCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerListCall()
Public Sub New
public:
GetSellerListCall()


GetSellerListCall Constructor (ApiContext)

GetSellerListCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellerListCall ► GetSellerListCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerListCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellerListCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


GranularityLevel Property

GranularityLevel Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► GranularityLevel
Gets or sets the GranularityLevel of type GranularityLevelCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public GranularityLevelCodeType GranularityLevel { get; set; }
Public Property GranularityLevel As GranularityLevelCodeType
    Get
    Set
public:
property GranularityLevelCodeType GranularityLevel {
    GranularityLevelCodeType get ();
    void set (GranularityLevelCodeType value);
}


HasMoreItems Property

HasMoreItems Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► HasMoreItems
Gets the returned HasMoreItems of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreItems { get; }
Public ReadOnly Property HasMoreItems As Boolean
    Get
public:
property bool HasMoreItems {
    bool get ();
}


IncludeVariations Property

IncludeVariations Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► IncludeVariations
Gets or sets the IncludeVariations of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeVariations { get; set; }
Public Property IncludeVariations As Boolean
    Get
    Set
public:
property bool IncludeVariations {
    bool get ();
    void set (bool value);
}


IncludeWatchCount Property

IncludeWatchCount Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► IncludeWatchCount
Gets or sets the IncludeWatchCount of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeWatchCount { get; set; }
Public Property IncludeWatchCount As Boolean
    Get
    Set
public:
property bool IncludeWatchCount {
    bool get ();
    void set (bool value);
}


ItemList Property

ItemList Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► ItemList
Gets the returned ItemArray of type ItemTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection ItemList { get; }
Public ReadOnly Property ItemList As ItemTypeCollection
    Get
public:
property ItemTypeCollection^ ItemList {
    ItemTypeCollection^ get ();
}


ItemsPerPage Property

ItemsPerPage Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► ItemsPerPage
Gets the returned ItemsPerPage of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int ItemsPerPage { get; }
Public ReadOnly Property ItemsPerPage As Integer
    Get
public:
property int ItemsPerPage {
    int get ();
}


MotorsDealerUserList Property

MotorsDealerUserList Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► MotorsDealerUserList
Gets or sets the MotorsDealerUsers of type UserIDArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public UserIDArrayType MotorsDealerUserList { get; set; }
Public Property MotorsDealerUserList As UserIDArrayType
    Get
    Set
public:
property UserIDArrayType^ MotorsDealerUserList {
    UserIDArrayType^ get ();
    void set (UserIDArrayType^ value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► PageNumber
Gets the returned PageNumber of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
public:
property int PageNumber {
    int get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


ReturnedItemCountActual Property

ReturnedItemCountActual Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► ReturnedItemCountActual
Gets the returned ReturnedItemCountActual of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int ReturnedItemCountActual { get; }
Public ReadOnly Property ReturnedItemCountActual As Integer
    Get
public:
property int ReturnedItemCountActual {
    int get ();
}


Seller Property

Seller Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► Seller
Gets the returned Seller of type UserType.
Declaration Syntax
C# Visual Basic Visual C++
public UserType Seller { get; }
Public ReadOnly Property Seller As UserType
    Get
public:
property UserType^ Seller {
    UserType^ get ();
}


SKUArrayList Property

SKUArrayList Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► SKUArrayList
Gets or sets the SKUArray of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection SKUArrayList { get; set; }
Public Property SKUArrayList As StringCollection
    Get
    Set
public:
property StringCollection^ SKUArrayList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Sort Property

Sort Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► Sort
Gets or sets the Sort of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int Sort { get; set; }
Public Property Sort As Integer
    Get
    Set
public:
property int Sort {
    int get ();
    void set (int value);
}


StartTimeFilter Property

StartTimeFilter Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► StartTimeFilter
Gets or sets the StartTimeFrom and StartTimeTo of type TimeFilter.
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter StartTimeFilter { get; set; }
Public Property StartTimeFilter As TimeFilter
    Get
    Set
public:
property TimeFilter^ StartTimeFilter {
    TimeFilter^ get ();
    void set (TimeFilter^ value);
}


StartTimeFrom Property

StartTimeFrom Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► StartTimeFrom
Gets or sets the StartTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTimeFrom { get; set; }
Public Property StartTimeFrom As DateTime
    Get
    Set
public:
property DateTime StartTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


StartTimeTo Property

StartTimeTo Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► StartTimeTo
Gets or sets the StartTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTimeTo { get; set; }
Public Property StartTimeTo As DateTime
    Get
    Set
public:
property DateTime StartTimeTo {
    DateTime get ();
    void set (DateTime value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Call ► GetSellerListCall ► UserID
Gets or sets the UserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetSellerPaymentsCall Class

GetSellerPaymentsCall Class
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellerPaymentsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellerPaymentsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellerPaymentsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerPaymentsCall()()()() |
 | GetSellerPaymentsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellerPaymentsRequestType for this API call.
 | ApiResponse | Gets the GetSellerPaymentsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellerPayments(RCSPaymentStatusCodeType, DateTime, DateTime, PaginationType) |
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasMorePayments | Gets the returned HasMorePayments of type Boolean.
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PageNumber | Gets the returned PageNumber of type Int32.
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | PaymentsPerPage | Gets the returned PaymentsPerPage of type Int32.
 | PaymentStatus | Gets or sets the PaymentStatus of type RCSPaymentStatusCodeType.
 | PaymentTimeFrom | Gets or sets the PaymentTimeFrom of type DateTime.
 | PaymentTimeTo | Gets or sets the PaymentTimeTo of type DateTime.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReturnedPaymentCountActual | Gets the returned ReturnedPaymentCountActual of type Int32.
 | SellerPaymentList | Gets the returned SellerPayment of type SellerPaymentTypeCollection.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellerPaymentsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► ApiRequest
Gets or sets the GetSellerPaymentsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerPaymentsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellerPaymentsRequestType
    Get
    Set
public:
property GetSellerPaymentsRequestType^ ApiRequest {
    GetSellerPaymentsRequestType^ get ();
    void set (GetSellerPaymentsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► ApiResponse
Gets the GetSellerPaymentsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerPaymentsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellerPaymentsResponseType
    Get
public:
property GetSellerPaymentsResponseType^ ApiResponse {
    GetSellerPaymentsResponseType^ get ();
}


GetSellerPayments Method (PaymentStatus, PaymentTimeFrom, PaymentTimeTo, Pagination)

GetSellerPayments Method (PaymentStatus, PaymentTimeFrom, PaymentTimeTo, Pagination)
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► GetSellerPayments(RCSPaymentStatusCodeType, DateTime, DateTime, PaginationType)
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentTypeCollection GetSellerPayments(
    RCSPaymentStatusCodeType PaymentStatus,
    DateTime PaymentTimeFrom,
    DateTime PaymentTimeTo,
    PaginationType Pagination
)
Public Function GetSellerPayments ( _
    PaymentStatus As RCSPaymentStatusCodeType, _
    PaymentTimeFrom As DateTime, _
    PaymentTimeTo As DateTime, _
    Pagination As PaginationType _
) As SellerPaymentTypeCollection
public:
SellerPaymentTypeCollection^ GetSellerPayments(
    RCSPaymentStatusCodeType PaymentStatus,
    DateTime PaymentTimeFrom,
    DateTime PaymentTimeTo,
    PaginationType^ Pagination
)
Parameters
PaymentStatus (RCSPaymentStatusCodeType)
PaymentTimeFrom (DateTime)
PaymentTimeTo (DateTime)
Pagination (PaginationType)


GetSellerPaymentsCall Constructor

GetSellerPaymentsCall Constructor
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► GetSellerPaymentsCall()()()()
Members
Icon | Member | Description
 | GetSellerPaymentsCall()()()() |
 | GetSellerPaymentsCall(ApiContext) |


GetSellerPaymentsCall Constructor

GetSellerPaymentsCall Constructor
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► GetSellerPaymentsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerPaymentsCall()
Public Sub New
public:
GetSellerPaymentsCall()


GetSellerPaymentsCall Constructor (ApiContext)

GetSellerPaymentsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► GetSellerPaymentsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerPaymentsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellerPaymentsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HasMorePayments Property

HasMorePayments Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► HasMorePayments
Gets the returned HasMorePayments of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMorePayments { get; }
Public ReadOnly Property HasMorePayments As Boolean
    Get
public:
property bool HasMorePayments {
    bool get ();
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► PageNumber
Gets the returned PageNumber of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
public:
property int PageNumber {
    int get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


PaymentsPerPage Property

PaymentsPerPage Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► PaymentsPerPage
Gets the returned PaymentsPerPage of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int PaymentsPerPage { get; }
Public ReadOnly Property PaymentsPerPage As Integer
    Get
public:
property int PaymentsPerPage {
    int get ();
}


PaymentStatus Property

PaymentStatus Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► PaymentStatus
Gets or sets the PaymentStatus of type RCSPaymentStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public RCSPaymentStatusCodeType PaymentStatus { get; set; }
Public Property PaymentStatus As RCSPaymentStatusCodeType
    Get
    Set
public:
property RCSPaymentStatusCodeType PaymentStatus {
    RCSPaymentStatusCodeType get ();
    void set (RCSPaymentStatusCodeType value);
}


PaymentTimeFrom Property

PaymentTimeFrom Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► PaymentTimeFrom
Gets or sets the PaymentTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PaymentTimeFrom { get; set; }
Public Property PaymentTimeFrom As DateTime
    Get
    Set
public:
property DateTime PaymentTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


PaymentTimeTo Property

PaymentTimeTo Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► PaymentTimeTo
Gets or sets the PaymentTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PaymentTimeTo { get; set; }
Public Property PaymentTimeTo As DateTime
    Get
    Set
public:
property DateTime PaymentTimeTo {
    DateTime get ();
    void set (DateTime value);
}


ReturnedPaymentCountActual Property

ReturnedPaymentCountActual Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► ReturnedPaymentCountActual
Gets the returned ReturnedPaymentCountActual of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int ReturnedPaymentCountActual { get; }
Public ReadOnly Property ReturnedPaymentCountActual As Integer
    Get
public:
property int ReturnedPaymentCountActual {
    int get ();
}


SellerPaymentList Property

SellerPaymentList Property
Namespaces ► eBay.Service.Call ► GetSellerPaymentsCall ► SellerPaymentList
Gets the returned SellerPayment of type SellerPaymentTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentTypeCollection SellerPaymentList { get; }
Public ReadOnly Property SellerPaymentList As SellerPaymentTypeCollection
    Get
public:
property SellerPaymentTypeCollection^ SellerPaymentList {
    SellerPaymentTypeCollection^ get ();
}


GetSellerTransactionsCall Class

GetSellerTransactionsCall Class
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellerTransactionsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellerTransactionsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellerTransactionsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerTransactionsCall()()()() |
 | GetSellerTransactionsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellerTransactionsRequestType for this API call.
 | ApiResponse | Gets the GetSellerTransactionsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellerTransactions(DateTime, DateTime, PaginationType, Boolean, Boolean, StringCollection, TransactionPlatformCodeType, Int32, InventoryTrackingMethodCodeType, Boolean) |
 | GetSellerTransactions(TimeFilter) | For backward compatibility with old wrappers.
 | GetSellerTransactions(DateTime, DateTime) | For backward compatibility with old wrappers.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasMoreTransactions | Gets the returned HasMoreTransactions of type Boolean.
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeCodiceFiscale | Gets or sets the IncludeCodiceFiscale of type Boolean.
 | IncludeContainingOrder | Gets or sets the IncludeContainingOrder of type Boolean.
 | IncludeFinalValueFee | Gets or sets the IncludeFinalValueFee of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | InventoryTrackingMethod | Gets or sets the InventoryTrackingMethod of type InventoryTrackingMethodCodeType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModTimeFilter | Gets or sets the ModTimeFrom and ModTimeTo of type TimeFilter.
 | ModTimeFrom | Gets or sets the ModTimeFrom of type DateTime.
 | ModTimeTo | Gets or sets the ModTimeTo of type DateTime.
 | NumberOfDays | Gets or sets the NumberOfDays of type Int32.
 | OutputSelector | (Inherited from ApiCall.)
 | PageNumber | Gets the returned PageNumber of type Int32.
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | PayPalPreferred | Gets the returned PayPalPreferred of type Boolean.
 | Platform | Gets or sets the Platform of type TransactionPlatformCodeType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReturnedTransactionCountActual | Gets the returned ReturnedTransactionCountActual of type Int32.
 | Seller | Gets the returned Seller of type UserType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SKUArrayList | Gets or sets the SKUArray of type StringCollection.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionList | Gets the returned TransactionArray of type TransactionTypeCollection.
 | TransactionsPerPage | Gets the returned TransactionsPerPage of type Int32.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellerTransactionsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► ApiRequest
Gets or sets the GetSellerTransactionsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerTransactionsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellerTransactionsRequestType
    Get
    Set
public:
property GetSellerTransactionsRequestType^ ApiRequest {
    GetSellerTransactionsRequestType^ get ();
    void set (GetSellerTransactionsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► ApiResponse
Gets the GetSellerTransactionsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerTransactionsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellerTransactionsResponseType
    Get
public:
property GetSellerTransactionsResponseType^ ApiResponse {
    GetSellerTransactionsResponseType^ get ();
}


GetSellerTransactions Method

GetSellerTransactions Method
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► GetSellerTransactions()()()()
Members
Icon | Member | Description
 | GetSellerTransactions(DateTime, DateTime, PaginationType, Boolean, Boolean, StringCollection, TransactionPlatformCodeType, Int32, InventoryTrackingMethodCodeType, Boolean) |
 | GetSellerTransactions(TimeFilter) | For backward compatibility with old wrappers.
 | GetSellerTransactions(DateTime, DateTime) | For backward compatibility with old wrappers.


GetSellerTransactions Method (ModTimeFilter)

GetSellerTransactions Method (ModTimeFilter)
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► GetSellerTransactions(TimeFilter)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection GetSellerTransactions(
    TimeFilter ModTimeFilter
)
Public Function GetSellerTransactions ( _
    ModTimeFilter As TimeFilter _
) As TransactionTypeCollection
public:
TransactionTypeCollection^ GetSellerTransactions(
    TimeFilter^ ModTimeFilter
)
Parameters
ModTimeFilter (TimeFilter)


GetSellerTransactions Method (ModTimeFrom, ModTimeTo, Pagination, IncludeFinalValueFee, IncludeContainingOrder, SKUArrayList, Platform, NumberOfDays, InventoryTrackingMethod, IncludeCodiceFiscale)

GetSellerTransactions Method (ModTimeFrom, ModTimeTo, Pagination, IncludeFinalValueFee, IncludeContainingOrder, SKUArrayList, Platform, NumberOfDays, InventoryTrackingMethod, IncludeCodiceFiscale)
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► GetSellerTransactions(DateTime, DateTime, PaginationType, Boolean, Boolean, StringCollection, TransactionPlatformCodeType, Int32, InventoryTrackingMethodCodeType, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection GetSellerTransactions(
    DateTime ModTimeFrom,
    DateTime ModTimeTo,
    PaginationType Pagination,
    bool IncludeFinalValueFee,
    bool IncludeContainingOrder,
    StringCollection SKUArrayList,
    TransactionPlatformCodeType Platform,
    int NumberOfDays,
    InventoryTrackingMethodCodeType InventoryTrackingMethod,
    bool IncludeCodiceFiscale
)
Public Function GetSellerTransactions ( _
    ModTimeFrom As DateTime, _
    ModTimeTo As DateTime, _
    Pagination As PaginationType, _
    IncludeFinalValueFee As Boolean, _
    IncludeContainingOrder As Boolean, _
    SKUArrayList As StringCollection, _
    Platform As TransactionPlatformCodeType, _
    NumberOfDays As Integer, _
    InventoryTrackingMethod As InventoryTrackingMethodCodeType, _
    IncludeCodiceFiscale As Boolean _
) As TransactionTypeCollection
public:
TransactionTypeCollection^ GetSellerTransactions(
    DateTime ModTimeFrom,
    DateTime ModTimeTo,
    PaginationType^ Pagination,
    bool IncludeFinalValueFee,
    bool IncludeContainingOrder,
    StringCollection^ SKUArrayList,
    TransactionPlatformCodeType Platform,
    int NumberOfDays,
    InventoryTrackingMethodCodeType InventoryTrackingMethod,
    bool IncludeCodiceFiscale
)
Parameters
ModTimeFrom (DateTime)
ModTimeTo (DateTime)
Pagination (PaginationType)
IncludeFinalValueFee (Boolean)
IncludeContainingOrder (Boolean)
SKUArrayList (StringCollection)
Platform (TransactionPlatformCodeType)
NumberOfDays (Int32)
InventoryTrackingMethod (InventoryTrackingMethodCodeType)
IncludeCodiceFiscale (Boolean)


GetSellerTransactions Method (TimeFrom, TimeTo)

GetSellerTransactions Method (TimeFrom, TimeTo)
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► GetSellerTransactions(DateTime, DateTime)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection GetSellerTransactions(
    DateTime TimeFrom,
    DateTime TimeTo
)
Public Function GetSellerTransactions ( _
    TimeFrom As DateTime, _
    TimeTo As DateTime _
) As TransactionTypeCollection
public:
TransactionTypeCollection^ GetSellerTransactions(
    DateTime TimeFrom,
    DateTime TimeTo
)
Parameters
TimeFrom (DateTime)
TimeTo (DateTime)


GetSellerTransactionsCall Constructor

GetSellerTransactionsCall Constructor
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► GetSellerTransactionsCall()()()()
Members
Icon | Member | Description
 | GetSellerTransactionsCall()()()() |
 | GetSellerTransactionsCall(ApiContext) |


GetSellerTransactionsCall Constructor

GetSellerTransactionsCall Constructor
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► GetSellerTransactionsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerTransactionsCall()
Public Sub New
public:
GetSellerTransactionsCall()


GetSellerTransactionsCall Constructor (ApiContext)

GetSellerTransactionsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► GetSellerTransactionsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerTransactionsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellerTransactionsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HasMoreTransactions Property

HasMoreTransactions Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► HasMoreTransactions
Gets the returned HasMoreTransactions of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreTransactions { get; }
Public ReadOnly Property HasMoreTransactions As Boolean
    Get
public:
property bool HasMoreTransactions {
    bool get ();
}


IncludeCodiceFiscale Property

IncludeCodiceFiscale Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► IncludeCodiceFiscale
Gets or sets the IncludeCodiceFiscale of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeCodiceFiscale { get; set; }
Public Property IncludeCodiceFiscale As Boolean
    Get
    Set
public:
property bool IncludeCodiceFiscale {
    bool get ();
    void set (bool value);
}


IncludeContainingOrder Property

IncludeContainingOrder Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► IncludeContainingOrder
Gets or sets the IncludeContainingOrder of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeContainingOrder { get; set; }
Public Property IncludeContainingOrder As Boolean
    Get
    Set
public:
property bool IncludeContainingOrder {
    bool get ();
    void set (bool value);
}


IncludeFinalValueFee Property

IncludeFinalValueFee Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► IncludeFinalValueFee
Gets or sets the IncludeFinalValueFee of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFee { get; set; }
Public Property IncludeFinalValueFee As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFee {
    bool get ();
    void set (bool value);
}


InventoryTrackingMethod Property

InventoryTrackingMethod Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► InventoryTrackingMethod
Gets or sets the InventoryTrackingMethod of type InventoryTrackingMethodCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public InventoryTrackingMethodCodeType InventoryTrackingMethod { get; set; }
Public Property InventoryTrackingMethod As InventoryTrackingMethodCodeType
    Get
    Set
public:
property InventoryTrackingMethodCodeType InventoryTrackingMethod {
    InventoryTrackingMethodCodeType get ();
    void set (InventoryTrackingMethodCodeType value);
}


ModTimeFilter Property

ModTimeFilter Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► ModTimeFilter
Gets or sets the ModTimeFrom and ModTimeTo of type TimeFilter.
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter ModTimeFilter { get; set; }
Public Property ModTimeFilter As TimeFilter
    Get
    Set
public:
property TimeFilter^ ModTimeFilter {
    TimeFilter^ get ();
    void set (TimeFilter^ value);
}


ModTimeFrom Property

ModTimeFrom Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► ModTimeFrom
Gets or sets the ModTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeFrom { get; set; }
Public Property ModTimeFrom As DateTime
    Get
    Set
public:
property DateTime ModTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


ModTimeTo Property

ModTimeTo Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► ModTimeTo
Gets or sets the ModTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeTo { get; set; }
Public Property ModTimeTo As DateTime
    Get
    Set
public:
property DateTime ModTimeTo {
    DateTime get ();
    void set (DateTime value);
}


NumberOfDays Property

NumberOfDays Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► NumberOfDays
Gets or sets the NumberOfDays of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfDays { get; set; }
Public Property NumberOfDays As Integer
    Get
    Set
public:
property int NumberOfDays {
    int get ();
    void set (int value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► PageNumber
Gets the returned PageNumber of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
public:
property int PageNumber {
    int get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


PayPalPreferred Property

PayPalPreferred Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► PayPalPreferred
Gets the returned PayPalPreferred of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalPreferred { get; }
Public ReadOnly Property PayPalPreferred As Boolean
    Get
public:
property bool PayPalPreferred {
    bool get ();
}


Platform Property

Platform Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► Platform
Gets or sets the Platform of type TransactionPlatformCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeType Platform { get; set; }
Public Property Platform As TransactionPlatformCodeType
    Get
    Set
public:
property TransactionPlatformCodeType Platform {
    TransactionPlatformCodeType get ();
    void set (TransactionPlatformCodeType value);
}


ReturnedTransactionCountActual Property

ReturnedTransactionCountActual Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► ReturnedTransactionCountActual
Gets the returned ReturnedTransactionCountActual of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int ReturnedTransactionCountActual { get; }
Public ReadOnly Property ReturnedTransactionCountActual As Integer
    Get
public:
property int ReturnedTransactionCountActual {
    int get ();
}


Seller Property

Seller Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► Seller
Gets the returned Seller of type UserType.
Declaration Syntax
C# Visual Basic Visual C++
public UserType Seller { get; }
Public ReadOnly Property Seller As UserType
    Get
public:
property UserType^ Seller {
    UserType^ get ();
}


SKUArrayList Property

SKUArrayList Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► SKUArrayList
Gets or sets the SKUArray of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection SKUArrayList { get; set; }
Public Property SKUArrayList As StringCollection
    Get
    Set
public:
property StringCollection^ SKUArrayList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


TransactionList Property

TransactionList Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► TransactionList
Gets the returned TransactionArray of type TransactionTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection TransactionList { get; }
Public ReadOnly Property TransactionList As TransactionTypeCollection
    Get
public:
property TransactionTypeCollection^ TransactionList {
    TransactionTypeCollection^ get ();
}


TransactionsPerPage Property

TransactionsPerPage Property
Namespaces ► eBay.Service.Call ► GetSellerTransactionsCall ► TransactionsPerPage
Gets the returned TransactionsPerPage of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int TransactionsPerPage { get; }
Public ReadOnly Property TransactionsPerPage As Integer
    Get
public:
property int TransactionsPerPage {
    int get ();
}


GetSellingManagerAlertsCall Class

GetSellingManagerAlertsCall Class
Namespaces ► eBay.Service.Call ► GetSellingManagerAlertsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellingManagerAlertsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellingManagerAlertsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellingManagerAlertsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerAlertsCall()()()() |
 | GetSellingManagerAlertsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | AlertList | Gets the returned Alert of type SellingManagerAlertTypeCollection.
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellingManagerAlertsRequestType for this API call.
 | ApiResponse | Gets the GetSellingManagerAlertsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellingManagerAlerts()()()() | Retrieves Selling Manager alerts. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellingManagerAlertsCall


AlertList Property

AlertList Property
Namespaces ► eBay.Service.Call ► GetSellingManagerAlertsCall ► AlertList
Gets the returned Alert of type SellingManagerAlertTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAlertTypeCollection AlertList { get; }
Public ReadOnly Property AlertList As SellingManagerAlertTypeCollection
    Get
public:
property SellingManagerAlertTypeCollection^ AlertList {
    SellingManagerAlertTypeCollection^ get ();
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellingManagerAlertsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellingManagerAlertsCall ► ApiRequest
Gets or sets the GetSellingManagerAlertsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerAlertsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellingManagerAlertsRequestType
    Get
    Set
public:
property GetSellingManagerAlertsRequestType^ ApiRequest {
    GetSellingManagerAlertsRequestType^ get ();
    void set (GetSellingManagerAlertsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellingManagerAlertsCall ► ApiResponse
Gets the GetSellingManagerAlertsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerAlertsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellingManagerAlertsResponseType
    Get
public:
property GetSellingManagerAlertsResponseType^ ApiResponse {
    GetSellingManagerAlertsResponseType^ get ();
}


GetSellingManagerAlerts Method

GetSellingManagerAlerts Method
Namespaces ► eBay.Service.Call ► GetSellingManagerAlertsCall ► GetSellingManagerAlerts()()()()
Retrieves Selling Manager alerts. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAlertTypeCollection GetSellingManagerAlerts()
Public Function GetSellingManagerAlerts As SellingManagerAlertTypeCollection
public:
SellingManagerAlertTypeCollection^ GetSellingManagerAlerts()


GetSellingManagerAlertsCall Constructor

GetSellingManagerAlertsCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerAlertsCall ► GetSellingManagerAlertsCall()()()()
Members
Icon | Member | Description
 | GetSellingManagerAlertsCall()()()() |
 | GetSellingManagerAlertsCall(ApiContext) |


GetSellingManagerAlertsCall Constructor

GetSellingManagerAlertsCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerAlertsCall ► GetSellingManagerAlertsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerAlertsCall()
Public Sub New
public:
GetSellingManagerAlertsCall()


GetSellingManagerAlertsCall Constructor (ApiContext)

GetSellingManagerAlertsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellingManagerAlertsCall ► GetSellingManagerAlertsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerAlertsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellingManagerAlertsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


GetSellingManagerEmailLogCall Class

GetSellingManagerEmailLogCall Class
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellingManagerEmailLogCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellingManagerEmailLogCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellingManagerEmailLogCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerEmailLogCall()()()() |
 | GetSellingManagerEmailLogCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellingManagerEmailLogRequestType for this API call.
 | ApiResponse | Gets the GetSellingManagerEmailLogResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EmailDateRange | Gets or sets the EmailDateRange of type TimeRangeType.
 | EmailLogList | Gets the returned EmailLog of type SellingManagerEmailLogTypeCollection.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellingManagerEmailLog(String, Int64, String, TimeRangeType, String) | Retrieves a log of emails sent, or scheduled to be sent, to buyers. The standard Trading API deprecation process is not applicable to this call.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderID | Gets or sets the OrderID of type String.
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type Int64.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellingManagerEmailLogCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► ApiRequest
Gets or sets the GetSellingManagerEmailLogRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerEmailLogRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellingManagerEmailLogRequestType
    Get
    Set
public:
property GetSellingManagerEmailLogRequestType^ ApiRequest {
    GetSellingManagerEmailLogRequestType^ get ();
    void set (GetSellingManagerEmailLogRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► ApiResponse
Gets the GetSellingManagerEmailLogResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerEmailLogResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellingManagerEmailLogResponseType
    Get
public:
property GetSellingManagerEmailLogResponseType^ ApiResponse {
    GetSellingManagerEmailLogResponseType^ get ();
}


EmailDateRange Property

EmailDateRange Property
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► EmailDateRange
Gets or sets the EmailDateRange of type TimeRangeType.
Declaration Syntax
C# Visual Basic Visual C++
public TimeRangeType EmailDateRange { get; set; }
Public Property EmailDateRange As TimeRangeType
    Get
    Set
public:
property TimeRangeType^ EmailDateRange {
    TimeRangeType^ get ();
    void set (TimeRangeType^ value);
}


EmailLogList Property

EmailLogList Property
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► EmailLogList
Gets the returned EmailLog of type SellingManagerEmailLogTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailLogTypeCollection EmailLogList { get; }
Public ReadOnly Property EmailLogList As SellingManagerEmailLogTypeCollection
    Get
public:
property SellingManagerEmailLogTypeCollection^ EmailLogList {
    SellingManagerEmailLogTypeCollection^ get ();
}


GetSellingManagerEmailLog Method (ItemID, TransactionID, OrderID, EmailDateRange, OrderLineItemID)

GetSellingManagerEmailLog Method (ItemID, TransactionID, OrderID, EmailDateRange, OrderLineItemID)
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► GetSellingManagerEmailLog(String, Int64, String, TimeRangeType, String)
Retrieves a log of emails sent, or scheduled to be sent, to buyers. The standard Trading API deprecation process is not applicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailLogTypeCollection GetSellingManagerEmailLog(
    string ItemID,
    long TransactionID,
    string OrderID,
    TimeRangeType EmailDateRange,
    string OrderLineItemID
)
Public Function GetSellingManagerEmailLog ( _
    ItemID As String, _
    TransactionID As Long, _
    OrderID As String, _
    EmailDateRange As TimeRangeType, _
    OrderLineItemID As String _
) As SellingManagerEmailLogTypeCollection
public:
SellingManagerEmailLogTypeCollection^ GetSellingManagerEmailLog(
    String^ ItemID,
    long long TransactionID,
    String^ OrderID,
    TimeRangeType^ EmailDateRange,
    String^ OrderLineItemID
)
Parameters
ItemID (String)
Unique identifier for the eBay item listing associated with the Selling Manager email log. Unless the OrderID or OrderLineItemID value is specified in the request, the ItemID and TransactionID fields must be used to identify the Selling Manager email log to retrieve. You can use GetSellingManagerSoldListings to retrieve the ItemID, TransactionID or OrderLineItemID values that correspond to the Selling Manager sale record (SaleRecordID). All four of these fields are returned under the SellingManagerSoldTransaction container of the GetSellingManagerSoldListings request.
TransactionID (Int64)
Unique identifier for the order line item (transaction) associated with the Selling Manager email log. Unless the OrderID or OrderLineItemID value is specified in the request, the ItemID and TransactionID fields must be used to identify the Selling Manager email log to retrieve. You can use GetSellingManagerSoldListings to retrieve the ItemID, TransactionID or OrderLineItemID values that correspond to the Selling Manager sale record (SaleRecordID). All four of these fields are returned under the SellingManagerSoldTransaction container of the GetSellingManagerSoldListings request.
OrderID (String)
A unique identifier that identifies a single line item or multiple line item (Combined Invoice) order associated with the Selling Manager email log. For a single line item order, the OrderID value is identical to the OrderLineItemID value that is generated upon creation of the order line item. For a Combined Invoice order, the OrderID value is created by eBay when the buyer or seller (sharing multiple, common order line items) combines multiple order line items into a Combined Invoice order through the eBay site (or when the seller creates Combined Invoice order through AddOrder). If an OrderID is used in the request, the OrderLineItemID and ItemID/TransactionID pair are not required.
EmailDateRange (TimeRangeType)
Specifies the earliest (oldest) and latest (most recent) dates to use in a date range filter based on email sent date. Each of the time ranges can be up to 90 days.
OrderLineItemID (String)
A unique identifier for an eBay order line item that is associated with the Selling Manager email log. This field is created as soon as there is a commitment to buy from the seller, and its value is based upon the concatenation of ItemID and TransactionID, with a hyphen in between these two IDs. You can use GetSellingManagerSoldListings to retrieve the ItemID, TransactionID or OrderLineItemID values that correspond to the Selling Manager sale record (SaleRecordID). All four of these fields are returned under the SellingManagerSoldTransaction container of the GetSellingManagerSoldListings request. Unless an OrderID or an ItemID/TransactionID pair is specified in the GetSellingManagerSaleRecord request, the OrderLineItemID is required.


GetSellingManagerEmailLogCall Constructor

GetSellingManagerEmailLogCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► GetSellingManagerEmailLogCall()()()()
Members
Icon | Member | Description
 | GetSellingManagerEmailLogCall()()()() |
 | GetSellingManagerEmailLogCall(ApiContext) |


GetSellingManagerEmailLogCall Constructor

GetSellingManagerEmailLogCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► GetSellingManagerEmailLogCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerEmailLogCall()
Public Sub New
public:
GetSellingManagerEmailLogCall()


GetSellingManagerEmailLogCall Constructor (ApiContext)

GetSellingManagerEmailLogCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► GetSellingManagerEmailLogCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerEmailLogCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellingManagerEmailLogCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► OrderID
Gets or sets the OrderID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerEmailLogCall ► TransactionID
Gets or sets the TransactionID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long TransactionID { get; set; }
Public Property TransactionID As Long
    Get
    Set
public:
property long long TransactionID {
    long long get ();
    void set (long long value);
}


GetSellingManagerInventoryCall Class

GetSellingManagerInventoryCall Class
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellingManagerInventoryCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellingManagerInventoryCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellingManagerInventoryCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerInventoryCall()()()() |
 | GetSellingManagerInventoryCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellingManagerInventoryRequestType for this API call.
 | ApiResponse | Gets the GetSellingManagerInventoryResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FilterList | Gets or sets the Filter of type SellingManagerInventoryPropertyTypeCodeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | FolderID | Gets or sets the FolderID of type Int64.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellingManagerInventory(SellingManagerProductSortCodeType, Int64, PaginationType, SortOrderCodeType, SellingManagerSearchType, Int64, SellingManagerInventoryPropertyTypeCodeTypeCollection) | Retrieves a paginated list containing details of a user's Selling Manager inventory. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | InventoryCountLastCalculatedDate | Gets the returned InventoryCountLastCalculatedDate of type DateTime.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Search | Gets or sets the Search of type SellingManagerSearchType.
 | SellingManagerProductList | Gets the returned SellingManagerProduct of type SellingManagerProductTypeCollection.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Sort | Gets or sets the Sort of type SellingManagerProductSortCodeType.
 | SortOrder | Gets or sets the SortOrder of type SortOrderCodeType.
 | StoreCategoryID | Gets or sets the StoreCategoryID of type Int64.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellingManagerInventoryCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► ApiRequest
Gets or sets the GetSellingManagerInventoryRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellingManagerInventoryRequestType
    Get
    Set
public:
property GetSellingManagerInventoryRequestType^ ApiRequest {
    GetSellingManagerInventoryRequestType^ get ();
    void set (GetSellingManagerInventoryRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► ApiResponse
Gets the GetSellingManagerInventoryResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellingManagerInventoryResponseType
    Get
public:
property GetSellingManagerInventoryResponseType^ ApiResponse {
    GetSellingManagerInventoryResponseType^ get ();
}


FilterList Property

FilterList Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► FilterList
Gets or sets the Filter of type SellingManagerInventoryPropertyTypeCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerInventoryPropertyTypeCodeTypeCollection FilterList { get; set; }
Public Property FilterList As SellingManagerInventoryPropertyTypeCodeTypeCollection
    Get
    Set
public:
property SellingManagerInventoryPropertyTypeCodeTypeCollection^ FilterList {
    SellingManagerInventoryPropertyTypeCodeTypeCollection^ get ();
    void set (SellingManagerInventoryPropertyTypeCodeTypeCollection^ value);
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► FolderID
Gets or sets the FolderID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


GetSellingManagerInventory Method (Sort, FolderID, Pagination, SortOrder, Search, StoreCategoryID, FilterList)

GetSellingManagerInventory Method (Sort, FolderID, Pagination, SortOrder, Search, StoreCategoryID, FilterList)
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► GetSellingManagerInventory(SellingManagerProductSortCodeType, Int64, PaginationType, SortOrderCodeType, SellingManagerSearchType, Int64, SellingManagerInventoryPropertyTypeCodeTypeCollection)
Retrieves a paginated list containing details of a user's Selling Manager inventory. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime GetSellingManagerInventory(
    SellingManagerProductSortCodeType Sort,
    long FolderID,
    PaginationType Pagination,
    SortOrderCodeType SortOrder,
    SellingManagerSearchType Search,
    long StoreCategoryID,
    SellingManagerInventoryPropertyTypeCodeTypeCollection FilterList
)
Public Function GetSellingManagerInventory ( _
    Sort As SellingManagerProductSortCodeType, _
    FolderID As Long, _
    Pagination As PaginationType, _
    SortOrder As SortOrderCodeType, _
    Search As SellingManagerSearchType, _
    StoreCategoryID As Long, _
    FilterList As SellingManagerInventoryPropertyTypeCodeTypeCollection _
) As DateTime
public:
DateTime GetSellingManagerInventory(
    SellingManagerProductSortCodeType Sort,
    long long FolderID,
    PaginationType^ Pagination,
    SortOrderCodeType SortOrder,
    SellingManagerSearchType^ Search,
    long long StoreCategoryID,
    SellingManagerInventoryPropertyTypeCodeTypeCollection^ FilterList
)
Parameters
Sort (SellingManagerProductSortCodeType)
Sets the sorting method for the results.
FolderID (Int64)
Specifies the inventory folder containing the requested inventory information.
Pagination (PaginationType)
Details about how many Products to return per page and which page to view.
SortOrder (SortOrderCodeType)
Order to be used for sorting retrieved product lists.
Search (SellingManagerSearchType)
Specifies types and values to search for in the seller's listings.
StoreCategoryID (Int64)
Specifies a store category whose products will be returned.
FilterList (SellingManagerInventoryPropertyTypeCodeTypeCollection)
Container for the list of filters that can be applied to the inventory information requested.


GetSellingManagerInventoryCall Constructor

GetSellingManagerInventoryCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► GetSellingManagerInventoryCall()()()()
Members
Icon | Member | Description
 | GetSellingManagerInventoryCall()()()() |
 | GetSellingManagerInventoryCall(ApiContext) |


GetSellingManagerInventoryCall Constructor

GetSellingManagerInventoryCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► GetSellingManagerInventoryCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryCall()
Public Sub New
public:
GetSellingManagerInventoryCall()


GetSellingManagerInventoryCall Constructor (ApiContext)

GetSellingManagerInventoryCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► GetSellingManagerInventoryCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellingManagerInventoryCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


InventoryCountLastCalculatedDate Property

InventoryCountLastCalculatedDate Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► InventoryCountLastCalculatedDate
Gets the returned InventoryCountLastCalculatedDate of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime InventoryCountLastCalculatedDate { get; }
Public ReadOnly Property InventoryCountLastCalculatedDate As DateTime
    Get
public:
property DateTime InventoryCountLastCalculatedDate {
    DateTime get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


Search Property

Search Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► Search
Gets or sets the Search of type SellingManagerSearchType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSearchType Search { get; set; }
Public Property Search As SellingManagerSearchType
    Get
    Set
public:
property SellingManagerSearchType^ Search {
    SellingManagerSearchType^ get ();
    void set (SellingManagerSearchType^ value);
}


SellingManagerProductList Property

SellingManagerProductList Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► SellingManagerProductList
Gets the returned SellingManagerProduct of type SellingManagerProductTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductTypeCollection SellingManagerProductList { get; }
Public ReadOnly Property SellingManagerProductList As SellingManagerProductTypeCollection
    Get
public:
property SellingManagerProductTypeCollection^ SellingManagerProductList {
    SellingManagerProductTypeCollection^ get ();
}


Sort Property

Sort Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► Sort
Gets or sets the Sort of type SellingManagerProductSortCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductSortCodeType Sort { get; set; }
Public Property Sort As SellingManagerProductSortCodeType
    Get
    Set
public:
property SellingManagerProductSortCodeType Sort {
    SellingManagerProductSortCodeType get ();
    void set (SellingManagerProductSortCodeType value);
}


SortOrder Property

SortOrder Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► SortOrder
Gets or sets the SortOrder of type SortOrderCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public SortOrderCodeType SortOrder { get; set; }
Public Property SortOrder As SortOrderCodeType
    Get
    Set
public:
property SortOrderCodeType SortOrder {
    SortOrderCodeType get ();
    void set (SortOrderCodeType value);
}


StoreCategoryID Property

StoreCategoryID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryCall ► StoreCategoryID
Gets or sets the StoreCategoryID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long StoreCategoryID { get; set; }
Public Property StoreCategoryID As Long
    Get
    Set
public:
property long long StoreCategoryID {
    long long get ();
    void set (long long value);
}


GetSellingManagerInventoryFolderCall Class

GetSellingManagerInventoryFolderCall Class
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellingManagerInventoryFolderCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellingManagerInventoryFolderCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellingManagerInventoryFolderCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerInventoryFolderCall()()()() |
 | GetSellingManagerInventoryFolderCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellingManagerInventoryFolderRequestType for this API call.
 | ApiResponse | Gets the GetSellingManagerInventoryFolderResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | Folder | Gets the returned Folder of type SellingManagerFolderDetailsType.
 | FolderID | Gets or sets the FolderID of type Int64.
 | FullRecursion | Gets or sets the FullRecursion of type Boolean.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellingManagerInventoryFolder(Int64, Int32, Boolean) | Retrieves Selling Manager inventory folders. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MaxDepth | Gets or sets the MaxDepth of type Int32.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellingManagerInventoryFolderCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall ► ApiRequest
Gets or sets the GetSellingManagerInventoryFolderRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryFolderRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellingManagerInventoryFolderRequestType
    Get
    Set
public:
property GetSellingManagerInventoryFolderRequestType^ ApiRequest {
    GetSellingManagerInventoryFolderRequestType^ get ();
    void set (GetSellingManagerInventoryFolderRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall ► ApiResponse
Gets the GetSellingManagerInventoryFolderResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryFolderResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellingManagerInventoryFolderResponseType
    Get
public:
property GetSellingManagerInventoryFolderResponseType^ ApiResponse {
    GetSellingManagerInventoryFolderResponseType^ get ();
}


Folder Property

Folder Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall ► Folder
Gets the returned Folder of type SellingManagerFolderDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType Folder { get; }
Public ReadOnly Property Folder As SellingManagerFolderDetailsType
    Get
public:
property SellingManagerFolderDetailsType^ Folder {
    SellingManagerFolderDetailsType^ get ();
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall ► FolderID
Gets or sets the FolderID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FullRecursion Property

FullRecursion Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall ► FullRecursion
Gets or sets the FullRecursion of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool FullRecursion { get; set; }
Public Property FullRecursion As Boolean
    Get
    Set
public:
property bool FullRecursion {
    bool get ();
    void set (bool value);
}


GetSellingManagerInventoryFolder Method (FolderID, MaxDepth, FullRecursion)

GetSellingManagerInventoryFolder Method (FolderID, MaxDepth, FullRecursion)
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall ► GetSellingManagerInventoryFolder(Int64, Int32, Boolean)
Retrieves Selling Manager inventory folders. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType GetSellingManagerInventoryFolder(
    long FolderID,
    int MaxDepth,
    bool FullRecursion
)
Public Function GetSellingManagerInventoryFolder ( _
    FolderID As Long, _
    MaxDepth As Integer, _
    FullRecursion As Boolean _
) As SellingManagerFolderDetailsType
public:
SellingManagerFolderDetailsType^ GetSellingManagerInventoryFolder(
    long long FolderID,
    int MaxDepth,
    bool FullRecursion
)
Parameters
FolderID (Int64)
If a FolderID is submitted, all child-folders below this folder will be returned.
MaxDepth (Int32)
Specifies the number of levels of subfolders to be returned. If 0, the parent folder is returned. If 1, the parent and child folders are returned. If 2, the parent and two levels of child folders are returned. Ignored if FullRecursion is set to True.
FullRecursion (Boolean)
Displays the entire tree of a user's folders. If this is provided, FolderID and MaxDepth need not be given.


GetSellingManagerInventoryFolderCall Constructor

GetSellingManagerInventoryFolderCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall ► GetSellingManagerInventoryFolderCall()()()()
Members
Icon | Member | Description
 | GetSellingManagerInventoryFolderCall()()()() |
 | GetSellingManagerInventoryFolderCall(ApiContext) |


GetSellingManagerInventoryFolderCall Constructor

GetSellingManagerInventoryFolderCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall ► GetSellingManagerInventoryFolderCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryFolderCall()
Public Sub New
public:
GetSellingManagerInventoryFolderCall()


GetSellingManagerInventoryFolderCall Constructor (ApiContext)

GetSellingManagerInventoryFolderCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall ► GetSellingManagerInventoryFolderCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryFolderCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellingManagerInventoryFolderCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


MaxDepth Property

MaxDepth Property
Namespaces ► eBay.Service.Call ► GetSellingManagerInventoryFolderCall ► MaxDepth
Gets or sets the MaxDepth of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int MaxDepth { get; set; }
Public Property MaxDepth As Integer
    Get
    Set
public:
property int MaxDepth {
    int get ();
    void set (int value);
}


GetSellingManagerItemAutomationRuleCall Class

GetSellingManagerItemAutomationRuleCall Class
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellingManagerItemAutomationRuleCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellingManagerItemAutomationRuleCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellingManagerItemAutomationRuleCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerItemAutomationRuleCall()()()() |
 | GetSellingManagerItemAutomationRuleCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellingManagerItemAutomationRuleRequestType for this API call.
 | ApiResponse | Gets the GetSellingManagerItemAutomationRuleResponseType for this API call.
 | AutomatedListingRule | Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
 | AutomatedRelistingRule | Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
 | AutomatedSecondChanceOfferRule | Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellingManagerItemAutomationRule(String) | Retrieves the set of Selling Manager automation rules associated with an item. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellingManagerItemAutomationRuleCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► ApiRequest
Gets or sets the GetSellingManagerItemAutomationRuleRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerItemAutomationRuleRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellingManagerItemAutomationRuleRequestType
    Get
    Set
public:
property GetSellingManagerItemAutomationRuleRequestType^ ApiRequest {
    GetSellingManagerItemAutomationRuleRequestType^ get ();
    void set (GetSellingManagerItemAutomationRuleRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► ApiResponse
Gets the GetSellingManagerItemAutomationRuleResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerItemAutomationRuleResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellingManagerItemAutomationRuleResponseType
    Get
public:
property GetSellingManagerItemAutomationRuleResponseType^ ApiResponse {
    GetSellingManagerItemAutomationRuleResponseType^ get ();
}


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► AutomatedListingRule
Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; }
Public ReadOnly Property AutomatedListingRule As SellingManagerAutoListType
    Get
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► AutomatedRelistingRule
Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; }
Public ReadOnly Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► AutomatedSecondChanceOfferRule
Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; }
Public ReadOnly Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
}


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


GetSellingManagerItemAutomationRule Method (ItemID)

GetSellingManagerItemAutomationRule Method (ItemID)
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► GetSellingManagerItemAutomationRule(String)
Retrieves the set of Selling Manager automation rules associated with an item. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType GetSellingManagerItemAutomationRule(
    string ItemID
)
Public Function GetSellingManagerItemAutomationRule ( _
    ItemID As String _
) As SellingManagerAutoListType
public:
SellingManagerAutoListType^ GetSellingManagerItemAutomationRule(
    String^ ItemID
)
Parameters
ItemID (String)
The ID of the item whose Selling Manager automation rules you want to retrieve.


GetSellingManagerItemAutomationRuleCall Constructor

GetSellingManagerItemAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► GetSellingManagerItemAutomationRuleCall()()()()
Members
Icon | Member | Description
 | GetSellingManagerItemAutomationRuleCall()()()() |
 | GetSellingManagerItemAutomationRuleCall(ApiContext) |


GetSellingManagerItemAutomationRuleCall Constructor

GetSellingManagerItemAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► GetSellingManagerItemAutomationRuleCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerItemAutomationRuleCall()
Public Sub New
public:
GetSellingManagerItemAutomationRuleCall()


GetSellingManagerItemAutomationRuleCall Constructor (ApiContext)

GetSellingManagerItemAutomationRuleCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► GetSellingManagerItemAutomationRuleCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerItemAutomationRuleCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellingManagerItemAutomationRuleCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerItemAutomationRuleCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


GetSellingManagerSaleRecordCall Class

GetSellingManagerSaleRecordCall Class
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellingManagerSaleRecordCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellingManagerSaleRecordCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellingManagerSaleRecordCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerSaleRecordCall()()()() |
 | GetSellingManagerSaleRecordCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellingManagerSaleRecordRequestType for this API call.
 | ApiResponse | Gets the GetSellingManagerSaleRecordResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellingManagerSaleRecord(String, String, String, String) | Retrieves the data for one or more Selling Manager sale records. The standard Trading API deprecation process is not applicable to this call.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderID | Gets or sets the OrderID of type String.
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellingManagerSoldOrder | Gets the returned SellingManagerSoldOrder of type SellingManagerSoldOrderType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellingManagerSaleRecordCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► ApiRequest
Gets or sets the GetSellingManagerSaleRecordRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSaleRecordRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellingManagerSaleRecordRequestType
    Get
    Set
public:
property GetSellingManagerSaleRecordRequestType^ ApiRequest {
    GetSellingManagerSaleRecordRequestType^ get ();
    void set (GetSellingManagerSaleRecordRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► ApiResponse
Gets the GetSellingManagerSaleRecordResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSaleRecordResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellingManagerSaleRecordResponseType
    Get
public:
property GetSellingManagerSaleRecordResponseType^ ApiResponse {
    GetSellingManagerSaleRecordResponseType^ get ();
}


GetSellingManagerSaleRecord Method (ItemID, TransactionID, OrderID, OrderLineItemID)

GetSellingManagerSaleRecord Method (ItemID, TransactionID, OrderID, OrderLineItemID)
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► GetSellingManagerSaleRecord(String, String, String, String)
Retrieves the data for one or more Selling Manager sale records. The standard Trading API deprecation process is not applicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderType GetSellingManagerSaleRecord(
    string ItemID,
    string TransactionID,
    string OrderID,
    string OrderLineItemID
)
Public Function GetSellingManagerSaleRecord ( _
    ItemID As String, _
    TransactionID As String, _
    OrderID As String, _
    OrderLineItemID As String _
) As SellingManagerSoldOrderType
public:
SellingManagerSoldOrderType^ GetSellingManagerSaleRecord(
    String^ ItemID,
    String^ TransactionID,
    String^ OrderID,
    String^ OrderLineItemID
)
Parameters
ItemID (String)
Unique identifier for the eBay item listing associated with the Selling Manager sale record. Unless the OrderID or OrderLineItemID value is specified in the request, the ItemID and TransactionID fields must be used to identify the Selling Manager sale record to retrieve. You can use GetSellingManagerSoldListings to retrieve the ItemID, TransactionID or OrderLineItemID values that correspond to the Selling Manager sale record (SaleRecordID). All four of these fields are returned under the SellingManagerSoldTransaction container of the GetSellingManagerSoldListings request.
TransactionID (String)
Unique identifier for the order line item (transaction) associated with the Selling Manager sale record. Unless the OrderID or OrderLineItemID value is specified in the request, the ItemID and TransactionID fields must be used to identify the Selling Manager sale record to retrieve. You can use GetSellingManagerSoldListings to retrieve the ItemID, TransactionID or OrderLineItemID values that correspond to the Selling Manager sale record (SaleRecordID). All four of these fields are returned under the SellingManagerSoldTransaction container of the GetSellingManagerSoldListings request.
OrderID (String)
A unique identifier that identifies a single line item or multiple line item (Combined Invoice) order associated with the Selling Manager sale record(s). For a single line item order, the OrderID value is identical to the OrderLineItemID value that is generated upon creation of the order line item. For a Combined Invoice order, the OrderID value is created by eBay when the buyer or seller (sharing multiple, common order line items) combines multiple order line items into a Combined Invoice order through the eBay site (or when the seller creates Combined Invoice order through AddOrder). If an OrderID is used in the request, the OrderLineItemID and ItemID/TransactionID pair are not required.
OrderLineItemID (String)
A unique identifier for an eBay order line item that is associated with the Selling Manager sale record. This field is created as soon as there is a commitment to buy from the seller, and its value is based upon the concatenation of ItemID and TransactionID, with a hyphen in between these two IDs. You can use GetSellingManagerSoldListings to retrieve the ItemID, TransactionID or OrderLineItemID values that correspond to the Selling Manager sale record (SaleRecordID). All four of these fields are returned under the SellingManagerSoldTransaction container of the GetSellingManagerSoldListings request. Unless an OrderID or an ItemID/Transaction pair is specified in the GetSellingManagerSaleRecord request, the OrderLineItemID is required.


GetSellingManagerSaleRecordCall Constructor

GetSellingManagerSaleRecordCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► GetSellingManagerSaleRecordCall()()()()
Members
Icon | Member | Description
 | GetSellingManagerSaleRecordCall()()()() |
 | GetSellingManagerSaleRecordCall(ApiContext) |


GetSellingManagerSaleRecordCall Constructor

GetSellingManagerSaleRecordCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► GetSellingManagerSaleRecordCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSaleRecordCall()
Public Sub New
public:
GetSellingManagerSaleRecordCall()


GetSellingManagerSaleRecordCall Constructor (ApiContext)

GetSellingManagerSaleRecordCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► GetSellingManagerSaleRecordCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSaleRecordCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellingManagerSaleRecordCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► OrderID
Gets or sets the OrderID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


SellingManagerSoldOrder Property

SellingManagerSoldOrder Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► SellingManagerSoldOrder
Gets the returned SellingManagerSoldOrder of type SellingManagerSoldOrderType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderType SellingManagerSoldOrder { get; }
Public ReadOnly Property SellingManagerSoldOrder As SellingManagerSoldOrderType
    Get
public:
property SellingManagerSoldOrderType^ SellingManagerSoldOrder {
    SellingManagerSoldOrderType^ get ();
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSaleRecordCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


GetSellingManagerSoldListingsCall Class

GetSellingManagerSoldListingsCall Class
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellingManagerSoldListingsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellingManagerSoldListingsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellingManagerSoldListingsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerSoldListingsCall()()()() |
 | GetSellingManagerSoldListingsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellingManagerSoldListingsRequestType for this API call.
 | ApiResponse | Gets the GetSellingManagerSoldListingsResponseType for this API call.
 | Archived | Gets or sets the Archived of type Boolean.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FilterList | Gets or sets the Filter of type SellingManagerSoldListingsPropertyTypeCodeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellingManagerSoldListings(SellingManagerSearchType, Int64, SellingManagerSoldListingsPropertyTypeCodeTypeCollection, Boolean, SellingManagerSoldListingsSortTypeCodeType, SortOrderCodeType, PaginationType, TimeRangeType) | Retrieves a Selling Manager user's sold listings. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SaleDateRange | Gets or sets the SaleDateRange of type TimeRangeType.
 | SaleRecordList | Gets the returned SaleRecord of type SellingManagerSoldOrderTypeCollection.
 | Search | Gets or sets the Search of type SellingManagerSearchType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Sort | Gets or sets the Sort of type SellingManagerSoldListingsSortTypeCodeType.
 | SortOrder | Gets or sets the SortOrder of type SortOrderCodeType.
 | StoreCategoryID | Gets or sets the StoreCategoryID of type Int64.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellingManagerSoldListingsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► ApiRequest
Gets or sets the GetSellingManagerSoldListingsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSoldListingsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellingManagerSoldListingsRequestType
    Get
    Set
public:
property GetSellingManagerSoldListingsRequestType^ ApiRequest {
    GetSellingManagerSoldListingsRequestType^ get ();
    void set (GetSellingManagerSoldListingsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► ApiResponse
Gets the GetSellingManagerSoldListingsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSoldListingsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellingManagerSoldListingsResponseType
    Get
public:
property GetSellingManagerSoldListingsResponseType^ ApiResponse {
    GetSellingManagerSoldListingsResponseType^ get ();
}


Archived Property

Archived Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► Archived
Gets or sets the Archived of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool Archived { get; set; }
Public Property Archived As Boolean
    Get
    Set
public:
property bool Archived {
    bool get ();
    void set (bool value);
}


FilterList Property

FilterList Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► FilterList
Gets or sets the Filter of type SellingManagerSoldListingsPropertyTypeCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldListingsPropertyTypeCodeTypeCollection FilterList { get; set; }
Public Property FilterList As SellingManagerSoldListingsPropertyTypeCodeTypeCollection
    Get
    Set
public:
property SellingManagerSoldListingsPropertyTypeCodeTypeCollection^ FilterList {
    SellingManagerSoldListingsPropertyTypeCodeTypeCollection^ get ();
    void set (SellingManagerSoldListingsPropertyTypeCodeTypeCollection^ value);
}


GetSellingManagerSoldListings Method (Search, StoreCategoryID, FilterList, Archived, Sort, SortOrder, Pagination, SaleDateRange)

GetSellingManagerSoldListings Method (Search, StoreCategoryID, FilterList, Archived, Sort, SortOrder, Pagination, SaleDateRange)
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► GetSellingManagerSoldListings(SellingManagerSearchType, Int64, SellingManagerSoldListingsPropertyTypeCodeTypeCollection, Boolean, SellingManagerSoldListingsSortTypeCodeType, SortOrderCodeType, PaginationType, TimeRangeType)
Retrieves a Selling Manager user's sold listings. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderTypeCollection GetSellingManagerSoldListings(
    SellingManagerSearchType Search,
    long StoreCategoryID,
    SellingManagerSoldListingsPropertyTypeCodeTypeCollection FilterList,
    bool Archived,
    SellingManagerSoldListingsSortTypeCodeType Sort,
    SortOrderCodeType SortOrder,
    PaginationType Pagination,
    TimeRangeType SaleDateRange
)
Public Function GetSellingManagerSoldListings ( _
    Search As SellingManagerSearchType, _
    StoreCategoryID As Long, _
    FilterList As SellingManagerSoldListingsPropertyTypeCodeTypeCollection, _
    Archived As Boolean, _
    Sort As SellingManagerSoldListingsSortTypeCodeType, _
    SortOrder As SortOrderCodeType, _
    Pagination As PaginationType, _
    SaleDateRange As TimeRangeType _
) As SellingManagerSoldOrderTypeCollection
public:
SellingManagerSoldOrderTypeCollection^ GetSellingManagerSoldListings(
    SellingManagerSearchType^ Search,
    long long StoreCategoryID,
    SellingManagerSoldListingsPropertyTypeCodeTypeCollection^ FilterList,
    bool Archived,
    SellingManagerSoldListingsSortTypeCodeType Sort,
    SortOrderCodeType SortOrder,
    PaginationType^ Pagination,
    TimeRangeType^ SaleDateRange
)
Parameters
Search (SellingManagerSearchType)
Search filters for sold listings.
StoreCategoryID (Int64)
Listings with this store category ID will be listed.
FilterList (SellingManagerSoldListingsPropertyTypeCodeTypeCollection)
This holds the list of filters that can be applicable for sold listings.
Archived (Boolean)
Requests listing records that are more than 90 days old. Records are archived between 90 and 120 days after being created, and thereafter can only be retrieved using this tag.
Sort (SellingManagerSoldListingsSortTypeCodeType)
Field to be used to sort the response.
SortOrder (SortOrderCodeType)
Order to be used for sorting the requested listings.
Pagination (PaginationType)
Details about how many listings to return per page and which page to view.
SaleDateRange (TimeRangeType)
Specifies the earliest (oldest) and latest (most recent) dates to use in a date range filter based on item start time. A time range can be up to 120 days.


GetSellingManagerSoldListingsCall Constructor

GetSellingManagerSoldListingsCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► GetSellingManagerSoldListingsCall()()()()
Members
Icon | Member | Description
 | GetSellingManagerSoldListingsCall()()()() |
 | GetSellingManagerSoldListingsCall(ApiContext) |


GetSellingManagerSoldListingsCall Constructor

GetSellingManagerSoldListingsCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► GetSellingManagerSoldListingsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSoldListingsCall()
Public Sub New
public:
GetSellingManagerSoldListingsCall()


GetSellingManagerSoldListingsCall Constructor (ApiContext)

GetSellingManagerSoldListingsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► GetSellingManagerSoldListingsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSoldListingsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellingManagerSoldListingsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


SaleDateRange Property

SaleDateRange Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► SaleDateRange
Gets or sets the SaleDateRange of type TimeRangeType.
Declaration Syntax
C# Visual Basic Visual C++
public TimeRangeType SaleDateRange { get; set; }
Public Property SaleDateRange As TimeRangeType
    Get
    Set
public:
property TimeRangeType^ SaleDateRange {
    TimeRangeType^ get ();
    void set (TimeRangeType^ value);
}


SaleRecordList Property

SaleRecordList Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► SaleRecordList
Gets the returned SaleRecord of type SellingManagerSoldOrderTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderTypeCollection SaleRecordList { get; }
Public ReadOnly Property SaleRecordList As SellingManagerSoldOrderTypeCollection
    Get
public:
property SellingManagerSoldOrderTypeCollection^ SaleRecordList {
    SellingManagerSoldOrderTypeCollection^ get ();
}


Search Property

Search Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► Search
Gets or sets the Search of type SellingManagerSearchType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSearchType Search { get; set; }
Public Property Search As SellingManagerSearchType
    Get
    Set
public:
property SellingManagerSearchType^ Search {
    SellingManagerSearchType^ get ();
    void set (SellingManagerSearchType^ value);
}


Sort Property

Sort Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► Sort
Gets or sets the Sort of type SellingManagerSoldListingsSortTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldListingsSortTypeCodeType Sort { get; set; }
Public Property Sort As SellingManagerSoldListingsSortTypeCodeType
    Get
    Set
public:
property SellingManagerSoldListingsSortTypeCodeType Sort {
    SellingManagerSoldListingsSortTypeCodeType get ();
    void set (SellingManagerSoldListingsSortTypeCodeType value);
}


SortOrder Property

SortOrder Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► SortOrder
Gets or sets the SortOrder of type SortOrderCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public SortOrderCodeType SortOrder { get; set; }
Public Property SortOrder As SortOrderCodeType
    Get
    Set
public:
property SortOrderCodeType SortOrder {
    SortOrderCodeType get ();
    void set (SortOrderCodeType value);
}


StoreCategoryID Property

StoreCategoryID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerSoldListingsCall ► StoreCategoryID
Gets or sets the StoreCategoryID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long StoreCategoryID { get; set; }
Public Property StoreCategoryID As Long
    Get
    Set
public:
property long long StoreCategoryID {
    long long get ();
    void set (long long value);
}


GetSellingManagerTemplateAutomationRuleCall Class

GetSellingManagerTemplateAutomationRuleCall Class
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellingManagerTemplateAutomationRuleCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellingManagerTemplateAutomationRuleCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellingManagerTemplateAutomationRuleCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerTemplateAutomationRuleCall()()()() |
 | GetSellingManagerTemplateAutomationRuleCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellingManagerTemplateAutomationRuleRequestType for this API call.
 | ApiResponse | Gets the GetSellingManagerTemplateAutomationRuleResponseType for this API call.
 | AutomatedListingRule | Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
 | AutomatedRelistingRule | Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
 | AutomatedSecondChanceOfferRule | Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellingManagerTemplateAutomationRule(Int64) | Retrieves the set of Selling Manager automation rules associated with a Selling Manager template. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SaleTemplateID | Gets or sets the SaleTemplateID of type Int64.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellingManagerTemplateAutomationRuleCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► ApiRequest
Gets or sets the GetSellingManagerTemplateAutomationRuleRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplateAutomationRuleRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellingManagerTemplateAutomationRuleRequestType
    Get
    Set
public:
property GetSellingManagerTemplateAutomationRuleRequestType^ ApiRequest {
    GetSellingManagerTemplateAutomationRuleRequestType^ get ();
    void set (GetSellingManagerTemplateAutomationRuleRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► ApiResponse
Gets the GetSellingManagerTemplateAutomationRuleResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplateAutomationRuleResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellingManagerTemplateAutomationRuleResponseType
    Get
public:
property GetSellingManagerTemplateAutomationRuleResponseType^ ApiResponse {
    GetSellingManagerTemplateAutomationRuleResponseType^ get ();
}


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► AutomatedListingRule
Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; }
Public ReadOnly Property AutomatedListingRule As SellingManagerAutoListType
    Get
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► AutomatedRelistingRule
Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; }
Public ReadOnly Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► AutomatedSecondChanceOfferRule
Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; }
Public ReadOnly Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
}


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


GetSellingManagerTemplateAutomationRule Method (SaleTemplateID)

GetSellingManagerTemplateAutomationRule Method (SaleTemplateID)
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► GetSellingManagerTemplateAutomationRule(Int64)
Retrieves the set of Selling Manager automation rules associated with a Selling Manager template. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType GetSellingManagerTemplateAutomationRule(
    long SaleTemplateID
)
Public Function GetSellingManagerTemplateAutomationRule ( _
    SaleTemplateID As Long _
) As SellingManagerAutoListType
public:
SellingManagerAutoListType^ GetSellingManagerTemplateAutomationRule(
    long long SaleTemplateID
)
Parameters
SaleTemplateID (Int64)
The ID of the Selling Manager template whose Selling Manager automation rules you want to retrieve. You can obtain a SaleTemplateID by calling GetSellingManagerInventory.


GetSellingManagerTemplateAutomationRuleCall Constructor

GetSellingManagerTemplateAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► GetSellingManagerTemplateAutomationRuleCall()()()()
Members
Icon | Member | Description
 | GetSellingManagerTemplateAutomationRuleCall()()()() |
 | GetSellingManagerTemplateAutomationRuleCall(ApiContext) |


GetSellingManagerTemplateAutomationRuleCall Constructor

GetSellingManagerTemplateAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► GetSellingManagerTemplateAutomationRuleCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplateAutomationRuleCall()
Public Sub New
public:
GetSellingManagerTemplateAutomationRuleCall()


GetSellingManagerTemplateAutomationRuleCall Constructor (ApiContext)

GetSellingManagerTemplateAutomationRuleCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► GetSellingManagerTemplateAutomationRuleCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplateAutomationRuleCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellingManagerTemplateAutomationRuleCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplateAutomationRuleCall ► SaleTemplateID
Gets or sets the SaleTemplateID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


GetSellingManagerTemplatesCall Class

GetSellingManagerTemplatesCall Class
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplatesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSellingManagerTemplatesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSellingManagerTemplatesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSellingManagerTemplatesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerTemplatesCall()()()() |
 | GetSellingManagerTemplatesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSellingManagerTemplatesRequestType for this API call.
 | ApiResponse | Gets the GetSellingManagerTemplatesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSellingManagerTemplates(Int64Collection) | Retrieves Selling Manager templates. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SaleTemplateIDList | Gets or sets the SaleTemplateID of type Int64Collection.
 | SellingManagerTemplateDetailsList | Gets the returned SellingManagerTemplateDetailsArray of type SellingManagerTemplateDetailsTypeCollection.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSellingManagerTemplatesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplatesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplatesCall ► ApiRequest
Gets or sets the GetSellingManagerTemplatesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplatesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSellingManagerTemplatesRequestType
    Get
    Set
public:
property GetSellingManagerTemplatesRequestType^ ApiRequest {
    GetSellingManagerTemplatesRequestType^ get ();
    void set (GetSellingManagerTemplatesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplatesCall ► ApiResponse
Gets the GetSellingManagerTemplatesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplatesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSellingManagerTemplatesResponseType
    Get
public:
property GetSellingManagerTemplatesResponseType^ ApiResponse {
    GetSellingManagerTemplatesResponseType^ get ();
}


GetSellingManagerTemplates Method (SaleTemplateIDList)

GetSellingManagerTemplates Method (SaleTemplateIDList)
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplatesCall ► GetSellingManagerTemplates(Int64Collection)
Retrieves Selling Manager templates. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerTemplateDetailsTypeCollection GetSellingManagerTemplates(
    Int64Collection SaleTemplateIDList
)
Public Function GetSellingManagerTemplates ( _
    SaleTemplateIDList As Int64Collection _
) As SellingManagerTemplateDetailsTypeCollection
public:
SellingManagerTemplateDetailsTypeCollection^ GetSellingManagerTemplates(
    Int64Collection^ SaleTemplateIDList
)
Parameters
SaleTemplateIDList (Int64Collection)
The ID of the template whose data will be returned. A SaleTemplateID is the ID of a Selling Manager template. A Selling Manager template contains the data needed to list an item. One or more template IDs can be specified, each in its own container. You can obtain a SaleTemplateID by calling GetSellingManagerInventory.


GetSellingManagerTemplatesCall Constructor

GetSellingManagerTemplatesCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplatesCall ► GetSellingManagerTemplatesCall()()()()
Members
Icon | Member | Description
 | GetSellingManagerTemplatesCall()()()() |
 | GetSellingManagerTemplatesCall(ApiContext) |


GetSellingManagerTemplatesCall Constructor

GetSellingManagerTemplatesCall Constructor
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplatesCall ► GetSellingManagerTemplatesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplatesCall()
Public Sub New
public:
GetSellingManagerTemplatesCall()


GetSellingManagerTemplatesCall Constructor (ApiContext)

GetSellingManagerTemplatesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplatesCall ► GetSellingManagerTemplatesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplatesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSellingManagerTemplatesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SaleTemplateIDList Property

SaleTemplateIDList Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplatesCall ► SaleTemplateIDList
Gets or sets the SaleTemplateID of type Int64Collection.
Declaration Syntax
C# Visual Basic Visual C++
public Int64Collection SaleTemplateIDList { get; set; }
Public Property SaleTemplateIDList As Int64Collection
    Get
    Set
public:
property Int64Collection^ SaleTemplateIDList {
    Int64Collection^ get ();
    void set (Int64Collection^ value);
}


SellingManagerTemplateDetailsList Property

SellingManagerTemplateDetailsList Property
Namespaces ► eBay.Service.Call ► GetSellingManagerTemplatesCall ► SellingManagerTemplateDetailsList
Gets the returned SellingManagerTemplateDetailsArray of type SellingManagerTemplateDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerTemplateDetailsTypeCollection SellingManagerTemplateDetailsList { get; }
Public ReadOnly Property SellingManagerTemplateDetailsList As SellingManagerTemplateDetailsTypeCollection
    Get
public:
property SellingManagerTemplateDetailsTypeCollection^ SellingManagerTemplateDetailsList {
    SellingManagerTemplateDetailsTypeCollection^ get ();
}


GetSessionIDCall Class

GetSessionIDCall Class
Namespaces ► eBay.Service.Call ► GetSessionIDCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSessionIDCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSessionIDCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSessionIDCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSessionIDCall()()()() |
 | GetSessionIDCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSessionIDRequestType for this API call.
 | ApiResponse | Gets the GetSessionIDResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Overrides ApiCall.GetSecurityHeader()()()().)
 | GetSessionID(String) | Retrieves a session ID that identifies a user and your application when you make a FetchToken request.
 | GetSessionID()()()() | Request for a SessionID, which is a unique identifier for authenticating data entry during the process that creates a user token.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | RuName | Gets or sets the RuName of type String.
 | SessionID | Gets the returned SessionID of type String.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSessionIDCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► ApiRequest
Gets or sets the GetSessionIDRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSessionIDRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSessionIDRequestType
    Get
    Set
public:
property GetSessionIDRequestType^ ApiRequest {
    GetSessionIDRequestType^ get ();
    void set (GetSessionIDRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► ApiResponse
Gets the GetSessionIDResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSessionIDResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSessionIDResponseType
    Get
public:
property GetSessionIDResponseType^ ApiResponse {
    GetSessionIDResponseType^ get ();
}


GetSecurityHeader Method

GetSecurityHeader Method
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► GetSecurityHeader()()()()
Constructs a security header from values in ApiContext.
Declaration Syntax
C# Visual Basic Visual C++
protected override CustomSecurityHeaderType GetSecurityHeader()
Protected Overrides Function GetSecurityHeader As CustomSecurityHeaderType
protected:
virtual CustomSecurityHeaderType^ GetSecurityHeader() override
Return Value
Security information of type CustomSecurityHeaderType.


GetSessionID Method

GetSessionID Method
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► GetSessionID()()()()
Members
Icon | Member | Description
 | GetSessionID(String) | Retrieves a session ID that identifies a user and your application when you make a FetchToken request.
 | GetSessionID()()()() | Request for a SessionID, which is a unique identifier for authenticating data entry during the process that creates a user token.


GetSessionID Method

GetSessionID Method
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► GetSessionID()()()()
Request for a SessionID, which is a unique identifier for authenticating data entry during the process that creates a user token.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSessionID()
Public Function GetSessionID As String
public:
String^ GetSessionID()


GetSessionID Method (RuName)

GetSessionID Method (RuName)
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► GetSessionID(String)
Retrieves a session ID that identifies a user and your application when you make a FetchToken request.
Declaration Syntax
C# Visual Basic Visual C++
public string GetSessionID(
    string RuName
)
Public Function GetSessionID ( _
    RuName As String _
) As String
public:
String^ GetSessionID(
    String^ RuName
)
Parameters
RuName (String)
The eBay Registered URL must be specified in this field. An eBay Registered URL is created and associated with a developer's Sandbox or Production key set by logging into the user's developer account on developer.ebay.com and going to the User Tokens page. The RuName value passed in this field must match the one specified for the specific Sandbox or Production key set being used to make the GetSessionID call. For more information on adding and registering your RuName, see the Setting Up an Application to Receive Tokens tutorial.


GetSessionIDCall Constructor

GetSessionIDCall Constructor
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► GetSessionIDCall()()()()
Members
Icon | Member | Description
 | GetSessionIDCall()()()() |
 | GetSessionIDCall(ApiContext) |


GetSessionIDCall Constructor

GetSessionIDCall Constructor
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► GetSessionIDCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSessionIDCall()
Public Sub New
public:
GetSessionIDCall()


GetSessionIDCall Constructor (ApiContext)

GetSessionIDCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► GetSessionIDCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSessionIDCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSessionIDCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


RuName Property

RuName Property
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► RuName
Gets or sets the RuName of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string RuName { get; set; }
Public Property RuName As String
    Get
    Set
public:
property String^ RuName {
    String^ get ();
    void set (String^ value);
}


SessionID Property

SessionID Property
Namespaces ► eBay.Service.Call ► GetSessionIDCall ► SessionID
Gets the returned SessionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SessionID { get; }
Public ReadOnly Property SessionID As String
    Get
public:
property String^ SessionID {
    String^ get ();
}


GetShippingDiscountProfilesCall Class

GetShippingDiscountProfilesCall Class
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetShippingDiscountProfilesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetShippingDiscountProfilesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetShippingDiscountProfilesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetShippingDiscountProfilesCall()()()() |
 | GetShippingDiscountProfilesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetShippingDiscountProfilesRequestType for this API call.
 | ApiResponse | Gets the GetShippingDiscountProfilesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CalculatedHandlingDiscount | Gets the returned CalculatedHandlingDiscount of type CalculatedHandlingDiscountType.
 | CalculatedShippingDiscount | Gets the returned CalculatedShippingDiscount of type CalculatedShippingDiscountType.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CombinedDuration | Gets the returned CombinedDuration of type CombinedPaymentPeriodCodeType.
 | CurrencyID | Gets the returned CurrencyID of type CurrencyCodeType.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | FlatShippingDiscount | Gets the returned FlatShippingDiscount of type FlatShippingDiscountType.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetShippingDiscountProfiles()()()() | Returns the shipping discount profiles defined by the user, along with other Combined Invoice-related details such as packaging and handling costs.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | InternationalShippingInsurance | Gets the returned InternationalShippingInsurance of type ShippingInsuranceType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PromotionalShippingDiscount | Gets the returned PromotionalShippingDiscount of type Boolean.
 | PromotionalShippingDiscountDetails | Gets the returned PromotionalShippingDiscountDetails of type PromotionalShippingDiscountDetailsType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ShippingInsurance | Gets the returned ShippingInsurance of type ShippingInsuranceType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetShippingDiscountProfilesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► ApiRequest
Gets or sets the GetShippingDiscountProfilesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetShippingDiscountProfilesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetShippingDiscountProfilesRequestType
    Get
    Set
public:
property GetShippingDiscountProfilesRequestType^ ApiRequest {
    GetShippingDiscountProfilesRequestType^ get ();
    void set (GetShippingDiscountProfilesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► ApiResponse
Gets the GetShippingDiscountProfilesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetShippingDiscountProfilesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetShippingDiscountProfilesResponseType
    Get
public:
property GetShippingDiscountProfilesResponseType^ ApiResponse {
    GetShippingDiscountProfilesResponseType^ get ();
}


CalculatedHandlingDiscount Property

CalculatedHandlingDiscount Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► CalculatedHandlingDiscount
Gets the returned CalculatedHandlingDiscount of type CalculatedHandlingDiscountType.
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedHandlingDiscountType CalculatedHandlingDiscount { get; }
Public ReadOnly Property CalculatedHandlingDiscount As CalculatedHandlingDiscountType
    Get
public:
property CalculatedHandlingDiscountType^ CalculatedHandlingDiscount {
    CalculatedHandlingDiscountType^ get ();
}


CalculatedShippingDiscount Property

CalculatedShippingDiscount Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► CalculatedShippingDiscount
Gets the returned CalculatedShippingDiscount of type CalculatedShippingDiscountType.
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingDiscountType CalculatedShippingDiscount { get; }
Public ReadOnly Property CalculatedShippingDiscount As CalculatedShippingDiscountType
    Get
public:
property CalculatedShippingDiscountType^ CalculatedShippingDiscount {
    CalculatedShippingDiscountType^ get ();
}


CombinedDuration Property

CombinedDuration Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► CombinedDuration
Gets the returned CombinedDuration of type CombinedPaymentPeriodCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public CombinedPaymentPeriodCodeType CombinedDuration { get; }
Public ReadOnly Property CombinedDuration As CombinedPaymentPeriodCodeType
    Get
public:
property CombinedPaymentPeriodCodeType CombinedDuration {
    CombinedPaymentPeriodCodeType get ();
}


CurrencyID Property

CurrencyID Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► CurrencyID
Gets the returned CurrencyID of type CurrencyCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType CurrencyID { get; }
Public ReadOnly Property CurrencyID As CurrencyCodeType
    Get
public:
property CurrencyCodeType CurrencyID {
    CurrencyCodeType get ();
}


FlatShippingDiscount Property

FlatShippingDiscount Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► FlatShippingDiscount
Gets the returned FlatShippingDiscount of type FlatShippingDiscountType.
Declaration Syntax
C# Visual Basic Visual C++
public FlatShippingDiscountType FlatShippingDiscount { get; }
Public ReadOnly Property FlatShippingDiscount As FlatShippingDiscountType
    Get
public:
property FlatShippingDiscountType^ FlatShippingDiscount {
    FlatShippingDiscountType^ get ();
}


GetShippingDiscountProfiles Method

GetShippingDiscountProfiles Method
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► GetShippingDiscountProfiles()()()()
Returns the shipping discount profiles defined by the user, along with other Combined Invoice-related details such as packaging and handling costs.
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType GetShippingDiscountProfiles()
Public Function GetShippingDiscountProfiles As CurrencyCodeType
public:
CurrencyCodeType GetShippingDiscountProfiles()


GetShippingDiscountProfilesCall Constructor

GetShippingDiscountProfilesCall Constructor
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► GetShippingDiscountProfilesCall()()()()
Members
Icon | Member | Description
 | GetShippingDiscountProfilesCall()()()() |
 | GetShippingDiscountProfilesCall(ApiContext) |


GetShippingDiscountProfilesCall Constructor

GetShippingDiscountProfilesCall Constructor
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► GetShippingDiscountProfilesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetShippingDiscountProfilesCall()
Public Sub New
public:
GetShippingDiscountProfilesCall()


GetShippingDiscountProfilesCall Constructor (ApiContext)

GetShippingDiscountProfilesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► GetShippingDiscountProfilesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetShippingDiscountProfilesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetShippingDiscountProfilesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


InternationalShippingInsurance Property

InternationalShippingInsurance Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► InternationalShippingInsurance
Gets the returned InternationalShippingInsurance of type ShippingInsuranceType.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingInsuranceType InternationalShippingInsurance { get; }
Public ReadOnly Property InternationalShippingInsurance As ShippingInsuranceType
    Get
public:
property ShippingInsuranceType^ InternationalShippingInsurance {
    ShippingInsuranceType^ get ();
}


PromotionalShippingDiscount Property

PromotionalShippingDiscount Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► PromotionalShippingDiscount
Gets the returned PromotionalShippingDiscount of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalShippingDiscount { get; }
Public ReadOnly Property PromotionalShippingDiscount As Boolean
    Get
public:
property bool PromotionalShippingDiscount {
    bool get ();
}


PromotionalShippingDiscountDetails Property

PromotionalShippingDiscountDetails Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► PromotionalShippingDiscountDetails
Gets the returned PromotionalShippingDiscountDetails of type PromotionalShippingDiscountDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalShippingDiscountDetailsType PromotionalShippingDiscountDetails { get; }
Public ReadOnly Property PromotionalShippingDiscountDetails As PromotionalShippingDiscountDetailsType
    Get
public:
property PromotionalShippingDiscountDetailsType^ PromotionalShippingDiscountDetails {
    PromotionalShippingDiscountDetailsType^ get ();
}


ShippingInsurance Property

ShippingInsurance Property
Namespaces ► eBay.Service.Call ► GetShippingDiscountProfilesCall ► ShippingInsurance
Gets the returned ShippingInsurance of type ShippingInsuranceType.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingInsuranceType ShippingInsurance { get; }
Public ReadOnly Property ShippingInsurance As ShippingInsuranceType
    Get
public:
property ShippingInsuranceType^ ShippingInsurance {
    ShippingInsuranceType^ get ();
}


GetStoreCall Class

GetStoreCall Class
Namespaces ► eBay.Service.Call ► GetStoreCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetStoreCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetStoreCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetStoreCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreCall()()()() |
 | GetStoreCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetStoreRequestType for this API call.
 | ApiResponse | Gets the GetStoreResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CategoryStructureOnly | Gets or sets the CategoryStructureOnly of type Boolean.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetStore(Boolean, Int64, Int32, String) | Retrieves configuration information for the eBay store owned by the specified UserID, or by the caller.
 | GetStore()()()() | For backward compatibility with old wrappers.
 | GetStore(Boolean, Int64, Int32) | For backward compatibility with old wrappers.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LevelLimit | Gets or sets the LevelLimit of type Int32.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | RootCategoryID | Gets or sets the RootCategoryID of type Int64.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Store | Gets the returned Store of type StoreType.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UserID | Gets or sets the UserID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetStoreCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetStoreCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetStoreCall ► ApiRequest
Gets or sets the GetStoreRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetStoreRequestType
    Get
    Set
public:
property GetStoreRequestType^ ApiRequest {
    GetStoreRequestType^ get ();
    void set (GetStoreRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetStoreCall ► ApiResponse
Gets the GetStoreResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetStoreResponseType
    Get
public:
property GetStoreResponseType^ ApiResponse {
    GetStoreResponseType^ get ();
}


CategoryStructureOnly Property

CategoryStructureOnly Property
Namespaces ► eBay.Service.Call ► GetStoreCall ► CategoryStructureOnly
Gets or sets the CategoryStructureOnly of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool CategoryStructureOnly { get; set; }
Public Property CategoryStructureOnly As Boolean
    Get
    Set
public:
property bool CategoryStructureOnly {
    bool get ();
    void set (bool value);
}


GetStore Method

GetStore Method
Namespaces ► eBay.Service.Call ► GetStoreCall ► GetStore()()()()
Members
Icon | Member | Description
 | GetStore(Boolean, Int64, Int32, String) | Retrieves configuration information for the eBay store owned by the specified UserID, or by the caller.
 | GetStore()()()() | For backward compatibility with old wrappers.
 | GetStore(Boolean, Int64, Int32) | For backward compatibility with old wrappers.


GetStore Method

GetStore Method
Namespaces ► eBay.Service.Call ► GetStoreCall ► GetStore()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public StoreType GetStore()
Public Function GetStore As StoreType
public:
StoreType^ GetStore()


GetStore Method (CategoryStructureOnly, RootCategoryID, LevelLimit)

GetStore Method (CategoryStructureOnly, RootCategoryID, LevelLimit)
Namespaces ► eBay.Service.Call ► GetStoreCall ► GetStore(Boolean, Int64, Int32)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public StoreType GetStore(
    bool CategoryStructureOnly,
    long RootCategoryID,
    int LevelLimit
)
Public Function GetStore ( _
    CategoryStructureOnly As Boolean, _
    RootCategoryID As Long, _
    LevelLimit As Integer _
) As StoreType
public:
StoreType^ GetStore(
    bool CategoryStructureOnly,
    long long RootCategoryID,
    int LevelLimit
)
Parameters
CategoryStructureOnly (Boolean)
RootCategoryID (Int64)
LevelLimit (Int32)


GetStore Method (CategoryStructureOnly, RootCategoryID, LevelLimit, UserID)

GetStore Method (CategoryStructureOnly, RootCategoryID, LevelLimit, UserID)
Namespaces ► eBay.Service.Call ► GetStoreCall ► GetStore(Boolean, Int64, Int32, String)
Retrieves configuration information for the eBay store owned by the specified UserID, or by the caller.
Declaration Syntax
C# Visual Basic Visual C++
public StoreType GetStore(
    bool CategoryStructureOnly,
    long RootCategoryID,
    int LevelLimit,
    string UserID
)
Public Function GetStore ( _
    CategoryStructureOnly As Boolean, _
    RootCategoryID As Long, _
    LevelLimit As Integer, _
    UserID As String _
) As StoreType
public:
StoreType^ GetStore(
    bool CategoryStructureOnly,
    long long RootCategoryID,
    int LevelLimit,
    String^ UserID
)
Parameters
CategoryStructureOnly (Boolean)
If this is set to True, only the category structure of the store is returned. If this is not specified or set to False, the complete store configuration is returned.
RootCategoryID (Int64)
Specifies the category ID for the topmost category to return (along with the subcategories under it, the value of the LevelLimit property determining how deep). This tag is optional. If RootCategoryID is not specified, then the category tree starting at that root Category is returned.
LevelLimit (Int32)
Specifies the limit for the number of levels of the category hierarchy to return, where the given root category is level 1 and its children are level 2. Only categories at or above the level specified are returned. This tag is optional. If LevelLimit is not set, the complete category hierarchy is returned. Stores support category hierarchies up to 3 levels only.
UserID (String)
Specifies the user whose store data is to be returned. If not specified, then the store returned is that for the requesting user.


GetStoreCall Constructor

GetStoreCall Constructor
Namespaces ► eBay.Service.Call ► GetStoreCall ► GetStoreCall()()()()
Members
Icon | Member | Description
 | GetStoreCall()()()() |
 | GetStoreCall(ApiContext) |


GetStoreCall Constructor

GetStoreCall Constructor
Namespaces ► eBay.Service.Call ► GetStoreCall ► GetStoreCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCall()
Public Sub New
public:
GetStoreCall()


GetStoreCall Constructor (ApiContext)

GetStoreCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetStoreCall ► GetStoreCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetStoreCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


LevelLimit Property

LevelLimit Property
Namespaces ► eBay.Service.Call ► GetStoreCall ► LevelLimit
Gets or sets the LevelLimit of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int LevelLimit { get; set; }
Public Property LevelLimit As Integer
    Get
    Set
public:
property int LevelLimit {
    int get ();
    void set (int value);
}


RootCategoryID Property

RootCategoryID Property
Namespaces ► eBay.Service.Call ► GetStoreCall ► RootCategoryID
Gets or sets the RootCategoryID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long RootCategoryID { get; set; }
Public Property RootCategoryID As Long
    Get
    Set
public:
property long long RootCategoryID {
    long long get ();
    void set (long long value);
}


Store Property

Store Property
Namespaces ► eBay.Service.Call ► GetStoreCall ► Store
Gets the returned Store of type StoreType.
Declaration Syntax
C# Visual Basic Visual C++
public StoreType Store { get; }
Public ReadOnly Property Store As StoreType
    Get
public:
property StoreType^ Store {
    StoreType^ get ();
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Call ► GetStoreCall ► UserID
Gets or sets the UserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetStoreCategoryUpdateStatusCall Class

GetStoreCategoryUpdateStatusCall Class
Namespaces ► eBay.Service.Call ► GetStoreCategoryUpdateStatusCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetStoreCategoryUpdateStatusCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetStoreCategoryUpdateStatusCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetStoreCategoryUpdateStatusCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreCategoryUpdateStatusCall()()()() |
 | GetStoreCategoryUpdateStatusCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetStoreCategoryUpdateStatusRequestType for this API call.
 | ApiResponse | Gets the GetStoreCategoryUpdateStatusResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetStoreCategoryUpdateStatus(Int64) | Returns the status of the processing for category-structure changes specified with a call to SetStoreCategories.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Status | Gets the returned Status of type TaskStatusCodeType.
 | TaskID | Gets or sets the TaskID of type Int64.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetStoreCategoryUpdateStatusCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetStoreCategoryUpdateStatusCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetStoreCategoryUpdateStatusCall ► ApiRequest
Gets or sets the GetStoreCategoryUpdateStatusRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCategoryUpdateStatusRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetStoreCategoryUpdateStatusRequestType
    Get
    Set
public:
property GetStoreCategoryUpdateStatusRequestType^ ApiRequest {
    GetStoreCategoryUpdateStatusRequestType^ get ();
    void set (GetStoreCategoryUpdateStatusRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetStoreCategoryUpdateStatusCall ► ApiResponse
Gets the GetStoreCategoryUpdateStatusResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCategoryUpdateStatusResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetStoreCategoryUpdateStatusResponseType
    Get
public:
property GetStoreCategoryUpdateStatusResponseType^ ApiResponse {
    GetStoreCategoryUpdateStatusResponseType^ get ();
}


GetStoreCategoryUpdateStatus Method (TaskID)

GetStoreCategoryUpdateStatus Method (TaskID)
Namespaces ► eBay.Service.Call ► GetStoreCategoryUpdateStatusCall ► GetStoreCategoryUpdateStatus(Int64)
Returns the status of the processing for category-structure changes specified with a call to SetStoreCategories.
Declaration Syntax
C# Visual Basic Visual C++
public TaskStatusCodeType GetStoreCategoryUpdateStatus(
    long TaskID
)
Public Function GetStoreCategoryUpdateStatus ( _
    TaskID As Long _
) As TaskStatusCodeType
public:
TaskStatusCodeType GetStoreCategoryUpdateStatus(
    long long TaskID
)
Parameters
TaskID (Int64)
The task ID returned by the SetStoreCategories call. If the SetStoreCategories call was processed asynchronously, the TaskID will be a positive number. If SetStoreCategories returned a TaskID with a value of 0, the change was completed at the time the call was made (and there is no need to check status).


GetStoreCategoryUpdateStatusCall Constructor

GetStoreCategoryUpdateStatusCall Constructor
Namespaces ► eBay.Service.Call ► GetStoreCategoryUpdateStatusCall ► GetStoreCategoryUpdateStatusCall()()()()
Members
Icon | Member | Description
 | GetStoreCategoryUpdateStatusCall()()()() |
 | GetStoreCategoryUpdateStatusCall(ApiContext) |


GetStoreCategoryUpdateStatusCall Constructor

GetStoreCategoryUpdateStatusCall Constructor
Namespaces ► eBay.Service.Call ► GetStoreCategoryUpdateStatusCall ► GetStoreCategoryUpdateStatusCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCategoryUpdateStatusCall()
Public Sub New
public:
GetStoreCategoryUpdateStatusCall()


GetStoreCategoryUpdateStatusCall Constructor (ApiContext)

GetStoreCategoryUpdateStatusCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetStoreCategoryUpdateStatusCall ► GetStoreCategoryUpdateStatusCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCategoryUpdateStatusCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetStoreCategoryUpdateStatusCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


Status Property

Status Property
Namespaces ► eBay.Service.Call ► GetStoreCategoryUpdateStatusCall ► Status
Gets the returned Status of type TaskStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public TaskStatusCodeType Status { get; }
Public ReadOnly Property Status As TaskStatusCodeType
    Get
public:
property TaskStatusCodeType Status {
    TaskStatusCodeType get ();
}


TaskID Property

TaskID Property
Namespaces ► eBay.Service.Call ► GetStoreCategoryUpdateStatusCall ► TaskID
Gets or sets the TaskID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long TaskID { get; set; }
Public Property TaskID As Long
    Get
    Set
public:
property long long TaskID {
    long long get ();
    void set (long long value);
}


GetStoreCustomPageCall Class

GetStoreCustomPageCall Class
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetStoreCustomPageCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetStoreCustomPageCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetStoreCustomPageCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreCustomPageCall()()()() |
 | GetStoreCustomPageCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetStoreCustomPageRequestType for this API call.
 | ApiResponse | Gets the GetStoreCustomPageResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CustomPageList | Gets the returned CustomPageArray of type StoreCustomPageTypeCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetStoreCustomPage(Int64) | Retrieves the custom page or pages for the authenticated user's Store.
 | GetStoreCustomPage()()()() | For backward compatibility with old wrappers.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PageID | Gets or sets the PageID of type Int64.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetStoreCustomPageCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall ► ApiRequest
Gets or sets the GetStoreCustomPageRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCustomPageRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetStoreCustomPageRequestType
    Get
    Set
public:
property GetStoreCustomPageRequestType^ ApiRequest {
    GetStoreCustomPageRequestType^ get ();
    void set (GetStoreCustomPageRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall ► ApiResponse
Gets the GetStoreCustomPageResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCustomPageResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetStoreCustomPageResponseType
    Get
public:
property GetStoreCustomPageResponseType^ ApiResponse {
    GetStoreCustomPageResponseType^ get ();
}


CustomPageList Property

CustomPageList Property
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall ► CustomPageList
Gets the returned CustomPageArray of type StoreCustomPageTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageTypeCollection CustomPageList { get; }
Public ReadOnly Property CustomPageList As StoreCustomPageTypeCollection
    Get
public:
property StoreCustomPageTypeCollection^ CustomPageList {
    StoreCustomPageTypeCollection^ get ();
}


GetStoreCustomPage Method

GetStoreCustomPage Method
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall ► GetStoreCustomPage()()()()
Members
Icon | Member | Description
 | GetStoreCustomPage(Int64) | Retrieves the custom page or pages for the authenticated user's Store.
 | GetStoreCustomPage()()()() | For backward compatibility with old wrappers.


GetStoreCustomPage Method

GetStoreCustomPage Method
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall ► GetStoreCustomPage()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageTypeCollection GetStoreCustomPage()
Public Function GetStoreCustomPage As StoreCustomPageTypeCollection
public:
StoreCustomPageTypeCollection^ GetStoreCustomPage()


GetStoreCustomPage Method (PageID)

GetStoreCustomPage Method (PageID)
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall ► GetStoreCustomPage(Int64)
Retrieves the custom page or pages for the authenticated user's Store.
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageTypeCollection GetStoreCustomPage(
    long PageID
)
Public Function GetStoreCustomPage ( _
    PageID As Long _
) As StoreCustomPageTypeCollection
public:
StoreCustomPageTypeCollection^ GetStoreCustomPage(
    long long PageID
)
Parameters
PageID (Int64)
If a PageID is specified, then that page is returned, and the returned page contains the page Content. If no PageID is specified, then all pages are returned, without the page Content.


GetStoreCustomPageCall Constructor

GetStoreCustomPageCall Constructor
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall ► GetStoreCustomPageCall()()()()
Members
Icon | Member | Description
 | GetStoreCustomPageCall()()()() |
 | GetStoreCustomPageCall(ApiContext) |


GetStoreCustomPageCall Constructor

GetStoreCustomPageCall Constructor
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall ► GetStoreCustomPageCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCustomPageCall()
Public Sub New
public:
GetStoreCustomPageCall()


GetStoreCustomPageCall Constructor (ApiContext)

GetStoreCustomPageCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall ► GetStoreCustomPageCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCustomPageCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetStoreCustomPageCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


PageID Property

PageID Property
Namespaces ► eBay.Service.Call ► GetStoreCustomPageCall ► PageID
Gets or sets the PageID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long PageID { get; set; }
Public Property PageID As Long
    Get
    Set
public:
property long long PageID {
    long long get ();
    void set (long long value);
}


GetStoreOptionsCall Class

GetStoreOptionsCall Class
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetStoreOptionsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetStoreOptionsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetStoreOptionsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreOptionsCall()()()() |
 | GetStoreOptionsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AdvancedThemeArray | Gets the returned AdvancedThemeArray of type StoreThemeArrayType.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetStoreOptionsRequestType for this API call.
 | ApiResponse | Gets the GetStoreOptionsResponseType for this API call.
 | BasicThemeArray | Gets the returned BasicThemeArray of type StoreThemeArrayType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetStoreOptions()()()() | Retrieves the current list of eBay store configuration settings.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | LogoList | Gets the returned LogoArray of type StoreLogoTypeCollection.
 | MaxCategories | Gets the returned MaxCategories of type Int32.
 | MaxCategoryLevels | Gets the returned MaxCategoryLevels of type Int32.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | SubscriptionList | Gets the returned SubscriptionArray of type StoreSubscriptionTypeCollection.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetStoreOptionsCall


AdvancedThemeArray Property

AdvancedThemeArray Property
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► AdvancedThemeArray
Gets the returned AdvancedThemeArray of type StoreThemeArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeArrayType AdvancedThemeArray { get; }
Public ReadOnly Property AdvancedThemeArray As StoreThemeArrayType
    Get
public:
property StoreThemeArrayType^ AdvancedThemeArray {
    StoreThemeArrayType^ get ();
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► ApiRequest
Gets or sets the GetStoreOptionsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreOptionsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetStoreOptionsRequestType
    Get
    Set
public:
property GetStoreOptionsRequestType^ ApiRequest {
    GetStoreOptionsRequestType^ get ();
    void set (GetStoreOptionsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► ApiResponse
Gets the GetStoreOptionsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreOptionsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetStoreOptionsResponseType
    Get
public:
property GetStoreOptionsResponseType^ ApiResponse {
    GetStoreOptionsResponseType^ get ();
}


BasicThemeArray Property

BasicThemeArray Property
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► BasicThemeArray
Gets the returned BasicThemeArray of type StoreThemeArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeArrayType BasicThemeArray { get; }
Public ReadOnly Property BasicThemeArray As StoreThemeArrayType
    Get
public:
property StoreThemeArrayType^ BasicThemeArray {
    StoreThemeArrayType^ get ();
}


GetStoreOptions Method

GetStoreOptions Method
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► GetStoreOptions()()()()
Retrieves the current list of eBay store configuration settings.
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeTypeCollection GetStoreOptions()
Public Function GetStoreOptions As StoreThemeTypeCollection
public:
StoreThemeTypeCollection^ GetStoreOptions()


GetStoreOptionsCall Constructor

GetStoreOptionsCall Constructor
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► GetStoreOptionsCall()()()()
Members
Icon | Member | Description
 | GetStoreOptionsCall()()()() |
 | GetStoreOptionsCall(ApiContext) |


GetStoreOptionsCall Constructor

GetStoreOptionsCall Constructor
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► GetStoreOptionsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreOptionsCall()
Public Sub New
public:
GetStoreOptionsCall()


GetStoreOptionsCall Constructor (ApiContext)

GetStoreOptionsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► GetStoreOptionsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreOptionsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetStoreOptionsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


LogoList Property

LogoList Property
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► LogoList
Gets the returned LogoArray of type StoreLogoTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StoreLogoTypeCollection LogoList { get; }
Public ReadOnly Property LogoList As StoreLogoTypeCollection
    Get
public:
property StoreLogoTypeCollection^ LogoList {
    StoreLogoTypeCollection^ get ();
}


MaxCategories Property

MaxCategories Property
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► MaxCategories
Gets the returned MaxCategories of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int MaxCategories { get; }
Public ReadOnly Property MaxCategories As Integer
    Get
public:
property int MaxCategories {
    int get ();
}


MaxCategoryLevels Property

MaxCategoryLevels Property
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► MaxCategoryLevels
Gets the returned MaxCategoryLevels of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int MaxCategoryLevels { get; }
Public ReadOnly Property MaxCategoryLevels As Integer
    Get
public:
property int MaxCategoryLevels {
    int get ();
}


SubscriptionList Property

SubscriptionList Property
Namespaces ► eBay.Service.Call ► GetStoreOptionsCall ► SubscriptionList
Gets the returned SubscriptionArray of type StoreSubscriptionTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StoreSubscriptionTypeCollection SubscriptionList { get; }
Public ReadOnly Property SubscriptionList As StoreSubscriptionTypeCollection
    Get
public:
property StoreSubscriptionTypeCollection^ SubscriptionList {
    StoreSubscriptionTypeCollection^ get ();
}


GetStorePreferencesCall Class

GetStorePreferencesCall Class
Namespaces ► eBay.Service.Call ► GetStorePreferencesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetStorePreferencesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetStorePreferencesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetStorePreferencesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStorePreferencesCall()()()() |
 | GetStorePreferencesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetStorePreferencesRequestType for this API call.
 | ApiResponse | Gets the GetStorePreferencesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetStorePreferences()()()() | Retrieves a user's Store preferences.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StorePreferences | Gets the returned StorePreferences of type StorePreferencesType.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetStorePreferencesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetStorePreferencesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetStorePreferencesCall ► ApiRequest
Gets or sets the GetStorePreferencesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetStorePreferencesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetStorePreferencesRequestType
    Get
    Set
public:
property GetStorePreferencesRequestType^ ApiRequest {
    GetStorePreferencesRequestType^ get ();
    void set (GetStorePreferencesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetStorePreferencesCall ► ApiResponse
Gets the GetStorePreferencesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetStorePreferencesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetStorePreferencesResponseType
    Get
public:
property GetStorePreferencesResponseType^ ApiResponse {
    GetStorePreferencesResponseType^ get ();
}


GetStorePreferences Method

GetStorePreferences Method
Namespaces ► eBay.Service.Call ► GetStorePreferencesCall ► GetStorePreferences()()()()
Retrieves a user's Store preferences.
Declaration Syntax
C# Visual Basic Visual C++
public StorePreferencesType GetStorePreferences()
Public Function GetStorePreferences As StorePreferencesType
public:
StorePreferencesType^ GetStorePreferences()


GetStorePreferencesCall Constructor

GetStorePreferencesCall Constructor
Namespaces ► eBay.Service.Call ► GetStorePreferencesCall ► GetStorePreferencesCall()()()()
Members
Icon | Member | Description
 | GetStorePreferencesCall()()()() |
 | GetStorePreferencesCall(ApiContext) |


GetStorePreferencesCall Constructor

GetStorePreferencesCall Constructor
Namespaces ► eBay.Service.Call ► GetStorePreferencesCall ► GetStorePreferencesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStorePreferencesCall()
Public Sub New
public:
GetStorePreferencesCall()


GetStorePreferencesCall Constructor (ApiContext)

GetStorePreferencesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetStorePreferencesCall ► GetStorePreferencesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetStorePreferencesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetStorePreferencesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


StorePreferences Property

StorePreferences Property
Namespaces ► eBay.Service.Call ► GetStorePreferencesCall ► StorePreferences
Gets the returned StorePreferences of type StorePreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public StorePreferencesType StorePreferences { get; }
Public ReadOnly Property StorePreferences As StorePreferencesType
    Get
public:
property StorePreferencesType^ StorePreferences {
    StorePreferencesType^ get ();
}


GetSuggestedCategoriesCall Class

GetSuggestedCategoriesCall Class
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetSuggestedCategoriesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetSuggestedCategoriesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetSuggestedCategoriesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSuggestedCategoriesCall()()()() |
 | GetSuggestedCategoriesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetSuggestedCategoriesRequestType for this API call.
 | ApiResponse | Gets the GetSuggestedCategoriesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CategoryCount | Gets the returned CategoryCount of type Int32.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetSuggestedCategories(String) | Returns a list of up to 10 categories that have the highest percentage of listings whose titles or descriptions contain the keywords you specify.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | Query | Gets or sets the Query of type String.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | SuggestedCategoryArray | Gets the returned SuggestedCategoryArray of type SuggestedCategoryArrayType.
 | SuggestedCategoryList | Gets the SuggestedCategory of type SuggestedCategoryTypeCollection.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetSuggestedCategoriesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall ► ApiRequest
Gets or sets the GetSuggestedCategoriesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSuggestedCategoriesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetSuggestedCategoriesRequestType
    Get
    Set
public:
property GetSuggestedCategoriesRequestType^ ApiRequest {
    GetSuggestedCategoriesRequestType^ get ();
    void set (GetSuggestedCategoriesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall ► ApiResponse
Gets the GetSuggestedCategoriesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetSuggestedCategoriesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetSuggestedCategoriesResponseType
    Get
public:
property GetSuggestedCategoriesResponseType^ ApiResponse {
    GetSuggestedCategoriesResponseType^ get ();
}


CategoryCount Property

CategoryCount Property
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall ► CategoryCount
Gets the returned CategoryCount of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int CategoryCount { get; }
Public ReadOnly Property CategoryCount As Integer
    Get
public:
property int CategoryCount {
    int get ();
}


GetSuggestedCategories Method (Query)

GetSuggestedCategories Method (Query)
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall ► GetSuggestedCategories(String)
Returns a list of up to 10 categories that have the highest percentage of listings whose titles or descriptions contain the keywords you specify.
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryTypeCollection GetSuggestedCategories(
    string Query
)
Public Function GetSuggestedCategories ( _
    Query As String _
) As SuggestedCategoryTypeCollection
public:
SuggestedCategoryTypeCollection^ GetSuggestedCategories(
    String^ Query
)
Parameters
Query (String)
Specifies the search string, consisting of one or more words to search for in the listing title. The words "and" and "or" are treated like any other word.


GetSuggestedCategoriesCall Constructor

GetSuggestedCategoriesCall Constructor
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall ► GetSuggestedCategoriesCall()()()()
Members
Icon | Member | Description
 | GetSuggestedCategoriesCall()()()() |
 | GetSuggestedCategoriesCall(ApiContext) |


GetSuggestedCategoriesCall Constructor

GetSuggestedCategoriesCall Constructor
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall ► GetSuggestedCategoriesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSuggestedCategoriesCall()
Public Sub New
public:
GetSuggestedCategoriesCall()


GetSuggestedCategoriesCall Constructor (ApiContext)

GetSuggestedCategoriesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall ► GetSuggestedCategoriesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetSuggestedCategoriesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetSuggestedCategoriesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


Query Property

Query Property
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall ► Query
Gets or sets the Query of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Query { get; set; }
Public Property Query As String
    Get
    Set
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}


SuggestedCategoryArray Property

SuggestedCategoryArray Property
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall ► SuggestedCategoryArray
Gets the returned SuggestedCategoryArray of type SuggestedCategoryArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryArrayType SuggestedCategoryArray { get; }
Public ReadOnly Property SuggestedCategoryArray As SuggestedCategoryArrayType
    Get
public:
property SuggestedCategoryArrayType^ SuggestedCategoryArray {
    SuggestedCategoryArrayType^ get ();
}


SuggestedCategoryList Property

SuggestedCategoryList Property
Namespaces ► eBay.Service.Call ► GetSuggestedCategoriesCall ► SuggestedCategoryList
Gets the SuggestedCategory of type SuggestedCategoryTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryTypeCollection SuggestedCategoryList { get; }
Public ReadOnly Property SuggestedCategoryList As SuggestedCategoryTypeCollection
    Get
public:
property SuggestedCategoryTypeCollection^ SuggestedCategoryList {
    SuggestedCategoryTypeCollection^ get ();
}


GetTaxTableCall Class

GetTaxTableCall Class
Namespaces ► eBay.Service.Call ► GetTaxTableCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetTaxTableCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetTaxTableCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetTaxTableCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetTaxTableCall()()()() |
 | GetTaxTableCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetTaxTableRequestType for this API call.
 | ApiResponse | Gets the GetTaxTableResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetTaxTable()()()() | Retrieves the tax table for a user on a given site or retrieves the valid jurisdictions (if any) for a given site.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LastUpdateTime | Gets the returned LastUpdateTime of type DateTime.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | TaxTableList | Gets the returned TaxTable of type TaxJurisdictionTypeCollection.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetTaxTableCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetTaxTableCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetTaxTableCall ► ApiRequest
Gets or sets the GetTaxTableRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetTaxTableRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetTaxTableRequestType
    Get
    Set
public:
property GetTaxTableRequestType^ ApiRequest {
    GetTaxTableRequestType^ get ();
    void set (GetTaxTableRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetTaxTableCall ► ApiResponse
Gets the GetTaxTableResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetTaxTableResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetTaxTableResponseType
    Get
public:
property GetTaxTableResponseType^ ApiResponse {
    GetTaxTableResponseType^ get ();
}


GetTaxTable Method

GetTaxTable Method
Namespaces ► eBay.Service.Call ► GetTaxTableCall ► GetTaxTable()()()()
Retrieves the tax table for a user on a given site or retrieves the valid jurisdictions (if any) for a given site.
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection GetTaxTable()
Public Function GetTaxTable As TaxJurisdictionTypeCollection
public:
TaxJurisdictionTypeCollection^ GetTaxTable()


GetTaxTableCall Constructor

GetTaxTableCall Constructor
Namespaces ► eBay.Service.Call ► GetTaxTableCall ► GetTaxTableCall()()()()
Members
Icon | Member | Description
 | GetTaxTableCall()()()() |
 | GetTaxTableCall(ApiContext) |


GetTaxTableCall Constructor

GetTaxTableCall Constructor
Namespaces ► eBay.Service.Call ► GetTaxTableCall ► GetTaxTableCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetTaxTableCall()
Public Sub New
public:
GetTaxTableCall()


GetTaxTableCall Constructor (ApiContext)

GetTaxTableCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetTaxTableCall ► GetTaxTableCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetTaxTableCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetTaxTableCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


LastUpdateTime Property

LastUpdateTime Property
Namespaces ► eBay.Service.Call ► GetTaxTableCall ► LastUpdateTime
Gets the returned LastUpdateTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastUpdateTime { get; }
Public ReadOnly Property LastUpdateTime As DateTime
    Get
public:
property DateTime LastUpdateTime {
    DateTime get ();
}


TaxTableList Property

TaxTableList Property
Namespaces ► eBay.Service.Call ► GetTaxTableCall ► TaxTableList
Gets the returned TaxTable of type TaxJurisdictionTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection TaxTableList { get; }
Public ReadOnly Property TaxTableList As TaxJurisdictionTypeCollection
    Get
public:
property TaxJurisdictionTypeCollection^ TaxTableList {
    TaxJurisdictionTypeCollection^ get ();
}


GetTokenStatusCall Class

GetTokenStatusCall Class
Namespaces ► eBay.Service.Call ► GetTokenStatusCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetTokenStatusCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetTokenStatusCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetTokenStatusCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetTokenStatusCall()()()() |
 | GetTokenStatusCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetTokenStatusRequestType for this API call.
 | ApiResponse | Gets the GetTokenStatusResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Overrides ApiCall.GetSecurityHeader()()()().)
 | GetTokenStatus()()()() | Requests current status of user token.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | TokenStatus | Gets the returned TokenStatus of type TokenStatusType.
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetTokenStatusCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetTokenStatusCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetTokenStatusCall ► ApiRequest
Gets or sets the GetTokenStatusRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetTokenStatusRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetTokenStatusRequestType
    Get
    Set
public:
property GetTokenStatusRequestType^ ApiRequest {
    GetTokenStatusRequestType^ get ();
    void set (GetTokenStatusRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetTokenStatusCall ► ApiResponse
Gets the GetTokenStatusResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetTokenStatusResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetTokenStatusResponseType
    Get
public:
property GetTokenStatusResponseType^ ApiResponse {
    GetTokenStatusResponseType^ get ();
}


GetSecurityHeader Method

GetSecurityHeader Method
Namespaces ► eBay.Service.Call ► GetTokenStatusCall ► GetSecurityHeader()()()()
Constructs a security header from values in ApiContext.
Declaration Syntax
C# Visual Basic Visual C++
protected override CustomSecurityHeaderType GetSecurityHeader()
Protected Overrides Function GetSecurityHeader As CustomSecurityHeaderType
protected:
virtual CustomSecurityHeaderType^ GetSecurityHeader() override
Return Value
Security information of type CustomSecurityHeaderType.


GetTokenStatus Method

GetTokenStatus Method
Namespaces ► eBay.Service.Call ► GetTokenStatusCall ► GetTokenStatus()()()()
Requests current status of user token.
Declaration Syntax
C# Visual Basic Visual C++
public TokenStatusType GetTokenStatus()
Public Function GetTokenStatus As TokenStatusType
public:
TokenStatusType^ GetTokenStatus()


GetTokenStatusCall Constructor

GetTokenStatusCall Constructor
Namespaces ► eBay.Service.Call ► GetTokenStatusCall ► GetTokenStatusCall()()()()
Members
Icon | Member | Description
 | GetTokenStatusCall()()()() |
 | GetTokenStatusCall(ApiContext) |


GetTokenStatusCall Constructor

GetTokenStatusCall Constructor
Namespaces ► eBay.Service.Call ► GetTokenStatusCall ► GetTokenStatusCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetTokenStatusCall()
Public Sub New
public:
GetTokenStatusCall()


GetTokenStatusCall Constructor (ApiContext)

GetTokenStatusCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetTokenStatusCall ► GetTokenStatusCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetTokenStatusCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetTokenStatusCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


TokenStatus Property

TokenStatus Property
Namespaces ► eBay.Service.Call ► GetTokenStatusCall ► TokenStatus
Gets the returned TokenStatus of type TokenStatusType.
Declaration Syntax
C# Visual Basic Visual C++
public TokenStatusType TokenStatus { get; }
Public ReadOnly Property TokenStatus As TokenStatusType
    Get
public:
property TokenStatusType^ TokenStatus {
    TokenStatusType^ get ();
}


GetUserCall Class

GetUserCall Class
Namespaces ► eBay.Service.Call ► GetUserCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetUserCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetUserCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetUserCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserCall()()()() |
 | GetUserCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetUserRequestType for this API call.
 | ApiResponse | Gets the GetUserResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | GetUser(String, String, Boolean, Boolean) | Retrieves data pertaining to a single eBay user. Callers can use this call to return their own user data or the data of another eBay user. Unless the caller passes in an ItemID that identifies a current or past common order, not all data (like email addresses) will be returned in the User object.
 | GetUser(String) | For backward compatibility with old wrappers.
 | GetUser()()()() | For backward compatibility with old wrappers.
 | GetUser(String, String) | For backward compatibility with old wrappers.
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeExpressRequirements | Gets or sets the IncludeExpressRequirements of type Boolean.
 | IncludeFeatureEligibility | Gets or sets the IncludeFeatureEligibility of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | User | Gets the returned User of type UserType.
 | UserID | Gets or sets the UserID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetUserCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetUserCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetUserCall ► ApiRequest
Gets or sets the GetUserRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetUserRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetUserRequestType
    Get
    Set
public:
property GetUserRequestType^ ApiRequest {
    GetUserRequestType^ get ();
    void set (GetUserRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetUserCall ► ApiResponse
Gets the GetUserResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetUserResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetUserResponseType
    Get
public:
property GetUserResponseType^ ApiResponse {
    GetUserResponseType^ get ();
}


GetUser Method

GetUser Method
Namespaces ► eBay.Service.Call ► GetUserCall ► GetUser()()()()
Members
Icon | Member | Description
 | GetUser(String, String, Boolean, Boolean) | Retrieves data pertaining to a single eBay user. Callers can use this call to return their own user data or the data of another eBay user. Unless the caller passes in an ItemID that identifies a current or past common order, not all data (like email addresses) will be returned in the User object.
 | GetUser(String) | For backward compatibility with old wrappers.
 | GetUser()()()() | For backward compatibility with old wrappers.
 | GetUser(String, String) | For backward compatibility with old wrappers.


GetUser Method

GetUser Method
Namespaces ► eBay.Service.Call ► GetUserCall ► GetUser()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public UserType GetUser()
Public Function GetUser As UserType
public:
UserType^ GetUser()


GetUser Method (ItemID, UserID, IncludeExpressRequirements, IncludeFeatureEligibility)

GetUser Method (ItemID, UserID, IncludeExpressRequirements, IncludeFeatureEligibility)
Namespaces ► eBay.Service.Call ► GetUserCall ► GetUser(String, String, Boolean, Boolean)
Retrieves data pertaining to a single eBay user. Callers can use this call to return their own user data or the data of another eBay user. Unless the caller passes in an ItemID that identifies a current or past common order, not all data (like email addresses) will be returned in the User object.
Declaration Syntax
C# Visual Basic Visual C++
public UserType GetUser(
    string ItemID,
    string UserID,
    bool IncludeExpressRequirements,
    bool IncludeFeatureEligibility
)
Public Function GetUser ( _
    ItemID As String, _
    UserID As String, _
    IncludeExpressRequirements As Boolean, _
    IncludeFeatureEligibility As Boolean _
) As UserType
public:
UserType^ GetUser(
    String^ ItemID,
    String^ UserID,
    bool IncludeExpressRequirements,
    bool IncludeFeatureEligibility
)
Parameters
ItemID (String)
Specify the item ID for a successfully concluded listing in which the requestor and target user were participants (one as seller and the other as buyer). Necessary to return certain data (like an email address). Not necessary if the requestor is retrieving their own data. ItemID is an optional input.
UserID (String)
Specify the user whose data you want returned by the call. UserID is optional. If not specified, eBay returns data pertaining to the requesting user (as specified with the eBayAuthToken).
IncludeExpressRequirements (Boolean)
This field is deprecated.
IncludeFeatureEligibility (Boolean)
If the IncludeFeatureEligibility flag is included and set to 'true', the call response will include a QualifiesForSelling flag which indicates if the eBay user is eligible to sell on eBay, and a IncludeFeatureEligibility container which indicates which selling features are available to the user.


GetUser Method (UserID)

GetUser Method (UserID)
Namespaces ► eBay.Service.Call ► GetUserCall ► GetUser(String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public UserType GetUser(
    string UserID
)
Public Function GetUser ( _
    UserID As String _
) As UserType
public:
UserType^ GetUser(
    String^ UserID
)
Parameters
UserID (String)


GetUser Method (UserID, ItemID)

GetUser Method (UserID, ItemID)
Namespaces ► eBay.Service.Call ► GetUserCall ► GetUser(String, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public UserType GetUser(
    string UserID,
    string ItemID
)
Public Function GetUser ( _
    UserID As String, _
    ItemID As String _
) As UserType
public:
UserType^ GetUser(
    String^ UserID,
    String^ ItemID
)
Parameters
UserID (String)
ItemID (String)


GetUserCall Constructor

GetUserCall Constructor
Namespaces ► eBay.Service.Call ► GetUserCall ► GetUserCall()()()()
Members
Icon | Member | Description
 | GetUserCall()()()() |
 | GetUserCall(ApiContext) |


GetUserCall Constructor

GetUserCall Constructor
Namespaces ► eBay.Service.Call ► GetUserCall ► GetUserCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserCall()
Public Sub New
public:
GetUserCall()


GetUserCall Constructor (ApiContext)

GetUserCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetUserCall ► GetUserCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetUserCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetUserCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


IncludeExpressRequirements Property

IncludeExpressRequirements Property
Namespaces ► eBay.Service.Call ► GetUserCall ► IncludeExpressRequirements
Gets or sets the IncludeExpressRequirements of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeExpressRequirements { get; set; }
Public Property IncludeExpressRequirements As Boolean
    Get
    Set
public:
property bool IncludeExpressRequirements {
    bool get ();
    void set (bool value);
}


IncludeFeatureEligibility Property

IncludeFeatureEligibility Property
Namespaces ► eBay.Service.Call ► GetUserCall ► IncludeFeatureEligibility
Gets or sets the IncludeFeatureEligibility of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFeatureEligibility { get; set; }
Public Property IncludeFeatureEligibility As Boolean
    Get
    Set
public:
property bool IncludeFeatureEligibility {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetUserCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


User Property

User Property
Namespaces ► eBay.Service.Call ► GetUserCall ► User
Gets the returned User of type UserType.
Declaration Syntax
C# Visual Basic Visual C++
public UserType User { get; }
Public ReadOnly Property User As UserType
    Get
public:
property UserType^ User {
    UserType^ get ();
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Call ► GetUserCall ► UserID
Gets or sets the UserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetUserContactDetailsCall Class

GetUserContactDetailsCall Class
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetUserContactDetailsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetUserContactDetailsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetUserContactDetailsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserContactDetailsCall()()()() |
 | GetUserContactDetailsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetUserContactDetailsRequestType for this API call.
 | ApiResponse | Gets the GetUserContactDetailsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | ContactAddress | Gets the returned ContactAddress of type AddressType.
 | ContactID | Gets or sets the ContactID of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | GetUserContactDetails(String, String, String) | Returns contact information for a specified user, given that a bidding relationship (as either a buyer or seller) exists between the caller and the user.
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | RegistrationDate | Gets the returned RegistrationDate of type DateTime.
 | RequesterID | Gets or sets the RequesterID of type String.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UserID | Gets the returned UserID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetUserContactDetailsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► ApiRequest
Gets or sets the GetUserContactDetailsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetUserContactDetailsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetUserContactDetailsRequestType
    Get
    Set
public:
property GetUserContactDetailsRequestType^ ApiRequest {
    GetUserContactDetailsRequestType^ get ();
    void set (GetUserContactDetailsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► ApiResponse
Gets the GetUserContactDetailsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetUserContactDetailsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetUserContactDetailsResponseType
    Get
public:
property GetUserContactDetailsResponseType^ ApiResponse {
    GetUserContactDetailsResponseType^ get ();
}


ContactAddress Property

ContactAddress Property
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► ContactAddress
Gets the returned ContactAddress of type AddressType.
Declaration Syntax
C# Visual Basic Visual C++
public AddressType ContactAddress { get; }
Public ReadOnly Property ContactAddress As AddressType
    Get
public:
property AddressType^ ContactAddress {
    AddressType^ get ();
}


ContactID Property

ContactID Property
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► ContactID
Gets or sets the ContactID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ContactID { get; set; }
Public Property ContactID As String
    Get
    Set
public:
property String^ ContactID {
    String^ get ();
    void set (String^ value);
}


GetUserContactDetails Method (ItemID, ContactID, RequesterID)

GetUserContactDetails Method (ItemID, ContactID, RequesterID)
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► GetUserContactDetails(String, String, String)
Returns contact information for a specified user, given that a bidding relationship (as either a buyer or seller) exists between the caller and the user.
Declaration Syntax
C# Visual Basic Visual C++
public string GetUserContactDetails(
    string ItemID,
    string ContactID,
    string RequesterID
)
Public Function GetUserContactDetails ( _
    ItemID As String, _
    ContactID As String, _
    RequesterID As String _
) As String
public:
String^ GetUserContactDetails(
    String^ ItemID,
    String^ ContactID,
    String^ RequesterID
)
Parameters
ItemID (String)
An eBay item ID that uniquely identifies a currently active item.
ContactID (String)
An eBay ID that uniquely identifies a given user for whom the caller is seeking information. This is the user's eBay username. Either a seller's or bidder's username can be specified here, as long as a bidding relationship exists between the requester and the user specified by this field. That is, a bidder must be bidding on the seller's active item, or have made an offer on the item via Best Offer.
RequesterID (String)
An eBay ID that uniquely identifies the person who is making the call. This is the requester's eBay username. Either a seller's or bidder's username can be specified here, as long as a bidding relationship exists between the requester and the user for whom information is being requested.


GetUserContactDetailsCall Constructor

GetUserContactDetailsCall Constructor
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► GetUserContactDetailsCall()()()()
Members
Icon | Member | Description
 | GetUserContactDetailsCall()()()() |
 | GetUserContactDetailsCall(ApiContext) |


GetUserContactDetailsCall Constructor

GetUserContactDetailsCall Constructor
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► GetUserContactDetailsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserContactDetailsCall()
Public Sub New
public:
GetUserContactDetailsCall()


GetUserContactDetailsCall Constructor (ApiContext)

GetUserContactDetailsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► GetUserContactDetailsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetUserContactDetailsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetUserContactDetailsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


RegistrationDate Property

RegistrationDate Property
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► RegistrationDate
Gets the returned RegistrationDate of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RegistrationDate { get; }
Public ReadOnly Property RegistrationDate As DateTime
    Get
public:
property DateTime RegistrationDate {
    DateTime get ();
}


RequesterID Property

RequesterID Property
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► RequesterID
Gets or sets the RequesterID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string RequesterID { get; set; }
Public Property RequesterID As String
    Get
    Set
public:
property String^ RequesterID {
    String^ get ();
    void set (String^ value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Call ► GetUserContactDetailsCall ► UserID
Gets the returned UserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; }
Public ReadOnly Property UserID As String
    Get
public:
property String^ UserID {
    String^ get ();
}


GetUserDisputesCall Class

GetUserDisputesCall Class
Namespaces ► eBay.Service.Call ► GetUserDisputesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetUserDisputesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetUserDisputesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetUserDisputesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserDisputesCall()()()() |
 | GetUserDisputesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetUserDisputesRequestType for this API call.
 | ApiResponse | Gets the GetUserDisputesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DisputeFilterList | Gets the returned DisputeFilterCount of type DisputeFilterCountTypeCollection.
 | DisputeFilterType | Gets or sets the DisputeFilterType of type DisputeFilterTypeCodeType.
 | DisputeList | Gets the returned DisputeArray of type DisputeTypeCollection.
 | DisputeSortType | Gets or sets the DisputeSortType of type DisputeSortTypeCodeType.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndingDisputeID | Gets the returned EndingDisputeID of type String.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | GetUserDisputes(DisputeFilterTypeCodeType, DisputeSortTypeCodeType, DateTime, DateTime, PaginationType) | Requests a list of disputes the requester is involved in as buyer or seller. eBay Money Back Guarantee Item Not Received and Significantly Not As Described cases are not returned with this call. To retrieve eBay Money Back Guarantee cases, use the Resolution Case Management API getUserCases call.
 | GetUserDisputes(PaginationType) | For backward compatibility with old wrappers.
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemsPerPage | Gets the returned ItemsPerPage of type Int32.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModTimeFrom | Gets or sets the ModTimeFrom of type DateTime.
 | ModTimeTo | Gets or sets the ModTimeTo of type DateTime.
 | OutputSelector | (Inherited from ApiCall.)
 | PageNumber | Gets the returned PageNumber of type Int32.
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartingDisputeID | Gets the returned StartingDisputeID of type String.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetUserDisputesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► ApiRequest
Gets or sets the GetUserDisputesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetUserDisputesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetUserDisputesRequestType
    Get
    Set
public:
property GetUserDisputesRequestType^ ApiRequest {
    GetUserDisputesRequestType^ get ();
    void set (GetUserDisputesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► ApiResponse
Gets the GetUserDisputesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetUserDisputesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetUserDisputesResponseType
    Get
public:
property GetUserDisputesResponseType^ ApiResponse {
    GetUserDisputesResponseType^ get ();
}


DisputeFilterList Property

DisputeFilterList Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► DisputeFilterList
Gets the returned DisputeFilterCount of type DisputeFilterCountTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterCountTypeCollection DisputeFilterList { get; }
Public ReadOnly Property DisputeFilterList As DisputeFilterCountTypeCollection
    Get
public:
property DisputeFilterCountTypeCollection^ DisputeFilterList {
    DisputeFilterCountTypeCollection^ get ();
}


DisputeFilterType Property

DisputeFilterType Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► DisputeFilterType
Gets or sets the DisputeFilterType of type DisputeFilterTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterTypeCodeType DisputeFilterType { get; set; }
Public Property DisputeFilterType As DisputeFilterTypeCodeType
    Get
    Set
public:
property DisputeFilterTypeCodeType DisputeFilterType {
    DisputeFilterTypeCodeType get ();
    void set (DisputeFilterTypeCodeType value);
}


DisputeList Property

DisputeList Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► DisputeList
Gets the returned DisputeArray of type DisputeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeTypeCollection DisputeList { get; }
Public ReadOnly Property DisputeList As DisputeTypeCollection
    Get
public:
property DisputeTypeCollection^ DisputeList {
    DisputeTypeCollection^ get ();
}


DisputeSortType Property

DisputeSortType Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► DisputeSortType
Gets or sets the DisputeSortType of type DisputeSortTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeSortTypeCodeType DisputeSortType { get; set; }
Public Property DisputeSortType As DisputeSortTypeCodeType
    Get
    Set
public:
property DisputeSortTypeCodeType DisputeSortType {
    DisputeSortTypeCodeType get ();
    void set (DisputeSortTypeCodeType value);
}


EndingDisputeID Property

EndingDisputeID Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► EndingDisputeID
Gets the returned EndingDisputeID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string EndingDisputeID { get; }
Public ReadOnly Property EndingDisputeID As String
    Get
public:
property String^ EndingDisputeID {
    String^ get ();
}


GetUserDisputes Method

GetUserDisputes Method
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► GetUserDisputes()()()()
Members
Icon | Member | Description
 | GetUserDisputes(DisputeFilterTypeCodeType, DisputeSortTypeCodeType, DateTime, DateTime, PaginationType) | Requests a list of disputes the requester is involved in as buyer or seller. eBay Money Back Guarantee Item Not Received and Significantly Not As Described cases are not returned with this call. To retrieve eBay Money Back Guarantee cases, use the Resolution Case Management API getUserCases call.
 | GetUserDisputes(PaginationType) | For backward compatibility with old wrappers.


GetUserDisputes Method (DisputeFilterType, DisputeSortType, ModTimeFrom, ModTimeTo, Pagination)

GetUserDisputes Method (DisputeFilterType, DisputeSortType, ModTimeFrom, ModTimeTo, Pagination)
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► GetUserDisputes(DisputeFilterTypeCodeType, DisputeSortTypeCodeType, DateTime, DateTime, PaginationType)
Requests a list of disputes the requester is involved in as buyer or seller. eBay Money Back Guarantee Item Not Received and Significantly Not As Described cases are not returned with this call. To retrieve eBay Money Back Guarantee cases, use the Resolution Case Management API getUserCases call.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeTypeCollection GetUserDisputes(
    DisputeFilterTypeCodeType DisputeFilterType,
    DisputeSortTypeCodeType DisputeSortType,
    DateTime ModTimeFrom,
    DateTime ModTimeTo,
    PaginationType Pagination
)
Public Function GetUserDisputes ( _
    DisputeFilterType As DisputeFilterTypeCodeType, _
    DisputeSortType As DisputeSortTypeCodeType, _
    ModTimeFrom As DateTime, _
    ModTimeTo As DateTime, _
    Pagination As PaginationType _
) As DisputeTypeCollection
public:
DisputeTypeCollection^ GetUserDisputes(
    DisputeFilterTypeCodeType DisputeFilterType,
    DisputeSortTypeCodeType DisputeSortType,
    DateTime ModTimeFrom,
    DateTime ModTimeTo,
    PaginationType^ Pagination
)
Parameters
DisputeFilterType (DisputeFilterTypeCodeType)
An inclusive filter that isolates the returned disputes to a certain type such as Item Not Received or Unpaid Item disputes. eBay Money Back Guarantee cases are not retrieved with this call, even if the ItemNotReceivedDisputes filter is included in the request.
DisputeSortType (DisputeSortTypeCodeType)
The value and sequence to use to sort the returned disputes.
ModTimeFrom (DateTime)
A filter that retrieves disputes whose DisputeModifiedTime is later than or equal to this value. Specify the time value in GMT. See the eBay Features Guide for information about specifying time values. For more precise control of the date range filter, it is a good practice to also specify ModTimeTo. Otherwise, the end of the date range is the present time. Filtering by date range is optional. You can use date range filters in combination with other filters like DisputeFilterType to control the amount of data returned.
ModTimeTo (DateTime)
A filter that retrieves disputes whose DisputeModifiedTime is earlier than or equal to this value. Specify the time value in GMT. See the eBay Features Guide for information about specifying time values. For more precise control of the date range filter, it is a good practice to also specify ModTimeFrom. Otherwise, all available disputes modified prior to the ModTimeTo value are returned. Filtering by date range is optional. You can use date range filters in combination with other filters like DisputeFilterType to control the amount of data returned.
Pagination (PaginationType)
The virtual page number of the result set to display. A result set has a number of disputes divided into virtual pages, with 200 disputes per page. The response can only display one page. The first page in the result set is number 1. Required. If not specified, a warning is returned and Pagination.PageNumber is set to 1 by default.


GetUserDisputes Method (Pagination)

GetUserDisputes Method (Pagination)
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► GetUserDisputes(PaginationType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeTypeCollection GetUserDisputes(
    PaginationType Pagination
)
Public Function GetUserDisputes ( _
    Pagination As PaginationType _
) As DisputeTypeCollection
public:
DisputeTypeCollection^ GetUserDisputes(
    PaginationType^ Pagination
)
Parameters
Pagination (PaginationType)


GetUserDisputesCall Constructor

GetUserDisputesCall Constructor
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► GetUserDisputesCall()()()()
Members
Icon | Member | Description
 | GetUserDisputesCall()()()() |
 | GetUserDisputesCall(ApiContext) |


GetUserDisputesCall Constructor

GetUserDisputesCall Constructor
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► GetUserDisputesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserDisputesCall()
Public Sub New
public:
GetUserDisputesCall()


GetUserDisputesCall Constructor (ApiContext)

GetUserDisputesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► GetUserDisputesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetUserDisputesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetUserDisputesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ItemsPerPage Property

ItemsPerPage Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► ItemsPerPage
Gets the returned ItemsPerPage of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int ItemsPerPage { get; }
Public ReadOnly Property ItemsPerPage As Integer
    Get
public:
property int ItemsPerPage {
    int get ();
}


ModTimeFrom Property

ModTimeFrom Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► ModTimeFrom
Gets or sets the ModTimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeFrom { get; set; }
Public Property ModTimeFrom As DateTime
    Get
    Set
public:
property DateTime ModTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


ModTimeTo Property

ModTimeTo Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► ModTimeTo
Gets or sets the ModTimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeTo { get; set; }
Public Property ModTimeTo As DateTime
    Get
    Set
public:
property DateTime ModTimeTo {
    DateTime get ();
    void set (DateTime value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► PageNumber
Gets the returned PageNumber of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
public:
property int PageNumber {
    int get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


StartingDisputeID Property

StartingDisputeID Property
Namespaces ► eBay.Service.Call ► GetUserDisputesCall ► StartingDisputeID
Gets the returned StartingDisputeID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string StartingDisputeID { get; }
Public ReadOnly Property StartingDisputeID As String
    Get
public:
property String^ StartingDisputeID {
    String^ get ();
}


GetUserPreferencesCall Class

GetUserPreferencesCall Class
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetUserPreferencesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetUserPreferencesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetUserPreferencesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserPreferencesCall()()()() |
 | GetUserPreferencesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetUserPreferencesRequestType for this API call.
 | ApiResponse | Gets the GetUserPreferencesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BidderNoticePreferences | Gets the returned BidderNoticePreferences of type BidderNoticePreferencesType.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CombinedPaymentPreferences | Gets the returned CombinedPaymentPreferences of type CombinedPaymentPreferencesType.
 | CrossPromotionPreferences | Gets the returned CrossPromotionPreferences of type CrossPromotionPreferencesType.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DispatchCutoffTimePreference | Gets the returned DispatchCutoffTimePreference of type DispatchCutoffTimePreferencesType.
 | eBayPLUSPreferenceList | Gets the returned eBayPLUSPreference of type eBayPLUSPreferenceTypeCollection.
 | EmailShipmentTrackingNumberPreference | Gets the returned EmailShipmentTrackingNumberPreference of type Boolean.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndOfAuctionEmailPreferences | Gets the returned EndOfAuctionEmailPreferences of type EndOfAuctionEmailPreferencesType.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | GetUserPreferences(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Retrieves the specified user preferences for the authenticated caller.
 | GetUserPreferences(Boolean, Boolean, Boolean, Boolean, Boolean) | For backward compatibility with old wrappers.
 | GetUserPreferences(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | For backward compatibility with old wrappers.
 | GlobalShippingProgramListingPreference | Gets the returned GlobalShippingProgramListingPreference of type Boolean.
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OfferGlobalShippingProgramPreference | Gets the returned OfferGlobalShippingProgramPreference of type Boolean.
 | OutOfStockControlPreference | Gets the returned OutOfStockControlPreference of type Boolean.
 | OutputSelector | (Inherited from ApiCall.)
 | OverrideGSPServiceWithIntlServicePreference | Gets the returned OverrideGSPServiceWithIntlServicePreference of type Boolean.
 | PickupDropoffSellerPreference | Gets the returned PickupDropoffSellerPreference of type Boolean.
 | ProStoresPreference | Gets the returned ProStoresPreference of type ProStoresCheckoutPreferenceType.
 | PurchaseReminderEmailPreferences | Gets the returned PurchaseReminderEmailPreferences of type PurchaseReminderEmailPreferencesType.
 | RequiredShipPhoneNumberPreference | Gets the returned RequiredShipPhoneNumberPreference of type Boolean.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellerExcludeShipToLocationPreferences | Gets the returned SellerExcludeShipToLocationPreferences of type SellerExcludeShipToLocationPreferencesType.
 | SellerFavoriteItemPreferences | Gets the returned SellerFavoriteItemPreferences of type SellerFavoriteItemPreferencesType.
 | SellerPaymentPreferences | Gets the returned SellerPaymentPreferences of type SellerPaymentPreferencesType.
 | SellerProfilePreferences | Gets the returned SellerProfilePreferences of type SellerProfilePreferencesType.
 | SellerReturnPreferences | Gets the returned SellerReturnPreferences of type SellerReturnPreferencesType.
 | SellerThirdPartyCheckoutDisabled | Gets the returned SellerThirdPartyCheckoutDisabled of type Boolean.
 | ShowBidderNoticePreferences | Gets or sets the ShowBidderNoticePreferences of type Boolean.
 | ShowCombinedPaymentPreferences | Gets or sets the ShowCombinedPaymentPreferences of type Boolean.
 | ShowCrossPromotionPreferences | Gets or sets the ShowCrossPromotionPreferences of type Boolean.
 | ShowDispatchCutoffTimePreferences | Gets or sets the ShowDispatchCutoffTimePreferences of type Boolean.
 | ShoweBayPLUSPreference | Gets or sets the ShoweBayPLUSPreference of type Boolean.
 | ShowEmailShipmentTrackingNumberPreference | Gets or sets the ShowEmailShipmentTrackingNumberPreference of type Boolean.
 | ShowEndOfAuctionEmailPreferences | Gets or sets the ShowEndOfAuctionEmailPreferences of type Boolean.
 | ShowGlobalShippingProgramListingPreference | Gets or sets the ShowGlobalShippingProgramListingPreference of type Boolean.
 | ShowGlobalShippingProgramPreference | Gets or sets the ShowGlobalShippingProgramPreference of type Boolean.
 | ShowOutOfStockControlPreference | Gets or sets the ShowOutOfStockControlPreference of type Boolean.
 | ShowOverrideGSPServiceWithIntlServicePreference | Gets or sets the ShowOverrideGSPServiceWithIntlServicePreference of type Boolean.
 | ShowPickupDropoffPreferences | Gets or sets the ShowPickupDropoffPreferences of type Boolean.
 | ShowProStoresPreferences | Gets or sets the ShowProStoresPreferences of type Boolean.
 | ShowPurchaseReminderEmailPreferences | Gets or sets the ShowPurchaseReminderEmailPreferences of type Boolean.
 | ShowRequiredShipPhoneNumberPreference | Gets or sets the ShowRequiredShipPhoneNumberPreference of type Boolean.
 | ShowSellerExcludeShipToLocationPreference | Gets or sets the ShowSellerExcludeShipToLocationPreference of type Boolean.
 | ShowSellerFavoriteItemPreferences | Gets or sets the ShowSellerFavoriteItemPreferences of type Boolean.
 | ShowSellerPaymentPreferences | Gets or sets the ShowSellerPaymentPreferences of type Boolean.
 | ShowSellerProfilePreferences | Gets or sets the ShowSellerProfilePreferences of type Boolean.
 | ShowSellerReturnPreferences | Gets or sets the ShowSellerReturnPreferences of type Boolean.
 | ShowUnpaidItemAssistanceExclusionList | Gets or sets the ShowUnpaidItemAssistanceExclusionList of type Boolean.
 | ShowUnpaidItemAssistancePreference | Gets or sets the ShowUnpaidItemAssistancePreference of type Boolean.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UnpaidItemAssistancePreferences | Gets the returned UnpaidItemAssistancePreferences of type UnpaidItemAssistancePreferencesType.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetUserPreferencesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ApiRequest
Gets or sets the GetUserPreferencesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetUserPreferencesRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetUserPreferencesRequestType
    Get
    Set
public:
property GetUserPreferencesRequestType^ ApiRequest {
    GetUserPreferencesRequestType^ get ();
    void set (GetUserPreferencesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ApiResponse
Gets the GetUserPreferencesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetUserPreferencesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetUserPreferencesResponseType
    Get
public:
property GetUserPreferencesResponseType^ ApiResponse {
    GetUserPreferencesResponseType^ get ();
}


BidderNoticePreferences Property

BidderNoticePreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► BidderNoticePreferences
Gets the returned BidderNoticePreferences of type BidderNoticePreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public BidderNoticePreferencesType BidderNoticePreferences { get; }
Public ReadOnly Property BidderNoticePreferences As BidderNoticePreferencesType
    Get
public:
property BidderNoticePreferencesType^ BidderNoticePreferences {
    BidderNoticePreferencesType^ get ();
}


CombinedPaymentPreferences Property

CombinedPaymentPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► CombinedPaymentPreferences
Gets the returned CombinedPaymentPreferences of type CombinedPaymentPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public CombinedPaymentPreferencesType CombinedPaymentPreferences { get; }
Public ReadOnly Property CombinedPaymentPreferences As CombinedPaymentPreferencesType
    Get
public:
property CombinedPaymentPreferencesType^ CombinedPaymentPreferences {
    CombinedPaymentPreferencesType^ get ();
}


CrossPromotionPreferences Property

CrossPromotionPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► CrossPromotionPreferences
Gets the returned CrossPromotionPreferences of type CrossPromotionPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public CrossPromotionPreferencesType CrossPromotionPreferences { get; }
Public ReadOnly Property CrossPromotionPreferences As CrossPromotionPreferencesType
    Get
public:
property CrossPromotionPreferencesType^ CrossPromotionPreferences {
    CrossPromotionPreferencesType^ get ();
}


DispatchCutoffTimePreference Property

DispatchCutoffTimePreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► DispatchCutoffTimePreference
Gets the returned DispatchCutoffTimePreference of type DispatchCutoffTimePreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public DispatchCutoffTimePreferencesType DispatchCutoffTimePreference { get; }
Public ReadOnly Property DispatchCutoffTimePreference As DispatchCutoffTimePreferencesType
    Get
public:
property DispatchCutoffTimePreferencesType^ DispatchCutoffTimePreference {
    DispatchCutoffTimePreferencesType^ get ();
}


eBayPLUSPreferenceList Property

eBayPLUSPreferenceList Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► eBayPLUSPreferenceList
Gets the returned eBayPLUSPreference of type eBayPLUSPreferenceTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public eBayPLUSPreferenceTypeCollection eBayPLUSPreferenceList { get; }
Public ReadOnly Property eBayPLUSPreferenceList As eBayPLUSPreferenceTypeCollection
    Get
public:
property eBayPLUSPreferenceTypeCollection^ eBayPLUSPreferenceList {
    eBayPLUSPreferenceTypeCollection^ get ();
}


EmailShipmentTrackingNumberPreference Property

EmailShipmentTrackingNumberPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► EmailShipmentTrackingNumberPreference
Gets the returned EmailShipmentTrackingNumberPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailShipmentTrackingNumberPreference { get; }
Public ReadOnly Property EmailShipmentTrackingNumberPreference As Boolean
    Get
public:
property bool EmailShipmentTrackingNumberPreference {
    bool get ();
}


EndOfAuctionEmailPreferences Property

EndOfAuctionEmailPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► EndOfAuctionEmailPreferences
Gets the returned EndOfAuctionEmailPreferences of type EndOfAuctionEmailPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public EndOfAuctionEmailPreferencesType EndOfAuctionEmailPreferences { get; }
Public ReadOnly Property EndOfAuctionEmailPreferences As EndOfAuctionEmailPreferencesType
    Get
public:
property EndOfAuctionEmailPreferencesType^ EndOfAuctionEmailPreferences {
    EndOfAuctionEmailPreferencesType^ get ();
}


GetUserPreferences Method

GetUserPreferences Method
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► GetUserPreferences()()()()
Members
Icon | Member | Description
 | GetUserPreferences(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Retrieves the specified user preferences for the authenticated caller.
 | GetUserPreferences(Boolean, Boolean, Boolean, Boolean, Boolean) | For backward compatibility with old wrappers.
 | GetUserPreferences(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | For backward compatibility with old wrappers.


GetUserPreferences Method (ShowBidderNoticePreferences, ShowCombinedPaymentPreferences, ShowCrossPromotionPreferences, ShowSellerPaymentPreferences, ShowEndOfAuctionEmailPreferences, ShowSellerFavoriteItemPreferences)

GetUserPreferences Method (ShowBidderNoticePreferences, ShowCombinedPaymentPreferences, ShowCrossPromotionPreferences, ShowSellerPaymentPreferences, ShowEndOfAuctionEmailPreferences, ShowSellerFavoriteItemPreferences)
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► GetUserPreferences(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public BidderNoticePreferencesType GetUserPreferences(
    bool ShowBidderNoticePreferences,
    bool ShowCombinedPaymentPreferences,
    bool ShowCrossPromotionPreferences,
    bool ShowSellerPaymentPreferences,
    bool ShowEndOfAuctionEmailPreferences,
    bool ShowSellerFavoriteItemPreferences
)
Public Function GetUserPreferences ( _
    ShowBidderNoticePreferences As Boolean, _
    ShowCombinedPaymentPreferences As Boolean, _
    ShowCrossPromotionPreferences As Boolean, _
    ShowSellerPaymentPreferences As Boolean, _
    ShowEndOfAuctionEmailPreferences As Boolean, _
    ShowSellerFavoriteItemPreferences As Boolean _
) As BidderNoticePreferencesType
public:
BidderNoticePreferencesType^ GetUserPreferences(
    bool ShowBidderNoticePreferences,
    bool ShowCombinedPaymentPreferences,
    bool ShowCrossPromotionPreferences,
    bool ShowSellerPaymentPreferences,
    bool ShowEndOfAuctionEmailPreferences,
    bool ShowSellerFavoriteItemPreferences
)
Parameters
ShowBidderNoticePreferences (Boolean)
ShowCombinedPaymentPreferences (Boolean)
ShowCrossPromotionPreferences (Boolean)
ShowSellerPaymentPreferences (Boolean)
ShowEndOfAuctionEmailPreferences (Boolean)
ShowSellerFavoriteItemPreferences (Boolean)


GetUserPreferences Method (ShowBidderNoticePreferences, ShowCombinedPaymentPreferences, ShowCrossPromotionPreferences, ShowSellerPaymentPreferences, ShowEndOfAuctionEmailPreferences, ShowSellerFavoriteItemPreferences, ShowProStoresPreferences, ShowEmailShipmentTrackingNumberPreference, ShowRequiredS

GetUserPreferences Method (ShowBidderNoticePreferences, ShowCombinedPaymentPreferences, ShowCrossPromotionPreferences, ShowSellerPaymentPreferences, ShowEndOfAuctionEmailPreferences, ShowSellerFavoriteItemPreferences, ShowProStoresPreferences, ShowEmailShipmentTrackingNumberPreference, ShowRequiredShipPhoneNumberPreference, ShowSellerExcludeShipToLocationPreference, ShowUnpaidItemAssistancePreference, ShowPurchaseReminderEmailPreferences, ShowUnpaidItemAssistanceExclusionList, ShowSellerProfilePreferences, ShowSellerReturnPreferences, ShowGlobalShippingProgramPreference, ShowDispatchCutoffTimePreferences, ShowGlobalShippingProgramListingPreference, ShowOverrideGSPServiceWithIntlServicePreference, ShowPickupDropoffPreferences, ShowOutOfStockControlPreference, ShoweBayPLUSPreference)
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► GetUserPreferences(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Retrieves the specified user preferences for the authenticated caller.
Declaration Syntax
C# Visual Basic Visual C++
public BidderNoticePreferencesType GetUserPreferences(
    bool ShowBidderNoticePreferences,
    bool ShowCombinedPaymentPreferences,
    bool ShowCrossPromotionPreferences,
    bool ShowSellerPaymentPreferences,
    bool ShowEndOfAuctionEmailPreferences,
    bool ShowSellerFavoriteItemPreferences,
    bool ShowProStoresPreferences,
    bool ShowEmailShipmentTrackingNumberPreference,
    bool ShowRequiredShipPhoneNumberPreference,
    bool ShowSellerExcludeShipToLocationPreference,
    bool ShowUnpaidItemAssistancePreference,
    bool ShowPurchaseReminderEmailPreferences,
    bool ShowUnpaidItemAssistanceExclusionList,
    bool ShowSellerProfilePreferences,
    bool ShowSellerReturnPreferences,
    bool ShowGlobalShippingProgramPreference,
    bool ShowDispatchCutoffTimePreferences,
    bool ShowGlobalShippingProgramListingPreference,
    bool ShowOverrideGSPServiceWithIntlServicePreference,
    bool ShowPickupDropoffPreferences,
    bool ShowOutOfStockControlPreference,
    bool ShoweBayPLUSPreference
)
Public Function GetUserPreferences ( _
    ShowBidderNoticePreferences As Boolean, _
    ShowCombinedPaymentPreferences As Boolean, _
    ShowCrossPromotionPreferences As Boolean, _
    ShowSellerPaymentPreferences As Boolean, _
    ShowEndOfAuctionEmailPreferences As Boolean, _
    ShowSellerFavoriteItemPreferences As Boolean, _
    ShowProStoresPreferences As Boolean, _
    ShowEmailShipmentTrackingNumberPreference As Boolean, _
    ShowRequiredShipPhoneNumberPreference As Boolean, _
    ShowSellerExcludeShipToLocationPreference As Boolean, _
    ShowUnpaidItemAssistancePreference As Boolean, _
    ShowPurchaseReminderEmailPreferences As Boolean, _
    ShowUnpaidItemAssistanceExclusionList As Boolean, _
    ShowSellerProfilePreferences As Boolean, _
    ShowSellerReturnPreferences As Boolean, _
    ShowGlobalShippingProgramPreference As Boolean, _
    ShowDispatchCutoffTimePreferences As Boolean, _
    ShowGlobalShippingProgramListingPreference As Boolean, _
    ShowOverrideGSPServiceWithIntlServicePreference As Boolean, _
    ShowPickupDropoffPreferences As Boolean, _
    ShowOutOfStockControlPreference As Boolean, _
    ShoweBayPLUSPreference As Boolean _
) As BidderNoticePreferencesType
public:
BidderNoticePreferencesType^ GetUserPreferences(
    bool ShowBidderNoticePreferences,
    bool ShowCombinedPaymentPreferences,
    bool ShowCrossPromotionPreferences,
    bool ShowSellerPaymentPreferences,
    bool ShowEndOfAuctionEmailPreferences,
    bool ShowSellerFavoriteItemPreferences,
    bool ShowProStoresPreferences,
    bool ShowEmailShipmentTrackingNumberPreference,
    bool ShowRequiredShipPhoneNumberPreference,
    bool ShowSellerExcludeShipToLocationPreference,
    bool ShowUnpaidItemAssistancePreference,
    bool ShowPurchaseReminderEmailPreferences,
    bool ShowUnpaidItemAssistanceExclusionList,
    bool ShowSellerProfilePreferences,
    bool ShowSellerReturnPreferences,
    bool ShowGlobalShippingProgramPreference,
    bool ShowDispatchCutoffTimePreferences,
    bool ShowGlobalShippingProgramListingPreference,
    bool ShowOverrideGSPServiceWithIntlServicePreference,
    bool ShowPickupDropoffPreferences,
    bool ShowOutOfStockControlPreference,
    bool ShoweBayPLUSPreference
)
Parameters
ShowBidderNoticePreferences (Boolean)
If included and set to
true
, the seller's preference for receiving contact information for unsuccessful bidders is returned in the response.
ShowCombinedPaymentPreferences (Boolean)
If included and set to
true
, the seller's combined payment preferences are returned in the response. These preferences are used to allow Combined Invoice orders. Note: The CombinedPaymentPreferences.CombinedPaymentOption field is the only preference that should be managed with the GetUserPreferences and SetUserPreferences calls. All other combined payment preferences should be managed with the SetDiscountProfiles and GetDiscountProfiles calls.
ShowCrossPromotionPreferences (Boolean)
This field is deprecated.
ShowSellerPaymentPreferences (Boolean)
If included and set to
true
, the seller's payment preferences are returned in the response.
ShowEndOfAuctionEmailPreferences (Boolean)
If included and set to
true
, the seller's preferences for the end-of-auction email sent to the winning bidder is returned in the response. These preferences are only applicable for auction listings.
ShowSellerFavoriteItemPreferences (Boolean)
If included and set to
true
, the seller's favorite item preferences are returned in the response.
ShowProStoresPreferences (Boolean)
This field is deprecated.
ShowEmailShipmentTrackingNumberPreference (Boolean)
If included and set to
true
, the seller's preference for sending an email to the buyer with the shipping tracking number is returned in the response.
ShowRequiredShipPhoneNumberPreference (Boolean)
If included and set to
true
, the seller's preference for requiring that the buyer supply a shipping phone number upon checkout is returned in the response. Some shipping carriers require the receiver's phone number.
ShowSellerExcludeShipToLocationPreference (Boolean)
If included and set to
true
, all of the seller's excluded shipping locations are returned in the response. The returned list mirrors the seller's current Exclude shipping locations list in My eBay's Shipping Preferences. An excluded shipping location in My eBay can be an entire geographical region (such as Middle East) or only an individual country (such as Iraq). Sellers can override these default settings for an individual listing by using the Item.ShippingDetails.ExcludeShipToLocation field in the AddItem family of calls.
ShowUnpaidItemAssistancePreference (Boolean)
If included and set to
true
, the seller's Unpaid Item Assistant preferences are returned in the response. The Unpaid Item Assistant automatically opens an Unpaid Item dispute on the behalf of the seller. Note: To return the list of buyers excluded from the Unpaid Item Assistant mechanism, the ShowUnpaidItemAssistanceExclusionList field must also be included and set to
true
in the request. Excluded buyers can be viewed in the UnpaidItemAssistancePreferences.ExcludedUser field.
ShowPurchaseReminderEmailPreferences (Boolean)
If included and set to
true
, the seller's preference for sending a purchase reminder email to buyers is returned in the response.
ShowUnpaidItemAssistanceExclusionList (Boolean)
If included and set to
true
, the list of eBay user IDs on the Unpaid Item Assistant Excluded User list is returned through the UnpaidItemAssistancePreferences.ExcludedUser field in the response.

For excluded users, an Unpaid Item dispute is not automatically filed through the UPI Assistance mechanism. The Excluded User list is managed through the SetUserPreferences call. Note: To return the list of buyers excluded from the Unpaid Item Assistant mechanism, the ShowUnpaidItemAssistancePreference field must also be included and set to true in the request.
ShowSellerProfilePreferences (Boolean)
If this flag is included and set to
true
, the seller's Business Policies profile information is returned in the response. This information includes a flag that indicates whether or not the seller has opted into Business Policies, as well as Business Policies profiles (payment, shipping, and return policy) active on the seller's account.
ShowSellerReturnPreferences (Boolean)
If this flag is included and set to
true
, the SellerReturnPreferences container is returned in the response and indicates whether or not the seller has opted in to eBay Managed Returns. eBay Managed Returns are currently only available on the US and UK sites.
ShowGlobalShippingProgramPreference (Boolean)
If this flag is included and set to
true
, the seller's preference for offering the Global Shipping Program to international buyers will be returned in OfferGlobalShippingProgramPreference.
ShowDispatchCutoffTimePreferences (Boolean)
If included and set to
true
, the seller's same day handling cut off time is returned in DispatchCutoffTimePreference.CutoffTime.
ShowGlobalShippingProgramListingPreference (Boolean)
If included and set to
true
, the GlobalShippingProgramListingPreference field is returned. A returned value of
true
indicates that the seller's new listings will enable the Global Shipping Program by default.
ShowOverrideGSPServiceWithIntlServicePreference (Boolean)
If included and set to
true
, the OverrideGSPServiceWithIntlServicePreference field is returned. A returned value of
true
indicates that for the seller's listings that specify an international shipping service for any Global Shipping-eligible country, the specified service will take precedence and be the listing's default international shipping option for buyers in that country, rather than the Global Shipping Program.

A returned value of
false
indicates that the Global Shipping program will take precedence over any international shipping service as the default option in Global Shipping-eligible listings for shipping to any Global Shipping-eligible country.
ShowPickupDropoffPreferences (Boolean)
If included and set to
true
, the PickupDropoffSellerPreference field is returned. A returned value of
true
indicates that the seller's new listings will enable the Click and Collect feature by default.

With the Click and Collect feature, a buyer can purchase certain items on eBay and collect them at a local store. Buyers are notified by eBay once their items are available. The Click and Collect feature is only available to large merchants on the eBay UK (site ID - 3) and eBay Australia (Site ID - 15) sites.
ShowOutOfStockControlPreference (Boolean)
If included and set to
true
, the seller's preferences related to the Out-of-Stock feature will be returned. This feature is set using the SetUserPreferences call.
ShoweBayPLUSPreference (Boolean)
To determine whether a seller can offer eBay Plus in qualified listings, include this field and set it to
true
.

eBay Plus is a premium account option for buyers, which provides benefits such as fast free domestic shipping and free returns on selected items. Top Rated eBay sellers must opt in to eBay Plus, and can offer the program on a per-listing basis.

The eBayPLUSPreference container is returned in the response with information about each country where the seller is eligible to offer eBay Plus on listings (one eBayPLUSPreference container per country), as well as the seller's opt-in status and listing preference for each country.

Note: Currently, eBay Plus is available only to buyers in Germany (DE).


GetUserPreferences Method (ShowBidderNoticePreferences, ShowCombinedPaymentPreferences, ShowCrossPromotionPreferences, ShowSellerPaymentPreferences, ShowSellerFavoriteItemPreferences)

GetUserPreferences Method (ShowBidderNoticePreferences, ShowCombinedPaymentPreferences, ShowCrossPromotionPreferences, ShowSellerPaymentPreferences, ShowSellerFavoriteItemPreferences)
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► GetUserPreferences(Boolean, Boolean, Boolean, Boolean, Boolean)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void GetUserPreferences(
    bool ShowBidderNoticePreferences,
    bool ShowCombinedPaymentPreferences,
    bool ShowCrossPromotionPreferences,
    bool ShowSellerPaymentPreferences,
    bool ShowSellerFavoriteItemPreferences
)
Public Sub GetUserPreferences ( _
    ShowBidderNoticePreferences As Boolean, _
    ShowCombinedPaymentPreferences As Boolean, _
    ShowCrossPromotionPreferences As Boolean, _
    ShowSellerPaymentPreferences As Boolean, _
    ShowSellerFavoriteItemPreferences As Boolean _
)
public:
void GetUserPreferences(
    bool ShowBidderNoticePreferences,
    bool ShowCombinedPaymentPreferences,
    bool ShowCrossPromotionPreferences,
    bool ShowSellerPaymentPreferences,
    bool ShowSellerFavoriteItemPreferences
)
Parameters
ShowBidderNoticePreferences (Boolean)
ShowCombinedPaymentPreferences (Boolean)
ShowCrossPromotionPreferences (Boolean)
ShowSellerPaymentPreferences (Boolean)
ShowSellerFavoriteItemPreferences (Boolean)


GetUserPreferencesCall Constructor

GetUserPreferencesCall Constructor
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► GetUserPreferencesCall()()()()
Members
Icon | Member | Description
 | GetUserPreferencesCall()()()() |
 | GetUserPreferencesCall(ApiContext) |


GetUserPreferencesCall Constructor

GetUserPreferencesCall Constructor
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► GetUserPreferencesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserPreferencesCall()
Public Sub New
public:
GetUserPreferencesCall()


GetUserPreferencesCall Constructor (ApiContext)

GetUserPreferencesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► GetUserPreferencesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetUserPreferencesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetUserPreferencesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


GlobalShippingProgramListingPreference Property

GlobalShippingProgramListingPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► GlobalShippingProgramListingPreference
Gets the returned GlobalShippingProgramListingPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShippingProgramListingPreference { get; }
Public ReadOnly Property GlobalShippingProgramListingPreference As Boolean
    Get
public:
property bool GlobalShippingProgramListingPreference {
    bool get ();
}


OfferGlobalShippingProgramPreference Property

OfferGlobalShippingProgramPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► OfferGlobalShippingProgramPreference
Gets the returned OfferGlobalShippingProgramPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool OfferGlobalShippingProgramPreference { get; }
Public ReadOnly Property OfferGlobalShippingProgramPreference As Boolean
    Get
public:
property bool OfferGlobalShippingProgramPreference {
    bool get ();
}


OutOfStockControlPreference Property

OutOfStockControlPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► OutOfStockControlPreference
Gets the returned OutOfStockControlPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool OutOfStockControlPreference { get; }
Public ReadOnly Property OutOfStockControlPreference As Boolean
    Get
public:
property bool OutOfStockControlPreference {
    bool get ();
}


OverrideGSPServiceWithIntlServicePreference Property

OverrideGSPServiceWithIntlServicePreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► OverrideGSPServiceWithIntlServicePreference
Gets the returned OverrideGSPServiceWithIntlServicePreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool OverrideGSPServiceWithIntlServicePreference { get; }
Public ReadOnly Property OverrideGSPServiceWithIntlServicePreference As Boolean
    Get
public:
property bool OverrideGSPServiceWithIntlServicePreference {
    bool get ();
}


PickupDropoffSellerPreference Property

PickupDropoffSellerPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► PickupDropoffSellerPreference
Gets the returned PickupDropoffSellerPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool PickupDropoffSellerPreference { get; }
Public ReadOnly Property PickupDropoffSellerPreference As Boolean
    Get
public:
property bool PickupDropoffSellerPreference {
    bool get ();
}


ProStoresPreference Property

ProStoresPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ProStoresPreference
Gets the returned ProStoresPreference of type ProStoresCheckoutPreferenceType.
Declaration Syntax
C# Visual Basic Visual C++
public ProStoresCheckoutPreferenceType ProStoresPreference { get; }
Public ReadOnly Property ProStoresPreference As ProStoresCheckoutPreferenceType
    Get
public:
property ProStoresCheckoutPreferenceType^ ProStoresPreference {
    ProStoresCheckoutPreferenceType^ get ();
}


PurchaseReminderEmailPreferences Property

PurchaseReminderEmailPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► PurchaseReminderEmailPreferences
Gets the returned PurchaseReminderEmailPreferences of type PurchaseReminderEmailPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public PurchaseReminderEmailPreferencesType PurchaseReminderEmailPreferences { get; }
Public ReadOnly Property PurchaseReminderEmailPreferences As PurchaseReminderEmailPreferencesType
    Get
public:
property PurchaseReminderEmailPreferencesType^ PurchaseReminderEmailPreferences {
    PurchaseReminderEmailPreferencesType^ get ();
}


RequiredShipPhoneNumberPreference Property

RequiredShipPhoneNumberPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► RequiredShipPhoneNumberPreference
Gets the returned RequiredShipPhoneNumberPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool RequiredShipPhoneNumberPreference { get; }
Public ReadOnly Property RequiredShipPhoneNumberPreference As Boolean
    Get
public:
property bool RequiredShipPhoneNumberPreference {
    bool get ();
}


SellerExcludeShipToLocationPreferences Property

SellerExcludeShipToLocationPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► SellerExcludeShipToLocationPreferences
Gets the returned SellerExcludeShipToLocationPreferences of type SellerExcludeShipToLocationPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public SellerExcludeShipToLocationPreferencesType SellerExcludeShipToLocationPreferences { get; }
Public ReadOnly Property SellerExcludeShipToLocationPreferences As SellerExcludeShipToLocationPreferencesType
    Get
public:
property SellerExcludeShipToLocationPreferencesType^ SellerExcludeShipToLocationPreferences {
    SellerExcludeShipToLocationPreferencesType^ get ();
}


SellerFavoriteItemPreferences Property

SellerFavoriteItemPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► SellerFavoriteItemPreferences
Gets the returned SellerFavoriteItemPreferences of type SellerFavoriteItemPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public SellerFavoriteItemPreferencesType SellerFavoriteItemPreferences { get; }
Public ReadOnly Property SellerFavoriteItemPreferences As SellerFavoriteItemPreferencesType
    Get
public:
property SellerFavoriteItemPreferencesType^ SellerFavoriteItemPreferences {
    SellerFavoriteItemPreferencesType^ get ();
}


SellerPaymentPreferences Property

SellerPaymentPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► SellerPaymentPreferences
Gets the returned SellerPaymentPreferences of type SellerPaymentPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentPreferencesType SellerPaymentPreferences { get; }
Public ReadOnly Property SellerPaymentPreferences As SellerPaymentPreferencesType
    Get
public:
property SellerPaymentPreferencesType^ SellerPaymentPreferences {
    SellerPaymentPreferencesType^ get ();
}


SellerProfilePreferences Property

SellerProfilePreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► SellerProfilePreferences
Gets the returned SellerProfilePreferences of type SellerProfilePreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public SellerProfilePreferencesType SellerProfilePreferences { get; }
Public ReadOnly Property SellerProfilePreferences As SellerProfilePreferencesType
    Get
public:
property SellerProfilePreferencesType^ SellerProfilePreferences {
    SellerProfilePreferencesType^ get ();
}


SellerReturnPreferences Property

SellerReturnPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► SellerReturnPreferences
Gets the returned SellerReturnPreferences of type SellerReturnPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public SellerReturnPreferencesType SellerReturnPreferences { get; }
Public ReadOnly Property SellerReturnPreferences As SellerReturnPreferencesType
    Get
public:
property SellerReturnPreferencesType^ SellerReturnPreferences {
    SellerReturnPreferencesType^ get ();
}


SellerThirdPartyCheckoutDisabled Property

SellerThirdPartyCheckoutDisabled Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► SellerThirdPartyCheckoutDisabled
Gets the returned SellerThirdPartyCheckoutDisabled of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerThirdPartyCheckoutDisabled { get; }
Public ReadOnly Property SellerThirdPartyCheckoutDisabled As Boolean
    Get
public:
property bool SellerThirdPartyCheckoutDisabled {
    bool get ();
}


ShowBidderNoticePreferences Property

ShowBidderNoticePreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowBidderNoticePreferences
Gets or sets the ShowBidderNoticePreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowBidderNoticePreferences { get; set; }
Public Property ShowBidderNoticePreferences As Boolean
    Get
    Set
public:
property bool ShowBidderNoticePreferences {
    bool get ();
    void set (bool value);
}


ShowCombinedPaymentPreferences Property

ShowCombinedPaymentPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowCombinedPaymentPreferences
Gets or sets the ShowCombinedPaymentPreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowCombinedPaymentPreferences { get; set; }
Public Property ShowCombinedPaymentPreferences As Boolean
    Get
    Set
public:
property bool ShowCombinedPaymentPreferences {
    bool get ();
    void set (bool value);
}


ShowCrossPromotionPreferences Property

ShowCrossPromotionPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowCrossPromotionPreferences
Gets or sets the ShowCrossPromotionPreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowCrossPromotionPreferences { get; set; }
Public Property ShowCrossPromotionPreferences As Boolean
    Get
    Set
public:
property bool ShowCrossPromotionPreferences {
    bool get ();
    void set (bool value);
}


ShowDispatchCutoffTimePreferences Property

ShowDispatchCutoffTimePreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowDispatchCutoffTimePreferences
Gets or sets the ShowDispatchCutoffTimePreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowDispatchCutoffTimePreferences { get; set; }
Public Property ShowDispatchCutoffTimePreferences As Boolean
    Get
    Set
public:
property bool ShowDispatchCutoffTimePreferences {
    bool get ();
    void set (bool value);
}


ShoweBayPLUSPreference Property

ShoweBayPLUSPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShoweBayPLUSPreference
Gets or sets the ShoweBayPLUSPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShoweBayPLUSPreference { get; set; }
Public Property ShoweBayPLUSPreference As Boolean
    Get
    Set
public:
property bool ShoweBayPLUSPreference {
    bool get ();
    void set (bool value);
}


ShowEmailShipmentTrackingNumberPreference Property

ShowEmailShipmentTrackingNumberPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowEmailShipmentTrackingNumberPreference
Gets or sets the ShowEmailShipmentTrackingNumberPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowEmailShipmentTrackingNumberPreference { get; set; }
Public Property ShowEmailShipmentTrackingNumberPreference As Boolean
    Get
    Set
public:
property bool ShowEmailShipmentTrackingNumberPreference {
    bool get ();
    void set (bool value);
}


ShowEndOfAuctionEmailPreferences Property

ShowEndOfAuctionEmailPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowEndOfAuctionEmailPreferences
Gets or sets the ShowEndOfAuctionEmailPreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowEndOfAuctionEmailPreferences { get; set; }
Public Property ShowEndOfAuctionEmailPreferences As Boolean
    Get
    Set
public:
property bool ShowEndOfAuctionEmailPreferences {
    bool get ();
    void set (bool value);
}


ShowGlobalShippingProgramListingPreference Property

ShowGlobalShippingProgramListingPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowGlobalShippingProgramListingPreference
Gets or sets the ShowGlobalShippingProgramListingPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowGlobalShippingProgramListingPreference { get; set; }
Public Property ShowGlobalShippingProgramListingPreference As Boolean
    Get
    Set
public:
property bool ShowGlobalShippingProgramListingPreference {
    bool get ();
    void set (bool value);
}


ShowGlobalShippingProgramPreference Property

ShowGlobalShippingProgramPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowGlobalShippingProgramPreference
Gets or sets the ShowGlobalShippingProgramPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowGlobalShippingProgramPreference { get; set; }
Public Property ShowGlobalShippingProgramPreference As Boolean
    Get
    Set
public:
property bool ShowGlobalShippingProgramPreference {
    bool get ();
    void set (bool value);
}


ShowOutOfStockControlPreference Property

ShowOutOfStockControlPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowOutOfStockControlPreference
Gets or sets the ShowOutOfStockControlPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowOutOfStockControlPreference { get; set; }
Public Property ShowOutOfStockControlPreference As Boolean
    Get
    Set
public:
property bool ShowOutOfStockControlPreference {
    bool get ();
    void set (bool value);
}


ShowOverrideGSPServiceWithIntlServicePreference Property

ShowOverrideGSPServiceWithIntlServicePreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowOverrideGSPServiceWithIntlServicePreference
Gets or sets the ShowOverrideGSPServiceWithIntlServicePreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowOverrideGSPServiceWithIntlServicePreference { get; set; }
Public Property ShowOverrideGSPServiceWithIntlServicePreference As Boolean
    Get
    Set
public:
property bool ShowOverrideGSPServiceWithIntlServicePreference {
    bool get ();
    void set (bool value);
}


ShowPickupDropoffPreferences Property

ShowPickupDropoffPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowPickupDropoffPreferences
Gets or sets the ShowPickupDropoffPreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowPickupDropoffPreferences { get; set; }
Public Property ShowPickupDropoffPreferences As Boolean
    Get
    Set
public:
property bool ShowPickupDropoffPreferences {
    bool get ();
    void set (bool value);
}


ShowProStoresPreferences Property

ShowProStoresPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowProStoresPreferences
Gets or sets the ShowProStoresPreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowProStoresPreferences { get; set; }
Public Property ShowProStoresPreferences As Boolean
    Get
    Set
public:
property bool ShowProStoresPreferences {
    bool get ();
    void set (bool value);
}


ShowPurchaseReminderEmailPreferences Property

ShowPurchaseReminderEmailPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowPurchaseReminderEmailPreferences
Gets or sets the ShowPurchaseReminderEmailPreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowPurchaseReminderEmailPreferences { get; set; }
Public Property ShowPurchaseReminderEmailPreferences As Boolean
    Get
    Set
public:
property bool ShowPurchaseReminderEmailPreferences {
    bool get ();
    void set (bool value);
}


ShowRequiredShipPhoneNumberPreference Property

ShowRequiredShipPhoneNumberPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowRequiredShipPhoneNumberPreference
Gets or sets the ShowRequiredShipPhoneNumberPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowRequiredShipPhoneNumberPreference { get; set; }
Public Property ShowRequiredShipPhoneNumberPreference As Boolean
    Get
    Set
public:
property bool ShowRequiredShipPhoneNumberPreference {
    bool get ();
    void set (bool value);
}


ShowSellerExcludeShipToLocationPreference Property

ShowSellerExcludeShipToLocationPreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowSellerExcludeShipToLocationPreference
Gets or sets the ShowSellerExcludeShipToLocationPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerExcludeShipToLocationPreference { get; set; }
Public Property ShowSellerExcludeShipToLocationPreference As Boolean
    Get
    Set
public:
property bool ShowSellerExcludeShipToLocationPreference {
    bool get ();
    void set (bool value);
}


ShowSellerFavoriteItemPreferences Property

ShowSellerFavoriteItemPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowSellerFavoriteItemPreferences
Gets or sets the ShowSellerFavoriteItemPreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerFavoriteItemPreferences { get; set; }
Public Property ShowSellerFavoriteItemPreferences As Boolean
    Get
    Set
public:
property bool ShowSellerFavoriteItemPreferences {
    bool get ();
    void set (bool value);
}


ShowSellerPaymentPreferences Property

ShowSellerPaymentPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowSellerPaymentPreferences
Gets or sets the ShowSellerPaymentPreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerPaymentPreferences { get; set; }
Public Property ShowSellerPaymentPreferences As Boolean
    Get
    Set
public:
property bool ShowSellerPaymentPreferences {
    bool get ();
    void set (bool value);
}


ShowSellerProfilePreferences Property

ShowSellerProfilePreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowSellerProfilePreferences
Gets or sets the ShowSellerProfilePreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerProfilePreferences { get; set; }
Public Property ShowSellerProfilePreferences As Boolean
    Get
    Set
public:
property bool ShowSellerProfilePreferences {
    bool get ();
    void set (bool value);
}


ShowSellerReturnPreferences Property

ShowSellerReturnPreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowSellerReturnPreferences
Gets or sets the ShowSellerReturnPreferences of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerReturnPreferences { get; set; }
Public Property ShowSellerReturnPreferences As Boolean
    Get
    Set
public:
property bool ShowSellerReturnPreferences {
    bool get ();
    void set (bool value);
}


ShowUnpaidItemAssistanceExclusionList Property

ShowUnpaidItemAssistanceExclusionList Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowUnpaidItemAssistanceExclusionList
Gets or sets the ShowUnpaidItemAssistanceExclusionList of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowUnpaidItemAssistanceExclusionList { get; set; }
Public Property ShowUnpaidItemAssistanceExclusionList As Boolean
    Get
    Set
public:
property bool ShowUnpaidItemAssistanceExclusionList {
    bool get ();
    void set (bool value);
}


ShowUnpaidItemAssistancePreference Property

ShowUnpaidItemAssistancePreference Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► ShowUnpaidItemAssistancePreference
Gets or sets the ShowUnpaidItemAssistancePreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowUnpaidItemAssistancePreference { get; set; }
Public Property ShowUnpaidItemAssistancePreference As Boolean
    Get
    Set
public:
property bool ShowUnpaidItemAssistancePreference {
    bool get ();
    void set (bool value);
}


UnpaidItemAssistancePreferences Property

UnpaidItemAssistancePreferences Property
Namespaces ► eBay.Service.Call ► GetUserPreferencesCall ► UnpaidItemAssistancePreferences
Gets the returned UnpaidItemAssistancePreferences of type UnpaidItemAssistancePreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public UnpaidItemAssistancePreferencesType UnpaidItemAssistancePreferences { get; }
Public ReadOnly Property UnpaidItemAssistancePreferences As UnpaidItemAssistancePreferencesType
    Get
public:
property UnpaidItemAssistancePreferencesType^ UnpaidItemAssistancePreferences {
    UnpaidItemAssistancePreferencesType^ get ();
}


GetVeROReasonCodeDetailsCall Class

GetVeROReasonCodeDetailsCall Class
Namespaces ► eBay.Service.Call ► GetVeROReasonCodeDetailsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetVeROReasonCodeDetailsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetVeROReasonCodeDetailsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetVeROReasonCodeDetailsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetVeROReasonCodeDetailsCall()()()() |
 | GetVeROReasonCodeDetailsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetVeROReasonCodeDetailsRequestType for this API call.
 | ApiResponse | Gets the GetVeROReasonCodeDetailsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | GetVeROReasonCodeDetails(Int64, Boolean) | Retrieves details for VeRO reason codes and their descriptions. You can specify a reason code ID to get details for a specific reason on the site specified in the request header. If ReasonCodeID is not passed in the request, all reason codes are returned. Set ReturnAllSites to true to retrieve reason codes for all sites. You must be a member of the Verified Rights Owner (VeRO) Program to use this call.
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ReasonCodeID | Gets or sets the ReasonCodeID of type Int64.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReturnAllSites | Gets or sets the ReturnAllSites of type Boolean.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | VeROReasonCodeDetailList | Gets the returned VeROReasonCodeDetails of type VeROSiteDetailTypeCollection.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetVeROReasonCodeDetailsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetVeROReasonCodeDetailsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetVeROReasonCodeDetailsCall ► ApiRequest
Gets or sets the GetVeROReasonCodeDetailsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReasonCodeDetailsRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetVeROReasonCodeDetailsRequestType
    Get
    Set
public:
property GetVeROReasonCodeDetailsRequestType^ ApiRequest {
    GetVeROReasonCodeDetailsRequestType^ get ();
    void set (GetVeROReasonCodeDetailsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetVeROReasonCodeDetailsCall ► ApiResponse
Gets the GetVeROReasonCodeDetailsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReasonCodeDetailsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetVeROReasonCodeDetailsResponseType
    Get
public:
property GetVeROReasonCodeDetailsResponseType^ ApiResponse {
    GetVeROReasonCodeDetailsResponseType^ get ();
}


GetVeROReasonCodeDetails Method (ReasonCodeID, ReturnAllSites)

GetVeROReasonCodeDetails Method (ReasonCodeID, ReturnAllSites)
Namespaces ► eBay.Service.Call ► GetVeROReasonCodeDetailsCall ► GetVeROReasonCodeDetails(Int64, Boolean)
Retrieves details for VeRO reason codes and their descriptions. You can specify a reason code ID to get details for a specific reason on the site specified in the request header. If ReasonCodeID is not passed in the request, all reason codes are returned. Set ReturnAllSites to true to retrieve reason codes for all sites. You must be a member of the Verified Rights Owner (VeRO) Program to use this call.
Declaration Syntax
C# Visual Basic Visual C++
public VeROSiteDetailTypeCollection GetVeROReasonCodeDetails(
    long ReasonCodeID,
    bool ReturnAllSites
)
Public Function GetVeROReasonCodeDetails ( _
    ReasonCodeID As Long, _
    ReturnAllSites As Boolean _
) As VeROSiteDetailTypeCollection
public:
VeROSiteDetailTypeCollection^ GetVeROReasonCodeDetails(
    long long ReasonCodeID,
    bool ReturnAllSites
)
Parameters
ReasonCodeID (Int64)
Unique identifier for a reason code. If this ReasonCodeID is passed then only details of this ReasonCodeID will be returned. If no reason code is specified, all reason codes are returned.
ReturnAllSites (Boolean)
Set to true to retrieve reason codes for all sites. If not specified, reason codes are returned for the site specified in the request header only. If ReasonCodeID is specified, this parameter is ignored.


GetVeROReasonCodeDetailsCall Constructor

GetVeROReasonCodeDetailsCall Constructor
Namespaces ► eBay.Service.Call ► GetVeROReasonCodeDetailsCall ► GetVeROReasonCodeDetailsCall()()()()
Members
Icon | Member | Description
 | GetVeROReasonCodeDetailsCall()()()() |
 | GetVeROReasonCodeDetailsCall(ApiContext) |


GetVeROReasonCodeDetailsCall Constructor

GetVeROReasonCodeDetailsCall Constructor
Namespaces ► eBay.Service.Call ► GetVeROReasonCodeDetailsCall ► GetVeROReasonCodeDetailsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReasonCodeDetailsCall()
Public Sub New
public:
GetVeROReasonCodeDetailsCall()


GetVeROReasonCodeDetailsCall Constructor (ApiContext)

GetVeROReasonCodeDetailsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetVeROReasonCodeDetailsCall ► GetVeROReasonCodeDetailsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReasonCodeDetailsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetVeROReasonCodeDetailsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ReasonCodeID Property

ReasonCodeID Property
Namespaces ► eBay.Service.Call ► GetVeROReasonCodeDetailsCall ► ReasonCodeID
Gets or sets the ReasonCodeID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long ReasonCodeID { get; set; }
Public Property ReasonCodeID As Long
    Get
    Set
public:
property long long ReasonCodeID {
    long long get ();
    void set (long long value);
}


ReturnAllSites Property

ReturnAllSites Property
Namespaces ► eBay.Service.Call ► GetVeROReasonCodeDetailsCall ► ReturnAllSites
Gets or sets the ReturnAllSites of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnAllSites { get; set; }
Public Property ReturnAllSites As Boolean
    Get
    Set
public:
property bool ReturnAllSites {
    bool get ();
    void set (bool value);
}


VeROReasonCodeDetailList Property

VeROReasonCodeDetailList Property
Namespaces ► eBay.Service.Call ► GetVeROReasonCodeDetailsCall ► VeROReasonCodeDetailList
Gets the returned VeROReasonCodeDetails of type VeROSiteDetailTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public VeROSiteDetailTypeCollection VeROReasonCodeDetailList { get; }
Public ReadOnly Property VeROReasonCodeDetailList As VeROSiteDetailTypeCollection
    Get
public:
property VeROSiteDetailTypeCollection^ VeROReasonCodeDetailList {
    VeROSiteDetailTypeCollection^ get ();
}


GetVeROReportStatusCall Class

GetVeROReportStatusCall Class
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class GetVeROReportStatusCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class GetVeROReportStatusCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class GetVeROReportStatusCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetVeROReportStatusCall()()()() |
 | GetVeROReportStatusCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the GetVeROReportStatusRequestType for this API call.
 | ApiResponse | Gets the GetVeROReportStatusResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | GetVeROReportStatus(Int64, String, Boolean, DateTime, DateTime, PaginationType) | Retrieves status information about VeRO reported items you have submitted. You can receive the status of individual items you have reported or, by specifying VeROReportPacketID, you can retrieve status for all items reported with a given VeROReportItems request. You can also retrieve items that were reported during a given time period. If no input parameters are specified, status is returned on all items you have reported in the last two years. You must be a member of the Verified Rights Owner (VeRO) Program to use this call.
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasMoreItems | Gets the returned HasMoreItems of type Boolean.
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeReportedItemDetails | Gets or sets the IncludeReportedItemDetails of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | ItemsPerPage | Gets the returned ItemsPerPage of type Int32.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PageNumber | Gets the returned PageNumber of type Int32.
 | Pagination | Gets or sets the Pagination of type PaginationType.
 | PaginationResult | Gets the returned PaginationResult of type PaginationResultType.
 | ReportedItemDetailList | Gets the returned ReportedItemDetails of type VeROReportedItemTypeCollection.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | TimeFrom | Gets or sets the TimeFrom of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | TimeTo | Gets or sets the TimeTo of type DateTime.
 | ToString()()()() | (Inherited from Object.)
 | VeROReportPacketID | Gets or sets the VeROReportPacketID of type Int64.
 | VeROReportPacketIDReturn | Gets the returned VeROReportPacketID of type Int64.
 | VeROReportPacketStatus | Gets the returned VeROReportPacketStatus of type VeROReportPacketStatusCodeType.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | GetVeROReportStatusCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► ApiRequest
Gets or sets the GetVeROReportStatusRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReportStatusRequestType ApiRequest { get; set; }
Public Property ApiRequest As GetVeROReportStatusRequestType
    Get
    Set
public:
property GetVeROReportStatusRequestType^ ApiRequest {
    GetVeROReportStatusRequestType^ get ();
    void set (GetVeROReportStatusRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► ApiResponse
Gets the GetVeROReportStatusResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReportStatusResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As GetVeROReportStatusResponseType
    Get
public:
property GetVeROReportStatusResponseType^ ApiResponse {
    GetVeROReportStatusResponseType^ get ();
}


GetVeROReportStatus Method (VeROReportPacketID, ItemID, IncludeReportedItemDetails, TimeFrom, TimeTo, Pagination)

GetVeROReportStatus Method (VeROReportPacketID, ItemID, IncludeReportedItemDetails, TimeFrom, TimeTo, Pagination)
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► GetVeROReportStatus(Int64, String, Boolean, DateTime, DateTime, PaginationType)
Retrieves status information about VeRO reported items you have submitted. You can receive the status of individual items you have reported or, by specifying VeROReportPacketID, you can retrieve status for all items reported with a given VeROReportItems request. You can also retrieve items that were reported during a given time period. If no input parameters are specified, status is returned on all items you have reported in the last two years. You must be a member of the Verified Rights Owner (VeRO) Program to use this call.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType GetVeROReportStatus(
    long VeROReportPacketID,
    string ItemID,
    bool IncludeReportedItemDetails,
    DateTime TimeFrom,
    DateTime TimeTo,
    PaginationType Pagination
)
Public Function GetVeROReportStatus ( _
    VeROReportPacketID As Long, _
    ItemID As String, _
    IncludeReportedItemDetails As Boolean, _
    TimeFrom As DateTime, _
    TimeTo As DateTime, _
    Pagination As PaginationType _
) As PaginationResultType
public:
PaginationResultType^ GetVeROReportStatus(
    long long VeROReportPacketID,
    String^ ItemID,
    bool IncludeReportedItemDetails,
    DateTime TimeFrom,
    DateTime TimeTo,
    PaginationType^ Pagination
)
Parameters
VeROReportPacketID (Int64)
Packet identifier associated with the reported items for which you want to retrieve status. By default, reported item details are not returned when you specify the packet ID in the request. Applies only to items reported with VeROReportItems.
ItemID (String)
Item ID for an item reported for alleged infringement. Applies to items reported with VeROReportItems or by other means (e.g., through the web flow).
IncludeReportedItemDetails (Boolean)
Set to true to return reported item details when you specify VeROReportPacketID in the request.
TimeFrom (DateTime)
Limits returned items to only those that were submitted on or after the date-time specified. If specified, TimeTo must also be specified. Express the date-time in the format YYYY-MM-DD HH:MM:SS, and in GMT. (For information on how to convert between your local time zone and GMT, see Time Values Note.) Applies to items reported with VeROReportItems or by other means (e.g., through the web flow). Infringement reporting data is maintained for two years after the date of submission. This field is ignored if VeROReportPacketID or ItemID is specified.
TimeTo (DateTime)
Limits returned items to only those that were submitted on or before the date-time specified. If specified, TimeFrom must also be specified. Express date-time in the format YYYY-MM-DD HH:MM:SS, and in GMT. (For information on how to convert between your local time zone and GMT, see Time Values Note.) Applies to items reported with VeROReportItems or by other means (e.g., through the web flow). Infringement reporting data is maintained for two years after the date of submission. This field is ignored if VeROReportPacketID or ItemID is specified.
Pagination (PaginationType)
Contains the data controlling the pagination of the returned values: how many items are returned per page of data (per call) and the number of the page to return with the current call.


GetVeROReportStatusCall Constructor

GetVeROReportStatusCall Constructor
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► GetVeROReportStatusCall()()()()
Members
Icon | Member | Description
 | GetVeROReportStatusCall()()()() |
 | GetVeROReportStatusCall(ApiContext) |


GetVeROReportStatusCall Constructor

GetVeROReportStatusCall Constructor
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► GetVeROReportStatusCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReportStatusCall()
Public Sub New
public:
GetVeROReportStatusCall()


GetVeROReportStatusCall Constructor (ApiContext)

GetVeROReportStatusCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► GetVeROReportStatusCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReportStatusCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetVeROReportStatusCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


HasMoreItems Property

HasMoreItems Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► HasMoreItems
Gets the returned HasMoreItems of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreItems { get; }
Public ReadOnly Property HasMoreItems As Boolean
    Get
public:
property bool HasMoreItems {
    bool get ();
}


IncludeReportedItemDetails Property

IncludeReportedItemDetails Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► IncludeReportedItemDetails
Gets or sets the IncludeReportedItemDetails of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeReportedItemDetails { get; set; }
Public Property IncludeReportedItemDetails As Boolean
    Get
    Set
public:
property bool IncludeReportedItemDetails {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ItemsPerPage Property

ItemsPerPage Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► ItemsPerPage
Gets the returned ItemsPerPage of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int ItemsPerPage { get; }
Public ReadOnly Property ItemsPerPage As Integer
    Get
public:
property int ItemsPerPage {
    int get ();
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► PageNumber
Gets the returned PageNumber of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
public:
property int PageNumber {
    int get ();
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► Pagination
Gets or sets the Pagination of type PaginationType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► PaginationResult
Gets the returned PaginationResult of type PaginationResultType.
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; }
Public ReadOnly Property PaginationResult As PaginationResultType
    Get
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
}


ReportedItemDetailList Property

ReportedItemDetailList Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► ReportedItemDetailList
Gets the returned ReportedItemDetails of type VeROReportedItemTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportedItemTypeCollection ReportedItemDetailList { get; }
Public ReadOnly Property ReportedItemDetailList As VeROReportedItemTypeCollection
    Get
public:
property VeROReportedItemTypeCollection^ ReportedItemDetailList {
    VeROReportedItemTypeCollection^ get ();
}


TimeFrom Property

TimeFrom Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► TimeFrom
Gets or sets the TimeFrom of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeFrom { get; set; }
Public Property TimeFrom As DateTime
    Get
    Set
public:
property DateTime TimeFrom {
    DateTime get ();
    void set (DateTime value);
}


TimeTo Property

TimeTo Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► TimeTo
Gets or sets the TimeTo of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeTo { get; set; }
Public Property TimeTo As DateTime
    Get
    Set
public:
property DateTime TimeTo {
    DateTime get ();
    void set (DateTime value);
}


VeROReportPacketID Property

VeROReportPacketID Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► VeROReportPacketID
Gets or sets the VeROReportPacketID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long VeROReportPacketID { get; set; }
Public Property VeROReportPacketID As Long
    Get
    Set
public:
property long long VeROReportPacketID {
    long long get ();
    void set (long long value);
}


VeROReportPacketIDReturn Property

VeROReportPacketIDReturn Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► VeROReportPacketIDReturn
Gets the returned VeROReportPacketID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long VeROReportPacketIDReturn { get; }
Public ReadOnly Property VeROReportPacketIDReturn As Long
    Get
public:
property long long VeROReportPacketIDReturn {
    long long get ();
}


VeROReportPacketStatus Property

VeROReportPacketStatus Property
Namespaces ► eBay.Service.Call ► GetVeROReportStatusCall ► VeROReportPacketStatus
Gets the returned VeROReportPacketStatus of type VeROReportPacketStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportPacketStatusCodeType VeROReportPacketStatus { get; }
Public ReadOnly Property VeROReportPacketStatus As VeROReportPacketStatusCodeType
    Get
public:
property VeROReportPacketStatusCodeType VeROReportPacketStatus {
    VeROReportPacketStatusCodeType get ();
}


IssueRefundCall Class

IssueRefundCall Class
Namespaces ► eBay.Service.Call ► IssueRefundCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class IssueRefundCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class IssueRefundCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class IssueRefundCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IssueRefundCall()()()() |
 | IssueRefundCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the IssueRefundRequestType for this API call.
 | ApiResponse | Gets the IssueRefundResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | IssueRefund(String, String, RefundReasonCodeType, RefundTypeCodeType, AmountType, String, String) |
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | RefundAmount | Gets or sets the RefundAmount of type AmountType.
 | RefundFromSeller | Gets the returned RefundFromSeller of type AmountType.
 | RefundMessage | Gets or sets the RefundMessage of type String.
 | RefundReason | Gets or sets the RefundReason of type RefundReasonCodeType.
 | RefundType | Gets or sets the RefundType of type RefundTypeCodeType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TotalRefundToBuyer | Gets the returned TotalRefundToBuyer of type AmountType.
 | TransactionID | Gets or sets the TransactionID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | IssueRefundCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► ApiRequest
Gets or sets the IssueRefundRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public IssueRefundRequestType ApiRequest { get; set; }
Public Property ApiRequest As IssueRefundRequestType
    Get
    Set
public:
property IssueRefundRequestType^ ApiRequest {
    IssueRefundRequestType^ get ();
    void set (IssueRefundRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► ApiResponse
Gets the IssueRefundResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public IssueRefundResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As IssueRefundResponseType
    Get
public:
property IssueRefundResponseType^ ApiResponse {
    IssueRefundResponseType^ get ();
}


IssueRefund Method (ItemID, TransactionID, RefundReason, RefundType, RefundAmount, RefundMessage, OrderLineItemID)

IssueRefund Method (ItemID, TransactionID, RefundReason, RefundType, RefundAmount, RefundMessage, OrderLineItemID)
Namespaces ► eBay.Service.Call ► IssueRefundCall ► IssueRefund(String, String, RefundReasonCodeType, RefundTypeCodeType, AmountType, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public AmountType IssueRefund(
    string ItemID,
    string TransactionID,
    RefundReasonCodeType RefundReason,
    RefundTypeCodeType RefundType,
    AmountType RefundAmount,
    string RefundMessage,
    string OrderLineItemID
)
Public Function IssueRefund ( _
    ItemID As String, _
    TransactionID As String, _
    RefundReason As RefundReasonCodeType, _
    RefundType As RefundTypeCodeType, _
    RefundAmount As AmountType, _
    RefundMessage As String, _
    OrderLineItemID As String _
) As AmountType
public:
AmountType^ IssueRefund(
    String^ ItemID,
    String^ TransactionID,
    RefundReasonCodeType RefundReason,
    RefundTypeCodeType RefundType,
    AmountType^ RefundAmount,
    String^ RefundMessage,
    String^ OrderLineItemID
)
Parameters
ItemID (String)
TransactionID (String)
RefundReason (RefundReasonCodeType)
RefundType (RefundTypeCodeType)
RefundAmount (AmountType)
RefundMessage (String)
OrderLineItemID (String)


IssueRefundCall Constructor

IssueRefundCall Constructor
Namespaces ► eBay.Service.Call ► IssueRefundCall ► IssueRefundCall()()()()
Members
Icon | Member | Description
 | IssueRefundCall()()()() |
 | IssueRefundCall(ApiContext) |


IssueRefundCall Constructor

IssueRefundCall Constructor
Namespaces ► eBay.Service.Call ► IssueRefundCall ► IssueRefundCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IssueRefundCall()
Public Sub New
public:
IssueRefundCall()


IssueRefundCall Constructor (ApiContext)

IssueRefundCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► IssueRefundCall ► IssueRefundCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public IssueRefundCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
IssueRefundCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


RefundAmount Property

RefundAmount Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► RefundAmount
Gets or sets the RefundAmount of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType RefundAmount { get; set; }
Public Property RefundAmount As AmountType
    Get
    Set
public:
property AmountType^ RefundAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


RefundFromSeller Property

RefundFromSeller Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► RefundFromSeller
Gets the returned RefundFromSeller of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType RefundFromSeller { get; }
Public ReadOnly Property RefundFromSeller As AmountType
    Get
public:
property AmountType^ RefundFromSeller {
    AmountType^ get ();
}


RefundMessage Property

RefundMessage Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► RefundMessage
Gets or sets the RefundMessage of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string RefundMessage { get; set; }
Public Property RefundMessage As String
    Get
    Set
public:
property String^ RefundMessage {
    String^ get ();
    void set (String^ value);
}


RefundReason Property

RefundReason Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► RefundReason
Gets or sets the RefundReason of type RefundReasonCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public RefundReasonCodeType RefundReason { get; set; }
Public Property RefundReason As RefundReasonCodeType
    Get
    Set
public:
property RefundReasonCodeType RefundReason {
    RefundReasonCodeType get ();
    void set (RefundReasonCodeType value);
}


RefundType Property

RefundType Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► RefundType
Gets or sets the RefundType of type RefundTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public RefundTypeCodeType RefundType { get; set; }
Public Property RefundType As RefundTypeCodeType
    Get
    Set
public:
property RefundTypeCodeType RefundType {
    RefundTypeCodeType get ();
    void set (RefundTypeCodeType value);
}


TotalRefundToBuyer Property

TotalRefundToBuyer Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► TotalRefundToBuyer
Gets the returned TotalRefundToBuyer of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalRefundToBuyer { get; }
Public ReadOnly Property TotalRefundToBuyer As AmountType
    Get
public:
property AmountType^ TotalRefundToBuyer {
    AmountType^ get ();
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► IssueRefundCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


LeaveFeedbackCall Class

LeaveFeedbackCall Class
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class LeaveFeedbackCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class LeaveFeedbackCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class LeaveFeedbackCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LeaveFeedbackCall()()()() |
 | LeaveFeedbackCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the LeaveFeedbackRequestType for this API call.
 | ApiResponse | Gets the LeaveFeedbackResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CommentText | Gets or sets the CommentText of type String.
 | CommentType | Gets or sets the CommentType of type CommentTypeCodeType.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeedbackID | Gets the returned FeedbackID of type String.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemArrivedWithinEDDType | Gets or sets the ItemArrivedWithinEDDType of type ItemArrivedWithinEDDCodeType.
 | ItemDeliveredWithinEDD | Gets or sets the ItemDeliveredWithinEDD of type Boolean.
 | ItemID | Gets or sets the ItemID of type String.
 | LeaveFeedback(String, String, CommentTypeCodeType, String, String, ItemRatingDetailsTypeCollection, String, ItemArrivedWithinEDDCodeType, Boolean) |
 | LeaveFeedback(String, String, String, CommentTypeCodeType, String) | For backward compatibility with old wrappers.
 | LeaveFeedback(String, String, CommentTypeCodeType, String) | For backward compatibility with old wrappers.
 | LeaveFeedback(String, String, CommentTypeCodeType, String, String) |
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellerItemRatingDetailArrayList | Gets or sets the SellerItemRatingDetailArray of type ItemRatingDetailsTypeCollection.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | TargetUser | Gets or sets the TargetUser of type String.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | LeaveFeedbackCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► ApiRequest
Gets or sets the LeaveFeedbackRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public LeaveFeedbackRequestType ApiRequest { get; set; }
Public Property ApiRequest As LeaveFeedbackRequestType
    Get
    Set
public:
property LeaveFeedbackRequestType^ ApiRequest {
    LeaveFeedbackRequestType^ get ();
    void set (LeaveFeedbackRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► ApiResponse
Gets the LeaveFeedbackResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public LeaveFeedbackResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As LeaveFeedbackResponseType
    Get
public:
property LeaveFeedbackResponseType^ ApiResponse {
    LeaveFeedbackResponseType^ get ();
}


CommentText Property

CommentText Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► CommentText
Gets or sets the CommentText of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CommentText { get; set; }
Public Property CommentText As String
    Get
    Set
public:
property String^ CommentText {
    String^ get ();
    void set (String^ value);
}


CommentType Property

CommentType Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► CommentType
Gets or sets the CommentType of type CommentTypeCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeType CommentType { get; set; }
Public Property CommentType As CommentTypeCodeType
    Get
    Set
public:
property CommentTypeCodeType CommentType {
    CommentTypeCodeType get ();
    void set (CommentTypeCodeType value);
}


FeedbackID Property

FeedbackID Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► FeedbackID
Gets the returned FeedbackID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string FeedbackID { get; }
Public ReadOnly Property FeedbackID As String
    Get
public:
property String^ FeedbackID {
    String^ get ();
}


ItemArrivedWithinEDDType Property

ItemArrivedWithinEDDType Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► ItemArrivedWithinEDDType
Gets or sets the ItemArrivedWithinEDDType of type ItemArrivedWithinEDDCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemArrivedWithinEDDCodeType ItemArrivedWithinEDDType { get; set; }
Public Property ItemArrivedWithinEDDType As ItemArrivedWithinEDDCodeType
    Get
    Set
public:
property ItemArrivedWithinEDDCodeType ItemArrivedWithinEDDType {
    ItemArrivedWithinEDDCodeType get ();
    void set (ItemArrivedWithinEDDCodeType value);
}


ItemDeliveredWithinEDD Property

ItemDeliveredWithinEDD Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► ItemDeliveredWithinEDD
Gets or sets the ItemDeliveredWithinEDD of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemDeliveredWithinEDD { get; set; }
Public Property ItemDeliveredWithinEDD As Boolean
    Get
    Set
public:
property bool ItemDeliveredWithinEDD {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


LeaveFeedback Method

LeaveFeedback Method
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► LeaveFeedback()()()()
Members
Icon | Member | Description
 | LeaveFeedback(String, String, CommentTypeCodeType, String, String, ItemRatingDetailsTypeCollection, String, ItemArrivedWithinEDDCodeType, Boolean) |
 | LeaveFeedback(String, String, String, CommentTypeCodeType, String) | For backward compatibility with old wrappers.
 | LeaveFeedback(String, String, CommentTypeCodeType, String) | For backward compatibility with old wrappers.
 | LeaveFeedback(String, String, CommentTypeCodeType, String, String) |


LeaveFeedback Method (ItemID, CommentText, CommentType, TransactionID, TargetUser)

LeaveFeedback Method (ItemID, CommentText, CommentType, TransactionID, TargetUser)
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► LeaveFeedback(String, String, CommentTypeCodeType, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public string LeaveFeedback(
    string ItemID,
    string CommentText,
    CommentTypeCodeType CommentType,
    string TransactionID,
    string TargetUser
)
Public Function LeaveFeedback ( _
    ItemID As String, _
    CommentText As String, _
    CommentType As CommentTypeCodeType, _
    TransactionID As String, _
    TargetUser As String _
) As String
public:
String^ LeaveFeedback(
    String^ ItemID,
    String^ CommentText,
    CommentTypeCodeType CommentType,
    String^ TransactionID,
    String^ TargetUser
)
Parameters
ItemID (String)
CommentText (String)
CommentType (CommentTypeCodeType)
TransactionID (String)
TargetUser (String)


LeaveFeedback Method (ItemID, CommentText, CommentType, TransactionID, TargetUser, SellerItemRatingDetailArrayList, OrderLineItemID, ItemArrivedWithinEDDType, ItemDeliveredWithinEDD)

LeaveFeedback Method (ItemID, CommentText, CommentType, TransactionID, TargetUser, SellerItemRatingDetailArrayList, OrderLineItemID, ItemArrivedWithinEDDType, ItemDeliveredWithinEDD)
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► LeaveFeedback(String, String, CommentTypeCodeType, String, String, ItemRatingDetailsTypeCollection, String, ItemArrivedWithinEDDCodeType, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public string LeaveFeedback(
    string ItemID,
    string CommentText,
    CommentTypeCodeType CommentType,
    string TransactionID,
    string TargetUser,
    ItemRatingDetailsTypeCollection SellerItemRatingDetailArrayList,
    string OrderLineItemID,
    ItemArrivedWithinEDDCodeType ItemArrivedWithinEDDType,
    bool ItemDeliveredWithinEDD
)
Public Function LeaveFeedback ( _
    ItemID As String, _
    CommentText As String, _
    CommentType As CommentTypeCodeType, _
    TransactionID As String, _
    TargetUser As String, _
    SellerItemRatingDetailArrayList As ItemRatingDetailsTypeCollection, _
    OrderLineItemID As String, _
    ItemArrivedWithinEDDType As ItemArrivedWithinEDDCodeType, _
    ItemDeliveredWithinEDD As Boolean _
) As String
public:
String^ LeaveFeedback(
    String^ ItemID,
    String^ CommentText,
    CommentTypeCodeType CommentType,
    String^ TransactionID,
    String^ TargetUser,
    ItemRatingDetailsTypeCollection^ SellerItemRatingDetailArrayList,
    String^ OrderLineItemID,
    ItemArrivedWithinEDDCodeType ItemArrivedWithinEDDType,
    bool ItemDeliveredWithinEDD
)
Parameters
ItemID (String)
CommentText (String)
CommentType (CommentTypeCodeType)
TransactionID (String)
TargetUser (String)
SellerItemRatingDetailArrayList (ItemRatingDetailsTypeCollection)
OrderLineItemID (String)
ItemArrivedWithinEDDType (ItemArrivedWithinEDDCodeType)
ItemDeliveredWithinEDD (Boolean)


LeaveFeedback Method (TargetUser, ItemID, CommentType, CommentText)

LeaveFeedback Method (TargetUser, ItemID, CommentType, CommentText)
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► LeaveFeedback(String, String, CommentTypeCodeType, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public string LeaveFeedback(
    string TargetUser,
    string ItemID,
    CommentTypeCodeType CommentType,
    string CommentText
)
Public Function LeaveFeedback ( _
    TargetUser As String, _
    ItemID As String, _
    CommentType As CommentTypeCodeType, _
    CommentText As String _
) As String
public:
String^ LeaveFeedback(
    String^ TargetUser,
    String^ ItemID,
    CommentTypeCodeType CommentType,
    String^ CommentText
)
Parameters
TargetUser (String)
ItemID (String)
CommentType (CommentTypeCodeType)
CommentText (String)


LeaveFeedback Method (TargetUser, ItemID, TransactionID, CommentType, CommentText)

LeaveFeedback Method (TargetUser, ItemID, TransactionID, CommentType, CommentText)
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► LeaveFeedback(String, String, String, CommentTypeCodeType, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public string LeaveFeedback(
    string TargetUser,
    string ItemID,
    string TransactionID,
    CommentTypeCodeType CommentType,
    string CommentText
)
Public Function LeaveFeedback ( _
    TargetUser As String, _
    ItemID As String, _
    TransactionID As String, _
    CommentType As CommentTypeCodeType, _
    CommentText As String _
) As String
public:
String^ LeaveFeedback(
    String^ TargetUser,
    String^ ItemID,
    String^ TransactionID,
    CommentTypeCodeType CommentType,
    String^ CommentText
)
Parameters
TargetUser (String)
ItemID (String)
TransactionID (String)
CommentType (CommentTypeCodeType)
CommentText (String)


LeaveFeedbackCall Constructor

LeaveFeedbackCall Constructor
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► LeaveFeedbackCall()()()()
Members
Icon | Member | Description
 | LeaveFeedbackCall()()()() |
 | LeaveFeedbackCall(ApiContext) |


LeaveFeedbackCall Constructor

LeaveFeedbackCall Constructor
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► LeaveFeedbackCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LeaveFeedbackCall()
Public Sub New
public:
LeaveFeedbackCall()


LeaveFeedbackCall Constructor (ApiContext)

LeaveFeedbackCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► LeaveFeedbackCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public LeaveFeedbackCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
LeaveFeedbackCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


SellerItemRatingDetailArrayList Property

SellerItemRatingDetailArrayList Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► SellerItemRatingDetailArrayList
Gets or sets the SellerItemRatingDetailArray of type ItemRatingDetailsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ItemRatingDetailsTypeCollection SellerItemRatingDetailArrayList { get; set; }
Public Property SellerItemRatingDetailArrayList As ItemRatingDetailsTypeCollection
    Get
    Set
public:
property ItemRatingDetailsTypeCollection^ SellerItemRatingDetailArrayList {
    ItemRatingDetailsTypeCollection^ get ();
    void set (ItemRatingDetailsTypeCollection^ value);
}


TargetUser Property

TargetUser Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► TargetUser
Gets or sets the TargetUser of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TargetUser { get; set; }
Public Property TargetUser As String
    Get
    Set
public:
property String^ TargetUser {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► LeaveFeedbackCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


MoveSellingManagerInventoryFolderCall Class

MoveSellingManagerInventoryFolderCall Class
Namespaces ► eBay.Service.Call ► MoveSellingManagerInventoryFolderCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class MoveSellingManagerInventoryFolderCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class MoveSellingManagerInventoryFolderCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class MoveSellingManagerInventoryFolderCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveSellingManagerInventoryFolderCall()()()() |
 | MoveSellingManagerInventoryFolderCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the MoveSellingManagerInventoryFolderRequestType for this API call.
 | ApiResponse | Gets the MoveSellingManagerInventoryFolderResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID | Gets or sets the FolderID of type Int64.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveSellingManagerInventoryFolder(Int64, Int64) | Enables a seller to move a Selling Manager inventory folder. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | NewParentFolderID | Gets or sets the NewParentFolderID of type Int64.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | MoveSellingManagerInventoryFolderCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► MoveSellingManagerInventoryFolderCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► MoveSellingManagerInventoryFolderCall ► ApiRequest
Gets or sets the MoveSellingManagerInventoryFolderRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public MoveSellingManagerInventoryFolderRequestType ApiRequest { get; set; }
Public Property ApiRequest As MoveSellingManagerInventoryFolderRequestType
    Get
    Set
public:
property MoveSellingManagerInventoryFolderRequestType^ ApiRequest {
    MoveSellingManagerInventoryFolderRequestType^ get ();
    void set (MoveSellingManagerInventoryFolderRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► MoveSellingManagerInventoryFolderCall ► ApiResponse
Gets the MoveSellingManagerInventoryFolderResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public MoveSellingManagerInventoryFolderResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As MoveSellingManagerInventoryFolderResponseType
    Get
public:
property MoveSellingManagerInventoryFolderResponseType^ ApiResponse {
    MoveSellingManagerInventoryFolderResponseType^ get ();
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Call ► MoveSellingManagerInventoryFolderCall ► FolderID
Gets or sets the FolderID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


MoveSellingManagerInventoryFolder Method (FolderID, NewParentFolderID)

MoveSellingManagerInventoryFolder Method (FolderID, NewParentFolderID)
Namespaces ► eBay.Service.Call ► MoveSellingManagerInventoryFolderCall ► MoveSellingManagerInventoryFolder(Int64, Int64)
Enables a seller to move a Selling Manager inventory folder. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public void MoveSellingManagerInventoryFolder(
    long FolderID,
    long NewParentFolderID
)
Public Sub MoveSellingManagerInventoryFolder ( _
    FolderID As Long, _
    NewParentFolderID As Long _
)
public:
void MoveSellingManagerInventoryFolder(
    long long FolderID,
    long long NewParentFolderID
)
Parameters
FolderID (Int64)
Unique ID of the folder that will be moved. User can retrieve the FolderId using GetSellingManagerInventoryFolder.
NewParentFolderID (Int64)
Unique folder ID for the new parent folder. If no NewParentFolderID is submitted, the folder is moved to the root level.


MoveSellingManagerInventoryFolderCall Constructor

MoveSellingManagerInventoryFolderCall Constructor
Namespaces ► eBay.Service.Call ► MoveSellingManagerInventoryFolderCall ► MoveSellingManagerInventoryFolderCall()()()()
Members
Icon | Member | Description
 | MoveSellingManagerInventoryFolderCall()()()() |
 | MoveSellingManagerInventoryFolderCall(ApiContext) |


MoveSellingManagerInventoryFolderCall Constructor

MoveSellingManagerInventoryFolderCall Constructor
Namespaces ► eBay.Service.Call ► MoveSellingManagerInventoryFolderCall ► MoveSellingManagerInventoryFolderCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MoveSellingManagerInventoryFolderCall()
Public Sub New
public:
MoveSellingManagerInventoryFolderCall()


MoveSellingManagerInventoryFolderCall Constructor (ApiContext)

MoveSellingManagerInventoryFolderCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► MoveSellingManagerInventoryFolderCall ► MoveSellingManagerInventoryFolderCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public MoveSellingManagerInventoryFolderCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
MoveSellingManagerInventoryFolderCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


NewParentFolderID Property

NewParentFolderID Property
Namespaces ► eBay.Service.Call ► MoveSellingManagerInventoryFolderCall ► NewParentFolderID
Gets or sets the NewParentFolderID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long NewParentFolderID { get; set; }
Public Property NewParentFolderID As Long
    Get
    Set
public:
property long long NewParentFolderID {
    long long get ();
    void set (long long value);
}


PlaceOfferCall Class

PlaceOfferCall Class
Namespaces ► eBay.Service.Call ► PlaceOfferCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class PlaceOfferCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class PlaceOfferCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class PlaceOfferCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlaceOfferCall()()()() |
 | PlaceOfferCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AffiliateTrackingDetails | Gets or sets the AffiliateTrackingDetails of type AffiliateTrackingDetailsType.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the PlaceOfferRequestType for this API call.
 | ApiResponse | Gets the PlaceOfferResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BestOffer | Gets the returned BestOffer of type BestOfferType.
 | BlockOnWarning | Gets or sets the BlockOnWarning of type Boolean.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Offer | Gets or sets the Offer of type OfferType.
 | OrderLineItemID | Gets the returned OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | PlaceOffer(OfferType, String, Boolean, AffiliateTrackingDetailsType, NameValueListTypeCollection) | Enables the authenticated user to make a bid, a Best Offer, or a purchase on the item specified by the ItemID input field.
 | PlaceOffer(OfferType, String) | For backward compatibility with old wrappers.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellingStatus | Gets the returned SellingStatus of type SellingStatusType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets the returned TransactionID of type String.
 | VariationSpecificList | Gets or sets the VariationSpecifics of type NameValueListTypeCollection.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | PlaceOfferCall


AffiliateTrackingDetails Property

AffiliateTrackingDetails Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► AffiliateTrackingDetails
Gets or sets the AffiliateTrackingDetails of type AffiliateTrackingDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public AffiliateTrackingDetailsType AffiliateTrackingDetails { get; set; }
Public Property AffiliateTrackingDetails As AffiliateTrackingDetailsType
    Get
    Set
public:
property AffiliateTrackingDetailsType^ AffiliateTrackingDetails {
    AffiliateTrackingDetailsType^ get ();
    void set (AffiliateTrackingDetailsType^ value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► ApiRequest
Gets or sets the PlaceOfferRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public PlaceOfferRequestType ApiRequest { get; set; }
Public Property ApiRequest As PlaceOfferRequestType
    Get
    Set
public:
property PlaceOfferRequestType^ ApiRequest {
    PlaceOfferRequestType^ get ();
    void set (PlaceOfferRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► ApiResponse
Gets the PlaceOfferResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public PlaceOfferResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As PlaceOfferResponseType
    Get
public:
property PlaceOfferResponseType^ ApiResponse {
    PlaceOfferResponseType^ get ();
}


BestOffer Property

BestOffer Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► BestOffer
Gets the returned BestOffer of type BestOfferType.
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferType BestOffer { get; }
Public ReadOnly Property BestOffer As BestOfferType
    Get
public:
property BestOfferType^ BestOffer {
    BestOfferType^ get ();
}


BlockOnWarning Property

BlockOnWarning Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► BlockOnWarning
Gets or sets the BlockOnWarning of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool BlockOnWarning { get; set; }
Public Property BlockOnWarning As Boolean
    Get
    Set
public:
property bool BlockOnWarning {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


Offer Property

Offer Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► Offer
Gets or sets the Offer of type OfferType.
Declaration Syntax
C# Visual Basic Visual C++
public OfferType Offer { get; set; }
Public Property Offer As OfferType
    Get
    Set
public:
property OfferType^ Offer {
    OfferType^ get ();
    void set (OfferType^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► OrderLineItemID
Gets the returned OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; }
Public ReadOnly Property OrderLineItemID As String
    Get
public:
property String^ OrderLineItemID {
    String^ get ();
}


PlaceOffer Method

PlaceOffer Method
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► PlaceOffer()()()()
Members
Icon | Member | Description
 | PlaceOffer(OfferType, String, Boolean, AffiliateTrackingDetailsType, NameValueListTypeCollection) | Enables the authenticated user to make a bid, a Best Offer, or a purchase on the item specified by the ItemID input field.
 | PlaceOffer(OfferType, String) | For backward compatibility with old wrappers.


PlaceOffer Method (Offer, ItemID)

PlaceOffer Method (Offer, ItemID)
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► PlaceOffer(OfferType, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public SellingStatusType PlaceOffer(
    OfferType Offer,
    string ItemID
)
Public Function PlaceOffer ( _
    Offer As OfferType, _
    ItemID As String _
) As SellingStatusType
public:
SellingStatusType^ PlaceOffer(
    OfferType^ Offer,
    String^ ItemID
)
Parameters
Offer (OfferType)
ItemID (String)


PlaceOffer Method (Offer, ItemID, BlockOnWarning, AffiliateTrackingDetails, VariationSpecificList)

PlaceOffer Method (Offer, ItemID, BlockOnWarning, AffiliateTrackingDetails, VariationSpecificList)
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► PlaceOffer(OfferType, String, Boolean, AffiliateTrackingDetailsType, NameValueListTypeCollection)
Enables the authenticated user to make a bid, a Best Offer, or a purchase on the item specified by the ItemID input field.
Declaration Syntax
C# Visual Basic Visual C++
public SellingStatusType PlaceOffer(
    OfferType Offer,
    string ItemID,
    bool BlockOnWarning,
    AffiliateTrackingDetailsType AffiliateTrackingDetails,
    NameValueListTypeCollection VariationSpecificList
)
Public Function PlaceOffer ( _
    Offer As OfferType, _
    ItemID As String, _
    BlockOnWarning As Boolean, _
    AffiliateTrackingDetails As AffiliateTrackingDetailsType, _
    VariationSpecificList As NameValueListTypeCollection _
) As SellingStatusType
public:
SellingStatusType^ PlaceOffer(
    OfferType^ Offer,
    String^ ItemID,
    bool BlockOnWarning,
    AffiliateTrackingDetailsType^ AffiliateTrackingDetails,
    NameValueListTypeCollection^ VariationSpecificList
)
Parameters
Offer (OfferType)
Specifies the type of offer being made. If the item is a competitive-bidding listing, the offer is a bid. If the item is a fixed-price listing, then the offer purchases the item. If the item is a competitive-bidding listing and the offer is of type with an active, unexercised Buy It Now option, then the offer can either purchase the item or be a bid. See the schema documentation for OfferType for details on its properties and their meanings.
ItemID (String)
Unique item ID that identifies the item listing for which the action is being submitted. If the item was listed with Variations, you must also specify VariationSpecifics in the request to uniquely identify the variant being purchased.
BlockOnWarning (Boolean)
If a warning message exists and BlockOnWarning is true, the warning message is returned and the bid is blocked. If no warning message exists and BlockOnWarning is true, the bid is placed. If BlockOnWarning is false, the bid is placed, regardless of warning.
AffiliateTrackingDetails (AffiliateTrackingDetailsType)
Container for affiliate-related tags, which enable the tracking of user activity. If you include AffiliateTrackingDetails in your PlaceOffer call, then it is possible to receive affiliate commissions based on calls made by your application. (See the eBay Partner Network for information about commissions.) Please note that affiliate tracking is not available in the Sandbox environment, and that affiliate tracking is not available when you make a best offer.
VariationSpecificList (NameValueListTypeCollection)
Name-value pairs that identify a single variation within the listing identified by ItemID. Required when the seller listed the item with Item Variations. If you want to buy items from multiple variations in the same listing, use a separate PlaceOffer request for each variation. For example, if you want to buy 3 red shirts and 2 black shirts from the same listing, use one PlaceOffer request for the 3 red shirts, and another PlaceOffer request for the 2 black shirts.


PlaceOfferCall Constructor

PlaceOfferCall Constructor
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► PlaceOfferCall()()()()
Members
Icon | Member | Description
 | PlaceOfferCall()()()() |
 | PlaceOfferCall(ApiContext) |


PlaceOfferCall Constructor

PlaceOfferCall Constructor
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► PlaceOfferCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PlaceOfferCall()
Public Sub New
public:
PlaceOfferCall()


PlaceOfferCall Constructor (ApiContext)

PlaceOfferCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► PlaceOfferCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public PlaceOfferCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
PlaceOfferCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SellingStatus Property

SellingStatus Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► SellingStatus
Gets the returned SellingStatus of type SellingStatusType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingStatusType SellingStatus { get; }
Public ReadOnly Property SellingStatus As SellingStatusType
    Get
public:
property SellingStatusType^ SellingStatus {
    SellingStatusType^ get ();
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► TransactionID
Gets the returned TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; }
Public ReadOnly Property TransactionID As String
    Get
public:
property String^ TransactionID {
    String^ get ();
}


VariationSpecificList Property

VariationSpecificList Property
Namespaces ► eBay.Service.Call ► PlaceOfferCall ► VariationSpecificList
Gets or sets the VariationSpecifics of type NameValueListTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection VariationSpecificList { get; set; }
Public Property VariationSpecificList As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ VariationSpecificList {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


RelistFixedPriceItemCall Class

RelistFixedPriceItemCall Class
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class RelistFixedPriceItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class RelistFixedPriceItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class RelistFixedPriceItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RelistFixedPriceItemCall()()()() |
 | RelistFixedPriceItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the RelistFixedPriceItemRequestType for this API call.
 | ApiResponse | Gets the RelistFixedPriceItemResponseType for this API call.
 | AutoSetItemUUID |
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Category2ID | Gets the returned Category2ID of type String.
 | CategoryID | Gets the returned CategoryID of type String.
 | DeletedFieldList | Gets or sets the DeletedField of type StringCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DiscountReasonList | Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | (Overrides ApiCall.Execute()()()().)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | ItemID | Gets the returned ItemID of type String.
 | ListingRecommendations | Gets the returned ListingRecommendations of type ListingRecommendationsType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewUUID()()()() | Generates a universal unique identifier.
 | OutputSelector | (Inherited from ApiCall.)
 | PictureFileList |
 | ProductSuggestions | Gets the returned ProductSuggestions of type ProductSuggestionsType.
 | RelistFixedPriceItem(ItemType, StringCollection) | Enables a seller to relist a single fixed-price listing that has ended on a specified eBay site. If the item was being watched when the listing ended, it will continue to be watched when the item is relisted.
 | ResetItemUUID(ItemType) | Sets or overwrites the UUID.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SKU | Gets the returned SKU of type String.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | RelistFixedPriceItemCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► ApiRequest
Gets or sets the RelistFixedPriceItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RelistFixedPriceItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As RelistFixedPriceItemRequestType
    Get
    Set
public:
property RelistFixedPriceItemRequestType^ ApiRequest {
    RelistFixedPriceItemRequestType^ get ();
    void set (RelistFixedPriceItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► ApiResponse
Gets the RelistFixedPriceItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RelistFixedPriceItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As RelistFixedPriceItemResponseType
    Get
public:
property RelistFixedPriceItemResponseType^ ApiResponse {
    RelistFixedPriceItemResponseType^ get ();
}


AutoSetItemUUID Property

AutoSetItemUUID Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► AutoSetItemUUID
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoSetItemUUID { get; set; }
Public Property AutoSetItemUUID As Boolean
    Get
    Set
public:
property bool AutoSetItemUUID {
    bool get ();
    void set (bool value);
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► Category2ID
Gets the returned Category2ID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; }
Public ReadOnly Property Category2ID As String
    Get
public:
property String^ Category2ID {
    String^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► CategoryID
Gets the returned CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; }
Public ReadOnly Property CategoryID As String
    Get
public:
property String^ CategoryID {
    String^ get ();
}


DeletedFieldList Property

DeletedFieldList Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► DeletedFieldList
Gets or sets the DeletedField of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedFieldList { get; set; }
Public Property DeletedFieldList As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedFieldList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


DiscountReasonList Property

DiscountReasonList Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► DiscountReasonList
Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReasonList { get; }
Public ReadOnly Property DiscountReasonList As DiscountReasonCodeTypeCollection
    Get
public:
property DiscountReasonCodeTypeCollection^ DiscountReasonList {
    DiscountReasonCodeTypeCollection^ get ();
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


Execute Method

Execute Method
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► Execute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Execute()
Public Overrides Sub Execute
public:
virtual void Execute() override


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► ItemID
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; }
Public ReadOnly Property ItemID As String
    Get
public:
property String^ ItemID {
    String^ get ();
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► ListingRecommendations
Gets the returned ListingRecommendations of type ListingRecommendationsType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; }
Public ReadOnly Property ListingRecommendations As ListingRecommendationsType
    Get
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
}


NewUUID Method

NewUUID Method
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► NewUUID()()()()
Generates a universal unique identifier.
Declaration Syntax
C# Visual Basic Visual C++
public static string NewUUID()
Public Shared Function NewUUID As String
public:
static String^ NewUUID()
Return Value
A universal unique identifier of type String


PictureFileList Property

PictureFileList Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► PictureFileList
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureFileList { get; set; }
Public Property PictureFileList As StringCollection
    Get
    Set
public:
property StringCollection^ PictureFileList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► ProductSuggestions
Gets the returned ProductSuggestions of type ProductSuggestionsType.
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; }
Public ReadOnly Property ProductSuggestions As ProductSuggestionsType
    Get
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
}


RelistFixedPriceItem Method (Item, DeletedFieldList)

RelistFixedPriceItem Method (Item, DeletedFieldList)
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► RelistFixedPriceItem(ItemType, StringCollection)
Enables a seller to relist a single fixed-price listing that has ended on a specified eBay site. If the item was being watched when the listing ended, it will continue to be watched when the item is relisted.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection RelistFixedPriceItem(
    ItemType Item,
    StringCollection DeletedFieldList
)
Public Function RelistFixedPriceItem ( _
    Item As ItemType, _
    DeletedFieldList As StringCollection _
) As FeeTypeCollection
public:
FeeTypeCollection^ RelistFixedPriceItem(
    ItemType^ Item,
    StringCollection^ DeletedFieldList
)
Parameters
Item (ItemType)
Child elements hold the values for item properties that change for the relisted item. Item is a required input. At a minimum, the Item.ItemID property must be set to the ID of the original listing (a listing that ended in the past 90 days). By default, the new listing's Item object properties are the same as those of the original (ended) listing. By setting a new value in the Item object, the new listing uses the new value rather than the original value from the old listing.
DeletedFieldList (StringCollection)
Specifies the name of the field to delete from a listing. See Relisting Items for rules on deleting values when relisting items. Also see the relevant field descriptions to determine when to use DeletedField (and potential consequences). The request can contain zero, one, or many instances of DeletedField (one for each field to be deleted). Some data (such as Variation nodes within Variations) can't be deleted by using a DeletedField tag. See the relevant field descriptions for how to delete such data. Case-sensitivity must be taken into account when using a DeletedField tag to delete a field. The value passed into a DeletedField tag must either match the case of the schema element names in the full field path (Item.PictureDetails.GalleryURL), or the initial letter of each schema element name in the full field path must be lowercase (item.pictureDetails.galleryURL). Do not change the case of letters in the middle of a field name. For example, item.picturedetails.galleryUrl is not allowed. To delete a listing enhancement like 'BoldTitle', specify the value you are deleting; for example, Item.ListingEnhancement[BoldTitle].


RelistFixedPriceItemCall Constructor

RelistFixedPriceItemCall Constructor
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► RelistFixedPriceItemCall()()()()
Members
Icon | Member | Description
 | RelistFixedPriceItemCall()()()() |
 | RelistFixedPriceItemCall(ApiContext) |


RelistFixedPriceItemCall Constructor

RelistFixedPriceItemCall Constructor
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► RelistFixedPriceItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RelistFixedPriceItemCall()
Public Sub New
public:
RelistFixedPriceItemCall()


RelistFixedPriceItemCall Constructor (ApiContext)

RelistFixedPriceItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► RelistFixedPriceItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public RelistFixedPriceItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
RelistFixedPriceItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ResetItemUUID Method (Item)

ResetItemUUID Method (Item)
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► ResetItemUUID(ItemType)
Sets or overwrites the UUID.
Declaration Syntax
C# Visual Basic Visual C++
public static void ResetItemUUID(
    ItemType Item
)
Public Shared Sub ResetItemUUID ( _
    Item As ItemType _
)
public:
static void ResetItemUUID(
    ItemType^ Item
)
Parameters
Item (ItemType)
The item to assign a universal unique identifier to.


SKU Property

SKU Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► SKU
Gets the returned SKU of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; }
Public ReadOnly Property SKU As String
    Get
public:
property String^ SKU {
    String^ get ();
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► RelistFixedPriceItemCall ► StartTime
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}


RelistItemCall Class

RelistItemCall Class
Namespaces ► eBay.Service.Call ► RelistItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class RelistItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class RelistItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class RelistItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RelistItemCall()()()() |
 | RelistItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the RelistItemRequestType for this API call.
 | ApiResponse | Gets the RelistItemResponseType for this API call.
 | AutoSetItemUUID |
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Category2ID | Gets the returned Category2ID of type String.
 | CategoryID | Gets the returned CategoryID of type String.
 | DeletedFieldList | Gets or sets the DeletedField of type StringCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DiscountReasonList | Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | (Overrides ApiCall.Execute()()()().)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | ItemID | Gets the returned ItemID of type String.
 | ListingRecommendations | Gets the returned ListingRecommendations of type ListingRecommendationsType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewUUID()()()() | Generates a universal unique identifier.
 | OutputSelector | (Inherited from ApiCall.)
 | PictureFileList |
 | ProductSuggestions | Gets the returned ProductSuggestions of type ProductSuggestionsType.
 | RelistItem(ItemType, StringCollection) | Enables a seller to relist a single listing that has ended on a specified eBay site. If the item was being watched when the listing ended, it will continue to be watched when the item is relisted.
 | RelistItem(ItemType) | For backward compatibility with old wrappers.
 | ResetItemUUID(ItemType) | Sets or overwrites the UUID.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | RelistItemCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► ApiRequest
Gets or sets the RelistItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RelistItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As RelistItemRequestType
    Get
    Set
public:
property RelistItemRequestType^ ApiRequest {
    RelistItemRequestType^ get ();
    void set (RelistItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► ApiResponse
Gets the RelistItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RelistItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As RelistItemResponseType
    Get
public:
property RelistItemResponseType^ ApiResponse {
    RelistItemResponseType^ get ();
}


AutoSetItemUUID Property

AutoSetItemUUID Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► AutoSetItemUUID
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoSetItemUUID { get; set; }
Public Property AutoSetItemUUID As Boolean
    Get
    Set
public:
property bool AutoSetItemUUID {
    bool get ();
    void set (bool value);
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► Category2ID
Gets the returned Category2ID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; }
Public ReadOnly Property Category2ID As String
    Get
public:
property String^ Category2ID {
    String^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► CategoryID
Gets the returned CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; }
Public ReadOnly Property CategoryID As String
    Get
public:
property String^ CategoryID {
    String^ get ();
}


DeletedFieldList Property

DeletedFieldList Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► DeletedFieldList
Gets or sets the DeletedField of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedFieldList { get; set; }
Public Property DeletedFieldList As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedFieldList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


DiscountReasonList Property

DiscountReasonList Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► DiscountReasonList
Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReasonList { get; }
Public ReadOnly Property DiscountReasonList As DiscountReasonCodeTypeCollection
    Get
public:
property DiscountReasonCodeTypeCollection^ DiscountReasonList {
    DiscountReasonCodeTypeCollection^ get ();
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


Execute Method

Execute Method
Namespaces ► eBay.Service.Call ► RelistItemCall ► Execute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Execute()
Public Overrides Sub Execute
public:
virtual void Execute() override


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► ItemID
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; }
Public ReadOnly Property ItemID As String
    Get
public:
property String^ ItemID {
    String^ get ();
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► ListingRecommendations
Gets the returned ListingRecommendations of type ListingRecommendationsType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; }
Public ReadOnly Property ListingRecommendations As ListingRecommendationsType
    Get
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
}


NewUUID Method

NewUUID Method
Namespaces ► eBay.Service.Call ► RelistItemCall ► NewUUID()()()()
Generates a universal unique identifier.
Declaration Syntax
C# Visual Basic Visual C++
public static string NewUUID()
Public Shared Function NewUUID As String
public:
static String^ NewUUID()
Return Value
A universal unique identifier of type String


PictureFileList Property

PictureFileList Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► PictureFileList
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureFileList { get; set; }
Public Property PictureFileList As StringCollection
    Get
    Set
public:
property StringCollection^ PictureFileList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► ProductSuggestions
Gets the returned ProductSuggestions of type ProductSuggestionsType.
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; }
Public ReadOnly Property ProductSuggestions As ProductSuggestionsType
    Get
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
}


RelistItem Method

RelistItem Method
Namespaces ► eBay.Service.Call ► RelistItemCall ► RelistItem()()()()
Members
Icon | Member | Description
 | RelistItem(ItemType, StringCollection) | Enables a seller to relist a single listing that has ended on a specified eBay site. If the item was being watched when the listing ended, it will continue to be watched when the item is relisted.
 | RelistItem(ItemType) | For backward compatibility with old wrappers.


RelistItem Method (Item)

RelistItem Method (Item)
Namespaces ► eBay.Service.Call ► RelistItemCall ► RelistItem(ItemType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection RelistItem(
    ItemType Item
)
Public Function RelistItem ( _
    Item As ItemType _
) As FeeTypeCollection
public:
FeeTypeCollection^ RelistItem(
    ItemType^ Item
)
Parameters
Item (ItemType)


RelistItem Method (Item, DeletedFieldList)

RelistItem Method (Item, DeletedFieldList)
Namespaces ► eBay.Service.Call ► RelistItemCall ► RelistItem(ItemType, StringCollection)
Enables a seller to relist a single listing that has ended on a specified eBay site. If the item was being watched when the listing ended, it will continue to be watched when the item is relisted.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection RelistItem(
    ItemType Item,
    StringCollection DeletedFieldList
)
Public Function RelistItem ( _
    Item As ItemType, _
    DeletedFieldList As StringCollection _
) As FeeTypeCollection
public:
FeeTypeCollection^ RelistItem(
    ItemType^ Item,
    StringCollection^ DeletedFieldList
)
Parameters
Item (ItemType)
Child elements hold the values for item properties that change for the relisted item. Item is a required input. At a minimum, the Item.ItemID property must be set to the ID of the listing being relisted (a listing that ended in the past 90 days). By default, the new listing's Item object properties are the same as those of the original (ended) listing. By setting a new value in the Item object, the new listing uses the new value rather than the corresponding value from the old listing.
DeletedFieldList (StringCollection)
Specifies the name of the field to delete from a listing. See Relisting Items for rules on deleting values when relisting items. Also see the relevant field descriptions to determine when to use DeletedField (and potential consequences). The request can contain zero, one, or many instances of DeletedField (one for each field to be deleted). Case-sensitivity must be taken into account when using a DeletedField tag to delete a field. The value passed into a DeletedField tag must either match the case of the schema element names in the full field path (Item.PictureDetails.GalleryURL), or the initial letter of each schema element name in the full field path must be lowercase (item.pictureDetails.galleryURL). Do not change the case of letters in the middle of a field name. For example, item.picturedetails.galleryUrl is not allowed. To delete a listing enhancement like 'BoldTitle', specify the value you are deleting; for example, Item.ListingEnhancement[BoldTitle].


RelistItemCall Constructor

RelistItemCall Constructor
Namespaces ► eBay.Service.Call ► RelistItemCall ► RelistItemCall()()()()
Members
Icon | Member | Description
 | RelistItemCall()()()() |
 | RelistItemCall(ApiContext) |


RelistItemCall Constructor

RelistItemCall Constructor
Namespaces ► eBay.Service.Call ► RelistItemCall ► RelistItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RelistItemCall()
Public Sub New
public:
RelistItemCall()


RelistItemCall Constructor (ApiContext)

RelistItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► RelistItemCall ► RelistItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public RelistItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
RelistItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ResetItemUUID Method (Item)

ResetItemUUID Method (Item)
Namespaces ► eBay.Service.Call ► RelistItemCall ► ResetItemUUID(ItemType)
Sets or overwrites the UUID.
Declaration Syntax
C# Visual Basic Visual C++
public static void ResetItemUUID(
    ItemType Item
)
Public Shared Sub ResetItemUUID ( _
    Item As ItemType _
)
public:
static void ResetItemUUID(
    ItemType^ Item
)
Parameters
Item (ItemType)
The item to assign a universal unique identifier to.


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► RelistItemCall ► StartTime
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}


RemoveFromWatchListCall Class

RemoveFromWatchListCall Class
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class RemoveFromWatchListCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class RemoveFromWatchListCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class RemoveFromWatchListCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RemoveFromWatchListCall()()()() |
 | RemoveFromWatchListCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the RemoveFromWatchListRequestType for this API call.
 | ApiResponse | Gets the RemoveFromWatchListResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemIDList | Gets or sets the ItemID of type StringCollection.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | RemoveAllItems | Gets or sets the RemoveAllItems of type Boolean.
 | RemoveFromWatchList(StringCollection, Boolean, VariationKeyTypeCollection) | Enables a user to remove one or more items from their My eBay watch list.
 | RemoveFromWatchList(StringCollection) | For backward compatibility with old wrappers.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | VariationKeyList | Gets or sets the VariationKey of type VariationKeyTypeCollection.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
 | WatchListCount | Gets the returned WatchListCount of type Int32.
 | WatchListMaximum | Gets the returned WatchListMaximum of type Int32.
Inheritance Hierarchy
Object
 | ApiCall
 |  | RemoveFromWatchListCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► ApiRequest
Gets or sets the RemoveFromWatchListRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RemoveFromWatchListRequestType ApiRequest { get; set; }
Public Property ApiRequest As RemoveFromWatchListRequestType
    Get
    Set
public:
property RemoveFromWatchListRequestType^ ApiRequest {
    RemoveFromWatchListRequestType^ get ();
    void set (RemoveFromWatchListRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► ApiResponse
Gets the RemoveFromWatchListResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RemoveFromWatchListResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As RemoveFromWatchListResponseType
    Get
public:
property RemoveFromWatchListResponseType^ ApiResponse {
    RemoveFromWatchListResponseType^ get ();
}


ItemIDList Property

ItemIDList Property
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► ItemIDList
Gets or sets the ItemID of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ItemIDList { get; set; }
Public Property ItemIDList As StringCollection
    Get
    Set
public:
property StringCollection^ ItemIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


RemoveAllItems Property

RemoveAllItems Property
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► RemoveAllItems
Gets or sets the RemoveAllItems of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveAllItems { get; set; }
Public Property RemoveAllItems As Boolean
    Get
    Set
public:
property bool RemoveAllItems {
    bool get ();
    void set (bool value);
}


RemoveFromWatchList Method

RemoveFromWatchList Method
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► RemoveFromWatchList()()()()
Members
Icon | Member | Description
 | RemoveFromWatchList(StringCollection, Boolean, VariationKeyTypeCollection) | Enables a user to remove one or more items from their My eBay watch list.
 | RemoveFromWatchList(StringCollection) | For backward compatibility with old wrappers.


RemoveFromWatchList Method (ItemIDList)

RemoveFromWatchList Method (ItemIDList)
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► RemoveFromWatchList(StringCollection)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public int RemoveFromWatchList(
    StringCollection ItemIDList
)
Public Function RemoveFromWatchList ( _
    ItemIDList As StringCollection _
) As Integer
public:
int RemoveFromWatchList(
    StringCollection^ ItemIDList
)
Parameters
ItemIDList (StringCollection)


RemoveFromWatchList Method (ItemIDList, RemoveAllItems, VariationKeyList)

RemoveFromWatchList Method (ItemIDList, RemoveAllItems, VariationKeyList)
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► RemoveFromWatchList(StringCollection, Boolean, VariationKeyTypeCollection)
Enables a user to remove one or more items from their My eBay watch list.
Declaration Syntax
C# Visual Basic Visual C++
public int RemoveFromWatchList(
    StringCollection ItemIDList,
    bool RemoveAllItems,
    VariationKeyTypeCollection VariationKeyList
)
Public Function RemoveFromWatchList ( _
    ItemIDList As StringCollection, _
    RemoveAllItems As Boolean, _
    VariationKeyList As VariationKeyTypeCollection _
) As Integer
public:
int RemoveFromWatchList(
    StringCollection^ ItemIDList,
    bool RemoveAllItems,
    VariationKeyTypeCollection^ VariationKeyList
)
Parameters
ItemIDList (StringCollection)
The ID of the item to be removed from the watch list. Either ItemID, RemoveAllItems, or VariationKey must be specified, but NOT more than one of these. Multiple ItemID fields can be specified in the same request.
RemoveAllItems (Boolean)
If true, then all the items in the user's watch list are removed. Either ItemID, RemoveAllItems, or VariationKey must be specified, but NOT more than one of these.
VariationKeyList (VariationKeyTypeCollection)
A variation (or set of variations) that you want to remove from the watch list. Either ItemID, RemoveAllItems, or VariationKey must be specified, but NOT more than one of these.


RemoveFromWatchListCall Constructor

RemoveFromWatchListCall Constructor
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► RemoveFromWatchListCall()()()()
Members
Icon | Member | Description
 | RemoveFromWatchListCall()()()() |
 | RemoveFromWatchListCall(ApiContext) |


RemoveFromWatchListCall Constructor

RemoveFromWatchListCall Constructor
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► RemoveFromWatchListCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RemoveFromWatchListCall()
Public Sub New
public:
RemoveFromWatchListCall()


RemoveFromWatchListCall Constructor (ApiContext)

RemoveFromWatchListCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► RemoveFromWatchListCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public RemoveFromWatchListCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
RemoveFromWatchListCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


VariationKeyList Property

VariationKeyList Property
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► VariationKeyList
Gets or sets the VariationKey of type VariationKeyTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public VariationKeyTypeCollection VariationKeyList { get; set; }
Public Property VariationKeyList As VariationKeyTypeCollection
    Get
    Set
public:
property VariationKeyTypeCollection^ VariationKeyList {
    VariationKeyTypeCollection^ get ();
    void set (VariationKeyTypeCollection^ value);
}


WatchListCount Property

WatchListCount Property
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► WatchListCount
Gets the returned WatchListCount of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int WatchListCount { get; }
Public ReadOnly Property WatchListCount As Integer
    Get
public:
property int WatchListCount {
    int get ();
}


WatchListMaximum Property

WatchListMaximum Property
Namespaces ► eBay.Service.Call ► RemoveFromWatchListCall ► WatchListMaximum
Gets the returned WatchListMaximum of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int WatchListMaximum { get; }
Public ReadOnly Property WatchListMaximum As Integer
    Get
public:
property int WatchListMaximum {
    int get ();
}


RespondToBestOfferCall Class

RespondToBestOfferCall Class
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class RespondToBestOfferCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class RespondToBestOfferCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class RespondToBestOfferCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RespondToBestOfferCall()()()() |
 | RespondToBestOfferCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | Action | Gets or sets the Action of type BestOfferActionCodeType.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the RespondToBestOfferRequestType for this API call.
 | ApiResponse | Gets the RespondToBestOfferResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BestOfferIDList | Gets or sets the BestOfferID of type StringCollection.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CounterOfferPrice | Gets or sets the CounterOfferPrice of type AmountType.
 | CounterOfferQuantity | Gets or sets the CounterOfferQuantity of type Int32.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | RespondToBestOffer(String, StringCollection, BestOfferActionCodeType, String, AmountType, Int32) | This call enables the seller to accept or decline a buyer's Best Offer on an item, or make a counter offer to the buyer's Best Offer. A seller can decline multiple Best Offers with one call, but the seller cannot accept or counter offer multiple Best Offers with one call. Best Offers are not applicable to auction listings.
 | RespondToBestOffer(String, StringCollection, BestOfferActionCodeType, String) | For backward compatibility with old wrappers.
 | RespondToBestOfferList | Gets the returned RespondToBestOffer of type BestOfferTypeCollection.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellerResponse | Gets or sets the SellerResponse of type String.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | RespondToBestOfferCall


Action Property

Action Property
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► Action
Gets or sets the Action of type BestOfferActionCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferActionCodeType Action { get; set; }
Public Property Action As BestOfferActionCodeType
    Get
    Set
public:
property BestOfferActionCodeType Action {
    BestOfferActionCodeType get ();
    void set (BestOfferActionCodeType value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► ApiRequest
Gets or sets the RespondToBestOfferRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RespondToBestOfferRequestType ApiRequest { get; set; }
Public Property ApiRequest As RespondToBestOfferRequestType
    Get
    Set
public:
property RespondToBestOfferRequestType^ ApiRequest {
    RespondToBestOfferRequestType^ get ();
    void set (RespondToBestOfferRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► ApiResponse
Gets the RespondToBestOfferResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RespondToBestOfferResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As RespondToBestOfferResponseType
    Get
public:
property RespondToBestOfferResponseType^ ApiResponse {
    RespondToBestOfferResponseType^ get ();
}


BestOfferIDList Property

BestOfferIDList Property
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► BestOfferIDList
Gets or sets the BestOfferID of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection BestOfferIDList { get; set; }
Public Property BestOfferIDList As StringCollection
    Get
    Set
public:
property StringCollection^ BestOfferIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


CounterOfferPrice Property

CounterOfferPrice Property
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► CounterOfferPrice
Gets or sets the CounterOfferPrice of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CounterOfferPrice { get; set; }
Public Property CounterOfferPrice As AmountType
    Get
    Set
public:
property AmountType^ CounterOfferPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


CounterOfferQuantity Property

CounterOfferQuantity Property
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► CounterOfferQuantity
Gets or sets the CounterOfferQuantity of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int CounterOfferQuantity { get; set; }
Public Property CounterOfferQuantity As Integer
    Get
    Set
public:
property int CounterOfferQuantity {
    int get ();
    void set (int value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


RespondToBestOffer Method

RespondToBestOffer Method
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► RespondToBestOffer()()()()
Members
Icon | Member | Description
 | RespondToBestOffer(String, StringCollection, BestOfferActionCodeType, String, AmountType, Int32) | This call enables the seller to accept or decline a buyer's Best Offer on an item, or make a counter offer to the buyer's Best Offer. A seller can decline multiple Best Offers with one call, but the seller cannot accept or counter offer multiple Best Offers with one call. Best Offers are not applicable to auction listings.
 | RespondToBestOffer(String, StringCollection, BestOfferActionCodeType, String) | For backward compatibility with old wrappers.


RespondToBestOffer Method (ItemID, BestOfferIDList, Action, SellerResponse)

RespondToBestOffer Method (ItemID, BestOfferIDList, Action, SellerResponse)
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► RespondToBestOffer(String, StringCollection, BestOfferActionCodeType, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection RespondToBestOffer(
    string ItemID,
    StringCollection BestOfferIDList,
    BestOfferActionCodeType Action,
    string SellerResponse
)
Public Function RespondToBestOffer ( _
    ItemID As String, _
    BestOfferIDList As StringCollection, _
    Action As BestOfferActionCodeType, _
    SellerResponse As String _
) As BestOfferTypeCollection
public:
BestOfferTypeCollection^ RespondToBestOffer(
    String^ ItemID,
    StringCollection^ BestOfferIDList,
    BestOfferActionCodeType Action,
    String^ SellerResponse
)
Parameters
ItemID (String)
BestOfferIDList (StringCollection)
Action (BestOfferActionCodeType)
SellerResponse (String)


RespondToBestOffer Method (ItemID, BestOfferIDList, Action, SellerResponse, CounterOfferPrice, CounterOfferQuantity)

RespondToBestOffer Method (ItemID, BestOfferIDList, Action, SellerResponse, CounterOfferPrice, CounterOfferQuantity)
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► RespondToBestOffer(String, StringCollection, BestOfferActionCodeType, String, AmountType, Int32)
This call enables the seller to accept or decline a buyer's Best Offer on an item, or make a counter offer to the buyer's Best Offer. A seller can decline multiple Best Offers with one call, but the seller cannot accept or counter offer multiple Best Offers with one call. Best Offers are not applicable to auction listings.
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection RespondToBestOffer(
    string ItemID,
    StringCollection BestOfferIDList,
    BestOfferActionCodeType Action,
    string SellerResponse,
    AmountType CounterOfferPrice,
    int CounterOfferQuantity
)
Public Function RespondToBestOffer ( _
    ItemID As String, _
    BestOfferIDList As StringCollection, _
    Action As BestOfferActionCodeType, _
    SellerResponse As String, _
    CounterOfferPrice As AmountType, _
    CounterOfferQuantity As Integer _
) As BestOfferTypeCollection
public:
BestOfferTypeCollection^ RespondToBestOffer(
    String^ ItemID,
    StringCollection^ BestOfferIDList,
    BestOfferActionCodeType Action,
    String^ SellerResponse,
    AmountType^ CounterOfferPrice,
    int CounterOfferQuantity
)
Parameters
ItemID (String)
The unique identifier of the listing to which the seller is responding. Specifies the item for which the BestOffer data is to be returned.
BestOfferIDList (StringCollection)
The unique identifier of a buyer's Best Offer for the item. This ID is created once the buyer makes a Best Offer. It is possible that a seller will get multiple Best Offers for an item, and if that seller would like to decline multiple/all of the Best Offers with one RespondToBestOffer call, the seller would pass in each of these identifiers in a separate BestOfferID field. However, the seller can only accept or counter offer one Best Offer at a time.
Action (BestOfferActionCodeType)
The enumeration value that the seller passes in to this field will control whether the seller accepts or make a counter offer to a single buyer's Best Offer, or declines one or more buyers' Best Offers. A seller can decline multiple Best Offers with one call, but the seller cannot accept or counter offer multiple Best Offers with one call.
SellerResponse (String)
This optional text field allows the seller to provide more details to the buyer about the action being taken against the buyer's Best Offer.
CounterOfferPrice (AmountType)
The seller inserts counter offer price into this field. This field is conditionally required and only applicable when the Action value is set to
Counter
, The counter offer price cannot exceed the Buy It Now price for a single quantity item. However, the dollar value in this field may exceed the Buy It Now price if the buyer is requesting or the seller is offering multiple quantity of the item (in a multiple-quantity listing). The quantity of the item must be specified in the CounterOfferQuantity field if the seller is making a counter offer.
CounterOfferQuantity (Int32)
The seller inserts the quantity of items in the counter offer into this field. This field is conditionally required and only applicable when the Action value is set to
Counter
, The counter offer price must be specified in the CounterOfferPrice field if the seller is making a counter offer. This price should reflect the quantity of items in the counter offer. So, if the seller's counter offer 'unit' price is 15 dollars, and the item quantity is '2', the dollar value passed into the CounterOfferPrice field would be
30.0
.


RespondToBestOfferCall Constructor

RespondToBestOfferCall Constructor
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► RespondToBestOfferCall()()()()
Members
Icon | Member | Description
 | RespondToBestOfferCall()()()() |
 | RespondToBestOfferCall(ApiContext) |


RespondToBestOfferCall Constructor

RespondToBestOfferCall Constructor
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► RespondToBestOfferCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RespondToBestOfferCall()
Public Sub New
public:
RespondToBestOfferCall()


RespondToBestOfferCall Constructor (ApiContext)

RespondToBestOfferCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► RespondToBestOfferCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public RespondToBestOfferCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
RespondToBestOfferCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


RespondToBestOfferList Property

RespondToBestOfferList Property
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► RespondToBestOfferList
Gets the returned RespondToBestOffer of type BestOfferTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection RespondToBestOfferList { get; }
Public ReadOnly Property RespondToBestOfferList As BestOfferTypeCollection
    Get
public:
property BestOfferTypeCollection^ RespondToBestOfferList {
    BestOfferTypeCollection^ get ();
}


SellerResponse Property

SellerResponse Property
Namespaces ► eBay.Service.Call ► RespondToBestOfferCall ► SellerResponse
Gets or sets the SellerResponse of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SellerResponse { get; set; }
Public Property SellerResponse As String
    Get
    Set
public:
property String^ SellerResponse {
    String^ get ();
    void set (String^ value);
}


RespondToFeedbackCall Class

RespondToFeedbackCall Class
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class RespondToFeedbackCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class RespondToFeedbackCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class RespondToFeedbackCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RespondToFeedbackCall()()()() |
 | RespondToFeedbackCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the RespondToFeedbackRequestType for this API call.
 | ApiResponse | Gets the RespondToFeedbackResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeedbackID | Gets or sets the FeedbackID of type String.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | RespondToFeedback(String, String, String, String, FeedbackResponseCodeType, String, String) | Enables a seller to reply to feedback that has been left for a user, or to post a follow-up comment to a feedback comment the user has left for someone else.
 | RespondToFeedback(String, String, String, FeedbackResponseCodeType, String) | For backward compatibility with old wrappers.
 | RespondToFeedback(String, String, FeedbackResponseCodeType, String) | For backward compatibility with old wrappers.
 | ResponseText | Gets or sets the ResponseText of type String.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ResponseType | Gets or sets the ResponseType of type FeedbackResponseCodeType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | TargetUserID | Gets or sets the TargetUserID of type String.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | RespondToFeedbackCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► ApiRequest
Gets or sets the RespondToFeedbackRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RespondToFeedbackRequestType ApiRequest { get; set; }
Public Property ApiRequest As RespondToFeedbackRequestType
    Get
    Set
public:
property RespondToFeedbackRequestType^ ApiRequest {
    RespondToFeedbackRequestType^ get ();
    void set (RespondToFeedbackRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► ApiResponse
Gets the RespondToFeedbackResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RespondToFeedbackResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As RespondToFeedbackResponseType
    Get
public:
property RespondToFeedbackResponseType^ ApiResponse {
    RespondToFeedbackResponseType^ get ();
}


FeedbackID Property

FeedbackID Property
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► FeedbackID
Gets or sets the FeedbackID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string FeedbackID { get; set; }
Public Property FeedbackID As String
    Get
    Set
public:
property String^ FeedbackID {
    String^ get ();
    void set (String^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


RespondToFeedback Method

RespondToFeedback Method
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► RespondToFeedback()()()()
Members
Icon | Member | Description
 | RespondToFeedback(String, String, String, String, FeedbackResponseCodeType, String, String) | Enables a seller to reply to feedback that has been left for a user, or to post a follow-up comment to a feedback comment the user has left for someone else.
 | RespondToFeedback(String, String, String, FeedbackResponseCodeType, String) | For backward compatibility with old wrappers.
 | RespondToFeedback(String, String, FeedbackResponseCodeType, String) | For backward compatibility with old wrappers.


RespondToFeedback Method (FeedbackID, ItemID, TransactionID, TargetUserID, ResponseType, ResponseText, OrderLineItemID)

RespondToFeedback Method (FeedbackID, ItemID, TransactionID, TargetUserID, ResponseType, ResponseText, OrderLineItemID)
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► RespondToFeedback(String, String, String, String, FeedbackResponseCodeType, String, String)
Enables a seller to reply to feedback that has been left for a user, or to post a follow-up comment to a feedback comment the user has left for someone else.
Declaration Syntax
C# Visual Basic Visual C++
public void RespondToFeedback(
    string FeedbackID,
    string ItemID,
    string TransactionID,
    string TargetUserID,
    FeedbackResponseCodeType ResponseType,
    string ResponseText,
    string OrderLineItemID
)
Public Sub RespondToFeedback ( _
    FeedbackID As String, _
    ItemID As String, _
    TransactionID As String, _
    TargetUserID As String, _
    ResponseType As FeedbackResponseCodeType, _
    ResponseText As String, _
    OrderLineItemID As String _
)
public:
void RespondToFeedback(
    String^ FeedbackID,
    String^ ItemID,
    String^ TransactionID,
    String^ TargetUserID,
    FeedbackResponseCodeType ResponseType,
    String^ ResponseText,
    String^ OrderLineItemID
)
Parameters
FeedbackID (String)
A unique identifier for a Feedback record. Buying and selling partners leave feedback for one another after the completion of an order. Feedback is left at the order line item (transaction) level, so a Feedback comment for each line item in a Combined Invoice order is expected from the buyer and seller. A unique FeedbackID is created whenever a buyer leaves feedback for a seller, and vice versa. A FeedbackID is created by eBay when feedback is left through the eBay site, or through the LeaveFeedback call. FeedbackIDs can be retrieved with the GetFeedback call. In the RespondToFeedback call, FeedbackID can be used as an input filter to respond to a specific Feedback comment. Since Feedback is always linked to a unique order line item, an ItemID/TransactionID pair or an OrderLineItemID can also be used to respond to a Feedback comment.
ItemID (String)
Unique identifier for an eBay item listing. A listing can have multiple order line items (transactions), but only one ItemID. An ItemID can be paired up with a corresponding TransactionID and used as an input filter to respond to a Feedback comment in the RespondToFeedback call. Unless the specific Feedback record is identified by a FeedbackID or an OrderLineItemID in the request, an ItemID/TransactionID pair is required.
TransactionID (String)
Unique identifier for an eBay order line item (transaction). A TransactionID can be paired up with its corresponding ItemID and used as an input filter to respond to a Feedback comment in the RespondToFeedback call. Unless the specific Feedback record is identified by a FeedbackID or an OrderLineItemID in the request, an ItemID/TransactionID pair is required.
TargetUserID (String)
The eBay user ID of the caller's order partner. The caller is either replying to or following up on this user's Feedback comment.
ResponseType (FeedbackResponseCodeType)
Specifies whether the response is a reply or a follow-up to a Feedback comment left by the user identified in the TargetUserID field.
ResponseText (String)
Textual comment that the user who is subject of feedback may leave in response or rebuttal to the Feedback comment. Alternatively, when the ResponseType is FollowUp, this value contains the text of the follow-up comment.
OrderLineItemID (String)
OrderLineItemID is a unique identifier for an eBay order line item and is based upon the concatenation of ItemID and TransactionID, with a hyphen in between these two IDs. Since Feedback is always linked to a unique order line item, an OrderLineItemID can be used to respond to a Feedback comment. Unless an ItemID/TransactionID pair or a FeedbackID is used to identify a Feedback record, the OrderLineItemID must be specified.


RespondToFeedback Method (TargetUserID, ItemID, ResponseType, ResponseText)

RespondToFeedback Method (TargetUserID, ItemID, ResponseType, ResponseText)
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► RespondToFeedback(String, String, FeedbackResponseCodeType, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void RespondToFeedback(
    string TargetUserID,
    string ItemID,
    FeedbackResponseCodeType ResponseType,
    string ResponseText
)
Public Sub RespondToFeedback ( _
    TargetUserID As String, _
    ItemID As String, _
    ResponseType As FeedbackResponseCodeType, _
    ResponseText As String _
)
public:
void RespondToFeedback(
    String^ TargetUserID,
    String^ ItemID,
    FeedbackResponseCodeType ResponseType,
    String^ ResponseText
)
Parameters
TargetUserID (String)
ItemID (String)
ResponseType (FeedbackResponseCodeType)
ResponseText (String)


RespondToFeedback Method (TargetUserID, ItemID, TransactionID, ResponseType, ResponseText)

RespondToFeedback Method (TargetUserID, ItemID, TransactionID, ResponseType, ResponseText)
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► RespondToFeedback(String, String, String, FeedbackResponseCodeType, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void RespondToFeedback(
    string TargetUserID,
    string ItemID,
    string TransactionID,
    FeedbackResponseCodeType ResponseType,
    string ResponseText
)
Public Sub RespondToFeedback ( _
    TargetUserID As String, _
    ItemID As String, _
    TransactionID As String, _
    ResponseType As FeedbackResponseCodeType, _
    ResponseText As String _
)
public:
void RespondToFeedback(
    String^ TargetUserID,
    String^ ItemID,
    String^ TransactionID,
    FeedbackResponseCodeType ResponseType,
    String^ ResponseText
)
Parameters
TargetUserID (String)
ItemID (String)
TransactionID (String)
ResponseType (FeedbackResponseCodeType)
ResponseText (String)


RespondToFeedbackCall Constructor

RespondToFeedbackCall Constructor
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► RespondToFeedbackCall()()()()
Members
Icon | Member | Description
 | RespondToFeedbackCall()()()() |
 | RespondToFeedbackCall(ApiContext) |


RespondToFeedbackCall Constructor

RespondToFeedbackCall Constructor
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► RespondToFeedbackCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RespondToFeedbackCall()
Public Sub New
public:
RespondToFeedbackCall()


RespondToFeedbackCall Constructor (ApiContext)

RespondToFeedbackCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► RespondToFeedbackCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public RespondToFeedbackCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
RespondToFeedbackCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ResponseText Property

ResponseText Property
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► ResponseText
Gets or sets the ResponseText of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ResponseText { get; set; }
Public Property ResponseText As String
    Get
    Set
public:
property String^ ResponseText {
    String^ get ();
    void set (String^ value);
}


ResponseType Property

ResponseType Property
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► ResponseType
Gets or sets the ResponseType of type FeedbackResponseCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackResponseCodeType ResponseType { get; set; }
Public Property ResponseType As FeedbackResponseCodeType
    Get
    Set
public:
property FeedbackResponseCodeType ResponseType {
    FeedbackResponseCodeType get ();
    void set (FeedbackResponseCodeType value);
}


TargetUserID Property

TargetUserID Property
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► TargetUserID
Gets or sets the TargetUserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TargetUserID { get; set; }
Public Property TargetUserID As String
    Get
    Set
public:
property String^ TargetUserID {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► RespondToFeedbackCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


ReviseCheckoutStatusCall Class

ReviseCheckoutStatusCall Class
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ReviseCheckoutStatusCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ReviseCheckoutStatusCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ReviseCheckoutStatusCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseCheckoutStatusCall()()()() |
 | ReviseCheckoutStatusCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AdjustmentAmount | Gets or sets the AdjustmentAmount of type AmountType.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | AmountPaid | Gets or sets the AmountPaid of type AmountType.
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ReviseCheckoutStatusRequestType for this API call.
 | ApiResponse | Gets the ReviseCheckoutStatusResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BuyerID | Gets or sets the BuyerID of type String.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CheckoutMethod | Gets or sets the CheckoutMethod of type CheckoutMethodCodeType.
 | CheckoutStatus | Gets or sets the CheckoutStatus of type CompleteStatusCodeType.
 | CODCost | Gets or sets the CODCost of type AmountType.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EncryptedID | Gets or sets the EncryptedID of type String.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | ExternalTransaction | Gets or sets the ExternalTransaction of type ExternalTransactionType.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InsuranceType | Gets or sets the InsuranceType of type InsuranceSelectedCodeType.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MultipleSellerPaymentID | Gets or sets the MultipleSellerPaymentID of type String.
 | OrderID | Gets or sets the OrderID of type String.
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | PaymentMethodUsed | Gets or sets the PaymentMethodUsed of type BuyerPaymentMethodCodeType.
 | PaymentStatus | Gets or sets the PaymentStatus of type RCSPaymentStatusCodeType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReviseCheckoutStatus(String, String, String, AmountType, BuyerPaymentMethodCodeType, CompleteStatusCodeType, String, Boolean, CheckoutMethodCodeType, InsuranceSelectedCodeType, RCSPaymentStatusCodeType, AmountType, AddressType, String, AmountType, AmountType, AmountType, String, ExternalTransactionType, String, AmountType, String) | Enables a seller to update the payment details, the shipping details, and the status of an order.
 | ReviseCheckoutStatus(String, String, CompleteStatusCodeType) | For backward compatibility with old wrappers.
 | ReviseCheckoutStatus(String, CompleteStatusCodeType) | For backward compatibility with old wrappers.
 | SalesTax | Gets or sets the SalesTax of type AmountType.
 | ShippingAddress | Gets or sets the ShippingAddress of type AddressType.
 | ShippingCost | Gets or sets the ShippingCost of type AmountType.
 | ShippingIncludedInTax | Gets or sets the ShippingIncludedInTax of type Boolean.
 | ShippingInsuranceCost | Gets or sets the ShippingInsuranceCost of type AmountType.
 | ShippingService | Gets or sets the ShippingService of type String.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ReviseCheckoutStatusCall


AdjustmentAmount Property

AdjustmentAmount Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► AdjustmentAmount
Gets or sets the AdjustmentAmount of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AdjustmentAmount { get; set; }
Public Property AdjustmentAmount As AmountType
    Get
    Set
public:
property AmountType^ AdjustmentAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


AmountPaid Property

AmountPaid Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► AmountPaid
Gets or sets the AmountPaid of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AmountPaid { get; set; }
Public Property AmountPaid As AmountType
    Get
    Set
public:
property AmountType^ AmountPaid {
    AmountType^ get ();
    void set (AmountType^ value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ApiRequest
Gets or sets the ReviseCheckoutStatusRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseCheckoutStatusRequestType ApiRequest { get; set; }
Public Property ApiRequest As ReviseCheckoutStatusRequestType
    Get
    Set
public:
property ReviseCheckoutStatusRequestType^ ApiRequest {
    ReviseCheckoutStatusRequestType^ get ();
    void set (ReviseCheckoutStatusRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ApiResponse
Gets the ReviseCheckoutStatusResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseCheckoutStatusResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ReviseCheckoutStatusResponseType
    Get
public:
property ReviseCheckoutStatusResponseType^ ApiResponse {
    ReviseCheckoutStatusResponseType^ get ();
}


BuyerID Property

BuyerID Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► BuyerID
Gets or sets the BuyerID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string BuyerID { get; set; }
Public Property BuyerID As String
    Get
    Set
public:
property String^ BuyerID {
    String^ get ();
    void set (String^ value);
}


CheckoutMethod Property

CheckoutMethod Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► CheckoutMethod
Gets or sets the CheckoutMethod of type CheckoutMethodCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public CheckoutMethodCodeType CheckoutMethod { get; set; }
Public Property CheckoutMethod As CheckoutMethodCodeType
    Get
    Set
public:
property CheckoutMethodCodeType CheckoutMethod {
    CheckoutMethodCodeType get ();
    void set (CheckoutMethodCodeType value);
}


CheckoutStatus Property

CheckoutStatus Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► CheckoutStatus
Gets or sets the CheckoutStatus of type CompleteStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public CompleteStatusCodeType CheckoutStatus { get; set; }
Public Property CheckoutStatus As CompleteStatusCodeType
    Get
    Set
public:
property CompleteStatusCodeType CheckoutStatus {
    CompleteStatusCodeType get ();
    void set (CompleteStatusCodeType value);
}


CODCost Property

CODCost Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► CODCost
Gets or sets the CODCost of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CODCost { get; set; }
Public Property CODCost As AmountType
    Get
    Set
public:
property AmountType^ CODCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


EncryptedID Property

EncryptedID Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► EncryptedID
Gets or sets the EncryptedID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string EncryptedID { get; set; }
Public Property EncryptedID As String
    Get
    Set
public:
property String^ EncryptedID {
    String^ get ();
    void set (String^ value);
}


ExternalTransaction Property

ExternalTransaction Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ExternalTransaction
Gets or sets the ExternalTransaction of type ExternalTransactionType.
Declaration Syntax
C# Visual Basic Visual C++
public ExternalTransactionType ExternalTransaction { get; set; }
Public Property ExternalTransaction As ExternalTransactionType
    Get
    Set
public:
property ExternalTransactionType^ ExternalTransaction {
    ExternalTransactionType^ get ();
    void set (ExternalTransactionType^ value);
}


InsuranceType Property

InsuranceType Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► InsuranceType
Gets or sets the InsuranceType of type InsuranceSelectedCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceSelectedCodeType InsuranceType { get; set; }
Public Property InsuranceType As InsuranceSelectedCodeType
    Get
    Set
public:
property InsuranceSelectedCodeType InsuranceType {
    InsuranceSelectedCodeType get ();
    void set (InsuranceSelectedCodeType value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MultipleSellerPaymentID Property

MultipleSellerPaymentID Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► MultipleSellerPaymentID
Gets or sets the MultipleSellerPaymentID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string MultipleSellerPaymentID { get; set; }
Public Property MultipleSellerPaymentID As String
    Get
    Set
public:
property String^ MultipleSellerPaymentID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► OrderID
Gets or sets the OrderID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


PaymentMethodUsed Property

PaymentMethodUsed Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► PaymentMethodUsed
Gets or sets the PaymentMethodUsed of type BuyerPaymentMethodCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeType PaymentMethodUsed { get; set; }
Public Property PaymentMethodUsed As BuyerPaymentMethodCodeType
    Get
    Set
public:
property BuyerPaymentMethodCodeType PaymentMethodUsed {
    BuyerPaymentMethodCodeType get ();
    void set (BuyerPaymentMethodCodeType value);
}


PaymentStatus Property

PaymentStatus Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► PaymentStatus
Gets or sets the PaymentStatus of type RCSPaymentStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public RCSPaymentStatusCodeType PaymentStatus { get; set; }
Public Property PaymentStatus As RCSPaymentStatusCodeType
    Get
    Set
public:
property RCSPaymentStatusCodeType PaymentStatus {
    RCSPaymentStatusCodeType get ();
    void set (RCSPaymentStatusCodeType value);
}


ReviseCheckoutStatus Method

ReviseCheckoutStatus Method
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ReviseCheckoutStatus()()()()
Members
Icon | Member | Description
 | ReviseCheckoutStatus(String, String, String, AmountType, BuyerPaymentMethodCodeType, CompleteStatusCodeType, String, Boolean, CheckoutMethodCodeType, InsuranceSelectedCodeType, RCSPaymentStatusCodeType, AmountType, AddressType, String, AmountType, AmountType, AmountType, String, ExternalTransactionType, String, AmountType, String) | Enables a seller to update the payment details, the shipping details, and the status of an order.
 | ReviseCheckoutStatus(String, String, CompleteStatusCodeType) | For backward compatibility with old wrappers.
 | ReviseCheckoutStatus(String, CompleteStatusCodeType) | For backward compatibility with old wrappers.


ReviseCheckoutStatus Method (ItemID, TransactionID, CheckoutStatus)

ReviseCheckoutStatus Method (ItemID, TransactionID, CheckoutStatus)
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ReviseCheckoutStatus(String, String, CompleteStatusCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void ReviseCheckoutStatus(
    string ItemID,
    string TransactionID,
    CompleteStatusCodeType CheckoutStatus
)
Public Sub ReviseCheckoutStatus ( _
    ItemID As String, _
    TransactionID As String, _
    CheckoutStatus As CompleteStatusCodeType _
)
public:
void ReviseCheckoutStatus(
    String^ ItemID,
    String^ TransactionID,
    CompleteStatusCodeType CheckoutStatus
)
Parameters
ItemID (String)
TransactionID (String)
CheckoutStatus (CompleteStatusCodeType)


ReviseCheckoutStatus Method (ItemID, TransactionID, OrderID, AmountPaid, PaymentMethodUsed, CheckoutStatus, ShippingService, ShippingIncludedInTax, CheckoutMethod, InsuranceType, PaymentStatus, AdjustmentAmount, ShippingAddress, BuyerID, ShippingInsuranceCost, SalesTax, ShippingCost, EncryptedID, Ex

ReviseCheckoutStatus Method (ItemID, TransactionID, OrderID, AmountPaid, PaymentMethodUsed, CheckoutStatus, ShippingService, ShippingIncludedInTax, CheckoutMethod, InsuranceType, PaymentStatus, AdjustmentAmount, ShippingAddress, BuyerID, ShippingInsuranceCost, SalesTax, ShippingCost, EncryptedID, ExternalTransaction, MultipleSellerPaymentID, CODCost, OrderLineItemID)
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ReviseCheckoutStatus(String, String, String, AmountType, BuyerPaymentMethodCodeType, CompleteStatusCodeType, String, Boolean, CheckoutMethodCodeType, InsuranceSelectedCodeType, RCSPaymentStatusCodeType, AmountType, AddressType, String, AmountType, AmountType, AmountType, String, ExternalTransactionType, String, AmountType, String)
Enables a seller to update the payment details, the shipping details, and the status of an order.
Declaration Syntax
C# Visual Basic Visual C++
public void ReviseCheckoutStatus(
    string ItemID,
    string TransactionID,
    string OrderID,
    AmountType AmountPaid,
    BuyerPaymentMethodCodeType PaymentMethodUsed,
    CompleteStatusCodeType CheckoutStatus,
    string ShippingService,
    bool ShippingIncludedInTax,
    CheckoutMethodCodeType CheckoutMethod,
    InsuranceSelectedCodeType InsuranceType,
    RCSPaymentStatusCodeType PaymentStatus,
    AmountType AdjustmentAmount,
    AddressType ShippingAddress,
    string BuyerID,
    AmountType ShippingInsuranceCost,
    AmountType SalesTax,
    AmountType ShippingCost,
    string EncryptedID,
    ExternalTransactionType ExternalTransaction,
    string MultipleSellerPaymentID,
    AmountType CODCost,
    string OrderLineItemID
)
Public Sub ReviseCheckoutStatus ( _
    ItemID As String, _
    TransactionID As String, _
    OrderID As String, _
    AmountPaid As AmountType, _
    PaymentMethodUsed As BuyerPaymentMethodCodeType, _
    CheckoutStatus As CompleteStatusCodeType, _
    ShippingService As String, _
    ShippingIncludedInTax As Boolean, _
    CheckoutMethod As CheckoutMethodCodeType, _
    InsuranceType As InsuranceSelectedCodeType, _
    PaymentStatus As RCSPaymentStatusCodeType, _
    AdjustmentAmount As AmountType, _
    ShippingAddress As AddressType, _
    BuyerID As String, _
    ShippingInsuranceCost As AmountType, _
    SalesTax As AmountType, _
    ShippingCost As AmountType, _
    EncryptedID As String, _
    ExternalTransaction As ExternalTransactionType, _
    MultipleSellerPaymentID As String, _
    CODCost As AmountType, _
    OrderLineItemID As String _
)
public:
void ReviseCheckoutStatus(
    String^ ItemID,
    String^ TransactionID,
    String^ OrderID,
    AmountType^ AmountPaid,
    BuyerPaymentMethodCodeType PaymentMethodUsed,
    CompleteStatusCodeType CheckoutStatus,
    String^ ShippingService,
    bool ShippingIncludedInTax,
    CheckoutMethodCodeType CheckoutMethod,
    InsuranceSelectedCodeType InsuranceType,
    RCSPaymentStatusCodeType PaymentStatus,
    AmountType^ AdjustmentAmount,
    AddressType^ ShippingAddress,
    String^ BuyerID,
    AmountType^ ShippingInsuranceCost,
    AmountType^ SalesTax,
    AmountType^ ShippingCost,
    String^ EncryptedID,
    ExternalTransactionType^ ExternalTransaction,
    String^ MultipleSellerPaymentID,
    AmountType^ CODCost,
    String^ OrderLineItemID
)
Parameters
ItemID (String)
Unique identifier for an eBay item listing. A listing can have multiple order line items (transactions), but only one ItemID. An ItemID can be paired up with a corresponding TransactionID and used as an input filter for ReviseCheckoutStatus. Unless an OrderLineItemID is used to identify a single line item order, or the OrderID is used to identify a single or multiple line item (Combined Invoice) order, the ItemID/TransactionID pair must be specified. For a multiple line item (Combined Invoice) order, OrderID should be used. If OrderID or OrderLineItemID are specified, the ItemID/TransactionID pair is ignored if present in the same request.

It is also possible to identify a single line item order with a ItemID/BuyerID combination, but this is not the most ideal approach since an error is returned if there are multiple order line items for that combination.
TransactionID (String)
Unique identifier for an eBay order line item (transaction). An order line item is created once there is a commitment from a buyer to purchase an item. Since an auction listing can only have one order line item during the duration of the listing, the TransactionID for auction listings is always 0. Along with its corresponding ItemID, a TransactionID is used and referenced during an order checkout flow and after checkout has been completed. The ItemID/TransactionID pair can be used as an input filter for ReviseCheckoutStatus. Unless an OrderLineItemID is used to identify a single line item order, or the OrderID is used to identify a single or multiple line item (Combined Invoice) order, the ItemID/TransactionID pair must be specified. For a multiple line item (Combined Invoice) order, OrderID must be used. If OrderID or OrderLineItemID are specified, the ItemID/TransactionID pair is ignored if present in the same request.
OrderID (String)
A unique identifier that identifies a single line item or multiple line item (Combined Invoice) order. For a single line item order, the OrderID value is identical to the OrderLineItemID value that is generated upon creation of the order line item. For a Combined Invoice order, the OrderID value is created by eBay when the buyer or seller (sharing multiple, common order line items) combines multiple order line items into a Combined Invoice order through the eBay site. A Combined Invoice order can also be created by the seller through the AddOrder call. The OrderID can be used as an input filter for ReviseCheckoutStatus. OrderID overrides an OrderLineItemID or ItemID/TransactionID pair if these fields are also specified in the same request.
AmountPaid (AmountType)
The total amount paid by the buyer. For a motor vehicle purchased on eBay Motors, AmountPaid is the total amount paid by the buyer for the deposit. AmountPaid is optional if CheckoutStatus is Incomplete and required if it is Complete.
PaymentMethodUsed (BuyerPaymentMethodCodeType)
Payment method used by the buyer. This field is required if CheckoutStatus is Complete and the payment method is a trusted payment method other than PayPal. See eBay's Accepted Payments Policy. If the payment method is PayPal, this field should not be used since only PayPal can set this field's value to "PayPal". ReviseCheckoutStatus cannot be used for a non-trusted payment method. Note:Required or allowed payment methods vary by site and category.
CheckoutStatus (CompleteStatusCodeType)
The current checkout status of the order. Often, the seller or application will mark this value as 'Complete' if payment has been made.
ShippingService (String)
The shipping service selected by the buyer from among the shipping services offered by the seller (such as UPS Ground). For a list of valid values, call GeteBayDetails with DetailName set to ShippingServiceDetails. The ShippingServiceDetails.ValidForSellingFlow flag must also be present. Otherwise, that particular shipping service option is no longer valid and cannot be offered to buyers through a listing.

Note:ReviseCheckoutStatus is not available for the Global Shipping program; specifying InternationalPriorityShipping as a value for this field will produce an error.
ShippingIncludedInTax (Boolean)
An indicator of whether shipping costs were included in the taxable amount. .
CheckoutMethod (CheckoutMethodCodeType)
InsuranceType (InsuranceSelectedCodeType)
Enumeration value that indicates whether shipping insurance was offered to and selected by the buyer.
PaymentStatus (RCSPaymentStatusCodeType)
This field is used to mark the order as paid or awaiting payment in My eBay. If you specify 'Paid', My eBay displays an icon for each line item in the order to indicate that the order status is Paid. If you specify 'Pending', this indicates that the order is awaiting payment (some applications may use 'Pending' when the buyer has paid, but the funds have not yet been sent to the seller's financial institution). ReviseCheckoutStatus cannot be used to update payment and checkout status for a non-trusted payment method. See eBay's Accepted Payments Policy for more information on trusted payment methods. If the payment method is PayPal, this field should not be used since PayPal automatically set this field's value to "Paid" upon receiving the buyer's payment.
AdjustmentAmount (AmountType)
Discount or charge agreed to by the buyer and seller. A positive value indicates that the amount is an extra charge being paid to the seller by the buyer. A negative value indicates that the amount is a discount given to the buyer by the seller.
ShippingAddress (AddressType)
For internal use.
BuyerID (String)
eBay user ID for the order's buyer. A single line item order can actually be identified by a BuyerID/ItemID pair, but this approach is not recommended since an error is returned if there are multiple order line items for that combination. BuyerID is ignored if any other valid filter or filter combination is used in the same request.
ShippingInsuranceCost (AmountType)
The amount of money paid for shipping insurance.
SalesTax (AmountType)
The sales tax amount for the order. This field should be used if sales tax was applied to the order.
ShippingCost (AmountType)
The amount of money paid for shipping.
EncryptedID (String)
Not supported.
ExternalTransaction (ExternalTransactionType)
This container is used to identify the electronic payment (other than Paypal) of an order.
MultipleSellerPaymentID (String)
Not supported.
CODCost (AmountType)
This dollar value indicates the money due from the buyer upon delivery of the item. This field should only be specified in the ReviseCheckoutStatus request if 'COD' (cash-on-delivery) was the payment method selected by the buyer and it is included as the PaymentMethodUsed value in the same request.
OrderLineItemID (String)
OrderLineItemID is a unique identifier for an eBay order line item and is based upon the concatenation of ItemID and TransactionID, with a hyphen in between these two IDs. For a single line item order, the OrderLineItemID value can be passed into the OrderID field to revise the checkout status of the order. Unless an ItemID/TransactionID pair is used to identify a single line item order, or the OrderID is used to identify a single or multiple line item (Combined Invoice) order, the OrderLineItemID must be specified. For a multiple line item (Combined Invoice) order, OrderID should be used. If OrderLineItemID is specified, the ItemID/TransactionID pair are ignored if present in the same request.


ReviseCheckoutStatus Method (OrderID, CheckoutStatus)

ReviseCheckoutStatus Method (OrderID, CheckoutStatus)
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ReviseCheckoutStatus(String, CompleteStatusCodeType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void ReviseCheckoutStatus(
    string OrderID,
    CompleteStatusCodeType CheckoutStatus
)
Public Sub ReviseCheckoutStatus ( _
    OrderID As String, _
    CheckoutStatus As CompleteStatusCodeType _
)
public:
void ReviseCheckoutStatus(
    String^ OrderID,
    CompleteStatusCodeType CheckoutStatus
)
Parameters
OrderID (String)
CheckoutStatus (CompleteStatusCodeType)


ReviseCheckoutStatusCall Constructor

ReviseCheckoutStatusCall Constructor
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ReviseCheckoutStatusCall()()()()
Members
Icon | Member | Description
 | ReviseCheckoutStatusCall()()()() |
 | ReviseCheckoutStatusCall(ApiContext) |


ReviseCheckoutStatusCall Constructor

ReviseCheckoutStatusCall Constructor
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ReviseCheckoutStatusCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseCheckoutStatusCall()
Public Sub New
public:
ReviseCheckoutStatusCall()


ReviseCheckoutStatusCall Constructor (ApiContext)

ReviseCheckoutStatusCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ReviseCheckoutStatusCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseCheckoutStatusCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ReviseCheckoutStatusCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SalesTax Property

SalesTax Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► SalesTax
Gets or sets the SalesTax of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType SalesTax { get; set; }
Public Property SalesTax As AmountType
    Get
    Set
public:
property AmountType^ SalesTax {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingAddress Property

ShippingAddress Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ShippingAddress
Gets or sets the ShippingAddress of type AddressType.
Declaration Syntax
C# Visual Basic Visual C++
public AddressType ShippingAddress { get; set; }
Public Property ShippingAddress As AddressType
    Get
    Set
public:
property AddressType^ ShippingAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


ShippingCost Property

ShippingCost Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ShippingCost
Gets or sets the ShippingCost of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingCost { get; set; }
Public Property ShippingCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingIncludedInTax Property

ShippingIncludedInTax Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ShippingIncludedInTax
Gets or sets the ShippingIncludedInTax of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingIncludedInTax { get; set; }
Public Property ShippingIncludedInTax As Boolean
    Get
    Set
public:
property bool ShippingIncludedInTax {
    bool get ();
    void set (bool value);
}


ShippingInsuranceCost Property

ShippingInsuranceCost Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ShippingInsuranceCost
Gets or sets the ShippingInsuranceCost of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingInsuranceCost { get; set; }
Public Property ShippingInsuranceCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingInsuranceCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingService Property

ShippingService Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► ShippingService
Gets or sets the ShippingService of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingService { get; set; }
Public Property ShippingService As String
    Get
    Set
public:
property String^ ShippingService {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► ReviseCheckoutStatusCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


ReviseFixedPriceItemCall Class

ReviseFixedPriceItemCall Class
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ReviseFixedPriceItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ReviseFixedPriceItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ReviseFixedPriceItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseFixedPriceItemCall()()()() |
 | ReviseFixedPriceItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ReviseFixedPriceItemRequestType for this API call.
 | ApiResponse | Gets the ReviseFixedPriceItemResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Category2ID | Gets the returned Category2ID of type String.
 | CategoryID | Gets the returned CategoryID of type String.
 | DeletedFieldList | Gets or sets the DeletedField of type StringCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DiscountReasonList | Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | (Overrides ApiCall.Execute()()()().)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | ItemID | Gets the returned ItemID of type String.
 | ListingRecommendations | Gets the returned ListingRecommendations of type ListingRecommendationsType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PictureFileList |
 | ProductSuggestions | Gets the returned ProductSuggestions of type ProductSuggestionsType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReviseFixedPriceItem(ItemType, StringCollection) | Enables a seller to change the properties of a currently active fixed-price listing (including multi-variation listings).
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SKU | Gets the returned SKU of type String.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ReviseFixedPriceItemCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► ApiRequest
Gets or sets the ReviseFixedPriceItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseFixedPriceItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As ReviseFixedPriceItemRequestType
    Get
    Set
public:
property ReviseFixedPriceItemRequestType^ ApiRequest {
    ReviseFixedPriceItemRequestType^ get ();
    void set (ReviseFixedPriceItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► ApiResponse
Gets the ReviseFixedPriceItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseFixedPriceItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ReviseFixedPriceItemResponseType
    Get
public:
property ReviseFixedPriceItemResponseType^ ApiResponse {
    ReviseFixedPriceItemResponseType^ get ();
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► Category2ID
Gets the returned Category2ID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; }
Public ReadOnly Property Category2ID As String
    Get
public:
property String^ Category2ID {
    String^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► CategoryID
Gets the returned CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; }
Public ReadOnly Property CategoryID As String
    Get
public:
property String^ CategoryID {
    String^ get ();
}


DeletedFieldList Property

DeletedFieldList Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► DeletedFieldList
Gets or sets the DeletedField of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedFieldList { get; set; }
Public Property DeletedFieldList As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedFieldList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


DiscountReasonList Property

DiscountReasonList Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► DiscountReasonList
Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReasonList { get; }
Public ReadOnly Property DiscountReasonList As DiscountReasonCodeTypeCollection
    Get
public:
property DiscountReasonCodeTypeCollection^ DiscountReasonList {
    DiscountReasonCodeTypeCollection^ get ();
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


Execute Method

Execute Method
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► Execute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Execute()
Public Overrides Sub Execute
public:
virtual void Execute() override


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► ItemID
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; }
Public ReadOnly Property ItemID As String
    Get
public:
property String^ ItemID {
    String^ get ();
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► ListingRecommendations
Gets the returned ListingRecommendations of type ListingRecommendationsType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; }
Public ReadOnly Property ListingRecommendations As ListingRecommendationsType
    Get
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
}


PictureFileList Property

PictureFileList Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► PictureFileList
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureFileList { get; set; }
Public Property PictureFileList As StringCollection
    Get
    Set
public:
property StringCollection^ PictureFileList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► ProductSuggestions
Gets the returned ProductSuggestions of type ProductSuggestionsType.
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; }
Public ReadOnly Property ProductSuggestions As ProductSuggestionsType
    Get
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
}


ReviseFixedPriceItem Method (Item, DeletedFieldList)

ReviseFixedPriceItem Method (Item, DeletedFieldList)
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► ReviseFixedPriceItem(ItemType, StringCollection)
Enables a seller to change the properties of a currently active fixed-price listing (including multi-variation listings).
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection ReviseFixedPriceItem(
    ItemType Item,
    StringCollection DeletedFieldList
)
Public Function ReviseFixedPriceItem ( _
    Item As ItemType, _
    DeletedFieldList As StringCollection _
) As FeeTypeCollection
public:
FeeTypeCollection^ ReviseFixedPriceItem(
    ItemType^ Item,
    StringCollection^ DeletedFieldList
)
Parameters
Item (ItemType)
Child elements hold the values for item details that you want to change. The Item.ItemID must always be set to the ID of the listing being changed. Only specify Item fields for the details that are changing. Unless otherwise specified in the field descriptions below, the listing retains its existing values for fields that you don't pass in the ReviseFixedPriceItem request. Use DeletedField to remove a field from the listing.
DeletedFieldList (StringCollection)
Specifies the name of a field to delete from a listing. The request can contain zero, one, or many instances of DeletedField (one for each field to be deleted). See the relevant field descriptions to determine when to use DeletedField (and potential consequences). You cannot delete required fields from a listing. Some fields are optional when you first list an item (e.g., SecondaryCategory), but once they are set they cannot be deleted when you revise an item. Some optional fields cannot be deleted if the item has bids and/or ends within 12 hours. Some optional fields cannot be deleted if other fields depend on them. See the eBay Trading API guide for rules on removing values when revising items. Some data (such as Variation nodes within Variations) can't be deleted by using DeletedFields. See the relevant field descriptions for how to delete such data. DeletedField accepts the following path names, which delete the corresponding nodes: Item.ApplicationData Item.AttributeSetArray Item.ConditionID Item.ItemSpecifics Item.ListingCheckoutRedirectPreference.ProStoresStoreName Item.ListingCheckoutRedirectPreference.SellerThirdPartyUsername Item.ListingDesigner.LayoutID Item.ListingDesigner.ThemeID Item.ListingEnhancement[Value] Item.PayPalEmailAddress Item.PictureDetails.GalleryURL Item.PictureDetails.PictureURL Item.PostalCode Item.ProductListingDetails Item.SellerContactDetails Item.SellerContactDetails.CompanyName Item.SellerContactDetails.County Item.SellerContactDetails.InternationalStreet Item.SellerContactDetails.Phone2AreaOrCityCode Item.SellerContactDetails.Phone2CountryCode Item.SellerContactDetails.Phone2CountryPrefix Item.SellerContactDetails.Phone2LocalNumber Item.SellerContactDetails.PhoneAreaOrCityCode Item.SellerContactDetails.PhoneCountryCode Item.SellerContactDetails.PhoneCountryPrefix Item.SellerContactDetails.PhoneLocalNumber Item.SellerContactDetails.Street Item.SellerContactDetails.Street2 Item.ShippingDetails.PaymentInstructions Item.ShippingServiceCostOverrideList Item.SKU (unless InventoryTrackingMethod is SKU) Item.SubTitle These values are case-sensitive. Use values that match the case of the schema element names (Item.PictureDetails.GalleryURL) or make the initial letter of each field name lowercase (item.pictureDetails.galleryURL). However, do not change the case of letters in the middle of a field name. For example, item.picturedetails.galleryUrl is not allowed. To delete a listing enhancement like BoldTitle, specify the value you are deleting in square brackets ("[ ]"); for example, Item.ListingEnhancement[BoldTitle].


ReviseFixedPriceItemCall Constructor

ReviseFixedPriceItemCall Constructor
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► ReviseFixedPriceItemCall()()()()
Members
Icon | Member | Description
 | ReviseFixedPriceItemCall()()()() |
 | ReviseFixedPriceItemCall(ApiContext) |


ReviseFixedPriceItemCall Constructor

ReviseFixedPriceItemCall Constructor
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► ReviseFixedPriceItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseFixedPriceItemCall()
Public Sub New
public:
ReviseFixedPriceItemCall()


ReviseFixedPriceItemCall Constructor (ApiContext)

ReviseFixedPriceItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► ReviseFixedPriceItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseFixedPriceItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ReviseFixedPriceItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SKU Property

SKU Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► SKU
Gets the returned SKU of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; }
Public ReadOnly Property SKU As String
    Get
public:
property String^ SKU {
    String^ get ();
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► ReviseFixedPriceItemCall ► StartTime
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}


ReviseInventoryStatusCall Class

ReviseInventoryStatusCall Class
Namespaces ► eBay.Service.Call ► ReviseInventoryStatusCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ReviseInventoryStatusCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ReviseInventoryStatusCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ReviseInventoryStatusCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon Member Description
ReviseInventoryStatusCall()()()()

ReviseInventoryStatusCall(ApiContext)

AbstractRequest
Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests.
(Inherited from ApiCall.)
AbstractResponse
Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses.
(Inherited from ApiCall.)
AfterRequest
Occurs after the API call returns the response.
(Inherited from ApiCall.)
ApiCallBase
The base interface object.

ApiContext
Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics.
(Inherited from ApiCall.)
ApiException
Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object.
(Inherited from ApiCall.)
ApiRequest
Gets or sets the ReviseInventoryStatusRequestType for this API call.

ApiResponse
Gets the ReviseInventoryStatusResponseType for this API call.

BeforeRequest
Occurs before the API call is sent.
(Inherited from ApiCall.)
CallMetricsEntry
Holds the call metrics object used to optionally track client and server side latencies.
(Inherited from ApiCall.)
CallRetry
Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext.
(Inherited from ApiCall.)
DetailLevelList
Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html
(Inherited from ApiCall.)
DetailLevelOverride
Prevents DetailLevelList from being sent if set to true.
(Inherited from ApiCall.)
EnableCompression
Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance.
(Inherited from ApiCall.)
Equals(Object) (Inherited from Object.)
Execute()()()()
Sends the Api call request AbstractRequest to eBay.
(Inherited from ApiCall.)
ExecuteRequest(AbstractRequestType)
Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest.
(Inherited from ApiCall.)
FeeList
Gets the returned Fees of type InventoryFeesTypeCollection.

Finalize()()()() (Inherited from Object.)
GetHashCode()()()() (Inherited from Object.)
GetSecurityHeader()()()()
Constructs a security header from values in ApiContext.
(Inherited from ApiCall.)
GetType()()()() (Inherited from Object.)
HasError
Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error.
(Inherited from ApiCall.)
HasWarning
An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.)
(Inherited from ApiCall.)
InterfaceServiceType
Reserved for eBay internal use. The type to be used to create the Web Service service instance.
(Inherited from ApiCall.)
InventoryStatuList
Gets or sets the InventoryStatus of type InventoryStatusTypeCollection.

InventoryStatuListReturn
Gets the returned InventoryStatus of type InventoryStatusTypeCollection.

LogMessage(String, MessageType, MessageSeverity)
Log the message information under the specified type and severity.
(Inherited from ApiCall.)
LogMessagePayload(String, MessageSeverity, Exception)
Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage.
(Inherited from ApiCall.)
MemberwiseClone()()()() (Inherited from Object.)
OutputSelector
(Inherited from ApiCall.)
ResponseTime
Gets the time the API Call took to respond of type TimeSpan
(Inherited from ApiCall.)
ReviseInventoryStatus(InventoryStatusTypeCollection)
Enables a seller to change the price and quantity of a currently- active, fixed-price listing. Using ReviseInventoryStatus to modify data qualifies as revising the listing. Inputs are the item IDs or SKUs of the listings being revised, and the price and quantity that are being changed for each revision. Only applicable to fixed-price listings. Changing the price or quantity of a currently- active, fixed-price listing does not reset the Best Match performance score. For Best Match information related to multi-variation listings, see the Best Match information at the following topic: Multi-quantity Fixed Price listings with variations. As with all listing calls, the site you specify in the request URL (for SOAP) or the X-EBAY-API-SITEID HTTP header (for XML) should match the original listing's Item.Site value. In particular, this is a best practice when you submit new and revised listings. For Large Merchant Services users: When you use ReviseInventoryStatus within a Merchant Data file, it must be enclosed within two BulkDataExchangeRequest tags. A namespace is returned in the BulkDataExchangeResponseType (top level) of the response. The BulkDataExchange tags are not shown in the call input/output descriptions.

Site
Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified.
(Inherited from ApiCall.)
SoapRequest
Gets the last raw web service request of type String
(Inherited from ApiCall.)
SoapResponse
Gets the last raw web service response of type String
(Inherited from ApiCall.)
Timeout
Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds.
(Inherited from ApiCall.)
ToString()()()() (Inherited from Object.)
Version
Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call.
(Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ReviseInventoryStatusCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ReviseInventoryStatusCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ReviseInventoryStatusCall ► ApiRequest
Gets or sets the ReviseInventoryStatusRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseInventoryStatusRequestType ApiRequest { get; set; }
Public Property ApiRequest As ReviseInventoryStatusRequestType
    Get
    Set
public:
property ReviseInventoryStatusRequestType^ ApiRequest {
    ReviseInventoryStatusRequestType^ get ();
    void set (ReviseInventoryStatusRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ReviseInventoryStatusCall ► ApiResponse
Gets the ReviseInventoryStatusResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseInventoryStatusResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ReviseInventoryStatusResponseType
    Get
public:
property ReviseInventoryStatusResponseType^ ApiResponse {
    ReviseInventoryStatusResponseType^ get ();
}


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► ReviseInventoryStatusCall ► FeeList
Gets the returned Fees of type InventoryFeesTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public InventoryFeesTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As InventoryFeesTypeCollection
    Get
public:
property InventoryFeesTypeCollection^ FeeList {
    InventoryFeesTypeCollection^ get ();
}


InventoryStatuList Property

InventoryStatuList Property
Namespaces ► eBay.Service.Call ► ReviseInventoryStatusCall ► InventoryStatuList
Gets or sets the InventoryStatus of type InventoryStatusTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusTypeCollection InventoryStatuList { get; set; }
Public Property InventoryStatuList As InventoryStatusTypeCollection
    Get
    Set
public:
property InventoryStatusTypeCollection^ InventoryStatuList {
    InventoryStatusTypeCollection^ get ();
    void set (InventoryStatusTypeCollection^ value);
}


InventoryStatuListReturn Property

InventoryStatuListReturn Property
Namespaces ► eBay.Service.Call ► ReviseInventoryStatusCall ► InventoryStatuListReturn
Gets the returned InventoryStatus of type InventoryStatusTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusTypeCollection InventoryStatuListReturn { get; }
Public ReadOnly Property InventoryStatuListReturn As InventoryStatusTypeCollection
    Get
public:
property InventoryStatusTypeCollection^ InventoryStatuListReturn {
    InventoryStatusTypeCollection^ get ();
}


ReviseInventoryStatus Method (InventoryStatuList)

ReviseInventoryStatus Method (InventoryStatuList)
Namespaces ► eBay.Service.Call ► ReviseInventoryStatusCall ► ReviseInventoryStatus(InventoryStatusTypeCollection)
Enables a seller to change the price and quantity of a currently- active, fixed-price listing. Using ReviseInventoryStatus to modify data qualifies as revising the listing. Inputs are the item IDs or SKUs of the listings being revised, and the price and quantity that are being changed for each revision. Only applicable to fixed-price listings. Changing the price or quantity of a currently- active, fixed-price listing does not reset the Best Match performance score. For Best Match information related to multi-variation listings, see the Best Match information at the following topic: Multi-quantity Fixed Price listings with variations. As with all listing calls, the site you specify in the request URL (for SOAP) or the X-EBAY-API-SITEID HTTP header (for XML) should match the original listing's Item.Site value. In particular, this is a best practice when you submit new and revised listings. For Large Merchant Services users: When you use ReviseInventoryStatus within a Merchant Data file, it must be enclosed within two BulkDataExchangeRequest tags. A namespace is returned in the BulkDataExchangeResponseType (top level) of the response. The BulkDataExchange tags are not shown in the call input/output descriptions.
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusTypeCollection ReviseInventoryStatus(
    InventoryStatusTypeCollection InventoryStatuList
)
Public Function ReviseInventoryStatus ( _
    InventoryStatuList As InventoryStatusTypeCollection _
) As InventoryStatusTypeCollection
public:
InventoryStatusTypeCollection^ ReviseInventoryStatus(
    InventoryStatusTypeCollection^ InventoryStatuList
)
Parameters
InventoryStatuList (InventoryStatusTypeCollection)
Contains the updated quantity and/or price of a listing being revised. You should not modify the same listing twice (by using a duplicate ItemID or SKU) in the same request; otherwise, you may get an error or unexpected results. (For example, you should not use one InventoryStatus node to update the quantity and another InventoryStatus node to update the price of the same item.) You can pass up to 4 InventoryStatus nodes in a single request.


ReviseInventoryStatusCall Constructor

ReviseInventoryStatusCall Constructor
Namespaces ► eBay.Service.Call ► ReviseInventoryStatusCall ► ReviseInventoryStatusCall()()()()
Members
Icon | Member | Description
 | ReviseInventoryStatusCall()()()() |
 | ReviseInventoryStatusCall(ApiContext) |


ReviseInventoryStatusCall Constructor

ReviseInventoryStatusCall Constructor
Namespaces ► eBay.Service.Call ► ReviseInventoryStatusCall ► ReviseInventoryStatusCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseInventoryStatusCall()
Public Sub New
public:
ReviseInventoryStatusCall()


ReviseInventoryStatusCall Constructor (ApiContext)

ReviseInventoryStatusCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ReviseInventoryStatusCall ► ReviseInventoryStatusCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseInventoryStatusCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ReviseInventoryStatusCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ReviseItemCall Class

ReviseItemCall Class
Namespaces ► eBay.Service.Call ► ReviseItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ReviseItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ReviseItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ReviseItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseItemCall()()()() |
 | ReviseItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ReviseItemRequestType for this API call.
 | ApiResponse | Gets the ReviseItemResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Category2ID | Gets the returned Category2ID of type String.
 | CategoryID | Gets the returned CategoryID of type String.
 | DeletedFieldList | Gets or sets the DeletedField of type StringCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DiscountReasonList | Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | (Overrides ApiCall.Execute()()()().)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | ItemID | Gets the returned ItemID of type String.
 | ListingRecommendations | Gets the returned ListingRecommendations of type ListingRecommendationsType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PictureFileList |
 | ProductSuggestions | Gets the returned ProductSuggestions of type ProductSuggestionsType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReviseItem(ItemType, StringCollection, Boolean) |
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | VerifyOnly | Gets or sets the VerifyOnly of type Boolean.
 | VerifyOnlyReturn | Gets the returned VerifyOnly of type Boolean.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ReviseItemCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► ApiRequest
Gets or sets the ReviseItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As ReviseItemRequestType
    Get
    Set
public:
property ReviseItemRequestType^ ApiRequest {
    ReviseItemRequestType^ get ();
    void set (ReviseItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► ApiResponse
Gets the ReviseItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ReviseItemResponseType
    Get
public:
property ReviseItemResponseType^ ApiResponse {
    ReviseItemResponseType^ get ();
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► Category2ID
Gets the returned Category2ID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; }
Public ReadOnly Property Category2ID As String
    Get
public:
property String^ Category2ID {
    String^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► CategoryID
Gets the returned CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; }
Public ReadOnly Property CategoryID As String
    Get
public:
property String^ CategoryID {
    String^ get ();
}


DeletedFieldList Property

DeletedFieldList Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► DeletedFieldList
Gets or sets the DeletedField of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedFieldList { get; set; }
Public Property DeletedFieldList As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedFieldList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


DiscountReasonList Property

DiscountReasonList Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► DiscountReasonList
Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReasonList { get; }
Public ReadOnly Property DiscountReasonList As DiscountReasonCodeTypeCollection
    Get
public:
property DiscountReasonCodeTypeCollection^ DiscountReasonList {
    DiscountReasonCodeTypeCollection^ get ();
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


Execute Method

Execute Method
Namespaces ► eBay.Service.Call ► ReviseItemCall ► Execute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Execute()
Public Overrides Sub Execute
public:
virtual void Execute() override


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► ItemID
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; }
Public ReadOnly Property ItemID As String
    Get
public:
property String^ ItemID {
    String^ get ();
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► ListingRecommendations
Gets the returned ListingRecommendations of type ListingRecommendationsType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; }
Public ReadOnly Property ListingRecommendations As ListingRecommendationsType
    Get
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
}


PictureFileList Property

PictureFileList Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► PictureFileList
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureFileList { get; set; }
Public Property PictureFileList As StringCollection
    Get
    Set
public:
property StringCollection^ PictureFileList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► ProductSuggestions
Gets the returned ProductSuggestions of type ProductSuggestionsType.
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; }
Public ReadOnly Property ProductSuggestions As ProductSuggestionsType
    Get
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
}


ReviseItem Method (Item, DeletedFieldList, VerifyOnly)

ReviseItem Method (Item, DeletedFieldList, VerifyOnly)
Namespaces ► eBay.Service.Call ► ReviseItemCall ► ReviseItem(ItemType, StringCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ReviseItem(
    ItemType Item,
    StringCollection DeletedFieldList,
    bool VerifyOnly
)
Public Function ReviseItem ( _
    Item As ItemType, _
    DeletedFieldList As StringCollection, _
    VerifyOnly As Boolean _
) As DateTime
public:
DateTime ReviseItem(
    ItemType^ Item,
    StringCollection^ DeletedFieldList,
    bool VerifyOnly
)
Parameters
Item (ItemType)
DeletedFieldList (StringCollection)
VerifyOnly (Boolean)


ReviseItemCall Constructor

ReviseItemCall Constructor
Namespaces ► eBay.Service.Call ► ReviseItemCall ► ReviseItemCall()()()()
Members
Icon | Member | Description
 | ReviseItemCall()()()() |
 | ReviseItemCall(ApiContext) |


ReviseItemCall Constructor

ReviseItemCall Constructor
Namespaces ► eBay.Service.Call ► ReviseItemCall ► ReviseItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseItemCall()
Public Sub New
public:
ReviseItemCall()


ReviseItemCall Constructor (ApiContext)

ReviseItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ReviseItemCall ► ReviseItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ReviseItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► StartTime
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}


VerifyOnly Property

VerifyOnly Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► VerifyOnly
Gets or sets the VerifyOnly of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnly { get; set; }
Public Property VerifyOnly As Boolean
    Get
    Set
public:
property bool VerifyOnly {
    bool get ();
    void set (bool value);
}


VerifyOnlyReturn Property

VerifyOnlyReturn Property
Namespaces ► eBay.Service.Call ► ReviseItemCall ► VerifyOnlyReturn
Gets the returned VerifyOnly of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnlyReturn { get; }
Public ReadOnly Property VerifyOnlyReturn As Boolean
    Get
public:
property bool VerifyOnlyReturn {
    bool get ();
}


ReviseMyMessagesCall Class

ReviseMyMessagesCall Class
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ReviseMyMessagesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ReviseMyMessagesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ReviseMyMessagesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseMyMessagesCall()()()() |
 | ReviseMyMessagesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | AlertIDList | Gets or sets the AlertIDs of type StringCollection.
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ReviseMyMessagesRequestType for this API call.
 | ApiResponse | Gets the ReviseMyMessagesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | Flagged | Gets or sets the Flagged of type Boolean.
 | FolderID | Gets or sets the FolderID of type Int64.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageIDList | Gets or sets the MessageIDs of type StringCollection.
 | OutputSelector | (Inherited from ApiCall.)
 | Read | Gets or sets the Read of type Boolean.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReviseMyMessages(StringCollection, StringCollection, Boolean, Boolean, Int64) | Sets the read state for messages, sets the flagged state of messages, and moves messages into and out of folders.
 | ReviseMyMessages(Boolean, Boolean, StringCollection) | For backward compatibility with old wrappers.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ReviseMyMessagesCall


AlertIDList Property

AlertIDList Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► AlertIDList
Gets or sets the AlertIDs of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection AlertIDList { get; set; }
Public Property AlertIDList As StringCollection
    Get
    Set
public:
property StringCollection^ AlertIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► ApiRequest
Gets or sets the ReviseMyMessagesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesRequestType ApiRequest { get; set; }
Public Property ApiRequest As ReviseMyMessagesRequestType
    Get
    Set
public:
property ReviseMyMessagesRequestType^ ApiRequest {
    ReviseMyMessagesRequestType^ get ();
    void set (ReviseMyMessagesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► ApiResponse
Gets the ReviseMyMessagesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ReviseMyMessagesResponseType
    Get
public:
property ReviseMyMessagesResponseType^ ApiResponse {
    ReviseMyMessagesResponseType^ get ();
}


Flagged Property

Flagged Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► Flagged
Gets or sets the Flagged of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool Flagged { get; set; }
Public Property Flagged As Boolean
    Get
    Set
public:
property bool Flagged {
    bool get ();
    void set (bool value);
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► FolderID
Gets or sets the FolderID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


MessageIDList Property

MessageIDList Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► MessageIDList
Gets or sets the MessageIDs of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection MessageIDList { get; set; }
Public Property MessageIDList As StringCollection
    Get
    Set
public:
property StringCollection^ MessageIDList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Read Property

Read Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► Read
Gets or sets the Read of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool Read { get; set; }
Public Property Read As Boolean
    Get
    Set
public:
property bool Read {
    bool get ();
    void set (bool value);
}


ReviseMyMessages Method

ReviseMyMessages Method
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► ReviseMyMessages()()()()
Members
Icon | Member | Description
 | ReviseMyMessages(StringCollection, StringCollection, Boolean, Boolean, Int64) | Sets the read state for messages, sets the flagged state of messages, and moves messages into and out of folders.
 | ReviseMyMessages(Boolean, Boolean, StringCollection) | For backward compatibility with old wrappers.


ReviseMyMessages Method (MessageIDList, AlertIDList, Read, Flagged, FolderID)

ReviseMyMessages Method (MessageIDList, AlertIDList, Read, Flagged, FolderID)
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► ReviseMyMessages(StringCollection, StringCollection, Boolean, Boolean, Int64)
Sets the read state for messages, sets the flagged state of messages, and moves messages into and out of folders.
Declaration Syntax
C# Visual Basic Visual C++
public void ReviseMyMessages(
    StringCollection MessageIDList,
    StringCollection AlertIDList,
    bool Read,
    bool Flagged,
    long FolderID
)
Public Sub ReviseMyMessages ( _
    MessageIDList As StringCollection, _
    AlertIDList As StringCollection, _
    Read As Boolean, _
    Flagged As Boolean, _
    FolderID As Long _
)
public:
void ReviseMyMessages(
    StringCollection^ MessageIDList,
    StringCollection^ AlertIDList,
    bool Read,
    bool Flagged,
    long long FolderID
)
Parameters
MessageIDList (StringCollection)
Contains a list of up to 10 MessageIDsMessageIDs values must be included in the request. Messages in the Sent box cannot be moved, marked as read, or flagged.
AlertIDList (StringCollection)
This field is deprecated.
Read (Boolean)
Changes the read states of all messages specified in a request. At least one of the Read, Flagged, or FolderID fields must be specified in the request. Messages in the Sent box cannot be moved, marked as read, or flagged. Note that messages retrieved with the API are not automatically marked read, and must be marked read with this call.
Flagged (Boolean)
Changes the flagged states of all messages specified in a request by their MessageID values. At least one of the Read, Flagged, or FolderID fields must be specified in the request. Messages in the Sent box cannot be moved, marked as read, or flagged.
FolderID (Int64)
An ID that uniquely identifies the My Messages folder to move messages into. At least one of the Read, Flagged, or FolderID fields must be specified in the request. Messages in the Sent box cannot be moved, marked as read, or flagged.


ReviseMyMessages Method (Read, Flagged, MessageIDList)

ReviseMyMessages Method (Read, Flagged, MessageIDList)
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► ReviseMyMessages(Boolean, Boolean, StringCollection)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void ReviseMyMessages(
    bool Read,
    bool Flagged,
    StringCollection MessageIDList
)
Public Sub ReviseMyMessages ( _
    Read As Boolean, _
    Flagged As Boolean, _
    MessageIDList As StringCollection _
)
public:
void ReviseMyMessages(
    bool Read,
    bool Flagged,
    StringCollection^ MessageIDList
)
Parameters
Read (Boolean)
Flagged (Boolean)
MessageIDList (StringCollection)


ReviseMyMessagesCall Constructor

ReviseMyMessagesCall Constructor
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► ReviseMyMessagesCall()()()()
Members
Icon | Member | Description
 | ReviseMyMessagesCall()()()() |
 | ReviseMyMessagesCall(ApiContext) |


ReviseMyMessagesCall Constructor

ReviseMyMessagesCall Constructor
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► ReviseMyMessagesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesCall()
Public Sub New
public:
ReviseMyMessagesCall()


ReviseMyMessagesCall Constructor (ApiContext)

ReviseMyMessagesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ReviseMyMessagesCall ► ReviseMyMessagesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ReviseMyMessagesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ReviseMyMessagesFoldersCall Class

ReviseMyMessagesFoldersCall Class
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ReviseMyMessagesFoldersCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ReviseMyMessagesFoldersCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ReviseMyMessagesFoldersCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseMyMessagesFoldersCall()()()() |
 | ReviseMyMessagesFoldersCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ReviseMyMessagesFoldersRequestType for this API call.
 | ApiResponse | Gets the ReviseMyMessagesFoldersResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderIDList | Gets or sets the FolderID of type Int64Collection.
 | FolderNameList | Gets or sets the FolderName of type StringCollection.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Operation | Gets or sets the Operation of type MyMessagesFolderOperationCodeType.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReviseMyMessagesFolders(MyMessagesFolderOperationCodeType, Int64Collection, StringCollection) | Renames, removes, or restores the specified My Messages folders for a given user.
 | ReviseMyMessagesFolders(MyMessagesFolderOperationCodeType, StringCollection, Int64Collection) | For backward compatibility with old wrappers.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ReviseMyMessagesFoldersCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► ApiRequest
Gets or sets the ReviseMyMessagesFoldersRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesFoldersRequestType ApiRequest { get; set; }
Public Property ApiRequest As ReviseMyMessagesFoldersRequestType
    Get
    Set
public:
property ReviseMyMessagesFoldersRequestType^ ApiRequest {
    ReviseMyMessagesFoldersRequestType^ get ();
    void set (ReviseMyMessagesFoldersRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► ApiResponse
Gets the ReviseMyMessagesFoldersResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesFoldersResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ReviseMyMessagesFoldersResponseType
    Get
public:
property ReviseMyMessagesFoldersResponseType^ ApiResponse {
    ReviseMyMessagesFoldersResponseType^ get ();
}


FolderIDList Property

FolderIDList Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► FolderIDList
Gets or sets the FolderID of type Int64Collection.
Declaration Syntax
C# Visual Basic Visual C++
public Int64Collection FolderIDList { get; set; }
Public Property FolderIDList As Int64Collection
    Get
    Set
public:
property Int64Collection^ FolderIDList {
    Int64Collection^ get ();
    void set (Int64Collection^ value);
}


FolderNameList Property

FolderNameList Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► FolderNameList
Gets or sets the FolderName of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection FolderNameList { get; set; }
Public Property FolderNameList As StringCollection
    Get
    Set
public:
property StringCollection^ FolderNameList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Operation Property

Operation Property
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► Operation
Gets or sets the Operation of type MyMessagesFolderOperationCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderOperationCodeType Operation { get; set; }
Public Property Operation As MyMessagesFolderOperationCodeType
    Get
    Set
public:
property MyMessagesFolderOperationCodeType Operation {
    MyMessagesFolderOperationCodeType get ();
    void set (MyMessagesFolderOperationCodeType value);
}


ReviseMyMessagesFolders Method

ReviseMyMessagesFolders Method
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► ReviseMyMessagesFolders()()()()
Members
Icon | Member | Description
 | ReviseMyMessagesFolders(MyMessagesFolderOperationCodeType, Int64Collection, StringCollection) | Renames, removes, or restores the specified My Messages folders for a given user.
 | ReviseMyMessagesFolders(MyMessagesFolderOperationCodeType, StringCollection, Int64Collection) | For backward compatibility with old wrappers.


ReviseMyMessagesFolders Method (Operation, FolderIDList, FolderNameList)

ReviseMyMessagesFolders Method (Operation, FolderIDList, FolderNameList)
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► ReviseMyMessagesFolders(MyMessagesFolderOperationCodeType, Int64Collection, StringCollection)
Renames, removes, or restores the specified My Messages folders for a given user.
Declaration Syntax
C# Visual Basic Visual C++
public void ReviseMyMessagesFolders(
    MyMessagesFolderOperationCodeType Operation,
    Int64Collection FolderIDList,
    StringCollection FolderNameList
)
Public Sub ReviseMyMessagesFolders ( _
    Operation As MyMessagesFolderOperationCodeType, _
    FolderIDList As Int64Collection, _
    FolderNameList As StringCollection _
)
public:
void ReviseMyMessagesFolders(
    MyMessagesFolderOperationCodeType Operation,
    Int64Collection^ FolderIDList,
    StringCollection^ FolderNameList
)
Parameters
Operation (MyMessagesFolderOperationCodeType)
Indicates the type of operation to perform on a specified My Messages folder. Operations include creating, renaming, removing, and restoring folders. Operations cannot be performed on the Inbox and Sent folders.
FolderIDList (Int64Collection)
An ID that uniquely identifies the My Messages folder to perform the operation on. This value is set by eBay and cannot be changed. Retrieve FolderIDs by calling GetMyMessages with a DetailLevel of ReturnSummary. Inbox is FolderID = 0, and Sent is FolderID = 1.
FolderNameList (StringCollection)
The name of a specified My Messages folder. Depending on the specified Operation, the value is an existing folder name or a new folder name. Retrieve existing FolderNames by calling GetMyMessages with a DetailLevel of ReturnSummary. Inbox is FolderID = 0, and Sent is FolderID = 1.


ReviseMyMessagesFolders Method (Operation, FolderNameList, FolderIDList)

ReviseMyMessagesFolders Method (Operation, FolderNameList, FolderIDList)
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► ReviseMyMessagesFolders(MyMessagesFolderOperationCodeType, StringCollection, Int64Collection)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void ReviseMyMessagesFolders(
    MyMessagesFolderOperationCodeType Operation,
    StringCollection FolderNameList,
    Int64Collection FolderIDList
)
Public Sub ReviseMyMessagesFolders ( _
    Operation As MyMessagesFolderOperationCodeType, _
    FolderNameList As StringCollection, _
    FolderIDList As Int64Collection _
)
public:
void ReviseMyMessagesFolders(
    MyMessagesFolderOperationCodeType Operation,
    StringCollection^ FolderNameList,
    Int64Collection^ FolderIDList
)
Parameters
Operation (MyMessagesFolderOperationCodeType)
FolderNameList (StringCollection)
FolderIDList (Int64Collection)


ReviseMyMessagesFoldersCall Constructor

ReviseMyMessagesFoldersCall Constructor
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► ReviseMyMessagesFoldersCall()()()()
Members
Icon | Member | Description
 | ReviseMyMessagesFoldersCall()()()() |
 | ReviseMyMessagesFoldersCall(ApiContext) |


ReviseMyMessagesFoldersCall Constructor

ReviseMyMessagesFoldersCall Constructor
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► ReviseMyMessagesFoldersCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesFoldersCall()
Public Sub New
public:
ReviseMyMessagesFoldersCall()


ReviseMyMessagesFoldersCall Constructor (ApiContext)

ReviseMyMessagesFoldersCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ReviseMyMessagesFoldersCall ► ReviseMyMessagesFoldersCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesFoldersCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ReviseMyMessagesFoldersCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ReviseSellingManagerInventoryFolderCall Class

ReviseSellingManagerInventoryFolderCall Class
Namespaces ► eBay.Service.Call ► ReviseSellingManagerInventoryFolderCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ReviseSellingManagerInventoryFolderCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ReviseSellingManagerInventoryFolderCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ReviseSellingManagerInventoryFolderCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerInventoryFolderCall()()()() |
 | ReviseSellingManagerInventoryFolderCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ReviseSellingManagerInventoryFolderRequestType for this API call.
 | ApiResponse | Gets the ReviseSellingManagerInventoryFolderResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | Folder | Gets or sets the Folder of type SellingManagerFolderDetailsType.
 | FolderReturn | Gets the returned Folder of type SellingManagerFolderDetailsType.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReviseSellingManagerInventoryFolder(SellingManagerFolderDetailsType) | Renames a Selling Manager inventory folder. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ReviseSellingManagerInventoryFolderCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerInventoryFolderCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerInventoryFolderCall ► ApiRequest
Gets or sets the ReviseSellingManagerInventoryFolderRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerInventoryFolderRequestType ApiRequest { get; set; }
Public Property ApiRequest As ReviseSellingManagerInventoryFolderRequestType
    Get
    Set
public:
property ReviseSellingManagerInventoryFolderRequestType^ ApiRequest {
    ReviseSellingManagerInventoryFolderRequestType^ get ();
    void set (ReviseSellingManagerInventoryFolderRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerInventoryFolderCall ► ApiResponse
Gets the ReviseSellingManagerInventoryFolderResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerInventoryFolderResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ReviseSellingManagerInventoryFolderResponseType
    Get
public:
property ReviseSellingManagerInventoryFolderResponseType^ ApiResponse {
    ReviseSellingManagerInventoryFolderResponseType^ get ();
}


Folder Property

Folder Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerInventoryFolderCall ► Folder
Gets or sets the Folder of type SellingManagerFolderDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType Folder { get; set; }
Public Property Folder As SellingManagerFolderDetailsType
    Get
    Set
public:
property SellingManagerFolderDetailsType^ Folder {
    SellingManagerFolderDetailsType^ get ();
    void set (SellingManagerFolderDetailsType^ value);
}


FolderReturn Property

FolderReturn Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerInventoryFolderCall ► FolderReturn
Gets the returned Folder of type SellingManagerFolderDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType FolderReturn { get; }
Public ReadOnly Property FolderReturn As SellingManagerFolderDetailsType
    Get
public:
property SellingManagerFolderDetailsType^ FolderReturn {
    SellingManagerFolderDetailsType^ get ();
}


ReviseSellingManagerInventoryFolder Method (Folder)

ReviseSellingManagerInventoryFolder Method (Folder)
Namespaces ► eBay.Service.Call ► ReviseSellingManagerInventoryFolderCall ► ReviseSellingManagerInventoryFolder(SellingManagerFolderDetailsType)
Renames a Selling Manager inventory folder. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType ReviseSellingManagerInventoryFolder(
    SellingManagerFolderDetailsType Folder
)
Public Function ReviseSellingManagerInventoryFolder ( _
    Folder As SellingManagerFolderDetailsType _
) As SellingManagerFolderDetailsType
public:
SellingManagerFolderDetailsType^ ReviseSellingManagerInventoryFolder(
    SellingManagerFolderDetailsType^ Folder
)
Parameters
Folder (SellingManagerFolderDetailsType)
Identifier of the folder to be modified. Valid inputs are folder ID, folder name, and comments.


ReviseSellingManagerInventoryFolderCall Constructor

ReviseSellingManagerInventoryFolderCall Constructor
Namespaces ► eBay.Service.Call ► ReviseSellingManagerInventoryFolderCall ► ReviseSellingManagerInventoryFolderCall()()()()
Members
Icon | Member | Description
 | ReviseSellingManagerInventoryFolderCall()()()() |
 | ReviseSellingManagerInventoryFolderCall(ApiContext) |


ReviseSellingManagerInventoryFolderCall Constructor

ReviseSellingManagerInventoryFolderCall Constructor
Namespaces ► eBay.Service.Call ► ReviseSellingManagerInventoryFolderCall ► ReviseSellingManagerInventoryFolderCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerInventoryFolderCall()
Public Sub New
public:
ReviseSellingManagerInventoryFolderCall()


ReviseSellingManagerInventoryFolderCall Constructor (ApiContext)

ReviseSellingManagerInventoryFolderCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ReviseSellingManagerInventoryFolderCall ► ReviseSellingManagerInventoryFolderCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerInventoryFolderCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ReviseSellingManagerInventoryFolderCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ReviseSellingManagerProductCall Class

ReviseSellingManagerProductCall Class
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ReviseSellingManagerProductCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ReviseSellingManagerProductCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ReviseSellingManagerProductCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerProductCall()()()() |
 | ReviseSellingManagerProductCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ReviseSellingManagerProductRequestType for this API call.
 | ApiResponse | Gets the ReviseSellingManagerProductResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeletedFieldList | Gets or sets the DeletedField of type StringCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReviseSellingManagerProduct(SellingManagerProductDetailsType, SellingManagerFolderDetailsType, StringCollection, SellingManagerProductSpecificsType) | Revises a Selling Manager product. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | SellingManagerFolderDetails | Gets or sets the SellingManagerFolderDetails of type SellingManagerFolderDetailsType.
 | SellingManagerProductDetails | Gets or sets the SellingManagerProductDetails of type SellingManagerProductDetailsType.
 | SellingManagerProductDetailsReturn | Gets the returned SellingManagerProductDetails of type SellingManagerProductDetailsType.
 | SellingManagerProductSpecifics | Gets or sets the SellingManagerProductSpecifics of type SellingManagerProductSpecificsType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ReviseSellingManagerProductCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► ApiRequest
Gets or sets the ReviseSellingManagerProductRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerProductRequestType ApiRequest { get; set; }
Public Property ApiRequest As ReviseSellingManagerProductRequestType
    Get
    Set
public:
property ReviseSellingManagerProductRequestType^ ApiRequest {
    ReviseSellingManagerProductRequestType^ get ();
    void set (ReviseSellingManagerProductRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► ApiResponse
Gets the ReviseSellingManagerProductResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerProductResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ReviseSellingManagerProductResponseType
    Get
public:
property ReviseSellingManagerProductResponseType^ ApiResponse {
    ReviseSellingManagerProductResponseType^ get ();
}


DeletedFieldList Property

DeletedFieldList Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► DeletedFieldList
Gets or sets the DeletedField of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedFieldList { get; set; }
Public Property DeletedFieldList As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedFieldList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ReviseSellingManagerProduct Method (SellingManagerProductDetails, SellingManagerFolderDetails, DeletedFieldList, SellingManagerProductSpecifics)

ReviseSellingManagerProduct Method (SellingManagerProductDetails, SellingManagerFolderDetails, DeletedFieldList, SellingManagerProductSpecifics)
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► ReviseSellingManagerProduct(SellingManagerProductDetailsType, SellingManagerFolderDetailsType, StringCollection, SellingManagerProductSpecificsType)
Revises a Selling Manager product. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType ReviseSellingManagerProduct(
    SellingManagerProductDetailsType SellingManagerProductDetails,
    SellingManagerFolderDetailsType SellingManagerFolderDetails,
    StringCollection DeletedFieldList,
    SellingManagerProductSpecificsType SellingManagerProductSpecifics
)
Public Function ReviseSellingManagerProduct ( _
    SellingManagerProductDetails As SellingManagerProductDetailsType, _
    SellingManagerFolderDetails As SellingManagerFolderDetailsType, _
    DeletedFieldList As StringCollection, _
    SellingManagerProductSpecifics As SellingManagerProductSpecificsType _
) As SellingManagerProductDetailsType
public:
SellingManagerProductDetailsType^ ReviseSellingManagerProduct(
    SellingManagerProductDetailsType^ SellingManagerProductDetails,
    SellingManagerFolderDetailsType^ SellingManagerFolderDetails,
    StringCollection^ DeletedFieldList,
    SellingManagerProductSpecificsType^ SellingManagerProductSpecifics
)
Parameters
SellingManagerProductDetails (SellingManagerProductDetailsType)
The details of the product that is being revised.
SellingManagerFolderDetails (SellingManagerFolderDetailsType)
The details of the folder for this product.
DeletedFieldList (StringCollection)
Specifies the name of a field to remove from a Selling Manager product. The request can contain zero, one, or many instances of DeletedField (one for each field to be removed). DeletedField accepts the following path names, which remove the corresponding fields: SellingManagerProductDetails.CustomLabel SellingManagerProductDetails.QuantityAvailable SellingManagerProductDetails.UnitCost These values are case-sensitive. Use values that match the case of the schema element names.
SellingManagerProductSpecifics (SellingManagerProductSpecificsType)
Specifies an eBay category associated with the product, defines Item Specifics that are relevant to the product, and defines variations available for the product (which may be used to create multivariation listings).


ReviseSellingManagerProductCall Constructor

ReviseSellingManagerProductCall Constructor
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► ReviseSellingManagerProductCall()()()()
Members
Icon | Member | Description
 | ReviseSellingManagerProductCall()()()() |
 | ReviseSellingManagerProductCall(ApiContext) |


ReviseSellingManagerProductCall Constructor

ReviseSellingManagerProductCall Constructor
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► ReviseSellingManagerProductCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerProductCall()
Public Sub New
public:
ReviseSellingManagerProductCall()


ReviseSellingManagerProductCall Constructor (ApiContext)

ReviseSellingManagerProductCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► ReviseSellingManagerProductCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerProductCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ReviseSellingManagerProductCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SellingManagerFolderDetails Property

SellingManagerFolderDetails Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► SellingManagerFolderDetails
Gets or sets the SellingManagerFolderDetails of type SellingManagerFolderDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType SellingManagerFolderDetails { get; set; }
Public Property SellingManagerFolderDetails As SellingManagerFolderDetailsType
    Get
    Set
public:
property SellingManagerFolderDetailsType^ SellingManagerFolderDetails {
    SellingManagerFolderDetailsType^ get ();
    void set (SellingManagerFolderDetailsType^ value);
}


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► SellingManagerProductDetails
Gets or sets the SellingManagerProductDetails of type SellingManagerProductDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; set; }
Public Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


SellingManagerProductDetailsReturn Property

SellingManagerProductDetailsReturn Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► SellingManagerProductDetailsReturn
Gets the returned SellingManagerProductDetails of type SellingManagerProductDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetailsReturn { get; }
Public ReadOnly Property SellingManagerProductDetailsReturn As SellingManagerProductDetailsType
    Get
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetailsReturn {
    SellingManagerProductDetailsType^ get ();
}


SellingManagerProductSpecifics Property

SellingManagerProductSpecifics Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerProductCall ► SellingManagerProductSpecifics
Gets or sets the SellingManagerProductSpecifics of type SellingManagerProductSpecificsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductSpecificsType SellingManagerProductSpecifics { get; set; }
Public Property SellingManagerProductSpecifics As SellingManagerProductSpecificsType
    Get
    Set
public:
property SellingManagerProductSpecificsType^ SellingManagerProductSpecifics {
    SellingManagerProductSpecificsType^ get ();
    void set (SellingManagerProductSpecificsType^ value);
}


ReviseSellingManagerSaleRecordCall Class

ReviseSellingManagerSaleRecordCall Class
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ReviseSellingManagerSaleRecordCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ReviseSellingManagerSaleRecordCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ReviseSellingManagerSaleRecordCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerSaleRecordCall()()()() |
 | ReviseSellingManagerSaleRecordCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ReviseSellingManagerSaleRecordRequestType for this API call.
 | ApiResponse | Gets the ReviseSellingManagerSaleRecordResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderID | Gets or sets the OrderID of type String.
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReviseSellingManagerSaleRecord(String, String, String, SellingManagerSoldOrderType, String) | Enables sellers, who subscribe to Selling Manager Pro, to revise a Selling Manager sale record.
 | SellingManagerSoldOrder | Gets or sets the SellingManagerSoldOrder of type SellingManagerSoldOrderType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ReviseSellingManagerSaleRecordCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► ApiRequest
Gets or sets the ReviseSellingManagerSaleRecordRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerSaleRecordRequestType ApiRequest { get; set; }
Public Property ApiRequest As ReviseSellingManagerSaleRecordRequestType
    Get
    Set
public:
property ReviseSellingManagerSaleRecordRequestType^ ApiRequest {
    ReviseSellingManagerSaleRecordRequestType^ get ();
    void set (ReviseSellingManagerSaleRecordRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► ApiResponse
Gets the ReviseSellingManagerSaleRecordResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerSaleRecordResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ReviseSellingManagerSaleRecordResponseType
    Get
public:
property ReviseSellingManagerSaleRecordResponseType^ ApiResponse {
    ReviseSellingManagerSaleRecordResponseType^ get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► OrderID
Gets or sets the OrderID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


ReviseSellingManagerSaleRecord Method (ItemID, TransactionID, OrderID, SellingManagerSoldOrder, OrderLineItemID)

ReviseSellingManagerSaleRecord Method (ItemID, TransactionID, OrderID, SellingManagerSoldOrder, OrderLineItemID)
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► ReviseSellingManagerSaleRecord(String, String, String, SellingManagerSoldOrderType, String)
Enables sellers, who subscribe to Selling Manager Pro, to revise a Selling Manager sale record.
Declaration Syntax
C# Visual Basic Visual C++
public void ReviseSellingManagerSaleRecord(
    string ItemID,
    string TransactionID,
    string OrderID,
    SellingManagerSoldOrderType SellingManagerSoldOrder,
    string OrderLineItemID
)
Public Sub ReviseSellingManagerSaleRecord ( _
    ItemID As String, _
    TransactionID As String, _
    OrderID As String, _
    SellingManagerSoldOrder As SellingManagerSoldOrderType, _
    OrderLineItemID As String _
)
public:
void ReviseSellingManagerSaleRecord(
    String^ ItemID,
    String^ TransactionID,
    String^ OrderID,
    SellingManagerSoldOrderType^ SellingManagerSoldOrder,
    String^ OrderLineItemID
)
Parameters
ItemID (String)
Unique identifier for an eBay item listing. A listing can have multiple order line items (transactions), but only one ItemID. An ItemID can be paired up with a corresponding TransactionID and used as an input filter for ReviseSellingManagerSaleRecord. The ItemID/TransactionID pair corresponds to a Selling Manager SaleRecordID, which can be retrieved with the GetSellingManagerSaleRecord call. Unless an OrderLineItemID is used to identify a single line item order, or the OrderID is used to identify a single or multiple line item (Combined Invoice) order, the ItemID/TransactionID pair must be specified. For a multiple line item (Combined Invoice) order, OrderID should be used. If OrderID or OrderLineItemID are specified, the ItemID/TransactionID pair is ignored if present in the same request.
TransactionID (String)
Unique identifier for an eBay order line item (transaction). An order line item is created once there is a commitment from a buyer to purchase an item. Since an auction listing can only have one order line item during the duration of the listing, the TransactionID for auction listings is always 0. Along with its corresponding ItemID, a TransactionID is used and referenced during an order checkout flow and after checkout has been completed. The ItemID/TransactionID pair can be used as an input filter for ReviseSellingManagerSaleRecord. The ItemID/TransactionID pair corresponds to a Selling Manager SaleRecordID, which can be retrieved with the GetSellingManagerSaleRecord call. Unless an OrderLineItemID is used to identify a single line item order, or the OrderID is used to identify a single or multiple line item (Combined Invoice) order, the ItemID/TransactionID pair must be specified. For a multiple line item (Combined Invoice) order, OrderID must be used. If OrderID or OrderLineItemID are specified, the ItemID/TransactionID pair is ignored if present in the same request.
OrderID (String)
A unique identifier that identifies a single line item or multiple line item (Combined Invoice) order. For a single line item order, the OrderID value is identical to the OrderLineItemID value that is generated upon creation of the order line item. For a Combined Invoice order, the OrderID value is created by eBay when the buyer or seller (sharing multiple, common order line items) combines multiple order line items into a Combined Invoice order through the eBay site. A Combined Invoice order can also be created by the seller through the AddOrder call. The OrderID can be used as an input filter for ReviseSellingManagerSaleRecord. The OrderID is linked to a Selling Manager SaleRecordID, and can be retrieved with the GetSellingManagerSaleRecord call. OrderID overrides an OrderLineItemID or ItemID/TransactionID pair if these fields are also specified in the same request.
SellingManagerSoldOrder (SellingManagerSoldOrderType)
Container consisting of order costs, shipping details, order status, and other information. The changes made under this container will update the order in Selling Manager.
OrderLineItemID (String)
OrderLineItemID is a unique identifier for an eBay order line item and is based upon the concatenation of ItemID and TransactionID, with a hyphen in between these two IDs. For a single line item order, the OrderLineItemID value can be passed into the OrderID field to revise the order in Selling Manager. Unless an ItemID/TransactionID pair is used to identify a single line item order, or the OrderID is used to identify a single or multiple line item (Combined Invoice) order, the OrderLineItemID must be specified. For a multiple line item (Combined Invoice) order, OrderID should be used. If OrderLineItemID is specified, the ItemID/TransactionID pair are ignored if present in the same request.


ReviseSellingManagerSaleRecordCall Constructor

ReviseSellingManagerSaleRecordCall Constructor
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► ReviseSellingManagerSaleRecordCall()()()()
Members
Icon | Member | Description
 | ReviseSellingManagerSaleRecordCall()()()() |
 | ReviseSellingManagerSaleRecordCall(ApiContext) |


ReviseSellingManagerSaleRecordCall Constructor

ReviseSellingManagerSaleRecordCall Constructor
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► ReviseSellingManagerSaleRecordCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerSaleRecordCall()
Public Sub New
public:
ReviseSellingManagerSaleRecordCall()


ReviseSellingManagerSaleRecordCall Constructor (ApiContext)

ReviseSellingManagerSaleRecordCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► ReviseSellingManagerSaleRecordCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerSaleRecordCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ReviseSellingManagerSaleRecordCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SellingManagerSoldOrder Property

SellingManagerSoldOrder Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► SellingManagerSoldOrder
Gets or sets the SellingManagerSoldOrder of type SellingManagerSoldOrderType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderType SellingManagerSoldOrder { get; set; }
Public Property SellingManagerSoldOrder As SellingManagerSoldOrderType
    Get
    Set
public:
property SellingManagerSoldOrderType^ SellingManagerSoldOrder {
    SellingManagerSoldOrderType^ get ();
    void set (SellingManagerSoldOrderType^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerSaleRecordCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


ReviseSellingManagerTemplateCall Class

ReviseSellingManagerTemplateCall Class
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ReviseSellingManagerTemplateCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ReviseSellingManagerTemplateCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ReviseSellingManagerTemplateCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerTemplateCall()()()() |
 | ReviseSellingManagerTemplateCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ReviseSellingManagerTemplateRequestType for this API call.
 | ApiResponse | Gets the ReviseSellingManagerTemplateResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Category2ID | Gets the returned Category2ID of type String.
 | CategoryID | Gets the returned CategoryID of type String.
 | DeletedFieldList | Gets or sets the DeletedField of type StringCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ProductID | Gets or sets the ProductID of type Int64.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | ReviseSellingManagerTemplate(Int64, Int64, String, ItemType, StringCollection, Boolean) | Revises a Selling Manager template. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | SaleTemplateID | Gets or sets the SaleTemplateID of type Int64.
 | SaleTemplateIDReturn | Gets the returned SaleTemplateID of type Int64.
 | SaleTemplateName | Gets or sets the SaleTemplateName of type String.
 | SaleTemplateNameReturn | Gets the returned SaleTemplateName of type String.
 | SellingManagerProductDetails | Gets the returned SellingManagerProductDetails of type SellingManagerProductDetailsType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | VerifyOnly | Gets or sets the VerifyOnly of type Boolean.
 | VerifyOnlyReturn | Gets the returned VerifyOnly of type Boolean.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ReviseSellingManagerTemplateCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► ApiRequest
Gets or sets the ReviseSellingManagerTemplateRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerTemplateRequestType ApiRequest { get; set; }
Public Property ApiRequest As ReviseSellingManagerTemplateRequestType
    Get
    Set
public:
property ReviseSellingManagerTemplateRequestType^ ApiRequest {
    ReviseSellingManagerTemplateRequestType^ get ();
    void set (ReviseSellingManagerTemplateRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► ApiResponse
Gets the ReviseSellingManagerTemplateResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerTemplateResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ReviseSellingManagerTemplateResponseType
    Get
public:
property ReviseSellingManagerTemplateResponseType^ ApiResponse {
    ReviseSellingManagerTemplateResponseType^ get ();
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► Category2ID
Gets the returned Category2ID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; }
Public ReadOnly Property Category2ID As String
    Get
public:
property String^ Category2ID {
    String^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► CategoryID
Gets the returned CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; }
Public ReadOnly Property CategoryID As String
    Get
public:
property String^ CategoryID {
    String^ get ();
}


DeletedFieldList Property

DeletedFieldList Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► DeletedFieldList
Gets or sets the DeletedField of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedFieldList { get; set; }
Public Property DeletedFieldList As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedFieldList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ProductID Property

ProductID Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► ProductID
Gets or sets the ProductID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long ProductID { get; set; }
Public Property ProductID As Long
    Get
    Set
public:
property long long ProductID {
    long long get ();
    void set (long long value);
}


ReviseSellingManagerTemplate Method (SaleTemplateID, ProductID, SaleTemplateName, Item, DeletedFieldList, VerifyOnly)

ReviseSellingManagerTemplate Method (SaleTemplateID, ProductID, SaleTemplateName, Item, DeletedFieldList, VerifyOnly)
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► ReviseSellingManagerTemplate(Int64, Int64, String, ItemType, StringCollection, Boolean)
Revises a Selling Manager template. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public long ReviseSellingManagerTemplate(
    long SaleTemplateID,
    long ProductID,
    string SaleTemplateName,
    ItemType Item,
    StringCollection DeletedFieldList,
    bool VerifyOnly
)
Public Function ReviseSellingManagerTemplate ( _
    SaleTemplateID As Long, _
    ProductID As Long, _
    SaleTemplateName As String, _
    Item As ItemType, _
    DeletedFieldList As StringCollection, _
    VerifyOnly As Boolean _
) As Long
public:
long long ReviseSellingManagerTemplate(
    long long SaleTemplateID,
    long long ProductID,
    String^ SaleTemplateName,
    ItemType^ Item,
    StringCollection^ DeletedFieldList,
    bool VerifyOnly
)
Parameters
SaleTemplateID (Int64)
The ID of the sale template. You can obtain a SaleTemplateID by calling GetSellingManagerInventory or AddSellingManagerTemplate.
ProductID (Int64)
Reserved for future use.
SaleTemplateName (String)
The name of the sale template.
Item (ItemType)
Required. In Item.ItemID, specify the same value as the value you specified in SaleTemplateID. Other child elements hold the values for properties that are being changed. Set values in the Item object only for those properties that are changing. Use DeletedField to remove a property.
DeletedFieldList (StringCollection)
Specifies the name of a field to remove from a template. See the eBay Features Guide for rules on removing values when revising items. Also see the relevant field descriptions to determine when to use DeletedField (and potential consequences). The request can contain zero, one, or many instances of DeletedField (one for each field to be removed). DeletedField accepts the following path names, which remove the corresponding fields: Item.ApplicationData Item.AttributeSetArray Item.ConditionID Item.ItemSpecifics Item.ListingCheckoutRedirectPreference.ProStoresStoreName Item.ListingCheckoutRedirectPreference.SellerThirdPartyUsername Item.ListingDesigner.LayoutID Item.ListingDesigner.ThemeID Item.ListingEnhancement[Value] Item.PayPalEmailAddress Item.PictureDetails.GalleryURL Item.PictureDetails.PictureURL Item.PostalCode Item.ProductListingDetails item.ShippingDetails.PaymentInstructions Item.ShippingServiceCostOverrideList item.SKU Item.SubTitle These values are case-sensitive. Use values that match the case of the schema element names (Item.PictureDetails.GalleryURL) or make the initial letter of each field name lowercase (item.pictureDetails.galleryURL). However, do not change the case of letters in the middle of a field name (e.g., item.picturedetails.galleryUrl is not allowed). Depending on how you have configured your pictures, you cannot necessarily delete both GalleryURL and PictureURL from an existing listing. If GalleryType was already set for the item you are revising, you cannot remove it. This means you still need to include either a first picture or a gallery URL in your revised listing.
VerifyOnly (Boolean)
Use this field to verify the template instead of revising it.


ReviseSellingManagerTemplateCall Constructor

ReviseSellingManagerTemplateCall Constructor
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► ReviseSellingManagerTemplateCall()()()()
Members
Icon | Member | Description
 | ReviseSellingManagerTemplateCall()()()() |
 | ReviseSellingManagerTemplateCall(ApiContext) |


ReviseSellingManagerTemplateCall Constructor

ReviseSellingManagerTemplateCall Constructor
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► ReviseSellingManagerTemplateCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerTemplateCall()
Public Sub New
public:
ReviseSellingManagerTemplateCall()


ReviseSellingManagerTemplateCall Constructor (ApiContext)

ReviseSellingManagerTemplateCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► ReviseSellingManagerTemplateCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerTemplateCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ReviseSellingManagerTemplateCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► SaleTemplateID
Gets or sets the SaleTemplateID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


SaleTemplateIDReturn Property

SaleTemplateIDReturn Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► SaleTemplateIDReturn
Gets the returned SaleTemplateID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateIDReturn { get; }
Public ReadOnly Property SaleTemplateIDReturn As Long
    Get
public:
property long long SaleTemplateIDReturn {
    long long get ();
}


SaleTemplateName Property

SaleTemplateName Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► SaleTemplateName
Gets or sets the SaleTemplateName of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SaleTemplateName { get; set; }
Public Property SaleTemplateName As String
    Get
    Set
public:
property String^ SaleTemplateName {
    String^ get ();
    void set (String^ value);
}


SaleTemplateNameReturn Property

SaleTemplateNameReturn Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► SaleTemplateNameReturn
Gets the returned SaleTemplateName of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SaleTemplateNameReturn { get; }
Public ReadOnly Property SaleTemplateNameReturn As String
    Get
public:
property String^ SaleTemplateNameReturn {
    String^ get ();
}


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► SellingManagerProductDetails
Gets the returned SellingManagerProductDetails of type SellingManagerProductDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; }
Public ReadOnly Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
}


VerifyOnly Property

VerifyOnly Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► VerifyOnly
Gets or sets the VerifyOnly of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnly { get; set; }
Public Property VerifyOnly As Boolean
    Get
    Set
public:
property bool VerifyOnly {
    bool get ();
    void set (bool value);
}


VerifyOnlyReturn Property

VerifyOnlyReturn Property
Namespaces ► eBay.Service.Call ► ReviseSellingManagerTemplateCall ► VerifyOnlyReturn
Gets the returned VerifyOnly of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnlyReturn { get; }
Public ReadOnly Property VerifyOnlyReturn As Boolean
    Get
public:
property bool VerifyOnlyReturn {
    bool get ();
}


RevokeTokenCall Class

RevokeTokenCall Class
Namespaces ► eBay.Service.Call ► RevokeTokenCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class RevokeTokenCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class RevokeTokenCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class RevokeTokenCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RevokeTokenCall()()()() |
 | RevokeTokenCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the RevokeTokenRequestType for this API call.
 | ApiResponse | Gets the RevokeTokenResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Overrides ApiCall.GetSecurityHeader()()()().)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | RevokeToken(Boolean) | Revokes a token before it would otherwise expire.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UnsubscribeNotification | Gets or sets the UnsubscribeNotification of type Boolean.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | RevokeTokenCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► RevokeTokenCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► RevokeTokenCall ► ApiRequest
Gets or sets the RevokeTokenRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RevokeTokenRequestType ApiRequest { get; set; }
Public Property ApiRequest As RevokeTokenRequestType
    Get
    Set
public:
property RevokeTokenRequestType^ ApiRequest {
    RevokeTokenRequestType^ get ();
    void set (RevokeTokenRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► RevokeTokenCall ► ApiResponse
Gets the RevokeTokenResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public RevokeTokenResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As RevokeTokenResponseType
    Get
public:
property RevokeTokenResponseType^ ApiResponse {
    RevokeTokenResponseType^ get ();
}


GetSecurityHeader Method

GetSecurityHeader Method
Namespaces ► eBay.Service.Call ► RevokeTokenCall ► GetSecurityHeader()()()()
Constructs a security header from values in ApiContext.
Declaration Syntax
C# Visual Basic Visual C++
protected override CustomSecurityHeaderType GetSecurityHeader()
Protected Overrides Function GetSecurityHeader As CustomSecurityHeaderType
protected:
virtual CustomSecurityHeaderType^ GetSecurityHeader() override
Return Value
Security information of type CustomSecurityHeaderType.


RevokeToken Method (UnsubscribeNotification)

RevokeToken Method (UnsubscribeNotification)
Namespaces ► eBay.Service.Call ► RevokeTokenCall ► RevokeToken(Boolean)
Revokes a token before it would otherwise expire.
Declaration Syntax
C# Visual Basic Visual C++
public void RevokeToken(
    bool UnsubscribeNotification
)
Public Sub RevokeToken ( _
    UnsubscribeNotification As Boolean _
)
public:
void RevokeToken(
    bool UnsubscribeNotification
)
Parameters
UnsubscribeNotification (Boolean)
Cancels notification subscriptions for the user/application if set to true. Default value is false.


RevokeTokenCall Constructor

RevokeTokenCall Constructor
Namespaces ► eBay.Service.Call ► RevokeTokenCall ► RevokeTokenCall()()()()
Members
Icon | Member | Description
 | RevokeTokenCall()()()() |
 | RevokeTokenCall(ApiContext) |


RevokeTokenCall Constructor

RevokeTokenCall Constructor
Namespaces ► eBay.Service.Call ► RevokeTokenCall ► RevokeTokenCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RevokeTokenCall()
Public Sub New
public:
RevokeTokenCall()


RevokeTokenCall Constructor (ApiContext)

RevokeTokenCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► RevokeTokenCall ► RevokeTokenCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public RevokeTokenCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
RevokeTokenCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


UnsubscribeNotification Property

UnsubscribeNotification Property
Namespaces ► eBay.Service.Call ► RevokeTokenCall ► UnsubscribeNotification
Gets or sets the UnsubscribeNotification of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool UnsubscribeNotification { get; set; }
Public Property UnsubscribeNotification As Boolean
    Get
    Set
public:
property bool UnsubscribeNotification {
    bool get ();
    void set (bool value);
}


SaveItemToSellingManagerTemplateCall Class

SaveItemToSellingManagerTemplateCall Class
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SaveItemToSellingManagerTemplateCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SaveItemToSellingManagerTemplateCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SaveItemToSellingManagerTemplateCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveItemToSellingManagerTemplateCall()()()() |
 | SaveItemToSellingManagerTemplateCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SaveItemToSellingManagerTemplateRequestType for this API call.
 | ApiResponse | Gets the SaveItemToSellingManagerTemplateResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ProductID | Gets or sets the ProductID of type Int64.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SaveItemToSellingManagerTemplate(String, Int64, String) | Creates a Selling Manager listing template that is similar to an item. This call is subject to change without notice; the deprecation process is inapplicable to this call.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | TemplateID | Gets the returned TemplateID of type Int64.
 | TemplateName | Gets or sets the TemplateName of type String.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SaveItemToSellingManagerTemplateCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall ► ApiRequest
Gets or sets the SaveItemToSellingManagerTemplateRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SaveItemToSellingManagerTemplateRequestType ApiRequest { get; set; }
Public Property ApiRequest As SaveItemToSellingManagerTemplateRequestType
    Get
    Set
public:
property SaveItemToSellingManagerTemplateRequestType^ ApiRequest {
    SaveItemToSellingManagerTemplateRequestType^ get ();
    void set (SaveItemToSellingManagerTemplateRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall ► ApiResponse
Gets the SaveItemToSellingManagerTemplateResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SaveItemToSellingManagerTemplateResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SaveItemToSellingManagerTemplateResponseType
    Get
public:
property SaveItemToSellingManagerTemplateResponseType^ ApiResponse {
    SaveItemToSellingManagerTemplateResponseType^ get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ProductID Property

ProductID Property
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall ► ProductID
Gets or sets the ProductID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long ProductID { get; set; }
Public Property ProductID As Long
    Get
    Set
public:
property long long ProductID {
    long long get ();
    void set (long long value);
}


SaveItemToSellingManagerTemplate Method (ItemID, ProductID, TemplateName)

SaveItemToSellingManagerTemplate Method (ItemID, ProductID, TemplateName)
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall ► SaveItemToSellingManagerTemplate(String, Int64, String)
Creates a Selling Manager listing template that is similar to an item. This call is subject to change without notice; the deprecation process is inapplicable to this call.
Declaration Syntax
C# Visual Basic Visual C++
public long SaveItemToSellingManagerTemplate(
    string ItemID,
    long ProductID,
    string TemplateName
)
Public Function SaveItemToSellingManagerTemplate ( _
    ItemID As String, _
    ProductID As Long, _
    TemplateName As String _
) As Long
public:
long long SaveItemToSellingManagerTemplate(
    String^ ItemID,
    long long ProductID,
    String^ TemplateName
)
Parameters
ItemID (String)
ItemID which should be created as a template and saved to inventory.
ProductID (Int64)
Associates the new template with a product.
TemplateName (String)
Name associated with the template. If no name is submitted, the template will be named automatically.


SaveItemToSellingManagerTemplateCall Constructor

SaveItemToSellingManagerTemplateCall Constructor
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall ► SaveItemToSellingManagerTemplateCall()()()()
Members
Icon | Member | Description
 | SaveItemToSellingManagerTemplateCall()()()() |
 | SaveItemToSellingManagerTemplateCall(ApiContext) |


SaveItemToSellingManagerTemplateCall Constructor

SaveItemToSellingManagerTemplateCall Constructor
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall ► SaveItemToSellingManagerTemplateCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SaveItemToSellingManagerTemplateCall()
Public Sub New
public:
SaveItemToSellingManagerTemplateCall()


SaveItemToSellingManagerTemplateCall Constructor (ApiContext)

SaveItemToSellingManagerTemplateCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall ► SaveItemToSellingManagerTemplateCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SaveItemToSellingManagerTemplateCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SaveItemToSellingManagerTemplateCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


TemplateID Property

TemplateID Property
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall ► TemplateID
Gets the returned TemplateID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long TemplateID { get; }
Public ReadOnly Property TemplateID As Long
    Get
public:
property long long TemplateID {
    long long get ();
}


TemplateName Property

TemplateName Property
Namespaces ► eBay.Service.Call ► SaveItemToSellingManagerTemplateCall ► TemplateName
Gets or sets the TemplateName of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TemplateName { get; set; }
Public Property TemplateName As String
    Get
    Set
public:
property String^ TemplateName {
    String^ get ();
    void set (String^ value);
}


SellerReverseDisputeCall Class

SellerReverseDisputeCall Class
Namespaces ► eBay.Service.Call ► SellerReverseDisputeCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SellerReverseDisputeCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SellerReverseDisputeCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SellerReverseDisputeCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerReverseDisputeCall()()()() |
 | SellerReverseDisputeCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SellerReverseDisputeRequestType for this API call.
 | ApiResponse | Gets the SellerReverseDisputeResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DisputeID | Gets or sets the DisputeID of type String.
 | DisputeResolutionReason | Gets or sets the DisputeResolutionReason of type DisputeResolutionReasonCodeType.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellerReverseDispute(String, DisputeResolutionReasonCodeType) | Enables a seller to "reverse" an Unpaid Item dispute that has been closed, for example, if buyer and seller reach an agreement. The seller's Final Value Fee credit and the buyer's strike are both reversed, if applicable. The dispute might have resulted in a strike to the buyer and a Final Value Fee credit to the seller. A buyer and seller sometimes come to agreement after a dispute has been closed. In particular, the seller might discover that the buyer actually paid, or the buyer might agree to pay the seller's fees in exchange for having the strike removed. A dispute can only be reversed if it was closed with DisputeActivity set to SellerEndCommunication, CameToAgreementNeedFVFCredit, or MutualAgreementOrNoBuyerResponse.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SellerReverseDisputeCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SellerReverseDisputeCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SellerReverseDisputeCall ► ApiRequest
Gets or sets the SellerReverseDisputeRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SellerReverseDisputeRequestType ApiRequest { get; set; }
Public Property ApiRequest As SellerReverseDisputeRequestType
    Get
    Set
public:
property SellerReverseDisputeRequestType^ ApiRequest {
    SellerReverseDisputeRequestType^ get ();
    void set (SellerReverseDisputeRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SellerReverseDisputeCall ► ApiResponse
Gets the SellerReverseDisputeResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SellerReverseDisputeResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SellerReverseDisputeResponseType
    Get
public:
property SellerReverseDisputeResponseType^ ApiResponse {
    SellerReverseDisputeResponseType^ get ();
}


DisputeID Property

DisputeID Property
Namespaces ► eBay.Service.Call ► SellerReverseDisputeCall ► DisputeID
Gets or sets the DisputeID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string DisputeID { get; set; }
Public Property DisputeID As String
    Get
    Set
public:
property String^ DisputeID {
    String^ get ();
    void set (String^ value);
}


DisputeResolutionReason Property

DisputeResolutionReason Property
Namespaces ► eBay.Service.Call ► SellerReverseDisputeCall ► DisputeResolutionReason
Gets or sets the DisputeResolutionReason of type DisputeResolutionReasonCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionReasonCodeType DisputeResolutionReason { get; set; }
Public Property DisputeResolutionReason As DisputeResolutionReasonCodeType
    Get
    Set
public:
property DisputeResolutionReasonCodeType DisputeResolutionReason {
    DisputeResolutionReasonCodeType get ();
    void set (DisputeResolutionReasonCodeType value);
}


SellerReverseDispute Method (DisputeID, DisputeResolutionReason)

SellerReverseDispute Method (DisputeID, DisputeResolutionReason)
Namespaces ► eBay.Service.Call ► SellerReverseDisputeCall ► SellerReverseDispute(String, DisputeResolutionReasonCodeType)
Enables a seller to "reverse" an Unpaid Item dispute that has been closed, for example, if buyer and seller reach an agreement. The seller's Final Value Fee credit and the buyer's strike are both reversed, if applicable. The dispute might have resulted in a strike to the buyer and a Final Value Fee credit to the seller. A buyer and seller sometimes come to agreement after a dispute has been closed. In particular, the seller might discover that the buyer actually paid, or the buyer might agree to pay the seller's fees in exchange for having the strike removed. A dispute can only be reversed if it was closed with DisputeActivity set to SellerEndCommunication, CameToAgreementNeedFVFCredit, or MutualAgreementOrNoBuyerResponse.
Declaration Syntax
C# Visual Basic Visual C++
public void SellerReverseDispute(
    string DisputeID,
    DisputeResolutionReasonCodeType DisputeResolutionReason
)
Public Sub SellerReverseDispute ( _
    DisputeID As String, _
    DisputeResolutionReason As DisputeResolutionReasonCodeType _
)
public:
void SellerReverseDispute(
    String^ DisputeID,
    DisputeResolutionReasonCodeType DisputeResolutionReason
)
Parameters
DisputeID (String)
The unique identifier of the dispute that was returned when the dispute was created. The dispute must be an Unpaid Item dispute that the seller opened.
DisputeResolutionReason (DisputeResolutionReasonCodeType)
The reason the dispute is being reversed.


SellerReverseDisputeCall Constructor

SellerReverseDisputeCall Constructor
Namespaces ► eBay.Service.Call ► SellerReverseDisputeCall ► SellerReverseDisputeCall()()()()
Members
Icon | Member | Description
 | SellerReverseDisputeCall()()()() |
 | SellerReverseDisputeCall(ApiContext) |


SellerReverseDisputeCall Constructor

SellerReverseDisputeCall Constructor
Namespaces ► eBay.Service.Call ► SellerReverseDisputeCall ► SellerReverseDisputeCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerReverseDisputeCall()
Public Sub New
public:
SellerReverseDisputeCall()


SellerReverseDisputeCall Constructor (ApiContext)

SellerReverseDisputeCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SellerReverseDisputeCall ► SellerReverseDisputeCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SellerReverseDisputeCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SellerReverseDisputeCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SendInvoiceCall Class

SendInvoiceCall Class
Namespaces ► eBay.Service.Call ► SendInvoiceCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SendInvoiceCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SendInvoiceCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SendInvoiceCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SendInvoiceCall()()()() |
 | SendInvoiceCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AdjustmentAmount | Gets or sets the AdjustmentAmount of type AmountType.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SendInvoiceRequestType for this API call.
 | ApiResponse | Gets the SendInvoiceResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CheckoutInstructions | Gets or sets the CheckoutInstructions of type String.
 | CODCost | Gets or sets the CODCost of type AmountType.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EmailCopyToSeller | Gets or sets the EmailCopyToSeller of type Boolean.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InsuranceFee | Gets or sets the InsuranceFee of type AmountType.
 | InsuranceOption | Gets or sets the InsuranceOption of type InsuranceOptionCodeType.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | InternationalShippingServiceOptionsList | Gets or sets the InternationalShippingServiceOptions of type InternationalShippingServiceOptionsTypeCollection.
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderID | Gets or sets the OrderID of type String.
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | PaymentMethodsList | Gets or sets the PaymentMethods of type BuyerPaymentMethodCodeTypeCollection.
 | PayPalEmailAddress | Gets or sets the PayPalEmailAddress of type String.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SalesTax | Gets or sets the SalesTax of type SalesTaxType.
 | SendInvoice(String, String, String, InternationalShippingServiceOptionsTypeCollection, ShippingServiceOptionsTypeCollection, SalesTaxType, InsuranceOptionCodeType, AmountType, BuyerPaymentMethodCodeTypeCollection, String, String, Boolean, AmountType, String, String, AmountType) | Enables a seller to send an order invoice to a buyer. Where applicable, updates to shipping, payment methods, and sales tax made in this request are applied to the specified order as a whole and to the individual order line items whose data are stored in individual Transaction objects.
 | SendInvoice(String, String, ShippingServiceOptionsTypeCollection) | For backward compatibility with old wrappers.
 | SendInvoice(String) | For backward compatibility with old wrappers.
 | ShippingServiceOptionsList | Gets or sets the ShippingServiceOptions of type ShippingServiceOptionsTypeCollection.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SKU | Gets or sets the SKU of type String.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SendInvoiceCall


AdjustmentAmount Property

AdjustmentAmount Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► AdjustmentAmount
Gets or sets the AdjustmentAmount of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AdjustmentAmount { get; set; }
Public Property AdjustmentAmount As AmountType
    Get
    Set
public:
property AmountType^ AdjustmentAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► ApiRequest
Gets or sets the SendInvoiceRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SendInvoiceRequestType ApiRequest { get; set; }
Public Property ApiRequest As SendInvoiceRequestType
    Get
    Set
public:
property SendInvoiceRequestType^ ApiRequest {
    SendInvoiceRequestType^ get ();
    void set (SendInvoiceRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► ApiResponse
Gets the SendInvoiceResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SendInvoiceResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SendInvoiceResponseType
    Get
public:
property SendInvoiceResponseType^ ApiResponse {
    SendInvoiceResponseType^ get ();
}


CheckoutInstructions Property

CheckoutInstructions Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► CheckoutInstructions
Gets or sets the CheckoutInstructions of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CheckoutInstructions { get; set; }
Public Property CheckoutInstructions As String
    Get
    Set
public:
property String^ CheckoutInstructions {
    String^ get ();
    void set (String^ value);
}


CODCost Property

CODCost Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► CODCost
Gets or sets the CODCost of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CODCost { get; set; }
Public Property CODCost As AmountType
    Get
    Set
public:
property AmountType^ CODCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


EmailCopyToSeller Property

EmailCopyToSeller Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► EmailCopyToSeller
Gets or sets the EmailCopyToSeller of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailCopyToSeller { get; set; }
Public Property EmailCopyToSeller As Boolean
    Get
    Set
public:
property bool EmailCopyToSeller {
    bool get ();
    void set (bool value);
}


InsuranceFee Property

InsuranceFee Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► InsuranceFee
Gets or sets the InsuranceFee of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType InsuranceFee { get; set; }
Public Property InsuranceFee As AmountType
    Get
    Set
public:
property AmountType^ InsuranceFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


InsuranceOption Property

InsuranceOption Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► InsuranceOption
Gets or sets the InsuranceOption of type InsuranceOptionCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceOptionCodeType InsuranceOption { get; set; }
Public Property InsuranceOption As InsuranceOptionCodeType
    Get
    Set
public:
property InsuranceOptionCodeType InsuranceOption {
    InsuranceOptionCodeType get ();
    void set (InsuranceOptionCodeType value);
}


InternationalShippingServiceOptionsList Property

InternationalShippingServiceOptionsList Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► InternationalShippingServiceOptionsList
Gets or sets the InternationalShippingServiceOptions of type InternationalShippingServiceOptionsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public InternationalShippingServiceOptionsTypeCollection InternationalShippingServiceOptionsList { get; set; }
Public Property InternationalShippingServiceOptionsList As InternationalShippingServiceOptionsTypeCollection
    Get
    Set
public:
property InternationalShippingServiceOptionsTypeCollection^ InternationalShippingServiceOptionsList {
    InternationalShippingServiceOptionsTypeCollection^ get ();
    void set (InternationalShippingServiceOptionsTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► OrderID
Gets or sets the OrderID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


PaymentMethodsList Property

PaymentMethodsList Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► PaymentMethodsList
Gets or sets the PaymentMethods of type BuyerPaymentMethodCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeTypeCollection PaymentMethodsList { get; set; }
Public Property PaymentMethodsList As BuyerPaymentMethodCodeTypeCollection
    Get
    Set
public:
property BuyerPaymentMethodCodeTypeCollection^ PaymentMethodsList {
    BuyerPaymentMethodCodeTypeCollection^ get ();
    void set (BuyerPaymentMethodCodeTypeCollection^ value);
}


PayPalEmailAddress Property

PayPalEmailAddress Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► PayPalEmailAddress
Gets or sets the PayPalEmailAddress of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string PayPalEmailAddress { get; set; }
Public Property PayPalEmailAddress As String
    Get
    Set
public:
property String^ PayPalEmailAddress {
    String^ get ();
    void set (String^ value);
}


SalesTax Property

SalesTax Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► SalesTax
Gets or sets the SalesTax of type SalesTaxType.
Declaration Syntax
C# Visual Basic Visual C++
public SalesTaxType SalesTax { get; set; }
Public Property SalesTax As SalesTaxType
    Get
    Set
public:
property SalesTaxType^ SalesTax {
    SalesTaxType^ get ();
    void set (SalesTaxType^ value);
}


SendInvoice Method

SendInvoice Method
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► SendInvoice()()()()
Members
Icon | Member | Description
 | SendInvoice(String, String, String, InternationalShippingServiceOptionsTypeCollection, ShippingServiceOptionsTypeCollection, SalesTaxType, InsuranceOptionCodeType, AmountType, BuyerPaymentMethodCodeTypeCollection, String, String, Boolean, AmountType, String, String, AmountType) | Enables a seller to send an order invoice to a buyer. Where applicable, updates to shipping, payment methods, and sales tax made in this request are applied to the specified order as a whole and to the individual order line items whose data are stored in individual Transaction objects.
 | SendInvoice(String, String, ShippingServiceOptionsTypeCollection) | For backward compatibility with old wrappers.
 | SendInvoice(String) | For backward compatibility with old wrappers.


SendInvoice Method (ItemID, TransactionID, OrderID, InternationalShippingServiceOptionsList, ShippingServiceOptionsList, SalesTax, InsuranceOption, InsuranceFee, PaymentMethodsList, PayPalEmailAddress, CheckoutInstructions, EmailCopyToSeller, CODCost, SKU, OrderLineItemID, AdjustmentAmount)

SendInvoice Method (ItemID, TransactionID, OrderID, InternationalShippingServiceOptionsList, ShippingServiceOptionsList, SalesTax, InsuranceOption, InsuranceFee, PaymentMethodsList, PayPalEmailAddress, CheckoutInstructions, EmailCopyToSeller, CODCost, SKU, OrderLineItemID, AdjustmentAmount)
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► SendInvoice(String, String, String, InternationalShippingServiceOptionsTypeCollection, ShippingServiceOptionsTypeCollection, SalesTaxType, InsuranceOptionCodeType, AmountType, BuyerPaymentMethodCodeTypeCollection, String, String, Boolean, AmountType, String, String, AmountType)
Enables a seller to send an order invoice to a buyer. Where applicable, updates to shipping, payment methods, and sales tax made in this request are applied to the specified order as a whole and to the individual order line items whose data are stored in individual Transaction objects.
Declaration Syntax
C# Visual Basic Visual C++
public void SendInvoice(
    string ItemID,
    string TransactionID,
    string OrderID,
    InternationalShippingServiceOptionsTypeCollection InternationalShippingServiceOptionsList,
    ShippingServiceOptionsTypeCollection ShippingServiceOptionsList,
    SalesTaxType SalesTax,
    InsuranceOptionCodeType InsuranceOption,
    AmountType InsuranceFee,
    BuyerPaymentMethodCodeTypeCollection PaymentMethodsList,
    string PayPalEmailAddress,
    string CheckoutInstructions,
    bool EmailCopyToSeller,
    AmountType CODCost,
    string SKU,
    string OrderLineItemID,
    AmountType AdjustmentAmount
)
Public Sub SendInvoice ( _
    ItemID As String, _
    TransactionID As String, _
    OrderID As String, _
    InternationalShippingServiceOptionsList As InternationalShippingServiceOptionsTypeCollection, _
    ShippingServiceOptionsList As ShippingServiceOptionsTypeCollection, _
    SalesTax As SalesTaxType, _
    InsuranceOption As InsuranceOptionCodeType, _
    InsuranceFee As AmountType, _
    PaymentMethodsList As BuyerPaymentMethodCodeTypeCollection, _
    PayPalEmailAddress As String, _
    CheckoutInstructions As String, _
    EmailCopyToSeller As Boolean, _
    CODCost As AmountType, _
    SKU As String, _
    OrderLineItemID As String, _
    AdjustmentAmount As AmountType _
)
public:
void SendInvoice(
    String^ ItemID,
    String^ TransactionID,
    String^ OrderID,
    InternationalShippingServiceOptionsTypeCollection^ InternationalShippingServiceOptionsList,
    ShippingServiceOptionsTypeCollection^ ShippingServiceOptionsList,
    SalesTaxType^ SalesTax,
    InsuranceOptionCodeType InsuranceOption,
    AmountType^ InsuranceFee,
    BuyerPaymentMethodCodeTypeCollection^ PaymentMethodsList,
    String^ PayPalEmailAddress,
    String^ CheckoutInstructions,
    bool EmailCopyToSeller,
    AmountType^ CODCost,
    String^ SKU,
    String^ OrderLineItemID,
    AmountType^ AdjustmentAmount
)
Parameters
ItemID (String)
Unique identifier for an eBay item listing. Unless OrderID or OrderLineItemID is provided in the request, the ItemID (or SKU) is required and must be paired with the corresponding TransactionID to identify a single line item order. For a multiple line item (Combined Invoice) order, OrderID should be used.
TransactionID (String)
Unique identifier for an eBay order line item (transaction). An order line item is created once there is a commitment from a buyer to purchase an item. Since an auction listing can only have one order line item during the duration of the listing, the TransactionID for auction listings is always 0. Unless OrderID or OrderLineItemID is provided in the request, the TransactionID is required and must be paired with the corresponding ItemID to identify a single line item order. For a multiple line item (Combined Invoice) order, OrderID should be used.
OrderID (String)
A unique identifier that identifies a single line item or multiple line item (Combined Invoice) orders. For a single line item order, the OrderID value is identical to the OrderLineItemID value that is generated upon creation of the order line item. For a Combined Invoice order, the OrderID value is created by eBay when the buyer or seller (sharing multiple, common order line items) combines multiple order line items into a Combined Invoice order. A Combined Invoice order can also be created by the seller through the AddOrder call. Unless the ItemID (or SKU) and corresponding TransactionID, or the OrderLineItemID is provided in the request to identify a single line item order, the OrderID must be specified. If OrderID is specified, OrderLineItemID, ItemID, TransactionID, and SKU are ignored if present in the same request.
InternationalShippingServiceOptionsList (InternationalShippingServiceOptionsTypeCollection)
If the buyer has an International shipping address, use this container to offer up to three International shipping services. If International shipping services are offered, (domestic) ShippingServiceOptions should not be included in the request.
ShippingServiceOptionsList (ShippingServiceOptionsTypeCollection)
If the buyer has a domestic shipping address, use this container to offer up to three domestic shipping services. If domestic shipping services are offered, InternationalShippingServiceOptions should not be included in the request.
SalesTax (SalesTaxType)
Container consisting of sales tax details. The amount of sales tax to add to the price of an order is dependent on the sales tax rate in the buyer's state and whether sales tax is being applied to the cost of the order only or the cost of the order plus shipping.
InsuranceOption (InsuranceOptionCodeType)
Specifies whether an insurance fee is required. An InsuranceOption value of IncludedInShippingHandling cannot be used if the item will use calculated shipping. Some shipping carriers automatically include shipping insurance for qualifying items.
InsuranceFee (AmountType)
Insurance cost, as set by seller, if ShippingType = 1. Specify if InsuranceOption is optional or required. Must be greater than zero value if a value of Optional or Required is passed in InsuranceOption. Value specified should be the total cost of insuring the item.
PaymentMethodsList (BuyerPaymentMethodCodeTypeCollection)
This optional field allows a US or German seller to add specific payment methods that were not in the original item listing. The only valid values for this field are 'PayPal' for a US listing, or 'MoneyXferAcceptedInCheckout' (CIP+) for a DE listing.
PayPalEmailAddress (String)
If the PaymentMethods field is used and set to PayPal, the seller provides his/her PayPal email address in this field.
CheckoutInstructions (String)
This field allows the seller to provide a message or instructions regarding checkout/payment or the return policy.
EmailCopyToSeller (Boolean)
Flag indicating whether or not the seller wishes to receive an email copy of the invoice sent to the buyer.
CODCost (AmountType)
This dollar value indicates the money due from the buyer upon delivery of the item. This field should only be specified in the SendInvoice request if 'COD' (cash-on-delivery) was the payment method selected by the buyer and it is included as the PaymentMethods value in the same request.
SKU (String)
The seller's unique identifier for an item that is being tracked by this SKU. If OrderID or OrderLineItemID are not provided, both SKU (or ItemID) and corresponding TransactionID must be provided to uniquely identify a single line item order. For a multiple line item (Combined Invoice) order, OrderID must be used. This field can only be used if the Item.InventoryTrackingMethod field (set with the AddFixedPriceItem or RelistFixedPriceItem calls) is set to SKU.
OrderLineItemID (String)
A unique identifier for an eBay order line item. This field is created as soon as there is a commitment to buy from the seller, and its value is based upon the concatenation of ItemID and TransactionID, with a hyphen in between these two IDs. Unless the ItemID (or SKU) and corresponding TransactionID is used to identify a single line item order, or the OrderID is used to identify a single or multiple line item (Combined Invoice) order, the OrderLineItemID must be specified. For a multiple line item (Combined Invoice) order, OrderID should be used. If OrderLineItemID is specified, ItemID, TransactionID, and SKU are ignored if present in the same request.
AdjustmentAmount (AmountType)
This field allows the seller to adjust the total cost of the order to account for an extra charge or to pass down a discount to the buyer. The currency used in this field must be the same currency of the listing site. A positive value in this field indicates that the amount is an extra charge being paid to the seller by the buyer, and a negative value indicates that the amount is a discount given to the buyer by the seller.


SendInvoice Method (ItemID, TransactionID, ShippingServiceOptionsList)

SendInvoice Method (ItemID, TransactionID, ShippingServiceOptionsList)
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► SendInvoice(String, String, ShippingServiceOptionsTypeCollection)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void SendInvoice(
    string ItemID,
    string TransactionID,
    ShippingServiceOptionsTypeCollection ShippingServiceOptionsList
)
Public Sub SendInvoice ( _
    ItemID As String, _
    TransactionID As String, _
    ShippingServiceOptionsList As ShippingServiceOptionsTypeCollection _
)
public:
void SendInvoice(
    String^ ItemID,
    String^ TransactionID,
    ShippingServiceOptionsTypeCollection^ ShippingServiceOptionsList
)
Parameters
ItemID (String)
TransactionID (String)
ShippingServiceOptionsList (ShippingServiceOptionsTypeCollection)


SendInvoice Method (OrderID)

SendInvoice Method (OrderID)
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► SendInvoice(String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void SendInvoice(
    string OrderID
)
Public Sub SendInvoice ( _
    OrderID As String _
)
public:
void SendInvoice(
    String^ OrderID
)
Parameters
OrderID (String)


SendInvoiceCall Constructor

SendInvoiceCall Constructor
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► SendInvoiceCall()()()()
Members
Icon | Member | Description
 | SendInvoiceCall()()()() |
 | SendInvoiceCall(ApiContext) |


SendInvoiceCall Constructor

SendInvoiceCall Constructor
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► SendInvoiceCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SendInvoiceCall()
Public Sub New
public:
SendInvoiceCall()


SendInvoiceCall Constructor (ApiContext)

SendInvoiceCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► SendInvoiceCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SendInvoiceCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SendInvoiceCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ShippingServiceOptionsList Property

ShippingServiceOptionsList Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► ShippingServiceOptionsList
Gets or sets the ShippingServiceOptions of type ShippingServiceOptionsTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsTypeCollection ShippingServiceOptionsList { get; set; }
Public Property ShippingServiceOptionsList As ShippingServiceOptionsTypeCollection
    Get
    Set
public:
property ShippingServiceOptionsTypeCollection^ ShippingServiceOptionsList {
    ShippingServiceOptionsTypeCollection^ get ();
    void set (ShippingServiceOptionsTypeCollection^ value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► SKU
Gets or sets the SKU of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► SendInvoiceCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


SetMessagePreferencesCall Class

SetMessagePreferencesCall Class
Namespaces ► eBay.Service.Call ► SetMessagePreferencesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetMessagePreferencesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetMessagePreferencesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetMessagePreferencesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetMessagePreferencesCall()()()() |
 | SetMessagePreferencesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetMessagePreferencesRequestType for this API call.
 | ApiResponse | Gets the SetMessagePreferencesResponseType for this API call.
 | ASQPreferences | Gets or sets the ASQPreferences of type ASQPreferencesType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetMessagePreferences(ASQPreferencesType) | Enables a seller to add custom Ask Seller a Question (ASQ) subjects to their Ask a Question page, or to reset any custom subjects to their default values.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetMessagePreferencesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetMessagePreferencesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetMessagePreferencesCall ► ApiRequest
Gets or sets the SetMessagePreferencesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetMessagePreferencesRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetMessagePreferencesRequestType
    Get
    Set
public:
property SetMessagePreferencesRequestType^ ApiRequest {
    SetMessagePreferencesRequestType^ get ();
    void set (SetMessagePreferencesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetMessagePreferencesCall ► ApiResponse
Gets the SetMessagePreferencesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetMessagePreferencesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetMessagePreferencesResponseType
    Get
public:
property SetMessagePreferencesResponseType^ ApiResponse {
    SetMessagePreferencesResponseType^ get ();
}


ASQPreferences Property

ASQPreferences Property
Namespaces ► eBay.Service.Call ► SetMessagePreferencesCall ► ASQPreferences
Gets or sets the ASQPreferences of type ASQPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public ASQPreferencesType ASQPreferences { get; set; }
Public Property ASQPreferences As ASQPreferencesType
    Get
    Set
public:
property ASQPreferencesType^ ASQPreferences {
    ASQPreferencesType^ get ();
    void set (ASQPreferencesType^ value);
}


SetMessagePreferences Method (ASQPreferences)

SetMessagePreferences Method (ASQPreferences)
Namespaces ► eBay.Service.Call ► SetMessagePreferencesCall ► SetMessagePreferences(ASQPreferencesType)
Enables a seller to add custom Ask Seller a Question (ASQ) subjects to their Ask a Question page, or to reset any custom subjects to their default values.
Declaration Syntax
C# Visual Basic Visual C++
public void SetMessagePreferences(
    ASQPreferencesType ASQPreferences
)
Public Sub SetMessagePreferences ( _
    ASQPreferences As ASQPreferencesType _
)
public:
void SetMessagePreferences(
    ASQPreferencesType^ ASQPreferences
)
Parameters
ASQPreferences (ASQPreferencesType)
Contains custom ASQ subjects or a flag to reset those subjects to their default values.


SetMessagePreferencesCall Constructor

SetMessagePreferencesCall Constructor
Namespaces ► eBay.Service.Call ► SetMessagePreferencesCall ► SetMessagePreferencesCall()()()()
Members
Icon | Member | Description
 | SetMessagePreferencesCall()()()() |
 | SetMessagePreferencesCall(ApiContext) |


SetMessagePreferencesCall Constructor

SetMessagePreferencesCall Constructor
Namespaces ► eBay.Service.Call ► SetMessagePreferencesCall ► SetMessagePreferencesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetMessagePreferencesCall()
Public Sub New
public:
SetMessagePreferencesCall()


SetMessagePreferencesCall Constructor (ApiContext)

SetMessagePreferencesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetMessagePreferencesCall ► SetMessagePreferencesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetMessagePreferencesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetMessagePreferencesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SetNotificationPreferencesCall Class

SetNotificationPreferencesCall Class
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetNotificationPreferencesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetNotificationPreferencesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetNotificationPreferencesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetNotificationPreferencesCall()()()() |
 | SetNotificationPreferencesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetNotificationPreferencesRequestType for this API call.
 | ApiResponse | Gets the SetNotificationPreferencesResponseType for this API call.
 | ApplicationDeliveryPreferences | Gets or sets the ApplicationDeliveryPreferences of type ApplicationDeliveryPreferencesType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeliveryURLName | Gets or sets the DeliveryURLName of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | EventPropertyList | Gets or sets the EventProperty of type NotificationEventPropertyTypeCollection.
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetNotificationPreferences(ApplicationDeliveryPreferencesType, NotificationEnableTypeCollection, NotificationUserDataType, NotificationEventPropertyTypeCollection, String) | Manages notification and alert preferences for applications and users.
 | SetNotificationPreferences(NotificationEnableTypeCollection) | For backward compatibility with old wrappers.
 | SetNotificationPreferences(ApplicationDeliveryPreferencesType) | For backward compatibility with old wrappers.
 | SetNotificationPreferences(ApplicationDeliveryPreferencesType, NotificationEnableTypeCollection) | For backward compatibility with old wrappers.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UserData | Gets or sets the UserData of type NotificationUserDataType.
 | UserDeliveryPreferenceList | Gets or sets the UserDeliveryPreferenceArray of type NotificationEnableTypeCollection.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetNotificationPreferencesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► ApiRequest
Gets or sets the SetNotificationPreferencesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetNotificationPreferencesRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetNotificationPreferencesRequestType
    Get
    Set
public:
property SetNotificationPreferencesRequestType^ ApiRequest {
    SetNotificationPreferencesRequestType^ get ();
    void set (SetNotificationPreferencesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► ApiResponse
Gets the SetNotificationPreferencesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetNotificationPreferencesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetNotificationPreferencesResponseType
    Get
public:
property SetNotificationPreferencesResponseType^ ApiResponse {
    SetNotificationPreferencesResponseType^ get ();
}


ApplicationDeliveryPreferences Property

ApplicationDeliveryPreferences Property
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► ApplicationDeliveryPreferences
Gets or sets the ApplicationDeliveryPreferences of type ApplicationDeliveryPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public ApplicationDeliveryPreferencesType ApplicationDeliveryPreferences { get; set; }
Public Property ApplicationDeliveryPreferences As ApplicationDeliveryPreferencesType
    Get
    Set
public:
property ApplicationDeliveryPreferencesType^ ApplicationDeliveryPreferences {
    ApplicationDeliveryPreferencesType^ get ();
    void set (ApplicationDeliveryPreferencesType^ value);
}


DeliveryURLName Property

DeliveryURLName Property
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► DeliveryURLName
Gets or sets the DeliveryURLName of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryURLName { get; set; }
Public Property DeliveryURLName As String
    Get
    Set
public:
property String^ DeliveryURLName {
    String^ get ();
    void set (String^ value);
}


EventPropertyList Property

EventPropertyList Property
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► EventPropertyList
Gets or sets the EventProperty of type NotificationEventPropertyTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyTypeCollection EventPropertyList { get; set; }
Public Property EventPropertyList As NotificationEventPropertyTypeCollection
    Get
    Set
public:
property NotificationEventPropertyTypeCollection^ EventPropertyList {
    NotificationEventPropertyTypeCollection^ get ();
    void set (NotificationEventPropertyTypeCollection^ value);
}


SetNotificationPreferences Method

SetNotificationPreferences Method
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► SetNotificationPreferences()()()()
Members
Icon | Member | Description
 | SetNotificationPreferences(ApplicationDeliveryPreferencesType, NotificationEnableTypeCollection, NotificationUserDataType, NotificationEventPropertyTypeCollection, String) | Manages notification and alert preferences for applications and users.
 | SetNotificationPreferences(NotificationEnableTypeCollection) | For backward compatibility with old wrappers.
 | SetNotificationPreferences(ApplicationDeliveryPreferencesType) | For backward compatibility with old wrappers.
 | SetNotificationPreferences(ApplicationDeliveryPreferencesType, NotificationEnableTypeCollection) | For backward compatibility with old wrappers.


SetNotificationPreferences Method (ApplicationDeliveryPreferences)

SetNotificationPreferences Method (ApplicationDeliveryPreferences)
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► SetNotificationPreferences(ApplicationDeliveryPreferencesType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void SetNotificationPreferences(
    ApplicationDeliveryPreferencesType ApplicationDeliveryPreferences
)
Public Sub SetNotificationPreferences ( _
    ApplicationDeliveryPreferences As ApplicationDeliveryPreferencesType _
)
public:
void SetNotificationPreferences(
    ApplicationDeliveryPreferencesType^ ApplicationDeliveryPreferences
)
Parameters
ApplicationDeliveryPreferences (ApplicationDeliveryPreferencesType)


SetNotificationPreferences Method (ApplicationDeliveryPreferences, UserDeliveryPreferenceList)

SetNotificationPreferences Method (ApplicationDeliveryPreferences, UserDeliveryPreferenceList)
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► SetNotificationPreferences(ApplicationDeliveryPreferencesType, NotificationEnableTypeCollection)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void SetNotificationPreferences(
    ApplicationDeliveryPreferencesType ApplicationDeliveryPreferences,
    NotificationEnableTypeCollection UserDeliveryPreferenceList
)
Public Sub SetNotificationPreferences ( _
    ApplicationDeliveryPreferences As ApplicationDeliveryPreferencesType, _
    UserDeliveryPreferenceList As NotificationEnableTypeCollection _
)
public:
void SetNotificationPreferences(
    ApplicationDeliveryPreferencesType^ ApplicationDeliveryPreferences,
    NotificationEnableTypeCollection^ UserDeliveryPreferenceList
)
Parameters
ApplicationDeliveryPreferences (ApplicationDeliveryPreferencesType)
UserDeliveryPreferenceList (NotificationEnableTypeCollection)


SetNotificationPreferences Method (ApplicationDeliveryPreferences, UserDeliveryPreferenceList, UserData, EventPropertyList, DeliveryURLName)

SetNotificationPreferences Method (ApplicationDeliveryPreferences, UserDeliveryPreferenceList, UserData, EventPropertyList, DeliveryURLName)
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► SetNotificationPreferences(ApplicationDeliveryPreferencesType, NotificationEnableTypeCollection, NotificationUserDataType, NotificationEventPropertyTypeCollection, String)
Manages notification and alert preferences for applications and users.
Declaration Syntax
C# Visual Basic Visual C++
public void SetNotificationPreferences(
    ApplicationDeliveryPreferencesType ApplicationDeliveryPreferences,
    NotificationEnableTypeCollection UserDeliveryPreferenceList,
    NotificationUserDataType UserData,
    NotificationEventPropertyTypeCollection EventPropertyList,
    string DeliveryURLName
)
Public Sub SetNotificationPreferences ( _
    ApplicationDeliveryPreferences As ApplicationDeliveryPreferencesType, _
    UserDeliveryPreferenceList As NotificationEnableTypeCollection, _
    UserData As NotificationUserDataType, _
    EventPropertyList As NotificationEventPropertyTypeCollection, _
    DeliveryURLName As String _
)
public:
void SetNotificationPreferences(
    ApplicationDeliveryPreferencesType^ ApplicationDeliveryPreferences,
    NotificationEnableTypeCollection^ UserDeliveryPreferenceList,
    NotificationUserDataType^ UserData,
    NotificationEventPropertyTypeCollection^ EventPropertyList,
    String^ DeliveryURLName
)
Parameters
ApplicationDeliveryPreferences (ApplicationDeliveryPreferencesType)
Specifies application-level event preferences that have been enabled, including the URL to which notifications should be delivered and whether notifications should be enabled or disabled (although the UserDeliveryPreferenceArray input property specifies specific notification subscriptions).
UserDeliveryPreferenceList (NotificationEnableTypeCollection)
Specifies events and whether or not they are enabled.
UserData (NotificationUserDataType)
Specifies user data for notification settings, such as mobile phone number.
EventPropertyList (NotificationEventPropertyTypeCollection)
Characteristics or details of an event such as type, name and value. Currently can only be set for wireless applications.
DeliveryURLName (String)
Specifies up to 25 ApplicationDeliveryPreferences.DeliveryURLDetails.DeliveryURLName to associate with a user token sent in a SetNotificationPreferences request. To specify multiple DeliveryURLNames, create separate instances of ApplicationDeliveryPreferences.DeliveryURLDetails.DeliveryURLName, and then enable up to 25 DeliveryURLNames by including them in comma-separated format in this field.


SetNotificationPreferences Method (UserDeliveryPreferenceList)

SetNotificationPreferences Method (UserDeliveryPreferenceList)
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► SetNotificationPreferences(NotificationEnableTypeCollection)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void SetNotificationPreferences(
    NotificationEnableTypeCollection UserDeliveryPreferenceList
)
Public Sub SetNotificationPreferences ( _
    UserDeliveryPreferenceList As NotificationEnableTypeCollection _
)
public:
void SetNotificationPreferences(
    NotificationEnableTypeCollection^ UserDeliveryPreferenceList
)
Parameters
UserDeliveryPreferenceList (NotificationEnableTypeCollection)


SetNotificationPreferencesCall Constructor

SetNotificationPreferencesCall Constructor
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► SetNotificationPreferencesCall()()()()
Members
Icon | Member | Description
 | SetNotificationPreferencesCall()()()() |
 | SetNotificationPreferencesCall(ApiContext) |


SetNotificationPreferencesCall Constructor

SetNotificationPreferencesCall Constructor
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► SetNotificationPreferencesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetNotificationPreferencesCall()
Public Sub New
public:
SetNotificationPreferencesCall()


SetNotificationPreferencesCall Constructor (ApiContext)

SetNotificationPreferencesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► SetNotificationPreferencesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetNotificationPreferencesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetNotificationPreferencesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


UserData Property

UserData Property
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► UserData
Gets or sets the UserData of type NotificationUserDataType.
Declaration Syntax
C# Visual Basic Visual C++
public NotificationUserDataType UserData { get; set; }
Public Property UserData As NotificationUserDataType
    Get
    Set
public:
property NotificationUserDataType^ UserData {
    NotificationUserDataType^ get ();
    void set (NotificationUserDataType^ value);
}


UserDeliveryPreferenceList Property

UserDeliveryPreferenceList Property
Namespaces ► eBay.Service.Call ► SetNotificationPreferencesCall ► UserDeliveryPreferenceList
Gets or sets the UserDeliveryPreferenceArray of type NotificationEnableTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEnableTypeCollection UserDeliveryPreferenceList { get; set; }
Public Property UserDeliveryPreferenceList As NotificationEnableTypeCollection
    Get
    Set
public:
property NotificationEnableTypeCollection^ UserDeliveryPreferenceList {
    NotificationEnableTypeCollection^ get ();
    void set (NotificationEnableTypeCollection^ value);
}


SetPromotionalSaleCall Class

SetPromotionalSaleCall Class
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetPromotionalSaleCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetPromotionalSaleCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetPromotionalSaleCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetPromotionalSaleCall()()()() |
 | SetPromotionalSaleCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | Action | Gets or sets the Action of type ModifyActionCodeType.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetPromotionalSaleRequestType for this API call.
 | ApiResponse | Gets the SetPromotionalSaleResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PromotionalSaleDetails | Gets or sets the PromotionalSaleDetails of type PromotionalSaleType.
 | PromotionalSaleID | Gets the returned PromotionalSaleID of type Int64.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetPromotionalSale(ModifyActionCodeType, PromotionalSaleType) | Creates or modifies a promotional sale. Promotional sales enable sellers to apply discounts and/or free shipping across many listings.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Status | Gets the returned Status of type PromotionalSaleStatusCodeType.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetPromotionalSaleCall


Action Property

Action Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall ► Action
Gets or sets the Action of type ModifyActionCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public ModifyActionCodeType Action { get; set; }
Public Property Action As ModifyActionCodeType
    Get
    Set
public:
property ModifyActionCodeType Action {
    ModifyActionCodeType get ();
    void set (ModifyActionCodeType value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall ► ApiRequest
Gets or sets the SetPromotionalSaleRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetPromotionalSaleRequestType
    Get
    Set
public:
property SetPromotionalSaleRequestType^ ApiRequest {
    SetPromotionalSaleRequestType^ get ();
    void set (SetPromotionalSaleRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall ► ApiResponse
Gets the SetPromotionalSaleResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetPromotionalSaleResponseType
    Get
public:
property SetPromotionalSaleResponseType^ ApiResponse {
    SetPromotionalSaleResponseType^ get ();
}


PromotionalSaleDetails Property

PromotionalSaleDetails Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall ► PromotionalSaleDetails
Gets or sets the PromotionalSaleDetails of type PromotionalSaleType.
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleType PromotionalSaleDetails { get; set; }
Public Property PromotionalSaleDetails As PromotionalSaleType
    Get
    Set
public:
property PromotionalSaleType^ PromotionalSaleDetails {
    PromotionalSaleType^ get ();
    void set (PromotionalSaleType^ value);
}


PromotionalSaleID Property

PromotionalSaleID Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall ► PromotionalSaleID
Gets the returned PromotionalSaleID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long PromotionalSaleID { get; }
Public ReadOnly Property PromotionalSaleID As Long
    Get
public:
property long long PromotionalSaleID {
    long long get ();
}


SetPromotionalSale Method (Action, PromotionalSaleDetails)

SetPromotionalSale Method (Action, PromotionalSaleDetails)
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall ► SetPromotionalSale(ModifyActionCodeType, PromotionalSaleType)
Creates or modifies a promotional sale. Promotional sales enable sellers to apply discounts and/or free shipping across many listings.
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeType SetPromotionalSale(
    ModifyActionCodeType Action,
    PromotionalSaleType PromotionalSaleDetails
)
Public Function SetPromotionalSale ( _
    Action As ModifyActionCodeType, _
    PromotionalSaleDetails As PromotionalSaleType _
) As PromotionalSaleStatusCodeType
public:
PromotionalSaleStatusCodeType SetPromotionalSale(
    ModifyActionCodeType Action,
    PromotionalSaleType^ PromotionalSaleDetails
)
Parameters
Action (ModifyActionCodeType)
The seller must include this field and set it to 'Add' to create a new promotional sale, or set it to 'Update' to modify an existing promotional sale, or set it to 'Delete' to delete a promotional sale.
PromotionalSaleDetails (PromotionalSaleType)
This container must be included in each SetPromotionalSale call. The fields of this container that will be used will depend on whether the seller is adding a new promotional sale, updating an existing promotional sale, or deleting an existing promotional sale.


SetPromotionalSaleCall Constructor

SetPromotionalSaleCall Constructor
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall ► SetPromotionalSaleCall()()()()
Members
Icon | Member | Description
 | SetPromotionalSaleCall()()()() |
 | SetPromotionalSaleCall(ApiContext) |


SetPromotionalSaleCall Constructor

SetPromotionalSaleCall Constructor
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall ► SetPromotionalSaleCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleCall()
Public Sub New
public:
SetPromotionalSaleCall()


SetPromotionalSaleCall Constructor (ApiContext)

SetPromotionalSaleCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall ► SetPromotionalSaleCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetPromotionalSaleCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


Status Property

Status Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleCall ► Status
Gets the returned Status of type PromotionalSaleStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeType Status { get; }
Public ReadOnly Property Status As PromotionalSaleStatusCodeType
    Get
public:
property PromotionalSaleStatusCodeType Status {
    PromotionalSaleStatusCodeType get ();
}


SetPromotionalSaleListingsCall Class

SetPromotionalSaleListingsCall Class
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetPromotionalSaleListingsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetPromotionalSaleListingsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetPromotionalSaleListingsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetPromotionalSaleListingsCall()()()() |
 | SetPromotionalSaleListingsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | Action | Gets or sets the Action of type ModifyActionCodeType.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | AllAuctionItems | Gets or sets the AllAuctionItems of type Boolean.
 | AllFixedPriceItems | Gets or sets the AllFixedPriceItems of type Boolean.
 | AllStoreInventoryItems | Gets or sets the AllStoreInventoryItems of type Boolean.
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetPromotionalSaleListingsRequestType for this API call.
 | ApiResponse | Gets the SetPromotionalSaleListingsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CategoryID | Gets or sets the CategoryID of type Int64.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | PromotionalSaleID | Gets or sets the PromotionalSaleID of type Int64.
 | PromotionalSaleItemIDArrayList | Gets or sets the PromotionalSaleItemIDArray of type ItemIDArrayType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetPromotionalSaleListings(Int64, ModifyActionCodeType, ItemIDArrayType, Int64, Int64, Boolean, Boolean, Boolean) | Enables the seller to change the item listings that are affected by a promotional sale.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Status | Gets the returned Status of type PromotionalSaleStatusCodeType.
 | StoreCategoryID | Gets or sets the StoreCategoryID of type Int64.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetPromotionalSaleListingsCall


Action Property

Action Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► Action
Gets or sets the Action of type ModifyActionCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public ModifyActionCodeType Action { get; set; }
Public Property Action As ModifyActionCodeType
    Get
    Set
public:
property ModifyActionCodeType Action {
    ModifyActionCodeType get ();
    void set (ModifyActionCodeType value);
}


AllAuctionItems Property

AllAuctionItems Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► AllAuctionItems
Gets or sets the AllAuctionItems of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool AllAuctionItems { get; set; }
Public Property AllAuctionItems As Boolean
    Get
    Set
public:
property bool AllAuctionItems {
    bool get ();
    void set (bool value);
}


AllFixedPriceItems Property

AllFixedPriceItems Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► AllFixedPriceItems
Gets or sets the AllFixedPriceItems of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool AllFixedPriceItems { get; set; }
Public Property AllFixedPriceItems As Boolean
    Get
    Set
public:
property bool AllFixedPriceItems {
    bool get ();
    void set (bool value);
}


AllStoreInventoryItems Property

AllStoreInventoryItems Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► AllStoreInventoryItems
Gets or sets the AllStoreInventoryItems of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool AllStoreInventoryItems { get; set; }
Public Property AllStoreInventoryItems As Boolean
    Get
    Set
public:
property bool AllStoreInventoryItems {
    bool get ();
    void set (bool value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► ApiRequest
Gets or sets the SetPromotionalSaleListingsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleListingsRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetPromotionalSaleListingsRequestType
    Get
    Set
public:
property SetPromotionalSaleListingsRequestType^ ApiRequest {
    SetPromotionalSaleListingsRequestType^ get ();
    void set (SetPromotionalSaleListingsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► ApiResponse
Gets the SetPromotionalSaleListingsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleListingsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetPromotionalSaleListingsResponseType
    Get
public:
property SetPromotionalSaleListingsResponseType^ ApiResponse {
    SetPromotionalSaleListingsResponseType^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► CategoryID
Gets or sets the CategoryID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long CategoryID { get; set; }
Public Property CategoryID As Long
    Get
    Set
public:
property long long CategoryID {
    long long get ();
    void set (long long value);
}


PromotionalSaleID Property

PromotionalSaleID Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► PromotionalSaleID
Gets or sets the PromotionalSaleID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long PromotionalSaleID { get; set; }
Public Property PromotionalSaleID As Long
    Get
    Set
public:
property long long PromotionalSaleID {
    long long get ();
    void set (long long value);
}


PromotionalSaleItemIDArrayList Property

PromotionalSaleItemIDArrayList Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► PromotionalSaleItemIDArrayList
Gets or sets the PromotionalSaleItemIDArray of type ItemIDArrayType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemIDArrayType PromotionalSaleItemIDArrayList { get; set; }
Public Property PromotionalSaleItemIDArrayList As ItemIDArrayType
    Get
    Set
public:
property ItemIDArrayType^ PromotionalSaleItemIDArrayList {
    ItemIDArrayType^ get ();
    void set (ItemIDArrayType^ value);
}


SetPromotionalSaleListings Method (PromotionalSaleID, Action, PromotionalSaleItemIDArrayList, StoreCategoryID, CategoryID, AllFixedPriceItems, AllStoreInventoryItems, AllAuctionItems)

SetPromotionalSaleListings Method (PromotionalSaleID, Action, PromotionalSaleItemIDArrayList, StoreCategoryID, CategoryID, AllFixedPriceItems, AllStoreInventoryItems, AllAuctionItems)
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► SetPromotionalSaleListings(Int64, ModifyActionCodeType, ItemIDArrayType, Int64, Int64, Boolean, Boolean, Boolean)
Enables the seller to change the item listings that are affected by a promotional sale.
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeType SetPromotionalSaleListings(
    long PromotionalSaleID,
    ModifyActionCodeType Action,
    ItemIDArrayType PromotionalSaleItemIDArrayList,
    long StoreCategoryID,
    long CategoryID,
    bool AllFixedPriceItems,
    bool AllStoreInventoryItems,
    bool AllAuctionItems
)
Public Function SetPromotionalSaleListings ( _
    PromotionalSaleID As Long, _
    Action As ModifyActionCodeType, _
    PromotionalSaleItemIDArrayList As ItemIDArrayType, _
    StoreCategoryID As Long, _
    CategoryID As Long, _
    AllFixedPriceItems As Boolean, _
    AllStoreInventoryItems As Boolean, _
    AllAuctionItems As Boolean _
) As PromotionalSaleStatusCodeType
public:
PromotionalSaleStatusCodeType SetPromotionalSaleListings(
    long long PromotionalSaleID,
    ModifyActionCodeType Action,
    ItemIDArrayType^ PromotionalSaleItemIDArrayList,
    long long StoreCategoryID,
    long long CategoryID,
    bool AllFixedPriceItems,
    bool AllStoreInventoryItems,
    bool AllAuctionItems
)
Parameters
PromotionalSaleID (Int64)
The unique identifier of the seller's promotional sale. Based on the Action value, listings will either be added to or removed from the promotional sale.
Action (ModifyActionCodeType)
This required field determines whether you are adding (specify 'Add') or removing (specify 'Delete) one or more listings from the promotional sale identified by the PromotionalSaleID value in the request. If you specify 'Delete', you must include one or more ItemID values under the PromotionalSaleItemIDArray container, and you cannot use the other filter options in the request. If you specify 'Add', you can add one or more listings using any of the filtering options in the request. Active auction listings that have one or more bids cannot be added to or removed from a promotional sale.
PromotionalSaleItemIDArrayList (ItemIDArrayType)
Container consisting of one or more ItemID values. Based on the Action value, the listings identified by these ItemID values are either added to or removed from the promotional sale. This container is required if listings are being removed (Action='Delete') from the promotional sale.
StoreCategoryID (Int64)
If a StoreCategoryID value is included in the call request, all active items in this store category are added to the promotional sale. This field cannot be used if the Action field is set to 'Delete'.
CategoryID (Int64)
If a CategoryID value is included in the call request, all active items in this eBay category are added to the promotional sale. This field cannot be used if the Action field is set to 'Delete'.
AllFixedPriceItems (Boolean)
If this field is included and set to 'true' in the call request, all fixed-price listings are added to the promotional sale. This field cannot be used if the Action field is set to 'Delete'.
AllStoreInventoryItems (Boolean)
This field is deprecated and should no longer be used because Store Inventory is no longer a supported listing format.
AllAuctionItems (Boolean)
If this field is included and set to 'true' in the call request, all auction listings are added to the promotional sale. This field cannot be used if the Action field is set to 'Delete'.


SetPromotionalSaleListingsCall Constructor

SetPromotionalSaleListingsCall Constructor
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► SetPromotionalSaleListingsCall()()()()
Members
Icon | Member | Description
 | SetPromotionalSaleListingsCall()()()() |
 | SetPromotionalSaleListingsCall(ApiContext) |


SetPromotionalSaleListingsCall Constructor

SetPromotionalSaleListingsCall Constructor
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► SetPromotionalSaleListingsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleListingsCall()
Public Sub New
public:
SetPromotionalSaleListingsCall()


SetPromotionalSaleListingsCall Constructor (ApiContext)

SetPromotionalSaleListingsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► SetPromotionalSaleListingsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleListingsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetPromotionalSaleListingsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


Status Property

Status Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► Status
Gets the returned Status of type PromotionalSaleStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeType Status { get; }
Public ReadOnly Property Status As PromotionalSaleStatusCodeType
    Get
public:
property PromotionalSaleStatusCodeType Status {
    PromotionalSaleStatusCodeType get ();
}


StoreCategoryID Property

StoreCategoryID Property
Namespaces ► eBay.Service.Call ► SetPromotionalSaleListingsCall ► StoreCategoryID
Gets or sets the StoreCategoryID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long StoreCategoryID { get; set; }
Public Property StoreCategoryID As Long
    Get
    Set
public:
property long long StoreCategoryID {
    long long get ();
    void set (long long value);
}


SetSellingManagerFeedbackOptionsCall Class

SetSellingManagerFeedbackOptionsCall Class
Namespaces ► eBay.Service.Call ► SetSellingManagerFeedbackOptionsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetSellingManagerFeedbackOptionsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetSellingManagerFeedbackOptionsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetSellingManagerFeedbackOptionsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetSellingManagerFeedbackOptionsCall()()()() |
 | SetSellingManagerFeedbackOptionsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetSellingManagerFeedbackOptionsRequestType for this API call.
 | ApiResponse | Gets the SetSellingManagerFeedbackOptionsResponseType for this API call.
 | AutomatedLeaveFeedbackEvent | Gets or sets the AutomatedLeaveFeedbackEvent of type AutomatedLeaveFeedbackEventCodeType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetSellingManagerFeedbackOptions(AutomatedLeaveFeedbackEventCodeType, StringCollection) | Enables Selling Manager subscribers to store standard feedback comments that can be left for their buyers. Selling Manager Pro subscribers can also specify what events, if any, will trigger an automated feedback to buyers.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StoredCommentList | Gets or sets the StoredComments of type StringCollection.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetSellingManagerFeedbackOptionsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetSellingManagerFeedbackOptionsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetSellingManagerFeedbackOptionsCall ► ApiRequest
Gets or sets the SetSellingManagerFeedbackOptionsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerFeedbackOptionsRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetSellingManagerFeedbackOptionsRequestType
    Get
    Set
public:
property SetSellingManagerFeedbackOptionsRequestType^ ApiRequest {
    SetSellingManagerFeedbackOptionsRequestType^ get ();
    void set (SetSellingManagerFeedbackOptionsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetSellingManagerFeedbackOptionsCall ► ApiResponse
Gets the SetSellingManagerFeedbackOptionsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerFeedbackOptionsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetSellingManagerFeedbackOptionsResponseType
    Get
public:
property SetSellingManagerFeedbackOptionsResponseType^ ApiResponse {
    SetSellingManagerFeedbackOptionsResponseType^ get ();
}


AutomatedLeaveFeedbackEvent Property

AutomatedLeaveFeedbackEvent Property
Namespaces ► eBay.Service.Call ► SetSellingManagerFeedbackOptionsCall ► AutomatedLeaveFeedbackEvent
Gets or sets the AutomatedLeaveFeedbackEvent of type AutomatedLeaveFeedbackEventCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public AutomatedLeaveFeedbackEventCodeType AutomatedLeaveFeedbackEvent { get; set; }
Public Property AutomatedLeaveFeedbackEvent As AutomatedLeaveFeedbackEventCodeType
    Get
    Set
public:
property AutomatedLeaveFeedbackEventCodeType AutomatedLeaveFeedbackEvent {
    AutomatedLeaveFeedbackEventCodeType get ();
    void set (AutomatedLeaveFeedbackEventCodeType value);
}


SetSellingManagerFeedbackOptions Method (AutomatedLeaveFeedbackEvent, StoredCommentList)

SetSellingManagerFeedbackOptions Method (AutomatedLeaveFeedbackEvent, StoredCommentList)
Namespaces ► eBay.Service.Call ► SetSellingManagerFeedbackOptionsCall ► SetSellingManagerFeedbackOptions(AutomatedLeaveFeedbackEventCodeType, StringCollection)
Enables Selling Manager subscribers to store standard feedback comments that can be left for their buyers. Selling Manager Pro subscribers can also specify what events, if any, will trigger an automated feedback to buyers.
Declaration Syntax
C# Visual Basic Visual C++
public void SetSellingManagerFeedbackOptions(
    AutomatedLeaveFeedbackEventCodeType AutomatedLeaveFeedbackEvent,
    StringCollection StoredCommentList
)
Public Sub SetSellingManagerFeedbackOptions ( _
    AutomatedLeaveFeedbackEvent As AutomatedLeaveFeedbackEventCodeType, _
    StoredCommentList As StringCollection _
)
public:
void SetSellingManagerFeedbackOptions(
    AutomatedLeaveFeedbackEventCodeType AutomatedLeaveFeedbackEvent,
    StringCollection^ StoredCommentList
)
Parameters
AutomatedLeaveFeedbackEvent (AutomatedLeaveFeedbackEventCodeType)
Specifies the event that will trigger automated feedback to the buyer. Applies to Selling Manager Pro subscribers only.
StoredCommentList (StringCollection)
Contains a set of comments from which one can be selected to leave feedback for a buyer. If automated feedback is used, a comment is selected from the set randomly. Automated feedback applies to Selling Manager Pro subscribers only. Stored comments cannot be replaced or edited individually. Submitting a stored comments array replaces all existing stored comments.


SetSellingManagerFeedbackOptionsCall Constructor

SetSellingManagerFeedbackOptionsCall Constructor
Namespaces ► eBay.Service.Call ► SetSellingManagerFeedbackOptionsCall ► SetSellingManagerFeedbackOptionsCall()()()()
Members
Icon | Member | Description
 | SetSellingManagerFeedbackOptionsCall()()()() |
 | SetSellingManagerFeedbackOptionsCall(ApiContext) |


SetSellingManagerFeedbackOptionsCall Constructor

SetSellingManagerFeedbackOptionsCall Constructor
Namespaces ► eBay.Service.Call ► SetSellingManagerFeedbackOptionsCall ► SetSellingManagerFeedbackOptionsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerFeedbackOptionsCall()
Public Sub New
public:
SetSellingManagerFeedbackOptionsCall()


SetSellingManagerFeedbackOptionsCall Constructor (ApiContext)

SetSellingManagerFeedbackOptionsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetSellingManagerFeedbackOptionsCall ► SetSellingManagerFeedbackOptionsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerFeedbackOptionsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetSellingManagerFeedbackOptionsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


StoredCommentList Property

StoredCommentList Property
Namespaces ► eBay.Service.Call ► SetSellingManagerFeedbackOptionsCall ► StoredCommentList
Gets or sets the StoredComments of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection StoredCommentList { get; set; }
Public Property StoredCommentList As StringCollection
    Get
    Set
public:
property StringCollection^ StoredCommentList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


SetSellingManagerItemAutomationRuleCall Class

SetSellingManagerItemAutomationRuleCall Class
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetSellingManagerItemAutomationRuleCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetSellingManagerItemAutomationRuleCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetSellingManagerItemAutomationRuleCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetSellingManagerItemAutomationRuleCall()()()() |
 | SetSellingManagerItemAutomationRuleCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetSellingManagerItemAutomationRuleRequestType for this API call.
 | ApiResponse | Gets the SetSellingManagerItemAutomationRuleResponseType for this API call.
 | AutomatedListingRule | Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
 | AutomatedRelistingRule | Gets or sets the AutomatedRelistingRule of type SellingManagerAutoRelistType.
 | AutomatedRelistingRuleReturn | Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
 | AutomatedSecondChanceOfferRule | Gets or sets the AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
 | AutomatedSecondChanceOfferRuleReturn | Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetSellingManagerItemAutomationRule(String, SellingManagerAutoRelistType, SellingManagerAutoSecondChanceOfferType) | Revises, or adds to, the set of Selling Manager automation rules associated with an item. This call is subject to change without notice; the deprecation process is inapplicable to this call. Using this call, you can add an autolist rule. You also can add a second chance offer rule (restricted to auction items and auction templates). Note that autorelist rules can only be set on templates. An autorelist rule for an item is inherited from a template. This call also enables you to specify particular information about automation rules. If a node is not passed in the call, the setting for the corresponding automation rule remains unchanged. Although this call can revise (overwrite) an existing rule, this call cannot delete an automation rule. (Instead, use DeleteSellingManagerItemAutomationRule.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetSellingManagerItemAutomationRuleCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► ApiRequest
Gets or sets the SetSellingManagerItemAutomationRuleRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerItemAutomationRuleRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetSellingManagerItemAutomationRuleRequestType
    Get
    Set
public:
property SetSellingManagerItemAutomationRuleRequestType^ ApiRequest {
    SetSellingManagerItemAutomationRuleRequestType^ get ();
    void set (SetSellingManagerItemAutomationRuleRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► ApiResponse
Gets the SetSellingManagerItemAutomationRuleResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerItemAutomationRuleResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetSellingManagerItemAutomationRuleResponseType
    Get
public:
property SetSellingManagerItemAutomationRuleResponseType^ ApiResponse {
    SetSellingManagerItemAutomationRuleResponseType^ get ();
}


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► AutomatedListingRule
Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; }
Public ReadOnly Property AutomatedListingRule As SellingManagerAutoListType
    Get
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► AutomatedRelistingRule
Gets or sets the AutomatedRelistingRule of type SellingManagerAutoRelistType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; set; }
Public Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
    Set
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
    void set (SellingManagerAutoRelistType^ value);
}


AutomatedRelistingRuleReturn Property

AutomatedRelistingRuleReturn Property
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► AutomatedRelistingRuleReturn
Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRuleReturn { get; }
Public ReadOnly Property AutomatedRelistingRuleReturn As SellingManagerAutoRelistType
    Get
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRuleReturn {
    SellingManagerAutoRelistType^ get ();
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► AutomatedSecondChanceOfferRule
Gets or sets the AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; set; }
Public Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
    Set
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
    void set (SellingManagerAutoSecondChanceOfferType^ value);
}


AutomatedSecondChanceOfferRuleReturn Property

AutomatedSecondChanceOfferRuleReturn Property
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► AutomatedSecondChanceOfferRuleReturn
Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRuleReturn { get; }
Public ReadOnly Property AutomatedSecondChanceOfferRuleReturn As SellingManagerAutoSecondChanceOfferType
    Get
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRuleReturn {
    SellingManagerAutoSecondChanceOfferType^ get ();
}


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


SetSellingManagerItemAutomationRule Method (ItemID, AutomatedRelistingRule, AutomatedSecondChanceOfferRule)

SetSellingManagerItemAutomationRule Method (ItemID, AutomatedRelistingRule, AutomatedSecondChanceOfferRule)
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► SetSellingManagerItemAutomationRule(String, SellingManagerAutoRelistType, SellingManagerAutoSecondChanceOfferType)
Revises, or adds to, the set of Selling Manager automation rules associated with an item. This call is subject to change without notice; the deprecation process is inapplicable to this call. Using this call, you can add an autolist rule. You also can add a second chance offer rule (restricted to auction items and auction templates). Note that autorelist rules can only be set on templates. An autorelist rule for an item is inherited from a template. This call also enables you to specify particular information about automation rules. If a node is not passed in the call, the setting for the corresponding automation rule remains unchanged. Although this call can revise (overwrite) an existing rule, this call cannot delete an automation rule. (Instead, use DeleteSellingManagerItemAutomationRule.)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType SetSellingManagerItemAutomationRule(
    string ItemID,
    SellingManagerAutoRelistType AutomatedRelistingRule,
    SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule
)
Public Function SetSellingManagerItemAutomationRule ( _
    ItemID As String, _
    AutomatedRelistingRule As SellingManagerAutoRelistType, _
    AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType _
) As SellingManagerAutoListType
public:
SellingManagerAutoListType^ SetSellingManagerItemAutomationRule(
    String^ ItemID,
    SellingManagerAutoRelistType^ AutomatedRelistingRule,
    SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule
)
Parameters
ItemID (String)
The item ID whose automation rules you want to change.
AutomatedRelistingRule (SellingManagerAutoRelistType)
The information for the automated relisting rule to be associated with the item.
AutomatedSecondChanceOfferRule (SellingManagerAutoSecondChanceOfferType)
The information for the automated second chance offer rule to be associated with the item.


SetSellingManagerItemAutomationRuleCall Constructor

SetSellingManagerItemAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► SetSellingManagerItemAutomationRuleCall()()()()
Members
Icon | Member | Description
 | SetSellingManagerItemAutomationRuleCall()()()() |
 | SetSellingManagerItemAutomationRuleCall(ApiContext) |


SetSellingManagerItemAutomationRuleCall Constructor

SetSellingManagerItemAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► SetSellingManagerItemAutomationRuleCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerItemAutomationRuleCall()
Public Sub New
public:
SetSellingManagerItemAutomationRuleCall()


SetSellingManagerItemAutomationRuleCall Constructor (ApiContext)

SetSellingManagerItemAutomationRuleCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetSellingManagerItemAutomationRuleCall ► SetSellingManagerItemAutomationRuleCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerItemAutomationRuleCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetSellingManagerItemAutomationRuleCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SetSellingManagerTemplateAutomationRuleCall Class

SetSellingManagerTemplateAutomationRuleCall Class
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetSellingManagerTemplateAutomationRuleCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetSellingManagerTemplateAutomationRuleCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetSellingManagerTemplateAutomationRuleCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetSellingManagerTemplateAutomationRuleCall()()()() |
 | SetSellingManagerTemplateAutomationRuleCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetSellingManagerTemplateAutomationRuleRequestType for this API call.
 | ApiResponse | Gets the SetSellingManagerTemplateAutomationRuleResponseType for this API call.
 | AutomatedListingRule | Gets or sets the AutomatedListingRule of type SellingManagerAutoListType.
 | AutomatedListingRuleReturn | Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
 | AutomatedRelistingRule | Gets or sets the AutomatedRelistingRule of type SellingManagerAutoRelistType.
 | AutomatedRelistingRuleReturn | Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
 | AutomatedSecondChanceOfferRule | Gets or sets the AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
 | AutomatedSecondChanceOfferRuleReturn | Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SaleTemplateID | Gets or sets the SaleTemplateID of type Int64.
 | SetSellingManagerTemplateAutomationRule(Int64, SellingManagerAutoListType, SellingManagerAutoRelistType, SellingManagerAutoSecondChanceOfferType) | Revises, or adds to, the Selling Manager automation rules associated with a template. This call is subject to change without notice; the deprecation process is inapplicable to this call. Using this call, you can add either an autorelist rule or an autolist rule, but not both. You also can add a second chance offer rule (restricted to auction items and auction templates). This call also enables you to specify particular information about automation rules. If a node is not passed in the call, the setting for the corresponding automation rule remains unchanged. Although this call can revise (overwrite) an existing rule, this call cannot delete an automation rule. (Instead, use DeleteSellingManagerTemplateAutomationRule.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetSellingManagerTemplateAutomationRuleCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► ApiRequest
Gets or sets the SetSellingManagerTemplateAutomationRuleRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerTemplateAutomationRuleRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetSellingManagerTemplateAutomationRuleRequestType
    Get
    Set
public:
property SetSellingManagerTemplateAutomationRuleRequestType^ ApiRequest {
    SetSellingManagerTemplateAutomationRuleRequestType^ get ();
    void set (SetSellingManagerTemplateAutomationRuleRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► ApiResponse
Gets the SetSellingManagerTemplateAutomationRuleResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerTemplateAutomationRuleResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetSellingManagerTemplateAutomationRuleResponseType
    Get
public:
property SetSellingManagerTemplateAutomationRuleResponseType^ ApiResponse {
    SetSellingManagerTemplateAutomationRuleResponseType^ get ();
}


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► AutomatedListingRule
Gets or sets the AutomatedListingRule of type SellingManagerAutoListType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; set; }
Public Property AutomatedListingRule As SellingManagerAutoListType
    Get
    Set
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
    void set (SellingManagerAutoListType^ value);
}


AutomatedListingRuleReturn Property

AutomatedListingRuleReturn Property
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► AutomatedListingRuleReturn
Gets the returned AutomatedListingRule of type SellingManagerAutoListType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRuleReturn { get; }
Public ReadOnly Property AutomatedListingRuleReturn As SellingManagerAutoListType
    Get
public:
property SellingManagerAutoListType^ AutomatedListingRuleReturn {
    SellingManagerAutoListType^ get ();
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► AutomatedRelistingRule
Gets or sets the AutomatedRelistingRule of type SellingManagerAutoRelistType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; set; }
Public Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
    Set
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
    void set (SellingManagerAutoRelistType^ value);
}


AutomatedRelistingRuleReturn Property

AutomatedRelistingRuleReturn Property
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► AutomatedRelistingRuleReturn
Gets the returned AutomatedRelistingRule of type SellingManagerAutoRelistType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRuleReturn { get; }
Public ReadOnly Property AutomatedRelistingRuleReturn As SellingManagerAutoRelistType
    Get
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRuleReturn {
    SellingManagerAutoRelistType^ get ();
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► AutomatedSecondChanceOfferRule
Gets or sets the AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; set; }
Public Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
    Set
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
    void set (SellingManagerAutoSecondChanceOfferType^ value);
}


AutomatedSecondChanceOfferRuleReturn Property

AutomatedSecondChanceOfferRuleReturn Property
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► AutomatedSecondChanceOfferRuleReturn
Gets the returned AutomatedSecondChanceOfferRule of type SellingManagerAutoSecondChanceOfferType.
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRuleReturn { get; }
Public ReadOnly Property AutomatedSecondChanceOfferRuleReturn As SellingManagerAutoSecondChanceOfferType
    Get
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRuleReturn {
    SellingManagerAutoSecondChanceOfferType^ get ();
}


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► SaleTemplateID
Gets or sets the SaleTemplateID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


SetSellingManagerTemplateAutomationRule Method (SaleTemplateID, AutomatedListingRule, AutomatedRelistingRule, AutomatedSecondChanceOfferRule)

SetSellingManagerTemplateAutomationRule Method (SaleTemplateID, AutomatedListingRule, AutomatedRelistingRule, AutomatedSecondChanceOfferRule)
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► SetSellingManagerTemplateAutomationRule(Int64, SellingManagerAutoListType, SellingManagerAutoRelistType, SellingManagerAutoSecondChanceOfferType)
Revises, or adds to, the Selling Manager automation rules associated with a template. This call is subject to change without notice; the deprecation process is inapplicable to this call. Using this call, you can add either an autorelist rule or an autolist rule, but not both. You also can add a second chance offer rule (restricted to auction items and auction templates). This call also enables you to specify particular information about automation rules. If a node is not passed in the call, the setting for the corresponding automation rule remains unchanged. Although this call can revise (overwrite) an existing rule, this call cannot delete an automation rule. (Instead, use DeleteSellingManagerTemplateAutomationRule.)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType SetSellingManagerTemplateAutomationRule(
    long SaleTemplateID,
    SellingManagerAutoListType AutomatedListingRule,
    SellingManagerAutoRelistType AutomatedRelistingRule,
    SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule
)
Public Function SetSellingManagerTemplateAutomationRule ( _
    SaleTemplateID As Long, _
    AutomatedListingRule As SellingManagerAutoListType, _
    AutomatedRelistingRule As SellingManagerAutoRelistType, _
    AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType _
) As SellingManagerAutoListType
public:
SellingManagerAutoListType^ SetSellingManagerTemplateAutomationRule(
    long long SaleTemplateID,
    SellingManagerAutoListType^ AutomatedListingRule,
    SellingManagerAutoRelistType^ AutomatedRelistingRule,
    SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule
)
Parameters
SaleTemplateID (Int64)
The ID of the Selling Manager template whose automation rules you want to change. You can obtain a SaleTemplateID by calling GetSellingManagerInventory.
AutomatedListingRule (SellingManagerAutoListType)
The information for the automated listing rule to be associated with the template.
AutomatedRelistingRule (SellingManagerAutoRelistType)
The information for the automated relisting rule to be associated with the template.
AutomatedSecondChanceOfferRule (SellingManagerAutoSecondChanceOfferType)
The information for the automated second chance offer rule to be associated with the template.


SetSellingManagerTemplateAutomationRuleCall Constructor

SetSellingManagerTemplateAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► SetSellingManagerTemplateAutomationRuleCall()()()()
Members
Icon | Member | Description
 | SetSellingManagerTemplateAutomationRuleCall()()()() |
 | SetSellingManagerTemplateAutomationRuleCall(ApiContext) |


SetSellingManagerTemplateAutomationRuleCall Constructor

SetSellingManagerTemplateAutomationRuleCall Constructor
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► SetSellingManagerTemplateAutomationRuleCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerTemplateAutomationRuleCall()
Public Sub New
public:
SetSellingManagerTemplateAutomationRuleCall()


SetSellingManagerTemplateAutomationRuleCall Constructor (ApiContext)

SetSellingManagerTemplateAutomationRuleCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetSellingManagerTemplateAutomationRuleCall ► SetSellingManagerTemplateAutomationRuleCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerTemplateAutomationRuleCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetSellingManagerTemplateAutomationRuleCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SetShippingDiscountProfilesCall Class

SetShippingDiscountProfilesCall Class
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetShippingDiscountProfilesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetShippingDiscountProfilesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetShippingDiscountProfilesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetShippingDiscountProfilesCall()()()() |
 | SetShippingDiscountProfilesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetShippingDiscountProfilesRequestType for this API call.
 | ApiResponse | Gets the SetShippingDiscountProfilesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CalculatedHandlingDiscount | Gets or sets the CalculatedHandlingDiscount of type CalculatedHandlingDiscountType.
 | CalculatedShippingDiscount | Gets or sets the CalculatedShippingDiscount of type CalculatedShippingDiscountType.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CombinedDuration | Gets or sets the CombinedDuration of type CombinedPaymentPeriodCodeType.
 | CurrencyID | Gets or sets the CurrencyID of type CurrencyCodeType.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | FlatShippingDiscount | Gets or sets the FlatShippingDiscount of type FlatShippingDiscountType.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | InternationalShippingInsurance | Gets or sets the InternationalShippingInsurance of type ShippingInsuranceType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModifyActionCode | Gets or sets the ModifyActionCode of type ModifyActionCodeType.
 | OutputSelector | (Inherited from ApiCall.)
 | PromotionalShippingDiscountDetails | Gets or sets the PromotionalShippingDiscountDetails of type PromotionalShippingDiscountDetailsType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetShippingDiscountProfiles(CurrencyCodeType, CombinedPaymentPeriodCodeType, ModifyActionCodeType, FlatShippingDiscountType, CalculatedShippingDiscountType, CalculatedHandlingDiscountType, PromotionalShippingDiscountDetailsType, ShippingInsuranceType, ShippingInsuranceType) | Enables a seller to define shipping cost discount profiles for things such as combined payments for shipping and handling costs.
 | ShippingInsurance | Gets or sets the ShippingInsurance of type ShippingInsuranceType.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetShippingDiscountProfilesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► ApiRequest
Gets or sets the SetShippingDiscountProfilesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetShippingDiscountProfilesRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetShippingDiscountProfilesRequestType
    Get
    Set
public:
property SetShippingDiscountProfilesRequestType^ ApiRequest {
    SetShippingDiscountProfilesRequestType^ get ();
    void set (SetShippingDiscountProfilesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► ApiResponse
Gets the SetShippingDiscountProfilesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetShippingDiscountProfilesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetShippingDiscountProfilesResponseType
    Get
public:
property SetShippingDiscountProfilesResponseType^ ApiResponse {
    SetShippingDiscountProfilesResponseType^ get ();
}


CalculatedHandlingDiscount Property

CalculatedHandlingDiscount Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► CalculatedHandlingDiscount
Gets or sets the CalculatedHandlingDiscount of type CalculatedHandlingDiscountType.
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedHandlingDiscountType CalculatedHandlingDiscount { get; set; }
Public Property CalculatedHandlingDiscount As CalculatedHandlingDiscountType
    Get
    Set
public:
property CalculatedHandlingDiscountType^ CalculatedHandlingDiscount {
    CalculatedHandlingDiscountType^ get ();
    void set (CalculatedHandlingDiscountType^ value);
}


CalculatedShippingDiscount Property

CalculatedShippingDiscount Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► CalculatedShippingDiscount
Gets or sets the CalculatedShippingDiscount of type CalculatedShippingDiscountType.
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingDiscountType CalculatedShippingDiscount { get; set; }
Public Property CalculatedShippingDiscount As CalculatedShippingDiscountType
    Get
    Set
public:
property CalculatedShippingDiscountType^ CalculatedShippingDiscount {
    CalculatedShippingDiscountType^ get ();
    void set (CalculatedShippingDiscountType^ value);
}


CombinedDuration Property

CombinedDuration Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► CombinedDuration
Gets or sets the CombinedDuration of type CombinedPaymentPeriodCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public CombinedPaymentPeriodCodeType CombinedDuration { get; set; }
Public Property CombinedDuration As CombinedPaymentPeriodCodeType
    Get
    Set
public:
property CombinedPaymentPeriodCodeType CombinedDuration {
    CombinedPaymentPeriodCodeType get ();
    void set (CombinedPaymentPeriodCodeType value);
}


CurrencyID Property

CurrencyID Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► CurrencyID
Gets or sets the CurrencyID of type CurrencyCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType CurrencyID { get; set; }
Public Property CurrencyID As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType CurrencyID {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


FlatShippingDiscount Property

FlatShippingDiscount Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► FlatShippingDiscount
Gets or sets the FlatShippingDiscount of type FlatShippingDiscountType.
Declaration Syntax
C# Visual Basic Visual C++
public FlatShippingDiscountType FlatShippingDiscount { get; set; }
Public Property FlatShippingDiscount As FlatShippingDiscountType
    Get
    Set
public:
property FlatShippingDiscountType^ FlatShippingDiscount {
    FlatShippingDiscountType^ get ();
    void set (FlatShippingDiscountType^ value);
}


InternationalShippingInsurance Property

InternationalShippingInsurance Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► InternationalShippingInsurance
Gets or sets the InternationalShippingInsurance of type ShippingInsuranceType.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingInsuranceType InternationalShippingInsurance { get; set; }
Public Property InternationalShippingInsurance As ShippingInsuranceType
    Get
    Set
public:
property ShippingInsuranceType^ InternationalShippingInsurance {
    ShippingInsuranceType^ get ();
    void set (ShippingInsuranceType^ value);
}


ModifyActionCode Property

ModifyActionCode Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► ModifyActionCode
Gets or sets the ModifyActionCode of type ModifyActionCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public ModifyActionCodeType ModifyActionCode { get; set; }
Public Property ModifyActionCode As ModifyActionCodeType
    Get
    Set
public:
property ModifyActionCodeType ModifyActionCode {
    ModifyActionCodeType get ();
    void set (ModifyActionCodeType value);
}


PromotionalShippingDiscountDetails Property

PromotionalShippingDiscountDetails Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► PromotionalShippingDiscountDetails
Gets or sets the PromotionalShippingDiscountDetails of type PromotionalShippingDiscountDetailsType.
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalShippingDiscountDetailsType PromotionalShippingDiscountDetails { get; set; }
Public Property PromotionalShippingDiscountDetails As PromotionalShippingDiscountDetailsType
    Get
    Set
public:
property PromotionalShippingDiscountDetailsType^ PromotionalShippingDiscountDetails {
    PromotionalShippingDiscountDetailsType^ get ();
    void set (PromotionalShippingDiscountDetailsType^ value);
}


SetShippingDiscountProfiles Method (CurrencyID, CombinedDuration, ModifyActionCode, FlatShippingDiscount, CalculatedShippingDiscount, CalculatedHandlingDiscount, PromotionalShippingDiscountDetails, ShippingInsurance, InternationalShippingInsurance)

SetShippingDiscountProfiles Method (CurrencyID, CombinedDuration, ModifyActionCode, FlatShippingDiscount, CalculatedShippingDiscount, CalculatedHandlingDiscount, PromotionalShippingDiscountDetails, ShippingInsurance, InternationalShippingInsurance)
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► SetShippingDiscountProfiles(CurrencyCodeType, CombinedPaymentPeriodCodeType, ModifyActionCodeType, FlatShippingDiscountType, CalculatedShippingDiscountType, CalculatedHandlingDiscountType, PromotionalShippingDiscountDetailsType, ShippingInsuranceType, ShippingInsuranceType)
Enables a seller to define shipping cost discount profiles for things such as combined payments for shipping and handling costs.
Declaration Syntax
C# Visual Basic Visual C++
public void SetShippingDiscountProfiles(
    CurrencyCodeType CurrencyID,
    CombinedPaymentPeriodCodeType CombinedDuration,
    ModifyActionCodeType ModifyActionCode,
    FlatShippingDiscountType FlatShippingDiscount,
    CalculatedShippingDiscountType CalculatedShippingDiscount,
    CalculatedHandlingDiscountType CalculatedHandlingDiscount,
    PromotionalShippingDiscountDetailsType PromotionalShippingDiscountDetails,
    ShippingInsuranceType ShippingInsurance,
    ShippingInsuranceType InternationalShippingInsurance
)
Public Sub SetShippingDiscountProfiles ( _
    CurrencyID As CurrencyCodeType, _
    CombinedDuration As CombinedPaymentPeriodCodeType, _
    ModifyActionCode As ModifyActionCodeType, _
    FlatShippingDiscount As FlatShippingDiscountType, _
    CalculatedShippingDiscount As CalculatedShippingDiscountType, _
    CalculatedHandlingDiscount As CalculatedHandlingDiscountType, _
    PromotionalShippingDiscountDetails As PromotionalShippingDiscountDetailsType, _
    ShippingInsurance As ShippingInsuranceType, _
    InternationalShippingInsurance As ShippingInsuranceType _
)
public:
void SetShippingDiscountProfiles(
    CurrencyCodeType CurrencyID,
    CombinedPaymentPeriodCodeType CombinedDuration,
    ModifyActionCodeType ModifyActionCode,
    FlatShippingDiscountType^ FlatShippingDiscount,
    CalculatedShippingDiscountType^ CalculatedShippingDiscount,
    CalculatedHandlingDiscountType^ CalculatedHandlingDiscount,
    PromotionalShippingDiscountDetailsType^ PromotionalShippingDiscountDetails,
    ShippingInsuranceType^ ShippingInsurance,
    ShippingInsuranceType^ InternationalShippingInsurance
)
Parameters
CurrencyID (CurrencyCodeType)
The three-digit code of the currency to be used for shipping cost discounts and insurance for Combined Invoice orders. A discount profile can only be associated with a listing if the CurrencyID value of the profile matches the Item.Currency value specified in a listing. Required if the user creates flat rate shipping discount profiles, a promotional discount, a packaging/handling cost profile based on a variable discount rule, or if the user defines shipping insurance range/fee pairs. Note: There is a currencyID attribute on many elements of SetShippingDiscountProfiles. To avoid an error, be sure to use the same CurrencyID value in each occurrence within the same request.
CombinedDuration (CombinedPaymentPeriodCodeType)
This field is used to specify the number of days after the sale of an item in which the buyer or seller can combine multiple and mutual order line items into one Combined Invoice order. In a Combined Invoice order, the buyer makes one payment for all order line items, hence only unpaid order line items can be combined into a Combined Invoice order.
ModifyActionCode (ModifyActionCodeType)
Indicates what action to take on the specified flat shipping discount, calculated shipping discount or promotional discount. If the action is Delete and if a flat rate or calculated shipping discount profile is specified, the discount profile identified by DiscountProfile.DiscountProfileID is deleted (see DiscountProfile.MappedDiscountProfileID for related details).
FlatShippingDiscount (FlatShippingDiscountType)
Details of a shipping cost discount profile for flat rate shipping. If this is provided, CalculatedShippingDiscount and PromotionalShippingDiscountDetails should be omitted.
CalculatedShippingDiscount (CalculatedShippingDiscountType)
Details of a shipping cost discount profile for calculated shipping. If this is provided, FlatShippingDiscount and PromotionalShippingDiscountDetails should be omitted.
CalculatedHandlingDiscount (CalculatedHandlingDiscountType)
This container is used by the seller to specify/modify packaging and handling discounts that are applied for Combined Invoice orders.
PromotionalShippingDiscountDetails (PromotionalShippingDiscountDetailsType)
The data for the promotional shipping discount. If this is provided, FlatShippingDiscount and CalculatedShippingDiscount should be omitted.
ShippingInsurance (ShippingInsuranceType)
Information establishing what fee to apply for domestic shipping insurance for Combined Invoice depending on which range the order item-total price falls into.
InternationalShippingInsurance (ShippingInsuranceType)
Information establishing what fee to apply for international shipping insurance for Combined Invoice depending on which range the order item-total price falls into.


SetShippingDiscountProfilesCall Constructor

SetShippingDiscountProfilesCall Constructor
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► SetShippingDiscountProfilesCall()()()()
Members
Icon | Member | Description
 | SetShippingDiscountProfilesCall()()()() |
 | SetShippingDiscountProfilesCall(ApiContext) |


SetShippingDiscountProfilesCall Constructor

SetShippingDiscountProfilesCall Constructor
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► SetShippingDiscountProfilesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetShippingDiscountProfilesCall()
Public Sub New
public:
SetShippingDiscountProfilesCall()


SetShippingDiscountProfilesCall Constructor (ApiContext)

SetShippingDiscountProfilesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► SetShippingDiscountProfilesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetShippingDiscountProfilesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetShippingDiscountProfilesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ShippingInsurance Property

ShippingInsurance Property
Namespaces ► eBay.Service.Call ► SetShippingDiscountProfilesCall ► ShippingInsurance
Gets or sets the ShippingInsurance of type ShippingInsuranceType.
Declaration Syntax
C# Visual Basic Visual C++
public ShippingInsuranceType ShippingInsurance { get; set; }
Public Property ShippingInsurance As ShippingInsuranceType
    Get
    Set
public:
property ShippingInsuranceType^ ShippingInsurance {
    ShippingInsuranceType^ get ();
    void set (ShippingInsuranceType^ value);
}


SetStoreCall Class

SetStoreCall Class
Namespaces ► eBay.Service.Call ► SetStoreCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetStoreCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetStoreCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetStoreCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStoreCall()()()() |
 | SetStoreCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetStoreRequestType for this API call.
 | ApiResponse | Gets the SetStoreResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetStore(StoreType) | Sets the configuration of the eBay store owned by the caller.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Store | Gets or sets the Store of type StoreType.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetStoreCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetStoreCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetStoreCall ► ApiRequest
Gets or sets the SetStoreRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetStoreRequestType
    Get
    Set
public:
property SetStoreRequestType^ ApiRequest {
    SetStoreRequestType^ get ();
    void set (SetStoreRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetStoreCall ► ApiResponse
Gets the SetStoreResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetStoreResponseType
    Get
public:
property SetStoreResponseType^ ApiResponse {
    SetStoreResponseType^ get ();
}


SetStore Method (Store)

SetStore Method (Store)
Namespaces ► eBay.Service.Call ► SetStoreCall ► SetStore(StoreType)
Sets the configuration of the eBay store owned by the caller.
Declaration Syntax
C# Visual Basic Visual C++
public void SetStore(
    StoreType Store
)
Public Sub SetStore ( _
    Store As StoreType _
)
public:
void SetStore(
    StoreType^ Store
)
Parameters
Store (StoreType)
Specifies the Store configuration that is being set for the user.


SetStoreCall Constructor

SetStoreCall Constructor
Namespaces ► eBay.Service.Call ► SetStoreCall ► SetStoreCall()()()()
Members
Icon | Member | Description
 | SetStoreCall()()()() |
 | SetStoreCall(ApiContext) |


SetStoreCall Constructor

SetStoreCall Constructor
Namespaces ► eBay.Service.Call ► SetStoreCall ► SetStoreCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCall()
Public Sub New
public:
SetStoreCall()


SetStoreCall Constructor (ApiContext)

SetStoreCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetStoreCall ► SetStoreCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetStoreCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


Store Property

Store Property
Namespaces ► eBay.Service.Call ► SetStoreCall ► Store
Gets or sets the Store of type StoreType.
Declaration Syntax
C# Visual Basic Visual C++
public StoreType Store { get; set; }
Public Property Store As StoreType
    Get
    Set
public:
property StoreType^ Store {
    StoreType^ get ();
    void set (StoreType^ value);
}


SetStoreCategoriesCall Class

SetStoreCategoriesCall Class
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetStoreCategoriesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetStoreCategoriesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetStoreCategoriesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStoreCategoriesCall()()()() |
 | SetStoreCategoriesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | Action | Gets or sets the Action of type StoreCategoryUpdateActionCodeType.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetStoreCategoriesRequestType for this API call.
 | ApiResponse | Gets the SetStoreCategoriesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CustomCategoryList | Gets the returned CustomCategory of type StoreCustomCategoryTypeCollection.
 | DestinationParentCategoryID | Gets or sets the DestinationParentCategoryID of type Int64.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemDestinationCategoryID | Gets or sets the ItemDestinationCategoryID of type Int64.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetStoreCategories(StoreCategoryUpdateActionCodeType, Int64, Int64, StoreCustomCategoryTypeCollection) | Changes the category structure of an eBay store.
 | SetStoreCategories(StoreCategoryUpdateActionCodeType, StoreCustomCategoryTypeCollection) |
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Status | Gets the returned Status of type TaskStatusCodeType.
 | StoreCategoryList | Gets or sets the StoreCategories of type StoreCustomCategoryTypeCollection.
 | TaskID | Gets the returned TaskID of type Int64.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetStoreCategoriesCall


Action Property

Action Property
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► Action
Gets or sets the Action of type StoreCategoryUpdateActionCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public StoreCategoryUpdateActionCodeType Action { get; set; }
Public Property Action As StoreCategoryUpdateActionCodeType
    Get
    Set
public:
property StoreCategoryUpdateActionCodeType Action {
    StoreCategoryUpdateActionCodeType get ();
    void set (StoreCategoryUpdateActionCodeType value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► ApiRequest
Gets or sets the SetStoreCategoriesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCategoriesRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetStoreCategoriesRequestType
    Get
    Set
public:
property SetStoreCategoriesRequestType^ ApiRequest {
    SetStoreCategoriesRequestType^ get ();
    void set (SetStoreCategoriesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► ApiResponse
Gets the SetStoreCategoriesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCategoriesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetStoreCategoriesResponseType
    Get
public:
property SetStoreCategoriesResponseType^ ApiResponse {
    SetStoreCategoriesResponseType^ get ();
}


CustomCategoryList Property

CustomCategoryList Property
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► CustomCategoryList
Gets the returned CustomCategory of type StoreCustomCategoryTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryTypeCollection CustomCategoryList { get; }
Public ReadOnly Property CustomCategoryList As StoreCustomCategoryTypeCollection
    Get
public:
property StoreCustomCategoryTypeCollection^ CustomCategoryList {
    StoreCustomCategoryTypeCollection^ get ();
}


DestinationParentCategoryID Property

DestinationParentCategoryID Property
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► DestinationParentCategoryID
Gets or sets the DestinationParentCategoryID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long DestinationParentCategoryID { get; set; }
Public Property DestinationParentCategoryID As Long
    Get
    Set
public:
property long long DestinationParentCategoryID {
    long long get ();
    void set (long long value);
}


ItemDestinationCategoryID Property

ItemDestinationCategoryID Property
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► ItemDestinationCategoryID
Gets or sets the ItemDestinationCategoryID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long ItemDestinationCategoryID { get; set; }
Public Property ItemDestinationCategoryID As Long
    Get
    Set
public:
property long long ItemDestinationCategoryID {
    long long get ();
    void set (long long value);
}


SetStoreCategories Method

SetStoreCategories Method
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► SetStoreCategories()()()()
Members
Icon | Member | Description
 | SetStoreCategories(StoreCategoryUpdateActionCodeType, Int64, Int64, StoreCustomCategoryTypeCollection) | Changes the category structure of an eBay store.
 | SetStoreCategories(StoreCategoryUpdateActionCodeType, StoreCustomCategoryTypeCollection) |


SetStoreCategories Method (Action, ItemDestinationCategoryID, DestinationParentCategoryID, StoreCategoryList)

SetStoreCategories Method (Action, ItemDestinationCategoryID, DestinationParentCategoryID, StoreCategoryList)
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► SetStoreCategories(StoreCategoryUpdateActionCodeType, Int64, Int64, StoreCustomCategoryTypeCollection)
Changes the category structure of an eBay store.
Declaration Syntax
C# Visual Basic Visual C++
public long SetStoreCategories(
    StoreCategoryUpdateActionCodeType Action,
    long ItemDestinationCategoryID,
    long DestinationParentCategoryID,
    StoreCustomCategoryTypeCollection StoreCategoryList
)
Public Function SetStoreCategories ( _
    Action As StoreCategoryUpdateActionCodeType, _
    ItemDestinationCategoryID As Long, _
    DestinationParentCategoryID As Long, _
    StoreCategoryList As StoreCustomCategoryTypeCollection _
) As Long
public:
long long SetStoreCategories(
    StoreCategoryUpdateActionCodeType Action,
    long long ItemDestinationCategoryID,
    long long DestinationParentCategoryID,
    StoreCustomCategoryTypeCollection^ StoreCategoryList
)
Parameters
Action (StoreCategoryUpdateActionCodeType)
Specifies the type of action (Add, Move, Delete, or Rename) to carry out for the specified categories.
ItemDestinationCategoryID (Int64)
Items can only be contained within child categories. A parent category cannot contain items. If adding, moving, or deleting categories displaces items, you must specify a destination child category under which the displaced items will be moved. The destination category must have no child categories.
DestinationParentCategoryID (Int64)
When adding or moving store categories, specifies the category under which the listed categories will be located. To add or move categories to the top level, set the value to -999.
StoreCategoryList (StoreCustomCategoryTypeCollection)
Specifies the store categories on which to act.


SetStoreCategories Method (Action, StoreCategoryList)

SetStoreCategories Method (Action, StoreCategoryList)
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► SetStoreCategories(StoreCategoryUpdateActionCodeType, StoreCustomCategoryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public long SetStoreCategories(
    StoreCategoryUpdateActionCodeType Action,
    StoreCustomCategoryTypeCollection StoreCategoryList
)
Public Function SetStoreCategories ( _
    Action As StoreCategoryUpdateActionCodeType, _
    StoreCategoryList As StoreCustomCategoryTypeCollection _
) As Long
public:
long long SetStoreCategories(
    StoreCategoryUpdateActionCodeType Action,
    StoreCustomCategoryTypeCollection^ StoreCategoryList
)
Parameters
Action (StoreCategoryUpdateActionCodeType)
StoreCategoryList (StoreCustomCategoryTypeCollection)


SetStoreCategoriesCall Constructor

SetStoreCategoriesCall Constructor
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► SetStoreCategoriesCall()()()()
Members
Icon | Member | Description
 | SetStoreCategoriesCall()()()() |
 | SetStoreCategoriesCall(ApiContext) |


SetStoreCategoriesCall Constructor

SetStoreCategoriesCall Constructor
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► SetStoreCategoriesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCategoriesCall()
Public Sub New
public:
SetStoreCategoriesCall()


SetStoreCategoriesCall Constructor (ApiContext)

SetStoreCategoriesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► SetStoreCategoriesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCategoriesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetStoreCategoriesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


Status Property

Status Property
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► Status
Gets the returned Status of type TaskStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public TaskStatusCodeType Status { get; }
Public ReadOnly Property Status As TaskStatusCodeType
    Get
public:
property TaskStatusCodeType Status {
    TaskStatusCodeType get ();
}


StoreCategoryList Property

StoreCategoryList Property
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► StoreCategoryList
Gets or sets the StoreCategories of type StoreCustomCategoryTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryTypeCollection StoreCategoryList { get; set; }
Public Property StoreCategoryList As StoreCustomCategoryTypeCollection
    Get
    Set
public:
property StoreCustomCategoryTypeCollection^ StoreCategoryList {
    StoreCustomCategoryTypeCollection^ get ();
    void set (StoreCustomCategoryTypeCollection^ value);
}


TaskID Property

TaskID Property
Namespaces ► eBay.Service.Call ► SetStoreCategoriesCall ► TaskID
Gets the returned TaskID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long TaskID { get; }
Public ReadOnly Property TaskID As Long
    Get
public:
property long long TaskID {
    long long get ();
}


SetStoreCustomPageCall Class

SetStoreCustomPageCall Class
Namespaces ► eBay.Service.Call ► SetStoreCustomPageCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetStoreCustomPageCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetStoreCustomPageCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetStoreCustomPageCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStoreCustomPageCall()()()() |
 | SetStoreCustomPageCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetStoreCustomPageRequestType for this API call.
 | ApiResponse | Gets the SetStoreCustomPageResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CustomPage | Gets or sets the CustomPage of type StoreCustomPageType.
 | CustomPageResult |
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetStoreCustomPage(StoreCustomPageType) | Creates or updates a custom page on a user's eBay Store.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetStoreCustomPageCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetStoreCustomPageCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetStoreCustomPageCall ► ApiRequest
Gets or sets the SetStoreCustomPageRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCustomPageRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetStoreCustomPageRequestType
    Get
    Set
public:
property SetStoreCustomPageRequestType^ ApiRequest {
    SetStoreCustomPageRequestType^ get ();
    void set (SetStoreCustomPageRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetStoreCustomPageCall ► ApiResponse
Gets the SetStoreCustomPageResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCustomPageResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetStoreCustomPageResponseType
    Get
public:
property SetStoreCustomPageResponseType^ ApiResponse {
    SetStoreCustomPageResponseType^ get ();
}


CustomPage Property

CustomPage Property
Namespaces ► eBay.Service.Call ► SetStoreCustomPageCall ► CustomPage
Gets or sets the CustomPage of type StoreCustomPageType.
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageType CustomPage { get; set; }
Public Property CustomPage As StoreCustomPageType
    Get
    Set
public:
property StoreCustomPageType^ CustomPage {
    StoreCustomPageType^ get ();
    void set (StoreCustomPageType^ value);
}


CustomPageResult Property

CustomPageResult Property
Namespaces ► eBay.Service.Call ► SetStoreCustomPageCall ► CustomPageResult
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageType CustomPageResult { get; }
Public ReadOnly Property CustomPageResult As StoreCustomPageType
    Get
public:
property StoreCustomPageType^ CustomPageResult {
    StoreCustomPageType^ get ();
}


SetStoreCustomPage Method (CustomPage)

SetStoreCustomPage Method (CustomPage)
Namespaces ► eBay.Service.Call ► SetStoreCustomPageCall ► SetStoreCustomPage(StoreCustomPageType)
Creates or updates a custom page on a user's eBay Store.
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageType SetStoreCustomPage(
    StoreCustomPageType CustomPage
)
Public Function SetStoreCustomPage ( _
    CustomPage As StoreCustomPageType _
) As StoreCustomPageType
public:
StoreCustomPageType^ SetStoreCustomPage(
    StoreCustomPageType^ CustomPage
)
Parameters
CustomPage (StoreCustomPageType)
The custom page being submitted.


SetStoreCustomPageCall Constructor

SetStoreCustomPageCall Constructor
Namespaces ► eBay.Service.Call ► SetStoreCustomPageCall ► SetStoreCustomPageCall()()()()
Members
Icon | Member | Description
 | SetStoreCustomPageCall()()()() |
 | SetStoreCustomPageCall(ApiContext) |


SetStoreCustomPageCall Constructor

SetStoreCustomPageCall Constructor
Namespaces ► eBay.Service.Call ► SetStoreCustomPageCall ► SetStoreCustomPageCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCustomPageCall()
Public Sub New
public:
SetStoreCustomPageCall()


SetStoreCustomPageCall Constructor (ApiContext)

SetStoreCustomPageCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetStoreCustomPageCall ► SetStoreCustomPageCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCustomPageCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetStoreCustomPageCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SetStorePreferencesCall Class

SetStorePreferencesCall Class
Namespaces ► eBay.Service.Call ► SetStorePreferencesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetStorePreferencesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetStorePreferencesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetStorePreferencesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStorePreferencesCall()()()() |
 | SetStorePreferencesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetStorePreferencesRequestType for this API call.
 | ApiResponse | Gets the SetStorePreferencesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetStorePreferences(StorePreferencesType) | Sets the preferences for a user's eBay Store.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StorePreferences | Gets or sets the StorePreferences of type StorePreferencesType.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetStorePreferencesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetStorePreferencesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetStorePreferencesCall ► ApiRequest
Gets or sets the SetStorePreferencesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetStorePreferencesRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetStorePreferencesRequestType
    Get
    Set
public:
property SetStorePreferencesRequestType^ ApiRequest {
    SetStorePreferencesRequestType^ get ();
    void set (SetStorePreferencesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetStorePreferencesCall ► ApiResponse
Gets the SetStorePreferencesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetStorePreferencesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetStorePreferencesResponseType
    Get
public:
property SetStorePreferencesResponseType^ ApiResponse {
    SetStorePreferencesResponseType^ get ();
}


SetStorePreferences Method (StorePreferences)

SetStorePreferences Method (StorePreferences)
Namespaces ► eBay.Service.Call ► SetStorePreferencesCall ► SetStorePreferences(StorePreferencesType)
Sets the preferences for a user's eBay Store.
Declaration Syntax
C# Visual Basic Visual C++
public void SetStorePreferences(
    StorePreferencesType StorePreferences
)
Public Sub SetStorePreferences ( _
    StorePreferences As StorePreferencesType _
)
public:
void SetStorePreferences(
    StorePreferencesType^ StorePreferences
)
Parameters
StorePreferences (StorePreferencesType)
Specifies the store preferences.


SetStorePreferencesCall Constructor

SetStorePreferencesCall Constructor
Namespaces ► eBay.Service.Call ► SetStorePreferencesCall ► SetStorePreferencesCall()()()()
Members
Icon | Member | Description
 | SetStorePreferencesCall()()()() |
 | SetStorePreferencesCall(ApiContext) |


SetStorePreferencesCall Constructor

SetStorePreferencesCall Constructor
Namespaces ► eBay.Service.Call ► SetStorePreferencesCall ► SetStorePreferencesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStorePreferencesCall()
Public Sub New
public:
SetStorePreferencesCall()


SetStorePreferencesCall Constructor (ApiContext)

SetStorePreferencesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetStorePreferencesCall ► SetStorePreferencesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetStorePreferencesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetStorePreferencesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


StorePreferences Property

StorePreferences Property
Namespaces ► eBay.Service.Call ► SetStorePreferencesCall ► StorePreferences
Gets or sets the StorePreferences of type StorePreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public StorePreferencesType StorePreferences { get; set; }
Public Property StorePreferences As StorePreferencesType
    Get
    Set
public:
property StorePreferencesType^ StorePreferences {
    StorePreferencesType^ get ();
    void set (StorePreferencesType^ value);
}


SetTaxTableCall Class

SetTaxTableCall Class
Namespaces ► eBay.Service.Call ► SetTaxTableCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetTaxTableCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetTaxTableCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetTaxTableCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetTaxTableCall()()()() |
 | SetTaxTableCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetTaxTableRequestType for this API call.
 | ApiResponse | Gets the SetTaxTableResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetTaxTable(TaxJurisdictionTypeCollection) | Sets the tax table for a seller on a given site.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | TaxTableList | Gets or sets the TaxTable of type TaxJurisdictionTypeCollection.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetTaxTableCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetTaxTableCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetTaxTableCall ► ApiRequest
Gets or sets the SetTaxTableRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetTaxTableRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetTaxTableRequestType
    Get
    Set
public:
property SetTaxTableRequestType^ ApiRequest {
    SetTaxTableRequestType^ get ();
    void set (SetTaxTableRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetTaxTableCall ► ApiResponse
Gets the SetTaxTableResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetTaxTableResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetTaxTableResponseType
    Get
public:
property SetTaxTableResponseType^ ApiResponse {
    SetTaxTableResponseType^ get ();
}


SetTaxTable Method (TaxTableList)

SetTaxTable Method (TaxTableList)
Namespaces ► eBay.Service.Call ► SetTaxTableCall ► SetTaxTable(TaxJurisdictionTypeCollection)
Sets the tax table for a seller on a given site.
Declaration Syntax
C# Visual Basic Visual C++
public void SetTaxTable(
    TaxJurisdictionTypeCollection TaxTableList
)
Public Sub SetTaxTable ( _
    TaxTableList As TaxJurisdictionTypeCollection _
)
public:
void SetTaxTable(
    TaxJurisdictionTypeCollection^ TaxTableList
)
Parameters
TaxTableList (TaxJurisdictionTypeCollection)
A container of tax jurisdiction information unique to a user/site combination.


SetTaxTableCall Constructor

SetTaxTableCall Constructor
Namespaces ► eBay.Service.Call ► SetTaxTableCall ► SetTaxTableCall()()()()
Members
Icon | Member | Description
 | SetTaxTableCall()()()() |
 | SetTaxTableCall(ApiContext) |


SetTaxTableCall Constructor

SetTaxTableCall Constructor
Namespaces ► eBay.Service.Call ► SetTaxTableCall ► SetTaxTableCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetTaxTableCall()
Public Sub New
public:
SetTaxTableCall()


SetTaxTableCall Constructor (ApiContext)

SetTaxTableCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetTaxTableCall ► SetTaxTableCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetTaxTableCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetTaxTableCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


TaxTableList Property

TaxTableList Property
Namespaces ► eBay.Service.Call ► SetTaxTableCall ► TaxTableList
Gets or sets the TaxTable of type TaxJurisdictionTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection TaxTableList { get; set; }
Public Property TaxTableList As TaxJurisdictionTypeCollection
    Get
    Set
public:
property TaxJurisdictionTypeCollection^ TaxTableList {
    TaxJurisdictionTypeCollection^ get ();
    void set (TaxJurisdictionTypeCollection^ value);
}


SetUserNotesCall Class

SetUserNotesCall Class
Namespaces ► eBay.Service.Call ► SetUserNotesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetUserNotesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetUserNotesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetUserNotesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetUserNotesCall()()()() |
 | SetUserNotesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | Action | Gets or sets the Action of type SetUserNotesActionCodeType.
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetUserNotesRequestType for this API call.
 | ApiResponse | Gets the SetUserNotesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NoteText | Gets or sets the NoteText of type String.
 | OrderLineItemID | Gets or sets the OrderLineItemID of type String.
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SetUserNotes(String, SetUserNotesActionCodeType, String, String, NameValueListTypeCollection, String, String) | Enables users to add, replace, and delete My eBay notes for items that are being tracked in the My eBay All Selling and All Buying areas.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SKU | Gets or sets the SKU of type String.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID | Gets or sets the TransactionID of type String.
 | VariationSpecificList | Gets or sets the VariationSpecifics of type NameValueListTypeCollection.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetUserNotesCall


Action Property

Action Property
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► Action
Gets or sets the Action of type SetUserNotesActionCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public SetUserNotesActionCodeType Action { get; set; }
Public Property Action As SetUserNotesActionCodeType
    Get
    Set
public:
property SetUserNotesActionCodeType Action {
    SetUserNotesActionCodeType get ();
    void set (SetUserNotesActionCodeType value);
}


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► ApiRequest
Gets or sets the SetUserNotesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetUserNotesRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetUserNotesRequestType
    Get
    Set
public:
property SetUserNotesRequestType^ ApiRequest {
    SetUserNotesRequestType^ get ();
    void set (SetUserNotesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► ApiResponse
Gets the SetUserNotesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetUserNotesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetUserNotesResponseType
    Get
public:
property SetUserNotesResponseType^ ApiResponse {
    SetUserNotesResponseType^ get ();
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


NoteText Property

NoteText Property
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► NoteText
Gets or sets the NoteText of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string NoteText { get; set; }
Public Property NoteText As String
    Get
    Set
public:
property String^ NoteText {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► OrderLineItemID
Gets or sets the OrderLineItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


SetUserNotes Method (ItemID, Action, NoteText, TransactionID, VariationSpecificList, SKU, OrderLineItemID)

SetUserNotes Method (ItemID, Action, NoteText, TransactionID, VariationSpecificList, SKU, OrderLineItemID)
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► SetUserNotes(String, SetUserNotesActionCodeType, String, String, NameValueListTypeCollection, String, String)
Enables users to add, replace, and delete My eBay notes for items that are being tracked in the My eBay All Selling and All Buying areas.
Declaration Syntax
C# Visual Basic Visual C++
public void SetUserNotes(
    string ItemID,
    SetUserNotesActionCodeType Action,
    string NoteText,
    string TransactionID,
    NameValueListTypeCollection VariationSpecificList,
    string SKU,
    string OrderLineItemID
)
Public Sub SetUserNotes ( _
    ItemID As String, _
    Action As SetUserNotesActionCodeType, _
    NoteText As String, _
    TransactionID As String, _
    VariationSpecificList As NameValueListTypeCollection, _
    SKU As String, _
    OrderLineItemID As String _
)
public:
void SetUserNotes(
    String^ ItemID,
    SetUserNotesActionCodeType Action,
    String^ NoteText,
    String^ TransactionID,
    NameValueListTypeCollection^ VariationSpecificList,
    String^ SKU,
    String^ OrderLineItemID
)
Parameters
ItemID (String)
ID of the item to which the My eBay note will be attached. Notes can only be added to items that are currently being tracked in My eBay.
Action (SetUserNotesActionCodeType)
The seller must include this field and set it to 'AddOrUpdate' to add a new user note or update an existing user note, or set it to 'Delete' to delete a an existing user note.
NoteText (String)
Text of the note. Maximum 250 characters. Required only if the Action is AddOrUpdate. This note text will completely replace any existing My eBay note for the specified item.
TransactionID (String)
Unique identifier for the order line item (transaction) to which the My eBay note will be attached. Notes can only be added to order line items that are currently being tracked in My eBay. Buyers can view user notes made on order line items in the PrivateNotes field of the WonList container in GetMyeBayBuying, and sellers can view user notes made on order line items in the PrivateNotes field of the SoldList and DeletedFromSoldList containers in GetMyeBaySellinging.
VariationSpecificList (NameValueListTypeCollection)
Container consisting of name-value pairs that identify (match) one variation within a fixed-price, multi-variation listing. The specified name-value pair(s) must exist in the listing specified by either the ItemID or SKU values specified in the request. If a specific order line item is targeted in the request with an ItemID/TransactionID pair or an OrderLineItemID value, any specified VariationSpecifics container is ignored by the call.
SKU (String)
SKU value of the item variation to which the My eBay note will be attached. Notes can only be added to items that are currently being tracked in My eBay. A SKU (stock keeping unit) value is defined by and used by the seller to identify a variation within a fixed-price, multi- variation listing. The SKU value is assigned to a variation of an item through the Variations.Variation.SKU element. This field can only be used if the Item.InventoryTrackingMethod field (set with the AddFixedPriceItem or RelistFixedPriceItem calls) is set to SKU. If a specific order line item is targeted in the request with an ItemID/TransactionID pair or an OrderLineItemID value, any specified SKU is ignored by the call.
OrderLineItemID (String)
A unique identifier for an eBay order line item. This field is created as soon as there is a commitment to buy from the seller, and its value is based upon the concatenation of ItemID and TransactionID, with a hyphen in between these two IDs. OrderLineItemID can be used in the input instead of an ItemID/TransactionID pair to identify an order line item. Notes can only be added to order line items that are currently being tracked in My eBay. Buyers can view user notes made on order line items in the PrivateNotes field of the WonList container in GetMyeBayBuying, and sellers can view user notes made on order line items in the PrivateNotes field of the SoldList and DeletedFromSoldList containers in GetMyeBaySellinging.


SetUserNotesCall Constructor

SetUserNotesCall Constructor
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► SetUserNotesCall()()()()
Members
Icon | Member | Description
 | SetUserNotesCall()()()() |
 | SetUserNotesCall(ApiContext) |


SetUserNotesCall Constructor

SetUserNotesCall Constructor
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► SetUserNotesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetUserNotesCall()
Public Sub New
public:
SetUserNotesCall()


SetUserNotesCall Constructor (ApiContext)

SetUserNotesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► SetUserNotesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetUserNotesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetUserNotesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


SKU Property

SKU Property
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► SKU
Gets or sets the SKU of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► TransactionID
Gets or sets the TransactionID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


VariationSpecificList Property

VariationSpecificList Property
Namespaces ► eBay.Service.Call ► SetUserNotesCall ► VariationSpecificList
Gets or sets the VariationSpecifics of type NameValueListTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection VariationSpecificList { get; set; }
Public Property VariationSpecificList As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ VariationSpecificList {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


SetUserPreferencesCall Class

SetUserPreferencesCall Class
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SetUserPreferencesCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SetUserPreferencesCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SetUserPreferencesCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetUserPreferencesCall()()()() |
 | SetUserPreferencesCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the SetUserPreferencesRequestType for this API call.
 | ApiResponse | Gets the SetUserPreferencesResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BidderNoticePreferences | Gets or sets the BidderNoticePreferences of type BidderNoticePreferencesType.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | CombinedPaymentPreferences | Gets or sets the CombinedPaymentPreferences of type CombinedPaymentPreferencesType.
 | CrossPromotionPreferences | Gets or sets the CrossPromotionPreferences of type CrossPromotionPreferencesType.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DispatchCutoffTimePreference | Gets or sets the DispatchCutoffTimePreference of type DispatchCutoffTimePreferencesType.
 | EmailShipmentTrackingNumberPreference | Gets or sets the EmailShipmentTrackingNumberPreference of type Boolean.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndOfAuctionEmailPreferences | Gets or sets the EndOfAuctionEmailPreferences of type EndOfAuctionEmailPreferencesType.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalShippingProgramListingPreference | Gets or sets the GlobalShippingProgramListingPreference of type Boolean.
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutOfStockControlPreference | Gets or sets the OutOfStockControlPreference of type Boolean.
 | OutputSelector | (Inherited from ApiCall.)
 | OverrideGSPserviceWithIntlService | Gets or sets the OverrideGSPserviceWithIntlService of type Boolean.
 | PurchaseReminderEmailPreferences | Gets or sets the PurchaseReminderEmailPreferences of type PurchaseReminderEmailPreferencesType.
 | RequiredShipPhoneNumberPreference | Gets or sets the RequiredShipPhoneNumberPreference of type Boolean.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellerFavoriteItemPreferences | Gets or sets the SellerFavoriteItemPreferences of type SellerFavoriteItemPreferencesType.
 | SellerPaymentPreferences | Gets or sets the SellerPaymentPreferences of type SellerPaymentPreferencesType.
 | SellerThirdPartyCheckoutDisabled | Gets or sets the SellerThirdPartyCheckoutDisabled of type Boolean.
 | SetUserPreferences(BidderNoticePreferencesType, CombinedPaymentPreferencesType, CrossPromotionPreferencesType, SellerPaymentPreferencesType, SellerFavoriteItemPreferencesType, EndOfAuctionEmailPreferencesType, Boolean, Boolean, UnpaidItemAssistancePreferencesType, PurchaseReminderEmailPreferencesType, Boolean, DispatchCutoffTimePreferencesType, Boolean, Boolean, Boolean) | Sets the authenticated user's preferences.
 | SetUserPreferences()()()() | For backward compatibility with old wrappers.
 | SetUserPreferences(BidderNoticePreferencesType, CombinedPaymentPreferencesType, CrossPromotionPreferencesType, SellerPaymentPreferencesType, SellerFavoriteItemPreferencesType, EndOfAuctionEmailPreferencesType) | For backward compatibility with old wrappers.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UnpaidItemAssistancePreferences | Gets or sets the UnpaidItemAssistancePreferences of type UnpaidItemAssistancePreferencesType.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | SetUserPreferencesCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► ApiRequest
Gets or sets the SetUserPreferencesRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetUserPreferencesRequestType ApiRequest { get; set; }
Public Property ApiRequest As SetUserPreferencesRequestType
    Get
    Set
public:
property SetUserPreferencesRequestType^ ApiRequest {
    SetUserPreferencesRequestType^ get ();
    void set (SetUserPreferencesRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► ApiResponse
Gets the SetUserPreferencesResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public SetUserPreferencesResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As SetUserPreferencesResponseType
    Get
public:
property SetUserPreferencesResponseType^ ApiResponse {
    SetUserPreferencesResponseType^ get ();
}


BidderNoticePreferences Property

BidderNoticePreferences Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► BidderNoticePreferences
Gets or sets the BidderNoticePreferences of type BidderNoticePreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public BidderNoticePreferencesType BidderNoticePreferences { get; set; }
Public Property BidderNoticePreferences As BidderNoticePreferencesType
    Get
    Set
public:
property BidderNoticePreferencesType^ BidderNoticePreferences {
    BidderNoticePreferencesType^ get ();
    void set (BidderNoticePreferencesType^ value);
}


CombinedPaymentPreferences Property

CombinedPaymentPreferences Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► CombinedPaymentPreferences
Gets or sets the CombinedPaymentPreferences of type CombinedPaymentPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public CombinedPaymentPreferencesType CombinedPaymentPreferences { get; set; }
Public Property CombinedPaymentPreferences As CombinedPaymentPreferencesType
    Get
    Set
public:
property CombinedPaymentPreferencesType^ CombinedPaymentPreferences {
    CombinedPaymentPreferencesType^ get ();
    void set (CombinedPaymentPreferencesType^ value);
}


CrossPromotionPreferences Property

CrossPromotionPreferences Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► CrossPromotionPreferences
Gets or sets the CrossPromotionPreferences of type CrossPromotionPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public CrossPromotionPreferencesType CrossPromotionPreferences { get; set; }
Public Property CrossPromotionPreferences As CrossPromotionPreferencesType
    Get
    Set
public:
property CrossPromotionPreferencesType^ CrossPromotionPreferences {
    CrossPromotionPreferencesType^ get ();
    void set (CrossPromotionPreferencesType^ value);
}


DispatchCutoffTimePreference Property

DispatchCutoffTimePreference Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► DispatchCutoffTimePreference
Gets or sets the DispatchCutoffTimePreference of type DispatchCutoffTimePreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public DispatchCutoffTimePreferencesType DispatchCutoffTimePreference { get; set; }
Public Property DispatchCutoffTimePreference As DispatchCutoffTimePreferencesType
    Get
    Set
public:
property DispatchCutoffTimePreferencesType^ DispatchCutoffTimePreference {
    DispatchCutoffTimePreferencesType^ get ();
    void set (DispatchCutoffTimePreferencesType^ value);
}


EmailShipmentTrackingNumberPreference Property

EmailShipmentTrackingNumberPreference Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► EmailShipmentTrackingNumberPreference
Gets or sets the EmailShipmentTrackingNumberPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailShipmentTrackingNumberPreference { get; set; }
Public Property EmailShipmentTrackingNumberPreference As Boolean
    Get
    Set
public:
property bool EmailShipmentTrackingNumberPreference {
    bool get ();
    void set (bool value);
}


EndOfAuctionEmailPreferences Property

EndOfAuctionEmailPreferences Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► EndOfAuctionEmailPreferences
Gets or sets the EndOfAuctionEmailPreferences of type EndOfAuctionEmailPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public EndOfAuctionEmailPreferencesType EndOfAuctionEmailPreferences { get; set; }
Public Property EndOfAuctionEmailPreferences As EndOfAuctionEmailPreferencesType
    Get
    Set
public:
property EndOfAuctionEmailPreferencesType^ EndOfAuctionEmailPreferences {
    EndOfAuctionEmailPreferencesType^ get ();
    void set (EndOfAuctionEmailPreferencesType^ value);
}


GlobalShippingProgramListingPreference Property

GlobalShippingProgramListingPreference Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► GlobalShippingProgramListingPreference
Gets or sets the GlobalShippingProgramListingPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShippingProgramListingPreference { get; set; }
Public Property GlobalShippingProgramListingPreference As Boolean
    Get
    Set
public:
property bool GlobalShippingProgramListingPreference {
    bool get ();
    void set (bool value);
}


OutOfStockControlPreference Property

OutOfStockControlPreference Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► OutOfStockControlPreference
Gets or sets the OutOfStockControlPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool OutOfStockControlPreference { get; set; }
Public Property OutOfStockControlPreference As Boolean
    Get
    Set
public:
property bool OutOfStockControlPreference {
    bool get ();
    void set (bool value);
}


OverrideGSPserviceWithIntlService Property

OverrideGSPserviceWithIntlService Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► OverrideGSPserviceWithIntlService
Gets or sets the OverrideGSPserviceWithIntlService of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool OverrideGSPserviceWithIntlService { get; set; }
Public Property OverrideGSPserviceWithIntlService As Boolean
    Get
    Set
public:
property bool OverrideGSPserviceWithIntlService {
    bool get ();
    void set (bool value);
}


PurchaseReminderEmailPreferences Property

PurchaseReminderEmailPreferences Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► PurchaseReminderEmailPreferences
Gets or sets the PurchaseReminderEmailPreferences of type PurchaseReminderEmailPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public PurchaseReminderEmailPreferencesType PurchaseReminderEmailPreferences { get; set; }
Public Property PurchaseReminderEmailPreferences As PurchaseReminderEmailPreferencesType
    Get
    Set
public:
property PurchaseReminderEmailPreferencesType^ PurchaseReminderEmailPreferences {
    PurchaseReminderEmailPreferencesType^ get ();
    void set (PurchaseReminderEmailPreferencesType^ value);
}


RequiredShipPhoneNumberPreference Property

RequiredShipPhoneNumberPreference Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► RequiredShipPhoneNumberPreference
Gets or sets the RequiredShipPhoneNumberPreference of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool RequiredShipPhoneNumberPreference { get; set; }
Public Property RequiredShipPhoneNumberPreference As Boolean
    Get
    Set
public:
property bool RequiredShipPhoneNumberPreference {
    bool get ();
    void set (bool value);
}


SellerFavoriteItemPreferences Property

SellerFavoriteItemPreferences Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► SellerFavoriteItemPreferences
Gets or sets the SellerFavoriteItemPreferences of type SellerFavoriteItemPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public SellerFavoriteItemPreferencesType SellerFavoriteItemPreferences { get; set; }
Public Property SellerFavoriteItemPreferences As SellerFavoriteItemPreferencesType
    Get
    Set
public:
property SellerFavoriteItemPreferencesType^ SellerFavoriteItemPreferences {
    SellerFavoriteItemPreferencesType^ get ();
    void set (SellerFavoriteItemPreferencesType^ value);
}


SellerPaymentPreferences Property

SellerPaymentPreferences Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► SellerPaymentPreferences
Gets or sets the SellerPaymentPreferences of type SellerPaymentPreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentPreferencesType SellerPaymentPreferences { get; set; }
Public Property SellerPaymentPreferences As SellerPaymentPreferencesType
    Get
    Set
public:
property SellerPaymentPreferencesType^ SellerPaymentPreferences {
    SellerPaymentPreferencesType^ get ();
    void set (SellerPaymentPreferencesType^ value);
}


SellerThirdPartyCheckoutDisabled Property

SellerThirdPartyCheckoutDisabled Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► SellerThirdPartyCheckoutDisabled
Gets or sets the SellerThirdPartyCheckoutDisabled of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerThirdPartyCheckoutDisabled { get; set; }
Public Property SellerThirdPartyCheckoutDisabled As Boolean
    Get
    Set
public:
property bool SellerThirdPartyCheckoutDisabled {
    bool get ();
    void set (bool value);
}


SetUserPreferences Method

SetUserPreferences Method
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► SetUserPreferences()()()()
Members
Icon | Member | Description
 | SetUserPreferences(BidderNoticePreferencesType, CombinedPaymentPreferencesType, CrossPromotionPreferencesType, SellerPaymentPreferencesType, SellerFavoriteItemPreferencesType, EndOfAuctionEmailPreferencesType, Boolean, Boolean, UnpaidItemAssistancePreferencesType, PurchaseReminderEmailPreferencesType, Boolean, DispatchCutoffTimePreferencesType, Boolean, Boolean, Boolean) | Sets the authenticated user's preferences.
 | SetUserPreferences()()()() | For backward compatibility with old wrappers.
 | SetUserPreferences(BidderNoticePreferencesType, CombinedPaymentPreferencesType, CrossPromotionPreferencesType, SellerPaymentPreferencesType, SellerFavoriteItemPreferencesType, EndOfAuctionEmailPreferencesType) | For backward compatibility with old wrappers.


SetUserPreferences Method

SetUserPreferences Method
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► SetUserPreferences()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void SetUserPreferences()
Public Sub SetUserPreferences
public:
void SetUserPreferences()


SetUserPreferences Method (BidderNoticePreferences, CombinedPaymentPreferences, CrossPromotionPreferences, SellerPaymentPreferences, SellerFavoriteItemPreferences, EndOfAuctionEmailPreferences)

SetUserPreferences Method (BidderNoticePreferences, CombinedPaymentPreferences, CrossPromotionPreferences, SellerPaymentPreferences, SellerFavoriteItemPreferences, EndOfAuctionEmailPreferences)
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► SetUserPreferences(BidderNoticePreferencesType, CombinedPaymentPreferencesType, CrossPromotionPreferencesType, SellerPaymentPreferencesType, SellerFavoriteItemPreferencesType, EndOfAuctionEmailPreferencesType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void SetUserPreferences(
    BidderNoticePreferencesType BidderNoticePreferences,
    CombinedPaymentPreferencesType CombinedPaymentPreferences,
    CrossPromotionPreferencesType CrossPromotionPreferences,
    SellerPaymentPreferencesType SellerPaymentPreferences,
    SellerFavoriteItemPreferencesType SellerFavoriteItemPreferences,
    EndOfAuctionEmailPreferencesType EndOfAuctionEmailPreferences
)
Public Sub SetUserPreferences ( _
    BidderNoticePreferences As BidderNoticePreferencesType, _
    CombinedPaymentPreferences As CombinedPaymentPreferencesType, _
    CrossPromotionPreferences As CrossPromotionPreferencesType, _
    SellerPaymentPreferences As SellerPaymentPreferencesType, _
    SellerFavoriteItemPreferences As SellerFavoriteItemPreferencesType, _
    EndOfAuctionEmailPreferences As EndOfAuctionEmailPreferencesType _
)
public:
void SetUserPreferences(
    BidderNoticePreferencesType^ BidderNoticePreferences,
    CombinedPaymentPreferencesType^ CombinedPaymentPreferences,
    CrossPromotionPreferencesType^ CrossPromotionPreferences,
    SellerPaymentPreferencesType^ SellerPaymentPreferences,
    SellerFavoriteItemPreferencesType^ SellerFavoriteItemPreferences,
    EndOfAuctionEmailPreferencesType^ EndOfAuctionEmailPreferences
)
Parameters
BidderNoticePreferences (BidderNoticePreferencesType)
CombinedPaymentPreferences (CombinedPaymentPreferencesType)
CrossPromotionPreferences (CrossPromotionPreferencesType)
SellerPaymentPreferences (SellerPaymentPreferencesType)
SellerFavoriteItemPreferences (SellerFavoriteItemPreferencesType)
EndOfAuctionEmailPreferences (EndOfAuctionEmailPreferencesType)


SetUserPreferences Method (BidderNoticePreferences, CombinedPaymentPreferences, CrossPromotionPreferences, SellerPaymentPreferences, SellerFavoriteItemPreferences, EndOfAuctionEmailPreferences, EmailShipmentTrackingNumberPreference, RequiredShipPhoneNumberPreference, UnpaidItemAssistancePreferences,

SetUserPreferences Method (BidderNoticePreferences, CombinedPaymentPreferences, CrossPromotionPreferences, SellerPaymentPreferences, SellerFavoriteItemPreferences, EndOfAuctionEmailPreferences, EmailShipmentTrackingNumberPreference, RequiredShipPhoneNumberPreference, UnpaidItemAssistancePreferences, PurchaseReminderEmailPreferences, SellerThirdPartyCheckoutDisabled, DispatchCutoffTimePreference, GlobalShippingProgramListingPreference, OverrideGSPserviceWithIntlService, OutOfStockControlPreference)
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► SetUserPreferences(BidderNoticePreferencesType, CombinedPaymentPreferencesType, CrossPromotionPreferencesType, SellerPaymentPreferencesType, SellerFavoriteItemPreferencesType, EndOfAuctionEmailPreferencesType, Boolean, Boolean, UnpaidItemAssistancePreferencesType, PurchaseReminderEmailPreferencesType, Boolean, DispatchCutoffTimePreferencesType, Boolean, Boolean, Boolean)
Sets the authenticated user's preferences.
Declaration Syntax
C# Visual Basic Visual C++
public void SetUserPreferences(
    BidderNoticePreferencesType BidderNoticePreferences,
    CombinedPaymentPreferencesType CombinedPaymentPreferences,
    CrossPromotionPreferencesType CrossPromotionPreferences,
    SellerPaymentPreferencesType SellerPaymentPreferences,
    SellerFavoriteItemPreferencesType SellerFavoriteItemPreferences,
    EndOfAuctionEmailPreferencesType EndOfAuctionEmailPreferences,
    bool EmailShipmentTrackingNumberPreference,
    bool RequiredShipPhoneNumberPreference,
    UnpaidItemAssistancePreferencesType UnpaidItemAssistancePreferences,
    PurchaseReminderEmailPreferencesType PurchaseReminderEmailPreferences,
    bool SellerThirdPartyCheckoutDisabled,
    DispatchCutoffTimePreferencesType DispatchCutoffTimePreference,
    bool GlobalShippingProgramListingPreference,
    bool OverrideGSPserviceWithIntlService,
    bool OutOfStockControlPreference
)
Public Sub SetUserPreferences ( _
    BidderNoticePreferences As BidderNoticePreferencesType, _
    CombinedPaymentPreferences As CombinedPaymentPreferencesType, _
    CrossPromotionPreferences As CrossPromotionPreferencesType, _
    SellerPaymentPreferences As SellerPaymentPreferencesType, _
    SellerFavoriteItemPreferences As SellerFavoriteItemPreferencesType, _
    EndOfAuctionEmailPreferences As EndOfAuctionEmailPreferencesType, _
    EmailShipmentTrackingNumberPreference As Boolean, _
    RequiredShipPhoneNumberPreference As Boolean, _
    UnpaidItemAssistancePreferences As UnpaidItemAssistancePreferencesType, _
    PurchaseReminderEmailPreferences As PurchaseReminderEmailPreferencesType, _
    SellerThirdPartyCheckoutDisabled As Boolean, _
    DispatchCutoffTimePreference As DispatchCutoffTimePreferencesType, _
    GlobalShippingProgramListingPreference As Boolean, _
    OverrideGSPserviceWithIntlService As Boolean, _
    OutOfStockControlPreference As Boolean _
)
public:
void SetUserPreferences(
    BidderNoticePreferencesType^ BidderNoticePreferences,
    CombinedPaymentPreferencesType^ CombinedPaymentPreferences,
    CrossPromotionPreferencesType^ CrossPromotionPreferences,
    SellerPaymentPreferencesType^ SellerPaymentPreferences,
    SellerFavoriteItemPreferencesType^ SellerFavoriteItemPreferences,
    EndOfAuctionEmailPreferencesType^ EndOfAuctionEmailPreferences,
    bool EmailShipmentTrackingNumberPreference,
    bool RequiredShipPhoneNumberPreference,
    UnpaidItemAssistancePreferencesType^ UnpaidItemAssistancePreferences,
    PurchaseReminderEmailPreferencesType^ PurchaseReminderEmailPreferences,
    bool SellerThirdPartyCheckoutDisabled,
    DispatchCutoffTimePreferencesType^ DispatchCutoffTimePreference,
    bool GlobalShippingProgramListingPreference,
    bool OverrideGSPserviceWithIntlService,
    bool OutOfStockControlPreference
)
Parameters
BidderNoticePreferences (BidderNoticePreferencesType)
Container consisting of the seller's preference for receiving contact information for unsuccessful bidders. This preference is only applicable for auction listings.
CombinedPaymentPreferences (CombinedPaymentPreferencesType)
Container consisting of the seller's preference for allowing Combined Invoice orders for the same seller and buyer. Note: Calculated and flat-rate shipping preferences are no longer set using this call. Instead, use the SetShippingDiscountProfiles call to set the shipping discounts for Combined Invoice orders. Note: A seller's combined payment preferences can take up to 7 days to have any affect on eBay.
CrossPromotionPreferences (CrossPromotionPreferencesType)
This field is deprecated.
SellerPaymentPreferences (SellerPaymentPreferencesType)
Container consisting of the seller's payment preferences. One or more preferences may be set or modified under this field. Payment preferences specified in a SetUserPreferences call override the settings in My eBay payment preferences.
SellerFavoriteItemPreferences (SellerFavoriteItemPreferencesType)
Container consisting of the seller's preferences for displaying items on a buyer's Favorite Sellers' Items page or Favorite Sellers' Items digest. One or more preferences may be set or modified under this field.
EndOfAuctionEmailPreferences (EndOfAuctionEmailPreferencesType)
Container consisting of the seller's preferences for the end-of-auction email sent to the winning bidder. These preferences allow the seller to customize the Email that is sent to buyer at the end of the auction. One or more preferences may be set or modified under this field. These preferences are only applicable for auction listings.
EmailShipmentTrackingNumberPreference (Boolean)
Flag that controls whether the shipment's tracking number is sent by Email from the seller to the buyer.
RequiredShipPhoneNumberPreference (Boolean)
Flag that controls whether the buyer is required to provide a shipping phone number upon checkout. Some shipping carriers require the receiver's phone number.
UnpaidItemAssistancePreferences (UnpaidItemAssistancePreferencesType)
Container consisting of a seller's Unpaid Item Assistant preferences. The Unpaid Item Assistant automatically opens an Unpaid Item dispute on the behalf of the seller. One or more preferences may be set or modified under this field.
PurchaseReminderEmailPreferences (PurchaseReminderEmailPreferencesType)
Container consisting of a seller's preference for sending a purchase reminder email to buyers.
SellerThirdPartyCheckoutDisabled (Boolean)
A flag used to disable the use of a third-party application to handle the checkout flow for a seller. If set to true, Third-Party Checkout is disabled and any checkout flow initiated on the seller's application is redirected to the eBay checkout flow.
DispatchCutoffTimePreference (DispatchCutoffTimePreferencesType)
Contains information about a seller's order cut off time preferences for same day shipping. If the seller specifies a value of
0
in Item.DispatchTimeMax to offer same day handling when listing an item, the seller's shipping time commitment depends on the order cut off time set for the listing site, as indicated by DispatchCutoffTimePreference.CutoffTime.
GlobalShippingProgramListingPreference (Boolean)
If this flag is included and set to
true
, the seller's new listings will enable the Global Shipping Program by default.

Note: This field is ignored for sellers who are not opted in to the Global Shipping Program (when GetUserPreferences returns OfferGlobalShippingProgramPreference with a value of
false
).
OverrideGSPserviceWithIntlService (Boolean)
If this flag is included and set to
true
, and the seller specifies an international shipping service to a particular country for a given listing, the specified service will take precedence and be the listing's default international shipping option for buyers in that country, rather than the Global Shipping Program. The Global Shipping Program will still be the listing's default option for shipping to any Global Shipping-eligible country for which the seller does not specify an international shipping service.

If this flag is set to
false
, the Global Shipping Program will be each Global Shipping-eligible listing's default option for shipping to any Global Shipping-eligible country, regardless of any international shipping service that the seller specifies for the listing.
OutOfStockControlPreference (Boolean)
When this flag is set to 'true', it enable the Out-of-Stock feature. A seller would use this feature to keep Fixed-Price GTC (Good 'Til Canceled) listings alive even when the "quantity available" value goes to 0 (zero). This is useful when waiting for additional stock and eliminates the need to end the listing and then recreating it when stock arrives.

While the "quantity available" value is 0, the listing would be hidden from eBay search and if that item was specifically searched for with GetItem (or related call), the element HideFromSearch would be returned as 'true' and ReasonHideFromSearch would be returned as 'OutOfStock'.

When stock is available, the seller can use the Revise calls to update the inventory of the item (through the Item.Quantity or Item.Variations.Variation.Quantity fields) and the listing would appear again.

You can return the value of this flag using the GetUserPreferences call and setting the ShowOutOfStockControlPreference field to 'true'.

IMPORTANT: When a listing using the Out-of-Stock feature has zero quantity, the seller has 90 days to add inventory without incurring a listing fee. Fees are changed at the end of each the billing cycle but are then refunded if the item is out-of-stock for an entire billing period. See Fees For a Listing With Zero Quantity for details.


SetUserPreferencesCall Constructor

SetUserPreferencesCall Constructor
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► SetUserPreferencesCall()()()()
Members
Icon | Member | Description
 | SetUserPreferencesCall()()()() |
 | SetUserPreferencesCall(ApiContext) |


SetUserPreferencesCall Constructor

SetUserPreferencesCall Constructor
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► SetUserPreferencesCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetUserPreferencesCall()
Public Sub New
public:
SetUserPreferencesCall()


SetUserPreferencesCall Constructor (ApiContext)

SetUserPreferencesCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► SetUserPreferencesCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public SetUserPreferencesCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
SetUserPreferencesCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


UnpaidItemAssistancePreferences Property

UnpaidItemAssistancePreferences Property
Namespaces ► eBay.Service.Call ► SetUserPreferencesCall ► UnpaidItemAssistancePreferences
Gets or sets the UnpaidItemAssistancePreferences of type UnpaidItemAssistancePreferencesType.
Declaration Syntax
C# Visual Basic Visual C++
public UnpaidItemAssistancePreferencesType UnpaidItemAssistancePreferences { get; set; }
Public Property UnpaidItemAssistancePreferences As UnpaidItemAssistancePreferencesType
    Get
    Set
public:
property UnpaidItemAssistancePreferencesType^ UnpaidItemAssistancePreferences {
    UnpaidItemAssistancePreferencesType^ get ();
    void set (UnpaidItemAssistancePreferencesType^ value);
}


ValidateChallengeInputCall Class

ValidateChallengeInputCall Class
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ValidateChallengeInputCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ValidateChallengeInputCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ValidateChallengeInputCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidateChallengeInputCall()()()() |
 | ValidateChallengeInputCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ValidateChallengeInputRequestType for this API call.
 | ApiResponse | Gets the ValidateChallengeInputResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | ChallengeToken | Gets or sets the ChallengeToken of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | KeepTokenValid | Gets or sets the KeepTokenValid of type Boolean.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | UserInput | Gets or sets the UserInput of type String.
 | ValidateChallengeInput(String, String, Boolean) | Validates the user response to a GetChallengeToken botblock challenge.
 | ValidToken | Gets the returned ValidToken of type Boolean.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ValidateChallengeInputCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall ► ApiRequest
Gets or sets the ValidateChallengeInputRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ValidateChallengeInputRequestType ApiRequest { get; set; }
Public Property ApiRequest As ValidateChallengeInputRequestType
    Get
    Set
public:
property ValidateChallengeInputRequestType^ ApiRequest {
    ValidateChallengeInputRequestType^ get ();
    void set (ValidateChallengeInputRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall ► ApiResponse
Gets the ValidateChallengeInputResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ValidateChallengeInputResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ValidateChallengeInputResponseType
    Get
public:
property ValidateChallengeInputResponseType^ ApiResponse {
    ValidateChallengeInputResponseType^ get ();
}


ChallengeToken Property

ChallengeToken Property
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall ► ChallengeToken
Gets or sets the ChallengeToken of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ChallengeToken { get; set; }
Public Property ChallengeToken As String
    Get
    Set
public:
property String^ ChallengeToken {
    String^ get ();
    void set (String^ value);
}


KeepTokenValid Property

KeepTokenValid Property
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall ► KeepTokenValid
Gets or sets the KeepTokenValid of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool KeepTokenValid { get; set; }
Public Property KeepTokenValid As Boolean
    Get
    Set
public:
property bool KeepTokenValid {
    bool get ();
    void set (bool value);
}


UserInput Property

UserInput Property
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall ► UserInput
Gets or sets the UserInput of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string UserInput { get; set; }
Public Property UserInput As String
    Get
    Set
public:
property String^ UserInput {
    String^ get ();
    void set (String^ value);
}


ValidateChallengeInput Method (ChallengeToken, UserInput, KeepTokenValid)

ValidateChallengeInput Method (ChallengeToken, UserInput, KeepTokenValid)
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall ► ValidateChallengeInput(String, String, Boolean)
Validates the user response to a GetChallengeToken botblock challenge.
Declaration Syntax
C# Visual Basic Visual C++
public bool ValidateChallengeInput(
    string ChallengeToken,
    string UserInput,
    bool KeepTokenValid
)
Public Function ValidateChallengeInput ( _
    ChallengeToken As String, _
    UserInput As String, _
    KeepTokenValid As Boolean _
) As Boolean
public:
bool ValidateChallengeInput(
    String^ ChallengeToken,
    String^ UserInput,
    bool KeepTokenValid
)
Parameters
ChallengeToken (String)
Botblock token that was returned by GetChallengeToken.
UserInput (String)
User response to a botblock challenge.
KeepTokenValid (Boolean)
Whether the challenge token should remain valid for up to two minutes.


ValidateChallengeInputCall Constructor

ValidateChallengeInputCall Constructor
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall ► ValidateChallengeInputCall()()()()
Members
Icon | Member | Description
 | ValidateChallengeInputCall()()()() |
 | ValidateChallengeInputCall(ApiContext) |


ValidateChallengeInputCall Constructor

ValidateChallengeInputCall Constructor
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall ► ValidateChallengeInputCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValidateChallengeInputCall()
Public Sub New
public:
ValidateChallengeInputCall()


ValidateChallengeInputCall Constructor (ApiContext)

ValidateChallengeInputCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall ► ValidateChallengeInputCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ValidateChallengeInputCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ValidateChallengeInputCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


ValidToken Property

ValidToken Property
Namespaces ► eBay.Service.Call ► ValidateChallengeInputCall ► ValidToken
Gets the returned ValidToken of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ValidToken { get; }
Public ReadOnly Property ValidToken As Boolean
    Get
public:
property bool ValidToken {
    bool get ();
}


ValidateTestUserRegistrationCall Class

ValidateTestUserRegistrationCall Class
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ValidateTestUserRegistrationCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ValidateTestUserRegistrationCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ValidateTestUserRegistrationCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidateTestUserRegistrationCall()()()() |
 | ValidateTestUserRegistrationCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the ValidateTestUserRegistrationRequestType for this API call.
 | ApiResponse | Gets the ValidateTestUserRegistrationResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeedbackScore | Gets or sets the FeedbackScore of type Int32.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | RegistrationDate | Gets or sets the RegistrationDate of type DateTime.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | SubscribeSA | Gets or sets the SubscribeSA of type Boolean.
 | SubscribeSAPro | Gets or sets the SubscribeSAPro of type Boolean.
 | SubscribeSM | Gets or sets the SubscribeSM of type Boolean.
 | SubscribeSMPro | Gets or sets the SubscribeSMPro of type Boolean.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | ValidateTestUserRegistration(Int32, DateTime, Boolean, Boolean, Boolean, Boolean) | Requests to enable a test user to sell items in the Sandbox environment.
 | ValidateTestUserRegistration()()()() | For backward compatibility with old wrappers.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | ValidateTestUserRegistrationCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► ApiRequest
Gets or sets the ValidateTestUserRegistrationRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ValidateTestUserRegistrationRequestType ApiRequest { get; set; }
Public Property ApiRequest As ValidateTestUserRegistrationRequestType
    Get
    Set
public:
property ValidateTestUserRegistrationRequestType^ ApiRequest {
    ValidateTestUserRegistrationRequestType^ get ();
    void set (ValidateTestUserRegistrationRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► ApiResponse
Gets the ValidateTestUserRegistrationResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public ValidateTestUserRegistrationResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As ValidateTestUserRegistrationResponseType
    Get
public:
property ValidateTestUserRegistrationResponseType^ ApiResponse {
    ValidateTestUserRegistrationResponseType^ get ();
}


FeedbackScore Property

FeedbackScore Property
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► FeedbackScore
Gets or sets the FeedbackScore of type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int FeedbackScore { get; set; }
Public Property FeedbackScore As Integer
    Get
    Set
public:
property int FeedbackScore {
    int get ();
    void set (int value);
}


RegistrationDate Property

RegistrationDate Property
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► RegistrationDate
Gets or sets the RegistrationDate of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RegistrationDate { get; set; }
Public Property RegistrationDate As DateTime
    Get
    Set
public:
property DateTime RegistrationDate {
    DateTime get ();
    void set (DateTime value);
}


SubscribeSA Property

SubscribeSA Property
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► SubscribeSA
Gets or sets the SubscribeSA of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSA { get; set; }
Public Property SubscribeSA As Boolean
    Get
    Set
public:
property bool SubscribeSA {
    bool get ();
    void set (bool value);
}


SubscribeSAPro Property

SubscribeSAPro Property
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► SubscribeSAPro
Gets or sets the SubscribeSAPro of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSAPro { get; set; }
Public Property SubscribeSAPro As Boolean
    Get
    Set
public:
property bool SubscribeSAPro {
    bool get ();
    void set (bool value);
}


SubscribeSM Property

SubscribeSM Property
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► SubscribeSM
Gets or sets the SubscribeSM of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSM { get; set; }
Public Property SubscribeSM As Boolean
    Get
    Set
public:
property bool SubscribeSM {
    bool get ();
    void set (bool value);
}


SubscribeSMPro Property

SubscribeSMPro Property
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► SubscribeSMPro
Gets or sets the SubscribeSMPro of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSMPro { get; set; }
Public Property SubscribeSMPro As Boolean
    Get
    Set
public:
property bool SubscribeSMPro {
    bool get ();
    void set (bool value);
}


ValidateTestUserRegistration Method

ValidateTestUserRegistration Method
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► ValidateTestUserRegistration()()()()
Members
Icon | Member | Description
 | ValidateTestUserRegistration(Int32, DateTime, Boolean, Boolean, Boolean, Boolean) | Requests to enable a test user to sell items in the Sandbox environment.
 | ValidateTestUserRegistration()()()() | For backward compatibility with old wrappers.


ValidateTestUserRegistration Method

ValidateTestUserRegistration Method
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► ValidateTestUserRegistration()()()()
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void ValidateTestUserRegistration()
Public Sub ValidateTestUserRegistration
public:
void ValidateTestUserRegistration()


ValidateTestUserRegistration Method (FeedbackScore, RegistrationDate, SubscribeSA, SubscribeSAPro, SubscribeSM, SubscribeSMPro)

ValidateTestUserRegistration Method (FeedbackScore, RegistrationDate, SubscribeSA, SubscribeSAPro, SubscribeSM, SubscribeSMPro)
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► ValidateTestUserRegistration(Int32, DateTime, Boolean, Boolean, Boolean, Boolean)
Requests to enable a test user to sell items in the Sandbox environment.
Declaration Syntax
C# Visual Basic Visual C++
public void ValidateTestUserRegistration(
    int FeedbackScore,
    DateTime RegistrationDate,
    bool SubscribeSA,
    bool SubscribeSAPro,
    bool SubscribeSM,
    bool SubscribeSMPro
)
Public Sub ValidateTestUserRegistration ( _
    FeedbackScore As Integer, _
    RegistrationDate As DateTime, _
    SubscribeSA As Boolean, _
    SubscribeSAPro As Boolean, _
    SubscribeSM As Boolean, _
    SubscribeSMPro As Boolean _
)
public:
void ValidateTestUserRegistration(
    int FeedbackScore,
    DateTime RegistrationDate,
    bool SubscribeSA,
    bool SubscribeSAPro,
    bool SubscribeSM,
    bool SubscribeSMPro
)
Parameters
FeedbackScore (Int32)
Value for the feedback score of a user. If no value is passed in the request, or if the value is zero, the feedback score is unchanged. This element is not intended for regularly testing feedback because the feedback value can change after the request.
RegistrationDate (DateTime)
Value for the date and time that a user's registration begins.
SubscribeSA (Boolean)
Indicates if a user subscribes to Seller's Assistant. You cannot request to subscribe a user to both Seller's Assistant and Seller's Assistant Pro. You cannot request to unsubscribe a user.
SubscribeSAPro (Boolean)
Indicates if a user subscribes to Seller's Assistant Pro. You cannot request to subscribe a user to both Seller's Assistant and Seller's Assistant Pro. You cannot request to unsubscribe a user.
SubscribeSM (Boolean)
Indicates if a user subscribes to Selling Manager. You cannot request to subscribe a user to both Selling Manager and Selling Manager Pro. You cannot request to unsubscribe a user.
SubscribeSMPro (Boolean)
Indicates if a user subscribes to Selling Manager Pro. You cannot request to subscribe a user to both Selling Manager and Selling Manager Pro. You cannot request to unsubscribe a user.


ValidateTestUserRegistrationCall Constructor

ValidateTestUserRegistrationCall Constructor
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► ValidateTestUserRegistrationCall()()()()
Members
Icon | Member | Description
 | ValidateTestUserRegistrationCall()()()() |
 | ValidateTestUserRegistrationCall(ApiContext) |


ValidateTestUserRegistrationCall Constructor

ValidateTestUserRegistrationCall Constructor
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► ValidateTestUserRegistrationCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValidateTestUserRegistrationCall()
Public Sub New
public:
ValidateTestUserRegistrationCall()


ValidateTestUserRegistrationCall Constructor (ApiContext)

ValidateTestUserRegistrationCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► ValidateTestUserRegistrationCall ► ValidateTestUserRegistrationCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public ValidateTestUserRegistrationCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ValidateTestUserRegistrationCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


VerifyAddFixedPriceItemCall Class

VerifyAddFixedPriceItemCall Class
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class VerifyAddFixedPriceItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class VerifyAddFixedPriceItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class VerifyAddFixedPriceItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyAddFixedPriceItemCall()()()() |
 | VerifyAddFixedPriceItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the VerifyAddFixedPriceItemRequestType for this API call.
 | ApiResponse | Gets the VerifyAddFixedPriceItemResponseType for this API call.
 | AutoSetItemUUID |
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Category2ID | Gets the returned Category2ID of type String.
 | CategoryID | Gets the returned CategoryID of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DiscountReasonList | Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | (Overrides ApiCall.Execute()()()().)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | ExpressItemRequirements | Gets the returned ExpressItemRequirements of type ExpressItemRequirementsType.
 | ExpressListing | Gets the returned ExpressListing of type Boolean.
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | ItemID | Gets the returned ItemID of type String.
 | ListingRecommendations | Gets the returned ListingRecommendations of type ListingRecommendationsType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewUUID()()()() | Generates a universal unique identifier.
 | OutputSelector | (Inherited from ApiCall.)
 | PictureFileList |
 | ResetItemUUID(ItemType) | Sets or overwrites the UUID.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SKU | Gets the returned SKU of type String.
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | VerifyAddFixedPriceItem(ItemType) | Enables a seller to test the definition of a new fixed-price listing by submitting the definition to eBay without creating a actual listing.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | VerifyAddFixedPriceItemCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► ApiRequest
Gets or sets the VerifyAddFixedPriceItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddFixedPriceItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As VerifyAddFixedPriceItemRequestType
    Get
    Set
public:
property VerifyAddFixedPriceItemRequestType^ ApiRequest {
    VerifyAddFixedPriceItemRequestType^ get ();
    void set (VerifyAddFixedPriceItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► ApiResponse
Gets the VerifyAddFixedPriceItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddFixedPriceItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As VerifyAddFixedPriceItemResponseType
    Get
public:
property VerifyAddFixedPriceItemResponseType^ ApiResponse {
    VerifyAddFixedPriceItemResponseType^ get ();
}


AutoSetItemUUID Property

AutoSetItemUUID Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► AutoSetItemUUID
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoSetItemUUID { get; set; }
Public Property AutoSetItemUUID As Boolean
    Get
    Set
public:
property bool AutoSetItemUUID {
    bool get ();
    void set (bool value);
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► Category2ID
Gets the returned Category2ID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; }
Public ReadOnly Property Category2ID As String
    Get
public:
property String^ Category2ID {
    String^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► CategoryID
Gets the returned CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; }
Public ReadOnly Property CategoryID As String
    Get
public:
property String^ CategoryID {
    String^ get ();
}


DiscountReasonList Property

DiscountReasonList Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► DiscountReasonList
Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReasonList { get; }
Public ReadOnly Property DiscountReasonList As DiscountReasonCodeTypeCollection
    Get
public:
property DiscountReasonCodeTypeCollection^ DiscountReasonList {
    DiscountReasonCodeTypeCollection^ get ();
}


Execute Method

Execute Method
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► Execute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Execute()
Public Overrides Sub Execute
public:
virtual void Execute() override


ExpressItemRequirements Property

ExpressItemRequirements Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► ExpressItemRequirements
Gets the returned ExpressItemRequirements of type ExpressItemRequirementsType.
Declaration Syntax
C# Visual Basic Visual C++
public ExpressItemRequirementsType ExpressItemRequirements { get; }
Public ReadOnly Property ExpressItemRequirements As ExpressItemRequirementsType
    Get
public:
property ExpressItemRequirementsType^ ExpressItemRequirements {
    ExpressItemRequirementsType^ get ();
}


ExpressListing Property

ExpressListing Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► ExpressListing
Gets the returned ExpressListing of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressListing { get; }
Public ReadOnly Property ExpressListing As Boolean
    Get
public:
property bool ExpressListing {
    bool get ();
}


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► ItemID
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; }
Public ReadOnly Property ItemID As String
    Get
public:
property String^ ItemID {
    String^ get ();
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► ListingRecommendations
Gets the returned ListingRecommendations of type ListingRecommendationsType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; }
Public ReadOnly Property ListingRecommendations As ListingRecommendationsType
    Get
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
}


NewUUID Method

NewUUID Method
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► NewUUID()()()()
Generates a universal unique identifier.
Declaration Syntax
C# Visual Basic Visual C++
public static string NewUUID()
Public Shared Function NewUUID As String
public:
static String^ NewUUID()
Return Value
A universal unique identifier of type String


PictureFileList Property

PictureFileList Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► PictureFileList
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureFileList { get; set; }
Public Property PictureFileList As StringCollection
    Get
    Set
public:
property StringCollection^ PictureFileList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ResetItemUUID Method (Item)

ResetItemUUID Method (Item)
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► ResetItemUUID(ItemType)
Sets or overwrites the UUID.
Declaration Syntax
C# Visual Basic Visual C++
public static void ResetItemUUID(
    ItemType Item
)
Public Shared Sub ResetItemUUID ( _
    Item As ItemType _
)
public:
static void ResetItemUUID(
    ItemType^ Item
)
Parameters
Item (ItemType)
The item to assign a universal unique identifier to.


SKU Property

SKU Property
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► SKU
Gets the returned SKU of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; }
Public ReadOnly Property SKU As String
    Get
public:
property String^ SKU {
    String^ get ();
}


VerifyAddFixedPriceItem Method (Item)

VerifyAddFixedPriceItem Method (Item)
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► VerifyAddFixedPriceItem(ItemType)
Enables a seller to test the definition of a new fixed-price listing by submitting the definition to eBay without creating a actual listing.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection VerifyAddFixedPriceItem(
    ItemType Item
)
Public Function VerifyAddFixedPriceItem ( _
    Item As ItemType _
) As FeeTypeCollection
public:
FeeTypeCollection^ VerifyAddFixedPriceItem(
    ItemType^ Item
)
Parameters
Item (ItemType)
Root container holding all values that define a new fixed-price listing.


VerifyAddFixedPriceItemCall Constructor

VerifyAddFixedPriceItemCall Constructor
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► VerifyAddFixedPriceItemCall()()()()
Members
Icon | Member | Description
 | VerifyAddFixedPriceItemCall()()()() |
 | VerifyAddFixedPriceItemCall(ApiContext) |


VerifyAddFixedPriceItemCall Constructor

VerifyAddFixedPriceItemCall Constructor
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► VerifyAddFixedPriceItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddFixedPriceItemCall()
Public Sub New
public:
VerifyAddFixedPriceItemCall()


VerifyAddFixedPriceItemCall Constructor (ApiContext)

VerifyAddFixedPriceItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► VerifyAddFixedPriceItemCall ► VerifyAddFixedPriceItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddFixedPriceItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
VerifyAddFixedPriceItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


VerifyAddItemCall Class

VerifyAddItemCall Class
Namespaces ► eBay.Service.Call ► VerifyAddItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class VerifyAddItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class VerifyAddItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class VerifyAddItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyAddItemCall()()()() |
 | VerifyAddItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the VerifyAddItemRequestType for this API call.
 | ApiResponse | Gets the VerifyAddItemResponseType for this API call.
 | AutoSetItemUUID |
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | Category2ID | Gets the returned Category2ID of type String.
 | CategoryID | Gets the returned CategoryID of type String.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DiscountReasonList | Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | (Overrides ApiCall.Execute()()()().)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | ExpressItemRequirements | Gets the returned ExpressItemRequirements of type ExpressItemRequirementsType.
 | ExpressListing | Gets the returned ExpressListing of type Boolean.
 | ExternalProductID | Gets or sets the ExternalProductID of type ExternalProductIDType.
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | IncludeExpressRequirements | Gets or sets the IncludeExpressRequirements of type Boolean.
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | ItemID | Gets the returned ItemID of type String.
 | ListingRecommendations | Gets the returned ListingRecommendations of type ListingRecommendationsType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewUUID()()()() | Generates a universal unique identifier.
 | OutputSelector | (Inherited from ApiCall.)
 | PictureFileList |
 | ProductSuggestions | Gets the returned ProductSuggestions of type ProductSuggestionsType.
 | ResetItemUUID(ItemType) | Sets or overwrites the UUID.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | VerifyAddItem(ItemType, Boolean, ExternalProductIDType) |
 | VerifyAddItem(ItemType) | For backward compatibility with old wrappers.
 | VerifyAddItem(ItemType, ExternalProductIDType) | For backward compatibility with old wrappers.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | VerifyAddItemCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► ApiRequest
Gets or sets the VerifyAddItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As VerifyAddItemRequestType
    Get
    Set
public:
property VerifyAddItemRequestType^ ApiRequest {
    VerifyAddItemRequestType^ get ();
    void set (VerifyAddItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► ApiResponse
Gets the VerifyAddItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As VerifyAddItemResponseType
    Get
public:
property VerifyAddItemResponseType^ ApiResponse {
    VerifyAddItemResponseType^ get ();
}


AutoSetItemUUID Property

AutoSetItemUUID Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► AutoSetItemUUID
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoSetItemUUID { get; set; }
Public Property AutoSetItemUUID As Boolean
    Get
    Set
public:
property bool AutoSetItemUUID {
    bool get ();
    void set (bool value);
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► Category2ID
Gets the returned Category2ID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; }
Public ReadOnly Property Category2ID As String
    Get
public:
property String^ Category2ID {
    String^ get ();
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► CategoryID
Gets the returned CategoryID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; }
Public ReadOnly Property CategoryID As String
    Get
public:
property String^ CategoryID {
    String^ get ();
}


DiscountReasonList Property

DiscountReasonList Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► DiscountReasonList
Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReasonList { get; }
Public ReadOnly Property DiscountReasonList As DiscountReasonCodeTypeCollection
    Get
public:
property DiscountReasonCodeTypeCollection^ DiscountReasonList {
    DiscountReasonCodeTypeCollection^ get ();
}


Execute Method

Execute Method
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► Execute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Execute()
Public Overrides Sub Execute
public:
virtual void Execute() override


ExpressItemRequirements Property

ExpressItemRequirements Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► ExpressItemRequirements
Gets the returned ExpressItemRequirements of type ExpressItemRequirementsType.
Declaration Syntax
C# Visual Basic Visual C++
public ExpressItemRequirementsType ExpressItemRequirements { get; }
Public ReadOnly Property ExpressItemRequirements As ExpressItemRequirementsType
    Get
public:
property ExpressItemRequirementsType^ ExpressItemRequirements {
    ExpressItemRequirementsType^ get ();
}


ExpressListing Property

ExpressListing Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► ExpressListing
Gets the returned ExpressListing of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressListing { get; }
Public ReadOnly Property ExpressListing As Boolean
    Get
public:
property bool ExpressListing {
    bool get ();
}


ExternalProductID Property

ExternalProductID Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► ExternalProductID
Gets or sets the ExternalProductID of type ExternalProductIDType.
Declaration Syntax
C# Visual Basic Visual C++
public ExternalProductIDType ExternalProductID { get; set; }
Public Property ExternalProductID As ExternalProductIDType
    Get
    Set
public:
property ExternalProductIDType^ ExternalProductID {
    ExternalProductIDType^ get ();
    void set (ExternalProductIDType^ value);
}


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


IncludeExpressRequirements Property

IncludeExpressRequirements Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► IncludeExpressRequirements
Gets or sets the IncludeExpressRequirements of type Boolean.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeExpressRequirements { get; set; }
Public Property IncludeExpressRequirements As Boolean
    Get
    Set
public:
property bool IncludeExpressRequirements {
    bool get ();
    void set (bool value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► ItemID
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; }
Public ReadOnly Property ItemID As String
    Get
public:
property String^ ItemID {
    String^ get ();
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► ListingRecommendations
Gets the returned ListingRecommendations of type ListingRecommendationsType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; }
Public ReadOnly Property ListingRecommendations As ListingRecommendationsType
    Get
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
}


NewUUID Method

NewUUID Method
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► NewUUID()()()()
Generates a universal unique identifier.
Declaration Syntax
C# Visual Basic Visual C++
public static string NewUUID()
Public Shared Function NewUUID As String
public:
static String^ NewUUID()
Return Value
A universal unique identifier of type String


PictureFileList Property

PictureFileList Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► PictureFileList
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureFileList { get; set; }
Public Property PictureFileList As StringCollection
    Get
    Set
public:
property StringCollection^ PictureFileList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► ProductSuggestions
Gets the returned ProductSuggestions of type ProductSuggestionsType.
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; }
Public ReadOnly Property ProductSuggestions As ProductSuggestionsType
    Get
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
}


ResetItemUUID Method (Item)

ResetItemUUID Method (Item)
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► ResetItemUUID(ItemType)
Sets or overwrites the UUID.
Declaration Syntax
C# Visual Basic Visual C++
public static void ResetItemUUID(
    ItemType Item
)
Public Shared Sub ResetItemUUID ( _
    Item As ItemType _
)
public:
static void ResetItemUUID(
    ItemType^ Item
)
Parameters
Item (ItemType)
The item to assign a universal unique identifier to.


VerifyAddItem Method

VerifyAddItem Method
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► VerifyAddItem()()()()
Members
Icon | Member | Description
 | VerifyAddItem(ItemType, Boolean, ExternalProductIDType) |
 | VerifyAddItem(ItemType) | For backward compatibility with old wrappers.
 | VerifyAddItem(ItemType, ExternalProductIDType) | For backward compatibility with old wrappers.


VerifyAddItem Method (Item)

VerifyAddItem Method (Item)
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► VerifyAddItem(ItemType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection VerifyAddItem(
    ItemType Item
)
Public Function VerifyAddItem ( _
    Item As ItemType _
) As FeeTypeCollection
public:
FeeTypeCollection^ VerifyAddItem(
    ItemType^ Item
)
Parameters
Item (ItemType)


VerifyAddItem Method (Item, ExternalProductID)

VerifyAddItem Method (Item, ExternalProductID)
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► VerifyAddItem(ItemType, ExternalProductIDType)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection VerifyAddItem(
    ItemType Item,
    ExternalProductIDType ExternalProductID
)
Public Function VerifyAddItem ( _
    Item As ItemType, _
    ExternalProductID As ExternalProductIDType _
) As FeeTypeCollection
public:
FeeTypeCollection^ VerifyAddItem(
    ItemType^ Item,
    ExternalProductIDType^ ExternalProductID
)
Parameters
Item (ItemType)
ExternalProductID (ExternalProductIDType)


VerifyAddItem Method (Item, IncludeExpressRequirements, ExternalProductID)

VerifyAddItem Method (Item, IncludeExpressRequirements, ExternalProductID)
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► VerifyAddItem(ItemType, Boolean, ExternalProductIDType)
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection VerifyAddItem(
    ItemType Item,
    bool IncludeExpressRequirements,
    ExternalProductIDType ExternalProductID
)
Public Function VerifyAddItem ( _
    Item As ItemType, _
    IncludeExpressRequirements As Boolean, _
    ExternalProductID As ExternalProductIDType _
) As FeeTypeCollection
public:
FeeTypeCollection^ VerifyAddItem(
    ItemType^ Item,
    bool IncludeExpressRequirements,
    ExternalProductIDType^ ExternalProductID
)
Parameters
Item (ItemType)
IncludeExpressRequirements (Boolean)
ExternalProductID (ExternalProductIDType)


VerifyAddItemCall Constructor

VerifyAddItemCall Constructor
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► VerifyAddItemCall()()()()
Members
Icon | Member | Description
 | VerifyAddItemCall()()()() |
 | VerifyAddItemCall(ApiContext) |


VerifyAddItemCall Constructor

VerifyAddItemCall Constructor
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► VerifyAddItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddItemCall()
Public Sub New
public:
VerifyAddItemCall()


VerifyAddItemCall Constructor (ApiContext)

VerifyAddItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► VerifyAddItemCall ► VerifyAddItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
VerifyAddItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


VerifyAddSecondChanceItemCall Class

VerifyAddSecondChanceItemCall Class
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class VerifyAddSecondChanceItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class VerifyAddSecondChanceItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class VerifyAddSecondChanceItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyAddSecondChanceItemCall()()()() |
 | VerifyAddSecondChanceItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the VerifyAddSecondChanceItemRequestType for this API call.
 | ApiResponse | Gets the VerifyAddSecondChanceItemResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | BuyItNowPrice | Gets or sets the BuyItNowPrice of type AmountType.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | Duration | Gets or sets the Duration of type SecondChanceOfferDurationCodeType.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item |
 | ItemID | Gets or sets the ItemID of type String.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | RecipientBidderUserID | Gets or sets the RecipientBidderUserID of type String.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | SellerMessage | Gets or sets the SellerMessage of type String.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | VerifyAddSecondChanceItem(String, AmountType, SecondChanceOfferDurationCodeType, String, String) | Simulates the creation of a new Second Chance Offer listing of an item without actually creating a listing.
 | VerifyAddSecondChanceItem(ItemType, String) | For backward compatibility with old wrappers.
 | VerifyAddSecondChanceItem(String, AmountType, Boolean, SecondChanceOfferDurationCodeType, String) | For backward compatibility with old wrappers.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | VerifyAddSecondChanceItemCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► ApiRequest
Gets or sets the VerifyAddSecondChanceItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddSecondChanceItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As VerifyAddSecondChanceItemRequestType
    Get
    Set
public:
property VerifyAddSecondChanceItemRequestType^ ApiRequest {
    VerifyAddSecondChanceItemRequestType^ get ();
    void set (VerifyAddSecondChanceItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► ApiResponse
Gets the VerifyAddSecondChanceItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddSecondChanceItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As VerifyAddSecondChanceItemResponseType
    Get
public:
property VerifyAddSecondChanceItemResponseType^ ApiResponse {
    VerifyAddSecondChanceItemResponseType^ get ();
}


BuyItNowPrice Property

BuyItNowPrice Property
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► BuyItNowPrice
Gets or sets the BuyItNowPrice of type AmountType.
Declaration Syntax
C# Visual Basic Visual C++
public AmountType BuyItNowPrice { get; set; }
Public Property BuyItNowPrice As AmountType
    Get
    Set
public:
property AmountType^ BuyItNowPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


Duration Property

Duration Property
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► Duration
Gets or sets the Duration of type SecondChanceOfferDurationCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public SecondChanceOfferDurationCodeType Duration { get; set; }
Public Property Duration As SecondChanceOfferDurationCodeType
    Get
    Set
public:
property SecondChanceOfferDurationCodeType Duration {
    SecondChanceOfferDurationCodeType get ();
    void set (SecondChanceOfferDurationCodeType value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► ItemID
Gets or sets the ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


RecipientBidderUserID Property

RecipientBidderUserID Property
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► RecipientBidderUserID
Gets or sets the RecipientBidderUserID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientBidderUserID { get; set; }
Public Property RecipientBidderUserID As String
    Get
    Set
public:
property String^ RecipientBidderUserID {
    String^ get ();
    void set (String^ value);
}


SellerMessage Property

SellerMessage Property
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► SellerMessage
Gets or sets the SellerMessage of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SellerMessage { get; set; }
Public Property SellerMessage As String
    Get
    Set
public:
property String^ SellerMessage {
    String^ get ();
    void set (String^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► StartTime
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}


VerifyAddSecondChanceItem Method

VerifyAddSecondChanceItem Method
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► VerifyAddSecondChanceItem()()()()
Members
Icon | Member | Description
 | VerifyAddSecondChanceItem(String, AmountType, SecondChanceOfferDurationCodeType, String, String) | Simulates the creation of a new Second Chance Offer listing of an item without actually creating a listing.
 | VerifyAddSecondChanceItem(ItemType, String) | For backward compatibility with old wrappers.
 | VerifyAddSecondChanceItem(String, AmountType, Boolean, SecondChanceOfferDurationCodeType, String) | For backward compatibility with old wrappers.


VerifyAddSecondChanceItem Method (Item, RecipientBidderUserID)

VerifyAddSecondChanceItem Method (Item, RecipientBidderUserID)
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► VerifyAddSecondChanceItem(ItemType, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void VerifyAddSecondChanceItem(
    ItemType Item,
    string RecipientBidderUserID
)
Public Sub VerifyAddSecondChanceItem ( _
    Item As ItemType, _
    RecipientBidderUserID As String _
)
public:
void VerifyAddSecondChanceItem(
    ItemType^ Item,
    String^ RecipientBidderUserID
)
Parameters
Item (ItemType)
RecipientBidderUserID (String)


VerifyAddSecondChanceItem Method (RecipientBidderUserID, BuyItNowPrice, CopyEmailToSeller, Duration, ItemID)

VerifyAddSecondChanceItem Method (RecipientBidderUserID, BuyItNowPrice, CopyEmailToSeller, Duration, ItemID)
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► VerifyAddSecondChanceItem(String, AmountType, Boolean, SecondChanceOfferDurationCodeType, String)
For backward compatibility with old wrappers.
Declaration Syntax
C# Visual Basic Visual C++
public void VerifyAddSecondChanceItem(
    string RecipientBidderUserID,
    AmountType BuyItNowPrice,
    bool CopyEmailToSeller,
    SecondChanceOfferDurationCodeType Duration,
    string ItemID
)
Public Sub VerifyAddSecondChanceItem ( _
    RecipientBidderUserID As String, _
    BuyItNowPrice As AmountType, _
    CopyEmailToSeller As Boolean, _
    Duration As SecondChanceOfferDurationCodeType, _
    ItemID As String _
)
public:
void VerifyAddSecondChanceItem(
    String^ RecipientBidderUserID,
    AmountType^ BuyItNowPrice,
    bool CopyEmailToSeller,
    SecondChanceOfferDurationCodeType Duration,
    String^ ItemID
)
Parameters
RecipientBidderUserID (String)
BuyItNowPrice (AmountType)
CopyEmailToSeller (Boolean)
Duration (SecondChanceOfferDurationCodeType)
ItemID (String)


VerifyAddSecondChanceItem Method (RecipientBidderUserID, BuyItNowPrice, Duration, ItemID, SellerMessage)

VerifyAddSecondChanceItem Method (RecipientBidderUserID, BuyItNowPrice, Duration, ItemID, SellerMessage)
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► VerifyAddSecondChanceItem(String, AmountType, SecondChanceOfferDurationCodeType, String, String)
Simulates the creation of a new Second Chance Offer listing of an item without actually creating a listing.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime VerifyAddSecondChanceItem(
    string RecipientBidderUserID,
    AmountType BuyItNowPrice,
    SecondChanceOfferDurationCodeType Duration,
    string ItemID,
    string SellerMessage
)
Public Function VerifyAddSecondChanceItem ( _
    RecipientBidderUserID As String, _
    BuyItNowPrice As AmountType, _
    Duration As SecondChanceOfferDurationCodeType, _
    ItemID As String, _
    SellerMessage As String _
) As DateTime
public:
DateTime VerifyAddSecondChanceItem(
    String^ RecipientBidderUserID,
    AmountType^ BuyItNowPrice,
    SecondChanceOfferDurationCodeType Duration,
    String^ ItemID,
    String^ SellerMessage
)
Parameters
RecipientBidderUserID (String)
Specifies the bidder from the original, ended listing to whom the seller is extending the second chance offer. Specify only one RecipientBidderUserID per call. If multiple users are specified (each in a RecipientBidderUserID node), only the last one specified receives the offer.
BuyItNowPrice (AmountType)
Specifies the amount the offer recipient must pay to purchase the item from the second chance offer listing. Use only when the original item was an eBay Motors (or in some categories on U.S. and international sites for high-priced items, such as items in many U.S. and Canada Business and Industrial categories) and it ended unsold because the reserve price was not met. Call fails with an error for any other item conditions.
Duration (SecondChanceOfferDurationCodeType)
Specifies the length of time the second chance offer listing will be active. The recipient bidder has that much time to purchase the item or the listing expires.
ItemID (String)
Specifies the item ID for the original, ended listing from which the second chance offer item comes. A new ItemID is returned for the second chance offer item.
SellerMessage (String)
Message content. Cannot contain HTML, asterisks, or quotes. This content is included in the second chance offer email sent to the recipient, which can be retrieved with GetMyMessages.


VerifyAddSecondChanceItemCall Constructor

VerifyAddSecondChanceItemCall Constructor
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► VerifyAddSecondChanceItemCall()()()()
Members
Icon | Member | Description
 | VerifyAddSecondChanceItemCall()()()() |
 | VerifyAddSecondChanceItemCall(ApiContext) |


VerifyAddSecondChanceItemCall Constructor

VerifyAddSecondChanceItemCall Constructor
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► VerifyAddSecondChanceItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddSecondChanceItemCall()
Public Sub New
public:
VerifyAddSecondChanceItemCall()


VerifyAddSecondChanceItemCall Constructor (ApiContext)

VerifyAddSecondChanceItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► VerifyAddSecondChanceItemCall ► VerifyAddSecondChanceItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddSecondChanceItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
VerifyAddSecondChanceItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


VerifyRelistItemCall Class

VerifyRelistItemCall Class
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class VerifyRelistItemCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class VerifyRelistItemCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class VerifyRelistItemCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyRelistItemCall()()()() |
 | VerifyRelistItemCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the VerifyRelistItemRequestType for this API call.
 | ApiResponse | Gets the VerifyRelistItemResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DeletedFieldList | Gets or sets the DeletedField of type StringCollection.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | DiscountReasonList | Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | EndTime | Gets the returned EndTime of type DateTime.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | FeeList | Gets the returned Fees of type FeeTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | Item | Gets or sets the Item of type ItemType.
 | ItemID | Gets the returned ItemID of type String.
 | ListingRecommendations | Gets the returned ListingRecommendations of type ListingRecommendationsType.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ProductSuggestions | Gets the returned ProductSuggestions of type ProductSuggestionsType.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | StartTime | Gets the returned StartTime of type DateTime.
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | VerifyRelistItem(ItemType, StringCollection) | Enable the seller to verify that the data they plan to pass into a RelistItem call will produce the results that you are expecting, including a successful call with no errors.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | VerifyRelistItemCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► ApiRequest
Gets or sets the VerifyRelistItemRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public VerifyRelistItemRequestType ApiRequest { get; set; }
Public Property ApiRequest As VerifyRelistItemRequestType
    Get
    Set
public:
property VerifyRelistItemRequestType^ ApiRequest {
    VerifyRelistItemRequestType^ get ();
    void set (VerifyRelistItemRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► ApiResponse
Gets the VerifyRelistItemResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public VerifyRelistItemResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As VerifyRelistItemResponseType
    Get
public:
property VerifyRelistItemResponseType^ ApiResponse {
    VerifyRelistItemResponseType^ get ();
}


DeletedFieldList Property

DeletedFieldList Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► DeletedFieldList
Gets or sets the DeletedField of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedFieldList { get; set; }
Public Property DeletedFieldList As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedFieldList {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


DiscountReasonList Property

DiscountReasonList Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► DiscountReasonList
Gets the returned DiscountReason of type DiscountReasonCodeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReasonList { get; }
Public ReadOnly Property DiscountReasonList As DiscountReasonCodeTypeCollection
    Get
public:
property DiscountReasonCodeTypeCollection^ DiscountReasonList {
    DiscountReasonCodeTypeCollection^ get ();
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► EndTime
Gets the returned EndTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; }
Public ReadOnly Property EndTime As DateTime
    Get
public:
property DateTime EndTime {
    DateTime get ();
}


FeeList Property

FeeList Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► FeeList
Gets the returned Fees of type FeeTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection FeeList { get; }
Public ReadOnly Property FeeList As FeeTypeCollection
    Get
public:
property FeeTypeCollection^ FeeList {
    FeeTypeCollection^ get ();
}


Item Property

Item Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► Item
Gets or sets the Item of type ItemType.
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► ItemID
Gets the returned ItemID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; }
Public ReadOnly Property ItemID As String
    Get
public:
property String^ ItemID {
    String^ get ();
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► ListingRecommendations
Gets the returned ListingRecommendations of type ListingRecommendationsType.
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; }
Public ReadOnly Property ListingRecommendations As ListingRecommendationsType
    Get
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► ProductSuggestions
Gets the returned ProductSuggestions of type ProductSuggestionsType.
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; }
Public ReadOnly Property ProductSuggestions As ProductSuggestionsType
    Get
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► StartTime
Gets the returned StartTime of type DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; }
Public ReadOnly Property StartTime As DateTime
    Get
public:
property DateTime StartTime {
    DateTime get ();
}


VerifyRelistItem Method (Item, DeletedFieldList)

VerifyRelistItem Method (Item, DeletedFieldList)
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► VerifyRelistItem(ItemType, StringCollection)
Enable the seller to verify that the data they plan to pass into a RelistItem call will produce the results that you are expecting, including a successful call with no errors.
Declaration Syntax
C# Visual Basic Visual C++
public string VerifyRelistItem(
    ItemType Item,
    StringCollection DeletedFieldList
)
Public Function VerifyRelistItem ( _
    Item As ItemType, _
    DeletedFieldList As StringCollection _
) As String
public:
String^ VerifyRelistItem(
    ItemType^ Item,
    StringCollection^ DeletedFieldList
)
Parameters
Item (ItemType)
Child elements hold the values for item properties that change for the relisted item. Item is a required input. At a minimum, the Item.ItemID property must be set to the ID of the listing being relisted (a listing that ended in the past 90 days). By default, the new listing's Item object properties are the same as those of the original (ended) listing. By setting a new value in the Item object, the new listing uses the new value rather than the corresponding value from the old listing.
DeletedFieldList (StringCollection)
Specifies the name of the field to delete from a listing. See the eBay Features Guide for rules on deleting values when relisting items. Also see the relevant field descriptions to determine when to use DeletedField (and potential consequences). The request can contain zero, one, or many instances of DeletedField (one for each field to be deleted). Case-sensitivity must be taken into account when using a DeletedField tag to delete a field. The value passed into a DeletedField tag must either match the case of the schema element names in the full field path (Item.PictureDetails.GalleryURL), or the initial letter of each schema element name in the full field path must be lowercase (item.pictureDetails.galleryURL). Do not change the case of letters in the middle of a field name. For example, item.picturedetails.galleryUrl is not allowed. To delete a listing enhancement like 'BoldTitle', specify the value you are deleting; for example, Item.ListingEnhancement[BoldTitle].


VerifyRelistItemCall Constructor

VerifyRelistItemCall Constructor
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► VerifyRelistItemCall()()()()
Members
Icon | Member | Description
 | VerifyRelistItemCall()()()() |
 | VerifyRelistItemCall(ApiContext) |


VerifyRelistItemCall Constructor

VerifyRelistItemCall Constructor
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► VerifyRelistItemCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyRelistItemCall()
Public Sub New
public:
VerifyRelistItemCall()


VerifyRelistItemCall Constructor (ApiContext)

VerifyRelistItemCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► VerifyRelistItemCall ► VerifyRelistItemCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public VerifyRelistItemCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
VerifyRelistItemCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


VeROReportItemsCall Class

VeROReportItemsCall Class
Namespaces ► eBay.Service.Call ► VeROReportItemsCall
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class VeROReportItemsCall : ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class VeROReportItemsCall _
    Inherits ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class VeROReportItemsCall : public ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VeROReportItemsCall()()()() |
 | VeROReportItemsCall(ApiContext) |
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests. (Inherited from ApiCall.)
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses. (Inherited from ApiCall.)
 | AfterRequest | Occurs after the API call returns the response. (Inherited from ApiCall.)
 | ApiCallBase | The base interface object.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics. (Inherited from ApiCall.)
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object. (Inherited from ApiCall.)
 | ApiRequest | Gets or sets the VeROReportItemsRequestType for this API call.
 | ApiResponse | Gets the VeROReportItemsResponseType for this API call.
 | BeforeRequest | Occurs before the API call is sent. (Inherited from ApiCall.)
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies. (Inherited from ApiCall.)
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext. (Inherited from ApiCall.)
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html (Inherited from ApiCall.)
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true. (Inherited from ApiCall.)
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance. (Inherited from ApiCall.)
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay. (Inherited from ApiCall.)
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest. (Inherited from ApiCall.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext. (Inherited from ApiCall.)
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error. (Inherited from ApiCall.)
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.) (Inherited from ApiCall.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance. (Inherited from ApiCall.)
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity. (Inherited from ApiCall.)
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage. (Inherited from ApiCall.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector | (Inherited from ApiCall.)
 | ReportItemList | Gets or sets the ReportItems of type VeROReportItemTypeCollection.
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan (Inherited from ApiCall.)
 | RightsOwnerID | Gets or sets the RightsOwnerID of type String.
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified. (Inherited from ApiCall.)
 | SoapRequest | Gets the last raw web service request of type String (Inherited from ApiCall.)
 | SoapResponse | Gets the last raw web service response of type String (Inherited from ApiCall.)
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds. (Inherited from ApiCall.)
 | ToString()()()() | (Inherited from Object.)
 | VeROReportItems(String, VeROReportItemTypeCollection) | Reports items that allegedly infringe your copyright, trademark, or other intellectual property rights. You can report one or more items at a time with this call. You must be a member of the Verified Rights Owner (VeRO) Program to use this call.
 | VeROReportPacketID | Gets the returned VeROReportPacketID of type Int64.
 | VeROReportPacketStatus | Gets the returned VeROReportPacketStatus of type VeROReportPacketStatusCodeType.
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call. (Inherited from ApiCall.)
Inheritance Hierarchy
Object
 | ApiCall
 |  | VeROReportItemsCall


ApiCallBase Property

ApiCallBase Property
Namespaces ► eBay.Service.Call ► VeROReportItemsCall ► ApiCallBase
The base interface object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall ApiCallBase { get; }
Public ReadOnly Property ApiCallBase As ApiCall
    Get
public:
property ApiCall^ ApiCallBase {
    ApiCall^ get ();
}
Remarks
This property is reserved for users who have difficulty querying multiple interfaces.


ApiRequest Property

ApiRequest Property
Namespaces ► eBay.Service.Call ► VeROReportItemsCall ► ApiRequest
Gets or sets the VeROReportItemsRequestType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemsRequestType ApiRequest { get; set; }
Public Property ApiRequest As VeROReportItemsRequestType
    Get
    Set
public:
property VeROReportItemsRequestType^ ApiRequest {
    VeROReportItemsRequestType^ get ();
    void set (VeROReportItemsRequestType^ value);
}


ApiResponse Property

ApiResponse Property
Namespaces ► eBay.Service.Call ► VeROReportItemsCall ► ApiResponse
Gets the VeROReportItemsResponseType for this API call.
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemsResponseType ApiResponse { get; }
Public ReadOnly Property ApiResponse As VeROReportItemsResponseType
    Get
public:
property VeROReportItemsResponseType^ ApiResponse {
    VeROReportItemsResponseType^ get ();
}


ReportItemList Property

ReportItemList Property
Namespaces ► eBay.Service.Call ► VeROReportItemsCall ► ReportItemList
Gets or sets the ReportItems of type VeROReportItemTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemTypeCollection ReportItemList { get; set; }
Public Property ReportItemList As VeROReportItemTypeCollection
    Get
    Set
public:
property VeROReportItemTypeCollection^ ReportItemList {
    VeROReportItemTypeCollection^ get ();
    void set (VeROReportItemTypeCollection^ value);
}


RightsOwnerID Property

RightsOwnerID Property
Namespaces ► eBay.Service.Call ► VeROReportItemsCall ► RightsOwnerID
Gets or sets the RightsOwnerID of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string RightsOwnerID { get; set; }
Public Property RightsOwnerID As String
    Get
    Set
public:
property String^ RightsOwnerID {
    String^ get ();
    void set (String^ value);
}


VeROReportItems Method (RightsOwnerID, ReportItemList)

VeROReportItems Method (RightsOwnerID, ReportItemList)
Namespaces ► eBay.Service.Call ► VeROReportItemsCall ► VeROReportItems(String, VeROReportItemTypeCollection)
Reports items that allegedly infringe your copyright, trademark, or other intellectual property rights. You can report one or more items at a time with this call. You must be a member of the Verified Rights Owner (VeRO) Program to use this call.
Declaration Syntax
C# Visual Basic Visual C++
public long VeROReportItems(
    string RightsOwnerID,
    VeROReportItemTypeCollection ReportItemList
)
Public Function VeROReportItems ( _
    RightsOwnerID As String, _
    ReportItemList As VeROReportItemTypeCollection _
) As Long
public:
long long VeROReportItems(
    String^ RightsOwnerID,
    VeROReportItemTypeCollection^ ReportItemList
)
Parameters
RightsOwnerID (String)
User ID of the VeRO member reporting the items.
ReportItemList (VeROReportItemTypeCollection)
Container (packet) for items being reported. You can report the same item more than once in a packet if a different reason code is used each time.


VeROReportItemsCall Constructor

VeROReportItemsCall Constructor
Namespaces ► eBay.Service.Call ► VeROReportItemsCall ► VeROReportItemsCall()()()()
Members
Icon | Member | Description
 | VeROReportItemsCall()()()() |
 | VeROReportItemsCall(ApiContext) |


VeROReportItemsCall Constructor

VeROReportItemsCall Constructor
Namespaces ► eBay.Service.Call ► VeROReportItemsCall ► VeROReportItemsCall()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemsCall()
Public Sub New
public:
VeROReportItemsCall()


VeROReportItemsCall Constructor (ApiContext)

VeROReportItemsCall Constructor (ApiContext)
Namespaces ► eBay.Service.Call ► VeROReportItemsCall ► VeROReportItemsCall(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemsCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
VeROReportItemsCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call of type ApiContext.


VeROReportPacketID Property

VeROReportPacketID Property
Namespaces ► eBay.Service.Call ► VeROReportItemsCall ► VeROReportPacketID
Gets the returned VeROReportPacketID of type Int64.
Declaration Syntax
C# Visual Basic Visual C++
public long VeROReportPacketID { get; }
Public ReadOnly Property VeROReportPacketID As Long
    Get
public:
property long long VeROReportPacketID {
    long long get ();
}


VeROReportPacketStatus Property

VeROReportPacketStatus Property
Namespaces ► eBay.Service.Call ► VeROReportItemsCall ► VeROReportPacketStatus
Gets the returned VeROReportPacketStatus of type VeROReportPacketStatusCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportPacketStatusCodeType VeROReportPacketStatus { get; }
Public ReadOnly Property VeROReportPacketStatus As VeROReportPacketStatusCodeType
    Get
public:
property VeROReportPacketStatusCodeType VeROReportPacketStatus {
    VeROReportPacketStatusCodeType get ();
}


eBay.Service.Core.Sdk Namespace

eBay.Service.Core.Sdk Namespace
Namespaces ► eBay.Service.Core.Sdk
Declaration Syntax
C# Visual Basic Visual C++
namespace eBay.Service.Core.Sdk
Namespace eBay.Service.Core.Sdk
namespace eBay.Service.Core.Sdk
Types
All Types Classes Delegates
Icon Type Description
AfterRequestEventArgs

AfterRequestEventHandler

ApiAccount
Optionally used to contain application ID, developer ID, and cert, formerly used by the API calls. This has now been replaced by the authorization (user) token stored in the eBayToken property. Note that if you use ApiCredential.eBayToken, the properties in the ApiAccount property are not automatically set with any ID or cert information derived from the token.

ApiCall
Base class for all eBay.Service.Call API call classes, such as AddItemCall, GetOrderCall, GeteBayDetailsCall, and so forth. Each API call object requires an ApiContext object, which is used to contain the context information needed to communicate with eBay, such as the URL, user token, and so forth. Other useful ApiCall properties and objects include Site, which you use to specify the eBay site you are using, CallRetry, which you use for retrying failed calls, and CallMetricsEntry, which you can use during development and testing to determine call performance.

ApiContext
Defines the API context in which the API call is invoked against the eBay API server. The API context object contains certain required data (ApiCredential and SoapApiServerUrl). It also contains other optional but useful properties for logging (ApiLogManager), call metrics (CallMetricsTable), call retry (CallRetry), and so forth. ApiContext is a singleton that is created and set typically before the construction of the API call wrapper objects, with the API call wrappers using the context object in their constructors.

ApiCredential
Used to store credentials needed to make API calls to the eBay API server. Normally, eBayToken (which stores the authorization token) is used rather than the older ApiAccount.

ApiException
Wraps errors which can be either client-side (e.g. validation) errors, SOAP faults, API errors, or nested HttpExceptions. ApiException extends SdkException, and is primarily used for exceptions from the API call wrapper layer (Api payload data-related). For example, you would get an ApiException if you supplied an invalid category ID in an AddItem call. You can check the HasError property of the API call wrapper to determine whether there is an ApiException, then use the call wrapper's ApiException property to return the exception object. You can then use the ApiException object properties to determine the error count, the error message, the error list, and so forth. You can also use the ApiException to trigger a call retry; for more information, see CallRetry

ApiLogManager
ApiLogManager is optional; it is used in an application if any file, console, or event logging is needed. The ApiLogManager object is set in the application's ApiContext object, logging is turned on using the EnableLogging property, and then any individual loggers are added using the ApiLoggerList Add property. Notice that the level of detail that is logged is set by the individual file, console, or event loggers that are in the logger list; the detail level is not set by the ApiLogManager. The individual loggers can be set to log error messages, and/or exceptions, and/or informational messages.

BeforeRequestEventArgs

BeforeRequestEventHandler

CallMetricsEntry
You use CallMetricsTable with the ApiContext object if you want to log all API calls. Alternatively, you could use CallMetricsEntry to simply log specific calls. To do this, you would create your API call wrapper object (for example, GetUserCall) then set its CallMetricsEntry property to an instance of the CallMetricsEntry object. Execute the call and then invoke GenerateReport(ApiLogger) on the call wrapper's CallMetricsEntry property.

CallMetricsTable
This feature is intended for development, not for deployed applications. During development, you may wish to log performance data for specific calls, in order to determine application performance before you deploy your application. The CallMetricsTable enables this. You set the CallMetricsTable object in your application's ApiContext, then set the EnableMetrics property to true. For more information on using CallMetrics, Enabling Call Metrics Logging.

CallRetry
When your application accesses the eBay platform using the SDK, errors can occur. For many types of these errors, your application should retry the call. For example, for most calls that fail due to HTTP problems, such as error 502 bad gateway, error 404, and so forth, you should retry two or three times. Similarly, API call failures, notably AddItemCall, can occur even though the request is validly constructed due to server traffic. The SDK provides an easy way to make call retries using the ApiCall class property named CallRetry. To do this, you instantiate an object of the CallRetry class and set the number of retries, the errors for which you want to retry and the interval at which you want to retry. You must retry only for errors caused on the eBay server side and not because of an error in your application, because retries will not help resolve application errors. You should normally try no more than 2 times. You should check the Error result set returned by the API call and set valid input arguments before you retry. You can retry on any of following errors:
  • API errors using TriggerErrorCodes
  • HTTP errors using TriggerHttpStatusCodes
  • .NET or SDK exception using TriggerExceptions
For details and a complete code sample, see the knowledgebase article Call Retries.

eBayAccount
Used to store eBay user ID and password, normally as credentials needed for some API calls. Normally, eBayToken is used instead for API call access.

ExceptionFilter
Exception filters are used to filter the exceptions that are to be logged using the ApiLogManager object, which is set in the ApiContext for the application. Only those exceptions specified in this filter will be logged. If the filter is not used, then all exceptions are logged.

HttpException
Wraps HTTP errors (unexpected return codes 300 - 499, 501-599) for SDK. The HTTP status code is available in the StatusCode property.

HttpWebResponseDecompressed
Summary description for HttpWebResponseDecompressed.

SdkException
SdkException is used for general exceptions related to SDK kernel itself. For example, if a token is not set the exception will be wrapped as SdkException.

TokenHardExpirationEventArgs

TokenHardExpirationWarningEventHandler


AfterRequestEventArgs Class

AfterRequestEventArgs Class
Namespaces ► eBay.Service.Core.Sdk ► AfterRequestEventArgs
Declaration Syntax
C# Visual Basic Visual C++
[ComVisibleAttribute(false)]
public class AfterRequestEventArgs : EventArgs
<ComVisibleAttribute(False)> _
Public Class AfterRequestEventArgs _
    Inherits EventArgs
[ComVisibleAttribute(false)]
public ref class AfterRequestEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AfterRequestEventArgs(AbstractResponseType) |
 | AbstractResponse | Gets the Response for this API call of type AbstractResponseType.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | AfterRequestEventArgs


AbstractResponse Property

AbstractResponse Property
Namespaces ► eBay.Service.Core.Sdk ► AfterRequestEventArgs ► AbstractResponse
Gets the Response for this API call of type AbstractResponseType.
Declaration Syntax
C# Visual Basic Visual C++
public AbstractResponseType AbstractResponse { get; }
Public ReadOnly Property AbstractResponse As AbstractResponseType
    Get
public:
property AbstractResponseType^ AbstractResponse {
    AbstractResponseType^ get ();
}


AfterRequestEventArgs Constructor (AbstractResponse)

AfterRequestEventArgs Constructor (AbstractResponse)
Namespaces ► eBay.Service.Core.Sdk ► AfterRequestEventArgs ► AfterRequestEventArgs(AbstractResponseType)
Declaration Syntax
C# Visual Basic Visual C++
public AfterRequestEventArgs(
    AbstractResponseType AbstractResponse
)
Public Sub New ( _
    AbstractResponse As AbstractResponseType _
)
public:
AfterRequestEventArgs(
    AbstractResponseType^ AbstractResponse
)
Parameters
AbstractResponse (AbstractResponseType)
The AbstractResponse for this API Call.


AfterRequestEventHandler Delegate

AfterRequestEventHandler Delegate
Namespaces ► eBay.Service.Core.Sdk ► AfterRequestEventHandler
Declaration Syntax
C# Visual Basic Visual C++
[ComVisibleAttribute(false)]
public delegate void AfterRequestEventHandler(
    Object sender,
    AfterRequestEventArgs e
)
<ComVisibleAttribute(False)> _
Public Delegate Sub AfterRequestEventHandler ( _
    sender As Object, _
    e As AfterRequestEventArgs _
)
[ComVisibleAttribute(false)]
public delegate void AfterRequestEventHandler(
    Object^ sender,
    AfterRequestEventArgs^ e
)
Parameters
sender (Object)
The source of the event.
e (AfterRequestEventArgs)
An AfterRequestEventArgs containing the event data.


ApiAccount Class

ApiAccount Class
Namespaces ► eBay.Service.Core.Sdk ► ApiAccount
Optionally used to contain application ID, developer ID, and cert, formerly used by the API calls. This has now been replaced by the authorization (user) token stored in the eBayToken property. Note that if you use ApiCredential.eBayToken, the properties in the ApiAccount property are not automatically set with any ID or cert information derived from the token.
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ApiAccount
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ApiAccount
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ApiAccount
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApiAccount()()()() |
 | ApiAccount(String, String, String) |
 | Application | Gets or sets the Application ID to use. The application ID for a developer application is manually obtained from the eBay developer account.
 | Certificate | Gets or sets the Certificate credential to use. The Certificate for a developer application is manually obtained from the eBay developer account.
 | Developer | Gets or sets the Developer ID to use. The Developer ID is manually obtained from the eBay developer account.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ApiAccount


ApiAccount Constructor

ApiAccount Constructor
Namespaces ► eBay.Service.Core.Sdk ► ApiAccount ► ApiAccount()()()()
Members
Icon | Member | Description
 | ApiAccount()()()() |
 | ApiAccount(String, String, String) |


ApiAccount Constructor

ApiAccount Constructor
Namespaces ► eBay.Service.Core.Sdk ► ApiAccount ► ApiAccount()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccount()
Public Sub New
public:
ApiAccount()


ApiAccount Constructor (Developer, Application, Certificate)

ApiAccount Constructor (Developer, Application, Certificate)
Namespaces ► eBay.Service.Core.Sdk ► ApiAccount ► ApiAccount(String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccount(
    string Developer,
    string Application,
    string Certificate
)
Public Sub New ( _
    Developer As String, _
    Application As String, _
    Certificate As String _
)
public:
ApiAccount(
    String^ Developer,
    String^ Application,
    String^ Certificate
)
Parameters
Developer (String)
The Developer credential.
Application (String)
The Application credential.
Certificate (String)
The Certificate credential.


Application Property

Application Property
Namespaces ► eBay.Service.Core.Sdk ► ApiAccount ► Application
Gets or sets the Application ID to use. The application ID for a developer application is manually obtained from the eBay developer account.
Declaration Syntax
C# Visual Basic Visual C++
public string Application { get; set; }
Public Property Application As String
    Get
    Set
public:
property String^ Application {
    String^ get ();
    void set (String^ value);
}


Certificate Property

Certificate Property
Namespaces ► eBay.Service.Core.Sdk ► ApiAccount ► Certificate
Gets or sets the Certificate credential to use. The Certificate for a developer application is manually obtained from the eBay developer account.
Declaration Syntax
C# Visual Basic Visual C++
public string Certificate { get; set; }
Public Property Certificate As String
    Get
    Set
public:
property String^ Certificate {
    String^ get ();
    void set (String^ value);
}


Developer Property

Developer Property
Namespaces ► eBay.Service.Core.Sdk ► ApiAccount ► Developer
Gets or sets the Developer ID to use. The Developer ID is manually obtained from the eBay developer account.
Declaration Syntax
C# Visual Basic Visual C++
public string Developer { get; set; }
Public Property Developer As String
    Get
    Set
public:
property String^ Developer {
    String^ get ();
    void set (String^ value);
}


ApiCall Class

ApiCall Class
Namespaces ► eBay.Service.Core.Sdk ► ApiCall
Base class for all eBay.Service.Call API call classes, such as AddItemCall, GetOrderCall, GeteBayDetailsCall, and so forth. Each API call object requires an ApiContext object, which is used to contain the context information needed to communicate with eBay, such as the URL, user token, and so forth. Other useful ApiCall properties and objects include Site, which you use to specify the eBay site you are using, CallRetry, which you use for retrying failed calls, and CallMetricsEntry, which you can use during development and testing to determine call performance.
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ApiCall
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ApiCall
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ApiCall
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApiCall()()()() | Constructor. If you use this constructor, you must subsequently set the context for this object by creating and setting properties in an ApiContext object, then set that object in the ApiCall object so it has the required context data.
 | ApiCall(ApiContext) | Constructor. Use this constructor to set the ApiContext object in the new ApiCall object.
 | AbstractRequest | Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests.
 | AbstractResponse | Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses.
 | AfterRequest | Occurs after the API call returns the response.
 | ApiContext | Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics.
 | ApiException | Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object.
 | BeforeRequest | Occurs before the API call is sent.
 | CallMetricsEntry | Holds the call metrics object used to optionally track client and server side latencies.
 | CallRetry | Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext.
 | DetailLevelList | Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html
 | DetailLevelOverride | Prevents DetailLevelList from being sent if set to true.
 | EnableCompression | Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance.
 | Equals(Object) | (Inherited from Object.)
 | Execute()()()() | Sends the Api call request AbstractRequest to eBay.
 | ExecuteRequest(AbstractRequestType) | Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSecurityHeader()()()() | Constructs a security header from values in ApiContext.
 | GetType()()()() | (Inherited from Object.)
 | HasError | Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error.
 | HasWarning | An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.)
 | InterfaceServiceType | Reserved for eBay internal use. The type to be used to create the Web Service service instance.
 | LogMessage(String, MessageType, MessageSeverity) | Log the message information under the specified type and severity.
 | LogMessagePayload(String, MessageSeverity, Exception) | Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutputSelector |
 | ResponseTime | Gets the time the API Call took to respond of type TimeSpan
 | Site | Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified.
 | SoapRequest | Gets the last raw web service request of type String
 | SoapResponse | Gets the last raw web service response of type String
 | Timeout | Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds.
 | ToString()()()() | (Inherited from Object.)
 | Version | Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call.
Inheritance Hierarchy
Object
 | ApiCall
 |  | AddDisputeCall
 |  | AddDisputeResponseCall
 |  | AddFixedPriceItemCall
 |  | AddItemCall
 |  | AddItemFromSellingManagerTemplateCall
 |  | AddItemsCall
 |  | AddMemberMessageAAQToPartnerCall
 |  | AddMemberMessageRTQCall
 |  | AddMemberMessagesAAQToBidderCall
 |  | AddOrderCall
 |  | AddSecondChanceItemCall
 |  | AddSellingManagerInventoryFolderCall
 |  | AddSellingManagerProductCall
 |  | AddSellingManagerTemplateCall
 |  | AddToItemDescriptionCall
 |  | AddToWatchListCall
 |  | AddTransactionConfirmationItemCall
 |  | CompleteSaleCall
 |  | ConfirmIdentityCall
 |  | DeleteMyMessagesCall
 |  | DeleteSellingManagerInventoryFolderCall
 |  | DeleteSellingManagerItemAutomationRuleCall
 |  | DeleteSellingManagerProductCall
 |  | DeleteSellingManagerTemplateAutomationRuleCall
 |  | DeleteSellingManagerTemplateCall
 |  | DisableUnpaidItemAssistanceCall
 |  | EndFixedPriceItemCall
 |  | EndItemCall
 |  | EndItemsCall
 |  | ExtendSiteHostedPicturesCall
 |  | FetchTokenCall
 |  | GetAccountCall
 |  | GetAdFormatLeadsCall
 |  | GetAllBiddersCall
 |  | GetApiAccessRulesCall
 |  | GetBestOffersCall
 |  | GetBidderListCall
 |  | GetCategoriesCall
 |  | GetCategoryFeaturesCall
 |  | GetCategoryMappingsCall
 |  | GetCategorySpecificsCall
 |  | GetChallengeTokenCall
 |  | GetCharitiesCall
 |  | GetClientAlertsAuthTokenCall
 |  | GetContextualKeywordsCall
 |  | GetDescriptionTemplatesCall
 |  | GetDisputeCall
 |  | GeteBayDetailsCall
 |  | GeteBayOfficialTimeCall
 |  | GetFeedbackCall
 |  | GetItemCall
 |  | GetItemsAwaitingFeedbackCall
 |  | GetItemShippingCall
 |  | GetItemTransactionsCall
 |  | GetMemberMessagesCall
 |  | GetMessagePreferencesCall
 |  | GetMyeBayBuyingCall
 |  | GetMyeBayRemindersCall
 |  | GetMyeBaySellingCall
 |  | GetMyMessagesCall
 |  | GetNotificationPreferencesCall
 |  | GetNotificationsUsageCall
 |  | GetOrdersCall
 |  | GetOrderTransactionsCall
 |  | GetPromotionalSaleDetailsCall
 |  | GetSellerDashboardCall
 |  | GetSellerEventsCall
 |  | GetSellerListCall
 |  | GetSellerPaymentsCall
 |  | GetSellerTransactionsCall
 |  | GetSellingManagerAlertsCall
 |  | GetSellingManagerEmailLogCall
 |  | GetSellingManagerInventoryCall
 |  | GetSellingManagerInventoryFolderCall
 |  | GetSellingManagerItemAutomationRuleCall
 |  | GetSellingManagerSaleRecordCall
 |  | GetSellingManagerSoldListingsCall
 |  | GetSellingManagerTemplateAutomationRuleCall
 |  | GetSellingManagerTemplatesCall
 |  | GetSessionIDCall
 |  | GetShippingDiscountProfilesCall
 |  | GetStoreCall
 |  | GetStoreCategoryUpdateStatusCall
 |  | GetStoreCustomPageCall
 |  | GetStoreOptionsCall
 |  | GetStorePreferencesCall
 |  | GetSuggestedCategoriesCall
 |  | GetTaxTableCall
 |  | GetTokenStatusCall
 |  | GetUserCall
 |  | GetUserContactDetailsCall
 |  | GetUserDisputesCall
 |  | GetUserPreferencesCall
 |  | GetVeROReasonCodeDetailsCall
 |  | GetVeROReportStatusCall
 |  | IssueRefundCall
 |  | LeaveFeedbackCall
 |  | MoveSellingManagerInventoryFolderCall
 |  | PlaceOfferCall
 |  | RelistFixedPriceItemCall
 |  | RelistItemCall
 |  | RemoveFromWatchListCall
 |  | RespondToBestOfferCall
 |  | RespondToFeedbackCall
 |  | ReviseCheckoutStatusCall
 |  | ReviseFixedPriceItemCall
 |  | ReviseInventoryStatusCall
 |  | ReviseItemCall
 |  | ReviseMyMessagesCall
 |  | ReviseMyMessagesFoldersCall
 |  | ReviseSellingManagerInventoryFolderCall
 |  | ReviseSellingManagerProductCall
 |  | ReviseSellingManagerSaleRecordCall
 |  | ReviseSellingManagerTemplateCall
 |  | RevokeTokenCall
 |  | SaveItemToSellingManagerTemplateCall
 |  | SellerReverseDisputeCall
 |  | SendInvoiceCall
 |  | SetMessagePreferencesCall
 |  | SetNotificationPreferencesCall
 |  | SetPromotionalSaleCall
 |  | SetPromotionalSaleListingsCall
 |  | SetSellingManagerFeedbackOptionsCall
 |  | SetSellingManagerItemAutomationRuleCall
 |  | SetSellingManagerTemplateAutomationRuleCall
 |  | SetShippingDiscountProfilesCall
 |  | SetStoreCall
 |  | SetStoreCategoriesCall
 |  | SetStoreCustomPageCall
 |  | SetStorePreferencesCall
 |  | SetTaxTableCall
 |  | SetUserNotesCall
 |  | SetUserPreferencesCall
 |  | ValidateChallengeInputCall
 |  | ValidateTestUserRegistrationCall
 |  | VerifyAddFixedPriceItemCall
 |  | VerifyAddItemCall
 |  | VerifyAddSecondChanceItemCall
 |  | VerifyRelistItemCall
 |  | VeROReportItemsCall


AbstractRequest Property

AbstractRequest Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► AbstractRequest
Gets or sets the Request of the call of type AbstractRequestType. The AbstractRequest is the abstract base class for all API call requests.
Declaration Syntax
C# Visual Basic Visual C++
public AbstractRequestType AbstractRequest { get; set; }
Public Property AbstractRequest As AbstractRequestType
    Get
    Set
public:
property AbstractRequestType^ AbstractRequest {
    AbstractRequestType^ get ();
    void set (AbstractRequestType^ value);
}


AbstractResponse Property

AbstractResponse Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► AbstractResponse
Gets the Response of the call of type AbstractResponseType. The AbstractResponse is the abstract base class for all API call responses.
Declaration Syntax
C# Visual Basic Visual C++
public AbstractResponseType AbstractResponse { get; }
Public ReadOnly Property AbstractResponse As AbstractResponseType
    Get
public:
property AbstractResponseType^ AbstractResponse {
    AbstractResponseType^ get ();
}


AfterRequest Event

AfterRequest Event
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► AfterRequest
Occurs after the API call returns the response.
Declaration Syntax
C# Visual Basic Visual C++
public event AfterRequestEventHandler AfterRequest
Public Event AfterRequest As AfterRequestEventHandler
public:
 event AfterRequestEventHandler^ AfterRequest {
    void add (AfterRequestEventHandler^ value);
    void remove (AfterRequestEventHandler^ value);
}


ApiCall Constructor

ApiCall Constructor
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► ApiCall()()()()
Members
Icon | Member | Description
 | ApiCall()()()() | Constructor. If you use this constructor, you must subsequently set the context for this object by creating and setting properties in an ApiContext object, then set that object in the ApiCall object so it has the required context data.
 | ApiCall(ApiContext) | Constructor. Use this constructor to set the ApiContext object in the new ApiCall object.


ApiCall Constructor

ApiCall Constructor
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► ApiCall()()()()
Constructor. If you use this constructor, you must subsequently set the context for this object by creating and setting properties in an ApiContext object, then set that object in the ApiCall object so it has the required context data.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall()
Public Sub New
public:
ApiCall()


ApiCall Constructor (ApiContext)

ApiCall Constructor (ApiContext)
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► ApiCall(ApiContext)
Constructor. Use this constructor to set the ApiContext object in the new ApiCall object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCall(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
ApiCall(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)
The ApiContext for this API Call. This object properties must be set to the ebay URL used for the Trading API, the user token, and the eBay site.


ApiContext Property

ApiContext Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► ApiContext
Gets or sets the ApiContext of the API call object. The API call object must be set with an ApiContext object containing valid URL, user token, site data, and other optional properties, such as logging and call metrics.
Declaration Syntax
C# Visual Basic Visual C++
public ApiContext ApiContext { get; set; }
Public Property ApiContext As ApiContext
    Get
    Set
public:
property ApiContext^ ApiContext {
    ApiContext^ get ();
    void set (ApiContext^ value);
}


ApiException Property

ApiException Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► ApiException
Returns the ApiException object that is created if an error occured during the API call request to the eBay API server. (If there was no error, this returns null.) The ApiException object is used for exceptions from the API call wrapper layer, which means it is API payload data-related. For example, you could get one of these exceptions if you supplied an invalid category ID in an AddItem call. In this case, the server returns a response indicating an error with an error severity of ‘Failure’, wrapped by the SDK as an ApiException object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiException ApiException { get; }
Public ReadOnly Property ApiException As ApiException
    Get
public:
property ApiException^ ApiException {
    ApiException^ get ();
}


BeforeRequest Event

BeforeRequest Event
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► BeforeRequest
Occurs before the API call is sent.
Declaration Syntax
C# Visual Basic Visual C++
public event BeforeRequestEventHandler BeforeRequest
Public Event BeforeRequest As BeforeRequestEventHandler
public:
 event BeforeRequestEventHandler^ BeforeRequest {
    void add (BeforeRequestEventHandler^ value);
    void remove (BeforeRequestEventHandler^ value);
}


CallMetricsEntry Property

CallMetricsEntry Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► CallMetricsEntry
Holds the call metrics object used to optionally track client and server side latencies.
Declaration Syntax
C# Visual Basic Visual C++
public CallMetricsEntry CallMetricsEntry { get; set; }
Public Property CallMetricsEntry As CallMetricsEntry
    Get
    Set
public:
property CallMetricsEntry^ CallMetricsEntry {
    CallMetricsEntry^ get ();
    void set (CallMetricsEntry^ value);
}


CallRetry Property

CallRetry Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► CallRetry
Gets or sets call retry of type CallRetry. The optional CallRetry object controls the behavior of failure-retry. Notice that call retry can be set in the ApiContext object to apply to all API calls, or it can be set in the API call wrapper object instead. The CallRetry object used by the API call wrapper overrides the CallRetry set in ApiContext.
Declaration Syntax
C# Visual Basic Visual C++
public CallRetry CallRetry { get; set; }
Public Property CallRetry As CallRetry
    Get
    Set
public:
property CallRetry^ CallRetry {
    CallRetry^ get ();
    void set (CallRetry^ value);
}


DetailLevelList Property

DetailLevelList Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► DetailLevelList
Gets or sets the DetailLevel of type DetailLevelCodeTypeCollection. The DetailLevel is used in some API calls that query eBay, for example, GetUserCall. The detail level specifies which data is to be returned in the query. For information on which detail levels are supported for a particular API call, refer to the eBay Trading API Call Reference http://www.developer.ebay.com/DevZone/XML/docs/Reference/eBay/index.html
Declaration Syntax
C# Visual Basic Visual C++
public DetailLevelCodeTypeCollection DetailLevelList { get; set; }
Public Property DetailLevelList As DetailLevelCodeTypeCollection
    Get
    Set
public:
property DetailLevelCodeTypeCollection^ DetailLevelList {
    DetailLevelCodeTypeCollection^ get ();
    void set (DetailLevelCodeTypeCollection^ value);
}


DetailLevelOverride Property

DetailLevelOverride Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► DetailLevelOverride
Prevents DetailLevelList from being sent if set to true.
Declaration Syntax
C# Visual Basic Visual C++
protected internal bool DetailLevelOverride { get; set; }
Protected Friend Property DetailLevelOverride As Boolean
    Get
    Set
protected public:
property bool DetailLevelOverride {
    bool get ();
    void set (bool value);
}
Remarks
This property is set to true for GetCategoriesVersion()()()().


EnableCompression Property

EnableCompression Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► EnableCompression
Set to true to ask the server to compress the response data to reduce the transfer size. By default HTTP compression is enabled to improve the performance.
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableCompression { get; set; }
Public Property EnableCompression As Boolean
    Get
    Set
public:
property bool EnableCompression {
    bool get ();
    void set (bool value);
}


Execute Method

Execute Method
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► Execute()()()()
Sends the Api call request AbstractRequest to eBay.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Execute()
Public Overridable Sub Execute
public:
virtual void Execute()
Return Value
Returns the response appropriate to the specific API call that is being Executed.


ExecuteRequest Method (Request)

ExecuteRequest Method (Request)
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► ExecuteRequest(AbstractRequestType)
Sends the Request and returns the Response. In most cases, you would use the Execute()()()() method to send the call request to eBay. The ExecuteRequest method is only used if you need to directly use the actual SOAP request object that underlies the ApiCall object to make the call (and use the actual underlying SOAP response object to receive the response). For more information, see http://ebay.custhelp.com/cgi-bin/ebay.cfg/php/enduser/std_adp.php?p_faqid=616 What is the difference between Execute and ExecuteRequest.
Declaration Syntax
C# Visual Basic Visual C++
public AbstractResponseType ExecuteRequest(
    AbstractRequestType Request
)
Public Function ExecuteRequest ( _
    Request As AbstractRequestType _
) As AbstractResponseType
public:
AbstractResponseType^ ExecuteRequest(
    AbstractRequestType^ Request
)
Parameters
Request (AbstractRequestType)
The AbstractRequestType.
Return Value
The AbstractResponseType.


GetSecurityHeader Method

GetSecurityHeader Method
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► GetSecurityHeader()()()()
Constructs a security header from values in ApiContext.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual CustomSecurityHeaderType GetSecurityHeader()
Protected Overridable Function GetSecurityHeader As CustomSecurityHeaderType
protected:
virtual CustomSecurityHeaderType^ GetSecurityHeader()
Return Value
Security information of type CustomSecurityHeaderType.


HasError Property

HasError Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► HasError
Indicates whether the API call resulted in an ApiException indicating that an error occured. If an error occurred, use the ApiException property to get the ApiException object and examine the error.
Declaration Syntax
C# Visual Basic Visual C++
public bool HasError { get; }
Public ReadOnly Property HasError As Boolean
    Get
public:
property bool HasError {
    bool get ();
}
Return Value
Returns true if the API call resulted in an ApiException. Returns false if there was no error.


HasWarning Property

HasWarning Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► HasWarning
An API call can result in a request sent successfully to the eBay API server, but yet contain an API warning in the response about some non critical issue. (You can use the ApiException property to examine the warning.)
Declaration Syntax
C# Visual Basic Visual C++
public bool HasWarning { get; }
Public ReadOnly Property HasWarning As Boolean
    Get
public:
property bool HasWarning {
    bool get ();
}
Return Value
Returns true after an API call if the response contained one or more warnings. Returns false if there are no warnings.


InterfaceServiceType Property

InterfaceServiceType Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► InterfaceServiceType
Reserved for eBay internal use. The type to be used to create the Web Service service instance.
Declaration Syntax
C# Visual Basic Visual C++
public Type InterfaceServiceType { get; set; }
Public Property InterfaceServiceType As Type
    Get
    Set
public:
property Type^ InterfaceServiceType {
    Type^ get ();
    void set (Type^ value);
}


LogMessage Method (Message, Type, Severity)

LogMessage Method (Message, Type, Severity)
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► LogMessage(String, MessageType, MessageSeverity)
Log the message information under the specified type and severity.
Declaration Syntax
C# Visual Basic Visual C++
protected internal void LogMessage(
    string Message,
    MessageType Type,
    MessageSeverity Severity
)
Protected Friend Sub LogMessage ( _
    Message As String, _
    Type As MessageType, _
    Severity As MessageSeverity _
)
protected public:
void LogMessage(
    String^ Message,
    MessageType Type,
    MessageSeverity Severity
)
Parameters
Message (String)
The content to log of type String.
Type (MessageType)
The type of message to log of type MessageType.
Severity (MessageSeverity)
The severity of the message of type MessageSeverity/


LogMessagePayload Method (Message, Severity, Ex)

LogMessagePayload Method (Message, Severity, Ex)
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► LogMessagePayload(String, MessageSeverity, Exception)
Log the message information under the specified type and severity, in the context of an exception - used for exception-based payload logging. Message type is always assumed to be ApiMessage.
Declaration Syntax
C# Visual Basic Visual C++
protected internal void LogMessagePayload(
    string Message,
    MessageSeverity Severity,
    Exception Ex
)
Protected Friend Sub LogMessagePayload ( _
    Message As String, _
    Severity As MessageSeverity, _
    Ex As Exception _
)
protected public:
void LogMessagePayload(
    String^ Message,
    MessageSeverity Severity,
    Exception^ Ex
)
Parameters
Message (String)
Severity (MessageSeverity)
Ex (Exception)


OutputSelector Property

OutputSelector Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► OutputSelector
Declaration Syntax
C# Visual Basic Visual C++
public string[] OutputSelector { get; set; }
Public Property OutputSelector As String()
    Get
    Set
public:
property array<String^>^ OutputSelector {
    array<String^>^ get ();
    void set (array<String^>^ value);
}


ResponseTime Property

ResponseTime Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► ResponseTime
Gets the time the API Call took to respond of type TimeSpan
Declaration Syntax
C# Visual Basic Visual C++
public TimeSpan ResponseTime { get; }
Public ReadOnly Property ResponseTime As TimeSpan
    Get
public:
property TimeSpan ResponseTime {
    TimeSpan get ();
}


Site Property

Site Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► Site
Gets or sets the eBay site (SiteCodeType)to be used in the API call. The site is important because the different sites support different API features, so data validation and returned data can be affected by the site value specified.
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType Site { get; set; }
Public Property Site As SiteCodeType
    Get
    Set
public:
property SiteCodeType Site {
    SiteCodeType get ();
    void set (SiteCodeType value);
}
Remarks
This property allows you to override the value set in ApiContext


SoapRequest Property

SoapRequest Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► SoapRequest
Gets the last raw web service request of type String
Declaration Syntax
C# Visual Basic Visual C++
public string SoapRequest { get; }
Public ReadOnly Property SoapRequest As String
    Get
public:
property String^ SoapRequest {
    String^ get ();
}


SoapResponse Property

SoapResponse Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► SoapResponse
Gets the last raw web service response of type String
Declaration Syntax
C# Visual Basic Visual C++
public string SoapResponse { get; }
Public ReadOnly Property SoapResponse As String
    Get
public:
property String^ SoapResponse {
    String^ get ();
}


Timeout Property

Timeout Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► Timeout
Gets or sets the Timeout value for the HTTP connection used in the API call. Time is expressed in milliseconds.
Declaration Syntax
C# Visual Basic Visual C++
public int Timeout { get; set; }
Public Property Timeout As Integer
    Get
    Set
public:
property int Timeout {
    int get ();
    void set (int value);
}
Remarks
This property allows you to override the value set in ApiContext


Version Property

Version Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCall ► Version
Gets or sets the Version for the API call. This specifies which Trading API WSDL version is to be used for the call.
Declaration Syntax
C# Visual Basic Visual C++
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
Remarks
This property allows you to override the value set in ApiContext


ApiContext Class

ApiContext Class
Namespaces ► eBay.Service.Core.Sdk ► ApiContext
Defines the API context in which the API call is invoked against the eBay API server. The API context object contains certain required data (ApiCredential and SoapApiServerUrl). It also contains other optional but useful properties for logging (ApiLogManager), call metrics (CallMetricsTable), call retry (CallRetry), and so forth. ApiContext is a singleton that is created and set typically before the construction of the API call wrapper objects, with the API call wrappers using the context object in their constructors.
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ApiContext
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ApiContext
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ApiContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApiContext()()()() | Default constructor.
 | ApiCredential | This value must be set before making API calls. Gets or sets the credentials to use for making API calls of type ApiCredential. You need to set the ApiCredential eBayToken property with a valid user token in order to make calls into eBay.
 | ApiLogManager | Gets or sets the ApiLogManager of type ApiLogManager used in the current context. If setting this property, you need to first create the ApiLogManager object, then use its ApiLoggerList property to add the loggers of type ApiLogger you wish to add. Typically, you would add a FileLogger object to write to a file log, but you could also use a ConsoleLogger or an EventLogger object.
 | CallMetricsTable | Holds a reference to a master table of call metrics for any API call made during the current session. There is normally one such table across an entire application (including multiple thread instances). To use call metrics only on a single call, use the CallMetricsEntry property on the API call wrapper object. Notice that you need to log the call metrics data, as described in the .NET SDK Getting Started guide.
 | CallRetry | Gets or sets the retry parameters of type CallRetry. When your application accesses the eBay platform using the SDK, errors can occur, such as network connection errors, an eBay server that is busy and fails to respond to the call request quickly enough, or some failure in the SDK layer itself. For many types of these failures, your application should retry the call using CallRetry. To do this, instantiate an object of the CallRetry class and set the number of retries, the errors for which you want to retry and the interval at which you want to retry.
 | CallUpdate(DateTime) | Used by the SDK to updates the last call time that an API call occured. You can find the time of the last API call simply by calling LastCallTime
 | EnableMetrics | If set to true, enables collection of data about total call latency, network latency, and server-side latency. All API calls will be tracked if you use this.
 | EPSServerUrl | Gets or sets the URL to use for uploading pictures if you are using the eBay Picture Service. Type String. If you use "self hosted images", you would not use this, but would instead supply your own host URL in the AddItemCall by setting PictureURL and or GalleryURL. For production site use the value "https://api.ebay.com/ws/api.dll" For sandbox, use the value "https://api.sandbox.ebay.com/ws/api.dll"
 | Equals(Object) | (Inherited from Object.)
 | ErrorLanguage | Gets or sets the language in which API errors will be returned. Type ErrorLanguageCodeType. By default, the errors returned are in the language used at the site you are sending the API calls to. You can change this default and have the errors returned in the language you specify here.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LastCallTime | Gets the time that the last API Call was made. Type DateTime
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RuleName | holds the rulename to use when fetching token.
 | RuName | The RuName identifies your application to eBay when you send users to the user consent flow page when using the Authentication & Authorization feature. (Developers generate RuNames in their eBay developer account.) Gets or sets the RuName. Type String.
 | SignInUrl | Gets or sets the URL where the user is directed to sign in during the Authentication & Authorization flow, as described in the Trading API Guide explanation of sign-in URL. type String.
 | Site | This value must be set before making API calls. Gets or sets the site to use when making API Calls. Type SiteCodeType. Used to specify the site you are invoking the API calls against. Features vary by site and so does validation. To determine which API call features are available for the site you wish to use, refer to the Trading API Call Reference.
 | SoapApiServerUrl | This value must be set before making any API calls. Gets or sets the URL of the eBay API server to which you send the API calls. For Sandbox use: "https://api.sandbox.ebay.com/wsapi" For production use "https://api.ebay.com/wsapi" Type String.
 | Timeout | Gets or sets the the number of milliseconds to wait before the API call times out. Type Int32.
 | ToString()()()() | (Inherited from Object.)
 | TotalCalls | Gets the total number of API calls that have been made with the current ApiContext object. Each time an API call is successfully made within the lifespan of the current ApiContext object, TotalCalls is incremented. Type Int32.
 | Version | Gets and sets version of the Trading API WSDL to be used. Type String. The Version refers to the WSDL version you want to use to make the API call; note that fields and features in the API call might or might not be available depending on the WSDL version you are using. For details, refer to the Trading API Call Reference. By default, the version is set to the version of the SDK currently being used. You can override this using this property. However, if you want to use a newer version than is supported by your SDK, you may need to do additional work. For details, see the .NET SDK Getting Started guide.
 | WebProxy | Set this if you accesss eBay API server behind a proxy server
 | XmlApiServerUrl | Gets or sets the url to use when making XML API calls of type String.
Inheritance Hierarchy
Object
ApiContext


ApiContext Constructor

ApiContext Constructor
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► ApiContext()()()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public ApiContext()
Public Sub New
public:
ApiContext()


ApiCredential Property

ApiCredential Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► ApiCredential
This value must be set before making API calls. Gets or sets the credentials to use for making API calls of type ApiCredential. You need to set the ApiCredential eBayToken property with a valid user token in order to make calls into eBay.
Declaration Syntax
C# Visual Basic Visual C++
public ApiCredential ApiCredential { get; set; }
Public Property ApiCredential As ApiCredential
    Get
    Set
public:
property ApiCredential^ ApiCredential {
    ApiCredential^ get ();
    void set (ApiCredential^ value);
}


ApiLogManager Property

ApiLogManager Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► ApiLogManager
Gets or sets the ApiLogManager of type ApiLogManager used in the current context. If setting this property, you need to first create the ApiLogManager object, then use its ApiLoggerList property to add the loggers of type ApiLogger you wish to add. Typically, you would add a FileLogger object to write to a file log, but you could also use a ConsoleLogger or an EventLogger object.
Declaration Syntax
C# Visual Basic Visual C++
public ApiLogManager ApiLogManager { get; set; }
Public Property ApiLogManager As ApiLogManager
    Get
    Set
public:
property ApiLogManager^ ApiLogManager {
    ApiLogManager^ get ();
    void set (ApiLogManager^ value);
}
Examples
This snippet shows how to add a file logger using the ApiLogManager class:
apiContext.ApiLogManager = new ApiLogManager();
            apiContext.ApiLogManager.ApiLoggerList.Add(new FileLogger("listing_log.txt", true, true, true));
            apiContext.ApiLogManager.EnableLogging = true;


CallMetricsTable Property

CallMetricsTable Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► CallMetricsTable
Holds a reference to a master table of call metrics for any API call made during the current session. There is normally one such table across an entire application (including multiple thread instances). To use call metrics only on a single call, use the CallMetricsEntry property on the API call wrapper object. Notice that you need to log the call metrics data, as described in the .NET SDK Getting Started guide.
Declaration Syntax
C# Visual Basic Visual C++
public CallMetricsTable CallMetricsTable { get; set; }
Public Property CallMetricsTable As CallMetricsTable
    Get
    Set
public:
property CallMetricsTable^ CallMetricsTable {
    CallMetricsTable^ get ();
    void set (CallMetricsTable^ value);
}


CallRetry Property

CallRetry Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► CallRetry
Gets or sets the retry parameters of type CallRetry. When your application accesses the eBay platform using the SDK, errors can occur, such as network connection errors, an eBay server that is busy and fails to respond to the call request quickly enough, or some failure in the SDK layer itself. For many types of these failures, your application should retry the call using CallRetry. To do this, instantiate an object of the CallRetry class and set the number of retries, the errors for which you want to retry and the interval at which you want to retry.
Declaration Syntax
C# Visual Basic Visual C++
public CallRetry CallRetry { get; set; }
Public Property CallRetry As CallRetry
    Get
    Set
public:
property CallRetry^ CallRetry {
    CallRetry^ get ();
    void set (CallRetry^ value);
}


CallUpdate Method (eBayTime)

CallUpdate Method (eBayTime)
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► CallUpdate(DateTime)
Used by the SDK to updates the last call time that an API call occured. You can find the time of the last API call simply by calling LastCallTime
Declaration Syntax
C# Visual Basic Visual C++
public void CallUpdate(
    DateTime eBayTime
)
Public Sub CallUpdate ( _
    eBayTime As DateTime _
)
public:
void CallUpdate(
    DateTime eBayTime
)
Parameters
eBayTime (DateTime)
The Timestamp.


EnableMetrics Property

EnableMetrics Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► EnableMetrics
If set to true, enables collection of data about total call latency, network latency, and server-side latency. All API calls will be tracked if you use this.
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableMetrics { get; set; }
Public Property EnableMetrics As Boolean
    Get
    Set
public:
property bool EnableMetrics {
    bool get ();
    void set (bool value);
}


EPSServerUrl Property

EPSServerUrl Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► EPSServerUrl
Gets or sets the URL to use for uploading pictures if you are using the eBay Picture Service. Type String. If you use "self hosted images", you would not use this, but would instead supply your own host URL in the AddItemCall by setting PictureURL and or GalleryURL. For production site use the value "https://api.ebay.com/ws/api.dll" For sandbox, use the value "https://api.sandbox.ebay.com/ws/api.dll"
Declaration Syntax
C# Visual Basic Visual C++
public string EPSServerUrl { get; set; }
Public Property EPSServerUrl As String
    Get
    Set
public:
property String^ EPSServerUrl {
    String^ get ();
    void set (String^ value);
}


ErrorLanguage Property

ErrorLanguage Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► ErrorLanguage
Gets or sets the language in which API errors will be returned. Type ErrorLanguageCodeType. By default, the errors returned are in the language used at the site you are sending the API calls to. You can change this default and have the errors returned in the language you specify here.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorLanguageCodeType ErrorLanguage { get; set; }
Public Property ErrorLanguage As ErrorLanguageCodeType
    Get
    Set
public:
property ErrorLanguageCodeType ErrorLanguage {
    ErrorLanguageCodeType get ();
    void set (ErrorLanguageCodeType value);
}


LastCallTime Property

LastCallTime Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► LastCallTime
Gets the time that the last API Call was made. Type DateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastCallTime { get; }
Public ReadOnly Property LastCallTime As DateTime
    Get
public:
property DateTime LastCallTime {
    DateTime get ();
}


RuleName Property

RuleName Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► RuleName
holds the rulename to use when fetching token.
Declaration Syntax
C# Visual Basic Visual C++
public string RuleName { get; set; }
Public Property RuleName As String
    Get
    Set
public:
property String^ RuleName {
    String^ get ();
    void set (String^ value);
}


RuName Property

RuName Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► RuName
The RuName identifies your application to eBay when you send users to the user consent flow page when using the Authentication & Authorization feature. (Developers generate RuNames in their eBay developer account.) Gets or sets the RuName. Type String.
Declaration Syntax
C# Visual Basic Visual C++
public string RuName { get; set; }
Public Property RuName As String
    Get
    Set
public:
property String^ RuName {
    String^ get ();
    void set (String^ value);
}


SignInUrl Property

SignInUrl Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► SignInUrl
Gets or sets the URL where the user is directed to sign in during the Authentication & Authorization flow, as described in the Trading API Guide explanation of sign-in URL. type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SignInUrl { get; set; }
Public Property SignInUrl As String
    Get
    Set
public:
property String^ SignInUrl {
    String^ get ();
    void set (String^ value);
}


Site Property

Site Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► Site
This value must be set before making API calls. Gets or sets the site to use when making API Calls. Type SiteCodeType. Used to specify the site you are invoking the API calls against. Features vary by site and so does validation. To determine which API call features are available for the site you wish to use, refer to the Trading API Call Reference.
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType Site { get; set; }
Public Property Site As SiteCodeType
    Get
    Set
public:
property SiteCodeType Site {
    SiteCodeType get ();
    void set (SiteCodeType value);
}


SoapApiServerUrl Property

SoapApiServerUrl Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► SoapApiServerUrl
This value must be set before making any API calls. Gets or sets the URL of the eBay API server to which you send the API calls. For Sandbox use: "https://api.sandbox.ebay.com/wsapi" For production use "https://api.ebay.com/wsapi" Type String.
Declaration Syntax
C# Visual Basic Visual C++
public string SoapApiServerUrl { get; set; }
Public Property SoapApiServerUrl As String
    Get
    Set
public:
property String^ SoapApiServerUrl {
    String^ get ();
    void set (String^ value);
}


Timeout Property

Timeout Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► Timeout
Gets or sets the the number of milliseconds to wait before the API call times out. Type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int Timeout { get; set; }
Public Property Timeout As Integer
    Get
    Set
public:
property int Timeout {
    int get ();
    void set (int value);
}


TotalCalls Property

TotalCalls Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► TotalCalls
Gets the total number of API calls that have been made with the current ApiContext object. Each time an API call is successfully made within the lifespan of the current ApiContext object, TotalCalls is incremented. Type Int32.
Declaration Syntax
C# Visual Basic Visual C++
public int TotalCalls { get; }
Public ReadOnly Property TotalCalls As Integer
    Get
public:
property int TotalCalls {
    int get ();
}


Version Property

Version Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► Version
Gets and sets version of the Trading API WSDL to be used. Type String. The Version refers to the WSDL version you want to use to make the API call; note that fields and features in the API call might or might not be available depending on the WSDL version you are using. For details, refer to the Trading API Call Reference. By default, the version is set to the version of the SDK currently being used. You can override this using this property. However, if you want to use a newer version than is supported by your SDK, you may need to do additional work. For details, see the .NET SDK Getting Started guide.
Declaration Syntax
C# Visual Basic Visual C++
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}


WebProxy Property

WebProxy Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► WebProxy
Set this if you accesss eBay API server behind a proxy server
Declaration Syntax
C# Visual Basic Visual C++
public IWebProxy WebProxy { get; set; }
Public Property WebProxy As IWebProxy
    Get
    Set
public:
property IWebProxy^ WebProxy {
    IWebProxy^ get ();
    void set (IWebProxy^ value);
}


XmlApiServerUrl Property

XmlApiServerUrl Property
Namespaces ► eBay.Service.Core.Sdk ► ApiContext ► XmlApiServerUrl
Gets or sets the url to use when making XML API calls of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string XmlApiServerUrl { get; set; }
Public Property XmlApiServerUrl As String
    Get
    Set
public:
property String^ XmlApiServerUrl {
    String^ get ();
    void set (String^ value);
}


ApiCredential Class

ApiCredential Class
Namespaces ► eBay.Service.Core.Sdk ► ApiCredential
Used to store credentials needed to make API calls to the eBay API server. Normally, eBayToken (which stores the authorization token) is used rather than the older ApiAccount.
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ApiCredential
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ApiCredential
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ApiCredential
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApiCredential()()()() |
 | ApiCredential(String) |
 | ApiAccount | Gets or sets the ApiAccount object used to store program credentials (Application, Developer, and Certificate IDs) if ApiAccount is used to supply these. This property is ignored if eBayToken is set. (Normally, eBayToken should be used instead of ApiAccount.) Type ApiAccount.
 | eBayAccount | Gets or sets the eBayAccount object used to store user credentials (eBay user id, password). This property is ignored if eBayToken is set. (Normally, eBayToken should be used instead.) Type eBayAccount.
 | eBayToken | Gets or sets the eBayToken object used to store the authorization (user) token. Type String. This token is required in order to make API calls, as it represents the user's authorization of your application to access eBay on behalf of that user. For more information on eBay authorization tokens, see Getting Tokens.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnTokenHardExpirationWarning |
 | TokenHardExpirationWarning(DateTime) | Authorization (user) tokens are valid for about 18 months, after which time they expire. This property can be read to determine when the token expires.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ApiCredential


ApiAccount Property

ApiAccount Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCredential ► ApiAccount
Gets or sets the ApiAccount object used to store program credentials (Application, Developer, and Certificate IDs) if ApiAccount is used to supply these. This property is ignored if eBayToken is set. (Normally, eBayToken should be used instead of ApiAccount.) Type ApiAccount.
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccount ApiAccount { get; set; }
Public Property ApiAccount As ApiAccount
    Get
    Set
public:
property ApiAccount^ ApiAccount {
    ApiAccount^ get ();
    void set (ApiAccount^ value);
}


ApiCredential Constructor

ApiCredential Constructor
Namespaces ► eBay.Service.Core.Sdk ► ApiCredential ► ApiCredential()()()()
Members
Icon | Member | Description
 | ApiCredential()()()() |
 | ApiCredential(String) |


ApiCredential Constructor

ApiCredential Constructor
Namespaces ► eBay.Service.Core.Sdk ► ApiCredential ► ApiCredential()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ApiCredential()
Public Sub New
public:
ApiCredential()


ApiCredential Constructor (eBayToken)

ApiCredential Constructor (eBayToken)
Namespaces ► eBay.Service.Core.Sdk ► ApiCredential ► ApiCredential(String)
Declaration Syntax
C# Visual Basic Visual C++
public ApiCredential(
    string eBayToken
)
Public Sub New ( _
    eBayToken As String _
)
public:
ApiCredential(
    String^ eBayToken
)
Parameters
eBayToken (String)
The token to use when making API calls.


eBayAccount Property

eBayAccount Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCredential ► eBayAccount
Gets or sets the eBayAccount object used to store user credentials (eBay user id, password). This property is ignored if eBayToken is set. (Normally, eBayToken should be used instead.) Type eBayAccount.
Declaration Syntax
C# Visual Basic Visual C++
public eBayAccount eBayAccount { get; set; }
Public Property eBayAccount As eBayAccount
    Get
    Set
public:
property eBayAccount^ eBayAccount {
    eBayAccount^ get ();
    void set (eBayAccount^ value);
}


eBayToken Property

eBayToken Property
Namespaces ► eBay.Service.Core.Sdk ► ApiCredential ► eBayToken
Gets or sets the eBayToken object used to store the authorization (user) token. Type String. This token is required in order to make API calls, as it represents the user's authorization of your application to access eBay on behalf of that user. For more information on eBay authorization tokens, see Getting Tokens.
Declaration Syntax
C# Visual Basic Visual C++
public string eBayToken { get; set; }
Public Property eBayToken As String
    Get
    Set
public:
property String^ eBayToken {
    String^ get ();
    void set (String^ value);
}


OnTokenHardExpirationWarning Event

OnTokenHardExpirationWarning Event
Namespaces ► eBay.Service.Core.Sdk ► ApiCredential ► OnTokenHardExpirationWarning
Declaration Syntax
C# Visual Basic Visual C++
public event TokenHardExpirationWarningEventHandler OnTokenHardExpirationWarning
Public Event OnTokenHardExpirationWarning As TokenHardExpirationWarningEventHandler
public:
 event TokenHardExpirationWarningEventHandler^ OnTokenHardExpirationWarning {
    void add (TokenHardExpirationWarningEventHandler^ value);
    void remove (TokenHardExpirationWarningEventHandler^ value);
}


TokenHardExpirationWarning Method (expirationDate)

TokenHardExpirationWarning Method (expirationDate)
Namespaces ► eBay.Service.Core.Sdk ► ApiCredential ► TokenHardExpirationWarning(DateTime)
Authorization (user) tokens are valid for about 18 months, after which time they expire. This property can be read to determine when the token expires.
Declaration Syntax
C# Visual Basic Visual C++
public void TokenHardExpirationWarning(
    DateTime expirationDate
)
Public Sub TokenHardExpirationWarning ( _
    expirationDate As DateTime _
)
public:
void TokenHardExpirationWarning(
    DateTime expirationDate
)
Parameters
expirationDate (DateTime)


ApiException Class

ApiException Class
Namespaces ► eBay.Service.Core.Sdk ► ApiException
Wraps errors which can be either client-side (e.g. validation) errors, SOAP faults, API errors, or nested HttpExceptions. ApiException extends SdkException, and is primarily used for exceptions from the API call wrapper layer (Api payload data-related). For example, you would get an ApiException if you supplied an invalid category ID in an AddItem call. You can check the HasError property of the API call wrapper to determine whether there is an ApiException, then use the call wrapper's ApiException property to return the exception object. You can then use the ApiException object properties to determine the error count, the error message, the error list, and so forth. You can also use the ApiException to trigger a call retry; for more information, see CallRetry
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ApiException : SdkException,
    ISerializable
<SerializableAttribute> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ApiException _
    Inherits SdkException _
    Implements ISerializable
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ApiException : public SdkException,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApiException()()()() | Default constructor.
 | ApiException(String) | Construct an ApiException described by the specified message.
 | ApiException(String, Exception) | Construct an ApiException wrapping the given exception, and described by the specified message.
 | ApiException(ErrorTypeCollection) | Construct an ApiException from the specified API error set (ErrorTypeCollection).
 | ApiException(SerializationInfo, StreamingContext) | Deserialize an ApiException from serialized state information.
 | containsErrorCode(String) | Returns true if the specified error code is one of the error codes belonging to this exception instance.
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | Gets the list of errors associated with this exception of type ErrorTypeCollection.
 | Finalize()()()() | (Inherited from Object.)
 | FromSoapException(SoapException) | Parses a soap fault into an ApiException.
 | FromXmlErrors(XPathNavigator) | Parses a failed xml request into an ApiException.
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Serialize an ApiException. (Overrides SdkException.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | Gets the formatted message of this exception of type String. (Overrides Exception.Message.)
 | SeverityErrorCount | Gets the number of errors associated with this exception with Error.
 | SeverityWarningCount | Gets the number of errors associated with this exception with Warning.
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | SdkException
 |  |  |  | ApiException


ApiException Constructor

ApiException Constructor
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► ApiException()()()()
Members
Icon | Member | Description
 | ApiException()()()() | Default constructor.
 | ApiException(String) | Construct an ApiException described by the specified message.
 | ApiException(String, Exception) | Construct an ApiException wrapping the given exception, and described by the specified message.
 | ApiException(ErrorTypeCollection) | Construct an ApiException from the specified API error set (ErrorTypeCollection).
 | ApiException(SerializationInfo, StreamingContext) | Deserialize an ApiException from serialized state information.


ApiException Constructor

ApiException Constructor
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► ApiException()()()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public ApiException()
Public Sub New
public:
ApiException()


ApiException Constructor (errors)

ApiException Constructor (errors)
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► ApiException(ErrorTypeCollection)
Construct an ApiException from the specified API error set (ErrorTypeCollection).
Declaration Syntax
C# Visual Basic Visual C++
public ApiException(
    ErrorTypeCollection errors
)
Public Sub New ( _
    errors As ErrorTypeCollection _
)
public:
ApiException(
    ErrorTypeCollection^ errors
)
Parameters
errors (ErrorTypeCollection)
The errors for this exception of type ErrorTypeCollection.


ApiException Constructor (info, context)

ApiException Constructor (info, context)
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► ApiException(SerializationInfo, StreamingContext)
Deserialize an ApiException from serialized state information.
Declaration Syntax
C# Visual Basic Visual C++
protected ApiException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ApiException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The object that holds the serialized object data.
context (StreamingContext)
The contextual information about the source or destination.


ApiException Constructor (message)

ApiException Constructor (message)
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► ApiException(String)
Construct an ApiException described by the specified message.
Declaration Syntax
C# Visual Basic Visual C++
public ApiException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
ApiException(
    String^ message
)
Parameters
message (String)
A message that describes the error.


ApiException Constructor (message, inner)

ApiException Constructor (message, inner)
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► ApiException(String, Exception)
Construct an ApiException wrapping the given exception, and described by the specified message.
Declaration Syntax
C# Visual Basic Visual C++
public ApiException(
    string message,
    Exception inner
)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
public:
ApiException(
    String^ message,
    Exception^ inner
)
Parameters
message (String)
A message that describes the error.
inner (Exception)
The exception that is the cause of the current exception.


containsErrorCode Method (errorcode)

containsErrorCode Method (errorcode)
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► containsErrorCode(String)
Returns true if the specified error code is one of the error codes belonging to this exception instance.
Declaration Syntax
C# Visual Basic Visual C++
public bool containsErrorCode(
    string errorcode
)
Public Function containsErrorCode ( _
    errorcode As String _
) As Boolean
public:
bool containsErrorCode(
    String^ errorcode
)
Parameters
errorcode (String)


Errors Property

Errors Property
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► Errors
Gets the list of errors associated with this exception of type ErrorTypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorTypeCollection Errors { get; }
Public ReadOnly Property Errors As ErrorTypeCollection
    Get
public:
property ErrorTypeCollection^ Errors {
    ErrorTypeCollection^ get ();
}


FromSoapException Method (soapex)

FromSoapException Method (soapex)
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► FromSoapException(SoapException)
Parses a soap fault into an ApiException.
Declaration Syntax
C# Visual Basic Visual C++
public static ApiException FromSoapException(
    SoapException soapex
)
Public Shared Function FromSoapException ( _
    soapex As SoapException _
) As ApiException
public:
static ApiException^ FromSoapException(
    SoapException^ soapex
)
Parameters
soapex (SoapException)
The SoapException.
Return Value
The ApiException.


FromXmlErrors Method (nav)

FromXmlErrors Method (nav)
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► FromXmlErrors(XPathNavigator)
Parses a failed xml request into an ApiException.
Declaration Syntax
C# Visual Basic Visual C++
public static ApiException FromXmlErrors(
    XPathNavigator nav
)
Public Shared Function FromXmlErrors ( _
    nav As XPathNavigator _
) As ApiException
public:
static ApiException^ FromXmlErrors(
    XPathNavigator^ nav
)
Parameters
nav (XPathNavigator)
The XPath navigator for the XML response.
Return Value
The ApiException.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► GetObjectData(SerializationInfo, StreamingContext)
Serialize an ApiException.
Declaration Syntax
C# Visual Basic Visual C++
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
[SecurityPermissionAttribute(SecurityAction::Demand, SerializationFormatter = true)]
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.


Message Property

Message Property
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► Message
Gets the formatted message of this exception of type String.
Declaration Syntax
C# Visual Basic Visual C++
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}


SeverityErrorCount Property

SeverityErrorCount Property
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► SeverityErrorCount
Gets the number of errors associated with this exception with Error.
Declaration Syntax
C# Visual Basic Visual C++
public int SeverityErrorCount { get; }
Public ReadOnly Property SeverityErrorCount As Integer
    Get
public:
property int SeverityErrorCount {
    int get ();
}


SeverityWarningCount Property

SeverityWarningCount Property
Namespaces ► eBay.Service.Core.Sdk ► ApiException ► SeverityWarningCount
Gets the number of errors associated with this exception with Warning.
Declaration Syntax
C# Visual Basic Visual C++
public int SeverityWarningCount { get; }
Public ReadOnly Property SeverityWarningCount As Integer
    Get
public:
property int SeverityWarningCount {
    int get ();
}


ApiLogManager Class

ApiLogManager Class
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager
ApiLogManager is optional; it is used in an application if any file, console, or event logging is needed. The ApiLogManager object is set in the application's ApiContext object, logging is turned on using the EnableLogging property, and then any individual loggers are added using the ApiLoggerList Add property. Notice that the level of detail that is logged is set by the individual file, console, or event loggers that are in the logger list; the detail level is not set by the ApiLogManager. The individual loggers can be set to log error messages, and/or exceptions, and/or informational messages.
Declaration Syntax
C# Visual Basic Visual C++
public class ApiLogManager
Public Class ApiLogManager
public ref class ApiLogManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApiLogManager()()()() |
 | ApiLogManager(ApiLoggerCollection) |
 | ApiLoggerList | Gets or sets the list of loggers to be used in the ApiLogManager. Type ApiLoggerCollection. The individual file, console, or event loggers are added to this list using ApiLoggerList Add.
 | EnableLogging | If used as a getter, indicates whether logging is enabled (true) or not enabled (false). If used as a setter, a value of true enables logging, a value of false disables logging.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LogApiMessages | Get only - returns true if any logger is enabling message logging. The enabling (or not) of this feature for each invidual logger is done in the logger constructor.
 | LogExceptions | Get only - returns true if any logger is enabling logging of exception message strings. The enabling (or not) of this feature for each invidual logger is done in the logger constructor.
 | LogInformation | Get only - returns true if any logger is enabling information logging. The enabling (or not) of this feature for each invidual logger is done in the logger constructor.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageLoggingFilter | Gets or sets a global message logging filter. If this is set, all loggers will perform message logging
 | RecordMessage(String) |
 | RecordMessage(String, MessageType, MessageSeverity) | Log a message to all loggers enabled for this type of message.
 | RecordPayloadOnException(String, MessageType, MessageSeverity, Exception) | Used only for exception-based payload logging; variation of RecordMessage which takes an exception parameter. Calls RecordMessage if no exception is supplied, or if this is not an ApiMessage (i.e. payload message), or if no MessageLoggingFilter property is configured on the log manager. Otherwise, the exception logic is applied: the method will continue calling RecordMessage only if the exception matches the configured MessageLoggingFilter property.
 | ToString()()()() | (Inherited from Object.)
Examples
This snippet shows how to add a file logger using the ApiLogManager class, with everything logged, error messages, exceptions, and informational messages:
            apiContext.ApiLogManager = new ApiLogManager();
            apiContext.ApiLogManager.ApiLoggerList.Add(new FileLogger("listing_log.txt", true, true, true));
            apiContext.ApiLogManager.EnableLogging = true;
Inheritance Hierarchy
Object
ApiLogManager


ApiLoggerList Property

ApiLoggerList Property
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► ApiLoggerList
Gets or sets the list of loggers to be used in the ApiLogManager. Type ApiLoggerCollection. The individual file, console, or event loggers are added to this list using ApiLoggerList Add.
Declaration Syntax
C# Visual Basic Visual C++
public ApiLoggerCollection ApiLoggerList { get; set; }
Public Property ApiLoggerList As ApiLoggerCollection
    Get
    Set
public:
property ApiLoggerCollection^ ApiLoggerList {
    ApiLoggerCollection^ get ();
    void set (ApiLoggerCollection^ value);
}


ApiLogManager Constructor

ApiLogManager Constructor
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► ApiLogManager()()()()
Members
Icon | Member | Description
 | ApiLogManager()()()() |
 | ApiLogManager(ApiLoggerCollection) |


ApiLogManager Constructor

ApiLogManager Constructor
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► ApiLogManager()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ApiLogManager()
Public Sub New
public:
ApiLogManager()


ApiLogManager Constructor (ApiLoggerList)

ApiLogManager Constructor (ApiLoggerList)
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► ApiLogManager(ApiLoggerCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ApiLogManager(
    ApiLoggerCollection ApiLoggerList
)
Public Sub New ( _
    ApiLoggerList As ApiLoggerCollection _
)
public:
ApiLogManager(
    ApiLoggerCollection^ ApiLoggerList
)
Parameters
ApiLoggerList (ApiLoggerCollection)


EnableLogging Property

EnableLogging Property
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► EnableLogging
If used as a getter, indicates whether logging is enabled (true) or not enabled (false). If used as a setter, a value of true enables logging, a value of false disables logging.
Declaration Syntax
C# Visual Basic Visual C++
public bool EnableLogging { get; set; }
Public Property EnableLogging As Boolean
    Get
    Set
public:
property bool EnableLogging {
    bool get ();
    void set (bool value);
}


LogApiMessages Property

LogApiMessages Property
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► LogApiMessages
Get only - returns true if any logger is enabling message logging. The enabling (or not) of this feature for each invidual logger is done in the logger constructor.
Declaration Syntax
C# Visual Basic Visual C++
public bool LogApiMessages { get; }
Public ReadOnly Property LogApiMessages As Boolean
    Get
public:
property bool LogApiMessages {
    bool get ();
}


LogExceptions Property

LogExceptions Property
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► LogExceptions
Get only - returns true if any logger is enabling logging of exception message strings. The enabling (or not) of this feature for each invidual logger is done in the logger constructor.
Declaration Syntax
C# Visual Basic Visual C++
public bool LogExceptions { get; }
Public ReadOnly Property LogExceptions As Boolean
    Get
public:
property bool LogExceptions {
    bool get ();
}


LogInformation Property

LogInformation Property
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► LogInformation
Get only - returns true if any logger is enabling information logging. The enabling (or not) of this feature for each invidual logger is done in the logger constructor.
Declaration Syntax
C# Visual Basic Visual C++
public bool LogInformation { get; }
Public ReadOnly Property LogInformation As Boolean
    Get
public:
property bool LogInformation {
    bool get ();
}


MessageLoggingFilter Property

MessageLoggingFilter Property
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► MessageLoggingFilter
Gets or sets a global message logging filter. If this is set, all loggers will perform message logging
Declaration Syntax
C# Visual Basic Visual C++
public ExceptionFilter MessageLoggingFilter { get; set; }
Public Property MessageLoggingFilter As ExceptionFilter
    Get
    Set
public:
property ExceptionFilter^ MessageLoggingFilter {
    ExceptionFilter^ get ();
    void set (ExceptionFilter^ value);
}


RecordMessage Method

RecordMessage Method
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► RecordMessage()()()()
Members
Icon | Member | Description
 | RecordMessage(String) |
 | RecordMessage(String, MessageType, MessageSeverity) | Log a message to all loggers enabled for this type of message.


RecordMessage Method (Message)

RecordMessage Method (Message)
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► RecordMessage(String)
Declaration Syntax
C# Visual Basic Visual C++
public void RecordMessage(
    string Message
)
Public Sub RecordMessage ( _
    Message As String _
)
public:
void RecordMessage(
    String^ Message
)
Parameters
Message (String)


RecordMessage Method (Message, Type, Severity)

RecordMessage Method (Message, Type, Severity)
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► RecordMessage(String, MessageType, MessageSeverity)
Log a message to all loggers enabled for this type of message.
Declaration Syntax
C# Visual Basic Visual C++
public void RecordMessage(
    string Message,
    MessageType Type,
    MessageSeverity Severity
)
Public Sub RecordMessage ( _
    Message As String, _
    Type As MessageType, _
    Severity As MessageSeverity _
)
public:
void RecordMessage(
    String^ Message,
    MessageType Type,
    MessageSeverity Severity
)
Parameters
Message (String)
Type (MessageType)
Severity (MessageSeverity)


RecordPayloadOnException Method (Message, Type, Severity, Ex)

RecordPayloadOnException Method (Message, Type, Severity, Ex)
Namespaces ► eBay.Service.Core.Sdk ► ApiLogManager ► RecordPayloadOnException(String, MessageType, MessageSeverity, Exception)
Used only for exception-based payload logging; variation of RecordMessage which takes an exception parameter. Calls RecordMessage if no exception is supplied, or if this is not an ApiMessage (i.e. payload message), or if no MessageLoggingFilter property is configured on the log manager. Otherwise, the exception logic is applied: the method will continue calling RecordMessage only if the exception matches the configured MessageLoggingFilter property.
Declaration Syntax
C# Visual Basic Visual C++
public void RecordPayloadOnException(
    string Message,
    MessageType Type,
    MessageSeverity Severity,
    Exception Ex
)
Public Sub RecordPayloadOnException ( _
    Message As String, _
    Type As MessageType, _
    Severity As MessageSeverity, _
    Ex As Exception _
)
public:
void RecordPayloadOnException(
    String^ Message,
    MessageType Type,
    MessageSeverity Severity,
    Exception^ Ex
)
Parameters
Message (String)
Type (MessageType)
Severity (MessageSeverity)
Ex (Exception)


BeforeRequestEventArgs Class

BeforeRequestEventArgs Class
Namespaces ► eBay.Service.Core.Sdk ► BeforeRequestEventArgs
Declaration Syntax
C# Visual Basic Visual C++
[ComVisibleAttribute(false)]
public class BeforeRequestEventArgs : EventArgs
<ComVisibleAttribute(False)> _
Public Class BeforeRequestEventArgs _
    Inherits EventArgs
[ComVisibleAttribute(false)]
public ref class BeforeRequestEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BeforeRequestEventArgs(AbstractRequestType) |
 | AbstractRequest | Gets or sets the Request for this API call of type AbstractRequestType.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | BeforeRequestEventArgs


AbstractRequest Property

AbstractRequest Property
Namespaces ► eBay.Service.Core.Sdk ► BeforeRequestEventArgs ► AbstractRequest
Gets or sets the Request for this API call of type AbstractRequestType.
Declaration Syntax
C# Visual Basic Visual C++
public AbstractRequestType AbstractRequest { get; set; }
Public Property AbstractRequest As AbstractRequestType
    Get
    Set
public:
property AbstractRequestType^ AbstractRequest {
    AbstractRequestType^ get ();
    void set (AbstractRequestType^ value);
}


BeforeRequestEventArgs Constructor (AbstractRequest)

BeforeRequestEventArgs Constructor (AbstractRequest)
Namespaces ► eBay.Service.Core.Sdk ► BeforeRequestEventArgs ► BeforeRequestEventArgs(AbstractRequestType)
Declaration Syntax
C# Visual Basic Visual C++
public BeforeRequestEventArgs(
    AbstractRequestType AbstractRequest
)
Public Sub New ( _
    AbstractRequest As AbstractRequestType _
)
public:
BeforeRequestEventArgs(
    AbstractRequestType^ AbstractRequest
)
Parameters
AbstractRequest (AbstractRequestType)
The AbstractRequest for this API Call.


BeforeRequestEventHandler Delegate

BeforeRequestEventHandler Delegate
Namespaces ► eBay.Service.Core.Sdk ► BeforeRequestEventHandler
Declaration Syntax
C# Visual Basic Visual C++
[ComVisibleAttribute(false)]
public delegate void BeforeRequestEventHandler(
    Object sender,
    BeforeRequestEventArgs e
)
<ComVisibleAttribute(False)> _
Public Delegate Sub BeforeRequestEventHandler ( _
    sender As Object, _
    e As BeforeRequestEventArgs _
)
[ComVisibleAttribute(false)]
public delegate void BeforeRequestEventHandler(
    Object^ sender,
    BeforeRequestEventArgs^ e
)
Parameters
sender (Object)
The source of the event.
e (BeforeRequestEventArgs)
An BeforeRequestEventArgs containing the event data.


CallMetricsEntry Class

CallMetricsEntry Class
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry
You use CallMetricsTable with the ApiContext object if you want to log all API calls. Alternatively, you could use CallMetricsEntry to simply log specific calls. To do this, you would create your API call wrapper object (for example, GetUserCall) then set its CallMetricsEntry property to an instance of the CallMetricsEntry object. Execute the call and then invoke GenerateReport(ApiLogger) on the call wrapper's CallMetricsEntry property.
Declaration Syntax
C# Visual Basic Visual C++
public class CallMetricsEntry
Public Class CallMetricsEntry
public ref class CallMetricsEntry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CallMetricsEntry()()()() | Default constructor.
 | CallMetricsEntry(String) | Initialize and set API call name on the entry so that it is ready to accumulate metrics..
 | ApiCallEnded | The time at which the ApiCall object finished issuing the call (end of SendRequest()).
 | ApiCallStarted | The time at which the ApiCall object began setting up and issuing the call (beginning of SendRequest()).
 | CallFinishTime | Time spent in decompression, deserialization, and final processing, after receiving the response (ApiCallEnded - NetworkReceiveEnded).
 | CallInitTime | Time spent in setup, serialization, and/or compression before sending the request (NetworkSendStarted - ApiCallStarted).
 | CallName | The name of the call currently being tracked.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatMsec(DateTime) |
 | FormatNumber(Int64) |
 | FormatString(String, Int32) |
 | GenerateReport(ApiLogger) | Generates the call metrics information about the API call that was made.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Initialize(String) |
 | logger | Reference to the logger to be used for recording data.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NetworkAndServerTime | Time spent between send and receive, equal to the combination of transmission and server processing time (NetworkReceiveEnded - NetworkSendStarted).
 | NetworkReceiveEnded | The time at which a response message was received from the network and became ready to deserialize.
 | NetworkSendStarted | The time at which the serialized request message bgan to be sent over the network.
 | NetworkTime |
 | ServerProcessingTime | The server-side processing time reported by the eBay server.
 | ToString()()()() | (Inherited from Object.)
 | TurnaroundTime | Total time spent in ApiCall processing (ApiCallEnded - ApiCallStarted).
 | UpdateTotals(array<Int64>[]()[][]) |
Examples
The following snippet shows how to set up the use of the CallMetricsEntry:
            GetUserCall apiCall = new GetUserCall(apiContext);
            apiCall.CallMetricsEntry = new CallMetricsEntry();
            apiCall.DetailLevelList.Add(DetailLevelCodeType.ReturnAll);
            apiCall.Execute();
            piLogger MyLog = new FileLogger("entry_log.txt", true, true, true);
            apiCall.CallMetricsEntry.GenerateReport(MyLog);
Inheritance Hierarchy
Object
CallMetricsEntry


ApiCallEnded Property

ApiCallEnded Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► ApiCallEnded
The time at which the ApiCall object finished issuing the call (end of SendRequest()).
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ApiCallEnded { get; set; }
Public Property ApiCallEnded As DateTime
    Get
    Set
public:
property DateTime ApiCallEnded {
    DateTime get ();
    void set (DateTime value);
}


ApiCallStarted Property

ApiCallStarted Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► ApiCallStarted
The time at which the ApiCall object began setting up and issuing the call (beginning of SendRequest()).
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ApiCallStarted { get; set; }
Public Property ApiCallStarted As DateTime
    Get
    Set
public:
property DateTime ApiCallStarted {
    DateTime get ();
    void set (DateTime value);
}


CallFinishTime Property

CallFinishTime Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► CallFinishTime
Time spent in decompression, deserialization, and final processing, after receiving the response (ApiCallEnded - NetworkReceiveEnded).
Declaration Syntax
C# Visual Basic Visual C++
public long CallFinishTime { get; }
Public ReadOnly Property CallFinishTime As Long
    Get
public:
property long long CallFinishTime {
    long long get ();
}


CallInitTime Property

CallInitTime Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► CallInitTime
Time spent in setup, serialization, and/or compression before sending the request (NetworkSendStarted - ApiCallStarted).
Declaration Syntax
C# Visual Basic Visual C++
public long CallInitTime { get; }
Public ReadOnly Property CallInitTime As Long
    Get
public:
property long long CallInitTime {
    long long get ();
}


CallMetricsEntry Constructor

CallMetricsEntry Constructor
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► CallMetricsEntry()()()()
Members
Icon | Member | Description
 | CallMetricsEntry()()()() | Default constructor.
 | CallMetricsEntry(String) | Initialize and set API call name on the entry so that it is ready to accumulate metrics..


CallMetricsEntry Constructor

CallMetricsEntry Constructor
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► CallMetricsEntry()()()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public CallMetricsEntry()
Public Sub New
public:
CallMetricsEntry()


CallMetricsEntry Constructor (callname)

CallMetricsEntry Constructor (callname)
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► CallMetricsEntry(String)
Initialize and set API call name on the entry so that it is ready to accumulate metrics..
Declaration Syntax
C# Visual Basic Visual C++
public CallMetricsEntry(
    string callname
)
Public Sub New ( _
    callname As String _
)
public:
CallMetricsEntry(
    String^ callname
)
Parameters
callname (String)


CallName Property

CallName Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► CallName
The name of the call currently being tracked.
Declaration Syntax
C# Visual Basic Visual C++
public string CallName { get; set; }
Public Property CallName As String
    Get
    Set
public:
property String^ CallName {
    String^ get ();
    void set (String^ value);
}


FormatMsec Method (d)

FormatMsec Method (d)
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► FormatMsec(DateTime)
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatMsec(
    DateTime d
)
Public Shared Function FormatMsec ( _
    d As DateTime _
) As String
public:
static String^ FormatMsec(
    DateTime d
)
Parameters
d (DateTime)
Return Value


FormatNumber Method (n)

FormatNumber Method (n)
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► FormatNumber(Int64)
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatNumber(
    long n
)
Public Shared Function FormatNumber ( _
    n As Long _
) As String
public:
static String^ FormatNumber(
    long long n
)
Parameters
n (Int64)


FormatString Method (str, width)

FormatString Method (str, width)
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► FormatString(String, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatString(
    string str,
    int width
)
Public Shared Function FormatString ( _
    str As String, _
    width As Integer _
) As String
public:
static String^ FormatString(
    String^ str,
    int width
)
Parameters
str (String)
width (Int32)


GenerateReport Method (logger)

GenerateReport Method (logger)
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► GenerateReport(ApiLogger)
Generates the call metrics information about the API call that was made.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateReport(
    ApiLogger logger
)
Public Sub GenerateReport ( _
    logger As ApiLogger _
)
public:
void GenerateReport(
    ApiLogger^ logger
)
Parameters
logger (ApiLogger)


Initialize Method (name)

Initialize Method (name)
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► Initialize(String)
Declaration Syntax
C# Visual Basic Visual C++
public void Initialize(
    string name
)
Public Sub Initialize ( _
    name As String _
)
public:
void Initialize(
    String^ name
)
Parameters
name (String)


logger Property

logger Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► logger
Reference to the logger to be used for recording data.
Declaration Syntax
C# Visual Basic Visual C++
public static ApiLogger logger { get; set; }
Public Shared Property logger As ApiLogger
    Get
    Set
public:
static property ApiLogger^ logger {
    ApiLogger^ get ();
    void set (ApiLogger^ value);
}


NetworkAndServerTime Property

NetworkAndServerTime Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► NetworkAndServerTime
Time spent between send and receive, equal to the combination of transmission and server processing time (NetworkReceiveEnded - NetworkSendStarted).
Declaration Syntax
C# Visual Basic Visual C++
public long NetworkAndServerTime { get; }
Public ReadOnly Property NetworkAndServerTime As Long
    Get
public:
property long long NetworkAndServerTime {
    long long get ();
}


NetworkReceiveEnded Property

NetworkReceiveEnded Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► NetworkReceiveEnded
The time at which a response message was received from the network and became ready to deserialize.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime NetworkReceiveEnded { get; set; }
Public Property NetworkReceiveEnded As DateTime
    Get
    Set
public:
property DateTime NetworkReceiveEnded {
    DateTime get ();
    void set (DateTime value);
}


NetworkSendStarted Property

NetworkSendStarted Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► NetworkSendStarted
The time at which the serialized request message bgan to be sent over the network.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime NetworkSendStarted { get; set; }
Public Property NetworkSendStarted As DateTime
    Get
    Set
public:
property DateTime NetworkSendStarted {
    DateTime get ();
    void set (DateTime value);
}


NetworkTime Property

NetworkTime Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► NetworkTime
Declaration Syntax
C# Visual Basic Visual C++
public long NetworkTime { get; }
Public ReadOnly Property NetworkTime As Long
    Get
public:
property long long NetworkTime {
    long long get ();
}


ServerProcessingTime Property

ServerProcessingTime Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► ServerProcessingTime
The server-side processing time reported by the eBay server.
Declaration Syntax
C# Visual Basic Visual C++
public long ServerProcessingTime { get; set; }
Public Property ServerProcessingTime As Long
    Get
    Set
public:
property long long ServerProcessingTime {
    long long get ();
    void set (long long value);
}


TurnaroundTime Property

TurnaroundTime Property
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► TurnaroundTime
Total time spent in ApiCall processing (ApiCallEnded - ApiCallStarted).
Declaration Syntax
C# Visual Basic Visual C++
public long TurnaroundTime { get; }
Public ReadOnly Property TurnaroundTime As Long
    Get
public:
property long long TurnaroundTime {
    long long get ();
}


UpdateTotals Method (totals)

UpdateTotals Method (totals)
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsEntry ► UpdateTotals(array<Int64>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateTotals(
    long[] totals
)
Public Sub UpdateTotals ( _
    totals As Long() _
)
public:
void UpdateTotals(
    array<long long>^ totals
)
Parameters
totals (array< Int64 >[]()[][])


CallMetricsTable Class

CallMetricsTable Class
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsTable
This feature is intended for development, not for deployed applications. During development, you may wish to log performance data for specific calls, in order to determine application performance before you deploy your application. The CallMetricsTable enables this. You set the CallMetricsTable object in your application's ApiContext, then set the EnableMetrics property to true. For more information on using CallMetrics, Enabling Call Metrics Logging.
Declaration Syntax
C# Visual Basic Visual C++
public class CallMetricsTable
Public Class CallMetricsTable
public ref class CallMetricsTable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CallMetricsTable()()()() | Default constructor.
 | AddCallMetrics(CallMetricsEntry) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GenerateReport(ApiLogger) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetNewEntry(String) |
 | GetType()()()() | (Inherited from Object.)
 | Log(String) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CallMetricsTable


AddCallMetrics Method (metrics)

AddCallMetrics Method (metrics)
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsTable ► AddCallMetrics(CallMetricsEntry)
Declaration Syntax
C# Visual Basic Visual C++
public void AddCallMetrics(
    CallMetricsEntry metrics
)
Public Sub AddCallMetrics ( _
    metrics As CallMetricsEntry _
)
public:
void AddCallMetrics(
    CallMetricsEntry^ metrics
)
Parameters
metrics (CallMetricsEntry)


CallMetricsTable Constructor

CallMetricsTable Constructor
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsTable ► CallMetricsTable()()()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public CallMetricsTable()
Public Sub New
public:
CallMetricsTable()


GenerateReport Method (logger)

GenerateReport Method (logger)
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsTable ► GenerateReport(ApiLogger)
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateReport(
    ApiLogger logger
)
Public Sub GenerateReport ( _
    logger As ApiLogger _
)
public:
void GenerateReport(
    ApiLogger^ logger
)
Parameters
logger (ApiLogger)


GetNewEntry Method (callname)

GetNewEntry Method (callname)
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsTable ► GetNewEntry(String)
Declaration Syntax
C# Visual Basic Visual C++
public CallMetricsEntry GetNewEntry(
    string callname
)
Public Function GetNewEntry ( _
    callname As String _
) As CallMetricsEntry
public:
CallMetricsEntry^ GetNewEntry(
    String^ callname
)
Parameters
callname (String)
Return Value


Log Method (str)

Log Method (str)
Namespaces ► eBay.Service.Core.Sdk ► CallMetricsTable ► Log(String)
Declaration Syntax
C# Visual Basic Visual C++
public void Log(
    string str
)
Public Sub Log ( _
    str As String _
)
public:
void Log(
    String^ str
)
Parameters
str (String)


CallRetry Class

CallRetry Class
Namespaces ► eBay.Service.Core.Sdk ► CallRetry
When your application accesses the eBay platform using the SDK, errors can occur. For many types of these errors, your application should retry the call. For example, for most calls that fail due to HTTP problems, such as error 502 bad gateway, error 404, and so forth, you should retry two or three times. Similarly, API call failures, notably AddItemCall, can occur even though the request is validly constructed due to server traffic. The SDK provides an easy way to make call retries using the ApiCall class property named CallRetry. To do this, you instantiate an object of the CallRetry class and set the number of retries, the errors for which you want to retry and the interval at which you want to retry. You must retry only for errors caused on the eBay server side and not because of an error in your application, because retries will not help resolve application errors. You should normally try no more than 2 times. You should check the Error result set returned by the API call and set valid input arguments before you retry. You can retry on any of following errors:
  • API errors using TriggerErrorCodes
  • HTTP errors using TriggerHttpStatusCodes
  • .NET or SDK exception using TriggerExceptions
For details and a complete code sample, see the knowledgebase article Call Retries.
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class CallRetry
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class CallRetry
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class CallRetry
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CallRetry()()()() |
 | DelayTime | Time to wait between retries.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MaximumRetries | Maximum number of times to retry.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShouldRetry(Exception) | Determines if a retry should be invoked based on an exception that occured.
 | ToString()()()() | (Inherited from Object.)
 | TriggerErrorCodes | If using the getter, this gets the error codes that will result in a retry. Type StringCollection. If using the setter, this specifies the error codes that are to cause a retry.
 | TriggerExceptions | If using the getter, this gets the exceptions that will result in a retry. Type TypeCollection.. If using the setter, this specifies the exceptions that are to cause a retry.
 | TriggerHttpStatusCodes | If using the getter, this gets the status codes that will result in a retry. Type StringCollection. If using the setter, this specifies the status codes that are to cause a retry.
Inheritance Hierarchy
Object
CallRetry


CallRetry Constructor

CallRetry Constructor
Namespaces ► eBay.Service.Core.Sdk ► CallRetry ► CallRetry()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CallRetry()
Public Sub New
public:
CallRetry()


DelayTime Property

DelayTime Property
Namespaces ► eBay.Service.Core.Sdk ► CallRetry ► DelayTime
Time to wait between retries.
Declaration Syntax
C# Visual Basic Visual C++
public int DelayTime { get; set; }
Public Property DelayTime As Integer
    Get
    Set
public:
property int DelayTime {
    int get ();
    void set (int value);
}


MaximumRetries Property

MaximumRetries Property
Namespaces ► eBay.Service.Core.Sdk ► CallRetry ► MaximumRetries
Maximum number of times to retry.
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumRetries { get; set; }
Public Property MaximumRetries As Integer
    Get
    Set
public:
property int MaximumRetries {
    int get ();
    void set (int value);
}


ShouldRetry Method (ex)

ShouldRetry Method (ex)
Namespaces ► eBay.Service.Core.Sdk ► CallRetry ► ShouldRetry(Exception)
Determines if a retry should be invoked based on an exception that occured.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShouldRetry(
    Exception ex
)
Public Function ShouldRetry ( _
    ex As Exception _
) As Boolean
public:
bool ShouldRetry(
    Exception^ ex
)
Parameters
ex (Exception)
The Exception to test for retry.
Return Value
Returns true if retry should be invoked, else false


TriggerErrorCodes Property

TriggerErrorCodes Property
Namespaces ► eBay.Service.Core.Sdk ► CallRetry ► TriggerErrorCodes
If using the getter, this gets the error codes that will result in a retry. Type StringCollection. If using the setter, this specifies the error codes that are to cause a retry.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection TriggerErrorCodes { get; set; }
Public Property TriggerErrorCodes As StringCollection
    Get
    Set
public:
property StringCollection^ TriggerErrorCodes {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


TriggerExceptions Property

TriggerExceptions Property
Namespaces ► eBay.Service.Core.Sdk ► CallRetry ► TriggerExceptions
If using the getter, this gets the exceptions that will result in a retry. Type TypeCollection.. If using the setter, this specifies the exceptions that are to cause a retry.
Declaration Syntax
C# Visual Basic Visual C++
public TypeCollection TriggerExceptions { get; set; }
Public Property TriggerExceptions As TypeCollection
    Get
    Set
public:
property TypeCollection^ TriggerExceptions {
    TypeCollection^ get ();
    void set (TypeCollection^ value);
}


TriggerHttpStatusCodes Property

TriggerHttpStatusCodes Property
Namespaces ► eBay.Service.Core.Sdk ► CallRetry ► TriggerHttpStatusCodes
If using the getter, this gets the status codes that will result in a retry. Type StringCollection. If using the setter, this specifies the status codes that are to cause a retry.
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection TriggerHttpStatusCodes { get; set; }
Public Property TriggerHttpStatusCodes As Int32Collection
    Get
    Set
public:
property Int32Collection^ TriggerHttpStatusCodes {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


eBayAccount Class

eBayAccount Class
Namespaces ► eBay.Service.Core.Sdk ► eBayAccount
Used to store eBay user ID and password, normally as credentials needed for some API calls. Normally, eBayToken is used instead for API call access.
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class eBayAccount
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class eBayAccount
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class eBayAccount
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayAccount()()()() |
 | eBayAccount(String, String) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Password | Gets or sets the user's password of type String.
 | ToString()()()() | this will return the UserName only (Overrides Object.ToString()()()().)
 | UserName | Gets or sets the user's id of type String.
Inheritance Hierarchy
Object
eBayAccount


eBayAccount Constructor

eBayAccount Constructor
Namespaces ► eBay.Service.Core.Sdk ► eBayAccount ► eBayAccount()()()()
Members
Icon | Member | Description
 | eBayAccount()()()() |
 | eBayAccount(String, String) |


eBayAccount Constructor

eBayAccount Constructor
Namespaces ► eBay.Service.Core.Sdk ► eBayAccount ► eBayAccount()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayAccount()
Public Sub New
public:
eBayAccount()


eBayAccount Constructor (UserName, Password)

eBayAccount Constructor (UserName, Password)
Namespaces ► eBay.Service.Core.Sdk ► eBayAccount ► eBayAccount(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public eBayAccount(
    string UserName,
    string Password
)
Public Sub New ( _
    UserName As String, _
    Password As String _
)
public:
eBayAccount(
    String^ UserName,
    String^ Password
)
Parameters
UserName (String)
The eBay UserId to use.
Password (String)
The user's password.


Password Property

Password Property
Namespaces ► eBay.Service.Core.Sdk ► eBayAccount ► Password
Gets or sets the user's password of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}


ToString Method

ToString Method
Namespaces ► eBay.Service.Core.Sdk ► eBayAccount ► ToString()()()()
this will return the UserName only
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value


UserName Property

UserName Property
Namespaces ► eBay.Service.Core.Sdk ► eBayAccount ► UserName
Gets or sets the user's id of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}


ExceptionFilter Class

ExceptionFilter Class
Namespaces ► eBay.Service.Core.Sdk ► ExceptionFilter
Exception filters are used to filter the exceptions that are to be logged using the ApiLogManager object, which is set in the ApiContext for the application. Only those exceptions specified in this filter will be logged. If the filter is not used, then all exceptions are logged.
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ExceptionFilter
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ExceptionFilter
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ExceptionFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExceptionFilter()()()() |
 | ExceptionFilter(String, String, String) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Matches(Exception) | Determines if an exception matches the criteria that have been set up for matching. 1. If no exceptions or codes have been configured to match, then the exception does not match the filter. (Empty filters do not match any exception.) 2. If the exception is an ApiException and has an error code configured in the CallRetry TriggerErrorCodes, the exception matches. (See Errors by Number in the Trading API Call Reference for a list of possible errors.) 3. If the exception is an ApiException containing (wrapping) an HttpException with a code configured in TriggerHttpStatusCodes, the exception matches. 4. If the exception is one of the types (classes) configured in TriggerExceptions, the exception matches. HttpException is supported for matching even though it arrives wrapped in an ApiException, because we unwrap the outer exception and match on the inner HttpException type. 5. Otherwise, the exception does not match the filter.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParseTriggerErrorCodes(String) | Converts comma-separated list of error codes into the appropriate StringCollection ready to set into the filter.
 | ParseTriggerExceptions(String) | Converts comma-separated list of exception type names into the appropriate TypeCollection ready to set into the filter.
 | ParseTriggerHttpStatusCodes(String) | Converts comma-separated list of integer status codes into the appropriate Int32Collection ready to set into the filter.
 | ToString()()()() | (Inherited from Object.)
 | TriggerErrorCodes | Gets or sets the error codes that retry should occur for of type StringCollection.
 | TriggerExceptions | Gets or sets the exception types that retry should occur for of type TypeCollection.
 | TriggerHttpStatusCodes | Gets or sets the error codes that retry should occur for of type StringCollection.
Inheritance Hierarchy
Object
ExceptionFilter


ExceptionFilter Constructor

ExceptionFilter Constructor
Namespaces ► eBay.Service.Core.Sdk ► ExceptionFilter ► ExceptionFilter()()()()
Members
Icon | Member | Description
 | ExceptionFilter()()()() |
 | ExceptionFilter(String, String, String) |


ExceptionFilter Constructor

ExceptionFilter Constructor
Namespaces ► eBay.Service.Core.Sdk ► ExceptionFilter ► ExceptionFilter()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExceptionFilter()
Public Sub New
public:
ExceptionFilter()


ExceptionFilter Constructor (errorCodes, exceptions, httpStatusCodes)

ExceptionFilter Constructor (errorCodes, exceptions, httpStatusCodes)
Namespaces ► eBay.Service.Core.Sdk ► ExceptionFilter ► ExceptionFilter(String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public ExceptionFilter(
    string errorCodes,
    string exceptions,
    string httpStatusCodes
)
Public Sub New ( _
    errorCodes As String, _
    exceptions As String, _
    httpStatusCodes As String _
)
public:
ExceptionFilter(
    String^ errorCodes,
    String^ exceptions,
    String^ httpStatusCodes
)
Parameters
errorCodes (String)
exceptions (String)
httpStatusCodes (String)


Matches Method (ex)

Matches Method (ex)
Namespaces ► eBay.Service.Core.Sdk ► ExceptionFilter ► Matches(Exception)
Determines if an exception matches the criteria that have been set up for matching. 1. If no exceptions or codes have been configured to match, then the exception does not match the filter. (Empty filters do not match any exception.) 2. If the exception is an ApiException and has an error code configured in the CallRetry TriggerErrorCodes, the exception matches. (See Errors by Number in the Trading API Call Reference for a list of possible errors.) 3. If the exception is an ApiException containing (wrapping) an HttpException with a code configured in TriggerHttpStatusCodes, the exception matches. 4. If the exception is one of the types (classes) configured in TriggerExceptions, the exception matches. HttpException is supported for matching even though it arrives wrapped in an ApiException, because we unwrap the outer exception and match on the inner HttpException type. 5. Otherwise, the exception does not match the filter.
Declaration Syntax
C# Visual Basic Visual C++
public bool Matches(
    Exception ex
)
Public Function Matches ( _
    ex As Exception _
) As Boolean
public:
bool Matches(
    Exception^ ex
)
Parameters
ex (Exception)
The Exception to test for retry.
Return Value
Returns true if retry should be invoked, else false


ParseTriggerErrorCodes Method (configString)

ParseTriggerErrorCodes Method (configString)
Namespaces ► eBay.Service.Core.Sdk ► ExceptionFilter ► ParseTriggerErrorCodes(String)
Converts comma-separated list of error codes into the appropriate StringCollection ready to set into the filter.
Declaration Syntax
C# Visual Basic Visual C++
public static StringCollection ParseTriggerErrorCodes(
    string configString
)
Public Shared Function ParseTriggerErrorCodes ( _
    configString As String _
) As StringCollection
public:
static StringCollection^ ParseTriggerErrorCodes(
    String^ configString
)
Parameters
configString (String)
Return Value


ParseTriggerExceptions Method (configString)

ParseTriggerExceptions Method (configString)
Namespaces ► eBay.Service.Core.Sdk ► ExceptionFilter ► ParseTriggerExceptions(String)
Converts comma-separated list of exception type names into the appropriate TypeCollection ready to set into the filter.
Declaration Syntax
C# Visual Basic Visual C++
public static TypeCollection ParseTriggerExceptions(
    string configString
)
Public Shared Function ParseTriggerExceptions ( _
    configString As String _
) As TypeCollection
public:
static TypeCollection^ ParseTriggerExceptions(
    String^ configString
)
Parameters
configString (String)
Return Value


ParseTriggerHttpStatusCodes Method (configString)

ParseTriggerHttpStatusCodes Method (configString)
Namespaces ► eBay.Service.Core.Sdk ► ExceptionFilter ► ParseTriggerHttpStatusCodes(String)
Converts comma-separated list of integer status codes into the appropriate Int32Collection ready to set into the filter.
Declaration Syntax
C# Visual Basic Visual C++
public static Int32Collection ParseTriggerHttpStatusCodes(
    string configString
)
Public Shared Function ParseTriggerHttpStatusCodes ( _
    configString As String _
) As Int32Collection
public:
static Int32Collection^ ParseTriggerHttpStatusCodes(
    String^ configString
)
Parameters
configString (String)
Return Value


TriggerErrorCodes Property

TriggerErrorCodes Property
Namespaces ► eBay.Service.Core.Sdk ► ExceptionFilter ► TriggerErrorCodes
Gets or sets the error codes that retry should occur for of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection TriggerErrorCodes { get; set; }
Public Property TriggerErrorCodes As StringCollection
    Get
    Set
public:
property StringCollection^ TriggerErrorCodes {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


TriggerExceptions Property

TriggerExceptions Property
Namespaces ► eBay.Service.Core.Sdk ► ExceptionFilter ► TriggerExceptions
Gets or sets the exception types that retry should occur for of type TypeCollection.
Declaration Syntax
C# Visual Basic Visual C++
public TypeCollection TriggerExceptions { get; set; }
Public Property TriggerExceptions As TypeCollection
    Get
    Set
public:
property TypeCollection^ TriggerExceptions {
    TypeCollection^ get ();
    void set (TypeCollection^ value);
}


TriggerHttpStatusCodes Property

TriggerHttpStatusCodes Property
Namespaces ► eBay.Service.Core.Sdk ► ExceptionFilter ► TriggerHttpStatusCodes
Gets or sets the error codes that retry should occur for of type StringCollection.
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection TriggerHttpStatusCodes { get; set; }
Public Property TriggerHttpStatusCodes As Int32Collection
    Get
    Set
public:
property Int32Collection^ TriggerHttpStatusCodes {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


HttpException Class

HttpException Class
Namespaces ► eBay.Service.Core.Sdk ► HttpException
Wraps HTTP errors (unexpected return codes 300 - 499, 501-599) for SDK. The HTTP status code is available in the StatusCode property.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class HttpException : SdkException,
    ISerializable
<SerializableAttribute> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class HttpException _
    Inherits SdkException _
    Implements ISerializable
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class HttpException : public SdkException,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HttpException()()()() | Default constructor.
 | HttpException(String) | Construct an HttpException described by the specified message.
 | HttpException(String, Exception) | Construct an HttpException wrapping the given exception, and described by the specified message.
 | HttpException(Int32) | Construct an HttpException with the specified HTTP status code.
 | HttpException(SerializationInfo, StreamingContext) | Deserialize an HttpException from serialized state information.
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Serialize an HttpException. (Overrides SdkException.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from Exception.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | StatusCode | Read-only property providing the StatusCode of the HttpException.
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | SdkException
 |  |  |  | HttpException


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► eBay.Service.Core.Sdk ► HttpException ► GetObjectData(SerializationInfo, StreamingContext)
Serialize an HttpException.
Declaration Syntax
C# Visual Basic Visual C++
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
[SecurityPermissionAttribute(SecurityAction::Demand, SerializationFormatter = true)]
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.


HttpException Constructor

HttpException Constructor
Namespaces ► eBay.Service.Core.Sdk ► HttpException ► HttpException()()()()
Members
Icon | Member | Description
 | HttpException()()()() | Default constructor.
 | HttpException(String) | Construct an HttpException described by the specified message.
 | HttpException(String, Exception) | Construct an HttpException wrapping the given exception, and described by the specified message.
 | HttpException(Int32) | Construct an HttpException with the specified HTTP status code.
 | HttpException(SerializationInfo, StreamingContext) | Deserialize an HttpException from serialized state information.


HttpException Constructor

HttpException Constructor
Namespaces ► eBay.Service.Core.Sdk ► HttpException ► HttpException()()()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public HttpException()
Public Sub New
public:
HttpException()


HttpException Constructor (code)

HttpException Constructor (code)
Namespaces ► eBay.Service.Core.Sdk ► HttpException ► HttpException(Int32)
Construct an HttpException with the specified HTTP status code.
Declaration Syntax
C# Visual Basic Visual C++
public HttpException(
    int code
)
Public Sub New ( _
    code As Integer _
)
public:
HttpException(
    int code
)
Parameters
code (Int32)
The HTTP status code associated with the exception.


HttpException Constructor (info, context)

HttpException Constructor (info, context)
Namespaces ► eBay.Service.Core.Sdk ► HttpException ► HttpException(SerializationInfo, StreamingContext)
Deserialize an HttpException from serialized state information.
Declaration Syntax
C# Visual Basic Visual C++
protected HttpException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
HttpException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The object that holds the serialized object data.
context (StreamingContext)
The contextual information about the source or destination.


HttpException Constructor (message)

HttpException Constructor (message)
Namespaces ► eBay.Service.Core.Sdk ► HttpException ► HttpException(String)
Construct an HttpException described by the specified message.
Declaration Syntax
C# Visual Basic Visual C++
public HttpException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
HttpException(
    String^ message
)
Parameters
message (String)
A message that describes the error.


HttpException Constructor (message, inner)

HttpException Constructor (message, inner)
Namespaces ► eBay.Service.Core.Sdk ► HttpException ► HttpException(String, Exception)
Construct an HttpException wrapping the given exception, and described by the specified message.
Declaration Syntax
C# Visual Basic Visual C++
public HttpException(
    string message,
    Exception inner
)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
public:
HttpException(
    String^ message,
    Exception^ inner
)
Parameters
message (String)
A message that describes the error.
inner (Exception)
The exception that is the cause of the current exception.


StatusCode Property

StatusCode Property
Namespaces ► eBay.Service.Core.Sdk ► HttpException ► StatusCode
Read-only property providing the StatusCode of the HttpException.
Declaration Syntax
C# Visual Basic Visual C++
public int StatusCode { get; }
Public ReadOnly Property StatusCode As Integer
    Get
public:
property int StatusCode {
    int get ();
}


HttpWebResponseDecompressed Class

HttpWebResponseDecompressed Class
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed
Summary description for HttpWebResponseDecompressed.
Declaration Syntax
C# Visual Basic Visual C++
public class HttpWebResponseDecompressed : WebResponse
Public Class HttpWebResponseDecompressed _
    Inherits WebResponse
public ref class HttpWebResponseDecompressed : public WebResponse
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HttpWebResponseDecompressed(WebRequest) |
 | ApiLogManager |
 | CastToHttpWebResponse |
 | Close()()()() | (Overrides WebResponse.Close()()()().)
 | ContentLength | (Overrides WebResponse.ContentLength.)
 | ContentType | (Overrides WebResponse.ContentType.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | IDisposable..::..Dispose()()()() | (Inherited from WebResponse.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | ISerializable..::..GetObjectData(SerializationInfo, StreamingContext) | (Inherited from WebResponse.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Inherited from WebResponse.)
 | GetResponseStream()()()() | (Overrides WebResponse.GetResponseStream()()()().)
 | GetType()()()() | (Inherited from Object.)
 | Headers | (Overrides WebResponse.Headers.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | IsFromCache | (Inherited from WebResponse.)
 | IsMutuallyAuthenticated | (Inherited from WebResponse.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ResponseUri | (Overrides WebResponse.ResponseUri.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | WebResponse
 |  |  | HttpWebResponseDecompressed


ApiLogManager Property

ApiLogManager Property
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed ► ApiLogManager
Declaration Syntax
C# Visual Basic Visual C++
public ApiLogManager ApiLogManager { get; set; }
Public Property ApiLogManager As ApiLogManager
    Get
    Set
public:
property ApiLogManager^ ApiLogManager {
    ApiLogManager^ get ();
    void set (ApiLogManager^ value);
}


CastToHttpWebResponse Property

CastToHttpWebResponse Property
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed ► CastToHttpWebResponse
Declaration Syntax
C# Visual Basic Visual C++
public HttpWebResponse CastToHttpWebResponse { get; }
Public ReadOnly Property CastToHttpWebResponse As HttpWebResponse
    Get
public:
property HttpWebResponse^ CastToHttpWebResponse {
    HttpWebResponse^ get ();
}


Close Method

Close Method
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed ► Close()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override void Close()
Public Overrides Sub Close
public:
virtual void Close() override


ContentLength Property

ContentLength Property
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed ► ContentLength
Declaration Syntax
C# Visual Basic Visual C++
public override long ContentLength { get; }
Public Overrides ReadOnly Property ContentLength As Long
    Get
public:
virtual property long long ContentLength {
    long long get () override;
}


ContentType Property

ContentType Property
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed ► ContentType
Declaration Syntax
C# Visual Basic Visual C++
public override string ContentType { get; }
Public Overrides ReadOnly Property ContentType As String
    Get
public:
virtual property String^ ContentType {
    String^ get () override;
}


GetResponseStream Method

GetResponseStream Method
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed ► GetResponseStream()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override Stream GetResponseStream()
Public Overrides Function GetResponseStream As Stream
public:
virtual Stream^ GetResponseStream() override
Return Value


Headers Property

Headers Property
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed ► Headers
Declaration Syntax
C# Visual Basic Visual C++
public override WebHeaderCollection Headers { get; }
Public Overrides ReadOnly Property Headers As WebHeaderCollection
    Get
public:
virtual property WebHeaderCollection^ Headers {
    WebHeaderCollection^ get () override;
}


HttpWebResponseDecompressed Constructor (request)

HttpWebResponseDecompressed Constructor (request)
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed ► HttpWebResponseDecompressed(WebRequest)
Declaration Syntax
C# Visual Basic Visual C++
public HttpWebResponseDecompressed(
    WebRequest request
)
Public Sub New ( _
    request As WebRequest _
)
public:
HttpWebResponseDecompressed(
    WebRequest^ request
)
Parameters
request (WebRequest)


ResponseUri Property

ResponseUri Property
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed ► ResponseUri
Declaration Syntax
C# Visual Basic Visual C++
public override Uri ResponseUri { get; }
Public Overrides ReadOnly Property ResponseUri As Uri
    Get
public:
virtual property Uri^ ResponseUri {
    Uri^ get () override;
}


SdkException Class

SdkException Class
Namespaces ► eBay.Service.Core.Sdk ► SdkException
SdkException is used for general exceptions related to SDK kernel itself. For example, if a token is not set the exception will be wrapped as SdkException.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SdkException : ApplicationException,
    ISerializable
<SerializableAttribute> _
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SdkException _
    Inherits ApplicationException _
    Implements ISerializable
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SdkException : public ApplicationException,
    ISerializable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SdkException()()()() |
 | SdkException(String) |
 | SdkException(String, Exception) |
 | SdkException(SerializationInfo, StreamingContext) |
 | Data | (Inherited from Exception.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetBaseException()()()() | (Inherited from Exception.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()()() | (Inherited from Exception.)
 | HelpLink | (Inherited from Exception.)
 | HResult | (Inherited from Exception.)
 | InnerException | (Inherited from Exception.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from Exception.)
 | Source | (Inherited from Exception.)
 | StackTrace | (Inherited from Exception.)
 | TargetSite | (Inherited from Exception.)
 | ToString()()()() | (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | SdkException
 |  |  |  | ApiException
 |  |  |  | HttpException


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► eBay.Service.Core.Sdk ► SdkException ► GetObjectData(SerializationInfo, StreamingContext)
Declaration Syntax
C# Visual Basic Visual C++
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
[SecurityPermissionAttribute(SecurityAction::Demand, SerializationFormatter = true)]
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
The SerializationInfo that holds the serialized object data about the exception being thrown.
context (StreamingContext)
The StreamingContext that contains contextual information about the source or destination.


SdkException Constructor

SdkException Constructor
Namespaces ► eBay.Service.Core.Sdk ► SdkException ► SdkException()()()()
Members
Icon | Member | Description
 | SdkException()()()() |
 | SdkException(String) |
 | SdkException(String, Exception) |
 | SdkException(SerializationInfo, StreamingContext) |


SdkException Constructor

SdkException Constructor
Namespaces ► eBay.Service.Core.Sdk ► SdkException ► SdkException()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SdkException()
Public Sub New
public:
SdkException()


SdkException Constructor (info, context)

SdkException Constructor (info, context)
Namespaces ► eBay.Service.Core.Sdk ► SdkException ► SdkException(SerializationInfo, StreamingContext)
Declaration Syntax
C# Visual Basic Visual C++
protected SdkException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
SdkException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
The object that holds the serialized object data.
context (StreamingContext)
The contextual information about the source or destination.


SdkException Constructor (message)

SdkException Constructor (message)
Namespaces ► eBay.Service.Core.Sdk ► SdkException ► SdkException(String)
Declaration Syntax
C# Visual Basic Visual C++
public SdkException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
SdkException(
    String^ message
)
Parameters
message (String)
A message that describes the error.


SdkException Constructor (message, inner)

SdkException Constructor (message, inner)
Namespaces ► eBay.Service.Core.Sdk ► SdkException ► SdkException(String, Exception)
Declaration Syntax
C# Visual Basic Visual C++
public SdkException(
    string message,
    Exception inner
)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
public:
SdkException(
    String^ message,
    Exception^ inner
)
Parameters
message (String)
A message that describes the error.
inner (Exception)
The exception that is the cause of the current exception.


TokenHardExpirationEventArgs Class

TokenHardExpirationEventArgs Class
Namespaces ► eBay.Service.Core.Sdk ► TokenHardExpirationEventArgs
Declaration Syntax
C# Visual Basic Visual C++
[ComVisibleAttribute(false)]
public class TokenHardExpirationEventArgs : EventArgs
<ComVisibleAttribute(False)> _
Public Class TokenHardExpirationEventArgs _
    Inherits EventArgs
[ComVisibleAttribute(false)]
public ref class TokenHardExpirationEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TokenHardExpirationEventArgs(DateTime) |
 | Equals(Object) | (Inherited from Object.)
 | ExpirationDate | Gets the time the token will expire.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | TokenHardExpirationEventArgs


ExpirationDate Property

ExpirationDate Property
Namespaces ► eBay.Service.Core.Sdk ► TokenHardExpirationEventArgs ► ExpirationDate
Gets the time the token will expire.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ExpirationDate { get; }
Public ReadOnly Property ExpirationDate As DateTime
    Get
public:
property DateTime ExpirationDate {
    DateTime get ();
}


TokenHardExpirationEventArgs Constructor (ExpirationDate)

TokenHardExpirationEventArgs Constructor (ExpirationDate)
Namespaces ► eBay.Service.Core.Sdk ► TokenHardExpirationEventArgs ► TokenHardExpirationEventArgs(DateTime)
Declaration Syntax
C# Visual Basic Visual C++
public TokenHardExpirationEventArgs(
    DateTime ExpirationDate
)
Public Sub New ( _
    ExpirationDate As DateTime _
)
public:
TokenHardExpirationEventArgs(
    DateTime ExpirationDate
)
Parameters
ExpirationDate (DateTime)
The time the token expires of type DateTime.


TokenHardExpirationWarningEventHandler Delegate

TokenHardExpirationWarningEventHandler Delegate
Namespaces ► eBay.Service.Core.Sdk ► TokenHardExpirationWarningEventHandler
Declaration Syntax
C# Visual Basic Visual C++
[ComVisibleAttribute(false)]
public delegate void TokenHardExpirationWarningEventHandler(
    Object sender,
    TokenHardExpirationEventArgs e
)
<ComVisibleAttribute(False)> _
Public Delegate Sub TokenHardExpirationWarningEventHandler ( _
    sender As Object, _
    e As TokenHardExpirationEventArgs _
)
[ComVisibleAttribute(false)]
public delegate void TokenHardExpirationWarningEventHandler(
    Object^ sender,
    TokenHardExpirationEventArgs^ e
)
Parameters
sender (Object)
The source of the event.
e (TokenHardExpirationEventArgs)
An TokenHardExpirationEventArgs containing the event data.


eBay.Service.Core.Soap Namespace

eBay.Service.Core.Soap Namespace
Namespaces ► eBay.Service.Core.Soap
Declaration Syntax
C# Visual Basic Visual C++
namespace eBay.Service.Core.Soap
Namespace eBay.Service.Core.Soap
namespace eBay.Service.Core.Soap
Types
All Types Classes Enumerations
Icon | Type | Description
 | AbstractRequestType |
 | AbstractResponseType |
 | AccessRuleCurrentStatusCodeType |
 | AccessRuleStatusCodeType |
 | AccountDetailEntryCodeType |
 | AccountEntriesType |
 | AccountEntrySortTypeCodeType |
 | AccountEntryType |
 | AccountEntryTypeCollection |
 | AccountHistorySelectionCodeType |
 | AccountStateCodeType |
 | AccountSummaryType |
 | AckCodeType |
 | AddDisputeRequestType |
 | AddDisputeResponseRequestType |
 | AddDisputeResponseResponseType |
 | AddDisputeResponseType |
 | AddFixedPriceItemRequestType |
 | AddFixedPriceItemResponseType |
 | AddItemFromSellingManagerTemplateRequestType |
 | AddItemFromSellingManagerTemplateResponseType |
 | AddItemRequestContainerType |
 | AddItemRequestContainerTypeCollection |
 | AddItemRequestType |
 | AddItemResponseContainerType |
 | AddItemResponseContainerTypeCollection |
 | AddItemResponseType |
 | AddItemsRequestType |
 | AddItemsResponseType |
 | AdditionalAccountType |
 | AdditionalAccountTypeCollection |
 | AdditionalCompatibilityEnabledDefinitionType |
 | AddMemberMessageAAQToPartnerRequestType |
 | AddMemberMessageAAQToPartnerResponseType |
 | AddMemberMessageRTQRequestType |
 | AddMemberMessageRTQResponseType |
 | AddMemberMessagesAAQToBidderRequestContainerType |
 | AddMemberMessagesAAQToBidderRequestContainerTypeCollection |
 | AddMemberMessagesAAQToBidderRequestType |
 | AddMemberMessagesAAQToBidderResponseContainerType |
 | AddMemberMessagesAAQToBidderResponseContainerTypeCollection |
 | AddMemberMessagesAAQToBidderResponseType |
 | AddOrderRequestType |
 | AddOrderResponseType |
 | AddressAttributeCodeType |
 | AddressAttributeType |
 | AddressAttributeTypeCollection |
 | AddressOwnerCodeType |
 | AddressRecordTypeCodeType |
 | AddressStatusCodeType |
 | AddressType |
 | AddressTypeCodeType |
 | AddressUsageCodeType |
 | AddSecondChanceItemRequestType |
 | AddSecondChanceItemResponseType |
 | AddSellingManagerInventoryFolderRequestType |
 | AddSellingManagerInventoryFolderResponseType |
 | AddSellingManagerProductRequestType |
 | AddSellingManagerProductResponseType |
 | AddSellingManagerTemplateRequestType |
 | AddSellingManagerTemplateResponseType |
 | AddToItemDescriptionRequestType |
 | AddToItemDescriptionResponseType |
 | AddToWatchListRequestType |
 | AddToWatchListResponseType |
 | AddTransactionConfirmationItemRequestType |
 | AddTransactionConfirmationItemResponseType |
 | AdFormatEnabledCodeType |
 | AdFormatEnabledDefinitionType |
 | AdFormatLeadStatusCodeType |
 | AdFormatLeadType |
 | AdFormatLeadTypeCollection |
 | AffiliateTrackingDetailsType |
 | AmountType |
 | AmountTypeCollection |
 | AnnouncementMessageCodeType |
 | AnnouncementMessageType |
 | AnnouncementMessageTypeCollection |
 | ApiAccessRuleType |
 | ApiAccessRuleTypeCollection |
 | ApplicationDeliveryPreferencesType |
 | ApplicationDeviceTypeCodeType |
 | ASQPreferencesType |
 | AttributeConversionEnabledCodeType |
 | AttributeConversionEnabledFeatureDefinitionType |
 | AttributeSetType |
 | AttributeSetTypeCollection |
 | AttributeType |
 | AttributeTypeCollection |
 | AutomatedLeaveFeedbackEventCodeType |
 | AverageRatingDetailsType |
 | AverageRatingDetailsTypeCollection |
 | AverageRatingSummaryType |
 | AverageRatingSummaryTypeCollection |
 | Base64BinaryType |
 | BasicUpgradePackEnabledDefinitionType |
 | BestOfferActionCodeType |
 | BestOfferAutoAcceptEnabledDefinitionType |
 | BestOfferAutoDeclineEnabledDefinitionType |
 | BestOfferCounterEnabledDefinitionType |
 | BestOfferDetailsType |
 | BestOfferEnabledDefinitionType |
 | BestOfferStatusCodeType |
 | BestOfferType |
 | BestOfferTypeCodeType |
 | BestOfferTypeCollection |
 | BidActionCodeType |
 | BidAssistantListType |
 | BidderNoticePreferencesType |
 | BiddingDetailsType |
 | BiddingSummaryType |
 | BidGroupItemStatusCodeType |
 | BidGroupItemType |
 | BidGroupItemTypeCollection |
 | BidGroupStatusCodeType |
 | BidGroupType |
 | BidGroupTypeCollection |
 | BoldTitleCodeType |
 | BorderCodeType |
 | BotBlockRequestType |
 | BotBlockResponseType |
 | BrandMPNIdentifierEnabledDefinitionType |
 | BrandMPNType |
 | BusinessRoleType |
 | BusinessSellerDetailsType |
 | BuyerGuaranteeEnabledDefinitionType |
 | BuyerPackageEnclosuresType |
 | BuyerPackageEnclosureType |
 | BuyerPackageEnclosureTypeCollection |
 | BuyerPaymentInstrumentCodeType |
 | BuyerPaymentMethodCodeType |
 | BuyerPaymentMethodCodeTypeCollection |
 | BuyerProtectionCodeType |
 | BuyerProtectionDetailsType |
 | BuyerProtectionSourceCodeType |
 | BuyerRequirementDetailsType |
 | BuyerRoleMetricsType |
 | BuyerSatisfactionDashboardType |
 | BuyerSatisfactionStatusCodeType |
 | BuyerType |
 | BuyingSummaryType |
 | CalculatedHandlingDiscountType |
 | CalculatedShippingChargeOptionCodeType |
 | CalculatedShippingDiscountType |
 | CalculatedShippingPreferencesType |
 | CalculatedShippingRateOptionCodeType |
 | CalculatedShippingRateType |
 | CancelDetailType |
 | CancelDetailTypeCollection |
 | CancelStatusCodeType |
 | CategoryFeatureType |
 | CategoryFeatureTypeCollection |
 | CategoryGroupType |
 | CategoryItemSpecificsType |
 | CategoryItemSpecificsTypeCollection |
 | CategoryMappingType |
 | CategoryMappingTypeCollection |
 | CategoryType |
 | CategoryTypeCollection |
 | CharacteristicsSetType |
 | CharacteristicsSetTypeCollection |
 | CharacteristicType |
 | CharacteristicTypeCollection |
 | CharityAffiliationDetailType |
 | CharityAffiliationDetailTypeCollection |
 | CharityAffiliationsType |
 | CharityAffiliationTypeCodeType |
 | CharityIDType |
 | CharityIDTypeCollection |
 | CharityInfoType |
 | CharityInfoTypeCollection |
 | CharityStatusCodeType |
 | CharityType |
 | CheckoutMethodCodeType |
 | CheckoutStatusCodeType |
 | CheckoutStatusType |
 | ClassifiedAdAutoAcceptEnabledDefinitionType |
 | ClassifiedAdAutoDeclineEnabledDefinitionType |
 | ClassifiedAdBestOfferEnabledCodeType |
 | ClassifiedAdBestOfferEnabledDefinitionType |
 | ClassifiedAdCompanyNameEnabledDefinitionType |
 | ClassifiedAdContactByAddressEnabledDefinitionType |
 | ClassifiedAdContactByEmailEnabledDefintionType |
 | ClassifiedAdContactByPhoneEnabledDefinitionType |
 | ClassifiedAdCounterOfferEnabledDefinitionType |
 | ClassifiedAdPaymentMethodEnabledCodeType |
 | ClassifiedAdPaymentMethodEnabledDefinitionType |
 | ClassifiedAdPayPerLeadEnabledDefinitionType |
 | ClassifiedAdPhoneCountDefinitionType |
 | ClassifiedAdShippingMethodEnabledDefinitionType |
 | ClassifiedAdStreetCountDefinitionType |
 | CombinedFixedPriceTreatmentEnabledDefinitionType |
 | CombinedPaymentOptionCodeType |
 | CombinedPaymentPeriodCodeType |
 | CombinedPaymentPreferencesType |
 | CommentTypeCodeType |
 | CommentTypeCodeTypeCollection |
 | CompatibleVehicleTypeDefinitionType |
 | CompleteSaleRequestType |
 | CompleteSaleResponseType |
 | CompleteStatusCodeType |
 | ConditionEnabledCodeType |
 | ConditionEnabledDefinitionType |
 | ConditionType |
 | ConditionTypeCollection |
 | ConditionValuesDefinitionType |
 | ConditionValuesType |
 | ConfirmIdentityRequestType |
 | ConfirmIdentityResponseType |
 | ContactHoursDetailsType |
 | ContextSearchAssetType |
 | ContextSearchAssetTypeCollection |
 | CountryCodeType |
 | CountryCodeTypeCollection |
 | CountryDetailsType |
 | CountryDetailsTypeCollection |
 | CrossBorderTradeAustraliaEnabledDefinitionType |
 | CrossBorderTradeGBEnabledDefinitionType |
 | CrossBorderTradeNorthAmericaEnabledDefinitionType |
 | CrossPromotionPreferencesType |
 | CrossPromotionsType |
 | CurrencyCodeType |
 | CurrencyDetailsType |
 | CurrencyDetailsTypeCollection |
 | CustomSecurityHeaderType |
 | DayOfWeekCodeType |
 | DayOfWeekCodeTypeCollection |
 | DaysCodeType |
 | DeleteMyMessagesRequestType |
 | DeleteMyMessagesResponseType |
 | DeleteSellingManagerInventoryFolderRequestType |
 | DeleteSellingManagerInventoryFolderResponseType |
 | DeleteSellingManagerItemAutomationRuleRequestType |
 | DeleteSellingManagerItemAutomationRuleResponseType |
 | DeleteSellingManagerProductRequestType |
 | DeleteSellingManagerProductResponseType |
 | DeleteSellingManagerTemplateAutomationRuleRequestType |
 | DeleteSellingManagerTemplateAutomationRuleResponseType |
 | DeleteSellingManagerTemplateRequestType |
 | DeleteSellingManagerTemplateResponseType |
 | DeliveryDetailsType |
 | DeliveryStatusType |
 | DeliveryURLDetailType |
 | DeliveryURLDetailTypeCollection |
 | DepositSupportedDefinitionType |
 | DepositTypeCodeType |
 | DescriptionReviseModeCodeType |
 | DescriptionTemplateCodeType |
 | DescriptionTemplateType |
 | DescriptionTemplateTypeCollection |
 | DetailLevelCodeType |
 | DetailLevelCodeTypeCollection |
 | DetailNameCodeType |
 | DetailNameCodeTypeCollection |
 | DeviceTypeCodeType |
 | DigitalDeliverySelectedType |
 | DigitalDeliveryUserType |
 | DigitalGoodDeliveryEnabledDefinitionType |
 | DigitalGoodInfoType |
 | DigitalStatusCodeType |
 | DisableUnpaidItemAssistanceRequestType |
 | DisableUnpaidItemAssistanceResponseType |
 | DiscountCodeType |
 | DiscountNameCodeType |
 | DiscountPriceInfoType |
 | DiscountProfileType |
 | DiscountProfileTypeCollection |
 | DiscountReasonCodeType |
 | DiscountReasonCodeTypeCollection |
 | DispatchCutoffTimePreferencesType |
 | DispatchTimeMaxDetailsType |
 | DispatchTimeMaxDetailsTypeCollection |
 | DisplayPayNowButtonCodeType |
 | DisputeActivityCodeType |
 | DisputeCreditEligibilityCodeType |
 | DisputeExplanationCodeType |
 | DisputeFilterCountType |
 | DisputeFilterCountTypeCollection |
 | DisputeFilterTypeCodeType |
 | DisputeMessageSourceCodeType |
 | DisputeMessageType |
 | DisputeMessageTypeCollection |
 | DisputeReasonCodeType |
 | DisputeRecordTypeCodeType |
 | DisputeResolutionReasonCodeType |
 | DisputeResolutionRecordTypeCodeType |
 | DisputeResolutionType |
 | DisputeResolutionTypeCollection |
 | DisputeSortTypeCodeType |
 | DisputeStateCodeType |
 | DisputeStatusCodeType |
 | DisputeType |
 | DisputeTypeCollection |
 | DistanceType |
 | DuplicateInvocationDetailsType |
 | DutchBINEnabledDefinitionType |
 | EANEnabledDefinitionType |
 | EANIdentifierEnabledDefinitionType |
 | eBayAPIInterfaceService |
 | eBayMotorsProAdFormatEnabledDefinitionType |
 | eBayMotorsProAutoAcceptEnabledDefinitionType |
 | eBayMotorsProAutoDeclineEnabledDefinitionType |
 | eBayMotorsProBestOfferEnabledDefinitionType |
 | eBayMotorsProCompanyNameEnabledDefinitionType |
 | eBayMotorsProContactByAddressEnabledDefinitionType |
 | eBayMotorsProContactByEmailEnabledDefinitionType |
 | eBayMotorsProContactByPhoneEnabledDefinitionType |
 | eBayMotorsProCounterOfferEnabledDefinitionType |
 | eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType |
 | eBayMotorsProPhoneCountDefinitionType |
 | eBayMotorsProSellerContactDetailsEnabledDefinitionType |
 | eBayMotorsProShippingMethodEnabledDefinitionType |
 | eBayMotorsProStreetCountDefinitionType |
 | eBayPaymentMismatchDetailsType |
 | eBayPLUSPreferenceType |
 | eBayPLUSPreferenceTypeCollection |
 | EBaySubscriptionTypeCodeType |
 | EBaySubscriptionTypeCodeTypeCollection |
 | eBayXmlAPIInterfaceService |
 | EnableCodeType |
 | EndFixedPriceItemRequestType |
 | EndFixedPriceItemResponseType |
 | EndItemRequestContainerType |
 | EndItemRequestContainerTypeCollection |
 | EndItemRequestType |
 | EndItemResponseContainerType |
 | EndItemResponseContainerTypeCollection |
 | EndItemResponseType |
 | EndItemsRequestType |
 | EndItemsResponseType |
 | EndOfAuctionEmailPreferencesType |
 | EndOfAuctionLogoTypeCodeType |
 | EndReasonCodeType |
 | EpidSupportedDefinitionType |
 | ErrorClassificationCodeType |
 | ErrorHandlingCodeType |
 | ErrorLanguageCodeType |
 | ErrorParameterType |
 | ErrorParameterTypeCollection |
 | ErrorType |
 | ErrorTypeCollection |
 | ExcludeShippingLocationDetailsType |
 | ExcludeShippingLocationDetailsTypeCollection |
 | ExpressConditionRequiredDefinitionType |
 | ExpressEnabledDefinitionType |
 | ExpressItemRequirementsType |
 | ExpressPicturesRequiredDefinitionType |
 | ExtendedContactDetailsType |
 | ExtendedPictureDetailsType |
 | ExtendedProductFinderIDType |
 | ExtendedProductFinderIDTypeCollection |
 | ExtendSiteHostedPicturesRequestType |
 | ExtendSiteHostedPicturesResponseType |
 | ExternalProductCodeType |
 | ExternalProductIDType |
 | ExternalTransactionType |
 | ExternalTransactionTypeCollection |
 | FeatureDefinitionsType |
 | FeaturedFirstCodeType |
 | FeaturedPlusCodeType |
 | FeatureEligibilityType |
 | FeatureIDCodeType |
 | FeatureIDCodeTypeCollection |
 | FedExRateOptionCodeType |
 | FeedbackDetailType |
 | FeedbackDetailTypeCollection |
 | FeedbackInfoType |
 | FeedbackPeriodType |
 | FeedbackPeriodTypeCollection |
 | FeedbackRatingDetailCodeType |
 | FeedbackRatingStarCodeType |
 | FeedbackResponseCodeType |
 | FeedbackSummaryPeriodCodeType |
 | FeedbackSummaryType |
 | FeedbackTypeCodeType |
 | FeeType |
 | FeeTypeCollection |
 | FetchTokenRequestType |
 | FetchTokenResponseType |
 | FlatRateInsuranceRangeCodeType |
 | FlatRateInsuranceRangeCostType |
 | FlatRateInsuranceRangeCostTypeCollection |
 | FlatShippingDiscountType |
 | FlatShippingPreferencesType |
 | FlatShippingRateOptionCodeType |
 | FreeGalleryPlusEnabledDefinitionType |
 | FreePicturePackEnabledDefinitionType |
 | GallerySortFilterCodeType |
 | GalleryStatusCodeType |
 | GalleryTypeCodeType |
 | GeographicExposureCodeType |
 | GetAccountRequestType |
 | GetAccountResponseType |
 | GetAdFormatLeadsRequestType |
 | GetAdFormatLeadsResponseType |
 | GetAllBiddersModeCodeType |
 | GetAllBiddersRequestType |
 | GetAllBiddersResponseType |
 | GetApiAccessRulesRequestType |
 | GetApiAccessRulesResponseType |
 | GetBestOffersRequestType |
 | GetBestOffersResponseType |
 | GetBidderListRequestType |
 | GetBidderListResponseType |
 | GetCategoriesRequestType |
 | GetCategoriesResponseType |
 | GetCategoryFeaturesRequestType |
 | GetCategoryFeaturesResponseType |
 | GetCategoryMappingsRequestType |
 | GetCategoryMappingsResponseType |
 | GetCategorySpecificsRequestType |
 | GetCategorySpecificsResponseType |
 | GetChallengeTokenRequestType |
 | GetChallengeTokenResponseType |
 | GetCharitiesRequestType |
 | GetCharitiesResponseType |
 | GetClientAlertsAuthTokenRequestType |
 | GetClientAlertsAuthTokenResponseType |
 | GetContextualKeywordsRequestType |
 | GetContextualKeywordsResponseType |
 | GetDescriptionTemplatesRequestType |
 | GetDescriptionTemplatesResponseType |
 | GetDisputeRequestType |
 | GetDisputeResponseType |
 | GeteBayDetailsRequestType |
 | GeteBayDetailsResponseType |
 | GeteBayOfficialTimeRequestType |
 | GeteBayOfficialTimeResponseType |
 | GetFeedbackRequestType |
 | GetFeedbackResponseType |
 | GetItemRequestType |
 | GetItemResponseType |
 | GetItemsAwaitingFeedbackRequestType |
 | GetItemsAwaitingFeedbackResponseType |
 | GetItemShippingRequestType |
 | GetItemShippingResponseType |
 | GetItemTransactionsRequestType |
 | GetItemTransactionsResponseType |
 | GetMemberMessagesRequestType |
 | GetMemberMessagesResponseType |
 | GetMessagePreferencesRequestType |
 | GetMessagePreferencesResponseType |
 | GetMyeBayBuyingRequestType |
 | GetMyeBayBuyingResponseType |
 | GetMyeBayRemindersRequestType |
 | GetMyeBayRemindersResponseType |
 | GetMyeBaySellingRequestType |
 | GetMyeBaySellingResponseType |
 | GetMyMessagesRequestType |
 | GetMyMessagesResponseType |
 | GetNotificationPreferencesRequestType |
 | GetNotificationPreferencesResponseType |
 | GetNotificationsUsageRequestType |
 | GetNotificationsUsageResponseType |
 | GetOrdersRequestType |
 | GetOrdersResponseType |
 | GetOrderTransactionsRequestType |
 | GetOrderTransactionsResponseType |
 | GetProductSellingPagesRequestType |
 | GetProductSellingPagesResponseType |
 | GetPromotionalSaleDetailsRequestType |
 | GetPromotionalSaleDetailsResponseType |
 | GetSellerDashboardRequestType |
 | GetSellerDashboardResponseType |
 | GetSellerEventsRequestType |
 | GetSellerEventsResponseType |
 | GetSellerListRequestType |
 | GetSellerListResponseType |
 | GetSellerPaymentsRequestType |
 | GetSellerPaymentsResponseType |
 | GetSellerTransactionsRequestType |
 | GetSellerTransactionsResponseType |
 | GetSellingManagerAlertsRequestType |
 | GetSellingManagerAlertsResponseType |
 | GetSellingManagerEmailLogRequestType |
 | GetSellingManagerEmailLogResponseType |
 | GetSellingManagerInventoryFolderRequestType |
 | GetSellingManagerInventoryFolderResponseType |
 | GetSellingManagerInventoryRequestType |
 | GetSellingManagerInventoryResponseType |
 | GetSellingManagerItemAutomationRuleRequestType |
 | GetSellingManagerItemAutomationRuleResponseType |
 | GetSellingManagerSaleRecordRequestType |
 | GetSellingManagerSaleRecordResponseType |
 | GetSellingManagerSoldListingsRequestType |
 | GetSellingManagerSoldListingsResponseType |
 | GetSellingManagerTemplateAutomationRuleRequestType |
 | GetSellingManagerTemplateAutomationRuleResponseType |
 | GetSellingManagerTemplatesRequestType |
 | GetSellingManagerTemplatesResponseType |
 | GetSessionIDRequestType |
 | GetSessionIDResponseType |
 | GetShippingDiscountProfilesRequestType |
 | GetShippingDiscountProfilesResponseType |
 | GetStoreCategoryUpdateStatusRequestType |
 | GetStoreCategoryUpdateStatusResponseType |
 | GetStoreCustomPageRequestType |
 | GetStoreCustomPageResponseType |
 | GetStoreOptionsRequestType |
 | GetStoreOptionsResponseType |
 | GetStorePreferencesRequestType |
 | GetStorePreferencesResponseType |
 | GetStoreRequestType |
 | GetStoreResponseType |
 | GetSuggestedCategoriesRequestType |
 | GetSuggestedCategoriesResponseType |
 | GetTaxTableRequestType |
 | GetTaxTableResponseType |
 | GetTokenStatusRequestType |
 | GetTokenStatusResponseType |
 | GetUserContactDetailsRequestType |
 | GetUserContactDetailsResponseType |
 | GetUserDisputesRequestType |
 | GetUserDisputesResponseType |
 | GetUserPreferencesRequestType |
 | GetUserPreferencesResponseType |
 | GetUserRequestType |
 | GetUserResponseType |
 | GetVeROReasonCodeDetailsRequestType |
 | GetVeROReasonCodeDetailsResponseType |
 | GetVeROReportStatusRequestType |
 | GetVeROReportStatusResponseType |
 | GiftIconCodeType |
 | GiftServicesCodeType |
 | GiftServicesCodeTypeCollection |
 | GiftSummaryType |
 | GlobalShippingEnabledDefinitionType |
 | GranularityLevelCodeType |
 | Group1MaxFlatShippingCostDefinitionType |
 | Group2MaxFlatShippingCostDefinitionType |
 | Group3MaxFlatShippingCostDefinitionType |
 | HandlingNameCodeType |
 | HandlingTimeEnabledDefinitionType |
 | HighlightCodeType |
 | HitCounterCodeType |
 | HomePageFeaturedCodeType |
 | HomePageFeaturedEnabledDefinitionType |
 | INEscrowWorkflowTimelineCodeType |
 | INEscrowWorkflowTimelineDefinitionType |
 | InquiryStatusCodeType |
 | InsuranceDetailsType |
 | InsuranceOptionCodeType |
 | InsuranceSelectedCodeType |
 | Int32Collection |
 | Int64Collection |
 | IntegratedMerchantCreditCardInfoType |
 | InternationalShippingServiceOptionsType |
 | InternationalShippingServiceOptionsTypeCollection |
 | InventoryFeesType |
 | InventoryFeesTypeCollection |
 | InventoryStatusType |
 | InventoryStatusTypeCollection |
 | InventoryTrackingMethodCodeType |
 | InvocationStatusType |
 | ISBNEnabledDefinitionType |
 | ISBNIdentifierEnabledDefinitionType |
 | IssueRefundRequestType |
 | IssueRefundResponseType |
 | ItemArrivedWithinEDDCodeType |
 | ItemBestOffersArrayType |
 | ItemBestOffersType |
 | ItemBestOffersTypeCollection |
 | ItemBidDetailsType |
 | ItemBidDetailsTypeCollection |
 | ItemCompatibilityEnabledCodeType |
 | ItemCompatibilityEnabledDefinitionType |
 | ItemCompatibilityListType |
 | ItemCompatibilityType |
 | ItemCompatibilityTypeCollection |
 | ItemConditionCodeType |
 | ItemFormatSortFilterCodeType |
 | ItemIDArrayType |
 | ItemListCustomizationType |
 | ItemPolicyViolationType |
 | ItemRatingDetailsType |
 | ItemRatingDetailsTypeCollection |
 | ItemsCanceledEventType |
 | ItemSortFilterCodeType |
 | ItemSortTypeCodeType |
 | ItemSpecificDetailsType |
 | ItemSpecificDetailsTypeCollection |
 | ItemSpecificsEnabledCodeType |
 | ItemSpecificsEnabledDefinitionType |
 | ItemSpecificSourceCodeType |
 | ItemTransactionIDType |
 | ItemTransactionIDTypeCollection |
 | ItemType |
 | ItemTypeCodeType |
 | ItemTypeCollection |
 | KTypeSupportedDefinitionType |
 | LabelType |
 | LeaveFeedbackRequestType |
 | LeaveFeedbackResponseType |
 | LineItemType |
 | LineItemTypeCollection |
 | ListingCheckoutRedirectPreferenceType |
 | ListingDesignerType |
 | ListingDetailsType |
 | ListingDurationDefinitionsType |
 | ListingDurationDefinitionType |
 | ListingDurationDefinitionTypeCollection |
 | ListingDurationReferenceType |
 | ListingDurationReferenceTypeCollection |
 | ListingEnhancementDurationDefinitionType |
 | ListingEnhancementDurationReferenceType |
 | ListingEnhancementsCodeType |
 | ListingEnhancementsCodeTypeCollection |
 | ListingFeatureDetailsType |
 | ListingFeatureDetailsTypeCollection |
 | ListingRecommendationsType |
 | ListingRecommendationType |
 | ListingRecommendationTypeCollection |
 | ListingStartPriceDetailsType |
 | ListingStartPriceDetailsTypeCollection |
 | ListingStatusCodeType |
 | ListingSubtypeCodeType |
 | ListingTypeCodeType |
 | LocalListingDistancesNonSubscriptionDefinitionType |
 | LocalListingDistancesRegularDefinitionType |
 | LocalListingDistancesSpecialtyDefinitionType |
 | LocalMarketAdFormatEnabledDefinitionType |
 | LocalMarketAutoAcceptEnabledDefinitionType |
 | LocalMarketAutoDeclineEnabledDefinitionType |
 | LocalMarketBestOfferEnabledDefinitionType |
 | LocalMarketCompanyNameEnabledDefinitionType |
 | LocalMarketContactByAddressEnabledDefinitionType |
 | LocalMarketContactByEmailEnabledDefinitionType |
 | LocalMarketContactByPhoneEnabledDefinitionType |
 | LocalMarketCounterOfferEnabledDefinitionType |
 | LocalMarketNonSubscriptionDefinitionType |
 | LocalMarketPaymentMethodCheckOutEnabledDefinitionType |
 | LocalMarketPhoneCountDefinitionType |
 | LocalMarketPremiumSubscriptionDefinitionType |
 | LocalMarketRegularSubscriptionDefinitionType |
 | LocalMarketSellerContactDetailsEnabledDefinitionType |
 | LocalMarketShippingMethodEnabledDefinitionType |
 | LocalMarketSpecialitySubscriptionDefinitionType |
 | LocalMarketStreetCountDefinitionType |
 | LookupAttributeType |
 | LookupAttributeTypeCollection |
 | MarkUpMarkDownEventType |
 | MarkUpMarkDownEventTypeCodeType |
 | MarkUpMarkDownEventTypeCollection |
 | MaxFlatShippingCostCBTExemptDefinitionType |
 | MaxFlatShippingCostDefinitionType |
 | MaxGranularFitmentCountDefinitionType |
 | MaximumBuyerPolicyViolationsDetailsType |
 | MaximumBuyerPolicyViolationsType |
 | MaximumItemRequirementsDetailsType |
 | MaximumItemRequirementsType |
 | MaximumUnpaidItemStrikesCountDetailsType |
 | MaximumUnpaidItemStrikesDurationDetailsType |
 | MaximumUnpaidItemStrikesDurationDetailsTypeCollection |
 | MaximumUnpaidItemStrikesInfoDetailsType |
 | MaximumUnpaidItemStrikesInfoType |
 | MaxItemCompatibilityDefinitionType |
 | MeasurementSystemCodeType |
 | MeasureType |
 | MemberMessageExchangeType |
 | MemberMessageExchangeTypeCollection |
 | MemberMessageType |
 | MerchandizingPrefCodeType |
 | MerchDisplayCodeType |
 | MessageMediaType |
 | MessageMediaTypeCollection |
 | MessageStatusTypeCodeType |
 | MessageTypeCodeType |
 | MetadataType |
 | MetadataTypeCollection |
 | MinimumAdvertisedPriceExposureCodeType |
 | MinimumFeedbackScoreDetailsType |
 | MinimumReservePriceDefinitionType |
 | MinItemCompatibilityDefinitionType |
 | MismatchTypeCodeType |
 | ModifyActionCodeType |
 | ModifyNameType |
 | ModifyNameTypeCollection |
 | MoveSellingManagerInventoryFolderRequestType |
 | MoveSellingManagerInventoryFolderResponseType |
 | MultiLegShipmentType |
 | MultiLegShippingDetailsType |
 | MultiLegShippingServiceType |
 | MyeBayFavoriteSearchListType |
 | MyeBayFavoriteSearchType |
 | MyeBayFavoriteSearchTypeCollection |
 | MyeBayFavoriteSellerListType |
 | MyeBayFavoriteSellerType |
 | MyeBayFavoriteSellerTypeCollection |
 | MyeBaySelectionType |
 | MyeBaySellingSummaryType |
 | MyMessagesAlertResolutionStatusCode |
 | MyMessagesAlertType |
 | MyMessagesAlertTypeCollection |
 | MyMessagesFolderOperationCodeType |
 | MyMessagesFolderSummaryType |
 | MyMessagesFolderSummaryTypeCollection |
 | MyMessagesFolderType |
 | MyMessagesForwardDetailsType |
 | MyMessagesMessageType |
 | MyMessagesMessageTypeCollection |
 | MyMessagesResponseDetailsType |
 | MyMessagesSummaryType |
 | NameRecommendationType |
 | NameRecommendationTypeCollection |
 | NameValueListType |
 | NameValueListTypeCollection |
 | NameValueRelationshipType |
 | NameValueRelationshipTypeCollection |
 | NonProfitAddressType |
 | NonProfitAddressTypeCollection |
 | NonProfitSocialAddressType |
 | NonProfitSocialAddressTypeCollection |
 | NonSubscriptionDefinitionType |
 | NotificationDetailsType |
 | NotificationDetailsTypeCollection |
 | NotificationEnableType |
 | NotificationEnableTypeCollection |
 | NotificationEventPropertyNameCodeType |
 | NotificationEventPropertyType |
 | NotificationEventPropertyTypeCollection |
 | NotificationEventStateCodeType |
 | NotificationEventTypeCodeType |
 | NotificationMessageType |
 | NotificationPayloadTypeCodeType |
 | NotificationRoleCodeType |
 | NotificationStatisticsType |
 | NotificationUserDataType |
 | NumberOfPolicyViolationsDetailsType |
 | OfferType |
 | OfferTypeCollection |
 | OrderStatusCodeType |
 | OrderStatusFilterCodeType |
 | OrderTransactionType |
 | OrderTransactionTypeCollection |
 | OrderType |
 | OrderTypeCollection |
 | PaginatedItemArrayType |
 | PaginatedOrderTransactionArrayType |
 | PaginatedTransactionArrayType |
 | PaginationResultType |
 | PaginationType |
 | PaidStatusCodeType |
 | PaisaPayFullEscrowEnabledDefinitionType |
 | PaymentDetailsType |
 | PaymentHoldDetailType |
 | PaymentHoldReasonCodeType |
 | PaymentHoldStatusCodeType |
 | PaymentInformationType |
 | PaymentInstructionCodeType |
 | PaymentMethodDefinitionType |
 | PaymentMethodSearchCodeType |
 | PaymentOptionDetailsType |
 | PaymentOptionDetailsTypeCollection |
 | PaymentOptionsGroupEnabledCodeType |
 | PaymentOptionsGroupEnabledDefinitionType |
 | PaymentsInformationType |
 | PaymentStatusCodeType |
 | PaymentTransactionStatusCodeType |
 | PaymentTransactionType |
 | PaymentTransactionTypeCollection |
 | PaymentTypeCodeType |
 | PayoutMethodType |
 | PayPalAccountLevelCodeType |
 | PayPalAccountStatusCodeType |
 | PayPalAccountTypeCodeType |
 | PayPalBuyerProtectionEnabledDefinitionType |
 | PayPalRequiredDefinitionType |
 | PayPalRequiredForStoreOwnerDefinitionType |
 | PerformanceDashboardType |
 | PerformanceDashboardTypeCollection |
 | PerformanceStatusCodeType |
 | PeriodCodeType |
 | PhotoDisplayCodeType |
 | PickupDetailsType |
 | PickupDropOffEnabledDefinitionType |
 | PickupInStoreDetailsType |
 | PickupMethodSelectedType |
 | PickupOptionsType |
 | PickupOptionsTypeCollection |
 | PickupStatusCodeType |
 | PictureDetailsType |
 | PictureFormatCodeType |
 | PictureSetCodeType |
 | PictureSetMemberType |
 | PictureSetMemberTypeCollection |
 | PictureSourceCodeType |
 | PicturesType |
 | PicturesTypeCollection |
 | PictureUploadPolicyCodeType |
 | PictureURLsType |
 | PictureURLsTypeCollection |
 | PictureWatermarkCodeType |
 | PictureWatermarkCodeTypeCollection |
 | PlaceOfferRequestType |
 | PlaceOfferResponseType |
 | PolicyComplianceDashboardType |
 | PolicyComplianceStatusCodeType |
 | PolicyViolationDurationDetailsType |
 | PolicyViolationDurationDetailsTypeCollection |
 | PowerSellerDashboardType |
 | PreferredLocationCodeType |
 | PremiumSubscriptionDefinitionType |
 | PricingTreatmentCodeType |
 | ProductCreationEnabledCodeType |
 | ProductCreationEnabledDefinitionType |
 | ProductDetailsType |
 | ProductIdentiferEnabledCodeType |
 | ProductListingDetailsType |
 | ProductSuggestionsType |
 | ProductSuggestionType |
 | ProductSuggestionTypeCollection |
 | ProductType |
 | ProductTypeCollection |
 | ProductUseCaseCodeType |
 | ProfileCategoryGroupCodeType |
 | ProfileCategoryGroupDefinitionType |
 | PromotedItemType |
 | PromotedItemTypeCollection |
 | PromotionalSaleDetailsType |
 | PromotionalSaleStatusCodeType |
 | PromotionalSaleStatusCodeTypeCollection |
 | PromotionalSaleType |
 | PromotionalSaleTypeCodeType |
 | PromotionalSaleTypeCollection |
 | PromotionalShippingDiscountDetailsType |
 | PromotionDetailsType |
 | PromotionDetailsTypeCollection |
 | PromotionItemPriceTypeCodeType |
 | PromotionItemSelectionCodeType |
 | PromotionMethodCodeType |
 | PromotionSchemeCodeType |
 | ProPackCodeType |
 | ProPackEnabledDefinitionType |
 | ProPackPlusEnabledDefinitionType |
 | ProStoresCheckoutPreferenceType |
 | ProStoresDetailsType |
 | PurchaseReminderEmailPreferencesType |
 | QuantityAvailableHintCodeType |
 | QuantityInfoType |
 | QuantityOperatorCodeType |
 | QuantityRestrictionPerBuyerInfoType |
 | QuestionTypeCodeType |
 | RateTableDetailsType |
 | RCSPaymentStatusCodeType |
 | ReasonCodeDetailType |
 | ReasonCodeDetailTypeCollection |
 | ReasonHideFromSearchCodeType |
 | RecipientRelationCodeType |
 | RecommendationsType |
 | RecommendationsTypeCollection |
 | RecommendationValidationRulesType |
 | RecoupmentPolicyConsentType |
 | RecoupmentPolicyDetailsType |
 | RecoupmentPolicyDetailsTypeCollection |
 | RefundDetailsType |
 | RefundDetailsTypeCollection |
 | RefundFailureCodeType |
 | RefundFailureReasonType |
 | RefundFundingSourceArrayType |
 | RefundFundingSourceType |
 | RefundFundingSourceTypeCollection |
 | RefundInformationType |
 | RefundingSourceTypeCodeType |
 | RefundLineArrayType |
 | RefundLineType |
 | RefundLineTypeCodeType |
 | RefundLineTypeCollection |
 | RefundReasonCodeType |
 | RefundSourceTypeCodeType |
 | RefundStatusCodeType |
 | RefundTransactionArrayType |
 | RefundTransactionInfoType |
 | RefundTransactionInfoTypeCollection |
 | RefundTransactionType |
 | RefundTransactionTypeCollection |
 | RefundType |
 | RefundTypeCodeType |
 | RefundTypeCollection |
 | RegionDetailsType |
 | RegionDetailsTypeCollection |
 | RegionOfOriginDetailsType |
 | RegionOfOriginDetailsTypeCollection |
 | RegularSubscriptionDefinitionType |
 | RelistFixedPriceItemRequestType |
 | RelistFixedPriceItemResponseType |
 | RelistItemRequestType |
 | RelistItemResponseType |
 | ReminderCustomizationType |
 | RemindersType |
 | RemoveFromWatchListRequestType |
 | RemoveFromWatchListResponseType |
 | RequiredSellerActionCodeType |
 | RequiredSellerActionCodeTypeCollection |
 | RespondToBestOfferRequestType |
 | RespondToBestOfferResponseType |
 | RespondToFeedbackRequestType |
 | RespondToFeedbackResponseType |
 | RestockingFeeValueDetailsType |
 | RestockingFeeValueDetailsTypeCollection |
 | ReturnPolicyDetailsType |
 | ReturnPolicyEnabledDefinitionType |
 | ReturnPolicyType |
 | ReturnsAcceptedDetailsType |
 | ReturnsAcceptedDetailsTypeCollection |
 | ReturnStatusCodeType |
 | ReturnsWithinDetailsType |
 | ReturnsWithinDetailsTypeCollection |
 | ReviseCheckoutStatusRequestType |
 | ReviseCheckoutStatusResponseType |
 | ReviseFixedPriceItemRequestType |
 | ReviseFixedPriceItemResponseType |
 | ReviseInventoryStatusRequestType |
 | ReviseInventoryStatusResponseType |
 | ReviseItemRequestType |
 | ReviseItemResponseType |
 | ReviseMyMessagesFoldersRequestType |
 | ReviseMyMessagesFoldersResponseType |
 | ReviseMyMessagesRequestType |
 | ReviseMyMessagesResponseType |
 | RevisePriceAllowedDefinitionType |
 | ReviseQuantityAllowedDefinitionType |
 | ReviseSellingManagerInventoryFolderRequestType |
 | ReviseSellingManagerInventoryFolderResponseType |
 | ReviseSellingManagerProductRequestType |
 | ReviseSellingManagerProductResponseType |
 | ReviseSellingManagerSaleRecordRequestType |
 | ReviseSellingManagerSaleRecordResponseType |
 | ReviseSellingManagerTemplateRequestType |
 | ReviseSellingManagerTemplateResponseType |
 | ReviseStatusType |
 | RevokeTokenRequestType |
 | RevokeTokenResponseType |
 | SafePaymentRequiredDefinitionType |
 | SalesTaxType |
 | SaveItemToSellingManagerTemplateRequestType |
 | SaveItemToSellingManagerTemplateResponseType |
 | SchedulingInfoType |
 | SearchDetailsType |
 | SearchFlagCodeType |
 | SearchFlagCodeTypeCollection |
 | SearchStandingDashboardType |
 | SearchStandingStatusCodeType |
 | SecondChanceOfferDurationCodeType |
 | SelectionModeCodeType |
 | SellerAccountDashboardType |
 | SellerAccountStatusCodeType |
 | SellerBusinessCodeType |
 | SellerContactDetailsEnabledDefinitionType |
 | SellerDashboardAlertSeverityCodeType |
 | SellerDashboardAlertType |
 | SellerDashboardAlertTypeCollection |
 | SellerDiscountsType |
 | SellerDiscountType |
 | SellerDiscountTypeCollection |
 | SellereBayPaymentProcessConsentCodeType |
 | SellereBayPaymentProcessStatusCodeType |
 | SellerExcludeShipToLocationPreferencesType |
 | SellerFavoriteItemPreferencesType |
 | SellerFeeDiscountDashboardType |
 | SellerGuaranteeLevelCodeType |
 | SellerLevelCodeType |
 | SellerPaymentMethodCodeType |
 | SellerPaymentPreferencesType |
 | SellerPaymentProfileType |
 | SellerPaymentType |
 | SellerPaymentTypeCollection |
 | SellerProfilePreferencesType |
 | SellerProfilesType |
 | SellerProvidedTitleSupportedDefinitionType |
 | SellerReturnPreferencesType |
 | SellerReturnProfileType |
 | SellerReverseDisputeRequestType |
 | SellerReverseDisputeResponseType |
 | SellerRoleMetricsType |
 | SellerShippingProfileType |
 | SellerType |
 | SellingManagerAlertType |
 | SellingManagerAlertTypeCodeType |
 | SellingManagerAlertTypeCollection |
 | SellingManagerAutoListAccordingToScheduleType |
 | SellingManagerAutoListMinActiveItemsType |
 | SellingManagerAutoListType |
 | SellingManagerAutomationPropertyTypeCodeType |
 | SellingManagerAutoRelistOptionCodeType |
 | SellingManagerAutoRelistType |
 | SellingManagerAutoRelistTypeCodeType |
 | SellingManagerAutoSecondChanceOfferType |
 | SellingManagerAutoSecondChanceOfferTypeCodeType |
 | SellingManagerEmailLogType |
 | SellingManagerEmailLogTypeCollection |
 | SellingManagerEmailSentStatusCodeType |
 | SellingManagerEmailTypeCodeType |
 | SellingManagerFolderDetailsType |
 | SellingManagerFolderDetailsTypeCollection |
 | SellingManagerGeneralPropertyTypeCodeType |
 | SellingManagerInventoryPropertyTypeCodeType |
 | SellingManagerInventoryPropertyTypeCodeTypeCollection |
 | SellingManagerOrderStatusType |
 | SellingManagerPaidStatusCodeType |
 | SellingManagerPaisaPayPropertyTypeCodeType |
 | SellingManagerProductDetailsType |
 | SellingManagerProductInventoryStatusType |
 | SellingManagerProductSortCodeType |
 | SellingManagerProductSpecificsType |
 | SellingManagerProductType |
 | SellingManagerProductTypeCollection |
 | SellingManagerSearchType |
 | SellingManagerSearchTypeCodeType |
 | SellingManagerShippedStatusCodeType |
 | SellingManagerSoldListingsPropertyTypeCodeType |
 | SellingManagerSoldListingsPropertyTypeCodeTypeCollection |
 | SellingManagerSoldListingsSortTypeCodeType |
 | SellingManagerSoldOrderType |
 | SellingManagerSoldOrderTypeCollection |
 | SellingManagerSoldTransactionType |
 | SellingManagerSoldTransactionTypeCollection |
 | SellingManagerTemplateDetailsType |
 | SellingManagerTemplateDetailsTypeCollection |
 | SellingManagerVendorDetailsType |
 | SellingStatusType |
 | SellingSummaryType |
 | SendInvoiceRequestType |
 | SendInvoiceResponseType |
 | SetMessagePreferencesRequestType |
 | SetMessagePreferencesResponseType |
 | SetNotificationPreferencesRequestType |
 | SetNotificationPreferencesResponseType |
 | SetPromotionalSaleListingsRequestType |
 | SetPromotionalSaleListingsResponseType |
 | SetPromotionalSaleRequestType |
 | SetPromotionalSaleResponseType |
 | SetSellingManagerFeedbackOptionsRequestType |
 | SetSellingManagerFeedbackOptionsResponseType |
 | SetSellingManagerItemAutomationRuleRequestType |
 | SetSellingManagerItemAutomationRuleResponseType |
 | SetSellingManagerTemplateAutomationRuleRequestType |
 | SetSellingManagerTemplateAutomationRuleResponseType |
 | SetShippingDiscountProfilesRequestType |
 | SetShippingDiscountProfilesResponseType |
 | SetStoreCategoriesRequestType |
 | SetStoreCategoriesResponseType |
 | SetStoreCustomPageRequestType |
 | SetStoreCustomPageResponseType |
 | SetStorePreferencesRequestType |
 | SetStorePreferencesResponseType |
 | SetStoreRequestType |
 | SetStoreResponseType |
 | SetTaxTableRequestType |
 | SetTaxTableResponseType |
 | SetUserNotesActionCodeType |
 | SetUserNotesRequestType |
 | SetUserNotesResponseType |
 | SetUserPreferencesRequestType |
 | SetUserPreferencesResponseType |
 | SeverityCodeType |
 | ShipmentDeliveryStatusCodeType |
 | ShipmentLineItemType |
 | ShipmentStatusCodeType |
 | ShipmentTrackingDetailsType |
 | ShipmentTrackingDetailsTypeCollection |
 | ShipmentType |
 | ShipPackageDetailsType |
 | ShippingCarrierCodeType |
 | ShippingCarrierCodeTypeCollection |
 | ShippingCarrierDetailsType |
 | ShippingCarrierDetailsTypeCollection |
 | ShippingCategoryDetailsType |
 | ShippingCategoryDetailsTypeCollection |
 | ShippingCostPaidByDetailsType |
 | ShippingCostPaidByDetailsTypeCollection |
 | ShippingDetailsType |
 | ShippingFeatureCodeType |
 | ShippingFeatureCodeTypeCollection |
 | ShippingInsuranceType |
 | ShippingLocationDetailsType |
 | ShippingLocationDetailsTypeCollection |
 | ShippingOverrideType |
 | ShippingPackageCodeType |
 | ShippingPackageCodeTypeCollection |
 | ShippingPackageDetailsType |
 | ShippingPackageDetailsTypeCollection |
 | ShippingPackageInfoType |
 | ShippingPackageInfoTypeCollection |
 | ShippingRateTypeCodeType |
 | ShippingRegionCodeType |
 | ShippingRegionCodeTypeCollection |
 | ShippingServiceCodeType |
 | ShippingServiceCostOverrideListType |
 | ShippingServiceCostOverrideType |
 | ShippingServiceCostOverrideTypeCollection |
 | ShippingServiceDetailsType |
 | ShippingServiceDetailsTypeCollection |
 | ShippingServiceOptionsType |
 | ShippingServiceOptionsTypeCollection |
 | ShippingServicePackageDetailsType |
 | ShippingServicePackageDetailsTypeCollection |
 | ShippingServiceType |
 | ShippingTermRequiredDefinitionType |
 | ShippingTypeCodeType |
 | ShippingTypeCodeTypeCollection |
 | SimpleItemSortCodeType |
 | SiteBuyerRequirementDetailsType |
 | SiteBuyerRequirementDetailsTypeCollection |
 | SiteCodeType |
 | SiteCodeTypeCollection |
 | SiteDefaultsType |
 | SiteDetailsType |
 | SiteDetailsTypeCollection |
 | SiteHostedPictureDetailsType |
 | SkypeContactOptionCodeType |
 | SkypeContactOptionCodeTypeCollection |
 | SkypeMeNonTransactionalEnabledDefinitionType |
 | SkypeMeTransactionalEnabledDefinitionType |
 | SMSSubscriptionErrorCodeCodeType |
 | SMSSubscriptionType |
 | SMSSubscriptionUserStatusCodeType |
 | SoapExtensionEx |
 | SoapExtensionExAttribute |
 | SoapHttpClientProtocolEx |
 | SocialAddressTypeCodeType |
 | SortOrderCodeType |
 | SpecialitySubscriptionDefinitionType |
 | StatusCodeType |
 | StoreCategoryUpdateActionCodeType |
 | StoreColorSchemeType |
 | StoreColorSchemeTypeCollection |
 | StoreColorType |
 | StoreCustomCategoryType |
 | StoreCustomCategoryTypeCollection |
 | StoreCustomHeaderLayoutCodeType |
 | StoreCustomListingHeaderDisplayCodeType |
 | StoreCustomListingHeaderLinkCodeType |
 | StoreCustomListingHeaderLinkType |
 | StoreCustomListingHeaderLinkTypeCollection |
 | StoreCustomListingHeaderType |
 | StoreCustomPageStatusCodeType |
 | StoreCustomPageType |
 | StoreCustomPageTypeCollection |
 | StoreFontFaceCodeType |
 | StoreFontSizeCodeType |
 | StoreFontType |
 | StorefrontType |
 | StoreHeaderStyleCodeType |
 | StoreInventoryEnabledDefinitionType |
 | StoreItemListLayoutCodeType |
 | StoreItemListSortOrderCodeType |
 | StoreLogoType |
 | StoreLogoTypeCollection |
 | StoreOwnerExtendedListingDurationsDefinitionType |
 | StoreOwnerExtendedListingDurationsEnabledDefinitionType |
 | StoreOwnerExtendedListingDurationsType |
 | StorePreferencesType |
 | StoreSubscriptionLevelCodeType |
 | StoreSubscriptionType |
 | StoreSubscriptionTypeCollection |
 | StoreThemeArrayType |
 | StoreThemeType |
 | StoreThemeTypeCollection |
 | StoreType |
 | StoreVacationPreferencesType |
 | StringCollection |
 | StringMatchCodeType |
 | SuggestedBidValueType |
 | SuggestedCategoryArrayType |
 | SuggestedCategoryType |
 | SuggestedCategoryTypeCollection |
 | SummaryEventScheduleType |
 | SummaryEventScheduleTypeCollection |
 | SummaryFrequencyCodeType |
 | SummaryWindowPeriodCodeType |
 | SupportedSellerProfileType |
 | SupportedSellerProfileTypeCollection |
 | TaskStatusCodeType |
 | TaxDescriptionCodeType |
 | TaxDetailsType |
 | TaxDetailsTypeCollection |
 | TaxesType |
 | TaxIdentifierAttributeCodeType |
 | TaxIdentifierAttributeType |
 | TaxIdentifierAttributeTypeCollection |
 | TaxIdentifierType |
 | TaxIdentifierTypeCollection |
 | TaxJurisdictionType |
 | TaxJurisdictionTypeCollection |
 | TaxTypeCodeType |
 | TCREnabledDefinitionType |
 | ThemeGroupType |
 | ThemeGroupTypeCollection |
 | TicketListingDetailsType |
 | TimeFilter | This class enables specification of time values for DateTime fields. Information and tips about DateTime objects are available in the MSDN library. This class contains properties for both local and GMT (UTC) time. If you use such properties of this class interchangably, the last property that is set overwrites the previous one. Note that if only the properties for local time are used, then the following can occur with an application: A local time (for example, 10 a.m.) is emitted by an application, and the API changes that time to GMT (for example, to 5 p.m.). And a GMT time from the API (for example, 1 p.m.) received by an application is converted to local time (for example, to 6 a.m.).
 | TimeRangeType |
 | TimeZoneDetailsType |
 | TimeZoneDetailsTypeCollection |
 | TokenStatusCodeType |
 | TokenStatusType |
 | TopRatedProgramCodeType |
 | TopRatedProgramCodeTypeCollection |
 | TopRatedSellerDetailsType |
 | TradingRoleCodeType |
 | TransactionPlatformCodeType |
 | TransactionPlatformCodeTypeCollection |
 | TransactionReferenceCodeType |
 | TransactionReferenceType |
 | TransactionReferenceTypeCollection |
 | TransactionStatusType |
 | TransactionType |
 | TransactionTypeCollection |
 | TypeCollection |
 | UnitInfoType |
 | UnitOfMeasurementDetailsType |
 | UnitOfMeasurementDetailsTypeCollection |
 | UnitOfMeasurementType |
 | UnitOfMeasurementTypeCollection |
 | UnpaidItemAssistancePreferencesType |
 | UnpaidItemCaseOpenTypeCodeType |
 | UnpaidItemCaseStatusTypeCodeType |
 | UnpaidItemStatusTypeCodeType |
 | UnpaidItemType |
 | UPCEnabledDefinitionType |
 | UPCIdentifierEnabledDefinitionType |
 | UploadSiteHostedPicturesRequestType |
 | UploadSiteHostedPicturesResponseType |
 | UPSRateOptionCodeType |
 | URLDetailsType |
 | URLDetailsTypeCollection |
 | URLTypeCodeType |
 | UserAgreementInfoType |
 | UserAgreementInfoTypeCollection |
 | UserConsentRequiredDefinitionType |
 | UserDefinedListType |
 | UserDefinedListTypeCollection |
 | UserIDArrayType |
 | UserIdentityCodeType |
 | UserIdentityType |
 | UserIdPasswordType |
 | UserStatusCodeType |
 | UserType |
 | USPSRateOptionCodeType |
 | ValidateChallengeInputRequestType |
 | ValidateChallengeInputResponseType |
 | ValidateTestUserRegistrationRequestType |
 | ValidateTestUserRegistrationResponseType |
 | ValType |
 | ValTypeCollection |
 | ValueCategoryDefinitionType |
 | ValueFormatCodeType |
 | ValuePackEnabledDefinitionType |
 | ValueRecommendationType |
 | ValueRecommendationTypeCollection |
 | ValueTypeCodeType |
 | VariationDetailsType |
 | VariationKeyType |
 | VariationKeyTypeCollection |
 | VariationPictureRuleCodeType |
 | VariationProductListingDetailsType |
 | VariationsEnabledDefinitionType |
 | VariationSpecificPictureSetType |
 | VariationSpecificPictureSetTypeCollection |
 | VariationSpecificsRuleCodeType |
 | VariationsType |
 | VariationType |
 | VariationTypeCollection |
 | VATDetailsType |
 | VATRateType |
 | VATRateTypeCollection |
 | VATStatusCodeType |
 | VerifiedUserRequirementsDetailsType |
 | VerifiedUserRequirementsType |
 | VerifyAddFixedPriceItemRequestType |
 | VerifyAddFixedPriceItemResponseType |
 | VerifyAddItemRequestType |
 | VerifyAddItemResponseType |
 | VerifyAddSecondChanceItemRequestType |
 | VerifyAddSecondChanceItemResponseType |
 | VerifyRelistItemRequestType |
 | VerifyRelistItemResponseType |
 | VeROItemStatusCodeType |
 | VeROReportedItemType |
 | VeROReportedItemTypeCollection |
 | VeROReportItemsRequestType |
 | VeROReportItemsResponseType |
 | VeROReportItemType |
 | VeROReportItemTypeCollection |
 | VeROReportPacketStatusCodeType |
 | VeROSiteDetailType |
 | VeROSiteDetailTypeCollection |
 | VINSupportedDefinitionType |
 | VRMSupportedDefinitionType |
 | WarningLevelCodeType |
 | WarrantyDurationDetailsType |
 | WarrantyDurationDetailsTypeCollection |
 | WarrantyOfferedDetailsType |
 | WarrantyOfferedDetailsTypeCollection |
 | WarrantyTypeDetailsType |
 | WarrantyTypeDetailsTypeCollection |
 | WirelessCarrierIDCodeType |
 | XmlElementCollection |


AbstractRequestType Class

AbstractRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public abstract class AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public MustInherit Class AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AbstractRequestType abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AbstractRequestType()()()() |
 | Any |
 | BotBlock |
 | DetailLevel |
 | EndUserIP |
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling |
 | ErrorHandlingSpecified |
 | ErrorLanguage |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID |
 | OutputSelector |
 | ToString()()()() | (Inherited from Object.)
 | Version |
 | WarningLevel |
 | WarningLevelSpecified |
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddDisputeRequestType
 |  | AddDisputeResponseRequestType
 |  | AddFixedPriceItemRequestType
 |  | AddItemFromSellingManagerTemplateRequestType
 |  | AddItemRequestType
 |  | AddItemsRequestType
 |  | AddMemberMessageAAQToPartnerRequestType
 |  | AddMemberMessageRTQRequestType
 |  | AddMemberMessagesAAQToBidderRequestType
 |  | AddOrderRequestType
 |  | AddSecondChanceItemRequestType
 |  | AddSellingManagerInventoryFolderRequestType
 |  | AddSellingManagerProductRequestType
 |  | AddSellingManagerTemplateRequestType
 |  | AddToItemDescriptionRequestType
 |  | AddToWatchListRequestType
 |  | AddTransactionConfirmationItemRequestType
 |  | CompleteSaleRequestType
 |  | ConfirmIdentityRequestType
 |  | DeleteMyMessagesRequestType
 |  | DeleteSellingManagerInventoryFolderRequestType
 |  | DeleteSellingManagerItemAutomationRuleRequestType
 |  | DeleteSellingManagerProductRequestType
 |  | DeleteSellingManagerTemplateAutomationRuleRequestType
 |  | DeleteSellingManagerTemplateRequestType
 |  | DisableUnpaidItemAssistanceRequestType
 |  | EndFixedPriceItemRequestType
 |  | EndItemRequestType
 |  | EndItemsRequestType
 |  | ExtendSiteHostedPicturesRequestType
 |  | FetchTokenRequestType
 |  | GetAccountRequestType
 |  | GetAdFormatLeadsRequestType
 |  | GetAllBiddersRequestType
 |  | GetApiAccessRulesRequestType
 |  | GetBestOffersRequestType
 |  | GetBidderListRequestType
 |  | GetCategoriesRequestType
 |  | GetCategoryFeaturesRequestType
 |  | GetCategoryMappingsRequestType
 |  | GetCategorySpecificsRequestType
 |  | GetChallengeTokenRequestType
 |  | GetCharitiesRequestType
 |  | GetClientAlertsAuthTokenRequestType
 |  | GetContextualKeywordsRequestType
 |  | GetDescriptionTemplatesRequestType
 |  | GetDisputeRequestType
 |  | GeteBayDetailsRequestType
 |  | GeteBayOfficialTimeRequestType
 |  | GetFeedbackRequestType
 |  | GetItemRequestType
 |  | GetItemsAwaitingFeedbackRequestType
 |  | GetItemShippingRequestType
 |  | GetItemTransactionsRequestType
 |  | GetMemberMessagesRequestType
 |  | GetMessagePreferencesRequestType
 |  | GetMyeBayBuyingRequestType
 |  | GetMyeBayRemindersRequestType
 |  | GetMyeBaySellingRequestType
 |  | GetMyMessagesRequestType
 |  | GetNotificationPreferencesRequestType
 |  | GetNotificationsUsageRequestType
 |  | GetOrdersRequestType
 |  | GetOrderTransactionsRequestType
 |  | GetProductSellingPagesRequestType
 |  | GetPromotionalSaleDetailsRequestType
 |  | GetSellerDashboardRequestType
 |  | GetSellerEventsRequestType
 |  | GetSellerListRequestType
 |  | GetSellerPaymentsRequestType
 |  | GetSellerTransactionsRequestType
 |  | GetSellingManagerAlertsRequestType
 |  | GetSellingManagerEmailLogRequestType
 |  | GetSellingManagerInventoryFolderRequestType
 |  | GetSellingManagerInventoryRequestType
 |  | GetSellingManagerItemAutomationRuleRequestType
 |  | GetSellingManagerSaleRecordRequestType
 |  | GetSellingManagerSoldListingsRequestType
 |  | GetSellingManagerTemplateAutomationRuleRequestType
 |  | GetSellingManagerTemplatesRequestType
 |  | GetSessionIDRequestType
 |  | GetShippingDiscountProfilesRequestType
 |  | GetStoreCategoryUpdateStatusRequestType
 |  | GetStoreCustomPageRequestType
 |  | GetStoreOptionsRequestType
 |  | GetStorePreferencesRequestType
 |  | GetStoreRequestType
 |  | GetSuggestedCategoriesRequestType
 |  | GetTaxTableRequestType
 |  | GetTokenStatusRequestType
 |  | GetUserContactDetailsRequestType
 |  | GetUserDisputesRequestType
 |  | GetUserPreferencesRequestType
 |  | GetUserRequestType
 |  | GetVeROReasonCodeDetailsRequestType
 |  | GetVeROReportStatusRequestType
 |  | IssueRefundRequestType
 |  | LeaveFeedbackRequestType
 |  | MoveSellingManagerInventoryFolderRequestType
 |  | PlaceOfferRequestType
 |  | RelistFixedPriceItemRequestType
 |  | RelistItemRequestType
 |  | RemoveFromWatchListRequestType
 |  | RespondToBestOfferRequestType
 |  | RespondToFeedbackRequestType
 |  | ReviseCheckoutStatusRequestType
 |  | ReviseFixedPriceItemRequestType
 |  | ReviseInventoryStatusRequestType
 |  | ReviseItemRequestType
 |  | ReviseMyMessagesFoldersRequestType
 |  | ReviseMyMessagesRequestType
 |  | ReviseSellingManagerInventoryFolderRequestType
 |  | ReviseSellingManagerProductRequestType
 |  | ReviseSellingManagerSaleRecordRequestType
 |  | ReviseSellingManagerTemplateRequestType
 |  | RevokeTokenRequestType
 |  | SaveItemToSellingManagerTemplateRequestType
 |  | SellerReverseDisputeRequestType
 |  | SendInvoiceRequestType
 |  | SetMessagePreferencesRequestType
 |  | SetNotificationPreferencesRequestType
 |  | SetPromotionalSaleListingsRequestType
 |  | SetPromotionalSaleRequestType
 |  | SetSellingManagerFeedbackOptionsRequestType
 |  | SetSellingManagerItemAutomationRuleRequestType
 |  | SetSellingManagerTemplateAutomationRuleRequestType
 |  | SetShippingDiscountProfilesRequestType
 |  | SetStoreCategoriesRequestType
 |  | SetStoreCustomPageRequestType
 |  | SetStorePreferencesRequestType
 |  | SetStoreRequestType
 |  | SetTaxTableRequestType
 |  | SetUserNotesRequestType
 |  | SetUserPreferencesRequestType
 |  | UploadSiteHostedPicturesRequestType
 |  | ValidateChallengeInputRequestType
 |  | ValidateTestUserRegistrationRequestType
 |  | VerifyAddFixedPriceItemRequestType
 |  | VerifyAddItemRequestType
 |  | VerifyAddSecondChanceItemRequestType
 |  | VerifyRelistItemRequestType
 |  | VeROReportItemsRequestType


AbstractRequestType Constructor

AbstractRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► AbstractRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected AbstractRequestType()
Protected Sub New
protected:
AbstractRequestType()


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BotBlock Property

BotBlock Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► BotBlock
Declaration Syntax
C# Visual Basic Visual C++
public BotBlockRequestType BotBlock { get; set; }
Public Property BotBlock As BotBlockRequestType
    Get
    Set
public:
property BotBlockRequestType^ BotBlock {
    BotBlockRequestType^ get ();
    void set (BotBlockRequestType^ value);
}


DetailLevel Property

DetailLevel Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► DetailLevel
Declaration Syntax
C# Visual Basic Visual C++
public DetailLevelCodeTypeCollection DetailLevel { get; set; }
Public Property DetailLevel As DetailLevelCodeTypeCollection
    Get
    Set
public:
property DetailLevelCodeTypeCollection^ DetailLevel {
    DetailLevelCodeTypeCollection^ get ();
    void set (DetailLevelCodeTypeCollection^ value);
}


EndUserIP Property

EndUserIP Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► EndUserIP
Declaration Syntax
C# Visual Basic Visual C++
public string EndUserIP { get; set; }
Public Property EndUserIP As String
    Get
    Set
public:
property String^ EndUserIP {
    String^ get ();
    void set (String^ value);
}


ErrorHandling Property

ErrorHandling Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► ErrorHandling
Declaration Syntax
C# Visual Basic Visual C++
public ErrorHandlingCodeType ErrorHandling { get; set; }
Public Property ErrorHandling As ErrorHandlingCodeType
    Get
    Set
public:
property ErrorHandlingCodeType ErrorHandling {
    ErrorHandlingCodeType get ();
    void set (ErrorHandlingCodeType value);
}


ErrorHandlingSpecified Property

ErrorHandlingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► ErrorHandlingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ErrorHandlingSpecified { get; set; }
Public Property ErrorHandlingSpecified As Boolean
    Get
    Set
public:
property bool ErrorHandlingSpecified {
    bool get ();
    void set (bool value);
}


ErrorLanguage Property

ErrorLanguage Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► ErrorLanguage
Declaration Syntax
C# Visual Basic Visual C++
public string ErrorLanguage { get; set; }
Public Property ErrorLanguage As String
    Get
    Set
public:
property String^ ErrorLanguage {
    String^ get ();
    void set (String^ value);
}


InvocationID Property

InvocationID Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► InvocationID
Declaration Syntax
C# Visual Basic Visual C++
public string InvocationID { get; set; }
Public Property InvocationID As String
    Get
    Set
public:
property String^ InvocationID {
    String^ get ();
    void set (String^ value);
}


MessageID Property

MessageID Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► MessageID
Declaration Syntax
C# Visual Basic Visual C++
public string MessageID { get; set; }
Public Property MessageID As String
    Get
    Set
public:
property String^ MessageID {
    String^ get ();
    void set (String^ value);
}


OutputSelector Property

OutputSelector Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► OutputSelector
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection OutputSelector { get; set; }
Public Property OutputSelector As StringCollection
    Get
    Set
public:
property StringCollection^ OutputSelector {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Version Property

Version Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► Version
Declaration Syntax
C# Visual Basic Visual C++
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}


WarningLevel Property

WarningLevel Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► WarningLevel
Declaration Syntax
C# Visual Basic Visual C++
public WarningLevelCodeType WarningLevel { get; set; }
Public Property WarningLevel As WarningLevelCodeType
    Get
    Set
public:
property WarningLevelCodeType WarningLevel {
    WarningLevelCodeType get ();
    void set (WarningLevelCodeType value);
}


WarningLevelSpecified Property

WarningLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AbstractRequestType ► WarningLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WarningLevelSpecified { get; set; }
Public Property WarningLevelSpecified As Boolean
    Get
    Set
public:
property bool WarningLevelSpecified {
    bool get ();
    void set (bool value);
}


AbstractResponseType Class

AbstractResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public abstract class AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public MustInherit Class AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AbstractResponseType abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AbstractResponseType()()()() |
 | Ack |
 | AckSpecified |
 | Any |
 | BotBlock |
 | Build |
 | CorrelationID |
 | DuplicateInvocationDetails |
 | EIASToken |
 | Equals(Object) | (Inherited from Object.)
 | Errors |
 | ExternalUserData |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message |
 | NotificationEventName |
 | NotificationSignature |
 | RecipientUserID |
 | Timestamp |
 | TimestampSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version |
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddDisputeResponseResponseType
 |  | AddDisputeResponseType
 |  | AddFixedPriceItemResponseType
 |  | AddItemFromSellingManagerTemplateResponseType
 |  | AddItemResponseType
 |  | AddItemsResponseType
 |  | AddMemberMessageAAQToPartnerResponseType
 |  | AddMemberMessageRTQResponseType
 |  | AddMemberMessagesAAQToBidderResponseType
 |  | AddOrderResponseType
 |  | AddSecondChanceItemResponseType
 |  | AddSellingManagerInventoryFolderResponseType
 |  | AddSellingManagerProductResponseType
 |  | AddSellingManagerTemplateResponseType
 |  | AddToItemDescriptionResponseType
 |  | AddToWatchListResponseType
 |  | AddTransactionConfirmationItemResponseType
 |  | CompleteSaleResponseType
 |  | ConfirmIdentityResponseType
 |  | DeleteMyMessagesResponseType
 |  | DeleteSellingManagerInventoryFolderResponseType
 |  | DeleteSellingManagerItemAutomationRuleResponseType
 |  | DeleteSellingManagerProductResponseType
 |  | DeleteSellingManagerTemplateAutomationRuleResponseType
 |  | DeleteSellingManagerTemplateResponseType
 |  | DisableUnpaidItemAssistanceResponseType
 |  | EndFixedPriceItemResponseType
 |  | EndItemResponseType
 |  | EndItemsResponseType
 |  | ExtendSiteHostedPicturesResponseType
 |  | FetchTokenResponseType
 |  | GetAccountResponseType
 |  | GetAdFormatLeadsResponseType
 |  | GetAllBiddersResponseType
 |  | GetApiAccessRulesResponseType
 |  | GetBestOffersResponseType
 |  | GetBidderListResponseType
 |  | GetCategoriesResponseType
 |  | GetCategoryFeaturesResponseType
 |  | GetCategoryMappingsResponseType
 |  | GetCategorySpecificsResponseType
 |  | GetChallengeTokenResponseType
 |  | GetCharitiesResponseType
 |  | GetClientAlertsAuthTokenResponseType
 |  | GetContextualKeywordsResponseType
 |  | GetDescriptionTemplatesResponseType
 |  | GetDisputeResponseType
 |  | GeteBayDetailsResponseType
 |  | GeteBayOfficialTimeResponseType
 |  | GetFeedbackResponseType
 |  | GetItemResponseType
 |  | GetItemsAwaitingFeedbackResponseType
 |  | GetItemShippingResponseType
 |  | GetItemTransactionsResponseType
 |  | GetMemberMessagesResponseType
 |  | GetMessagePreferencesResponseType
 |  | GetMyeBayBuyingResponseType
 |  | GetMyeBayRemindersResponseType
 |  | GetMyeBaySellingResponseType
 |  | GetMyMessagesResponseType
 |  | GetNotificationPreferencesResponseType
 |  | GetNotificationsUsageResponseType
 |  | GetOrdersResponseType
 |  | GetOrderTransactionsResponseType
 |  | GetProductSellingPagesResponseType
 |  | GetPromotionalSaleDetailsResponseType
 |  | GetSellerDashboardResponseType
 |  | GetSellerEventsResponseType
 |  | GetSellerListResponseType
 |  | GetSellerPaymentsResponseType
 |  | GetSellerTransactionsResponseType
 |  | GetSellingManagerAlertsResponseType
 |  | GetSellingManagerEmailLogResponseType
 |  | GetSellingManagerInventoryFolderResponseType
 |  | GetSellingManagerInventoryResponseType
 |  | GetSellingManagerItemAutomationRuleResponseType
 |  | GetSellingManagerSaleRecordResponseType
 |  | GetSellingManagerSoldListingsResponseType
 |  | GetSellingManagerTemplateAutomationRuleResponseType
 |  | GetSellingManagerTemplatesResponseType
 |  | GetSessionIDResponseType
 |  | GetShippingDiscountProfilesResponseType
 |  | GetStoreCategoryUpdateStatusResponseType
 |  | GetStoreCustomPageResponseType
 |  | GetStoreOptionsResponseType
 |  | GetStorePreferencesResponseType
 |  | GetStoreResponseType
 |  | GetSuggestedCategoriesResponseType
 |  | GetTaxTableResponseType
 |  | GetTokenStatusResponseType
 |  | GetUserContactDetailsResponseType
 |  | GetUserDisputesResponseType
 |  | GetUserPreferencesResponseType
 |  | GetUserResponseType
 |  | GetVeROReasonCodeDetailsResponseType
 |  | GetVeROReportStatusResponseType
 |  | IssueRefundResponseType
 |  | ItemsCanceledEventType
 |  | LeaveFeedbackResponseType
 |  | MoveSellingManagerInventoryFolderResponseType
 |  | NotificationMessageType
 |  | PlaceOfferResponseType
 |  | RelistFixedPriceItemResponseType
 |  | RelistItemResponseType
 |  | RemoveFromWatchListResponseType
 |  | RespondToBestOfferResponseType
 |  | RespondToFeedbackResponseType
 |  | ReviseCheckoutStatusResponseType
 |  | ReviseFixedPriceItemResponseType
 |  | ReviseInventoryStatusResponseType
 |  | ReviseItemResponseType
 |  | ReviseMyMessagesFoldersResponseType
 |  | ReviseMyMessagesResponseType
 |  | ReviseSellingManagerInventoryFolderResponseType
 |  | ReviseSellingManagerProductResponseType
 |  | ReviseSellingManagerSaleRecordResponseType
 |  | ReviseSellingManagerTemplateResponseType
 |  | RevokeTokenResponseType
 |  | SaveItemToSellingManagerTemplateResponseType
 |  | SellerReverseDisputeResponseType
 |  | SendInvoiceResponseType
 |  | SetMessagePreferencesResponseType
 |  | SetNotificationPreferencesResponseType
 |  | SetPromotionalSaleListingsResponseType
 |  | SetPromotionalSaleResponseType
 |  | SetSellingManagerFeedbackOptionsResponseType
 |  | SetSellingManagerItemAutomationRuleResponseType
 |  | SetSellingManagerTemplateAutomationRuleResponseType
 |  | SetShippingDiscountProfilesResponseType
 |  | SetStoreCategoriesResponseType
 |  | SetStoreCustomPageResponseType
 |  | SetStorePreferencesResponseType
 |  | SetStoreResponseType
 |  | SetTaxTableResponseType
 |  | SetUserNotesResponseType
 |  | SetUserPreferencesResponseType
 |  | UploadSiteHostedPicturesResponseType
 |  | ValidateChallengeInputResponseType
 |  | ValidateTestUserRegistrationResponseType
 |  | VerifyAddFixedPriceItemResponseType
 |  | VerifyAddItemResponseType
 |  | VerifyAddSecondChanceItemResponseType
 |  | VerifyRelistItemResponseType
 |  | VeROReportItemsResponseType


AbstractResponseType Constructor

AbstractResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► AbstractResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected AbstractResponseType()
Protected Sub New
protected:
AbstractResponseType()


Ack Property

Ack Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► Ack
Declaration Syntax
C# Visual Basic Visual C++
public AckCodeType Ack { get; set; }
Public Property Ack As AckCodeType
    Get
    Set
public:
property AckCodeType Ack {
    AckCodeType get ();
    void set (AckCodeType value);
}


AckSpecified Property

AckSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► AckSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AckSpecified { get; set; }
Public Property AckSpecified As Boolean
    Get
    Set
public:
property bool AckSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BotBlock Property

BotBlock Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► BotBlock
Declaration Syntax
C# Visual Basic Visual C++
public BotBlockResponseType BotBlock { get; set; }
Public Property BotBlock As BotBlockResponseType
    Get
    Set
public:
property BotBlockResponseType^ BotBlock {
    BotBlockResponseType^ get ();
    void set (BotBlockResponseType^ value);
}


Build Property

Build Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► Build
Declaration Syntax
C# Visual Basic Visual C++
public string Build { get; set; }
Public Property Build As String
    Get
    Set
public:
property String^ Build {
    String^ get ();
    void set (String^ value);
}


CorrelationID Property

CorrelationID Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► CorrelationID
Declaration Syntax
C# Visual Basic Visual C++
public string CorrelationID { get; set; }
Public Property CorrelationID As String
    Get
    Set
public:
property String^ CorrelationID {
    String^ get ();
    void set (String^ value);
}


DuplicateInvocationDetails Property

DuplicateInvocationDetails Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► DuplicateInvocationDetails
Declaration Syntax
C# Visual Basic Visual C++
public DuplicateInvocationDetailsType DuplicateInvocationDetails { get; set; }
Public Property DuplicateInvocationDetails As DuplicateInvocationDetailsType
    Get
    Set
public:
property DuplicateInvocationDetailsType^ DuplicateInvocationDetails {
    DuplicateInvocationDetailsType^ get ();
    void set (DuplicateInvocationDetailsType^ value);
}


EIASToken Property

EIASToken Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► EIASToken
Declaration Syntax
C# Visual Basic Visual C++
public string EIASToken { get; set; }
Public Property EIASToken As String
    Get
    Set
public:
property String^ EIASToken {
    String^ get ();
    void set (String^ value);
}


Errors Property

Errors Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► Errors
Declaration Syntax
C# Visual Basic Visual C++
public ErrorTypeCollection Errors { get; set; }
Public Property Errors As ErrorTypeCollection
    Get
    Set
public:
property ErrorTypeCollection^ Errors {
    ErrorTypeCollection^ get ();
    void set (ErrorTypeCollection^ value);
}


ExternalUserData Property

ExternalUserData Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► ExternalUserData
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalUserData { get; set; }
Public Property ExternalUserData As String
    Get
    Set
public:
property String^ ExternalUserData {
    String^ get ();
    void set (String^ value);
}


HardExpirationWarning Property

HardExpirationWarning Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► HardExpirationWarning
Declaration Syntax
C# Visual Basic Visual C++
public string HardExpirationWarning { get; set; }
Public Property HardExpirationWarning As String
    Get
    Set
public:
property String^ HardExpirationWarning {
    String^ get ();
    void set (String^ value);
}


Message Property

Message Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► Message
Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


NotificationEventName Property

NotificationEventName Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► NotificationEventName
Declaration Syntax
C# Visual Basic Visual C++
public string NotificationEventName { get; set; }
Public Property NotificationEventName As String
    Get
    Set
public:
property String^ NotificationEventName {
    String^ get ();
    void set (String^ value);
}


NotificationSignature Property

NotificationSignature Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► NotificationSignature
Declaration Syntax
C# Visual Basic Visual C++
public string NotificationSignature { get; set; }
Public Property NotificationSignature As String
    Get
    Set
public:
property String^ NotificationSignature {
    String^ get ();
    void set (String^ value);
}


RecipientUserID Property

RecipientUserID Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► RecipientUserID
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientUserID { get; set; }
Public Property RecipientUserID As String
    Get
    Set
public:
property String^ RecipientUserID {
    String^ get ();
    void set (String^ value);
}


Timestamp Property

Timestamp Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► Timestamp
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}


TimestampSpecified Property

TimestampSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► TimestampSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TimestampSpecified { get; set; }
Public Property TimestampSpecified As Boolean
    Get
    Set
public:
property bool TimestampSpecified {
    bool get ();
    void set (bool value);
}


Version Property

Version Property
Namespaces ► eBay.Service.Core.Soap ► AbstractResponseType ► Version
Declaration Syntax
C# Visual Basic Visual C++
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}


AccessRuleCurrentStatusCodeType Enumeration

AccessRuleCurrentStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AccessRuleCurrentStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AccessRuleCurrentStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AccessRuleCurrentStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AccessRuleCurrentStatusCodeType
Members
Member | Description
NotSet |
HourlyLimitExceeded |
DailyLimitExceeded |
PeriodicLimitExceeded |
HourlySoftLimitExceeded |
DailySoftLimitExceeded |
PeriodicSoftLimitExceeded |
CustomCode |
Remarks


AccessRuleStatusCodeType Enumeration

AccessRuleStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AccessRuleStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AccessRuleStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AccessRuleStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AccessRuleStatusCodeType
Members
Member | Description
RuleOff |
RuleOn |
ApplicationBlocked |
CustomCode |
Remarks


AccountDetailEntryCodeType Enumeration

AccountDetailEntryCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AccountDetailEntryCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AccountDetailEntryCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AccountDetailEntryCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AccountDetailEntryCodeType
Members
Member | Description
Unknown |
FeeInsertion |
FeeBold |
FeeFeatured |
FeeCategoryFeatured |
FeeFinalValue |
PaymentCheck |
PaymentCC |
CreditCourtesy |
CreditNoSale |
CreditPartialSale |
RefundCC |
RefundCheck |
FinanceCharge |
AWDebit |
AWCredit |
AWMemo |
CreditDuplicateListing |
FeePartialSale |
PaymentElectronicTransferReversal |
PaymentCCOnce |
FeeReturnedCheck |
FeeRedepositCheck |
PaymentCash |
CreditInsertion |
CreditBold |
CreditFeatured |
CreditCategoryFeatured |
CreditFinalValue |
FeeNSFCheck |
FeeReturnCheckClose |
Memo |
PaymentMoneyOrder |
CreditCardOnFile |
CreditCardNotOnFile |
Invoiced |
InvoicedCreditCard |
CreditTransferFrom |
DebitTransferTo |
InvoiceCreditBalance |
eBayDebit |
eBayCredit |
PromotionalCredit |
CCNotOnFilePerCustReq |
CreditInsertionFee |
CCPaymentRejected |
FeeGiftIcon |
CreditGiftIcon |
FeeGallery |
FeeFeaturedGallery |
CreditGallery |
CreditFeaturedGallery |
ItemMoveFee |
OutageCredit |
CreditPSA |
CreditPCGS |
FeeReserve |
CreditReserve |
eBayVISACredit |
BBAdminCredit |
BBAdminDebit |
ReferrerCredit |
ReferrerDebit |
SwitchCurrency |
PaymentGiftCertificate |
PaymentWireTransfer |
PaymentHomeBanking |
PaymentElectronicTransfer |
PaymentAdjustmentCredit |
PaymentAdjustmentDebit |
Chargeoff |
ChargeoffRecovery |
ChargeoffBankruptcy |
ChargeoffSuspended |
ChargeoffDeceased |
ChargeoffOther |
ChargeoffWacko |
FinanceChargeReversal |
FVFCreditReversal |
ForeignFundsConvert |
ForeignFundsCheckReversal |
EOMRestriction |
AllFeesCredit |
SetOnHold |
RevertUserState |
DirectDebitOnFile |
DirectDebitNotOnFile |
PaymentDirectDebit |
DirectDebitReversal |
DirectDebitReturnedItem |
FeeHighlight |
CreditHighlight |
BulkUserSuspension |
FeeRealEstate30DaysListing |
CreditRealEstate30DaysListing |
TradingLimitOverrideOn |
TradingLimitOverrideOff |
EquifaxRealtimeFee |
CreditEquifaxRealtimeFee |
PaymentEquifaxDebit |
PaymentEquifaxCredit |
Merged |
AutoTraderOn |
AutoTraderOff |
PaperInvoiceOn |
PaperInvoiceOff |
AccountStateSwitch |
FVFCreditReversalAutomatic |
CreditSoftOutage |
LACatalogFee |
LAExtraItem |
LACatalogItemFeeRefund |
LACatalogInsertionRefund |
LAFinalValueFee |
LAFinalValueFeeRefund |
LABuyerPremiumPercentageFee |
LABuyerPremiumPercentageFeeRefund |
LAAudioVideoFee |
LAAudioVideoFeeRefund |
FeeIPIXPhoto |
FeeIPIXSlideShow |
CreditIPIXPhoto |
CreditIPIXSlideShow |
FeeTenDayAuction |
CreditTenDayAuction |
TemporaryCredit |
TemporaryCreditReversal |
SubscriptionAABasic |
SubscriptionAAPro |
CreditAABasic |
CreditAAPro |
FeeLargePicture |
CreditLargePicture |
FeePicturePack |
CreditPicturePackPartial |
CreditPicturePackFull |
SubscriptioneBayStores |
CrediteBayStores |
FeeInsertionFixedPrice |
CreditInsertionFixedPrice |
FeeFinalValueFixedPrice |
CreditFinalValueFixedPrice |
ElectronicInvoiceOn |
ElectronicInvoiceOff |
FlagDDDDPending |
FlagDDPaymentConfirmed |
FixedPriceDurationFee |
FixedPriceDurationCredit |
BuyItNowFee |
BuyItNowCredit |
FeeSchedule |
CreditSchedule |
SubscriptionSMBasic |
SubscriptionSMBasicPro |
CreditSMBasic |
CreditSMBasicPro |
StoresGTCFee |
StoresGTCCredit |
ListingDesignerFee |
ListingDesignerCredit |
ExtendedAuctionFee |
ExtendedAcutionCredit |
PayPalOTPSucc |
PayPalOTPPend |
PayPalFailed |
PayPalChargeBack |
ChargeBack |
ChargeBackReversal |
PayPalRefund |
BonusPointsAddition |
BonusPointsReduction |
BonusPointsPaymentAutomatic |
BonusPointsPaymentManual |
BonusPointsPaymentReversal |
BonusPointsCashPayout |
VATCredit |
VATDebit |
VATStatusChangePending |
VATStatusChangeApproved |
VATStatusChange_Denied |
VATStatusDeletedByCSR |
VATStatusDeletedByUser |
SMProListingDesignerFee |
SMProListingDesignerCredit |
StoresSuccessfulListingFee |
StoresSuccessfulListingFeeCredit |
StoresReferralFee |
StoresReferralCredit |
SubtitleFee |
SubtitleFeeCredit |
eBayStoreInventorySubscriptionCredit |
AutoPmntReqExempt |
AutoPmntReqRein |
PictureManagerSubscriptionFee |
PictureManagerSubscriptionFeeCredit |
SellerReportsBasicFee |
SellerReportsBasicCredit |
SellerReportsPlusFee |
SellerReportsPlusCredit |
PaypalOnFile |
PaypalOnFileByCSR |
PaypalOffFile |
BorderFee |
BorderFeeCredit |
FeeSearchableMobileDE |
SalesReportsPlusFee |
SalesReportsPlusCredit |
CreditSearchableMobileDE |
EmailMarketingFee |
EmailMarketingCredit |
FeePictureShow |
CreditPictureShow |
ProPackBundleFee |
ProPackBundleFeeCredit |
BasicUpgradePackBundleFee |
BasicUpgradePackBundleFeeCredit |
ValuePackBundleFee |
ValuePackBundleFeeCredit |
ProPackPlusBundleFee |
ProPackPlusBundleFeeCredit |
FinalEntry |
CustomCode |
ExtendedDurationFee |
ExtendedDurationFeeCredit |
InternationalListingFee |
InternationalListingCredit |
MarketplaceResearchExpiredSubscriptionFee |
MarketplaceResearchExpiredSubscriptionFeeCredit |
MarketplaceResearchBasicSubscriptionFee |
MarketplaceResearchBasicSubscriptionFeeCredit |
MarketplaceResearchProSubscriptionFee |
BasicBundleFee |
BasicBundleFeeCredit |
MarketplaceResearchProSubscriptionFeeCredit |
VehicleLocalSubscriptionFee |
VehicleLocalSubscriptionFeeCredit |
VehicleLocalInsertionFee |
VehicleLocalInsertionFeeCredit |
VehicleLocalFinalValueFee |
VehicleLocalFinalValueFeeCredit |
VehicleLocalGTCFee |
VehicleLocalGTCFeeCredit |
eBayMotorsProFee |
CrediteBayMotorsProFee |
eBayMotorsProFeatureFee |
CrediteBayMotorsProFeatureFee |
FeeGalleryPlus |
CreditGalleryPlus |
PrivateListing |
CreditPrivateListing |
ImmoProFee |
CreditImmoProFee |
ImmoProFeatureFee |
CreditImmoProFeatureFee |
RealEstateProFee |
CreditRealEstateProFee |
RealEstateProFeatureFee |
CreditRealEstateProFeatureFee |
Discount |
CreditFinalValueShipping |
FeeFinalValueShipping |
FeeReturnShipping |
CreditReturnShipping |
FeeGlobalShippingProgram |
CreditGlobalShippingProgram |
FeeAuctionEndEarly |
CreditAuctionEndEarly |
FeeFedExShippingLabel |
CreditFedExShippingLabel |
FeeReturnRefund |
CreditReturnRefund |
FeeStoresSubscriptionEarlyTermination |
CreditStoresSubscriptionEarlyTermination |
FeeVehicleSubscriptionEarlyTermination |
CreditVehicleSubscriptionEarlyTermination |
FeeVehicleSubscription |
CreditVehicleSubscription |
FeeAUPostShippingLabel |
CreditAUPostShippingLabel |
FeeAPACFedExShippingLabel |
CreditAPACFedExShippingLabel |
FeeAPACTNTShippingLabel |
CreditAPACTNTShippingLabel |
FeeEBPReimbursement |
CreditEBPReimbursement |
FeePromotedListingFeature |
CreditPromotedListingFeature |
FeeAd |
CreditAd |
FeeUBIShippingLabel |
CreditUBIShippingLabel |
FeeeBayPlusSubscription |
CrediteBayPlusSubscription |
Remarks


AccountEntriesType Class

AccountEntriesType Class
Namespaces ► eBay.Service.Core.Soap ► AccountEntriesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AccountEntriesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AccountEntriesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AccountEntriesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccountEntriesType()()()() |
 | AccountEntry |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AccountEntriesType


AccountEntriesType Constructor

AccountEntriesType Constructor
Namespaces ► eBay.Service.Core.Soap ► AccountEntriesType ► AccountEntriesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntriesType()
Public Sub New
public:
AccountEntriesType()


AccountEntry Property

AccountEntry Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntriesType ► AccountEntry
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntryTypeCollection AccountEntry { get; set; }
Public Property AccountEntry As AccountEntryTypeCollection
    Get
    Set
public:
property AccountEntryTypeCollection^ AccountEntry {
    AccountEntryTypeCollection^ get ();
    void set (AccountEntryTypeCollection^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntriesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AccountEntrySortTypeCodeType Enumeration

AccountEntrySortTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AccountEntrySortTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AccountEntrySortTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AccountEntrySortTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AccountEntrySortTypeCodeType
Members
Member | Description
None |
AccountEntryCreatedTimeAscending |
AccountEntryCreatedTimeDescending |
AccountEntryItemNumberAscending |
AccountEntryItemNumberDescending |
AccountEntryFeeTypeAscending |
AccountEntryFeeTypeDescending |
CustomCode |
Remarks


AccountEntryType Class

AccountEntryType Class
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AccountEntryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AccountEntryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AccountEntryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccountEntryType()()()() |
 | AccountDetailsEntryType |
 | AccountDetailsEntryTypeSpecified |
 | Any |
 | Balance |
 | ConversionRate |
 | Date |
 | DateSpecified |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GrossDetailAmount |
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Memo |
 | NetDetailAmount |
 | OrderLineItemID |
 | ReceivedTopRatedDiscount |
 | ReceivedTopRatedDiscountSpecified |
 | RefNumber |
 | Title |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | VATPercent |
 | VATPercentSpecified |
Remarks
Inheritance Hierarchy
Object
AccountEntryType


AccountDetailsEntryType Property

AccountDetailsEntryType Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► AccountDetailsEntryType
Declaration Syntax
C# Visual Basic Visual C++
public AccountDetailEntryCodeType AccountDetailsEntryType { get; set; }
Public Property AccountDetailsEntryType As AccountDetailEntryCodeType
    Get
    Set
public:
property AccountDetailEntryCodeType AccountDetailsEntryType {
    AccountDetailEntryCodeType get ();
    void set (AccountDetailEntryCodeType value);
}


AccountDetailsEntryTypeSpecified Property

AccountDetailsEntryTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► AccountDetailsEntryTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AccountDetailsEntryTypeSpecified { get; set; }
Public Property AccountDetailsEntryTypeSpecified As Boolean
    Get
    Set
public:
property bool AccountDetailsEntryTypeSpecified {
    bool get ();
    void set (bool value);
}


AccountEntryType Constructor

AccountEntryType Constructor
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► AccountEntryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntryType()
Public Sub New
public:
AccountEntryType()


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Balance Property

Balance Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► Balance
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Balance { get; set; }
Public Property Balance As AmountType
    Get
    Set
public:
property AmountType^ Balance {
    AmountType^ get ();
    void set (AmountType^ value);
}


ConversionRate Property

ConversionRate Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► ConversionRate
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ConversionRate { get; set; }
Public Property ConversionRate As AmountType
    Get
    Set
public:
property AmountType^ ConversionRate {
    AmountType^ get ();
    void set (AmountType^ value);
}


Date Property

Date Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► Date
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Date { get; set; }
Public Property Date As DateTime
    Get
    Set
public:
property DateTime Date {
    DateTime get ();
    void set (DateTime value);
}


DateSpecified Property

DateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► DateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DateSpecified { get; set; }
Public Property DateSpecified As Boolean
    Get
    Set
public:
property bool DateSpecified {
    bool get ();
    void set (bool value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


GrossDetailAmount Property

GrossDetailAmount Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► GrossDetailAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType GrossDetailAmount { get; set; }
Public Property GrossDetailAmount As AmountType
    Get
    Set
public:
property AmountType^ GrossDetailAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


Memo Property

Memo Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► Memo
Declaration Syntax
C# Visual Basic Visual C++
public string Memo { get; set; }
Public Property Memo As String
    Get
    Set
public:
property String^ Memo {
    String^ get ();
    void set (String^ value);
}


NetDetailAmount Property

NetDetailAmount Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► NetDetailAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType NetDetailAmount { get; set; }
Public Property NetDetailAmount As AmountType
    Get
    Set
public:
property AmountType^ NetDetailAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


ReceivedTopRatedDiscount Property

ReceivedTopRatedDiscount Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► ReceivedTopRatedDiscount
Declaration Syntax
C# Visual Basic Visual C++
public bool ReceivedTopRatedDiscount { get; set; }
Public Property ReceivedTopRatedDiscount As Boolean
    Get
    Set
public:
property bool ReceivedTopRatedDiscount {
    bool get ();
    void set (bool value);
}


ReceivedTopRatedDiscountSpecified Property

ReceivedTopRatedDiscountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► ReceivedTopRatedDiscountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReceivedTopRatedDiscountSpecified { get; set; }
Public Property ReceivedTopRatedDiscountSpecified As Boolean
    Get
    Set
public:
property bool ReceivedTopRatedDiscountSpecified {
    bool get ();
    void set (bool value);
}


RefNumber Property

RefNumber Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► RefNumber
Declaration Syntax
C# Visual Basic Visual C++
public string RefNumber { get; set; }
Public Property RefNumber As String
    Get
    Set
public:
property String^ RefNumber {
    String^ get ();
    void set (String^ value);
}


Title Property

Title Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► Title
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


VATPercent Property

VATPercent Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► VATPercent
Declaration Syntax
C# Visual Basic Visual C++
public decimal VATPercent { get; set; }
Public Property VATPercent As Decimal
    Get
    Set
public:
property Decimal VATPercent {
    Decimal get ();
    void set (Decimal value);
}


VATPercentSpecified Property

VATPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryType ► VATPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VATPercentSpecified { get; set; }
Public Property VATPercentSpecified As Boolean
    Get
    Set
public:
property bool VATPercentSpecified {
    bool get ();
    void set (bool value);
}


AccountEntryTypeCollection Class

AccountEntryTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AccountEntryTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AccountEntryTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AccountEntryTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccountEntryTypeCollection()()()() |
 | AccountEntryTypeCollection(array<AccountEntryType>[]()[][]) |
 | AccountEntryTypeCollection(AccountEntryTypeCollection) |
 | Add(AccountEntryType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AccountEntryType>[]()[][]) |
 | AddRange(AccountEntryTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AccountEntryType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AccountEntryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AccountEntryType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AccountEntryType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AccountEntryType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AccountEntryTypeCollection


AccountEntryTypeCollection Constructor

AccountEntryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► AccountEntryTypeCollection()()()()
Members
Icon | Member | Description
 | AccountEntryTypeCollection()()()() |
 | AccountEntryTypeCollection(array<AccountEntryType>[]()[][]) |
 | AccountEntryTypeCollection(AccountEntryTypeCollection) |


AccountEntryTypeCollection Constructor

AccountEntryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► AccountEntryTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntryTypeCollection()
Public Sub New
public:
AccountEntryTypeCollection()


AccountEntryTypeCollection Constructor (items)

AccountEntryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► AccountEntryTypeCollection(array<AccountEntryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntryTypeCollection(
    AccountEntryType[] items
)
Public Sub New ( _
    items As AccountEntryType() _
)
public:
AccountEntryTypeCollection(
    array<AccountEntryType^>^ items
)
Parameters
items (array< AccountEntryType >[]()[][])


AccountEntryTypeCollection Constructor (items)

AccountEntryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► AccountEntryTypeCollection(AccountEntryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntryTypeCollection(
    AccountEntryTypeCollection items
)
Public Sub New ( _
    items As AccountEntryTypeCollection _
)
public:
AccountEntryTypeCollection(
    AccountEntryTypeCollection^ items
)
Parameters
items (AccountEntryTypeCollection)


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► Add(AccountEntryType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AccountEntryType item
)
Public Function Add ( _
    item As AccountEntryType _
) As Integer
public:
int Add(
    AccountEntryType^ item
)
Parameters
item (AccountEntryType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AccountEntryType>[]()[][]) |
 | AddRange(AccountEntryTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► AddRange(array<AccountEntryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AccountEntryType[] items
)
Public Sub AddRange ( _
    items As AccountEntryType() _
)
public:
void AddRange(
    array<AccountEntryType^>^ items
)
Parameters
items (array< AccountEntryType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► AddRange(AccountEntryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AccountEntryTypeCollection items
)
Public Sub AddRange ( _
    items As AccountEntryTypeCollection _
)
public:
void AddRange(
    AccountEntryTypeCollection^ items
)
Parameters
items (AccountEntryTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► Contains(AccountEntryType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AccountEntryType item
)
Public Function Contains ( _
    item As AccountEntryType _
) As Boolean
public:
bool Contains(
    AccountEntryType^ item
)
Parameters
item (AccountEntryType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► CopyTo(array<AccountEntryType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AccountEntryType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AccountEntryType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AccountEntryType^>^ items,
    int index
)
Parameters
items (array< AccountEntryType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► IndexOf(AccountEntryType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AccountEntryType item
)
Public Function IndexOf ( _
    item As AccountEntryType _
) As Integer
public:
int IndexOf(
    AccountEntryType^ item
)
Parameters
item (AccountEntryType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► Insert(Int32, AccountEntryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AccountEntryType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AccountEntryType _
)
public:
void Insert(
    int index,
    AccountEntryType^ item
)
Parameters
index (Int32)
item (AccountEntryType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntryType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AccountEntryType
    Get
    Set
public:
property AccountEntryType^ default[int index] {
    AccountEntryType^ get (int index);
    void set (int index, AccountEntryType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntryType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AccountEntryType
public:
AccountEntryType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► Remove(AccountEntryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AccountEntryType item
)
Public Sub Remove ( _
    item As AccountEntryType _
)
public:
void Remove(
    AccountEntryType^ item
)
Parameters
item (AccountEntryType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntryType[] ToArray()
Public Function ToArray As AccountEntryType()
public:
array<AccountEntryType^>^ ToArray()
Return Value


AccountHistorySelectionCodeType Enumeration

AccountHistorySelectionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AccountHistorySelectionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AccountHistorySelectionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AccountHistorySelectionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AccountHistorySelectionCodeType
Members
Member | Description
LastInvoice |
SpecifiedInvoice |
BetweenSpecifiedDates |
CustomCode |
Remarks


AccountStateCodeType Enumeration

AccountStateCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AccountStateCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AccountStateCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AccountStateCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AccountStateCodeType
Members
Member | Description
Active |
Pending |
Inactive |
CustomCode |
Remarks


AccountSummaryType Class

AccountSummaryType Class
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AccountSummaryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AccountSummaryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AccountSummaryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AccountSummaryType()()()() |
 | AccountState |
 | AccountStateSpecified |
 | AdditionalAccount |
 | AmountPastDue |
 | Any |
 | BankAccountInfo |
 | BankModifyDate |
 | BankModifyDateSpecified |
 | BillingCycleDate |
 | BillingCycleDateSpecified |
 | CreditCardExpiration |
 | CreditCardExpirationSpecified |
 | CreditCardInfo |
 | CreditCardModifyDate |
 | CreditCardModifyDateSpecified |
 | CurrentBalance |
 | Email |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvoiceBalance |
 | InvoiceCredit |
 | InvoiceDate |
 | InvoiceDateSpecified |
 | InvoiceNewFee |
 | InvoicePayment |
 | LastAmountPaid |
 | LastPaymentDate |
 | LastPaymentDateSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PastDue |
 | PastDueSpecified |
 | PaymentMethod |
 | PaymentMethodSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AccountSummaryType


AccountState Property

AccountState Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► AccountState
Declaration Syntax
C# Visual Basic Visual C++
public AccountStateCodeType AccountState { get; set; }
Public Property AccountState As AccountStateCodeType
    Get
    Set
public:
property AccountStateCodeType AccountState {
    AccountStateCodeType get ();
    void set (AccountStateCodeType value);
}


AccountStateSpecified Property

AccountStateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► AccountStateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AccountStateSpecified { get; set; }
Public Property AccountStateSpecified As Boolean
    Get
    Set
public:
property bool AccountStateSpecified {
    bool get ();
    void set (bool value);
}


AccountSummaryType Constructor

AccountSummaryType Constructor
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► AccountSummaryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AccountSummaryType()
Public Sub New
public:
AccountSummaryType()


AdditionalAccount Property

AdditionalAccount Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► AdditionalAccount
Declaration Syntax
C# Visual Basic Visual C++
public AdditionalAccountTypeCollection AdditionalAccount { get; set; }
Public Property AdditionalAccount As AdditionalAccountTypeCollection
    Get
    Set
public:
property AdditionalAccountTypeCollection^ AdditionalAccount {
    AdditionalAccountTypeCollection^ get ();
    void set (AdditionalAccountTypeCollection^ value);
}


AmountPastDue Property

AmountPastDue Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► AmountPastDue
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AmountPastDue { get; set; }
Public Property AmountPastDue As AmountType
    Get
    Set
public:
property AmountType^ AmountPastDue {
    AmountType^ get ();
    void set (AmountType^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BankAccountInfo Property

BankAccountInfo Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► BankAccountInfo
Declaration Syntax
C# Visual Basic Visual C++
public string BankAccountInfo { get; set; }
Public Property BankAccountInfo As String
    Get
    Set
public:
property String^ BankAccountInfo {
    String^ get ();
    void set (String^ value);
}


BankModifyDate Property

BankModifyDate Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► BankModifyDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime BankModifyDate { get; set; }
Public Property BankModifyDate As DateTime
    Get
    Set
public:
property DateTime BankModifyDate {
    DateTime get ();
    void set (DateTime value);
}


BankModifyDateSpecified Property

BankModifyDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► BankModifyDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BankModifyDateSpecified { get; set; }
Public Property BankModifyDateSpecified As Boolean
    Get
    Set
public:
property bool BankModifyDateSpecified {
    bool get ();
    void set (bool value);
}


BillingCycleDate Property

BillingCycleDate Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► BillingCycleDate
Declaration Syntax
C# Visual Basic Visual C++
public int BillingCycleDate { get; set; }
Public Property BillingCycleDate As Integer
    Get
    Set
public:
property int BillingCycleDate {
    int get ();
    void set (int value);
}


BillingCycleDateSpecified Property

BillingCycleDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► BillingCycleDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BillingCycleDateSpecified { get; set; }
Public Property BillingCycleDateSpecified As Boolean
    Get
    Set
public:
property bool BillingCycleDateSpecified {
    bool get ();
    void set (bool value);
}


CreditCardExpiration Property

CreditCardExpiration Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► CreditCardExpiration
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreditCardExpiration { get; set; }
Public Property CreditCardExpiration As DateTime
    Get
    Set
public:
property DateTime CreditCardExpiration {
    DateTime get ();
    void set (DateTime value);
}


CreditCardExpirationSpecified Property

CreditCardExpirationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► CreditCardExpirationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreditCardExpirationSpecified { get; set; }
Public Property CreditCardExpirationSpecified As Boolean
    Get
    Set
public:
property bool CreditCardExpirationSpecified {
    bool get ();
    void set (bool value);
}


CreditCardInfo Property

CreditCardInfo Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► CreditCardInfo
Declaration Syntax
C# Visual Basic Visual C++
public string CreditCardInfo { get; set; }
Public Property CreditCardInfo As String
    Get
    Set
public:
property String^ CreditCardInfo {
    String^ get ();
    void set (String^ value);
}


CreditCardModifyDate Property

CreditCardModifyDate Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► CreditCardModifyDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreditCardModifyDate { get; set; }
Public Property CreditCardModifyDate As DateTime
    Get
    Set
public:
property DateTime CreditCardModifyDate {
    DateTime get ();
    void set (DateTime value);
}


CreditCardModifyDateSpecified Property

CreditCardModifyDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► CreditCardModifyDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreditCardModifyDateSpecified { get; set; }
Public Property CreditCardModifyDateSpecified As Boolean
    Get
    Set
public:
property bool CreditCardModifyDateSpecified {
    bool get ();
    void set (bool value);
}


CurrentBalance Property

CurrentBalance Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► CurrentBalance
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CurrentBalance { get; set; }
Public Property CurrentBalance As AmountType
    Get
    Set
public:
property AmountType^ CurrentBalance {
    AmountType^ get ();
    void set (AmountType^ value);
}


Email Property

Email Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► Email
Declaration Syntax
C# Visual Basic Visual C++
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}


InvoiceBalance Property

InvoiceBalance Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► InvoiceBalance
Declaration Syntax
C# Visual Basic Visual C++
public AmountType InvoiceBalance { get; set; }
Public Property InvoiceBalance As AmountType
    Get
    Set
public:
property AmountType^ InvoiceBalance {
    AmountType^ get ();
    void set (AmountType^ value);
}


InvoiceCredit Property

InvoiceCredit Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► InvoiceCredit
Declaration Syntax
C# Visual Basic Visual C++
public AmountType InvoiceCredit { get; set; }
Public Property InvoiceCredit As AmountType
    Get
    Set
public:
property AmountType^ InvoiceCredit {
    AmountType^ get ();
    void set (AmountType^ value);
}


InvoiceDate Property

InvoiceDate Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► InvoiceDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime InvoiceDate { get; set; }
Public Property InvoiceDate As DateTime
    Get
    Set
public:
property DateTime InvoiceDate {
    DateTime get ();
    void set (DateTime value);
}


InvoiceDateSpecified Property

InvoiceDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► InvoiceDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InvoiceDateSpecified { get; set; }
Public Property InvoiceDateSpecified As Boolean
    Get
    Set
public:
property bool InvoiceDateSpecified {
    bool get ();
    void set (bool value);
}


InvoiceNewFee Property

InvoiceNewFee Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► InvoiceNewFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType InvoiceNewFee { get; set; }
Public Property InvoiceNewFee As AmountType
    Get
    Set
public:
property AmountType^ InvoiceNewFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


InvoicePayment Property

InvoicePayment Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► InvoicePayment
Declaration Syntax
C# Visual Basic Visual C++
public AmountType InvoicePayment { get; set; }
Public Property InvoicePayment As AmountType
    Get
    Set
public:
property AmountType^ InvoicePayment {
    AmountType^ get ();
    void set (AmountType^ value);
}


LastAmountPaid Property

LastAmountPaid Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► LastAmountPaid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType LastAmountPaid { get; set; }
Public Property LastAmountPaid As AmountType
    Get
    Set
public:
property AmountType^ LastAmountPaid {
    AmountType^ get ();
    void set (AmountType^ value);
}


LastPaymentDate Property

LastPaymentDate Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► LastPaymentDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastPaymentDate { get; set; }
Public Property LastPaymentDate As DateTime
    Get
    Set
public:
property DateTime LastPaymentDate {
    DateTime get ();
    void set (DateTime value);
}


LastPaymentDateSpecified Property

LastPaymentDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► LastPaymentDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastPaymentDateSpecified { get; set; }
Public Property LastPaymentDateSpecified As Boolean
    Get
    Set
public:
property bool LastPaymentDateSpecified {
    bool get ();
    void set (bool value);
}


PastDue Property

PastDue Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► PastDue
Declaration Syntax
C# Visual Basic Visual C++
public bool PastDue { get; set; }
Public Property PastDue As Boolean
    Get
    Set
public:
property bool PastDue {
    bool get ();
    void set (bool value);
}


PastDueSpecified Property

PastDueSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► PastDueSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PastDueSpecified { get; set; }
Public Property PastDueSpecified As Boolean
    Get
    Set
public:
property bool PastDueSpecified {
    bool get ();
    void set (bool value);
}


PaymentMethod Property

PaymentMethod Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► PaymentMethod
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentMethodCodeType PaymentMethod { get; set; }
Public Property PaymentMethod As SellerPaymentMethodCodeType
    Get
    Set
public:
property SellerPaymentMethodCodeType PaymentMethod {
    SellerPaymentMethodCodeType get ();
    void set (SellerPaymentMethodCodeType value);
}


PaymentMethodSpecified Property

PaymentMethodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AccountSummaryType ► PaymentMethodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentMethodSpecified { get; set; }
Public Property PaymentMethodSpecified As Boolean
    Get
    Set
public:
property bool PaymentMethodSpecified {
    bool get ();
    void set (bool value);
}


AckCodeType Enumeration

AckCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AckCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AckCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AckCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AckCodeType
Members
Member | Description
Success |
Failure |
Warning |
PartialFailure |
CustomCode |
Remarks


AddDisputeRequestType Class

AddDisputeRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddDisputeRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddDisputeRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddDisputeRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddDisputeRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddDisputeRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | DisputeExplanation |
 | DisputeExplanationSpecified |
 | DisputeReason |
 | DisputeReasonSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddDisputeRequestType


AddDisputeRequestType Constructor

AddDisputeRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddDisputeRequestType ► AddDisputeRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeRequestType()
Public Sub New
public:
AddDisputeRequestType()


DisputeExplanation Property

DisputeExplanation Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeRequestType ► DisputeExplanation
Declaration Syntax
C# Visual Basic Visual C++
public DisputeExplanationCodeType DisputeExplanation { get; set; }
Public Property DisputeExplanation As DisputeExplanationCodeType
    Get
    Set
public:
property DisputeExplanationCodeType DisputeExplanation {
    DisputeExplanationCodeType get ();
    void set (DisputeExplanationCodeType value);
}


DisputeExplanationSpecified Property

DisputeExplanationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeRequestType ► DisputeExplanationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeExplanationSpecified { get; set; }
Public Property DisputeExplanationSpecified As Boolean
    Get
    Set
public:
property bool DisputeExplanationSpecified {
    bool get ();
    void set (bool value);
}


DisputeReason Property

DisputeReason Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeRequestType ► DisputeReason
Declaration Syntax
C# Visual Basic Visual C++
public DisputeReasonCodeType DisputeReason { get; set; }
Public Property DisputeReason As DisputeReasonCodeType
    Get
    Set
public:
property DisputeReasonCodeType DisputeReason {
    DisputeReasonCodeType get ();
    void set (DisputeReasonCodeType value);
}


DisputeReasonSpecified Property

DisputeReasonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeRequestType ► DisputeReasonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeReasonSpecified { get; set; }
Public Property DisputeReasonSpecified As Boolean
    Get
    Set
public:
property bool DisputeReasonSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


AddDisputeResponseRequestType Class

AddDisputeResponseRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddDisputeResponseRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddDisputeResponseRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddDisputeResponseRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddDisputeResponseRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | DisputeActivity |
 | DisputeActivitySpecified |
 | DisputeID |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | MessageText |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ShipmentTrackNumber |
 | ShippingCarrierUsed |
 | ShippingTime |
 | ShippingTimeSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddDisputeResponseRequestType


AddDisputeResponseRequestType Constructor

AddDisputeResponseRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseRequestType ► AddDisputeResponseRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeResponseRequestType()
Public Sub New
public:
AddDisputeResponseRequestType()


DisputeActivity Property

DisputeActivity Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseRequestType ► DisputeActivity
Declaration Syntax
C# Visual Basic Visual C++
public DisputeActivityCodeType DisputeActivity { get; set; }
Public Property DisputeActivity As DisputeActivityCodeType
    Get
    Set
public:
property DisputeActivityCodeType DisputeActivity {
    DisputeActivityCodeType get ();
    void set (DisputeActivityCodeType value);
}


DisputeActivitySpecified Property

DisputeActivitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseRequestType ► DisputeActivitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeActivitySpecified { get; set; }
Public Property DisputeActivitySpecified As Boolean
    Get
    Set
public:
property bool DisputeActivitySpecified {
    bool get ();
    void set (bool value);
}


DisputeID Property

DisputeID Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseRequestType ► DisputeID
Declaration Syntax
C# Visual Basic Visual C++
public string DisputeID { get; set; }
Public Property DisputeID As String
    Get
    Set
public:
property String^ DisputeID {
    String^ get ();
    void set (String^ value);
}


MessageText Property

MessageText Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseRequestType ► MessageText
Declaration Syntax
C# Visual Basic Visual C++
public string MessageText { get; set; }
Public Property MessageText As String
    Get
    Set
public:
property String^ MessageText {
    String^ get ();
    void set (String^ value);
}


ShipmentTrackNumber Property

ShipmentTrackNumber Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseRequestType ► ShipmentTrackNumber
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentTrackNumber { get; set; }
Public Property ShipmentTrackNumber As String
    Get
    Set
public:
property String^ ShipmentTrackNumber {
    String^ get ();
    void set (String^ value);
}


ShippingCarrierUsed Property

ShippingCarrierUsed Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseRequestType ► ShippingCarrierUsed
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingCarrierUsed { get; set; }
Public Property ShippingCarrierUsed As String
    Get
    Set
public:
property String^ ShippingCarrierUsed {
    String^ get ();
    void set (String^ value);
}


ShippingTime Property

ShippingTime Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseRequestType ► ShippingTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ShippingTime { get; set; }
Public Property ShippingTime As DateTime
    Get
    Set
public:
property DateTime ShippingTime {
    DateTime get ();
    void set (DateTime value);
}


ShippingTimeSpecified Property

ShippingTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseRequestType ► ShippingTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTimeSpecified { get; set; }
Public Property ShippingTimeSpecified As Boolean
    Get
    Set
public:
property bool ShippingTimeSpecified {
    bool get ();
    void set (bool value);
}


AddDisputeResponseResponseType Class

AddDisputeResponseResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddDisputeResponseResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddDisputeResponseResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddDisputeResponseResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddDisputeResponseResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddDisputeResponseResponseType


AddDisputeResponseResponseType Constructor

AddDisputeResponseResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseResponseType ► AddDisputeResponseResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeResponseResponseType()
Public Sub New
public:
AddDisputeResponseResponseType()


AddDisputeResponseType Class

AddDisputeResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddDisputeResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddDisputeResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddDisputeResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddDisputeResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DisputeID |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddDisputeResponseType


AddDisputeResponseType Constructor

AddDisputeResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseType ► AddDisputeResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeResponseType()
Public Sub New
public:
AddDisputeResponseType()


DisputeID Property

DisputeID Property
Namespaces ► eBay.Service.Core.Soap ► AddDisputeResponseType ► DisputeID
Declaration Syntax
C# Visual Basic Visual C++
public string DisputeID { get; set; }
Public Property DisputeID As String
    Get
    Set
public:
property String^ DisputeID {
    String^ get ();
    void set (String^ value);
}


AddFixedPriceItemRequestType Class

AddFixedPriceItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddFixedPriceItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddFixedPriceItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddFixedPriceItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddFixedPriceItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddFixedPriceItemRequestType


AddFixedPriceItemRequestType Constructor

AddFixedPriceItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemRequestType ► AddFixedPriceItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddFixedPriceItemRequestType()
Public Sub New
public:
AddFixedPriceItemRequestType()


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


AddFixedPriceItemResponseType Class

AddFixedPriceItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddFixedPriceItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddFixedPriceItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddFixedPriceItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddFixedPriceItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category2ID |
 | CategoryID |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DiscountReason |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | ListingRecommendations |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | ProductSuggestions |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SKU |
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddFixedPriceItemResponseType


AddFixedPriceItemResponseType Constructor

AddFixedPriceItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► AddFixedPriceItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddFixedPriceItemResponseType()
Public Sub New
public:
AddFixedPriceItemResponseType()


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; set; }
Public Property Category2ID As String
    Get
    Set
public:
property String^ Category2ID {
    String^ get ();
    void set (String^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


DiscountReason Property

DiscountReason Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► DiscountReason
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReason { get; set; }
Public Property DiscountReason As DiscountReasonCodeTypeCollection
    Get
    Set
public:
property DiscountReasonCodeTypeCollection^ DiscountReason {
    DiscountReasonCodeTypeCollection^ get ();
    void set (DiscountReasonCodeTypeCollection^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► ListingRecommendations
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; set; }
Public Property ListingRecommendations As ListingRecommendationsType
    Get
    Set
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
    void set (ListingRecommendationsType^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► ProductSuggestions
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; set; }
Public Property ProductSuggestions As ProductSuggestionsType
    Get
    Set
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
    void set (ProductSuggestionsType^ value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddFixedPriceItemResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


AddItemFromSellingManagerTemplateRequestType Class

AddItemFromSellingManagerTemplateRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddItemFromSellingManagerTemplateRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddItemFromSellingManagerTemplateRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddItemFromSellingManagerTemplateRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemFromSellingManagerTemplateRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SaleTemplateID |
 | SaleTemplateIDSpecified |
 | ScheduleTime |
 | ScheduleTimeSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddItemFromSellingManagerTemplateRequestType


AddItemFromSellingManagerTemplateRequestType Constructor

AddItemFromSellingManagerTemplateRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateRequestType ► AddItemFromSellingManagerTemplateRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemFromSellingManagerTemplateRequestType()
Public Sub New
public:
AddItemFromSellingManagerTemplateRequestType()


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateRequestType ► SaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


SaleTemplateIDSpecified Property

SaleTemplateIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateRequestType ► SaleTemplateIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SaleTemplateIDSpecified { get; set; }
Public Property SaleTemplateIDSpecified As Boolean
    Get
    Set
public:
property bool SaleTemplateIDSpecified {
    bool get ();
    void set (bool value);
}


ScheduleTime Property

ScheduleTime Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateRequestType ► ScheduleTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ScheduleTime { get; set; }
Public Property ScheduleTime As DateTime
    Get
    Set
public:
property DateTime ScheduleTime {
    DateTime get ();
    void set (DateTime value);
}


ScheduleTimeSpecified Property

ScheduleTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateRequestType ► ScheduleTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ScheduleTimeSpecified { get; set; }
Public Property ScheduleTimeSpecified As Boolean
    Get
    Set
public:
property bool ScheduleTimeSpecified {
    bool get ();
    void set (bool value);
}


AddItemFromSellingManagerTemplateResponseType Class

AddItemFromSellingManagerTemplateResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddItemFromSellingManagerTemplateResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddItemFromSellingManagerTemplateResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddItemFromSellingManagerTemplateResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemFromSellingManagerTemplateResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category2ID |
 | CategoryID |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddItemFromSellingManagerTemplateResponseType


AddItemFromSellingManagerTemplateResponseType Constructor

AddItemFromSellingManagerTemplateResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateResponseType ► AddItemFromSellingManagerTemplateResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemFromSellingManagerTemplateResponseType()
Public Sub New
public:
AddItemFromSellingManagerTemplateResponseType()


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateResponseType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; set; }
Public Property Category2ID As String
    Get
    Set
public:
property String^ Category2ID {
    String^ get ();
    void set (String^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateResponseType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddItemFromSellingManagerTemplateResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


AddItemRequestContainerType Class

AddItemRequestContainerType Class
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddItemRequestContainerType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddItemRequestContainerType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddItemRequestContainerType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemRequestContainerType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AddItemRequestContainerType


AddItemRequestContainerType Constructor

AddItemRequestContainerType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerType ► AddItemRequestContainerType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemRequestContainerType()
Public Sub New
public:
AddItemRequestContainerType()


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


MessageID Property

MessageID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerType ► MessageID
Declaration Syntax
C# Visual Basic Visual C++
public string MessageID { get; set; }
Public Property MessageID As String
    Get
    Set
public:
property String^ MessageID {
    String^ get ();
    void set (String^ value);
}


AddItemRequestContainerTypeCollection Class

AddItemRequestContainerTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AddItemRequestContainerTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AddItemRequestContainerTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AddItemRequestContainerTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemRequestContainerTypeCollection()()()() |
 | AddItemRequestContainerTypeCollection(array<AddItemRequestContainerType>[]()[][]) |
 | AddItemRequestContainerTypeCollection(AddItemRequestContainerTypeCollection) |
 | Add(AddItemRequestContainerType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AddItemRequestContainerType>[]()[][]) |
 | AddRange(AddItemRequestContainerTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AddItemRequestContainerType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AddItemRequestContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AddItemRequestContainerType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AddItemRequestContainerType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AddItemRequestContainerType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AddItemRequestContainerTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► Add(AddItemRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AddItemRequestContainerType item
)
Public Function Add ( _
    item As AddItemRequestContainerType _
) As Integer
public:
int Add(
    AddItemRequestContainerType^ item
)
Parameters
item (AddItemRequestContainerType)
Return Value


AddItemRequestContainerTypeCollection Constructor

AddItemRequestContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► AddItemRequestContainerTypeCollection()()()()
Members
Icon | Member | Description
 | AddItemRequestContainerTypeCollection()()()() |
 | AddItemRequestContainerTypeCollection(array<AddItemRequestContainerType>[]()[][]) |
 | AddItemRequestContainerTypeCollection(AddItemRequestContainerTypeCollection) |


AddItemRequestContainerTypeCollection Constructor

AddItemRequestContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► AddItemRequestContainerTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemRequestContainerTypeCollection()
Public Sub New
public:
AddItemRequestContainerTypeCollection()


AddItemRequestContainerTypeCollection Constructor (items)

AddItemRequestContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► AddItemRequestContainerTypeCollection(array<AddItemRequestContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AddItemRequestContainerTypeCollection(
    AddItemRequestContainerType[] items
)
Public Sub New ( _
    items As AddItemRequestContainerType() _
)
public:
AddItemRequestContainerTypeCollection(
    array<AddItemRequestContainerType^>^ items
)
Parameters
items (array< AddItemRequestContainerType >[]()[][])


AddItemRequestContainerTypeCollection Constructor (items)

AddItemRequestContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► AddItemRequestContainerTypeCollection(AddItemRequestContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AddItemRequestContainerTypeCollection(
    AddItemRequestContainerTypeCollection items
)
Public Sub New ( _
    items As AddItemRequestContainerTypeCollection _
)
public:
AddItemRequestContainerTypeCollection(
    AddItemRequestContainerTypeCollection^ items
)
Parameters
items (AddItemRequestContainerTypeCollection)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AddItemRequestContainerType>[]()[][]) |
 | AddRange(AddItemRequestContainerTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► AddRange(array<AddItemRequestContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AddItemRequestContainerType[] items
)
Public Sub AddRange ( _
    items As AddItemRequestContainerType() _
)
public:
void AddRange(
    array<AddItemRequestContainerType^>^ items
)
Parameters
items (array< AddItemRequestContainerType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► AddRange(AddItemRequestContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AddItemRequestContainerTypeCollection items
)
Public Sub AddRange ( _
    items As AddItemRequestContainerTypeCollection _
)
public:
void AddRange(
    AddItemRequestContainerTypeCollection^ items
)
Parameters
items (AddItemRequestContainerTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► Contains(AddItemRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AddItemRequestContainerType item
)
Public Function Contains ( _
    item As AddItemRequestContainerType _
) As Boolean
public:
bool Contains(
    AddItemRequestContainerType^ item
)
Parameters
item (AddItemRequestContainerType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► CopyTo(array<AddItemRequestContainerType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AddItemRequestContainerType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AddItemRequestContainerType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AddItemRequestContainerType^>^ items,
    int index
)
Parameters
items (array< AddItemRequestContainerType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► IndexOf(AddItemRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AddItemRequestContainerType item
)
Public Function IndexOf ( _
    item As AddItemRequestContainerType _
) As Integer
public:
int IndexOf(
    AddItemRequestContainerType^ item
)
Parameters
item (AddItemRequestContainerType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► Insert(Int32, AddItemRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AddItemRequestContainerType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AddItemRequestContainerType _
)
public:
void Insert(
    int index,
    AddItemRequestContainerType^ item
)
Parameters
index (Int32)
item (AddItemRequestContainerType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AddItemRequestContainerType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AddItemRequestContainerType
    Get
    Set
public:
property AddItemRequestContainerType^ default[int index] {
    AddItemRequestContainerType^ get (int index);
    void set (int index, AddItemRequestContainerType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AddItemRequestContainerType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AddItemRequestContainerType
public:
AddItemRequestContainerType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► Remove(AddItemRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AddItemRequestContainerType item
)
Public Sub Remove ( _
    item As AddItemRequestContainerType _
)
public:
void Remove(
    AddItemRequestContainerType^ item
)
Parameters
item (AddItemRequestContainerType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemRequestContainerType[] ToArray()
Public Function ToArray As AddItemRequestContainerType()
public:
array<AddItemRequestContainerType^>^ ToArray()
Return Value


AddItemRequestType Class

AddItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddItemRequestType


AddItemRequestType Constructor

AddItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestType ► AddItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemRequestType()
Public Sub New
public:
AddItemRequestType()


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


AddItemResponseContainerType Class

AddItemResponseContainerType Class
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddItemResponseContainerType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddItemResponseContainerType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddItemResponseContainerType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemResponseContainerType()()()() |
 | Any |
 | Category2ID |
 | CategoryID |
 | CorrelationID |
 | DiscountReason |
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors |
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | ListingRecommendations |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message |
 | StartTime |
 | StartTimeSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AddItemResponseContainerType


AddItemResponseContainerType Constructor

AddItemResponseContainerType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► AddItemResponseContainerType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseContainerType()
Public Sub New
public:
AddItemResponseContainerType()


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; set; }
Public Property Category2ID As String
    Get
    Set
public:
property String^ Category2ID {
    String^ get ();
    void set (String^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


CorrelationID Property

CorrelationID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► CorrelationID
Declaration Syntax
C# Visual Basic Visual C++
public string CorrelationID { get; set; }
Public Property CorrelationID As String
    Get
    Set
public:
property String^ CorrelationID {
    String^ get ();
    void set (String^ value);
}


DiscountReason Property

DiscountReason Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► DiscountReason
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReason { get; set; }
Public Property DiscountReason As DiscountReasonCodeTypeCollection
    Get
    Set
public:
property DiscountReasonCodeTypeCollection^ DiscountReason {
    DiscountReasonCodeTypeCollection^ get ();
    void set (DiscountReasonCodeTypeCollection^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


Errors Property

Errors Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► Errors
Declaration Syntax
C# Visual Basic Visual C++
public ErrorTypeCollection Errors { get; set; }
Public Property Errors As ErrorTypeCollection
    Get
    Set
public:
property ErrorTypeCollection^ Errors {
    ErrorTypeCollection^ get ();
    void set (ErrorTypeCollection^ value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► ListingRecommendations
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; set; }
Public Property ListingRecommendations As ListingRecommendationsType
    Get
    Set
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
    void set (ListingRecommendationsType^ value);
}


Message Property

Message Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► Message
Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


AddItemResponseContainerTypeCollection Class

AddItemResponseContainerTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AddItemResponseContainerTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AddItemResponseContainerTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AddItemResponseContainerTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemResponseContainerTypeCollection()()()() |
 | AddItemResponseContainerTypeCollection(array<AddItemResponseContainerType>[]()[][]) |
 | AddItemResponseContainerTypeCollection(AddItemResponseContainerTypeCollection) |
 | Add(AddItemResponseContainerType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AddItemResponseContainerType>[]()[][]) |
 | AddRange(AddItemResponseContainerTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AddItemResponseContainerType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AddItemResponseContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AddItemResponseContainerType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AddItemResponseContainerType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AddItemResponseContainerType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AddItemResponseContainerTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► Add(AddItemResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AddItemResponseContainerType item
)
Public Function Add ( _
    item As AddItemResponseContainerType _
) As Integer
public:
int Add(
    AddItemResponseContainerType^ item
)
Parameters
item (AddItemResponseContainerType)
Return Value


AddItemResponseContainerTypeCollection Constructor

AddItemResponseContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► AddItemResponseContainerTypeCollection()()()()
Members
Icon | Member | Description
 | AddItemResponseContainerTypeCollection()()()() |
 | AddItemResponseContainerTypeCollection(array<AddItemResponseContainerType>[]()[][]) |
 | AddItemResponseContainerTypeCollection(AddItemResponseContainerTypeCollection) |


AddItemResponseContainerTypeCollection Constructor

AddItemResponseContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► AddItemResponseContainerTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseContainerTypeCollection()
Public Sub New
public:
AddItemResponseContainerTypeCollection()


AddItemResponseContainerTypeCollection Constructor (items)

AddItemResponseContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► AddItemResponseContainerTypeCollection(array<AddItemResponseContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseContainerTypeCollection(
    AddItemResponseContainerType[] items
)
Public Sub New ( _
    items As AddItemResponseContainerType() _
)
public:
AddItemResponseContainerTypeCollection(
    array<AddItemResponseContainerType^>^ items
)
Parameters
items (array< AddItemResponseContainerType >[]()[][])


AddItemResponseContainerTypeCollection Constructor (items)

AddItemResponseContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► AddItemResponseContainerTypeCollection(AddItemResponseContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseContainerTypeCollection(
    AddItemResponseContainerTypeCollection items
)
Public Sub New ( _
    items As AddItemResponseContainerTypeCollection _
)
public:
AddItemResponseContainerTypeCollection(
    AddItemResponseContainerTypeCollection^ items
)
Parameters
items (AddItemResponseContainerTypeCollection)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AddItemResponseContainerType>[]()[][]) |
 | AddRange(AddItemResponseContainerTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► AddRange(array<AddItemResponseContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AddItemResponseContainerType[] items
)
Public Sub AddRange ( _
    items As AddItemResponseContainerType() _
)
public:
void AddRange(
    array<AddItemResponseContainerType^>^ items
)
Parameters
items (array< AddItemResponseContainerType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► AddRange(AddItemResponseContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AddItemResponseContainerTypeCollection items
)
Public Sub AddRange ( _
    items As AddItemResponseContainerTypeCollection _
)
public:
void AddRange(
    AddItemResponseContainerTypeCollection^ items
)
Parameters
items (AddItemResponseContainerTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► Contains(AddItemResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AddItemResponseContainerType item
)
Public Function Contains ( _
    item As AddItemResponseContainerType _
) As Boolean
public:
bool Contains(
    AddItemResponseContainerType^ item
)
Parameters
item (AddItemResponseContainerType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► CopyTo(array<AddItemResponseContainerType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AddItemResponseContainerType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AddItemResponseContainerType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AddItemResponseContainerType^>^ items,
    int index
)
Parameters
items (array< AddItemResponseContainerType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► IndexOf(AddItemResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AddItemResponseContainerType item
)
Public Function IndexOf ( _
    item As AddItemResponseContainerType _
) As Integer
public:
int IndexOf(
    AddItemResponseContainerType^ item
)
Parameters
item (AddItemResponseContainerType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► Insert(Int32, AddItemResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AddItemResponseContainerType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AddItemResponseContainerType _
)
public:
void Insert(
    int index,
    AddItemResponseContainerType^ item
)
Parameters
index (Int32)
item (AddItemResponseContainerType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseContainerType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AddItemResponseContainerType
    Get
    Set
public:
property AddItemResponseContainerType^ default[int index] {
    AddItemResponseContainerType^ get (int index);
    void set (int index, AddItemResponseContainerType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseContainerType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AddItemResponseContainerType
public:
AddItemResponseContainerType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► Remove(AddItemResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AddItemResponseContainerType item
)
Public Sub Remove ( _
    item As AddItemResponseContainerType _
)
public:
void Remove(
    AddItemResponseContainerType^ item
)
Parameters
item (AddItemResponseContainerType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseContainerType[] ToArray()
Public Function ToArray As AddItemResponseContainerType()
public:
array<AddItemResponseContainerType^>^ ToArray()
Return Value


AddItemResponseType Class

AddItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category2ID |
 | CategoryID |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DiscountReason |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | ListingRecommendations |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | ProductSuggestions |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddItemResponseType


AddItemResponseType Constructor

AddItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► AddItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseType()
Public Sub New
public:
AddItemResponseType()


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; set; }
Public Property Category2ID As String
    Get
    Set
public:
property String^ Category2ID {
    String^ get ();
    void set (String^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


DiscountReason Property

DiscountReason Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► DiscountReason
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReason { get; set; }
Public Property DiscountReason As DiscountReasonCodeTypeCollection
    Get
    Set
public:
property DiscountReasonCodeTypeCollection^ DiscountReason {
    DiscountReasonCodeTypeCollection^ get ();
    void set (DiscountReasonCodeTypeCollection^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► ListingRecommendations
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; set; }
Public Property ListingRecommendations As ListingRecommendationsType
    Get
    Set
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
    void set (ListingRecommendationsType^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► ProductSuggestions
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; set; }
Public Property ProductSuggestions As ProductSuggestionsType
    Get
    Set
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
    void set (ProductSuggestionsType^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


AddItemsRequestType Class

AddItemsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddItemsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddItemsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddItemsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddItemsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemsRequestType()()()() |
 | AddItemRequestContainer |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddItemsRequestType


AddItemRequestContainer Property

AddItemRequestContainer Property
Namespaces ► eBay.Service.Core.Soap ► AddItemsRequestType ► AddItemRequestContainer
Declaration Syntax
C# Visual Basic Visual C++
public AddItemRequestContainerTypeCollection AddItemRequestContainer { get; set; }
Public Property AddItemRequestContainer As AddItemRequestContainerTypeCollection
    Get
    Set
public:
property AddItemRequestContainerTypeCollection^ AddItemRequestContainer {
    AddItemRequestContainerTypeCollection^ get ();
    void set (AddItemRequestContainerTypeCollection^ value);
}


AddItemsRequestType Constructor

AddItemsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemsRequestType ► AddItemsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemsRequestType()
Public Sub New
public:
AddItemsRequestType()


AddItemsResponseType Class

AddItemsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddItemsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddItemsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddItemsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddItemsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddItemsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | AddItemResponseContainer |
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddItemsResponseType


AddItemResponseContainer Property

AddItemResponseContainer Property
Namespaces ► eBay.Service.Core.Soap ► AddItemsResponseType ► AddItemResponseContainer
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseContainerTypeCollection AddItemResponseContainer { get; set; }
Public Property AddItemResponseContainer As AddItemResponseContainerTypeCollection
    Get
    Set
public:
property AddItemResponseContainerTypeCollection^ AddItemResponseContainer {
    AddItemResponseContainerTypeCollection^ get ();
    void set (AddItemResponseContainerTypeCollection^ value);
}


AddItemsResponseType Constructor

AddItemsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddItemsResponseType ► AddItemsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddItemsResponseType()
Public Sub New
public:
AddItemsResponseType()


AdditionalAccountType Class

AdditionalAccountType Class
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AdditionalAccountType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AdditionalAccountType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AdditionalAccountType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdditionalAccountType()()()() |
 | AccountCode |
 | Any |
 | Balance |
 | Currency |
 | CurrencySpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AdditionalAccountType


AccountCode Property

AccountCode Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountType ► AccountCode
Declaration Syntax
C# Visual Basic Visual C++
public string AccountCode { get; set; }
Public Property AccountCode As String
    Get
    Set
public:
property String^ AccountCode {
    String^ get ();
    void set (String^ value);
}


AdditionalAccountType Constructor

AdditionalAccountType Constructor
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountType ► AdditionalAccountType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AdditionalAccountType()
Public Sub New
public:
AdditionalAccountType()


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Balance Property

Balance Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountType ► Balance
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Balance { get; set; }
Public Property Balance As AmountType
    Get
    Set
public:
property AmountType^ Balance {
    AmountType^ get ();
    void set (AmountType^ value);
}


Currency Property

Currency Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountType ► Currency
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType Currency { get; set; }
Public Property Currency As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType Currency {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


CurrencySpecified Property

CurrencySpecified Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountType ► CurrencySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CurrencySpecified { get; set; }
Public Property CurrencySpecified As Boolean
    Get
    Set
public:
property bool CurrencySpecified {
    bool get ();
    void set (bool value);
}


AdditionalAccountTypeCollection Class

AdditionalAccountTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AdditionalAccountTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AdditionalAccountTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AdditionalAccountTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdditionalAccountTypeCollection()()()() |
 | AdditionalAccountTypeCollection(array<AdditionalAccountType>[]()[][]) |
 | AdditionalAccountTypeCollection(AdditionalAccountTypeCollection) |
 | Add(AdditionalAccountType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AdditionalAccountType>[]()[][]) |
 | AddRange(AdditionalAccountTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AdditionalAccountType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AdditionalAccountType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AdditionalAccountType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AdditionalAccountType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AdditionalAccountType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AdditionalAccountTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► Add(AdditionalAccountType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AdditionalAccountType item
)
Public Function Add ( _
    item As AdditionalAccountType _
) As Integer
public:
int Add(
    AdditionalAccountType^ item
)
Parameters
item (AdditionalAccountType)
Return Value


AdditionalAccountTypeCollection Constructor

AdditionalAccountTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► AdditionalAccountTypeCollection()()()()
Members
Icon | Member | Description
 | AdditionalAccountTypeCollection()()()() |
 | AdditionalAccountTypeCollection(array<AdditionalAccountType>[]()[][]) |
 | AdditionalAccountTypeCollection(AdditionalAccountTypeCollection) |


AdditionalAccountTypeCollection Constructor

AdditionalAccountTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► AdditionalAccountTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AdditionalAccountTypeCollection()
Public Sub New
public:
AdditionalAccountTypeCollection()


AdditionalAccountTypeCollection Constructor (items)

AdditionalAccountTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► AdditionalAccountTypeCollection(array<AdditionalAccountType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AdditionalAccountTypeCollection(
    AdditionalAccountType[] items
)
Public Sub New ( _
    items As AdditionalAccountType() _
)
public:
AdditionalAccountTypeCollection(
    array<AdditionalAccountType^>^ items
)
Parameters
items (array< AdditionalAccountType >[]()[][])


AdditionalAccountTypeCollection Constructor (items)

AdditionalAccountTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► AdditionalAccountTypeCollection(AdditionalAccountTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AdditionalAccountTypeCollection(
    AdditionalAccountTypeCollection items
)
Public Sub New ( _
    items As AdditionalAccountTypeCollection _
)
public:
AdditionalAccountTypeCollection(
    AdditionalAccountTypeCollection^ items
)
Parameters
items (AdditionalAccountTypeCollection)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AdditionalAccountType>[]()[][]) |
 | AddRange(AdditionalAccountTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► AddRange(array<AdditionalAccountType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AdditionalAccountType[] items
)
Public Sub AddRange ( _
    items As AdditionalAccountType() _
)
public:
void AddRange(
    array<AdditionalAccountType^>^ items
)
Parameters
items (array< AdditionalAccountType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► AddRange(AdditionalAccountTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AdditionalAccountTypeCollection items
)
Public Sub AddRange ( _
    items As AdditionalAccountTypeCollection _
)
public:
void AddRange(
    AdditionalAccountTypeCollection^ items
)
Parameters
items (AdditionalAccountTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► Contains(AdditionalAccountType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AdditionalAccountType item
)
Public Function Contains ( _
    item As AdditionalAccountType _
) As Boolean
public:
bool Contains(
    AdditionalAccountType^ item
)
Parameters
item (AdditionalAccountType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► CopyTo(array<AdditionalAccountType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AdditionalAccountType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AdditionalAccountType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AdditionalAccountType^>^ items,
    int index
)
Parameters
items (array< AdditionalAccountType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► IndexOf(AdditionalAccountType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AdditionalAccountType item
)
Public Function IndexOf ( _
    item As AdditionalAccountType _
) As Integer
public:
int IndexOf(
    AdditionalAccountType^ item
)
Parameters
item (AdditionalAccountType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► Insert(Int32, AdditionalAccountType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AdditionalAccountType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AdditionalAccountType _
)
public:
void Insert(
    int index,
    AdditionalAccountType^ item
)
Parameters
index (Int32)
item (AdditionalAccountType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AdditionalAccountType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AdditionalAccountType
    Get
    Set
public:
property AdditionalAccountType^ default[int index] {
    AdditionalAccountType^ get (int index);
    void set (int index, AdditionalAccountType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AdditionalAccountType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AdditionalAccountType
public:
AdditionalAccountType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► Remove(AdditionalAccountType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AdditionalAccountType item
)
Public Sub Remove ( _
    item As AdditionalAccountType _
)
public:
void Remove(
    AdditionalAccountType^ item
)
Parameters
item (AdditionalAccountType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AdditionalAccountType[] ToArray()
Public Function ToArray As AdditionalAccountType()
public:
array<AdditionalAccountType^>^ ToArray()
Return Value


AdditionalCompatibilityEnabledDefinitionType Class

AdditionalCompatibilityEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► AdditionalCompatibilityEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AdditionalCompatibilityEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AdditionalCompatibilityEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AdditionalCompatibilityEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdditionalCompatibilityEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AdditionalCompatibilityEnabledDefinitionType


AdditionalCompatibilityEnabledDefinitionType Constructor

AdditionalCompatibilityEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► AdditionalCompatibilityEnabledDefinitionType ► AdditionalCompatibilityEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AdditionalCompatibilityEnabledDefinitionType()
Public Sub New
public:
AdditionalCompatibilityEnabledDefinitionType()


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalCompatibilityEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AddMemberMessageAAQToPartnerRequestType Class

AddMemberMessageAAQToPartnerRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageAAQToPartnerRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddMemberMessageAAQToPartnerRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddMemberMessageAAQToPartnerRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddMemberMessageAAQToPartnerRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessageAAQToPartnerRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberMessage |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddMemberMessageAAQToPartnerRequestType


AddMemberMessageAAQToPartnerRequestType Constructor

AddMemberMessageAAQToPartnerRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageAAQToPartnerRequestType ► AddMemberMessageAAQToPartnerRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageAAQToPartnerRequestType()
Public Sub New
public:
AddMemberMessageAAQToPartnerRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageAAQToPartnerRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MemberMessage Property

MemberMessage Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageAAQToPartnerRequestType ► MemberMessage
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageType MemberMessage { get; set; }
Public Property MemberMessage As MemberMessageType
    Get
    Set
public:
property MemberMessageType^ MemberMessage {
    MemberMessageType^ get ();
    void set (MemberMessageType^ value);
}


AddMemberMessageAAQToPartnerResponseType Class

AddMemberMessageAAQToPartnerResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageAAQToPartnerResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddMemberMessageAAQToPartnerResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddMemberMessageAAQToPartnerResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddMemberMessageAAQToPartnerResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessageAAQToPartnerResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddMemberMessageAAQToPartnerResponseType


AddMemberMessageAAQToPartnerResponseType Constructor

AddMemberMessageAAQToPartnerResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageAAQToPartnerResponseType ► AddMemberMessageAAQToPartnerResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageAAQToPartnerResponseType()
Public Sub New
public:
AddMemberMessageAAQToPartnerResponseType()


AddMemberMessageRTQRequestType Class

AddMemberMessageRTQRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageRTQRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddMemberMessageRTQRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddMemberMessageRTQRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddMemberMessageRTQRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessageRTQRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberMessage |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddMemberMessageRTQRequestType


AddMemberMessageRTQRequestType Constructor

AddMemberMessageRTQRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageRTQRequestType ► AddMemberMessageRTQRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageRTQRequestType()
Public Sub New
public:
AddMemberMessageRTQRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageRTQRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MemberMessage Property

MemberMessage Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageRTQRequestType ► MemberMessage
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageType MemberMessage { get; set; }
Public Property MemberMessage As MemberMessageType
    Get
    Set
public:
property MemberMessageType^ MemberMessage {
    MemberMessageType^ get ();
    void set (MemberMessageType^ value);
}


AddMemberMessageRTQResponseType Class

AddMemberMessageRTQResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageRTQResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddMemberMessageRTQResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddMemberMessageRTQResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddMemberMessageRTQResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessageRTQResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddMemberMessageRTQResponseType


AddMemberMessageRTQResponseType Constructor

AddMemberMessageRTQResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessageRTQResponseType ► AddMemberMessageRTQResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageRTQResponseType()
Public Sub New
public:
AddMemberMessageRTQResponseType()


AddMemberMessagesAAQToBidderRequestContainerType Class

AddMemberMessagesAAQToBidderRequestContainerType Class
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddMemberMessagesAAQToBidderRequestContainerType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddMemberMessagesAAQToBidderRequestContainerType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddMemberMessagesAAQToBidderRequestContainerType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessagesAAQToBidderRequestContainerType()()()() |
 | CorrelationID |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberMessage |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AddMemberMessagesAAQToBidderRequestContainerType


AddMemberMessagesAAQToBidderRequestContainerType Constructor

AddMemberMessagesAAQToBidderRequestContainerType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerType ► AddMemberMessagesAAQToBidderRequestContainerType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderRequestContainerType()
Public Sub New
public:
AddMemberMessagesAAQToBidderRequestContainerType()


CorrelationID Property

CorrelationID Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerType ► CorrelationID
Declaration Syntax
C# Visual Basic Visual C++
public string CorrelationID { get; set; }
Public Property CorrelationID As String
    Get
    Set
public:
property String^ CorrelationID {
    String^ get ();
    void set (String^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MemberMessage Property

MemberMessage Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerType ► MemberMessage
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageType MemberMessage { get; set; }
Public Property MemberMessage As MemberMessageType
    Get
    Set
public:
property MemberMessageType^ MemberMessage {
    MemberMessageType^ get ();
    void set (MemberMessageType^ value);
}


AddMemberMessagesAAQToBidderRequestContainerTypeCollection Class

AddMemberMessagesAAQToBidderRequestContainerTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AddMemberMessagesAAQToBidderRequestContainerTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AddMemberMessagesAAQToBidderRequestContainerTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AddMemberMessagesAAQToBidderRequestContainerTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessagesAAQToBidderRequestContainerTypeCollection()()()() |
 | AddMemberMessagesAAQToBidderRequestContainerTypeCollection(array<AddMemberMessagesAAQToBidderRequestContainerType>[]()[][]) |
 | AddMemberMessagesAAQToBidderRequestContainerTypeCollection(AddMemberMessagesAAQToBidderRequestContainerTypeCollection) |
 | Add(AddMemberMessagesAAQToBidderRequestContainerType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AddMemberMessagesAAQToBidderRequestContainerType>[]()[][]) |
 | AddRange(AddMemberMessagesAAQToBidderRequestContainerTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AddMemberMessagesAAQToBidderRequestContainerType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AddMemberMessagesAAQToBidderRequestContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AddMemberMessagesAAQToBidderRequestContainerType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AddMemberMessagesAAQToBidderRequestContainerType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AddMemberMessagesAAQToBidderRequestContainerType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AddMemberMessagesAAQToBidderRequestContainerTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► Add(AddMemberMessagesAAQToBidderRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AddMemberMessagesAAQToBidderRequestContainerType item
)
Public Function Add ( _
    item As AddMemberMessagesAAQToBidderRequestContainerType _
) As Integer
public:
int Add(
    AddMemberMessagesAAQToBidderRequestContainerType^ item
)
Parameters
item (AddMemberMessagesAAQToBidderRequestContainerType)
Return Value


AddMemberMessagesAAQToBidderRequestContainerTypeCollection Constructor

AddMemberMessagesAAQToBidderRequestContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection()()()()
Members
Icon | Member | Description
 | AddMemberMessagesAAQToBidderRequestContainerTypeCollection()()()() |
 | AddMemberMessagesAAQToBidderRequestContainerTypeCollection(array<AddMemberMessagesAAQToBidderRequestContainerType>[]()[][]) |
 | AddMemberMessagesAAQToBidderRequestContainerTypeCollection(AddMemberMessagesAAQToBidderRequestContainerTypeCollection) |


AddMemberMessagesAAQToBidderRequestContainerTypeCollection Constructor

AddMemberMessagesAAQToBidderRequestContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderRequestContainerTypeCollection()
Public Sub New
public:
AddMemberMessagesAAQToBidderRequestContainerTypeCollection()


AddMemberMessagesAAQToBidderRequestContainerTypeCollection Constructor (items)

AddMemberMessagesAAQToBidderRequestContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection(array<AddMemberMessagesAAQToBidderRequestContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderRequestContainerTypeCollection(
    AddMemberMessagesAAQToBidderRequestContainerType[] items
)
Public Sub New ( _
    items As AddMemberMessagesAAQToBidderRequestContainerType() _
)
public:
AddMemberMessagesAAQToBidderRequestContainerTypeCollection(
    array<AddMemberMessagesAAQToBidderRequestContainerType^>^ items
)
Parameters
items (array< AddMemberMessagesAAQToBidderRequestContainerType >[]()[][])


AddMemberMessagesAAQToBidderRequestContainerTypeCollection Constructor (items)

AddMemberMessagesAAQToBidderRequestContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection(AddMemberMessagesAAQToBidderRequestContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderRequestContainerTypeCollection(
    AddMemberMessagesAAQToBidderRequestContainerTypeCollection items
)
Public Sub New ( _
    items As AddMemberMessagesAAQToBidderRequestContainerTypeCollection _
)
public:
AddMemberMessagesAAQToBidderRequestContainerTypeCollection(
    AddMemberMessagesAAQToBidderRequestContainerTypeCollection^ items
)
Parameters
items (AddMemberMessagesAAQToBidderRequestContainerTypeCollection)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AddMemberMessagesAAQToBidderRequestContainerType>[]()[][]) |
 | AddRange(AddMemberMessagesAAQToBidderRequestContainerTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► AddRange(array<AddMemberMessagesAAQToBidderRequestContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AddMemberMessagesAAQToBidderRequestContainerType[] items
)
Public Sub AddRange ( _
    items As AddMemberMessagesAAQToBidderRequestContainerType() _
)
public:
void AddRange(
    array<AddMemberMessagesAAQToBidderRequestContainerType^>^ items
)
Parameters
items (array< AddMemberMessagesAAQToBidderRequestContainerType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► AddRange(AddMemberMessagesAAQToBidderRequestContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AddMemberMessagesAAQToBidderRequestContainerTypeCollection items
)
Public Sub AddRange ( _
    items As AddMemberMessagesAAQToBidderRequestContainerTypeCollection _
)
public:
void AddRange(
    AddMemberMessagesAAQToBidderRequestContainerTypeCollection^ items
)
Parameters
items (AddMemberMessagesAAQToBidderRequestContainerTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► Contains(AddMemberMessagesAAQToBidderRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AddMemberMessagesAAQToBidderRequestContainerType item
)
Public Function Contains ( _
    item As AddMemberMessagesAAQToBidderRequestContainerType _
) As Boolean
public:
bool Contains(
    AddMemberMessagesAAQToBidderRequestContainerType^ item
)
Parameters
item (AddMemberMessagesAAQToBidderRequestContainerType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► CopyTo(array<AddMemberMessagesAAQToBidderRequestContainerType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AddMemberMessagesAAQToBidderRequestContainerType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AddMemberMessagesAAQToBidderRequestContainerType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AddMemberMessagesAAQToBidderRequestContainerType^>^ items,
    int index
)
Parameters
items (array< AddMemberMessagesAAQToBidderRequestContainerType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► IndexOf(AddMemberMessagesAAQToBidderRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AddMemberMessagesAAQToBidderRequestContainerType item
)
Public Function IndexOf ( _
    item As AddMemberMessagesAAQToBidderRequestContainerType _
) As Integer
public:
int IndexOf(
    AddMemberMessagesAAQToBidderRequestContainerType^ item
)
Parameters
item (AddMemberMessagesAAQToBidderRequestContainerType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► Insert(Int32, AddMemberMessagesAAQToBidderRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AddMemberMessagesAAQToBidderRequestContainerType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AddMemberMessagesAAQToBidderRequestContainerType _
)
public:
void Insert(
    int index,
    AddMemberMessagesAAQToBidderRequestContainerType^ item
)
Parameters
index (Int32)
item (AddMemberMessagesAAQToBidderRequestContainerType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderRequestContainerType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AddMemberMessagesAAQToBidderRequestContainerType
    Get
    Set
public:
property AddMemberMessagesAAQToBidderRequestContainerType^ default[int index] {
    AddMemberMessagesAAQToBidderRequestContainerType^ get (int index);
    void set (int index, AddMemberMessagesAAQToBidderRequestContainerType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderRequestContainerType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AddMemberMessagesAAQToBidderRequestContainerType
public:
AddMemberMessagesAAQToBidderRequestContainerType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► Remove(AddMemberMessagesAAQToBidderRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AddMemberMessagesAAQToBidderRequestContainerType item
)
Public Sub Remove ( _
    item As AddMemberMessagesAAQToBidderRequestContainerType _
)
public:
void Remove(
    AddMemberMessagesAAQToBidderRequestContainerType^ item
)
Parameters
item (AddMemberMessagesAAQToBidderRequestContainerType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderRequestContainerType[] ToArray()
Public Function ToArray As AddMemberMessagesAAQToBidderRequestContainerType()
public:
array<AddMemberMessagesAAQToBidderRequestContainerType^>^ ToArray()
Return Value


AddMemberMessagesAAQToBidderRequestType Class

AddMemberMessagesAAQToBidderRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddMemberMessagesAAQToBidderRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddMemberMessagesAAQToBidderRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddMemberMessagesAAQToBidderRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessagesAAQToBidderRequestType()()()() |
 | AddMemberMessagesAAQToBidderRequestContainer |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddMemberMessagesAAQToBidderRequestType


AddMemberMessagesAAQToBidderRequestContainer Property

AddMemberMessagesAAQToBidderRequestContainer Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestType ► AddMemberMessagesAAQToBidderRequestContainer
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderRequestContainerTypeCollection AddMemberMessagesAAQToBidderRequestContainer { get; set; }
Public Property AddMemberMessagesAAQToBidderRequestContainer As AddMemberMessagesAAQToBidderRequestContainerTypeCollection
    Get
    Set
public:
property AddMemberMessagesAAQToBidderRequestContainerTypeCollection^ AddMemberMessagesAAQToBidderRequestContainer {
    AddMemberMessagesAAQToBidderRequestContainerTypeCollection^ get ();
    void set (AddMemberMessagesAAQToBidderRequestContainerTypeCollection^ value);
}


AddMemberMessagesAAQToBidderRequestType Constructor

AddMemberMessagesAAQToBidderRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestType ► AddMemberMessagesAAQToBidderRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderRequestType()
Public Sub New
public:
AddMemberMessagesAAQToBidderRequestType()


AddMemberMessagesAAQToBidderResponseContainerType Class

AddMemberMessagesAAQToBidderResponseContainerType Class
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddMemberMessagesAAQToBidderResponseContainerType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddMemberMessagesAAQToBidderResponseContainerType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddMemberMessagesAAQToBidderResponseContainerType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessagesAAQToBidderResponseContainerType()()()() |
 | Ack |
 | AckSpecified |
 | CorrelationID |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AddMemberMessagesAAQToBidderResponseContainerType


Ack Property

Ack Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerType ► Ack
Declaration Syntax
C# Visual Basic Visual C++
public AckCodeType Ack { get; set; }
Public Property Ack As AckCodeType
    Get
    Set
public:
property AckCodeType Ack {
    AckCodeType get ();
    void set (AckCodeType value);
}


AckSpecified Property

AckSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerType ► AckSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AckSpecified { get; set; }
Public Property AckSpecified As Boolean
    Get
    Set
public:
property bool AckSpecified {
    bool get ();
    void set (bool value);
}


AddMemberMessagesAAQToBidderResponseContainerType Constructor

AddMemberMessagesAAQToBidderResponseContainerType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerType ► AddMemberMessagesAAQToBidderResponseContainerType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseContainerType()
Public Sub New
public:
AddMemberMessagesAAQToBidderResponseContainerType()


CorrelationID Property

CorrelationID Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerType ► CorrelationID
Declaration Syntax
C# Visual Basic Visual C++
public string CorrelationID { get; set; }
Public Property CorrelationID As String
    Get
    Set
public:
property String^ CorrelationID {
    String^ get ();
    void set (String^ value);
}


AddMemberMessagesAAQToBidderResponseContainerTypeCollection Class

AddMemberMessagesAAQToBidderResponseContainerTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AddMemberMessagesAAQToBidderResponseContainerTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AddMemberMessagesAAQToBidderResponseContainerTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AddMemberMessagesAAQToBidderResponseContainerTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessagesAAQToBidderResponseContainerTypeCollection()()()() |
 | AddMemberMessagesAAQToBidderResponseContainerTypeCollection(array<AddMemberMessagesAAQToBidderResponseContainerType>[]()[][]) |
 | AddMemberMessagesAAQToBidderResponseContainerTypeCollection(AddMemberMessagesAAQToBidderResponseContainerTypeCollection) |
 | Add(AddMemberMessagesAAQToBidderResponseContainerType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AddMemberMessagesAAQToBidderResponseContainerType>[]()[][]) |
 | AddRange(AddMemberMessagesAAQToBidderResponseContainerTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AddMemberMessagesAAQToBidderResponseContainerType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AddMemberMessagesAAQToBidderResponseContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AddMemberMessagesAAQToBidderResponseContainerType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AddMemberMessagesAAQToBidderResponseContainerType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AddMemberMessagesAAQToBidderResponseContainerType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AddMemberMessagesAAQToBidderResponseContainerTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► Add(AddMemberMessagesAAQToBidderResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AddMemberMessagesAAQToBidderResponseContainerType item
)
Public Function Add ( _
    item As AddMemberMessagesAAQToBidderResponseContainerType _
) As Integer
public:
int Add(
    AddMemberMessagesAAQToBidderResponseContainerType^ item
)
Parameters
item (AddMemberMessagesAAQToBidderResponseContainerType)
Return Value


AddMemberMessagesAAQToBidderResponseContainerTypeCollection Constructor

AddMemberMessagesAAQToBidderResponseContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection()()()()
Members
Icon | Member | Description
 | AddMemberMessagesAAQToBidderResponseContainerTypeCollection()()()() |
 | AddMemberMessagesAAQToBidderResponseContainerTypeCollection(array<AddMemberMessagesAAQToBidderResponseContainerType>[]()[][]) |
 | AddMemberMessagesAAQToBidderResponseContainerTypeCollection(AddMemberMessagesAAQToBidderResponseContainerTypeCollection) |


AddMemberMessagesAAQToBidderResponseContainerTypeCollection Constructor

AddMemberMessagesAAQToBidderResponseContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseContainerTypeCollection()
Public Sub New
public:
AddMemberMessagesAAQToBidderResponseContainerTypeCollection()


AddMemberMessagesAAQToBidderResponseContainerTypeCollection Constructor (items)

AddMemberMessagesAAQToBidderResponseContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection(array<AddMemberMessagesAAQToBidderResponseContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseContainerTypeCollection(
    AddMemberMessagesAAQToBidderResponseContainerType[] items
)
Public Sub New ( _
    items As AddMemberMessagesAAQToBidderResponseContainerType() _
)
public:
AddMemberMessagesAAQToBidderResponseContainerTypeCollection(
    array<AddMemberMessagesAAQToBidderResponseContainerType^>^ items
)
Parameters
items (array< AddMemberMessagesAAQToBidderResponseContainerType >[]()[][])


AddMemberMessagesAAQToBidderResponseContainerTypeCollection Constructor (items)

AddMemberMessagesAAQToBidderResponseContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection(AddMemberMessagesAAQToBidderResponseContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseContainerTypeCollection(
    AddMemberMessagesAAQToBidderResponseContainerTypeCollection items
)
Public Sub New ( _
    items As AddMemberMessagesAAQToBidderResponseContainerTypeCollection _
)
public:
AddMemberMessagesAAQToBidderResponseContainerTypeCollection(
    AddMemberMessagesAAQToBidderResponseContainerTypeCollection^ items
)
Parameters
items (AddMemberMessagesAAQToBidderResponseContainerTypeCollection)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AddMemberMessagesAAQToBidderResponseContainerType>[]()[][]) |
 | AddRange(AddMemberMessagesAAQToBidderResponseContainerTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► AddRange(array<AddMemberMessagesAAQToBidderResponseContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AddMemberMessagesAAQToBidderResponseContainerType[] items
)
Public Sub AddRange ( _
    items As AddMemberMessagesAAQToBidderResponseContainerType() _
)
public:
void AddRange(
    array<AddMemberMessagesAAQToBidderResponseContainerType^>^ items
)
Parameters
items (array< AddMemberMessagesAAQToBidderResponseContainerType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► AddRange(AddMemberMessagesAAQToBidderResponseContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AddMemberMessagesAAQToBidderResponseContainerTypeCollection items
)
Public Sub AddRange ( _
    items As AddMemberMessagesAAQToBidderResponseContainerTypeCollection _
)
public:
void AddRange(
    AddMemberMessagesAAQToBidderResponseContainerTypeCollection^ items
)
Parameters
items (AddMemberMessagesAAQToBidderResponseContainerTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► Contains(AddMemberMessagesAAQToBidderResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AddMemberMessagesAAQToBidderResponseContainerType item
)
Public Function Contains ( _
    item As AddMemberMessagesAAQToBidderResponseContainerType _
) As Boolean
public:
bool Contains(
    AddMemberMessagesAAQToBidderResponseContainerType^ item
)
Parameters
item (AddMemberMessagesAAQToBidderResponseContainerType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► CopyTo(array<AddMemberMessagesAAQToBidderResponseContainerType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AddMemberMessagesAAQToBidderResponseContainerType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AddMemberMessagesAAQToBidderResponseContainerType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AddMemberMessagesAAQToBidderResponseContainerType^>^ items,
    int index
)
Parameters
items (array< AddMemberMessagesAAQToBidderResponseContainerType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► IndexOf(AddMemberMessagesAAQToBidderResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AddMemberMessagesAAQToBidderResponseContainerType item
)
Public Function IndexOf ( _
    item As AddMemberMessagesAAQToBidderResponseContainerType _
) As Integer
public:
int IndexOf(
    AddMemberMessagesAAQToBidderResponseContainerType^ item
)
Parameters
item (AddMemberMessagesAAQToBidderResponseContainerType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► Insert(Int32, AddMemberMessagesAAQToBidderResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AddMemberMessagesAAQToBidderResponseContainerType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AddMemberMessagesAAQToBidderResponseContainerType _
)
public:
void Insert(
    int index,
    AddMemberMessagesAAQToBidderResponseContainerType^ item
)
Parameters
index (Int32)
item (AddMemberMessagesAAQToBidderResponseContainerType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseContainerType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AddMemberMessagesAAQToBidderResponseContainerType
    Get
    Set
public:
property AddMemberMessagesAAQToBidderResponseContainerType^ default[int index] {
    AddMemberMessagesAAQToBidderResponseContainerType^ get (int index);
    void set (int index, AddMemberMessagesAAQToBidderResponseContainerType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseContainerType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AddMemberMessagesAAQToBidderResponseContainerType
public:
AddMemberMessagesAAQToBidderResponseContainerType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► Remove(AddMemberMessagesAAQToBidderResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AddMemberMessagesAAQToBidderResponseContainerType item
)
Public Sub Remove ( _
    item As AddMemberMessagesAAQToBidderResponseContainerType _
)
public:
void Remove(
    AddMemberMessagesAAQToBidderResponseContainerType^ item
)
Parameters
item (AddMemberMessagesAAQToBidderResponseContainerType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseContainerType[] ToArray()
Public Function ToArray As AddMemberMessagesAAQToBidderResponseContainerType()
public:
array<AddMemberMessagesAAQToBidderResponseContainerType^>^ ToArray()
Return Value


AddMemberMessagesAAQToBidderResponseType Class

AddMemberMessagesAAQToBidderResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddMemberMessagesAAQToBidderResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddMemberMessagesAAQToBidderResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddMemberMessagesAAQToBidderResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddMemberMessagesAAQToBidderResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | AddMemberMessagesAAQToBidderResponseContainer |
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddMemberMessagesAAQToBidderResponseType


AddMemberMessagesAAQToBidderResponseContainer Property

AddMemberMessagesAAQToBidderResponseContainer Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseType ► AddMemberMessagesAAQToBidderResponseContainer
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseContainerTypeCollection AddMemberMessagesAAQToBidderResponseContainer { get; set; }
Public Property AddMemberMessagesAAQToBidderResponseContainer As AddMemberMessagesAAQToBidderResponseContainerTypeCollection
    Get
    Set
public:
property AddMemberMessagesAAQToBidderResponseContainerTypeCollection^ AddMemberMessagesAAQToBidderResponseContainer {
    AddMemberMessagesAAQToBidderResponseContainerTypeCollection^ get ();
    void set (AddMemberMessagesAAQToBidderResponseContainerTypeCollection^ value);
}


AddMemberMessagesAAQToBidderResponseType Constructor

AddMemberMessagesAAQToBidderResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseType ► AddMemberMessagesAAQToBidderResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseType()
Public Sub New
public:
AddMemberMessagesAAQToBidderResponseType()


AddOrderRequestType Class

AddOrderRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddOrderRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddOrderRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddOrderRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddOrderRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddOrderRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | Order |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddOrderRequestType


AddOrderRequestType Constructor

AddOrderRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddOrderRequestType ► AddOrderRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddOrderRequestType()
Public Sub New
public:
AddOrderRequestType()


Order Property

Order Property
Namespaces ► eBay.Service.Core.Soap ► AddOrderRequestType ► Order
Declaration Syntax
C# Visual Basic Visual C++
public OrderType Order { get; set; }
Public Property Order As OrderType
    Get
    Set
public:
property OrderType^ Order {
    OrderType^ get ();
    void set (OrderType^ value);
}


AddOrderResponseType Class

AddOrderResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddOrderResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddOrderResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddOrderResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddOrderResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddOrderResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | CreatedTime |
 | CreatedTimeSpecified |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | OrderID |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddOrderResponseType


AddOrderResponseType Constructor

AddOrderResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddOrderResponseType ► AddOrderResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddOrderResponseType()
Public Sub New
public:
AddOrderResponseType()


CreatedTime Property

CreatedTime Property
Namespaces ► eBay.Service.Core.Soap ► AddOrderResponseType ► CreatedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreatedTime { get; set; }
Public Property CreatedTime As DateTime
    Get
    Set
public:
property DateTime CreatedTime {
    DateTime get ();
    void set (DateTime value);
}


CreatedTimeSpecified Property

CreatedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddOrderResponseType ► CreatedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreatedTimeSpecified { get; set; }
Public Property CreatedTimeSpecified As Boolean
    Get
    Set
public:
property bool CreatedTimeSpecified {
    bool get ();
    void set (bool value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Core.Soap ► AddOrderResponseType ► OrderID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


AddressAttributeCodeType Enumeration

AddressAttributeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AddressAttributeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AddressAttributeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AddressAttributeCodeType
Members
Member | Description
ReferenceNumber |
CustomCode |
Remarks


AddressAttributeType Class

AddressAttributeType Class
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddressAttributeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddressAttributeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddressAttributeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddressAttributeType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | type |
 | typeSpecified |
 | Value |
Remarks
Inheritance Hierarchy
Object
AddressAttributeType


AddressAttributeType Constructor

AddressAttributeType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeType ► AddressAttributeType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddressAttributeType()
Public Sub New
public:
AddressAttributeType()


type Property

type Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeType ► type
Declaration Syntax
C# Visual Basic Visual C++
public AddressAttributeCodeType type { get; set; }
Public Property type As AddressAttributeCodeType
    Get
    Set
public:
property AddressAttributeCodeType type {
    AddressAttributeCodeType get ();
    void set (AddressAttributeCodeType value);
}


typeSpecified Property

typeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeType ► typeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool typeSpecified { get; set; }
Public Property typeSpecified As Boolean
    Get
    Set
public:
property bool typeSpecified {
    bool get ();
    void set (bool value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


AddressAttributeTypeCollection Class

AddressAttributeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AddressAttributeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AddressAttributeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AddressAttributeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddressAttributeTypeCollection()()()() |
 | AddressAttributeTypeCollection(array<AddressAttributeType>[]()[][]) |
 | AddressAttributeTypeCollection(AddressAttributeTypeCollection) |
 | Add(AddressAttributeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AddressAttributeType>[]()[][]) |
 | AddRange(AddressAttributeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AddressAttributeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AddressAttributeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AddressAttributeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AddressAttributeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AddressAttributeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AddressAttributeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► Add(AddressAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AddressAttributeType item
)
Public Function Add ( _
    item As AddressAttributeType _
) As Integer
public:
int Add(
    AddressAttributeType^ item
)
Parameters
item (AddressAttributeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AddressAttributeType>[]()[][]) |
 | AddRange(AddressAttributeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► AddRange(array<AddressAttributeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AddressAttributeType[] items
)
Public Sub AddRange ( _
    items As AddressAttributeType() _
)
public:
void AddRange(
    array<AddressAttributeType^>^ items
)
Parameters
items (array< AddressAttributeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► AddRange(AddressAttributeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AddressAttributeTypeCollection items
)
Public Sub AddRange ( _
    items As AddressAttributeTypeCollection _
)
public:
void AddRange(
    AddressAttributeTypeCollection^ items
)
Parameters
items (AddressAttributeTypeCollection)


AddressAttributeTypeCollection Constructor

AddressAttributeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► AddressAttributeTypeCollection()()()()
Members
Icon | Member | Description
 | AddressAttributeTypeCollection()()()() |
 | AddressAttributeTypeCollection(array<AddressAttributeType>[]()[][]) |
 | AddressAttributeTypeCollection(AddressAttributeTypeCollection) |


AddressAttributeTypeCollection Constructor

AddressAttributeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► AddressAttributeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddressAttributeTypeCollection()
Public Sub New
public:
AddressAttributeTypeCollection()


AddressAttributeTypeCollection Constructor (items)

AddressAttributeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► AddressAttributeTypeCollection(array<AddressAttributeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AddressAttributeTypeCollection(
    AddressAttributeType[] items
)
Public Sub New ( _
    items As AddressAttributeType() _
)
public:
AddressAttributeTypeCollection(
    array<AddressAttributeType^>^ items
)
Parameters
items (array< AddressAttributeType >[]()[][])


AddressAttributeTypeCollection Constructor (items)

AddressAttributeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► AddressAttributeTypeCollection(AddressAttributeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AddressAttributeTypeCollection(
    AddressAttributeTypeCollection items
)
Public Sub New ( _
    items As AddressAttributeTypeCollection _
)
public:
AddressAttributeTypeCollection(
    AddressAttributeTypeCollection^ items
)
Parameters
items (AddressAttributeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► Contains(AddressAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AddressAttributeType item
)
Public Function Contains ( _
    item As AddressAttributeType _
) As Boolean
public:
bool Contains(
    AddressAttributeType^ item
)
Parameters
item (AddressAttributeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► CopyTo(array<AddressAttributeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AddressAttributeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AddressAttributeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AddressAttributeType^>^ items,
    int index
)
Parameters
items (array< AddressAttributeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► IndexOf(AddressAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AddressAttributeType item
)
Public Function IndexOf ( _
    item As AddressAttributeType _
) As Integer
public:
int IndexOf(
    AddressAttributeType^ item
)
Parameters
item (AddressAttributeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► Insert(Int32, AddressAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AddressAttributeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AddressAttributeType _
)
public:
void Insert(
    int index,
    AddressAttributeType^ item
)
Parameters
index (Int32)
item (AddressAttributeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AddressAttributeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AddressAttributeType
    Get
    Set
public:
property AddressAttributeType^ default[int index] {
    AddressAttributeType^ get (int index);
    void set (int index, AddressAttributeType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AddressAttributeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AddressAttributeType
public:
AddressAttributeType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► Remove(AddressAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AddressAttributeType item
)
Public Sub Remove ( _
    item As AddressAttributeType _
)
public:
void Remove(
    AddressAttributeType^ item
)
Parameters
item (AddressAttributeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddressAttributeType[] ToArray()
Public Function ToArray As AddressAttributeType()
public:
array<AddressAttributeType^>^ ToArray()
Return Value


AddressOwnerCodeType Enumeration

AddressOwnerCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AddressOwnerCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AddressOwnerCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AddressOwnerCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AddressOwnerCodeType
Members
Member | Description
PayPal |
eBay |
CustomCode |
Remarks


AddressRecordTypeCodeType Enumeration

AddressRecordTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AddressRecordTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AddressRecordTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AddressRecordTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AddressRecordTypeCodeType
Members
Member | Description
Residential |
Business |
CustomCode |
Remarks


AddressStatusCodeType Enumeration

AddressStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AddressStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AddressStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AddressStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AddressStatusCodeType
Members
Member | Description
None |
Confirmed |
Unconfirmed |
CustomCode |
Remarks


AddressType Class

AddressType Class
Namespaces ► eBay.Service.Core.Soap ► AddressType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddressType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddressType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddressType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddressType()()()() |
 | AddressAttribute |
 | AddressID |
 | AddressOwner |
 | AddressOwnerSpecified |
 | AddressRecordType |
 | AddressRecordTypeSpecified |
 | AddressStatus |
 | AddressStatusSpecified |
 | AddressUsage |
 | AddressUsageSpecified |
 | Any |
 | CityName |
 | CompanyName |
 | Country |
 | CountryName |
 | CountrySpecified |
 | County |
 | Equals(Object) | (Inherited from Object.)
 | ExternalAddressID |
 | Finalize()()()() | (Inherited from Object.)
 | FirstName |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InternationalName |
 | InternationalStateAndCity |
 | InternationalStreet |
 | LastName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | Phone |
 | Phone2 |
 | Phone2AreaOrCityCode |
 | Phone2CountryCode |
 | Phone2CountryCodeSpecified |
 | Phone2CountryPrefix |
 | Phone2LocalNumber |
 | PhoneAreaOrCityCode |
 | PhoneCountryCode |
 | PhoneCountryCodeSpecified |
 | PhoneCountryPrefix |
 | PhoneLocalNumber |
 | PostalCode |
 | ReferenceID |
 | StateOrProvince |
 | Street |
 | Street1 |
 | Street2 |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AddressType


AddressAttribute Property

AddressAttribute Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► AddressAttribute
Declaration Syntax
C# Visual Basic Visual C++
public AddressAttributeTypeCollection AddressAttribute { get; set; }
Public Property AddressAttribute As AddressAttributeTypeCollection
    Get
    Set
public:
property AddressAttributeTypeCollection^ AddressAttribute {
    AddressAttributeTypeCollection^ get ();
    void set (AddressAttributeTypeCollection^ value);
}


AddressID Property

AddressID Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► AddressID
Declaration Syntax
C# Visual Basic Visual C++
public string AddressID { get; set; }
Public Property AddressID As String
    Get
    Set
public:
property String^ AddressID {
    String^ get ();
    void set (String^ value);
}


AddressOwner Property

AddressOwner Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► AddressOwner
Declaration Syntax
C# Visual Basic Visual C++
public AddressOwnerCodeType AddressOwner { get; set; }
Public Property AddressOwner As AddressOwnerCodeType
    Get
    Set
public:
property AddressOwnerCodeType AddressOwner {
    AddressOwnerCodeType get ();
    void set (AddressOwnerCodeType value);
}


AddressOwnerSpecified Property

AddressOwnerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► AddressOwnerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AddressOwnerSpecified { get; set; }
Public Property AddressOwnerSpecified As Boolean
    Get
    Set
public:
property bool AddressOwnerSpecified {
    bool get ();
    void set (bool value);
}


AddressRecordType Property

AddressRecordType Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► AddressRecordType
Declaration Syntax
C# Visual Basic Visual C++
public AddressRecordTypeCodeType AddressRecordType { get; set; }
Public Property AddressRecordType As AddressRecordTypeCodeType
    Get
    Set
public:
property AddressRecordTypeCodeType AddressRecordType {
    AddressRecordTypeCodeType get ();
    void set (AddressRecordTypeCodeType value);
}


AddressRecordTypeSpecified Property

AddressRecordTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► AddressRecordTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AddressRecordTypeSpecified { get; set; }
Public Property AddressRecordTypeSpecified As Boolean
    Get
    Set
public:
property bool AddressRecordTypeSpecified {
    bool get ();
    void set (bool value);
}


AddressStatus Property

AddressStatus Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► AddressStatus
Declaration Syntax
C# Visual Basic Visual C++
public AddressStatusCodeType AddressStatus { get; set; }
Public Property AddressStatus As AddressStatusCodeType
    Get
    Set
public:
property AddressStatusCodeType AddressStatus {
    AddressStatusCodeType get ();
    void set (AddressStatusCodeType value);
}


AddressStatusSpecified Property

AddressStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► AddressStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AddressStatusSpecified { get; set; }
Public Property AddressStatusSpecified As Boolean
    Get
    Set
public:
property bool AddressStatusSpecified {
    bool get ();
    void set (bool value);
}


AddressType Constructor

AddressType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddressType ► AddressType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddressType()
Public Sub New
public:
AddressType()


AddressUsage Property

AddressUsage Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► AddressUsage
Declaration Syntax
C# Visual Basic Visual C++
public AddressUsageCodeType AddressUsage { get; set; }
Public Property AddressUsage As AddressUsageCodeType
    Get
    Set
public:
property AddressUsageCodeType AddressUsage {
    AddressUsageCodeType get ();
    void set (AddressUsageCodeType value);
}


AddressUsageSpecified Property

AddressUsageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► AddressUsageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AddressUsageSpecified { get; set; }
Public Property AddressUsageSpecified As Boolean
    Get
    Set
public:
property bool AddressUsageSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CityName Property

CityName Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► CityName
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}


CompanyName Property

CompanyName Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► CompanyName
Declaration Syntax
C# Visual Basic Visual C++
public string CompanyName { get; set; }
Public Property CompanyName As String
    Get
    Set
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}


Country Property

Country Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Country
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType Country { get; set; }
Public Property Country As CountryCodeType
    Get
    Set
public:
property CountryCodeType Country {
    CountryCodeType get ();
    void set (CountryCodeType value);
}


CountryName Property

CountryName Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► CountryName
Declaration Syntax
C# Visual Basic Visual C++
public string CountryName { get; set; }
Public Property CountryName As String
    Get
    Set
public:
property String^ CountryName {
    String^ get ();
    void set (String^ value);
}


CountrySpecified Property

CountrySpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► CountrySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CountrySpecified { get; set; }
Public Property CountrySpecified As Boolean
    Get
    Set
public:
property bool CountrySpecified {
    bool get ();
    void set (bool value);
}


County Property

County Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► County
Declaration Syntax
C# Visual Basic Visual C++
public string County { get; set; }
Public Property County As String
    Get
    Set
public:
property String^ County {
    String^ get ();
    void set (String^ value);
}


ExternalAddressID Property

ExternalAddressID Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► ExternalAddressID
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalAddressID { get; set; }
Public Property ExternalAddressID As String
    Get
    Set
public:
property String^ ExternalAddressID {
    String^ get ();
    void set (String^ value);
}


FirstName Property

FirstName Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► FirstName
Declaration Syntax
C# Visual Basic Visual C++
public string FirstName { get; set; }
Public Property FirstName As String
    Get
    Set
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}


InternationalName Property

InternationalName Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► InternationalName
Declaration Syntax
C# Visual Basic Visual C++
public string InternationalName { get; set; }
Public Property InternationalName As String
    Get
    Set
public:
property String^ InternationalName {
    String^ get ();
    void set (String^ value);
}


InternationalStateAndCity Property

InternationalStateAndCity Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► InternationalStateAndCity
Declaration Syntax
C# Visual Basic Visual C++
public string InternationalStateAndCity { get; set; }
Public Property InternationalStateAndCity As String
    Get
    Set
public:
property String^ InternationalStateAndCity {
    String^ get ();
    void set (String^ value);
}


InternationalStreet Property

InternationalStreet Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► InternationalStreet
Declaration Syntax
C# Visual Basic Visual C++
public string InternationalStreet { get; set; }
Public Property InternationalStreet As String
    Get
    Set
public:
property String^ InternationalStreet {
    String^ get ();
    void set (String^ value);
}


LastName Property

LastName Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► LastName
Declaration Syntax
C# Visual Basic Visual C++
public string LastName { get; set; }
Public Property LastName As String
    Get
    Set
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Phone Property

Phone Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Phone
Declaration Syntax
C# Visual Basic Visual C++
public string Phone { get; set; }
Public Property Phone As String
    Get
    Set
public:
property String^ Phone {
    String^ get ();
    void set (String^ value);
}


Phone2 Property

Phone2 Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Phone2
Declaration Syntax
C# Visual Basic Visual C++
public string Phone2 { get; set; }
Public Property Phone2 As String
    Get
    Set
public:
property String^ Phone2 {
    String^ get ();
    void set (String^ value);
}


Phone2AreaOrCityCode Property

Phone2AreaOrCityCode Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Phone2AreaOrCityCode
Declaration Syntax
C# Visual Basic Visual C++
public string Phone2AreaOrCityCode { get; set; }
Public Property Phone2AreaOrCityCode As String
    Get
    Set
public:
property String^ Phone2AreaOrCityCode {
    String^ get ();
    void set (String^ value);
}


Phone2CountryCode Property

Phone2CountryCode Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Phone2CountryCode
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType Phone2CountryCode { get; set; }
Public Property Phone2CountryCode As CountryCodeType
    Get
    Set
public:
property CountryCodeType Phone2CountryCode {
    CountryCodeType get ();
    void set (CountryCodeType value);
}


Phone2CountryCodeSpecified Property

Phone2CountryCodeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Phone2CountryCodeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool Phone2CountryCodeSpecified { get; set; }
Public Property Phone2CountryCodeSpecified As Boolean
    Get
    Set
public:
property bool Phone2CountryCodeSpecified {
    bool get ();
    void set (bool value);
}


Phone2CountryPrefix Property

Phone2CountryPrefix Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Phone2CountryPrefix
Declaration Syntax
C# Visual Basic Visual C++
public string Phone2CountryPrefix { get; set; }
Public Property Phone2CountryPrefix As String
    Get
    Set
public:
property String^ Phone2CountryPrefix {
    String^ get ();
    void set (String^ value);
}


Phone2LocalNumber Property

Phone2LocalNumber Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Phone2LocalNumber
Declaration Syntax
C# Visual Basic Visual C++
public string Phone2LocalNumber { get; set; }
Public Property Phone2LocalNumber As String
    Get
    Set
public:
property String^ Phone2LocalNumber {
    String^ get ();
    void set (String^ value);
}


PhoneAreaOrCityCode Property

PhoneAreaOrCityCode Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► PhoneAreaOrCityCode
Declaration Syntax
C# Visual Basic Visual C++
public string PhoneAreaOrCityCode { get; set; }
Public Property PhoneAreaOrCityCode As String
    Get
    Set
public:
property String^ PhoneAreaOrCityCode {
    String^ get ();
    void set (String^ value);
}


PhoneCountryCode Property

PhoneCountryCode Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► PhoneCountryCode
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType PhoneCountryCode { get; set; }
Public Property PhoneCountryCode As CountryCodeType
    Get
    Set
public:
property CountryCodeType PhoneCountryCode {
    CountryCodeType get ();
    void set (CountryCodeType value);
}


PhoneCountryCodeSpecified Property

PhoneCountryCodeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► PhoneCountryCodeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PhoneCountryCodeSpecified { get; set; }
Public Property PhoneCountryCodeSpecified As Boolean
    Get
    Set
public:
property bool PhoneCountryCodeSpecified {
    bool get ();
    void set (bool value);
}


PhoneCountryPrefix Property

PhoneCountryPrefix Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► PhoneCountryPrefix
Declaration Syntax
C# Visual Basic Visual C++
public string PhoneCountryPrefix { get; set; }
Public Property PhoneCountryPrefix As String
    Get
    Set
public:
property String^ PhoneCountryPrefix {
    String^ get ();
    void set (String^ value);
}


PhoneLocalNumber Property

PhoneLocalNumber Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► PhoneLocalNumber
Declaration Syntax
C# Visual Basic Visual C++
public string PhoneLocalNumber { get; set; }
Public Property PhoneLocalNumber As String
    Get
    Set
public:
property String^ PhoneLocalNumber {
    String^ get ();
    void set (String^ value);
}


PostalCode Property

PostalCode Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► PostalCode
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


ReferenceID Property

ReferenceID Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► ReferenceID
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceID { get; set; }
Public Property ReferenceID As String
    Get
    Set
public:
property String^ ReferenceID {
    String^ get ();
    void set (String^ value);
}


StateOrProvince Property

StateOrProvince Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► StateOrProvince
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvince { get; set; }
Public Property StateOrProvince As String
    Get
    Set
public:
property String^ StateOrProvince {
    String^ get ();
    void set (String^ value);
}


Street Property

Street Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Street
Declaration Syntax
C# Visual Basic Visual C++
public string Street { get; set; }
Public Property Street As String
    Get
    Set
public:
property String^ Street {
    String^ get ();
    void set (String^ value);
}


Street1 Property

Street1 Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Street1
Declaration Syntax
C# Visual Basic Visual C++
public string Street1 { get; set; }
Public Property Street1 As String
    Get
    Set
public:
property String^ Street1 {
    String^ get ();
    void set (String^ value);
}


Street2 Property

Street2 Property
Namespaces ► eBay.Service.Core.Soap ► AddressType ► Street2
Declaration Syntax
C# Visual Basic Visual C++
public string Street2 { get; set; }
Public Property Street2 As String
    Get
    Set
public:
property String^ Street2 {
    String^ get ();
    void set (String^ value);
}


AddressTypeCodeType Enumeration

AddressTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AddressTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AddressTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AddressTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AddressTypeCodeType
Members
Member | Description
Contact |
Registered |
CustomCode |
Remarks


AddressUsageCodeType Enumeration

AddressUsageCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AddressUsageCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AddressUsageCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AddressUsageCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AddressUsageCodeType
Members
Member | Description
DefaultShipping |
Shipping |
Invalid |
CustomCode |
Remarks


AddSecondChanceItemRequestType Class

AddSecondChanceItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddSecondChanceItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddSecondChanceItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddSecondChanceItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSecondChanceItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | BuyItNowPrice |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | Duration |
 | DurationSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | RecipientBidderUserID |
 | SellerMessage |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddSecondChanceItemRequestType


AddSecondChanceItemRequestType Constructor

AddSecondChanceItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemRequestType ► AddSecondChanceItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSecondChanceItemRequestType()
Public Sub New
public:
AddSecondChanceItemRequestType()


BuyItNowPrice Property

BuyItNowPrice Property
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemRequestType ► BuyItNowPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType BuyItNowPrice { get; set; }
Public Property BuyItNowPrice As AmountType
    Get
    Set
public:
property AmountType^ BuyItNowPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


Duration Property

Duration Property
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemRequestType ► Duration
Declaration Syntax
C# Visual Basic Visual C++
public SecondChanceOfferDurationCodeType Duration { get; set; }
Public Property Duration As SecondChanceOfferDurationCodeType
    Get
    Set
public:
property SecondChanceOfferDurationCodeType Duration {
    SecondChanceOfferDurationCodeType get ();
    void set (SecondChanceOfferDurationCodeType value);
}


DurationSpecified Property

DurationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemRequestType ► DurationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DurationSpecified { get; set; }
Public Property DurationSpecified As Boolean
    Get
    Set
public:
property bool DurationSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


RecipientBidderUserID Property

RecipientBidderUserID Property
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemRequestType ► RecipientBidderUserID
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientBidderUserID { get; set; }
Public Property RecipientBidderUserID As String
    Get
    Set
public:
property String^ RecipientBidderUserID {
    String^ get ();
    void set (String^ value);
}


SellerMessage Property

SellerMessage Property
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemRequestType ► SellerMessage
Declaration Syntax
C# Visual Basic Visual C++
public string SellerMessage { get; set; }
Public Property SellerMessage As String
    Get
    Set
public:
property String^ SellerMessage {
    String^ get ();
    void set (String^ value);
}


AddSecondChanceItemResponseType Class

AddSecondChanceItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddSecondChanceItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddSecondChanceItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddSecondChanceItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSecondChanceItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddSecondChanceItemResponseType


AddSecondChanceItemResponseType Constructor

AddSecondChanceItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemResponseType ► AddSecondChanceItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSecondChanceItemResponseType()
Public Sub New
public:
AddSecondChanceItemResponseType()


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddSecondChanceItemResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


AddSellingManagerInventoryFolderRequestType Class

AddSellingManagerInventoryFolderRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerInventoryFolderRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddSellingManagerInventoryFolderRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddSellingManagerInventoryFolderRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddSellingManagerInventoryFolderRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSellingManagerInventoryFolderRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | Comment |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderName |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ParentFolderID |
 | ParentFolderIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddSellingManagerInventoryFolderRequestType


AddSellingManagerInventoryFolderRequestType Constructor

AddSellingManagerInventoryFolderRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerInventoryFolderRequestType ► AddSellingManagerInventoryFolderRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerInventoryFolderRequestType()
Public Sub New
public:
AddSellingManagerInventoryFolderRequestType()


Comment Property

Comment Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerInventoryFolderRequestType ► Comment
Declaration Syntax
C# Visual Basic Visual C++
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}


FolderName Property

FolderName Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerInventoryFolderRequestType ► FolderName
Declaration Syntax
C# Visual Basic Visual C++
public string FolderName { get; set; }
Public Property FolderName As String
    Get
    Set
public:
property String^ FolderName {
    String^ get ();
    void set (String^ value);
}


ParentFolderID Property

ParentFolderID Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerInventoryFolderRequestType ► ParentFolderID
Declaration Syntax
C# Visual Basic Visual C++
public long ParentFolderID { get; set; }
Public Property ParentFolderID As Long
    Get
    Set
public:
property long long ParentFolderID {
    long long get ();
    void set (long long value);
}


ParentFolderIDSpecified Property

ParentFolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerInventoryFolderRequestType ► ParentFolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ParentFolderIDSpecified { get; set; }
Public Property ParentFolderIDSpecified As Boolean
    Get
    Set
public:
property bool ParentFolderIDSpecified {
    bool get ();
    void set (bool value);
}


AddSellingManagerInventoryFolderResponseType Class

AddSellingManagerInventoryFolderResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerInventoryFolderResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddSellingManagerInventoryFolderResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddSellingManagerInventoryFolderResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddSellingManagerInventoryFolderResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSellingManagerInventoryFolderResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID |
 | FolderIDSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddSellingManagerInventoryFolderResponseType


AddSellingManagerInventoryFolderResponseType Constructor

AddSellingManagerInventoryFolderResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerInventoryFolderResponseType ► AddSellingManagerInventoryFolderResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerInventoryFolderResponseType()
Public Sub New
public:
AddSellingManagerInventoryFolderResponseType()


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerInventoryFolderResponseType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerInventoryFolderResponseType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


AddSellingManagerProductRequestType Class

AddSellingManagerProductRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerProductRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddSellingManagerProductRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddSellingManagerProductRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddSellingManagerProductRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSellingManagerProductRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID |
 | FolderIDSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SellingManagerProductDetails |
 | SellingManagerProductSpecifics |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddSellingManagerProductRequestType


AddSellingManagerProductRequestType Constructor

AddSellingManagerProductRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerProductRequestType ► AddSellingManagerProductRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerProductRequestType()
Public Sub New
public:
AddSellingManagerProductRequestType()


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerProductRequestType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerProductRequestType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerProductRequestType ► SellingManagerProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; set; }
Public Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


SellingManagerProductSpecifics Property

SellingManagerProductSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerProductRequestType ► SellingManagerProductSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductSpecificsType SellingManagerProductSpecifics { get; set; }
Public Property SellingManagerProductSpecifics As SellingManagerProductSpecificsType
    Get
    Set
public:
property SellingManagerProductSpecificsType^ SellingManagerProductSpecifics {
    SellingManagerProductSpecificsType^ get ();
    void set (SellingManagerProductSpecificsType^ value);
}


AddSellingManagerProductResponseType Class

AddSellingManagerProductResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerProductResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddSellingManagerProductResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddSellingManagerProductResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddSellingManagerProductResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSellingManagerProductResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SellingManagerProductDetails |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddSellingManagerProductResponseType


AddSellingManagerProductResponseType Constructor

AddSellingManagerProductResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerProductResponseType ► AddSellingManagerProductResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerProductResponseType()
Public Sub New
public:
AddSellingManagerProductResponseType()


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerProductResponseType ► SellingManagerProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; set; }
Public Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


AddSellingManagerTemplateRequestType Class

AddSellingManagerTemplateRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddSellingManagerTemplateRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddSellingManagerTemplateRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddSellingManagerTemplateRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSellingManagerTemplateRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ProductID |
 | ProductIDSpecified |
 | SaleTemplateName |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddSellingManagerTemplateRequestType


AddSellingManagerTemplateRequestType Constructor

AddSellingManagerTemplateRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateRequestType ► AddSellingManagerTemplateRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerTemplateRequestType()
Public Sub New
public:
AddSellingManagerTemplateRequestType()


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ProductID Property

ProductID Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateRequestType ► ProductID
Declaration Syntax
C# Visual Basic Visual C++
public long ProductID { get; set; }
Public Property ProductID As Long
    Get
    Set
public:
property long long ProductID {
    long long get ();
    void set (long long value);
}


ProductIDSpecified Property

ProductIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateRequestType ► ProductIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductIDSpecified { get; set; }
Public Property ProductIDSpecified As Boolean
    Get
    Set
public:
property bool ProductIDSpecified {
    bool get ();
    void set (bool value);
}


SaleTemplateName Property

SaleTemplateName Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateRequestType ► SaleTemplateName
Declaration Syntax
C# Visual Basic Visual C++
public string SaleTemplateName { get; set; }
Public Property SaleTemplateName As String
    Get
    Set
public:
property String^ SaleTemplateName {
    String^ get ();
    void set (String^ value);
}


AddSellingManagerTemplateResponseType Class

AddSellingManagerTemplateResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddSellingManagerTemplateResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddSellingManagerTemplateResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddSellingManagerTemplateResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddSellingManagerTemplateResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category2ID |
 | Category2IDSpecified |
 | CategoryID |
 | CategoryIDSpecified |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SaleTemplateGroupID |
 | SaleTemplateGroupIDSpecified |
 | SaleTemplateID |
 | SaleTemplateIDSpecified |
 | SaleTemplateName |
 | SellingManagerProductDetails |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddSellingManagerTemplateResponseType


AddSellingManagerTemplateResponseType Constructor

AddSellingManagerTemplateResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► AddSellingManagerTemplateResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerTemplateResponseType()
Public Sub New
public:
AddSellingManagerTemplateResponseType()


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public long Category2ID { get; set; }
Public Property Category2ID As Long
    Get
    Set
public:
property long long Category2ID {
    long long get ();
    void set (long long value);
}


Category2IDSpecified Property

Category2IDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► Category2IDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool Category2IDSpecified { get; set; }
Public Property Category2IDSpecified As Boolean
    Get
    Set
public:
property bool Category2IDSpecified {
    bool get ();
    void set (bool value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public long CategoryID { get; set; }
Public Property CategoryID As Long
    Get
    Set
public:
property long long CategoryID {
    long long get ();
    void set (long long value);
}


CategoryIDSpecified Property

CategoryIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► CategoryIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CategoryIDSpecified { get; set; }
Public Property CategoryIDSpecified As Boolean
    Get
    Set
public:
property bool CategoryIDSpecified {
    bool get ();
    void set (bool value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


SaleTemplateGroupID Property

SaleTemplateGroupID Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► SaleTemplateGroupID
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateGroupID { get; set; }
Public Property SaleTemplateGroupID As Long
    Get
    Set
public:
property long long SaleTemplateGroupID {
    long long get ();
    void set (long long value);
}


SaleTemplateGroupIDSpecified Property

SaleTemplateGroupIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► SaleTemplateGroupIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SaleTemplateGroupIDSpecified { get; set; }
Public Property SaleTemplateGroupIDSpecified As Boolean
    Get
    Set
public:
property bool SaleTemplateGroupIDSpecified {
    bool get ();
    void set (bool value);
}


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► SaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


SaleTemplateIDSpecified Property

SaleTemplateIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► SaleTemplateIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SaleTemplateIDSpecified { get; set; }
Public Property SaleTemplateIDSpecified As Boolean
    Get
    Set
public:
property bool SaleTemplateIDSpecified {
    bool get ();
    void set (bool value);
}


SaleTemplateName Property

SaleTemplateName Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► SaleTemplateName
Declaration Syntax
C# Visual Basic Visual C++
public string SaleTemplateName { get; set; }
Public Property SaleTemplateName As String
    Get
    Set
public:
property String^ SaleTemplateName {
    String^ get ();
    void set (String^ value);
}


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► AddSellingManagerTemplateResponseType ► SellingManagerProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; set; }
Public Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


AddToItemDescriptionRequestType Class

AddToItemDescriptionRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddToItemDescriptionRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddToItemDescriptionRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddToItemDescriptionRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddToItemDescriptionRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddToItemDescriptionRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | Description |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddToItemDescriptionRequestType


AddToItemDescriptionRequestType Constructor

AddToItemDescriptionRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddToItemDescriptionRequestType ► AddToItemDescriptionRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddToItemDescriptionRequestType()
Public Sub New
public:
AddToItemDescriptionRequestType()


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► AddToItemDescriptionRequestType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddToItemDescriptionRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


AddToItemDescriptionResponseType Class

AddToItemDescriptionResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddToItemDescriptionResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddToItemDescriptionResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddToItemDescriptionResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddToItemDescriptionResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddToItemDescriptionResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddToItemDescriptionResponseType


AddToItemDescriptionResponseType Constructor

AddToItemDescriptionResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddToItemDescriptionResponseType ► AddToItemDescriptionResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddToItemDescriptionResponseType()
Public Sub New
public:
AddToItemDescriptionResponseType()


AddToWatchListRequestType Class

AddToWatchListRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddToWatchListRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddToWatchListRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddToWatchListRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddToWatchListRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddToWatchListRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | VariationKey |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddToWatchListRequestType


AddToWatchListRequestType Constructor

AddToWatchListRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddToWatchListRequestType ► AddToWatchListRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddToWatchListRequestType()
Public Sub New
public:
AddToWatchListRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddToWatchListRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ItemID { get; set; }
Public Property ItemID As StringCollection
    Get
    Set
public:
property StringCollection^ ItemID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


VariationKey Property

VariationKey Property
Namespaces ► eBay.Service.Core.Soap ► AddToWatchListRequestType ► VariationKey
Declaration Syntax
C# Visual Basic Visual C++
public VariationKeyTypeCollection VariationKey { get; set; }
Public Property VariationKey As VariationKeyTypeCollection
    Get
    Set
public:
property VariationKeyTypeCollection^ VariationKey {
    VariationKeyTypeCollection^ get ();
    void set (VariationKeyTypeCollection^ value);
}


AddToWatchListResponseType Class

AddToWatchListResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddToWatchListResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddToWatchListResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddToWatchListResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddToWatchListResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddToWatchListResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
 | WatchListCount |
 | WatchListCountSpecified |
 | WatchListMaximum |
 | WatchListMaximumSpecified |
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddToWatchListResponseType


AddToWatchListResponseType Constructor

AddToWatchListResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddToWatchListResponseType ► AddToWatchListResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddToWatchListResponseType()
Public Sub New
public:
AddToWatchListResponseType()


WatchListCount Property

WatchListCount Property
Namespaces ► eBay.Service.Core.Soap ► AddToWatchListResponseType ► WatchListCount
Declaration Syntax
C# Visual Basic Visual C++
public int WatchListCount { get; set; }
Public Property WatchListCount As Integer
    Get
    Set
public:
property int WatchListCount {
    int get ();
    void set (int value);
}


WatchListCountSpecified Property

WatchListCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddToWatchListResponseType ► WatchListCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WatchListCountSpecified { get; set; }
Public Property WatchListCountSpecified As Boolean
    Get
    Set
public:
property bool WatchListCountSpecified {
    bool get ();
    void set (bool value);
}


WatchListMaximum Property

WatchListMaximum Property
Namespaces ► eBay.Service.Core.Soap ► AddToWatchListResponseType ► WatchListMaximum
Declaration Syntax
C# Visual Basic Visual C++
public int WatchListMaximum { get; set; }
Public Property WatchListMaximum As Integer
    Get
    Set
public:
property int WatchListMaximum {
    int get ();
    void set (int value);
}


WatchListMaximumSpecified Property

WatchListMaximumSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddToWatchListResponseType ► WatchListMaximumSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WatchListMaximumSpecified { get; set; }
Public Property WatchListMaximumSpecified As Boolean
    Get
    Set
public:
property bool WatchListMaximumSpecified {
    bool get ();
    void set (bool value);
}


AddTransactionConfirmationItemRequestType Class

AddTransactionConfirmationItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddTransactionConfirmationItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddTransactionConfirmationItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddTransactionConfirmationItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddTransactionConfirmationItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | Comments |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | ListingDuration |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | NegotiatedPrice |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | RecipientPostalCode |
 | RecipientRelationType |
 | RecipientUserID |
 | ToString()()()() | (Inherited from Object.)
 | VerifyEligibilityOnly |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | AddTransactionConfirmationItemRequestType


AddTransactionConfirmationItemRequestType Constructor

AddTransactionConfirmationItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemRequestType ► AddTransactionConfirmationItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddTransactionConfirmationItemRequestType()
Public Sub New
public:
AddTransactionConfirmationItemRequestType()


Comments Property

Comments Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemRequestType ► Comments
Declaration Syntax
C# Visual Basic Visual C++
public string Comments { get; set; }
Public Property Comments As String
    Get
    Set
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingDuration Property

ListingDuration Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemRequestType ► ListingDuration
Declaration Syntax
C# Visual Basic Visual C++
public SecondChanceOfferDurationCodeType ListingDuration { get; set; }
Public Property ListingDuration As SecondChanceOfferDurationCodeType
    Get
    Set
public:
property SecondChanceOfferDurationCodeType ListingDuration {
    SecondChanceOfferDurationCodeType get ();
    void set (SecondChanceOfferDurationCodeType value);
}


NegotiatedPrice Property

NegotiatedPrice Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemRequestType ► NegotiatedPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType NegotiatedPrice { get; set; }
Public Property NegotiatedPrice As AmountType
    Get
    Set
public:
property AmountType^ NegotiatedPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


RecipientPostalCode Property

RecipientPostalCode Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemRequestType ► RecipientPostalCode
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientPostalCode { get; set; }
Public Property RecipientPostalCode As String
    Get
    Set
public:
property String^ RecipientPostalCode {
    String^ get ();
    void set (String^ value);
}


RecipientRelationType Property

RecipientRelationType Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemRequestType ► RecipientRelationType
Declaration Syntax
C# Visual Basic Visual C++
public RecipientRelationCodeType RecipientRelationType { get; set; }
Public Property RecipientRelationType As RecipientRelationCodeType
    Get
    Set
public:
property RecipientRelationCodeType RecipientRelationType {
    RecipientRelationCodeType get ();
    void set (RecipientRelationCodeType value);
}


RecipientUserID Property

RecipientUserID Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemRequestType ► RecipientUserID
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientUserID { get; set; }
Public Property RecipientUserID As String
    Get
    Set
public:
property String^ RecipientUserID {
    String^ get ();
    void set (String^ value);
}


VerifyEligibilityOnly Property

VerifyEligibilityOnly Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemRequestType ► VerifyEligibilityOnly
Declaration Syntax
C# Visual Basic Visual C++
public string VerifyEligibilityOnly { get; set; }
Public Property VerifyEligibilityOnly As String
    Get
    Set
public:
property String^ VerifyEligibilityOnly {
    String^ get ();
    void set (String^ value);
}


AddTransactionConfirmationItemResponseType Class

AddTransactionConfirmationItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AddTransactionConfirmationItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AddTransactionConfirmationItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AddTransactionConfirmationItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddTransactionConfirmationItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | AddTransactionConfirmationItemResponseType


AddTransactionConfirmationItemResponseType Constructor

AddTransactionConfirmationItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemResponseType ► AddTransactionConfirmationItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AddTransactionConfirmationItemResponseType()
Public Sub New
public:
AddTransactionConfirmationItemResponseType()


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AddTransactionConfirmationItemResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


AdFormatEnabledCodeType Enumeration

AdFormatEnabledCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AdFormatEnabledCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AdFormatEnabledCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AdFormatEnabledCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AdFormatEnabledCodeType
Members
Member | Description
Disabled |
Enabled |
Only |
ClassifiedAdEnabled |
ClassifiedAdOnly |
LocalMarketBestOfferOnly |
CustomCode |
Remarks


AdFormatEnabledDefinitionType Class

AdFormatEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► AdFormatEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AdFormatEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AdFormatEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AdFormatEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdFormatEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AdFormatEnabledDefinitionType


AdFormatEnabledDefinitionType Constructor

AdFormatEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► AdFormatEnabledDefinitionType ► AdFormatEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatEnabledDefinitionType()
Public Sub New
public:
AdFormatEnabledDefinitionType()


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AdFormatLeadStatusCodeType Enumeration

AdFormatLeadStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AdFormatLeadStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AdFormatLeadStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AdFormatLeadStatusCodeType
Members
Member | Description
New |
Responded |
CustomCode |
Remarks


AdFormatLeadType Class

AdFormatLeadType Class
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AdFormatLeadType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AdFormatLeadType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AdFormatLeadType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdFormatLeadType()()()() |
 | AdditionalInformation |
 | Address |
 | Answer1 |
 | Answer1Specified |
 | Answer2 |
 | Answer2Specified |
 | Any |
 | BestTimeToCall |
 | Email |
 | Equals(Object) | (Inherited from Object.)
 | ExternalEmail |
 | Finalize()()()() | (Inherited from Object.)
 | FinancingAnswer |
 | FinancingAnswerSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | ItemTitle |
 | LeadFee |
 | MemberMessage |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PurchaseTimeFrame |
 | Status |
 | StatusSpecified |
 | SubmittedTime |
 | SubmittedTimeSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TradeInMake |
 | TradeInModel |
 | TradeInYear |
 | UserID |
Remarks
Inheritance Hierarchy
Object
AdFormatLeadType


AdditionalInformation Property

AdditionalInformation Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► AdditionalInformation
Declaration Syntax
C# Visual Basic Visual C++
public string AdditionalInformation { get; set; }
Public Property AdditionalInformation As String
    Get
    Set
public:
property String^ AdditionalInformation {
    String^ get ();
    void set (String^ value);
}


Address Property

Address Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► Address
Declaration Syntax
C# Visual Basic Visual C++
public AddressType Address { get; set; }
Public Property Address As AddressType
    Get
    Set
public:
property AddressType^ Address {
    AddressType^ get ();
    void set (AddressType^ value);
}


AdFormatLeadType Constructor

AdFormatLeadType Constructor
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► AdFormatLeadType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadType()
Public Sub New
public:
AdFormatLeadType()


Answer1 Property

Answer1 Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► Answer1
Declaration Syntax
C# Visual Basic Visual C++
public bool Answer1 { get; set; }
Public Property Answer1 As Boolean
    Get
    Set
public:
property bool Answer1 {
    bool get ();
    void set (bool value);
}


Answer1Specified Property

Answer1Specified Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► Answer1Specified
Declaration Syntax
C# Visual Basic Visual C++
public bool Answer1Specified { get; set; }
Public Property Answer1Specified As Boolean
    Get
    Set
public:
property bool Answer1Specified {
    bool get ();
    void set (bool value);
}


Answer2 Property

Answer2 Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► Answer2
Declaration Syntax
C# Visual Basic Visual C++
public bool Answer2 { get; set; }
Public Property Answer2 As Boolean
    Get
    Set
public:
property bool Answer2 {
    bool get ();
    void set (bool value);
}


Answer2Specified Property

Answer2Specified Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► Answer2Specified
Declaration Syntax
C# Visual Basic Visual C++
public bool Answer2Specified { get; set; }
Public Property Answer2Specified As Boolean
    Get
    Set
public:
property bool Answer2Specified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestTimeToCall Property

BestTimeToCall Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► BestTimeToCall
Declaration Syntax
C# Visual Basic Visual C++
public string BestTimeToCall { get; set; }
Public Property BestTimeToCall As String
    Get
    Set
public:
property String^ BestTimeToCall {
    String^ get ();
    void set (String^ value);
}


Email Property

Email Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► Email
Declaration Syntax
C# Visual Basic Visual C++
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}


ExternalEmail Property

ExternalEmail Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► ExternalEmail
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalEmail { get; set; }
Public Property ExternalEmail As String
    Get
    Set
public:
property String^ ExternalEmail {
    String^ get ();
    void set (String^ value);
}


FinancingAnswer Property

FinancingAnswer Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► FinancingAnswer
Declaration Syntax
C# Visual Basic Visual C++
public bool FinancingAnswer { get; set; }
Public Property FinancingAnswer As Boolean
    Get
    Set
public:
property bool FinancingAnswer {
    bool get ();
    void set (bool value);
}


FinancingAnswerSpecified Property

FinancingAnswerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► FinancingAnswerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FinancingAnswerSpecified { get; set; }
Public Property FinancingAnswerSpecified As Boolean
    Get
    Set
public:
property bool FinancingAnswerSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ItemTitle Property

ItemTitle Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► ItemTitle
Declaration Syntax
C# Visual Basic Visual C++
public string ItemTitle { get; set; }
Public Property ItemTitle As String
    Get
    Set
public:
property String^ ItemTitle {
    String^ get ();
    void set (String^ value);
}


LeadFee Property

LeadFee Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► LeadFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType LeadFee { get; set; }
Public Property LeadFee As AmountType
    Get
    Set
public:
property AmountType^ LeadFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


MemberMessage Property

MemberMessage Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► MemberMessage
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeTypeCollection MemberMessage { get; set; }
Public Property MemberMessage As MemberMessageExchangeTypeCollection
    Get
    Set
public:
property MemberMessageExchangeTypeCollection^ MemberMessage {
    MemberMessageExchangeTypeCollection^ get ();
    void set (MemberMessageExchangeTypeCollection^ value);
}


PurchaseTimeFrame Property

PurchaseTimeFrame Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► PurchaseTimeFrame
Declaration Syntax
C# Visual Basic Visual C++
public string PurchaseTimeFrame { get; set; }
Public Property PurchaseTimeFrame As String
    Get
    Set
public:
property String^ PurchaseTimeFrame {
    String^ get ();
    void set (String^ value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadStatusCodeType Status { get; set; }
Public Property Status As AdFormatLeadStatusCodeType
    Get
    Set
public:
property AdFormatLeadStatusCodeType Status {
    AdFormatLeadStatusCodeType get ();
    void set (AdFormatLeadStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


SubmittedTime Property

SubmittedTime Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► SubmittedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime SubmittedTime { get; set; }
Public Property SubmittedTime As DateTime
    Get
    Set
public:
property DateTime SubmittedTime {
    DateTime get ();
    void set (DateTime value);
}


SubmittedTimeSpecified Property

SubmittedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► SubmittedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SubmittedTimeSpecified { get; set; }
Public Property SubmittedTimeSpecified As Boolean
    Get
    Set
public:
property bool SubmittedTimeSpecified {
    bool get ();
    void set (bool value);
}


TradeInMake Property

TradeInMake Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► TradeInMake
Declaration Syntax
C# Visual Basic Visual C++
public string TradeInMake { get; set; }
Public Property TradeInMake As String
    Get
    Set
public:
property String^ TradeInMake {
    String^ get ();
    void set (String^ value);
}


TradeInModel Property

TradeInModel Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► TradeInModel
Declaration Syntax
C# Visual Basic Visual C++
public string TradeInModel { get; set; }
Public Property TradeInModel As String
    Get
    Set
public:
property String^ TradeInModel {
    String^ get ();
    void set (String^ value);
}


TradeInYear Property

TradeInYear Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► TradeInYear
Declaration Syntax
C# Visual Basic Visual C++
public string TradeInYear { get; set; }
Public Property TradeInYear As String
    Get
    Set
public:
property String^ TradeInYear {
    String^ get ();
    void set (String^ value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


AdFormatLeadTypeCollection Class

AdFormatLeadTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AdFormatLeadTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AdFormatLeadTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AdFormatLeadTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdFormatLeadTypeCollection()()()() |
 | AdFormatLeadTypeCollection(array<AdFormatLeadType>[]()[][]) |
 | AdFormatLeadTypeCollection(AdFormatLeadTypeCollection) |
 | Add(AdFormatLeadType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AdFormatLeadType>[]()[][]) |
 | AddRange(AdFormatLeadTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AdFormatLeadType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AdFormatLeadType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AdFormatLeadType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AdFormatLeadType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AdFormatLeadType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AdFormatLeadTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► Add(AdFormatLeadType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AdFormatLeadType item
)
Public Function Add ( _
    item As AdFormatLeadType _
) As Integer
public:
int Add(
    AdFormatLeadType^ item
)
Parameters
item (AdFormatLeadType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AdFormatLeadType>[]()[][]) |
 | AddRange(AdFormatLeadTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► AddRange(array<AdFormatLeadType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AdFormatLeadType[] items
)
Public Sub AddRange ( _
    items As AdFormatLeadType() _
)
public:
void AddRange(
    array<AdFormatLeadType^>^ items
)
Parameters
items (array< AdFormatLeadType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► AddRange(AdFormatLeadTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AdFormatLeadTypeCollection items
)
Public Sub AddRange ( _
    items As AdFormatLeadTypeCollection _
)
public:
void AddRange(
    AdFormatLeadTypeCollection^ items
)
Parameters
items (AdFormatLeadTypeCollection)


AdFormatLeadTypeCollection Constructor

AdFormatLeadTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► AdFormatLeadTypeCollection()()()()
Members
Icon | Member | Description
 | AdFormatLeadTypeCollection()()()() |
 | AdFormatLeadTypeCollection(array<AdFormatLeadType>[]()[][]) |
 | AdFormatLeadTypeCollection(AdFormatLeadTypeCollection) |


AdFormatLeadTypeCollection Constructor

AdFormatLeadTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► AdFormatLeadTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadTypeCollection()
Public Sub New
public:
AdFormatLeadTypeCollection()


AdFormatLeadTypeCollection Constructor (items)

AdFormatLeadTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► AdFormatLeadTypeCollection(array<AdFormatLeadType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadTypeCollection(
    AdFormatLeadType[] items
)
Public Sub New ( _
    items As AdFormatLeadType() _
)
public:
AdFormatLeadTypeCollection(
    array<AdFormatLeadType^>^ items
)
Parameters
items (array< AdFormatLeadType >[]()[][])


AdFormatLeadTypeCollection Constructor (items)

AdFormatLeadTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► AdFormatLeadTypeCollection(AdFormatLeadTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadTypeCollection(
    AdFormatLeadTypeCollection items
)
Public Sub New ( _
    items As AdFormatLeadTypeCollection _
)
public:
AdFormatLeadTypeCollection(
    AdFormatLeadTypeCollection^ items
)
Parameters
items (AdFormatLeadTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► Contains(AdFormatLeadType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AdFormatLeadType item
)
Public Function Contains ( _
    item As AdFormatLeadType _
) As Boolean
public:
bool Contains(
    AdFormatLeadType^ item
)
Parameters
item (AdFormatLeadType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► CopyTo(array<AdFormatLeadType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AdFormatLeadType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AdFormatLeadType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AdFormatLeadType^>^ items,
    int index
)
Parameters
items (array< AdFormatLeadType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► IndexOf(AdFormatLeadType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AdFormatLeadType item
)
Public Function IndexOf ( _
    item As AdFormatLeadType _
) As Integer
public:
int IndexOf(
    AdFormatLeadType^ item
)
Parameters
item (AdFormatLeadType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► Insert(Int32, AdFormatLeadType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AdFormatLeadType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AdFormatLeadType _
)
public:
void Insert(
    int index,
    AdFormatLeadType^ item
)
Parameters
index (Int32)
item (AdFormatLeadType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AdFormatLeadType
    Get
    Set
public:
property AdFormatLeadType^ default[int index] {
    AdFormatLeadType^ get (int index);
    void set (int index, AdFormatLeadType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AdFormatLeadType
public:
AdFormatLeadType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► Remove(AdFormatLeadType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AdFormatLeadType item
)
Public Sub Remove ( _
    item As AdFormatLeadType _
)
public:
void Remove(
    AdFormatLeadType^ item
)
Parameters
item (AdFormatLeadType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadType[] ToArray()
Public Function ToArray As AdFormatLeadType()
public:
array<AdFormatLeadType^>^ ToArray()
Return Value


AffiliateTrackingDetailsType Class

AffiliateTrackingDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► AffiliateTrackingDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AffiliateTrackingDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AffiliateTrackingDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AffiliateTrackingDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AffiliateTrackingDetailsType()()()() |
 | AffiliateUserID |
 | Any |
 | ApplicationDeviceType |
 | ApplicationDeviceTypeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TrackingID |
 | TrackingPartnerCode |
Remarks
Inheritance Hierarchy
Object
AffiliateTrackingDetailsType


AffiliateTrackingDetailsType Constructor

AffiliateTrackingDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► AffiliateTrackingDetailsType ► AffiliateTrackingDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AffiliateTrackingDetailsType()
Public Sub New
public:
AffiliateTrackingDetailsType()


AffiliateUserID Property

AffiliateUserID Property
Namespaces ► eBay.Service.Core.Soap ► AffiliateTrackingDetailsType ► AffiliateUserID
Declaration Syntax
C# Visual Basic Visual C++
public string AffiliateUserID { get; set; }
Public Property AffiliateUserID As String
    Get
    Set
public:
property String^ AffiliateUserID {
    String^ get ();
    void set (String^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AffiliateTrackingDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ApplicationDeviceType Property

ApplicationDeviceType Property
Namespaces ► eBay.Service.Core.Soap ► AffiliateTrackingDetailsType ► ApplicationDeviceType
Declaration Syntax
C# Visual Basic Visual C++
public ApplicationDeviceTypeCodeType ApplicationDeviceType { get; set; }
Public Property ApplicationDeviceType As ApplicationDeviceTypeCodeType
    Get
    Set
public:
property ApplicationDeviceTypeCodeType ApplicationDeviceType {
    ApplicationDeviceTypeCodeType get ();
    void set (ApplicationDeviceTypeCodeType value);
}


ApplicationDeviceTypeSpecified Property

ApplicationDeviceTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AffiliateTrackingDetailsType ► ApplicationDeviceTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ApplicationDeviceTypeSpecified { get; set; }
Public Property ApplicationDeviceTypeSpecified As Boolean
    Get
    Set
public:
property bool ApplicationDeviceTypeSpecified {
    bool get ();
    void set (bool value);
}


TrackingID Property

TrackingID Property
Namespaces ► eBay.Service.Core.Soap ► AffiliateTrackingDetailsType ► TrackingID
Declaration Syntax
C# Visual Basic Visual C++
public string TrackingID { get; set; }
Public Property TrackingID As String
    Get
    Set
public:
property String^ TrackingID {
    String^ get ();
    void set (String^ value);
}


TrackingPartnerCode Property

TrackingPartnerCode Property
Namespaces ► eBay.Service.Core.Soap ► AffiliateTrackingDetailsType ► TrackingPartnerCode
Declaration Syntax
C# Visual Basic Visual C++
public string TrackingPartnerCode { get; set; }
Public Property TrackingPartnerCode As String
    Get
    Set
public:
property String^ TrackingPartnerCode {
    String^ get ();
    void set (String^ value);
}


AmountType Class

AmountType Class
Namespaces ► eBay.Service.Core.Soap ► AmountType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AmountType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AmountType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AmountType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AmountType()()()() |
 | currencyID |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Value |
Remarks
Inheritance Hierarchy
Object
 | AmountType
 |  | RefundLineType


AmountType Constructor

AmountType Constructor
Namespaces ► eBay.Service.Core.Soap ► AmountType ► AmountType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AmountType()
Public Sub New
public:
AmountType()


currencyID Property

currencyID Property
Namespaces ► eBay.Service.Core.Soap ► AmountType ► currencyID
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType currencyID { get; set; }
Public Property currencyID As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType currencyID {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► AmountType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}


AmountTypeCollection Class

AmountTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AmountTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AmountTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AmountTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AmountTypeCollection()()()() |
 | AmountTypeCollection(array<AmountType>[]()[][]) |
 | AmountTypeCollection(AmountTypeCollection) |
 | Add(AmountType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AmountType>[]()[][]) |
 | AddRange(AmountTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AmountType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AmountType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AmountType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AmountType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AmountType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AmountTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► Add(AmountType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AmountType item
)
Public Function Add ( _
    item As AmountType _
) As Integer
public:
int Add(
    AmountType^ item
)
Parameters
item (AmountType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AmountType>[]()[][]) |
 | AddRange(AmountTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► AddRange(array<AmountType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AmountType[] items
)
Public Sub AddRange ( _
    items As AmountType() _
)
public:
void AddRange(
    array<AmountType^>^ items
)
Parameters
items (array< AmountType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► AddRange(AmountTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AmountTypeCollection items
)
Public Sub AddRange ( _
    items As AmountTypeCollection _
)
public:
void AddRange(
    AmountTypeCollection^ items
)
Parameters
items (AmountTypeCollection)


AmountTypeCollection Constructor

AmountTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► AmountTypeCollection()()()()
Members
Icon | Member | Description
 | AmountTypeCollection()()()() |
 | AmountTypeCollection(array<AmountType>[]()[][]) |
 | AmountTypeCollection(AmountTypeCollection) |


AmountTypeCollection Constructor

AmountTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► AmountTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AmountTypeCollection()
Public Sub New
public:
AmountTypeCollection()


AmountTypeCollection Constructor (items)

AmountTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► AmountTypeCollection(array<AmountType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AmountTypeCollection(
    AmountType[] items
)
Public Sub New ( _
    items As AmountType() _
)
public:
AmountTypeCollection(
    array<AmountType^>^ items
)
Parameters
items (array< AmountType >[]()[][])


AmountTypeCollection Constructor (items)

AmountTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► AmountTypeCollection(AmountTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AmountTypeCollection(
    AmountTypeCollection items
)
Public Sub New ( _
    items As AmountTypeCollection _
)
public:
AmountTypeCollection(
    AmountTypeCollection^ items
)
Parameters
items (AmountTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► Contains(AmountType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AmountType item
)
Public Function Contains ( _
    item As AmountType _
) As Boolean
public:
bool Contains(
    AmountType^ item
)
Parameters
item (AmountType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► CopyTo(array<AmountType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AmountType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AmountType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AmountType^>^ items,
    int index
)
Parameters
items (array< AmountType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► IndexOf(AmountType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AmountType item
)
Public Function IndexOf ( _
    item As AmountType _
) As Integer
public:
int IndexOf(
    AmountType^ item
)
Parameters
item (AmountType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► Insert(Int32, AmountType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AmountType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AmountType _
)
public:
void Insert(
    int index,
    AmountType^ item
)
Parameters
index (Int32)
item (AmountType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AmountType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AmountType
    Get
    Set
public:
property AmountType^ default[int index] {
    AmountType^ get (int index);
    void set (int index, AmountType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AmountType
public:
AmountType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► Remove(AmountType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AmountType item
)
Public Sub Remove ( _
    item As AmountType _
)
public:
void Remove(
    AmountType^ item
)
Parameters
item (AmountType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AmountType[] ToArray()
Public Function ToArray As AmountType()
public:
array<AmountType^>^ ToArray()
Return Value


AnnouncementMessageCodeType Enumeration

AnnouncementMessageCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AnnouncementMessageCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AnnouncementMessageCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AnnouncementMessageCodeType
Members
Member | Description
None |
Deprecation |
Mapping |
DeprecationAndMapping |
CustomCode |
Remarks


AnnouncementMessageType Class

AnnouncementMessageType Class
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AnnouncementMessageType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AnnouncementMessageType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AnnouncementMessageType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnnouncementMessageType()()()() |
 | AnnouncementStartTime |
 | AnnouncementStartTimeSpecified |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | EventTime |
 | EventTimeSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageType |
 | MessageTypeSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AnnouncementMessageType


AnnouncementMessageType Constructor

AnnouncementMessageType Constructor
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageType ► AnnouncementMessageType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AnnouncementMessageType()
Public Sub New
public:
AnnouncementMessageType()


AnnouncementStartTime Property

AnnouncementStartTime Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageType ► AnnouncementStartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime AnnouncementStartTime { get; set; }
Public Property AnnouncementStartTime As DateTime
    Get
    Set
public:
property DateTime AnnouncementStartTime {
    DateTime get ();
    void set (DateTime value);
}


AnnouncementStartTimeSpecified Property

AnnouncementStartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageType ► AnnouncementStartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AnnouncementStartTimeSpecified { get; set; }
Public Property AnnouncementStartTimeSpecified As Boolean
    Get
    Set
public:
property bool AnnouncementStartTimeSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EventTime Property

EventTime Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageType ► EventTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EventTime { get; set; }
Public Property EventTime As DateTime
    Get
    Set
public:
property DateTime EventTime {
    DateTime get ();
    void set (DateTime value);
}


EventTimeSpecified Property

EventTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageType ► EventTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EventTimeSpecified { get; set; }
Public Property EventTimeSpecified As Boolean
    Get
    Set
public:
property bool EventTimeSpecified {
    bool get ();
    void set (bool value);
}


MessageType Property

MessageType Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageType ► MessageType
Declaration Syntax
C# Visual Basic Visual C++
public AnnouncementMessageCodeType MessageType { get; set; }
Public Property MessageType As AnnouncementMessageCodeType
    Get
    Set
public:
property AnnouncementMessageCodeType MessageType {
    AnnouncementMessageCodeType get ();
    void set (AnnouncementMessageCodeType value);
}


MessageTypeSpecified Property

MessageTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageType ► MessageTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageTypeSpecified { get; set; }
Public Property MessageTypeSpecified As Boolean
    Get
    Set
public:
property bool MessageTypeSpecified {
    bool get ();
    void set (bool value);
}


AnnouncementMessageTypeCollection Class

AnnouncementMessageTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AnnouncementMessageTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AnnouncementMessageTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AnnouncementMessageTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AnnouncementMessageTypeCollection()()()() |
 | AnnouncementMessageTypeCollection(array<AnnouncementMessageType>[]()[][]) |
 | AnnouncementMessageTypeCollection(AnnouncementMessageTypeCollection) |
 | Add(AnnouncementMessageType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AnnouncementMessageType>[]()[][]) |
 | AddRange(AnnouncementMessageTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AnnouncementMessageType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AnnouncementMessageType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AnnouncementMessageType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AnnouncementMessageType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AnnouncementMessageType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AnnouncementMessageTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► Add(AnnouncementMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AnnouncementMessageType item
)
Public Function Add ( _
    item As AnnouncementMessageType _
) As Integer
public:
int Add(
    AnnouncementMessageType^ item
)
Parameters
item (AnnouncementMessageType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AnnouncementMessageType>[]()[][]) |
 | AddRange(AnnouncementMessageTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► AddRange(array<AnnouncementMessageType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AnnouncementMessageType[] items
)
Public Sub AddRange ( _
    items As AnnouncementMessageType() _
)
public:
void AddRange(
    array<AnnouncementMessageType^>^ items
)
Parameters
items (array< AnnouncementMessageType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► AddRange(AnnouncementMessageTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AnnouncementMessageTypeCollection items
)
Public Sub AddRange ( _
    items As AnnouncementMessageTypeCollection _
)
public:
void AddRange(
    AnnouncementMessageTypeCollection^ items
)
Parameters
items (AnnouncementMessageTypeCollection)


AnnouncementMessageTypeCollection Constructor

AnnouncementMessageTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► AnnouncementMessageTypeCollection()()()()
Members
Icon | Member | Description
 | AnnouncementMessageTypeCollection()()()() |
 | AnnouncementMessageTypeCollection(array<AnnouncementMessageType>[]()[][]) |
 | AnnouncementMessageTypeCollection(AnnouncementMessageTypeCollection) |


AnnouncementMessageTypeCollection Constructor

AnnouncementMessageTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► AnnouncementMessageTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AnnouncementMessageTypeCollection()
Public Sub New
public:
AnnouncementMessageTypeCollection()


AnnouncementMessageTypeCollection Constructor (items)

AnnouncementMessageTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► AnnouncementMessageTypeCollection(array<AnnouncementMessageType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AnnouncementMessageTypeCollection(
    AnnouncementMessageType[] items
)
Public Sub New ( _
    items As AnnouncementMessageType() _
)
public:
AnnouncementMessageTypeCollection(
    array<AnnouncementMessageType^>^ items
)
Parameters
items (array< AnnouncementMessageType >[]()[][])


AnnouncementMessageTypeCollection Constructor (items)

AnnouncementMessageTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► AnnouncementMessageTypeCollection(AnnouncementMessageTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AnnouncementMessageTypeCollection(
    AnnouncementMessageTypeCollection items
)
Public Sub New ( _
    items As AnnouncementMessageTypeCollection _
)
public:
AnnouncementMessageTypeCollection(
    AnnouncementMessageTypeCollection^ items
)
Parameters
items (AnnouncementMessageTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► Contains(AnnouncementMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AnnouncementMessageType item
)
Public Function Contains ( _
    item As AnnouncementMessageType _
) As Boolean
public:
bool Contains(
    AnnouncementMessageType^ item
)
Parameters
item (AnnouncementMessageType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► CopyTo(array<AnnouncementMessageType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AnnouncementMessageType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AnnouncementMessageType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AnnouncementMessageType^>^ items,
    int index
)
Parameters
items (array< AnnouncementMessageType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► IndexOf(AnnouncementMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AnnouncementMessageType item
)
Public Function IndexOf ( _
    item As AnnouncementMessageType _
) As Integer
public:
int IndexOf(
    AnnouncementMessageType^ item
)
Parameters
item (AnnouncementMessageType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► Insert(Int32, AnnouncementMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AnnouncementMessageType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AnnouncementMessageType _
)
public:
void Insert(
    int index,
    AnnouncementMessageType^ item
)
Parameters
index (Int32)
item (AnnouncementMessageType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AnnouncementMessageType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AnnouncementMessageType
    Get
    Set
public:
property AnnouncementMessageType^ default[int index] {
    AnnouncementMessageType^ get (int index);
    void set (int index, AnnouncementMessageType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AnnouncementMessageType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AnnouncementMessageType
public:
AnnouncementMessageType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► Remove(AnnouncementMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AnnouncementMessageType item
)
Public Sub Remove ( _
    item As AnnouncementMessageType _
)
public:
void Remove(
    AnnouncementMessageType^ item
)
Parameters
item (AnnouncementMessageType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AnnouncementMessageType[] ToArray()
Public Function ToArray As AnnouncementMessageType()
public:
array<AnnouncementMessageType^>^ ToArray()
Return Value


ApiAccessRuleType Class

ApiAccessRuleType Class
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ApiAccessRuleType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ApiAccessRuleType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ApiAccessRuleType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApiAccessRuleType()()()() |
 | Any |
 | CallName |
 | CountsTowardAggregate |
 | CountsTowardAggregateSpecified |
 | DailyHardLimit |
 | DailyHardLimitSpecified |
 | DailySoftLimit |
 | DailySoftLimitSpecified |
 | DailyUsage |
 | DailyUsageSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HourlyHardLimit |
 | HourlyHardLimitSpecified |
 | HourlySoftLimit |
 | HourlySoftLimitSpecified |
 | HourlyUsage |
 | HourlyUsageSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModTime |
 | ModTimeSpecified |
 | Period |
 | PeriodicHardLimit |
 | PeriodicHardLimitSpecified |
 | PeriodicSoftLimit |
 | PeriodicSoftLimitSpecified |
 | PeriodicStartDate |
 | PeriodicStartDateSpecified |
 | PeriodicUsage |
 | PeriodicUsageSpecified |
 | PeriodSpecified |
 | RuleCurrentStatus |
 | RuleCurrentStatusSpecified |
 | RuleStatus |
 | RuleStatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ApiAccessRuleType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ApiAccessRuleType Constructor

ApiAccessRuleType Constructor
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► ApiAccessRuleType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccessRuleType()
Public Sub New
public:
ApiAccessRuleType()


CallName Property

CallName Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► CallName
Declaration Syntax
C# Visual Basic Visual C++
public string CallName { get; set; }
Public Property CallName As String
    Get
    Set
public:
property String^ CallName {
    String^ get ();
    void set (String^ value);
}


CountsTowardAggregate Property

CountsTowardAggregate Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► CountsTowardAggregate
Declaration Syntax
C# Visual Basic Visual C++
public bool CountsTowardAggregate { get; set; }
Public Property CountsTowardAggregate As Boolean
    Get
    Set
public:
property bool CountsTowardAggregate {
    bool get ();
    void set (bool value);
}


CountsTowardAggregateSpecified Property

CountsTowardAggregateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► CountsTowardAggregateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CountsTowardAggregateSpecified { get; set; }
Public Property CountsTowardAggregateSpecified As Boolean
    Get
    Set
public:
property bool CountsTowardAggregateSpecified {
    bool get ();
    void set (bool value);
}


DailyHardLimit Property

DailyHardLimit Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► DailyHardLimit
Declaration Syntax
C# Visual Basic Visual C++
public long DailyHardLimit { get; set; }
Public Property DailyHardLimit As Long
    Get
    Set
public:
property long long DailyHardLimit {
    long long get ();
    void set (long long value);
}


DailyHardLimitSpecified Property

DailyHardLimitSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► DailyHardLimitSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DailyHardLimitSpecified { get; set; }
Public Property DailyHardLimitSpecified As Boolean
    Get
    Set
public:
property bool DailyHardLimitSpecified {
    bool get ();
    void set (bool value);
}


DailySoftLimit Property

DailySoftLimit Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► DailySoftLimit
Declaration Syntax
C# Visual Basic Visual C++
public long DailySoftLimit { get; set; }
Public Property DailySoftLimit As Long
    Get
    Set
public:
property long long DailySoftLimit {
    long long get ();
    void set (long long value);
}


DailySoftLimitSpecified Property

DailySoftLimitSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► DailySoftLimitSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DailySoftLimitSpecified { get; set; }
Public Property DailySoftLimitSpecified As Boolean
    Get
    Set
public:
property bool DailySoftLimitSpecified {
    bool get ();
    void set (bool value);
}


DailyUsage Property

DailyUsage Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► DailyUsage
Declaration Syntax
C# Visual Basic Visual C++
public long DailyUsage { get; set; }
Public Property DailyUsage As Long
    Get
    Set
public:
property long long DailyUsage {
    long long get ();
    void set (long long value);
}


DailyUsageSpecified Property

DailyUsageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► DailyUsageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DailyUsageSpecified { get; set; }
Public Property DailyUsageSpecified As Boolean
    Get
    Set
public:
property bool DailyUsageSpecified {
    bool get ();
    void set (bool value);
}


HourlyHardLimit Property

HourlyHardLimit Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► HourlyHardLimit
Declaration Syntax
C# Visual Basic Visual C++
public long HourlyHardLimit { get; set; }
Public Property HourlyHardLimit As Long
    Get
    Set
public:
property long long HourlyHardLimit {
    long long get ();
    void set (long long value);
}


HourlyHardLimitSpecified Property

HourlyHardLimitSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► HourlyHardLimitSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HourlyHardLimitSpecified { get; set; }
Public Property HourlyHardLimitSpecified As Boolean
    Get
    Set
public:
property bool HourlyHardLimitSpecified {
    bool get ();
    void set (bool value);
}


HourlySoftLimit Property

HourlySoftLimit Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► HourlySoftLimit
Declaration Syntax
C# Visual Basic Visual C++
public long HourlySoftLimit { get; set; }
Public Property HourlySoftLimit As Long
    Get
    Set
public:
property long long HourlySoftLimit {
    long long get ();
    void set (long long value);
}


HourlySoftLimitSpecified Property

HourlySoftLimitSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► HourlySoftLimitSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HourlySoftLimitSpecified { get; set; }
Public Property HourlySoftLimitSpecified As Boolean
    Get
    Set
public:
property bool HourlySoftLimitSpecified {
    bool get ();
    void set (bool value);
}


HourlyUsage Property

HourlyUsage Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► HourlyUsage
Declaration Syntax
C# Visual Basic Visual C++
public long HourlyUsage { get; set; }
Public Property HourlyUsage As Long
    Get
    Set
public:
property long long HourlyUsage {
    long long get ();
    void set (long long value);
}


HourlyUsageSpecified Property

HourlyUsageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► HourlyUsageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HourlyUsageSpecified { get; set; }
Public Property HourlyUsageSpecified As Boolean
    Get
    Set
public:
property bool HourlyUsageSpecified {
    bool get ();
    void set (bool value);
}


ModTime Property

ModTime Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► ModTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTime { get; set; }
Public Property ModTime As DateTime
    Get
    Set
public:
property DateTime ModTime {
    DateTime get ();
    void set (DateTime value);
}


ModTimeSpecified Property

ModTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► ModTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModTimeSpecified { get; set; }
Public Property ModTimeSpecified As Boolean
    Get
    Set
public:
property bool ModTimeSpecified {
    bool get ();
    void set (bool value);
}


Period Property

Period Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► Period
Declaration Syntax
C# Visual Basic Visual C++
public int Period { get; set; }
Public Property Period As Integer
    Get
    Set
public:
property int Period {
    int get ();
    void set (int value);
}


PeriodicHardLimit Property

PeriodicHardLimit Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► PeriodicHardLimit
Declaration Syntax
C# Visual Basic Visual C++
public long PeriodicHardLimit { get; set; }
Public Property PeriodicHardLimit As Long
    Get
    Set
public:
property long long PeriodicHardLimit {
    long long get ();
    void set (long long value);
}


PeriodicHardLimitSpecified Property

PeriodicHardLimitSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► PeriodicHardLimitSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PeriodicHardLimitSpecified { get; set; }
Public Property PeriodicHardLimitSpecified As Boolean
    Get
    Set
public:
property bool PeriodicHardLimitSpecified {
    bool get ();
    void set (bool value);
}


PeriodicSoftLimit Property

PeriodicSoftLimit Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► PeriodicSoftLimit
Declaration Syntax
C# Visual Basic Visual C++
public long PeriodicSoftLimit { get; set; }
Public Property PeriodicSoftLimit As Long
    Get
    Set
public:
property long long PeriodicSoftLimit {
    long long get ();
    void set (long long value);
}


PeriodicSoftLimitSpecified Property

PeriodicSoftLimitSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► PeriodicSoftLimitSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PeriodicSoftLimitSpecified { get; set; }
Public Property PeriodicSoftLimitSpecified As Boolean
    Get
    Set
public:
property bool PeriodicSoftLimitSpecified {
    bool get ();
    void set (bool value);
}


PeriodicStartDate Property

PeriodicStartDate Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► PeriodicStartDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PeriodicStartDate { get; set; }
Public Property PeriodicStartDate As DateTime
    Get
    Set
public:
property DateTime PeriodicStartDate {
    DateTime get ();
    void set (DateTime value);
}


PeriodicStartDateSpecified Property

PeriodicStartDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► PeriodicStartDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PeriodicStartDateSpecified { get; set; }
Public Property PeriodicStartDateSpecified As Boolean
    Get
    Set
public:
property bool PeriodicStartDateSpecified {
    bool get ();
    void set (bool value);
}


PeriodicUsage Property

PeriodicUsage Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► PeriodicUsage
Declaration Syntax
C# Visual Basic Visual C++
public long PeriodicUsage { get; set; }
Public Property PeriodicUsage As Long
    Get
    Set
public:
property long long PeriodicUsage {
    long long get ();
    void set (long long value);
}


PeriodicUsageSpecified Property

PeriodicUsageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► PeriodicUsageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PeriodicUsageSpecified { get; set; }
Public Property PeriodicUsageSpecified As Boolean
    Get
    Set
public:
property bool PeriodicUsageSpecified {
    bool get ();
    void set (bool value);
}


PeriodSpecified Property

PeriodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► PeriodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PeriodSpecified { get; set; }
Public Property PeriodSpecified As Boolean
    Get
    Set
public:
property bool PeriodSpecified {
    bool get ();
    void set (bool value);
}


RuleCurrentStatus Property

RuleCurrentStatus Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► RuleCurrentStatus
Declaration Syntax
C# Visual Basic Visual C++
public AccessRuleCurrentStatusCodeType RuleCurrentStatus { get; set; }
Public Property RuleCurrentStatus As AccessRuleCurrentStatusCodeType
    Get
    Set
public:
property AccessRuleCurrentStatusCodeType RuleCurrentStatus {
    AccessRuleCurrentStatusCodeType get ();
    void set (AccessRuleCurrentStatusCodeType value);
}


RuleCurrentStatusSpecified Property

RuleCurrentStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► RuleCurrentStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RuleCurrentStatusSpecified { get; set; }
Public Property RuleCurrentStatusSpecified As Boolean
    Get
    Set
public:
property bool RuleCurrentStatusSpecified {
    bool get ();
    void set (bool value);
}


RuleStatus Property

RuleStatus Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► RuleStatus
Declaration Syntax
C# Visual Basic Visual C++
public AccessRuleStatusCodeType RuleStatus { get; set; }
Public Property RuleStatus As AccessRuleStatusCodeType
    Get
    Set
public:
property AccessRuleStatusCodeType RuleStatus {
    AccessRuleStatusCodeType get ();
    void set (AccessRuleStatusCodeType value);
}


RuleStatusSpecified Property

RuleStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleType ► RuleStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RuleStatusSpecified { get; set; }
Public Property RuleStatusSpecified As Boolean
    Get
    Set
public:
property bool RuleStatusSpecified {
    bool get ();
    void set (bool value);
}


ApiAccessRuleTypeCollection Class

ApiAccessRuleTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ApiAccessRuleTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ApiAccessRuleTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ApiAccessRuleTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApiAccessRuleTypeCollection()()()() |
 | ApiAccessRuleTypeCollection(array<ApiAccessRuleType>[]()[][]) |
 | ApiAccessRuleTypeCollection(ApiAccessRuleTypeCollection) |
 | Add(ApiAccessRuleType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ApiAccessRuleType>[]()[][]) |
 | AddRange(ApiAccessRuleTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ApiAccessRuleType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ApiAccessRuleType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ApiAccessRuleType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ApiAccessRuleType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ApiAccessRuleType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ApiAccessRuleTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► Add(ApiAccessRuleType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ApiAccessRuleType item
)
Public Function Add ( _
    item As ApiAccessRuleType _
) As Integer
public:
int Add(
    ApiAccessRuleType^ item
)
Parameters
item (ApiAccessRuleType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ApiAccessRuleType>[]()[][]) |
 | AddRange(ApiAccessRuleTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► AddRange(array<ApiAccessRuleType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ApiAccessRuleType[] items
)
Public Sub AddRange ( _
    items As ApiAccessRuleType() _
)
public:
void AddRange(
    array<ApiAccessRuleType^>^ items
)
Parameters
items (array< ApiAccessRuleType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► AddRange(ApiAccessRuleTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ApiAccessRuleTypeCollection items
)
Public Sub AddRange ( _
    items As ApiAccessRuleTypeCollection _
)
public:
void AddRange(
    ApiAccessRuleTypeCollection^ items
)
Parameters
items (ApiAccessRuleTypeCollection)


ApiAccessRuleTypeCollection Constructor

ApiAccessRuleTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► ApiAccessRuleTypeCollection()()()()
Members
Icon | Member | Description
 | ApiAccessRuleTypeCollection()()()() |
 | ApiAccessRuleTypeCollection(array<ApiAccessRuleType>[]()[][]) |
 | ApiAccessRuleTypeCollection(ApiAccessRuleTypeCollection) |


ApiAccessRuleTypeCollection Constructor

ApiAccessRuleTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► ApiAccessRuleTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccessRuleTypeCollection()
Public Sub New
public:
ApiAccessRuleTypeCollection()


ApiAccessRuleTypeCollection Constructor (items)

ApiAccessRuleTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► ApiAccessRuleTypeCollection(array<ApiAccessRuleType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccessRuleTypeCollection(
    ApiAccessRuleType[] items
)
Public Sub New ( _
    items As ApiAccessRuleType() _
)
public:
ApiAccessRuleTypeCollection(
    array<ApiAccessRuleType^>^ items
)
Parameters
items (array< ApiAccessRuleType >[]()[][])


ApiAccessRuleTypeCollection Constructor (items)

ApiAccessRuleTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► ApiAccessRuleTypeCollection(ApiAccessRuleTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccessRuleTypeCollection(
    ApiAccessRuleTypeCollection items
)
Public Sub New ( _
    items As ApiAccessRuleTypeCollection _
)
public:
ApiAccessRuleTypeCollection(
    ApiAccessRuleTypeCollection^ items
)
Parameters
items (ApiAccessRuleTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► Contains(ApiAccessRuleType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ApiAccessRuleType item
)
Public Function Contains ( _
    item As ApiAccessRuleType _
) As Boolean
public:
bool Contains(
    ApiAccessRuleType^ item
)
Parameters
item (ApiAccessRuleType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► CopyTo(array<ApiAccessRuleType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ApiAccessRuleType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ApiAccessRuleType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ApiAccessRuleType^>^ items,
    int index
)
Parameters
items (array< ApiAccessRuleType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► IndexOf(ApiAccessRuleType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ApiAccessRuleType item
)
Public Function IndexOf ( _
    item As ApiAccessRuleType _
) As Integer
public:
int IndexOf(
    ApiAccessRuleType^ item
)
Parameters
item (ApiAccessRuleType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► Insert(Int32, ApiAccessRuleType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ApiAccessRuleType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ApiAccessRuleType _
)
public:
void Insert(
    int index,
    ApiAccessRuleType^ item
)
Parameters
index (Int32)
item (ApiAccessRuleType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccessRuleType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ApiAccessRuleType
    Get
    Set
public:
property ApiAccessRuleType^ default[int index] {
    ApiAccessRuleType^ get (int index);
    void set (int index, ApiAccessRuleType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccessRuleType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ApiAccessRuleType
public:
ApiAccessRuleType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► Remove(ApiAccessRuleType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ApiAccessRuleType item
)
Public Sub Remove ( _
    item As ApiAccessRuleType _
)
public:
void Remove(
    ApiAccessRuleType^ item
)
Parameters
item (ApiAccessRuleType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccessRuleType[] ToArray()
Public Function ToArray As ApiAccessRuleType()
public:
array<ApiAccessRuleType^>^ ToArray()
Return Value


ApplicationDeliveryPreferencesType Class

ApplicationDeliveryPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ApplicationDeliveryPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ApplicationDeliveryPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ApplicationDeliveryPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApplicationDeliveryPreferencesType()()()() |
 | AlertEmail |
 | AlertEnable |
 | AlertEnableSpecified |
 | Any |
 | ApplicationEnable |
 | ApplicationEnableSpecified |
 | ApplicationURL |
 | DeliveryURLDetails |
 | DeviceType |
 | DeviceTypeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NotificationPayloadType |
 | NotificationPayloadTypeSpecified |
 | PayloadVersion |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ApplicationDeliveryPreferencesType


AlertEmail Property

AlertEmail Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► AlertEmail
Declaration Syntax
C# Visual Basic Visual C++
public string AlertEmail { get; set; }
Public Property AlertEmail As String
    Get
    Set
public:
property String^ AlertEmail {
    String^ get ();
    void set (String^ value);
}


AlertEnable Property

AlertEnable Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► AlertEnable
Declaration Syntax
C# Visual Basic Visual C++
public EnableCodeType AlertEnable { get; set; }
Public Property AlertEnable As EnableCodeType
    Get
    Set
public:
property EnableCodeType AlertEnable {
    EnableCodeType get ();
    void set (EnableCodeType value);
}


AlertEnableSpecified Property

AlertEnableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► AlertEnableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AlertEnableSpecified { get; set; }
Public Property AlertEnableSpecified As Boolean
    Get
    Set
public:
property bool AlertEnableSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ApplicationDeliveryPreferencesType Constructor

ApplicationDeliveryPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► ApplicationDeliveryPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ApplicationDeliveryPreferencesType()
Public Sub New
public:
ApplicationDeliveryPreferencesType()


ApplicationEnable Property

ApplicationEnable Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► ApplicationEnable
Declaration Syntax
C# Visual Basic Visual C++
public EnableCodeType ApplicationEnable { get; set; }
Public Property ApplicationEnable As EnableCodeType
    Get
    Set
public:
property EnableCodeType ApplicationEnable {
    EnableCodeType get ();
    void set (EnableCodeType value);
}


ApplicationEnableSpecified Property

ApplicationEnableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► ApplicationEnableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ApplicationEnableSpecified { get; set; }
Public Property ApplicationEnableSpecified As Boolean
    Get
    Set
public:
property bool ApplicationEnableSpecified {
    bool get ();
    void set (bool value);
}


ApplicationURL Property

ApplicationURL Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► ApplicationURL
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationURL { get; set; }
Public Property ApplicationURL As String
    Get
    Set
public:
property String^ ApplicationURL {
    String^ get ();
    void set (String^ value);
}


DeliveryURLDetails Property

DeliveryURLDetails Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► DeliveryURLDetails
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryURLDetailTypeCollection DeliveryURLDetails { get; set; }
Public Property DeliveryURLDetails As DeliveryURLDetailTypeCollection
    Get
    Set
public:
property DeliveryURLDetailTypeCollection^ DeliveryURLDetails {
    DeliveryURLDetailTypeCollection^ get ();
    void set (DeliveryURLDetailTypeCollection^ value);
}


DeviceType Property

DeviceType Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► DeviceType
Declaration Syntax
C# Visual Basic Visual C++
public DeviceTypeCodeType DeviceType { get; set; }
Public Property DeviceType As DeviceTypeCodeType
    Get
    Set
public:
property DeviceTypeCodeType DeviceType {
    DeviceTypeCodeType get ();
    void set (DeviceTypeCodeType value);
}


DeviceTypeSpecified Property

DeviceTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► DeviceTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeviceTypeSpecified { get; set; }
Public Property DeviceTypeSpecified As Boolean
    Get
    Set
public:
property bool DeviceTypeSpecified {
    bool get ();
    void set (bool value);
}


NotificationPayloadType Property

NotificationPayloadType Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► NotificationPayloadType
Declaration Syntax
C# Visual Basic Visual C++
public NotificationPayloadTypeCodeType NotificationPayloadType { get; set; }
Public Property NotificationPayloadType As NotificationPayloadTypeCodeType
    Get
    Set
public:
property NotificationPayloadTypeCodeType NotificationPayloadType {
    NotificationPayloadTypeCodeType get ();
    void set (NotificationPayloadTypeCodeType value);
}


NotificationPayloadTypeSpecified Property

NotificationPayloadTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► NotificationPayloadTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NotificationPayloadTypeSpecified { get; set; }
Public Property NotificationPayloadTypeSpecified As Boolean
    Get
    Set
public:
property bool NotificationPayloadTypeSpecified {
    bool get ();
    void set (bool value);
}


PayloadVersion Property

PayloadVersion Property
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeliveryPreferencesType ► PayloadVersion
Declaration Syntax
C# Visual Basic Visual C++
public string PayloadVersion { get; set; }
Public Property PayloadVersion As String
    Get
    Set
public:
property String^ PayloadVersion {
    String^ get ();
    void set (String^ value);
}


ApplicationDeviceTypeCodeType Enumeration

ApplicationDeviceTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ApplicationDeviceTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ApplicationDeviceTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ApplicationDeviceTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ApplicationDeviceTypeCodeType
Members
Member | Description
Browser |
Wireless |
Desktop |
SetTopTVBox |
CustomCode |
Remarks


ASQPreferencesType Class

ASQPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► ASQPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ASQPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ASQPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ASQPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ASQPreferencesType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ResetDefaultSubjects |
 | ResetDefaultSubjectsSpecified |
 | Subject |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ASQPreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ASQPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ASQPreferencesType Constructor

ASQPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► ASQPreferencesType ► ASQPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ASQPreferencesType()
Public Sub New
public:
ASQPreferencesType()


ResetDefaultSubjects Property

ResetDefaultSubjects Property
Namespaces ► eBay.Service.Core.Soap ► ASQPreferencesType ► ResetDefaultSubjects
Declaration Syntax
C# Visual Basic Visual C++
public bool ResetDefaultSubjects { get; set; }
Public Property ResetDefaultSubjects As Boolean
    Get
    Set
public:
property bool ResetDefaultSubjects {
    bool get ();
    void set (bool value);
}


ResetDefaultSubjectsSpecified Property

ResetDefaultSubjectsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ASQPreferencesType ► ResetDefaultSubjectsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ResetDefaultSubjectsSpecified { get; set; }
Public Property ResetDefaultSubjectsSpecified As Boolean
    Get
    Set
public:
property bool ResetDefaultSubjectsSpecified {
    bool get ();
    void set (bool value);
}


Subject Property

Subject Property
Namespaces ► eBay.Service.Core.Soap ► ASQPreferencesType ► Subject
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection Subject { get; set; }
Public Property Subject As StringCollection
    Get
    Set
public:
property StringCollection^ Subject {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


AttributeConversionEnabledCodeType Enumeration

AttributeConversionEnabledCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AttributeConversionEnabledCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AttributeConversionEnabledCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AttributeConversionEnabledCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AttributeConversionEnabledCodeType
Members
Member | Description
NotApplicable |
Enabled |
Disabled |
CustomCode |
Remarks


AttributeConversionEnabledFeatureDefinitionType Class

AttributeConversionEnabledFeatureDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► AttributeConversionEnabledFeatureDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AttributeConversionEnabledFeatureDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AttributeConversionEnabledFeatureDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AttributeConversionEnabledFeatureDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributeConversionEnabledFeatureDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AttributeConversionEnabledFeatureDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AttributeConversionEnabledFeatureDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AttributeConversionEnabledFeatureDefinitionType Constructor

AttributeConversionEnabledFeatureDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► AttributeConversionEnabledFeatureDefinitionType ► AttributeConversionEnabledFeatureDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AttributeConversionEnabledFeatureDefinitionType()
Public Sub New
public:
AttributeConversionEnabledFeatureDefinitionType()


AttributeSetType Class

AttributeSetType Class
Namespaces ► eBay.Service.Core.Soap ► AttributeSetType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AttributeSetType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AttributeSetType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AttributeSetType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributeSetType()()()() |
 | Any |
 | Attribute |
 | attributeSetID |
 | attributeSetIDSpecified |
 | attributeSetVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
 | AttributeSetType
 |  | AttributeSet


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Attribute Property

Attribute Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetType ► Attribute
Declaration Syntax
C# Visual Basic Visual C++
public AttributeTypeCollection Attribute { get; set; }
Public Property Attribute As AttributeTypeCollection
    Get
    Set
public:
property AttributeTypeCollection^ Attribute {
    AttributeTypeCollection^ get ();
    void set (AttributeTypeCollection^ value);
}


attributeSetID Property

attributeSetID Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetType ► attributeSetID
Declaration Syntax
C# Visual Basic Visual C++
public int attributeSetID { get; set; }
Public Property attributeSetID As Integer
    Get
    Set
public:
property int attributeSetID {
    int get ();
    void set (int value);
}


attributeSetIDSpecified Property

attributeSetIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetType ► attributeSetIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool attributeSetIDSpecified { get; set; }
Public Property attributeSetIDSpecified As Boolean
    Get
    Set
public:
property bool attributeSetIDSpecified {
    bool get ();
    void set (bool value);
}


AttributeSetType Constructor

AttributeSetType Constructor
Namespaces ► eBay.Service.Core.Soap ► AttributeSetType ► AttributeSetType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetType()
Public Sub New
public:
AttributeSetType()


attributeSetVersion Property

attributeSetVersion Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetType ► attributeSetVersion
Declaration Syntax
C# Visual Basic Visual C++
public string attributeSetVersion { get; set; }
Public Property attributeSetVersion As String
    Get
    Set
public:
property String^ attributeSetVersion {
    String^ get ();
    void set (String^ value);
}


AttributeSetTypeCollection Class

AttributeSetTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AttributeSetTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AttributeSetTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AttributeSetTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributeSetTypeCollection()()()() |
 | AttributeSetTypeCollection(array<AttributeSetType>[]()[][]) |
 | AttributeSetTypeCollection(AttributeSetTypeCollection) |
 | Add(AttributeSetType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AttributeSetType>[]()[][]) |
 | AddRange(AttributeSetTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AttributeSetType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AttributeSetType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AttributeSetType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AttributeSetType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AttributeSetType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AttributeSetTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► Add(AttributeSetType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AttributeSetType item
)
Public Function Add ( _
    item As AttributeSetType _
) As Integer
public:
int Add(
    AttributeSetType^ item
)
Parameters
item (AttributeSetType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AttributeSetType>[]()[][]) |
 | AddRange(AttributeSetTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► AddRange(array<AttributeSetType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AttributeSetType[] items
)
Public Sub AddRange ( _
    items As AttributeSetType() _
)
public:
void AddRange(
    array<AttributeSetType^>^ items
)
Parameters
items (array< AttributeSetType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► AddRange(AttributeSetTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AttributeSetTypeCollection items
)
Public Sub AddRange ( _
    items As AttributeSetTypeCollection _
)
public:
void AddRange(
    AttributeSetTypeCollection^ items
)
Parameters
items (AttributeSetTypeCollection)


AttributeSetTypeCollection Constructor

AttributeSetTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► AttributeSetTypeCollection()()()()
Members
Icon | Member | Description
 | AttributeSetTypeCollection()()()() |
 | AttributeSetTypeCollection(array<AttributeSetType>[]()[][]) |
 | AttributeSetTypeCollection(AttributeSetTypeCollection) |


AttributeSetTypeCollection Constructor

AttributeSetTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► AttributeSetTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetTypeCollection()
Public Sub New
public:
AttributeSetTypeCollection()


AttributeSetTypeCollection Constructor (items)

AttributeSetTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► AttributeSetTypeCollection(array<AttributeSetType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetTypeCollection(
    AttributeSetType[] items
)
Public Sub New ( _
    items As AttributeSetType() _
)
public:
AttributeSetTypeCollection(
    array<AttributeSetType^>^ items
)
Parameters
items (array< AttributeSetType >[]()[][])


AttributeSetTypeCollection Constructor (items)

AttributeSetTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► AttributeSetTypeCollection(AttributeSetTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetTypeCollection(
    AttributeSetTypeCollection items
)
Public Sub New ( _
    items As AttributeSetTypeCollection _
)
public:
AttributeSetTypeCollection(
    AttributeSetTypeCollection^ items
)
Parameters
items (AttributeSetTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► Contains(AttributeSetType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AttributeSetType item
)
Public Function Contains ( _
    item As AttributeSetType _
) As Boolean
public:
bool Contains(
    AttributeSetType^ item
)
Parameters
item (AttributeSetType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► CopyTo(array<AttributeSetType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AttributeSetType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AttributeSetType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AttributeSetType^>^ items,
    int index
)
Parameters
items (array< AttributeSetType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► IndexOf(AttributeSetType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AttributeSetType item
)
Public Function IndexOf ( _
    item As AttributeSetType _
) As Integer
public:
int IndexOf(
    AttributeSetType^ item
)
Parameters
item (AttributeSetType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► Insert(Int32, AttributeSetType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AttributeSetType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AttributeSetType _
)
public:
void Insert(
    int index,
    AttributeSetType^ item
)
Parameters
index (Int32)
item (AttributeSetType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AttributeSetType
    Get
    Set
public:
property AttributeSetType^ default[int index] {
    AttributeSetType^ get (int index);
    void set (int index, AttributeSetType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AttributeSetType
public:
AttributeSetType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► Remove(AttributeSetType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AttributeSetType item
)
Public Sub Remove ( _
    item As AttributeSetType _
)
public:
void Remove(
    AttributeSetType^ item
)
Parameters
item (AttributeSetType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetType[] ToArray()
Public Function ToArray As AttributeSetType()
public:
array<AttributeSetType^>^ ToArray()
Return Value


AttributeType Class

AttributeType Class
Namespaces ► eBay.Service.Core.Soap ► AttributeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AttributeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AttributeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AttributeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributeType()()()() |
 | Any |
 | attributeID |
 | attributeIDSpecified |
 | attributeLabel |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Value |
Remarks
Inheritance Hierarchy
Object
 | AttributeType
 |  | Attribute


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AttributeType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


attributeID Property

attributeID Property
Namespaces ► eBay.Service.Core.Soap ► AttributeType ► attributeID
Declaration Syntax
C# Visual Basic Visual C++
public int attributeID { get; set; }
Public Property attributeID As Integer
    Get
    Set
public:
property int attributeID {
    int get ();
    void set (int value);
}


attributeIDSpecified Property

attributeIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AttributeType ► attributeIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool attributeIDSpecified { get; set; }
Public Property attributeIDSpecified As Boolean
    Get
    Set
public:
property bool attributeIDSpecified {
    bool get ();
    void set (bool value);
}


attributeLabel Property

attributeLabel Property
Namespaces ► eBay.Service.Core.Soap ► AttributeType ► attributeLabel
Declaration Syntax
C# Visual Basic Visual C++
public string attributeLabel { get; set; }
Public Property attributeLabel As String
    Get
    Set
public:
property String^ attributeLabel {
    String^ get ();
    void set (String^ value);
}


AttributeType Constructor

AttributeType Constructor
Namespaces ► eBay.Service.Core.Soap ► AttributeType ► AttributeType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AttributeType()
Public Sub New
public:
AttributeType()


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► AttributeType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public ValTypeCollection Value { get; set; }
Public Property Value As ValTypeCollection
    Get
    Set
public:
property ValTypeCollection^ Value {
    ValTypeCollection^ get ();
    void set (ValTypeCollection^ value);
}


AttributeTypeCollection Class

AttributeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AttributeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AttributeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AttributeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributeTypeCollection()()()() |
 | AttributeTypeCollection(array<AttributeType>[]()[][]) |
 | AttributeTypeCollection(AttributeTypeCollection) |
 | Add(AttributeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AttributeType>[]()[][]) |
 | AddRange(AttributeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AttributeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AttributeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AttributeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AttributeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AttributeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AttributeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► Add(AttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AttributeType item
)
Public Function Add ( _
    item As AttributeType _
) As Integer
public:
int Add(
    AttributeType^ item
)
Parameters
item (AttributeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AttributeType>[]()[][]) |
 | AddRange(AttributeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► AddRange(array<AttributeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AttributeType[] items
)
Public Sub AddRange ( _
    items As AttributeType() _
)
public:
void AddRange(
    array<AttributeType^>^ items
)
Parameters
items (array< AttributeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► AddRange(AttributeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AttributeTypeCollection items
)
Public Sub AddRange ( _
    items As AttributeTypeCollection _
)
public:
void AddRange(
    AttributeTypeCollection^ items
)
Parameters
items (AttributeTypeCollection)


AttributeTypeCollection Constructor

AttributeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► AttributeTypeCollection()()()()
Members
Icon | Member | Description
 | AttributeTypeCollection()()()() |
 | AttributeTypeCollection(array<AttributeType>[]()[][]) |
 | AttributeTypeCollection(AttributeTypeCollection) |


AttributeTypeCollection Constructor

AttributeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► AttributeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AttributeTypeCollection()
Public Sub New
public:
AttributeTypeCollection()


AttributeTypeCollection Constructor (items)

AttributeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► AttributeTypeCollection(array<AttributeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AttributeTypeCollection(
    AttributeType[] items
)
Public Sub New ( _
    items As AttributeType() _
)
public:
AttributeTypeCollection(
    array<AttributeType^>^ items
)
Parameters
items (array< AttributeType >[]()[][])


AttributeTypeCollection Constructor (items)

AttributeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► AttributeTypeCollection(AttributeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AttributeTypeCollection(
    AttributeTypeCollection items
)
Public Sub New ( _
    items As AttributeTypeCollection _
)
public:
AttributeTypeCollection(
    AttributeTypeCollection^ items
)
Parameters
items (AttributeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► Contains(AttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AttributeType item
)
Public Function Contains ( _
    item As AttributeType _
) As Boolean
public:
bool Contains(
    AttributeType^ item
)
Parameters
item (AttributeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► CopyTo(array<AttributeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AttributeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AttributeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AttributeType^>^ items,
    int index
)
Parameters
items (array< AttributeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► IndexOf(AttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AttributeType item
)
Public Function IndexOf ( _
    item As AttributeType _
) As Integer
public:
int IndexOf(
    AttributeType^ item
)
Parameters
item (AttributeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► Insert(Int32, AttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AttributeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AttributeType _
)
public:
void Insert(
    int index,
    AttributeType^ item
)
Parameters
index (Int32)
item (AttributeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AttributeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AttributeType
    Get
    Set
public:
property AttributeType^ default[int index] {
    AttributeType^ get (int index);
    void set (int index, AttributeType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AttributeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AttributeType
public:
AttributeType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► Remove(AttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AttributeType item
)
Public Sub Remove ( _
    item As AttributeType _
)
public:
void Remove(
    AttributeType^ item
)
Parameters
item (AttributeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AttributeType[] ToArray()
Public Function ToArray As AttributeType()
public:
array<AttributeType^>^ ToArray()
Return Value


AutomatedLeaveFeedbackEventCodeType Enumeration

AutomatedLeaveFeedbackEventCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► AutomatedLeaveFeedbackEventCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum AutomatedLeaveFeedbackEventCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration AutomatedLeaveFeedbackEventCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class AutomatedLeaveFeedbackEventCodeType
Members
Member | Description
PositiveFeedbackReceived |
PaymentReceived |
None |
CustomCode |
Remarks


AverageRatingDetailsType Class

AverageRatingDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AverageRatingDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AverageRatingDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AverageRatingDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AverageRatingDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Rating |
 | RatingCount |
 | RatingCountSpecified |
 | RatingDetail |
 | RatingDetailSpecified |
 | RatingSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AverageRatingDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AverageRatingDetailsType Constructor

AverageRatingDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsType ► AverageRatingDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingDetailsType()
Public Sub New
public:
AverageRatingDetailsType()


Rating Property

Rating Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsType ► Rating
Declaration Syntax
C# Visual Basic Visual C++
public double Rating { get; set; }
Public Property Rating As Double
    Get
    Set
public:
property double Rating {
    double get ();
    void set (double value);
}


RatingCount Property

RatingCount Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsType ► RatingCount
Declaration Syntax
C# Visual Basic Visual C++
public int RatingCount { get; set; }
Public Property RatingCount As Integer
    Get
    Set
public:
property int RatingCount {
    int get ();
    void set (int value);
}


RatingCountSpecified Property

RatingCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsType ► RatingCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RatingCountSpecified { get; set; }
Public Property RatingCountSpecified As Boolean
    Get
    Set
public:
property bool RatingCountSpecified {
    bool get ();
    void set (bool value);
}


RatingDetail Property

RatingDetail Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsType ► RatingDetail
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackRatingDetailCodeType RatingDetail { get; set; }
Public Property RatingDetail As FeedbackRatingDetailCodeType
    Get
    Set
public:
property FeedbackRatingDetailCodeType RatingDetail {
    FeedbackRatingDetailCodeType get ();
    void set (FeedbackRatingDetailCodeType value);
}


RatingDetailSpecified Property

RatingDetailSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsType ► RatingDetailSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RatingDetailSpecified { get; set; }
Public Property RatingDetailSpecified As Boolean
    Get
    Set
public:
property bool RatingDetailSpecified {
    bool get ();
    void set (bool value);
}


RatingSpecified Property

RatingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsType ► RatingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RatingSpecified { get; set; }
Public Property RatingSpecified As Boolean
    Get
    Set
public:
property bool RatingSpecified {
    bool get ();
    void set (bool value);
}


AverageRatingDetailsTypeCollection Class

AverageRatingDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AverageRatingDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AverageRatingDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AverageRatingDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AverageRatingDetailsTypeCollection()()()() |
 | AverageRatingDetailsTypeCollection(array<AverageRatingDetailsType>[]()[][]) |
 | AverageRatingDetailsTypeCollection(AverageRatingDetailsTypeCollection) |
 | Add(AverageRatingDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AverageRatingDetailsType>[]()[][]) |
 | AddRange(AverageRatingDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AverageRatingDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AverageRatingDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AverageRatingDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AverageRatingDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AverageRatingDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AverageRatingDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► Add(AverageRatingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AverageRatingDetailsType item
)
Public Function Add ( _
    item As AverageRatingDetailsType _
) As Integer
public:
int Add(
    AverageRatingDetailsType^ item
)
Parameters
item (AverageRatingDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AverageRatingDetailsType>[]()[][]) |
 | AddRange(AverageRatingDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► AddRange(array<AverageRatingDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AverageRatingDetailsType[] items
)
Public Sub AddRange ( _
    items As AverageRatingDetailsType() _
)
public:
void AddRange(
    array<AverageRatingDetailsType^>^ items
)
Parameters
items (array< AverageRatingDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► AddRange(AverageRatingDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AverageRatingDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As AverageRatingDetailsTypeCollection _
)
public:
void AddRange(
    AverageRatingDetailsTypeCollection^ items
)
Parameters
items (AverageRatingDetailsTypeCollection)


AverageRatingDetailsTypeCollection Constructor

AverageRatingDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► AverageRatingDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | AverageRatingDetailsTypeCollection()()()() |
 | AverageRatingDetailsTypeCollection(array<AverageRatingDetailsType>[]()[][]) |
 | AverageRatingDetailsTypeCollection(AverageRatingDetailsTypeCollection) |


AverageRatingDetailsTypeCollection Constructor

AverageRatingDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► AverageRatingDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingDetailsTypeCollection()
Public Sub New
public:
AverageRatingDetailsTypeCollection()


AverageRatingDetailsTypeCollection Constructor (items)

AverageRatingDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► AverageRatingDetailsTypeCollection(array<AverageRatingDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingDetailsTypeCollection(
    AverageRatingDetailsType[] items
)
Public Sub New ( _
    items As AverageRatingDetailsType() _
)
public:
AverageRatingDetailsTypeCollection(
    array<AverageRatingDetailsType^>^ items
)
Parameters
items (array< AverageRatingDetailsType >[]()[][])


AverageRatingDetailsTypeCollection Constructor (items)

AverageRatingDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► AverageRatingDetailsTypeCollection(AverageRatingDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingDetailsTypeCollection(
    AverageRatingDetailsTypeCollection items
)
Public Sub New ( _
    items As AverageRatingDetailsTypeCollection _
)
public:
AverageRatingDetailsTypeCollection(
    AverageRatingDetailsTypeCollection^ items
)
Parameters
items (AverageRatingDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► Contains(AverageRatingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AverageRatingDetailsType item
)
Public Function Contains ( _
    item As AverageRatingDetailsType _
) As Boolean
public:
bool Contains(
    AverageRatingDetailsType^ item
)
Parameters
item (AverageRatingDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► CopyTo(array<AverageRatingDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AverageRatingDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AverageRatingDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AverageRatingDetailsType^>^ items,
    int index
)
Parameters
items (array< AverageRatingDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► IndexOf(AverageRatingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AverageRatingDetailsType item
)
Public Function IndexOf ( _
    item As AverageRatingDetailsType _
) As Integer
public:
int IndexOf(
    AverageRatingDetailsType^ item
)
Parameters
item (AverageRatingDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► Insert(Int32, AverageRatingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AverageRatingDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AverageRatingDetailsType _
)
public:
void Insert(
    int index,
    AverageRatingDetailsType^ item
)
Parameters
index (Int32)
item (AverageRatingDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AverageRatingDetailsType
    Get
    Set
public:
property AverageRatingDetailsType^ default[int index] {
    AverageRatingDetailsType^ get (int index);
    void set (int index, AverageRatingDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AverageRatingDetailsType
public:
AverageRatingDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► Remove(AverageRatingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AverageRatingDetailsType item
)
Public Sub Remove ( _
    item As AverageRatingDetailsType _
)
public:
void Remove(
    AverageRatingDetailsType^ item
)
Parameters
item (AverageRatingDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingDetailsType[] ToArray()
Public Function ToArray As AverageRatingDetailsType()
public:
array<AverageRatingDetailsType^>^ ToArray()
Return Value


AverageRatingSummaryType Class

AverageRatingSummaryType Class
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class AverageRatingSummaryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class AverageRatingSummaryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class AverageRatingSummaryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AverageRatingSummaryType()()()() |
 | Any |
 | AverageRatingDetails |
 | Equals(Object) | (Inherited from Object.)
 | FeedbackSummaryPeriod |
 | FeedbackSummaryPeriodSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AverageRatingSummaryType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AverageRatingDetails Property

AverageRatingDetails Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryType ► AverageRatingDetails
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingDetailsTypeCollection AverageRatingDetails { get; set; }
Public Property AverageRatingDetails As AverageRatingDetailsTypeCollection
    Get
    Set
public:
property AverageRatingDetailsTypeCollection^ AverageRatingDetails {
    AverageRatingDetailsTypeCollection^ get ();
    void set (AverageRatingDetailsTypeCollection^ value);
}


AverageRatingSummaryType Constructor

AverageRatingSummaryType Constructor
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryType ► AverageRatingSummaryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingSummaryType()
Public Sub New
public:
AverageRatingSummaryType()


FeedbackSummaryPeriod Property

FeedbackSummaryPeriod Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryType ► FeedbackSummaryPeriod
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackSummaryPeriodCodeType FeedbackSummaryPeriod { get; set; }
Public Property FeedbackSummaryPeriod As FeedbackSummaryPeriodCodeType
    Get
    Set
public:
property FeedbackSummaryPeriodCodeType FeedbackSummaryPeriod {
    FeedbackSummaryPeriodCodeType get ();
    void set (FeedbackSummaryPeriodCodeType value);
}


FeedbackSummaryPeriodSpecified Property

FeedbackSummaryPeriodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryType ► FeedbackSummaryPeriodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackSummaryPeriodSpecified { get; set; }
Public Property FeedbackSummaryPeriodSpecified As Boolean
    Get
    Set
public:
property bool FeedbackSummaryPeriodSpecified {
    bool get ();
    void set (bool value);
}


AverageRatingSummaryTypeCollection Class

AverageRatingSummaryTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class AverageRatingSummaryTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class AverageRatingSummaryTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class AverageRatingSummaryTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AverageRatingSummaryTypeCollection()()()() |
 | AverageRatingSummaryTypeCollection(array<AverageRatingSummaryType>[]()[][]) |
 | AverageRatingSummaryTypeCollection(AverageRatingSummaryTypeCollection) |
 | Add(AverageRatingSummaryType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AverageRatingSummaryType>[]()[][]) |
 | AddRange(AverageRatingSummaryTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(AverageRatingSummaryType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AverageRatingSummaryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AverageRatingSummaryType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AverageRatingSummaryType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AverageRatingSummaryType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AverageRatingSummaryTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► Add(AverageRatingSummaryType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AverageRatingSummaryType item
)
Public Function Add ( _
    item As AverageRatingSummaryType _
) As Integer
public:
int Add(
    AverageRatingSummaryType^ item
)
Parameters
item (AverageRatingSummaryType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AverageRatingSummaryType>[]()[][]) |
 | AddRange(AverageRatingSummaryTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► AddRange(array<AverageRatingSummaryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AverageRatingSummaryType[] items
)
Public Sub AddRange ( _
    items As AverageRatingSummaryType() _
)
public:
void AddRange(
    array<AverageRatingSummaryType^>^ items
)
Parameters
items (array< AverageRatingSummaryType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► AddRange(AverageRatingSummaryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AverageRatingSummaryTypeCollection items
)
Public Sub AddRange ( _
    items As AverageRatingSummaryTypeCollection _
)
public:
void AddRange(
    AverageRatingSummaryTypeCollection^ items
)
Parameters
items (AverageRatingSummaryTypeCollection)


AverageRatingSummaryTypeCollection Constructor

AverageRatingSummaryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► AverageRatingSummaryTypeCollection()()()()
Members
Icon | Member | Description
 | AverageRatingSummaryTypeCollection()()()() |
 | AverageRatingSummaryTypeCollection(array<AverageRatingSummaryType>[]()[][]) |
 | AverageRatingSummaryTypeCollection(AverageRatingSummaryTypeCollection) |


AverageRatingSummaryTypeCollection Constructor

AverageRatingSummaryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► AverageRatingSummaryTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingSummaryTypeCollection()
Public Sub New
public:
AverageRatingSummaryTypeCollection()


AverageRatingSummaryTypeCollection Constructor (items)

AverageRatingSummaryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► AverageRatingSummaryTypeCollection(array<AverageRatingSummaryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingSummaryTypeCollection(
    AverageRatingSummaryType[] items
)
Public Sub New ( _
    items As AverageRatingSummaryType() _
)
public:
AverageRatingSummaryTypeCollection(
    array<AverageRatingSummaryType^>^ items
)
Parameters
items (array< AverageRatingSummaryType >[]()[][])


AverageRatingSummaryTypeCollection Constructor (items)

AverageRatingSummaryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► AverageRatingSummaryTypeCollection(AverageRatingSummaryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingSummaryTypeCollection(
    AverageRatingSummaryTypeCollection items
)
Public Sub New ( _
    items As AverageRatingSummaryTypeCollection _
)
public:
AverageRatingSummaryTypeCollection(
    AverageRatingSummaryTypeCollection^ items
)
Parameters
items (AverageRatingSummaryTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► Contains(AverageRatingSummaryType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AverageRatingSummaryType item
)
Public Function Contains ( _
    item As AverageRatingSummaryType _
) As Boolean
public:
bool Contains(
    AverageRatingSummaryType^ item
)
Parameters
item (AverageRatingSummaryType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► CopyTo(array<AverageRatingSummaryType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AverageRatingSummaryType[] items,
    int index
)
Public Sub CopyTo ( _
    items As AverageRatingSummaryType(), _
    index As Integer _
)
public:
void CopyTo(
    array<AverageRatingSummaryType^>^ items,
    int index
)
Parameters
items (array< AverageRatingSummaryType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► IndexOf(AverageRatingSummaryType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AverageRatingSummaryType item
)
Public Function IndexOf ( _
    item As AverageRatingSummaryType _
) As Integer
public:
int IndexOf(
    AverageRatingSummaryType^ item
)
Parameters
item (AverageRatingSummaryType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► Insert(Int32, AverageRatingSummaryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AverageRatingSummaryType item
)
Public Sub Insert ( _
    index As Integer, _
    item As AverageRatingSummaryType _
)
public:
void Insert(
    int index,
    AverageRatingSummaryType^ item
)
Parameters
index (Int32)
item (AverageRatingSummaryType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingSummaryType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AverageRatingSummaryType
    Get
    Set
public:
property AverageRatingSummaryType^ default[int index] {
    AverageRatingSummaryType^ get (int index);
    void set (int index, AverageRatingSummaryType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingSummaryType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AverageRatingSummaryType
public:
AverageRatingSummaryType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► Remove(AverageRatingSummaryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AverageRatingSummaryType item
)
Public Sub Remove ( _
    item As AverageRatingSummaryType _
)
public:
void Remove(
    AverageRatingSummaryType^ item
)
Parameters
item (AverageRatingSummaryType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingSummaryType[] ToArray()
Public Function ToArray As AverageRatingSummaryType()
public:
array<AverageRatingSummaryType^>^ ToArray()
Return Value


Base64BinaryType Class

Base64BinaryType Class
Namespaces ► eBay.Service.Core.Soap ► Base64BinaryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class Base64BinaryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class Base64BinaryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class Base64BinaryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Base64BinaryType()()()() |
 | contentType |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Value |
Remarks
Inheritance Hierarchy
Object
Base64BinaryType


Base64BinaryType Constructor

Base64BinaryType Constructor
Namespaces ► eBay.Service.Core.Soap ► Base64BinaryType ► Base64BinaryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Base64BinaryType()
Public Sub New
public:
Base64BinaryType()


contentType Property

contentType Property
Namespaces ► eBay.Service.Core.Soap ► Base64BinaryType ► contentType
Declaration Syntax
C# Visual Basic Visual C++
public string contentType { get; set; }
Public Property contentType As String
    Get
    Set
public:
property String^ contentType {
    String^ get ();
    void set (String^ value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► Base64BinaryType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public byte[] Value { get; set; }
Public Property Value As Byte()
    Get
    Set
public:
property array<unsigned char>^ Value {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


BasicUpgradePackEnabledDefinitionType Class

BasicUpgradePackEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► BasicUpgradePackEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BasicUpgradePackEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BasicUpgradePackEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BasicUpgradePackEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BasicUpgradePackEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BasicUpgradePackEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BasicUpgradePackEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BasicUpgradePackEnabledDefinitionType Constructor

BasicUpgradePackEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► BasicUpgradePackEnabledDefinitionType ► BasicUpgradePackEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BasicUpgradePackEnabledDefinitionType()
Public Sub New
public:
BasicUpgradePackEnabledDefinitionType()


BestOfferActionCodeType Enumeration

BestOfferActionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BestOfferActionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BestOfferActionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BestOfferActionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BestOfferActionCodeType
Members
Member | Description
Accept |
Decline |
Counter |
CustomCode |
Remarks


BestOfferAutoAcceptEnabledDefinitionType Class

BestOfferAutoAcceptEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► BestOfferAutoAcceptEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BestOfferAutoAcceptEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BestOfferAutoAcceptEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BestOfferAutoAcceptEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BestOfferAutoAcceptEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BestOfferAutoAcceptEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferAutoAcceptEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestOfferAutoAcceptEnabledDefinitionType Constructor

BestOfferAutoAcceptEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► BestOfferAutoAcceptEnabledDefinitionType ► BestOfferAutoAcceptEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferAutoAcceptEnabledDefinitionType()
Public Sub New
public:
BestOfferAutoAcceptEnabledDefinitionType()


BestOfferAutoDeclineEnabledDefinitionType Class

BestOfferAutoDeclineEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► BestOfferAutoDeclineEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BestOfferAutoDeclineEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BestOfferAutoDeclineEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BestOfferAutoDeclineEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BestOfferAutoDeclineEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BestOfferAutoDeclineEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferAutoDeclineEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestOfferAutoDeclineEnabledDefinitionType Constructor

BestOfferAutoDeclineEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► BestOfferAutoDeclineEnabledDefinitionType ► BestOfferAutoDeclineEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferAutoDeclineEnabledDefinitionType()
Public Sub New
public:
BestOfferAutoDeclineEnabledDefinitionType()


BestOfferCounterEnabledDefinitionType Class

BestOfferCounterEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► BestOfferCounterEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BestOfferCounterEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BestOfferCounterEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BestOfferCounterEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BestOfferCounterEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BestOfferCounterEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferCounterEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestOfferCounterEnabledDefinitionType Constructor

BestOfferCounterEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► BestOfferCounterEnabledDefinitionType ► BestOfferCounterEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferCounterEnabledDefinitionType()
Public Sub New
public:
BestOfferCounterEnabledDefinitionType()


BestOfferDetailsType Class

BestOfferDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BestOfferDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BestOfferDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BestOfferDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BestOfferDetailsType()()()() |
 | Any |
 | BestOffer |
 | BestOfferCount |
 | BestOfferCountSpecified |
 | BestOfferEnabled |
 | BestOfferEnabledSpecified |
 | BestOfferStatus |
 | BestOfferStatusSpecified |
 | BestOfferType |
 | BestOfferTypeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewBestOffer |
 | NewBestOfferSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BestOfferDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestOffer Property

BestOffer Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► BestOffer
Declaration Syntax
C# Visual Basic Visual C++
public AmountType BestOffer { get; set; }
Public Property BestOffer As AmountType
    Get
    Set
public:
property AmountType^ BestOffer {
    AmountType^ get ();
    void set (AmountType^ value);
}


BestOfferCount Property

BestOfferCount Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► BestOfferCount
Declaration Syntax
C# Visual Basic Visual C++
public int BestOfferCount { get; set; }
Public Property BestOfferCount As Integer
    Get
    Set
public:
property int BestOfferCount {
    int get ();
    void set (int value);
}


BestOfferCountSpecified Property

BestOfferCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► BestOfferCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferCountSpecified { get; set; }
Public Property BestOfferCountSpecified As Boolean
    Get
    Set
public:
property bool BestOfferCountSpecified {
    bool get ();
    void set (bool value);
}


BestOfferDetailsType Constructor

BestOfferDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► BestOfferDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferDetailsType()
Public Sub New
public:
BestOfferDetailsType()


BestOfferEnabled Property

BestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► BestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferEnabled { get; set; }
Public Property BestOfferEnabled As Boolean
    Get
    Set
public:
property bool BestOfferEnabled {
    bool get ();
    void set (bool value);
}


BestOfferEnabledSpecified Property

BestOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► BestOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferEnabledSpecified { get; set; }
Public Property BestOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool BestOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


BestOfferStatus Property

BestOfferStatus Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► BestOfferStatus
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferStatusCodeType BestOfferStatus { get; set; }
Public Property BestOfferStatus As BestOfferStatusCodeType
    Get
    Set
public:
property BestOfferStatusCodeType BestOfferStatus {
    BestOfferStatusCodeType get ();
    void set (BestOfferStatusCodeType value);
}


BestOfferStatusSpecified Property

BestOfferStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► BestOfferStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferStatusSpecified { get; set; }
Public Property BestOfferStatusSpecified As Boolean
    Get
    Set
public:
property bool BestOfferStatusSpecified {
    bool get ();
    void set (bool value);
}


BestOfferType Property

BestOfferType Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► BestOfferType
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCodeType BestOfferType { get; set; }
Public Property BestOfferType As BestOfferTypeCodeType
    Get
    Set
public:
property BestOfferTypeCodeType BestOfferType {
    BestOfferTypeCodeType get ();
    void set (BestOfferTypeCodeType value);
}


BestOfferTypeSpecified Property

BestOfferTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► BestOfferTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferTypeSpecified { get; set; }
Public Property BestOfferTypeSpecified As Boolean
    Get
    Set
public:
property bool BestOfferTypeSpecified {
    bool get ();
    void set (bool value);
}


NewBestOffer Property

NewBestOffer Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► NewBestOffer
Declaration Syntax
C# Visual Basic Visual C++
public bool NewBestOffer { get; set; }
Public Property NewBestOffer As Boolean
    Get
    Set
public:
property bool NewBestOffer {
    bool get ();
    void set (bool value);
}


NewBestOfferSpecified Property

NewBestOfferSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferDetailsType ► NewBestOfferSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewBestOfferSpecified { get; set; }
Public Property NewBestOfferSpecified As Boolean
    Get
    Set
public:
property bool NewBestOfferSpecified {
    bool get ();
    void set (bool value);
}


BestOfferEnabledDefinitionType Class

BestOfferEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► BestOfferEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BestOfferEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BestOfferEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BestOfferEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BestOfferEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BestOfferEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestOfferEnabledDefinitionType Constructor

BestOfferEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► BestOfferEnabledDefinitionType ► BestOfferEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferEnabledDefinitionType()
Public Sub New
public:
BestOfferEnabledDefinitionType()


BestOfferStatusCodeType Enumeration

BestOfferStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BestOfferStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BestOfferStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BestOfferStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BestOfferStatusCodeType
Members
Member | Description
Pending |
Accepted |
Declined |
Expired |
Retracted |
AdminEnded |
Active |
Countered |
All |
PendingBuyerPayment |
PendingBuyerConfirmation |
CustomCode |
Remarks


BestOfferType Class

BestOfferType Class
Namespaces ► eBay.Service.Core.Soap ► BestOfferType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BestOfferType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BestOfferType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BestOfferType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BestOfferType()()()() |
 | Any |
 | BestOfferCodeType |
 | BestOfferCodeTypeSpecified |
 | BestOfferID |
 | Buyer |
 | BuyerMessage |
 | CallStatus |
 | Equals(Object) | (Inherited from Object.)
 | ExpirationTime |
 | ExpirationTimeSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ImmediatePayEligible |
 | ImmediatePayEligibleSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewBestOffer |
 | NewBestOfferSpecified |
 | Price |
 | Quantity |
 | QuantitySpecified |
 | SellerMessage |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BestOfferType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestOfferCodeType Property

BestOfferCodeType Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► BestOfferCodeType
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCodeType BestOfferCodeType { get; set; }
Public Property BestOfferCodeType As BestOfferTypeCodeType
    Get
    Set
public:
property BestOfferTypeCodeType BestOfferCodeType {
    BestOfferTypeCodeType get ();
    void set (BestOfferTypeCodeType value);
}


BestOfferCodeTypeSpecified Property

BestOfferCodeTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► BestOfferCodeTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferCodeTypeSpecified { get; set; }
Public Property BestOfferCodeTypeSpecified As Boolean
    Get
    Set
public:
property bool BestOfferCodeTypeSpecified {
    bool get ();
    void set (bool value);
}


BestOfferID Property

BestOfferID Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► BestOfferID
Declaration Syntax
C# Visual Basic Visual C++
public string BestOfferID { get; set; }
Public Property BestOfferID As String
    Get
    Set
public:
property String^ BestOfferID {
    String^ get ();
    void set (String^ value);
}


BestOfferType Constructor

BestOfferType Constructor
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► BestOfferType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferType()
Public Sub New
public:
BestOfferType()


Buyer Property

Buyer Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► Buyer
Declaration Syntax
C# Visual Basic Visual C++
public UserType Buyer { get; set; }
Public Property Buyer As UserType
    Get
    Set
public:
property UserType^ Buyer {
    UserType^ get ();
    void set (UserType^ value);
}


BuyerMessage Property

BuyerMessage Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► BuyerMessage
Declaration Syntax
C# Visual Basic Visual C++
public string BuyerMessage { get; set; }
Public Property BuyerMessage As String
    Get
    Set
public:
property String^ BuyerMessage {
    String^ get ();
    void set (String^ value);
}


CallStatus Property

CallStatus Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► CallStatus
Declaration Syntax
C# Visual Basic Visual C++
public string CallStatus { get; set; }
Public Property CallStatus As String
    Get
    Set
public:
property String^ CallStatus {
    String^ get ();
    void set (String^ value);
}


ExpirationTime Property

ExpirationTime Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► ExpirationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ExpirationTime { get; set; }
Public Property ExpirationTime As DateTime
    Get
    Set
public:
property DateTime ExpirationTime {
    DateTime get ();
    void set (DateTime value);
}


ExpirationTimeSpecified Property

ExpirationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► ExpirationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpirationTimeSpecified { get; set; }
Public Property ExpirationTimeSpecified As Boolean
    Get
    Set
public:
property bool ExpirationTimeSpecified {
    bool get ();
    void set (bool value);
}


ImmediatePayEligible Property

ImmediatePayEligible Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► ImmediatePayEligible
Declaration Syntax
C# Visual Basic Visual C++
public bool ImmediatePayEligible { get; set; }
Public Property ImmediatePayEligible As Boolean
    Get
    Set
public:
property bool ImmediatePayEligible {
    bool get ();
    void set (bool value);
}


ImmediatePayEligibleSpecified Property

ImmediatePayEligibleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► ImmediatePayEligibleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ImmediatePayEligibleSpecified { get; set; }
Public Property ImmediatePayEligibleSpecified As Boolean
    Get
    Set
public:
property bool ImmediatePayEligibleSpecified {
    bool get ();
    void set (bool value);
}


NewBestOffer Property

NewBestOffer Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► NewBestOffer
Declaration Syntax
C# Visual Basic Visual C++
public bool NewBestOffer { get; set; }
Public Property NewBestOffer As Boolean
    Get
    Set
public:
property bool NewBestOffer {
    bool get ();
    void set (bool value);
}


NewBestOfferSpecified Property

NewBestOfferSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► NewBestOfferSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewBestOfferSpecified { get; set; }
Public Property NewBestOfferSpecified As Boolean
    Get
    Set
public:
property bool NewBestOfferSpecified {
    bool get ();
    void set (bool value);
}


Price Property

Price Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► Price
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Price { get; set; }
Public Property Price As AmountType
    Get
    Set
public:
property AmountType^ Price {
    AmountType^ get ();
    void set (AmountType^ value);
}


Quantity Property

Quantity Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public int Quantity { get; set; }
Public Property Quantity As Integer
    Get
    Set
public:
property int Quantity {
    int get ();
    void set (int value);
}


QuantitySpecified Property

QuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► QuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySpecified { get; set; }
Public Property QuantitySpecified As Boolean
    Get
    Set
public:
property bool QuantitySpecified {
    bool get ();
    void set (bool value);
}


SellerMessage Property

SellerMessage Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► SellerMessage
Declaration Syntax
C# Visual Basic Visual C++
public string SellerMessage { get; set; }
Public Property SellerMessage As String
    Get
    Set
public:
property String^ SellerMessage {
    String^ get ();
    void set (String^ value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferStatusCodeType Status { get; set; }
Public Property Status As BestOfferStatusCodeType
    Get
    Set
public:
property BestOfferStatusCodeType Status {
    BestOfferStatusCodeType get ();
    void set (BestOfferStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


BestOfferTypeCodeType Enumeration

BestOfferTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BestOfferTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BestOfferTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BestOfferTypeCodeType
Members
Member | Description
BuyerBestOffer |
BuyerCounterOffer |
SellerCounterOffer |
CustomCode |
Remarks


BestOfferTypeCollection Class

BestOfferTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class BestOfferTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class BestOfferTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class BestOfferTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BestOfferTypeCollection()()()() |
 | BestOfferTypeCollection(array<BestOfferType>[]()[][]) |
 | BestOfferTypeCollection(BestOfferTypeCollection) |
 | Add(BestOfferType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<BestOfferType>[]()[][]) |
 | AddRange(BestOfferTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(BestOfferType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<BestOfferType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(BestOfferType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, BestOfferType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(BestOfferType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | BestOfferTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► Add(BestOfferType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    BestOfferType item
)
Public Function Add ( _
    item As BestOfferType _
) As Integer
public:
int Add(
    BestOfferType^ item
)
Parameters
item (BestOfferType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<BestOfferType>[]()[][]) |
 | AddRange(BestOfferTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► AddRange(array<BestOfferType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    BestOfferType[] items
)
Public Sub AddRange ( _
    items As BestOfferType() _
)
public:
void AddRange(
    array<BestOfferType^>^ items
)
Parameters
items (array< BestOfferType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► AddRange(BestOfferTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    BestOfferTypeCollection items
)
Public Sub AddRange ( _
    items As BestOfferTypeCollection _
)
public:
void AddRange(
    BestOfferTypeCollection^ items
)
Parameters
items (BestOfferTypeCollection)


BestOfferTypeCollection Constructor

BestOfferTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► BestOfferTypeCollection()()()()
Members
Icon | Member | Description
 | BestOfferTypeCollection()()()() |
 | BestOfferTypeCollection(array<BestOfferType>[]()[][]) |
 | BestOfferTypeCollection(BestOfferTypeCollection) |


BestOfferTypeCollection Constructor

BestOfferTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► BestOfferTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection()
Public Sub New
public:
BestOfferTypeCollection()


BestOfferTypeCollection Constructor (items)

BestOfferTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► BestOfferTypeCollection(array<BestOfferType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection(
    BestOfferType[] items
)
Public Sub New ( _
    items As BestOfferType() _
)
public:
BestOfferTypeCollection(
    array<BestOfferType^>^ items
)
Parameters
items (array< BestOfferType >[]()[][])


BestOfferTypeCollection Constructor (items)

BestOfferTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► BestOfferTypeCollection(BestOfferTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection(
    BestOfferTypeCollection items
)
Public Sub New ( _
    items As BestOfferTypeCollection _
)
public:
BestOfferTypeCollection(
    BestOfferTypeCollection^ items
)
Parameters
items (BestOfferTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► Contains(BestOfferType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    BestOfferType item
)
Public Function Contains ( _
    item As BestOfferType _
) As Boolean
public:
bool Contains(
    BestOfferType^ item
)
Parameters
item (BestOfferType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► CopyTo(array<BestOfferType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    BestOfferType[] items,
    int index
)
Public Sub CopyTo ( _
    items As BestOfferType(), _
    index As Integer _
)
public:
void CopyTo(
    array<BestOfferType^>^ items,
    int index
)
Parameters
items (array< BestOfferType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► IndexOf(BestOfferType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    BestOfferType item
)
Public Function IndexOf ( _
    item As BestOfferType _
) As Integer
public:
int IndexOf(
    BestOfferType^ item
)
Parameters
item (BestOfferType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► Insert(Int32, BestOfferType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    BestOfferType item
)
Public Sub Insert ( _
    index As Integer, _
    item As BestOfferType _
)
public:
void Insert(
    int index,
    BestOfferType^ item
)
Parameters
index (Int32)
item (BestOfferType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As BestOfferType
    Get
    Set
public:
property BestOfferType^ default[int index] {
    BestOfferType^ get (int index);
    void set (int index, BestOfferType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As BestOfferType
public:
BestOfferType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► Remove(BestOfferType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    BestOfferType item
)
Public Sub Remove ( _
    item As BestOfferType _
)
public:
void Remove(
    BestOfferType^ item
)
Parameters
item (BestOfferType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferType[] ToArray()
Public Function ToArray As BestOfferType()
public:
array<BestOfferType^>^ ToArray()
Return Value


BidActionCodeType Enumeration

BidActionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BidActionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BidActionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BidActionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BidActionCodeType
Members
Member | Description
Unknown |
Bid |
NotUsed |
Retraction |
AutoRetraction |
Cancelled |
AutoCancel |
Absentee |
BuyItNow |
Purchase |
CustomCode |
Offer |
Counter |
Accept |
Decline |
Remarks


BidAssistantListType Class

BidAssistantListType Class
Namespaces ► eBay.Service.Core.Soap ► BidAssistantListType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BidAssistantListType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BidAssistantListType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BidAssistantListType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BidAssistantListType()()()() |
 | Any |
 | BidGroupID |
 | BidGroupIDSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeNotes |
 | IncludeNotesSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BidAssistantListType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BidAssistantListType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidAssistantListType Constructor

BidAssistantListType Constructor
Namespaces ► eBay.Service.Core.Soap ► BidAssistantListType ► BidAssistantListType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BidAssistantListType()
Public Sub New
public:
BidAssistantListType()


BidGroupID Property

BidGroupID Property
Namespaces ► eBay.Service.Core.Soap ► BidAssistantListType ► BidGroupID
Declaration Syntax
C# Visual Basic Visual C++
public long BidGroupID { get; set; }
Public Property BidGroupID As Long
    Get
    Set
public:
property long long BidGroupID {
    long long get ();
    void set (long long value);
}


BidGroupIDSpecified Property

BidGroupIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BidAssistantListType ► BidGroupIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidGroupIDSpecified { get; set; }
Public Property BidGroupIDSpecified As Boolean
    Get
    Set
public:
property bool BidGroupIDSpecified {
    bool get ();
    void set (bool value);
}


IncludeNotes Property

IncludeNotes Property
Namespaces ► eBay.Service.Core.Soap ► BidAssistantListType ► IncludeNotes
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeNotes { get; set; }
Public Property IncludeNotes As Boolean
    Get
    Set
public:
property bool IncludeNotes {
    bool get ();
    void set (bool value);
}


IncludeNotesSpecified Property

IncludeNotesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BidAssistantListType ► IncludeNotesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeNotesSpecified { get; set; }
Public Property IncludeNotesSpecified As Boolean
    Get
    Set
public:
property bool IncludeNotesSpecified {
    bool get ();
    void set (bool value);
}


BidderNoticePreferencesType Class

BidderNoticePreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► BidderNoticePreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BidderNoticePreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BidderNoticePreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BidderNoticePreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BidderNoticePreferencesType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UnsuccessfulBidderNoticeIncludeMyItems |
 | UnsuccessfulBidderNoticeIncludeMyItemsSpecified |
Remarks
Inheritance Hierarchy
Object
BidderNoticePreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BidderNoticePreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidderNoticePreferencesType Constructor

BidderNoticePreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► BidderNoticePreferencesType ► BidderNoticePreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BidderNoticePreferencesType()
Public Sub New
public:
BidderNoticePreferencesType()


UnsuccessfulBidderNoticeIncludeMyItems Property

UnsuccessfulBidderNoticeIncludeMyItems Property
Namespaces ► eBay.Service.Core.Soap ► BidderNoticePreferencesType ► UnsuccessfulBidderNoticeIncludeMyItems
Declaration Syntax
C# Visual Basic Visual C++
public bool UnsuccessfulBidderNoticeIncludeMyItems { get; set; }
Public Property UnsuccessfulBidderNoticeIncludeMyItems As Boolean
    Get
    Set
public:
property bool UnsuccessfulBidderNoticeIncludeMyItems {
    bool get ();
    void set (bool value);
}


UnsuccessfulBidderNoticeIncludeMyItemsSpecified Property

UnsuccessfulBidderNoticeIncludeMyItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BidderNoticePreferencesType ► UnsuccessfulBidderNoticeIncludeMyItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UnsuccessfulBidderNoticeIncludeMyItemsSpecified { get; set; }
Public Property UnsuccessfulBidderNoticeIncludeMyItemsSpecified As Boolean
    Get
    Set
public:
property bool UnsuccessfulBidderNoticeIncludeMyItemsSpecified {
    bool get ();
    void set (bool value);
}


BiddingDetailsType Class

BiddingDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BiddingDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BiddingDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BiddingDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BiddingDetailsType()()()() |
 | Any |
 | BidAssistant |
 | BidAssistantSpecified |
 | ConvertedMaxBid |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MaxBid |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QuantityBid |
 | QuantityBidSpecified |
 | QuantityWon |
 | QuantityWonSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Winning |
 | WinningSpecified |
Remarks
Inheritance Hierarchy
Object
BiddingDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidAssistant Property

BidAssistant Property
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► BidAssistant
Declaration Syntax
C# Visual Basic Visual C++
public bool BidAssistant { get; set; }
Public Property BidAssistant As Boolean
    Get
    Set
public:
property bool BidAssistant {
    bool get ();
    void set (bool value);
}


BidAssistantSpecified Property

BidAssistantSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► BidAssistantSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidAssistantSpecified { get; set; }
Public Property BidAssistantSpecified As Boolean
    Get
    Set
public:
property bool BidAssistantSpecified {
    bool get ();
    void set (bool value);
}


BiddingDetailsType Constructor

BiddingDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► BiddingDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BiddingDetailsType()
Public Sub New
public:
BiddingDetailsType()


ConvertedMaxBid Property

ConvertedMaxBid Property
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► ConvertedMaxBid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ConvertedMaxBid { get; set; }
Public Property ConvertedMaxBid As AmountType
    Get
    Set
public:
property AmountType^ ConvertedMaxBid {
    AmountType^ get ();
    void set (AmountType^ value);
}


MaxBid Property

MaxBid Property
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► MaxBid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MaxBid { get; set; }
Public Property MaxBid As AmountType
    Get
    Set
public:
property AmountType^ MaxBid {
    AmountType^ get ();
    void set (AmountType^ value);
}


QuantityBid Property

QuantityBid Property
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► QuantityBid
Declaration Syntax
C# Visual Basic Visual C++
public int QuantityBid { get; set; }
Public Property QuantityBid As Integer
    Get
    Set
public:
property int QuantityBid {
    int get ();
    void set (int value);
}


QuantityBidSpecified Property

QuantityBidSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► QuantityBidSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityBidSpecified { get; set; }
Public Property QuantityBidSpecified As Boolean
    Get
    Set
public:
property bool QuantityBidSpecified {
    bool get ();
    void set (bool value);
}


QuantityWon Property

QuantityWon Property
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► QuantityWon
Declaration Syntax
C# Visual Basic Visual C++
public int QuantityWon { get; set; }
Public Property QuantityWon As Integer
    Get
    Set
public:
property int QuantityWon {
    int get ();
    void set (int value);
}


QuantityWonSpecified Property

QuantityWonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► QuantityWonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityWonSpecified { get; set; }
Public Property QuantityWonSpecified As Boolean
    Get
    Set
public:
property bool QuantityWonSpecified {
    bool get ();
    void set (bool value);
}


Winning Property

Winning Property
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► Winning
Declaration Syntax
C# Visual Basic Visual C++
public bool Winning { get; set; }
Public Property Winning As Boolean
    Get
    Set
public:
property bool Winning {
    bool get ();
    void set (bool value);
}


WinningSpecified Property

WinningSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BiddingDetailsType ► WinningSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WinningSpecified { get; set; }
Public Property WinningSpecified As Boolean
    Get
    Set
public:
property bool WinningSpecified {
    bool get ();
    void set (bool value);
}


BiddingSummaryType Class

BiddingSummaryType Class
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BiddingSummaryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BiddingSummaryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BiddingSummaryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BiddingSummaryType()()()() |
 | Any |
 | BidActivityWithSeller |
 | BidActivityWithSellerSpecified |
 | BidRetractions |
 | BidRetractionsSpecified |
 | BidsToUniqueCategories |
 | BidsToUniqueCategoriesSpecified |
 | BidsToUniqueSellers |
 | BidsToUniqueSellersSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemBidDetails |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SummaryDays |
 | SummaryDaysSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TotalBids |
 | TotalBidsSpecified |
Remarks
Inheritance Hierarchy
Object
BiddingSummaryType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidActivityWithSeller Property

BidActivityWithSeller Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► BidActivityWithSeller
Declaration Syntax
C# Visual Basic Visual C++
public int BidActivityWithSeller { get; set; }
Public Property BidActivityWithSeller As Integer
    Get
    Set
public:
property int BidActivityWithSeller {
    int get ();
    void set (int value);
}


BidActivityWithSellerSpecified Property

BidActivityWithSellerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► BidActivityWithSellerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidActivityWithSellerSpecified { get; set; }
Public Property BidActivityWithSellerSpecified As Boolean
    Get
    Set
public:
property bool BidActivityWithSellerSpecified {
    bool get ();
    void set (bool value);
}


BiddingSummaryType Constructor

BiddingSummaryType Constructor
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► BiddingSummaryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BiddingSummaryType()
Public Sub New
public:
BiddingSummaryType()


BidRetractions Property

BidRetractions Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► BidRetractions
Declaration Syntax
C# Visual Basic Visual C++
public int BidRetractions { get; set; }
Public Property BidRetractions As Integer
    Get
    Set
public:
property int BidRetractions {
    int get ();
    void set (int value);
}


BidRetractionsSpecified Property

BidRetractionsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► BidRetractionsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidRetractionsSpecified { get; set; }
Public Property BidRetractionsSpecified As Boolean
    Get
    Set
public:
property bool BidRetractionsSpecified {
    bool get ();
    void set (bool value);
}


BidsToUniqueCategories Property

BidsToUniqueCategories Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► BidsToUniqueCategories
Declaration Syntax
C# Visual Basic Visual C++
public int BidsToUniqueCategories { get; set; }
Public Property BidsToUniqueCategories As Integer
    Get
    Set
public:
property int BidsToUniqueCategories {
    int get ();
    void set (int value);
}


BidsToUniqueCategoriesSpecified Property

BidsToUniqueCategoriesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► BidsToUniqueCategoriesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidsToUniqueCategoriesSpecified { get; set; }
Public Property BidsToUniqueCategoriesSpecified As Boolean
    Get
    Set
public:
property bool BidsToUniqueCategoriesSpecified {
    bool get ();
    void set (bool value);
}


BidsToUniqueSellers Property

BidsToUniqueSellers Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► BidsToUniqueSellers
Declaration Syntax
C# Visual Basic Visual C++
public int BidsToUniqueSellers { get; set; }
Public Property BidsToUniqueSellers As Integer
    Get
    Set
public:
property int BidsToUniqueSellers {
    int get ();
    void set (int value);
}


BidsToUniqueSellersSpecified Property

BidsToUniqueSellersSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► BidsToUniqueSellersSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidsToUniqueSellersSpecified { get; set; }
Public Property BidsToUniqueSellersSpecified As Boolean
    Get
    Set
public:
property bool BidsToUniqueSellersSpecified {
    bool get ();
    void set (bool value);
}


ItemBidDetails Property

ItemBidDetails Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► ItemBidDetails
Declaration Syntax
C# Visual Basic Visual C++
public ItemBidDetailsTypeCollection ItemBidDetails { get; set; }
Public Property ItemBidDetails As ItemBidDetailsTypeCollection
    Get
    Set
public:
property ItemBidDetailsTypeCollection^ ItemBidDetails {
    ItemBidDetailsTypeCollection^ get ();
    void set (ItemBidDetailsTypeCollection^ value);
}


SummaryDays Property

SummaryDays Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► SummaryDays
Declaration Syntax
C# Visual Basic Visual C++
public int SummaryDays { get; set; }
Public Property SummaryDays As Integer
    Get
    Set
public:
property int SummaryDays {
    int get ();
    void set (int value);
}


SummaryDaysSpecified Property

SummaryDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► SummaryDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SummaryDaysSpecified { get; set; }
Public Property SummaryDaysSpecified As Boolean
    Get
    Set
public:
property bool SummaryDaysSpecified {
    bool get ();
    void set (bool value);
}


TotalBids Property

TotalBids Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► TotalBids
Declaration Syntax
C# Visual Basic Visual C++
public int TotalBids { get; set; }
Public Property TotalBids As Integer
    Get
    Set
public:
property int TotalBids {
    int get ();
    void set (int value);
}


TotalBidsSpecified Property

TotalBidsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BiddingSummaryType ► TotalBidsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalBidsSpecified { get; set; }
Public Property TotalBidsSpecified As Boolean
    Get
    Set
public:
property bool TotalBidsSpecified {
    bool get ();
    void set (bool value);
}


BidGroupItemStatusCodeType Enumeration

BidGroupItemStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BidGroupItemStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BidGroupItemStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BidGroupItemStatusCodeType
Members
Member | Description
CurrentBid |
Cancelled |
Pending |
Skipped |
Ended |
Won |
GroupClosed |
CustomCode |
Remarks


BidGroupItemType Class

BidGroupItemType Class
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BidGroupItemType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BidGroupItemType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BidGroupItemType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BidGroupItemType()()()() |
 | Any |
 | BidGroupItemStatus |
 | BidGroupItemStatusSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Item |
 | MaxBidAmount |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BidGroupItemType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidGroupItemStatus Property

BidGroupItemStatus Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemType ► BidGroupItemStatus
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupItemStatusCodeType BidGroupItemStatus { get; set; }
Public Property BidGroupItemStatus As BidGroupItemStatusCodeType
    Get
    Set
public:
property BidGroupItemStatusCodeType BidGroupItemStatus {
    BidGroupItemStatusCodeType get ();
    void set (BidGroupItemStatusCodeType value);
}


BidGroupItemStatusSpecified Property

BidGroupItemStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemType ► BidGroupItemStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidGroupItemStatusSpecified { get; set; }
Public Property BidGroupItemStatusSpecified As Boolean
    Get
    Set
public:
property bool BidGroupItemStatusSpecified {
    bool get ();
    void set (bool value);
}


BidGroupItemType Constructor

BidGroupItemType Constructor
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemType ► BidGroupItemType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupItemType()
Public Sub New
public:
BidGroupItemType()


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


MaxBidAmount Property

MaxBidAmount Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemType ► MaxBidAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MaxBidAmount { get; set; }
Public Property MaxBidAmount As AmountType
    Get
    Set
public:
property AmountType^ MaxBidAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


BidGroupItemTypeCollection Class

BidGroupItemTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class BidGroupItemTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class BidGroupItemTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class BidGroupItemTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BidGroupItemTypeCollection()()()() |
 | BidGroupItemTypeCollection(array<BidGroupItemType>[]()[][]) |
 | BidGroupItemTypeCollection(BidGroupItemTypeCollection) |
 | Add(BidGroupItemType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<BidGroupItemType>[]()[][]) |
 | AddRange(BidGroupItemTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(BidGroupItemType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<BidGroupItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(BidGroupItemType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, BidGroupItemType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(BidGroupItemType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | BidGroupItemTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► Add(BidGroupItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    BidGroupItemType item
)
Public Function Add ( _
    item As BidGroupItemType _
) As Integer
public:
int Add(
    BidGroupItemType^ item
)
Parameters
item (BidGroupItemType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<BidGroupItemType>[]()[][]) |
 | AddRange(BidGroupItemTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► AddRange(array<BidGroupItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    BidGroupItemType[] items
)
Public Sub AddRange ( _
    items As BidGroupItemType() _
)
public:
void AddRange(
    array<BidGroupItemType^>^ items
)
Parameters
items (array< BidGroupItemType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► AddRange(BidGroupItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    BidGroupItemTypeCollection items
)
Public Sub AddRange ( _
    items As BidGroupItemTypeCollection _
)
public:
void AddRange(
    BidGroupItemTypeCollection^ items
)
Parameters
items (BidGroupItemTypeCollection)


BidGroupItemTypeCollection Constructor

BidGroupItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► BidGroupItemTypeCollection()()()()
Members
Icon | Member | Description
 | BidGroupItemTypeCollection()()()() |
 | BidGroupItemTypeCollection(array<BidGroupItemType>[]()[][]) |
 | BidGroupItemTypeCollection(BidGroupItemTypeCollection) |


BidGroupItemTypeCollection Constructor

BidGroupItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► BidGroupItemTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupItemTypeCollection()
Public Sub New
public:
BidGroupItemTypeCollection()


BidGroupItemTypeCollection Constructor (items)

BidGroupItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► BidGroupItemTypeCollection(array<BidGroupItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupItemTypeCollection(
    BidGroupItemType[] items
)
Public Sub New ( _
    items As BidGroupItemType() _
)
public:
BidGroupItemTypeCollection(
    array<BidGroupItemType^>^ items
)
Parameters
items (array< BidGroupItemType >[]()[][])


BidGroupItemTypeCollection Constructor (items)

BidGroupItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► BidGroupItemTypeCollection(BidGroupItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupItemTypeCollection(
    BidGroupItemTypeCollection items
)
Public Sub New ( _
    items As BidGroupItemTypeCollection _
)
public:
BidGroupItemTypeCollection(
    BidGroupItemTypeCollection^ items
)
Parameters
items (BidGroupItemTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► Contains(BidGroupItemType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    BidGroupItemType item
)
Public Function Contains ( _
    item As BidGroupItemType _
) As Boolean
public:
bool Contains(
    BidGroupItemType^ item
)
Parameters
item (BidGroupItemType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► CopyTo(array<BidGroupItemType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    BidGroupItemType[] items,
    int index
)
Public Sub CopyTo ( _
    items As BidGroupItemType(), _
    index As Integer _
)
public:
void CopyTo(
    array<BidGroupItemType^>^ items,
    int index
)
Parameters
items (array< BidGroupItemType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► IndexOf(BidGroupItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    BidGroupItemType item
)
Public Function IndexOf ( _
    item As BidGroupItemType _
) As Integer
public:
int IndexOf(
    BidGroupItemType^ item
)
Parameters
item (BidGroupItemType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► Insert(Int32, BidGroupItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    BidGroupItemType item
)
Public Sub Insert ( _
    index As Integer, _
    item As BidGroupItemType _
)
public:
void Insert(
    int index,
    BidGroupItemType^ item
)
Parameters
index (Int32)
item (BidGroupItemType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupItemType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As BidGroupItemType
    Get
    Set
public:
property BidGroupItemType^ default[int index] {
    BidGroupItemType^ get (int index);
    void set (int index, BidGroupItemType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupItemType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As BidGroupItemType
public:
BidGroupItemType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► Remove(BidGroupItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    BidGroupItemType item
)
Public Sub Remove ( _
    item As BidGroupItemType _
)
public:
void Remove(
    BidGroupItemType^ item
)
Parameters
item (BidGroupItemType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupItemType[] ToArray()
Public Function ToArray As BidGroupItemType()
public:
array<BidGroupItemType^>^ ToArray()
Return Value


BidGroupStatusCodeType Enumeration

BidGroupStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BidGroupStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BidGroupStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BidGroupStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BidGroupStatusCodeType
Members
Member | Description
Open |
Closed |
CustomCode |
Remarks


BidGroupType Class

BidGroupType Class
Namespaces ► eBay.Service.Core.Soap ► BidGroupType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BidGroupType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BidGroupType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BidGroupType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BidGroupType()()()() |
 | Any |
 | BidGroupID |
 | BidGroupIDSpecified |
 | BidGroupItem |
 | BidGroupName |
 | BidGroupStatus |
 | BidGroupStatusSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BidGroupType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidGroupID Property

BidGroupID Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupType ► BidGroupID
Declaration Syntax
C# Visual Basic Visual C++
public long BidGroupID { get; set; }
Public Property BidGroupID As Long
    Get
    Set
public:
property long long BidGroupID {
    long long get ();
    void set (long long value);
}


BidGroupIDSpecified Property

BidGroupIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupType ► BidGroupIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidGroupIDSpecified { get; set; }
Public Property BidGroupIDSpecified As Boolean
    Get
    Set
public:
property bool BidGroupIDSpecified {
    bool get ();
    void set (bool value);
}


BidGroupItem Property

BidGroupItem Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupType ► BidGroupItem
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupItemTypeCollection BidGroupItem { get; set; }
Public Property BidGroupItem As BidGroupItemTypeCollection
    Get
    Set
public:
property BidGroupItemTypeCollection^ BidGroupItem {
    BidGroupItemTypeCollection^ get ();
    void set (BidGroupItemTypeCollection^ value);
}


BidGroupName Property

BidGroupName Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupType ► BidGroupName
Declaration Syntax
C# Visual Basic Visual C++
public string BidGroupName { get; set; }
Public Property BidGroupName As String
    Get
    Set
public:
property String^ BidGroupName {
    String^ get ();
    void set (String^ value);
}


BidGroupStatus Property

BidGroupStatus Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupType ► BidGroupStatus
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupStatusCodeType BidGroupStatus { get; set; }
Public Property BidGroupStatus As BidGroupStatusCodeType
    Get
    Set
public:
property BidGroupStatusCodeType BidGroupStatus {
    BidGroupStatusCodeType get ();
    void set (BidGroupStatusCodeType value);
}


BidGroupStatusSpecified Property

BidGroupStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupType ► BidGroupStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidGroupStatusSpecified { get; set; }
Public Property BidGroupStatusSpecified As Boolean
    Get
    Set
public:
property bool BidGroupStatusSpecified {
    bool get ();
    void set (bool value);
}


BidGroupType Constructor

BidGroupType Constructor
Namespaces ► eBay.Service.Core.Soap ► BidGroupType ► BidGroupType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupType()
Public Sub New
public:
BidGroupType()


BidGroupTypeCollection Class

BidGroupTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class BidGroupTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class BidGroupTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class BidGroupTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BidGroupTypeCollection()()()() |
 | BidGroupTypeCollection(array<BidGroupType>[]()[][]) |
 | BidGroupTypeCollection(BidGroupTypeCollection) |
 | Add(BidGroupType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<BidGroupType>[]()[][]) |
 | AddRange(BidGroupTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(BidGroupType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<BidGroupType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(BidGroupType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, BidGroupType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(BidGroupType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | BidGroupTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► Add(BidGroupType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    BidGroupType item
)
Public Function Add ( _
    item As BidGroupType _
) As Integer
public:
int Add(
    BidGroupType^ item
)
Parameters
item (BidGroupType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<BidGroupType>[]()[][]) |
 | AddRange(BidGroupTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► AddRange(array<BidGroupType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    BidGroupType[] items
)
Public Sub AddRange ( _
    items As BidGroupType() _
)
public:
void AddRange(
    array<BidGroupType^>^ items
)
Parameters
items (array< BidGroupType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► AddRange(BidGroupTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    BidGroupTypeCollection items
)
Public Sub AddRange ( _
    items As BidGroupTypeCollection _
)
public:
void AddRange(
    BidGroupTypeCollection^ items
)
Parameters
items (BidGroupTypeCollection)


BidGroupTypeCollection Constructor

BidGroupTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► BidGroupTypeCollection()()()()
Members
Icon | Member | Description
 | BidGroupTypeCollection()()()() |
 | BidGroupTypeCollection(array<BidGroupType>[]()[][]) |
 | BidGroupTypeCollection(BidGroupTypeCollection) |


BidGroupTypeCollection Constructor

BidGroupTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► BidGroupTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupTypeCollection()
Public Sub New
public:
BidGroupTypeCollection()


BidGroupTypeCollection Constructor (items)

BidGroupTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► BidGroupTypeCollection(array<BidGroupType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupTypeCollection(
    BidGroupType[] items
)
Public Sub New ( _
    items As BidGroupType() _
)
public:
BidGroupTypeCollection(
    array<BidGroupType^>^ items
)
Parameters
items (array< BidGroupType >[]()[][])


BidGroupTypeCollection Constructor (items)

BidGroupTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► BidGroupTypeCollection(BidGroupTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupTypeCollection(
    BidGroupTypeCollection items
)
Public Sub New ( _
    items As BidGroupTypeCollection _
)
public:
BidGroupTypeCollection(
    BidGroupTypeCollection^ items
)
Parameters
items (BidGroupTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► Contains(BidGroupType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    BidGroupType item
)
Public Function Contains ( _
    item As BidGroupType _
) As Boolean
public:
bool Contains(
    BidGroupType^ item
)
Parameters
item (BidGroupType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► CopyTo(array<BidGroupType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    BidGroupType[] items,
    int index
)
Public Sub CopyTo ( _
    items As BidGroupType(), _
    index As Integer _
)
public:
void CopyTo(
    array<BidGroupType^>^ items,
    int index
)
Parameters
items (array< BidGroupType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► IndexOf(BidGroupType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    BidGroupType item
)
Public Function IndexOf ( _
    item As BidGroupType _
) As Integer
public:
int IndexOf(
    BidGroupType^ item
)
Parameters
item (BidGroupType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► Insert(Int32, BidGroupType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    BidGroupType item
)
Public Sub Insert ( _
    index As Integer, _
    item As BidGroupType _
)
public:
void Insert(
    int index,
    BidGroupType^ item
)
Parameters
index (Int32)
item (BidGroupType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As BidGroupType
    Get
    Set
public:
property BidGroupType^ default[int index] {
    BidGroupType^ get (int index);
    void set (int index, BidGroupType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As BidGroupType
public:
BidGroupType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► Remove(BidGroupType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    BidGroupType item
)
Public Sub Remove ( _
    item As BidGroupType _
)
public:
void Remove(
    BidGroupType^ item
)
Parameters
item (BidGroupType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupType[] ToArray()
Public Function ToArray As BidGroupType()
public:
array<BidGroupType^>^ ToArray()
Return Value


BoldTitleCodeType Enumeration

BoldTitleCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BoldTitleCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BoldTitleCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BoldTitleCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BoldTitleCodeType
Members
Member | Description
Enabled |
Disabled |
CustomCode |
Remarks


BorderCodeType Enumeration

BorderCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BorderCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BorderCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BorderCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BorderCodeType
Members
Member | Description
Enabled |
Disabled |
CustomCode |
Remarks


BotBlockRequestType Class

BotBlockRequestType Class
Namespaces ► eBay.Service.Core.Soap ► BotBlockRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BotBlockRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BotBlockRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BotBlockRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BotBlockRequestType()()()() |
 | Any |
 | BotBlockToken |
 | BotBlockUserInput |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BotBlockRequestType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BotBlockRequestType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BotBlockRequestType Constructor

BotBlockRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► BotBlockRequestType ► BotBlockRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BotBlockRequestType()
Public Sub New
public:
BotBlockRequestType()


BotBlockToken Property

BotBlockToken Property
Namespaces ► eBay.Service.Core.Soap ► BotBlockRequestType ► BotBlockToken
Declaration Syntax
C# Visual Basic Visual C++
public string BotBlockToken { get; set; }
Public Property BotBlockToken As String
    Get
    Set
public:
property String^ BotBlockToken {
    String^ get ();
    void set (String^ value);
}


BotBlockUserInput Property

BotBlockUserInput Property
Namespaces ► eBay.Service.Core.Soap ► BotBlockRequestType ► BotBlockUserInput
Declaration Syntax
C# Visual Basic Visual C++
public string BotBlockUserInput { get; set; }
Public Property BotBlockUserInput As String
    Get
    Set
public:
property String^ BotBlockUserInput {
    String^ get ();
    void set (String^ value);
}


BotBlockResponseType Class

BotBlockResponseType Class
Namespaces ► eBay.Service.Core.Soap ► BotBlockResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BotBlockResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BotBlockResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BotBlockResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BotBlockResponseType()()()() |
 | Any |
 | BotBlockAudioUrl |
 | BotBlockToken |
 | BotBlockUrl |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BotBlockResponseType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BotBlockResponseType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BotBlockAudioUrl Property

BotBlockAudioUrl Property
Namespaces ► eBay.Service.Core.Soap ► BotBlockResponseType ► BotBlockAudioUrl
Declaration Syntax
C# Visual Basic Visual C++
public string BotBlockAudioUrl { get; set; }
Public Property BotBlockAudioUrl As String
    Get
    Set
public:
property String^ BotBlockAudioUrl {
    String^ get ();
    void set (String^ value);
}


BotBlockResponseType Constructor

BotBlockResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► BotBlockResponseType ► BotBlockResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BotBlockResponseType()
Public Sub New
public:
BotBlockResponseType()


BotBlockToken Property

BotBlockToken Property
Namespaces ► eBay.Service.Core.Soap ► BotBlockResponseType ► BotBlockToken
Declaration Syntax
C# Visual Basic Visual C++
public string BotBlockToken { get; set; }
Public Property BotBlockToken As String
    Get
    Set
public:
property String^ BotBlockToken {
    String^ get ();
    void set (String^ value);
}


BotBlockUrl Property

BotBlockUrl Property
Namespaces ► eBay.Service.Core.Soap ► BotBlockResponseType ► BotBlockUrl
Declaration Syntax
C# Visual Basic Visual C++
public string BotBlockUrl { get; set; }
Public Property BotBlockUrl As String
    Get
    Set
public:
property String^ BotBlockUrl {
    String^ get ();
    void set (String^ value);
}


BrandMPNIdentifierEnabledDefinitionType Class

BrandMPNIdentifierEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► BrandMPNIdentifierEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BrandMPNIdentifierEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BrandMPNIdentifierEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BrandMPNIdentifierEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BrandMPNIdentifierEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BrandMPNIdentifierEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BrandMPNIdentifierEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BrandMPNIdentifierEnabledDefinitionType Constructor

BrandMPNIdentifierEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► BrandMPNIdentifierEnabledDefinitionType ► BrandMPNIdentifierEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BrandMPNIdentifierEnabledDefinitionType()
Public Sub New
public:
BrandMPNIdentifierEnabledDefinitionType()


BrandMPNType Class

BrandMPNType Class
Namespaces ► eBay.Service.Core.Soap ► BrandMPNType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BrandMPNType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BrandMPNType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BrandMPNType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BrandMPNType()()()() |
 | Any |
 | Brand |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MPN |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BrandMPNType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BrandMPNType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Brand Property

Brand Property
Namespaces ► eBay.Service.Core.Soap ► BrandMPNType ► Brand
Declaration Syntax
C# Visual Basic Visual C++
public string Brand { get; set; }
Public Property Brand As String
    Get
    Set
public:
property String^ Brand {
    String^ get ();
    void set (String^ value);
}


BrandMPNType Constructor

BrandMPNType Constructor
Namespaces ► eBay.Service.Core.Soap ► BrandMPNType ► BrandMPNType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BrandMPNType()
Public Sub New
public:
BrandMPNType()


MPN Property

MPN Property
Namespaces ► eBay.Service.Core.Soap ► BrandMPNType ► MPN
Declaration Syntax
C# Visual Basic Visual C++
public string MPN { get; set; }
Public Property MPN As String
    Get
    Set
public:
property String^ MPN {
    String^ get ();
    void set (String^ value);
}


BusinessRoleType Enumeration

BusinessRoleType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BusinessRoleType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BusinessRoleType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BusinessRoleType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BusinessRoleType
Members
Member | Description
Shopper |
FullMarketPlaceParticipant |
Remarks


BusinessSellerDetailsType Class

BusinessSellerDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BusinessSellerDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BusinessSellerDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BusinessSellerDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BusinessSellerDetailsType()()()() |
 | AdditionalContactInformation |
 | Address |
 | Any |
 | Email |
 | Equals(Object) | (Inherited from Object.)
 | Fax |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LegalInvoice |
 | LegalInvoiceSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | TermsAndConditions |
 | ToString()()()() | (Inherited from Object.)
 | TradeRegistrationNumber |
 | VATDetails |
Remarks
Inheritance Hierarchy
Object
BusinessSellerDetailsType


AdditionalContactInformation Property

AdditionalContactInformation Property
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType ► AdditionalContactInformation
Declaration Syntax
C# Visual Basic Visual C++
public string AdditionalContactInformation { get; set; }
Public Property AdditionalContactInformation As String
    Get
    Set
public:
property String^ AdditionalContactInformation {
    String^ get ();
    void set (String^ value);
}


Address Property

Address Property
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType ► Address
Declaration Syntax
C# Visual Basic Visual C++
public AddressType Address { get; set; }
Public Property Address As AddressType
    Get
    Set
public:
property AddressType^ Address {
    AddressType^ get ();
    void set (AddressType^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BusinessSellerDetailsType Constructor

BusinessSellerDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType ► BusinessSellerDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BusinessSellerDetailsType()
Public Sub New
public:
BusinessSellerDetailsType()


Email Property

Email Property
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType ► Email
Declaration Syntax
C# Visual Basic Visual C++
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}


Fax Property

Fax Property
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType ► Fax
Declaration Syntax
C# Visual Basic Visual C++
public string Fax { get; set; }
Public Property Fax As String
    Get
    Set
public:
property String^ Fax {
    String^ get ();
    void set (String^ value);
}


LegalInvoice Property

LegalInvoice Property
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType ► LegalInvoice
Declaration Syntax
C# Visual Basic Visual C++
public bool LegalInvoice { get; set; }
Public Property LegalInvoice As Boolean
    Get
    Set
public:
property bool LegalInvoice {
    bool get ();
    void set (bool value);
}


LegalInvoiceSpecified Property

LegalInvoiceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType ► LegalInvoiceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LegalInvoiceSpecified { get; set; }
Public Property LegalInvoiceSpecified As Boolean
    Get
    Set
public:
property bool LegalInvoiceSpecified {
    bool get ();
    void set (bool value);
}


TermsAndConditions Property

TermsAndConditions Property
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType ► TermsAndConditions
Declaration Syntax
C# Visual Basic Visual C++
public string TermsAndConditions { get; set; }
Public Property TermsAndConditions As String
    Get
    Set
public:
property String^ TermsAndConditions {
    String^ get ();
    void set (String^ value);
}


TradeRegistrationNumber Property

TradeRegistrationNumber Property
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType ► TradeRegistrationNumber
Declaration Syntax
C# Visual Basic Visual C++
public string TradeRegistrationNumber { get; set; }
Public Property TradeRegistrationNumber As String
    Get
    Set
public:
property String^ TradeRegistrationNumber {
    String^ get ();
    void set (String^ value);
}


VATDetails Property

VATDetails Property
Namespaces ► eBay.Service.Core.Soap ► BusinessSellerDetailsType ► VATDetails
Declaration Syntax
C# Visual Basic Visual C++
public VATDetailsType VATDetails { get; set; }
Public Property VATDetails As VATDetailsType
    Get
    Set
public:
property VATDetailsType^ VATDetails {
    VATDetailsType^ get ();
    void set (VATDetailsType^ value);
}


BuyerGuaranteeEnabledDefinitionType Class

BuyerGuaranteeEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► BuyerGuaranteeEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BuyerGuaranteeEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BuyerGuaranteeEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BuyerGuaranteeEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuyerGuaranteeEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BuyerGuaranteeEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BuyerGuaranteeEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyerGuaranteeEnabledDefinitionType Constructor

BuyerGuaranteeEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerGuaranteeEnabledDefinitionType ► BuyerGuaranteeEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerGuaranteeEnabledDefinitionType()
Public Sub New
public:
BuyerGuaranteeEnabledDefinitionType()


BuyerPackageEnclosuresType Class

BuyerPackageEnclosuresType Class
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosuresType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BuyerPackageEnclosuresType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BuyerPackageEnclosuresType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BuyerPackageEnclosuresType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuyerPackageEnclosuresType()()()() |
 | Any |
 | BuyerPackageEnclosure |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BuyerPackageEnclosuresType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosuresType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyerPackageEnclosure Property

BuyerPackageEnclosure Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosuresType ► BuyerPackageEnclosure
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPackageEnclosureTypeCollection BuyerPackageEnclosure { get; set; }
Public Property BuyerPackageEnclosure As BuyerPackageEnclosureTypeCollection
    Get
    Set
public:
property BuyerPackageEnclosureTypeCollection^ BuyerPackageEnclosure {
    BuyerPackageEnclosureTypeCollection^ get ();
    void set (BuyerPackageEnclosureTypeCollection^ value);
}


BuyerPackageEnclosuresType Constructor

BuyerPackageEnclosuresType Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosuresType ► BuyerPackageEnclosuresType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPackageEnclosuresType()
Public Sub New
public:
BuyerPackageEnclosuresType()


BuyerPackageEnclosureType Class

BuyerPackageEnclosureType Class
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BuyerPackageEnclosureType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BuyerPackageEnclosureType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BuyerPackageEnclosureType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuyerPackageEnclosureType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | type |
 | typeSpecified |
 | Value |
Remarks
Inheritance Hierarchy
Object
BuyerPackageEnclosureType


BuyerPackageEnclosureType Constructor

BuyerPackageEnclosureType Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureType ► BuyerPackageEnclosureType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPackageEnclosureType()
Public Sub New
public:
BuyerPackageEnclosureType()


type Property

type Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureType ► type
Declaration Syntax
C# Visual Basic Visual C++
public PaymentInstructionCodeType type { get; set; }
Public Property type As PaymentInstructionCodeType
    Get
    Set
public:
property PaymentInstructionCodeType type {
    PaymentInstructionCodeType get ();
    void set (PaymentInstructionCodeType value);
}


typeSpecified Property

typeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureType ► typeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool typeSpecified { get; set; }
Public Property typeSpecified As Boolean
    Get
    Set
public:
property bool typeSpecified {
    bool get ();
    void set (bool value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


BuyerPackageEnclosureTypeCollection Class

BuyerPackageEnclosureTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class BuyerPackageEnclosureTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class BuyerPackageEnclosureTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class BuyerPackageEnclosureTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuyerPackageEnclosureTypeCollection()()()() |
 | BuyerPackageEnclosureTypeCollection(array<BuyerPackageEnclosureType>[]()[][]) |
 | BuyerPackageEnclosureTypeCollection(BuyerPackageEnclosureTypeCollection) |
 | Add(BuyerPackageEnclosureType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<BuyerPackageEnclosureType>[]()[][]) |
 | AddRange(BuyerPackageEnclosureTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(BuyerPackageEnclosureType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<BuyerPackageEnclosureType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(BuyerPackageEnclosureType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, BuyerPackageEnclosureType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(BuyerPackageEnclosureType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | BuyerPackageEnclosureTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► Add(BuyerPackageEnclosureType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    BuyerPackageEnclosureType item
)
Public Function Add ( _
    item As BuyerPackageEnclosureType _
) As Integer
public:
int Add(
    BuyerPackageEnclosureType^ item
)
Parameters
item (BuyerPackageEnclosureType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<BuyerPackageEnclosureType>[]()[][]) |
 | AddRange(BuyerPackageEnclosureTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► AddRange(array<BuyerPackageEnclosureType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    BuyerPackageEnclosureType[] items
)
Public Sub AddRange ( _
    items As BuyerPackageEnclosureType() _
)
public:
void AddRange(
    array<BuyerPackageEnclosureType^>^ items
)
Parameters
items (array< BuyerPackageEnclosureType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► AddRange(BuyerPackageEnclosureTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    BuyerPackageEnclosureTypeCollection items
)
Public Sub AddRange ( _
    items As BuyerPackageEnclosureTypeCollection _
)
public:
void AddRange(
    BuyerPackageEnclosureTypeCollection^ items
)
Parameters
items (BuyerPackageEnclosureTypeCollection)


BuyerPackageEnclosureTypeCollection Constructor

BuyerPackageEnclosureTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► BuyerPackageEnclosureTypeCollection()()()()
Members
Icon | Member | Description
 | BuyerPackageEnclosureTypeCollection()()()() |
 | BuyerPackageEnclosureTypeCollection(array<BuyerPackageEnclosureType>[]()[][]) |
 | BuyerPackageEnclosureTypeCollection(BuyerPackageEnclosureTypeCollection) |


BuyerPackageEnclosureTypeCollection Constructor

BuyerPackageEnclosureTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► BuyerPackageEnclosureTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPackageEnclosureTypeCollection()
Public Sub New
public:
BuyerPackageEnclosureTypeCollection()


BuyerPackageEnclosureTypeCollection Constructor (items)

BuyerPackageEnclosureTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► BuyerPackageEnclosureTypeCollection(array<BuyerPackageEnclosureType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPackageEnclosureTypeCollection(
    BuyerPackageEnclosureType[] items
)
Public Sub New ( _
    items As BuyerPackageEnclosureType() _
)
public:
BuyerPackageEnclosureTypeCollection(
    array<BuyerPackageEnclosureType^>^ items
)
Parameters
items (array< BuyerPackageEnclosureType >[]()[][])


BuyerPackageEnclosureTypeCollection Constructor (items)

BuyerPackageEnclosureTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► BuyerPackageEnclosureTypeCollection(BuyerPackageEnclosureTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPackageEnclosureTypeCollection(
    BuyerPackageEnclosureTypeCollection items
)
Public Sub New ( _
    items As BuyerPackageEnclosureTypeCollection _
)
public:
BuyerPackageEnclosureTypeCollection(
    BuyerPackageEnclosureTypeCollection^ items
)
Parameters
items (BuyerPackageEnclosureTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► Contains(BuyerPackageEnclosureType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    BuyerPackageEnclosureType item
)
Public Function Contains ( _
    item As BuyerPackageEnclosureType _
) As Boolean
public:
bool Contains(
    BuyerPackageEnclosureType^ item
)
Parameters
item (BuyerPackageEnclosureType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► CopyTo(array<BuyerPackageEnclosureType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    BuyerPackageEnclosureType[] items,
    int index
)
Public Sub CopyTo ( _
    items As BuyerPackageEnclosureType(), _
    index As Integer _
)
public:
void CopyTo(
    array<BuyerPackageEnclosureType^>^ items,
    int index
)
Parameters
items (array< BuyerPackageEnclosureType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► IndexOf(BuyerPackageEnclosureType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    BuyerPackageEnclosureType item
)
Public Function IndexOf ( _
    item As BuyerPackageEnclosureType _
) As Integer
public:
int IndexOf(
    BuyerPackageEnclosureType^ item
)
Parameters
item (BuyerPackageEnclosureType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► Insert(Int32, BuyerPackageEnclosureType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    BuyerPackageEnclosureType item
)
Public Sub Insert ( _
    index As Integer, _
    item As BuyerPackageEnclosureType _
)
public:
void Insert(
    int index,
    BuyerPackageEnclosureType^ item
)
Parameters
index (Int32)
item (BuyerPackageEnclosureType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPackageEnclosureType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As BuyerPackageEnclosureType
    Get
    Set
public:
property BuyerPackageEnclosureType^ default[int index] {
    BuyerPackageEnclosureType^ get (int index);
    void set (int index, BuyerPackageEnclosureType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPackageEnclosureType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As BuyerPackageEnclosureType
public:
BuyerPackageEnclosureType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► Remove(BuyerPackageEnclosureType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    BuyerPackageEnclosureType item
)
Public Sub Remove ( _
    item As BuyerPackageEnclosureType _
)
public:
void Remove(
    BuyerPackageEnclosureType^ item
)
Parameters
item (BuyerPackageEnclosureType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPackageEnclosureType[] ToArray()
Public Function ToArray As BuyerPackageEnclosureType()
public:
array<BuyerPackageEnclosureType^>^ ToArray()
Return Value


BuyerPaymentInstrumentCodeType Enumeration

BuyerPaymentInstrumentCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentInstrumentCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BuyerPaymentInstrumentCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BuyerPaymentInstrumentCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BuyerPaymentInstrumentCodeType
Members
Member | Description
None |
CreditCard |
BankDirectDebit |
PayPal |
ELV |
LocalPaymentCreditCardOther |
LocalPaymentELV |
LocalPaymentMasterCard |
LocalPaymentAMEX |
LocalPaymentVISA |
LocalPaymentDiscover |
LocalPaymentDinersclub |
LocalPaymentJCB |
LocalPaymentSWITCH |
LocalPaymentSOLO |
GIROPAY |
BML |
PayUponInvoice |
CustomCode |
Remarks


BuyerPaymentMethodCodeType Enumeration

BuyerPaymentMethodCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BuyerPaymentMethodCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BuyerPaymentMethodCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BuyerPaymentMethodCodeType
Members
Member | Description
None |
MOCC |
AmEx |
PaymentSeeDescription |
CCAccepted |
PersonalCheck |
COD |
VisaMC |
PaisaPayAccepted |
Other |
PayPal |
Discover |
CashOnPickup |
MoneyXferAccepted |
MoneyXferAcceptedInCheckout |
OtherOnlinePayments |
Escrow |
PrePayDelivery |
CODPrePayDelivery |
PostalTransfer |
CustomCode |
LoanCheck |
CashInPerson |
ELV |
PaisaPayEscrow |
PaisaPayEscrowEMI |
IntegratedMerchantCreditCard |
Moneybookers |
Paymate |
ProPay |
PayOnPickup |
Diners |
StandardPayment |
DirectDebit |
CreditCard |
PayUponInvoice |
QIWI |
PayPalCredit |
Remarks


BuyerPaymentMethodCodeTypeCollection Class

BuyerPaymentMethodCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class BuyerPaymentMethodCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class BuyerPaymentMethodCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class BuyerPaymentMethodCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuyerPaymentMethodCodeTypeCollection()()()() |
 | BuyerPaymentMethodCodeTypeCollection(array<BuyerPaymentMethodCodeType>[]()[][]) |
 | BuyerPaymentMethodCodeTypeCollection(BuyerPaymentMethodCodeTypeCollection) |
 | Add(BuyerPaymentMethodCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<BuyerPaymentMethodCodeType>[]()[][]) |
 | AddRange(BuyerPaymentMethodCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(BuyerPaymentMethodCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<BuyerPaymentMethodCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(BuyerPaymentMethodCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, BuyerPaymentMethodCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(BuyerPaymentMethodCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | BuyerPaymentMethodCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► Add(BuyerPaymentMethodCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    BuyerPaymentMethodCodeType item
)
Public Function Add ( _
    item As BuyerPaymentMethodCodeType _
) As Integer
public:
int Add(
    BuyerPaymentMethodCodeType item
)
Parameters
item (BuyerPaymentMethodCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<BuyerPaymentMethodCodeType>[]()[][]) |
 | AddRange(BuyerPaymentMethodCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► AddRange(array<BuyerPaymentMethodCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    BuyerPaymentMethodCodeType[] items
)
Public Sub AddRange ( _
    items As BuyerPaymentMethodCodeType() _
)
public:
void AddRange(
    array<BuyerPaymentMethodCodeType>^ items
)
Parameters
items (array< BuyerPaymentMethodCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► AddRange(BuyerPaymentMethodCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    BuyerPaymentMethodCodeTypeCollection items
)
Public Sub AddRange ( _
    items As BuyerPaymentMethodCodeTypeCollection _
)
public:
void AddRange(
    BuyerPaymentMethodCodeTypeCollection^ items
)
Parameters
items (BuyerPaymentMethodCodeTypeCollection)


BuyerPaymentMethodCodeTypeCollection Constructor

BuyerPaymentMethodCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► BuyerPaymentMethodCodeTypeCollection()()()()
Members
Icon | Member | Description
 | BuyerPaymentMethodCodeTypeCollection()()()() |
 | BuyerPaymentMethodCodeTypeCollection(array<BuyerPaymentMethodCodeType>[]()[][]) |
 | BuyerPaymentMethodCodeTypeCollection(BuyerPaymentMethodCodeTypeCollection) |


BuyerPaymentMethodCodeTypeCollection Constructor

BuyerPaymentMethodCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► BuyerPaymentMethodCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeTypeCollection()
Public Sub New
public:
BuyerPaymentMethodCodeTypeCollection()


BuyerPaymentMethodCodeTypeCollection Constructor (items)

BuyerPaymentMethodCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► BuyerPaymentMethodCodeTypeCollection(array<BuyerPaymentMethodCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeTypeCollection(
    BuyerPaymentMethodCodeType[] items
)
Public Sub New ( _
    items As BuyerPaymentMethodCodeType() _
)
public:
BuyerPaymentMethodCodeTypeCollection(
    array<BuyerPaymentMethodCodeType>^ items
)
Parameters
items (array< BuyerPaymentMethodCodeType >[]()[][])


BuyerPaymentMethodCodeTypeCollection Constructor (items)

BuyerPaymentMethodCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► BuyerPaymentMethodCodeTypeCollection(BuyerPaymentMethodCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeTypeCollection(
    BuyerPaymentMethodCodeTypeCollection items
)
Public Sub New ( _
    items As BuyerPaymentMethodCodeTypeCollection _
)
public:
BuyerPaymentMethodCodeTypeCollection(
    BuyerPaymentMethodCodeTypeCollection^ items
)
Parameters
items (BuyerPaymentMethodCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► Contains(BuyerPaymentMethodCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    BuyerPaymentMethodCodeType item
)
Public Function Contains ( _
    item As BuyerPaymentMethodCodeType _
) As Boolean
public:
bool Contains(
    BuyerPaymentMethodCodeType item
)
Parameters
item (BuyerPaymentMethodCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► CopyTo(array<BuyerPaymentMethodCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    BuyerPaymentMethodCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As BuyerPaymentMethodCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<BuyerPaymentMethodCodeType>^ items,
    int index
)
Parameters
items (array< BuyerPaymentMethodCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► IndexOf(BuyerPaymentMethodCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    BuyerPaymentMethodCodeType item
)
Public Function IndexOf ( _
    item As BuyerPaymentMethodCodeType _
) As Integer
public:
int IndexOf(
    BuyerPaymentMethodCodeType item
)
Parameters
item (BuyerPaymentMethodCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► Insert(Int32, BuyerPaymentMethodCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    BuyerPaymentMethodCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As BuyerPaymentMethodCodeType _
)
public:
void Insert(
    int index,
    BuyerPaymentMethodCodeType item
)
Parameters
index (Int32)
item (BuyerPaymentMethodCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As BuyerPaymentMethodCodeType
    Get
    Set
public:
property BuyerPaymentMethodCodeType default[int index] {
    BuyerPaymentMethodCodeType get (int index);
    void set (int index, BuyerPaymentMethodCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As BuyerPaymentMethodCodeType
public:
BuyerPaymentMethodCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► Remove(BuyerPaymentMethodCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    BuyerPaymentMethodCodeType item
)
Public Sub Remove ( _
    item As BuyerPaymentMethodCodeType _
)
public:
void Remove(
    BuyerPaymentMethodCodeType item
)
Parameters
item (BuyerPaymentMethodCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeType[] ToArray()
Public Function ToArray As BuyerPaymentMethodCodeType()
public:
array<BuyerPaymentMethodCodeType>^ ToArray()
Return Value


BuyerProtectionCodeType Enumeration

BuyerProtectionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BuyerProtectionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BuyerProtectionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BuyerProtectionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BuyerProtectionCodeType
Members
Member | Description
ItemIneligible |
ItemEligible |
ItemMarkedIneligible |
ItemMarkedEligible |
NoCoverage |
CustomCode |
Remarks


BuyerProtectionDetailsType Class

BuyerProtectionDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► BuyerProtectionDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BuyerProtectionDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BuyerProtectionDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BuyerProtectionDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuyerProtectionDetailsType()()()() |
 | Any |
 | BuyerProtectionSource |
 | BuyerProtectionSourceSpecified |
 | BuyerProtectionStatus |
 | BuyerProtectionStatusSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BuyerProtectionDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BuyerProtectionDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyerProtectionDetailsType Constructor

BuyerProtectionDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerProtectionDetailsType ► BuyerProtectionDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerProtectionDetailsType()
Public Sub New
public:
BuyerProtectionDetailsType()


BuyerProtectionSource Property

BuyerProtectionSource Property
Namespaces ► eBay.Service.Core.Soap ► BuyerProtectionDetailsType ► BuyerProtectionSource
Declaration Syntax
C# Visual Basic Visual C++
public BuyerProtectionSourceCodeType BuyerProtectionSource { get; set; }
Public Property BuyerProtectionSource As BuyerProtectionSourceCodeType
    Get
    Set
public:
property BuyerProtectionSourceCodeType BuyerProtectionSource {
    BuyerProtectionSourceCodeType get ();
    void set (BuyerProtectionSourceCodeType value);
}


BuyerProtectionSourceSpecified Property

BuyerProtectionSourceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerProtectionDetailsType ► BuyerProtectionSourceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerProtectionSourceSpecified { get; set; }
Public Property BuyerProtectionSourceSpecified As Boolean
    Get
    Set
public:
property bool BuyerProtectionSourceSpecified {
    bool get ();
    void set (bool value);
}


BuyerProtectionStatus Property

BuyerProtectionStatus Property
Namespaces ► eBay.Service.Core.Soap ► BuyerProtectionDetailsType ► BuyerProtectionStatus
Declaration Syntax
C# Visual Basic Visual C++
public BuyerProtectionCodeType BuyerProtectionStatus { get; set; }
Public Property BuyerProtectionStatus As BuyerProtectionCodeType
    Get
    Set
public:
property BuyerProtectionCodeType BuyerProtectionStatus {
    BuyerProtectionCodeType get ();
    void set (BuyerProtectionCodeType value);
}


BuyerProtectionStatusSpecified Property

BuyerProtectionStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerProtectionDetailsType ► BuyerProtectionStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerProtectionStatusSpecified { get; set; }
Public Property BuyerProtectionStatusSpecified As Boolean
    Get
    Set
public:
property bool BuyerProtectionStatusSpecified {
    bool get ();
    void set (bool value);
}


BuyerProtectionSourceCodeType Enumeration

BuyerProtectionSourceCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BuyerProtectionSourceCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BuyerProtectionSourceCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BuyerProtectionSourceCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BuyerProtectionSourceCodeType
Members
Member | Description
eBay |
PayPal |
CustomCode |
Remarks


BuyerRequirementDetailsType Class

BuyerRequirementDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BuyerRequirementDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BuyerRequirementDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BuyerRequirementDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuyerRequirementDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LinkedPayPalAccount |
 | LinkedPayPalAccountSpecified |
 | MaximumBuyerPolicyViolations |
 | MaximumItemRequirements |
 | MaximumUnpaidItemStrikesInfo |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumFeedbackScore |
 | MinimumFeedbackScoreSpecified |
 | ShipToRegistrationCountry |
 | ShipToRegistrationCountrySpecified |
 | ToString()()()() | (Inherited from Object.)
 | VerifiedUserRequirements |
 | ZeroFeedbackScore |
 | ZeroFeedbackScoreSpecified |
Remarks
Inheritance Hierarchy
Object
BuyerRequirementDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyerRequirementDetailsType Constructor

BuyerRequirementDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► BuyerRequirementDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerRequirementDetailsType()
Public Sub New
public:
BuyerRequirementDetailsType()


LinkedPayPalAccount Property

LinkedPayPalAccount Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► LinkedPayPalAccount
Declaration Syntax
C# Visual Basic Visual C++
public bool LinkedPayPalAccount { get; set; }
Public Property LinkedPayPalAccount As Boolean
    Get
    Set
public:
property bool LinkedPayPalAccount {
    bool get ();
    void set (bool value);
}


LinkedPayPalAccountSpecified Property

LinkedPayPalAccountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► LinkedPayPalAccountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LinkedPayPalAccountSpecified { get; set; }
Public Property LinkedPayPalAccountSpecified As Boolean
    Get
    Set
public:
property bool LinkedPayPalAccountSpecified {
    bool get ();
    void set (bool value);
}


MaximumBuyerPolicyViolations Property

MaximumBuyerPolicyViolations Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► MaximumBuyerPolicyViolations
Declaration Syntax
C# Visual Basic Visual C++
public MaximumBuyerPolicyViolationsType MaximumBuyerPolicyViolations { get; set; }
Public Property MaximumBuyerPolicyViolations As MaximumBuyerPolicyViolationsType
    Get
    Set
public:
property MaximumBuyerPolicyViolationsType^ MaximumBuyerPolicyViolations {
    MaximumBuyerPolicyViolationsType^ get ();
    void set (MaximumBuyerPolicyViolationsType^ value);
}


MaximumItemRequirements Property

MaximumItemRequirements Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► MaximumItemRequirements
Declaration Syntax
C# Visual Basic Visual C++
public MaximumItemRequirementsType MaximumItemRequirements { get; set; }
Public Property MaximumItemRequirements As MaximumItemRequirementsType
    Get
    Set
public:
property MaximumItemRequirementsType^ MaximumItemRequirements {
    MaximumItemRequirementsType^ get ();
    void set (MaximumItemRequirementsType^ value);
}


MaximumUnpaidItemStrikesInfo Property

MaximumUnpaidItemStrikesInfo Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► MaximumUnpaidItemStrikesInfo
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesInfoType MaximumUnpaidItemStrikesInfo { get; set; }
Public Property MaximumUnpaidItemStrikesInfo As MaximumUnpaidItemStrikesInfoType
    Get
    Set
public:
property MaximumUnpaidItemStrikesInfoType^ MaximumUnpaidItemStrikesInfo {
    MaximumUnpaidItemStrikesInfoType^ get ();
    void set (MaximumUnpaidItemStrikesInfoType^ value);
}


MinimumFeedbackScore Property

MinimumFeedbackScore Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► MinimumFeedbackScore
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumFeedbackScore { get; set; }
Public Property MinimumFeedbackScore As Integer
    Get
    Set
public:
property int MinimumFeedbackScore {
    int get ();
    void set (int value);
}


MinimumFeedbackScoreSpecified Property

MinimumFeedbackScoreSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► MinimumFeedbackScoreSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinimumFeedbackScoreSpecified { get; set; }
Public Property MinimumFeedbackScoreSpecified As Boolean
    Get
    Set
public:
property bool MinimumFeedbackScoreSpecified {
    bool get ();
    void set (bool value);
}


ShipToRegistrationCountry Property

ShipToRegistrationCountry Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► ShipToRegistrationCountry
Declaration Syntax
C# Visual Basic Visual C++
public bool ShipToRegistrationCountry { get; set; }
Public Property ShipToRegistrationCountry As Boolean
    Get
    Set
public:
property bool ShipToRegistrationCountry {
    bool get ();
    void set (bool value);
}


ShipToRegistrationCountrySpecified Property

ShipToRegistrationCountrySpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► ShipToRegistrationCountrySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShipToRegistrationCountrySpecified { get; set; }
Public Property ShipToRegistrationCountrySpecified As Boolean
    Get
    Set
public:
property bool ShipToRegistrationCountrySpecified {
    bool get ();
    void set (bool value);
}


VerifiedUserRequirements Property

VerifiedUserRequirements Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► VerifiedUserRequirements
Declaration Syntax
C# Visual Basic Visual C++
public VerifiedUserRequirementsType VerifiedUserRequirements { get; set; }
Public Property VerifiedUserRequirements As VerifiedUserRequirementsType
    Get
    Set
public:
property VerifiedUserRequirementsType^ VerifiedUserRequirements {
    VerifiedUserRequirementsType^ get ();
    void set (VerifiedUserRequirementsType^ value);
}


ZeroFeedbackScore Property

ZeroFeedbackScore Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► ZeroFeedbackScore
Declaration Syntax
C# Visual Basic Visual C++
public bool ZeroFeedbackScore { get; set; }
Public Property ZeroFeedbackScore As Boolean
    Get
    Set
public:
property bool ZeroFeedbackScore {
    bool get ();
    void set (bool value);
}


ZeroFeedbackScoreSpecified Property

ZeroFeedbackScoreSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRequirementDetailsType ► ZeroFeedbackScoreSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ZeroFeedbackScoreSpecified { get; set; }
Public Property ZeroFeedbackScoreSpecified As Boolean
    Get
    Set
public:
property bool ZeroFeedbackScoreSpecified {
    bool get ();
    void set (bool value);
}


BuyerRoleMetricsType Class

BuyerRoleMetricsType Class
Namespaces ► eBay.Service.Core.Soap ► BuyerRoleMetricsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BuyerRoleMetricsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BuyerRoleMetricsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BuyerRoleMetricsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuyerRoleMetricsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | FeedbackLeftPercent |
 | FeedbackLeftPercentSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NegativeFeedbackLeftCount |
 | NegativeFeedbackLeftCountSpecified |
 | NeutralFeedbackLeftCount |
 | NeutralFeedbackLeftCountSpecified |
 | PositiveFeedbackLeftCount |
 | PositiveFeedbackLeftCountSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BuyerRoleMetricsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRoleMetricsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyerRoleMetricsType Constructor

BuyerRoleMetricsType Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerRoleMetricsType ► BuyerRoleMetricsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerRoleMetricsType()
Public Sub New
public:
BuyerRoleMetricsType()


FeedbackLeftPercent Property

FeedbackLeftPercent Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRoleMetricsType ► FeedbackLeftPercent
Declaration Syntax
C# Visual Basic Visual C++
public float FeedbackLeftPercent { get; set; }
Public Property FeedbackLeftPercent As Single
    Get
    Set
public:
property float FeedbackLeftPercent {
    float get ();
    void set (float value);
}


FeedbackLeftPercentSpecified Property

FeedbackLeftPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRoleMetricsType ► FeedbackLeftPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackLeftPercentSpecified { get; set; }
Public Property FeedbackLeftPercentSpecified As Boolean
    Get
    Set
public:
property bool FeedbackLeftPercentSpecified {
    bool get ();
    void set (bool value);
}


NegativeFeedbackLeftCount Property

NegativeFeedbackLeftCount Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRoleMetricsType ► NegativeFeedbackLeftCount
Declaration Syntax
C# Visual Basic Visual C++
public int NegativeFeedbackLeftCount { get; set; }
Public Property NegativeFeedbackLeftCount As Integer
    Get
    Set
public:
property int NegativeFeedbackLeftCount {
    int get ();
    void set (int value);
}


NegativeFeedbackLeftCountSpecified Property

NegativeFeedbackLeftCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRoleMetricsType ► NegativeFeedbackLeftCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NegativeFeedbackLeftCountSpecified { get; set; }
Public Property NegativeFeedbackLeftCountSpecified As Boolean
    Get
    Set
public:
property bool NegativeFeedbackLeftCountSpecified {
    bool get ();
    void set (bool value);
}


NeutralFeedbackLeftCount Property

NeutralFeedbackLeftCount Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRoleMetricsType ► NeutralFeedbackLeftCount
Declaration Syntax
C# Visual Basic Visual C++
public int NeutralFeedbackLeftCount { get; set; }
Public Property NeutralFeedbackLeftCount As Integer
    Get
    Set
public:
property int NeutralFeedbackLeftCount {
    int get ();
    void set (int value);
}


NeutralFeedbackLeftCountSpecified Property

NeutralFeedbackLeftCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRoleMetricsType ► NeutralFeedbackLeftCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NeutralFeedbackLeftCountSpecified { get; set; }
Public Property NeutralFeedbackLeftCountSpecified As Boolean
    Get
    Set
public:
property bool NeutralFeedbackLeftCountSpecified {
    bool get ();
    void set (bool value);
}


PositiveFeedbackLeftCount Property

PositiveFeedbackLeftCount Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRoleMetricsType ► PositiveFeedbackLeftCount
Declaration Syntax
C# Visual Basic Visual C++
public int PositiveFeedbackLeftCount { get; set; }
Public Property PositiveFeedbackLeftCount As Integer
    Get
    Set
public:
property int PositiveFeedbackLeftCount {
    int get ();
    void set (int value);
}


PositiveFeedbackLeftCountSpecified Property

PositiveFeedbackLeftCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerRoleMetricsType ► PositiveFeedbackLeftCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PositiveFeedbackLeftCountSpecified { get; set; }
Public Property PositiveFeedbackLeftCountSpecified As Boolean
    Get
    Set
public:
property bool PositiveFeedbackLeftCountSpecified {
    bool get ();
    void set (bool value);
}


BuyerSatisfactionDashboardType Class

BuyerSatisfactionDashboardType Class
Namespaces ► eBay.Service.Core.Soap ► BuyerSatisfactionDashboardType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BuyerSatisfactionDashboardType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BuyerSatisfactionDashboardType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BuyerSatisfactionDashboardType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuyerSatisfactionDashboardType()()()() |
 | Alert |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BuyerSatisfactionDashboardType


Alert Property

Alert Property
Namespaces ► eBay.Service.Core.Soap ► BuyerSatisfactionDashboardType ► Alert
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertTypeCollection Alert { get; set; }
Public Property Alert As SellerDashboardAlertTypeCollection
    Get
    Set
public:
property SellerDashboardAlertTypeCollection^ Alert {
    SellerDashboardAlertTypeCollection^ get ();
    void set (SellerDashboardAlertTypeCollection^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BuyerSatisfactionDashboardType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyerSatisfactionDashboardType Constructor

BuyerSatisfactionDashboardType Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerSatisfactionDashboardType ► BuyerSatisfactionDashboardType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerSatisfactionDashboardType()
Public Sub New
public:
BuyerSatisfactionDashboardType()


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► BuyerSatisfactionDashboardType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public BuyerSatisfactionStatusCodeType Status { get; set; }
Public Property Status As BuyerSatisfactionStatusCodeType
    Get
    Set
public:
property BuyerSatisfactionStatusCodeType Status {
    BuyerSatisfactionStatusCodeType get ();
    void set (BuyerSatisfactionStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyerSatisfactionDashboardType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


BuyerSatisfactionStatusCodeType Enumeration

BuyerSatisfactionStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► BuyerSatisfactionStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum BuyerSatisfactionStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration BuyerSatisfactionStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class BuyerSatisfactionStatusCodeType
Members
Member | Description
Excellent |
Good |
NeedsWork |
Poor |
VeryPoor |
Unacceptable |
CustomCode |
Remarks


BuyerType Class

BuyerType Class
Namespaces ► eBay.Service.Core.Soap ► BuyerType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BuyerType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BuyerType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BuyerType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuyerType()()()() |
 | Any |
 | BuyerTaxIdentifier |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingAddress |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
BuyerType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► BuyerType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyerTaxIdentifier Property

BuyerTaxIdentifier Property
Namespaces ► eBay.Service.Core.Soap ► BuyerType ► BuyerTaxIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierTypeCollection BuyerTaxIdentifier { get; set; }
Public Property BuyerTaxIdentifier As TaxIdentifierTypeCollection
    Get
    Set
public:
property TaxIdentifierTypeCollection^ BuyerTaxIdentifier {
    TaxIdentifierTypeCollection^ get ();
    void set (TaxIdentifierTypeCollection^ value);
}


BuyerType Constructor

BuyerType Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyerType ► BuyerType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyerType()
Public Sub New
public:
BuyerType()


ShippingAddress Property

ShippingAddress Property
Namespaces ► eBay.Service.Core.Soap ► BuyerType ► ShippingAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType ShippingAddress { get; set; }
Public Property ShippingAddress As AddressType
    Get
    Set
public:
property AddressType^ ShippingAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


BuyingSummaryType Class

BuyingSummaryType Class
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class BuyingSummaryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class BuyingSummaryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class BuyingSummaryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuyingSummaryType()()()() |
 | BestOfferCount |
 | BestOfferCountSpecified |
 | BiddingCount |
 | BiddingCountSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TotalWinningCost |
 | TotalWonCost |
 | WinningCount |
 | WinningCountSpecified |
 | WonCount |
 | WonCountSpecified |
 | WonDurationInDays |
 | WonDurationInDaysSpecified |
Remarks
Inheritance Hierarchy
Object
BuyingSummaryType


BestOfferCount Property

BestOfferCount Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► BestOfferCount
Declaration Syntax
C# Visual Basic Visual C++
public int BestOfferCount { get; set; }
Public Property BestOfferCount As Integer
    Get
    Set
public:
property int BestOfferCount {
    int get ();
    void set (int value);
}


BestOfferCountSpecified Property

BestOfferCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► BestOfferCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferCountSpecified { get; set; }
Public Property BestOfferCountSpecified As Boolean
    Get
    Set
public:
property bool BestOfferCountSpecified {
    bool get ();
    void set (bool value);
}


BiddingCount Property

BiddingCount Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► BiddingCount
Declaration Syntax
C# Visual Basic Visual C++
public int BiddingCount { get; set; }
Public Property BiddingCount As Integer
    Get
    Set
public:
property int BiddingCount {
    int get ();
    void set (int value);
}


BiddingCountSpecified Property

BiddingCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► BiddingCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BiddingCountSpecified { get; set; }
Public Property BiddingCountSpecified As Boolean
    Get
    Set
public:
property bool BiddingCountSpecified {
    bool get ();
    void set (bool value);
}


BuyingSummaryType Constructor

BuyingSummaryType Constructor
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► BuyingSummaryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public BuyingSummaryType()
Public Sub New
public:
BuyingSummaryType()


TotalWinningCost Property

TotalWinningCost Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► TotalWinningCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalWinningCost { get; set; }
Public Property TotalWinningCost As AmountType
    Get
    Set
public:
property AmountType^ TotalWinningCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


TotalWonCost Property

TotalWonCost Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► TotalWonCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalWonCost { get; set; }
Public Property TotalWonCost As AmountType
    Get
    Set
public:
property AmountType^ TotalWonCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


WinningCount Property

WinningCount Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► WinningCount
Declaration Syntax
C# Visual Basic Visual C++
public int WinningCount { get; set; }
Public Property WinningCount As Integer
    Get
    Set
public:
property int WinningCount {
    int get ();
    void set (int value);
}


WinningCountSpecified Property

WinningCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► WinningCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WinningCountSpecified { get; set; }
Public Property WinningCountSpecified As Boolean
    Get
    Set
public:
property bool WinningCountSpecified {
    bool get ();
    void set (bool value);
}


WonCount Property

WonCount Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► WonCount
Declaration Syntax
C# Visual Basic Visual C++
public int WonCount { get; set; }
Public Property WonCount As Integer
    Get
    Set
public:
property int WonCount {
    int get ();
    void set (int value);
}


WonCountSpecified Property

WonCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► WonCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WonCountSpecified { get; set; }
Public Property WonCountSpecified As Boolean
    Get
    Set
public:
property bool WonCountSpecified {
    bool get ();
    void set (bool value);
}


WonDurationInDays Property

WonDurationInDays Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► WonDurationInDays
Declaration Syntax
C# Visual Basic Visual C++
public int WonDurationInDays { get; set; }
Public Property WonDurationInDays As Integer
    Get
    Set
public:
property int WonDurationInDays {
    int get ();
    void set (int value);
}


WonDurationInDaysSpecified Property

WonDurationInDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► BuyingSummaryType ► WonDurationInDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WonDurationInDaysSpecified { get; set; }
Public Property WonDurationInDaysSpecified As Boolean
    Get
    Set
public:
property bool WonDurationInDaysSpecified {
    bool get ();
    void set (bool value);
}


CalculatedHandlingDiscountType Class

CalculatedHandlingDiscountType Class
Namespaces ► eBay.Service.Core.Soap ► CalculatedHandlingDiscountType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CalculatedHandlingDiscountType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CalculatedHandlingDiscountType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CalculatedHandlingDiscountType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CalculatedHandlingDiscountType()()()() |
 | Any |
 | DiscountName |
 | DiscountNameSpecified |
 | EachAdditionalAmount |
 | EachAdditionalOffAmount |
 | EachAdditionalPercentOff |
 | EachAdditionalPercentOffSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderHandlingAmount |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CalculatedHandlingDiscountType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedHandlingDiscountType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CalculatedHandlingDiscountType Constructor

CalculatedHandlingDiscountType Constructor
Namespaces ► eBay.Service.Core.Soap ► CalculatedHandlingDiscountType ► CalculatedHandlingDiscountType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedHandlingDiscountType()
Public Sub New
public:
CalculatedHandlingDiscountType()


DiscountName Property

DiscountName Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedHandlingDiscountType ► DiscountName
Declaration Syntax
C# Visual Basic Visual C++
public HandlingNameCodeType DiscountName { get; set; }
Public Property DiscountName As HandlingNameCodeType
    Get
    Set
public:
property HandlingNameCodeType DiscountName {
    HandlingNameCodeType get ();
    void set (HandlingNameCodeType value);
}


DiscountNameSpecified Property

DiscountNameSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedHandlingDiscountType ► DiscountNameSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DiscountNameSpecified { get; set; }
Public Property DiscountNameSpecified As Boolean
    Get
    Set
public:
property bool DiscountNameSpecified {
    bool get ();
    void set (bool value);
}


EachAdditionalAmount Property

EachAdditionalAmount Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedHandlingDiscountType ► EachAdditionalAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType EachAdditionalAmount { get; set; }
Public Property EachAdditionalAmount As AmountType
    Get
    Set
public:
property AmountType^ EachAdditionalAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


EachAdditionalOffAmount Property

EachAdditionalOffAmount Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedHandlingDiscountType ► EachAdditionalOffAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType EachAdditionalOffAmount { get; set; }
Public Property EachAdditionalOffAmount As AmountType
    Get
    Set
public:
property AmountType^ EachAdditionalOffAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


EachAdditionalPercentOff Property

EachAdditionalPercentOff Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedHandlingDiscountType ► EachAdditionalPercentOff
Declaration Syntax
C# Visual Basic Visual C++
public float EachAdditionalPercentOff { get; set; }
Public Property EachAdditionalPercentOff As Single
    Get
    Set
public:
property float EachAdditionalPercentOff {
    float get ();
    void set (float value);
}


EachAdditionalPercentOffSpecified Property

EachAdditionalPercentOffSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedHandlingDiscountType ► EachAdditionalPercentOffSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EachAdditionalPercentOffSpecified { get; set; }
Public Property EachAdditionalPercentOffSpecified As Boolean
    Get
    Set
public:
property bool EachAdditionalPercentOffSpecified {
    bool get ();
    void set (bool value);
}


OrderHandlingAmount Property

OrderHandlingAmount Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedHandlingDiscountType ► OrderHandlingAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType OrderHandlingAmount { get; set; }
Public Property OrderHandlingAmount As AmountType
    Get
    Set
public:
property AmountType^ OrderHandlingAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


CalculatedShippingChargeOptionCodeType Enumeration

CalculatedShippingChargeOptionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingChargeOptionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CalculatedShippingChargeOptionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CalculatedShippingChargeOptionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CalculatedShippingChargeOptionCodeType
Members
Member | Description
ChargeEachItem |
ChargeEntireOrder |
CustomCode |
Remarks


CalculatedShippingDiscountType Class

CalculatedShippingDiscountType Class
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingDiscountType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CalculatedShippingDiscountType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CalculatedShippingDiscountType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CalculatedShippingDiscountType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CalculatedShippingDiscountType()()()() |
 | Any |
 | DiscountName |
 | DiscountNameSpecified |
 | DiscountProfile |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CalculatedShippingDiscountType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingDiscountType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CalculatedShippingDiscountType Constructor

CalculatedShippingDiscountType Constructor
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingDiscountType ► CalculatedShippingDiscountType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingDiscountType()
Public Sub New
public:
CalculatedShippingDiscountType()


DiscountName Property

DiscountName Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingDiscountType ► DiscountName
Declaration Syntax
C# Visual Basic Visual C++
public DiscountNameCodeType DiscountName { get; set; }
Public Property DiscountName As DiscountNameCodeType
    Get
    Set
public:
property DiscountNameCodeType DiscountName {
    DiscountNameCodeType get ();
    void set (DiscountNameCodeType value);
}


DiscountNameSpecified Property

DiscountNameSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingDiscountType ► DiscountNameSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DiscountNameSpecified { get; set; }
Public Property DiscountNameSpecified As Boolean
    Get
    Set
public:
property bool DiscountNameSpecified {
    bool get ();
    void set (bool value);
}


DiscountProfile Property

DiscountProfile Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingDiscountType ► DiscountProfile
Declaration Syntax
C# Visual Basic Visual C++
public DiscountProfileTypeCollection DiscountProfile { get; set; }
Public Property DiscountProfile As DiscountProfileTypeCollection
    Get
    Set
public:
property DiscountProfileTypeCollection^ DiscountProfile {
    DiscountProfileTypeCollection^ get ();
    void set (DiscountProfileTypeCollection^ value);
}


CalculatedShippingPreferencesType Class

CalculatedShippingPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CalculatedShippingPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CalculatedShippingPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CalculatedShippingPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CalculatedShippingPreferencesType()()()() |
 | Any |
 | CalculatedShippingAmountForEntireOrder |
 | CalculatedShippingChargeOption |
 | CalculatedShippingChargeOptionSpecified |
 | CalculatedShippingRateOption |
 | CalculatedShippingRateOptionSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InsuranceOption |
 | InsuranceOptionSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CalculatedShippingPreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CalculatedShippingAmountForEntireOrder Property

CalculatedShippingAmountForEntireOrder Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingPreferencesType ► CalculatedShippingAmountForEntireOrder
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CalculatedShippingAmountForEntireOrder { get; set; }
Public Property CalculatedShippingAmountForEntireOrder As AmountType
    Get
    Set
public:
property AmountType^ CalculatedShippingAmountForEntireOrder {
    AmountType^ get ();
    void set (AmountType^ value);
}


CalculatedShippingChargeOption Property

CalculatedShippingChargeOption Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingPreferencesType ► CalculatedShippingChargeOption
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingChargeOptionCodeType CalculatedShippingChargeOption { get; set; }
Public Property CalculatedShippingChargeOption As CalculatedShippingChargeOptionCodeType
    Get
    Set
public:
property CalculatedShippingChargeOptionCodeType CalculatedShippingChargeOption {
    CalculatedShippingChargeOptionCodeType get ();
    void set (CalculatedShippingChargeOptionCodeType value);
}


CalculatedShippingChargeOptionSpecified Property

CalculatedShippingChargeOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingPreferencesType ► CalculatedShippingChargeOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CalculatedShippingChargeOptionSpecified { get; set; }
Public Property CalculatedShippingChargeOptionSpecified As Boolean
    Get
    Set
public:
property bool CalculatedShippingChargeOptionSpecified {
    bool get ();
    void set (bool value);
}


CalculatedShippingPreferencesType Constructor

CalculatedShippingPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingPreferencesType ► CalculatedShippingPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingPreferencesType()
Public Sub New
public:
CalculatedShippingPreferencesType()


CalculatedShippingRateOption Property

CalculatedShippingRateOption Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingPreferencesType ► CalculatedShippingRateOption
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingRateOptionCodeType CalculatedShippingRateOption { get; set; }
Public Property CalculatedShippingRateOption As CalculatedShippingRateOptionCodeType
    Get
    Set
public:
property CalculatedShippingRateOptionCodeType CalculatedShippingRateOption {
    CalculatedShippingRateOptionCodeType get ();
    void set (CalculatedShippingRateOptionCodeType value);
}


CalculatedShippingRateOptionSpecified Property

CalculatedShippingRateOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingPreferencesType ► CalculatedShippingRateOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CalculatedShippingRateOptionSpecified { get; set; }
Public Property CalculatedShippingRateOptionSpecified As Boolean
    Get
    Set
public:
property bool CalculatedShippingRateOptionSpecified {
    bool get ();
    void set (bool value);
}


InsuranceOption Property

InsuranceOption Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingPreferencesType ► InsuranceOption
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceOptionCodeType InsuranceOption { get; set; }
Public Property InsuranceOption As InsuranceOptionCodeType
    Get
    Set
public:
property InsuranceOptionCodeType InsuranceOption {
    InsuranceOptionCodeType get ();
    void set (InsuranceOptionCodeType value);
}


InsuranceOptionSpecified Property

InsuranceOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingPreferencesType ► InsuranceOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InsuranceOptionSpecified { get; set; }
Public Property InsuranceOptionSpecified As Boolean
    Get
    Set
public:
property bool InsuranceOptionSpecified {
    bool get ();
    void set (bool value);
}


CalculatedShippingRateOptionCodeType Enumeration

CalculatedShippingRateOptionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateOptionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CalculatedShippingRateOptionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CalculatedShippingRateOptionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CalculatedShippingRateOptionCodeType
Members
Member | Description
CombinedItemWeight |
IndividualItemWeight |
CustomCode |
Remarks


CalculatedShippingRateType Class

CalculatedShippingRateType Class
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CalculatedShippingRateType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CalculatedShippingRateType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CalculatedShippingRateType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CalculatedShippingRateType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InternationalPackagingHandlingCosts |
 | MeasurementUnit |
 | MeasurementUnitSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OriginatingPostalCode |
 | PackageDepth |
 | PackageLength |
 | PackageWidth |
 | PackagingHandlingCosts |
 | ShippingIrregular |
 | ShippingIrregularSpecified |
 | ShippingPackage |
 | ShippingPackageSpecified |
 | ToString()()()() | (Inherited from Object.)
 | WeightMajor |
 | WeightMinor |
Remarks
Inheritance Hierarchy
Object
CalculatedShippingRateType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CalculatedShippingRateType Constructor

CalculatedShippingRateType Constructor
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► CalculatedShippingRateType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingRateType()
Public Sub New
public:
CalculatedShippingRateType()


InternationalPackagingHandlingCosts Property

InternationalPackagingHandlingCosts Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► InternationalPackagingHandlingCosts
Declaration Syntax
C# Visual Basic Visual C++
public AmountType InternationalPackagingHandlingCosts { get; set; }
Public Property InternationalPackagingHandlingCosts As AmountType
    Get
    Set
public:
property AmountType^ InternationalPackagingHandlingCosts {
    AmountType^ get ();
    void set (AmountType^ value);
}


MeasurementUnit Property

MeasurementUnit Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► MeasurementUnit
Declaration Syntax
C# Visual Basic Visual C++
public MeasurementSystemCodeType MeasurementUnit { get; set; }
Public Property MeasurementUnit As MeasurementSystemCodeType
    Get
    Set
public:
property MeasurementSystemCodeType MeasurementUnit {
    MeasurementSystemCodeType get ();
    void set (MeasurementSystemCodeType value);
}


MeasurementUnitSpecified Property

MeasurementUnitSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► MeasurementUnitSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MeasurementUnitSpecified { get; set; }
Public Property MeasurementUnitSpecified As Boolean
    Get
    Set
public:
property bool MeasurementUnitSpecified {
    bool get ();
    void set (bool value);
}


OriginatingPostalCode Property

OriginatingPostalCode Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► OriginatingPostalCode
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingPostalCode { get; set; }
Public Property OriginatingPostalCode As String
    Get
    Set
public:
property String^ OriginatingPostalCode {
    String^ get ();
    void set (String^ value);
}


PackageDepth Property

PackageDepth Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► PackageDepth
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType PackageDepth { get; set; }
Public Property PackageDepth As MeasureType
    Get
    Set
public:
property MeasureType^ PackageDepth {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


PackageLength Property

PackageLength Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► PackageLength
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType PackageLength { get; set; }
Public Property PackageLength As MeasureType
    Get
    Set
public:
property MeasureType^ PackageLength {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


PackageWidth Property

PackageWidth Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► PackageWidth
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType PackageWidth { get; set; }
Public Property PackageWidth As MeasureType
    Get
    Set
public:
property MeasureType^ PackageWidth {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


PackagingHandlingCosts Property

PackagingHandlingCosts Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► PackagingHandlingCosts
Declaration Syntax
C# Visual Basic Visual C++
public AmountType PackagingHandlingCosts { get; set; }
Public Property PackagingHandlingCosts As AmountType
    Get
    Set
public:
property AmountType^ PackagingHandlingCosts {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingIrregular Property

ShippingIrregular Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► ShippingIrregular
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingIrregular { get; set; }
Public Property ShippingIrregular As Boolean
    Get
    Set
public:
property bool ShippingIrregular {
    bool get ();
    void set (bool value);
}


ShippingIrregularSpecified Property

ShippingIrregularSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► ShippingIrregularSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingIrregularSpecified { get; set; }
Public Property ShippingIrregularSpecified As Boolean
    Get
    Set
public:
property bool ShippingIrregularSpecified {
    bool get ();
    void set (bool value);
}


ShippingPackage Property

ShippingPackage Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► ShippingPackage
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeType ShippingPackage { get; set; }
Public Property ShippingPackage As ShippingPackageCodeType
    Get
    Set
public:
property ShippingPackageCodeType ShippingPackage {
    ShippingPackageCodeType get ();
    void set (ShippingPackageCodeType value);
}


ShippingPackageSpecified Property

ShippingPackageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► ShippingPackageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingPackageSpecified { get; set; }
Public Property ShippingPackageSpecified As Boolean
    Get
    Set
public:
property bool ShippingPackageSpecified {
    bool get ();
    void set (bool value);
}


WeightMajor Property

WeightMajor Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► WeightMajor
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType WeightMajor { get; set; }
Public Property WeightMajor As MeasureType
    Get
    Set
public:
property MeasureType^ WeightMajor {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


WeightMinor Property

WeightMinor Property
Namespaces ► eBay.Service.Core.Soap ► CalculatedShippingRateType ► WeightMinor
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType WeightMinor { get; set; }
Public Property WeightMinor As MeasureType
    Get
    Set
public:
property MeasureType^ WeightMinor {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


CancelDetailType Class

CancelDetailType Class
Namespaces ► eBay.Service.Core.Soap ► CancelDetailType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CancelDetailType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CancelDetailType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CancelDetailType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CancelDetailType()()()() |
 | Any |
 | CancelCompleteDate |
 | CancelCompleteDateSpecified |
 | CancelIntiationDate |
 | CancelIntiationDateSpecified |
 | CancelIntiator |
 | CancelReason |
 | CancelReasonDetails |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CancelDetailType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CancelCompleteDate Property

CancelCompleteDate Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailType ► CancelCompleteDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CancelCompleteDate { get; set; }
Public Property CancelCompleteDate As DateTime
    Get
    Set
public:
property DateTime CancelCompleteDate {
    DateTime get ();
    void set (DateTime value);
}


CancelCompleteDateSpecified Property

CancelCompleteDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailType ► CancelCompleteDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CancelCompleteDateSpecified { get; set; }
Public Property CancelCompleteDateSpecified As Boolean
    Get
    Set
public:
property bool CancelCompleteDateSpecified {
    bool get ();
    void set (bool value);
}


CancelDetailType Constructor

CancelDetailType Constructor
Namespaces ► eBay.Service.Core.Soap ► CancelDetailType ► CancelDetailType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CancelDetailType()
Public Sub New
public:
CancelDetailType()


CancelIntiationDate Property

CancelIntiationDate Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailType ► CancelIntiationDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CancelIntiationDate { get; set; }
Public Property CancelIntiationDate As DateTime
    Get
    Set
public:
property DateTime CancelIntiationDate {
    DateTime get ();
    void set (DateTime value);
}


CancelIntiationDateSpecified Property

CancelIntiationDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailType ► CancelIntiationDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CancelIntiationDateSpecified { get; set; }
Public Property CancelIntiationDateSpecified As Boolean
    Get
    Set
public:
property bool CancelIntiationDateSpecified {
    bool get ();
    void set (bool value);
}


CancelIntiator Property

CancelIntiator Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailType ► CancelIntiator
Declaration Syntax
C# Visual Basic Visual C++
public string CancelIntiator { get; set; }
Public Property CancelIntiator As String
    Get
    Set
public:
property String^ CancelIntiator {
    String^ get ();
    void set (String^ value);
}


CancelReason Property

CancelReason Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailType ► CancelReason
Declaration Syntax
C# Visual Basic Visual C++
public string CancelReason { get; set; }
Public Property CancelReason As String
    Get
    Set
public:
property String^ CancelReason {
    String^ get ();
    void set (String^ value);
}


CancelReasonDetails Property

CancelReasonDetails Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailType ► CancelReasonDetails
Declaration Syntax
C# Visual Basic Visual C++
public string CancelReasonDetails { get; set; }
Public Property CancelReasonDetails As String
    Get
    Set
public:
property String^ CancelReasonDetails {
    String^ get ();
    void set (String^ value);
}


CancelDetailTypeCollection Class

CancelDetailTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CancelDetailTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CancelDetailTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CancelDetailTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CancelDetailTypeCollection()()()() |
 | CancelDetailTypeCollection(array<CancelDetailType>[]()[][]) |
 | CancelDetailTypeCollection(CancelDetailTypeCollection) |
 | Add(CancelDetailType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CancelDetailType>[]()[][]) |
 | AddRange(CancelDetailTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CancelDetailType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CancelDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CancelDetailType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CancelDetailType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CancelDetailType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CancelDetailTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► Add(CancelDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CancelDetailType item
)
Public Function Add ( _
    item As CancelDetailType _
) As Integer
public:
int Add(
    CancelDetailType^ item
)
Parameters
item (CancelDetailType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CancelDetailType>[]()[][]) |
 | AddRange(CancelDetailTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► AddRange(array<CancelDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CancelDetailType[] items
)
Public Sub AddRange ( _
    items As CancelDetailType() _
)
public:
void AddRange(
    array<CancelDetailType^>^ items
)
Parameters
items (array< CancelDetailType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► AddRange(CancelDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CancelDetailTypeCollection items
)
Public Sub AddRange ( _
    items As CancelDetailTypeCollection _
)
public:
void AddRange(
    CancelDetailTypeCollection^ items
)
Parameters
items (CancelDetailTypeCollection)


CancelDetailTypeCollection Constructor

CancelDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► CancelDetailTypeCollection()()()()
Members
Icon | Member | Description
 | CancelDetailTypeCollection()()()() |
 | CancelDetailTypeCollection(array<CancelDetailType>[]()[][]) |
 | CancelDetailTypeCollection(CancelDetailTypeCollection) |


CancelDetailTypeCollection Constructor

CancelDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► CancelDetailTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CancelDetailTypeCollection()
Public Sub New
public:
CancelDetailTypeCollection()


CancelDetailTypeCollection Constructor (items)

CancelDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► CancelDetailTypeCollection(array<CancelDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CancelDetailTypeCollection(
    CancelDetailType[] items
)
Public Sub New ( _
    items As CancelDetailType() _
)
public:
CancelDetailTypeCollection(
    array<CancelDetailType^>^ items
)
Parameters
items (array< CancelDetailType >[]()[][])


CancelDetailTypeCollection Constructor (items)

CancelDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► CancelDetailTypeCollection(CancelDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CancelDetailTypeCollection(
    CancelDetailTypeCollection items
)
Public Sub New ( _
    items As CancelDetailTypeCollection _
)
public:
CancelDetailTypeCollection(
    CancelDetailTypeCollection^ items
)
Parameters
items (CancelDetailTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► Contains(CancelDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CancelDetailType item
)
Public Function Contains ( _
    item As CancelDetailType _
) As Boolean
public:
bool Contains(
    CancelDetailType^ item
)
Parameters
item (CancelDetailType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► CopyTo(array<CancelDetailType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CancelDetailType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CancelDetailType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CancelDetailType^>^ items,
    int index
)
Parameters
items (array< CancelDetailType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► IndexOf(CancelDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CancelDetailType item
)
Public Function IndexOf ( _
    item As CancelDetailType _
) As Integer
public:
int IndexOf(
    CancelDetailType^ item
)
Parameters
item (CancelDetailType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► Insert(Int32, CancelDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CancelDetailType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CancelDetailType _
)
public:
void Insert(
    int index,
    CancelDetailType^ item
)
Parameters
index (Int32)
item (CancelDetailType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CancelDetailType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CancelDetailType
    Get
    Set
public:
property CancelDetailType^ default[int index] {
    CancelDetailType^ get (int index);
    void set (int index, CancelDetailType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CancelDetailType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CancelDetailType
public:
CancelDetailType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► Remove(CancelDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CancelDetailType item
)
Public Sub Remove ( _
    item As CancelDetailType _
)
public:
void Remove(
    CancelDetailType^ item
)
Parameters
item (CancelDetailType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CancelDetailType[] ToArray()
Public Function ToArray As CancelDetailType()
public:
array<CancelDetailType^>^ ToArray()
Return Value


CancelStatusCodeType Enumeration

CancelStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CancelStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CancelStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CancelStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CancelStatusCodeType
Members
Member | Description
Invalid |
NotApplicable |
CancelRequested |
CancelPending |
CancelRejected |
CancelClosedNoRefund |
CancelClosedWithRefund |
CancelClosedUnknownRefund |
CancelClosedForCommitment |
CancelComplete |
CancelFailed |
CustomCode |
Remarks


CategoryFeatureType Class

CategoryFeatureType Class
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CategoryFeatureType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CategoryFeatureType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CategoryFeatureType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoryFeatureType()()()() |
 | AdditionalCompatibilityEnabled |
 | AdditionalCompatibilityEnabledSpecified |
 | AdFormatEnabled |
 | AdFormatEnabledSpecified |
 | Any |
 | AttributeConversionEnabled |
 | AttributeConversionEnabledSpecified |
 | BasicUpgradePackEnabled |
 | BasicUpgradePackEnabledSpecified |
 | BestOfferAutoAcceptEnabled |
 | BestOfferAutoAcceptEnabledSpecified |
 | BestOfferAutoDeclineEnabled |
 | BestOfferAutoDeclineEnabledSpecified |
 | BestOfferCounterEnabled |
 | BestOfferCounterEnabledSpecified |
 | BestOfferEnabled |
 | BestOfferEnabledSpecified |
 | BrandMPNIdentifierEnabled |
 | BrandMPNIdentifierEnabledSpecified |
 | BuyerGuaranteeEnabled |
 | BuyerGuaranteeEnabledSpecified |
 | CategoryID |
 | ClassifiedAdAutoAcceptEnabled |
 | ClassifiedAdAutoAcceptEnabledSpecified |
 | ClassifiedAdAutoDeclineEnabled |
 | ClassifiedAdAutoDeclineEnabledSpecified |
 | ClassifiedAdBestOfferEnabled |
 | ClassifiedAdBestOfferEnabledSpecified |
 | ClassifiedAdCompanyNameEnabled |
 | ClassifiedAdCompanyNameEnabledSpecified |
 | ClassifiedAdContactByAddressEnabled |
 | ClassifiedAdContactByAddressEnabledSpecified |
 | ClassifiedAdContactByEmailEnabled |
 | ClassifiedAdContactByEmailEnabledSpecified |
 | ClassifiedAdContactByPhoneEnabled |
 | ClassifiedAdContactByPhoneEnabledSpecified |
 | ClassifiedAdCounterOfferEnabled |
 | ClassifiedAdCounterOfferEnabledSpecified |
 | ClassifiedAdPaymentMethodEnabled |
 | ClassifiedAdPaymentMethodEnabledSpecified |
 | ClassifiedAdPayPerLeadEnabled |
 | ClassifiedAdPayPerLeadEnabledSpecified |
 | ClassifiedAdPhoneCount |
 | ClassifiedAdPhoneCountSpecified |
 | ClassifiedAdShippingMethodEnabled |
 | ClassifiedAdShippingMethodEnabledSpecified |
 | ClassifiedAdStreetCount |
 | ClassifiedAdStreetCountSpecified |
 | CombinedFixedPriceTreatmentEnabled |
 | CombinedFixedPriceTreatmentEnabledSpecified |
 | CompatibleVehicleType |
 | ConditionEnabled |
 | ConditionEnabledSpecified |
 | ConditionValues |
 | CrossBorderTradeAustraliaEnabled |
 | CrossBorderTradeAustraliaEnabledSpecified |
 | CrossBorderTradeGBEnabled |
 | CrossBorderTradeGBEnabledSpecified |
 | CrossBorderTradeNorthAmericaEnabled |
 | CrossBorderTradeNorthAmericaEnabledSpecified |
 | DepositSupported |
 | DepositSupportedSpecified |
 | DigitalGoodDeliveryEnabled |
 | DigitalGoodDeliveryEnabledSpecified |
 | DutchBINEnabled |
 | DutchBINEnabledSpecified |
 | EANEnabled |
 | EANEnabledSpecified |
 | eBayMotorsProAdFormatEnabled |
 | eBayMotorsProAdFormatEnabledSpecified |
 | eBayMotorsProAutoAcceptEnabled |
 | eBayMotorsProAutoAcceptEnabledSpecified |
 | eBayMotorsProAutoDeclineEnabled |
 | eBayMotorsProAutoDeclineEnabledSpecified |
 | eBayMotorsProBestOfferEnabled |
 | eBayMotorsProBestOfferEnabledSpecified |
 | eBayMotorsProCompanyNameEnabled |
 | eBayMotorsProCompanyNameEnabledSpecified |
 | eBayMotorsProContactByAddressEnabled |
 | eBayMotorsProContactByAddressEnabledSpecified |
 | eBayMotorsProContactByEmailEnabled |
 | eBayMotorsProContactByEmailEnabledSpecified |
 | eBayMotorsProContactByPhoneEnabled |
 | eBayMotorsProContactByPhoneEnabledSpecified |
 | eBayMotorsProCounterOfferEnabled |
 | eBayMotorsProCounterOfferEnabledSpecified |
 | eBayMotorsProPaymentMethodCheckOutEnabled |
 | eBayMotorsProPaymentMethodCheckOutEnabledSpecified |
 | eBayMotorsProPhoneCount |
 | eBayMotorsProPhoneCountSpecified |
 | eBayMotorsProSellerContactDetailsEnabled |
 | eBayMotorsProSellerContactDetailsEnabledSpecified |
 | eBayMotorsProShippingMethodEnabled |
 | eBayMotorsProShippingMethodEnabledSpecified |
 | eBayMotorsProStreetCount |
 | eBayMotorsProStreetCountSpecified |
 | EpidSupported |
 | EpidSupportedSpecified |
 | Equals(Object) | (Inherited from Object.)
 | ExpressConditionRequired |
 | ExpressConditionRequiredSpecified |
 | ExpressEnabled |
 | ExpressEnabledSpecified |
 | ExpressPicturesRequired |
 | ExpressPicturesRequiredSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | FreeGalleryPlusEnabled |
 | FreeGalleryPlusEnabledSpecified |
 | FreePicturePackEnabled |
 | FreePicturePackEnabledSpecified |
 | GalleryFeaturedDurations |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalShippingEnabled |
 | GlobalShippingEnabledSpecified |
 | Group1MaxFlatShippingCost |
 | Group2MaxFlatShippingCost |
 | Group3MaxFlatShippingCost |
 | HandlingTimeEnabled |
 | HandlingTimeEnabledSpecified |
 | HomePageFeaturedEnabled |
 | HomePageFeaturedEnabledSpecified |
 | INEscrowWorkflowTimeline |
 | INEscrowWorkflowTimelineSpecified |
 | ISBNEnabled |
 | ISBNEnabledSpecified |
 | ItemCompatibilityEnabled |
 | ItemCompatibilityEnabledSpecified |
 | ItemSpecificsEnabled |
 | ItemSpecificsEnabledSpecified |
 | KTypeSupported |
 | KTypeSupportedSpecified |
 | ListingDuration |
 | LocalMarketAdFormatEnabled |
 | LocalMarketAdFormatEnabledSpecified |
 | LocalMarketAutoAcceptEnabled |
 | LocalMarketAutoAcceptEnabledSpecified |
 | LocalMarketAutoDeclineEnabled |
 | LocalMarketAutoDeclineEnabledSpecified |
 | LocalMarketBestOfferEnabled |
 | LocalMarketBestOfferEnabledSpecified |
 | LocalMarketCompanyNameEnabled |
 | LocalMarketCompanyNameEnabledSpecified |
 | LocalMarketContactByAddressEnabled |
 | LocalMarketContactByAddressEnabledSpecified |
 | LocalMarketContactByEmailEnabled |
 | LocalMarketContactByEmailEnabledSpecified |
 | LocalMarketContactByPhoneEnabled |
 | LocalMarketContactByPhoneEnabledSpecified |
 | LocalMarketCounterOfferEnabled |
 | LocalMarketCounterOfferEnabledSpecified |
 | LocalMarketNonSubscription |
 | LocalMarketNonSubscriptionSpecified |
 | LocalMarketPaymentMethodCheckOutEnabled |
 | LocalMarketPaymentMethodCheckOutEnabledSpecified |
 | LocalMarketPhoneCount |
 | LocalMarketPhoneCountSpecified |
 | LocalMarketPremiumSubscription |
 | LocalMarketPremiumSubscriptionSpecified |
 | LocalMarketRegularSubscription |
 | LocalMarketRegularSubscriptionSpecified |
 | LocalMarketSellerContactDetailsEnabled |
 | LocalMarketSellerContactDetailsEnabledSpecified |
 | LocalMarketShippingMethodEnabled |
 | LocalMarketShippingMethodEnabledSpecified |
 | LocalMarketSpecialitySubscription |
 | LocalMarketSpecialitySubscriptionSpecified |
 | LocalMarketStreetCount |
 | LocalMarketStreetCountSpecified |
 | MaxFlatShippingCost |
 | MaxGranularFitmentCount |
 | MaxGranularFitmentCountSpecified |
 | MaxItemCompatibility |
 | MaxItemCompatibilitySpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumReservePrice |
 | MinimumReservePriceSpecified |
 | MinItemCompatibility |
 | MinItemCompatibilitySpecified |
 | NonSubscription |
 | NonSubscriptionSpecified |
 | PaisaPayFullEscrowEnabled |
 | PaisaPayFullEscrowEnabledSpecified |
 | PaymentMethod |
 | PaymentOptionsGroup |
 | PaymentOptionsGroupSpecified |
 | PaymentProfileCategoryGroup |
 | PaymentProfileCategoryGroupSpecified |
 | PayPalBuyerProtectionEnabled |
 | PayPalBuyerProtectionEnabledSpecified |
 | PayPalRequired |
 | PayPalRequiredForStoreOwner |
 | PayPalRequiredForStoreOwnerSpecified |
 | PayPalRequiredSpecified |
 | PickupDropOffEnabled |
 | PickupDropOffEnabledSpecified |
 | PremiumSubscription |
 | PremiumSubscriptionSpecified |
 | ProductCreationEnabled |
 | ProductCreationEnabledSpecified |
 | ProPackEnabled |
 | ProPackEnabledSpecified |
 | ProPackPlusEnabled |
 | ProPackPlusEnabledSpecified |
 | RegularSubscription |
 | RegularSubscriptionSpecified |
 | ReturnPolicyEnabled |
 | ReturnPolicyEnabledSpecified |
 | ReturnPolicyProfileCategoryGroup |
 | ReturnPolicyProfileCategoryGroupSpecified |
 | RevisePriceAllowed |
 | RevisePriceAllowedSpecified |
 | ReviseQuantityAllowed |
 | ReviseQuantityAllowedSpecified |
 | SafePaymentRequired |
 | SafePaymentRequiredSpecified |
 | SellerContactDetailsEnabled |
 | SellerContactDetailsEnabledSpecified |
 | SellerProvidedTitleSupported |
 | SellerProvidedTitleSupportedSpecified |
 | ShippingProfileCategoryGroup |
 | ShippingProfileCategoryGroupSpecified |
 | ShippingTermsRequired |
 | ShippingTermsRequiredSpecified |
 | SkypeMeNonTransactionalEnabled |
 | SkypeMeNonTransactionalEnabledSpecified |
 | SkypeMeTransactionalEnabled |
 | SkypeMeTransactionalEnabledSpecified |
 | SpecialitySubscription |
 | SpecialitySubscriptionSpecified |
 | StoreInventoryEnabled |
 | StoreInventoryEnabledSpecified |
 | StoreOwnerExtendedListingDurations |
 | StoreOwnerExtendedListingDurationsEnabled |
 | StoreOwnerExtendedListingDurationsEnabledSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TransactionConfirmationRequestEnabled |
 | TransactionConfirmationRequestEnabledSpecified |
 | UPCEnabled |
 | UPCEnabledSpecified |
 | UserConsentRequired |
 | UserConsentRequiredSpecified |
 | ValueCategory |
 | ValueCategorySpecified |
 | ValuePackEnabled |
 | ValuePackEnabledSpecified |
 | VariationsEnabled |
 | VariationsEnabledSpecified |
 | VINSupported |
 | VINSupportedSpecified |
 | VRMSupported |
 | VRMSupportedSpecified |
Remarks
Inheritance Hierarchy
Object
CategoryFeatureType


AdditionalCompatibilityEnabled Property

AdditionalCompatibilityEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► AdditionalCompatibilityEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool AdditionalCompatibilityEnabled { get; set; }
Public Property AdditionalCompatibilityEnabled As Boolean
    Get
    Set
public:
property bool AdditionalCompatibilityEnabled {
    bool get ();
    void set (bool value);
}


AdditionalCompatibilityEnabledSpecified Property

AdditionalCompatibilityEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► AdditionalCompatibilityEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AdditionalCompatibilityEnabledSpecified { get; set; }
Public Property AdditionalCompatibilityEnabledSpecified As Boolean
    Get
    Set
public:
property bool AdditionalCompatibilityEnabledSpecified {
    bool get ();
    void set (bool value);
}


AdFormatEnabled Property

AdFormatEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► AdFormatEnabled
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatEnabledCodeType AdFormatEnabled { get; set; }
Public Property AdFormatEnabled As AdFormatEnabledCodeType
    Get
    Set
public:
property AdFormatEnabledCodeType AdFormatEnabled {
    AdFormatEnabledCodeType get ();
    void set (AdFormatEnabledCodeType value);
}


AdFormatEnabledSpecified Property

AdFormatEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► AdFormatEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AdFormatEnabledSpecified { get; set; }
Public Property AdFormatEnabledSpecified As Boolean
    Get
    Set
public:
property bool AdFormatEnabledSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AttributeConversionEnabled Property

AttributeConversionEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► AttributeConversionEnabled
Declaration Syntax
C# Visual Basic Visual C++
public AttributeConversionEnabledCodeType AttributeConversionEnabled { get; set; }
Public Property AttributeConversionEnabled As AttributeConversionEnabledCodeType
    Get
    Set
public:
property AttributeConversionEnabledCodeType AttributeConversionEnabled {
    AttributeConversionEnabledCodeType get ();
    void set (AttributeConversionEnabledCodeType value);
}


AttributeConversionEnabledSpecified Property

AttributeConversionEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► AttributeConversionEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AttributeConversionEnabledSpecified { get; set; }
Public Property AttributeConversionEnabledSpecified As Boolean
    Get
    Set
public:
property bool AttributeConversionEnabledSpecified {
    bool get ();
    void set (bool value);
}


BasicUpgradePackEnabled Property

BasicUpgradePackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BasicUpgradePackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BasicUpgradePackEnabled { get; set; }
Public Property BasicUpgradePackEnabled As Boolean
    Get
    Set
public:
property bool BasicUpgradePackEnabled {
    bool get ();
    void set (bool value);
}


BasicUpgradePackEnabledSpecified Property

BasicUpgradePackEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BasicUpgradePackEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BasicUpgradePackEnabledSpecified { get; set; }
Public Property BasicUpgradePackEnabledSpecified As Boolean
    Get
    Set
public:
property bool BasicUpgradePackEnabledSpecified {
    bool get ();
    void set (bool value);
}


BestOfferAutoAcceptEnabled Property

BestOfferAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BestOfferAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferAutoAcceptEnabled { get; set; }
Public Property BestOfferAutoAcceptEnabled As Boolean
    Get
    Set
public:
property bool BestOfferAutoAcceptEnabled {
    bool get ();
    void set (bool value);
}


BestOfferAutoAcceptEnabledSpecified Property

BestOfferAutoAcceptEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BestOfferAutoAcceptEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferAutoAcceptEnabledSpecified { get; set; }
Public Property BestOfferAutoAcceptEnabledSpecified As Boolean
    Get
    Set
public:
property bool BestOfferAutoAcceptEnabledSpecified {
    bool get ();
    void set (bool value);
}


BestOfferAutoDeclineEnabled Property

BestOfferAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BestOfferAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferAutoDeclineEnabled { get; set; }
Public Property BestOfferAutoDeclineEnabled As Boolean
    Get
    Set
public:
property bool BestOfferAutoDeclineEnabled {
    bool get ();
    void set (bool value);
}


BestOfferAutoDeclineEnabledSpecified Property

BestOfferAutoDeclineEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BestOfferAutoDeclineEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferAutoDeclineEnabledSpecified { get; set; }
Public Property BestOfferAutoDeclineEnabledSpecified As Boolean
    Get
    Set
public:
property bool BestOfferAutoDeclineEnabledSpecified {
    bool get ();
    void set (bool value);
}


BestOfferCounterEnabled Property

BestOfferCounterEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BestOfferCounterEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferCounterEnabled { get; set; }
Public Property BestOfferCounterEnabled As Boolean
    Get
    Set
public:
property bool BestOfferCounterEnabled {
    bool get ();
    void set (bool value);
}


BestOfferCounterEnabledSpecified Property

BestOfferCounterEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BestOfferCounterEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferCounterEnabledSpecified { get; set; }
Public Property BestOfferCounterEnabledSpecified As Boolean
    Get
    Set
public:
property bool BestOfferCounterEnabledSpecified {
    bool get ();
    void set (bool value);
}


BestOfferEnabled Property

BestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferEnabled { get; set; }
Public Property BestOfferEnabled As Boolean
    Get
    Set
public:
property bool BestOfferEnabled {
    bool get ();
    void set (bool value);
}


BestOfferEnabledSpecified Property

BestOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BestOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferEnabledSpecified { get; set; }
Public Property BestOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool BestOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


BrandMPNIdentifierEnabled Property

BrandMPNIdentifierEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BrandMPNIdentifierEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BrandMPNIdentifierEnabled { get; set; }
Public Property BrandMPNIdentifierEnabled As Boolean
    Get
    Set
public:
property bool BrandMPNIdentifierEnabled {
    bool get ();
    void set (bool value);
}


BrandMPNIdentifierEnabledSpecified Property

BrandMPNIdentifierEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BrandMPNIdentifierEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BrandMPNIdentifierEnabledSpecified { get; set; }
Public Property BrandMPNIdentifierEnabledSpecified As Boolean
    Get
    Set
public:
property bool BrandMPNIdentifierEnabledSpecified {
    bool get ();
    void set (bool value);
}


BuyerGuaranteeEnabled Property

BuyerGuaranteeEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BuyerGuaranteeEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerGuaranteeEnabled { get; set; }
Public Property BuyerGuaranteeEnabled As Boolean
    Get
    Set
public:
property bool BuyerGuaranteeEnabled {
    bool get ();
    void set (bool value);
}


BuyerGuaranteeEnabledSpecified Property

BuyerGuaranteeEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► BuyerGuaranteeEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerGuaranteeEnabledSpecified { get; set; }
Public Property BuyerGuaranteeEnabledSpecified As Boolean
    Get
    Set
public:
property bool BuyerGuaranteeEnabledSpecified {
    bool get ();
    void set (bool value);
}


CategoryFeatureType Constructor

CategoryFeatureType Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► CategoryFeatureType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureType()
Public Sub New
public:
CategoryFeatureType()


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


ClassifiedAdAutoAcceptEnabled Property

ClassifiedAdAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdAutoAcceptEnabled { get; set; }
Public Property ClassifiedAdAutoAcceptEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdAutoAcceptEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdAutoAcceptEnabledSpecified Property

ClassifiedAdAutoAcceptEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdAutoAcceptEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdAutoAcceptEnabledSpecified { get; set; }
Public Property ClassifiedAdAutoAcceptEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdAutoAcceptEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdAutoDeclineEnabled Property

ClassifiedAdAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdAutoDeclineEnabled { get; set; }
Public Property ClassifiedAdAutoDeclineEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdAutoDeclineEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdAutoDeclineEnabledSpecified Property

ClassifiedAdAutoDeclineEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdAutoDeclineEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdAutoDeclineEnabledSpecified { get; set; }
Public Property ClassifiedAdAutoDeclineEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdAutoDeclineEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdBestOfferEnabled Property

ClassifiedAdBestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdBestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdBestOfferEnabledCodeType ClassifiedAdBestOfferEnabled { get; set; }
Public Property ClassifiedAdBestOfferEnabled As ClassifiedAdBestOfferEnabledCodeType
    Get
    Set
public:
property ClassifiedAdBestOfferEnabledCodeType ClassifiedAdBestOfferEnabled {
    ClassifiedAdBestOfferEnabledCodeType get ();
    void set (ClassifiedAdBestOfferEnabledCodeType value);
}


ClassifiedAdBestOfferEnabledSpecified Property

ClassifiedAdBestOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdBestOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdBestOfferEnabledSpecified { get; set; }
Public Property ClassifiedAdBestOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdBestOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdCompanyNameEnabled Property

ClassifiedAdCompanyNameEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdCompanyNameEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdCompanyNameEnabled { get; set; }
Public Property ClassifiedAdCompanyNameEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdCompanyNameEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdCompanyNameEnabledSpecified Property

ClassifiedAdCompanyNameEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdCompanyNameEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdCompanyNameEnabledSpecified { get; set; }
Public Property ClassifiedAdCompanyNameEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdCompanyNameEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByAddressEnabled Property

ClassifiedAdContactByAddressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdContactByAddressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByAddressEnabled { get; set; }
Public Property ClassifiedAdContactByAddressEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByAddressEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByAddressEnabledSpecified Property

ClassifiedAdContactByAddressEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdContactByAddressEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByAddressEnabledSpecified { get; set; }
Public Property ClassifiedAdContactByAddressEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByAddressEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByEmailEnabled Property

ClassifiedAdContactByEmailEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdContactByEmailEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByEmailEnabled { get; set; }
Public Property ClassifiedAdContactByEmailEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByEmailEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByEmailEnabledSpecified Property

ClassifiedAdContactByEmailEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdContactByEmailEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByEmailEnabledSpecified { get; set; }
Public Property ClassifiedAdContactByEmailEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByEmailEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByPhoneEnabled Property

ClassifiedAdContactByPhoneEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdContactByPhoneEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByPhoneEnabled { get; set; }
Public Property ClassifiedAdContactByPhoneEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByPhoneEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByPhoneEnabledSpecified Property

ClassifiedAdContactByPhoneEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdContactByPhoneEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByPhoneEnabledSpecified { get; set; }
Public Property ClassifiedAdContactByPhoneEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByPhoneEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdCounterOfferEnabled Property

ClassifiedAdCounterOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdCounterOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdCounterOfferEnabled { get; set; }
Public Property ClassifiedAdCounterOfferEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdCounterOfferEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdCounterOfferEnabledSpecified Property

ClassifiedAdCounterOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdCounterOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdCounterOfferEnabledSpecified { get; set; }
Public Property ClassifiedAdCounterOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdCounterOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdPaymentMethodEnabled Property

ClassifiedAdPaymentMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdPaymentMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPaymentMethodEnabledCodeType ClassifiedAdPaymentMethodEnabled { get; set; }
Public Property ClassifiedAdPaymentMethodEnabled As ClassifiedAdPaymentMethodEnabledCodeType
    Get
    Set
public:
property ClassifiedAdPaymentMethodEnabledCodeType ClassifiedAdPaymentMethodEnabled {
    ClassifiedAdPaymentMethodEnabledCodeType get ();
    void set (ClassifiedAdPaymentMethodEnabledCodeType value);
}


ClassifiedAdPaymentMethodEnabledSpecified Property

ClassifiedAdPaymentMethodEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdPaymentMethodEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdPaymentMethodEnabledSpecified { get; set; }
Public Property ClassifiedAdPaymentMethodEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdPaymentMethodEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdPayPerLeadEnabled Property

ClassifiedAdPayPerLeadEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdPayPerLeadEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdPayPerLeadEnabled { get; set; }
Public Property ClassifiedAdPayPerLeadEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdPayPerLeadEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdPayPerLeadEnabledSpecified Property

ClassifiedAdPayPerLeadEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdPayPerLeadEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdPayPerLeadEnabledSpecified { get; set; }
Public Property ClassifiedAdPayPerLeadEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdPayPerLeadEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdPhoneCount Property

ClassifiedAdPhoneCount Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdPhoneCount
Declaration Syntax
C# Visual Basic Visual C++
public int ClassifiedAdPhoneCount { get; set; }
Public Property ClassifiedAdPhoneCount As Integer
    Get
    Set
public:
property int ClassifiedAdPhoneCount {
    int get ();
    void set (int value);
}


ClassifiedAdPhoneCountSpecified Property

ClassifiedAdPhoneCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdPhoneCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdPhoneCountSpecified { get; set; }
Public Property ClassifiedAdPhoneCountSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdPhoneCountSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdShippingMethodEnabled Property

ClassifiedAdShippingMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdShippingMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdShippingMethodEnabled { get; set; }
Public Property ClassifiedAdShippingMethodEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdShippingMethodEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdShippingMethodEnabledSpecified Property

ClassifiedAdShippingMethodEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdShippingMethodEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdShippingMethodEnabledSpecified { get; set; }
Public Property ClassifiedAdShippingMethodEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdShippingMethodEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdStreetCount Property

ClassifiedAdStreetCount Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdStreetCount
Declaration Syntax
C# Visual Basic Visual C++
public int ClassifiedAdStreetCount { get; set; }
Public Property ClassifiedAdStreetCount As Integer
    Get
    Set
public:
property int ClassifiedAdStreetCount {
    int get ();
    void set (int value);
}


ClassifiedAdStreetCountSpecified Property

ClassifiedAdStreetCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ClassifiedAdStreetCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdStreetCountSpecified { get; set; }
Public Property ClassifiedAdStreetCountSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdStreetCountSpecified {
    bool get ();
    void set (bool value);
}


CombinedFixedPriceTreatmentEnabled Property

CombinedFixedPriceTreatmentEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► CombinedFixedPriceTreatmentEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CombinedFixedPriceTreatmentEnabled { get; set; }
Public Property CombinedFixedPriceTreatmentEnabled As Boolean
    Get
    Set
public:
property bool CombinedFixedPriceTreatmentEnabled {
    bool get ();
    void set (bool value);
}


CombinedFixedPriceTreatmentEnabledSpecified Property

CombinedFixedPriceTreatmentEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► CombinedFixedPriceTreatmentEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CombinedFixedPriceTreatmentEnabledSpecified { get; set; }
Public Property CombinedFixedPriceTreatmentEnabledSpecified As Boolean
    Get
    Set
public:
property bool CombinedFixedPriceTreatmentEnabledSpecified {
    bool get ();
    void set (bool value);
}


CompatibleVehicleType Property

CompatibleVehicleType Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► CompatibleVehicleType
Declaration Syntax
C# Visual Basic Visual C++
public string CompatibleVehicleType { get; set; }
Public Property CompatibleVehicleType As String
    Get
    Set
public:
property String^ CompatibleVehicleType {
    String^ get ();
    void set (String^ value);
}


ConditionEnabled Property

ConditionEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ConditionEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ConditionEnabledCodeType ConditionEnabled { get; set; }
Public Property ConditionEnabled As ConditionEnabledCodeType
    Get
    Set
public:
property ConditionEnabledCodeType ConditionEnabled {
    ConditionEnabledCodeType get ();
    void set (ConditionEnabledCodeType value);
}


ConditionEnabledSpecified Property

ConditionEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ConditionEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ConditionEnabledSpecified { get; set; }
Public Property ConditionEnabledSpecified As Boolean
    Get
    Set
public:
property bool ConditionEnabledSpecified {
    bool get ();
    void set (bool value);
}


ConditionValues Property

ConditionValues Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ConditionValues
Declaration Syntax
C# Visual Basic Visual C++
public ConditionValuesType ConditionValues { get; set; }
Public Property ConditionValues As ConditionValuesType
    Get
    Set
public:
property ConditionValuesType^ ConditionValues {
    ConditionValuesType^ get ();
    void set (ConditionValuesType^ value);
}


CrossBorderTradeAustraliaEnabled Property

CrossBorderTradeAustraliaEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► CrossBorderTradeAustraliaEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeAustraliaEnabled { get; set; }
Public Property CrossBorderTradeAustraliaEnabled As Boolean
    Get
    Set
public:
property bool CrossBorderTradeAustraliaEnabled {
    bool get ();
    void set (bool value);
}


CrossBorderTradeAustraliaEnabledSpecified Property

CrossBorderTradeAustraliaEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► CrossBorderTradeAustraliaEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeAustraliaEnabledSpecified { get; set; }
Public Property CrossBorderTradeAustraliaEnabledSpecified As Boolean
    Get
    Set
public:
property bool CrossBorderTradeAustraliaEnabledSpecified {
    bool get ();
    void set (bool value);
}


CrossBorderTradeGBEnabled Property

CrossBorderTradeGBEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► CrossBorderTradeGBEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeGBEnabled { get; set; }
Public Property CrossBorderTradeGBEnabled As Boolean
    Get
    Set
public:
property bool CrossBorderTradeGBEnabled {
    bool get ();
    void set (bool value);
}


CrossBorderTradeGBEnabledSpecified Property

CrossBorderTradeGBEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► CrossBorderTradeGBEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeGBEnabledSpecified { get; set; }
Public Property CrossBorderTradeGBEnabledSpecified As Boolean
    Get
    Set
public:
property bool CrossBorderTradeGBEnabledSpecified {
    bool get ();
    void set (bool value);
}


CrossBorderTradeNorthAmericaEnabled Property

CrossBorderTradeNorthAmericaEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► CrossBorderTradeNorthAmericaEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeNorthAmericaEnabled { get; set; }
Public Property CrossBorderTradeNorthAmericaEnabled As Boolean
    Get
    Set
public:
property bool CrossBorderTradeNorthAmericaEnabled {
    bool get ();
    void set (bool value);
}


CrossBorderTradeNorthAmericaEnabledSpecified Property

CrossBorderTradeNorthAmericaEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► CrossBorderTradeNorthAmericaEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeNorthAmericaEnabledSpecified { get; set; }
Public Property CrossBorderTradeNorthAmericaEnabledSpecified As Boolean
    Get
    Set
public:
property bool CrossBorderTradeNorthAmericaEnabledSpecified {
    bool get ();
    void set (bool value);
}


DepositSupported Property

DepositSupported Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► DepositSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool DepositSupported { get; set; }
Public Property DepositSupported As Boolean
    Get
    Set
public:
property bool DepositSupported {
    bool get ();
    void set (bool value);
}


DepositSupportedSpecified Property

DepositSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► DepositSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DepositSupportedSpecified { get; set; }
Public Property DepositSupportedSpecified As Boolean
    Get
    Set
public:
property bool DepositSupportedSpecified {
    bool get ();
    void set (bool value);
}


DigitalGoodDeliveryEnabled Property

DigitalGoodDeliveryEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► DigitalGoodDeliveryEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool DigitalGoodDeliveryEnabled { get; set; }
Public Property DigitalGoodDeliveryEnabled As Boolean
    Get
    Set
public:
property bool DigitalGoodDeliveryEnabled {
    bool get ();
    void set (bool value);
}


DigitalGoodDeliveryEnabledSpecified Property

DigitalGoodDeliveryEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► DigitalGoodDeliveryEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DigitalGoodDeliveryEnabledSpecified { get; set; }
Public Property DigitalGoodDeliveryEnabledSpecified As Boolean
    Get
    Set
public:
property bool DigitalGoodDeliveryEnabledSpecified {
    bool get ();
    void set (bool value);
}


DutchBINEnabled Property

DutchBINEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► DutchBINEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool DutchBINEnabled { get; set; }
Public Property DutchBINEnabled As Boolean
    Get
    Set
public:
property bool DutchBINEnabled {
    bool get ();
    void set (bool value);
}


DutchBINEnabledSpecified Property

DutchBINEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► DutchBINEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DutchBINEnabledSpecified { get; set; }
Public Property DutchBINEnabledSpecified As Boolean
    Get
    Set
public:
property bool DutchBINEnabledSpecified {
    bool get ();
    void set (bool value);
}


EANEnabled Property

EANEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► EANEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ProductIdentiferEnabledCodeType EANEnabled { get; set; }
Public Property EANEnabled As ProductIdentiferEnabledCodeType
    Get
    Set
public:
property ProductIdentiferEnabledCodeType EANEnabled {
    ProductIdentiferEnabledCodeType get ();
    void set (ProductIdentiferEnabledCodeType value);
}


EANEnabledSpecified Property

EANEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► EANEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EANEnabledSpecified { get; set; }
Public Property EANEnabledSpecified As Boolean
    Get
    Set
public:
property bool EANEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProAdFormatEnabled Property

eBayMotorsProAdFormatEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProAdFormatEnabled
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatEnabledCodeType eBayMotorsProAdFormatEnabled { get; set; }
Public Property eBayMotorsProAdFormatEnabled As AdFormatEnabledCodeType
    Get
    Set
public:
property AdFormatEnabledCodeType eBayMotorsProAdFormatEnabled {
    AdFormatEnabledCodeType get ();
    void set (AdFormatEnabledCodeType value);
}


eBayMotorsProAdFormatEnabledSpecified Property

eBayMotorsProAdFormatEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProAdFormatEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProAdFormatEnabledSpecified { get; set; }
Public Property eBayMotorsProAdFormatEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProAdFormatEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProAutoAcceptEnabled Property

eBayMotorsProAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProAutoAcceptEnabled { get; set; }
Public Property eBayMotorsProAutoAcceptEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProAutoAcceptEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProAutoAcceptEnabledSpecified Property

eBayMotorsProAutoAcceptEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProAutoAcceptEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProAutoAcceptEnabledSpecified { get; set; }
Public Property eBayMotorsProAutoAcceptEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProAutoAcceptEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProAutoDeclineEnabled Property

eBayMotorsProAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProAutoDeclineEnabled { get; set; }
Public Property eBayMotorsProAutoDeclineEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProAutoDeclineEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProAutoDeclineEnabledSpecified Property

eBayMotorsProAutoDeclineEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProAutoDeclineEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProAutoDeclineEnabledSpecified { get; set; }
Public Property eBayMotorsProAutoDeclineEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProAutoDeclineEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProBestOfferEnabled Property

eBayMotorsProBestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProBestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdBestOfferEnabledCodeType eBayMotorsProBestOfferEnabled { get; set; }
Public Property eBayMotorsProBestOfferEnabled As ClassifiedAdBestOfferEnabledCodeType
    Get
    Set
public:
property ClassifiedAdBestOfferEnabledCodeType eBayMotorsProBestOfferEnabled {
    ClassifiedAdBestOfferEnabledCodeType get ();
    void set (ClassifiedAdBestOfferEnabledCodeType value);
}


eBayMotorsProBestOfferEnabledSpecified Property

eBayMotorsProBestOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProBestOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProBestOfferEnabledSpecified { get; set; }
Public Property eBayMotorsProBestOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProBestOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProCompanyNameEnabled Property

eBayMotorsProCompanyNameEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProCompanyNameEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProCompanyNameEnabled { get; set; }
Public Property eBayMotorsProCompanyNameEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProCompanyNameEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProCompanyNameEnabledSpecified Property

eBayMotorsProCompanyNameEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProCompanyNameEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProCompanyNameEnabledSpecified { get; set; }
Public Property eBayMotorsProCompanyNameEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProCompanyNameEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByAddressEnabled Property

eBayMotorsProContactByAddressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProContactByAddressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByAddressEnabled { get; set; }
Public Property eBayMotorsProContactByAddressEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByAddressEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByAddressEnabledSpecified Property

eBayMotorsProContactByAddressEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProContactByAddressEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByAddressEnabledSpecified { get; set; }
Public Property eBayMotorsProContactByAddressEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByAddressEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByEmailEnabled Property

eBayMotorsProContactByEmailEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProContactByEmailEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByEmailEnabled { get; set; }
Public Property eBayMotorsProContactByEmailEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByEmailEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByEmailEnabledSpecified Property

eBayMotorsProContactByEmailEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProContactByEmailEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByEmailEnabledSpecified { get; set; }
Public Property eBayMotorsProContactByEmailEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByEmailEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByPhoneEnabled Property

eBayMotorsProContactByPhoneEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProContactByPhoneEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByPhoneEnabled { get; set; }
Public Property eBayMotorsProContactByPhoneEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByPhoneEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByPhoneEnabledSpecified Property

eBayMotorsProContactByPhoneEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProContactByPhoneEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByPhoneEnabledSpecified { get; set; }
Public Property eBayMotorsProContactByPhoneEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByPhoneEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProCounterOfferEnabled Property

eBayMotorsProCounterOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProCounterOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProCounterOfferEnabled { get; set; }
Public Property eBayMotorsProCounterOfferEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProCounterOfferEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProCounterOfferEnabledSpecified Property

eBayMotorsProCounterOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProCounterOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProCounterOfferEnabledSpecified { get; set; }
Public Property eBayMotorsProCounterOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProCounterOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProPaymentMethodCheckOutEnabled Property

eBayMotorsProPaymentMethodCheckOutEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProPaymentMethodCheckOutEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPaymentMethodEnabledCodeType eBayMotorsProPaymentMethodCheckOutEnabled { get; set; }
Public Property eBayMotorsProPaymentMethodCheckOutEnabled As ClassifiedAdPaymentMethodEnabledCodeType
    Get
    Set
public:
property ClassifiedAdPaymentMethodEnabledCodeType eBayMotorsProPaymentMethodCheckOutEnabled {
    ClassifiedAdPaymentMethodEnabledCodeType get ();
    void set (ClassifiedAdPaymentMethodEnabledCodeType value);
}


eBayMotorsProPaymentMethodCheckOutEnabledSpecified Property

eBayMotorsProPaymentMethodCheckOutEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProPaymentMethodCheckOutEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProPaymentMethodCheckOutEnabledSpecified { get; set; }
Public Property eBayMotorsProPaymentMethodCheckOutEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProPaymentMethodCheckOutEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProPhoneCount Property

eBayMotorsProPhoneCount Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProPhoneCount
Declaration Syntax
C# Visual Basic Visual C++
public int eBayMotorsProPhoneCount { get; set; }
Public Property eBayMotorsProPhoneCount As Integer
    Get
    Set
public:
property int eBayMotorsProPhoneCount {
    int get ();
    void set (int value);
}


eBayMotorsProPhoneCountSpecified Property

eBayMotorsProPhoneCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProPhoneCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProPhoneCountSpecified { get; set; }
Public Property eBayMotorsProPhoneCountSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProPhoneCountSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProSellerContactDetailsEnabled Property

eBayMotorsProSellerContactDetailsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProSellerContactDetailsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProSellerContactDetailsEnabled { get; set; }
Public Property eBayMotorsProSellerContactDetailsEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProSellerContactDetailsEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProSellerContactDetailsEnabledSpecified Property

eBayMotorsProSellerContactDetailsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProSellerContactDetailsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProSellerContactDetailsEnabledSpecified { get; set; }
Public Property eBayMotorsProSellerContactDetailsEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProSellerContactDetailsEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProShippingMethodEnabled Property

eBayMotorsProShippingMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProShippingMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProShippingMethodEnabled { get; set; }
Public Property eBayMotorsProShippingMethodEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProShippingMethodEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProShippingMethodEnabledSpecified Property

eBayMotorsProShippingMethodEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProShippingMethodEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProShippingMethodEnabledSpecified { get; set; }
Public Property eBayMotorsProShippingMethodEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProShippingMethodEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProStreetCount Property

eBayMotorsProStreetCount Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProStreetCount
Declaration Syntax
C# Visual Basic Visual C++
public int eBayMotorsProStreetCount { get; set; }
Public Property eBayMotorsProStreetCount As Integer
    Get
    Set
public:
property int eBayMotorsProStreetCount {
    int get ();
    void set (int value);
}


eBayMotorsProStreetCountSpecified Property

eBayMotorsProStreetCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► eBayMotorsProStreetCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProStreetCountSpecified { get; set; }
Public Property eBayMotorsProStreetCountSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProStreetCountSpecified {
    bool get ();
    void set (bool value);
}


EpidSupported Property

EpidSupported Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► EpidSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool EpidSupported { get; set; }
Public Property EpidSupported As Boolean
    Get
    Set
public:
property bool EpidSupported {
    bool get ();
    void set (bool value);
}


EpidSupportedSpecified Property

EpidSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► EpidSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EpidSupportedSpecified { get; set; }
Public Property EpidSupportedSpecified As Boolean
    Get
    Set
public:
property bool EpidSupportedSpecified {
    bool get ();
    void set (bool value);
}


ExpressConditionRequired Property

ExpressConditionRequired Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ExpressConditionRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressConditionRequired { get; set; }
Public Property ExpressConditionRequired As Boolean
    Get
    Set
public:
property bool ExpressConditionRequired {
    bool get ();
    void set (bool value);
}


ExpressConditionRequiredSpecified Property

ExpressConditionRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ExpressConditionRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressConditionRequiredSpecified { get; set; }
Public Property ExpressConditionRequiredSpecified As Boolean
    Get
    Set
public:
property bool ExpressConditionRequiredSpecified {
    bool get ();
    void set (bool value);
}


ExpressEnabled Property

ExpressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ExpressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressEnabled { get; set; }
Public Property ExpressEnabled As Boolean
    Get
    Set
public:
property bool ExpressEnabled {
    bool get ();
    void set (bool value);
}


ExpressEnabledSpecified Property

ExpressEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ExpressEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressEnabledSpecified { get; set; }
Public Property ExpressEnabledSpecified As Boolean
    Get
    Set
public:
property bool ExpressEnabledSpecified {
    bool get ();
    void set (bool value);
}


ExpressPicturesRequired Property

ExpressPicturesRequired Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ExpressPicturesRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressPicturesRequired { get; set; }
Public Property ExpressPicturesRequired As Boolean
    Get
    Set
public:
property bool ExpressPicturesRequired {
    bool get ();
    void set (bool value);
}


ExpressPicturesRequiredSpecified Property

ExpressPicturesRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ExpressPicturesRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressPicturesRequiredSpecified { get; set; }
Public Property ExpressPicturesRequiredSpecified As Boolean
    Get
    Set
public:
property bool ExpressPicturesRequiredSpecified {
    bool get ();
    void set (bool value);
}


FreeGalleryPlusEnabled Property

FreeGalleryPlusEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► FreeGalleryPlusEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool FreeGalleryPlusEnabled { get; set; }
Public Property FreeGalleryPlusEnabled As Boolean
    Get
    Set
public:
property bool FreeGalleryPlusEnabled {
    bool get ();
    void set (bool value);
}


FreeGalleryPlusEnabledSpecified Property

FreeGalleryPlusEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► FreeGalleryPlusEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FreeGalleryPlusEnabledSpecified { get; set; }
Public Property FreeGalleryPlusEnabledSpecified As Boolean
    Get
    Set
public:
property bool FreeGalleryPlusEnabledSpecified {
    bool get ();
    void set (bool value);
}


FreePicturePackEnabled Property

FreePicturePackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► FreePicturePackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool FreePicturePackEnabled { get; set; }
Public Property FreePicturePackEnabled As Boolean
    Get
    Set
public:
property bool FreePicturePackEnabled {
    bool get ();
    void set (bool value);
}


FreePicturePackEnabledSpecified Property

FreePicturePackEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► FreePicturePackEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FreePicturePackEnabledSpecified { get; set; }
Public Property FreePicturePackEnabledSpecified As Boolean
    Get
    Set
public:
property bool FreePicturePackEnabledSpecified {
    bool get ();
    void set (bool value);
}


GalleryFeaturedDurations Property

GalleryFeaturedDurations Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► GalleryFeaturedDurations
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementDurationReferenceType GalleryFeaturedDurations { get; set; }
Public Property GalleryFeaturedDurations As ListingEnhancementDurationReferenceType
    Get
    Set
public:
property ListingEnhancementDurationReferenceType^ GalleryFeaturedDurations {
    ListingEnhancementDurationReferenceType^ get ();
    void set (ListingEnhancementDurationReferenceType^ value);
}


GlobalShippingEnabled Property

GlobalShippingEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► GlobalShippingEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShippingEnabled { get; set; }
Public Property GlobalShippingEnabled As Boolean
    Get
    Set
public:
property bool GlobalShippingEnabled {
    bool get ();
    void set (bool value);
}


GlobalShippingEnabledSpecified Property

GlobalShippingEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► GlobalShippingEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShippingEnabledSpecified { get; set; }
Public Property GlobalShippingEnabledSpecified As Boolean
    Get
    Set
public:
property bool GlobalShippingEnabledSpecified {
    bool get ();
    void set (bool value);
}


Group1MaxFlatShippingCost Property

Group1MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► Group1MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Group1MaxFlatShippingCost { get; set; }
Public Property Group1MaxFlatShippingCost As AmountType
    Get
    Set
public:
property AmountType^ Group1MaxFlatShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


Group2MaxFlatShippingCost Property

Group2MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► Group2MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Group2MaxFlatShippingCost { get; set; }
Public Property Group2MaxFlatShippingCost As AmountType
    Get
    Set
public:
property AmountType^ Group2MaxFlatShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


Group3MaxFlatShippingCost Property

Group3MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► Group3MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Group3MaxFlatShippingCost { get; set; }
Public Property Group3MaxFlatShippingCost As AmountType
    Get
    Set
public:
property AmountType^ Group3MaxFlatShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


HandlingTimeEnabled Property

HandlingTimeEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► HandlingTimeEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool HandlingTimeEnabled { get; set; }
Public Property HandlingTimeEnabled As Boolean
    Get
    Set
public:
property bool HandlingTimeEnabled {
    bool get ();
    void set (bool value);
}


HandlingTimeEnabledSpecified Property

HandlingTimeEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► HandlingTimeEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HandlingTimeEnabledSpecified { get; set; }
Public Property HandlingTimeEnabledSpecified As Boolean
    Get
    Set
public:
property bool HandlingTimeEnabledSpecified {
    bool get ();
    void set (bool value);
}


HomePageFeaturedEnabled Property

HomePageFeaturedEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► HomePageFeaturedEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool HomePageFeaturedEnabled { get; set; }
Public Property HomePageFeaturedEnabled As Boolean
    Get
    Set
public:
property bool HomePageFeaturedEnabled {
    bool get ();
    void set (bool value);
}


HomePageFeaturedEnabledSpecified Property

HomePageFeaturedEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► HomePageFeaturedEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HomePageFeaturedEnabledSpecified { get; set; }
Public Property HomePageFeaturedEnabledSpecified As Boolean
    Get
    Set
public:
property bool HomePageFeaturedEnabledSpecified {
    bool get ();
    void set (bool value);
}


INEscrowWorkflowTimeline Property

INEscrowWorkflowTimeline Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► INEscrowWorkflowTimeline
Declaration Syntax
C# Visual Basic Visual C++
public INEscrowWorkflowTimelineCodeType INEscrowWorkflowTimeline { get; set; }
Public Property INEscrowWorkflowTimeline As INEscrowWorkflowTimelineCodeType
    Get
    Set
public:
property INEscrowWorkflowTimelineCodeType INEscrowWorkflowTimeline {
    INEscrowWorkflowTimelineCodeType get ();
    void set (INEscrowWorkflowTimelineCodeType value);
}


INEscrowWorkflowTimelineSpecified Property

INEscrowWorkflowTimelineSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► INEscrowWorkflowTimelineSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool INEscrowWorkflowTimelineSpecified { get; set; }
Public Property INEscrowWorkflowTimelineSpecified As Boolean
    Get
    Set
public:
property bool INEscrowWorkflowTimelineSpecified {
    bool get ();
    void set (bool value);
}


ISBNEnabled Property

ISBNEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ISBNEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ProductIdentiferEnabledCodeType ISBNEnabled { get; set; }
Public Property ISBNEnabled As ProductIdentiferEnabledCodeType
    Get
    Set
public:
property ProductIdentiferEnabledCodeType ISBNEnabled {
    ProductIdentiferEnabledCodeType get ();
    void set (ProductIdentiferEnabledCodeType value);
}


ISBNEnabledSpecified Property

ISBNEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ISBNEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ISBNEnabledSpecified { get; set; }
Public Property ISBNEnabledSpecified As Boolean
    Get
    Set
public:
property bool ISBNEnabledSpecified {
    bool get ();
    void set (bool value);
}


ItemCompatibilityEnabled Property

ItemCompatibilityEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ItemCompatibilityEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityEnabledCodeType ItemCompatibilityEnabled { get; set; }
Public Property ItemCompatibilityEnabled As ItemCompatibilityEnabledCodeType
    Get
    Set
public:
property ItemCompatibilityEnabledCodeType ItemCompatibilityEnabled {
    ItemCompatibilityEnabledCodeType get ();
    void set (ItemCompatibilityEnabledCodeType value);
}


ItemCompatibilityEnabledSpecified Property

ItemCompatibilityEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ItemCompatibilityEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemCompatibilityEnabledSpecified { get; set; }
Public Property ItemCompatibilityEnabledSpecified As Boolean
    Get
    Set
public:
property bool ItemCompatibilityEnabledSpecified {
    bool get ();
    void set (bool value);
}


ItemSpecificsEnabled Property

ItemSpecificsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ItemSpecificsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificsEnabledCodeType ItemSpecificsEnabled { get; set; }
Public Property ItemSpecificsEnabled As ItemSpecificsEnabledCodeType
    Get
    Set
public:
property ItemSpecificsEnabledCodeType ItemSpecificsEnabled {
    ItemSpecificsEnabledCodeType get ();
    void set (ItemSpecificsEnabledCodeType value);
}


ItemSpecificsEnabledSpecified Property

ItemSpecificsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ItemSpecificsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemSpecificsEnabledSpecified { get; set; }
Public Property ItemSpecificsEnabledSpecified As Boolean
    Get
    Set
public:
property bool ItemSpecificsEnabledSpecified {
    bool get ();
    void set (bool value);
}


KTypeSupported Property

KTypeSupported Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► KTypeSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool KTypeSupported { get; set; }
Public Property KTypeSupported As Boolean
    Get
    Set
public:
property bool KTypeSupported {
    bool get ();
    void set (bool value);
}


KTypeSupportedSpecified Property

KTypeSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► KTypeSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool KTypeSupportedSpecified { get; set; }
Public Property KTypeSupportedSpecified As Boolean
    Get
    Set
public:
property bool KTypeSupportedSpecified {
    bool get ();
    void set (bool value);
}


ListingDuration Property

ListingDuration Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ListingDuration
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationReferenceTypeCollection ListingDuration { get; set; }
Public Property ListingDuration As ListingDurationReferenceTypeCollection
    Get
    Set
public:
property ListingDurationReferenceTypeCollection^ ListingDuration {
    ListingDurationReferenceTypeCollection^ get ();
    void set (ListingDurationReferenceTypeCollection^ value);
}


LocalMarketAdFormatEnabled Property

LocalMarketAdFormatEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketAdFormatEnabled
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatEnabledCodeType LocalMarketAdFormatEnabled { get; set; }
Public Property LocalMarketAdFormatEnabled As AdFormatEnabledCodeType
    Get
    Set
public:
property AdFormatEnabledCodeType LocalMarketAdFormatEnabled {
    AdFormatEnabledCodeType get ();
    void set (AdFormatEnabledCodeType value);
}


LocalMarketAdFormatEnabledSpecified Property

LocalMarketAdFormatEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketAdFormatEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketAdFormatEnabledSpecified { get; set; }
Public Property LocalMarketAdFormatEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketAdFormatEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketAutoAcceptEnabled Property

LocalMarketAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketAutoAcceptEnabled { get; set; }
Public Property LocalMarketAutoAcceptEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketAutoAcceptEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketAutoAcceptEnabledSpecified Property

LocalMarketAutoAcceptEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketAutoAcceptEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketAutoAcceptEnabledSpecified { get; set; }
Public Property LocalMarketAutoAcceptEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketAutoAcceptEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketAutoDeclineEnabled Property

LocalMarketAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketAutoDeclineEnabled { get; set; }
Public Property LocalMarketAutoDeclineEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketAutoDeclineEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketAutoDeclineEnabledSpecified Property

LocalMarketAutoDeclineEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketAutoDeclineEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketAutoDeclineEnabledSpecified { get; set; }
Public Property LocalMarketAutoDeclineEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketAutoDeclineEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketBestOfferEnabled Property

LocalMarketBestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketBestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdBestOfferEnabledCodeType LocalMarketBestOfferEnabled { get; set; }
Public Property LocalMarketBestOfferEnabled As ClassifiedAdBestOfferEnabledCodeType
    Get
    Set
public:
property ClassifiedAdBestOfferEnabledCodeType LocalMarketBestOfferEnabled {
    ClassifiedAdBestOfferEnabledCodeType get ();
    void set (ClassifiedAdBestOfferEnabledCodeType value);
}


LocalMarketBestOfferEnabledSpecified Property

LocalMarketBestOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketBestOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketBestOfferEnabledSpecified { get; set; }
Public Property LocalMarketBestOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketBestOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketCompanyNameEnabled Property

LocalMarketCompanyNameEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketCompanyNameEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketCompanyNameEnabled { get; set; }
Public Property LocalMarketCompanyNameEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketCompanyNameEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketCompanyNameEnabledSpecified Property

LocalMarketCompanyNameEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketCompanyNameEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketCompanyNameEnabledSpecified { get; set; }
Public Property LocalMarketCompanyNameEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketCompanyNameEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketContactByAddressEnabled Property

LocalMarketContactByAddressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketContactByAddressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByAddressEnabled { get; set; }
Public Property LocalMarketContactByAddressEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketContactByAddressEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketContactByAddressEnabledSpecified Property

LocalMarketContactByAddressEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketContactByAddressEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByAddressEnabledSpecified { get; set; }
Public Property LocalMarketContactByAddressEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketContactByAddressEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketContactByEmailEnabled Property

LocalMarketContactByEmailEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketContactByEmailEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByEmailEnabled { get; set; }
Public Property LocalMarketContactByEmailEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketContactByEmailEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketContactByEmailEnabledSpecified Property

LocalMarketContactByEmailEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketContactByEmailEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByEmailEnabledSpecified { get; set; }
Public Property LocalMarketContactByEmailEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketContactByEmailEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketContactByPhoneEnabled Property

LocalMarketContactByPhoneEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketContactByPhoneEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByPhoneEnabled { get; set; }
Public Property LocalMarketContactByPhoneEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketContactByPhoneEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketContactByPhoneEnabledSpecified Property

LocalMarketContactByPhoneEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketContactByPhoneEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByPhoneEnabledSpecified { get; set; }
Public Property LocalMarketContactByPhoneEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketContactByPhoneEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketCounterOfferEnabled Property

LocalMarketCounterOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketCounterOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketCounterOfferEnabled { get; set; }
Public Property LocalMarketCounterOfferEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketCounterOfferEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketCounterOfferEnabledSpecified Property

LocalMarketCounterOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketCounterOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketCounterOfferEnabledSpecified { get; set; }
Public Property LocalMarketCounterOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketCounterOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketNonSubscription Property

LocalMarketNonSubscription Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketNonSubscription
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketNonSubscription { get; set; }
Public Property LocalMarketNonSubscription As Boolean
    Get
    Set
public:
property bool LocalMarketNonSubscription {
    bool get ();
    void set (bool value);
}


LocalMarketNonSubscriptionSpecified Property

LocalMarketNonSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketNonSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketNonSubscriptionSpecified { get; set; }
Public Property LocalMarketNonSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketNonSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketPaymentMethodCheckOutEnabled Property

LocalMarketPaymentMethodCheckOutEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketPaymentMethodCheckOutEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPaymentMethodEnabledCodeType LocalMarketPaymentMethodCheckOutEnabled { get; set; }
Public Property LocalMarketPaymentMethodCheckOutEnabled As ClassifiedAdPaymentMethodEnabledCodeType
    Get
    Set
public:
property ClassifiedAdPaymentMethodEnabledCodeType LocalMarketPaymentMethodCheckOutEnabled {
    ClassifiedAdPaymentMethodEnabledCodeType get ();
    void set (ClassifiedAdPaymentMethodEnabledCodeType value);
}


LocalMarketPaymentMethodCheckOutEnabledSpecified Property

LocalMarketPaymentMethodCheckOutEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketPaymentMethodCheckOutEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketPaymentMethodCheckOutEnabledSpecified { get; set; }
Public Property LocalMarketPaymentMethodCheckOutEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketPaymentMethodCheckOutEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketPhoneCount Property

LocalMarketPhoneCount Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketPhoneCount
Declaration Syntax
C# Visual Basic Visual C++
public int LocalMarketPhoneCount { get; set; }
Public Property LocalMarketPhoneCount As Integer
    Get
    Set
public:
property int LocalMarketPhoneCount {
    int get ();
    void set (int value);
}


LocalMarketPhoneCountSpecified Property

LocalMarketPhoneCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketPhoneCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketPhoneCountSpecified { get; set; }
Public Property LocalMarketPhoneCountSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketPhoneCountSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketPremiumSubscription Property

LocalMarketPremiumSubscription Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketPremiumSubscription
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketPremiumSubscription { get; set; }
Public Property LocalMarketPremiumSubscription As Boolean
    Get
    Set
public:
property bool LocalMarketPremiumSubscription {
    bool get ();
    void set (bool value);
}


LocalMarketPremiumSubscriptionSpecified Property

LocalMarketPremiumSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketPremiumSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketPremiumSubscriptionSpecified { get; set; }
Public Property LocalMarketPremiumSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketPremiumSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketRegularSubscription Property

LocalMarketRegularSubscription Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketRegularSubscription
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketRegularSubscription { get; set; }
Public Property LocalMarketRegularSubscription As Boolean
    Get
    Set
public:
property bool LocalMarketRegularSubscription {
    bool get ();
    void set (bool value);
}


LocalMarketRegularSubscriptionSpecified Property

LocalMarketRegularSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketRegularSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketRegularSubscriptionSpecified { get; set; }
Public Property LocalMarketRegularSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketRegularSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketSellerContactDetailsEnabled Property

LocalMarketSellerContactDetailsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketSellerContactDetailsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketSellerContactDetailsEnabled { get; set; }
Public Property LocalMarketSellerContactDetailsEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketSellerContactDetailsEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketSellerContactDetailsEnabledSpecified Property

LocalMarketSellerContactDetailsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketSellerContactDetailsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketSellerContactDetailsEnabledSpecified { get; set; }
Public Property LocalMarketSellerContactDetailsEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketSellerContactDetailsEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketShippingMethodEnabled Property

LocalMarketShippingMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketShippingMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketShippingMethodEnabled { get; set; }
Public Property LocalMarketShippingMethodEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketShippingMethodEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketShippingMethodEnabledSpecified Property

LocalMarketShippingMethodEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketShippingMethodEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketShippingMethodEnabledSpecified { get; set; }
Public Property LocalMarketShippingMethodEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketShippingMethodEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketSpecialitySubscription Property

LocalMarketSpecialitySubscription Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketSpecialitySubscription
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketSpecialitySubscription { get; set; }
Public Property LocalMarketSpecialitySubscription As Boolean
    Get
    Set
public:
property bool LocalMarketSpecialitySubscription {
    bool get ();
    void set (bool value);
}


LocalMarketSpecialitySubscriptionSpecified Property

LocalMarketSpecialitySubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketSpecialitySubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketSpecialitySubscriptionSpecified { get; set; }
Public Property LocalMarketSpecialitySubscriptionSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketSpecialitySubscriptionSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketStreetCount Property

LocalMarketStreetCount Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketStreetCount
Declaration Syntax
C# Visual Basic Visual C++
public int LocalMarketStreetCount { get; set; }
Public Property LocalMarketStreetCount As Integer
    Get
    Set
public:
property int LocalMarketStreetCount {
    int get ();
    void set (int value);
}


LocalMarketStreetCountSpecified Property

LocalMarketStreetCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► LocalMarketStreetCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketStreetCountSpecified { get; set; }
Public Property LocalMarketStreetCountSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketStreetCountSpecified {
    bool get ();
    void set (bool value);
}


MaxFlatShippingCost Property

MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MaxFlatShippingCost { get; set; }
Public Property MaxFlatShippingCost As AmountType
    Get
    Set
public:
property AmountType^ MaxFlatShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


MaxGranularFitmentCount Property

MaxGranularFitmentCount Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► MaxGranularFitmentCount
Declaration Syntax
C# Visual Basic Visual C++
public int MaxGranularFitmentCount { get; set; }
Public Property MaxGranularFitmentCount As Integer
    Get
    Set
public:
property int MaxGranularFitmentCount {
    int get ();
    void set (int value);
}


MaxGranularFitmentCountSpecified Property

MaxGranularFitmentCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► MaxGranularFitmentCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxGranularFitmentCountSpecified { get; set; }
Public Property MaxGranularFitmentCountSpecified As Boolean
    Get
    Set
public:
property bool MaxGranularFitmentCountSpecified {
    bool get ();
    void set (bool value);
}


MaxItemCompatibility Property

MaxItemCompatibility Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► MaxItemCompatibility
Declaration Syntax
C# Visual Basic Visual C++
public int MaxItemCompatibility { get; set; }
Public Property MaxItemCompatibility As Integer
    Get
    Set
public:
property int MaxItemCompatibility {
    int get ();
    void set (int value);
}


MaxItemCompatibilitySpecified Property

MaxItemCompatibilitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► MaxItemCompatibilitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxItemCompatibilitySpecified { get; set; }
Public Property MaxItemCompatibilitySpecified As Boolean
    Get
    Set
public:
property bool MaxItemCompatibilitySpecified {
    bool get ();
    void set (bool value);
}


MinimumReservePrice Property

MinimumReservePrice Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► MinimumReservePrice
Declaration Syntax
C# Visual Basic Visual C++
public double MinimumReservePrice { get; set; }
Public Property MinimumReservePrice As Double
    Get
    Set
public:
property double MinimumReservePrice {
    double get ();
    void set (double value);
}


MinimumReservePriceSpecified Property

MinimumReservePriceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► MinimumReservePriceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinimumReservePriceSpecified { get; set; }
Public Property MinimumReservePriceSpecified As Boolean
    Get
    Set
public:
property bool MinimumReservePriceSpecified {
    bool get ();
    void set (bool value);
}


MinItemCompatibility Property

MinItemCompatibility Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► MinItemCompatibility
Declaration Syntax
C# Visual Basic Visual C++
public int MinItemCompatibility { get; set; }
Public Property MinItemCompatibility As Integer
    Get
    Set
public:
property int MinItemCompatibility {
    int get ();
    void set (int value);
}


MinItemCompatibilitySpecified Property

MinItemCompatibilitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► MinItemCompatibilitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinItemCompatibilitySpecified { get; set; }
Public Property MinItemCompatibilitySpecified As Boolean
    Get
    Set
public:
property bool MinItemCompatibilitySpecified {
    bool get ();
    void set (bool value);
}


NonSubscription Property

NonSubscription Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► NonSubscription
Declaration Syntax
C# Visual Basic Visual C++
public GeographicExposureCodeType NonSubscription { get; set; }
Public Property NonSubscription As GeographicExposureCodeType
    Get
    Set
public:
property GeographicExposureCodeType NonSubscription {
    GeographicExposureCodeType get ();
    void set (GeographicExposureCodeType value);
}


NonSubscriptionSpecified Property

NonSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► NonSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NonSubscriptionSpecified { get; set; }
Public Property NonSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool NonSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


PaisaPayFullEscrowEnabled Property

PaisaPayFullEscrowEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PaisaPayFullEscrowEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool PaisaPayFullEscrowEnabled { get; set; }
Public Property PaisaPayFullEscrowEnabled As Boolean
    Get
    Set
public:
property bool PaisaPayFullEscrowEnabled {
    bool get ();
    void set (bool value);
}


PaisaPayFullEscrowEnabledSpecified Property

PaisaPayFullEscrowEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PaisaPayFullEscrowEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaisaPayFullEscrowEnabledSpecified { get; set; }
Public Property PaisaPayFullEscrowEnabledSpecified As Boolean
    Get
    Set
public:
property bool PaisaPayFullEscrowEnabledSpecified {
    bool get ();
    void set (bool value);
}


PaymentMethod Property

PaymentMethod Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PaymentMethod
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeTypeCollection PaymentMethod { get; set; }
Public Property PaymentMethod As BuyerPaymentMethodCodeTypeCollection
    Get
    Set
public:
property BuyerPaymentMethodCodeTypeCollection^ PaymentMethod {
    BuyerPaymentMethodCodeTypeCollection^ get ();
    void set (BuyerPaymentMethodCodeTypeCollection^ value);
}


PaymentOptionsGroup Property

PaymentOptionsGroup Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PaymentOptionsGroup
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionsGroupEnabledCodeType PaymentOptionsGroup { get; set; }
Public Property PaymentOptionsGroup As PaymentOptionsGroupEnabledCodeType
    Get
    Set
public:
property PaymentOptionsGroupEnabledCodeType PaymentOptionsGroup {
    PaymentOptionsGroupEnabledCodeType get ();
    void set (PaymentOptionsGroupEnabledCodeType value);
}


PaymentOptionsGroupSpecified Property

PaymentOptionsGroupSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PaymentOptionsGroupSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentOptionsGroupSpecified { get; set; }
Public Property PaymentOptionsGroupSpecified As Boolean
    Get
    Set
public:
property bool PaymentOptionsGroupSpecified {
    bool get ();
    void set (bool value);
}


PaymentProfileCategoryGroup Property

PaymentProfileCategoryGroup Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PaymentProfileCategoryGroup
Declaration Syntax
C# Visual Basic Visual C++
public ProfileCategoryGroupCodeType PaymentProfileCategoryGroup { get; set; }
Public Property PaymentProfileCategoryGroup As ProfileCategoryGroupCodeType
    Get
    Set
public:
property ProfileCategoryGroupCodeType PaymentProfileCategoryGroup {
    ProfileCategoryGroupCodeType get ();
    void set (ProfileCategoryGroupCodeType value);
}


PaymentProfileCategoryGroupSpecified Property

PaymentProfileCategoryGroupSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PaymentProfileCategoryGroupSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentProfileCategoryGroupSpecified { get; set; }
Public Property PaymentProfileCategoryGroupSpecified As Boolean
    Get
    Set
public:
property bool PaymentProfileCategoryGroupSpecified {
    bool get ();
    void set (bool value);
}


PayPalBuyerProtectionEnabled Property

PayPalBuyerProtectionEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PayPalBuyerProtectionEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalBuyerProtectionEnabled { get; set; }
Public Property PayPalBuyerProtectionEnabled As Boolean
    Get
    Set
public:
property bool PayPalBuyerProtectionEnabled {
    bool get ();
    void set (bool value);
}


PayPalBuyerProtectionEnabledSpecified Property

PayPalBuyerProtectionEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PayPalBuyerProtectionEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalBuyerProtectionEnabledSpecified { get; set; }
Public Property PayPalBuyerProtectionEnabledSpecified As Boolean
    Get
    Set
public:
property bool PayPalBuyerProtectionEnabledSpecified {
    bool get ();
    void set (bool value);
}


PayPalRequired Property

PayPalRequired Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PayPalRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalRequired { get; set; }
Public Property PayPalRequired As Boolean
    Get
    Set
public:
property bool PayPalRequired {
    bool get ();
    void set (bool value);
}


PayPalRequiredForStoreOwner Property

PayPalRequiredForStoreOwner Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PayPalRequiredForStoreOwner
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalRequiredForStoreOwner { get; set; }
Public Property PayPalRequiredForStoreOwner As Boolean
    Get
    Set
public:
property bool PayPalRequiredForStoreOwner {
    bool get ();
    void set (bool value);
}


PayPalRequiredForStoreOwnerSpecified Property

PayPalRequiredForStoreOwnerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PayPalRequiredForStoreOwnerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalRequiredForStoreOwnerSpecified { get; set; }
Public Property PayPalRequiredForStoreOwnerSpecified As Boolean
    Get
    Set
public:
property bool PayPalRequiredForStoreOwnerSpecified {
    bool get ();
    void set (bool value);
}


PayPalRequiredSpecified Property

PayPalRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PayPalRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalRequiredSpecified { get; set; }
Public Property PayPalRequiredSpecified As Boolean
    Get
    Set
public:
property bool PayPalRequiredSpecified {
    bool get ();
    void set (bool value);
}


PickupDropOffEnabled Property

PickupDropOffEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PickupDropOffEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool PickupDropOffEnabled { get; set; }
Public Property PickupDropOffEnabled As Boolean
    Get
    Set
public:
property bool PickupDropOffEnabled {
    bool get ();
    void set (bool value);
}


PickupDropOffEnabledSpecified Property

PickupDropOffEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PickupDropOffEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PickupDropOffEnabledSpecified { get; set; }
Public Property PickupDropOffEnabledSpecified As Boolean
    Get
    Set
public:
property bool PickupDropOffEnabledSpecified {
    bool get ();
    void set (bool value);
}


PremiumSubscription Property

PremiumSubscription Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PremiumSubscription
Declaration Syntax
C# Visual Basic Visual C++
public GeographicExposureCodeType PremiumSubscription { get; set; }
Public Property PremiumSubscription As GeographicExposureCodeType
    Get
    Set
public:
property GeographicExposureCodeType PremiumSubscription {
    GeographicExposureCodeType get ();
    void set (GeographicExposureCodeType value);
}


PremiumSubscriptionSpecified Property

PremiumSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► PremiumSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PremiumSubscriptionSpecified { get; set; }
Public Property PremiumSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool PremiumSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


ProductCreationEnabled Property

ProductCreationEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ProductCreationEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ProductCreationEnabledCodeType ProductCreationEnabled { get; set; }
Public Property ProductCreationEnabled As ProductCreationEnabledCodeType
    Get
    Set
public:
property ProductCreationEnabledCodeType ProductCreationEnabled {
    ProductCreationEnabledCodeType get ();
    void set (ProductCreationEnabledCodeType value);
}


ProductCreationEnabledSpecified Property

ProductCreationEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ProductCreationEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductCreationEnabledSpecified { get; set; }
Public Property ProductCreationEnabledSpecified As Boolean
    Get
    Set
public:
property bool ProductCreationEnabledSpecified {
    bool get ();
    void set (bool value);
}


ProPackEnabled Property

ProPackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ProPackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ProPackEnabled { get; set; }
Public Property ProPackEnabled As Boolean
    Get
    Set
public:
property bool ProPackEnabled {
    bool get ();
    void set (bool value);
}


ProPackEnabledSpecified Property

ProPackEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ProPackEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProPackEnabledSpecified { get; set; }
Public Property ProPackEnabledSpecified As Boolean
    Get
    Set
public:
property bool ProPackEnabledSpecified {
    bool get ();
    void set (bool value);
}


ProPackPlusEnabled Property

ProPackPlusEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ProPackPlusEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ProPackPlusEnabled { get; set; }
Public Property ProPackPlusEnabled As Boolean
    Get
    Set
public:
property bool ProPackPlusEnabled {
    bool get ();
    void set (bool value);
}


ProPackPlusEnabledSpecified Property

ProPackPlusEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ProPackPlusEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProPackPlusEnabledSpecified { get; set; }
Public Property ProPackPlusEnabledSpecified As Boolean
    Get
    Set
public:
property bool ProPackPlusEnabledSpecified {
    bool get ();
    void set (bool value);
}


RegularSubscription Property

RegularSubscription Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► RegularSubscription
Declaration Syntax
C# Visual Basic Visual C++
public GeographicExposureCodeType RegularSubscription { get; set; }
Public Property RegularSubscription As GeographicExposureCodeType
    Get
    Set
public:
property GeographicExposureCodeType RegularSubscription {
    GeographicExposureCodeType get ();
    void set (GeographicExposureCodeType value);
}


RegularSubscriptionSpecified Property

RegularSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► RegularSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RegularSubscriptionSpecified { get; set; }
Public Property RegularSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool RegularSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


ReturnPolicyEnabled Property

ReturnPolicyEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ReturnPolicyEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnPolicyEnabled { get; set; }
Public Property ReturnPolicyEnabled As Boolean
    Get
    Set
public:
property bool ReturnPolicyEnabled {
    bool get ();
    void set (bool value);
}


ReturnPolicyEnabledSpecified Property

ReturnPolicyEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ReturnPolicyEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnPolicyEnabledSpecified { get; set; }
Public Property ReturnPolicyEnabledSpecified As Boolean
    Get
    Set
public:
property bool ReturnPolicyEnabledSpecified {
    bool get ();
    void set (bool value);
}


ReturnPolicyProfileCategoryGroup Property

ReturnPolicyProfileCategoryGroup Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ReturnPolicyProfileCategoryGroup
Declaration Syntax
C# Visual Basic Visual C++
public ProfileCategoryGroupCodeType ReturnPolicyProfileCategoryGroup { get; set; }
Public Property ReturnPolicyProfileCategoryGroup As ProfileCategoryGroupCodeType
    Get
    Set
public:
property ProfileCategoryGroupCodeType ReturnPolicyProfileCategoryGroup {
    ProfileCategoryGroupCodeType get ();
    void set (ProfileCategoryGroupCodeType value);
}


ReturnPolicyProfileCategoryGroupSpecified Property

ReturnPolicyProfileCategoryGroupSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ReturnPolicyProfileCategoryGroupSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnPolicyProfileCategoryGroupSpecified { get; set; }
Public Property ReturnPolicyProfileCategoryGroupSpecified As Boolean
    Get
    Set
public:
property bool ReturnPolicyProfileCategoryGroupSpecified {
    bool get ();
    void set (bool value);
}


RevisePriceAllowed Property

RevisePriceAllowed Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► RevisePriceAllowed
Declaration Syntax
C# Visual Basic Visual C++
public bool RevisePriceAllowed { get; set; }
Public Property RevisePriceAllowed As Boolean
    Get
    Set
public:
property bool RevisePriceAllowed {
    bool get ();
    void set (bool value);
}


RevisePriceAllowedSpecified Property

RevisePriceAllowedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► RevisePriceAllowedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RevisePriceAllowedSpecified { get; set; }
Public Property RevisePriceAllowedSpecified As Boolean
    Get
    Set
public:
property bool RevisePriceAllowedSpecified {
    bool get ();
    void set (bool value);
}


ReviseQuantityAllowed Property

ReviseQuantityAllowed Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ReviseQuantityAllowed
Declaration Syntax
C# Visual Basic Visual C++
public bool ReviseQuantityAllowed { get; set; }
Public Property ReviseQuantityAllowed As Boolean
    Get
    Set
public:
property bool ReviseQuantityAllowed {
    bool get ();
    void set (bool value);
}


ReviseQuantityAllowedSpecified Property

ReviseQuantityAllowedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ReviseQuantityAllowedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReviseQuantityAllowedSpecified { get; set; }
Public Property ReviseQuantityAllowedSpecified As Boolean
    Get
    Set
public:
property bool ReviseQuantityAllowedSpecified {
    bool get ();
    void set (bool value);
}


SafePaymentRequired Property

SafePaymentRequired Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SafePaymentRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool SafePaymentRequired { get; set; }
Public Property SafePaymentRequired As Boolean
    Get
    Set
public:
property bool SafePaymentRequired {
    bool get ();
    void set (bool value);
}


SafePaymentRequiredSpecified Property

SafePaymentRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SafePaymentRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SafePaymentRequiredSpecified { get; set; }
Public Property SafePaymentRequiredSpecified As Boolean
    Get
    Set
public:
property bool SafePaymentRequiredSpecified {
    bool get ();
    void set (bool value);
}


SellerContactDetailsEnabled Property

SellerContactDetailsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SellerContactDetailsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerContactDetailsEnabled { get; set; }
Public Property SellerContactDetailsEnabled As Boolean
    Get
    Set
public:
property bool SellerContactDetailsEnabled {
    bool get ();
    void set (bool value);
}


SellerContactDetailsEnabledSpecified Property

SellerContactDetailsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SellerContactDetailsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerContactDetailsEnabledSpecified { get; set; }
Public Property SellerContactDetailsEnabledSpecified As Boolean
    Get
    Set
public:
property bool SellerContactDetailsEnabledSpecified {
    bool get ();
    void set (bool value);
}


SellerProvidedTitleSupported Property

SellerProvidedTitleSupported Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SellerProvidedTitleSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerProvidedTitleSupported { get; set; }
Public Property SellerProvidedTitleSupported As Boolean
    Get
    Set
public:
property bool SellerProvidedTitleSupported {
    bool get ();
    void set (bool value);
}


SellerProvidedTitleSupportedSpecified Property

SellerProvidedTitleSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SellerProvidedTitleSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerProvidedTitleSupportedSpecified { get; set; }
Public Property SellerProvidedTitleSupportedSpecified As Boolean
    Get
    Set
public:
property bool SellerProvidedTitleSupportedSpecified {
    bool get ();
    void set (bool value);
}


ShippingProfileCategoryGroup Property

ShippingProfileCategoryGroup Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ShippingProfileCategoryGroup
Declaration Syntax
C# Visual Basic Visual C++
public ProfileCategoryGroupCodeType ShippingProfileCategoryGroup { get; set; }
Public Property ShippingProfileCategoryGroup As ProfileCategoryGroupCodeType
    Get
    Set
public:
property ProfileCategoryGroupCodeType ShippingProfileCategoryGroup {
    ProfileCategoryGroupCodeType get ();
    void set (ProfileCategoryGroupCodeType value);
}


ShippingProfileCategoryGroupSpecified Property

ShippingProfileCategoryGroupSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ShippingProfileCategoryGroupSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingProfileCategoryGroupSpecified { get; set; }
Public Property ShippingProfileCategoryGroupSpecified As Boolean
    Get
    Set
public:
property bool ShippingProfileCategoryGroupSpecified {
    bool get ();
    void set (bool value);
}


ShippingTermsRequired Property

ShippingTermsRequired Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ShippingTermsRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTermsRequired { get; set; }
Public Property ShippingTermsRequired As Boolean
    Get
    Set
public:
property bool ShippingTermsRequired {
    bool get ();
    void set (bool value);
}


ShippingTermsRequiredSpecified Property

ShippingTermsRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ShippingTermsRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTermsRequiredSpecified { get; set; }
Public Property ShippingTermsRequiredSpecified As Boolean
    Get
    Set
public:
property bool ShippingTermsRequiredSpecified {
    bool get ();
    void set (bool value);
}


SkypeMeNonTransactionalEnabled Property

SkypeMeNonTransactionalEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SkypeMeNonTransactionalEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool SkypeMeNonTransactionalEnabled { get; set; }
Public Property SkypeMeNonTransactionalEnabled As Boolean
    Get
    Set
public:
property bool SkypeMeNonTransactionalEnabled {
    bool get ();
    void set (bool value);
}


SkypeMeNonTransactionalEnabledSpecified Property

SkypeMeNonTransactionalEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SkypeMeNonTransactionalEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SkypeMeNonTransactionalEnabledSpecified { get; set; }
Public Property SkypeMeNonTransactionalEnabledSpecified As Boolean
    Get
    Set
public:
property bool SkypeMeNonTransactionalEnabledSpecified {
    bool get ();
    void set (bool value);
}


SkypeMeTransactionalEnabled Property

SkypeMeTransactionalEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SkypeMeTransactionalEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool SkypeMeTransactionalEnabled { get; set; }
Public Property SkypeMeTransactionalEnabled As Boolean
    Get
    Set
public:
property bool SkypeMeTransactionalEnabled {
    bool get ();
    void set (bool value);
}


SkypeMeTransactionalEnabledSpecified Property

SkypeMeTransactionalEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SkypeMeTransactionalEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SkypeMeTransactionalEnabledSpecified { get; set; }
Public Property SkypeMeTransactionalEnabledSpecified As Boolean
    Get
    Set
public:
property bool SkypeMeTransactionalEnabledSpecified {
    bool get ();
    void set (bool value);
}


SpecialitySubscription Property

SpecialitySubscription Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SpecialitySubscription
Declaration Syntax
C# Visual Basic Visual C++
public GeographicExposureCodeType SpecialitySubscription { get; set; }
Public Property SpecialitySubscription As GeographicExposureCodeType
    Get
    Set
public:
property GeographicExposureCodeType SpecialitySubscription {
    GeographicExposureCodeType get ();
    void set (GeographicExposureCodeType value);
}


SpecialitySubscriptionSpecified Property

SpecialitySubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► SpecialitySubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SpecialitySubscriptionSpecified { get; set; }
Public Property SpecialitySubscriptionSpecified As Boolean
    Get
    Set
public:
property bool SpecialitySubscriptionSpecified {
    bool get ();
    void set (bool value);
}


StoreInventoryEnabled Property

StoreInventoryEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► StoreInventoryEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreInventoryEnabled { get; set; }
Public Property StoreInventoryEnabled As Boolean
    Get
    Set
public:
property bool StoreInventoryEnabled {
    bool get ();
    void set (bool value);
}


StoreInventoryEnabledSpecified Property

StoreInventoryEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► StoreInventoryEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreInventoryEnabledSpecified { get; set; }
Public Property StoreInventoryEnabledSpecified As Boolean
    Get
    Set
public:
property bool StoreInventoryEnabledSpecified {
    bool get ();
    void set (bool value);
}


StoreOwnerExtendedListingDurations Property

StoreOwnerExtendedListingDurations Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► StoreOwnerExtendedListingDurations
Declaration Syntax
C# Visual Basic Visual C++
public StoreOwnerExtendedListingDurationsType StoreOwnerExtendedListingDurations { get; set; }
Public Property StoreOwnerExtendedListingDurations As StoreOwnerExtendedListingDurationsType
    Get
    Set
public:
property StoreOwnerExtendedListingDurationsType^ StoreOwnerExtendedListingDurations {
    StoreOwnerExtendedListingDurationsType^ get ();
    void set (StoreOwnerExtendedListingDurationsType^ value);
}


StoreOwnerExtendedListingDurationsEnabled Property

StoreOwnerExtendedListingDurationsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► StoreOwnerExtendedListingDurationsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreOwnerExtendedListingDurationsEnabled { get; set; }
Public Property StoreOwnerExtendedListingDurationsEnabled As Boolean
    Get
    Set
public:
property bool StoreOwnerExtendedListingDurationsEnabled {
    bool get ();
    void set (bool value);
}


StoreOwnerExtendedListingDurationsEnabledSpecified Property

StoreOwnerExtendedListingDurationsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► StoreOwnerExtendedListingDurationsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreOwnerExtendedListingDurationsEnabledSpecified { get; set; }
Public Property StoreOwnerExtendedListingDurationsEnabledSpecified As Boolean
    Get
    Set
public:
property bool StoreOwnerExtendedListingDurationsEnabledSpecified {
    bool get ();
    void set (bool value);
}


TransactionConfirmationRequestEnabled Property

TransactionConfirmationRequestEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► TransactionConfirmationRequestEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool TransactionConfirmationRequestEnabled { get; set; }
Public Property TransactionConfirmationRequestEnabled As Boolean
    Get
    Set
public:
property bool TransactionConfirmationRequestEnabled {
    bool get ();
    void set (bool value);
}


TransactionConfirmationRequestEnabledSpecified Property

TransactionConfirmationRequestEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► TransactionConfirmationRequestEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TransactionConfirmationRequestEnabledSpecified { get; set; }
Public Property TransactionConfirmationRequestEnabledSpecified As Boolean
    Get
    Set
public:
property bool TransactionConfirmationRequestEnabledSpecified {
    bool get ();
    void set (bool value);
}


UPCEnabled Property

UPCEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► UPCEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ProductIdentiferEnabledCodeType UPCEnabled { get; set; }
Public Property UPCEnabled As ProductIdentiferEnabledCodeType
    Get
    Set
public:
property ProductIdentiferEnabledCodeType UPCEnabled {
    ProductIdentiferEnabledCodeType get ();
    void set (ProductIdentiferEnabledCodeType value);
}


UPCEnabledSpecified Property

UPCEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► UPCEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UPCEnabledSpecified { get; set; }
Public Property UPCEnabledSpecified As Boolean
    Get
    Set
public:
property bool UPCEnabledSpecified {
    bool get ();
    void set (bool value);
}


UserConsentRequired Property

UserConsentRequired Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► UserConsentRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool UserConsentRequired { get; set; }
Public Property UserConsentRequired As Boolean
    Get
    Set
public:
property bool UserConsentRequired {
    bool get ();
    void set (bool value);
}


UserConsentRequiredSpecified Property

UserConsentRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► UserConsentRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UserConsentRequiredSpecified { get; set; }
Public Property UserConsentRequiredSpecified As Boolean
    Get
    Set
public:
property bool UserConsentRequiredSpecified {
    bool get ();
    void set (bool value);
}


ValueCategory Property

ValueCategory Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ValueCategory
Declaration Syntax
C# Visual Basic Visual C++
public bool ValueCategory { get; set; }
Public Property ValueCategory As Boolean
    Get
    Set
public:
property bool ValueCategory {
    bool get ();
    void set (bool value);
}


ValueCategorySpecified Property

ValueCategorySpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ValueCategorySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ValueCategorySpecified { get; set; }
Public Property ValueCategorySpecified As Boolean
    Get
    Set
public:
property bool ValueCategorySpecified {
    bool get ();
    void set (bool value);
}


ValuePackEnabled Property

ValuePackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ValuePackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ValuePackEnabled { get; set; }
Public Property ValuePackEnabled As Boolean
    Get
    Set
public:
property bool ValuePackEnabled {
    bool get ();
    void set (bool value);
}


ValuePackEnabledSpecified Property

ValuePackEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► ValuePackEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ValuePackEnabledSpecified { get; set; }
Public Property ValuePackEnabledSpecified As Boolean
    Get
    Set
public:
property bool ValuePackEnabledSpecified {
    bool get ();
    void set (bool value);
}


VariationsEnabled Property

VariationsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► VariationsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool VariationsEnabled { get; set; }
Public Property VariationsEnabled As Boolean
    Get
    Set
public:
property bool VariationsEnabled {
    bool get ();
    void set (bool value);
}


VariationsEnabledSpecified Property

VariationsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► VariationsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VariationsEnabledSpecified { get; set; }
Public Property VariationsEnabledSpecified As Boolean
    Get
    Set
public:
property bool VariationsEnabledSpecified {
    bool get ();
    void set (bool value);
}


VINSupported Property

VINSupported Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► VINSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool VINSupported { get; set; }
Public Property VINSupported As Boolean
    Get
    Set
public:
property bool VINSupported {
    bool get ();
    void set (bool value);
}


VINSupportedSpecified Property

VINSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► VINSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VINSupportedSpecified { get; set; }
Public Property VINSupportedSpecified As Boolean
    Get
    Set
public:
property bool VINSupportedSpecified {
    bool get ();
    void set (bool value);
}


VRMSupported Property

VRMSupported Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► VRMSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool VRMSupported { get; set; }
Public Property VRMSupported As Boolean
    Get
    Set
public:
property bool VRMSupported {
    bool get ();
    void set (bool value);
}


VRMSupportedSpecified Property

VRMSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureType ► VRMSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VRMSupportedSpecified { get; set; }
Public Property VRMSupportedSpecified As Boolean
    Get
    Set
public:
property bool VRMSupportedSpecified {
    bool get ();
    void set (bool value);
}


CategoryFeatureTypeCollection Class

CategoryFeatureTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CategoryFeatureTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CategoryFeatureTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CategoryFeatureTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoryFeatureTypeCollection()()()() |
 | CategoryFeatureTypeCollection(array<CategoryFeatureType>[]()[][]) |
 | CategoryFeatureTypeCollection(CategoryFeatureTypeCollection) |
 | Add(CategoryFeatureType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CategoryFeatureType>[]()[][]) |
 | AddRange(CategoryFeatureTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CategoryFeatureType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CategoryFeatureType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CategoryFeatureType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CategoryFeatureType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CategoryFeatureType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CategoryFeatureTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► Add(CategoryFeatureType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CategoryFeatureType item
)
Public Function Add ( _
    item As CategoryFeatureType _
) As Integer
public:
int Add(
    CategoryFeatureType^ item
)
Parameters
item (CategoryFeatureType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CategoryFeatureType>[]()[][]) |
 | AddRange(CategoryFeatureTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► AddRange(array<CategoryFeatureType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CategoryFeatureType[] items
)
Public Sub AddRange ( _
    items As CategoryFeatureType() _
)
public:
void AddRange(
    array<CategoryFeatureType^>^ items
)
Parameters
items (array< CategoryFeatureType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► AddRange(CategoryFeatureTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CategoryFeatureTypeCollection items
)
Public Sub AddRange ( _
    items As CategoryFeatureTypeCollection _
)
public:
void AddRange(
    CategoryFeatureTypeCollection^ items
)
Parameters
items (CategoryFeatureTypeCollection)


CategoryFeatureTypeCollection Constructor

CategoryFeatureTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► CategoryFeatureTypeCollection()()()()
Members
Icon | Member | Description
 | CategoryFeatureTypeCollection()()()() |
 | CategoryFeatureTypeCollection(array<CategoryFeatureType>[]()[][]) |
 | CategoryFeatureTypeCollection(CategoryFeatureTypeCollection) |


CategoryFeatureTypeCollection Constructor

CategoryFeatureTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► CategoryFeatureTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureTypeCollection()
Public Sub New
public:
CategoryFeatureTypeCollection()


CategoryFeatureTypeCollection Constructor (items)

CategoryFeatureTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► CategoryFeatureTypeCollection(array<CategoryFeatureType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureTypeCollection(
    CategoryFeatureType[] items
)
Public Sub New ( _
    items As CategoryFeatureType() _
)
public:
CategoryFeatureTypeCollection(
    array<CategoryFeatureType^>^ items
)
Parameters
items (array< CategoryFeatureType >[]()[][])


CategoryFeatureTypeCollection Constructor (items)

CategoryFeatureTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► CategoryFeatureTypeCollection(CategoryFeatureTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureTypeCollection(
    CategoryFeatureTypeCollection items
)
Public Sub New ( _
    items As CategoryFeatureTypeCollection _
)
public:
CategoryFeatureTypeCollection(
    CategoryFeatureTypeCollection^ items
)
Parameters
items (CategoryFeatureTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► Contains(CategoryFeatureType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CategoryFeatureType item
)
Public Function Contains ( _
    item As CategoryFeatureType _
) As Boolean
public:
bool Contains(
    CategoryFeatureType^ item
)
Parameters
item (CategoryFeatureType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► CopyTo(array<CategoryFeatureType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CategoryFeatureType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CategoryFeatureType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CategoryFeatureType^>^ items,
    int index
)
Parameters
items (array< CategoryFeatureType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► IndexOf(CategoryFeatureType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CategoryFeatureType item
)
Public Function IndexOf ( _
    item As CategoryFeatureType _
) As Integer
public:
int IndexOf(
    CategoryFeatureType^ item
)
Parameters
item (CategoryFeatureType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► Insert(Int32, CategoryFeatureType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CategoryFeatureType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CategoryFeatureType _
)
public:
void Insert(
    int index,
    CategoryFeatureType^ item
)
Parameters
index (Int32)
item (CategoryFeatureType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CategoryFeatureType
    Get
    Set
public:
property CategoryFeatureType^ default[int index] {
    CategoryFeatureType^ get (int index);
    void set (int index, CategoryFeatureType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CategoryFeatureType
public:
CategoryFeatureType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► Remove(CategoryFeatureType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CategoryFeatureType item
)
Public Sub Remove ( _
    item As CategoryFeatureType _
)
public:
void Remove(
    CategoryFeatureType^ item
)
Parameters
item (CategoryFeatureType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureType[] ToArray()
Public Function ToArray As CategoryFeatureType()
public:
array<CategoryFeatureType^>^ ToArray()
Return Value


CategoryGroupType Class

CategoryGroupType Class
Namespaces ► eBay.Service.Core.Soap ► CategoryGroupType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CategoryGroupType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CategoryGroupType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CategoryGroupType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoryGroupType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsDefault |
 | IsDefaultSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CategoryGroupType


CategoryGroupType Constructor

CategoryGroupType Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryGroupType ► CategoryGroupType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryGroupType()
Public Sub New
public:
CategoryGroupType()


IsDefault Property

IsDefault Property
Namespaces ► eBay.Service.Core.Soap ► CategoryGroupType ► IsDefault
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDefault { get; set; }
Public Property IsDefault As Boolean
    Get
    Set
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}


IsDefaultSpecified Property

IsDefaultSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryGroupType ► IsDefaultSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDefaultSpecified { get; set; }
Public Property IsDefaultSpecified As Boolean
    Get
    Set
public:
property bool IsDefaultSpecified {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► CategoryGroupType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


CategoryItemSpecificsType Class

CategoryItemSpecificsType Class
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CategoryItemSpecificsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CategoryItemSpecificsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CategoryItemSpecificsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoryItemSpecificsType()()()() |
 | Any |
 | CategoryID |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemSpecifics |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CategoryItemSpecificsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


CategoryItemSpecificsType Constructor

CategoryItemSpecificsType Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsType ► CategoryItemSpecificsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryItemSpecificsType()
Public Sub New
public:
CategoryItemSpecificsType()


ItemSpecifics Property

ItemSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsType ► ItemSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection ItemSpecifics { get; set; }
Public Property ItemSpecifics As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ ItemSpecifics {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


CategoryItemSpecificsTypeCollection Class

CategoryItemSpecificsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CategoryItemSpecificsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CategoryItemSpecificsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CategoryItemSpecificsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoryItemSpecificsTypeCollection()()()() |
 | CategoryItemSpecificsTypeCollection(array<CategoryItemSpecificsType>[]()[][]) |
 | CategoryItemSpecificsTypeCollection(CategoryItemSpecificsTypeCollection) |
 | Add(CategoryItemSpecificsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CategoryItemSpecificsType>[]()[][]) |
 | AddRange(CategoryItemSpecificsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CategoryItemSpecificsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CategoryItemSpecificsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CategoryItemSpecificsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CategoryItemSpecificsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CategoryItemSpecificsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CategoryItemSpecificsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► Add(CategoryItemSpecificsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CategoryItemSpecificsType item
)
Public Function Add ( _
    item As CategoryItemSpecificsType _
) As Integer
public:
int Add(
    CategoryItemSpecificsType^ item
)
Parameters
item (CategoryItemSpecificsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CategoryItemSpecificsType>[]()[][]) |
 | AddRange(CategoryItemSpecificsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► AddRange(array<CategoryItemSpecificsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CategoryItemSpecificsType[] items
)
Public Sub AddRange ( _
    items As CategoryItemSpecificsType() _
)
public:
void AddRange(
    array<CategoryItemSpecificsType^>^ items
)
Parameters
items (array< CategoryItemSpecificsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► AddRange(CategoryItemSpecificsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CategoryItemSpecificsTypeCollection items
)
Public Sub AddRange ( _
    items As CategoryItemSpecificsTypeCollection _
)
public:
void AddRange(
    CategoryItemSpecificsTypeCollection^ items
)
Parameters
items (CategoryItemSpecificsTypeCollection)


CategoryItemSpecificsTypeCollection Constructor

CategoryItemSpecificsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► CategoryItemSpecificsTypeCollection()()()()
Members
Icon | Member | Description
 | CategoryItemSpecificsTypeCollection()()()() |
 | CategoryItemSpecificsTypeCollection(array<CategoryItemSpecificsType>[]()[][]) |
 | CategoryItemSpecificsTypeCollection(CategoryItemSpecificsTypeCollection) |


CategoryItemSpecificsTypeCollection Constructor

CategoryItemSpecificsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► CategoryItemSpecificsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryItemSpecificsTypeCollection()
Public Sub New
public:
CategoryItemSpecificsTypeCollection()


CategoryItemSpecificsTypeCollection Constructor (items)

CategoryItemSpecificsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► CategoryItemSpecificsTypeCollection(array<CategoryItemSpecificsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CategoryItemSpecificsTypeCollection(
    CategoryItemSpecificsType[] items
)
Public Sub New ( _
    items As CategoryItemSpecificsType() _
)
public:
CategoryItemSpecificsTypeCollection(
    array<CategoryItemSpecificsType^>^ items
)
Parameters
items (array< CategoryItemSpecificsType >[]()[][])


CategoryItemSpecificsTypeCollection Constructor (items)

CategoryItemSpecificsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► CategoryItemSpecificsTypeCollection(CategoryItemSpecificsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CategoryItemSpecificsTypeCollection(
    CategoryItemSpecificsTypeCollection items
)
Public Sub New ( _
    items As CategoryItemSpecificsTypeCollection _
)
public:
CategoryItemSpecificsTypeCollection(
    CategoryItemSpecificsTypeCollection^ items
)
Parameters
items (CategoryItemSpecificsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► Contains(CategoryItemSpecificsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CategoryItemSpecificsType item
)
Public Function Contains ( _
    item As CategoryItemSpecificsType _
) As Boolean
public:
bool Contains(
    CategoryItemSpecificsType^ item
)
Parameters
item (CategoryItemSpecificsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► CopyTo(array<CategoryItemSpecificsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CategoryItemSpecificsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CategoryItemSpecificsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CategoryItemSpecificsType^>^ items,
    int index
)
Parameters
items (array< CategoryItemSpecificsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► IndexOf(CategoryItemSpecificsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CategoryItemSpecificsType item
)
Public Function IndexOf ( _
    item As CategoryItemSpecificsType _
) As Integer
public:
int IndexOf(
    CategoryItemSpecificsType^ item
)
Parameters
item (CategoryItemSpecificsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► Insert(Int32, CategoryItemSpecificsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CategoryItemSpecificsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CategoryItemSpecificsType _
)
public:
void Insert(
    int index,
    CategoryItemSpecificsType^ item
)
Parameters
index (Int32)
item (CategoryItemSpecificsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CategoryItemSpecificsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CategoryItemSpecificsType
    Get
    Set
public:
property CategoryItemSpecificsType^ default[int index] {
    CategoryItemSpecificsType^ get (int index);
    void set (int index, CategoryItemSpecificsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CategoryItemSpecificsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CategoryItemSpecificsType
public:
CategoryItemSpecificsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► Remove(CategoryItemSpecificsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CategoryItemSpecificsType item
)
Public Sub Remove ( _
    item As CategoryItemSpecificsType _
)
public:
void Remove(
    CategoryItemSpecificsType^ item
)
Parameters
item (CategoryItemSpecificsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryItemSpecificsType[] ToArray()
Public Function ToArray As CategoryItemSpecificsType()
public:
array<CategoryItemSpecificsType^>^ ToArray()
Return Value


CategoryMappingType Class

CategoryMappingType Class
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CategoryMappingType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CategoryMappingType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CategoryMappingType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoryMappingType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | id |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | oldID |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CategoryMappingType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CategoryMappingType Constructor

CategoryMappingType Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingType ► CategoryMappingType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryMappingType()
Public Sub New
public:
CategoryMappingType()


id Property

id Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingType ► id
Declaration Syntax
C# Visual Basic Visual C++
public string id { get; set; }
Public Property id As String
    Get
    Set
public:
property String^ id {
    String^ get ();
    void set (String^ value);
}


oldID Property

oldID Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingType ► oldID
Declaration Syntax
C# Visual Basic Visual C++
public string oldID { get; set; }
Public Property oldID As String
    Get
    Set
public:
property String^ oldID {
    String^ get ();
    void set (String^ value);
}


CategoryMappingTypeCollection Class

CategoryMappingTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CategoryMappingTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CategoryMappingTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CategoryMappingTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoryMappingTypeCollection()()()() |
 | CategoryMappingTypeCollection(array<CategoryMappingType>[]()[][]) |
 | CategoryMappingTypeCollection(CategoryMappingTypeCollection) |
 | Add(CategoryMappingType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CategoryMappingType>[]()[][]) |
 | AddRange(CategoryMappingTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CategoryMappingType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CategoryMappingType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CategoryMappingType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CategoryMappingType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CategoryMappingType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CategoryMappingTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► Add(CategoryMappingType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CategoryMappingType item
)
Public Function Add ( _
    item As CategoryMappingType _
) As Integer
public:
int Add(
    CategoryMappingType^ item
)
Parameters
item (CategoryMappingType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CategoryMappingType>[]()[][]) |
 | AddRange(CategoryMappingTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► AddRange(array<CategoryMappingType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CategoryMappingType[] items
)
Public Sub AddRange ( _
    items As CategoryMappingType() _
)
public:
void AddRange(
    array<CategoryMappingType^>^ items
)
Parameters
items (array< CategoryMappingType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► AddRange(CategoryMappingTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CategoryMappingTypeCollection items
)
Public Sub AddRange ( _
    items As CategoryMappingTypeCollection _
)
public:
void AddRange(
    CategoryMappingTypeCollection^ items
)
Parameters
items (CategoryMappingTypeCollection)


CategoryMappingTypeCollection Constructor

CategoryMappingTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► CategoryMappingTypeCollection()()()()
Members
Icon | Member | Description
 | CategoryMappingTypeCollection()()()() |
 | CategoryMappingTypeCollection(array<CategoryMappingType>[]()[][]) |
 | CategoryMappingTypeCollection(CategoryMappingTypeCollection) |


CategoryMappingTypeCollection Constructor

CategoryMappingTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► CategoryMappingTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryMappingTypeCollection()
Public Sub New
public:
CategoryMappingTypeCollection()


CategoryMappingTypeCollection Constructor (items)

CategoryMappingTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► CategoryMappingTypeCollection(array<CategoryMappingType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CategoryMappingTypeCollection(
    CategoryMappingType[] items
)
Public Sub New ( _
    items As CategoryMappingType() _
)
public:
CategoryMappingTypeCollection(
    array<CategoryMappingType^>^ items
)
Parameters
items (array< CategoryMappingType >[]()[][])


CategoryMappingTypeCollection Constructor (items)

CategoryMappingTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► CategoryMappingTypeCollection(CategoryMappingTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CategoryMappingTypeCollection(
    CategoryMappingTypeCollection items
)
Public Sub New ( _
    items As CategoryMappingTypeCollection _
)
public:
CategoryMappingTypeCollection(
    CategoryMappingTypeCollection^ items
)
Parameters
items (CategoryMappingTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► Contains(CategoryMappingType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CategoryMappingType item
)
Public Function Contains ( _
    item As CategoryMappingType _
) As Boolean
public:
bool Contains(
    CategoryMappingType^ item
)
Parameters
item (CategoryMappingType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► CopyTo(array<CategoryMappingType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CategoryMappingType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CategoryMappingType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CategoryMappingType^>^ items,
    int index
)
Parameters
items (array< CategoryMappingType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► IndexOf(CategoryMappingType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CategoryMappingType item
)
Public Function IndexOf ( _
    item As CategoryMappingType _
) As Integer
public:
int IndexOf(
    CategoryMappingType^ item
)
Parameters
item (CategoryMappingType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► Insert(Int32, CategoryMappingType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CategoryMappingType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CategoryMappingType _
)
public:
void Insert(
    int index,
    CategoryMappingType^ item
)
Parameters
index (Int32)
item (CategoryMappingType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CategoryMappingType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CategoryMappingType
    Get
    Set
public:
property CategoryMappingType^ default[int index] {
    CategoryMappingType^ get (int index);
    void set (int index, CategoryMappingType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CategoryMappingType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CategoryMappingType
public:
CategoryMappingType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► Remove(CategoryMappingType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CategoryMappingType item
)
Public Sub Remove ( _
    item As CategoryMappingType _
)
public:
void Remove(
    CategoryMappingType^ item
)
Parameters
item (CategoryMappingType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryMappingType[] ToArray()
Public Function ToArray As CategoryMappingType()
public:
array<CategoryMappingType^>^ ToArray()
Return Value


CategoryType Class

CategoryType Class
Namespaces ► eBay.Service.Core.Soap ► CategoryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CategoryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CategoryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CategoryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoryType()()()() |
 | Any |
 | AutoPayEnabled |
 | AutoPayEnabledSpecified |
 | B2BVATEnabled |
 | B2BVATEnabledSpecified |
 | BestOfferEnabled |
 | BestOfferEnabledSpecified |
 | CatalogEnabled |
 | CatalogEnabledSpecified |
 | CategoryID |
 | CategoryLevel |
 | CategoryLevelSpecified |
 | CategoryName |
 | CategoryParentID |
 | CategoryParentName |
 | CharacteristicsSets |
 | Equals(Object) | (Inherited from Object.)
 | Expired |
 | ExpiredSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IntlAutosFixedCat |
 | IntlAutosFixedCatSpecified |
 | Keywords |
 | LeafCategory |
 | LeafCategorySpecified |
 | LSD |
 | LSDSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumOfItems |
 | NumOfItemsSpecified |
 | ORPA |
 | ORPASpecified |
 | ORRA |
 | ORRASpecified |
 | ProductFinderIDs |
 | ProductSearchPageAvailable |
 | ProductSearchPageAvailableSpecified |
 | SellerGuaranteeEligible |
 | SellerGuaranteeEligibleSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Virtual |
 | VirtualSpecified |
Remarks
Inheritance Hierarchy
Object
CategoryType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AutoPayEnabled Property

AutoPayEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► AutoPayEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPayEnabled { get; set; }
Public Property AutoPayEnabled As Boolean
    Get
    Set
public:
property bool AutoPayEnabled {
    bool get ();
    void set (bool value);
}


AutoPayEnabledSpecified Property

AutoPayEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► AutoPayEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPayEnabledSpecified { get; set; }
Public Property AutoPayEnabledSpecified As Boolean
    Get
    Set
public:
property bool AutoPayEnabledSpecified {
    bool get ();
    void set (bool value);
}


B2BVATEnabled Property

B2BVATEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► B2BVATEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool B2BVATEnabled { get; set; }
Public Property B2BVATEnabled As Boolean
    Get
    Set
public:
property bool B2BVATEnabled {
    bool get ();
    void set (bool value);
}


B2BVATEnabledSpecified Property

B2BVATEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► B2BVATEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool B2BVATEnabledSpecified { get; set; }
Public Property B2BVATEnabledSpecified As Boolean
    Get
    Set
public:
property bool B2BVATEnabledSpecified {
    bool get ();
    void set (bool value);
}


BestOfferEnabled Property

BestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► BestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferEnabled { get; set; }
Public Property BestOfferEnabled As Boolean
    Get
    Set
public:
property bool BestOfferEnabled {
    bool get ();
    void set (bool value);
}


BestOfferEnabledSpecified Property

BestOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► BestOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferEnabledSpecified { get; set; }
Public Property BestOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool BestOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


CatalogEnabled Property

CatalogEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► CatalogEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CatalogEnabled { get; set; }
Public Property CatalogEnabled As Boolean
    Get
    Set
public:
property bool CatalogEnabled {
    bool get ();
    void set (bool value);
}


CatalogEnabledSpecified Property

CatalogEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► CatalogEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CatalogEnabledSpecified { get; set; }
Public Property CatalogEnabledSpecified As Boolean
    Get
    Set
public:
property bool CatalogEnabledSpecified {
    bool get ();
    void set (bool value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


CategoryLevel Property

CategoryLevel Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► CategoryLevel
Declaration Syntax
C# Visual Basic Visual C++
public int CategoryLevel { get; set; }
Public Property CategoryLevel As Integer
    Get
    Set
public:
property int CategoryLevel {
    int get ();
    void set (int value);
}


CategoryLevelSpecified Property

CategoryLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► CategoryLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CategoryLevelSpecified { get; set; }
Public Property CategoryLevelSpecified As Boolean
    Get
    Set
public:
property bool CategoryLevelSpecified {
    bool get ();
    void set (bool value);
}


CategoryName Property

CategoryName Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► CategoryName
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryName { get; set; }
Public Property CategoryName As String
    Get
    Set
public:
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}


CategoryParentID Property

CategoryParentID Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► CategoryParentID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection CategoryParentID { get; set; }
Public Property CategoryParentID As StringCollection
    Get
    Set
public:
property StringCollection^ CategoryParentID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


CategoryParentName Property

CategoryParentName Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► CategoryParentName
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection CategoryParentName { get; set; }
Public Property CategoryParentName As StringCollection
    Get
    Set
public:
property StringCollection^ CategoryParentName {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


CategoryType Constructor

CategoryType Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► CategoryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryType()
Public Sub New
public:
CategoryType()


CharacteristicsSets Property

CharacteristicsSets Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► CharacteristicsSets
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicsSetTypeCollection CharacteristicsSets { get; set; }
Public Property CharacteristicsSets As CharacteristicsSetTypeCollection
    Get
    Set
public:
property CharacteristicsSetTypeCollection^ CharacteristicsSets {
    CharacteristicsSetTypeCollection^ get ();
    void set (CharacteristicsSetTypeCollection^ value);
}


Expired Property

Expired Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► Expired
Declaration Syntax
C# Visual Basic Visual C++
public bool Expired { get; set; }
Public Property Expired As Boolean
    Get
    Set
public:
property bool Expired {
    bool get ();
    void set (bool value);
}


ExpiredSpecified Property

ExpiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► ExpiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpiredSpecified { get; set; }
Public Property ExpiredSpecified As Boolean
    Get
    Set
public:
property bool ExpiredSpecified {
    bool get ();
    void set (bool value);
}


IntlAutosFixedCat Property

IntlAutosFixedCat Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► IntlAutosFixedCat
Declaration Syntax
C# Visual Basic Visual C++
public bool IntlAutosFixedCat { get; set; }
Public Property IntlAutosFixedCat As Boolean
    Get
    Set
public:
property bool IntlAutosFixedCat {
    bool get ();
    void set (bool value);
}


IntlAutosFixedCatSpecified Property

IntlAutosFixedCatSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► IntlAutosFixedCatSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IntlAutosFixedCatSpecified { get; set; }
Public Property IntlAutosFixedCatSpecified As Boolean
    Get
    Set
public:
property bool IntlAutosFixedCatSpecified {
    bool get ();
    void set (bool value);
}


Keywords Property

Keywords Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► Keywords
Declaration Syntax
C# Visual Basic Visual C++
public string Keywords { get; set; }
Public Property Keywords As String
    Get
    Set
public:
property String^ Keywords {
    String^ get ();
    void set (String^ value);
}


LeafCategory Property

LeafCategory Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► LeafCategory
Declaration Syntax
C# Visual Basic Visual C++
public bool LeafCategory { get; set; }
Public Property LeafCategory As Boolean
    Get
    Set
public:
property bool LeafCategory {
    bool get ();
    void set (bool value);
}


LeafCategorySpecified Property

LeafCategorySpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► LeafCategorySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LeafCategorySpecified { get; set; }
Public Property LeafCategorySpecified As Boolean
    Get
    Set
public:
property bool LeafCategorySpecified {
    bool get ();
    void set (bool value);
}


LSD Property

LSD Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► LSD
Declaration Syntax
C# Visual Basic Visual C++
public bool LSD { get; set; }
Public Property LSD As Boolean
    Get
    Set
public:
property bool LSD {
    bool get ();
    void set (bool value);
}


LSDSpecified Property

LSDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► LSDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LSDSpecified { get; set; }
Public Property LSDSpecified As Boolean
    Get
    Set
public:
property bool LSDSpecified {
    bool get ();
    void set (bool value);
}


NumOfItems Property

NumOfItems Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► NumOfItems
Declaration Syntax
C# Visual Basic Visual C++
public int NumOfItems { get; set; }
Public Property NumOfItems As Integer
    Get
    Set
public:
property int NumOfItems {
    int get ();
    void set (int value);
}


NumOfItemsSpecified Property

NumOfItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► NumOfItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NumOfItemsSpecified { get; set; }
Public Property NumOfItemsSpecified As Boolean
    Get
    Set
public:
property bool NumOfItemsSpecified {
    bool get ();
    void set (bool value);
}


ORPA Property

ORPA Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► ORPA
Declaration Syntax
C# Visual Basic Visual C++
public bool ORPA { get; set; }
Public Property ORPA As Boolean
    Get
    Set
public:
property bool ORPA {
    bool get ();
    void set (bool value);
}


ORPASpecified Property

ORPASpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► ORPASpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ORPASpecified { get; set; }
Public Property ORPASpecified As Boolean
    Get
    Set
public:
property bool ORPASpecified {
    bool get ();
    void set (bool value);
}


ORRA Property

ORRA Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► ORRA
Declaration Syntax
C# Visual Basic Visual C++
public bool ORRA { get; set; }
Public Property ORRA As Boolean
    Get
    Set
public:
property bool ORRA {
    bool get ();
    void set (bool value);
}


ORRASpecified Property

ORRASpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► ORRASpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ORRASpecified { get; set; }
Public Property ORRASpecified As Boolean
    Get
    Set
public:
property bool ORRASpecified {
    bool get ();
    void set (bool value);
}


ProductFinderIDs Property

ProductFinderIDs Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► ProductFinderIDs
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedProductFinderIDTypeCollection ProductFinderIDs { get; set; }
Public Property ProductFinderIDs As ExtendedProductFinderIDTypeCollection
    Get
    Set
public:
property ExtendedProductFinderIDTypeCollection^ ProductFinderIDs {
    ExtendedProductFinderIDTypeCollection^ get ();
    void set (ExtendedProductFinderIDTypeCollection^ value);
}


ProductSearchPageAvailable Property

ProductSearchPageAvailable Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► ProductSearchPageAvailable
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductSearchPageAvailable { get; set; }
Public Property ProductSearchPageAvailable As Boolean
    Get
    Set
public:
property bool ProductSearchPageAvailable {
    bool get ();
    void set (bool value);
}


ProductSearchPageAvailableSpecified Property

ProductSearchPageAvailableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► ProductSearchPageAvailableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductSearchPageAvailableSpecified { get; set; }
Public Property ProductSearchPageAvailableSpecified As Boolean
    Get
    Set
public:
property bool ProductSearchPageAvailableSpecified {
    bool get ();
    void set (bool value);
}


SellerGuaranteeEligible Property

SellerGuaranteeEligible Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► SellerGuaranteeEligible
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerGuaranteeEligible { get; set; }
Public Property SellerGuaranteeEligible As Boolean
    Get
    Set
public:
property bool SellerGuaranteeEligible {
    bool get ();
    void set (bool value);
}


SellerGuaranteeEligibleSpecified Property

SellerGuaranteeEligibleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► SellerGuaranteeEligibleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerGuaranteeEligibleSpecified { get; set; }
Public Property SellerGuaranteeEligibleSpecified As Boolean
    Get
    Set
public:
property bool SellerGuaranteeEligibleSpecified {
    bool get ();
    void set (bool value);
}


Virtual Property

Virtual Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► Virtual
Declaration Syntax
C# Visual Basic Visual C++
public bool Virtual { get; set; }
Public Property Virtual As Boolean
    Get
    Set
public:
property bool Virtual {
    bool get ();
    void set (bool value);
}


VirtualSpecified Property

VirtualSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CategoryType ► VirtualSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VirtualSpecified { get; set; }
Public Property VirtualSpecified As Boolean
    Get
    Set
public:
property bool VirtualSpecified {
    bool get ();
    void set (bool value);
}


CategoryTypeCollection Class

CategoryTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CategoryTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CategoryTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CategoryTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoryTypeCollection()()()() |
 | CategoryTypeCollection(array<CategoryType>[]()[][]) |
 | CategoryTypeCollection(CategoryTypeCollection) |
 | Add(CategoryType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CategoryType>[]()[][]) |
 | AddRange(CategoryTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CategoryType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CategoryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CategoryType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CategoryType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CategoryType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CategoryTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► Add(CategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CategoryType item
)
Public Function Add ( _
    item As CategoryType _
) As Integer
public:
int Add(
    CategoryType^ item
)
Parameters
item (CategoryType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CategoryType>[]()[][]) |
 | AddRange(CategoryTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► AddRange(array<CategoryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CategoryType[] items
)
Public Sub AddRange ( _
    items As CategoryType() _
)
public:
void AddRange(
    array<CategoryType^>^ items
)
Parameters
items (array< CategoryType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► AddRange(CategoryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CategoryTypeCollection items
)
Public Sub AddRange ( _
    items As CategoryTypeCollection _
)
public:
void AddRange(
    CategoryTypeCollection^ items
)
Parameters
items (CategoryTypeCollection)


CategoryTypeCollection Constructor

CategoryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► CategoryTypeCollection()()()()
Members
Icon | Member | Description
 | CategoryTypeCollection()()()() |
 | CategoryTypeCollection(array<CategoryType>[]()[][]) |
 | CategoryTypeCollection(CategoryTypeCollection) |


CategoryTypeCollection Constructor

CategoryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► CategoryTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryTypeCollection()
Public Sub New
public:
CategoryTypeCollection()


CategoryTypeCollection Constructor (items)

CategoryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► CategoryTypeCollection(array<CategoryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CategoryTypeCollection(
    CategoryType[] items
)
Public Sub New ( _
    items As CategoryType() _
)
public:
CategoryTypeCollection(
    array<CategoryType^>^ items
)
Parameters
items (array< CategoryType >[]()[][])


CategoryTypeCollection Constructor (items)

CategoryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► CategoryTypeCollection(CategoryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CategoryTypeCollection(
    CategoryTypeCollection items
)
Public Sub New ( _
    items As CategoryTypeCollection _
)
public:
CategoryTypeCollection(
    CategoryTypeCollection^ items
)
Parameters
items (CategoryTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► Contains(CategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CategoryType item
)
Public Function Contains ( _
    item As CategoryType _
) As Boolean
public:
bool Contains(
    CategoryType^ item
)
Parameters
item (CategoryType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► CopyTo(array<CategoryType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CategoryType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CategoryType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CategoryType^>^ items,
    int index
)
Parameters
items (array< CategoryType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► IndexOf(CategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CategoryType item
)
Public Function IndexOf ( _
    item As CategoryType _
) As Integer
public:
int IndexOf(
    CategoryType^ item
)
Parameters
item (CategoryType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► Insert(Int32, CategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CategoryType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CategoryType _
)
public:
void Insert(
    int index,
    CategoryType^ item
)
Parameters
index (Int32)
item (CategoryType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CategoryType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CategoryType
    Get
    Set
public:
property CategoryType^ default[int index] {
    CategoryType^ get (int index);
    void set (int index, CategoryType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CategoryType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CategoryType
public:
CategoryType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► Remove(CategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CategoryType item
)
Public Sub Remove ( _
    item As CategoryType _
)
public:
void Remove(
    CategoryType^ item
)
Parameters
item (CategoryType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CategoryType[] ToArray()
Public Function ToArray As CategoryType()
public:
array<CategoryType^>^ ToArray()
Return Value


CharacteristicsSetType Class

CharacteristicsSetType Class
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CharacteristicsSetType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CharacteristicsSetType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CharacteristicsSetType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharacteristicsSetType()()()() |
 | Any |
 | AttributeSetID |
 | AttributeSetIDSpecified |
 | AttributeSetVersion |
 | Characteristics |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CharacteristicsSetType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AttributeSetID Property

AttributeSetID Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetType ► AttributeSetID
Declaration Syntax
C# Visual Basic Visual C++
public int AttributeSetID { get; set; }
Public Property AttributeSetID As Integer
    Get
    Set
public:
property int AttributeSetID {
    int get ();
    void set (int value);
}


AttributeSetIDSpecified Property

AttributeSetIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetType ► AttributeSetIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AttributeSetIDSpecified { get; set; }
Public Property AttributeSetIDSpecified As Boolean
    Get
    Set
public:
property bool AttributeSetIDSpecified {
    bool get ();
    void set (bool value);
}


AttributeSetVersion Property

AttributeSetVersion Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetType ► AttributeSetVersion
Declaration Syntax
C# Visual Basic Visual C++
public string AttributeSetVersion { get; set; }
Public Property AttributeSetVersion As String
    Get
    Set
public:
property String^ AttributeSetVersion {
    String^ get ();
    void set (String^ value);
}


Characteristics Property

Characteristics Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetType ► Characteristics
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicTypeCollection Characteristics { get; set; }
Public Property Characteristics As CharacteristicTypeCollection
    Get
    Set
public:
property CharacteristicTypeCollection^ Characteristics {
    CharacteristicTypeCollection^ get ();
    void set (CharacteristicTypeCollection^ value);
}


CharacteristicsSetType Constructor

CharacteristicsSetType Constructor
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetType ► CharacteristicsSetType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicsSetType()
Public Sub New
public:
CharacteristicsSetType()


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


CharacteristicsSetTypeCollection Class

CharacteristicsSetTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CharacteristicsSetTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CharacteristicsSetTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CharacteristicsSetTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharacteristicsSetTypeCollection()()()() |
 | CharacteristicsSetTypeCollection(array<CharacteristicsSetType>[]()[][]) |
 | CharacteristicsSetTypeCollection(CharacteristicsSetTypeCollection) |
 | Add(CharacteristicsSetType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CharacteristicsSetType>[]()[][]) |
 | AddRange(CharacteristicsSetTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CharacteristicsSetType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CharacteristicsSetType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CharacteristicsSetType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CharacteristicsSetType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CharacteristicsSetType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CharacteristicsSetTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► Add(CharacteristicsSetType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CharacteristicsSetType item
)
Public Function Add ( _
    item As CharacteristicsSetType _
) As Integer
public:
int Add(
    CharacteristicsSetType^ item
)
Parameters
item (CharacteristicsSetType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CharacteristicsSetType>[]()[][]) |
 | AddRange(CharacteristicsSetTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► AddRange(array<CharacteristicsSetType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CharacteristicsSetType[] items
)
Public Sub AddRange ( _
    items As CharacteristicsSetType() _
)
public:
void AddRange(
    array<CharacteristicsSetType^>^ items
)
Parameters
items (array< CharacteristicsSetType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► AddRange(CharacteristicsSetTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CharacteristicsSetTypeCollection items
)
Public Sub AddRange ( _
    items As CharacteristicsSetTypeCollection _
)
public:
void AddRange(
    CharacteristicsSetTypeCollection^ items
)
Parameters
items (CharacteristicsSetTypeCollection)


CharacteristicsSetTypeCollection Constructor

CharacteristicsSetTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► CharacteristicsSetTypeCollection()()()()
Members
Icon | Member | Description
 | CharacteristicsSetTypeCollection()()()() |
 | CharacteristicsSetTypeCollection(array<CharacteristicsSetType>[]()[][]) |
 | CharacteristicsSetTypeCollection(CharacteristicsSetTypeCollection) |


CharacteristicsSetTypeCollection Constructor

CharacteristicsSetTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► CharacteristicsSetTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicsSetTypeCollection()
Public Sub New
public:
CharacteristicsSetTypeCollection()


CharacteristicsSetTypeCollection Constructor (items)

CharacteristicsSetTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► CharacteristicsSetTypeCollection(array<CharacteristicsSetType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicsSetTypeCollection(
    CharacteristicsSetType[] items
)
Public Sub New ( _
    items As CharacteristicsSetType() _
)
public:
CharacteristicsSetTypeCollection(
    array<CharacteristicsSetType^>^ items
)
Parameters
items (array< CharacteristicsSetType >[]()[][])


CharacteristicsSetTypeCollection Constructor (items)

CharacteristicsSetTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► CharacteristicsSetTypeCollection(CharacteristicsSetTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicsSetTypeCollection(
    CharacteristicsSetTypeCollection items
)
Public Sub New ( _
    items As CharacteristicsSetTypeCollection _
)
public:
CharacteristicsSetTypeCollection(
    CharacteristicsSetTypeCollection^ items
)
Parameters
items (CharacteristicsSetTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► Contains(CharacteristicsSetType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CharacteristicsSetType item
)
Public Function Contains ( _
    item As CharacteristicsSetType _
) As Boolean
public:
bool Contains(
    CharacteristicsSetType^ item
)
Parameters
item (CharacteristicsSetType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► CopyTo(array<CharacteristicsSetType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CharacteristicsSetType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CharacteristicsSetType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CharacteristicsSetType^>^ items,
    int index
)
Parameters
items (array< CharacteristicsSetType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► IndexOf(CharacteristicsSetType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CharacteristicsSetType item
)
Public Function IndexOf ( _
    item As CharacteristicsSetType _
) As Integer
public:
int IndexOf(
    CharacteristicsSetType^ item
)
Parameters
item (CharacteristicsSetType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► Insert(Int32, CharacteristicsSetType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CharacteristicsSetType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CharacteristicsSetType _
)
public:
void Insert(
    int index,
    CharacteristicsSetType^ item
)
Parameters
index (Int32)
item (CharacteristicsSetType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicsSetType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CharacteristicsSetType
    Get
    Set
public:
property CharacteristicsSetType^ default[int index] {
    CharacteristicsSetType^ get (int index);
    void set (int index, CharacteristicsSetType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicsSetType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CharacteristicsSetType
public:
CharacteristicsSetType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► Remove(CharacteristicsSetType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CharacteristicsSetType item
)
Public Sub Remove ( _
    item As CharacteristicsSetType _
)
public:
void Remove(
    CharacteristicsSetType^ item
)
Parameters
item (CharacteristicsSetType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicsSetType[] ToArray()
Public Function ToArray As CharacteristicsSetType()
public:
array<CharacteristicsSetType^>^ ToArray()
Return Value


CharacteristicType Class

CharacteristicType Class
Namespaces ► eBay.Service.Core.Soap ► CharacteristicType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CharacteristicType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CharacteristicType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CharacteristicType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharacteristicType()()()() |
 | Any |
 | AttributeID |
 | DateFormat |
 | DisplaySequence |
 | DisplayUOM |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Label |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SortOrder |
 | SortOrderSpecified |
 | ToString()()()() | (Inherited from Object.)
 | ValueList |
Remarks
Inheritance Hierarchy
Object
CharacteristicType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AttributeID Property

AttributeID Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicType ► AttributeID
Declaration Syntax
C# Visual Basic Visual C++
public int AttributeID { get; set; }
Public Property AttributeID As Integer
    Get
    Set
public:
property int AttributeID {
    int get ();
    void set (int value);
}


CharacteristicType Constructor

CharacteristicType Constructor
Namespaces ► eBay.Service.Core.Soap ► CharacteristicType ► CharacteristicType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicType()
Public Sub New
public:
CharacteristicType()


DateFormat Property

DateFormat Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicType ► DateFormat
Declaration Syntax
C# Visual Basic Visual C++
public string DateFormat { get; set; }
Public Property DateFormat As String
    Get
    Set
public:
property String^ DateFormat {
    String^ get ();
    void set (String^ value);
}


DisplaySequence Property

DisplaySequence Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicType ► DisplaySequence
Declaration Syntax
C# Visual Basic Visual C++
public string DisplaySequence { get; set; }
Public Property DisplaySequence As String
    Get
    Set
public:
property String^ DisplaySequence {
    String^ get ();
    void set (String^ value);
}


DisplayUOM Property

DisplayUOM Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicType ► DisplayUOM
Declaration Syntax
C# Visual Basic Visual C++
public string DisplayUOM { get; set; }
Public Property DisplayUOM As String
    Get
    Set
public:
property String^ DisplayUOM {
    String^ get ();
    void set (String^ value);
}


Label Property

Label Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicType ► Label
Declaration Syntax
C# Visual Basic Visual C++
public LabelType Label { get; set; }
Public Property Label As LabelType
    Get
    Set
public:
property LabelType^ Label {
    LabelType^ get ();
    void set (LabelType^ value);
}


SortOrder Property

SortOrder Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicType ► SortOrder
Declaration Syntax
C# Visual Basic Visual C++
public SortOrderCodeType SortOrder { get; set; }
Public Property SortOrder As SortOrderCodeType
    Get
    Set
public:
property SortOrderCodeType SortOrder {
    SortOrderCodeType get ();
    void set (SortOrderCodeType value);
}


SortOrderSpecified Property

SortOrderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicType ► SortOrderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SortOrderSpecified { get; set; }
Public Property SortOrderSpecified As Boolean
    Get
    Set
public:
property bool SortOrderSpecified {
    bool get ();
    void set (bool value);
}


ValueList Property

ValueList Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicType ► ValueList
Declaration Syntax
C# Visual Basic Visual C++
public ValTypeCollection ValueList { get; set; }
Public Property ValueList As ValTypeCollection
    Get
    Set
public:
property ValTypeCollection^ ValueList {
    ValTypeCollection^ get ();
    void set (ValTypeCollection^ value);
}


CharacteristicTypeCollection Class

CharacteristicTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CharacteristicTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CharacteristicTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CharacteristicTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharacteristicTypeCollection()()()() |
 | CharacteristicTypeCollection(array<CharacteristicType>[]()[][]) |
 | CharacteristicTypeCollection(CharacteristicTypeCollection) |
 | Add(CharacteristicType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CharacteristicType>[]()[][]) |
 | AddRange(CharacteristicTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CharacteristicType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CharacteristicType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CharacteristicType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CharacteristicType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CharacteristicType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CharacteristicTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► Add(CharacteristicType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CharacteristicType item
)
Public Function Add ( _
    item As CharacteristicType _
) As Integer
public:
int Add(
    CharacteristicType^ item
)
Parameters
item (CharacteristicType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CharacteristicType>[]()[][]) |
 | AddRange(CharacteristicTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► AddRange(array<CharacteristicType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CharacteristicType[] items
)
Public Sub AddRange ( _
    items As CharacteristicType() _
)
public:
void AddRange(
    array<CharacteristicType^>^ items
)
Parameters
items (array< CharacteristicType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► AddRange(CharacteristicTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CharacteristicTypeCollection items
)
Public Sub AddRange ( _
    items As CharacteristicTypeCollection _
)
public:
void AddRange(
    CharacteristicTypeCollection^ items
)
Parameters
items (CharacteristicTypeCollection)


CharacteristicTypeCollection Constructor

CharacteristicTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► CharacteristicTypeCollection()()()()
Members
Icon | Member | Description
 | CharacteristicTypeCollection()()()() |
 | CharacteristicTypeCollection(array<CharacteristicType>[]()[][]) |
 | CharacteristicTypeCollection(CharacteristicTypeCollection) |


CharacteristicTypeCollection Constructor

CharacteristicTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► CharacteristicTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicTypeCollection()
Public Sub New
public:
CharacteristicTypeCollection()


CharacteristicTypeCollection Constructor (items)

CharacteristicTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► CharacteristicTypeCollection(array<CharacteristicType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicTypeCollection(
    CharacteristicType[] items
)
Public Sub New ( _
    items As CharacteristicType() _
)
public:
CharacteristicTypeCollection(
    array<CharacteristicType^>^ items
)
Parameters
items (array< CharacteristicType >[]()[][])


CharacteristicTypeCollection Constructor (items)

CharacteristicTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► CharacteristicTypeCollection(CharacteristicTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicTypeCollection(
    CharacteristicTypeCollection items
)
Public Sub New ( _
    items As CharacteristicTypeCollection _
)
public:
CharacteristicTypeCollection(
    CharacteristicTypeCollection^ items
)
Parameters
items (CharacteristicTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► Contains(CharacteristicType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CharacteristicType item
)
Public Function Contains ( _
    item As CharacteristicType _
) As Boolean
public:
bool Contains(
    CharacteristicType^ item
)
Parameters
item (CharacteristicType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► CopyTo(array<CharacteristicType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CharacteristicType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CharacteristicType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CharacteristicType^>^ items,
    int index
)
Parameters
items (array< CharacteristicType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► IndexOf(CharacteristicType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CharacteristicType item
)
Public Function IndexOf ( _
    item As CharacteristicType _
) As Integer
public:
int IndexOf(
    CharacteristicType^ item
)
Parameters
item (CharacteristicType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► Insert(Int32, CharacteristicType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CharacteristicType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CharacteristicType _
)
public:
void Insert(
    int index,
    CharacteristicType^ item
)
Parameters
index (Int32)
item (CharacteristicType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CharacteristicType
    Get
    Set
public:
property CharacteristicType^ default[int index] {
    CharacteristicType^ get (int index);
    void set (int index, CharacteristicType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CharacteristicType
public:
CharacteristicType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► Remove(CharacteristicType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CharacteristicType item
)
Public Sub Remove ( _
    item As CharacteristicType _
)
public:
void Remove(
    CharacteristicType^ item
)
Parameters
item (CharacteristicType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicType[] ToArray()
Public Function ToArray As CharacteristicType()
public:
array<CharacteristicType^>^ ToArray()
Return Value


CharityAffiliationDetailType Class

CharityAffiliationDetailType Class
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CharityAffiliationDetailType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CharityAffiliationDetailType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CharityAffiliationDetailType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharityAffiliationDetailType()()()() |
 | AffiliationType |
 | AffiliationTypeSpecified |
 | Any |
 | CharityID |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LastUsedTime |
 | LastUsedTimeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CharityAffiliationDetailType


AffiliationType Property

AffiliationType Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailType ► AffiliationType
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationTypeCodeType AffiliationType { get; set; }
Public Property AffiliationType As CharityAffiliationTypeCodeType
    Get
    Set
public:
property CharityAffiliationTypeCodeType AffiliationType {
    CharityAffiliationTypeCodeType get ();
    void set (CharityAffiliationTypeCodeType value);
}


AffiliationTypeSpecified Property

AffiliationTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailType ► AffiliationTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AffiliationTypeSpecified { get; set; }
Public Property AffiliationTypeSpecified As Boolean
    Get
    Set
public:
property bool AffiliationTypeSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CharityAffiliationDetailType Constructor

CharityAffiliationDetailType Constructor
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailType ► CharityAffiliationDetailType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationDetailType()
Public Sub New
public:
CharityAffiliationDetailType()


CharityID Property

CharityID Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailType ► CharityID
Declaration Syntax
C# Visual Basic Visual C++
public string CharityID { get; set; }
Public Property CharityID As String
    Get
    Set
public:
property String^ CharityID {
    String^ get ();
    void set (String^ value);
}


LastUsedTime Property

LastUsedTime Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailType ► LastUsedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastUsedTime { get; set; }
Public Property LastUsedTime As DateTime
    Get
    Set
public:
property DateTime LastUsedTime {
    DateTime get ();
    void set (DateTime value);
}


LastUsedTimeSpecified Property

LastUsedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailType ► LastUsedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastUsedTimeSpecified { get; set; }
Public Property LastUsedTimeSpecified As Boolean
    Get
    Set
public:
property bool LastUsedTimeSpecified {
    bool get ();
    void set (bool value);
}


CharityAffiliationDetailTypeCollection Class

CharityAffiliationDetailTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CharityAffiliationDetailTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CharityAffiliationDetailTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CharityAffiliationDetailTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharityAffiliationDetailTypeCollection()()()() |
 | CharityAffiliationDetailTypeCollection(array<CharityAffiliationDetailType>[]()[][]) |
 | CharityAffiliationDetailTypeCollection(CharityAffiliationDetailTypeCollection) |
 | Add(CharityAffiliationDetailType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CharityAffiliationDetailType>[]()[][]) |
 | AddRange(CharityAffiliationDetailTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CharityAffiliationDetailType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CharityAffiliationDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CharityAffiliationDetailType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CharityAffiliationDetailType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CharityAffiliationDetailType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CharityAffiliationDetailTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► Add(CharityAffiliationDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CharityAffiliationDetailType item
)
Public Function Add ( _
    item As CharityAffiliationDetailType _
) As Integer
public:
int Add(
    CharityAffiliationDetailType^ item
)
Parameters
item (CharityAffiliationDetailType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CharityAffiliationDetailType>[]()[][]) |
 | AddRange(CharityAffiliationDetailTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► AddRange(array<CharityAffiliationDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CharityAffiliationDetailType[] items
)
Public Sub AddRange ( _
    items As CharityAffiliationDetailType() _
)
public:
void AddRange(
    array<CharityAffiliationDetailType^>^ items
)
Parameters
items (array< CharityAffiliationDetailType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► AddRange(CharityAffiliationDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CharityAffiliationDetailTypeCollection items
)
Public Sub AddRange ( _
    items As CharityAffiliationDetailTypeCollection _
)
public:
void AddRange(
    CharityAffiliationDetailTypeCollection^ items
)
Parameters
items (CharityAffiliationDetailTypeCollection)


CharityAffiliationDetailTypeCollection Constructor

CharityAffiliationDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► CharityAffiliationDetailTypeCollection()()()()
Members
Icon | Member | Description
 | CharityAffiliationDetailTypeCollection()()()() |
 | CharityAffiliationDetailTypeCollection(array<CharityAffiliationDetailType>[]()[][]) |
 | CharityAffiliationDetailTypeCollection(CharityAffiliationDetailTypeCollection) |


CharityAffiliationDetailTypeCollection Constructor

CharityAffiliationDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► CharityAffiliationDetailTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationDetailTypeCollection()
Public Sub New
public:
CharityAffiliationDetailTypeCollection()


CharityAffiliationDetailTypeCollection Constructor (items)

CharityAffiliationDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► CharityAffiliationDetailTypeCollection(array<CharityAffiliationDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationDetailTypeCollection(
    CharityAffiliationDetailType[] items
)
Public Sub New ( _
    items As CharityAffiliationDetailType() _
)
public:
CharityAffiliationDetailTypeCollection(
    array<CharityAffiliationDetailType^>^ items
)
Parameters
items (array< CharityAffiliationDetailType >[]()[][])


CharityAffiliationDetailTypeCollection Constructor (items)

CharityAffiliationDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► CharityAffiliationDetailTypeCollection(CharityAffiliationDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationDetailTypeCollection(
    CharityAffiliationDetailTypeCollection items
)
Public Sub New ( _
    items As CharityAffiliationDetailTypeCollection _
)
public:
CharityAffiliationDetailTypeCollection(
    CharityAffiliationDetailTypeCollection^ items
)
Parameters
items (CharityAffiliationDetailTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► Contains(CharityAffiliationDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CharityAffiliationDetailType item
)
Public Function Contains ( _
    item As CharityAffiliationDetailType _
) As Boolean
public:
bool Contains(
    CharityAffiliationDetailType^ item
)
Parameters
item (CharityAffiliationDetailType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► CopyTo(array<CharityAffiliationDetailType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CharityAffiliationDetailType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CharityAffiliationDetailType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CharityAffiliationDetailType^>^ items,
    int index
)
Parameters
items (array< CharityAffiliationDetailType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► IndexOf(CharityAffiliationDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CharityAffiliationDetailType item
)
Public Function IndexOf ( _
    item As CharityAffiliationDetailType _
) As Integer
public:
int IndexOf(
    CharityAffiliationDetailType^ item
)
Parameters
item (CharityAffiliationDetailType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► Insert(Int32, CharityAffiliationDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CharityAffiliationDetailType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CharityAffiliationDetailType _
)
public:
void Insert(
    int index,
    CharityAffiliationDetailType^ item
)
Parameters
index (Int32)
item (CharityAffiliationDetailType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationDetailType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CharityAffiliationDetailType
    Get
    Set
public:
property CharityAffiliationDetailType^ default[int index] {
    CharityAffiliationDetailType^ get (int index);
    void set (int index, CharityAffiliationDetailType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationDetailType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CharityAffiliationDetailType
public:
CharityAffiliationDetailType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► Remove(CharityAffiliationDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CharityAffiliationDetailType item
)
Public Sub Remove ( _
    item As CharityAffiliationDetailType _
)
public:
void Remove(
    CharityAffiliationDetailType^ item
)
Parameters
item (CharityAffiliationDetailType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationDetailType[] ToArray()
Public Function ToArray As CharityAffiliationDetailType()
public:
array<CharityAffiliationDetailType^>^ ToArray()
Return Value


CharityAffiliationsType Class

CharityAffiliationsType Class
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CharityAffiliationsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CharityAffiliationsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CharityAffiliationsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharityAffiliationsType()()()() |
 | Any |
 | CharityID |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CharityAffiliationsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CharityAffiliationsType Constructor

CharityAffiliationsType Constructor
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationsType ► CharityAffiliationsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationsType()
Public Sub New
public:
CharityAffiliationsType()


CharityID Property

CharityID Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationsType ► CharityID
Declaration Syntax
C# Visual Basic Visual C++
public CharityIDTypeCollection CharityID { get; set; }
Public Property CharityID As CharityIDTypeCollection
    Get
    Set
public:
property CharityIDTypeCollection^ CharityID {
    CharityIDTypeCollection^ get ();
    void set (CharityIDTypeCollection^ value);
}


CharityAffiliationTypeCodeType Enumeration

CharityAffiliationTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CharityAffiliationTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CharityAffiliationTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CharityAffiliationTypeCodeType
Members
Member | Description
Community |
Direct |
Remove |
CustomCode |
Remarks


CharityIDType Class

CharityIDType Class
Namespaces ► eBay.Service.Core.Soap ► CharityIDType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CharityIDType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CharityIDType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CharityIDType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharityIDType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | type |
 | Value |
Remarks
Inheritance Hierarchy
Object
CharityIDType


CharityIDType Constructor

CharityIDType Constructor
Namespaces ► eBay.Service.Core.Soap ► CharityIDType ► CharityIDType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharityIDType()
Public Sub New
public:
CharityIDType()


type Property

type Property
Namespaces ► eBay.Service.Core.Soap ► CharityIDType ► type
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationTypeCodeType type { get; set; }
Public Property type As CharityAffiliationTypeCodeType
    Get
    Set
public:
property CharityAffiliationTypeCodeType type {
    CharityAffiliationTypeCodeType get ();
    void set (CharityAffiliationTypeCodeType value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► CharityIDType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


CharityIDTypeCollection Class

CharityIDTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CharityIDTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CharityIDTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CharityIDTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharityIDTypeCollection()()()() |
 | CharityIDTypeCollection(array<CharityIDType>[]()[][]) |
 | CharityIDTypeCollection(CharityIDTypeCollection) |
 | Add(CharityIDType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CharityIDType>[]()[][]) |
 | AddRange(CharityIDTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CharityIDType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CharityIDType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CharityIDType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CharityIDType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CharityIDType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CharityIDTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► Add(CharityIDType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CharityIDType item
)
Public Function Add ( _
    item As CharityIDType _
) As Integer
public:
int Add(
    CharityIDType^ item
)
Parameters
item (CharityIDType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CharityIDType>[]()[][]) |
 | AddRange(CharityIDTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► AddRange(array<CharityIDType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CharityIDType[] items
)
Public Sub AddRange ( _
    items As CharityIDType() _
)
public:
void AddRange(
    array<CharityIDType^>^ items
)
Parameters
items (array< CharityIDType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► AddRange(CharityIDTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CharityIDTypeCollection items
)
Public Sub AddRange ( _
    items As CharityIDTypeCollection _
)
public:
void AddRange(
    CharityIDTypeCollection^ items
)
Parameters
items (CharityIDTypeCollection)


CharityIDTypeCollection Constructor

CharityIDTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► CharityIDTypeCollection()()()()
Members
Icon | Member | Description
 | CharityIDTypeCollection()()()() |
 | CharityIDTypeCollection(array<CharityIDType>[]()[][]) |
 | CharityIDTypeCollection(CharityIDTypeCollection) |


CharityIDTypeCollection Constructor

CharityIDTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► CharityIDTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharityIDTypeCollection()
Public Sub New
public:
CharityIDTypeCollection()


CharityIDTypeCollection Constructor (items)

CharityIDTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► CharityIDTypeCollection(array<CharityIDType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CharityIDTypeCollection(
    CharityIDType[] items
)
Public Sub New ( _
    items As CharityIDType() _
)
public:
CharityIDTypeCollection(
    array<CharityIDType^>^ items
)
Parameters
items (array< CharityIDType >[]()[][])


CharityIDTypeCollection Constructor (items)

CharityIDTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► CharityIDTypeCollection(CharityIDTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CharityIDTypeCollection(
    CharityIDTypeCollection items
)
Public Sub New ( _
    items As CharityIDTypeCollection _
)
public:
CharityIDTypeCollection(
    CharityIDTypeCollection^ items
)
Parameters
items (CharityIDTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► Contains(CharityIDType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CharityIDType item
)
Public Function Contains ( _
    item As CharityIDType _
) As Boolean
public:
bool Contains(
    CharityIDType^ item
)
Parameters
item (CharityIDType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► CopyTo(array<CharityIDType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CharityIDType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CharityIDType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CharityIDType^>^ items,
    int index
)
Parameters
items (array< CharityIDType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► IndexOf(CharityIDType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CharityIDType item
)
Public Function IndexOf ( _
    item As CharityIDType _
) As Integer
public:
int IndexOf(
    CharityIDType^ item
)
Parameters
item (CharityIDType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► Insert(Int32, CharityIDType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CharityIDType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CharityIDType _
)
public:
void Insert(
    int index,
    CharityIDType^ item
)
Parameters
index (Int32)
item (CharityIDType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CharityIDType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CharityIDType
    Get
    Set
public:
property CharityIDType^ default[int index] {
    CharityIDType^ get (int index);
    void set (int index, CharityIDType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CharityIDType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CharityIDType
public:
CharityIDType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► Remove(CharityIDType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CharityIDType item
)
Public Sub Remove ( _
    item As CharityIDType _
)
public:
void Remove(
    CharityIDType^ item
)
Parameters
item (CharityIDType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharityIDType[] ToArray()
Public Function ToArray As CharityIDType()
public:
array<CharityIDType^>^ ToArray()
Return Value


CharityInfoType Class

CharityInfoType Class
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CharityInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CharityInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CharityInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharityInfoType()()()() |
 | Any |
 | CharityDomain |
 | CharityID |
 | CharityRegion |
 | CharityRegionSpecified |
 | Description |
 | DisplayLogoSelling |
 | DisplayLogoSellingSpecified |
 | DisplayNameInCheckout |
 | DisplayNameInCheckoutSpecified |
 | EIN |
 | Equals(Object) | (Inherited from Object.)
 | ExternalID |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | id |
 | ListingNPContactName |
 | ListingNPEmail |
 | ListingNPEmailNotifPref |
 | ListingNPEmailNotifPrefSpecified |
 | LogoURL |
 | LogoURLSelling |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mission |
 | Name |
 | NonProfitAddress |
 | NonProfitSecondName |
 | NonProfitSocialAddress |
 | PopularityIndex |
 | PopularityIndexSpecified |
 | SearchableString |
 | ShowMultipleDonationAmountInCheckout |
 | ShowMultipleDonationAmountInCheckoutSpecified |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CharityInfoType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CharityDomain Property

CharityDomain Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► CharityDomain
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection CharityDomain { get; set; }
Public Property CharityDomain As Int32Collection
    Get
    Set
public:
property Int32Collection^ CharityDomain {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


CharityID Property

CharityID Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► CharityID
Declaration Syntax
C# Visual Basic Visual C++
public string CharityID { get; set; }
Public Property CharityID As String
    Get
    Set
public:
property String^ CharityID {
    String^ get ();
    void set (String^ value);
}


CharityInfoType Constructor

CharityInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► CharityInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharityInfoType()
Public Sub New
public:
CharityInfoType()


CharityRegion Property

CharityRegion Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► CharityRegion
Declaration Syntax
C# Visual Basic Visual C++
public int CharityRegion { get; set; }
Public Property CharityRegion As Integer
    Get
    Set
public:
property int CharityRegion {
    int get ();
    void set (int value);
}


CharityRegionSpecified Property

CharityRegionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► CharityRegionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CharityRegionSpecified { get; set; }
Public Property CharityRegionSpecified As Boolean
    Get
    Set
public:
property bool CharityRegionSpecified {
    bool get ();
    void set (bool value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DisplayLogoSelling Property

DisplayLogoSelling Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► DisplayLogoSelling
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayLogoSelling { get; set; }
Public Property DisplayLogoSelling As Boolean
    Get
    Set
public:
property bool DisplayLogoSelling {
    bool get ();
    void set (bool value);
}


DisplayLogoSellingSpecified Property

DisplayLogoSellingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► DisplayLogoSellingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayLogoSellingSpecified { get; set; }
Public Property DisplayLogoSellingSpecified As Boolean
    Get
    Set
public:
property bool DisplayLogoSellingSpecified {
    bool get ();
    void set (bool value);
}


DisplayNameInCheckout Property

DisplayNameInCheckout Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► DisplayNameInCheckout
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayNameInCheckout { get; set; }
Public Property DisplayNameInCheckout As Boolean
    Get
    Set
public:
property bool DisplayNameInCheckout {
    bool get ();
    void set (bool value);
}


DisplayNameInCheckoutSpecified Property

DisplayNameInCheckoutSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► DisplayNameInCheckoutSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayNameInCheckoutSpecified { get; set; }
Public Property DisplayNameInCheckoutSpecified As Boolean
    Get
    Set
public:
property bool DisplayNameInCheckoutSpecified {
    bool get ();
    void set (bool value);
}


EIN Property

EIN Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► EIN
Declaration Syntax
C# Visual Basic Visual C++
public string EIN { get; set; }
Public Property EIN As String
    Get
    Set
public:
property String^ EIN {
    String^ get ();
    void set (String^ value);
}


ExternalID Property

ExternalID Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► ExternalID
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalID { get; set; }
Public Property ExternalID As String
    Get
    Set
public:
property String^ ExternalID {
    String^ get ();
    void set (String^ value);
}


id Property

id Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► id
Declaration Syntax
C# Visual Basic Visual C++
public string id { get; set; }
Public Property id As String
    Get
    Set
public:
property String^ id {
    String^ get ();
    void set (String^ value);
}


ListingNPContactName Property

ListingNPContactName Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► ListingNPContactName
Declaration Syntax
C# Visual Basic Visual C++
public string ListingNPContactName { get; set; }
Public Property ListingNPContactName As String
    Get
    Set
public:
property String^ ListingNPContactName {
    String^ get ();
    void set (String^ value);
}


ListingNPEmail Property

ListingNPEmail Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► ListingNPEmail
Declaration Syntax
C# Visual Basic Visual C++
public string ListingNPEmail { get; set; }
Public Property ListingNPEmail As String
    Get
    Set
public:
property String^ ListingNPEmail {
    String^ get ();
    void set (String^ value);
}


ListingNPEmailNotifPref Property

ListingNPEmailNotifPref Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► ListingNPEmailNotifPref
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingNPEmailNotifPref { get; set; }
Public Property ListingNPEmailNotifPref As Boolean
    Get
    Set
public:
property bool ListingNPEmailNotifPref {
    bool get ();
    void set (bool value);
}


ListingNPEmailNotifPrefSpecified Property

ListingNPEmailNotifPrefSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► ListingNPEmailNotifPrefSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingNPEmailNotifPrefSpecified { get; set; }
Public Property ListingNPEmailNotifPrefSpecified As Boolean
    Get
    Set
public:
property bool ListingNPEmailNotifPrefSpecified {
    bool get ();
    void set (bool value);
}


LogoURL Property

LogoURL Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► LogoURL
Declaration Syntax
C# Visual Basic Visual C++
public string LogoURL { get; set; }
Public Property LogoURL As String
    Get
    Set
public:
property String^ LogoURL {
    String^ get ();
    void set (String^ value);
}


LogoURLSelling Property

LogoURLSelling Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► LogoURLSelling
Declaration Syntax
C# Visual Basic Visual C++
public string LogoURLSelling { get; set; }
Public Property LogoURLSelling As String
    Get
    Set
public:
property String^ LogoURLSelling {
    String^ get ();
    void set (String^ value);
}


Mission Property

Mission Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► Mission
Declaration Syntax
C# Visual Basic Visual C++
public string Mission { get; set; }
Public Property Mission As String
    Get
    Set
public:
property String^ Mission {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


NonProfitAddress Property

NonProfitAddress Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► NonProfitAddress
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitAddressTypeCollection NonProfitAddress { get; set; }
Public Property NonProfitAddress As NonProfitAddressTypeCollection
    Get
    Set
public:
property NonProfitAddressTypeCollection^ NonProfitAddress {
    NonProfitAddressTypeCollection^ get ();
    void set (NonProfitAddressTypeCollection^ value);
}


NonProfitSecondName Property

NonProfitSecondName Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► NonProfitSecondName
Declaration Syntax
C# Visual Basic Visual C++
public string NonProfitSecondName { get; set; }
Public Property NonProfitSecondName As String
    Get
    Set
public:
property String^ NonProfitSecondName {
    String^ get ();
    void set (String^ value);
}


NonProfitSocialAddress Property

NonProfitSocialAddress Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► NonProfitSocialAddress
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitSocialAddressTypeCollection NonProfitSocialAddress { get; set; }
Public Property NonProfitSocialAddress As NonProfitSocialAddressTypeCollection
    Get
    Set
public:
property NonProfitSocialAddressTypeCollection^ NonProfitSocialAddress {
    NonProfitSocialAddressTypeCollection^ get ();
    void set (NonProfitSocialAddressTypeCollection^ value);
}


PopularityIndex Property

PopularityIndex Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► PopularityIndex
Declaration Syntax
C# Visual Basic Visual C++
public int PopularityIndex { get; set; }
Public Property PopularityIndex As Integer
    Get
    Set
public:
property int PopularityIndex {
    int get ();
    void set (int value);
}


PopularityIndexSpecified Property

PopularityIndexSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► PopularityIndexSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PopularityIndexSpecified { get; set; }
Public Property PopularityIndexSpecified As Boolean
    Get
    Set
public:
property bool PopularityIndexSpecified {
    bool get ();
    void set (bool value);
}


SearchableString Property

SearchableString Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► SearchableString
Declaration Syntax
C# Visual Basic Visual C++
public string SearchableString { get; set; }
Public Property SearchableString As String
    Get
    Set
public:
property String^ SearchableString {
    String^ get ();
    void set (String^ value);
}


ShowMultipleDonationAmountInCheckout Property

ShowMultipleDonationAmountInCheckout Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► ShowMultipleDonationAmountInCheckout
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowMultipleDonationAmountInCheckout { get; set; }
Public Property ShowMultipleDonationAmountInCheckout As Boolean
    Get
    Set
public:
property bool ShowMultipleDonationAmountInCheckout {
    bool get ();
    void set (bool value);
}


ShowMultipleDonationAmountInCheckoutSpecified Property

ShowMultipleDonationAmountInCheckoutSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► ShowMultipleDonationAmountInCheckoutSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowMultipleDonationAmountInCheckoutSpecified { get; set; }
Public Property ShowMultipleDonationAmountInCheckoutSpecified As Boolean
    Get
    Set
public:
property bool ShowMultipleDonationAmountInCheckoutSpecified {
    bool get ();
    void set (bool value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public CharityStatusCodeType Status { get; set; }
Public Property Status As CharityStatusCodeType
    Get
    Set
public:
property CharityStatusCodeType Status {
    CharityStatusCodeType get ();
    void set (CharityStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


CharityInfoTypeCollection Class

CharityInfoTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CharityInfoTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CharityInfoTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CharityInfoTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharityInfoTypeCollection()()()() |
 | CharityInfoTypeCollection(array<CharityInfoType>[]()[][]) |
 | CharityInfoTypeCollection(CharityInfoTypeCollection) |
 | Add(CharityInfoType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CharityInfoType>[]()[][]) |
 | AddRange(CharityInfoTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CharityInfoType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CharityInfoType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CharityInfoType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CharityInfoType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CharityInfoType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CharityInfoTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► Add(CharityInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CharityInfoType item
)
Public Function Add ( _
    item As CharityInfoType _
) As Integer
public:
int Add(
    CharityInfoType^ item
)
Parameters
item (CharityInfoType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CharityInfoType>[]()[][]) |
 | AddRange(CharityInfoTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► AddRange(array<CharityInfoType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CharityInfoType[] items
)
Public Sub AddRange ( _
    items As CharityInfoType() _
)
public:
void AddRange(
    array<CharityInfoType^>^ items
)
Parameters
items (array< CharityInfoType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► AddRange(CharityInfoTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CharityInfoTypeCollection items
)
Public Sub AddRange ( _
    items As CharityInfoTypeCollection _
)
public:
void AddRange(
    CharityInfoTypeCollection^ items
)
Parameters
items (CharityInfoTypeCollection)


CharityInfoTypeCollection Constructor

CharityInfoTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► CharityInfoTypeCollection()()()()
Members
Icon | Member | Description
 | CharityInfoTypeCollection()()()() |
 | CharityInfoTypeCollection(array<CharityInfoType>[]()[][]) |
 | CharityInfoTypeCollection(CharityInfoTypeCollection) |


CharityInfoTypeCollection Constructor

CharityInfoTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► CharityInfoTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharityInfoTypeCollection()
Public Sub New
public:
CharityInfoTypeCollection()


CharityInfoTypeCollection Constructor (items)

CharityInfoTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► CharityInfoTypeCollection(array<CharityInfoType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CharityInfoTypeCollection(
    CharityInfoType[] items
)
Public Sub New ( _
    items As CharityInfoType() _
)
public:
CharityInfoTypeCollection(
    array<CharityInfoType^>^ items
)
Parameters
items (array< CharityInfoType >[]()[][])


CharityInfoTypeCollection Constructor (items)

CharityInfoTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► CharityInfoTypeCollection(CharityInfoTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CharityInfoTypeCollection(
    CharityInfoTypeCollection items
)
Public Sub New ( _
    items As CharityInfoTypeCollection _
)
public:
CharityInfoTypeCollection(
    CharityInfoTypeCollection^ items
)
Parameters
items (CharityInfoTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► Contains(CharityInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CharityInfoType item
)
Public Function Contains ( _
    item As CharityInfoType _
) As Boolean
public:
bool Contains(
    CharityInfoType^ item
)
Parameters
item (CharityInfoType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► CopyTo(array<CharityInfoType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CharityInfoType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CharityInfoType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CharityInfoType^>^ items,
    int index
)
Parameters
items (array< CharityInfoType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► IndexOf(CharityInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CharityInfoType item
)
Public Function IndexOf ( _
    item As CharityInfoType _
) As Integer
public:
int IndexOf(
    CharityInfoType^ item
)
Parameters
item (CharityInfoType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► Insert(Int32, CharityInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CharityInfoType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CharityInfoType _
)
public:
void Insert(
    int index,
    CharityInfoType^ item
)
Parameters
index (Int32)
item (CharityInfoType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CharityInfoType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CharityInfoType
    Get
    Set
public:
property CharityInfoType^ default[int index] {
    CharityInfoType^ get (int index);
    void set (int index, CharityInfoType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CharityInfoType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CharityInfoType
public:
CharityInfoType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► Remove(CharityInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CharityInfoType item
)
Public Sub Remove ( _
    item As CharityInfoType _
)
public:
void Remove(
    CharityInfoType^ item
)
Parameters
item (CharityInfoType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharityInfoType[] ToArray()
Public Function ToArray As CharityInfoType()
public:
array<CharityInfoType^>^ ToArray()
Return Value


CharityStatusCodeType Enumeration

CharityStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CharityStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CharityStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CharityStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CharityStatusCodeType
Members
Member | Description
Valid |
NoLongerValid |
CustomCode |
Remarks


CharityType Class

CharityType Class
Namespaces ► eBay.Service.Core.Soap ► CharityType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CharityType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CharityType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CharityType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CharityType()()()() |
 | Any |
 | CharityID |
 | CharityListing |
 | CharityListingSpecified |
 | CharityName |
 | CharityNumber |
 | CharityNumberSpecified |
 | DonationPercent |
 | DonationPercentSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LogoURL |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Mission |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CharityType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CharityID Property

CharityID Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► CharityID
Declaration Syntax
C# Visual Basic Visual C++
public string CharityID { get; set; }
Public Property CharityID As String
    Get
    Set
public:
property String^ CharityID {
    String^ get ();
    void set (String^ value);
}


CharityListing Property

CharityListing Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► CharityListing
Declaration Syntax
C# Visual Basic Visual C++
public bool CharityListing { get; set; }
Public Property CharityListing As Boolean
    Get
    Set
public:
property bool CharityListing {
    bool get ();
    void set (bool value);
}


CharityListingSpecified Property

CharityListingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► CharityListingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CharityListingSpecified { get; set; }
Public Property CharityListingSpecified As Boolean
    Get
    Set
public:
property bool CharityListingSpecified {
    bool get ();
    void set (bool value);
}


CharityName Property

CharityName Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► CharityName
Declaration Syntax
C# Visual Basic Visual C++
public string CharityName { get; set; }
Public Property CharityName As String
    Get
    Set
public:
property String^ CharityName {
    String^ get ();
    void set (String^ value);
}


CharityNumber Property

CharityNumber Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► CharityNumber
Declaration Syntax
C# Visual Basic Visual C++
public int CharityNumber { get; set; }
Public Property CharityNumber As Integer
    Get
    Set
public:
property int CharityNumber {
    int get ();
    void set (int value);
}


CharityNumberSpecified Property

CharityNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► CharityNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CharityNumberSpecified { get; set; }
Public Property CharityNumberSpecified As Boolean
    Get
    Set
public:
property bool CharityNumberSpecified {
    bool get ();
    void set (bool value);
}


CharityType Constructor

CharityType Constructor
Namespaces ► eBay.Service.Core.Soap ► CharityType ► CharityType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CharityType()
Public Sub New
public:
CharityType()


DonationPercent Property

DonationPercent Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► DonationPercent
Declaration Syntax
C# Visual Basic Visual C++
public float DonationPercent { get; set; }
Public Property DonationPercent As Single
    Get
    Set
public:
property float DonationPercent {
    float get ();
    void set (float value);
}


DonationPercentSpecified Property

DonationPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► DonationPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DonationPercentSpecified { get; set; }
Public Property DonationPercentSpecified As Boolean
    Get
    Set
public:
property bool DonationPercentSpecified {
    bool get ();
    void set (bool value);
}


LogoURL Property

LogoURL Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► LogoURL
Declaration Syntax
C# Visual Basic Visual C++
public string LogoURL { get; set; }
Public Property LogoURL As String
    Get
    Set
public:
property String^ LogoURL {
    String^ get ();
    void set (String^ value);
}


Mission Property

Mission Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► Mission
Declaration Syntax
C# Visual Basic Visual C++
public string Mission { get; set; }
Public Property Mission As String
    Get
    Set
public:
property String^ Mission {
    String^ get ();
    void set (String^ value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public CharityStatusCodeType Status { get; set; }
Public Property Status As CharityStatusCodeType
    Get
    Set
public:
property CharityStatusCodeType Status {
    CharityStatusCodeType get ();
    void set (CharityStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CharityType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


CheckoutMethodCodeType Enumeration

CheckoutMethodCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CheckoutMethodCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CheckoutMethodCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CheckoutMethodCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CheckoutMethodCodeType
Members
Member | Description
Other |
ThirdPartyCheckout |
CustomCode |
Remarks


CheckoutStatusCodeType Enumeration

CheckoutStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CheckoutStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CheckoutStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CheckoutStatusCodeType
Members
Member | Description
CheckoutComplete |
CheckoutIncomplete |
BuyerRequestsTotal |
SellerResponded |
CustomCode |
Remarks


CheckoutStatusType Class

CheckoutStatusType Class
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CheckoutStatusType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CheckoutStatusType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CheckoutStatusType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckoutStatusType()()()() |
 | Any |
 | eBayPaymentMismatchDetails |
 | eBayPaymentStatus |
 | eBayPaymentStatusSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IntegratedMerchantCreditCardEnabled |
 | IntegratedMerchantCreditCardEnabledSpecified |
 | LastModifiedTime |
 | LastModifiedTimeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PaymentInstrument |
 | PaymentInstrumentSpecified |
 | PaymentMethod |
 | PaymentMethodSpecified |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CheckoutStatusType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CheckoutStatusType Constructor

CheckoutStatusType Constructor
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► CheckoutStatusType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CheckoutStatusType()
Public Sub New
public:
CheckoutStatusType()


eBayPaymentMismatchDetails Property

eBayPaymentMismatchDetails Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► eBayPaymentMismatchDetails
Declaration Syntax
C# Visual Basic Visual C++
public eBayPaymentMismatchDetailsType eBayPaymentMismatchDetails { get; set; }
Public Property eBayPaymentMismatchDetails As eBayPaymentMismatchDetailsType
    Get
    Set
public:
property eBayPaymentMismatchDetailsType^ eBayPaymentMismatchDetails {
    eBayPaymentMismatchDetailsType^ get ();
    void set (eBayPaymentMismatchDetailsType^ value);
}


eBayPaymentStatus Property

eBayPaymentStatus Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► eBayPaymentStatus
Declaration Syntax
C# Visual Basic Visual C++
public PaymentStatusCodeType eBayPaymentStatus { get; set; }
Public Property eBayPaymentStatus As PaymentStatusCodeType
    Get
    Set
public:
property PaymentStatusCodeType eBayPaymentStatus {
    PaymentStatusCodeType get ();
    void set (PaymentStatusCodeType value);
}


eBayPaymentStatusSpecified Property

eBayPaymentStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► eBayPaymentStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayPaymentStatusSpecified { get; set; }
Public Property eBayPaymentStatusSpecified As Boolean
    Get
    Set
public:
property bool eBayPaymentStatusSpecified {
    bool get ();
    void set (bool value);
}


IntegratedMerchantCreditCardEnabled Property

IntegratedMerchantCreditCardEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► IntegratedMerchantCreditCardEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool IntegratedMerchantCreditCardEnabled { get; set; }
Public Property IntegratedMerchantCreditCardEnabled As Boolean
    Get
    Set
public:
property bool IntegratedMerchantCreditCardEnabled {
    bool get ();
    void set (bool value);
}


IntegratedMerchantCreditCardEnabledSpecified Property

IntegratedMerchantCreditCardEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► IntegratedMerchantCreditCardEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IntegratedMerchantCreditCardEnabledSpecified { get; set; }
Public Property IntegratedMerchantCreditCardEnabledSpecified As Boolean
    Get
    Set
public:
property bool IntegratedMerchantCreditCardEnabledSpecified {
    bool get ();
    void set (bool value);
}


LastModifiedTime Property

LastModifiedTime Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► LastModifiedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastModifiedTime { get; set; }
Public Property LastModifiedTime As DateTime
    Get
    Set
public:
property DateTime LastModifiedTime {
    DateTime get ();
    void set (DateTime value);
}


LastModifiedTimeSpecified Property

LastModifiedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► LastModifiedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastModifiedTimeSpecified { get; set; }
Public Property LastModifiedTimeSpecified As Boolean
    Get
    Set
public:
property bool LastModifiedTimeSpecified {
    bool get ();
    void set (bool value);
}


PaymentInstrument Property

PaymentInstrument Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► PaymentInstrument
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentInstrumentCodeType PaymentInstrument { get; set; }
Public Property PaymentInstrument As BuyerPaymentInstrumentCodeType
    Get
    Set
public:
property BuyerPaymentInstrumentCodeType PaymentInstrument {
    BuyerPaymentInstrumentCodeType get ();
    void set (BuyerPaymentInstrumentCodeType value);
}


PaymentInstrumentSpecified Property

PaymentInstrumentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► PaymentInstrumentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentInstrumentSpecified { get; set; }
Public Property PaymentInstrumentSpecified As Boolean
    Get
    Set
public:
property bool PaymentInstrumentSpecified {
    bool get ();
    void set (bool value);
}


PaymentMethod Property

PaymentMethod Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► PaymentMethod
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeType PaymentMethod { get; set; }
Public Property PaymentMethod As BuyerPaymentMethodCodeType
    Get
    Set
public:
property BuyerPaymentMethodCodeType PaymentMethod {
    BuyerPaymentMethodCodeType get ();
    void set (BuyerPaymentMethodCodeType value);
}


PaymentMethodSpecified Property

PaymentMethodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► PaymentMethodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentMethodSpecified { get; set; }
Public Property PaymentMethodSpecified As Boolean
    Get
    Set
public:
property bool PaymentMethodSpecified {
    bool get ();
    void set (bool value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public CompleteStatusCodeType Status { get; set; }
Public Property Status As CompleteStatusCodeType
    Get
    Set
public:
property CompleteStatusCodeType Status {
    CompleteStatusCodeType get ();
    void set (CompleteStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CheckoutStatusType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdAutoAcceptEnabledDefinitionType Class

ClassifiedAdAutoAcceptEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdAutoAcceptEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdAutoAcceptEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdAutoAcceptEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdAutoAcceptEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdAutoAcceptEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdAutoAcceptEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdAutoAcceptEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdAutoAcceptEnabledDefinitionType Constructor

ClassifiedAdAutoAcceptEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdAutoAcceptEnabledDefinitionType ► ClassifiedAdAutoAcceptEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdAutoAcceptEnabledDefinitionType()
Public Sub New
public:
ClassifiedAdAutoAcceptEnabledDefinitionType()


ClassifiedAdAutoDeclineEnabledDefinitionType Class

ClassifiedAdAutoDeclineEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdAutoDeclineEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdAutoDeclineEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdAutoDeclineEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdAutoDeclineEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdAutoDeclineEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdAutoDeclineEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdAutoDeclineEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdAutoDeclineEnabledDefinitionType Constructor

ClassifiedAdAutoDeclineEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdAutoDeclineEnabledDefinitionType ► ClassifiedAdAutoDeclineEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdAutoDeclineEnabledDefinitionType()
Public Sub New
public:
ClassifiedAdAutoDeclineEnabledDefinitionType()


ClassifiedAdBestOfferEnabledCodeType Enumeration

ClassifiedAdBestOfferEnabledCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdBestOfferEnabledCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ClassifiedAdBestOfferEnabledCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ClassifiedAdBestOfferEnabledCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ClassifiedAdBestOfferEnabledCodeType
Members
Member | Description
Disabled |
Enabled |
Required |
CustomCode |
Remarks


ClassifiedAdBestOfferEnabledDefinitionType Class

ClassifiedAdBestOfferEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdBestOfferEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdBestOfferEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdBestOfferEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdBestOfferEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdBestOfferEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdBestOfferEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdBestOfferEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdBestOfferEnabledDefinitionType Constructor

ClassifiedAdBestOfferEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdBestOfferEnabledDefinitionType ► ClassifiedAdBestOfferEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdBestOfferEnabledDefinitionType()
Public Sub New
public:
ClassifiedAdBestOfferEnabledDefinitionType()


ClassifiedAdCompanyNameEnabledDefinitionType Class

ClassifiedAdCompanyNameEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdCompanyNameEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdCompanyNameEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdCompanyNameEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdCompanyNameEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdCompanyNameEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdCompanyNameEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdCompanyNameEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdCompanyNameEnabledDefinitionType Constructor

ClassifiedAdCompanyNameEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdCompanyNameEnabledDefinitionType ► ClassifiedAdCompanyNameEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdCompanyNameEnabledDefinitionType()
Public Sub New
public:
ClassifiedAdCompanyNameEnabledDefinitionType()


ClassifiedAdContactByAddressEnabledDefinitionType Class

ClassifiedAdContactByAddressEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdContactByAddressEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdContactByAddressEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdContactByAddressEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdContactByAddressEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdContactByAddressEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdContactByAddressEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdContactByAddressEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdContactByAddressEnabledDefinitionType Constructor

ClassifiedAdContactByAddressEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdContactByAddressEnabledDefinitionType ► ClassifiedAdContactByAddressEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdContactByAddressEnabledDefinitionType()
Public Sub New
public:
ClassifiedAdContactByAddressEnabledDefinitionType()


ClassifiedAdContactByEmailEnabledDefintionType Class

ClassifiedAdContactByEmailEnabledDefintionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdContactByEmailEnabledDefintionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdContactByEmailEnabledDefintionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdContactByEmailEnabledDefintionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdContactByEmailEnabledDefintionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdContactByEmailEnabledDefintionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdContactByEmailEnabledDefintionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdContactByEmailEnabledDefintionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdContactByEmailEnabledDefintionType Constructor

ClassifiedAdContactByEmailEnabledDefintionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdContactByEmailEnabledDefintionType ► ClassifiedAdContactByEmailEnabledDefintionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdContactByEmailEnabledDefintionType()
Public Sub New
public:
ClassifiedAdContactByEmailEnabledDefintionType()


ClassifiedAdContactByPhoneEnabledDefinitionType Class

ClassifiedAdContactByPhoneEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdContactByPhoneEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdContactByPhoneEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdContactByPhoneEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdContactByPhoneEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdContactByPhoneEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdContactByPhoneEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdContactByPhoneEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdContactByPhoneEnabledDefinitionType Constructor

ClassifiedAdContactByPhoneEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdContactByPhoneEnabledDefinitionType ► ClassifiedAdContactByPhoneEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdContactByPhoneEnabledDefinitionType()
Public Sub New
public:
ClassifiedAdContactByPhoneEnabledDefinitionType()


ClassifiedAdCounterOfferEnabledDefinitionType Class

ClassifiedAdCounterOfferEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdCounterOfferEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdCounterOfferEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdCounterOfferEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdCounterOfferEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdCounterOfferEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdCounterOfferEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdCounterOfferEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdCounterOfferEnabledDefinitionType Constructor

ClassifiedAdCounterOfferEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdCounterOfferEnabledDefinitionType ► ClassifiedAdCounterOfferEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdCounterOfferEnabledDefinitionType()
Public Sub New
public:
ClassifiedAdCounterOfferEnabledDefinitionType()


ClassifiedAdPaymentMethodEnabledCodeType Enumeration

ClassifiedAdPaymentMethodEnabledCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdPaymentMethodEnabledCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ClassifiedAdPaymentMethodEnabledCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ClassifiedAdPaymentMethodEnabledCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ClassifiedAdPaymentMethodEnabledCodeType
Members
Member | Description
EnabledWithCheckout |
EnabledWithoutCheckout |
NotSupported |
CustomCode |
Remarks


ClassifiedAdPaymentMethodEnabledDefinitionType Class

ClassifiedAdPaymentMethodEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdPaymentMethodEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdPaymentMethodEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdPaymentMethodEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdPaymentMethodEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdPaymentMethodEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdPaymentMethodEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdPaymentMethodEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdPaymentMethodEnabledDefinitionType Constructor

ClassifiedAdPaymentMethodEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdPaymentMethodEnabledDefinitionType ► ClassifiedAdPaymentMethodEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPaymentMethodEnabledDefinitionType()
Public Sub New
public:
ClassifiedAdPaymentMethodEnabledDefinitionType()


ClassifiedAdPayPerLeadEnabledDefinitionType Class

ClassifiedAdPayPerLeadEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdPayPerLeadEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdPayPerLeadEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdPayPerLeadEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdPayPerLeadEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdPayPerLeadEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdPayPerLeadEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdPayPerLeadEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdPayPerLeadEnabledDefinitionType Constructor

ClassifiedAdPayPerLeadEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdPayPerLeadEnabledDefinitionType ► ClassifiedAdPayPerLeadEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPayPerLeadEnabledDefinitionType()
Public Sub New
public:
ClassifiedAdPayPerLeadEnabledDefinitionType()


ClassifiedAdPhoneCountDefinitionType Class

ClassifiedAdPhoneCountDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdPhoneCountDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdPhoneCountDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdPhoneCountDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdPhoneCountDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdPhoneCountDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdPhoneCountDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdPhoneCountDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdPhoneCountDefinitionType Constructor

ClassifiedAdPhoneCountDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdPhoneCountDefinitionType ► ClassifiedAdPhoneCountDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPhoneCountDefinitionType()
Public Sub New
public:
ClassifiedAdPhoneCountDefinitionType()


ClassifiedAdShippingMethodEnabledDefinitionType Class

ClassifiedAdShippingMethodEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdShippingMethodEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdShippingMethodEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdShippingMethodEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdShippingMethodEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdShippingMethodEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdShippingMethodEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdShippingMethodEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdShippingMethodEnabledDefinitionType Constructor

ClassifiedAdShippingMethodEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdShippingMethodEnabledDefinitionType ► ClassifiedAdShippingMethodEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdShippingMethodEnabledDefinitionType()
Public Sub New
public:
ClassifiedAdShippingMethodEnabledDefinitionType()


ClassifiedAdStreetCountDefinitionType Class

ClassifiedAdStreetCountDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdStreetCountDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ClassifiedAdStreetCountDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ClassifiedAdStreetCountDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ClassifiedAdStreetCountDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassifiedAdStreetCountDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClassifiedAdStreetCountDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdStreetCountDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdStreetCountDefinitionType Constructor

ClassifiedAdStreetCountDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ClassifiedAdStreetCountDefinitionType ► ClassifiedAdStreetCountDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdStreetCountDefinitionType()
Public Sub New
public:
ClassifiedAdStreetCountDefinitionType()


CombinedFixedPriceTreatmentEnabledDefinitionType Class

CombinedFixedPriceTreatmentEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► CombinedFixedPriceTreatmentEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CombinedFixedPriceTreatmentEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CombinedFixedPriceTreatmentEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CombinedFixedPriceTreatmentEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CombinedFixedPriceTreatmentEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CombinedFixedPriceTreatmentEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CombinedFixedPriceTreatmentEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CombinedFixedPriceTreatmentEnabledDefinitionType Constructor

CombinedFixedPriceTreatmentEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► CombinedFixedPriceTreatmentEnabledDefinitionType ► CombinedFixedPriceTreatmentEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CombinedFixedPriceTreatmentEnabledDefinitionType()
Public Sub New
public:
CombinedFixedPriceTreatmentEnabledDefinitionType()


CombinedPaymentOptionCodeType Enumeration

CombinedPaymentOptionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CombinedPaymentOptionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CombinedPaymentOptionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CombinedPaymentOptionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CombinedPaymentOptionCodeType
Members
Member | Description
NoCombinedPayment |
DiscountSpecified |
SpecifyDiscountLater |
CustomCode |
Remarks


CombinedPaymentPeriodCodeType Enumeration

CombinedPaymentPeriodCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CombinedPaymentPeriodCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CombinedPaymentPeriodCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CombinedPaymentPeriodCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CombinedPaymentPeriodCodeType
Members
Member | Description
Days_3 |
Days_5 |
Days_7 |
Days_14 |
Days_30 |
Ineligible |
CustomCode |
Remarks


CombinedPaymentPreferencesType Class

CombinedPaymentPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► CombinedPaymentPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CombinedPaymentPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CombinedPaymentPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CombinedPaymentPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CombinedPaymentPreferencesType()()()() |
 | Any |
 | CalculatedShippingPreferences |
 | CombinedPaymentOption |
 | CombinedPaymentOptionSpecified |
 | CombinedPaymentPeriod |
 | CombinedPaymentPeriodSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FlatShippingPreferences |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CombinedPaymentPreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CombinedPaymentPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CalculatedShippingPreferences Property

CalculatedShippingPreferences Property
Namespaces ► eBay.Service.Core.Soap ► CombinedPaymentPreferencesType ► CalculatedShippingPreferences
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingPreferencesType CalculatedShippingPreferences { get; set; }
Public Property CalculatedShippingPreferences As CalculatedShippingPreferencesType
    Get
    Set
public:
property CalculatedShippingPreferencesType^ CalculatedShippingPreferences {
    CalculatedShippingPreferencesType^ get ();
    void set (CalculatedShippingPreferencesType^ value);
}


CombinedPaymentOption Property

CombinedPaymentOption Property
Namespaces ► eBay.Service.Core.Soap ► CombinedPaymentPreferencesType ► CombinedPaymentOption
Declaration Syntax
C# Visual Basic Visual C++
public CombinedPaymentOptionCodeType CombinedPaymentOption { get; set; }
Public Property CombinedPaymentOption As CombinedPaymentOptionCodeType
    Get
    Set
public:
property CombinedPaymentOptionCodeType CombinedPaymentOption {
    CombinedPaymentOptionCodeType get ();
    void set (CombinedPaymentOptionCodeType value);
}


CombinedPaymentOptionSpecified Property

CombinedPaymentOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CombinedPaymentPreferencesType ► CombinedPaymentOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CombinedPaymentOptionSpecified { get; set; }
Public Property CombinedPaymentOptionSpecified As Boolean
    Get
    Set
public:
property bool CombinedPaymentOptionSpecified {
    bool get ();
    void set (bool value);
}


CombinedPaymentPeriod Property

CombinedPaymentPeriod Property
Namespaces ► eBay.Service.Core.Soap ► CombinedPaymentPreferencesType ► CombinedPaymentPeriod
Declaration Syntax
C# Visual Basic Visual C++
public CombinedPaymentPeriodCodeType CombinedPaymentPeriod { get; set; }
Public Property CombinedPaymentPeriod As CombinedPaymentPeriodCodeType
    Get
    Set
public:
property CombinedPaymentPeriodCodeType CombinedPaymentPeriod {
    CombinedPaymentPeriodCodeType get ();
    void set (CombinedPaymentPeriodCodeType value);
}


CombinedPaymentPeriodSpecified Property

CombinedPaymentPeriodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CombinedPaymentPreferencesType ► CombinedPaymentPeriodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CombinedPaymentPeriodSpecified { get; set; }
Public Property CombinedPaymentPeriodSpecified As Boolean
    Get
    Set
public:
property bool CombinedPaymentPeriodSpecified {
    bool get ();
    void set (bool value);
}


CombinedPaymentPreferencesType Constructor

CombinedPaymentPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► CombinedPaymentPreferencesType ► CombinedPaymentPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CombinedPaymentPreferencesType()
Public Sub New
public:
CombinedPaymentPreferencesType()


FlatShippingPreferences Property

FlatShippingPreferences Property
Namespaces ► eBay.Service.Core.Soap ► CombinedPaymentPreferencesType ► FlatShippingPreferences
Declaration Syntax
C# Visual Basic Visual C++
public FlatShippingPreferencesType FlatShippingPreferences { get; set; }
Public Property FlatShippingPreferences As FlatShippingPreferencesType
    Get
    Set
public:
property FlatShippingPreferencesType^ FlatShippingPreferences {
    FlatShippingPreferencesType^ get ();
    void set (FlatShippingPreferencesType^ value);
}


CommentTypeCodeType Enumeration

CommentTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CommentTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CommentTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CommentTypeCodeType
Members
Member | Description
Positive |
Neutral |
Negative |
Withdrawn |
IndependentlyWithdrawn |
CustomCode |
Remarks


CommentTypeCodeTypeCollection Class

CommentTypeCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CommentTypeCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CommentTypeCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CommentTypeCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CommentTypeCodeTypeCollection()()()() |
 | CommentTypeCodeTypeCollection(array<CommentTypeCodeType>[]()[][]) |
 | CommentTypeCodeTypeCollection(CommentTypeCodeTypeCollection) |
 | Add(CommentTypeCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CommentTypeCodeType>[]()[][]) |
 | AddRange(CommentTypeCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CommentTypeCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CommentTypeCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CommentTypeCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CommentTypeCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CommentTypeCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CommentTypeCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► Add(CommentTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CommentTypeCodeType item
)
Public Function Add ( _
    item As CommentTypeCodeType _
) As Integer
public:
int Add(
    CommentTypeCodeType item
)
Parameters
item (CommentTypeCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CommentTypeCodeType>[]()[][]) |
 | AddRange(CommentTypeCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► AddRange(array<CommentTypeCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CommentTypeCodeType[] items
)
Public Sub AddRange ( _
    items As CommentTypeCodeType() _
)
public:
void AddRange(
    array<CommentTypeCodeType>^ items
)
Parameters
items (array< CommentTypeCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► AddRange(CommentTypeCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CommentTypeCodeTypeCollection items
)
Public Sub AddRange ( _
    items As CommentTypeCodeTypeCollection _
)
public:
void AddRange(
    CommentTypeCodeTypeCollection^ items
)
Parameters
items (CommentTypeCodeTypeCollection)


CommentTypeCodeTypeCollection Constructor

CommentTypeCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► CommentTypeCodeTypeCollection()()()()
Members
Icon | Member | Description
 | CommentTypeCodeTypeCollection()()()() |
 | CommentTypeCodeTypeCollection(array<CommentTypeCodeType>[]()[][]) |
 | CommentTypeCodeTypeCollection(CommentTypeCodeTypeCollection) |


CommentTypeCodeTypeCollection Constructor

CommentTypeCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► CommentTypeCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeTypeCollection()
Public Sub New
public:
CommentTypeCodeTypeCollection()


CommentTypeCodeTypeCollection Constructor (items)

CommentTypeCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► CommentTypeCodeTypeCollection(array<CommentTypeCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeTypeCollection(
    CommentTypeCodeType[] items
)
Public Sub New ( _
    items As CommentTypeCodeType() _
)
public:
CommentTypeCodeTypeCollection(
    array<CommentTypeCodeType>^ items
)
Parameters
items (array< CommentTypeCodeType >[]()[][])


CommentTypeCodeTypeCollection Constructor (items)

CommentTypeCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► CommentTypeCodeTypeCollection(CommentTypeCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeTypeCollection(
    CommentTypeCodeTypeCollection items
)
Public Sub New ( _
    items As CommentTypeCodeTypeCollection _
)
public:
CommentTypeCodeTypeCollection(
    CommentTypeCodeTypeCollection^ items
)
Parameters
items (CommentTypeCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► Contains(CommentTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CommentTypeCodeType item
)
Public Function Contains ( _
    item As CommentTypeCodeType _
) As Boolean
public:
bool Contains(
    CommentTypeCodeType item
)
Parameters
item (CommentTypeCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► CopyTo(array<CommentTypeCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CommentTypeCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CommentTypeCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CommentTypeCodeType>^ items,
    int index
)
Parameters
items (array< CommentTypeCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► IndexOf(CommentTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CommentTypeCodeType item
)
Public Function IndexOf ( _
    item As CommentTypeCodeType _
) As Integer
public:
int IndexOf(
    CommentTypeCodeType item
)
Parameters
item (CommentTypeCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► Insert(Int32, CommentTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CommentTypeCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CommentTypeCodeType _
)
public:
void Insert(
    int index,
    CommentTypeCodeType item
)
Parameters
index (Int32)
item (CommentTypeCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CommentTypeCodeType
    Get
    Set
public:
property CommentTypeCodeType default[int index] {
    CommentTypeCodeType get (int index);
    void set (int index, CommentTypeCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CommentTypeCodeType
public:
CommentTypeCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► Remove(CommentTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CommentTypeCodeType item
)
Public Sub Remove ( _
    item As CommentTypeCodeType _
)
public:
void Remove(
    CommentTypeCodeType item
)
Parameters
item (CommentTypeCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeType[] ToArray()
Public Function ToArray As CommentTypeCodeType()
public:
array<CommentTypeCodeType>^ ToArray()
Return Value


CompatibleVehicleTypeDefinitionType Class

CompatibleVehicleTypeDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► CompatibleVehicleTypeDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CompatibleVehicleTypeDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CompatibleVehicleTypeDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CompatibleVehicleTypeDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompatibleVehicleTypeDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CompatibleVehicleTypeDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CompatibleVehicleTypeDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CompatibleVehicleTypeDefinitionType Constructor

CompatibleVehicleTypeDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► CompatibleVehicleTypeDefinitionType ► CompatibleVehicleTypeDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CompatibleVehicleTypeDefinitionType()
Public Sub New
public:
CompatibleVehicleTypeDefinitionType()


CompleteSaleRequestType Class

CompleteSaleRequestType Class
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CompleteSaleRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CompleteSaleRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CompleteSaleRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompleteSaleRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | FeedbackInfo |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | ListingType |
 | ListingTypeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderID |
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Paid |
 | PaidSpecified |
 | Shipment |
 | Shipped |
 | ShippedSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | CompleteSaleRequestType


CompleteSaleRequestType Constructor

CompleteSaleRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► CompleteSaleRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CompleteSaleRequestType()
Public Sub New
public:
CompleteSaleRequestType()


FeedbackInfo Property

FeedbackInfo Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► FeedbackInfo
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackInfoType FeedbackInfo { get; set; }
Public Property FeedbackInfo As FeedbackInfoType
    Get
    Set
public:
property FeedbackInfoType^ FeedbackInfo {
    FeedbackInfoType^ get ();
    void set (FeedbackInfoType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingType Property

ListingType Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► ListingType
Declaration Syntax
C# Visual Basic Visual C++
public ListingTypeCodeType ListingType { get; set; }
Public Property ListingType As ListingTypeCodeType
    Get
    Set
public:
property ListingTypeCodeType ListingType {
    ListingTypeCodeType get ();
    void set (ListingTypeCodeType value);
}


ListingTypeSpecified Property

ListingTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► ListingTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingTypeSpecified { get; set; }
Public Property ListingTypeSpecified As Boolean
    Get
    Set
public:
property bool ListingTypeSpecified {
    bool get ();
    void set (bool value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► OrderID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


Paid Property

Paid Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► Paid
Declaration Syntax
C# Visual Basic Visual C++
public bool Paid { get; set; }
Public Property Paid As Boolean
    Get
    Set
public:
property bool Paid {
    bool get ();
    void set (bool value);
}


PaidSpecified Property

PaidSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► PaidSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaidSpecified { get; set; }
Public Property PaidSpecified As Boolean
    Get
    Set
public:
property bool PaidSpecified {
    bool get ();
    void set (bool value);
}


Shipment Property

Shipment Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► Shipment
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentType Shipment { get; set; }
Public Property Shipment As ShipmentType
    Get
    Set
public:
property ShipmentType^ Shipment {
    ShipmentType^ get ();
    void set (ShipmentType^ value);
}


Shipped Property

Shipped Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► Shipped
Declaration Syntax
C# Visual Basic Visual C++
public bool Shipped { get; set; }
Public Property Shipped As Boolean
    Get
    Set
public:
property bool Shipped {
    bool get ();
    void set (bool value);
}


ShippedSpecified Property

ShippedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► ShippedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippedSpecified { get; set; }
Public Property ShippedSpecified As Boolean
    Get
    Set
public:
property bool ShippedSpecified {
    bool get ();
    void set (bool value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


CompleteSaleResponseType Class

CompleteSaleResponseType Class
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CompleteSaleResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CompleteSaleResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CompleteSaleResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompleteSaleResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | CompleteSaleResponseType


CompleteSaleResponseType Constructor

CompleteSaleResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► CompleteSaleResponseType ► CompleteSaleResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CompleteSaleResponseType()
Public Sub New
public:
CompleteSaleResponseType()


CompleteStatusCodeType Enumeration

CompleteStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CompleteStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CompleteStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CompleteStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CompleteStatusCodeType
Members
Member | Description
Incomplete |
Complete |
Pending |
CustomCode |
Remarks


ConditionEnabledCodeType Enumeration

ConditionEnabledCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ConditionEnabledCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ConditionEnabledCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ConditionEnabledCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ConditionEnabledCodeType
Members
Member | Description
Disabled |
Enabled |
Required |
CustomCode |
Remarks


ConditionEnabledDefinitionType Class

ConditionEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ConditionEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ConditionEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ConditionEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ConditionEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ConditionEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ConditionEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ConditionEnabledDefinitionType Constructor

ConditionEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ConditionEnabledDefinitionType ► ConditionEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ConditionEnabledDefinitionType()
Public Sub New
public:
ConditionEnabledDefinitionType()


ConditionType Class

ConditionType Class
Namespaces ► eBay.Service.Core.Soap ► ConditionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ConditionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ConditionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ConditionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionType()()()() |
 | Any |
 | DisplayName |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ID |
 | IDSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ConditionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ConditionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ConditionType Constructor

ConditionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ConditionType ► ConditionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ConditionType()
Public Sub New
public:
ConditionType()


DisplayName Property

DisplayName Property
Namespaces ► eBay.Service.Core.Soap ► ConditionType ► DisplayName
Declaration Syntax
C# Visual Basic Visual C++
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}


ID Property

ID Property
Namespaces ► eBay.Service.Core.Soap ► ConditionType ► ID
Declaration Syntax
C# Visual Basic Visual C++
public int ID { get; set; }
Public Property ID As Integer
    Get
    Set
public:
property int ID {
    int get ();
    void set (int value);
}


IDSpecified Property

IDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ConditionType ► IDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IDSpecified { get; set; }
Public Property IDSpecified As Boolean
    Get
    Set
public:
property bool IDSpecified {
    bool get ();
    void set (bool value);
}


ConditionTypeCollection Class

ConditionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ConditionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ConditionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ConditionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionTypeCollection()()()() |
 | ConditionTypeCollection(array<ConditionType>[]()[][]) |
 | ConditionTypeCollection(ConditionTypeCollection) |
 | Add(ConditionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ConditionType>[]()[][]) |
 | AddRange(ConditionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ConditionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ConditionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ConditionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ConditionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ConditionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ConditionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► Add(ConditionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ConditionType item
)
Public Function Add ( _
    item As ConditionType _
) As Integer
public:
int Add(
    ConditionType^ item
)
Parameters
item (ConditionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ConditionType>[]()[][]) |
 | AddRange(ConditionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► AddRange(array<ConditionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ConditionType[] items
)
Public Sub AddRange ( _
    items As ConditionType() _
)
public:
void AddRange(
    array<ConditionType^>^ items
)
Parameters
items (array< ConditionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► AddRange(ConditionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ConditionTypeCollection items
)
Public Sub AddRange ( _
    items As ConditionTypeCollection _
)
public:
void AddRange(
    ConditionTypeCollection^ items
)
Parameters
items (ConditionTypeCollection)


ConditionTypeCollection Constructor

ConditionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► ConditionTypeCollection()()()()
Members
Icon | Member | Description
 | ConditionTypeCollection()()()() |
 | ConditionTypeCollection(array<ConditionType>[]()[][]) |
 | ConditionTypeCollection(ConditionTypeCollection) |


ConditionTypeCollection Constructor

ConditionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► ConditionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ConditionTypeCollection()
Public Sub New
public:
ConditionTypeCollection()


ConditionTypeCollection Constructor (items)

ConditionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► ConditionTypeCollection(array<ConditionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ConditionTypeCollection(
    ConditionType[] items
)
Public Sub New ( _
    items As ConditionType() _
)
public:
ConditionTypeCollection(
    array<ConditionType^>^ items
)
Parameters
items (array< ConditionType >[]()[][])


ConditionTypeCollection Constructor (items)

ConditionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► ConditionTypeCollection(ConditionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ConditionTypeCollection(
    ConditionTypeCollection items
)
Public Sub New ( _
    items As ConditionTypeCollection _
)
public:
ConditionTypeCollection(
    ConditionTypeCollection^ items
)
Parameters
items (ConditionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► Contains(ConditionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ConditionType item
)
Public Function Contains ( _
    item As ConditionType _
) As Boolean
public:
bool Contains(
    ConditionType^ item
)
Parameters
item (ConditionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► CopyTo(array<ConditionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ConditionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ConditionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ConditionType^>^ items,
    int index
)
Parameters
items (array< ConditionType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► IndexOf(ConditionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ConditionType item
)
Public Function IndexOf ( _
    item As ConditionType _
) As Integer
public:
int IndexOf(
    ConditionType^ item
)
Parameters
item (ConditionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► Insert(Int32, ConditionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ConditionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ConditionType _
)
public:
void Insert(
    int index,
    ConditionType^ item
)
Parameters
index (Int32)
item (ConditionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ConditionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ConditionType
    Get
    Set
public:
property ConditionType^ default[int index] {
    ConditionType^ get (int index);
    void set (int index, ConditionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ConditionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ConditionType
public:
ConditionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► Remove(ConditionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ConditionType item
)
Public Sub Remove ( _
    item As ConditionType _
)
public:
void Remove(
    ConditionType^ item
)
Parameters
item (ConditionType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ConditionType[] ToArray()
Public Function ToArray As ConditionType()
public:
array<ConditionType^>^ ToArray()
Return Value


ConditionValuesDefinitionType Class

ConditionValuesDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ConditionValuesDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ConditionValuesDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ConditionValuesDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ConditionValuesDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionValuesDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ConditionValuesDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ConditionValuesDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ConditionValuesDefinitionType Constructor

ConditionValuesDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ConditionValuesDefinitionType ► ConditionValuesDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ConditionValuesDefinitionType()
Public Sub New
public:
ConditionValuesDefinitionType()


ConditionValuesType Class

ConditionValuesType Class
Namespaces ► eBay.Service.Core.Soap ► ConditionValuesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ConditionValuesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ConditionValuesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ConditionValuesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionValuesType()()()() |
 | Any |
 | Condition |
 | ConditionHelpURL |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ConditionValuesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ConditionValuesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Condition Property

Condition Property
Namespaces ► eBay.Service.Core.Soap ► ConditionValuesType ► Condition
Declaration Syntax
C# Visual Basic Visual C++
public ConditionTypeCollection Condition { get; set; }
Public Property Condition As ConditionTypeCollection
    Get
    Set
public:
property ConditionTypeCollection^ Condition {
    ConditionTypeCollection^ get ();
    void set (ConditionTypeCollection^ value);
}


ConditionHelpURL Property

ConditionHelpURL Property
Namespaces ► eBay.Service.Core.Soap ► ConditionValuesType ► ConditionHelpURL
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionHelpURL { get; set; }
Public Property ConditionHelpURL As String
    Get
    Set
public:
property String^ ConditionHelpURL {
    String^ get ();
    void set (String^ value);
}


ConditionValuesType Constructor

ConditionValuesType Constructor
Namespaces ► eBay.Service.Core.Soap ► ConditionValuesType ► ConditionValuesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ConditionValuesType()
Public Sub New
public:
ConditionValuesType()


ConfirmIdentityRequestType Class

ConfirmIdentityRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ConfirmIdentityRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ConfirmIdentityRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ConfirmIdentityRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ConfirmIdentityRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfirmIdentityRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SessionID |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ConfirmIdentityRequestType


ConfirmIdentityRequestType Constructor

ConfirmIdentityRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ConfirmIdentityRequestType ► ConfirmIdentityRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ConfirmIdentityRequestType()
Public Sub New
public:
ConfirmIdentityRequestType()


SessionID Property

SessionID Property
Namespaces ► eBay.Service.Core.Soap ► ConfirmIdentityRequestType ► SessionID
Declaration Syntax
C# Visual Basic Visual C++
public string SessionID { get; set; }
Public Property SessionID As String
    Get
    Set
public:
property String^ SessionID {
    String^ get ();
    void set (String^ value);
}


ConfirmIdentityResponseType Class

ConfirmIdentityResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ConfirmIdentityResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ConfirmIdentityResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ConfirmIdentityResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ConfirmIdentityResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfirmIdentityResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | UserID |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ConfirmIdentityResponseType


ConfirmIdentityResponseType Constructor

ConfirmIdentityResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ConfirmIdentityResponseType ► ConfirmIdentityResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ConfirmIdentityResponseType()
Public Sub New
public:
ConfirmIdentityResponseType()


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► ConfirmIdentityResponseType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


ContactHoursDetailsType Class

ContactHoursDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ContactHoursDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ContactHoursDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ContactHoursDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContactHoursDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Hours1AnyTime |
 | Hours1AnyTimeSpecified |
 | Hours1Days |
 | Hours1DaysSpecified |
 | Hours1From |
 | Hours1FromSpecified |
 | Hours1To |
 | Hours1ToSpecified |
 | Hours2AnyTime |
 | Hours2AnyTimeSpecified |
 | Hours2Days |
 | Hours2DaysSpecified |
 | Hours2From |
 | Hours2FromSpecified |
 | Hours2To |
 | Hours2ToSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | TimeZoneID |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ContactHoursDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ContactHoursDetailsType Constructor

ContactHoursDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► ContactHoursDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ContactHoursDetailsType()
Public Sub New
public:
ContactHoursDetailsType()


Hours1AnyTime Property

Hours1AnyTime Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours1AnyTime
Declaration Syntax
C# Visual Basic Visual C++
public bool Hours1AnyTime { get; set; }
Public Property Hours1AnyTime As Boolean
    Get
    Set
public:
property bool Hours1AnyTime {
    bool get ();
    void set (bool value);
}


Hours1AnyTimeSpecified Property

Hours1AnyTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours1AnyTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool Hours1AnyTimeSpecified { get; set; }
Public Property Hours1AnyTimeSpecified As Boolean
    Get
    Set
public:
property bool Hours1AnyTimeSpecified {
    bool get ();
    void set (bool value);
}


Hours1Days Property

Hours1Days Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours1Days
Declaration Syntax
C# Visual Basic Visual C++
public DaysCodeType Hours1Days { get; set; }
Public Property Hours1Days As DaysCodeType
    Get
    Set
public:
property DaysCodeType Hours1Days {
    DaysCodeType get ();
    void set (DaysCodeType value);
}


Hours1DaysSpecified Property

Hours1DaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours1DaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool Hours1DaysSpecified { get; set; }
Public Property Hours1DaysSpecified As Boolean
    Get
    Set
public:
property bool Hours1DaysSpecified {
    bool get ();
    void set (bool value);
}


Hours1From Property

Hours1From Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours1From
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Hours1From { get; set; }
Public Property Hours1From As DateTime
    Get
    Set
public:
property DateTime Hours1From {
    DateTime get ();
    void set (DateTime value);
}


Hours1FromSpecified Property

Hours1FromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours1FromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool Hours1FromSpecified { get; set; }
Public Property Hours1FromSpecified As Boolean
    Get
    Set
public:
property bool Hours1FromSpecified {
    bool get ();
    void set (bool value);
}


Hours1To Property

Hours1To Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours1To
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Hours1To { get; set; }
Public Property Hours1To As DateTime
    Get
    Set
public:
property DateTime Hours1To {
    DateTime get ();
    void set (DateTime value);
}


Hours1ToSpecified Property

Hours1ToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours1ToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool Hours1ToSpecified { get; set; }
Public Property Hours1ToSpecified As Boolean
    Get
    Set
public:
property bool Hours1ToSpecified {
    bool get ();
    void set (bool value);
}


Hours2AnyTime Property

Hours2AnyTime Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours2AnyTime
Declaration Syntax
C# Visual Basic Visual C++
public bool Hours2AnyTime { get; set; }
Public Property Hours2AnyTime As Boolean
    Get
    Set
public:
property bool Hours2AnyTime {
    bool get ();
    void set (bool value);
}


Hours2AnyTimeSpecified Property

Hours2AnyTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours2AnyTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool Hours2AnyTimeSpecified { get; set; }
Public Property Hours2AnyTimeSpecified As Boolean
    Get
    Set
public:
property bool Hours2AnyTimeSpecified {
    bool get ();
    void set (bool value);
}


Hours2Days Property

Hours2Days Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours2Days
Declaration Syntax
C# Visual Basic Visual C++
public DaysCodeType Hours2Days { get; set; }
Public Property Hours2Days As DaysCodeType
    Get
    Set
public:
property DaysCodeType Hours2Days {
    DaysCodeType get ();
    void set (DaysCodeType value);
}


Hours2DaysSpecified Property

Hours2DaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours2DaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool Hours2DaysSpecified { get; set; }
Public Property Hours2DaysSpecified As Boolean
    Get
    Set
public:
property bool Hours2DaysSpecified {
    bool get ();
    void set (bool value);
}


Hours2From Property

Hours2From Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours2From
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Hours2From { get; set; }
Public Property Hours2From As DateTime
    Get
    Set
public:
property DateTime Hours2From {
    DateTime get ();
    void set (DateTime value);
}


Hours2FromSpecified Property

Hours2FromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours2FromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool Hours2FromSpecified { get; set; }
Public Property Hours2FromSpecified As Boolean
    Get
    Set
public:
property bool Hours2FromSpecified {
    bool get ();
    void set (bool value);
}


Hours2To Property

Hours2To Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours2To
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Hours2To { get; set; }
Public Property Hours2To As DateTime
    Get
    Set
public:
property DateTime Hours2To {
    DateTime get ();
    void set (DateTime value);
}


Hours2ToSpecified Property

Hours2ToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► Hours2ToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool Hours2ToSpecified { get; set; }
Public Property Hours2ToSpecified As Boolean
    Get
    Set
public:
property bool Hours2ToSpecified {
    bool get ();
    void set (bool value);
}


TimeZoneID Property

TimeZoneID Property
Namespaces ► eBay.Service.Core.Soap ► ContactHoursDetailsType ► TimeZoneID
Declaration Syntax
C# Visual Basic Visual C++
public string TimeZoneID { get; set; }
Public Property TimeZoneID As String
    Get
    Set
public:
property String^ TimeZoneID {
    String^ get ();
    void set (String^ value);
}


ContextSearchAssetType Class

ContextSearchAssetType Class
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ContextSearchAssetType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ContextSearchAssetType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ContextSearchAssetType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextSearchAssetType()()()() |
 | Category |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Keyword |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Ranking |
 | RankingSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ContextSearchAssetType


Category Property

Category Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetType ► Category
Declaration Syntax
C# Visual Basic Visual C++
public CategoryType Category { get; set; }
Public Property Category As CategoryType
    Get
    Set
public:
property CategoryType^ Category {
    CategoryType^ get ();
    void set (CategoryType^ value);
}


ContextSearchAssetType Constructor

ContextSearchAssetType Constructor
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetType ► ContextSearchAssetType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ContextSearchAssetType()
Public Sub New
public:
ContextSearchAssetType()


Keyword Property

Keyword Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetType ► Keyword
Declaration Syntax
C# Visual Basic Visual C++
public string Keyword { get; set; }
Public Property Keyword As String
    Get
    Set
public:
property String^ Keyword {
    String^ get ();
    void set (String^ value);
}


Ranking Property

Ranking Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetType ► Ranking
Declaration Syntax
C# Visual Basic Visual C++
public int Ranking { get; set; }
Public Property Ranking As Integer
    Get
    Set
public:
property int Ranking {
    int get ();
    void set (int value);
}


RankingSpecified Property

RankingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetType ► RankingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RankingSpecified { get; set; }
Public Property RankingSpecified As Boolean
    Get
    Set
public:
property bool RankingSpecified {
    bool get ();
    void set (bool value);
}


ContextSearchAssetTypeCollection Class

ContextSearchAssetTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ContextSearchAssetTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ContextSearchAssetTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ContextSearchAssetTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextSearchAssetTypeCollection()()()() |
 | ContextSearchAssetTypeCollection(array<ContextSearchAssetType>[]()[][]) |
 | ContextSearchAssetTypeCollection(ContextSearchAssetTypeCollection) |
 | Add(ContextSearchAssetType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ContextSearchAssetType>[]()[][]) |
 | AddRange(ContextSearchAssetTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ContextSearchAssetType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ContextSearchAssetType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ContextSearchAssetType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ContextSearchAssetType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ContextSearchAssetType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ContextSearchAssetTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► Add(ContextSearchAssetType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ContextSearchAssetType item
)
Public Function Add ( _
    item As ContextSearchAssetType _
) As Integer
public:
int Add(
    ContextSearchAssetType^ item
)
Parameters
item (ContextSearchAssetType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ContextSearchAssetType>[]()[][]) |
 | AddRange(ContextSearchAssetTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► AddRange(array<ContextSearchAssetType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ContextSearchAssetType[] items
)
Public Sub AddRange ( _
    items As ContextSearchAssetType() _
)
public:
void AddRange(
    array<ContextSearchAssetType^>^ items
)
Parameters
items (array< ContextSearchAssetType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► AddRange(ContextSearchAssetTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ContextSearchAssetTypeCollection items
)
Public Sub AddRange ( _
    items As ContextSearchAssetTypeCollection _
)
public:
void AddRange(
    ContextSearchAssetTypeCollection^ items
)
Parameters
items (ContextSearchAssetTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► Contains(ContextSearchAssetType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ContextSearchAssetType item
)
Public Function Contains ( _
    item As ContextSearchAssetType _
) As Boolean
public:
bool Contains(
    ContextSearchAssetType^ item
)
Parameters
item (ContextSearchAssetType)
Return Value


ContextSearchAssetTypeCollection Constructor

ContextSearchAssetTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► ContextSearchAssetTypeCollection()()()()
Members
Icon | Member | Description
 | ContextSearchAssetTypeCollection()()()() |
 | ContextSearchAssetTypeCollection(array<ContextSearchAssetType>[]()[][]) |
 | ContextSearchAssetTypeCollection(ContextSearchAssetTypeCollection) |


ContextSearchAssetTypeCollection Constructor

ContextSearchAssetTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► ContextSearchAssetTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ContextSearchAssetTypeCollection()
Public Sub New
public:
ContextSearchAssetTypeCollection()


ContextSearchAssetTypeCollection Constructor (items)

ContextSearchAssetTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► ContextSearchAssetTypeCollection(array<ContextSearchAssetType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ContextSearchAssetTypeCollection(
    ContextSearchAssetType[] items
)
Public Sub New ( _
    items As ContextSearchAssetType() _
)
public:
ContextSearchAssetTypeCollection(
    array<ContextSearchAssetType^>^ items
)
Parameters
items (array< ContextSearchAssetType >[]()[][])


ContextSearchAssetTypeCollection Constructor (items)

ContextSearchAssetTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► ContextSearchAssetTypeCollection(ContextSearchAssetTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ContextSearchAssetTypeCollection(
    ContextSearchAssetTypeCollection items
)
Public Sub New ( _
    items As ContextSearchAssetTypeCollection _
)
public:
ContextSearchAssetTypeCollection(
    ContextSearchAssetTypeCollection^ items
)
Parameters
items (ContextSearchAssetTypeCollection)


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► CopyTo(array<ContextSearchAssetType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ContextSearchAssetType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ContextSearchAssetType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ContextSearchAssetType^>^ items,
    int index
)
Parameters
items (array< ContextSearchAssetType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► IndexOf(ContextSearchAssetType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ContextSearchAssetType item
)
Public Function IndexOf ( _
    item As ContextSearchAssetType _
) As Integer
public:
int IndexOf(
    ContextSearchAssetType^ item
)
Parameters
item (ContextSearchAssetType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► Insert(Int32, ContextSearchAssetType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ContextSearchAssetType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ContextSearchAssetType _
)
public:
void Insert(
    int index,
    ContextSearchAssetType^ item
)
Parameters
index (Int32)
item (ContextSearchAssetType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ContextSearchAssetType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ContextSearchAssetType
    Get
    Set
public:
property ContextSearchAssetType^ default[int index] {
    ContextSearchAssetType^ get (int index);
    void set (int index, ContextSearchAssetType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ContextSearchAssetType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ContextSearchAssetType
public:
ContextSearchAssetType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► Remove(ContextSearchAssetType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ContextSearchAssetType item
)
Public Sub Remove ( _
    item As ContextSearchAssetType _
)
public:
void Remove(
    ContextSearchAssetType^ item
)
Parameters
item (ContextSearchAssetType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ContextSearchAssetType[] ToArray()
Public Function ToArray As ContextSearchAssetType()
public:
array<ContextSearchAssetType^>^ ToArray()
Return Value


CountryCodeType Enumeration

CountryCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CountryCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CountryCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CountryCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CountryCodeType
Members
Member | Description
AF |
AL |
DZ |
AS |
AD |
AO |
AI |
AQ |
AG |
AR |
AM |
AW |
AU |
AT |
AZ |
BS |
BH |
BD |
BB |
BY |
BE |
BZ |
BJ |
BM |
BT |
BO |
BA |
BW |
BV |
BR |
IO |
BN |
BG |
BF |
BI |
KH |
CM |
CA |
CV |
KY |
CF |
TD |
CL |
CN |
CX |
CC |
CO |
KM |
CG |
CD |
CK |
CR |
CI |
HR |
CU |
CY |
CZ |
DK |
DJ |
DM |
DO |
TP |
EC |
EG |
SV |
GQ |
ER |
EE |
ET |
FK |
FO |
FJ |
FI |
FR |
GF |
PF |
TF |
GA |
GM |
GE |
DE |
GH |
GI |
GR |
GL |
GD |
GP |
GU |
GT |
GN |
GW |
GY |
HT |
HM |
VA |
HN |
HK |
HU |
IS |
IN |
ID |
IR |
IQ |
IE |
IL |
IT |
JM |
JP |
JO |
KZ |
KE |
KI |
KP |
KR |
KW |
KG |
LA |
LV |
LB |
LS |
LR |
LY |
LI |
LT |
LU |
MO |
MK |
MG |
MW |
MY |
MV |
ML |
MT |
MH |
MQ |
MR |
MU |
YT |
MX |
FM |
MD |
MC |
MN |
MS |
MA |
MZ |
MM |
NA |
NR |
NP |
NL |
AN |
NC |
NZ |
NI |
NE |
NG |
NU |
NF |
MP |
NO |
OM |
PK |
PW |
PS |
PA |
PG |
PY |
PE |
PH |
PN |
PL |
PT |
PR |
QA |
RE |
RO |
RU |
RW |
SH |
KN |
LC |
PM |
VC |
WS |
SM |
ST |
SA |
SN |
SC |
SL |
SG |
SK |
SI |
SB |
SO |
ZA |
GS |
ES |
LK |
SD |
SR |
SJ |
SZ |
SE |
CH |
SY |
TW |
TJ |
TZ |
TH |
TG |
TK |
TO |
TT |
TN |
TR |
TM |
TC |
TV |
UG |
UA |
AE |
GB |
US |
UM |
UY |
UZ |
VU |
VE |
VN |
VG |
VI |
WF |
EH |
YE |
YU |
ZM |
ZW |
AA |
QM |
QN |
QO |
QP |
JE |
GG |
ZZ |
RS |
ME |
CustomCode |
Remarks


CountryCodeTypeCollection Class

CountryCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CountryCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CountryCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CountryCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CountryCodeTypeCollection()()()() |
 | CountryCodeTypeCollection(array<CountryCodeType>[]()[][]) |
 | CountryCodeTypeCollection(CountryCodeTypeCollection) |
 | Add(CountryCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CountryCodeType>[]()[][]) |
 | AddRange(CountryCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CountryCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CountryCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CountryCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CountryCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CountryCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CountryCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► Add(CountryCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CountryCodeType item
)
Public Function Add ( _
    item As CountryCodeType _
) As Integer
public:
int Add(
    CountryCodeType item
)
Parameters
item (CountryCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CountryCodeType>[]()[][]) |
 | AddRange(CountryCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► AddRange(array<CountryCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CountryCodeType[] items
)
Public Sub AddRange ( _
    items As CountryCodeType() _
)
public:
void AddRange(
    array<CountryCodeType>^ items
)
Parameters
items (array< CountryCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► AddRange(CountryCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CountryCodeTypeCollection items
)
Public Sub AddRange ( _
    items As CountryCodeTypeCollection _
)
public:
void AddRange(
    CountryCodeTypeCollection^ items
)
Parameters
items (CountryCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► Contains(CountryCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CountryCodeType item
)
Public Function Contains ( _
    item As CountryCodeType _
) As Boolean
public:
bool Contains(
    CountryCodeType item
)
Parameters
item (CountryCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► CopyTo(array<CountryCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CountryCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CountryCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CountryCodeType>^ items,
    int index
)
Parameters
items (array< CountryCodeType >[]()[][])
index (Int32)


CountryCodeTypeCollection Constructor

CountryCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► CountryCodeTypeCollection()()()()
Members
Icon | Member | Description
 | CountryCodeTypeCollection()()()() |
 | CountryCodeTypeCollection(array<CountryCodeType>[]()[][]) |
 | CountryCodeTypeCollection(CountryCodeTypeCollection) |


CountryCodeTypeCollection Constructor

CountryCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► CountryCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeTypeCollection()
Public Sub New
public:
CountryCodeTypeCollection()


CountryCodeTypeCollection Constructor (items)

CountryCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► CountryCodeTypeCollection(array<CountryCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeTypeCollection(
    CountryCodeType[] items
)
Public Sub New ( _
    items As CountryCodeType() _
)
public:
CountryCodeTypeCollection(
    array<CountryCodeType>^ items
)
Parameters
items (array< CountryCodeType >[]()[][])


CountryCodeTypeCollection Constructor (items)

CountryCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► CountryCodeTypeCollection(CountryCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeTypeCollection(
    CountryCodeTypeCollection items
)
Public Sub New ( _
    items As CountryCodeTypeCollection _
)
public:
CountryCodeTypeCollection(
    CountryCodeTypeCollection^ items
)
Parameters
items (CountryCodeTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► IndexOf(CountryCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CountryCodeType item
)
Public Function IndexOf ( _
    item As CountryCodeType _
) As Integer
public:
int IndexOf(
    CountryCodeType item
)
Parameters
item (CountryCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► Insert(Int32, CountryCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CountryCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CountryCodeType _
)
public:
void Insert(
    int index,
    CountryCodeType item
)
Parameters
index (Int32)
item (CountryCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CountryCodeType
    Get
    Set
public:
property CountryCodeType default[int index] {
    CountryCodeType get (int index);
    void set (int index, CountryCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CountryCodeType
public:
CountryCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► Remove(CountryCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CountryCodeType item
)
Public Sub Remove ( _
    item As CountryCodeType _
)
public:
void Remove(
    CountryCodeType item
)
Parameters
item (CountryCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType[] ToArray()
Public Function ToArray As CountryCodeType()
public:
array<CountryCodeType>^ ToArray()
Return Value


CountryDetailsType Class

CountryDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CountryDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CountryDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CountryDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CountryDetailsType()()()() |
 | Any |
 | Country |
 | CountrySpecified |
 | Description |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
CountryDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Country Property

Country Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsType ► Country
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType Country { get; set; }
Public Property Country As CountryCodeType
    Get
    Set
public:
property CountryCodeType Country {
    CountryCodeType get ();
    void set (CountryCodeType value);
}


CountryDetailsType Constructor

CountryDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsType ► CountryDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsType()
Public Sub New
public:
CountryDetailsType()


CountrySpecified Property

CountrySpecified Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsType ► CountrySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CountrySpecified { get; set; }
Public Property CountrySpecified As Boolean
    Get
    Set
public:
property bool CountrySpecified {
    bool get ();
    void set (bool value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


CountryDetailsTypeCollection Class

CountryDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CountryDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CountryDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CountryDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CountryDetailsTypeCollection()()()() |
 | CountryDetailsTypeCollection(array<CountryDetailsType>[]()[][]) |
 | CountryDetailsTypeCollection(CountryDetailsTypeCollection) |
 | Add(CountryDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CountryDetailsType>[]()[][]) |
 | AddRange(CountryDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CountryDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CountryDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CountryDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CountryDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CountryDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CountryDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► Add(CountryDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CountryDetailsType item
)
Public Function Add ( _
    item As CountryDetailsType _
) As Integer
public:
int Add(
    CountryDetailsType^ item
)
Parameters
item (CountryDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CountryDetailsType>[]()[][]) |
 | AddRange(CountryDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► AddRange(array<CountryDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CountryDetailsType[] items
)
Public Sub AddRange ( _
    items As CountryDetailsType() _
)
public:
void AddRange(
    array<CountryDetailsType^>^ items
)
Parameters
items (array< CountryDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► AddRange(CountryDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CountryDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As CountryDetailsTypeCollection _
)
public:
void AddRange(
    CountryDetailsTypeCollection^ items
)
Parameters
items (CountryDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► Contains(CountryDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CountryDetailsType item
)
Public Function Contains ( _
    item As CountryDetailsType _
) As Boolean
public:
bool Contains(
    CountryDetailsType^ item
)
Parameters
item (CountryDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► CopyTo(array<CountryDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CountryDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CountryDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CountryDetailsType^>^ items,
    int index
)
Parameters
items (array< CountryDetailsType >[]()[][])
index (Int32)


CountryDetailsTypeCollection Constructor

CountryDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► CountryDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | CountryDetailsTypeCollection()()()() |
 | CountryDetailsTypeCollection(array<CountryDetailsType>[]()[][]) |
 | CountryDetailsTypeCollection(CountryDetailsTypeCollection) |


CountryDetailsTypeCollection Constructor

CountryDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► CountryDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsTypeCollection()
Public Sub New
public:
CountryDetailsTypeCollection()


CountryDetailsTypeCollection Constructor (items)

CountryDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► CountryDetailsTypeCollection(array<CountryDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsTypeCollection(
    CountryDetailsType[] items
)
Public Sub New ( _
    items As CountryDetailsType() _
)
public:
CountryDetailsTypeCollection(
    array<CountryDetailsType^>^ items
)
Parameters
items (array< CountryDetailsType >[]()[][])


CountryDetailsTypeCollection Constructor (items)

CountryDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► CountryDetailsTypeCollection(CountryDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsTypeCollection(
    CountryDetailsTypeCollection items
)
Public Sub New ( _
    items As CountryDetailsTypeCollection _
)
public:
CountryDetailsTypeCollection(
    CountryDetailsTypeCollection^ items
)
Parameters
items (CountryDetailsTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► IndexOf(CountryDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CountryDetailsType item
)
Public Function IndexOf ( _
    item As CountryDetailsType _
) As Integer
public:
int IndexOf(
    CountryDetailsType^ item
)
Parameters
item (CountryDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► Insert(Int32, CountryDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CountryDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CountryDetailsType _
)
public:
void Insert(
    int index,
    CountryDetailsType^ item
)
Parameters
index (Int32)
item (CountryDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CountryDetailsType
    Get
    Set
public:
property CountryDetailsType^ default[int index] {
    CountryDetailsType^ get (int index);
    void set (int index, CountryDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CountryDetailsType
public:
CountryDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► Remove(CountryDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CountryDetailsType item
)
Public Sub Remove ( _
    item As CountryDetailsType _
)
public:
void Remove(
    CountryDetailsType^ item
)
Parameters
item (CountryDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsType[] ToArray()
Public Function ToArray As CountryDetailsType()
public:
array<CountryDetailsType^>^ ToArray()
Return Value


CrossBorderTradeAustraliaEnabledDefinitionType Class

CrossBorderTradeAustraliaEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► CrossBorderTradeAustraliaEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CrossBorderTradeAustraliaEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CrossBorderTradeAustraliaEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CrossBorderTradeAustraliaEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrossBorderTradeAustraliaEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CrossBorderTradeAustraliaEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CrossBorderTradeAustraliaEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CrossBorderTradeAustraliaEnabledDefinitionType Constructor

CrossBorderTradeAustraliaEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► CrossBorderTradeAustraliaEnabledDefinitionType ► CrossBorderTradeAustraliaEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CrossBorderTradeAustraliaEnabledDefinitionType()
Public Sub New
public:
CrossBorderTradeAustraliaEnabledDefinitionType()


CrossBorderTradeGBEnabledDefinitionType Class

CrossBorderTradeGBEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► CrossBorderTradeGBEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CrossBorderTradeGBEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CrossBorderTradeGBEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CrossBorderTradeGBEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrossBorderTradeGBEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CrossBorderTradeGBEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CrossBorderTradeGBEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CrossBorderTradeGBEnabledDefinitionType Constructor

CrossBorderTradeGBEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► CrossBorderTradeGBEnabledDefinitionType ► CrossBorderTradeGBEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CrossBorderTradeGBEnabledDefinitionType()
Public Sub New
public:
CrossBorderTradeGBEnabledDefinitionType()


CrossBorderTradeNorthAmericaEnabledDefinitionType Class

CrossBorderTradeNorthAmericaEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► CrossBorderTradeNorthAmericaEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CrossBorderTradeNorthAmericaEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CrossBorderTradeNorthAmericaEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CrossBorderTradeNorthAmericaEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrossBorderTradeNorthAmericaEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CrossBorderTradeNorthAmericaEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CrossBorderTradeNorthAmericaEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CrossBorderTradeNorthAmericaEnabledDefinitionType Constructor

CrossBorderTradeNorthAmericaEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► CrossBorderTradeNorthAmericaEnabledDefinitionType ► CrossBorderTradeNorthAmericaEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CrossBorderTradeNorthAmericaEnabledDefinitionType()
Public Sub New
public:
CrossBorderTradeNorthAmericaEnabledDefinitionType()


CrossPromotionPreferencesType Class

CrossPromotionPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CrossPromotionPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CrossPromotionPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CrossPromotionPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrossPromotionPreferencesType()()()() |
 | Any |
 | CrossPromotionEnabled |
 | CrossPromotionEnabledSpecified |
 | CrossSellGallerySortFilter |
 | CrossSellGallerySortFilterSpecified |
 | CrossSellItemFormatSortFilter |
 | CrossSellItemFormatSortFilterSpecified |
 | CrossSellItemSortFilter |
 | CrossSellItemSortFilterSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UpSellGallerySortFilter |
 | UpSellGallerySortFilterSpecified |
 | UpSellItemFormatSortFilter |
 | UpSellItemFormatSortFilterSpecified |
 | UpSellItemSortFilter |
 | UpSellItemSortFilterSpecified |
Remarks
Inheritance Hierarchy
Object
CrossPromotionPreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CrossPromotionEnabled Property

CrossPromotionEnabled Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► CrossPromotionEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossPromotionEnabled { get; set; }
Public Property CrossPromotionEnabled As Boolean
    Get
    Set
public:
property bool CrossPromotionEnabled {
    bool get ();
    void set (bool value);
}


CrossPromotionEnabledSpecified Property

CrossPromotionEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► CrossPromotionEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossPromotionEnabledSpecified { get; set; }
Public Property CrossPromotionEnabledSpecified As Boolean
    Get
    Set
public:
property bool CrossPromotionEnabledSpecified {
    bool get ();
    void set (bool value);
}


CrossPromotionPreferencesType Constructor

CrossPromotionPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► CrossPromotionPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CrossPromotionPreferencesType()
Public Sub New
public:
CrossPromotionPreferencesType()


CrossSellGallerySortFilter Property

CrossSellGallerySortFilter Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► CrossSellGallerySortFilter
Declaration Syntax
C# Visual Basic Visual C++
public GallerySortFilterCodeType CrossSellGallerySortFilter { get; set; }
Public Property CrossSellGallerySortFilter As GallerySortFilterCodeType
    Get
    Set
public:
property GallerySortFilterCodeType CrossSellGallerySortFilter {
    GallerySortFilterCodeType get ();
    void set (GallerySortFilterCodeType value);
}


CrossSellGallerySortFilterSpecified Property

CrossSellGallerySortFilterSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► CrossSellGallerySortFilterSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossSellGallerySortFilterSpecified { get; set; }
Public Property CrossSellGallerySortFilterSpecified As Boolean
    Get
    Set
public:
property bool CrossSellGallerySortFilterSpecified {
    bool get ();
    void set (bool value);
}


CrossSellItemFormatSortFilter Property

CrossSellItemFormatSortFilter Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► CrossSellItemFormatSortFilter
Declaration Syntax
C# Visual Basic Visual C++
public ItemFormatSortFilterCodeType CrossSellItemFormatSortFilter { get; set; }
Public Property CrossSellItemFormatSortFilter As ItemFormatSortFilterCodeType
    Get
    Set
public:
property ItemFormatSortFilterCodeType CrossSellItemFormatSortFilter {
    ItemFormatSortFilterCodeType get ();
    void set (ItemFormatSortFilterCodeType value);
}


CrossSellItemFormatSortFilterSpecified Property

CrossSellItemFormatSortFilterSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► CrossSellItemFormatSortFilterSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossSellItemFormatSortFilterSpecified { get; set; }
Public Property CrossSellItemFormatSortFilterSpecified As Boolean
    Get
    Set
public:
property bool CrossSellItemFormatSortFilterSpecified {
    bool get ();
    void set (bool value);
}


CrossSellItemSortFilter Property

CrossSellItemSortFilter Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► CrossSellItemSortFilter
Declaration Syntax
C# Visual Basic Visual C++
public ItemSortFilterCodeType CrossSellItemSortFilter { get; set; }
Public Property CrossSellItemSortFilter As ItemSortFilterCodeType
    Get
    Set
public:
property ItemSortFilterCodeType CrossSellItemSortFilter {
    ItemSortFilterCodeType get ();
    void set (ItemSortFilterCodeType value);
}


CrossSellItemSortFilterSpecified Property

CrossSellItemSortFilterSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► CrossSellItemSortFilterSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossSellItemSortFilterSpecified { get; set; }
Public Property CrossSellItemSortFilterSpecified As Boolean
    Get
    Set
public:
property bool CrossSellItemSortFilterSpecified {
    bool get ();
    void set (bool value);
}


UpSellGallerySortFilter Property

UpSellGallerySortFilter Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► UpSellGallerySortFilter
Declaration Syntax
C# Visual Basic Visual C++
public GallerySortFilterCodeType UpSellGallerySortFilter { get; set; }
Public Property UpSellGallerySortFilter As GallerySortFilterCodeType
    Get
    Set
public:
property GallerySortFilterCodeType UpSellGallerySortFilter {
    GallerySortFilterCodeType get ();
    void set (GallerySortFilterCodeType value);
}


UpSellGallerySortFilterSpecified Property

UpSellGallerySortFilterSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► UpSellGallerySortFilterSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpSellGallerySortFilterSpecified { get; set; }
Public Property UpSellGallerySortFilterSpecified As Boolean
    Get
    Set
public:
property bool UpSellGallerySortFilterSpecified {
    bool get ();
    void set (bool value);
}


UpSellItemFormatSortFilter Property

UpSellItemFormatSortFilter Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► UpSellItemFormatSortFilter
Declaration Syntax
C# Visual Basic Visual C++
public ItemFormatSortFilterCodeType UpSellItemFormatSortFilter { get; set; }
Public Property UpSellItemFormatSortFilter As ItemFormatSortFilterCodeType
    Get
    Set
public:
property ItemFormatSortFilterCodeType UpSellItemFormatSortFilter {
    ItemFormatSortFilterCodeType get ();
    void set (ItemFormatSortFilterCodeType value);
}


UpSellItemFormatSortFilterSpecified Property

UpSellItemFormatSortFilterSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► UpSellItemFormatSortFilterSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpSellItemFormatSortFilterSpecified { get; set; }
Public Property UpSellItemFormatSortFilterSpecified As Boolean
    Get
    Set
public:
property bool UpSellItemFormatSortFilterSpecified {
    bool get ();
    void set (bool value);
}


UpSellItemSortFilter Property

UpSellItemSortFilter Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► UpSellItemSortFilter
Declaration Syntax
C# Visual Basic Visual C++
public ItemSortFilterCodeType UpSellItemSortFilter { get; set; }
Public Property UpSellItemSortFilter As ItemSortFilterCodeType
    Get
    Set
public:
property ItemSortFilterCodeType UpSellItemSortFilter {
    ItemSortFilterCodeType get ();
    void set (ItemSortFilterCodeType value);
}


UpSellItemSortFilterSpecified Property

UpSellItemSortFilterSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionPreferencesType ► UpSellItemSortFilterSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpSellItemSortFilterSpecified { get; set; }
Public Property UpSellItemSortFilterSpecified As Boolean
    Get
    Set
public:
property bool UpSellItemSortFilterSpecified {
    bool get ();
    void set (bool value);
}


CrossPromotionsType Class

CrossPromotionsType Class
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CrossPromotionsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CrossPromotionsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CrossPromotionsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrossPromotionsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PrimaryScheme |
 | PrimarySchemeSpecified |
 | PromotedItem |
 | PromotionMethod |
 | PromotionMethodSpecified |
 | SellerID |
 | ShippingDiscount |
 | StoreName |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CrossPromotionsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CrossPromotionsType Constructor

CrossPromotionsType Constructor
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType ► CrossPromotionsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CrossPromotionsType()
Public Sub New
public:
CrossPromotionsType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


PrimaryScheme Property

PrimaryScheme Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType ► PrimaryScheme
Declaration Syntax
C# Visual Basic Visual C++
public PromotionSchemeCodeType PrimaryScheme { get; set; }
Public Property PrimaryScheme As PromotionSchemeCodeType
    Get
    Set
public:
property PromotionSchemeCodeType PrimaryScheme {
    PromotionSchemeCodeType get ();
    void set (PromotionSchemeCodeType value);
}


PrimarySchemeSpecified Property

PrimarySchemeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType ► PrimarySchemeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PrimarySchemeSpecified { get; set; }
Public Property PrimarySchemeSpecified As Boolean
    Get
    Set
public:
property bool PrimarySchemeSpecified {
    bool get ();
    void set (bool value);
}


PromotedItem Property

PromotedItem Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType ► PromotedItem
Declaration Syntax
C# Visual Basic Visual C++
public PromotedItemTypeCollection PromotedItem { get; set; }
Public Property PromotedItem As PromotedItemTypeCollection
    Get
    Set
public:
property PromotedItemTypeCollection^ PromotedItem {
    PromotedItemTypeCollection^ get ();
    void set (PromotedItemTypeCollection^ value);
}


PromotionMethod Property

PromotionMethod Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType ► PromotionMethod
Declaration Syntax
C# Visual Basic Visual C++
public PromotionMethodCodeType PromotionMethod { get; set; }
Public Property PromotionMethod As PromotionMethodCodeType
    Get
    Set
public:
property PromotionMethodCodeType PromotionMethod {
    PromotionMethodCodeType get ();
    void set (PromotionMethodCodeType value);
}


PromotionMethodSpecified Property

PromotionMethodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType ► PromotionMethodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionMethodSpecified { get; set; }
Public Property PromotionMethodSpecified As Boolean
    Get
    Set
public:
property bool PromotionMethodSpecified {
    bool get ();
    void set (bool value);
}


SellerID Property

SellerID Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType ► SellerID
Declaration Syntax
C# Visual Basic Visual C++
public string SellerID { get; set; }
Public Property SellerID As String
    Get
    Set
public:
property String^ SellerID {
    String^ get ();
    void set (String^ value);
}


ShippingDiscount Property

ShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType ► ShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingDiscount { get; set; }
Public Property ShippingDiscount As Boolean
    Get
    Set
public:
property bool ShippingDiscount {
    bool get ();
    void set (bool value);
}


StoreName Property

StoreName Property
Namespaces ► eBay.Service.Core.Soap ► CrossPromotionsType ► StoreName
Declaration Syntax
C# Visual Basic Visual C++
public string StoreName { get; set; }
Public Property StoreName As String
    Get
    Set
public:
property String^ StoreName {
    String^ get ();
    void set (String^ value);
}


CurrencyCodeType Enumeration

CurrencyCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► CurrencyCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum CurrencyCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration CurrencyCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class CurrencyCodeType
Members
Member | Description
AFA |
ALL |
DZD |
ADP |
AOA |
ARS |
AMD |
AWG |
AZM |
BSD |
BHD |
BDT |
BBD |
BYR |
BZD |
BMD |
BTN |
INR |
BOV |
BOB |
BAM |
BWP |
BRL |
BND |
BGL |
BGN |
BIF |
KHR |
CAD |
CVE |
KYD |
XAF |
CLF |
CLP |
CNY |
COP |
KMF |
CDF |
CRC |
HRK |
CUP |
CYP |
CZK |
DKK |
DJF |
DOP |
TPE |
ECV |
ECS |
EGP |
SVC |
ERN |
EEK |
ETB |
FKP |
FJD |
GMD |
GEL |
GHC |
GIP |
GTQ |
GNF |
GWP |
GYD |
HTG |
HNL |
HKD |
HUF |
ISK |
IDR |
IRR |
IQD |
ILS |
JMD |
JPY |
JOD |
KZT |
KES |
AUD |
KPW |
KRW |
KWD |
KGS |
LAK |
LVL |
LBP |
LSL |
LRD |
LYD |
CHF |
LTL |
MOP |
MKD |
MGF |
MWK |
MYR |
MVR |
MTL |
EUR |
MRO |
MUR |
MXN |
MXV |
MDL |
MNT |
XCD |
MZM |
MMK |
ZAR |
NAD |
NPR |
ANG |
XPF |
NZD |
NIO |
NGN |
NOK |
OMR |
PKR |
PAB |
PGK |
PYG |
PEN |
PHP |
PLN |
USD |
QAR |
ROL |
RUB |
RUR |
RWF |
SHP |
WST |
STD |
SAR |
SCR |
SLL |
SGD |
SKK |
SIT |
SBD |
SOS |
LKR |
SDD |
SRG |
SZL |
SEK |
SYP |
TWD |
TJS |
TZS |
THB |
XOF |
TOP |
TTD |
TND |
TRL |
TMM |
UGX |
UAH |
AED |
GBP |
USS |
USN |
UYU |
UZS |
VUV |
VEB |
VND |
MAD |
YER |
YUM |
ZMK |
ZWD |
ATS |
CustomCode |
Remarks


CurrencyDetailsType Class

CurrencyDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CurrencyDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CurrencyDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CurrencyDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CurrencyDetailsType()()()() |
 | Any |
 | Currency |
 | CurrencySpecified |
 | Description |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
CurrencyDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Currency Property

Currency Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsType ► Currency
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType Currency { get; set; }
Public Property Currency As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType Currency {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


CurrencyDetailsType Constructor

CurrencyDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsType ► CurrencyDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyDetailsType()
Public Sub New
public:
CurrencyDetailsType()


CurrencySpecified Property

CurrencySpecified Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsType ► CurrencySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CurrencySpecified { get; set; }
Public Property CurrencySpecified As Boolean
    Get
    Set
public:
property bool CurrencySpecified {
    bool get ();
    void set (bool value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


CurrencyDetailsTypeCollection Class

CurrencyDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class CurrencyDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class CurrencyDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CurrencyDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CurrencyDetailsTypeCollection()()()() |
 | CurrencyDetailsTypeCollection(array<CurrencyDetailsType>[]()[][]) |
 | CurrencyDetailsTypeCollection(CurrencyDetailsTypeCollection) |
 | Add(CurrencyDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<CurrencyDetailsType>[]()[][]) |
 | AddRange(CurrencyDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(CurrencyDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<CurrencyDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(CurrencyDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, CurrencyDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(CurrencyDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CurrencyDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► Add(CurrencyDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    CurrencyDetailsType item
)
Public Function Add ( _
    item As CurrencyDetailsType _
) As Integer
public:
int Add(
    CurrencyDetailsType^ item
)
Parameters
item (CurrencyDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<CurrencyDetailsType>[]()[][]) |
 | AddRange(CurrencyDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► AddRange(array<CurrencyDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CurrencyDetailsType[] items
)
Public Sub AddRange ( _
    items As CurrencyDetailsType() _
)
public:
void AddRange(
    array<CurrencyDetailsType^>^ items
)
Parameters
items (array< CurrencyDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► AddRange(CurrencyDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    CurrencyDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As CurrencyDetailsTypeCollection _
)
public:
void AddRange(
    CurrencyDetailsTypeCollection^ items
)
Parameters
items (CurrencyDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► Contains(CurrencyDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    CurrencyDetailsType item
)
Public Function Contains ( _
    item As CurrencyDetailsType _
) As Boolean
public:
bool Contains(
    CurrencyDetailsType^ item
)
Parameters
item (CurrencyDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► CopyTo(array<CurrencyDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    CurrencyDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As CurrencyDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<CurrencyDetailsType^>^ items,
    int index
)
Parameters
items (array< CurrencyDetailsType >[]()[][])
index (Int32)


CurrencyDetailsTypeCollection Constructor

CurrencyDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► CurrencyDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | CurrencyDetailsTypeCollection()()()() |
 | CurrencyDetailsTypeCollection(array<CurrencyDetailsType>[]()[][]) |
 | CurrencyDetailsTypeCollection(CurrencyDetailsTypeCollection) |


CurrencyDetailsTypeCollection Constructor

CurrencyDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► CurrencyDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyDetailsTypeCollection()
Public Sub New
public:
CurrencyDetailsTypeCollection()


CurrencyDetailsTypeCollection Constructor (items)

CurrencyDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► CurrencyDetailsTypeCollection(array<CurrencyDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyDetailsTypeCollection(
    CurrencyDetailsType[] items
)
Public Sub New ( _
    items As CurrencyDetailsType() _
)
public:
CurrencyDetailsTypeCollection(
    array<CurrencyDetailsType^>^ items
)
Parameters
items (array< CurrencyDetailsType >[]()[][])


CurrencyDetailsTypeCollection Constructor (items)

CurrencyDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► CurrencyDetailsTypeCollection(CurrencyDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyDetailsTypeCollection(
    CurrencyDetailsTypeCollection items
)
Public Sub New ( _
    items As CurrencyDetailsTypeCollection _
)
public:
CurrencyDetailsTypeCollection(
    CurrencyDetailsTypeCollection^ items
)
Parameters
items (CurrencyDetailsTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► IndexOf(CurrencyDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    CurrencyDetailsType item
)
Public Function IndexOf ( _
    item As CurrencyDetailsType _
) As Integer
public:
int IndexOf(
    CurrencyDetailsType^ item
)
Parameters
item (CurrencyDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► Insert(Int32, CurrencyDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    CurrencyDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As CurrencyDetailsType _
)
public:
void Insert(
    int index,
    CurrencyDetailsType^ item
)
Parameters
index (Int32)
item (CurrencyDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As CurrencyDetailsType
    Get
    Set
public:
property CurrencyDetailsType^ default[int index] {
    CurrencyDetailsType^ get (int index);
    void set (int index, CurrencyDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As CurrencyDetailsType
public:
CurrencyDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► Remove(CurrencyDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    CurrencyDetailsType item
)
Public Sub Remove ( _
    item As CurrencyDetailsType _
)
public:
void Remove(
    CurrencyDetailsType^ item
)
Parameters
item (CurrencyDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyDetailsType[] ToArray()
Public Function ToArray As CurrencyDetailsType()
public:
array<CurrencyDetailsType^>^ ToArray()
Return Value


CustomSecurityHeaderType Class

CustomSecurityHeaderType Class
Namespaces ► eBay.Service.Core.Soap ► CustomSecurityHeaderType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class CustomSecurityHeaderType : SoapHeader
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class CustomSecurityHeaderType _
    Inherits SoapHeader
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class CustomSecurityHeaderType : public SoapHeader
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomSecurityHeaderType()()()() |
 | Actor | (Inherited from SoapHeader.)
 | Any |
 | Credentials |
 | DidUnderstand | (Inherited from SoapHeader.)
 | eBayAuthToken |
 | EncodedMustUnderstand | (Inherited from SoapHeader.)
 | EncodedMustUnderstand12 | (Inherited from SoapHeader.)
 | EncodedRelay | (Inherited from SoapHeader.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MustUnderstand | (Inherited from SoapHeader.)
 | NotificationSignature |
 | Relay | (Inherited from SoapHeader.)
 | Role | (Inherited from SoapHeader.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
 | SoapHeader
 |  | CustomSecurityHeaderType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► CustomSecurityHeaderType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Credentials Property

Credentials Property
Namespaces ► eBay.Service.Core.Soap ► CustomSecurityHeaderType ► Credentials
Declaration Syntax
C# Visual Basic Visual C++
public UserIdPasswordType Credentials { get; set; }
Public Property Credentials As UserIdPasswordType
    Get
    Set
public:
property UserIdPasswordType^ Credentials {
    UserIdPasswordType^ get ();
    void set (UserIdPasswordType^ value);
}


CustomSecurityHeaderType Constructor

CustomSecurityHeaderType Constructor
Namespaces ► eBay.Service.Core.Soap ► CustomSecurityHeaderType ► CustomSecurityHeaderType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CustomSecurityHeaderType()
Public Sub New
public:
CustomSecurityHeaderType()


eBayAuthToken Property

eBayAuthToken Property
Namespaces ► eBay.Service.Core.Soap ► CustomSecurityHeaderType ► eBayAuthToken
Declaration Syntax
C# Visual Basic Visual C++
public string eBayAuthToken { get; set; }
Public Property eBayAuthToken As String
    Get
    Set
public:
property String^ eBayAuthToken {
    String^ get ();
    void set (String^ value);
}


HardExpirationWarning Property

HardExpirationWarning Property
Namespaces ► eBay.Service.Core.Soap ► CustomSecurityHeaderType ► HardExpirationWarning
Declaration Syntax
C# Visual Basic Visual C++
public string HardExpirationWarning { get; set; }
Public Property HardExpirationWarning As String
    Get
    Set
public:
property String^ HardExpirationWarning {
    String^ get ();
    void set (String^ value);
}


NotificationSignature Property

NotificationSignature Property
Namespaces ► eBay.Service.Core.Soap ► CustomSecurityHeaderType ► NotificationSignature
Declaration Syntax
C# Visual Basic Visual C++
public string NotificationSignature { get; set; }
Public Property NotificationSignature As String
    Get
    Set
public:
property String^ NotificationSignature {
    String^ get ();
    void set (String^ value);
}


DayOfWeekCodeType Enumeration

DayOfWeekCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DayOfWeekCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DayOfWeekCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DayOfWeekCodeType
Members
Member | Description
Sunday |
Monday |
Tuesday |
Wednesday |
Thursday |
Friday |
Saturday |
CustomCode |
Remarks


DayOfWeekCodeTypeCollection Class

DayOfWeekCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DayOfWeekCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DayOfWeekCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DayOfWeekCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DayOfWeekCodeTypeCollection()()()() |
 | DayOfWeekCodeTypeCollection(array<DayOfWeekCodeType>[]()[][]) |
 | DayOfWeekCodeTypeCollection(DayOfWeekCodeTypeCollection) |
 | Add(DayOfWeekCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DayOfWeekCodeType>[]()[][]) |
 | AddRange(DayOfWeekCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DayOfWeekCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DayOfWeekCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DayOfWeekCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DayOfWeekCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DayOfWeekCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DayOfWeekCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► Add(DayOfWeekCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DayOfWeekCodeType item
)
Public Function Add ( _
    item As DayOfWeekCodeType _
) As Integer
public:
int Add(
    DayOfWeekCodeType item
)
Parameters
item (DayOfWeekCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DayOfWeekCodeType>[]()[][]) |
 | AddRange(DayOfWeekCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► AddRange(array<DayOfWeekCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DayOfWeekCodeType[] items
)
Public Sub AddRange ( _
    items As DayOfWeekCodeType() _
)
public:
void AddRange(
    array<DayOfWeekCodeType>^ items
)
Parameters
items (array< DayOfWeekCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► AddRange(DayOfWeekCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DayOfWeekCodeTypeCollection items
)
Public Sub AddRange ( _
    items As DayOfWeekCodeTypeCollection _
)
public:
void AddRange(
    DayOfWeekCodeTypeCollection^ items
)
Parameters
items (DayOfWeekCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► Contains(DayOfWeekCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DayOfWeekCodeType item
)
Public Function Contains ( _
    item As DayOfWeekCodeType _
) As Boolean
public:
bool Contains(
    DayOfWeekCodeType item
)
Parameters
item (DayOfWeekCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► CopyTo(array<DayOfWeekCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DayOfWeekCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DayOfWeekCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DayOfWeekCodeType>^ items,
    int index
)
Parameters
items (array< DayOfWeekCodeType >[]()[][])
index (Int32)


DayOfWeekCodeTypeCollection Constructor

DayOfWeekCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► DayOfWeekCodeTypeCollection()()()()
Members
Icon | Member | Description
 | DayOfWeekCodeTypeCollection()()()() |
 | DayOfWeekCodeTypeCollection(array<DayOfWeekCodeType>[]()[][]) |
 | DayOfWeekCodeTypeCollection(DayOfWeekCodeTypeCollection) |


DayOfWeekCodeTypeCollection Constructor

DayOfWeekCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► DayOfWeekCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DayOfWeekCodeTypeCollection()
Public Sub New
public:
DayOfWeekCodeTypeCollection()


DayOfWeekCodeTypeCollection Constructor (items)

DayOfWeekCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► DayOfWeekCodeTypeCollection(array<DayOfWeekCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DayOfWeekCodeTypeCollection(
    DayOfWeekCodeType[] items
)
Public Sub New ( _
    items As DayOfWeekCodeType() _
)
public:
DayOfWeekCodeTypeCollection(
    array<DayOfWeekCodeType>^ items
)
Parameters
items (array< DayOfWeekCodeType >[]()[][])


DayOfWeekCodeTypeCollection Constructor (items)

DayOfWeekCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► DayOfWeekCodeTypeCollection(DayOfWeekCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DayOfWeekCodeTypeCollection(
    DayOfWeekCodeTypeCollection items
)
Public Sub New ( _
    items As DayOfWeekCodeTypeCollection _
)
public:
DayOfWeekCodeTypeCollection(
    DayOfWeekCodeTypeCollection^ items
)
Parameters
items (DayOfWeekCodeTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► IndexOf(DayOfWeekCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DayOfWeekCodeType item
)
Public Function IndexOf ( _
    item As DayOfWeekCodeType _
) As Integer
public:
int IndexOf(
    DayOfWeekCodeType item
)
Parameters
item (DayOfWeekCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► Insert(Int32, DayOfWeekCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DayOfWeekCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DayOfWeekCodeType _
)
public:
void Insert(
    int index,
    DayOfWeekCodeType item
)
Parameters
index (Int32)
item (DayOfWeekCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DayOfWeekCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DayOfWeekCodeType
    Get
    Set
public:
property DayOfWeekCodeType default[int index] {
    DayOfWeekCodeType get (int index);
    void set (int index, DayOfWeekCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DayOfWeekCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DayOfWeekCodeType
public:
DayOfWeekCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► Remove(DayOfWeekCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DayOfWeekCodeType item
)
Public Sub Remove ( _
    item As DayOfWeekCodeType _
)
public:
void Remove(
    DayOfWeekCodeType item
)
Parameters
item (DayOfWeekCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DayOfWeekCodeType[] ToArray()
Public Function ToArray As DayOfWeekCodeType()
public:
array<DayOfWeekCodeType>^ ToArray()
Return Value


DaysCodeType Enumeration

DaysCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DaysCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DaysCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DaysCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DaysCodeType
Members
Member | Description
None |
EveryDay |
Weekdays |
Weekends |
CustomCode |
Remarks


DeleteMyMessagesRequestType Class

DeleteMyMessagesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteMyMessagesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteMyMessagesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteMyMessagesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteMyMessagesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteMyMessagesRequestType()()()() |
 | AlertIDs |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | MessageIDs |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | DeleteMyMessagesRequestType


AlertIDs Property

AlertIDs Property
Namespaces ► eBay.Service.Core.Soap ► DeleteMyMessagesRequestType ► AlertIDs
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection AlertIDs { get; set; }
Public Property AlertIDs As StringCollection
    Get
    Set
public:
property StringCollection^ AlertIDs {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


DeleteMyMessagesRequestType Constructor

DeleteMyMessagesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteMyMessagesRequestType ► DeleteMyMessagesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteMyMessagesRequestType()
Public Sub New
public:
DeleteMyMessagesRequestType()


MessageIDs Property

MessageIDs Property
Namespaces ► eBay.Service.Core.Soap ► DeleteMyMessagesRequestType ► MessageIDs
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection MessageIDs { get; set; }
Public Property MessageIDs As StringCollection
    Get
    Set
public:
property StringCollection^ MessageIDs {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


DeleteMyMessagesResponseType Class

DeleteMyMessagesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteMyMessagesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteMyMessagesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteMyMessagesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteMyMessagesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteMyMessagesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | DeleteMyMessagesResponseType


DeleteMyMessagesResponseType Constructor

DeleteMyMessagesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteMyMessagesResponseType ► DeleteMyMessagesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteMyMessagesResponseType()
Public Sub New
public:
DeleteMyMessagesResponseType()


DeleteSellingManagerInventoryFolderRequestType Class

DeleteSellingManagerInventoryFolderRequestType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerInventoryFolderRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteSellingManagerInventoryFolderRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteSellingManagerInventoryFolderRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteSellingManagerInventoryFolderRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerInventoryFolderRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID |
 | FolderIDSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | DeleteSellingManagerInventoryFolderRequestType


DeleteSellingManagerInventoryFolderRequestType Constructor

DeleteSellingManagerInventoryFolderRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerInventoryFolderRequestType ► DeleteSellingManagerInventoryFolderRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerInventoryFolderRequestType()
Public Sub New
public:
DeleteSellingManagerInventoryFolderRequestType()


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerInventoryFolderRequestType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerInventoryFolderRequestType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


DeleteSellingManagerInventoryFolderResponseType Class

DeleteSellingManagerInventoryFolderResponseType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerInventoryFolderResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteSellingManagerInventoryFolderResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteSellingManagerInventoryFolderResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteSellingManagerInventoryFolderResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerInventoryFolderResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | DeleteSellingManagerInventoryFolderResponseType


DeleteSellingManagerInventoryFolderResponseType Constructor

DeleteSellingManagerInventoryFolderResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerInventoryFolderResponseType ► DeleteSellingManagerInventoryFolderResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerInventoryFolderResponseType()
Public Sub New
public:
DeleteSellingManagerInventoryFolderResponseType()


DeleteSellingManagerItemAutomationRuleRequestType Class

DeleteSellingManagerItemAutomationRuleRequestType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteSellingManagerItemAutomationRuleRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteSellingManagerItemAutomationRuleRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteSellingManagerItemAutomationRuleRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerItemAutomationRuleRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DeleteAutomatedRelistingRule |
 | DeleteAutomatedRelistingRuleSpecified |
 | DeleteAutomatedSecondChanceOfferRule |
 | DeleteAutomatedSecondChanceOfferRuleSpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | DeleteSellingManagerItemAutomationRuleRequestType


DeleteAutomatedRelistingRule Property

DeleteAutomatedRelistingRule Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleRequestType ► DeleteAutomatedRelistingRule
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedRelistingRule { get; set; }
Public Property DeleteAutomatedRelistingRule As Boolean
    Get
    Set
public:
property bool DeleteAutomatedRelistingRule {
    bool get ();
    void set (bool value);
}


DeleteAutomatedRelistingRuleSpecified Property

DeleteAutomatedRelistingRuleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleRequestType ► DeleteAutomatedRelistingRuleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedRelistingRuleSpecified { get; set; }
Public Property DeleteAutomatedRelistingRuleSpecified As Boolean
    Get
    Set
public:
property bool DeleteAutomatedRelistingRuleSpecified {
    bool get ();
    void set (bool value);
}


DeleteAutomatedSecondChanceOfferRule Property

DeleteAutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleRequestType ► DeleteAutomatedSecondChanceOfferRule
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedSecondChanceOfferRule { get; set; }
Public Property DeleteAutomatedSecondChanceOfferRule As Boolean
    Get
    Set
public:
property bool DeleteAutomatedSecondChanceOfferRule {
    bool get ();
    void set (bool value);
}


DeleteAutomatedSecondChanceOfferRuleSpecified Property

DeleteAutomatedSecondChanceOfferRuleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleRequestType ► DeleteAutomatedSecondChanceOfferRuleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedSecondChanceOfferRuleSpecified { get; set; }
Public Property DeleteAutomatedSecondChanceOfferRuleSpecified As Boolean
    Get
    Set
public:
property bool DeleteAutomatedSecondChanceOfferRuleSpecified {
    bool get ();
    void set (bool value);
}


DeleteSellingManagerItemAutomationRuleRequestType Constructor

DeleteSellingManagerItemAutomationRuleRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleRequestType ► DeleteSellingManagerItemAutomationRuleRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerItemAutomationRuleRequestType()
Public Sub New
public:
DeleteSellingManagerItemAutomationRuleRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


DeleteSellingManagerItemAutomationRuleResponseType Class

DeleteSellingManagerItemAutomationRuleResponseType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteSellingManagerItemAutomationRuleResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteSellingManagerItemAutomationRuleResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteSellingManagerItemAutomationRuleResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerItemAutomationRuleResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | AutomatedListingRule |
 | AutomatedRelistingRule |
 | AutomatedSecondChanceOfferRule |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | DeleteSellingManagerItemAutomationRuleResponseType


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleResponseType ► AutomatedListingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; set; }
Public Property AutomatedListingRule As SellingManagerAutoListType
    Get
    Set
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
    void set (SellingManagerAutoListType^ value);
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleResponseType ► AutomatedRelistingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; set; }
Public Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
    Set
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
    void set (SellingManagerAutoRelistType^ value);
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleResponseType ► AutomatedSecondChanceOfferRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; set; }
Public Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
    Set
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
    void set (SellingManagerAutoSecondChanceOfferType^ value);
}


DeleteSellingManagerItemAutomationRuleResponseType Constructor

DeleteSellingManagerItemAutomationRuleResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleResponseType ► DeleteSellingManagerItemAutomationRuleResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerItemAutomationRuleResponseType()
Public Sub New
public:
DeleteSellingManagerItemAutomationRuleResponseType()


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerItemAutomationRuleResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


DeleteSellingManagerProductRequestType Class

DeleteSellingManagerProductRequestType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerProductRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteSellingManagerProductRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteSellingManagerProductRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteSellingManagerProductRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerProductRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ProductID |
 | ProductIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | DeleteSellingManagerProductRequestType


DeleteSellingManagerProductRequestType Constructor

DeleteSellingManagerProductRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerProductRequestType ► DeleteSellingManagerProductRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerProductRequestType()
Public Sub New
public:
DeleteSellingManagerProductRequestType()


ProductID Property

ProductID Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerProductRequestType ► ProductID
Declaration Syntax
C# Visual Basic Visual C++
public long ProductID { get; set; }
Public Property ProductID As Long
    Get
    Set
public:
property long long ProductID {
    long long get ();
    void set (long long value);
}


ProductIDSpecified Property

ProductIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerProductRequestType ► ProductIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductIDSpecified { get; set; }
Public Property ProductIDSpecified As Boolean
    Get
    Set
public:
property bool ProductIDSpecified {
    bool get ();
    void set (bool value);
}


DeleteSellingManagerProductResponseType Class

DeleteSellingManagerProductResponseType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerProductResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteSellingManagerProductResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteSellingManagerProductResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteSellingManagerProductResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerProductResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DeletedSellingManagerProductDetails |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | DeleteSellingManagerProductResponseType


DeletedSellingManagerProductDetails Property

DeletedSellingManagerProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerProductResponseType ► DeletedSellingManagerProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType DeletedSellingManagerProductDetails { get; set; }
Public Property DeletedSellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ DeletedSellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


DeleteSellingManagerProductResponseType Constructor

DeleteSellingManagerProductResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerProductResponseType ► DeleteSellingManagerProductResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerProductResponseType()
Public Sub New
public:
DeleteSellingManagerProductResponseType()


DeleteSellingManagerTemplateAutomationRuleRequestType Class

DeleteSellingManagerTemplateAutomationRuleRequestType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteSellingManagerTemplateAutomationRuleRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteSellingManagerTemplateAutomationRuleRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteSellingManagerTemplateAutomationRuleRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerTemplateAutomationRuleRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DeleteAutomatedListingRule |
 | DeleteAutomatedListingRuleSpecified |
 | DeleteAutomatedRelistingRule |
 | DeleteAutomatedRelistingRuleSpecified |
 | DeleteAutomatedSecondChanceOfferRule |
 | DeleteAutomatedSecondChanceOfferRuleSpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SaleTemplateID |
 | SaleTemplateIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | DeleteSellingManagerTemplateAutomationRuleRequestType


DeleteAutomatedListingRule Property

DeleteAutomatedListingRule Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleRequestType ► DeleteAutomatedListingRule
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedListingRule { get; set; }
Public Property DeleteAutomatedListingRule As Boolean
    Get
    Set
public:
property bool DeleteAutomatedListingRule {
    bool get ();
    void set (bool value);
}


DeleteAutomatedListingRuleSpecified Property

DeleteAutomatedListingRuleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleRequestType ► DeleteAutomatedListingRuleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedListingRuleSpecified { get; set; }
Public Property DeleteAutomatedListingRuleSpecified As Boolean
    Get
    Set
public:
property bool DeleteAutomatedListingRuleSpecified {
    bool get ();
    void set (bool value);
}


DeleteAutomatedRelistingRule Property

DeleteAutomatedRelistingRule Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleRequestType ► DeleteAutomatedRelistingRule
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedRelistingRule { get; set; }
Public Property DeleteAutomatedRelistingRule As Boolean
    Get
    Set
public:
property bool DeleteAutomatedRelistingRule {
    bool get ();
    void set (bool value);
}


DeleteAutomatedRelistingRuleSpecified Property

DeleteAutomatedRelistingRuleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleRequestType ► DeleteAutomatedRelistingRuleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedRelistingRuleSpecified { get; set; }
Public Property DeleteAutomatedRelistingRuleSpecified As Boolean
    Get
    Set
public:
property bool DeleteAutomatedRelistingRuleSpecified {
    bool get ();
    void set (bool value);
}


DeleteAutomatedSecondChanceOfferRule Property

DeleteAutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleRequestType ► DeleteAutomatedSecondChanceOfferRule
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedSecondChanceOfferRule { get; set; }
Public Property DeleteAutomatedSecondChanceOfferRule As Boolean
    Get
    Set
public:
property bool DeleteAutomatedSecondChanceOfferRule {
    bool get ();
    void set (bool value);
}


DeleteAutomatedSecondChanceOfferRuleSpecified Property

DeleteAutomatedSecondChanceOfferRuleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleRequestType ► DeleteAutomatedSecondChanceOfferRuleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAutomatedSecondChanceOfferRuleSpecified { get; set; }
Public Property DeleteAutomatedSecondChanceOfferRuleSpecified As Boolean
    Get
    Set
public:
property bool DeleteAutomatedSecondChanceOfferRuleSpecified {
    bool get ();
    void set (bool value);
}


DeleteSellingManagerTemplateAutomationRuleRequestType Constructor

DeleteSellingManagerTemplateAutomationRuleRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleRequestType ► DeleteSellingManagerTemplateAutomationRuleRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateAutomationRuleRequestType()
Public Sub New
public:
DeleteSellingManagerTemplateAutomationRuleRequestType()


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleRequestType ► SaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


SaleTemplateIDSpecified Property

SaleTemplateIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleRequestType ► SaleTemplateIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SaleTemplateIDSpecified { get; set; }
Public Property SaleTemplateIDSpecified As Boolean
    Get
    Set
public:
property bool SaleTemplateIDSpecified {
    bool get ();
    void set (bool value);
}


DeleteSellingManagerTemplateAutomationRuleResponseType Class

DeleteSellingManagerTemplateAutomationRuleResponseType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteSellingManagerTemplateAutomationRuleResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteSellingManagerTemplateAutomationRuleResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteSellingManagerTemplateAutomationRuleResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerTemplateAutomationRuleResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | AutomatedListingRule |
 | AutomatedRelistingRule |
 | AutomatedSecondChanceOfferRule |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | DeleteSellingManagerTemplateAutomationRuleResponseType


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleResponseType ► AutomatedListingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; set; }
Public Property AutomatedListingRule As SellingManagerAutoListType
    Get
    Set
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
    void set (SellingManagerAutoListType^ value);
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleResponseType ► AutomatedRelistingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; set; }
Public Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
    Set
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
    void set (SellingManagerAutoRelistType^ value);
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleResponseType ► AutomatedSecondChanceOfferRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; set; }
Public Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
    Set
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
    void set (SellingManagerAutoSecondChanceOfferType^ value);
}


DeleteSellingManagerTemplateAutomationRuleResponseType Constructor

DeleteSellingManagerTemplateAutomationRuleResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleResponseType ► DeleteSellingManagerTemplateAutomationRuleResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateAutomationRuleResponseType()
Public Sub New
public:
DeleteSellingManagerTemplateAutomationRuleResponseType()


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateAutomationRuleResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


DeleteSellingManagerTemplateRequestType Class

DeleteSellingManagerTemplateRequestType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteSellingManagerTemplateRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteSellingManagerTemplateRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteSellingManagerTemplateRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerTemplateRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SaleTemplateID |
 | SaleTemplateIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | DeleteSellingManagerTemplateRequestType


DeleteSellingManagerTemplateRequestType Constructor

DeleteSellingManagerTemplateRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateRequestType ► DeleteSellingManagerTemplateRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateRequestType()
Public Sub New
public:
DeleteSellingManagerTemplateRequestType()


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateRequestType ► SaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


SaleTemplateIDSpecified Property

SaleTemplateIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateRequestType ► SaleTemplateIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SaleTemplateIDSpecified { get; set; }
Public Property SaleTemplateIDSpecified As Boolean
    Get
    Set
public:
property bool SaleTemplateIDSpecified {
    bool get ();
    void set (bool value);
}


DeleteSellingManagerTemplateResponseType Class

DeleteSellingManagerTemplateResponseType Class
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeleteSellingManagerTemplateResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeleteSellingManagerTemplateResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeleteSellingManagerTemplateResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeleteSellingManagerTemplateResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DeletedSaleTemplateID |
 | DeletedSaleTemplateName |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | DeleteSellingManagerTemplateResponseType


DeletedSaleTemplateID Property

DeletedSaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateResponseType ► DeletedSaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public string DeletedSaleTemplateID { get; set; }
Public Property DeletedSaleTemplateID As String
    Get
    Set
public:
property String^ DeletedSaleTemplateID {
    String^ get ();
    void set (String^ value);
}


DeletedSaleTemplateName Property

DeletedSaleTemplateName Property
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateResponseType ► DeletedSaleTemplateName
Declaration Syntax
C# Visual Basic Visual C++
public string DeletedSaleTemplateName { get; set; }
Public Property DeletedSaleTemplateName As String
    Get
    Set
public:
property String^ DeletedSaleTemplateName {
    String^ get ();
    void set (String^ value);
}


DeleteSellingManagerTemplateResponseType Constructor

DeleteSellingManagerTemplateResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeleteSellingManagerTemplateResponseType ► DeleteSellingManagerTemplateResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateResponseType()
Public Sub New
public:
DeleteSellingManagerTemplateResponseType()


DeliveryDetailsType Class

DeliveryDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► DeliveryDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeliveryDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeliveryDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeliveryDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeliveryDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Recipient |
 | Sender |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DeliveryDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DeliveryDetailsType Constructor

DeliveryDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeliveryDetailsType ► DeliveryDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryDetailsType()
Public Sub New
public:
DeliveryDetailsType()


Recipient Property

Recipient Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryDetailsType ► Recipient
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDeliveryUserType Recipient { get; set; }
Public Property Recipient As DigitalDeliveryUserType
    Get
    Set
public:
property DigitalDeliveryUserType^ Recipient {
    DigitalDeliveryUserType^ get ();
    void set (DigitalDeliveryUserType^ value);
}


Sender Property

Sender Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryDetailsType ► Sender
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDeliveryUserType Sender { get; set; }
Public Property Sender As DigitalDeliveryUserType
    Get
    Set
public:
property DigitalDeliveryUserType^ Sender {
    DigitalDeliveryUserType^ get ();
    void set (DigitalDeliveryUserType^ value);
}


DeliveryStatusType Class

DeliveryStatusType Class
Namespaces ► eBay.Service.Core.Soap ► DeliveryStatusType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeliveryStatusType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeliveryStatusType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeliveryStatusType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeliveryStatusType()()()() |
 | Any |
 | Email |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DeliveryStatusType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryStatusType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DeliveryStatusType Constructor

DeliveryStatusType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeliveryStatusType ► DeliveryStatusType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryStatusType()
Public Sub New
public:
DeliveryStatusType()


Email Property

Email Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryStatusType ► Email
Declaration Syntax
C# Visual Basic Visual C++
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}


DeliveryURLDetailType Class

DeliveryURLDetailType Class
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DeliveryURLDetailType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DeliveryURLDetailType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DeliveryURLDetailType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeliveryURLDetailType()()()() |
 | Any |
 | DeliveryURL |
 | DeliveryURLName |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DeliveryURLDetailType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DeliveryURL Property

DeliveryURL Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailType ► DeliveryURL
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryURL { get; set; }
Public Property DeliveryURL As String
    Get
    Set
public:
property String^ DeliveryURL {
    String^ get ();
    void set (String^ value);
}


DeliveryURLDetailType Constructor

DeliveryURLDetailType Constructor
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailType ► DeliveryURLDetailType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryURLDetailType()
Public Sub New
public:
DeliveryURLDetailType()


DeliveryURLName Property

DeliveryURLName Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailType ► DeliveryURLName
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryURLName { get; set; }
Public Property DeliveryURLName As String
    Get
    Set
public:
property String^ DeliveryURLName {
    String^ get ();
    void set (String^ value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public EnableCodeType Status { get; set; }
Public Property Status As EnableCodeType
    Get
    Set
public:
property EnableCodeType Status {
    EnableCodeType get ();
    void set (EnableCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


DeliveryURLDetailTypeCollection Class

DeliveryURLDetailTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DeliveryURLDetailTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DeliveryURLDetailTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DeliveryURLDetailTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeliveryURLDetailTypeCollection()()()() |
 | DeliveryURLDetailTypeCollection(array<DeliveryURLDetailType>[]()[][]) |
 | DeliveryURLDetailTypeCollection(DeliveryURLDetailTypeCollection) |
 | Add(DeliveryURLDetailType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DeliveryURLDetailType>[]()[][]) |
 | AddRange(DeliveryURLDetailTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DeliveryURLDetailType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DeliveryURLDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DeliveryURLDetailType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DeliveryURLDetailType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DeliveryURLDetailType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DeliveryURLDetailTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► Add(DeliveryURLDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DeliveryURLDetailType item
)
Public Function Add ( _
    item As DeliveryURLDetailType _
) As Integer
public:
int Add(
    DeliveryURLDetailType^ item
)
Parameters
item (DeliveryURLDetailType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DeliveryURLDetailType>[]()[][]) |
 | AddRange(DeliveryURLDetailTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► AddRange(array<DeliveryURLDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DeliveryURLDetailType[] items
)
Public Sub AddRange ( _
    items As DeliveryURLDetailType() _
)
public:
void AddRange(
    array<DeliveryURLDetailType^>^ items
)
Parameters
items (array< DeliveryURLDetailType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► AddRange(DeliveryURLDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DeliveryURLDetailTypeCollection items
)
Public Sub AddRange ( _
    items As DeliveryURLDetailTypeCollection _
)
public:
void AddRange(
    DeliveryURLDetailTypeCollection^ items
)
Parameters
items (DeliveryURLDetailTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► Contains(DeliveryURLDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DeliveryURLDetailType item
)
Public Function Contains ( _
    item As DeliveryURLDetailType _
) As Boolean
public:
bool Contains(
    DeliveryURLDetailType^ item
)
Parameters
item (DeliveryURLDetailType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► CopyTo(array<DeliveryURLDetailType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DeliveryURLDetailType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DeliveryURLDetailType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DeliveryURLDetailType^>^ items,
    int index
)
Parameters
items (array< DeliveryURLDetailType >[]()[][])
index (Int32)


DeliveryURLDetailTypeCollection Constructor

DeliveryURLDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► DeliveryURLDetailTypeCollection()()()()
Members
Icon | Member | Description
 | DeliveryURLDetailTypeCollection()()()() |
 | DeliveryURLDetailTypeCollection(array<DeliveryURLDetailType>[]()[][]) |
 | DeliveryURLDetailTypeCollection(DeliveryURLDetailTypeCollection) |


DeliveryURLDetailTypeCollection Constructor

DeliveryURLDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► DeliveryURLDetailTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryURLDetailTypeCollection()
Public Sub New
public:
DeliveryURLDetailTypeCollection()


DeliveryURLDetailTypeCollection Constructor (items)

DeliveryURLDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► DeliveryURLDetailTypeCollection(array<DeliveryURLDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryURLDetailTypeCollection(
    DeliveryURLDetailType[] items
)
Public Sub New ( _
    items As DeliveryURLDetailType() _
)
public:
DeliveryURLDetailTypeCollection(
    array<DeliveryURLDetailType^>^ items
)
Parameters
items (array< DeliveryURLDetailType >[]()[][])


DeliveryURLDetailTypeCollection Constructor (items)

DeliveryURLDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► DeliveryURLDetailTypeCollection(DeliveryURLDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryURLDetailTypeCollection(
    DeliveryURLDetailTypeCollection items
)
Public Sub New ( _
    items As DeliveryURLDetailTypeCollection _
)
public:
DeliveryURLDetailTypeCollection(
    DeliveryURLDetailTypeCollection^ items
)
Parameters
items (DeliveryURLDetailTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► IndexOf(DeliveryURLDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DeliveryURLDetailType item
)
Public Function IndexOf ( _
    item As DeliveryURLDetailType _
) As Integer
public:
int IndexOf(
    DeliveryURLDetailType^ item
)
Parameters
item (DeliveryURLDetailType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► Insert(Int32, DeliveryURLDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DeliveryURLDetailType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DeliveryURLDetailType _
)
public:
void Insert(
    int index,
    DeliveryURLDetailType^ item
)
Parameters
index (Int32)
item (DeliveryURLDetailType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryURLDetailType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DeliveryURLDetailType
    Get
    Set
public:
property DeliveryURLDetailType^ default[int index] {
    DeliveryURLDetailType^ get (int index);
    void set (int index, DeliveryURLDetailType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryURLDetailType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DeliveryURLDetailType
public:
DeliveryURLDetailType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► Remove(DeliveryURLDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DeliveryURLDetailType item
)
Public Sub Remove ( _
    item As DeliveryURLDetailType _
)
public:
void Remove(
    DeliveryURLDetailType^ item
)
Parameters
item (DeliveryURLDetailType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryURLDetailType[] ToArray()
Public Function ToArray As DeliveryURLDetailType()
public:
array<DeliveryURLDetailType^>^ ToArray()
Return Value


DepositSupportedDefinitionType Class

DepositSupportedDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► DepositSupportedDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DepositSupportedDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DepositSupportedDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DepositSupportedDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DepositSupportedDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DepositSupportedDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DepositSupportedDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DepositSupportedDefinitionType Constructor

DepositSupportedDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► DepositSupportedDefinitionType ► DepositSupportedDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DepositSupportedDefinitionType()
Public Sub New
public:
DepositSupportedDefinitionType()


DepositTypeCodeType Enumeration

DepositTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DepositTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DepositTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DepositTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DepositTypeCodeType
Members
Member | Description
None |
OtherMethod |
FastDeposit |
CustomCode |
Remarks


DescriptionReviseModeCodeType Enumeration

DescriptionReviseModeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DescriptionReviseModeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DescriptionReviseModeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DescriptionReviseModeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DescriptionReviseModeCodeType
Members
Member | Description
Replace |
Prepend |
Append |
CustomCode |
Remarks


DescriptionTemplateCodeType Enumeration

DescriptionTemplateCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DescriptionTemplateCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DescriptionTemplateCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DescriptionTemplateCodeType
Members
Member | Description
Layout |
Theme |
CustomCode |
Remarks


DescriptionTemplateType Class

DescriptionTemplateType Class
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DescriptionTemplateType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DescriptionTemplateType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DescriptionTemplateType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DescriptionTemplateType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GroupID |
 | GroupIDSpecified |
 | ID |
 | IDSpecified |
 | ImageURL |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | TemplateXML |
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | TypeSpecified |
Remarks
Inheritance Hierarchy
Object
DescriptionTemplateType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DescriptionTemplateType Constructor

DescriptionTemplateType Constructor
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType ► DescriptionTemplateType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionTemplateType()
Public Sub New
public:
DescriptionTemplateType()


GroupID Property

GroupID Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType ► GroupID
Declaration Syntax
C# Visual Basic Visual C++
public int GroupID { get; set; }
Public Property GroupID As Integer
    Get
    Set
public:
property int GroupID {
    int get ();
    void set (int value);
}


GroupIDSpecified Property

GroupIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType ► GroupIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GroupIDSpecified { get; set; }
Public Property GroupIDSpecified As Boolean
    Get
    Set
public:
property bool GroupIDSpecified {
    bool get ();
    void set (bool value);
}


ID Property

ID Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType ► ID
Declaration Syntax
C# Visual Basic Visual C++
public int ID { get; set; }
Public Property ID As Integer
    Get
    Set
public:
property int ID {
    int get ();
    void set (int value);
}


IDSpecified Property

IDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType ► IDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IDSpecified { get; set; }
Public Property IDSpecified As Boolean
    Get
    Set
public:
property bool IDSpecified {
    bool get ();
    void set (bool value);
}


ImageURL Property

ImageURL Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType ► ImageURL
Declaration Syntax
C# Visual Basic Visual C++
public string ImageURL { get; set; }
Public Property ImageURL As String
    Get
    Set
public:
property String^ ImageURL {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


TemplateXML Property

TemplateXML Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType ► TemplateXML
Declaration Syntax
C# Visual Basic Visual C++
public string TemplateXML { get; set; }
Public Property TemplateXML As String
    Get
    Set
public:
property String^ TemplateXML {
    String^ get ();
    void set (String^ value);
}


Type Property

Type Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType ► Type
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionTemplateCodeType Type { get; set; }
Public Property Type As DescriptionTemplateCodeType
    Get
    Set
public:
property DescriptionTemplateCodeType Type {
    DescriptionTemplateCodeType get ();
    void set (DescriptionTemplateCodeType value);
}


TypeSpecified Property

TypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateType ► TypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TypeSpecified { get; set; }
Public Property TypeSpecified As Boolean
    Get
    Set
public:
property bool TypeSpecified {
    bool get ();
    void set (bool value);
}


DescriptionTemplateTypeCollection Class

DescriptionTemplateTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DescriptionTemplateTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DescriptionTemplateTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DescriptionTemplateTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DescriptionTemplateTypeCollection()()()() |
 | DescriptionTemplateTypeCollection(array<DescriptionTemplateType>[]()[][]) |
 | DescriptionTemplateTypeCollection(DescriptionTemplateTypeCollection) |
 | Add(DescriptionTemplateType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DescriptionTemplateType>[]()[][]) |
 | AddRange(DescriptionTemplateTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DescriptionTemplateType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DescriptionTemplateType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DescriptionTemplateType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DescriptionTemplateType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DescriptionTemplateType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DescriptionTemplateTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► Add(DescriptionTemplateType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DescriptionTemplateType item
)
Public Function Add ( _
    item As DescriptionTemplateType _
) As Integer
public:
int Add(
    DescriptionTemplateType^ item
)
Parameters
item (DescriptionTemplateType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DescriptionTemplateType>[]()[][]) |
 | AddRange(DescriptionTemplateTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► AddRange(array<DescriptionTemplateType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DescriptionTemplateType[] items
)
Public Sub AddRange ( _
    items As DescriptionTemplateType() _
)
public:
void AddRange(
    array<DescriptionTemplateType^>^ items
)
Parameters
items (array< DescriptionTemplateType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► AddRange(DescriptionTemplateTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DescriptionTemplateTypeCollection items
)
Public Sub AddRange ( _
    items As DescriptionTemplateTypeCollection _
)
public:
void AddRange(
    DescriptionTemplateTypeCollection^ items
)
Parameters
items (DescriptionTemplateTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► Contains(DescriptionTemplateType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DescriptionTemplateType item
)
Public Function Contains ( _
    item As DescriptionTemplateType _
) As Boolean
public:
bool Contains(
    DescriptionTemplateType^ item
)
Parameters
item (DescriptionTemplateType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► CopyTo(array<DescriptionTemplateType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DescriptionTemplateType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DescriptionTemplateType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DescriptionTemplateType^>^ items,
    int index
)
Parameters
items (array< DescriptionTemplateType >[]()[][])
index (Int32)


DescriptionTemplateTypeCollection Constructor

DescriptionTemplateTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► DescriptionTemplateTypeCollection()()()()
Members
Icon | Member | Description
 | DescriptionTemplateTypeCollection()()()() |
 | DescriptionTemplateTypeCollection(array<DescriptionTemplateType>[]()[][]) |
 | DescriptionTemplateTypeCollection(DescriptionTemplateTypeCollection) |


DescriptionTemplateTypeCollection Constructor

DescriptionTemplateTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► DescriptionTemplateTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionTemplateTypeCollection()
Public Sub New
public:
DescriptionTemplateTypeCollection()


DescriptionTemplateTypeCollection Constructor (items)

DescriptionTemplateTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► DescriptionTemplateTypeCollection(array<DescriptionTemplateType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionTemplateTypeCollection(
    DescriptionTemplateType[] items
)
Public Sub New ( _
    items As DescriptionTemplateType() _
)
public:
DescriptionTemplateTypeCollection(
    array<DescriptionTemplateType^>^ items
)
Parameters
items (array< DescriptionTemplateType >[]()[][])


DescriptionTemplateTypeCollection Constructor (items)

DescriptionTemplateTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► DescriptionTemplateTypeCollection(DescriptionTemplateTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionTemplateTypeCollection(
    DescriptionTemplateTypeCollection items
)
Public Sub New ( _
    items As DescriptionTemplateTypeCollection _
)
public:
DescriptionTemplateTypeCollection(
    DescriptionTemplateTypeCollection^ items
)
Parameters
items (DescriptionTemplateTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► IndexOf(DescriptionTemplateType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DescriptionTemplateType item
)
Public Function IndexOf ( _
    item As DescriptionTemplateType _
) As Integer
public:
int IndexOf(
    DescriptionTemplateType^ item
)
Parameters
item (DescriptionTemplateType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► Insert(Int32, DescriptionTemplateType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DescriptionTemplateType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DescriptionTemplateType _
)
public:
void Insert(
    int index,
    DescriptionTemplateType^ item
)
Parameters
index (Int32)
item (DescriptionTemplateType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionTemplateType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DescriptionTemplateType
    Get
    Set
public:
property DescriptionTemplateType^ default[int index] {
    DescriptionTemplateType^ get (int index);
    void set (int index, DescriptionTemplateType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionTemplateType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DescriptionTemplateType
public:
DescriptionTemplateType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► Remove(DescriptionTemplateType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DescriptionTemplateType item
)
Public Sub Remove ( _
    item As DescriptionTemplateType _
)
public:
void Remove(
    DescriptionTemplateType^ item
)
Parameters
item (DescriptionTemplateType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionTemplateType[] ToArray()
Public Function ToArray As DescriptionTemplateType()
public:
array<DescriptionTemplateType^>^ ToArray()
Return Value


DetailLevelCodeType Enumeration

DetailLevelCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DetailLevelCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DetailLevelCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DetailLevelCodeType
Members
Member | Description
ReturnAll |
ItemReturnDescription |
ItemReturnAttributes |
ItemReturnCategories |
ReturnSummary |
ReturnHeaders |
ReturnMessages |
Remarks


DetailLevelCodeTypeCollection Class

DetailLevelCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DetailLevelCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DetailLevelCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DetailLevelCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DetailLevelCodeTypeCollection()()()() |
 | DetailLevelCodeTypeCollection(array<DetailLevelCodeType>[]()[][]) |
 | DetailLevelCodeTypeCollection(DetailLevelCodeTypeCollection) |
 | Add(DetailLevelCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DetailLevelCodeType>[]()[][]) |
 | AddRange(DetailLevelCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DetailLevelCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DetailLevelCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DetailLevelCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DetailLevelCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DetailLevelCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DetailLevelCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► Add(DetailLevelCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DetailLevelCodeType item
)
Public Function Add ( _
    item As DetailLevelCodeType _
) As Integer
public:
int Add(
    DetailLevelCodeType item
)
Parameters
item (DetailLevelCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DetailLevelCodeType>[]()[][]) |
 | AddRange(DetailLevelCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► AddRange(array<DetailLevelCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DetailLevelCodeType[] items
)
Public Sub AddRange ( _
    items As DetailLevelCodeType() _
)
public:
void AddRange(
    array<DetailLevelCodeType>^ items
)
Parameters
items (array< DetailLevelCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► AddRange(DetailLevelCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DetailLevelCodeTypeCollection items
)
Public Sub AddRange ( _
    items As DetailLevelCodeTypeCollection _
)
public:
void AddRange(
    DetailLevelCodeTypeCollection^ items
)
Parameters
items (DetailLevelCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► Contains(DetailLevelCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DetailLevelCodeType item
)
Public Function Contains ( _
    item As DetailLevelCodeType _
) As Boolean
public:
bool Contains(
    DetailLevelCodeType item
)
Parameters
item (DetailLevelCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► CopyTo(array<DetailLevelCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DetailLevelCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DetailLevelCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DetailLevelCodeType>^ items,
    int index
)
Parameters
items (array< DetailLevelCodeType >[]()[][])
index (Int32)


DetailLevelCodeTypeCollection Constructor

DetailLevelCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► DetailLevelCodeTypeCollection()()()()
Members
Icon | Member | Description
 | DetailLevelCodeTypeCollection()()()() |
 | DetailLevelCodeTypeCollection(array<DetailLevelCodeType>[]()[][]) |
 | DetailLevelCodeTypeCollection(DetailLevelCodeTypeCollection) |


DetailLevelCodeTypeCollection Constructor

DetailLevelCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► DetailLevelCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DetailLevelCodeTypeCollection()
Public Sub New
public:
DetailLevelCodeTypeCollection()


DetailLevelCodeTypeCollection Constructor (items)

DetailLevelCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► DetailLevelCodeTypeCollection(array<DetailLevelCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DetailLevelCodeTypeCollection(
    DetailLevelCodeType[] items
)
Public Sub New ( _
    items As DetailLevelCodeType() _
)
public:
DetailLevelCodeTypeCollection(
    array<DetailLevelCodeType>^ items
)
Parameters
items (array< DetailLevelCodeType >[]()[][])


DetailLevelCodeTypeCollection Constructor (items)

DetailLevelCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► DetailLevelCodeTypeCollection(DetailLevelCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DetailLevelCodeTypeCollection(
    DetailLevelCodeTypeCollection items
)
Public Sub New ( _
    items As DetailLevelCodeTypeCollection _
)
public:
DetailLevelCodeTypeCollection(
    DetailLevelCodeTypeCollection^ items
)
Parameters
items (DetailLevelCodeTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► IndexOf(DetailLevelCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DetailLevelCodeType item
)
Public Function IndexOf ( _
    item As DetailLevelCodeType _
) As Integer
public:
int IndexOf(
    DetailLevelCodeType item
)
Parameters
item (DetailLevelCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► Insert(Int32, DetailLevelCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DetailLevelCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DetailLevelCodeType _
)
public:
void Insert(
    int index,
    DetailLevelCodeType item
)
Parameters
index (Int32)
item (DetailLevelCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DetailLevelCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DetailLevelCodeType
    Get
    Set
public:
property DetailLevelCodeType default[int index] {
    DetailLevelCodeType get (int index);
    void set (int index, DetailLevelCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DetailLevelCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DetailLevelCodeType
public:
DetailLevelCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► Remove(DetailLevelCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DetailLevelCodeType item
)
Public Sub Remove ( _
    item As DetailLevelCodeType _
)
public:
void Remove(
    DetailLevelCodeType item
)
Parameters
item (DetailLevelCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DetailLevelCodeType[] ToArray()
Public Function ToArray As DetailLevelCodeType()
public:
array<DetailLevelCodeType>^ ToArray()
Return Value


DetailNameCodeType Enumeration

DetailNameCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DetailNameCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DetailNameCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DetailNameCodeType
Members
Member | Description
CountryDetails |
CurrencyDetails |
PaymentOptionDetails |
RegionDetails |
ShippingLocationDetails |
ShippingServiceDetails |
SiteDetails |
TaxJurisdiction |
URLDetails |
TimeZoneDetails |
RegionOfOriginDetails |
DispatchTimeMaxDetails |
ItemSpecificDetails |
UnitOfMeasurementDetails |
ShippingPackageDetails |
CustomCode |
ShippingCarrierDetails |
ListingStartPriceDetails |
ReturnPolicyDetails |
BuyerRequirementDetails |
ListingFeatureDetails |
VariationDetails |
ExcludeShippingLocationDetails |
RecoupmentPolicyDetails |
ShippingCategoryDetails |
ProductDetails |
Remarks


DetailNameCodeTypeCollection Class

DetailNameCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DetailNameCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DetailNameCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DetailNameCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DetailNameCodeTypeCollection()()()() |
 | DetailNameCodeTypeCollection(array<DetailNameCodeType>[]()[][]) |
 | DetailNameCodeTypeCollection(DetailNameCodeTypeCollection) |
 | Add(DetailNameCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DetailNameCodeType>[]()[][]) |
 | AddRange(DetailNameCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DetailNameCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DetailNameCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DetailNameCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DetailNameCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DetailNameCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DetailNameCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► Add(DetailNameCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DetailNameCodeType item
)
Public Function Add ( _
    item As DetailNameCodeType _
) As Integer
public:
int Add(
    DetailNameCodeType item
)
Parameters
item (DetailNameCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DetailNameCodeType>[]()[][]) |
 | AddRange(DetailNameCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► AddRange(array<DetailNameCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DetailNameCodeType[] items
)
Public Sub AddRange ( _
    items As DetailNameCodeType() _
)
public:
void AddRange(
    array<DetailNameCodeType>^ items
)
Parameters
items (array< DetailNameCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► AddRange(DetailNameCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DetailNameCodeTypeCollection items
)
Public Sub AddRange ( _
    items As DetailNameCodeTypeCollection _
)
public:
void AddRange(
    DetailNameCodeTypeCollection^ items
)
Parameters
items (DetailNameCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► Contains(DetailNameCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DetailNameCodeType item
)
Public Function Contains ( _
    item As DetailNameCodeType _
) As Boolean
public:
bool Contains(
    DetailNameCodeType item
)
Parameters
item (DetailNameCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► CopyTo(array<DetailNameCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DetailNameCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DetailNameCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DetailNameCodeType>^ items,
    int index
)
Parameters
items (array< DetailNameCodeType >[]()[][])
index (Int32)


DetailNameCodeTypeCollection Constructor

DetailNameCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► DetailNameCodeTypeCollection()()()()
Members
Icon | Member | Description
 | DetailNameCodeTypeCollection()()()() |
 | DetailNameCodeTypeCollection(array<DetailNameCodeType>[]()[][]) |
 | DetailNameCodeTypeCollection(DetailNameCodeTypeCollection) |


DetailNameCodeTypeCollection Constructor

DetailNameCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► DetailNameCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DetailNameCodeTypeCollection()
Public Sub New
public:
DetailNameCodeTypeCollection()


DetailNameCodeTypeCollection Constructor (items)

DetailNameCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► DetailNameCodeTypeCollection(array<DetailNameCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DetailNameCodeTypeCollection(
    DetailNameCodeType[] items
)
Public Sub New ( _
    items As DetailNameCodeType() _
)
public:
DetailNameCodeTypeCollection(
    array<DetailNameCodeType>^ items
)
Parameters
items (array< DetailNameCodeType >[]()[][])


DetailNameCodeTypeCollection Constructor (items)

DetailNameCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► DetailNameCodeTypeCollection(DetailNameCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DetailNameCodeTypeCollection(
    DetailNameCodeTypeCollection items
)
Public Sub New ( _
    items As DetailNameCodeTypeCollection _
)
public:
DetailNameCodeTypeCollection(
    DetailNameCodeTypeCollection^ items
)
Parameters
items (DetailNameCodeTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► IndexOf(DetailNameCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DetailNameCodeType item
)
Public Function IndexOf ( _
    item As DetailNameCodeType _
) As Integer
public:
int IndexOf(
    DetailNameCodeType item
)
Parameters
item (DetailNameCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► Insert(Int32, DetailNameCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DetailNameCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DetailNameCodeType _
)
public:
void Insert(
    int index,
    DetailNameCodeType item
)
Parameters
index (Int32)
item (DetailNameCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DetailNameCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DetailNameCodeType
    Get
    Set
public:
property DetailNameCodeType default[int index] {
    DetailNameCodeType get (int index);
    void set (int index, DetailNameCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DetailNameCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DetailNameCodeType
public:
DetailNameCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► Remove(DetailNameCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DetailNameCodeType item
)
Public Sub Remove ( _
    item As DetailNameCodeType _
)
public:
void Remove(
    DetailNameCodeType item
)
Parameters
item (DetailNameCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DetailNameCodeType[] ToArray()
Public Function ToArray As DetailNameCodeType()
public:
array<DetailNameCodeType>^ ToArray()
Return Value


DeviceTypeCodeType Enumeration

DeviceTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DeviceTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DeviceTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DeviceTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DeviceTypeCodeType
Members
Member | Description
Platform |
SMS |
ClientAlerts |
CustomCode |
Remarks


DigitalDeliverySelectedType Class

DigitalDeliverySelectedType Class
Namespaces ► eBay.Service.Core.Soap ► DigitalDeliverySelectedType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DigitalDeliverySelectedType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DigitalDeliverySelectedType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DigitalDeliverySelectedType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalDeliverySelectedType()()()() |
 | Any |
 | DeliveryDetails |
 | DeliveryMethod |
 | DeliveryStatus |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DigitalDeliverySelectedType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DigitalDeliverySelectedType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DeliveryDetails Property

DeliveryDetails Property
Namespaces ► eBay.Service.Core.Soap ► DigitalDeliverySelectedType ► DeliveryDetails
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryDetailsType DeliveryDetails { get; set; }
Public Property DeliveryDetails As DeliveryDetailsType
    Get
    Set
public:
property DeliveryDetailsType^ DeliveryDetails {
    DeliveryDetailsType^ get ();
    void set (DeliveryDetailsType^ value);
}


DeliveryMethod Property

DeliveryMethod Property
Namespaces ► eBay.Service.Core.Soap ► DigitalDeliverySelectedType ► DeliveryMethod
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryMethod { get; set; }
Public Property DeliveryMethod As String
    Get
    Set
public:
property String^ DeliveryMethod {
    String^ get ();
    void set (String^ value);
}


DeliveryStatus Property

DeliveryStatus Property
Namespaces ► eBay.Service.Core.Soap ► DigitalDeliverySelectedType ► DeliveryStatus
Declaration Syntax
C# Visual Basic Visual C++
public DeliveryStatusType DeliveryStatus { get; set; }
Public Property DeliveryStatus As DeliveryStatusType
    Get
    Set
public:
property DeliveryStatusType^ DeliveryStatus {
    DeliveryStatusType^ get ();
    void set (DeliveryStatusType^ value);
}


DigitalDeliverySelectedType Constructor

DigitalDeliverySelectedType Constructor
Namespaces ► eBay.Service.Core.Soap ► DigitalDeliverySelectedType ► DigitalDeliverySelectedType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDeliverySelectedType()
Public Sub New
public:
DigitalDeliverySelectedType()


DigitalDeliveryUserType Class

DigitalDeliveryUserType Class
Namespaces ► eBay.Service.Core.Soap ► DigitalDeliveryUserType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DigitalDeliveryUserType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DigitalDeliveryUserType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DigitalDeliveryUserType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalDeliveryUserType()()()() |
 | Any |
 | Email |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DigitalDeliveryUserType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DigitalDeliveryUserType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DigitalDeliveryUserType Constructor

DigitalDeliveryUserType Constructor
Namespaces ► eBay.Service.Core.Soap ► DigitalDeliveryUserType ► DigitalDeliveryUserType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDeliveryUserType()
Public Sub New
public:
DigitalDeliveryUserType()


Email Property

Email Property
Namespaces ► eBay.Service.Core.Soap ► DigitalDeliveryUserType ► Email
Declaration Syntax
C# Visual Basic Visual C++
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► DigitalDeliveryUserType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


DigitalGoodDeliveryEnabledDefinitionType Class

DigitalGoodDeliveryEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► DigitalGoodDeliveryEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DigitalGoodDeliveryEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DigitalGoodDeliveryEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DigitalGoodDeliveryEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalGoodDeliveryEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DigitalGoodDeliveryEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DigitalGoodDeliveryEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DigitalGoodDeliveryEnabledDefinitionType Constructor

DigitalGoodDeliveryEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► DigitalGoodDeliveryEnabledDefinitionType ► DigitalGoodDeliveryEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DigitalGoodDeliveryEnabledDefinitionType()
Public Sub New
public:
DigitalGoodDeliveryEnabledDefinitionType()


DigitalGoodInfoType Class

DigitalGoodInfoType Class
Namespaces ► eBay.Service.Core.Soap ► DigitalGoodInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DigitalGoodInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DigitalGoodInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DigitalGoodInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DigitalGoodInfoType()()()() |
 | Any |
 | DigitalDelivery |
 | DigitalDeliverySpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DigitalGoodInfoType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DigitalGoodInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DigitalDelivery Property

DigitalDelivery Property
Namespaces ► eBay.Service.Core.Soap ► DigitalGoodInfoType ► DigitalDelivery
Declaration Syntax
C# Visual Basic Visual C++
public bool DigitalDelivery { get; set; }
Public Property DigitalDelivery As Boolean
    Get
    Set
public:
property bool DigitalDelivery {
    bool get ();
    void set (bool value);
}


DigitalDeliverySpecified Property

DigitalDeliverySpecified Property
Namespaces ► eBay.Service.Core.Soap ► DigitalGoodInfoType ► DigitalDeliverySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DigitalDeliverySpecified { get; set; }
Public Property DigitalDeliverySpecified As Boolean
    Get
    Set
public:
property bool DigitalDeliverySpecified {
    bool get ();
    void set (bool value);
}


DigitalGoodInfoType Constructor

DigitalGoodInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► DigitalGoodInfoType ► DigitalGoodInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DigitalGoodInfoType()
Public Sub New
public:
DigitalGoodInfoType()


DigitalStatusCodeType Enumeration

DigitalStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DigitalStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DigitalStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DigitalStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DigitalStatusCodeType
Members
Member | Description
Inactive |
Activated |
Downloaded |
Deactivated |
CustomCode |
Remarks


DisableUnpaidItemAssistanceRequestType Class

DisableUnpaidItemAssistanceRequestType Class
Namespaces ► eBay.Service.Core.Soap ► DisableUnpaidItemAssistanceRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DisableUnpaidItemAssistanceRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DisableUnpaidItemAssistanceRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DisableUnpaidItemAssistanceRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisableUnpaidItemAssistanceRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | DisputeID |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | DisableUnpaidItemAssistanceRequestType


DisableUnpaidItemAssistanceRequestType Constructor

DisableUnpaidItemAssistanceRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► DisableUnpaidItemAssistanceRequestType ► DisableUnpaidItemAssistanceRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisableUnpaidItemAssistanceRequestType()
Public Sub New
public:
DisableUnpaidItemAssistanceRequestType()


DisputeID Property

DisputeID Property
Namespaces ► eBay.Service.Core.Soap ► DisableUnpaidItemAssistanceRequestType ► DisputeID
Declaration Syntax
C# Visual Basic Visual C++
public string DisputeID { get; set; }
Public Property DisputeID As String
    Get
    Set
public:
property String^ DisputeID {
    String^ get ();
    void set (String^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► DisableUnpaidItemAssistanceRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► DisableUnpaidItemAssistanceRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► DisableUnpaidItemAssistanceRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


DisableUnpaidItemAssistanceResponseType Class

DisableUnpaidItemAssistanceResponseType Class
Namespaces ► eBay.Service.Core.Soap ► DisableUnpaidItemAssistanceResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DisableUnpaidItemAssistanceResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DisableUnpaidItemAssistanceResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DisableUnpaidItemAssistanceResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisableUnpaidItemAssistanceResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | DisableUnpaidItemAssistanceResponseType


DisableUnpaidItemAssistanceResponseType Constructor

DisableUnpaidItemAssistanceResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► DisableUnpaidItemAssistanceResponseType ► DisableUnpaidItemAssistanceResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisableUnpaidItemAssistanceResponseType()
Public Sub New
public:
DisableUnpaidItemAssistanceResponseType()


DiscountCodeType Enumeration

DiscountCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DiscountCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DiscountCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DiscountCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DiscountCodeType
Members
Member | Description
Percentage |
Price |
CustomCode |
Remarks


DiscountNameCodeType Enumeration

DiscountNameCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DiscountNameCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DiscountNameCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DiscountNameCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DiscountNameCodeType
Members
Member | Description
EachAdditionalAmount |
EachAdditionalAmountOff |
EachAdditionalPercentOff |
IndividualItemWeight |
CombinedItemWeight |
WeightOff |
ShippingCostXForAmountY |
ShippingCostXForItemCountN |
MaximumShippingCostPerOrder |
CustomCode |
Remarks


DiscountPriceInfoType Class

DiscountPriceInfoType Class
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DiscountPriceInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DiscountPriceInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DiscountPriceInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DiscountPriceInfoType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MadeForOutletComparisonPrice |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumAdvertisedPrice |
 | MinimumAdvertisedPriceExposure |
 | MinimumAdvertisedPriceExposureSpecified |
 | OriginalRetailPrice |
 | PricingTreatment |
 | PricingTreatmentSpecified |
 | SoldOffeBay |
 | SoldOneBay |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DiscountPriceInfoType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DiscountPriceInfoType Constructor

DiscountPriceInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType ► DiscountPriceInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DiscountPriceInfoType()
Public Sub New
public:
DiscountPriceInfoType()


MadeForOutletComparisonPrice Property

MadeForOutletComparisonPrice Property
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType ► MadeForOutletComparisonPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MadeForOutletComparisonPrice { get; set; }
Public Property MadeForOutletComparisonPrice As AmountType
    Get
    Set
public:
property AmountType^ MadeForOutletComparisonPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


MinimumAdvertisedPrice Property

MinimumAdvertisedPrice Property
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType ► MinimumAdvertisedPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MinimumAdvertisedPrice { get; set; }
Public Property MinimumAdvertisedPrice As AmountType
    Get
    Set
public:
property AmountType^ MinimumAdvertisedPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


MinimumAdvertisedPriceExposure Property

MinimumAdvertisedPriceExposure Property
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType ► MinimumAdvertisedPriceExposure
Declaration Syntax
C# Visual Basic Visual C++
public MinimumAdvertisedPriceExposureCodeType MinimumAdvertisedPriceExposure { get; set; }
Public Property MinimumAdvertisedPriceExposure As MinimumAdvertisedPriceExposureCodeType
    Get
    Set
public:
property MinimumAdvertisedPriceExposureCodeType MinimumAdvertisedPriceExposure {
    MinimumAdvertisedPriceExposureCodeType get ();
    void set (MinimumAdvertisedPriceExposureCodeType value);
}


MinimumAdvertisedPriceExposureSpecified Property

MinimumAdvertisedPriceExposureSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType ► MinimumAdvertisedPriceExposureSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinimumAdvertisedPriceExposureSpecified { get; set; }
Public Property MinimumAdvertisedPriceExposureSpecified As Boolean
    Get
    Set
public:
property bool MinimumAdvertisedPriceExposureSpecified {
    bool get ();
    void set (bool value);
}


OriginalRetailPrice Property

OriginalRetailPrice Property
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType ► OriginalRetailPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType OriginalRetailPrice { get; set; }
Public Property OriginalRetailPrice As AmountType
    Get
    Set
public:
property AmountType^ OriginalRetailPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


PricingTreatment Property

PricingTreatment Property
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType ► PricingTreatment
Declaration Syntax
C# Visual Basic Visual C++
public PricingTreatmentCodeType PricingTreatment { get; set; }
Public Property PricingTreatment As PricingTreatmentCodeType
    Get
    Set
public:
property PricingTreatmentCodeType PricingTreatment {
    PricingTreatmentCodeType get ();
    void set (PricingTreatmentCodeType value);
}


PricingTreatmentSpecified Property

PricingTreatmentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType ► PricingTreatmentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PricingTreatmentSpecified { get; set; }
Public Property PricingTreatmentSpecified As Boolean
    Get
    Set
public:
property bool PricingTreatmentSpecified {
    bool get ();
    void set (bool value);
}


SoldOffeBay Property

SoldOffeBay Property
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType ► SoldOffeBay
Declaration Syntax
C# Visual Basic Visual C++
public bool SoldOffeBay { get; set; }
Public Property SoldOffeBay As Boolean
    Get
    Set
public:
property bool SoldOffeBay {
    bool get ();
    void set (bool value);
}


SoldOneBay Property

SoldOneBay Property
Namespaces ► eBay.Service.Core.Soap ► DiscountPriceInfoType ► SoldOneBay
Declaration Syntax
C# Visual Basic Visual C++
public bool SoldOneBay { get; set; }
Public Property SoldOneBay As Boolean
    Get
    Set
public:
property bool SoldOneBay {
    bool get ();
    void set (bool value);
}


DiscountProfileType Class

DiscountProfileType Class
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DiscountProfileType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DiscountProfileType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DiscountProfileType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DiscountProfileType()()()() |
 | Any |
 | DiscountProfileID |
 | DiscountProfileName |
 | EachAdditionalAmount |
 | EachAdditionalAmountOff |
 | EachAdditionalPercentOff |
 | EachAdditionalPercentOffSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MappedDiscountProfileID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | WeightOff |
Remarks
Inheritance Hierarchy
Object
DiscountProfileType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DiscountProfileID Property

DiscountProfileID Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileType ► DiscountProfileID
Declaration Syntax
C# Visual Basic Visual C++
public string DiscountProfileID { get; set; }
Public Property DiscountProfileID As String
    Get
    Set
public:
property String^ DiscountProfileID {
    String^ get ();
    void set (String^ value);
}


DiscountProfileName Property

DiscountProfileName Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileType ► DiscountProfileName
Declaration Syntax
C# Visual Basic Visual C++
public string DiscountProfileName { get; set; }
Public Property DiscountProfileName As String
    Get
    Set
public:
property String^ DiscountProfileName {
    String^ get ();
    void set (String^ value);
}


DiscountProfileType Constructor

DiscountProfileType Constructor
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileType ► DiscountProfileType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DiscountProfileType()
Public Sub New
public:
DiscountProfileType()


EachAdditionalAmount Property

EachAdditionalAmount Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileType ► EachAdditionalAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType EachAdditionalAmount { get; set; }
Public Property EachAdditionalAmount As AmountType
    Get
    Set
public:
property AmountType^ EachAdditionalAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


EachAdditionalAmountOff Property

EachAdditionalAmountOff Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileType ► EachAdditionalAmountOff
Declaration Syntax
C# Visual Basic Visual C++
public AmountType EachAdditionalAmountOff { get; set; }
Public Property EachAdditionalAmountOff As AmountType
    Get
    Set
public:
property AmountType^ EachAdditionalAmountOff {
    AmountType^ get ();
    void set (AmountType^ value);
}


EachAdditionalPercentOff Property

EachAdditionalPercentOff Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileType ► EachAdditionalPercentOff
Declaration Syntax
C# Visual Basic Visual C++
public float EachAdditionalPercentOff { get; set; }
Public Property EachAdditionalPercentOff As Single
    Get
    Set
public:
property float EachAdditionalPercentOff {
    float get ();
    void set (float value);
}


EachAdditionalPercentOffSpecified Property

EachAdditionalPercentOffSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileType ► EachAdditionalPercentOffSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EachAdditionalPercentOffSpecified { get; set; }
Public Property EachAdditionalPercentOffSpecified As Boolean
    Get
    Set
public:
property bool EachAdditionalPercentOffSpecified {
    bool get ();
    void set (bool value);
}


MappedDiscountProfileID Property

MappedDiscountProfileID Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileType ► MappedDiscountProfileID
Declaration Syntax
C# Visual Basic Visual C++
public string MappedDiscountProfileID { get; set; }
Public Property MappedDiscountProfileID As String
    Get
    Set
public:
property String^ MappedDiscountProfileID {
    String^ get ();
    void set (String^ value);
}


WeightOff Property

WeightOff Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileType ► WeightOff
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType WeightOff { get; set; }
Public Property WeightOff As MeasureType
    Get
    Set
public:
property MeasureType^ WeightOff {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


DiscountProfileTypeCollection Class

DiscountProfileTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DiscountProfileTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DiscountProfileTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DiscountProfileTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DiscountProfileTypeCollection()()()() |
 | DiscountProfileTypeCollection(array<DiscountProfileType>[]()[][]) |
 | DiscountProfileTypeCollection(DiscountProfileTypeCollection) |
 | Add(DiscountProfileType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DiscountProfileType>[]()[][]) |
 | AddRange(DiscountProfileTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DiscountProfileType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DiscountProfileType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DiscountProfileType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DiscountProfileType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DiscountProfileType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DiscountProfileTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► Add(DiscountProfileType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DiscountProfileType item
)
Public Function Add ( _
    item As DiscountProfileType _
) As Integer
public:
int Add(
    DiscountProfileType^ item
)
Parameters
item (DiscountProfileType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DiscountProfileType>[]()[][]) |
 | AddRange(DiscountProfileTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► AddRange(array<DiscountProfileType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DiscountProfileType[] items
)
Public Sub AddRange ( _
    items As DiscountProfileType() _
)
public:
void AddRange(
    array<DiscountProfileType^>^ items
)
Parameters
items (array< DiscountProfileType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► AddRange(DiscountProfileTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DiscountProfileTypeCollection items
)
Public Sub AddRange ( _
    items As DiscountProfileTypeCollection _
)
public:
void AddRange(
    DiscountProfileTypeCollection^ items
)
Parameters
items (DiscountProfileTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► Contains(DiscountProfileType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DiscountProfileType item
)
Public Function Contains ( _
    item As DiscountProfileType _
) As Boolean
public:
bool Contains(
    DiscountProfileType^ item
)
Parameters
item (DiscountProfileType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► CopyTo(array<DiscountProfileType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DiscountProfileType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DiscountProfileType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DiscountProfileType^>^ items,
    int index
)
Parameters
items (array< DiscountProfileType >[]()[][])
index (Int32)


DiscountProfileTypeCollection Constructor

DiscountProfileTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► DiscountProfileTypeCollection()()()()
Members
Icon | Member | Description
 | DiscountProfileTypeCollection()()()() |
 | DiscountProfileTypeCollection(array<DiscountProfileType>[]()[][]) |
 | DiscountProfileTypeCollection(DiscountProfileTypeCollection) |


DiscountProfileTypeCollection Constructor

DiscountProfileTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► DiscountProfileTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DiscountProfileTypeCollection()
Public Sub New
public:
DiscountProfileTypeCollection()


DiscountProfileTypeCollection Constructor (items)

DiscountProfileTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► DiscountProfileTypeCollection(array<DiscountProfileType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DiscountProfileTypeCollection(
    DiscountProfileType[] items
)
Public Sub New ( _
    items As DiscountProfileType() _
)
public:
DiscountProfileTypeCollection(
    array<DiscountProfileType^>^ items
)
Parameters
items (array< DiscountProfileType >[]()[][])


DiscountProfileTypeCollection Constructor (items)

DiscountProfileTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► DiscountProfileTypeCollection(DiscountProfileTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DiscountProfileTypeCollection(
    DiscountProfileTypeCollection items
)
Public Sub New ( _
    items As DiscountProfileTypeCollection _
)
public:
DiscountProfileTypeCollection(
    DiscountProfileTypeCollection^ items
)
Parameters
items (DiscountProfileTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► IndexOf(DiscountProfileType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DiscountProfileType item
)
Public Function IndexOf ( _
    item As DiscountProfileType _
) As Integer
public:
int IndexOf(
    DiscountProfileType^ item
)
Parameters
item (DiscountProfileType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► Insert(Int32, DiscountProfileType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DiscountProfileType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DiscountProfileType _
)
public:
void Insert(
    int index,
    DiscountProfileType^ item
)
Parameters
index (Int32)
item (DiscountProfileType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DiscountProfileType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DiscountProfileType
    Get
    Set
public:
property DiscountProfileType^ default[int index] {
    DiscountProfileType^ get (int index);
    void set (int index, DiscountProfileType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DiscountProfileType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DiscountProfileType
public:
DiscountProfileType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► Remove(DiscountProfileType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DiscountProfileType item
)
Public Sub Remove ( _
    item As DiscountProfileType _
)
public:
void Remove(
    DiscountProfileType^ item
)
Parameters
item (DiscountProfileType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DiscountProfileType[] ToArray()
Public Function ToArray As DiscountProfileType()
public:
array<DiscountProfileType^>^ ToArray()
Return Value


DiscountReasonCodeType Enumeration

DiscountReasonCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DiscountReasonCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DiscountReasonCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DiscountReasonCodeType
Members
Member | Description
SpecialOffer |
Promotion |
CustomCode |
Remarks


DiscountReasonCodeTypeCollection Class

DiscountReasonCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DiscountReasonCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DiscountReasonCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DiscountReasonCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DiscountReasonCodeTypeCollection()()()() |
 | DiscountReasonCodeTypeCollection(array<DiscountReasonCodeType>[]()[][]) |
 | DiscountReasonCodeTypeCollection(DiscountReasonCodeTypeCollection) |
 | Add(DiscountReasonCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DiscountReasonCodeType>[]()[][]) |
 | AddRange(DiscountReasonCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DiscountReasonCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DiscountReasonCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DiscountReasonCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DiscountReasonCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DiscountReasonCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DiscountReasonCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► Add(DiscountReasonCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DiscountReasonCodeType item
)
Public Function Add ( _
    item As DiscountReasonCodeType _
) As Integer
public:
int Add(
    DiscountReasonCodeType item
)
Parameters
item (DiscountReasonCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DiscountReasonCodeType>[]()[][]) |
 | AddRange(DiscountReasonCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► AddRange(array<DiscountReasonCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DiscountReasonCodeType[] items
)
Public Sub AddRange ( _
    items As DiscountReasonCodeType() _
)
public:
void AddRange(
    array<DiscountReasonCodeType>^ items
)
Parameters
items (array< DiscountReasonCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► AddRange(DiscountReasonCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DiscountReasonCodeTypeCollection items
)
Public Sub AddRange ( _
    items As DiscountReasonCodeTypeCollection _
)
public:
void AddRange(
    DiscountReasonCodeTypeCollection^ items
)
Parameters
items (DiscountReasonCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► Contains(DiscountReasonCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DiscountReasonCodeType item
)
Public Function Contains ( _
    item As DiscountReasonCodeType _
) As Boolean
public:
bool Contains(
    DiscountReasonCodeType item
)
Parameters
item (DiscountReasonCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► CopyTo(array<DiscountReasonCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DiscountReasonCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DiscountReasonCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DiscountReasonCodeType>^ items,
    int index
)
Parameters
items (array< DiscountReasonCodeType >[]()[][])
index (Int32)


DiscountReasonCodeTypeCollection Constructor

DiscountReasonCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► DiscountReasonCodeTypeCollection()()()()
Members
Icon | Member | Description
 | DiscountReasonCodeTypeCollection()()()() |
 | DiscountReasonCodeTypeCollection(array<DiscountReasonCodeType>[]()[][]) |
 | DiscountReasonCodeTypeCollection(DiscountReasonCodeTypeCollection) |


DiscountReasonCodeTypeCollection Constructor

DiscountReasonCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► DiscountReasonCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection()
Public Sub New
public:
DiscountReasonCodeTypeCollection()


DiscountReasonCodeTypeCollection Constructor (items)

DiscountReasonCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► DiscountReasonCodeTypeCollection(array<DiscountReasonCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection(
    DiscountReasonCodeType[] items
)
Public Sub New ( _
    items As DiscountReasonCodeType() _
)
public:
DiscountReasonCodeTypeCollection(
    array<DiscountReasonCodeType>^ items
)
Parameters
items (array< DiscountReasonCodeType >[]()[][])


DiscountReasonCodeTypeCollection Constructor (items)

DiscountReasonCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► DiscountReasonCodeTypeCollection(DiscountReasonCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection(
    DiscountReasonCodeTypeCollection items
)
Public Sub New ( _
    items As DiscountReasonCodeTypeCollection _
)
public:
DiscountReasonCodeTypeCollection(
    DiscountReasonCodeTypeCollection^ items
)
Parameters
items (DiscountReasonCodeTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► IndexOf(DiscountReasonCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DiscountReasonCodeType item
)
Public Function IndexOf ( _
    item As DiscountReasonCodeType _
) As Integer
public:
int IndexOf(
    DiscountReasonCodeType item
)
Parameters
item (DiscountReasonCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► Insert(Int32, DiscountReasonCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DiscountReasonCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DiscountReasonCodeType _
)
public:
void Insert(
    int index,
    DiscountReasonCodeType item
)
Parameters
index (Int32)
item (DiscountReasonCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DiscountReasonCodeType
    Get
    Set
public:
property DiscountReasonCodeType default[int index] {
    DiscountReasonCodeType get (int index);
    void set (int index, DiscountReasonCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DiscountReasonCodeType
public:
DiscountReasonCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► Remove(DiscountReasonCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DiscountReasonCodeType item
)
Public Sub Remove ( _
    item As DiscountReasonCodeType _
)
public:
void Remove(
    DiscountReasonCodeType item
)
Parameters
item (DiscountReasonCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeType[] ToArray()
Public Function ToArray As DiscountReasonCodeType()
public:
array<DiscountReasonCodeType>^ ToArray()
Return Value


DispatchCutoffTimePreferencesType Class

DispatchCutoffTimePreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► DispatchCutoffTimePreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DispatchCutoffTimePreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DispatchCutoffTimePreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DispatchCutoffTimePreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DispatchCutoffTimePreferencesType()()()() |
 | Any |
 | CutoffTime |
 | CutoffTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DispatchCutoffTimePreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DispatchCutoffTimePreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CutoffTime Property

CutoffTime Property
Namespaces ► eBay.Service.Core.Soap ► DispatchCutoffTimePreferencesType ► CutoffTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CutoffTime { get; set; }
Public Property CutoffTime As DateTime
    Get
    Set
public:
property DateTime CutoffTime {
    DateTime get ();
    void set (DateTime value);
}


CutoffTimeSpecified Property

CutoffTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DispatchCutoffTimePreferencesType ► CutoffTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CutoffTimeSpecified { get; set; }
Public Property CutoffTimeSpecified As Boolean
    Get
    Set
public:
property bool CutoffTimeSpecified {
    bool get ();
    void set (bool value);
}


DispatchCutoffTimePreferencesType Constructor

DispatchCutoffTimePreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► DispatchCutoffTimePreferencesType ► DispatchCutoffTimePreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DispatchCutoffTimePreferencesType()
Public Sub New
public:
DispatchCutoffTimePreferencesType()


DispatchTimeMaxDetailsType Class

DispatchTimeMaxDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DispatchTimeMaxDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DispatchTimeMaxDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DispatchTimeMaxDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DispatchTimeMaxDetailsType()()()() |
 | Any |
 | Description |
 | DetailVersion |
 | DispatchTimeMax |
 | DispatchTimeMaxSpecified |
 | Equals(Object) | (Inherited from Object.)
 | ExtendedHandling |
 | ExtendedHandlingSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
DispatchTimeMaxDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


DispatchTimeMax Property

DispatchTimeMax Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsType ► DispatchTimeMax
Declaration Syntax
C# Visual Basic Visual C++
public int DispatchTimeMax { get; set; }
Public Property DispatchTimeMax As Integer
    Get
    Set
public:
property int DispatchTimeMax {
    int get ();
    void set (int value);
}


DispatchTimeMaxDetailsType Constructor

DispatchTimeMaxDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsType ► DispatchTimeMaxDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DispatchTimeMaxDetailsType()
Public Sub New
public:
DispatchTimeMaxDetailsType()


DispatchTimeMaxSpecified Property

DispatchTimeMaxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsType ► DispatchTimeMaxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DispatchTimeMaxSpecified { get; set; }
Public Property DispatchTimeMaxSpecified As Boolean
    Get
    Set
public:
property bool DispatchTimeMaxSpecified {
    bool get ();
    void set (bool value);
}


ExtendedHandling Property

ExtendedHandling Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsType ► ExtendedHandling
Declaration Syntax
C# Visual Basic Visual C++
public bool ExtendedHandling { get; set; }
Public Property ExtendedHandling As Boolean
    Get
    Set
public:
property bool ExtendedHandling {
    bool get ();
    void set (bool value);
}


ExtendedHandlingSpecified Property

ExtendedHandlingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsType ► ExtendedHandlingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExtendedHandlingSpecified { get; set; }
Public Property ExtendedHandlingSpecified As Boolean
    Get
    Set
public:
property bool ExtendedHandlingSpecified {
    bool get ();
    void set (bool value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


DispatchTimeMaxDetailsTypeCollection Class

DispatchTimeMaxDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DispatchTimeMaxDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DispatchTimeMaxDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DispatchTimeMaxDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DispatchTimeMaxDetailsTypeCollection()()()() |
 | DispatchTimeMaxDetailsTypeCollection(array<DispatchTimeMaxDetailsType>[]()[][]) |
 | DispatchTimeMaxDetailsTypeCollection(DispatchTimeMaxDetailsTypeCollection) |
 | Add(DispatchTimeMaxDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DispatchTimeMaxDetailsType>[]()[][]) |
 | AddRange(DispatchTimeMaxDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DispatchTimeMaxDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DispatchTimeMaxDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DispatchTimeMaxDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DispatchTimeMaxDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DispatchTimeMaxDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DispatchTimeMaxDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► Add(DispatchTimeMaxDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DispatchTimeMaxDetailsType item
)
Public Function Add ( _
    item As DispatchTimeMaxDetailsType _
) As Integer
public:
int Add(
    DispatchTimeMaxDetailsType^ item
)
Parameters
item (DispatchTimeMaxDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DispatchTimeMaxDetailsType>[]()[][]) |
 | AddRange(DispatchTimeMaxDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► AddRange(array<DispatchTimeMaxDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DispatchTimeMaxDetailsType[] items
)
Public Sub AddRange ( _
    items As DispatchTimeMaxDetailsType() _
)
public:
void AddRange(
    array<DispatchTimeMaxDetailsType^>^ items
)
Parameters
items (array< DispatchTimeMaxDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► AddRange(DispatchTimeMaxDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DispatchTimeMaxDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As DispatchTimeMaxDetailsTypeCollection _
)
public:
void AddRange(
    DispatchTimeMaxDetailsTypeCollection^ items
)
Parameters
items (DispatchTimeMaxDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► Contains(DispatchTimeMaxDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DispatchTimeMaxDetailsType item
)
Public Function Contains ( _
    item As DispatchTimeMaxDetailsType _
) As Boolean
public:
bool Contains(
    DispatchTimeMaxDetailsType^ item
)
Parameters
item (DispatchTimeMaxDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► CopyTo(array<DispatchTimeMaxDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DispatchTimeMaxDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DispatchTimeMaxDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DispatchTimeMaxDetailsType^>^ items,
    int index
)
Parameters
items (array< DispatchTimeMaxDetailsType >[]()[][])
index (Int32)


DispatchTimeMaxDetailsTypeCollection Constructor

DispatchTimeMaxDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► DispatchTimeMaxDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | DispatchTimeMaxDetailsTypeCollection()()()() |
 | DispatchTimeMaxDetailsTypeCollection(array<DispatchTimeMaxDetailsType>[]()[][]) |
 | DispatchTimeMaxDetailsTypeCollection(DispatchTimeMaxDetailsTypeCollection) |


DispatchTimeMaxDetailsTypeCollection Constructor

DispatchTimeMaxDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► DispatchTimeMaxDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DispatchTimeMaxDetailsTypeCollection()
Public Sub New
public:
DispatchTimeMaxDetailsTypeCollection()


DispatchTimeMaxDetailsTypeCollection Constructor (items)

DispatchTimeMaxDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► DispatchTimeMaxDetailsTypeCollection(array<DispatchTimeMaxDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DispatchTimeMaxDetailsTypeCollection(
    DispatchTimeMaxDetailsType[] items
)
Public Sub New ( _
    items As DispatchTimeMaxDetailsType() _
)
public:
DispatchTimeMaxDetailsTypeCollection(
    array<DispatchTimeMaxDetailsType^>^ items
)
Parameters
items (array< DispatchTimeMaxDetailsType >[]()[][])


DispatchTimeMaxDetailsTypeCollection Constructor (items)

DispatchTimeMaxDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► DispatchTimeMaxDetailsTypeCollection(DispatchTimeMaxDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DispatchTimeMaxDetailsTypeCollection(
    DispatchTimeMaxDetailsTypeCollection items
)
Public Sub New ( _
    items As DispatchTimeMaxDetailsTypeCollection _
)
public:
DispatchTimeMaxDetailsTypeCollection(
    DispatchTimeMaxDetailsTypeCollection^ items
)
Parameters
items (DispatchTimeMaxDetailsTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► IndexOf(DispatchTimeMaxDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DispatchTimeMaxDetailsType item
)
Public Function IndexOf ( _
    item As DispatchTimeMaxDetailsType _
) As Integer
public:
int IndexOf(
    DispatchTimeMaxDetailsType^ item
)
Parameters
item (DispatchTimeMaxDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► Insert(Int32, DispatchTimeMaxDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DispatchTimeMaxDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DispatchTimeMaxDetailsType _
)
public:
void Insert(
    int index,
    DispatchTimeMaxDetailsType^ item
)
Parameters
index (Int32)
item (DispatchTimeMaxDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DispatchTimeMaxDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DispatchTimeMaxDetailsType
    Get
    Set
public:
property DispatchTimeMaxDetailsType^ default[int index] {
    DispatchTimeMaxDetailsType^ get (int index);
    void set (int index, DispatchTimeMaxDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DispatchTimeMaxDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DispatchTimeMaxDetailsType
public:
DispatchTimeMaxDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► Remove(DispatchTimeMaxDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DispatchTimeMaxDetailsType item
)
Public Sub Remove ( _
    item As DispatchTimeMaxDetailsType _
)
public:
void Remove(
    DispatchTimeMaxDetailsType^ item
)
Parameters
item (DispatchTimeMaxDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DispatchTimeMaxDetailsType[] ToArray()
Public Function ToArray As DispatchTimeMaxDetailsType()
public:
array<DispatchTimeMaxDetailsType^>^ ToArray()
Return Value


DisplayPayNowButtonCodeType Enumeration

DisplayPayNowButtonCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisplayPayNowButtonCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisplayPayNowButtonCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisplayPayNowButtonCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisplayPayNowButtonCodeType
Members
Member | Description
ShowPayNowButtonForAllPaymentMethods |
ShowPayNowButtonForPayPalOnly |
CustomCode |
Remarks


DisputeActivityCodeType Enumeration

DisputeActivityCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeActivityCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeActivityCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeActivityCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeActivityCodeType
Members
Member | Description
SellerAddInformation |
SellerCompletedTransaction |
CameToAgreementNeedFVFCredit |
SellerEndCommunication |
MutualAgreementOrNoBuyerResponse |
SellerOffersRefund |
SellerShippedItem |
SellerComment |
SellerPaymentNotReceived |
CustomCode |
Remarks


DisputeCreditEligibilityCodeType Enumeration

DisputeCreditEligibilityCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeCreditEligibilityCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeCreditEligibilityCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeCreditEligibilityCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeCreditEligibilityCodeType
Members
Member | Description
InEligible |
Eligible |
CustomCode |
Remarks


DisputeExplanationCodeType Enumeration

DisputeExplanationCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeExplanationCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeExplanationCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeExplanationCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeExplanationCodeType
Members
Member | Description
BuyerHasNotResponded |
BuyerRefusedToPay |
BuyerNotClearedToPay |
BuyerReturnedItemForRefund |
UnableToResolveTerms |
BuyerNoLongerWantsItem |
BuyerPurchasingMistake |
ShipCountryNotSupported |
ShippingAddressNotConfirmed |
PaymentMethodNotSupported |
BuyerNoLongerRegistered |
OtherExplanation |
Unspecified |
UPIAssistance |
BuyerPaymentNotReceivedOrCleared |
SellerDoesntShipToCountry |
BuyerNotPaid |
UPIAssistanceDisabled |
SellerRanOutOfStock |
CustomCode |
Remarks


DisputeFilterCountType Class

DisputeFilterCountType Class
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DisputeFilterCountType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DisputeFilterCountType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DisputeFilterCountType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisputeFilterCountType()()()() |
 | Any |
 | DisputeFilterType |
 | DisputeFilterTypeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TotalAvailable |
 | TotalAvailableSpecified |
Remarks
Inheritance Hierarchy
Object
DisputeFilterCountType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DisputeFilterCountType Constructor

DisputeFilterCountType Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountType ► DisputeFilterCountType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterCountType()
Public Sub New
public:
DisputeFilterCountType()


DisputeFilterType Property

DisputeFilterType Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountType ► DisputeFilterType
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterTypeCodeType DisputeFilterType { get; set; }
Public Property DisputeFilterType As DisputeFilterTypeCodeType
    Get
    Set
public:
property DisputeFilterTypeCodeType DisputeFilterType {
    DisputeFilterTypeCodeType get ();
    void set (DisputeFilterTypeCodeType value);
}


DisputeFilterTypeSpecified Property

DisputeFilterTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountType ► DisputeFilterTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeFilterTypeSpecified { get; set; }
Public Property DisputeFilterTypeSpecified As Boolean
    Get
    Set
public:
property bool DisputeFilterTypeSpecified {
    bool get ();
    void set (bool value);
}


TotalAvailable Property

TotalAvailable Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountType ► TotalAvailable
Declaration Syntax
C# Visual Basic Visual C++
public int TotalAvailable { get; set; }
Public Property TotalAvailable As Integer
    Get
    Set
public:
property int TotalAvailable {
    int get ();
    void set (int value);
}


TotalAvailableSpecified Property

TotalAvailableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountType ► TotalAvailableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalAvailableSpecified { get; set; }
Public Property TotalAvailableSpecified As Boolean
    Get
    Set
public:
property bool TotalAvailableSpecified {
    bool get ();
    void set (bool value);
}


DisputeFilterCountTypeCollection Class

DisputeFilterCountTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DisputeFilterCountTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DisputeFilterCountTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DisputeFilterCountTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisputeFilterCountTypeCollection()()()() |
 | DisputeFilterCountTypeCollection(array<DisputeFilterCountType>[]()[][]) |
 | DisputeFilterCountTypeCollection(DisputeFilterCountTypeCollection) |
 | Add(DisputeFilterCountType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DisputeFilterCountType>[]()[][]) |
 | AddRange(DisputeFilterCountTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DisputeFilterCountType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DisputeFilterCountType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DisputeFilterCountType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DisputeFilterCountType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DisputeFilterCountType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DisputeFilterCountTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► Add(DisputeFilterCountType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DisputeFilterCountType item
)
Public Function Add ( _
    item As DisputeFilterCountType _
) As Integer
public:
int Add(
    DisputeFilterCountType^ item
)
Parameters
item (DisputeFilterCountType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DisputeFilterCountType>[]()[][]) |
 | AddRange(DisputeFilterCountTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► AddRange(array<DisputeFilterCountType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DisputeFilterCountType[] items
)
Public Sub AddRange ( _
    items As DisputeFilterCountType() _
)
public:
void AddRange(
    array<DisputeFilterCountType^>^ items
)
Parameters
items (array< DisputeFilterCountType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► AddRange(DisputeFilterCountTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DisputeFilterCountTypeCollection items
)
Public Sub AddRange ( _
    items As DisputeFilterCountTypeCollection _
)
public:
void AddRange(
    DisputeFilterCountTypeCollection^ items
)
Parameters
items (DisputeFilterCountTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► Contains(DisputeFilterCountType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DisputeFilterCountType item
)
Public Function Contains ( _
    item As DisputeFilterCountType _
) As Boolean
public:
bool Contains(
    DisputeFilterCountType^ item
)
Parameters
item (DisputeFilterCountType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► CopyTo(array<DisputeFilterCountType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DisputeFilterCountType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DisputeFilterCountType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DisputeFilterCountType^>^ items,
    int index
)
Parameters
items (array< DisputeFilterCountType >[]()[][])
index (Int32)


DisputeFilterCountTypeCollection Constructor

DisputeFilterCountTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► DisputeFilterCountTypeCollection()()()()
Members
Icon | Member | Description
 | DisputeFilterCountTypeCollection()()()() |
 | DisputeFilterCountTypeCollection(array<DisputeFilterCountType>[]()[][]) |
 | DisputeFilterCountTypeCollection(DisputeFilterCountTypeCollection) |


DisputeFilterCountTypeCollection Constructor

DisputeFilterCountTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► DisputeFilterCountTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterCountTypeCollection()
Public Sub New
public:
DisputeFilterCountTypeCollection()


DisputeFilterCountTypeCollection Constructor (items)

DisputeFilterCountTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► DisputeFilterCountTypeCollection(array<DisputeFilterCountType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterCountTypeCollection(
    DisputeFilterCountType[] items
)
Public Sub New ( _
    items As DisputeFilterCountType() _
)
public:
DisputeFilterCountTypeCollection(
    array<DisputeFilterCountType^>^ items
)
Parameters
items (array< DisputeFilterCountType >[]()[][])


DisputeFilterCountTypeCollection Constructor (items)

DisputeFilterCountTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► DisputeFilterCountTypeCollection(DisputeFilterCountTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterCountTypeCollection(
    DisputeFilterCountTypeCollection items
)
Public Sub New ( _
    items As DisputeFilterCountTypeCollection _
)
public:
DisputeFilterCountTypeCollection(
    DisputeFilterCountTypeCollection^ items
)
Parameters
items (DisputeFilterCountTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► IndexOf(DisputeFilterCountType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DisputeFilterCountType item
)
Public Function IndexOf ( _
    item As DisputeFilterCountType _
) As Integer
public:
int IndexOf(
    DisputeFilterCountType^ item
)
Parameters
item (DisputeFilterCountType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► Insert(Int32, DisputeFilterCountType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DisputeFilterCountType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DisputeFilterCountType _
)
public:
void Insert(
    int index,
    DisputeFilterCountType^ item
)
Parameters
index (Int32)
item (DisputeFilterCountType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterCountType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DisputeFilterCountType
    Get
    Set
public:
property DisputeFilterCountType^ default[int index] {
    DisputeFilterCountType^ get (int index);
    void set (int index, DisputeFilterCountType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterCountType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DisputeFilterCountType
public:
DisputeFilterCountType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► Remove(DisputeFilterCountType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DisputeFilterCountType item
)
Public Sub Remove ( _
    item As DisputeFilterCountType _
)
public:
void Remove(
    DisputeFilterCountType^ item
)
Parameters
item (DisputeFilterCountType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterCountType[] ToArray()
Public Function ToArray As DisputeFilterCountType()
public:
array<DisputeFilterCountType^>^ ToArray()
Return Value


DisputeFilterTypeCodeType Enumeration

DisputeFilterTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeFilterTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeFilterTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeFilterTypeCodeType
Members
Member | Description
AllInvolvedDisputes |
DisputesAwaitingMyResponse |
DisputesAwaitingOtherPartyResponse |
AllInvolvedClosedDisputes |
EligibleForCredit |
UnpaidItemDisputes |
ItemNotReceivedDisputes |
CustomCode |
Remarks


DisputeMessageSourceCodeType Enumeration

DisputeMessageSourceCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageSourceCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeMessageSourceCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeMessageSourceCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeMessageSourceCodeType
Members
Member | Description
Buyer |
Seller |
eBay |
CustomCode |
Remarks


DisputeMessageType Class

DisputeMessageType Class
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DisputeMessageType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DisputeMessageType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DisputeMessageType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisputeMessageType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageCreationTime |
 | MessageCreationTimeSpecified |
 | MessageID |
 | MessageIDSpecified |
 | MessageSource |
 | MessageSourceSpecified |
 | MessageText |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DisputeMessageType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DisputeMessageType Constructor

DisputeMessageType Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageType ► DisputeMessageType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeMessageType()
Public Sub New
public:
DisputeMessageType()


MessageCreationTime Property

MessageCreationTime Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageType ► MessageCreationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime MessageCreationTime { get; set; }
Public Property MessageCreationTime As DateTime
    Get
    Set
public:
property DateTime MessageCreationTime {
    DateTime get ();
    void set (DateTime value);
}


MessageCreationTimeSpecified Property

MessageCreationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageType ► MessageCreationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageCreationTimeSpecified { get; set; }
Public Property MessageCreationTimeSpecified As Boolean
    Get
    Set
public:
property bool MessageCreationTimeSpecified {
    bool get ();
    void set (bool value);
}


MessageID Property

MessageID Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageType ► MessageID
Declaration Syntax
C# Visual Basic Visual C++
public int MessageID { get; set; }
Public Property MessageID As Integer
    Get
    Set
public:
property int MessageID {
    int get ();
    void set (int value);
}


MessageIDSpecified Property

MessageIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageType ► MessageIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageIDSpecified { get; set; }
Public Property MessageIDSpecified As Boolean
    Get
    Set
public:
property bool MessageIDSpecified {
    bool get ();
    void set (bool value);
}


MessageSource Property

MessageSource Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageType ► MessageSource
Declaration Syntax
C# Visual Basic Visual C++
public DisputeMessageSourceCodeType MessageSource { get; set; }
Public Property MessageSource As DisputeMessageSourceCodeType
    Get
    Set
public:
property DisputeMessageSourceCodeType MessageSource {
    DisputeMessageSourceCodeType get ();
    void set (DisputeMessageSourceCodeType value);
}


MessageSourceSpecified Property

MessageSourceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageType ► MessageSourceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageSourceSpecified { get; set; }
Public Property MessageSourceSpecified As Boolean
    Get
    Set
public:
property bool MessageSourceSpecified {
    bool get ();
    void set (bool value);
}


MessageText Property

MessageText Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageType ► MessageText
Declaration Syntax
C# Visual Basic Visual C++
public string MessageText { get; set; }
Public Property MessageText As String
    Get
    Set
public:
property String^ MessageText {
    String^ get ();
    void set (String^ value);
}


DisputeMessageTypeCollection Class

DisputeMessageTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DisputeMessageTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DisputeMessageTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DisputeMessageTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisputeMessageTypeCollection()()()() |
 | DisputeMessageTypeCollection(array<DisputeMessageType>[]()[][]) |
 | DisputeMessageTypeCollection(DisputeMessageTypeCollection) |
 | Add(DisputeMessageType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DisputeMessageType>[]()[][]) |
 | AddRange(DisputeMessageTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DisputeMessageType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DisputeMessageType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DisputeMessageType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DisputeMessageType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DisputeMessageType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DisputeMessageTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► Add(DisputeMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DisputeMessageType item
)
Public Function Add ( _
    item As DisputeMessageType _
) As Integer
public:
int Add(
    DisputeMessageType^ item
)
Parameters
item (DisputeMessageType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DisputeMessageType>[]()[][]) |
 | AddRange(DisputeMessageTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► AddRange(array<DisputeMessageType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DisputeMessageType[] items
)
Public Sub AddRange ( _
    items As DisputeMessageType() _
)
public:
void AddRange(
    array<DisputeMessageType^>^ items
)
Parameters
items (array< DisputeMessageType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► AddRange(DisputeMessageTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DisputeMessageTypeCollection items
)
Public Sub AddRange ( _
    items As DisputeMessageTypeCollection _
)
public:
void AddRange(
    DisputeMessageTypeCollection^ items
)
Parameters
items (DisputeMessageTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► Contains(DisputeMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DisputeMessageType item
)
Public Function Contains ( _
    item As DisputeMessageType _
) As Boolean
public:
bool Contains(
    DisputeMessageType^ item
)
Parameters
item (DisputeMessageType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► CopyTo(array<DisputeMessageType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DisputeMessageType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DisputeMessageType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DisputeMessageType^>^ items,
    int index
)
Parameters
items (array< DisputeMessageType >[]()[][])
index (Int32)


DisputeMessageTypeCollection Constructor

DisputeMessageTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► DisputeMessageTypeCollection()()()()
Members
Icon | Member | Description
 | DisputeMessageTypeCollection()()()() |
 | DisputeMessageTypeCollection(array<DisputeMessageType>[]()[][]) |
 | DisputeMessageTypeCollection(DisputeMessageTypeCollection) |


DisputeMessageTypeCollection Constructor

DisputeMessageTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► DisputeMessageTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeMessageTypeCollection()
Public Sub New
public:
DisputeMessageTypeCollection()


DisputeMessageTypeCollection Constructor (items)

DisputeMessageTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► DisputeMessageTypeCollection(array<DisputeMessageType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DisputeMessageTypeCollection(
    DisputeMessageType[] items
)
Public Sub New ( _
    items As DisputeMessageType() _
)
public:
DisputeMessageTypeCollection(
    array<DisputeMessageType^>^ items
)
Parameters
items (array< DisputeMessageType >[]()[][])


DisputeMessageTypeCollection Constructor (items)

DisputeMessageTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► DisputeMessageTypeCollection(DisputeMessageTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DisputeMessageTypeCollection(
    DisputeMessageTypeCollection items
)
Public Sub New ( _
    items As DisputeMessageTypeCollection _
)
public:
DisputeMessageTypeCollection(
    DisputeMessageTypeCollection^ items
)
Parameters
items (DisputeMessageTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► IndexOf(DisputeMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DisputeMessageType item
)
Public Function IndexOf ( _
    item As DisputeMessageType _
) As Integer
public:
int IndexOf(
    DisputeMessageType^ item
)
Parameters
item (DisputeMessageType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► Insert(Int32, DisputeMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DisputeMessageType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DisputeMessageType _
)
public:
void Insert(
    int index,
    DisputeMessageType^ item
)
Parameters
index (Int32)
item (DisputeMessageType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DisputeMessageType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DisputeMessageType
    Get
    Set
public:
property DisputeMessageType^ default[int index] {
    DisputeMessageType^ get (int index);
    void set (int index, DisputeMessageType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DisputeMessageType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DisputeMessageType
public:
DisputeMessageType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► Remove(DisputeMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DisputeMessageType item
)
Public Sub Remove ( _
    item As DisputeMessageType _
)
public:
void Remove(
    DisputeMessageType^ item
)
Parameters
item (DisputeMessageType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeMessageType[] ToArray()
Public Function ToArray As DisputeMessageType()
public:
array<DisputeMessageType^>^ ToArray()
Return Value


DisputeReasonCodeType Enumeration

DisputeReasonCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeReasonCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeReasonCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeReasonCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeReasonCodeType
Members
Member | Description
BuyerHasNotPaid |
TransactionMutuallyCanceled |
ItemNotReceived |
SignificantlyNotAsDescribed |
NoRefund |
ReturnPolicyUnpaidItem |
CustomCode |
Remarks


DisputeRecordTypeCodeType Enumeration

DisputeRecordTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeRecordTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeRecordTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeRecordTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeRecordTypeCodeType
Members
Member | Description
UnpaidItem |
ItemNotReceived |
HalfDispute |
CustomCode |
Remarks


DisputeResolutionReasonCodeType Enumeration

DisputeResolutionReasonCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionReasonCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeResolutionReasonCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeResolutionReasonCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeResolutionReasonCodeType
Members
Member | Description
Unresolved |
ProofOfPayment |
ComputerTechnicalProblem |
NoContact |
FamilyEmergency |
ProofGivenInFeedback |
FirstInfraction |
CameToAgreement |
ItemReturned |
BuyerPaidAuctionFees |
SellerReceivedPayment |
OtherResolution |
ClaimPaid |
CustomCode |
Remarks


DisputeResolutionRecordTypeCodeType Enumeration

DisputeResolutionRecordTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionRecordTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeResolutionRecordTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeResolutionRecordTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeResolutionRecordTypeCodeType
Members
Member | Description
StrikeBuyer |
SuspendBuyer |
RestrictBuyer |
FVFCredit |
InsertionFeeCredit |
AppealBuyerStrike |
UnsuspendBuyer |
UnrestrictBuyer |
ReverseFVFCredit |
ReverseInsertionFeeCredit |
GenerateCSTicketForSuspend |
FVFCreditNotGranted |
ItemNotReceivedClaimFiled |
UnpaidItemRelisted |
UnpaidItemRevised |
FVFOnShippingCredit |
FVFOnShippingCreditNotGranted |
ReverseFVFOnShippingCredit |
FeatureFeeCredit |
FeatureFeeNotCredit |
ReverseFeatureFeeCredit |
CustomCode |
Remarks


DisputeResolutionType Class

DisputeResolutionType Class
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DisputeResolutionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DisputeResolutionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DisputeResolutionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisputeResolutionType()()()() |
 | Any |
 | DisputeResolutionReason |
 | DisputeResolutionReasonSpecified |
 | DisputeResolutionRecordType |
 | DisputeResolutionRecordTypeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ResolutionTime |
 | ResolutionTimeSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DisputeResolutionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DisputeResolutionReason Property

DisputeResolutionReason Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionType ► DisputeResolutionReason
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionReasonCodeType DisputeResolutionReason { get; set; }
Public Property DisputeResolutionReason As DisputeResolutionReasonCodeType
    Get
    Set
public:
property DisputeResolutionReasonCodeType DisputeResolutionReason {
    DisputeResolutionReasonCodeType get ();
    void set (DisputeResolutionReasonCodeType value);
}


DisputeResolutionReasonSpecified Property

DisputeResolutionReasonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionType ► DisputeResolutionReasonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeResolutionReasonSpecified { get; set; }
Public Property DisputeResolutionReasonSpecified As Boolean
    Get
    Set
public:
property bool DisputeResolutionReasonSpecified {
    bool get ();
    void set (bool value);
}


DisputeResolutionRecordType Property

DisputeResolutionRecordType Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionType ► DisputeResolutionRecordType
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionRecordTypeCodeType DisputeResolutionRecordType { get; set; }
Public Property DisputeResolutionRecordType As DisputeResolutionRecordTypeCodeType
    Get
    Set
public:
property DisputeResolutionRecordTypeCodeType DisputeResolutionRecordType {
    DisputeResolutionRecordTypeCodeType get ();
    void set (DisputeResolutionRecordTypeCodeType value);
}


DisputeResolutionRecordTypeSpecified Property

DisputeResolutionRecordTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionType ► DisputeResolutionRecordTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeResolutionRecordTypeSpecified { get; set; }
Public Property DisputeResolutionRecordTypeSpecified As Boolean
    Get
    Set
public:
property bool DisputeResolutionRecordTypeSpecified {
    bool get ();
    void set (bool value);
}


DisputeResolutionType Constructor

DisputeResolutionType Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionType ► DisputeResolutionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionType()
Public Sub New
public:
DisputeResolutionType()


ResolutionTime Property

ResolutionTime Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionType ► ResolutionTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ResolutionTime { get; set; }
Public Property ResolutionTime As DateTime
    Get
    Set
public:
property DateTime ResolutionTime {
    DateTime get ();
    void set (DateTime value);
}


ResolutionTimeSpecified Property

ResolutionTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionType ► ResolutionTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ResolutionTimeSpecified { get; set; }
Public Property ResolutionTimeSpecified As Boolean
    Get
    Set
public:
property bool ResolutionTimeSpecified {
    bool get ();
    void set (bool value);
}


DisputeResolutionTypeCollection Class

DisputeResolutionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DisputeResolutionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DisputeResolutionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DisputeResolutionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisputeResolutionTypeCollection()()()() |
 | DisputeResolutionTypeCollection(array<DisputeResolutionType>[]()[][]) |
 | DisputeResolutionTypeCollection(DisputeResolutionTypeCollection) |
 | Add(DisputeResolutionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DisputeResolutionType>[]()[][]) |
 | AddRange(DisputeResolutionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DisputeResolutionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DisputeResolutionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DisputeResolutionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DisputeResolutionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DisputeResolutionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DisputeResolutionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► Add(DisputeResolutionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DisputeResolutionType item
)
Public Function Add ( _
    item As DisputeResolutionType _
) As Integer
public:
int Add(
    DisputeResolutionType^ item
)
Parameters
item (DisputeResolutionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DisputeResolutionType>[]()[][]) |
 | AddRange(DisputeResolutionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► AddRange(array<DisputeResolutionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DisputeResolutionType[] items
)
Public Sub AddRange ( _
    items As DisputeResolutionType() _
)
public:
void AddRange(
    array<DisputeResolutionType^>^ items
)
Parameters
items (array< DisputeResolutionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► AddRange(DisputeResolutionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DisputeResolutionTypeCollection items
)
Public Sub AddRange ( _
    items As DisputeResolutionTypeCollection _
)
public:
void AddRange(
    DisputeResolutionTypeCollection^ items
)
Parameters
items (DisputeResolutionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► Contains(DisputeResolutionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DisputeResolutionType item
)
Public Function Contains ( _
    item As DisputeResolutionType _
) As Boolean
public:
bool Contains(
    DisputeResolutionType^ item
)
Parameters
item (DisputeResolutionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► CopyTo(array<DisputeResolutionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DisputeResolutionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DisputeResolutionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DisputeResolutionType^>^ items,
    int index
)
Parameters
items (array< DisputeResolutionType >[]()[][])
index (Int32)


DisputeResolutionTypeCollection Constructor

DisputeResolutionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► DisputeResolutionTypeCollection()()()()
Members
Icon | Member | Description
 | DisputeResolutionTypeCollection()()()() |
 | DisputeResolutionTypeCollection(array<DisputeResolutionType>[]()[][]) |
 | DisputeResolutionTypeCollection(DisputeResolutionTypeCollection) |


DisputeResolutionTypeCollection Constructor

DisputeResolutionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► DisputeResolutionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionTypeCollection()
Public Sub New
public:
DisputeResolutionTypeCollection()


DisputeResolutionTypeCollection Constructor (items)

DisputeResolutionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► DisputeResolutionTypeCollection(array<DisputeResolutionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionTypeCollection(
    DisputeResolutionType[] items
)
Public Sub New ( _
    items As DisputeResolutionType() _
)
public:
DisputeResolutionTypeCollection(
    array<DisputeResolutionType^>^ items
)
Parameters
items (array< DisputeResolutionType >[]()[][])


DisputeResolutionTypeCollection Constructor (items)

DisputeResolutionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► DisputeResolutionTypeCollection(DisputeResolutionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionTypeCollection(
    DisputeResolutionTypeCollection items
)
Public Sub New ( _
    items As DisputeResolutionTypeCollection _
)
public:
DisputeResolutionTypeCollection(
    DisputeResolutionTypeCollection^ items
)
Parameters
items (DisputeResolutionTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► IndexOf(DisputeResolutionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DisputeResolutionType item
)
Public Function IndexOf ( _
    item As DisputeResolutionType _
) As Integer
public:
int IndexOf(
    DisputeResolutionType^ item
)
Parameters
item (DisputeResolutionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► Insert(Int32, DisputeResolutionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DisputeResolutionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DisputeResolutionType _
)
public:
void Insert(
    int index,
    DisputeResolutionType^ item
)
Parameters
index (Int32)
item (DisputeResolutionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DisputeResolutionType
    Get
    Set
public:
property DisputeResolutionType^ default[int index] {
    DisputeResolutionType^ get (int index);
    void set (int index, DisputeResolutionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DisputeResolutionType
public:
DisputeResolutionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► Remove(DisputeResolutionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DisputeResolutionType item
)
Public Sub Remove ( _
    item As DisputeResolutionType _
)
public:
void Remove(
    DisputeResolutionType^ item
)
Parameters
item (DisputeResolutionType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionType[] ToArray()
Public Function ToArray As DisputeResolutionType()
public:
array<DisputeResolutionType^>^ ToArray()
Return Value


DisputeSortTypeCodeType Enumeration

DisputeSortTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeSortTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeSortTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeSortTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeSortTypeCodeType
Members
Member | Description
None |
DisputeCreatedTimeAscending |
DisputeCreatedTimeDescending |
DisputeStatusAscending |
DisputeStatusDescending |
DisputeCreditEligibilityAscending |
DisputeCreditEligibilityDescending |
CustomCode |
Remarks


DisputeStateCodeType Enumeration

DisputeStateCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeStateCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeStateCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeStateCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeStateCodeType
Members
Member | Description
Locked |
Closed |
BuyerFirstResponsePayOption |
BuyerFirstResponseNoPayOption |
BuyerFirstResponsePayOptionLateResponse |
BuyerFirstResponseNoPayOptionLateResponse |
MutualCommunicationPayOption |
MutualCommunicationNoPayOption |
PendingResolve |
MutualWithdrawalAgreement |
MutualWithdrawalAgreementLate |
NotReceivedNoSellerResponse |
NotAsDescribedNoSellerResponse |
NotReceivedMutualCommunication |
NotAsDescribedMutualCommunication |
MutualAgreementOrBuyerReturningItem |
ClaimOpened |
NoDocumentation |
ClaimClosed |
ClaimDenied |
ClaimPending |
ClaimPaymentPending |
ClaimPaid |
ClaimResolved |
ClaimSubmitted |
UnpaidItemOpen |
UPIAssistanceDisabledByeBay |
UPIAssistanceDisabledBySeller |
CustomCode |
Remarks


DisputeStatusCodeType Enumeration

DisputeStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► DisputeStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum DisputeStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration DisputeStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class DisputeStatusCodeType
Members
Member | Description
Closed |
WaitingForSellerResponse |
WaitingForBuyerResponse |
ClosedFVFCreditStrike |
ClosedNoFVFCreditStrike |
ClosedFVFCreditNoStrike |
ClosedNoFVFCreditNoStrike |
StrikeAppealedAfterClosing |
FVFCreditReversedAfterClosing |
StrikeAppealedAndFVFCreditReversed |
ClaimOpened |
NoDocumentation |
ClaimClosed |
ClaimDenied |
ClaimInProcess |
ClaimApproved |
ClaimPaid |
ClaimResolved |
ClaimSubmitted |
UnpaidItemOpened |
CustomCode |
Remarks


DisputeType Class

DisputeType Class
Namespaces ► eBay.Service.Core.Soap ► DisputeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DisputeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DisputeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DisputeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisputeType()()()() |
 | Any |
 | BuyerUserID |
 | DisputeCreatedTime |
 | DisputeCreatedTimeSpecified |
 | DisputeCreditEligibility |
 | DisputeCreditEligibilitySpecified |
 | DisputeExplanation |
 | DisputeExplanationSpecified |
 | DisputeID |
 | DisputeMessage |
 | DisputeModifiedTime |
 | DisputeModifiedTimeSpecified |
 | DisputeReason |
 | DisputeReasonSpecified |
 | DisputeRecordType |
 | DisputeRecordTypeSpecified |
 | DisputeResolution |
 | DisputeState |
 | DisputeStateSpecified |
 | DisputeStatus |
 | DisputeStatusSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Escalation |
 | EscalationSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderLineItemID |
 | OtherPartyName |
 | OtherPartyRole |
 | OtherPartyRoleSpecified |
 | PurchaseProtection |
 | PurchaseProtectionSpecified |
 | SellerUserID |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | UserRole |
 | UserRoleSpecified |
Remarks
Inheritance Hierarchy
Object
DisputeType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyerUserID Property

BuyerUserID Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► BuyerUserID
Declaration Syntax
C# Visual Basic Visual C++
public string BuyerUserID { get; set; }
Public Property BuyerUserID As String
    Get
    Set
public:
property String^ BuyerUserID {
    String^ get ();
    void set (String^ value);
}


DisputeCreatedTime Property

DisputeCreatedTime Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeCreatedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DisputeCreatedTime { get; set; }
Public Property DisputeCreatedTime As DateTime
    Get
    Set
public:
property DateTime DisputeCreatedTime {
    DateTime get ();
    void set (DateTime value);
}


DisputeCreatedTimeSpecified Property

DisputeCreatedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeCreatedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeCreatedTimeSpecified { get; set; }
Public Property DisputeCreatedTimeSpecified As Boolean
    Get
    Set
public:
property bool DisputeCreatedTimeSpecified {
    bool get ();
    void set (bool value);
}


DisputeCreditEligibility Property

DisputeCreditEligibility Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeCreditEligibility
Declaration Syntax
C# Visual Basic Visual C++
public DisputeCreditEligibilityCodeType DisputeCreditEligibility { get; set; }
Public Property DisputeCreditEligibility As DisputeCreditEligibilityCodeType
    Get
    Set
public:
property DisputeCreditEligibilityCodeType DisputeCreditEligibility {
    DisputeCreditEligibilityCodeType get ();
    void set (DisputeCreditEligibilityCodeType value);
}


DisputeCreditEligibilitySpecified Property

DisputeCreditEligibilitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeCreditEligibilitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeCreditEligibilitySpecified { get; set; }
Public Property DisputeCreditEligibilitySpecified As Boolean
    Get
    Set
public:
property bool DisputeCreditEligibilitySpecified {
    bool get ();
    void set (bool value);
}


DisputeExplanation Property

DisputeExplanation Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeExplanation
Declaration Syntax
C# Visual Basic Visual C++
public DisputeExplanationCodeType DisputeExplanation { get; set; }
Public Property DisputeExplanation As DisputeExplanationCodeType
    Get
    Set
public:
property DisputeExplanationCodeType DisputeExplanation {
    DisputeExplanationCodeType get ();
    void set (DisputeExplanationCodeType value);
}


DisputeExplanationSpecified Property

DisputeExplanationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeExplanationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeExplanationSpecified { get; set; }
Public Property DisputeExplanationSpecified As Boolean
    Get
    Set
public:
property bool DisputeExplanationSpecified {
    bool get ();
    void set (bool value);
}


DisputeID Property

DisputeID Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeID
Declaration Syntax
C# Visual Basic Visual C++
public string DisputeID { get; set; }
Public Property DisputeID As String
    Get
    Set
public:
property String^ DisputeID {
    String^ get ();
    void set (String^ value);
}


DisputeMessage Property

DisputeMessage Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeMessage
Declaration Syntax
C# Visual Basic Visual C++
public DisputeMessageTypeCollection DisputeMessage { get; set; }
Public Property DisputeMessage As DisputeMessageTypeCollection
    Get
    Set
public:
property DisputeMessageTypeCollection^ DisputeMessage {
    DisputeMessageTypeCollection^ get ();
    void set (DisputeMessageTypeCollection^ value);
}


DisputeModifiedTime Property

DisputeModifiedTime Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeModifiedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DisputeModifiedTime { get; set; }
Public Property DisputeModifiedTime As DateTime
    Get
    Set
public:
property DateTime DisputeModifiedTime {
    DateTime get ();
    void set (DateTime value);
}


DisputeModifiedTimeSpecified Property

DisputeModifiedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeModifiedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeModifiedTimeSpecified { get; set; }
Public Property DisputeModifiedTimeSpecified As Boolean
    Get
    Set
public:
property bool DisputeModifiedTimeSpecified {
    bool get ();
    void set (bool value);
}


DisputeReason Property

DisputeReason Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeReason
Declaration Syntax
C# Visual Basic Visual C++
public DisputeReasonCodeType DisputeReason { get; set; }
Public Property DisputeReason As DisputeReasonCodeType
    Get
    Set
public:
property DisputeReasonCodeType DisputeReason {
    DisputeReasonCodeType get ();
    void set (DisputeReasonCodeType value);
}


DisputeReasonSpecified Property

DisputeReasonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeReasonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeReasonSpecified { get; set; }
Public Property DisputeReasonSpecified As Boolean
    Get
    Set
public:
property bool DisputeReasonSpecified {
    bool get ();
    void set (bool value);
}


DisputeRecordType Property

DisputeRecordType Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeRecordType
Declaration Syntax
C# Visual Basic Visual C++
public DisputeRecordTypeCodeType DisputeRecordType { get; set; }
Public Property DisputeRecordType As DisputeRecordTypeCodeType
    Get
    Set
public:
property DisputeRecordTypeCodeType DisputeRecordType {
    DisputeRecordTypeCodeType get ();
    void set (DisputeRecordTypeCodeType value);
}


DisputeRecordTypeSpecified Property

DisputeRecordTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeRecordTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeRecordTypeSpecified { get; set; }
Public Property DisputeRecordTypeSpecified As Boolean
    Get
    Set
public:
property bool DisputeRecordTypeSpecified {
    bool get ();
    void set (bool value);
}


DisputeResolution Property

DisputeResolution Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeResolution
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionTypeCollection DisputeResolution { get; set; }
Public Property DisputeResolution As DisputeResolutionTypeCollection
    Get
    Set
public:
property DisputeResolutionTypeCollection^ DisputeResolution {
    DisputeResolutionTypeCollection^ get ();
    void set (DisputeResolutionTypeCollection^ value);
}


DisputeState Property

DisputeState Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeState
Declaration Syntax
C# Visual Basic Visual C++
public DisputeStateCodeType DisputeState { get; set; }
Public Property DisputeState As DisputeStateCodeType
    Get
    Set
public:
property DisputeStateCodeType DisputeState {
    DisputeStateCodeType get ();
    void set (DisputeStateCodeType value);
}


DisputeStateSpecified Property

DisputeStateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeStateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeStateSpecified { get; set; }
Public Property DisputeStateSpecified As Boolean
    Get
    Set
public:
property bool DisputeStateSpecified {
    bool get ();
    void set (bool value);
}


DisputeStatus Property

DisputeStatus Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeStatus
Declaration Syntax
C# Visual Basic Visual C++
public DisputeStatusCodeType DisputeStatus { get; set; }
Public Property DisputeStatus As DisputeStatusCodeType
    Get
    Set
public:
property DisputeStatusCodeType DisputeStatus {
    DisputeStatusCodeType get ();
    void set (DisputeStatusCodeType value);
}


DisputeStatusSpecified Property

DisputeStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeStatusSpecified { get; set; }
Public Property DisputeStatusSpecified As Boolean
    Get
    Set
public:
property bool DisputeStatusSpecified {
    bool get ();
    void set (bool value);
}


DisputeType Constructor

DisputeType Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► DisputeType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeType()
Public Sub New
public:
DisputeType()


Escalation Property

Escalation Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► Escalation
Declaration Syntax
C# Visual Basic Visual C++
public bool Escalation { get; set; }
Public Property Escalation As Boolean
    Get
    Set
public:
property bool Escalation {
    bool get ();
    void set (bool value);
}


EscalationSpecified Property

EscalationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► EscalationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EscalationSpecified { get; set; }
Public Property EscalationSpecified As Boolean
    Get
    Set
public:
property bool EscalationSpecified {
    bool get ();
    void set (bool value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


OtherPartyName Property

OtherPartyName Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► OtherPartyName
Declaration Syntax
C# Visual Basic Visual C++
public string OtherPartyName { get; set; }
Public Property OtherPartyName As String
    Get
    Set
public:
property String^ OtherPartyName {
    String^ get ();
    void set (String^ value);
}


OtherPartyRole Property

OtherPartyRole Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► OtherPartyRole
Declaration Syntax
C# Visual Basic Visual C++
public TradingRoleCodeType OtherPartyRole { get; set; }
Public Property OtherPartyRole As TradingRoleCodeType
    Get
    Set
public:
property TradingRoleCodeType OtherPartyRole {
    TradingRoleCodeType get ();
    void set (TradingRoleCodeType value);
}


OtherPartyRoleSpecified Property

OtherPartyRoleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► OtherPartyRoleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OtherPartyRoleSpecified { get; set; }
Public Property OtherPartyRoleSpecified As Boolean
    Get
    Set
public:
property bool OtherPartyRoleSpecified {
    bool get ();
    void set (bool value);
}


PurchaseProtection Property

PurchaseProtection Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► PurchaseProtection
Declaration Syntax
C# Visual Basic Visual C++
public bool PurchaseProtection { get; set; }
Public Property PurchaseProtection As Boolean
    Get
    Set
public:
property bool PurchaseProtection {
    bool get ();
    void set (bool value);
}


PurchaseProtectionSpecified Property

PurchaseProtectionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► PurchaseProtectionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PurchaseProtectionSpecified { get; set; }
Public Property PurchaseProtectionSpecified As Boolean
    Get
    Set
public:
property bool PurchaseProtectionSpecified {
    bool get ();
    void set (bool value);
}


SellerUserID Property

SellerUserID Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► SellerUserID
Declaration Syntax
C# Visual Basic Visual C++
public string SellerUserID { get; set; }
Public Property SellerUserID As String
    Get
    Set
public:
property String^ SellerUserID {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


UserRole Property

UserRole Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► UserRole
Declaration Syntax
C# Visual Basic Visual C++
public TradingRoleCodeType UserRole { get; set; }
Public Property UserRole As TradingRoleCodeType
    Get
    Set
public:
property TradingRoleCodeType UserRole {
    TradingRoleCodeType get ();
    void set (TradingRoleCodeType value);
}


UserRoleSpecified Property

UserRoleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DisputeType ► UserRoleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UserRoleSpecified { get; set; }
Public Property UserRoleSpecified As Boolean
    Get
    Set
public:
property bool UserRoleSpecified {
    bool get ();
    void set (bool value);
}


DisputeTypeCollection Class

DisputeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class DisputeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class DisputeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class DisputeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DisputeTypeCollection()()()() |
 | DisputeTypeCollection(array<DisputeType>[]()[][]) |
 | DisputeTypeCollection(DisputeTypeCollection) |
 | Add(DisputeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<DisputeType>[]()[][]) |
 | AddRange(DisputeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(DisputeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<DisputeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(DisputeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, DisputeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(DisputeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | DisputeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► Add(DisputeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    DisputeType item
)
Public Function Add ( _
    item As DisputeType _
) As Integer
public:
int Add(
    DisputeType^ item
)
Parameters
item (DisputeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<DisputeType>[]()[][]) |
 | AddRange(DisputeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► AddRange(array<DisputeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DisputeType[] items
)
Public Sub AddRange ( _
    items As DisputeType() _
)
public:
void AddRange(
    array<DisputeType^>^ items
)
Parameters
items (array< DisputeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► AddRange(DisputeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    DisputeTypeCollection items
)
Public Sub AddRange ( _
    items As DisputeTypeCollection _
)
public:
void AddRange(
    DisputeTypeCollection^ items
)
Parameters
items (DisputeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► Contains(DisputeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    DisputeType item
)
Public Function Contains ( _
    item As DisputeType _
) As Boolean
public:
bool Contains(
    DisputeType^ item
)
Parameters
item (DisputeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► CopyTo(array<DisputeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    DisputeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As DisputeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<DisputeType^>^ items,
    int index
)
Parameters
items (array< DisputeType >[]()[][])
index (Int32)


DisputeTypeCollection Constructor

DisputeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► DisputeTypeCollection()()()()
Members
Icon | Member | Description
 | DisputeTypeCollection()()()() |
 | DisputeTypeCollection(array<DisputeType>[]()[][]) |
 | DisputeTypeCollection(DisputeTypeCollection) |


DisputeTypeCollection Constructor

DisputeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► DisputeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeTypeCollection()
Public Sub New
public:
DisputeTypeCollection()


DisputeTypeCollection Constructor (items)

DisputeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► DisputeTypeCollection(array<DisputeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public DisputeTypeCollection(
    DisputeType[] items
)
Public Sub New ( _
    items As DisputeType() _
)
public:
DisputeTypeCollection(
    array<DisputeType^>^ items
)
Parameters
items (array< DisputeType >[]()[][])


DisputeTypeCollection Constructor (items)

DisputeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► DisputeTypeCollection(DisputeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public DisputeTypeCollection(
    DisputeTypeCollection items
)
Public Sub New ( _
    items As DisputeTypeCollection _
)
public:
DisputeTypeCollection(
    DisputeTypeCollection^ items
)
Parameters
items (DisputeTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► IndexOf(DisputeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    DisputeType item
)
Public Function IndexOf ( _
    item As DisputeType _
) As Integer
public:
int IndexOf(
    DisputeType^ item
)
Parameters
item (DisputeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► Insert(Int32, DisputeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    DisputeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As DisputeType _
)
public:
void Insert(
    int index,
    DisputeType^ item
)
Parameters
index (Int32)
item (DisputeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public DisputeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As DisputeType
    Get
    Set
public:
property DisputeType^ default[int index] {
    DisputeType^ get (int index);
    void set (int index, DisputeType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DisputeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As DisputeType
public:
DisputeType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► Remove(DisputeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    DisputeType item
)
Public Sub Remove ( _
    item As DisputeType _
)
public:
void Remove(
    DisputeType^ item
)
Parameters
item (DisputeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DisputeType[] ToArray()
Public Function ToArray As DisputeType()
public:
array<DisputeType^>^ ToArray()
Return Value


DistanceType Class

DistanceType Class
Namespaces ► eBay.Service.Core.Soap ► DistanceType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DistanceType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DistanceType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DistanceType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DistanceType()()()() |
 | Any |
 | DistanceMeasurement |
 | DistanceUnit |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DistanceType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DistanceType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DistanceMeasurement Property

DistanceMeasurement Property
Namespaces ► eBay.Service.Core.Soap ► DistanceType ► DistanceMeasurement
Declaration Syntax
C# Visual Basic Visual C++
public int DistanceMeasurement { get; set; }
Public Property DistanceMeasurement As Integer
    Get
    Set
public:
property int DistanceMeasurement {
    int get ();
    void set (int value);
}


DistanceType Constructor

DistanceType Constructor
Namespaces ► eBay.Service.Core.Soap ► DistanceType ► DistanceType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DistanceType()
Public Sub New
public:
DistanceType()


DistanceUnit Property

DistanceUnit Property
Namespaces ► eBay.Service.Core.Soap ► DistanceType ► DistanceUnit
Declaration Syntax
C# Visual Basic Visual C++
public string DistanceUnit { get; set; }
Public Property DistanceUnit As String
    Get
    Set
public:
property String^ DistanceUnit {
    String^ get ();
    void set (String^ value);
}


DuplicateInvocationDetailsType Class

DuplicateInvocationDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► DuplicateInvocationDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DuplicateInvocationDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DuplicateInvocationDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DuplicateInvocationDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DuplicateInvocationDetailsType()()()() |
 | Any |
 | DuplicateInvocationID |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationTrackingID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DuplicateInvocationDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DuplicateInvocationDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DuplicateInvocationDetailsType Constructor

DuplicateInvocationDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► DuplicateInvocationDetailsType ► DuplicateInvocationDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DuplicateInvocationDetailsType()
Public Sub New
public:
DuplicateInvocationDetailsType()


DuplicateInvocationID Property

DuplicateInvocationID Property
Namespaces ► eBay.Service.Core.Soap ► DuplicateInvocationDetailsType ► DuplicateInvocationID
Declaration Syntax
C# Visual Basic Visual C++
public string DuplicateInvocationID { get; set; }
Public Property DuplicateInvocationID As String
    Get
    Set
public:
property String^ DuplicateInvocationID {
    String^ get ();
    void set (String^ value);
}


InvocationTrackingID Property

InvocationTrackingID Property
Namespaces ► eBay.Service.Core.Soap ► DuplicateInvocationDetailsType ► InvocationTrackingID
Declaration Syntax
C# Visual Basic Visual C++
public string InvocationTrackingID { get; set; }
Public Property InvocationTrackingID As String
    Get
    Set
public:
property String^ InvocationTrackingID {
    String^ get ();
    void set (String^ value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► DuplicateInvocationDetailsType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public InvocationStatusType Status { get; set; }
Public Property Status As InvocationStatusType
    Get
    Set
public:
property InvocationStatusType Status {
    InvocationStatusType get ();
    void set (InvocationStatusType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► DuplicateInvocationDetailsType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


DutchBINEnabledDefinitionType Class

DutchBINEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► DutchBINEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class DutchBINEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class DutchBINEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class DutchBINEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DutchBINEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
DutchBINEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► DutchBINEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DutchBINEnabledDefinitionType Constructor

DutchBINEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► DutchBINEnabledDefinitionType ► DutchBINEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DutchBINEnabledDefinitionType()
Public Sub New
public:
DutchBINEnabledDefinitionType()


EANEnabledDefinitionType Class

EANEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► EANEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EANEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EANEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EANEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EANEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
EANEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► EANEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EANEnabledDefinitionType Constructor

EANEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► EANEnabledDefinitionType ► EANEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EANEnabledDefinitionType()
Public Sub New
public:
EANEnabledDefinitionType()


EANIdentifierEnabledDefinitionType Class

EANIdentifierEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► EANIdentifierEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EANIdentifierEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EANIdentifierEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EANIdentifierEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EANIdentifierEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
EANIdentifierEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► EANIdentifierEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EANIdentifierEnabledDefinitionType Constructor

EANIdentifierEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► EANIdentifierEnabledDefinitionType ► EANIdentifierEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EANIdentifierEnabledDefinitionType()
Public Sub New
public:
EANIdentifierEnabledDefinitionType()


eBayAPIInterfaceService Class

eBayAPIInterfaceService Class
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService
Declaration Syntax
C# Visual Basic Visual C++
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
[WebServiceBindingAttribute(Name = "eBayAPISoapBinding", Namespace = "urn:ebay:apis:eBLBaseComponents")]
public class eBayAPIInterfaceService : SoapHttpClientProtocolEx
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
<WebServiceBindingAttribute(Name := "eBayAPISoapBinding", Namespace := "urn:ebay:apis:eBLBaseComponents")> _
Public Class eBayAPIInterfaceService _
    Inherits SoapHttpClientProtocolEx
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
[WebServiceBindingAttribute(Name = L"eBayAPISoapBinding", Namespace = L"urn:ebay:apis:eBLBaseComponents")]
public ref class eBayAPIInterfaceService : public SoapHttpClientProtocolEx
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayAPIInterfaceService()()()() |
 | Abort()()()() | (Inherited from WebClientProtocol.)
 | AddDispute(AddDisputeRequestType) |
 | AddDisputeResponse(AddDisputeResponseRequestType) |
 | AddFixedPriceItem(AddFixedPriceItemRequestType) |
 | AddItem(AddItemRequestType) |
 | AddItemFromSellingManagerTemplate(AddItemFromSellingManagerTemplateRequestType) |
 | AddItems(AddItemsRequestType) |
 | AddMemberMessageAAQToPartner(AddMemberMessageAAQToPartnerRequestType) |
 | AddMemberMessageRTQ(AddMemberMessageRTQRequestType) |
 | AddMemberMessagesAAQToBidder(AddMemberMessagesAAQToBidderRequestType) |
 | AddOrder(AddOrderRequestType) |
 | AddSecondChanceItem(AddSecondChanceItemRequestType) |
 | AddSellingManagerInventoryFolder(AddSellingManagerInventoryFolderRequestType) |
 | AddSellingManagerProduct(AddSellingManagerProductRequestType) |
 | AddSellingManagerTemplate(AddSellingManagerTemplateRequestType) |
 | AddToItemDescription(AddToItemDescriptionRequestType) |
 | AddToWatchList(AddToWatchListRequestType) |
 | AddTransactionConfirmationItem(AddTransactionConfirmationItemRequestType) |
 | AllowAutoRedirect | (Inherited from HttpWebClientProtocol.)
 | BeginAddDispute(AddDisputeRequestType, AsyncCallback, Object) |
 | BeginAddDisputeResponse(AddDisputeResponseRequestType, AsyncCallback, Object) |
 | BeginAddFixedPriceItem(AddFixedPriceItemRequestType, AsyncCallback, Object) |
 | BeginAddItem(AddItemRequestType, AsyncCallback, Object) |
 | BeginAddItemFromSellingManagerTemplate(AddItemFromSellingManagerTemplateRequestType, AsyncCallback, Object) |
 | BeginAddItems(AddItemsRequestType, AsyncCallback, Object) |
 | BeginAddMemberMessageAAQToPartner(AddMemberMessageAAQToPartnerRequestType, AsyncCallback, Object) |
 | BeginAddMemberMessageRTQ(AddMemberMessageRTQRequestType, AsyncCallback, Object) |
 | BeginAddMemberMessagesAAQToBidder(AddMemberMessagesAAQToBidderRequestType, AsyncCallback, Object) |
 | BeginAddOrder(AddOrderRequestType, AsyncCallback, Object) |
 | BeginAddSecondChanceItem(AddSecondChanceItemRequestType, AsyncCallback, Object) |
 | BeginAddSellingManagerInventoryFolder(AddSellingManagerInventoryFolderRequestType, AsyncCallback, Object) |
 | BeginAddSellingManagerProduct(AddSellingManagerProductRequestType, AsyncCallback, Object) |
 | BeginAddSellingManagerTemplate(AddSellingManagerTemplateRequestType, AsyncCallback, Object) |
 | BeginAddToItemDescription(AddToItemDescriptionRequestType, AsyncCallback, Object) |
 | BeginAddToWatchList(AddToWatchListRequestType, AsyncCallback, Object) |
 | BeginAddTransactionConfirmationItem(AddTransactionConfirmationItemRequestType, AsyncCallback, Object) |
 | BeginCompleteSale(CompleteSaleRequestType, AsyncCallback, Object) |
 | BeginConfirmIdentity(ConfirmIdentityRequestType, AsyncCallback, Object) |
 | BeginDeleteMyMessages(DeleteMyMessagesRequestType, AsyncCallback, Object) |
 | BeginDeleteSellingManagerInventoryFolder(DeleteSellingManagerInventoryFolderRequestType, AsyncCallback, Object) |
 | BeginDeleteSellingManagerItemAutomationRule(DeleteSellingManagerItemAutomationRuleRequestType, AsyncCallback, Object) |
 | BeginDeleteSellingManagerProduct(DeleteSellingManagerProductRequestType, AsyncCallback, Object) |
 | BeginDeleteSellingManagerTemplate(DeleteSellingManagerTemplateRequestType, AsyncCallback, Object) |
 | BeginDeleteSellingManagerTemplateAutomationRule(DeleteSellingManagerTemplateAutomationRuleRequestType, AsyncCallback, Object) |
 | BeginDisableUnpaidItemAssistance(DisableUnpaidItemAssistanceRequestType, AsyncCallback, Object) |
 | BeginEndFixedPriceItem(EndFixedPriceItemRequestType, AsyncCallback, Object) |
 | BeginEndItem(EndItemRequestType, AsyncCallback, Object) |
 | BeginEndItems(EndItemsRequestType, AsyncCallback, Object) |
 | BeginExtendSiteHostedPictures(ExtendSiteHostedPicturesRequestType, AsyncCallback, Object) |
 | BeginFetchToken(FetchTokenRequestType, AsyncCallback, Object) |
 | BeginGetAccount(GetAccountRequestType, AsyncCallback, Object) |
 | BeginGetAdFormatLeads(GetAdFormatLeadsRequestType, AsyncCallback, Object) |
 | BeginGetAllBidders(GetAllBiddersRequestType, AsyncCallback, Object) |
 | BeginGetApiAccessRules(GetApiAccessRulesRequestType, AsyncCallback, Object) |
 | BeginGetBestOffers(GetBestOffersRequestType, AsyncCallback, Object) |
 | BeginGetBidderList(GetBidderListRequestType, AsyncCallback, Object) |
 | BeginGetCategories(GetCategoriesRequestType, AsyncCallback, Object) |
 | BeginGetCategoryFeatures(GetCategoryFeaturesRequestType, AsyncCallback, Object) |
 | BeginGetCategoryMappings(GetCategoryMappingsRequestType, AsyncCallback, Object) |
 | BeginGetCategorySpecifics(GetCategorySpecificsRequestType, AsyncCallback, Object) |
 | BeginGetChallengeToken(GetChallengeTokenRequestType, AsyncCallback, Object) |
 | BeginGetCharities(GetCharitiesRequestType, AsyncCallback, Object) |
 | BeginGetClientAlertsAuthToken(GetClientAlertsAuthTokenRequestType, AsyncCallback, Object) |
 | BeginGetContextualKeywords(GetContextualKeywordsRequestType, AsyncCallback, Object) |
 | BeginGetDescriptionTemplates(GetDescriptionTemplatesRequestType, AsyncCallback, Object) |
 | BeginGetDispute(GetDisputeRequestType, AsyncCallback, Object) |
 | BeginGeteBayDetails(GeteBayDetailsRequestType, AsyncCallback, Object) |
 | BeginGeteBayOfficialTime(GeteBayOfficialTimeRequestType, AsyncCallback, Object) |
 | BeginGetFeedback(GetFeedbackRequestType, AsyncCallback, Object) |
 | BeginGetItem(GetItemRequestType, AsyncCallback, Object) |
 | BeginGetItemsAwaitingFeedback(GetItemsAwaitingFeedbackRequestType, AsyncCallback, Object) |
 | BeginGetItemShipping(GetItemShippingRequestType, AsyncCallback, Object) |
 | BeginGetItemTransactions(GetItemTransactionsRequestType, AsyncCallback, Object) |
 | BeginGetMemberMessages(GetMemberMessagesRequestType, AsyncCallback, Object) |
 | BeginGetMessagePreferences(GetMessagePreferencesRequestType, AsyncCallback, Object) |
 | BeginGetMyeBayBuying(GetMyeBayBuyingRequestType, AsyncCallback, Object) |
 | BeginGetMyeBayReminders(GetMyeBayRemindersRequestType, AsyncCallback, Object) |
 | BeginGetMyeBaySelling(GetMyeBaySellingRequestType, AsyncCallback, Object) |
 | BeginGetMyMessages(GetMyMessagesRequestType, AsyncCallback, Object) |
 | BeginGetNotificationPreferences(GetNotificationPreferencesRequestType, AsyncCallback, Object) |
 | BeginGetNotificationsUsage(GetNotificationsUsageRequestType, AsyncCallback, Object) |
 | BeginGetOrders(GetOrdersRequestType, AsyncCallback, Object) |
 | BeginGetOrderTransactions(GetOrderTransactionsRequestType, AsyncCallback, Object) |
 | BeginGetProductSellingPages(GetProductSellingPagesRequestType, AsyncCallback, Object) |
 | BeginGetPromotionalSaleDetails(GetPromotionalSaleDetailsRequestType, AsyncCallback, Object) |
 | BeginGetSellerDashboard(GetSellerDashboardRequestType, AsyncCallback, Object) |
 | BeginGetSellerEvents(GetSellerEventsRequestType, AsyncCallback, Object) |
 | BeginGetSellerList(GetSellerListRequestType, AsyncCallback, Object) |
 | BeginGetSellerPayments(GetSellerPaymentsRequestType, AsyncCallback, Object) |
 | BeginGetSellerTransactions(GetSellerTransactionsRequestType, AsyncCallback, Object) |
 | BeginGetSellingManagerAlerts(GetSellingManagerAlertsRequestType, AsyncCallback, Object) |
 | BeginGetSellingManagerEmailLog(GetSellingManagerEmailLogRequestType, AsyncCallback, Object) |
 | BeginGetSellingManagerInventory(GetSellingManagerInventoryRequestType, AsyncCallback, Object) |
 | BeginGetSellingManagerInventoryFolder(GetSellingManagerInventoryFolderRequestType, AsyncCallback, Object) |
 | BeginGetSellingManagerItemAutomationRule(GetSellingManagerItemAutomationRuleRequestType, AsyncCallback, Object) |
 | BeginGetSellingManagerSaleRecord(GetSellingManagerSaleRecordRequestType, AsyncCallback, Object) |
 | BeginGetSellingManagerSoldListings(GetSellingManagerSoldListingsRequestType, AsyncCallback, Object) |
 | BeginGetSellingManagerTemplateAutomationRule(GetSellingManagerTemplateAutomationRuleRequestType, AsyncCallback, Object) |
 | BeginGetSellingManagerTemplates(GetSellingManagerTemplatesRequestType, AsyncCallback, Object) |
 | BeginGetSessionID(GetSessionIDRequestType, AsyncCallback, Object) |
 | BeginGetShippingDiscountProfiles(GetShippingDiscountProfilesRequestType, AsyncCallback, Object) |
 | BeginGetStore(GetStoreRequestType, AsyncCallback, Object) |
 | BeginGetStoreCategoryUpdateStatus(GetStoreCategoryUpdateStatusRequestType, AsyncCallback, Object) |
 | BeginGetStoreCustomPage(GetStoreCustomPageRequestType, AsyncCallback, Object) |
 | BeginGetStoreOptions(GetStoreOptionsRequestType, AsyncCallback, Object) |
 | BeginGetStorePreferences(GetStorePreferencesRequestType, AsyncCallback, Object) |
 | BeginGetSuggestedCategories(GetSuggestedCategoriesRequestType, AsyncCallback, Object) |
 | BeginGetTaxTable(GetTaxTableRequestType, AsyncCallback, Object) |
 | BeginGetTokenStatus(GetTokenStatusRequestType, AsyncCallback, Object) |
 | BeginGetUser(GetUserRequestType, AsyncCallback, Object) |
 | BeginGetUserContactDetails(GetUserContactDetailsRequestType, AsyncCallback, Object) |
 | BeginGetUserDisputes(GetUserDisputesRequestType, AsyncCallback, Object) |
 | BeginGetUserPreferences(GetUserPreferencesRequestType, AsyncCallback, Object) |
 | BeginGetVeROReasonCodeDetails(GetVeROReasonCodeDetailsRequestType, AsyncCallback, Object) |
 | BeginGetVeROReportStatus(GetVeROReportStatusRequestType, AsyncCallback, Object) |
 | BeginInvoke(String, array<Object>[]()[][], AsyncCallback, Object) | (Inherited from SoapHttpClientProtocol.)
 | BeginIssueRefund(IssueRefundRequestType, AsyncCallback, Object) |
 | BeginLeaveFeedback(LeaveFeedbackRequestType, AsyncCallback, Object) |
 | BeginMoveSellingManagerInventoryFolder(MoveSellingManagerInventoryFolderRequestType, AsyncCallback, Object) |
 | BeginPlaceOffer(PlaceOfferRequestType, AsyncCallback, Object) |
 | BeginRelistFixedPriceItem(RelistFixedPriceItemRequestType, AsyncCallback, Object) |
 | BeginRelistItem(RelistItemRequestType, AsyncCallback, Object) |
 | BeginRemoveFromWatchList(RemoveFromWatchListRequestType, AsyncCallback, Object) |
 | BeginRespondToBestOffer(RespondToBestOfferRequestType, AsyncCallback, Object) |
 | BeginRespondToFeedback(RespondToFeedbackRequestType, AsyncCallback, Object) |
 | BeginReviseCheckoutStatus(ReviseCheckoutStatusRequestType, AsyncCallback, Object) |
 | BeginReviseFixedPriceItem(ReviseFixedPriceItemRequestType, AsyncCallback, Object) |
 | BeginReviseInventoryStatus(ReviseInventoryStatusRequestType, AsyncCallback, Object) |
 | BeginReviseItem(ReviseItemRequestType, AsyncCallback, Object) |
 | BeginReviseMyMessages(ReviseMyMessagesRequestType, AsyncCallback, Object) |
 | BeginReviseMyMessagesFolders(ReviseMyMessagesFoldersRequestType, AsyncCallback, Object) |
 | BeginReviseSellingManagerInventoryFolder(ReviseSellingManagerInventoryFolderRequestType, AsyncCallback, Object) |
 | BeginReviseSellingManagerProduct(ReviseSellingManagerProductRequestType, AsyncCallback, Object) |
 | BeginReviseSellingManagerSaleRecord(ReviseSellingManagerSaleRecordRequestType, AsyncCallback, Object) |
 | BeginReviseSellingManagerTemplate(ReviseSellingManagerTemplateRequestType, AsyncCallback, Object) |
 | BeginRevokeToken(RevokeTokenRequestType, AsyncCallback, Object) |
 | BeginSaveItemToSellingManagerTemplate(SaveItemToSellingManagerTemplateRequestType, AsyncCallback, Object) |
 | BeginSellerReverseDispute(SellerReverseDisputeRequestType, AsyncCallback, Object) |
 | BeginSendInvoice(SendInvoiceRequestType, AsyncCallback, Object) |
 | BeginSetMessagePreferences(SetMessagePreferencesRequestType, AsyncCallback, Object) |
 | BeginSetNotificationPreferences(SetNotificationPreferencesRequestType, AsyncCallback, Object) |
 | BeginSetPromotionalSale(SetPromotionalSaleRequestType, AsyncCallback, Object) |
 | BeginSetPromotionalSaleListings(SetPromotionalSaleListingsRequestType, AsyncCallback, Object) |
 | BeginSetSellingManagerFeedbackOptions(SetSellingManagerFeedbackOptionsRequestType, AsyncCallback, Object) |
 | BeginSetSellingManagerItemAutomationRule(SetSellingManagerItemAutomationRuleRequestType, AsyncCallback, Object) |
 | BeginSetSellingManagerTemplateAutomationRule(SetSellingManagerTemplateAutomationRuleRequestType, AsyncCallback, Object) |
 | BeginSetShippingDiscountProfiles(SetShippingDiscountProfilesRequestType, AsyncCallback, Object) |
 | BeginSetStore(SetStoreRequestType, AsyncCallback, Object) |
 | BeginSetStoreCategories(SetStoreCategoriesRequestType, AsyncCallback, Object) |
 | BeginSetStoreCustomPage(SetStoreCustomPageRequestType, AsyncCallback, Object) |
 | BeginSetStorePreferences(SetStorePreferencesRequestType, AsyncCallback, Object) |
 | BeginSetTaxTable(SetTaxTableRequestType, AsyncCallback, Object) |
 | BeginSetUserNotes(SetUserNotesRequestType, AsyncCallback, Object) |
 | BeginSetUserPreferences(SetUserPreferencesRequestType, AsyncCallback, Object) |
 | BeginValidateChallengeInput(ValidateChallengeInputRequestType, AsyncCallback, Object) |
 | BeginValidateTestUserRegistration(ValidateTestUserRegistrationRequestType, AsyncCallback, Object) |
 | BeginVerifyAddFixedPriceItem(VerifyAddFixedPriceItemRequestType, AsyncCallback, Object) |
 | BeginVerifyAddItem(VerifyAddItemRequestType, AsyncCallback, Object) |
 | BeginVerifyAddSecondChanceItem(VerifyAddSecondChanceItemRequestType, AsyncCallback, Object) |
 | BeginVerifyRelistItem(VerifyRelistItemRequestType, AsyncCallback, Object) |
 | BeginVeROReportItems(VeROReportItemsRequestType, AsyncCallback, Object) |
 | CancelAsync(Object) | (Inherited from HttpWebClientProtocol.)
 | CanRaiseEvents | (Inherited from Component.)
 | ClientCertificates | (Inherited from HttpWebClientProtocol.)
 | CompleteSale(CompleteSaleRequestType) |
 | ConfirmIdentity(ConfirmIdentityRequestType) |
 | ConnectionGroupName | (Inherited from WebClientProtocol.)
 | Container | (Inherited from Component.)
 | CookieContainer | (Inherited from HttpWebClientProtocol.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Credentials | (Inherited from WebClientProtocol.)
 | DeleteMyMessages(DeleteMyMessagesRequestType) |
 | DeleteSellingManagerInventoryFolder(DeleteSellingManagerInventoryFolderRequestType) |
 | DeleteSellingManagerItemAutomationRule(DeleteSellingManagerItemAutomationRuleRequestType) |
 | DeleteSellingManagerProduct(DeleteSellingManagerProductRequestType) |
 | DeleteSellingManagerTemplate(DeleteSellingManagerTemplateRequestType) |
 | DeleteSellingManagerTemplateAutomationRule(DeleteSellingManagerTemplateAutomationRuleRequestType) |
 | DesignMode | (Inherited from Component.)
 | DisableUnpaidItemAssistance(DisableUnpaidItemAssistanceRequestType) |
 | Discover()()()() | (Inherited from SoapHttpClientProtocol.)
 | Dispose()()()() | (Inherited from Component.)
 | Dispose(Boolean) | (Inherited from Component.)
 | Disposed | (Inherited from Component.)
 | EnableDecompression | (Inherited from HttpWebClientProtocol.)
 | EndAddDispute(IAsyncResult) |
 | EndAddDisputeResponse(IAsyncResult) |
 | EndAddFixedPriceItem(IAsyncResult) |
 | EndAddItem(IAsyncResult) |
 | EndAddItemFromSellingManagerTemplate(IAsyncResult) |
 | EndAddItems(IAsyncResult) |
 | EndAddMemberMessageAAQToPartner(IAsyncResult) |
 | EndAddMemberMessageRTQ(IAsyncResult) |
 | EndAddMemberMessagesAAQToBidder(IAsyncResult) |
 | EndAddOrder(IAsyncResult) |
 | EndAddSecondChanceItem(IAsyncResult) |
 | EndAddSellingManagerInventoryFolder(IAsyncResult) |
 | EndAddSellingManagerProduct(IAsyncResult) |
 | EndAddSellingManagerTemplate(IAsyncResult) |
 | EndAddToItemDescription(IAsyncResult) |
 | EndAddToWatchList(IAsyncResult) |
 | EndAddTransactionConfirmationItem(IAsyncResult) |
 | EndCompleteSale(IAsyncResult) |
 | EndConfirmIdentity(IAsyncResult) |
 | EndDeleteMyMessages(IAsyncResult) |
 | EndDeleteSellingManagerInventoryFolder(IAsyncResult) |
 | EndDeleteSellingManagerItemAutomationRule(IAsyncResult) |
 | EndDeleteSellingManagerProduct(IAsyncResult) |
 | EndDeleteSellingManagerTemplate(IAsyncResult) |
 | EndDeleteSellingManagerTemplateAutomationRule(IAsyncResult) |
 | EndDisableUnpaidItemAssistance(IAsyncResult) |
 | EndEndFixedPriceItem(IAsyncResult) |
 | EndEndItem(IAsyncResult) |
 | EndEndItems(IAsyncResult) |
 | EndExtendSiteHostedPictures(IAsyncResult) |
 | EndFetchToken(IAsyncResult) |
 | EndFixedPriceItem(EndFixedPriceItemRequestType) |
 | EndGetAccount(IAsyncResult) |
 | EndGetAdFormatLeads(IAsyncResult) |
 | EndGetAllBidders(IAsyncResult) |
 | EndGetApiAccessRules(IAsyncResult) |
 | EndGetBestOffers(IAsyncResult) |
 | EndGetBidderList(IAsyncResult) |
 | EndGetCategories(IAsyncResult) |
 | EndGetCategoryFeatures(IAsyncResult) |
 | EndGetCategoryMappings(IAsyncResult) |
 | EndGetCategorySpecifics(IAsyncResult) |
 | EndGetChallengeToken(IAsyncResult) |
 | EndGetCharities(IAsyncResult) |
 | EndGetClientAlertsAuthToken(IAsyncResult) |
 | EndGetContextualKeywords(IAsyncResult) |
 | EndGetDescriptionTemplates(IAsyncResult) |
 | EndGetDispute(IAsyncResult) |
 | EndGeteBayDetails(IAsyncResult) |
 | EndGeteBayOfficialTime(IAsyncResult) |
 | EndGetFeedback(IAsyncResult) |
 | EndGetItem(IAsyncResult) |
 | EndGetItemsAwaitingFeedback(IAsyncResult) |
 | EndGetItemShipping(IAsyncResult) |
 | EndGetItemTransactions(IAsyncResult) |
 | EndGetMemberMessages(IAsyncResult) |
 | EndGetMessagePreferences(IAsyncResult) |
 | EndGetMyeBayBuying(IAsyncResult) |
 | EndGetMyeBayReminders(IAsyncResult) |
 | EndGetMyeBaySelling(IAsyncResult) |
 | EndGetMyMessages(IAsyncResult) |
 | EndGetNotificationPreferences(IAsyncResult) |
 | EndGetNotificationsUsage(IAsyncResult) |
 | EndGetOrders(IAsyncResult) |
 | EndGetOrderTransactions(IAsyncResult) |
 | EndGetProductSellingPages(IAsyncResult) |
 | EndGetPromotionalSaleDetails(IAsyncResult) |
 | EndGetSellerDashboard(IAsyncResult) |
 | EndGetSellerEvents(IAsyncResult) |
 | EndGetSellerList(IAsyncResult) |
 | EndGetSellerPayments(IAsyncResult) |
 | EndGetSellerTransactions(IAsyncResult) |
 | EndGetSellingManagerAlerts(IAsyncResult) |
 | EndGetSellingManagerEmailLog(IAsyncResult) |
 | EndGetSellingManagerInventory(IAsyncResult) |
 | EndGetSellingManagerInventoryFolder(IAsyncResult) |
 | EndGetSellingManagerItemAutomationRule(IAsyncResult) |
 | EndGetSellingManagerSaleRecord(IAsyncResult) |
 | EndGetSellingManagerSoldListings(IAsyncResult) |
 | EndGetSellingManagerTemplateAutomationRule(IAsyncResult) |
 | EndGetSellingManagerTemplates(IAsyncResult) |
 | EndGetSessionID(IAsyncResult) |
 | EndGetShippingDiscountProfiles(IAsyncResult) |
 | EndGetStore(IAsyncResult) |
 | EndGetStoreCategoryUpdateStatus(IAsyncResult) |
 | EndGetStoreCustomPage(IAsyncResult) |
 | EndGetStoreOptions(IAsyncResult) |
 | EndGetStorePreferences(IAsyncResult) |
 | EndGetSuggestedCategories(IAsyncResult) |
 | EndGetTaxTable(IAsyncResult) |
 | EndGetTokenStatus(IAsyncResult) |
 | EndGetUser(IAsyncResult) |
 | EndGetUserContactDetails(IAsyncResult) |
 | EndGetUserDisputes(IAsyncResult) |
 | EndGetUserPreferences(IAsyncResult) |
 | EndGetVeROReasonCodeDetails(IAsyncResult) |
 | EndGetVeROReportStatus(IAsyncResult) |
 | EndInvoke(IAsyncResult) | (Inherited from SoapHttpClientProtocol.)
 | EndIssueRefund(IAsyncResult) |
 | EndItem(EndItemRequestType) |
 | EndItems(EndItemsRequestType) |
 | EndLeaveFeedback(IAsyncResult) |
 | EndMoveSellingManagerInventoryFolder(IAsyncResult) |
 | EndPlaceOffer(IAsyncResult) |
 | EndRelistFixedPriceItem(IAsyncResult) |
 | EndRelistItem(IAsyncResult) |
 | EndRemoveFromWatchList(IAsyncResult) |
 | EndRespondToBestOffer(IAsyncResult) |
 | EndRespondToFeedback(IAsyncResult) |
 | EndReviseCheckoutStatus(IAsyncResult) |
 | EndReviseFixedPriceItem(IAsyncResult) |
 | EndReviseInventoryStatus(IAsyncResult) |
 | EndReviseItem(IAsyncResult) |
 | EndReviseMyMessages(IAsyncResult) |
 | EndReviseMyMessagesFolders(IAsyncResult) |
 | EndReviseSellingManagerInventoryFolder(IAsyncResult) |
 | EndReviseSellingManagerProduct(IAsyncResult) |
 | EndReviseSellingManagerSaleRecord(IAsyncResult) |
 | EndReviseSellingManagerTemplate(IAsyncResult) |
 | EndRevokeToken(IAsyncResult) |
 | EndSaveItemToSellingManagerTemplate(IAsyncResult) |
 | EndSellerReverseDispute(IAsyncResult) |
 | EndSendInvoice(IAsyncResult) |
 | EndSetMessagePreferences(IAsyncResult) |
 | EndSetNotificationPreferences(IAsyncResult) |
 | EndSetPromotionalSale(IAsyncResult) |
 | EndSetPromotionalSaleListings(IAsyncResult) |
 | EndSetSellingManagerFeedbackOptions(IAsyncResult) |
 | EndSetSellingManagerItemAutomationRule(IAsyncResult) |
 | EndSetSellingManagerTemplateAutomationRule(IAsyncResult) |
 | EndSetShippingDiscountProfiles(IAsyncResult) |
 | EndSetStore(IAsyncResult) |
 | EndSetStoreCategories(IAsyncResult) |
 | EndSetStoreCustomPage(IAsyncResult) |
 | EndSetStorePreferences(IAsyncResult) |
 | EndSetTaxTable(IAsyncResult) |
 | EndSetUserNotes(IAsyncResult) |
 | EndSetUserPreferences(IAsyncResult) |
 | EndValidateChallengeInput(IAsyncResult) |
 | EndValidateTestUserRegistration(IAsyncResult) |
 | EndVerifyAddFixedPriceItem(IAsyncResult) |
 | EndVerifyAddItem(IAsyncResult) |
 | EndVerifyAddSecondChanceItem(IAsyncResult) |
 | EndVerifyRelistItem(IAsyncResult) |
 | EndVeROReportItems(IAsyncResult) |
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Component.)
 | ExtendSiteHostedPictures(ExtendSiteHostedPicturesRequestType) |
 | FetchToken(FetchTokenRequestType) |
 | Finalize()()()() | (Inherited from Component.)
 | GetAccount(GetAccountRequestType) |
 | GetAdFormatLeads(GetAdFormatLeadsRequestType) |
 | GetAllBidders(GetAllBiddersRequestType) |
 | GetApiAccessRules(GetApiAccessRulesRequestType) |
 | GetBestOffers(GetBestOffersRequestType) |
 | GetBidderList(GetBidderListRequestType) |
 | GetCategories(GetCategoriesRequestType) |
 | GetCategoryFeatures(GetCategoryFeaturesRequestType) |
 | GetCategoryMappings(GetCategoryMappingsRequestType) |
 | GetCategorySpecifics(GetCategorySpecificsRequestType) |
 | GetChallengeToken(GetChallengeTokenRequestType) |
 | GetCharities(GetCharitiesRequestType) |
 | GetClientAlertsAuthToken(GetClientAlertsAuthTokenRequestType) |
 | GetContextualKeywords(GetContextualKeywordsRequestType) |
 | GetDescriptionTemplates(GetDescriptionTemplatesRequestType) |
 | GetDispute(GetDisputeRequestType) |
 | GeteBayDetails(GeteBayDetailsRequestType) |
 | GeteBayOfficialTime(GeteBayOfficialTimeRequestType) |
 | GetFeedback(GetFeedbackRequestType) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItem(GetItemRequestType) |
 | GetItemsAwaitingFeedback(GetItemsAwaitingFeedbackRequestType) |
 | GetItemShipping(GetItemShippingRequestType) |
 | GetItemTransactions(GetItemTransactionsRequestType) |
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetMemberMessages(GetMemberMessagesRequestType) |
 | GetMessagePreferences(GetMessagePreferencesRequestType) |
 | GetMyeBayBuying(GetMyeBayBuyingRequestType) |
 | GetMyeBayReminders(GetMyeBayRemindersRequestType) |
 | GetMyeBaySelling(GetMyeBaySellingRequestType) |
 | GetMyMessages(GetMyMessagesRequestType) |
 | GetNotificationPreferences(GetNotificationPreferencesRequestType) |
 | GetNotificationsUsage(GetNotificationsUsageRequestType) |
 | GetOrders(GetOrdersRequestType) |
 | GetOrderTransactions(GetOrderTransactionsRequestType) |
 | GetProductSellingPages(GetProductSellingPagesRequestType) |
 | GetPromotionalSaleDetails(GetPromotionalSaleDetailsRequestType) |
 | GetReaderForMessage(SoapClientMessage, Int32) | (Inherited from SoapHttpClientProtocol.)
 | GetSellerDashboard(GetSellerDashboardRequestType) |
 | GetSellerEvents(GetSellerEventsRequestType) |
 | GetSellerList(GetSellerListRequestType) |
 | GetSellerPayments(GetSellerPaymentsRequestType) |
 | GetSellerTransactions(GetSellerTransactionsRequestType) |
 | GetSellingManagerAlerts(GetSellingManagerAlertsRequestType) |
 | GetSellingManagerEmailLog(GetSellingManagerEmailLogRequestType) |
 | GetSellingManagerInventory(GetSellingManagerInventoryRequestType) |
 | GetSellingManagerInventoryFolder(GetSellingManagerInventoryFolderRequestType) |
 | GetSellingManagerItemAutomationRule(GetSellingManagerItemAutomationRuleRequestType) |
 | GetSellingManagerSaleRecord(GetSellingManagerSaleRecordRequestType) |
 | GetSellingManagerSoldListings(GetSellingManagerSoldListingsRequestType) |
 | GetSellingManagerTemplateAutomationRule(GetSellingManagerTemplateAutomationRuleRequestType) |
 | GetSellingManagerTemplates(GetSellingManagerTemplatesRequestType) |
 | GetService(Type) | (Inherited from Component.)
 | GetSessionID(GetSessionIDRequestType) |
 | GetShippingDiscountProfiles(GetShippingDiscountProfilesRequestType) |
 | GetStore(GetStoreRequestType) |
 | GetStoreCategoryUpdateStatus(GetStoreCategoryUpdateStatusRequestType) |
 | GetStoreCustomPage(GetStoreCustomPageRequestType) |
 | GetStoreOptions(GetStoreOptionsRequestType) |
 | GetStorePreferences(GetStorePreferencesRequestType) |
 | GetSuggestedCategories(GetSuggestedCategoriesRequestType) |
 | GetTaxTable(GetTaxTableRequestType) |
 | GetTokenStatus(GetTokenStatusRequestType) |
 | GetType()()()() | (Inherited from Object.)
 | GetUser(GetUserRequestType) |
 | GetUserContactDetails(GetUserContactDetailsRequestType) |
 | GetUserDisputes(GetUserDisputesRequestType) |
 | GetUserPreferences(GetUserPreferencesRequestType) |
 | GetVeROReasonCodeDetails(GetVeROReasonCodeDetailsRequestType) |
 | GetVeROReportStatus(GetVeROReportStatusRequestType) |
 | GetWebRequest(Uri) | (Inherited from SoapHttpClientProtocol.)
 | GetWebResponse(WebRequest) | (Inherited from HttpWebClientProtocol.)
 | GetWebResponse(WebRequest, IAsyncResult) | (Inherited from HttpWebClientProtocol.)
 | GetWriterForMessage(SoapClientMessage, Int32) | (Inherited from SoapHttpClientProtocol.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Invoke(String, array<Object>[]()[][]) | (Inherited from SoapHttpClientProtocol.)
 | InvokeAsync(String, array<Object>[]()[][], SendOrPostCallback) | (Inherited from SoapHttpClientProtocol.)
 | InvokeAsync(String, array<Object>[]()[][], SendOrPostCallback, Object) | (Inherited from SoapHttpClientProtocol.)
 | IssueRefund(IssueRefundRequestType) |
 | LeaveFeedback(LeaveFeedbackRequestType) |
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MoveSellingManagerInventoryFolder(MoveSellingManagerInventoryFolderRequestType) |
 | PlaceOffer(PlaceOfferRequestType) |
 | PreAuthenticate | (Inherited from WebClientProtocol.)
 | Proxy | (Inherited from HttpWebClientProtocol.)
 | RelistFixedPriceItem(RelistFixedPriceItemRequestType) |
 | RelistItem(RelistItemRequestType) |
 | RemoveFromWatchList(RemoveFromWatchListRequestType) |
 | RequestEncoding | (Inherited from WebClientProtocol.)
 | RequesterCredentials |
 | RespondToBestOffer(RespondToBestOfferRequestType) |
 | RespondToFeedback(RespondToFeedbackRequestType) |
 | ReviseCheckoutStatus(ReviseCheckoutStatusRequestType) |
 | ReviseFixedPriceItem(ReviseFixedPriceItemRequestType) |
 | ReviseInventoryStatus(ReviseInventoryStatusRequestType) |
 | ReviseItem(ReviseItemRequestType) |
 | ReviseMyMessages(ReviseMyMessagesRequestType) |
 | ReviseMyMessagesFolders(ReviseMyMessagesFoldersRequestType) |
 | ReviseSellingManagerInventoryFolder(ReviseSellingManagerInventoryFolderRequestType) |
 | ReviseSellingManagerProduct(ReviseSellingManagerProductRequestType) |
 | ReviseSellingManagerSaleRecord(ReviseSellingManagerSaleRecordRequestType) |
 | ReviseSellingManagerTemplate(ReviseSellingManagerTemplateRequestType) |
 | RevokeToken(RevokeTokenRequestType) |
 | SaveItemToSellingManagerTemplate(SaveItemToSellingManagerTemplateRequestType) |
 | SellerReverseDispute(SellerReverseDisputeRequestType) |
 | SendInvoice(SendInvoiceRequestType) |
 | SetMessagePreferences(SetMessagePreferencesRequestType) |
 | SetNotificationPreferences(SetNotificationPreferencesRequestType) |
 | SetPromotionalSale(SetPromotionalSaleRequestType) |
 | SetPromotionalSaleListings(SetPromotionalSaleListingsRequestType) |
 | SetSellingManagerFeedbackOptions(SetSellingManagerFeedbackOptionsRequestType) |
 | SetSellingManagerItemAutomationRule(SetSellingManagerItemAutomationRuleRequestType) |
 | SetSellingManagerTemplateAutomationRule(SetSellingManagerTemplateAutomationRuleRequestType) |
 | SetShippingDiscountProfiles(SetShippingDiscountProfilesRequestType) |
 | SetStore(SetStoreRequestType) |
 | SetStoreCategories(SetStoreCategoriesRequestType) |
 | SetStoreCustomPage(SetStoreCustomPageRequestType) |
 | SetStorePreferences(SetStorePreferencesRequestType) |
 | SetTaxTable(SetTaxTableRequestType) |
 | SetUserNotes(SetUserNotesRequestType) |
 | SetUserPreferences(SetUserPreferencesRequestType) |
 | Site | (Inherited from Component.)
 | SoapRequest | (Inherited from SoapHttpClientProtocolEx.)
 | SoapResponse | (Inherited from SoapHttpClientProtocolEx.)
 | SoapVersion | (Inherited from SoapHttpClientProtocol.)
 | Timeout | (Inherited from WebClientProtocol.)
 | ToString()()()() | (Inherited from Component.)
 | UnsafeAuthenticatedConnectionSharing | (Inherited from HttpWebClientProtocol.)
 | Url | (Inherited from WebClientProtocol.)
 | UseDefaultCredentials | (Inherited from WebClientProtocol.)
 | UserAgent | (Inherited from HttpWebClientProtocol.)
 | ValidateChallengeInput(ValidateChallengeInputRequestType) |
 | ValidateTestUserRegistration(ValidateTestUserRegistrationRequestType) |
 | VerifyAddFixedPriceItem(VerifyAddFixedPriceItemRequestType) |
 | VerifyAddItem(VerifyAddItemRequestType) |
 | VerifyAddSecondChanceItem(VerifyAddSecondChanceItemRequestType) |
 | VerifyRelistItem(VerifyRelistItemRequestType) |
 | VeROReportItems(VeROReportItemsRequestType) |
Remarks
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | WebClientProtocol
 |  |  |  | HttpWebClientProtocol
 |  |  |  |  | SoapHttpClientProtocol
 |  |  |  |  |  | SoapHttpClientProtocolEx
 |  |  |  |  |  |  | eBayAPIInterfaceService


AddDispute Method (AddDisputeRequest)

AddDispute Method (AddDisputeRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddDispute(AddDisputeRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddDisputeResponseType AddDispute(
    AddDisputeRequestType AddDisputeRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddDispute ( _
    AddDisputeRequest As AddDisputeRequestType _
) As AddDisputeResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddDisputeResponseType^ AddDispute(
    AddDisputeRequestType^ AddDisputeRequest
)
Parameters
AddDisputeRequest (AddDisputeRequestType)
Remarks


AddDisputeResponse Method (AddDisputeResponseRequest)

AddDisputeResponse Method (AddDisputeResponseRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddDisputeResponse(AddDisputeResponseRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddDisputeResponseResponseType AddDisputeResponse(
    AddDisputeResponseRequestType AddDisputeResponseRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddDisputeResponse ( _
    AddDisputeResponseRequest As AddDisputeResponseRequestType _
) As AddDisputeResponseResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddDisputeResponseResponseType^ AddDisputeResponse(
    AddDisputeResponseRequestType^ AddDisputeResponseRequest
)
Parameters
AddDisputeResponseRequest (AddDisputeResponseRequestType)
Remarks


AddFixedPriceItem Method (AddFixedPriceItemRequest)

AddFixedPriceItem Method (AddFixedPriceItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddFixedPriceItem(AddFixedPriceItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddFixedPriceItemResponseType AddFixedPriceItem(
    AddFixedPriceItemRequestType AddFixedPriceItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddFixedPriceItem ( _
    AddFixedPriceItemRequest As AddFixedPriceItemRequestType _
) As AddFixedPriceItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddFixedPriceItemResponseType^ AddFixedPriceItem(
    AddFixedPriceItemRequestType^ AddFixedPriceItemRequest
)
Parameters
AddFixedPriceItemRequest (AddFixedPriceItemRequestType)
Remarks


AddItem Method (AddItemRequest)

AddItem Method (AddItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddItem(AddItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddItemResponseType AddItem(
    AddItemRequestType AddItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddItem ( _
    AddItemRequest As AddItemRequestType _
) As AddItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddItemResponseType^ AddItem(
    AddItemRequestType^ AddItemRequest
)
Parameters
AddItemRequest (AddItemRequestType)
Remarks


AddItemFromSellingManagerTemplate Method (AddItemFromSellingManagerTemplateRequest)

AddItemFromSellingManagerTemplate Method (AddItemFromSellingManagerTemplateRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddItemFromSellingManagerTemplate(AddItemFromSellingManagerTemplateRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddItemFromSellingManagerTemplateResponseType AddItemFromSellingManagerTemplate(
    AddItemFromSellingManagerTemplateRequestType AddItemFromSellingManagerTemplateRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddItemFromSellingManagerTemplate ( _
    AddItemFromSellingManagerTemplateRequest As AddItemFromSellingManagerTemplateRequestType _
) As AddItemFromSellingManagerTemplateResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddItemFromSellingManagerTemplateResponseType^ AddItemFromSellingManagerTemplate(
    AddItemFromSellingManagerTemplateRequestType^ AddItemFromSellingManagerTemplateRequest
)
Parameters
AddItemFromSellingManagerTemplateRequest (AddItemFromSellingManagerTemplateRequestType)
Remarks


AddItems Method (AddItemsRequest)

AddItems Method (AddItemsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddItems(AddItemsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddItemsResponseType AddItems(
    AddItemsRequestType AddItemsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddItems ( _
    AddItemsRequest As AddItemsRequestType _
) As AddItemsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddItemsResponseType^ AddItems(
    AddItemsRequestType^ AddItemsRequest
)
Parameters
AddItemsRequest (AddItemsRequestType)
Remarks


AddMemberMessageAAQToPartner Method (AddMemberMessageAAQToPartnerRequest)

AddMemberMessageAAQToPartner Method (AddMemberMessageAAQToPartnerRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddMemberMessageAAQToPartner(AddMemberMessageAAQToPartnerRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddMemberMessageAAQToPartnerResponseType AddMemberMessageAAQToPartner(
    AddMemberMessageAAQToPartnerRequestType AddMemberMessageAAQToPartnerRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddMemberMessageAAQToPartner ( _
    AddMemberMessageAAQToPartnerRequest As AddMemberMessageAAQToPartnerRequestType _
) As AddMemberMessageAAQToPartnerResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddMemberMessageAAQToPartnerResponseType^ AddMemberMessageAAQToPartner(
    AddMemberMessageAAQToPartnerRequestType^ AddMemberMessageAAQToPartnerRequest
)
Parameters
AddMemberMessageAAQToPartnerRequest (AddMemberMessageAAQToPartnerRequestType)
Remarks


AddMemberMessageRTQ Method (AddMemberMessageRTQRequest)

AddMemberMessageRTQ Method (AddMemberMessageRTQRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddMemberMessageRTQ(AddMemberMessageRTQRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddMemberMessageRTQResponseType AddMemberMessageRTQ(
    AddMemberMessageRTQRequestType AddMemberMessageRTQRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddMemberMessageRTQ ( _
    AddMemberMessageRTQRequest As AddMemberMessageRTQRequestType _
) As AddMemberMessageRTQResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddMemberMessageRTQResponseType^ AddMemberMessageRTQ(
    AddMemberMessageRTQRequestType^ AddMemberMessageRTQRequest
)
Parameters
AddMemberMessageRTQRequest (AddMemberMessageRTQRequestType)
Remarks


AddMemberMessagesAAQToBidder Method (AddMemberMessagesAAQToBidderRequest)

AddMemberMessagesAAQToBidder Method (AddMemberMessagesAAQToBidderRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddMemberMessagesAAQToBidder(AddMemberMessagesAAQToBidderRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddMemberMessagesAAQToBidderResponseType AddMemberMessagesAAQToBidder(
    AddMemberMessagesAAQToBidderRequestType AddMemberMessagesAAQToBidderRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddMemberMessagesAAQToBidder ( _
    AddMemberMessagesAAQToBidderRequest As AddMemberMessagesAAQToBidderRequestType _
) As AddMemberMessagesAAQToBidderResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddMemberMessagesAAQToBidderResponseType^ AddMemberMessagesAAQToBidder(
    AddMemberMessagesAAQToBidderRequestType^ AddMemberMessagesAAQToBidderRequest
)
Parameters
AddMemberMessagesAAQToBidderRequest (AddMemberMessagesAAQToBidderRequestType)
Remarks


AddOrder Method (AddOrderRequest)

AddOrder Method (AddOrderRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddOrder(AddOrderRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddOrderResponseType AddOrder(
    AddOrderRequestType AddOrderRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddOrder ( _
    AddOrderRequest As AddOrderRequestType _
) As AddOrderResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddOrderResponseType^ AddOrder(
    AddOrderRequestType^ AddOrderRequest
)
Parameters
AddOrderRequest (AddOrderRequestType)
Remarks


AddSecondChanceItem Method (AddSecondChanceItemRequest)

AddSecondChanceItem Method (AddSecondChanceItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddSecondChanceItem(AddSecondChanceItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddSecondChanceItemResponseType AddSecondChanceItem(
    AddSecondChanceItemRequestType AddSecondChanceItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddSecondChanceItem ( _
    AddSecondChanceItemRequest As AddSecondChanceItemRequestType _
) As AddSecondChanceItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddSecondChanceItemResponseType^ AddSecondChanceItem(
    AddSecondChanceItemRequestType^ AddSecondChanceItemRequest
)
Parameters
AddSecondChanceItemRequest (AddSecondChanceItemRequestType)
Remarks


AddSellingManagerInventoryFolder Method (AddSellingManagerInventoryFolderRequest)

AddSellingManagerInventoryFolder Method (AddSellingManagerInventoryFolderRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddSellingManagerInventoryFolder(AddSellingManagerInventoryFolderRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddSellingManagerInventoryFolderResponseType AddSellingManagerInventoryFolder(
    AddSellingManagerInventoryFolderRequestType AddSellingManagerInventoryFolderRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddSellingManagerInventoryFolder ( _
    AddSellingManagerInventoryFolderRequest As AddSellingManagerInventoryFolderRequestType _
) As AddSellingManagerInventoryFolderResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddSellingManagerInventoryFolderResponseType^ AddSellingManagerInventoryFolder(
    AddSellingManagerInventoryFolderRequestType^ AddSellingManagerInventoryFolderRequest
)
Parameters
AddSellingManagerInventoryFolderRequest (AddSellingManagerInventoryFolderRequestType)
Remarks


AddSellingManagerProduct Method (AddSellingManagerProductRequest)

AddSellingManagerProduct Method (AddSellingManagerProductRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddSellingManagerProduct(AddSellingManagerProductRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddSellingManagerProductResponseType AddSellingManagerProduct(
    AddSellingManagerProductRequestType AddSellingManagerProductRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddSellingManagerProduct ( _
    AddSellingManagerProductRequest As AddSellingManagerProductRequestType _
) As AddSellingManagerProductResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddSellingManagerProductResponseType^ AddSellingManagerProduct(
    AddSellingManagerProductRequestType^ AddSellingManagerProductRequest
)
Parameters
AddSellingManagerProductRequest (AddSellingManagerProductRequestType)
Remarks


AddSellingManagerTemplate Method (AddSellingManagerTemplateRequest)

AddSellingManagerTemplate Method (AddSellingManagerTemplateRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddSellingManagerTemplate(AddSellingManagerTemplateRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddSellingManagerTemplateResponseType AddSellingManagerTemplate(
    AddSellingManagerTemplateRequestType AddSellingManagerTemplateRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddSellingManagerTemplate ( _
    AddSellingManagerTemplateRequest As AddSellingManagerTemplateRequestType _
) As AddSellingManagerTemplateResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddSellingManagerTemplateResponseType^ AddSellingManagerTemplate(
    AddSellingManagerTemplateRequestType^ AddSellingManagerTemplateRequest
)
Parameters
AddSellingManagerTemplateRequest (AddSellingManagerTemplateRequestType)
Remarks


AddToItemDescription Method (AddToItemDescriptionRequest)

AddToItemDescription Method (AddToItemDescriptionRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddToItemDescription(AddToItemDescriptionRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddToItemDescriptionResponseType AddToItemDescription(
    AddToItemDescriptionRequestType AddToItemDescriptionRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddToItemDescription ( _
    AddToItemDescriptionRequest As AddToItemDescriptionRequestType _
) As AddToItemDescriptionResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddToItemDescriptionResponseType^ AddToItemDescription(
    AddToItemDescriptionRequestType^ AddToItemDescriptionRequest
)
Parameters
AddToItemDescriptionRequest (AddToItemDescriptionRequestType)
Remarks


AddToWatchList Method (AddToWatchListRequest)

AddToWatchList Method (AddToWatchListRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddToWatchList(AddToWatchListRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddToWatchListResponseType AddToWatchList(
    AddToWatchListRequestType AddToWatchListRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddToWatchList ( _
    AddToWatchListRequest As AddToWatchListRequestType _
) As AddToWatchListResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddToWatchListResponseType^ AddToWatchList(
    AddToWatchListRequestType^ AddToWatchListRequest
)
Parameters
AddToWatchListRequest (AddToWatchListRequestType)
Remarks


AddTransactionConfirmationItem Method (AddTransactionConfirmationItemRequest)

AddTransactionConfirmationItem Method (AddTransactionConfirmationItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► AddTransactionConfirmationItem(AddTransactionConfirmationItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public AddTransactionConfirmationItemResponseType AddTransactionConfirmationItem(
    AddTransactionConfirmationItemRequestType AddTransactionConfirmationItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function AddTransactionConfirmationItem ( _
    AddTransactionConfirmationItemRequest As AddTransactionConfirmationItemRequestType _
) As AddTransactionConfirmationItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
AddTransactionConfirmationItemResponseType^ AddTransactionConfirmationItem(
    AddTransactionConfirmationItemRequestType^ AddTransactionConfirmationItemRequest
)
Parameters
AddTransactionConfirmationItemRequest (AddTransactionConfirmationItemRequestType)
Remarks


BeginAddDispute Method (AddDisputeRequest, callback, asyncState)

BeginAddDispute Method (AddDisputeRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddDispute(AddDisputeRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddDispute(
    AddDisputeRequestType AddDisputeRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddDispute ( _
    AddDisputeRequest As AddDisputeRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddDispute(
    AddDisputeRequestType^ AddDisputeRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddDisputeRequest (AddDisputeRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddDisputeResponse Method (AddDisputeResponseRequest, callback, asyncState)

BeginAddDisputeResponse Method (AddDisputeResponseRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddDisputeResponse(AddDisputeResponseRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddDisputeResponse(
    AddDisputeResponseRequestType AddDisputeResponseRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddDisputeResponse ( _
    AddDisputeResponseRequest As AddDisputeResponseRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddDisputeResponse(
    AddDisputeResponseRequestType^ AddDisputeResponseRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddDisputeResponseRequest (AddDisputeResponseRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddFixedPriceItem Method (AddFixedPriceItemRequest, callback, asyncState)

BeginAddFixedPriceItem Method (AddFixedPriceItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddFixedPriceItem(AddFixedPriceItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddFixedPriceItem(
    AddFixedPriceItemRequestType AddFixedPriceItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddFixedPriceItem ( _
    AddFixedPriceItemRequest As AddFixedPriceItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddFixedPriceItem(
    AddFixedPriceItemRequestType^ AddFixedPriceItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddFixedPriceItemRequest (AddFixedPriceItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddItem Method (AddItemRequest, callback, asyncState)

BeginAddItem Method (AddItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddItem(AddItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddItem(
    AddItemRequestType AddItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddItem ( _
    AddItemRequest As AddItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddItem(
    AddItemRequestType^ AddItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddItemRequest (AddItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddItemFromSellingManagerTemplate Method (AddItemFromSellingManagerTemplateRequest, callback, asyncState)

BeginAddItemFromSellingManagerTemplate Method (AddItemFromSellingManagerTemplateRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddItemFromSellingManagerTemplate(AddItemFromSellingManagerTemplateRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddItemFromSellingManagerTemplate(
    AddItemFromSellingManagerTemplateRequestType AddItemFromSellingManagerTemplateRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddItemFromSellingManagerTemplate ( _
    AddItemFromSellingManagerTemplateRequest As AddItemFromSellingManagerTemplateRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddItemFromSellingManagerTemplate(
    AddItemFromSellingManagerTemplateRequestType^ AddItemFromSellingManagerTemplateRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddItemFromSellingManagerTemplateRequest (AddItemFromSellingManagerTemplateRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddItems Method (AddItemsRequest, callback, asyncState)

BeginAddItems Method (AddItemsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddItems(AddItemsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddItems(
    AddItemsRequestType AddItemsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddItems ( _
    AddItemsRequest As AddItemsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddItems(
    AddItemsRequestType^ AddItemsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddItemsRequest (AddItemsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddMemberMessageAAQToPartner Method (AddMemberMessageAAQToPartnerRequest, callback, asyncState)

BeginAddMemberMessageAAQToPartner Method (AddMemberMessageAAQToPartnerRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddMemberMessageAAQToPartner(AddMemberMessageAAQToPartnerRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddMemberMessageAAQToPartner(
    AddMemberMessageAAQToPartnerRequestType AddMemberMessageAAQToPartnerRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddMemberMessageAAQToPartner ( _
    AddMemberMessageAAQToPartnerRequest As AddMemberMessageAAQToPartnerRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddMemberMessageAAQToPartner(
    AddMemberMessageAAQToPartnerRequestType^ AddMemberMessageAAQToPartnerRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddMemberMessageAAQToPartnerRequest (AddMemberMessageAAQToPartnerRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddMemberMessageRTQ Method (AddMemberMessageRTQRequest, callback, asyncState)

BeginAddMemberMessageRTQ Method (AddMemberMessageRTQRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddMemberMessageRTQ(AddMemberMessageRTQRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddMemberMessageRTQ(
    AddMemberMessageRTQRequestType AddMemberMessageRTQRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddMemberMessageRTQ ( _
    AddMemberMessageRTQRequest As AddMemberMessageRTQRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddMemberMessageRTQ(
    AddMemberMessageRTQRequestType^ AddMemberMessageRTQRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddMemberMessageRTQRequest (AddMemberMessageRTQRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddMemberMessagesAAQToBidder Method (AddMemberMessagesAAQToBidderRequest, callback, asyncState)

BeginAddMemberMessagesAAQToBidder Method (AddMemberMessagesAAQToBidderRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddMemberMessagesAAQToBidder(AddMemberMessagesAAQToBidderRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddMemberMessagesAAQToBidder(
    AddMemberMessagesAAQToBidderRequestType AddMemberMessagesAAQToBidderRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddMemberMessagesAAQToBidder ( _
    AddMemberMessagesAAQToBidderRequest As AddMemberMessagesAAQToBidderRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddMemberMessagesAAQToBidder(
    AddMemberMessagesAAQToBidderRequestType^ AddMemberMessagesAAQToBidderRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddMemberMessagesAAQToBidderRequest (AddMemberMessagesAAQToBidderRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddOrder Method (AddOrderRequest, callback, asyncState)

BeginAddOrder Method (AddOrderRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddOrder(AddOrderRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddOrder(
    AddOrderRequestType AddOrderRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddOrder ( _
    AddOrderRequest As AddOrderRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddOrder(
    AddOrderRequestType^ AddOrderRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddOrderRequest (AddOrderRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddSecondChanceItem Method (AddSecondChanceItemRequest, callback, asyncState)

BeginAddSecondChanceItem Method (AddSecondChanceItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddSecondChanceItem(AddSecondChanceItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddSecondChanceItem(
    AddSecondChanceItemRequestType AddSecondChanceItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddSecondChanceItem ( _
    AddSecondChanceItemRequest As AddSecondChanceItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddSecondChanceItem(
    AddSecondChanceItemRequestType^ AddSecondChanceItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddSecondChanceItemRequest (AddSecondChanceItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddSellingManagerInventoryFolder Method (AddSellingManagerInventoryFolderRequest, callback, asyncState)

BeginAddSellingManagerInventoryFolder Method (AddSellingManagerInventoryFolderRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddSellingManagerInventoryFolder(AddSellingManagerInventoryFolderRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddSellingManagerInventoryFolder(
    AddSellingManagerInventoryFolderRequestType AddSellingManagerInventoryFolderRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddSellingManagerInventoryFolder ( _
    AddSellingManagerInventoryFolderRequest As AddSellingManagerInventoryFolderRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddSellingManagerInventoryFolder(
    AddSellingManagerInventoryFolderRequestType^ AddSellingManagerInventoryFolderRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddSellingManagerInventoryFolderRequest (AddSellingManagerInventoryFolderRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddSellingManagerProduct Method (AddSellingManagerProductRequest, callback, asyncState)

BeginAddSellingManagerProduct Method (AddSellingManagerProductRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddSellingManagerProduct(AddSellingManagerProductRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddSellingManagerProduct(
    AddSellingManagerProductRequestType AddSellingManagerProductRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddSellingManagerProduct ( _
    AddSellingManagerProductRequest As AddSellingManagerProductRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddSellingManagerProduct(
    AddSellingManagerProductRequestType^ AddSellingManagerProductRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddSellingManagerProductRequest (AddSellingManagerProductRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddSellingManagerTemplate Method (AddSellingManagerTemplateRequest, callback, asyncState)

BeginAddSellingManagerTemplate Method (AddSellingManagerTemplateRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddSellingManagerTemplate(AddSellingManagerTemplateRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddSellingManagerTemplate(
    AddSellingManagerTemplateRequestType AddSellingManagerTemplateRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddSellingManagerTemplate ( _
    AddSellingManagerTemplateRequest As AddSellingManagerTemplateRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddSellingManagerTemplate(
    AddSellingManagerTemplateRequestType^ AddSellingManagerTemplateRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddSellingManagerTemplateRequest (AddSellingManagerTemplateRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddToItemDescription Method (AddToItemDescriptionRequest, callback, asyncState)

BeginAddToItemDescription Method (AddToItemDescriptionRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddToItemDescription(AddToItemDescriptionRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddToItemDescription(
    AddToItemDescriptionRequestType AddToItemDescriptionRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddToItemDescription ( _
    AddToItemDescriptionRequest As AddToItemDescriptionRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddToItemDescription(
    AddToItemDescriptionRequestType^ AddToItemDescriptionRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddToItemDescriptionRequest (AddToItemDescriptionRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddToWatchList Method (AddToWatchListRequest, callback, asyncState)

BeginAddToWatchList Method (AddToWatchListRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddToWatchList(AddToWatchListRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddToWatchList(
    AddToWatchListRequestType AddToWatchListRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddToWatchList ( _
    AddToWatchListRequest As AddToWatchListRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddToWatchList(
    AddToWatchListRequestType^ AddToWatchListRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddToWatchListRequest (AddToWatchListRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginAddTransactionConfirmationItem Method (AddTransactionConfirmationItemRequest, callback, asyncState)

BeginAddTransactionConfirmationItem Method (AddTransactionConfirmationItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginAddTransactionConfirmationItem(AddTransactionConfirmationItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginAddTransactionConfirmationItem(
    AddTransactionConfirmationItemRequestType AddTransactionConfirmationItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginAddTransactionConfirmationItem ( _
    AddTransactionConfirmationItemRequest As AddTransactionConfirmationItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginAddTransactionConfirmationItem(
    AddTransactionConfirmationItemRequestType^ AddTransactionConfirmationItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
AddTransactionConfirmationItemRequest (AddTransactionConfirmationItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginCompleteSale Method (CompleteSaleRequest, callback, asyncState)

BeginCompleteSale Method (CompleteSaleRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginCompleteSale(CompleteSaleRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginCompleteSale(
    CompleteSaleRequestType CompleteSaleRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginCompleteSale ( _
    CompleteSaleRequest As CompleteSaleRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginCompleteSale(
    CompleteSaleRequestType^ CompleteSaleRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
CompleteSaleRequest (CompleteSaleRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginConfirmIdentity Method (ConfirmIdentityRequest, callback, asyncState)

BeginConfirmIdentity Method (ConfirmIdentityRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginConfirmIdentity(ConfirmIdentityRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginConfirmIdentity(
    ConfirmIdentityRequestType ConfirmIdentityRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginConfirmIdentity ( _
    ConfirmIdentityRequest As ConfirmIdentityRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginConfirmIdentity(
    ConfirmIdentityRequestType^ ConfirmIdentityRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ConfirmIdentityRequest (ConfirmIdentityRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDeleteMyMessages Method (DeleteMyMessagesRequest, callback, asyncState)

BeginDeleteMyMessages Method (DeleteMyMessagesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginDeleteMyMessages(DeleteMyMessagesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginDeleteMyMessages(
    DeleteMyMessagesRequestType DeleteMyMessagesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginDeleteMyMessages ( _
    DeleteMyMessagesRequest As DeleteMyMessagesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginDeleteMyMessages(
    DeleteMyMessagesRequestType^ DeleteMyMessagesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
DeleteMyMessagesRequest (DeleteMyMessagesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDeleteSellingManagerInventoryFolder Method (DeleteSellingManagerInventoryFolderRequest, callback, asyncState)

BeginDeleteSellingManagerInventoryFolder Method (DeleteSellingManagerInventoryFolderRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginDeleteSellingManagerInventoryFolder(DeleteSellingManagerInventoryFolderRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginDeleteSellingManagerInventoryFolder(
    DeleteSellingManagerInventoryFolderRequestType DeleteSellingManagerInventoryFolderRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginDeleteSellingManagerInventoryFolder ( _
    DeleteSellingManagerInventoryFolderRequest As DeleteSellingManagerInventoryFolderRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginDeleteSellingManagerInventoryFolder(
    DeleteSellingManagerInventoryFolderRequestType^ DeleteSellingManagerInventoryFolderRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
DeleteSellingManagerInventoryFolderRequest (DeleteSellingManagerInventoryFolderRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDeleteSellingManagerItemAutomationRule Method (DeleteSellingManagerItemAutomationRuleRequest, callback, asyncState)

BeginDeleteSellingManagerItemAutomationRule Method (DeleteSellingManagerItemAutomationRuleRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginDeleteSellingManagerItemAutomationRule(DeleteSellingManagerItemAutomationRuleRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginDeleteSellingManagerItemAutomationRule(
    DeleteSellingManagerItemAutomationRuleRequestType DeleteSellingManagerItemAutomationRuleRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginDeleteSellingManagerItemAutomationRule ( _
    DeleteSellingManagerItemAutomationRuleRequest As DeleteSellingManagerItemAutomationRuleRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginDeleteSellingManagerItemAutomationRule(
    DeleteSellingManagerItemAutomationRuleRequestType^ DeleteSellingManagerItemAutomationRuleRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
DeleteSellingManagerItemAutomationRuleRequest (DeleteSellingManagerItemAutomationRuleRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDeleteSellingManagerProduct Method (DeleteSellingManagerProductRequest, callback, asyncState)

BeginDeleteSellingManagerProduct Method (DeleteSellingManagerProductRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginDeleteSellingManagerProduct(DeleteSellingManagerProductRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginDeleteSellingManagerProduct(
    DeleteSellingManagerProductRequestType DeleteSellingManagerProductRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginDeleteSellingManagerProduct ( _
    DeleteSellingManagerProductRequest As DeleteSellingManagerProductRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginDeleteSellingManagerProduct(
    DeleteSellingManagerProductRequestType^ DeleteSellingManagerProductRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
DeleteSellingManagerProductRequest (DeleteSellingManagerProductRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDeleteSellingManagerTemplate Method (DeleteSellingManagerTemplateRequest, callback, asyncState)

BeginDeleteSellingManagerTemplate Method (DeleteSellingManagerTemplateRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginDeleteSellingManagerTemplate(DeleteSellingManagerTemplateRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginDeleteSellingManagerTemplate(
    DeleteSellingManagerTemplateRequestType DeleteSellingManagerTemplateRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginDeleteSellingManagerTemplate ( _
    DeleteSellingManagerTemplateRequest As DeleteSellingManagerTemplateRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginDeleteSellingManagerTemplate(
    DeleteSellingManagerTemplateRequestType^ DeleteSellingManagerTemplateRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
DeleteSellingManagerTemplateRequest (DeleteSellingManagerTemplateRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDeleteSellingManagerTemplateAutomationRule Method (DeleteSellingManagerTemplateAutomationRuleRequest, callback, asyncState)

BeginDeleteSellingManagerTemplateAutomationRule Method (DeleteSellingManagerTemplateAutomationRuleRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginDeleteSellingManagerTemplateAutomationRule(DeleteSellingManagerTemplateAutomationRuleRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginDeleteSellingManagerTemplateAutomationRule(
    DeleteSellingManagerTemplateAutomationRuleRequestType DeleteSellingManagerTemplateAutomationRuleRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginDeleteSellingManagerTemplateAutomationRule ( _
    DeleteSellingManagerTemplateAutomationRuleRequest As DeleteSellingManagerTemplateAutomationRuleRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginDeleteSellingManagerTemplateAutomationRule(
    DeleteSellingManagerTemplateAutomationRuleRequestType^ DeleteSellingManagerTemplateAutomationRuleRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
DeleteSellingManagerTemplateAutomationRuleRequest (DeleteSellingManagerTemplateAutomationRuleRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginDisableUnpaidItemAssistance Method (DisableUnpaidItemAssistanceRequest, callback, asyncState)

BeginDisableUnpaidItemAssistance Method (DisableUnpaidItemAssistanceRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginDisableUnpaidItemAssistance(DisableUnpaidItemAssistanceRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginDisableUnpaidItemAssistance(
    DisableUnpaidItemAssistanceRequestType DisableUnpaidItemAssistanceRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginDisableUnpaidItemAssistance ( _
    DisableUnpaidItemAssistanceRequest As DisableUnpaidItemAssistanceRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginDisableUnpaidItemAssistance(
    DisableUnpaidItemAssistanceRequestType^ DisableUnpaidItemAssistanceRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
DisableUnpaidItemAssistanceRequest (DisableUnpaidItemAssistanceRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginEndFixedPriceItem Method (EndFixedPriceItemRequest, callback, asyncState)

BeginEndFixedPriceItem Method (EndFixedPriceItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginEndFixedPriceItem(EndFixedPriceItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginEndFixedPriceItem(
    EndFixedPriceItemRequestType EndFixedPriceItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginEndFixedPriceItem ( _
    EndFixedPriceItemRequest As EndFixedPriceItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginEndFixedPriceItem(
    EndFixedPriceItemRequestType^ EndFixedPriceItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
EndFixedPriceItemRequest (EndFixedPriceItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginEndItem Method (EndItemRequest, callback, asyncState)

BeginEndItem Method (EndItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginEndItem(EndItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginEndItem(
    EndItemRequestType EndItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginEndItem ( _
    EndItemRequest As EndItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginEndItem(
    EndItemRequestType^ EndItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
EndItemRequest (EndItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginEndItems Method (EndItemsRequest, callback, asyncState)

BeginEndItems Method (EndItemsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginEndItems(EndItemsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginEndItems(
    EndItemsRequestType EndItemsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginEndItems ( _
    EndItemsRequest As EndItemsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginEndItems(
    EndItemsRequestType^ EndItemsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
EndItemsRequest (EndItemsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginExtendSiteHostedPictures Method (ExtendSiteHostedPicturesRequest, callback, asyncState)

BeginExtendSiteHostedPictures Method (ExtendSiteHostedPicturesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginExtendSiteHostedPictures(ExtendSiteHostedPicturesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginExtendSiteHostedPictures(
    ExtendSiteHostedPicturesRequestType ExtendSiteHostedPicturesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginExtendSiteHostedPictures ( _
    ExtendSiteHostedPicturesRequest As ExtendSiteHostedPicturesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginExtendSiteHostedPictures(
    ExtendSiteHostedPicturesRequestType^ ExtendSiteHostedPicturesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ExtendSiteHostedPicturesRequest (ExtendSiteHostedPicturesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginFetchToken Method (FetchTokenRequest, callback, asyncState)

BeginFetchToken Method (FetchTokenRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginFetchToken(FetchTokenRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginFetchToken(
    FetchTokenRequestType FetchTokenRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginFetchToken ( _
    FetchTokenRequest As FetchTokenRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginFetchToken(
    FetchTokenRequestType^ FetchTokenRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
FetchTokenRequest (FetchTokenRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetAccount Method (GetAccountRequest, callback, asyncState)

BeginGetAccount Method (GetAccountRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetAccount(GetAccountRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetAccount(
    GetAccountRequestType GetAccountRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetAccount ( _
    GetAccountRequest As GetAccountRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetAccount(
    GetAccountRequestType^ GetAccountRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetAccountRequest (GetAccountRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetAdFormatLeads Method (GetAdFormatLeadsRequest, callback, asyncState)

BeginGetAdFormatLeads Method (GetAdFormatLeadsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetAdFormatLeads(GetAdFormatLeadsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetAdFormatLeads(
    GetAdFormatLeadsRequestType GetAdFormatLeadsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetAdFormatLeads ( _
    GetAdFormatLeadsRequest As GetAdFormatLeadsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetAdFormatLeads(
    GetAdFormatLeadsRequestType^ GetAdFormatLeadsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetAdFormatLeadsRequest (GetAdFormatLeadsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetAllBidders Method (GetAllBiddersRequest, callback, asyncState)

BeginGetAllBidders Method (GetAllBiddersRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetAllBidders(GetAllBiddersRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetAllBidders(
    GetAllBiddersRequestType GetAllBiddersRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetAllBidders ( _
    GetAllBiddersRequest As GetAllBiddersRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetAllBidders(
    GetAllBiddersRequestType^ GetAllBiddersRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetAllBiddersRequest (GetAllBiddersRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetApiAccessRules Method (GetApiAccessRulesRequest, callback, asyncState)

BeginGetApiAccessRules Method (GetApiAccessRulesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetApiAccessRules(GetApiAccessRulesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetApiAccessRules(
    GetApiAccessRulesRequestType GetApiAccessRulesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetApiAccessRules ( _
    GetApiAccessRulesRequest As GetApiAccessRulesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetApiAccessRules(
    GetApiAccessRulesRequestType^ GetApiAccessRulesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetApiAccessRulesRequest (GetApiAccessRulesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetBestOffers Method (GetBestOffersRequest, callback, asyncState)

BeginGetBestOffers Method (GetBestOffersRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetBestOffers(GetBestOffersRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetBestOffers(
    GetBestOffersRequestType GetBestOffersRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetBestOffers ( _
    GetBestOffersRequest As GetBestOffersRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetBestOffers(
    GetBestOffersRequestType^ GetBestOffersRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetBestOffersRequest (GetBestOffersRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetBidderList Method (GetBidderListRequest, callback, asyncState)

BeginGetBidderList Method (GetBidderListRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetBidderList(GetBidderListRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetBidderList(
    GetBidderListRequestType GetBidderListRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetBidderList ( _
    GetBidderListRequest As GetBidderListRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetBidderList(
    GetBidderListRequestType^ GetBidderListRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetBidderListRequest (GetBidderListRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetCategories Method (GetCategoriesRequest, callback, asyncState)

BeginGetCategories Method (GetCategoriesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetCategories(GetCategoriesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetCategories(
    GetCategoriesRequestType GetCategoriesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetCategories ( _
    GetCategoriesRequest As GetCategoriesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetCategories(
    GetCategoriesRequestType^ GetCategoriesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetCategoriesRequest (GetCategoriesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetCategoryFeatures Method (GetCategoryFeaturesRequest, callback, asyncState)

BeginGetCategoryFeatures Method (GetCategoryFeaturesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetCategoryFeatures(GetCategoryFeaturesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetCategoryFeatures(
    GetCategoryFeaturesRequestType GetCategoryFeaturesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetCategoryFeatures ( _
    GetCategoryFeaturesRequest As GetCategoryFeaturesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetCategoryFeatures(
    GetCategoryFeaturesRequestType^ GetCategoryFeaturesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetCategoryFeaturesRequest (GetCategoryFeaturesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetCategoryMappings Method (GetCategoryMappingsRequest, callback, asyncState)

BeginGetCategoryMappings Method (GetCategoryMappingsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetCategoryMappings(GetCategoryMappingsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetCategoryMappings(
    GetCategoryMappingsRequestType GetCategoryMappingsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetCategoryMappings ( _
    GetCategoryMappingsRequest As GetCategoryMappingsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetCategoryMappings(
    GetCategoryMappingsRequestType^ GetCategoryMappingsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetCategoryMappingsRequest (GetCategoryMappingsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetCategorySpecifics Method (GetCategorySpecificsRequest, callback, asyncState)

BeginGetCategorySpecifics Method (GetCategorySpecificsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetCategorySpecifics(GetCategorySpecificsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetCategorySpecifics(
    GetCategorySpecificsRequestType GetCategorySpecificsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetCategorySpecifics ( _
    GetCategorySpecificsRequest As GetCategorySpecificsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetCategorySpecifics(
    GetCategorySpecificsRequestType^ GetCategorySpecificsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetCategorySpecificsRequest (GetCategorySpecificsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetChallengeToken Method (GetChallengeTokenRequest, callback, asyncState)

BeginGetChallengeToken Method (GetChallengeTokenRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetChallengeToken(GetChallengeTokenRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetChallengeToken(
    GetChallengeTokenRequestType GetChallengeTokenRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetChallengeToken ( _
    GetChallengeTokenRequest As GetChallengeTokenRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetChallengeToken(
    GetChallengeTokenRequestType^ GetChallengeTokenRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetChallengeTokenRequest (GetChallengeTokenRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetCharities Method (GetCharitiesRequest, callback, asyncState)

BeginGetCharities Method (GetCharitiesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetCharities(GetCharitiesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetCharities(
    GetCharitiesRequestType GetCharitiesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetCharities ( _
    GetCharitiesRequest As GetCharitiesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetCharities(
    GetCharitiesRequestType^ GetCharitiesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetCharitiesRequest (GetCharitiesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetClientAlertsAuthToken Method (GetClientAlertsAuthTokenRequest, callback, asyncState)

BeginGetClientAlertsAuthToken Method (GetClientAlertsAuthTokenRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetClientAlertsAuthToken(GetClientAlertsAuthTokenRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetClientAlertsAuthToken(
    GetClientAlertsAuthTokenRequestType GetClientAlertsAuthTokenRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetClientAlertsAuthToken ( _
    GetClientAlertsAuthTokenRequest As GetClientAlertsAuthTokenRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetClientAlertsAuthToken(
    GetClientAlertsAuthTokenRequestType^ GetClientAlertsAuthTokenRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetClientAlertsAuthTokenRequest (GetClientAlertsAuthTokenRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetContextualKeywords Method (GetContextualKeywordsRequest, callback, asyncState)

BeginGetContextualKeywords Method (GetContextualKeywordsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetContextualKeywords(GetContextualKeywordsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetContextualKeywords(
    GetContextualKeywordsRequestType GetContextualKeywordsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetContextualKeywords ( _
    GetContextualKeywordsRequest As GetContextualKeywordsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetContextualKeywords(
    GetContextualKeywordsRequestType^ GetContextualKeywordsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetContextualKeywordsRequest (GetContextualKeywordsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetDescriptionTemplates Method (GetDescriptionTemplatesRequest, callback, asyncState)

BeginGetDescriptionTemplates Method (GetDescriptionTemplatesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetDescriptionTemplates(GetDescriptionTemplatesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetDescriptionTemplates(
    GetDescriptionTemplatesRequestType GetDescriptionTemplatesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetDescriptionTemplates ( _
    GetDescriptionTemplatesRequest As GetDescriptionTemplatesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetDescriptionTemplates(
    GetDescriptionTemplatesRequestType^ GetDescriptionTemplatesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetDescriptionTemplatesRequest (GetDescriptionTemplatesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetDispute Method (GetDisputeRequest, callback, asyncState)

BeginGetDispute Method (GetDisputeRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetDispute(GetDisputeRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetDispute(
    GetDisputeRequestType GetDisputeRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetDispute ( _
    GetDisputeRequest As GetDisputeRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetDispute(
    GetDisputeRequestType^ GetDisputeRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetDisputeRequest (GetDisputeRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGeteBayDetails Method (GeteBayDetailsRequest, callback, asyncState)

BeginGeteBayDetails Method (GeteBayDetailsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGeteBayDetails(GeteBayDetailsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGeteBayDetails(
    GeteBayDetailsRequestType GeteBayDetailsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGeteBayDetails ( _
    GeteBayDetailsRequest As GeteBayDetailsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGeteBayDetails(
    GeteBayDetailsRequestType^ GeteBayDetailsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GeteBayDetailsRequest (GeteBayDetailsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGeteBayOfficialTime Method (GeteBayOfficialTimeRequest, callback, asyncState)

BeginGeteBayOfficialTime Method (GeteBayOfficialTimeRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGeteBayOfficialTime(GeteBayOfficialTimeRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGeteBayOfficialTime(
    GeteBayOfficialTimeRequestType GeteBayOfficialTimeRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGeteBayOfficialTime ( _
    GeteBayOfficialTimeRequest As GeteBayOfficialTimeRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGeteBayOfficialTime(
    GeteBayOfficialTimeRequestType^ GeteBayOfficialTimeRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GeteBayOfficialTimeRequest (GeteBayOfficialTimeRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetFeedback Method (GetFeedbackRequest, callback, asyncState)

BeginGetFeedback Method (GetFeedbackRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetFeedback(GetFeedbackRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetFeedback(
    GetFeedbackRequestType GetFeedbackRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetFeedback ( _
    GetFeedbackRequest As GetFeedbackRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetFeedback(
    GetFeedbackRequestType^ GetFeedbackRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetFeedbackRequest (GetFeedbackRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItem Method (GetItemRequest, callback, asyncState)

BeginGetItem Method (GetItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetItem(GetItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetItem(
    GetItemRequestType GetItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetItem ( _
    GetItemRequest As GetItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetItem(
    GetItemRequestType^ GetItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetItemRequest (GetItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemsAwaitingFeedback Method (GetItemsAwaitingFeedbackRequest, callback, asyncState)

BeginGetItemsAwaitingFeedback Method (GetItemsAwaitingFeedbackRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetItemsAwaitingFeedback(GetItemsAwaitingFeedbackRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetItemsAwaitingFeedback(
    GetItemsAwaitingFeedbackRequestType GetItemsAwaitingFeedbackRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetItemsAwaitingFeedback ( _
    GetItemsAwaitingFeedbackRequest As GetItemsAwaitingFeedbackRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetItemsAwaitingFeedback(
    GetItemsAwaitingFeedbackRequestType^ GetItemsAwaitingFeedbackRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetItemsAwaitingFeedbackRequest (GetItemsAwaitingFeedbackRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemShipping Method (GetItemShippingRequest, callback, asyncState)

BeginGetItemShipping Method (GetItemShippingRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetItemShipping(GetItemShippingRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetItemShipping(
    GetItemShippingRequestType GetItemShippingRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetItemShipping ( _
    GetItemShippingRequest As GetItemShippingRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetItemShipping(
    GetItemShippingRequestType^ GetItemShippingRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetItemShippingRequest (GetItemShippingRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetItemTransactions Method (GetItemTransactionsRequest, callback, asyncState)

BeginGetItemTransactions Method (GetItemTransactionsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetItemTransactions(GetItemTransactionsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetItemTransactions(
    GetItemTransactionsRequestType GetItemTransactionsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetItemTransactions ( _
    GetItemTransactionsRequest As GetItemTransactionsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetItemTransactions(
    GetItemTransactionsRequestType^ GetItemTransactionsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetItemTransactionsRequest (GetItemTransactionsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetMemberMessages Method (GetMemberMessagesRequest, callback, asyncState)

BeginGetMemberMessages Method (GetMemberMessagesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetMemberMessages(GetMemberMessagesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetMemberMessages(
    GetMemberMessagesRequestType GetMemberMessagesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetMemberMessages ( _
    GetMemberMessagesRequest As GetMemberMessagesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetMemberMessages(
    GetMemberMessagesRequestType^ GetMemberMessagesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetMemberMessagesRequest (GetMemberMessagesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetMessagePreferences Method (GetMessagePreferencesRequest, callback, asyncState)

BeginGetMessagePreferences Method (GetMessagePreferencesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetMessagePreferences(GetMessagePreferencesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetMessagePreferences(
    GetMessagePreferencesRequestType GetMessagePreferencesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetMessagePreferences ( _
    GetMessagePreferencesRequest As GetMessagePreferencesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetMessagePreferences(
    GetMessagePreferencesRequestType^ GetMessagePreferencesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetMessagePreferencesRequest (GetMessagePreferencesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetMyeBayBuying Method (GetMyeBayBuyingRequest, callback, asyncState)

BeginGetMyeBayBuying Method (GetMyeBayBuyingRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetMyeBayBuying(GetMyeBayBuyingRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetMyeBayBuying(
    GetMyeBayBuyingRequestType GetMyeBayBuyingRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetMyeBayBuying ( _
    GetMyeBayBuyingRequest As GetMyeBayBuyingRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetMyeBayBuying(
    GetMyeBayBuyingRequestType^ GetMyeBayBuyingRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetMyeBayBuyingRequest (GetMyeBayBuyingRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetMyeBayReminders Method (GetMyeBayRemindersRequest, callback, asyncState)

BeginGetMyeBayReminders Method (GetMyeBayRemindersRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetMyeBayReminders(GetMyeBayRemindersRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetMyeBayReminders(
    GetMyeBayRemindersRequestType GetMyeBayRemindersRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetMyeBayReminders ( _
    GetMyeBayRemindersRequest As GetMyeBayRemindersRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetMyeBayReminders(
    GetMyeBayRemindersRequestType^ GetMyeBayRemindersRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetMyeBayRemindersRequest (GetMyeBayRemindersRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetMyeBaySelling Method (GetMyeBaySellingRequest, callback, asyncState)

BeginGetMyeBaySelling Method (GetMyeBaySellingRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetMyeBaySelling(GetMyeBaySellingRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetMyeBaySelling(
    GetMyeBaySellingRequestType GetMyeBaySellingRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetMyeBaySelling ( _
    GetMyeBaySellingRequest As GetMyeBaySellingRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetMyeBaySelling(
    GetMyeBaySellingRequestType^ GetMyeBaySellingRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetMyeBaySellingRequest (GetMyeBaySellingRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetMyMessages Method (GetMyMessagesRequest, callback, asyncState)

BeginGetMyMessages Method (GetMyMessagesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetMyMessages(GetMyMessagesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetMyMessages(
    GetMyMessagesRequestType GetMyMessagesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetMyMessages ( _
    GetMyMessagesRequest As GetMyMessagesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetMyMessages(
    GetMyMessagesRequestType^ GetMyMessagesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetMyMessagesRequest (GetMyMessagesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetNotificationPreferences Method (GetNotificationPreferencesRequest, callback, asyncState)

BeginGetNotificationPreferences Method (GetNotificationPreferencesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetNotificationPreferences(GetNotificationPreferencesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetNotificationPreferences(
    GetNotificationPreferencesRequestType GetNotificationPreferencesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetNotificationPreferences ( _
    GetNotificationPreferencesRequest As GetNotificationPreferencesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetNotificationPreferences(
    GetNotificationPreferencesRequestType^ GetNotificationPreferencesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetNotificationPreferencesRequest (GetNotificationPreferencesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetNotificationsUsage Method (GetNotificationsUsageRequest, callback, asyncState)

BeginGetNotificationsUsage Method (GetNotificationsUsageRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetNotificationsUsage(GetNotificationsUsageRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetNotificationsUsage(
    GetNotificationsUsageRequestType GetNotificationsUsageRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetNotificationsUsage ( _
    GetNotificationsUsageRequest As GetNotificationsUsageRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetNotificationsUsage(
    GetNotificationsUsageRequestType^ GetNotificationsUsageRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetNotificationsUsageRequest (GetNotificationsUsageRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetOrders Method (GetOrdersRequest, callback, asyncState)

BeginGetOrders Method (GetOrdersRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetOrders(GetOrdersRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetOrders(
    GetOrdersRequestType GetOrdersRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetOrders ( _
    GetOrdersRequest As GetOrdersRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetOrders(
    GetOrdersRequestType^ GetOrdersRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetOrdersRequest (GetOrdersRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetOrderTransactions Method (GetOrderTransactionsRequest, callback, asyncState)

BeginGetOrderTransactions Method (GetOrderTransactionsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetOrderTransactions(GetOrderTransactionsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetOrderTransactions(
    GetOrderTransactionsRequestType GetOrderTransactionsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetOrderTransactions ( _
    GetOrderTransactionsRequest As GetOrderTransactionsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetOrderTransactions(
    GetOrderTransactionsRequestType^ GetOrderTransactionsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetOrderTransactionsRequest (GetOrderTransactionsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetProductSellingPages Method (GetProductSellingPagesRequest, callback, asyncState)

BeginGetProductSellingPages Method (GetProductSellingPagesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetProductSellingPages(GetProductSellingPagesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetProductSellingPages(
    GetProductSellingPagesRequestType GetProductSellingPagesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetProductSellingPages ( _
    GetProductSellingPagesRequest As GetProductSellingPagesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetProductSellingPages(
    GetProductSellingPagesRequestType^ GetProductSellingPagesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetProductSellingPagesRequest (GetProductSellingPagesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetPromotionalSaleDetails Method (GetPromotionalSaleDetailsRequest, callback, asyncState)

BeginGetPromotionalSaleDetails Method (GetPromotionalSaleDetailsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetPromotionalSaleDetails(GetPromotionalSaleDetailsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetPromotionalSaleDetails(
    GetPromotionalSaleDetailsRequestType GetPromotionalSaleDetailsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetPromotionalSaleDetails ( _
    GetPromotionalSaleDetailsRequest As GetPromotionalSaleDetailsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetPromotionalSaleDetails(
    GetPromotionalSaleDetailsRequestType^ GetPromotionalSaleDetailsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetPromotionalSaleDetailsRequest (GetPromotionalSaleDetailsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellerDashboard Method (GetSellerDashboardRequest, callback, asyncState)

BeginGetSellerDashboard Method (GetSellerDashboardRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellerDashboard(GetSellerDashboardRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellerDashboard(
    GetSellerDashboardRequestType GetSellerDashboardRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellerDashboard ( _
    GetSellerDashboardRequest As GetSellerDashboardRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellerDashboard(
    GetSellerDashboardRequestType^ GetSellerDashboardRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellerDashboardRequest (GetSellerDashboardRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellerEvents Method (GetSellerEventsRequest, callback, asyncState)

BeginGetSellerEvents Method (GetSellerEventsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellerEvents(GetSellerEventsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellerEvents(
    GetSellerEventsRequestType GetSellerEventsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellerEvents ( _
    GetSellerEventsRequest As GetSellerEventsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellerEvents(
    GetSellerEventsRequestType^ GetSellerEventsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellerEventsRequest (GetSellerEventsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellerList Method (GetSellerListRequest, callback, asyncState)

BeginGetSellerList Method (GetSellerListRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellerList(GetSellerListRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellerList(
    GetSellerListRequestType GetSellerListRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellerList ( _
    GetSellerListRequest As GetSellerListRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellerList(
    GetSellerListRequestType^ GetSellerListRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellerListRequest (GetSellerListRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellerPayments Method (GetSellerPaymentsRequest, callback, asyncState)

BeginGetSellerPayments Method (GetSellerPaymentsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellerPayments(GetSellerPaymentsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellerPayments(
    GetSellerPaymentsRequestType GetSellerPaymentsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellerPayments ( _
    GetSellerPaymentsRequest As GetSellerPaymentsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellerPayments(
    GetSellerPaymentsRequestType^ GetSellerPaymentsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellerPaymentsRequest (GetSellerPaymentsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellerTransactions Method (GetSellerTransactionsRequest, callback, asyncState)

BeginGetSellerTransactions Method (GetSellerTransactionsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellerTransactions(GetSellerTransactionsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellerTransactions(
    GetSellerTransactionsRequestType GetSellerTransactionsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellerTransactions ( _
    GetSellerTransactionsRequest As GetSellerTransactionsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellerTransactions(
    GetSellerTransactionsRequestType^ GetSellerTransactionsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellerTransactionsRequest (GetSellerTransactionsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellingManagerAlerts Method (GetSellingManagerAlertsRequest, callback, asyncState)

BeginGetSellingManagerAlerts Method (GetSellingManagerAlertsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellingManagerAlerts(GetSellingManagerAlertsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellingManagerAlerts(
    GetSellingManagerAlertsRequestType GetSellingManagerAlertsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellingManagerAlerts ( _
    GetSellingManagerAlertsRequest As GetSellingManagerAlertsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellingManagerAlerts(
    GetSellingManagerAlertsRequestType^ GetSellingManagerAlertsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellingManagerAlertsRequest (GetSellingManagerAlertsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellingManagerEmailLog Method (GetSellingManagerEmailLogRequest, callback, asyncState)

BeginGetSellingManagerEmailLog Method (GetSellingManagerEmailLogRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellingManagerEmailLog(GetSellingManagerEmailLogRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellingManagerEmailLog(
    GetSellingManagerEmailLogRequestType GetSellingManagerEmailLogRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellingManagerEmailLog ( _
    GetSellingManagerEmailLogRequest As GetSellingManagerEmailLogRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellingManagerEmailLog(
    GetSellingManagerEmailLogRequestType^ GetSellingManagerEmailLogRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellingManagerEmailLogRequest (GetSellingManagerEmailLogRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellingManagerInventory Method (GetSellingManagerInventoryRequest, callback, asyncState)

BeginGetSellingManagerInventory Method (GetSellingManagerInventoryRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellingManagerInventory(GetSellingManagerInventoryRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellingManagerInventory(
    GetSellingManagerInventoryRequestType GetSellingManagerInventoryRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellingManagerInventory ( _
    GetSellingManagerInventoryRequest As GetSellingManagerInventoryRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellingManagerInventory(
    GetSellingManagerInventoryRequestType^ GetSellingManagerInventoryRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellingManagerInventoryRequest (GetSellingManagerInventoryRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellingManagerInventoryFolder Method (GetSellingManagerInventoryFolderRequest, callback, asyncState)

BeginGetSellingManagerInventoryFolder Method (GetSellingManagerInventoryFolderRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellingManagerInventoryFolder(GetSellingManagerInventoryFolderRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellingManagerInventoryFolder(
    GetSellingManagerInventoryFolderRequestType GetSellingManagerInventoryFolderRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellingManagerInventoryFolder ( _
    GetSellingManagerInventoryFolderRequest As GetSellingManagerInventoryFolderRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellingManagerInventoryFolder(
    GetSellingManagerInventoryFolderRequestType^ GetSellingManagerInventoryFolderRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellingManagerInventoryFolderRequest (GetSellingManagerInventoryFolderRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellingManagerItemAutomationRule Method (GetSellingManagerItemAutomationRuleRequest, callback, asyncState)

BeginGetSellingManagerItemAutomationRule Method (GetSellingManagerItemAutomationRuleRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellingManagerItemAutomationRule(GetSellingManagerItemAutomationRuleRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellingManagerItemAutomationRule(
    GetSellingManagerItemAutomationRuleRequestType GetSellingManagerItemAutomationRuleRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellingManagerItemAutomationRule ( _
    GetSellingManagerItemAutomationRuleRequest As GetSellingManagerItemAutomationRuleRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellingManagerItemAutomationRule(
    GetSellingManagerItemAutomationRuleRequestType^ GetSellingManagerItemAutomationRuleRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellingManagerItemAutomationRuleRequest (GetSellingManagerItemAutomationRuleRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellingManagerSaleRecord Method (GetSellingManagerSaleRecordRequest, callback, asyncState)

BeginGetSellingManagerSaleRecord Method (GetSellingManagerSaleRecordRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellingManagerSaleRecord(GetSellingManagerSaleRecordRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellingManagerSaleRecord(
    GetSellingManagerSaleRecordRequestType GetSellingManagerSaleRecordRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellingManagerSaleRecord ( _
    GetSellingManagerSaleRecordRequest As GetSellingManagerSaleRecordRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellingManagerSaleRecord(
    GetSellingManagerSaleRecordRequestType^ GetSellingManagerSaleRecordRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellingManagerSaleRecordRequest (GetSellingManagerSaleRecordRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellingManagerSoldListings Method (GetSellingManagerSoldListingsRequest, callback, asyncState)

BeginGetSellingManagerSoldListings Method (GetSellingManagerSoldListingsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellingManagerSoldListings(GetSellingManagerSoldListingsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellingManagerSoldListings(
    GetSellingManagerSoldListingsRequestType GetSellingManagerSoldListingsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellingManagerSoldListings ( _
    GetSellingManagerSoldListingsRequest As GetSellingManagerSoldListingsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellingManagerSoldListings(
    GetSellingManagerSoldListingsRequestType^ GetSellingManagerSoldListingsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellingManagerSoldListingsRequest (GetSellingManagerSoldListingsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellingManagerTemplateAutomationRule Method (GetSellingManagerTemplateAutomationRuleRequest, callback, asyncState)

BeginGetSellingManagerTemplateAutomationRule Method (GetSellingManagerTemplateAutomationRuleRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellingManagerTemplateAutomationRule(GetSellingManagerTemplateAutomationRuleRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellingManagerTemplateAutomationRule(
    GetSellingManagerTemplateAutomationRuleRequestType GetSellingManagerTemplateAutomationRuleRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellingManagerTemplateAutomationRule ( _
    GetSellingManagerTemplateAutomationRuleRequest As GetSellingManagerTemplateAutomationRuleRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellingManagerTemplateAutomationRule(
    GetSellingManagerTemplateAutomationRuleRequestType^ GetSellingManagerTemplateAutomationRuleRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellingManagerTemplateAutomationRuleRequest (GetSellingManagerTemplateAutomationRuleRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSellingManagerTemplates Method (GetSellingManagerTemplatesRequest, callback, asyncState)

BeginGetSellingManagerTemplates Method (GetSellingManagerTemplatesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSellingManagerTemplates(GetSellingManagerTemplatesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSellingManagerTemplates(
    GetSellingManagerTemplatesRequestType GetSellingManagerTemplatesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSellingManagerTemplates ( _
    GetSellingManagerTemplatesRequest As GetSellingManagerTemplatesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSellingManagerTemplates(
    GetSellingManagerTemplatesRequestType^ GetSellingManagerTemplatesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSellingManagerTemplatesRequest (GetSellingManagerTemplatesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSessionID Method (GetSessionIDRequest, callback, asyncState)

BeginGetSessionID Method (GetSessionIDRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSessionID(GetSessionIDRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSessionID(
    GetSessionIDRequestType GetSessionIDRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSessionID ( _
    GetSessionIDRequest As GetSessionIDRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSessionID(
    GetSessionIDRequestType^ GetSessionIDRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSessionIDRequest (GetSessionIDRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetShippingDiscountProfiles Method (GetShippingDiscountProfilesRequest, callback, asyncState)

BeginGetShippingDiscountProfiles Method (GetShippingDiscountProfilesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetShippingDiscountProfiles(GetShippingDiscountProfilesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetShippingDiscountProfiles(
    GetShippingDiscountProfilesRequestType GetShippingDiscountProfilesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetShippingDiscountProfiles ( _
    GetShippingDiscountProfilesRequest As GetShippingDiscountProfilesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetShippingDiscountProfiles(
    GetShippingDiscountProfilesRequestType^ GetShippingDiscountProfilesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetShippingDiscountProfilesRequest (GetShippingDiscountProfilesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetStore Method (GetStoreRequest, callback, asyncState)

BeginGetStore Method (GetStoreRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetStore(GetStoreRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetStore(
    GetStoreRequestType GetStoreRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetStore ( _
    GetStoreRequest As GetStoreRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetStore(
    GetStoreRequestType^ GetStoreRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetStoreRequest (GetStoreRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetStoreCategoryUpdateStatus Method (GetStoreCategoryUpdateStatusRequest, callback, asyncState)

BeginGetStoreCategoryUpdateStatus Method (GetStoreCategoryUpdateStatusRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetStoreCategoryUpdateStatus(GetStoreCategoryUpdateStatusRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetStoreCategoryUpdateStatus(
    GetStoreCategoryUpdateStatusRequestType GetStoreCategoryUpdateStatusRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetStoreCategoryUpdateStatus ( _
    GetStoreCategoryUpdateStatusRequest As GetStoreCategoryUpdateStatusRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetStoreCategoryUpdateStatus(
    GetStoreCategoryUpdateStatusRequestType^ GetStoreCategoryUpdateStatusRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetStoreCategoryUpdateStatusRequest (GetStoreCategoryUpdateStatusRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetStoreCustomPage Method (GetStoreCustomPageRequest, callback, asyncState)

BeginGetStoreCustomPage Method (GetStoreCustomPageRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetStoreCustomPage(GetStoreCustomPageRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetStoreCustomPage(
    GetStoreCustomPageRequestType GetStoreCustomPageRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetStoreCustomPage ( _
    GetStoreCustomPageRequest As GetStoreCustomPageRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetStoreCustomPage(
    GetStoreCustomPageRequestType^ GetStoreCustomPageRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetStoreCustomPageRequest (GetStoreCustomPageRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetStoreOptions Method (GetStoreOptionsRequest, callback, asyncState)

BeginGetStoreOptions Method (GetStoreOptionsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetStoreOptions(GetStoreOptionsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetStoreOptions(
    GetStoreOptionsRequestType GetStoreOptionsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetStoreOptions ( _
    GetStoreOptionsRequest As GetStoreOptionsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetStoreOptions(
    GetStoreOptionsRequestType^ GetStoreOptionsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetStoreOptionsRequest (GetStoreOptionsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetStorePreferences Method (GetStorePreferencesRequest, callback, asyncState)

BeginGetStorePreferences Method (GetStorePreferencesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetStorePreferences(GetStorePreferencesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetStorePreferences(
    GetStorePreferencesRequestType GetStorePreferencesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetStorePreferences ( _
    GetStorePreferencesRequest As GetStorePreferencesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetStorePreferences(
    GetStorePreferencesRequestType^ GetStorePreferencesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetStorePreferencesRequest (GetStorePreferencesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetSuggestedCategories Method (GetSuggestedCategoriesRequest, callback, asyncState)

BeginGetSuggestedCategories Method (GetSuggestedCategoriesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetSuggestedCategories(GetSuggestedCategoriesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetSuggestedCategories(
    GetSuggestedCategoriesRequestType GetSuggestedCategoriesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetSuggestedCategories ( _
    GetSuggestedCategoriesRequest As GetSuggestedCategoriesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetSuggestedCategories(
    GetSuggestedCategoriesRequestType^ GetSuggestedCategoriesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetSuggestedCategoriesRequest (GetSuggestedCategoriesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetTaxTable Method (GetTaxTableRequest, callback, asyncState)

BeginGetTaxTable Method (GetTaxTableRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetTaxTable(GetTaxTableRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetTaxTable(
    GetTaxTableRequestType GetTaxTableRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetTaxTable ( _
    GetTaxTableRequest As GetTaxTableRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetTaxTable(
    GetTaxTableRequestType^ GetTaxTableRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetTaxTableRequest (GetTaxTableRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetTokenStatus Method (GetTokenStatusRequest, callback, asyncState)

BeginGetTokenStatus Method (GetTokenStatusRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetTokenStatus(GetTokenStatusRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetTokenStatus(
    GetTokenStatusRequestType GetTokenStatusRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetTokenStatus ( _
    GetTokenStatusRequest As GetTokenStatusRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetTokenStatus(
    GetTokenStatusRequestType^ GetTokenStatusRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetTokenStatusRequest (GetTokenStatusRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetUser Method (GetUserRequest, callback, asyncState)

BeginGetUser Method (GetUserRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetUser(GetUserRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetUser(
    GetUserRequestType GetUserRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetUser ( _
    GetUserRequest As GetUserRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetUser(
    GetUserRequestType^ GetUserRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetUserRequest (GetUserRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetUserContactDetails Method (GetUserContactDetailsRequest, callback, asyncState)

BeginGetUserContactDetails Method (GetUserContactDetailsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetUserContactDetails(GetUserContactDetailsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetUserContactDetails(
    GetUserContactDetailsRequestType GetUserContactDetailsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetUserContactDetails ( _
    GetUserContactDetailsRequest As GetUserContactDetailsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetUserContactDetails(
    GetUserContactDetailsRequestType^ GetUserContactDetailsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetUserContactDetailsRequest (GetUserContactDetailsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetUserDisputes Method (GetUserDisputesRequest, callback, asyncState)

BeginGetUserDisputes Method (GetUserDisputesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetUserDisputes(GetUserDisputesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetUserDisputes(
    GetUserDisputesRequestType GetUserDisputesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetUserDisputes ( _
    GetUserDisputesRequest As GetUserDisputesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetUserDisputes(
    GetUserDisputesRequestType^ GetUserDisputesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetUserDisputesRequest (GetUserDisputesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetUserPreferences Method (GetUserPreferencesRequest, callback, asyncState)

BeginGetUserPreferences Method (GetUserPreferencesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetUserPreferences(GetUserPreferencesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetUserPreferences(
    GetUserPreferencesRequestType GetUserPreferencesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetUserPreferences ( _
    GetUserPreferencesRequest As GetUserPreferencesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetUserPreferences(
    GetUserPreferencesRequestType^ GetUserPreferencesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetUserPreferencesRequest (GetUserPreferencesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetVeROReasonCodeDetails Method (GetVeROReasonCodeDetailsRequest, callback, asyncState)

BeginGetVeROReasonCodeDetails Method (GetVeROReasonCodeDetailsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetVeROReasonCodeDetails(GetVeROReasonCodeDetailsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetVeROReasonCodeDetails(
    GetVeROReasonCodeDetailsRequestType GetVeROReasonCodeDetailsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetVeROReasonCodeDetails ( _
    GetVeROReasonCodeDetailsRequest As GetVeROReasonCodeDetailsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetVeROReasonCodeDetails(
    GetVeROReasonCodeDetailsRequestType^ GetVeROReasonCodeDetailsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetVeROReasonCodeDetailsRequest (GetVeROReasonCodeDetailsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginGetVeROReportStatus Method (GetVeROReportStatusRequest, callback, asyncState)

BeginGetVeROReportStatus Method (GetVeROReportStatusRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginGetVeROReportStatus(GetVeROReportStatusRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginGetVeROReportStatus(
    GetVeROReportStatusRequestType GetVeROReportStatusRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginGetVeROReportStatus ( _
    GetVeROReportStatusRequest As GetVeROReportStatusRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginGetVeROReportStatus(
    GetVeROReportStatusRequestType^ GetVeROReportStatusRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
GetVeROReportStatusRequest (GetVeROReportStatusRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginIssueRefund Method (IssueRefundRequest, callback, asyncState)

BeginIssueRefund Method (IssueRefundRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginIssueRefund(IssueRefundRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginIssueRefund(
    IssueRefundRequestType IssueRefundRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginIssueRefund ( _
    IssueRefundRequest As IssueRefundRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginIssueRefund(
    IssueRefundRequestType^ IssueRefundRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
IssueRefundRequest (IssueRefundRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginLeaveFeedback Method (LeaveFeedbackRequest, callback, asyncState)

BeginLeaveFeedback Method (LeaveFeedbackRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginLeaveFeedback(LeaveFeedbackRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginLeaveFeedback(
    LeaveFeedbackRequestType LeaveFeedbackRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginLeaveFeedback ( _
    LeaveFeedbackRequest As LeaveFeedbackRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginLeaveFeedback(
    LeaveFeedbackRequestType^ LeaveFeedbackRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
LeaveFeedbackRequest (LeaveFeedbackRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginMoveSellingManagerInventoryFolder Method (MoveSellingManagerInventoryFolderRequest, callback, asyncState)

BeginMoveSellingManagerInventoryFolder Method (MoveSellingManagerInventoryFolderRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginMoveSellingManagerInventoryFolder(MoveSellingManagerInventoryFolderRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginMoveSellingManagerInventoryFolder(
    MoveSellingManagerInventoryFolderRequestType MoveSellingManagerInventoryFolderRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginMoveSellingManagerInventoryFolder ( _
    MoveSellingManagerInventoryFolderRequest As MoveSellingManagerInventoryFolderRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginMoveSellingManagerInventoryFolder(
    MoveSellingManagerInventoryFolderRequestType^ MoveSellingManagerInventoryFolderRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
MoveSellingManagerInventoryFolderRequest (MoveSellingManagerInventoryFolderRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginPlaceOffer Method (PlaceOfferRequest, callback, asyncState)

BeginPlaceOffer Method (PlaceOfferRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginPlaceOffer(PlaceOfferRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginPlaceOffer(
    PlaceOfferRequestType PlaceOfferRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginPlaceOffer ( _
    PlaceOfferRequest As PlaceOfferRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginPlaceOffer(
    PlaceOfferRequestType^ PlaceOfferRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
PlaceOfferRequest (PlaceOfferRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginRelistFixedPriceItem Method (RelistFixedPriceItemRequest, callback, asyncState)

BeginRelistFixedPriceItem Method (RelistFixedPriceItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginRelistFixedPriceItem(RelistFixedPriceItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginRelistFixedPriceItem(
    RelistFixedPriceItemRequestType RelistFixedPriceItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginRelistFixedPriceItem ( _
    RelistFixedPriceItemRequest As RelistFixedPriceItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginRelistFixedPriceItem(
    RelistFixedPriceItemRequestType^ RelistFixedPriceItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
RelistFixedPriceItemRequest (RelistFixedPriceItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginRelistItem Method (RelistItemRequest, callback, asyncState)

BeginRelistItem Method (RelistItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginRelistItem(RelistItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginRelistItem(
    RelistItemRequestType RelistItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginRelistItem ( _
    RelistItemRequest As RelistItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginRelistItem(
    RelistItemRequestType^ RelistItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
RelistItemRequest (RelistItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginRemoveFromWatchList Method (RemoveFromWatchListRequest, callback, asyncState)

BeginRemoveFromWatchList Method (RemoveFromWatchListRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginRemoveFromWatchList(RemoveFromWatchListRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginRemoveFromWatchList(
    RemoveFromWatchListRequestType RemoveFromWatchListRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginRemoveFromWatchList ( _
    RemoveFromWatchListRequest As RemoveFromWatchListRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginRemoveFromWatchList(
    RemoveFromWatchListRequestType^ RemoveFromWatchListRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
RemoveFromWatchListRequest (RemoveFromWatchListRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginRespondToBestOffer Method (RespondToBestOfferRequest, callback, asyncState)

BeginRespondToBestOffer Method (RespondToBestOfferRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginRespondToBestOffer(RespondToBestOfferRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginRespondToBestOffer(
    RespondToBestOfferRequestType RespondToBestOfferRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginRespondToBestOffer ( _
    RespondToBestOfferRequest As RespondToBestOfferRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginRespondToBestOffer(
    RespondToBestOfferRequestType^ RespondToBestOfferRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
RespondToBestOfferRequest (RespondToBestOfferRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginRespondToFeedback Method (RespondToFeedbackRequest, callback, asyncState)

BeginRespondToFeedback Method (RespondToFeedbackRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginRespondToFeedback(RespondToFeedbackRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginRespondToFeedback(
    RespondToFeedbackRequestType RespondToFeedbackRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginRespondToFeedback ( _
    RespondToFeedbackRequest As RespondToFeedbackRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginRespondToFeedback(
    RespondToFeedbackRequestType^ RespondToFeedbackRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
RespondToFeedbackRequest (RespondToFeedbackRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginReviseCheckoutStatus Method (ReviseCheckoutStatusRequest, callback, asyncState)

BeginReviseCheckoutStatus Method (ReviseCheckoutStatusRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginReviseCheckoutStatus(ReviseCheckoutStatusRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginReviseCheckoutStatus(
    ReviseCheckoutStatusRequestType ReviseCheckoutStatusRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginReviseCheckoutStatus ( _
    ReviseCheckoutStatusRequest As ReviseCheckoutStatusRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginReviseCheckoutStatus(
    ReviseCheckoutStatusRequestType^ ReviseCheckoutStatusRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ReviseCheckoutStatusRequest (ReviseCheckoutStatusRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginReviseFixedPriceItem Method (ReviseFixedPriceItemRequest, callback, asyncState)

BeginReviseFixedPriceItem Method (ReviseFixedPriceItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginReviseFixedPriceItem(ReviseFixedPriceItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginReviseFixedPriceItem(
    ReviseFixedPriceItemRequestType ReviseFixedPriceItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginReviseFixedPriceItem ( _
    ReviseFixedPriceItemRequest As ReviseFixedPriceItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginReviseFixedPriceItem(
    ReviseFixedPriceItemRequestType^ ReviseFixedPriceItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ReviseFixedPriceItemRequest (ReviseFixedPriceItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginReviseInventoryStatus Method (ReviseInventoryStatusRequest, callback, asyncState)

BeginReviseInventoryStatus Method (ReviseInventoryStatusRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginReviseInventoryStatus(ReviseInventoryStatusRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginReviseInventoryStatus(
    ReviseInventoryStatusRequestType ReviseInventoryStatusRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginReviseInventoryStatus ( _
    ReviseInventoryStatusRequest As ReviseInventoryStatusRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginReviseInventoryStatus(
    ReviseInventoryStatusRequestType^ ReviseInventoryStatusRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ReviseInventoryStatusRequest (ReviseInventoryStatusRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginReviseItem Method (ReviseItemRequest, callback, asyncState)

BeginReviseItem Method (ReviseItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginReviseItem(ReviseItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginReviseItem(
    ReviseItemRequestType ReviseItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginReviseItem ( _
    ReviseItemRequest As ReviseItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginReviseItem(
    ReviseItemRequestType^ ReviseItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ReviseItemRequest (ReviseItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginReviseMyMessages Method (ReviseMyMessagesRequest, callback, asyncState)

BeginReviseMyMessages Method (ReviseMyMessagesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginReviseMyMessages(ReviseMyMessagesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginReviseMyMessages(
    ReviseMyMessagesRequestType ReviseMyMessagesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginReviseMyMessages ( _
    ReviseMyMessagesRequest As ReviseMyMessagesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginReviseMyMessages(
    ReviseMyMessagesRequestType^ ReviseMyMessagesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ReviseMyMessagesRequest (ReviseMyMessagesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginReviseMyMessagesFolders Method (ReviseMyMessagesFoldersRequest, callback, asyncState)

BeginReviseMyMessagesFolders Method (ReviseMyMessagesFoldersRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginReviseMyMessagesFolders(ReviseMyMessagesFoldersRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginReviseMyMessagesFolders(
    ReviseMyMessagesFoldersRequestType ReviseMyMessagesFoldersRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginReviseMyMessagesFolders ( _
    ReviseMyMessagesFoldersRequest As ReviseMyMessagesFoldersRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginReviseMyMessagesFolders(
    ReviseMyMessagesFoldersRequestType^ ReviseMyMessagesFoldersRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ReviseMyMessagesFoldersRequest (ReviseMyMessagesFoldersRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginReviseSellingManagerInventoryFolder Method (ReviseSellingManagerInventoryFolderRequest, callback, asyncState)

BeginReviseSellingManagerInventoryFolder Method (ReviseSellingManagerInventoryFolderRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginReviseSellingManagerInventoryFolder(ReviseSellingManagerInventoryFolderRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginReviseSellingManagerInventoryFolder(
    ReviseSellingManagerInventoryFolderRequestType ReviseSellingManagerInventoryFolderRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginReviseSellingManagerInventoryFolder ( _
    ReviseSellingManagerInventoryFolderRequest As ReviseSellingManagerInventoryFolderRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginReviseSellingManagerInventoryFolder(
    ReviseSellingManagerInventoryFolderRequestType^ ReviseSellingManagerInventoryFolderRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ReviseSellingManagerInventoryFolderRequest (ReviseSellingManagerInventoryFolderRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginReviseSellingManagerProduct Method (ReviseSellingManagerProductRequest, callback, asyncState)

BeginReviseSellingManagerProduct Method (ReviseSellingManagerProductRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginReviseSellingManagerProduct(ReviseSellingManagerProductRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginReviseSellingManagerProduct(
    ReviseSellingManagerProductRequestType ReviseSellingManagerProductRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginReviseSellingManagerProduct ( _
    ReviseSellingManagerProductRequest As ReviseSellingManagerProductRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginReviseSellingManagerProduct(
    ReviseSellingManagerProductRequestType^ ReviseSellingManagerProductRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ReviseSellingManagerProductRequest (ReviseSellingManagerProductRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginReviseSellingManagerSaleRecord Method (ReviseSellingManagerSaleRecordRequest, callback, asyncState)

BeginReviseSellingManagerSaleRecord Method (ReviseSellingManagerSaleRecordRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginReviseSellingManagerSaleRecord(ReviseSellingManagerSaleRecordRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginReviseSellingManagerSaleRecord(
    ReviseSellingManagerSaleRecordRequestType ReviseSellingManagerSaleRecordRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginReviseSellingManagerSaleRecord ( _
    ReviseSellingManagerSaleRecordRequest As ReviseSellingManagerSaleRecordRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginReviseSellingManagerSaleRecord(
    ReviseSellingManagerSaleRecordRequestType^ ReviseSellingManagerSaleRecordRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ReviseSellingManagerSaleRecordRequest (ReviseSellingManagerSaleRecordRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginReviseSellingManagerTemplate Method (ReviseSellingManagerTemplateRequest, callback, asyncState)

BeginReviseSellingManagerTemplate Method (ReviseSellingManagerTemplateRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginReviseSellingManagerTemplate(ReviseSellingManagerTemplateRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginReviseSellingManagerTemplate(
    ReviseSellingManagerTemplateRequestType ReviseSellingManagerTemplateRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginReviseSellingManagerTemplate ( _
    ReviseSellingManagerTemplateRequest As ReviseSellingManagerTemplateRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginReviseSellingManagerTemplate(
    ReviseSellingManagerTemplateRequestType^ ReviseSellingManagerTemplateRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ReviseSellingManagerTemplateRequest (ReviseSellingManagerTemplateRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginRevokeToken Method (RevokeTokenRequest, callback, asyncState)

BeginRevokeToken Method (RevokeTokenRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginRevokeToken(RevokeTokenRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginRevokeToken(
    RevokeTokenRequestType RevokeTokenRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginRevokeToken ( _
    RevokeTokenRequest As RevokeTokenRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginRevokeToken(
    RevokeTokenRequestType^ RevokeTokenRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
RevokeTokenRequest (RevokeTokenRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSaveItemToSellingManagerTemplate Method (SaveItemToSellingManagerTemplateRequest, callback, asyncState)

BeginSaveItemToSellingManagerTemplate Method (SaveItemToSellingManagerTemplateRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSaveItemToSellingManagerTemplate(SaveItemToSellingManagerTemplateRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSaveItemToSellingManagerTemplate(
    SaveItemToSellingManagerTemplateRequestType SaveItemToSellingManagerTemplateRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSaveItemToSellingManagerTemplate ( _
    SaveItemToSellingManagerTemplateRequest As SaveItemToSellingManagerTemplateRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSaveItemToSellingManagerTemplate(
    SaveItemToSellingManagerTemplateRequestType^ SaveItemToSellingManagerTemplateRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SaveItemToSellingManagerTemplateRequest (SaveItemToSellingManagerTemplateRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSellerReverseDispute Method (SellerReverseDisputeRequest, callback, asyncState)

BeginSellerReverseDispute Method (SellerReverseDisputeRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSellerReverseDispute(SellerReverseDisputeRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSellerReverseDispute(
    SellerReverseDisputeRequestType SellerReverseDisputeRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSellerReverseDispute ( _
    SellerReverseDisputeRequest As SellerReverseDisputeRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSellerReverseDispute(
    SellerReverseDisputeRequestType^ SellerReverseDisputeRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SellerReverseDisputeRequest (SellerReverseDisputeRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSendInvoice Method (SendInvoiceRequest, callback, asyncState)

BeginSendInvoice Method (SendInvoiceRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSendInvoice(SendInvoiceRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSendInvoice(
    SendInvoiceRequestType SendInvoiceRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSendInvoice ( _
    SendInvoiceRequest As SendInvoiceRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSendInvoice(
    SendInvoiceRequestType^ SendInvoiceRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SendInvoiceRequest (SendInvoiceRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetMessagePreferences Method (SetMessagePreferencesRequest, callback, asyncState)

BeginSetMessagePreferences Method (SetMessagePreferencesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetMessagePreferences(SetMessagePreferencesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetMessagePreferences(
    SetMessagePreferencesRequestType SetMessagePreferencesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetMessagePreferences ( _
    SetMessagePreferencesRequest As SetMessagePreferencesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetMessagePreferences(
    SetMessagePreferencesRequestType^ SetMessagePreferencesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetMessagePreferencesRequest (SetMessagePreferencesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetNotificationPreferences Method (SetNotificationPreferencesRequest, callback, asyncState)

BeginSetNotificationPreferences Method (SetNotificationPreferencesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetNotificationPreferences(SetNotificationPreferencesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetNotificationPreferences(
    SetNotificationPreferencesRequestType SetNotificationPreferencesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetNotificationPreferences ( _
    SetNotificationPreferencesRequest As SetNotificationPreferencesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetNotificationPreferences(
    SetNotificationPreferencesRequestType^ SetNotificationPreferencesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetNotificationPreferencesRequest (SetNotificationPreferencesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetPromotionalSale Method (SetPromotionalSaleRequest, callback, asyncState)

BeginSetPromotionalSale Method (SetPromotionalSaleRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetPromotionalSale(SetPromotionalSaleRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetPromotionalSale(
    SetPromotionalSaleRequestType SetPromotionalSaleRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetPromotionalSale ( _
    SetPromotionalSaleRequest As SetPromotionalSaleRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetPromotionalSale(
    SetPromotionalSaleRequestType^ SetPromotionalSaleRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetPromotionalSaleRequest (SetPromotionalSaleRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetPromotionalSaleListings Method (SetPromotionalSaleListingsRequest, callback, asyncState)

BeginSetPromotionalSaleListings Method (SetPromotionalSaleListingsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetPromotionalSaleListings(SetPromotionalSaleListingsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetPromotionalSaleListings(
    SetPromotionalSaleListingsRequestType SetPromotionalSaleListingsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetPromotionalSaleListings ( _
    SetPromotionalSaleListingsRequest As SetPromotionalSaleListingsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetPromotionalSaleListings(
    SetPromotionalSaleListingsRequestType^ SetPromotionalSaleListingsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetPromotionalSaleListingsRequest (SetPromotionalSaleListingsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetSellingManagerFeedbackOptions Method (SetSellingManagerFeedbackOptionsRequest, callback, asyncState)

BeginSetSellingManagerFeedbackOptions Method (SetSellingManagerFeedbackOptionsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetSellingManagerFeedbackOptions(SetSellingManagerFeedbackOptionsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetSellingManagerFeedbackOptions(
    SetSellingManagerFeedbackOptionsRequestType SetSellingManagerFeedbackOptionsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetSellingManagerFeedbackOptions ( _
    SetSellingManagerFeedbackOptionsRequest As SetSellingManagerFeedbackOptionsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetSellingManagerFeedbackOptions(
    SetSellingManagerFeedbackOptionsRequestType^ SetSellingManagerFeedbackOptionsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetSellingManagerFeedbackOptionsRequest (SetSellingManagerFeedbackOptionsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetSellingManagerItemAutomationRule Method (SetSellingManagerItemAutomationRuleRequest, callback, asyncState)

BeginSetSellingManagerItemAutomationRule Method (SetSellingManagerItemAutomationRuleRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetSellingManagerItemAutomationRule(SetSellingManagerItemAutomationRuleRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetSellingManagerItemAutomationRule(
    SetSellingManagerItemAutomationRuleRequestType SetSellingManagerItemAutomationRuleRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetSellingManagerItemAutomationRule ( _
    SetSellingManagerItemAutomationRuleRequest As SetSellingManagerItemAutomationRuleRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetSellingManagerItemAutomationRule(
    SetSellingManagerItemAutomationRuleRequestType^ SetSellingManagerItemAutomationRuleRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetSellingManagerItemAutomationRuleRequest (SetSellingManagerItemAutomationRuleRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetSellingManagerTemplateAutomationRule Method (SetSellingManagerTemplateAutomationRuleRequest, callback, asyncState)

BeginSetSellingManagerTemplateAutomationRule Method (SetSellingManagerTemplateAutomationRuleRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetSellingManagerTemplateAutomationRule(SetSellingManagerTemplateAutomationRuleRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetSellingManagerTemplateAutomationRule(
    SetSellingManagerTemplateAutomationRuleRequestType SetSellingManagerTemplateAutomationRuleRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetSellingManagerTemplateAutomationRule ( _
    SetSellingManagerTemplateAutomationRuleRequest As SetSellingManagerTemplateAutomationRuleRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetSellingManagerTemplateAutomationRule(
    SetSellingManagerTemplateAutomationRuleRequestType^ SetSellingManagerTemplateAutomationRuleRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetSellingManagerTemplateAutomationRuleRequest (SetSellingManagerTemplateAutomationRuleRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetShippingDiscountProfiles Method (SetShippingDiscountProfilesRequest, callback, asyncState)

BeginSetShippingDiscountProfiles Method (SetShippingDiscountProfilesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetShippingDiscountProfiles(SetShippingDiscountProfilesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetShippingDiscountProfiles(
    SetShippingDiscountProfilesRequestType SetShippingDiscountProfilesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetShippingDiscountProfiles ( _
    SetShippingDiscountProfilesRequest As SetShippingDiscountProfilesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetShippingDiscountProfiles(
    SetShippingDiscountProfilesRequestType^ SetShippingDiscountProfilesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetShippingDiscountProfilesRequest (SetShippingDiscountProfilesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetStore Method (SetStoreRequest, callback, asyncState)

BeginSetStore Method (SetStoreRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetStore(SetStoreRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetStore(
    SetStoreRequestType SetStoreRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetStore ( _
    SetStoreRequest As SetStoreRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetStore(
    SetStoreRequestType^ SetStoreRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetStoreRequest (SetStoreRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetStoreCategories Method (SetStoreCategoriesRequest, callback, asyncState)

BeginSetStoreCategories Method (SetStoreCategoriesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetStoreCategories(SetStoreCategoriesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetStoreCategories(
    SetStoreCategoriesRequestType SetStoreCategoriesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetStoreCategories ( _
    SetStoreCategoriesRequest As SetStoreCategoriesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetStoreCategories(
    SetStoreCategoriesRequestType^ SetStoreCategoriesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetStoreCategoriesRequest (SetStoreCategoriesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetStoreCustomPage Method (SetStoreCustomPageRequest, callback, asyncState)

BeginSetStoreCustomPage Method (SetStoreCustomPageRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetStoreCustomPage(SetStoreCustomPageRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetStoreCustomPage(
    SetStoreCustomPageRequestType SetStoreCustomPageRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetStoreCustomPage ( _
    SetStoreCustomPageRequest As SetStoreCustomPageRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetStoreCustomPage(
    SetStoreCustomPageRequestType^ SetStoreCustomPageRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetStoreCustomPageRequest (SetStoreCustomPageRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetStorePreferences Method (SetStorePreferencesRequest, callback, asyncState)

BeginSetStorePreferences Method (SetStorePreferencesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetStorePreferences(SetStorePreferencesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetStorePreferences(
    SetStorePreferencesRequestType SetStorePreferencesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetStorePreferences ( _
    SetStorePreferencesRequest As SetStorePreferencesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetStorePreferences(
    SetStorePreferencesRequestType^ SetStorePreferencesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetStorePreferencesRequest (SetStorePreferencesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetTaxTable Method (SetTaxTableRequest, callback, asyncState)

BeginSetTaxTable Method (SetTaxTableRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetTaxTable(SetTaxTableRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetTaxTable(
    SetTaxTableRequestType SetTaxTableRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetTaxTable ( _
    SetTaxTableRequest As SetTaxTableRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetTaxTable(
    SetTaxTableRequestType^ SetTaxTableRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetTaxTableRequest (SetTaxTableRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetUserNotes Method (SetUserNotesRequest, callback, asyncState)

BeginSetUserNotes Method (SetUserNotesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetUserNotes(SetUserNotesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetUserNotes(
    SetUserNotesRequestType SetUserNotesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetUserNotes ( _
    SetUserNotesRequest As SetUserNotesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetUserNotes(
    SetUserNotesRequestType^ SetUserNotesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetUserNotesRequest (SetUserNotesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginSetUserPreferences Method (SetUserPreferencesRequest, callback, asyncState)

BeginSetUserPreferences Method (SetUserPreferencesRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginSetUserPreferences(SetUserPreferencesRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginSetUserPreferences(
    SetUserPreferencesRequestType SetUserPreferencesRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginSetUserPreferences ( _
    SetUserPreferencesRequest As SetUserPreferencesRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginSetUserPreferences(
    SetUserPreferencesRequestType^ SetUserPreferencesRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
SetUserPreferencesRequest (SetUserPreferencesRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginValidateChallengeInput Method (ValidateChallengeInputRequest, callback, asyncState)

BeginValidateChallengeInput Method (ValidateChallengeInputRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginValidateChallengeInput(ValidateChallengeInputRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginValidateChallengeInput(
    ValidateChallengeInputRequestType ValidateChallengeInputRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginValidateChallengeInput ( _
    ValidateChallengeInputRequest As ValidateChallengeInputRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginValidateChallengeInput(
    ValidateChallengeInputRequestType^ ValidateChallengeInputRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ValidateChallengeInputRequest (ValidateChallengeInputRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginValidateTestUserRegistration Method (ValidateTestUserRegistrationRequest, callback, asyncState)

BeginValidateTestUserRegistration Method (ValidateTestUserRegistrationRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginValidateTestUserRegistration(ValidateTestUserRegistrationRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginValidateTestUserRegistration(
    ValidateTestUserRegistrationRequestType ValidateTestUserRegistrationRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginValidateTestUserRegistration ( _
    ValidateTestUserRegistrationRequest As ValidateTestUserRegistrationRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginValidateTestUserRegistration(
    ValidateTestUserRegistrationRequestType^ ValidateTestUserRegistrationRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
ValidateTestUserRegistrationRequest (ValidateTestUserRegistrationRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginVerifyAddFixedPriceItem Method (VerifyAddFixedPriceItemRequest, callback, asyncState)

BeginVerifyAddFixedPriceItem Method (VerifyAddFixedPriceItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginVerifyAddFixedPriceItem(VerifyAddFixedPriceItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginVerifyAddFixedPriceItem(
    VerifyAddFixedPriceItemRequestType VerifyAddFixedPriceItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginVerifyAddFixedPriceItem ( _
    VerifyAddFixedPriceItemRequest As VerifyAddFixedPriceItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginVerifyAddFixedPriceItem(
    VerifyAddFixedPriceItemRequestType^ VerifyAddFixedPriceItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
VerifyAddFixedPriceItemRequest (VerifyAddFixedPriceItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginVerifyAddItem Method (VerifyAddItemRequest, callback, asyncState)

BeginVerifyAddItem Method (VerifyAddItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginVerifyAddItem(VerifyAddItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginVerifyAddItem(
    VerifyAddItemRequestType VerifyAddItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginVerifyAddItem ( _
    VerifyAddItemRequest As VerifyAddItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginVerifyAddItem(
    VerifyAddItemRequestType^ VerifyAddItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
VerifyAddItemRequest (VerifyAddItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginVerifyAddSecondChanceItem Method (VerifyAddSecondChanceItemRequest, callback, asyncState)

BeginVerifyAddSecondChanceItem Method (VerifyAddSecondChanceItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginVerifyAddSecondChanceItem(VerifyAddSecondChanceItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginVerifyAddSecondChanceItem(
    VerifyAddSecondChanceItemRequestType VerifyAddSecondChanceItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginVerifyAddSecondChanceItem ( _
    VerifyAddSecondChanceItemRequest As VerifyAddSecondChanceItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginVerifyAddSecondChanceItem(
    VerifyAddSecondChanceItemRequestType^ VerifyAddSecondChanceItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
VerifyAddSecondChanceItemRequest (VerifyAddSecondChanceItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginVerifyRelistItem Method (VerifyRelistItemRequest, callback, asyncState)

BeginVerifyRelistItem Method (VerifyRelistItemRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginVerifyRelistItem(VerifyRelistItemRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginVerifyRelistItem(
    VerifyRelistItemRequestType VerifyRelistItemRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginVerifyRelistItem ( _
    VerifyRelistItemRequest As VerifyRelistItemRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginVerifyRelistItem(
    VerifyRelistItemRequestType^ VerifyRelistItemRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
VerifyRelistItemRequest (VerifyRelistItemRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


BeginVeROReportItems Method (VeROReportItemsRequest, callback, asyncState)

BeginVeROReportItems Method (VeROReportItemsRequest, callback, asyncState)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► BeginVeROReportItems(VeROReportItemsRequestType, AsyncCallback, Object)
Declaration Syntax
C# Visual Basic Visual C++
public IAsyncResult BeginVeROReportItems(
    VeROReportItemsRequestType VeROReportItemsRequest,
    AsyncCallback callback,
    Object asyncState
)
Public Function BeginVeROReportItems ( _
    VeROReportItemsRequest As VeROReportItemsRequestType, _
    callback As AsyncCallback, _
    asyncState As Object _
) As IAsyncResult
public:
IAsyncResult^ BeginVeROReportItems(
    VeROReportItemsRequestType^ VeROReportItemsRequest,
    AsyncCallback^ callback,
    Object^ asyncState
)
Parameters
VeROReportItemsRequest (VeROReportItemsRequestType)
callback (AsyncCallback)
asyncState (Object)
Remarks


CompleteSale Method (CompleteSaleRequest)

CompleteSale Method (CompleteSaleRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► CompleteSale(CompleteSaleRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public CompleteSaleResponseType CompleteSale(
    CompleteSaleRequestType CompleteSaleRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function CompleteSale ( _
    CompleteSaleRequest As CompleteSaleRequestType _
) As CompleteSaleResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
CompleteSaleResponseType^ CompleteSale(
    CompleteSaleRequestType^ CompleteSaleRequest
)
Parameters
CompleteSaleRequest (CompleteSaleRequestType)
Remarks


ConfirmIdentity Method (ConfirmIdentityRequest)

ConfirmIdentity Method (ConfirmIdentityRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ConfirmIdentity(ConfirmIdentityRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ConfirmIdentityResponseType ConfirmIdentity(
    ConfirmIdentityRequestType ConfirmIdentityRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ConfirmIdentity ( _
    ConfirmIdentityRequest As ConfirmIdentityRequestType _
) As ConfirmIdentityResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ConfirmIdentityResponseType^ ConfirmIdentity(
    ConfirmIdentityRequestType^ ConfirmIdentityRequest
)
Parameters
ConfirmIdentityRequest (ConfirmIdentityRequestType)
Remarks


DeleteMyMessages Method (DeleteMyMessagesRequest)

DeleteMyMessages Method (DeleteMyMessagesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► DeleteMyMessages(DeleteMyMessagesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public DeleteMyMessagesResponseType DeleteMyMessages(
    DeleteMyMessagesRequestType DeleteMyMessagesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function DeleteMyMessages ( _
    DeleteMyMessagesRequest As DeleteMyMessagesRequestType _
) As DeleteMyMessagesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
DeleteMyMessagesResponseType^ DeleteMyMessages(
    DeleteMyMessagesRequestType^ DeleteMyMessagesRequest
)
Parameters
DeleteMyMessagesRequest (DeleteMyMessagesRequestType)
Remarks


DeleteSellingManagerInventoryFolder Method (DeleteSellingManagerInventoryFolderRequest)

DeleteSellingManagerInventoryFolder Method (DeleteSellingManagerInventoryFolderRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► DeleteSellingManagerInventoryFolder(DeleteSellingManagerInventoryFolderRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public DeleteSellingManagerInventoryFolderResponseType DeleteSellingManagerInventoryFolder(
    DeleteSellingManagerInventoryFolderRequestType DeleteSellingManagerInventoryFolderRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function DeleteSellingManagerInventoryFolder ( _
    DeleteSellingManagerInventoryFolderRequest As DeleteSellingManagerInventoryFolderRequestType _
) As DeleteSellingManagerInventoryFolderResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
DeleteSellingManagerInventoryFolderResponseType^ DeleteSellingManagerInventoryFolder(
    DeleteSellingManagerInventoryFolderRequestType^ DeleteSellingManagerInventoryFolderRequest
)
Parameters
DeleteSellingManagerInventoryFolderRequest (DeleteSellingManagerInventoryFolderRequestType)
Remarks


DeleteSellingManagerItemAutomationRule Method (DeleteSellingManagerItemAutomationRuleRequest)

DeleteSellingManagerItemAutomationRule Method (DeleteSellingManagerItemAutomationRuleRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► DeleteSellingManagerItemAutomationRule(DeleteSellingManagerItemAutomationRuleRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public DeleteSellingManagerItemAutomationRuleResponseType DeleteSellingManagerItemAutomationRule(
    DeleteSellingManagerItemAutomationRuleRequestType DeleteSellingManagerItemAutomationRuleRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function DeleteSellingManagerItemAutomationRule ( _
    DeleteSellingManagerItemAutomationRuleRequest As DeleteSellingManagerItemAutomationRuleRequestType _
) As DeleteSellingManagerItemAutomationRuleResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
DeleteSellingManagerItemAutomationRuleResponseType^ DeleteSellingManagerItemAutomationRule(
    DeleteSellingManagerItemAutomationRuleRequestType^ DeleteSellingManagerItemAutomationRuleRequest
)
Parameters
DeleteSellingManagerItemAutomationRuleRequest (DeleteSellingManagerItemAutomationRuleRequestType)
Remarks


DeleteSellingManagerProduct Method (DeleteSellingManagerProductRequest)

DeleteSellingManagerProduct Method (DeleteSellingManagerProductRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► DeleteSellingManagerProduct(DeleteSellingManagerProductRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public DeleteSellingManagerProductResponseType DeleteSellingManagerProduct(
    DeleteSellingManagerProductRequestType DeleteSellingManagerProductRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function DeleteSellingManagerProduct ( _
    DeleteSellingManagerProductRequest As DeleteSellingManagerProductRequestType _
) As DeleteSellingManagerProductResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
DeleteSellingManagerProductResponseType^ DeleteSellingManagerProduct(
    DeleteSellingManagerProductRequestType^ DeleteSellingManagerProductRequest
)
Parameters
DeleteSellingManagerProductRequest (DeleteSellingManagerProductRequestType)
Remarks


DeleteSellingManagerTemplate Method (DeleteSellingManagerTemplateRequest)

DeleteSellingManagerTemplate Method (DeleteSellingManagerTemplateRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► DeleteSellingManagerTemplate(DeleteSellingManagerTemplateRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public DeleteSellingManagerTemplateResponseType DeleteSellingManagerTemplate(
    DeleteSellingManagerTemplateRequestType DeleteSellingManagerTemplateRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function DeleteSellingManagerTemplate ( _
    DeleteSellingManagerTemplateRequest As DeleteSellingManagerTemplateRequestType _
) As DeleteSellingManagerTemplateResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
DeleteSellingManagerTemplateResponseType^ DeleteSellingManagerTemplate(
    DeleteSellingManagerTemplateRequestType^ DeleteSellingManagerTemplateRequest
)
Parameters
DeleteSellingManagerTemplateRequest (DeleteSellingManagerTemplateRequestType)
Remarks


DeleteSellingManagerTemplateAutomationRule Method (DeleteSellingManagerTemplateAutomationRuleRequest)

DeleteSellingManagerTemplateAutomationRule Method (DeleteSellingManagerTemplateAutomationRuleRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► DeleteSellingManagerTemplateAutomationRule(DeleteSellingManagerTemplateAutomationRuleRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public DeleteSellingManagerTemplateAutomationRuleResponseType DeleteSellingManagerTemplateAutomationRule(
    DeleteSellingManagerTemplateAutomationRuleRequestType DeleteSellingManagerTemplateAutomationRuleRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function DeleteSellingManagerTemplateAutomationRule ( _
    DeleteSellingManagerTemplateAutomationRuleRequest As DeleteSellingManagerTemplateAutomationRuleRequestType _
) As DeleteSellingManagerTemplateAutomationRuleResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
DeleteSellingManagerTemplateAutomationRuleResponseType^ DeleteSellingManagerTemplateAutomationRule(
    DeleteSellingManagerTemplateAutomationRuleRequestType^ DeleteSellingManagerTemplateAutomationRuleRequest
)
Parameters
DeleteSellingManagerTemplateAutomationRuleRequest (DeleteSellingManagerTemplateAutomationRuleRequestType)
Remarks


DisableUnpaidItemAssistance Method (DisableUnpaidItemAssistanceRequest)

DisableUnpaidItemAssistance Method (DisableUnpaidItemAssistanceRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► DisableUnpaidItemAssistance(DisableUnpaidItemAssistanceRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public DisableUnpaidItemAssistanceResponseType DisableUnpaidItemAssistance(
    DisableUnpaidItemAssistanceRequestType DisableUnpaidItemAssistanceRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function DisableUnpaidItemAssistance ( _
    DisableUnpaidItemAssistanceRequest As DisableUnpaidItemAssistanceRequestType _
) As DisableUnpaidItemAssistanceResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
DisableUnpaidItemAssistanceResponseType^ DisableUnpaidItemAssistance(
    DisableUnpaidItemAssistanceRequestType^ DisableUnpaidItemAssistanceRequest
)
Parameters
DisableUnpaidItemAssistanceRequest (DisableUnpaidItemAssistanceRequestType)
Remarks


eBayAPIInterfaceService Constructor

eBayAPIInterfaceService Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► eBayAPIInterfaceService()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayAPIInterfaceService()
Public Sub New
public:
eBayAPIInterfaceService()
Remarks


EndAddDispute Method (asyncResult)

EndAddDispute Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddDispute(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeResponseType EndAddDispute(
    IAsyncResult asyncResult
)
Public Function EndAddDispute ( _
    asyncResult As IAsyncResult _
) As AddDisputeResponseType
public:
AddDisputeResponseType^ EndAddDispute(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddDisputeResponse Method (asyncResult)

EndAddDisputeResponse Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddDisputeResponse(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddDisputeResponseResponseType EndAddDisputeResponse(
    IAsyncResult asyncResult
)
Public Function EndAddDisputeResponse ( _
    asyncResult As IAsyncResult _
) As AddDisputeResponseResponseType
public:
AddDisputeResponseResponseType^ EndAddDisputeResponse(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddFixedPriceItem Method (asyncResult)

EndAddFixedPriceItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddFixedPriceItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddFixedPriceItemResponseType EndAddFixedPriceItem(
    IAsyncResult asyncResult
)
Public Function EndAddFixedPriceItem ( _
    asyncResult As IAsyncResult _
) As AddFixedPriceItemResponseType
public:
AddFixedPriceItemResponseType^ EndAddFixedPriceItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddItem Method (asyncResult)

EndAddItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddItemResponseType EndAddItem(
    IAsyncResult asyncResult
)
Public Function EndAddItem ( _
    asyncResult As IAsyncResult _
) As AddItemResponseType
public:
AddItemResponseType^ EndAddItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddItemFromSellingManagerTemplate Method (asyncResult)

EndAddItemFromSellingManagerTemplate Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddItemFromSellingManagerTemplate(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddItemFromSellingManagerTemplateResponseType EndAddItemFromSellingManagerTemplate(
    IAsyncResult asyncResult
)
Public Function EndAddItemFromSellingManagerTemplate ( _
    asyncResult As IAsyncResult _
) As AddItemFromSellingManagerTemplateResponseType
public:
AddItemFromSellingManagerTemplateResponseType^ EndAddItemFromSellingManagerTemplate(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddItems Method (asyncResult)

EndAddItems Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddItems(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddItemsResponseType EndAddItems(
    IAsyncResult asyncResult
)
Public Function EndAddItems ( _
    asyncResult As IAsyncResult _
) As AddItemsResponseType
public:
AddItemsResponseType^ EndAddItems(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddMemberMessageAAQToPartner Method (asyncResult)

EndAddMemberMessageAAQToPartner Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddMemberMessageAAQToPartner(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageAAQToPartnerResponseType EndAddMemberMessageAAQToPartner(
    IAsyncResult asyncResult
)
Public Function EndAddMemberMessageAAQToPartner ( _
    asyncResult As IAsyncResult _
) As AddMemberMessageAAQToPartnerResponseType
public:
AddMemberMessageAAQToPartnerResponseType^ EndAddMemberMessageAAQToPartner(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddMemberMessageRTQ Method (asyncResult)

EndAddMemberMessageRTQ Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddMemberMessageRTQ(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessageRTQResponseType EndAddMemberMessageRTQ(
    IAsyncResult asyncResult
)
Public Function EndAddMemberMessageRTQ ( _
    asyncResult As IAsyncResult _
) As AddMemberMessageRTQResponseType
public:
AddMemberMessageRTQResponseType^ EndAddMemberMessageRTQ(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddMemberMessagesAAQToBidder Method (asyncResult)

EndAddMemberMessagesAAQToBidder Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddMemberMessagesAAQToBidder(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddMemberMessagesAAQToBidderResponseType EndAddMemberMessagesAAQToBidder(
    IAsyncResult asyncResult
)
Public Function EndAddMemberMessagesAAQToBidder ( _
    asyncResult As IAsyncResult _
) As AddMemberMessagesAAQToBidderResponseType
public:
AddMemberMessagesAAQToBidderResponseType^ EndAddMemberMessagesAAQToBidder(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddOrder Method (asyncResult)

EndAddOrder Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddOrder(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddOrderResponseType EndAddOrder(
    IAsyncResult asyncResult
)
Public Function EndAddOrder ( _
    asyncResult As IAsyncResult _
) As AddOrderResponseType
public:
AddOrderResponseType^ EndAddOrder(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddSecondChanceItem Method (asyncResult)

EndAddSecondChanceItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddSecondChanceItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddSecondChanceItemResponseType EndAddSecondChanceItem(
    IAsyncResult asyncResult
)
Public Function EndAddSecondChanceItem ( _
    asyncResult As IAsyncResult _
) As AddSecondChanceItemResponseType
public:
AddSecondChanceItemResponseType^ EndAddSecondChanceItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddSellingManagerInventoryFolder Method (asyncResult)

EndAddSellingManagerInventoryFolder Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddSellingManagerInventoryFolder(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerInventoryFolderResponseType EndAddSellingManagerInventoryFolder(
    IAsyncResult asyncResult
)
Public Function EndAddSellingManagerInventoryFolder ( _
    asyncResult As IAsyncResult _
) As AddSellingManagerInventoryFolderResponseType
public:
AddSellingManagerInventoryFolderResponseType^ EndAddSellingManagerInventoryFolder(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddSellingManagerProduct Method (asyncResult)

EndAddSellingManagerProduct Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddSellingManagerProduct(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerProductResponseType EndAddSellingManagerProduct(
    IAsyncResult asyncResult
)
Public Function EndAddSellingManagerProduct ( _
    asyncResult As IAsyncResult _
) As AddSellingManagerProductResponseType
public:
AddSellingManagerProductResponseType^ EndAddSellingManagerProduct(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddSellingManagerTemplate Method (asyncResult)

EndAddSellingManagerTemplate Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddSellingManagerTemplate(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddSellingManagerTemplateResponseType EndAddSellingManagerTemplate(
    IAsyncResult asyncResult
)
Public Function EndAddSellingManagerTemplate ( _
    asyncResult As IAsyncResult _
) As AddSellingManagerTemplateResponseType
public:
AddSellingManagerTemplateResponseType^ EndAddSellingManagerTemplate(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddToItemDescription Method (asyncResult)

EndAddToItemDescription Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddToItemDescription(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddToItemDescriptionResponseType EndAddToItemDescription(
    IAsyncResult asyncResult
)
Public Function EndAddToItemDescription ( _
    asyncResult As IAsyncResult _
) As AddToItemDescriptionResponseType
public:
AddToItemDescriptionResponseType^ EndAddToItemDescription(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddToWatchList Method (asyncResult)

EndAddToWatchList Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddToWatchList(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddToWatchListResponseType EndAddToWatchList(
    IAsyncResult asyncResult
)
Public Function EndAddToWatchList ( _
    asyncResult As IAsyncResult _
) As AddToWatchListResponseType
public:
AddToWatchListResponseType^ EndAddToWatchList(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndAddTransactionConfirmationItem Method (asyncResult)

EndAddTransactionConfirmationItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndAddTransactionConfirmationItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public AddTransactionConfirmationItemResponseType EndAddTransactionConfirmationItem(
    IAsyncResult asyncResult
)
Public Function EndAddTransactionConfirmationItem ( _
    asyncResult As IAsyncResult _
) As AddTransactionConfirmationItemResponseType
public:
AddTransactionConfirmationItemResponseType^ EndAddTransactionConfirmationItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndCompleteSale Method (asyncResult)

EndCompleteSale Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndCompleteSale(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public CompleteSaleResponseType EndCompleteSale(
    IAsyncResult asyncResult
)
Public Function EndCompleteSale ( _
    asyncResult As IAsyncResult _
) As CompleteSaleResponseType
public:
CompleteSaleResponseType^ EndCompleteSale(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndConfirmIdentity Method (asyncResult)

EndConfirmIdentity Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndConfirmIdentity(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ConfirmIdentityResponseType EndConfirmIdentity(
    IAsyncResult asyncResult
)
Public Function EndConfirmIdentity ( _
    asyncResult As IAsyncResult _
) As ConfirmIdentityResponseType
public:
ConfirmIdentityResponseType^ EndConfirmIdentity(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDeleteMyMessages Method (asyncResult)

EndDeleteMyMessages Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndDeleteMyMessages(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteMyMessagesResponseType EndDeleteMyMessages(
    IAsyncResult asyncResult
)
Public Function EndDeleteMyMessages ( _
    asyncResult As IAsyncResult _
) As DeleteMyMessagesResponseType
public:
DeleteMyMessagesResponseType^ EndDeleteMyMessages(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDeleteSellingManagerInventoryFolder Method (asyncResult)

EndDeleteSellingManagerInventoryFolder Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndDeleteSellingManagerInventoryFolder(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerInventoryFolderResponseType EndDeleteSellingManagerInventoryFolder(
    IAsyncResult asyncResult
)
Public Function EndDeleteSellingManagerInventoryFolder ( _
    asyncResult As IAsyncResult _
) As DeleteSellingManagerInventoryFolderResponseType
public:
DeleteSellingManagerInventoryFolderResponseType^ EndDeleteSellingManagerInventoryFolder(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDeleteSellingManagerItemAutomationRule Method (asyncResult)

EndDeleteSellingManagerItemAutomationRule Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndDeleteSellingManagerItemAutomationRule(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerItemAutomationRuleResponseType EndDeleteSellingManagerItemAutomationRule(
    IAsyncResult asyncResult
)
Public Function EndDeleteSellingManagerItemAutomationRule ( _
    asyncResult As IAsyncResult _
) As DeleteSellingManagerItemAutomationRuleResponseType
public:
DeleteSellingManagerItemAutomationRuleResponseType^ EndDeleteSellingManagerItemAutomationRule(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDeleteSellingManagerProduct Method (asyncResult)

EndDeleteSellingManagerProduct Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndDeleteSellingManagerProduct(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerProductResponseType EndDeleteSellingManagerProduct(
    IAsyncResult asyncResult
)
Public Function EndDeleteSellingManagerProduct ( _
    asyncResult As IAsyncResult _
) As DeleteSellingManagerProductResponseType
public:
DeleteSellingManagerProductResponseType^ EndDeleteSellingManagerProduct(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDeleteSellingManagerTemplate Method (asyncResult)

EndDeleteSellingManagerTemplate Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndDeleteSellingManagerTemplate(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateResponseType EndDeleteSellingManagerTemplate(
    IAsyncResult asyncResult
)
Public Function EndDeleteSellingManagerTemplate ( _
    asyncResult As IAsyncResult _
) As DeleteSellingManagerTemplateResponseType
public:
DeleteSellingManagerTemplateResponseType^ EndDeleteSellingManagerTemplate(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDeleteSellingManagerTemplateAutomationRule Method (asyncResult)

EndDeleteSellingManagerTemplateAutomationRule Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndDeleteSellingManagerTemplateAutomationRule(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public DeleteSellingManagerTemplateAutomationRuleResponseType EndDeleteSellingManagerTemplateAutomationRule(
    IAsyncResult asyncResult
)
Public Function EndDeleteSellingManagerTemplateAutomationRule ( _
    asyncResult As IAsyncResult _
) As DeleteSellingManagerTemplateAutomationRuleResponseType
public:
DeleteSellingManagerTemplateAutomationRuleResponseType^ EndDeleteSellingManagerTemplateAutomationRule(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndDisableUnpaidItemAssistance Method (asyncResult)

EndDisableUnpaidItemAssistance Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndDisableUnpaidItemAssistance(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public DisableUnpaidItemAssistanceResponseType EndDisableUnpaidItemAssistance(
    IAsyncResult asyncResult
)
Public Function EndDisableUnpaidItemAssistance ( _
    asyncResult As IAsyncResult _
) As DisableUnpaidItemAssistanceResponseType
public:
DisableUnpaidItemAssistanceResponseType^ EndDisableUnpaidItemAssistance(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndEndFixedPriceItem Method (asyncResult)

EndEndFixedPriceItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndEndFixedPriceItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public EndFixedPriceItemResponseType EndEndFixedPriceItem(
    IAsyncResult asyncResult
)
Public Function EndEndFixedPriceItem ( _
    asyncResult As IAsyncResult _
) As EndFixedPriceItemResponseType
public:
EndFixedPriceItemResponseType^ EndEndFixedPriceItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndEndItem Method (asyncResult)

EndEndItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndEndItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseType EndEndItem(
    IAsyncResult asyncResult
)
Public Function EndEndItem ( _
    asyncResult As IAsyncResult _
) As EndItemResponseType
public:
EndItemResponseType^ EndEndItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndEndItems Method (asyncResult)

EndEndItems Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndEndItems(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public EndItemsResponseType EndEndItems(
    IAsyncResult asyncResult
)
Public Function EndEndItems ( _
    asyncResult As IAsyncResult _
) As EndItemsResponseType
public:
EndItemsResponseType^ EndEndItems(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndExtendSiteHostedPictures Method (asyncResult)

EndExtendSiteHostedPictures Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndExtendSiteHostedPictures(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ExtendSiteHostedPicturesResponseType EndExtendSiteHostedPictures(
    IAsyncResult asyncResult
)
Public Function EndExtendSiteHostedPictures ( _
    asyncResult As IAsyncResult _
) As ExtendSiteHostedPicturesResponseType
public:
ExtendSiteHostedPicturesResponseType^ EndExtendSiteHostedPictures(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndFetchToken Method (asyncResult)

EndFetchToken Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndFetchToken(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public FetchTokenResponseType EndFetchToken(
    IAsyncResult asyncResult
)
Public Function EndFetchToken ( _
    asyncResult As IAsyncResult _
) As FetchTokenResponseType
public:
FetchTokenResponseType^ EndFetchToken(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndFixedPriceItem Method (EndFixedPriceItemRequest)

EndFixedPriceItem Method (EndFixedPriceItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndFixedPriceItem(EndFixedPriceItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public EndFixedPriceItemResponseType EndFixedPriceItem(
    EndFixedPriceItemRequestType EndFixedPriceItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function EndFixedPriceItem ( _
    EndFixedPriceItemRequest As EndFixedPriceItemRequestType _
) As EndFixedPriceItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
EndFixedPriceItemResponseType^ EndFixedPriceItem(
    EndFixedPriceItemRequestType^ EndFixedPriceItemRequest
)
Parameters
EndFixedPriceItemRequest (EndFixedPriceItemRequestType)
Remarks


EndGetAccount Method (asyncResult)

EndGetAccount Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetAccount(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetAccountResponseType EndGetAccount(
    IAsyncResult asyncResult
)
Public Function EndGetAccount ( _
    asyncResult As IAsyncResult _
) As GetAccountResponseType
public:
GetAccountResponseType^ EndGetAccount(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetAdFormatLeads Method (asyncResult)

EndGetAdFormatLeads Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetAdFormatLeads(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetAdFormatLeadsResponseType EndGetAdFormatLeads(
    IAsyncResult asyncResult
)
Public Function EndGetAdFormatLeads ( _
    asyncResult As IAsyncResult _
) As GetAdFormatLeadsResponseType
public:
GetAdFormatLeadsResponseType^ EndGetAdFormatLeads(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetAllBidders Method (asyncResult)

EndGetAllBidders Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetAllBidders(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetAllBiddersResponseType EndGetAllBidders(
    IAsyncResult asyncResult
)
Public Function EndGetAllBidders ( _
    asyncResult As IAsyncResult _
) As GetAllBiddersResponseType
public:
GetAllBiddersResponseType^ EndGetAllBidders(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetApiAccessRules Method (asyncResult)

EndGetApiAccessRules Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetApiAccessRules(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetApiAccessRulesResponseType EndGetApiAccessRules(
    IAsyncResult asyncResult
)
Public Function EndGetApiAccessRules ( _
    asyncResult As IAsyncResult _
) As GetApiAccessRulesResponseType
public:
GetApiAccessRulesResponseType^ EndGetApiAccessRules(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetBestOffers Method (asyncResult)

EndGetBestOffers Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetBestOffers(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetBestOffersResponseType EndGetBestOffers(
    IAsyncResult asyncResult
)
Public Function EndGetBestOffers ( _
    asyncResult As IAsyncResult _
) As GetBestOffersResponseType
public:
GetBestOffersResponseType^ EndGetBestOffers(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetBidderList Method (asyncResult)

EndGetBidderList Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetBidderList(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetBidderListResponseType EndGetBidderList(
    IAsyncResult asyncResult
)
Public Function EndGetBidderList ( _
    asyncResult As IAsyncResult _
) As GetBidderListResponseType
public:
GetBidderListResponseType^ EndGetBidderList(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetCategories Method (asyncResult)

EndGetCategories Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetCategories(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoriesResponseType EndGetCategories(
    IAsyncResult asyncResult
)
Public Function EndGetCategories ( _
    asyncResult As IAsyncResult _
) As GetCategoriesResponseType
public:
GetCategoriesResponseType^ EndGetCategories(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetCategoryFeatures Method (asyncResult)

EndGetCategoryFeatures Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetCategoryFeatures(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryFeaturesResponseType EndGetCategoryFeatures(
    IAsyncResult asyncResult
)
Public Function EndGetCategoryFeatures ( _
    asyncResult As IAsyncResult _
) As GetCategoryFeaturesResponseType
public:
GetCategoryFeaturesResponseType^ EndGetCategoryFeatures(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetCategoryMappings Method (asyncResult)

EndGetCategoryMappings Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetCategoryMappings(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryMappingsResponseType EndGetCategoryMappings(
    IAsyncResult asyncResult
)
Public Function EndGetCategoryMappings ( _
    asyncResult As IAsyncResult _
) As GetCategoryMappingsResponseType
public:
GetCategoryMappingsResponseType^ EndGetCategoryMappings(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetCategorySpecifics Method (asyncResult)

EndGetCategorySpecifics Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetCategorySpecifics(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetCategorySpecificsResponseType EndGetCategorySpecifics(
    IAsyncResult asyncResult
)
Public Function EndGetCategorySpecifics ( _
    asyncResult As IAsyncResult _
) As GetCategorySpecificsResponseType
public:
GetCategorySpecificsResponseType^ EndGetCategorySpecifics(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetChallengeToken Method (asyncResult)

EndGetChallengeToken Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetChallengeToken(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetChallengeTokenResponseType EndGetChallengeToken(
    IAsyncResult asyncResult
)
Public Function EndGetChallengeToken ( _
    asyncResult As IAsyncResult _
) As GetChallengeTokenResponseType
public:
GetChallengeTokenResponseType^ EndGetChallengeToken(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetCharities Method (asyncResult)

EndGetCharities Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetCharities(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetCharitiesResponseType EndGetCharities(
    IAsyncResult asyncResult
)
Public Function EndGetCharities ( _
    asyncResult As IAsyncResult _
) As GetCharitiesResponseType
public:
GetCharitiesResponseType^ EndGetCharities(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetClientAlertsAuthToken Method (asyncResult)

EndGetClientAlertsAuthToken Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetClientAlertsAuthToken(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetClientAlertsAuthTokenResponseType EndGetClientAlertsAuthToken(
    IAsyncResult asyncResult
)
Public Function EndGetClientAlertsAuthToken ( _
    asyncResult As IAsyncResult _
) As GetClientAlertsAuthTokenResponseType
public:
GetClientAlertsAuthTokenResponseType^ EndGetClientAlertsAuthToken(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetContextualKeywords Method (asyncResult)

EndGetContextualKeywords Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetContextualKeywords(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetContextualKeywordsResponseType EndGetContextualKeywords(
    IAsyncResult asyncResult
)
Public Function EndGetContextualKeywords ( _
    asyncResult As IAsyncResult _
) As GetContextualKeywordsResponseType
public:
GetContextualKeywordsResponseType^ EndGetContextualKeywords(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetDescriptionTemplates Method (asyncResult)

EndGetDescriptionTemplates Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetDescriptionTemplates(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetDescriptionTemplatesResponseType EndGetDescriptionTemplates(
    IAsyncResult asyncResult
)
Public Function EndGetDescriptionTemplates ( _
    asyncResult As IAsyncResult _
) As GetDescriptionTemplatesResponseType
public:
GetDescriptionTemplatesResponseType^ EndGetDescriptionTemplates(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetDispute Method (asyncResult)

EndGetDispute Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetDispute(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetDisputeResponseType EndGetDispute(
    IAsyncResult asyncResult
)
Public Function EndGetDispute ( _
    asyncResult As IAsyncResult _
) As GetDisputeResponseType
public:
GetDisputeResponseType^ EndGetDispute(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGeteBayDetails Method (asyncResult)

EndGeteBayDetails Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGeteBayDetails(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayDetailsResponseType EndGeteBayDetails(
    IAsyncResult asyncResult
)
Public Function EndGeteBayDetails ( _
    asyncResult As IAsyncResult _
) As GeteBayDetailsResponseType
public:
GeteBayDetailsResponseType^ EndGeteBayDetails(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGeteBayOfficialTime Method (asyncResult)

EndGeteBayOfficialTime Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGeteBayOfficialTime(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayOfficialTimeResponseType EndGeteBayOfficialTime(
    IAsyncResult asyncResult
)
Public Function EndGeteBayOfficialTime ( _
    asyncResult As IAsyncResult _
) As GeteBayOfficialTimeResponseType
public:
GeteBayOfficialTimeResponseType^ EndGeteBayOfficialTime(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetFeedback Method (asyncResult)

EndGetFeedback Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetFeedback(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetFeedbackResponseType EndGetFeedback(
    IAsyncResult asyncResult
)
Public Function EndGetFeedback ( _
    asyncResult As IAsyncResult _
) As GetFeedbackResponseType
public:
GetFeedbackResponseType^ EndGetFeedback(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItem Method (asyncResult)

EndGetItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetItemResponseType EndGetItem(
    IAsyncResult asyncResult
)
Public Function EndGetItem ( _
    asyncResult As IAsyncResult _
) As GetItemResponseType
public:
GetItemResponseType^ EndGetItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemsAwaitingFeedback Method (asyncResult)

EndGetItemsAwaitingFeedback Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetItemsAwaitingFeedback(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetItemsAwaitingFeedbackResponseType EndGetItemsAwaitingFeedback(
    IAsyncResult asyncResult
)
Public Function EndGetItemsAwaitingFeedback ( _
    asyncResult As IAsyncResult _
) As GetItemsAwaitingFeedbackResponseType
public:
GetItemsAwaitingFeedbackResponseType^ EndGetItemsAwaitingFeedback(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemShipping Method (asyncResult)

EndGetItemShipping Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetItemShipping(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetItemShippingResponseType EndGetItemShipping(
    IAsyncResult asyncResult
)
Public Function EndGetItemShipping ( _
    asyncResult As IAsyncResult _
) As GetItemShippingResponseType
public:
GetItemShippingResponseType^ EndGetItemShipping(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetItemTransactions Method (asyncResult)

EndGetItemTransactions Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetItemTransactions(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetItemTransactionsResponseType EndGetItemTransactions(
    IAsyncResult asyncResult
)
Public Function EndGetItemTransactions ( _
    asyncResult As IAsyncResult _
) As GetItemTransactionsResponseType
public:
GetItemTransactionsResponseType^ EndGetItemTransactions(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetMemberMessages Method (asyncResult)

EndGetMemberMessages Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetMemberMessages(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetMemberMessagesResponseType EndGetMemberMessages(
    IAsyncResult asyncResult
)
Public Function EndGetMemberMessages ( _
    asyncResult As IAsyncResult _
) As GetMemberMessagesResponseType
public:
GetMemberMessagesResponseType^ EndGetMemberMessages(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetMessagePreferences Method (asyncResult)

EndGetMessagePreferences Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetMessagePreferences(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetMessagePreferencesResponseType EndGetMessagePreferences(
    IAsyncResult asyncResult
)
Public Function EndGetMessagePreferences ( _
    asyncResult As IAsyncResult _
) As GetMessagePreferencesResponseType
public:
GetMessagePreferencesResponseType^ EndGetMessagePreferences(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetMyeBayBuying Method (asyncResult)

EndGetMyeBayBuying Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetMyeBayBuying(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayBuyingResponseType EndGetMyeBayBuying(
    IAsyncResult asyncResult
)
Public Function EndGetMyeBayBuying ( _
    asyncResult As IAsyncResult _
) As GetMyeBayBuyingResponseType
public:
GetMyeBayBuyingResponseType^ EndGetMyeBayBuying(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetMyeBayReminders Method (asyncResult)

EndGetMyeBayReminders Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetMyeBayReminders(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayRemindersResponseType EndGetMyeBayReminders(
    IAsyncResult asyncResult
)
Public Function EndGetMyeBayReminders ( _
    asyncResult As IAsyncResult _
) As GetMyeBayRemindersResponseType
public:
GetMyeBayRemindersResponseType^ EndGetMyeBayReminders(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetMyeBaySelling Method (asyncResult)

EndGetMyeBaySelling Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetMyeBaySelling(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBaySellingResponseType EndGetMyeBaySelling(
    IAsyncResult asyncResult
)
Public Function EndGetMyeBaySelling ( _
    asyncResult As IAsyncResult _
) As GetMyeBaySellingResponseType
public:
GetMyeBaySellingResponseType^ EndGetMyeBaySelling(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetMyMessages Method (asyncResult)

EndGetMyMessages Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetMyMessages(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetMyMessagesResponseType EndGetMyMessages(
    IAsyncResult asyncResult
)
Public Function EndGetMyMessages ( _
    asyncResult As IAsyncResult _
) As GetMyMessagesResponseType
public:
GetMyMessagesResponseType^ EndGetMyMessages(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetNotificationPreferences Method (asyncResult)

EndGetNotificationPreferences Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetNotificationPreferences(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationPreferencesResponseType EndGetNotificationPreferences(
    IAsyncResult asyncResult
)
Public Function EndGetNotificationPreferences ( _
    asyncResult As IAsyncResult _
) As GetNotificationPreferencesResponseType
public:
GetNotificationPreferencesResponseType^ EndGetNotificationPreferences(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetNotificationsUsage Method (asyncResult)

EndGetNotificationsUsage Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetNotificationsUsage(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationsUsageResponseType EndGetNotificationsUsage(
    IAsyncResult asyncResult
)
Public Function EndGetNotificationsUsage ( _
    asyncResult As IAsyncResult _
) As GetNotificationsUsageResponseType
public:
GetNotificationsUsageResponseType^ EndGetNotificationsUsage(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetOrders Method (asyncResult)

EndGetOrders Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetOrders(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetOrdersResponseType EndGetOrders(
    IAsyncResult asyncResult
)
Public Function EndGetOrders ( _
    asyncResult As IAsyncResult _
) As GetOrdersResponseType
public:
GetOrdersResponseType^ EndGetOrders(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetOrderTransactions Method (asyncResult)

EndGetOrderTransactions Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetOrderTransactions(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetOrderTransactionsResponseType EndGetOrderTransactions(
    IAsyncResult asyncResult
)
Public Function EndGetOrderTransactions ( _
    asyncResult As IAsyncResult _
) As GetOrderTransactionsResponseType
public:
GetOrderTransactionsResponseType^ EndGetOrderTransactions(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetProductSellingPages Method (asyncResult)

EndGetProductSellingPages Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetProductSellingPages(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetProductSellingPagesResponseType EndGetProductSellingPages(
    IAsyncResult asyncResult
)
Public Function EndGetProductSellingPages ( _
    asyncResult As IAsyncResult _
) As GetProductSellingPagesResponseType
public:
GetProductSellingPagesResponseType^ EndGetProductSellingPages(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetPromotionalSaleDetails Method (asyncResult)

EndGetPromotionalSaleDetails Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetPromotionalSaleDetails(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetPromotionalSaleDetailsResponseType EndGetPromotionalSaleDetails(
    IAsyncResult asyncResult
)
Public Function EndGetPromotionalSaleDetails ( _
    asyncResult As IAsyncResult _
) As GetPromotionalSaleDetailsResponseType
public:
GetPromotionalSaleDetailsResponseType^ EndGetPromotionalSaleDetails(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellerDashboard Method (asyncResult)

EndGetSellerDashboard Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellerDashboard(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerDashboardResponseType EndGetSellerDashboard(
    IAsyncResult asyncResult
)
Public Function EndGetSellerDashboard ( _
    asyncResult As IAsyncResult _
) As GetSellerDashboardResponseType
public:
GetSellerDashboardResponseType^ EndGetSellerDashboard(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellerEvents Method (asyncResult)

EndGetSellerEvents Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellerEvents(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerEventsResponseType EndGetSellerEvents(
    IAsyncResult asyncResult
)
Public Function EndGetSellerEvents ( _
    asyncResult As IAsyncResult _
) As GetSellerEventsResponseType
public:
GetSellerEventsResponseType^ EndGetSellerEvents(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellerList Method (asyncResult)

EndGetSellerList Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellerList(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerListResponseType EndGetSellerList(
    IAsyncResult asyncResult
)
Public Function EndGetSellerList ( _
    asyncResult As IAsyncResult _
) As GetSellerListResponseType
public:
GetSellerListResponseType^ EndGetSellerList(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellerPayments Method (asyncResult)

EndGetSellerPayments Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellerPayments(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerPaymentsResponseType EndGetSellerPayments(
    IAsyncResult asyncResult
)
Public Function EndGetSellerPayments ( _
    asyncResult As IAsyncResult _
) As GetSellerPaymentsResponseType
public:
GetSellerPaymentsResponseType^ EndGetSellerPayments(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellerTransactions Method (asyncResult)

EndGetSellerTransactions Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellerTransactions(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerTransactionsResponseType EndGetSellerTransactions(
    IAsyncResult asyncResult
)
Public Function EndGetSellerTransactions ( _
    asyncResult As IAsyncResult _
) As GetSellerTransactionsResponseType
public:
GetSellerTransactionsResponseType^ EndGetSellerTransactions(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellingManagerAlerts Method (asyncResult)

EndGetSellingManagerAlerts Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellingManagerAlerts(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerAlertsResponseType EndGetSellingManagerAlerts(
    IAsyncResult asyncResult
)
Public Function EndGetSellingManagerAlerts ( _
    asyncResult As IAsyncResult _
) As GetSellingManagerAlertsResponseType
public:
GetSellingManagerAlertsResponseType^ EndGetSellingManagerAlerts(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellingManagerEmailLog Method (asyncResult)

EndGetSellingManagerEmailLog Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellingManagerEmailLog(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerEmailLogResponseType EndGetSellingManagerEmailLog(
    IAsyncResult asyncResult
)
Public Function EndGetSellingManagerEmailLog ( _
    asyncResult As IAsyncResult _
) As GetSellingManagerEmailLogResponseType
public:
GetSellingManagerEmailLogResponseType^ EndGetSellingManagerEmailLog(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellingManagerInventory Method (asyncResult)

EndGetSellingManagerInventory Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellingManagerInventory(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryResponseType EndGetSellingManagerInventory(
    IAsyncResult asyncResult
)
Public Function EndGetSellingManagerInventory ( _
    asyncResult As IAsyncResult _
) As GetSellingManagerInventoryResponseType
public:
GetSellingManagerInventoryResponseType^ EndGetSellingManagerInventory(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellingManagerInventoryFolder Method (asyncResult)

EndGetSellingManagerInventoryFolder Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellingManagerInventoryFolder(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryFolderResponseType EndGetSellingManagerInventoryFolder(
    IAsyncResult asyncResult
)
Public Function EndGetSellingManagerInventoryFolder ( _
    asyncResult As IAsyncResult _
) As GetSellingManagerInventoryFolderResponseType
public:
GetSellingManagerInventoryFolderResponseType^ EndGetSellingManagerInventoryFolder(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellingManagerItemAutomationRule Method (asyncResult)

EndGetSellingManagerItemAutomationRule Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellingManagerItemAutomationRule(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerItemAutomationRuleResponseType EndGetSellingManagerItemAutomationRule(
    IAsyncResult asyncResult
)
Public Function EndGetSellingManagerItemAutomationRule ( _
    asyncResult As IAsyncResult _
) As GetSellingManagerItemAutomationRuleResponseType
public:
GetSellingManagerItemAutomationRuleResponseType^ EndGetSellingManagerItemAutomationRule(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellingManagerSaleRecord Method (asyncResult)

EndGetSellingManagerSaleRecord Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellingManagerSaleRecord(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSaleRecordResponseType EndGetSellingManagerSaleRecord(
    IAsyncResult asyncResult
)
Public Function EndGetSellingManagerSaleRecord ( _
    asyncResult As IAsyncResult _
) As GetSellingManagerSaleRecordResponseType
public:
GetSellingManagerSaleRecordResponseType^ EndGetSellingManagerSaleRecord(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellingManagerSoldListings Method (asyncResult)

EndGetSellingManagerSoldListings Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellingManagerSoldListings(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSoldListingsResponseType EndGetSellingManagerSoldListings(
    IAsyncResult asyncResult
)
Public Function EndGetSellingManagerSoldListings ( _
    asyncResult As IAsyncResult _
) As GetSellingManagerSoldListingsResponseType
public:
GetSellingManagerSoldListingsResponseType^ EndGetSellingManagerSoldListings(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellingManagerTemplateAutomationRule Method (asyncResult)

EndGetSellingManagerTemplateAutomationRule Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellingManagerTemplateAutomationRule(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplateAutomationRuleResponseType EndGetSellingManagerTemplateAutomationRule(
    IAsyncResult asyncResult
)
Public Function EndGetSellingManagerTemplateAutomationRule ( _
    asyncResult As IAsyncResult _
) As GetSellingManagerTemplateAutomationRuleResponseType
public:
GetSellingManagerTemplateAutomationRuleResponseType^ EndGetSellingManagerTemplateAutomationRule(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSellingManagerTemplates Method (asyncResult)

EndGetSellingManagerTemplates Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSellingManagerTemplates(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplatesResponseType EndGetSellingManagerTemplates(
    IAsyncResult asyncResult
)
Public Function EndGetSellingManagerTemplates ( _
    asyncResult As IAsyncResult _
) As GetSellingManagerTemplatesResponseType
public:
GetSellingManagerTemplatesResponseType^ EndGetSellingManagerTemplates(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSessionID Method (asyncResult)

EndGetSessionID Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSessionID(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSessionIDResponseType EndGetSessionID(
    IAsyncResult asyncResult
)
Public Function EndGetSessionID ( _
    asyncResult As IAsyncResult _
) As GetSessionIDResponseType
public:
GetSessionIDResponseType^ EndGetSessionID(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetShippingDiscountProfiles Method (asyncResult)

EndGetShippingDiscountProfiles Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetShippingDiscountProfiles(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetShippingDiscountProfilesResponseType EndGetShippingDiscountProfiles(
    IAsyncResult asyncResult
)
Public Function EndGetShippingDiscountProfiles ( _
    asyncResult As IAsyncResult _
) As GetShippingDiscountProfilesResponseType
public:
GetShippingDiscountProfilesResponseType^ EndGetShippingDiscountProfiles(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetStore Method (asyncResult)

EndGetStore Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetStore(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreResponseType EndGetStore(
    IAsyncResult asyncResult
)
Public Function EndGetStore ( _
    asyncResult As IAsyncResult _
) As GetStoreResponseType
public:
GetStoreResponseType^ EndGetStore(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetStoreCategoryUpdateStatus Method (asyncResult)

EndGetStoreCategoryUpdateStatus Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetStoreCategoryUpdateStatus(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCategoryUpdateStatusResponseType EndGetStoreCategoryUpdateStatus(
    IAsyncResult asyncResult
)
Public Function EndGetStoreCategoryUpdateStatus ( _
    asyncResult As IAsyncResult _
) As GetStoreCategoryUpdateStatusResponseType
public:
GetStoreCategoryUpdateStatusResponseType^ EndGetStoreCategoryUpdateStatus(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetStoreCustomPage Method (asyncResult)

EndGetStoreCustomPage Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetStoreCustomPage(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCustomPageResponseType EndGetStoreCustomPage(
    IAsyncResult asyncResult
)
Public Function EndGetStoreCustomPage ( _
    asyncResult As IAsyncResult _
) As GetStoreCustomPageResponseType
public:
GetStoreCustomPageResponseType^ EndGetStoreCustomPage(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetStoreOptions Method (asyncResult)

EndGetStoreOptions Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetStoreOptions(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreOptionsResponseType EndGetStoreOptions(
    IAsyncResult asyncResult
)
Public Function EndGetStoreOptions ( _
    asyncResult As IAsyncResult _
) As GetStoreOptionsResponseType
public:
GetStoreOptionsResponseType^ EndGetStoreOptions(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetStorePreferences Method (asyncResult)

EndGetStorePreferences Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetStorePreferences(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetStorePreferencesResponseType EndGetStorePreferences(
    IAsyncResult asyncResult
)
Public Function EndGetStorePreferences ( _
    asyncResult As IAsyncResult _
) As GetStorePreferencesResponseType
public:
GetStorePreferencesResponseType^ EndGetStorePreferences(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetSuggestedCategories Method (asyncResult)

EndGetSuggestedCategories Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetSuggestedCategories(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetSuggestedCategoriesResponseType EndGetSuggestedCategories(
    IAsyncResult asyncResult
)
Public Function EndGetSuggestedCategories ( _
    asyncResult As IAsyncResult _
) As GetSuggestedCategoriesResponseType
public:
GetSuggestedCategoriesResponseType^ EndGetSuggestedCategories(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetTaxTable Method (asyncResult)

EndGetTaxTable Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetTaxTable(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetTaxTableResponseType EndGetTaxTable(
    IAsyncResult asyncResult
)
Public Function EndGetTaxTable ( _
    asyncResult As IAsyncResult _
) As GetTaxTableResponseType
public:
GetTaxTableResponseType^ EndGetTaxTable(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetTokenStatus Method (asyncResult)

EndGetTokenStatus Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetTokenStatus(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetTokenStatusResponseType EndGetTokenStatus(
    IAsyncResult asyncResult
)
Public Function EndGetTokenStatus ( _
    asyncResult As IAsyncResult _
) As GetTokenStatusResponseType
public:
GetTokenStatusResponseType^ EndGetTokenStatus(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetUser Method (asyncResult)

EndGetUser Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetUser(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetUserResponseType EndGetUser(
    IAsyncResult asyncResult
)
Public Function EndGetUser ( _
    asyncResult As IAsyncResult _
) As GetUserResponseType
public:
GetUserResponseType^ EndGetUser(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetUserContactDetails Method (asyncResult)

EndGetUserContactDetails Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetUserContactDetails(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetUserContactDetailsResponseType EndGetUserContactDetails(
    IAsyncResult asyncResult
)
Public Function EndGetUserContactDetails ( _
    asyncResult As IAsyncResult _
) As GetUserContactDetailsResponseType
public:
GetUserContactDetailsResponseType^ EndGetUserContactDetails(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetUserDisputes Method (asyncResult)

EndGetUserDisputes Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetUserDisputes(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetUserDisputesResponseType EndGetUserDisputes(
    IAsyncResult asyncResult
)
Public Function EndGetUserDisputes ( _
    asyncResult As IAsyncResult _
) As GetUserDisputesResponseType
public:
GetUserDisputesResponseType^ EndGetUserDisputes(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetUserPreferences Method (asyncResult)

EndGetUserPreferences Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetUserPreferences(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetUserPreferencesResponseType EndGetUserPreferences(
    IAsyncResult asyncResult
)
Public Function EndGetUserPreferences ( _
    asyncResult As IAsyncResult _
) As GetUserPreferencesResponseType
public:
GetUserPreferencesResponseType^ EndGetUserPreferences(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetVeROReasonCodeDetails Method (asyncResult)

EndGetVeROReasonCodeDetails Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetVeROReasonCodeDetails(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReasonCodeDetailsResponseType EndGetVeROReasonCodeDetails(
    IAsyncResult asyncResult
)
Public Function EndGetVeROReasonCodeDetails ( _
    asyncResult As IAsyncResult _
) As GetVeROReasonCodeDetailsResponseType
public:
GetVeROReasonCodeDetailsResponseType^ EndGetVeROReasonCodeDetails(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndGetVeROReportStatus Method (asyncResult)

EndGetVeROReportStatus Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndGetVeROReportStatus(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReportStatusResponseType EndGetVeROReportStatus(
    IAsyncResult asyncResult
)
Public Function EndGetVeROReportStatus ( _
    asyncResult As IAsyncResult _
) As GetVeROReportStatusResponseType
public:
GetVeROReportStatusResponseType^ EndGetVeROReportStatus(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndIssueRefund Method (asyncResult)

EndIssueRefund Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndIssueRefund(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public IssueRefundResponseType EndIssueRefund(
    IAsyncResult asyncResult
)
Public Function EndIssueRefund ( _
    asyncResult As IAsyncResult _
) As IssueRefundResponseType
public:
IssueRefundResponseType^ EndIssueRefund(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndItem Method (EndItemRequest)

EndItem Method (EndItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndItem(EndItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public EndItemResponseType EndItem(
    EndItemRequestType EndItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function EndItem ( _
    EndItemRequest As EndItemRequestType _
) As EndItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
EndItemResponseType^ EndItem(
    EndItemRequestType^ EndItemRequest
)
Parameters
EndItemRequest (EndItemRequestType)
Remarks


EndItems Method (EndItemsRequest)

EndItems Method (EndItemsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndItems(EndItemsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public EndItemsResponseType EndItems(
    EndItemsRequestType EndItemsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function EndItems ( _
    EndItemsRequest As EndItemsRequestType _
) As EndItemsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
EndItemsResponseType^ EndItems(
    EndItemsRequestType^ EndItemsRequest
)
Parameters
EndItemsRequest (EndItemsRequestType)
Remarks


EndLeaveFeedback Method (asyncResult)

EndLeaveFeedback Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndLeaveFeedback(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public LeaveFeedbackResponseType EndLeaveFeedback(
    IAsyncResult asyncResult
)
Public Function EndLeaveFeedback ( _
    asyncResult As IAsyncResult _
) As LeaveFeedbackResponseType
public:
LeaveFeedbackResponseType^ EndLeaveFeedback(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndMoveSellingManagerInventoryFolder Method (asyncResult)

EndMoveSellingManagerInventoryFolder Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndMoveSellingManagerInventoryFolder(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public MoveSellingManagerInventoryFolderResponseType EndMoveSellingManagerInventoryFolder(
    IAsyncResult asyncResult
)
Public Function EndMoveSellingManagerInventoryFolder ( _
    asyncResult As IAsyncResult _
) As MoveSellingManagerInventoryFolderResponseType
public:
MoveSellingManagerInventoryFolderResponseType^ EndMoveSellingManagerInventoryFolder(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndPlaceOffer Method (asyncResult)

EndPlaceOffer Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndPlaceOffer(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public PlaceOfferResponseType EndPlaceOffer(
    IAsyncResult asyncResult
)
Public Function EndPlaceOffer ( _
    asyncResult As IAsyncResult _
) As PlaceOfferResponseType
public:
PlaceOfferResponseType^ EndPlaceOffer(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndRelistFixedPriceItem Method (asyncResult)

EndRelistFixedPriceItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndRelistFixedPriceItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public RelistFixedPriceItemResponseType EndRelistFixedPriceItem(
    IAsyncResult asyncResult
)
Public Function EndRelistFixedPriceItem ( _
    asyncResult As IAsyncResult _
) As RelistFixedPriceItemResponseType
public:
RelistFixedPriceItemResponseType^ EndRelistFixedPriceItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndRelistItem Method (asyncResult)

EndRelistItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndRelistItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public RelistItemResponseType EndRelistItem(
    IAsyncResult asyncResult
)
Public Function EndRelistItem ( _
    asyncResult As IAsyncResult _
) As RelistItemResponseType
public:
RelistItemResponseType^ EndRelistItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndRemoveFromWatchList Method (asyncResult)

EndRemoveFromWatchList Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndRemoveFromWatchList(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public RemoveFromWatchListResponseType EndRemoveFromWatchList(
    IAsyncResult asyncResult
)
Public Function EndRemoveFromWatchList ( _
    asyncResult As IAsyncResult _
) As RemoveFromWatchListResponseType
public:
RemoveFromWatchListResponseType^ EndRemoveFromWatchList(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndRespondToBestOffer Method (asyncResult)

EndRespondToBestOffer Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndRespondToBestOffer(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public RespondToBestOfferResponseType EndRespondToBestOffer(
    IAsyncResult asyncResult
)
Public Function EndRespondToBestOffer ( _
    asyncResult As IAsyncResult _
) As RespondToBestOfferResponseType
public:
RespondToBestOfferResponseType^ EndRespondToBestOffer(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndRespondToFeedback Method (asyncResult)

EndRespondToFeedback Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndRespondToFeedback(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public RespondToFeedbackResponseType EndRespondToFeedback(
    IAsyncResult asyncResult
)
Public Function EndRespondToFeedback ( _
    asyncResult As IAsyncResult _
) As RespondToFeedbackResponseType
public:
RespondToFeedbackResponseType^ EndRespondToFeedback(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndReviseCheckoutStatus Method (asyncResult)

EndReviseCheckoutStatus Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndReviseCheckoutStatus(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseCheckoutStatusResponseType EndReviseCheckoutStatus(
    IAsyncResult asyncResult
)
Public Function EndReviseCheckoutStatus ( _
    asyncResult As IAsyncResult _
) As ReviseCheckoutStatusResponseType
public:
ReviseCheckoutStatusResponseType^ EndReviseCheckoutStatus(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndReviseFixedPriceItem Method (asyncResult)

EndReviseFixedPriceItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndReviseFixedPriceItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseFixedPriceItemResponseType EndReviseFixedPriceItem(
    IAsyncResult asyncResult
)
Public Function EndReviseFixedPriceItem ( _
    asyncResult As IAsyncResult _
) As ReviseFixedPriceItemResponseType
public:
ReviseFixedPriceItemResponseType^ EndReviseFixedPriceItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndReviseInventoryStatus Method (asyncResult)

EndReviseInventoryStatus Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndReviseInventoryStatus(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseInventoryStatusResponseType EndReviseInventoryStatus(
    IAsyncResult asyncResult
)
Public Function EndReviseInventoryStatus ( _
    asyncResult As IAsyncResult _
) As ReviseInventoryStatusResponseType
public:
ReviseInventoryStatusResponseType^ EndReviseInventoryStatus(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndReviseItem Method (asyncResult)

EndReviseItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndReviseItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseItemResponseType EndReviseItem(
    IAsyncResult asyncResult
)
Public Function EndReviseItem ( _
    asyncResult As IAsyncResult _
) As ReviseItemResponseType
public:
ReviseItemResponseType^ EndReviseItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndReviseMyMessages Method (asyncResult)

EndReviseMyMessages Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndReviseMyMessages(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesResponseType EndReviseMyMessages(
    IAsyncResult asyncResult
)
Public Function EndReviseMyMessages ( _
    asyncResult As IAsyncResult _
) As ReviseMyMessagesResponseType
public:
ReviseMyMessagesResponseType^ EndReviseMyMessages(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndReviseMyMessagesFolders Method (asyncResult)

EndReviseMyMessagesFolders Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndReviseMyMessagesFolders(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesFoldersResponseType EndReviseMyMessagesFolders(
    IAsyncResult asyncResult
)
Public Function EndReviseMyMessagesFolders ( _
    asyncResult As IAsyncResult _
) As ReviseMyMessagesFoldersResponseType
public:
ReviseMyMessagesFoldersResponseType^ EndReviseMyMessagesFolders(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndReviseSellingManagerInventoryFolder Method (asyncResult)

EndReviseSellingManagerInventoryFolder Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndReviseSellingManagerInventoryFolder(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerInventoryFolderResponseType EndReviseSellingManagerInventoryFolder(
    IAsyncResult asyncResult
)
Public Function EndReviseSellingManagerInventoryFolder ( _
    asyncResult As IAsyncResult _
) As ReviseSellingManagerInventoryFolderResponseType
public:
ReviseSellingManagerInventoryFolderResponseType^ EndReviseSellingManagerInventoryFolder(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndReviseSellingManagerProduct Method (asyncResult)

EndReviseSellingManagerProduct Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndReviseSellingManagerProduct(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerProductResponseType EndReviseSellingManagerProduct(
    IAsyncResult asyncResult
)
Public Function EndReviseSellingManagerProduct ( _
    asyncResult As IAsyncResult _
) As ReviseSellingManagerProductResponseType
public:
ReviseSellingManagerProductResponseType^ EndReviseSellingManagerProduct(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndReviseSellingManagerSaleRecord Method (asyncResult)

EndReviseSellingManagerSaleRecord Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndReviseSellingManagerSaleRecord(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerSaleRecordResponseType EndReviseSellingManagerSaleRecord(
    IAsyncResult asyncResult
)
Public Function EndReviseSellingManagerSaleRecord ( _
    asyncResult As IAsyncResult _
) As ReviseSellingManagerSaleRecordResponseType
public:
ReviseSellingManagerSaleRecordResponseType^ EndReviseSellingManagerSaleRecord(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndReviseSellingManagerTemplate Method (asyncResult)

EndReviseSellingManagerTemplate Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndReviseSellingManagerTemplate(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerTemplateResponseType EndReviseSellingManagerTemplate(
    IAsyncResult asyncResult
)
Public Function EndReviseSellingManagerTemplate ( _
    asyncResult As IAsyncResult _
) As ReviseSellingManagerTemplateResponseType
public:
ReviseSellingManagerTemplateResponseType^ EndReviseSellingManagerTemplate(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndRevokeToken Method (asyncResult)

EndRevokeToken Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndRevokeToken(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public RevokeTokenResponseType EndRevokeToken(
    IAsyncResult asyncResult
)
Public Function EndRevokeToken ( _
    asyncResult As IAsyncResult _
) As RevokeTokenResponseType
public:
RevokeTokenResponseType^ EndRevokeToken(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSaveItemToSellingManagerTemplate Method (asyncResult)

EndSaveItemToSellingManagerTemplate Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSaveItemToSellingManagerTemplate(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SaveItemToSellingManagerTemplateResponseType EndSaveItemToSellingManagerTemplate(
    IAsyncResult asyncResult
)
Public Function EndSaveItemToSellingManagerTemplate ( _
    asyncResult As IAsyncResult _
) As SaveItemToSellingManagerTemplateResponseType
public:
SaveItemToSellingManagerTemplateResponseType^ EndSaveItemToSellingManagerTemplate(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSellerReverseDispute Method (asyncResult)

EndSellerReverseDispute Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSellerReverseDispute(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SellerReverseDisputeResponseType EndSellerReverseDispute(
    IAsyncResult asyncResult
)
Public Function EndSellerReverseDispute ( _
    asyncResult As IAsyncResult _
) As SellerReverseDisputeResponseType
public:
SellerReverseDisputeResponseType^ EndSellerReverseDispute(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSendInvoice Method (asyncResult)

EndSendInvoice Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSendInvoice(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SendInvoiceResponseType EndSendInvoice(
    IAsyncResult asyncResult
)
Public Function EndSendInvoice ( _
    asyncResult As IAsyncResult _
) As SendInvoiceResponseType
public:
SendInvoiceResponseType^ EndSendInvoice(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetMessagePreferences Method (asyncResult)

EndSetMessagePreferences Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetMessagePreferences(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetMessagePreferencesResponseType EndSetMessagePreferences(
    IAsyncResult asyncResult
)
Public Function EndSetMessagePreferences ( _
    asyncResult As IAsyncResult _
) As SetMessagePreferencesResponseType
public:
SetMessagePreferencesResponseType^ EndSetMessagePreferences(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetNotificationPreferences Method (asyncResult)

EndSetNotificationPreferences Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetNotificationPreferences(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetNotificationPreferencesResponseType EndSetNotificationPreferences(
    IAsyncResult asyncResult
)
Public Function EndSetNotificationPreferences ( _
    asyncResult As IAsyncResult _
) As SetNotificationPreferencesResponseType
public:
SetNotificationPreferencesResponseType^ EndSetNotificationPreferences(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetPromotionalSale Method (asyncResult)

EndSetPromotionalSale Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetPromotionalSale(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleResponseType EndSetPromotionalSale(
    IAsyncResult asyncResult
)
Public Function EndSetPromotionalSale ( _
    asyncResult As IAsyncResult _
) As SetPromotionalSaleResponseType
public:
SetPromotionalSaleResponseType^ EndSetPromotionalSale(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetPromotionalSaleListings Method (asyncResult)

EndSetPromotionalSaleListings Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetPromotionalSaleListings(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleListingsResponseType EndSetPromotionalSaleListings(
    IAsyncResult asyncResult
)
Public Function EndSetPromotionalSaleListings ( _
    asyncResult As IAsyncResult _
) As SetPromotionalSaleListingsResponseType
public:
SetPromotionalSaleListingsResponseType^ EndSetPromotionalSaleListings(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetSellingManagerFeedbackOptions Method (asyncResult)

EndSetSellingManagerFeedbackOptions Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetSellingManagerFeedbackOptions(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerFeedbackOptionsResponseType EndSetSellingManagerFeedbackOptions(
    IAsyncResult asyncResult
)
Public Function EndSetSellingManagerFeedbackOptions ( _
    asyncResult As IAsyncResult _
) As SetSellingManagerFeedbackOptionsResponseType
public:
SetSellingManagerFeedbackOptionsResponseType^ EndSetSellingManagerFeedbackOptions(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetSellingManagerItemAutomationRule Method (asyncResult)

EndSetSellingManagerItemAutomationRule Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetSellingManagerItemAutomationRule(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerItemAutomationRuleResponseType EndSetSellingManagerItemAutomationRule(
    IAsyncResult asyncResult
)
Public Function EndSetSellingManagerItemAutomationRule ( _
    asyncResult As IAsyncResult _
) As SetSellingManagerItemAutomationRuleResponseType
public:
SetSellingManagerItemAutomationRuleResponseType^ EndSetSellingManagerItemAutomationRule(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetSellingManagerTemplateAutomationRule Method (asyncResult)

EndSetSellingManagerTemplateAutomationRule Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetSellingManagerTemplateAutomationRule(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerTemplateAutomationRuleResponseType EndSetSellingManagerTemplateAutomationRule(
    IAsyncResult asyncResult
)
Public Function EndSetSellingManagerTemplateAutomationRule ( _
    asyncResult As IAsyncResult _
) As SetSellingManagerTemplateAutomationRuleResponseType
public:
SetSellingManagerTemplateAutomationRuleResponseType^ EndSetSellingManagerTemplateAutomationRule(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetShippingDiscountProfiles Method (asyncResult)

EndSetShippingDiscountProfiles Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetShippingDiscountProfiles(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetShippingDiscountProfilesResponseType EndSetShippingDiscountProfiles(
    IAsyncResult asyncResult
)
Public Function EndSetShippingDiscountProfiles ( _
    asyncResult As IAsyncResult _
) As SetShippingDiscountProfilesResponseType
public:
SetShippingDiscountProfilesResponseType^ EndSetShippingDiscountProfiles(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetStore Method (asyncResult)

EndSetStore Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetStore(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreResponseType EndSetStore(
    IAsyncResult asyncResult
)
Public Function EndSetStore ( _
    asyncResult As IAsyncResult _
) As SetStoreResponseType
public:
SetStoreResponseType^ EndSetStore(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetStoreCategories Method (asyncResult)

EndSetStoreCategories Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetStoreCategories(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCategoriesResponseType EndSetStoreCategories(
    IAsyncResult asyncResult
)
Public Function EndSetStoreCategories ( _
    asyncResult As IAsyncResult _
) As SetStoreCategoriesResponseType
public:
SetStoreCategoriesResponseType^ EndSetStoreCategories(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetStoreCustomPage Method (asyncResult)

EndSetStoreCustomPage Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetStoreCustomPage(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCustomPageResponseType EndSetStoreCustomPage(
    IAsyncResult asyncResult
)
Public Function EndSetStoreCustomPage ( _
    asyncResult As IAsyncResult _
) As SetStoreCustomPageResponseType
public:
SetStoreCustomPageResponseType^ EndSetStoreCustomPage(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetStorePreferences Method (asyncResult)

EndSetStorePreferences Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetStorePreferences(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetStorePreferencesResponseType EndSetStorePreferences(
    IAsyncResult asyncResult
)
Public Function EndSetStorePreferences ( _
    asyncResult As IAsyncResult _
) As SetStorePreferencesResponseType
public:
SetStorePreferencesResponseType^ EndSetStorePreferences(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetTaxTable Method (asyncResult)

EndSetTaxTable Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetTaxTable(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetTaxTableResponseType EndSetTaxTable(
    IAsyncResult asyncResult
)
Public Function EndSetTaxTable ( _
    asyncResult As IAsyncResult _
) As SetTaxTableResponseType
public:
SetTaxTableResponseType^ EndSetTaxTable(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetUserNotes Method (asyncResult)

EndSetUserNotes Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetUserNotes(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetUserNotesResponseType EndSetUserNotes(
    IAsyncResult asyncResult
)
Public Function EndSetUserNotes ( _
    asyncResult As IAsyncResult _
) As SetUserNotesResponseType
public:
SetUserNotesResponseType^ EndSetUserNotes(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndSetUserPreferences Method (asyncResult)

EndSetUserPreferences Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndSetUserPreferences(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public SetUserPreferencesResponseType EndSetUserPreferences(
    IAsyncResult asyncResult
)
Public Function EndSetUserPreferences ( _
    asyncResult As IAsyncResult _
) As SetUserPreferencesResponseType
public:
SetUserPreferencesResponseType^ EndSetUserPreferences(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndValidateChallengeInput Method (asyncResult)

EndValidateChallengeInput Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndValidateChallengeInput(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ValidateChallengeInputResponseType EndValidateChallengeInput(
    IAsyncResult asyncResult
)
Public Function EndValidateChallengeInput ( _
    asyncResult As IAsyncResult _
) As ValidateChallengeInputResponseType
public:
ValidateChallengeInputResponseType^ EndValidateChallengeInput(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndValidateTestUserRegistration Method (asyncResult)

EndValidateTestUserRegistration Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndValidateTestUserRegistration(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public ValidateTestUserRegistrationResponseType EndValidateTestUserRegistration(
    IAsyncResult asyncResult
)
Public Function EndValidateTestUserRegistration ( _
    asyncResult As IAsyncResult _
) As ValidateTestUserRegistrationResponseType
public:
ValidateTestUserRegistrationResponseType^ EndValidateTestUserRegistration(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndVerifyAddFixedPriceItem Method (asyncResult)

EndVerifyAddFixedPriceItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndVerifyAddFixedPriceItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddFixedPriceItemResponseType EndVerifyAddFixedPriceItem(
    IAsyncResult asyncResult
)
Public Function EndVerifyAddFixedPriceItem ( _
    asyncResult As IAsyncResult _
) As VerifyAddFixedPriceItemResponseType
public:
VerifyAddFixedPriceItemResponseType^ EndVerifyAddFixedPriceItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndVerifyAddItem Method (asyncResult)

EndVerifyAddItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndVerifyAddItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddItemResponseType EndVerifyAddItem(
    IAsyncResult asyncResult
)
Public Function EndVerifyAddItem ( _
    asyncResult As IAsyncResult _
) As VerifyAddItemResponseType
public:
VerifyAddItemResponseType^ EndVerifyAddItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndVerifyAddSecondChanceItem Method (asyncResult)

EndVerifyAddSecondChanceItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndVerifyAddSecondChanceItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddSecondChanceItemResponseType EndVerifyAddSecondChanceItem(
    IAsyncResult asyncResult
)
Public Function EndVerifyAddSecondChanceItem ( _
    asyncResult As IAsyncResult _
) As VerifyAddSecondChanceItemResponseType
public:
VerifyAddSecondChanceItemResponseType^ EndVerifyAddSecondChanceItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndVerifyRelistItem Method (asyncResult)

EndVerifyRelistItem Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndVerifyRelistItem(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public VerifyRelistItemResponseType EndVerifyRelistItem(
    IAsyncResult asyncResult
)
Public Function EndVerifyRelistItem ( _
    asyncResult As IAsyncResult _
) As VerifyRelistItemResponseType
public:
VerifyRelistItemResponseType^ EndVerifyRelistItem(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


EndVeROReportItems Method (asyncResult)

EndVeROReportItems Method (asyncResult)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► EndVeROReportItems(IAsyncResult)
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemsResponseType EndVeROReportItems(
    IAsyncResult asyncResult
)
Public Function EndVeROReportItems ( _
    asyncResult As IAsyncResult _
) As VeROReportItemsResponseType
public:
VeROReportItemsResponseType^ EndVeROReportItems(
    IAsyncResult^ asyncResult
)
Parameters
asyncResult (IAsyncResult)
Remarks


ExtendSiteHostedPictures Method (ExtendSiteHostedPicturesRequest)

ExtendSiteHostedPictures Method (ExtendSiteHostedPicturesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ExtendSiteHostedPictures(ExtendSiteHostedPicturesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ExtendSiteHostedPicturesResponseType ExtendSiteHostedPictures(
    ExtendSiteHostedPicturesRequestType ExtendSiteHostedPicturesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ExtendSiteHostedPictures ( _
    ExtendSiteHostedPicturesRequest As ExtendSiteHostedPicturesRequestType _
) As ExtendSiteHostedPicturesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ExtendSiteHostedPicturesResponseType^ ExtendSiteHostedPictures(
    ExtendSiteHostedPicturesRequestType^ ExtendSiteHostedPicturesRequest
)
Parameters
ExtendSiteHostedPicturesRequest (ExtendSiteHostedPicturesRequestType)
Remarks


FetchToken Method (FetchTokenRequest)

FetchToken Method (FetchTokenRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► FetchToken(FetchTokenRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public FetchTokenResponseType FetchToken(
    FetchTokenRequestType FetchTokenRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function FetchToken ( _
    FetchTokenRequest As FetchTokenRequestType _
) As FetchTokenResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
FetchTokenResponseType^ FetchToken(
    FetchTokenRequestType^ FetchTokenRequest
)
Parameters
FetchTokenRequest (FetchTokenRequestType)
Remarks


GetAccount Method (GetAccountRequest)

GetAccount Method (GetAccountRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetAccount(GetAccountRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetAccountResponseType GetAccount(
    GetAccountRequestType GetAccountRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetAccount ( _
    GetAccountRequest As GetAccountRequestType _
) As GetAccountResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetAccountResponseType^ GetAccount(
    GetAccountRequestType^ GetAccountRequest
)
Parameters
GetAccountRequest (GetAccountRequestType)
Remarks


GetAdFormatLeads Method (GetAdFormatLeadsRequest)

GetAdFormatLeads Method (GetAdFormatLeadsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetAdFormatLeads(GetAdFormatLeadsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetAdFormatLeadsResponseType GetAdFormatLeads(
    GetAdFormatLeadsRequestType GetAdFormatLeadsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetAdFormatLeads ( _
    GetAdFormatLeadsRequest As GetAdFormatLeadsRequestType _
) As GetAdFormatLeadsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetAdFormatLeadsResponseType^ GetAdFormatLeads(
    GetAdFormatLeadsRequestType^ GetAdFormatLeadsRequest
)
Parameters
GetAdFormatLeadsRequest (GetAdFormatLeadsRequestType)
Remarks


GetAllBidders Method (GetAllBiddersRequest)

GetAllBidders Method (GetAllBiddersRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetAllBidders(GetAllBiddersRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetAllBiddersResponseType GetAllBidders(
    GetAllBiddersRequestType GetAllBiddersRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetAllBidders ( _
    GetAllBiddersRequest As GetAllBiddersRequestType _
) As GetAllBiddersResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetAllBiddersResponseType^ GetAllBidders(
    GetAllBiddersRequestType^ GetAllBiddersRequest
)
Parameters
GetAllBiddersRequest (GetAllBiddersRequestType)
Remarks


GetApiAccessRules Method (GetApiAccessRulesRequest)

GetApiAccessRules Method (GetApiAccessRulesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetApiAccessRules(GetApiAccessRulesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetApiAccessRulesResponseType GetApiAccessRules(
    GetApiAccessRulesRequestType GetApiAccessRulesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetApiAccessRules ( _
    GetApiAccessRulesRequest As GetApiAccessRulesRequestType _
) As GetApiAccessRulesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetApiAccessRulesResponseType^ GetApiAccessRules(
    GetApiAccessRulesRequestType^ GetApiAccessRulesRequest
)
Parameters
GetApiAccessRulesRequest (GetApiAccessRulesRequestType)
Remarks


GetBestOffers Method (GetBestOffersRequest)

GetBestOffers Method (GetBestOffersRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetBestOffers(GetBestOffersRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetBestOffersResponseType GetBestOffers(
    GetBestOffersRequestType GetBestOffersRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetBestOffers ( _
    GetBestOffersRequest As GetBestOffersRequestType _
) As GetBestOffersResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetBestOffersResponseType^ GetBestOffers(
    GetBestOffersRequestType^ GetBestOffersRequest
)
Parameters
GetBestOffersRequest (GetBestOffersRequestType)
Remarks


GetBidderList Method (GetBidderListRequest)

GetBidderList Method (GetBidderListRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetBidderList(GetBidderListRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetBidderListResponseType GetBidderList(
    GetBidderListRequestType GetBidderListRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetBidderList ( _
    GetBidderListRequest As GetBidderListRequestType _
) As GetBidderListResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetBidderListResponseType^ GetBidderList(
    GetBidderListRequestType^ GetBidderListRequest
)
Parameters
GetBidderListRequest (GetBidderListRequestType)
Remarks


GetCategories Method (GetCategoriesRequest)

GetCategories Method (GetCategoriesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetCategories(GetCategoriesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetCategoriesResponseType GetCategories(
    GetCategoriesRequestType GetCategoriesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetCategories ( _
    GetCategoriesRequest As GetCategoriesRequestType _
) As GetCategoriesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetCategoriesResponseType^ GetCategories(
    GetCategoriesRequestType^ GetCategoriesRequest
)
Parameters
GetCategoriesRequest (GetCategoriesRequestType)
Remarks


GetCategoryFeatures Method (GetCategoryFeaturesRequest)

GetCategoryFeatures Method (GetCategoryFeaturesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetCategoryFeatures(GetCategoryFeaturesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetCategoryFeaturesResponseType GetCategoryFeatures(
    GetCategoryFeaturesRequestType GetCategoryFeaturesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetCategoryFeatures ( _
    GetCategoryFeaturesRequest As GetCategoryFeaturesRequestType _
) As GetCategoryFeaturesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetCategoryFeaturesResponseType^ GetCategoryFeatures(
    GetCategoryFeaturesRequestType^ GetCategoryFeaturesRequest
)
Parameters
GetCategoryFeaturesRequest (GetCategoryFeaturesRequestType)
Remarks


GetCategoryMappings Method (GetCategoryMappingsRequest)

GetCategoryMappings Method (GetCategoryMappingsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetCategoryMappings(GetCategoryMappingsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetCategoryMappingsResponseType GetCategoryMappings(
    GetCategoryMappingsRequestType GetCategoryMappingsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetCategoryMappings ( _
    GetCategoryMappingsRequest As GetCategoryMappingsRequestType _
) As GetCategoryMappingsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetCategoryMappingsResponseType^ GetCategoryMappings(
    GetCategoryMappingsRequestType^ GetCategoryMappingsRequest
)
Parameters
GetCategoryMappingsRequest (GetCategoryMappingsRequestType)
Remarks


GetCategorySpecifics Method (GetCategorySpecificsRequest)

GetCategorySpecifics Method (GetCategorySpecificsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetCategorySpecifics(GetCategorySpecificsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetCategorySpecificsResponseType GetCategorySpecifics(
    GetCategorySpecificsRequestType GetCategorySpecificsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetCategorySpecifics ( _
    GetCategorySpecificsRequest As GetCategorySpecificsRequestType _
) As GetCategorySpecificsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetCategorySpecificsResponseType^ GetCategorySpecifics(
    GetCategorySpecificsRequestType^ GetCategorySpecificsRequest
)
Parameters
GetCategorySpecificsRequest (GetCategorySpecificsRequestType)
Remarks


GetChallengeToken Method (GetChallengeTokenRequest)

GetChallengeToken Method (GetChallengeTokenRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetChallengeToken(GetChallengeTokenRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetChallengeTokenResponseType GetChallengeToken(
    GetChallengeTokenRequestType GetChallengeTokenRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetChallengeToken ( _
    GetChallengeTokenRequest As GetChallengeTokenRequestType _
) As GetChallengeTokenResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetChallengeTokenResponseType^ GetChallengeToken(
    GetChallengeTokenRequestType^ GetChallengeTokenRequest
)
Parameters
GetChallengeTokenRequest (GetChallengeTokenRequestType)
Remarks


GetCharities Method (GetCharitiesRequest)

GetCharities Method (GetCharitiesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetCharities(GetCharitiesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetCharitiesResponseType GetCharities(
    GetCharitiesRequestType GetCharitiesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetCharities ( _
    GetCharitiesRequest As GetCharitiesRequestType _
) As GetCharitiesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetCharitiesResponseType^ GetCharities(
    GetCharitiesRequestType^ GetCharitiesRequest
)
Parameters
GetCharitiesRequest (GetCharitiesRequestType)
Remarks


GetClientAlertsAuthToken Method (GetClientAlertsAuthTokenRequest)

GetClientAlertsAuthToken Method (GetClientAlertsAuthTokenRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetClientAlertsAuthToken(GetClientAlertsAuthTokenRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetClientAlertsAuthTokenResponseType GetClientAlertsAuthToken(
    GetClientAlertsAuthTokenRequestType GetClientAlertsAuthTokenRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetClientAlertsAuthToken ( _
    GetClientAlertsAuthTokenRequest As GetClientAlertsAuthTokenRequestType _
) As GetClientAlertsAuthTokenResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetClientAlertsAuthTokenResponseType^ GetClientAlertsAuthToken(
    GetClientAlertsAuthTokenRequestType^ GetClientAlertsAuthTokenRequest
)
Parameters
GetClientAlertsAuthTokenRequest (GetClientAlertsAuthTokenRequestType)
Remarks


GetContextualKeywords Method (GetContextualKeywordsRequest)

GetContextualKeywords Method (GetContextualKeywordsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetContextualKeywords(GetContextualKeywordsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetContextualKeywordsResponseType GetContextualKeywords(
    GetContextualKeywordsRequestType GetContextualKeywordsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetContextualKeywords ( _
    GetContextualKeywordsRequest As GetContextualKeywordsRequestType _
) As GetContextualKeywordsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetContextualKeywordsResponseType^ GetContextualKeywords(
    GetContextualKeywordsRequestType^ GetContextualKeywordsRequest
)
Parameters
GetContextualKeywordsRequest (GetContextualKeywordsRequestType)
Remarks


GetDescriptionTemplates Method (GetDescriptionTemplatesRequest)

GetDescriptionTemplates Method (GetDescriptionTemplatesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetDescriptionTemplates(GetDescriptionTemplatesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetDescriptionTemplatesResponseType GetDescriptionTemplates(
    GetDescriptionTemplatesRequestType GetDescriptionTemplatesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetDescriptionTemplates ( _
    GetDescriptionTemplatesRequest As GetDescriptionTemplatesRequestType _
) As GetDescriptionTemplatesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetDescriptionTemplatesResponseType^ GetDescriptionTemplates(
    GetDescriptionTemplatesRequestType^ GetDescriptionTemplatesRequest
)
Parameters
GetDescriptionTemplatesRequest (GetDescriptionTemplatesRequestType)
Remarks


GetDispute Method (GetDisputeRequest)

GetDispute Method (GetDisputeRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetDispute(GetDisputeRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetDisputeResponseType GetDispute(
    GetDisputeRequestType GetDisputeRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetDispute ( _
    GetDisputeRequest As GetDisputeRequestType _
) As GetDisputeResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetDisputeResponseType^ GetDispute(
    GetDisputeRequestType^ GetDisputeRequest
)
Parameters
GetDisputeRequest (GetDisputeRequestType)
Remarks


GeteBayDetails Method (GeteBayDetailsRequest)

GeteBayDetails Method (GeteBayDetailsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GeteBayDetails(GeteBayDetailsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GeteBayDetailsResponseType GeteBayDetails(
    GeteBayDetailsRequestType GeteBayDetailsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GeteBayDetails ( _
    GeteBayDetailsRequest As GeteBayDetailsRequestType _
) As GeteBayDetailsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GeteBayDetailsResponseType^ GeteBayDetails(
    GeteBayDetailsRequestType^ GeteBayDetailsRequest
)
Parameters
GeteBayDetailsRequest (GeteBayDetailsRequestType)
Remarks


GeteBayOfficialTime Method (GeteBayOfficialTimeRequest)

GeteBayOfficialTime Method (GeteBayOfficialTimeRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GeteBayOfficialTime(GeteBayOfficialTimeRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GeteBayOfficialTimeResponseType GeteBayOfficialTime(
    GeteBayOfficialTimeRequestType GeteBayOfficialTimeRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GeteBayOfficialTime ( _
    GeteBayOfficialTimeRequest As GeteBayOfficialTimeRequestType _
) As GeteBayOfficialTimeResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GeteBayOfficialTimeResponseType^ GeteBayOfficialTime(
    GeteBayOfficialTimeRequestType^ GeteBayOfficialTimeRequest
)
Parameters
GeteBayOfficialTimeRequest (GeteBayOfficialTimeRequestType)
Remarks


GetFeedback Method (GetFeedbackRequest)

GetFeedback Method (GetFeedbackRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetFeedback(GetFeedbackRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetFeedbackResponseType GetFeedback(
    GetFeedbackRequestType GetFeedbackRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetFeedback ( _
    GetFeedbackRequest As GetFeedbackRequestType _
) As GetFeedbackResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetFeedbackResponseType^ GetFeedback(
    GetFeedbackRequestType^ GetFeedbackRequest
)
Parameters
GetFeedbackRequest (GetFeedbackRequestType)
Remarks


GetItem Method (GetItemRequest)

GetItem Method (GetItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetItem(GetItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetItemResponseType GetItem(
    GetItemRequestType GetItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetItem ( _
    GetItemRequest As GetItemRequestType _
) As GetItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetItemResponseType^ GetItem(
    GetItemRequestType^ GetItemRequest
)
Parameters
GetItemRequest (GetItemRequestType)
Remarks


GetItemsAwaitingFeedback Method (GetItemsAwaitingFeedbackRequest)

GetItemsAwaitingFeedback Method (GetItemsAwaitingFeedbackRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetItemsAwaitingFeedback(GetItemsAwaitingFeedbackRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetItemsAwaitingFeedbackResponseType GetItemsAwaitingFeedback(
    GetItemsAwaitingFeedbackRequestType GetItemsAwaitingFeedbackRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetItemsAwaitingFeedback ( _
    GetItemsAwaitingFeedbackRequest As GetItemsAwaitingFeedbackRequestType _
) As GetItemsAwaitingFeedbackResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetItemsAwaitingFeedbackResponseType^ GetItemsAwaitingFeedback(
    GetItemsAwaitingFeedbackRequestType^ GetItemsAwaitingFeedbackRequest
)
Parameters
GetItemsAwaitingFeedbackRequest (GetItemsAwaitingFeedbackRequestType)
Remarks


GetItemShipping Method (GetItemShippingRequest)

GetItemShipping Method (GetItemShippingRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetItemShipping(GetItemShippingRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetItemShippingResponseType GetItemShipping(
    GetItemShippingRequestType GetItemShippingRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetItemShipping ( _
    GetItemShippingRequest As GetItemShippingRequestType _
) As GetItemShippingResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetItemShippingResponseType^ GetItemShipping(
    GetItemShippingRequestType^ GetItemShippingRequest
)
Parameters
GetItemShippingRequest (GetItemShippingRequestType)
Remarks


GetItemTransactions Method (GetItemTransactionsRequest)

GetItemTransactions Method (GetItemTransactionsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetItemTransactions(GetItemTransactionsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetItemTransactionsResponseType GetItemTransactions(
    GetItemTransactionsRequestType GetItemTransactionsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetItemTransactions ( _
    GetItemTransactionsRequest As GetItemTransactionsRequestType _
) As GetItemTransactionsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetItemTransactionsResponseType^ GetItemTransactions(
    GetItemTransactionsRequestType^ GetItemTransactionsRequest
)
Parameters
GetItemTransactionsRequest (GetItemTransactionsRequestType)
Remarks


GetMemberMessages Method (GetMemberMessagesRequest)

GetMemberMessages Method (GetMemberMessagesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetMemberMessages(GetMemberMessagesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetMemberMessagesResponseType GetMemberMessages(
    GetMemberMessagesRequestType GetMemberMessagesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetMemberMessages ( _
    GetMemberMessagesRequest As GetMemberMessagesRequestType _
) As GetMemberMessagesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetMemberMessagesResponseType^ GetMemberMessages(
    GetMemberMessagesRequestType^ GetMemberMessagesRequest
)
Parameters
GetMemberMessagesRequest (GetMemberMessagesRequestType)
Remarks


GetMessagePreferences Method (GetMessagePreferencesRequest)

GetMessagePreferences Method (GetMessagePreferencesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetMessagePreferences(GetMessagePreferencesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetMessagePreferencesResponseType GetMessagePreferences(
    GetMessagePreferencesRequestType GetMessagePreferencesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetMessagePreferences ( _
    GetMessagePreferencesRequest As GetMessagePreferencesRequestType _
) As GetMessagePreferencesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetMessagePreferencesResponseType^ GetMessagePreferences(
    GetMessagePreferencesRequestType^ GetMessagePreferencesRequest
)
Parameters
GetMessagePreferencesRequest (GetMessagePreferencesRequestType)
Remarks


GetMyeBayBuying Method (GetMyeBayBuyingRequest)

GetMyeBayBuying Method (GetMyeBayBuyingRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetMyeBayBuying(GetMyeBayBuyingRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetMyeBayBuyingResponseType GetMyeBayBuying(
    GetMyeBayBuyingRequestType GetMyeBayBuyingRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetMyeBayBuying ( _
    GetMyeBayBuyingRequest As GetMyeBayBuyingRequestType _
) As GetMyeBayBuyingResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetMyeBayBuyingResponseType^ GetMyeBayBuying(
    GetMyeBayBuyingRequestType^ GetMyeBayBuyingRequest
)
Parameters
GetMyeBayBuyingRequest (GetMyeBayBuyingRequestType)
Remarks


GetMyeBayReminders Method (GetMyeBayRemindersRequest)

GetMyeBayReminders Method (GetMyeBayRemindersRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetMyeBayReminders(GetMyeBayRemindersRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetMyeBayRemindersResponseType GetMyeBayReminders(
    GetMyeBayRemindersRequestType GetMyeBayRemindersRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetMyeBayReminders ( _
    GetMyeBayRemindersRequest As GetMyeBayRemindersRequestType _
) As GetMyeBayRemindersResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetMyeBayRemindersResponseType^ GetMyeBayReminders(
    GetMyeBayRemindersRequestType^ GetMyeBayRemindersRequest
)
Parameters
GetMyeBayRemindersRequest (GetMyeBayRemindersRequestType)
Remarks


GetMyeBaySelling Method (GetMyeBaySellingRequest)

GetMyeBaySelling Method (GetMyeBaySellingRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetMyeBaySelling(GetMyeBaySellingRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetMyeBaySellingResponseType GetMyeBaySelling(
    GetMyeBaySellingRequestType GetMyeBaySellingRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetMyeBaySelling ( _
    GetMyeBaySellingRequest As GetMyeBaySellingRequestType _
) As GetMyeBaySellingResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetMyeBaySellingResponseType^ GetMyeBaySelling(
    GetMyeBaySellingRequestType^ GetMyeBaySellingRequest
)
Parameters
GetMyeBaySellingRequest (GetMyeBaySellingRequestType)
Remarks


GetMyMessages Method (GetMyMessagesRequest)

GetMyMessages Method (GetMyMessagesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetMyMessages(GetMyMessagesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetMyMessagesResponseType GetMyMessages(
    GetMyMessagesRequestType GetMyMessagesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetMyMessages ( _
    GetMyMessagesRequest As GetMyMessagesRequestType _
) As GetMyMessagesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetMyMessagesResponseType^ GetMyMessages(
    GetMyMessagesRequestType^ GetMyMessagesRequest
)
Parameters
GetMyMessagesRequest (GetMyMessagesRequestType)
Remarks


GetNotificationPreferences Method (GetNotificationPreferencesRequest)

GetNotificationPreferences Method (GetNotificationPreferencesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetNotificationPreferences(GetNotificationPreferencesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetNotificationPreferencesResponseType GetNotificationPreferences(
    GetNotificationPreferencesRequestType GetNotificationPreferencesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetNotificationPreferences ( _
    GetNotificationPreferencesRequest As GetNotificationPreferencesRequestType _
) As GetNotificationPreferencesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetNotificationPreferencesResponseType^ GetNotificationPreferences(
    GetNotificationPreferencesRequestType^ GetNotificationPreferencesRequest
)
Parameters
GetNotificationPreferencesRequest (GetNotificationPreferencesRequestType)
Remarks


GetNotificationsUsage Method (GetNotificationsUsageRequest)

GetNotificationsUsage Method (GetNotificationsUsageRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetNotificationsUsage(GetNotificationsUsageRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetNotificationsUsageResponseType GetNotificationsUsage(
    GetNotificationsUsageRequestType GetNotificationsUsageRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetNotificationsUsage ( _
    GetNotificationsUsageRequest As GetNotificationsUsageRequestType _
) As GetNotificationsUsageResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetNotificationsUsageResponseType^ GetNotificationsUsage(
    GetNotificationsUsageRequestType^ GetNotificationsUsageRequest
)
Parameters
GetNotificationsUsageRequest (GetNotificationsUsageRequestType)
Remarks


GetOrders Method (GetOrdersRequest)

GetOrders Method (GetOrdersRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetOrders(GetOrdersRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetOrdersResponseType GetOrders(
    GetOrdersRequestType GetOrdersRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetOrders ( _
    GetOrdersRequest As GetOrdersRequestType _
) As GetOrdersResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetOrdersResponseType^ GetOrders(
    GetOrdersRequestType^ GetOrdersRequest
)
Parameters
GetOrdersRequest (GetOrdersRequestType)
Remarks


GetOrderTransactions Method (GetOrderTransactionsRequest)

GetOrderTransactions Method (GetOrderTransactionsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetOrderTransactions(GetOrderTransactionsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetOrderTransactionsResponseType GetOrderTransactions(
    GetOrderTransactionsRequestType GetOrderTransactionsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetOrderTransactions ( _
    GetOrderTransactionsRequest As GetOrderTransactionsRequestType _
) As GetOrderTransactionsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetOrderTransactionsResponseType^ GetOrderTransactions(
    GetOrderTransactionsRequestType^ GetOrderTransactionsRequest
)
Parameters
GetOrderTransactionsRequest (GetOrderTransactionsRequestType)
Remarks


GetProductSellingPages Method (GetProductSellingPagesRequest)

GetProductSellingPages Method (GetProductSellingPagesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetProductSellingPages(GetProductSellingPagesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetProductSellingPagesResponseType GetProductSellingPages(
    GetProductSellingPagesRequestType GetProductSellingPagesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetProductSellingPages ( _
    GetProductSellingPagesRequest As GetProductSellingPagesRequestType _
) As GetProductSellingPagesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetProductSellingPagesResponseType^ GetProductSellingPages(
    GetProductSellingPagesRequestType^ GetProductSellingPagesRequest
)
Parameters
GetProductSellingPagesRequest (GetProductSellingPagesRequestType)
Remarks


GetPromotionalSaleDetails Method (GetPromotionalSaleDetailsRequest)

GetPromotionalSaleDetails Method (GetPromotionalSaleDetailsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetPromotionalSaleDetails(GetPromotionalSaleDetailsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetPromotionalSaleDetailsResponseType GetPromotionalSaleDetails(
    GetPromotionalSaleDetailsRequestType GetPromotionalSaleDetailsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetPromotionalSaleDetails ( _
    GetPromotionalSaleDetailsRequest As GetPromotionalSaleDetailsRequestType _
) As GetPromotionalSaleDetailsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetPromotionalSaleDetailsResponseType^ GetPromotionalSaleDetails(
    GetPromotionalSaleDetailsRequestType^ GetPromotionalSaleDetailsRequest
)
Parameters
GetPromotionalSaleDetailsRequest (GetPromotionalSaleDetailsRequestType)
Remarks


GetSellerDashboard Method (GetSellerDashboardRequest)

GetSellerDashboard Method (GetSellerDashboardRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellerDashboard(GetSellerDashboardRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellerDashboardResponseType GetSellerDashboard(
    GetSellerDashboardRequestType GetSellerDashboardRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellerDashboard ( _
    GetSellerDashboardRequest As GetSellerDashboardRequestType _
) As GetSellerDashboardResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellerDashboardResponseType^ GetSellerDashboard(
    GetSellerDashboardRequestType^ GetSellerDashboardRequest
)
Parameters
GetSellerDashboardRequest (GetSellerDashboardRequestType)
Remarks


GetSellerEvents Method (GetSellerEventsRequest)

GetSellerEvents Method (GetSellerEventsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellerEvents(GetSellerEventsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellerEventsResponseType GetSellerEvents(
    GetSellerEventsRequestType GetSellerEventsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellerEvents ( _
    GetSellerEventsRequest As GetSellerEventsRequestType _
) As GetSellerEventsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellerEventsResponseType^ GetSellerEvents(
    GetSellerEventsRequestType^ GetSellerEventsRequest
)
Parameters
GetSellerEventsRequest (GetSellerEventsRequestType)
Remarks


GetSellerList Method (GetSellerListRequest)

GetSellerList Method (GetSellerListRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellerList(GetSellerListRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellerListResponseType GetSellerList(
    GetSellerListRequestType GetSellerListRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellerList ( _
    GetSellerListRequest As GetSellerListRequestType _
) As GetSellerListResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellerListResponseType^ GetSellerList(
    GetSellerListRequestType^ GetSellerListRequest
)
Parameters
GetSellerListRequest (GetSellerListRequestType)
Remarks


GetSellerPayments Method (GetSellerPaymentsRequest)

GetSellerPayments Method (GetSellerPaymentsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellerPayments(GetSellerPaymentsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellerPaymentsResponseType GetSellerPayments(
    GetSellerPaymentsRequestType GetSellerPaymentsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellerPayments ( _
    GetSellerPaymentsRequest As GetSellerPaymentsRequestType _
) As GetSellerPaymentsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellerPaymentsResponseType^ GetSellerPayments(
    GetSellerPaymentsRequestType^ GetSellerPaymentsRequest
)
Parameters
GetSellerPaymentsRequest (GetSellerPaymentsRequestType)
Remarks


GetSellerTransactions Method (GetSellerTransactionsRequest)

GetSellerTransactions Method (GetSellerTransactionsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellerTransactions(GetSellerTransactionsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellerTransactionsResponseType GetSellerTransactions(
    GetSellerTransactionsRequestType GetSellerTransactionsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellerTransactions ( _
    GetSellerTransactionsRequest As GetSellerTransactionsRequestType _
) As GetSellerTransactionsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellerTransactionsResponseType^ GetSellerTransactions(
    GetSellerTransactionsRequestType^ GetSellerTransactionsRequest
)
Parameters
GetSellerTransactionsRequest (GetSellerTransactionsRequestType)
Remarks


GetSellingManagerAlerts Method (GetSellingManagerAlertsRequest)

GetSellingManagerAlerts Method (GetSellingManagerAlertsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellingManagerAlerts(GetSellingManagerAlertsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellingManagerAlertsResponseType GetSellingManagerAlerts(
    GetSellingManagerAlertsRequestType GetSellingManagerAlertsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellingManagerAlerts ( _
    GetSellingManagerAlertsRequest As GetSellingManagerAlertsRequestType _
) As GetSellingManagerAlertsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellingManagerAlertsResponseType^ GetSellingManagerAlerts(
    GetSellingManagerAlertsRequestType^ GetSellingManagerAlertsRequest
)
Parameters
GetSellingManagerAlertsRequest (GetSellingManagerAlertsRequestType)
Remarks


GetSellingManagerEmailLog Method (GetSellingManagerEmailLogRequest)

GetSellingManagerEmailLog Method (GetSellingManagerEmailLogRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellingManagerEmailLog(GetSellingManagerEmailLogRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellingManagerEmailLogResponseType GetSellingManagerEmailLog(
    GetSellingManagerEmailLogRequestType GetSellingManagerEmailLogRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellingManagerEmailLog ( _
    GetSellingManagerEmailLogRequest As GetSellingManagerEmailLogRequestType _
) As GetSellingManagerEmailLogResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellingManagerEmailLogResponseType^ GetSellingManagerEmailLog(
    GetSellingManagerEmailLogRequestType^ GetSellingManagerEmailLogRequest
)
Parameters
GetSellingManagerEmailLogRequest (GetSellingManagerEmailLogRequestType)
Remarks


GetSellingManagerInventory Method (GetSellingManagerInventoryRequest)

GetSellingManagerInventory Method (GetSellingManagerInventoryRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellingManagerInventory(GetSellingManagerInventoryRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellingManagerInventoryResponseType GetSellingManagerInventory(
    GetSellingManagerInventoryRequestType GetSellingManagerInventoryRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellingManagerInventory ( _
    GetSellingManagerInventoryRequest As GetSellingManagerInventoryRequestType _
) As GetSellingManagerInventoryResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellingManagerInventoryResponseType^ GetSellingManagerInventory(
    GetSellingManagerInventoryRequestType^ GetSellingManagerInventoryRequest
)
Parameters
GetSellingManagerInventoryRequest (GetSellingManagerInventoryRequestType)
Remarks


GetSellingManagerInventoryFolder Method (GetSellingManagerInventoryFolderRequest)

GetSellingManagerInventoryFolder Method (GetSellingManagerInventoryFolderRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellingManagerInventoryFolder(GetSellingManagerInventoryFolderRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellingManagerInventoryFolderResponseType GetSellingManagerInventoryFolder(
    GetSellingManagerInventoryFolderRequestType GetSellingManagerInventoryFolderRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellingManagerInventoryFolder ( _
    GetSellingManagerInventoryFolderRequest As GetSellingManagerInventoryFolderRequestType _
) As GetSellingManagerInventoryFolderResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellingManagerInventoryFolderResponseType^ GetSellingManagerInventoryFolder(
    GetSellingManagerInventoryFolderRequestType^ GetSellingManagerInventoryFolderRequest
)
Parameters
GetSellingManagerInventoryFolderRequest (GetSellingManagerInventoryFolderRequestType)
Remarks


GetSellingManagerItemAutomationRule Method (GetSellingManagerItemAutomationRuleRequest)

GetSellingManagerItemAutomationRule Method (GetSellingManagerItemAutomationRuleRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellingManagerItemAutomationRule(GetSellingManagerItemAutomationRuleRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellingManagerItemAutomationRuleResponseType GetSellingManagerItemAutomationRule(
    GetSellingManagerItemAutomationRuleRequestType GetSellingManagerItemAutomationRuleRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellingManagerItemAutomationRule ( _
    GetSellingManagerItemAutomationRuleRequest As GetSellingManagerItemAutomationRuleRequestType _
) As GetSellingManagerItemAutomationRuleResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellingManagerItemAutomationRuleResponseType^ GetSellingManagerItemAutomationRule(
    GetSellingManagerItemAutomationRuleRequestType^ GetSellingManagerItemAutomationRuleRequest
)
Parameters
GetSellingManagerItemAutomationRuleRequest (GetSellingManagerItemAutomationRuleRequestType)
Remarks


GetSellingManagerSaleRecord Method (GetSellingManagerSaleRecordRequest)

GetSellingManagerSaleRecord Method (GetSellingManagerSaleRecordRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellingManagerSaleRecord(GetSellingManagerSaleRecordRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellingManagerSaleRecordResponseType GetSellingManagerSaleRecord(
    GetSellingManagerSaleRecordRequestType GetSellingManagerSaleRecordRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellingManagerSaleRecord ( _
    GetSellingManagerSaleRecordRequest As GetSellingManagerSaleRecordRequestType _
) As GetSellingManagerSaleRecordResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellingManagerSaleRecordResponseType^ GetSellingManagerSaleRecord(
    GetSellingManagerSaleRecordRequestType^ GetSellingManagerSaleRecordRequest
)
Parameters
GetSellingManagerSaleRecordRequest (GetSellingManagerSaleRecordRequestType)
Remarks


GetSellingManagerSoldListings Method (GetSellingManagerSoldListingsRequest)

GetSellingManagerSoldListings Method (GetSellingManagerSoldListingsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellingManagerSoldListings(GetSellingManagerSoldListingsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellingManagerSoldListingsResponseType GetSellingManagerSoldListings(
    GetSellingManagerSoldListingsRequestType GetSellingManagerSoldListingsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellingManagerSoldListings ( _
    GetSellingManagerSoldListingsRequest As GetSellingManagerSoldListingsRequestType _
) As GetSellingManagerSoldListingsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellingManagerSoldListingsResponseType^ GetSellingManagerSoldListings(
    GetSellingManagerSoldListingsRequestType^ GetSellingManagerSoldListingsRequest
)
Parameters
GetSellingManagerSoldListingsRequest (GetSellingManagerSoldListingsRequestType)
Remarks


GetSellingManagerTemplateAutomationRule Method (GetSellingManagerTemplateAutomationRuleRequest)

GetSellingManagerTemplateAutomationRule Method (GetSellingManagerTemplateAutomationRuleRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellingManagerTemplateAutomationRule(GetSellingManagerTemplateAutomationRuleRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellingManagerTemplateAutomationRuleResponseType GetSellingManagerTemplateAutomationRule(
    GetSellingManagerTemplateAutomationRuleRequestType GetSellingManagerTemplateAutomationRuleRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellingManagerTemplateAutomationRule ( _
    GetSellingManagerTemplateAutomationRuleRequest As GetSellingManagerTemplateAutomationRuleRequestType _
) As GetSellingManagerTemplateAutomationRuleResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellingManagerTemplateAutomationRuleResponseType^ GetSellingManagerTemplateAutomationRule(
    GetSellingManagerTemplateAutomationRuleRequestType^ GetSellingManagerTemplateAutomationRuleRequest
)
Parameters
GetSellingManagerTemplateAutomationRuleRequest (GetSellingManagerTemplateAutomationRuleRequestType)
Remarks


GetSellingManagerTemplates Method (GetSellingManagerTemplatesRequest)

GetSellingManagerTemplates Method (GetSellingManagerTemplatesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSellingManagerTemplates(GetSellingManagerTemplatesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSellingManagerTemplatesResponseType GetSellingManagerTemplates(
    GetSellingManagerTemplatesRequestType GetSellingManagerTemplatesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSellingManagerTemplates ( _
    GetSellingManagerTemplatesRequest As GetSellingManagerTemplatesRequestType _
) As GetSellingManagerTemplatesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSellingManagerTemplatesResponseType^ GetSellingManagerTemplates(
    GetSellingManagerTemplatesRequestType^ GetSellingManagerTemplatesRequest
)
Parameters
GetSellingManagerTemplatesRequest (GetSellingManagerTemplatesRequestType)
Remarks


GetSessionID Method (GetSessionIDRequest)

GetSessionID Method (GetSessionIDRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSessionID(GetSessionIDRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSessionIDResponseType GetSessionID(
    GetSessionIDRequestType GetSessionIDRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSessionID ( _
    GetSessionIDRequest As GetSessionIDRequestType _
) As GetSessionIDResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSessionIDResponseType^ GetSessionID(
    GetSessionIDRequestType^ GetSessionIDRequest
)
Parameters
GetSessionIDRequest (GetSessionIDRequestType)
Remarks


GetShippingDiscountProfiles Method (GetShippingDiscountProfilesRequest)

GetShippingDiscountProfiles Method (GetShippingDiscountProfilesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetShippingDiscountProfiles(GetShippingDiscountProfilesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetShippingDiscountProfilesResponseType GetShippingDiscountProfiles(
    GetShippingDiscountProfilesRequestType GetShippingDiscountProfilesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetShippingDiscountProfiles ( _
    GetShippingDiscountProfilesRequest As GetShippingDiscountProfilesRequestType _
) As GetShippingDiscountProfilesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetShippingDiscountProfilesResponseType^ GetShippingDiscountProfiles(
    GetShippingDiscountProfilesRequestType^ GetShippingDiscountProfilesRequest
)
Parameters
GetShippingDiscountProfilesRequest (GetShippingDiscountProfilesRequestType)
Remarks


GetStore Method (GetStoreRequest)

GetStore Method (GetStoreRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetStore(GetStoreRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetStoreResponseType GetStore(
    GetStoreRequestType GetStoreRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetStore ( _
    GetStoreRequest As GetStoreRequestType _
) As GetStoreResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetStoreResponseType^ GetStore(
    GetStoreRequestType^ GetStoreRequest
)
Parameters
GetStoreRequest (GetStoreRequestType)
Remarks


GetStoreCategoryUpdateStatus Method (GetStoreCategoryUpdateStatusRequest)

GetStoreCategoryUpdateStatus Method (GetStoreCategoryUpdateStatusRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetStoreCategoryUpdateStatus(GetStoreCategoryUpdateStatusRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetStoreCategoryUpdateStatusResponseType GetStoreCategoryUpdateStatus(
    GetStoreCategoryUpdateStatusRequestType GetStoreCategoryUpdateStatusRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetStoreCategoryUpdateStatus ( _
    GetStoreCategoryUpdateStatusRequest As GetStoreCategoryUpdateStatusRequestType _
) As GetStoreCategoryUpdateStatusResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetStoreCategoryUpdateStatusResponseType^ GetStoreCategoryUpdateStatus(
    GetStoreCategoryUpdateStatusRequestType^ GetStoreCategoryUpdateStatusRequest
)
Parameters
GetStoreCategoryUpdateStatusRequest (GetStoreCategoryUpdateStatusRequestType)
Remarks


GetStoreCustomPage Method (GetStoreCustomPageRequest)

GetStoreCustomPage Method (GetStoreCustomPageRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetStoreCustomPage(GetStoreCustomPageRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetStoreCustomPageResponseType GetStoreCustomPage(
    GetStoreCustomPageRequestType GetStoreCustomPageRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetStoreCustomPage ( _
    GetStoreCustomPageRequest As GetStoreCustomPageRequestType _
) As GetStoreCustomPageResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetStoreCustomPageResponseType^ GetStoreCustomPage(
    GetStoreCustomPageRequestType^ GetStoreCustomPageRequest
)
Parameters
GetStoreCustomPageRequest (GetStoreCustomPageRequestType)
Remarks


GetStoreOptions Method (GetStoreOptionsRequest)

GetStoreOptions Method (GetStoreOptionsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetStoreOptions(GetStoreOptionsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetStoreOptionsResponseType GetStoreOptions(
    GetStoreOptionsRequestType GetStoreOptionsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetStoreOptions ( _
    GetStoreOptionsRequest As GetStoreOptionsRequestType _
) As GetStoreOptionsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetStoreOptionsResponseType^ GetStoreOptions(
    GetStoreOptionsRequestType^ GetStoreOptionsRequest
)
Parameters
GetStoreOptionsRequest (GetStoreOptionsRequestType)
Remarks


GetStorePreferences Method (GetStorePreferencesRequest)

GetStorePreferences Method (GetStorePreferencesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetStorePreferences(GetStorePreferencesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetStorePreferencesResponseType GetStorePreferences(
    GetStorePreferencesRequestType GetStorePreferencesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetStorePreferences ( _
    GetStorePreferencesRequest As GetStorePreferencesRequestType _
) As GetStorePreferencesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetStorePreferencesResponseType^ GetStorePreferences(
    GetStorePreferencesRequestType^ GetStorePreferencesRequest
)
Parameters
GetStorePreferencesRequest (GetStorePreferencesRequestType)
Remarks


GetSuggestedCategories Method (GetSuggestedCategoriesRequest)

GetSuggestedCategories Method (GetSuggestedCategoriesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetSuggestedCategories(GetSuggestedCategoriesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetSuggestedCategoriesResponseType GetSuggestedCategories(
    GetSuggestedCategoriesRequestType GetSuggestedCategoriesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetSuggestedCategories ( _
    GetSuggestedCategoriesRequest As GetSuggestedCategoriesRequestType _
) As GetSuggestedCategoriesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetSuggestedCategoriesResponseType^ GetSuggestedCategories(
    GetSuggestedCategoriesRequestType^ GetSuggestedCategoriesRequest
)
Parameters
GetSuggestedCategoriesRequest (GetSuggestedCategoriesRequestType)
Remarks


GetTaxTable Method (GetTaxTableRequest)

GetTaxTable Method (GetTaxTableRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetTaxTable(GetTaxTableRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetTaxTableResponseType GetTaxTable(
    GetTaxTableRequestType GetTaxTableRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetTaxTable ( _
    GetTaxTableRequest As GetTaxTableRequestType _
) As GetTaxTableResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetTaxTableResponseType^ GetTaxTable(
    GetTaxTableRequestType^ GetTaxTableRequest
)
Parameters
GetTaxTableRequest (GetTaxTableRequestType)
Remarks


GetTokenStatus Method (GetTokenStatusRequest)

GetTokenStatus Method (GetTokenStatusRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetTokenStatus(GetTokenStatusRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetTokenStatusResponseType GetTokenStatus(
    GetTokenStatusRequestType GetTokenStatusRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetTokenStatus ( _
    GetTokenStatusRequest As GetTokenStatusRequestType _
) As GetTokenStatusResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetTokenStatusResponseType^ GetTokenStatus(
    GetTokenStatusRequestType^ GetTokenStatusRequest
)
Parameters
GetTokenStatusRequest (GetTokenStatusRequestType)
Remarks


GetUser Method (GetUserRequest)

GetUser Method (GetUserRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetUser(GetUserRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetUserResponseType GetUser(
    GetUserRequestType GetUserRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetUser ( _
    GetUserRequest As GetUserRequestType _
) As GetUserResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetUserResponseType^ GetUser(
    GetUserRequestType^ GetUserRequest
)
Parameters
GetUserRequest (GetUserRequestType)
Remarks


GetUserContactDetails Method (GetUserContactDetailsRequest)

GetUserContactDetails Method (GetUserContactDetailsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetUserContactDetails(GetUserContactDetailsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetUserContactDetailsResponseType GetUserContactDetails(
    GetUserContactDetailsRequestType GetUserContactDetailsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetUserContactDetails ( _
    GetUserContactDetailsRequest As GetUserContactDetailsRequestType _
) As GetUserContactDetailsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetUserContactDetailsResponseType^ GetUserContactDetails(
    GetUserContactDetailsRequestType^ GetUserContactDetailsRequest
)
Parameters
GetUserContactDetailsRequest (GetUserContactDetailsRequestType)
Remarks


GetUserDisputes Method (GetUserDisputesRequest)

GetUserDisputes Method (GetUserDisputesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetUserDisputes(GetUserDisputesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetUserDisputesResponseType GetUserDisputes(
    GetUserDisputesRequestType GetUserDisputesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetUserDisputes ( _
    GetUserDisputesRequest As GetUserDisputesRequestType _
) As GetUserDisputesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetUserDisputesResponseType^ GetUserDisputes(
    GetUserDisputesRequestType^ GetUserDisputesRequest
)
Parameters
GetUserDisputesRequest (GetUserDisputesRequestType)
Remarks


GetUserPreferences Method (GetUserPreferencesRequest)

GetUserPreferences Method (GetUserPreferencesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetUserPreferences(GetUserPreferencesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetUserPreferencesResponseType GetUserPreferences(
    GetUserPreferencesRequestType GetUserPreferencesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetUserPreferences ( _
    GetUserPreferencesRequest As GetUserPreferencesRequestType _
) As GetUserPreferencesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetUserPreferencesResponseType^ GetUserPreferences(
    GetUserPreferencesRequestType^ GetUserPreferencesRequest
)
Parameters
GetUserPreferencesRequest (GetUserPreferencesRequestType)
Remarks


GetVeROReasonCodeDetails Method (GetVeROReasonCodeDetailsRequest)

GetVeROReasonCodeDetails Method (GetVeROReasonCodeDetailsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetVeROReasonCodeDetails(GetVeROReasonCodeDetailsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetVeROReasonCodeDetailsResponseType GetVeROReasonCodeDetails(
    GetVeROReasonCodeDetailsRequestType GetVeROReasonCodeDetailsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetVeROReasonCodeDetails ( _
    GetVeROReasonCodeDetailsRequest As GetVeROReasonCodeDetailsRequestType _
) As GetVeROReasonCodeDetailsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetVeROReasonCodeDetailsResponseType^ GetVeROReasonCodeDetails(
    GetVeROReasonCodeDetailsRequestType^ GetVeROReasonCodeDetailsRequest
)
Parameters
GetVeROReasonCodeDetailsRequest (GetVeROReasonCodeDetailsRequestType)
Remarks


GetVeROReportStatus Method (GetVeROReportStatusRequest)

GetVeROReportStatus Method (GetVeROReportStatusRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetVeROReportStatus(GetVeROReportStatusRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public GetVeROReportStatusResponseType GetVeROReportStatus(
    GetVeROReportStatusRequestType GetVeROReportStatusRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function GetVeROReportStatus ( _
    GetVeROReportStatusRequest As GetVeROReportStatusRequestType _
) As GetVeROReportStatusResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
GetVeROReportStatusResponseType^ GetVeROReportStatus(
    GetVeROReportStatusRequestType^ GetVeROReportStatusRequest
)
Parameters
GetVeROReportStatusRequest (GetVeROReportStatusRequestType)
Remarks


IssueRefund Method (IssueRefundRequest)

IssueRefund Method (IssueRefundRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► IssueRefund(IssueRefundRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public IssueRefundResponseType IssueRefund(
    IssueRefundRequestType IssueRefundRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function IssueRefund ( _
    IssueRefundRequest As IssueRefundRequestType _
) As IssueRefundResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
IssueRefundResponseType^ IssueRefund(
    IssueRefundRequestType^ IssueRefundRequest
)
Parameters
IssueRefundRequest (IssueRefundRequestType)
Remarks


LeaveFeedback Method (LeaveFeedbackRequest)

LeaveFeedback Method (LeaveFeedbackRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► LeaveFeedback(LeaveFeedbackRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public LeaveFeedbackResponseType LeaveFeedback(
    LeaveFeedbackRequestType LeaveFeedbackRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function LeaveFeedback ( _
    LeaveFeedbackRequest As LeaveFeedbackRequestType _
) As LeaveFeedbackResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
LeaveFeedbackResponseType^ LeaveFeedback(
    LeaveFeedbackRequestType^ LeaveFeedbackRequest
)
Parameters
LeaveFeedbackRequest (LeaveFeedbackRequestType)
Remarks


MoveSellingManagerInventoryFolder Method (MoveSellingManagerInventoryFolderRequest)

MoveSellingManagerInventoryFolder Method (MoveSellingManagerInventoryFolderRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► MoveSellingManagerInventoryFolder(MoveSellingManagerInventoryFolderRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public MoveSellingManagerInventoryFolderResponseType MoveSellingManagerInventoryFolder(
    MoveSellingManagerInventoryFolderRequestType MoveSellingManagerInventoryFolderRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function MoveSellingManagerInventoryFolder ( _
    MoveSellingManagerInventoryFolderRequest As MoveSellingManagerInventoryFolderRequestType _
) As MoveSellingManagerInventoryFolderResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
MoveSellingManagerInventoryFolderResponseType^ MoveSellingManagerInventoryFolder(
    MoveSellingManagerInventoryFolderRequestType^ MoveSellingManagerInventoryFolderRequest
)
Parameters
MoveSellingManagerInventoryFolderRequest (MoveSellingManagerInventoryFolderRequestType)
Remarks


PlaceOffer Method (PlaceOfferRequest)

PlaceOffer Method (PlaceOfferRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► PlaceOffer(PlaceOfferRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public PlaceOfferResponseType PlaceOffer(
    PlaceOfferRequestType PlaceOfferRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function PlaceOffer ( _
    PlaceOfferRequest As PlaceOfferRequestType _
) As PlaceOfferResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
PlaceOfferResponseType^ PlaceOffer(
    PlaceOfferRequestType^ PlaceOfferRequest
)
Parameters
PlaceOfferRequest (PlaceOfferRequestType)
Remarks


RelistFixedPriceItem Method (RelistFixedPriceItemRequest)

RelistFixedPriceItem Method (RelistFixedPriceItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► RelistFixedPriceItem(RelistFixedPriceItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public RelistFixedPriceItemResponseType RelistFixedPriceItem(
    RelistFixedPriceItemRequestType RelistFixedPriceItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function RelistFixedPriceItem ( _
    RelistFixedPriceItemRequest As RelistFixedPriceItemRequestType _
) As RelistFixedPriceItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
RelistFixedPriceItemResponseType^ RelistFixedPriceItem(
    RelistFixedPriceItemRequestType^ RelistFixedPriceItemRequest
)
Parameters
RelistFixedPriceItemRequest (RelistFixedPriceItemRequestType)
Remarks


RelistItem Method (RelistItemRequest)

RelistItem Method (RelistItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► RelistItem(RelistItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public RelistItemResponseType RelistItem(
    RelistItemRequestType RelistItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function RelistItem ( _
    RelistItemRequest As RelistItemRequestType _
) As RelistItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
RelistItemResponseType^ RelistItem(
    RelistItemRequestType^ RelistItemRequest
)
Parameters
RelistItemRequest (RelistItemRequestType)
Remarks


RemoveFromWatchList Method (RemoveFromWatchListRequest)

RemoveFromWatchList Method (RemoveFromWatchListRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► RemoveFromWatchList(RemoveFromWatchListRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public RemoveFromWatchListResponseType RemoveFromWatchList(
    RemoveFromWatchListRequestType RemoveFromWatchListRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function RemoveFromWatchList ( _
    RemoveFromWatchListRequest As RemoveFromWatchListRequestType _
) As RemoveFromWatchListResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
RemoveFromWatchListResponseType^ RemoveFromWatchList(
    RemoveFromWatchListRequestType^ RemoveFromWatchListRequest
)
Parameters
RemoveFromWatchListRequest (RemoveFromWatchListRequestType)
Remarks


RequesterCredentials Property

RequesterCredentials Property
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► RequesterCredentials
Declaration Syntax
C# Visual Basic Visual C++
public CustomSecurityHeaderType RequesterCredentials { get; set; }
Public Property RequesterCredentials As CustomSecurityHeaderType
    Get
    Set
public:
property CustomSecurityHeaderType^ RequesterCredentials {
    CustomSecurityHeaderType^ get ();
    void set (CustomSecurityHeaderType^ value);
}


RespondToBestOffer Method (RespondToBestOfferRequest)

RespondToBestOffer Method (RespondToBestOfferRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► RespondToBestOffer(RespondToBestOfferRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public RespondToBestOfferResponseType RespondToBestOffer(
    RespondToBestOfferRequestType RespondToBestOfferRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function RespondToBestOffer ( _
    RespondToBestOfferRequest As RespondToBestOfferRequestType _
) As RespondToBestOfferResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
RespondToBestOfferResponseType^ RespondToBestOffer(
    RespondToBestOfferRequestType^ RespondToBestOfferRequest
)
Parameters
RespondToBestOfferRequest (RespondToBestOfferRequestType)
Remarks


RespondToFeedback Method (RespondToFeedbackRequest)

RespondToFeedback Method (RespondToFeedbackRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► RespondToFeedback(RespondToFeedbackRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public RespondToFeedbackResponseType RespondToFeedback(
    RespondToFeedbackRequestType RespondToFeedbackRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function RespondToFeedback ( _
    RespondToFeedbackRequest As RespondToFeedbackRequestType _
) As RespondToFeedbackResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
RespondToFeedbackResponseType^ RespondToFeedback(
    RespondToFeedbackRequestType^ RespondToFeedbackRequest
)
Parameters
RespondToFeedbackRequest (RespondToFeedbackRequestType)
Remarks


ReviseCheckoutStatus Method (ReviseCheckoutStatusRequest)

ReviseCheckoutStatus Method (ReviseCheckoutStatusRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ReviseCheckoutStatus(ReviseCheckoutStatusRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ReviseCheckoutStatusResponseType ReviseCheckoutStatus(
    ReviseCheckoutStatusRequestType ReviseCheckoutStatusRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ReviseCheckoutStatus ( _
    ReviseCheckoutStatusRequest As ReviseCheckoutStatusRequestType _
) As ReviseCheckoutStatusResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ReviseCheckoutStatusResponseType^ ReviseCheckoutStatus(
    ReviseCheckoutStatusRequestType^ ReviseCheckoutStatusRequest
)
Parameters
ReviseCheckoutStatusRequest (ReviseCheckoutStatusRequestType)
Remarks


ReviseFixedPriceItem Method (ReviseFixedPriceItemRequest)

ReviseFixedPriceItem Method (ReviseFixedPriceItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ReviseFixedPriceItem(ReviseFixedPriceItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ReviseFixedPriceItemResponseType ReviseFixedPriceItem(
    ReviseFixedPriceItemRequestType ReviseFixedPriceItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ReviseFixedPriceItem ( _
    ReviseFixedPriceItemRequest As ReviseFixedPriceItemRequestType _
) As ReviseFixedPriceItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ReviseFixedPriceItemResponseType^ ReviseFixedPriceItem(
    ReviseFixedPriceItemRequestType^ ReviseFixedPriceItemRequest
)
Parameters
ReviseFixedPriceItemRequest (ReviseFixedPriceItemRequestType)
Remarks


ReviseInventoryStatus Method (ReviseInventoryStatusRequest)

ReviseInventoryStatus Method (ReviseInventoryStatusRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ReviseInventoryStatus(ReviseInventoryStatusRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ReviseInventoryStatusResponseType ReviseInventoryStatus(
    ReviseInventoryStatusRequestType ReviseInventoryStatusRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ReviseInventoryStatus ( _
    ReviseInventoryStatusRequest As ReviseInventoryStatusRequestType _
) As ReviseInventoryStatusResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ReviseInventoryStatusResponseType^ ReviseInventoryStatus(
    ReviseInventoryStatusRequestType^ ReviseInventoryStatusRequest
)
Parameters
ReviseInventoryStatusRequest (ReviseInventoryStatusRequestType)
Remarks


ReviseItem Method (ReviseItemRequest)

ReviseItem Method (ReviseItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ReviseItem(ReviseItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ReviseItemResponseType ReviseItem(
    ReviseItemRequestType ReviseItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ReviseItem ( _
    ReviseItemRequest As ReviseItemRequestType _
) As ReviseItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ReviseItemResponseType^ ReviseItem(
    ReviseItemRequestType^ ReviseItemRequest
)
Parameters
ReviseItemRequest (ReviseItemRequestType)
Remarks


ReviseMyMessages Method (ReviseMyMessagesRequest)

ReviseMyMessages Method (ReviseMyMessagesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ReviseMyMessages(ReviseMyMessagesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ReviseMyMessagesResponseType ReviseMyMessages(
    ReviseMyMessagesRequestType ReviseMyMessagesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ReviseMyMessages ( _
    ReviseMyMessagesRequest As ReviseMyMessagesRequestType _
) As ReviseMyMessagesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ReviseMyMessagesResponseType^ ReviseMyMessages(
    ReviseMyMessagesRequestType^ ReviseMyMessagesRequest
)
Parameters
ReviseMyMessagesRequest (ReviseMyMessagesRequestType)
Remarks


ReviseMyMessagesFolders Method (ReviseMyMessagesFoldersRequest)

ReviseMyMessagesFolders Method (ReviseMyMessagesFoldersRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ReviseMyMessagesFolders(ReviseMyMessagesFoldersRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ReviseMyMessagesFoldersResponseType ReviseMyMessagesFolders(
    ReviseMyMessagesFoldersRequestType ReviseMyMessagesFoldersRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ReviseMyMessagesFolders ( _
    ReviseMyMessagesFoldersRequest As ReviseMyMessagesFoldersRequestType _
) As ReviseMyMessagesFoldersResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ReviseMyMessagesFoldersResponseType^ ReviseMyMessagesFolders(
    ReviseMyMessagesFoldersRequestType^ ReviseMyMessagesFoldersRequest
)
Parameters
ReviseMyMessagesFoldersRequest (ReviseMyMessagesFoldersRequestType)
Remarks


ReviseSellingManagerInventoryFolder Method (ReviseSellingManagerInventoryFolderRequest)

ReviseSellingManagerInventoryFolder Method (ReviseSellingManagerInventoryFolderRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ReviseSellingManagerInventoryFolder(ReviseSellingManagerInventoryFolderRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ReviseSellingManagerInventoryFolderResponseType ReviseSellingManagerInventoryFolder(
    ReviseSellingManagerInventoryFolderRequestType ReviseSellingManagerInventoryFolderRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ReviseSellingManagerInventoryFolder ( _
    ReviseSellingManagerInventoryFolderRequest As ReviseSellingManagerInventoryFolderRequestType _
) As ReviseSellingManagerInventoryFolderResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ReviseSellingManagerInventoryFolderResponseType^ ReviseSellingManagerInventoryFolder(
    ReviseSellingManagerInventoryFolderRequestType^ ReviseSellingManagerInventoryFolderRequest
)
Parameters
ReviseSellingManagerInventoryFolderRequest (ReviseSellingManagerInventoryFolderRequestType)
Remarks


ReviseSellingManagerProduct Method (ReviseSellingManagerProductRequest)

ReviseSellingManagerProduct Method (ReviseSellingManagerProductRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ReviseSellingManagerProduct(ReviseSellingManagerProductRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ReviseSellingManagerProductResponseType ReviseSellingManagerProduct(
    ReviseSellingManagerProductRequestType ReviseSellingManagerProductRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ReviseSellingManagerProduct ( _
    ReviseSellingManagerProductRequest As ReviseSellingManagerProductRequestType _
) As ReviseSellingManagerProductResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ReviseSellingManagerProductResponseType^ ReviseSellingManagerProduct(
    ReviseSellingManagerProductRequestType^ ReviseSellingManagerProductRequest
)
Parameters
ReviseSellingManagerProductRequest (ReviseSellingManagerProductRequestType)
Remarks


ReviseSellingManagerSaleRecord Method (ReviseSellingManagerSaleRecordRequest)

ReviseSellingManagerSaleRecord Method (ReviseSellingManagerSaleRecordRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ReviseSellingManagerSaleRecord(ReviseSellingManagerSaleRecordRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ReviseSellingManagerSaleRecordResponseType ReviseSellingManagerSaleRecord(
    ReviseSellingManagerSaleRecordRequestType ReviseSellingManagerSaleRecordRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ReviseSellingManagerSaleRecord ( _
    ReviseSellingManagerSaleRecordRequest As ReviseSellingManagerSaleRecordRequestType _
) As ReviseSellingManagerSaleRecordResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ReviseSellingManagerSaleRecordResponseType^ ReviseSellingManagerSaleRecord(
    ReviseSellingManagerSaleRecordRequestType^ ReviseSellingManagerSaleRecordRequest
)
Parameters
ReviseSellingManagerSaleRecordRequest (ReviseSellingManagerSaleRecordRequestType)
Remarks


ReviseSellingManagerTemplate Method (ReviseSellingManagerTemplateRequest)

ReviseSellingManagerTemplate Method (ReviseSellingManagerTemplateRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ReviseSellingManagerTemplate(ReviseSellingManagerTemplateRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ReviseSellingManagerTemplateResponseType ReviseSellingManagerTemplate(
    ReviseSellingManagerTemplateRequestType ReviseSellingManagerTemplateRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ReviseSellingManagerTemplate ( _
    ReviseSellingManagerTemplateRequest As ReviseSellingManagerTemplateRequestType _
) As ReviseSellingManagerTemplateResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ReviseSellingManagerTemplateResponseType^ ReviseSellingManagerTemplate(
    ReviseSellingManagerTemplateRequestType^ ReviseSellingManagerTemplateRequest
)
Parameters
ReviseSellingManagerTemplateRequest (ReviseSellingManagerTemplateRequestType)
Remarks


RevokeToken Method (RevokeTokenRequest)

RevokeToken Method (RevokeTokenRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► RevokeToken(RevokeTokenRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public RevokeTokenResponseType RevokeToken(
    RevokeTokenRequestType RevokeTokenRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function RevokeToken ( _
    RevokeTokenRequest As RevokeTokenRequestType _
) As RevokeTokenResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
RevokeTokenResponseType^ RevokeToken(
    RevokeTokenRequestType^ RevokeTokenRequest
)
Parameters
RevokeTokenRequest (RevokeTokenRequestType)
Remarks


SaveItemToSellingManagerTemplate Method (SaveItemToSellingManagerTemplateRequest)

SaveItemToSellingManagerTemplate Method (SaveItemToSellingManagerTemplateRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SaveItemToSellingManagerTemplate(SaveItemToSellingManagerTemplateRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SaveItemToSellingManagerTemplateResponseType SaveItemToSellingManagerTemplate(
    SaveItemToSellingManagerTemplateRequestType SaveItemToSellingManagerTemplateRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SaveItemToSellingManagerTemplate ( _
    SaveItemToSellingManagerTemplateRequest As SaveItemToSellingManagerTemplateRequestType _
) As SaveItemToSellingManagerTemplateResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SaveItemToSellingManagerTemplateResponseType^ SaveItemToSellingManagerTemplate(
    SaveItemToSellingManagerTemplateRequestType^ SaveItemToSellingManagerTemplateRequest
)
Parameters
SaveItemToSellingManagerTemplateRequest (SaveItemToSellingManagerTemplateRequestType)
Remarks


SellerReverseDispute Method (SellerReverseDisputeRequest)

SellerReverseDispute Method (SellerReverseDisputeRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SellerReverseDispute(SellerReverseDisputeRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SellerReverseDisputeResponseType SellerReverseDispute(
    SellerReverseDisputeRequestType SellerReverseDisputeRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SellerReverseDispute ( _
    SellerReverseDisputeRequest As SellerReverseDisputeRequestType _
) As SellerReverseDisputeResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SellerReverseDisputeResponseType^ SellerReverseDispute(
    SellerReverseDisputeRequestType^ SellerReverseDisputeRequest
)
Parameters
SellerReverseDisputeRequest (SellerReverseDisputeRequestType)
Remarks


SendInvoice Method (SendInvoiceRequest)

SendInvoice Method (SendInvoiceRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SendInvoice(SendInvoiceRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SendInvoiceResponseType SendInvoice(
    SendInvoiceRequestType SendInvoiceRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SendInvoice ( _
    SendInvoiceRequest As SendInvoiceRequestType _
) As SendInvoiceResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SendInvoiceResponseType^ SendInvoice(
    SendInvoiceRequestType^ SendInvoiceRequest
)
Parameters
SendInvoiceRequest (SendInvoiceRequestType)
Remarks


SetMessagePreferences Method (SetMessagePreferencesRequest)

SetMessagePreferences Method (SetMessagePreferencesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetMessagePreferences(SetMessagePreferencesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetMessagePreferencesResponseType SetMessagePreferences(
    SetMessagePreferencesRequestType SetMessagePreferencesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetMessagePreferences ( _
    SetMessagePreferencesRequest As SetMessagePreferencesRequestType _
) As SetMessagePreferencesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetMessagePreferencesResponseType^ SetMessagePreferences(
    SetMessagePreferencesRequestType^ SetMessagePreferencesRequest
)
Parameters
SetMessagePreferencesRequest (SetMessagePreferencesRequestType)
Remarks


SetNotificationPreferences Method (SetNotificationPreferencesRequest)

SetNotificationPreferences Method (SetNotificationPreferencesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetNotificationPreferences(SetNotificationPreferencesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetNotificationPreferencesResponseType SetNotificationPreferences(
    SetNotificationPreferencesRequestType SetNotificationPreferencesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetNotificationPreferences ( _
    SetNotificationPreferencesRequest As SetNotificationPreferencesRequestType _
) As SetNotificationPreferencesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetNotificationPreferencesResponseType^ SetNotificationPreferences(
    SetNotificationPreferencesRequestType^ SetNotificationPreferencesRequest
)
Parameters
SetNotificationPreferencesRequest (SetNotificationPreferencesRequestType)
Remarks


SetPromotionalSale Method (SetPromotionalSaleRequest)

SetPromotionalSale Method (SetPromotionalSaleRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetPromotionalSale(SetPromotionalSaleRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetPromotionalSaleResponseType SetPromotionalSale(
    SetPromotionalSaleRequestType SetPromotionalSaleRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetPromotionalSale ( _
    SetPromotionalSaleRequest As SetPromotionalSaleRequestType _
) As SetPromotionalSaleResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetPromotionalSaleResponseType^ SetPromotionalSale(
    SetPromotionalSaleRequestType^ SetPromotionalSaleRequest
)
Parameters
SetPromotionalSaleRequest (SetPromotionalSaleRequestType)
Remarks


SetPromotionalSaleListings Method (SetPromotionalSaleListingsRequest)

SetPromotionalSaleListings Method (SetPromotionalSaleListingsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetPromotionalSaleListings(SetPromotionalSaleListingsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetPromotionalSaleListingsResponseType SetPromotionalSaleListings(
    SetPromotionalSaleListingsRequestType SetPromotionalSaleListingsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetPromotionalSaleListings ( _
    SetPromotionalSaleListingsRequest As SetPromotionalSaleListingsRequestType _
) As SetPromotionalSaleListingsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetPromotionalSaleListingsResponseType^ SetPromotionalSaleListings(
    SetPromotionalSaleListingsRequestType^ SetPromotionalSaleListingsRequest
)
Parameters
SetPromotionalSaleListingsRequest (SetPromotionalSaleListingsRequestType)
Remarks


SetSellingManagerFeedbackOptions Method (SetSellingManagerFeedbackOptionsRequest)

SetSellingManagerFeedbackOptions Method (SetSellingManagerFeedbackOptionsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetSellingManagerFeedbackOptions(SetSellingManagerFeedbackOptionsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetSellingManagerFeedbackOptionsResponseType SetSellingManagerFeedbackOptions(
    SetSellingManagerFeedbackOptionsRequestType SetSellingManagerFeedbackOptionsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetSellingManagerFeedbackOptions ( _
    SetSellingManagerFeedbackOptionsRequest As SetSellingManagerFeedbackOptionsRequestType _
) As SetSellingManagerFeedbackOptionsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetSellingManagerFeedbackOptionsResponseType^ SetSellingManagerFeedbackOptions(
    SetSellingManagerFeedbackOptionsRequestType^ SetSellingManagerFeedbackOptionsRequest
)
Parameters
SetSellingManagerFeedbackOptionsRequest (SetSellingManagerFeedbackOptionsRequestType)
Remarks


SetSellingManagerItemAutomationRule Method (SetSellingManagerItemAutomationRuleRequest)

SetSellingManagerItemAutomationRule Method (SetSellingManagerItemAutomationRuleRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetSellingManagerItemAutomationRule(SetSellingManagerItemAutomationRuleRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetSellingManagerItemAutomationRuleResponseType SetSellingManagerItemAutomationRule(
    SetSellingManagerItemAutomationRuleRequestType SetSellingManagerItemAutomationRuleRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetSellingManagerItemAutomationRule ( _
    SetSellingManagerItemAutomationRuleRequest As SetSellingManagerItemAutomationRuleRequestType _
) As SetSellingManagerItemAutomationRuleResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetSellingManagerItemAutomationRuleResponseType^ SetSellingManagerItemAutomationRule(
    SetSellingManagerItemAutomationRuleRequestType^ SetSellingManagerItemAutomationRuleRequest
)
Parameters
SetSellingManagerItemAutomationRuleRequest (SetSellingManagerItemAutomationRuleRequestType)
Remarks


SetSellingManagerTemplateAutomationRule Method (SetSellingManagerTemplateAutomationRuleRequest)

SetSellingManagerTemplateAutomationRule Method (SetSellingManagerTemplateAutomationRuleRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetSellingManagerTemplateAutomationRule(SetSellingManagerTemplateAutomationRuleRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetSellingManagerTemplateAutomationRuleResponseType SetSellingManagerTemplateAutomationRule(
    SetSellingManagerTemplateAutomationRuleRequestType SetSellingManagerTemplateAutomationRuleRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetSellingManagerTemplateAutomationRule ( _
    SetSellingManagerTemplateAutomationRuleRequest As SetSellingManagerTemplateAutomationRuleRequestType _
) As SetSellingManagerTemplateAutomationRuleResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetSellingManagerTemplateAutomationRuleResponseType^ SetSellingManagerTemplateAutomationRule(
    SetSellingManagerTemplateAutomationRuleRequestType^ SetSellingManagerTemplateAutomationRuleRequest
)
Parameters
SetSellingManagerTemplateAutomationRuleRequest (SetSellingManagerTemplateAutomationRuleRequestType)
Remarks


SetShippingDiscountProfiles Method (SetShippingDiscountProfilesRequest)

SetShippingDiscountProfiles Method (SetShippingDiscountProfilesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetShippingDiscountProfiles(SetShippingDiscountProfilesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetShippingDiscountProfilesResponseType SetShippingDiscountProfiles(
    SetShippingDiscountProfilesRequestType SetShippingDiscountProfilesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetShippingDiscountProfiles ( _
    SetShippingDiscountProfilesRequest As SetShippingDiscountProfilesRequestType _
) As SetShippingDiscountProfilesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetShippingDiscountProfilesResponseType^ SetShippingDiscountProfiles(
    SetShippingDiscountProfilesRequestType^ SetShippingDiscountProfilesRequest
)
Parameters
SetShippingDiscountProfilesRequest (SetShippingDiscountProfilesRequestType)
Remarks


SetStore Method (SetStoreRequest)

SetStore Method (SetStoreRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetStore(SetStoreRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetStoreResponseType SetStore(
    SetStoreRequestType SetStoreRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetStore ( _
    SetStoreRequest As SetStoreRequestType _
) As SetStoreResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetStoreResponseType^ SetStore(
    SetStoreRequestType^ SetStoreRequest
)
Parameters
SetStoreRequest (SetStoreRequestType)
Remarks


SetStoreCategories Method (SetStoreCategoriesRequest)

SetStoreCategories Method (SetStoreCategoriesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetStoreCategories(SetStoreCategoriesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetStoreCategoriesResponseType SetStoreCategories(
    SetStoreCategoriesRequestType SetStoreCategoriesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetStoreCategories ( _
    SetStoreCategoriesRequest As SetStoreCategoriesRequestType _
) As SetStoreCategoriesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetStoreCategoriesResponseType^ SetStoreCategories(
    SetStoreCategoriesRequestType^ SetStoreCategoriesRequest
)
Parameters
SetStoreCategoriesRequest (SetStoreCategoriesRequestType)
Remarks


SetStoreCustomPage Method (SetStoreCustomPageRequest)

SetStoreCustomPage Method (SetStoreCustomPageRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetStoreCustomPage(SetStoreCustomPageRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetStoreCustomPageResponseType SetStoreCustomPage(
    SetStoreCustomPageRequestType SetStoreCustomPageRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetStoreCustomPage ( _
    SetStoreCustomPageRequest As SetStoreCustomPageRequestType _
) As SetStoreCustomPageResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetStoreCustomPageResponseType^ SetStoreCustomPage(
    SetStoreCustomPageRequestType^ SetStoreCustomPageRequest
)
Parameters
SetStoreCustomPageRequest (SetStoreCustomPageRequestType)
Remarks


SetStorePreferences Method (SetStorePreferencesRequest)

SetStorePreferences Method (SetStorePreferencesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetStorePreferences(SetStorePreferencesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetStorePreferencesResponseType SetStorePreferences(
    SetStorePreferencesRequestType SetStorePreferencesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetStorePreferences ( _
    SetStorePreferencesRequest As SetStorePreferencesRequestType _
) As SetStorePreferencesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetStorePreferencesResponseType^ SetStorePreferences(
    SetStorePreferencesRequestType^ SetStorePreferencesRequest
)
Parameters
SetStorePreferencesRequest (SetStorePreferencesRequestType)
Remarks


SetTaxTable Method (SetTaxTableRequest)

SetTaxTable Method (SetTaxTableRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetTaxTable(SetTaxTableRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetTaxTableResponseType SetTaxTable(
    SetTaxTableRequestType SetTaxTableRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetTaxTable ( _
    SetTaxTableRequest As SetTaxTableRequestType _
) As SetTaxTableResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetTaxTableResponseType^ SetTaxTable(
    SetTaxTableRequestType^ SetTaxTableRequest
)
Parameters
SetTaxTableRequest (SetTaxTableRequestType)
Remarks


SetUserNotes Method (SetUserNotesRequest)

SetUserNotes Method (SetUserNotesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetUserNotes(SetUserNotesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetUserNotesResponseType SetUserNotes(
    SetUserNotesRequestType SetUserNotesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetUserNotes ( _
    SetUserNotesRequest As SetUserNotesRequestType _
) As SetUserNotesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetUserNotesResponseType^ SetUserNotes(
    SetUserNotesRequestType^ SetUserNotesRequest
)
Parameters
SetUserNotesRequest (SetUserNotesRequestType)
Remarks


SetUserPreferences Method (SetUserPreferencesRequest)

SetUserPreferences Method (SetUserPreferencesRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► SetUserPreferences(SetUserPreferencesRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public SetUserPreferencesResponseType SetUserPreferences(
    SetUserPreferencesRequestType SetUserPreferencesRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function SetUserPreferences ( _
    SetUserPreferencesRequest As SetUserPreferencesRequestType _
) As SetUserPreferencesResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
SetUserPreferencesResponseType^ SetUserPreferences(
    SetUserPreferencesRequestType^ SetUserPreferencesRequest
)
Parameters
SetUserPreferencesRequest (SetUserPreferencesRequestType)
Remarks


ValidateChallengeInput Method (ValidateChallengeInputRequest)

ValidateChallengeInput Method (ValidateChallengeInputRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ValidateChallengeInput(ValidateChallengeInputRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ValidateChallengeInputResponseType ValidateChallengeInput(
    ValidateChallengeInputRequestType ValidateChallengeInputRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ValidateChallengeInput ( _
    ValidateChallengeInputRequest As ValidateChallengeInputRequestType _
) As ValidateChallengeInputResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ValidateChallengeInputResponseType^ ValidateChallengeInput(
    ValidateChallengeInputRequestType^ ValidateChallengeInputRequest
)
Parameters
ValidateChallengeInputRequest (ValidateChallengeInputRequestType)
Remarks


ValidateTestUserRegistration Method (ValidateTestUserRegistrationRequest)

ValidateTestUserRegistration Method (ValidateTestUserRegistrationRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► ValidateTestUserRegistration(ValidateTestUserRegistrationRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public ValidateTestUserRegistrationResponseType ValidateTestUserRegistration(
    ValidateTestUserRegistrationRequestType ValidateTestUserRegistrationRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function ValidateTestUserRegistration ( _
    ValidateTestUserRegistrationRequest As ValidateTestUserRegistrationRequestType _
) As ValidateTestUserRegistrationResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
ValidateTestUserRegistrationResponseType^ ValidateTestUserRegistration(
    ValidateTestUserRegistrationRequestType^ ValidateTestUserRegistrationRequest
)
Parameters
ValidateTestUserRegistrationRequest (ValidateTestUserRegistrationRequestType)
Remarks


VerifyAddFixedPriceItem Method (VerifyAddFixedPriceItemRequest)

VerifyAddFixedPriceItem Method (VerifyAddFixedPriceItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► VerifyAddFixedPriceItem(VerifyAddFixedPriceItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public VerifyAddFixedPriceItemResponseType VerifyAddFixedPriceItem(
    VerifyAddFixedPriceItemRequestType VerifyAddFixedPriceItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function VerifyAddFixedPriceItem ( _
    VerifyAddFixedPriceItemRequest As VerifyAddFixedPriceItemRequestType _
) As VerifyAddFixedPriceItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
VerifyAddFixedPriceItemResponseType^ VerifyAddFixedPriceItem(
    VerifyAddFixedPriceItemRequestType^ VerifyAddFixedPriceItemRequest
)
Parameters
VerifyAddFixedPriceItemRequest (VerifyAddFixedPriceItemRequestType)
Remarks


VerifyAddItem Method (VerifyAddItemRequest)

VerifyAddItem Method (VerifyAddItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► VerifyAddItem(VerifyAddItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public VerifyAddItemResponseType VerifyAddItem(
    VerifyAddItemRequestType VerifyAddItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function VerifyAddItem ( _
    VerifyAddItemRequest As VerifyAddItemRequestType _
) As VerifyAddItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
VerifyAddItemResponseType^ VerifyAddItem(
    VerifyAddItemRequestType^ VerifyAddItemRequest
)
Parameters
VerifyAddItemRequest (VerifyAddItemRequestType)
Remarks


VerifyAddSecondChanceItem Method (VerifyAddSecondChanceItemRequest)

VerifyAddSecondChanceItem Method (VerifyAddSecondChanceItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► VerifyAddSecondChanceItem(VerifyAddSecondChanceItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public VerifyAddSecondChanceItemResponseType VerifyAddSecondChanceItem(
    VerifyAddSecondChanceItemRequestType VerifyAddSecondChanceItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function VerifyAddSecondChanceItem ( _
    VerifyAddSecondChanceItemRequest As VerifyAddSecondChanceItemRequestType _
) As VerifyAddSecondChanceItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
VerifyAddSecondChanceItemResponseType^ VerifyAddSecondChanceItem(
    VerifyAddSecondChanceItemRequestType^ VerifyAddSecondChanceItemRequest
)
Parameters
VerifyAddSecondChanceItemRequest (VerifyAddSecondChanceItemRequestType)
Remarks


VerifyRelistItem Method (VerifyRelistItemRequest)

VerifyRelistItem Method (VerifyRelistItemRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► VerifyRelistItem(VerifyRelistItemRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public VerifyRelistItemResponseType VerifyRelistItem(
    VerifyRelistItemRequestType VerifyRelistItemRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function VerifyRelistItem ( _
    VerifyRelistItemRequest As VerifyRelistItemRequestType _
) As VerifyRelistItemResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
VerifyRelistItemResponseType^ VerifyRelistItem(
    VerifyRelistItemRequestType^ VerifyRelistItemRequest
)
Parameters
VerifyRelistItemRequest (VerifyRelistItemRequestType)
Remarks


VeROReportItems Method (VeROReportItemsRequest)

VeROReportItems Method (VeROReportItemsRequest)
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► VeROReportItems(VeROReportItemsRequestType)
Declaration Syntax
C# Visual Basic Visual C++
[SoapHeaderAttribute("RequesterCredentials", Direction = SoapHeaderDirection.InOut)]
[SoapDocumentMethodAttribute("", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
[SoapExtensionExAttribute]
public VeROReportItemsResponseType VeROReportItems(
    VeROReportItemsRequestType VeROReportItemsRequest
)
<SoapHeaderAttribute("RequesterCredentials", Direction := SoapHeaderDirection.InOut)> _
<SoapDocumentMethodAttribute("", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
<SoapExtensionExAttribute> _
Public Function VeROReportItems ( _
    VeROReportItemsRequest As VeROReportItemsRequestType _
) As VeROReportItemsResponseType
[SoapHeaderAttribute(L"RequesterCredentials", Direction = SoapHeaderDirection::InOut)]
[SoapDocumentMethodAttribute(L"", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
[SoapExtensionExAttribute]
public:
VeROReportItemsResponseType^ VeROReportItems(
    VeROReportItemsRequestType^ VeROReportItemsRequest
)
Parameters
VeROReportItemsRequest (VeROReportItemsRequestType)
Remarks


eBayMotorsProAdFormatEnabledDefinitionType Class

eBayMotorsProAdFormatEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProAdFormatEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProAdFormatEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProAdFormatEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProAdFormatEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProAdFormatEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProAdFormatEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProAdFormatEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProAdFormatEnabledDefinitionType Constructor

eBayMotorsProAdFormatEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProAdFormatEnabledDefinitionType ► eBayMotorsProAdFormatEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProAdFormatEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProAdFormatEnabledDefinitionType()


eBayMotorsProAutoAcceptEnabledDefinitionType Class

eBayMotorsProAutoAcceptEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProAutoAcceptEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProAutoAcceptEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProAutoAcceptEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProAutoAcceptEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProAutoAcceptEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProAutoAcceptEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProAutoAcceptEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProAutoAcceptEnabledDefinitionType Constructor

eBayMotorsProAutoAcceptEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProAutoAcceptEnabledDefinitionType ► eBayMotorsProAutoAcceptEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProAutoAcceptEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProAutoAcceptEnabledDefinitionType()


eBayMotorsProAutoDeclineEnabledDefinitionType Class

eBayMotorsProAutoDeclineEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProAutoDeclineEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProAutoDeclineEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProAutoDeclineEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProAutoDeclineEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProAutoDeclineEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProAutoDeclineEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProAutoDeclineEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProAutoDeclineEnabledDefinitionType Constructor

eBayMotorsProAutoDeclineEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProAutoDeclineEnabledDefinitionType ► eBayMotorsProAutoDeclineEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProAutoDeclineEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProAutoDeclineEnabledDefinitionType()


eBayMotorsProBestOfferEnabledDefinitionType Class

eBayMotorsProBestOfferEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProBestOfferEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProBestOfferEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProBestOfferEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProBestOfferEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProBestOfferEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProBestOfferEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProBestOfferEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProBestOfferEnabledDefinitionType Constructor

eBayMotorsProBestOfferEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProBestOfferEnabledDefinitionType ► eBayMotorsProBestOfferEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProBestOfferEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProBestOfferEnabledDefinitionType()


eBayMotorsProCompanyNameEnabledDefinitionType Class

eBayMotorsProCompanyNameEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProCompanyNameEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProCompanyNameEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProCompanyNameEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProCompanyNameEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProCompanyNameEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProCompanyNameEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProCompanyNameEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProCompanyNameEnabledDefinitionType Constructor

eBayMotorsProCompanyNameEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProCompanyNameEnabledDefinitionType ► eBayMotorsProCompanyNameEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProCompanyNameEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProCompanyNameEnabledDefinitionType()


eBayMotorsProContactByAddressEnabledDefinitionType Class

eBayMotorsProContactByAddressEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProContactByAddressEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProContactByAddressEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProContactByAddressEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProContactByAddressEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProContactByAddressEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProContactByAddressEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProContactByAddressEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProContactByAddressEnabledDefinitionType Constructor

eBayMotorsProContactByAddressEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProContactByAddressEnabledDefinitionType ► eBayMotorsProContactByAddressEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProContactByAddressEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProContactByAddressEnabledDefinitionType()


eBayMotorsProContactByEmailEnabledDefinitionType Class

eBayMotorsProContactByEmailEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProContactByEmailEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProContactByEmailEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProContactByEmailEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProContactByEmailEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProContactByEmailEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProContactByEmailEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProContactByEmailEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProContactByEmailEnabledDefinitionType Constructor

eBayMotorsProContactByEmailEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProContactByEmailEnabledDefinitionType ► eBayMotorsProContactByEmailEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProContactByEmailEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProContactByEmailEnabledDefinitionType()


eBayMotorsProContactByPhoneEnabledDefinitionType Class

eBayMotorsProContactByPhoneEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProContactByPhoneEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProContactByPhoneEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProContactByPhoneEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProContactByPhoneEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProContactByPhoneEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProContactByPhoneEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProContactByPhoneEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProContactByPhoneEnabledDefinitionType Constructor

eBayMotorsProContactByPhoneEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProContactByPhoneEnabledDefinitionType ► eBayMotorsProContactByPhoneEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProContactByPhoneEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProContactByPhoneEnabledDefinitionType()


eBayMotorsProCounterOfferEnabledDefinitionType Class

eBayMotorsProCounterOfferEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProCounterOfferEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProCounterOfferEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProCounterOfferEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProCounterOfferEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProCounterOfferEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProCounterOfferEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProCounterOfferEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProCounterOfferEnabledDefinitionType Constructor

eBayMotorsProCounterOfferEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProCounterOfferEnabledDefinitionType ► eBayMotorsProCounterOfferEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProCounterOfferEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProCounterOfferEnabledDefinitionType()


eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType Class

eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType Constructor

eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType ► eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType()


eBayMotorsProPhoneCountDefinitionType Class

eBayMotorsProPhoneCountDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProPhoneCountDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProPhoneCountDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProPhoneCountDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProPhoneCountDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProPhoneCountDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProPhoneCountDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProPhoneCountDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProPhoneCountDefinitionType Constructor

eBayMotorsProPhoneCountDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProPhoneCountDefinitionType ► eBayMotorsProPhoneCountDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProPhoneCountDefinitionType()
Public Sub New
public:
eBayMotorsProPhoneCountDefinitionType()


eBayMotorsProSellerContactDetailsEnabledDefinitionType Class

eBayMotorsProSellerContactDetailsEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProSellerContactDetailsEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProSellerContactDetailsEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProSellerContactDetailsEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProSellerContactDetailsEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProSellerContactDetailsEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProSellerContactDetailsEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProSellerContactDetailsEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProSellerContactDetailsEnabledDefinitionType Constructor

eBayMotorsProSellerContactDetailsEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProSellerContactDetailsEnabledDefinitionType ► eBayMotorsProSellerContactDetailsEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProSellerContactDetailsEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProSellerContactDetailsEnabledDefinitionType()


eBayMotorsProShippingMethodEnabledDefinitionType Class

eBayMotorsProShippingMethodEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProShippingMethodEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProShippingMethodEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProShippingMethodEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProShippingMethodEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProShippingMethodEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProShippingMethodEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProShippingMethodEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProShippingMethodEnabledDefinitionType Constructor

eBayMotorsProShippingMethodEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProShippingMethodEnabledDefinitionType ► eBayMotorsProShippingMethodEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProShippingMethodEnabledDefinitionType()
Public Sub New
public:
eBayMotorsProShippingMethodEnabledDefinitionType()


eBayMotorsProStreetCountDefinitionType Class

eBayMotorsProStreetCountDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProStreetCountDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayMotorsProStreetCountDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayMotorsProStreetCountDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayMotorsProStreetCountDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayMotorsProStreetCountDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayMotorsProStreetCountDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProStreetCountDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayMotorsProStreetCountDefinitionType Constructor

eBayMotorsProStreetCountDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayMotorsProStreetCountDefinitionType ► eBayMotorsProStreetCountDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProStreetCountDefinitionType()
Public Sub New
public:
eBayMotorsProStreetCountDefinitionType()


eBayPaymentMismatchDetailsType Class

eBayPaymentMismatchDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► eBayPaymentMismatchDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayPaymentMismatchDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayPaymentMismatchDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayPaymentMismatchDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayPaymentMismatchDetailsType()()()() |
 | ActionRequiredBy |
 | ActionRequiredBySpecified |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MismatchAmount |
 | MismatchType |
 | MismatchTypeSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayPaymentMismatchDetailsType


ActionRequiredBy Property

ActionRequiredBy Property
Namespaces ► eBay.Service.Core.Soap ► eBayPaymentMismatchDetailsType ► ActionRequiredBy
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ActionRequiredBy { get; set; }
Public Property ActionRequiredBy As DateTime
    Get
    Set
public:
property DateTime ActionRequiredBy {
    DateTime get ();
    void set (DateTime value);
}


ActionRequiredBySpecified Property

ActionRequiredBySpecified Property
Namespaces ► eBay.Service.Core.Soap ► eBayPaymentMismatchDetailsType ► ActionRequiredBySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ActionRequiredBySpecified { get; set; }
Public Property ActionRequiredBySpecified As Boolean
    Get
    Set
public:
property bool ActionRequiredBySpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayPaymentMismatchDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayPaymentMismatchDetailsType Constructor

eBayPaymentMismatchDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayPaymentMismatchDetailsType ► eBayPaymentMismatchDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayPaymentMismatchDetailsType()
Public Sub New
public:
eBayPaymentMismatchDetailsType()


MismatchAmount Property

MismatchAmount Property
Namespaces ► eBay.Service.Core.Soap ► eBayPaymentMismatchDetailsType ► MismatchAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MismatchAmount { get; set; }
Public Property MismatchAmount As AmountType
    Get
    Set
public:
property AmountType^ MismatchAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


MismatchType Property

MismatchType Property
Namespaces ► eBay.Service.Core.Soap ► eBayPaymentMismatchDetailsType ► MismatchType
Declaration Syntax
C# Visual Basic Visual C++
public MismatchTypeCodeType MismatchType { get; set; }
Public Property MismatchType As MismatchTypeCodeType
    Get
    Set
public:
property MismatchTypeCodeType MismatchType {
    MismatchTypeCodeType get ();
    void set (MismatchTypeCodeType value);
}


MismatchTypeSpecified Property

MismatchTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► eBayPaymentMismatchDetailsType ► MismatchTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MismatchTypeSpecified { get; set; }
Public Property MismatchTypeSpecified As Boolean
    Get
    Set
public:
property bool MismatchTypeSpecified {
    bool get ();
    void set (bool value);
}


eBayPLUSPreferenceType Class

eBayPLUSPreferenceType Class
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class eBayPLUSPreferenceType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class eBayPLUSPreferenceType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class eBayPLUSPreferenceType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayPLUSPreferenceType()()()() |
 | Any |
 | Country |
 | CountrySpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ListingPreference |
 | ListingPreferenceSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OptInStatus |
 | OptInStatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
eBayPLUSPreferenceType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Country Property

Country Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceType ► Country
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType Country { get; set; }
Public Property Country As CountryCodeType
    Get
    Set
public:
property CountryCodeType Country {
    CountryCodeType get ();
    void set (CountryCodeType value);
}


CountrySpecified Property

CountrySpecified Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceType ► CountrySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CountrySpecified { get; set; }
Public Property CountrySpecified As Boolean
    Get
    Set
public:
property bool CountrySpecified {
    bool get ();
    void set (bool value);
}


eBayPLUSPreferenceType Constructor

eBayPLUSPreferenceType Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceType ► eBayPLUSPreferenceType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayPLUSPreferenceType()
Public Sub New
public:
eBayPLUSPreferenceType()


ListingPreference Property

ListingPreference Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceType ► ListingPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingPreference { get; set; }
Public Property ListingPreference As Boolean
    Get
    Set
public:
property bool ListingPreference {
    bool get ();
    void set (bool value);
}


ListingPreferenceSpecified Property

ListingPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceType ► ListingPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingPreferenceSpecified { get; set; }
Public Property ListingPreferenceSpecified As Boolean
    Get
    Set
public:
property bool ListingPreferenceSpecified {
    bool get ();
    void set (bool value);
}


OptInStatus Property

OptInStatus Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceType ► OptInStatus
Declaration Syntax
C# Visual Basic Visual C++
public bool OptInStatus { get; set; }
Public Property OptInStatus As Boolean
    Get
    Set
public:
property bool OptInStatus {
    bool get ();
    void set (bool value);
}


OptInStatusSpecified Property

OptInStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceType ► OptInStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OptInStatusSpecified { get; set; }
Public Property OptInStatusSpecified As Boolean
    Get
    Set
public:
property bool OptInStatusSpecified {
    bool get ();
    void set (bool value);
}


eBayPLUSPreferenceTypeCollection Class

eBayPLUSPreferenceTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class eBayPLUSPreferenceTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class eBayPLUSPreferenceTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class eBayPLUSPreferenceTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayPLUSPreferenceTypeCollection()()()() |
 | eBayPLUSPreferenceTypeCollection(array<eBayPLUSPreferenceType>[]()[][]) |
 | eBayPLUSPreferenceTypeCollection(eBayPLUSPreferenceTypeCollection) |
 | Add(eBayPLUSPreferenceType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<eBayPLUSPreferenceType>[]()[][]) |
 | AddRange(eBayPLUSPreferenceTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(eBayPLUSPreferenceType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<eBayPLUSPreferenceType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(eBayPLUSPreferenceType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, eBayPLUSPreferenceType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(eBayPLUSPreferenceType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | eBayPLUSPreferenceTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► Add(eBayPLUSPreferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    eBayPLUSPreferenceType item
)
Public Function Add ( _
    item As eBayPLUSPreferenceType _
) As Integer
public:
int Add(
    eBayPLUSPreferenceType^ item
)
Parameters
item (eBayPLUSPreferenceType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<eBayPLUSPreferenceType>[]()[][]) |
 | AddRange(eBayPLUSPreferenceTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► AddRange(array<eBayPLUSPreferenceType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    eBayPLUSPreferenceType[] items
)
Public Sub AddRange ( _
    items As eBayPLUSPreferenceType() _
)
public:
void AddRange(
    array<eBayPLUSPreferenceType^>^ items
)
Parameters
items (array< eBayPLUSPreferenceType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► AddRange(eBayPLUSPreferenceTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    eBayPLUSPreferenceTypeCollection items
)
Public Sub AddRange ( _
    items As eBayPLUSPreferenceTypeCollection _
)
public:
void AddRange(
    eBayPLUSPreferenceTypeCollection^ items
)
Parameters
items (eBayPLUSPreferenceTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► Contains(eBayPLUSPreferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    eBayPLUSPreferenceType item
)
Public Function Contains ( _
    item As eBayPLUSPreferenceType _
) As Boolean
public:
bool Contains(
    eBayPLUSPreferenceType^ item
)
Parameters
item (eBayPLUSPreferenceType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► CopyTo(array<eBayPLUSPreferenceType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    eBayPLUSPreferenceType[] items,
    int index
)
Public Sub CopyTo ( _
    items As eBayPLUSPreferenceType(), _
    index As Integer _
)
public:
void CopyTo(
    array<eBayPLUSPreferenceType^>^ items,
    int index
)
Parameters
items (array< eBayPLUSPreferenceType >[]()[][])
index (Int32)


eBayPLUSPreferenceTypeCollection Constructor

eBayPLUSPreferenceTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► eBayPLUSPreferenceTypeCollection()()()()
Members
Icon | Member | Description
 | eBayPLUSPreferenceTypeCollection()()()() |
 | eBayPLUSPreferenceTypeCollection(array<eBayPLUSPreferenceType>[]()[][]) |
 | eBayPLUSPreferenceTypeCollection(eBayPLUSPreferenceTypeCollection) |


eBayPLUSPreferenceTypeCollection Constructor

eBayPLUSPreferenceTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► eBayPLUSPreferenceTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayPLUSPreferenceTypeCollection()
Public Sub New
public:
eBayPLUSPreferenceTypeCollection()


eBayPLUSPreferenceTypeCollection Constructor (items)

eBayPLUSPreferenceTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► eBayPLUSPreferenceTypeCollection(array<eBayPLUSPreferenceType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public eBayPLUSPreferenceTypeCollection(
    eBayPLUSPreferenceType[] items
)
Public Sub New ( _
    items As eBayPLUSPreferenceType() _
)
public:
eBayPLUSPreferenceTypeCollection(
    array<eBayPLUSPreferenceType^>^ items
)
Parameters
items (array< eBayPLUSPreferenceType >[]()[][])


eBayPLUSPreferenceTypeCollection Constructor (items)

eBayPLUSPreferenceTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► eBayPLUSPreferenceTypeCollection(eBayPLUSPreferenceTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public eBayPLUSPreferenceTypeCollection(
    eBayPLUSPreferenceTypeCollection items
)
Public Sub New ( _
    items As eBayPLUSPreferenceTypeCollection _
)
public:
eBayPLUSPreferenceTypeCollection(
    eBayPLUSPreferenceTypeCollection^ items
)
Parameters
items (eBayPLUSPreferenceTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► IndexOf(eBayPLUSPreferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    eBayPLUSPreferenceType item
)
Public Function IndexOf ( _
    item As eBayPLUSPreferenceType _
) As Integer
public:
int IndexOf(
    eBayPLUSPreferenceType^ item
)
Parameters
item (eBayPLUSPreferenceType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► Insert(Int32, eBayPLUSPreferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    eBayPLUSPreferenceType item
)
Public Sub Insert ( _
    index As Integer, _
    item As eBayPLUSPreferenceType _
)
public:
void Insert(
    int index,
    eBayPLUSPreferenceType^ item
)
Parameters
index (Int32)
item (eBayPLUSPreferenceType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public eBayPLUSPreferenceType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As eBayPLUSPreferenceType
    Get
    Set
public:
property eBayPLUSPreferenceType^ default[int index] {
    eBayPLUSPreferenceType^ get (int index);
    void set (int index, eBayPLUSPreferenceType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public eBayPLUSPreferenceType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As eBayPLUSPreferenceType
public:
eBayPLUSPreferenceType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► Remove(eBayPLUSPreferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    eBayPLUSPreferenceType item
)
Public Sub Remove ( _
    item As eBayPLUSPreferenceType _
)
public:
void Remove(
    eBayPLUSPreferenceType^ item
)
Parameters
item (eBayPLUSPreferenceType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayPLUSPreferenceType[] ToArray()
Public Function ToArray As eBayPLUSPreferenceType()
public:
array<eBayPLUSPreferenceType^>^ ToArray()
Return Value


EBaySubscriptionTypeCodeType Enumeration

EBaySubscriptionTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum EBaySubscriptionTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration EBaySubscriptionTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class EBaySubscriptionTypeCodeType
Members
Member | Description
SellerAssistant |
SellerAssistantPro |
EBayStoreBasic |
EBayStoreFeatured |
EBayStoreAnchor |
SellingManager |
SellingManagerPro |
PictureManagerLevel1 |
PictureManagerLevel2 |
PictureManagerLevel3 |
PictureManagerLevel4 |
PictureManagerLevel5 |
PictureManagerLevel6 |
PictureManagerLevel7 |
SellerReportsBasic |
SellerReportsPlus |
FileExchange |
LocalMarketSpecialty |
LocalMarketRegular |
LocalMarketPremium |
CustomCode |
Remarks


EBaySubscriptionTypeCodeTypeCollection Class

EBaySubscriptionTypeCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class EBaySubscriptionTypeCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class EBaySubscriptionTypeCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class EBaySubscriptionTypeCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EBaySubscriptionTypeCodeTypeCollection()()()() |
 | EBaySubscriptionTypeCodeTypeCollection(array<EBaySubscriptionTypeCodeType>[]()[][]) |
 | EBaySubscriptionTypeCodeTypeCollection(EBaySubscriptionTypeCodeTypeCollection) |
 | Add(EBaySubscriptionTypeCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<EBaySubscriptionTypeCodeType>[]()[][]) |
 | AddRange(EBaySubscriptionTypeCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(EBaySubscriptionTypeCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<EBaySubscriptionTypeCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(EBaySubscriptionTypeCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, EBaySubscriptionTypeCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(EBaySubscriptionTypeCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | EBaySubscriptionTypeCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► Add(EBaySubscriptionTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    EBaySubscriptionTypeCodeType item
)
Public Function Add ( _
    item As EBaySubscriptionTypeCodeType _
) As Integer
public:
int Add(
    EBaySubscriptionTypeCodeType item
)
Parameters
item (EBaySubscriptionTypeCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<EBaySubscriptionTypeCodeType>[]()[][]) |
 | AddRange(EBaySubscriptionTypeCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► AddRange(array<EBaySubscriptionTypeCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    EBaySubscriptionTypeCodeType[] items
)
Public Sub AddRange ( _
    items As EBaySubscriptionTypeCodeType() _
)
public:
void AddRange(
    array<EBaySubscriptionTypeCodeType>^ items
)
Parameters
items (array< EBaySubscriptionTypeCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► AddRange(EBaySubscriptionTypeCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    EBaySubscriptionTypeCodeTypeCollection items
)
Public Sub AddRange ( _
    items As EBaySubscriptionTypeCodeTypeCollection _
)
public:
void AddRange(
    EBaySubscriptionTypeCodeTypeCollection^ items
)
Parameters
items (EBaySubscriptionTypeCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► Contains(EBaySubscriptionTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    EBaySubscriptionTypeCodeType item
)
Public Function Contains ( _
    item As EBaySubscriptionTypeCodeType _
) As Boolean
public:
bool Contains(
    EBaySubscriptionTypeCodeType item
)
Parameters
item (EBaySubscriptionTypeCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► CopyTo(array<EBaySubscriptionTypeCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    EBaySubscriptionTypeCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As EBaySubscriptionTypeCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<EBaySubscriptionTypeCodeType>^ items,
    int index
)
Parameters
items (array< EBaySubscriptionTypeCodeType >[]()[][])
index (Int32)


EBaySubscriptionTypeCodeTypeCollection Constructor

EBaySubscriptionTypeCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► EBaySubscriptionTypeCodeTypeCollection()()()()
Members
Icon | Member | Description
 | EBaySubscriptionTypeCodeTypeCollection()()()() |
 | EBaySubscriptionTypeCodeTypeCollection(array<EBaySubscriptionTypeCodeType>[]()[][]) |
 | EBaySubscriptionTypeCodeTypeCollection(EBaySubscriptionTypeCodeTypeCollection) |


EBaySubscriptionTypeCodeTypeCollection Constructor

EBaySubscriptionTypeCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► EBaySubscriptionTypeCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EBaySubscriptionTypeCodeTypeCollection()
Public Sub New
public:
EBaySubscriptionTypeCodeTypeCollection()


EBaySubscriptionTypeCodeTypeCollection Constructor (items)

EBaySubscriptionTypeCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► EBaySubscriptionTypeCodeTypeCollection(array<EBaySubscriptionTypeCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public EBaySubscriptionTypeCodeTypeCollection(
    EBaySubscriptionTypeCodeType[] items
)
Public Sub New ( _
    items As EBaySubscriptionTypeCodeType() _
)
public:
EBaySubscriptionTypeCodeTypeCollection(
    array<EBaySubscriptionTypeCodeType>^ items
)
Parameters
items (array< EBaySubscriptionTypeCodeType >[]()[][])


EBaySubscriptionTypeCodeTypeCollection Constructor (items)

EBaySubscriptionTypeCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► EBaySubscriptionTypeCodeTypeCollection(EBaySubscriptionTypeCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public EBaySubscriptionTypeCodeTypeCollection(
    EBaySubscriptionTypeCodeTypeCollection items
)
Public Sub New ( _
    items As EBaySubscriptionTypeCodeTypeCollection _
)
public:
EBaySubscriptionTypeCodeTypeCollection(
    EBaySubscriptionTypeCodeTypeCollection^ items
)
Parameters
items (EBaySubscriptionTypeCodeTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► IndexOf(EBaySubscriptionTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    EBaySubscriptionTypeCodeType item
)
Public Function IndexOf ( _
    item As EBaySubscriptionTypeCodeType _
) As Integer
public:
int IndexOf(
    EBaySubscriptionTypeCodeType item
)
Parameters
item (EBaySubscriptionTypeCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► Insert(Int32, EBaySubscriptionTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    EBaySubscriptionTypeCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As EBaySubscriptionTypeCodeType _
)
public:
void Insert(
    int index,
    EBaySubscriptionTypeCodeType item
)
Parameters
index (Int32)
item (EBaySubscriptionTypeCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public EBaySubscriptionTypeCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As EBaySubscriptionTypeCodeType
    Get
    Set
public:
property EBaySubscriptionTypeCodeType default[int index] {
    EBaySubscriptionTypeCodeType get (int index);
    void set (int index, EBaySubscriptionTypeCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public EBaySubscriptionTypeCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As EBaySubscriptionTypeCodeType
public:
EBaySubscriptionTypeCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► Remove(EBaySubscriptionTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    EBaySubscriptionTypeCodeType item
)
Public Sub Remove ( _
    item As EBaySubscriptionTypeCodeType _
)
public:
void Remove(
    EBaySubscriptionTypeCodeType item
)
Parameters
item (EBaySubscriptionTypeCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EBaySubscriptionTypeCodeType[] ToArray()
Public Function ToArray As EBaySubscriptionTypeCodeType()
public:
array<EBaySubscriptionTypeCodeType>^ ToArray()
Return Value


eBayXmlAPIInterfaceService Class

eBayXmlAPIInterfaceService Class
Namespaces ► eBay.Service.Core.Soap ► eBayXmlAPIInterfaceService
Declaration Syntax
C# Visual Basic Visual C++
public class eBayXmlAPIInterfaceService
Public Class eBayXmlAPIInterfaceService
public ref class eBayXmlAPIInterfaceService
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayXmlAPIInterfaceService()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Invoke(XmlDocument) | Makes an Xml request to eBay.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RequesterCredentials | Gets or sets credential information that is used to set the required Http headers.
 | Timeout | Gets or sets the Timeout for the API call.
 | ToString()()()() | (Inherited from Object.)
 | Url | Gets or sets the Url to send the API Call to.
 | Version | Gets or sets the Compatability Level of the API call.
 | XmlRequest | Gets the API Request of type String.
 | XmlResponse | Gets the API Response of type String.
Inheritance Hierarchy
Object
eBayXmlAPIInterfaceService


eBayXmlAPIInterfaceService Constructor

eBayXmlAPIInterfaceService Constructor
Namespaces ► eBay.Service.Core.Soap ► eBayXmlAPIInterfaceService ► eBayXmlAPIInterfaceService()()()()
Declaration Syntax
C# Visual Basic Visual C++
public eBayXmlAPIInterfaceService()
Public Sub New
public:
eBayXmlAPIInterfaceService()


Invoke Method (Request)

Invoke Method (Request)
Namespaces ► eBay.Service.Core.Soap ► eBayXmlAPIInterfaceService ► Invoke(XmlDocument)
Makes an Xml request to eBay.
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument Invoke(
    XmlDocument Request
)
Public Function Invoke ( _
    Request As XmlDocument _
) As XmlDocument
public:
XmlDocument^ Invoke(
    XmlDocument^ Request
)
Parameters
Request (XmlDocument)
The Xml Request to make of type XmlDocument.
Return Value
The XmlDocument response from the API call.


RequesterCredentials Property

RequesterCredentials Property
Namespaces ► eBay.Service.Core.Soap ► eBayXmlAPIInterfaceService ► RequesterCredentials
Gets or sets credential information that is used to set the required Http headers.
Declaration Syntax
C# Visual Basic Visual C++
public CustomSecurityHeaderType RequesterCredentials { get; set; }
Public Property RequesterCredentials As CustomSecurityHeaderType
    Get
    Set
public:
property CustomSecurityHeaderType^ RequesterCredentials {
    CustomSecurityHeaderType^ get ();
    void set (CustomSecurityHeaderType^ value);
}
Remarks
Only the AppId, DevId, and AuthCert are required.


Timeout Property

Timeout Property
Namespaces ► eBay.Service.Core.Soap ► eBayXmlAPIInterfaceService ► Timeout
Gets or sets the Timeout for the API call.
Declaration Syntax
C# Visual Basic Visual C++
public int Timeout { get; set; }
Public Property Timeout As Integer
    Get
    Set
public:
property int Timeout {
    int get ();
    void set (int value);
}


Url Property

Url Property
Namespaces ► eBay.Service.Core.Soap ► eBayXmlAPIInterfaceService ► Url
Gets or sets the Url to send the API Call to.
Declaration Syntax
C# Visual Basic Visual C++
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}


Version Property

Version Property
Namespaces ► eBay.Service.Core.Soap ► eBayXmlAPIInterfaceService ► Version
Gets or sets the Compatability Level of the API call.
Declaration Syntax
C# Visual Basic Visual C++
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}


XmlRequest Property

XmlRequest Property
Namespaces ► eBay.Service.Core.Soap ► eBayXmlAPIInterfaceService ► XmlRequest
Gets the API Request of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string XmlRequest { get; }
Public ReadOnly Property XmlRequest As String
    Get
public:
property String^ XmlRequest {
    String^ get ();
}


XmlResponse Property

XmlResponse Property
Namespaces ► eBay.Service.Core.Soap ► eBayXmlAPIInterfaceService ► XmlResponse
Gets the API Response of type String.
Declaration Syntax
C# Visual Basic Visual C++
public string XmlResponse { get; }
Public ReadOnly Property XmlResponse As String
    Get
public:
property String^ XmlResponse {
    String^ get ();
}


EnableCodeType Enumeration

EnableCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► EnableCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum EnableCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration EnableCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class EnableCodeType
Members
Member | Description
Enable |
Disable |
CustomCode |
Remarks


EndFixedPriceItemRequestType Class

EndFixedPriceItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► EndFixedPriceItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EndFixedPriceItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EndFixedPriceItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EndFixedPriceItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndFixedPriceItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndingReason |
 | EndingReasonSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SKU |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | EndFixedPriceItemRequestType


EndFixedPriceItemRequestType Constructor

EndFixedPriceItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► EndFixedPriceItemRequestType ► EndFixedPriceItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndFixedPriceItemRequestType()
Public Sub New
public:
EndFixedPriceItemRequestType()


EndingReason Property

EndingReason Property
Namespaces ► eBay.Service.Core.Soap ► EndFixedPriceItemRequestType ► EndingReason
Declaration Syntax
C# Visual Basic Visual C++
public EndReasonCodeType EndingReason { get; set; }
Public Property EndingReason As EndReasonCodeType
    Get
    Set
public:
property EndReasonCodeType EndingReason {
    EndReasonCodeType get ();
    void set (EndReasonCodeType value);
}


EndingReasonSpecified Property

EndingReasonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► EndFixedPriceItemRequestType ► EndingReasonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndingReasonSpecified { get; set; }
Public Property EndingReasonSpecified As Boolean
    Get
    Set
public:
property bool EndingReasonSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► EndFixedPriceItemRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► EndFixedPriceItemRequestType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


EndFixedPriceItemResponseType Class

EndFixedPriceItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► EndFixedPriceItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EndFixedPriceItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EndFixedPriceItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EndFixedPriceItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndFixedPriceItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SKU |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | EndFixedPriceItemResponseType


EndFixedPriceItemResponseType Constructor

EndFixedPriceItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► EndFixedPriceItemResponseType ► EndFixedPriceItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndFixedPriceItemResponseType()
Public Sub New
public:
EndFixedPriceItemResponseType()


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► EndFixedPriceItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► EndFixedPriceItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► EndFixedPriceItemResponseType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


EndItemRequestContainerType Class

EndItemRequestContainerType Class
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EndItemRequestContainerType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EndItemRequestContainerType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EndItemRequestContainerType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndItemRequestContainerType()()()() |
 | Any |
 | EndingReason |
 | EndingReasonSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID |
 | SellerInventoryID |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
EndItemRequestContainerType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EndingReason Property

EndingReason Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerType ► EndingReason
Declaration Syntax
C# Visual Basic Visual C++
public EndReasonCodeType EndingReason { get; set; }
Public Property EndingReason As EndReasonCodeType
    Get
    Set
public:
property EndReasonCodeType EndingReason {
    EndReasonCodeType get ();
    void set (EndReasonCodeType value);
}


EndingReasonSpecified Property

EndingReasonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerType ► EndingReasonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndingReasonSpecified { get; set; }
Public Property EndingReasonSpecified As Boolean
    Get
    Set
public:
property bool EndingReasonSpecified {
    bool get ();
    void set (bool value);
}


EndItemRequestContainerType Constructor

EndItemRequestContainerType Constructor
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerType ► EndItemRequestContainerType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemRequestContainerType()
Public Sub New
public:
EndItemRequestContainerType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MessageID Property

MessageID Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerType ► MessageID
Declaration Syntax
C# Visual Basic Visual C++
public string MessageID { get; set; }
Public Property MessageID As String
    Get
    Set
public:
property String^ MessageID {
    String^ get ();
    void set (String^ value);
}


SellerInventoryID Property

SellerInventoryID Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerType ► SellerInventoryID
Declaration Syntax
C# Visual Basic Visual C++
public string SellerInventoryID { get; set; }
Public Property SellerInventoryID As String
    Get
    Set
public:
property String^ SellerInventoryID {
    String^ get ();
    void set (String^ value);
}


EndItemRequestContainerTypeCollection Class

EndItemRequestContainerTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class EndItemRequestContainerTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class EndItemRequestContainerTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class EndItemRequestContainerTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndItemRequestContainerTypeCollection()()()() |
 | EndItemRequestContainerTypeCollection(array<EndItemRequestContainerType>[]()[][]) |
 | EndItemRequestContainerTypeCollection(EndItemRequestContainerTypeCollection) |
 | Add(EndItemRequestContainerType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<EndItemRequestContainerType>[]()[][]) |
 | AddRange(EndItemRequestContainerTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(EndItemRequestContainerType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<EndItemRequestContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(EndItemRequestContainerType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, EndItemRequestContainerType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(EndItemRequestContainerType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | EndItemRequestContainerTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► Add(EndItemRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    EndItemRequestContainerType item
)
Public Function Add ( _
    item As EndItemRequestContainerType _
) As Integer
public:
int Add(
    EndItemRequestContainerType^ item
)
Parameters
item (EndItemRequestContainerType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<EndItemRequestContainerType>[]()[][]) |
 | AddRange(EndItemRequestContainerTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► AddRange(array<EndItemRequestContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    EndItemRequestContainerType[] items
)
Public Sub AddRange ( _
    items As EndItemRequestContainerType() _
)
public:
void AddRange(
    array<EndItemRequestContainerType^>^ items
)
Parameters
items (array< EndItemRequestContainerType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► AddRange(EndItemRequestContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    EndItemRequestContainerTypeCollection items
)
Public Sub AddRange ( _
    items As EndItemRequestContainerTypeCollection _
)
public:
void AddRange(
    EndItemRequestContainerTypeCollection^ items
)
Parameters
items (EndItemRequestContainerTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► Contains(EndItemRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    EndItemRequestContainerType item
)
Public Function Contains ( _
    item As EndItemRequestContainerType _
) As Boolean
public:
bool Contains(
    EndItemRequestContainerType^ item
)
Parameters
item (EndItemRequestContainerType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► CopyTo(array<EndItemRequestContainerType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    EndItemRequestContainerType[] items,
    int index
)
Public Sub CopyTo ( _
    items As EndItemRequestContainerType(), _
    index As Integer _
)
public:
void CopyTo(
    array<EndItemRequestContainerType^>^ items,
    int index
)
Parameters
items (array< EndItemRequestContainerType >[]()[][])
index (Int32)


EndItemRequestContainerTypeCollection Constructor

EndItemRequestContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► EndItemRequestContainerTypeCollection()()()()
Members
Icon | Member | Description
 | EndItemRequestContainerTypeCollection()()()() |
 | EndItemRequestContainerTypeCollection(array<EndItemRequestContainerType>[]()[][]) |
 | EndItemRequestContainerTypeCollection(EndItemRequestContainerTypeCollection) |


EndItemRequestContainerTypeCollection Constructor

EndItemRequestContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► EndItemRequestContainerTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemRequestContainerTypeCollection()
Public Sub New
public:
EndItemRequestContainerTypeCollection()


EndItemRequestContainerTypeCollection Constructor (items)

EndItemRequestContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► EndItemRequestContainerTypeCollection(array<EndItemRequestContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public EndItemRequestContainerTypeCollection(
    EndItemRequestContainerType[] items
)
Public Sub New ( _
    items As EndItemRequestContainerType() _
)
public:
EndItemRequestContainerTypeCollection(
    array<EndItemRequestContainerType^>^ items
)
Parameters
items (array< EndItemRequestContainerType >[]()[][])


EndItemRequestContainerTypeCollection Constructor (items)

EndItemRequestContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► EndItemRequestContainerTypeCollection(EndItemRequestContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public EndItemRequestContainerTypeCollection(
    EndItemRequestContainerTypeCollection items
)
Public Sub New ( _
    items As EndItemRequestContainerTypeCollection _
)
public:
EndItemRequestContainerTypeCollection(
    EndItemRequestContainerTypeCollection^ items
)
Parameters
items (EndItemRequestContainerTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► IndexOf(EndItemRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    EndItemRequestContainerType item
)
Public Function IndexOf ( _
    item As EndItemRequestContainerType _
) As Integer
public:
int IndexOf(
    EndItemRequestContainerType^ item
)
Parameters
item (EndItemRequestContainerType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► Insert(Int32, EndItemRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    EndItemRequestContainerType item
)
Public Sub Insert ( _
    index As Integer, _
    item As EndItemRequestContainerType _
)
public:
void Insert(
    int index,
    EndItemRequestContainerType^ item
)
Parameters
index (Int32)
item (EndItemRequestContainerType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public EndItemRequestContainerType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As EndItemRequestContainerType
    Get
    Set
public:
property EndItemRequestContainerType^ default[int index] {
    EndItemRequestContainerType^ get (int index);
    void set (int index, EndItemRequestContainerType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public EndItemRequestContainerType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As EndItemRequestContainerType
public:
EndItemRequestContainerType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► Remove(EndItemRequestContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    EndItemRequestContainerType item
)
Public Sub Remove ( _
    item As EndItemRequestContainerType _
)
public:
void Remove(
    EndItemRequestContainerType^ item
)
Parameters
item (EndItemRequestContainerType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemRequestContainerType[] ToArray()
Public Function ToArray As EndItemRequestContainerType()
public:
array<EndItemRequestContainerType^>^ ToArray()
Return Value


EndItemRequestType Class

EndItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EndItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EndItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EndItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndingReason |
 | EndingReasonSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SellerInventoryID |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | EndItemRequestType


EndingReason Property

EndingReason Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestType ► EndingReason
Declaration Syntax
C# Visual Basic Visual C++
public EndReasonCodeType EndingReason { get; set; }
Public Property EndingReason As EndReasonCodeType
    Get
    Set
public:
property EndReasonCodeType EndingReason {
    EndReasonCodeType get ();
    void set (EndReasonCodeType value);
}


EndingReasonSpecified Property

EndingReasonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestType ► EndingReasonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndingReasonSpecified { get; set; }
Public Property EndingReasonSpecified As Boolean
    Get
    Set
public:
property bool EndingReasonSpecified {
    bool get ();
    void set (bool value);
}


EndItemRequestType Constructor

EndItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestType ► EndItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemRequestType()
Public Sub New
public:
EndItemRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


SellerInventoryID Property

SellerInventoryID Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestType ► SellerInventoryID
Declaration Syntax
C# Visual Basic Visual C++
public string SellerInventoryID { get; set; }
Public Property SellerInventoryID As String
    Get
    Set
public:
property String^ SellerInventoryID {
    String^ get ();
    void set (String^ value);
}


EndItemResponseContainerType Class

EndItemResponseContainerType Class
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EndItemResponseContainerType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EndItemResponseContainerType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EndItemResponseContainerType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndItemResponseContainerType()()()() |
 | Any |
 | CorrelationID |
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
EndItemResponseContainerType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CorrelationID Property

CorrelationID Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerType ► CorrelationID
Declaration Syntax
C# Visual Basic Visual C++
public string CorrelationID { get; set; }
Public Property CorrelationID As String
    Get
    Set
public:
property String^ CorrelationID {
    String^ get ();
    void set (String^ value);
}


EndItemResponseContainerType Constructor

EndItemResponseContainerType Constructor
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerType ► EndItemResponseContainerType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseContainerType()
Public Sub New
public:
EndItemResponseContainerType()


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


Errors Property

Errors Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerType ► Errors
Declaration Syntax
C# Visual Basic Visual C++
public ErrorTypeCollection Errors { get; set; }
Public Property Errors As ErrorTypeCollection
    Get
    Set
public:
property ErrorTypeCollection^ Errors {
    ErrorTypeCollection^ get ();
    void set (ErrorTypeCollection^ value);
}


EndItemResponseContainerTypeCollection Class

EndItemResponseContainerTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class EndItemResponseContainerTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class EndItemResponseContainerTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class EndItemResponseContainerTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndItemResponseContainerTypeCollection()()()() |
 | EndItemResponseContainerTypeCollection(array<EndItemResponseContainerType>[]()[][]) |
 | EndItemResponseContainerTypeCollection(EndItemResponseContainerTypeCollection) |
 | Add(EndItemResponseContainerType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<EndItemResponseContainerType>[]()[][]) |
 | AddRange(EndItemResponseContainerTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(EndItemResponseContainerType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<EndItemResponseContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(EndItemResponseContainerType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, EndItemResponseContainerType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(EndItemResponseContainerType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | EndItemResponseContainerTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► Add(EndItemResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    EndItemResponseContainerType item
)
Public Function Add ( _
    item As EndItemResponseContainerType _
) As Integer
public:
int Add(
    EndItemResponseContainerType^ item
)
Parameters
item (EndItemResponseContainerType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<EndItemResponseContainerType>[]()[][]) |
 | AddRange(EndItemResponseContainerTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► AddRange(array<EndItemResponseContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    EndItemResponseContainerType[] items
)
Public Sub AddRange ( _
    items As EndItemResponseContainerType() _
)
public:
void AddRange(
    array<EndItemResponseContainerType^>^ items
)
Parameters
items (array< EndItemResponseContainerType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► AddRange(EndItemResponseContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    EndItemResponseContainerTypeCollection items
)
Public Sub AddRange ( _
    items As EndItemResponseContainerTypeCollection _
)
public:
void AddRange(
    EndItemResponseContainerTypeCollection^ items
)
Parameters
items (EndItemResponseContainerTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► Contains(EndItemResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    EndItemResponseContainerType item
)
Public Function Contains ( _
    item As EndItemResponseContainerType _
) As Boolean
public:
bool Contains(
    EndItemResponseContainerType^ item
)
Parameters
item (EndItemResponseContainerType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► CopyTo(array<EndItemResponseContainerType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    EndItemResponseContainerType[] items,
    int index
)
Public Sub CopyTo ( _
    items As EndItemResponseContainerType(), _
    index As Integer _
)
public:
void CopyTo(
    array<EndItemResponseContainerType^>^ items,
    int index
)
Parameters
items (array< EndItemResponseContainerType >[]()[][])
index (Int32)


EndItemResponseContainerTypeCollection Constructor

EndItemResponseContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► EndItemResponseContainerTypeCollection()()()()
Members
Icon | Member | Description
 | EndItemResponseContainerTypeCollection()()()() |
 | EndItemResponseContainerTypeCollection(array<EndItemResponseContainerType>[]()[][]) |
 | EndItemResponseContainerTypeCollection(EndItemResponseContainerTypeCollection) |


EndItemResponseContainerTypeCollection Constructor

EndItemResponseContainerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► EndItemResponseContainerTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseContainerTypeCollection()
Public Sub New
public:
EndItemResponseContainerTypeCollection()


EndItemResponseContainerTypeCollection Constructor (items)

EndItemResponseContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► EndItemResponseContainerTypeCollection(array<EndItemResponseContainerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseContainerTypeCollection(
    EndItemResponseContainerType[] items
)
Public Sub New ( _
    items As EndItemResponseContainerType() _
)
public:
EndItemResponseContainerTypeCollection(
    array<EndItemResponseContainerType^>^ items
)
Parameters
items (array< EndItemResponseContainerType >[]()[][])


EndItemResponseContainerTypeCollection Constructor (items)

EndItemResponseContainerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► EndItemResponseContainerTypeCollection(EndItemResponseContainerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseContainerTypeCollection(
    EndItemResponseContainerTypeCollection items
)
Public Sub New ( _
    items As EndItemResponseContainerTypeCollection _
)
public:
EndItemResponseContainerTypeCollection(
    EndItemResponseContainerTypeCollection^ items
)
Parameters
items (EndItemResponseContainerTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► IndexOf(EndItemResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    EndItemResponseContainerType item
)
Public Function IndexOf ( _
    item As EndItemResponseContainerType _
) As Integer
public:
int IndexOf(
    EndItemResponseContainerType^ item
)
Parameters
item (EndItemResponseContainerType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► Insert(Int32, EndItemResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    EndItemResponseContainerType item
)
Public Sub Insert ( _
    index As Integer, _
    item As EndItemResponseContainerType _
)
public:
void Insert(
    int index,
    EndItemResponseContainerType^ item
)
Parameters
index (Int32)
item (EndItemResponseContainerType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseContainerType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As EndItemResponseContainerType
    Get
    Set
public:
property EndItemResponseContainerType^ default[int index] {
    EndItemResponseContainerType^ get (int index);
    void set (int index, EndItemResponseContainerType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseContainerType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As EndItemResponseContainerType
public:
EndItemResponseContainerType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► Remove(EndItemResponseContainerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    EndItemResponseContainerType item
)
Public Sub Remove ( _
    item As EndItemResponseContainerType _
)
public:
void Remove(
    EndItemResponseContainerType^ item
)
Parameters
item (EndItemResponseContainerType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseContainerType[] ToArray()
Public Function ToArray As EndItemResponseContainerType()
public:
array<EndItemResponseContainerType^>^ ToArray()
Return Value


EndItemResponseType Class

EndItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EndItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EndItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EndItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | EndItemResponseType


EndItemResponseType Constructor

EndItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseType ► EndItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseType()
Public Sub New
public:
EndItemResponseType()


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


EndItemsRequestType Class

EndItemsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► EndItemsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EndItemsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EndItemsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EndItemsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndItemsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndItemRequestContainer |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | EndItemsRequestType


EndItemRequestContainer Property

EndItemRequestContainer Property
Namespaces ► eBay.Service.Core.Soap ► EndItemsRequestType ► EndItemRequestContainer
Declaration Syntax
C# Visual Basic Visual C++
public EndItemRequestContainerTypeCollection EndItemRequestContainer { get; set; }
Public Property EndItemRequestContainer As EndItemRequestContainerTypeCollection
    Get
    Set
public:
property EndItemRequestContainerTypeCollection^ EndItemRequestContainer {
    EndItemRequestContainerTypeCollection^ get ();
    void set (EndItemRequestContainerTypeCollection^ value);
}


EndItemsRequestType Constructor

EndItemsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► EndItemsRequestType ► EndItemsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemsRequestType()
Public Sub New
public:
EndItemsRequestType()


EndItemsResponseType Class

EndItemsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► EndItemsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EndItemsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EndItemsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EndItemsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndItemsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndItemResponseContainer |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | EndItemsResponseType


EndItemResponseContainer Property

EndItemResponseContainer Property
Namespaces ► eBay.Service.Core.Soap ► EndItemsResponseType ► EndItemResponseContainer
Declaration Syntax
C# Visual Basic Visual C++
public EndItemResponseContainerTypeCollection EndItemResponseContainer { get; set; }
Public Property EndItemResponseContainer As EndItemResponseContainerTypeCollection
    Get
    Set
public:
property EndItemResponseContainerTypeCollection^ EndItemResponseContainer {
    EndItemResponseContainerTypeCollection^ get ();
    void set (EndItemResponseContainerTypeCollection^ value);
}


EndItemsResponseType Constructor

EndItemsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► EndItemsResponseType ► EndItemsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndItemsResponseType()
Public Sub New
public:
EndItemsResponseType()


EndOfAuctionEmailPreferencesType Class

EndOfAuctionEmailPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EndOfAuctionEmailPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EndOfAuctionEmailPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EndOfAuctionEmailPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EndOfAuctionEmailPreferencesType()()()() |
 | Any |
 | CopyEmail |
 | CopyEmailSpecified |
 | EmailCustomized |
 | EmailCustomizedSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LogoCustomized |
 | LogoCustomizedSpecified |
 | LogoType |
 | LogoTypeSpecified |
 | LogoURL |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | TemplateText |
 | TextCustomized |
 | TextCustomizedSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
EndOfAuctionEmailPreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CopyEmail Property

CopyEmail Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► CopyEmail
Declaration Syntax
C# Visual Basic Visual C++
public bool CopyEmail { get; set; }
Public Property CopyEmail As Boolean
    Get
    Set
public:
property bool CopyEmail {
    bool get ();
    void set (bool value);
}


CopyEmailSpecified Property

CopyEmailSpecified Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► CopyEmailSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CopyEmailSpecified { get; set; }
Public Property CopyEmailSpecified As Boolean
    Get
    Set
public:
property bool CopyEmailSpecified {
    bool get ();
    void set (bool value);
}


EmailCustomized Property

EmailCustomized Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► EmailCustomized
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailCustomized { get; set; }
Public Property EmailCustomized As Boolean
    Get
    Set
public:
property bool EmailCustomized {
    bool get ();
    void set (bool value);
}


EmailCustomizedSpecified Property

EmailCustomizedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► EmailCustomizedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailCustomizedSpecified { get; set; }
Public Property EmailCustomizedSpecified As Boolean
    Get
    Set
public:
property bool EmailCustomizedSpecified {
    bool get ();
    void set (bool value);
}


EndOfAuctionEmailPreferencesType Constructor

EndOfAuctionEmailPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► EndOfAuctionEmailPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EndOfAuctionEmailPreferencesType()
Public Sub New
public:
EndOfAuctionEmailPreferencesType()


LogoCustomized Property

LogoCustomized Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► LogoCustomized
Declaration Syntax
C# Visual Basic Visual C++
public bool LogoCustomized { get; set; }
Public Property LogoCustomized As Boolean
    Get
    Set
public:
property bool LogoCustomized {
    bool get ();
    void set (bool value);
}


LogoCustomizedSpecified Property

LogoCustomizedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► LogoCustomizedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LogoCustomizedSpecified { get; set; }
Public Property LogoCustomizedSpecified As Boolean
    Get
    Set
public:
property bool LogoCustomizedSpecified {
    bool get ();
    void set (bool value);
}


LogoType Property

LogoType Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► LogoType
Declaration Syntax
C# Visual Basic Visual C++
public EndOfAuctionLogoTypeCodeType LogoType { get; set; }
Public Property LogoType As EndOfAuctionLogoTypeCodeType
    Get
    Set
public:
property EndOfAuctionLogoTypeCodeType LogoType {
    EndOfAuctionLogoTypeCodeType get ();
    void set (EndOfAuctionLogoTypeCodeType value);
}


LogoTypeSpecified Property

LogoTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► LogoTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LogoTypeSpecified { get; set; }
Public Property LogoTypeSpecified As Boolean
    Get
    Set
public:
property bool LogoTypeSpecified {
    bool get ();
    void set (bool value);
}


LogoURL Property

LogoURL Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► LogoURL
Declaration Syntax
C# Visual Basic Visual C++
public string LogoURL { get; set; }
Public Property LogoURL As String
    Get
    Set
public:
property String^ LogoURL {
    String^ get ();
    void set (String^ value);
}


TemplateText Property

TemplateText Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► TemplateText
Declaration Syntax
C# Visual Basic Visual C++
public string TemplateText { get; set; }
Public Property TemplateText As String
    Get
    Set
public:
property String^ TemplateText {
    String^ get ();
    void set (String^ value);
}


TextCustomized Property

TextCustomized Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► TextCustomized
Declaration Syntax
C# Visual Basic Visual C++
public bool TextCustomized { get; set; }
Public Property TextCustomized As Boolean
    Get
    Set
public:
property bool TextCustomized {
    bool get ();
    void set (bool value);
}


TextCustomizedSpecified Property

TextCustomizedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionEmailPreferencesType ► TextCustomizedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TextCustomizedSpecified { get; set; }
Public Property TextCustomizedSpecified As Boolean
    Get
    Set
public:
property bool TextCustomizedSpecified {
    bool get ();
    void set (bool value);
}


EndOfAuctionLogoTypeCodeType Enumeration

EndOfAuctionLogoTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► EndOfAuctionLogoTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum EndOfAuctionLogoTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration EndOfAuctionLogoTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class EndOfAuctionLogoTypeCodeType
Members
Member | Description
WinningBidderNotice |
Store |
Customized |
CustomCode |
None |
Remarks


EndReasonCodeType Enumeration

EndReasonCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► EndReasonCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum EndReasonCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration EndReasonCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class EndReasonCodeType
Members
Member | Description
LostOrBroken |
NotAvailable |
Incorrect |
OtherListingError |
CustomCode |
SellToHighBidder |
Sold |
Remarks


EpidSupportedDefinitionType Class

EpidSupportedDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► EpidSupportedDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class EpidSupportedDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class EpidSupportedDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class EpidSupportedDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EpidSupportedDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
EpidSupportedDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► EpidSupportedDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EpidSupportedDefinitionType Constructor

EpidSupportedDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► EpidSupportedDefinitionType ► EpidSupportedDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EpidSupportedDefinitionType()
Public Sub New
public:
EpidSupportedDefinitionType()


ErrorClassificationCodeType Enumeration

ErrorClassificationCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ErrorClassificationCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ErrorClassificationCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ErrorClassificationCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ErrorClassificationCodeType
Members
Member | Description
RequestError |
SystemError |
CustomCode |
Remarks


ErrorHandlingCodeType Enumeration

ErrorHandlingCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ErrorHandlingCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ErrorHandlingCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ErrorHandlingCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ErrorHandlingCodeType
Members
Member | Description
Legacy |
BestEffort |
AllOrNothing |
FailOnError |
Remarks


ErrorLanguageCodeType Enumeration

ErrorLanguageCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ErrorLanguageCodeType
Declaration Syntax
C# Visual Basic Visual C++
public enum ErrorLanguageCodeType
Public Enumeration ErrorLanguageCodeType
public enum class ErrorLanguageCodeType
Members
Member | Description
de_AT |
de_CH |
de_DE |
en_AU |
en_CA |
en_GB |
en_HK |
en_IN |
en_MY |
en_PH |
en_SG |
en_US |
es_ES |
fr_BE |
fr_FR |
it_IT |
nl_BE |
nl_NL |
zh_CN |
zh_TW |
CustomCode |


ErrorParameterType Class

ErrorParameterType Class
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ErrorParameterType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ErrorParameterType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ErrorParameterType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorParameterType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParamID |
 | ToString()()()() | (Inherited from Object.)
 | Value |
Remarks
Inheritance Hierarchy
Object
ErrorParameterType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ErrorParameterType Constructor

ErrorParameterType Constructor
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterType ► ErrorParameterType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ErrorParameterType()
Public Sub New
public:
ErrorParameterType()


ParamID Property

ParamID Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterType ► ParamID
Declaration Syntax
C# Visual Basic Visual C++
public string ParamID { get; set; }
Public Property ParamID As String
    Get
    Set
public:
property String^ ParamID {
    String^ get ();
    void set (String^ value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


ErrorParameterTypeCollection Class

ErrorParameterTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ErrorParameterTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ErrorParameterTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ErrorParameterTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorParameterTypeCollection()()()() |
 | ErrorParameterTypeCollection(array<ErrorParameterType>[]()[][]) |
 | ErrorParameterTypeCollection(ErrorParameterTypeCollection) |
 | Add(ErrorParameterType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ErrorParameterType>[]()[][]) |
 | AddRange(ErrorParameterTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ErrorParameterType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ErrorParameterType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ErrorParameterType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ErrorParameterType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ErrorParameterType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ErrorParameterTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► Add(ErrorParameterType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ErrorParameterType item
)
Public Function Add ( _
    item As ErrorParameterType _
) As Integer
public:
int Add(
    ErrorParameterType^ item
)
Parameters
item (ErrorParameterType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ErrorParameterType>[]()[][]) |
 | AddRange(ErrorParameterTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► AddRange(array<ErrorParameterType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ErrorParameterType[] items
)
Public Sub AddRange ( _
    items As ErrorParameterType() _
)
public:
void AddRange(
    array<ErrorParameterType^>^ items
)
Parameters
items (array< ErrorParameterType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► AddRange(ErrorParameterTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ErrorParameterTypeCollection items
)
Public Sub AddRange ( _
    items As ErrorParameterTypeCollection _
)
public:
void AddRange(
    ErrorParameterTypeCollection^ items
)
Parameters
items (ErrorParameterTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► Contains(ErrorParameterType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ErrorParameterType item
)
Public Function Contains ( _
    item As ErrorParameterType _
) As Boolean
public:
bool Contains(
    ErrorParameterType^ item
)
Parameters
item (ErrorParameterType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► CopyTo(array<ErrorParameterType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ErrorParameterType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ErrorParameterType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ErrorParameterType^>^ items,
    int index
)
Parameters
items (array< ErrorParameterType >[]()[][])
index (Int32)


ErrorParameterTypeCollection Constructor

ErrorParameterTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► ErrorParameterTypeCollection()()()()
Members
Icon | Member | Description
 | ErrorParameterTypeCollection()()()() |
 | ErrorParameterTypeCollection(array<ErrorParameterType>[]()[][]) |
 | ErrorParameterTypeCollection(ErrorParameterTypeCollection) |


ErrorParameterTypeCollection Constructor

ErrorParameterTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► ErrorParameterTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ErrorParameterTypeCollection()
Public Sub New
public:
ErrorParameterTypeCollection()


ErrorParameterTypeCollection Constructor (items)

ErrorParameterTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► ErrorParameterTypeCollection(array<ErrorParameterType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ErrorParameterTypeCollection(
    ErrorParameterType[] items
)
Public Sub New ( _
    items As ErrorParameterType() _
)
public:
ErrorParameterTypeCollection(
    array<ErrorParameterType^>^ items
)
Parameters
items (array< ErrorParameterType >[]()[][])


ErrorParameterTypeCollection Constructor (items)

ErrorParameterTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► ErrorParameterTypeCollection(ErrorParameterTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ErrorParameterTypeCollection(
    ErrorParameterTypeCollection items
)
Public Sub New ( _
    items As ErrorParameterTypeCollection _
)
public:
ErrorParameterTypeCollection(
    ErrorParameterTypeCollection^ items
)
Parameters
items (ErrorParameterTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► IndexOf(ErrorParameterType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ErrorParameterType item
)
Public Function IndexOf ( _
    item As ErrorParameterType _
) As Integer
public:
int IndexOf(
    ErrorParameterType^ item
)
Parameters
item (ErrorParameterType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► Insert(Int32, ErrorParameterType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ErrorParameterType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ErrorParameterType _
)
public:
void Insert(
    int index,
    ErrorParameterType^ item
)
Parameters
index (Int32)
item (ErrorParameterType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ErrorParameterType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ErrorParameterType
    Get
    Set
public:
property ErrorParameterType^ default[int index] {
    ErrorParameterType^ get (int index);
    void set (int index, ErrorParameterType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ErrorParameterType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ErrorParameterType
public:
ErrorParameterType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► Remove(ErrorParameterType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ErrorParameterType item
)
Public Sub Remove ( _
    item As ErrorParameterType _
)
public:
void Remove(
    ErrorParameterType^ item
)
Parameters
item (ErrorParameterType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ErrorParameterType[] ToArray()
Public Function ToArray As ErrorParameterType()
public:
array<ErrorParameterType^>^ ToArray()
Return Value


ErrorType Class

ErrorType Class
Namespaces ► eBay.Service.Core.Soap ► ErrorType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ErrorType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ErrorType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ErrorType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | ErrorClassification |
 | ErrorClassificationSpecified |
 | ErrorCode |
 | ErrorParameters |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LongMessage |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SeverityCode |
 | SeverityCodeSpecified |
 | ShortMessage |
 | ToString()()()() | (Inherited from Object.)
 | UserDisplayHint |
 | UserDisplayHintSpecified |
Remarks
Inheritance Hierarchy
Object
ErrorType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ErrorClassification Property

ErrorClassification Property
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► ErrorClassification
Declaration Syntax
C# Visual Basic Visual C++
public ErrorClassificationCodeType ErrorClassification { get; set; }
Public Property ErrorClassification As ErrorClassificationCodeType
    Get
    Set
public:
property ErrorClassificationCodeType ErrorClassification {
    ErrorClassificationCodeType get ();
    void set (ErrorClassificationCodeType value);
}


ErrorClassificationSpecified Property

ErrorClassificationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► ErrorClassificationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ErrorClassificationSpecified { get; set; }
Public Property ErrorClassificationSpecified As Boolean
    Get
    Set
public:
property bool ErrorClassificationSpecified {
    bool get ();
    void set (bool value);
}


ErrorCode Property

ErrorCode Property
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► ErrorCode
Declaration Syntax
C# Visual Basic Visual C++
public string ErrorCode { get; set; }
Public Property ErrorCode As String
    Get
    Set
public:
property String^ ErrorCode {
    String^ get ();
    void set (String^ value);
}


ErrorParameters Property

ErrorParameters Property
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► ErrorParameters
Declaration Syntax
C# Visual Basic Visual C++
public ErrorParameterTypeCollection ErrorParameters { get; set; }
Public Property ErrorParameters As ErrorParameterTypeCollection
    Get
    Set
public:
property ErrorParameterTypeCollection^ ErrorParameters {
    ErrorParameterTypeCollection^ get ();
    void set (ErrorParameterTypeCollection^ value);
}


ErrorType Constructor

ErrorType Constructor
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► ErrorType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ErrorType()
Public Sub New
public:
ErrorType()


LongMessage Property

LongMessage Property
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► LongMessage
Declaration Syntax
C# Visual Basic Visual C++
public string LongMessage { get; set; }
Public Property LongMessage As String
    Get
    Set
public:
property String^ LongMessage {
    String^ get ();
    void set (String^ value);
}


SeverityCode Property

SeverityCode Property
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► SeverityCode
Declaration Syntax
C# Visual Basic Visual C++
public SeverityCodeType SeverityCode { get; set; }
Public Property SeverityCode As SeverityCodeType
    Get
    Set
public:
property SeverityCodeType SeverityCode {
    SeverityCodeType get ();
    void set (SeverityCodeType value);
}


SeverityCodeSpecified Property

SeverityCodeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► SeverityCodeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SeverityCodeSpecified { get; set; }
Public Property SeverityCodeSpecified As Boolean
    Get
    Set
public:
property bool SeverityCodeSpecified {
    bool get ();
    void set (bool value);
}


ShortMessage Property

ShortMessage Property
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► ShortMessage
Declaration Syntax
C# Visual Basic Visual C++
public string ShortMessage { get; set; }
Public Property ShortMessage As String
    Get
    Set
public:
property String^ ShortMessage {
    String^ get ();
    void set (String^ value);
}


UserDisplayHint Property

UserDisplayHint Property
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► UserDisplayHint
Declaration Syntax
C# Visual Basic Visual C++
public bool UserDisplayHint { get; set; }
Public Property UserDisplayHint As Boolean
    Get
    Set
public:
property bool UserDisplayHint {
    bool get ();
    void set (bool value);
}


UserDisplayHintSpecified Property

UserDisplayHintSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ErrorType ► UserDisplayHintSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UserDisplayHintSpecified { get; set; }
Public Property UserDisplayHintSpecified As Boolean
    Get
    Set
public:
property bool UserDisplayHintSpecified {
    bool get ();
    void set (bool value);
}


ErrorTypeCollection Class

ErrorTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ErrorTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ErrorTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ErrorTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorTypeCollection()()()() |
 | ErrorTypeCollection(array<ErrorType>[]()[][]) |
 | ErrorTypeCollection(ErrorTypeCollection) |
 | Add(ErrorType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ErrorType>[]()[][]) |
 | AddRange(ErrorTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ErrorType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ErrorType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ErrorType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ErrorType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ErrorType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ErrorTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► Add(ErrorType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ErrorType item
)
Public Function Add ( _
    item As ErrorType _
) As Integer
public:
int Add(
    ErrorType^ item
)
Parameters
item (ErrorType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ErrorType>[]()[][]) |
 | AddRange(ErrorTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► AddRange(array<ErrorType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ErrorType[] items
)
Public Sub AddRange ( _
    items As ErrorType() _
)
public:
void AddRange(
    array<ErrorType^>^ items
)
Parameters
items (array< ErrorType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► AddRange(ErrorTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ErrorTypeCollection items
)
Public Sub AddRange ( _
    items As ErrorTypeCollection _
)
public:
void AddRange(
    ErrorTypeCollection^ items
)
Parameters
items (ErrorTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► Contains(ErrorType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ErrorType item
)
Public Function Contains ( _
    item As ErrorType _
) As Boolean
public:
bool Contains(
    ErrorType^ item
)
Parameters
item (ErrorType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► CopyTo(array<ErrorType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ErrorType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ErrorType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ErrorType^>^ items,
    int index
)
Parameters
items (array< ErrorType >[]()[][])
index (Int32)


ErrorTypeCollection Constructor

ErrorTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► ErrorTypeCollection()()()()
Members
Icon | Member | Description
 | ErrorTypeCollection()()()() |
 | ErrorTypeCollection(array<ErrorType>[]()[][]) |
 | ErrorTypeCollection(ErrorTypeCollection) |


ErrorTypeCollection Constructor

ErrorTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► ErrorTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ErrorTypeCollection()
Public Sub New
public:
ErrorTypeCollection()


ErrorTypeCollection Constructor (items)

ErrorTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► ErrorTypeCollection(array<ErrorType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ErrorTypeCollection(
    ErrorType[] items
)
Public Sub New ( _
    items As ErrorType() _
)
public:
ErrorTypeCollection(
    array<ErrorType^>^ items
)
Parameters
items (array< ErrorType >[]()[][])


ErrorTypeCollection Constructor (items)

ErrorTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► ErrorTypeCollection(ErrorTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ErrorTypeCollection(
    ErrorTypeCollection items
)
Public Sub New ( _
    items As ErrorTypeCollection _
)
public:
ErrorTypeCollection(
    ErrorTypeCollection^ items
)
Parameters
items (ErrorTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► IndexOf(ErrorType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ErrorType item
)
Public Function IndexOf ( _
    item As ErrorType _
) As Integer
public:
int IndexOf(
    ErrorType^ item
)
Parameters
item (ErrorType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► Insert(Int32, ErrorType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ErrorType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ErrorType _
)
public:
void Insert(
    int index,
    ErrorType^ item
)
Parameters
index (Int32)
item (ErrorType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ErrorType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ErrorType
    Get
    Set
public:
property ErrorType^ default[int index] {
    ErrorType^ get (int index);
    void set (int index, ErrorType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ErrorType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ErrorType
public:
ErrorType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► Remove(ErrorType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ErrorType item
)
Public Sub Remove ( _
    item As ErrorType _
)
public:
void Remove(
    ErrorType^ item
)
Parameters
item (ErrorType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ErrorType[] ToArray()
Public Function ToArray As ErrorType()
public:
array<ErrorType^>^ ToArray()
Return Value


ExcludeShippingLocationDetailsType Class

ExcludeShippingLocationDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExcludeShippingLocationDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExcludeShippingLocationDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExcludeShippingLocationDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExcludeShippingLocationDetailsType()()()() |
 | Any |
 | Description |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Location |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Region |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
ExcludeShippingLocationDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


ExcludeShippingLocationDetailsType Constructor

ExcludeShippingLocationDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsType ► ExcludeShippingLocationDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExcludeShippingLocationDetailsType()
Public Sub New
public:
ExcludeShippingLocationDetailsType()


Location Property

Location Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsType ► Location
Declaration Syntax
C# Visual Basic Visual C++
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}


Region Property

Region Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsType ► Region
Declaration Syntax
C# Visual Basic Visual C++
public string Region { get; set; }
Public Property Region As String
    Get
    Set
public:
property String^ Region {
    String^ get ();
    void set (String^ value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


ExcludeShippingLocationDetailsTypeCollection Class

ExcludeShippingLocationDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ExcludeShippingLocationDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ExcludeShippingLocationDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ExcludeShippingLocationDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExcludeShippingLocationDetailsTypeCollection()()()() |
 | ExcludeShippingLocationDetailsTypeCollection(array<ExcludeShippingLocationDetailsType>[]()[][]) |
 | ExcludeShippingLocationDetailsTypeCollection(ExcludeShippingLocationDetailsTypeCollection) |
 | Add(ExcludeShippingLocationDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ExcludeShippingLocationDetailsType>[]()[][]) |
 | AddRange(ExcludeShippingLocationDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ExcludeShippingLocationDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ExcludeShippingLocationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ExcludeShippingLocationDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ExcludeShippingLocationDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ExcludeShippingLocationDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ExcludeShippingLocationDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► Add(ExcludeShippingLocationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ExcludeShippingLocationDetailsType item
)
Public Function Add ( _
    item As ExcludeShippingLocationDetailsType _
) As Integer
public:
int Add(
    ExcludeShippingLocationDetailsType^ item
)
Parameters
item (ExcludeShippingLocationDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ExcludeShippingLocationDetailsType>[]()[][]) |
 | AddRange(ExcludeShippingLocationDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► AddRange(array<ExcludeShippingLocationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ExcludeShippingLocationDetailsType[] items
)
Public Sub AddRange ( _
    items As ExcludeShippingLocationDetailsType() _
)
public:
void AddRange(
    array<ExcludeShippingLocationDetailsType^>^ items
)
Parameters
items (array< ExcludeShippingLocationDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► AddRange(ExcludeShippingLocationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ExcludeShippingLocationDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ExcludeShippingLocationDetailsTypeCollection _
)
public:
void AddRange(
    ExcludeShippingLocationDetailsTypeCollection^ items
)
Parameters
items (ExcludeShippingLocationDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► Contains(ExcludeShippingLocationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ExcludeShippingLocationDetailsType item
)
Public Function Contains ( _
    item As ExcludeShippingLocationDetailsType _
) As Boolean
public:
bool Contains(
    ExcludeShippingLocationDetailsType^ item
)
Parameters
item (ExcludeShippingLocationDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► CopyTo(array<ExcludeShippingLocationDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ExcludeShippingLocationDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ExcludeShippingLocationDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ExcludeShippingLocationDetailsType^>^ items,
    int index
)
Parameters
items (array< ExcludeShippingLocationDetailsType >[]()[][])
index (Int32)


ExcludeShippingLocationDetailsTypeCollection Constructor

ExcludeShippingLocationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► ExcludeShippingLocationDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ExcludeShippingLocationDetailsTypeCollection()()()() |
 | ExcludeShippingLocationDetailsTypeCollection(array<ExcludeShippingLocationDetailsType>[]()[][]) |
 | ExcludeShippingLocationDetailsTypeCollection(ExcludeShippingLocationDetailsTypeCollection) |


ExcludeShippingLocationDetailsTypeCollection Constructor

ExcludeShippingLocationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► ExcludeShippingLocationDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExcludeShippingLocationDetailsTypeCollection()
Public Sub New
public:
ExcludeShippingLocationDetailsTypeCollection()


ExcludeShippingLocationDetailsTypeCollection Constructor (items)

ExcludeShippingLocationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► ExcludeShippingLocationDetailsTypeCollection(array<ExcludeShippingLocationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ExcludeShippingLocationDetailsTypeCollection(
    ExcludeShippingLocationDetailsType[] items
)
Public Sub New ( _
    items As ExcludeShippingLocationDetailsType() _
)
public:
ExcludeShippingLocationDetailsTypeCollection(
    array<ExcludeShippingLocationDetailsType^>^ items
)
Parameters
items (array< ExcludeShippingLocationDetailsType >[]()[][])


ExcludeShippingLocationDetailsTypeCollection Constructor (items)

ExcludeShippingLocationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► ExcludeShippingLocationDetailsTypeCollection(ExcludeShippingLocationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ExcludeShippingLocationDetailsTypeCollection(
    ExcludeShippingLocationDetailsTypeCollection items
)
Public Sub New ( _
    items As ExcludeShippingLocationDetailsTypeCollection _
)
public:
ExcludeShippingLocationDetailsTypeCollection(
    ExcludeShippingLocationDetailsTypeCollection^ items
)
Parameters
items (ExcludeShippingLocationDetailsTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► IndexOf(ExcludeShippingLocationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ExcludeShippingLocationDetailsType item
)
Public Function IndexOf ( _
    item As ExcludeShippingLocationDetailsType _
) As Integer
public:
int IndexOf(
    ExcludeShippingLocationDetailsType^ item
)
Parameters
item (ExcludeShippingLocationDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► Insert(Int32, ExcludeShippingLocationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ExcludeShippingLocationDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ExcludeShippingLocationDetailsType _
)
public:
void Insert(
    int index,
    ExcludeShippingLocationDetailsType^ item
)
Parameters
index (Int32)
item (ExcludeShippingLocationDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ExcludeShippingLocationDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ExcludeShippingLocationDetailsType
    Get
    Set
public:
property ExcludeShippingLocationDetailsType^ default[int index] {
    ExcludeShippingLocationDetailsType^ get (int index);
    void set (int index, ExcludeShippingLocationDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ExcludeShippingLocationDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ExcludeShippingLocationDetailsType
public:
ExcludeShippingLocationDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► Remove(ExcludeShippingLocationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ExcludeShippingLocationDetailsType item
)
Public Sub Remove ( _
    item As ExcludeShippingLocationDetailsType _
)
public:
void Remove(
    ExcludeShippingLocationDetailsType^ item
)
Parameters
item (ExcludeShippingLocationDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExcludeShippingLocationDetailsType[] ToArray()
Public Function ToArray As ExcludeShippingLocationDetailsType()
public:
array<ExcludeShippingLocationDetailsType^>^ ToArray()
Return Value


ExpressConditionRequiredDefinitionType Class

ExpressConditionRequiredDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ExpressConditionRequiredDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExpressConditionRequiredDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExpressConditionRequiredDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExpressConditionRequiredDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExpressConditionRequiredDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ExpressConditionRequiredDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ExpressConditionRequiredDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExpressConditionRequiredDefinitionType Constructor

ExpressConditionRequiredDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExpressConditionRequiredDefinitionType ► ExpressConditionRequiredDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExpressConditionRequiredDefinitionType()
Public Sub New
public:
ExpressConditionRequiredDefinitionType()


ExpressEnabledDefinitionType Class

ExpressEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ExpressEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExpressEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExpressEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExpressEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExpressEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ExpressEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ExpressEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExpressEnabledDefinitionType Constructor

ExpressEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExpressEnabledDefinitionType ► ExpressEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExpressEnabledDefinitionType()
Public Sub New
public:
ExpressEnabledDefinitionType()


ExpressItemRequirementsType Class

ExpressItemRequirementsType Class
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExpressItemRequirementsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExpressItemRequirementsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExpressItemRequirementsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExpressItemRequirementsType()()()() |
 | Any |
 | CombinedShippingDiscount |
 | CombinedShippingDiscountSpecified |
 | DomesticShippingCost |
 | DomesticShippingCostSpecified |
 | EligibleCheckout |
 | EligibleCheckoutSpecified |
 | EligibleItemCondition |
 | EligibleItemConditionSpecified |
 | EligiblePayPalAccount |
 | EligiblePayPalAccountSpecified |
 | EligibleReturnPolicy |
 | EligibleReturnPolicySpecified |
 | Equals(Object) | (Inherited from Object.)
 | ExpressApproved |
 | ExpressApprovedSpecified |
 | ExpressEligibleListingType |
 | ExpressEligibleListingTypeSpecified |
 | ExpressEnabledCategory |
 | ExpressEnabledCategorySpecified |
 | ExpressOptOut |
 | ExpressOptOutSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NoCharity |
 | NoCharitySpecified |
 | NoPreapprovedBidderList |
 | NoPreapprovedBidderListSpecified |
 | PayPalAccountAcceptsUnconfirmedAddress |
 | PayPalAccountAcceptsUnconfirmedAddressSpecified |
 | Picture |
 | PictureSpecified |
 | PriceAboveMinimum |
 | PriceAboveMinimumSpecified |
 | PriceBelowMaximum |
 | PriceBelowMaximumSpecified |
 | SellerExpressEligible |
 | SellerExpressEligibleSpecified |
 | ShipFromEligibleCountry |
 | ShipFromEligibleCountrySpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ExpressItemRequirementsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CombinedShippingDiscount Property

CombinedShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► CombinedShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public bool CombinedShippingDiscount { get; set; }
Public Property CombinedShippingDiscount As Boolean
    Get
    Set
public:
property bool CombinedShippingDiscount {
    bool get ();
    void set (bool value);
}


CombinedShippingDiscountSpecified Property

CombinedShippingDiscountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► CombinedShippingDiscountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CombinedShippingDiscountSpecified { get; set; }
Public Property CombinedShippingDiscountSpecified As Boolean
    Get
    Set
public:
property bool CombinedShippingDiscountSpecified {
    bool get ();
    void set (bool value);
}


DomesticShippingCost Property

DomesticShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► DomesticShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public bool DomesticShippingCost { get; set; }
Public Property DomesticShippingCost As Boolean
    Get
    Set
public:
property bool DomesticShippingCost {
    bool get ();
    void set (bool value);
}


DomesticShippingCostSpecified Property

DomesticShippingCostSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► DomesticShippingCostSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DomesticShippingCostSpecified { get; set; }
Public Property DomesticShippingCostSpecified As Boolean
    Get
    Set
public:
property bool DomesticShippingCostSpecified {
    bool get ();
    void set (bool value);
}


EligibleCheckout Property

EligibleCheckout Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► EligibleCheckout
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleCheckout { get; set; }
Public Property EligibleCheckout As Boolean
    Get
    Set
public:
property bool EligibleCheckout {
    bool get ();
    void set (bool value);
}


EligibleCheckoutSpecified Property

EligibleCheckoutSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► EligibleCheckoutSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleCheckoutSpecified { get; set; }
Public Property EligibleCheckoutSpecified As Boolean
    Get
    Set
public:
property bool EligibleCheckoutSpecified {
    bool get ();
    void set (bool value);
}


EligibleItemCondition Property

EligibleItemCondition Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► EligibleItemCondition
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleItemCondition { get; set; }
Public Property EligibleItemCondition As Boolean
    Get
    Set
public:
property bool EligibleItemCondition {
    bool get ();
    void set (bool value);
}


EligibleItemConditionSpecified Property

EligibleItemConditionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► EligibleItemConditionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleItemConditionSpecified { get; set; }
Public Property EligibleItemConditionSpecified As Boolean
    Get
    Set
public:
property bool EligibleItemConditionSpecified {
    bool get ();
    void set (bool value);
}


EligiblePayPalAccount Property

EligiblePayPalAccount Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► EligiblePayPalAccount
Declaration Syntax
C# Visual Basic Visual C++
public bool EligiblePayPalAccount { get; set; }
Public Property EligiblePayPalAccount As Boolean
    Get
    Set
public:
property bool EligiblePayPalAccount {
    bool get ();
    void set (bool value);
}


EligiblePayPalAccountSpecified Property

EligiblePayPalAccountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► EligiblePayPalAccountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EligiblePayPalAccountSpecified { get; set; }
Public Property EligiblePayPalAccountSpecified As Boolean
    Get
    Set
public:
property bool EligiblePayPalAccountSpecified {
    bool get ();
    void set (bool value);
}


EligibleReturnPolicy Property

EligibleReturnPolicy Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► EligibleReturnPolicy
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleReturnPolicy { get; set; }
Public Property EligibleReturnPolicy As Boolean
    Get
    Set
public:
property bool EligibleReturnPolicy {
    bool get ();
    void set (bool value);
}


EligibleReturnPolicySpecified Property

EligibleReturnPolicySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► EligibleReturnPolicySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleReturnPolicySpecified { get; set; }
Public Property EligibleReturnPolicySpecified As Boolean
    Get
    Set
public:
property bool EligibleReturnPolicySpecified {
    bool get ();
    void set (bool value);
}


ExpressApproved Property

ExpressApproved Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► ExpressApproved
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressApproved { get; set; }
Public Property ExpressApproved As Boolean
    Get
    Set
public:
property bool ExpressApproved {
    bool get ();
    void set (bool value);
}


ExpressApprovedSpecified Property

ExpressApprovedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► ExpressApprovedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressApprovedSpecified { get; set; }
Public Property ExpressApprovedSpecified As Boolean
    Get
    Set
public:
property bool ExpressApprovedSpecified {
    bool get ();
    void set (bool value);
}


ExpressEligibleListingType Property

ExpressEligibleListingType Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► ExpressEligibleListingType
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressEligibleListingType { get; set; }
Public Property ExpressEligibleListingType As Boolean
    Get
    Set
public:
property bool ExpressEligibleListingType {
    bool get ();
    void set (bool value);
}


ExpressEligibleListingTypeSpecified Property

ExpressEligibleListingTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► ExpressEligibleListingTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressEligibleListingTypeSpecified { get; set; }
Public Property ExpressEligibleListingTypeSpecified As Boolean
    Get
    Set
public:
property bool ExpressEligibleListingTypeSpecified {
    bool get ();
    void set (bool value);
}


ExpressEnabledCategory Property

ExpressEnabledCategory Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► ExpressEnabledCategory
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressEnabledCategory { get; set; }
Public Property ExpressEnabledCategory As Boolean
    Get
    Set
public:
property bool ExpressEnabledCategory {
    bool get ();
    void set (bool value);
}


ExpressEnabledCategorySpecified Property

ExpressEnabledCategorySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► ExpressEnabledCategorySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressEnabledCategorySpecified { get; set; }
Public Property ExpressEnabledCategorySpecified As Boolean
    Get
    Set
public:
property bool ExpressEnabledCategorySpecified {
    bool get ();
    void set (bool value);
}


ExpressItemRequirementsType Constructor

ExpressItemRequirementsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► ExpressItemRequirementsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExpressItemRequirementsType()
Public Sub New
public:
ExpressItemRequirementsType()


ExpressOptOut Property

ExpressOptOut Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► ExpressOptOut
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressOptOut { get; set; }
Public Property ExpressOptOut As Boolean
    Get
    Set
public:
property bool ExpressOptOut {
    bool get ();
    void set (bool value);
}


ExpressOptOutSpecified Property

ExpressOptOutSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► ExpressOptOutSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressOptOutSpecified { get; set; }
Public Property ExpressOptOutSpecified As Boolean
    Get
    Set
public:
property bool ExpressOptOutSpecified {
    bool get ();
    void set (bool value);
}


NoCharity Property

NoCharity Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► NoCharity
Declaration Syntax
C# Visual Basic Visual C++
public bool NoCharity { get; set; }
Public Property NoCharity As Boolean
    Get
    Set
public:
property bool NoCharity {
    bool get ();
    void set (bool value);
}


NoCharitySpecified Property

NoCharitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► NoCharitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NoCharitySpecified { get; set; }
Public Property NoCharitySpecified As Boolean
    Get
    Set
public:
property bool NoCharitySpecified {
    bool get ();
    void set (bool value);
}


NoPreapprovedBidderList Property

NoPreapprovedBidderList Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► NoPreapprovedBidderList
Declaration Syntax
C# Visual Basic Visual C++
public bool NoPreapprovedBidderList { get; set; }
Public Property NoPreapprovedBidderList As Boolean
    Get
    Set
public:
property bool NoPreapprovedBidderList {
    bool get ();
    void set (bool value);
}


NoPreapprovedBidderListSpecified Property

NoPreapprovedBidderListSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► NoPreapprovedBidderListSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NoPreapprovedBidderListSpecified { get; set; }
Public Property NoPreapprovedBidderListSpecified As Boolean
    Get
    Set
public:
property bool NoPreapprovedBidderListSpecified {
    bool get ();
    void set (bool value);
}


PayPalAccountAcceptsUnconfirmedAddress Property

PayPalAccountAcceptsUnconfirmedAddress Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► PayPalAccountAcceptsUnconfirmedAddress
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalAccountAcceptsUnconfirmedAddress { get; set; }
Public Property PayPalAccountAcceptsUnconfirmedAddress As Boolean
    Get
    Set
public:
property bool PayPalAccountAcceptsUnconfirmedAddress {
    bool get ();
    void set (bool value);
}


PayPalAccountAcceptsUnconfirmedAddressSpecified Property

PayPalAccountAcceptsUnconfirmedAddressSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► PayPalAccountAcceptsUnconfirmedAddressSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalAccountAcceptsUnconfirmedAddressSpecified { get; set; }
Public Property PayPalAccountAcceptsUnconfirmedAddressSpecified As Boolean
    Get
    Set
public:
property bool PayPalAccountAcceptsUnconfirmedAddressSpecified {
    bool get ();
    void set (bool value);
}


Picture Property

Picture Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► Picture
Declaration Syntax
C# Visual Basic Visual C++
public bool Picture { get; set; }
Public Property Picture As Boolean
    Get
    Set
public:
property bool Picture {
    bool get ();
    void set (bool value);
}


PictureSpecified Property

PictureSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► PictureSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PictureSpecified { get; set; }
Public Property PictureSpecified As Boolean
    Get
    Set
public:
property bool PictureSpecified {
    bool get ();
    void set (bool value);
}


PriceAboveMinimum Property

PriceAboveMinimum Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► PriceAboveMinimum
Declaration Syntax
C# Visual Basic Visual C++
public bool PriceAboveMinimum { get; set; }
Public Property PriceAboveMinimum As Boolean
    Get
    Set
public:
property bool PriceAboveMinimum {
    bool get ();
    void set (bool value);
}


PriceAboveMinimumSpecified Property

PriceAboveMinimumSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► PriceAboveMinimumSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PriceAboveMinimumSpecified { get; set; }
Public Property PriceAboveMinimumSpecified As Boolean
    Get
    Set
public:
property bool PriceAboveMinimumSpecified {
    bool get ();
    void set (bool value);
}


PriceBelowMaximum Property

PriceBelowMaximum Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► PriceBelowMaximum
Declaration Syntax
C# Visual Basic Visual C++
public bool PriceBelowMaximum { get; set; }
Public Property PriceBelowMaximum As Boolean
    Get
    Set
public:
property bool PriceBelowMaximum {
    bool get ();
    void set (bool value);
}


PriceBelowMaximumSpecified Property

PriceBelowMaximumSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► PriceBelowMaximumSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PriceBelowMaximumSpecified { get; set; }
Public Property PriceBelowMaximumSpecified As Boolean
    Get
    Set
public:
property bool PriceBelowMaximumSpecified {
    bool get ();
    void set (bool value);
}


SellerExpressEligible Property

SellerExpressEligible Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► SellerExpressEligible
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerExpressEligible { get; set; }
Public Property SellerExpressEligible As Boolean
    Get
    Set
public:
property bool SellerExpressEligible {
    bool get ();
    void set (bool value);
}


SellerExpressEligibleSpecified Property

SellerExpressEligibleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► SellerExpressEligibleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerExpressEligibleSpecified { get; set; }
Public Property SellerExpressEligibleSpecified As Boolean
    Get
    Set
public:
property bool SellerExpressEligibleSpecified {
    bool get ();
    void set (bool value);
}


ShipFromEligibleCountry Property

ShipFromEligibleCountry Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► ShipFromEligibleCountry
Declaration Syntax
C# Visual Basic Visual C++
public bool ShipFromEligibleCountry { get; set; }
Public Property ShipFromEligibleCountry As Boolean
    Get
    Set
public:
property bool ShipFromEligibleCountry {
    bool get ();
    void set (bool value);
}


ShipFromEligibleCountrySpecified Property

ShipFromEligibleCountrySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExpressItemRequirementsType ► ShipFromEligibleCountrySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShipFromEligibleCountrySpecified { get; set; }
Public Property ShipFromEligibleCountrySpecified As Boolean
    Get
    Set
public:
property bool ShipFromEligibleCountrySpecified {
    bool get ();
    void set (bool value);
}


ExpressPicturesRequiredDefinitionType Class

ExpressPicturesRequiredDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ExpressPicturesRequiredDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExpressPicturesRequiredDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExpressPicturesRequiredDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExpressPicturesRequiredDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExpressPicturesRequiredDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ExpressPicturesRequiredDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ExpressPicturesRequiredDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExpressPicturesRequiredDefinitionType Constructor

ExpressPicturesRequiredDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExpressPicturesRequiredDefinitionType ► ExpressPicturesRequiredDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExpressPicturesRequiredDefinitionType()
Public Sub New
public:
ExpressPicturesRequiredDefinitionType()


ExtendedContactDetailsType Class

ExtendedContactDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ExtendedContactDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExtendedContactDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExtendedContactDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExtendedContactDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExtendedContactDetailsType()()()() |
 | Any |
 | ClassifiedAdContactByEmailEnabled |
 | ClassifiedAdContactByEmailEnabledSpecified |
 | ContactHoursDetails |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PayPerLeadPhoneNumber |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ExtendedContactDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedContactDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ClassifiedAdContactByEmailEnabled Property

ClassifiedAdContactByEmailEnabled Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedContactDetailsType ► ClassifiedAdContactByEmailEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByEmailEnabled { get; set; }
Public Property ClassifiedAdContactByEmailEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByEmailEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByEmailEnabledSpecified Property

ClassifiedAdContactByEmailEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedContactDetailsType ► ClassifiedAdContactByEmailEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByEmailEnabledSpecified { get; set; }
Public Property ClassifiedAdContactByEmailEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByEmailEnabledSpecified {
    bool get ();
    void set (bool value);
}


ContactHoursDetails Property

ContactHoursDetails Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedContactDetailsType ► ContactHoursDetails
Declaration Syntax
C# Visual Basic Visual C++
public ContactHoursDetailsType ContactHoursDetails { get; set; }
Public Property ContactHoursDetails As ContactHoursDetailsType
    Get
    Set
public:
property ContactHoursDetailsType^ ContactHoursDetails {
    ContactHoursDetailsType^ get ();
    void set (ContactHoursDetailsType^ value);
}


ExtendedContactDetailsType Constructor

ExtendedContactDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExtendedContactDetailsType ► ExtendedContactDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedContactDetailsType()
Public Sub New
public:
ExtendedContactDetailsType()


PayPerLeadPhoneNumber Property

PayPerLeadPhoneNumber Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedContactDetailsType ► PayPerLeadPhoneNumber
Declaration Syntax
C# Visual Basic Visual C++
public string PayPerLeadPhoneNumber { get; set; }
Public Property PayPerLeadPhoneNumber As String
    Get
    Set
public:
property String^ PayPerLeadPhoneNumber {
    String^ get ();
    void set (String^ value);
}


ExtendedPictureDetailsType Class

ExtendedPictureDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ExtendedPictureDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExtendedPictureDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExtendedPictureDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExtendedPictureDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExtendedPictureDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PictureURLs |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ExtendedPictureDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedPictureDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExtendedPictureDetailsType Constructor

ExtendedPictureDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExtendedPictureDetailsType ► ExtendedPictureDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedPictureDetailsType()
Public Sub New
public:
ExtendedPictureDetailsType()


PictureURLs Property

PictureURLs Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedPictureDetailsType ► PictureURLs
Declaration Syntax
C# Visual Basic Visual C++
public PictureURLsTypeCollection PictureURLs { get; set; }
Public Property PictureURLs As PictureURLsTypeCollection
    Get
    Set
public:
property PictureURLsTypeCollection^ PictureURLs {
    PictureURLsTypeCollection^ get ();
    void set (PictureURLsTypeCollection^ value);
}


ExtendedProductFinderIDType Class

ExtendedProductFinderIDType Class
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExtendedProductFinderIDType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExtendedProductFinderIDType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExtendedProductFinderIDType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExtendedProductFinderIDType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProductFinderBuySide |
 | ProductFinderBuySideSpecified |
 | ProductFinderID |
 | ProductFinderIDSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ExtendedProductFinderIDType


ExtendedProductFinderIDType Constructor

ExtendedProductFinderIDType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDType ► ExtendedProductFinderIDType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedProductFinderIDType()
Public Sub New
public:
ExtendedProductFinderIDType()


ProductFinderBuySide Property

ProductFinderBuySide Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDType ► ProductFinderBuySide
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductFinderBuySide { get; set; }
Public Property ProductFinderBuySide As Boolean
    Get
    Set
public:
property bool ProductFinderBuySide {
    bool get ();
    void set (bool value);
}


ProductFinderBuySideSpecified Property

ProductFinderBuySideSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDType ► ProductFinderBuySideSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductFinderBuySideSpecified { get; set; }
Public Property ProductFinderBuySideSpecified As Boolean
    Get
    Set
public:
property bool ProductFinderBuySideSpecified {
    bool get ();
    void set (bool value);
}


ProductFinderID Property

ProductFinderID Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDType ► ProductFinderID
Declaration Syntax
C# Visual Basic Visual C++
public int ProductFinderID { get; set; }
Public Property ProductFinderID As Integer
    Get
    Set
public:
property int ProductFinderID {
    int get ();
    void set (int value);
}


ProductFinderIDSpecified Property

ProductFinderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDType ► ProductFinderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductFinderIDSpecified { get; set; }
Public Property ProductFinderIDSpecified As Boolean
    Get
    Set
public:
property bool ProductFinderIDSpecified {
    bool get ();
    void set (bool value);
}


ExtendedProductFinderIDTypeCollection Class

ExtendedProductFinderIDTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ExtendedProductFinderIDTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ExtendedProductFinderIDTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ExtendedProductFinderIDTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExtendedProductFinderIDTypeCollection()()()() |
 | ExtendedProductFinderIDTypeCollection(array<ExtendedProductFinderIDType>[]()[][]) |
 | ExtendedProductFinderIDTypeCollection(ExtendedProductFinderIDTypeCollection) |
 | Add(ExtendedProductFinderIDType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ExtendedProductFinderIDType>[]()[][]) |
 | AddRange(ExtendedProductFinderIDTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ExtendedProductFinderIDType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ExtendedProductFinderIDType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ExtendedProductFinderIDType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ExtendedProductFinderIDType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ExtendedProductFinderIDType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ExtendedProductFinderIDTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► Add(ExtendedProductFinderIDType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ExtendedProductFinderIDType item
)
Public Function Add ( _
    item As ExtendedProductFinderIDType _
) As Integer
public:
int Add(
    ExtendedProductFinderIDType^ item
)
Parameters
item (ExtendedProductFinderIDType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ExtendedProductFinderIDType>[]()[][]) |
 | AddRange(ExtendedProductFinderIDTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► AddRange(array<ExtendedProductFinderIDType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ExtendedProductFinderIDType[] items
)
Public Sub AddRange ( _
    items As ExtendedProductFinderIDType() _
)
public:
void AddRange(
    array<ExtendedProductFinderIDType^>^ items
)
Parameters
items (array< ExtendedProductFinderIDType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► AddRange(ExtendedProductFinderIDTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ExtendedProductFinderIDTypeCollection items
)
Public Sub AddRange ( _
    items As ExtendedProductFinderIDTypeCollection _
)
public:
void AddRange(
    ExtendedProductFinderIDTypeCollection^ items
)
Parameters
items (ExtendedProductFinderIDTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► Contains(ExtendedProductFinderIDType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ExtendedProductFinderIDType item
)
Public Function Contains ( _
    item As ExtendedProductFinderIDType _
) As Boolean
public:
bool Contains(
    ExtendedProductFinderIDType^ item
)
Parameters
item (ExtendedProductFinderIDType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► CopyTo(array<ExtendedProductFinderIDType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ExtendedProductFinderIDType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ExtendedProductFinderIDType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ExtendedProductFinderIDType^>^ items,
    int index
)
Parameters
items (array< ExtendedProductFinderIDType >[]()[][])
index (Int32)


ExtendedProductFinderIDTypeCollection Constructor

ExtendedProductFinderIDTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► ExtendedProductFinderIDTypeCollection()()()()
Members
Icon | Member | Description
 | ExtendedProductFinderIDTypeCollection()()()() |
 | ExtendedProductFinderIDTypeCollection(array<ExtendedProductFinderIDType>[]()[][]) |
 | ExtendedProductFinderIDTypeCollection(ExtendedProductFinderIDTypeCollection) |


ExtendedProductFinderIDTypeCollection Constructor

ExtendedProductFinderIDTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► ExtendedProductFinderIDTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedProductFinderIDTypeCollection()
Public Sub New
public:
ExtendedProductFinderIDTypeCollection()


ExtendedProductFinderIDTypeCollection Constructor (items)

ExtendedProductFinderIDTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► ExtendedProductFinderIDTypeCollection(array<ExtendedProductFinderIDType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedProductFinderIDTypeCollection(
    ExtendedProductFinderIDType[] items
)
Public Sub New ( _
    items As ExtendedProductFinderIDType() _
)
public:
ExtendedProductFinderIDTypeCollection(
    array<ExtendedProductFinderIDType^>^ items
)
Parameters
items (array< ExtendedProductFinderIDType >[]()[][])


ExtendedProductFinderIDTypeCollection Constructor (items)

ExtendedProductFinderIDTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► ExtendedProductFinderIDTypeCollection(ExtendedProductFinderIDTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedProductFinderIDTypeCollection(
    ExtendedProductFinderIDTypeCollection items
)
Public Sub New ( _
    items As ExtendedProductFinderIDTypeCollection _
)
public:
ExtendedProductFinderIDTypeCollection(
    ExtendedProductFinderIDTypeCollection^ items
)
Parameters
items (ExtendedProductFinderIDTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► IndexOf(ExtendedProductFinderIDType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ExtendedProductFinderIDType item
)
Public Function IndexOf ( _
    item As ExtendedProductFinderIDType _
) As Integer
public:
int IndexOf(
    ExtendedProductFinderIDType^ item
)
Parameters
item (ExtendedProductFinderIDType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► Insert(Int32, ExtendedProductFinderIDType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ExtendedProductFinderIDType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ExtendedProductFinderIDType _
)
public:
void Insert(
    int index,
    ExtendedProductFinderIDType^ item
)
Parameters
index (Int32)
item (ExtendedProductFinderIDType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedProductFinderIDType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ExtendedProductFinderIDType
    Get
    Set
public:
property ExtendedProductFinderIDType^ default[int index] {
    ExtendedProductFinderIDType^ get (int index);
    void set (int index, ExtendedProductFinderIDType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedProductFinderIDType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ExtendedProductFinderIDType
public:
ExtendedProductFinderIDType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► Remove(ExtendedProductFinderIDType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ExtendedProductFinderIDType item
)
Public Sub Remove ( _
    item As ExtendedProductFinderIDType _
)
public:
void Remove(
    ExtendedProductFinderIDType^ item
)
Parameters
item (ExtendedProductFinderIDType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedProductFinderIDType[] ToArray()
Public Function ToArray As ExtendedProductFinderIDType()
public:
array<ExtendedProductFinderIDType^>^ ToArray()
Return Value


ExtendSiteHostedPicturesRequestType Class

ExtendSiteHostedPicturesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ExtendSiteHostedPicturesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExtendSiteHostedPicturesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExtendSiteHostedPicturesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExtendSiteHostedPicturesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExtendSiteHostedPicturesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | ExtensionInDays |
 | ExtensionInDaysSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | PictureURL |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ExtendSiteHostedPicturesRequestType


ExtendSiteHostedPicturesRequestType Constructor

ExtendSiteHostedPicturesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExtendSiteHostedPicturesRequestType ► ExtendSiteHostedPicturesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExtendSiteHostedPicturesRequestType()
Public Sub New
public:
ExtendSiteHostedPicturesRequestType()


ExtensionInDays Property

ExtensionInDays Property
Namespaces ► eBay.Service.Core.Soap ► ExtendSiteHostedPicturesRequestType ► ExtensionInDays
Declaration Syntax
C# Visual Basic Visual C++
public int ExtensionInDays { get; set; }
Public Property ExtensionInDays As Integer
    Get
    Set
public:
property int ExtensionInDays {
    int get ();
    void set (int value);
}


ExtensionInDaysSpecified Property

ExtensionInDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExtendSiteHostedPicturesRequestType ► ExtensionInDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExtensionInDaysSpecified { get; set; }
Public Property ExtensionInDaysSpecified As Boolean
    Get
    Set
public:
property bool ExtensionInDaysSpecified {
    bool get ();
    void set (bool value);
}


PictureURL Property

PictureURL Property
Namespaces ► eBay.Service.Core.Soap ► ExtendSiteHostedPicturesRequestType ► PictureURL
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureURL { get; set; }
Public Property PictureURL As StringCollection
    Get
    Set
public:
property StringCollection^ PictureURL {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ExtendSiteHostedPicturesResponseType Class

ExtendSiteHostedPicturesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ExtendSiteHostedPicturesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExtendSiteHostedPicturesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExtendSiteHostedPicturesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExtendSiteHostedPicturesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExtendSiteHostedPicturesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PictureURL |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ExtendSiteHostedPicturesResponseType


ExtendSiteHostedPicturesResponseType Constructor

ExtendSiteHostedPicturesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExtendSiteHostedPicturesResponseType ► ExtendSiteHostedPicturesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExtendSiteHostedPicturesResponseType()
Public Sub New
public:
ExtendSiteHostedPicturesResponseType()


PictureURL Property

PictureURL Property
Namespaces ► eBay.Service.Core.Soap ► ExtendSiteHostedPicturesResponseType ► PictureURL
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureURL { get; set; }
Public Property PictureURL As StringCollection
    Get
    Set
public:
property StringCollection^ PictureURL {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ExternalProductCodeType Enumeration

ExternalProductCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ExternalProductCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ExternalProductCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ExternalProductCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ExternalProductCodeType
Members
Member | Description
ISBN |
UPC |
ProductID |
EAN |
Keywords |
MPN |
CustomCode |
Remarks


ExternalProductIDType Class

ExternalProductIDType Class
Namespaces ► eBay.Service.Core.Soap ► ExternalProductIDType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExternalProductIDType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExternalProductIDType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExternalProductIDType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExternalProductIDType()()()() |
 | AlternateValue |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReturnSearchResultOnDuplicates |
 | ReturnSearchResultOnDuplicatesSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | TypeSpecified |
 | Value |
Remarks
Inheritance Hierarchy
Object
ExternalProductIDType


AlternateValue Property

AlternateValue Property
Namespaces ► eBay.Service.Core.Soap ► ExternalProductIDType ► AlternateValue
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection AlternateValue { get; set; }
Public Property AlternateValue As StringCollection
    Get
    Set
public:
property StringCollection^ AlternateValue {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ExternalProductIDType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExternalProductIDType Constructor

ExternalProductIDType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExternalProductIDType ► ExternalProductIDType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExternalProductIDType()
Public Sub New
public:
ExternalProductIDType()


ReturnSearchResultOnDuplicates Property

ReturnSearchResultOnDuplicates Property
Namespaces ► eBay.Service.Core.Soap ► ExternalProductIDType ► ReturnSearchResultOnDuplicates
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnSearchResultOnDuplicates { get; set; }
Public Property ReturnSearchResultOnDuplicates As Boolean
    Get
    Set
public:
property bool ReturnSearchResultOnDuplicates {
    bool get ();
    void set (bool value);
}


ReturnSearchResultOnDuplicatesSpecified Property

ReturnSearchResultOnDuplicatesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExternalProductIDType ► ReturnSearchResultOnDuplicatesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnSearchResultOnDuplicatesSpecified { get; set; }
Public Property ReturnSearchResultOnDuplicatesSpecified As Boolean
    Get
    Set
public:
property bool ReturnSearchResultOnDuplicatesSpecified {
    bool get ();
    void set (bool value);
}


Type Property

Type Property
Namespaces ► eBay.Service.Core.Soap ► ExternalProductIDType ► Type
Declaration Syntax
C# Visual Basic Visual C++
public ExternalProductCodeType Type { get; set; }
Public Property Type As ExternalProductCodeType
    Get
    Set
public:
property ExternalProductCodeType Type {
    ExternalProductCodeType get ();
    void set (ExternalProductCodeType value);
}


TypeSpecified Property

TypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExternalProductIDType ► TypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TypeSpecified { get; set; }
Public Property TypeSpecified As Boolean
    Get
    Set
public:
property bool TypeSpecified {
    bool get ();
    void set (bool value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► ExternalProductIDType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


ExternalTransactionType Class

ExternalTransactionType Class
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ExternalTransactionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ExternalTransactionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ExternalTransactionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExternalTransactionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | ExternalTransactionID |
 | ExternalTransactionStatus |
 | ExternalTransactionStatusSpecified |
 | ExternalTransactionTime |
 | ExternalTransactionTimeSpecified |
 | FeeOrCreditAmount |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PaymentOrRefundAmount |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ExternalTransactionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExternalTransactionID Property

ExternalTransactionID Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionType ► ExternalTransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalTransactionID { get; set; }
Public Property ExternalTransactionID As String
    Get
    Set
public:
property String^ ExternalTransactionID {
    String^ get ();
    void set (String^ value);
}


ExternalTransactionStatus Property

ExternalTransactionStatus Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionType ► ExternalTransactionStatus
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTransactionStatusCodeType ExternalTransactionStatus { get; set; }
Public Property ExternalTransactionStatus As PaymentTransactionStatusCodeType
    Get
    Set
public:
property PaymentTransactionStatusCodeType ExternalTransactionStatus {
    PaymentTransactionStatusCodeType get ();
    void set (PaymentTransactionStatusCodeType value);
}


ExternalTransactionStatusSpecified Property

ExternalTransactionStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionType ► ExternalTransactionStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExternalTransactionStatusSpecified { get; set; }
Public Property ExternalTransactionStatusSpecified As Boolean
    Get
    Set
public:
property bool ExternalTransactionStatusSpecified {
    bool get ();
    void set (bool value);
}


ExternalTransactionTime Property

ExternalTransactionTime Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionType ► ExternalTransactionTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ExternalTransactionTime { get; set; }
Public Property ExternalTransactionTime As DateTime
    Get
    Set
public:
property DateTime ExternalTransactionTime {
    DateTime get ();
    void set (DateTime value);
}


ExternalTransactionTimeSpecified Property

ExternalTransactionTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionType ► ExternalTransactionTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExternalTransactionTimeSpecified { get; set; }
Public Property ExternalTransactionTimeSpecified As Boolean
    Get
    Set
public:
property bool ExternalTransactionTimeSpecified {
    bool get ();
    void set (bool value);
}


ExternalTransactionType Constructor

ExternalTransactionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionType ► ExternalTransactionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExternalTransactionType()
Public Sub New
public:
ExternalTransactionType()


FeeOrCreditAmount Property

FeeOrCreditAmount Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionType ► FeeOrCreditAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType FeeOrCreditAmount { get; set; }
Public Property FeeOrCreditAmount As AmountType
    Get
    Set
public:
property AmountType^ FeeOrCreditAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


PaymentOrRefundAmount Property

PaymentOrRefundAmount Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionType ► PaymentOrRefundAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType PaymentOrRefundAmount { get; set; }
Public Property PaymentOrRefundAmount As AmountType
    Get
    Set
public:
property AmountType^ PaymentOrRefundAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


ExternalTransactionTypeCollection Class

ExternalTransactionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ExternalTransactionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ExternalTransactionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ExternalTransactionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExternalTransactionTypeCollection()()()() |
 | ExternalTransactionTypeCollection(array<ExternalTransactionType>[]()[][]) |
 | ExternalTransactionTypeCollection(ExternalTransactionTypeCollection) |
 | Add(ExternalTransactionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ExternalTransactionType>[]()[][]) |
 | AddRange(ExternalTransactionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ExternalTransactionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ExternalTransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ExternalTransactionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ExternalTransactionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ExternalTransactionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ExternalTransactionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► Add(ExternalTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ExternalTransactionType item
)
Public Function Add ( _
    item As ExternalTransactionType _
) As Integer
public:
int Add(
    ExternalTransactionType^ item
)
Parameters
item (ExternalTransactionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ExternalTransactionType>[]()[][]) |
 | AddRange(ExternalTransactionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► AddRange(array<ExternalTransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ExternalTransactionType[] items
)
Public Sub AddRange ( _
    items As ExternalTransactionType() _
)
public:
void AddRange(
    array<ExternalTransactionType^>^ items
)
Parameters
items (array< ExternalTransactionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► AddRange(ExternalTransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ExternalTransactionTypeCollection items
)
Public Sub AddRange ( _
    items As ExternalTransactionTypeCollection _
)
public:
void AddRange(
    ExternalTransactionTypeCollection^ items
)
Parameters
items (ExternalTransactionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► Contains(ExternalTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ExternalTransactionType item
)
Public Function Contains ( _
    item As ExternalTransactionType _
) As Boolean
public:
bool Contains(
    ExternalTransactionType^ item
)
Parameters
item (ExternalTransactionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► CopyTo(array<ExternalTransactionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ExternalTransactionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ExternalTransactionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ExternalTransactionType^>^ items,
    int index
)
Parameters
items (array< ExternalTransactionType >[]()[][])
index (Int32)


ExternalTransactionTypeCollection Constructor

ExternalTransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► ExternalTransactionTypeCollection()()()()
Members
Icon | Member | Description
 | ExternalTransactionTypeCollection()()()() |
 | ExternalTransactionTypeCollection(array<ExternalTransactionType>[]()[][]) |
 | ExternalTransactionTypeCollection(ExternalTransactionTypeCollection) |


ExternalTransactionTypeCollection Constructor

ExternalTransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► ExternalTransactionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExternalTransactionTypeCollection()
Public Sub New
public:
ExternalTransactionTypeCollection()


ExternalTransactionTypeCollection Constructor (items)

ExternalTransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► ExternalTransactionTypeCollection(array<ExternalTransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ExternalTransactionTypeCollection(
    ExternalTransactionType[] items
)
Public Sub New ( _
    items As ExternalTransactionType() _
)
public:
ExternalTransactionTypeCollection(
    array<ExternalTransactionType^>^ items
)
Parameters
items (array< ExternalTransactionType >[]()[][])


ExternalTransactionTypeCollection Constructor (items)

ExternalTransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► ExternalTransactionTypeCollection(ExternalTransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ExternalTransactionTypeCollection(
    ExternalTransactionTypeCollection items
)
Public Sub New ( _
    items As ExternalTransactionTypeCollection _
)
public:
ExternalTransactionTypeCollection(
    ExternalTransactionTypeCollection^ items
)
Parameters
items (ExternalTransactionTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► IndexOf(ExternalTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ExternalTransactionType item
)
Public Function IndexOf ( _
    item As ExternalTransactionType _
) As Integer
public:
int IndexOf(
    ExternalTransactionType^ item
)
Parameters
item (ExternalTransactionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► Insert(Int32, ExternalTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ExternalTransactionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ExternalTransactionType _
)
public:
void Insert(
    int index,
    ExternalTransactionType^ item
)
Parameters
index (Int32)
item (ExternalTransactionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ExternalTransactionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ExternalTransactionType
    Get
    Set
public:
property ExternalTransactionType^ default[int index] {
    ExternalTransactionType^ get (int index);
    void set (int index, ExternalTransactionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ExternalTransactionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ExternalTransactionType
public:
ExternalTransactionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► Remove(ExternalTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ExternalTransactionType item
)
Public Sub Remove ( _
    item As ExternalTransactionType _
)
public:
void Remove(
    ExternalTransactionType^ item
)
Parameters
item (ExternalTransactionType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ExternalTransactionType[] ToArray()
Public Function ToArray As ExternalTransactionType()
public:
array<ExternalTransactionType^>^ ToArray()
Return Value


FeatureDefinitionsType Class

FeatureDefinitionsType Class
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FeatureDefinitionsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FeatureDefinitionsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FeatureDefinitionsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeatureDefinitionsType()()()() |
 | AdditionalCompatibilityEnabled |
 | AdFormatEnabled |
 | Any |
 | AttributeConversionEnabled |
 | BasicUpgradePackEnabled |
 | BestOfferAutoAcceptEnabled |
 | BestOfferAutoDeclineEnabled |
 | BestOfferCounterEnabled |
 | BestOfferEnabled |
 | BrandMPNIdentifierEnabled |
 | BuyerGuaranteeEnabled |
 | ClassifiedAdAutoAcceptEnabled |
 | ClassifiedAdAutoDeclineEnabled |
 | ClassifiedAdBestOfferEnabled |
 | ClassifiedAdCompanyNameEnabled |
 | ClassifiedAdContactByAddressEnabled |
 | ClassifiedAdContactByEmailEnabled |
 | ClassifiedAdContactByPhoneEnabled |
 | ClassifiedAdCounterOfferEnabled |
 | ClassifiedAdPaymentMethodEnabled |
 | ClassifiedAdPayPerLeadEnabled |
 | ClassifiedAdPhoneCount |
 | ClassifiedAdShippingMethodEnabled |
 | ClassifiedAdStreetCount |
 | CombinedFixedPriceTreatmentEnabled |
 | CompatibleVehicleType |
 | ConditionEnabled |
 | ConditionValues |
 | CrossBorderTradeAustraliaEnabled |
 | CrossBorderTradeGBEnabled |
 | CrossBorderTradeNorthAmericaEnabled |
 | DepositSupported |
 | DigitalGoodDeliveryEnabled |
 | DutchBINEnabled |
 | EANEnabled |
 | EANIdentifierEnabled |
 | eBayMotorsProAdFormatEnabled |
 | eBayMotorsProAutoAcceptEnabled |
 | eBayMotorsProAutoDeclineEnabled |
 | eBayMotorsProBestOfferEnabled |
 | eBayMotorsProCompanyNameEnabled |
 | eBayMotorsProContactByAddressEnabled |
 | eBayMotorsProContactByEmailEnabled |
 | eBayMotorsProContactByPhoneEnabled |
 | eBayMotorsProCounterOfferEnabled |
 | eBayMotorsProPaymentMethodCheckOutEnabled |
 | eBayMotorsProPhoneCount |
 | eBayMotorsProSellerContactDetailsEnabled |
 | eBayMotorsProShippingMethodEnabled |
 | eBayMotorsProStreetCount |
 | EpidSupported |
 | Equals(Object) | (Inherited from Object.)
 | ExpressConditionRequired |
 | ExpressEnabled |
 | ExpressPicturesRequired |
 | Finalize()()()() | (Inherited from Object.)
 | FreeGalleryPlusEnabled |
 | FreePicturePackEnabled |
 | GalleryFeaturedDurations |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalShippingEnabled |
 | Group1MaxFlatShippingCost |
 | Group2MaxFlatShippingCost |
 | Group3MaxFlatShippingCost |
 | HandlingTimeEnabled |
 | HomePageFeaturedEnabled |
 | INEscrowWorkflowTimeline |
 | ISBNEnabled |
 | ISBNIdentifierEnabled |
 | ItemCompatibilityEnabled |
 | ItemSpecificsEnabled |
 | KTypeSupported |
 | ListingDurations |
 | LocalListingDistancesNonSubscription |
 | LocalListingDistancesRegular |
 | LocalListingDistancesSpecialty |
 | LocalMarketAdFormatEnabled |
 | LocalMarketAutoAcceptEnabled |
 | LocalMarketAutoDeclineEnabled |
 | LocalMarketBestOfferEnabled |
 | LocalMarketCompanyNameEnabled |
 | LocalMarketContactByAddressEnabled |
 | LocalMarketContactByEmailEnabled |
 | LocalMarketContactByPhoneEnabled |
 | LocalMarketCounterOfferEnabled |
 | LocalMarketNonSubscription |
 | LocalMarketPaymentMethodCheckOutEnabled |
 | LocalMarketPhoneCount |
 | LocalMarketPremiumSubscription |
 | LocalMarketRegularSubscription |
 | LocalMarketSellerContactDetailsEnabled |
 | LocalMarketShippingMethodEnabled |
 | LocalMarketSpecialitySubscription |
 | LocalMarketStreetCount |
 | MaxFlatShippingCost |
 | MaxFlatShippingCostCBTExempt |
 | MaxGranularFitmentCount |
 | MaxItemCompatibility |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumReservePrice |
 | MinItemCompatibility |
 | NonSubscription |
 | PaisaPayFullEscrowEnabled |
 | PaymentMethod |
 | PaymentOptionsGroup |
 | PaymentProfileCategoryGroup |
 | PayPalBuyerProtectionEnabled |
 | PayPalRequired |
 | PayPalRequiredForStoreOwner |
 | PickupDropOffEnabled |
 | PremiumSubscription |
 | ProductCreationEnabled |
 | ProPackEnabled |
 | ProPackPlusEnabled |
 | RegularSubscription |
 | ReturnPolicyEnabled |
 | ReturnPolicyProfileCategoryGroup |
 | RevisePriceAllowed |
 | ReviseQuantityAllowed |
 | SafePaymentRequired |
 | SellerContactDetailsEnabled |
 | SellerProvidedTitleSupported |
 | ShippingProfileCategoryGroup |
 | ShippingTermsRequired |
 | SkypeMeNonTransactionalEnabled |
 | SkypeMeTransactionalEnabled |
 | SpecialitySubscription |
 | StoreInventoryEnabled |
 | StoreOwnerExtendedListingDurations |
 | StoreOwnerExtendedListingDurationsEnabled |
 | ToString()()()() | (Inherited from Object.)
 | TransactionConfirmationRequestEnabled |
 | UPCEnabled |
 | UPCIdentifierEnabled |
 | UserConsentRequired |
 | ValueCategory |
 | ValuePackEnabled |
 | VariationsEnabled |
 | VINSupported |
 | VRMSupported |
Remarks
Inheritance Hierarchy
Object
FeatureDefinitionsType


AdditionalCompatibilityEnabled Property

AdditionalCompatibilityEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► AdditionalCompatibilityEnabled
Declaration Syntax
C# Visual Basic Visual C++
public AdditionalCompatibilityEnabledDefinitionType AdditionalCompatibilityEnabled { get; set; }
Public Property AdditionalCompatibilityEnabled As AdditionalCompatibilityEnabledDefinitionType
    Get
    Set
public:
property AdditionalCompatibilityEnabledDefinitionType^ AdditionalCompatibilityEnabled {
    AdditionalCompatibilityEnabledDefinitionType^ get ();
    void set (AdditionalCompatibilityEnabledDefinitionType^ value);
}


AdFormatEnabled Property

AdFormatEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► AdFormatEnabled
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatEnabledDefinitionType AdFormatEnabled { get; set; }
Public Property AdFormatEnabled As AdFormatEnabledDefinitionType
    Get
    Set
public:
property AdFormatEnabledDefinitionType^ AdFormatEnabled {
    AdFormatEnabledDefinitionType^ get ();
    void set (AdFormatEnabledDefinitionType^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AttributeConversionEnabled Property

AttributeConversionEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► AttributeConversionEnabled
Declaration Syntax
C# Visual Basic Visual C++
public AttributeConversionEnabledFeatureDefinitionType AttributeConversionEnabled { get; set; }
Public Property AttributeConversionEnabled As AttributeConversionEnabledFeatureDefinitionType
    Get
    Set
public:
property AttributeConversionEnabledFeatureDefinitionType^ AttributeConversionEnabled {
    AttributeConversionEnabledFeatureDefinitionType^ get ();
    void set (AttributeConversionEnabledFeatureDefinitionType^ value);
}


BasicUpgradePackEnabled Property

BasicUpgradePackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► BasicUpgradePackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public BasicUpgradePackEnabledDefinitionType BasicUpgradePackEnabled { get; set; }
Public Property BasicUpgradePackEnabled As BasicUpgradePackEnabledDefinitionType
    Get
    Set
public:
property BasicUpgradePackEnabledDefinitionType^ BasicUpgradePackEnabled {
    BasicUpgradePackEnabledDefinitionType^ get ();
    void set (BasicUpgradePackEnabledDefinitionType^ value);
}


BestOfferAutoAcceptEnabled Property

BestOfferAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► BestOfferAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferAutoAcceptEnabledDefinitionType BestOfferAutoAcceptEnabled { get; set; }
Public Property BestOfferAutoAcceptEnabled As BestOfferAutoAcceptEnabledDefinitionType
    Get
    Set
public:
property BestOfferAutoAcceptEnabledDefinitionType^ BestOfferAutoAcceptEnabled {
    BestOfferAutoAcceptEnabledDefinitionType^ get ();
    void set (BestOfferAutoAcceptEnabledDefinitionType^ value);
}


BestOfferAutoDeclineEnabled Property

BestOfferAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► BestOfferAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferAutoDeclineEnabledDefinitionType BestOfferAutoDeclineEnabled { get; set; }
Public Property BestOfferAutoDeclineEnabled As BestOfferAutoDeclineEnabledDefinitionType
    Get
    Set
public:
property BestOfferAutoDeclineEnabledDefinitionType^ BestOfferAutoDeclineEnabled {
    BestOfferAutoDeclineEnabledDefinitionType^ get ();
    void set (BestOfferAutoDeclineEnabledDefinitionType^ value);
}


BestOfferCounterEnabled Property

BestOfferCounterEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► BestOfferCounterEnabled
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferCounterEnabledDefinitionType BestOfferCounterEnabled { get; set; }
Public Property BestOfferCounterEnabled As BestOfferCounterEnabledDefinitionType
    Get
    Set
public:
property BestOfferCounterEnabledDefinitionType^ BestOfferCounterEnabled {
    BestOfferCounterEnabledDefinitionType^ get ();
    void set (BestOfferCounterEnabledDefinitionType^ value);
}


BestOfferEnabled Property

BestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► BestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferEnabledDefinitionType BestOfferEnabled { get; set; }
Public Property BestOfferEnabled As BestOfferEnabledDefinitionType
    Get
    Set
public:
property BestOfferEnabledDefinitionType^ BestOfferEnabled {
    BestOfferEnabledDefinitionType^ get ();
    void set (BestOfferEnabledDefinitionType^ value);
}


BrandMPNIdentifierEnabled Property

BrandMPNIdentifierEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► BrandMPNIdentifierEnabled
Declaration Syntax
C# Visual Basic Visual C++
public BrandMPNIdentifierEnabledDefinitionType BrandMPNIdentifierEnabled { get; set; }
Public Property BrandMPNIdentifierEnabled As BrandMPNIdentifierEnabledDefinitionType
    Get
    Set
public:
property BrandMPNIdentifierEnabledDefinitionType^ BrandMPNIdentifierEnabled {
    BrandMPNIdentifierEnabledDefinitionType^ get ();
    void set (BrandMPNIdentifierEnabledDefinitionType^ value);
}


BuyerGuaranteeEnabled Property

BuyerGuaranteeEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► BuyerGuaranteeEnabled
Declaration Syntax
C# Visual Basic Visual C++
public BuyerGuaranteeEnabledDefinitionType BuyerGuaranteeEnabled { get; set; }
Public Property BuyerGuaranteeEnabled As BuyerGuaranteeEnabledDefinitionType
    Get
    Set
public:
property BuyerGuaranteeEnabledDefinitionType^ BuyerGuaranteeEnabled {
    BuyerGuaranteeEnabledDefinitionType^ get ();
    void set (BuyerGuaranteeEnabledDefinitionType^ value);
}


ClassifiedAdAutoAcceptEnabled Property

ClassifiedAdAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdAutoAcceptEnabledDefinitionType ClassifiedAdAutoAcceptEnabled { get; set; }
Public Property ClassifiedAdAutoAcceptEnabled As ClassifiedAdAutoAcceptEnabledDefinitionType
    Get
    Set
public:
property ClassifiedAdAutoAcceptEnabledDefinitionType^ ClassifiedAdAutoAcceptEnabled {
    ClassifiedAdAutoAcceptEnabledDefinitionType^ get ();
    void set (ClassifiedAdAutoAcceptEnabledDefinitionType^ value);
}


ClassifiedAdAutoDeclineEnabled Property

ClassifiedAdAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdAutoDeclineEnabledDefinitionType ClassifiedAdAutoDeclineEnabled { get; set; }
Public Property ClassifiedAdAutoDeclineEnabled As ClassifiedAdAutoDeclineEnabledDefinitionType
    Get
    Set
public:
property ClassifiedAdAutoDeclineEnabledDefinitionType^ ClassifiedAdAutoDeclineEnabled {
    ClassifiedAdAutoDeclineEnabledDefinitionType^ get ();
    void set (ClassifiedAdAutoDeclineEnabledDefinitionType^ value);
}


ClassifiedAdBestOfferEnabled Property

ClassifiedAdBestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdBestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdBestOfferEnabledDefinitionType ClassifiedAdBestOfferEnabled { get; set; }
Public Property ClassifiedAdBestOfferEnabled As ClassifiedAdBestOfferEnabledDefinitionType
    Get
    Set
public:
property ClassifiedAdBestOfferEnabledDefinitionType^ ClassifiedAdBestOfferEnabled {
    ClassifiedAdBestOfferEnabledDefinitionType^ get ();
    void set (ClassifiedAdBestOfferEnabledDefinitionType^ value);
}


ClassifiedAdCompanyNameEnabled Property

ClassifiedAdCompanyNameEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdCompanyNameEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdCompanyNameEnabledDefinitionType ClassifiedAdCompanyNameEnabled { get; set; }
Public Property ClassifiedAdCompanyNameEnabled As ClassifiedAdCompanyNameEnabledDefinitionType
    Get
    Set
public:
property ClassifiedAdCompanyNameEnabledDefinitionType^ ClassifiedAdCompanyNameEnabled {
    ClassifiedAdCompanyNameEnabledDefinitionType^ get ();
    void set (ClassifiedAdCompanyNameEnabledDefinitionType^ value);
}


ClassifiedAdContactByAddressEnabled Property

ClassifiedAdContactByAddressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdContactByAddressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdContactByAddressEnabledDefinitionType ClassifiedAdContactByAddressEnabled { get; set; }
Public Property ClassifiedAdContactByAddressEnabled As ClassifiedAdContactByAddressEnabledDefinitionType
    Get
    Set
public:
property ClassifiedAdContactByAddressEnabledDefinitionType^ ClassifiedAdContactByAddressEnabled {
    ClassifiedAdContactByAddressEnabledDefinitionType^ get ();
    void set (ClassifiedAdContactByAddressEnabledDefinitionType^ value);
}


ClassifiedAdContactByEmailEnabled Property

ClassifiedAdContactByEmailEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdContactByEmailEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdContactByEmailEnabledDefintionType ClassifiedAdContactByEmailEnabled { get; set; }
Public Property ClassifiedAdContactByEmailEnabled As ClassifiedAdContactByEmailEnabledDefintionType
    Get
    Set
public:
property ClassifiedAdContactByEmailEnabledDefintionType^ ClassifiedAdContactByEmailEnabled {
    ClassifiedAdContactByEmailEnabledDefintionType^ get ();
    void set (ClassifiedAdContactByEmailEnabledDefintionType^ value);
}


ClassifiedAdContactByPhoneEnabled Property

ClassifiedAdContactByPhoneEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdContactByPhoneEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdContactByPhoneEnabledDefinitionType ClassifiedAdContactByPhoneEnabled { get; set; }
Public Property ClassifiedAdContactByPhoneEnabled As ClassifiedAdContactByPhoneEnabledDefinitionType
    Get
    Set
public:
property ClassifiedAdContactByPhoneEnabledDefinitionType^ ClassifiedAdContactByPhoneEnabled {
    ClassifiedAdContactByPhoneEnabledDefinitionType^ get ();
    void set (ClassifiedAdContactByPhoneEnabledDefinitionType^ value);
}


ClassifiedAdCounterOfferEnabled Property

ClassifiedAdCounterOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdCounterOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdCounterOfferEnabledDefinitionType ClassifiedAdCounterOfferEnabled { get; set; }
Public Property ClassifiedAdCounterOfferEnabled As ClassifiedAdCounterOfferEnabledDefinitionType
    Get
    Set
public:
property ClassifiedAdCounterOfferEnabledDefinitionType^ ClassifiedAdCounterOfferEnabled {
    ClassifiedAdCounterOfferEnabledDefinitionType^ get ();
    void set (ClassifiedAdCounterOfferEnabledDefinitionType^ value);
}


ClassifiedAdPaymentMethodEnabled Property

ClassifiedAdPaymentMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdPaymentMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPaymentMethodEnabledDefinitionType ClassifiedAdPaymentMethodEnabled { get; set; }
Public Property ClassifiedAdPaymentMethodEnabled As ClassifiedAdPaymentMethodEnabledDefinitionType
    Get
    Set
public:
property ClassifiedAdPaymentMethodEnabledDefinitionType^ ClassifiedAdPaymentMethodEnabled {
    ClassifiedAdPaymentMethodEnabledDefinitionType^ get ();
    void set (ClassifiedAdPaymentMethodEnabledDefinitionType^ value);
}


ClassifiedAdPayPerLeadEnabled Property

ClassifiedAdPayPerLeadEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdPayPerLeadEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPayPerLeadEnabledDefinitionType ClassifiedAdPayPerLeadEnabled { get; set; }
Public Property ClassifiedAdPayPerLeadEnabled As ClassifiedAdPayPerLeadEnabledDefinitionType
    Get
    Set
public:
property ClassifiedAdPayPerLeadEnabledDefinitionType^ ClassifiedAdPayPerLeadEnabled {
    ClassifiedAdPayPerLeadEnabledDefinitionType^ get ();
    void set (ClassifiedAdPayPerLeadEnabledDefinitionType^ value);
}


ClassifiedAdPhoneCount Property

ClassifiedAdPhoneCount Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdPhoneCount
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPhoneCountDefinitionType ClassifiedAdPhoneCount { get; set; }
Public Property ClassifiedAdPhoneCount As ClassifiedAdPhoneCountDefinitionType
    Get
    Set
public:
property ClassifiedAdPhoneCountDefinitionType^ ClassifiedAdPhoneCount {
    ClassifiedAdPhoneCountDefinitionType^ get ();
    void set (ClassifiedAdPhoneCountDefinitionType^ value);
}


ClassifiedAdShippingMethodEnabled Property

ClassifiedAdShippingMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdShippingMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdShippingMethodEnabledDefinitionType ClassifiedAdShippingMethodEnabled { get; set; }
Public Property ClassifiedAdShippingMethodEnabled As ClassifiedAdShippingMethodEnabledDefinitionType
    Get
    Set
public:
property ClassifiedAdShippingMethodEnabledDefinitionType^ ClassifiedAdShippingMethodEnabled {
    ClassifiedAdShippingMethodEnabledDefinitionType^ get ();
    void set (ClassifiedAdShippingMethodEnabledDefinitionType^ value);
}


ClassifiedAdStreetCount Property

ClassifiedAdStreetCount Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ClassifiedAdStreetCount
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdStreetCountDefinitionType ClassifiedAdStreetCount { get; set; }
Public Property ClassifiedAdStreetCount As ClassifiedAdStreetCountDefinitionType
    Get
    Set
public:
property ClassifiedAdStreetCountDefinitionType^ ClassifiedAdStreetCount {
    ClassifiedAdStreetCountDefinitionType^ get ();
    void set (ClassifiedAdStreetCountDefinitionType^ value);
}


CombinedFixedPriceTreatmentEnabled Property

CombinedFixedPriceTreatmentEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► CombinedFixedPriceTreatmentEnabled
Declaration Syntax
C# Visual Basic Visual C++
public CombinedFixedPriceTreatmentEnabledDefinitionType CombinedFixedPriceTreatmentEnabled { get; set; }
Public Property CombinedFixedPriceTreatmentEnabled As CombinedFixedPriceTreatmentEnabledDefinitionType
    Get
    Set
public:
property CombinedFixedPriceTreatmentEnabledDefinitionType^ CombinedFixedPriceTreatmentEnabled {
    CombinedFixedPriceTreatmentEnabledDefinitionType^ get ();
    void set (CombinedFixedPriceTreatmentEnabledDefinitionType^ value);
}


CompatibleVehicleType Property

CompatibleVehicleType Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► CompatibleVehicleType
Declaration Syntax
C# Visual Basic Visual C++
public CompatibleVehicleTypeDefinitionType CompatibleVehicleType { get; set; }
Public Property CompatibleVehicleType As CompatibleVehicleTypeDefinitionType
    Get
    Set
public:
property CompatibleVehicleTypeDefinitionType^ CompatibleVehicleType {
    CompatibleVehicleTypeDefinitionType^ get ();
    void set (CompatibleVehicleTypeDefinitionType^ value);
}


ConditionEnabled Property

ConditionEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ConditionEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ConditionEnabledDefinitionType ConditionEnabled { get; set; }
Public Property ConditionEnabled As ConditionEnabledDefinitionType
    Get
    Set
public:
property ConditionEnabledDefinitionType^ ConditionEnabled {
    ConditionEnabledDefinitionType^ get ();
    void set (ConditionEnabledDefinitionType^ value);
}


ConditionValues Property

ConditionValues Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ConditionValues
Declaration Syntax
C# Visual Basic Visual C++
public ConditionValuesDefinitionType ConditionValues { get; set; }
Public Property ConditionValues As ConditionValuesDefinitionType
    Get
    Set
public:
property ConditionValuesDefinitionType^ ConditionValues {
    ConditionValuesDefinitionType^ get ();
    void set (ConditionValuesDefinitionType^ value);
}


CrossBorderTradeAustraliaEnabled Property

CrossBorderTradeAustraliaEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► CrossBorderTradeAustraliaEnabled
Declaration Syntax
C# Visual Basic Visual C++
public CrossBorderTradeAustraliaEnabledDefinitionType CrossBorderTradeAustraliaEnabled { get; set; }
Public Property CrossBorderTradeAustraliaEnabled As CrossBorderTradeAustraliaEnabledDefinitionType
    Get
    Set
public:
property CrossBorderTradeAustraliaEnabledDefinitionType^ CrossBorderTradeAustraliaEnabled {
    CrossBorderTradeAustraliaEnabledDefinitionType^ get ();
    void set (CrossBorderTradeAustraliaEnabledDefinitionType^ value);
}


CrossBorderTradeGBEnabled Property

CrossBorderTradeGBEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► CrossBorderTradeGBEnabled
Declaration Syntax
C# Visual Basic Visual C++
public CrossBorderTradeGBEnabledDefinitionType CrossBorderTradeGBEnabled { get; set; }
Public Property CrossBorderTradeGBEnabled As CrossBorderTradeGBEnabledDefinitionType
    Get
    Set
public:
property CrossBorderTradeGBEnabledDefinitionType^ CrossBorderTradeGBEnabled {
    CrossBorderTradeGBEnabledDefinitionType^ get ();
    void set (CrossBorderTradeGBEnabledDefinitionType^ value);
}


CrossBorderTradeNorthAmericaEnabled Property

CrossBorderTradeNorthAmericaEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► CrossBorderTradeNorthAmericaEnabled
Declaration Syntax
C# Visual Basic Visual C++
public CrossBorderTradeNorthAmericaEnabledDefinitionType CrossBorderTradeNorthAmericaEnabled { get; set; }
Public Property CrossBorderTradeNorthAmericaEnabled As CrossBorderTradeNorthAmericaEnabledDefinitionType
    Get
    Set
public:
property CrossBorderTradeNorthAmericaEnabledDefinitionType^ CrossBorderTradeNorthAmericaEnabled {
    CrossBorderTradeNorthAmericaEnabledDefinitionType^ get ();
    void set (CrossBorderTradeNorthAmericaEnabledDefinitionType^ value);
}


DepositSupported Property

DepositSupported Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► DepositSupported
Declaration Syntax
C# Visual Basic Visual C++
public DepositSupportedDefinitionType DepositSupported { get; set; }
Public Property DepositSupported As DepositSupportedDefinitionType
    Get
    Set
public:
property DepositSupportedDefinitionType^ DepositSupported {
    DepositSupportedDefinitionType^ get ();
    void set (DepositSupportedDefinitionType^ value);
}


DigitalGoodDeliveryEnabled Property

DigitalGoodDeliveryEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► DigitalGoodDeliveryEnabled
Declaration Syntax
C# Visual Basic Visual C++
public DigitalGoodDeliveryEnabledDefinitionType DigitalGoodDeliveryEnabled { get; set; }
Public Property DigitalGoodDeliveryEnabled As DigitalGoodDeliveryEnabledDefinitionType
    Get
    Set
public:
property DigitalGoodDeliveryEnabledDefinitionType^ DigitalGoodDeliveryEnabled {
    DigitalGoodDeliveryEnabledDefinitionType^ get ();
    void set (DigitalGoodDeliveryEnabledDefinitionType^ value);
}


DutchBINEnabled Property

DutchBINEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► DutchBINEnabled
Declaration Syntax
C# Visual Basic Visual C++
public DutchBINEnabledDefinitionType DutchBINEnabled { get; set; }
Public Property DutchBINEnabled As DutchBINEnabledDefinitionType
    Get
    Set
public:
property DutchBINEnabledDefinitionType^ DutchBINEnabled {
    DutchBINEnabledDefinitionType^ get ();
    void set (DutchBINEnabledDefinitionType^ value);
}


EANEnabled Property

EANEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► EANEnabled
Declaration Syntax
C# Visual Basic Visual C++
public EANEnabledDefinitionType EANEnabled { get; set; }
Public Property EANEnabled As EANEnabledDefinitionType
    Get
    Set
public:
property EANEnabledDefinitionType^ EANEnabled {
    EANEnabledDefinitionType^ get ();
    void set (EANEnabledDefinitionType^ value);
}


EANIdentifierEnabled Property

EANIdentifierEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► EANIdentifierEnabled
Declaration Syntax
C# Visual Basic Visual C++
public EANIdentifierEnabledDefinitionType EANIdentifierEnabled { get; set; }
Public Property EANIdentifierEnabled As EANIdentifierEnabledDefinitionType
    Get
    Set
public:
property EANIdentifierEnabledDefinitionType^ EANIdentifierEnabled {
    EANIdentifierEnabledDefinitionType^ get ();
    void set (EANIdentifierEnabledDefinitionType^ value);
}


eBayMotorsProAdFormatEnabled Property

eBayMotorsProAdFormatEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProAdFormatEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProAdFormatEnabledDefinitionType eBayMotorsProAdFormatEnabled { get; set; }
Public Property eBayMotorsProAdFormatEnabled As eBayMotorsProAdFormatEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProAdFormatEnabledDefinitionType^ eBayMotorsProAdFormatEnabled {
    eBayMotorsProAdFormatEnabledDefinitionType^ get ();
    void set (eBayMotorsProAdFormatEnabledDefinitionType^ value);
}


eBayMotorsProAutoAcceptEnabled Property

eBayMotorsProAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProAutoAcceptEnabledDefinitionType eBayMotorsProAutoAcceptEnabled { get; set; }
Public Property eBayMotorsProAutoAcceptEnabled As eBayMotorsProAutoAcceptEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProAutoAcceptEnabledDefinitionType^ eBayMotorsProAutoAcceptEnabled {
    eBayMotorsProAutoAcceptEnabledDefinitionType^ get ();
    void set (eBayMotorsProAutoAcceptEnabledDefinitionType^ value);
}


eBayMotorsProAutoDeclineEnabled Property

eBayMotorsProAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProAutoDeclineEnabledDefinitionType eBayMotorsProAutoDeclineEnabled { get; set; }
Public Property eBayMotorsProAutoDeclineEnabled As eBayMotorsProAutoDeclineEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProAutoDeclineEnabledDefinitionType^ eBayMotorsProAutoDeclineEnabled {
    eBayMotorsProAutoDeclineEnabledDefinitionType^ get ();
    void set (eBayMotorsProAutoDeclineEnabledDefinitionType^ value);
}


eBayMotorsProBestOfferEnabled Property

eBayMotorsProBestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProBestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProBestOfferEnabledDefinitionType eBayMotorsProBestOfferEnabled { get; set; }
Public Property eBayMotorsProBestOfferEnabled As eBayMotorsProBestOfferEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProBestOfferEnabledDefinitionType^ eBayMotorsProBestOfferEnabled {
    eBayMotorsProBestOfferEnabledDefinitionType^ get ();
    void set (eBayMotorsProBestOfferEnabledDefinitionType^ value);
}


eBayMotorsProCompanyNameEnabled Property

eBayMotorsProCompanyNameEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProCompanyNameEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProCompanyNameEnabledDefinitionType eBayMotorsProCompanyNameEnabled { get; set; }
Public Property eBayMotorsProCompanyNameEnabled As eBayMotorsProCompanyNameEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProCompanyNameEnabledDefinitionType^ eBayMotorsProCompanyNameEnabled {
    eBayMotorsProCompanyNameEnabledDefinitionType^ get ();
    void set (eBayMotorsProCompanyNameEnabledDefinitionType^ value);
}


eBayMotorsProContactByAddressEnabled Property

eBayMotorsProContactByAddressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProContactByAddressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProContactByAddressEnabledDefinitionType eBayMotorsProContactByAddressEnabled { get; set; }
Public Property eBayMotorsProContactByAddressEnabled As eBayMotorsProContactByAddressEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProContactByAddressEnabledDefinitionType^ eBayMotorsProContactByAddressEnabled {
    eBayMotorsProContactByAddressEnabledDefinitionType^ get ();
    void set (eBayMotorsProContactByAddressEnabledDefinitionType^ value);
}


eBayMotorsProContactByEmailEnabled Property

eBayMotorsProContactByEmailEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProContactByEmailEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProContactByEmailEnabledDefinitionType eBayMotorsProContactByEmailEnabled { get; set; }
Public Property eBayMotorsProContactByEmailEnabled As eBayMotorsProContactByEmailEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProContactByEmailEnabledDefinitionType^ eBayMotorsProContactByEmailEnabled {
    eBayMotorsProContactByEmailEnabledDefinitionType^ get ();
    void set (eBayMotorsProContactByEmailEnabledDefinitionType^ value);
}


eBayMotorsProContactByPhoneEnabled Property

eBayMotorsProContactByPhoneEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProContactByPhoneEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProContactByPhoneEnabledDefinitionType eBayMotorsProContactByPhoneEnabled { get; set; }
Public Property eBayMotorsProContactByPhoneEnabled As eBayMotorsProContactByPhoneEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProContactByPhoneEnabledDefinitionType^ eBayMotorsProContactByPhoneEnabled {
    eBayMotorsProContactByPhoneEnabledDefinitionType^ get ();
    void set (eBayMotorsProContactByPhoneEnabledDefinitionType^ value);
}


eBayMotorsProCounterOfferEnabled Property

eBayMotorsProCounterOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProCounterOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProCounterOfferEnabledDefinitionType eBayMotorsProCounterOfferEnabled { get; set; }
Public Property eBayMotorsProCounterOfferEnabled As eBayMotorsProCounterOfferEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProCounterOfferEnabledDefinitionType^ eBayMotorsProCounterOfferEnabled {
    eBayMotorsProCounterOfferEnabledDefinitionType^ get ();
    void set (eBayMotorsProCounterOfferEnabledDefinitionType^ value);
}


eBayMotorsProPaymentMethodCheckOutEnabled Property

eBayMotorsProPaymentMethodCheckOutEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProPaymentMethodCheckOutEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType eBayMotorsProPaymentMethodCheckOutEnabled { get; set; }
Public Property eBayMotorsProPaymentMethodCheckOutEnabled As eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType^ eBayMotorsProPaymentMethodCheckOutEnabled {
    eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType^ get ();
    void set (eBayMotorsProPaymentMethodCheckOutEnabledDefinitionType^ value);
}


eBayMotorsProPhoneCount Property

eBayMotorsProPhoneCount Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProPhoneCount
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProPhoneCountDefinitionType eBayMotorsProPhoneCount { get; set; }
Public Property eBayMotorsProPhoneCount As eBayMotorsProPhoneCountDefinitionType
    Get
    Set
public:
property eBayMotorsProPhoneCountDefinitionType^ eBayMotorsProPhoneCount {
    eBayMotorsProPhoneCountDefinitionType^ get ();
    void set (eBayMotorsProPhoneCountDefinitionType^ value);
}


eBayMotorsProSellerContactDetailsEnabled Property

eBayMotorsProSellerContactDetailsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProSellerContactDetailsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProSellerContactDetailsEnabledDefinitionType eBayMotorsProSellerContactDetailsEnabled { get; set; }
Public Property eBayMotorsProSellerContactDetailsEnabled As eBayMotorsProSellerContactDetailsEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProSellerContactDetailsEnabledDefinitionType^ eBayMotorsProSellerContactDetailsEnabled {
    eBayMotorsProSellerContactDetailsEnabledDefinitionType^ get ();
    void set (eBayMotorsProSellerContactDetailsEnabledDefinitionType^ value);
}


eBayMotorsProShippingMethodEnabled Property

eBayMotorsProShippingMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProShippingMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProShippingMethodEnabledDefinitionType eBayMotorsProShippingMethodEnabled { get; set; }
Public Property eBayMotorsProShippingMethodEnabled As eBayMotorsProShippingMethodEnabledDefinitionType
    Get
    Set
public:
property eBayMotorsProShippingMethodEnabledDefinitionType^ eBayMotorsProShippingMethodEnabled {
    eBayMotorsProShippingMethodEnabledDefinitionType^ get ();
    void set (eBayMotorsProShippingMethodEnabledDefinitionType^ value);
}


eBayMotorsProStreetCount Property

eBayMotorsProStreetCount Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► eBayMotorsProStreetCount
Declaration Syntax
C# Visual Basic Visual C++
public eBayMotorsProStreetCountDefinitionType eBayMotorsProStreetCount { get; set; }
Public Property eBayMotorsProStreetCount As eBayMotorsProStreetCountDefinitionType
    Get
    Set
public:
property eBayMotorsProStreetCountDefinitionType^ eBayMotorsProStreetCount {
    eBayMotorsProStreetCountDefinitionType^ get ();
    void set (eBayMotorsProStreetCountDefinitionType^ value);
}


EpidSupported Property

EpidSupported Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► EpidSupported
Declaration Syntax
C# Visual Basic Visual C++
public EpidSupportedDefinitionType EpidSupported { get; set; }
Public Property EpidSupported As EpidSupportedDefinitionType
    Get
    Set
public:
property EpidSupportedDefinitionType^ EpidSupported {
    EpidSupportedDefinitionType^ get ();
    void set (EpidSupportedDefinitionType^ value);
}


ExpressConditionRequired Property

ExpressConditionRequired Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ExpressConditionRequired
Declaration Syntax
C# Visual Basic Visual C++
public ExpressConditionRequiredDefinitionType ExpressConditionRequired { get; set; }
Public Property ExpressConditionRequired As ExpressConditionRequiredDefinitionType
    Get
    Set
public:
property ExpressConditionRequiredDefinitionType^ ExpressConditionRequired {
    ExpressConditionRequiredDefinitionType^ get ();
    void set (ExpressConditionRequiredDefinitionType^ value);
}


ExpressEnabled Property

ExpressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ExpressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ExpressEnabledDefinitionType ExpressEnabled { get; set; }
Public Property ExpressEnabled As ExpressEnabledDefinitionType
    Get
    Set
public:
property ExpressEnabledDefinitionType^ ExpressEnabled {
    ExpressEnabledDefinitionType^ get ();
    void set (ExpressEnabledDefinitionType^ value);
}


ExpressPicturesRequired Property

ExpressPicturesRequired Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ExpressPicturesRequired
Declaration Syntax
C# Visual Basic Visual C++
public ExpressPicturesRequiredDefinitionType ExpressPicturesRequired { get; set; }
Public Property ExpressPicturesRequired As ExpressPicturesRequiredDefinitionType
    Get
    Set
public:
property ExpressPicturesRequiredDefinitionType^ ExpressPicturesRequired {
    ExpressPicturesRequiredDefinitionType^ get ();
    void set (ExpressPicturesRequiredDefinitionType^ value);
}


FeatureDefinitionsType Constructor

FeatureDefinitionsType Constructor
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► FeatureDefinitionsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeatureDefinitionsType()
Public Sub New
public:
FeatureDefinitionsType()


FreeGalleryPlusEnabled Property

FreeGalleryPlusEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► FreeGalleryPlusEnabled
Declaration Syntax
C# Visual Basic Visual C++
public FreeGalleryPlusEnabledDefinitionType FreeGalleryPlusEnabled { get; set; }
Public Property FreeGalleryPlusEnabled As FreeGalleryPlusEnabledDefinitionType
    Get
    Set
public:
property FreeGalleryPlusEnabledDefinitionType^ FreeGalleryPlusEnabled {
    FreeGalleryPlusEnabledDefinitionType^ get ();
    void set (FreeGalleryPlusEnabledDefinitionType^ value);
}


FreePicturePackEnabled Property

FreePicturePackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► FreePicturePackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public FreePicturePackEnabledDefinitionType FreePicturePackEnabled { get; set; }
Public Property FreePicturePackEnabled As FreePicturePackEnabledDefinitionType
    Get
    Set
public:
property FreePicturePackEnabledDefinitionType^ FreePicturePackEnabled {
    FreePicturePackEnabledDefinitionType^ get ();
    void set (FreePicturePackEnabledDefinitionType^ value);
}


GalleryFeaturedDurations Property

GalleryFeaturedDurations Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► GalleryFeaturedDurations
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementDurationDefinitionType GalleryFeaturedDurations { get; set; }
Public Property GalleryFeaturedDurations As ListingEnhancementDurationDefinitionType
    Get
    Set
public:
property ListingEnhancementDurationDefinitionType^ GalleryFeaturedDurations {
    ListingEnhancementDurationDefinitionType^ get ();
    void set (ListingEnhancementDurationDefinitionType^ value);
}


GlobalShippingEnabled Property

GlobalShippingEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► GlobalShippingEnabled
Declaration Syntax
C# Visual Basic Visual C++
public GlobalShippingEnabledDefinitionType GlobalShippingEnabled { get; set; }
Public Property GlobalShippingEnabled As GlobalShippingEnabledDefinitionType
    Get
    Set
public:
property GlobalShippingEnabledDefinitionType^ GlobalShippingEnabled {
    GlobalShippingEnabledDefinitionType^ get ();
    void set (GlobalShippingEnabledDefinitionType^ value);
}


Group1MaxFlatShippingCost Property

Group1MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► Group1MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public Group1MaxFlatShippingCostDefinitionType Group1MaxFlatShippingCost { get; set; }
Public Property Group1MaxFlatShippingCost As Group1MaxFlatShippingCostDefinitionType
    Get
    Set
public:
property Group1MaxFlatShippingCostDefinitionType^ Group1MaxFlatShippingCost {
    Group1MaxFlatShippingCostDefinitionType^ get ();
    void set (Group1MaxFlatShippingCostDefinitionType^ value);
}


Group2MaxFlatShippingCost Property

Group2MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► Group2MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public Group2MaxFlatShippingCostDefinitionType Group2MaxFlatShippingCost { get; set; }
Public Property Group2MaxFlatShippingCost As Group2MaxFlatShippingCostDefinitionType
    Get
    Set
public:
property Group2MaxFlatShippingCostDefinitionType^ Group2MaxFlatShippingCost {
    Group2MaxFlatShippingCostDefinitionType^ get ();
    void set (Group2MaxFlatShippingCostDefinitionType^ value);
}


Group3MaxFlatShippingCost Property

Group3MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► Group3MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public Group3MaxFlatShippingCostDefinitionType Group3MaxFlatShippingCost { get; set; }
Public Property Group3MaxFlatShippingCost As Group3MaxFlatShippingCostDefinitionType
    Get
    Set
public:
property Group3MaxFlatShippingCostDefinitionType^ Group3MaxFlatShippingCost {
    Group3MaxFlatShippingCostDefinitionType^ get ();
    void set (Group3MaxFlatShippingCostDefinitionType^ value);
}


HandlingTimeEnabled Property

HandlingTimeEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► HandlingTimeEnabled
Declaration Syntax
C# Visual Basic Visual C++
public HandlingTimeEnabledDefinitionType HandlingTimeEnabled { get; set; }
Public Property HandlingTimeEnabled As HandlingTimeEnabledDefinitionType
    Get
    Set
public:
property HandlingTimeEnabledDefinitionType^ HandlingTimeEnabled {
    HandlingTimeEnabledDefinitionType^ get ();
    void set (HandlingTimeEnabledDefinitionType^ value);
}


HomePageFeaturedEnabled Property

HomePageFeaturedEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► HomePageFeaturedEnabled
Declaration Syntax
C# Visual Basic Visual C++
public HomePageFeaturedEnabledDefinitionType HomePageFeaturedEnabled { get; set; }
Public Property HomePageFeaturedEnabled As HomePageFeaturedEnabledDefinitionType
    Get
    Set
public:
property HomePageFeaturedEnabledDefinitionType^ HomePageFeaturedEnabled {
    HomePageFeaturedEnabledDefinitionType^ get ();
    void set (HomePageFeaturedEnabledDefinitionType^ value);
}


INEscrowWorkflowTimeline Property

INEscrowWorkflowTimeline Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► INEscrowWorkflowTimeline
Declaration Syntax
C# Visual Basic Visual C++
public INEscrowWorkflowTimelineDefinitionType INEscrowWorkflowTimeline { get; set; }
Public Property INEscrowWorkflowTimeline As INEscrowWorkflowTimelineDefinitionType
    Get
    Set
public:
property INEscrowWorkflowTimelineDefinitionType^ INEscrowWorkflowTimeline {
    INEscrowWorkflowTimelineDefinitionType^ get ();
    void set (INEscrowWorkflowTimelineDefinitionType^ value);
}


ISBNEnabled Property

ISBNEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ISBNEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ISBNEnabledDefinitionType ISBNEnabled { get; set; }
Public Property ISBNEnabled As ISBNEnabledDefinitionType
    Get
    Set
public:
property ISBNEnabledDefinitionType^ ISBNEnabled {
    ISBNEnabledDefinitionType^ get ();
    void set (ISBNEnabledDefinitionType^ value);
}


ISBNIdentifierEnabled Property

ISBNIdentifierEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ISBNIdentifierEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ISBNIdentifierEnabledDefinitionType ISBNIdentifierEnabled { get; set; }
Public Property ISBNIdentifierEnabled As ISBNIdentifierEnabledDefinitionType
    Get
    Set
public:
property ISBNIdentifierEnabledDefinitionType^ ISBNIdentifierEnabled {
    ISBNIdentifierEnabledDefinitionType^ get ();
    void set (ISBNIdentifierEnabledDefinitionType^ value);
}


ItemCompatibilityEnabled Property

ItemCompatibilityEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ItemCompatibilityEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityEnabledDefinitionType ItemCompatibilityEnabled { get; set; }
Public Property ItemCompatibilityEnabled As ItemCompatibilityEnabledDefinitionType
    Get
    Set
public:
property ItemCompatibilityEnabledDefinitionType^ ItemCompatibilityEnabled {
    ItemCompatibilityEnabledDefinitionType^ get ();
    void set (ItemCompatibilityEnabledDefinitionType^ value);
}


ItemSpecificsEnabled Property

ItemSpecificsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ItemSpecificsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificsEnabledDefinitionType ItemSpecificsEnabled { get; set; }
Public Property ItemSpecificsEnabled As ItemSpecificsEnabledDefinitionType
    Get
    Set
public:
property ItemSpecificsEnabledDefinitionType^ ItemSpecificsEnabled {
    ItemSpecificsEnabledDefinitionType^ get ();
    void set (ItemSpecificsEnabledDefinitionType^ value);
}


KTypeSupported Property

KTypeSupported Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► KTypeSupported
Declaration Syntax
C# Visual Basic Visual C++
public KTypeSupportedDefinitionType KTypeSupported { get; set; }
Public Property KTypeSupported As KTypeSupportedDefinitionType
    Get
    Set
public:
property KTypeSupportedDefinitionType^ KTypeSupported {
    KTypeSupportedDefinitionType^ get ();
    void set (KTypeSupportedDefinitionType^ value);
}


ListingDurations Property

ListingDurations Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ListingDurations
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationDefinitionsType ListingDurations { get; set; }
Public Property ListingDurations As ListingDurationDefinitionsType
    Get
    Set
public:
property ListingDurationDefinitionsType^ ListingDurations {
    ListingDurationDefinitionsType^ get ();
    void set (ListingDurationDefinitionsType^ value);
}


LocalListingDistancesNonSubscription Property

LocalListingDistancesNonSubscription Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalListingDistancesNonSubscription
Declaration Syntax
C# Visual Basic Visual C++
public LocalListingDistancesNonSubscriptionDefinitionType LocalListingDistancesNonSubscription { get; set; }
Public Property LocalListingDistancesNonSubscription As LocalListingDistancesNonSubscriptionDefinitionType
    Get
    Set
public:
property LocalListingDistancesNonSubscriptionDefinitionType^ LocalListingDistancesNonSubscription {
    LocalListingDistancesNonSubscriptionDefinitionType^ get ();
    void set (LocalListingDistancesNonSubscriptionDefinitionType^ value);
}


LocalListingDistancesRegular Property

LocalListingDistancesRegular Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalListingDistancesRegular
Declaration Syntax
C# Visual Basic Visual C++
public LocalListingDistancesRegularDefinitionType LocalListingDistancesRegular { get; set; }
Public Property LocalListingDistancesRegular As LocalListingDistancesRegularDefinitionType
    Get
    Set
public:
property LocalListingDistancesRegularDefinitionType^ LocalListingDistancesRegular {
    LocalListingDistancesRegularDefinitionType^ get ();
    void set (LocalListingDistancesRegularDefinitionType^ value);
}


LocalListingDistancesSpecialty Property

LocalListingDistancesSpecialty Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalListingDistancesSpecialty
Declaration Syntax
C# Visual Basic Visual C++
public LocalListingDistancesSpecialtyDefinitionType LocalListingDistancesSpecialty { get; set; }
Public Property LocalListingDistancesSpecialty As LocalListingDistancesSpecialtyDefinitionType
    Get
    Set
public:
property LocalListingDistancesSpecialtyDefinitionType^ LocalListingDistancesSpecialty {
    LocalListingDistancesSpecialtyDefinitionType^ get ();
    void set (LocalListingDistancesSpecialtyDefinitionType^ value);
}


LocalMarketAdFormatEnabled Property

LocalMarketAdFormatEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketAdFormatEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketAdFormatEnabledDefinitionType LocalMarketAdFormatEnabled { get; set; }
Public Property LocalMarketAdFormatEnabled As LocalMarketAdFormatEnabledDefinitionType
    Get
    Set
public:
property LocalMarketAdFormatEnabledDefinitionType^ LocalMarketAdFormatEnabled {
    LocalMarketAdFormatEnabledDefinitionType^ get ();
    void set (LocalMarketAdFormatEnabledDefinitionType^ value);
}


LocalMarketAutoAcceptEnabled Property

LocalMarketAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketAutoAcceptEnabledDefinitionType LocalMarketAutoAcceptEnabled { get; set; }
Public Property LocalMarketAutoAcceptEnabled As LocalMarketAutoAcceptEnabledDefinitionType
    Get
    Set
public:
property LocalMarketAutoAcceptEnabledDefinitionType^ LocalMarketAutoAcceptEnabled {
    LocalMarketAutoAcceptEnabledDefinitionType^ get ();
    void set (LocalMarketAutoAcceptEnabledDefinitionType^ value);
}


LocalMarketAutoDeclineEnabled Property

LocalMarketAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketAutoDeclineEnabledDefinitionType LocalMarketAutoDeclineEnabled { get; set; }
Public Property LocalMarketAutoDeclineEnabled As LocalMarketAutoDeclineEnabledDefinitionType
    Get
    Set
public:
property LocalMarketAutoDeclineEnabledDefinitionType^ LocalMarketAutoDeclineEnabled {
    LocalMarketAutoDeclineEnabledDefinitionType^ get ();
    void set (LocalMarketAutoDeclineEnabledDefinitionType^ value);
}


LocalMarketBestOfferEnabled Property

LocalMarketBestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketBestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketBestOfferEnabledDefinitionType LocalMarketBestOfferEnabled { get; set; }
Public Property LocalMarketBestOfferEnabled As LocalMarketBestOfferEnabledDefinitionType
    Get
    Set
public:
property LocalMarketBestOfferEnabledDefinitionType^ LocalMarketBestOfferEnabled {
    LocalMarketBestOfferEnabledDefinitionType^ get ();
    void set (LocalMarketBestOfferEnabledDefinitionType^ value);
}


LocalMarketCompanyNameEnabled Property

LocalMarketCompanyNameEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketCompanyNameEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketCompanyNameEnabledDefinitionType LocalMarketCompanyNameEnabled { get; set; }
Public Property LocalMarketCompanyNameEnabled As LocalMarketCompanyNameEnabledDefinitionType
    Get
    Set
public:
property LocalMarketCompanyNameEnabledDefinitionType^ LocalMarketCompanyNameEnabled {
    LocalMarketCompanyNameEnabledDefinitionType^ get ();
    void set (LocalMarketCompanyNameEnabledDefinitionType^ value);
}


LocalMarketContactByAddressEnabled Property

LocalMarketContactByAddressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketContactByAddressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketContactByAddressEnabledDefinitionType LocalMarketContactByAddressEnabled { get; set; }
Public Property LocalMarketContactByAddressEnabled As LocalMarketContactByAddressEnabledDefinitionType
    Get
    Set
public:
property LocalMarketContactByAddressEnabledDefinitionType^ LocalMarketContactByAddressEnabled {
    LocalMarketContactByAddressEnabledDefinitionType^ get ();
    void set (LocalMarketContactByAddressEnabledDefinitionType^ value);
}


LocalMarketContactByEmailEnabled Property

LocalMarketContactByEmailEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketContactByEmailEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketContactByEmailEnabledDefinitionType LocalMarketContactByEmailEnabled { get; set; }
Public Property LocalMarketContactByEmailEnabled As LocalMarketContactByEmailEnabledDefinitionType
    Get
    Set
public:
property LocalMarketContactByEmailEnabledDefinitionType^ LocalMarketContactByEmailEnabled {
    LocalMarketContactByEmailEnabledDefinitionType^ get ();
    void set (LocalMarketContactByEmailEnabledDefinitionType^ value);
}


LocalMarketContactByPhoneEnabled Property

LocalMarketContactByPhoneEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketContactByPhoneEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketContactByPhoneEnabledDefinitionType LocalMarketContactByPhoneEnabled { get; set; }
Public Property LocalMarketContactByPhoneEnabled As LocalMarketContactByPhoneEnabledDefinitionType
    Get
    Set
public:
property LocalMarketContactByPhoneEnabledDefinitionType^ LocalMarketContactByPhoneEnabled {
    LocalMarketContactByPhoneEnabledDefinitionType^ get ();
    void set (LocalMarketContactByPhoneEnabledDefinitionType^ value);
}


LocalMarketCounterOfferEnabled Property

LocalMarketCounterOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketCounterOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketCounterOfferEnabledDefinitionType LocalMarketCounterOfferEnabled { get; set; }
Public Property LocalMarketCounterOfferEnabled As LocalMarketCounterOfferEnabledDefinitionType
    Get
    Set
public:
property LocalMarketCounterOfferEnabledDefinitionType^ LocalMarketCounterOfferEnabled {
    LocalMarketCounterOfferEnabledDefinitionType^ get ();
    void set (LocalMarketCounterOfferEnabledDefinitionType^ value);
}


LocalMarketNonSubscription Property

LocalMarketNonSubscription Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketNonSubscription
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketNonSubscriptionDefinitionType LocalMarketNonSubscription { get; set; }
Public Property LocalMarketNonSubscription As LocalMarketNonSubscriptionDefinitionType
    Get
    Set
public:
property LocalMarketNonSubscriptionDefinitionType^ LocalMarketNonSubscription {
    LocalMarketNonSubscriptionDefinitionType^ get ();
    void set (LocalMarketNonSubscriptionDefinitionType^ value);
}


LocalMarketPaymentMethodCheckOutEnabled Property

LocalMarketPaymentMethodCheckOutEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketPaymentMethodCheckOutEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketPaymentMethodCheckOutEnabledDefinitionType LocalMarketPaymentMethodCheckOutEnabled { get; set; }
Public Property LocalMarketPaymentMethodCheckOutEnabled As LocalMarketPaymentMethodCheckOutEnabledDefinitionType
    Get
    Set
public:
property LocalMarketPaymentMethodCheckOutEnabledDefinitionType^ LocalMarketPaymentMethodCheckOutEnabled {
    LocalMarketPaymentMethodCheckOutEnabledDefinitionType^ get ();
    void set (LocalMarketPaymentMethodCheckOutEnabledDefinitionType^ value);
}


LocalMarketPhoneCount Property

LocalMarketPhoneCount Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketPhoneCount
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketPhoneCountDefinitionType LocalMarketPhoneCount { get; set; }
Public Property LocalMarketPhoneCount As LocalMarketPhoneCountDefinitionType
    Get
    Set
public:
property LocalMarketPhoneCountDefinitionType^ LocalMarketPhoneCount {
    LocalMarketPhoneCountDefinitionType^ get ();
    void set (LocalMarketPhoneCountDefinitionType^ value);
}


LocalMarketPremiumSubscription Property

LocalMarketPremiumSubscription Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketPremiumSubscription
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketPremiumSubscriptionDefinitionType LocalMarketPremiumSubscription { get; set; }
Public Property LocalMarketPremiumSubscription As LocalMarketPremiumSubscriptionDefinitionType
    Get
    Set
public:
property LocalMarketPremiumSubscriptionDefinitionType^ LocalMarketPremiumSubscription {
    LocalMarketPremiumSubscriptionDefinitionType^ get ();
    void set (LocalMarketPremiumSubscriptionDefinitionType^ value);
}


LocalMarketRegularSubscription Property

LocalMarketRegularSubscription Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketRegularSubscription
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketRegularSubscriptionDefinitionType LocalMarketRegularSubscription { get; set; }
Public Property LocalMarketRegularSubscription As LocalMarketRegularSubscriptionDefinitionType
    Get
    Set
public:
property LocalMarketRegularSubscriptionDefinitionType^ LocalMarketRegularSubscription {
    LocalMarketRegularSubscriptionDefinitionType^ get ();
    void set (LocalMarketRegularSubscriptionDefinitionType^ value);
}


LocalMarketSellerContactDetailsEnabled Property

LocalMarketSellerContactDetailsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketSellerContactDetailsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketSellerContactDetailsEnabledDefinitionType LocalMarketSellerContactDetailsEnabled { get; set; }
Public Property LocalMarketSellerContactDetailsEnabled As LocalMarketSellerContactDetailsEnabledDefinitionType
    Get
    Set
public:
property LocalMarketSellerContactDetailsEnabledDefinitionType^ LocalMarketSellerContactDetailsEnabled {
    LocalMarketSellerContactDetailsEnabledDefinitionType^ get ();
    void set (LocalMarketSellerContactDetailsEnabledDefinitionType^ value);
}


LocalMarketShippingMethodEnabled Property

LocalMarketShippingMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketShippingMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketShippingMethodEnabledDefinitionType LocalMarketShippingMethodEnabled { get; set; }
Public Property LocalMarketShippingMethodEnabled As LocalMarketShippingMethodEnabledDefinitionType
    Get
    Set
public:
property LocalMarketShippingMethodEnabledDefinitionType^ LocalMarketShippingMethodEnabled {
    LocalMarketShippingMethodEnabledDefinitionType^ get ();
    void set (LocalMarketShippingMethodEnabledDefinitionType^ value);
}


LocalMarketSpecialitySubscription Property

LocalMarketSpecialitySubscription Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketSpecialitySubscription
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketSpecialitySubscriptionDefinitionType LocalMarketSpecialitySubscription { get; set; }
Public Property LocalMarketSpecialitySubscription As LocalMarketSpecialitySubscriptionDefinitionType
    Get
    Set
public:
property LocalMarketSpecialitySubscriptionDefinitionType^ LocalMarketSpecialitySubscription {
    LocalMarketSpecialitySubscriptionDefinitionType^ get ();
    void set (LocalMarketSpecialitySubscriptionDefinitionType^ value);
}


LocalMarketStreetCount Property

LocalMarketStreetCount Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► LocalMarketStreetCount
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketStreetCountDefinitionType LocalMarketStreetCount { get; set; }
Public Property LocalMarketStreetCount As LocalMarketStreetCountDefinitionType
    Get
    Set
public:
property LocalMarketStreetCountDefinitionType^ LocalMarketStreetCount {
    LocalMarketStreetCountDefinitionType^ get ();
    void set (LocalMarketStreetCountDefinitionType^ value);
}


MaxFlatShippingCost Property

MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public MaxFlatShippingCostDefinitionType MaxFlatShippingCost { get; set; }
Public Property MaxFlatShippingCost As MaxFlatShippingCostDefinitionType
    Get
    Set
public:
property MaxFlatShippingCostDefinitionType^ MaxFlatShippingCost {
    MaxFlatShippingCostDefinitionType^ get ();
    void set (MaxFlatShippingCostDefinitionType^ value);
}


MaxFlatShippingCostCBTExempt Property

MaxFlatShippingCostCBTExempt Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► MaxFlatShippingCostCBTExempt
Declaration Syntax
C# Visual Basic Visual C++
public MaxFlatShippingCostCBTExemptDefinitionType MaxFlatShippingCostCBTExempt { get; set; }
Public Property MaxFlatShippingCostCBTExempt As MaxFlatShippingCostCBTExemptDefinitionType
    Get
    Set
public:
property MaxFlatShippingCostCBTExemptDefinitionType^ MaxFlatShippingCostCBTExempt {
    MaxFlatShippingCostCBTExemptDefinitionType^ get ();
    void set (MaxFlatShippingCostCBTExemptDefinitionType^ value);
}


MaxGranularFitmentCount Property

MaxGranularFitmentCount Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► MaxGranularFitmentCount
Declaration Syntax
C# Visual Basic Visual C++
public MaxGranularFitmentCountDefinitionType MaxGranularFitmentCount { get; set; }
Public Property MaxGranularFitmentCount As MaxGranularFitmentCountDefinitionType
    Get
    Set
public:
property MaxGranularFitmentCountDefinitionType^ MaxGranularFitmentCount {
    MaxGranularFitmentCountDefinitionType^ get ();
    void set (MaxGranularFitmentCountDefinitionType^ value);
}


MaxItemCompatibility Property

MaxItemCompatibility Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► MaxItemCompatibility
Declaration Syntax
C# Visual Basic Visual C++
public MaxItemCompatibilityDefinitionType MaxItemCompatibility { get; set; }
Public Property MaxItemCompatibility As MaxItemCompatibilityDefinitionType
    Get
    Set
public:
property MaxItemCompatibilityDefinitionType^ MaxItemCompatibility {
    MaxItemCompatibilityDefinitionType^ get ();
    void set (MaxItemCompatibilityDefinitionType^ value);
}


MinimumReservePrice Property

MinimumReservePrice Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► MinimumReservePrice
Declaration Syntax
C# Visual Basic Visual C++
public MinimumReservePriceDefinitionType MinimumReservePrice { get; set; }
Public Property MinimumReservePrice As MinimumReservePriceDefinitionType
    Get
    Set
public:
property MinimumReservePriceDefinitionType^ MinimumReservePrice {
    MinimumReservePriceDefinitionType^ get ();
    void set (MinimumReservePriceDefinitionType^ value);
}


MinItemCompatibility Property

MinItemCompatibility Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► MinItemCompatibility
Declaration Syntax
C# Visual Basic Visual C++
public MinItemCompatibilityDefinitionType MinItemCompatibility { get; set; }
Public Property MinItemCompatibility As MinItemCompatibilityDefinitionType
    Get
    Set
public:
property MinItemCompatibilityDefinitionType^ MinItemCompatibility {
    MinItemCompatibilityDefinitionType^ get ();
    void set (MinItemCompatibilityDefinitionType^ value);
}


NonSubscription Property

NonSubscription Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► NonSubscription
Declaration Syntax
C# Visual Basic Visual C++
public NonSubscriptionDefinitionType NonSubscription { get; set; }
Public Property NonSubscription As NonSubscriptionDefinitionType
    Get
    Set
public:
property NonSubscriptionDefinitionType^ NonSubscription {
    NonSubscriptionDefinitionType^ get ();
    void set (NonSubscriptionDefinitionType^ value);
}


PaisaPayFullEscrowEnabled Property

PaisaPayFullEscrowEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► PaisaPayFullEscrowEnabled
Declaration Syntax
C# Visual Basic Visual C++
public PaisaPayFullEscrowEnabledDefinitionType PaisaPayFullEscrowEnabled { get; set; }
Public Property PaisaPayFullEscrowEnabled As PaisaPayFullEscrowEnabledDefinitionType
    Get
    Set
public:
property PaisaPayFullEscrowEnabledDefinitionType^ PaisaPayFullEscrowEnabled {
    PaisaPayFullEscrowEnabledDefinitionType^ get ();
    void set (PaisaPayFullEscrowEnabledDefinitionType^ value);
}


PaymentMethod Property

PaymentMethod Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► PaymentMethod
Declaration Syntax
C# Visual Basic Visual C++
public PaymentMethodDefinitionType PaymentMethod { get; set; }
Public Property PaymentMethod As PaymentMethodDefinitionType
    Get
    Set
public:
property PaymentMethodDefinitionType^ PaymentMethod {
    PaymentMethodDefinitionType^ get ();
    void set (PaymentMethodDefinitionType^ value);
}


PaymentOptionsGroup Property

PaymentOptionsGroup Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► PaymentOptionsGroup
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionsGroupEnabledDefinitionType PaymentOptionsGroup { get; set; }
Public Property PaymentOptionsGroup As PaymentOptionsGroupEnabledDefinitionType
    Get
    Set
public:
property PaymentOptionsGroupEnabledDefinitionType^ PaymentOptionsGroup {
    PaymentOptionsGroupEnabledDefinitionType^ get ();
    void set (PaymentOptionsGroupEnabledDefinitionType^ value);
}


PaymentProfileCategoryGroup Property

PaymentProfileCategoryGroup Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► PaymentProfileCategoryGroup
Declaration Syntax
C# Visual Basic Visual C++
public ProfileCategoryGroupDefinitionType PaymentProfileCategoryGroup { get; set; }
Public Property PaymentProfileCategoryGroup As ProfileCategoryGroupDefinitionType
    Get
    Set
public:
property ProfileCategoryGroupDefinitionType^ PaymentProfileCategoryGroup {
    ProfileCategoryGroupDefinitionType^ get ();
    void set (ProfileCategoryGroupDefinitionType^ value);
}


PayPalBuyerProtectionEnabled Property

PayPalBuyerProtectionEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► PayPalBuyerProtectionEnabled
Declaration Syntax
C# Visual Basic Visual C++
public PayPalBuyerProtectionEnabledDefinitionType PayPalBuyerProtectionEnabled { get; set; }
Public Property PayPalBuyerProtectionEnabled As PayPalBuyerProtectionEnabledDefinitionType
    Get
    Set
public:
property PayPalBuyerProtectionEnabledDefinitionType^ PayPalBuyerProtectionEnabled {
    PayPalBuyerProtectionEnabledDefinitionType^ get ();
    void set (PayPalBuyerProtectionEnabledDefinitionType^ value);
}


PayPalRequired Property

PayPalRequired Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► PayPalRequired
Declaration Syntax
C# Visual Basic Visual C++
public PayPalRequiredDefinitionType PayPalRequired { get; set; }
Public Property PayPalRequired As PayPalRequiredDefinitionType
    Get
    Set
public:
property PayPalRequiredDefinitionType^ PayPalRequired {
    PayPalRequiredDefinitionType^ get ();
    void set (PayPalRequiredDefinitionType^ value);
}


PayPalRequiredForStoreOwner Property

PayPalRequiredForStoreOwner Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► PayPalRequiredForStoreOwner
Declaration Syntax
C# Visual Basic Visual C++
public PayPalRequiredForStoreOwnerDefinitionType PayPalRequiredForStoreOwner { get; set; }
Public Property PayPalRequiredForStoreOwner As PayPalRequiredForStoreOwnerDefinitionType
    Get
    Set
public:
property PayPalRequiredForStoreOwnerDefinitionType^ PayPalRequiredForStoreOwner {
    PayPalRequiredForStoreOwnerDefinitionType^ get ();
    void set (PayPalRequiredForStoreOwnerDefinitionType^ value);
}


PickupDropOffEnabled Property

PickupDropOffEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► PickupDropOffEnabled
Declaration Syntax
C# Visual Basic Visual C++
public PickupDropOffEnabledDefinitionType PickupDropOffEnabled { get; set; }
Public Property PickupDropOffEnabled As PickupDropOffEnabledDefinitionType
    Get
    Set
public:
property PickupDropOffEnabledDefinitionType^ PickupDropOffEnabled {
    PickupDropOffEnabledDefinitionType^ get ();
    void set (PickupDropOffEnabledDefinitionType^ value);
}


PremiumSubscription Property

PremiumSubscription Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► PremiumSubscription
Declaration Syntax
C# Visual Basic Visual C++
public PremiumSubscriptionDefinitionType PremiumSubscription { get; set; }
Public Property PremiumSubscription As PremiumSubscriptionDefinitionType
    Get
    Set
public:
property PremiumSubscriptionDefinitionType^ PremiumSubscription {
    PremiumSubscriptionDefinitionType^ get ();
    void set (PremiumSubscriptionDefinitionType^ value);
}


ProductCreationEnabled Property

ProductCreationEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ProductCreationEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ProductCreationEnabledDefinitionType ProductCreationEnabled { get; set; }
Public Property ProductCreationEnabled As ProductCreationEnabledDefinitionType
    Get
    Set
public:
property ProductCreationEnabledDefinitionType^ ProductCreationEnabled {
    ProductCreationEnabledDefinitionType^ get ();
    void set (ProductCreationEnabledDefinitionType^ value);
}


ProPackEnabled Property

ProPackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ProPackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ProPackEnabledDefinitionType ProPackEnabled { get; set; }
Public Property ProPackEnabled As ProPackEnabledDefinitionType
    Get
    Set
public:
property ProPackEnabledDefinitionType^ ProPackEnabled {
    ProPackEnabledDefinitionType^ get ();
    void set (ProPackEnabledDefinitionType^ value);
}


ProPackPlusEnabled Property

ProPackPlusEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ProPackPlusEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ProPackPlusEnabledDefinitionType ProPackPlusEnabled { get; set; }
Public Property ProPackPlusEnabled As ProPackPlusEnabledDefinitionType
    Get
    Set
public:
property ProPackPlusEnabledDefinitionType^ ProPackPlusEnabled {
    ProPackPlusEnabledDefinitionType^ get ();
    void set (ProPackPlusEnabledDefinitionType^ value);
}


RegularSubscription Property

RegularSubscription Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► RegularSubscription
Declaration Syntax
C# Visual Basic Visual C++
public RegularSubscriptionDefinitionType RegularSubscription { get; set; }
Public Property RegularSubscription As RegularSubscriptionDefinitionType
    Get
    Set
public:
property RegularSubscriptionDefinitionType^ RegularSubscription {
    RegularSubscriptionDefinitionType^ get ();
    void set (RegularSubscriptionDefinitionType^ value);
}


ReturnPolicyEnabled Property

ReturnPolicyEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ReturnPolicyEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ReturnPolicyEnabledDefinitionType ReturnPolicyEnabled { get; set; }
Public Property ReturnPolicyEnabled As ReturnPolicyEnabledDefinitionType
    Get
    Set
public:
property ReturnPolicyEnabledDefinitionType^ ReturnPolicyEnabled {
    ReturnPolicyEnabledDefinitionType^ get ();
    void set (ReturnPolicyEnabledDefinitionType^ value);
}


ReturnPolicyProfileCategoryGroup Property

ReturnPolicyProfileCategoryGroup Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ReturnPolicyProfileCategoryGroup
Declaration Syntax
C# Visual Basic Visual C++
public ProfileCategoryGroupDefinitionType ReturnPolicyProfileCategoryGroup { get; set; }
Public Property ReturnPolicyProfileCategoryGroup As ProfileCategoryGroupDefinitionType
    Get
    Set
public:
property ProfileCategoryGroupDefinitionType^ ReturnPolicyProfileCategoryGroup {
    ProfileCategoryGroupDefinitionType^ get ();
    void set (ProfileCategoryGroupDefinitionType^ value);
}


RevisePriceAllowed Property

RevisePriceAllowed Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► RevisePriceAllowed
Declaration Syntax
C# Visual Basic Visual C++
public RevisePriceAllowedDefinitionType RevisePriceAllowed { get; set; }
Public Property RevisePriceAllowed As RevisePriceAllowedDefinitionType
    Get
    Set
public:
property RevisePriceAllowedDefinitionType^ RevisePriceAllowed {
    RevisePriceAllowedDefinitionType^ get ();
    void set (RevisePriceAllowedDefinitionType^ value);
}


ReviseQuantityAllowed Property

ReviseQuantityAllowed Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ReviseQuantityAllowed
Declaration Syntax
C# Visual Basic Visual C++
public ReviseQuantityAllowedDefinitionType ReviseQuantityAllowed { get; set; }
Public Property ReviseQuantityAllowed As ReviseQuantityAllowedDefinitionType
    Get
    Set
public:
property ReviseQuantityAllowedDefinitionType^ ReviseQuantityAllowed {
    ReviseQuantityAllowedDefinitionType^ get ();
    void set (ReviseQuantityAllowedDefinitionType^ value);
}


SafePaymentRequired Property

SafePaymentRequired Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► SafePaymentRequired
Declaration Syntax
C# Visual Basic Visual C++
public SafePaymentRequiredDefinitionType SafePaymentRequired { get; set; }
Public Property SafePaymentRequired As SafePaymentRequiredDefinitionType
    Get
    Set
public:
property SafePaymentRequiredDefinitionType^ SafePaymentRequired {
    SafePaymentRequiredDefinitionType^ get ();
    void set (SafePaymentRequiredDefinitionType^ value);
}


SellerContactDetailsEnabled Property

SellerContactDetailsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► SellerContactDetailsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public SellerContactDetailsEnabledDefinitionType SellerContactDetailsEnabled { get; set; }
Public Property SellerContactDetailsEnabled As SellerContactDetailsEnabledDefinitionType
    Get
    Set
public:
property SellerContactDetailsEnabledDefinitionType^ SellerContactDetailsEnabled {
    SellerContactDetailsEnabledDefinitionType^ get ();
    void set (SellerContactDetailsEnabledDefinitionType^ value);
}


SellerProvidedTitleSupported Property

SellerProvidedTitleSupported Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► SellerProvidedTitleSupported
Declaration Syntax
C# Visual Basic Visual C++
public SellerProvidedTitleSupportedDefinitionType SellerProvidedTitleSupported { get; set; }
Public Property SellerProvidedTitleSupported As SellerProvidedTitleSupportedDefinitionType
    Get
    Set
public:
property SellerProvidedTitleSupportedDefinitionType^ SellerProvidedTitleSupported {
    SellerProvidedTitleSupportedDefinitionType^ get ();
    void set (SellerProvidedTitleSupportedDefinitionType^ value);
}


ShippingProfileCategoryGroup Property

ShippingProfileCategoryGroup Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ShippingProfileCategoryGroup
Declaration Syntax
C# Visual Basic Visual C++
public ProfileCategoryGroupDefinitionType ShippingProfileCategoryGroup { get; set; }
Public Property ShippingProfileCategoryGroup As ProfileCategoryGroupDefinitionType
    Get
    Set
public:
property ProfileCategoryGroupDefinitionType^ ShippingProfileCategoryGroup {
    ProfileCategoryGroupDefinitionType^ get ();
    void set (ProfileCategoryGroupDefinitionType^ value);
}


ShippingTermsRequired Property

ShippingTermsRequired Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ShippingTermsRequired
Declaration Syntax
C# Visual Basic Visual C++
public ShippingTermRequiredDefinitionType ShippingTermsRequired { get; set; }
Public Property ShippingTermsRequired As ShippingTermRequiredDefinitionType
    Get
    Set
public:
property ShippingTermRequiredDefinitionType^ ShippingTermsRequired {
    ShippingTermRequiredDefinitionType^ get ();
    void set (ShippingTermRequiredDefinitionType^ value);
}


SkypeMeNonTransactionalEnabled Property

SkypeMeNonTransactionalEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► SkypeMeNonTransactionalEnabled
Declaration Syntax
C# Visual Basic Visual C++
public SkypeMeNonTransactionalEnabledDefinitionType SkypeMeNonTransactionalEnabled { get; set; }
Public Property SkypeMeNonTransactionalEnabled As SkypeMeNonTransactionalEnabledDefinitionType
    Get
    Set
public:
property SkypeMeNonTransactionalEnabledDefinitionType^ SkypeMeNonTransactionalEnabled {
    SkypeMeNonTransactionalEnabledDefinitionType^ get ();
    void set (SkypeMeNonTransactionalEnabledDefinitionType^ value);
}


SkypeMeTransactionalEnabled Property

SkypeMeTransactionalEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► SkypeMeTransactionalEnabled
Declaration Syntax
C# Visual Basic Visual C++
public SkypeMeTransactionalEnabledDefinitionType SkypeMeTransactionalEnabled { get; set; }
Public Property SkypeMeTransactionalEnabled As SkypeMeTransactionalEnabledDefinitionType
    Get
    Set
public:
property SkypeMeTransactionalEnabledDefinitionType^ SkypeMeTransactionalEnabled {
    SkypeMeTransactionalEnabledDefinitionType^ get ();
    void set (SkypeMeTransactionalEnabledDefinitionType^ value);
}


SpecialitySubscription Property

SpecialitySubscription Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► SpecialitySubscription
Declaration Syntax
C# Visual Basic Visual C++
public SpecialitySubscriptionDefinitionType SpecialitySubscription { get; set; }
Public Property SpecialitySubscription As SpecialitySubscriptionDefinitionType
    Get
    Set
public:
property SpecialitySubscriptionDefinitionType^ SpecialitySubscription {
    SpecialitySubscriptionDefinitionType^ get ();
    void set (SpecialitySubscriptionDefinitionType^ value);
}


StoreInventoryEnabled Property

StoreInventoryEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► StoreInventoryEnabled
Declaration Syntax
C# Visual Basic Visual C++
public StoreInventoryEnabledDefinitionType StoreInventoryEnabled { get; set; }
Public Property StoreInventoryEnabled As StoreInventoryEnabledDefinitionType
    Get
    Set
public:
property StoreInventoryEnabledDefinitionType^ StoreInventoryEnabled {
    StoreInventoryEnabledDefinitionType^ get ();
    void set (StoreInventoryEnabledDefinitionType^ value);
}


StoreOwnerExtendedListingDurations Property

StoreOwnerExtendedListingDurations Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► StoreOwnerExtendedListingDurations
Declaration Syntax
C# Visual Basic Visual C++
public StoreOwnerExtendedListingDurationsDefinitionType StoreOwnerExtendedListingDurations { get; set; }
Public Property StoreOwnerExtendedListingDurations As StoreOwnerExtendedListingDurationsDefinitionType
    Get
    Set
public:
property StoreOwnerExtendedListingDurationsDefinitionType^ StoreOwnerExtendedListingDurations {
    StoreOwnerExtendedListingDurationsDefinitionType^ get ();
    void set (StoreOwnerExtendedListingDurationsDefinitionType^ value);
}


StoreOwnerExtendedListingDurationsEnabled Property

StoreOwnerExtendedListingDurationsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► StoreOwnerExtendedListingDurationsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public StoreOwnerExtendedListingDurationsEnabledDefinitionType StoreOwnerExtendedListingDurationsEnabled { get; set; }
Public Property StoreOwnerExtendedListingDurationsEnabled As StoreOwnerExtendedListingDurationsEnabledDefinitionType
    Get
    Set
public:
property StoreOwnerExtendedListingDurationsEnabledDefinitionType^ StoreOwnerExtendedListingDurationsEnabled {
    StoreOwnerExtendedListingDurationsEnabledDefinitionType^ get ();
    void set (StoreOwnerExtendedListingDurationsEnabledDefinitionType^ value);
}


TransactionConfirmationRequestEnabled Property

TransactionConfirmationRequestEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► TransactionConfirmationRequestEnabled
Declaration Syntax
C# Visual Basic Visual C++
public TCREnabledDefinitionType TransactionConfirmationRequestEnabled { get; set; }
Public Property TransactionConfirmationRequestEnabled As TCREnabledDefinitionType
    Get
    Set
public:
property TCREnabledDefinitionType^ TransactionConfirmationRequestEnabled {
    TCREnabledDefinitionType^ get ();
    void set (TCREnabledDefinitionType^ value);
}


UPCEnabled Property

UPCEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► UPCEnabled
Declaration Syntax
C# Visual Basic Visual C++
public UPCEnabledDefinitionType UPCEnabled { get; set; }
Public Property UPCEnabled As UPCEnabledDefinitionType
    Get
    Set
public:
property UPCEnabledDefinitionType^ UPCEnabled {
    UPCEnabledDefinitionType^ get ();
    void set (UPCEnabledDefinitionType^ value);
}


UPCIdentifierEnabled Property

UPCIdentifierEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► UPCIdentifierEnabled
Declaration Syntax
C# Visual Basic Visual C++
public UPCIdentifierEnabledDefinitionType UPCIdentifierEnabled { get; set; }
Public Property UPCIdentifierEnabled As UPCIdentifierEnabledDefinitionType
    Get
    Set
public:
property UPCIdentifierEnabledDefinitionType^ UPCIdentifierEnabled {
    UPCIdentifierEnabledDefinitionType^ get ();
    void set (UPCIdentifierEnabledDefinitionType^ value);
}


UserConsentRequired Property

UserConsentRequired Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► UserConsentRequired
Declaration Syntax
C# Visual Basic Visual C++
public UserConsentRequiredDefinitionType UserConsentRequired { get; set; }
Public Property UserConsentRequired As UserConsentRequiredDefinitionType
    Get
    Set
public:
property UserConsentRequiredDefinitionType^ UserConsentRequired {
    UserConsentRequiredDefinitionType^ get ();
    void set (UserConsentRequiredDefinitionType^ value);
}


ValueCategory Property

ValueCategory Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ValueCategory
Declaration Syntax
C# Visual Basic Visual C++
public ValueCategoryDefinitionType ValueCategory { get; set; }
Public Property ValueCategory As ValueCategoryDefinitionType
    Get
    Set
public:
property ValueCategoryDefinitionType^ ValueCategory {
    ValueCategoryDefinitionType^ get ();
    void set (ValueCategoryDefinitionType^ value);
}


ValuePackEnabled Property

ValuePackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► ValuePackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ValuePackEnabledDefinitionType ValuePackEnabled { get; set; }
Public Property ValuePackEnabled As ValuePackEnabledDefinitionType
    Get
    Set
public:
property ValuePackEnabledDefinitionType^ ValuePackEnabled {
    ValuePackEnabledDefinitionType^ get ();
    void set (ValuePackEnabledDefinitionType^ value);
}


VariationsEnabled Property

VariationsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► VariationsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public VariationsEnabledDefinitionType VariationsEnabled { get; set; }
Public Property VariationsEnabled As VariationsEnabledDefinitionType
    Get
    Set
public:
property VariationsEnabledDefinitionType^ VariationsEnabled {
    VariationsEnabledDefinitionType^ get ();
    void set (VariationsEnabledDefinitionType^ value);
}


VINSupported Property

VINSupported Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► VINSupported
Declaration Syntax
C# Visual Basic Visual C++
public VINSupportedDefinitionType VINSupported { get; set; }
Public Property VINSupported As VINSupportedDefinitionType
    Get
    Set
public:
property VINSupportedDefinitionType^ VINSupported {
    VINSupportedDefinitionType^ get ();
    void set (VINSupportedDefinitionType^ value);
}


VRMSupported Property

VRMSupported Property
Namespaces ► eBay.Service.Core.Soap ► FeatureDefinitionsType ► VRMSupported
Declaration Syntax
C# Visual Basic Visual C++
public VRMSupportedDefinitionType VRMSupported { get; set; }
Public Property VRMSupported As VRMSupportedDefinitionType
    Get
    Set
public:
property VRMSupportedDefinitionType^ VRMSupported {
    VRMSupportedDefinitionType^ get ();
    void set (VRMSupportedDefinitionType^ value);
}


FeaturedFirstCodeType Enumeration

FeaturedFirstCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► FeaturedFirstCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum FeaturedFirstCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration FeaturedFirstCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class FeaturedFirstCodeType
Members
Member | Description
Enabled |
Disabled |
PowerSellerOnly |
TopRatedSellerOnly |
CustomCode |
Remarks


FeaturedPlusCodeType Enumeration

FeaturedPlusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► FeaturedPlusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum FeaturedPlusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration FeaturedPlusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class FeaturedPlusCodeType
Members
Member | Description
Enabled |
Disabled |
PowerSellerOnly |
TopRatedSellerOnly |
CustomCode |
Remarks


FeatureEligibilityType Class

FeatureEligibilityType Class
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FeatureEligibilityType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FeatureEligibilityType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FeatureEligibilityType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeatureEligibilityType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QualifiedForAuctionOneDayDuration |
 | QualifiedForAuctionOneDayDurationSpecified |
 | QualifiedForFixedPriceOneDayDuration |
 | QualifiedForFixedPriceOneDayDurationSpecified |
 | QualifiesForBuyItNow |
 | QualifiesForBuyItNowMultiple |
 | QualifiesForBuyItNowMultipleSpecified |
 | QualifiesForBuyItNowSpecified |
 | QualifiesForVariations |
 | QualifiesForVariationsSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
FeatureEligibilityType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FeatureEligibilityType Constructor

FeatureEligibilityType Constructor
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► FeatureEligibilityType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeatureEligibilityType()
Public Sub New
public:
FeatureEligibilityType()


QualifiedForAuctionOneDayDuration Property

QualifiedForAuctionOneDayDuration Property
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► QualifiedForAuctionOneDayDuration
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiedForAuctionOneDayDuration { get; set; }
Public Property QualifiedForAuctionOneDayDuration As Boolean
    Get
    Set
public:
property bool QualifiedForAuctionOneDayDuration {
    bool get ();
    void set (bool value);
}


QualifiedForAuctionOneDayDurationSpecified Property

QualifiedForAuctionOneDayDurationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► QualifiedForAuctionOneDayDurationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiedForAuctionOneDayDurationSpecified { get; set; }
Public Property QualifiedForAuctionOneDayDurationSpecified As Boolean
    Get
    Set
public:
property bool QualifiedForAuctionOneDayDurationSpecified {
    bool get ();
    void set (bool value);
}


QualifiedForFixedPriceOneDayDuration Property

QualifiedForFixedPriceOneDayDuration Property
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► QualifiedForFixedPriceOneDayDuration
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiedForFixedPriceOneDayDuration { get; set; }
Public Property QualifiedForFixedPriceOneDayDuration As Boolean
    Get
    Set
public:
property bool QualifiedForFixedPriceOneDayDuration {
    bool get ();
    void set (bool value);
}


QualifiedForFixedPriceOneDayDurationSpecified Property

QualifiedForFixedPriceOneDayDurationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► QualifiedForFixedPriceOneDayDurationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiedForFixedPriceOneDayDurationSpecified { get; set; }
Public Property QualifiedForFixedPriceOneDayDurationSpecified As Boolean
    Get
    Set
public:
property bool QualifiedForFixedPriceOneDayDurationSpecified {
    bool get ();
    void set (bool value);
}


QualifiesForBuyItNow Property

QualifiesForBuyItNow Property
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► QualifiesForBuyItNow
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiesForBuyItNow { get; set; }
Public Property QualifiesForBuyItNow As Boolean
    Get
    Set
public:
property bool QualifiesForBuyItNow {
    bool get ();
    void set (bool value);
}


QualifiesForBuyItNowMultiple Property

QualifiesForBuyItNowMultiple Property
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► QualifiesForBuyItNowMultiple
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiesForBuyItNowMultiple { get; set; }
Public Property QualifiesForBuyItNowMultiple As Boolean
    Get
    Set
public:
property bool QualifiesForBuyItNowMultiple {
    bool get ();
    void set (bool value);
}


QualifiesForBuyItNowMultipleSpecified Property

QualifiesForBuyItNowMultipleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► QualifiesForBuyItNowMultipleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiesForBuyItNowMultipleSpecified { get; set; }
Public Property QualifiesForBuyItNowMultipleSpecified As Boolean
    Get
    Set
public:
property bool QualifiesForBuyItNowMultipleSpecified {
    bool get ();
    void set (bool value);
}


QualifiesForBuyItNowSpecified Property

QualifiesForBuyItNowSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► QualifiesForBuyItNowSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiesForBuyItNowSpecified { get; set; }
Public Property QualifiesForBuyItNowSpecified As Boolean
    Get
    Set
public:
property bool QualifiesForBuyItNowSpecified {
    bool get ();
    void set (bool value);
}


QualifiesForVariations Property

QualifiesForVariations Property
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► QualifiesForVariations
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiesForVariations { get; set; }
Public Property QualifiesForVariations As Boolean
    Get
    Set
public:
property bool QualifiesForVariations {
    bool get ();
    void set (bool value);
}


QualifiesForVariationsSpecified Property

QualifiesForVariationsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeatureEligibilityType ► QualifiesForVariationsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiesForVariationsSpecified { get; set; }
Public Property QualifiesForVariationsSpecified As Boolean
    Get
    Set
public:
property bool QualifiesForVariationsSpecified {
    bool get ();
    void set (bool value);
}


FeatureIDCodeType Enumeration

FeatureIDCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum FeatureIDCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration FeatureIDCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class FeatureIDCodeType
Members
Member | Description
ListingDurations |
BestOfferEnabled |
DutchBINEnabled |
ShippingTermsRequired |
UserConsentRequired |
HomePageFeaturedEnabled |
AdFormatEnabled |
DigitalDeliveryEnabled |
BestOfferCounterEnabled |
BestOfferAutoDeclineEnabled |
ProPack |
BasicUpgradePack |
ValuePack |
ProPackPlus |
LocalMarketSpecialitySubscription |
LocalMarketRegularSubscription |
LocalMarketPremiumSubscription |
LocalMarketNonSubscription |
ExpressEnabled |
ExpressPicturesRequired |
ExpressConditionRequired |
SellerContactDetailsEnabled |
CustomCode |
MinimumReservePrice |
TransactionConfirmationRequestEnabled |
StoreInventoryEnabled |
LocalListingDistances |
SkypeMeTransactionalEnabled |
SkypeMeNonTransactionalEnabled |
ClassifiedAdPaymentMethodEnabled |
ClassifiedAdShippingMethodEnabled |
ClassifiedAdBestOfferEnabled |
ClassifiedAdCounterOfferEnabled |
ClassifiedAdAutoDeclineEnabled |
ClassifiedAdContactByEmailEnabled |
ClassifiedAdContactByPhoneEnabled |
SafePaymentRequired |
MaximumBestOffersAllowed |
ClassifiedAdMaximumBestOffersAllowed |
ClassifiedAdContactByEmailAvailable |
ClassifiedAdPayPerLeadEnabled |
ItemSpecificsEnabled |
PaisaPayFullEscrowEnabled |
ISBNIdentifierEnabled |
UPCIdentifierEnabled |
EANIdentifierEnabled |
BrandMPNIdentifierEnabled |
ClassifiedAdAutoAcceptEnabled |
BestOfferAutoAcceptEnabled |
CrossBorderTradeEnabled |
PayPalBuyerProtectionEnabled |
BuyerGuaranteeEnabled |
INEscrowWorkflowTimeline |
CombinedFixedPriceTreatment |
GalleryFeaturedDurations |
PayPalRequired |
eBayMotorsProAdFormatEnabled |
eBayMotorsProContactByPhoneEnabled |
eBayMotorsProContactByAddressEnabled |
eBayMotorsProCompanyNameEnabled |
eBayMotorsProContactByEmailEnabled |
eBayMotorsProBestOfferEnabled |
eBayMotorsProAutoAcceptEnabled |
eBayMotorsProAutoDeclineEnabled |
eBayMotorsProPaymentMethodCheckOutEnabled |
eBayMotorsProShippingMethodEnabled |
eBayMotorsProCounterOfferEnabled |
eBayMotorsProSellerContactDetailsEnabled |
LocalMarketAdFormatEnabled |
LocalMarketContactByPhoneEnabled |
LocalMarketContactByAddressEnabled |
LocalMarketCompanyNameEnabled |
LocalMarketContactByEmailEnabled |
LocalMarketBestOfferEnabled |
LocalMarketAutoAcceptEnabled |
LocalMarketAutoDeclineEnabled |
LocalMarketPaymentMethodCheckOutEnabled |
LocalMarketShippingMethodEnabled |
LocalMarketCounterOfferEnabled |
LocalMarketSellerContactDetailsEnabled |
ClassifiedAdContactByAddressEnabled |
ClassifiedAdCompanyNameEnabled |
SpecialitySubscription |
RegularSubscription |
PremiumSubscription |
NonSubscription |
IntangibleEnabled |
PayPalRequiredForStoreOwner |
ReviseQuantityAllowed |
RevisePriceAllowed |
StoreOwnerExtendedListingDurationsEnabled |
StoreOwnerExtendedListingDurations |
ReturnPolicyEnabled |
HandlingTimeEnabled |
PaymentMethods |
MaxFlatShippingCost |
MaxFlatShippingCostCBTExempt |
Group1MaxFlatShippingCost |
Group2MaxFlatShippingCost |
Group3MaxFlatShippingCost |
VariationsEnabled |
AttributeConversionEnabled |
FreeGalleryPlusEnabled |
FreePicturePackEnabled |
CompatibilityEnabled |
MinCompatibleApplications |
MaxCompatibleApplications |
ConditionEnabled |
ConditionValues |
ValueCategory |
ProductCreationEnabled |
EANEnabled |
ISBNEnabled |
UPCEnabled |
MaxGranularFitmentCount |
CompatibleVehicleType |
PaymentOptionsGroup |
ShippingProfileCategoryGroup |
PaymentProfileCategoryGroup |
ReturnPolicyProfileCategoryGroup |
VINSupported |
VRMSupported |
SellerProvidedTitleSupported |
DepositSupported |
GlobalShippingEnabled |
AdditionalCompatibilityEnabled |
PickupDropOffEnabled |
DigitalGoodDeliveryEnabled |
EpidSupported |
KTypeSupported |
Remarks


FeatureIDCodeTypeCollection Class

FeatureIDCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class FeatureIDCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class FeatureIDCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class FeatureIDCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeatureIDCodeTypeCollection()()()() |
 | FeatureIDCodeTypeCollection(array<FeatureIDCodeType>[]()[][]) |
 | FeatureIDCodeTypeCollection(FeatureIDCodeTypeCollection) |
 | Add(FeatureIDCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<FeatureIDCodeType>[]()[][]) |
 | AddRange(FeatureIDCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(FeatureIDCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<FeatureIDCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(FeatureIDCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, FeatureIDCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(FeatureIDCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | FeatureIDCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► Add(FeatureIDCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    FeatureIDCodeType item
)
Public Function Add ( _
    item As FeatureIDCodeType _
) As Integer
public:
int Add(
    FeatureIDCodeType item
)
Parameters
item (FeatureIDCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<FeatureIDCodeType>[]()[][]) |
 | AddRange(FeatureIDCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► AddRange(array<FeatureIDCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    FeatureIDCodeType[] items
)
Public Sub AddRange ( _
    items As FeatureIDCodeType() _
)
public:
void AddRange(
    array<FeatureIDCodeType>^ items
)
Parameters
items (array< FeatureIDCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► AddRange(FeatureIDCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    FeatureIDCodeTypeCollection items
)
Public Sub AddRange ( _
    items As FeatureIDCodeTypeCollection _
)
public:
void AddRange(
    FeatureIDCodeTypeCollection^ items
)
Parameters
items (FeatureIDCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► Contains(FeatureIDCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    FeatureIDCodeType item
)
Public Function Contains ( _
    item As FeatureIDCodeType _
) As Boolean
public:
bool Contains(
    FeatureIDCodeType item
)
Parameters
item (FeatureIDCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► CopyTo(array<FeatureIDCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    FeatureIDCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As FeatureIDCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<FeatureIDCodeType>^ items,
    int index
)
Parameters
items (array< FeatureIDCodeType >[]()[][])
index (Int32)


FeatureIDCodeTypeCollection Constructor

FeatureIDCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► FeatureIDCodeTypeCollection()()()()
Members
Icon | Member | Description
 | FeatureIDCodeTypeCollection()()()() |
 | FeatureIDCodeTypeCollection(array<FeatureIDCodeType>[]()[][]) |
 | FeatureIDCodeTypeCollection(FeatureIDCodeTypeCollection) |


FeatureIDCodeTypeCollection Constructor

FeatureIDCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► FeatureIDCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeatureIDCodeTypeCollection()
Public Sub New
public:
FeatureIDCodeTypeCollection()


FeatureIDCodeTypeCollection Constructor (items)

FeatureIDCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► FeatureIDCodeTypeCollection(array<FeatureIDCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public FeatureIDCodeTypeCollection(
    FeatureIDCodeType[] items
)
Public Sub New ( _
    items As FeatureIDCodeType() _
)
public:
FeatureIDCodeTypeCollection(
    array<FeatureIDCodeType>^ items
)
Parameters
items (array< FeatureIDCodeType >[]()[][])


FeatureIDCodeTypeCollection Constructor (items)

FeatureIDCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► FeatureIDCodeTypeCollection(FeatureIDCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public FeatureIDCodeTypeCollection(
    FeatureIDCodeTypeCollection items
)
Public Sub New ( _
    items As FeatureIDCodeTypeCollection _
)
public:
FeatureIDCodeTypeCollection(
    FeatureIDCodeTypeCollection^ items
)
Parameters
items (FeatureIDCodeTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► IndexOf(FeatureIDCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    FeatureIDCodeType item
)
Public Function IndexOf ( _
    item As FeatureIDCodeType _
) As Integer
public:
int IndexOf(
    FeatureIDCodeType item
)
Parameters
item (FeatureIDCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► Insert(Int32, FeatureIDCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    FeatureIDCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As FeatureIDCodeType _
)
public:
void Insert(
    int index,
    FeatureIDCodeType item
)
Parameters
index (Int32)
item (FeatureIDCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public FeatureIDCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As FeatureIDCodeType
    Get
    Set
public:
property FeatureIDCodeType default[int index] {
    FeatureIDCodeType get (int index);
    void set (int index, FeatureIDCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public FeatureIDCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As FeatureIDCodeType
public:
FeatureIDCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► Remove(FeatureIDCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    FeatureIDCodeType item
)
Public Sub Remove ( _
    item As FeatureIDCodeType _
)
public:
void Remove(
    FeatureIDCodeType item
)
Parameters
item (FeatureIDCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeatureIDCodeType[] ToArray()
Public Function ToArray As FeatureIDCodeType()
public:
array<FeatureIDCodeType>^ ToArray()
Return Value


FedExRateOptionCodeType Enumeration

FedExRateOptionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► FedExRateOptionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum FedExRateOptionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration FedExRateOptionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class FedExRateOptionCodeType
Members
Member | Description
FedExStandardList |
FedExCounter |
FedExDiscounted |
CustomCode |
Remarks


FeedbackDetailType Class

FeedbackDetailType Class
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FeedbackDetailType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FeedbackDetailType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FeedbackDetailType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeedbackDetailType()()()() |
 | Any |
 | CommentingUser |
 | CommentingUserScore |
 | CommentingUserScoreSpecified |
 | CommentReplaced |
 | CommentReplacedSpecified |
 | CommentText |
 | CommentTime |
 | CommentTimeSpecified |
 | CommentType |
 | CommentTypeSpecified |
 | Countable |
 | CountableSpecified |
 | Equals(Object) | (Inherited from Object.)
 | FeedbackID |
 | FeedbackRatingStar |
 | FeedbackRatingStarSpecified |
 | FeedbackResponse |
 | FeedbackRevised |
 | FeedbackRevisedSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | Followup |
 | FollowUpReplaced |
 | FollowUpReplacedSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | ItemPrice |
 | ItemTitle |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderLineItemID |
 | ResponseReplaced |
 | ResponseReplacedSpecified |
 | Role |
 | RoleSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
Remarks
Inheritance Hierarchy
Object
FeedbackDetailType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CommentingUser Property

CommentingUser Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► CommentingUser
Declaration Syntax
C# Visual Basic Visual C++
public string CommentingUser { get; set; }
Public Property CommentingUser As String
    Get
    Set
public:
property String^ CommentingUser {
    String^ get ();
    void set (String^ value);
}


CommentingUserScore Property

CommentingUserScore Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► CommentingUserScore
Declaration Syntax
C# Visual Basic Visual C++
public int CommentingUserScore { get; set; }
Public Property CommentingUserScore As Integer
    Get
    Set
public:
property int CommentingUserScore {
    int get ();
    void set (int value);
}


CommentingUserScoreSpecified Property

CommentingUserScoreSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► CommentingUserScoreSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CommentingUserScoreSpecified { get; set; }
Public Property CommentingUserScoreSpecified As Boolean
    Get
    Set
public:
property bool CommentingUserScoreSpecified {
    bool get ();
    void set (bool value);
}


CommentReplaced Property

CommentReplaced Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► CommentReplaced
Declaration Syntax
C# Visual Basic Visual C++
public bool CommentReplaced { get; set; }
Public Property CommentReplaced As Boolean
    Get
    Set
public:
property bool CommentReplaced {
    bool get ();
    void set (bool value);
}


CommentReplacedSpecified Property

CommentReplacedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► CommentReplacedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CommentReplacedSpecified { get; set; }
Public Property CommentReplacedSpecified As Boolean
    Get
    Set
public:
property bool CommentReplacedSpecified {
    bool get ();
    void set (bool value);
}


CommentText Property

CommentText Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► CommentText
Declaration Syntax
C# Visual Basic Visual C++
public string CommentText { get; set; }
Public Property CommentText As String
    Get
    Set
public:
property String^ CommentText {
    String^ get ();
    void set (String^ value);
}


CommentTime Property

CommentTime Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► CommentTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CommentTime { get; set; }
Public Property CommentTime As DateTime
    Get
    Set
public:
property DateTime CommentTime {
    DateTime get ();
    void set (DateTime value);
}


CommentTimeSpecified Property

CommentTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► CommentTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CommentTimeSpecified { get; set; }
Public Property CommentTimeSpecified As Boolean
    Get
    Set
public:
property bool CommentTimeSpecified {
    bool get ();
    void set (bool value);
}


CommentType Property

CommentType Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► CommentType
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeType CommentType { get; set; }
Public Property CommentType As CommentTypeCodeType
    Get
    Set
public:
property CommentTypeCodeType CommentType {
    CommentTypeCodeType get ();
    void set (CommentTypeCodeType value);
}


CommentTypeSpecified Property

CommentTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► CommentTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CommentTypeSpecified { get; set; }
Public Property CommentTypeSpecified As Boolean
    Get
    Set
public:
property bool CommentTypeSpecified {
    bool get ();
    void set (bool value);
}


Countable Property

Countable Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► Countable
Declaration Syntax
C# Visual Basic Visual C++
public bool Countable { get; set; }
Public Property Countable As Boolean
    Get
    Set
public:
property bool Countable {
    bool get ();
    void set (bool value);
}


CountableSpecified Property

CountableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► CountableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CountableSpecified { get; set; }
Public Property CountableSpecified As Boolean
    Get
    Set
public:
property bool CountableSpecified {
    bool get ();
    void set (bool value);
}


FeedbackDetailType Constructor

FeedbackDetailType Constructor
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► FeedbackDetailType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailType()
Public Sub New
public:
FeedbackDetailType()


FeedbackID Property

FeedbackID Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► FeedbackID
Declaration Syntax
C# Visual Basic Visual C++
public string FeedbackID { get; set; }
Public Property FeedbackID As String
    Get
    Set
public:
property String^ FeedbackID {
    String^ get ();
    void set (String^ value);
}


FeedbackRatingStar Property

FeedbackRatingStar Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► FeedbackRatingStar
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackRatingStarCodeType FeedbackRatingStar { get; set; }
Public Property FeedbackRatingStar As FeedbackRatingStarCodeType
    Get
    Set
public:
property FeedbackRatingStarCodeType FeedbackRatingStar {
    FeedbackRatingStarCodeType get ();
    void set (FeedbackRatingStarCodeType value);
}


FeedbackRatingStarSpecified Property

FeedbackRatingStarSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► FeedbackRatingStarSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackRatingStarSpecified { get; set; }
Public Property FeedbackRatingStarSpecified As Boolean
    Get
    Set
public:
property bool FeedbackRatingStarSpecified {
    bool get ();
    void set (bool value);
}


FeedbackResponse Property

FeedbackResponse Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► FeedbackResponse
Declaration Syntax
C# Visual Basic Visual C++
public string FeedbackResponse { get; set; }
Public Property FeedbackResponse As String
    Get
    Set
public:
property String^ FeedbackResponse {
    String^ get ();
    void set (String^ value);
}


FeedbackRevised Property

FeedbackRevised Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► FeedbackRevised
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackRevised { get; set; }
Public Property FeedbackRevised As Boolean
    Get
    Set
public:
property bool FeedbackRevised {
    bool get ();
    void set (bool value);
}


FeedbackRevisedSpecified Property

FeedbackRevisedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► FeedbackRevisedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackRevisedSpecified { get; set; }
Public Property FeedbackRevisedSpecified As Boolean
    Get
    Set
public:
property bool FeedbackRevisedSpecified {
    bool get ();
    void set (bool value);
}


Followup Property

Followup Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► Followup
Declaration Syntax
C# Visual Basic Visual C++
public string Followup { get; set; }
Public Property Followup As String
    Get
    Set
public:
property String^ Followup {
    String^ get ();
    void set (String^ value);
}


FollowUpReplaced Property

FollowUpReplaced Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► FollowUpReplaced
Declaration Syntax
C# Visual Basic Visual C++
public bool FollowUpReplaced { get; set; }
Public Property FollowUpReplaced As Boolean
    Get
    Set
public:
property bool FollowUpReplaced {
    bool get ();
    void set (bool value);
}


FollowUpReplacedSpecified Property

FollowUpReplacedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► FollowUpReplacedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FollowUpReplacedSpecified { get; set; }
Public Property FollowUpReplacedSpecified As Boolean
    Get
    Set
public:
property bool FollowUpReplacedSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ItemPrice Property

ItemPrice Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► ItemPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ItemPrice { get; set; }
Public Property ItemPrice As AmountType
    Get
    Set
public:
property AmountType^ ItemPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


ItemTitle Property

ItemTitle Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► ItemTitle
Declaration Syntax
C# Visual Basic Visual C++
public string ItemTitle { get; set; }
Public Property ItemTitle As String
    Get
    Set
public:
property String^ ItemTitle {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


ResponseReplaced Property

ResponseReplaced Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► ResponseReplaced
Declaration Syntax
C# Visual Basic Visual C++
public bool ResponseReplaced { get; set; }
Public Property ResponseReplaced As Boolean
    Get
    Set
public:
property bool ResponseReplaced {
    bool get ();
    void set (bool value);
}


ResponseReplacedSpecified Property

ResponseReplacedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► ResponseReplacedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ResponseReplacedSpecified { get; set; }
Public Property ResponseReplacedSpecified As Boolean
    Get
    Set
public:
property bool ResponseReplacedSpecified {
    bool get ();
    void set (bool value);
}


Role Property

Role Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► Role
Declaration Syntax
C# Visual Basic Visual C++
public TradingRoleCodeType Role { get; set; }
Public Property Role As TradingRoleCodeType
    Get
    Set
public:
property TradingRoleCodeType Role {
    TradingRoleCodeType get ();
    void set (TradingRoleCodeType value);
}


RoleSpecified Property

RoleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► RoleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RoleSpecified { get; set; }
Public Property RoleSpecified As Boolean
    Get
    Set
public:
property bool RoleSpecified {
    bool get ();
    void set (bool value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


FeedbackDetailTypeCollection Class

FeedbackDetailTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class FeedbackDetailTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class FeedbackDetailTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class FeedbackDetailTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeedbackDetailTypeCollection()()()() |
 | FeedbackDetailTypeCollection(array<FeedbackDetailType>[]()[][]) |
 | FeedbackDetailTypeCollection(FeedbackDetailTypeCollection) |
 | Add(FeedbackDetailType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<FeedbackDetailType>[]()[][]) |
 | AddRange(FeedbackDetailTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(FeedbackDetailType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<FeedbackDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(FeedbackDetailType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, FeedbackDetailType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(FeedbackDetailType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | FeedbackDetailTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► Add(FeedbackDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    FeedbackDetailType item
)
Public Function Add ( _
    item As FeedbackDetailType _
) As Integer
public:
int Add(
    FeedbackDetailType^ item
)
Parameters
item (FeedbackDetailType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<FeedbackDetailType>[]()[][]) |
 | AddRange(FeedbackDetailTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► AddRange(array<FeedbackDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    FeedbackDetailType[] items
)
Public Sub AddRange ( _
    items As FeedbackDetailType() _
)
public:
void AddRange(
    array<FeedbackDetailType^>^ items
)
Parameters
items (array< FeedbackDetailType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► AddRange(FeedbackDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    FeedbackDetailTypeCollection items
)
Public Sub AddRange ( _
    items As FeedbackDetailTypeCollection _
)
public:
void AddRange(
    FeedbackDetailTypeCollection^ items
)
Parameters
items (FeedbackDetailTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► Contains(FeedbackDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    FeedbackDetailType item
)
Public Function Contains ( _
    item As FeedbackDetailType _
) As Boolean
public:
bool Contains(
    FeedbackDetailType^ item
)
Parameters
item (FeedbackDetailType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► CopyTo(array<FeedbackDetailType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    FeedbackDetailType[] items,
    int index
)
Public Sub CopyTo ( _
    items As FeedbackDetailType(), _
    index As Integer _
)
public:
void CopyTo(
    array<FeedbackDetailType^>^ items,
    int index
)
Parameters
items (array< FeedbackDetailType >[]()[][])
index (Int32)


FeedbackDetailTypeCollection Constructor

FeedbackDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► FeedbackDetailTypeCollection()()()()
Members
Icon | Member | Description
 | FeedbackDetailTypeCollection()()()() |
 | FeedbackDetailTypeCollection(array<FeedbackDetailType>[]()[][]) |
 | FeedbackDetailTypeCollection(FeedbackDetailTypeCollection) |


FeedbackDetailTypeCollection Constructor

FeedbackDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► FeedbackDetailTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailTypeCollection()
Public Sub New
public:
FeedbackDetailTypeCollection()


FeedbackDetailTypeCollection Constructor (items)

FeedbackDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► FeedbackDetailTypeCollection(array<FeedbackDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailTypeCollection(
    FeedbackDetailType[] items
)
Public Sub New ( _
    items As FeedbackDetailType() _
)
public:
FeedbackDetailTypeCollection(
    array<FeedbackDetailType^>^ items
)
Parameters
items (array< FeedbackDetailType >[]()[][])


FeedbackDetailTypeCollection Constructor (items)

FeedbackDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► FeedbackDetailTypeCollection(FeedbackDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailTypeCollection(
    FeedbackDetailTypeCollection items
)
Public Sub New ( _
    items As FeedbackDetailTypeCollection _
)
public:
FeedbackDetailTypeCollection(
    FeedbackDetailTypeCollection^ items
)
Parameters
items (FeedbackDetailTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► IndexOf(FeedbackDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    FeedbackDetailType item
)
Public Function IndexOf ( _
    item As FeedbackDetailType _
) As Integer
public:
int IndexOf(
    FeedbackDetailType^ item
)
Parameters
item (FeedbackDetailType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► Insert(Int32, FeedbackDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    FeedbackDetailType item
)
Public Sub Insert ( _
    index As Integer, _
    item As FeedbackDetailType _
)
public:
void Insert(
    int index,
    FeedbackDetailType^ item
)
Parameters
index (Int32)
item (FeedbackDetailType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As FeedbackDetailType
    Get
    Set
public:
property FeedbackDetailType^ default[int index] {
    FeedbackDetailType^ get (int index);
    void set (int index, FeedbackDetailType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As FeedbackDetailType
public:
FeedbackDetailType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► Remove(FeedbackDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    FeedbackDetailType item
)
Public Sub Remove ( _
    item As FeedbackDetailType _
)
public:
void Remove(
    FeedbackDetailType^ item
)
Parameters
item (FeedbackDetailType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailType[] ToArray()
Public Function ToArray As FeedbackDetailType()
public:
array<FeedbackDetailType^>^ ToArray()
Return Value


FeedbackInfoType Class

FeedbackInfoType Class
Namespaces ► eBay.Service.Core.Soap ► FeedbackInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FeedbackInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FeedbackInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FeedbackInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeedbackInfoType()()()() |
 | Any |
 | CommentText |
 | CommentType |
 | CommentTypeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | TargetUser |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
FeedbackInfoType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CommentText Property

CommentText Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackInfoType ► CommentText
Declaration Syntax
C# Visual Basic Visual C++
public string CommentText { get; set; }
Public Property CommentText As String
    Get
    Set
public:
property String^ CommentText {
    String^ get ();
    void set (String^ value);
}


CommentType Property

CommentType Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackInfoType ► CommentType
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeType CommentType { get; set; }
Public Property CommentType As CommentTypeCodeType
    Get
    Set
public:
property CommentTypeCodeType CommentType {
    CommentTypeCodeType get ();
    void set (CommentTypeCodeType value);
}


CommentTypeSpecified Property

CommentTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackInfoType ► CommentTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CommentTypeSpecified { get; set; }
Public Property CommentTypeSpecified As Boolean
    Get
    Set
public:
property bool CommentTypeSpecified {
    bool get ();
    void set (bool value);
}


FeedbackInfoType Constructor

FeedbackInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► FeedbackInfoType ► FeedbackInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackInfoType()
Public Sub New
public:
FeedbackInfoType()


TargetUser Property

TargetUser Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackInfoType ► TargetUser
Declaration Syntax
C# Visual Basic Visual C++
public string TargetUser { get; set; }
Public Property TargetUser As String
    Get
    Set
public:
property String^ TargetUser {
    String^ get ();
    void set (String^ value);
}


FeedbackPeriodType Class

FeedbackPeriodType Class
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FeedbackPeriodType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FeedbackPeriodType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FeedbackPeriodType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeedbackPeriodType()()()() |
 | Any |
 | Count |
 | CountSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PeriodInDays |
 | PeriodInDaysSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
FeedbackPeriodType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Count Property

Count Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodType ► Count
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; set; }
Public Property Count As Integer
    Get
    Set
public:
property int Count {
    int get ();
    void set (int value);
}


CountSpecified Property

CountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodType ► CountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CountSpecified { get; set; }
Public Property CountSpecified As Boolean
    Get
    Set
public:
property bool CountSpecified {
    bool get ();
    void set (bool value);
}


FeedbackPeriodType Constructor

FeedbackPeriodType Constructor
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodType ► FeedbackPeriodType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodType()
Public Sub New
public:
FeedbackPeriodType()


PeriodInDays Property

PeriodInDays Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodType ► PeriodInDays
Declaration Syntax
C# Visual Basic Visual C++
public int PeriodInDays { get; set; }
Public Property PeriodInDays As Integer
    Get
    Set
public:
property int PeriodInDays {
    int get ();
    void set (int value);
}


PeriodInDaysSpecified Property

PeriodInDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodType ► PeriodInDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PeriodInDaysSpecified { get; set; }
Public Property PeriodInDaysSpecified As Boolean
    Get
    Set
public:
property bool PeriodInDaysSpecified {
    bool get ();
    void set (bool value);
}


FeedbackPeriodTypeCollection Class

FeedbackPeriodTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class FeedbackPeriodTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class FeedbackPeriodTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class FeedbackPeriodTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeedbackPeriodTypeCollection()()()() |
 | FeedbackPeriodTypeCollection(array<FeedbackPeriodType>[]()[][]) |
 | FeedbackPeriodTypeCollection(FeedbackPeriodTypeCollection) |
 | Add(FeedbackPeriodType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<FeedbackPeriodType>[]()[][]) |
 | AddRange(FeedbackPeriodTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(FeedbackPeriodType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<FeedbackPeriodType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(FeedbackPeriodType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, FeedbackPeriodType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(FeedbackPeriodType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | FeedbackPeriodTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► Add(FeedbackPeriodType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    FeedbackPeriodType item
)
Public Function Add ( _
    item As FeedbackPeriodType _
) As Integer
public:
int Add(
    FeedbackPeriodType^ item
)
Parameters
item (FeedbackPeriodType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<FeedbackPeriodType>[]()[][]) |
 | AddRange(FeedbackPeriodTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► AddRange(array<FeedbackPeriodType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    FeedbackPeriodType[] items
)
Public Sub AddRange ( _
    items As FeedbackPeriodType() _
)
public:
void AddRange(
    array<FeedbackPeriodType^>^ items
)
Parameters
items (array< FeedbackPeriodType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► AddRange(FeedbackPeriodTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    FeedbackPeriodTypeCollection items
)
Public Sub AddRange ( _
    items As FeedbackPeriodTypeCollection _
)
public:
void AddRange(
    FeedbackPeriodTypeCollection^ items
)
Parameters
items (FeedbackPeriodTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► Contains(FeedbackPeriodType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    FeedbackPeriodType item
)
Public Function Contains ( _
    item As FeedbackPeriodType _
) As Boolean
public:
bool Contains(
    FeedbackPeriodType^ item
)
Parameters
item (FeedbackPeriodType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► CopyTo(array<FeedbackPeriodType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    FeedbackPeriodType[] items,
    int index
)
Public Sub CopyTo ( _
    items As FeedbackPeriodType(), _
    index As Integer _
)
public:
void CopyTo(
    array<FeedbackPeriodType^>^ items,
    int index
)
Parameters
items (array< FeedbackPeriodType >[]()[][])
index (Int32)


FeedbackPeriodTypeCollection Constructor

FeedbackPeriodTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► FeedbackPeriodTypeCollection()()()()
Members
Icon | Member | Description
 | FeedbackPeriodTypeCollection()()()() |
 | FeedbackPeriodTypeCollection(array<FeedbackPeriodType>[]()[][]) |
 | FeedbackPeriodTypeCollection(FeedbackPeriodTypeCollection) |


FeedbackPeriodTypeCollection Constructor

FeedbackPeriodTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► FeedbackPeriodTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodTypeCollection()
Public Sub New
public:
FeedbackPeriodTypeCollection()


FeedbackPeriodTypeCollection Constructor (items)

FeedbackPeriodTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► FeedbackPeriodTypeCollection(array<FeedbackPeriodType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodTypeCollection(
    FeedbackPeriodType[] items
)
Public Sub New ( _
    items As FeedbackPeriodType() _
)
public:
FeedbackPeriodTypeCollection(
    array<FeedbackPeriodType^>^ items
)
Parameters
items (array< FeedbackPeriodType >[]()[][])


FeedbackPeriodTypeCollection Constructor (items)

FeedbackPeriodTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► FeedbackPeriodTypeCollection(FeedbackPeriodTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodTypeCollection(
    FeedbackPeriodTypeCollection items
)
Public Sub New ( _
    items As FeedbackPeriodTypeCollection _
)
public:
FeedbackPeriodTypeCollection(
    FeedbackPeriodTypeCollection^ items
)
Parameters
items (FeedbackPeriodTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► IndexOf(FeedbackPeriodType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    FeedbackPeriodType item
)
Public Function IndexOf ( _
    item As FeedbackPeriodType _
) As Integer
public:
int IndexOf(
    FeedbackPeriodType^ item
)
Parameters
item (FeedbackPeriodType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► Insert(Int32, FeedbackPeriodType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    FeedbackPeriodType item
)
Public Sub Insert ( _
    index As Integer, _
    item As FeedbackPeriodType _
)
public:
void Insert(
    int index,
    FeedbackPeriodType^ item
)
Parameters
index (Int32)
item (FeedbackPeriodType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As FeedbackPeriodType
    Get
    Set
public:
property FeedbackPeriodType^ default[int index] {
    FeedbackPeriodType^ get (int index);
    void set (int index, FeedbackPeriodType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As FeedbackPeriodType
public:
FeedbackPeriodType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► Remove(FeedbackPeriodType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    FeedbackPeriodType item
)
Public Sub Remove ( _
    item As FeedbackPeriodType _
)
public:
void Remove(
    FeedbackPeriodType^ item
)
Parameters
item (FeedbackPeriodType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodType[] ToArray()
Public Function ToArray As FeedbackPeriodType()
public:
array<FeedbackPeriodType^>^ ToArray()
Return Value


FeedbackRatingDetailCodeType Enumeration

FeedbackRatingDetailCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► FeedbackRatingDetailCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum FeedbackRatingDetailCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration FeedbackRatingDetailCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class FeedbackRatingDetailCodeType
Members
Member | Description
ItemAsDescribed |
Communication |
ShippingTime |
ShippingAndHandlingCharges |
CustomCode |
Remarks


FeedbackRatingStarCodeType Enumeration

FeedbackRatingStarCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► FeedbackRatingStarCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum FeedbackRatingStarCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration FeedbackRatingStarCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class FeedbackRatingStarCodeType
Members
Member | Description
None |
Yellow |
Blue |
Turquoise |
Purple |
Red |
Green |
YellowShooting |
TurquoiseShooting |
PurpleShooting |
RedShooting |
GreenShooting |
SilverShooting |
CustomCode |
Remarks


FeedbackResponseCodeType Enumeration

FeedbackResponseCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► FeedbackResponseCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum FeedbackResponseCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration FeedbackResponseCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class FeedbackResponseCodeType
Members
Member | Description
Reply |
FollowUp |
CustomCode |
Remarks


FeedbackSummaryPeriodCodeType Enumeration

FeedbackSummaryPeriodCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryPeriodCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum FeedbackSummaryPeriodCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration FeedbackSummaryPeriodCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class FeedbackSummaryPeriodCodeType
Members
Member | Description
ThirtyDays |
FiftyTwoWeeks |
CustomCode |
Remarks


FeedbackSummaryType Class

FeedbackSummaryType Class
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FeedbackSummaryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FeedbackSummaryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FeedbackSummaryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeedbackSummaryType()()()() |
 | Any |
 | BidRetractionFeedbackPeriodArray |
 | BuyerRoleMetrics |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NegativeFeedbackPeriodArray |
 | NeutralCommentCountFromSuspendedUsers |
 | NeutralCommentCountFromSuspendedUsersSpecified |
 | NeutralFeedbackPeriodArray |
 | PositiveFeedbackPeriodArray |
 | SellerRatingSummaryArray |
 | SellerRoleMetrics |
 | ToString()()()() | (Inherited from Object.)
 | TotalFeedbackPeriodArray |
 | UniqueNegativeFeedbackCount |
 | UniqueNegativeFeedbackCountSpecified |
 | UniqueNeutralFeedbackCount |
 | UniqueNeutralFeedbackCountSpecified |
 | UniquePositiveFeedbackCount |
 | UniquePositiveFeedbackCountSpecified |
Remarks
Inheritance Hierarchy
Object
FeedbackSummaryType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidRetractionFeedbackPeriodArray Property

BidRetractionFeedbackPeriodArray Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► BidRetractionFeedbackPeriodArray
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodTypeCollection BidRetractionFeedbackPeriodArray { get; set; }
Public Property BidRetractionFeedbackPeriodArray As FeedbackPeriodTypeCollection
    Get
    Set
public:
property FeedbackPeriodTypeCollection^ BidRetractionFeedbackPeriodArray {
    FeedbackPeriodTypeCollection^ get ();
    void set (FeedbackPeriodTypeCollection^ value);
}


BuyerRoleMetrics Property

BuyerRoleMetrics Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► BuyerRoleMetrics
Declaration Syntax
C# Visual Basic Visual C++
public BuyerRoleMetricsType BuyerRoleMetrics { get; set; }
Public Property BuyerRoleMetrics As BuyerRoleMetricsType
    Get
    Set
public:
property BuyerRoleMetricsType^ BuyerRoleMetrics {
    BuyerRoleMetricsType^ get ();
    void set (BuyerRoleMetricsType^ value);
}


FeedbackSummaryType Constructor

FeedbackSummaryType Constructor
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► FeedbackSummaryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackSummaryType()
Public Sub New
public:
FeedbackSummaryType()


NegativeFeedbackPeriodArray Property

NegativeFeedbackPeriodArray Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► NegativeFeedbackPeriodArray
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodTypeCollection NegativeFeedbackPeriodArray { get; set; }
Public Property NegativeFeedbackPeriodArray As FeedbackPeriodTypeCollection
    Get
    Set
public:
property FeedbackPeriodTypeCollection^ NegativeFeedbackPeriodArray {
    FeedbackPeriodTypeCollection^ get ();
    void set (FeedbackPeriodTypeCollection^ value);
}


NeutralCommentCountFromSuspendedUsers Property

NeutralCommentCountFromSuspendedUsers Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► NeutralCommentCountFromSuspendedUsers
Declaration Syntax
C# Visual Basic Visual C++
public int NeutralCommentCountFromSuspendedUsers { get; set; }
Public Property NeutralCommentCountFromSuspendedUsers As Integer
    Get
    Set
public:
property int NeutralCommentCountFromSuspendedUsers {
    int get ();
    void set (int value);
}


NeutralCommentCountFromSuspendedUsersSpecified Property

NeutralCommentCountFromSuspendedUsersSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► NeutralCommentCountFromSuspendedUsersSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NeutralCommentCountFromSuspendedUsersSpecified { get; set; }
Public Property NeutralCommentCountFromSuspendedUsersSpecified As Boolean
    Get
    Set
public:
property bool NeutralCommentCountFromSuspendedUsersSpecified {
    bool get ();
    void set (bool value);
}


NeutralFeedbackPeriodArray Property

NeutralFeedbackPeriodArray Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► NeutralFeedbackPeriodArray
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodTypeCollection NeutralFeedbackPeriodArray { get; set; }
Public Property NeutralFeedbackPeriodArray As FeedbackPeriodTypeCollection
    Get
    Set
public:
property FeedbackPeriodTypeCollection^ NeutralFeedbackPeriodArray {
    FeedbackPeriodTypeCollection^ get ();
    void set (FeedbackPeriodTypeCollection^ value);
}


PositiveFeedbackPeriodArray Property

PositiveFeedbackPeriodArray Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► PositiveFeedbackPeriodArray
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodTypeCollection PositiveFeedbackPeriodArray { get; set; }
Public Property PositiveFeedbackPeriodArray As FeedbackPeriodTypeCollection
    Get
    Set
public:
property FeedbackPeriodTypeCollection^ PositiveFeedbackPeriodArray {
    FeedbackPeriodTypeCollection^ get ();
    void set (FeedbackPeriodTypeCollection^ value);
}


SellerRatingSummaryArray Property

SellerRatingSummaryArray Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► SellerRatingSummaryArray
Declaration Syntax
C# Visual Basic Visual C++
public AverageRatingSummaryTypeCollection SellerRatingSummaryArray { get; set; }
Public Property SellerRatingSummaryArray As AverageRatingSummaryTypeCollection
    Get
    Set
public:
property AverageRatingSummaryTypeCollection^ SellerRatingSummaryArray {
    AverageRatingSummaryTypeCollection^ get ();
    void set (AverageRatingSummaryTypeCollection^ value);
}


SellerRoleMetrics Property

SellerRoleMetrics Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► SellerRoleMetrics
Declaration Syntax
C# Visual Basic Visual C++
public SellerRoleMetricsType SellerRoleMetrics { get; set; }
Public Property SellerRoleMetrics As SellerRoleMetricsType
    Get
    Set
public:
property SellerRoleMetricsType^ SellerRoleMetrics {
    SellerRoleMetricsType^ get ();
    void set (SellerRoleMetricsType^ value);
}


TotalFeedbackPeriodArray Property

TotalFeedbackPeriodArray Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► TotalFeedbackPeriodArray
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackPeriodTypeCollection TotalFeedbackPeriodArray { get; set; }
Public Property TotalFeedbackPeriodArray As FeedbackPeriodTypeCollection
    Get
    Set
public:
property FeedbackPeriodTypeCollection^ TotalFeedbackPeriodArray {
    FeedbackPeriodTypeCollection^ get ();
    void set (FeedbackPeriodTypeCollection^ value);
}


UniqueNegativeFeedbackCount Property

UniqueNegativeFeedbackCount Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► UniqueNegativeFeedbackCount
Declaration Syntax
C# Visual Basic Visual C++
public int UniqueNegativeFeedbackCount { get; set; }
Public Property UniqueNegativeFeedbackCount As Integer
    Get
    Set
public:
property int UniqueNegativeFeedbackCount {
    int get ();
    void set (int value);
}


UniqueNegativeFeedbackCountSpecified Property

UniqueNegativeFeedbackCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► UniqueNegativeFeedbackCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UniqueNegativeFeedbackCountSpecified { get; set; }
Public Property UniqueNegativeFeedbackCountSpecified As Boolean
    Get
    Set
public:
property bool UniqueNegativeFeedbackCountSpecified {
    bool get ();
    void set (bool value);
}


UniqueNeutralFeedbackCount Property

UniqueNeutralFeedbackCount Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► UniqueNeutralFeedbackCount
Declaration Syntax
C# Visual Basic Visual C++
public int UniqueNeutralFeedbackCount { get; set; }
Public Property UniqueNeutralFeedbackCount As Integer
    Get
    Set
public:
property int UniqueNeutralFeedbackCount {
    int get ();
    void set (int value);
}


UniqueNeutralFeedbackCountSpecified Property

UniqueNeutralFeedbackCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► UniqueNeutralFeedbackCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UniqueNeutralFeedbackCountSpecified { get; set; }
Public Property UniqueNeutralFeedbackCountSpecified As Boolean
    Get
    Set
public:
property bool UniqueNeutralFeedbackCountSpecified {
    bool get ();
    void set (bool value);
}


UniquePositiveFeedbackCount Property

UniquePositiveFeedbackCount Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► UniquePositiveFeedbackCount
Declaration Syntax
C# Visual Basic Visual C++
public int UniquePositiveFeedbackCount { get; set; }
Public Property UniquePositiveFeedbackCount As Integer
    Get
    Set
public:
property int UniquePositiveFeedbackCount {
    int get ();
    void set (int value);
}


UniquePositiveFeedbackCountSpecified Property

UniquePositiveFeedbackCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackSummaryType ► UniquePositiveFeedbackCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UniquePositiveFeedbackCountSpecified { get; set; }
Public Property UniquePositiveFeedbackCountSpecified As Boolean
    Get
    Set
public:
property bool UniquePositiveFeedbackCountSpecified {
    bool get ();
    void set (bool value);
}


FeedbackTypeCodeType Enumeration

FeedbackTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► FeedbackTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum FeedbackTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration FeedbackTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class FeedbackTypeCodeType
Members
Member | Description
FeedbackReceivedAsSeller |
FeedbackReceivedAsBuyer |
FeedbackReceived |
FeedbackLeft |
CustomCode |
Remarks


FeeType Class

FeeType Class
Namespaces ► eBay.Service.Core.Soap ► FeeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FeeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FeeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FeeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeeType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Fee |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | PromotionalDiscount |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
FeeType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FeeType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Fee Property

Fee Property
Namespaces ► eBay.Service.Core.Soap ► FeeType ► Fee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Fee { get; set; }
Public Property Fee As AmountType
    Get
    Set
public:
property AmountType^ Fee {
    AmountType^ get ();
    void set (AmountType^ value);
}


FeeType Constructor

FeeType Constructor
Namespaces ► eBay.Service.Core.Soap ► FeeType ► FeeType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeeType()
Public Sub New
public:
FeeType()


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► FeeType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


PromotionalDiscount Property

PromotionalDiscount Property
Namespaces ► eBay.Service.Core.Soap ► FeeType ► PromotionalDiscount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType PromotionalDiscount { get; set; }
Public Property PromotionalDiscount As AmountType
    Get
    Set
public:
property AmountType^ PromotionalDiscount {
    AmountType^ get ();
    void set (AmountType^ value);
}


FeeTypeCollection Class

FeeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class FeeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class FeeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class FeeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeeTypeCollection()()()() |
 | FeeTypeCollection(array<FeeType>[]()[][]) |
 | FeeTypeCollection(FeeTypeCollection) |
 | Add(FeeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<FeeType>[]()[][]) |
 | AddRange(FeeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(FeeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<FeeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(FeeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, FeeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(FeeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | FeeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► Add(FeeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    FeeType item
)
Public Function Add ( _
    item As FeeType _
) As Integer
public:
int Add(
    FeeType^ item
)
Parameters
item (FeeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<FeeType>[]()[][]) |
 | AddRange(FeeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► AddRange(array<FeeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    FeeType[] items
)
Public Sub AddRange ( _
    items As FeeType() _
)
public:
void AddRange(
    array<FeeType^>^ items
)
Parameters
items (array< FeeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► AddRange(FeeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    FeeTypeCollection items
)
Public Sub AddRange ( _
    items As FeeTypeCollection _
)
public:
void AddRange(
    FeeTypeCollection^ items
)
Parameters
items (FeeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► Contains(FeeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    FeeType item
)
Public Function Contains ( _
    item As FeeType _
) As Boolean
public:
bool Contains(
    FeeType^ item
)
Parameters
item (FeeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► CopyTo(array<FeeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    FeeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As FeeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<FeeType^>^ items,
    int index
)
Parameters
items (array< FeeType >[]()[][])
index (Int32)


FeeTypeCollection Constructor

FeeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► FeeTypeCollection()()()()
Members
Icon | Member | Description
 | FeeTypeCollection()()()() |
 | FeeTypeCollection(array<FeeType>[]()[][]) |
 | FeeTypeCollection(FeeTypeCollection) |


FeeTypeCollection Constructor

FeeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► FeeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection()
Public Sub New
public:
FeeTypeCollection()


FeeTypeCollection Constructor (items)

FeeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► FeeTypeCollection(array<FeeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection(
    FeeType[] items
)
Public Sub New ( _
    items As FeeType() _
)
public:
FeeTypeCollection(
    array<FeeType^>^ items
)
Parameters
items (array< FeeType >[]()[][])


FeeTypeCollection Constructor (items)

FeeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► FeeTypeCollection(FeeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection(
    FeeTypeCollection items
)
Public Sub New ( _
    items As FeeTypeCollection _
)
public:
FeeTypeCollection(
    FeeTypeCollection^ items
)
Parameters
items (FeeTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► IndexOf(FeeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    FeeType item
)
Public Function IndexOf ( _
    item As FeeType _
) As Integer
public:
int IndexOf(
    FeeType^ item
)
Parameters
item (FeeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► Insert(Int32, FeeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    FeeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As FeeType _
)
public:
void Insert(
    int index,
    FeeType^ item
)
Parameters
index (Int32)
item (FeeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public FeeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As FeeType
    Get
    Set
public:
property FeeType^ default[int index] {
    FeeType^ get (int index);
    void set (int index, FeeType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public FeeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As FeeType
public:
FeeType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► Remove(FeeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    FeeType item
)
Public Sub Remove ( _
    item As FeeType _
)
public:
void Remove(
    FeeType^ item
)
Parameters
item (FeeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeeType[] ToArray()
Public Function ToArray As FeeType()
public:
array<FeeType^>^ ToArray()
Return Value


FetchTokenRequestType Class

FetchTokenRequestType Class
Namespaces ► eBay.Service.Core.Soap ► FetchTokenRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FetchTokenRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FetchTokenRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FetchTokenRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FetchTokenRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SecretID |
 | SessionID |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | FetchTokenRequestType


FetchTokenRequestType Constructor

FetchTokenRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► FetchTokenRequestType ► FetchTokenRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FetchTokenRequestType()
Public Sub New
public:
FetchTokenRequestType()


SecretID Property

SecretID Property
Namespaces ► eBay.Service.Core.Soap ► FetchTokenRequestType ► SecretID
Declaration Syntax
C# Visual Basic Visual C++
public string SecretID { get; set; }
Public Property SecretID As String
    Get
    Set
public:
property String^ SecretID {
    String^ get ();
    void set (String^ value);
}


SessionID Property

SessionID Property
Namespaces ► eBay.Service.Core.Soap ► FetchTokenRequestType ► SessionID
Declaration Syntax
C# Visual Basic Visual C++
public string SessionID { get; set; }
Public Property SessionID As String
    Get
    Set
public:
property String^ SessionID {
    String^ get ();
    void set (String^ value);
}


FetchTokenResponseType Class

FetchTokenResponseType Class
Namespaces ► eBay.Service.Core.Soap ► FetchTokenResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FetchTokenResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FetchTokenResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FetchTokenResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FetchTokenResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | eBayAuthToken |
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationTime |
 | HardExpirationTimeSpecified |
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | RESTToken |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | FetchTokenResponseType


eBayAuthToken Property

eBayAuthToken Property
Namespaces ► eBay.Service.Core.Soap ► FetchTokenResponseType ► eBayAuthToken
Declaration Syntax
C# Visual Basic Visual C++
public string eBayAuthToken { get; set; }
Public Property eBayAuthToken As String
    Get
    Set
public:
property String^ eBayAuthToken {
    String^ get ();
    void set (String^ value);
}


FetchTokenResponseType Constructor

FetchTokenResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► FetchTokenResponseType ► FetchTokenResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FetchTokenResponseType()
Public Sub New
public:
FetchTokenResponseType()


HardExpirationTime Property

HardExpirationTime Property
Namespaces ► eBay.Service.Core.Soap ► FetchTokenResponseType ► HardExpirationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime HardExpirationTime { get; set; }
Public Property HardExpirationTime As DateTime
    Get
    Set
public:
property DateTime HardExpirationTime {
    DateTime get ();
    void set (DateTime value);
}


HardExpirationTimeSpecified Property

HardExpirationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FetchTokenResponseType ► HardExpirationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HardExpirationTimeSpecified { get; set; }
Public Property HardExpirationTimeSpecified As Boolean
    Get
    Set
public:
property bool HardExpirationTimeSpecified {
    bool get ();
    void set (bool value);
}


RESTToken Property

RESTToken Property
Namespaces ► eBay.Service.Core.Soap ► FetchTokenResponseType ► RESTToken
Declaration Syntax
C# Visual Basic Visual C++
public string RESTToken { get; set; }
Public Property RESTToken As String
    Get
    Set
public:
property String^ RESTToken {
    String^ get ();
    void set (String^ value);
}


FlatRateInsuranceRangeCodeType Enumeration

FlatRateInsuranceRangeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum FlatRateInsuranceRangeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration FlatRateInsuranceRangeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class FlatRateInsuranceRangeCodeType
Members
Member | Description
FlatRateInsuranceRange1 |
FlatRateInsuranceRange2 |
FlatRateInsuranceRange3 |
FlatRateInsuranceRange4 |
FlatRateInsuranceRange5 |
FlatRateInsuranceRange6 |
CustomCode |
Remarks


FlatRateInsuranceRangeCostType Class

FlatRateInsuranceRangeCostType Class
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FlatRateInsuranceRangeCostType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FlatRateInsuranceRangeCostType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FlatRateInsuranceRangeCostType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FlatRateInsuranceRangeCostType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FlatRateInsuranceRange |
 | FlatRateInsuranceRangeSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InsuranceCost |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
FlatRateInsuranceRangeCostType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FlatRateInsuranceRange Property

FlatRateInsuranceRange Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostType ► FlatRateInsuranceRange
Declaration Syntax
C# Visual Basic Visual C++
public FlatRateInsuranceRangeCodeType FlatRateInsuranceRange { get; set; }
Public Property FlatRateInsuranceRange As FlatRateInsuranceRangeCodeType
    Get
    Set
public:
property FlatRateInsuranceRangeCodeType FlatRateInsuranceRange {
    FlatRateInsuranceRangeCodeType get ();
    void set (FlatRateInsuranceRangeCodeType value);
}


FlatRateInsuranceRangeCostType Constructor

FlatRateInsuranceRangeCostType Constructor
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostType ► FlatRateInsuranceRangeCostType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FlatRateInsuranceRangeCostType()
Public Sub New
public:
FlatRateInsuranceRangeCostType()


FlatRateInsuranceRangeSpecified Property

FlatRateInsuranceRangeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostType ► FlatRateInsuranceRangeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FlatRateInsuranceRangeSpecified { get; set; }
Public Property FlatRateInsuranceRangeSpecified As Boolean
    Get
    Set
public:
property bool FlatRateInsuranceRangeSpecified {
    bool get ();
    void set (bool value);
}


InsuranceCost Property

InsuranceCost Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostType ► InsuranceCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType InsuranceCost { get; set; }
Public Property InsuranceCost As AmountType
    Get
    Set
public:
property AmountType^ InsuranceCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


FlatRateInsuranceRangeCostTypeCollection Class

FlatRateInsuranceRangeCostTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class FlatRateInsuranceRangeCostTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class FlatRateInsuranceRangeCostTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class FlatRateInsuranceRangeCostTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FlatRateInsuranceRangeCostTypeCollection()()()() |
 | FlatRateInsuranceRangeCostTypeCollection(array<FlatRateInsuranceRangeCostType>[]()[][]) |
 | FlatRateInsuranceRangeCostTypeCollection(FlatRateInsuranceRangeCostTypeCollection) |
 | Add(FlatRateInsuranceRangeCostType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<FlatRateInsuranceRangeCostType>[]()[][]) |
 | AddRange(FlatRateInsuranceRangeCostTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(FlatRateInsuranceRangeCostType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<FlatRateInsuranceRangeCostType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(FlatRateInsuranceRangeCostType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, FlatRateInsuranceRangeCostType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(FlatRateInsuranceRangeCostType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | FlatRateInsuranceRangeCostTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► Add(FlatRateInsuranceRangeCostType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    FlatRateInsuranceRangeCostType item
)
Public Function Add ( _
    item As FlatRateInsuranceRangeCostType _
) As Integer
public:
int Add(
    FlatRateInsuranceRangeCostType^ item
)
Parameters
item (FlatRateInsuranceRangeCostType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<FlatRateInsuranceRangeCostType>[]()[][]) |
 | AddRange(FlatRateInsuranceRangeCostTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► AddRange(array<FlatRateInsuranceRangeCostType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    FlatRateInsuranceRangeCostType[] items
)
Public Sub AddRange ( _
    items As FlatRateInsuranceRangeCostType() _
)
public:
void AddRange(
    array<FlatRateInsuranceRangeCostType^>^ items
)
Parameters
items (array< FlatRateInsuranceRangeCostType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► AddRange(FlatRateInsuranceRangeCostTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    FlatRateInsuranceRangeCostTypeCollection items
)
Public Sub AddRange ( _
    items As FlatRateInsuranceRangeCostTypeCollection _
)
public:
void AddRange(
    FlatRateInsuranceRangeCostTypeCollection^ items
)
Parameters
items (FlatRateInsuranceRangeCostTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► Contains(FlatRateInsuranceRangeCostType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    FlatRateInsuranceRangeCostType item
)
Public Function Contains ( _
    item As FlatRateInsuranceRangeCostType _
) As Boolean
public:
bool Contains(
    FlatRateInsuranceRangeCostType^ item
)
Parameters
item (FlatRateInsuranceRangeCostType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► CopyTo(array<FlatRateInsuranceRangeCostType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    FlatRateInsuranceRangeCostType[] items,
    int index
)
Public Sub CopyTo ( _
    items As FlatRateInsuranceRangeCostType(), _
    index As Integer _
)
public:
void CopyTo(
    array<FlatRateInsuranceRangeCostType^>^ items,
    int index
)
Parameters
items (array< FlatRateInsuranceRangeCostType >[]()[][])
index (Int32)


FlatRateInsuranceRangeCostTypeCollection Constructor

FlatRateInsuranceRangeCostTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► FlatRateInsuranceRangeCostTypeCollection()()()()
Members
Icon | Member | Description
 | FlatRateInsuranceRangeCostTypeCollection()()()() |
 | FlatRateInsuranceRangeCostTypeCollection(array<FlatRateInsuranceRangeCostType>[]()[][]) |
 | FlatRateInsuranceRangeCostTypeCollection(FlatRateInsuranceRangeCostTypeCollection) |


FlatRateInsuranceRangeCostTypeCollection Constructor

FlatRateInsuranceRangeCostTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► FlatRateInsuranceRangeCostTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FlatRateInsuranceRangeCostTypeCollection()
Public Sub New
public:
FlatRateInsuranceRangeCostTypeCollection()


FlatRateInsuranceRangeCostTypeCollection Constructor (items)

FlatRateInsuranceRangeCostTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► FlatRateInsuranceRangeCostTypeCollection(array<FlatRateInsuranceRangeCostType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public FlatRateInsuranceRangeCostTypeCollection(
    FlatRateInsuranceRangeCostType[] items
)
Public Sub New ( _
    items As FlatRateInsuranceRangeCostType() _
)
public:
FlatRateInsuranceRangeCostTypeCollection(
    array<FlatRateInsuranceRangeCostType^>^ items
)
Parameters
items (array< FlatRateInsuranceRangeCostType >[]()[][])


FlatRateInsuranceRangeCostTypeCollection Constructor (items)

FlatRateInsuranceRangeCostTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► FlatRateInsuranceRangeCostTypeCollection(FlatRateInsuranceRangeCostTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public FlatRateInsuranceRangeCostTypeCollection(
    FlatRateInsuranceRangeCostTypeCollection items
)
Public Sub New ( _
    items As FlatRateInsuranceRangeCostTypeCollection _
)
public:
FlatRateInsuranceRangeCostTypeCollection(
    FlatRateInsuranceRangeCostTypeCollection^ items
)
Parameters
items (FlatRateInsuranceRangeCostTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► IndexOf(FlatRateInsuranceRangeCostType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    FlatRateInsuranceRangeCostType item
)
Public Function IndexOf ( _
    item As FlatRateInsuranceRangeCostType _
) As Integer
public:
int IndexOf(
    FlatRateInsuranceRangeCostType^ item
)
Parameters
item (FlatRateInsuranceRangeCostType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► Insert(Int32, FlatRateInsuranceRangeCostType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    FlatRateInsuranceRangeCostType item
)
Public Sub Insert ( _
    index As Integer, _
    item As FlatRateInsuranceRangeCostType _
)
public:
void Insert(
    int index,
    FlatRateInsuranceRangeCostType^ item
)
Parameters
index (Int32)
item (FlatRateInsuranceRangeCostType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public FlatRateInsuranceRangeCostType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As FlatRateInsuranceRangeCostType
    Get
    Set
public:
property FlatRateInsuranceRangeCostType^ default[int index] {
    FlatRateInsuranceRangeCostType^ get (int index);
    void set (int index, FlatRateInsuranceRangeCostType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public FlatRateInsuranceRangeCostType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As FlatRateInsuranceRangeCostType
public:
FlatRateInsuranceRangeCostType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► Remove(FlatRateInsuranceRangeCostType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    FlatRateInsuranceRangeCostType item
)
Public Sub Remove ( _
    item As FlatRateInsuranceRangeCostType _
)
public:
void Remove(
    FlatRateInsuranceRangeCostType^ item
)
Parameters
item (FlatRateInsuranceRangeCostType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FlatRateInsuranceRangeCostType[] ToArray()
Public Function ToArray As FlatRateInsuranceRangeCostType()
public:
array<FlatRateInsuranceRangeCostType^>^ ToArray()
Return Value


FlatShippingDiscountType Class

FlatShippingDiscountType Class
Namespaces ► eBay.Service.Core.Soap ► FlatShippingDiscountType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FlatShippingDiscountType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FlatShippingDiscountType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FlatShippingDiscountType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FlatShippingDiscountType()()()() |
 | Any |
 | DiscountName |
 | DiscountNameSpecified |
 | DiscountProfile |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
FlatShippingDiscountType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingDiscountType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DiscountName Property

DiscountName Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingDiscountType ► DiscountName
Declaration Syntax
C# Visual Basic Visual C++
public DiscountNameCodeType DiscountName { get; set; }
Public Property DiscountName As DiscountNameCodeType
    Get
    Set
public:
property DiscountNameCodeType DiscountName {
    DiscountNameCodeType get ();
    void set (DiscountNameCodeType value);
}


DiscountNameSpecified Property

DiscountNameSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingDiscountType ► DiscountNameSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DiscountNameSpecified { get; set; }
Public Property DiscountNameSpecified As Boolean
    Get
    Set
public:
property bool DiscountNameSpecified {
    bool get ();
    void set (bool value);
}


DiscountProfile Property

DiscountProfile Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingDiscountType ► DiscountProfile
Declaration Syntax
C# Visual Basic Visual C++
public DiscountProfileTypeCollection DiscountProfile { get; set; }
Public Property DiscountProfile As DiscountProfileTypeCollection
    Get
    Set
public:
property DiscountProfileTypeCollection^ DiscountProfile {
    DiscountProfileTypeCollection^ get ();
    void set (DiscountProfileTypeCollection^ value);
}


FlatShippingDiscountType Constructor

FlatShippingDiscountType Constructor
Namespaces ► eBay.Service.Core.Soap ► FlatShippingDiscountType ► FlatShippingDiscountType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FlatShippingDiscountType()
Public Sub New
public:
FlatShippingDiscountType()


FlatShippingPreferencesType Class

FlatShippingPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► FlatShippingPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FlatShippingPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FlatShippingPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FlatShippingPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FlatShippingPreferencesType()()()() |
 | AmountPerAdditionalItem |
 | Any |
 | DeductionAmountPerAdditionalItem |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FlatRateInsuranceRangeCost |
 | FlatShippingRateOption |
 | FlatShippingRateOptionSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InsuranceOption |
 | InsuranceOptionSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
FlatShippingPreferencesType


AmountPerAdditionalItem Property

AmountPerAdditionalItem Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingPreferencesType ► AmountPerAdditionalItem
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AmountPerAdditionalItem { get; set; }
Public Property AmountPerAdditionalItem As AmountType
    Get
    Set
public:
property AmountType^ AmountPerAdditionalItem {
    AmountType^ get ();
    void set (AmountType^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DeductionAmountPerAdditionalItem Property

DeductionAmountPerAdditionalItem Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingPreferencesType ► DeductionAmountPerAdditionalItem
Declaration Syntax
C# Visual Basic Visual C++
public AmountType DeductionAmountPerAdditionalItem { get; set; }
Public Property DeductionAmountPerAdditionalItem As AmountType
    Get
    Set
public:
property AmountType^ DeductionAmountPerAdditionalItem {
    AmountType^ get ();
    void set (AmountType^ value);
}


FlatRateInsuranceRangeCost Property

FlatRateInsuranceRangeCost Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingPreferencesType ► FlatRateInsuranceRangeCost
Declaration Syntax
C# Visual Basic Visual C++
public FlatRateInsuranceRangeCostTypeCollection FlatRateInsuranceRangeCost { get; set; }
Public Property FlatRateInsuranceRangeCost As FlatRateInsuranceRangeCostTypeCollection
    Get
    Set
public:
property FlatRateInsuranceRangeCostTypeCollection^ FlatRateInsuranceRangeCost {
    FlatRateInsuranceRangeCostTypeCollection^ get ();
    void set (FlatRateInsuranceRangeCostTypeCollection^ value);
}


FlatShippingPreferencesType Constructor

FlatShippingPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► FlatShippingPreferencesType ► FlatShippingPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FlatShippingPreferencesType()
Public Sub New
public:
FlatShippingPreferencesType()


FlatShippingRateOption Property

FlatShippingRateOption Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingPreferencesType ► FlatShippingRateOption
Declaration Syntax
C# Visual Basic Visual C++
public FlatShippingRateOptionCodeType FlatShippingRateOption { get; set; }
Public Property FlatShippingRateOption As FlatShippingRateOptionCodeType
    Get
    Set
public:
property FlatShippingRateOptionCodeType FlatShippingRateOption {
    FlatShippingRateOptionCodeType get ();
    void set (FlatShippingRateOptionCodeType value);
}


FlatShippingRateOptionSpecified Property

FlatShippingRateOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingPreferencesType ► FlatShippingRateOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FlatShippingRateOptionSpecified { get; set; }
Public Property FlatShippingRateOptionSpecified As Boolean
    Get
    Set
public:
property bool FlatShippingRateOptionSpecified {
    bool get ();
    void set (bool value);
}


InsuranceOption Property

InsuranceOption Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingPreferencesType ► InsuranceOption
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceOptionCodeType InsuranceOption { get; set; }
Public Property InsuranceOption As InsuranceOptionCodeType
    Get
    Set
public:
property InsuranceOptionCodeType InsuranceOption {
    InsuranceOptionCodeType get ();
    void set (InsuranceOptionCodeType value);
}


InsuranceOptionSpecified Property

InsuranceOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► FlatShippingPreferencesType ► InsuranceOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InsuranceOptionSpecified { get; set; }
Public Property InsuranceOptionSpecified As Boolean
    Get
    Set
public:
property bool InsuranceOptionSpecified {
    bool get ();
    void set (bool value);
}


FlatShippingRateOptionCodeType Enumeration

FlatShippingRateOptionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► FlatShippingRateOptionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum FlatShippingRateOptionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration FlatShippingRateOptionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class FlatShippingRateOptionCodeType
Members
Member | Description
ChargeAmountForEachAdditionalItem |
DeductAmountFromEachAdditionalItem |
ShipAdditionalItemsFree |
CustomCode |
Remarks


FreeGalleryPlusEnabledDefinitionType Class

FreeGalleryPlusEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► FreeGalleryPlusEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FreeGalleryPlusEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FreeGalleryPlusEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FreeGalleryPlusEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FreeGalleryPlusEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
FreeGalleryPlusEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FreeGalleryPlusEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FreeGalleryPlusEnabledDefinitionType Constructor

FreeGalleryPlusEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► FreeGalleryPlusEnabledDefinitionType ► FreeGalleryPlusEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FreeGalleryPlusEnabledDefinitionType()
Public Sub New
public:
FreeGalleryPlusEnabledDefinitionType()


FreePicturePackEnabledDefinitionType Class

FreePicturePackEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► FreePicturePackEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class FreePicturePackEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class FreePicturePackEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class FreePicturePackEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FreePicturePackEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
FreePicturePackEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► FreePicturePackEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FreePicturePackEnabledDefinitionType Constructor

FreePicturePackEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► FreePicturePackEnabledDefinitionType ► FreePicturePackEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FreePicturePackEnabledDefinitionType()
Public Sub New
public:
FreePicturePackEnabledDefinitionType()


GallerySortFilterCodeType Enumeration

GallerySortFilterCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► GallerySortFilterCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum GallerySortFilterCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration GallerySortFilterCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class GallerySortFilterCodeType
Members
Member | Description
ShowAnyItems |
ShowItemsWithGalleryImagesFirst |
ShowOnlyItemsWithGalleryImages |
CustomCode |
Remarks


GalleryStatusCodeType Enumeration

GalleryStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► GalleryStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum GalleryStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration GalleryStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class GalleryStatusCodeType
Members
Member | Description
Success |
Pending |
InvalidUrl |
InvalidProtocol |
InvalidFile |
ServerDown |
ImageNonExistent |
ImageReadTimeOut |
InvalidFileFormat |
ImageProcessingError |
CustomCode |
Remarks


GalleryTypeCodeType Enumeration

GalleryTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► GalleryTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum GalleryTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration GalleryTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class GalleryTypeCodeType
Members
Member | Description
None |
Featured |
Gallery |
Plus |
CustomCode |
Remarks


GeographicExposureCodeType Enumeration

GeographicExposureCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► GeographicExposureCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum GeographicExposureCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration GeographicExposureCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class GeographicExposureCodeType
Members
Member | Description
National |
LocalOnly |
LocalOptional |
CustomCode |
Remarks


GetAccountRequestType Class

GetAccountRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetAccountRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetAccountRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetAccountRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetAccountRequestType()()()() |
 | AccountEntrySortType |
 | AccountEntrySortTypeSpecified |
 | AccountHistorySelection |
 | AccountHistorySelectionSpecified |
 | Any | (Inherited from AbstractRequestType.)
 | BeginDate |
 | BeginDateSpecified |
 | BotBlock | (Inherited from AbstractRequestType.)
 | Currency |
 | CurrencySpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndDate |
 | EndDateSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | ExcludeBalance |
 | ExcludeBalanceSpecified |
 | ExcludeSummary |
 | ExcludeSummarySpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeConversionRate |
 | IncludeConversionRateSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | InvoiceDate |
 | InvoiceDateSpecified |
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetAccountRequestType


AccountEntrySortType Property

AccountEntrySortType Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► AccountEntrySortType
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntrySortTypeCodeType AccountEntrySortType { get; set; }
Public Property AccountEntrySortType As AccountEntrySortTypeCodeType
    Get
    Set
public:
property AccountEntrySortTypeCodeType AccountEntrySortType {
    AccountEntrySortTypeCodeType get ();
    void set (AccountEntrySortTypeCodeType value);
}


AccountEntrySortTypeSpecified Property

AccountEntrySortTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► AccountEntrySortTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AccountEntrySortTypeSpecified { get; set; }
Public Property AccountEntrySortTypeSpecified As Boolean
    Get
    Set
public:
property bool AccountEntrySortTypeSpecified {
    bool get ();
    void set (bool value);
}


AccountHistorySelection Property

AccountHistorySelection Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► AccountHistorySelection
Declaration Syntax
C# Visual Basic Visual C++
public AccountHistorySelectionCodeType AccountHistorySelection { get; set; }
Public Property AccountHistorySelection As AccountHistorySelectionCodeType
    Get
    Set
public:
property AccountHistorySelectionCodeType AccountHistorySelection {
    AccountHistorySelectionCodeType get ();
    void set (AccountHistorySelectionCodeType value);
}


AccountHistorySelectionSpecified Property

AccountHistorySelectionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► AccountHistorySelectionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AccountHistorySelectionSpecified { get; set; }
Public Property AccountHistorySelectionSpecified As Boolean
    Get
    Set
public:
property bool AccountHistorySelectionSpecified {
    bool get ();
    void set (bool value);
}


BeginDate Property

BeginDate Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► BeginDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime BeginDate { get; set; }
Public Property BeginDate As DateTime
    Get
    Set
public:
property DateTime BeginDate {
    DateTime get ();
    void set (DateTime value);
}


BeginDateSpecified Property

BeginDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► BeginDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BeginDateSpecified { get; set; }
Public Property BeginDateSpecified As Boolean
    Get
    Set
public:
property bool BeginDateSpecified {
    bool get ();
    void set (bool value);
}


Currency Property

Currency Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► Currency
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType Currency { get; set; }
Public Property Currency As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType Currency {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


CurrencySpecified Property

CurrencySpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► CurrencySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CurrencySpecified { get; set; }
Public Property CurrencySpecified As Boolean
    Get
    Set
public:
property bool CurrencySpecified {
    bool get ();
    void set (bool value);
}


EndDate Property

EndDate Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► EndDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndDate { get; set; }
Public Property EndDate As DateTime
    Get
    Set
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}


EndDateSpecified Property

EndDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► EndDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndDateSpecified { get; set; }
Public Property EndDateSpecified As Boolean
    Get
    Set
public:
property bool EndDateSpecified {
    bool get ();
    void set (bool value);
}


ExcludeBalance Property

ExcludeBalance Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► ExcludeBalance
Declaration Syntax
C# Visual Basic Visual C++
public bool ExcludeBalance { get; set; }
Public Property ExcludeBalance As Boolean
    Get
    Set
public:
property bool ExcludeBalance {
    bool get ();
    void set (bool value);
}


ExcludeBalanceSpecified Property

ExcludeBalanceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► ExcludeBalanceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExcludeBalanceSpecified { get; set; }
Public Property ExcludeBalanceSpecified As Boolean
    Get
    Set
public:
property bool ExcludeBalanceSpecified {
    bool get ();
    void set (bool value);
}


ExcludeSummary Property

ExcludeSummary Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► ExcludeSummary
Declaration Syntax
C# Visual Basic Visual C++
public bool ExcludeSummary { get; set; }
Public Property ExcludeSummary As Boolean
    Get
    Set
public:
property bool ExcludeSummary {
    bool get ();
    void set (bool value);
}


ExcludeSummarySpecified Property

ExcludeSummarySpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► ExcludeSummarySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExcludeSummarySpecified { get; set; }
Public Property ExcludeSummarySpecified As Boolean
    Get
    Set
public:
property bool ExcludeSummarySpecified {
    bool get ();
    void set (bool value);
}


GetAccountRequestType Constructor

GetAccountRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► GetAccountRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetAccountRequestType()
Public Sub New
public:
GetAccountRequestType()


IncludeConversionRate Property

IncludeConversionRate Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► IncludeConversionRate
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeConversionRate { get; set; }
Public Property IncludeConversionRate As Boolean
    Get
    Set
public:
property bool IncludeConversionRate {
    bool get ();
    void set (bool value);
}


IncludeConversionRateSpecified Property

IncludeConversionRateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► IncludeConversionRateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeConversionRateSpecified { get; set; }
Public Property IncludeConversionRateSpecified As Boolean
    Get
    Set
public:
property bool IncludeConversionRateSpecified {
    bool get ();
    void set (bool value);
}


InvoiceDate Property

InvoiceDate Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► InvoiceDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime InvoiceDate { get; set; }
Public Property InvoiceDate As DateTime
    Get
    Set
public:
property DateTime InvoiceDate {
    DateTime get ();
    void set (DateTime value);
}


InvoiceDateSpecified Property

InvoiceDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► InvoiceDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InvoiceDateSpecified { get; set; }
Public Property InvoiceDateSpecified As Boolean
    Get
    Set
public:
property bool InvoiceDateSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


GetAccountResponseType Class

GetAccountResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetAccountResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetAccountResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetAccountResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetAccountResponseType()()()() |
 | AccountEntries |
 | AccountID |
 | AccountSummary |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | Currency |
 | CurrencySpecified |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EntriesPerPage |
 | EntriesPerPageSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | HasMoreEntries |
 | HasMoreEntriesSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PageNumber |
 | PageNumberSpecified |
 | PaginationResult |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetAccountResponseType


AccountEntries Property

AccountEntries Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► AccountEntries
Declaration Syntax
C# Visual Basic Visual C++
public AccountEntriesType AccountEntries { get; set; }
Public Property AccountEntries As AccountEntriesType
    Get
    Set
public:
property AccountEntriesType^ AccountEntries {
    AccountEntriesType^ get ();
    void set (AccountEntriesType^ value);
}


AccountID Property

AccountID Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► AccountID
Declaration Syntax
C# Visual Basic Visual C++
public string AccountID { get; set; }
Public Property AccountID As String
    Get
    Set
public:
property String^ AccountID {
    String^ get ();
    void set (String^ value);
}


AccountSummary Property

AccountSummary Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► AccountSummary
Declaration Syntax
C# Visual Basic Visual C++
public AccountSummaryType AccountSummary { get; set; }
Public Property AccountSummary As AccountSummaryType
    Get
    Set
public:
property AccountSummaryType^ AccountSummary {
    AccountSummaryType^ get ();
    void set (AccountSummaryType^ value);
}


Currency Property

Currency Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► Currency
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType Currency { get; set; }
Public Property Currency As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType Currency {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


CurrencySpecified Property

CurrencySpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► CurrencySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CurrencySpecified { get; set; }
Public Property CurrencySpecified As Boolean
    Get
    Set
public:
property bool CurrencySpecified {
    bool get ();
    void set (bool value);
}


EntriesPerPage Property

EntriesPerPage Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► EntriesPerPage
Declaration Syntax
C# Visual Basic Visual C++
public int EntriesPerPage { get; set; }
Public Property EntriesPerPage As Integer
    Get
    Set
public:
property int EntriesPerPage {
    int get ();
    void set (int value);
}


EntriesPerPageSpecified Property

EntriesPerPageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► EntriesPerPageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EntriesPerPageSpecified { get; set; }
Public Property EntriesPerPageSpecified As Boolean
    Get
    Set
public:
property bool EntriesPerPageSpecified {
    bool get ();
    void set (bool value);
}


GetAccountResponseType Constructor

GetAccountResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► GetAccountResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetAccountResponseType()
Public Sub New
public:
GetAccountResponseType()


HasMoreEntries Property

HasMoreEntries Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► HasMoreEntries
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreEntries { get; set; }
Public Property HasMoreEntries As Boolean
    Get
    Set
public:
property bool HasMoreEntries {
    bool get ();
    void set (bool value);
}


HasMoreEntriesSpecified Property

HasMoreEntriesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► HasMoreEntriesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreEntriesSpecified { get; set; }
Public Property HasMoreEntriesSpecified As Boolean
    Get
    Set
public:
property bool HasMoreEntriesSpecified {
    bool get ();
    void set (bool value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► PageNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}


PageNumberSpecified Property

PageNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► PageNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageNumberSpecified { get; set; }
Public Property PageNumberSpecified As Boolean
    Get
    Set
public:
property bool PageNumberSpecified {
    bool get ();
    void set (bool value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetAccountResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


GetAdFormatLeadsRequestType Class

GetAdFormatLeadsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetAdFormatLeadsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetAdFormatLeadsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetAdFormatLeadsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetAdFormatLeadsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndCreationTime |
 | EndCreationTimeSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeMemberMessages |
 | IncludeMemberMessagesSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | StartCreationTime |
 | StartCreationTimeSpecified |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetAdFormatLeadsRequestType


EndCreationTime Property

EndCreationTime Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsRequestType ► EndCreationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndCreationTime { get; set; }
Public Property EndCreationTime As DateTime
    Get
    Set
public:
property DateTime EndCreationTime {
    DateTime get ();
    void set (DateTime value);
}


EndCreationTimeSpecified Property

EndCreationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsRequestType ► EndCreationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndCreationTimeSpecified { get; set; }
Public Property EndCreationTimeSpecified As Boolean
    Get
    Set
public:
property bool EndCreationTimeSpecified {
    bool get ();
    void set (bool value);
}


GetAdFormatLeadsRequestType Constructor

GetAdFormatLeadsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsRequestType ► GetAdFormatLeadsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetAdFormatLeadsRequestType()
Public Sub New
public:
GetAdFormatLeadsRequestType()


IncludeMemberMessages Property

IncludeMemberMessages Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsRequestType ► IncludeMemberMessages
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeMemberMessages { get; set; }
Public Property IncludeMemberMessages As Boolean
    Get
    Set
public:
property bool IncludeMemberMessages {
    bool get ();
    void set (bool value);
}


IncludeMemberMessagesSpecified Property

IncludeMemberMessagesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsRequestType ► IncludeMemberMessagesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeMemberMessagesSpecified { get; set; }
Public Property IncludeMemberMessagesSpecified As Boolean
    Get
    Set
public:
property bool IncludeMemberMessagesSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


StartCreationTime Property

StartCreationTime Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsRequestType ► StartCreationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartCreationTime { get; set; }
Public Property StartCreationTime As DateTime
    Get
    Set
public:
property DateTime StartCreationTime {
    DateTime get ();
    void set (DateTime value);
}


StartCreationTimeSpecified Property

StartCreationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsRequestType ► StartCreationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartCreationTimeSpecified { get; set; }
Public Property StartCreationTimeSpecified As Boolean
    Get
    Set
public:
property bool StartCreationTimeSpecified {
    bool get ();
    void set (bool value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsRequestType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public MessageStatusTypeCodeType Status { get; set; }
Public Property Status As MessageStatusTypeCodeType
    Get
    Set
public:
property MessageStatusTypeCodeType Status {
    MessageStatusTypeCodeType get ();
    void set (MessageStatusTypeCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsRequestType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


GetAdFormatLeadsResponseType Class

GetAdFormatLeadsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetAdFormatLeadsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetAdFormatLeadsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetAdFormatLeadsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetAdFormatLeadsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | AdFormatLead |
 | AdFormatLeadCount |
 | AdFormatLeadCountSpecified |
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetAdFormatLeadsResponseType


AdFormatLead Property

AdFormatLead Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsResponseType ► AdFormatLead
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatLeadTypeCollection AdFormatLead { get; set; }
Public Property AdFormatLead As AdFormatLeadTypeCollection
    Get
    Set
public:
property AdFormatLeadTypeCollection^ AdFormatLead {
    AdFormatLeadTypeCollection^ get ();
    void set (AdFormatLeadTypeCollection^ value);
}


AdFormatLeadCount Property

AdFormatLeadCount Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsResponseType ► AdFormatLeadCount
Declaration Syntax
C# Visual Basic Visual C++
public int AdFormatLeadCount { get; set; }
Public Property AdFormatLeadCount As Integer
    Get
    Set
public:
property int AdFormatLeadCount {
    int get ();
    void set (int value);
}


AdFormatLeadCountSpecified Property

AdFormatLeadCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsResponseType ► AdFormatLeadCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AdFormatLeadCountSpecified { get; set; }
Public Property AdFormatLeadCountSpecified As Boolean
    Get
    Set
public:
property bool AdFormatLeadCountSpecified {
    bool get ();
    void set (bool value);
}


GetAdFormatLeadsResponseType Constructor

GetAdFormatLeadsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetAdFormatLeadsResponseType ► GetAdFormatLeadsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetAdFormatLeadsResponseType()
Public Sub New
public:
GetAdFormatLeadsResponseType()


GetAllBiddersModeCodeType Enumeration

GetAllBiddersModeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersModeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum GetAllBiddersModeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration GetAllBiddersModeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class GetAllBiddersModeCodeType
Members
Member | Description
ViewAll |
EndedListing |
SecondChanceEligibleEndedListing |
CustomCode |
Remarks


GetAllBiddersRequestType Class

GetAllBiddersRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetAllBiddersRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetAllBiddersRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetAllBiddersRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetAllBiddersRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CallMode |
 | CallModeSpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeBiddingSummary |
 | IncludeBiddingSummarySpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetAllBiddersRequestType


CallMode Property

CallMode Property
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersRequestType ► CallMode
Declaration Syntax
C# Visual Basic Visual C++
public GetAllBiddersModeCodeType CallMode { get; set; }
Public Property CallMode As GetAllBiddersModeCodeType
    Get
    Set
public:
property GetAllBiddersModeCodeType CallMode {
    GetAllBiddersModeCodeType get ();
    void set (GetAllBiddersModeCodeType value);
}


CallModeSpecified Property

CallModeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersRequestType ► CallModeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CallModeSpecified { get; set; }
Public Property CallModeSpecified As Boolean
    Get
    Set
public:
property bool CallModeSpecified {
    bool get ();
    void set (bool value);
}


GetAllBiddersRequestType Constructor

GetAllBiddersRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersRequestType ► GetAllBiddersRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetAllBiddersRequestType()
Public Sub New
public:
GetAllBiddersRequestType()


IncludeBiddingSummary Property

IncludeBiddingSummary Property
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersRequestType ► IncludeBiddingSummary
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeBiddingSummary { get; set; }
Public Property IncludeBiddingSummary As Boolean
    Get
    Set
public:
property bool IncludeBiddingSummary {
    bool get ();
    void set (bool value);
}


IncludeBiddingSummarySpecified Property

IncludeBiddingSummarySpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersRequestType ► IncludeBiddingSummarySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeBiddingSummarySpecified { get; set; }
Public Property IncludeBiddingSummarySpecified As Boolean
    Get
    Set
public:
property bool IncludeBiddingSummarySpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


GetAllBiddersResponseType Class

GetAllBiddersResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetAllBiddersResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetAllBiddersResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetAllBiddersResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetAllBiddersResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BidArray |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | HighBidder |
 | HighestBid |
 | ListingStatus |
 | ListingStatusSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetAllBiddersResponseType


BidArray Property

BidArray Property
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersResponseType ► BidArray
Declaration Syntax
C# Visual Basic Visual C++
public OfferTypeCollection BidArray { get; set; }
Public Property BidArray As OfferTypeCollection
    Get
    Set
public:
property OfferTypeCollection^ BidArray {
    OfferTypeCollection^ get ();
    void set (OfferTypeCollection^ value);
}


GetAllBiddersResponseType Constructor

GetAllBiddersResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersResponseType ► GetAllBiddersResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetAllBiddersResponseType()
Public Sub New
public:
GetAllBiddersResponseType()


HighBidder Property

HighBidder Property
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersResponseType ► HighBidder
Declaration Syntax
C# Visual Basic Visual C++
public string HighBidder { get; set; }
Public Property HighBidder As String
    Get
    Set
public:
property String^ HighBidder {
    String^ get ();
    void set (String^ value);
}


HighestBid Property

HighestBid Property
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersResponseType ► HighestBid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType HighestBid { get; set; }
Public Property HighestBid As AmountType
    Get
    Set
public:
property AmountType^ HighestBid {
    AmountType^ get ();
    void set (AmountType^ value);
}


ListingStatus Property

ListingStatus Property
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersResponseType ► ListingStatus
Declaration Syntax
C# Visual Basic Visual C++
public ListingStatusCodeType ListingStatus { get; set; }
Public Property ListingStatus As ListingStatusCodeType
    Get
    Set
public:
property ListingStatusCodeType ListingStatus {
    ListingStatusCodeType get ();
    void set (ListingStatusCodeType value);
}


ListingStatusSpecified Property

ListingStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetAllBiddersResponseType ► ListingStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingStatusSpecified { get; set; }
Public Property ListingStatusSpecified As Boolean
    Get
    Set
public:
property bool ListingStatusSpecified {
    bool get ();
    void set (bool value);
}


GetApiAccessRulesRequestType Class

GetApiAccessRulesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetApiAccessRulesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetApiAccessRulesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetApiAccessRulesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetApiAccessRulesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetApiAccessRulesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetApiAccessRulesRequestType


GetApiAccessRulesRequestType Constructor

GetApiAccessRulesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetApiAccessRulesRequestType ► GetApiAccessRulesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetApiAccessRulesRequestType()
Public Sub New
public:
GetApiAccessRulesRequestType()


GetApiAccessRulesResponseType Class

GetApiAccessRulesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetApiAccessRulesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetApiAccessRulesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetApiAccessRulesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetApiAccessRulesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetApiAccessRulesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | ApiAccessRule |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetApiAccessRulesResponseType


ApiAccessRule Property

ApiAccessRule Property
Namespaces ► eBay.Service.Core.Soap ► GetApiAccessRulesResponseType ► ApiAccessRule
Declaration Syntax
C# Visual Basic Visual C++
public ApiAccessRuleTypeCollection ApiAccessRule { get; set; }
Public Property ApiAccessRule As ApiAccessRuleTypeCollection
    Get
    Set
public:
property ApiAccessRuleTypeCollection^ ApiAccessRule {
    ApiAccessRuleTypeCollection^ get ();
    void set (ApiAccessRuleTypeCollection^ value);
}


GetApiAccessRulesResponseType Constructor

GetApiAccessRulesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetApiAccessRulesResponseType ► GetApiAccessRulesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetApiAccessRulesResponseType()
Public Sub New
public:
GetApiAccessRulesResponseType()


GetBestOffersRequestType Class

GetBestOffersRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetBestOffersRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetBestOffersRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetBestOffersRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetBestOffersRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BestOfferID |
 | BestOfferStatus |
 | BestOfferStatusSpecified |
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetBestOffersRequestType


BestOfferID Property

BestOfferID Property
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersRequestType ► BestOfferID
Declaration Syntax
C# Visual Basic Visual C++
public string BestOfferID { get; set; }
Public Property BestOfferID As String
    Get
    Set
public:
property String^ BestOfferID {
    String^ get ();
    void set (String^ value);
}


BestOfferStatus Property

BestOfferStatus Property
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersRequestType ► BestOfferStatus
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferStatusCodeType BestOfferStatus { get; set; }
Public Property BestOfferStatus As BestOfferStatusCodeType
    Get
    Set
public:
property BestOfferStatusCodeType BestOfferStatus {
    BestOfferStatusCodeType get ();
    void set (BestOfferStatusCodeType value);
}


BestOfferStatusSpecified Property

BestOfferStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersRequestType ► BestOfferStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferStatusSpecified { get; set; }
Public Property BestOfferStatusSpecified As Boolean
    Get
    Set
public:
property bool BestOfferStatusSpecified {
    bool get ();
    void set (bool value);
}


GetBestOffersRequestType Constructor

GetBestOffersRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersRequestType ► GetBestOffersRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetBestOffersRequestType()
Public Sub New
public:
GetBestOffersRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


GetBestOffersResponseType Class

GetBestOffersResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetBestOffersResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetBestOffersResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetBestOffersResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetBestOffersResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BestOfferArray |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | Item |
 | ItemBestOffersArray |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PageNumber |
 | PageNumberSpecified |
 | PaginationResult |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetBestOffersResponseType


BestOfferArray Property

BestOfferArray Property
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersResponseType ► BestOfferArray
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection BestOfferArray { get; set; }
Public Property BestOfferArray As BestOfferTypeCollection
    Get
    Set
public:
property BestOfferTypeCollection^ BestOfferArray {
    BestOfferTypeCollection^ get ();
    void set (BestOfferTypeCollection^ value);
}


GetBestOffersResponseType Constructor

GetBestOffersResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersResponseType ► GetBestOffersResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetBestOffersResponseType()
Public Sub New
public:
GetBestOffersResponseType()


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersResponseType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemBestOffersArray Property

ItemBestOffersArray Property
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersResponseType ► ItemBestOffersArray
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersArrayType ItemBestOffersArray { get; set; }
Public Property ItemBestOffersArray As ItemBestOffersArrayType
    Get
    Set
public:
property ItemBestOffersArrayType^ ItemBestOffersArray {
    ItemBestOffersArrayType^ get ();
    void set (ItemBestOffersArrayType^ value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersResponseType ► PageNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}


PageNumberSpecified Property

PageNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersResponseType ► PageNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageNumberSpecified { get; set; }
Public Property PageNumberSpecified As Boolean
    Get
    Set
public:
property bool PageNumberSpecified {
    bool get ();
    void set (bool value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetBestOffersResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


GetBidderListRequestType Class

GetBidderListRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetBidderListRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetBidderListRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetBidderListRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetBidderListRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetBidderListRequestType()()()() |
 | ActiveItemsOnly |
 | ActiveItemsOnlySpecified |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndTimeFrom |
 | EndTimeFromSpecified |
 | EndTimeTo |
 | EndTimeToSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GranularityLevel |
 | GranularityLevelSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | UserID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetBidderListRequestType


ActiveItemsOnly Property

ActiveItemsOnly Property
Namespaces ► eBay.Service.Core.Soap ► GetBidderListRequestType ► ActiveItemsOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool ActiveItemsOnly { get; set; }
Public Property ActiveItemsOnly As Boolean
    Get
    Set
public:
property bool ActiveItemsOnly {
    bool get ();
    void set (bool value);
}


ActiveItemsOnlySpecified Property

ActiveItemsOnlySpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetBidderListRequestType ► ActiveItemsOnlySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ActiveItemsOnlySpecified { get; set; }
Public Property ActiveItemsOnlySpecified As Boolean
    Get
    Set
public:
property bool ActiveItemsOnlySpecified {
    bool get ();
    void set (bool value);
}


EndTimeFrom Property

EndTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetBidderListRequestType ► EndTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeFrom { get; set; }
Public Property EndTimeFrom As DateTime
    Get
    Set
public:
property DateTime EndTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


EndTimeFromSpecified Property

EndTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetBidderListRequestType ► EndTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeFromSpecified { get; set; }
Public Property EndTimeFromSpecified As Boolean
    Get
    Set
public:
property bool EndTimeFromSpecified {
    bool get ();
    void set (bool value);
}


EndTimeTo Property

EndTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetBidderListRequestType ► EndTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeTo { get; set; }
Public Property EndTimeTo As DateTime
    Get
    Set
public:
property DateTime EndTimeTo {
    DateTime get ();
    void set (DateTime value);
}


EndTimeToSpecified Property

EndTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetBidderListRequestType ► EndTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeToSpecified { get; set; }
Public Property EndTimeToSpecified As Boolean
    Get
    Set
public:
property bool EndTimeToSpecified {
    bool get ();
    void set (bool value);
}


GetBidderListRequestType Constructor

GetBidderListRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetBidderListRequestType ► GetBidderListRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetBidderListRequestType()
Public Sub New
public:
GetBidderListRequestType()


GranularityLevel Property

GranularityLevel Property
Namespaces ► eBay.Service.Core.Soap ► GetBidderListRequestType ► GranularityLevel
Declaration Syntax
C# Visual Basic Visual C++
public GranularityLevelCodeType GranularityLevel { get; set; }
Public Property GranularityLevel As GranularityLevelCodeType
    Get
    Set
public:
property GranularityLevelCodeType GranularityLevel {
    GranularityLevelCodeType get ();
    void set (GranularityLevelCodeType value);
}


GranularityLevelSpecified Property

GranularityLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetBidderListRequestType ► GranularityLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GranularityLevelSpecified { get; set; }
Public Property GranularityLevelSpecified As Boolean
    Get
    Set
public:
property bool GranularityLevelSpecified {
    bool get ();
    void set (bool value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► GetBidderListRequestType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetBidderListResponseType Class

GetBidderListResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetBidderListResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetBidderListResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetBidderListResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetBidderListResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetBidderListResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | Bidder |
 | BidItemArray |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetBidderListResponseType


Bidder Property

Bidder Property
Namespaces ► eBay.Service.Core.Soap ► GetBidderListResponseType ► Bidder
Declaration Syntax
C# Visual Basic Visual C++
public UserType Bidder { get; set; }
Public Property Bidder As UserType
    Get
    Set
public:
property UserType^ Bidder {
    UserType^ get ();
    void set (UserType^ value);
}


BidItemArray Property

BidItemArray Property
Namespaces ► eBay.Service.Core.Soap ► GetBidderListResponseType ► BidItemArray
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection BidItemArray { get; set; }
Public Property BidItemArray As ItemTypeCollection
    Get
    Set
public:
property ItemTypeCollection^ BidItemArray {
    ItemTypeCollection^ get ();
    void set (ItemTypeCollection^ value);
}


GetBidderListResponseType Constructor

GetBidderListResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetBidderListResponseType ► GetBidderListResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetBidderListResponseType()
Public Sub New
public:
GetBidderListResponseType()


GetCategoriesRequestType Class

GetCategoriesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetCategoriesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetCategoriesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetCategoriesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategoriesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CategoryParent |
 | CategorySiteID |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | LevelLimit |
 | LevelLimitSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | ViewAllNodes |
 | ViewAllNodesSpecified |
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetCategoriesRequestType


CategoryParent Property

CategoryParent Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesRequestType ► CategoryParent
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection CategoryParent { get; set; }
Public Property CategoryParent As StringCollection
    Get
    Set
public:
property StringCollection^ CategoryParent {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


CategorySiteID Property

CategorySiteID Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesRequestType ► CategorySiteID
Declaration Syntax
C# Visual Basic Visual C++
public string CategorySiteID { get; set; }
Public Property CategorySiteID As String
    Get
    Set
public:
property String^ CategorySiteID {
    String^ get ();
    void set (String^ value);
}


GetCategoriesRequestType Constructor

GetCategoriesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesRequestType ► GetCategoriesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoriesRequestType()
Public Sub New
public:
GetCategoriesRequestType()


LevelLimit Property

LevelLimit Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesRequestType ► LevelLimit
Declaration Syntax
C# Visual Basic Visual C++
public int LevelLimit { get; set; }
Public Property LevelLimit As Integer
    Get
    Set
public:
property int LevelLimit {
    int get ();
    void set (int value);
}


LevelLimitSpecified Property

LevelLimitSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesRequestType ► LevelLimitSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LevelLimitSpecified { get; set; }
Public Property LevelLimitSpecified As Boolean
    Get
    Set
public:
property bool LevelLimitSpecified {
    bool get ();
    void set (bool value);
}


ViewAllNodes Property

ViewAllNodes Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesRequestType ► ViewAllNodes
Declaration Syntax
C# Visual Basic Visual C++
public bool ViewAllNodes { get; set; }
Public Property ViewAllNodes As Boolean
    Get
    Set
public:
property bool ViewAllNodes {
    bool get ();
    void set (bool value);
}


ViewAllNodesSpecified Property

ViewAllNodesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesRequestType ► ViewAllNodesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ViewAllNodesSpecified { get; set; }
Public Property ViewAllNodesSpecified As Boolean
    Get
    Set
public:
property bool ViewAllNodesSpecified {
    bool get ();
    void set (bool value);
}


GetCategoriesResponseType Class

GetCategoriesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetCategoriesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetCategoriesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetCategoriesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategoriesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CategoryArray |
 | CategoryCount |
 | CategoryCountSpecified |
 | CategoryVersion |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | MinimumReservePrice |
 | MinimumReservePriceSpecified |
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | ReduceReserveAllowed |
 | ReduceReserveAllowedSpecified |
 | ReservePriceAllowed |
 | ReservePriceAllowedSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetCategoriesResponseType


CategoryArray Property

CategoryArray Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► CategoryArray
Declaration Syntax
C# Visual Basic Visual C++
public CategoryTypeCollection CategoryArray { get; set; }
Public Property CategoryArray As CategoryTypeCollection
    Get
    Set
public:
property CategoryTypeCollection^ CategoryArray {
    CategoryTypeCollection^ get ();
    void set (CategoryTypeCollection^ value);
}


CategoryCount Property

CategoryCount Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► CategoryCount
Declaration Syntax
C# Visual Basic Visual C++
public int CategoryCount { get; set; }
Public Property CategoryCount As Integer
    Get
    Set
public:
property int CategoryCount {
    int get ();
    void set (int value);
}


CategoryCountSpecified Property

CategoryCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► CategoryCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CategoryCountSpecified { get; set; }
Public Property CategoryCountSpecified As Boolean
    Get
    Set
public:
property bool CategoryCountSpecified {
    bool get ();
    void set (bool value);
}


CategoryVersion Property

CategoryVersion Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► CategoryVersion
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryVersion { get; set; }
Public Property CategoryVersion As String
    Get
    Set
public:
property String^ CategoryVersion {
    String^ get ();
    void set (String^ value);
}


GetCategoriesResponseType Constructor

GetCategoriesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► GetCategoriesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoriesResponseType()
Public Sub New
public:
GetCategoriesResponseType()


MinimumReservePrice Property

MinimumReservePrice Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► MinimumReservePrice
Declaration Syntax
C# Visual Basic Visual C++
public double MinimumReservePrice { get; set; }
Public Property MinimumReservePrice As Double
    Get
    Set
public:
property double MinimumReservePrice {
    double get ();
    void set (double value);
}


MinimumReservePriceSpecified Property

MinimumReservePriceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► MinimumReservePriceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinimumReservePriceSpecified { get; set; }
Public Property MinimumReservePriceSpecified As Boolean
    Get
    Set
public:
property bool MinimumReservePriceSpecified {
    bool get ();
    void set (bool value);
}


ReduceReserveAllowed Property

ReduceReserveAllowed Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► ReduceReserveAllowed
Declaration Syntax
C# Visual Basic Visual C++
public bool ReduceReserveAllowed { get; set; }
Public Property ReduceReserveAllowed As Boolean
    Get
    Set
public:
property bool ReduceReserveAllowed {
    bool get ();
    void set (bool value);
}


ReduceReserveAllowedSpecified Property

ReduceReserveAllowedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► ReduceReserveAllowedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReduceReserveAllowedSpecified { get; set; }
Public Property ReduceReserveAllowedSpecified As Boolean
    Get
    Set
public:
property bool ReduceReserveAllowedSpecified {
    bool get ();
    void set (bool value);
}


ReservePriceAllowed Property

ReservePriceAllowed Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► ReservePriceAllowed
Declaration Syntax
C# Visual Basic Visual C++
public bool ReservePriceAllowed { get; set; }
Public Property ReservePriceAllowed As Boolean
    Get
    Set
public:
property bool ReservePriceAllowed {
    bool get ();
    void set (bool value);
}


ReservePriceAllowedSpecified Property

ReservePriceAllowedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► ReservePriceAllowedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReservePriceAllowedSpecified { get; set; }
Public Property ReservePriceAllowedSpecified As Boolean
    Get
    Set
public:
property bool ReservePriceAllowedSpecified {
    bool get ();
    void set (bool value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoriesResponseType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


GetCategoryFeaturesRequestType Class

GetCategoryFeaturesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetCategoryFeaturesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetCategoryFeaturesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetCategoryFeaturesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategoryFeaturesRequestType()()()() |
 | AllFeaturesForCategory |
 | AllFeaturesForCategorySpecified |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CategoryID |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | FeatureID |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | LevelLimit |
 | LevelLimitSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | ViewAllNodes |
 | ViewAllNodesSpecified |
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetCategoryFeaturesRequestType


AllFeaturesForCategory Property

AllFeaturesForCategory Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesRequestType ► AllFeaturesForCategory
Declaration Syntax
C# Visual Basic Visual C++
public bool AllFeaturesForCategory { get; set; }
Public Property AllFeaturesForCategory As Boolean
    Get
    Set
public:
property bool AllFeaturesForCategory {
    bool get ();
    void set (bool value);
}


AllFeaturesForCategorySpecified Property

AllFeaturesForCategorySpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesRequestType ► AllFeaturesForCategorySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AllFeaturesForCategorySpecified { get; set; }
Public Property AllFeaturesForCategorySpecified As Boolean
    Get
    Set
public:
property bool AllFeaturesForCategorySpecified {
    bool get ();
    void set (bool value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesRequestType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


FeatureID Property

FeatureID Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesRequestType ► FeatureID
Declaration Syntax
C# Visual Basic Visual C++
public FeatureIDCodeTypeCollection FeatureID { get; set; }
Public Property FeatureID As FeatureIDCodeTypeCollection
    Get
    Set
public:
property FeatureIDCodeTypeCollection^ FeatureID {
    FeatureIDCodeTypeCollection^ get ();
    void set (FeatureIDCodeTypeCollection^ value);
}


GetCategoryFeaturesRequestType Constructor

GetCategoryFeaturesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesRequestType ► GetCategoryFeaturesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryFeaturesRequestType()
Public Sub New
public:
GetCategoryFeaturesRequestType()


LevelLimit Property

LevelLimit Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesRequestType ► LevelLimit
Declaration Syntax
C# Visual Basic Visual C++
public int LevelLimit { get; set; }
Public Property LevelLimit As Integer
    Get
    Set
public:
property int LevelLimit {
    int get ();
    void set (int value);
}


LevelLimitSpecified Property

LevelLimitSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesRequestType ► LevelLimitSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LevelLimitSpecified { get; set; }
Public Property LevelLimitSpecified As Boolean
    Get
    Set
public:
property bool LevelLimitSpecified {
    bool get ();
    void set (bool value);
}


ViewAllNodes Property

ViewAllNodes Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesRequestType ► ViewAllNodes
Declaration Syntax
C# Visual Basic Visual C++
public bool ViewAllNodes { get; set; }
Public Property ViewAllNodes As Boolean
    Get
    Set
public:
property bool ViewAllNodes {
    bool get ();
    void set (bool value);
}


ViewAllNodesSpecified Property

ViewAllNodesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesRequestType ► ViewAllNodesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ViewAllNodesSpecified { get; set; }
Public Property ViewAllNodesSpecified As Boolean
    Get
    Set
public:
property bool ViewAllNodesSpecified {
    bool get ();
    void set (bool value);
}


GetCategoryFeaturesResponseType Class

GetCategoryFeaturesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetCategoryFeaturesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetCategoryFeaturesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetCategoryFeaturesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategoryFeaturesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category |
 | CategoryVersion |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | FeatureDefinitions |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SiteDefaults |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetCategoryFeaturesResponseType


Category Property

Category Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesResponseType ► Category
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureTypeCollection Category { get; set; }
Public Property Category As CategoryFeatureTypeCollection
    Get
    Set
public:
property CategoryFeatureTypeCollection^ Category {
    CategoryFeatureTypeCollection^ get ();
    void set (CategoryFeatureTypeCollection^ value);
}


CategoryVersion Property

CategoryVersion Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesResponseType ► CategoryVersion
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryVersion { get; set; }
Public Property CategoryVersion As String
    Get
    Set
public:
property String^ CategoryVersion {
    String^ get ();
    void set (String^ value);
}


FeatureDefinitions Property

FeatureDefinitions Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesResponseType ► FeatureDefinitions
Declaration Syntax
C# Visual Basic Visual C++
public FeatureDefinitionsType FeatureDefinitions { get; set; }
Public Property FeatureDefinitions As FeatureDefinitionsType
    Get
    Set
public:
property FeatureDefinitionsType^ FeatureDefinitions {
    FeatureDefinitionsType^ get ();
    void set (FeatureDefinitionsType^ value);
}


GetCategoryFeaturesResponseType Constructor

GetCategoryFeaturesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesResponseType ► GetCategoryFeaturesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryFeaturesResponseType()
Public Sub New
public:
GetCategoryFeaturesResponseType()


SiteDefaults Property

SiteDefaults Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesResponseType ► SiteDefaults
Declaration Syntax
C# Visual Basic Visual C++
public SiteDefaultsType SiteDefaults { get; set; }
Public Property SiteDefaults As SiteDefaultsType
    Get
    Set
public:
property SiteDefaultsType^ SiteDefaults {
    SiteDefaultsType^ get ();
    void set (SiteDefaultsType^ value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesResponseType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryFeaturesResponseType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


GetCategoryMappingsRequestType Class

GetCategoryMappingsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetCategoryMappingsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetCategoryMappingsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetCategoryMappingsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetCategoryMappingsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategoryMappingsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CategoryVersion |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetCategoryMappingsRequestType


CategoryVersion Property

CategoryVersion Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryMappingsRequestType ► CategoryVersion
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryVersion { get; set; }
Public Property CategoryVersion As String
    Get
    Set
public:
property String^ CategoryVersion {
    String^ get ();
    void set (String^ value);
}


GetCategoryMappingsRequestType Constructor

GetCategoryMappingsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetCategoryMappingsRequestType ► GetCategoryMappingsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryMappingsRequestType()
Public Sub New
public:
GetCategoryMappingsRequestType()


GetCategoryMappingsResponseType Class

GetCategoryMappingsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetCategoryMappingsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetCategoryMappingsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetCategoryMappingsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetCategoryMappingsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategoryMappingsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CategoryMapping |
 | CategoryVersion |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetCategoryMappingsResponseType


CategoryMapping Property

CategoryMapping Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryMappingsResponseType ► CategoryMapping
Declaration Syntax
C# Visual Basic Visual C++
public CategoryMappingTypeCollection CategoryMapping { get; set; }
Public Property CategoryMapping As CategoryMappingTypeCollection
    Get
    Set
public:
property CategoryMappingTypeCollection^ CategoryMapping {
    CategoryMappingTypeCollection^ get ();
    void set (CategoryMappingTypeCollection^ value);
}


CategoryVersion Property

CategoryVersion Property
Namespaces ► eBay.Service.Core.Soap ► GetCategoryMappingsResponseType ► CategoryVersion
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryVersion { get; set; }
Public Property CategoryVersion As String
    Get
    Set
public:
property String^ CategoryVersion {
    String^ get ();
    void set (String^ value);
}


GetCategoryMappingsResponseType Constructor

GetCategoryMappingsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetCategoryMappingsResponseType ► GetCategoryMappingsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryMappingsResponseType()
Public Sub New
public:
GetCategoryMappingsResponseType()


GetCategorySpecificsRequestType Class

GetCategorySpecificsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetCategorySpecificsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetCategorySpecificsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetCategorySpecificsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategorySpecificsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CategoryID |
 | CategorySpecific |
 | CategorySpecificsFileInfo |
 | CategorySpecificsFileInfoSpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | ExcludeRelationships |
 | ExcludeRelationshipsSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeConfidence |
 | IncludeConfidenceSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | LastUpdateTime |
 | LastUpdateTimeSpecified |
 | MaxNames |
 | MaxNamesSpecified |
 | MaxValuesPerName |
 | MaxValuesPerNameSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | Name |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetCategorySpecificsRequestType


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection CategoryID { get; set; }
Public Property CategoryID As StringCollection
    Get
    Set
public:
property StringCollection^ CategoryID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


CategorySpecific Property

CategorySpecific Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► CategorySpecific
Declaration Syntax
C# Visual Basic Visual C++
public CategoryItemSpecificsTypeCollection CategorySpecific { get; set; }
Public Property CategorySpecific As CategoryItemSpecificsTypeCollection
    Get
    Set
public:
property CategoryItemSpecificsTypeCollection^ CategorySpecific {
    CategoryItemSpecificsTypeCollection^ get ();
    void set (CategoryItemSpecificsTypeCollection^ value);
}


CategorySpecificsFileInfo Property

CategorySpecificsFileInfo Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► CategorySpecificsFileInfo
Declaration Syntax
C# Visual Basic Visual C++
public bool CategorySpecificsFileInfo { get; set; }
Public Property CategorySpecificsFileInfo As Boolean
    Get
    Set
public:
property bool CategorySpecificsFileInfo {
    bool get ();
    void set (bool value);
}


CategorySpecificsFileInfoSpecified Property

CategorySpecificsFileInfoSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► CategorySpecificsFileInfoSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CategorySpecificsFileInfoSpecified { get; set; }
Public Property CategorySpecificsFileInfoSpecified As Boolean
    Get
    Set
public:
property bool CategorySpecificsFileInfoSpecified {
    bool get ();
    void set (bool value);
}


ExcludeRelationships Property

ExcludeRelationships Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► ExcludeRelationships
Declaration Syntax
C# Visual Basic Visual C++
public bool ExcludeRelationships { get; set; }
Public Property ExcludeRelationships As Boolean
    Get
    Set
public:
property bool ExcludeRelationships {
    bool get ();
    void set (bool value);
}


ExcludeRelationshipsSpecified Property

ExcludeRelationshipsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► ExcludeRelationshipsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExcludeRelationshipsSpecified { get; set; }
Public Property ExcludeRelationshipsSpecified As Boolean
    Get
    Set
public:
property bool ExcludeRelationshipsSpecified {
    bool get ();
    void set (bool value);
}


GetCategorySpecificsRequestType Constructor

GetCategorySpecificsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► GetCategorySpecificsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategorySpecificsRequestType()
Public Sub New
public:
GetCategorySpecificsRequestType()


IncludeConfidence Property

IncludeConfidence Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► IncludeConfidence
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeConfidence { get; set; }
Public Property IncludeConfidence As Boolean
    Get
    Set
public:
property bool IncludeConfidence {
    bool get ();
    void set (bool value);
}


IncludeConfidenceSpecified Property

IncludeConfidenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► IncludeConfidenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeConfidenceSpecified { get; set; }
Public Property IncludeConfidenceSpecified As Boolean
    Get
    Set
public:
property bool IncludeConfidenceSpecified {
    bool get ();
    void set (bool value);
}


LastUpdateTime Property

LastUpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► LastUpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastUpdateTime { get; set; }
Public Property LastUpdateTime As DateTime
    Get
    Set
public:
property DateTime LastUpdateTime {
    DateTime get ();
    void set (DateTime value);
}


LastUpdateTimeSpecified Property

LastUpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► LastUpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastUpdateTimeSpecified { get; set; }
Public Property LastUpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool LastUpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


MaxNames Property

MaxNames Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► MaxNames
Declaration Syntax
C# Visual Basic Visual C++
public int MaxNames { get; set; }
Public Property MaxNames As Integer
    Get
    Set
public:
property int MaxNames {
    int get ();
    void set (int value);
}


MaxNamesSpecified Property

MaxNamesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► MaxNamesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxNamesSpecified { get; set; }
Public Property MaxNamesSpecified As Boolean
    Get
    Set
public:
property bool MaxNamesSpecified {
    bool get ();
    void set (bool value);
}


MaxValuesPerName Property

MaxValuesPerName Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► MaxValuesPerName
Declaration Syntax
C# Visual Basic Visual C++
public int MaxValuesPerName { get; set; }
Public Property MaxValuesPerName As Integer
    Get
    Set
public:
property int MaxValuesPerName {
    int get ();
    void set (int value);
}


MaxValuesPerNameSpecified Property

MaxValuesPerNameSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► MaxValuesPerNameSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxValuesPerNameSpecified { get; set; }
Public Property MaxValuesPerNameSpecified As Boolean
    Get
    Set
public:
property bool MaxValuesPerNameSpecified {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsRequestType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


GetCategorySpecificsResponseType Class

GetCategorySpecificsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetCategorySpecificsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetCategorySpecificsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetCategorySpecificsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCategorySpecificsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | FileReferenceID |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Recommendations |
 | TaskReferenceID |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetCategorySpecificsResponseType


FileReferenceID Property

FileReferenceID Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsResponseType ► FileReferenceID
Declaration Syntax
C# Visual Basic Visual C++
public string FileReferenceID { get; set; }
Public Property FileReferenceID As String
    Get
    Set
public:
property String^ FileReferenceID {
    String^ get ();
    void set (String^ value);
}


GetCategorySpecificsResponseType Constructor

GetCategorySpecificsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsResponseType ► GetCategorySpecificsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCategorySpecificsResponseType()
Public Sub New
public:
GetCategorySpecificsResponseType()


Recommendations Property

Recommendations Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsResponseType ► Recommendations
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationsTypeCollection Recommendations { get; set; }
Public Property Recommendations As RecommendationsTypeCollection
    Get
    Set
public:
property RecommendationsTypeCollection^ Recommendations {
    RecommendationsTypeCollection^ get ();
    void set (RecommendationsTypeCollection^ value);
}


TaskReferenceID Property

TaskReferenceID Property
Namespaces ► eBay.Service.Core.Soap ► GetCategorySpecificsResponseType ► TaskReferenceID
Declaration Syntax
C# Visual Basic Visual C++
public string TaskReferenceID { get; set; }
Public Property TaskReferenceID As String
    Get
    Set
public:
property String^ TaskReferenceID {
    String^ get ();
    void set (String^ value);
}


GetChallengeTokenRequestType Class

GetChallengeTokenRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetChallengeTokenRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetChallengeTokenRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetChallengeTokenRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetChallengeTokenRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetChallengeTokenRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetChallengeTokenRequestType


GetChallengeTokenRequestType Constructor

GetChallengeTokenRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetChallengeTokenRequestType ► GetChallengeTokenRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetChallengeTokenRequestType()
Public Sub New
public:
GetChallengeTokenRequestType()


GetChallengeTokenResponseType Class

GetChallengeTokenResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetChallengeTokenResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetChallengeTokenResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetChallengeTokenResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetChallengeTokenResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetChallengeTokenResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | AudioChallengeURL |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | ChallengeToken |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ImageChallengeURL |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetChallengeTokenResponseType


AudioChallengeURL Property

AudioChallengeURL Property
Namespaces ► eBay.Service.Core.Soap ► GetChallengeTokenResponseType ► AudioChallengeURL
Declaration Syntax
C# Visual Basic Visual C++
public string AudioChallengeURL { get; set; }
Public Property AudioChallengeURL As String
    Get
    Set
public:
property String^ AudioChallengeURL {
    String^ get ();
    void set (String^ value);
}


ChallengeToken Property

ChallengeToken Property
Namespaces ► eBay.Service.Core.Soap ► GetChallengeTokenResponseType ► ChallengeToken
Declaration Syntax
C# Visual Basic Visual C++
public string ChallengeToken { get; set; }
Public Property ChallengeToken As String
    Get
    Set
public:
property String^ ChallengeToken {
    String^ get ();
    void set (String^ value);
}


GetChallengeTokenResponseType Constructor

GetChallengeTokenResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetChallengeTokenResponseType ► GetChallengeTokenResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetChallengeTokenResponseType()
Public Sub New
public:
GetChallengeTokenResponseType()


ImageChallengeURL Property

ImageChallengeURL Property
Namespaces ► eBay.Service.Core.Soap ► GetChallengeTokenResponseType ► ImageChallengeURL
Declaration Syntax
C# Visual Basic Visual C++
public string ImageChallengeURL { get; set; }
Public Property ImageChallengeURL As String
    Get
    Set
public:
property String^ ImageChallengeURL {
    String^ get ();
    void set (String^ value);
}


GetCharitiesRequestType Class

GetCharitiesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetCharitiesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetCharitiesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetCharitiesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCharitiesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CampaignID |
 | CampaignIDSpecified |
 | CharityDomain |
 | CharityDomainSpecified |
 | CharityID |
 | CharityName |
 | CharityRegion |
 | CharityRegionSpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Featured |
 | FeaturedSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeDescription |
 | IncludeDescriptionSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | MatchType |
 | MatchTypeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Query |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetCharitiesRequestType


CampaignID Property

CampaignID Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► CampaignID
Declaration Syntax
C# Visual Basic Visual C++
public long CampaignID { get; set; }
Public Property CampaignID As Long
    Get
    Set
public:
property long long CampaignID {
    long long get ();
    void set (long long value);
}


CampaignIDSpecified Property

CampaignIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► CampaignIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CampaignIDSpecified { get; set; }
Public Property CampaignIDSpecified As Boolean
    Get
    Set
public:
property bool CampaignIDSpecified {
    bool get ();
    void set (bool value);
}


CharityDomain Property

CharityDomain Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► CharityDomain
Declaration Syntax
C# Visual Basic Visual C++
public int CharityDomain { get; set; }
Public Property CharityDomain As Integer
    Get
    Set
public:
property int CharityDomain {
    int get ();
    void set (int value);
}


CharityDomainSpecified Property

CharityDomainSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► CharityDomainSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CharityDomainSpecified { get; set; }
Public Property CharityDomainSpecified As Boolean
    Get
    Set
public:
property bool CharityDomainSpecified {
    bool get ();
    void set (bool value);
}


CharityID Property

CharityID Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► CharityID
Declaration Syntax
C# Visual Basic Visual C++
public string CharityID { get; set; }
Public Property CharityID As String
    Get
    Set
public:
property String^ CharityID {
    String^ get ();
    void set (String^ value);
}


CharityName Property

CharityName Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► CharityName
Declaration Syntax
C# Visual Basic Visual C++
public string CharityName { get; set; }
Public Property CharityName As String
    Get
    Set
public:
property String^ CharityName {
    String^ get ();
    void set (String^ value);
}


CharityRegion Property

CharityRegion Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► CharityRegion
Declaration Syntax
C# Visual Basic Visual C++
public int CharityRegion { get; set; }
Public Property CharityRegion As Integer
    Get
    Set
public:
property int CharityRegion {
    int get ();
    void set (int value);
}


CharityRegionSpecified Property

CharityRegionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► CharityRegionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CharityRegionSpecified { get; set; }
Public Property CharityRegionSpecified As Boolean
    Get
    Set
public:
property bool CharityRegionSpecified {
    bool get ();
    void set (bool value);
}


Featured Property

Featured Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► Featured
Declaration Syntax
C# Visual Basic Visual C++
public bool Featured { get; set; }
Public Property Featured As Boolean
    Get
    Set
public:
property bool Featured {
    bool get ();
    void set (bool value);
}


FeaturedSpecified Property

FeaturedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► FeaturedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeaturedSpecified { get; set; }
Public Property FeaturedSpecified As Boolean
    Get
    Set
public:
property bool FeaturedSpecified {
    bool get ();
    void set (bool value);
}


GetCharitiesRequestType Constructor

GetCharitiesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► GetCharitiesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCharitiesRequestType()
Public Sub New
public:
GetCharitiesRequestType()


IncludeDescription Property

IncludeDescription Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► IncludeDescription
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeDescription { get; set; }
Public Property IncludeDescription As Boolean
    Get
    Set
public:
property bool IncludeDescription {
    bool get ();
    void set (bool value);
}


IncludeDescriptionSpecified Property

IncludeDescriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► IncludeDescriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeDescriptionSpecified { get; set; }
Public Property IncludeDescriptionSpecified As Boolean
    Get
    Set
public:
property bool IncludeDescriptionSpecified {
    bool get ();
    void set (bool value);
}


MatchType Property

MatchType Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► MatchType
Declaration Syntax
C# Visual Basic Visual C++
public StringMatchCodeType MatchType { get; set; }
Public Property MatchType As StringMatchCodeType
    Get
    Set
public:
property StringMatchCodeType MatchType {
    StringMatchCodeType get ();
    void set (StringMatchCodeType value);
}


MatchTypeSpecified Property

MatchTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► MatchTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MatchTypeSpecified { get; set; }
Public Property MatchTypeSpecified As Boolean
    Get
    Set
public:
property bool MatchTypeSpecified {
    bool get ();
    void set (bool value);
}


Query Property

Query Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesRequestType ► Query
Declaration Syntax
C# Visual Basic Visual C++
public string Query { get; set; }
Public Property Query As String
    Get
    Set
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}


GetCharitiesResponseType Class

GetCharitiesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetCharitiesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetCharitiesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetCharitiesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetCharitiesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Charity |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetCharitiesResponseType


Charity Property

Charity Property
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesResponseType ► Charity
Declaration Syntax
C# Visual Basic Visual C++
public CharityInfoTypeCollection Charity { get; set; }
Public Property Charity As CharityInfoTypeCollection
    Get
    Set
public:
property CharityInfoTypeCollection^ Charity {
    CharityInfoTypeCollection^ get ();
    void set (CharityInfoTypeCollection^ value);
}


GetCharitiesResponseType Constructor

GetCharitiesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetCharitiesResponseType ► GetCharitiesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetCharitiesResponseType()
Public Sub New
public:
GetCharitiesResponseType()


GetClientAlertsAuthTokenRequestType Class

GetClientAlertsAuthTokenRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetClientAlertsAuthTokenRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetClientAlertsAuthTokenRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetClientAlertsAuthTokenRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetClientAlertsAuthTokenRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetClientAlertsAuthTokenRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetClientAlertsAuthTokenRequestType


GetClientAlertsAuthTokenRequestType Constructor

GetClientAlertsAuthTokenRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetClientAlertsAuthTokenRequestType ► GetClientAlertsAuthTokenRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetClientAlertsAuthTokenRequestType()
Public Sub New
public:
GetClientAlertsAuthTokenRequestType()


GetClientAlertsAuthTokenResponseType Class

GetClientAlertsAuthTokenResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetClientAlertsAuthTokenResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetClientAlertsAuthTokenResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetClientAlertsAuthTokenResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetClientAlertsAuthTokenResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetClientAlertsAuthTokenResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | ClientAlertsAuthToken |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationTime |
 | HardExpirationTimeSpecified |
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetClientAlertsAuthTokenResponseType


ClientAlertsAuthToken Property

ClientAlertsAuthToken Property
Namespaces ► eBay.Service.Core.Soap ► GetClientAlertsAuthTokenResponseType ► ClientAlertsAuthToken
Declaration Syntax
C# Visual Basic Visual C++
public string ClientAlertsAuthToken { get; set; }
Public Property ClientAlertsAuthToken As String
    Get
    Set
public:
property String^ ClientAlertsAuthToken {
    String^ get ();
    void set (String^ value);
}


GetClientAlertsAuthTokenResponseType Constructor

GetClientAlertsAuthTokenResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetClientAlertsAuthTokenResponseType ► GetClientAlertsAuthTokenResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetClientAlertsAuthTokenResponseType()
Public Sub New
public:
GetClientAlertsAuthTokenResponseType()


HardExpirationTime Property

HardExpirationTime Property
Namespaces ► eBay.Service.Core.Soap ► GetClientAlertsAuthTokenResponseType ► HardExpirationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime HardExpirationTime { get; set; }
Public Property HardExpirationTime As DateTime
    Get
    Set
public:
property DateTime HardExpirationTime {
    DateTime get ();
    void set (DateTime value);
}


HardExpirationTimeSpecified Property

HardExpirationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetClientAlertsAuthTokenResponseType ► HardExpirationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HardExpirationTimeSpecified { get; set; }
Public Property HardExpirationTimeSpecified As Boolean
    Get
    Set
public:
property bool HardExpirationTimeSpecified {
    bool get ();
    void set (bool value);
}


GetContextualKeywordsRequestType Class

GetContextualKeywordsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetContextualKeywordsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetContextualKeywordsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetContextualKeywordsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetContextualKeywordsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetContextualKeywordsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CategoryID |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | Encoding |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | URL |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetContextualKeywordsRequestType


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► GetContextualKeywordsRequestType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection CategoryID { get; set; }
Public Property CategoryID As StringCollection
    Get
    Set
public:
property StringCollection^ CategoryID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Encoding Property

Encoding Property
Namespaces ► eBay.Service.Core.Soap ► GetContextualKeywordsRequestType ► Encoding
Declaration Syntax
C# Visual Basic Visual C++
public string Encoding { get; set; }
Public Property Encoding As String
    Get
    Set
public:
property String^ Encoding {
    String^ get ();
    void set (String^ value);
}


GetContextualKeywordsRequestType Constructor

GetContextualKeywordsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetContextualKeywordsRequestType ► GetContextualKeywordsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetContextualKeywordsRequestType()
Public Sub New
public:
GetContextualKeywordsRequestType()


URL Property

URL Property
Namespaces ► eBay.Service.Core.Soap ► GetContextualKeywordsRequestType ► URL
Declaration Syntax
C# Visual Basic Visual C++
public string URL { get; set; }
Public Property URL As String
    Get
    Set
public:
property String^ URL {
    String^ get ();
    void set (String^ value);
}


GetContextualKeywordsResponseType Class

GetContextualKeywordsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetContextualKeywordsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetContextualKeywordsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetContextualKeywordsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetContextualKeywordsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetContextualKeywordsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | ContextSearchAsset |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetContextualKeywordsResponseType


ContextSearchAsset Property

ContextSearchAsset Property
Namespaces ► eBay.Service.Core.Soap ► GetContextualKeywordsResponseType ► ContextSearchAsset
Declaration Syntax
C# Visual Basic Visual C++
public ContextSearchAssetTypeCollection ContextSearchAsset { get; set; }
Public Property ContextSearchAsset As ContextSearchAssetTypeCollection
    Get
    Set
public:
property ContextSearchAssetTypeCollection^ ContextSearchAsset {
    ContextSearchAssetTypeCollection^ get ();
    void set (ContextSearchAssetTypeCollection^ value);
}


GetContextualKeywordsResponseType Constructor

GetContextualKeywordsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetContextualKeywordsResponseType ► GetContextualKeywordsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetContextualKeywordsResponseType()
Public Sub New
public:
GetContextualKeywordsResponseType()


GetDescriptionTemplatesRequestType Class

GetDescriptionTemplatesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetDescriptionTemplatesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetDescriptionTemplatesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetDescriptionTemplatesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetDescriptionTemplatesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CategoryID |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | LastModifiedTime |
 | LastModifiedTimeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | MotorVehicles |
 | MotorVehiclesSpecified |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetDescriptionTemplatesRequestType


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesRequestType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


GetDescriptionTemplatesRequestType Constructor

GetDescriptionTemplatesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesRequestType ► GetDescriptionTemplatesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetDescriptionTemplatesRequestType()
Public Sub New
public:
GetDescriptionTemplatesRequestType()


LastModifiedTime Property

LastModifiedTime Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesRequestType ► LastModifiedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastModifiedTime { get; set; }
Public Property LastModifiedTime As DateTime
    Get
    Set
public:
property DateTime LastModifiedTime {
    DateTime get ();
    void set (DateTime value);
}


LastModifiedTimeSpecified Property

LastModifiedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesRequestType ► LastModifiedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastModifiedTimeSpecified { get; set; }
Public Property LastModifiedTimeSpecified As Boolean
    Get
    Set
public:
property bool LastModifiedTimeSpecified {
    bool get ();
    void set (bool value);
}


MotorVehicles Property

MotorVehicles Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesRequestType ► MotorVehicles
Declaration Syntax
C# Visual Basic Visual C++
public bool MotorVehicles { get; set; }
Public Property MotorVehicles As Boolean
    Get
    Set
public:
property bool MotorVehicles {
    bool get ();
    void set (bool value);
}


MotorVehiclesSpecified Property

MotorVehiclesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesRequestType ► MotorVehiclesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MotorVehiclesSpecified { get; set; }
Public Property MotorVehiclesSpecified As Boolean
    Get
    Set
public:
property bool MotorVehiclesSpecified {
    bool get ();
    void set (bool value);
}


GetDescriptionTemplatesResponseType Class

GetDescriptionTemplatesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetDescriptionTemplatesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetDescriptionTemplatesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetDescriptionTemplatesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetDescriptionTemplatesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DescriptionTemplate |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | LayoutTotal |
 | LayoutTotalSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | ObsoleteLayoutID |
 | ObsoleteThemeID |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | ThemeGroup |
 | ThemeTotal |
 | ThemeTotalSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetDescriptionTemplatesResponseType


DescriptionTemplate Property

DescriptionTemplate Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesResponseType ► DescriptionTemplate
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionTemplateTypeCollection DescriptionTemplate { get; set; }
Public Property DescriptionTemplate As DescriptionTemplateTypeCollection
    Get
    Set
public:
property DescriptionTemplateTypeCollection^ DescriptionTemplate {
    DescriptionTemplateTypeCollection^ get ();
    void set (DescriptionTemplateTypeCollection^ value);
}


GetDescriptionTemplatesResponseType Constructor

GetDescriptionTemplatesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesResponseType ► GetDescriptionTemplatesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetDescriptionTemplatesResponseType()
Public Sub New
public:
GetDescriptionTemplatesResponseType()


LayoutTotal Property

LayoutTotal Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesResponseType ► LayoutTotal
Declaration Syntax
C# Visual Basic Visual C++
public int LayoutTotal { get; set; }
Public Property LayoutTotal As Integer
    Get
    Set
public:
property int LayoutTotal {
    int get ();
    void set (int value);
}


LayoutTotalSpecified Property

LayoutTotalSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesResponseType ► LayoutTotalSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LayoutTotalSpecified { get; set; }
Public Property LayoutTotalSpecified As Boolean
    Get
    Set
public:
property bool LayoutTotalSpecified {
    bool get ();
    void set (bool value);
}


ObsoleteLayoutID Property

ObsoleteLayoutID Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesResponseType ► ObsoleteLayoutID
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection ObsoleteLayoutID { get; set; }
Public Property ObsoleteLayoutID As Int32Collection
    Get
    Set
public:
property Int32Collection^ ObsoleteLayoutID {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


ObsoleteThemeID Property

ObsoleteThemeID Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesResponseType ► ObsoleteThemeID
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection ObsoleteThemeID { get; set; }
Public Property ObsoleteThemeID As Int32Collection
    Get
    Set
public:
property Int32Collection^ ObsoleteThemeID {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


ThemeGroup Property

ThemeGroup Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesResponseType ► ThemeGroup
Declaration Syntax
C# Visual Basic Visual C++
public ThemeGroupTypeCollection ThemeGroup { get; set; }
Public Property ThemeGroup As ThemeGroupTypeCollection
    Get
    Set
public:
property ThemeGroupTypeCollection^ ThemeGroup {
    ThemeGroupTypeCollection^ get ();
    void set (ThemeGroupTypeCollection^ value);
}


ThemeTotal Property

ThemeTotal Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesResponseType ► ThemeTotal
Declaration Syntax
C# Visual Basic Visual C++
public int ThemeTotal { get; set; }
Public Property ThemeTotal As Integer
    Get
    Set
public:
property int ThemeTotal {
    int get ();
    void set (int value);
}


ThemeTotalSpecified Property

ThemeTotalSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetDescriptionTemplatesResponseType ► ThemeTotalSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ThemeTotalSpecified { get; set; }
Public Property ThemeTotalSpecified As Boolean
    Get
    Set
public:
property bool ThemeTotalSpecified {
    bool get ();
    void set (bool value);
}


GetDisputeRequestType Class

GetDisputeRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetDisputeRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetDisputeRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetDisputeRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetDisputeRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetDisputeRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | DisputeID |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetDisputeRequestType


DisputeID Property

DisputeID Property
Namespaces ► eBay.Service.Core.Soap ► GetDisputeRequestType ► DisputeID
Declaration Syntax
C# Visual Basic Visual C++
public string DisputeID { get; set; }
Public Property DisputeID As String
    Get
    Set
public:
property String^ DisputeID {
    String^ get ();
    void set (String^ value);
}


GetDisputeRequestType Constructor

GetDisputeRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetDisputeRequestType ► GetDisputeRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetDisputeRequestType()
Public Sub New
public:
GetDisputeRequestType()


GetDisputeResponseType Class

GetDisputeResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetDisputeResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetDisputeResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetDisputeResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetDisputeResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetDisputeResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | Dispute |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetDisputeResponseType


Dispute Property

Dispute Property
Namespaces ► eBay.Service.Core.Soap ► GetDisputeResponseType ► Dispute
Declaration Syntax
C# Visual Basic Visual C++
public DisputeType Dispute { get; set; }
Public Property Dispute As DisputeType
    Get
    Set
public:
property DisputeType^ Dispute {
    DisputeType^ get ();
    void set (DisputeType^ value);
}


GetDisputeResponseType Constructor

GetDisputeResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetDisputeResponseType ► GetDisputeResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetDisputeResponseType()
Public Sub New
public:
GetDisputeResponseType()


GeteBayDetailsRequestType Class

GeteBayDetailsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GeteBayDetailsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GeteBayDetailsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GeteBayDetailsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeteBayDetailsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | DetailName |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GeteBayDetailsRequestType


DetailName Property

DetailName Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsRequestType ► DetailName
Declaration Syntax
C# Visual Basic Visual C++
public DetailNameCodeTypeCollection DetailName { get; set; }
Public Property DetailName As DetailNameCodeTypeCollection
    Get
    Set
public:
property DetailNameCodeTypeCollection^ DetailName {
    DetailNameCodeTypeCollection^ get ();
    void set (DetailNameCodeTypeCollection^ value);
}


GeteBayDetailsRequestType Constructor

GeteBayDetailsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsRequestType ► GeteBayDetailsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayDetailsRequestType()
Public Sub New
public:
GeteBayDetailsRequestType()


GeteBayDetailsResponseType Class

GeteBayDetailsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GeteBayDetailsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GeteBayDetailsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GeteBayDetailsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeteBayDetailsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | BuyerRequirementDetails |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | CountryDetails |
 | CurrencyDetails |
 | DispatchTimeMaxDetails |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExcludeShippingLocationDetails |
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemSpecificDetails |
 | ListingFeatureDetails |
 | ListingStartPriceDetails |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PaymentOptionDetails |
 | ProductDetails |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | RecoupmentPolicyDetails |
 | RegionDetails |
 | RegionOfOriginDetails |
 | ReturnPolicyDetails |
 | ShippingCarrierDetails |
 | ShippingCategoryDetails |
 | ShippingLocationDetails |
 | ShippingPackageDetails |
 | ShippingServiceDetails |
 | SiteDetails |
 | TaxJurisdiction |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | TimeZoneDetails |
 | ToString()()()() | (Inherited from Object.)
 | UnitOfMeasurementDetails |
 | UpdateTime |
 | UpdateTimeSpecified |
 | URLDetails |
 | VariationDetails |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GeteBayDetailsResponseType


BuyerRequirementDetails Property

BuyerRequirementDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► BuyerRequirementDetails
Declaration Syntax
C# Visual Basic Visual C++
public SiteBuyerRequirementDetailsTypeCollection BuyerRequirementDetails { get; set; }
Public Property BuyerRequirementDetails As SiteBuyerRequirementDetailsTypeCollection
    Get
    Set
public:
property SiteBuyerRequirementDetailsTypeCollection^ BuyerRequirementDetails {
    SiteBuyerRequirementDetailsTypeCollection^ get ();
    void set (SiteBuyerRequirementDetailsTypeCollection^ value);
}


CountryDetails Property

CountryDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► CountryDetails
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsTypeCollection CountryDetails { get; set; }
Public Property CountryDetails As CountryDetailsTypeCollection
    Get
    Set
public:
property CountryDetailsTypeCollection^ CountryDetails {
    CountryDetailsTypeCollection^ get ();
    void set (CountryDetailsTypeCollection^ value);
}


CurrencyDetails Property

CurrencyDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► CurrencyDetails
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyDetailsTypeCollection CurrencyDetails { get; set; }
Public Property CurrencyDetails As CurrencyDetailsTypeCollection
    Get
    Set
public:
property CurrencyDetailsTypeCollection^ CurrencyDetails {
    CurrencyDetailsTypeCollection^ get ();
    void set (CurrencyDetailsTypeCollection^ value);
}


DispatchTimeMaxDetails Property

DispatchTimeMaxDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► DispatchTimeMaxDetails
Declaration Syntax
C# Visual Basic Visual C++
public DispatchTimeMaxDetailsTypeCollection DispatchTimeMaxDetails { get; set; }
Public Property DispatchTimeMaxDetails As DispatchTimeMaxDetailsTypeCollection
    Get
    Set
public:
property DispatchTimeMaxDetailsTypeCollection^ DispatchTimeMaxDetails {
    DispatchTimeMaxDetailsTypeCollection^ get ();
    void set (DispatchTimeMaxDetailsTypeCollection^ value);
}


ExcludeShippingLocationDetails Property

ExcludeShippingLocationDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► ExcludeShippingLocationDetails
Declaration Syntax
C# Visual Basic Visual C++
public ExcludeShippingLocationDetailsTypeCollection ExcludeShippingLocationDetails { get; set; }
Public Property ExcludeShippingLocationDetails As ExcludeShippingLocationDetailsTypeCollection
    Get
    Set
public:
property ExcludeShippingLocationDetailsTypeCollection^ ExcludeShippingLocationDetails {
    ExcludeShippingLocationDetailsTypeCollection^ get ();
    void set (ExcludeShippingLocationDetailsTypeCollection^ value);
}


GeteBayDetailsResponseType Constructor

GeteBayDetailsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► GeteBayDetailsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayDetailsResponseType()
Public Sub New
public:
GeteBayDetailsResponseType()


ItemSpecificDetails Property

ItemSpecificDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► ItemSpecificDetails
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificDetailsTypeCollection ItemSpecificDetails { get; set; }
Public Property ItemSpecificDetails As ItemSpecificDetailsTypeCollection
    Get
    Set
public:
property ItemSpecificDetailsTypeCollection^ ItemSpecificDetails {
    ItemSpecificDetailsTypeCollection^ get ();
    void set (ItemSpecificDetailsTypeCollection^ value);
}


ListingFeatureDetails Property

ListingFeatureDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► ListingFeatureDetails
Declaration Syntax
C# Visual Basic Visual C++
public ListingFeatureDetailsTypeCollection ListingFeatureDetails { get; set; }
Public Property ListingFeatureDetails As ListingFeatureDetailsTypeCollection
    Get
    Set
public:
property ListingFeatureDetailsTypeCollection^ ListingFeatureDetails {
    ListingFeatureDetailsTypeCollection^ get ();
    void set (ListingFeatureDetailsTypeCollection^ value);
}


ListingStartPriceDetails Property

ListingStartPriceDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► ListingStartPriceDetails
Declaration Syntax
C# Visual Basic Visual C++
public ListingStartPriceDetailsTypeCollection ListingStartPriceDetails { get; set; }
Public Property ListingStartPriceDetails As ListingStartPriceDetailsTypeCollection
    Get
    Set
public:
property ListingStartPriceDetailsTypeCollection^ ListingStartPriceDetails {
    ListingStartPriceDetailsTypeCollection^ get ();
    void set (ListingStartPriceDetailsTypeCollection^ value);
}


PaymentOptionDetails Property

PaymentOptionDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► PaymentOptionDetails
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionDetailsTypeCollection PaymentOptionDetails { get; set; }
Public Property PaymentOptionDetails As PaymentOptionDetailsTypeCollection
    Get
    Set
public:
property PaymentOptionDetailsTypeCollection^ PaymentOptionDetails {
    PaymentOptionDetailsTypeCollection^ get ();
    void set (PaymentOptionDetailsTypeCollection^ value);
}


ProductDetails Property

ProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► ProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public ProductDetailsType ProductDetails { get; set; }
Public Property ProductDetails As ProductDetailsType
    Get
    Set
public:
property ProductDetailsType^ ProductDetails {
    ProductDetailsType^ get ();
    void set (ProductDetailsType^ value);
}


RecoupmentPolicyDetails Property

RecoupmentPolicyDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► RecoupmentPolicyDetails
Declaration Syntax
C# Visual Basic Visual C++
public RecoupmentPolicyDetailsTypeCollection RecoupmentPolicyDetails { get; set; }
Public Property RecoupmentPolicyDetails As RecoupmentPolicyDetailsTypeCollection
    Get
    Set
public:
property RecoupmentPolicyDetailsTypeCollection^ RecoupmentPolicyDetails {
    RecoupmentPolicyDetailsTypeCollection^ get ();
    void set (RecoupmentPolicyDetailsTypeCollection^ value);
}


RegionDetails Property

RegionDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► RegionDetails
Declaration Syntax
C# Visual Basic Visual C++
public RegionDetailsTypeCollection RegionDetails { get; set; }
Public Property RegionDetails As RegionDetailsTypeCollection
    Get
    Set
public:
property RegionDetailsTypeCollection^ RegionDetails {
    RegionDetailsTypeCollection^ get ();
    void set (RegionDetailsTypeCollection^ value);
}


RegionOfOriginDetails Property

RegionOfOriginDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► RegionOfOriginDetails
Declaration Syntax
C# Visual Basic Visual C++
public RegionOfOriginDetailsTypeCollection RegionOfOriginDetails { get; set; }
Public Property RegionOfOriginDetails As RegionOfOriginDetailsTypeCollection
    Get
    Set
public:
property RegionOfOriginDetailsTypeCollection^ RegionOfOriginDetails {
    RegionOfOriginDetailsTypeCollection^ get ();
    void set (RegionOfOriginDetailsTypeCollection^ value);
}


ReturnPolicyDetails Property

ReturnPolicyDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► ReturnPolicyDetails
Declaration Syntax
C# Visual Basic Visual C++
public ReturnPolicyDetailsType ReturnPolicyDetails { get; set; }
Public Property ReturnPolicyDetails As ReturnPolicyDetailsType
    Get
    Set
public:
property ReturnPolicyDetailsType^ ReturnPolicyDetails {
    ReturnPolicyDetailsType^ get ();
    void set (ReturnPolicyDetailsType^ value);
}


ShippingCarrierDetails Property

ShippingCarrierDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► ShippingCarrierDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierDetailsTypeCollection ShippingCarrierDetails { get; set; }
Public Property ShippingCarrierDetails As ShippingCarrierDetailsTypeCollection
    Get
    Set
public:
property ShippingCarrierDetailsTypeCollection^ ShippingCarrierDetails {
    ShippingCarrierDetailsTypeCollection^ get ();
    void set (ShippingCarrierDetailsTypeCollection^ value);
}


ShippingCategoryDetails Property

ShippingCategoryDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► ShippingCategoryDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCategoryDetailsTypeCollection ShippingCategoryDetails { get; set; }
Public Property ShippingCategoryDetails As ShippingCategoryDetailsTypeCollection
    Get
    Set
public:
property ShippingCategoryDetailsTypeCollection^ ShippingCategoryDetails {
    ShippingCategoryDetailsTypeCollection^ get ();
    void set (ShippingCategoryDetailsTypeCollection^ value);
}


ShippingLocationDetails Property

ShippingLocationDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► ShippingLocationDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShippingLocationDetailsTypeCollection ShippingLocationDetails { get; set; }
Public Property ShippingLocationDetails As ShippingLocationDetailsTypeCollection
    Get
    Set
public:
property ShippingLocationDetailsTypeCollection^ ShippingLocationDetails {
    ShippingLocationDetailsTypeCollection^ get ();
    void set (ShippingLocationDetailsTypeCollection^ value);
}


ShippingPackageDetails Property

ShippingPackageDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► ShippingPackageDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageDetailsTypeCollection ShippingPackageDetails { get; set; }
Public Property ShippingPackageDetails As ShippingPackageDetailsTypeCollection
    Get
    Set
public:
property ShippingPackageDetailsTypeCollection^ ShippingPackageDetails {
    ShippingPackageDetailsTypeCollection^ get ();
    void set (ShippingPackageDetailsTypeCollection^ value);
}


ShippingServiceDetails Property

ShippingServiceDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► ShippingServiceDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceDetailsTypeCollection ShippingServiceDetails { get; set; }
Public Property ShippingServiceDetails As ShippingServiceDetailsTypeCollection
    Get
    Set
public:
property ShippingServiceDetailsTypeCollection^ ShippingServiceDetails {
    ShippingServiceDetailsTypeCollection^ get ();
    void set (ShippingServiceDetailsTypeCollection^ value);
}


SiteDetails Property

SiteDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► SiteDetails
Declaration Syntax
C# Visual Basic Visual C++
public SiteDetailsTypeCollection SiteDetails { get; set; }
Public Property SiteDetails As SiteDetailsTypeCollection
    Get
    Set
public:
property SiteDetailsTypeCollection^ SiteDetails {
    SiteDetailsTypeCollection^ get ();
    void set (SiteDetailsTypeCollection^ value);
}


TaxJurisdiction Property

TaxJurisdiction Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► TaxJurisdiction
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection TaxJurisdiction { get; set; }
Public Property TaxJurisdiction As TaxJurisdictionTypeCollection
    Get
    Set
public:
property TaxJurisdictionTypeCollection^ TaxJurisdiction {
    TaxJurisdictionTypeCollection^ get ();
    void set (TaxJurisdictionTypeCollection^ value);
}


TimeZoneDetails Property

TimeZoneDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► TimeZoneDetails
Declaration Syntax
C# Visual Basic Visual C++
public TimeZoneDetailsTypeCollection TimeZoneDetails { get; set; }
Public Property TimeZoneDetails As TimeZoneDetailsTypeCollection
    Get
    Set
public:
property TimeZoneDetailsTypeCollection^ TimeZoneDetails {
    TimeZoneDetailsTypeCollection^ get ();
    void set (TimeZoneDetailsTypeCollection^ value);
}


UnitOfMeasurementDetails Property

UnitOfMeasurementDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► UnitOfMeasurementDetails
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementDetailsTypeCollection UnitOfMeasurementDetails { get; set; }
Public Property UnitOfMeasurementDetails As UnitOfMeasurementDetailsTypeCollection
    Get
    Set
public:
property UnitOfMeasurementDetailsTypeCollection^ UnitOfMeasurementDetails {
    UnitOfMeasurementDetailsTypeCollection^ get ();
    void set (UnitOfMeasurementDetailsTypeCollection^ value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


URLDetails Property

URLDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► URLDetails
Declaration Syntax
C# Visual Basic Visual C++
public URLDetailsTypeCollection URLDetails { get; set; }
Public Property URLDetails As URLDetailsTypeCollection
    Get
    Set
public:
property URLDetailsTypeCollection^ URLDetails {
    URLDetailsTypeCollection^ get ();
    void set (URLDetailsTypeCollection^ value);
}


VariationDetails Property

VariationDetails Property
Namespaces ► eBay.Service.Core.Soap ► GeteBayDetailsResponseType ► VariationDetails
Declaration Syntax
C# Visual Basic Visual C++
public VariationDetailsType VariationDetails { get; set; }
Public Property VariationDetails As VariationDetailsType
    Get
    Set
public:
property VariationDetailsType^ VariationDetails {
    VariationDetailsType^ get ();
    void set (VariationDetailsType^ value);
}


GeteBayOfficialTimeRequestType Class

GeteBayOfficialTimeRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GeteBayOfficialTimeRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GeteBayOfficialTimeRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GeteBayOfficialTimeRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GeteBayOfficialTimeRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeteBayOfficialTimeRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GeteBayOfficialTimeRequestType


GeteBayOfficialTimeRequestType Constructor

GeteBayOfficialTimeRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GeteBayOfficialTimeRequestType ► GeteBayOfficialTimeRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayOfficialTimeRequestType()
Public Sub New
public:
GeteBayOfficialTimeRequestType()


GeteBayOfficialTimeResponseType Class

GeteBayOfficialTimeResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GeteBayOfficialTimeResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GeteBayOfficialTimeResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GeteBayOfficialTimeResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GeteBayOfficialTimeResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeteBayOfficialTimeResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GeteBayOfficialTimeResponseType


GeteBayOfficialTimeResponseType Constructor

GeteBayOfficialTimeResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GeteBayOfficialTimeResponseType ► GeteBayOfficialTimeResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayOfficialTimeResponseType()
Public Sub New
public:
GeteBayOfficialTimeResponseType()


GetFeedbackRequestType Class

GetFeedbackRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetFeedbackRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetFeedbackRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetFeedbackRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetFeedbackRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CommentType |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | FeedbackID |
 | FeedbackType |
 | FeedbackTypeSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | UserID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetFeedbackRequestType


CommentType Property

CommentType Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackRequestType ► CommentType
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeTypeCollection CommentType { get; set; }
Public Property CommentType As CommentTypeCodeTypeCollection
    Get
    Set
public:
property CommentTypeCodeTypeCollection^ CommentType {
    CommentTypeCodeTypeCollection^ get ();
    void set (CommentTypeCodeTypeCollection^ value);
}


FeedbackID Property

FeedbackID Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackRequestType ► FeedbackID
Declaration Syntax
C# Visual Basic Visual C++
public string FeedbackID { get; set; }
Public Property FeedbackID As String
    Get
    Set
public:
property String^ FeedbackID {
    String^ get ();
    void set (String^ value);
}


FeedbackType Property

FeedbackType Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackRequestType ► FeedbackType
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackTypeCodeType FeedbackType { get; set; }
Public Property FeedbackType As FeedbackTypeCodeType
    Get
    Set
public:
property FeedbackTypeCodeType FeedbackType {
    FeedbackTypeCodeType get ();
    void set (FeedbackTypeCodeType value);
}


FeedbackTypeSpecified Property

FeedbackTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackRequestType ► FeedbackTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackTypeSpecified { get; set; }
Public Property FeedbackTypeSpecified As Boolean
    Get
    Set
public:
property bool FeedbackTypeSpecified {
    bool get ();
    void set (bool value);
}


GetFeedbackRequestType Constructor

GetFeedbackRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackRequestType ► GetFeedbackRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetFeedbackRequestType()
Public Sub New
public:
GetFeedbackRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackRequestType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetFeedbackResponseType Class

GetFeedbackResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetFeedbackResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetFeedbackResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetFeedbackResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetFeedbackResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EntriesPerPage |
 | EntriesPerPageSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | FeedbackDetailArray |
 | FeedbackDetailItemTotal |
 | FeedbackDetailItemTotalSpecified |
 | FeedbackScore |
 | FeedbackScoreSpecified |
 | FeedbackSummary |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PageNumber |
 | PageNumberSpecified |
 | PaginationResult |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetFeedbackResponseType


EntriesPerPage Property

EntriesPerPage Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► EntriesPerPage
Declaration Syntax
C# Visual Basic Visual C++
public int EntriesPerPage { get; set; }
Public Property EntriesPerPage As Integer
    Get
    Set
public:
property int EntriesPerPage {
    int get ();
    void set (int value);
}


EntriesPerPageSpecified Property

EntriesPerPageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► EntriesPerPageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EntriesPerPageSpecified { get; set; }
Public Property EntriesPerPageSpecified As Boolean
    Get
    Set
public:
property bool EntriesPerPageSpecified {
    bool get ();
    void set (bool value);
}


FeedbackDetailArray Property

FeedbackDetailArray Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► FeedbackDetailArray
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackDetailTypeCollection FeedbackDetailArray { get; set; }
Public Property FeedbackDetailArray As FeedbackDetailTypeCollection
    Get
    Set
public:
property FeedbackDetailTypeCollection^ FeedbackDetailArray {
    FeedbackDetailTypeCollection^ get ();
    void set (FeedbackDetailTypeCollection^ value);
}


FeedbackDetailItemTotal Property

FeedbackDetailItemTotal Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► FeedbackDetailItemTotal
Declaration Syntax
C# Visual Basic Visual C++
public int FeedbackDetailItemTotal { get; set; }
Public Property FeedbackDetailItemTotal As Integer
    Get
    Set
public:
property int FeedbackDetailItemTotal {
    int get ();
    void set (int value);
}


FeedbackDetailItemTotalSpecified Property

FeedbackDetailItemTotalSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► FeedbackDetailItemTotalSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackDetailItemTotalSpecified { get; set; }
Public Property FeedbackDetailItemTotalSpecified As Boolean
    Get
    Set
public:
property bool FeedbackDetailItemTotalSpecified {
    bool get ();
    void set (bool value);
}


FeedbackScore Property

FeedbackScore Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► FeedbackScore
Declaration Syntax
C# Visual Basic Visual C++
public int FeedbackScore { get; set; }
Public Property FeedbackScore As Integer
    Get
    Set
public:
property int FeedbackScore {
    int get ();
    void set (int value);
}


FeedbackScoreSpecified Property

FeedbackScoreSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► FeedbackScoreSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackScoreSpecified { get; set; }
Public Property FeedbackScoreSpecified As Boolean
    Get
    Set
public:
property bool FeedbackScoreSpecified {
    bool get ();
    void set (bool value);
}


FeedbackSummary Property

FeedbackSummary Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► FeedbackSummary
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackSummaryType FeedbackSummary { get; set; }
Public Property FeedbackSummary As FeedbackSummaryType
    Get
    Set
public:
property FeedbackSummaryType^ FeedbackSummary {
    FeedbackSummaryType^ get ();
    void set (FeedbackSummaryType^ value);
}


GetFeedbackResponseType Constructor

GetFeedbackResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► GetFeedbackResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetFeedbackResponseType()
Public Sub New
public:
GetFeedbackResponseType()


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► PageNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}


PageNumberSpecified Property

PageNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► PageNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageNumberSpecified { get; set; }
Public Property PageNumberSpecified As Boolean
    Get
    Set
public:
property bool PageNumberSpecified {
    bool get ();
    void set (bool value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetFeedbackResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


GetItemRequestType Class

GetItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeCrossPromotion |
 | IncludeCrossPromotionSpecified |
 | IncludeItemCompatibilityList |
 | IncludeItemCompatibilityListSpecified |
 | IncludeItemSpecifics |
 | IncludeItemSpecificsSpecified |
 | IncludeTaxTable |
 | IncludeTaxTableSpecified |
 | IncludeWatchCount |
 | IncludeWatchCountSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SKU |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | VariationSKU |
 | VariationSpecifics |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetItemRequestType


GetItemRequestType Constructor

GetItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► GetItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemRequestType()
Public Sub New
public:
GetItemRequestType()


IncludeCrossPromotion Property

IncludeCrossPromotion Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► IncludeCrossPromotion
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeCrossPromotion { get; set; }
Public Property IncludeCrossPromotion As Boolean
    Get
    Set
public:
property bool IncludeCrossPromotion {
    bool get ();
    void set (bool value);
}


IncludeCrossPromotionSpecified Property

IncludeCrossPromotionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► IncludeCrossPromotionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeCrossPromotionSpecified { get; set; }
Public Property IncludeCrossPromotionSpecified As Boolean
    Get
    Set
public:
property bool IncludeCrossPromotionSpecified {
    bool get ();
    void set (bool value);
}


IncludeItemCompatibilityList Property

IncludeItemCompatibilityList Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► IncludeItemCompatibilityList
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeItemCompatibilityList { get; set; }
Public Property IncludeItemCompatibilityList As Boolean
    Get
    Set
public:
property bool IncludeItemCompatibilityList {
    bool get ();
    void set (bool value);
}


IncludeItemCompatibilityListSpecified Property

IncludeItemCompatibilityListSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► IncludeItemCompatibilityListSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeItemCompatibilityListSpecified { get; set; }
Public Property IncludeItemCompatibilityListSpecified As Boolean
    Get
    Set
public:
property bool IncludeItemCompatibilityListSpecified {
    bool get ();
    void set (bool value);
}


IncludeItemSpecifics Property

IncludeItemSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► IncludeItemSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeItemSpecifics { get; set; }
Public Property IncludeItemSpecifics As Boolean
    Get
    Set
public:
property bool IncludeItemSpecifics {
    bool get ();
    void set (bool value);
}


IncludeItemSpecificsSpecified Property

IncludeItemSpecificsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► IncludeItemSpecificsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeItemSpecificsSpecified { get; set; }
Public Property IncludeItemSpecificsSpecified As Boolean
    Get
    Set
public:
property bool IncludeItemSpecificsSpecified {
    bool get ();
    void set (bool value);
}


IncludeTaxTable Property

IncludeTaxTable Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► IncludeTaxTable
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeTaxTable { get; set; }
Public Property IncludeTaxTable As Boolean
    Get
    Set
public:
property bool IncludeTaxTable {
    bool get ();
    void set (bool value);
}


IncludeTaxTableSpecified Property

IncludeTaxTableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► IncludeTaxTableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeTaxTableSpecified { get; set; }
Public Property IncludeTaxTableSpecified As Boolean
    Get
    Set
public:
property bool IncludeTaxTableSpecified {
    bool get ();
    void set (bool value);
}


IncludeWatchCount Property

IncludeWatchCount Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► IncludeWatchCount
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeWatchCount { get; set; }
Public Property IncludeWatchCount As Boolean
    Get
    Set
public:
property bool IncludeWatchCount {
    bool get ();
    void set (bool value);
}


IncludeWatchCountSpecified Property

IncludeWatchCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► IncludeWatchCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeWatchCountSpecified { get; set; }
Public Property IncludeWatchCountSpecified As Boolean
    Get
    Set
public:
property bool IncludeWatchCountSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


VariationSKU Property

VariationSKU Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► VariationSKU
Declaration Syntax
C# Visual Basic Visual C++
public string VariationSKU { get; set; }
Public Property VariationSKU As String
    Get
    Set
public:
property String^ VariationSKU {
    String^ get ();
    void set (String^ value);
}


VariationSpecifics Property

VariationSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► GetItemRequestType ► VariationSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection VariationSpecifics { get; set; }
Public Property VariationSpecifics As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ VariationSpecifics {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


GetItemResponseType Class

GetItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetItemResponseType


GetItemResponseType Constructor

GetItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetItemResponseType ► GetItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemResponseType()
Public Sub New
public:
GetItemResponseType()


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► GetItemResponseType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


GetItemsAwaitingFeedbackRequestType Class

GetItemsAwaitingFeedbackRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetItemsAwaitingFeedbackRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetItemsAwaitingFeedbackRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetItemsAwaitingFeedbackRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetItemsAwaitingFeedbackRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemsAwaitingFeedbackRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | Sort |
 | SortSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetItemsAwaitingFeedbackRequestType


GetItemsAwaitingFeedbackRequestType Constructor

GetItemsAwaitingFeedbackRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetItemsAwaitingFeedbackRequestType ► GetItemsAwaitingFeedbackRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemsAwaitingFeedbackRequestType()
Public Sub New
public:
GetItemsAwaitingFeedbackRequestType()


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetItemsAwaitingFeedbackRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


Sort Property

Sort Property
Namespaces ► eBay.Service.Core.Soap ► GetItemsAwaitingFeedbackRequestType ► Sort
Declaration Syntax
C# Visual Basic Visual C++
public ItemSortTypeCodeType Sort { get; set; }
Public Property Sort As ItemSortTypeCodeType
    Get
    Set
public:
property ItemSortTypeCodeType Sort {
    ItemSortTypeCodeType get ();
    void set (ItemSortTypeCodeType value);
}


SortSpecified Property

SortSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemsAwaitingFeedbackRequestType ► SortSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SortSpecified { get; set; }
Public Property SortSpecified As Boolean
    Get
    Set
public:
property bool SortSpecified {
    bool get ();
    void set (bool value);
}


GetItemsAwaitingFeedbackResponseType Class

GetItemsAwaitingFeedbackResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetItemsAwaitingFeedbackResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetItemsAwaitingFeedbackResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetItemsAwaitingFeedbackResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetItemsAwaitingFeedbackResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemsAwaitingFeedbackResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemsAwaitingFeedback |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetItemsAwaitingFeedbackResponseType


GetItemsAwaitingFeedbackResponseType Constructor

GetItemsAwaitingFeedbackResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetItemsAwaitingFeedbackResponseType ► GetItemsAwaitingFeedbackResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemsAwaitingFeedbackResponseType()
Public Sub New
public:
GetItemsAwaitingFeedbackResponseType()


ItemsAwaitingFeedback Property

ItemsAwaitingFeedback Property
Namespaces ► eBay.Service.Core.Soap ► GetItemsAwaitingFeedbackResponseType ► ItemsAwaitingFeedback
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedTransactionArrayType ItemsAwaitingFeedback { get; set; }
Public Property ItemsAwaitingFeedback As PaginatedTransactionArrayType
    Get
    Set
public:
property PaginatedTransactionArrayType^ ItemsAwaitingFeedback {
    PaginatedTransactionArrayType^ get ();
    void set (PaginatedTransactionArrayType^ value);
}


GetItemShippingRequestType Class

GetItemShippingRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetItemShippingRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetItemShippingRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetItemShippingRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemShippingRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DestinationCountryCode |
 | DestinationCountryCodeSpecified |
 | DestinationPostalCode |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | QuantitySold |
 | QuantitySoldSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetItemShippingRequestType


DestinationCountryCode Property

DestinationCountryCode Property
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingRequestType ► DestinationCountryCode
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType DestinationCountryCode { get; set; }
Public Property DestinationCountryCode As CountryCodeType
    Get
    Set
public:
property CountryCodeType DestinationCountryCode {
    CountryCodeType get ();
    void set (CountryCodeType value);
}


DestinationCountryCodeSpecified Property

DestinationCountryCodeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingRequestType ► DestinationCountryCodeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DestinationCountryCodeSpecified { get; set; }
Public Property DestinationCountryCodeSpecified As Boolean
    Get
    Set
public:
property bool DestinationCountryCodeSpecified {
    bool get ();
    void set (bool value);
}


DestinationPostalCode Property

DestinationPostalCode Property
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingRequestType ► DestinationPostalCode
Declaration Syntax
C# Visual Basic Visual C++
public string DestinationPostalCode { get; set; }
Public Property DestinationPostalCode As String
    Get
    Set
public:
property String^ DestinationPostalCode {
    String^ get ();
    void set (String^ value);
}


GetItemShippingRequestType Constructor

GetItemShippingRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingRequestType ► GetItemShippingRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemShippingRequestType()
Public Sub New
public:
GetItemShippingRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


QuantitySold Property

QuantitySold Property
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingRequestType ► QuantitySold
Declaration Syntax
C# Visual Basic Visual C++
public int QuantitySold { get; set; }
Public Property QuantitySold As Integer
    Get
    Set
public:
property int QuantitySold {
    int get ();
    void set (int value);
}


QuantitySoldSpecified Property

QuantitySoldSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingRequestType ► QuantitySoldSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySoldSpecified { get; set; }
Public Property QuantitySoldSpecified As Boolean
    Get
    Set
public:
property bool QuantitySoldSpecified {
    bool get ();
    void set (bool value);
}


GetItemShippingResponseType Class

GetItemShippingResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetItemShippingResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetItemShippingResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetItemShippingResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemShippingResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PickUpInStoreDetails |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | ShippingDetails |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetItemShippingResponseType


GetItemShippingResponseType Constructor

GetItemShippingResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingResponseType ► GetItemShippingResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemShippingResponseType()
Public Sub New
public:
GetItemShippingResponseType()


PickUpInStoreDetails Property

PickUpInStoreDetails Property
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingResponseType ► PickUpInStoreDetails
Declaration Syntax
C# Visual Basic Visual C++
public PickupInStoreDetailsType PickUpInStoreDetails { get; set; }
Public Property PickUpInStoreDetails As PickupInStoreDetailsType
    Get
    Set
public:
property PickupInStoreDetailsType^ PickUpInStoreDetails {
    PickupInStoreDetailsType^ get ();
    void set (PickupInStoreDetailsType^ value);
}


ShippingDetails Property

ShippingDetails Property
Namespaces ► eBay.Service.Core.Soap ► GetItemShippingResponseType ► ShippingDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShippingDetailsType ShippingDetails { get; set; }
Public Property ShippingDetails As ShippingDetailsType
    Get
    Set
public:
property ShippingDetailsType^ ShippingDetails {
    ShippingDetailsType^ get ();
    void set (ShippingDetailsType^ value);
}


GetItemTransactionsRequestType Class

GetItemTransactionsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetItemTransactionsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetItemTransactionsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetItemTransactionsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemTransactionsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeContainingOrder |
 | IncludeContainingOrderSpecified |
 | IncludeFinalValueFee |
 | IncludeFinalValueFeeSpecified |
 | IncludeVariations |
 | IncludeVariationsSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | ModTimeFrom |
 | ModTimeFromSpecified |
 | ModTimeTo |
 | ModTimeToSpecified |
 | NumberOfDays |
 | NumberOfDaysSpecified |
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | Platform |
 | PlatformSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetItemTransactionsRequestType


GetItemTransactionsRequestType Constructor

GetItemTransactionsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► GetItemTransactionsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemTransactionsRequestType()
Public Sub New
public:
GetItemTransactionsRequestType()


IncludeContainingOrder Property

IncludeContainingOrder Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► IncludeContainingOrder
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeContainingOrder { get; set; }
Public Property IncludeContainingOrder As Boolean
    Get
    Set
public:
property bool IncludeContainingOrder {
    bool get ();
    void set (bool value);
}


IncludeContainingOrderSpecified Property

IncludeContainingOrderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► IncludeContainingOrderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeContainingOrderSpecified { get; set; }
Public Property IncludeContainingOrderSpecified As Boolean
    Get
    Set
public:
property bool IncludeContainingOrderSpecified {
    bool get ();
    void set (bool value);
}


IncludeFinalValueFee Property

IncludeFinalValueFee Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► IncludeFinalValueFee
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFee { get; set; }
Public Property IncludeFinalValueFee As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFee {
    bool get ();
    void set (bool value);
}


IncludeFinalValueFeeSpecified Property

IncludeFinalValueFeeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► IncludeFinalValueFeeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFeeSpecified { get; set; }
Public Property IncludeFinalValueFeeSpecified As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFeeSpecified {
    bool get ();
    void set (bool value);
}


IncludeVariations Property

IncludeVariations Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► IncludeVariations
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeVariations { get; set; }
Public Property IncludeVariations As Boolean
    Get
    Set
public:
property bool IncludeVariations {
    bool get ();
    void set (bool value);
}


IncludeVariationsSpecified Property

IncludeVariationsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► IncludeVariationsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeVariationsSpecified { get; set; }
Public Property IncludeVariationsSpecified As Boolean
    Get
    Set
public:
property bool IncludeVariationsSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ModTimeFrom Property

ModTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► ModTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeFrom { get; set; }
Public Property ModTimeFrom As DateTime
    Get
    Set
public:
property DateTime ModTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


ModTimeFromSpecified Property

ModTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► ModTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModTimeFromSpecified { get; set; }
Public Property ModTimeFromSpecified As Boolean
    Get
    Set
public:
property bool ModTimeFromSpecified {
    bool get ();
    void set (bool value);
}


ModTimeTo Property

ModTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► ModTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeTo { get; set; }
Public Property ModTimeTo As DateTime
    Get
    Set
public:
property DateTime ModTimeTo {
    DateTime get ();
    void set (DateTime value);
}


ModTimeToSpecified Property

ModTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► ModTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModTimeToSpecified { get; set; }
Public Property ModTimeToSpecified As Boolean
    Get
    Set
public:
property bool ModTimeToSpecified {
    bool get ();
    void set (bool value);
}


NumberOfDays Property

NumberOfDays Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► NumberOfDays
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfDays { get; set; }
Public Property NumberOfDays As Integer
    Get
    Set
public:
property int NumberOfDays {
    int get ();
    void set (int value);
}


NumberOfDaysSpecified Property

NumberOfDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► NumberOfDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NumberOfDaysSpecified { get; set; }
Public Property NumberOfDaysSpecified As Boolean
    Get
    Set
public:
property bool NumberOfDaysSpecified {
    bool get ();
    void set (bool value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


Platform Property

Platform Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► Platform
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeType Platform { get; set; }
Public Property Platform As TransactionPlatformCodeType
    Get
    Set
public:
property TransactionPlatformCodeType Platform {
    TransactionPlatformCodeType get ();
    void set (TransactionPlatformCodeType value);
}


PlatformSpecified Property

PlatformSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► PlatformSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PlatformSpecified { get; set; }
Public Property PlatformSpecified As Boolean
    Get
    Set
public:
property bool PlatformSpecified {
    bool get ();
    void set (bool value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


GetItemTransactionsResponseType Class

GetItemTransactionsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetItemTransactionsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetItemTransactionsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetItemTransactionsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetItemTransactionsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | HasMoreTransactions |
 | HasMoreTransactionsSpecified |
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PageNumber |
 | PageNumberSpecified |
 | PaginationResult |
 | PayPalPreferred |
 | PayPalPreferredSpecified |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | ReturnedTransactionCountActual |
 | ReturnedTransactionCountActualSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionArray |
 | TransactionsPerPage |
 | TransactionsPerPageSpecified |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetItemTransactionsResponseType


GetItemTransactionsResponseType Constructor

GetItemTransactionsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► GetItemTransactionsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetItemTransactionsResponseType()
Public Sub New
public:
GetItemTransactionsResponseType()


HasMoreTransactions Property

HasMoreTransactions Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► HasMoreTransactions
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreTransactions { get; set; }
Public Property HasMoreTransactions As Boolean
    Get
    Set
public:
property bool HasMoreTransactions {
    bool get ();
    void set (bool value);
}


HasMoreTransactionsSpecified Property

HasMoreTransactionsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► HasMoreTransactionsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreTransactionsSpecified { get; set; }
Public Property HasMoreTransactionsSpecified As Boolean
    Get
    Set
public:
property bool HasMoreTransactionsSpecified {
    bool get ();
    void set (bool value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► PageNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}


PageNumberSpecified Property

PageNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► PageNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageNumberSpecified { get; set; }
Public Property PageNumberSpecified As Boolean
    Get
    Set
public:
property bool PageNumberSpecified {
    bool get ();
    void set (bool value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


PayPalPreferred Property

PayPalPreferred Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► PayPalPreferred
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalPreferred { get; set; }
Public Property PayPalPreferred As Boolean
    Get
    Set
public:
property bool PayPalPreferred {
    bool get ();
    void set (bool value);
}


PayPalPreferredSpecified Property

PayPalPreferredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► PayPalPreferredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalPreferredSpecified { get; set; }
Public Property PayPalPreferredSpecified As Boolean
    Get
    Set
public:
property bool PayPalPreferredSpecified {
    bool get ();
    void set (bool value);
}


ReturnedTransactionCountActual Property

ReturnedTransactionCountActual Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► ReturnedTransactionCountActual
Declaration Syntax
C# Visual Basic Visual C++
public int ReturnedTransactionCountActual { get; set; }
Public Property ReturnedTransactionCountActual As Integer
    Get
    Set
public:
property int ReturnedTransactionCountActual {
    int get ();
    void set (int value);
}


ReturnedTransactionCountActualSpecified Property

ReturnedTransactionCountActualSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► ReturnedTransactionCountActualSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnedTransactionCountActualSpecified { get; set; }
Public Property ReturnedTransactionCountActualSpecified As Boolean
    Get
    Set
public:
property bool ReturnedTransactionCountActualSpecified {
    bool get ();
    void set (bool value);
}


TransactionArray Property

TransactionArray Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► TransactionArray
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection TransactionArray { get; set; }
Public Property TransactionArray As TransactionTypeCollection
    Get
    Set
public:
property TransactionTypeCollection^ TransactionArray {
    TransactionTypeCollection^ get ();
    void set (TransactionTypeCollection^ value);
}


TransactionsPerPage Property

TransactionsPerPage Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► TransactionsPerPage
Declaration Syntax
C# Visual Basic Visual C++
public int TransactionsPerPage { get; set; }
Public Property TransactionsPerPage As Integer
    Get
    Set
public:
property int TransactionsPerPage {
    int get ();
    void set (int value);
}


TransactionsPerPageSpecified Property

TransactionsPerPageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetItemTransactionsResponseType ► TransactionsPerPageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TransactionsPerPageSpecified { get; set; }
Public Property TransactionsPerPageSpecified As Boolean
    Get
    Set
public:
property bool TransactionsPerPageSpecified {
    bool get ();
    void set (bool value);
}


GetMemberMessagesRequestType Class

GetMemberMessagesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMemberMessagesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMemberMessagesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMemberMessagesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMemberMessagesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | DisplayToPublic |
 | DisplayToPublicSpecified |
 | EndCreationTime |
 | EndCreationTimeSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MailMessageType |
 | MailMessageTypeSpecified |
 | MemberMessageID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | MessageStatus |
 | MessageStatusSpecified |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | SenderID |
 | StartCreationTime |
 | StartCreationTimeSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetMemberMessagesRequestType


DisplayToPublic Property

DisplayToPublic Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► DisplayToPublic
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayToPublic { get; set; }
Public Property DisplayToPublic As Boolean
    Get
    Set
public:
property bool DisplayToPublic {
    bool get ();
    void set (bool value);
}


DisplayToPublicSpecified Property

DisplayToPublicSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► DisplayToPublicSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayToPublicSpecified { get; set; }
Public Property DisplayToPublicSpecified As Boolean
    Get
    Set
public:
property bool DisplayToPublicSpecified {
    bool get ();
    void set (bool value);
}


EndCreationTime Property

EndCreationTime Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► EndCreationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndCreationTime { get; set; }
Public Property EndCreationTime As DateTime
    Get
    Set
public:
property DateTime EndCreationTime {
    DateTime get ();
    void set (DateTime value);
}


EndCreationTimeSpecified Property

EndCreationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► EndCreationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndCreationTimeSpecified { get; set; }
Public Property EndCreationTimeSpecified As Boolean
    Get
    Set
public:
property bool EndCreationTimeSpecified {
    bool get ();
    void set (bool value);
}


GetMemberMessagesRequestType Constructor

GetMemberMessagesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► GetMemberMessagesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMemberMessagesRequestType()
Public Sub New
public:
GetMemberMessagesRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MailMessageType Property

MailMessageType Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► MailMessageType
Declaration Syntax
C# Visual Basic Visual C++
public MessageTypeCodeType MailMessageType { get; set; }
Public Property MailMessageType As MessageTypeCodeType
    Get
    Set
public:
property MessageTypeCodeType MailMessageType {
    MessageTypeCodeType get ();
    void set (MessageTypeCodeType value);
}


MailMessageTypeSpecified Property

MailMessageTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► MailMessageTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MailMessageTypeSpecified { get; set; }
Public Property MailMessageTypeSpecified As Boolean
    Get
    Set
public:
property bool MailMessageTypeSpecified {
    bool get ();
    void set (bool value);
}


MemberMessageID Property

MemberMessageID Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► MemberMessageID
Declaration Syntax
C# Visual Basic Visual C++
public string MemberMessageID { get; set; }
Public Property MemberMessageID As String
    Get
    Set
public:
property String^ MemberMessageID {
    String^ get ();
    void set (String^ value);
}


MessageStatus Property

MessageStatus Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► MessageStatus
Declaration Syntax
C# Visual Basic Visual C++
public MessageStatusTypeCodeType MessageStatus { get; set; }
Public Property MessageStatus As MessageStatusTypeCodeType
    Get
    Set
public:
property MessageStatusTypeCodeType MessageStatus {
    MessageStatusTypeCodeType get ();
    void set (MessageStatusTypeCodeType value);
}


MessageStatusSpecified Property

MessageStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► MessageStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageStatusSpecified { get; set; }
Public Property MessageStatusSpecified As Boolean
    Get
    Set
public:
property bool MessageStatusSpecified {
    bool get ();
    void set (bool value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


SenderID Property

SenderID Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► SenderID
Declaration Syntax
C# Visual Basic Visual C++
public string SenderID { get; set; }
Public Property SenderID As String
    Get
    Set
public:
property String^ SenderID {
    String^ get ();
    void set (String^ value);
}


StartCreationTime Property

StartCreationTime Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► StartCreationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartCreationTime { get; set; }
Public Property StartCreationTime As DateTime
    Get
    Set
public:
property DateTime StartCreationTime {
    DateTime get ();
    void set (DateTime value);
}


StartCreationTimeSpecified Property

StartCreationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesRequestType ► StartCreationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartCreationTimeSpecified { get; set; }
Public Property StartCreationTimeSpecified As Boolean
    Get
    Set
public:
property bool StartCreationTimeSpecified {
    bool get ();
    void set (bool value);
}


GetMemberMessagesResponseType Class

GetMemberMessagesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMemberMessagesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMemberMessagesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMemberMessagesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMemberMessagesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | HasMoreItems |
 | HasMoreItemsSpecified |
 | MemberMessage |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PaginationResult |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetMemberMessagesResponseType


GetMemberMessagesResponseType Constructor

GetMemberMessagesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesResponseType ► GetMemberMessagesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMemberMessagesResponseType()
Public Sub New
public:
GetMemberMessagesResponseType()


HasMoreItems Property

HasMoreItems Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesResponseType ► HasMoreItems
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreItems { get; set; }
Public Property HasMoreItems As Boolean
    Get
    Set
public:
property bool HasMoreItems {
    bool get ();
    void set (bool value);
}


HasMoreItemsSpecified Property

HasMoreItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesResponseType ► HasMoreItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreItemsSpecified { get; set; }
Public Property HasMoreItemsSpecified As Boolean
    Get
    Set
public:
property bool HasMoreItemsSpecified {
    bool get ();
    void set (bool value);
}


MemberMessage Property

MemberMessage Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesResponseType ► MemberMessage
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeTypeCollection MemberMessage { get; set; }
Public Property MemberMessage As MemberMessageExchangeTypeCollection
    Get
    Set
public:
property MemberMessageExchangeTypeCollection^ MemberMessage {
    MemberMessageExchangeTypeCollection^ get ();
    void set (MemberMessageExchangeTypeCollection^ value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetMemberMessagesResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


GetMessagePreferencesRequestType Class

GetMessagePreferencesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetMessagePreferencesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMessagePreferencesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMessagePreferencesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMessagePreferencesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMessagePreferencesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeASQPreferences |
 | IncludeASQPreferencesSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SellerID |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetMessagePreferencesRequestType


GetMessagePreferencesRequestType Constructor

GetMessagePreferencesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMessagePreferencesRequestType ► GetMessagePreferencesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMessagePreferencesRequestType()
Public Sub New
public:
GetMessagePreferencesRequestType()


IncludeASQPreferences Property

IncludeASQPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetMessagePreferencesRequestType ► IncludeASQPreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeASQPreferences { get; set; }
Public Property IncludeASQPreferences As Boolean
    Get
    Set
public:
property bool IncludeASQPreferences {
    bool get ();
    void set (bool value);
}


IncludeASQPreferencesSpecified Property

IncludeASQPreferencesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMessagePreferencesRequestType ► IncludeASQPreferencesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeASQPreferencesSpecified { get; set; }
Public Property IncludeASQPreferencesSpecified As Boolean
    Get
    Set
public:
property bool IncludeASQPreferencesSpecified {
    bool get ();
    void set (bool value);
}


SellerID Property

SellerID Property
Namespaces ► eBay.Service.Core.Soap ► GetMessagePreferencesRequestType ► SellerID
Declaration Syntax
C# Visual Basic Visual C++
public string SellerID { get; set; }
Public Property SellerID As String
    Get
    Set
public:
property String^ SellerID {
    String^ get ();
    void set (String^ value);
}


GetMessagePreferencesResponseType Class

GetMessagePreferencesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetMessagePreferencesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMessagePreferencesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMessagePreferencesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMessagePreferencesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMessagePreferencesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | ASQPreferences |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetMessagePreferencesResponseType


ASQPreferences Property

ASQPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetMessagePreferencesResponseType ► ASQPreferences
Declaration Syntax
C# Visual Basic Visual C++
public ASQPreferencesType ASQPreferences { get; set; }
Public Property ASQPreferences As ASQPreferencesType
    Get
    Set
public:
property ASQPreferencesType^ ASQPreferences {
    ASQPreferencesType^ get ();
    void set (ASQPreferencesType^ value);
}


GetMessagePreferencesResponseType Constructor

GetMessagePreferencesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMessagePreferencesResponseType ► GetMessagePreferencesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMessagePreferencesResponseType()
Public Sub New
public:
GetMessagePreferencesResponseType()


GetMyeBayBuyingRequestType Class

GetMyeBayBuyingRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMyeBayBuyingRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMyeBayBuyingRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMyeBayBuyingRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyeBayBuyingRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BestOfferList |
 | BidAssistantList |
 | BidList |
 | BotBlock | (Inherited from AbstractRequestType.)
 | BuyingSummary |
 | DeletedFromLostList |
 | DeletedFromWonList |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | FavoriteSearches |
 | FavoriteSellers |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HideVariations |
 | HideVariationsSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | LostList |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SecondChanceOffer |
 | ToString()()()() | (Inherited from Object.)
 | UserDefinedLists |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
 | WatchList |
 | WonList |
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetMyeBayBuyingRequestType


BestOfferList Property

BestOfferList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► BestOfferList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType BestOfferList { get; set; }
Public Property BestOfferList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ BestOfferList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


BidAssistantList Property

BidAssistantList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► BidAssistantList
Declaration Syntax
C# Visual Basic Visual C++
public BidAssistantListType BidAssistantList { get; set; }
Public Property BidAssistantList As BidAssistantListType
    Get
    Set
public:
property BidAssistantListType^ BidAssistantList {
    BidAssistantListType^ get ();
    void set (BidAssistantListType^ value);
}


BidList Property

BidList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► BidList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType BidList { get; set; }
Public Property BidList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ BidList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


BuyingSummary Property

BuyingSummary Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► BuyingSummary
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType BuyingSummary { get; set; }
Public Property BuyingSummary As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ BuyingSummary {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


DeletedFromLostList Property

DeletedFromLostList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► DeletedFromLostList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType DeletedFromLostList { get; set; }
Public Property DeletedFromLostList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ DeletedFromLostList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


DeletedFromWonList Property

DeletedFromWonList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► DeletedFromWonList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType DeletedFromWonList { get; set; }
Public Property DeletedFromWonList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ DeletedFromWonList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


FavoriteSearches Property

FavoriteSearches Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► FavoriteSearches
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySelectionType FavoriteSearches { get; set; }
Public Property FavoriteSearches As MyeBaySelectionType
    Get
    Set
public:
property MyeBaySelectionType^ FavoriteSearches {
    MyeBaySelectionType^ get ();
    void set (MyeBaySelectionType^ value);
}


FavoriteSellers Property

FavoriteSellers Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► FavoriteSellers
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySelectionType FavoriteSellers { get; set; }
Public Property FavoriteSellers As MyeBaySelectionType
    Get
    Set
public:
property MyeBaySelectionType^ FavoriteSellers {
    MyeBaySelectionType^ get ();
    void set (MyeBaySelectionType^ value);
}


GetMyeBayBuyingRequestType Constructor

GetMyeBayBuyingRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► GetMyeBayBuyingRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayBuyingRequestType()
Public Sub New
public:
GetMyeBayBuyingRequestType()


HideVariations Property

HideVariations Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► HideVariations
Declaration Syntax
C# Visual Basic Visual C++
public bool HideVariations { get; set; }
Public Property HideVariations As Boolean
    Get
    Set
public:
property bool HideVariations {
    bool get ();
    void set (bool value);
}


HideVariationsSpecified Property

HideVariationsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► HideVariationsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HideVariationsSpecified { get; set; }
Public Property HideVariationsSpecified As Boolean
    Get
    Set
public:
property bool HideVariationsSpecified {
    bool get ();
    void set (bool value);
}


LostList Property

LostList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► LostList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType LostList { get; set; }
Public Property LostList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ LostList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


SecondChanceOffer Property

SecondChanceOffer Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► SecondChanceOffer
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySelectionType SecondChanceOffer { get; set; }
Public Property SecondChanceOffer As MyeBaySelectionType
    Get
    Set
public:
property MyeBaySelectionType^ SecondChanceOffer {
    MyeBaySelectionType^ get ();
    void set (MyeBaySelectionType^ value);
}


UserDefinedLists Property

UserDefinedLists Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► UserDefinedLists
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySelectionType UserDefinedLists { get; set; }
Public Property UserDefinedLists As MyeBaySelectionType
    Get
    Set
public:
property MyeBaySelectionType^ UserDefinedLists {
    MyeBaySelectionType^ get ();
    void set (MyeBaySelectionType^ value);
}


WatchList Property

WatchList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► WatchList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType WatchList { get; set; }
Public Property WatchList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ WatchList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


WonList Property

WonList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingRequestType ► WonList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType WonList { get; set; }
Public Property WonList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ WonList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


GetMyeBayBuyingResponseType Class

GetMyeBayBuyingResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMyeBayBuyingResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMyeBayBuyingResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMyeBayBuyingResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyeBayBuyingResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BestOfferList |
 | BidAssistantList |
 | BidList |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | BuyingSummary |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DeletedFromLostList |
 | DeletedFromWonList |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | FavoriteSearches |
 | FavoriteSellers |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | LostList |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SecondChanceOffer |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | UserDefinedList |
 | Version | (Inherited from AbstractResponseType.)
 | WatchList |
 | WonList |
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetMyeBayBuyingResponseType


BestOfferList Property

BestOfferList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► BestOfferList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType BestOfferList { get; set; }
Public Property BestOfferList As PaginatedItemArrayType
    Get
    Set
public:
property PaginatedItemArrayType^ BestOfferList {
    PaginatedItemArrayType^ get ();
    void set (PaginatedItemArrayType^ value);
}


BidAssistantList Property

BidAssistantList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► BidAssistantList
Declaration Syntax
C# Visual Basic Visual C++
public BidGroupTypeCollection BidAssistantList { get; set; }
Public Property BidAssistantList As BidGroupTypeCollection
    Get
    Set
public:
property BidGroupTypeCollection^ BidAssistantList {
    BidGroupTypeCollection^ get ();
    void set (BidGroupTypeCollection^ value);
}


BidList Property

BidList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► BidList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType BidList { get; set; }
Public Property BidList As PaginatedItemArrayType
    Get
    Set
public:
property PaginatedItemArrayType^ BidList {
    PaginatedItemArrayType^ get ();
    void set (PaginatedItemArrayType^ value);
}


BuyingSummary Property

BuyingSummary Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► BuyingSummary
Declaration Syntax
C# Visual Basic Visual C++
public BuyingSummaryType BuyingSummary { get; set; }
Public Property BuyingSummary As BuyingSummaryType
    Get
    Set
public:
property BuyingSummaryType^ BuyingSummary {
    BuyingSummaryType^ get ();
    void set (BuyingSummaryType^ value);
}


DeletedFromLostList Property

DeletedFromLostList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► DeletedFromLostList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType DeletedFromLostList { get; set; }
Public Property DeletedFromLostList As PaginatedItemArrayType
    Get
    Set
public:
property PaginatedItemArrayType^ DeletedFromLostList {
    PaginatedItemArrayType^ get ();
    void set (PaginatedItemArrayType^ value);
}


DeletedFromWonList Property

DeletedFromWonList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► DeletedFromWonList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedOrderTransactionArrayType DeletedFromWonList { get; set; }
Public Property DeletedFromWonList As PaginatedOrderTransactionArrayType
    Get
    Set
public:
property PaginatedOrderTransactionArrayType^ DeletedFromWonList {
    PaginatedOrderTransactionArrayType^ get ();
    void set (PaginatedOrderTransactionArrayType^ value);
}


FavoriteSearches Property

FavoriteSearches Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► FavoriteSearches
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchListType FavoriteSearches { get; set; }
Public Property FavoriteSearches As MyeBayFavoriteSearchListType
    Get
    Set
public:
property MyeBayFavoriteSearchListType^ FavoriteSearches {
    MyeBayFavoriteSearchListType^ get ();
    void set (MyeBayFavoriteSearchListType^ value);
}


FavoriteSellers Property

FavoriteSellers Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► FavoriteSellers
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerListType FavoriteSellers { get; set; }
Public Property FavoriteSellers As MyeBayFavoriteSellerListType
    Get
    Set
public:
property MyeBayFavoriteSellerListType^ FavoriteSellers {
    MyeBayFavoriteSellerListType^ get ();
    void set (MyeBayFavoriteSellerListType^ value);
}


GetMyeBayBuyingResponseType Constructor

GetMyeBayBuyingResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► GetMyeBayBuyingResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayBuyingResponseType()
Public Sub New
public:
GetMyeBayBuyingResponseType()


LostList Property

LostList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► LostList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType LostList { get; set; }
Public Property LostList As PaginatedItemArrayType
    Get
    Set
public:
property PaginatedItemArrayType^ LostList {
    PaginatedItemArrayType^ get ();
    void set (PaginatedItemArrayType^ value);
}


SecondChanceOffer Property

SecondChanceOffer Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► SecondChanceOffer
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection SecondChanceOffer { get; set; }
Public Property SecondChanceOffer As ItemTypeCollection
    Get
    Set
public:
property ItemTypeCollection^ SecondChanceOffer {
    ItemTypeCollection^ get ();
    void set (ItemTypeCollection^ value);
}


UserDefinedList Property

UserDefinedList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► UserDefinedList
Declaration Syntax
C# Visual Basic Visual C++
public UserDefinedListTypeCollection UserDefinedList { get; set; }
Public Property UserDefinedList As UserDefinedListTypeCollection
    Get
    Set
public:
property UserDefinedListTypeCollection^ UserDefinedList {
    UserDefinedListTypeCollection^ get ();
    void set (UserDefinedListTypeCollection^ value);
}


WatchList Property

WatchList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► WatchList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType WatchList { get; set; }
Public Property WatchList As PaginatedItemArrayType
    Get
    Set
public:
property PaginatedItemArrayType^ WatchList {
    PaginatedItemArrayType^ get ();
    void set (PaginatedItemArrayType^ value);
}


WonList Property

WonList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayBuyingResponseType ► WonList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedOrderTransactionArrayType WonList { get; set; }
Public Property WonList As PaginatedOrderTransactionArrayType
    Get
    Set
public:
property PaginatedOrderTransactionArrayType^ WonList {
    PaginatedOrderTransactionArrayType^ get ();
    void set (PaginatedOrderTransactionArrayType^ value);
}


GetMyeBayRemindersRequestType Class

GetMyeBayRemindersRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayRemindersRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMyeBayRemindersRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMyeBayRemindersRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMyeBayRemindersRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyeBayRemindersRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | BuyingReminders |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SellingReminders |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetMyeBayRemindersRequestType


BuyingReminders Property

BuyingReminders Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayRemindersRequestType ► BuyingReminders
Declaration Syntax
C# Visual Basic Visual C++
public ReminderCustomizationType BuyingReminders { get; set; }
Public Property BuyingReminders As ReminderCustomizationType
    Get
    Set
public:
property ReminderCustomizationType^ BuyingReminders {
    ReminderCustomizationType^ get ();
    void set (ReminderCustomizationType^ value);
}


GetMyeBayRemindersRequestType Constructor

GetMyeBayRemindersRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayRemindersRequestType ► GetMyeBayRemindersRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayRemindersRequestType()
Public Sub New
public:
GetMyeBayRemindersRequestType()


SellingReminders Property

SellingReminders Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayRemindersRequestType ► SellingReminders
Declaration Syntax
C# Visual Basic Visual C++
public ReminderCustomizationType SellingReminders { get; set; }
Public Property SellingReminders As ReminderCustomizationType
    Get
    Set
public:
property ReminderCustomizationType^ SellingReminders {
    ReminderCustomizationType^ get ();
    void set (ReminderCustomizationType^ value);
}


GetMyeBayRemindersResponseType Class

GetMyeBayRemindersResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayRemindersResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMyeBayRemindersResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMyeBayRemindersResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMyeBayRemindersResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyeBayRemindersResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | BuyingReminders |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SellingReminders |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetMyeBayRemindersResponseType


BuyingReminders Property

BuyingReminders Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayRemindersResponseType ► BuyingReminders
Declaration Syntax
C# Visual Basic Visual C++
public RemindersType BuyingReminders { get; set; }
Public Property BuyingReminders As RemindersType
    Get
    Set
public:
property RemindersType^ BuyingReminders {
    RemindersType^ get ();
    void set (RemindersType^ value);
}


GetMyeBayRemindersResponseType Constructor

GetMyeBayRemindersResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayRemindersResponseType ► GetMyeBayRemindersResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBayRemindersResponseType()
Public Sub New
public:
GetMyeBayRemindersResponseType()


SellingReminders Property

SellingReminders Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBayRemindersResponseType ► SellingReminders
Declaration Syntax
C# Visual Basic Visual C++
public RemindersType SellingReminders { get; set; }
Public Property SellingReminders As RemindersType
    Get
    Set
public:
property RemindersType^ SellingReminders {
    RemindersType^ get ();
    void set (RemindersType^ value);
}


GetMyeBaySellingRequestType Class

GetMyeBaySellingRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMyeBaySellingRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMyeBaySellingRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMyeBaySellingRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyeBaySellingRequestType()()()() |
 | ActiveList |
 | Any | (Inherited from AbstractRequestType.)
 | BidList |
 | BotBlock | (Inherited from AbstractRequestType.)
 | DeletedFromSoldList |
 | DeletedFromUnsoldList |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HideVariations |
 | HideVariationsSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ScheduledList |
 | SellingSummary |
 | SoldList |
 | ToString()()()() | (Inherited from Object.)
 | UnsoldList |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetMyeBaySellingRequestType


ActiveList Property

ActiveList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType ► ActiveList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType ActiveList { get; set; }
Public Property ActiveList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ ActiveList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


BidList Property

BidList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType ► BidList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType BidList { get; set; }
Public Property BidList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ BidList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


DeletedFromSoldList Property

DeletedFromSoldList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType ► DeletedFromSoldList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType DeletedFromSoldList { get; set; }
Public Property DeletedFromSoldList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ DeletedFromSoldList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


DeletedFromUnsoldList Property

DeletedFromUnsoldList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType ► DeletedFromUnsoldList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType DeletedFromUnsoldList { get; set; }
Public Property DeletedFromUnsoldList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ DeletedFromUnsoldList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


GetMyeBaySellingRequestType Constructor

GetMyeBaySellingRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType ► GetMyeBaySellingRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBaySellingRequestType()
Public Sub New
public:
GetMyeBaySellingRequestType()


HideVariations Property

HideVariations Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType ► HideVariations
Declaration Syntax
C# Visual Basic Visual C++
public bool HideVariations { get; set; }
Public Property HideVariations As Boolean
    Get
    Set
public:
property bool HideVariations {
    bool get ();
    void set (bool value);
}


HideVariationsSpecified Property

HideVariationsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType ► HideVariationsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HideVariationsSpecified { get; set; }
Public Property HideVariationsSpecified As Boolean
    Get
    Set
public:
property bool HideVariationsSpecified {
    bool get ();
    void set (bool value);
}


ScheduledList Property

ScheduledList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType ► ScheduledList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType ScheduledList { get; set; }
Public Property ScheduledList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ ScheduledList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


SellingSummary Property

SellingSummary Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType ► SellingSummary
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType SellingSummary { get; set; }
Public Property SellingSummary As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ SellingSummary {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


SoldList Property

SoldList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType ► SoldList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType SoldList { get; set; }
Public Property SoldList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ SoldList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


UnsoldList Property

UnsoldList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingRequestType ► UnsoldList
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType UnsoldList { get; set; }
Public Property UnsoldList As ItemListCustomizationType
    Get
    Set
public:
property ItemListCustomizationType^ UnsoldList {
    ItemListCustomizationType^ get ();
    void set (ItemListCustomizationType^ value);
}


GetMyeBaySellingResponseType Class

GetMyeBaySellingResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMyeBaySellingResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMyeBaySellingResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMyeBaySellingResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyeBaySellingResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | ActiveList |
 | Any | (Inherited from AbstractResponseType.)
 | BidList |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DeletedFromSoldList |
 | DeletedFromUnsoldList |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | ScheduledList |
 | SellingSummary |
 | SoldList |
 | Summary |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | UnsoldList |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetMyeBaySellingResponseType


ActiveList Property

ActiveList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingResponseType ► ActiveList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType ActiveList { get; set; }
Public Property ActiveList As PaginatedItemArrayType
    Get
    Set
public:
property PaginatedItemArrayType^ ActiveList {
    PaginatedItemArrayType^ get ();
    void set (PaginatedItemArrayType^ value);
}


BidList Property

BidList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingResponseType ► BidList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType BidList { get; set; }
Public Property BidList As PaginatedItemArrayType
    Get
    Set
public:
property PaginatedItemArrayType^ BidList {
    PaginatedItemArrayType^ get ();
    void set (PaginatedItemArrayType^ value);
}


DeletedFromSoldList Property

DeletedFromSoldList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingResponseType ► DeletedFromSoldList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedOrderTransactionArrayType DeletedFromSoldList { get; set; }
Public Property DeletedFromSoldList As PaginatedOrderTransactionArrayType
    Get
    Set
public:
property PaginatedOrderTransactionArrayType^ DeletedFromSoldList {
    PaginatedOrderTransactionArrayType^ get ();
    void set (PaginatedOrderTransactionArrayType^ value);
}


DeletedFromUnsoldList Property

DeletedFromUnsoldList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingResponseType ► DeletedFromUnsoldList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType DeletedFromUnsoldList { get; set; }
Public Property DeletedFromUnsoldList As PaginatedItemArrayType
    Get
    Set
public:
property PaginatedItemArrayType^ DeletedFromUnsoldList {
    PaginatedItemArrayType^ get ();
    void set (PaginatedItemArrayType^ value);
}


GetMyeBaySellingResponseType Constructor

GetMyeBaySellingResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingResponseType ► GetMyeBaySellingResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyeBaySellingResponseType()
Public Sub New
public:
GetMyeBaySellingResponseType()


ScheduledList Property

ScheduledList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingResponseType ► ScheduledList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType ScheduledList { get; set; }
Public Property ScheduledList As PaginatedItemArrayType
    Get
    Set
public:
property PaginatedItemArrayType^ ScheduledList {
    PaginatedItemArrayType^ get ();
    void set (PaginatedItemArrayType^ value);
}


SellingSummary Property

SellingSummary Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingResponseType ► SellingSummary
Declaration Syntax
C# Visual Basic Visual C++
public SellingSummaryType SellingSummary { get; set; }
Public Property SellingSummary As SellingSummaryType
    Get
    Set
public:
property SellingSummaryType^ SellingSummary {
    SellingSummaryType^ get ();
    void set (SellingSummaryType^ value);
}


SoldList Property

SoldList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingResponseType ► SoldList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedOrderTransactionArrayType SoldList { get; set; }
Public Property SoldList As PaginatedOrderTransactionArrayType
    Get
    Set
public:
property PaginatedOrderTransactionArrayType^ SoldList {
    PaginatedOrderTransactionArrayType^ get ();
    void set (PaginatedOrderTransactionArrayType^ value);
}


Summary Property

Summary Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingResponseType ► Summary
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySellingSummaryType Summary { get; set; }
Public Property Summary As MyeBaySellingSummaryType
    Get
    Set
public:
property MyeBaySellingSummaryType^ Summary {
    MyeBaySellingSummaryType^ get ();
    void set (MyeBaySellingSummaryType^ value);
}


UnsoldList Property

UnsoldList Property
Namespaces ► eBay.Service.Core.Soap ► GetMyeBaySellingResponseType ► UnsoldList
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType UnsoldList { get; set; }
Public Property UnsoldList As PaginatedItemArrayType
    Get
    Set
public:
property PaginatedItemArrayType^ UnsoldList {
    PaginatedItemArrayType^ get ();
    void set (PaginatedItemArrayType^ value);
}


GetMyMessagesRequestType Class

GetMyMessagesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMyMessagesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMyMessagesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMyMessagesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyMessagesRequestType()()()() |
 | AlertIDs |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndTime |
 | EndTimeSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | ExternalMessageIDs |
 | Finalize()()()() | (Inherited from Object.)
 | FolderID |
 | FolderIDSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeHighPriorityMessageOnly |
 | IncludeHighPriorityMessageOnlySpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | MessageIDs |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | StartTime |
 | StartTimeSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetMyMessagesRequestType


AlertIDs Property

AlertIDs Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► AlertIDs
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection AlertIDs { get; set; }
Public Property AlertIDs As StringCollection
    Get
    Set
public:
property StringCollection^ AlertIDs {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


ExternalMessageIDs Property

ExternalMessageIDs Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► ExternalMessageIDs
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ExternalMessageIDs { get; set; }
Public Property ExternalMessageIDs As StringCollection
    Get
    Set
public:
property StringCollection^ ExternalMessageIDs {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


GetMyMessagesRequestType Constructor

GetMyMessagesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► GetMyMessagesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyMessagesRequestType()
Public Sub New
public:
GetMyMessagesRequestType()


IncludeHighPriorityMessageOnly Property

IncludeHighPriorityMessageOnly Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► IncludeHighPriorityMessageOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeHighPriorityMessageOnly { get; set; }
Public Property IncludeHighPriorityMessageOnly As Boolean
    Get
    Set
public:
property bool IncludeHighPriorityMessageOnly {
    bool get ();
    void set (bool value);
}


IncludeHighPriorityMessageOnlySpecified Property

IncludeHighPriorityMessageOnlySpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► IncludeHighPriorityMessageOnlySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeHighPriorityMessageOnlySpecified { get; set; }
Public Property IncludeHighPriorityMessageOnlySpecified As Boolean
    Get
    Set
public:
property bool IncludeHighPriorityMessageOnlySpecified {
    bool get ();
    void set (bool value);
}


MessageIDs Property

MessageIDs Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► MessageIDs
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection MessageIDs { get; set; }
Public Property MessageIDs As StringCollection
    Get
    Set
public:
property StringCollection^ MessageIDs {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesRequestType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


GetMyMessagesResponseType Class

GetMyMessagesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetMyMessagesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetMyMessagesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetMyMessagesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetMyMessagesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Alerts |
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | Messages |
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Summary |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetMyMessagesResponseType


Alerts Property

Alerts Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesResponseType ► Alerts
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesAlertTypeCollection Alerts { get; set; }
Public Property Alerts As MyMessagesAlertTypeCollection
    Get
    Set
public:
property MyMessagesAlertTypeCollection^ Alerts {
    MyMessagesAlertTypeCollection^ get ();
    void set (MyMessagesAlertTypeCollection^ value);
}


GetMyMessagesResponseType Constructor

GetMyMessagesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesResponseType ► GetMyMessagesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetMyMessagesResponseType()
Public Sub New
public:
GetMyMessagesResponseType()


Messages Property

Messages Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesResponseType ► Messages
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesMessageTypeCollection Messages { get; set; }
Public Property Messages As MyMessagesMessageTypeCollection
    Get
    Set
public:
property MyMessagesMessageTypeCollection^ Messages {
    MyMessagesMessageTypeCollection^ get ();
    void set (MyMessagesMessageTypeCollection^ value);
}


Summary Property

Summary Property
Namespaces ► eBay.Service.Core.Soap ► GetMyMessagesResponseType ► Summary
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesSummaryType Summary { get; set; }
Public Property Summary As MyMessagesSummaryType
    Get
    Set
public:
property MyMessagesSummaryType^ Summary {
    MyMessagesSummaryType^ get ();
    void set (MyMessagesSummaryType^ value);
}


GetNotificationPreferencesRequestType Class

GetNotificationPreferencesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetNotificationPreferencesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetNotificationPreferencesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetNotificationPreferencesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetNotificationPreferencesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetNotificationPreferencesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | PreferenceLevel |
 | PreferenceLevelSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetNotificationPreferencesRequestType


GetNotificationPreferencesRequestType Constructor

GetNotificationPreferencesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetNotificationPreferencesRequestType ► GetNotificationPreferencesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationPreferencesRequestType()
Public Sub New
public:
GetNotificationPreferencesRequestType()


PreferenceLevel Property

PreferenceLevel Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationPreferencesRequestType ► PreferenceLevel
Declaration Syntax
C# Visual Basic Visual C++
public NotificationRoleCodeType PreferenceLevel { get; set; }
Public Property PreferenceLevel As NotificationRoleCodeType
    Get
    Set
public:
property NotificationRoleCodeType PreferenceLevel {
    NotificationRoleCodeType get ();
    void set (NotificationRoleCodeType value);
}


PreferenceLevelSpecified Property

PreferenceLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationPreferencesRequestType ► PreferenceLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PreferenceLevelSpecified { get; set; }
Public Property PreferenceLevelSpecified As Boolean
    Get
    Set
public:
property bool PreferenceLevelSpecified {
    bool get ();
    void set (bool value);
}


GetNotificationPreferencesResponseType Class

GetNotificationPreferencesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetNotificationPreferencesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetNotificationPreferencesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetNotificationPreferencesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetNotificationPreferencesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetNotificationPreferencesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | ApplicationDeliveryPreferences |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DeliveryURLName |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | EventProperty |
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | UserData |
 | UserDeliveryPreferenceArray |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetNotificationPreferencesResponseType


ApplicationDeliveryPreferences Property

ApplicationDeliveryPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationPreferencesResponseType ► ApplicationDeliveryPreferences
Declaration Syntax
C# Visual Basic Visual C++
public ApplicationDeliveryPreferencesType ApplicationDeliveryPreferences { get; set; }
Public Property ApplicationDeliveryPreferences As ApplicationDeliveryPreferencesType
    Get
    Set
public:
property ApplicationDeliveryPreferencesType^ ApplicationDeliveryPreferences {
    ApplicationDeliveryPreferencesType^ get ();
    void set (ApplicationDeliveryPreferencesType^ value);
}


DeliveryURLName Property

DeliveryURLName Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationPreferencesResponseType ► DeliveryURLName
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryURLName { get; set; }
Public Property DeliveryURLName As String
    Get
    Set
public:
property String^ DeliveryURLName {
    String^ get ();
    void set (String^ value);
}


EventProperty Property

EventProperty Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationPreferencesResponseType ► EventProperty
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyTypeCollection EventProperty { get; set; }
Public Property EventProperty As NotificationEventPropertyTypeCollection
    Get
    Set
public:
property NotificationEventPropertyTypeCollection^ EventProperty {
    NotificationEventPropertyTypeCollection^ get ();
    void set (NotificationEventPropertyTypeCollection^ value);
}


GetNotificationPreferencesResponseType Constructor

GetNotificationPreferencesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetNotificationPreferencesResponseType ► GetNotificationPreferencesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationPreferencesResponseType()
Public Sub New
public:
GetNotificationPreferencesResponseType()


UserData Property

UserData Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationPreferencesResponseType ► UserData
Declaration Syntax
C# Visual Basic Visual C++
public NotificationUserDataType UserData { get; set; }
Public Property UserData As NotificationUserDataType
    Get
    Set
public:
property NotificationUserDataType^ UserData {
    NotificationUserDataType^ get ();
    void set (NotificationUserDataType^ value);
}


UserDeliveryPreferenceArray Property

UserDeliveryPreferenceArray Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationPreferencesResponseType ► UserDeliveryPreferenceArray
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEnableTypeCollection UserDeliveryPreferenceArray { get; set; }
Public Property UserDeliveryPreferenceArray As NotificationEnableTypeCollection
    Get
    Set
public:
property NotificationEnableTypeCollection^ UserDeliveryPreferenceArray {
    NotificationEnableTypeCollection^ get ();
    void set (NotificationEnableTypeCollection^ value);
}


GetNotificationsUsageRequestType Class

GetNotificationsUsageRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetNotificationsUsageRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetNotificationsUsageRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetNotificationsUsageRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetNotificationsUsageRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndTime |
 | EndTimeSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | StartTime |
 | StartTimeSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetNotificationsUsageRequestType


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageRequestType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageRequestType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


GetNotificationsUsageRequestType Constructor

GetNotificationsUsageRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageRequestType ► GetNotificationsUsageRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationsUsageRequestType()
Public Sub New
public:
GetNotificationsUsageRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageRequestType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageRequestType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


GetNotificationsUsageResponseType Class

GetNotificationsUsageResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetNotificationsUsageResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetNotificationsUsageResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetNotificationsUsageResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetNotificationsUsageResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MarkUpMarkDownHistory |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationDetailsArray |
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | NotificationStatistics |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetNotificationsUsageResponseType


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


GetNotificationsUsageResponseType Constructor

GetNotificationsUsageResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageResponseType ► GetNotificationsUsageResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetNotificationsUsageResponseType()
Public Sub New
public:
GetNotificationsUsageResponseType()


MarkUpMarkDownHistory Property

MarkUpMarkDownHistory Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageResponseType ► MarkUpMarkDownHistory
Declaration Syntax
C# Visual Basic Visual C++
public MarkUpMarkDownEventTypeCollection MarkUpMarkDownHistory { get; set; }
Public Property MarkUpMarkDownHistory As MarkUpMarkDownEventTypeCollection
    Get
    Set
public:
property MarkUpMarkDownEventTypeCollection^ MarkUpMarkDownHistory {
    MarkUpMarkDownEventTypeCollection^ get ();
    void set (MarkUpMarkDownEventTypeCollection^ value);
}


NotificationDetailsArray Property

NotificationDetailsArray Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageResponseType ► NotificationDetailsArray
Declaration Syntax
C# Visual Basic Visual C++
public NotificationDetailsTypeCollection NotificationDetailsArray { get; set; }
Public Property NotificationDetailsArray As NotificationDetailsTypeCollection
    Get
    Set
public:
property NotificationDetailsTypeCollection^ NotificationDetailsArray {
    NotificationDetailsTypeCollection^ get ();
    void set (NotificationDetailsTypeCollection^ value);
}


NotificationStatistics Property

NotificationStatistics Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageResponseType ► NotificationStatistics
Declaration Syntax
C# Visual Basic Visual C++
public NotificationStatisticsType NotificationStatistics { get; set; }
Public Property NotificationStatistics As NotificationStatisticsType
    Get
    Set
public:
property NotificationStatisticsType^ NotificationStatistics {
    NotificationStatisticsType^ get ();
    void set (NotificationStatisticsType^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetNotificationsUsageResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


GetOrdersRequestType Class

GetOrdersRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetOrdersRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetOrdersRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetOrdersRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetOrdersRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CreateTimeFrom |
 | CreateTimeFromSpecified |
 | CreateTimeTo |
 | CreateTimeToSpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeFinalValueFee |
 | IncludeFinalValueFeeSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | ListingType |
 | ListingTypeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | ModTimeFrom |
 | ModTimeFromSpecified |
 | ModTimeTo |
 | ModTimeToSpecified |
 | NumberOfDays |
 | NumberOfDaysSpecified |
 | OrderIDArray |
 | OrderRole |
 | OrderRoleSpecified |
 | OrderStatus |
 | OrderStatusSpecified |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | SortingOrder |
 | SortingOrderSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetOrdersRequestType


CreateTimeFrom Property

CreateTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► CreateTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreateTimeFrom { get; set; }
Public Property CreateTimeFrom As DateTime
    Get
    Set
public:
property DateTime CreateTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


CreateTimeFromSpecified Property

CreateTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► CreateTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreateTimeFromSpecified { get; set; }
Public Property CreateTimeFromSpecified As Boolean
    Get
    Set
public:
property bool CreateTimeFromSpecified {
    bool get ();
    void set (bool value);
}


CreateTimeTo Property

CreateTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► CreateTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreateTimeTo { get; set; }
Public Property CreateTimeTo As DateTime
    Get
    Set
public:
property DateTime CreateTimeTo {
    DateTime get ();
    void set (DateTime value);
}


CreateTimeToSpecified Property

CreateTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► CreateTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreateTimeToSpecified { get; set; }
Public Property CreateTimeToSpecified As Boolean
    Get
    Set
public:
property bool CreateTimeToSpecified {
    bool get ();
    void set (bool value);
}


GetOrdersRequestType Constructor

GetOrdersRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► GetOrdersRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetOrdersRequestType()
Public Sub New
public:
GetOrdersRequestType()


IncludeFinalValueFee Property

IncludeFinalValueFee Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► IncludeFinalValueFee
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFee { get; set; }
Public Property IncludeFinalValueFee As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFee {
    bool get ();
    void set (bool value);
}


IncludeFinalValueFeeSpecified Property

IncludeFinalValueFeeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► IncludeFinalValueFeeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFeeSpecified { get; set; }
Public Property IncludeFinalValueFeeSpecified As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFeeSpecified {
    bool get ();
    void set (bool value);
}


ListingType Property

ListingType Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► ListingType
Declaration Syntax
C# Visual Basic Visual C++
public ListingTypeCodeType ListingType { get; set; }
Public Property ListingType As ListingTypeCodeType
    Get
    Set
public:
property ListingTypeCodeType ListingType {
    ListingTypeCodeType get ();
    void set (ListingTypeCodeType value);
}


ListingTypeSpecified Property

ListingTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► ListingTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingTypeSpecified { get; set; }
Public Property ListingTypeSpecified As Boolean
    Get
    Set
public:
property bool ListingTypeSpecified {
    bool get ();
    void set (bool value);
}


ModTimeFrom Property

ModTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► ModTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeFrom { get; set; }
Public Property ModTimeFrom As DateTime
    Get
    Set
public:
property DateTime ModTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


ModTimeFromSpecified Property

ModTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► ModTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModTimeFromSpecified { get; set; }
Public Property ModTimeFromSpecified As Boolean
    Get
    Set
public:
property bool ModTimeFromSpecified {
    bool get ();
    void set (bool value);
}


ModTimeTo Property

ModTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► ModTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeTo { get; set; }
Public Property ModTimeTo As DateTime
    Get
    Set
public:
property DateTime ModTimeTo {
    DateTime get ();
    void set (DateTime value);
}


ModTimeToSpecified Property

ModTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► ModTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModTimeToSpecified { get; set; }
Public Property ModTimeToSpecified As Boolean
    Get
    Set
public:
property bool ModTimeToSpecified {
    bool get ();
    void set (bool value);
}


NumberOfDays Property

NumberOfDays Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► NumberOfDays
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfDays { get; set; }
Public Property NumberOfDays As Integer
    Get
    Set
public:
property int NumberOfDays {
    int get ();
    void set (int value);
}


NumberOfDaysSpecified Property

NumberOfDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► NumberOfDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NumberOfDaysSpecified { get; set; }
Public Property NumberOfDaysSpecified As Boolean
    Get
    Set
public:
property bool NumberOfDaysSpecified {
    bool get ();
    void set (bool value);
}


OrderIDArray Property

OrderIDArray Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► OrderIDArray
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection OrderIDArray { get; set; }
Public Property OrderIDArray As StringCollection
    Get
    Set
public:
property StringCollection^ OrderIDArray {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


OrderRole Property

OrderRole Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► OrderRole
Declaration Syntax
C# Visual Basic Visual C++
public TradingRoleCodeType OrderRole { get; set; }
Public Property OrderRole As TradingRoleCodeType
    Get
    Set
public:
property TradingRoleCodeType OrderRole {
    TradingRoleCodeType get ();
    void set (TradingRoleCodeType value);
}


OrderRoleSpecified Property

OrderRoleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► OrderRoleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OrderRoleSpecified { get; set; }
Public Property OrderRoleSpecified As Boolean
    Get
    Set
public:
property bool OrderRoleSpecified {
    bool get ();
    void set (bool value);
}


OrderStatus Property

OrderStatus Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► OrderStatus
Declaration Syntax
C# Visual Basic Visual C++
public OrderStatusCodeType OrderStatus { get; set; }
Public Property OrderStatus As OrderStatusCodeType
    Get
    Set
public:
property OrderStatusCodeType OrderStatus {
    OrderStatusCodeType get ();
    void set (OrderStatusCodeType value);
}


OrderStatusSpecified Property

OrderStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► OrderStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OrderStatusSpecified { get; set; }
Public Property OrderStatusSpecified As Boolean
    Get
    Set
public:
property bool OrderStatusSpecified {
    bool get ();
    void set (bool value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


SortingOrder Property

SortingOrder Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► SortingOrder
Declaration Syntax
C# Visual Basic Visual C++
public SortOrderCodeType SortingOrder { get; set; }
Public Property SortingOrder As SortOrderCodeType
    Get
    Set
public:
property SortOrderCodeType SortingOrder {
    SortOrderCodeType get ();
    void set (SortOrderCodeType value);
}


SortingOrderSpecified Property

SortingOrderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersRequestType ► SortingOrderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SortingOrderSpecified { get; set; }
Public Property SortingOrderSpecified As Boolean
    Get
    Set
public:
property bool SortingOrderSpecified {
    bool get ();
    void set (bool value);
}


GetOrdersResponseType Class

GetOrdersResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetOrdersResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetOrdersResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetOrdersResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetOrdersResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | HasMoreOrders |
 | HasMoreOrdersSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | OrderArray |
 | OrdersPerPage |
 | OrdersPerPageSpecified |
 | PageNumber |
 | PageNumberSpecified |
 | PaginationResult |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | ReturnedOrderCountActual |
 | ReturnedOrderCountActualSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetOrdersResponseType


GetOrdersResponseType Constructor

GetOrdersResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType ► GetOrdersResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetOrdersResponseType()
Public Sub New
public:
GetOrdersResponseType()


HasMoreOrders Property

HasMoreOrders Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType ► HasMoreOrders
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreOrders { get; set; }
Public Property HasMoreOrders As Boolean
    Get
    Set
public:
property bool HasMoreOrders {
    bool get ();
    void set (bool value);
}


HasMoreOrdersSpecified Property

HasMoreOrdersSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType ► HasMoreOrdersSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreOrdersSpecified { get; set; }
Public Property HasMoreOrdersSpecified As Boolean
    Get
    Set
public:
property bool HasMoreOrdersSpecified {
    bool get ();
    void set (bool value);
}


OrderArray Property

OrderArray Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType ► OrderArray
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection OrderArray { get; set; }
Public Property OrderArray As OrderTypeCollection
    Get
    Set
public:
property OrderTypeCollection^ OrderArray {
    OrderTypeCollection^ get ();
    void set (OrderTypeCollection^ value);
}


OrdersPerPage Property

OrdersPerPage Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType ► OrdersPerPage
Declaration Syntax
C# Visual Basic Visual C++
public int OrdersPerPage { get; set; }
Public Property OrdersPerPage As Integer
    Get
    Set
public:
property int OrdersPerPage {
    int get ();
    void set (int value);
}


OrdersPerPageSpecified Property

OrdersPerPageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType ► OrdersPerPageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OrdersPerPageSpecified { get; set; }
Public Property OrdersPerPageSpecified As Boolean
    Get
    Set
public:
property bool OrdersPerPageSpecified {
    bool get ();
    void set (bool value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType ► PageNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}


PageNumberSpecified Property

PageNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType ► PageNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageNumberSpecified { get; set; }
Public Property PageNumberSpecified As Boolean
    Get
    Set
public:
property bool PageNumberSpecified {
    bool get ();
    void set (bool value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


ReturnedOrderCountActual Property

ReturnedOrderCountActual Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType ► ReturnedOrderCountActual
Declaration Syntax
C# Visual Basic Visual C++
public int ReturnedOrderCountActual { get; set; }
Public Property ReturnedOrderCountActual As Integer
    Get
    Set
public:
property int ReturnedOrderCountActual {
    int get ();
    void set (int value);
}


ReturnedOrderCountActualSpecified Property

ReturnedOrderCountActualSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrdersResponseType ► ReturnedOrderCountActualSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnedOrderCountActualSpecified { get; set; }
Public Property ReturnedOrderCountActualSpecified As Boolean
    Get
    Set
public:
property bool ReturnedOrderCountActualSpecified {
    bool get ();
    void set (bool value);
}


GetOrderTransactionsRequestType Class

GetOrderTransactionsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetOrderTransactionsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetOrderTransactionsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetOrderTransactionsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetOrderTransactionsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetOrderTransactionsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeFinalValueFees |
 | IncludeFinalValueFeesSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemTransactionIDArray |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderIDArray |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Platform |
 | PlatformSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetOrderTransactionsRequestType


GetOrderTransactionsRequestType Constructor

GetOrderTransactionsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetOrderTransactionsRequestType ► GetOrderTransactionsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetOrderTransactionsRequestType()
Public Sub New
public:
GetOrderTransactionsRequestType()


IncludeFinalValueFees Property

IncludeFinalValueFees Property
Namespaces ► eBay.Service.Core.Soap ► GetOrderTransactionsRequestType ► IncludeFinalValueFees
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFees { get; set; }
Public Property IncludeFinalValueFees As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFees {
    bool get ();
    void set (bool value);
}


IncludeFinalValueFeesSpecified Property

IncludeFinalValueFeesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrderTransactionsRequestType ► IncludeFinalValueFeesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFeesSpecified { get; set; }
Public Property IncludeFinalValueFeesSpecified As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFeesSpecified {
    bool get ();
    void set (bool value);
}


ItemTransactionIDArray Property

ItemTransactionIDArray Property
Namespaces ► eBay.Service.Core.Soap ► GetOrderTransactionsRequestType ► ItemTransactionIDArray
Declaration Syntax
C# Visual Basic Visual C++
public ItemTransactionIDTypeCollection ItemTransactionIDArray { get; set; }
Public Property ItemTransactionIDArray As ItemTransactionIDTypeCollection
    Get
    Set
public:
property ItemTransactionIDTypeCollection^ ItemTransactionIDArray {
    ItemTransactionIDTypeCollection^ get ();
    void set (ItemTransactionIDTypeCollection^ value);
}


OrderIDArray Property

OrderIDArray Property
Namespaces ► eBay.Service.Core.Soap ► GetOrderTransactionsRequestType ► OrderIDArray
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection OrderIDArray { get; set; }
Public Property OrderIDArray As StringCollection
    Get
    Set
public:
property StringCollection^ OrderIDArray {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Platform Property

Platform Property
Namespaces ► eBay.Service.Core.Soap ► GetOrderTransactionsRequestType ► Platform
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeType Platform { get; set; }
Public Property Platform As TransactionPlatformCodeType
    Get
    Set
public:
property TransactionPlatformCodeType Platform {
    TransactionPlatformCodeType get ();
    void set (TransactionPlatformCodeType value);
}


PlatformSpecified Property

PlatformSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetOrderTransactionsRequestType ► PlatformSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PlatformSpecified { get; set; }
Public Property PlatformSpecified As Boolean
    Get
    Set
public:
property bool PlatformSpecified {
    bool get ();
    void set (bool value);
}


GetOrderTransactionsResponseType Class

GetOrderTransactionsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetOrderTransactionsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetOrderTransactionsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetOrderTransactionsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetOrderTransactionsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetOrderTransactionsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | OrderArray |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetOrderTransactionsResponseType


GetOrderTransactionsResponseType Constructor

GetOrderTransactionsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetOrderTransactionsResponseType ► GetOrderTransactionsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetOrderTransactionsResponseType()
Public Sub New
public:
GetOrderTransactionsResponseType()


OrderArray Property

OrderArray Property
Namespaces ► eBay.Service.Core.Soap ► GetOrderTransactionsResponseType ► OrderArray
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection OrderArray { get; set; }
Public Property OrderArray As OrderTypeCollection
    Get
    Set
public:
property OrderTypeCollection^ OrderArray {
    OrderTypeCollection^ get ();
    void set (OrderTypeCollection^ value);
}


GetProductSellingPagesRequestType Class

GetProductSellingPagesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetProductSellingPagesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetProductSellingPagesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetProductSellingPagesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetProductSellingPagesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetProductSellingPagesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Product |
 | ToString()()()() | (Inherited from Object.)
 | UseCase |
 | UseCaseSpecified |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetProductSellingPagesRequestType


GetProductSellingPagesRequestType Constructor

GetProductSellingPagesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetProductSellingPagesRequestType ► GetProductSellingPagesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetProductSellingPagesRequestType()
Public Sub New
public:
GetProductSellingPagesRequestType()


Product Property

Product Property
Namespaces ► eBay.Service.Core.Soap ► GetProductSellingPagesRequestType ► Product
Declaration Syntax
C# Visual Basic Visual C++
public ProductTypeCollection Product { get; set; }
Public Property Product As ProductTypeCollection
    Get
    Set
public:
property ProductTypeCollection^ Product {
    ProductTypeCollection^ get ();
    void set (ProductTypeCollection^ value);
}


UseCase Property

UseCase Property
Namespaces ► eBay.Service.Core.Soap ► GetProductSellingPagesRequestType ► UseCase
Declaration Syntax
C# Visual Basic Visual C++
public ProductUseCaseCodeType UseCase { get; set; }
Public Property UseCase As ProductUseCaseCodeType
    Get
    Set
public:
property ProductUseCaseCodeType UseCase {
    ProductUseCaseCodeType get ();
    void set (ProductUseCaseCodeType value);
}


UseCaseSpecified Property

UseCaseSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetProductSellingPagesRequestType ► UseCaseSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UseCaseSpecified { get; set; }
Public Property UseCaseSpecified As Boolean
    Get
    Set
public:
property bool UseCaseSpecified {
    bool get ();
    void set (bool value);
}


GetProductSellingPagesResponseType Class

GetProductSellingPagesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetProductSellingPagesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetProductSellingPagesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetProductSellingPagesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetProductSellingPagesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetProductSellingPagesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | ProductSellingPagesData |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetProductSellingPagesResponseType


GetProductSellingPagesResponseType Constructor

GetProductSellingPagesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetProductSellingPagesResponseType ► GetProductSellingPagesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetProductSellingPagesResponseType()
Public Sub New
public:
GetProductSellingPagesResponseType()


ProductSellingPagesData Property

ProductSellingPagesData Property
Namespaces ► eBay.Service.Core.Soap ► GetProductSellingPagesResponseType ► ProductSellingPagesData
Declaration Syntax
C# Visual Basic Visual C++
public string ProductSellingPagesData { get; set; }
Public Property ProductSellingPagesData As String
    Get
    Set
public:
property String^ ProductSellingPagesData {
    String^ get ();
    void set (String^ value);
}


GetPromotionalSaleDetailsRequestType Class

GetPromotionalSaleDetailsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetPromotionalSaleDetailsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetPromotionalSaleDetailsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetPromotionalSaleDetailsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetPromotionalSaleDetailsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetPromotionalSaleDetailsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | PromotionalSaleID |
 | PromotionalSaleIDSpecified |
 | PromotionalSaleStatus |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetPromotionalSaleDetailsRequestType


GetPromotionalSaleDetailsRequestType Constructor

GetPromotionalSaleDetailsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetPromotionalSaleDetailsRequestType ► GetPromotionalSaleDetailsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetPromotionalSaleDetailsRequestType()
Public Sub New
public:
GetPromotionalSaleDetailsRequestType()


PromotionalSaleID Property

PromotionalSaleID Property
Namespaces ► eBay.Service.Core.Soap ► GetPromotionalSaleDetailsRequestType ► PromotionalSaleID
Declaration Syntax
C# Visual Basic Visual C++
public long PromotionalSaleID { get; set; }
Public Property PromotionalSaleID As Long
    Get
    Set
public:
property long long PromotionalSaleID {
    long long get ();
    void set (long long value);
}


PromotionalSaleIDSpecified Property

PromotionalSaleIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetPromotionalSaleDetailsRequestType ► PromotionalSaleIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalSaleIDSpecified { get; set; }
Public Property PromotionalSaleIDSpecified As Boolean
    Get
    Set
public:
property bool PromotionalSaleIDSpecified {
    bool get ();
    void set (bool value);
}


PromotionalSaleStatus Property

PromotionalSaleStatus Property
Namespaces ► eBay.Service.Core.Soap ► GetPromotionalSaleDetailsRequestType ► PromotionalSaleStatus
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeTypeCollection PromotionalSaleStatus { get; set; }
Public Property PromotionalSaleStatus As PromotionalSaleStatusCodeTypeCollection
    Get
    Set
public:
property PromotionalSaleStatusCodeTypeCollection^ PromotionalSaleStatus {
    PromotionalSaleStatusCodeTypeCollection^ get ();
    void set (PromotionalSaleStatusCodeTypeCollection^ value);
}


GetPromotionalSaleDetailsResponseType Class

GetPromotionalSaleDetailsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetPromotionalSaleDetailsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetPromotionalSaleDetailsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetPromotionalSaleDetailsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetPromotionalSaleDetailsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetPromotionalSaleDetailsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PromotionalSaleDetails |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetPromotionalSaleDetailsResponseType


GetPromotionalSaleDetailsResponseType Constructor

GetPromotionalSaleDetailsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetPromotionalSaleDetailsResponseType ► GetPromotionalSaleDetailsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetPromotionalSaleDetailsResponseType()
Public Sub New
public:
GetPromotionalSaleDetailsResponseType()


PromotionalSaleDetails Property

PromotionalSaleDetails Property
Namespaces ► eBay.Service.Core.Soap ► GetPromotionalSaleDetailsResponseType ► PromotionalSaleDetails
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleTypeCollection PromotionalSaleDetails { get; set; }
Public Property PromotionalSaleDetails As PromotionalSaleTypeCollection
    Get
    Set
public:
property PromotionalSaleTypeCollection^ PromotionalSaleDetails {
    PromotionalSaleTypeCollection^ get ();
    void set (PromotionalSaleTypeCollection^ value);
}


GetSellerDashboardRequestType Class

GetSellerDashboardRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellerDashboardRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellerDashboardRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellerDashboardRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellerDashboardRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerDashboardRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellerDashboardRequestType


GetSellerDashboardRequestType Constructor

GetSellerDashboardRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellerDashboardRequestType ► GetSellerDashboardRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerDashboardRequestType()
Public Sub New
public:
GetSellerDashboardRequestType()


GetSellerDashboardResponseType Class

GetSellerDashboardResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellerDashboardResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellerDashboardResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellerDashboardResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellerDashboardResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerDashboardResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | BuyerSatisfaction |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | Performance |
 | PolicyCompliance |
 | PowerSellerStatus |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SearchStanding |
 | SellerAccount |
 | SellerFeeDiscount |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellerDashboardResponseType


BuyerSatisfaction Property

BuyerSatisfaction Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerDashboardResponseType ► BuyerSatisfaction
Declaration Syntax
C# Visual Basic Visual C++
public BuyerSatisfactionDashboardType BuyerSatisfaction { get; set; }
Public Property BuyerSatisfaction As BuyerSatisfactionDashboardType
    Get
    Set
public:
property BuyerSatisfactionDashboardType^ BuyerSatisfaction {
    BuyerSatisfactionDashboardType^ get ();
    void set (BuyerSatisfactionDashboardType^ value);
}


GetSellerDashboardResponseType Constructor

GetSellerDashboardResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellerDashboardResponseType ► GetSellerDashboardResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerDashboardResponseType()
Public Sub New
public:
GetSellerDashboardResponseType()


Performance Property

Performance Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerDashboardResponseType ► Performance
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceDashboardTypeCollection Performance { get; set; }
Public Property Performance As PerformanceDashboardTypeCollection
    Get
    Set
public:
property PerformanceDashboardTypeCollection^ Performance {
    PerformanceDashboardTypeCollection^ get ();
    void set (PerformanceDashboardTypeCollection^ value);
}


PolicyCompliance Property

PolicyCompliance Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerDashboardResponseType ► PolicyCompliance
Declaration Syntax
C# Visual Basic Visual C++
public PolicyComplianceDashboardType PolicyCompliance { get; set; }
Public Property PolicyCompliance As PolicyComplianceDashboardType
    Get
    Set
public:
property PolicyComplianceDashboardType^ PolicyCompliance {
    PolicyComplianceDashboardType^ get ();
    void set (PolicyComplianceDashboardType^ value);
}


PowerSellerStatus Property

PowerSellerStatus Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerDashboardResponseType ► PowerSellerStatus
Declaration Syntax
C# Visual Basic Visual C++
public PowerSellerDashboardType PowerSellerStatus { get; set; }
Public Property PowerSellerStatus As PowerSellerDashboardType
    Get
    Set
public:
property PowerSellerDashboardType^ PowerSellerStatus {
    PowerSellerDashboardType^ get ();
    void set (PowerSellerDashboardType^ value);
}


SearchStanding Property

SearchStanding Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerDashboardResponseType ► SearchStanding
Declaration Syntax
C# Visual Basic Visual C++
public SearchStandingDashboardType SearchStanding { get; set; }
Public Property SearchStanding As SearchStandingDashboardType
    Get
    Set
public:
property SearchStandingDashboardType^ SearchStanding {
    SearchStandingDashboardType^ get ();
    void set (SearchStandingDashboardType^ value);
}


SellerAccount Property

SellerAccount Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerDashboardResponseType ► SellerAccount
Declaration Syntax
C# Visual Basic Visual C++
public SellerAccountDashboardType SellerAccount { get; set; }
Public Property SellerAccount As SellerAccountDashboardType
    Get
    Set
public:
property SellerAccountDashboardType^ SellerAccount {
    SellerAccountDashboardType^ get ();
    void set (SellerAccountDashboardType^ value);
}


SellerFeeDiscount Property

SellerFeeDiscount Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerDashboardResponseType ► SellerFeeDiscount
Declaration Syntax
C# Visual Basic Visual C++
public SellerFeeDiscountDashboardType SellerFeeDiscount { get; set; }
Public Property SellerFeeDiscount As SellerFeeDiscountDashboardType
    Get
    Set
public:
property SellerFeeDiscountDashboardType^ SellerFeeDiscount {
    SellerFeeDiscountDashboardType^ get ();
    void set (SellerFeeDiscountDashboardType^ value);
}


GetSellerEventsRequestType Class

GetSellerEventsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellerEventsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellerEventsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellerEventsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerEventsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndTimeFrom |
 | EndTimeFromSpecified |
 | EndTimeTo |
 | EndTimeToSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HideVariations |
 | HideVariationsSpecified |
 | IncludeVariationSpecifics |
 | IncludeVariationSpecificsSpecified |
 | IncludeWatchCount |
 | IncludeWatchCountSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | ModTimeFrom |
 | ModTimeFromSpecified |
 | ModTimeTo |
 | ModTimeToSpecified |
 | NewItemFilter |
 | NewItemFilterSpecified |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | StartTimeFrom |
 | StartTimeFromSpecified |
 | StartTimeTo |
 | StartTimeToSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UserID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellerEventsRequestType


EndTimeFrom Property

EndTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► EndTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeFrom { get; set; }
Public Property EndTimeFrom As DateTime
    Get
    Set
public:
property DateTime EndTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


EndTimeFromSpecified Property

EndTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► EndTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeFromSpecified { get; set; }
Public Property EndTimeFromSpecified As Boolean
    Get
    Set
public:
property bool EndTimeFromSpecified {
    bool get ();
    void set (bool value);
}


EndTimeTo Property

EndTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► EndTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeTo { get; set; }
Public Property EndTimeTo As DateTime
    Get
    Set
public:
property DateTime EndTimeTo {
    DateTime get ();
    void set (DateTime value);
}


EndTimeToSpecified Property

EndTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► EndTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeToSpecified { get; set; }
Public Property EndTimeToSpecified As Boolean
    Get
    Set
public:
property bool EndTimeToSpecified {
    bool get ();
    void set (bool value);
}


GetSellerEventsRequestType Constructor

GetSellerEventsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► GetSellerEventsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerEventsRequestType()
Public Sub New
public:
GetSellerEventsRequestType()


HideVariations Property

HideVariations Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► HideVariations
Declaration Syntax
C# Visual Basic Visual C++
public bool HideVariations { get; set; }
Public Property HideVariations As Boolean
    Get
    Set
public:
property bool HideVariations {
    bool get ();
    void set (bool value);
}


HideVariationsSpecified Property

HideVariationsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► HideVariationsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HideVariationsSpecified { get; set; }
Public Property HideVariationsSpecified As Boolean
    Get
    Set
public:
property bool HideVariationsSpecified {
    bool get ();
    void set (bool value);
}


IncludeVariationSpecifics Property

IncludeVariationSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► IncludeVariationSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeVariationSpecifics { get; set; }
Public Property IncludeVariationSpecifics As Boolean
    Get
    Set
public:
property bool IncludeVariationSpecifics {
    bool get ();
    void set (bool value);
}


IncludeVariationSpecificsSpecified Property

IncludeVariationSpecificsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► IncludeVariationSpecificsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeVariationSpecificsSpecified { get; set; }
Public Property IncludeVariationSpecificsSpecified As Boolean
    Get
    Set
public:
property bool IncludeVariationSpecificsSpecified {
    bool get ();
    void set (bool value);
}


IncludeWatchCount Property

IncludeWatchCount Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► IncludeWatchCount
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeWatchCount { get; set; }
Public Property IncludeWatchCount As Boolean
    Get
    Set
public:
property bool IncludeWatchCount {
    bool get ();
    void set (bool value);
}


IncludeWatchCountSpecified Property

IncludeWatchCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► IncludeWatchCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeWatchCountSpecified { get; set; }
Public Property IncludeWatchCountSpecified As Boolean
    Get
    Set
public:
property bool IncludeWatchCountSpecified {
    bool get ();
    void set (bool value);
}


ModTimeFrom Property

ModTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► ModTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeFrom { get; set; }
Public Property ModTimeFrom As DateTime
    Get
    Set
public:
property DateTime ModTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


ModTimeFromSpecified Property

ModTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► ModTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModTimeFromSpecified { get; set; }
Public Property ModTimeFromSpecified As Boolean
    Get
    Set
public:
property bool ModTimeFromSpecified {
    bool get ();
    void set (bool value);
}


ModTimeTo Property

ModTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► ModTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeTo { get; set; }
Public Property ModTimeTo As DateTime
    Get
    Set
public:
property DateTime ModTimeTo {
    DateTime get ();
    void set (DateTime value);
}


ModTimeToSpecified Property

ModTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► ModTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModTimeToSpecified { get; set; }
Public Property ModTimeToSpecified As Boolean
    Get
    Set
public:
property bool ModTimeToSpecified {
    bool get ();
    void set (bool value);
}


NewItemFilter Property

NewItemFilter Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► NewItemFilter
Declaration Syntax
C# Visual Basic Visual C++
public bool NewItemFilter { get; set; }
Public Property NewItemFilter As Boolean
    Get
    Set
public:
property bool NewItemFilter {
    bool get ();
    void set (bool value);
}


NewItemFilterSpecified Property

NewItemFilterSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► NewItemFilterSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewItemFilterSpecified { get; set; }
Public Property NewItemFilterSpecified As Boolean
    Get
    Set
public:
property bool NewItemFilterSpecified {
    bool get ();
    void set (bool value);
}


StartTimeFrom Property

StartTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► StartTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTimeFrom { get; set; }
Public Property StartTimeFrom As DateTime
    Get
    Set
public:
property DateTime StartTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


StartTimeFromSpecified Property

StartTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► StartTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeFromSpecified { get; set; }
Public Property StartTimeFromSpecified As Boolean
    Get
    Set
public:
property bool StartTimeFromSpecified {
    bool get ();
    void set (bool value);
}


StartTimeTo Property

StartTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► StartTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTimeTo { get; set; }
Public Property StartTimeTo As DateTime
    Get
    Set
public:
property DateTime StartTimeTo {
    DateTime get ();
    void set (DateTime value);
}


StartTimeToSpecified Property

StartTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► StartTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeToSpecified { get; set; }
Public Property StartTimeToSpecified As Boolean
    Get
    Set
public:
property bool StartTimeToSpecified {
    bool get ();
    void set (bool value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsRequestType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetSellerEventsResponseType Class

GetSellerEventsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellerEventsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellerEventsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellerEventsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerEventsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemArray |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | TimeTo |
 | TimeToSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellerEventsResponseType


GetSellerEventsResponseType Constructor

GetSellerEventsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsResponseType ► GetSellerEventsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerEventsResponseType()
Public Sub New
public:
GetSellerEventsResponseType()


ItemArray Property

ItemArray Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsResponseType ► ItemArray
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection ItemArray { get; set; }
Public Property ItemArray As ItemTypeCollection
    Get
    Set
public:
property ItemTypeCollection^ ItemArray {
    ItemTypeCollection^ get ();
    void set (ItemTypeCollection^ value);
}


TimeTo Property

TimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsResponseType ► TimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeTo { get; set; }
Public Property TimeTo As DateTime
    Get
    Set
public:
property DateTime TimeTo {
    DateTime get ();
    void set (DateTime value);
}


TimeToSpecified Property

TimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerEventsResponseType ► TimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TimeToSpecified { get; set; }
Public Property TimeToSpecified As Boolean
    Get
    Set
public:
property bool TimeToSpecified {
    bool get ();
    void set (bool value);
}


GetSellerListRequestType Class

GetSellerListRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellerListRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellerListRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellerListRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerListRequestType()()()() |
 | AdminEndedItemsOnly |
 | AdminEndedItemsOnlySpecified |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CategoryID |
 | CategoryIDSpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndTimeFrom |
 | EndTimeFromSpecified |
 | EndTimeTo |
 | EndTimeToSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GranularityLevel |
 | GranularityLevelSpecified |
 | IncludeVariations |
 | IncludeVariationsSpecified |
 | IncludeWatchCount |
 | IncludeWatchCountSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | MotorsDealerUsers |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | SKUArray |
 | Sort |
 | SortSpecified |
 | StartTimeFrom |
 | StartTimeFromSpecified |
 | StartTimeTo |
 | StartTimeToSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UserID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellerListRequestType


AdminEndedItemsOnly Property

AdminEndedItemsOnly Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► AdminEndedItemsOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool AdminEndedItemsOnly { get; set; }
Public Property AdminEndedItemsOnly As Boolean
    Get
    Set
public:
property bool AdminEndedItemsOnly {
    bool get ();
    void set (bool value);
}


AdminEndedItemsOnlySpecified Property

AdminEndedItemsOnlySpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► AdminEndedItemsOnlySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AdminEndedItemsOnlySpecified { get; set; }
Public Property AdminEndedItemsOnlySpecified As Boolean
    Get
    Set
public:
property bool AdminEndedItemsOnlySpecified {
    bool get ();
    void set (bool value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public int CategoryID { get; set; }
Public Property CategoryID As Integer
    Get
    Set
public:
property int CategoryID {
    int get ();
    void set (int value);
}


CategoryIDSpecified Property

CategoryIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► CategoryIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CategoryIDSpecified { get; set; }
Public Property CategoryIDSpecified As Boolean
    Get
    Set
public:
property bool CategoryIDSpecified {
    bool get ();
    void set (bool value);
}


EndTimeFrom Property

EndTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► EndTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeFrom { get; set; }
Public Property EndTimeFrom As DateTime
    Get
    Set
public:
property DateTime EndTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


EndTimeFromSpecified Property

EndTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► EndTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeFromSpecified { get; set; }
Public Property EndTimeFromSpecified As Boolean
    Get
    Set
public:
property bool EndTimeFromSpecified {
    bool get ();
    void set (bool value);
}


EndTimeTo Property

EndTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► EndTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeTo { get; set; }
Public Property EndTimeTo As DateTime
    Get
    Set
public:
property DateTime EndTimeTo {
    DateTime get ();
    void set (DateTime value);
}


EndTimeToSpecified Property

EndTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► EndTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeToSpecified { get; set; }
Public Property EndTimeToSpecified As Boolean
    Get
    Set
public:
property bool EndTimeToSpecified {
    bool get ();
    void set (bool value);
}


GetSellerListRequestType Constructor

GetSellerListRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► GetSellerListRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerListRequestType()
Public Sub New
public:
GetSellerListRequestType()


GranularityLevel Property

GranularityLevel Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► GranularityLevel
Declaration Syntax
C# Visual Basic Visual C++
public GranularityLevelCodeType GranularityLevel { get; set; }
Public Property GranularityLevel As GranularityLevelCodeType
    Get
    Set
public:
property GranularityLevelCodeType GranularityLevel {
    GranularityLevelCodeType get ();
    void set (GranularityLevelCodeType value);
}


GranularityLevelSpecified Property

GranularityLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► GranularityLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GranularityLevelSpecified { get; set; }
Public Property GranularityLevelSpecified As Boolean
    Get
    Set
public:
property bool GranularityLevelSpecified {
    bool get ();
    void set (bool value);
}


IncludeVariations Property

IncludeVariations Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► IncludeVariations
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeVariations { get; set; }
Public Property IncludeVariations As Boolean
    Get
    Set
public:
property bool IncludeVariations {
    bool get ();
    void set (bool value);
}


IncludeVariationsSpecified Property

IncludeVariationsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► IncludeVariationsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeVariationsSpecified { get; set; }
Public Property IncludeVariationsSpecified As Boolean
    Get
    Set
public:
property bool IncludeVariationsSpecified {
    bool get ();
    void set (bool value);
}


IncludeWatchCount Property

IncludeWatchCount Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► IncludeWatchCount
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeWatchCount { get; set; }
Public Property IncludeWatchCount As Boolean
    Get
    Set
public:
property bool IncludeWatchCount {
    bool get ();
    void set (bool value);
}


IncludeWatchCountSpecified Property

IncludeWatchCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► IncludeWatchCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeWatchCountSpecified { get; set; }
Public Property IncludeWatchCountSpecified As Boolean
    Get
    Set
public:
property bool IncludeWatchCountSpecified {
    bool get ();
    void set (bool value);
}


MotorsDealerUsers Property

MotorsDealerUsers Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► MotorsDealerUsers
Declaration Syntax
C# Visual Basic Visual C++
public UserIDArrayType MotorsDealerUsers { get; set; }
Public Property MotorsDealerUsers As UserIDArrayType
    Get
    Set
public:
property UserIDArrayType^ MotorsDealerUsers {
    UserIDArrayType^ get ();
    void set (UserIDArrayType^ value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


SKUArray Property

SKUArray Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► SKUArray
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection SKUArray { get; set; }
Public Property SKUArray As StringCollection
    Get
    Set
public:
property StringCollection^ SKUArray {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Sort Property

Sort Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► Sort
Declaration Syntax
C# Visual Basic Visual C++
public int Sort { get; set; }
Public Property Sort As Integer
    Get
    Set
public:
property int Sort {
    int get ();
    void set (int value);
}


SortSpecified Property

SortSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► SortSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SortSpecified { get; set; }
Public Property SortSpecified As Boolean
    Get
    Set
public:
property bool SortSpecified {
    bool get ();
    void set (bool value);
}


StartTimeFrom Property

StartTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► StartTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTimeFrom { get; set; }
Public Property StartTimeFrom As DateTime
    Get
    Set
public:
property DateTime StartTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


StartTimeFromSpecified Property

StartTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► StartTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeFromSpecified { get; set; }
Public Property StartTimeFromSpecified As Boolean
    Get
    Set
public:
property bool StartTimeFromSpecified {
    bool get ();
    void set (bool value);
}


StartTimeTo Property

StartTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► StartTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTimeTo { get; set; }
Public Property StartTimeTo As DateTime
    Get
    Set
public:
property DateTime StartTimeTo {
    DateTime get ();
    void set (DateTime value);
}


StartTimeToSpecified Property

StartTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► StartTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeToSpecified { get; set; }
Public Property StartTimeToSpecified As Boolean
    Get
    Set
public:
property bool StartTimeToSpecified {
    bool get ();
    void set (bool value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListRequestType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetSellerListResponseType Class

GetSellerListResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellerListResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellerListResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellerListResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerListResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | HasMoreItems |
 | HasMoreItemsSpecified |
 | ItemArray |
 | ItemsPerPage |
 | ItemsPerPageSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PageNumber |
 | PageNumberSpecified |
 | PaginationResult |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | ReturnedItemCountActual |
 | ReturnedItemCountActualSpecified |
 | Seller |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellerListResponseType


GetSellerListResponseType Constructor

GetSellerListResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► GetSellerListResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerListResponseType()
Public Sub New
public:
GetSellerListResponseType()


HasMoreItems Property

HasMoreItems Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► HasMoreItems
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreItems { get; set; }
Public Property HasMoreItems As Boolean
    Get
    Set
public:
property bool HasMoreItems {
    bool get ();
    void set (bool value);
}


HasMoreItemsSpecified Property

HasMoreItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► HasMoreItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreItemsSpecified { get; set; }
Public Property HasMoreItemsSpecified As Boolean
    Get
    Set
public:
property bool HasMoreItemsSpecified {
    bool get ();
    void set (bool value);
}


ItemArray Property

ItemArray Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► ItemArray
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection ItemArray { get; set; }
Public Property ItemArray As ItemTypeCollection
    Get
    Set
public:
property ItemTypeCollection^ ItemArray {
    ItemTypeCollection^ get ();
    void set (ItemTypeCollection^ value);
}


ItemsPerPage Property

ItemsPerPage Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► ItemsPerPage
Declaration Syntax
C# Visual Basic Visual C++
public int ItemsPerPage { get; set; }
Public Property ItemsPerPage As Integer
    Get
    Set
public:
property int ItemsPerPage {
    int get ();
    void set (int value);
}


ItemsPerPageSpecified Property

ItemsPerPageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► ItemsPerPageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemsPerPageSpecified { get; set; }
Public Property ItemsPerPageSpecified As Boolean
    Get
    Set
public:
property bool ItemsPerPageSpecified {
    bool get ();
    void set (bool value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► PageNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}


PageNumberSpecified Property

PageNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► PageNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageNumberSpecified { get; set; }
Public Property PageNumberSpecified As Boolean
    Get
    Set
public:
property bool PageNumberSpecified {
    bool get ();
    void set (bool value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


ReturnedItemCountActual Property

ReturnedItemCountActual Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► ReturnedItemCountActual
Declaration Syntax
C# Visual Basic Visual C++
public int ReturnedItemCountActual { get; set; }
Public Property ReturnedItemCountActual As Integer
    Get
    Set
public:
property int ReturnedItemCountActual {
    int get ();
    void set (int value);
}


ReturnedItemCountActualSpecified Property

ReturnedItemCountActualSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► ReturnedItemCountActualSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnedItemCountActualSpecified { get; set; }
Public Property ReturnedItemCountActualSpecified As Boolean
    Get
    Set
public:
property bool ReturnedItemCountActualSpecified {
    bool get ();
    void set (bool value);
}


Seller Property

Seller Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerListResponseType ► Seller
Declaration Syntax
C# Visual Basic Visual C++
public UserType Seller { get; set; }
Public Property Seller As UserType
    Get
    Set
public:
property UserType^ Seller {
    UserType^ get ();
    void set (UserType^ value);
}


GetSellerPaymentsRequestType Class

GetSellerPaymentsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellerPaymentsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellerPaymentsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellerPaymentsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerPaymentsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | PaymentStatus |
 | PaymentStatusSpecified |
 | PaymentTimeFrom |
 | PaymentTimeFromSpecified |
 | PaymentTimeTo |
 | PaymentTimeToSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellerPaymentsRequestType


GetSellerPaymentsRequestType Constructor

GetSellerPaymentsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsRequestType ► GetSellerPaymentsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerPaymentsRequestType()
Public Sub New
public:
GetSellerPaymentsRequestType()


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


PaymentStatus Property

PaymentStatus Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsRequestType ► PaymentStatus
Declaration Syntax
C# Visual Basic Visual C++
public RCSPaymentStatusCodeType PaymentStatus { get; set; }
Public Property PaymentStatus As RCSPaymentStatusCodeType
    Get
    Set
public:
property RCSPaymentStatusCodeType PaymentStatus {
    RCSPaymentStatusCodeType get ();
    void set (RCSPaymentStatusCodeType value);
}


PaymentStatusSpecified Property

PaymentStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsRequestType ► PaymentStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentStatusSpecified { get; set; }
Public Property PaymentStatusSpecified As Boolean
    Get
    Set
public:
property bool PaymentStatusSpecified {
    bool get ();
    void set (bool value);
}


PaymentTimeFrom Property

PaymentTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsRequestType ► PaymentTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PaymentTimeFrom { get; set; }
Public Property PaymentTimeFrom As DateTime
    Get
    Set
public:
property DateTime PaymentTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


PaymentTimeFromSpecified Property

PaymentTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsRequestType ► PaymentTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentTimeFromSpecified { get; set; }
Public Property PaymentTimeFromSpecified As Boolean
    Get
    Set
public:
property bool PaymentTimeFromSpecified {
    bool get ();
    void set (bool value);
}


PaymentTimeTo Property

PaymentTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsRequestType ► PaymentTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PaymentTimeTo { get; set; }
Public Property PaymentTimeTo As DateTime
    Get
    Set
public:
property DateTime PaymentTimeTo {
    DateTime get ();
    void set (DateTime value);
}


PaymentTimeToSpecified Property

PaymentTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsRequestType ► PaymentTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentTimeToSpecified { get; set; }
Public Property PaymentTimeToSpecified As Boolean
    Get
    Set
public:
property bool PaymentTimeToSpecified {
    bool get ();
    void set (bool value);
}


GetSellerPaymentsResponseType Class

GetSellerPaymentsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellerPaymentsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellerPaymentsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellerPaymentsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerPaymentsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | HasMorePayments |
 | HasMorePaymentsSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PageNumber |
 | PageNumberSpecified |
 | PaginationResult |
 | PaymentsPerPage |
 | PaymentsPerPageSpecified |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | ReturnedPaymentCountActual |
 | ReturnedPaymentCountActualSpecified |
 | SellerPayment |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellerPaymentsResponseType


GetSellerPaymentsResponseType Constructor

GetSellerPaymentsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType ► GetSellerPaymentsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerPaymentsResponseType()
Public Sub New
public:
GetSellerPaymentsResponseType()


HasMorePayments Property

HasMorePayments Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType ► HasMorePayments
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMorePayments { get; set; }
Public Property HasMorePayments As Boolean
    Get
    Set
public:
property bool HasMorePayments {
    bool get ();
    void set (bool value);
}


HasMorePaymentsSpecified Property

HasMorePaymentsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType ► HasMorePaymentsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMorePaymentsSpecified { get; set; }
Public Property HasMorePaymentsSpecified As Boolean
    Get
    Set
public:
property bool HasMorePaymentsSpecified {
    bool get ();
    void set (bool value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType ► PageNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}


PageNumberSpecified Property

PageNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType ► PageNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageNumberSpecified { get; set; }
Public Property PageNumberSpecified As Boolean
    Get
    Set
public:
property bool PageNumberSpecified {
    bool get ();
    void set (bool value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


PaymentsPerPage Property

PaymentsPerPage Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType ► PaymentsPerPage
Declaration Syntax
C# Visual Basic Visual C++
public int PaymentsPerPage { get; set; }
Public Property PaymentsPerPage As Integer
    Get
    Set
public:
property int PaymentsPerPage {
    int get ();
    void set (int value);
}


PaymentsPerPageSpecified Property

PaymentsPerPageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType ► PaymentsPerPageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentsPerPageSpecified { get; set; }
Public Property PaymentsPerPageSpecified As Boolean
    Get
    Set
public:
property bool PaymentsPerPageSpecified {
    bool get ();
    void set (bool value);
}


ReturnedPaymentCountActual Property

ReturnedPaymentCountActual Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType ► ReturnedPaymentCountActual
Declaration Syntax
C# Visual Basic Visual C++
public int ReturnedPaymentCountActual { get; set; }
Public Property ReturnedPaymentCountActual As Integer
    Get
    Set
public:
property int ReturnedPaymentCountActual {
    int get ();
    void set (int value);
}


ReturnedPaymentCountActualSpecified Property

ReturnedPaymentCountActualSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType ► ReturnedPaymentCountActualSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnedPaymentCountActualSpecified { get; set; }
Public Property ReturnedPaymentCountActualSpecified As Boolean
    Get
    Set
public:
property bool ReturnedPaymentCountActualSpecified {
    bool get ();
    void set (bool value);
}


SellerPayment Property

SellerPayment Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerPaymentsResponseType ► SellerPayment
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentTypeCollection SellerPayment { get; set; }
Public Property SellerPayment As SellerPaymentTypeCollection
    Get
    Set
public:
property SellerPaymentTypeCollection^ SellerPayment {
    SellerPaymentTypeCollection^ get ();
    void set (SellerPaymentTypeCollection^ value);
}


GetSellerTransactionsRequestType Class

GetSellerTransactionsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellerTransactionsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellerTransactionsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellerTransactionsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerTransactionsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeCodiceFiscale |
 | IncludeCodiceFiscaleSpecified |
 | IncludeContainingOrder |
 | IncludeContainingOrderSpecified |
 | IncludeFinalValueFee |
 | IncludeFinalValueFeeSpecified |
 | InventoryTrackingMethod |
 | InventoryTrackingMethodSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | ModTimeFrom |
 | ModTimeFromSpecified |
 | ModTimeTo |
 | ModTimeToSpecified |
 | NumberOfDays |
 | NumberOfDaysSpecified |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | Platform |
 | PlatformSpecified |
 | SKUArray |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellerTransactionsRequestType


GetSellerTransactionsRequestType Constructor

GetSellerTransactionsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► GetSellerTransactionsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerTransactionsRequestType()
Public Sub New
public:
GetSellerTransactionsRequestType()


IncludeCodiceFiscale Property

IncludeCodiceFiscale Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► IncludeCodiceFiscale
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeCodiceFiscale { get; set; }
Public Property IncludeCodiceFiscale As Boolean
    Get
    Set
public:
property bool IncludeCodiceFiscale {
    bool get ();
    void set (bool value);
}


IncludeCodiceFiscaleSpecified Property

IncludeCodiceFiscaleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► IncludeCodiceFiscaleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeCodiceFiscaleSpecified { get; set; }
Public Property IncludeCodiceFiscaleSpecified As Boolean
    Get
    Set
public:
property bool IncludeCodiceFiscaleSpecified {
    bool get ();
    void set (bool value);
}


IncludeContainingOrder Property

IncludeContainingOrder Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► IncludeContainingOrder
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeContainingOrder { get; set; }
Public Property IncludeContainingOrder As Boolean
    Get
    Set
public:
property bool IncludeContainingOrder {
    bool get ();
    void set (bool value);
}


IncludeContainingOrderSpecified Property

IncludeContainingOrderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► IncludeContainingOrderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeContainingOrderSpecified { get; set; }
Public Property IncludeContainingOrderSpecified As Boolean
    Get
    Set
public:
property bool IncludeContainingOrderSpecified {
    bool get ();
    void set (bool value);
}


IncludeFinalValueFee Property

IncludeFinalValueFee Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► IncludeFinalValueFee
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFee { get; set; }
Public Property IncludeFinalValueFee As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFee {
    bool get ();
    void set (bool value);
}


IncludeFinalValueFeeSpecified Property

IncludeFinalValueFeeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► IncludeFinalValueFeeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFinalValueFeeSpecified { get; set; }
Public Property IncludeFinalValueFeeSpecified As Boolean
    Get
    Set
public:
property bool IncludeFinalValueFeeSpecified {
    bool get ();
    void set (bool value);
}


InventoryTrackingMethod Property

InventoryTrackingMethod Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► InventoryTrackingMethod
Declaration Syntax
C# Visual Basic Visual C++
public InventoryTrackingMethodCodeType InventoryTrackingMethod { get; set; }
Public Property InventoryTrackingMethod As InventoryTrackingMethodCodeType
    Get
    Set
public:
property InventoryTrackingMethodCodeType InventoryTrackingMethod {
    InventoryTrackingMethodCodeType get ();
    void set (InventoryTrackingMethodCodeType value);
}


InventoryTrackingMethodSpecified Property

InventoryTrackingMethodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► InventoryTrackingMethodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InventoryTrackingMethodSpecified { get; set; }
Public Property InventoryTrackingMethodSpecified As Boolean
    Get
    Set
public:
property bool InventoryTrackingMethodSpecified {
    bool get ();
    void set (bool value);
}


ModTimeFrom Property

ModTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► ModTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeFrom { get; set; }
Public Property ModTimeFrom As DateTime
    Get
    Set
public:
property DateTime ModTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


ModTimeFromSpecified Property

ModTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► ModTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModTimeFromSpecified { get; set; }
Public Property ModTimeFromSpecified As Boolean
    Get
    Set
public:
property bool ModTimeFromSpecified {
    bool get ();
    void set (bool value);
}


ModTimeTo Property

ModTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► ModTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeTo { get; set; }
Public Property ModTimeTo As DateTime
    Get
    Set
public:
property DateTime ModTimeTo {
    DateTime get ();
    void set (DateTime value);
}


ModTimeToSpecified Property

ModTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► ModTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModTimeToSpecified { get; set; }
Public Property ModTimeToSpecified As Boolean
    Get
    Set
public:
property bool ModTimeToSpecified {
    bool get ();
    void set (bool value);
}


NumberOfDays Property

NumberOfDays Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► NumberOfDays
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfDays { get; set; }
Public Property NumberOfDays As Integer
    Get
    Set
public:
property int NumberOfDays {
    int get ();
    void set (int value);
}


NumberOfDaysSpecified Property

NumberOfDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► NumberOfDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NumberOfDaysSpecified { get; set; }
Public Property NumberOfDaysSpecified As Boolean
    Get
    Set
public:
property bool NumberOfDaysSpecified {
    bool get ();
    void set (bool value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


Platform Property

Platform Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► Platform
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeType Platform { get; set; }
Public Property Platform As TransactionPlatformCodeType
    Get
    Set
public:
property TransactionPlatformCodeType Platform {
    TransactionPlatformCodeType get ();
    void set (TransactionPlatformCodeType value);
}


PlatformSpecified Property

PlatformSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► PlatformSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PlatformSpecified { get; set; }
Public Property PlatformSpecified As Boolean
    Get
    Set
public:
property bool PlatformSpecified {
    bool get ();
    void set (bool value);
}


SKUArray Property

SKUArray Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsRequestType ► SKUArray
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection SKUArray { get; set; }
Public Property SKUArray As StringCollection
    Get
    Set
public:
property StringCollection^ SKUArray {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


GetSellerTransactionsResponseType Class

GetSellerTransactionsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellerTransactionsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellerTransactionsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellerTransactionsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellerTransactionsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | HasMoreTransactions |
 | HasMoreTransactionsSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PageNumber |
 | PageNumberSpecified |
 | PaginationResult |
 | PayPalPreferred |
 | PayPalPreferredSpecified |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | ReturnedTransactionCountActual |
 | ReturnedTransactionCountActualSpecified |
 | Seller |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionArray |
 | TransactionsPerPage |
 | TransactionsPerPageSpecified |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellerTransactionsResponseType


GetSellerTransactionsResponseType Constructor

GetSellerTransactionsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► GetSellerTransactionsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellerTransactionsResponseType()
Public Sub New
public:
GetSellerTransactionsResponseType()


HasMoreTransactions Property

HasMoreTransactions Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► HasMoreTransactions
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreTransactions { get; set; }
Public Property HasMoreTransactions As Boolean
    Get
    Set
public:
property bool HasMoreTransactions {
    bool get ();
    void set (bool value);
}


HasMoreTransactionsSpecified Property

HasMoreTransactionsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► HasMoreTransactionsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreTransactionsSpecified { get; set; }
Public Property HasMoreTransactionsSpecified As Boolean
    Get
    Set
public:
property bool HasMoreTransactionsSpecified {
    bool get ();
    void set (bool value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► PageNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}


PageNumberSpecified Property

PageNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► PageNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageNumberSpecified { get; set; }
Public Property PageNumberSpecified As Boolean
    Get
    Set
public:
property bool PageNumberSpecified {
    bool get ();
    void set (bool value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


PayPalPreferred Property

PayPalPreferred Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► PayPalPreferred
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalPreferred { get; set; }
Public Property PayPalPreferred As Boolean
    Get
    Set
public:
property bool PayPalPreferred {
    bool get ();
    void set (bool value);
}


PayPalPreferredSpecified Property

PayPalPreferredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► PayPalPreferredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalPreferredSpecified { get; set; }
Public Property PayPalPreferredSpecified As Boolean
    Get
    Set
public:
property bool PayPalPreferredSpecified {
    bool get ();
    void set (bool value);
}


ReturnedTransactionCountActual Property

ReturnedTransactionCountActual Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► ReturnedTransactionCountActual
Declaration Syntax
C# Visual Basic Visual C++
public int ReturnedTransactionCountActual { get; set; }
Public Property ReturnedTransactionCountActual As Integer
    Get
    Set
public:
property int ReturnedTransactionCountActual {
    int get ();
    void set (int value);
}


ReturnedTransactionCountActualSpecified Property

ReturnedTransactionCountActualSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► ReturnedTransactionCountActualSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnedTransactionCountActualSpecified { get; set; }
Public Property ReturnedTransactionCountActualSpecified As Boolean
    Get
    Set
public:
property bool ReturnedTransactionCountActualSpecified {
    bool get ();
    void set (bool value);
}


Seller Property

Seller Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► Seller
Declaration Syntax
C# Visual Basic Visual C++
public UserType Seller { get; set; }
Public Property Seller As UserType
    Get
    Set
public:
property UserType^ Seller {
    UserType^ get ();
    void set (UserType^ value);
}


TransactionArray Property

TransactionArray Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► TransactionArray
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection TransactionArray { get; set; }
Public Property TransactionArray As TransactionTypeCollection
    Get
    Set
public:
property TransactionTypeCollection^ TransactionArray {
    TransactionTypeCollection^ get ();
    void set (TransactionTypeCollection^ value);
}


TransactionsPerPage Property

TransactionsPerPage Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► TransactionsPerPage
Declaration Syntax
C# Visual Basic Visual C++
public int TransactionsPerPage { get; set; }
Public Property TransactionsPerPage As Integer
    Get
    Set
public:
property int TransactionsPerPage {
    int get ();
    void set (int value);
}


TransactionsPerPageSpecified Property

TransactionsPerPageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellerTransactionsResponseType ► TransactionsPerPageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TransactionsPerPageSpecified { get; set; }
Public Property TransactionsPerPageSpecified As Boolean
    Get
    Set
public:
property bool TransactionsPerPageSpecified {
    bool get ();
    void set (bool value);
}


GetSellingManagerAlertsRequestType Class

GetSellingManagerAlertsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerAlertsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerAlertsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerAlertsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerAlertsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerAlertsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellingManagerAlertsRequestType


GetSellingManagerAlertsRequestType Constructor

GetSellingManagerAlertsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerAlertsRequestType ► GetSellingManagerAlertsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerAlertsRequestType()
Public Sub New
public:
GetSellingManagerAlertsRequestType()


GetSellingManagerAlertsResponseType Class

GetSellingManagerAlertsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerAlertsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerAlertsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerAlertsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerAlertsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerAlertsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Alert |
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellingManagerAlertsResponseType


Alert Property

Alert Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerAlertsResponseType ► Alert
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAlertTypeCollection Alert { get; set; }
Public Property Alert As SellingManagerAlertTypeCollection
    Get
    Set
public:
property SellingManagerAlertTypeCollection^ Alert {
    SellingManagerAlertTypeCollection^ get ();
    void set (SellingManagerAlertTypeCollection^ value);
}


GetSellingManagerAlertsResponseType Constructor

GetSellingManagerAlertsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerAlertsResponseType ► GetSellingManagerAlertsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerAlertsResponseType()
Public Sub New
public:
GetSellingManagerAlertsResponseType()


GetSellingManagerEmailLogRequestType Class

GetSellingManagerEmailLogRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerEmailLogRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerEmailLogRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerEmailLogRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerEmailLogRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerEmailLogRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EmailDateRange |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderID |
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | TransactionIDSpecified |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellingManagerEmailLogRequestType


EmailDateRange Property

EmailDateRange Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerEmailLogRequestType ► EmailDateRange
Declaration Syntax
C# Visual Basic Visual C++
public TimeRangeType EmailDateRange { get; set; }
Public Property EmailDateRange As TimeRangeType
    Get
    Set
public:
property TimeRangeType^ EmailDateRange {
    TimeRangeType^ get ();
    void set (TimeRangeType^ value);
}


GetSellingManagerEmailLogRequestType Constructor

GetSellingManagerEmailLogRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerEmailLogRequestType ► GetSellingManagerEmailLogRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerEmailLogRequestType()
Public Sub New
public:
GetSellingManagerEmailLogRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerEmailLogRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerEmailLogRequestType ► OrderID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerEmailLogRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerEmailLogRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public long TransactionID { get; set; }
Public Property TransactionID As Long
    Get
    Set
public:
property long long TransactionID {
    long long get ();
    void set (long long value);
}


TransactionIDSpecified Property

TransactionIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerEmailLogRequestType ► TransactionIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TransactionIDSpecified { get; set; }
Public Property TransactionIDSpecified As Boolean
    Get
    Set
public:
property bool TransactionIDSpecified {
    bool get ();
    void set (bool value);
}


GetSellingManagerEmailLogResponseType Class

GetSellingManagerEmailLogResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerEmailLogResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerEmailLogResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerEmailLogResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerEmailLogResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerEmailLogResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EmailLog |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellingManagerEmailLogResponseType


EmailLog Property

EmailLog Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerEmailLogResponseType ► EmailLog
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailLogTypeCollection EmailLog { get; set; }
Public Property EmailLog As SellingManagerEmailLogTypeCollection
    Get
    Set
public:
property SellingManagerEmailLogTypeCollection^ EmailLog {
    SellingManagerEmailLogTypeCollection^ get ();
    void set (SellingManagerEmailLogTypeCollection^ value);
}


GetSellingManagerEmailLogResponseType Constructor

GetSellingManagerEmailLogResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerEmailLogResponseType ► GetSellingManagerEmailLogResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerEmailLogResponseType()
Public Sub New
public:
GetSellingManagerEmailLogResponseType()


GetSellingManagerInventoryFolderRequestType Class

GetSellingManagerInventoryFolderRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryFolderRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerInventoryFolderRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerInventoryFolderRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerInventoryFolderRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerInventoryFolderRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID |
 | FolderIDSpecified |
 | FullRecursion |
 | FullRecursionSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MaxDepth |
 | MaxDepthSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellingManagerInventoryFolderRequestType


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryFolderRequestType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryFolderRequestType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


FullRecursion Property

FullRecursion Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryFolderRequestType ► FullRecursion
Declaration Syntax
C# Visual Basic Visual C++
public bool FullRecursion { get; set; }
Public Property FullRecursion As Boolean
    Get
    Set
public:
property bool FullRecursion {
    bool get ();
    void set (bool value);
}


FullRecursionSpecified Property

FullRecursionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryFolderRequestType ► FullRecursionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FullRecursionSpecified { get; set; }
Public Property FullRecursionSpecified As Boolean
    Get
    Set
public:
property bool FullRecursionSpecified {
    bool get ();
    void set (bool value);
}


GetSellingManagerInventoryFolderRequestType Constructor

GetSellingManagerInventoryFolderRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryFolderRequestType ► GetSellingManagerInventoryFolderRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryFolderRequestType()
Public Sub New
public:
GetSellingManagerInventoryFolderRequestType()


MaxDepth Property

MaxDepth Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryFolderRequestType ► MaxDepth
Declaration Syntax
C# Visual Basic Visual C++
public int MaxDepth { get; set; }
Public Property MaxDepth As Integer
    Get
    Set
public:
property int MaxDepth {
    int get ();
    void set (int value);
}


MaxDepthSpecified Property

MaxDepthSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryFolderRequestType ► MaxDepthSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxDepthSpecified { get; set; }
Public Property MaxDepthSpecified As Boolean
    Get
    Set
public:
property bool MaxDepthSpecified {
    bool get ();
    void set (bool value);
}


GetSellingManagerInventoryFolderResponseType Class

GetSellingManagerInventoryFolderResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryFolderResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerInventoryFolderResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerInventoryFolderResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerInventoryFolderResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerInventoryFolderResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | Folder |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellingManagerInventoryFolderResponseType


Folder Property

Folder Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryFolderResponseType ► Folder
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType Folder { get; set; }
Public Property Folder As SellingManagerFolderDetailsType
    Get
    Set
public:
property SellingManagerFolderDetailsType^ Folder {
    SellingManagerFolderDetailsType^ get ();
    void set (SellingManagerFolderDetailsType^ value);
}


GetSellingManagerInventoryFolderResponseType Constructor

GetSellingManagerInventoryFolderResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryFolderResponseType ► GetSellingManagerInventoryFolderResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryFolderResponseType()
Public Sub New
public:
GetSellingManagerInventoryFolderResponseType()


GetSellingManagerInventoryRequestType Class

GetSellingManagerInventoryRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerInventoryRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerInventoryRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerInventoryRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerInventoryRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Filter |
 | Finalize()()()() | (Inherited from Object.)
 | FolderID |
 | FolderIDSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | Search |
 | Sort |
 | SortOrder |
 | SortOrderSpecified |
 | SortSpecified |
 | StoreCategoryID |
 | StoreCategoryIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellingManagerInventoryRequestType


Filter Property

Filter Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► Filter
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerInventoryPropertyTypeCodeTypeCollection Filter { get; set; }
Public Property Filter As SellingManagerInventoryPropertyTypeCodeTypeCollection
    Get
    Set
public:
property SellingManagerInventoryPropertyTypeCodeTypeCollection^ Filter {
    SellingManagerInventoryPropertyTypeCodeTypeCollection^ get ();
    void set (SellingManagerInventoryPropertyTypeCodeTypeCollection^ value);
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


GetSellingManagerInventoryRequestType Constructor

GetSellingManagerInventoryRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► GetSellingManagerInventoryRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryRequestType()
Public Sub New
public:
GetSellingManagerInventoryRequestType()


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


Search Property

Search Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► Search
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSearchType Search { get; set; }
Public Property Search As SellingManagerSearchType
    Get
    Set
public:
property SellingManagerSearchType^ Search {
    SellingManagerSearchType^ get ();
    void set (SellingManagerSearchType^ value);
}


Sort Property

Sort Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► Sort
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductSortCodeType Sort { get; set; }
Public Property Sort As SellingManagerProductSortCodeType
    Get
    Set
public:
property SellingManagerProductSortCodeType Sort {
    SellingManagerProductSortCodeType get ();
    void set (SellingManagerProductSortCodeType value);
}


SortOrder Property

SortOrder Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► SortOrder
Declaration Syntax
C# Visual Basic Visual C++
public SortOrderCodeType SortOrder { get; set; }
Public Property SortOrder As SortOrderCodeType
    Get
    Set
public:
property SortOrderCodeType SortOrder {
    SortOrderCodeType get ();
    void set (SortOrderCodeType value);
}


SortOrderSpecified Property

SortOrderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► SortOrderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SortOrderSpecified { get; set; }
Public Property SortOrderSpecified As Boolean
    Get
    Set
public:
property bool SortOrderSpecified {
    bool get ();
    void set (bool value);
}


SortSpecified Property

SortSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► SortSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SortSpecified { get; set; }
Public Property SortSpecified As Boolean
    Get
    Set
public:
property bool SortSpecified {
    bool get ();
    void set (bool value);
}


StoreCategoryID Property

StoreCategoryID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► StoreCategoryID
Declaration Syntax
C# Visual Basic Visual C++
public long StoreCategoryID { get; set; }
Public Property StoreCategoryID As Long
    Get
    Set
public:
property long long StoreCategoryID {
    long long get ();
    void set (long long value);
}


StoreCategoryIDSpecified Property

StoreCategoryIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryRequestType ► StoreCategoryIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreCategoryIDSpecified { get; set; }
Public Property StoreCategoryIDSpecified As Boolean
    Get
    Set
public:
property bool StoreCategoryIDSpecified {
    bool get ();
    void set (bool value);
}


GetSellingManagerInventoryResponseType Class

GetSellingManagerInventoryResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerInventoryResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerInventoryResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerInventoryResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerInventoryResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | InventoryCountLastCalculatedDate |
 | InventoryCountLastCalculatedDateSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PaginationResult |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SellingManagerProduct |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellingManagerInventoryResponseType


GetSellingManagerInventoryResponseType Constructor

GetSellingManagerInventoryResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryResponseType ► GetSellingManagerInventoryResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerInventoryResponseType()
Public Sub New
public:
GetSellingManagerInventoryResponseType()


InventoryCountLastCalculatedDate Property

InventoryCountLastCalculatedDate Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryResponseType ► InventoryCountLastCalculatedDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime InventoryCountLastCalculatedDate { get; set; }
Public Property InventoryCountLastCalculatedDate As DateTime
    Get
    Set
public:
property DateTime InventoryCountLastCalculatedDate {
    DateTime get ();
    void set (DateTime value);
}


InventoryCountLastCalculatedDateSpecified Property

InventoryCountLastCalculatedDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryResponseType ► InventoryCountLastCalculatedDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InventoryCountLastCalculatedDateSpecified { get; set; }
Public Property InventoryCountLastCalculatedDateSpecified As Boolean
    Get
    Set
public:
property bool InventoryCountLastCalculatedDateSpecified {
    bool get ();
    void set (bool value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


SellingManagerProduct Property

SellingManagerProduct Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerInventoryResponseType ► SellingManagerProduct
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductTypeCollection SellingManagerProduct { get; set; }
Public Property SellingManagerProduct As SellingManagerProductTypeCollection
    Get
    Set
public:
property SellingManagerProductTypeCollection^ SellingManagerProduct {
    SellingManagerProductTypeCollection^ get ();
    void set (SellingManagerProductTypeCollection^ value);
}


GetSellingManagerItemAutomationRuleRequestType Class

GetSellingManagerItemAutomationRuleRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerItemAutomationRuleRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerItemAutomationRuleRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerItemAutomationRuleRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerItemAutomationRuleRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerItemAutomationRuleRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellingManagerItemAutomationRuleRequestType


GetSellingManagerItemAutomationRuleRequestType Constructor

GetSellingManagerItemAutomationRuleRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerItemAutomationRuleRequestType ► GetSellingManagerItemAutomationRuleRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerItemAutomationRuleRequestType()
Public Sub New
public:
GetSellingManagerItemAutomationRuleRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerItemAutomationRuleRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


GetSellingManagerItemAutomationRuleResponseType Class

GetSellingManagerItemAutomationRuleResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerItemAutomationRuleResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerItemAutomationRuleResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerItemAutomationRuleResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerItemAutomationRuleResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerItemAutomationRuleResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | AutomatedListingRule |
 | AutomatedRelistingRule |
 | AutomatedSecondChanceOfferRule |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellingManagerItemAutomationRuleResponseType


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerItemAutomationRuleResponseType ► AutomatedListingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; set; }
Public Property AutomatedListingRule As SellingManagerAutoListType
    Get
    Set
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
    void set (SellingManagerAutoListType^ value);
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerItemAutomationRuleResponseType ► AutomatedRelistingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; set; }
Public Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
    Set
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
    void set (SellingManagerAutoRelistType^ value);
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerItemAutomationRuleResponseType ► AutomatedSecondChanceOfferRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; set; }
Public Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
    Set
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
    void set (SellingManagerAutoSecondChanceOfferType^ value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerItemAutomationRuleResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


GetSellingManagerItemAutomationRuleResponseType Constructor

GetSellingManagerItemAutomationRuleResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerItemAutomationRuleResponseType ► GetSellingManagerItemAutomationRuleResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerItemAutomationRuleResponseType()
Public Sub New
public:
GetSellingManagerItemAutomationRuleResponseType()


GetSellingManagerSaleRecordRequestType Class

GetSellingManagerSaleRecordRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSaleRecordRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerSaleRecordRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerSaleRecordRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerSaleRecordRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerSaleRecordRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderID |
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellingManagerSaleRecordRequestType


GetSellingManagerSaleRecordRequestType Constructor

GetSellingManagerSaleRecordRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSaleRecordRequestType ► GetSellingManagerSaleRecordRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSaleRecordRequestType()
Public Sub New
public:
GetSellingManagerSaleRecordRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSaleRecordRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSaleRecordRequestType ► OrderID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSaleRecordRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSaleRecordRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


GetSellingManagerSaleRecordResponseType Class

GetSellingManagerSaleRecordResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSaleRecordResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerSaleRecordResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerSaleRecordResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerSaleRecordResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerSaleRecordResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SellingManagerSoldOrder |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellingManagerSaleRecordResponseType


GetSellingManagerSaleRecordResponseType Constructor

GetSellingManagerSaleRecordResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSaleRecordResponseType ► GetSellingManagerSaleRecordResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSaleRecordResponseType()
Public Sub New
public:
GetSellingManagerSaleRecordResponseType()


SellingManagerSoldOrder Property

SellingManagerSoldOrder Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSaleRecordResponseType ► SellingManagerSoldOrder
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderType SellingManagerSoldOrder { get; set; }
Public Property SellingManagerSoldOrder As SellingManagerSoldOrderType
    Get
    Set
public:
property SellingManagerSoldOrderType^ SellingManagerSoldOrder {
    SellingManagerSoldOrderType^ get ();
    void set (SellingManagerSoldOrderType^ value);
}


GetSellingManagerSoldListingsRequestType Class

GetSellingManagerSoldListingsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerSoldListingsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerSoldListingsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerSoldListingsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerSoldListingsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | Archived |
 | ArchivedSpecified |
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Filter |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | SaleDateRange |
 | Search |
 | Sort |
 | SortOrder |
 | SortOrderSpecified |
 | SortSpecified |
 | StoreCategoryID |
 | StoreCategoryIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellingManagerSoldListingsRequestType


Archived Property

Archived Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► Archived
Declaration Syntax
C# Visual Basic Visual C++
public bool Archived { get; set; }
Public Property Archived As Boolean
    Get
    Set
public:
property bool Archived {
    bool get ();
    void set (bool value);
}


ArchivedSpecified Property

ArchivedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► ArchivedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ArchivedSpecified { get; set; }
Public Property ArchivedSpecified As Boolean
    Get
    Set
public:
property bool ArchivedSpecified {
    bool get ();
    void set (bool value);
}


Filter Property

Filter Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► Filter
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldListingsPropertyTypeCodeTypeCollection Filter { get; set; }
Public Property Filter As SellingManagerSoldListingsPropertyTypeCodeTypeCollection
    Get
    Set
public:
property SellingManagerSoldListingsPropertyTypeCodeTypeCollection^ Filter {
    SellingManagerSoldListingsPropertyTypeCodeTypeCollection^ get ();
    void set (SellingManagerSoldListingsPropertyTypeCodeTypeCollection^ value);
}


GetSellingManagerSoldListingsRequestType Constructor

GetSellingManagerSoldListingsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► GetSellingManagerSoldListingsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSoldListingsRequestType()
Public Sub New
public:
GetSellingManagerSoldListingsRequestType()


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


SaleDateRange Property

SaleDateRange Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► SaleDateRange
Declaration Syntax
C# Visual Basic Visual C++
public TimeRangeType SaleDateRange { get; set; }
Public Property SaleDateRange As TimeRangeType
    Get
    Set
public:
property TimeRangeType^ SaleDateRange {
    TimeRangeType^ get ();
    void set (TimeRangeType^ value);
}


Search Property

Search Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► Search
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSearchType Search { get; set; }
Public Property Search As SellingManagerSearchType
    Get
    Set
public:
property SellingManagerSearchType^ Search {
    SellingManagerSearchType^ get ();
    void set (SellingManagerSearchType^ value);
}


Sort Property

Sort Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► Sort
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldListingsSortTypeCodeType Sort { get; set; }
Public Property Sort As SellingManagerSoldListingsSortTypeCodeType
    Get
    Set
public:
property SellingManagerSoldListingsSortTypeCodeType Sort {
    SellingManagerSoldListingsSortTypeCodeType get ();
    void set (SellingManagerSoldListingsSortTypeCodeType value);
}


SortOrder Property

SortOrder Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► SortOrder
Declaration Syntax
C# Visual Basic Visual C++
public SortOrderCodeType SortOrder { get; set; }
Public Property SortOrder As SortOrderCodeType
    Get
    Set
public:
property SortOrderCodeType SortOrder {
    SortOrderCodeType get ();
    void set (SortOrderCodeType value);
}


SortOrderSpecified Property

SortOrderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► SortOrderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SortOrderSpecified { get; set; }
Public Property SortOrderSpecified As Boolean
    Get
    Set
public:
property bool SortOrderSpecified {
    bool get ();
    void set (bool value);
}


SortSpecified Property

SortSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► SortSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SortSpecified { get; set; }
Public Property SortSpecified As Boolean
    Get
    Set
public:
property bool SortSpecified {
    bool get ();
    void set (bool value);
}


StoreCategoryID Property

StoreCategoryID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► StoreCategoryID
Declaration Syntax
C# Visual Basic Visual C++
public long StoreCategoryID { get; set; }
Public Property StoreCategoryID As Long
    Get
    Set
public:
property long long StoreCategoryID {
    long long get ();
    void set (long long value);
}


StoreCategoryIDSpecified Property

StoreCategoryIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsRequestType ► StoreCategoryIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreCategoryIDSpecified { get; set; }
Public Property StoreCategoryIDSpecified As Boolean
    Get
    Set
public:
property bool StoreCategoryIDSpecified {
    bool get ();
    void set (bool value);
}


GetSellingManagerSoldListingsResponseType Class

GetSellingManagerSoldListingsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerSoldListingsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerSoldListingsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerSoldListingsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerSoldListingsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PaginationResult |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SaleRecord |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellingManagerSoldListingsResponseType


GetSellingManagerSoldListingsResponseType Constructor

GetSellingManagerSoldListingsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsResponseType ► GetSellingManagerSoldListingsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerSoldListingsResponseType()
Public Sub New
public:
GetSellingManagerSoldListingsResponseType()


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


SaleRecord Property

SaleRecord Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerSoldListingsResponseType ► SaleRecord
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderTypeCollection SaleRecord { get; set; }
Public Property SaleRecord As SellingManagerSoldOrderTypeCollection
    Get
    Set
public:
property SellingManagerSoldOrderTypeCollection^ SaleRecord {
    SellingManagerSoldOrderTypeCollection^ get ();
    void set (SellingManagerSoldOrderTypeCollection^ value);
}


GetSellingManagerTemplateAutomationRuleRequestType Class

GetSellingManagerTemplateAutomationRuleRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplateAutomationRuleRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerTemplateAutomationRuleRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerTemplateAutomationRuleRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerTemplateAutomationRuleRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerTemplateAutomationRuleRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SaleTemplateID |
 | SaleTemplateIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellingManagerTemplateAutomationRuleRequestType


GetSellingManagerTemplateAutomationRuleRequestType Constructor

GetSellingManagerTemplateAutomationRuleRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplateAutomationRuleRequestType ► GetSellingManagerTemplateAutomationRuleRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplateAutomationRuleRequestType()
Public Sub New
public:
GetSellingManagerTemplateAutomationRuleRequestType()


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplateAutomationRuleRequestType ► SaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


SaleTemplateIDSpecified Property

SaleTemplateIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplateAutomationRuleRequestType ► SaleTemplateIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SaleTemplateIDSpecified { get; set; }
Public Property SaleTemplateIDSpecified As Boolean
    Get
    Set
public:
property bool SaleTemplateIDSpecified {
    bool get ();
    void set (bool value);
}


GetSellingManagerTemplateAutomationRuleResponseType Class

GetSellingManagerTemplateAutomationRuleResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplateAutomationRuleResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerTemplateAutomationRuleResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerTemplateAutomationRuleResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerTemplateAutomationRuleResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerTemplateAutomationRuleResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | AutomatedListingRule |
 | AutomatedRelistingRule |
 | AutomatedSecondChanceOfferRule |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellingManagerTemplateAutomationRuleResponseType


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplateAutomationRuleResponseType ► AutomatedListingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; set; }
Public Property AutomatedListingRule As SellingManagerAutoListType
    Get
    Set
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
    void set (SellingManagerAutoListType^ value);
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplateAutomationRuleResponseType ► AutomatedRelistingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; set; }
Public Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
    Set
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
    void set (SellingManagerAutoRelistType^ value);
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplateAutomationRuleResponseType ► AutomatedSecondChanceOfferRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; set; }
Public Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
    Set
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
    void set (SellingManagerAutoSecondChanceOfferType^ value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplateAutomationRuleResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


GetSellingManagerTemplateAutomationRuleResponseType Constructor

GetSellingManagerTemplateAutomationRuleResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplateAutomationRuleResponseType ► GetSellingManagerTemplateAutomationRuleResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplateAutomationRuleResponseType()
Public Sub New
public:
GetSellingManagerTemplateAutomationRuleResponseType()


GetSellingManagerTemplatesRequestType Class

GetSellingManagerTemplatesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplatesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerTemplatesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerTemplatesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerTemplatesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerTemplatesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SaleTemplateID |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSellingManagerTemplatesRequestType


GetSellingManagerTemplatesRequestType Constructor

GetSellingManagerTemplatesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplatesRequestType ► GetSellingManagerTemplatesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplatesRequestType()
Public Sub New
public:
GetSellingManagerTemplatesRequestType()


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplatesRequestType ► SaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public Int64Collection SaleTemplateID { get; set; }
Public Property SaleTemplateID As Int64Collection
    Get
    Set
public:
property Int64Collection^ SaleTemplateID {
    Int64Collection^ get ();
    void set (Int64Collection^ value);
}


GetSellingManagerTemplatesResponseType Class

GetSellingManagerTemplatesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplatesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSellingManagerTemplatesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSellingManagerTemplatesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSellingManagerTemplatesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSellingManagerTemplatesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SellingManagerTemplateDetailsArray |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSellingManagerTemplatesResponseType


GetSellingManagerTemplatesResponseType Constructor

GetSellingManagerTemplatesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplatesResponseType ► GetSellingManagerTemplatesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSellingManagerTemplatesResponseType()
Public Sub New
public:
GetSellingManagerTemplatesResponseType()


SellingManagerTemplateDetailsArray Property

SellingManagerTemplateDetailsArray Property
Namespaces ► eBay.Service.Core.Soap ► GetSellingManagerTemplatesResponseType ► SellingManagerTemplateDetailsArray
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerTemplateDetailsTypeCollection SellingManagerTemplateDetailsArray { get; set; }
Public Property SellingManagerTemplateDetailsArray As SellingManagerTemplateDetailsTypeCollection
    Get
    Set
public:
property SellingManagerTemplateDetailsTypeCollection^ SellingManagerTemplateDetailsArray {
    SellingManagerTemplateDetailsTypeCollection^ get ();
    void set (SellingManagerTemplateDetailsTypeCollection^ value);
}


GetSessionIDRequestType Class

GetSessionIDRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSessionIDRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSessionIDRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSessionIDRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSessionIDRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSessionIDRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | RuName |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSessionIDRequestType


GetSessionIDRequestType Constructor

GetSessionIDRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSessionIDRequestType ► GetSessionIDRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSessionIDRequestType()
Public Sub New
public:
GetSessionIDRequestType()


RuName Property

RuName Property
Namespaces ► eBay.Service.Core.Soap ► GetSessionIDRequestType ► RuName
Declaration Syntax
C# Visual Basic Visual C++
public string RuName { get; set; }
Public Property RuName As String
    Get
    Set
public:
property String^ RuName {
    String^ get ();
    void set (String^ value);
}


GetSessionIDResponseType Class

GetSessionIDResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSessionIDResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSessionIDResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSessionIDResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSessionIDResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSessionIDResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SessionID |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSessionIDResponseType


GetSessionIDResponseType Constructor

GetSessionIDResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSessionIDResponseType ► GetSessionIDResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSessionIDResponseType()
Public Sub New
public:
GetSessionIDResponseType()


SessionID Property

SessionID Property
Namespaces ► eBay.Service.Core.Soap ► GetSessionIDResponseType ► SessionID
Declaration Syntax
C# Visual Basic Visual C++
public string SessionID { get; set; }
Public Property SessionID As String
    Get
    Set
public:
property String^ SessionID {
    String^ get ();
    void set (String^ value);
}


GetShippingDiscountProfilesRequestType Class

GetShippingDiscountProfilesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetShippingDiscountProfilesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetShippingDiscountProfilesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetShippingDiscountProfilesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetShippingDiscountProfilesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetShippingDiscountProfilesRequestType


GetShippingDiscountProfilesRequestType Constructor

GetShippingDiscountProfilesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesRequestType ► GetShippingDiscountProfilesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetShippingDiscountProfilesRequestType()
Public Sub New
public:
GetShippingDiscountProfilesRequestType()


GetShippingDiscountProfilesResponseType Class

GetShippingDiscountProfilesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetShippingDiscountProfilesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetShippingDiscountProfilesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetShippingDiscountProfilesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetShippingDiscountProfilesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CalculatedHandlingDiscount |
 | CalculatedShippingDiscount |
 | CombinedDuration |
 | CombinedDurationSpecified |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | CurrencyID |
 | CurrencyIDSpecified |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | FlatShippingDiscount |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | InternationalShippingInsurance |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PromotionalShippingDiscount |
 | PromotionalShippingDiscountDetails |
 | PromotionalShippingDiscountSpecified |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | ShippingInsurance |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetShippingDiscountProfilesResponseType


CalculatedHandlingDiscount Property

CalculatedHandlingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► CalculatedHandlingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedHandlingDiscountType CalculatedHandlingDiscount { get; set; }
Public Property CalculatedHandlingDiscount As CalculatedHandlingDiscountType
    Get
    Set
public:
property CalculatedHandlingDiscountType^ CalculatedHandlingDiscount {
    CalculatedHandlingDiscountType^ get ();
    void set (CalculatedHandlingDiscountType^ value);
}


CalculatedShippingDiscount Property

CalculatedShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► CalculatedShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingDiscountType CalculatedShippingDiscount { get; set; }
Public Property CalculatedShippingDiscount As CalculatedShippingDiscountType
    Get
    Set
public:
property CalculatedShippingDiscountType^ CalculatedShippingDiscount {
    CalculatedShippingDiscountType^ get ();
    void set (CalculatedShippingDiscountType^ value);
}


CombinedDuration Property

CombinedDuration Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► CombinedDuration
Declaration Syntax
C# Visual Basic Visual C++
public CombinedPaymentPeriodCodeType CombinedDuration { get; set; }
Public Property CombinedDuration As CombinedPaymentPeriodCodeType
    Get
    Set
public:
property CombinedPaymentPeriodCodeType CombinedDuration {
    CombinedPaymentPeriodCodeType get ();
    void set (CombinedPaymentPeriodCodeType value);
}


CombinedDurationSpecified Property

CombinedDurationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► CombinedDurationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CombinedDurationSpecified { get; set; }
Public Property CombinedDurationSpecified As Boolean
    Get
    Set
public:
property bool CombinedDurationSpecified {
    bool get ();
    void set (bool value);
}


CurrencyID Property

CurrencyID Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► CurrencyID
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType CurrencyID { get; set; }
Public Property CurrencyID As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType CurrencyID {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


CurrencyIDSpecified Property

CurrencyIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► CurrencyIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CurrencyIDSpecified { get; set; }
Public Property CurrencyIDSpecified As Boolean
    Get
    Set
public:
property bool CurrencyIDSpecified {
    bool get ();
    void set (bool value);
}


FlatShippingDiscount Property

FlatShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► FlatShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public FlatShippingDiscountType FlatShippingDiscount { get; set; }
Public Property FlatShippingDiscount As FlatShippingDiscountType
    Get
    Set
public:
property FlatShippingDiscountType^ FlatShippingDiscount {
    FlatShippingDiscountType^ get ();
    void set (FlatShippingDiscountType^ value);
}


GetShippingDiscountProfilesResponseType Constructor

GetShippingDiscountProfilesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► GetShippingDiscountProfilesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetShippingDiscountProfilesResponseType()
Public Sub New
public:
GetShippingDiscountProfilesResponseType()


InternationalShippingInsurance Property

InternationalShippingInsurance Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► InternationalShippingInsurance
Declaration Syntax
C# Visual Basic Visual C++
public ShippingInsuranceType InternationalShippingInsurance { get; set; }
Public Property InternationalShippingInsurance As ShippingInsuranceType
    Get
    Set
public:
property ShippingInsuranceType^ InternationalShippingInsurance {
    ShippingInsuranceType^ get ();
    void set (ShippingInsuranceType^ value);
}


PromotionalShippingDiscount Property

PromotionalShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► PromotionalShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalShippingDiscount { get; set; }
Public Property PromotionalShippingDiscount As Boolean
    Get
    Set
public:
property bool PromotionalShippingDiscount {
    bool get ();
    void set (bool value);
}


PromotionalShippingDiscountDetails Property

PromotionalShippingDiscountDetails Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► PromotionalShippingDiscountDetails
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalShippingDiscountDetailsType PromotionalShippingDiscountDetails { get; set; }
Public Property PromotionalShippingDiscountDetails As PromotionalShippingDiscountDetailsType
    Get
    Set
public:
property PromotionalShippingDiscountDetailsType^ PromotionalShippingDiscountDetails {
    PromotionalShippingDiscountDetailsType^ get ();
    void set (PromotionalShippingDiscountDetailsType^ value);
}


PromotionalShippingDiscountSpecified Property

PromotionalShippingDiscountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► PromotionalShippingDiscountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalShippingDiscountSpecified { get; set; }
Public Property PromotionalShippingDiscountSpecified As Boolean
    Get
    Set
public:
property bool PromotionalShippingDiscountSpecified {
    bool get ();
    void set (bool value);
}


ShippingInsurance Property

ShippingInsurance Property
Namespaces ► eBay.Service.Core.Soap ► GetShippingDiscountProfilesResponseType ► ShippingInsurance
Declaration Syntax
C# Visual Basic Visual C++
public ShippingInsuranceType ShippingInsurance { get; set; }
Public Property ShippingInsurance As ShippingInsuranceType
    Get
    Set
public:
property ShippingInsuranceType^ ShippingInsurance {
    ShippingInsuranceType^ get ();
    void set (ShippingInsuranceType^ value);
}


GetStoreCategoryUpdateStatusRequestType Class

GetStoreCategoryUpdateStatusRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetStoreCategoryUpdateStatusRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetStoreCategoryUpdateStatusRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetStoreCategoryUpdateStatusRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetStoreCategoryUpdateStatusRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreCategoryUpdateStatusRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | TaskID |
 | TaskIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetStoreCategoryUpdateStatusRequestType


GetStoreCategoryUpdateStatusRequestType Constructor

GetStoreCategoryUpdateStatusRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetStoreCategoryUpdateStatusRequestType ► GetStoreCategoryUpdateStatusRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCategoryUpdateStatusRequestType()
Public Sub New
public:
GetStoreCategoryUpdateStatusRequestType()


TaskID Property

TaskID Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreCategoryUpdateStatusRequestType ► TaskID
Declaration Syntax
C# Visual Basic Visual C++
public long TaskID { get; set; }
Public Property TaskID As Long
    Get
    Set
public:
property long long TaskID {
    long long get ();
    void set (long long value);
}


TaskIDSpecified Property

TaskIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreCategoryUpdateStatusRequestType ► TaskIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TaskIDSpecified { get; set; }
Public Property TaskIDSpecified As Boolean
    Get
    Set
public:
property bool TaskIDSpecified {
    bool get ();
    void set (bool value);
}


GetStoreCategoryUpdateStatusResponseType Class

GetStoreCategoryUpdateStatusResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetStoreCategoryUpdateStatusResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetStoreCategoryUpdateStatusResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetStoreCategoryUpdateStatusResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetStoreCategoryUpdateStatusResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreCategoryUpdateStatusResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Status |
 | StatusSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetStoreCategoryUpdateStatusResponseType


GetStoreCategoryUpdateStatusResponseType Constructor

GetStoreCategoryUpdateStatusResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetStoreCategoryUpdateStatusResponseType ► GetStoreCategoryUpdateStatusResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCategoryUpdateStatusResponseType()
Public Sub New
public:
GetStoreCategoryUpdateStatusResponseType()


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreCategoryUpdateStatusResponseType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public TaskStatusCodeType Status { get; set; }
Public Property Status As TaskStatusCodeType
    Get
    Set
public:
property TaskStatusCodeType Status {
    TaskStatusCodeType get ();
    void set (TaskStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreCategoryUpdateStatusResponseType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


GetStoreCustomPageRequestType Class

GetStoreCustomPageRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetStoreCustomPageRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetStoreCustomPageRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetStoreCustomPageRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetStoreCustomPageRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreCustomPageRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | PageID |
 | PageIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetStoreCustomPageRequestType


GetStoreCustomPageRequestType Constructor

GetStoreCustomPageRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetStoreCustomPageRequestType ► GetStoreCustomPageRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCustomPageRequestType()
Public Sub New
public:
GetStoreCustomPageRequestType()


PageID Property

PageID Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreCustomPageRequestType ► PageID
Declaration Syntax
C# Visual Basic Visual C++
public long PageID { get; set; }
Public Property PageID As Long
    Get
    Set
public:
property long long PageID {
    long long get ();
    void set (long long value);
}


PageIDSpecified Property

PageIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreCustomPageRequestType ► PageIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageIDSpecified { get; set; }
Public Property PageIDSpecified As Boolean
    Get
    Set
public:
property bool PageIDSpecified {
    bool get ();
    void set (bool value);
}


GetStoreCustomPageResponseType Class

GetStoreCustomPageResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetStoreCustomPageResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetStoreCustomPageResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetStoreCustomPageResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetStoreCustomPageResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreCustomPageResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | CustomPageArray |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetStoreCustomPageResponseType


CustomPageArray Property

CustomPageArray Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreCustomPageResponseType ► CustomPageArray
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageTypeCollection CustomPageArray { get; set; }
Public Property CustomPageArray As StoreCustomPageTypeCollection
    Get
    Set
public:
property StoreCustomPageTypeCollection^ CustomPageArray {
    StoreCustomPageTypeCollection^ get ();
    void set (StoreCustomPageTypeCollection^ value);
}


GetStoreCustomPageResponseType Constructor

GetStoreCustomPageResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetStoreCustomPageResponseType ► GetStoreCustomPageResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreCustomPageResponseType()
Public Sub New
public:
GetStoreCustomPageResponseType()


GetStoreOptionsRequestType Class

GetStoreOptionsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetStoreOptionsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetStoreOptionsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetStoreOptionsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreOptionsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetStoreOptionsRequestType


GetStoreOptionsRequestType Constructor

GetStoreOptionsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsRequestType ► GetStoreOptionsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreOptionsRequestType()
Public Sub New
public:
GetStoreOptionsRequestType()


GetStoreOptionsResponseType Class

GetStoreOptionsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetStoreOptionsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetStoreOptionsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetStoreOptionsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreOptionsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | AdvancedThemeArray |
 | Any | (Inherited from AbstractResponseType.)
 | BasicThemeArray |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | LogoArray |
 | MaxCategories |
 | MaxCategoriesSpecified |
 | MaxCategoryLevels |
 | MaxCategoryLevelsSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SubscriptionArray |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetStoreOptionsResponseType


AdvancedThemeArray Property

AdvancedThemeArray Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsResponseType ► AdvancedThemeArray
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeArrayType AdvancedThemeArray { get; set; }
Public Property AdvancedThemeArray As StoreThemeArrayType
    Get
    Set
public:
property StoreThemeArrayType^ AdvancedThemeArray {
    StoreThemeArrayType^ get ();
    void set (StoreThemeArrayType^ value);
}


BasicThemeArray Property

BasicThemeArray Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsResponseType ► BasicThemeArray
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeArrayType BasicThemeArray { get; set; }
Public Property BasicThemeArray As StoreThemeArrayType
    Get
    Set
public:
property StoreThemeArrayType^ BasicThemeArray {
    StoreThemeArrayType^ get ();
    void set (StoreThemeArrayType^ value);
}


GetStoreOptionsResponseType Constructor

GetStoreOptionsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsResponseType ► GetStoreOptionsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreOptionsResponseType()
Public Sub New
public:
GetStoreOptionsResponseType()


LogoArray Property

LogoArray Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsResponseType ► LogoArray
Declaration Syntax
C# Visual Basic Visual C++
public StoreLogoTypeCollection LogoArray { get; set; }
Public Property LogoArray As StoreLogoTypeCollection
    Get
    Set
public:
property StoreLogoTypeCollection^ LogoArray {
    StoreLogoTypeCollection^ get ();
    void set (StoreLogoTypeCollection^ value);
}


MaxCategories Property

MaxCategories Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsResponseType ► MaxCategories
Declaration Syntax
C# Visual Basic Visual C++
public int MaxCategories { get; set; }
Public Property MaxCategories As Integer
    Get
    Set
public:
property int MaxCategories {
    int get ();
    void set (int value);
}


MaxCategoriesSpecified Property

MaxCategoriesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsResponseType ► MaxCategoriesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxCategoriesSpecified { get; set; }
Public Property MaxCategoriesSpecified As Boolean
    Get
    Set
public:
property bool MaxCategoriesSpecified {
    bool get ();
    void set (bool value);
}


MaxCategoryLevels Property

MaxCategoryLevels Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsResponseType ► MaxCategoryLevels
Declaration Syntax
C# Visual Basic Visual C++
public int MaxCategoryLevels { get; set; }
Public Property MaxCategoryLevels As Integer
    Get
    Set
public:
property int MaxCategoryLevels {
    int get ();
    void set (int value);
}


MaxCategoryLevelsSpecified Property

MaxCategoryLevelsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsResponseType ► MaxCategoryLevelsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxCategoryLevelsSpecified { get; set; }
Public Property MaxCategoryLevelsSpecified As Boolean
    Get
    Set
public:
property bool MaxCategoryLevelsSpecified {
    bool get ();
    void set (bool value);
}


SubscriptionArray Property

SubscriptionArray Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreOptionsResponseType ► SubscriptionArray
Declaration Syntax
C# Visual Basic Visual C++
public StoreSubscriptionTypeCollection SubscriptionArray { get; set; }
Public Property SubscriptionArray As StoreSubscriptionTypeCollection
    Get
    Set
public:
property StoreSubscriptionTypeCollection^ SubscriptionArray {
    StoreSubscriptionTypeCollection^ get ();
    void set (StoreSubscriptionTypeCollection^ value);
}


GetStorePreferencesRequestType Class

GetStorePreferencesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetStorePreferencesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetStorePreferencesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetStorePreferencesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetStorePreferencesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStorePreferencesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetStorePreferencesRequestType


GetStorePreferencesRequestType Constructor

GetStorePreferencesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetStorePreferencesRequestType ► GetStorePreferencesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStorePreferencesRequestType()
Public Sub New
public:
GetStorePreferencesRequestType()


GetStorePreferencesResponseType Class

GetStorePreferencesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetStorePreferencesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetStorePreferencesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetStorePreferencesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetStorePreferencesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStorePreferencesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | StorePreferences |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetStorePreferencesResponseType


GetStorePreferencesResponseType Constructor

GetStorePreferencesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetStorePreferencesResponseType ► GetStorePreferencesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStorePreferencesResponseType()
Public Sub New
public:
GetStorePreferencesResponseType()


StorePreferences Property

StorePreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetStorePreferencesResponseType ► StorePreferences
Declaration Syntax
C# Visual Basic Visual C++
public StorePreferencesType StorePreferences { get; set; }
Public Property StorePreferences As StorePreferencesType
    Get
    Set
public:
property StorePreferencesType^ StorePreferences {
    StorePreferencesType^ get ();
    void set (StorePreferencesType^ value);
}


GetStoreRequestType Class

GetStoreRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetStoreRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetStoreRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetStoreRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetStoreRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CategoryStructureOnly |
 | CategoryStructureOnlySpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | LevelLimit |
 | LevelLimitSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | RootCategoryID |
 | RootCategoryIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UserID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetStoreRequestType


CategoryStructureOnly Property

CategoryStructureOnly Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreRequestType ► CategoryStructureOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool CategoryStructureOnly { get; set; }
Public Property CategoryStructureOnly As Boolean
    Get
    Set
public:
property bool CategoryStructureOnly {
    bool get ();
    void set (bool value);
}


CategoryStructureOnlySpecified Property

CategoryStructureOnlySpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreRequestType ► CategoryStructureOnlySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CategoryStructureOnlySpecified { get; set; }
Public Property CategoryStructureOnlySpecified As Boolean
    Get
    Set
public:
property bool CategoryStructureOnlySpecified {
    bool get ();
    void set (bool value);
}


GetStoreRequestType Constructor

GetStoreRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetStoreRequestType ► GetStoreRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreRequestType()
Public Sub New
public:
GetStoreRequestType()


LevelLimit Property

LevelLimit Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreRequestType ► LevelLimit
Declaration Syntax
C# Visual Basic Visual C++
public int LevelLimit { get; set; }
Public Property LevelLimit As Integer
    Get
    Set
public:
property int LevelLimit {
    int get ();
    void set (int value);
}


LevelLimitSpecified Property

LevelLimitSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreRequestType ► LevelLimitSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LevelLimitSpecified { get; set; }
Public Property LevelLimitSpecified As Boolean
    Get
    Set
public:
property bool LevelLimitSpecified {
    bool get ();
    void set (bool value);
}


RootCategoryID Property

RootCategoryID Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreRequestType ► RootCategoryID
Declaration Syntax
C# Visual Basic Visual C++
public long RootCategoryID { get; set; }
Public Property RootCategoryID As Long
    Get
    Set
public:
property long long RootCategoryID {
    long long get ();
    void set (long long value);
}


RootCategoryIDSpecified Property

RootCategoryIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreRequestType ► RootCategoryIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RootCategoryIDSpecified { get; set; }
Public Property RootCategoryIDSpecified As Boolean
    Get
    Set
public:
property bool RootCategoryIDSpecified {
    bool get ();
    void set (bool value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreRequestType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetStoreResponseType Class

GetStoreResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetStoreResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetStoreResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetStoreResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetStoreResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetStoreResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Store |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetStoreResponseType


GetStoreResponseType Constructor

GetStoreResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetStoreResponseType ► GetStoreResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetStoreResponseType()
Public Sub New
public:
GetStoreResponseType()


Store Property

Store Property
Namespaces ► eBay.Service.Core.Soap ► GetStoreResponseType ► Store
Declaration Syntax
C# Visual Basic Visual C++
public StoreType Store { get; set; }
Public Property Store As StoreType
    Get
    Set
public:
property StoreType^ Store {
    StoreType^ get ();
    void set (StoreType^ value);
}


GetSuggestedCategoriesRequestType Class

GetSuggestedCategoriesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetSuggestedCategoriesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSuggestedCategoriesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSuggestedCategoriesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSuggestedCategoriesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSuggestedCategoriesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Query |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetSuggestedCategoriesRequestType


GetSuggestedCategoriesRequestType Constructor

GetSuggestedCategoriesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSuggestedCategoriesRequestType ► GetSuggestedCategoriesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSuggestedCategoriesRequestType()
Public Sub New
public:
GetSuggestedCategoriesRequestType()


Query Property

Query Property
Namespaces ► eBay.Service.Core.Soap ► GetSuggestedCategoriesRequestType ► Query
Declaration Syntax
C# Visual Basic Visual C++
public string Query { get; set; }
Public Property Query As String
    Get
    Set
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}


GetSuggestedCategoriesResponseType Class

GetSuggestedCategoriesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetSuggestedCategoriesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetSuggestedCategoriesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetSuggestedCategoriesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetSuggestedCategoriesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetSuggestedCategoriesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CategoryCount |
 | CategoryCountSpecified |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SuggestedCategoryArray |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetSuggestedCategoriesResponseType


CategoryCount Property

CategoryCount Property
Namespaces ► eBay.Service.Core.Soap ► GetSuggestedCategoriesResponseType ► CategoryCount
Declaration Syntax
C# Visual Basic Visual C++
public int CategoryCount { get; set; }
Public Property CategoryCount As Integer
    Get
    Set
public:
property int CategoryCount {
    int get ();
    void set (int value);
}


CategoryCountSpecified Property

CategoryCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetSuggestedCategoriesResponseType ► CategoryCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CategoryCountSpecified { get; set; }
Public Property CategoryCountSpecified As Boolean
    Get
    Set
public:
property bool CategoryCountSpecified {
    bool get ();
    void set (bool value);
}


GetSuggestedCategoriesResponseType Constructor

GetSuggestedCategoriesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetSuggestedCategoriesResponseType ► GetSuggestedCategoriesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetSuggestedCategoriesResponseType()
Public Sub New
public:
GetSuggestedCategoriesResponseType()


SuggestedCategoryArray Property

SuggestedCategoryArray Property
Namespaces ► eBay.Service.Core.Soap ► GetSuggestedCategoriesResponseType ► SuggestedCategoryArray
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryArrayType SuggestedCategoryArray { get; set; }
Public Property SuggestedCategoryArray As SuggestedCategoryArrayType
    Get
    Set
public:
property SuggestedCategoryArrayType^ SuggestedCategoryArray {
    SuggestedCategoryArrayType^ get ();
    void set (SuggestedCategoryArrayType^ value);
}


GetTaxTableRequestType Class

GetTaxTableRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetTaxTableRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetTaxTableRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetTaxTableRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetTaxTableRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetTaxTableRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetTaxTableRequestType


GetTaxTableRequestType Constructor

GetTaxTableRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetTaxTableRequestType ► GetTaxTableRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetTaxTableRequestType()
Public Sub New
public:
GetTaxTableRequestType()


GetTaxTableResponseType Class

GetTaxTableResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetTaxTableResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetTaxTableResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetTaxTableResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetTaxTableResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetTaxTableResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | LastUpdateTime |
 | LastUpdateTimeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | TaxTable |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetTaxTableResponseType


GetTaxTableResponseType Constructor

GetTaxTableResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetTaxTableResponseType ► GetTaxTableResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetTaxTableResponseType()
Public Sub New
public:
GetTaxTableResponseType()


LastUpdateTime Property

LastUpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► GetTaxTableResponseType ► LastUpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastUpdateTime { get; set; }
Public Property LastUpdateTime As DateTime
    Get
    Set
public:
property DateTime LastUpdateTime {
    DateTime get ();
    void set (DateTime value);
}


LastUpdateTimeSpecified Property

LastUpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetTaxTableResponseType ► LastUpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastUpdateTimeSpecified { get; set; }
Public Property LastUpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool LastUpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


TaxTable Property

TaxTable Property
Namespaces ► eBay.Service.Core.Soap ► GetTaxTableResponseType ► TaxTable
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection TaxTable { get; set; }
Public Property TaxTable As TaxJurisdictionTypeCollection
    Get
    Set
public:
property TaxJurisdictionTypeCollection^ TaxTable {
    TaxJurisdictionTypeCollection^ get ();
    void set (TaxJurisdictionTypeCollection^ value);
}


GetTokenStatusRequestType Class

GetTokenStatusRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetTokenStatusRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetTokenStatusRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetTokenStatusRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetTokenStatusRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetTokenStatusRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetTokenStatusRequestType


GetTokenStatusRequestType Constructor

GetTokenStatusRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetTokenStatusRequestType ► GetTokenStatusRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetTokenStatusRequestType()
Public Sub New
public:
GetTokenStatusRequestType()


GetTokenStatusResponseType Class

GetTokenStatusResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetTokenStatusResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetTokenStatusResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetTokenStatusResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetTokenStatusResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetTokenStatusResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | TokenStatus |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetTokenStatusResponseType


GetTokenStatusResponseType Constructor

GetTokenStatusResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetTokenStatusResponseType ► GetTokenStatusResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetTokenStatusResponseType()
Public Sub New
public:
GetTokenStatusResponseType()


TokenStatus Property

TokenStatus Property
Namespaces ► eBay.Service.Core.Soap ► GetTokenStatusResponseType ► TokenStatus
Declaration Syntax
C# Visual Basic Visual C++
public TokenStatusType TokenStatus { get; set; }
Public Property TokenStatus As TokenStatusType
    Get
    Set
public:
property TokenStatusType^ TokenStatus {
    TokenStatusType^ get ();
    void set (TokenStatusType^ value);
}


GetUserContactDetailsRequestType Class

GetUserContactDetailsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetUserContactDetailsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetUserContactDetailsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetUserContactDetailsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetUserContactDetailsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserContactDetailsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | ContactID |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | RequesterID |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetUserContactDetailsRequestType


ContactID Property

ContactID Property
Namespaces ► eBay.Service.Core.Soap ► GetUserContactDetailsRequestType ► ContactID
Declaration Syntax
C# Visual Basic Visual C++
public string ContactID { get; set; }
Public Property ContactID As String
    Get
    Set
public:
property String^ ContactID {
    String^ get ();
    void set (String^ value);
}


GetUserContactDetailsRequestType Constructor

GetUserContactDetailsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetUserContactDetailsRequestType ► GetUserContactDetailsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserContactDetailsRequestType()
Public Sub New
public:
GetUserContactDetailsRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetUserContactDetailsRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


RequesterID Property

RequesterID Property
Namespaces ► eBay.Service.Core.Soap ► GetUserContactDetailsRequestType ► RequesterID
Declaration Syntax
C# Visual Basic Visual C++
public string RequesterID { get; set; }
Public Property RequesterID As String
    Get
    Set
public:
property String^ RequesterID {
    String^ get ();
    void set (String^ value);
}


GetUserContactDetailsResponseType Class

GetUserContactDetailsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetUserContactDetailsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetUserContactDetailsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetUserContactDetailsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetUserContactDetailsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserContactDetailsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | ContactAddress |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | RegistrationDate |
 | RegistrationDateSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | UserID |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetUserContactDetailsResponseType


ContactAddress Property

ContactAddress Property
Namespaces ► eBay.Service.Core.Soap ► GetUserContactDetailsResponseType ► ContactAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType ContactAddress { get; set; }
Public Property ContactAddress As AddressType
    Get
    Set
public:
property AddressType^ ContactAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


GetUserContactDetailsResponseType Constructor

GetUserContactDetailsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetUserContactDetailsResponseType ► GetUserContactDetailsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserContactDetailsResponseType()
Public Sub New
public:
GetUserContactDetailsResponseType()


RegistrationDate Property

RegistrationDate Property
Namespaces ► eBay.Service.Core.Soap ► GetUserContactDetailsResponseType ► RegistrationDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RegistrationDate { get; set; }
Public Property RegistrationDate As DateTime
    Get
    Set
public:
property DateTime RegistrationDate {
    DateTime get ();
    void set (DateTime value);
}


RegistrationDateSpecified Property

RegistrationDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserContactDetailsResponseType ► RegistrationDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RegistrationDateSpecified { get; set; }
Public Property RegistrationDateSpecified As Boolean
    Get
    Set
public:
property bool RegistrationDateSpecified {
    bool get ();
    void set (bool value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► GetUserContactDetailsResponseType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetUserDisputesRequestType Class

GetUserDisputesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetUserDisputesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetUserDisputesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetUserDisputesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserDisputesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | DisputeFilterType |
 | DisputeFilterTypeSpecified |
 | DisputeSortType |
 | DisputeSortTypeSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | ModTimeFrom |
 | ModTimeFromSpecified |
 | ModTimeTo |
 | ModTimeToSpecified |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetUserDisputesRequestType


DisputeFilterType Property

DisputeFilterType Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesRequestType ► DisputeFilterType
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterTypeCodeType DisputeFilterType { get; set; }
Public Property DisputeFilterType As DisputeFilterTypeCodeType
    Get
    Set
public:
property DisputeFilterTypeCodeType DisputeFilterType {
    DisputeFilterTypeCodeType get ();
    void set (DisputeFilterTypeCodeType value);
}


DisputeFilterTypeSpecified Property

DisputeFilterTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesRequestType ► DisputeFilterTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeFilterTypeSpecified { get; set; }
Public Property DisputeFilterTypeSpecified As Boolean
    Get
    Set
public:
property bool DisputeFilterTypeSpecified {
    bool get ();
    void set (bool value);
}


DisputeSortType Property

DisputeSortType Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesRequestType ► DisputeSortType
Declaration Syntax
C# Visual Basic Visual C++
public DisputeSortTypeCodeType DisputeSortType { get; set; }
Public Property DisputeSortType As DisputeSortTypeCodeType
    Get
    Set
public:
property DisputeSortTypeCodeType DisputeSortType {
    DisputeSortTypeCodeType get ();
    void set (DisputeSortTypeCodeType value);
}


DisputeSortTypeSpecified Property

DisputeSortTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesRequestType ► DisputeSortTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeSortTypeSpecified { get; set; }
Public Property DisputeSortTypeSpecified As Boolean
    Get
    Set
public:
property bool DisputeSortTypeSpecified {
    bool get ();
    void set (bool value);
}


GetUserDisputesRequestType Constructor

GetUserDisputesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesRequestType ► GetUserDisputesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserDisputesRequestType()
Public Sub New
public:
GetUserDisputesRequestType()


ModTimeFrom Property

ModTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesRequestType ► ModTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeFrom { get; set; }
Public Property ModTimeFrom As DateTime
    Get
    Set
public:
property DateTime ModTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


ModTimeFromSpecified Property

ModTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesRequestType ► ModTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModTimeFromSpecified { get; set; }
Public Property ModTimeFromSpecified As Boolean
    Get
    Set
public:
property bool ModTimeFromSpecified {
    bool get ();
    void set (bool value);
}


ModTimeTo Property

ModTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesRequestType ► ModTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ModTimeTo { get; set; }
Public Property ModTimeTo As DateTime
    Get
    Set
public:
property DateTime ModTimeTo {
    DateTime get ();
    void set (DateTime value);
}


ModTimeToSpecified Property

ModTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesRequestType ► ModTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModTimeToSpecified { get; set; }
Public Property ModTimeToSpecified As Boolean
    Get
    Set
public:
property bool ModTimeToSpecified {
    bool get ();
    void set (bool value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


GetUserDisputesResponseType Class

GetUserDisputesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetUserDisputesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetUserDisputesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetUserDisputesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserDisputesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DisputeArray |
 | DisputeFilterCount |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndingDisputeID |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemsPerPage |
 | ItemsPerPageSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PageNumber |
 | PageNumberSpecified |
 | PaginationResult |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | StartingDisputeID |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetUserDisputesResponseType


DisputeArray Property

DisputeArray Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesResponseType ► DisputeArray
Declaration Syntax
C# Visual Basic Visual C++
public DisputeTypeCollection DisputeArray { get; set; }
Public Property DisputeArray As DisputeTypeCollection
    Get
    Set
public:
property DisputeTypeCollection^ DisputeArray {
    DisputeTypeCollection^ get ();
    void set (DisputeTypeCollection^ value);
}


DisputeFilterCount Property

DisputeFilterCount Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesResponseType ► DisputeFilterCount
Declaration Syntax
C# Visual Basic Visual C++
public DisputeFilterCountTypeCollection DisputeFilterCount { get; set; }
Public Property DisputeFilterCount As DisputeFilterCountTypeCollection
    Get
    Set
public:
property DisputeFilterCountTypeCollection^ DisputeFilterCount {
    DisputeFilterCountTypeCollection^ get ();
    void set (DisputeFilterCountTypeCollection^ value);
}


EndingDisputeID Property

EndingDisputeID Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesResponseType ► EndingDisputeID
Declaration Syntax
C# Visual Basic Visual C++
public string EndingDisputeID { get; set; }
Public Property EndingDisputeID As String
    Get
    Set
public:
property String^ EndingDisputeID {
    String^ get ();
    void set (String^ value);
}


GetUserDisputesResponseType Constructor

GetUserDisputesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesResponseType ► GetUserDisputesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserDisputesResponseType()
Public Sub New
public:
GetUserDisputesResponseType()


ItemsPerPage Property

ItemsPerPage Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesResponseType ► ItemsPerPage
Declaration Syntax
C# Visual Basic Visual C++
public int ItemsPerPage { get; set; }
Public Property ItemsPerPage As Integer
    Get
    Set
public:
property int ItemsPerPage {
    int get ();
    void set (int value);
}


ItemsPerPageSpecified Property

ItemsPerPageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesResponseType ► ItemsPerPageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemsPerPageSpecified { get; set; }
Public Property ItemsPerPageSpecified As Boolean
    Get
    Set
public:
property bool ItemsPerPageSpecified {
    bool get ();
    void set (bool value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesResponseType ► PageNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}


PageNumberSpecified Property

PageNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesResponseType ► PageNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageNumberSpecified { get; set; }
Public Property PageNumberSpecified As Boolean
    Get
    Set
public:
property bool PageNumberSpecified {
    bool get ();
    void set (bool value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


StartingDisputeID Property

StartingDisputeID Property
Namespaces ► eBay.Service.Core.Soap ► GetUserDisputesResponseType ► StartingDisputeID
Declaration Syntax
C# Visual Basic Visual C++
public string StartingDisputeID { get; set; }
Public Property StartingDisputeID As String
    Get
    Set
public:
property String^ StartingDisputeID {
    String^ get ();
    void set (String^ value);
}


GetUserPreferencesRequestType Class

GetUserPreferencesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetUserPreferencesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetUserPreferencesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetUserPreferencesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserPreferencesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ShowBidderNoticePreferences |
 | ShowCombinedPaymentPreferences |
 | ShowCrossPromotionPreferences |
 | ShowDispatchCutoffTimePreferences |
 | ShowDispatchCutoffTimePreferencesSpecified |
 | ShoweBayPLUSPreference |
 | ShoweBayPLUSPreferenceSpecified |
 | ShowEmailShipmentTrackingNumberPreference |
 | ShowEmailShipmentTrackingNumberPreferenceSpecified |
 | ShowEndOfAuctionEmailPreferences |
 | ShowEndOfAuctionEmailPreferencesSpecified |
 | ShowGlobalShippingProgramListingPreference |
 | ShowGlobalShippingProgramListingPreferenceSpecified |
 | ShowGlobalShippingProgramPreference |
 | ShowGlobalShippingProgramPreferenceSpecified |
 | ShowOutOfStockControlPreference |
 | ShowOutOfStockControlPreferenceSpecified |
 | ShowOverrideGSPServiceWithIntlServicePreference |
 | ShowOverrideGSPServiceWithIntlServicePreferenceSpecified |
 | ShowPickupDropoffPreferences |
 | ShowPickupDropoffPreferencesSpecified |
 | ShowProStoresPreferences |
 | ShowProStoresPreferencesSpecified |
 | ShowPurchaseReminderEmailPreferences |
 | ShowPurchaseReminderEmailPreferencesSpecified |
 | ShowRequiredShipPhoneNumberPreference |
 | ShowRequiredShipPhoneNumberPreferenceSpecified |
 | ShowSellerExcludeShipToLocationPreference |
 | ShowSellerExcludeShipToLocationPreferenceSpecified |
 | ShowSellerFavoriteItemPreferences |
 | ShowSellerFavoriteItemPreferencesSpecified |
 | ShowSellerPaymentPreferences |
 | ShowSellerProfilePreferences |
 | ShowSellerReturnPreferences |
 | ShowSellerReturnPreferencesSpecified |
 | ShowUnpaidItemAssistanceExclusionList |
 | ShowUnpaidItemAssistanceExclusionListSpecified |
 | ShowUnpaidItemAssistancePreference |
 | ShowUnpaidItemAssistancePreferenceSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetUserPreferencesRequestType


GetUserPreferencesRequestType Constructor

GetUserPreferencesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► GetUserPreferencesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserPreferencesRequestType()
Public Sub New
public:
GetUserPreferencesRequestType()


ShowBidderNoticePreferences Property

ShowBidderNoticePreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowBidderNoticePreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowBidderNoticePreferences { get; set; }
Public Property ShowBidderNoticePreferences As Boolean
    Get
    Set
public:
property bool ShowBidderNoticePreferences {
    bool get ();
    void set (bool value);
}


ShowCombinedPaymentPreferences Property

ShowCombinedPaymentPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowCombinedPaymentPreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowCombinedPaymentPreferences { get; set; }
Public Property ShowCombinedPaymentPreferences As Boolean
    Get
    Set
public:
property bool ShowCombinedPaymentPreferences {
    bool get ();
    void set (bool value);
}


ShowCrossPromotionPreferences Property

ShowCrossPromotionPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowCrossPromotionPreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowCrossPromotionPreferences { get; set; }
Public Property ShowCrossPromotionPreferences As Boolean
    Get
    Set
public:
property bool ShowCrossPromotionPreferences {
    bool get ();
    void set (bool value);
}


ShowDispatchCutoffTimePreferences Property

ShowDispatchCutoffTimePreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowDispatchCutoffTimePreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowDispatchCutoffTimePreferences { get; set; }
Public Property ShowDispatchCutoffTimePreferences As Boolean
    Get
    Set
public:
property bool ShowDispatchCutoffTimePreferences {
    bool get ();
    void set (bool value);
}


ShowDispatchCutoffTimePreferencesSpecified Property

ShowDispatchCutoffTimePreferencesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowDispatchCutoffTimePreferencesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowDispatchCutoffTimePreferencesSpecified { get; set; }
Public Property ShowDispatchCutoffTimePreferencesSpecified As Boolean
    Get
    Set
public:
property bool ShowDispatchCutoffTimePreferencesSpecified {
    bool get ();
    void set (bool value);
}


ShoweBayPLUSPreference Property

ShoweBayPLUSPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShoweBayPLUSPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool ShoweBayPLUSPreference { get; set; }
Public Property ShoweBayPLUSPreference As Boolean
    Get
    Set
public:
property bool ShoweBayPLUSPreference {
    bool get ();
    void set (bool value);
}


ShoweBayPLUSPreferenceSpecified Property

ShoweBayPLUSPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShoweBayPLUSPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShoweBayPLUSPreferenceSpecified { get; set; }
Public Property ShoweBayPLUSPreferenceSpecified As Boolean
    Get
    Set
public:
property bool ShoweBayPLUSPreferenceSpecified {
    bool get ();
    void set (bool value);
}


ShowEmailShipmentTrackingNumberPreference Property

ShowEmailShipmentTrackingNumberPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowEmailShipmentTrackingNumberPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowEmailShipmentTrackingNumberPreference { get; set; }
Public Property ShowEmailShipmentTrackingNumberPreference As Boolean
    Get
    Set
public:
property bool ShowEmailShipmentTrackingNumberPreference {
    bool get ();
    void set (bool value);
}


ShowEmailShipmentTrackingNumberPreferenceSpecified Property

ShowEmailShipmentTrackingNumberPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowEmailShipmentTrackingNumberPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowEmailShipmentTrackingNumberPreferenceSpecified { get; set; }
Public Property ShowEmailShipmentTrackingNumberPreferenceSpecified As Boolean
    Get
    Set
public:
property bool ShowEmailShipmentTrackingNumberPreferenceSpecified {
    bool get ();
    void set (bool value);
}


ShowEndOfAuctionEmailPreferences Property

ShowEndOfAuctionEmailPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowEndOfAuctionEmailPreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowEndOfAuctionEmailPreferences { get; set; }
Public Property ShowEndOfAuctionEmailPreferences As Boolean
    Get
    Set
public:
property bool ShowEndOfAuctionEmailPreferences {
    bool get ();
    void set (bool value);
}


ShowEndOfAuctionEmailPreferencesSpecified Property

ShowEndOfAuctionEmailPreferencesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowEndOfAuctionEmailPreferencesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowEndOfAuctionEmailPreferencesSpecified { get; set; }
Public Property ShowEndOfAuctionEmailPreferencesSpecified As Boolean
    Get
    Set
public:
property bool ShowEndOfAuctionEmailPreferencesSpecified {
    bool get ();
    void set (bool value);
}


ShowGlobalShippingProgramListingPreference Property

ShowGlobalShippingProgramListingPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowGlobalShippingProgramListingPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowGlobalShippingProgramListingPreference { get; set; }
Public Property ShowGlobalShippingProgramListingPreference As Boolean
    Get
    Set
public:
property bool ShowGlobalShippingProgramListingPreference {
    bool get ();
    void set (bool value);
}


ShowGlobalShippingProgramListingPreferenceSpecified Property

ShowGlobalShippingProgramListingPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowGlobalShippingProgramListingPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowGlobalShippingProgramListingPreferenceSpecified { get; set; }
Public Property ShowGlobalShippingProgramListingPreferenceSpecified As Boolean
    Get
    Set
public:
property bool ShowGlobalShippingProgramListingPreferenceSpecified {
    bool get ();
    void set (bool value);
}


ShowGlobalShippingProgramPreference Property

ShowGlobalShippingProgramPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowGlobalShippingProgramPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowGlobalShippingProgramPreference { get; set; }
Public Property ShowGlobalShippingProgramPreference As Boolean
    Get
    Set
public:
property bool ShowGlobalShippingProgramPreference {
    bool get ();
    void set (bool value);
}


ShowGlobalShippingProgramPreferenceSpecified Property

ShowGlobalShippingProgramPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowGlobalShippingProgramPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowGlobalShippingProgramPreferenceSpecified { get; set; }
Public Property ShowGlobalShippingProgramPreferenceSpecified As Boolean
    Get
    Set
public:
property bool ShowGlobalShippingProgramPreferenceSpecified {
    bool get ();
    void set (bool value);
}


ShowOutOfStockControlPreference Property

ShowOutOfStockControlPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowOutOfStockControlPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowOutOfStockControlPreference { get; set; }
Public Property ShowOutOfStockControlPreference As Boolean
    Get
    Set
public:
property bool ShowOutOfStockControlPreference {
    bool get ();
    void set (bool value);
}


ShowOutOfStockControlPreferenceSpecified Property

ShowOutOfStockControlPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowOutOfStockControlPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowOutOfStockControlPreferenceSpecified { get; set; }
Public Property ShowOutOfStockControlPreferenceSpecified As Boolean
    Get
    Set
public:
property bool ShowOutOfStockControlPreferenceSpecified {
    bool get ();
    void set (bool value);
}


ShowOverrideGSPServiceWithIntlServicePreference Property

ShowOverrideGSPServiceWithIntlServicePreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowOverrideGSPServiceWithIntlServicePreference
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowOverrideGSPServiceWithIntlServicePreference { get; set; }
Public Property ShowOverrideGSPServiceWithIntlServicePreference As Boolean
    Get
    Set
public:
property bool ShowOverrideGSPServiceWithIntlServicePreference {
    bool get ();
    void set (bool value);
}


ShowOverrideGSPServiceWithIntlServicePreferenceSpecified Property

ShowOverrideGSPServiceWithIntlServicePreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowOverrideGSPServiceWithIntlServicePreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowOverrideGSPServiceWithIntlServicePreferenceSpecified { get; set; }
Public Property ShowOverrideGSPServiceWithIntlServicePreferenceSpecified As Boolean
    Get
    Set
public:
property bool ShowOverrideGSPServiceWithIntlServicePreferenceSpecified {
    bool get ();
    void set (bool value);
}


ShowPickupDropoffPreferences Property

ShowPickupDropoffPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowPickupDropoffPreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowPickupDropoffPreferences { get; set; }
Public Property ShowPickupDropoffPreferences As Boolean
    Get
    Set
public:
property bool ShowPickupDropoffPreferences {
    bool get ();
    void set (bool value);
}


ShowPickupDropoffPreferencesSpecified Property

ShowPickupDropoffPreferencesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowPickupDropoffPreferencesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowPickupDropoffPreferencesSpecified { get; set; }
Public Property ShowPickupDropoffPreferencesSpecified As Boolean
    Get
    Set
public:
property bool ShowPickupDropoffPreferencesSpecified {
    bool get ();
    void set (bool value);
}


ShowProStoresPreferences Property

ShowProStoresPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowProStoresPreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowProStoresPreferences { get; set; }
Public Property ShowProStoresPreferences As Boolean
    Get
    Set
public:
property bool ShowProStoresPreferences {
    bool get ();
    void set (bool value);
}


ShowProStoresPreferencesSpecified Property

ShowProStoresPreferencesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowProStoresPreferencesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowProStoresPreferencesSpecified { get; set; }
Public Property ShowProStoresPreferencesSpecified As Boolean
    Get
    Set
public:
property bool ShowProStoresPreferencesSpecified {
    bool get ();
    void set (bool value);
}


ShowPurchaseReminderEmailPreferences Property

ShowPurchaseReminderEmailPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowPurchaseReminderEmailPreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowPurchaseReminderEmailPreferences { get; set; }
Public Property ShowPurchaseReminderEmailPreferences As Boolean
    Get
    Set
public:
property bool ShowPurchaseReminderEmailPreferences {
    bool get ();
    void set (bool value);
}


ShowPurchaseReminderEmailPreferencesSpecified Property

ShowPurchaseReminderEmailPreferencesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowPurchaseReminderEmailPreferencesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowPurchaseReminderEmailPreferencesSpecified { get; set; }
Public Property ShowPurchaseReminderEmailPreferencesSpecified As Boolean
    Get
    Set
public:
property bool ShowPurchaseReminderEmailPreferencesSpecified {
    bool get ();
    void set (bool value);
}


ShowRequiredShipPhoneNumberPreference Property

ShowRequiredShipPhoneNumberPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowRequiredShipPhoneNumberPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowRequiredShipPhoneNumberPreference { get; set; }
Public Property ShowRequiredShipPhoneNumberPreference As Boolean
    Get
    Set
public:
property bool ShowRequiredShipPhoneNumberPreference {
    bool get ();
    void set (bool value);
}


ShowRequiredShipPhoneNumberPreferenceSpecified Property

ShowRequiredShipPhoneNumberPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowRequiredShipPhoneNumberPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowRequiredShipPhoneNumberPreferenceSpecified { get; set; }
Public Property ShowRequiredShipPhoneNumberPreferenceSpecified As Boolean
    Get
    Set
public:
property bool ShowRequiredShipPhoneNumberPreferenceSpecified {
    bool get ();
    void set (bool value);
}


ShowSellerExcludeShipToLocationPreference Property

ShowSellerExcludeShipToLocationPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowSellerExcludeShipToLocationPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerExcludeShipToLocationPreference { get; set; }
Public Property ShowSellerExcludeShipToLocationPreference As Boolean
    Get
    Set
public:
property bool ShowSellerExcludeShipToLocationPreference {
    bool get ();
    void set (bool value);
}


ShowSellerExcludeShipToLocationPreferenceSpecified Property

ShowSellerExcludeShipToLocationPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowSellerExcludeShipToLocationPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerExcludeShipToLocationPreferenceSpecified { get; set; }
Public Property ShowSellerExcludeShipToLocationPreferenceSpecified As Boolean
    Get
    Set
public:
property bool ShowSellerExcludeShipToLocationPreferenceSpecified {
    bool get ();
    void set (bool value);
}


ShowSellerFavoriteItemPreferences Property

ShowSellerFavoriteItemPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowSellerFavoriteItemPreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerFavoriteItemPreferences { get; set; }
Public Property ShowSellerFavoriteItemPreferences As Boolean
    Get
    Set
public:
property bool ShowSellerFavoriteItemPreferences {
    bool get ();
    void set (bool value);
}


ShowSellerFavoriteItemPreferencesSpecified Property

ShowSellerFavoriteItemPreferencesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowSellerFavoriteItemPreferencesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerFavoriteItemPreferencesSpecified { get; set; }
Public Property ShowSellerFavoriteItemPreferencesSpecified As Boolean
    Get
    Set
public:
property bool ShowSellerFavoriteItemPreferencesSpecified {
    bool get ();
    void set (bool value);
}


ShowSellerPaymentPreferences Property

ShowSellerPaymentPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowSellerPaymentPreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerPaymentPreferences { get; set; }
Public Property ShowSellerPaymentPreferences As Boolean
    Get
    Set
public:
property bool ShowSellerPaymentPreferences {
    bool get ();
    void set (bool value);
}


ShowSellerProfilePreferences Property

ShowSellerProfilePreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowSellerProfilePreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerProfilePreferences { get; set; }
Public Property ShowSellerProfilePreferences As Boolean
    Get
    Set
public:
property bool ShowSellerProfilePreferences {
    bool get ();
    void set (bool value);
}


ShowSellerReturnPreferences Property

ShowSellerReturnPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowSellerReturnPreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerReturnPreferences { get; set; }
Public Property ShowSellerReturnPreferences As Boolean
    Get
    Set
public:
property bool ShowSellerReturnPreferences {
    bool get ();
    void set (bool value);
}


ShowSellerReturnPreferencesSpecified Property

ShowSellerReturnPreferencesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowSellerReturnPreferencesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowSellerReturnPreferencesSpecified { get; set; }
Public Property ShowSellerReturnPreferencesSpecified As Boolean
    Get
    Set
public:
property bool ShowSellerReturnPreferencesSpecified {
    bool get ();
    void set (bool value);
}


ShowUnpaidItemAssistanceExclusionList Property

ShowUnpaidItemAssistanceExclusionList Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowUnpaidItemAssistanceExclusionList
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowUnpaidItemAssistanceExclusionList { get; set; }
Public Property ShowUnpaidItemAssistanceExclusionList As Boolean
    Get
    Set
public:
property bool ShowUnpaidItemAssistanceExclusionList {
    bool get ();
    void set (bool value);
}


ShowUnpaidItemAssistanceExclusionListSpecified Property

ShowUnpaidItemAssistanceExclusionListSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowUnpaidItemAssistanceExclusionListSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowUnpaidItemAssistanceExclusionListSpecified { get; set; }
Public Property ShowUnpaidItemAssistanceExclusionListSpecified As Boolean
    Get
    Set
public:
property bool ShowUnpaidItemAssistanceExclusionListSpecified {
    bool get ();
    void set (bool value);
}


ShowUnpaidItemAssistancePreference Property

ShowUnpaidItemAssistancePreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowUnpaidItemAssistancePreference
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowUnpaidItemAssistancePreference { get; set; }
Public Property ShowUnpaidItemAssistancePreference As Boolean
    Get
    Set
public:
property bool ShowUnpaidItemAssistancePreference {
    bool get ();
    void set (bool value);
}


ShowUnpaidItemAssistancePreferenceSpecified Property

ShowUnpaidItemAssistancePreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesRequestType ► ShowUnpaidItemAssistancePreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowUnpaidItemAssistancePreferenceSpecified { get; set; }
Public Property ShowUnpaidItemAssistancePreferenceSpecified As Boolean
    Get
    Set
public:
property bool ShowUnpaidItemAssistancePreferenceSpecified {
    bool get ();
    void set (bool value);
}


GetUserPreferencesResponseType Class

GetUserPreferencesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetUserPreferencesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetUserPreferencesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetUserPreferencesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserPreferencesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BidderNoticePreferences |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CombinedPaymentPreferences |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | CrossPromotionPreferences |
 | DispatchCutoffTimePreference |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | eBayPLUSPreference |
 | EIASToken | (Inherited from AbstractResponseType.)
 | EmailShipmentTrackingNumberPreference |
 | EmailShipmentTrackingNumberPreferenceSpecified |
 | EndOfAuctionEmailPreferences |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalShippingProgramListingPreference |
 | GlobalShippingProgramListingPreferenceSpecified |
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | OfferGlobalShippingProgramPreference |
 | OfferGlobalShippingProgramPreferenceSpecified |
 | OutOfStockControlPreference |
 | OutOfStockControlPreferenceSpecified |
 | OverrideGSPServiceWithIntlServicePreference |
 | OverrideGSPServiceWithIntlServicePreferenceSpecified |
 | PickupDropoffSellerPreference |
 | PickupDropoffSellerPreferenceSpecified |
 | ProStoresPreference |
 | PurchaseReminderEmailPreferences |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | RequiredShipPhoneNumberPreference |
 | RequiredShipPhoneNumberPreferenceSpecified |
 | SellerExcludeShipToLocationPreferences |
 | SellerFavoriteItemPreferences |
 | SellerPaymentPreferences |
 | SellerProfilePreferences |
 | SellerReturnPreferences |
 | SellerThirdPartyCheckoutDisabled |
 | SellerThirdPartyCheckoutDisabledSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | UnpaidItemAssistancePreferences |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetUserPreferencesResponseType


BidderNoticePreferences Property

BidderNoticePreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► BidderNoticePreferences
Declaration Syntax
C# Visual Basic Visual C++
public BidderNoticePreferencesType BidderNoticePreferences { get; set; }
Public Property BidderNoticePreferences As BidderNoticePreferencesType
    Get
    Set
public:
property BidderNoticePreferencesType^ BidderNoticePreferences {
    BidderNoticePreferencesType^ get ();
    void set (BidderNoticePreferencesType^ value);
}


CombinedPaymentPreferences Property

CombinedPaymentPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► CombinedPaymentPreferences
Declaration Syntax
C# Visual Basic Visual C++
public CombinedPaymentPreferencesType CombinedPaymentPreferences { get; set; }
Public Property CombinedPaymentPreferences As CombinedPaymentPreferencesType
    Get
    Set
public:
property CombinedPaymentPreferencesType^ CombinedPaymentPreferences {
    CombinedPaymentPreferencesType^ get ();
    void set (CombinedPaymentPreferencesType^ value);
}


CrossPromotionPreferences Property

CrossPromotionPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► CrossPromotionPreferences
Declaration Syntax
C# Visual Basic Visual C++
public CrossPromotionPreferencesType CrossPromotionPreferences { get; set; }
Public Property CrossPromotionPreferences As CrossPromotionPreferencesType
    Get
    Set
public:
property CrossPromotionPreferencesType^ CrossPromotionPreferences {
    CrossPromotionPreferencesType^ get ();
    void set (CrossPromotionPreferencesType^ value);
}


DispatchCutoffTimePreference Property

DispatchCutoffTimePreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► DispatchCutoffTimePreference
Declaration Syntax
C# Visual Basic Visual C++
public DispatchCutoffTimePreferencesType DispatchCutoffTimePreference { get; set; }
Public Property DispatchCutoffTimePreference As DispatchCutoffTimePreferencesType
    Get
    Set
public:
property DispatchCutoffTimePreferencesType^ DispatchCutoffTimePreference {
    DispatchCutoffTimePreferencesType^ get ();
    void set (DispatchCutoffTimePreferencesType^ value);
}


eBayPLUSPreference Property

eBayPLUSPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► eBayPLUSPreference
Declaration Syntax
C# Visual Basic Visual C++
public eBayPLUSPreferenceTypeCollection eBayPLUSPreference { get; set; }
Public Property eBayPLUSPreference As eBayPLUSPreferenceTypeCollection
    Get
    Set
public:
property eBayPLUSPreferenceTypeCollection^ eBayPLUSPreference {
    eBayPLUSPreferenceTypeCollection^ get ();
    void set (eBayPLUSPreferenceTypeCollection^ value);
}


EmailShipmentTrackingNumberPreference Property

EmailShipmentTrackingNumberPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► EmailShipmentTrackingNumberPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailShipmentTrackingNumberPreference { get; set; }
Public Property EmailShipmentTrackingNumberPreference As Boolean
    Get
    Set
public:
property bool EmailShipmentTrackingNumberPreference {
    bool get ();
    void set (bool value);
}


EmailShipmentTrackingNumberPreferenceSpecified Property

EmailShipmentTrackingNumberPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► EmailShipmentTrackingNumberPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailShipmentTrackingNumberPreferenceSpecified { get; set; }
Public Property EmailShipmentTrackingNumberPreferenceSpecified As Boolean
    Get
    Set
public:
property bool EmailShipmentTrackingNumberPreferenceSpecified {
    bool get ();
    void set (bool value);
}


EndOfAuctionEmailPreferences Property

EndOfAuctionEmailPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► EndOfAuctionEmailPreferences
Declaration Syntax
C# Visual Basic Visual C++
public EndOfAuctionEmailPreferencesType EndOfAuctionEmailPreferences { get; set; }
Public Property EndOfAuctionEmailPreferences As EndOfAuctionEmailPreferencesType
    Get
    Set
public:
property EndOfAuctionEmailPreferencesType^ EndOfAuctionEmailPreferences {
    EndOfAuctionEmailPreferencesType^ get ();
    void set (EndOfAuctionEmailPreferencesType^ value);
}


GetUserPreferencesResponseType Constructor

GetUserPreferencesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► GetUserPreferencesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserPreferencesResponseType()
Public Sub New
public:
GetUserPreferencesResponseType()


GlobalShippingProgramListingPreference Property

GlobalShippingProgramListingPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► GlobalShippingProgramListingPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShippingProgramListingPreference { get; set; }
Public Property GlobalShippingProgramListingPreference As Boolean
    Get
    Set
public:
property bool GlobalShippingProgramListingPreference {
    bool get ();
    void set (bool value);
}


GlobalShippingProgramListingPreferenceSpecified Property

GlobalShippingProgramListingPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► GlobalShippingProgramListingPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShippingProgramListingPreferenceSpecified { get; set; }
Public Property GlobalShippingProgramListingPreferenceSpecified As Boolean
    Get
    Set
public:
property bool GlobalShippingProgramListingPreferenceSpecified {
    bool get ();
    void set (bool value);
}


OfferGlobalShippingProgramPreference Property

OfferGlobalShippingProgramPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► OfferGlobalShippingProgramPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool OfferGlobalShippingProgramPreference { get; set; }
Public Property OfferGlobalShippingProgramPreference As Boolean
    Get
    Set
public:
property bool OfferGlobalShippingProgramPreference {
    bool get ();
    void set (bool value);
}


OfferGlobalShippingProgramPreferenceSpecified Property

OfferGlobalShippingProgramPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► OfferGlobalShippingProgramPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OfferGlobalShippingProgramPreferenceSpecified { get; set; }
Public Property OfferGlobalShippingProgramPreferenceSpecified As Boolean
    Get
    Set
public:
property bool OfferGlobalShippingProgramPreferenceSpecified {
    bool get ();
    void set (bool value);
}


OutOfStockControlPreference Property

OutOfStockControlPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► OutOfStockControlPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool OutOfStockControlPreference { get; set; }
Public Property OutOfStockControlPreference As Boolean
    Get
    Set
public:
property bool OutOfStockControlPreference {
    bool get ();
    void set (bool value);
}


OutOfStockControlPreferenceSpecified Property

OutOfStockControlPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► OutOfStockControlPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OutOfStockControlPreferenceSpecified { get; set; }
Public Property OutOfStockControlPreferenceSpecified As Boolean
    Get
    Set
public:
property bool OutOfStockControlPreferenceSpecified {
    bool get ();
    void set (bool value);
}


OverrideGSPServiceWithIntlServicePreference Property

OverrideGSPServiceWithIntlServicePreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► OverrideGSPServiceWithIntlServicePreference
Declaration Syntax
C# Visual Basic Visual C++
public bool OverrideGSPServiceWithIntlServicePreference { get; set; }
Public Property OverrideGSPServiceWithIntlServicePreference As Boolean
    Get
    Set
public:
property bool OverrideGSPServiceWithIntlServicePreference {
    bool get ();
    void set (bool value);
}


OverrideGSPServiceWithIntlServicePreferenceSpecified Property

OverrideGSPServiceWithIntlServicePreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► OverrideGSPServiceWithIntlServicePreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OverrideGSPServiceWithIntlServicePreferenceSpecified { get; set; }
Public Property OverrideGSPServiceWithIntlServicePreferenceSpecified As Boolean
    Get
    Set
public:
property bool OverrideGSPServiceWithIntlServicePreferenceSpecified {
    bool get ();
    void set (bool value);
}


PickupDropoffSellerPreference Property

PickupDropoffSellerPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► PickupDropoffSellerPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool PickupDropoffSellerPreference { get; set; }
Public Property PickupDropoffSellerPreference As Boolean
    Get
    Set
public:
property bool PickupDropoffSellerPreference {
    bool get ();
    void set (bool value);
}


PickupDropoffSellerPreferenceSpecified Property

PickupDropoffSellerPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► PickupDropoffSellerPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PickupDropoffSellerPreferenceSpecified { get; set; }
Public Property PickupDropoffSellerPreferenceSpecified As Boolean
    Get
    Set
public:
property bool PickupDropoffSellerPreferenceSpecified {
    bool get ();
    void set (bool value);
}


ProStoresPreference Property

ProStoresPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► ProStoresPreference
Declaration Syntax
C# Visual Basic Visual C++
public ProStoresCheckoutPreferenceType ProStoresPreference { get; set; }
Public Property ProStoresPreference As ProStoresCheckoutPreferenceType
    Get
    Set
public:
property ProStoresCheckoutPreferenceType^ ProStoresPreference {
    ProStoresCheckoutPreferenceType^ get ();
    void set (ProStoresCheckoutPreferenceType^ value);
}


PurchaseReminderEmailPreferences Property

PurchaseReminderEmailPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► PurchaseReminderEmailPreferences
Declaration Syntax
C# Visual Basic Visual C++
public PurchaseReminderEmailPreferencesType PurchaseReminderEmailPreferences { get; set; }
Public Property PurchaseReminderEmailPreferences As PurchaseReminderEmailPreferencesType
    Get
    Set
public:
property PurchaseReminderEmailPreferencesType^ PurchaseReminderEmailPreferences {
    PurchaseReminderEmailPreferencesType^ get ();
    void set (PurchaseReminderEmailPreferencesType^ value);
}


RequiredShipPhoneNumberPreference Property

RequiredShipPhoneNumberPreference Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► RequiredShipPhoneNumberPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool RequiredShipPhoneNumberPreference { get; set; }
Public Property RequiredShipPhoneNumberPreference As Boolean
    Get
    Set
public:
property bool RequiredShipPhoneNumberPreference {
    bool get ();
    void set (bool value);
}


RequiredShipPhoneNumberPreferenceSpecified Property

RequiredShipPhoneNumberPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► RequiredShipPhoneNumberPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RequiredShipPhoneNumberPreferenceSpecified { get; set; }
Public Property RequiredShipPhoneNumberPreferenceSpecified As Boolean
    Get
    Set
public:
property bool RequiredShipPhoneNumberPreferenceSpecified {
    bool get ();
    void set (bool value);
}


SellerExcludeShipToLocationPreferences Property

SellerExcludeShipToLocationPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► SellerExcludeShipToLocationPreferences
Declaration Syntax
C# Visual Basic Visual C++
public SellerExcludeShipToLocationPreferencesType SellerExcludeShipToLocationPreferences { get; set; }
Public Property SellerExcludeShipToLocationPreferences As SellerExcludeShipToLocationPreferencesType
    Get
    Set
public:
property SellerExcludeShipToLocationPreferencesType^ SellerExcludeShipToLocationPreferences {
    SellerExcludeShipToLocationPreferencesType^ get ();
    void set (SellerExcludeShipToLocationPreferencesType^ value);
}


SellerFavoriteItemPreferences Property

SellerFavoriteItemPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► SellerFavoriteItemPreferences
Declaration Syntax
C# Visual Basic Visual C++
public SellerFavoriteItemPreferencesType SellerFavoriteItemPreferences { get; set; }
Public Property SellerFavoriteItemPreferences As SellerFavoriteItemPreferencesType
    Get
    Set
public:
property SellerFavoriteItemPreferencesType^ SellerFavoriteItemPreferences {
    SellerFavoriteItemPreferencesType^ get ();
    void set (SellerFavoriteItemPreferencesType^ value);
}


SellerPaymentPreferences Property

SellerPaymentPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► SellerPaymentPreferences
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentPreferencesType SellerPaymentPreferences { get; set; }
Public Property SellerPaymentPreferences As SellerPaymentPreferencesType
    Get
    Set
public:
property SellerPaymentPreferencesType^ SellerPaymentPreferences {
    SellerPaymentPreferencesType^ get ();
    void set (SellerPaymentPreferencesType^ value);
}


SellerProfilePreferences Property

SellerProfilePreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► SellerProfilePreferences
Declaration Syntax
C# Visual Basic Visual C++
public SellerProfilePreferencesType SellerProfilePreferences { get; set; }
Public Property SellerProfilePreferences As SellerProfilePreferencesType
    Get
    Set
public:
property SellerProfilePreferencesType^ SellerProfilePreferences {
    SellerProfilePreferencesType^ get ();
    void set (SellerProfilePreferencesType^ value);
}


SellerReturnPreferences Property

SellerReturnPreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► SellerReturnPreferences
Declaration Syntax
C# Visual Basic Visual C++
public SellerReturnPreferencesType SellerReturnPreferences { get; set; }
Public Property SellerReturnPreferences As SellerReturnPreferencesType
    Get
    Set
public:
property SellerReturnPreferencesType^ SellerReturnPreferences {
    SellerReturnPreferencesType^ get ();
    void set (SellerReturnPreferencesType^ value);
}


SellerThirdPartyCheckoutDisabled Property

SellerThirdPartyCheckoutDisabled Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► SellerThirdPartyCheckoutDisabled
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerThirdPartyCheckoutDisabled { get; set; }
Public Property SellerThirdPartyCheckoutDisabled As Boolean
    Get
    Set
public:
property bool SellerThirdPartyCheckoutDisabled {
    bool get ();
    void set (bool value);
}


SellerThirdPartyCheckoutDisabledSpecified Property

SellerThirdPartyCheckoutDisabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► SellerThirdPartyCheckoutDisabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerThirdPartyCheckoutDisabledSpecified { get; set; }
Public Property SellerThirdPartyCheckoutDisabledSpecified As Boolean
    Get
    Set
public:
property bool SellerThirdPartyCheckoutDisabledSpecified {
    bool get ();
    void set (bool value);
}


UnpaidItemAssistancePreferences Property

UnpaidItemAssistancePreferences Property
Namespaces ► eBay.Service.Core.Soap ► GetUserPreferencesResponseType ► UnpaidItemAssistancePreferences
Declaration Syntax
C# Visual Basic Visual C++
public UnpaidItemAssistancePreferencesType UnpaidItemAssistancePreferences { get; set; }
Public Property UnpaidItemAssistancePreferences As UnpaidItemAssistancePreferencesType
    Get
    Set
public:
property UnpaidItemAssistancePreferencesType^ UnpaidItemAssistancePreferences {
    UnpaidItemAssistancePreferencesType^ get ();
    void set (UnpaidItemAssistancePreferencesType^ value);
}


GetUserRequestType Class

GetUserRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetUserRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetUserRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetUserRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetUserRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeExpressRequirements |
 | IncludeExpressRequirementsSpecified |
 | IncludeFeatureEligibility |
 | IncludeFeatureEligibilitySpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | UserID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetUserRequestType


GetUserRequestType Constructor

GetUserRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetUserRequestType ► GetUserRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserRequestType()
Public Sub New
public:
GetUserRequestType()


IncludeExpressRequirements Property

IncludeExpressRequirements Property
Namespaces ► eBay.Service.Core.Soap ► GetUserRequestType ► IncludeExpressRequirements
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeExpressRequirements { get; set; }
Public Property IncludeExpressRequirements As Boolean
    Get
    Set
public:
property bool IncludeExpressRequirements {
    bool get ();
    void set (bool value);
}


IncludeExpressRequirementsSpecified Property

IncludeExpressRequirementsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserRequestType ► IncludeExpressRequirementsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeExpressRequirementsSpecified { get; set; }
Public Property IncludeExpressRequirementsSpecified As Boolean
    Get
    Set
public:
property bool IncludeExpressRequirementsSpecified {
    bool get ();
    void set (bool value);
}


IncludeFeatureEligibility Property

IncludeFeatureEligibility Property
Namespaces ► eBay.Service.Core.Soap ► GetUserRequestType ► IncludeFeatureEligibility
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFeatureEligibility { get; set; }
Public Property IncludeFeatureEligibility As Boolean
    Get
    Set
public:
property bool IncludeFeatureEligibility {
    bool get ();
    void set (bool value);
}


IncludeFeatureEligibilitySpecified Property

IncludeFeatureEligibilitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetUserRequestType ► IncludeFeatureEligibilitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFeatureEligibilitySpecified { get; set; }
Public Property IncludeFeatureEligibilitySpecified As Boolean
    Get
    Set
public:
property bool IncludeFeatureEligibilitySpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetUserRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► GetUserRequestType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


GetUserResponseType Class

GetUserResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetUserResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetUserResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetUserResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetUserResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetUserResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | User |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetUserResponseType


GetUserResponseType Constructor

GetUserResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetUserResponseType ► GetUserResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetUserResponseType()
Public Sub New
public:
GetUserResponseType()


User Property

User Property
Namespaces ► eBay.Service.Core.Soap ► GetUserResponseType ► User
Declaration Syntax
C# Visual Basic Visual C++
public UserType User { get; set; }
Public Property User As UserType
    Get
    Set
public:
property UserType^ User {
    UserType^ get ();
    void set (UserType^ value);
}


GetVeROReasonCodeDetailsRequestType Class

GetVeROReasonCodeDetailsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetVeROReasonCodeDetailsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetVeROReasonCodeDetailsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetVeROReasonCodeDetailsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetVeROReasonCodeDetailsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetVeROReasonCodeDetailsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ReasonCodeID |
 | ReasonCodeIDSpecified |
 | ReturnAllSites |
 | ReturnAllSitesSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetVeROReasonCodeDetailsRequestType


GetVeROReasonCodeDetailsRequestType Constructor

GetVeROReasonCodeDetailsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetVeROReasonCodeDetailsRequestType ► GetVeROReasonCodeDetailsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReasonCodeDetailsRequestType()
Public Sub New
public:
GetVeROReasonCodeDetailsRequestType()


ReasonCodeID Property

ReasonCodeID Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReasonCodeDetailsRequestType ► ReasonCodeID
Declaration Syntax
C# Visual Basic Visual C++
public long ReasonCodeID { get; set; }
Public Property ReasonCodeID As Long
    Get
    Set
public:
property long long ReasonCodeID {
    long long get ();
    void set (long long value);
}


ReasonCodeIDSpecified Property

ReasonCodeIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReasonCodeDetailsRequestType ► ReasonCodeIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReasonCodeIDSpecified { get; set; }
Public Property ReasonCodeIDSpecified As Boolean
    Get
    Set
public:
property bool ReasonCodeIDSpecified {
    bool get ();
    void set (bool value);
}


ReturnAllSites Property

ReturnAllSites Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReasonCodeDetailsRequestType ► ReturnAllSites
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnAllSites { get; set; }
Public Property ReturnAllSites As Boolean
    Get
    Set
public:
property bool ReturnAllSites {
    bool get ();
    void set (bool value);
}


ReturnAllSitesSpecified Property

ReturnAllSitesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReasonCodeDetailsRequestType ► ReturnAllSitesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnAllSitesSpecified { get; set; }
Public Property ReturnAllSitesSpecified As Boolean
    Get
    Set
public:
property bool ReturnAllSitesSpecified {
    bool get ();
    void set (bool value);
}


GetVeROReasonCodeDetailsResponseType Class

GetVeROReasonCodeDetailsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetVeROReasonCodeDetailsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetVeROReasonCodeDetailsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetVeROReasonCodeDetailsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetVeROReasonCodeDetailsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetVeROReasonCodeDetailsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | VeROReasonCodeDetails |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetVeROReasonCodeDetailsResponseType


GetVeROReasonCodeDetailsResponseType Constructor

GetVeROReasonCodeDetailsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetVeROReasonCodeDetailsResponseType ► GetVeROReasonCodeDetailsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReasonCodeDetailsResponseType()
Public Sub New
public:
GetVeROReasonCodeDetailsResponseType()


VeROReasonCodeDetails Property

VeROReasonCodeDetails Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReasonCodeDetailsResponseType ► VeROReasonCodeDetails
Declaration Syntax
C# Visual Basic Visual C++
public VeROSiteDetailTypeCollection VeROReasonCodeDetails { get; set; }
Public Property VeROReasonCodeDetails As VeROSiteDetailTypeCollection
    Get
    Set
public:
property VeROSiteDetailTypeCollection^ VeROReasonCodeDetails {
    VeROSiteDetailTypeCollection^ get ();
    void set (VeROSiteDetailTypeCollection^ value);
}


GetVeROReportStatusRequestType Class

GetVeROReportStatusRequestType Class
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetVeROReportStatusRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetVeROReportStatusRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetVeROReportStatusRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetVeROReportStatusRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeReportedItemDetails |
 | IncludeReportedItemDetailsSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Pagination |
 | TimeFrom |
 | TimeFromSpecified |
 | TimeTo |
 | TimeToSpecified |
 | ToString()()()() | (Inherited from Object.)
 | VeROReportPacketID |
 | VeROReportPacketIDSpecified |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | GetVeROReportStatusRequestType


GetVeROReportStatusRequestType Constructor

GetVeROReportStatusRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType ► GetVeROReportStatusRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReportStatusRequestType()
Public Sub New
public:
GetVeROReportStatusRequestType()


IncludeReportedItemDetails Property

IncludeReportedItemDetails Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType ► IncludeReportedItemDetails
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeReportedItemDetails { get; set; }
Public Property IncludeReportedItemDetails As Boolean
    Get
    Set
public:
property bool IncludeReportedItemDetails {
    bool get ();
    void set (bool value);
}


IncludeReportedItemDetailsSpecified Property

IncludeReportedItemDetailsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType ► IncludeReportedItemDetailsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeReportedItemDetailsSpecified { get; set; }
Public Property IncludeReportedItemDetailsSpecified As Boolean
    Get
    Set
public:
property bool IncludeReportedItemDetailsSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


TimeFrom Property

TimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType ► TimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeFrom { get; set; }
Public Property TimeFrom As DateTime
    Get
    Set
public:
property DateTime TimeFrom {
    DateTime get ();
    void set (DateTime value);
}


TimeFromSpecified Property

TimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType ► TimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TimeFromSpecified { get; set; }
Public Property TimeFromSpecified As Boolean
    Get
    Set
public:
property bool TimeFromSpecified {
    bool get ();
    void set (bool value);
}


TimeTo Property

TimeTo Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType ► TimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeTo { get; set; }
Public Property TimeTo As DateTime
    Get
    Set
public:
property DateTime TimeTo {
    DateTime get ();
    void set (DateTime value);
}


TimeToSpecified Property

TimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType ► TimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TimeToSpecified { get; set; }
Public Property TimeToSpecified As Boolean
    Get
    Set
public:
property bool TimeToSpecified {
    bool get ();
    void set (bool value);
}


VeROReportPacketID Property

VeROReportPacketID Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType ► VeROReportPacketID
Declaration Syntax
C# Visual Basic Visual C++
public long VeROReportPacketID { get; set; }
Public Property VeROReportPacketID As Long
    Get
    Set
public:
property long long VeROReportPacketID {
    long long get ();
    void set (long long value);
}


VeROReportPacketIDSpecified Property

VeROReportPacketIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusRequestType ► VeROReportPacketIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VeROReportPacketIDSpecified { get; set; }
Public Property VeROReportPacketIDSpecified As Boolean
    Get
    Set
public:
property bool VeROReportPacketIDSpecified {
    bool get ();
    void set (bool value);
}


GetVeROReportStatusResponseType Class

GetVeROReportStatusResponseType Class
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GetVeROReportStatusResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GetVeROReportStatusResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GetVeROReportStatusResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GetVeROReportStatusResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | HasMoreItems |
 | HasMoreItemsSpecified |
 | ItemsPerPage |
 | ItemsPerPageSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PageNumber |
 | PageNumberSpecified |
 | PaginationResult |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | ReportedItemDetails |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | VeROReportPacketID |
 | VeROReportPacketIDSpecified |
 | VeROReportPacketStatus |
 | VeROReportPacketStatusSpecified |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | GetVeROReportStatusResponseType


GetVeROReportStatusResponseType Constructor

GetVeROReportStatusResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► GetVeROReportStatusResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GetVeROReportStatusResponseType()
Public Sub New
public:
GetVeROReportStatusResponseType()


HasMoreItems Property

HasMoreItems Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► HasMoreItems
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreItems { get; set; }
Public Property HasMoreItems As Boolean
    Get
    Set
public:
property bool HasMoreItems {
    bool get ();
    void set (bool value);
}


HasMoreItemsSpecified Property

HasMoreItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► HasMoreItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HasMoreItemsSpecified { get; set; }
Public Property HasMoreItemsSpecified As Boolean
    Get
    Set
public:
property bool HasMoreItemsSpecified {
    bool get ();
    void set (bool value);
}


ItemsPerPage Property

ItemsPerPage Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► ItemsPerPage
Declaration Syntax
C# Visual Basic Visual C++
public int ItemsPerPage { get; set; }
Public Property ItemsPerPage As Integer
    Get
    Set
public:
property int ItemsPerPage {
    int get ();
    void set (int value);
}


ItemsPerPageSpecified Property

ItemsPerPageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► ItemsPerPageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemsPerPageSpecified { get; set; }
Public Property ItemsPerPageSpecified As Boolean
    Get
    Set
public:
property bool ItemsPerPageSpecified {
    bool get ();
    void set (bool value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► PageNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}


PageNumberSpecified Property

PageNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► PageNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageNumberSpecified { get; set; }
Public Property PageNumberSpecified As Boolean
    Get
    Set
public:
property bool PageNumberSpecified {
    bool get ();
    void set (bool value);
}


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


ReportedItemDetails Property

ReportedItemDetails Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► ReportedItemDetails
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportedItemTypeCollection ReportedItemDetails { get; set; }
Public Property ReportedItemDetails As VeROReportedItemTypeCollection
    Get
    Set
public:
property VeROReportedItemTypeCollection^ ReportedItemDetails {
    VeROReportedItemTypeCollection^ get ();
    void set (VeROReportedItemTypeCollection^ value);
}


VeROReportPacketID Property

VeROReportPacketID Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► VeROReportPacketID
Declaration Syntax
C# Visual Basic Visual C++
public long VeROReportPacketID { get; set; }
Public Property VeROReportPacketID As Long
    Get
    Set
public:
property long long VeROReportPacketID {
    long long get ();
    void set (long long value);
}


VeROReportPacketIDSpecified Property

VeROReportPacketIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► VeROReportPacketIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VeROReportPacketIDSpecified { get; set; }
Public Property VeROReportPacketIDSpecified As Boolean
    Get
    Set
public:
property bool VeROReportPacketIDSpecified {
    bool get ();
    void set (bool value);
}


VeROReportPacketStatus Property

VeROReportPacketStatus Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► VeROReportPacketStatus
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportPacketStatusCodeType VeROReportPacketStatus { get; set; }
Public Property VeROReportPacketStatus As VeROReportPacketStatusCodeType
    Get
    Set
public:
property VeROReportPacketStatusCodeType VeROReportPacketStatus {
    VeROReportPacketStatusCodeType get ();
    void set (VeROReportPacketStatusCodeType value);
}


VeROReportPacketStatusSpecified Property

VeROReportPacketStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► GetVeROReportStatusResponseType ► VeROReportPacketStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VeROReportPacketStatusSpecified { get; set; }
Public Property VeROReportPacketStatusSpecified As Boolean
    Get
    Set
public:
property bool VeROReportPacketStatusSpecified {
    bool get ();
    void set (bool value);
}


GiftIconCodeType Enumeration

GiftIconCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► GiftIconCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum GiftIconCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration GiftIconCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class GiftIconCodeType
Members
Member | Description
Enabled |
Disabled |
CustomCode |
Remarks


GiftServicesCodeType Enumeration

GiftServicesCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum GiftServicesCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration GiftServicesCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class GiftServicesCodeType
Members
Member | Description
GiftExpressShipping |
GiftShipToRecipient |
GiftWrap |
CustomCode |
Remarks


GiftServicesCodeTypeCollection Class

GiftServicesCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class GiftServicesCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class GiftServicesCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class GiftServicesCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GiftServicesCodeTypeCollection()()()() |
 | GiftServicesCodeTypeCollection(array<GiftServicesCodeType>[]()[][]) |
 | GiftServicesCodeTypeCollection(GiftServicesCodeTypeCollection) |
 | Add(GiftServicesCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<GiftServicesCodeType>[]()[][]) |
 | AddRange(GiftServicesCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(GiftServicesCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<GiftServicesCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(GiftServicesCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, GiftServicesCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(GiftServicesCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | GiftServicesCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► Add(GiftServicesCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    GiftServicesCodeType item
)
Public Function Add ( _
    item As GiftServicesCodeType _
) As Integer
public:
int Add(
    GiftServicesCodeType item
)
Parameters
item (GiftServicesCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<GiftServicesCodeType>[]()[][]) |
 | AddRange(GiftServicesCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► AddRange(array<GiftServicesCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    GiftServicesCodeType[] items
)
Public Sub AddRange ( _
    items As GiftServicesCodeType() _
)
public:
void AddRange(
    array<GiftServicesCodeType>^ items
)
Parameters
items (array< GiftServicesCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► AddRange(GiftServicesCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    GiftServicesCodeTypeCollection items
)
Public Sub AddRange ( _
    items As GiftServicesCodeTypeCollection _
)
public:
void AddRange(
    GiftServicesCodeTypeCollection^ items
)
Parameters
items (GiftServicesCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► Contains(GiftServicesCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    GiftServicesCodeType item
)
Public Function Contains ( _
    item As GiftServicesCodeType _
) As Boolean
public:
bool Contains(
    GiftServicesCodeType item
)
Parameters
item (GiftServicesCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► CopyTo(array<GiftServicesCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    GiftServicesCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As GiftServicesCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<GiftServicesCodeType>^ items,
    int index
)
Parameters
items (array< GiftServicesCodeType >[]()[][])
index (Int32)


GiftServicesCodeTypeCollection Constructor

GiftServicesCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► GiftServicesCodeTypeCollection()()()()
Members
Icon | Member | Description
 | GiftServicesCodeTypeCollection()()()() |
 | GiftServicesCodeTypeCollection(array<GiftServicesCodeType>[]()[][]) |
 | GiftServicesCodeTypeCollection(GiftServicesCodeTypeCollection) |


GiftServicesCodeTypeCollection Constructor

GiftServicesCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► GiftServicesCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GiftServicesCodeTypeCollection()
Public Sub New
public:
GiftServicesCodeTypeCollection()


GiftServicesCodeTypeCollection Constructor (items)

GiftServicesCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► GiftServicesCodeTypeCollection(array<GiftServicesCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public GiftServicesCodeTypeCollection(
    GiftServicesCodeType[] items
)
Public Sub New ( _
    items As GiftServicesCodeType() _
)
public:
GiftServicesCodeTypeCollection(
    array<GiftServicesCodeType>^ items
)
Parameters
items (array< GiftServicesCodeType >[]()[][])


GiftServicesCodeTypeCollection Constructor (items)

GiftServicesCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► GiftServicesCodeTypeCollection(GiftServicesCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public GiftServicesCodeTypeCollection(
    GiftServicesCodeTypeCollection items
)
Public Sub New ( _
    items As GiftServicesCodeTypeCollection _
)
public:
GiftServicesCodeTypeCollection(
    GiftServicesCodeTypeCollection^ items
)
Parameters
items (GiftServicesCodeTypeCollection)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► IndexOf(GiftServicesCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    GiftServicesCodeType item
)
Public Function IndexOf ( _
    item As GiftServicesCodeType _
) As Integer
public:
int IndexOf(
    GiftServicesCodeType item
)
Parameters
item (GiftServicesCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► Insert(Int32, GiftServicesCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    GiftServicesCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As GiftServicesCodeType _
)
public:
void Insert(
    int index,
    GiftServicesCodeType item
)
Parameters
index (Int32)
item (GiftServicesCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public GiftServicesCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As GiftServicesCodeType
    Get
    Set
public:
property GiftServicesCodeType default[int index] {
    GiftServicesCodeType get (int index);
    void set (int index, GiftServicesCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public GiftServicesCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As GiftServicesCodeType
public:
GiftServicesCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► Remove(GiftServicesCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    GiftServicesCodeType item
)
Public Sub Remove ( _
    item As GiftServicesCodeType _
)
public:
void Remove(
    GiftServicesCodeType item
)
Parameters
item (GiftServicesCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GiftServicesCodeType[] ToArray()
Public Function ToArray As GiftServicesCodeType()
public:
array<GiftServicesCodeType>^ ToArray()
Return Value


GiftSummaryType Class

GiftSummaryType Class
Namespaces ► eBay.Service.Core.Soap ► GiftSummaryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GiftSummaryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GiftSummaryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GiftSummaryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GiftSummaryType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
GiftSummaryType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► GiftSummaryType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


GiftSummaryType Constructor

GiftSummaryType Constructor
Namespaces ► eBay.Service.Core.Soap ► GiftSummaryType ► GiftSummaryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GiftSummaryType()
Public Sub New
public:
GiftSummaryType()


Message Property

Message Property
Namespaces ► eBay.Service.Core.Soap ► GiftSummaryType ► Message
Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


GlobalShippingEnabledDefinitionType Class

GlobalShippingEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► GlobalShippingEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class GlobalShippingEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class GlobalShippingEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class GlobalShippingEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GlobalShippingEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
GlobalShippingEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► GlobalShippingEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


GlobalShippingEnabledDefinitionType Constructor

GlobalShippingEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► GlobalShippingEnabledDefinitionType ► GlobalShippingEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public GlobalShippingEnabledDefinitionType()
Public Sub New
public:
GlobalShippingEnabledDefinitionType()


GranularityLevelCodeType Enumeration

GranularityLevelCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► GranularityLevelCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum GranularityLevelCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration GranularityLevelCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class GranularityLevelCodeType
Members
Member | Description
Coarse |
Fine |
Medium |
CustomCode |
Remarks


Group1MaxFlatShippingCostDefinitionType Class

Group1MaxFlatShippingCostDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► Group1MaxFlatShippingCostDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class Group1MaxFlatShippingCostDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class Group1MaxFlatShippingCostDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class Group1MaxFlatShippingCostDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Group1MaxFlatShippingCostDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
Group1MaxFlatShippingCostDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► Group1MaxFlatShippingCostDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Group1MaxFlatShippingCostDefinitionType Constructor

Group1MaxFlatShippingCostDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► Group1MaxFlatShippingCostDefinitionType ► Group1MaxFlatShippingCostDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Group1MaxFlatShippingCostDefinitionType()
Public Sub New
public:
Group1MaxFlatShippingCostDefinitionType()


Group2MaxFlatShippingCostDefinitionType Class

Group2MaxFlatShippingCostDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► Group2MaxFlatShippingCostDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class Group2MaxFlatShippingCostDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class Group2MaxFlatShippingCostDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class Group2MaxFlatShippingCostDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Group2MaxFlatShippingCostDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
Group2MaxFlatShippingCostDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► Group2MaxFlatShippingCostDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Group2MaxFlatShippingCostDefinitionType Constructor

Group2MaxFlatShippingCostDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► Group2MaxFlatShippingCostDefinitionType ► Group2MaxFlatShippingCostDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Group2MaxFlatShippingCostDefinitionType()
Public Sub New
public:
Group2MaxFlatShippingCostDefinitionType()


Group3MaxFlatShippingCostDefinitionType Class

Group3MaxFlatShippingCostDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► Group3MaxFlatShippingCostDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class Group3MaxFlatShippingCostDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class Group3MaxFlatShippingCostDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class Group3MaxFlatShippingCostDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Group3MaxFlatShippingCostDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
Group3MaxFlatShippingCostDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► Group3MaxFlatShippingCostDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Group3MaxFlatShippingCostDefinitionType Constructor

Group3MaxFlatShippingCostDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► Group3MaxFlatShippingCostDefinitionType ► Group3MaxFlatShippingCostDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Group3MaxFlatShippingCostDefinitionType()
Public Sub New
public:
Group3MaxFlatShippingCostDefinitionType()


HandlingNameCodeType Enumeration

HandlingNameCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► HandlingNameCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum HandlingNameCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration HandlingNameCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class HandlingNameCodeType
Members
Member | Description
EachAdditionalAmount |
EachAdditionalAmountOff |
EachAdditionalPercentOff |
IndividualHandlingFee |
CombinedHandlingFee |
CustomCode |
Remarks


HandlingTimeEnabledDefinitionType Class

HandlingTimeEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► HandlingTimeEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class HandlingTimeEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class HandlingTimeEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class HandlingTimeEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HandlingTimeEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
HandlingTimeEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► HandlingTimeEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


HandlingTimeEnabledDefinitionType Constructor

HandlingTimeEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► HandlingTimeEnabledDefinitionType ► HandlingTimeEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public HandlingTimeEnabledDefinitionType()
Public Sub New
public:
HandlingTimeEnabledDefinitionType()


HighlightCodeType Enumeration

HighlightCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► HighlightCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum HighlightCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration HighlightCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class HighlightCodeType
Members
Member | Description
Enabled |
Disabled |
CustomCode |
Remarks


HitCounterCodeType Enumeration

HitCounterCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► HitCounterCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum HitCounterCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration HitCounterCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class HitCounterCodeType
Members
Member | Description
NoHitCounter |
HonestyStyle |
GreenLED |
Hidden |
BasicStyle |
RetroStyle |
HiddenStyle |
CustomCode |
Remarks


HomePageFeaturedCodeType Enumeration

HomePageFeaturedCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► HomePageFeaturedCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum HomePageFeaturedCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration HomePageFeaturedCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class HomePageFeaturedCodeType
Members
Member | Description
Enabled |
Disabled |
CustomCode |
Remarks


HomePageFeaturedEnabledDefinitionType Class

HomePageFeaturedEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► HomePageFeaturedEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class HomePageFeaturedEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class HomePageFeaturedEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class HomePageFeaturedEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HomePageFeaturedEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
HomePageFeaturedEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► HomePageFeaturedEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


HomePageFeaturedEnabledDefinitionType Constructor

HomePageFeaturedEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► HomePageFeaturedEnabledDefinitionType ► HomePageFeaturedEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public HomePageFeaturedEnabledDefinitionType()
Public Sub New
public:
HomePageFeaturedEnabledDefinitionType()


INEscrowWorkflowTimelineCodeType Enumeration

INEscrowWorkflowTimelineCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► INEscrowWorkflowTimelineCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum INEscrowWorkflowTimelineCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration INEscrowWorkflowTimelineCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class INEscrowWorkflowTimelineCodeType
Members
Member | Description
Default |
WorkflowA |
WorkflowB |
CustomCode |
Remarks


INEscrowWorkflowTimelineDefinitionType Class

INEscrowWorkflowTimelineDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► INEscrowWorkflowTimelineDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class INEscrowWorkflowTimelineDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class INEscrowWorkflowTimelineDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class INEscrowWorkflowTimelineDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | INEscrowWorkflowTimelineDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
INEscrowWorkflowTimelineDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► INEscrowWorkflowTimelineDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


INEscrowWorkflowTimelineDefinitionType Constructor

INEscrowWorkflowTimelineDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► INEscrowWorkflowTimelineDefinitionType ► INEscrowWorkflowTimelineDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public INEscrowWorkflowTimelineDefinitionType()
Public Sub New
public:
INEscrowWorkflowTimelineDefinitionType()


InquiryStatusCodeType Enumeration

InquiryStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► InquiryStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum InquiryStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration InquiryStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class InquiryStatusCodeType
Members
Member | Description
Invalid |
NotApplicable |
TrackInquiryPendingBuyerResponse |
TrackInquiryPendingSellerResponse |
TrackInquiryClosedWithRefund |
TrackInquiryClosedNoRefund |
TrackInquiryEscalatedPendingBuyer |
TrackInquiryEscalatedPendingSeller |
TrackInquiryEscalatedPendingCS |
TrackInquiryEscalatedClosedWithRefund |
TrackInquiryEscalatedClosedNoRefund |
CustomCode |
Remarks


InsuranceDetailsType Class

InsuranceDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► InsuranceDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class InsuranceDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class InsuranceDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class InsuranceDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InsuranceDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InsuranceFee |
 | InsuranceOption |
 | InsuranceOptionSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
InsuranceDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► InsuranceDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


InsuranceDetailsType Constructor

InsuranceDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► InsuranceDetailsType ► InsuranceDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceDetailsType()
Public Sub New
public:
InsuranceDetailsType()


InsuranceFee Property

InsuranceFee Property
Namespaces ► eBay.Service.Core.Soap ► InsuranceDetailsType ► InsuranceFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType InsuranceFee { get; set; }
Public Property InsuranceFee As AmountType
    Get
    Set
public:
property AmountType^ InsuranceFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


InsuranceOption Property

InsuranceOption Property
Namespaces ► eBay.Service.Core.Soap ► InsuranceDetailsType ► InsuranceOption
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceOptionCodeType InsuranceOption { get; set; }
Public Property InsuranceOption As InsuranceOptionCodeType
    Get
    Set
public:
property InsuranceOptionCodeType InsuranceOption {
    InsuranceOptionCodeType get ();
    void set (InsuranceOptionCodeType value);
}


InsuranceOptionSpecified Property

InsuranceOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► InsuranceDetailsType ► InsuranceOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InsuranceOptionSpecified { get; set; }
Public Property InsuranceOptionSpecified As Boolean
    Get
    Set
public:
property bool InsuranceOptionSpecified {
    bool get ();
    void set (bool value);
}


InsuranceOptionCodeType Enumeration

InsuranceOptionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► InsuranceOptionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum InsuranceOptionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration InsuranceOptionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class InsuranceOptionCodeType
Members
Member | Description
Optional |
Required |
NotOffered |
IncludedInShippingHandling |
NotOfferedOnSite |
CustomCode |
Remarks


InsuranceSelectedCodeType Enumeration

InsuranceSelectedCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► InsuranceSelectedCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum InsuranceSelectedCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration InsuranceSelectedCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class InsuranceSelectedCodeType
Members
Member | Description
NotOffered |
OfferedNotSelected |
OfferedSelected |
Required |
IncludedInShippingHandling |
CustomCode |
Remarks


Int32Collection Class

Int32Collection Class
Namespaces ► eBay.Service.Core.Soap ► Int32Collection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class Int32Collection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class Int32Collection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class Int32Collection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Int32Collection()()()() |
 | Int32Collection(array<Int32>[]()[][]) |
 | Int32Collection(Int32Collection) |
 | Add(Int32) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<Int32>[]()[][]) |
 | AddRange(Int32Collection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(Int32) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<Int32>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(Int32) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, Int32) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(Int32) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | Int32Collection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Add(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    int item
)
Public Function Add ( _
    item As Integer _
) As Integer
public:
int Add(
    int item
)
Parameters
item (Int32)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<Int32>[]()[][]) |
 | AddRange(Int32Collection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► AddRange(Int32Collection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    Int32Collection items
)
Public Sub AddRange ( _
    items As Int32Collection _
)
public:
void AddRange(
    Int32Collection^ items
)
Parameters
items (Int32Collection)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► AddRange(array<Int32>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    int[] items
)
Public Sub AddRange ( _
    items As Integer() _
)
public:
void AddRange(
    array<int>^ items
)
Parameters
items (array< Int32 >[]()[][])


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Contains(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    int item
)
Public Function Contains ( _
    item As Integer _
) As Boolean
public:
bool Contains(
    int item
)
Parameters
item (Int32)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► CopyTo(array<Int32>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    int[] items,
    int index
)
Public Sub CopyTo ( _
    items As Integer(), _
    index As Integer _
)
public:
void CopyTo(
    array<int>^ items,
    int index
)
Parameters
items (array< Int32 >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► IndexOf(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    int item
)
Public Function IndexOf ( _
    item As Integer _
) As Integer
public:
int IndexOf(
    int item
)
Parameters
item (Int32)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Insert(Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    int item
)
Public Sub Insert ( _
    index As Integer, _
    item As Integer _
)
public:
void Insert(
    int index,
    int item
)
Parameters
index (Int32)
item (Int32)


Int32Collection Constructor

Int32Collection Constructor
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Int32Collection()()()()
Members
Icon | Member | Description
 | Int32Collection()()()() |
 | Int32Collection(array<Int32>[]()[][]) |
 | Int32Collection(Int32Collection) |


Int32Collection Constructor

Int32Collection Constructor
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Int32Collection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection()
Public Sub New
public:
Int32Collection()


Int32Collection Constructor (items)

Int32Collection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Int32Collection(Int32Collection)
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection(
    Int32Collection items
)
Public Sub New ( _
    items As Int32Collection _
)
public:
Int32Collection(
    Int32Collection^ items
)
Parameters
items (Int32Collection)


Int32Collection Constructor (items)

Int32Collection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Int32Collection(array<Int32>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection(
    int[] items
)
Public Sub New ( _
    items As Integer() _
)
public:
Int32Collection(
    array<int>^ items
)
Parameters
items (array< Int32 >[]()[][])


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public int this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Integer
    Get
    Set
public:
property int default[int index] {
    int get (int index);
    void set (int index, int value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public int ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As Integer
public:
int ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Remove(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    int item
)
Public Sub Remove ( _
    item As Integer _
)
public:
void Remove(
    int item
)
Parameters
item (Int32)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public int[] ToArray()
Public Function ToArray As Integer()
public:
array<int>^ ToArray()
Return Value


Int64Collection Class

Int64Collection Class
Namespaces ► eBay.Service.Core.Soap ► Int64Collection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class Int64Collection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class Int64Collection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class Int64Collection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Int64Collection()()()() |
 | Int64Collection(array<Int64>[]()[][]) |
 | Int64Collection(Int64Collection) |
 | Add(Int64) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<Int64>[]()[][]) |
 | AddRange(Int64Collection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(Int64) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<Int64>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(Int64) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, Int64) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(Int64) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | Int64Collection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Add(Int64)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    long item
)
Public Function Add ( _
    item As Long _
) As Integer
public:
int Add(
    long long item
)
Parameters
item (Int64)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<Int64>[]()[][]) |
 | AddRange(Int64Collection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► AddRange(Int64Collection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    Int64Collection items
)
Public Sub AddRange ( _
    items As Int64Collection _
)
public:
void AddRange(
    Int64Collection^ items
)
Parameters
items (Int64Collection)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► AddRange(array<Int64>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    long[] items
)
Public Sub AddRange ( _
    items As Long() _
)
public:
void AddRange(
    array<long long>^ items
)
Parameters
items (array< Int64 >[]()[][])


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Contains(Int64)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    long item
)
Public Function Contains ( _
    item As Long _
) As Boolean
public:
bool Contains(
    long long item
)
Parameters
item (Int64)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► CopyTo(array<Int64>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    long[] items,
    int index
)
Public Sub CopyTo ( _
    items As Long(), _
    index As Integer _
)
public:
void CopyTo(
    array<long long>^ items,
    int index
)
Parameters
items (array< Int64 >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► IndexOf(Int64)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    long item
)
Public Function IndexOf ( _
    item As Long _
) As Integer
public:
int IndexOf(
    long long item
)
Parameters
item (Int64)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Insert(Int32, Int64)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    long item
)
Public Sub Insert ( _
    index As Integer, _
    item As Long _
)
public:
void Insert(
    int index,
    long long item
)
Parameters
index (Int32)
item (Int64)


Int64Collection Constructor

Int64Collection Constructor
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Int64Collection()()()()
Members
Icon | Member | Description
 | Int64Collection()()()() |
 | Int64Collection(array<Int64>[]()[][]) |
 | Int64Collection(Int64Collection) |


Int64Collection Constructor

Int64Collection Constructor
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Int64Collection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Int64Collection()
Public Sub New
public:
Int64Collection()


Int64Collection Constructor (items)

Int64Collection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Int64Collection(Int64Collection)
Declaration Syntax
C# Visual Basic Visual C++
public Int64Collection(
    Int64Collection items
)
Public Sub New ( _
    items As Int64Collection _
)
public:
Int64Collection(
    Int64Collection^ items
)
Parameters
items (Int64Collection)


Int64Collection Constructor (items)

Int64Collection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Int64Collection(array<Int64>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public Int64Collection(
    long[] items
)
Public Sub New ( _
    items As Long() _
)
public:
Int64Collection(
    array<long long>^ items
)
Parameters
items (array< Int64 >[]()[][])


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public long this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Long
    Get
    Set
public:
property long long default[int index] {
    long long get (int index);
    void set (int index, long long value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public long ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As Long
public:
long long ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Remove(Int64)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    long item
)
Public Sub Remove ( _
    item As Long _
)
public:
void Remove(
    long long item
)
Parameters
item (Int64)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public long[] ToArray()
Public Function ToArray As Long()
public:
array<long long>^ ToArray()
Return Value


IntegratedMerchantCreditCardInfoType Class

IntegratedMerchantCreditCardInfoType Class
Namespaces ► eBay.Service.Core.Soap ► IntegratedMerchantCreditCardInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class IntegratedMerchantCreditCardInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class IntegratedMerchantCreditCardInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class IntegratedMerchantCreditCardInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntegratedMerchantCreditCardInfoType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SupportedSite |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
IntegratedMerchantCreditCardInfoType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► IntegratedMerchantCreditCardInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


IntegratedMerchantCreditCardInfoType Constructor

IntegratedMerchantCreditCardInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► IntegratedMerchantCreditCardInfoType ► IntegratedMerchantCreditCardInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IntegratedMerchantCreditCardInfoType()
Public Sub New
public:
IntegratedMerchantCreditCardInfoType()


SupportedSite Property

SupportedSite Property
Namespaces ► eBay.Service.Core.Soap ► IntegratedMerchantCreditCardInfoType ► SupportedSite
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeTypeCollection SupportedSite { get; set; }
Public Property SupportedSite As SiteCodeTypeCollection
    Get
    Set
public:
property SiteCodeTypeCollection^ SupportedSite {
    SiteCodeTypeCollection^ get ();
    void set (SiteCodeTypeCollection^ value);
}


InternationalShippingServiceOptionsType Class

InternationalShippingServiceOptionsType Class
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class InternationalShippingServiceOptionsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class InternationalShippingServiceOptionsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class InternationalShippingServiceOptionsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InternationalShippingServiceOptionsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ImportCharge |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingInsuranceCost |
 | ShippingService |
 | ShippingServiceAdditionalCost |
 | ShippingServiceCost |
 | ShippingServiceCutOffTime |
 | ShippingServiceCutOffTimeSpecified |
 | ShippingServicePriority |
 | ShippingServicePrioritySpecified |
 | ShipToLocation |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
InternationalShippingServiceOptionsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ImportCharge Property

ImportCharge Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► ImportCharge
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ImportCharge { get; set; }
Public Property ImportCharge As AmountType
    Get
    Set
public:
property AmountType^ ImportCharge {
    AmountType^ get ();
    void set (AmountType^ value);
}


InternationalShippingServiceOptionsType Constructor

InternationalShippingServiceOptionsType Constructor
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► InternationalShippingServiceOptionsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public InternationalShippingServiceOptionsType()
Public Sub New
public:
InternationalShippingServiceOptionsType()


ShippingInsuranceCost Property

ShippingInsuranceCost Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► ShippingInsuranceCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingInsuranceCost { get; set; }
Public Property ShippingInsuranceCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingInsuranceCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingService Property

ShippingService Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► ShippingService
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingService { get; set; }
Public Property ShippingService As String
    Get
    Set
public:
property String^ ShippingService {
    String^ get ();
    void set (String^ value);
}


ShippingServiceAdditionalCost Property

ShippingServiceAdditionalCost Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► ShippingServiceAdditionalCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingServiceAdditionalCost { get; set; }
Public Property ShippingServiceAdditionalCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingServiceAdditionalCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingServiceCost Property

ShippingServiceCost Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► ShippingServiceCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingServiceCost { get; set; }
Public Property ShippingServiceCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingServiceCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingServiceCutOffTime Property

ShippingServiceCutOffTime Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► ShippingServiceCutOffTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ShippingServiceCutOffTime { get; set; }
Public Property ShippingServiceCutOffTime As DateTime
    Get
    Set
public:
property DateTime ShippingServiceCutOffTime {
    DateTime get ();
    void set (DateTime value);
}


ShippingServiceCutOffTimeSpecified Property

ShippingServiceCutOffTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► ShippingServiceCutOffTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingServiceCutOffTimeSpecified { get; set; }
Public Property ShippingServiceCutOffTimeSpecified As Boolean
    Get
    Set
public:
property bool ShippingServiceCutOffTimeSpecified {
    bool get ();
    void set (bool value);
}


ShippingServicePriority Property

ShippingServicePriority Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► ShippingServicePriority
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingServicePriority { get; set; }
Public Property ShippingServicePriority As Integer
    Get
    Set
public:
property int ShippingServicePriority {
    int get ();
    void set (int value);
}


ShippingServicePrioritySpecified Property

ShippingServicePrioritySpecified Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► ShippingServicePrioritySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingServicePrioritySpecified { get; set; }
Public Property ShippingServicePrioritySpecified As Boolean
    Get
    Set
public:
property bool ShippingServicePrioritySpecified {
    bool get ();
    void set (bool value);
}


ShipToLocation Property

ShipToLocation Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsType ► ShipToLocation
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ShipToLocation { get; set; }
Public Property ShipToLocation As StringCollection
    Get
    Set
public:
property StringCollection^ ShipToLocation {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


InternationalShippingServiceOptionsTypeCollection Class

InternationalShippingServiceOptionsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class InternationalShippingServiceOptionsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class InternationalShippingServiceOptionsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class InternationalShippingServiceOptionsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InternationalShippingServiceOptionsTypeCollection()()()() |
 | InternationalShippingServiceOptionsTypeCollection(array<InternationalShippingServiceOptionsType>[]()[][]) |
 | InternationalShippingServiceOptionsTypeCollection(InternationalShippingServiceOptionsTypeCollection) |
 | Add(InternationalShippingServiceOptionsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<InternationalShippingServiceOptionsType>[]()[][]) |
 | AddRange(InternationalShippingServiceOptionsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(InternationalShippingServiceOptionsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<InternationalShippingServiceOptionsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(InternationalShippingServiceOptionsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, InternationalShippingServiceOptionsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(InternationalShippingServiceOptionsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | InternationalShippingServiceOptionsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► Add(InternationalShippingServiceOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    InternationalShippingServiceOptionsType item
)
Public Function Add ( _
    item As InternationalShippingServiceOptionsType _
) As Integer
public:
int Add(
    InternationalShippingServiceOptionsType^ item
)
Parameters
item (InternationalShippingServiceOptionsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<InternationalShippingServiceOptionsType>[]()[][]) |
 | AddRange(InternationalShippingServiceOptionsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► AddRange(array<InternationalShippingServiceOptionsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    InternationalShippingServiceOptionsType[] items
)
Public Sub AddRange ( _
    items As InternationalShippingServiceOptionsType() _
)
public:
void AddRange(
    array<InternationalShippingServiceOptionsType^>^ items
)
Parameters
items (array< InternationalShippingServiceOptionsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► AddRange(InternationalShippingServiceOptionsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    InternationalShippingServiceOptionsTypeCollection items
)
Public Sub AddRange ( _
    items As InternationalShippingServiceOptionsTypeCollection _
)
public:
void AddRange(
    InternationalShippingServiceOptionsTypeCollection^ items
)
Parameters
items (InternationalShippingServiceOptionsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► Contains(InternationalShippingServiceOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    InternationalShippingServiceOptionsType item
)
Public Function Contains ( _
    item As InternationalShippingServiceOptionsType _
) As Boolean
public:
bool Contains(
    InternationalShippingServiceOptionsType^ item
)
Parameters
item (InternationalShippingServiceOptionsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► CopyTo(array<InternationalShippingServiceOptionsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    InternationalShippingServiceOptionsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As InternationalShippingServiceOptionsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<InternationalShippingServiceOptionsType^>^ items,
    int index
)
Parameters
items (array< InternationalShippingServiceOptionsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► IndexOf(InternationalShippingServiceOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    InternationalShippingServiceOptionsType item
)
Public Function IndexOf ( _
    item As InternationalShippingServiceOptionsType _
) As Integer
public:
int IndexOf(
    InternationalShippingServiceOptionsType^ item
)
Parameters
item (InternationalShippingServiceOptionsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► Insert(Int32, InternationalShippingServiceOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    InternationalShippingServiceOptionsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As InternationalShippingServiceOptionsType _
)
public:
void Insert(
    int index,
    InternationalShippingServiceOptionsType^ item
)
Parameters
index (Int32)
item (InternationalShippingServiceOptionsType)


InternationalShippingServiceOptionsTypeCollection Constructor

InternationalShippingServiceOptionsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► InternationalShippingServiceOptionsTypeCollection()()()()
Members
Icon | Member | Description
 | InternationalShippingServiceOptionsTypeCollection()()()() |
 | InternationalShippingServiceOptionsTypeCollection(array<InternationalShippingServiceOptionsType>[]()[][]) |
 | InternationalShippingServiceOptionsTypeCollection(InternationalShippingServiceOptionsTypeCollection) |


InternationalShippingServiceOptionsTypeCollection Constructor

InternationalShippingServiceOptionsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► InternationalShippingServiceOptionsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public InternationalShippingServiceOptionsTypeCollection()
Public Sub New
public:
InternationalShippingServiceOptionsTypeCollection()


InternationalShippingServiceOptionsTypeCollection Constructor (items)

InternationalShippingServiceOptionsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► InternationalShippingServiceOptionsTypeCollection(array<InternationalShippingServiceOptionsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public InternationalShippingServiceOptionsTypeCollection(
    InternationalShippingServiceOptionsType[] items
)
Public Sub New ( _
    items As InternationalShippingServiceOptionsType() _
)
public:
InternationalShippingServiceOptionsTypeCollection(
    array<InternationalShippingServiceOptionsType^>^ items
)
Parameters
items (array< InternationalShippingServiceOptionsType >[]()[][])


InternationalShippingServiceOptionsTypeCollection Constructor (items)

InternationalShippingServiceOptionsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► InternationalShippingServiceOptionsTypeCollection(InternationalShippingServiceOptionsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public InternationalShippingServiceOptionsTypeCollection(
    InternationalShippingServiceOptionsTypeCollection items
)
Public Sub New ( _
    items As InternationalShippingServiceOptionsTypeCollection _
)
public:
InternationalShippingServiceOptionsTypeCollection(
    InternationalShippingServiceOptionsTypeCollection^ items
)
Parameters
items (InternationalShippingServiceOptionsTypeCollection)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public InternationalShippingServiceOptionsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As InternationalShippingServiceOptionsType
    Get
    Set
public:
property InternationalShippingServiceOptionsType^ default[int index] {
    InternationalShippingServiceOptionsType^ get (int index);
    void set (int index, InternationalShippingServiceOptionsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public InternationalShippingServiceOptionsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As InternationalShippingServiceOptionsType
public:
InternationalShippingServiceOptionsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► Remove(InternationalShippingServiceOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    InternationalShippingServiceOptionsType item
)
Public Sub Remove ( _
    item As InternationalShippingServiceOptionsType _
)
public:
void Remove(
    InternationalShippingServiceOptionsType^ item
)
Parameters
item (InternationalShippingServiceOptionsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public InternationalShippingServiceOptionsType[] ToArray()
Public Function ToArray As InternationalShippingServiceOptionsType()
public:
array<InternationalShippingServiceOptionsType^>^ ToArray()
Return Value


InventoryFeesType Class

InventoryFeesType Class
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class InventoryFeesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class InventoryFeesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class InventoryFeesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InventoryFeesType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Fee |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
InventoryFeesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Fee Property

Fee Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesType ► Fee
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fee { get; set; }
Public Property Fee As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fee {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


InventoryFeesType Constructor

InventoryFeesType Constructor
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesType ► InventoryFeesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public InventoryFeesType()
Public Sub New
public:
InventoryFeesType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


InventoryFeesTypeCollection Class

InventoryFeesTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class InventoryFeesTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class InventoryFeesTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class InventoryFeesTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InventoryFeesTypeCollection()()()() |
 | InventoryFeesTypeCollection(array<InventoryFeesType>[]()[][]) |
 | InventoryFeesTypeCollection(InventoryFeesTypeCollection) |
 | Add(InventoryFeesType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<InventoryFeesType>[]()[][]) |
 | AddRange(InventoryFeesTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(InventoryFeesType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<InventoryFeesType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(InventoryFeesType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, InventoryFeesType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(InventoryFeesType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | InventoryFeesTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► Add(InventoryFeesType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    InventoryFeesType item
)
Public Function Add ( _
    item As InventoryFeesType _
) As Integer
public:
int Add(
    InventoryFeesType^ item
)
Parameters
item (InventoryFeesType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<InventoryFeesType>[]()[][]) |
 | AddRange(InventoryFeesTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► AddRange(array<InventoryFeesType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    InventoryFeesType[] items
)
Public Sub AddRange ( _
    items As InventoryFeesType() _
)
public:
void AddRange(
    array<InventoryFeesType^>^ items
)
Parameters
items (array< InventoryFeesType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► AddRange(InventoryFeesTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    InventoryFeesTypeCollection items
)
Public Sub AddRange ( _
    items As InventoryFeesTypeCollection _
)
public:
void AddRange(
    InventoryFeesTypeCollection^ items
)
Parameters
items (InventoryFeesTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► Contains(InventoryFeesType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    InventoryFeesType item
)
Public Function Contains ( _
    item As InventoryFeesType _
) As Boolean
public:
bool Contains(
    InventoryFeesType^ item
)
Parameters
item (InventoryFeesType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► CopyTo(array<InventoryFeesType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    InventoryFeesType[] items,
    int index
)
Public Sub CopyTo ( _
    items As InventoryFeesType(), _
    index As Integer _
)
public:
void CopyTo(
    array<InventoryFeesType^>^ items,
    int index
)
Parameters
items (array< InventoryFeesType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► IndexOf(InventoryFeesType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    InventoryFeesType item
)
Public Function IndexOf ( _
    item As InventoryFeesType _
) As Integer
public:
int IndexOf(
    InventoryFeesType^ item
)
Parameters
item (InventoryFeesType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► Insert(Int32, InventoryFeesType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    InventoryFeesType item
)
Public Sub Insert ( _
    index As Integer, _
    item As InventoryFeesType _
)
public:
void Insert(
    int index,
    InventoryFeesType^ item
)
Parameters
index (Int32)
item (InventoryFeesType)


InventoryFeesTypeCollection Constructor

InventoryFeesTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► InventoryFeesTypeCollection()()()()
Members
Icon | Member | Description
 | InventoryFeesTypeCollection()()()() |
 | InventoryFeesTypeCollection(array<InventoryFeesType>[]()[][]) |
 | InventoryFeesTypeCollection(InventoryFeesTypeCollection) |


InventoryFeesTypeCollection Constructor

InventoryFeesTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► InventoryFeesTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public InventoryFeesTypeCollection()
Public Sub New
public:
InventoryFeesTypeCollection()


InventoryFeesTypeCollection Constructor (items)

InventoryFeesTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► InventoryFeesTypeCollection(array<InventoryFeesType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public InventoryFeesTypeCollection(
    InventoryFeesType[] items
)
Public Sub New ( _
    items As InventoryFeesType() _
)
public:
InventoryFeesTypeCollection(
    array<InventoryFeesType^>^ items
)
Parameters
items (array< InventoryFeesType >[]()[][])


InventoryFeesTypeCollection Constructor (items)

InventoryFeesTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► InventoryFeesTypeCollection(InventoryFeesTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public InventoryFeesTypeCollection(
    InventoryFeesTypeCollection items
)
Public Sub New ( _
    items As InventoryFeesTypeCollection _
)
public:
InventoryFeesTypeCollection(
    InventoryFeesTypeCollection^ items
)
Parameters
items (InventoryFeesTypeCollection)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public InventoryFeesType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As InventoryFeesType
    Get
    Set
public:
property InventoryFeesType^ default[int index] {
    InventoryFeesType^ get (int index);
    void set (int index, InventoryFeesType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public InventoryFeesType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As InventoryFeesType
public:
InventoryFeesType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► Remove(InventoryFeesType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    InventoryFeesType item
)
Public Sub Remove ( _
    item As InventoryFeesType _
)
public:
void Remove(
    InventoryFeesType^ item
)
Parameters
item (InventoryFeesType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public InventoryFeesType[] ToArray()
Public Function ToArray As InventoryFeesType()
public:
array<InventoryFeesType^>^ ToArray()
Return Value


InventoryStatusType Class

InventoryStatusType Class
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class InventoryStatusType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class InventoryStatusType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class InventoryStatusType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InventoryStatusType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Quantity |
 | QuantitySpecified |
 | SKU |
 | StartPrice |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
InventoryStatusType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


InventoryStatusType Constructor

InventoryStatusType Constructor
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusType ► InventoryStatusType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusType()
Public Sub New
public:
InventoryStatusType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusType ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public int Quantity { get; set; }
Public Property Quantity As Integer
    Get
    Set
public:
property int Quantity {
    int get ();
    void set (int value);
}


QuantitySpecified Property

QuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusType ► QuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySpecified { get; set; }
Public Property QuantitySpecified As Boolean
    Get
    Set
public:
property bool QuantitySpecified {
    bool get ();
    void set (bool value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


StartPrice Property

StartPrice Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusType ► StartPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType StartPrice { get; set; }
Public Property StartPrice As AmountType
    Get
    Set
public:
property AmountType^ StartPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


InventoryStatusTypeCollection Class

InventoryStatusTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class InventoryStatusTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class InventoryStatusTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class InventoryStatusTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InventoryStatusTypeCollection()()()() |
 | InventoryStatusTypeCollection(array<InventoryStatusType>[]()[][]) |
 | InventoryStatusTypeCollection(InventoryStatusTypeCollection) |
 | Add(InventoryStatusType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<InventoryStatusType>[]()[][]) |
 | AddRange(InventoryStatusTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(InventoryStatusType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<InventoryStatusType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(InventoryStatusType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, InventoryStatusType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(InventoryStatusType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | InventoryStatusTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► Add(InventoryStatusType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    InventoryStatusType item
)
Public Function Add ( _
    item As InventoryStatusType _
) As Integer
public:
int Add(
    InventoryStatusType^ item
)
Parameters
item (InventoryStatusType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<InventoryStatusType>[]()[][]) |
 | AddRange(InventoryStatusTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► AddRange(array<InventoryStatusType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    InventoryStatusType[] items
)
Public Sub AddRange ( _
    items As InventoryStatusType() _
)
public:
void AddRange(
    array<InventoryStatusType^>^ items
)
Parameters
items (array< InventoryStatusType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► AddRange(InventoryStatusTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    InventoryStatusTypeCollection items
)
Public Sub AddRange ( _
    items As InventoryStatusTypeCollection _
)
public:
void AddRange(
    InventoryStatusTypeCollection^ items
)
Parameters
items (InventoryStatusTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► Contains(InventoryStatusType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    InventoryStatusType item
)
Public Function Contains ( _
    item As InventoryStatusType _
) As Boolean
public:
bool Contains(
    InventoryStatusType^ item
)
Parameters
item (InventoryStatusType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► CopyTo(array<InventoryStatusType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    InventoryStatusType[] items,
    int index
)
Public Sub CopyTo ( _
    items As InventoryStatusType(), _
    index As Integer _
)
public:
void CopyTo(
    array<InventoryStatusType^>^ items,
    int index
)
Parameters
items (array< InventoryStatusType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► IndexOf(InventoryStatusType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    InventoryStatusType item
)
Public Function IndexOf ( _
    item As InventoryStatusType _
) As Integer
public:
int IndexOf(
    InventoryStatusType^ item
)
Parameters
item (InventoryStatusType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► Insert(Int32, InventoryStatusType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    InventoryStatusType item
)
Public Sub Insert ( _
    index As Integer, _
    item As InventoryStatusType _
)
public:
void Insert(
    int index,
    InventoryStatusType^ item
)
Parameters
index (Int32)
item (InventoryStatusType)


InventoryStatusTypeCollection Constructor

InventoryStatusTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► InventoryStatusTypeCollection()()()()
Members
Icon | Member | Description
 | InventoryStatusTypeCollection()()()() |
 | InventoryStatusTypeCollection(array<InventoryStatusType>[]()[][]) |
 | InventoryStatusTypeCollection(InventoryStatusTypeCollection) |


InventoryStatusTypeCollection Constructor

InventoryStatusTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► InventoryStatusTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusTypeCollection()
Public Sub New
public:
InventoryStatusTypeCollection()


InventoryStatusTypeCollection Constructor (items)

InventoryStatusTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► InventoryStatusTypeCollection(array<InventoryStatusType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusTypeCollection(
    InventoryStatusType[] items
)
Public Sub New ( _
    items As InventoryStatusType() _
)
public:
InventoryStatusTypeCollection(
    array<InventoryStatusType^>^ items
)
Parameters
items (array< InventoryStatusType >[]()[][])


InventoryStatusTypeCollection Constructor (items)

InventoryStatusTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► InventoryStatusTypeCollection(InventoryStatusTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusTypeCollection(
    InventoryStatusTypeCollection items
)
Public Sub New ( _
    items As InventoryStatusTypeCollection _
)
public:
InventoryStatusTypeCollection(
    InventoryStatusTypeCollection^ items
)
Parameters
items (InventoryStatusTypeCollection)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As InventoryStatusType
    Get
    Set
public:
property InventoryStatusType^ default[int index] {
    InventoryStatusType^ get (int index);
    void set (int index, InventoryStatusType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As InventoryStatusType
public:
InventoryStatusType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► Remove(InventoryStatusType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    InventoryStatusType item
)
Public Sub Remove ( _
    item As InventoryStatusType _
)
public:
void Remove(
    InventoryStatusType^ item
)
Parameters
item (InventoryStatusType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusType[] ToArray()
Public Function ToArray As InventoryStatusType()
public:
array<InventoryStatusType^>^ ToArray()
Return Value


InventoryTrackingMethodCodeType Enumeration

InventoryTrackingMethodCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► InventoryTrackingMethodCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum InventoryTrackingMethodCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration InventoryTrackingMethodCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class InventoryTrackingMethodCodeType
Members
Member | Description
ItemID |
SKU |
CustomCode |
Remarks


InvocationStatusType Enumeration

InvocationStatusType Enumeration
Namespaces ► eBay.Service.Core.Soap ► InvocationStatusType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum InvocationStatusType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration InvocationStatusType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class InvocationStatusType
Members
Member | Description
InProgress |
Success |
Failure |
CustomCode |
Remarks


ISBNEnabledDefinitionType Class

ISBNEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ISBNEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ISBNEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ISBNEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ISBNEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ISBNEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ISBNEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ISBNEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ISBNEnabledDefinitionType Constructor

ISBNEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ISBNEnabledDefinitionType ► ISBNEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ISBNEnabledDefinitionType()
Public Sub New
public:
ISBNEnabledDefinitionType()


ISBNIdentifierEnabledDefinitionType Class

ISBNIdentifierEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ISBNIdentifierEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ISBNIdentifierEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ISBNIdentifierEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ISBNIdentifierEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ISBNIdentifierEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ISBNIdentifierEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ISBNIdentifierEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ISBNIdentifierEnabledDefinitionType Constructor

ISBNIdentifierEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ISBNIdentifierEnabledDefinitionType ► ISBNIdentifierEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ISBNIdentifierEnabledDefinitionType()
Public Sub New
public:
ISBNIdentifierEnabledDefinitionType()


IssueRefundRequestType Class

IssueRefundRequestType Class
Namespaces ► eBay.Service.Core.Soap ► IssueRefundRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class IssueRefundRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class IssueRefundRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class IssueRefundRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IssueRefundRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | RefundAmount |
 | RefundMessage |
 | RefundReason |
 | RefundReasonSpecified |
 | RefundType |
 | RefundTypeSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | IssueRefundRequestType


IssueRefundRequestType Constructor

IssueRefundRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► IssueRefundRequestType ► IssueRefundRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IssueRefundRequestType()
Public Sub New
public:
IssueRefundRequestType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► IssueRefundRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► IssueRefundRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


RefundAmount Property

RefundAmount Property
Namespaces ► eBay.Service.Core.Soap ► IssueRefundRequestType ► RefundAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType RefundAmount { get; set; }
Public Property RefundAmount As AmountType
    Get
    Set
public:
property AmountType^ RefundAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


RefundMessage Property

RefundMessage Property
Namespaces ► eBay.Service.Core.Soap ► IssueRefundRequestType ► RefundMessage
Declaration Syntax
C# Visual Basic Visual C++
public string RefundMessage { get; set; }
Public Property RefundMessage As String
    Get
    Set
public:
property String^ RefundMessage {
    String^ get ();
    void set (String^ value);
}


RefundReason Property

RefundReason Property
Namespaces ► eBay.Service.Core.Soap ► IssueRefundRequestType ► RefundReason
Declaration Syntax
C# Visual Basic Visual C++
public RefundReasonCodeType RefundReason { get; set; }
Public Property RefundReason As RefundReasonCodeType
    Get
    Set
public:
property RefundReasonCodeType RefundReason {
    RefundReasonCodeType get ();
    void set (RefundReasonCodeType value);
}


RefundReasonSpecified Property

RefundReasonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► IssueRefundRequestType ► RefundReasonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundReasonSpecified { get; set; }
Public Property RefundReasonSpecified As Boolean
    Get
    Set
public:
property bool RefundReasonSpecified {
    bool get ();
    void set (bool value);
}


RefundType Property

RefundType Property
Namespaces ► eBay.Service.Core.Soap ► IssueRefundRequestType ► RefundType
Declaration Syntax
C# Visual Basic Visual C++
public RefundTypeCodeType RefundType { get; set; }
Public Property RefundType As RefundTypeCodeType
    Get
    Set
public:
property RefundTypeCodeType RefundType {
    RefundTypeCodeType get ();
    void set (RefundTypeCodeType value);
}


RefundTypeSpecified Property

RefundTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► IssueRefundRequestType ► RefundTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundTypeSpecified { get; set; }
Public Property RefundTypeSpecified As Boolean
    Get
    Set
public:
property bool RefundTypeSpecified {
    bool get ();
    void set (bool value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► IssueRefundRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


IssueRefundResponseType Class

IssueRefundResponseType Class
Namespaces ► eBay.Service.Core.Soap ► IssueRefundResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class IssueRefundResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class IssueRefundResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class IssueRefundResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IssueRefundResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | RefundFromSeller |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | TotalRefundToBuyer |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | IssueRefundResponseType


IssueRefundResponseType Constructor

IssueRefundResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► IssueRefundResponseType ► IssueRefundResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IssueRefundResponseType()
Public Sub New
public:
IssueRefundResponseType()


RefundFromSeller Property

RefundFromSeller Property
Namespaces ► eBay.Service.Core.Soap ► IssueRefundResponseType ► RefundFromSeller
Declaration Syntax
C# Visual Basic Visual C++
public AmountType RefundFromSeller { get; set; }
Public Property RefundFromSeller As AmountType
    Get
    Set
public:
property AmountType^ RefundFromSeller {
    AmountType^ get ();
    void set (AmountType^ value);
}


TotalRefundToBuyer Property

TotalRefundToBuyer Property
Namespaces ► eBay.Service.Core.Soap ► IssueRefundResponseType ► TotalRefundToBuyer
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalRefundToBuyer { get; set; }
Public Property TotalRefundToBuyer As AmountType
    Get
    Set
public:
property AmountType^ TotalRefundToBuyer {
    AmountType^ get ();
    void set (AmountType^ value);
}


ItemArrivedWithinEDDCodeType Enumeration

ItemArrivedWithinEDDCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ItemArrivedWithinEDDCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ItemArrivedWithinEDDCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ItemArrivedWithinEDDCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ItemArrivedWithinEDDCodeType
Members
Member | Description
EddQuestionWasNotAsked |
BuyerDidntProvideAnswer |
BuyerIndicatedItemArrivedWithinEDDRange |
BuyerIndicatedItemNotArrivedWithinEDDRange |
CustomCode |
Remarks


ItemBestOffersArrayType Class

ItemBestOffersArrayType Class
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersArrayType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemBestOffersArrayType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemBestOffersArrayType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemBestOffersArrayType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemBestOffersArrayType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemBestOffers |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ItemBestOffersArrayType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersArrayType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemBestOffers Property

ItemBestOffers Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersArrayType ► ItemBestOffers
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersTypeCollection ItemBestOffers { get; set; }
Public Property ItemBestOffers As ItemBestOffersTypeCollection
    Get
    Set
public:
property ItemBestOffersTypeCollection^ ItemBestOffers {
    ItemBestOffersTypeCollection^ get ();
    void set (ItemBestOffersTypeCollection^ value);
}


ItemBestOffersArrayType Constructor

ItemBestOffersArrayType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersArrayType ► ItemBestOffersArrayType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersArrayType()
Public Sub New
public:
ItemBestOffersArrayType()


ItemBestOffersType Class

ItemBestOffersType Class
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemBestOffersType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemBestOffersType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemBestOffersType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemBestOffersType()()()() |
 | Any |
 | BestOfferArray |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Role |
 | RoleSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ItemBestOffersType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestOfferArray Property

BestOfferArray Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersType ► BestOfferArray
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection BestOfferArray { get; set; }
Public Property BestOfferArray As BestOfferTypeCollection
    Get
    Set
public:
property BestOfferTypeCollection^ BestOfferArray {
    BestOfferTypeCollection^ get ();
    void set (BestOfferTypeCollection^ value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ItemBestOffersType Constructor

ItemBestOffersType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersType ► ItemBestOffersType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersType()
Public Sub New
public:
ItemBestOffersType()


Role Property

Role Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersType ► Role
Declaration Syntax
C# Visual Basic Visual C++
public TradingRoleCodeType Role { get; set; }
Public Property Role As TradingRoleCodeType
    Get
    Set
public:
property TradingRoleCodeType Role {
    TradingRoleCodeType get ();
    void set (TradingRoleCodeType value);
}


RoleSpecified Property

RoleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersType ► RoleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RoleSpecified { get; set; }
Public Property RoleSpecified As Boolean
    Get
    Set
public:
property bool RoleSpecified {
    bool get ();
    void set (bool value);
}


ItemBestOffersTypeCollection Class

ItemBestOffersTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ItemBestOffersTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ItemBestOffersTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ItemBestOffersTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemBestOffersTypeCollection()()()() |
 | ItemBestOffersTypeCollection(array<ItemBestOffersType>[]()[][]) |
 | ItemBestOffersTypeCollection(ItemBestOffersTypeCollection) |
 | Add(ItemBestOffersType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ItemBestOffersType>[]()[][]) |
 | AddRange(ItemBestOffersTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ItemBestOffersType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ItemBestOffersType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ItemBestOffersType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ItemBestOffersType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ItemBestOffersType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ItemBestOffersTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► Add(ItemBestOffersType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ItemBestOffersType item
)
Public Function Add ( _
    item As ItemBestOffersType _
) As Integer
public:
int Add(
    ItemBestOffersType^ item
)
Parameters
item (ItemBestOffersType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ItemBestOffersType>[]()[][]) |
 | AddRange(ItemBestOffersTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► AddRange(array<ItemBestOffersType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemBestOffersType[] items
)
Public Sub AddRange ( _
    items As ItemBestOffersType() _
)
public:
void AddRange(
    array<ItemBestOffersType^>^ items
)
Parameters
items (array< ItemBestOffersType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► AddRange(ItemBestOffersTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemBestOffersTypeCollection items
)
Public Sub AddRange ( _
    items As ItemBestOffersTypeCollection _
)
public:
void AddRange(
    ItemBestOffersTypeCollection^ items
)
Parameters
items (ItemBestOffersTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► Contains(ItemBestOffersType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ItemBestOffersType item
)
Public Function Contains ( _
    item As ItemBestOffersType _
) As Boolean
public:
bool Contains(
    ItemBestOffersType^ item
)
Parameters
item (ItemBestOffersType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► CopyTo(array<ItemBestOffersType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ItemBestOffersType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ItemBestOffersType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ItemBestOffersType^>^ items,
    int index
)
Parameters
items (array< ItemBestOffersType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► IndexOf(ItemBestOffersType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ItemBestOffersType item
)
Public Function IndexOf ( _
    item As ItemBestOffersType _
) As Integer
public:
int IndexOf(
    ItemBestOffersType^ item
)
Parameters
item (ItemBestOffersType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► Insert(Int32, ItemBestOffersType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ItemBestOffersType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ItemBestOffersType _
)
public:
void Insert(
    int index,
    ItemBestOffersType^ item
)
Parameters
index (Int32)
item (ItemBestOffersType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ItemBestOffersType
    Get
    Set
public:
property ItemBestOffersType^ default[int index] {
    ItemBestOffersType^ get (int index);
    void set (int index, ItemBestOffersType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ItemBestOffersType
public:
ItemBestOffersType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ItemBestOffersTypeCollection Constructor

ItemBestOffersTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► ItemBestOffersTypeCollection()()()()
Members
Icon | Member | Description
 | ItemBestOffersTypeCollection()()()() |
 | ItemBestOffersTypeCollection(array<ItemBestOffersType>[]()[][]) |
 | ItemBestOffersTypeCollection(ItemBestOffersTypeCollection) |


ItemBestOffersTypeCollection Constructor

ItemBestOffersTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► ItemBestOffersTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersTypeCollection()
Public Sub New
public:
ItemBestOffersTypeCollection()


ItemBestOffersTypeCollection Constructor (items)

ItemBestOffersTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► ItemBestOffersTypeCollection(array<ItemBestOffersType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersTypeCollection(
    ItemBestOffersType[] items
)
Public Sub New ( _
    items As ItemBestOffersType() _
)
public:
ItemBestOffersTypeCollection(
    array<ItemBestOffersType^>^ items
)
Parameters
items (array< ItemBestOffersType >[]()[][])


ItemBestOffersTypeCollection Constructor (items)

ItemBestOffersTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► ItemBestOffersTypeCollection(ItemBestOffersTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersTypeCollection(
    ItemBestOffersTypeCollection items
)
Public Sub New ( _
    items As ItemBestOffersTypeCollection _
)
public:
ItemBestOffersTypeCollection(
    ItemBestOffersTypeCollection^ items
)
Parameters
items (ItemBestOffersTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► Remove(ItemBestOffersType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ItemBestOffersType item
)
Public Sub Remove ( _
    item As ItemBestOffersType _
)
public:
void Remove(
    ItemBestOffersType^ item
)
Parameters
item (ItemBestOffersType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemBestOffersType[] ToArray()
Public Function ToArray As ItemBestOffersType()
public:
array<ItemBestOffersType^>^ ToArray()
Return Value


ItemBidDetailsType Class

ItemBidDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemBidDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemBidDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemBidDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemBidDetailsType()()()() |
 | Any |
 | BidCount |
 | BidCountSpecified |
 | CategoryID |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | LastBidTime |
 | LastBidTimeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SellerID |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ItemBidDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidCount Property

BidCount Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsType ► BidCount
Declaration Syntax
C# Visual Basic Visual C++
public int BidCount { get; set; }
Public Property BidCount As Integer
    Get
    Set
public:
property int BidCount {
    int get ();
    void set (int value);
}


BidCountSpecified Property

BidCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsType ► BidCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidCountSpecified { get; set; }
Public Property BidCountSpecified As Boolean
    Get
    Set
public:
property bool BidCountSpecified {
    bool get ();
    void set (bool value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


ItemBidDetailsType Constructor

ItemBidDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsType ► ItemBidDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemBidDetailsType()
Public Sub New
public:
ItemBidDetailsType()


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


LastBidTime Property

LastBidTime Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsType ► LastBidTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastBidTime { get; set; }
Public Property LastBidTime As DateTime
    Get
    Set
public:
property DateTime LastBidTime {
    DateTime get ();
    void set (DateTime value);
}


LastBidTimeSpecified Property

LastBidTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsType ► LastBidTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastBidTimeSpecified { get; set; }
Public Property LastBidTimeSpecified As Boolean
    Get
    Set
public:
property bool LastBidTimeSpecified {
    bool get ();
    void set (bool value);
}


SellerID Property

SellerID Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsType ► SellerID
Declaration Syntax
C# Visual Basic Visual C++
public string SellerID { get; set; }
Public Property SellerID As String
    Get
    Set
public:
property String^ SellerID {
    String^ get ();
    void set (String^ value);
}


ItemBidDetailsTypeCollection Class

ItemBidDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ItemBidDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ItemBidDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ItemBidDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemBidDetailsTypeCollection()()()() |
 | ItemBidDetailsTypeCollection(array<ItemBidDetailsType>[]()[][]) |
 | ItemBidDetailsTypeCollection(ItemBidDetailsTypeCollection) |
 | Add(ItemBidDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ItemBidDetailsType>[]()[][]) |
 | AddRange(ItemBidDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ItemBidDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ItemBidDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ItemBidDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ItemBidDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ItemBidDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ItemBidDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► Add(ItemBidDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ItemBidDetailsType item
)
Public Function Add ( _
    item As ItemBidDetailsType _
) As Integer
public:
int Add(
    ItemBidDetailsType^ item
)
Parameters
item (ItemBidDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ItemBidDetailsType>[]()[][]) |
 | AddRange(ItemBidDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► AddRange(array<ItemBidDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemBidDetailsType[] items
)
Public Sub AddRange ( _
    items As ItemBidDetailsType() _
)
public:
void AddRange(
    array<ItemBidDetailsType^>^ items
)
Parameters
items (array< ItemBidDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► AddRange(ItemBidDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemBidDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ItemBidDetailsTypeCollection _
)
public:
void AddRange(
    ItemBidDetailsTypeCollection^ items
)
Parameters
items (ItemBidDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► Contains(ItemBidDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ItemBidDetailsType item
)
Public Function Contains ( _
    item As ItemBidDetailsType _
) As Boolean
public:
bool Contains(
    ItemBidDetailsType^ item
)
Parameters
item (ItemBidDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► CopyTo(array<ItemBidDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ItemBidDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ItemBidDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ItemBidDetailsType^>^ items,
    int index
)
Parameters
items (array< ItemBidDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► IndexOf(ItemBidDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ItemBidDetailsType item
)
Public Function IndexOf ( _
    item As ItemBidDetailsType _
) As Integer
public:
int IndexOf(
    ItemBidDetailsType^ item
)
Parameters
item (ItemBidDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► Insert(Int32, ItemBidDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ItemBidDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ItemBidDetailsType _
)
public:
void Insert(
    int index,
    ItemBidDetailsType^ item
)
Parameters
index (Int32)
item (ItemBidDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ItemBidDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ItemBidDetailsType
    Get
    Set
public:
property ItemBidDetailsType^ default[int index] {
    ItemBidDetailsType^ get (int index);
    void set (int index, ItemBidDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ItemBidDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ItemBidDetailsType
public:
ItemBidDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ItemBidDetailsTypeCollection Constructor

ItemBidDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► ItemBidDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ItemBidDetailsTypeCollection()()()() |
 | ItemBidDetailsTypeCollection(array<ItemBidDetailsType>[]()[][]) |
 | ItemBidDetailsTypeCollection(ItemBidDetailsTypeCollection) |


ItemBidDetailsTypeCollection Constructor

ItemBidDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► ItemBidDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemBidDetailsTypeCollection()
Public Sub New
public:
ItemBidDetailsTypeCollection()


ItemBidDetailsTypeCollection Constructor (items)

ItemBidDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► ItemBidDetailsTypeCollection(array<ItemBidDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ItemBidDetailsTypeCollection(
    ItemBidDetailsType[] items
)
Public Sub New ( _
    items As ItemBidDetailsType() _
)
public:
ItemBidDetailsTypeCollection(
    array<ItemBidDetailsType^>^ items
)
Parameters
items (array< ItemBidDetailsType >[]()[][])


ItemBidDetailsTypeCollection Constructor (items)

ItemBidDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► ItemBidDetailsTypeCollection(ItemBidDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ItemBidDetailsTypeCollection(
    ItemBidDetailsTypeCollection items
)
Public Sub New ( _
    items As ItemBidDetailsTypeCollection _
)
public:
ItemBidDetailsTypeCollection(
    ItemBidDetailsTypeCollection^ items
)
Parameters
items (ItemBidDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► Remove(ItemBidDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ItemBidDetailsType item
)
Public Sub Remove ( _
    item As ItemBidDetailsType _
)
public:
void Remove(
    ItemBidDetailsType^ item
)
Parameters
item (ItemBidDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemBidDetailsType[] ToArray()
Public Function ToArray As ItemBidDetailsType()
public:
array<ItemBidDetailsType^>^ ToArray()
Return Value


ItemCompatibilityEnabledCodeType Enumeration

ItemCompatibilityEnabledCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityEnabledCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ItemCompatibilityEnabledCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ItemCompatibilityEnabledCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ItemCompatibilityEnabledCodeType
Members
Member | Description
Disabled |
ByApplication |
BySpecification |
CustomCode |
Remarks


ItemCompatibilityEnabledDefinitionType Class

ItemCompatibilityEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemCompatibilityEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemCompatibilityEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemCompatibilityEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemCompatibilityEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ItemCompatibilityEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemCompatibilityEnabledDefinitionType Constructor

ItemCompatibilityEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityEnabledDefinitionType ► ItemCompatibilityEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityEnabledDefinitionType()
Public Sub New
public:
ItemCompatibilityEnabledDefinitionType()


ItemCompatibilityListType Class

ItemCompatibilityListType Class
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityListType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemCompatibilityListType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemCompatibilityListType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemCompatibilityListType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemCompatibilityListType()()()() |
 | Any |
 | Compatibility |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReplaceAll |
 | ReplaceAllSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ItemCompatibilityListType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityListType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Compatibility Property

Compatibility Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityListType ► Compatibility
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityTypeCollection Compatibility { get; set; }
Public Property Compatibility As ItemCompatibilityTypeCollection
    Get
    Set
public:
property ItemCompatibilityTypeCollection^ Compatibility {
    ItemCompatibilityTypeCollection^ get ();
    void set (ItemCompatibilityTypeCollection^ value);
}


ItemCompatibilityListType Constructor

ItemCompatibilityListType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityListType ► ItemCompatibilityListType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityListType()
Public Sub New
public:
ItemCompatibilityListType()


ReplaceAll Property

ReplaceAll Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityListType ► ReplaceAll
Declaration Syntax
C# Visual Basic Visual C++
public bool ReplaceAll { get; set; }
Public Property ReplaceAll As Boolean
    Get
    Set
public:
property bool ReplaceAll {
    bool get ();
    void set (bool value);
}


ReplaceAllSpecified Property

ReplaceAllSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityListType ► ReplaceAllSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReplaceAllSpecified { get; set; }
Public Property ReplaceAllSpecified As Boolean
    Get
    Set
public:
property bool ReplaceAllSpecified {
    bool get ();
    void set (bool value);
}


ItemCompatibilityType Class

ItemCompatibilityType Class
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemCompatibilityType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemCompatibilityType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemCompatibilityType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemCompatibilityType()()()() |
 | Any |
 | CompatibilityNotes |
 | Delete |
 | DeleteSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NameValueList |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ItemCompatibilityType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CompatibilityNotes Property

CompatibilityNotes Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityType ► CompatibilityNotes
Declaration Syntax
C# Visual Basic Visual C++
public string CompatibilityNotes { get; set; }
Public Property CompatibilityNotes As String
    Get
    Set
public:
property String^ CompatibilityNotes {
    String^ get ();
    void set (String^ value);
}


Delete Property

Delete Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityType ► Delete
Declaration Syntax
C# Visual Basic Visual C++
public bool Delete { get; set; }
Public Property Delete As Boolean
    Get
    Set
public:
property bool Delete {
    bool get ();
    void set (bool value);
}


DeleteSpecified Property

DeleteSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityType ► DeleteSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteSpecified { get; set; }
Public Property DeleteSpecified As Boolean
    Get
    Set
public:
property bool DeleteSpecified {
    bool get ();
    void set (bool value);
}


ItemCompatibilityType Constructor

ItemCompatibilityType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityType ► ItemCompatibilityType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityType()
Public Sub New
public:
ItemCompatibilityType()


NameValueList Property

NameValueList Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityType ► NameValueList
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection NameValueList { get; set; }
Public Property NameValueList As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ NameValueList {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


ItemCompatibilityTypeCollection Class

ItemCompatibilityTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ItemCompatibilityTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ItemCompatibilityTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ItemCompatibilityTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemCompatibilityTypeCollection()()()() |
 | ItemCompatibilityTypeCollection(array<ItemCompatibilityType>[]()[][]) |
 | ItemCompatibilityTypeCollection(ItemCompatibilityTypeCollection) |
 | Add(ItemCompatibilityType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ItemCompatibilityType>[]()[][]) |
 | AddRange(ItemCompatibilityTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ItemCompatibilityType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ItemCompatibilityType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ItemCompatibilityType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ItemCompatibilityType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ItemCompatibilityType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ItemCompatibilityTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► Add(ItemCompatibilityType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ItemCompatibilityType item
)
Public Function Add ( _
    item As ItemCompatibilityType _
) As Integer
public:
int Add(
    ItemCompatibilityType^ item
)
Parameters
item (ItemCompatibilityType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ItemCompatibilityType>[]()[][]) |
 | AddRange(ItemCompatibilityTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► AddRange(array<ItemCompatibilityType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemCompatibilityType[] items
)
Public Sub AddRange ( _
    items As ItemCompatibilityType() _
)
public:
void AddRange(
    array<ItemCompatibilityType^>^ items
)
Parameters
items (array< ItemCompatibilityType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► AddRange(ItemCompatibilityTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemCompatibilityTypeCollection items
)
Public Sub AddRange ( _
    items As ItemCompatibilityTypeCollection _
)
public:
void AddRange(
    ItemCompatibilityTypeCollection^ items
)
Parameters
items (ItemCompatibilityTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► Contains(ItemCompatibilityType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ItemCompatibilityType item
)
Public Function Contains ( _
    item As ItemCompatibilityType _
) As Boolean
public:
bool Contains(
    ItemCompatibilityType^ item
)
Parameters
item (ItemCompatibilityType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► CopyTo(array<ItemCompatibilityType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ItemCompatibilityType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ItemCompatibilityType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ItemCompatibilityType^>^ items,
    int index
)
Parameters
items (array< ItemCompatibilityType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► IndexOf(ItemCompatibilityType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ItemCompatibilityType item
)
Public Function IndexOf ( _
    item As ItemCompatibilityType _
) As Integer
public:
int IndexOf(
    ItemCompatibilityType^ item
)
Parameters
item (ItemCompatibilityType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► Insert(Int32, ItemCompatibilityType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ItemCompatibilityType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ItemCompatibilityType _
)
public:
void Insert(
    int index,
    ItemCompatibilityType^ item
)
Parameters
index (Int32)
item (ItemCompatibilityType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ItemCompatibilityType
    Get
    Set
public:
property ItemCompatibilityType^ default[int index] {
    ItemCompatibilityType^ get (int index);
    void set (int index, ItemCompatibilityType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ItemCompatibilityType
public:
ItemCompatibilityType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ItemCompatibilityTypeCollection Constructor

ItemCompatibilityTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► ItemCompatibilityTypeCollection()()()()
Members
Icon | Member | Description
 | ItemCompatibilityTypeCollection()()()() |
 | ItemCompatibilityTypeCollection(array<ItemCompatibilityType>[]()[][]) |
 | ItemCompatibilityTypeCollection(ItemCompatibilityTypeCollection) |


ItemCompatibilityTypeCollection Constructor

ItemCompatibilityTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► ItemCompatibilityTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityTypeCollection()
Public Sub New
public:
ItemCompatibilityTypeCollection()


ItemCompatibilityTypeCollection Constructor (items)

ItemCompatibilityTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► ItemCompatibilityTypeCollection(array<ItemCompatibilityType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityTypeCollection(
    ItemCompatibilityType[] items
)
Public Sub New ( _
    items As ItemCompatibilityType() _
)
public:
ItemCompatibilityTypeCollection(
    array<ItemCompatibilityType^>^ items
)
Parameters
items (array< ItemCompatibilityType >[]()[][])


ItemCompatibilityTypeCollection Constructor (items)

ItemCompatibilityTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► ItemCompatibilityTypeCollection(ItemCompatibilityTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityTypeCollection(
    ItemCompatibilityTypeCollection items
)
Public Sub New ( _
    items As ItemCompatibilityTypeCollection _
)
public:
ItemCompatibilityTypeCollection(
    ItemCompatibilityTypeCollection^ items
)
Parameters
items (ItemCompatibilityTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► Remove(ItemCompatibilityType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ItemCompatibilityType item
)
Public Sub Remove ( _
    item As ItemCompatibilityType _
)
public:
void Remove(
    ItemCompatibilityType^ item
)
Parameters
item (ItemCompatibilityType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityType[] ToArray()
Public Function ToArray As ItemCompatibilityType()
public:
array<ItemCompatibilityType^>^ ToArray()
Return Value


ItemConditionCodeType Enumeration

ItemConditionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ItemConditionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ItemConditionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ItemConditionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ItemConditionCodeType
Members
Member | Description
New |
Used |
CustomCode |
Remarks


ItemFormatSortFilterCodeType Enumeration

ItemFormatSortFilterCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ItemFormatSortFilterCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ItemFormatSortFilterCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ItemFormatSortFilterCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ItemFormatSortFilterCodeType
Members
Member | Description
ShowAnyItems |
ShowItemsWithBINFirst |
ShowOnlyItemsWithBIN |
ShowOnlyStoreItems |
CustomCode |
Remarks


ItemIDArrayType Class

ItemIDArrayType Class
Namespaces ► eBay.Service.Core.Soap ► ItemIDArrayType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemIDArrayType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemIDArrayType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemIDArrayType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemIDArrayType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ItemIDArrayType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemIDArrayType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► ItemIDArrayType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ItemID { get; set; }
Public Property ItemID As StringCollection
    Get
    Set
public:
property StringCollection^ ItemID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ItemIDArrayType Constructor

ItemIDArrayType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemIDArrayType ► ItemIDArrayType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemIDArrayType()
Public Sub New
public:
ItemIDArrayType()


ItemListCustomizationType Class

ItemListCustomizationType Class
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemListCustomizationType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemListCustomizationType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemListCustomizationType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemListCustomizationType()()()() |
 | Any |
 | DurationInDays |
 | DurationInDaysSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Include |
 | IncludeNotes |
 | IncludeNotesSpecified |
 | IncludeSpecified |
 | ListingType |
 | ListingTypeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderStatusFilter |
 | OrderStatusFilterSpecified |
 | Pagination |
 | Sort |
 | SortSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ItemListCustomizationType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DurationInDays Property

DurationInDays Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► DurationInDays
Declaration Syntax
C# Visual Basic Visual C++
public int DurationInDays { get; set; }
Public Property DurationInDays As Integer
    Get
    Set
public:
property int DurationInDays {
    int get ();
    void set (int value);
}


DurationInDaysSpecified Property

DurationInDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► DurationInDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DurationInDaysSpecified { get; set; }
Public Property DurationInDaysSpecified As Boolean
    Get
    Set
public:
property bool DurationInDaysSpecified {
    bool get ();
    void set (bool value);
}


Include Property

Include Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► Include
Declaration Syntax
C# Visual Basic Visual C++
public bool Include { get; set; }
Public Property Include As Boolean
    Get
    Set
public:
property bool Include {
    bool get ();
    void set (bool value);
}


IncludeNotes Property

IncludeNotes Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► IncludeNotes
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeNotes { get; set; }
Public Property IncludeNotes As Boolean
    Get
    Set
public:
property bool IncludeNotes {
    bool get ();
    void set (bool value);
}


IncludeNotesSpecified Property

IncludeNotesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► IncludeNotesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeNotesSpecified { get; set; }
Public Property IncludeNotesSpecified As Boolean
    Get
    Set
public:
property bool IncludeNotesSpecified {
    bool get ();
    void set (bool value);
}


IncludeSpecified Property

IncludeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► IncludeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeSpecified { get; set; }
Public Property IncludeSpecified As Boolean
    Get
    Set
public:
property bool IncludeSpecified {
    bool get ();
    void set (bool value);
}


ItemListCustomizationType Constructor

ItemListCustomizationType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► ItemListCustomizationType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemListCustomizationType()
Public Sub New
public:
ItemListCustomizationType()


ListingType Property

ListingType Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► ListingType
Declaration Syntax
C# Visual Basic Visual C++
public ListingTypeCodeType ListingType { get; set; }
Public Property ListingType As ListingTypeCodeType
    Get
    Set
public:
property ListingTypeCodeType ListingType {
    ListingTypeCodeType get ();
    void set (ListingTypeCodeType value);
}


ListingTypeSpecified Property

ListingTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► ListingTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingTypeSpecified { get; set; }
Public Property ListingTypeSpecified As Boolean
    Get
    Set
public:
property bool ListingTypeSpecified {
    bool get ();
    void set (bool value);
}


OrderStatusFilter Property

OrderStatusFilter Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► OrderStatusFilter
Declaration Syntax
C# Visual Basic Visual C++
public OrderStatusFilterCodeType OrderStatusFilter { get; set; }
Public Property OrderStatusFilter As OrderStatusFilterCodeType
    Get
    Set
public:
property OrderStatusFilterCodeType OrderStatusFilter {
    OrderStatusFilterCodeType get ();
    void set (OrderStatusFilterCodeType value);
}


OrderStatusFilterSpecified Property

OrderStatusFilterSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► OrderStatusFilterSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OrderStatusFilterSpecified { get; set; }
Public Property OrderStatusFilterSpecified As Boolean
    Get
    Set
public:
property bool OrderStatusFilterSpecified {
    bool get ();
    void set (bool value);
}


Pagination Property

Pagination Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► Pagination
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType Pagination { get; set; }
Public Property Pagination As PaginationType
    Get
    Set
public:
property PaginationType^ Pagination {
    PaginationType^ get ();
    void set (PaginationType^ value);
}


Sort Property

Sort Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► Sort
Declaration Syntax
C# Visual Basic Visual C++
public ItemSortTypeCodeType Sort { get; set; }
Public Property Sort As ItemSortTypeCodeType
    Get
    Set
public:
property ItemSortTypeCodeType Sort {
    ItemSortTypeCodeType get ();
    void set (ItemSortTypeCodeType value);
}


SortSpecified Property

SortSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemListCustomizationType ► SortSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SortSpecified { get; set; }
Public Property SortSpecified As Boolean
    Get
    Set
public:
property bool SortSpecified {
    bool get ();
    void set (bool value);
}


ItemPolicyViolationType Class

ItemPolicyViolationType Class
Namespaces ► eBay.Service.Core.Soap ► ItemPolicyViolationType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemPolicyViolationType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemPolicyViolationType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemPolicyViolationType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemPolicyViolationType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PolicyID |
 | PolicyIDSpecified |
 | PolicyText |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ItemPolicyViolationType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemPolicyViolationType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemPolicyViolationType Constructor

ItemPolicyViolationType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemPolicyViolationType ► ItemPolicyViolationType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemPolicyViolationType()
Public Sub New
public:
ItemPolicyViolationType()


PolicyID Property

PolicyID Property
Namespaces ► eBay.Service.Core.Soap ► ItemPolicyViolationType ► PolicyID
Declaration Syntax
C# Visual Basic Visual C++
public long PolicyID { get; set; }
Public Property PolicyID As Long
    Get
    Set
public:
property long long PolicyID {
    long long get ();
    void set (long long value);
}


PolicyIDSpecified Property

PolicyIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemPolicyViolationType ► PolicyIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PolicyIDSpecified { get; set; }
Public Property PolicyIDSpecified As Boolean
    Get
    Set
public:
property bool PolicyIDSpecified {
    bool get ();
    void set (bool value);
}


PolicyText Property

PolicyText Property
Namespaces ► eBay.Service.Core.Soap ► ItemPolicyViolationType ► PolicyText
Declaration Syntax
C# Visual Basic Visual C++
public string PolicyText { get; set; }
Public Property PolicyText As String
    Get
    Set
public:
property String^ PolicyText {
    String^ get ();
    void set (String^ value);
}


ItemRatingDetailsType Class

ItemRatingDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemRatingDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemRatingDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemRatingDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemRatingDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Rating |
 | RatingDetail |
 | RatingDetailSpecified |
 | RatingSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ItemRatingDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemRatingDetailsType Constructor

ItemRatingDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsType ► ItemRatingDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemRatingDetailsType()
Public Sub New
public:
ItemRatingDetailsType()


Rating Property

Rating Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsType ► Rating
Declaration Syntax
C# Visual Basic Visual C++
public int Rating { get; set; }
Public Property Rating As Integer
    Get
    Set
public:
property int Rating {
    int get ();
    void set (int value);
}


RatingDetail Property

RatingDetail Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsType ► RatingDetail
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackRatingDetailCodeType RatingDetail { get; set; }
Public Property RatingDetail As FeedbackRatingDetailCodeType
    Get
    Set
public:
property FeedbackRatingDetailCodeType RatingDetail {
    FeedbackRatingDetailCodeType get ();
    void set (FeedbackRatingDetailCodeType value);
}


RatingDetailSpecified Property

RatingDetailSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsType ► RatingDetailSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RatingDetailSpecified { get; set; }
Public Property RatingDetailSpecified As Boolean
    Get
    Set
public:
property bool RatingDetailSpecified {
    bool get ();
    void set (bool value);
}


RatingSpecified Property

RatingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsType ► RatingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RatingSpecified { get; set; }
Public Property RatingSpecified As Boolean
    Get
    Set
public:
property bool RatingSpecified {
    bool get ();
    void set (bool value);
}


ItemRatingDetailsTypeCollection Class

ItemRatingDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ItemRatingDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ItemRatingDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ItemRatingDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemRatingDetailsTypeCollection()()()() |
 | ItemRatingDetailsTypeCollection(array<ItemRatingDetailsType>[]()[][]) |
 | ItemRatingDetailsTypeCollection(ItemRatingDetailsTypeCollection) |
 | Add(ItemRatingDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ItemRatingDetailsType>[]()[][]) |
 | AddRange(ItemRatingDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ItemRatingDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ItemRatingDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ItemRatingDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ItemRatingDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ItemRatingDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ItemRatingDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► Add(ItemRatingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ItemRatingDetailsType item
)
Public Function Add ( _
    item As ItemRatingDetailsType _
) As Integer
public:
int Add(
    ItemRatingDetailsType^ item
)
Parameters
item (ItemRatingDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ItemRatingDetailsType>[]()[][]) |
 | AddRange(ItemRatingDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► AddRange(array<ItemRatingDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemRatingDetailsType[] items
)
Public Sub AddRange ( _
    items As ItemRatingDetailsType() _
)
public:
void AddRange(
    array<ItemRatingDetailsType^>^ items
)
Parameters
items (array< ItemRatingDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► AddRange(ItemRatingDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemRatingDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ItemRatingDetailsTypeCollection _
)
public:
void AddRange(
    ItemRatingDetailsTypeCollection^ items
)
Parameters
items (ItemRatingDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► Contains(ItemRatingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ItemRatingDetailsType item
)
Public Function Contains ( _
    item As ItemRatingDetailsType _
) As Boolean
public:
bool Contains(
    ItemRatingDetailsType^ item
)
Parameters
item (ItemRatingDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► CopyTo(array<ItemRatingDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ItemRatingDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ItemRatingDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ItemRatingDetailsType^>^ items,
    int index
)
Parameters
items (array< ItemRatingDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► IndexOf(ItemRatingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ItemRatingDetailsType item
)
Public Function IndexOf ( _
    item As ItemRatingDetailsType _
) As Integer
public:
int IndexOf(
    ItemRatingDetailsType^ item
)
Parameters
item (ItemRatingDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► Insert(Int32, ItemRatingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ItemRatingDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ItemRatingDetailsType _
)
public:
void Insert(
    int index,
    ItemRatingDetailsType^ item
)
Parameters
index (Int32)
item (ItemRatingDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ItemRatingDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ItemRatingDetailsType
    Get
    Set
public:
property ItemRatingDetailsType^ default[int index] {
    ItemRatingDetailsType^ get (int index);
    void set (int index, ItemRatingDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ItemRatingDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ItemRatingDetailsType
public:
ItemRatingDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ItemRatingDetailsTypeCollection Constructor

ItemRatingDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► ItemRatingDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ItemRatingDetailsTypeCollection()()()() |
 | ItemRatingDetailsTypeCollection(array<ItemRatingDetailsType>[]()[][]) |
 | ItemRatingDetailsTypeCollection(ItemRatingDetailsTypeCollection) |


ItemRatingDetailsTypeCollection Constructor

ItemRatingDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► ItemRatingDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemRatingDetailsTypeCollection()
Public Sub New
public:
ItemRatingDetailsTypeCollection()


ItemRatingDetailsTypeCollection Constructor (items)

ItemRatingDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► ItemRatingDetailsTypeCollection(array<ItemRatingDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ItemRatingDetailsTypeCollection(
    ItemRatingDetailsType[] items
)
Public Sub New ( _
    items As ItemRatingDetailsType() _
)
public:
ItemRatingDetailsTypeCollection(
    array<ItemRatingDetailsType^>^ items
)
Parameters
items (array< ItemRatingDetailsType >[]()[][])


ItemRatingDetailsTypeCollection Constructor (items)

ItemRatingDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► ItemRatingDetailsTypeCollection(ItemRatingDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ItemRatingDetailsTypeCollection(
    ItemRatingDetailsTypeCollection items
)
Public Sub New ( _
    items As ItemRatingDetailsTypeCollection _
)
public:
ItemRatingDetailsTypeCollection(
    ItemRatingDetailsTypeCollection^ items
)
Parameters
items (ItemRatingDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► Remove(ItemRatingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ItemRatingDetailsType item
)
Public Sub Remove ( _
    item As ItemRatingDetailsType _
)
public:
void Remove(
    ItemRatingDetailsType^ item
)
Parameters
item (ItemRatingDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemRatingDetailsType[] ToArray()
Public Function ToArray As ItemRatingDetailsType()
public:
array<ItemRatingDetailsType^>^ ToArray()
Return Value


ItemsCanceledEventType Class

ItemsCanceledEventType Class
Namespaces ► eBay.Service.Core.Soap ► ItemsCanceledEventType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemsCanceledEventType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemsCanceledEventType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemsCanceledEventType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemsCanceledEventType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CanceledItemIDArray |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EligibleForRelist |
 | EligibleForRelistSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SellerID |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ItemsCanceledEventType


CanceledItemIDArray Property

CanceledItemIDArray Property
Namespaces ► eBay.Service.Core.Soap ► ItemsCanceledEventType ► CanceledItemIDArray
Declaration Syntax
C# Visual Basic Visual C++
public ItemIDArrayType CanceledItemIDArray { get; set; }
Public Property CanceledItemIDArray As ItemIDArrayType
    Get
    Set
public:
property ItemIDArrayType^ CanceledItemIDArray {
    ItemIDArrayType^ get ();
    void set (ItemIDArrayType^ value);
}


EligibleForRelist Property

EligibleForRelist Property
Namespaces ► eBay.Service.Core.Soap ► ItemsCanceledEventType ► EligibleForRelist
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleForRelist { get; set; }
Public Property EligibleForRelist As Boolean
    Get
    Set
public:
property bool EligibleForRelist {
    bool get ();
    void set (bool value);
}


EligibleForRelistSpecified Property

EligibleForRelistSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemsCanceledEventType ► EligibleForRelistSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleForRelistSpecified { get; set; }
Public Property EligibleForRelistSpecified As Boolean
    Get
    Set
public:
property bool EligibleForRelistSpecified {
    bool get ();
    void set (bool value);
}


ItemsCanceledEventType Constructor

ItemsCanceledEventType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemsCanceledEventType ► ItemsCanceledEventType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemsCanceledEventType()
Public Sub New
public:
ItemsCanceledEventType()


SellerID Property

SellerID Property
Namespaces ► eBay.Service.Core.Soap ► ItemsCanceledEventType ► SellerID
Declaration Syntax
C# Visual Basic Visual C++
public string SellerID { get; set; }
Public Property SellerID As String
    Get
    Set
public:
property String^ SellerID {
    String^ get ();
    void set (String^ value);
}


ItemSortFilterCodeType Enumeration

ItemSortFilterCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ItemSortFilterCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ItemSortFilterCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ItemSortFilterCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ItemSortFilterCodeType
Members
Member | Description
EndingLast |
EndingSoonest |
HighestPrice |
LowestPrice |
NewlyListed |
RandomlySelected |
CustomCode |
Remarks


ItemSortTypeCodeType Enumeration

ItemSortTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ItemSortTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ItemSortTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ItemSortTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ItemSortTypeCodeType
Members
Member | Description
ItemID |
Price |
StartPrice |
Title |
BidCount |
Quantity |
StartTime |
EndTime |
SellerUserID |
TimeLeft |
ListingDuration |
ListingType |
CurrentPrice |
ReservePrice |
MaxBid |
BidderCount |
HighBidderUserID |
BuyerUserID |
BuyerPostalCode |
BuyerEmail |
SellerEmail |
TotalPrice |
WatchCount |
BestOfferCount |
QuestionCount |
ShippingServiceCost |
FeedbackReceived |
FeedbackLeft |
UserID |
QuantitySold |
BestOffer |
QuantityAvailable |
QuantityPurchased |
WonPlatform |
SoldPlatform |
ListingDurationDescending |
ListingTypeDescending |
CurrentPriceDescending |
ReservePriceDescending |
MaxBidDescending |
BidderCountDescending |
HighBidderUserIDDescending |
BuyerUserIDDescending |
BuyerPostalCodeDescending |
BuyerEmailDescending |
SellerEmailDescending |
TotalPriceDescending |
WatchCountDescending |
QuestionCountDescending |
ShippingServiceCostDescending |
FeedbackReceivedDescending |
FeedbackLeftDescending |
UserIDDescending |
QuantitySoldDescending |
BestOfferCountDescending |
QuantityAvailableDescending |
QuantityPurchasedDescending |
BestOfferDescending |
ItemIDDescending |
PriceDescending |
StartPriceDescending |
TitleDescending |
BidCountDescending |
QuantityDescending |
StartTimeDescending |
EndTimeDescending |
SellerUserIDDescending |
TimeLeftDescending |
WonPlatformDescending |
SoldPlatformDescending |
LeadCount |
NewLeadCount |
LeadCountDescending |
NewLeadCountDescending |
ClassifiedAdPayPerLeadFee |
ClassifiedAdPayPerLeadFeeDescending |
CustomCode |
Remarks


ItemSpecificDetailsType Class

ItemSpecificDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemSpecificDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemSpecificDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemSpecificDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemSpecificDetailsType()()()() |
 | Any |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MaxCharactersPerName |
 | MaxCharactersPerNameSpecified |
 | MaxCharactersPerValue |
 | MaxCharactersPerValueSpecified |
 | MaxItemSpecificsPerItem |
 | MaxItemSpecificsPerItemSpecified |
 | MaxValuesPerName |
 | MaxValuesPerNameSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
ItemSpecificDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


ItemSpecificDetailsType Constructor

ItemSpecificDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► ItemSpecificDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificDetailsType()
Public Sub New
public:
ItemSpecificDetailsType()


MaxCharactersPerName Property

MaxCharactersPerName Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► MaxCharactersPerName
Declaration Syntax
C# Visual Basic Visual C++
public int MaxCharactersPerName { get; set; }
Public Property MaxCharactersPerName As Integer
    Get
    Set
public:
property int MaxCharactersPerName {
    int get ();
    void set (int value);
}


MaxCharactersPerNameSpecified Property

MaxCharactersPerNameSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► MaxCharactersPerNameSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxCharactersPerNameSpecified { get; set; }
Public Property MaxCharactersPerNameSpecified As Boolean
    Get
    Set
public:
property bool MaxCharactersPerNameSpecified {
    bool get ();
    void set (bool value);
}


MaxCharactersPerValue Property

MaxCharactersPerValue Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► MaxCharactersPerValue
Declaration Syntax
C# Visual Basic Visual C++
public int MaxCharactersPerValue { get; set; }
Public Property MaxCharactersPerValue As Integer
    Get
    Set
public:
property int MaxCharactersPerValue {
    int get ();
    void set (int value);
}


MaxCharactersPerValueSpecified Property

MaxCharactersPerValueSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► MaxCharactersPerValueSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxCharactersPerValueSpecified { get; set; }
Public Property MaxCharactersPerValueSpecified As Boolean
    Get
    Set
public:
property bool MaxCharactersPerValueSpecified {
    bool get ();
    void set (bool value);
}


MaxItemSpecificsPerItem Property

MaxItemSpecificsPerItem Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► MaxItemSpecificsPerItem
Declaration Syntax
C# Visual Basic Visual C++
public int MaxItemSpecificsPerItem { get; set; }
Public Property MaxItemSpecificsPerItem As Integer
    Get
    Set
public:
property int MaxItemSpecificsPerItem {
    int get ();
    void set (int value);
}


MaxItemSpecificsPerItemSpecified Property

MaxItemSpecificsPerItemSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► MaxItemSpecificsPerItemSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxItemSpecificsPerItemSpecified { get; set; }
Public Property MaxItemSpecificsPerItemSpecified As Boolean
    Get
    Set
public:
property bool MaxItemSpecificsPerItemSpecified {
    bool get ();
    void set (bool value);
}


MaxValuesPerName Property

MaxValuesPerName Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► MaxValuesPerName
Declaration Syntax
C# Visual Basic Visual C++
public int MaxValuesPerName { get; set; }
Public Property MaxValuesPerName As Integer
    Get
    Set
public:
property int MaxValuesPerName {
    int get ();
    void set (int value);
}


MaxValuesPerNameSpecified Property

MaxValuesPerNameSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► MaxValuesPerNameSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxValuesPerNameSpecified { get; set; }
Public Property MaxValuesPerNameSpecified As Boolean
    Get
    Set
public:
property bool MaxValuesPerNameSpecified {
    bool get ();
    void set (bool value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


ItemSpecificDetailsTypeCollection Class

ItemSpecificDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ItemSpecificDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ItemSpecificDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ItemSpecificDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemSpecificDetailsTypeCollection()()()() |
 | ItemSpecificDetailsTypeCollection(array<ItemSpecificDetailsType>[]()[][]) |
 | ItemSpecificDetailsTypeCollection(ItemSpecificDetailsTypeCollection) |
 | Add(ItemSpecificDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ItemSpecificDetailsType>[]()[][]) |
 | AddRange(ItemSpecificDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ItemSpecificDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ItemSpecificDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ItemSpecificDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ItemSpecificDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ItemSpecificDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ItemSpecificDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► Add(ItemSpecificDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ItemSpecificDetailsType item
)
Public Function Add ( _
    item As ItemSpecificDetailsType _
) As Integer
public:
int Add(
    ItemSpecificDetailsType^ item
)
Parameters
item (ItemSpecificDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ItemSpecificDetailsType>[]()[][]) |
 | AddRange(ItemSpecificDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► AddRange(array<ItemSpecificDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemSpecificDetailsType[] items
)
Public Sub AddRange ( _
    items As ItemSpecificDetailsType() _
)
public:
void AddRange(
    array<ItemSpecificDetailsType^>^ items
)
Parameters
items (array< ItemSpecificDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► AddRange(ItemSpecificDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemSpecificDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ItemSpecificDetailsTypeCollection _
)
public:
void AddRange(
    ItemSpecificDetailsTypeCollection^ items
)
Parameters
items (ItemSpecificDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► Contains(ItemSpecificDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ItemSpecificDetailsType item
)
Public Function Contains ( _
    item As ItemSpecificDetailsType _
) As Boolean
public:
bool Contains(
    ItemSpecificDetailsType^ item
)
Parameters
item (ItemSpecificDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► CopyTo(array<ItemSpecificDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ItemSpecificDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ItemSpecificDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ItemSpecificDetailsType^>^ items,
    int index
)
Parameters
items (array< ItemSpecificDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► IndexOf(ItemSpecificDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ItemSpecificDetailsType item
)
Public Function IndexOf ( _
    item As ItemSpecificDetailsType _
) As Integer
public:
int IndexOf(
    ItemSpecificDetailsType^ item
)
Parameters
item (ItemSpecificDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► Insert(Int32, ItemSpecificDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ItemSpecificDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ItemSpecificDetailsType _
)
public:
void Insert(
    int index,
    ItemSpecificDetailsType^ item
)
Parameters
index (Int32)
item (ItemSpecificDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ItemSpecificDetailsType
    Get
    Set
public:
property ItemSpecificDetailsType^ default[int index] {
    ItemSpecificDetailsType^ get (int index);
    void set (int index, ItemSpecificDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ItemSpecificDetailsType
public:
ItemSpecificDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ItemSpecificDetailsTypeCollection Constructor

ItemSpecificDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► ItemSpecificDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ItemSpecificDetailsTypeCollection()()()() |
 | ItemSpecificDetailsTypeCollection(array<ItemSpecificDetailsType>[]()[][]) |
 | ItemSpecificDetailsTypeCollection(ItemSpecificDetailsTypeCollection) |


ItemSpecificDetailsTypeCollection Constructor

ItemSpecificDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► ItemSpecificDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificDetailsTypeCollection()
Public Sub New
public:
ItemSpecificDetailsTypeCollection()


ItemSpecificDetailsTypeCollection Constructor (items)

ItemSpecificDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► ItemSpecificDetailsTypeCollection(array<ItemSpecificDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificDetailsTypeCollection(
    ItemSpecificDetailsType[] items
)
Public Sub New ( _
    items As ItemSpecificDetailsType() _
)
public:
ItemSpecificDetailsTypeCollection(
    array<ItemSpecificDetailsType^>^ items
)
Parameters
items (array< ItemSpecificDetailsType >[]()[][])


ItemSpecificDetailsTypeCollection Constructor (items)

ItemSpecificDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► ItemSpecificDetailsTypeCollection(ItemSpecificDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificDetailsTypeCollection(
    ItemSpecificDetailsTypeCollection items
)
Public Sub New ( _
    items As ItemSpecificDetailsTypeCollection _
)
public:
ItemSpecificDetailsTypeCollection(
    ItemSpecificDetailsTypeCollection^ items
)
Parameters
items (ItemSpecificDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► Remove(ItemSpecificDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ItemSpecificDetailsType item
)
Public Sub Remove ( _
    item As ItemSpecificDetailsType _
)
public:
void Remove(
    ItemSpecificDetailsType^ item
)
Parameters
item (ItemSpecificDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificDetailsType[] ToArray()
Public Function ToArray As ItemSpecificDetailsType()
public:
array<ItemSpecificDetailsType^>^ ToArray()
Return Value


ItemSpecificsEnabledCodeType Enumeration

ItemSpecificsEnabledCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificsEnabledCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ItemSpecificsEnabledCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ItemSpecificsEnabledCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ItemSpecificsEnabledCodeType
Members
Member | Description
Disabled |
Enabled |
CustomCode |
Remarks


ItemSpecificsEnabledDefinitionType Class

ItemSpecificsEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificsEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemSpecificsEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemSpecificsEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemSpecificsEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemSpecificsEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ItemSpecificsEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificsEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemSpecificsEnabledDefinitionType Constructor

ItemSpecificsEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificsEnabledDefinitionType ► ItemSpecificsEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificsEnabledDefinitionType()
Public Sub New
public:
ItemSpecificsEnabledDefinitionType()


ItemSpecificSourceCodeType Enumeration

ItemSpecificSourceCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificSourceCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ItemSpecificSourceCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ItemSpecificSourceCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ItemSpecificSourceCodeType
Members
Member | Description
ItemSpecific |
Attribute |
Product |
CustomCode |
Remarks


ItemTransactionIDType Class

ItemTransactionIDType Class
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemTransactionIDType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemTransactionIDType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemTransactionIDType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemTransactionIDType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderLineItemID |
 | SKU |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
Remarks
Inheritance Hierarchy
Object
ItemTransactionIDType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ItemTransactionIDType Constructor

ItemTransactionIDType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDType ► ItemTransactionIDType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemTransactionIDType()
Public Sub New
public:
ItemTransactionIDType()


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


ItemTransactionIDTypeCollection Class

ItemTransactionIDTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ItemTransactionIDTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ItemTransactionIDTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ItemTransactionIDTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemTransactionIDTypeCollection()()()() |
 | ItemTransactionIDTypeCollection(array<ItemTransactionIDType>[]()[][]) |
 | ItemTransactionIDTypeCollection(ItemTransactionIDTypeCollection) |
 | Add(ItemTransactionIDType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ItemTransactionIDType>[]()[][]) |
 | AddRange(ItemTransactionIDTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ItemTransactionIDType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ItemTransactionIDType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ItemTransactionIDType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ItemTransactionIDType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ItemTransactionIDType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ItemTransactionIDTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► Add(ItemTransactionIDType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ItemTransactionIDType item
)
Public Function Add ( _
    item As ItemTransactionIDType _
) As Integer
public:
int Add(
    ItemTransactionIDType^ item
)
Parameters
item (ItemTransactionIDType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ItemTransactionIDType>[]()[][]) |
 | AddRange(ItemTransactionIDTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► AddRange(array<ItemTransactionIDType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemTransactionIDType[] items
)
Public Sub AddRange ( _
    items As ItemTransactionIDType() _
)
public:
void AddRange(
    array<ItemTransactionIDType^>^ items
)
Parameters
items (array< ItemTransactionIDType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► AddRange(ItemTransactionIDTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemTransactionIDTypeCollection items
)
Public Sub AddRange ( _
    items As ItemTransactionIDTypeCollection _
)
public:
void AddRange(
    ItemTransactionIDTypeCollection^ items
)
Parameters
items (ItemTransactionIDTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► Contains(ItemTransactionIDType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ItemTransactionIDType item
)
Public Function Contains ( _
    item As ItemTransactionIDType _
) As Boolean
public:
bool Contains(
    ItemTransactionIDType^ item
)
Parameters
item (ItemTransactionIDType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► CopyTo(array<ItemTransactionIDType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ItemTransactionIDType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ItemTransactionIDType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ItemTransactionIDType^>^ items,
    int index
)
Parameters
items (array< ItemTransactionIDType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► IndexOf(ItemTransactionIDType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ItemTransactionIDType item
)
Public Function IndexOf ( _
    item As ItemTransactionIDType _
) As Integer
public:
int IndexOf(
    ItemTransactionIDType^ item
)
Parameters
item (ItemTransactionIDType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► Insert(Int32, ItemTransactionIDType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ItemTransactionIDType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ItemTransactionIDType _
)
public:
void Insert(
    int index,
    ItemTransactionIDType^ item
)
Parameters
index (Int32)
item (ItemTransactionIDType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ItemTransactionIDType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ItemTransactionIDType
    Get
    Set
public:
property ItemTransactionIDType^ default[int index] {
    ItemTransactionIDType^ get (int index);
    void set (int index, ItemTransactionIDType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ItemTransactionIDType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ItemTransactionIDType
public:
ItemTransactionIDType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ItemTransactionIDTypeCollection Constructor

ItemTransactionIDTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► ItemTransactionIDTypeCollection()()()()
Members
Icon | Member | Description
 | ItemTransactionIDTypeCollection()()()() |
 | ItemTransactionIDTypeCollection(array<ItemTransactionIDType>[]()[][]) |
 | ItemTransactionIDTypeCollection(ItemTransactionIDTypeCollection) |


ItemTransactionIDTypeCollection Constructor

ItemTransactionIDTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► ItemTransactionIDTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemTransactionIDTypeCollection()
Public Sub New
public:
ItemTransactionIDTypeCollection()


ItemTransactionIDTypeCollection Constructor (items)

ItemTransactionIDTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► ItemTransactionIDTypeCollection(array<ItemTransactionIDType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ItemTransactionIDTypeCollection(
    ItemTransactionIDType[] items
)
Public Sub New ( _
    items As ItemTransactionIDType() _
)
public:
ItemTransactionIDTypeCollection(
    array<ItemTransactionIDType^>^ items
)
Parameters
items (array< ItemTransactionIDType >[]()[][])


ItemTransactionIDTypeCollection Constructor (items)

ItemTransactionIDTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► ItemTransactionIDTypeCollection(ItemTransactionIDTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ItemTransactionIDTypeCollection(
    ItemTransactionIDTypeCollection items
)
Public Sub New ( _
    items As ItemTransactionIDTypeCollection _
)
public:
ItemTransactionIDTypeCollection(
    ItemTransactionIDTypeCollection^ items
)
Parameters
items (ItemTransactionIDTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► Remove(ItemTransactionIDType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ItemTransactionIDType item
)
Public Sub Remove ( _
    item As ItemTransactionIDType _
)
public:
void Remove(
    ItemTransactionIDType^ item
)
Parameters
item (ItemTransactionIDType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemTransactionIDType[] ToArray()
Public Function ToArray As ItemTransactionIDType()
public:
array<ItemTransactionIDType^>^ ToArray()
Return Value


ItemType Class

ItemType Class
Namespaces ► eBay.Service.Core.Soap ► ItemType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ItemType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ItemType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ItemType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemType()()()() |
 | Any |
 | ApplicationData |
 | ApplyBuyerProtection |
 | AttributeArray |
 | AttributeSetArray |
 | AutoPay |
 | AutoPaySpecified |
 | AvailableForPickupDropOff |
 | AvailableForPickupDropOffSpecified |
 | BestOfferDetails |
 | BestOfferEnabled |
 | BestOfferEnabledSpecified |
 | BiddingDetails |
 | BidGroupItem |
 | BidGroupItemSpecified |
 | BusinessSellerDetails |
 | BuyerGuaranteePrice |
 | BuyerProtection |
 | BuyerProtectionSpecified |
 | BuyerRequirementDetails |
 | BuyerResponsibleForShipping |
 | BuyerResponsibleForShippingSpecified |
 | BuyItNowPrice |
 | CategoryBasedAttributesPrefill |
 | CategoryMappingAllowed |
 | CeilingPrice |
 | Charity |
 | ClassifiedAdPayPerLeadFee |
 | ConditionDefinition |
 | ConditionDescription |
 | ConditionDisplayName |
 | ConditionID |
 | ConditionIDSpecified |
 | Country |
 | CountrySpecified |
 | CrossBorderTrade |
 | CrossPromotion |
 | Currency |
 | CurrencySpecified |
 | Description |
 | DescriptionReviseMode |
 | DescriptionReviseModeSpecified |
 | DigitalGoodInfo |
 | DisableBuyerRequirements |
 | DisableBuyerRequirementsSpecified |
 | DiscountPriceInfo |
 | DispatchTimeMax |
 | DispatchTimeMaxSpecified |
 | Distance |
 | eBayNotes |
 | eBayNowAvailable |
 | eBayNowAvailableSpecified |
 | eBayNowEligible |
 | eBayNowEligibleSpecified |
 | eBayPlus |
 | eBayPlusEligible |
 | eBayPlusEligibleSpecified |
 | eBayPlusSpecified |
 | EligibleForPickupDropOff |
 | EligibleForPickupDropOffSpecified |
 | eMailDeliveryAvailable |
 | eMailDeliveryAvailableSpecified |
 | Equals(Object) | (Inherited from Object.)
 | ExtendedSellerContactDetails |
 | ExternalProductID |
 | Finalize()()()() | (Inherited from Object.)
 | FloorPrice |
 | FreeAddedCategory |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItFast |
 | GetItFastSpecified |
 | GetType()()()() | (Inherited from Object.)
 | GiftIcon |
 | GiftIconSpecified |
 | GiftServices |
 | GroupCategoryID |
 | HideFromSearch |
 | HideFromSearchSpecified |
 | HitCount |
 | HitCounter |
 | HitCounterSpecified |
 | HitCountSpecified |
 | IgnoreQuantity |
 | IgnoreQuantitySpecified |
 | IncludeRecommendations |
 | IntegratedMerchantCreditCardEnabled |
 | IntegratedMerchantCreditCardEnabledSpecified |
 | InventoryTrackingMethod |
 | InventoryTrackingMethodSpecified |
 | IsIntermediatedShippingEligible |
 | IsIntermediatedShippingEligibleSpecified |
 | ItemCompatibilityCount |
 | ItemCompatibilityCountSpecified |
 | ItemCompatibilityList |
 | ItemID |
 | ItemPolicyViolation |
 | ItemSpecifics |
 | LeadCount |
 | LeadCountSpecified |
 | LimitedWarrantyEligible |
 | LimitedWarrantyEligibleSpecified |
 | ListingCheckoutRedirectPreference |
 | ListingDesigner |
 | ListingDetails |
 | ListingDuration |
 | ListingEnhancement |
 | ListingSubtype2 |
 | ListingSubtype2Specified |
 | ListingType |
 | ListingTypeSpecified |
 | LiveAuction |
 | LiveAuctionSpecified |
 | LocalListing |
 | LocalListingSpecified |
 | Location |
 | LocationDefaulted |
 | LocationDefaultedSpecified |
 | LookupAttributeArray |
 | LotSize |
 | LotSizeSpecified |
 | MechanicalCheckAccepted |
 | MechanicalCheckAcceptedSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MotorsGermanySearchable |
 | MotorsGermanySearchableSpecified |
 | NewLeadCount |
 | NewLeadCountSpecified |
 | PartnerCode |
 | PartnerName |
 | PaymentAllowedSite |
 | PaymentDetails |
 | PaymentMethods |
 | PayPalEmailAddress |
 | PickupInStoreDetails |
 | PictureDetails |
 | PostalCode |
 | PostCheckoutExperienceEnabled |
 | PostCheckoutExperienceEnabledSpecified |
 | PrimaryCategory |
 | PrivateListing |
 | PrivateListingSpecified |
 | PrivateNotes |
 | ProductListingDetails |
 | ProxyItem |
 | ProxyItemSpecified |
 | Quantity |
 | QuantityAvailable |
 | QuantityAvailableHint |
 | QuantityAvailableHintSpecified |
 | QuantityAvailableSpecified |
 | QuantityInfo |
 | QuantityRestrictionPerBuyer |
 | QuantitySpecified |
 | QuantityThreshold |
 | QuantityThresholdSpecified |
 | QuestionCount |
 | QuestionCountSpecified |
 | ReasonHideFromSearch |
 | ReasonHideFromSearchSpecified |
 | RegionID |
 | Relisted |
 | RelistedSpecified |
 | RelistLink |
 | RelistLinkSpecified |
 | RelistParentID |
 | RelistParentIDSpecified |
 | ReservePrice |
 | ReturnPolicy |
 | ReviseStatus |
 | ScheduleTime |
 | ScheduleTimeSpecified |
 | SearchDetails |
 | SecondaryCategory |
 | Seller |
 | SellerContactDetails |
 | SellerInventoryID |
 | SellerProfiles |
 | SellerProvidedTitle |
 | SellerVacationNote |
 | SellingStatus |
 | ShippingDetails |
 | ShippingOverride |
 | ShippingPackageDetails |
 | ShippingServiceCostOverrideList |
 | ShippingTermsInDescription |
 | ShippingTermsInDescriptionSpecified |
 | ShipToLocations |
 | Site |
 | SiteSpecified |
 | SKU |
 | SkypeContactOption |
 | SkypeEnabled |
 | SkypeEnabledSpecified |
 | SkypeID |
 | StartPrice |
 | Storefront |
 | SubTitle |
 | TaxCategory |
 | ThirdPartyCheckout |
 | ThirdPartyCheckoutIntegration |
 | ThirdPartyCheckoutIntegrationSpecified |
 | ThirdPartyCheckoutSpecified |
 | TimeLeft |
 | Title |
 | TopRatedListing |
 | TopRatedListingSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TotalQuestionCount |
 | TotalQuestionCountSpecified |
 | UnitInfo |
 | UpdateReturnPolicy |
 | UpdateReturnPolicySpecified |
 | UpdateSellerInfo |
 | UpdateSellerInfoSpecified |
 | UseRecommendedProduct |
 | UseTaxTable |
 | UseTaxTableSpecified |
 | UUID |
 | Variations |
 | VATDetails |
 | VIN |
 | VINLink |
 | VRM |
 | VRMLink |
 | WatchCount |
 | WatchCountSpecified |
Remarks
Inheritance Hierarchy
Object
ItemType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ApplicationData Property

ApplicationData Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ApplicationData
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationData { get; set; }
Public Property ApplicationData As String
    Get
    Set
public:
property String^ ApplicationData {
    String^ get ();
    void set (String^ value);
}


ApplyBuyerProtection Property

ApplyBuyerProtection Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ApplyBuyerProtection
Declaration Syntax
C# Visual Basic Visual C++
public BuyerProtectionDetailsType ApplyBuyerProtection { get; set; }
Public Property ApplyBuyerProtection As BuyerProtectionDetailsType
    Get
    Set
public:
property BuyerProtectionDetailsType^ ApplyBuyerProtection {
    BuyerProtectionDetailsType^ get ();
    void set (BuyerProtectionDetailsType^ value);
}


AttributeArray Property

AttributeArray Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► AttributeArray
Declaration Syntax
C# Visual Basic Visual C++
public AttributeTypeCollection AttributeArray { get; set; }
Public Property AttributeArray As AttributeTypeCollection
    Get
    Set
public:
property AttributeTypeCollection^ AttributeArray {
    AttributeTypeCollection^ get ();
    void set (AttributeTypeCollection^ value);
}


AttributeSetArray Property

AttributeSetArray Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► AttributeSetArray
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetTypeCollection AttributeSetArray { get; set; }
Public Property AttributeSetArray As AttributeSetTypeCollection
    Get
    Set
public:
property AttributeSetTypeCollection^ AttributeSetArray {
    AttributeSetTypeCollection^ get ();
    void set (AttributeSetTypeCollection^ value);
}


AutoPay Property

AutoPay Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► AutoPay
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPay { get; set; }
Public Property AutoPay As Boolean
    Get
    Set
public:
property bool AutoPay {
    bool get ();
    void set (bool value);
}


AutoPaySpecified Property

AutoPaySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► AutoPaySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPaySpecified { get; set; }
Public Property AutoPaySpecified As Boolean
    Get
    Set
public:
property bool AutoPaySpecified {
    bool get ();
    void set (bool value);
}


AvailableForPickupDropOff Property

AvailableForPickupDropOff Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► AvailableForPickupDropOff
Declaration Syntax
C# Visual Basic Visual C++
public bool AvailableForPickupDropOff { get; set; }
Public Property AvailableForPickupDropOff As Boolean
    Get
    Set
public:
property bool AvailableForPickupDropOff {
    bool get ();
    void set (bool value);
}


AvailableForPickupDropOffSpecified Property

AvailableForPickupDropOffSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► AvailableForPickupDropOffSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AvailableForPickupDropOffSpecified { get; set; }
Public Property AvailableForPickupDropOffSpecified As Boolean
    Get
    Set
public:
property bool AvailableForPickupDropOffSpecified {
    bool get ();
    void set (bool value);
}


BestOfferDetails Property

BestOfferDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BestOfferDetails
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferDetailsType BestOfferDetails { get; set; }
Public Property BestOfferDetails As BestOfferDetailsType
    Get
    Set
public:
property BestOfferDetailsType^ BestOfferDetails {
    BestOfferDetailsType^ get ();
    void set (BestOfferDetailsType^ value);
}


BestOfferEnabled Property

BestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferEnabled { get; set; }
Public Property BestOfferEnabled As Boolean
    Get
    Set
public:
property bool BestOfferEnabled {
    bool get ();
    void set (bool value);
}


BestOfferEnabledSpecified Property

BestOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BestOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferEnabledSpecified { get; set; }
Public Property BestOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool BestOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


BiddingDetails Property

BiddingDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BiddingDetails
Declaration Syntax
C# Visual Basic Visual C++
public BiddingDetailsType BiddingDetails { get; set; }
Public Property BiddingDetails As BiddingDetailsType
    Get
    Set
public:
property BiddingDetailsType^ BiddingDetails {
    BiddingDetailsType^ get ();
    void set (BiddingDetailsType^ value);
}


BidGroupItem Property

BidGroupItem Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BidGroupItem
Declaration Syntax
C# Visual Basic Visual C++
public bool BidGroupItem { get; set; }
Public Property BidGroupItem As Boolean
    Get
    Set
public:
property bool BidGroupItem {
    bool get ();
    void set (bool value);
}


BidGroupItemSpecified Property

BidGroupItemSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BidGroupItemSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidGroupItemSpecified { get; set; }
Public Property BidGroupItemSpecified As Boolean
    Get
    Set
public:
property bool BidGroupItemSpecified {
    bool get ();
    void set (bool value);
}


BusinessSellerDetails Property

BusinessSellerDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BusinessSellerDetails
Declaration Syntax
C# Visual Basic Visual C++
public BusinessSellerDetailsType BusinessSellerDetails { get; set; }
Public Property BusinessSellerDetails As BusinessSellerDetailsType
    Get
    Set
public:
property BusinessSellerDetailsType^ BusinessSellerDetails {
    BusinessSellerDetailsType^ get ();
    void set (BusinessSellerDetailsType^ value);
}


BuyerGuaranteePrice Property

BuyerGuaranteePrice Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BuyerGuaranteePrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType BuyerGuaranteePrice { get; set; }
Public Property BuyerGuaranteePrice As AmountType
    Get
    Set
public:
property AmountType^ BuyerGuaranteePrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


BuyerProtection Property

BuyerProtection Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BuyerProtection
Declaration Syntax
C# Visual Basic Visual C++
public BuyerProtectionCodeType BuyerProtection { get; set; }
Public Property BuyerProtection As BuyerProtectionCodeType
    Get
    Set
public:
property BuyerProtectionCodeType BuyerProtection {
    BuyerProtectionCodeType get ();
    void set (BuyerProtectionCodeType value);
}


BuyerProtectionSpecified Property

BuyerProtectionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BuyerProtectionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerProtectionSpecified { get; set; }
Public Property BuyerProtectionSpecified As Boolean
    Get
    Set
public:
property bool BuyerProtectionSpecified {
    bool get ();
    void set (bool value);
}


BuyerRequirementDetails Property

BuyerRequirementDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BuyerRequirementDetails
Declaration Syntax
C# Visual Basic Visual C++
public BuyerRequirementDetailsType BuyerRequirementDetails { get; set; }
Public Property BuyerRequirementDetails As BuyerRequirementDetailsType
    Get
    Set
public:
property BuyerRequirementDetailsType^ BuyerRequirementDetails {
    BuyerRequirementDetailsType^ get ();
    void set (BuyerRequirementDetailsType^ value);
}


BuyerResponsibleForShipping Property

BuyerResponsibleForShipping Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BuyerResponsibleForShipping
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerResponsibleForShipping { get; set; }
Public Property BuyerResponsibleForShipping As Boolean
    Get
    Set
public:
property bool BuyerResponsibleForShipping {
    bool get ();
    void set (bool value);
}


BuyerResponsibleForShippingSpecified Property

BuyerResponsibleForShippingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BuyerResponsibleForShippingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerResponsibleForShippingSpecified { get; set; }
Public Property BuyerResponsibleForShippingSpecified As Boolean
    Get
    Set
public:
property bool BuyerResponsibleForShippingSpecified {
    bool get ();
    void set (bool value);
}


BuyItNowPrice Property

BuyItNowPrice Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► BuyItNowPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType BuyItNowPrice { get; set; }
Public Property BuyItNowPrice As AmountType
    Get
    Set
public:
property AmountType^ BuyItNowPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


CategoryBasedAttributesPrefill Property

CategoryBasedAttributesPrefill Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► CategoryBasedAttributesPrefill
Declaration Syntax
C# Visual Basic Visual C++
public bool CategoryBasedAttributesPrefill { get; set; }
Public Property CategoryBasedAttributesPrefill As Boolean
    Get
    Set
public:
property bool CategoryBasedAttributesPrefill {
    bool get ();
    void set (bool value);
}


CategoryMappingAllowed Property

CategoryMappingAllowed Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► CategoryMappingAllowed
Declaration Syntax
C# Visual Basic Visual C++
public bool CategoryMappingAllowed { get; set; }
Public Property CategoryMappingAllowed As Boolean
    Get
    Set
public:
property bool CategoryMappingAllowed {
    bool get ();
    void set (bool value);
}


CeilingPrice Property

CeilingPrice Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► CeilingPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CeilingPrice { get; set; }
Public Property CeilingPrice As AmountType
    Get
    Set
public:
property AmountType^ CeilingPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


Charity Property

Charity Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Charity
Declaration Syntax
C# Visual Basic Visual C++
public CharityType Charity { get; set; }
Public Property Charity As CharityType
    Get
    Set
public:
property CharityType^ Charity {
    CharityType^ get ();
    void set (CharityType^ value);
}


ClassifiedAdPayPerLeadFee Property

ClassifiedAdPayPerLeadFee Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ClassifiedAdPayPerLeadFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ClassifiedAdPayPerLeadFee { get; set; }
Public Property ClassifiedAdPayPerLeadFee As AmountType
    Get
    Set
public:
property AmountType^ ClassifiedAdPayPerLeadFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


ConditionDefinition Property

ConditionDefinition Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ConditionDefinition
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionDefinition { get; set; }
Public Property ConditionDefinition As String
    Get
    Set
public:
property String^ ConditionDefinition {
    String^ get ();
    void set (String^ value);
}


ConditionDescription Property

ConditionDescription Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ConditionDescription
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionDescription { get; set; }
Public Property ConditionDescription As String
    Get
    Set
public:
property String^ ConditionDescription {
    String^ get ();
    void set (String^ value);
}


ConditionDisplayName Property

ConditionDisplayName Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ConditionDisplayName
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionDisplayName { get; set; }
Public Property ConditionDisplayName As String
    Get
    Set
public:
property String^ ConditionDisplayName {
    String^ get ();
    void set (String^ value);
}


ConditionID Property

ConditionID Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ConditionID
Declaration Syntax
C# Visual Basic Visual C++
public int ConditionID { get; set; }
Public Property ConditionID As Integer
    Get
    Set
public:
property int ConditionID {
    int get ();
    void set (int value);
}


ConditionIDSpecified Property

ConditionIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ConditionIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ConditionIDSpecified { get; set; }
Public Property ConditionIDSpecified As Boolean
    Get
    Set
public:
property bool ConditionIDSpecified {
    bool get ();
    void set (bool value);
}


Country Property

Country Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Country
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType Country { get; set; }
Public Property Country As CountryCodeType
    Get
    Set
public:
property CountryCodeType Country {
    CountryCodeType get ();
    void set (CountryCodeType value);
}


CountrySpecified Property

CountrySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► CountrySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CountrySpecified { get; set; }
Public Property CountrySpecified As Boolean
    Get
    Set
public:
property bool CountrySpecified {
    bool get ();
    void set (bool value);
}


CrossBorderTrade Property

CrossBorderTrade Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► CrossBorderTrade
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection CrossBorderTrade { get; set; }
Public Property CrossBorderTrade As StringCollection
    Get
    Set
public:
property StringCollection^ CrossBorderTrade {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


CrossPromotion Property

CrossPromotion Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► CrossPromotion
Declaration Syntax
C# Visual Basic Visual C++
public CrossPromotionsType CrossPromotion { get; set; }
Public Property CrossPromotion As CrossPromotionsType
    Get
    Set
public:
property CrossPromotionsType^ CrossPromotion {
    CrossPromotionsType^ get ();
    void set (CrossPromotionsType^ value);
}


Currency Property

Currency Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Currency
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType Currency { get; set; }
Public Property Currency As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType Currency {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


CurrencySpecified Property

CurrencySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► CurrencySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CurrencySpecified { get; set; }
Public Property CurrencySpecified As Boolean
    Get
    Set
public:
property bool CurrencySpecified {
    bool get ();
    void set (bool value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DescriptionReviseMode Property

DescriptionReviseMode Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► DescriptionReviseMode
Declaration Syntax
C# Visual Basic Visual C++
public DescriptionReviseModeCodeType DescriptionReviseMode { get; set; }
Public Property DescriptionReviseMode As DescriptionReviseModeCodeType
    Get
    Set
public:
property DescriptionReviseModeCodeType DescriptionReviseMode {
    DescriptionReviseModeCodeType get ();
    void set (DescriptionReviseModeCodeType value);
}


DescriptionReviseModeSpecified Property

DescriptionReviseModeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► DescriptionReviseModeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DescriptionReviseModeSpecified { get; set; }
Public Property DescriptionReviseModeSpecified As Boolean
    Get
    Set
public:
property bool DescriptionReviseModeSpecified {
    bool get ();
    void set (bool value);
}


DigitalGoodInfo Property

DigitalGoodInfo Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► DigitalGoodInfo
Declaration Syntax
C# Visual Basic Visual C++
public DigitalGoodInfoType DigitalGoodInfo { get; set; }
Public Property DigitalGoodInfo As DigitalGoodInfoType
    Get
    Set
public:
property DigitalGoodInfoType^ DigitalGoodInfo {
    DigitalGoodInfoType^ get ();
    void set (DigitalGoodInfoType^ value);
}


DisableBuyerRequirements Property

DisableBuyerRequirements Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► DisableBuyerRequirements
Declaration Syntax
C# Visual Basic Visual C++
public bool DisableBuyerRequirements { get; set; }
Public Property DisableBuyerRequirements As Boolean
    Get
    Set
public:
property bool DisableBuyerRequirements {
    bool get ();
    void set (bool value);
}


DisableBuyerRequirementsSpecified Property

DisableBuyerRequirementsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► DisableBuyerRequirementsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisableBuyerRequirementsSpecified { get; set; }
Public Property DisableBuyerRequirementsSpecified As Boolean
    Get
    Set
public:
property bool DisableBuyerRequirementsSpecified {
    bool get ();
    void set (bool value);
}


DiscountPriceInfo Property

DiscountPriceInfo Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► DiscountPriceInfo
Declaration Syntax
C# Visual Basic Visual C++
public DiscountPriceInfoType DiscountPriceInfo { get; set; }
Public Property DiscountPriceInfo As DiscountPriceInfoType
    Get
    Set
public:
property DiscountPriceInfoType^ DiscountPriceInfo {
    DiscountPriceInfoType^ get ();
    void set (DiscountPriceInfoType^ value);
}


DispatchTimeMax Property

DispatchTimeMax Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► DispatchTimeMax
Declaration Syntax
C# Visual Basic Visual C++
public int DispatchTimeMax { get; set; }
Public Property DispatchTimeMax As Integer
    Get
    Set
public:
property int DispatchTimeMax {
    int get ();
    void set (int value);
}


DispatchTimeMaxSpecified Property

DispatchTimeMaxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► DispatchTimeMaxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DispatchTimeMaxSpecified { get; set; }
Public Property DispatchTimeMaxSpecified As Boolean
    Get
    Set
public:
property bool DispatchTimeMaxSpecified {
    bool get ();
    void set (bool value);
}


Distance Property

Distance Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Distance
Declaration Syntax
C# Visual Basic Visual C++
public DistanceType Distance { get; set; }
Public Property Distance As DistanceType
    Get
    Set
public:
property DistanceType^ Distance {
    DistanceType^ get ();
    void set (DistanceType^ value);
}


eBayNotes Property

eBayNotes Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► eBayNotes
Declaration Syntax
C# Visual Basic Visual C++
public string eBayNotes { get; set; }
Public Property eBayNotes As String
    Get
    Set
public:
property String^ eBayNotes {
    String^ get ();
    void set (String^ value);
}


eBayNowAvailable Property

eBayNowAvailable Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► eBayNowAvailable
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayNowAvailable { get; set; }
Public Property eBayNowAvailable As Boolean
    Get
    Set
public:
property bool eBayNowAvailable {
    bool get ();
    void set (bool value);
}


eBayNowAvailableSpecified Property

eBayNowAvailableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► eBayNowAvailableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayNowAvailableSpecified { get; set; }
Public Property eBayNowAvailableSpecified As Boolean
    Get
    Set
public:
property bool eBayNowAvailableSpecified {
    bool get ();
    void set (bool value);
}


eBayNowEligible Property

eBayNowEligible Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► eBayNowEligible
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayNowEligible { get; set; }
Public Property eBayNowEligible As Boolean
    Get
    Set
public:
property bool eBayNowEligible {
    bool get ();
    void set (bool value);
}


eBayNowEligibleSpecified Property

eBayNowEligibleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► eBayNowEligibleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayNowEligibleSpecified { get; set; }
Public Property eBayNowEligibleSpecified As Boolean
    Get
    Set
public:
property bool eBayNowEligibleSpecified {
    bool get ();
    void set (bool value);
}


eBayPlus Property

eBayPlus Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► eBayPlus
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayPlus { get; set; }
Public Property eBayPlus As Boolean
    Get
    Set
public:
property bool eBayPlus {
    bool get ();
    void set (bool value);
}


eBayPlusEligible Property

eBayPlusEligible Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► eBayPlusEligible
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayPlusEligible { get; set; }
Public Property eBayPlusEligible As Boolean
    Get
    Set
public:
property bool eBayPlusEligible {
    bool get ();
    void set (bool value);
}


eBayPlusEligibleSpecified Property

eBayPlusEligibleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► eBayPlusEligibleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayPlusEligibleSpecified { get; set; }
Public Property eBayPlusEligibleSpecified As Boolean
    Get
    Set
public:
property bool eBayPlusEligibleSpecified {
    bool get ();
    void set (bool value);
}


eBayPlusSpecified Property

eBayPlusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► eBayPlusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayPlusSpecified { get; set; }
Public Property eBayPlusSpecified As Boolean
    Get
    Set
public:
property bool eBayPlusSpecified {
    bool get ();
    void set (bool value);
}


EligibleForPickupDropOff Property

EligibleForPickupDropOff Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► EligibleForPickupDropOff
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleForPickupDropOff { get; set; }
Public Property EligibleForPickupDropOff As Boolean
    Get
    Set
public:
property bool EligibleForPickupDropOff {
    bool get ();
    void set (bool value);
}


EligibleForPickupDropOffSpecified Property

EligibleForPickupDropOffSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► EligibleForPickupDropOffSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleForPickupDropOffSpecified { get; set; }
Public Property EligibleForPickupDropOffSpecified As Boolean
    Get
    Set
public:
property bool EligibleForPickupDropOffSpecified {
    bool get ();
    void set (bool value);
}


eMailDeliveryAvailable Property

eMailDeliveryAvailable Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► eMailDeliveryAvailable
Declaration Syntax
C# Visual Basic Visual C++
public bool eMailDeliveryAvailable { get; set; }
Public Property eMailDeliveryAvailable As Boolean
    Get
    Set
public:
property bool eMailDeliveryAvailable {
    bool get ();
    void set (bool value);
}


eMailDeliveryAvailableSpecified Property

eMailDeliveryAvailableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► eMailDeliveryAvailableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eMailDeliveryAvailableSpecified { get; set; }
Public Property eMailDeliveryAvailableSpecified As Boolean
    Get
    Set
public:
property bool eMailDeliveryAvailableSpecified {
    bool get ();
    void set (bool value);
}


ExtendedSellerContactDetails Property

ExtendedSellerContactDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ExtendedSellerContactDetails
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedContactDetailsType ExtendedSellerContactDetails { get; set; }
Public Property ExtendedSellerContactDetails As ExtendedContactDetailsType
    Get
    Set
public:
property ExtendedContactDetailsType^ ExtendedSellerContactDetails {
    ExtendedContactDetailsType^ get ();
    void set (ExtendedContactDetailsType^ value);
}


ExternalProductID Property

ExternalProductID Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ExternalProductID
Declaration Syntax
C# Visual Basic Visual C++
public ExternalProductIDType ExternalProductID { get; set; }
Public Property ExternalProductID As ExternalProductIDType
    Get
    Set
public:
property ExternalProductIDType^ ExternalProductID {
    ExternalProductIDType^ get ();
    void set (ExternalProductIDType^ value);
}


FloorPrice Property

FloorPrice Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► FloorPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType FloorPrice { get; set; }
Public Property FloorPrice As AmountType
    Get
    Set
public:
property AmountType^ FloorPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


FreeAddedCategory Property

FreeAddedCategory Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► FreeAddedCategory
Declaration Syntax
C# Visual Basic Visual C++
public CategoryType FreeAddedCategory { get; set; }
Public Property FreeAddedCategory As CategoryType
    Get
    Set
public:
property CategoryType^ FreeAddedCategory {
    CategoryType^ get ();
    void set (CategoryType^ value);
}


GetItFast Property

GetItFast Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► GetItFast
Declaration Syntax
C# Visual Basic Visual C++
public bool GetItFast { get; set; }
Public Property GetItFast As Boolean
    Get
    Set
public:
property bool GetItFast {
    bool get ();
    void set (bool value);
}


GetItFastSpecified Property

GetItFastSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► GetItFastSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GetItFastSpecified { get; set; }
Public Property GetItFastSpecified As Boolean
    Get
    Set
public:
property bool GetItFastSpecified {
    bool get ();
    void set (bool value);
}


GiftIcon Property

GiftIcon Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► GiftIcon
Declaration Syntax
C# Visual Basic Visual C++
public int GiftIcon { get; set; }
Public Property GiftIcon As Integer
    Get
    Set
public:
property int GiftIcon {
    int get ();
    void set (int value);
}


GiftIconSpecified Property

GiftIconSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► GiftIconSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GiftIconSpecified { get; set; }
Public Property GiftIconSpecified As Boolean
    Get
    Set
public:
property bool GiftIconSpecified {
    bool get ();
    void set (bool value);
}


GiftServices Property

GiftServices Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► GiftServices
Declaration Syntax
C# Visual Basic Visual C++
public GiftServicesCodeTypeCollection GiftServices { get; set; }
Public Property GiftServices As GiftServicesCodeTypeCollection
    Get
    Set
public:
property GiftServicesCodeTypeCollection^ GiftServices {
    GiftServicesCodeTypeCollection^ get ();
    void set (GiftServicesCodeTypeCollection^ value);
}


GroupCategoryID Property

GroupCategoryID Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► GroupCategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string GroupCategoryID { get; set; }
Public Property GroupCategoryID As String
    Get
    Set
public:
property String^ GroupCategoryID {
    String^ get ();
    void set (String^ value);
}


HideFromSearch Property

HideFromSearch Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► HideFromSearch
Declaration Syntax
C# Visual Basic Visual C++
public bool HideFromSearch { get; set; }
Public Property HideFromSearch As Boolean
    Get
    Set
public:
property bool HideFromSearch {
    bool get ();
    void set (bool value);
}


HideFromSearchSpecified Property

HideFromSearchSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► HideFromSearchSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HideFromSearchSpecified { get; set; }
Public Property HideFromSearchSpecified As Boolean
    Get
    Set
public:
property bool HideFromSearchSpecified {
    bool get ();
    void set (bool value);
}


HitCount Property

HitCount Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► HitCount
Declaration Syntax
C# Visual Basic Visual C++
public long HitCount { get; set; }
Public Property HitCount As Long
    Get
    Set
public:
property long long HitCount {
    long long get ();
    void set (long long value);
}


HitCounter Property

HitCounter Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► HitCounter
Declaration Syntax
C# Visual Basic Visual C++
public HitCounterCodeType HitCounter { get; set; }
Public Property HitCounter As HitCounterCodeType
    Get
    Set
public:
property HitCounterCodeType HitCounter {
    HitCounterCodeType get ();
    void set (HitCounterCodeType value);
}


HitCounterSpecified Property

HitCounterSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► HitCounterSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HitCounterSpecified { get; set; }
Public Property HitCounterSpecified As Boolean
    Get
    Set
public:
property bool HitCounterSpecified {
    bool get ();
    void set (bool value);
}


HitCountSpecified Property

HitCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► HitCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HitCountSpecified { get; set; }
Public Property HitCountSpecified As Boolean
    Get
    Set
public:
property bool HitCountSpecified {
    bool get ();
    void set (bool value);
}


IgnoreQuantity Property

IgnoreQuantity Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► IgnoreQuantity
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreQuantity { get; set; }
Public Property IgnoreQuantity As Boolean
    Get
    Set
public:
property bool IgnoreQuantity {
    bool get ();
    void set (bool value);
}


IgnoreQuantitySpecified Property

IgnoreQuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► IgnoreQuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreQuantitySpecified { get; set; }
Public Property IgnoreQuantitySpecified As Boolean
    Get
    Set
public:
property bool IgnoreQuantitySpecified {
    bool get ();
    void set (bool value);
}


IncludeRecommendations Property

IncludeRecommendations Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► IncludeRecommendations
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeRecommendations { get; set; }
Public Property IncludeRecommendations As Boolean
    Get
    Set
public:
property bool IncludeRecommendations {
    bool get ();
    void set (bool value);
}


IntegratedMerchantCreditCardEnabled Property

IntegratedMerchantCreditCardEnabled Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► IntegratedMerchantCreditCardEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool IntegratedMerchantCreditCardEnabled { get; set; }
Public Property IntegratedMerchantCreditCardEnabled As Boolean
    Get
    Set
public:
property bool IntegratedMerchantCreditCardEnabled {
    bool get ();
    void set (bool value);
}


IntegratedMerchantCreditCardEnabledSpecified Property

IntegratedMerchantCreditCardEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► IntegratedMerchantCreditCardEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IntegratedMerchantCreditCardEnabledSpecified { get; set; }
Public Property IntegratedMerchantCreditCardEnabledSpecified As Boolean
    Get
    Set
public:
property bool IntegratedMerchantCreditCardEnabledSpecified {
    bool get ();
    void set (bool value);
}


InventoryTrackingMethod Property

InventoryTrackingMethod Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► InventoryTrackingMethod
Declaration Syntax
C# Visual Basic Visual C++
public InventoryTrackingMethodCodeType InventoryTrackingMethod { get; set; }
Public Property InventoryTrackingMethod As InventoryTrackingMethodCodeType
    Get
    Set
public:
property InventoryTrackingMethodCodeType InventoryTrackingMethod {
    InventoryTrackingMethodCodeType get ();
    void set (InventoryTrackingMethodCodeType value);
}


InventoryTrackingMethodSpecified Property

InventoryTrackingMethodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► InventoryTrackingMethodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InventoryTrackingMethodSpecified { get; set; }
Public Property InventoryTrackingMethodSpecified As Boolean
    Get
    Set
public:
property bool InventoryTrackingMethodSpecified {
    bool get ();
    void set (bool value);
}


IsIntermediatedShippingEligible Property

IsIntermediatedShippingEligible Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► IsIntermediatedShippingEligible
Declaration Syntax
C# Visual Basic Visual C++
public bool IsIntermediatedShippingEligible { get; set; }
Public Property IsIntermediatedShippingEligible As Boolean
    Get
    Set
public:
property bool IsIntermediatedShippingEligible {
    bool get ();
    void set (bool value);
}


IsIntermediatedShippingEligibleSpecified Property

IsIntermediatedShippingEligibleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► IsIntermediatedShippingEligibleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IsIntermediatedShippingEligibleSpecified { get; set; }
Public Property IsIntermediatedShippingEligibleSpecified As Boolean
    Get
    Set
public:
property bool IsIntermediatedShippingEligibleSpecified {
    bool get ();
    void set (bool value);
}


ItemCompatibilityCount Property

ItemCompatibilityCount Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ItemCompatibilityCount
Declaration Syntax
C# Visual Basic Visual C++
public int ItemCompatibilityCount { get; set; }
Public Property ItemCompatibilityCount As Integer
    Get
    Set
public:
property int ItemCompatibilityCount {
    int get ();
    void set (int value);
}


ItemCompatibilityCountSpecified Property

ItemCompatibilityCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ItemCompatibilityCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemCompatibilityCountSpecified { get; set; }
Public Property ItemCompatibilityCountSpecified As Boolean
    Get
    Set
public:
property bool ItemCompatibilityCountSpecified {
    bool get ();
    void set (bool value);
}


ItemCompatibilityList Property

ItemCompatibilityList Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ItemCompatibilityList
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityListType ItemCompatibilityList { get; set; }
Public Property ItemCompatibilityList As ItemCompatibilityListType
    Get
    Set
public:
property ItemCompatibilityListType^ ItemCompatibilityList {
    ItemCompatibilityListType^ get ();
    void set (ItemCompatibilityListType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ItemPolicyViolation Property

ItemPolicyViolation Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ItemPolicyViolation
Declaration Syntax
C# Visual Basic Visual C++
public ItemPolicyViolationType ItemPolicyViolation { get; set; }
Public Property ItemPolicyViolation As ItemPolicyViolationType
    Get
    Set
public:
property ItemPolicyViolationType^ ItemPolicyViolation {
    ItemPolicyViolationType^ get ();
    void set (ItemPolicyViolationType^ value);
}


ItemSpecifics Property

ItemSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ItemSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection ItemSpecifics { get; set; }
Public Property ItemSpecifics As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ ItemSpecifics {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


ItemType Constructor

ItemType Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ItemType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemType()
Public Sub New
public:
ItemType()


LeadCount Property

LeadCount Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LeadCount
Declaration Syntax
C# Visual Basic Visual C++
public int LeadCount { get; set; }
Public Property LeadCount As Integer
    Get
    Set
public:
property int LeadCount {
    int get ();
    void set (int value);
}


LeadCountSpecified Property

LeadCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LeadCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LeadCountSpecified { get; set; }
Public Property LeadCountSpecified As Boolean
    Get
    Set
public:
property bool LeadCountSpecified {
    bool get ();
    void set (bool value);
}


LimitedWarrantyEligible Property

LimitedWarrantyEligible Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LimitedWarrantyEligible
Declaration Syntax
C# Visual Basic Visual C++
public bool LimitedWarrantyEligible { get; set; }
Public Property LimitedWarrantyEligible As Boolean
    Get
    Set
public:
property bool LimitedWarrantyEligible {
    bool get ();
    void set (bool value);
}


LimitedWarrantyEligibleSpecified Property

LimitedWarrantyEligibleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LimitedWarrantyEligibleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LimitedWarrantyEligibleSpecified { get; set; }
Public Property LimitedWarrantyEligibleSpecified As Boolean
    Get
    Set
public:
property bool LimitedWarrantyEligibleSpecified {
    bool get ();
    void set (bool value);
}


ListingCheckoutRedirectPreference Property

ListingCheckoutRedirectPreference Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ListingCheckoutRedirectPreference
Declaration Syntax
C# Visual Basic Visual C++
public ListingCheckoutRedirectPreferenceType ListingCheckoutRedirectPreference { get; set; }
Public Property ListingCheckoutRedirectPreference As ListingCheckoutRedirectPreferenceType
    Get
    Set
public:
property ListingCheckoutRedirectPreferenceType^ ListingCheckoutRedirectPreference {
    ListingCheckoutRedirectPreferenceType^ get ();
    void set (ListingCheckoutRedirectPreferenceType^ value);
}


ListingDesigner Property

ListingDesigner Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ListingDesigner
Declaration Syntax
C# Visual Basic Visual C++
public ListingDesignerType ListingDesigner { get; set; }
Public Property ListingDesigner As ListingDesignerType
    Get
    Set
public:
property ListingDesignerType^ ListingDesigner {
    ListingDesignerType^ get ();
    void set (ListingDesignerType^ value);
}


ListingDetails Property

ListingDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ListingDetails
Declaration Syntax
C# Visual Basic Visual C++
public ListingDetailsType ListingDetails { get; set; }
Public Property ListingDetails As ListingDetailsType
    Get
    Set
public:
property ListingDetailsType^ ListingDetails {
    ListingDetailsType^ get ();
    void set (ListingDetailsType^ value);
}


ListingDuration Property

ListingDuration Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ListingDuration
Declaration Syntax
C# Visual Basic Visual C++
public string ListingDuration { get; set; }
Public Property ListingDuration As String
    Get
    Set
public:
property String^ ListingDuration {
    String^ get ();
    void set (String^ value);
}


ListingEnhancement Property

ListingEnhancement Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ListingEnhancement
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementsCodeTypeCollection ListingEnhancement { get; set; }
Public Property ListingEnhancement As ListingEnhancementsCodeTypeCollection
    Get
    Set
public:
property ListingEnhancementsCodeTypeCollection^ ListingEnhancement {
    ListingEnhancementsCodeTypeCollection^ get ();
    void set (ListingEnhancementsCodeTypeCollection^ value);
}


ListingSubtype2 Property

ListingSubtype2 Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ListingSubtype2
Declaration Syntax
C# Visual Basic Visual C++
public ListingSubtypeCodeType ListingSubtype2 { get; set; }
Public Property ListingSubtype2 As ListingSubtypeCodeType
    Get
    Set
public:
property ListingSubtypeCodeType ListingSubtype2 {
    ListingSubtypeCodeType get ();
    void set (ListingSubtypeCodeType value);
}


ListingSubtype2Specified Property

ListingSubtype2Specified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ListingSubtype2Specified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingSubtype2Specified { get; set; }
Public Property ListingSubtype2Specified As Boolean
    Get
    Set
public:
property bool ListingSubtype2Specified {
    bool get ();
    void set (bool value);
}


ListingType Property

ListingType Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ListingType
Declaration Syntax
C# Visual Basic Visual C++
public ListingTypeCodeType ListingType { get; set; }
Public Property ListingType As ListingTypeCodeType
    Get
    Set
public:
property ListingTypeCodeType ListingType {
    ListingTypeCodeType get ();
    void set (ListingTypeCodeType value);
}


ListingTypeSpecified Property

ListingTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ListingTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingTypeSpecified { get; set; }
Public Property ListingTypeSpecified As Boolean
    Get
    Set
public:
property bool ListingTypeSpecified {
    bool get ();
    void set (bool value);
}


LiveAuction Property

LiveAuction Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LiveAuction
Declaration Syntax
C# Visual Basic Visual C++
public bool LiveAuction { get; set; }
Public Property LiveAuction As Boolean
    Get
    Set
public:
property bool LiveAuction {
    bool get ();
    void set (bool value);
}


LiveAuctionSpecified Property

LiveAuctionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LiveAuctionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LiveAuctionSpecified { get; set; }
Public Property LiveAuctionSpecified As Boolean
    Get
    Set
public:
property bool LiveAuctionSpecified {
    bool get ();
    void set (bool value);
}


LocalListing Property

LocalListing Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LocalListing
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalListing { get; set; }
Public Property LocalListing As Boolean
    Get
    Set
public:
property bool LocalListing {
    bool get ();
    void set (bool value);
}


LocalListingSpecified Property

LocalListingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LocalListingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalListingSpecified { get; set; }
Public Property LocalListingSpecified As Boolean
    Get
    Set
public:
property bool LocalListingSpecified {
    bool get ();
    void set (bool value);
}


Location Property

Location Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Location
Declaration Syntax
C# Visual Basic Visual C++
public string Location { get; set; }
Public Property Location As String
    Get
    Set
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}


LocationDefaulted Property

LocationDefaulted Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LocationDefaulted
Declaration Syntax
C# Visual Basic Visual C++
public bool LocationDefaulted { get; set; }
Public Property LocationDefaulted As Boolean
    Get
    Set
public:
property bool LocationDefaulted {
    bool get ();
    void set (bool value);
}


LocationDefaultedSpecified Property

LocationDefaultedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LocationDefaultedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocationDefaultedSpecified { get; set; }
Public Property LocationDefaultedSpecified As Boolean
    Get
    Set
public:
property bool LocationDefaultedSpecified {
    bool get ();
    void set (bool value);
}


LookupAttributeArray Property

LookupAttributeArray Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LookupAttributeArray
Declaration Syntax
C# Visual Basic Visual C++
public LookupAttributeTypeCollection LookupAttributeArray { get; set; }
Public Property LookupAttributeArray As LookupAttributeTypeCollection
    Get
    Set
public:
property LookupAttributeTypeCollection^ LookupAttributeArray {
    LookupAttributeTypeCollection^ get ();
    void set (LookupAttributeTypeCollection^ value);
}


LotSize Property

LotSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LotSize
Declaration Syntax
C# Visual Basic Visual C++
public int LotSize { get; set; }
Public Property LotSize As Integer
    Get
    Set
public:
property int LotSize {
    int get ();
    void set (int value);
}


LotSizeSpecified Property

LotSizeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► LotSizeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LotSizeSpecified { get; set; }
Public Property LotSizeSpecified As Boolean
    Get
    Set
public:
property bool LotSizeSpecified {
    bool get ();
    void set (bool value);
}


MechanicalCheckAccepted Property

MechanicalCheckAccepted Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► MechanicalCheckAccepted
Declaration Syntax
C# Visual Basic Visual C++
public bool MechanicalCheckAccepted { get; set; }
Public Property MechanicalCheckAccepted As Boolean
    Get
    Set
public:
property bool MechanicalCheckAccepted {
    bool get ();
    void set (bool value);
}


MechanicalCheckAcceptedSpecified Property

MechanicalCheckAcceptedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► MechanicalCheckAcceptedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MechanicalCheckAcceptedSpecified { get; set; }
Public Property MechanicalCheckAcceptedSpecified As Boolean
    Get
    Set
public:
property bool MechanicalCheckAcceptedSpecified {
    bool get ();
    void set (bool value);
}


MotorsGermanySearchable Property

MotorsGermanySearchable Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► MotorsGermanySearchable
Declaration Syntax
C# Visual Basic Visual C++
public bool MotorsGermanySearchable { get; set; }
Public Property MotorsGermanySearchable As Boolean
    Get
    Set
public:
property bool MotorsGermanySearchable {
    bool get ();
    void set (bool value);
}


MotorsGermanySearchableSpecified Property

MotorsGermanySearchableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► MotorsGermanySearchableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MotorsGermanySearchableSpecified { get; set; }
Public Property MotorsGermanySearchableSpecified As Boolean
    Get
    Set
public:
property bool MotorsGermanySearchableSpecified {
    bool get ();
    void set (bool value);
}


NewLeadCount Property

NewLeadCount Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► NewLeadCount
Declaration Syntax
C# Visual Basic Visual C++
public int NewLeadCount { get; set; }
Public Property NewLeadCount As Integer
    Get
    Set
public:
property int NewLeadCount {
    int get ();
    void set (int value);
}


NewLeadCountSpecified Property

NewLeadCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► NewLeadCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewLeadCountSpecified { get; set; }
Public Property NewLeadCountSpecified As Boolean
    Get
    Set
public:
property bool NewLeadCountSpecified {
    bool get ();
    void set (bool value);
}


PartnerCode Property

PartnerCode Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PartnerCode
Declaration Syntax
C# Visual Basic Visual C++
public string PartnerCode { get; set; }
Public Property PartnerCode As String
    Get
    Set
public:
property String^ PartnerCode {
    String^ get ();
    void set (String^ value);
}


PartnerName Property

PartnerName Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PartnerName
Declaration Syntax
C# Visual Basic Visual C++
public string PartnerName { get; set; }
Public Property PartnerName As String
    Get
    Set
public:
property String^ PartnerName {
    String^ get ();
    void set (String^ value);
}


PaymentAllowedSite Property

PaymentAllowedSite Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PaymentAllowedSite
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeTypeCollection PaymentAllowedSite { get; set; }
Public Property PaymentAllowedSite As SiteCodeTypeCollection
    Get
    Set
public:
property SiteCodeTypeCollection^ PaymentAllowedSite {
    SiteCodeTypeCollection^ get ();
    void set (SiteCodeTypeCollection^ value);
}


PaymentDetails Property

PaymentDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PaymentDetails
Declaration Syntax
C# Visual Basic Visual C++
public PaymentDetailsType PaymentDetails { get; set; }
Public Property PaymentDetails As PaymentDetailsType
    Get
    Set
public:
property PaymentDetailsType^ PaymentDetails {
    PaymentDetailsType^ get ();
    void set (PaymentDetailsType^ value);
}


PaymentMethods Property

PaymentMethods Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PaymentMethods
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeTypeCollection PaymentMethods { get; set; }
Public Property PaymentMethods As BuyerPaymentMethodCodeTypeCollection
    Get
    Set
public:
property BuyerPaymentMethodCodeTypeCollection^ PaymentMethods {
    BuyerPaymentMethodCodeTypeCollection^ get ();
    void set (BuyerPaymentMethodCodeTypeCollection^ value);
}


PayPalEmailAddress Property

PayPalEmailAddress Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PayPalEmailAddress
Declaration Syntax
C# Visual Basic Visual C++
public string PayPalEmailAddress { get; set; }
Public Property PayPalEmailAddress As String
    Get
    Set
public:
property String^ PayPalEmailAddress {
    String^ get ();
    void set (String^ value);
}


PickupInStoreDetails Property

PickupInStoreDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PickupInStoreDetails
Declaration Syntax
C# Visual Basic Visual C++
public PickupInStoreDetailsType PickupInStoreDetails { get; set; }
Public Property PickupInStoreDetails As PickupInStoreDetailsType
    Get
    Set
public:
property PickupInStoreDetailsType^ PickupInStoreDetails {
    PickupInStoreDetailsType^ get ();
    void set (PickupInStoreDetailsType^ value);
}


PictureDetails Property

PictureDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PictureDetails
Declaration Syntax
C# Visual Basic Visual C++
public PictureDetailsType PictureDetails { get; set; }
Public Property PictureDetails As PictureDetailsType
    Get
    Set
public:
property PictureDetailsType^ PictureDetails {
    PictureDetailsType^ get ();
    void set (PictureDetailsType^ value);
}


PostalCode Property

PostalCode Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PostalCode
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


PostCheckoutExperienceEnabled Property

PostCheckoutExperienceEnabled Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PostCheckoutExperienceEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool PostCheckoutExperienceEnabled { get; set; }
Public Property PostCheckoutExperienceEnabled As Boolean
    Get
    Set
public:
property bool PostCheckoutExperienceEnabled {
    bool get ();
    void set (bool value);
}


PostCheckoutExperienceEnabledSpecified Property

PostCheckoutExperienceEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PostCheckoutExperienceEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PostCheckoutExperienceEnabledSpecified { get; set; }
Public Property PostCheckoutExperienceEnabledSpecified As Boolean
    Get
    Set
public:
property bool PostCheckoutExperienceEnabledSpecified {
    bool get ();
    void set (bool value);
}


PrimaryCategory Property

PrimaryCategory Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PrimaryCategory
Declaration Syntax
C# Visual Basic Visual C++
public CategoryType PrimaryCategory { get; set; }
Public Property PrimaryCategory As CategoryType
    Get
    Set
public:
property CategoryType^ PrimaryCategory {
    CategoryType^ get ();
    void set (CategoryType^ value);
}


PrivateListing Property

PrivateListing Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PrivateListing
Declaration Syntax
C# Visual Basic Visual C++
public bool PrivateListing { get; set; }
Public Property PrivateListing As Boolean
    Get
    Set
public:
property bool PrivateListing {
    bool get ();
    void set (bool value);
}


PrivateListingSpecified Property

PrivateListingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PrivateListingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PrivateListingSpecified { get; set; }
Public Property PrivateListingSpecified As Boolean
    Get
    Set
public:
property bool PrivateListingSpecified {
    bool get ();
    void set (bool value);
}


PrivateNotes Property

PrivateNotes Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► PrivateNotes
Declaration Syntax
C# Visual Basic Visual C++
public string PrivateNotes { get; set; }
Public Property PrivateNotes As String
    Get
    Set
public:
property String^ PrivateNotes {
    String^ get ();
    void set (String^ value);
}


ProductListingDetails Property

ProductListingDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ProductListingDetails
Declaration Syntax
C# Visual Basic Visual C++
public ProductListingDetailsType ProductListingDetails { get; set; }
Public Property ProductListingDetails As ProductListingDetailsType
    Get
    Set
public:
property ProductListingDetailsType^ ProductListingDetails {
    ProductListingDetailsType^ get ();
    void set (ProductListingDetailsType^ value);
}


ProxyItem Property

ProxyItem Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ProxyItem
Declaration Syntax
C# Visual Basic Visual C++
public bool ProxyItem { get; set; }
Public Property ProxyItem As Boolean
    Get
    Set
public:
property bool ProxyItem {
    bool get ();
    void set (bool value);
}


ProxyItemSpecified Property

ProxyItemSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ProxyItemSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProxyItemSpecified { get; set; }
Public Property ProxyItemSpecified As Boolean
    Get
    Set
public:
property bool ProxyItemSpecified {
    bool get ();
    void set (bool value);
}


Quantity Property

Quantity Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public int Quantity { get; set; }
Public Property Quantity As Integer
    Get
    Set
public:
property int Quantity {
    int get ();
    void set (int value);
}


QuantityAvailable Property

QuantityAvailable Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► QuantityAvailable
Declaration Syntax
C# Visual Basic Visual C++
public int QuantityAvailable { get; set; }
Public Property QuantityAvailable As Integer
    Get
    Set
public:
property int QuantityAvailable {
    int get ();
    void set (int value);
}


QuantityAvailableHint Property

QuantityAvailableHint Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► QuantityAvailableHint
Declaration Syntax
C# Visual Basic Visual C++
public QuantityAvailableHintCodeType QuantityAvailableHint { get; set; }
Public Property QuantityAvailableHint As QuantityAvailableHintCodeType
    Get
    Set
public:
property QuantityAvailableHintCodeType QuantityAvailableHint {
    QuantityAvailableHintCodeType get ();
    void set (QuantityAvailableHintCodeType value);
}


QuantityAvailableHintSpecified Property

QuantityAvailableHintSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► QuantityAvailableHintSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityAvailableHintSpecified { get; set; }
Public Property QuantityAvailableHintSpecified As Boolean
    Get
    Set
public:
property bool QuantityAvailableHintSpecified {
    bool get ();
    void set (bool value);
}


QuantityAvailableSpecified Property

QuantityAvailableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► QuantityAvailableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityAvailableSpecified { get; set; }
Public Property QuantityAvailableSpecified As Boolean
    Get
    Set
public:
property bool QuantityAvailableSpecified {
    bool get ();
    void set (bool value);
}


QuantityInfo Property

QuantityInfo Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► QuantityInfo
Declaration Syntax
C# Visual Basic Visual C++
public QuantityInfoType QuantityInfo { get; set; }
Public Property QuantityInfo As QuantityInfoType
    Get
    Set
public:
property QuantityInfoType^ QuantityInfo {
    QuantityInfoType^ get ();
    void set (QuantityInfoType^ value);
}


QuantityRestrictionPerBuyer Property

QuantityRestrictionPerBuyer Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► QuantityRestrictionPerBuyer
Declaration Syntax
C# Visual Basic Visual C++
public QuantityRestrictionPerBuyerInfoType QuantityRestrictionPerBuyer { get; set; }
Public Property QuantityRestrictionPerBuyer As QuantityRestrictionPerBuyerInfoType
    Get
    Set
public:
property QuantityRestrictionPerBuyerInfoType^ QuantityRestrictionPerBuyer {
    QuantityRestrictionPerBuyerInfoType^ get ();
    void set (QuantityRestrictionPerBuyerInfoType^ value);
}


QuantitySpecified Property

QuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► QuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySpecified { get; set; }
Public Property QuantitySpecified As Boolean
    Get
    Set
public:
property bool QuantitySpecified {
    bool get ();
    void set (bool value);
}


QuantityThreshold Property

QuantityThreshold Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► QuantityThreshold
Declaration Syntax
C# Visual Basic Visual C++
public int QuantityThreshold { get; set; }
Public Property QuantityThreshold As Integer
    Get
    Set
public:
property int QuantityThreshold {
    int get ();
    void set (int value);
}


QuantityThresholdSpecified Property

QuantityThresholdSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► QuantityThresholdSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityThresholdSpecified { get; set; }
Public Property QuantityThresholdSpecified As Boolean
    Get
    Set
public:
property bool QuantityThresholdSpecified {
    bool get ();
    void set (bool value);
}


QuestionCount Property

QuestionCount Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► QuestionCount
Declaration Syntax
C# Visual Basic Visual C++
public long QuestionCount { get; set; }
Public Property QuestionCount As Long
    Get
    Set
public:
property long long QuestionCount {
    long long get ();
    void set (long long value);
}


QuestionCountSpecified Property

QuestionCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► QuestionCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuestionCountSpecified { get; set; }
Public Property QuestionCountSpecified As Boolean
    Get
    Set
public:
property bool QuestionCountSpecified {
    bool get ();
    void set (bool value);
}


ReasonHideFromSearch Property

ReasonHideFromSearch Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ReasonHideFromSearch
Declaration Syntax
C# Visual Basic Visual C++
public ReasonHideFromSearchCodeType ReasonHideFromSearch { get; set; }
Public Property ReasonHideFromSearch As ReasonHideFromSearchCodeType
    Get
    Set
public:
property ReasonHideFromSearchCodeType ReasonHideFromSearch {
    ReasonHideFromSearchCodeType get ();
    void set (ReasonHideFromSearchCodeType value);
}


ReasonHideFromSearchSpecified Property

ReasonHideFromSearchSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ReasonHideFromSearchSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReasonHideFromSearchSpecified { get; set; }
Public Property ReasonHideFromSearchSpecified As Boolean
    Get
    Set
public:
property bool ReasonHideFromSearchSpecified {
    bool get ();
    void set (bool value);
}


RegionID Property

RegionID Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► RegionID
Declaration Syntax
C# Visual Basic Visual C++
public string RegionID { get; set; }
Public Property RegionID As String
    Get
    Set
public:
property String^ RegionID {
    String^ get ();
    void set (String^ value);
}


Relisted Property

Relisted Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Relisted
Declaration Syntax
C# Visual Basic Visual C++
public bool Relisted { get; set; }
Public Property Relisted As Boolean
    Get
    Set
public:
property bool Relisted {
    bool get ();
    void set (bool value);
}


RelistedSpecified Property

RelistedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► RelistedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RelistedSpecified { get; set; }
Public Property RelistedSpecified As Boolean
    Get
    Set
public:
property bool RelistedSpecified {
    bool get ();
    void set (bool value);
}


RelistLink Property

RelistLink Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► RelistLink
Declaration Syntax
C# Visual Basic Visual C++
public bool RelistLink { get; set; }
Public Property RelistLink As Boolean
    Get
    Set
public:
property bool RelistLink {
    bool get ();
    void set (bool value);
}


RelistLinkSpecified Property

RelistLinkSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► RelistLinkSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RelistLinkSpecified { get; set; }
Public Property RelistLinkSpecified As Boolean
    Get
    Set
public:
property bool RelistLinkSpecified {
    bool get ();
    void set (bool value);
}


RelistParentID Property

RelistParentID Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► RelistParentID
Declaration Syntax
C# Visual Basic Visual C++
public long RelistParentID { get; set; }
Public Property RelistParentID As Long
    Get
    Set
public:
property long long RelistParentID {
    long long get ();
    void set (long long value);
}


RelistParentIDSpecified Property

RelistParentIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► RelistParentIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RelistParentIDSpecified { get; set; }
Public Property RelistParentIDSpecified As Boolean
    Get
    Set
public:
property bool RelistParentIDSpecified {
    bool get ();
    void set (bool value);
}


ReservePrice Property

ReservePrice Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ReservePrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ReservePrice { get; set; }
Public Property ReservePrice As AmountType
    Get
    Set
public:
property AmountType^ ReservePrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


ReturnPolicy Property

ReturnPolicy Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ReturnPolicy
Declaration Syntax
C# Visual Basic Visual C++
public ReturnPolicyType ReturnPolicy { get; set; }
Public Property ReturnPolicy As ReturnPolicyType
    Get
    Set
public:
property ReturnPolicyType^ ReturnPolicy {
    ReturnPolicyType^ get ();
    void set (ReturnPolicyType^ value);
}


ReviseStatus Property

ReviseStatus Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ReviseStatus
Declaration Syntax
C# Visual Basic Visual C++
public ReviseStatusType ReviseStatus { get; set; }
Public Property ReviseStatus As ReviseStatusType
    Get
    Set
public:
property ReviseStatusType^ ReviseStatus {
    ReviseStatusType^ get ();
    void set (ReviseStatusType^ value);
}


ScheduleTime Property

ScheduleTime Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ScheduleTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ScheduleTime { get; set; }
Public Property ScheduleTime As DateTime
    Get
    Set
public:
property DateTime ScheduleTime {
    DateTime get ();
    void set (DateTime value);
}


ScheduleTimeSpecified Property

ScheduleTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ScheduleTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ScheduleTimeSpecified { get; set; }
Public Property ScheduleTimeSpecified As Boolean
    Get
    Set
public:
property bool ScheduleTimeSpecified {
    bool get ();
    void set (bool value);
}


SearchDetails Property

SearchDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SearchDetails
Declaration Syntax
C# Visual Basic Visual C++
public SearchDetailsType SearchDetails { get; set; }
Public Property SearchDetails As SearchDetailsType
    Get
    Set
public:
property SearchDetailsType^ SearchDetails {
    SearchDetailsType^ get ();
    void set (SearchDetailsType^ value);
}


SecondaryCategory Property

SecondaryCategory Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SecondaryCategory
Declaration Syntax
C# Visual Basic Visual C++
public CategoryType SecondaryCategory { get; set; }
Public Property SecondaryCategory As CategoryType
    Get
    Set
public:
property CategoryType^ SecondaryCategory {
    CategoryType^ get ();
    void set (CategoryType^ value);
}


Seller Property

Seller Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Seller
Declaration Syntax
C# Visual Basic Visual C++
public UserType Seller { get; set; }
Public Property Seller As UserType
    Get
    Set
public:
property UserType^ Seller {
    UserType^ get ();
    void set (UserType^ value);
}


SellerContactDetails Property

SellerContactDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SellerContactDetails
Declaration Syntax
C# Visual Basic Visual C++
public AddressType SellerContactDetails { get; set; }
Public Property SellerContactDetails As AddressType
    Get
    Set
public:
property AddressType^ SellerContactDetails {
    AddressType^ get ();
    void set (AddressType^ value);
}


SellerInventoryID Property

SellerInventoryID Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SellerInventoryID
Declaration Syntax
C# Visual Basic Visual C++
public string SellerInventoryID { get; set; }
Public Property SellerInventoryID As String
    Get
    Set
public:
property String^ SellerInventoryID {
    String^ get ();
    void set (String^ value);
}


SellerProfiles Property

SellerProfiles Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SellerProfiles
Declaration Syntax
C# Visual Basic Visual C++
public SellerProfilesType SellerProfiles { get; set; }
Public Property SellerProfiles As SellerProfilesType
    Get
    Set
public:
property SellerProfilesType^ SellerProfiles {
    SellerProfilesType^ get ();
    void set (SellerProfilesType^ value);
}


SellerProvidedTitle Property

SellerProvidedTitle Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SellerProvidedTitle
Declaration Syntax
C# Visual Basic Visual C++
public string SellerProvidedTitle { get; set; }
Public Property SellerProvidedTitle As String
    Get
    Set
public:
property String^ SellerProvidedTitle {
    String^ get ();
    void set (String^ value);
}


SellerVacationNote Property

SellerVacationNote Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SellerVacationNote
Declaration Syntax
C# Visual Basic Visual C++
public string SellerVacationNote { get; set; }
Public Property SellerVacationNote As String
    Get
    Set
public:
property String^ SellerVacationNote {
    String^ get ();
    void set (String^ value);
}


SellingStatus Property

SellingStatus Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SellingStatus
Declaration Syntax
C# Visual Basic Visual C++
public SellingStatusType SellingStatus { get; set; }
Public Property SellingStatus As SellingStatusType
    Get
    Set
public:
property SellingStatusType^ SellingStatus {
    SellingStatusType^ get ();
    void set (SellingStatusType^ value);
}


ShippingDetails Property

ShippingDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ShippingDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShippingDetailsType ShippingDetails { get; set; }
Public Property ShippingDetails As ShippingDetailsType
    Get
    Set
public:
property ShippingDetailsType^ ShippingDetails {
    ShippingDetailsType^ get ();
    void set (ShippingDetailsType^ value);
}


ShippingOverride Property

ShippingOverride Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ShippingOverride
Declaration Syntax
C# Visual Basic Visual C++
public ShippingOverrideType ShippingOverride { get; set; }
Public Property ShippingOverride As ShippingOverrideType
    Get
    Set
public:
property ShippingOverrideType^ ShippingOverride {
    ShippingOverrideType^ get ();
    void set (ShippingOverrideType^ value);
}


ShippingPackageDetails Property

ShippingPackageDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ShippingPackageDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShipPackageDetailsType ShippingPackageDetails { get; set; }
Public Property ShippingPackageDetails As ShipPackageDetailsType
    Get
    Set
public:
property ShipPackageDetailsType^ ShippingPackageDetails {
    ShipPackageDetailsType^ get ();
    void set (ShipPackageDetailsType^ value);
}


ShippingServiceCostOverrideList Property

ShippingServiceCostOverrideList Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ShippingServiceCostOverrideList
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCostOverrideListType ShippingServiceCostOverrideList { get; set; }
Public Property ShippingServiceCostOverrideList As ShippingServiceCostOverrideListType
    Get
    Set
public:
property ShippingServiceCostOverrideListType^ ShippingServiceCostOverrideList {
    ShippingServiceCostOverrideListType^ get ();
    void set (ShippingServiceCostOverrideListType^ value);
}


ShippingTermsInDescription Property

ShippingTermsInDescription Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ShippingTermsInDescription
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTermsInDescription { get; set; }
Public Property ShippingTermsInDescription As Boolean
    Get
    Set
public:
property bool ShippingTermsInDescription {
    bool get ();
    void set (bool value);
}


ShippingTermsInDescriptionSpecified Property

ShippingTermsInDescriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ShippingTermsInDescriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTermsInDescriptionSpecified { get; set; }
Public Property ShippingTermsInDescriptionSpecified As Boolean
    Get
    Set
public:
property bool ShippingTermsInDescriptionSpecified {
    bool get ();
    void set (bool value);
}


ShipToLocations Property

ShipToLocations Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ShipToLocations
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ShipToLocations { get; set; }
Public Property ShipToLocations As StringCollection
    Get
    Set
public:
property StringCollection^ ShipToLocations {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Site Property

Site Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Site
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType Site { get; set; }
Public Property Site As SiteCodeType
    Get
    Set
public:
property SiteCodeType Site {
    SiteCodeType get ();
    void set (SiteCodeType value);
}


SiteSpecified Property

SiteSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SiteSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SiteSpecified { get; set; }
Public Property SiteSpecified As Boolean
    Get
    Set
public:
property bool SiteSpecified {
    bool get ();
    void set (bool value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


SkypeContactOption Property

SkypeContactOption Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SkypeContactOption
Declaration Syntax
C# Visual Basic Visual C++
public SkypeContactOptionCodeTypeCollection SkypeContactOption { get; set; }
Public Property SkypeContactOption As SkypeContactOptionCodeTypeCollection
    Get
    Set
public:
property SkypeContactOptionCodeTypeCollection^ SkypeContactOption {
    SkypeContactOptionCodeTypeCollection^ get ();
    void set (SkypeContactOptionCodeTypeCollection^ value);
}


SkypeEnabled Property

SkypeEnabled Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SkypeEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool SkypeEnabled { get; set; }
Public Property SkypeEnabled As Boolean
    Get
    Set
public:
property bool SkypeEnabled {
    bool get ();
    void set (bool value);
}


SkypeEnabledSpecified Property

SkypeEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SkypeEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SkypeEnabledSpecified { get; set; }
Public Property SkypeEnabledSpecified As Boolean
    Get
    Set
public:
property bool SkypeEnabledSpecified {
    bool get ();
    void set (bool value);
}


SkypeID Property

SkypeID Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SkypeID
Declaration Syntax
C# Visual Basic Visual C++
public string SkypeID { get; set; }
Public Property SkypeID As String
    Get
    Set
public:
property String^ SkypeID {
    String^ get ();
    void set (String^ value);
}


StartPrice Property

StartPrice Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► StartPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType StartPrice { get; set; }
Public Property StartPrice As AmountType
    Get
    Set
public:
property AmountType^ StartPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


Storefront Property

Storefront Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Storefront
Declaration Syntax
C# Visual Basic Visual C++
public StorefrontType Storefront { get; set; }
Public Property Storefront As StorefrontType
    Get
    Set
public:
property StorefrontType^ Storefront {
    StorefrontType^ get ();
    void set (StorefrontType^ value);
}


SubTitle Property

SubTitle Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► SubTitle
Declaration Syntax
C# Visual Basic Visual C++
public string SubTitle { get; set; }
Public Property SubTitle As String
    Get
    Set
public:
property String^ SubTitle {
    String^ get ();
    void set (String^ value);
}


TaxCategory Property

TaxCategory Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► TaxCategory
Declaration Syntax
C# Visual Basic Visual C++
public string TaxCategory { get; set; }
Public Property TaxCategory As String
    Get
    Set
public:
property String^ TaxCategory {
    String^ get ();
    void set (String^ value);
}


ThirdPartyCheckout Property

ThirdPartyCheckout Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ThirdPartyCheckout
Declaration Syntax
C# Visual Basic Visual C++
public bool ThirdPartyCheckout { get; set; }
Public Property ThirdPartyCheckout As Boolean
    Get
    Set
public:
property bool ThirdPartyCheckout {
    bool get ();
    void set (bool value);
}


ThirdPartyCheckoutIntegration Property

ThirdPartyCheckoutIntegration Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ThirdPartyCheckoutIntegration
Declaration Syntax
C# Visual Basic Visual C++
public bool ThirdPartyCheckoutIntegration { get; set; }
Public Property ThirdPartyCheckoutIntegration As Boolean
    Get
    Set
public:
property bool ThirdPartyCheckoutIntegration {
    bool get ();
    void set (bool value);
}


ThirdPartyCheckoutIntegrationSpecified Property

ThirdPartyCheckoutIntegrationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ThirdPartyCheckoutIntegrationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ThirdPartyCheckoutIntegrationSpecified { get; set; }
Public Property ThirdPartyCheckoutIntegrationSpecified As Boolean
    Get
    Set
public:
property bool ThirdPartyCheckoutIntegrationSpecified {
    bool get ();
    void set (bool value);
}


ThirdPartyCheckoutSpecified Property

ThirdPartyCheckoutSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► ThirdPartyCheckoutSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ThirdPartyCheckoutSpecified { get; set; }
Public Property ThirdPartyCheckoutSpecified As Boolean
    Get
    Set
public:
property bool ThirdPartyCheckoutSpecified {
    bool get ();
    void set (bool value);
}


TimeLeft Property

TimeLeft Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► TimeLeft
Declaration Syntax
C# Visual Basic Visual C++
public string TimeLeft { get; set; }
Public Property TimeLeft As String
    Get
    Set
public:
property String^ TimeLeft {
    String^ get ();
    void set (String^ value);
}


Title Property

Title Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Title
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}


TopRatedListing Property

TopRatedListing Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► TopRatedListing
Declaration Syntax
C# Visual Basic Visual C++
public bool TopRatedListing { get; set; }
Public Property TopRatedListing As Boolean
    Get
    Set
public:
property bool TopRatedListing {
    bool get ();
    void set (bool value);
}


TopRatedListingSpecified Property

TopRatedListingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► TopRatedListingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TopRatedListingSpecified { get; set; }
Public Property TopRatedListingSpecified As Boolean
    Get
    Set
public:
property bool TopRatedListingSpecified {
    bool get ();
    void set (bool value);
}


TotalQuestionCount Property

TotalQuestionCount Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► TotalQuestionCount
Declaration Syntax
C# Visual Basic Visual C++
public long TotalQuestionCount { get; set; }
Public Property TotalQuestionCount As Long
    Get
    Set
public:
property long long TotalQuestionCount {
    long long get ();
    void set (long long value);
}


TotalQuestionCountSpecified Property

TotalQuestionCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► TotalQuestionCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalQuestionCountSpecified { get; set; }
Public Property TotalQuestionCountSpecified As Boolean
    Get
    Set
public:
property bool TotalQuestionCountSpecified {
    bool get ();
    void set (bool value);
}


UnitInfo Property

UnitInfo Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► UnitInfo
Declaration Syntax
C# Visual Basic Visual C++
public UnitInfoType UnitInfo { get; set; }
Public Property UnitInfo As UnitInfoType
    Get
    Set
public:
property UnitInfoType^ UnitInfo {
    UnitInfoType^ get ();
    void set (UnitInfoType^ value);
}


UpdateReturnPolicy Property

UpdateReturnPolicy Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► UpdateReturnPolicy
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateReturnPolicy { get; set; }
Public Property UpdateReturnPolicy As Boolean
    Get
    Set
public:
property bool UpdateReturnPolicy {
    bool get ();
    void set (bool value);
}


UpdateReturnPolicySpecified Property

UpdateReturnPolicySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► UpdateReturnPolicySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateReturnPolicySpecified { get; set; }
Public Property UpdateReturnPolicySpecified As Boolean
    Get
    Set
public:
property bool UpdateReturnPolicySpecified {
    bool get ();
    void set (bool value);
}


UpdateSellerInfo Property

UpdateSellerInfo Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► UpdateSellerInfo
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateSellerInfo { get; set; }
Public Property UpdateSellerInfo As Boolean
    Get
    Set
public:
property bool UpdateSellerInfo {
    bool get ();
    void set (bool value);
}


UpdateSellerInfoSpecified Property

UpdateSellerInfoSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► UpdateSellerInfoSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateSellerInfoSpecified { get; set; }
Public Property UpdateSellerInfoSpecified As Boolean
    Get
    Set
public:
property bool UpdateSellerInfoSpecified {
    bool get ();
    void set (bool value);
}


UseRecommendedProduct Property

UseRecommendedProduct Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► UseRecommendedProduct
Declaration Syntax
C# Visual Basic Visual C++
public bool UseRecommendedProduct { get; set; }
Public Property UseRecommendedProduct As Boolean
    Get
    Set
public:
property bool UseRecommendedProduct {
    bool get ();
    void set (bool value);
}


UseTaxTable Property

UseTaxTable Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► UseTaxTable
Declaration Syntax
C# Visual Basic Visual C++
public bool UseTaxTable { get; set; }
Public Property UseTaxTable As Boolean
    Get
    Set
public:
property bool UseTaxTable {
    bool get ();
    void set (bool value);
}


UseTaxTableSpecified Property

UseTaxTableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► UseTaxTableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UseTaxTableSpecified { get; set; }
Public Property UseTaxTableSpecified As Boolean
    Get
    Set
public:
property bool UseTaxTableSpecified {
    bool get ();
    void set (bool value);
}


UUID Property

UUID Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► UUID
Declaration Syntax
C# Visual Basic Visual C++
public string UUID { get; set; }
Public Property UUID As String
    Get
    Set
public:
property String^ UUID {
    String^ get ();
    void set (String^ value);
}


Variations Property

Variations Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► Variations
Declaration Syntax
C# Visual Basic Visual C++
public VariationsType Variations { get; set; }
Public Property Variations As VariationsType
    Get
    Set
public:
property VariationsType^ Variations {
    VariationsType^ get ();
    void set (VariationsType^ value);
}


VATDetails Property

VATDetails Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► VATDetails
Declaration Syntax
C# Visual Basic Visual C++
public VATDetailsType VATDetails { get; set; }
Public Property VATDetails As VATDetailsType
    Get
    Set
public:
property VATDetailsType^ VATDetails {
    VATDetailsType^ get ();
    void set (VATDetailsType^ value);
}


VIN Property

VIN Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► VIN
Declaration Syntax
C# Visual Basic Visual C++
public string VIN { get; set; }
Public Property VIN As String
    Get
    Set
public:
property String^ VIN {
    String^ get ();
    void set (String^ value);
}


VINLink Property

VINLink Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► VINLink
Declaration Syntax
C# Visual Basic Visual C++
public string VINLink { get; set; }
Public Property VINLink As String
    Get
    Set
public:
property String^ VINLink {
    String^ get ();
    void set (String^ value);
}


VRM Property

VRM Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► VRM
Declaration Syntax
C# Visual Basic Visual C++
public string VRM { get; set; }
Public Property VRM As String
    Get
    Set
public:
property String^ VRM {
    String^ get ();
    void set (String^ value);
}


VRMLink Property

VRMLink Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► VRMLink
Declaration Syntax
C# Visual Basic Visual C++
public string VRMLink { get; set; }
Public Property VRMLink As String
    Get
    Set
public:
property String^ VRMLink {
    String^ get ();
    void set (String^ value);
}


WatchCount Property

WatchCount Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► WatchCount
Declaration Syntax
C# Visual Basic Visual C++
public long WatchCount { get; set; }
Public Property WatchCount As Long
    Get
    Set
public:
property long long WatchCount {
    long long get ();
    void set (long long value);
}


WatchCountSpecified Property

WatchCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ItemType ► WatchCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WatchCountSpecified { get; set; }
Public Property WatchCountSpecified As Boolean
    Get
    Set
public:
property bool WatchCountSpecified {
    bool get ();
    void set (bool value);
}


ItemTypeCodeType Enumeration

ItemTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ItemTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ItemTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ItemTypeCodeType
Members
Member | Description
AuctionItemsOnly |
FixedPricedItem |
AllItems |
StoreInventoryOnly |
FixedPriceExcludeStoreInventory |
ExcludeStoreInventory |
AllItemTypes |
AllFixedPriceItemTypes |
CustomCode |
ClassifiedItemsOnly |
AdFormat |
Remarks


ItemTypeCollection Class

ItemTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ItemTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ItemTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ItemTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ItemTypeCollection()()()() |
 | ItemTypeCollection(array<ItemType>[]()[][]) |
 | ItemTypeCollection(ItemTypeCollection) |
 | Add(ItemType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ItemType>[]()[][]) |
 | AddRange(ItemTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ItemType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ItemType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ItemType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ItemType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ItemTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► Add(ItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ItemType item
)
Public Function Add ( _
    item As ItemType _
) As Integer
public:
int Add(
    ItemType^ item
)
Parameters
item (ItemType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ItemType>[]()[][]) |
 | AddRange(ItemTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► AddRange(array<ItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemType[] items
)
Public Sub AddRange ( _
    items As ItemType() _
)
public:
void AddRange(
    array<ItemType^>^ items
)
Parameters
items (array< ItemType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► AddRange(ItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ItemTypeCollection items
)
Public Sub AddRange ( _
    items As ItemTypeCollection _
)
public:
void AddRange(
    ItemTypeCollection^ items
)
Parameters
items (ItemTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► Contains(ItemType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ItemType item
)
Public Function Contains ( _
    item As ItemType _
) As Boolean
public:
bool Contains(
    ItemType^ item
)
Parameters
item (ItemType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► CopyTo(array<ItemType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ItemType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ItemType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ItemType^>^ items,
    int index
)
Parameters
items (array< ItemType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► IndexOf(ItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ItemType item
)
Public Function IndexOf ( _
    item As ItemType _
) As Integer
public:
int IndexOf(
    ItemType^ item
)
Parameters
item (ItemType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► Insert(Int32, ItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ItemType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ItemType _
)
public:
void Insert(
    int index,
    ItemType^ item
)
Parameters
index (Int32)
item (ItemType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ItemType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ItemType
    Get
    Set
public:
property ItemType^ default[int index] {
    ItemType^ get (int index);
    void set (int index, ItemType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ItemType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ItemType
public:
ItemType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ItemTypeCollection Constructor

ItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► ItemTypeCollection()()()()
Members
Icon | Member | Description
 | ItemTypeCollection()()()() |
 | ItemTypeCollection(array<ItemType>[]()[][]) |
 | ItemTypeCollection(ItemTypeCollection) |


ItemTypeCollection Constructor

ItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► ItemTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection()
Public Sub New
public:
ItemTypeCollection()


ItemTypeCollection Constructor (items)

ItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► ItemTypeCollection(array<ItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection(
    ItemType[] items
)
Public Sub New ( _
    items As ItemType() _
)
public:
ItemTypeCollection(
    array<ItemType^>^ items
)
Parameters
items (array< ItemType >[]()[][])


ItemTypeCollection Constructor (items)

ItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► ItemTypeCollection(ItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection(
    ItemTypeCollection items
)
Public Sub New ( _
    items As ItemTypeCollection _
)
public:
ItemTypeCollection(
    ItemTypeCollection^ items
)
Parameters
items (ItemTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► Remove(ItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ItemType item
)
Public Sub Remove ( _
    item As ItemType _
)
public:
void Remove(
    ItemType^ item
)
Parameters
item (ItemType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ItemType[] ToArray()
Public Function ToArray As ItemType()
public:
array<ItemType^>^ ToArray()
Return Value


KTypeSupportedDefinitionType Class

KTypeSupportedDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► KTypeSupportedDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class KTypeSupportedDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class KTypeSupportedDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class KTypeSupportedDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KTypeSupportedDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
KTypeSupportedDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► KTypeSupportedDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


KTypeSupportedDefinitionType Constructor

KTypeSupportedDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► KTypeSupportedDefinitionType ► KTypeSupportedDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public KTypeSupportedDefinitionType()
Public Sub New
public:
KTypeSupportedDefinitionType()


LabelType Class

LabelType Class
Namespaces ► eBay.Service.Core.Soap ► LabelType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LabelType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LabelType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LabelType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LabelType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
 | visible |
 | visibleSpecified |
Remarks
Inheritance Hierarchy
Object
LabelType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LabelType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LabelType Constructor

LabelType Constructor
Namespaces ► eBay.Service.Core.Soap ► LabelType ► LabelType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LabelType()
Public Sub New
public:
LabelType()


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► LabelType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


visible Property

visible Property
Namespaces ► eBay.Service.Core.Soap ► LabelType ► visible
Declaration Syntax
C# Visual Basic Visual C++
public bool visible { get; set; }
Public Property visible As Boolean
    Get
    Set
public:
property bool visible {
    bool get ();
    void set (bool value);
}


visibleSpecified Property

visibleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► LabelType ► visibleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool visibleSpecified { get; set; }
Public Property visibleSpecified As Boolean
    Get
    Set
public:
property bool visibleSpecified {
    bool get ();
    void set (bool value);
}


LeaveFeedbackRequestType Class

LeaveFeedbackRequestType Class
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LeaveFeedbackRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LeaveFeedbackRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LeaveFeedbackRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LeaveFeedbackRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CommentText |
 | CommentType |
 | CommentTypeSpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemArrivedWithinEDDType |
 | ItemArrivedWithinEDDTypeSpecified |
 | ItemDeliveredWithinEDD |
 | ItemDeliveredWithinEDDSpecified |
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SellerItemRatingDetailArray |
 | TargetUser |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | LeaveFeedbackRequestType


CommentText Property

CommentText Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► CommentText
Declaration Syntax
C# Visual Basic Visual C++
public string CommentText { get; set; }
Public Property CommentText As String
    Get
    Set
public:
property String^ CommentText {
    String^ get ();
    void set (String^ value);
}


CommentType Property

CommentType Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► CommentType
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeType CommentType { get; set; }
Public Property CommentType As CommentTypeCodeType
    Get
    Set
public:
property CommentTypeCodeType CommentType {
    CommentTypeCodeType get ();
    void set (CommentTypeCodeType value);
}


CommentTypeSpecified Property

CommentTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► CommentTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CommentTypeSpecified { get; set; }
Public Property CommentTypeSpecified As Boolean
    Get
    Set
public:
property bool CommentTypeSpecified {
    bool get ();
    void set (bool value);
}


ItemArrivedWithinEDDType Property

ItemArrivedWithinEDDType Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► ItemArrivedWithinEDDType
Declaration Syntax
C# Visual Basic Visual C++
public ItemArrivedWithinEDDCodeType ItemArrivedWithinEDDType { get; set; }
Public Property ItemArrivedWithinEDDType As ItemArrivedWithinEDDCodeType
    Get
    Set
public:
property ItemArrivedWithinEDDCodeType ItemArrivedWithinEDDType {
    ItemArrivedWithinEDDCodeType get ();
    void set (ItemArrivedWithinEDDCodeType value);
}


ItemArrivedWithinEDDTypeSpecified Property

ItemArrivedWithinEDDTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► ItemArrivedWithinEDDTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemArrivedWithinEDDTypeSpecified { get; set; }
Public Property ItemArrivedWithinEDDTypeSpecified As Boolean
    Get
    Set
public:
property bool ItemArrivedWithinEDDTypeSpecified {
    bool get ();
    void set (bool value);
}


ItemDeliveredWithinEDD Property

ItemDeliveredWithinEDD Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► ItemDeliveredWithinEDD
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemDeliveredWithinEDD { get; set; }
Public Property ItemDeliveredWithinEDD As Boolean
    Get
    Set
public:
property bool ItemDeliveredWithinEDD {
    bool get ();
    void set (bool value);
}


ItemDeliveredWithinEDDSpecified Property

ItemDeliveredWithinEDDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► ItemDeliveredWithinEDDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemDeliveredWithinEDDSpecified { get; set; }
Public Property ItemDeliveredWithinEDDSpecified As Boolean
    Get
    Set
public:
property bool ItemDeliveredWithinEDDSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


LeaveFeedbackRequestType Constructor

LeaveFeedbackRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► LeaveFeedbackRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LeaveFeedbackRequestType()
Public Sub New
public:
LeaveFeedbackRequestType()


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


SellerItemRatingDetailArray Property

SellerItemRatingDetailArray Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► SellerItemRatingDetailArray
Declaration Syntax
C# Visual Basic Visual C++
public ItemRatingDetailsTypeCollection SellerItemRatingDetailArray { get; set; }
Public Property SellerItemRatingDetailArray As ItemRatingDetailsTypeCollection
    Get
    Set
public:
property ItemRatingDetailsTypeCollection^ SellerItemRatingDetailArray {
    ItemRatingDetailsTypeCollection^ get ();
    void set (ItemRatingDetailsTypeCollection^ value);
}


TargetUser Property

TargetUser Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► TargetUser
Declaration Syntax
C# Visual Basic Visual C++
public string TargetUser { get; set; }
Public Property TargetUser As String
    Get
    Set
public:
property String^ TargetUser {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


LeaveFeedbackResponseType Class

LeaveFeedbackResponseType Class
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LeaveFeedbackResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LeaveFeedbackResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LeaveFeedbackResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LeaveFeedbackResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | FeedbackID |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | LeaveFeedbackResponseType


FeedbackID Property

FeedbackID Property
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackResponseType ► FeedbackID
Declaration Syntax
C# Visual Basic Visual C++
public string FeedbackID { get; set; }
Public Property FeedbackID As String
    Get
    Set
public:
property String^ FeedbackID {
    String^ get ();
    void set (String^ value);
}


LeaveFeedbackResponseType Constructor

LeaveFeedbackResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► LeaveFeedbackResponseType ► LeaveFeedbackResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LeaveFeedbackResponseType()
Public Sub New
public:
LeaveFeedbackResponseType()


LineItemType Class

LineItemType Class
Namespaces ► eBay.Service.Core.Soap ► LineItemType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LineItemType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LineItemType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LineItemType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LineItemType()()()() |
 | Any |
 | CountryOfOrigin |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Quantity |
 | QuantitySpecified |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
Remarks
Inheritance Hierarchy
Object
LineItemType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LineItemType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CountryOfOrigin Property

CountryOfOrigin Property
Namespaces ► eBay.Service.Core.Soap ► LineItemType ► CountryOfOrigin
Declaration Syntax
C# Visual Basic Visual C++
public string CountryOfOrigin { get; set; }
Public Property CountryOfOrigin As String
    Get
    Set
public:
property String^ CountryOfOrigin {
    String^ get ();
    void set (String^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► LineItemType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► LineItemType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


LineItemType Constructor

LineItemType Constructor
Namespaces ► eBay.Service.Core.Soap ► LineItemType ► LineItemType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LineItemType()
Public Sub New
public:
LineItemType()


Quantity Property

Quantity Property
Namespaces ► eBay.Service.Core.Soap ► LineItemType ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public int Quantity { get; set; }
Public Property Quantity As Integer
    Get
    Set
public:
property int Quantity {
    int get ();
    void set (int value);
}


QuantitySpecified Property

QuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► LineItemType ► QuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySpecified { get; set; }
Public Property QuantitySpecified As Boolean
    Get
    Set
public:
property bool QuantitySpecified {
    bool get ();
    void set (bool value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► LineItemType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


LineItemTypeCollection Class

LineItemTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class LineItemTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class LineItemTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class LineItemTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LineItemTypeCollection()()()() |
 | LineItemTypeCollection(array<LineItemType>[]()[][]) |
 | LineItemTypeCollection(LineItemTypeCollection) |
 | Add(LineItemType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<LineItemType>[]()[][]) |
 | AddRange(LineItemTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(LineItemType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<LineItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(LineItemType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, LineItemType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(LineItemType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | LineItemTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► Add(LineItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    LineItemType item
)
Public Function Add ( _
    item As LineItemType _
) As Integer
public:
int Add(
    LineItemType^ item
)
Parameters
item (LineItemType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<LineItemType>[]()[][]) |
 | AddRange(LineItemTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► AddRange(array<LineItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    LineItemType[] items
)
Public Sub AddRange ( _
    items As LineItemType() _
)
public:
void AddRange(
    array<LineItemType^>^ items
)
Parameters
items (array< LineItemType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► AddRange(LineItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    LineItemTypeCollection items
)
Public Sub AddRange ( _
    items As LineItemTypeCollection _
)
public:
void AddRange(
    LineItemTypeCollection^ items
)
Parameters
items (LineItemTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► Contains(LineItemType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    LineItemType item
)
Public Function Contains ( _
    item As LineItemType _
) As Boolean
public:
bool Contains(
    LineItemType^ item
)
Parameters
item (LineItemType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► CopyTo(array<LineItemType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    LineItemType[] items,
    int index
)
Public Sub CopyTo ( _
    items As LineItemType(), _
    index As Integer _
)
public:
void CopyTo(
    array<LineItemType^>^ items,
    int index
)
Parameters
items (array< LineItemType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► IndexOf(LineItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    LineItemType item
)
Public Function IndexOf ( _
    item As LineItemType _
) As Integer
public:
int IndexOf(
    LineItemType^ item
)
Parameters
item (LineItemType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► Insert(Int32, LineItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    LineItemType item
)
Public Sub Insert ( _
    index As Integer, _
    item As LineItemType _
)
public:
void Insert(
    int index,
    LineItemType^ item
)
Parameters
index (Int32)
item (LineItemType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public LineItemType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As LineItemType
    Get
    Set
public:
property LineItemType^ default[int index] {
    LineItemType^ get (int index);
    void set (int index, LineItemType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public LineItemType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As LineItemType
public:
LineItemType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


LineItemTypeCollection Constructor

LineItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► LineItemTypeCollection()()()()
Members
Icon | Member | Description
 | LineItemTypeCollection()()()() |
 | LineItemTypeCollection(array<LineItemType>[]()[][]) |
 | LineItemTypeCollection(LineItemTypeCollection) |


LineItemTypeCollection Constructor

LineItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► LineItemTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LineItemTypeCollection()
Public Sub New
public:
LineItemTypeCollection()


LineItemTypeCollection Constructor (items)

LineItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► LineItemTypeCollection(array<LineItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public LineItemTypeCollection(
    LineItemType[] items
)
Public Sub New ( _
    items As LineItemType() _
)
public:
LineItemTypeCollection(
    array<LineItemType^>^ items
)
Parameters
items (array< LineItemType >[]()[][])


LineItemTypeCollection Constructor (items)

LineItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► LineItemTypeCollection(LineItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public LineItemTypeCollection(
    LineItemTypeCollection items
)
Public Sub New ( _
    items As LineItemTypeCollection _
)
public:
LineItemTypeCollection(
    LineItemTypeCollection^ items
)
Parameters
items (LineItemTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► Remove(LineItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    LineItemType item
)
Public Sub Remove ( _
    item As LineItemType _
)
public:
void Remove(
    LineItemType^ item
)
Parameters
item (LineItemType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LineItemType[] ToArray()
Public Function ToArray As LineItemType()
public:
array<LineItemType^>^ ToArray()
Return Value


ListingCheckoutRedirectPreferenceType Class

ListingCheckoutRedirectPreferenceType Class
Namespaces ► eBay.Service.Core.Soap ► ListingCheckoutRedirectPreferenceType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingCheckoutRedirectPreferenceType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingCheckoutRedirectPreferenceType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingCheckoutRedirectPreferenceType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingCheckoutRedirectPreferenceType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProStoresStoreName |
 | SellerThirdPartyUsername |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ListingCheckoutRedirectPreferenceType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ListingCheckoutRedirectPreferenceType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ListingCheckoutRedirectPreferenceType Constructor

ListingCheckoutRedirectPreferenceType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingCheckoutRedirectPreferenceType ► ListingCheckoutRedirectPreferenceType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingCheckoutRedirectPreferenceType()
Public Sub New
public:
ListingCheckoutRedirectPreferenceType()


ProStoresStoreName Property

ProStoresStoreName Property
Namespaces ► eBay.Service.Core.Soap ► ListingCheckoutRedirectPreferenceType ► ProStoresStoreName
Declaration Syntax
C# Visual Basic Visual C++
public string ProStoresStoreName { get; set; }
Public Property ProStoresStoreName As String
    Get
    Set
public:
property String^ ProStoresStoreName {
    String^ get ();
    void set (String^ value);
}


SellerThirdPartyUsername Property

SellerThirdPartyUsername Property
Namespaces ► eBay.Service.Core.Soap ► ListingCheckoutRedirectPreferenceType ► SellerThirdPartyUsername
Declaration Syntax
C# Visual Basic Visual C++
public string SellerThirdPartyUsername { get; set; }
Public Property SellerThirdPartyUsername As String
    Get
    Set
public:
property String^ SellerThirdPartyUsername {
    String^ get ();
    void set (String^ value);
}


ListingDesignerType Class

ListingDesignerType Class
Namespaces ► eBay.Service.Core.Soap ► ListingDesignerType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingDesignerType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingDesignerType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingDesignerType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingDesignerType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LayoutID |
 | LayoutIDSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OptimalPictureSize |
 | OptimalPictureSizeSpecified |
 | ThemeID |
 | ThemeIDSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ListingDesignerType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ListingDesignerType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LayoutID Property

LayoutID Property
Namespaces ► eBay.Service.Core.Soap ► ListingDesignerType ► LayoutID
Declaration Syntax
C# Visual Basic Visual C++
public int LayoutID { get; set; }
Public Property LayoutID As Integer
    Get
    Set
public:
property int LayoutID {
    int get ();
    void set (int value);
}


LayoutIDSpecified Property

LayoutIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDesignerType ► LayoutIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LayoutIDSpecified { get; set; }
Public Property LayoutIDSpecified As Boolean
    Get
    Set
public:
property bool LayoutIDSpecified {
    bool get ();
    void set (bool value);
}


ListingDesignerType Constructor

ListingDesignerType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingDesignerType ► ListingDesignerType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingDesignerType()
Public Sub New
public:
ListingDesignerType()


OptimalPictureSize Property

OptimalPictureSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingDesignerType ► OptimalPictureSize
Declaration Syntax
C# Visual Basic Visual C++
public bool OptimalPictureSize { get; set; }
Public Property OptimalPictureSize As Boolean
    Get
    Set
public:
property bool OptimalPictureSize {
    bool get ();
    void set (bool value);
}


OptimalPictureSizeSpecified Property

OptimalPictureSizeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDesignerType ► OptimalPictureSizeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OptimalPictureSizeSpecified { get; set; }
Public Property OptimalPictureSizeSpecified As Boolean
    Get
    Set
public:
property bool OptimalPictureSizeSpecified {
    bool get ();
    void set (bool value);
}


ThemeID Property

ThemeID Property
Namespaces ► eBay.Service.Core.Soap ► ListingDesignerType ► ThemeID
Declaration Syntax
C# Visual Basic Visual C++
public int ThemeID { get; set; }
Public Property ThemeID As Integer
    Get
    Set
public:
property int ThemeID {
    int get ();
    void set (int value);
}


ThemeIDSpecified Property

ThemeIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDesignerType ► ThemeIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ThemeIDSpecified { get; set; }
Public Property ThemeIDSpecified As Boolean
    Get
    Set
public:
property bool ThemeIDSpecified {
    bool get ();
    void set (bool value);
}


ListingDetailsType Class

ListingDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingDetailsType()()()() |
 | Adult |
 | AdultSpecified |
 | Any |
 | BestOfferAutoAcceptPrice |
 | BindingAuction |
 | BindingAuctionSpecified |
 | BuyItNowAvailable |
 | BuyItNowAvailableSpecified |
 | CheckoutEnabled |
 | CheckoutEnabledSpecified |
 | ConvertedBuyItNowPrice |
 | ConvertedReservePrice |
 | ConvertedStartPrice |
 | EndingReason |
 | EndingReasonSpecified |
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HasPublicMessages |
 | HasPublicMessagesSpecified |
 | HasReservePrice |
 | HasReservePriceSpecified |
 | HasUnansweredQuestions |
 | HasUnansweredQuestionsSpecified |
 | LocalListingDistance |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumBestOfferMessage |
 | MinimumBestOfferPrice |
 | PayPerLeadEnabled |
 | PayPerLeadEnabledSpecified |
 | RelistedItemID |
 | SecondChanceOriginalItemID |
 | SellerBusinessType |
 | SellerBusinessTypeSpecified |
 | StartTime |
 | StartTimeSpecified |
 | TCROriginalItemID |
 | ToString()()()() | (Inherited from Object.)
 | ViewItemURL |
 | ViewItemURLForNaturalSearch |
Remarks
Inheritance Hierarchy
Object
ListingDetailsType


Adult Property

Adult Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► Adult
Declaration Syntax
C# Visual Basic Visual C++
public bool Adult { get; set; }
Public Property Adult As Boolean
    Get
    Set
public:
property bool Adult {
    bool get ();
    void set (bool value);
}


AdultSpecified Property

AdultSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► AdultSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AdultSpecified { get; set; }
Public Property AdultSpecified As Boolean
    Get
    Set
public:
property bool AdultSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestOfferAutoAcceptPrice Property

BestOfferAutoAcceptPrice Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► BestOfferAutoAcceptPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType BestOfferAutoAcceptPrice { get; set; }
Public Property BestOfferAutoAcceptPrice As AmountType
    Get
    Set
public:
property AmountType^ BestOfferAutoAcceptPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


BindingAuction Property

BindingAuction Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► BindingAuction
Declaration Syntax
C# Visual Basic Visual C++
public bool BindingAuction { get; set; }
Public Property BindingAuction As Boolean
    Get
    Set
public:
property bool BindingAuction {
    bool get ();
    void set (bool value);
}


BindingAuctionSpecified Property

BindingAuctionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► BindingAuctionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BindingAuctionSpecified { get; set; }
Public Property BindingAuctionSpecified As Boolean
    Get
    Set
public:
property bool BindingAuctionSpecified {
    bool get ();
    void set (bool value);
}


BuyItNowAvailable Property

BuyItNowAvailable Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► BuyItNowAvailable
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyItNowAvailable { get; set; }
Public Property BuyItNowAvailable As Boolean
    Get
    Set
public:
property bool BuyItNowAvailable {
    bool get ();
    void set (bool value);
}


BuyItNowAvailableSpecified Property

BuyItNowAvailableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► BuyItNowAvailableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyItNowAvailableSpecified { get; set; }
Public Property BuyItNowAvailableSpecified As Boolean
    Get
    Set
public:
property bool BuyItNowAvailableSpecified {
    bool get ();
    void set (bool value);
}


CheckoutEnabled Property

CheckoutEnabled Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► CheckoutEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckoutEnabled { get; set; }
Public Property CheckoutEnabled As Boolean
    Get
    Set
public:
property bool CheckoutEnabled {
    bool get ();
    void set (bool value);
}


CheckoutEnabledSpecified Property

CheckoutEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► CheckoutEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckoutEnabledSpecified { get; set; }
Public Property CheckoutEnabledSpecified As Boolean
    Get
    Set
public:
property bool CheckoutEnabledSpecified {
    bool get ();
    void set (bool value);
}


ConvertedBuyItNowPrice Property

ConvertedBuyItNowPrice Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► ConvertedBuyItNowPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ConvertedBuyItNowPrice { get; set; }
Public Property ConvertedBuyItNowPrice As AmountType
    Get
    Set
public:
property AmountType^ ConvertedBuyItNowPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


ConvertedReservePrice Property

ConvertedReservePrice Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► ConvertedReservePrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ConvertedReservePrice { get; set; }
Public Property ConvertedReservePrice As AmountType
    Get
    Set
public:
property AmountType^ ConvertedReservePrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


ConvertedStartPrice Property

ConvertedStartPrice Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► ConvertedStartPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ConvertedStartPrice { get; set; }
Public Property ConvertedStartPrice As AmountType
    Get
    Set
public:
property AmountType^ ConvertedStartPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


EndingReason Property

EndingReason Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► EndingReason
Declaration Syntax
C# Visual Basic Visual C++
public EndReasonCodeType EndingReason { get; set; }
Public Property EndingReason As EndReasonCodeType
    Get
    Set
public:
property EndReasonCodeType EndingReason {
    EndReasonCodeType get ();
    void set (EndReasonCodeType value);
}


EndingReasonSpecified Property

EndingReasonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► EndingReasonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndingReasonSpecified { get; set; }
Public Property EndingReasonSpecified As Boolean
    Get
    Set
public:
property bool EndingReasonSpecified {
    bool get ();
    void set (bool value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


HasPublicMessages Property

HasPublicMessages Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► HasPublicMessages
Declaration Syntax
C# Visual Basic Visual C++
public bool HasPublicMessages { get; set; }
Public Property HasPublicMessages As Boolean
    Get
    Set
public:
property bool HasPublicMessages {
    bool get ();
    void set (bool value);
}


HasPublicMessagesSpecified Property

HasPublicMessagesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► HasPublicMessagesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HasPublicMessagesSpecified { get; set; }
Public Property HasPublicMessagesSpecified As Boolean
    Get
    Set
public:
property bool HasPublicMessagesSpecified {
    bool get ();
    void set (bool value);
}


HasReservePrice Property

HasReservePrice Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► HasReservePrice
Declaration Syntax
C# Visual Basic Visual C++
public bool HasReservePrice { get; set; }
Public Property HasReservePrice As Boolean
    Get
    Set
public:
property bool HasReservePrice {
    bool get ();
    void set (bool value);
}


HasReservePriceSpecified Property

HasReservePriceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► HasReservePriceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HasReservePriceSpecified { get; set; }
Public Property HasReservePriceSpecified As Boolean
    Get
    Set
public:
property bool HasReservePriceSpecified {
    bool get ();
    void set (bool value);
}


HasUnansweredQuestions Property

HasUnansweredQuestions Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► HasUnansweredQuestions
Declaration Syntax
C# Visual Basic Visual C++
public bool HasUnansweredQuestions { get; set; }
Public Property HasUnansweredQuestions As Boolean
    Get
    Set
public:
property bool HasUnansweredQuestions {
    bool get ();
    void set (bool value);
}


HasUnansweredQuestionsSpecified Property

HasUnansweredQuestionsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► HasUnansweredQuestionsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HasUnansweredQuestionsSpecified { get; set; }
Public Property HasUnansweredQuestionsSpecified As Boolean
    Get
    Set
public:
property bool HasUnansweredQuestionsSpecified {
    bool get ();
    void set (bool value);
}


ListingDetailsType Constructor

ListingDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► ListingDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingDetailsType()
Public Sub New
public:
ListingDetailsType()


LocalListingDistance Property

LocalListingDistance Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► LocalListingDistance
Declaration Syntax
C# Visual Basic Visual C++
public string LocalListingDistance { get; set; }
Public Property LocalListingDistance As String
    Get
    Set
public:
property String^ LocalListingDistance {
    String^ get ();
    void set (String^ value);
}


MinimumBestOfferMessage Property

MinimumBestOfferMessage Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► MinimumBestOfferMessage
Declaration Syntax
C# Visual Basic Visual C++
public string MinimumBestOfferMessage { get; set; }
Public Property MinimumBestOfferMessage As String
    Get
    Set
public:
property String^ MinimumBestOfferMessage {
    String^ get ();
    void set (String^ value);
}


MinimumBestOfferPrice Property

MinimumBestOfferPrice Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► MinimumBestOfferPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MinimumBestOfferPrice { get; set; }
Public Property MinimumBestOfferPrice As AmountType
    Get
    Set
public:
property AmountType^ MinimumBestOfferPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


PayPerLeadEnabled Property

PayPerLeadEnabled Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► PayPerLeadEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPerLeadEnabled { get; set; }
Public Property PayPerLeadEnabled As Boolean
    Get
    Set
public:
property bool PayPerLeadEnabled {
    bool get ();
    void set (bool value);
}


PayPerLeadEnabledSpecified Property

PayPerLeadEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► PayPerLeadEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPerLeadEnabledSpecified { get; set; }
Public Property PayPerLeadEnabledSpecified As Boolean
    Get
    Set
public:
property bool PayPerLeadEnabledSpecified {
    bool get ();
    void set (bool value);
}


RelistedItemID Property

RelistedItemID Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► RelistedItemID
Declaration Syntax
C# Visual Basic Visual C++
public string RelistedItemID { get; set; }
Public Property RelistedItemID As String
    Get
    Set
public:
property String^ RelistedItemID {
    String^ get ();
    void set (String^ value);
}


SecondChanceOriginalItemID Property

SecondChanceOriginalItemID Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► SecondChanceOriginalItemID
Declaration Syntax
C# Visual Basic Visual C++
public string SecondChanceOriginalItemID { get; set; }
Public Property SecondChanceOriginalItemID As String
    Get
    Set
public:
property String^ SecondChanceOriginalItemID {
    String^ get ();
    void set (String^ value);
}


SellerBusinessType Property

SellerBusinessType Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► SellerBusinessType
Declaration Syntax
C# Visual Basic Visual C++
public SellerBusinessCodeType SellerBusinessType { get; set; }
Public Property SellerBusinessType As SellerBusinessCodeType
    Get
    Set
public:
property SellerBusinessCodeType SellerBusinessType {
    SellerBusinessCodeType get ();
    void set (SellerBusinessCodeType value);
}


SellerBusinessTypeSpecified Property

SellerBusinessTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► SellerBusinessTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerBusinessTypeSpecified { get; set; }
Public Property SellerBusinessTypeSpecified As Boolean
    Get
    Set
public:
property bool SellerBusinessTypeSpecified {
    bool get ();
    void set (bool value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


TCROriginalItemID Property

TCROriginalItemID Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► TCROriginalItemID
Declaration Syntax
C# Visual Basic Visual C++
public string TCROriginalItemID { get; set; }
Public Property TCROriginalItemID As String
    Get
    Set
public:
property String^ TCROriginalItemID {
    String^ get ();
    void set (String^ value);
}


ViewItemURL Property

ViewItemURL Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► ViewItemURL
Declaration Syntax
C# Visual Basic Visual C++
public string ViewItemURL { get; set; }
Public Property ViewItemURL As String
    Get
    Set
public:
property String^ ViewItemURL {
    String^ get ();
    void set (String^ value);
}


ViewItemURLForNaturalSearch Property

ViewItemURLForNaturalSearch Property
Namespaces ► eBay.Service.Core.Soap ► ListingDetailsType ► ViewItemURLForNaturalSearch
Declaration Syntax
C# Visual Basic Visual C++
public string ViewItemURLForNaturalSearch { get; set; }
Public Property ViewItemURLForNaturalSearch As String
    Get
    Set
public:
property String^ ViewItemURLForNaturalSearch {
    String^ get ();
    void set (String^ value);
}


ListingDurationDefinitionsType Class

ListingDurationDefinitionsType Class
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingDurationDefinitionsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingDurationDefinitionsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingDurationDefinitionsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingDurationDefinitionsType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ListingDuration |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Version |
 | VersionSpecified |
Remarks
Inheritance Hierarchy
Object
ListingDurationDefinitionsType


ListingDuration Property

ListingDuration Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionsType ► ListingDuration
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationDefinitionTypeCollection ListingDuration { get; set; }
Public Property ListingDuration As ListingDurationDefinitionTypeCollection
    Get
    Set
public:
property ListingDurationDefinitionTypeCollection^ ListingDuration {
    ListingDurationDefinitionTypeCollection^ get ();
    void set (ListingDurationDefinitionTypeCollection^ value);
}


ListingDurationDefinitionsType Constructor

ListingDurationDefinitionsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionsType ► ListingDurationDefinitionsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationDefinitionsType()
Public Sub New
public:
ListingDurationDefinitionsType()


Version Property

Version Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionsType ► Version
Declaration Syntax
C# Visual Basic Visual C++
public int Version { get; set; }
Public Property Version As Integer
    Get
    Set
public:
property int Version {
    int get ();
    void set (int value);
}


VersionSpecified Property

VersionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionsType ► VersionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VersionSpecified { get; set; }
Public Property VersionSpecified As Boolean
    Get
    Set
public:
property bool VersionSpecified {
    bool get ();
    void set (bool value);
}


ListingDurationDefinitionType Class

ListingDurationDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingDurationDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingDurationDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingDurationDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingDurationDefinitionType()()()() |
 | Any |
 | Duration |
 | durationSetID |
 | durationSetIDSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ListingDurationDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Duration Property

Duration Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionType ► Duration
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection Duration { get; set; }
Public Property Duration As StringCollection
    Get
    Set
public:
property StringCollection^ Duration {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


durationSetID Property

durationSetID Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionType ► durationSetID
Declaration Syntax
C# Visual Basic Visual C++
public int durationSetID { get; set; }
Public Property durationSetID As Integer
    Get
    Set
public:
property int durationSetID {
    int get ();
    void set (int value);
}


durationSetIDSpecified Property

durationSetIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionType ► durationSetIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool durationSetIDSpecified { get; set; }
Public Property durationSetIDSpecified As Boolean
    Get
    Set
public:
property bool durationSetIDSpecified {
    bool get ();
    void set (bool value);
}


ListingDurationDefinitionType Constructor

ListingDurationDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionType ► ListingDurationDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationDefinitionType()
Public Sub New
public:
ListingDurationDefinitionType()


ListingDurationDefinitionTypeCollection Class

ListingDurationDefinitionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ListingDurationDefinitionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ListingDurationDefinitionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ListingDurationDefinitionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingDurationDefinitionTypeCollection()()()() |
 | ListingDurationDefinitionTypeCollection(array<ListingDurationDefinitionType>[]()[][]) |
 | ListingDurationDefinitionTypeCollection(ListingDurationDefinitionTypeCollection) |
 | Add(ListingDurationDefinitionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ListingDurationDefinitionType>[]()[][]) |
 | AddRange(ListingDurationDefinitionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ListingDurationDefinitionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ListingDurationDefinitionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ListingDurationDefinitionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ListingDurationDefinitionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ListingDurationDefinitionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ListingDurationDefinitionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► Add(ListingDurationDefinitionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ListingDurationDefinitionType item
)
Public Function Add ( _
    item As ListingDurationDefinitionType _
) As Integer
public:
int Add(
    ListingDurationDefinitionType^ item
)
Parameters
item (ListingDurationDefinitionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ListingDurationDefinitionType>[]()[][]) |
 | AddRange(ListingDurationDefinitionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► AddRange(array<ListingDurationDefinitionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingDurationDefinitionType[] items
)
Public Sub AddRange ( _
    items As ListingDurationDefinitionType() _
)
public:
void AddRange(
    array<ListingDurationDefinitionType^>^ items
)
Parameters
items (array< ListingDurationDefinitionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► AddRange(ListingDurationDefinitionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingDurationDefinitionTypeCollection items
)
Public Sub AddRange ( _
    items As ListingDurationDefinitionTypeCollection _
)
public:
void AddRange(
    ListingDurationDefinitionTypeCollection^ items
)
Parameters
items (ListingDurationDefinitionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► Contains(ListingDurationDefinitionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ListingDurationDefinitionType item
)
Public Function Contains ( _
    item As ListingDurationDefinitionType _
) As Boolean
public:
bool Contains(
    ListingDurationDefinitionType^ item
)
Parameters
item (ListingDurationDefinitionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► CopyTo(array<ListingDurationDefinitionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ListingDurationDefinitionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ListingDurationDefinitionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ListingDurationDefinitionType^>^ items,
    int index
)
Parameters
items (array< ListingDurationDefinitionType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► IndexOf(ListingDurationDefinitionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ListingDurationDefinitionType item
)
Public Function IndexOf ( _
    item As ListingDurationDefinitionType _
) As Integer
public:
int IndexOf(
    ListingDurationDefinitionType^ item
)
Parameters
item (ListingDurationDefinitionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► Insert(Int32, ListingDurationDefinitionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ListingDurationDefinitionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ListingDurationDefinitionType _
)
public:
void Insert(
    int index,
    ListingDurationDefinitionType^ item
)
Parameters
index (Int32)
item (ListingDurationDefinitionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationDefinitionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ListingDurationDefinitionType
    Get
    Set
public:
property ListingDurationDefinitionType^ default[int index] {
    ListingDurationDefinitionType^ get (int index);
    void set (int index, ListingDurationDefinitionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationDefinitionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ListingDurationDefinitionType
public:
ListingDurationDefinitionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ListingDurationDefinitionTypeCollection Constructor

ListingDurationDefinitionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► ListingDurationDefinitionTypeCollection()()()()
Members
Icon | Member | Description
 | ListingDurationDefinitionTypeCollection()()()() |
 | ListingDurationDefinitionTypeCollection(array<ListingDurationDefinitionType>[]()[][]) |
 | ListingDurationDefinitionTypeCollection(ListingDurationDefinitionTypeCollection) |


ListingDurationDefinitionTypeCollection Constructor

ListingDurationDefinitionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► ListingDurationDefinitionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationDefinitionTypeCollection()
Public Sub New
public:
ListingDurationDefinitionTypeCollection()


ListingDurationDefinitionTypeCollection Constructor (items)

ListingDurationDefinitionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► ListingDurationDefinitionTypeCollection(array<ListingDurationDefinitionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationDefinitionTypeCollection(
    ListingDurationDefinitionType[] items
)
Public Sub New ( _
    items As ListingDurationDefinitionType() _
)
public:
ListingDurationDefinitionTypeCollection(
    array<ListingDurationDefinitionType^>^ items
)
Parameters
items (array< ListingDurationDefinitionType >[]()[][])


ListingDurationDefinitionTypeCollection Constructor (items)

ListingDurationDefinitionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► ListingDurationDefinitionTypeCollection(ListingDurationDefinitionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationDefinitionTypeCollection(
    ListingDurationDefinitionTypeCollection items
)
Public Sub New ( _
    items As ListingDurationDefinitionTypeCollection _
)
public:
ListingDurationDefinitionTypeCollection(
    ListingDurationDefinitionTypeCollection^ items
)
Parameters
items (ListingDurationDefinitionTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► Remove(ListingDurationDefinitionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ListingDurationDefinitionType item
)
Public Sub Remove ( _
    item As ListingDurationDefinitionType _
)
public:
void Remove(
    ListingDurationDefinitionType^ item
)
Parameters
item (ListingDurationDefinitionType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationDefinitionType[] ToArray()
Public Function ToArray As ListingDurationDefinitionType()
public:
array<ListingDurationDefinitionType^>^ ToArray()
Return Value


ListingDurationReferenceType Class

ListingDurationReferenceType Class
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingDurationReferenceType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingDurationReferenceType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingDurationReferenceType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingDurationReferenceType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | type |
 | typeSpecified |
 | Value |
Remarks
Inheritance Hierarchy
Object
ListingDurationReferenceType


ListingDurationReferenceType Constructor

ListingDurationReferenceType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceType ► ListingDurationReferenceType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationReferenceType()
Public Sub New
public:
ListingDurationReferenceType()


type Property

type Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceType ► type
Declaration Syntax
C# Visual Basic Visual C++
public ListingTypeCodeType type { get; set; }
Public Property type As ListingTypeCodeType
    Get
    Set
public:
property ListingTypeCodeType type {
    ListingTypeCodeType get ();
    void set (ListingTypeCodeType value);
}


typeSpecified Property

typeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceType ► typeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool typeSpecified { get; set; }
Public Property typeSpecified As Boolean
    Get
    Set
public:
property bool typeSpecified {
    bool get ();
    void set (bool value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set
public:
property int Value {
    int get ();
    void set (int value);
}


ListingDurationReferenceTypeCollection Class

ListingDurationReferenceTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ListingDurationReferenceTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ListingDurationReferenceTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ListingDurationReferenceTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingDurationReferenceTypeCollection()()()() |
 | ListingDurationReferenceTypeCollection(array<ListingDurationReferenceType>[]()[][]) |
 | ListingDurationReferenceTypeCollection(ListingDurationReferenceTypeCollection) |
 | Add(ListingDurationReferenceType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ListingDurationReferenceType>[]()[][]) |
 | AddRange(ListingDurationReferenceTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ListingDurationReferenceType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ListingDurationReferenceType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ListingDurationReferenceType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ListingDurationReferenceType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ListingDurationReferenceType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ListingDurationReferenceTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► Add(ListingDurationReferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ListingDurationReferenceType item
)
Public Function Add ( _
    item As ListingDurationReferenceType _
) As Integer
public:
int Add(
    ListingDurationReferenceType^ item
)
Parameters
item (ListingDurationReferenceType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ListingDurationReferenceType>[]()[][]) |
 | AddRange(ListingDurationReferenceTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► AddRange(array<ListingDurationReferenceType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingDurationReferenceType[] items
)
Public Sub AddRange ( _
    items As ListingDurationReferenceType() _
)
public:
void AddRange(
    array<ListingDurationReferenceType^>^ items
)
Parameters
items (array< ListingDurationReferenceType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► AddRange(ListingDurationReferenceTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingDurationReferenceTypeCollection items
)
Public Sub AddRange ( _
    items As ListingDurationReferenceTypeCollection _
)
public:
void AddRange(
    ListingDurationReferenceTypeCollection^ items
)
Parameters
items (ListingDurationReferenceTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► Contains(ListingDurationReferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ListingDurationReferenceType item
)
Public Function Contains ( _
    item As ListingDurationReferenceType _
) As Boolean
public:
bool Contains(
    ListingDurationReferenceType^ item
)
Parameters
item (ListingDurationReferenceType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► CopyTo(array<ListingDurationReferenceType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ListingDurationReferenceType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ListingDurationReferenceType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ListingDurationReferenceType^>^ items,
    int index
)
Parameters
items (array< ListingDurationReferenceType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► IndexOf(ListingDurationReferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ListingDurationReferenceType item
)
Public Function IndexOf ( _
    item As ListingDurationReferenceType _
) As Integer
public:
int IndexOf(
    ListingDurationReferenceType^ item
)
Parameters
item (ListingDurationReferenceType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► Insert(Int32, ListingDurationReferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ListingDurationReferenceType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ListingDurationReferenceType _
)
public:
void Insert(
    int index,
    ListingDurationReferenceType^ item
)
Parameters
index (Int32)
item (ListingDurationReferenceType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationReferenceType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ListingDurationReferenceType
    Get
    Set
public:
property ListingDurationReferenceType^ default[int index] {
    ListingDurationReferenceType^ get (int index);
    void set (int index, ListingDurationReferenceType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationReferenceType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ListingDurationReferenceType
public:
ListingDurationReferenceType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ListingDurationReferenceTypeCollection Constructor

ListingDurationReferenceTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► ListingDurationReferenceTypeCollection()()()()
Members
Icon | Member | Description
 | ListingDurationReferenceTypeCollection()()()() |
 | ListingDurationReferenceTypeCollection(array<ListingDurationReferenceType>[]()[][]) |
 | ListingDurationReferenceTypeCollection(ListingDurationReferenceTypeCollection) |


ListingDurationReferenceTypeCollection Constructor

ListingDurationReferenceTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► ListingDurationReferenceTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationReferenceTypeCollection()
Public Sub New
public:
ListingDurationReferenceTypeCollection()


ListingDurationReferenceTypeCollection Constructor (items)

ListingDurationReferenceTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► ListingDurationReferenceTypeCollection(array<ListingDurationReferenceType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationReferenceTypeCollection(
    ListingDurationReferenceType[] items
)
Public Sub New ( _
    items As ListingDurationReferenceType() _
)
public:
ListingDurationReferenceTypeCollection(
    array<ListingDurationReferenceType^>^ items
)
Parameters
items (array< ListingDurationReferenceType >[]()[][])


ListingDurationReferenceTypeCollection Constructor (items)

ListingDurationReferenceTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► ListingDurationReferenceTypeCollection(ListingDurationReferenceTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationReferenceTypeCollection(
    ListingDurationReferenceTypeCollection items
)
Public Sub New ( _
    items As ListingDurationReferenceTypeCollection _
)
public:
ListingDurationReferenceTypeCollection(
    ListingDurationReferenceTypeCollection^ items
)
Parameters
items (ListingDurationReferenceTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► Remove(ListingDurationReferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ListingDurationReferenceType item
)
Public Sub Remove ( _
    item As ListingDurationReferenceType _
)
public:
void Remove(
    ListingDurationReferenceType^ item
)
Parameters
item (ListingDurationReferenceType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationReferenceType[] ToArray()
Public Function ToArray As ListingDurationReferenceType()
public:
array<ListingDurationReferenceType^>^ ToArray()
Return Value


ListingEnhancementDurationDefinitionType Class

ListingEnhancementDurationDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementDurationDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingEnhancementDurationDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingEnhancementDurationDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingEnhancementDurationDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingEnhancementDurationDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ListingEnhancementDurationDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementDurationDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ListingEnhancementDurationDefinitionType Constructor

ListingEnhancementDurationDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementDurationDefinitionType ► ListingEnhancementDurationDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementDurationDefinitionType()
Public Sub New
public:
ListingEnhancementDurationDefinitionType()


ListingEnhancementDurationReferenceType Class

ListingEnhancementDurationReferenceType Class
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementDurationReferenceType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingEnhancementDurationReferenceType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingEnhancementDurationReferenceType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingEnhancementDurationReferenceType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingEnhancementDurationReferenceType()()()() |
 | Any |
 | Duration |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ListingEnhancementDurationReferenceType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementDurationReferenceType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Duration Property

Duration Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementDurationReferenceType ► Duration
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection Duration { get; set; }
Public Property Duration As StringCollection
    Get
    Set
public:
property StringCollection^ Duration {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ListingEnhancementDurationReferenceType Constructor

ListingEnhancementDurationReferenceType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementDurationReferenceType ► ListingEnhancementDurationReferenceType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementDurationReferenceType()
Public Sub New
public:
ListingEnhancementDurationReferenceType()


ListingEnhancementsCodeType Enumeration

ListingEnhancementsCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ListingEnhancementsCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ListingEnhancementsCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ListingEnhancementsCodeType
Members
Member | Description
Border |
BoldTitle |
Featured |
Highlight |
HomePageFeatured |
ProPackBundle |
BasicUpgradePackBundle |
ValuePackBundle |
ProPackPlusBundle |
CustomCode |
Remarks


ListingEnhancementsCodeTypeCollection Class

ListingEnhancementsCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ListingEnhancementsCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ListingEnhancementsCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ListingEnhancementsCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingEnhancementsCodeTypeCollection()()()() |
 | ListingEnhancementsCodeTypeCollection(array<ListingEnhancementsCodeType>[]()[][]) |
 | ListingEnhancementsCodeTypeCollection(ListingEnhancementsCodeTypeCollection) |
 | Add(ListingEnhancementsCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ListingEnhancementsCodeType>[]()[][]) |
 | AddRange(ListingEnhancementsCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ListingEnhancementsCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ListingEnhancementsCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ListingEnhancementsCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ListingEnhancementsCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ListingEnhancementsCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ListingEnhancementsCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► Add(ListingEnhancementsCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ListingEnhancementsCodeType item
)
Public Function Add ( _
    item As ListingEnhancementsCodeType _
) As Integer
public:
int Add(
    ListingEnhancementsCodeType item
)
Parameters
item (ListingEnhancementsCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ListingEnhancementsCodeType>[]()[][]) |
 | AddRange(ListingEnhancementsCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► AddRange(array<ListingEnhancementsCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingEnhancementsCodeType[] items
)
Public Sub AddRange ( _
    items As ListingEnhancementsCodeType() _
)
public:
void AddRange(
    array<ListingEnhancementsCodeType>^ items
)
Parameters
items (array< ListingEnhancementsCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► AddRange(ListingEnhancementsCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingEnhancementsCodeTypeCollection items
)
Public Sub AddRange ( _
    items As ListingEnhancementsCodeTypeCollection _
)
public:
void AddRange(
    ListingEnhancementsCodeTypeCollection^ items
)
Parameters
items (ListingEnhancementsCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► Contains(ListingEnhancementsCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ListingEnhancementsCodeType item
)
Public Function Contains ( _
    item As ListingEnhancementsCodeType _
) As Boolean
public:
bool Contains(
    ListingEnhancementsCodeType item
)
Parameters
item (ListingEnhancementsCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► CopyTo(array<ListingEnhancementsCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ListingEnhancementsCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ListingEnhancementsCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ListingEnhancementsCodeType>^ items,
    int index
)
Parameters
items (array< ListingEnhancementsCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► IndexOf(ListingEnhancementsCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ListingEnhancementsCodeType item
)
Public Function IndexOf ( _
    item As ListingEnhancementsCodeType _
) As Integer
public:
int IndexOf(
    ListingEnhancementsCodeType item
)
Parameters
item (ListingEnhancementsCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► Insert(Int32, ListingEnhancementsCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ListingEnhancementsCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ListingEnhancementsCodeType _
)
public:
void Insert(
    int index,
    ListingEnhancementsCodeType item
)
Parameters
index (Int32)
item (ListingEnhancementsCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementsCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ListingEnhancementsCodeType
    Get
    Set
public:
property ListingEnhancementsCodeType default[int index] {
    ListingEnhancementsCodeType get (int index);
    void set (int index, ListingEnhancementsCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementsCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ListingEnhancementsCodeType
public:
ListingEnhancementsCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ListingEnhancementsCodeTypeCollection Constructor

ListingEnhancementsCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► ListingEnhancementsCodeTypeCollection()()()()
Members
Icon | Member | Description
 | ListingEnhancementsCodeTypeCollection()()()() |
 | ListingEnhancementsCodeTypeCollection(array<ListingEnhancementsCodeType>[]()[][]) |
 | ListingEnhancementsCodeTypeCollection(ListingEnhancementsCodeTypeCollection) |


ListingEnhancementsCodeTypeCollection Constructor

ListingEnhancementsCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► ListingEnhancementsCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementsCodeTypeCollection()
Public Sub New
public:
ListingEnhancementsCodeTypeCollection()


ListingEnhancementsCodeTypeCollection Constructor (items)

ListingEnhancementsCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► ListingEnhancementsCodeTypeCollection(array<ListingEnhancementsCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementsCodeTypeCollection(
    ListingEnhancementsCodeType[] items
)
Public Sub New ( _
    items As ListingEnhancementsCodeType() _
)
public:
ListingEnhancementsCodeTypeCollection(
    array<ListingEnhancementsCodeType>^ items
)
Parameters
items (array< ListingEnhancementsCodeType >[]()[][])


ListingEnhancementsCodeTypeCollection Constructor (items)

ListingEnhancementsCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► ListingEnhancementsCodeTypeCollection(ListingEnhancementsCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementsCodeTypeCollection(
    ListingEnhancementsCodeTypeCollection items
)
Public Sub New ( _
    items As ListingEnhancementsCodeTypeCollection _
)
public:
ListingEnhancementsCodeTypeCollection(
    ListingEnhancementsCodeTypeCollection^ items
)
Parameters
items (ListingEnhancementsCodeTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► Remove(ListingEnhancementsCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ListingEnhancementsCodeType item
)
Public Sub Remove ( _
    item As ListingEnhancementsCodeType _
)
public:
void Remove(
    ListingEnhancementsCodeType item
)
Parameters
item (ListingEnhancementsCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementsCodeType[] ToArray()
Public Function ToArray As ListingEnhancementsCodeType()
public:
array<ListingEnhancementsCodeType>^ ToArray()
Return Value


ListingFeatureDetailsType Class

ListingFeatureDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingFeatureDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingFeatureDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingFeatureDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingFeatureDetailsType()()()() |
 | Any |
 | BoldTitle |
 | BoldTitleSpecified |
 | Border |
 | BorderSpecified |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | FeaturedFirst |
 | FeaturedFirstSpecified |
 | FeaturedPlus |
 | FeaturedPlusSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GiftIcon |
 | GiftIconSpecified |
 | Highlight |
 | HighlightSpecified |
 | HomePageFeatured |
 | HomePageFeaturedSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProPack |
 | ProPackSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
ListingFeatureDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BoldTitle Property

BoldTitle Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► BoldTitle
Declaration Syntax
C# Visual Basic Visual C++
public BoldTitleCodeType BoldTitle { get; set; }
Public Property BoldTitle As BoldTitleCodeType
    Get
    Set
public:
property BoldTitleCodeType BoldTitle {
    BoldTitleCodeType get ();
    void set (BoldTitleCodeType value);
}


BoldTitleSpecified Property

BoldTitleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► BoldTitleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BoldTitleSpecified { get; set; }
Public Property BoldTitleSpecified As Boolean
    Get
    Set
public:
property bool BoldTitleSpecified {
    bool get ();
    void set (bool value);
}


Border Property

Border Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► Border
Declaration Syntax
C# Visual Basic Visual C++
public BorderCodeType Border { get; set; }
Public Property Border As BorderCodeType
    Get
    Set
public:
property BorderCodeType Border {
    BorderCodeType get ();
    void set (BorderCodeType value);
}


BorderSpecified Property

BorderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► BorderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BorderSpecified { get; set; }
Public Property BorderSpecified As Boolean
    Get
    Set
public:
property bool BorderSpecified {
    bool get ();
    void set (bool value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


FeaturedFirst Property

FeaturedFirst Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► FeaturedFirst
Declaration Syntax
C# Visual Basic Visual C++
public FeaturedFirstCodeType FeaturedFirst { get; set; }
Public Property FeaturedFirst As FeaturedFirstCodeType
    Get
    Set
public:
property FeaturedFirstCodeType FeaturedFirst {
    FeaturedFirstCodeType get ();
    void set (FeaturedFirstCodeType value);
}


FeaturedFirstSpecified Property

FeaturedFirstSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► FeaturedFirstSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeaturedFirstSpecified { get; set; }
Public Property FeaturedFirstSpecified As Boolean
    Get
    Set
public:
property bool FeaturedFirstSpecified {
    bool get ();
    void set (bool value);
}


FeaturedPlus Property

FeaturedPlus Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► FeaturedPlus
Declaration Syntax
C# Visual Basic Visual C++
public FeaturedPlusCodeType FeaturedPlus { get; set; }
Public Property FeaturedPlus As FeaturedPlusCodeType
    Get
    Set
public:
property FeaturedPlusCodeType FeaturedPlus {
    FeaturedPlusCodeType get ();
    void set (FeaturedPlusCodeType value);
}


FeaturedPlusSpecified Property

FeaturedPlusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► FeaturedPlusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeaturedPlusSpecified { get; set; }
Public Property FeaturedPlusSpecified As Boolean
    Get
    Set
public:
property bool FeaturedPlusSpecified {
    bool get ();
    void set (bool value);
}


GiftIcon Property

GiftIcon Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► GiftIcon
Declaration Syntax
C# Visual Basic Visual C++
public GiftIconCodeType GiftIcon { get; set; }
Public Property GiftIcon As GiftIconCodeType
    Get
    Set
public:
property GiftIconCodeType GiftIcon {
    GiftIconCodeType get ();
    void set (GiftIconCodeType value);
}


GiftIconSpecified Property

GiftIconSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► GiftIconSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GiftIconSpecified { get; set; }
Public Property GiftIconSpecified As Boolean
    Get
    Set
public:
property bool GiftIconSpecified {
    bool get ();
    void set (bool value);
}


Highlight Property

Highlight Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► Highlight
Declaration Syntax
C# Visual Basic Visual C++
public HighlightCodeType Highlight { get; set; }
Public Property Highlight As HighlightCodeType
    Get
    Set
public:
property HighlightCodeType Highlight {
    HighlightCodeType get ();
    void set (HighlightCodeType value);
}


HighlightSpecified Property

HighlightSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► HighlightSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HighlightSpecified { get; set; }
Public Property HighlightSpecified As Boolean
    Get
    Set
public:
property bool HighlightSpecified {
    bool get ();
    void set (bool value);
}


HomePageFeatured Property

HomePageFeatured Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► HomePageFeatured
Declaration Syntax
C# Visual Basic Visual C++
public HomePageFeaturedCodeType HomePageFeatured { get; set; }
Public Property HomePageFeatured As HomePageFeaturedCodeType
    Get
    Set
public:
property HomePageFeaturedCodeType HomePageFeatured {
    HomePageFeaturedCodeType get ();
    void set (HomePageFeaturedCodeType value);
}


HomePageFeaturedSpecified Property

HomePageFeaturedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► HomePageFeaturedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HomePageFeaturedSpecified { get; set; }
Public Property HomePageFeaturedSpecified As Boolean
    Get
    Set
public:
property bool HomePageFeaturedSpecified {
    bool get ();
    void set (bool value);
}


ListingFeatureDetailsType Constructor

ListingFeatureDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► ListingFeatureDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingFeatureDetailsType()
Public Sub New
public:
ListingFeatureDetailsType()


ProPack Property

ProPack Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► ProPack
Declaration Syntax
C# Visual Basic Visual C++
public ProPackCodeType ProPack { get; set; }
Public Property ProPack As ProPackCodeType
    Get
    Set
public:
property ProPackCodeType ProPack {
    ProPackCodeType get ();
    void set (ProPackCodeType value);
}


ProPackSpecified Property

ProPackSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► ProPackSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProPackSpecified { get; set; }
Public Property ProPackSpecified As Boolean
    Get
    Set
public:
property bool ProPackSpecified {
    bool get ();
    void set (bool value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


ListingFeatureDetailsTypeCollection Class

ListingFeatureDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ListingFeatureDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ListingFeatureDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ListingFeatureDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingFeatureDetailsTypeCollection()()()() |
 | ListingFeatureDetailsTypeCollection(array<ListingFeatureDetailsType>[]()[][]) |
 | ListingFeatureDetailsTypeCollection(ListingFeatureDetailsTypeCollection) |
 | Add(ListingFeatureDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ListingFeatureDetailsType>[]()[][]) |
 | AddRange(ListingFeatureDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ListingFeatureDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ListingFeatureDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ListingFeatureDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ListingFeatureDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ListingFeatureDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ListingFeatureDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► Add(ListingFeatureDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ListingFeatureDetailsType item
)
Public Function Add ( _
    item As ListingFeatureDetailsType _
) As Integer
public:
int Add(
    ListingFeatureDetailsType^ item
)
Parameters
item (ListingFeatureDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ListingFeatureDetailsType>[]()[][]) |
 | AddRange(ListingFeatureDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► AddRange(array<ListingFeatureDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingFeatureDetailsType[] items
)
Public Sub AddRange ( _
    items As ListingFeatureDetailsType() _
)
public:
void AddRange(
    array<ListingFeatureDetailsType^>^ items
)
Parameters
items (array< ListingFeatureDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► AddRange(ListingFeatureDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingFeatureDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ListingFeatureDetailsTypeCollection _
)
public:
void AddRange(
    ListingFeatureDetailsTypeCollection^ items
)
Parameters
items (ListingFeatureDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► Contains(ListingFeatureDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ListingFeatureDetailsType item
)
Public Function Contains ( _
    item As ListingFeatureDetailsType _
) As Boolean
public:
bool Contains(
    ListingFeatureDetailsType^ item
)
Parameters
item (ListingFeatureDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► CopyTo(array<ListingFeatureDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ListingFeatureDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ListingFeatureDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ListingFeatureDetailsType^>^ items,
    int index
)
Parameters
items (array< ListingFeatureDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► IndexOf(ListingFeatureDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ListingFeatureDetailsType item
)
Public Function IndexOf ( _
    item As ListingFeatureDetailsType _
) As Integer
public:
int IndexOf(
    ListingFeatureDetailsType^ item
)
Parameters
item (ListingFeatureDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► Insert(Int32, ListingFeatureDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ListingFeatureDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ListingFeatureDetailsType _
)
public:
void Insert(
    int index,
    ListingFeatureDetailsType^ item
)
Parameters
index (Int32)
item (ListingFeatureDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ListingFeatureDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ListingFeatureDetailsType
    Get
    Set
public:
property ListingFeatureDetailsType^ default[int index] {
    ListingFeatureDetailsType^ get (int index);
    void set (int index, ListingFeatureDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ListingFeatureDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ListingFeatureDetailsType
public:
ListingFeatureDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ListingFeatureDetailsTypeCollection Constructor

ListingFeatureDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► ListingFeatureDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ListingFeatureDetailsTypeCollection()()()() |
 | ListingFeatureDetailsTypeCollection(array<ListingFeatureDetailsType>[]()[][]) |
 | ListingFeatureDetailsTypeCollection(ListingFeatureDetailsTypeCollection) |


ListingFeatureDetailsTypeCollection Constructor

ListingFeatureDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► ListingFeatureDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingFeatureDetailsTypeCollection()
Public Sub New
public:
ListingFeatureDetailsTypeCollection()


ListingFeatureDetailsTypeCollection Constructor (items)

ListingFeatureDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► ListingFeatureDetailsTypeCollection(array<ListingFeatureDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ListingFeatureDetailsTypeCollection(
    ListingFeatureDetailsType[] items
)
Public Sub New ( _
    items As ListingFeatureDetailsType() _
)
public:
ListingFeatureDetailsTypeCollection(
    array<ListingFeatureDetailsType^>^ items
)
Parameters
items (array< ListingFeatureDetailsType >[]()[][])


ListingFeatureDetailsTypeCollection Constructor (items)

ListingFeatureDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► ListingFeatureDetailsTypeCollection(ListingFeatureDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ListingFeatureDetailsTypeCollection(
    ListingFeatureDetailsTypeCollection items
)
Public Sub New ( _
    items As ListingFeatureDetailsTypeCollection _
)
public:
ListingFeatureDetailsTypeCollection(
    ListingFeatureDetailsTypeCollection^ items
)
Parameters
items (ListingFeatureDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► Remove(ListingFeatureDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ListingFeatureDetailsType item
)
Public Sub Remove ( _
    item As ListingFeatureDetailsType _
)
public:
void Remove(
    ListingFeatureDetailsType^ item
)
Parameters
item (ListingFeatureDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingFeatureDetailsType[] ToArray()
Public Function ToArray As ListingFeatureDetailsType()
public:
array<ListingFeatureDetailsType^>^ ToArray()
Return Value


ListingRecommendationsType Class

ListingRecommendationsType Class
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingRecommendationsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingRecommendationsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingRecommendationsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingRecommendationsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Recommendation |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ListingRecommendationsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ListingRecommendationsType Constructor

ListingRecommendationsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationsType ► ListingRecommendationsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType()
Public Sub New
public:
ListingRecommendationsType()


Recommendation Property

Recommendation Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationsType ► Recommendation
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationTypeCollection Recommendation { get; set; }
Public Property Recommendation As ListingRecommendationTypeCollection
    Get
    Set
public:
property ListingRecommendationTypeCollection^ Recommendation {
    ListingRecommendationTypeCollection^ get ();
    void set (ListingRecommendationTypeCollection^ value);
}


ListingRecommendationType Class

ListingRecommendationType Class
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingRecommendationType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingRecommendationType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingRecommendationType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingRecommendationType()()()() |
 | Any |
 | Code |
 | Equals(Object) | (Inherited from Object.)
 | FieldName |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Group |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message |
 | Metadata |
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | Value |
Remarks
Inheritance Hierarchy
Object
ListingRecommendationType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Code Property

Code Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationType ► Code
Declaration Syntax
C# Visual Basic Visual C++
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}


FieldName Property

FieldName Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationType ► FieldName
Declaration Syntax
C# Visual Basic Visual C++
public string FieldName { get; set; }
Public Property FieldName As String
    Get
    Set
public:
property String^ FieldName {
    String^ get ();
    void set (String^ value);
}


Group Property

Group Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationType ► Group
Declaration Syntax
C# Visual Basic Visual C++
public string Group { get; set; }
Public Property Group As String
    Get
    Set
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}


ListingRecommendationType Constructor

ListingRecommendationType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationType ► ListingRecommendationType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationType()
Public Sub New
public:
ListingRecommendationType()


Message Property

Message Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationType ► Message
Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


Metadata Property

Metadata Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationType ► Metadata
Declaration Syntax
C# Visual Basic Visual C++
public MetadataTypeCollection Metadata { get; set; }
Public Property Metadata As MetadataTypeCollection
    Get
    Set
public:
property MetadataTypeCollection^ Metadata {
    MetadataTypeCollection^ get ();
    void set (MetadataTypeCollection^ value);
}


Type Property

Type Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationType ► Type
Declaration Syntax
C# Visual Basic Visual C++
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection Value { get; set; }
Public Property Value As StringCollection
    Get
    Set
public:
property StringCollection^ Value {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ListingRecommendationTypeCollection Class

ListingRecommendationTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ListingRecommendationTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ListingRecommendationTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ListingRecommendationTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingRecommendationTypeCollection()()()() |
 | ListingRecommendationTypeCollection(array<ListingRecommendationType>[]()[][]) |
 | ListingRecommendationTypeCollection(ListingRecommendationTypeCollection) |
 | Add(ListingRecommendationType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ListingRecommendationType>[]()[][]) |
 | AddRange(ListingRecommendationTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ListingRecommendationType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ListingRecommendationType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ListingRecommendationType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ListingRecommendationType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ListingRecommendationType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ListingRecommendationTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► Add(ListingRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ListingRecommendationType item
)
Public Function Add ( _
    item As ListingRecommendationType _
) As Integer
public:
int Add(
    ListingRecommendationType^ item
)
Parameters
item (ListingRecommendationType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ListingRecommendationType>[]()[][]) |
 | AddRange(ListingRecommendationTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► AddRange(array<ListingRecommendationType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingRecommendationType[] items
)
Public Sub AddRange ( _
    items As ListingRecommendationType() _
)
public:
void AddRange(
    array<ListingRecommendationType^>^ items
)
Parameters
items (array< ListingRecommendationType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► AddRange(ListingRecommendationTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingRecommendationTypeCollection items
)
Public Sub AddRange ( _
    items As ListingRecommendationTypeCollection _
)
public:
void AddRange(
    ListingRecommendationTypeCollection^ items
)
Parameters
items (ListingRecommendationTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► Contains(ListingRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ListingRecommendationType item
)
Public Function Contains ( _
    item As ListingRecommendationType _
) As Boolean
public:
bool Contains(
    ListingRecommendationType^ item
)
Parameters
item (ListingRecommendationType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► CopyTo(array<ListingRecommendationType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ListingRecommendationType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ListingRecommendationType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ListingRecommendationType^>^ items,
    int index
)
Parameters
items (array< ListingRecommendationType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► IndexOf(ListingRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ListingRecommendationType item
)
Public Function IndexOf ( _
    item As ListingRecommendationType _
) As Integer
public:
int IndexOf(
    ListingRecommendationType^ item
)
Parameters
item (ListingRecommendationType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► Insert(Int32, ListingRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ListingRecommendationType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ListingRecommendationType _
)
public:
void Insert(
    int index,
    ListingRecommendationType^ item
)
Parameters
index (Int32)
item (ListingRecommendationType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ListingRecommendationType
    Get
    Set
public:
property ListingRecommendationType^ default[int index] {
    ListingRecommendationType^ get (int index);
    void set (int index, ListingRecommendationType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ListingRecommendationType
public:
ListingRecommendationType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ListingRecommendationTypeCollection Constructor

ListingRecommendationTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► ListingRecommendationTypeCollection()()()()
Members
Icon | Member | Description
 | ListingRecommendationTypeCollection()()()() |
 | ListingRecommendationTypeCollection(array<ListingRecommendationType>[]()[][]) |
 | ListingRecommendationTypeCollection(ListingRecommendationTypeCollection) |


ListingRecommendationTypeCollection Constructor

ListingRecommendationTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► ListingRecommendationTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationTypeCollection()
Public Sub New
public:
ListingRecommendationTypeCollection()


ListingRecommendationTypeCollection Constructor (items)

ListingRecommendationTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► ListingRecommendationTypeCollection(array<ListingRecommendationType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationTypeCollection(
    ListingRecommendationType[] items
)
Public Sub New ( _
    items As ListingRecommendationType() _
)
public:
ListingRecommendationTypeCollection(
    array<ListingRecommendationType^>^ items
)
Parameters
items (array< ListingRecommendationType >[]()[][])


ListingRecommendationTypeCollection Constructor (items)

ListingRecommendationTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► ListingRecommendationTypeCollection(ListingRecommendationTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationTypeCollection(
    ListingRecommendationTypeCollection items
)
Public Sub New ( _
    items As ListingRecommendationTypeCollection _
)
public:
ListingRecommendationTypeCollection(
    ListingRecommendationTypeCollection^ items
)
Parameters
items (ListingRecommendationTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► Remove(ListingRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ListingRecommendationType item
)
Public Sub Remove ( _
    item As ListingRecommendationType _
)
public:
void Remove(
    ListingRecommendationType^ item
)
Parameters
item (ListingRecommendationType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationType[] ToArray()
Public Function ToArray As ListingRecommendationType()
public:
array<ListingRecommendationType^>^ ToArray()
Return Value


ListingStartPriceDetailsType Class

ListingStartPriceDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ListingStartPriceDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ListingStartPriceDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ListingStartPriceDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingStartPriceDetailsType()()()() |
 | Any |
 | Description |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ListingType |
 | ListingTypeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinBuyItNowPricePercent |
 | MinBuyItNowPricePercentSpecified |
 | StartPrice |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
ListingStartPriceDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


ListingStartPriceDetailsType Constructor

ListingStartPriceDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType ► ListingStartPriceDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingStartPriceDetailsType()
Public Sub New
public:
ListingStartPriceDetailsType()


ListingType Property

ListingType Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType ► ListingType
Declaration Syntax
C# Visual Basic Visual C++
public ListingTypeCodeType ListingType { get; set; }
Public Property ListingType As ListingTypeCodeType
    Get
    Set
public:
property ListingTypeCodeType ListingType {
    ListingTypeCodeType get ();
    void set (ListingTypeCodeType value);
}


ListingTypeSpecified Property

ListingTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType ► ListingTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingTypeSpecified { get; set; }
Public Property ListingTypeSpecified As Boolean
    Get
    Set
public:
property bool ListingTypeSpecified {
    bool get ();
    void set (bool value);
}


MinBuyItNowPricePercent Property

MinBuyItNowPricePercent Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType ► MinBuyItNowPricePercent
Declaration Syntax
C# Visual Basic Visual C++
public float MinBuyItNowPricePercent { get; set; }
Public Property MinBuyItNowPricePercent As Single
    Get
    Set
public:
property float MinBuyItNowPricePercent {
    float get ();
    void set (float value);
}


MinBuyItNowPricePercentSpecified Property

MinBuyItNowPricePercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType ► MinBuyItNowPricePercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinBuyItNowPricePercentSpecified { get; set; }
Public Property MinBuyItNowPricePercentSpecified As Boolean
    Get
    Set
public:
property bool MinBuyItNowPricePercentSpecified {
    bool get ();
    void set (bool value);
}


StartPrice Property

StartPrice Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType ► StartPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType StartPrice { get; set; }
Public Property StartPrice As AmountType
    Get
    Set
public:
property AmountType^ StartPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


ListingStartPriceDetailsTypeCollection Class

ListingStartPriceDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ListingStartPriceDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ListingStartPriceDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ListingStartPriceDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ListingStartPriceDetailsTypeCollection()()()() |
 | ListingStartPriceDetailsTypeCollection(array<ListingStartPriceDetailsType>[]()[][]) |
 | ListingStartPriceDetailsTypeCollection(ListingStartPriceDetailsTypeCollection) |
 | Add(ListingStartPriceDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ListingStartPriceDetailsType>[]()[][]) |
 | AddRange(ListingStartPriceDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ListingStartPriceDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ListingStartPriceDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ListingStartPriceDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ListingStartPriceDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ListingStartPriceDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ListingStartPriceDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► Add(ListingStartPriceDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ListingStartPriceDetailsType item
)
Public Function Add ( _
    item As ListingStartPriceDetailsType _
) As Integer
public:
int Add(
    ListingStartPriceDetailsType^ item
)
Parameters
item (ListingStartPriceDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ListingStartPriceDetailsType>[]()[][]) |
 | AddRange(ListingStartPriceDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► AddRange(array<ListingStartPriceDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingStartPriceDetailsType[] items
)
Public Sub AddRange ( _
    items As ListingStartPriceDetailsType() _
)
public:
void AddRange(
    array<ListingStartPriceDetailsType^>^ items
)
Parameters
items (array< ListingStartPriceDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► AddRange(ListingStartPriceDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ListingStartPriceDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ListingStartPriceDetailsTypeCollection _
)
public:
void AddRange(
    ListingStartPriceDetailsTypeCollection^ items
)
Parameters
items (ListingStartPriceDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► Contains(ListingStartPriceDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ListingStartPriceDetailsType item
)
Public Function Contains ( _
    item As ListingStartPriceDetailsType _
) As Boolean
public:
bool Contains(
    ListingStartPriceDetailsType^ item
)
Parameters
item (ListingStartPriceDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► CopyTo(array<ListingStartPriceDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ListingStartPriceDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ListingStartPriceDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ListingStartPriceDetailsType^>^ items,
    int index
)
Parameters
items (array< ListingStartPriceDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► IndexOf(ListingStartPriceDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ListingStartPriceDetailsType item
)
Public Function IndexOf ( _
    item As ListingStartPriceDetailsType _
) As Integer
public:
int IndexOf(
    ListingStartPriceDetailsType^ item
)
Parameters
item (ListingStartPriceDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► Insert(Int32, ListingStartPriceDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ListingStartPriceDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ListingStartPriceDetailsType _
)
public:
void Insert(
    int index,
    ListingStartPriceDetailsType^ item
)
Parameters
index (Int32)
item (ListingStartPriceDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ListingStartPriceDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ListingStartPriceDetailsType
    Get
    Set
public:
property ListingStartPriceDetailsType^ default[int index] {
    ListingStartPriceDetailsType^ get (int index);
    void set (int index, ListingStartPriceDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ListingStartPriceDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ListingStartPriceDetailsType
public:
ListingStartPriceDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ListingStartPriceDetailsTypeCollection Constructor

ListingStartPriceDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► ListingStartPriceDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ListingStartPriceDetailsTypeCollection()()()() |
 | ListingStartPriceDetailsTypeCollection(array<ListingStartPriceDetailsType>[]()[][]) |
 | ListingStartPriceDetailsTypeCollection(ListingStartPriceDetailsTypeCollection) |


ListingStartPriceDetailsTypeCollection Constructor

ListingStartPriceDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► ListingStartPriceDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingStartPriceDetailsTypeCollection()
Public Sub New
public:
ListingStartPriceDetailsTypeCollection()


ListingStartPriceDetailsTypeCollection Constructor (items)

ListingStartPriceDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► ListingStartPriceDetailsTypeCollection(array<ListingStartPriceDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ListingStartPriceDetailsTypeCollection(
    ListingStartPriceDetailsType[] items
)
Public Sub New ( _
    items As ListingStartPriceDetailsType() _
)
public:
ListingStartPriceDetailsTypeCollection(
    array<ListingStartPriceDetailsType^>^ items
)
Parameters
items (array< ListingStartPriceDetailsType >[]()[][])


ListingStartPriceDetailsTypeCollection Constructor (items)

ListingStartPriceDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► ListingStartPriceDetailsTypeCollection(ListingStartPriceDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ListingStartPriceDetailsTypeCollection(
    ListingStartPriceDetailsTypeCollection items
)
Public Sub New ( _
    items As ListingStartPriceDetailsTypeCollection _
)
public:
ListingStartPriceDetailsTypeCollection(
    ListingStartPriceDetailsTypeCollection^ items
)
Parameters
items (ListingStartPriceDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► Remove(ListingStartPriceDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ListingStartPriceDetailsType item
)
Public Sub Remove ( _
    item As ListingStartPriceDetailsType _
)
public:
void Remove(
    ListingStartPriceDetailsType^ item
)
Parameters
item (ListingStartPriceDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ListingStartPriceDetailsType[] ToArray()
Public Function ToArray As ListingStartPriceDetailsType()
public:
array<ListingStartPriceDetailsType^>^ ToArray()
Return Value


ListingStatusCodeType Enumeration

ListingStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ListingStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ListingStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ListingStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ListingStatusCodeType
Members
Member | Description
Active |
Ended |
Completed |
CustomCode |
Custom |
Remarks


ListingSubtypeCodeType Enumeration

ListingSubtypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ListingSubtypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ListingSubtypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ListingSubtypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ListingSubtypeCodeType
Members
Member | Description
ClassifiedAd |
LocalMarketBestOfferOnly |
CustomCode |
Remarks


ListingTypeCodeType Enumeration

ListingTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ListingTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ListingTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ListingTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ListingTypeCodeType
Members
Member | Description
Unknown |
Chinese |
Dutch |
Live |
Auction |
AdType |
StoresFixedPrice |
PersonalOffer |
FixedPriceItem |
Half |
LeadGeneration |
Express |
Shopping |
CustomCode |
Remarks


LocalListingDistancesNonSubscriptionDefinitionType Class

LocalListingDistancesNonSubscriptionDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalListingDistancesNonSubscriptionDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalListingDistancesNonSubscriptionDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalListingDistancesNonSubscriptionDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalListingDistancesNonSubscriptionDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalListingDistancesNonSubscriptionDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalListingDistancesNonSubscriptionDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalListingDistancesNonSubscriptionDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalListingDistancesNonSubscriptionDefinitionType Constructor

LocalListingDistancesNonSubscriptionDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalListingDistancesNonSubscriptionDefinitionType ► LocalListingDistancesNonSubscriptionDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalListingDistancesNonSubscriptionDefinitionType()
Public Sub New
public:
LocalListingDistancesNonSubscriptionDefinitionType()


LocalListingDistancesRegularDefinitionType Class

LocalListingDistancesRegularDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalListingDistancesRegularDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalListingDistancesRegularDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalListingDistancesRegularDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalListingDistancesRegularDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalListingDistancesRegularDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalListingDistancesRegularDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalListingDistancesRegularDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalListingDistancesRegularDefinitionType Constructor

LocalListingDistancesRegularDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalListingDistancesRegularDefinitionType ► LocalListingDistancesRegularDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalListingDistancesRegularDefinitionType()
Public Sub New
public:
LocalListingDistancesRegularDefinitionType()


LocalListingDistancesSpecialtyDefinitionType Class

LocalListingDistancesSpecialtyDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalListingDistancesSpecialtyDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalListingDistancesSpecialtyDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalListingDistancesSpecialtyDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalListingDistancesSpecialtyDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalListingDistancesSpecialtyDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalListingDistancesSpecialtyDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalListingDistancesSpecialtyDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalListingDistancesSpecialtyDefinitionType Constructor

LocalListingDistancesSpecialtyDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalListingDistancesSpecialtyDefinitionType ► LocalListingDistancesSpecialtyDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalListingDistancesSpecialtyDefinitionType()
Public Sub New
public:
LocalListingDistancesSpecialtyDefinitionType()


LocalMarketAdFormatEnabledDefinitionType Class

LocalMarketAdFormatEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketAdFormatEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketAdFormatEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketAdFormatEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketAdFormatEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketAdFormatEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketAdFormatEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketAdFormatEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketAdFormatEnabledDefinitionType Constructor

LocalMarketAdFormatEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketAdFormatEnabledDefinitionType ► LocalMarketAdFormatEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketAdFormatEnabledDefinitionType()
Public Sub New
public:
LocalMarketAdFormatEnabledDefinitionType()


LocalMarketAutoAcceptEnabledDefinitionType Class

LocalMarketAutoAcceptEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketAutoAcceptEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketAutoAcceptEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketAutoAcceptEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketAutoAcceptEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketAutoAcceptEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketAutoAcceptEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketAutoAcceptEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketAutoAcceptEnabledDefinitionType Constructor

LocalMarketAutoAcceptEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketAutoAcceptEnabledDefinitionType ► LocalMarketAutoAcceptEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketAutoAcceptEnabledDefinitionType()
Public Sub New
public:
LocalMarketAutoAcceptEnabledDefinitionType()


LocalMarketAutoDeclineEnabledDefinitionType Class

LocalMarketAutoDeclineEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketAutoDeclineEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketAutoDeclineEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketAutoDeclineEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketAutoDeclineEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketAutoDeclineEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketAutoDeclineEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketAutoDeclineEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketAutoDeclineEnabledDefinitionType Constructor

LocalMarketAutoDeclineEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketAutoDeclineEnabledDefinitionType ► LocalMarketAutoDeclineEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketAutoDeclineEnabledDefinitionType()
Public Sub New
public:
LocalMarketAutoDeclineEnabledDefinitionType()


LocalMarketBestOfferEnabledDefinitionType Class

LocalMarketBestOfferEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketBestOfferEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketBestOfferEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketBestOfferEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketBestOfferEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketBestOfferEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketBestOfferEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketBestOfferEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketBestOfferEnabledDefinitionType Constructor

LocalMarketBestOfferEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketBestOfferEnabledDefinitionType ► LocalMarketBestOfferEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketBestOfferEnabledDefinitionType()
Public Sub New
public:
LocalMarketBestOfferEnabledDefinitionType()


LocalMarketCompanyNameEnabledDefinitionType Class

LocalMarketCompanyNameEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketCompanyNameEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketCompanyNameEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketCompanyNameEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketCompanyNameEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketCompanyNameEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketCompanyNameEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketCompanyNameEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketCompanyNameEnabledDefinitionType Constructor

LocalMarketCompanyNameEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketCompanyNameEnabledDefinitionType ► LocalMarketCompanyNameEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketCompanyNameEnabledDefinitionType()
Public Sub New
public:
LocalMarketCompanyNameEnabledDefinitionType()


LocalMarketContactByAddressEnabledDefinitionType Class

LocalMarketContactByAddressEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketContactByAddressEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketContactByAddressEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketContactByAddressEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketContactByAddressEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketContactByAddressEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketContactByAddressEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketContactByAddressEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketContactByAddressEnabledDefinitionType Constructor

LocalMarketContactByAddressEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketContactByAddressEnabledDefinitionType ► LocalMarketContactByAddressEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketContactByAddressEnabledDefinitionType()
Public Sub New
public:
LocalMarketContactByAddressEnabledDefinitionType()


LocalMarketContactByEmailEnabledDefinitionType Class

LocalMarketContactByEmailEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketContactByEmailEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketContactByEmailEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketContactByEmailEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketContactByEmailEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketContactByEmailEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketContactByEmailEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketContactByEmailEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketContactByEmailEnabledDefinitionType Constructor

LocalMarketContactByEmailEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketContactByEmailEnabledDefinitionType ► LocalMarketContactByEmailEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketContactByEmailEnabledDefinitionType()
Public Sub New
public:
LocalMarketContactByEmailEnabledDefinitionType()


LocalMarketContactByPhoneEnabledDefinitionType Class

LocalMarketContactByPhoneEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketContactByPhoneEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketContactByPhoneEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketContactByPhoneEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketContactByPhoneEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketContactByPhoneEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketContactByPhoneEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketContactByPhoneEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketContactByPhoneEnabledDefinitionType Constructor

LocalMarketContactByPhoneEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketContactByPhoneEnabledDefinitionType ► LocalMarketContactByPhoneEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketContactByPhoneEnabledDefinitionType()
Public Sub New
public:
LocalMarketContactByPhoneEnabledDefinitionType()


LocalMarketCounterOfferEnabledDefinitionType Class

LocalMarketCounterOfferEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketCounterOfferEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketCounterOfferEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketCounterOfferEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketCounterOfferEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketCounterOfferEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketCounterOfferEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketCounterOfferEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketCounterOfferEnabledDefinitionType Constructor

LocalMarketCounterOfferEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketCounterOfferEnabledDefinitionType ► LocalMarketCounterOfferEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketCounterOfferEnabledDefinitionType()
Public Sub New
public:
LocalMarketCounterOfferEnabledDefinitionType()


LocalMarketNonSubscriptionDefinitionType Class

LocalMarketNonSubscriptionDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketNonSubscriptionDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketNonSubscriptionDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketNonSubscriptionDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketNonSubscriptionDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketNonSubscriptionDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketNonSubscriptionDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketNonSubscriptionDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketNonSubscriptionDefinitionType Constructor

LocalMarketNonSubscriptionDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketNonSubscriptionDefinitionType ► LocalMarketNonSubscriptionDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketNonSubscriptionDefinitionType()
Public Sub New
public:
LocalMarketNonSubscriptionDefinitionType()


LocalMarketPaymentMethodCheckOutEnabledDefinitionType Class

LocalMarketPaymentMethodCheckOutEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketPaymentMethodCheckOutEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketPaymentMethodCheckOutEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketPaymentMethodCheckOutEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketPaymentMethodCheckOutEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketPaymentMethodCheckOutEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketPaymentMethodCheckOutEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketPaymentMethodCheckOutEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketPaymentMethodCheckOutEnabledDefinitionType Constructor

LocalMarketPaymentMethodCheckOutEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketPaymentMethodCheckOutEnabledDefinitionType ► LocalMarketPaymentMethodCheckOutEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketPaymentMethodCheckOutEnabledDefinitionType()
Public Sub New
public:
LocalMarketPaymentMethodCheckOutEnabledDefinitionType()


LocalMarketPhoneCountDefinitionType Class

LocalMarketPhoneCountDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketPhoneCountDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketPhoneCountDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketPhoneCountDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketPhoneCountDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketPhoneCountDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketPhoneCountDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketPhoneCountDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketPhoneCountDefinitionType Constructor

LocalMarketPhoneCountDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketPhoneCountDefinitionType ► LocalMarketPhoneCountDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketPhoneCountDefinitionType()
Public Sub New
public:
LocalMarketPhoneCountDefinitionType()


LocalMarketPremiumSubscriptionDefinitionType Class

LocalMarketPremiumSubscriptionDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketPremiumSubscriptionDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketPremiumSubscriptionDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketPremiumSubscriptionDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketPremiumSubscriptionDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketPremiumSubscriptionDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketPremiumSubscriptionDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketPremiumSubscriptionDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketPremiumSubscriptionDefinitionType Constructor

LocalMarketPremiumSubscriptionDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketPremiumSubscriptionDefinitionType ► LocalMarketPremiumSubscriptionDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketPremiumSubscriptionDefinitionType()
Public Sub New
public:
LocalMarketPremiumSubscriptionDefinitionType()


LocalMarketRegularSubscriptionDefinitionType Class

LocalMarketRegularSubscriptionDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketRegularSubscriptionDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketRegularSubscriptionDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketRegularSubscriptionDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketRegularSubscriptionDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketRegularSubscriptionDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketRegularSubscriptionDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketRegularSubscriptionDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketRegularSubscriptionDefinitionType Constructor

LocalMarketRegularSubscriptionDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketRegularSubscriptionDefinitionType ► LocalMarketRegularSubscriptionDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketRegularSubscriptionDefinitionType()
Public Sub New
public:
LocalMarketRegularSubscriptionDefinitionType()


LocalMarketSellerContactDetailsEnabledDefinitionType Class

LocalMarketSellerContactDetailsEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketSellerContactDetailsEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketSellerContactDetailsEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketSellerContactDetailsEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketSellerContactDetailsEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketSellerContactDetailsEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketSellerContactDetailsEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketSellerContactDetailsEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketSellerContactDetailsEnabledDefinitionType Constructor

LocalMarketSellerContactDetailsEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketSellerContactDetailsEnabledDefinitionType ► LocalMarketSellerContactDetailsEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketSellerContactDetailsEnabledDefinitionType()
Public Sub New
public:
LocalMarketSellerContactDetailsEnabledDefinitionType()


LocalMarketShippingMethodEnabledDefinitionType Class

LocalMarketShippingMethodEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketShippingMethodEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketShippingMethodEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketShippingMethodEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketShippingMethodEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketShippingMethodEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketShippingMethodEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketShippingMethodEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketShippingMethodEnabledDefinitionType Constructor

LocalMarketShippingMethodEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketShippingMethodEnabledDefinitionType ► LocalMarketShippingMethodEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketShippingMethodEnabledDefinitionType()
Public Sub New
public:
LocalMarketShippingMethodEnabledDefinitionType()


LocalMarketSpecialitySubscriptionDefinitionType Class

LocalMarketSpecialitySubscriptionDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketSpecialitySubscriptionDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketSpecialitySubscriptionDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketSpecialitySubscriptionDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketSpecialitySubscriptionDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketSpecialitySubscriptionDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketSpecialitySubscriptionDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketSpecialitySubscriptionDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketSpecialitySubscriptionDefinitionType Constructor

LocalMarketSpecialitySubscriptionDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketSpecialitySubscriptionDefinitionType ► LocalMarketSpecialitySubscriptionDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketSpecialitySubscriptionDefinitionType()
Public Sub New
public:
LocalMarketSpecialitySubscriptionDefinitionType()


LocalMarketStreetCountDefinitionType Class

LocalMarketStreetCountDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► LocalMarketStreetCountDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LocalMarketStreetCountDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LocalMarketStreetCountDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LocalMarketStreetCountDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalMarketStreetCountDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
LocalMarketStreetCountDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LocalMarketStreetCountDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LocalMarketStreetCountDefinitionType Constructor

LocalMarketStreetCountDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► LocalMarketStreetCountDefinitionType ► LocalMarketStreetCountDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LocalMarketStreetCountDefinitionType()
Public Sub New
public:
LocalMarketStreetCountDefinitionType()


LookupAttributeType Class

LookupAttributeType Class
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class LookupAttributeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class LookupAttributeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class LookupAttributeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LookupAttributeType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
 | Value |
Remarks
Inheritance Hierarchy
Object
LookupAttributeType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LookupAttributeType Constructor

LookupAttributeType Constructor
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeType ► LookupAttributeType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LookupAttributeType()
Public Sub New
public:
LookupAttributeType()


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


LookupAttributeTypeCollection Class

LookupAttributeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class LookupAttributeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class LookupAttributeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class LookupAttributeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LookupAttributeTypeCollection()()()() |
 | LookupAttributeTypeCollection(array<LookupAttributeType>[]()[][]) |
 | LookupAttributeTypeCollection(LookupAttributeTypeCollection) |
 | Add(LookupAttributeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<LookupAttributeType>[]()[][]) |
 | AddRange(LookupAttributeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(LookupAttributeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<LookupAttributeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(LookupAttributeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, LookupAttributeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(LookupAttributeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | LookupAttributeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► Add(LookupAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    LookupAttributeType item
)
Public Function Add ( _
    item As LookupAttributeType _
) As Integer
public:
int Add(
    LookupAttributeType^ item
)
Parameters
item (LookupAttributeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<LookupAttributeType>[]()[][]) |
 | AddRange(LookupAttributeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► AddRange(array<LookupAttributeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    LookupAttributeType[] items
)
Public Sub AddRange ( _
    items As LookupAttributeType() _
)
public:
void AddRange(
    array<LookupAttributeType^>^ items
)
Parameters
items (array< LookupAttributeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► AddRange(LookupAttributeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    LookupAttributeTypeCollection items
)
Public Sub AddRange ( _
    items As LookupAttributeTypeCollection _
)
public:
void AddRange(
    LookupAttributeTypeCollection^ items
)
Parameters
items (LookupAttributeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► Contains(LookupAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    LookupAttributeType item
)
Public Function Contains ( _
    item As LookupAttributeType _
) As Boolean
public:
bool Contains(
    LookupAttributeType^ item
)
Parameters
item (LookupAttributeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► CopyTo(array<LookupAttributeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    LookupAttributeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As LookupAttributeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<LookupAttributeType^>^ items,
    int index
)
Parameters
items (array< LookupAttributeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► IndexOf(LookupAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    LookupAttributeType item
)
Public Function IndexOf ( _
    item As LookupAttributeType _
) As Integer
public:
int IndexOf(
    LookupAttributeType^ item
)
Parameters
item (LookupAttributeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► Insert(Int32, LookupAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    LookupAttributeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As LookupAttributeType _
)
public:
void Insert(
    int index,
    LookupAttributeType^ item
)
Parameters
index (Int32)
item (LookupAttributeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public LookupAttributeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As LookupAttributeType
    Get
    Set
public:
property LookupAttributeType^ default[int index] {
    LookupAttributeType^ get (int index);
    void set (int index, LookupAttributeType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public LookupAttributeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As LookupAttributeType
public:
LookupAttributeType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


LookupAttributeTypeCollection Constructor

LookupAttributeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► LookupAttributeTypeCollection()()()()
Members
Icon | Member | Description
 | LookupAttributeTypeCollection()()()() |
 | LookupAttributeTypeCollection(array<LookupAttributeType>[]()[][]) |
 | LookupAttributeTypeCollection(LookupAttributeTypeCollection) |


LookupAttributeTypeCollection Constructor

LookupAttributeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► LookupAttributeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LookupAttributeTypeCollection()
Public Sub New
public:
LookupAttributeTypeCollection()


LookupAttributeTypeCollection Constructor (items)

LookupAttributeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► LookupAttributeTypeCollection(array<LookupAttributeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public LookupAttributeTypeCollection(
    LookupAttributeType[] items
)
Public Sub New ( _
    items As LookupAttributeType() _
)
public:
LookupAttributeTypeCollection(
    array<LookupAttributeType^>^ items
)
Parameters
items (array< LookupAttributeType >[]()[][])


LookupAttributeTypeCollection Constructor (items)

LookupAttributeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► LookupAttributeTypeCollection(LookupAttributeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public LookupAttributeTypeCollection(
    LookupAttributeTypeCollection items
)
Public Sub New ( _
    items As LookupAttributeTypeCollection _
)
public:
LookupAttributeTypeCollection(
    LookupAttributeTypeCollection^ items
)
Parameters
items (LookupAttributeTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► Remove(LookupAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    LookupAttributeType item
)
Public Sub Remove ( _
    item As LookupAttributeType _
)
public:
void Remove(
    LookupAttributeType^ item
)
Parameters
item (LookupAttributeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LookupAttributeType[] ToArray()
Public Function ToArray As LookupAttributeType()
public:
array<LookupAttributeType^>^ ToArray()
Return Value


MarkUpMarkDownEventType Class

MarkUpMarkDownEventType Class
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MarkUpMarkDownEventType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MarkUpMarkDownEventType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MarkUpMarkDownEventType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MarkUpMarkDownEventType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Reason |
 | Time |
 | TimeSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | TypeSpecified |
Remarks
Inheritance Hierarchy
Object
MarkUpMarkDownEventType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MarkUpMarkDownEventType Constructor

MarkUpMarkDownEventType Constructor
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventType ► MarkUpMarkDownEventType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MarkUpMarkDownEventType()
Public Sub New
public:
MarkUpMarkDownEventType()


Reason Property

Reason Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventType ► Reason
Declaration Syntax
C# Visual Basic Visual C++
public string Reason { get; set; }
Public Property Reason As String
    Get
    Set
public:
property String^ Reason {
    String^ get ();
    void set (String^ value);
}


Time Property

Time Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventType ► Time
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Time { get; set; }
Public Property Time As DateTime
    Get
    Set
public:
property DateTime Time {
    DateTime get ();
    void set (DateTime value);
}


TimeSpecified Property

TimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventType ► TimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TimeSpecified { get; set; }
Public Property TimeSpecified As Boolean
    Get
    Set
public:
property bool TimeSpecified {
    bool get ();
    void set (bool value);
}


Type Property

Type Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventType ► Type
Declaration Syntax
C# Visual Basic Visual C++
public MarkUpMarkDownEventTypeCodeType Type { get; set; }
Public Property Type As MarkUpMarkDownEventTypeCodeType
    Get
    Set
public:
property MarkUpMarkDownEventTypeCodeType Type {
    MarkUpMarkDownEventTypeCodeType get ();
    void set (MarkUpMarkDownEventTypeCodeType value);
}


TypeSpecified Property

TypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventType ► TypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TypeSpecified { get; set; }
Public Property TypeSpecified As Boolean
    Get
    Set
public:
property bool TypeSpecified {
    bool get ();
    void set (bool value);
}


MarkUpMarkDownEventTypeCodeType Enumeration

MarkUpMarkDownEventTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum MarkUpMarkDownEventTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration MarkUpMarkDownEventTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class MarkUpMarkDownEventTypeCodeType
Members
Member | Description
MarkUp |
MarkDown |
CustomCode |
Remarks


MarkUpMarkDownEventTypeCollection Class

MarkUpMarkDownEventTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class MarkUpMarkDownEventTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class MarkUpMarkDownEventTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class MarkUpMarkDownEventTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MarkUpMarkDownEventTypeCollection()()()() |
 | MarkUpMarkDownEventTypeCollection(array<MarkUpMarkDownEventType>[]()[][]) |
 | MarkUpMarkDownEventTypeCollection(MarkUpMarkDownEventTypeCollection) |
 | Add(MarkUpMarkDownEventType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<MarkUpMarkDownEventType>[]()[][]) |
 | AddRange(MarkUpMarkDownEventTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(MarkUpMarkDownEventType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<MarkUpMarkDownEventType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(MarkUpMarkDownEventType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, MarkUpMarkDownEventType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(MarkUpMarkDownEventType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | MarkUpMarkDownEventTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► Add(MarkUpMarkDownEventType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MarkUpMarkDownEventType item
)
Public Function Add ( _
    item As MarkUpMarkDownEventType _
) As Integer
public:
int Add(
    MarkUpMarkDownEventType^ item
)
Parameters
item (MarkUpMarkDownEventType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<MarkUpMarkDownEventType>[]()[][]) |
 | AddRange(MarkUpMarkDownEventTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► AddRange(array<MarkUpMarkDownEventType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MarkUpMarkDownEventType[] items
)
Public Sub AddRange ( _
    items As MarkUpMarkDownEventType() _
)
public:
void AddRange(
    array<MarkUpMarkDownEventType^>^ items
)
Parameters
items (array< MarkUpMarkDownEventType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► AddRange(MarkUpMarkDownEventTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MarkUpMarkDownEventTypeCollection items
)
Public Sub AddRange ( _
    items As MarkUpMarkDownEventTypeCollection _
)
public:
void AddRange(
    MarkUpMarkDownEventTypeCollection^ items
)
Parameters
items (MarkUpMarkDownEventTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► Contains(MarkUpMarkDownEventType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    MarkUpMarkDownEventType item
)
Public Function Contains ( _
    item As MarkUpMarkDownEventType _
) As Boolean
public:
bool Contains(
    MarkUpMarkDownEventType^ item
)
Parameters
item (MarkUpMarkDownEventType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► CopyTo(array<MarkUpMarkDownEventType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MarkUpMarkDownEventType[] items,
    int index
)
Public Sub CopyTo ( _
    items As MarkUpMarkDownEventType(), _
    index As Integer _
)
public:
void CopyTo(
    array<MarkUpMarkDownEventType^>^ items,
    int index
)
Parameters
items (array< MarkUpMarkDownEventType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► IndexOf(MarkUpMarkDownEventType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    MarkUpMarkDownEventType item
)
Public Function IndexOf ( _
    item As MarkUpMarkDownEventType _
) As Integer
public:
int IndexOf(
    MarkUpMarkDownEventType^ item
)
Parameters
item (MarkUpMarkDownEventType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► Insert(Int32, MarkUpMarkDownEventType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    MarkUpMarkDownEventType item
)
Public Sub Insert ( _
    index As Integer, _
    item As MarkUpMarkDownEventType _
)
public:
void Insert(
    int index,
    MarkUpMarkDownEventType^ item
)
Parameters
index (Int32)
item (MarkUpMarkDownEventType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MarkUpMarkDownEventType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MarkUpMarkDownEventType
    Get
    Set
public:
property MarkUpMarkDownEventType^ default[int index] {
    MarkUpMarkDownEventType^ get (int index);
    void set (int index, MarkUpMarkDownEventType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MarkUpMarkDownEventType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As MarkUpMarkDownEventType
public:
MarkUpMarkDownEventType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


MarkUpMarkDownEventTypeCollection Constructor

MarkUpMarkDownEventTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► MarkUpMarkDownEventTypeCollection()()()()
Members
Icon | Member | Description
 | MarkUpMarkDownEventTypeCollection()()()() |
 | MarkUpMarkDownEventTypeCollection(array<MarkUpMarkDownEventType>[]()[][]) |
 | MarkUpMarkDownEventTypeCollection(MarkUpMarkDownEventTypeCollection) |


MarkUpMarkDownEventTypeCollection Constructor

MarkUpMarkDownEventTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► MarkUpMarkDownEventTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MarkUpMarkDownEventTypeCollection()
Public Sub New
public:
MarkUpMarkDownEventTypeCollection()


MarkUpMarkDownEventTypeCollection Constructor (items)

MarkUpMarkDownEventTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► MarkUpMarkDownEventTypeCollection(array<MarkUpMarkDownEventType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public MarkUpMarkDownEventTypeCollection(
    MarkUpMarkDownEventType[] items
)
Public Sub New ( _
    items As MarkUpMarkDownEventType() _
)
public:
MarkUpMarkDownEventTypeCollection(
    array<MarkUpMarkDownEventType^>^ items
)
Parameters
items (array< MarkUpMarkDownEventType >[]()[][])


MarkUpMarkDownEventTypeCollection Constructor (items)

MarkUpMarkDownEventTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► MarkUpMarkDownEventTypeCollection(MarkUpMarkDownEventTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MarkUpMarkDownEventTypeCollection(
    MarkUpMarkDownEventTypeCollection items
)
Public Sub New ( _
    items As MarkUpMarkDownEventTypeCollection _
)
public:
MarkUpMarkDownEventTypeCollection(
    MarkUpMarkDownEventTypeCollection^ items
)
Parameters
items (MarkUpMarkDownEventTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► Remove(MarkUpMarkDownEventType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    MarkUpMarkDownEventType item
)
Public Sub Remove ( _
    item As MarkUpMarkDownEventType _
)
public:
void Remove(
    MarkUpMarkDownEventType^ item
)
Parameters
item (MarkUpMarkDownEventType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MarkUpMarkDownEventType[] ToArray()
Public Function ToArray As MarkUpMarkDownEventType()
public:
array<MarkUpMarkDownEventType^>^ ToArray()
Return Value


MaxFlatShippingCostCBTExemptDefinitionType Class

MaxFlatShippingCostCBTExemptDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► MaxFlatShippingCostCBTExemptDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaxFlatShippingCostCBTExemptDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaxFlatShippingCostCBTExemptDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaxFlatShippingCostCBTExemptDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaxFlatShippingCostCBTExemptDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaxFlatShippingCostCBTExemptDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MaxFlatShippingCostCBTExemptDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MaxFlatShippingCostCBTExemptDefinitionType Constructor

MaxFlatShippingCostCBTExemptDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaxFlatShippingCostCBTExemptDefinitionType ► MaxFlatShippingCostCBTExemptDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaxFlatShippingCostCBTExemptDefinitionType()
Public Sub New
public:
MaxFlatShippingCostCBTExemptDefinitionType()


MaxFlatShippingCostDefinitionType Class

MaxFlatShippingCostDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► MaxFlatShippingCostDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaxFlatShippingCostDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaxFlatShippingCostDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaxFlatShippingCostDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaxFlatShippingCostDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaxFlatShippingCostDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MaxFlatShippingCostDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MaxFlatShippingCostDefinitionType Constructor

MaxFlatShippingCostDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaxFlatShippingCostDefinitionType ► MaxFlatShippingCostDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaxFlatShippingCostDefinitionType()
Public Sub New
public:
MaxFlatShippingCostDefinitionType()


MaxGranularFitmentCountDefinitionType Class

MaxGranularFitmentCountDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► MaxGranularFitmentCountDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaxGranularFitmentCountDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaxGranularFitmentCountDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaxGranularFitmentCountDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaxGranularFitmentCountDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaxGranularFitmentCountDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MaxGranularFitmentCountDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MaxGranularFitmentCountDefinitionType Constructor

MaxGranularFitmentCountDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaxGranularFitmentCountDefinitionType ► MaxGranularFitmentCountDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaxGranularFitmentCountDefinitionType()
Public Sub New
public:
MaxGranularFitmentCountDefinitionType()


MaximumBuyerPolicyViolationsDetailsType Class

MaximumBuyerPolicyViolationsDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaximumBuyerPolicyViolationsDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaximumBuyerPolicyViolationsDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaximumBuyerPolicyViolationsDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaximumBuyerPolicyViolationsDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumberOfPolicyViolations |
 | PolicyViolationDuration |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaximumBuyerPolicyViolationsDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MaximumBuyerPolicyViolationsDetailsType Constructor

MaximumBuyerPolicyViolationsDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsDetailsType ► MaximumBuyerPolicyViolationsDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaximumBuyerPolicyViolationsDetailsType()
Public Sub New
public:
MaximumBuyerPolicyViolationsDetailsType()


NumberOfPolicyViolations Property

NumberOfPolicyViolations Property
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsDetailsType ► NumberOfPolicyViolations
Declaration Syntax
C# Visual Basic Visual C++
public NumberOfPolicyViolationsDetailsType NumberOfPolicyViolations { get; set; }
Public Property NumberOfPolicyViolations As NumberOfPolicyViolationsDetailsType
    Get
    Set
public:
property NumberOfPolicyViolationsDetailsType^ NumberOfPolicyViolations {
    NumberOfPolicyViolationsDetailsType^ get ();
    void set (NumberOfPolicyViolationsDetailsType^ value);
}


PolicyViolationDuration Property

PolicyViolationDuration Property
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsDetailsType ► PolicyViolationDuration
Declaration Syntax
C# Visual Basic Visual C++
public PolicyViolationDurationDetailsTypeCollection PolicyViolationDuration { get; set; }
Public Property PolicyViolationDuration As PolicyViolationDurationDetailsTypeCollection
    Get
    Set
public:
property PolicyViolationDurationDetailsTypeCollection^ PolicyViolationDuration {
    PolicyViolationDurationDetailsTypeCollection^ get ();
    void set (PolicyViolationDurationDetailsTypeCollection^ value);
}


MaximumBuyerPolicyViolationsType Class

MaximumBuyerPolicyViolationsType Class
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaximumBuyerPolicyViolationsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaximumBuyerPolicyViolationsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaximumBuyerPolicyViolationsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaximumBuyerPolicyViolationsType()()()() |
 | Any |
 | Count |
 | CountSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Period |
 | PeriodSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaximumBuyerPolicyViolationsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Count Property

Count Property
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsType ► Count
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; set; }
Public Property Count As Integer
    Get
    Set
public:
property int Count {
    int get ();
    void set (int value);
}


CountSpecified Property

CountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsType ► CountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CountSpecified { get; set; }
Public Property CountSpecified As Boolean
    Get
    Set
public:
property bool CountSpecified {
    bool get ();
    void set (bool value);
}


MaximumBuyerPolicyViolationsType Constructor

MaximumBuyerPolicyViolationsType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsType ► MaximumBuyerPolicyViolationsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaximumBuyerPolicyViolationsType()
Public Sub New
public:
MaximumBuyerPolicyViolationsType()


Period Property

Period Property
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsType ► Period
Declaration Syntax
C# Visual Basic Visual C++
public PeriodCodeType Period { get; set; }
Public Property Period As PeriodCodeType
    Get
    Set
public:
property PeriodCodeType Period {
    PeriodCodeType get ();
    void set (PeriodCodeType value);
}


PeriodSpecified Property

PeriodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MaximumBuyerPolicyViolationsType ► PeriodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PeriodSpecified { get; set; }
Public Property PeriodSpecified As Boolean
    Get
    Set
public:
property bool PeriodSpecified {
    bool get ();
    void set (bool value);
}


MaximumItemRequirementsDetailsType Class

MaximumItemRequirementsDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► MaximumItemRequirementsDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaximumItemRequirementsDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaximumItemRequirementsDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaximumItemRequirementsDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaximumItemRequirementsDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MaximumItemCount |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumFeedbackScore |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaximumItemRequirementsDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MaximumItemRequirementsDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MaximumItemCount Property

MaximumItemCount Property
Namespaces ► eBay.Service.Core.Soap ► MaximumItemRequirementsDetailsType ► MaximumItemCount
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection MaximumItemCount { get; set; }
Public Property MaximumItemCount As Int32Collection
    Get
    Set
public:
property Int32Collection^ MaximumItemCount {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


MaximumItemRequirementsDetailsType Constructor

MaximumItemRequirementsDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaximumItemRequirementsDetailsType ► MaximumItemRequirementsDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaximumItemRequirementsDetailsType()
Public Sub New
public:
MaximumItemRequirementsDetailsType()


MinimumFeedbackScore Property

MinimumFeedbackScore Property
Namespaces ► eBay.Service.Core.Soap ► MaximumItemRequirementsDetailsType ► MinimumFeedbackScore
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection MinimumFeedbackScore { get; set; }
Public Property MinimumFeedbackScore As Int32Collection
    Get
    Set
public:
property Int32Collection^ MinimumFeedbackScore {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


MaximumItemRequirementsType Class

MaximumItemRequirementsType Class
Namespaces ► eBay.Service.Core.Soap ► MaximumItemRequirementsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaximumItemRequirementsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaximumItemRequirementsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaximumItemRequirementsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaximumItemRequirementsType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MaximumItemCount |
 | MaximumItemCountSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumFeedbackScore |
 | MinimumFeedbackScoreSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaximumItemRequirementsType


MaximumItemCount Property

MaximumItemCount Property
Namespaces ► eBay.Service.Core.Soap ► MaximumItemRequirementsType ► MaximumItemCount
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumItemCount { get; set; }
Public Property MaximumItemCount As Integer
    Get
    Set
public:
property int MaximumItemCount {
    int get ();
    void set (int value);
}


MaximumItemCountSpecified Property

MaximumItemCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MaximumItemRequirementsType ► MaximumItemCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaximumItemCountSpecified { get; set; }
Public Property MaximumItemCountSpecified As Boolean
    Get
    Set
public:
property bool MaximumItemCountSpecified {
    bool get ();
    void set (bool value);
}


MaximumItemRequirementsType Constructor

MaximumItemRequirementsType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaximumItemRequirementsType ► MaximumItemRequirementsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaximumItemRequirementsType()
Public Sub New
public:
MaximumItemRequirementsType()


MinimumFeedbackScore Property

MinimumFeedbackScore Property
Namespaces ► eBay.Service.Core.Soap ► MaximumItemRequirementsType ► MinimumFeedbackScore
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumFeedbackScore { get; set; }
Public Property MinimumFeedbackScore As Integer
    Get
    Set
public:
property int MinimumFeedbackScore {
    int get ();
    void set (int value);
}


MinimumFeedbackScoreSpecified Property

MinimumFeedbackScoreSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MaximumItemRequirementsType ► MinimumFeedbackScoreSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinimumFeedbackScoreSpecified { get; set; }
Public Property MinimumFeedbackScoreSpecified As Boolean
    Get
    Set
public:
property bool MinimumFeedbackScoreSpecified {
    bool get ();
    void set (bool value);
}


MaximumUnpaidItemStrikesCountDetailsType Class

MaximumUnpaidItemStrikesCountDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesCountDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaximumUnpaidItemStrikesCountDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaximumUnpaidItemStrikesCountDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaximumUnpaidItemStrikesCountDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaximumUnpaidItemStrikesCountDetailsType()()()() |
 | Any |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaximumUnpaidItemStrikesCountDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesCountDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Count Property

Count Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesCountDetailsType ► Count
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection Count { get; set; }
Public Property Count As Int32Collection
    Get
    Set
public:
property Int32Collection^ Count {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


MaximumUnpaidItemStrikesCountDetailsType Constructor

MaximumUnpaidItemStrikesCountDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesCountDetailsType ► MaximumUnpaidItemStrikesCountDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesCountDetailsType()
Public Sub New
public:
MaximumUnpaidItemStrikesCountDetailsType()


MaximumUnpaidItemStrikesDurationDetailsType Class

MaximumUnpaidItemStrikesDurationDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaximumUnpaidItemStrikesDurationDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaximumUnpaidItemStrikesDurationDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaximumUnpaidItemStrikesDurationDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaximumUnpaidItemStrikesDurationDetailsType()()()() |
 | Any |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Period |
 | PeriodSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaximumUnpaidItemStrikesDurationDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


MaximumUnpaidItemStrikesDurationDetailsType Constructor

MaximumUnpaidItemStrikesDurationDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsType ► MaximumUnpaidItemStrikesDurationDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesDurationDetailsType()
Public Sub New
public:
MaximumUnpaidItemStrikesDurationDetailsType()


Period Property

Period Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsType ► Period
Declaration Syntax
C# Visual Basic Visual C++
public PeriodCodeType Period { get; set; }
Public Property Period As PeriodCodeType
    Get
    Set
public:
property PeriodCodeType Period {
    PeriodCodeType get ();
    void set (PeriodCodeType value);
}


PeriodSpecified Property

PeriodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsType ► PeriodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PeriodSpecified { get; set; }
Public Property PeriodSpecified As Boolean
    Get
    Set
public:
property bool PeriodSpecified {
    bool get ();
    void set (bool value);
}


MaximumUnpaidItemStrikesDurationDetailsTypeCollection Class

MaximumUnpaidItemStrikesDurationDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class MaximumUnpaidItemStrikesDurationDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class MaximumUnpaidItemStrikesDurationDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class MaximumUnpaidItemStrikesDurationDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaximumUnpaidItemStrikesDurationDetailsTypeCollection()()()() |
 | MaximumUnpaidItemStrikesDurationDetailsTypeCollection(array<MaximumUnpaidItemStrikesDurationDetailsType>[]()[][]) |
 | MaximumUnpaidItemStrikesDurationDetailsTypeCollection(MaximumUnpaidItemStrikesDurationDetailsTypeCollection) |
 | Add(MaximumUnpaidItemStrikesDurationDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<MaximumUnpaidItemStrikesDurationDetailsType>[]()[][]) |
 | AddRange(MaximumUnpaidItemStrikesDurationDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(MaximumUnpaidItemStrikesDurationDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<MaximumUnpaidItemStrikesDurationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(MaximumUnpaidItemStrikesDurationDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, MaximumUnpaidItemStrikesDurationDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(MaximumUnpaidItemStrikesDurationDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | MaximumUnpaidItemStrikesDurationDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► Add(MaximumUnpaidItemStrikesDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MaximumUnpaidItemStrikesDurationDetailsType item
)
Public Function Add ( _
    item As MaximumUnpaidItemStrikesDurationDetailsType _
) As Integer
public:
int Add(
    MaximumUnpaidItemStrikesDurationDetailsType^ item
)
Parameters
item (MaximumUnpaidItemStrikesDurationDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<MaximumUnpaidItemStrikesDurationDetailsType>[]()[][]) |
 | AddRange(MaximumUnpaidItemStrikesDurationDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► AddRange(array<MaximumUnpaidItemStrikesDurationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MaximumUnpaidItemStrikesDurationDetailsType[] items
)
Public Sub AddRange ( _
    items As MaximumUnpaidItemStrikesDurationDetailsType() _
)
public:
void AddRange(
    array<MaximumUnpaidItemStrikesDurationDetailsType^>^ items
)
Parameters
items (array< MaximumUnpaidItemStrikesDurationDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► AddRange(MaximumUnpaidItemStrikesDurationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MaximumUnpaidItemStrikesDurationDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As MaximumUnpaidItemStrikesDurationDetailsTypeCollection _
)
public:
void AddRange(
    MaximumUnpaidItemStrikesDurationDetailsTypeCollection^ items
)
Parameters
items (MaximumUnpaidItemStrikesDurationDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► Contains(MaximumUnpaidItemStrikesDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    MaximumUnpaidItemStrikesDurationDetailsType item
)
Public Function Contains ( _
    item As MaximumUnpaidItemStrikesDurationDetailsType _
) As Boolean
public:
bool Contains(
    MaximumUnpaidItemStrikesDurationDetailsType^ item
)
Parameters
item (MaximumUnpaidItemStrikesDurationDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► CopyTo(array<MaximumUnpaidItemStrikesDurationDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MaximumUnpaidItemStrikesDurationDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As MaximumUnpaidItemStrikesDurationDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<MaximumUnpaidItemStrikesDurationDetailsType^>^ items,
    int index
)
Parameters
items (array< MaximumUnpaidItemStrikesDurationDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► IndexOf(MaximumUnpaidItemStrikesDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    MaximumUnpaidItemStrikesDurationDetailsType item
)
Public Function IndexOf ( _
    item As MaximumUnpaidItemStrikesDurationDetailsType _
) As Integer
public:
int IndexOf(
    MaximumUnpaidItemStrikesDurationDetailsType^ item
)
Parameters
item (MaximumUnpaidItemStrikesDurationDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► Insert(Int32, MaximumUnpaidItemStrikesDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    MaximumUnpaidItemStrikesDurationDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As MaximumUnpaidItemStrikesDurationDetailsType _
)
public:
void Insert(
    int index,
    MaximumUnpaidItemStrikesDurationDetailsType^ item
)
Parameters
index (Int32)
item (MaximumUnpaidItemStrikesDurationDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesDurationDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MaximumUnpaidItemStrikesDurationDetailsType
    Get
    Set
public:
property MaximumUnpaidItemStrikesDurationDetailsType^ default[int index] {
    MaximumUnpaidItemStrikesDurationDetailsType^ get (int index);
    void set (int index, MaximumUnpaidItemStrikesDurationDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesDurationDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As MaximumUnpaidItemStrikesDurationDetailsType
public:
MaximumUnpaidItemStrikesDurationDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


MaximumUnpaidItemStrikesDurationDetailsTypeCollection Constructor

MaximumUnpaidItemStrikesDurationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | MaximumUnpaidItemStrikesDurationDetailsTypeCollection()()()() |
 | MaximumUnpaidItemStrikesDurationDetailsTypeCollection(array<MaximumUnpaidItemStrikesDurationDetailsType>[]()[][]) |
 | MaximumUnpaidItemStrikesDurationDetailsTypeCollection(MaximumUnpaidItemStrikesDurationDetailsTypeCollection) |


MaximumUnpaidItemStrikesDurationDetailsTypeCollection Constructor

MaximumUnpaidItemStrikesDurationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesDurationDetailsTypeCollection()
Public Sub New
public:
MaximumUnpaidItemStrikesDurationDetailsTypeCollection()


MaximumUnpaidItemStrikesDurationDetailsTypeCollection Constructor (items)

MaximumUnpaidItemStrikesDurationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection(array<MaximumUnpaidItemStrikesDurationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesDurationDetailsTypeCollection(
    MaximumUnpaidItemStrikesDurationDetailsType[] items
)
Public Sub New ( _
    items As MaximumUnpaidItemStrikesDurationDetailsType() _
)
public:
MaximumUnpaidItemStrikesDurationDetailsTypeCollection(
    array<MaximumUnpaidItemStrikesDurationDetailsType^>^ items
)
Parameters
items (array< MaximumUnpaidItemStrikesDurationDetailsType >[]()[][])


MaximumUnpaidItemStrikesDurationDetailsTypeCollection Constructor (items)

MaximumUnpaidItemStrikesDurationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection(MaximumUnpaidItemStrikesDurationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesDurationDetailsTypeCollection(
    MaximumUnpaidItemStrikesDurationDetailsTypeCollection items
)
Public Sub New ( _
    items As MaximumUnpaidItemStrikesDurationDetailsTypeCollection _
)
public:
MaximumUnpaidItemStrikesDurationDetailsTypeCollection(
    MaximumUnpaidItemStrikesDurationDetailsTypeCollection^ items
)
Parameters
items (MaximumUnpaidItemStrikesDurationDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► Remove(MaximumUnpaidItemStrikesDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    MaximumUnpaidItemStrikesDurationDetailsType item
)
Public Sub Remove ( _
    item As MaximumUnpaidItemStrikesDurationDetailsType _
)
public:
void Remove(
    MaximumUnpaidItemStrikesDurationDetailsType^ item
)
Parameters
item (MaximumUnpaidItemStrikesDurationDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesDurationDetailsType[] ToArray()
Public Function ToArray As MaximumUnpaidItemStrikesDurationDetailsType()
public:
array<MaximumUnpaidItemStrikesDurationDetailsType^>^ ToArray()
Return Value


MaximumUnpaidItemStrikesInfoDetailsType Class

MaximumUnpaidItemStrikesInfoDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaximumUnpaidItemStrikesInfoDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaximumUnpaidItemStrikesInfoDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaximumUnpaidItemStrikesInfoDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaximumUnpaidItemStrikesInfoDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MaximumUnpaidItemStrikesCount |
 | MaximumUnpaidItemStrikesDuration |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaximumUnpaidItemStrikesInfoDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MaximumUnpaidItemStrikesCount Property

MaximumUnpaidItemStrikesCount Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoDetailsType ► MaximumUnpaidItemStrikesCount
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesCountDetailsType MaximumUnpaidItemStrikesCount { get; set; }
Public Property MaximumUnpaidItemStrikesCount As MaximumUnpaidItemStrikesCountDetailsType
    Get
    Set
public:
property MaximumUnpaidItemStrikesCountDetailsType^ MaximumUnpaidItemStrikesCount {
    MaximumUnpaidItemStrikesCountDetailsType^ get ();
    void set (MaximumUnpaidItemStrikesCountDetailsType^ value);
}


MaximumUnpaidItemStrikesDuration Property

MaximumUnpaidItemStrikesDuration Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoDetailsType ► MaximumUnpaidItemStrikesDuration
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesDurationDetailsTypeCollection MaximumUnpaidItemStrikesDuration { get; set; }
Public Property MaximumUnpaidItemStrikesDuration As MaximumUnpaidItemStrikesDurationDetailsTypeCollection
    Get
    Set
public:
property MaximumUnpaidItemStrikesDurationDetailsTypeCollection^ MaximumUnpaidItemStrikesDuration {
    MaximumUnpaidItemStrikesDurationDetailsTypeCollection^ get ();
    void set (MaximumUnpaidItemStrikesDurationDetailsTypeCollection^ value);
}


MaximumUnpaidItemStrikesInfoDetailsType Constructor

MaximumUnpaidItemStrikesInfoDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoDetailsType ► MaximumUnpaidItemStrikesInfoDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesInfoDetailsType()
Public Sub New
public:
MaximumUnpaidItemStrikesInfoDetailsType()


MaximumUnpaidItemStrikesInfoType Class

MaximumUnpaidItemStrikesInfoType Class
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaximumUnpaidItemStrikesInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaximumUnpaidItemStrikesInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaximumUnpaidItemStrikesInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaximumUnpaidItemStrikesInfoType()()()() |
 | Any |
 | Count |
 | CountSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Period |
 | PeriodSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaximumUnpaidItemStrikesInfoType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Count Property

Count Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoType ► Count
Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; set; }
Public Property Count As Integer
    Get
    Set
public:
property int Count {
    int get ();
    void set (int value);
}


CountSpecified Property

CountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoType ► CountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CountSpecified { get; set; }
Public Property CountSpecified As Boolean
    Get
    Set
public:
property bool CountSpecified {
    bool get ();
    void set (bool value);
}


MaximumUnpaidItemStrikesInfoType Constructor

MaximumUnpaidItemStrikesInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoType ► MaximumUnpaidItemStrikesInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesInfoType()
Public Sub New
public:
MaximumUnpaidItemStrikesInfoType()


Period Property

Period Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoType ► Period
Declaration Syntax
C# Visual Basic Visual C++
public PeriodCodeType Period { get; set; }
Public Property Period As PeriodCodeType
    Get
    Set
public:
property PeriodCodeType Period {
    PeriodCodeType get ();
    void set (PeriodCodeType value);
}


PeriodSpecified Property

PeriodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesInfoType ► PeriodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PeriodSpecified { get; set; }
Public Property PeriodSpecified As Boolean
    Get
    Set
public:
property bool PeriodSpecified {
    bool get ();
    void set (bool value);
}


MaxItemCompatibilityDefinitionType Class

MaxItemCompatibilityDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► MaxItemCompatibilityDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MaxItemCompatibilityDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MaxItemCompatibilityDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MaxItemCompatibilityDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MaxItemCompatibilityDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MaxItemCompatibilityDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MaxItemCompatibilityDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MaxItemCompatibilityDefinitionType Constructor

MaxItemCompatibilityDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► MaxItemCompatibilityDefinitionType ► MaxItemCompatibilityDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MaxItemCompatibilityDefinitionType()
Public Sub New
public:
MaxItemCompatibilityDefinitionType()


MeasurementSystemCodeType Enumeration

MeasurementSystemCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► MeasurementSystemCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum MeasurementSystemCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration MeasurementSystemCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class MeasurementSystemCodeType
Members
Member | Description
English |
Metric |
Remarks


MeasureType Class

MeasureType Class
Namespaces ► eBay.Service.Core.Soap ► MeasureType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MeasureType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MeasureType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MeasureType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MeasureType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | measurementSystem |
 | measurementSystemSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | unit |
 | Value |
Remarks
Inheritance Hierarchy
Object
MeasureType


measurementSystem Property

measurementSystem Property
Namespaces ► eBay.Service.Core.Soap ► MeasureType ► measurementSystem
Declaration Syntax
C# Visual Basic Visual C++
public MeasurementSystemCodeType measurementSystem { get; set; }
Public Property measurementSystem As MeasurementSystemCodeType
    Get
    Set
public:
property MeasurementSystemCodeType measurementSystem {
    MeasurementSystemCodeType get ();
    void set (MeasurementSystemCodeType value);
}


measurementSystemSpecified Property

measurementSystemSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MeasureType ► measurementSystemSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool measurementSystemSpecified { get; set; }
Public Property measurementSystemSpecified As Boolean
    Get
    Set
public:
property bool measurementSystemSpecified {
    bool get ();
    void set (bool value);
}


MeasureType Constructor

MeasureType Constructor
Namespaces ► eBay.Service.Core.Soap ► MeasureType ► MeasureType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType()
Public Sub New
public:
MeasureType()


unit Property

unit Property
Namespaces ► eBay.Service.Core.Soap ► MeasureType ► unit
Declaration Syntax
C# Visual Basic Visual C++
public string unit { get; set; }
Public Property unit As String
    Get
    Set
public:
property String^ unit {
    String^ get ();
    void set (String^ value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► MeasureType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public decimal Value { get; set; }
Public Property Value As Decimal
    Get
    Set
public:
property Decimal Value {
    Decimal get ();
    void set (Decimal value);
}


MemberMessageExchangeType Class

MemberMessageExchangeType Class
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MemberMessageExchangeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MemberMessageExchangeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MemberMessageExchangeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MemberMessageExchangeType()()()() |
 | Any |
 | CreationDate |
 | CreationDateSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Item |
 | LastModifiedDate |
 | LastModifiedDateSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageMedia |
 | MessageStatus |
 | MessageStatusSpecified |
 | Question |
 | Response |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MemberMessageExchangeType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CreationDate Property

CreationDate Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► CreationDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreationDate { get; set; }
Public Property CreationDate As DateTime
    Get
    Set
public:
property DateTime CreationDate {
    DateTime get ();
    void set (DateTime value);
}


CreationDateSpecified Property

CreationDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► CreationDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreationDateSpecified { get; set; }
Public Property CreationDateSpecified As Boolean
    Get
    Set
public:
property bool CreationDateSpecified {
    bool get ();
    void set (bool value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


LastModifiedDate Property

LastModifiedDate Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► LastModifiedDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastModifiedDate { get; set; }
Public Property LastModifiedDate As DateTime
    Get
    Set
public:
property DateTime LastModifiedDate {
    DateTime get ();
    void set (DateTime value);
}


LastModifiedDateSpecified Property

LastModifiedDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► LastModifiedDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastModifiedDateSpecified { get; set; }
Public Property LastModifiedDateSpecified As Boolean
    Get
    Set
public:
property bool LastModifiedDateSpecified {
    bool get ();
    void set (bool value);
}


MemberMessageExchangeType Constructor

MemberMessageExchangeType Constructor
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► MemberMessageExchangeType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeType()
Public Sub New
public:
MemberMessageExchangeType()


MessageMedia Property

MessageMedia Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► MessageMedia
Declaration Syntax
C# Visual Basic Visual C++
public MessageMediaTypeCollection MessageMedia { get; set; }
Public Property MessageMedia As MessageMediaTypeCollection
    Get
    Set
public:
property MessageMediaTypeCollection^ MessageMedia {
    MessageMediaTypeCollection^ get ();
    void set (MessageMediaTypeCollection^ value);
}


MessageStatus Property

MessageStatus Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► MessageStatus
Declaration Syntax
C# Visual Basic Visual C++
public MessageStatusTypeCodeType MessageStatus { get; set; }
Public Property MessageStatus As MessageStatusTypeCodeType
    Get
    Set
public:
property MessageStatusTypeCodeType MessageStatus {
    MessageStatusTypeCodeType get ();
    void set (MessageStatusTypeCodeType value);
}


MessageStatusSpecified Property

MessageStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► MessageStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageStatusSpecified { get; set; }
Public Property MessageStatusSpecified As Boolean
    Get
    Set
public:
property bool MessageStatusSpecified {
    bool get ();
    void set (bool value);
}


Question Property

Question Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► Question
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageType Question { get; set; }
Public Property Question As MemberMessageType
    Get
    Set
public:
property MemberMessageType^ Question {
    MemberMessageType^ get ();
    void set (MemberMessageType^ value);
}


Response Property

Response Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeType ► Response
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection Response { get; set; }
Public Property Response As StringCollection
    Get
    Set
public:
property StringCollection^ Response {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


MemberMessageExchangeTypeCollection Class

MemberMessageExchangeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class MemberMessageExchangeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class MemberMessageExchangeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class MemberMessageExchangeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MemberMessageExchangeTypeCollection()()()() |
 | MemberMessageExchangeTypeCollection(array<MemberMessageExchangeType>[]()[][]) |
 | MemberMessageExchangeTypeCollection(MemberMessageExchangeTypeCollection) |
 | Add(MemberMessageExchangeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<MemberMessageExchangeType>[]()[][]) |
 | AddRange(MemberMessageExchangeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(MemberMessageExchangeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<MemberMessageExchangeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(MemberMessageExchangeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, MemberMessageExchangeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(MemberMessageExchangeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | MemberMessageExchangeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► Add(MemberMessageExchangeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MemberMessageExchangeType item
)
Public Function Add ( _
    item As MemberMessageExchangeType _
) As Integer
public:
int Add(
    MemberMessageExchangeType^ item
)
Parameters
item (MemberMessageExchangeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<MemberMessageExchangeType>[]()[][]) |
 | AddRange(MemberMessageExchangeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► AddRange(array<MemberMessageExchangeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MemberMessageExchangeType[] items
)
Public Sub AddRange ( _
    items As MemberMessageExchangeType() _
)
public:
void AddRange(
    array<MemberMessageExchangeType^>^ items
)
Parameters
items (array< MemberMessageExchangeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► AddRange(MemberMessageExchangeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MemberMessageExchangeTypeCollection items
)
Public Sub AddRange ( _
    items As MemberMessageExchangeTypeCollection _
)
public:
void AddRange(
    MemberMessageExchangeTypeCollection^ items
)
Parameters
items (MemberMessageExchangeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► Contains(MemberMessageExchangeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    MemberMessageExchangeType item
)
Public Function Contains ( _
    item As MemberMessageExchangeType _
) As Boolean
public:
bool Contains(
    MemberMessageExchangeType^ item
)
Parameters
item (MemberMessageExchangeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► CopyTo(array<MemberMessageExchangeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MemberMessageExchangeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As MemberMessageExchangeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<MemberMessageExchangeType^>^ items,
    int index
)
Parameters
items (array< MemberMessageExchangeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► IndexOf(MemberMessageExchangeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    MemberMessageExchangeType item
)
Public Function IndexOf ( _
    item As MemberMessageExchangeType _
) As Integer
public:
int IndexOf(
    MemberMessageExchangeType^ item
)
Parameters
item (MemberMessageExchangeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► Insert(Int32, MemberMessageExchangeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    MemberMessageExchangeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As MemberMessageExchangeType _
)
public:
void Insert(
    int index,
    MemberMessageExchangeType^ item
)
Parameters
index (Int32)
item (MemberMessageExchangeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MemberMessageExchangeType
    Get
    Set
public:
property MemberMessageExchangeType^ default[int index] {
    MemberMessageExchangeType^ get (int index);
    void set (int index, MemberMessageExchangeType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As MemberMessageExchangeType
public:
MemberMessageExchangeType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


MemberMessageExchangeTypeCollection Constructor

MemberMessageExchangeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► MemberMessageExchangeTypeCollection()()()()
Members
Icon | Member | Description
 | MemberMessageExchangeTypeCollection()()()() |
 | MemberMessageExchangeTypeCollection(array<MemberMessageExchangeType>[]()[][]) |
 | MemberMessageExchangeTypeCollection(MemberMessageExchangeTypeCollection) |


MemberMessageExchangeTypeCollection Constructor

MemberMessageExchangeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► MemberMessageExchangeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeTypeCollection()
Public Sub New
public:
MemberMessageExchangeTypeCollection()


MemberMessageExchangeTypeCollection Constructor (items)

MemberMessageExchangeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► MemberMessageExchangeTypeCollection(array<MemberMessageExchangeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeTypeCollection(
    MemberMessageExchangeType[] items
)
Public Sub New ( _
    items As MemberMessageExchangeType() _
)
public:
MemberMessageExchangeTypeCollection(
    array<MemberMessageExchangeType^>^ items
)
Parameters
items (array< MemberMessageExchangeType >[]()[][])


MemberMessageExchangeTypeCollection Constructor (items)

MemberMessageExchangeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► MemberMessageExchangeTypeCollection(MemberMessageExchangeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeTypeCollection(
    MemberMessageExchangeTypeCollection items
)
Public Sub New ( _
    items As MemberMessageExchangeTypeCollection _
)
public:
MemberMessageExchangeTypeCollection(
    MemberMessageExchangeTypeCollection^ items
)
Parameters
items (MemberMessageExchangeTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► Remove(MemberMessageExchangeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    MemberMessageExchangeType item
)
Public Sub Remove ( _
    item As MemberMessageExchangeType _
)
public:
void Remove(
    MemberMessageExchangeType^ item
)
Parameters
item (MemberMessageExchangeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageExchangeType[] ToArray()
Public Function ToArray As MemberMessageExchangeType()
public:
array<MemberMessageExchangeType^>^ ToArray()
Return Value


MemberMessageType Class

MemberMessageType Class
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MemberMessageType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MemberMessageType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MemberMessageType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MemberMessageType()()()() |
 | Any |
 | Body |
 | DisplayToPublic |
 | DisplayToPublicSpecified |
 | EmailCopyToSender |
 | EmailCopyToSenderSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HideSendersEmailAddress |
 | HideSendersEmailAddressSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID |
 | MessageMedia |
 | MessageType |
 | MessageTypeSpecified |
 | ParentMessageID |
 | QuestionType |
 | QuestionTypeSpecified |
 | RecipientID |
 | SenderEmail |
 | SenderID |
 | Subject |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MemberMessageType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Body Property

Body Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► Body
Declaration Syntax
C# Visual Basic Visual C++
public string Body { get; set; }
Public Property Body As String
    Get
    Set
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}


DisplayToPublic Property

DisplayToPublic Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► DisplayToPublic
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayToPublic { get; set; }
Public Property DisplayToPublic As Boolean
    Get
    Set
public:
property bool DisplayToPublic {
    bool get ();
    void set (bool value);
}


DisplayToPublicSpecified Property

DisplayToPublicSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► DisplayToPublicSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayToPublicSpecified { get; set; }
Public Property DisplayToPublicSpecified As Boolean
    Get
    Set
public:
property bool DisplayToPublicSpecified {
    bool get ();
    void set (bool value);
}


EmailCopyToSender Property

EmailCopyToSender Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► EmailCopyToSender
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailCopyToSender { get; set; }
Public Property EmailCopyToSender As Boolean
    Get
    Set
public:
property bool EmailCopyToSender {
    bool get ();
    void set (bool value);
}


EmailCopyToSenderSpecified Property

EmailCopyToSenderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► EmailCopyToSenderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailCopyToSenderSpecified { get; set; }
Public Property EmailCopyToSenderSpecified As Boolean
    Get
    Set
public:
property bool EmailCopyToSenderSpecified {
    bool get ();
    void set (bool value);
}


HideSendersEmailAddress Property

HideSendersEmailAddress Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► HideSendersEmailAddress
Declaration Syntax
C# Visual Basic Visual C++
public bool HideSendersEmailAddress { get; set; }
Public Property HideSendersEmailAddress As Boolean
    Get
    Set
public:
property bool HideSendersEmailAddress {
    bool get ();
    void set (bool value);
}


HideSendersEmailAddressSpecified Property

HideSendersEmailAddressSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► HideSendersEmailAddressSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HideSendersEmailAddressSpecified { get; set; }
Public Property HideSendersEmailAddressSpecified As Boolean
    Get
    Set
public:
property bool HideSendersEmailAddressSpecified {
    bool get ();
    void set (bool value);
}


MemberMessageType Constructor

MemberMessageType Constructor
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► MemberMessageType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MemberMessageType()
Public Sub New
public:
MemberMessageType()


MessageID Property

MessageID Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► MessageID
Declaration Syntax
C# Visual Basic Visual C++
public string MessageID { get; set; }
Public Property MessageID As String
    Get
    Set
public:
property String^ MessageID {
    String^ get ();
    void set (String^ value);
}


MessageMedia Property

MessageMedia Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► MessageMedia
Declaration Syntax
C# Visual Basic Visual C++
public MessageMediaTypeCollection MessageMedia { get; set; }
Public Property MessageMedia As MessageMediaTypeCollection
    Get
    Set
public:
property MessageMediaTypeCollection^ MessageMedia {
    MessageMediaTypeCollection^ get ();
    void set (MessageMediaTypeCollection^ value);
}


MessageType Property

MessageType Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► MessageType
Declaration Syntax
C# Visual Basic Visual C++
public MessageTypeCodeType MessageType { get; set; }
Public Property MessageType As MessageTypeCodeType
    Get
    Set
public:
property MessageTypeCodeType MessageType {
    MessageTypeCodeType get ();
    void set (MessageTypeCodeType value);
}


MessageTypeSpecified Property

MessageTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► MessageTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageTypeSpecified { get; set; }
Public Property MessageTypeSpecified As Boolean
    Get
    Set
public:
property bool MessageTypeSpecified {
    bool get ();
    void set (bool value);
}


ParentMessageID Property

ParentMessageID Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► ParentMessageID
Declaration Syntax
C# Visual Basic Visual C++
public string ParentMessageID { get; set; }
Public Property ParentMessageID As String
    Get
    Set
public:
property String^ ParentMessageID {
    String^ get ();
    void set (String^ value);
}


QuestionType Property

QuestionType Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► QuestionType
Declaration Syntax
C# Visual Basic Visual C++
public QuestionTypeCodeType QuestionType { get; set; }
Public Property QuestionType As QuestionTypeCodeType
    Get
    Set
public:
property QuestionTypeCodeType QuestionType {
    QuestionTypeCodeType get ();
    void set (QuestionTypeCodeType value);
}


QuestionTypeSpecified Property

QuestionTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► QuestionTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuestionTypeSpecified { get; set; }
Public Property QuestionTypeSpecified As Boolean
    Get
    Set
public:
property bool QuestionTypeSpecified {
    bool get ();
    void set (bool value);
}


RecipientID Property

RecipientID Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► RecipientID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection RecipientID { get; set; }
Public Property RecipientID As StringCollection
    Get
    Set
public:
property StringCollection^ RecipientID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


SenderEmail Property

SenderEmail Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► SenderEmail
Declaration Syntax
C# Visual Basic Visual C++
public string SenderEmail { get; set; }
Public Property SenderEmail As String
    Get
    Set
public:
property String^ SenderEmail {
    String^ get ();
    void set (String^ value);
}


SenderID Property

SenderID Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► SenderID
Declaration Syntax
C# Visual Basic Visual C++
public string SenderID { get; set; }
Public Property SenderID As String
    Get
    Set
public:
property String^ SenderID {
    String^ get ();
    void set (String^ value);
}


Subject Property

Subject Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageType ► Subject
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}


MerchandizingPrefCodeType Enumeration

MerchandizingPrefCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► MerchandizingPrefCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum MerchandizingPrefCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration MerchandizingPrefCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class MerchandizingPrefCodeType
Members
Member | Description
OptIn |
OptOut |
CustomCode |
Remarks


MerchDisplayCodeType Enumeration

MerchDisplayCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► MerchDisplayCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum MerchDisplayCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration MerchDisplayCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class MerchDisplayCodeType
Members
Member | Description
DefaultTheme |
StoreTheme |
CustomCode |
Remarks


MessageMediaType Class

MessageMediaType Class
Namespaces ► eBay.Service.Core.Soap ► MessageMediaType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MessageMediaType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MessageMediaType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MessageMediaType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MessageMediaType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MediaName |
 | MediaURL |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MessageMediaType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MediaName Property

MediaName Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaType ► MediaName
Declaration Syntax
C# Visual Basic Visual C++
public string MediaName { get; set; }
Public Property MediaName As String
    Get
    Set
public:
property String^ MediaName {
    String^ get ();
    void set (String^ value);
}


MediaURL Property

MediaURL Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaType ► MediaURL
Declaration Syntax
C# Visual Basic Visual C++
public string MediaURL { get; set; }
Public Property MediaURL As String
    Get
    Set
public:
property String^ MediaURL {
    String^ get ();
    void set (String^ value);
}


MessageMediaType Constructor

MessageMediaType Constructor
Namespaces ► eBay.Service.Core.Soap ► MessageMediaType ► MessageMediaType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MessageMediaType()
Public Sub New
public:
MessageMediaType()


MessageMediaTypeCollection Class

MessageMediaTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class MessageMediaTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class MessageMediaTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class MessageMediaTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MessageMediaTypeCollection()()()() |
 | MessageMediaTypeCollection(array<MessageMediaType>[]()[][]) |
 | MessageMediaTypeCollection(MessageMediaTypeCollection) |
 | Add(MessageMediaType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<MessageMediaType>[]()[][]) |
 | AddRange(MessageMediaTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(MessageMediaType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<MessageMediaType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(MessageMediaType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, MessageMediaType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(MessageMediaType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | MessageMediaTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► Add(MessageMediaType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MessageMediaType item
)
Public Function Add ( _
    item As MessageMediaType _
) As Integer
public:
int Add(
    MessageMediaType^ item
)
Parameters
item (MessageMediaType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<MessageMediaType>[]()[][]) |
 | AddRange(MessageMediaTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► AddRange(array<MessageMediaType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MessageMediaType[] items
)
Public Sub AddRange ( _
    items As MessageMediaType() _
)
public:
void AddRange(
    array<MessageMediaType^>^ items
)
Parameters
items (array< MessageMediaType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► AddRange(MessageMediaTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MessageMediaTypeCollection items
)
Public Sub AddRange ( _
    items As MessageMediaTypeCollection _
)
public:
void AddRange(
    MessageMediaTypeCollection^ items
)
Parameters
items (MessageMediaTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► Contains(MessageMediaType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    MessageMediaType item
)
Public Function Contains ( _
    item As MessageMediaType _
) As Boolean
public:
bool Contains(
    MessageMediaType^ item
)
Parameters
item (MessageMediaType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► CopyTo(array<MessageMediaType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MessageMediaType[] items,
    int index
)
Public Sub CopyTo ( _
    items As MessageMediaType(), _
    index As Integer _
)
public:
void CopyTo(
    array<MessageMediaType^>^ items,
    int index
)
Parameters
items (array< MessageMediaType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► IndexOf(MessageMediaType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    MessageMediaType item
)
Public Function IndexOf ( _
    item As MessageMediaType _
) As Integer
public:
int IndexOf(
    MessageMediaType^ item
)
Parameters
item (MessageMediaType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► Insert(Int32, MessageMediaType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    MessageMediaType item
)
Public Sub Insert ( _
    index As Integer, _
    item As MessageMediaType _
)
public:
void Insert(
    int index,
    MessageMediaType^ item
)
Parameters
index (Int32)
item (MessageMediaType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MessageMediaType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MessageMediaType
    Get
    Set
public:
property MessageMediaType^ default[int index] {
    MessageMediaType^ get (int index);
    void set (int index, MessageMediaType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MessageMediaType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As MessageMediaType
public:
MessageMediaType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


MessageMediaTypeCollection Constructor

MessageMediaTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► MessageMediaTypeCollection()()()()
Members
Icon | Member | Description
 | MessageMediaTypeCollection()()()() |
 | MessageMediaTypeCollection(array<MessageMediaType>[]()[][]) |
 | MessageMediaTypeCollection(MessageMediaTypeCollection) |


MessageMediaTypeCollection Constructor

MessageMediaTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► MessageMediaTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MessageMediaTypeCollection()
Public Sub New
public:
MessageMediaTypeCollection()


MessageMediaTypeCollection Constructor (items)

MessageMediaTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► MessageMediaTypeCollection(array<MessageMediaType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public MessageMediaTypeCollection(
    MessageMediaType[] items
)
Public Sub New ( _
    items As MessageMediaType() _
)
public:
MessageMediaTypeCollection(
    array<MessageMediaType^>^ items
)
Parameters
items (array< MessageMediaType >[]()[][])


MessageMediaTypeCollection Constructor (items)

MessageMediaTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► MessageMediaTypeCollection(MessageMediaTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MessageMediaTypeCollection(
    MessageMediaTypeCollection items
)
Public Sub New ( _
    items As MessageMediaTypeCollection _
)
public:
MessageMediaTypeCollection(
    MessageMediaTypeCollection^ items
)
Parameters
items (MessageMediaTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► Remove(MessageMediaType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    MessageMediaType item
)
Public Sub Remove ( _
    item As MessageMediaType _
)
public:
void Remove(
    MessageMediaType^ item
)
Parameters
item (MessageMediaType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MessageMediaType[] ToArray()
Public Function ToArray As MessageMediaType()
public:
array<MessageMediaType^>^ ToArray()
Return Value


MessageStatusTypeCodeType Enumeration

MessageStatusTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► MessageStatusTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum MessageStatusTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration MessageStatusTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class MessageStatusTypeCodeType
Members
Member | Description
Answered |
Unanswered |
CustomCode |
Remarks


MessageTypeCodeType Enumeration

MessageTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► MessageTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum MessageTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration MessageTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class MessageTypeCodeType
Members
Member | Description
AskSellerQuestion |
ResponseToASQQuestion |
ContactEbayMember |
ContactTransactionPartner |
ResponseToContacteBayMember |
ContacteBayMemberViaCommunityLink |
CustomCode |
All |
ContactMyBidder |
ContacteBayMemberViaAnonymousEmail |
ClassifiedsContactSeller |
ClassifiedsBestOffer |
Remarks


MetadataType Class

MetadataType Class
Namespaces ► eBay.Service.Core.Soap ► MetadataType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MetadataType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MetadataType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MetadataType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MetadataType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
 | Value |
Remarks
Inheritance Hierarchy
Object
MetadataType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MetadataType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MetadataType Constructor

MetadataType Constructor
Namespaces ► eBay.Service.Core.Soap ► MetadataType ► MetadataType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MetadataType()
Public Sub New
public:
MetadataType()


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► MetadataType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► MetadataType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection Value { get; set; }
Public Property Value As StringCollection
    Get
    Set
public:
property StringCollection^ Value {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


MetadataTypeCollection Class

MetadataTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class MetadataTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class MetadataTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class MetadataTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MetadataTypeCollection()()()() |
 | MetadataTypeCollection(array<MetadataType>[]()[][]) |
 | MetadataTypeCollection(MetadataTypeCollection) |
 | Add(MetadataType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<MetadataType>[]()[][]) |
 | AddRange(MetadataTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(MetadataType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<MetadataType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(MetadataType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, MetadataType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(MetadataType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | MetadataTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► Add(MetadataType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MetadataType item
)
Public Function Add ( _
    item As MetadataType _
) As Integer
public:
int Add(
    MetadataType^ item
)
Parameters
item (MetadataType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<MetadataType>[]()[][]) |
 | AddRange(MetadataTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► AddRange(array<MetadataType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MetadataType[] items
)
Public Sub AddRange ( _
    items As MetadataType() _
)
public:
void AddRange(
    array<MetadataType^>^ items
)
Parameters
items (array< MetadataType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► AddRange(MetadataTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MetadataTypeCollection items
)
Public Sub AddRange ( _
    items As MetadataTypeCollection _
)
public:
void AddRange(
    MetadataTypeCollection^ items
)
Parameters
items (MetadataTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► Contains(MetadataType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    MetadataType item
)
Public Function Contains ( _
    item As MetadataType _
) As Boolean
public:
bool Contains(
    MetadataType^ item
)
Parameters
item (MetadataType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► CopyTo(array<MetadataType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MetadataType[] items,
    int index
)
Public Sub CopyTo ( _
    items As MetadataType(), _
    index As Integer _
)
public:
void CopyTo(
    array<MetadataType^>^ items,
    int index
)
Parameters
items (array< MetadataType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► IndexOf(MetadataType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    MetadataType item
)
Public Function IndexOf ( _
    item As MetadataType _
) As Integer
public:
int IndexOf(
    MetadataType^ item
)
Parameters
item (MetadataType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► Insert(Int32, MetadataType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    MetadataType item
)
Public Sub Insert ( _
    index As Integer, _
    item As MetadataType _
)
public:
void Insert(
    int index,
    MetadataType^ item
)
Parameters
index (Int32)
item (MetadataType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MetadataType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MetadataType
    Get
    Set
public:
property MetadataType^ default[int index] {
    MetadataType^ get (int index);
    void set (int index, MetadataType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MetadataType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As MetadataType
public:
MetadataType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


MetadataTypeCollection Constructor

MetadataTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► MetadataTypeCollection()()()()
Members
Icon | Member | Description
 | MetadataTypeCollection()()()() |
 | MetadataTypeCollection(array<MetadataType>[]()[][]) |
 | MetadataTypeCollection(MetadataTypeCollection) |


MetadataTypeCollection Constructor

MetadataTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► MetadataTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MetadataTypeCollection()
Public Sub New
public:
MetadataTypeCollection()


MetadataTypeCollection Constructor (items)

MetadataTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► MetadataTypeCollection(array<MetadataType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public MetadataTypeCollection(
    MetadataType[] items
)
Public Sub New ( _
    items As MetadataType() _
)
public:
MetadataTypeCollection(
    array<MetadataType^>^ items
)
Parameters
items (array< MetadataType >[]()[][])


MetadataTypeCollection Constructor (items)

MetadataTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► MetadataTypeCollection(MetadataTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MetadataTypeCollection(
    MetadataTypeCollection items
)
Public Sub New ( _
    items As MetadataTypeCollection _
)
public:
MetadataTypeCollection(
    MetadataTypeCollection^ items
)
Parameters
items (MetadataTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► Remove(MetadataType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    MetadataType item
)
Public Sub Remove ( _
    item As MetadataType _
)
public:
void Remove(
    MetadataType^ item
)
Parameters
item (MetadataType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MetadataType[] ToArray()
Public Function ToArray As MetadataType()
public:
array<MetadataType^>^ ToArray()
Return Value


MinimumAdvertisedPriceExposureCodeType Enumeration

MinimumAdvertisedPriceExposureCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► MinimumAdvertisedPriceExposureCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum MinimumAdvertisedPriceExposureCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration MinimumAdvertisedPriceExposureCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class MinimumAdvertisedPriceExposureCodeType
Members
Member | Description
PreCheckout |
DuringCheckout |
None |
CustomCode |
Remarks


MinimumFeedbackScoreDetailsType Class

MinimumFeedbackScoreDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► MinimumFeedbackScoreDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MinimumFeedbackScoreDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MinimumFeedbackScoreDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MinimumFeedbackScoreDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MinimumFeedbackScoreDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | FeedbackScore |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MinimumFeedbackScoreDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MinimumFeedbackScoreDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FeedbackScore Property

FeedbackScore Property
Namespaces ► eBay.Service.Core.Soap ► MinimumFeedbackScoreDetailsType ► FeedbackScore
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection FeedbackScore { get; set; }
Public Property FeedbackScore As Int32Collection
    Get
    Set
public:
property Int32Collection^ FeedbackScore {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


MinimumFeedbackScoreDetailsType Constructor

MinimumFeedbackScoreDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► MinimumFeedbackScoreDetailsType ► MinimumFeedbackScoreDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MinimumFeedbackScoreDetailsType()
Public Sub New
public:
MinimumFeedbackScoreDetailsType()


MinimumReservePriceDefinitionType Class

MinimumReservePriceDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► MinimumReservePriceDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MinimumReservePriceDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MinimumReservePriceDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MinimumReservePriceDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MinimumReservePriceDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MinimumReservePriceDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MinimumReservePriceDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MinimumReservePriceDefinitionType Constructor

MinimumReservePriceDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► MinimumReservePriceDefinitionType ► MinimumReservePriceDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MinimumReservePriceDefinitionType()
Public Sub New
public:
MinimumReservePriceDefinitionType()


MinItemCompatibilityDefinitionType Class

MinItemCompatibilityDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► MinItemCompatibilityDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MinItemCompatibilityDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MinItemCompatibilityDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MinItemCompatibilityDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MinItemCompatibilityDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MinItemCompatibilityDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MinItemCompatibilityDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MinItemCompatibilityDefinitionType Constructor

MinItemCompatibilityDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► MinItemCompatibilityDefinitionType ► MinItemCompatibilityDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MinItemCompatibilityDefinitionType()
Public Sub New
public:
MinItemCompatibilityDefinitionType()


MismatchTypeCodeType Enumeration

MismatchTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► MismatchTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum MismatchTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration MismatchTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class MismatchTypeCodeType
Members
Member | Description
OverPayment |
UnderPayment |
CustomCode |
Remarks


ModifyActionCodeType Enumeration

ModifyActionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ModifyActionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ModifyActionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ModifyActionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ModifyActionCodeType
Members
Member | Description
Add |
Delete |
Update |
CustomCode |
Remarks


ModifyNameType Class

ModifyNameType Class
Namespaces ► eBay.Service.Core.Soap ► ModifyNameType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ModifyNameType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ModifyNameType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ModifyNameType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ModifyNameType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | NewName |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ModifyNameType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ModifyNameType Constructor

ModifyNameType Constructor
Namespaces ► eBay.Service.Core.Soap ► ModifyNameType ► ModifyNameType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ModifyNameType()
Public Sub New
public:
ModifyNameType()


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


NewName Property

NewName Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameType ► NewName
Declaration Syntax
C# Visual Basic Visual C++
public string NewName { get; set; }
Public Property NewName As String
    Get
    Set
public:
property String^ NewName {
    String^ get ();
    void set (String^ value);
}


ModifyNameTypeCollection Class

ModifyNameTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ModifyNameTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ModifyNameTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ModifyNameTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ModifyNameTypeCollection()()()() |
 | ModifyNameTypeCollection(array<ModifyNameType>[]()[][]) |
 | ModifyNameTypeCollection(ModifyNameTypeCollection) |
 | Add(ModifyNameType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ModifyNameType>[]()[][]) |
 | AddRange(ModifyNameTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ModifyNameType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ModifyNameType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ModifyNameType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ModifyNameType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ModifyNameType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ModifyNameTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► Add(ModifyNameType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ModifyNameType item
)
Public Function Add ( _
    item As ModifyNameType _
) As Integer
public:
int Add(
    ModifyNameType^ item
)
Parameters
item (ModifyNameType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ModifyNameType>[]()[][]) |
 | AddRange(ModifyNameTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► AddRange(array<ModifyNameType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ModifyNameType[] items
)
Public Sub AddRange ( _
    items As ModifyNameType() _
)
public:
void AddRange(
    array<ModifyNameType^>^ items
)
Parameters
items (array< ModifyNameType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► AddRange(ModifyNameTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ModifyNameTypeCollection items
)
Public Sub AddRange ( _
    items As ModifyNameTypeCollection _
)
public:
void AddRange(
    ModifyNameTypeCollection^ items
)
Parameters
items (ModifyNameTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► Contains(ModifyNameType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ModifyNameType item
)
Public Function Contains ( _
    item As ModifyNameType _
) As Boolean
public:
bool Contains(
    ModifyNameType^ item
)
Parameters
item (ModifyNameType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► CopyTo(array<ModifyNameType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ModifyNameType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ModifyNameType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ModifyNameType^>^ items,
    int index
)
Parameters
items (array< ModifyNameType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► IndexOf(ModifyNameType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ModifyNameType item
)
Public Function IndexOf ( _
    item As ModifyNameType _
) As Integer
public:
int IndexOf(
    ModifyNameType^ item
)
Parameters
item (ModifyNameType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► Insert(Int32, ModifyNameType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ModifyNameType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ModifyNameType _
)
public:
void Insert(
    int index,
    ModifyNameType^ item
)
Parameters
index (Int32)
item (ModifyNameType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ModifyNameType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ModifyNameType
    Get
    Set
public:
property ModifyNameType^ default[int index] {
    ModifyNameType^ get (int index);
    void set (int index, ModifyNameType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ModifyNameType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ModifyNameType
public:
ModifyNameType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ModifyNameTypeCollection Constructor

ModifyNameTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► ModifyNameTypeCollection()()()()
Members
Icon | Member | Description
 | ModifyNameTypeCollection()()()() |
 | ModifyNameTypeCollection(array<ModifyNameType>[]()[][]) |
 | ModifyNameTypeCollection(ModifyNameTypeCollection) |


ModifyNameTypeCollection Constructor

ModifyNameTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► ModifyNameTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ModifyNameTypeCollection()
Public Sub New
public:
ModifyNameTypeCollection()


ModifyNameTypeCollection Constructor (items)

ModifyNameTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► ModifyNameTypeCollection(array<ModifyNameType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ModifyNameTypeCollection(
    ModifyNameType[] items
)
Public Sub New ( _
    items As ModifyNameType() _
)
public:
ModifyNameTypeCollection(
    array<ModifyNameType^>^ items
)
Parameters
items (array< ModifyNameType >[]()[][])


ModifyNameTypeCollection Constructor (items)

ModifyNameTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► ModifyNameTypeCollection(ModifyNameTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ModifyNameTypeCollection(
    ModifyNameTypeCollection items
)
Public Sub New ( _
    items As ModifyNameTypeCollection _
)
public:
ModifyNameTypeCollection(
    ModifyNameTypeCollection^ items
)
Parameters
items (ModifyNameTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► Remove(ModifyNameType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ModifyNameType item
)
Public Sub Remove ( _
    item As ModifyNameType _
)
public:
void Remove(
    ModifyNameType^ item
)
Parameters
item (ModifyNameType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ModifyNameType[] ToArray()
Public Function ToArray As ModifyNameType()
public:
array<ModifyNameType^>^ ToArray()
Return Value


MoveSellingManagerInventoryFolderRequestType Class

MoveSellingManagerInventoryFolderRequestType Class
Namespaces ► eBay.Service.Core.Soap ► MoveSellingManagerInventoryFolderRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MoveSellingManagerInventoryFolderRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MoveSellingManagerInventoryFolderRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MoveSellingManagerInventoryFolderRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveSellingManagerInventoryFolderRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID |
 | FolderIDSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | NewParentFolderID |
 | NewParentFolderIDSpecified |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | MoveSellingManagerInventoryFolderRequestType


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► MoveSellingManagerInventoryFolderRequestType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MoveSellingManagerInventoryFolderRequestType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


MoveSellingManagerInventoryFolderRequestType Constructor

MoveSellingManagerInventoryFolderRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► MoveSellingManagerInventoryFolderRequestType ► MoveSellingManagerInventoryFolderRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MoveSellingManagerInventoryFolderRequestType()
Public Sub New
public:
MoveSellingManagerInventoryFolderRequestType()


NewParentFolderID Property

NewParentFolderID Property
Namespaces ► eBay.Service.Core.Soap ► MoveSellingManagerInventoryFolderRequestType ► NewParentFolderID
Declaration Syntax
C# Visual Basic Visual C++
public long NewParentFolderID { get; set; }
Public Property NewParentFolderID As Long
    Get
    Set
public:
property long long NewParentFolderID {
    long long get ();
    void set (long long value);
}


NewParentFolderIDSpecified Property

NewParentFolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MoveSellingManagerInventoryFolderRequestType ► NewParentFolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewParentFolderIDSpecified { get; set; }
Public Property NewParentFolderIDSpecified As Boolean
    Get
    Set
public:
property bool NewParentFolderIDSpecified {
    bool get ();
    void set (bool value);
}


MoveSellingManagerInventoryFolderResponseType Class

MoveSellingManagerInventoryFolderResponseType Class
Namespaces ► eBay.Service.Core.Soap ► MoveSellingManagerInventoryFolderResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MoveSellingManagerInventoryFolderResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MoveSellingManagerInventoryFolderResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MoveSellingManagerInventoryFolderResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MoveSellingManagerInventoryFolderResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | MoveSellingManagerInventoryFolderResponseType


MoveSellingManagerInventoryFolderResponseType Constructor

MoveSellingManagerInventoryFolderResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► MoveSellingManagerInventoryFolderResponseType ► MoveSellingManagerInventoryFolderResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MoveSellingManagerInventoryFolderResponseType()
Public Sub New
public:
MoveSellingManagerInventoryFolderResponseType()


MultiLegShipmentType Class

MultiLegShipmentType Class
Namespaces ► eBay.Service.Core.Soap ► MultiLegShipmentType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MultiLegShipmentType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MultiLegShipmentType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MultiLegShipmentType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiLegShipmentType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingServiceDetails |
 | ShippingTimeMax |
 | ShippingTimeMaxSpecified |
 | ShippingTimeMin |
 | ShippingTimeMinSpecified |
 | ShipToAddress |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MultiLegShipmentType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShipmentType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MultiLegShipmentType Constructor

MultiLegShipmentType Constructor
Namespaces ► eBay.Service.Core.Soap ► MultiLegShipmentType ► MultiLegShipmentType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MultiLegShipmentType()
Public Sub New
public:
MultiLegShipmentType()


ShippingServiceDetails Property

ShippingServiceDetails Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShipmentType ► ShippingServiceDetails
Declaration Syntax
C# Visual Basic Visual C++
public MultiLegShippingServiceType ShippingServiceDetails { get; set; }
Public Property ShippingServiceDetails As MultiLegShippingServiceType
    Get
    Set
public:
property MultiLegShippingServiceType^ ShippingServiceDetails {
    MultiLegShippingServiceType^ get ();
    void set (MultiLegShippingServiceType^ value);
}


ShippingTimeMax Property

ShippingTimeMax Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShipmentType ► ShippingTimeMax
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingTimeMax { get; set; }
Public Property ShippingTimeMax As Integer
    Get
    Set
public:
property int ShippingTimeMax {
    int get ();
    void set (int value);
}


ShippingTimeMaxSpecified Property

ShippingTimeMaxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShipmentType ► ShippingTimeMaxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTimeMaxSpecified { get; set; }
Public Property ShippingTimeMaxSpecified As Boolean
    Get
    Set
public:
property bool ShippingTimeMaxSpecified {
    bool get ();
    void set (bool value);
}


ShippingTimeMin Property

ShippingTimeMin Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShipmentType ► ShippingTimeMin
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingTimeMin { get; set; }
Public Property ShippingTimeMin As Integer
    Get
    Set
public:
property int ShippingTimeMin {
    int get ();
    void set (int value);
}


ShippingTimeMinSpecified Property

ShippingTimeMinSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShipmentType ► ShippingTimeMinSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTimeMinSpecified { get; set; }
Public Property ShippingTimeMinSpecified As Boolean
    Get
    Set
public:
property bool ShippingTimeMinSpecified {
    bool get ();
    void set (bool value);
}


ShipToAddress Property

ShipToAddress Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShipmentType ► ShipToAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType ShipToAddress { get; set; }
Public Property ShipToAddress As AddressType
    Get
    Set
public:
property AddressType^ ShipToAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


MultiLegShippingDetailsType Class

MultiLegShippingDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► MultiLegShippingDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MultiLegShippingDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MultiLegShippingDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MultiLegShippingDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiLegShippingDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LogisticsProviderShipmentToBuyer |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SellerShipmentToLogisticsProvider |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MultiLegShippingDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShippingDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LogisticsProviderShipmentToBuyer Property

LogisticsProviderShipmentToBuyer Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShippingDetailsType ► LogisticsProviderShipmentToBuyer
Declaration Syntax
C# Visual Basic Visual C++
public MultiLegShipmentType LogisticsProviderShipmentToBuyer { get; set; }
Public Property LogisticsProviderShipmentToBuyer As MultiLegShipmentType
    Get
    Set
public:
property MultiLegShipmentType^ LogisticsProviderShipmentToBuyer {
    MultiLegShipmentType^ get ();
    void set (MultiLegShipmentType^ value);
}


MultiLegShippingDetailsType Constructor

MultiLegShippingDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► MultiLegShippingDetailsType ► MultiLegShippingDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MultiLegShippingDetailsType()
Public Sub New
public:
MultiLegShippingDetailsType()


SellerShipmentToLogisticsProvider Property

SellerShipmentToLogisticsProvider Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShippingDetailsType ► SellerShipmentToLogisticsProvider
Declaration Syntax
C# Visual Basic Visual C++
public MultiLegShipmentType SellerShipmentToLogisticsProvider { get; set; }
Public Property SellerShipmentToLogisticsProvider As MultiLegShipmentType
    Get
    Set
public:
property MultiLegShipmentType^ SellerShipmentToLogisticsProvider {
    MultiLegShipmentType^ get ();
    void set (MultiLegShipmentType^ value);
}


MultiLegShippingServiceType Class

MultiLegShippingServiceType Class
Namespaces ► eBay.Service.Core.Soap ► MultiLegShippingServiceType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MultiLegShippingServiceType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MultiLegShippingServiceType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MultiLegShippingServiceType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MultiLegShippingServiceType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingService |
 | ToString()()()() | (Inherited from Object.)
 | TotalShippingCost |
Remarks
Inheritance Hierarchy
Object
MultiLegShippingServiceType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShippingServiceType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MultiLegShippingServiceType Constructor

MultiLegShippingServiceType Constructor
Namespaces ► eBay.Service.Core.Soap ► MultiLegShippingServiceType ► MultiLegShippingServiceType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MultiLegShippingServiceType()
Public Sub New
public:
MultiLegShippingServiceType()


ShippingService Property

ShippingService Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShippingServiceType ► ShippingService
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingService { get; set; }
Public Property ShippingService As String
    Get
    Set
public:
property String^ ShippingService {
    String^ get ();
    void set (String^ value);
}


TotalShippingCost Property

TotalShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► MultiLegShippingServiceType ► TotalShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalShippingCost { get; set; }
Public Property TotalShippingCost As AmountType
    Get
    Set
public:
property AmountType^ TotalShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


MyeBayFavoriteSearchListType Class

MyeBayFavoriteSearchListType Class
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchListType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyeBayFavoriteSearchListType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyeBayFavoriteSearchListType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyeBayFavoriteSearchListType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyeBayFavoriteSearchListType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | FavoriteSearch |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TotalAvailable |
 | TotalAvailableSpecified |
Remarks
Inheritance Hierarchy
Object
MyeBayFavoriteSearchListType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchListType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FavoriteSearch Property

FavoriteSearch Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchListType ► FavoriteSearch
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchTypeCollection FavoriteSearch { get; set; }
Public Property FavoriteSearch As MyeBayFavoriteSearchTypeCollection
    Get
    Set
public:
property MyeBayFavoriteSearchTypeCollection^ FavoriteSearch {
    MyeBayFavoriteSearchTypeCollection^ get ();
    void set (MyeBayFavoriteSearchTypeCollection^ value);
}


MyeBayFavoriteSearchListType Constructor

MyeBayFavoriteSearchListType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchListType ► MyeBayFavoriteSearchListType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchListType()
Public Sub New
public:
MyeBayFavoriteSearchListType()


TotalAvailable Property

TotalAvailable Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchListType ► TotalAvailable
Declaration Syntax
C# Visual Basic Visual C++
public int TotalAvailable { get; set; }
Public Property TotalAvailable As Integer
    Get
    Set
public:
property int TotalAvailable {
    int get ();
    void set (int value);
}


TotalAvailableSpecified Property

TotalAvailableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchListType ► TotalAvailableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalAvailableSpecified { get; set; }
Public Property TotalAvailableSpecified As Boolean
    Get
    Set
public:
property bool TotalAvailableSpecified {
    bool get ();
    void set (bool value);
}


MyeBayFavoriteSearchType Class

MyeBayFavoriteSearchType Class
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyeBayFavoriteSearchType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyeBayFavoriteSearchType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyeBayFavoriteSearchType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyeBayFavoriteSearchType()()()() |
 | Any |
 | BidCountMax |
 | BidCountMaxSpecified |
 | BidCountMin |
 | BidCountMinSpecified |
 | CategoryID |
 | Condition |
 | ConditionSpecified |
 | Currency |
 | CurrencySpecified |
 | EndTimeFrom |
 | EndTimeFromSpecified |
 | EndTimeTo |
 | EndTimeToSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemsAvailableTo |
 | ItemsAvailableToSpecified |
 | ItemsLocatedIn |
 | ItemsLocatedInSpecified |
 | ItemSort |
 | ItemSortSpecified |
 | ItemType |
 | ItemTypeSpecified |
 | MaxDistance |
 | MaxDistanceSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PaymentMethod |
 | PaymentMethodSpecified |
 | PostalCode |
 | PreferredLocation |
 | PreferredLocationSpecified |
 | PriceMax |
 | PriceMin |
 | Quantity |
 | QuantityOperator |
 | QuantityOperatorSpecified |
 | QuantitySpecified |
 | QueryKeywords |
 | SearchFlag |
 | SearchName |
 | SearchQuery |
 | SellerBusinessType |
 | SellerBusinessTypeSpecified |
 | SellerID |
 | SellerIDExclude |
 | SortOrder |
 | SortOrderSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MyeBayFavoriteSearchType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidCountMax Property

BidCountMax Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► BidCountMax
Declaration Syntax
C# Visual Basic Visual C++
public int BidCountMax { get; set; }
Public Property BidCountMax As Integer
    Get
    Set
public:
property int BidCountMax {
    int get ();
    void set (int value);
}


BidCountMaxSpecified Property

BidCountMaxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► BidCountMaxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidCountMaxSpecified { get; set; }
Public Property BidCountMaxSpecified As Boolean
    Get
    Set
public:
property bool BidCountMaxSpecified {
    bool get ();
    void set (bool value);
}


BidCountMin Property

BidCountMin Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► BidCountMin
Declaration Syntax
C# Visual Basic Visual C++
public int BidCountMin { get; set; }
Public Property BidCountMin As Integer
    Get
    Set
public:
property int BidCountMin {
    int get ();
    void set (int value);
}


BidCountMinSpecified Property

BidCountMinSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► BidCountMinSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidCountMinSpecified { get; set; }
Public Property BidCountMinSpecified As Boolean
    Get
    Set
public:
property bool BidCountMinSpecified {
    bool get ();
    void set (bool value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


Condition Property

Condition Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► Condition
Declaration Syntax
C# Visual Basic Visual C++
public ItemConditionCodeType Condition { get; set; }
Public Property Condition As ItemConditionCodeType
    Get
    Set
public:
property ItemConditionCodeType Condition {
    ItemConditionCodeType get ();
    void set (ItemConditionCodeType value);
}


ConditionSpecified Property

ConditionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► ConditionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ConditionSpecified { get; set; }
Public Property ConditionSpecified As Boolean
    Get
    Set
public:
property bool ConditionSpecified {
    bool get ();
    void set (bool value);
}


Currency Property

Currency Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► Currency
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType Currency { get; set; }
Public Property Currency As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType Currency {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


CurrencySpecified Property

CurrencySpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► CurrencySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CurrencySpecified { get; set; }
Public Property CurrencySpecified As Boolean
    Get
    Set
public:
property bool CurrencySpecified {
    bool get ();
    void set (bool value);
}


EndTimeFrom Property

EndTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► EndTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeFrom { get; set; }
Public Property EndTimeFrom As DateTime
    Get
    Set
public:
property DateTime EndTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


EndTimeFromSpecified Property

EndTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► EndTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeFromSpecified { get; set; }
Public Property EndTimeFromSpecified As Boolean
    Get
    Set
public:
property bool EndTimeFromSpecified {
    bool get ();
    void set (bool value);
}


EndTimeTo Property

EndTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► EndTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTimeTo { get; set; }
Public Property EndTimeTo As DateTime
    Get
    Set
public:
property DateTime EndTimeTo {
    DateTime get ();
    void set (DateTime value);
}


EndTimeToSpecified Property

EndTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► EndTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeToSpecified { get; set; }
Public Property EndTimeToSpecified As Boolean
    Get
    Set
public:
property bool EndTimeToSpecified {
    bool get ();
    void set (bool value);
}


ItemsAvailableTo Property

ItemsAvailableTo Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► ItemsAvailableTo
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType ItemsAvailableTo { get; set; }
Public Property ItemsAvailableTo As CountryCodeType
    Get
    Set
public:
property CountryCodeType ItemsAvailableTo {
    CountryCodeType get ();
    void set (CountryCodeType value);
}


ItemsAvailableToSpecified Property

ItemsAvailableToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► ItemsAvailableToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemsAvailableToSpecified { get; set; }
Public Property ItemsAvailableToSpecified As Boolean
    Get
    Set
public:
property bool ItemsAvailableToSpecified {
    bool get ();
    void set (bool value);
}


ItemsLocatedIn Property

ItemsLocatedIn Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► ItemsLocatedIn
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeType ItemsLocatedIn { get; set; }
Public Property ItemsLocatedIn As CountryCodeType
    Get
    Set
public:
property CountryCodeType ItemsLocatedIn {
    CountryCodeType get ();
    void set (CountryCodeType value);
}


ItemsLocatedInSpecified Property

ItemsLocatedInSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► ItemsLocatedInSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemsLocatedInSpecified { get; set; }
Public Property ItemsLocatedInSpecified As Boolean
    Get
    Set
public:
property bool ItemsLocatedInSpecified {
    bool get ();
    void set (bool value);
}


ItemSort Property

ItemSort Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► ItemSort
Declaration Syntax
C# Visual Basic Visual C++
public SimpleItemSortCodeType ItemSort { get; set; }
Public Property ItemSort As SimpleItemSortCodeType
    Get
    Set
public:
property SimpleItemSortCodeType ItemSort {
    SimpleItemSortCodeType get ();
    void set (SimpleItemSortCodeType value);
}


ItemSortSpecified Property

ItemSortSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► ItemSortSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemSortSpecified { get; set; }
Public Property ItemSortSpecified As Boolean
    Get
    Set
public:
property bool ItemSortSpecified {
    bool get ();
    void set (bool value);
}


ItemType Property

ItemType Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► ItemType
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCodeType ItemType { get; set; }
Public Property ItemType As ItemTypeCodeType
    Get
    Set
public:
property ItemTypeCodeType ItemType {
    ItemTypeCodeType get ();
    void set (ItemTypeCodeType value);
}


ItemTypeSpecified Property

ItemTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► ItemTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemTypeSpecified { get; set; }
Public Property ItemTypeSpecified As Boolean
    Get
    Set
public:
property bool ItemTypeSpecified {
    bool get ();
    void set (bool value);
}


MaxDistance Property

MaxDistance Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► MaxDistance
Declaration Syntax
C# Visual Basic Visual C++
public int MaxDistance { get; set; }
Public Property MaxDistance As Integer
    Get
    Set
public:
property int MaxDistance {
    int get ();
    void set (int value);
}


MaxDistanceSpecified Property

MaxDistanceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► MaxDistanceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxDistanceSpecified { get; set; }
Public Property MaxDistanceSpecified As Boolean
    Get
    Set
public:
property bool MaxDistanceSpecified {
    bool get ();
    void set (bool value);
}


MyeBayFavoriteSearchType Constructor

MyeBayFavoriteSearchType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► MyeBayFavoriteSearchType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchType()
Public Sub New
public:
MyeBayFavoriteSearchType()


PaymentMethod Property

PaymentMethod Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► PaymentMethod
Declaration Syntax
C# Visual Basic Visual C++
public PaymentMethodSearchCodeType PaymentMethod { get; set; }
Public Property PaymentMethod As PaymentMethodSearchCodeType
    Get
    Set
public:
property PaymentMethodSearchCodeType PaymentMethod {
    PaymentMethodSearchCodeType get ();
    void set (PaymentMethodSearchCodeType value);
}


PaymentMethodSpecified Property

PaymentMethodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► PaymentMethodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentMethodSpecified { get; set; }
Public Property PaymentMethodSpecified As Boolean
    Get
    Set
public:
property bool PaymentMethodSpecified {
    bool get ();
    void set (bool value);
}


PostalCode Property

PostalCode Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► PostalCode
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}


PreferredLocation Property

PreferredLocation Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► PreferredLocation
Declaration Syntax
C# Visual Basic Visual C++
public PreferredLocationCodeType PreferredLocation { get; set; }
Public Property PreferredLocation As PreferredLocationCodeType
    Get
    Set
public:
property PreferredLocationCodeType PreferredLocation {
    PreferredLocationCodeType get ();
    void set (PreferredLocationCodeType value);
}


PreferredLocationSpecified Property

PreferredLocationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► PreferredLocationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PreferredLocationSpecified { get; set; }
Public Property PreferredLocationSpecified As Boolean
    Get
    Set
public:
property bool PreferredLocationSpecified {
    bool get ();
    void set (bool value);
}


PriceMax Property

PriceMax Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► PriceMax
Declaration Syntax
C# Visual Basic Visual C++
public AmountType PriceMax { get; set; }
Public Property PriceMax As AmountType
    Get
    Set
public:
property AmountType^ PriceMax {
    AmountType^ get ();
    void set (AmountType^ value);
}


PriceMin Property

PriceMin Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► PriceMin
Declaration Syntax
C# Visual Basic Visual C++
public AmountType PriceMin { get; set; }
Public Property PriceMin As AmountType
    Get
    Set
public:
property AmountType^ PriceMin {
    AmountType^ get ();
    void set (AmountType^ value);
}


Quantity Property

Quantity Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public int Quantity { get; set; }
Public Property Quantity As Integer
    Get
    Set
public:
property int Quantity {
    int get ();
    void set (int value);
}


QuantityOperator Property

QuantityOperator Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► QuantityOperator
Declaration Syntax
C# Visual Basic Visual C++
public QuantityOperatorCodeType QuantityOperator { get; set; }
Public Property QuantityOperator As QuantityOperatorCodeType
    Get
    Set
public:
property QuantityOperatorCodeType QuantityOperator {
    QuantityOperatorCodeType get ();
    void set (QuantityOperatorCodeType value);
}


QuantityOperatorSpecified Property

QuantityOperatorSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► QuantityOperatorSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityOperatorSpecified { get; set; }
Public Property QuantityOperatorSpecified As Boolean
    Get
    Set
public:
property bool QuantityOperatorSpecified {
    bool get ();
    void set (bool value);
}


QuantitySpecified Property

QuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► QuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySpecified { get; set; }
Public Property QuantitySpecified As Boolean
    Get
    Set
public:
property bool QuantitySpecified {
    bool get ();
    void set (bool value);
}


QueryKeywords Property

QueryKeywords Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► QueryKeywords
Declaration Syntax
C# Visual Basic Visual C++
public string QueryKeywords { get; set; }
Public Property QueryKeywords As String
    Get
    Set
public:
property String^ QueryKeywords {
    String^ get ();
    void set (String^ value);
}


SearchFlag Property

SearchFlag Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► SearchFlag
Declaration Syntax
C# Visual Basic Visual C++
public SearchFlagCodeTypeCollection SearchFlag { get; set; }
Public Property SearchFlag As SearchFlagCodeTypeCollection
    Get
    Set
public:
property SearchFlagCodeTypeCollection^ SearchFlag {
    SearchFlagCodeTypeCollection^ get ();
    void set (SearchFlagCodeTypeCollection^ value);
}


SearchName Property

SearchName Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► SearchName
Declaration Syntax
C# Visual Basic Visual C++
public string SearchName { get; set; }
Public Property SearchName As String
    Get
    Set
public:
property String^ SearchName {
    String^ get ();
    void set (String^ value);
}


SearchQuery Property

SearchQuery Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► SearchQuery
Declaration Syntax
C# Visual Basic Visual C++
public string SearchQuery { get; set; }
Public Property SearchQuery As String
    Get
    Set
public:
property String^ SearchQuery {
    String^ get ();
    void set (String^ value);
}


SellerBusinessType Property

SellerBusinessType Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► SellerBusinessType
Declaration Syntax
C# Visual Basic Visual C++
public SellerBusinessCodeType SellerBusinessType { get; set; }
Public Property SellerBusinessType As SellerBusinessCodeType
    Get
    Set
public:
property SellerBusinessCodeType SellerBusinessType {
    SellerBusinessCodeType get ();
    void set (SellerBusinessCodeType value);
}


SellerBusinessTypeSpecified Property

SellerBusinessTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► SellerBusinessTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerBusinessTypeSpecified { get; set; }
Public Property SellerBusinessTypeSpecified As Boolean
    Get
    Set
public:
property bool SellerBusinessTypeSpecified {
    bool get ();
    void set (bool value);
}


SellerID Property

SellerID Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► SellerID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection SellerID { get; set; }
Public Property SellerID As StringCollection
    Get
    Set
public:
property StringCollection^ SellerID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


SellerIDExclude Property

SellerIDExclude Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► SellerIDExclude
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection SellerIDExclude { get; set; }
Public Property SellerIDExclude As StringCollection
    Get
    Set
public:
property StringCollection^ SellerIDExclude {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


SortOrder Property

SortOrder Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► SortOrder
Declaration Syntax
C# Visual Basic Visual C++
public SortOrderCodeType SortOrder { get; set; }
Public Property SortOrder As SortOrderCodeType
    Get
    Set
public:
property SortOrderCodeType SortOrder {
    SortOrderCodeType get ();
    void set (SortOrderCodeType value);
}


SortOrderSpecified Property

SortOrderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchType ► SortOrderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SortOrderSpecified { get; set; }
Public Property SortOrderSpecified As Boolean
    Get
    Set
public:
property bool SortOrderSpecified {
    bool get ();
    void set (bool value);
}


MyeBayFavoriteSearchTypeCollection Class

MyeBayFavoriteSearchTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class MyeBayFavoriteSearchTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class MyeBayFavoriteSearchTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class MyeBayFavoriteSearchTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyeBayFavoriteSearchTypeCollection()()()() |
 | MyeBayFavoriteSearchTypeCollection(array<MyeBayFavoriteSearchType>[]()[][]) |
 | MyeBayFavoriteSearchTypeCollection(MyeBayFavoriteSearchTypeCollection) |
 | Add(MyeBayFavoriteSearchType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<MyeBayFavoriteSearchType>[]()[][]) |
 | AddRange(MyeBayFavoriteSearchTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(MyeBayFavoriteSearchType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<MyeBayFavoriteSearchType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(MyeBayFavoriteSearchType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, MyeBayFavoriteSearchType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(MyeBayFavoriteSearchType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | MyeBayFavoriteSearchTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► Add(MyeBayFavoriteSearchType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MyeBayFavoriteSearchType item
)
Public Function Add ( _
    item As MyeBayFavoriteSearchType _
) As Integer
public:
int Add(
    MyeBayFavoriteSearchType^ item
)
Parameters
item (MyeBayFavoriteSearchType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<MyeBayFavoriteSearchType>[]()[][]) |
 | AddRange(MyeBayFavoriteSearchTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► AddRange(array<MyeBayFavoriteSearchType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MyeBayFavoriteSearchType[] items
)
Public Sub AddRange ( _
    items As MyeBayFavoriteSearchType() _
)
public:
void AddRange(
    array<MyeBayFavoriteSearchType^>^ items
)
Parameters
items (array< MyeBayFavoriteSearchType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► AddRange(MyeBayFavoriteSearchTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MyeBayFavoriteSearchTypeCollection items
)
Public Sub AddRange ( _
    items As MyeBayFavoriteSearchTypeCollection _
)
public:
void AddRange(
    MyeBayFavoriteSearchTypeCollection^ items
)
Parameters
items (MyeBayFavoriteSearchTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► Contains(MyeBayFavoriteSearchType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    MyeBayFavoriteSearchType item
)
Public Function Contains ( _
    item As MyeBayFavoriteSearchType _
) As Boolean
public:
bool Contains(
    MyeBayFavoriteSearchType^ item
)
Parameters
item (MyeBayFavoriteSearchType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► CopyTo(array<MyeBayFavoriteSearchType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MyeBayFavoriteSearchType[] items,
    int index
)
Public Sub CopyTo ( _
    items As MyeBayFavoriteSearchType(), _
    index As Integer _
)
public:
void CopyTo(
    array<MyeBayFavoriteSearchType^>^ items,
    int index
)
Parameters
items (array< MyeBayFavoriteSearchType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► IndexOf(MyeBayFavoriteSearchType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    MyeBayFavoriteSearchType item
)
Public Function IndexOf ( _
    item As MyeBayFavoriteSearchType _
) As Integer
public:
int IndexOf(
    MyeBayFavoriteSearchType^ item
)
Parameters
item (MyeBayFavoriteSearchType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► Insert(Int32, MyeBayFavoriteSearchType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    MyeBayFavoriteSearchType item
)
Public Sub Insert ( _
    index As Integer, _
    item As MyeBayFavoriteSearchType _
)
public:
void Insert(
    int index,
    MyeBayFavoriteSearchType^ item
)
Parameters
index (Int32)
item (MyeBayFavoriteSearchType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MyeBayFavoriteSearchType
    Get
    Set
public:
property MyeBayFavoriteSearchType^ default[int index] {
    MyeBayFavoriteSearchType^ get (int index);
    void set (int index, MyeBayFavoriteSearchType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As MyeBayFavoriteSearchType
public:
MyeBayFavoriteSearchType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


MyeBayFavoriteSearchTypeCollection Constructor

MyeBayFavoriteSearchTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► MyeBayFavoriteSearchTypeCollection()()()()
Members
Icon | Member | Description
 | MyeBayFavoriteSearchTypeCollection()()()() |
 | MyeBayFavoriteSearchTypeCollection(array<MyeBayFavoriteSearchType>[]()[][]) |
 | MyeBayFavoriteSearchTypeCollection(MyeBayFavoriteSearchTypeCollection) |


MyeBayFavoriteSearchTypeCollection Constructor

MyeBayFavoriteSearchTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► MyeBayFavoriteSearchTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchTypeCollection()
Public Sub New
public:
MyeBayFavoriteSearchTypeCollection()


MyeBayFavoriteSearchTypeCollection Constructor (items)

MyeBayFavoriteSearchTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► MyeBayFavoriteSearchTypeCollection(array<MyeBayFavoriteSearchType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchTypeCollection(
    MyeBayFavoriteSearchType[] items
)
Public Sub New ( _
    items As MyeBayFavoriteSearchType() _
)
public:
MyeBayFavoriteSearchTypeCollection(
    array<MyeBayFavoriteSearchType^>^ items
)
Parameters
items (array< MyeBayFavoriteSearchType >[]()[][])


MyeBayFavoriteSearchTypeCollection Constructor (items)

MyeBayFavoriteSearchTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► MyeBayFavoriteSearchTypeCollection(MyeBayFavoriteSearchTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchTypeCollection(
    MyeBayFavoriteSearchTypeCollection items
)
Public Sub New ( _
    items As MyeBayFavoriteSearchTypeCollection _
)
public:
MyeBayFavoriteSearchTypeCollection(
    MyeBayFavoriteSearchTypeCollection^ items
)
Parameters
items (MyeBayFavoriteSearchTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► Remove(MyeBayFavoriteSearchType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    MyeBayFavoriteSearchType item
)
Public Sub Remove ( _
    item As MyeBayFavoriteSearchType _
)
public:
void Remove(
    MyeBayFavoriteSearchType^ item
)
Parameters
item (MyeBayFavoriteSearchType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchType[] ToArray()
Public Function ToArray As MyeBayFavoriteSearchType()
public:
array<MyeBayFavoriteSearchType^>^ ToArray()
Return Value


MyeBayFavoriteSellerListType Class

MyeBayFavoriteSellerListType Class
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerListType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyeBayFavoriteSellerListType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyeBayFavoriteSellerListType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyeBayFavoriteSellerListType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyeBayFavoriteSellerListType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | FavoriteSeller |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TotalAvailable |
 | TotalAvailableSpecified |
Remarks
Inheritance Hierarchy
Object
MyeBayFavoriteSellerListType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerListType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FavoriteSeller Property

FavoriteSeller Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerListType ► FavoriteSeller
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerTypeCollection FavoriteSeller { get; set; }
Public Property FavoriteSeller As MyeBayFavoriteSellerTypeCollection
    Get
    Set
public:
property MyeBayFavoriteSellerTypeCollection^ FavoriteSeller {
    MyeBayFavoriteSellerTypeCollection^ get ();
    void set (MyeBayFavoriteSellerTypeCollection^ value);
}


MyeBayFavoriteSellerListType Constructor

MyeBayFavoriteSellerListType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerListType ► MyeBayFavoriteSellerListType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerListType()
Public Sub New
public:
MyeBayFavoriteSellerListType()


TotalAvailable Property

TotalAvailable Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerListType ► TotalAvailable
Declaration Syntax
C# Visual Basic Visual C++
public int TotalAvailable { get; set; }
Public Property TotalAvailable As Integer
    Get
    Set
public:
property int TotalAvailable {
    int get ();
    void set (int value);
}


TotalAvailableSpecified Property

TotalAvailableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerListType ► TotalAvailableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalAvailableSpecified { get; set; }
Public Property TotalAvailableSpecified As Boolean
    Get
    Set
public:
property bool TotalAvailableSpecified {
    bool get ();
    void set (bool value);
}


MyeBayFavoriteSellerType Class

MyeBayFavoriteSellerType Class
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyeBayFavoriteSellerType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyeBayFavoriteSellerType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyeBayFavoriteSellerType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyeBayFavoriteSellerType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | StoreName |
 | ToString()()()() | (Inherited from Object.)
 | UserID |
Remarks
Inheritance Hierarchy
Object
MyeBayFavoriteSellerType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MyeBayFavoriteSellerType Constructor

MyeBayFavoriteSellerType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerType ► MyeBayFavoriteSellerType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerType()
Public Sub New
public:
MyeBayFavoriteSellerType()


StoreName Property

StoreName Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerType ► StoreName
Declaration Syntax
C# Visual Basic Visual C++
public string StoreName { get; set; }
Public Property StoreName As String
    Get
    Set
public:
property String^ StoreName {
    String^ get ();
    void set (String^ value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


MyeBayFavoriteSellerTypeCollection Class

MyeBayFavoriteSellerTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class MyeBayFavoriteSellerTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class MyeBayFavoriteSellerTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class MyeBayFavoriteSellerTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyeBayFavoriteSellerTypeCollection()()()() |
 | MyeBayFavoriteSellerTypeCollection(array<MyeBayFavoriteSellerType>[]()[][]) |
 | MyeBayFavoriteSellerTypeCollection(MyeBayFavoriteSellerTypeCollection) |
 | Add(MyeBayFavoriteSellerType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<MyeBayFavoriteSellerType>[]()[][]) |
 | AddRange(MyeBayFavoriteSellerTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(MyeBayFavoriteSellerType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<MyeBayFavoriteSellerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(MyeBayFavoriteSellerType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, MyeBayFavoriteSellerType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(MyeBayFavoriteSellerType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | MyeBayFavoriteSellerTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► Add(MyeBayFavoriteSellerType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MyeBayFavoriteSellerType item
)
Public Function Add ( _
    item As MyeBayFavoriteSellerType _
) As Integer
public:
int Add(
    MyeBayFavoriteSellerType^ item
)
Parameters
item (MyeBayFavoriteSellerType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<MyeBayFavoriteSellerType>[]()[][]) |
 | AddRange(MyeBayFavoriteSellerTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► AddRange(array<MyeBayFavoriteSellerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MyeBayFavoriteSellerType[] items
)
Public Sub AddRange ( _
    items As MyeBayFavoriteSellerType() _
)
public:
void AddRange(
    array<MyeBayFavoriteSellerType^>^ items
)
Parameters
items (array< MyeBayFavoriteSellerType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► AddRange(MyeBayFavoriteSellerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MyeBayFavoriteSellerTypeCollection items
)
Public Sub AddRange ( _
    items As MyeBayFavoriteSellerTypeCollection _
)
public:
void AddRange(
    MyeBayFavoriteSellerTypeCollection^ items
)
Parameters
items (MyeBayFavoriteSellerTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► Contains(MyeBayFavoriteSellerType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    MyeBayFavoriteSellerType item
)
Public Function Contains ( _
    item As MyeBayFavoriteSellerType _
) As Boolean
public:
bool Contains(
    MyeBayFavoriteSellerType^ item
)
Parameters
item (MyeBayFavoriteSellerType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► CopyTo(array<MyeBayFavoriteSellerType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MyeBayFavoriteSellerType[] items,
    int index
)
Public Sub CopyTo ( _
    items As MyeBayFavoriteSellerType(), _
    index As Integer _
)
public:
void CopyTo(
    array<MyeBayFavoriteSellerType^>^ items,
    int index
)
Parameters
items (array< MyeBayFavoriteSellerType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► IndexOf(MyeBayFavoriteSellerType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    MyeBayFavoriteSellerType item
)
Public Function IndexOf ( _
    item As MyeBayFavoriteSellerType _
) As Integer
public:
int IndexOf(
    MyeBayFavoriteSellerType^ item
)
Parameters
item (MyeBayFavoriteSellerType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► Insert(Int32, MyeBayFavoriteSellerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    MyeBayFavoriteSellerType item
)
Public Sub Insert ( _
    index As Integer, _
    item As MyeBayFavoriteSellerType _
)
public:
void Insert(
    int index,
    MyeBayFavoriteSellerType^ item
)
Parameters
index (Int32)
item (MyeBayFavoriteSellerType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MyeBayFavoriteSellerType
    Get
    Set
public:
property MyeBayFavoriteSellerType^ default[int index] {
    MyeBayFavoriteSellerType^ get (int index);
    void set (int index, MyeBayFavoriteSellerType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As MyeBayFavoriteSellerType
public:
MyeBayFavoriteSellerType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


MyeBayFavoriteSellerTypeCollection Constructor

MyeBayFavoriteSellerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► MyeBayFavoriteSellerTypeCollection()()()()
Members
Icon | Member | Description
 | MyeBayFavoriteSellerTypeCollection()()()() |
 | MyeBayFavoriteSellerTypeCollection(array<MyeBayFavoriteSellerType>[]()[][]) |
 | MyeBayFavoriteSellerTypeCollection(MyeBayFavoriteSellerTypeCollection) |


MyeBayFavoriteSellerTypeCollection Constructor

MyeBayFavoriteSellerTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► MyeBayFavoriteSellerTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerTypeCollection()
Public Sub New
public:
MyeBayFavoriteSellerTypeCollection()


MyeBayFavoriteSellerTypeCollection Constructor (items)

MyeBayFavoriteSellerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► MyeBayFavoriteSellerTypeCollection(array<MyeBayFavoriteSellerType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerTypeCollection(
    MyeBayFavoriteSellerType[] items
)
Public Sub New ( _
    items As MyeBayFavoriteSellerType() _
)
public:
MyeBayFavoriteSellerTypeCollection(
    array<MyeBayFavoriteSellerType^>^ items
)
Parameters
items (array< MyeBayFavoriteSellerType >[]()[][])


MyeBayFavoriteSellerTypeCollection Constructor (items)

MyeBayFavoriteSellerTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► MyeBayFavoriteSellerTypeCollection(MyeBayFavoriteSellerTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerTypeCollection(
    MyeBayFavoriteSellerTypeCollection items
)
Public Sub New ( _
    items As MyeBayFavoriteSellerTypeCollection _
)
public:
MyeBayFavoriteSellerTypeCollection(
    MyeBayFavoriteSellerTypeCollection^ items
)
Parameters
items (MyeBayFavoriteSellerTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► Remove(MyeBayFavoriteSellerType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    MyeBayFavoriteSellerType item
)
Public Sub Remove ( _
    item As MyeBayFavoriteSellerType _
)
public:
void Remove(
    MyeBayFavoriteSellerType^ item
)
Parameters
item (MyeBayFavoriteSellerType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerType[] ToArray()
Public Function ToArray As MyeBayFavoriteSellerType()
public:
array<MyeBayFavoriteSellerType^>^ ToArray()
Return Value


MyeBaySelectionType Class

MyeBaySelectionType Class
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyeBaySelectionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyeBaySelectionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyeBaySelectionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyeBaySelectionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Include |
 | IncludeFavoriteSearcheCount |
 | IncludeFavoriteSearcheCountSpecified |
 | IncludeFavoriteSellerCount |
 | IncludeFavoriteSellerCountSpecified |
 | IncludeItemCount |
 | IncludeItemCountSpecified |
 | IncludeListContents |
 | IncludeListContentsSpecified |
 | IncludeSpecified |
 | MaxResults |
 | MaxResultsSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Sort |
 | SortSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UserDefinedListName |
Remarks
Inheritance Hierarchy
Object
MyeBaySelectionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Include Property

Include Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► Include
Declaration Syntax
C# Visual Basic Visual C++
public bool Include { get; set; }
Public Property Include As Boolean
    Get
    Set
public:
property bool Include {
    bool get ();
    void set (bool value);
}


IncludeFavoriteSearcheCount Property

IncludeFavoriteSearcheCount Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► IncludeFavoriteSearcheCount
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFavoriteSearcheCount { get; set; }
Public Property IncludeFavoriteSearcheCount As Boolean
    Get
    Set
public:
property bool IncludeFavoriteSearcheCount {
    bool get ();
    void set (bool value);
}


IncludeFavoriteSearcheCountSpecified Property

IncludeFavoriteSearcheCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► IncludeFavoriteSearcheCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFavoriteSearcheCountSpecified { get; set; }
Public Property IncludeFavoriteSearcheCountSpecified As Boolean
    Get
    Set
public:
property bool IncludeFavoriteSearcheCountSpecified {
    bool get ();
    void set (bool value);
}


IncludeFavoriteSellerCount Property

IncludeFavoriteSellerCount Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► IncludeFavoriteSellerCount
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFavoriteSellerCount { get; set; }
Public Property IncludeFavoriteSellerCount As Boolean
    Get
    Set
public:
property bool IncludeFavoriteSellerCount {
    bool get ();
    void set (bool value);
}


IncludeFavoriteSellerCountSpecified Property

IncludeFavoriteSellerCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► IncludeFavoriteSellerCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFavoriteSellerCountSpecified { get; set; }
Public Property IncludeFavoriteSellerCountSpecified As Boolean
    Get
    Set
public:
property bool IncludeFavoriteSellerCountSpecified {
    bool get ();
    void set (bool value);
}


IncludeItemCount Property

IncludeItemCount Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► IncludeItemCount
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeItemCount { get; set; }
Public Property IncludeItemCount As Boolean
    Get
    Set
public:
property bool IncludeItemCount {
    bool get ();
    void set (bool value);
}


IncludeItemCountSpecified Property

IncludeItemCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► IncludeItemCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeItemCountSpecified { get; set; }
Public Property IncludeItemCountSpecified As Boolean
    Get
    Set
public:
property bool IncludeItemCountSpecified {
    bool get ();
    void set (bool value);
}


IncludeListContents Property

IncludeListContents Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► IncludeListContents
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeListContents { get; set; }
Public Property IncludeListContents As Boolean
    Get
    Set
public:
property bool IncludeListContents {
    bool get ();
    void set (bool value);
}


IncludeListContentsSpecified Property

IncludeListContentsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► IncludeListContentsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeListContentsSpecified { get; set; }
Public Property IncludeListContentsSpecified As Boolean
    Get
    Set
public:
property bool IncludeListContentsSpecified {
    bool get ();
    void set (bool value);
}


IncludeSpecified Property

IncludeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► IncludeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeSpecified { get; set; }
Public Property IncludeSpecified As Boolean
    Get
    Set
public:
property bool IncludeSpecified {
    bool get ();
    void set (bool value);
}


MaxResults Property

MaxResults Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► MaxResults
Declaration Syntax
C# Visual Basic Visual C++
public int MaxResults { get; set; }
Public Property MaxResults As Integer
    Get
    Set
public:
property int MaxResults {
    int get ();
    void set (int value);
}


MaxResultsSpecified Property

MaxResultsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► MaxResultsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxResultsSpecified { get; set; }
Public Property MaxResultsSpecified As Boolean
    Get
    Set
public:
property bool MaxResultsSpecified {
    bool get ();
    void set (bool value);
}


MyeBaySelectionType Constructor

MyeBaySelectionType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► MyeBaySelectionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySelectionType()
Public Sub New
public:
MyeBaySelectionType()


Sort Property

Sort Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► Sort
Declaration Syntax
C# Visual Basic Visual C++
public SortOrderCodeType Sort { get; set; }
Public Property Sort As SortOrderCodeType
    Get
    Set
public:
property SortOrderCodeType Sort {
    SortOrderCodeType get ();
    void set (SortOrderCodeType value);
}


SortSpecified Property

SortSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► SortSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SortSpecified { get; set; }
Public Property SortSpecified As Boolean
    Get
    Set
public:
property bool SortSpecified {
    bool get ();
    void set (bool value);
}


UserDefinedListName Property

UserDefinedListName Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySelectionType ► UserDefinedListName
Declaration Syntax
C# Visual Basic Visual C++
public string UserDefinedListName { get; set; }
Public Property UserDefinedListName As String
    Get
    Set
public:
property String^ UserDefinedListName {
    String^ get ();
    void set (String^ value);
}


MyeBaySellingSummaryType Class

MyeBaySellingSummaryType Class
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyeBaySellingSummaryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyeBaySellingSummaryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyeBaySellingSummaryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyeBaySellingSummaryType()()()() |
 | ActiveAuctionCount |
 | ActiveAuctionCountSpecified |
 | AmountLimitRemaining |
 | Any |
 | AuctionBidCount |
 | AuctionBidCountSpecified |
 | AuctionSellingCount |
 | AuctionSellingCountSpecified |
 | ClassifiedAdCount |
 | ClassifiedAdCountSpecified |
 | ClassifiedAdOfferCount |
 | ClassifiedAdOfferCountSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QuantityLimitRemaining |
 | QuantityLimitRemainingSpecified |
 | SoldDurationInDays |
 | SoldDurationInDaysSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TotalAuctionSellingValue |
 | TotalLeadCount |
 | TotalLeadCountSpecified |
 | TotalListingsWithLeads |
 | TotalListingsWithLeadsSpecified |
 | TotalSoldCount |
 | TotalSoldCountSpecified |
 | TotalSoldValue |
Remarks
Inheritance Hierarchy
Object
MyeBaySellingSummaryType


ActiveAuctionCount Property

ActiveAuctionCount Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► ActiveAuctionCount
Declaration Syntax
C# Visual Basic Visual C++
public int ActiveAuctionCount { get; set; }
Public Property ActiveAuctionCount As Integer
    Get
    Set
public:
property int ActiveAuctionCount {
    int get ();
    void set (int value);
}


ActiveAuctionCountSpecified Property

ActiveAuctionCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► ActiveAuctionCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ActiveAuctionCountSpecified { get; set; }
Public Property ActiveAuctionCountSpecified As Boolean
    Get
    Set
public:
property bool ActiveAuctionCountSpecified {
    bool get ();
    void set (bool value);
}


AmountLimitRemaining Property

AmountLimitRemaining Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► AmountLimitRemaining
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AmountLimitRemaining { get; set; }
Public Property AmountLimitRemaining As AmountType
    Get
    Set
public:
property AmountType^ AmountLimitRemaining {
    AmountType^ get ();
    void set (AmountType^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AuctionBidCount Property

AuctionBidCount Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► AuctionBidCount
Declaration Syntax
C# Visual Basic Visual C++
public int AuctionBidCount { get; set; }
Public Property AuctionBidCount As Integer
    Get
    Set
public:
property int AuctionBidCount {
    int get ();
    void set (int value);
}


AuctionBidCountSpecified Property

AuctionBidCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► AuctionBidCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AuctionBidCountSpecified { get; set; }
Public Property AuctionBidCountSpecified As Boolean
    Get
    Set
public:
property bool AuctionBidCountSpecified {
    bool get ();
    void set (bool value);
}


AuctionSellingCount Property

AuctionSellingCount Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► AuctionSellingCount
Declaration Syntax
C# Visual Basic Visual C++
public int AuctionSellingCount { get; set; }
Public Property AuctionSellingCount As Integer
    Get
    Set
public:
property int AuctionSellingCount {
    int get ();
    void set (int value);
}


AuctionSellingCountSpecified Property

AuctionSellingCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► AuctionSellingCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AuctionSellingCountSpecified { get; set; }
Public Property AuctionSellingCountSpecified As Boolean
    Get
    Set
public:
property bool AuctionSellingCountSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdCount Property

ClassifiedAdCount Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► ClassifiedAdCount
Declaration Syntax
C# Visual Basic Visual C++
public int ClassifiedAdCount { get; set; }
Public Property ClassifiedAdCount As Integer
    Get
    Set
public:
property int ClassifiedAdCount {
    int get ();
    void set (int value);
}


ClassifiedAdCountSpecified Property

ClassifiedAdCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► ClassifiedAdCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdCountSpecified { get; set; }
Public Property ClassifiedAdCountSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdCountSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdOfferCount Property

ClassifiedAdOfferCount Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► ClassifiedAdOfferCount
Declaration Syntax
C# Visual Basic Visual C++
public int ClassifiedAdOfferCount { get; set; }
Public Property ClassifiedAdOfferCount As Integer
    Get
    Set
public:
property int ClassifiedAdOfferCount {
    int get ();
    void set (int value);
}


ClassifiedAdOfferCountSpecified Property

ClassifiedAdOfferCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► ClassifiedAdOfferCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdOfferCountSpecified { get; set; }
Public Property ClassifiedAdOfferCountSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdOfferCountSpecified {
    bool get ();
    void set (bool value);
}


MyeBaySellingSummaryType Constructor

MyeBaySellingSummaryType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► MyeBaySellingSummaryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyeBaySellingSummaryType()
Public Sub New
public:
MyeBaySellingSummaryType()


QuantityLimitRemaining Property

QuantityLimitRemaining Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► QuantityLimitRemaining
Declaration Syntax
C# Visual Basic Visual C++
public long QuantityLimitRemaining { get; set; }
Public Property QuantityLimitRemaining As Long
    Get
    Set
public:
property long long QuantityLimitRemaining {
    long long get ();
    void set (long long value);
}


QuantityLimitRemainingSpecified Property

QuantityLimitRemainingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► QuantityLimitRemainingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityLimitRemainingSpecified { get; set; }
Public Property QuantityLimitRemainingSpecified As Boolean
    Get
    Set
public:
property bool QuantityLimitRemainingSpecified {
    bool get ();
    void set (bool value);
}


SoldDurationInDays Property

SoldDurationInDays Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► SoldDurationInDays
Declaration Syntax
C# Visual Basic Visual C++
public int SoldDurationInDays { get; set; }
Public Property SoldDurationInDays As Integer
    Get
    Set
public:
property int SoldDurationInDays {
    int get ();
    void set (int value);
}


SoldDurationInDaysSpecified Property

SoldDurationInDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► SoldDurationInDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SoldDurationInDaysSpecified { get; set; }
Public Property SoldDurationInDaysSpecified As Boolean
    Get
    Set
public:
property bool SoldDurationInDaysSpecified {
    bool get ();
    void set (bool value);
}


TotalAuctionSellingValue Property

TotalAuctionSellingValue Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► TotalAuctionSellingValue
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalAuctionSellingValue { get; set; }
Public Property TotalAuctionSellingValue As AmountType
    Get
    Set
public:
property AmountType^ TotalAuctionSellingValue {
    AmountType^ get ();
    void set (AmountType^ value);
}


TotalLeadCount Property

TotalLeadCount Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► TotalLeadCount
Declaration Syntax
C# Visual Basic Visual C++
public int TotalLeadCount { get; set; }
Public Property TotalLeadCount As Integer
    Get
    Set
public:
property int TotalLeadCount {
    int get ();
    void set (int value);
}


TotalLeadCountSpecified Property

TotalLeadCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► TotalLeadCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalLeadCountSpecified { get; set; }
Public Property TotalLeadCountSpecified As Boolean
    Get
    Set
public:
property bool TotalLeadCountSpecified {
    bool get ();
    void set (bool value);
}


TotalListingsWithLeads Property

TotalListingsWithLeads Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► TotalListingsWithLeads
Declaration Syntax
C# Visual Basic Visual C++
public int TotalListingsWithLeads { get; set; }
Public Property TotalListingsWithLeads As Integer
    Get
    Set
public:
property int TotalListingsWithLeads {
    int get ();
    void set (int value);
}


TotalListingsWithLeadsSpecified Property

TotalListingsWithLeadsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► TotalListingsWithLeadsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalListingsWithLeadsSpecified { get; set; }
Public Property TotalListingsWithLeadsSpecified As Boolean
    Get
    Set
public:
property bool TotalListingsWithLeadsSpecified {
    bool get ();
    void set (bool value);
}


TotalSoldCount Property

TotalSoldCount Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► TotalSoldCount
Declaration Syntax
C# Visual Basic Visual C++
public int TotalSoldCount { get; set; }
Public Property TotalSoldCount As Integer
    Get
    Set
public:
property int TotalSoldCount {
    int get ();
    void set (int value);
}


TotalSoldCountSpecified Property

TotalSoldCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► TotalSoldCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalSoldCountSpecified { get; set; }
Public Property TotalSoldCountSpecified As Boolean
    Get
    Set
public:
property bool TotalSoldCountSpecified {
    bool get ();
    void set (bool value);
}


TotalSoldValue Property

TotalSoldValue Property
Namespaces ► eBay.Service.Core.Soap ► MyeBaySellingSummaryType ► TotalSoldValue
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalSoldValue { get; set; }
Public Property TotalSoldValue As AmountType
    Get
    Set
public:
property AmountType^ TotalSoldValue {
    AmountType^ get ();
    void set (AmountType^ value);
}


MyMessagesAlertResolutionStatusCode Enumeration

MyMessagesAlertResolutionStatusCode Enumeration
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertResolutionStatusCode
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum MyMessagesAlertResolutionStatusCode
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration MyMessagesAlertResolutionStatusCode
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class MyMessagesAlertResolutionStatusCode
Members
Member | Description
Unresolved |
ResolvedByAutoResolution |
ResolvedByUser |
CustomCode |
Remarks


MyMessagesAlertType Class

MyMessagesAlertType Class
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyMessagesAlertType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyMessagesAlertType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyMessagesAlertType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyMessagesAlertType()()()() |
 | ActionURL |
 | AlertID |
 | Any |
 | ContentType |
 | CreationDate |
 | CreationDateSpecified |
 | Equals(Object) | (Inherited from Object.)
 | ExpirationDate |
 | ExpirationDateSpecified |
 | ExternalAlertID |
 | Finalize()()()() | (Inherited from Object.)
 | Folder |
 | ForwardDetails |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IsTimedResolution |
 | IsTimedResolutionSpecified |
 | ItemID |
 | LastReadDate |
 | LastReadDateSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Priority |
 | Read |
 | ReadSpecified |
 | ReceiveDate |
 | ReceiveDateSpecified |
 | RecipientUserID |
 | ResolutionDate |
 | ResolutionDateSpecified |
 | ResolutionStatus |
 | ResolutionStatusSpecified |
 | ResponseDetails |
 | Sender |
 | Subject |
 | Text |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MyMessagesAlertType


ActionURL Property

ActionURL Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ActionURL
Declaration Syntax
C# Visual Basic Visual C++
public string ActionURL { get; set; }
Public Property ActionURL As String
    Get
    Set
public:
property String^ ActionURL {
    String^ get ();
    void set (String^ value);
}


AlertID Property

AlertID Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► AlertID
Declaration Syntax
C# Visual Basic Visual C++
public string AlertID { get; set; }
Public Property AlertID As String
    Get
    Set
public:
property String^ AlertID {
    String^ get ();
    void set (String^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ContentType Property

ContentType Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ContentType
Declaration Syntax
C# Visual Basic Visual C++
public string ContentType { get; set; }
Public Property ContentType As String
    Get
    Set
public:
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}


CreationDate Property

CreationDate Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► CreationDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreationDate { get; set; }
Public Property CreationDate As DateTime
    Get
    Set
public:
property DateTime CreationDate {
    DateTime get ();
    void set (DateTime value);
}


CreationDateSpecified Property

CreationDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► CreationDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreationDateSpecified { get; set; }
Public Property CreationDateSpecified As Boolean
    Get
    Set
public:
property bool CreationDateSpecified {
    bool get ();
    void set (bool value);
}


ExpirationDate Property

ExpirationDate Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ExpirationDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ExpirationDate { get; set; }
Public Property ExpirationDate As DateTime
    Get
    Set
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}


ExpirationDateSpecified Property

ExpirationDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ExpirationDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpirationDateSpecified { get; set; }
Public Property ExpirationDateSpecified As Boolean
    Get
    Set
public:
property bool ExpirationDateSpecified {
    bool get ();
    void set (bool value);
}


ExternalAlertID Property

ExternalAlertID Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ExternalAlertID
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalAlertID { get; set; }
Public Property ExternalAlertID As String
    Get
    Set
public:
property String^ ExternalAlertID {
    String^ get ();
    void set (String^ value);
}


Folder Property

Folder Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► Folder
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderType Folder { get; set; }
Public Property Folder As MyMessagesFolderType
    Get
    Set
public:
property MyMessagesFolderType^ Folder {
    MyMessagesFolderType^ get ();
    void set (MyMessagesFolderType^ value);
}


ForwardDetails Property

ForwardDetails Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ForwardDetails
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesForwardDetailsType ForwardDetails { get; set; }
Public Property ForwardDetails As MyMessagesForwardDetailsType
    Get
    Set
public:
property MyMessagesForwardDetailsType^ ForwardDetails {
    MyMessagesForwardDetailsType^ get ();
    void set (MyMessagesForwardDetailsType^ value);
}


IsTimedResolution Property

IsTimedResolution Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► IsTimedResolution
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTimedResolution { get; set; }
Public Property IsTimedResolution As Boolean
    Get
    Set
public:
property bool IsTimedResolution {
    bool get ();
    void set (bool value);
}


IsTimedResolutionSpecified Property

IsTimedResolutionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► IsTimedResolutionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTimedResolutionSpecified { get; set; }
Public Property IsTimedResolutionSpecified As Boolean
    Get
    Set
public:
property bool IsTimedResolutionSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


LastReadDate Property

LastReadDate Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► LastReadDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastReadDate { get; set; }
Public Property LastReadDate As DateTime
    Get
    Set
public:
property DateTime LastReadDate {
    DateTime get ();
    void set (DateTime value);
}


LastReadDateSpecified Property

LastReadDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► LastReadDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastReadDateSpecified { get; set; }
Public Property LastReadDateSpecified As Boolean
    Get
    Set
public:
property bool LastReadDateSpecified {
    bool get ();
    void set (bool value);
}


MyMessagesAlertType Constructor

MyMessagesAlertType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► MyMessagesAlertType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesAlertType()
Public Sub New
public:
MyMessagesAlertType()


Priority Property

Priority Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► Priority
Declaration Syntax
C# Visual Basic Visual C++
public string Priority { get; set; }
Public Property Priority As String
    Get
    Set
public:
property String^ Priority {
    String^ get ();
    void set (String^ value);
}


Read Property

Read Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► Read
Declaration Syntax
C# Visual Basic Visual C++
public bool Read { get; set; }
Public Property Read As Boolean
    Get
    Set
public:
property bool Read {
    bool get ();
    void set (bool value);
}


ReadSpecified Property

ReadSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ReadSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReadSpecified { get; set; }
Public Property ReadSpecified As Boolean
    Get
    Set
public:
property bool ReadSpecified {
    bool get ();
    void set (bool value);
}


ReceiveDate Property

ReceiveDate Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ReceiveDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ReceiveDate { get; set; }
Public Property ReceiveDate As DateTime
    Get
    Set
public:
property DateTime ReceiveDate {
    DateTime get ();
    void set (DateTime value);
}


ReceiveDateSpecified Property

ReceiveDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ReceiveDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReceiveDateSpecified { get; set; }
Public Property ReceiveDateSpecified As Boolean
    Get
    Set
public:
property bool ReceiveDateSpecified {
    bool get ();
    void set (bool value);
}


RecipientUserID Property

RecipientUserID Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► RecipientUserID
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientUserID { get; set; }
Public Property RecipientUserID As String
    Get
    Set
public:
property String^ RecipientUserID {
    String^ get ();
    void set (String^ value);
}


ResolutionDate Property

ResolutionDate Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ResolutionDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ResolutionDate { get; set; }
Public Property ResolutionDate As DateTime
    Get
    Set
public:
property DateTime ResolutionDate {
    DateTime get ();
    void set (DateTime value);
}


ResolutionDateSpecified Property

ResolutionDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ResolutionDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ResolutionDateSpecified { get; set; }
Public Property ResolutionDateSpecified As Boolean
    Get
    Set
public:
property bool ResolutionDateSpecified {
    bool get ();
    void set (bool value);
}


ResolutionStatus Property

ResolutionStatus Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ResolutionStatus
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesAlertResolutionStatusCode ResolutionStatus { get; set; }
Public Property ResolutionStatus As MyMessagesAlertResolutionStatusCode
    Get
    Set
public:
property MyMessagesAlertResolutionStatusCode ResolutionStatus {
    MyMessagesAlertResolutionStatusCode get ();
    void set (MyMessagesAlertResolutionStatusCode value);
}


ResolutionStatusSpecified Property

ResolutionStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ResolutionStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ResolutionStatusSpecified { get; set; }
Public Property ResolutionStatusSpecified As Boolean
    Get
    Set
public:
property bool ResolutionStatusSpecified {
    bool get ();
    void set (bool value);
}


ResponseDetails Property

ResponseDetails Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► ResponseDetails
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesResponseDetailsType ResponseDetails { get; set; }
Public Property ResponseDetails As MyMessagesResponseDetailsType
    Get
    Set
public:
property MyMessagesResponseDetailsType^ ResponseDetails {
    MyMessagesResponseDetailsType^ get ();
    void set (MyMessagesResponseDetailsType^ value);
}


Sender Property

Sender Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► Sender
Declaration Syntax
C# Visual Basic Visual C++
public string Sender { get; set; }
Public Property Sender As String
    Get
    Set
public:
property String^ Sender {
    String^ get ();
    void set (String^ value);
}


Subject Property

Subject Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► Subject
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}


Text Property

Text Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertType ► Text
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}


MyMessagesAlertTypeCollection Class

MyMessagesAlertTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class MyMessagesAlertTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class MyMessagesAlertTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class MyMessagesAlertTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyMessagesAlertTypeCollection()()()() |
 | MyMessagesAlertTypeCollection(array<MyMessagesAlertType>[]()[][]) |
 | MyMessagesAlertTypeCollection(MyMessagesAlertTypeCollection) |
 | Add(MyMessagesAlertType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<MyMessagesAlertType>[]()[][]) |
 | AddRange(MyMessagesAlertTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(MyMessagesAlertType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<MyMessagesAlertType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(MyMessagesAlertType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, MyMessagesAlertType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(MyMessagesAlertType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | MyMessagesAlertTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► Add(MyMessagesAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MyMessagesAlertType item
)
Public Function Add ( _
    item As MyMessagesAlertType _
) As Integer
public:
int Add(
    MyMessagesAlertType^ item
)
Parameters
item (MyMessagesAlertType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<MyMessagesAlertType>[]()[][]) |
 | AddRange(MyMessagesAlertTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► AddRange(array<MyMessagesAlertType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MyMessagesAlertType[] items
)
Public Sub AddRange ( _
    items As MyMessagesAlertType() _
)
public:
void AddRange(
    array<MyMessagesAlertType^>^ items
)
Parameters
items (array< MyMessagesAlertType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► AddRange(MyMessagesAlertTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MyMessagesAlertTypeCollection items
)
Public Sub AddRange ( _
    items As MyMessagesAlertTypeCollection _
)
public:
void AddRange(
    MyMessagesAlertTypeCollection^ items
)
Parameters
items (MyMessagesAlertTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► Contains(MyMessagesAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    MyMessagesAlertType item
)
Public Function Contains ( _
    item As MyMessagesAlertType _
) As Boolean
public:
bool Contains(
    MyMessagesAlertType^ item
)
Parameters
item (MyMessagesAlertType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► CopyTo(array<MyMessagesAlertType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MyMessagesAlertType[] items,
    int index
)
Public Sub CopyTo ( _
    items As MyMessagesAlertType(), _
    index As Integer _
)
public:
void CopyTo(
    array<MyMessagesAlertType^>^ items,
    int index
)
Parameters
items (array< MyMessagesAlertType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► IndexOf(MyMessagesAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    MyMessagesAlertType item
)
Public Function IndexOf ( _
    item As MyMessagesAlertType _
) As Integer
public:
int IndexOf(
    MyMessagesAlertType^ item
)
Parameters
item (MyMessagesAlertType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► Insert(Int32, MyMessagesAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    MyMessagesAlertType item
)
Public Sub Insert ( _
    index As Integer, _
    item As MyMessagesAlertType _
)
public:
void Insert(
    int index,
    MyMessagesAlertType^ item
)
Parameters
index (Int32)
item (MyMessagesAlertType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesAlertType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MyMessagesAlertType
    Get
    Set
public:
property MyMessagesAlertType^ default[int index] {
    MyMessagesAlertType^ get (int index);
    void set (int index, MyMessagesAlertType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesAlertType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As MyMessagesAlertType
public:
MyMessagesAlertType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


MyMessagesAlertTypeCollection Constructor

MyMessagesAlertTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► MyMessagesAlertTypeCollection()()()()
Members
Icon | Member | Description
 | MyMessagesAlertTypeCollection()()()() |
 | MyMessagesAlertTypeCollection(array<MyMessagesAlertType>[]()[][]) |
 | MyMessagesAlertTypeCollection(MyMessagesAlertTypeCollection) |


MyMessagesAlertTypeCollection Constructor

MyMessagesAlertTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► MyMessagesAlertTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesAlertTypeCollection()
Public Sub New
public:
MyMessagesAlertTypeCollection()


MyMessagesAlertTypeCollection Constructor (items)

MyMessagesAlertTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► MyMessagesAlertTypeCollection(array<MyMessagesAlertType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesAlertTypeCollection(
    MyMessagesAlertType[] items
)
Public Sub New ( _
    items As MyMessagesAlertType() _
)
public:
MyMessagesAlertTypeCollection(
    array<MyMessagesAlertType^>^ items
)
Parameters
items (array< MyMessagesAlertType >[]()[][])


MyMessagesAlertTypeCollection Constructor (items)

MyMessagesAlertTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► MyMessagesAlertTypeCollection(MyMessagesAlertTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesAlertTypeCollection(
    MyMessagesAlertTypeCollection items
)
Public Sub New ( _
    items As MyMessagesAlertTypeCollection _
)
public:
MyMessagesAlertTypeCollection(
    MyMessagesAlertTypeCollection^ items
)
Parameters
items (MyMessagesAlertTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► Remove(MyMessagesAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    MyMessagesAlertType item
)
Public Sub Remove ( _
    item As MyMessagesAlertType _
)
public:
void Remove(
    MyMessagesAlertType^ item
)
Parameters
item (MyMessagesAlertType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesAlertType[] ToArray()
Public Function ToArray As MyMessagesAlertType()
public:
array<MyMessagesAlertType^>^ ToArray()
Return Value


MyMessagesFolderOperationCodeType Enumeration

MyMessagesFolderOperationCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderOperationCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum MyMessagesFolderOperationCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration MyMessagesFolderOperationCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class MyMessagesFolderOperationCodeType
Members
Member | Description
Display |
Rename |
Remove |
CustomCode |
Remarks


MyMessagesFolderSummaryType Class

MyMessagesFolderSummaryType Class
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyMessagesFolderSummaryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyMessagesFolderSummaryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyMessagesFolderSummaryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyMessagesFolderSummaryType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID |
 | FolderIDSpecified |
 | FolderName |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewAlertCount |
 | NewAlertCountSpecified |
 | NewHighPriorityCount |
 | NewHighPriorityCountSpecified |
 | NewMessageCount |
 | NewMessageCountSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TotalAlertCount |
 | TotalAlertCountSpecified |
 | TotalHighPriorityCount |
 | TotalHighPriorityCountSpecified |
 | TotalMessageCount |
 | TotalMessageCountSpecified |
Remarks
Inheritance Hierarchy
Object
MyMessagesFolderSummaryType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


FolderName Property

FolderName Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► FolderName
Declaration Syntax
C# Visual Basic Visual C++
public string FolderName { get; set; }
Public Property FolderName As String
    Get
    Set
public:
property String^ FolderName {
    String^ get ();
    void set (String^ value);
}


MyMessagesFolderSummaryType Constructor

MyMessagesFolderSummaryType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► MyMessagesFolderSummaryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderSummaryType()
Public Sub New
public:
MyMessagesFolderSummaryType()


NewAlertCount Property

NewAlertCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► NewAlertCount
Declaration Syntax
C# Visual Basic Visual C++
public int NewAlertCount { get; set; }
Public Property NewAlertCount As Integer
    Get
    Set
public:
property int NewAlertCount {
    int get ();
    void set (int value);
}


NewAlertCountSpecified Property

NewAlertCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► NewAlertCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewAlertCountSpecified { get; set; }
Public Property NewAlertCountSpecified As Boolean
    Get
    Set
public:
property bool NewAlertCountSpecified {
    bool get ();
    void set (bool value);
}


NewHighPriorityCount Property

NewHighPriorityCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► NewHighPriorityCount
Declaration Syntax
C# Visual Basic Visual C++
public int NewHighPriorityCount { get; set; }
Public Property NewHighPriorityCount As Integer
    Get
    Set
public:
property int NewHighPriorityCount {
    int get ();
    void set (int value);
}


NewHighPriorityCountSpecified Property

NewHighPriorityCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► NewHighPriorityCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewHighPriorityCountSpecified { get; set; }
Public Property NewHighPriorityCountSpecified As Boolean
    Get
    Set
public:
property bool NewHighPriorityCountSpecified {
    bool get ();
    void set (bool value);
}


NewMessageCount Property

NewMessageCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► NewMessageCount
Declaration Syntax
C# Visual Basic Visual C++
public int NewMessageCount { get; set; }
Public Property NewMessageCount As Integer
    Get
    Set
public:
property int NewMessageCount {
    int get ();
    void set (int value);
}


NewMessageCountSpecified Property

NewMessageCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► NewMessageCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewMessageCountSpecified { get; set; }
Public Property NewMessageCountSpecified As Boolean
    Get
    Set
public:
property bool NewMessageCountSpecified {
    bool get ();
    void set (bool value);
}


TotalAlertCount Property

TotalAlertCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► TotalAlertCount
Declaration Syntax
C# Visual Basic Visual C++
public int TotalAlertCount { get; set; }
Public Property TotalAlertCount As Integer
    Get
    Set
public:
property int TotalAlertCount {
    int get ();
    void set (int value);
}


TotalAlertCountSpecified Property

TotalAlertCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► TotalAlertCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalAlertCountSpecified { get; set; }
Public Property TotalAlertCountSpecified As Boolean
    Get
    Set
public:
property bool TotalAlertCountSpecified {
    bool get ();
    void set (bool value);
}


TotalHighPriorityCount Property

TotalHighPriorityCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► TotalHighPriorityCount
Declaration Syntax
C# Visual Basic Visual C++
public int TotalHighPriorityCount { get; set; }
Public Property TotalHighPriorityCount As Integer
    Get
    Set
public:
property int TotalHighPriorityCount {
    int get ();
    void set (int value);
}


TotalHighPriorityCountSpecified Property

TotalHighPriorityCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► TotalHighPriorityCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalHighPriorityCountSpecified { get; set; }
Public Property TotalHighPriorityCountSpecified As Boolean
    Get
    Set
public:
property bool TotalHighPriorityCountSpecified {
    bool get ();
    void set (bool value);
}


TotalMessageCount Property

TotalMessageCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► TotalMessageCount
Declaration Syntax
C# Visual Basic Visual C++
public int TotalMessageCount { get; set; }
Public Property TotalMessageCount As Integer
    Get
    Set
public:
property int TotalMessageCount {
    int get ();
    void set (int value);
}


TotalMessageCountSpecified Property

TotalMessageCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryType ► TotalMessageCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalMessageCountSpecified { get; set; }
Public Property TotalMessageCountSpecified As Boolean
    Get
    Set
public:
property bool TotalMessageCountSpecified {
    bool get ();
    void set (bool value);
}


MyMessagesFolderSummaryTypeCollection Class

MyMessagesFolderSummaryTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class MyMessagesFolderSummaryTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class MyMessagesFolderSummaryTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class MyMessagesFolderSummaryTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyMessagesFolderSummaryTypeCollection()()()() |
 | MyMessagesFolderSummaryTypeCollection(array<MyMessagesFolderSummaryType>[]()[][]) |
 | MyMessagesFolderSummaryTypeCollection(MyMessagesFolderSummaryTypeCollection) |
 | Add(MyMessagesFolderSummaryType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<MyMessagesFolderSummaryType>[]()[][]) |
 | AddRange(MyMessagesFolderSummaryTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(MyMessagesFolderSummaryType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<MyMessagesFolderSummaryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(MyMessagesFolderSummaryType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, MyMessagesFolderSummaryType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(MyMessagesFolderSummaryType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | MyMessagesFolderSummaryTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► Add(MyMessagesFolderSummaryType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MyMessagesFolderSummaryType item
)
Public Function Add ( _
    item As MyMessagesFolderSummaryType _
) As Integer
public:
int Add(
    MyMessagesFolderSummaryType^ item
)
Parameters
item (MyMessagesFolderSummaryType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<MyMessagesFolderSummaryType>[]()[][]) |
 | AddRange(MyMessagesFolderSummaryTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► AddRange(array<MyMessagesFolderSummaryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MyMessagesFolderSummaryType[] items
)
Public Sub AddRange ( _
    items As MyMessagesFolderSummaryType() _
)
public:
void AddRange(
    array<MyMessagesFolderSummaryType^>^ items
)
Parameters
items (array< MyMessagesFolderSummaryType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► AddRange(MyMessagesFolderSummaryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MyMessagesFolderSummaryTypeCollection items
)
Public Sub AddRange ( _
    items As MyMessagesFolderSummaryTypeCollection _
)
public:
void AddRange(
    MyMessagesFolderSummaryTypeCollection^ items
)
Parameters
items (MyMessagesFolderSummaryTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► Contains(MyMessagesFolderSummaryType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    MyMessagesFolderSummaryType item
)
Public Function Contains ( _
    item As MyMessagesFolderSummaryType _
) As Boolean
public:
bool Contains(
    MyMessagesFolderSummaryType^ item
)
Parameters
item (MyMessagesFolderSummaryType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► CopyTo(array<MyMessagesFolderSummaryType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MyMessagesFolderSummaryType[] items,
    int index
)
Public Sub CopyTo ( _
    items As MyMessagesFolderSummaryType(), _
    index As Integer _
)
public:
void CopyTo(
    array<MyMessagesFolderSummaryType^>^ items,
    int index
)
Parameters
items (array< MyMessagesFolderSummaryType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► IndexOf(MyMessagesFolderSummaryType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    MyMessagesFolderSummaryType item
)
Public Function IndexOf ( _
    item As MyMessagesFolderSummaryType _
) As Integer
public:
int IndexOf(
    MyMessagesFolderSummaryType^ item
)
Parameters
item (MyMessagesFolderSummaryType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► Insert(Int32, MyMessagesFolderSummaryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    MyMessagesFolderSummaryType item
)
Public Sub Insert ( _
    index As Integer, _
    item As MyMessagesFolderSummaryType _
)
public:
void Insert(
    int index,
    MyMessagesFolderSummaryType^ item
)
Parameters
index (Int32)
item (MyMessagesFolderSummaryType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderSummaryType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MyMessagesFolderSummaryType
    Get
    Set
public:
property MyMessagesFolderSummaryType^ default[int index] {
    MyMessagesFolderSummaryType^ get (int index);
    void set (int index, MyMessagesFolderSummaryType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderSummaryType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As MyMessagesFolderSummaryType
public:
MyMessagesFolderSummaryType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


MyMessagesFolderSummaryTypeCollection Constructor

MyMessagesFolderSummaryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► MyMessagesFolderSummaryTypeCollection()()()()
Members
Icon | Member | Description
 | MyMessagesFolderSummaryTypeCollection()()()() |
 | MyMessagesFolderSummaryTypeCollection(array<MyMessagesFolderSummaryType>[]()[][]) |
 | MyMessagesFolderSummaryTypeCollection(MyMessagesFolderSummaryTypeCollection) |


MyMessagesFolderSummaryTypeCollection Constructor

MyMessagesFolderSummaryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► MyMessagesFolderSummaryTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderSummaryTypeCollection()
Public Sub New
public:
MyMessagesFolderSummaryTypeCollection()


MyMessagesFolderSummaryTypeCollection Constructor (items)

MyMessagesFolderSummaryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► MyMessagesFolderSummaryTypeCollection(array<MyMessagesFolderSummaryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderSummaryTypeCollection(
    MyMessagesFolderSummaryType[] items
)
Public Sub New ( _
    items As MyMessagesFolderSummaryType() _
)
public:
MyMessagesFolderSummaryTypeCollection(
    array<MyMessagesFolderSummaryType^>^ items
)
Parameters
items (array< MyMessagesFolderSummaryType >[]()[][])


MyMessagesFolderSummaryTypeCollection Constructor (items)

MyMessagesFolderSummaryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► MyMessagesFolderSummaryTypeCollection(MyMessagesFolderSummaryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderSummaryTypeCollection(
    MyMessagesFolderSummaryTypeCollection items
)
Public Sub New ( _
    items As MyMessagesFolderSummaryTypeCollection _
)
public:
MyMessagesFolderSummaryTypeCollection(
    MyMessagesFolderSummaryTypeCollection^ items
)
Parameters
items (MyMessagesFolderSummaryTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► Remove(MyMessagesFolderSummaryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    MyMessagesFolderSummaryType item
)
Public Sub Remove ( _
    item As MyMessagesFolderSummaryType _
)
public:
void Remove(
    MyMessagesFolderSummaryType^ item
)
Parameters
item (MyMessagesFolderSummaryType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderSummaryType[] ToArray()
Public Function ToArray As MyMessagesFolderSummaryType()
public:
array<MyMessagesFolderSummaryType^>^ ToArray()
Return Value


MyMessagesFolderType Class

MyMessagesFolderType Class
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyMessagesFolderType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyMessagesFolderType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyMessagesFolderType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyMessagesFolderType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID |
 | FolderIDSpecified |
 | FolderName |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MyMessagesFolderType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


FolderName Property

FolderName Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderType ► FolderName
Declaration Syntax
C# Visual Basic Visual C++
public string FolderName { get; set; }
Public Property FolderName As String
    Get
    Set
public:
property String^ FolderName {
    String^ get ();
    void set (String^ value);
}


MyMessagesFolderType Constructor

MyMessagesFolderType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderType ► MyMessagesFolderType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderType()
Public Sub New
public:
MyMessagesFolderType()


MyMessagesForwardDetailsType Class

MyMessagesForwardDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► MyMessagesForwardDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyMessagesForwardDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyMessagesForwardDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyMessagesForwardDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyMessagesForwardDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | ForwardMessageEncoding |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UserForwardDate |
 | UserForwardDateSpecified |
Remarks
Inheritance Hierarchy
Object
MyMessagesForwardDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesForwardDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ForwardMessageEncoding Property

ForwardMessageEncoding Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesForwardDetailsType ► ForwardMessageEncoding
Declaration Syntax
C# Visual Basic Visual C++
public string ForwardMessageEncoding { get; set; }
Public Property ForwardMessageEncoding As String
    Get
    Set
public:
property String^ ForwardMessageEncoding {
    String^ get ();
    void set (String^ value);
}


MyMessagesForwardDetailsType Constructor

MyMessagesForwardDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesForwardDetailsType ► MyMessagesForwardDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesForwardDetailsType()
Public Sub New
public:
MyMessagesForwardDetailsType()


UserForwardDate Property

UserForwardDate Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesForwardDetailsType ► UserForwardDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UserForwardDate { get; set; }
Public Property UserForwardDate As DateTime
    Get
    Set
public:
property DateTime UserForwardDate {
    DateTime get ();
    void set (DateTime value);
}


UserForwardDateSpecified Property

UserForwardDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesForwardDetailsType ► UserForwardDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UserForwardDateSpecified { get; set; }
Public Property UserForwardDateSpecified As Boolean
    Get
    Set
public:
property bool UserForwardDateSpecified {
    bool get ();
    void set (bool value);
}


MyMessagesMessageType Class

MyMessagesMessageType Class
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyMessagesMessageType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyMessagesMessageType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyMessagesMessageType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyMessagesMessageType()()()() |
 | Any |
 | Content |
 | ContentType |
 | CreationDate |
 | CreationDateSpecified |
 | Equals(Object) | (Inherited from Object.)
 | ExpirationDate |
 | ExpirationDateSpecified |
 | ExternalMessageID |
 | Finalize()()()() | (Inherited from Object.)
 | Flagged |
 | FlaggedSpecified |
 | Folder |
 | ForwardDetails |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HighPriority |
 | HighPrioritySpecified |
 | ItemEndTime |
 | ItemEndTimeSpecified |
 | ItemID |
 | ItemTitle |
 | ListingStatus |
 | ListingStatusSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID |
 | MessageMedia |
 | MessageType |
 | MessageTypeSpecified |
 | QuestionType |
 | QuestionTypeSpecified |
 | Read |
 | ReadSpecified |
 | ReceiveDate |
 | ReceiveDateSpecified |
 | RecipientUserID |
 | Replied |
 | RepliedSpecified |
 | ResponseDetails |
 | Sender |
 | SendToName |
 | Subject |
 | Text |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MyMessagesMessageType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Content Property

Content Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► Content
Declaration Syntax
C# Visual Basic Visual C++
public string Content { get; set; }
Public Property Content As String
    Get
    Set
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}


ContentType Property

ContentType Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ContentType
Declaration Syntax
C# Visual Basic Visual C++
public string ContentType { get; set; }
Public Property ContentType As String
    Get
    Set
public:
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}


CreationDate Property

CreationDate Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► CreationDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreationDate { get; set; }
Public Property CreationDate As DateTime
    Get
    Set
public:
property DateTime CreationDate {
    DateTime get ();
    void set (DateTime value);
}


CreationDateSpecified Property

CreationDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► CreationDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreationDateSpecified { get; set; }
Public Property CreationDateSpecified As Boolean
    Get
    Set
public:
property bool CreationDateSpecified {
    bool get ();
    void set (bool value);
}


ExpirationDate Property

ExpirationDate Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ExpirationDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ExpirationDate { get; set; }
Public Property ExpirationDate As DateTime
    Get
    Set
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}


ExpirationDateSpecified Property

ExpirationDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ExpirationDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpirationDateSpecified { get; set; }
Public Property ExpirationDateSpecified As Boolean
    Get
    Set
public:
property bool ExpirationDateSpecified {
    bool get ();
    void set (bool value);
}


ExternalMessageID Property

ExternalMessageID Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ExternalMessageID
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalMessageID { get; set; }
Public Property ExternalMessageID As String
    Get
    Set
public:
property String^ ExternalMessageID {
    String^ get ();
    void set (String^ value);
}


Flagged Property

Flagged Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► Flagged
Declaration Syntax
C# Visual Basic Visual C++
public bool Flagged { get; set; }
Public Property Flagged As Boolean
    Get
    Set
public:
property bool Flagged {
    bool get ();
    void set (bool value);
}


FlaggedSpecified Property

FlaggedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► FlaggedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FlaggedSpecified { get; set; }
Public Property FlaggedSpecified As Boolean
    Get
    Set
public:
property bool FlaggedSpecified {
    bool get ();
    void set (bool value);
}


Folder Property

Folder Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► Folder
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderType Folder { get; set; }
Public Property Folder As MyMessagesFolderType
    Get
    Set
public:
property MyMessagesFolderType^ Folder {
    MyMessagesFolderType^ get ();
    void set (MyMessagesFolderType^ value);
}


ForwardDetails Property

ForwardDetails Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ForwardDetails
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesForwardDetailsType ForwardDetails { get; set; }
Public Property ForwardDetails As MyMessagesForwardDetailsType
    Get
    Set
public:
property MyMessagesForwardDetailsType^ ForwardDetails {
    MyMessagesForwardDetailsType^ get ();
    void set (MyMessagesForwardDetailsType^ value);
}


HighPriority Property

HighPriority Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► HighPriority
Declaration Syntax
C# Visual Basic Visual C++
public bool HighPriority { get; set; }
Public Property HighPriority As Boolean
    Get
    Set
public:
property bool HighPriority {
    bool get ();
    void set (bool value);
}


HighPrioritySpecified Property

HighPrioritySpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► HighPrioritySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HighPrioritySpecified { get; set; }
Public Property HighPrioritySpecified As Boolean
    Get
    Set
public:
property bool HighPrioritySpecified {
    bool get ();
    void set (bool value);
}


ItemEndTime Property

ItemEndTime Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ItemEndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ItemEndTime { get; set; }
Public Property ItemEndTime As DateTime
    Get
    Set
public:
property DateTime ItemEndTime {
    DateTime get ();
    void set (DateTime value);
}


ItemEndTimeSpecified Property

ItemEndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ItemEndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemEndTimeSpecified { get; set; }
Public Property ItemEndTimeSpecified As Boolean
    Get
    Set
public:
property bool ItemEndTimeSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ItemTitle Property

ItemTitle Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ItemTitle
Declaration Syntax
C# Visual Basic Visual C++
public string ItemTitle { get; set; }
Public Property ItemTitle As String
    Get
    Set
public:
property String^ ItemTitle {
    String^ get ();
    void set (String^ value);
}


ListingStatus Property

ListingStatus Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ListingStatus
Declaration Syntax
C# Visual Basic Visual C++
public ListingStatusCodeType ListingStatus { get; set; }
Public Property ListingStatus As ListingStatusCodeType
    Get
    Set
public:
property ListingStatusCodeType ListingStatus {
    ListingStatusCodeType get ();
    void set (ListingStatusCodeType value);
}


ListingStatusSpecified Property

ListingStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ListingStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingStatusSpecified { get; set; }
Public Property ListingStatusSpecified As Boolean
    Get
    Set
public:
property bool ListingStatusSpecified {
    bool get ();
    void set (bool value);
}


MessageID Property

MessageID Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► MessageID
Declaration Syntax
C# Visual Basic Visual C++
public string MessageID { get; set; }
Public Property MessageID As String
    Get
    Set
public:
property String^ MessageID {
    String^ get ();
    void set (String^ value);
}


MessageMedia Property

MessageMedia Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► MessageMedia
Declaration Syntax
C# Visual Basic Visual C++
public MessageMediaTypeCollection MessageMedia { get; set; }
Public Property MessageMedia As MessageMediaTypeCollection
    Get
    Set
public:
property MessageMediaTypeCollection^ MessageMedia {
    MessageMediaTypeCollection^ get ();
    void set (MessageMediaTypeCollection^ value);
}


MessageType Property

MessageType Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► MessageType
Declaration Syntax
C# Visual Basic Visual C++
public MessageTypeCodeType MessageType { get; set; }
Public Property MessageType As MessageTypeCodeType
    Get
    Set
public:
property MessageTypeCodeType MessageType {
    MessageTypeCodeType get ();
    void set (MessageTypeCodeType value);
}


MessageTypeSpecified Property

MessageTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► MessageTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageTypeSpecified { get; set; }
Public Property MessageTypeSpecified As Boolean
    Get
    Set
public:
property bool MessageTypeSpecified {
    bool get ();
    void set (bool value);
}


MyMessagesMessageType Constructor

MyMessagesMessageType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► MyMessagesMessageType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesMessageType()
Public Sub New
public:
MyMessagesMessageType()


QuestionType Property

QuestionType Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► QuestionType
Declaration Syntax
C# Visual Basic Visual C++
public QuestionTypeCodeType QuestionType { get; set; }
Public Property QuestionType As QuestionTypeCodeType
    Get
    Set
public:
property QuestionTypeCodeType QuestionType {
    QuestionTypeCodeType get ();
    void set (QuestionTypeCodeType value);
}


QuestionTypeSpecified Property

QuestionTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► QuestionTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuestionTypeSpecified { get; set; }
Public Property QuestionTypeSpecified As Boolean
    Get
    Set
public:
property bool QuestionTypeSpecified {
    bool get ();
    void set (bool value);
}


Read Property

Read Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► Read
Declaration Syntax
C# Visual Basic Visual C++
public bool Read { get; set; }
Public Property Read As Boolean
    Get
    Set
public:
property bool Read {
    bool get ();
    void set (bool value);
}


ReadSpecified Property

ReadSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ReadSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReadSpecified { get; set; }
Public Property ReadSpecified As Boolean
    Get
    Set
public:
property bool ReadSpecified {
    bool get ();
    void set (bool value);
}


ReceiveDate Property

ReceiveDate Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ReceiveDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ReceiveDate { get; set; }
Public Property ReceiveDate As DateTime
    Get
    Set
public:
property DateTime ReceiveDate {
    DateTime get ();
    void set (DateTime value);
}


ReceiveDateSpecified Property

ReceiveDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ReceiveDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReceiveDateSpecified { get; set; }
Public Property ReceiveDateSpecified As Boolean
    Get
    Set
public:
property bool ReceiveDateSpecified {
    bool get ();
    void set (bool value);
}


RecipientUserID Property

RecipientUserID Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► RecipientUserID
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientUserID { get; set; }
Public Property RecipientUserID As String
    Get
    Set
public:
property String^ RecipientUserID {
    String^ get ();
    void set (String^ value);
}


Replied Property

Replied Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► Replied
Declaration Syntax
C# Visual Basic Visual C++
public bool Replied { get; set; }
Public Property Replied As Boolean
    Get
    Set
public:
property bool Replied {
    bool get ();
    void set (bool value);
}


RepliedSpecified Property

RepliedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► RepliedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RepliedSpecified { get; set; }
Public Property RepliedSpecified As Boolean
    Get
    Set
public:
property bool RepliedSpecified {
    bool get ();
    void set (bool value);
}


ResponseDetails Property

ResponseDetails Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► ResponseDetails
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesResponseDetailsType ResponseDetails { get; set; }
Public Property ResponseDetails As MyMessagesResponseDetailsType
    Get
    Set
public:
property MyMessagesResponseDetailsType^ ResponseDetails {
    MyMessagesResponseDetailsType^ get ();
    void set (MyMessagesResponseDetailsType^ value);
}


Sender Property

Sender Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► Sender
Declaration Syntax
C# Visual Basic Visual C++
public string Sender { get; set; }
Public Property Sender As String
    Get
    Set
public:
property String^ Sender {
    String^ get ();
    void set (String^ value);
}


SendToName Property

SendToName Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► SendToName
Declaration Syntax
C# Visual Basic Visual C++
public string SendToName { get; set; }
Public Property SendToName As String
    Get
    Set
public:
property String^ SendToName {
    String^ get ();
    void set (String^ value);
}


Subject Property

Subject Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► Subject
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}


Text Property

Text Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageType ► Text
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}


MyMessagesMessageTypeCollection Class

MyMessagesMessageTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class MyMessagesMessageTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class MyMessagesMessageTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class MyMessagesMessageTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyMessagesMessageTypeCollection()()()() |
 | MyMessagesMessageTypeCollection(array<MyMessagesMessageType>[]()[][]) |
 | MyMessagesMessageTypeCollection(MyMessagesMessageTypeCollection) |
 | Add(MyMessagesMessageType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<MyMessagesMessageType>[]()[][]) |
 | AddRange(MyMessagesMessageTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(MyMessagesMessageType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<MyMessagesMessageType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(MyMessagesMessageType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, MyMessagesMessageType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(MyMessagesMessageType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | MyMessagesMessageTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► Add(MyMessagesMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    MyMessagesMessageType item
)
Public Function Add ( _
    item As MyMessagesMessageType _
) As Integer
public:
int Add(
    MyMessagesMessageType^ item
)
Parameters
item (MyMessagesMessageType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<MyMessagesMessageType>[]()[][]) |
 | AddRange(MyMessagesMessageTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► AddRange(array<MyMessagesMessageType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MyMessagesMessageType[] items
)
Public Sub AddRange ( _
    items As MyMessagesMessageType() _
)
public:
void AddRange(
    array<MyMessagesMessageType^>^ items
)
Parameters
items (array< MyMessagesMessageType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► AddRange(MyMessagesMessageTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    MyMessagesMessageTypeCollection items
)
Public Sub AddRange ( _
    items As MyMessagesMessageTypeCollection _
)
public:
void AddRange(
    MyMessagesMessageTypeCollection^ items
)
Parameters
items (MyMessagesMessageTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► Contains(MyMessagesMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    MyMessagesMessageType item
)
Public Function Contains ( _
    item As MyMessagesMessageType _
) As Boolean
public:
bool Contains(
    MyMessagesMessageType^ item
)
Parameters
item (MyMessagesMessageType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► CopyTo(array<MyMessagesMessageType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    MyMessagesMessageType[] items,
    int index
)
Public Sub CopyTo ( _
    items As MyMessagesMessageType(), _
    index As Integer _
)
public:
void CopyTo(
    array<MyMessagesMessageType^>^ items,
    int index
)
Parameters
items (array< MyMessagesMessageType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► IndexOf(MyMessagesMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    MyMessagesMessageType item
)
Public Function IndexOf ( _
    item As MyMessagesMessageType _
) As Integer
public:
int IndexOf(
    MyMessagesMessageType^ item
)
Parameters
item (MyMessagesMessageType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► Insert(Int32, MyMessagesMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    MyMessagesMessageType item
)
Public Sub Insert ( _
    index As Integer, _
    item As MyMessagesMessageType _
)
public:
void Insert(
    int index,
    MyMessagesMessageType^ item
)
Parameters
index (Int32)
item (MyMessagesMessageType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesMessageType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As MyMessagesMessageType
    Get
    Set
public:
property MyMessagesMessageType^ default[int index] {
    MyMessagesMessageType^ get (int index);
    void set (int index, MyMessagesMessageType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesMessageType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As MyMessagesMessageType
public:
MyMessagesMessageType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


MyMessagesMessageTypeCollection Constructor

MyMessagesMessageTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► MyMessagesMessageTypeCollection()()()()
Members
Icon | Member | Description
 | MyMessagesMessageTypeCollection()()()() |
 | MyMessagesMessageTypeCollection(array<MyMessagesMessageType>[]()[][]) |
 | MyMessagesMessageTypeCollection(MyMessagesMessageTypeCollection) |


MyMessagesMessageTypeCollection Constructor

MyMessagesMessageTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► MyMessagesMessageTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesMessageTypeCollection()
Public Sub New
public:
MyMessagesMessageTypeCollection()


MyMessagesMessageTypeCollection Constructor (items)

MyMessagesMessageTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► MyMessagesMessageTypeCollection(array<MyMessagesMessageType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesMessageTypeCollection(
    MyMessagesMessageType[] items
)
Public Sub New ( _
    items As MyMessagesMessageType() _
)
public:
MyMessagesMessageTypeCollection(
    array<MyMessagesMessageType^>^ items
)
Parameters
items (array< MyMessagesMessageType >[]()[][])


MyMessagesMessageTypeCollection Constructor (items)

MyMessagesMessageTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► MyMessagesMessageTypeCollection(MyMessagesMessageTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesMessageTypeCollection(
    MyMessagesMessageTypeCollection items
)
Public Sub New ( _
    items As MyMessagesMessageTypeCollection _
)
public:
MyMessagesMessageTypeCollection(
    MyMessagesMessageTypeCollection^ items
)
Parameters
items (MyMessagesMessageTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► Remove(MyMessagesMessageType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    MyMessagesMessageType item
)
Public Sub Remove ( _
    item As MyMessagesMessageType _
)
public:
void Remove(
    MyMessagesMessageType^ item
)
Parameters
item (MyMessagesMessageType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesMessageType[] ToArray()
Public Function ToArray As MyMessagesMessageType()
public:
array<MyMessagesMessageType^>^ ToArray()
Return Value


MyMessagesResponseDetailsType Class

MyMessagesResponseDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► MyMessagesResponseDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyMessagesResponseDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyMessagesResponseDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyMessagesResponseDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyMessagesResponseDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ResponseEnabled |
 | ResponseEnabledSpecified |
 | ResponseURL |
 | ToString()()()() | (Inherited from Object.)
 | UserResponseDate |
 | UserResponseDateSpecified |
Remarks
Inheritance Hierarchy
Object
MyMessagesResponseDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesResponseDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MyMessagesResponseDetailsType Constructor

MyMessagesResponseDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesResponseDetailsType ► MyMessagesResponseDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesResponseDetailsType()
Public Sub New
public:
MyMessagesResponseDetailsType()


ResponseEnabled Property

ResponseEnabled Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesResponseDetailsType ► ResponseEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ResponseEnabled { get; set; }
Public Property ResponseEnabled As Boolean
    Get
    Set
public:
property bool ResponseEnabled {
    bool get ();
    void set (bool value);
}


ResponseEnabledSpecified Property

ResponseEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesResponseDetailsType ► ResponseEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ResponseEnabledSpecified { get; set; }
Public Property ResponseEnabledSpecified As Boolean
    Get
    Set
public:
property bool ResponseEnabledSpecified {
    bool get ();
    void set (bool value);
}


ResponseURL Property

ResponseURL Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesResponseDetailsType ► ResponseURL
Declaration Syntax
C# Visual Basic Visual C++
public string ResponseURL { get; set; }
Public Property ResponseURL As String
    Get
    Set
public:
property String^ ResponseURL {
    String^ get ();
    void set (String^ value);
}


UserResponseDate Property

UserResponseDate Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesResponseDetailsType ► UserResponseDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UserResponseDate { get; set; }
Public Property UserResponseDate As DateTime
    Get
    Set
public:
property DateTime UserResponseDate {
    DateTime get ();
    void set (DateTime value);
}


UserResponseDateSpecified Property

UserResponseDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesResponseDetailsType ► UserResponseDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UserResponseDateSpecified { get; set; }
Public Property UserResponseDateSpecified As Boolean
    Get
    Set
public:
property bool UserResponseDateSpecified {
    bool get ();
    void set (bool value);
}


MyMessagesSummaryType Class

MyMessagesSummaryType Class
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class MyMessagesSummaryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class MyMessagesSummaryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class MyMessagesSummaryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MyMessagesSummaryType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FlaggedMessageCount |
 | FlaggedMessageCountSpecified |
 | FolderSummary |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NewAlertCount |
 | NewAlertCountSpecified |
 | NewHighPriorityCount |
 | NewHighPriorityCountSpecified |
 | NewMessageCount |
 | NewMessageCountSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TotalAlertCount |
 | TotalAlertCountSpecified |
 | TotalHighPriorityCount |
 | TotalHighPriorityCountSpecified |
 | TotalMessageCount |
 | TotalMessageCountSpecified |
 | UnresolvedAlertCount |
 | UnresolvedAlertCountSpecified |
Remarks
Inheritance Hierarchy
Object
MyMessagesSummaryType


FlaggedMessageCount Property

FlaggedMessageCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► FlaggedMessageCount
Declaration Syntax
C# Visual Basic Visual C++
public int FlaggedMessageCount { get; set; }
Public Property FlaggedMessageCount As Integer
    Get
    Set
public:
property int FlaggedMessageCount {
    int get ();
    void set (int value);
}


FlaggedMessageCountSpecified Property

FlaggedMessageCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► FlaggedMessageCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FlaggedMessageCountSpecified { get; set; }
Public Property FlaggedMessageCountSpecified As Boolean
    Get
    Set
public:
property bool FlaggedMessageCountSpecified {
    bool get ();
    void set (bool value);
}


FolderSummary Property

FolderSummary Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► FolderSummary
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderSummaryTypeCollection FolderSummary { get; set; }
Public Property FolderSummary As MyMessagesFolderSummaryTypeCollection
    Get
    Set
public:
property MyMessagesFolderSummaryTypeCollection^ FolderSummary {
    MyMessagesFolderSummaryTypeCollection^ get ();
    void set (MyMessagesFolderSummaryTypeCollection^ value);
}


MyMessagesSummaryType Constructor

MyMessagesSummaryType Constructor
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► MyMessagesSummaryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesSummaryType()
Public Sub New
public:
MyMessagesSummaryType()


NewAlertCount Property

NewAlertCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► NewAlertCount
Declaration Syntax
C# Visual Basic Visual C++
public int NewAlertCount { get; set; }
Public Property NewAlertCount As Integer
    Get
    Set
public:
property int NewAlertCount {
    int get ();
    void set (int value);
}


NewAlertCountSpecified Property

NewAlertCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► NewAlertCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewAlertCountSpecified { get; set; }
Public Property NewAlertCountSpecified As Boolean
    Get
    Set
public:
property bool NewAlertCountSpecified {
    bool get ();
    void set (bool value);
}


NewHighPriorityCount Property

NewHighPriorityCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► NewHighPriorityCount
Declaration Syntax
C# Visual Basic Visual C++
public int NewHighPriorityCount { get; set; }
Public Property NewHighPriorityCount As Integer
    Get
    Set
public:
property int NewHighPriorityCount {
    int get ();
    void set (int value);
}


NewHighPriorityCountSpecified Property

NewHighPriorityCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► NewHighPriorityCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewHighPriorityCountSpecified { get; set; }
Public Property NewHighPriorityCountSpecified As Boolean
    Get
    Set
public:
property bool NewHighPriorityCountSpecified {
    bool get ();
    void set (bool value);
}


NewMessageCount Property

NewMessageCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► NewMessageCount
Declaration Syntax
C# Visual Basic Visual C++
public int NewMessageCount { get; set; }
Public Property NewMessageCount As Integer
    Get
    Set
public:
property int NewMessageCount {
    int get ();
    void set (int value);
}


NewMessageCountSpecified Property

NewMessageCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► NewMessageCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewMessageCountSpecified { get; set; }
Public Property NewMessageCountSpecified As Boolean
    Get
    Set
public:
property bool NewMessageCountSpecified {
    bool get ();
    void set (bool value);
}


TotalAlertCount Property

TotalAlertCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► TotalAlertCount
Declaration Syntax
C# Visual Basic Visual C++
public int TotalAlertCount { get; set; }
Public Property TotalAlertCount As Integer
    Get
    Set
public:
property int TotalAlertCount {
    int get ();
    void set (int value);
}


TotalAlertCountSpecified Property

TotalAlertCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► TotalAlertCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalAlertCountSpecified { get; set; }
Public Property TotalAlertCountSpecified As Boolean
    Get
    Set
public:
property bool TotalAlertCountSpecified {
    bool get ();
    void set (bool value);
}


TotalHighPriorityCount Property

TotalHighPriorityCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► TotalHighPriorityCount
Declaration Syntax
C# Visual Basic Visual C++
public int TotalHighPriorityCount { get; set; }
Public Property TotalHighPriorityCount As Integer
    Get
    Set
public:
property int TotalHighPriorityCount {
    int get ();
    void set (int value);
}


TotalHighPriorityCountSpecified Property

TotalHighPriorityCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► TotalHighPriorityCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalHighPriorityCountSpecified { get; set; }
Public Property TotalHighPriorityCountSpecified As Boolean
    Get
    Set
public:
property bool TotalHighPriorityCountSpecified {
    bool get ();
    void set (bool value);
}


TotalMessageCount Property

TotalMessageCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► TotalMessageCount
Declaration Syntax
C# Visual Basic Visual C++
public int TotalMessageCount { get; set; }
Public Property TotalMessageCount As Integer
    Get
    Set
public:
property int TotalMessageCount {
    int get ();
    void set (int value);
}


TotalMessageCountSpecified Property

TotalMessageCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► TotalMessageCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalMessageCountSpecified { get; set; }
Public Property TotalMessageCountSpecified As Boolean
    Get
    Set
public:
property bool TotalMessageCountSpecified {
    bool get ();
    void set (bool value);
}


UnresolvedAlertCount Property

UnresolvedAlertCount Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► UnresolvedAlertCount
Declaration Syntax
C# Visual Basic Visual C++
public int UnresolvedAlertCount { get; set; }
Public Property UnresolvedAlertCount As Integer
    Get
    Set
public:
property int UnresolvedAlertCount {
    int get ();
    void set (int value);
}


UnresolvedAlertCountSpecified Property

UnresolvedAlertCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesSummaryType ► UnresolvedAlertCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UnresolvedAlertCountSpecified { get; set; }
Public Property UnresolvedAlertCountSpecified As Boolean
    Get
    Set
public:
property bool UnresolvedAlertCountSpecified {
    bool get ();
    void set (bool value);
}


NameRecommendationType Class

NameRecommendationType Class
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NameRecommendationType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NameRecommendationType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NameRecommendationType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NameRecommendationType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HelpText |
 | HelpURL |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | Source |
 | SourceSpecified |
 | ToString()()()() | (Inherited from Object.)
 | ValidationRules |
 | ValueRecommendation |
Remarks
Inheritance Hierarchy
Object
NameRecommendationType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


HelpText Property

HelpText Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationType ► HelpText
Declaration Syntax
C# Visual Basic Visual C++
public string HelpText { get; set; }
Public Property HelpText As String
    Get
    Set
public:
property String^ HelpText {
    String^ get ();
    void set (String^ value);
}


HelpURL Property

HelpURL Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationType ► HelpURL
Declaration Syntax
C# Visual Basic Visual C++
public string HelpURL { get; set; }
Public Property HelpURL As String
    Get
    Set
public:
property String^ HelpURL {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


NameRecommendationType Constructor

NameRecommendationType Constructor
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationType ► NameRecommendationType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NameRecommendationType()
Public Sub New
public:
NameRecommendationType()


Source Property

Source Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationType ► Source
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificSourceCodeType Source { get; set; }
Public Property Source As ItemSpecificSourceCodeType
    Get
    Set
public:
property ItemSpecificSourceCodeType Source {
    ItemSpecificSourceCodeType get ();
    void set (ItemSpecificSourceCodeType value);
}


SourceSpecified Property

SourceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationType ► SourceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SourceSpecified { get; set; }
Public Property SourceSpecified As Boolean
    Get
    Set
public:
property bool SourceSpecified {
    bool get ();
    void set (bool value);
}


ValidationRules Property

ValidationRules Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationType ► ValidationRules
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationValidationRulesType ValidationRules { get; set; }
Public Property ValidationRules As RecommendationValidationRulesType
    Get
    Set
public:
property RecommendationValidationRulesType^ ValidationRules {
    RecommendationValidationRulesType^ get ();
    void set (RecommendationValidationRulesType^ value);
}


ValueRecommendation Property

ValueRecommendation Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationType ► ValueRecommendation
Declaration Syntax
C# Visual Basic Visual C++
public ValueRecommendationTypeCollection ValueRecommendation { get; set; }
Public Property ValueRecommendation As ValueRecommendationTypeCollection
    Get
    Set
public:
property ValueRecommendationTypeCollection^ ValueRecommendation {
    ValueRecommendationTypeCollection^ get ();
    void set (ValueRecommendationTypeCollection^ value);
}


NameRecommendationTypeCollection Class

NameRecommendationTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class NameRecommendationTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class NameRecommendationTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class NameRecommendationTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NameRecommendationTypeCollection()()()() |
 | NameRecommendationTypeCollection(array<NameRecommendationType>[]()[][]) |
 | NameRecommendationTypeCollection(NameRecommendationTypeCollection) |
 | Add(NameRecommendationType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<NameRecommendationType>[]()[][]) |
 | AddRange(NameRecommendationTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(NameRecommendationType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<NameRecommendationType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(NameRecommendationType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, NameRecommendationType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(NameRecommendationType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | NameRecommendationTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► Add(NameRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    NameRecommendationType item
)
Public Function Add ( _
    item As NameRecommendationType _
) As Integer
public:
int Add(
    NameRecommendationType^ item
)
Parameters
item (NameRecommendationType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<NameRecommendationType>[]()[][]) |
 | AddRange(NameRecommendationTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► AddRange(array<NameRecommendationType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NameRecommendationType[] items
)
Public Sub AddRange ( _
    items As NameRecommendationType() _
)
public:
void AddRange(
    array<NameRecommendationType^>^ items
)
Parameters
items (array< NameRecommendationType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► AddRange(NameRecommendationTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NameRecommendationTypeCollection items
)
Public Sub AddRange ( _
    items As NameRecommendationTypeCollection _
)
public:
void AddRange(
    NameRecommendationTypeCollection^ items
)
Parameters
items (NameRecommendationTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► Contains(NameRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    NameRecommendationType item
)
Public Function Contains ( _
    item As NameRecommendationType _
) As Boolean
public:
bool Contains(
    NameRecommendationType^ item
)
Parameters
item (NameRecommendationType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► CopyTo(array<NameRecommendationType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    NameRecommendationType[] items,
    int index
)
Public Sub CopyTo ( _
    items As NameRecommendationType(), _
    index As Integer _
)
public:
void CopyTo(
    array<NameRecommendationType^>^ items,
    int index
)
Parameters
items (array< NameRecommendationType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► IndexOf(NameRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    NameRecommendationType item
)
Public Function IndexOf ( _
    item As NameRecommendationType _
) As Integer
public:
int IndexOf(
    NameRecommendationType^ item
)
Parameters
item (NameRecommendationType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► Insert(Int32, NameRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    NameRecommendationType item
)
Public Sub Insert ( _
    index As Integer, _
    item As NameRecommendationType _
)
public:
void Insert(
    int index,
    NameRecommendationType^ item
)
Parameters
index (Int32)
item (NameRecommendationType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public NameRecommendationType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As NameRecommendationType
    Get
    Set
public:
property NameRecommendationType^ default[int index] {
    NameRecommendationType^ get (int index);
    void set (int index, NameRecommendationType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public NameRecommendationType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As NameRecommendationType
public:
NameRecommendationType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


NameRecommendationTypeCollection Constructor

NameRecommendationTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► NameRecommendationTypeCollection()()()()
Members
Icon | Member | Description
 | NameRecommendationTypeCollection()()()() |
 | NameRecommendationTypeCollection(array<NameRecommendationType>[]()[][]) |
 | NameRecommendationTypeCollection(NameRecommendationTypeCollection) |


NameRecommendationTypeCollection Constructor

NameRecommendationTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► NameRecommendationTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NameRecommendationTypeCollection()
Public Sub New
public:
NameRecommendationTypeCollection()


NameRecommendationTypeCollection Constructor (items)

NameRecommendationTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► NameRecommendationTypeCollection(array<NameRecommendationType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public NameRecommendationTypeCollection(
    NameRecommendationType[] items
)
Public Sub New ( _
    items As NameRecommendationType() _
)
public:
NameRecommendationTypeCollection(
    array<NameRecommendationType^>^ items
)
Parameters
items (array< NameRecommendationType >[]()[][])


NameRecommendationTypeCollection Constructor (items)

NameRecommendationTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► NameRecommendationTypeCollection(NameRecommendationTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public NameRecommendationTypeCollection(
    NameRecommendationTypeCollection items
)
Public Sub New ( _
    items As NameRecommendationTypeCollection _
)
public:
NameRecommendationTypeCollection(
    NameRecommendationTypeCollection^ items
)
Parameters
items (NameRecommendationTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► Remove(NameRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    NameRecommendationType item
)
Public Sub Remove ( _
    item As NameRecommendationType _
)
public:
void Remove(
    NameRecommendationType^ item
)
Parameters
item (NameRecommendationType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NameRecommendationType[] ToArray()
Public Function ToArray As NameRecommendationType()
public:
array<NameRecommendationType^>^ ToArray()
Return Value


NameValueListType Class

NameValueListType Class
Namespaces ► eBay.Service.Core.Soap ► NameValueListType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NameValueListType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NameValueListType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NameValueListType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NameValueListType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | Source |
 | SourceSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Value |
Remarks
Inheritance Hierarchy
Object
NameValueListType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


NameValueListType Constructor

NameValueListType Constructor
Namespaces ► eBay.Service.Core.Soap ► NameValueListType ► NameValueListType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListType()
Public Sub New
public:
NameValueListType()


Source Property

Source Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListType ► Source
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificSourceCodeType Source { get; set; }
Public Property Source As ItemSpecificSourceCodeType
    Get
    Set
public:
property ItemSpecificSourceCodeType Source {
    ItemSpecificSourceCodeType get ();
    void set (ItemSpecificSourceCodeType value);
}


SourceSpecified Property

SourceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListType ► SourceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SourceSpecified { get; set; }
Public Property SourceSpecified As Boolean
    Get
    Set
public:
property bool SourceSpecified {
    bool get ();
    void set (bool value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection Value { get; set; }
Public Property Value As StringCollection
    Get
    Set
public:
property StringCollection^ Value {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


NameValueListTypeCollection Class

NameValueListTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class NameValueListTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class NameValueListTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class NameValueListTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NameValueListTypeCollection()()()() |
 | NameValueListTypeCollection(array<NameValueListType>[]()[][]) |
 | NameValueListTypeCollection(NameValueListTypeCollection) |
 | Add(NameValueListType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<NameValueListType>[]()[][]) |
 | AddRange(NameValueListTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(NameValueListType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<NameValueListType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(NameValueListType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, NameValueListType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(NameValueListType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | NameValueListTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► Add(NameValueListType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    NameValueListType item
)
Public Function Add ( _
    item As NameValueListType _
) As Integer
public:
int Add(
    NameValueListType^ item
)
Parameters
item (NameValueListType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<NameValueListType>[]()[][]) |
 | AddRange(NameValueListTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► AddRange(array<NameValueListType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NameValueListType[] items
)
Public Sub AddRange ( _
    items As NameValueListType() _
)
public:
void AddRange(
    array<NameValueListType^>^ items
)
Parameters
items (array< NameValueListType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► AddRange(NameValueListTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NameValueListTypeCollection items
)
Public Sub AddRange ( _
    items As NameValueListTypeCollection _
)
public:
void AddRange(
    NameValueListTypeCollection^ items
)
Parameters
items (NameValueListTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► Contains(NameValueListType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    NameValueListType item
)
Public Function Contains ( _
    item As NameValueListType _
) As Boolean
public:
bool Contains(
    NameValueListType^ item
)
Parameters
item (NameValueListType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► CopyTo(array<NameValueListType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    NameValueListType[] items,
    int index
)
Public Sub CopyTo ( _
    items As NameValueListType(), _
    index As Integer _
)
public:
void CopyTo(
    array<NameValueListType^>^ items,
    int index
)
Parameters
items (array< NameValueListType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► IndexOf(NameValueListType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    NameValueListType item
)
Public Function IndexOf ( _
    item As NameValueListType _
) As Integer
public:
int IndexOf(
    NameValueListType^ item
)
Parameters
item (NameValueListType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► Insert(Int32, NameValueListType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    NameValueListType item
)
Public Sub Insert ( _
    index As Integer, _
    item As NameValueListType _
)
public:
void Insert(
    int index,
    NameValueListType^ item
)
Parameters
index (Int32)
item (NameValueListType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As NameValueListType
    Get
    Set
public:
property NameValueListType^ default[int index] {
    NameValueListType^ get (int index);
    void set (int index, NameValueListType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As NameValueListType
public:
NameValueListType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


NameValueListTypeCollection Constructor

NameValueListTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► NameValueListTypeCollection()()()()
Members
Icon | Member | Description
 | NameValueListTypeCollection()()()() |
 | NameValueListTypeCollection(array<NameValueListType>[]()[][]) |
 | NameValueListTypeCollection(NameValueListTypeCollection) |


NameValueListTypeCollection Constructor

NameValueListTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► NameValueListTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection()
Public Sub New
public:
NameValueListTypeCollection()


NameValueListTypeCollection Constructor (items)

NameValueListTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► NameValueListTypeCollection(array<NameValueListType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection(
    NameValueListType[] items
)
Public Sub New ( _
    items As NameValueListType() _
)
public:
NameValueListTypeCollection(
    array<NameValueListType^>^ items
)
Parameters
items (array< NameValueListType >[]()[][])


NameValueListTypeCollection Constructor (items)

NameValueListTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► NameValueListTypeCollection(NameValueListTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection(
    NameValueListTypeCollection items
)
Public Sub New ( _
    items As NameValueListTypeCollection _
)
public:
NameValueListTypeCollection(
    NameValueListTypeCollection^ items
)
Parameters
items (NameValueListTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► Remove(NameValueListType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    NameValueListType item
)
Public Sub Remove ( _
    item As NameValueListType _
)
public:
void Remove(
    NameValueListType^ item
)
Parameters
item (NameValueListType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListType[] ToArray()
Public Function ToArray As NameValueListType()
public:
array<NameValueListType^>^ ToArray()
Return Value


NameValueRelationshipType Class

NameValueRelationshipType Class
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NameValueRelationshipType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NameValueRelationshipType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NameValueRelationshipType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NameValueRelationshipType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParentName |
 | ParentValue |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
NameValueRelationshipType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


NameValueRelationshipType Constructor

NameValueRelationshipType Constructor
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipType ► NameValueRelationshipType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NameValueRelationshipType()
Public Sub New
public:
NameValueRelationshipType()


ParentName Property

ParentName Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipType ► ParentName
Declaration Syntax
C# Visual Basic Visual C++
public string ParentName { get; set; }
Public Property ParentName As String
    Get
    Set
public:
property String^ ParentName {
    String^ get ();
    void set (String^ value);
}


ParentValue Property

ParentValue Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipType ► ParentValue
Declaration Syntax
C# Visual Basic Visual C++
public string ParentValue { get; set; }
Public Property ParentValue As String
    Get
    Set
public:
property String^ ParentValue {
    String^ get ();
    void set (String^ value);
}


NameValueRelationshipTypeCollection Class

NameValueRelationshipTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class NameValueRelationshipTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class NameValueRelationshipTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class NameValueRelationshipTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NameValueRelationshipTypeCollection()()()() |
 | NameValueRelationshipTypeCollection(array<NameValueRelationshipType>[]()[][]) |
 | NameValueRelationshipTypeCollection(NameValueRelationshipTypeCollection) |
 | Add(NameValueRelationshipType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<NameValueRelationshipType>[]()[][]) |
 | AddRange(NameValueRelationshipTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(NameValueRelationshipType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<NameValueRelationshipType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(NameValueRelationshipType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, NameValueRelationshipType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(NameValueRelationshipType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | NameValueRelationshipTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► Add(NameValueRelationshipType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    NameValueRelationshipType item
)
Public Function Add ( _
    item As NameValueRelationshipType _
) As Integer
public:
int Add(
    NameValueRelationshipType^ item
)
Parameters
item (NameValueRelationshipType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<NameValueRelationshipType>[]()[][]) |
 | AddRange(NameValueRelationshipTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► AddRange(array<NameValueRelationshipType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NameValueRelationshipType[] items
)
Public Sub AddRange ( _
    items As NameValueRelationshipType() _
)
public:
void AddRange(
    array<NameValueRelationshipType^>^ items
)
Parameters
items (array< NameValueRelationshipType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► AddRange(NameValueRelationshipTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NameValueRelationshipTypeCollection items
)
Public Sub AddRange ( _
    items As NameValueRelationshipTypeCollection _
)
public:
void AddRange(
    NameValueRelationshipTypeCollection^ items
)
Parameters
items (NameValueRelationshipTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► Contains(NameValueRelationshipType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    NameValueRelationshipType item
)
Public Function Contains ( _
    item As NameValueRelationshipType _
) As Boolean
public:
bool Contains(
    NameValueRelationshipType^ item
)
Parameters
item (NameValueRelationshipType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► CopyTo(array<NameValueRelationshipType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    NameValueRelationshipType[] items,
    int index
)
Public Sub CopyTo ( _
    items As NameValueRelationshipType(), _
    index As Integer _
)
public:
void CopyTo(
    array<NameValueRelationshipType^>^ items,
    int index
)
Parameters
items (array< NameValueRelationshipType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► IndexOf(NameValueRelationshipType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    NameValueRelationshipType item
)
Public Function IndexOf ( _
    item As NameValueRelationshipType _
) As Integer
public:
int IndexOf(
    NameValueRelationshipType^ item
)
Parameters
item (NameValueRelationshipType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► Insert(Int32, NameValueRelationshipType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    NameValueRelationshipType item
)
Public Sub Insert ( _
    index As Integer, _
    item As NameValueRelationshipType _
)
public:
void Insert(
    int index,
    NameValueRelationshipType^ item
)
Parameters
index (Int32)
item (NameValueRelationshipType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public NameValueRelationshipType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As NameValueRelationshipType
    Get
    Set
public:
property NameValueRelationshipType^ default[int index] {
    NameValueRelationshipType^ get (int index);
    void set (int index, NameValueRelationshipType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public NameValueRelationshipType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As NameValueRelationshipType
public:
NameValueRelationshipType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


NameValueRelationshipTypeCollection Constructor

NameValueRelationshipTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► NameValueRelationshipTypeCollection()()()()
Members
Icon | Member | Description
 | NameValueRelationshipTypeCollection()()()() |
 | NameValueRelationshipTypeCollection(array<NameValueRelationshipType>[]()[][]) |
 | NameValueRelationshipTypeCollection(NameValueRelationshipTypeCollection) |


NameValueRelationshipTypeCollection Constructor

NameValueRelationshipTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► NameValueRelationshipTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NameValueRelationshipTypeCollection()
Public Sub New
public:
NameValueRelationshipTypeCollection()


NameValueRelationshipTypeCollection Constructor (items)

NameValueRelationshipTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► NameValueRelationshipTypeCollection(array<NameValueRelationshipType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public NameValueRelationshipTypeCollection(
    NameValueRelationshipType[] items
)
Public Sub New ( _
    items As NameValueRelationshipType() _
)
public:
NameValueRelationshipTypeCollection(
    array<NameValueRelationshipType^>^ items
)
Parameters
items (array< NameValueRelationshipType >[]()[][])


NameValueRelationshipTypeCollection Constructor (items)

NameValueRelationshipTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► NameValueRelationshipTypeCollection(NameValueRelationshipTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public NameValueRelationshipTypeCollection(
    NameValueRelationshipTypeCollection items
)
Public Sub New ( _
    items As NameValueRelationshipTypeCollection _
)
public:
NameValueRelationshipTypeCollection(
    NameValueRelationshipTypeCollection^ items
)
Parameters
items (NameValueRelationshipTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► Remove(NameValueRelationshipType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    NameValueRelationshipType item
)
Public Sub Remove ( _
    item As NameValueRelationshipType _
)
public:
void Remove(
    NameValueRelationshipType^ item
)
Parameters
item (NameValueRelationshipType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NameValueRelationshipType[] ToArray()
Public Function ToArray As NameValueRelationshipType()
public:
array<NameValueRelationshipType^>^ ToArray()
Return Value


NonProfitAddressType Class

NonProfitAddressType Class
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NonProfitAddressType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NonProfitAddressType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NonProfitAddressType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NonProfitAddressType()()()() |
 | AddressLine1 |
 | AddressLine2 |
 | AddressType |
 | AddressTypeSpecified |
 | Any |
 | City |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Latitude |
 | LatitudeSpecified |
 | Longitude |
 | LongitudeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | State |
 | ToString()()()() | (Inherited from Object.)
 | ZipCode |
Remarks
Inheritance Hierarchy
Object
NonProfitAddressType


AddressLine1 Property

AddressLine1 Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► AddressLine1
Declaration Syntax
C# Visual Basic Visual C++
public string AddressLine1 { get; set; }
Public Property AddressLine1 As String
    Get
    Set
public:
property String^ AddressLine1 {
    String^ get ();
    void set (String^ value);
}


AddressLine2 Property

AddressLine2 Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► AddressLine2
Declaration Syntax
C# Visual Basic Visual C++
public string AddressLine2 { get; set; }
Public Property AddressLine2 As String
    Get
    Set
public:
property String^ AddressLine2 {
    String^ get ();
    void set (String^ value);
}


AddressType Property

AddressType Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► AddressType
Declaration Syntax
C# Visual Basic Visual C++
public AddressTypeCodeType AddressType { get; set; }
Public Property AddressType As AddressTypeCodeType
    Get
    Set
public:
property AddressTypeCodeType AddressType {
    AddressTypeCodeType get ();
    void set (AddressTypeCodeType value);
}


AddressTypeSpecified Property

AddressTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► AddressTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AddressTypeSpecified { get; set; }
Public Property AddressTypeSpecified As Boolean
    Get
    Set
public:
property bool AddressTypeSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


City Property

City Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► City
Declaration Syntax
C# Visual Basic Visual C++
public string City { get; set; }
Public Property City As String
    Get
    Set
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}


Latitude Property

Latitude Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► Latitude
Declaration Syntax
C# Visual Basic Visual C++
public decimal Latitude { get; set; }
Public Property Latitude As Decimal
    Get
    Set
public:
property Decimal Latitude {
    Decimal get ();
    void set (Decimal value);
}


LatitudeSpecified Property

LatitudeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► LatitudeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LatitudeSpecified { get; set; }
Public Property LatitudeSpecified As Boolean
    Get
    Set
public:
property bool LatitudeSpecified {
    bool get ();
    void set (bool value);
}


Longitude Property

Longitude Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► Longitude
Declaration Syntax
C# Visual Basic Visual C++
public decimal Longitude { get; set; }
Public Property Longitude As Decimal
    Get
    Set
public:
property Decimal Longitude {
    Decimal get ();
    void set (Decimal value);
}


LongitudeSpecified Property

LongitudeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► LongitudeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LongitudeSpecified { get; set; }
Public Property LongitudeSpecified As Boolean
    Get
    Set
public:
property bool LongitudeSpecified {
    bool get ();
    void set (bool value);
}


NonProfitAddressType Constructor

NonProfitAddressType Constructor
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► NonProfitAddressType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitAddressType()
Public Sub New
public:
NonProfitAddressType()


State Property

State Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► State
Declaration Syntax
C# Visual Basic Visual C++
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}


ZipCode Property

ZipCode Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressType ► ZipCode
Declaration Syntax
C# Visual Basic Visual C++
public string ZipCode { get; set; }
Public Property ZipCode As String
    Get
    Set
public:
property String^ ZipCode {
    String^ get ();
    void set (String^ value);
}


NonProfitAddressTypeCollection Class

NonProfitAddressTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class NonProfitAddressTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class NonProfitAddressTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class NonProfitAddressTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NonProfitAddressTypeCollection()()()() |
 | NonProfitAddressTypeCollection(array<NonProfitAddressType>[]()[][]) |
 | NonProfitAddressTypeCollection(NonProfitAddressTypeCollection) |
 | Add(NonProfitAddressType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<NonProfitAddressType>[]()[][]) |
 | AddRange(NonProfitAddressTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(NonProfitAddressType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<NonProfitAddressType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(NonProfitAddressType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, NonProfitAddressType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(NonProfitAddressType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | NonProfitAddressTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► Add(NonProfitAddressType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    NonProfitAddressType item
)
Public Function Add ( _
    item As NonProfitAddressType _
) As Integer
public:
int Add(
    NonProfitAddressType^ item
)
Parameters
item (NonProfitAddressType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<NonProfitAddressType>[]()[][]) |
 | AddRange(NonProfitAddressTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► AddRange(array<NonProfitAddressType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NonProfitAddressType[] items
)
Public Sub AddRange ( _
    items As NonProfitAddressType() _
)
public:
void AddRange(
    array<NonProfitAddressType^>^ items
)
Parameters
items (array< NonProfitAddressType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► AddRange(NonProfitAddressTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NonProfitAddressTypeCollection items
)
Public Sub AddRange ( _
    items As NonProfitAddressTypeCollection _
)
public:
void AddRange(
    NonProfitAddressTypeCollection^ items
)
Parameters
items (NonProfitAddressTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► Contains(NonProfitAddressType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    NonProfitAddressType item
)
Public Function Contains ( _
    item As NonProfitAddressType _
) As Boolean
public:
bool Contains(
    NonProfitAddressType^ item
)
Parameters
item (NonProfitAddressType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► CopyTo(array<NonProfitAddressType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    NonProfitAddressType[] items,
    int index
)
Public Sub CopyTo ( _
    items As NonProfitAddressType(), _
    index As Integer _
)
public:
void CopyTo(
    array<NonProfitAddressType^>^ items,
    int index
)
Parameters
items (array< NonProfitAddressType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► IndexOf(NonProfitAddressType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    NonProfitAddressType item
)
Public Function IndexOf ( _
    item As NonProfitAddressType _
) As Integer
public:
int IndexOf(
    NonProfitAddressType^ item
)
Parameters
item (NonProfitAddressType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► Insert(Int32, NonProfitAddressType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    NonProfitAddressType item
)
Public Sub Insert ( _
    index As Integer, _
    item As NonProfitAddressType _
)
public:
void Insert(
    int index,
    NonProfitAddressType^ item
)
Parameters
index (Int32)
item (NonProfitAddressType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitAddressType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As NonProfitAddressType
    Get
    Set
public:
property NonProfitAddressType^ default[int index] {
    NonProfitAddressType^ get (int index);
    void set (int index, NonProfitAddressType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitAddressType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As NonProfitAddressType
public:
NonProfitAddressType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


NonProfitAddressTypeCollection Constructor

NonProfitAddressTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► NonProfitAddressTypeCollection()()()()
Members
Icon | Member | Description
 | NonProfitAddressTypeCollection()()()() |
 | NonProfitAddressTypeCollection(array<NonProfitAddressType>[]()[][]) |
 | NonProfitAddressTypeCollection(NonProfitAddressTypeCollection) |


NonProfitAddressTypeCollection Constructor

NonProfitAddressTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► NonProfitAddressTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitAddressTypeCollection()
Public Sub New
public:
NonProfitAddressTypeCollection()


NonProfitAddressTypeCollection Constructor (items)

NonProfitAddressTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► NonProfitAddressTypeCollection(array<NonProfitAddressType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitAddressTypeCollection(
    NonProfitAddressType[] items
)
Public Sub New ( _
    items As NonProfitAddressType() _
)
public:
NonProfitAddressTypeCollection(
    array<NonProfitAddressType^>^ items
)
Parameters
items (array< NonProfitAddressType >[]()[][])


NonProfitAddressTypeCollection Constructor (items)

NonProfitAddressTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► NonProfitAddressTypeCollection(NonProfitAddressTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitAddressTypeCollection(
    NonProfitAddressTypeCollection items
)
Public Sub New ( _
    items As NonProfitAddressTypeCollection _
)
public:
NonProfitAddressTypeCollection(
    NonProfitAddressTypeCollection^ items
)
Parameters
items (NonProfitAddressTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► Remove(NonProfitAddressType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    NonProfitAddressType item
)
Public Sub Remove ( _
    item As NonProfitAddressType _
)
public:
void Remove(
    NonProfitAddressType^ item
)
Parameters
item (NonProfitAddressType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitAddressType[] ToArray()
Public Function ToArray As NonProfitAddressType()
public:
array<NonProfitAddressType^>^ ToArray()
Return Value


NonProfitSocialAddressType Class

NonProfitSocialAddressType Class
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NonProfitSocialAddressType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NonProfitSocialAddressType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NonProfitSocialAddressType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NonProfitSocialAddressType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SocialAddressId |
 | SocialAddressType |
 | SocialAddressTypeSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
NonProfitSocialAddressType


NonProfitSocialAddressType Constructor

NonProfitSocialAddressType Constructor
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressType ► NonProfitSocialAddressType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitSocialAddressType()
Public Sub New
public:
NonProfitSocialAddressType()


SocialAddressId Property

SocialAddressId Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressType ► SocialAddressId
Declaration Syntax
C# Visual Basic Visual C++
public string SocialAddressId { get; set; }
Public Property SocialAddressId As String
    Get
    Set
public:
property String^ SocialAddressId {
    String^ get ();
    void set (String^ value);
}


SocialAddressType Property

SocialAddressType Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressType ► SocialAddressType
Declaration Syntax
C# Visual Basic Visual C++
public SocialAddressTypeCodeType SocialAddressType { get; set; }
Public Property SocialAddressType As SocialAddressTypeCodeType
    Get
    Set
public:
property SocialAddressTypeCodeType SocialAddressType {
    SocialAddressTypeCodeType get ();
    void set (SocialAddressTypeCodeType value);
}


SocialAddressTypeSpecified Property

SocialAddressTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressType ► SocialAddressTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SocialAddressTypeSpecified { get; set; }
Public Property SocialAddressTypeSpecified As Boolean
    Get
    Set
public:
property bool SocialAddressTypeSpecified {
    bool get ();
    void set (bool value);
}


NonProfitSocialAddressTypeCollection Class

NonProfitSocialAddressTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class NonProfitSocialAddressTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class NonProfitSocialAddressTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class NonProfitSocialAddressTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NonProfitSocialAddressTypeCollection()()()() |
 | NonProfitSocialAddressTypeCollection(array<NonProfitSocialAddressType>[]()[][]) |
 | NonProfitSocialAddressTypeCollection(NonProfitSocialAddressTypeCollection) |
 | Add(NonProfitSocialAddressType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<NonProfitSocialAddressType>[]()[][]) |
 | AddRange(NonProfitSocialAddressTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(NonProfitSocialAddressType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<NonProfitSocialAddressType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(NonProfitSocialAddressType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, NonProfitSocialAddressType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(NonProfitSocialAddressType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | NonProfitSocialAddressTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► Add(NonProfitSocialAddressType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    NonProfitSocialAddressType item
)
Public Function Add ( _
    item As NonProfitSocialAddressType _
) As Integer
public:
int Add(
    NonProfitSocialAddressType^ item
)
Parameters
item (NonProfitSocialAddressType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<NonProfitSocialAddressType>[]()[][]) |
 | AddRange(NonProfitSocialAddressTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► AddRange(array<NonProfitSocialAddressType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NonProfitSocialAddressType[] items
)
Public Sub AddRange ( _
    items As NonProfitSocialAddressType() _
)
public:
void AddRange(
    array<NonProfitSocialAddressType^>^ items
)
Parameters
items (array< NonProfitSocialAddressType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► AddRange(NonProfitSocialAddressTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NonProfitSocialAddressTypeCollection items
)
Public Sub AddRange ( _
    items As NonProfitSocialAddressTypeCollection _
)
public:
void AddRange(
    NonProfitSocialAddressTypeCollection^ items
)
Parameters
items (NonProfitSocialAddressTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► Contains(NonProfitSocialAddressType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    NonProfitSocialAddressType item
)
Public Function Contains ( _
    item As NonProfitSocialAddressType _
) As Boolean
public:
bool Contains(
    NonProfitSocialAddressType^ item
)
Parameters
item (NonProfitSocialAddressType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► CopyTo(array<NonProfitSocialAddressType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    NonProfitSocialAddressType[] items,
    int index
)
Public Sub CopyTo ( _
    items As NonProfitSocialAddressType(), _
    index As Integer _
)
public:
void CopyTo(
    array<NonProfitSocialAddressType^>^ items,
    int index
)
Parameters
items (array< NonProfitSocialAddressType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► IndexOf(NonProfitSocialAddressType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    NonProfitSocialAddressType item
)
Public Function IndexOf ( _
    item As NonProfitSocialAddressType _
) As Integer
public:
int IndexOf(
    NonProfitSocialAddressType^ item
)
Parameters
item (NonProfitSocialAddressType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► Insert(Int32, NonProfitSocialAddressType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    NonProfitSocialAddressType item
)
Public Sub Insert ( _
    index As Integer, _
    item As NonProfitSocialAddressType _
)
public:
void Insert(
    int index,
    NonProfitSocialAddressType^ item
)
Parameters
index (Int32)
item (NonProfitSocialAddressType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitSocialAddressType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As NonProfitSocialAddressType
    Get
    Set
public:
property NonProfitSocialAddressType^ default[int index] {
    NonProfitSocialAddressType^ get (int index);
    void set (int index, NonProfitSocialAddressType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitSocialAddressType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As NonProfitSocialAddressType
public:
NonProfitSocialAddressType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


NonProfitSocialAddressTypeCollection Constructor

NonProfitSocialAddressTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► NonProfitSocialAddressTypeCollection()()()()
Members
Icon | Member | Description
 | NonProfitSocialAddressTypeCollection()()()() |
 | NonProfitSocialAddressTypeCollection(array<NonProfitSocialAddressType>[]()[][]) |
 | NonProfitSocialAddressTypeCollection(NonProfitSocialAddressTypeCollection) |


NonProfitSocialAddressTypeCollection Constructor

NonProfitSocialAddressTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► NonProfitSocialAddressTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitSocialAddressTypeCollection()
Public Sub New
public:
NonProfitSocialAddressTypeCollection()


NonProfitSocialAddressTypeCollection Constructor (items)

NonProfitSocialAddressTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► NonProfitSocialAddressTypeCollection(array<NonProfitSocialAddressType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitSocialAddressTypeCollection(
    NonProfitSocialAddressType[] items
)
Public Sub New ( _
    items As NonProfitSocialAddressType() _
)
public:
NonProfitSocialAddressTypeCollection(
    array<NonProfitSocialAddressType^>^ items
)
Parameters
items (array< NonProfitSocialAddressType >[]()[][])


NonProfitSocialAddressTypeCollection Constructor (items)

NonProfitSocialAddressTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► NonProfitSocialAddressTypeCollection(NonProfitSocialAddressTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitSocialAddressTypeCollection(
    NonProfitSocialAddressTypeCollection items
)
Public Sub New ( _
    items As NonProfitSocialAddressTypeCollection _
)
public:
NonProfitSocialAddressTypeCollection(
    NonProfitSocialAddressTypeCollection^ items
)
Parameters
items (NonProfitSocialAddressTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► Remove(NonProfitSocialAddressType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    NonProfitSocialAddressType item
)
Public Sub Remove ( _
    item As NonProfitSocialAddressType _
)
public:
void Remove(
    NonProfitSocialAddressType^ item
)
Parameters
item (NonProfitSocialAddressType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NonProfitSocialAddressType[] ToArray()
Public Function ToArray As NonProfitSocialAddressType()
public:
array<NonProfitSocialAddressType^>^ ToArray()
Return Value


NonSubscriptionDefinitionType Class

NonSubscriptionDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► NonSubscriptionDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NonSubscriptionDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NonSubscriptionDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NonSubscriptionDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NonSubscriptionDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
NonSubscriptionDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► NonSubscriptionDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


NonSubscriptionDefinitionType Constructor

NonSubscriptionDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► NonSubscriptionDefinitionType ► NonSubscriptionDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NonSubscriptionDefinitionType()
Public Sub New
public:
NonSubscriptionDefinitionType()


NotificationDetailsType Class

NotificationDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NotificationDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NotificationDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NotificationDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationDetailsType()()()() |
 | Any |
 | DeliveryStatus |
 | DeliveryStatusSpecified |
 | DeliveryTime |
 | DeliveryTimeSpecified |
 | DeliveryURL |
 | DeliveryURLName |
 | Equals(Object) | (Inherited from Object.)
 | ErrorMessage |
 | ExpirationTime |
 | ExpirationTimeSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NextRetryTime |
 | NextRetryTimeSpecified |
 | ReferenceID |
 | Retries |
 | RetriesSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | TypeSpecified |
Remarks
Inheritance Hierarchy
Object
NotificationDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DeliveryStatus Property

DeliveryStatus Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► DeliveryStatus
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventStateCodeType DeliveryStatus { get; set; }
Public Property DeliveryStatus As NotificationEventStateCodeType
    Get
    Set
public:
property NotificationEventStateCodeType DeliveryStatus {
    NotificationEventStateCodeType get ();
    void set (NotificationEventStateCodeType value);
}


DeliveryStatusSpecified Property

DeliveryStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► DeliveryStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeliveryStatusSpecified { get; set; }
Public Property DeliveryStatusSpecified As Boolean
    Get
    Set
public:
property bool DeliveryStatusSpecified {
    bool get ();
    void set (bool value);
}


DeliveryTime Property

DeliveryTime Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► DeliveryTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DeliveryTime { get; set; }
Public Property DeliveryTime As DateTime
    Get
    Set
public:
property DateTime DeliveryTime {
    DateTime get ();
    void set (DateTime value);
}


DeliveryTimeSpecified Property

DeliveryTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► DeliveryTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeliveryTimeSpecified { get; set; }
Public Property DeliveryTimeSpecified As Boolean
    Get
    Set
public:
property bool DeliveryTimeSpecified {
    bool get ();
    void set (bool value);
}


DeliveryURL Property

DeliveryURL Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► DeliveryURL
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryURL { get; set; }
Public Property DeliveryURL As String
    Get
    Set
public:
property String^ DeliveryURL {
    String^ get ();
    void set (String^ value);
}


DeliveryURLName Property

DeliveryURLName Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► DeliveryURLName
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryURLName { get; set; }
Public Property DeliveryURLName As String
    Get
    Set
public:
property String^ DeliveryURLName {
    String^ get ();
    void set (String^ value);
}


ErrorMessage Property

ErrorMessage Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► ErrorMessage
Declaration Syntax
C# Visual Basic Visual C++
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
    Get
    Set
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}


ExpirationTime Property

ExpirationTime Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► ExpirationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ExpirationTime { get; set; }
Public Property ExpirationTime As DateTime
    Get
    Set
public:
property DateTime ExpirationTime {
    DateTime get ();
    void set (DateTime value);
}


ExpirationTimeSpecified Property

ExpirationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► ExpirationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpirationTimeSpecified { get; set; }
Public Property ExpirationTimeSpecified As Boolean
    Get
    Set
public:
property bool ExpirationTimeSpecified {
    bool get ();
    void set (bool value);
}


NextRetryTime Property

NextRetryTime Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► NextRetryTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime NextRetryTime { get; set; }
Public Property NextRetryTime As DateTime
    Get
    Set
public:
property DateTime NextRetryTime {
    DateTime get ();
    void set (DateTime value);
}


NextRetryTimeSpecified Property

NextRetryTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► NextRetryTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NextRetryTimeSpecified { get; set; }
Public Property NextRetryTimeSpecified As Boolean
    Get
    Set
public:
property bool NextRetryTimeSpecified {
    bool get ();
    void set (bool value);
}


NotificationDetailsType Constructor

NotificationDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► NotificationDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationDetailsType()
Public Sub New
public:
NotificationDetailsType()


ReferenceID Property

ReferenceID Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► ReferenceID
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceID { get; set; }
Public Property ReferenceID As String
    Get
    Set
public:
property String^ ReferenceID {
    String^ get ();
    void set (String^ value);
}


Retries Property

Retries Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► Retries
Declaration Syntax
C# Visual Basic Visual C++
public int Retries { get; set; }
Public Property Retries As Integer
    Get
    Set
public:
property int Retries {
    int get ();
    void set (int value);
}


RetriesSpecified Property

RetriesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► RetriesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RetriesSpecified { get; set; }
Public Property RetriesSpecified As Boolean
    Get
    Set
public:
property bool RetriesSpecified {
    bool get ();
    void set (bool value);
}


Type Property

Type Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► Type
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventTypeCodeType Type { get; set; }
Public Property Type As NotificationEventTypeCodeType
    Get
    Set
public:
property NotificationEventTypeCodeType Type {
    NotificationEventTypeCodeType get ();
    void set (NotificationEventTypeCodeType value);
}


TypeSpecified Property

TypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsType ► TypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TypeSpecified { get; set; }
Public Property TypeSpecified As Boolean
    Get
    Set
public:
property bool TypeSpecified {
    bool get ();
    void set (bool value);
}


NotificationDetailsTypeCollection Class

NotificationDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class NotificationDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class NotificationDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class NotificationDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationDetailsTypeCollection()()()() |
 | NotificationDetailsTypeCollection(array<NotificationDetailsType>[]()[][]) |
 | NotificationDetailsTypeCollection(NotificationDetailsTypeCollection) |
 | Add(NotificationDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<NotificationDetailsType>[]()[][]) |
 | AddRange(NotificationDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(NotificationDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<NotificationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(NotificationDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, NotificationDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(NotificationDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | NotificationDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► Add(NotificationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    NotificationDetailsType item
)
Public Function Add ( _
    item As NotificationDetailsType _
) As Integer
public:
int Add(
    NotificationDetailsType^ item
)
Parameters
item (NotificationDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<NotificationDetailsType>[]()[][]) |
 | AddRange(NotificationDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► AddRange(array<NotificationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NotificationDetailsType[] items
)
Public Sub AddRange ( _
    items As NotificationDetailsType() _
)
public:
void AddRange(
    array<NotificationDetailsType^>^ items
)
Parameters
items (array< NotificationDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► AddRange(NotificationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NotificationDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As NotificationDetailsTypeCollection _
)
public:
void AddRange(
    NotificationDetailsTypeCollection^ items
)
Parameters
items (NotificationDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► Contains(NotificationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    NotificationDetailsType item
)
Public Function Contains ( _
    item As NotificationDetailsType _
) As Boolean
public:
bool Contains(
    NotificationDetailsType^ item
)
Parameters
item (NotificationDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► CopyTo(array<NotificationDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    NotificationDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As NotificationDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<NotificationDetailsType^>^ items,
    int index
)
Parameters
items (array< NotificationDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► IndexOf(NotificationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    NotificationDetailsType item
)
Public Function IndexOf ( _
    item As NotificationDetailsType _
) As Integer
public:
int IndexOf(
    NotificationDetailsType^ item
)
Parameters
item (NotificationDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► Insert(Int32, NotificationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    NotificationDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As NotificationDetailsType _
)
public:
void Insert(
    int index,
    NotificationDetailsType^ item
)
Parameters
index (Int32)
item (NotificationDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public NotificationDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As NotificationDetailsType
    Get
    Set
public:
property NotificationDetailsType^ default[int index] {
    NotificationDetailsType^ get (int index);
    void set (int index, NotificationDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public NotificationDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As NotificationDetailsType
public:
NotificationDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


NotificationDetailsTypeCollection Constructor

NotificationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► NotificationDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | NotificationDetailsTypeCollection()()()() |
 | NotificationDetailsTypeCollection(array<NotificationDetailsType>[]()[][]) |
 | NotificationDetailsTypeCollection(NotificationDetailsTypeCollection) |


NotificationDetailsTypeCollection Constructor

NotificationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► NotificationDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationDetailsTypeCollection()
Public Sub New
public:
NotificationDetailsTypeCollection()


NotificationDetailsTypeCollection Constructor (items)

NotificationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► NotificationDetailsTypeCollection(array<NotificationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public NotificationDetailsTypeCollection(
    NotificationDetailsType[] items
)
Public Sub New ( _
    items As NotificationDetailsType() _
)
public:
NotificationDetailsTypeCollection(
    array<NotificationDetailsType^>^ items
)
Parameters
items (array< NotificationDetailsType >[]()[][])


NotificationDetailsTypeCollection Constructor (items)

NotificationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► NotificationDetailsTypeCollection(NotificationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public NotificationDetailsTypeCollection(
    NotificationDetailsTypeCollection items
)
Public Sub New ( _
    items As NotificationDetailsTypeCollection _
)
public:
NotificationDetailsTypeCollection(
    NotificationDetailsTypeCollection^ items
)
Parameters
items (NotificationDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► Remove(NotificationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    NotificationDetailsType item
)
Public Sub Remove ( _
    item As NotificationDetailsType _
)
public:
void Remove(
    NotificationDetailsType^ item
)
Parameters
item (NotificationDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationDetailsType[] ToArray()
Public Function ToArray As NotificationDetailsType()
public:
array<NotificationDetailsType^>^ ToArray()
Return Value


NotificationEnableType Class

NotificationEnableType Class
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NotificationEnableType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NotificationEnableType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NotificationEnableType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationEnableType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | EventEnable |
 | EventEnableSpecified |
 | EventType |
 | EventTypeSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
NotificationEnableType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EventEnable Property

EventEnable Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableType ► EventEnable
Declaration Syntax
C# Visual Basic Visual C++
public EnableCodeType EventEnable { get; set; }
Public Property EventEnable As EnableCodeType
    Get
    Set
public:
property EnableCodeType EventEnable {
    EnableCodeType get ();
    void set (EnableCodeType value);
}


EventEnableSpecified Property

EventEnableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableType ► EventEnableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EventEnableSpecified { get; set; }
Public Property EventEnableSpecified As Boolean
    Get
    Set
public:
property bool EventEnableSpecified {
    bool get ();
    void set (bool value);
}


EventType Property

EventType Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableType ► EventType
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventTypeCodeType EventType { get; set; }
Public Property EventType As NotificationEventTypeCodeType
    Get
    Set
public:
property NotificationEventTypeCodeType EventType {
    NotificationEventTypeCodeType get ();
    void set (NotificationEventTypeCodeType value);
}


EventTypeSpecified Property

EventTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableType ► EventTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EventTypeSpecified { get; set; }
Public Property EventTypeSpecified As Boolean
    Get
    Set
public:
property bool EventTypeSpecified {
    bool get ();
    void set (bool value);
}


NotificationEnableType Constructor

NotificationEnableType Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableType ► NotificationEnableType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEnableType()
Public Sub New
public:
NotificationEnableType()


NotificationEnableTypeCollection Class

NotificationEnableTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class NotificationEnableTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class NotificationEnableTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class NotificationEnableTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationEnableTypeCollection()()()() |
 | NotificationEnableTypeCollection(array<NotificationEnableType>[]()[][]) |
 | NotificationEnableTypeCollection(NotificationEnableTypeCollection) |
 | Add(NotificationEnableType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<NotificationEnableType>[]()[][]) |
 | AddRange(NotificationEnableTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(NotificationEnableType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<NotificationEnableType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(NotificationEnableType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, NotificationEnableType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(NotificationEnableType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | NotificationEnableTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► Add(NotificationEnableType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    NotificationEnableType item
)
Public Function Add ( _
    item As NotificationEnableType _
) As Integer
public:
int Add(
    NotificationEnableType^ item
)
Parameters
item (NotificationEnableType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<NotificationEnableType>[]()[][]) |
 | AddRange(NotificationEnableTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► AddRange(array<NotificationEnableType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NotificationEnableType[] items
)
Public Sub AddRange ( _
    items As NotificationEnableType() _
)
public:
void AddRange(
    array<NotificationEnableType^>^ items
)
Parameters
items (array< NotificationEnableType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► AddRange(NotificationEnableTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NotificationEnableTypeCollection items
)
Public Sub AddRange ( _
    items As NotificationEnableTypeCollection _
)
public:
void AddRange(
    NotificationEnableTypeCollection^ items
)
Parameters
items (NotificationEnableTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► Contains(NotificationEnableType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    NotificationEnableType item
)
Public Function Contains ( _
    item As NotificationEnableType _
) As Boolean
public:
bool Contains(
    NotificationEnableType^ item
)
Parameters
item (NotificationEnableType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► CopyTo(array<NotificationEnableType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    NotificationEnableType[] items,
    int index
)
Public Sub CopyTo ( _
    items As NotificationEnableType(), _
    index As Integer _
)
public:
void CopyTo(
    array<NotificationEnableType^>^ items,
    int index
)
Parameters
items (array< NotificationEnableType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► IndexOf(NotificationEnableType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    NotificationEnableType item
)
Public Function IndexOf ( _
    item As NotificationEnableType _
) As Integer
public:
int IndexOf(
    NotificationEnableType^ item
)
Parameters
item (NotificationEnableType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► Insert(Int32, NotificationEnableType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    NotificationEnableType item
)
Public Sub Insert ( _
    index As Integer, _
    item As NotificationEnableType _
)
public:
void Insert(
    int index,
    NotificationEnableType^ item
)
Parameters
index (Int32)
item (NotificationEnableType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEnableType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As NotificationEnableType
    Get
    Set
public:
property NotificationEnableType^ default[int index] {
    NotificationEnableType^ get (int index);
    void set (int index, NotificationEnableType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEnableType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As NotificationEnableType
public:
NotificationEnableType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


NotificationEnableTypeCollection Constructor

NotificationEnableTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► NotificationEnableTypeCollection()()()()
Members
Icon | Member | Description
 | NotificationEnableTypeCollection()()()() |
 | NotificationEnableTypeCollection(array<NotificationEnableType>[]()[][]) |
 | NotificationEnableTypeCollection(NotificationEnableTypeCollection) |


NotificationEnableTypeCollection Constructor

NotificationEnableTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► NotificationEnableTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEnableTypeCollection()
Public Sub New
public:
NotificationEnableTypeCollection()


NotificationEnableTypeCollection Constructor (items)

NotificationEnableTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► NotificationEnableTypeCollection(array<NotificationEnableType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEnableTypeCollection(
    NotificationEnableType[] items
)
Public Sub New ( _
    items As NotificationEnableType() _
)
public:
NotificationEnableTypeCollection(
    array<NotificationEnableType^>^ items
)
Parameters
items (array< NotificationEnableType >[]()[][])


NotificationEnableTypeCollection Constructor (items)

NotificationEnableTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► NotificationEnableTypeCollection(NotificationEnableTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEnableTypeCollection(
    NotificationEnableTypeCollection items
)
Public Sub New ( _
    items As NotificationEnableTypeCollection _
)
public:
NotificationEnableTypeCollection(
    NotificationEnableTypeCollection^ items
)
Parameters
items (NotificationEnableTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► Remove(NotificationEnableType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    NotificationEnableType item
)
Public Sub Remove ( _
    item As NotificationEnableType _
)
public:
void Remove(
    NotificationEnableType^ item
)
Parameters
item (NotificationEnableType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEnableType[] ToArray()
Public Function ToArray As NotificationEnableType()
public:
array<NotificationEnableType^>^ ToArray()
Return Value


NotificationEventPropertyNameCodeType Enumeration

NotificationEventPropertyNameCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyNameCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum NotificationEventPropertyNameCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration NotificationEventPropertyNameCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class NotificationEventPropertyNameCodeType
Members
Member | Description
TimeLeft |
CustomCode |
Remarks


NotificationEventPropertyType Class

NotificationEventPropertyType Class
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NotificationEventPropertyType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NotificationEventPropertyType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NotificationEventPropertyType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationEventPropertyType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | EventType |
 | EventTypeSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | NameSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Value |
Remarks
Inheritance Hierarchy
Object
NotificationEventPropertyType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EventType Property

EventType Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyType ► EventType
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventTypeCodeType EventType { get; set; }
Public Property EventType As NotificationEventTypeCodeType
    Get
    Set
public:
property NotificationEventTypeCodeType EventType {
    NotificationEventTypeCodeType get ();
    void set (NotificationEventTypeCodeType value);
}


EventTypeSpecified Property

EventTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyType ► EventTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EventTypeSpecified { get; set; }
Public Property EventTypeSpecified As Boolean
    Get
    Set
public:
property bool EventTypeSpecified {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyNameCodeType Name { get; set; }
Public Property Name As NotificationEventPropertyNameCodeType
    Get
    Set
public:
property NotificationEventPropertyNameCodeType Name {
    NotificationEventPropertyNameCodeType get ();
    void set (NotificationEventPropertyNameCodeType value);
}


NameSpecified Property

NameSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyType ► NameSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NameSpecified { get; set; }
Public Property NameSpecified As Boolean
    Get
    Set
public:
property bool NameSpecified {
    bool get ();
    void set (bool value);
}


NotificationEventPropertyType Constructor

NotificationEventPropertyType Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyType ► NotificationEventPropertyType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyType()
Public Sub New
public:
NotificationEventPropertyType()


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


NotificationEventPropertyTypeCollection Class

NotificationEventPropertyTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class NotificationEventPropertyTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class NotificationEventPropertyTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class NotificationEventPropertyTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationEventPropertyTypeCollection()()()() |
 | NotificationEventPropertyTypeCollection(array<NotificationEventPropertyType>[]()[][]) |
 | NotificationEventPropertyTypeCollection(NotificationEventPropertyTypeCollection) |
 | Add(NotificationEventPropertyType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<NotificationEventPropertyType>[]()[][]) |
 | AddRange(NotificationEventPropertyTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(NotificationEventPropertyType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<NotificationEventPropertyType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(NotificationEventPropertyType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, NotificationEventPropertyType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(NotificationEventPropertyType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | NotificationEventPropertyTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► Add(NotificationEventPropertyType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    NotificationEventPropertyType item
)
Public Function Add ( _
    item As NotificationEventPropertyType _
) As Integer
public:
int Add(
    NotificationEventPropertyType^ item
)
Parameters
item (NotificationEventPropertyType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<NotificationEventPropertyType>[]()[][]) |
 | AddRange(NotificationEventPropertyTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► AddRange(array<NotificationEventPropertyType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NotificationEventPropertyType[] items
)
Public Sub AddRange ( _
    items As NotificationEventPropertyType() _
)
public:
void AddRange(
    array<NotificationEventPropertyType^>^ items
)
Parameters
items (array< NotificationEventPropertyType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► AddRange(NotificationEventPropertyTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    NotificationEventPropertyTypeCollection items
)
Public Sub AddRange ( _
    items As NotificationEventPropertyTypeCollection _
)
public:
void AddRange(
    NotificationEventPropertyTypeCollection^ items
)
Parameters
items (NotificationEventPropertyTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► Contains(NotificationEventPropertyType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    NotificationEventPropertyType item
)
Public Function Contains ( _
    item As NotificationEventPropertyType _
) As Boolean
public:
bool Contains(
    NotificationEventPropertyType^ item
)
Parameters
item (NotificationEventPropertyType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► CopyTo(array<NotificationEventPropertyType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    NotificationEventPropertyType[] items,
    int index
)
Public Sub CopyTo ( _
    items As NotificationEventPropertyType(), _
    index As Integer _
)
public:
void CopyTo(
    array<NotificationEventPropertyType^>^ items,
    int index
)
Parameters
items (array< NotificationEventPropertyType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► IndexOf(NotificationEventPropertyType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    NotificationEventPropertyType item
)
Public Function IndexOf ( _
    item As NotificationEventPropertyType _
) As Integer
public:
int IndexOf(
    NotificationEventPropertyType^ item
)
Parameters
item (NotificationEventPropertyType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► Insert(Int32, NotificationEventPropertyType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    NotificationEventPropertyType item
)
Public Sub Insert ( _
    index As Integer, _
    item As NotificationEventPropertyType _
)
public:
void Insert(
    int index,
    NotificationEventPropertyType^ item
)
Parameters
index (Int32)
item (NotificationEventPropertyType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As NotificationEventPropertyType
    Get
    Set
public:
property NotificationEventPropertyType^ default[int index] {
    NotificationEventPropertyType^ get (int index);
    void set (int index, NotificationEventPropertyType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As NotificationEventPropertyType
public:
NotificationEventPropertyType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


NotificationEventPropertyTypeCollection Constructor

NotificationEventPropertyTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► NotificationEventPropertyTypeCollection()()()()
Members
Icon | Member | Description
 | NotificationEventPropertyTypeCollection()()()() |
 | NotificationEventPropertyTypeCollection(array<NotificationEventPropertyType>[]()[][]) |
 | NotificationEventPropertyTypeCollection(NotificationEventPropertyTypeCollection) |


NotificationEventPropertyTypeCollection Constructor

NotificationEventPropertyTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► NotificationEventPropertyTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyTypeCollection()
Public Sub New
public:
NotificationEventPropertyTypeCollection()


NotificationEventPropertyTypeCollection Constructor (items)

NotificationEventPropertyTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► NotificationEventPropertyTypeCollection(array<NotificationEventPropertyType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyTypeCollection(
    NotificationEventPropertyType[] items
)
Public Sub New ( _
    items As NotificationEventPropertyType() _
)
public:
NotificationEventPropertyTypeCollection(
    array<NotificationEventPropertyType^>^ items
)
Parameters
items (array< NotificationEventPropertyType >[]()[][])


NotificationEventPropertyTypeCollection Constructor (items)

NotificationEventPropertyTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► NotificationEventPropertyTypeCollection(NotificationEventPropertyTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyTypeCollection(
    NotificationEventPropertyTypeCollection items
)
Public Sub New ( _
    items As NotificationEventPropertyTypeCollection _
)
public:
NotificationEventPropertyTypeCollection(
    NotificationEventPropertyTypeCollection^ items
)
Parameters
items (NotificationEventPropertyTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► Remove(NotificationEventPropertyType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    NotificationEventPropertyType item
)
Public Sub Remove ( _
    item As NotificationEventPropertyType _
)
public:
void Remove(
    NotificationEventPropertyType^ item
)
Parameters
item (NotificationEventPropertyType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyType[] ToArray()
Public Function ToArray As NotificationEventPropertyType()
public:
array<NotificationEventPropertyType^>^ ToArray()
Return Value


NotificationEventStateCodeType Enumeration

NotificationEventStateCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► NotificationEventStateCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum NotificationEventStateCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration NotificationEventStateCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class NotificationEventStateCodeType
Members
Member | Description
New |
Failed |
MarkedDown |
Pending |
FailedPending |
MarkedDownPending |
Delivered |
Undeliverable |
Rejected |
Canceled |
CustomCode |
Remarks


NotificationEventTypeCodeType Enumeration

NotificationEventTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► NotificationEventTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum NotificationEventTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration NotificationEventTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class NotificationEventTypeCodeType
Members
Member | Description
None |
OutBid |
EndOfAuction |
AuctionCheckoutComplete |
CheckoutBuyerRequestsTotal |
Feedback |
FeedbackForSeller |
FixedPriceTransaction |
SecondChanceOffer |
AskSellerQuestion |
ItemListed |
ItemRevised |
BuyerResponseDispute |
SellerOpenedDispute |
SellerRespondedToDispute |
SellerClosedDispute |
BestOffer |
MyMessagesAlertHeader |
MyMessagesAlert |
MyMessageseBayMessageHeader |
MyMessageseBayMessage |
MyMessagesM2MMessageHeader |
MyMessagesM2MMessage |
INRBuyerOpenedDispute |
INRBuyerRespondedToDispute |
INRBuyerClosedDispute |
INRSellerRespondedToDispute |
Checkout |
WatchedItemEndingSoon |
ItemClosed |
ItemSuspended |
ItemSold |
ItemExtended |
UserIDChanged |
EmailAddressChanged |
PasswordChanged |
PasswordHintChanged |
PaymentDetailChanged |
AccountSuspended |
AccountSummary |
ThirdPartyCartCheckout |
ItemRevisedAddCharity |
ItemAddedToWatchList |
ItemRemovedFromWatchList |
ItemAddedToBidGroup |
ItemRemovedFromBidGroup |
FeedbackLeft |
FeedbackReceived |
FeedbackStarChanged |
BidPlaced |
BidReceived |
ItemWon |
ItemLost |
ItemUnsold |
CounterOfferReceived |
BestOfferDeclined |
BestOfferPlaced |
AddToWatchList |
PlaceOffer |
RemoveFromWatchList |
AddToBidGroup |
RemoveFromBidGroup |
ItemsCanceled |
TokenRevocation |
BulkDataExchangeJobCompleted |
CustomCode |
ItemMarkedShipped |
ItemMarkedPaid |
EBPMyResponseDue |
EBPOtherPartyResponseDue |
EBPEscalatedCase |
EBPAppealedCase |
EBPMyPaymentDue |
EBPPaymentDone |
EBPClosedAppeal |
EBPClosedCase |
MyMessagesHighPriorityMessage |
MyMessagesHighPriorityMessageHeader |
EBPOnHoldCase |
ReadyToShip |
ReadyForPayout |
BidItemEndingSoon |
ShoppingCartItemEndingSoon |
ReturnCreated |
ReturnWaitingForSellerInfo |
ReturnSellerInfoOverdue |
ReturnShipped |
ReturnDelivered |
ReturnRefundOverdue |
ReturnClosed |
ReturnEscalated |
BuyerCancelRequested |
UnmatchedPaymentReceived |
RefundSuccess |
RefundFailure |
PaymentReminder |
EBNOrderPickedUp |
EBNOrderCanceled |
M2MMessageStatusChange |
Remarks


NotificationMessageType Class

NotificationMessageType Class
Namespaces ► eBay.Service.Core.Soap ► NotificationMessageType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NotificationMessageType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NotificationMessageType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NotificationMessageType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationMessageType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIAS |
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | MessageBody |
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | NotificationMessageType


EIAS Property

EIAS Property
Namespaces ► eBay.Service.Core.Soap ► NotificationMessageType ► EIAS
Declaration Syntax
C# Visual Basic Visual C++
public string EIAS { get; set; }
Public Property EIAS As String
    Get
    Set
public:
property String^ EIAS {
    String^ get ();
    void set (String^ value);
}


MessageBody Property

MessageBody Property
Namespaces ► eBay.Service.Core.Soap ► NotificationMessageType ► MessageBody
Declaration Syntax
C# Visual Basic Visual C++
public string MessageBody { get; set; }
Public Property MessageBody As String
    Get
    Set
public:
property String^ MessageBody {
    String^ get ();
    void set (String^ value);
}


NotificationMessageType Constructor

NotificationMessageType Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationMessageType ► NotificationMessageType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationMessageType()
Public Sub New
public:
NotificationMessageType()


NotificationPayloadTypeCodeType Enumeration

NotificationPayloadTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► NotificationPayloadTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum NotificationPayloadTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration NotificationPayloadTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class NotificationPayloadTypeCodeType
Members
Member | Description
eBLSchemaSOAP |
CustomCode |
Remarks


NotificationRoleCodeType Enumeration

NotificationRoleCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► NotificationRoleCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum NotificationRoleCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration NotificationRoleCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class NotificationRoleCodeType
Members
Member | Description
Application |
User |
UserData |
Event |
CustomCode |
Remarks


NotificationStatisticsType Class

NotificationStatisticsType Class
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NotificationStatisticsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NotificationStatisticsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NotificationStatisticsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationStatisticsType()()()() |
 | Any |
 | DeliveredCount |
 | DeliveredCountSpecified |
 | Equals(Object) | (Inherited from Object.)
 | ErrorCount |
 | ErrorCountSpecified |
 | ExpiredCount |
 | ExpiredCountSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QueuedNewCount |
 | QueuedNewCountSpecified |
 | QueuedPendingCount |
 | QueuedPendingCountSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
NotificationStatisticsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DeliveredCount Property

DeliveredCount Property
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► DeliveredCount
Declaration Syntax
C# Visual Basic Visual C++
public int DeliveredCount { get; set; }
Public Property DeliveredCount As Integer
    Get
    Set
public:
property int DeliveredCount {
    int get ();
    void set (int value);
}


DeliveredCountSpecified Property

DeliveredCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► DeliveredCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeliveredCountSpecified { get; set; }
Public Property DeliveredCountSpecified As Boolean
    Get
    Set
public:
property bool DeliveredCountSpecified {
    bool get ();
    void set (bool value);
}


ErrorCount Property

ErrorCount Property
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► ErrorCount
Declaration Syntax
C# Visual Basic Visual C++
public int ErrorCount { get; set; }
Public Property ErrorCount As Integer
    Get
    Set
public:
property int ErrorCount {
    int get ();
    void set (int value);
}


ErrorCountSpecified Property

ErrorCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► ErrorCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ErrorCountSpecified { get; set; }
Public Property ErrorCountSpecified As Boolean
    Get
    Set
public:
property bool ErrorCountSpecified {
    bool get ();
    void set (bool value);
}


ExpiredCount Property

ExpiredCount Property
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► ExpiredCount
Declaration Syntax
C# Visual Basic Visual C++
public int ExpiredCount { get; set; }
Public Property ExpiredCount As Integer
    Get
    Set
public:
property int ExpiredCount {
    int get ();
    void set (int value);
}


ExpiredCountSpecified Property

ExpiredCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► ExpiredCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpiredCountSpecified { get; set; }
Public Property ExpiredCountSpecified As Boolean
    Get
    Set
public:
property bool ExpiredCountSpecified {
    bool get ();
    void set (bool value);
}


NotificationStatisticsType Constructor

NotificationStatisticsType Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► NotificationStatisticsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationStatisticsType()
Public Sub New
public:
NotificationStatisticsType()


QueuedNewCount Property

QueuedNewCount Property
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► QueuedNewCount
Declaration Syntax
C# Visual Basic Visual C++
public int QueuedNewCount { get; set; }
Public Property QueuedNewCount As Integer
    Get
    Set
public:
property int QueuedNewCount {
    int get ();
    void set (int value);
}


QueuedNewCountSpecified Property

QueuedNewCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► QueuedNewCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QueuedNewCountSpecified { get; set; }
Public Property QueuedNewCountSpecified As Boolean
    Get
    Set
public:
property bool QueuedNewCountSpecified {
    bool get ();
    void set (bool value);
}


QueuedPendingCount Property

QueuedPendingCount Property
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► QueuedPendingCount
Declaration Syntax
C# Visual Basic Visual C++
public int QueuedPendingCount { get; set; }
Public Property QueuedPendingCount As Integer
    Get
    Set
public:
property int QueuedPendingCount {
    int get ();
    void set (int value);
}


QueuedPendingCountSpecified Property

QueuedPendingCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► NotificationStatisticsType ► QueuedPendingCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QueuedPendingCountSpecified { get; set; }
Public Property QueuedPendingCountSpecified As Boolean
    Get
    Set
public:
property bool QueuedPendingCountSpecified {
    bool get ();
    void set (bool value);
}


NotificationUserDataType Class

NotificationUserDataType Class
Namespaces ► eBay.Service.Core.Soap ► NotificationUserDataType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NotificationUserDataType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NotificationUserDataType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NotificationUserDataType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationUserDataType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | ExternalUserData |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SMSSubscription |
 | SummarySchedule |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
NotificationUserDataType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► NotificationUserDataType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExternalUserData Property

ExternalUserData Property
Namespaces ► eBay.Service.Core.Soap ► NotificationUserDataType ► ExternalUserData
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalUserData { get; set; }
Public Property ExternalUserData As String
    Get
    Set
public:
property String^ ExternalUserData {
    String^ get ();
    void set (String^ value);
}


NotificationUserDataType Constructor

NotificationUserDataType Constructor
Namespaces ► eBay.Service.Core.Soap ► NotificationUserDataType ► NotificationUserDataType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NotificationUserDataType()
Public Sub New
public:
NotificationUserDataType()


SMSSubscription Property

SMSSubscription Property
Namespaces ► eBay.Service.Core.Soap ► NotificationUserDataType ► SMSSubscription
Declaration Syntax
C# Visual Basic Visual C++
public SMSSubscriptionType SMSSubscription { get; set; }
Public Property SMSSubscription As SMSSubscriptionType
    Get
    Set
public:
property SMSSubscriptionType^ SMSSubscription {
    SMSSubscriptionType^ get ();
    void set (SMSSubscriptionType^ value);
}


SummarySchedule Property

SummarySchedule Property
Namespaces ► eBay.Service.Core.Soap ► NotificationUserDataType ► SummarySchedule
Declaration Syntax
C# Visual Basic Visual C++
public SummaryEventScheduleTypeCollection SummarySchedule { get; set; }
Public Property SummarySchedule As SummaryEventScheduleTypeCollection
    Get
    Set
public:
property SummaryEventScheduleTypeCollection^ SummarySchedule {
    SummaryEventScheduleTypeCollection^ get ();
    void set (SummaryEventScheduleTypeCollection^ value);
}


NumberOfPolicyViolationsDetailsType Class

NumberOfPolicyViolationsDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► NumberOfPolicyViolationsDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class NumberOfPolicyViolationsDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class NumberOfPolicyViolationsDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class NumberOfPolicyViolationsDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NumberOfPolicyViolationsDetailsType()()()() |
 | Any |
 | Count |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
NumberOfPolicyViolationsDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► NumberOfPolicyViolationsDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Count Property

Count Property
Namespaces ► eBay.Service.Core.Soap ► NumberOfPolicyViolationsDetailsType ► Count
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection Count { get; set; }
Public Property Count As Int32Collection
    Get
    Set
public:
property Int32Collection^ Count {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


NumberOfPolicyViolationsDetailsType Constructor

NumberOfPolicyViolationsDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► NumberOfPolicyViolationsDetailsType ► NumberOfPolicyViolationsDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public NumberOfPolicyViolationsDetailsType()
Public Sub New
public:
NumberOfPolicyViolationsDetailsType()


OfferType Class

OfferType Class
Namespaces ► eBay.Service.Core.Soap ► OfferType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class OfferType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class OfferType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class OfferType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OfferType()()()() |
 | Action |
 | ActionSpecified |
 | Any |
 | BestOfferID |
 | BidCount |
 | BidCountSpecified |
 | ConvertedPrice |
 | Currency |
 | CurrencySpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HighestBid |
 | ItemID |
 | MaxBid |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message |
 | MyMaxBid |
 | Quantity |
 | QuantitySpecified |
 | SecondChanceEnabled |
 | SecondChanceEnabledSpecified |
 | SiteCurrency |
 | SiteCurrencySpecified |
 | TimeBid |
 | TimeBidSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | User |
 | UserConsent |
 | UserConsentSpecified |
Remarks
Inheritance Hierarchy
Object
OfferType


Action Property

Action Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► Action
Declaration Syntax
C# Visual Basic Visual C++
public BidActionCodeType Action { get; set; }
Public Property Action As BidActionCodeType
    Get
    Set
public:
property BidActionCodeType Action {
    BidActionCodeType get ();
    void set (BidActionCodeType value);
}


ActionSpecified Property

ActionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► ActionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ActionSpecified { get; set; }
Public Property ActionSpecified As Boolean
    Get
    Set
public:
property bool ActionSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestOfferID Property

BestOfferID Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► BestOfferID
Declaration Syntax
C# Visual Basic Visual C++
public string BestOfferID { get; set; }
Public Property BestOfferID As String
    Get
    Set
public:
property String^ BestOfferID {
    String^ get ();
    void set (String^ value);
}


BidCount Property

BidCount Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► BidCount
Declaration Syntax
C# Visual Basic Visual C++
public int BidCount { get; set; }
Public Property BidCount As Integer
    Get
    Set
public:
property int BidCount {
    int get ();
    void set (int value);
}


BidCountSpecified Property

BidCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► BidCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidCountSpecified { get; set; }
Public Property BidCountSpecified As Boolean
    Get
    Set
public:
property bool BidCountSpecified {
    bool get ();
    void set (bool value);
}


ConvertedPrice Property

ConvertedPrice Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► ConvertedPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ConvertedPrice { get; set; }
Public Property ConvertedPrice As AmountType
    Get
    Set
public:
property AmountType^ ConvertedPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


Currency Property

Currency Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► Currency
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType Currency { get; set; }
Public Property Currency As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType Currency {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


CurrencySpecified Property

CurrencySpecified Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► CurrencySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CurrencySpecified { get; set; }
Public Property CurrencySpecified As Boolean
    Get
    Set
public:
property bool CurrencySpecified {
    bool get ();
    void set (bool value);
}


HighestBid Property

HighestBid Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► HighestBid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType HighestBid { get; set; }
Public Property HighestBid As AmountType
    Get
    Set
public:
property AmountType^ HighestBid {
    AmountType^ get ();
    void set (AmountType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MaxBid Property

MaxBid Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► MaxBid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MaxBid { get; set; }
Public Property MaxBid As AmountType
    Get
    Set
public:
property AmountType^ MaxBid {
    AmountType^ get ();
    void set (AmountType^ value);
}


Message Property

Message Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► Message
Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


MyMaxBid Property

MyMaxBid Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► MyMaxBid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MyMaxBid { get; set; }
Public Property MyMaxBid As AmountType
    Get
    Set
public:
property AmountType^ MyMaxBid {
    AmountType^ get ();
    void set (AmountType^ value);
}


OfferType Constructor

OfferType Constructor
Namespaces ► eBay.Service.Core.Soap ► OfferType ► OfferType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OfferType()
Public Sub New
public:
OfferType()


Quantity Property

Quantity Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public int Quantity { get; set; }
Public Property Quantity As Integer
    Get
    Set
public:
property int Quantity {
    int get ();
    void set (int value);
}


QuantitySpecified Property

QuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► QuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySpecified { get; set; }
Public Property QuantitySpecified As Boolean
    Get
    Set
public:
property bool QuantitySpecified {
    bool get ();
    void set (bool value);
}


SecondChanceEnabled Property

SecondChanceEnabled Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► SecondChanceEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool SecondChanceEnabled { get; set; }
Public Property SecondChanceEnabled As Boolean
    Get
    Set
public:
property bool SecondChanceEnabled {
    bool get ();
    void set (bool value);
}


SecondChanceEnabledSpecified Property

SecondChanceEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► SecondChanceEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SecondChanceEnabledSpecified { get; set; }
Public Property SecondChanceEnabledSpecified As Boolean
    Get
    Set
public:
property bool SecondChanceEnabledSpecified {
    bool get ();
    void set (bool value);
}


SiteCurrency Property

SiteCurrency Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► SiteCurrency
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType SiteCurrency { get; set; }
Public Property SiteCurrency As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType SiteCurrency {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


SiteCurrencySpecified Property

SiteCurrencySpecified Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► SiteCurrencySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SiteCurrencySpecified { get; set; }
Public Property SiteCurrencySpecified As Boolean
    Get
    Set
public:
property bool SiteCurrencySpecified {
    bool get ();
    void set (bool value);
}


TimeBid Property

TimeBid Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► TimeBid
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeBid { get; set; }
Public Property TimeBid As DateTime
    Get
    Set
public:
property DateTime TimeBid {
    DateTime get ();
    void set (DateTime value);
}


TimeBidSpecified Property

TimeBidSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► TimeBidSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TimeBidSpecified { get; set; }
Public Property TimeBidSpecified As Boolean
    Get
    Set
public:
property bool TimeBidSpecified {
    bool get ();
    void set (bool value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


User Property

User Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► User
Declaration Syntax
C# Visual Basic Visual C++
public UserType User { get; set; }
Public Property User As UserType
    Get
    Set
public:
property UserType^ User {
    UserType^ get ();
    void set (UserType^ value);
}


UserConsent Property

UserConsent Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► UserConsent
Declaration Syntax
C# Visual Basic Visual C++
public bool UserConsent { get; set; }
Public Property UserConsent As Boolean
    Get
    Set
public:
property bool UserConsent {
    bool get ();
    void set (bool value);
}


UserConsentSpecified Property

UserConsentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OfferType ► UserConsentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UserConsentSpecified { get; set; }
Public Property UserConsentSpecified As Boolean
    Get
    Set
public:
property bool UserConsentSpecified {
    bool get ();
    void set (bool value);
}


OfferTypeCollection Class

OfferTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class OfferTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class OfferTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class OfferTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OfferTypeCollection()()()() |
 | OfferTypeCollection(array<OfferType>[]()[][]) |
 | OfferTypeCollection(OfferTypeCollection) |
 | Add(OfferType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<OfferType>[]()[][]) |
 | AddRange(OfferTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(OfferType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<OfferType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(OfferType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, OfferType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(OfferType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | OfferTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► Add(OfferType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    OfferType item
)
Public Function Add ( _
    item As OfferType _
) As Integer
public:
int Add(
    OfferType^ item
)
Parameters
item (OfferType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<OfferType>[]()[][]) |
 | AddRange(OfferTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► AddRange(array<OfferType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    OfferType[] items
)
Public Sub AddRange ( _
    items As OfferType() _
)
public:
void AddRange(
    array<OfferType^>^ items
)
Parameters
items (array< OfferType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► AddRange(OfferTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    OfferTypeCollection items
)
Public Sub AddRange ( _
    items As OfferTypeCollection _
)
public:
void AddRange(
    OfferTypeCollection^ items
)
Parameters
items (OfferTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► Contains(OfferType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    OfferType item
)
Public Function Contains ( _
    item As OfferType _
) As Boolean
public:
bool Contains(
    OfferType^ item
)
Parameters
item (OfferType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► CopyTo(array<OfferType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    OfferType[] items,
    int index
)
Public Sub CopyTo ( _
    items As OfferType(), _
    index As Integer _
)
public:
void CopyTo(
    array<OfferType^>^ items,
    int index
)
Parameters
items (array< OfferType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► IndexOf(OfferType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    OfferType item
)
Public Function IndexOf ( _
    item As OfferType _
) As Integer
public:
int IndexOf(
    OfferType^ item
)
Parameters
item (OfferType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► Insert(Int32, OfferType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    OfferType item
)
Public Sub Insert ( _
    index As Integer, _
    item As OfferType _
)
public:
void Insert(
    int index,
    OfferType^ item
)
Parameters
index (Int32)
item (OfferType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public OfferType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As OfferType
    Get
    Set
public:
property OfferType^ default[int index] {
    OfferType^ get (int index);
    void set (int index, OfferType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public OfferType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As OfferType
public:
OfferType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


OfferTypeCollection Constructor

OfferTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► OfferTypeCollection()()()()
Members
Icon | Member | Description
 | OfferTypeCollection()()()() |
 | OfferTypeCollection(array<OfferType>[]()[][]) |
 | OfferTypeCollection(OfferTypeCollection) |


OfferTypeCollection Constructor

OfferTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► OfferTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OfferTypeCollection()
Public Sub New
public:
OfferTypeCollection()


OfferTypeCollection Constructor (items)

OfferTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► OfferTypeCollection(array<OfferType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public OfferTypeCollection(
    OfferType[] items
)
Public Sub New ( _
    items As OfferType() _
)
public:
OfferTypeCollection(
    array<OfferType^>^ items
)
Parameters
items (array< OfferType >[]()[][])


OfferTypeCollection Constructor (items)

OfferTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► OfferTypeCollection(OfferTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public OfferTypeCollection(
    OfferTypeCollection items
)
Public Sub New ( _
    items As OfferTypeCollection _
)
public:
OfferTypeCollection(
    OfferTypeCollection^ items
)
Parameters
items (OfferTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► Remove(OfferType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    OfferType item
)
Public Sub Remove ( _
    item As OfferType _
)
public:
void Remove(
    OfferType^ item
)
Parameters
item (OfferType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OfferType[] ToArray()
Public Function ToArray As OfferType()
public:
array<OfferType^>^ ToArray()
Return Value


OrderStatusCodeType Enumeration

OrderStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► OrderStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum OrderStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration OrderStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class OrderStatusCodeType
Members
Member | Description
Active |
Inactive |
Completed |
Cancelled |
Shipped |
Default |
Authenticated |
InProcess |
Invalid |
CustomCode |
All |
CancelPending |
Remarks


OrderStatusFilterCodeType Enumeration

OrderStatusFilterCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► OrderStatusFilterCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum OrderStatusFilterCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration OrderStatusFilterCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class OrderStatusFilterCodeType
Members
Member | Description
All |
AwaitingPayment |
AwaitingShipment |
PaidAndShipped |
CustomCode |
Remarks


OrderTransactionType Class

OrderTransactionType Class
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class OrderTransactionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class OrderTransactionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class OrderTransactionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OrderTransactionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Order |
 | ToString()()()() | (Inherited from Object.)
 | Transaction |
Remarks
Inheritance Hierarchy
Object
OrderTransactionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Order Property

Order Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionType ► Order
Declaration Syntax
C# Visual Basic Visual C++
public OrderType Order { get; set; }
Public Property Order As OrderType
    Get
    Set
public:
property OrderType^ Order {
    OrderType^ get ();
    void set (OrderType^ value);
}


OrderTransactionType Constructor

OrderTransactionType Constructor
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionType ► OrderTransactionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OrderTransactionType()
Public Sub New
public:
OrderTransactionType()


Transaction Property

Transaction Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionType ► Transaction
Declaration Syntax
C# Visual Basic Visual C++
public TransactionType Transaction { get; set; }
Public Property Transaction As TransactionType
    Get
    Set
public:
property TransactionType^ Transaction {
    TransactionType^ get ();
    void set (TransactionType^ value);
}


OrderTransactionTypeCollection Class

OrderTransactionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class OrderTransactionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class OrderTransactionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class OrderTransactionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OrderTransactionTypeCollection()()()() |
 | OrderTransactionTypeCollection(array<OrderTransactionType>[]()[][]) |
 | OrderTransactionTypeCollection(OrderTransactionTypeCollection) |
 | Add(OrderTransactionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<OrderTransactionType>[]()[][]) |
 | AddRange(OrderTransactionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(OrderTransactionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<OrderTransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(OrderTransactionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, OrderTransactionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(OrderTransactionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | OrderTransactionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► Add(OrderTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    OrderTransactionType item
)
Public Function Add ( _
    item As OrderTransactionType _
) As Integer
public:
int Add(
    OrderTransactionType^ item
)
Parameters
item (OrderTransactionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<OrderTransactionType>[]()[][]) |
 | AddRange(OrderTransactionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► AddRange(array<OrderTransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    OrderTransactionType[] items
)
Public Sub AddRange ( _
    items As OrderTransactionType() _
)
public:
void AddRange(
    array<OrderTransactionType^>^ items
)
Parameters
items (array< OrderTransactionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► AddRange(OrderTransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    OrderTransactionTypeCollection items
)
Public Sub AddRange ( _
    items As OrderTransactionTypeCollection _
)
public:
void AddRange(
    OrderTransactionTypeCollection^ items
)
Parameters
items (OrderTransactionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► Contains(OrderTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    OrderTransactionType item
)
Public Function Contains ( _
    item As OrderTransactionType _
) As Boolean
public:
bool Contains(
    OrderTransactionType^ item
)
Parameters
item (OrderTransactionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► CopyTo(array<OrderTransactionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    OrderTransactionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As OrderTransactionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<OrderTransactionType^>^ items,
    int index
)
Parameters
items (array< OrderTransactionType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► IndexOf(OrderTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    OrderTransactionType item
)
Public Function IndexOf ( _
    item As OrderTransactionType _
) As Integer
public:
int IndexOf(
    OrderTransactionType^ item
)
Parameters
item (OrderTransactionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► Insert(Int32, OrderTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    OrderTransactionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As OrderTransactionType _
)
public:
void Insert(
    int index,
    OrderTransactionType^ item
)
Parameters
index (Int32)
item (OrderTransactionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public OrderTransactionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As OrderTransactionType
    Get
    Set
public:
property OrderTransactionType^ default[int index] {
    OrderTransactionType^ get (int index);
    void set (int index, OrderTransactionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public OrderTransactionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As OrderTransactionType
public:
OrderTransactionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


OrderTransactionTypeCollection Constructor

OrderTransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► OrderTransactionTypeCollection()()()()
Members
Icon | Member | Description
 | OrderTransactionTypeCollection()()()() |
 | OrderTransactionTypeCollection(array<OrderTransactionType>[]()[][]) |
 | OrderTransactionTypeCollection(OrderTransactionTypeCollection) |


OrderTransactionTypeCollection Constructor

OrderTransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► OrderTransactionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OrderTransactionTypeCollection()
Public Sub New
public:
OrderTransactionTypeCollection()


OrderTransactionTypeCollection Constructor (items)

OrderTransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► OrderTransactionTypeCollection(array<OrderTransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public OrderTransactionTypeCollection(
    OrderTransactionType[] items
)
Public Sub New ( _
    items As OrderTransactionType() _
)
public:
OrderTransactionTypeCollection(
    array<OrderTransactionType^>^ items
)
Parameters
items (array< OrderTransactionType >[]()[][])


OrderTransactionTypeCollection Constructor (items)

OrderTransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► OrderTransactionTypeCollection(OrderTransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public OrderTransactionTypeCollection(
    OrderTransactionTypeCollection items
)
Public Sub New ( _
    items As OrderTransactionTypeCollection _
)
public:
OrderTransactionTypeCollection(
    OrderTransactionTypeCollection^ items
)
Parameters
items (OrderTransactionTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► Remove(OrderTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    OrderTransactionType item
)
Public Sub Remove ( _
    item As OrderTransactionType _
)
public:
void Remove(
    OrderTransactionType^ item
)
Parameters
item (OrderTransactionType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OrderTransactionType[] ToArray()
Public Function ToArray As OrderTransactionType()
public:
array<OrderTransactionType^>^ ToArray()
Return Value


OrderType Class

OrderType Class
Namespaces ► eBay.Service.Core.Soap ► OrderType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class OrderType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class OrderType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class OrderType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OrderType()()()() |
 | AdjustmentAmount |
 | AmountPaid |
 | AmountSaved |
 | Any |
 | BundlePurchase |
 | BundlePurchaseSpecified |
 | BuyerCheckoutMessage |
 | BuyerPackageEnclosures |
 | BuyerTaxIdentifier |
 | BuyerUserID |
 | CancelDetail |
 | CancelReason |
 | CancelReasonDetails |
 | CancelStatus |
 | CancelStatusSpecified |
 | CheckoutStatus |
 | ContainseBayPlusTransaction |
 | ContainseBayPlusTransactionSpecified |
 | CreatedTime |
 | CreatedTimeSpecified |
 | CreatingUserRole |
 | CreatingUserRoleSpecified |
 | EIASToken |
 | Equals(Object) | (Inherited from Object.)
 | ExtendedOrderID |
 | ExternalTransaction |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IntegratedMerchantCreditCardEnabled |
 | IntegratedMerchantCreditCardEnabledSpecified |
 | IsMultiLegShipping |
 | IsMultiLegShippingSpecified |
 | LogisticsPlanType |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MonetaryDetails |
 | MultiLegShippingDetails |
 | OrderID |
 | OrderStatus |
 | OrderStatusSpecified |
 | PaidTime |
 | PaidTimeSpecified |
 | PaymentHoldDetails |
 | PaymentHoldStatus |
 | PaymentHoldStatusSpecified |
 | PaymentMethods |
 | PickupDetails |
 | PickupMethodSelected |
 | RefundAmount |
 | RefundArray |
 | RefundStatus |
 | SellerEIASToken |
 | SellerEmail |
 | SellerUserID |
 | ShippedTime |
 | ShippedTimeSpecified |
 | ShippingAddress |
 | ShippingConvenienceCharge |
 | ShippingDetails |
 | ShippingServiceSelected |
 | Subtotal |
 | ToString()()()() | (Inherited from Object.)
 | Total |
 | TransactionArray |
Remarks
Inheritance Hierarchy
Object
OrderType


AdjustmentAmount Property

AdjustmentAmount Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► AdjustmentAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AdjustmentAmount { get; set; }
Public Property AdjustmentAmount As AmountType
    Get
    Set
public:
property AmountType^ AdjustmentAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


AmountPaid Property

AmountPaid Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► AmountPaid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AmountPaid { get; set; }
Public Property AmountPaid As AmountType
    Get
    Set
public:
property AmountType^ AmountPaid {
    AmountType^ get ();
    void set (AmountType^ value);
}


AmountSaved Property

AmountSaved Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► AmountSaved
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AmountSaved { get; set; }
Public Property AmountSaved As AmountType
    Get
    Set
public:
property AmountType^ AmountSaved {
    AmountType^ get ();
    void set (AmountType^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BundlePurchase Property

BundlePurchase Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► BundlePurchase
Declaration Syntax
C# Visual Basic Visual C++
public bool BundlePurchase { get; set; }
Public Property BundlePurchase As Boolean
    Get
    Set
public:
property bool BundlePurchase {
    bool get ();
    void set (bool value);
}


BundlePurchaseSpecified Property

BundlePurchaseSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► BundlePurchaseSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BundlePurchaseSpecified { get; set; }
Public Property BundlePurchaseSpecified As Boolean
    Get
    Set
public:
property bool BundlePurchaseSpecified {
    bool get ();
    void set (bool value);
}


BuyerCheckoutMessage Property

BuyerCheckoutMessage Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► BuyerCheckoutMessage
Declaration Syntax
C# Visual Basic Visual C++
public string BuyerCheckoutMessage { get; set; }
Public Property BuyerCheckoutMessage As String
    Get
    Set
public:
property String^ BuyerCheckoutMessage {
    String^ get ();
    void set (String^ value);
}


BuyerPackageEnclosures Property

BuyerPackageEnclosures Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► BuyerPackageEnclosures
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPackageEnclosuresType BuyerPackageEnclosures { get; set; }
Public Property BuyerPackageEnclosures As BuyerPackageEnclosuresType
    Get
    Set
public:
property BuyerPackageEnclosuresType^ BuyerPackageEnclosures {
    BuyerPackageEnclosuresType^ get ();
    void set (BuyerPackageEnclosuresType^ value);
}


BuyerTaxIdentifier Property

BuyerTaxIdentifier Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► BuyerTaxIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierTypeCollection BuyerTaxIdentifier { get; set; }
Public Property BuyerTaxIdentifier As TaxIdentifierTypeCollection
    Get
    Set
public:
property TaxIdentifierTypeCollection^ BuyerTaxIdentifier {
    TaxIdentifierTypeCollection^ get ();
    void set (TaxIdentifierTypeCollection^ value);
}


BuyerUserID Property

BuyerUserID Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► BuyerUserID
Declaration Syntax
C# Visual Basic Visual C++
public string BuyerUserID { get; set; }
Public Property BuyerUserID As String
    Get
    Set
public:
property String^ BuyerUserID {
    String^ get ();
    void set (String^ value);
}


CancelDetail Property

CancelDetail Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► CancelDetail
Declaration Syntax
C# Visual Basic Visual C++
public CancelDetailTypeCollection CancelDetail { get; set; }
Public Property CancelDetail As CancelDetailTypeCollection
    Get
    Set
public:
property CancelDetailTypeCollection^ CancelDetail {
    CancelDetailTypeCollection^ get ();
    void set (CancelDetailTypeCollection^ value);
}


CancelReason Property

CancelReason Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► CancelReason
Declaration Syntax
C# Visual Basic Visual C++
public string CancelReason { get; set; }
Public Property CancelReason As String
    Get
    Set
public:
property String^ CancelReason {
    String^ get ();
    void set (String^ value);
}


CancelReasonDetails Property

CancelReasonDetails Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► CancelReasonDetails
Declaration Syntax
C# Visual Basic Visual C++
public string CancelReasonDetails { get; set; }
Public Property CancelReasonDetails As String
    Get
    Set
public:
property String^ CancelReasonDetails {
    String^ get ();
    void set (String^ value);
}


CancelStatus Property

CancelStatus Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► CancelStatus
Declaration Syntax
C# Visual Basic Visual C++
public CancelStatusCodeType CancelStatus { get; set; }
Public Property CancelStatus As CancelStatusCodeType
    Get
    Set
public:
property CancelStatusCodeType CancelStatus {
    CancelStatusCodeType get ();
    void set (CancelStatusCodeType value);
}


CancelStatusSpecified Property

CancelStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► CancelStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CancelStatusSpecified { get; set; }
Public Property CancelStatusSpecified As Boolean
    Get
    Set
public:
property bool CancelStatusSpecified {
    bool get ();
    void set (bool value);
}


CheckoutStatus Property

CheckoutStatus Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► CheckoutStatus
Declaration Syntax
C# Visual Basic Visual C++
public CheckoutStatusType CheckoutStatus { get; set; }
Public Property CheckoutStatus As CheckoutStatusType
    Get
    Set
public:
property CheckoutStatusType^ CheckoutStatus {
    CheckoutStatusType^ get ();
    void set (CheckoutStatusType^ value);
}


ContainseBayPlusTransaction Property

ContainseBayPlusTransaction Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► ContainseBayPlusTransaction
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainseBayPlusTransaction { get; set; }
Public Property ContainseBayPlusTransaction As Boolean
    Get
    Set
public:
property bool ContainseBayPlusTransaction {
    bool get ();
    void set (bool value);
}


ContainseBayPlusTransactionSpecified Property

ContainseBayPlusTransactionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► ContainseBayPlusTransactionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainseBayPlusTransactionSpecified { get; set; }
Public Property ContainseBayPlusTransactionSpecified As Boolean
    Get
    Set
public:
property bool ContainseBayPlusTransactionSpecified {
    bool get ();
    void set (bool value);
}


CreatedTime Property

CreatedTime Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► CreatedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreatedTime { get; set; }
Public Property CreatedTime As DateTime
    Get
    Set
public:
property DateTime CreatedTime {
    DateTime get ();
    void set (DateTime value);
}


CreatedTimeSpecified Property

CreatedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► CreatedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreatedTimeSpecified { get; set; }
Public Property CreatedTimeSpecified As Boolean
    Get
    Set
public:
property bool CreatedTimeSpecified {
    bool get ();
    void set (bool value);
}


CreatingUserRole Property

CreatingUserRole Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► CreatingUserRole
Declaration Syntax
C# Visual Basic Visual C++
public TradingRoleCodeType CreatingUserRole { get; set; }
Public Property CreatingUserRole As TradingRoleCodeType
    Get
    Set
public:
property TradingRoleCodeType CreatingUserRole {
    TradingRoleCodeType get ();
    void set (TradingRoleCodeType value);
}


CreatingUserRoleSpecified Property

CreatingUserRoleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► CreatingUserRoleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreatingUserRoleSpecified { get; set; }
Public Property CreatingUserRoleSpecified As Boolean
    Get
    Set
public:
property bool CreatingUserRoleSpecified {
    bool get ();
    void set (bool value);
}


EIASToken Property

EIASToken Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► EIASToken
Declaration Syntax
C# Visual Basic Visual C++
public string EIASToken { get; set; }
Public Property EIASToken As String
    Get
    Set
public:
property String^ EIASToken {
    String^ get ();
    void set (String^ value);
}


ExtendedOrderID Property

ExtendedOrderID Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► ExtendedOrderID
Declaration Syntax
C# Visual Basic Visual C++
public string ExtendedOrderID { get; set; }
Public Property ExtendedOrderID As String
    Get
    Set
public:
property String^ ExtendedOrderID {
    String^ get ();
    void set (String^ value);
}


ExternalTransaction Property

ExternalTransaction Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► ExternalTransaction
Declaration Syntax
C# Visual Basic Visual C++
public ExternalTransactionTypeCollection ExternalTransaction { get; set; }
Public Property ExternalTransaction As ExternalTransactionTypeCollection
    Get
    Set
public:
property ExternalTransactionTypeCollection^ ExternalTransaction {
    ExternalTransactionTypeCollection^ get ();
    void set (ExternalTransactionTypeCollection^ value);
}


IntegratedMerchantCreditCardEnabled Property

IntegratedMerchantCreditCardEnabled Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► IntegratedMerchantCreditCardEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool IntegratedMerchantCreditCardEnabled { get; set; }
Public Property IntegratedMerchantCreditCardEnabled As Boolean
    Get
    Set
public:
property bool IntegratedMerchantCreditCardEnabled {
    bool get ();
    void set (bool value);
}


IntegratedMerchantCreditCardEnabledSpecified Property

IntegratedMerchantCreditCardEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► IntegratedMerchantCreditCardEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IntegratedMerchantCreditCardEnabledSpecified { get; set; }
Public Property IntegratedMerchantCreditCardEnabledSpecified As Boolean
    Get
    Set
public:
property bool IntegratedMerchantCreditCardEnabledSpecified {
    bool get ();
    void set (bool value);
}


IsMultiLegShipping Property

IsMultiLegShipping Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► IsMultiLegShipping
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMultiLegShipping { get; set; }
Public Property IsMultiLegShipping As Boolean
    Get
    Set
public:
property bool IsMultiLegShipping {
    bool get ();
    void set (bool value);
}


IsMultiLegShippingSpecified Property

IsMultiLegShippingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► IsMultiLegShippingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMultiLegShippingSpecified { get; set; }
Public Property IsMultiLegShippingSpecified As Boolean
    Get
    Set
public:
property bool IsMultiLegShippingSpecified {
    bool get ();
    void set (bool value);
}


LogisticsPlanType Property

LogisticsPlanType Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► LogisticsPlanType
Declaration Syntax
C# Visual Basic Visual C++
public string LogisticsPlanType { get; set; }
Public Property LogisticsPlanType As String
    Get
    Set
public:
property String^ LogisticsPlanType {
    String^ get ();
    void set (String^ value);
}


MonetaryDetails Property

MonetaryDetails Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► MonetaryDetails
Declaration Syntax
C# Visual Basic Visual C++
public PaymentsInformationType MonetaryDetails { get; set; }
Public Property MonetaryDetails As PaymentsInformationType
    Get
    Set
public:
property PaymentsInformationType^ MonetaryDetails {
    PaymentsInformationType^ get ();
    void set (PaymentsInformationType^ value);
}


MultiLegShippingDetails Property

MultiLegShippingDetails Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► MultiLegShippingDetails
Declaration Syntax
C# Visual Basic Visual C++
public MultiLegShippingDetailsType MultiLegShippingDetails { get; set; }
Public Property MultiLegShippingDetails As MultiLegShippingDetailsType
    Get
    Set
public:
property MultiLegShippingDetailsType^ MultiLegShippingDetails {
    MultiLegShippingDetailsType^ get ();
    void set (MultiLegShippingDetailsType^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► OrderID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderStatus Property

OrderStatus Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► OrderStatus
Declaration Syntax
C# Visual Basic Visual C++
public OrderStatusCodeType OrderStatus { get; set; }
Public Property OrderStatus As OrderStatusCodeType
    Get
    Set
public:
property OrderStatusCodeType OrderStatus {
    OrderStatusCodeType get ();
    void set (OrderStatusCodeType value);
}


OrderStatusSpecified Property

OrderStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► OrderStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OrderStatusSpecified { get; set; }
Public Property OrderStatusSpecified As Boolean
    Get
    Set
public:
property bool OrderStatusSpecified {
    bool get ();
    void set (bool value);
}


OrderType Constructor

OrderType Constructor
Namespaces ► eBay.Service.Core.Soap ► OrderType ► OrderType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OrderType()
Public Sub New
public:
OrderType()


PaidTime Property

PaidTime Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► PaidTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PaidTime { get; set; }
Public Property PaidTime As DateTime
    Get
    Set
public:
property DateTime PaidTime {
    DateTime get ();
    void set (DateTime value);
}


PaidTimeSpecified Property

PaidTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► PaidTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaidTimeSpecified { get; set; }
Public Property PaidTimeSpecified As Boolean
    Get
    Set
public:
property bool PaidTimeSpecified {
    bool get ();
    void set (bool value);
}


PaymentHoldDetails Property

PaymentHoldDetails Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► PaymentHoldDetails
Declaration Syntax
C# Visual Basic Visual C++
public PaymentHoldDetailType PaymentHoldDetails { get; set; }
Public Property PaymentHoldDetails As PaymentHoldDetailType
    Get
    Set
public:
property PaymentHoldDetailType^ PaymentHoldDetails {
    PaymentHoldDetailType^ get ();
    void set (PaymentHoldDetailType^ value);
}


PaymentHoldStatus Property

PaymentHoldStatus Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► PaymentHoldStatus
Declaration Syntax
C# Visual Basic Visual C++
public PaymentHoldStatusCodeType PaymentHoldStatus { get; set; }
Public Property PaymentHoldStatus As PaymentHoldStatusCodeType
    Get
    Set
public:
property PaymentHoldStatusCodeType PaymentHoldStatus {
    PaymentHoldStatusCodeType get ();
    void set (PaymentHoldStatusCodeType value);
}


PaymentHoldStatusSpecified Property

PaymentHoldStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► PaymentHoldStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentHoldStatusSpecified { get; set; }
Public Property PaymentHoldStatusSpecified As Boolean
    Get
    Set
public:
property bool PaymentHoldStatusSpecified {
    bool get ();
    void set (bool value);
}


PaymentMethods Property

PaymentMethods Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► PaymentMethods
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeTypeCollection PaymentMethods { get; set; }
Public Property PaymentMethods As BuyerPaymentMethodCodeTypeCollection
    Get
    Set
public:
property BuyerPaymentMethodCodeTypeCollection^ PaymentMethods {
    BuyerPaymentMethodCodeTypeCollection^ get ();
    void set (BuyerPaymentMethodCodeTypeCollection^ value);
}


PickupDetails Property

PickupDetails Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► PickupDetails
Declaration Syntax
C# Visual Basic Visual C++
public PickupDetailsType PickupDetails { get; set; }
Public Property PickupDetails As PickupDetailsType
    Get
    Set
public:
property PickupDetailsType^ PickupDetails {
    PickupDetailsType^ get ();
    void set (PickupDetailsType^ value);
}


PickupMethodSelected Property

PickupMethodSelected Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► PickupMethodSelected
Declaration Syntax
C# Visual Basic Visual C++
public PickupMethodSelectedType PickupMethodSelected { get; set; }
Public Property PickupMethodSelected As PickupMethodSelectedType
    Get
    Set
public:
property PickupMethodSelectedType^ PickupMethodSelected {
    PickupMethodSelectedType^ get ();
    void set (PickupMethodSelectedType^ value);
}


RefundAmount Property

RefundAmount Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► RefundAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType RefundAmount { get; set; }
Public Property RefundAmount As AmountType
    Get
    Set
public:
property AmountType^ RefundAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


RefundArray Property

RefundArray Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► RefundArray
Declaration Syntax
C# Visual Basic Visual C++
public RefundTypeCollection RefundArray { get; set; }
Public Property RefundArray As RefundTypeCollection
    Get
    Set
public:
property RefundTypeCollection^ RefundArray {
    RefundTypeCollection^ get ();
    void set (RefundTypeCollection^ value);
}


RefundStatus Property

RefundStatus Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► RefundStatus
Declaration Syntax
C# Visual Basic Visual C++
public string RefundStatus { get; set; }
Public Property RefundStatus As String
    Get
    Set
public:
property String^ RefundStatus {
    String^ get ();
    void set (String^ value);
}


SellerEIASToken Property

SellerEIASToken Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► SellerEIASToken
Declaration Syntax
C# Visual Basic Visual C++
public string SellerEIASToken { get; set; }
Public Property SellerEIASToken As String
    Get
    Set
public:
property String^ SellerEIASToken {
    String^ get ();
    void set (String^ value);
}


SellerEmail Property

SellerEmail Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► SellerEmail
Declaration Syntax
C# Visual Basic Visual C++
public string SellerEmail { get; set; }
Public Property SellerEmail As String
    Get
    Set
public:
property String^ SellerEmail {
    String^ get ();
    void set (String^ value);
}


SellerUserID Property

SellerUserID Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► SellerUserID
Declaration Syntax
C# Visual Basic Visual C++
public string SellerUserID { get; set; }
Public Property SellerUserID As String
    Get
    Set
public:
property String^ SellerUserID {
    String^ get ();
    void set (String^ value);
}


ShippedTime Property

ShippedTime Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► ShippedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ShippedTime { get; set; }
Public Property ShippedTime As DateTime
    Get
    Set
public:
property DateTime ShippedTime {
    DateTime get ();
    void set (DateTime value);
}


ShippedTimeSpecified Property

ShippedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► ShippedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippedTimeSpecified { get; set; }
Public Property ShippedTimeSpecified As Boolean
    Get
    Set
public:
property bool ShippedTimeSpecified {
    bool get ();
    void set (bool value);
}


ShippingAddress Property

ShippingAddress Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► ShippingAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType ShippingAddress { get; set; }
Public Property ShippingAddress As AddressType
    Get
    Set
public:
property AddressType^ ShippingAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


ShippingConvenienceCharge Property

ShippingConvenienceCharge Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► ShippingConvenienceCharge
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingConvenienceCharge { get; set; }
Public Property ShippingConvenienceCharge As AmountType
    Get
    Set
public:
property AmountType^ ShippingConvenienceCharge {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingDetails Property

ShippingDetails Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► ShippingDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShippingDetailsType ShippingDetails { get; set; }
Public Property ShippingDetails As ShippingDetailsType
    Get
    Set
public:
property ShippingDetailsType^ ShippingDetails {
    ShippingDetailsType^ get ();
    void set (ShippingDetailsType^ value);
}


ShippingServiceSelected Property

ShippingServiceSelected Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► ShippingServiceSelected
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsType ShippingServiceSelected { get; set; }
Public Property ShippingServiceSelected As ShippingServiceOptionsType
    Get
    Set
public:
property ShippingServiceOptionsType^ ShippingServiceSelected {
    ShippingServiceOptionsType^ get ();
    void set (ShippingServiceOptionsType^ value);
}


Subtotal Property

Subtotal Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► Subtotal
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Subtotal { get; set; }
Public Property Subtotal As AmountType
    Get
    Set
public:
property AmountType^ Subtotal {
    AmountType^ get ();
    void set (AmountType^ value);
}


Total Property

Total Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► Total
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Total { get; set; }
Public Property Total As AmountType
    Get
    Set
public:
property AmountType^ Total {
    AmountType^ get ();
    void set (AmountType^ value);
}


TransactionArray Property

TransactionArray Property
Namespaces ► eBay.Service.Core.Soap ► OrderType ► TransactionArray
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection TransactionArray { get; set; }
Public Property TransactionArray As TransactionTypeCollection
    Get
    Set
public:
property TransactionTypeCollection^ TransactionArray {
    TransactionTypeCollection^ get ();
    void set (TransactionTypeCollection^ value);
}


OrderTypeCollection Class

OrderTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class OrderTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class OrderTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class OrderTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OrderTypeCollection()()()() |
 | OrderTypeCollection(array<OrderType>[]()[][]) |
 | OrderTypeCollection(OrderTypeCollection) |
 | Add(OrderType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<OrderType>[]()[][]) |
 | AddRange(OrderTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(OrderType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<OrderType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(OrderType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, OrderType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(OrderType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | OrderTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► Add(OrderType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    OrderType item
)
Public Function Add ( _
    item As OrderType _
) As Integer
public:
int Add(
    OrderType^ item
)
Parameters
item (OrderType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<OrderType>[]()[][]) |
 | AddRange(OrderTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► AddRange(array<OrderType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    OrderType[] items
)
Public Sub AddRange ( _
    items As OrderType() _
)
public:
void AddRange(
    array<OrderType^>^ items
)
Parameters
items (array< OrderType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► AddRange(OrderTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    OrderTypeCollection items
)
Public Sub AddRange ( _
    items As OrderTypeCollection _
)
public:
void AddRange(
    OrderTypeCollection^ items
)
Parameters
items (OrderTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► Contains(OrderType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    OrderType item
)
Public Function Contains ( _
    item As OrderType _
) As Boolean
public:
bool Contains(
    OrderType^ item
)
Parameters
item (OrderType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► CopyTo(array<OrderType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    OrderType[] items,
    int index
)
Public Sub CopyTo ( _
    items As OrderType(), _
    index As Integer _
)
public:
void CopyTo(
    array<OrderType^>^ items,
    int index
)
Parameters
items (array< OrderType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► IndexOf(OrderType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    OrderType item
)
Public Function IndexOf ( _
    item As OrderType _
) As Integer
public:
int IndexOf(
    OrderType^ item
)
Parameters
item (OrderType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► Insert(Int32, OrderType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    OrderType item
)
Public Sub Insert ( _
    index As Integer, _
    item As OrderType _
)
public:
void Insert(
    int index,
    OrderType^ item
)
Parameters
index (Int32)
item (OrderType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public OrderType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As OrderType
    Get
    Set
public:
property OrderType^ default[int index] {
    OrderType^ get (int index);
    void set (int index, OrderType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public OrderType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As OrderType
public:
OrderType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


OrderTypeCollection Constructor

OrderTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► OrderTypeCollection()()()()
Members
Icon | Member | Description
 | OrderTypeCollection()()()() |
 | OrderTypeCollection(array<OrderType>[]()[][]) |
 | OrderTypeCollection(OrderTypeCollection) |


OrderTypeCollection Constructor

OrderTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► OrderTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection()
Public Sub New
public:
OrderTypeCollection()


OrderTypeCollection Constructor (items)

OrderTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► OrderTypeCollection(array<OrderType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection(
    OrderType[] items
)
Public Sub New ( _
    items As OrderType() _
)
public:
OrderTypeCollection(
    array<OrderType^>^ items
)
Parameters
items (array< OrderType >[]()[][])


OrderTypeCollection Constructor (items)

OrderTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► OrderTypeCollection(OrderTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public OrderTypeCollection(
    OrderTypeCollection items
)
Public Sub New ( _
    items As OrderTypeCollection _
)
public:
OrderTypeCollection(
    OrderTypeCollection^ items
)
Parameters
items (OrderTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► Remove(OrderType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    OrderType item
)
Public Sub Remove ( _
    item As OrderType _
)
public:
void Remove(
    OrderType^ item
)
Parameters
item (OrderType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public OrderType[] ToArray()
Public Function ToArray As OrderType()
public:
array<OrderType^>^ ToArray()
Return Value


PaginatedItemArrayType Class

PaginatedItemArrayType Class
Namespaces ► eBay.Service.Core.Soap ► PaginatedItemArrayType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaginatedItemArrayType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaginatedItemArrayType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaginatedItemArrayType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaginatedItemArrayType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemArray |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PaginationResult |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PaginatedItemArrayType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaginatedItemArrayType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemArray Property

ItemArray Property
Namespaces ► eBay.Service.Core.Soap ► PaginatedItemArrayType ► ItemArray
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection ItemArray { get; set; }
Public Property ItemArray As ItemTypeCollection
    Get
    Set
public:
property ItemTypeCollection^ ItemArray {
    ItemTypeCollection^ get ();
    void set (ItemTypeCollection^ value);
}


PaginatedItemArrayType Constructor

PaginatedItemArrayType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaginatedItemArrayType ► PaginatedItemArrayType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedItemArrayType()
Public Sub New
public:
PaginatedItemArrayType()


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► PaginatedItemArrayType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


PaginatedOrderTransactionArrayType Class

PaginatedOrderTransactionArrayType Class
Namespaces ► eBay.Service.Core.Soap ► PaginatedOrderTransactionArrayType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaginatedOrderTransactionArrayType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaginatedOrderTransactionArrayType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaginatedOrderTransactionArrayType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaginatedOrderTransactionArrayType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderTransactionArray |
 | PaginationResult |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PaginatedOrderTransactionArrayType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaginatedOrderTransactionArrayType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


OrderTransactionArray Property

OrderTransactionArray Property
Namespaces ► eBay.Service.Core.Soap ► PaginatedOrderTransactionArrayType ► OrderTransactionArray
Declaration Syntax
C# Visual Basic Visual C++
public OrderTransactionTypeCollection OrderTransactionArray { get; set; }
Public Property OrderTransactionArray As OrderTransactionTypeCollection
    Get
    Set
public:
property OrderTransactionTypeCollection^ OrderTransactionArray {
    OrderTransactionTypeCollection^ get ();
    void set (OrderTransactionTypeCollection^ value);
}


PaginatedOrderTransactionArrayType Constructor

PaginatedOrderTransactionArrayType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaginatedOrderTransactionArrayType ► PaginatedOrderTransactionArrayType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedOrderTransactionArrayType()
Public Sub New
public:
PaginatedOrderTransactionArrayType()


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► PaginatedOrderTransactionArrayType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


PaginatedTransactionArrayType Class

PaginatedTransactionArrayType Class
Namespaces ► eBay.Service.Core.Soap ► PaginatedTransactionArrayType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaginatedTransactionArrayType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaginatedTransactionArrayType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaginatedTransactionArrayType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaginatedTransactionArrayType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PaginationResult |
 | ToString()()()() | (Inherited from Object.)
 | TransactionArray |
Remarks
Inheritance Hierarchy
Object
PaginatedTransactionArrayType


PaginatedTransactionArrayType Constructor

PaginatedTransactionArrayType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaginatedTransactionArrayType ► PaginatedTransactionArrayType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaginatedTransactionArrayType()
Public Sub New
public:
PaginatedTransactionArrayType()


PaginationResult Property

PaginationResult Property
Namespaces ► eBay.Service.Core.Soap ► PaginatedTransactionArrayType ► PaginationResult
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType PaginationResult { get; set; }
Public Property PaginationResult As PaginationResultType
    Get
    Set
public:
property PaginationResultType^ PaginationResult {
    PaginationResultType^ get ();
    void set (PaginationResultType^ value);
}


TransactionArray Property

TransactionArray Property
Namespaces ► eBay.Service.Core.Soap ► PaginatedTransactionArrayType ► TransactionArray
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection TransactionArray { get; set; }
Public Property TransactionArray As TransactionTypeCollection
    Get
    Set
public:
property TransactionTypeCollection^ TransactionArray {
    TransactionTypeCollection^ get ();
    void set (TransactionTypeCollection^ value);
}


PaginationResultType Class

PaginationResultType Class
Namespaces ► eBay.Service.Core.Soap ► PaginationResultType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaginationResultType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaginationResultType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaginationResultType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaginationResultType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | TotalNumberOfEntries |
 | TotalNumberOfEntriesSpecified |
 | TotalNumberOfPages |
 | TotalNumberOfPagesSpecified |
Remarks
Inheritance Hierarchy
Object
PaginationResultType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaginationResultType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PaginationResultType Constructor

PaginationResultType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaginationResultType ► PaginationResultType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaginationResultType()
Public Sub New
public:
PaginationResultType()


TotalNumberOfEntries Property

TotalNumberOfEntries Property
Namespaces ► eBay.Service.Core.Soap ► PaginationResultType ► TotalNumberOfEntries
Declaration Syntax
C# Visual Basic Visual C++
public int TotalNumberOfEntries { get; set; }
Public Property TotalNumberOfEntries As Integer
    Get
    Set
public:
property int TotalNumberOfEntries {
    int get ();
    void set (int value);
}


TotalNumberOfEntriesSpecified Property

TotalNumberOfEntriesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaginationResultType ► TotalNumberOfEntriesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalNumberOfEntriesSpecified { get; set; }
Public Property TotalNumberOfEntriesSpecified As Boolean
    Get
    Set
public:
property bool TotalNumberOfEntriesSpecified {
    bool get ();
    void set (bool value);
}


TotalNumberOfPages Property

TotalNumberOfPages Property
Namespaces ► eBay.Service.Core.Soap ► PaginationResultType ► TotalNumberOfPages
Declaration Syntax
C# Visual Basic Visual C++
public int TotalNumberOfPages { get; set; }
Public Property TotalNumberOfPages As Integer
    Get
    Set
public:
property int TotalNumberOfPages {
    int get ();
    void set (int value);
}


TotalNumberOfPagesSpecified Property

TotalNumberOfPagesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaginationResultType ► TotalNumberOfPagesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalNumberOfPagesSpecified { get; set; }
Public Property TotalNumberOfPagesSpecified As Boolean
    Get
    Set
public:
property bool TotalNumberOfPagesSpecified {
    bool get ();
    void set (bool value);
}


PaginationType Class

PaginationType Class
Namespaces ► eBay.Service.Core.Soap ► PaginationType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaginationType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaginationType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaginationType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaginationType()()()() |
 | Any |
 | EntriesPerPage |
 | EntriesPerPageSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PageNumber |
 | PageNumberSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PaginationType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaginationType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EntriesPerPage Property

EntriesPerPage Property
Namespaces ► eBay.Service.Core.Soap ► PaginationType ► EntriesPerPage
Declaration Syntax
C# Visual Basic Visual C++
public int EntriesPerPage { get; set; }
Public Property EntriesPerPage As Integer
    Get
    Set
public:
property int EntriesPerPage {
    int get ();
    void set (int value);
}


EntriesPerPageSpecified Property

EntriesPerPageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaginationType ► EntriesPerPageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EntriesPerPageSpecified { get; set; }
Public Property EntriesPerPageSpecified As Boolean
    Get
    Set
public:
property bool EntriesPerPageSpecified {
    bool get ();
    void set (bool value);
}


PageNumber Property

PageNumber Property
Namespaces ► eBay.Service.Core.Soap ► PaginationType ► PageNumber
Declaration Syntax
C# Visual Basic Visual C++
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}


PageNumberSpecified Property

PageNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaginationType ► PageNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageNumberSpecified { get; set; }
Public Property PageNumberSpecified As Boolean
    Get
    Set
public:
property bool PageNumberSpecified {
    bool get ();
    void set (bool value);
}


PaginationType Constructor

PaginationType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaginationType ► PaginationType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaginationType()
Public Sub New
public:
PaginationType()


PaidStatusCodeType Enumeration

PaidStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PaidStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PaidStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PaidStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PaidStatusCodeType
Members
Member | Description
NotPaid |
BuyerHasNotCompletedCheckout |
PaymentPendingWithPayPal |
PaidWithPayPal |
MarkedAsPaid |
PaymentPendingWithEscrow |
PaidWithEscrow |
EscrowPaymentCancelled |
PaymentPendingWithPaisaPay |
PaidWithPaisaPay |
PaymentPending |
PaymentPendingWithPaisaPayEscrow |
PaidWithPaisaPayEscrow |
PaisaPayNotPaid |
Refunded |
WaitingForCODPayment |
PaidCOD |
CustomCode |
Paid |
PayUponInvoice |
Remarks


PaisaPayFullEscrowEnabledDefinitionType Class

PaisaPayFullEscrowEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► PaisaPayFullEscrowEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaisaPayFullEscrowEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaisaPayFullEscrowEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaisaPayFullEscrowEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaisaPayFullEscrowEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PaisaPayFullEscrowEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaisaPayFullEscrowEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PaisaPayFullEscrowEnabledDefinitionType Constructor

PaisaPayFullEscrowEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaisaPayFullEscrowEnabledDefinitionType ► PaisaPayFullEscrowEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaisaPayFullEscrowEnabledDefinitionType()
Public Sub New
public:
PaisaPayFullEscrowEnabledDefinitionType()


PaymentDetailsType Class

PaymentDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► PaymentDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaymentDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaymentDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaymentDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaymentDetailsType()()()() |
 | Any |
 | DaysToFullPayment |
 | DaysToFullPaymentSpecified |
 | DepositAmount |
 | DepositType |
 | DepositTypeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HoursToDeposit |
 | HoursToDepositSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PaymentDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaymentDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DaysToFullPayment Property

DaysToFullPayment Property
Namespaces ► eBay.Service.Core.Soap ► PaymentDetailsType ► DaysToFullPayment
Declaration Syntax
C# Visual Basic Visual C++
public int DaysToFullPayment { get; set; }
Public Property DaysToFullPayment As Integer
    Get
    Set
public:
property int DaysToFullPayment {
    int get ();
    void set (int value);
}


DaysToFullPaymentSpecified Property

DaysToFullPaymentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaymentDetailsType ► DaysToFullPaymentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DaysToFullPaymentSpecified { get; set; }
Public Property DaysToFullPaymentSpecified As Boolean
    Get
    Set
public:
property bool DaysToFullPaymentSpecified {
    bool get ();
    void set (bool value);
}


DepositAmount Property

DepositAmount Property
Namespaces ► eBay.Service.Core.Soap ► PaymentDetailsType ► DepositAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType DepositAmount { get; set; }
Public Property DepositAmount As AmountType
    Get
    Set
public:
property AmountType^ DepositAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


DepositType Property

DepositType Property
Namespaces ► eBay.Service.Core.Soap ► PaymentDetailsType ► DepositType
Declaration Syntax
C# Visual Basic Visual C++
public DepositTypeCodeType DepositType { get; set; }
Public Property DepositType As DepositTypeCodeType
    Get
    Set
public:
property DepositTypeCodeType DepositType {
    DepositTypeCodeType get ();
    void set (DepositTypeCodeType value);
}


DepositTypeSpecified Property

DepositTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaymentDetailsType ► DepositTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DepositTypeSpecified { get; set; }
Public Property DepositTypeSpecified As Boolean
    Get
    Set
public:
property bool DepositTypeSpecified {
    bool get ();
    void set (bool value);
}


HoursToDeposit Property

HoursToDeposit Property
Namespaces ► eBay.Service.Core.Soap ► PaymentDetailsType ► HoursToDeposit
Declaration Syntax
C# Visual Basic Visual C++
public int HoursToDeposit { get; set; }
Public Property HoursToDeposit As Integer
    Get
    Set
public:
property int HoursToDeposit {
    int get ();
    void set (int value);
}


HoursToDepositSpecified Property

HoursToDepositSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaymentDetailsType ► HoursToDepositSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HoursToDepositSpecified { get; set; }
Public Property HoursToDepositSpecified As Boolean
    Get
    Set
public:
property bool HoursToDepositSpecified {
    bool get ();
    void set (bool value);
}


PaymentDetailsType Constructor

PaymentDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentDetailsType ► PaymentDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentDetailsType()
Public Sub New
public:
PaymentDetailsType()


PaymentHoldDetailType Class

PaymentHoldDetailType Class
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldDetailType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaymentHoldDetailType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaymentHoldDetailType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaymentHoldDetailType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaymentHoldDetailType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | ExpectedReleaseDate |
 | ExpectedReleaseDateSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NumOfReqSellerActions |
 | NumOfReqSellerActionsSpecified |
 | PaymentHoldReason |
 | PaymentHoldReasonSpecified |
 | RequiredSellerActionArray |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PaymentHoldDetailType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldDetailType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExpectedReleaseDate Property

ExpectedReleaseDate Property
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldDetailType ► ExpectedReleaseDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ExpectedReleaseDate { get; set; }
Public Property ExpectedReleaseDate As DateTime
    Get
    Set
public:
property DateTime ExpectedReleaseDate {
    DateTime get ();
    void set (DateTime value);
}


ExpectedReleaseDateSpecified Property

ExpectedReleaseDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldDetailType ► ExpectedReleaseDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpectedReleaseDateSpecified { get; set; }
Public Property ExpectedReleaseDateSpecified As Boolean
    Get
    Set
public:
property bool ExpectedReleaseDateSpecified {
    bool get ();
    void set (bool value);
}


NumOfReqSellerActions Property

NumOfReqSellerActions Property
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldDetailType ► NumOfReqSellerActions
Declaration Syntax
C# Visual Basic Visual C++
public int NumOfReqSellerActions { get; set; }
Public Property NumOfReqSellerActions As Integer
    Get
    Set
public:
property int NumOfReqSellerActions {
    int get ();
    void set (int value);
}


NumOfReqSellerActionsSpecified Property

NumOfReqSellerActionsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldDetailType ► NumOfReqSellerActionsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NumOfReqSellerActionsSpecified { get; set; }
Public Property NumOfReqSellerActionsSpecified As Boolean
    Get
    Set
public:
property bool NumOfReqSellerActionsSpecified {
    bool get ();
    void set (bool value);
}


PaymentHoldDetailType Constructor

PaymentHoldDetailType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldDetailType ► PaymentHoldDetailType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentHoldDetailType()
Public Sub New
public:
PaymentHoldDetailType()


PaymentHoldReason Property

PaymentHoldReason Property
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldDetailType ► PaymentHoldReason
Declaration Syntax
C# Visual Basic Visual C++
public PaymentHoldReasonCodeType PaymentHoldReason { get; set; }
Public Property PaymentHoldReason As PaymentHoldReasonCodeType
    Get
    Set
public:
property PaymentHoldReasonCodeType PaymentHoldReason {
    PaymentHoldReasonCodeType get ();
    void set (PaymentHoldReasonCodeType value);
}


PaymentHoldReasonSpecified Property

PaymentHoldReasonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldDetailType ► PaymentHoldReasonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentHoldReasonSpecified { get; set; }
Public Property PaymentHoldReasonSpecified As Boolean
    Get
    Set
public:
property bool PaymentHoldReasonSpecified {
    bool get ();
    void set (bool value);
}


RequiredSellerActionArray Property

RequiredSellerActionArray Property
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldDetailType ► RequiredSellerActionArray
Declaration Syntax
C# Visual Basic Visual C++
public RequiredSellerActionCodeTypeCollection RequiredSellerActionArray { get; set; }
Public Property RequiredSellerActionArray As RequiredSellerActionCodeTypeCollection
    Get
    Set
public:
property RequiredSellerActionCodeTypeCollection^ RequiredSellerActionArray {
    RequiredSellerActionCodeTypeCollection^ get ();
    void set (RequiredSellerActionCodeTypeCollection^ value);
}


PaymentHoldReasonCodeType Enumeration

PaymentHoldReasonCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldReasonCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PaymentHoldReasonCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PaymentHoldReasonCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PaymentHoldReasonCodeType
Members
Member | Description
NewSeller |
BelowStandardSeller |
EbpCaseOpen |
ReinstatementAfterSuspension |
CasualSeller |
NewPaypalAccountAdded |
NotAvailable |
SellerIsOnBlackList |
Other |
None |
CustomCode |
Remarks


PaymentHoldStatusCodeType Enumeration

PaymentHoldStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PaymentHoldStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PaymentHoldStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PaymentHoldStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PaymentHoldStatusCodeType
Members
Member | Description
PaymentReview |
MerchantHold |
Released |
None |
NewSellerHold |
PaymentHold |
ReleasePending |
ReleaseConfirmed |
ReleaseFailed |
CustomCode |
Remarks


PaymentInformationType Class

PaymentInformationType Class
Namespaces ► eBay.Service.Core.Soap ► PaymentInformationType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaymentInformationType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaymentInformationType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaymentInformationType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaymentInformationType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Payment |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PaymentInformationType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaymentInformationType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Payment Property

Payment Property
Namespaces ► eBay.Service.Core.Soap ► PaymentInformationType ► Payment
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTransactionTypeCollection Payment { get; set; }
Public Property Payment As PaymentTransactionTypeCollection
    Get
    Set
public:
property PaymentTransactionTypeCollection^ Payment {
    PaymentTransactionTypeCollection^ get ();
    void set (PaymentTransactionTypeCollection^ value);
}


PaymentInformationType Constructor

PaymentInformationType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentInformationType ► PaymentInformationType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentInformationType()
Public Sub New
public:
PaymentInformationType()


PaymentInstructionCodeType Enumeration

PaymentInstructionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PaymentInstructionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PaymentInstructionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PaymentInstructionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PaymentInstructionCodeType
Members
Member | Description
PaymentInstruction |
CustomCode |
Remarks


PaymentMethodDefinitionType Class

PaymentMethodDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► PaymentMethodDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaymentMethodDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaymentMethodDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaymentMethodDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaymentMethodDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PaymentMethodDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaymentMethodDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PaymentMethodDefinitionType Constructor

PaymentMethodDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentMethodDefinitionType ► PaymentMethodDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentMethodDefinitionType()
Public Sub New
public:
PaymentMethodDefinitionType()


PaymentMethodSearchCodeType Enumeration

PaymentMethodSearchCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PaymentMethodSearchCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PaymentMethodSearchCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PaymentMethodSearchCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PaymentMethodSearchCodeType
Members
Member | Description
PayPal |
PaisaPay |
PayPalOrPaisaPay |
CustomCode |
PaisaPayEscrowEMI |
Remarks


PaymentOptionDetailsType Class

PaymentOptionDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaymentOptionDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaymentOptionDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaymentOptionDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaymentOptionDetailsType()()()() |
 | Any |
 | Description |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PaymentOption |
 | PaymentOptionSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
PaymentOptionDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


PaymentOption Property

PaymentOption Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsType ► PaymentOption
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeType PaymentOption { get; set; }
Public Property PaymentOption As BuyerPaymentMethodCodeType
    Get
    Set
public:
property BuyerPaymentMethodCodeType PaymentOption {
    BuyerPaymentMethodCodeType get ();
    void set (BuyerPaymentMethodCodeType value);
}


PaymentOptionDetailsType Constructor

PaymentOptionDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsType ► PaymentOptionDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionDetailsType()
Public Sub New
public:
PaymentOptionDetailsType()


PaymentOptionSpecified Property

PaymentOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsType ► PaymentOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentOptionSpecified { get; set; }
Public Property PaymentOptionSpecified As Boolean
    Get
    Set
public:
property bool PaymentOptionSpecified {
    bool get ();
    void set (bool value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


PaymentOptionDetailsTypeCollection Class

PaymentOptionDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PaymentOptionDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PaymentOptionDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PaymentOptionDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaymentOptionDetailsTypeCollection()()()() |
 | PaymentOptionDetailsTypeCollection(array<PaymentOptionDetailsType>[]()[][]) |
 | PaymentOptionDetailsTypeCollection(PaymentOptionDetailsTypeCollection) |
 | Add(PaymentOptionDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PaymentOptionDetailsType>[]()[][]) |
 | AddRange(PaymentOptionDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PaymentOptionDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PaymentOptionDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PaymentOptionDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PaymentOptionDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PaymentOptionDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PaymentOptionDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► Add(PaymentOptionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PaymentOptionDetailsType item
)
Public Function Add ( _
    item As PaymentOptionDetailsType _
) As Integer
public:
int Add(
    PaymentOptionDetailsType^ item
)
Parameters
item (PaymentOptionDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PaymentOptionDetailsType>[]()[][]) |
 | AddRange(PaymentOptionDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► AddRange(array<PaymentOptionDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PaymentOptionDetailsType[] items
)
Public Sub AddRange ( _
    items As PaymentOptionDetailsType() _
)
public:
void AddRange(
    array<PaymentOptionDetailsType^>^ items
)
Parameters
items (array< PaymentOptionDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► AddRange(PaymentOptionDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PaymentOptionDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As PaymentOptionDetailsTypeCollection _
)
public:
void AddRange(
    PaymentOptionDetailsTypeCollection^ items
)
Parameters
items (PaymentOptionDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► Contains(PaymentOptionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PaymentOptionDetailsType item
)
Public Function Contains ( _
    item As PaymentOptionDetailsType _
) As Boolean
public:
bool Contains(
    PaymentOptionDetailsType^ item
)
Parameters
item (PaymentOptionDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► CopyTo(array<PaymentOptionDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PaymentOptionDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PaymentOptionDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PaymentOptionDetailsType^>^ items,
    int index
)
Parameters
items (array< PaymentOptionDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► IndexOf(PaymentOptionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PaymentOptionDetailsType item
)
Public Function IndexOf ( _
    item As PaymentOptionDetailsType _
) As Integer
public:
int IndexOf(
    PaymentOptionDetailsType^ item
)
Parameters
item (PaymentOptionDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► Insert(Int32, PaymentOptionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PaymentOptionDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PaymentOptionDetailsType _
)
public:
void Insert(
    int index,
    PaymentOptionDetailsType^ item
)
Parameters
index (Int32)
item (PaymentOptionDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PaymentOptionDetailsType
    Get
    Set
public:
property PaymentOptionDetailsType^ default[int index] {
    PaymentOptionDetailsType^ get (int index);
    void set (int index, PaymentOptionDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PaymentOptionDetailsType
public:
PaymentOptionDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PaymentOptionDetailsTypeCollection Constructor

PaymentOptionDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► PaymentOptionDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | PaymentOptionDetailsTypeCollection()()()() |
 | PaymentOptionDetailsTypeCollection(array<PaymentOptionDetailsType>[]()[][]) |
 | PaymentOptionDetailsTypeCollection(PaymentOptionDetailsTypeCollection) |


PaymentOptionDetailsTypeCollection Constructor

PaymentOptionDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► PaymentOptionDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionDetailsTypeCollection()
Public Sub New
public:
PaymentOptionDetailsTypeCollection()


PaymentOptionDetailsTypeCollection Constructor (items)

PaymentOptionDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► PaymentOptionDetailsTypeCollection(array<PaymentOptionDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionDetailsTypeCollection(
    PaymentOptionDetailsType[] items
)
Public Sub New ( _
    items As PaymentOptionDetailsType() _
)
public:
PaymentOptionDetailsTypeCollection(
    array<PaymentOptionDetailsType^>^ items
)
Parameters
items (array< PaymentOptionDetailsType >[]()[][])


PaymentOptionDetailsTypeCollection Constructor (items)

PaymentOptionDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► PaymentOptionDetailsTypeCollection(PaymentOptionDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionDetailsTypeCollection(
    PaymentOptionDetailsTypeCollection items
)
Public Sub New ( _
    items As PaymentOptionDetailsTypeCollection _
)
public:
PaymentOptionDetailsTypeCollection(
    PaymentOptionDetailsTypeCollection^ items
)
Parameters
items (PaymentOptionDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► Remove(PaymentOptionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PaymentOptionDetailsType item
)
Public Sub Remove ( _
    item As PaymentOptionDetailsType _
)
public:
void Remove(
    PaymentOptionDetailsType^ item
)
Parameters
item (PaymentOptionDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionDetailsType[] ToArray()
Public Function ToArray As PaymentOptionDetailsType()
public:
array<PaymentOptionDetailsType^>^ ToArray()
Return Value


PaymentOptionsGroupEnabledCodeType Enumeration

PaymentOptionsGroupEnabledCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionsGroupEnabledCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PaymentOptionsGroupEnabledCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PaymentOptionsGroupEnabledCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PaymentOptionsGroupEnabledCodeType
Members
Member | Description
eBayPaymentProcessEnabled |
NonStandardPaymentsEnabled |
eBayPaymentProcessExcluded |
CustomCode |
Remarks


PaymentOptionsGroupEnabledDefinitionType Class

PaymentOptionsGroupEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionsGroupEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaymentOptionsGroupEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaymentOptionsGroupEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaymentOptionsGroupEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaymentOptionsGroupEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PaymentOptionsGroupEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionsGroupEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PaymentOptionsGroupEnabledDefinitionType Constructor

PaymentOptionsGroupEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionsGroupEnabledDefinitionType ► PaymentOptionsGroupEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionsGroupEnabledDefinitionType()
Public Sub New
public:
PaymentOptionsGroupEnabledDefinitionType()


PaymentsInformationType Class

PaymentsInformationType Class
Namespaces ► eBay.Service.Core.Soap ► PaymentsInformationType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaymentsInformationType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaymentsInformationType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaymentsInformationType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaymentsInformationType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Payments |
 | Refunds |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PaymentsInformationType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaymentsInformationType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Payments Property

Payments Property
Namespaces ► eBay.Service.Core.Soap ► PaymentsInformationType ► Payments
Declaration Syntax
C# Visual Basic Visual C++
public PaymentInformationType Payments { get; set; }
Public Property Payments As PaymentInformationType
    Get
    Set
public:
property PaymentInformationType^ Payments {
    PaymentInformationType^ get ();
    void set (PaymentInformationType^ value);
}


PaymentsInformationType Constructor

PaymentsInformationType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentsInformationType ► PaymentsInformationType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentsInformationType()
Public Sub New
public:
PaymentsInformationType()


Refunds Property

Refunds Property
Namespaces ► eBay.Service.Core.Soap ► PaymentsInformationType ► Refunds
Declaration Syntax
C# Visual Basic Visual C++
public RefundInformationType Refunds { get; set; }
Public Property Refunds As RefundInformationType
    Get
    Set
public:
property RefundInformationType^ Refunds {
    RefundInformationType^ get ();
    void set (RefundInformationType^ value);
}


PaymentStatusCodeType Enumeration

PaymentStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PaymentStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PaymentStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PaymentStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PaymentStatusCodeType
Members
Member | Description
NoPaymentFailure |
BuyerECheckBounced |
BuyerCreditCardFailed |
BuyerFailedPaymentReportedBySeller |
PayPalPaymentInProcess |
PaymentInProcess |
CustomCode |
Remarks


PaymentTransactionStatusCodeType Enumeration

PaymentTransactionStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PaymentTransactionStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PaymentTransactionStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PaymentTransactionStatusCodeType
Members
Member | Description
Failed |
Succeeded |
Pending |
CustomCode |
Remarks


PaymentTransactionType Class

PaymentTransactionType Class
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PaymentTransactionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PaymentTransactionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PaymentTransactionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaymentTransactionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | FeeOrCreditAmount |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Payee |
 | Payer |
 | PaymentAmount |
 | PaymentReferenceID |
 | PaymentStatus |
 | PaymentStatusSpecified |
 | PaymentTime |
 | PaymentTimeSpecified |
 | ReferenceID |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PaymentTransactionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FeeOrCreditAmount Property

FeeOrCreditAmount Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► FeeOrCreditAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType FeeOrCreditAmount { get; set; }
Public Property FeeOrCreditAmount As AmountType
    Get
    Set
public:
property AmountType^ FeeOrCreditAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


Payee Property

Payee Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► Payee
Declaration Syntax
C# Visual Basic Visual C++
public UserIdentityType Payee { get; set; }
Public Property Payee As UserIdentityType
    Get
    Set
public:
property UserIdentityType^ Payee {
    UserIdentityType^ get ();
    void set (UserIdentityType^ value);
}


Payer Property

Payer Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► Payer
Declaration Syntax
C# Visual Basic Visual C++
public UserIdentityType Payer { get; set; }
Public Property Payer As UserIdentityType
    Get
    Set
public:
property UserIdentityType^ Payer {
    UserIdentityType^ get ();
    void set (UserIdentityType^ value);
}


PaymentAmount Property

PaymentAmount Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► PaymentAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType PaymentAmount { get; set; }
Public Property PaymentAmount As AmountType
    Get
    Set
public:
property AmountType^ PaymentAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


PaymentReferenceID Property

PaymentReferenceID Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► PaymentReferenceID
Declaration Syntax
C# Visual Basic Visual C++
public TransactionReferenceTypeCollection PaymentReferenceID { get; set; }
Public Property PaymentReferenceID As TransactionReferenceTypeCollection
    Get
    Set
public:
property TransactionReferenceTypeCollection^ PaymentReferenceID {
    TransactionReferenceTypeCollection^ get ();
    void set (TransactionReferenceTypeCollection^ value);
}


PaymentStatus Property

PaymentStatus Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► PaymentStatus
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTransactionStatusCodeType PaymentStatus { get; set; }
Public Property PaymentStatus As PaymentTransactionStatusCodeType
    Get
    Set
public:
property PaymentTransactionStatusCodeType PaymentStatus {
    PaymentTransactionStatusCodeType get ();
    void set (PaymentTransactionStatusCodeType value);
}


PaymentStatusSpecified Property

PaymentStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► PaymentStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentStatusSpecified { get; set; }
Public Property PaymentStatusSpecified As Boolean
    Get
    Set
public:
property bool PaymentStatusSpecified {
    bool get ();
    void set (bool value);
}


PaymentTime Property

PaymentTime Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► PaymentTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PaymentTime { get; set; }
Public Property PaymentTime As DateTime
    Get
    Set
public:
property DateTime PaymentTime {
    DateTime get ();
    void set (DateTime value);
}


PaymentTimeSpecified Property

PaymentTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► PaymentTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentTimeSpecified { get; set; }
Public Property PaymentTimeSpecified As Boolean
    Get
    Set
public:
property bool PaymentTimeSpecified {
    bool get ();
    void set (bool value);
}


PaymentTransactionType Constructor

PaymentTransactionType Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► PaymentTransactionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTransactionType()
Public Sub New
public:
PaymentTransactionType()


ReferenceID Property

ReferenceID Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionType ► ReferenceID
Declaration Syntax
C# Visual Basic Visual C++
public TransactionReferenceType ReferenceID { get; set; }
Public Property ReferenceID As TransactionReferenceType
    Get
    Set
public:
property TransactionReferenceType^ ReferenceID {
    TransactionReferenceType^ get ();
    void set (TransactionReferenceType^ value);
}


PaymentTransactionTypeCollection Class

PaymentTransactionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PaymentTransactionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PaymentTransactionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PaymentTransactionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaymentTransactionTypeCollection()()()() |
 | PaymentTransactionTypeCollection(array<PaymentTransactionType>[]()[][]) |
 | PaymentTransactionTypeCollection(PaymentTransactionTypeCollection) |
 | Add(PaymentTransactionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PaymentTransactionType>[]()[][]) |
 | AddRange(PaymentTransactionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PaymentTransactionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PaymentTransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PaymentTransactionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PaymentTransactionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PaymentTransactionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PaymentTransactionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► Add(PaymentTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PaymentTransactionType item
)
Public Function Add ( _
    item As PaymentTransactionType _
) As Integer
public:
int Add(
    PaymentTransactionType^ item
)
Parameters
item (PaymentTransactionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PaymentTransactionType>[]()[][]) |
 | AddRange(PaymentTransactionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► AddRange(array<PaymentTransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PaymentTransactionType[] items
)
Public Sub AddRange ( _
    items As PaymentTransactionType() _
)
public:
void AddRange(
    array<PaymentTransactionType^>^ items
)
Parameters
items (array< PaymentTransactionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► AddRange(PaymentTransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PaymentTransactionTypeCollection items
)
Public Sub AddRange ( _
    items As PaymentTransactionTypeCollection _
)
public:
void AddRange(
    PaymentTransactionTypeCollection^ items
)
Parameters
items (PaymentTransactionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► Contains(PaymentTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PaymentTransactionType item
)
Public Function Contains ( _
    item As PaymentTransactionType _
) As Boolean
public:
bool Contains(
    PaymentTransactionType^ item
)
Parameters
item (PaymentTransactionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► CopyTo(array<PaymentTransactionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PaymentTransactionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PaymentTransactionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PaymentTransactionType^>^ items,
    int index
)
Parameters
items (array< PaymentTransactionType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► IndexOf(PaymentTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PaymentTransactionType item
)
Public Function IndexOf ( _
    item As PaymentTransactionType _
) As Integer
public:
int IndexOf(
    PaymentTransactionType^ item
)
Parameters
item (PaymentTransactionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► Insert(Int32, PaymentTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PaymentTransactionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PaymentTransactionType _
)
public:
void Insert(
    int index,
    PaymentTransactionType^ item
)
Parameters
index (Int32)
item (PaymentTransactionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTransactionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PaymentTransactionType
    Get
    Set
public:
property PaymentTransactionType^ default[int index] {
    PaymentTransactionType^ get (int index);
    void set (int index, PaymentTransactionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTransactionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PaymentTransactionType
public:
PaymentTransactionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PaymentTransactionTypeCollection Constructor

PaymentTransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► PaymentTransactionTypeCollection()()()()
Members
Icon | Member | Description
 | PaymentTransactionTypeCollection()()()() |
 | PaymentTransactionTypeCollection(array<PaymentTransactionType>[]()[][]) |
 | PaymentTransactionTypeCollection(PaymentTransactionTypeCollection) |


PaymentTransactionTypeCollection Constructor

PaymentTransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► PaymentTransactionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTransactionTypeCollection()
Public Sub New
public:
PaymentTransactionTypeCollection()


PaymentTransactionTypeCollection Constructor (items)

PaymentTransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► PaymentTransactionTypeCollection(array<PaymentTransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTransactionTypeCollection(
    PaymentTransactionType[] items
)
Public Sub New ( _
    items As PaymentTransactionType() _
)
public:
PaymentTransactionTypeCollection(
    array<PaymentTransactionType^>^ items
)
Parameters
items (array< PaymentTransactionType >[]()[][])


PaymentTransactionTypeCollection Constructor (items)

PaymentTransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► PaymentTransactionTypeCollection(PaymentTransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTransactionTypeCollection(
    PaymentTransactionTypeCollection items
)
Public Sub New ( _
    items As PaymentTransactionTypeCollection _
)
public:
PaymentTransactionTypeCollection(
    PaymentTransactionTypeCollection^ items
)
Parameters
items (PaymentTransactionTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► Remove(PaymentTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PaymentTransactionType item
)
Public Sub Remove ( _
    item As PaymentTransactionType _
)
public:
void Remove(
    PaymentTransactionType^ item
)
Parameters
item (PaymentTransactionType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTransactionType[] ToArray()
Public Function ToArray As PaymentTransactionType()
public:
array<PaymentTransactionType^>^ ToArray()
Return Value


PaymentTypeCodeType Enumeration

PaymentTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PaymentTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PaymentTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PaymentTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PaymentTypeCodeType
Members
Member | Description
Sale |
Refund |
SellerDeniedPayment |
AdminReversal |
AllOther |
RentalExtension |
RentalBuyout |
CustomCode |
Remarks


PayoutMethodType Enumeration

PayoutMethodType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PayoutMethodType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PayoutMethodType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PayoutMethodType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PayoutMethodType
Members
Member | Description
PAYPAL |
EFT |
MONEYBOOKERS |
Remarks


PayPalAccountLevelCodeType Enumeration

PayPalAccountLevelCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PayPalAccountLevelCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PayPalAccountLevelCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PayPalAccountLevelCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PayPalAccountLevelCodeType
Members
Member | Description
Unverified |
InternationalUnverified |
Verified |
InternationalVerified |
Trusted |
Unknown |
Invalid |
CustomCode |
Remarks


PayPalAccountStatusCodeType Enumeration

PayPalAccountStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PayPalAccountStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PayPalAccountStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PayPalAccountStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PayPalAccountStatusCodeType
Members
Member | Description
Active |
Closed |
HighRestricted |
LowRestricted |
Locked |
CustomCode |
WireOff |
Unknown |
Invalid |
Remarks


PayPalAccountTypeCodeType Enumeration

PayPalAccountTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PayPalAccountTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PayPalAccountTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PayPalAccountTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PayPalAccountTypeCodeType
Members
Member | Description
Personal |
Premier |
Business |
Unknown |
Invalid |
CustomCode |
Remarks


PayPalBuyerProtectionEnabledDefinitionType Class

PayPalBuyerProtectionEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► PayPalBuyerProtectionEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PayPalBuyerProtectionEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PayPalBuyerProtectionEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PayPalBuyerProtectionEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PayPalBuyerProtectionEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PayPalBuyerProtectionEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PayPalBuyerProtectionEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PayPalBuyerProtectionEnabledDefinitionType Constructor

PayPalBuyerProtectionEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► PayPalBuyerProtectionEnabledDefinitionType ► PayPalBuyerProtectionEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PayPalBuyerProtectionEnabledDefinitionType()
Public Sub New
public:
PayPalBuyerProtectionEnabledDefinitionType()


PayPalRequiredDefinitionType Class

PayPalRequiredDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► PayPalRequiredDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PayPalRequiredDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PayPalRequiredDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PayPalRequiredDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PayPalRequiredDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PayPalRequiredDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PayPalRequiredDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PayPalRequiredDefinitionType Constructor

PayPalRequiredDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► PayPalRequiredDefinitionType ► PayPalRequiredDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PayPalRequiredDefinitionType()
Public Sub New
public:
PayPalRequiredDefinitionType()


PayPalRequiredForStoreOwnerDefinitionType Class

PayPalRequiredForStoreOwnerDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► PayPalRequiredForStoreOwnerDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PayPalRequiredForStoreOwnerDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PayPalRequiredForStoreOwnerDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PayPalRequiredForStoreOwnerDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PayPalRequiredForStoreOwnerDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PayPalRequiredForStoreOwnerDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PayPalRequiredForStoreOwnerDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PayPalRequiredForStoreOwnerDefinitionType Constructor

PayPalRequiredForStoreOwnerDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► PayPalRequiredForStoreOwnerDefinitionType ► PayPalRequiredForStoreOwnerDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PayPalRequiredForStoreOwnerDefinitionType()
Public Sub New
public:
PayPalRequiredForStoreOwnerDefinitionType()


PerformanceDashboardType Class

PerformanceDashboardType Class
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PerformanceDashboardType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PerformanceDashboardType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PerformanceDashboardType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PerformanceDashboardType()()()() |
 | Alert |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Site |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PerformanceDashboardType


Alert Property

Alert Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardType ► Alert
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertType Alert { get; set; }
Public Property Alert As SellerDashboardAlertType
    Get
    Set
public:
property SellerDashboardAlertType^ Alert {
    SellerDashboardAlertType^ get ();
    void set (SellerDashboardAlertType^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PerformanceDashboardType Constructor

PerformanceDashboardType Constructor
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardType ► PerformanceDashboardType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceDashboardType()
Public Sub New
public:
PerformanceDashboardType()


Site Property

Site Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardType ► Site
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeTypeCollection Site { get; set; }
Public Property Site As SiteCodeTypeCollection
    Get
    Set
public:
property SiteCodeTypeCollection^ Site {
    SiteCodeTypeCollection^ get ();
    void set (SiteCodeTypeCollection^ value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceStatusCodeType Status { get; set; }
Public Property Status As PerformanceStatusCodeType
    Get
    Set
public:
property PerformanceStatusCodeType Status {
    PerformanceStatusCodeType get ();
    void set (PerformanceStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


PerformanceDashboardTypeCollection Class

PerformanceDashboardTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PerformanceDashboardTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PerformanceDashboardTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PerformanceDashboardTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PerformanceDashboardTypeCollection()()()() |
 | PerformanceDashboardTypeCollection(array<PerformanceDashboardType>[]()[][]) |
 | PerformanceDashboardTypeCollection(PerformanceDashboardTypeCollection) |
 | Add(PerformanceDashboardType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PerformanceDashboardType>[]()[][]) |
 | AddRange(PerformanceDashboardTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PerformanceDashboardType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PerformanceDashboardType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PerformanceDashboardType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PerformanceDashboardType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PerformanceDashboardType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PerformanceDashboardTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► Add(PerformanceDashboardType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PerformanceDashboardType item
)
Public Function Add ( _
    item As PerformanceDashboardType _
) As Integer
public:
int Add(
    PerformanceDashboardType^ item
)
Parameters
item (PerformanceDashboardType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PerformanceDashboardType>[]()[][]) |
 | AddRange(PerformanceDashboardTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► AddRange(array<PerformanceDashboardType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PerformanceDashboardType[] items
)
Public Sub AddRange ( _
    items As PerformanceDashboardType() _
)
public:
void AddRange(
    array<PerformanceDashboardType^>^ items
)
Parameters
items (array< PerformanceDashboardType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► AddRange(PerformanceDashboardTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PerformanceDashboardTypeCollection items
)
Public Sub AddRange ( _
    items As PerformanceDashboardTypeCollection _
)
public:
void AddRange(
    PerformanceDashboardTypeCollection^ items
)
Parameters
items (PerformanceDashboardTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► Contains(PerformanceDashboardType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PerformanceDashboardType item
)
Public Function Contains ( _
    item As PerformanceDashboardType _
) As Boolean
public:
bool Contains(
    PerformanceDashboardType^ item
)
Parameters
item (PerformanceDashboardType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► CopyTo(array<PerformanceDashboardType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PerformanceDashboardType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PerformanceDashboardType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PerformanceDashboardType^>^ items,
    int index
)
Parameters
items (array< PerformanceDashboardType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► IndexOf(PerformanceDashboardType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PerformanceDashboardType item
)
Public Function IndexOf ( _
    item As PerformanceDashboardType _
) As Integer
public:
int IndexOf(
    PerformanceDashboardType^ item
)
Parameters
item (PerformanceDashboardType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► Insert(Int32, PerformanceDashboardType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PerformanceDashboardType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PerformanceDashboardType _
)
public:
void Insert(
    int index,
    PerformanceDashboardType^ item
)
Parameters
index (Int32)
item (PerformanceDashboardType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceDashboardType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PerformanceDashboardType
    Get
    Set
public:
property PerformanceDashboardType^ default[int index] {
    PerformanceDashboardType^ get (int index);
    void set (int index, PerformanceDashboardType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceDashboardType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PerformanceDashboardType
public:
PerformanceDashboardType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PerformanceDashboardTypeCollection Constructor

PerformanceDashboardTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► PerformanceDashboardTypeCollection()()()()
Members
Icon | Member | Description
 | PerformanceDashboardTypeCollection()()()() |
 | PerformanceDashboardTypeCollection(array<PerformanceDashboardType>[]()[][]) |
 | PerformanceDashboardTypeCollection(PerformanceDashboardTypeCollection) |


PerformanceDashboardTypeCollection Constructor

PerformanceDashboardTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► PerformanceDashboardTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceDashboardTypeCollection()
Public Sub New
public:
PerformanceDashboardTypeCollection()


PerformanceDashboardTypeCollection Constructor (items)

PerformanceDashboardTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► PerformanceDashboardTypeCollection(array<PerformanceDashboardType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceDashboardTypeCollection(
    PerformanceDashboardType[] items
)
Public Sub New ( _
    items As PerformanceDashboardType() _
)
public:
PerformanceDashboardTypeCollection(
    array<PerformanceDashboardType^>^ items
)
Parameters
items (array< PerformanceDashboardType >[]()[][])


PerformanceDashboardTypeCollection Constructor (items)

PerformanceDashboardTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► PerformanceDashboardTypeCollection(PerformanceDashboardTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceDashboardTypeCollection(
    PerformanceDashboardTypeCollection items
)
Public Sub New ( _
    items As PerformanceDashboardTypeCollection _
)
public:
PerformanceDashboardTypeCollection(
    PerformanceDashboardTypeCollection^ items
)
Parameters
items (PerformanceDashboardTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► Remove(PerformanceDashboardType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PerformanceDashboardType item
)
Public Sub Remove ( _
    item As PerformanceDashboardType _
)
public:
void Remove(
    PerformanceDashboardType^ item
)
Parameters
item (PerformanceDashboardType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceDashboardType[] ToArray()
Public Function ToArray As PerformanceDashboardType()
public:
array<PerformanceDashboardType^>^ ToArray()
Return Value


PerformanceStatusCodeType Enumeration

PerformanceStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PerformanceStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PerformanceStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PerformanceStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PerformanceStatusCodeType
Members
Member | Description
TopRated |
AboveStandard |
Standard |
BelowStandard |
CustomCode |
Remarks


PeriodCodeType Enumeration

PeriodCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PeriodCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PeriodCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PeriodCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PeriodCodeType
Members
Member | Description
Days_1 |
Days_30 |
Days_180 |
Days_360 |
Days_540 |
CustomCode |
Remarks


PhotoDisplayCodeType Enumeration

PhotoDisplayCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PhotoDisplayCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PhotoDisplayCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PhotoDisplayCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PhotoDisplayCodeType
Members
Member | Description
None |
SlideShow |
SuperSize |
PicturePack |
SiteHostedPictureShow |
VendorHostedPictureShow |
SuperSizePictureShow |
CustomCode |
Remarks


PickupDetailsType Class

PickupDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► PickupDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PickupDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PickupDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PickupDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PickupDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PickupOptions |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PickupDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PickupDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PickupDetailsType Constructor

PickupDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► PickupDetailsType ► PickupDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PickupDetailsType()
Public Sub New
public:
PickupDetailsType()


PickupOptions Property

PickupOptions Property
Namespaces ► eBay.Service.Core.Soap ► PickupDetailsType ► PickupOptions
Declaration Syntax
C# Visual Basic Visual C++
public PickupOptionsTypeCollection PickupOptions { get; set; }
Public Property PickupOptions As PickupOptionsTypeCollection
    Get
    Set
public:
property PickupOptionsTypeCollection^ PickupOptions {
    PickupOptionsTypeCollection^ get ();
    void set (PickupOptionsTypeCollection^ value);
}


PickupDropOffEnabledDefinitionType Class

PickupDropOffEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► PickupDropOffEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PickupDropOffEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PickupDropOffEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PickupDropOffEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PickupDropOffEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PickupDropOffEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PickupDropOffEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PickupDropOffEnabledDefinitionType Constructor

PickupDropOffEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► PickupDropOffEnabledDefinitionType ► PickupDropOffEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PickupDropOffEnabledDefinitionType()
Public Sub New
public:
PickupDropOffEnabledDefinitionType()


PickupInStoreDetailsType Class

PickupInStoreDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► PickupInStoreDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PickupInStoreDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PickupInStoreDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PickupInStoreDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PickupInStoreDetailsType()()()() |
 | Any |
 | EligibleForPickupDropOff |
 | EligibleForPickupDropOffSpecified |
 | EligibleForPickupInStore |
 | EligibleForPickupInStoreSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PickupInStoreDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PickupInStoreDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EligibleForPickupDropOff Property

EligibleForPickupDropOff Property
Namespaces ► eBay.Service.Core.Soap ► PickupInStoreDetailsType ► EligibleForPickupDropOff
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleForPickupDropOff { get; set; }
Public Property EligibleForPickupDropOff As Boolean
    Get
    Set
public:
property bool EligibleForPickupDropOff {
    bool get ();
    void set (bool value);
}


EligibleForPickupDropOffSpecified Property

EligibleForPickupDropOffSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PickupInStoreDetailsType ► EligibleForPickupDropOffSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleForPickupDropOffSpecified { get; set; }
Public Property EligibleForPickupDropOffSpecified As Boolean
    Get
    Set
public:
property bool EligibleForPickupDropOffSpecified {
    bool get ();
    void set (bool value);
}


EligibleForPickupInStore Property

EligibleForPickupInStore Property
Namespaces ► eBay.Service.Core.Soap ► PickupInStoreDetailsType ► EligibleForPickupInStore
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleForPickupInStore { get; set; }
Public Property EligibleForPickupInStore As Boolean
    Get
    Set
public:
property bool EligibleForPickupInStore {
    bool get ();
    void set (bool value);
}


EligibleForPickupInStoreSpecified Property

EligibleForPickupInStoreSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PickupInStoreDetailsType ► EligibleForPickupInStoreSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EligibleForPickupInStoreSpecified { get; set; }
Public Property EligibleForPickupInStoreSpecified As Boolean
    Get
    Set
public:
property bool EligibleForPickupInStoreSpecified {
    bool get ();
    void set (bool value);
}


PickupInStoreDetailsType Constructor

PickupInStoreDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► PickupInStoreDetailsType ► PickupInStoreDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PickupInStoreDetailsType()
Public Sub New
public:
PickupInStoreDetailsType()


PickupMethodSelectedType Class

PickupMethodSelectedType Class
Namespaces ► eBay.Service.Core.Soap ► PickupMethodSelectedType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PickupMethodSelectedType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PickupMethodSelectedType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PickupMethodSelectedType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PickupMethodSelectedType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MerchantPickupCode |
 | PickupFulfillmentTime |
 | PickupFulfillmentTimeSpecified |
 | PickupLocationUUID |
 | PickupMethod |
 | PickupStatus |
 | PickupStatusSpecified |
 | PickupStoreID |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PickupMethodSelectedType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PickupMethodSelectedType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MerchantPickupCode Property

MerchantPickupCode Property
Namespaces ► eBay.Service.Core.Soap ► PickupMethodSelectedType ► MerchantPickupCode
Declaration Syntax
C# Visual Basic Visual C++
public string MerchantPickupCode { get; set; }
Public Property MerchantPickupCode As String
    Get
    Set
public:
property String^ MerchantPickupCode {
    String^ get ();
    void set (String^ value);
}


PickupFulfillmentTime Property

PickupFulfillmentTime Property
Namespaces ► eBay.Service.Core.Soap ► PickupMethodSelectedType ► PickupFulfillmentTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PickupFulfillmentTime { get; set; }
Public Property PickupFulfillmentTime As DateTime
    Get
    Set
public:
property DateTime PickupFulfillmentTime {
    DateTime get ();
    void set (DateTime value);
}


PickupFulfillmentTimeSpecified Property

PickupFulfillmentTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PickupMethodSelectedType ► PickupFulfillmentTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PickupFulfillmentTimeSpecified { get; set; }
Public Property PickupFulfillmentTimeSpecified As Boolean
    Get
    Set
public:
property bool PickupFulfillmentTimeSpecified {
    bool get ();
    void set (bool value);
}


PickupLocationUUID Property

PickupLocationUUID Property
Namespaces ► eBay.Service.Core.Soap ► PickupMethodSelectedType ► PickupLocationUUID
Declaration Syntax
C# Visual Basic Visual C++
public string PickupLocationUUID { get; set; }
Public Property PickupLocationUUID As String
    Get
    Set
public:
property String^ PickupLocationUUID {
    String^ get ();
    void set (String^ value);
}


PickupMethod Property

PickupMethod Property
Namespaces ► eBay.Service.Core.Soap ► PickupMethodSelectedType ► PickupMethod
Declaration Syntax
C# Visual Basic Visual C++
public string PickupMethod { get; set; }
Public Property PickupMethod As String
    Get
    Set
public:
property String^ PickupMethod {
    String^ get ();
    void set (String^ value);
}


PickupMethodSelectedType Constructor

PickupMethodSelectedType Constructor
Namespaces ► eBay.Service.Core.Soap ► PickupMethodSelectedType ► PickupMethodSelectedType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PickupMethodSelectedType()
Public Sub New
public:
PickupMethodSelectedType()


PickupStatus Property

PickupStatus Property
Namespaces ► eBay.Service.Core.Soap ► PickupMethodSelectedType ► PickupStatus
Declaration Syntax
C# Visual Basic Visual C++
public PickupStatusCodeType PickupStatus { get; set; }
Public Property PickupStatus As PickupStatusCodeType
    Get
    Set
public:
property PickupStatusCodeType PickupStatus {
    PickupStatusCodeType get ();
    void set (PickupStatusCodeType value);
}


PickupStatusSpecified Property

PickupStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PickupMethodSelectedType ► PickupStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PickupStatusSpecified { get; set; }
Public Property PickupStatusSpecified As Boolean
    Get
    Set
public:
property bool PickupStatusSpecified {
    bool get ();
    void set (bool value);
}


PickupStoreID Property

PickupStoreID Property
Namespaces ► eBay.Service.Core.Soap ► PickupMethodSelectedType ► PickupStoreID
Declaration Syntax
C# Visual Basic Visual C++
public string PickupStoreID { get; set; }
Public Property PickupStoreID As String
    Get
    Set
public:
property String^ PickupStoreID {
    String^ get ();
    void set (String^ value);
}


PickupOptionsType Class

PickupOptionsType Class
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PickupOptionsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PickupOptionsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PickupOptionsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PickupOptionsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PickupMethod |
 | PickupPriority |
 | PickupPrioritySpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PickupOptionsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PickupMethod Property

PickupMethod Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsType ► PickupMethod
Declaration Syntax
C# Visual Basic Visual C++
public string PickupMethod { get; set; }
Public Property PickupMethod As String
    Get
    Set
public:
property String^ PickupMethod {
    String^ get ();
    void set (String^ value);
}


PickupOptionsType Constructor

PickupOptionsType Constructor
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsType ► PickupOptionsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PickupOptionsType()
Public Sub New
public:
PickupOptionsType()


PickupPriority Property

PickupPriority Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsType ► PickupPriority
Declaration Syntax
C# Visual Basic Visual C++
public int PickupPriority { get; set; }
Public Property PickupPriority As Integer
    Get
    Set
public:
property int PickupPriority {
    int get ();
    void set (int value);
}


PickupPrioritySpecified Property

PickupPrioritySpecified Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsType ► PickupPrioritySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PickupPrioritySpecified { get; set; }
Public Property PickupPrioritySpecified As Boolean
    Get
    Set
public:
property bool PickupPrioritySpecified {
    bool get ();
    void set (bool value);
}


PickupOptionsTypeCollection Class

PickupOptionsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PickupOptionsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PickupOptionsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PickupOptionsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PickupOptionsTypeCollection()()()() |
 | PickupOptionsTypeCollection(array<PickupOptionsType>[]()[][]) |
 | PickupOptionsTypeCollection(PickupOptionsTypeCollection) |
 | Add(PickupOptionsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PickupOptionsType>[]()[][]) |
 | AddRange(PickupOptionsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PickupOptionsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PickupOptionsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PickupOptionsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PickupOptionsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PickupOptionsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PickupOptionsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► Add(PickupOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PickupOptionsType item
)
Public Function Add ( _
    item As PickupOptionsType _
) As Integer
public:
int Add(
    PickupOptionsType^ item
)
Parameters
item (PickupOptionsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PickupOptionsType>[]()[][]) |
 | AddRange(PickupOptionsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► AddRange(array<PickupOptionsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PickupOptionsType[] items
)
Public Sub AddRange ( _
    items As PickupOptionsType() _
)
public:
void AddRange(
    array<PickupOptionsType^>^ items
)
Parameters
items (array< PickupOptionsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► AddRange(PickupOptionsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PickupOptionsTypeCollection items
)
Public Sub AddRange ( _
    items As PickupOptionsTypeCollection _
)
public:
void AddRange(
    PickupOptionsTypeCollection^ items
)
Parameters
items (PickupOptionsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► Contains(PickupOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PickupOptionsType item
)
Public Function Contains ( _
    item As PickupOptionsType _
) As Boolean
public:
bool Contains(
    PickupOptionsType^ item
)
Parameters
item (PickupOptionsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► CopyTo(array<PickupOptionsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PickupOptionsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PickupOptionsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PickupOptionsType^>^ items,
    int index
)
Parameters
items (array< PickupOptionsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► IndexOf(PickupOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PickupOptionsType item
)
Public Function IndexOf ( _
    item As PickupOptionsType _
) As Integer
public:
int IndexOf(
    PickupOptionsType^ item
)
Parameters
item (PickupOptionsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► Insert(Int32, PickupOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PickupOptionsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PickupOptionsType _
)
public:
void Insert(
    int index,
    PickupOptionsType^ item
)
Parameters
index (Int32)
item (PickupOptionsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PickupOptionsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PickupOptionsType
    Get
    Set
public:
property PickupOptionsType^ default[int index] {
    PickupOptionsType^ get (int index);
    void set (int index, PickupOptionsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PickupOptionsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PickupOptionsType
public:
PickupOptionsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PickupOptionsTypeCollection Constructor

PickupOptionsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► PickupOptionsTypeCollection()()()()
Members
Icon | Member | Description
 | PickupOptionsTypeCollection()()()() |
 | PickupOptionsTypeCollection(array<PickupOptionsType>[]()[][]) |
 | PickupOptionsTypeCollection(PickupOptionsTypeCollection) |


PickupOptionsTypeCollection Constructor

PickupOptionsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► PickupOptionsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PickupOptionsTypeCollection()
Public Sub New
public:
PickupOptionsTypeCollection()


PickupOptionsTypeCollection Constructor (items)

PickupOptionsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► PickupOptionsTypeCollection(array<PickupOptionsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PickupOptionsTypeCollection(
    PickupOptionsType[] items
)
Public Sub New ( _
    items As PickupOptionsType() _
)
public:
PickupOptionsTypeCollection(
    array<PickupOptionsType^>^ items
)
Parameters
items (array< PickupOptionsType >[]()[][])


PickupOptionsTypeCollection Constructor (items)

PickupOptionsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► PickupOptionsTypeCollection(PickupOptionsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PickupOptionsTypeCollection(
    PickupOptionsTypeCollection items
)
Public Sub New ( _
    items As PickupOptionsTypeCollection _
)
public:
PickupOptionsTypeCollection(
    PickupOptionsTypeCollection^ items
)
Parameters
items (PickupOptionsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► Remove(PickupOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PickupOptionsType item
)
Public Sub Remove ( _
    item As PickupOptionsType _
)
public:
void Remove(
    PickupOptionsType^ item
)
Parameters
item (PickupOptionsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PickupOptionsType[] ToArray()
Public Function ToArray As PickupOptionsType()
public:
array<PickupOptionsType^>^ ToArray()
Return Value


PickupStatusCodeType Enumeration

PickupStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PickupStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PickupStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PickupStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PickupStatusCodeType
Members
Member | Description
Invalid |
NotApplicable |
PendingMerchantConfirmation |
ReadyToPickup |
Pickedup |
PickupCancelledOutOfStock |
PickupCancelledBuyerRejected |
PickupCancelledBuyerNoShow |
PickupCancelled |
CustomCode |
Remarks


PictureDetailsType Class

PictureDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PictureDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PictureDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PictureDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PictureDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | ExtendedPictureDetails |
 | ExternalPictureURL |
 | Finalize()()()() | (Inherited from Object.)
 | GalleryDuration |
 | GalleryErrorInfo |
 | GalleryStatus |
 | GalleryStatusSpecified |
 | GalleryType |
 | GalleryTypeSpecified |
 | GalleryURL |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PhotoDisplay |
 | PhotoDisplaySpecified |
 | PictureSource |
 | PictureSourceSpecified |
 | PictureURL |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PictureDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExtendedPictureDetails Property

ExtendedPictureDetails Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► ExtendedPictureDetails
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedPictureDetailsType ExtendedPictureDetails { get; set; }
Public Property ExtendedPictureDetails As ExtendedPictureDetailsType
    Get
    Set
public:
property ExtendedPictureDetailsType^ ExtendedPictureDetails {
    ExtendedPictureDetailsType^ get ();
    void set (ExtendedPictureDetailsType^ value);
}


ExternalPictureURL Property

ExternalPictureURL Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► ExternalPictureURL
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ExternalPictureURL { get; set; }
Public Property ExternalPictureURL As StringCollection
    Get
    Set
public:
property StringCollection^ ExternalPictureURL {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


GalleryDuration Property

GalleryDuration Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► GalleryDuration
Declaration Syntax
C# Visual Basic Visual C++
public string GalleryDuration { get; set; }
Public Property GalleryDuration As String
    Get
    Set
public:
property String^ GalleryDuration {
    String^ get ();
    void set (String^ value);
}


GalleryErrorInfo Property

GalleryErrorInfo Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► GalleryErrorInfo
Declaration Syntax
C# Visual Basic Visual C++
public string GalleryErrorInfo { get; set; }
Public Property GalleryErrorInfo As String
    Get
    Set
public:
property String^ GalleryErrorInfo {
    String^ get ();
    void set (String^ value);
}


GalleryStatus Property

GalleryStatus Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► GalleryStatus
Declaration Syntax
C# Visual Basic Visual C++
public GalleryStatusCodeType GalleryStatus { get; set; }
Public Property GalleryStatus As GalleryStatusCodeType
    Get
    Set
public:
property GalleryStatusCodeType GalleryStatus {
    GalleryStatusCodeType get ();
    void set (GalleryStatusCodeType value);
}


GalleryStatusSpecified Property

GalleryStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► GalleryStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GalleryStatusSpecified { get; set; }
Public Property GalleryStatusSpecified As Boolean
    Get
    Set
public:
property bool GalleryStatusSpecified {
    bool get ();
    void set (bool value);
}


GalleryType Property

GalleryType Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► GalleryType
Declaration Syntax
C# Visual Basic Visual C++
public GalleryTypeCodeType GalleryType { get; set; }
Public Property GalleryType As GalleryTypeCodeType
    Get
    Set
public:
property GalleryTypeCodeType GalleryType {
    GalleryTypeCodeType get ();
    void set (GalleryTypeCodeType value);
}


GalleryTypeSpecified Property

GalleryTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► GalleryTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GalleryTypeSpecified { get; set; }
Public Property GalleryTypeSpecified As Boolean
    Get
    Set
public:
property bool GalleryTypeSpecified {
    bool get ();
    void set (bool value);
}


GalleryURL Property

GalleryURL Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► GalleryURL
Declaration Syntax
C# Visual Basic Visual C++
public string GalleryURL { get; set; }
Public Property GalleryURL As String
    Get
    Set
public:
property String^ GalleryURL {
    String^ get ();
    void set (String^ value);
}


PhotoDisplay Property

PhotoDisplay Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► PhotoDisplay
Declaration Syntax
C# Visual Basic Visual C++
public PhotoDisplayCodeType PhotoDisplay { get; set; }
Public Property PhotoDisplay As PhotoDisplayCodeType
    Get
    Set
public:
property PhotoDisplayCodeType PhotoDisplay {
    PhotoDisplayCodeType get ();
    void set (PhotoDisplayCodeType value);
}


PhotoDisplaySpecified Property

PhotoDisplaySpecified Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► PhotoDisplaySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PhotoDisplaySpecified { get; set; }
Public Property PhotoDisplaySpecified As Boolean
    Get
    Set
public:
property bool PhotoDisplaySpecified {
    bool get ();
    void set (bool value);
}


PictureDetailsType Constructor

PictureDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► PictureDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PictureDetailsType()
Public Sub New
public:
PictureDetailsType()


PictureSource Property

PictureSource Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► PictureSource
Declaration Syntax
C# Visual Basic Visual C++
public PictureSourceCodeType PictureSource { get; set; }
Public Property PictureSource As PictureSourceCodeType
    Get
    Set
public:
property PictureSourceCodeType PictureSource {
    PictureSourceCodeType get ();
    void set (PictureSourceCodeType value);
}


PictureSourceSpecified Property

PictureSourceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► PictureSourceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PictureSourceSpecified { get; set; }
Public Property PictureSourceSpecified As Boolean
    Get
    Set
public:
property bool PictureSourceSpecified {
    bool get ();
    void set (bool value);
}


PictureURL Property

PictureURL Property
Namespaces ► eBay.Service.Core.Soap ► PictureDetailsType ► PictureURL
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureURL { get; set; }
Public Property PictureURL As StringCollection
    Get
    Set
public:
property StringCollection^ PictureURL {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


PictureFormatCodeType Enumeration

PictureFormatCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PictureFormatCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PictureFormatCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PictureFormatCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PictureFormatCodeType
Members
Member | Description
JPG |
GIF |
CustomCode |
Remarks


PictureSetCodeType Enumeration

PictureSetCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PictureSetCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PictureSetCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PictureSetCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PictureSetCodeType
Members
Member | Description
Standard |
Supersize |
Large |
CustomCode |
Remarks


PictureSetMemberType Class

PictureSetMemberType Class
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PictureSetMemberType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PictureSetMemberType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PictureSetMemberType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PictureSetMemberType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberURL |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PictureHeight |
 | PictureHeightSpecified |
 | PictureWidth |
 | PictureWidthSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PictureSetMemberType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MemberURL Property

MemberURL Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberType ► MemberURL
Declaration Syntax
C# Visual Basic Visual C++
public string MemberURL { get; set; }
Public Property MemberURL As String
    Get
    Set
public:
property String^ MemberURL {
    String^ get ();
    void set (String^ value);
}


PictureHeight Property

PictureHeight Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberType ► PictureHeight
Declaration Syntax
C# Visual Basic Visual C++
public int PictureHeight { get; set; }
Public Property PictureHeight As Integer
    Get
    Set
public:
property int PictureHeight {
    int get ();
    void set (int value);
}


PictureHeightSpecified Property

PictureHeightSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberType ► PictureHeightSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PictureHeightSpecified { get; set; }
Public Property PictureHeightSpecified As Boolean
    Get
    Set
public:
property bool PictureHeightSpecified {
    bool get ();
    void set (bool value);
}


PictureSetMemberType Constructor

PictureSetMemberType Constructor
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberType ► PictureSetMemberType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PictureSetMemberType()
Public Sub New
public:
PictureSetMemberType()


PictureWidth Property

PictureWidth Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberType ► PictureWidth
Declaration Syntax
C# Visual Basic Visual C++
public int PictureWidth { get; set; }
Public Property PictureWidth As Integer
    Get
    Set
public:
property int PictureWidth {
    int get ();
    void set (int value);
}


PictureWidthSpecified Property

PictureWidthSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberType ► PictureWidthSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PictureWidthSpecified { get; set; }
Public Property PictureWidthSpecified As Boolean
    Get
    Set
public:
property bool PictureWidthSpecified {
    bool get ();
    void set (bool value);
}


PictureSetMemberTypeCollection Class

PictureSetMemberTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PictureSetMemberTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PictureSetMemberTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PictureSetMemberTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PictureSetMemberTypeCollection()()()() |
 | PictureSetMemberTypeCollection(array<PictureSetMemberType>[]()[][]) |
 | PictureSetMemberTypeCollection(PictureSetMemberTypeCollection) |
 | Add(PictureSetMemberType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PictureSetMemberType>[]()[][]) |
 | AddRange(PictureSetMemberTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PictureSetMemberType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PictureSetMemberType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PictureSetMemberType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PictureSetMemberType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PictureSetMemberType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PictureSetMemberTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► Add(PictureSetMemberType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PictureSetMemberType item
)
Public Function Add ( _
    item As PictureSetMemberType _
) As Integer
public:
int Add(
    PictureSetMemberType^ item
)
Parameters
item (PictureSetMemberType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PictureSetMemberType>[]()[][]) |
 | AddRange(PictureSetMemberTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► AddRange(array<PictureSetMemberType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PictureSetMemberType[] items
)
Public Sub AddRange ( _
    items As PictureSetMemberType() _
)
public:
void AddRange(
    array<PictureSetMemberType^>^ items
)
Parameters
items (array< PictureSetMemberType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► AddRange(PictureSetMemberTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PictureSetMemberTypeCollection items
)
Public Sub AddRange ( _
    items As PictureSetMemberTypeCollection _
)
public:
void AddRange(
    PictureSetMemberTypeCollection^ items
)
Parameters
items (PictureSetMemberTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► Contains(PictureSetMemberType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PictureSetMemberType item
)
Public Function Contains ( _
    item As PictureSetMemberType _
) As Boolean
public:
bool Contains(
    PictureSetMemberType^ item
)
Parameters
item (PictureSetMemberType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► CopyTo(array<PictureSetMemberType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PictureSetMemberType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PictureSetMemberType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PictureSetMemberType^>^ items,
    int index
)
Parameters
items (array< PictureSetMemberType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► IndexOf(PictureSetMemberType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PictureSetMemberType item
)
Public Function IndexOf ( _
    item As PictureSetMemberType _
) As Integer
public:
int IndexOf(
    PictureSetMemberType^ item
)
Parameters
item (PictureSetMemberType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► Insert(Int32, PictureSetMemberType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PictureSetMemberType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PictureSetMemberType _
)
public:
void Insert(
    int index,
    PictureSetMemberType^ item
)
Parameters
index (Int32)
item (PictureSetMemberType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PictureSetMemberType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PictureSetMemberType
    Get
    Set
public:
property PictureSetMemberType^ default[int index] {
    PictureSetMemberType^ get (int index);
    void set (int index, PictureSetMemberType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PictureSetMemberType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PictureSetMemberType
public:
PictureSetMemberType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PictureSetMemberTypeCollection Constructor

PictureSetMemberTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► PictureSetMemberTypeCollection()()()()
Members
Icon | Member | Description
 | PictureSetMemberTypeCollection()()()() |
 | PictureSetMemberTypeCollection(array<PictureSetMemberType>[]()[][]) |
 | PictureSetMemberTypeCollection(PictureSetMemberTypeCollection) |


PictureSetMemberTypeCollection Constructor

PictureSetMemberTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► PictureSetMemberTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PictureSetMemberTypeCollection()
Public Sub New
public:
PictureSetMemberTypeCollection()


PictureSetMemberTypeCollection Constructor (items)

PictureSetMemberTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► PictureSetMemberTypeCollection(array<PictureSetMemberType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PictureSetMemberTypeCollection(
    PictureSetMemberType[] items
)
Public Sub New ( _
    items As PictureSetMemberType() _
)
public:
PictureSetMemberTypeCollection(
    array<PictureSetMemberType^>^ items
)
Parameters
items (array< PictureSetMemberType >[]()[][])


PictureSetMemberTypeCollection Constructor (items)

PictureSetMemberTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► PictureSetMemberTypeCollection(PictureSetMemberTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PictureSetMemberTypeCollection(
    PictureSetMemberTypeCollection items
)
Public Sub New ( _
    items As PictureSetMemberTypeCollection _
)
public:
PictureSetMemberTypeCollection(
    PictureSetMemberTypeCollection^ items
)
Parameters
items (PictureSetMemberTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► Remove(PictureSetMemberType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PictureSetMemberType item
)
Public Sub Remove ( _
    item As PictureSetMemberType _
)
public:
void Remove(
    PictureSetMemberType^ item
)
Parameters
item (PictureSetMemberType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PictureSetMemberType[] ToArray()
Public Function ToArray As PictureSetMemberType()
public:
array<PictureSetMemberType^>^ ToArray()
Return Value


PictureSourceCodeType Enumeration

PictureSourceCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PictureSourceCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PictureSourceCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PictureSourceCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PictureSourceCodeType
Members
Member | Description
EPS |
PictureManager |
Vendor |
CustomCode |
Remarks


PicturesType Class

PicturesType Class
Namespaces ► eBay.Service.Core.Soap ► PicturesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PicturesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PicturesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PicturesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PicturesType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | VariationSpecificName |
 | VariationSpecificPictureSet |
Remarks
Inheritance Hierarchy
Object
PicturesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PicturesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PicturesType Constructor

PicturesType Constructor
Namespaces ► eBay.Service.Core.Soap ► PicturesType ► PicturesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PicturesType()
Public Sub New
public:
PicturesType()


VariationSpecificName Property

VariationSpecificName Property
Namespaces ► eBay.Service.Core.Soap ► PicturesType ► VariationSpecificName
Declaration Syntax
C# Visual Basic Visual C++
public string VariationSpecificName { get; set; }
Public Property VariationSpecificName As String
    Get
    Set
public:
property String^ VariationSpecificName {
    String^ get ();
    void set (String^ value);
}


VariationSpecificPictureSet Property

VariationSpecificPictureSet Property
Namespaces ► eBay.Service.Core.Soap ► PicturesType ► VariationSpecificPictureSet
Declaration Syntax
C# Visual Basic Visual C++
public VariationSpecificPictureSetTypeCollection VariationSpecificPictureSet { get; set; }
Public Property VariationSpecificPictureSet As VariationSpecificPictureSetTypeCollection
    Get
    Set
public:
property VariationSpecificPictureSetTypeCollection^ VariationSpecificPictureSet {
    VariationSpecificPictureSetTypeCollection^ get ();
    void set (VariationSpecificPictureSetTypeCollection^ value);
}


PicturesTypeCollection Class

PicturesTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PicturesTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PicturesTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PicturesTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PicturesTypeCollection()()()() |
 | PicturesTypeCollection(array<PicturesType>[]()[][]) |
 | PicturesTypeCollection(PicturesTypeCollection) |
 | Add(PicturesType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PicturesType>[]()[][]) |
 | AddRange(PicturesTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PicturesType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PicturesType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PicturesType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PicturesType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PicturesType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PicturesTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► Add(PicturesType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PicturesType item
)
Public Function Add ( _
    item As PicturesType _
) As Integer
public:
int Add(
    PicturesType^ item
)
Parameters
item (PicturesType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PicturesType>[]()[][]) |
 | AddRange(PicturesTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► AddRange(array<PicturesType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PicturesType[] items
)
Public Sub AddRange ( _
    items As PicturesType() _
)
public:
void AddRange(
    array<PicturesType^>^ items
)
Parameters
items (array< PicturesType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► AddRange(PicturesTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PicturesTypeCollection items
)
Public Sub AddRange ( _
    items As PicturesTypeCollection _
)
public:
void AddRange(
    PicturesTypeCollection^ items
)
Parameters
items (PicturesTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► Contains(PicturesType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PicturesType item
)
Public Function Contains ( _
    item As PicturesType _
) As Boolean
public:
bool Contains(
    PicturesType^ item
)
Parameters
item (PicturesType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► CopyTo(array<PicturesType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PicturesType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PicturesType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PicturesType^>^ items,
    int index
)
Parameters
items (array< PicturesType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► IndexOf(PicturesType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PicturesType item
)
Public Function IndexOf ( _
    item As PicturesType _
) As Integer
public:
int IndexOf(
    PicturesType^ item
)
Parameters
item (PicturesType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► Insert(Int32, PicturesType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PicturesType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PicturesType _
)
public:
void Insert(
    int index,
    PicturesType^ item
)
Parameters
index (Int32)
item (PicturesType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PicturesType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PicturesType
    Get
    Set
public:
property PicturesType^ default[int index] {
    PicturesType^ get (int index);
    void set (int index, PicturesType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PicturesType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PicturesType
public:
PicturesType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PicturesTypeCollection Constructor

PicturesTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► PicturesTypeCollection()()()()
Members
Icon | Member | Description
 | PicturesTypeCollection()()()() |
 | PicturesTypeCollection(array<PicturesType>[]()[][]) |
 | PicturesTypeCollection(PicturesTypeCollection) |


PicturesTypeCollection Constructor

PicturesTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► PicturesTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PicturesTypeCollection()
Public Sub New
public:
PicturesTypeCollection()


PicturesTypeCollection Constructor (items)

PicturesTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► PicturesTypeCollection(array<PicturesType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PicturesTypeCollection(
    PicturesType[] items
)
Public Sub New ( _
    items As PicturesType() _
)
public:
PicturesTypeCollection(
    array<PicturesType^>^ items
)
Parameters
items (array< PicturesType >[]()[][])


PicturesTypeCollection Constructor (items)

PicturesTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► PicturesTypeCollection(PicturesTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PicturesTypeCollection(
    PicturesTypeCollection items
)
Public Sub New ( _
    items As PicturesTypeCollection _
)
public:
PicturesTypeCollection(
    PicturesTypeCollection^ items
)
Parameters
items (PicturesTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► Remove(PicturesType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PicturesType item
)
Public Sub Remove ( _
    item As PicturesType _
)
public:
void Remove(
    PicturesType^ item
)
Parameters
item (PicturesType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PicturesType[] ToArray()
Public Function ToArray As PicturesType()
public:
array<PicturesType^>^ ToArray()
Return Value


PictureUploadPolicyCodeType Enumeration

PictureUploadPolicyCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PictureUploadPolicyCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PictureUploadPolicyCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PictureUploadPolicyCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PictureUploadPolicyCodeType
Members
Member | Description
Add |
ClearAndAdd |
CustomCode |
Remarks


PictureURLsType Class

PictureURLsType Class
Namespaces ► eBay.Service.Core.Soap ► PictureURLsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PictureURLsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PictureURLsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PictureURLsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PictureURLsType()()()() |
 | Any |
 | eBayPictureURL |
 | Equals(Object) | (Inherited from Object.)
 | ExternalPictureURL |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PictureURLsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


eBayPictureURL Property

eBayPictureURL Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsType ► eBayPictureURL
Declaration Syntax
C# Visual Basic Visual C++
public string eBayPictureURL { get; set; }
Public Property eBayPictureURL As String
    Get
    Set
public:
property String^ eBayPictureURL {
    String^ get ();
    void set (String^ value);
}


ExternalPictureURL Property

ExternalPictureURL Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsType ► ExternalPictureURL
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalPictureURL { get; set; }
Public Property ExternalPictureURL As String
    Get
    Set
public:
property String^ ExternalPictureURL {
    String^ get ();
    void set (String^ value);
}


PictureURLsType Constructor

PictureURLsType Constructor
Namespaces ► eBay.Service.Core.Soap ► PictureURLsType ► PictureURLsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PictureURLsType()
Public Sub New
public:
PictureURLsType()


PictureURLsTypeCollection Class

PictureURLsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PictureURLsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PictureURLsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PictureURLsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PictureURLsTypeCollection()()()() |
 | PictureURLsTypeCollection(array<PictureURLsType>[]()[][]) |
 | PictureURLsTypeCollection(PictureURLsTypeCollection) |
 | Add(PictureURLsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PictureURLsType>[]()[][]) |
 | AddRange(PictureURLsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PictureURLsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PictureURLsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PictureURLsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PictureURLsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PictureURLsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PictureURLsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► Add(PictureURLsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PictureURLsType item
)
Public Function Add ( _
    item As PictureURLsType _
) As Integer
public:
int Add(
    PictureURLsType^ item
)
Parameters
item (PictureURLsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PictureURLsType>[]()[][]) |
 | AddRange(PictureURLsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► AddRange(array<PictureURLsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PictureURLsType[] items
)
Public Sub AddRange ( _
    items As PictureURLsType() _
)
public:
void AddRange(
    array<PictureURLsType^>^ items
)
Parameters
items (array< PictureURLsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► AddRange(PictureURLsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PictureURLsTypeCollection items
)
Public Sub AddRange ( _
    items As PictureURLsTypeCollection _
)
public:
void AddRange(
    PictureURLsTypeCollection^ items
)
Parameters
items (PictureURLsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► Contains(PictureURLsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PictureURLsType item
)
Public Function Contains ( _
    item As PictureURLsType _
) As Boolean
public:
bool Contains(
    PictureURLsType^ item
)
Parameters
item (PictureURLsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► CopyTo(array<PictureURLsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PictureURLsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PictureURLsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PictureURLsType^>^ items,
    int index
)
Parameters
items (array< PictureURLsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► IndexOf(PictureURLsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PictureURLsType item
)
Public Function IndexOf ( _
    item As PictureURLsType _
) As Integer
public:
int IndexOf(
    PictureURLsType^ item
)
Parameters
item (PictureURLsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► Insert(Int32, PictureURLsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PictureURLsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PictureURLsType _
)
public:
void Insert(
    int index,
    PictureURLsType^ item
)
Parameters
index (Int32)
item (PictureURLsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PictureURLsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PictureURLsType
    Get
    Set
public:
property PictureURLsType^ default[int index] {
    PictureURLsType^ get (int index);
    void set (int index, PictureURLsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PictureURLsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PictureURLsType
public:
PictureURLsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PictureURLsTypeCollection Constructor

PictureURLsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► PictureURLsTypeCollection()()()()
Members
Icon | Member | Description
 | PictureURLsTypeCollection()()()() |
 | PictureURLsTypeCollection(array<PictureURLsType>[]()[][]) |
 | PictureURLsTypeCollection(PictureURLsTypeCollection) |


PictureURLsTypeCollection Constructor

PictureURLsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► PictureURLsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PictureURLsTypeCollection()
Public Sub New
public:
PictureURLsTypeCollection()


PictureURLsTypeCollection Constructor (items)

PictureURLsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► PictureURLsTypeCollection(array<PictureURLsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PictureURLsTypeCollection(
    PictureURLsType[] items
)
Public Sub New ( _
    items As PictureURLsType() _
)
public:
PictureURLsTypeCollection(
    array<PictureURLsType^>^ items
)
Parameters
items (array< PictureURLsType >[]()[][])


PictureURLsTypeCollection Constructor (items)

PictureURLsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► PictureURLsTypeCollection(PictureURLsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PictureURLsTypeCollection(
    PictureURLsTypeCollection items
)
Public Sub New ( _
    items As PictureURLsTypeCollection _
)
public:
PictureURLsTypeCollection(
    PictureURLsTypeCollection^ items
)
Parameters
items (PictureURLsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► Remove(PictureURLsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PictureURLsType item
)
Public Sub Remove ( _
    item As PictureURLsType _
)
public:
void Remove(
    PictureURLsType^ item
)
Parameters
item (PictureURLsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PictureURLsType[] ToArray()
Public Function ToArray As PictureURLsType()
public:
array<PictureURLsType^>^ ToArray()
Return Value


PictureWatermarkCodeType Enumeration

PictureWatermarkCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PictureWatermarkCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PictureWatermarkCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PictureWatermarkCodeType
Members
Member | Description
User |
Icon |
CustomCode |
Remarks


PictureWatermarkCodeTypeCollection Class

PictureWatermarkCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PictureWatermarkCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PictureWatermarkCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PictureWatermarkCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PictureWatermarkCodeTypeCollection()()()() |
 | PictureWatermarkCodeTypeCollection(array<PictureWatermarkCodeType>[]()[][]) |
 | PictureWatermarkCodeTypeCollection(PictureWatermarkCodeTypeCollection) |
 | Add(PictureWatermarkCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PictureWatermarkCodeType>[]()[][]) |
 | AddRange(PictureWatermarkCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PictureWatermarkCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PictureWatermarkCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PictureWatermarkCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PictureWatermarkCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PictureWatermarkCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PictureWatermarkCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► Add(PictureWatermarkCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PictureWatermarkCodeType item
)
Public Function Add ( _
    item As PictureWatermarkCodeType _
) As Integer
public:
int Add(
    PictureWatermarkCodeType item
)
Parameters
item (PictureWatermarkCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PictureWatermarkCodeType>[]()[][]) |
 | AddRange(PictureWatermarkCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► AddRange(array<PictureWatermarkCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PictureWatermarkCodeType[] items
)
Public Sub AddRange ( _
    items As PictureWatermarkCodeType() _
)
public:
void AddRange(
    array<PictureWatermarkCodeType>^ items
)
Parameters
items (array< PictureWatermarkCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► AddRange(PictureWatermarkCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PictureWatermarkCodeTypeCollection items
)
Public Sub AddRange ( _
    items As PictureWatermarkCodeTypeCollection _
)
public:
void AddRange(
    PictureWatermarkCodeTypeCollection^ items
)
Parameters
items (PictureWatermarkCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► Contains(PictureWatermarkCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PictureWatermarkCodeType item
)
Public Function Contains ( _
    item As PictureWatermarkCodeType _
) As Boolean
public:
bool Contains(
    PictureWatermarkCodeType item
)
Parameters
item (PictureWatermarkCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► CopyTo(array<PictureWatermarkCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PictureWatermarkCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PictureWatermarkCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PictureWatermarkCodeType>^ items,
    int index
)
Parameters
items (array< PictureWatermarkCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► IndexOf(PictureWatermarkCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PictureWatermarkCodeType item
)
Public Function IndexOf ( _
    item As PictureWatermarkCodeType _
) As Integer
public:
int IndexOf(
    PictureWatermarkCodeType item
)
Parameters
item (PictureWatermarkCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► Insert(Int32, PictureWatermarkCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PictureWatermarkCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PictureWatermarkCodeType _
)
public:
void Insert(
    int index,
    PictureWatermarkCodeType item
)
Parameters
index (Int32)
item (PictureWatermarkCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PictureWatermarkCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PictureWatermarkCodeType
    Get
    Set
public:
property PictureWatermarkCodeType default[int index] {
    PictureWatermarkCodeType get (int index);
    void set (int index, PictureWatermarkCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PictureWatermarkCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PictureWatermarkCodeType
public:
PictureWatermarkCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PictureWatermarkCodeTypeCollection Constructor

PictureWatermarkCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► PictureWatermarkCodeTypeCollection()()()()
Members
Icon | Member | Description
 | PictureWatermarkCodeTypeCollection()()()() |
 | PictureWatermarkCodeTypeCollection(array<PictureWatermarkCodeType>[]()[][]) |
 | PictureWatermarkCodeTypeCollection(PictureWatermarkCodeTypeCollection) |


PictureWatermarkCodeTypeCollection Constructor

PictureWatermarkCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► PictureWatermarkCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PictureWatermarkCodeTypeCollection()
Public Sub New
public:
PictureWatermarkCodeTypeCollection()


PictureWatermarkCodeTypeCollection Constructor (items)

PictureWatermarkCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► PictureWatermarkCodeTypeCollection(array<PictureWatermarkCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PictureWatermarkCodeTypeCollection(
    PictureWatermarkCodeType[] items
)
Public Sub New ( _
    items As PictureWatermarkCodeType() _
)
public:
PictureWatermarkCodeTypeCollection(
    array<PictureWatermarkCodeType>^ items
)
Parameters
items (array< PictureWatermarkCodeType >[]()[][])


PictureWatermarkCodeTypeCollection Constructor (items)

PictureWatermarkCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► PictureWatermarkCodeTypeCollection(PictureWatermarkCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PictureWatermarkCodeTypeCollection(
    PictureWatermarkCodeTypeCollection items
)
Public Sub New ( _
    items As PictureWatermarkCodeTypeCollection _
)
public:
PictureWatermarkCodeTypeCollection(
    PictureWatermarkCodeTypeCollection^ items
)
Parameters
items (PictureWatermarkCodeTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► Remove(PictureWatermarkCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PictureWatermarkCodeType item
)
Public Sub Remove ( _
    item As PictureWatermarkCodeType _
)
public:
void Remove(
    PictureWatermarkCodeType item
)
Parameters
item (PictureWatermarkCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PictureWatermarkCodeType[] ToArray()
Public Function ToArray As PictureWatermarkCodeType()
public:
array<PictureWatermarkCodeType>^ ToArray()
Return Value


PlaceOfferRequestType Class

PlaceOfferRequestType Class
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PlaceOfferRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PlaceOfferRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PlaceOfferRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlaceOfferRequestType()()()() |
 | AffiliateTrackingDetails |
 | Any | (Inherited from AbstractRequestType.)
 | BlockOnWarning |
 | BlockOnWarningSpecified |
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | Offer |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | VariationSpecifics |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | PlaceOfferRequestType


AffiliateTrackingDetails Property

AffiliateTrackingDetails Property
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferRequestType ► AffiliateTrackingDetails
Declaration Syntax
C# Visual Basic Visual C++
public AffiliateTrackingDetailsType AffiliateTrackingDetails { get; set; }
Public Property AffiliateTrackingDetails As AffiliateTrackingDetailsType
    Get
    Set
public:
property AffiliateTrackingDetailsType^ AffiliateTrackingDetails {
    AffiliateTrackingDetailsType^ get ();
    void set (AffiliateTrackingDetailsType^ value);
}


BlockOnWarning Property

BlockOnWarning Property
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferRequestType ► BlockOnWarning
Declaration Syntax
C# Visual Basic Visual C++
public bool BlockOnWarning { get; set; }
Public Property BlockOnWarning As Boolean
    Get
    Set
public:
property bool BlockOnWarning {
    bool get ();
    void set (bool value);
}


BlockOnWarningSpecified Property

BlockOnWarningSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferRequestType ► BlockOnWarningSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BlockOnWarningSpecified { get; set; }
Public Property BlockOnWarningSpecified As Boolean
    Get
    Set
public:
property bool BlockOnWarningSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


Offer Property

Offer Property
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferRequestType ► Offer
Declaration Syntax
C# Visual Basic Visual C++
public OfferType Offer { get; set; }
Public Property Offer As OfferType
    Get
    Set
public:
property OfferType^ Offer {
    OfferType^ get ();
    void set (OfferType^ value);
}


PlaceOfferRequestType Constructor

PlaceOfferRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferRequestType ► PlaceOfferRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PlaceOfferRequestType()
Public Sub New
public:
PlaceOfferRequestType()


VariationSpecifics Property

VariationSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferRequestType ► VariationSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection VariationSpecifics { get; set; }
Public Property VariationSpecifics As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ VariationSpecifics {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


PlaceOfferResponseType Class

PlaceOfferResponseType Class
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PlaceOfferResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PlaceOfferResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PlaceOfferResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlaceOfferResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BestOffer |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | OrderLineItemID |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SellingStatus |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | PlaceOfferResponseType


BestOffer Property

BestOffer Property
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferResponseType ► BestOffer
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferType BestOffer { get; set; }
Public Property BestOffer As BestOfferType
    Get
    Set
public:
property BestOfferType^ BestOffer {
    BestOfferType^ get ();
    void set (BestOfferType^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferResponseType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


PlaceOfferResponseType Constructor

PlaceOfferResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferResponseType ► PlaceOfferResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PlaceOfferResponseType()
Public Sub New
public:
PlaceOfferResponseType()


SellingStatus Property

SellingStatus Property
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferResponseType ► SellingStatus
Declaration Syntax
C# Visual Basic Visual C++
public SellingStatusType SellingStatus { get; set; }
Public Property SellingStatus As SellingStatusType
    Get
    Set
public:
property SellingStatusType^ SellingStatus {
    SellingStatusType^ get ();
    void set (SellingStatusType^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► PlaceOfferResponseType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


PolicyComplianceDashboardType Class

PolicyComplianceDashboardType Class
Namespaces ► eBay.Service.Core.Soap ► PolicyComplianceDashboardType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PolicyComplianceDashboardType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PolicyComplianceDashboardType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PolicyComplianceDashboardType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolicyComplianceDashboardType()()()() |
 | Alert |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PolicyComplianceDashboardType


Alert Property

Alert Property
Namespaces ► eBay.Service.Core.Soap ► PolicyComplianceDashboardType ► Alert
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertTypeCollection Alert { get; set; }
Public Property Alert As SellerDashboardAlertTypeCollection
    Get
    Set
public:
property SellerDashboardAlertTypeCollection^ Alert {
    SellerDashboardAlertTypeCollection^ get ();
    void set (SellerDashboardAlertTypeCollection^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PolicyComplianceDashboardType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PolicyComplianceDashboardType Constructor

PolicyComplianceDashboardType Constructor
Namespaces ► eBay.Service.Core.Soap ► PolicyComplianceDashboardType ► PolicyComplianceDashboardType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolicyComplianceDashboardType()
Public Sub New
public:
PolicyComplianceDashboardType()


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► PolicyComplianceDashboardType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public PolicyComplianceStatusCodeType Status { get; set; }
Public Property Status As PolicyComplianceStatusCodeType
    Get
    Set
public:
property PolicyComplianceStatusCodeType Status {
    PolicyComplianceStatusCodeType get ();
    void set (PolicyComplianceStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PolicyComplianceDashboardType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


PolicyComplianceStatusCodeType Enumeration

PolicyComplianceStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PolicyComplianceStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PolicyComplianceStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PolicyComplianceStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PolicyComplianceStatusCodeType
Members
Member | Description
Good |
Fair |
Poor |
Failing |
CustomCode |
Remarks


PolicyViolationDurationDetailsType Class

PolicyViolationDurationDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PolicyViolationDurationDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PolicyViolationDurationDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PolicyViolationDurationDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolicyViolationDurationDetailsType()()()() |
 | Any |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Period |
 | PeriodSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PolicyViolationDurationDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Period Property

Period Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsType ► Period
Declaration Syntax
C# Visual Basic Visual C++
public PeriodCodeType Period { get; set; }
Public Property Period As PeriodCodeType
    Get
    Set
public:
property PeriodCodeType Period {
    PeriodCodeType get ();
    void set (PeriodCodeType value);
}


PeriodSpecified Property

PeriodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsType ► PeriodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PeriodSpecified { get; set; }
Public Property PeriodSpecified As Boolean
    Get
    Set
public:
property bool PeriodSpecified {
    bool get ();
    void set (bool value);
}


PolicyViolationDurationDetailsType Constructor

PolicyViolationDurationDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsType ► PolicyViolationDurationDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolicyViolationDurationDetailsType()
Public Sub New
public:
PolicyViolationDurationDetailsType()


PolicyViolationDurationDetailsTypeCollection Class

PolicyViolationDurationDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PolicyViolationDurationDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PolicyViolationDurationDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PolicyViolationDurationDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolicyViolationDurationDetailsTypeCollection()()()() |
 | PolicyViolationDurationDetailsTypeCollection(array<PolicyViolationDurationDetailsType>[]()[][]) |
 | PolicyViolationDurationDetailsTypeCollection(PolicyViolationDurationDetailsTypeCollection) |
 | Add(PolicyViolationDurationDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PolicyViolationDurationDetailsType>[]()[][]) |
 | AddRange(PolicyViolationDurationDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PolicyViolationDurationDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PolicyViolationDurationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PolicyViolationDurationDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PolicyViolationDurationDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PolicyViolationDurationDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PolicyViolationDurationDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► Add(PolicyViolationDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PolicyViolationDurationDetailsType item
)
Public Function Add ( _
    item As PolicyViolationDurationDetailsType _
) As Integer
public:
int Add(
    PolicyViolationDurationDetailsType^ item
)
Parameters
item (PolicyViolationDurationDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PolicyViolationDurationDetailsType>[]()[][]) |
 | AddRange(PolicyViolationDurationDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► AddRange(array<PolicyViolationDurationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PolicyViolationDurationDetailsType[] items
)
Public Sub AddRange ( _
    items As PolicyViolationDurationDetailsType() _
)
public:
void AddRange(
    array<PolicyViolationDurationDetailsType^>^ items
)
Parameters
items (array< PolicyViolationDurationDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► AddRange(PolicyViolationDurationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PolicyViolationDurationDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As PolicyViolationDurationDetailsTypeCollection _
)
public:
void AddRange(
    PolicyViolationDurationDetailsTypeCollection^ items
)
Parameters
items (PolicyViolationDurationDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► Contains(PolicyViolationDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PolicyViolationDurationDetailsType item
)
Public Function Contains ( _
    item As PolicyViolationDurationDetailsType _
) As Boolean
public:
bool Contains(
    PolicyViolationDurationDetailsType^ item
)
Parameters
item (PolicyViolationDurationDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► CopyTo(array<PolicyViolationDurationDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PolicyViolationDurationDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PolicyViolationDurationDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PolicyViolationDurationDetailsType^>^ items,
    int index
)
Parameters
items (array< PolicyViolationDurationDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► IndexOf(PolicyViolationDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PolicyViolationDurationDetailsType item
)
Public Function IndexOf ( _
    item As PolicyViolationDurationDetailsType _
) As Integer
public:
int IndexOf(
    PolicyViolationDurationDetailsType^ item
)
Parameters
item (PolicyViolationDurationDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► Insert(Int32, PolicyViolationDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PolicyViolationDurationDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PolicyViolationDurationDetailsType _
)
public:
void Insert(
    int index,
    PolicyViolationDurationDetailsType^ item
)
Parameters
index (Int32)
item (PolicyViolationDurationDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PolicyViolationDurationDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PolicyViolationDurationDetailsType
    Get
    Set
public:
property PolicyViolationDurationDetailsType^ default[int index] {
    PolicyViolationDurationDetailsType^ get (int index);
    void set (int index, PolicyViolationDurationDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PolicyViolationDurationDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PolicyViolationDurationDetailsType
public:
PolicyViolationDurationDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PolicyViolationDurationDetailsTypeCollection Constructor

PolicyViolationDurationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► PolicyViolationDurationDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | PolicyViolationDurationDetailsTypeCollection()()()() |
 | PolicyViolationDurationDetailsTypeCollection(array<PolicyViolationDurationDetailsType>[]()[][]) |
 | PolicyViolationDurationDetailsTypeCollection(PolicyViolationDurationDetailsTypeCollection) |


PolicyViolationDurationDetailsTypeCollection Constructor

PolicyViolationDurationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► PolicyViolationDurationDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolicyViolationDurationDetailsTypeCollection()
Public Sub New
public:
PolicyViolationDurationDetailsTypeCollection()


PolicyViolationDurationDetailsTypeCollection Constructor (items)

PolicyViolationDurationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► PolicyViolationDurationDetailsTypeCollection(array<PolicyViolationDurationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PolicyViolationDurationDetailsTypeCollection(
    PolicyViolationDurationDetailsType[] items
)
Public Sub New ( _
    items As PolicyViolationDurationDetailsType() _
)
public:
PolicyViolationDurationDetailsTypeCollection(
    array<PolicyViolationDurationDetailsType^>^ items
)
Parameters
items (array< PolicyViolationDurationDetailsType >[]()[][])


PolicyViolationDurationDetailsTypeCollection Constructor (items)

PolicyViolationDurationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► PolicyViolationDurationDetailsTypeCollection(PolicyViolationDurationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PolicyViolationDurationDetailsTypeCollection(
    PolicyViolationDurationDetailsTypeCollection items
)
Public Sub New ( _
    items As PolicyViolationDurationDetailsTypeCollection _
)
public:
PolicyViolationDurationDetailsTypeCollection(
    PolicyViolationDurationDetailsTypeCollection^ items
)
Parameters
items (PolicyViolationDurationDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► Remove(PolicyViolationDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PolicyViolationDurationDetailsType item
)
Public Sub Remove ( _
    item As PolicyViolationDurationDetailsType _
)
public:
void Remove(
    PolicyViolationDurationDetailsType^ item
)
Parameters
item (PolicyViolationDurationDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PolicyViolationDurationDetailsType[] ToArray()
Public Function ToArray As PolicyViolationDurationDetailsType()
public:
array<PolicyViolationDurationDetailsType^>^ ToArray()
Return Value


PowerSellerDashboardType Class

PowerSellerDashboardType Class
Namespaces ► eBay.Service.Core.Soap ► PowerSellerDashboardType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PowerSellerDashboardType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PowerSellerDashboardType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PowerSellerDashboardType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PowerSellerDashboardType()()()() |
 | Alert |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Level |
 | LevelSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PowerSellerDashboardType


Alert Property

Alert Property
Namespaces ► eBay.Service.Core.Soap ► PowerSellerDashboardType ► Alert
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertTypeCollection Alert { get; set; }
Public Property Alert As SellerDashboardAlertTypeCollection
    Get
    Set
public:
property SellerDashboardAlertTypeCollection^ Alert {
    SellerDashboardAlertTypeCollection^ get ();
    void set (SellerDashboardAlertTypeCollection^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PowerSellerDashboardType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Level Property

Level Property
Namespaces ► eBay.Service.Core.Soap ► PowerSellerDashboardType ► Level
Declaration Syntax
C# Visual Basic Visual C++
public SellerLevelCodeType Level { get; set; }
Public Property Level As SellerLevelCodeType
    Get
    Set
public:
property SellerLevelCodeType Level {
    SellerLevelCodeType get ();
    void set (SellerLevelCodeType value);
}


LevelSpecified Property

LevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PowerSellerDashboardType ► LevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LevelSpecified { get; set; }
Public Property LevelSpecified As Boolean
    Get
    Set
public:
property bool LevelSpecified {
    bool get ();
    void set (bool value);
}


PowerSellerDashboardType Constructor

PowerSellerDashboardType Constructor
Namespaces ► eBay.Service.Core.Soap ► PowerSellerDashboardType ► PowerSellerDashboardType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PowerSellerDashboardType()
Public Sub New
public:
PowerSellerDashboardType()


PreferredLocationCodeType Enumeration

PreferredLocationCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PreferredLocationCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PreferredLocationCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PreferredLocationCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PreferredLocationCodeType
Members
Member | Description
ListedInCurrencyImplied |
LocatedInCountryImplied |
AvailableInCountryImplied |
SiteImplied |
BelgiumListing |
CustomCode |
Remarks


PremiumSubscriptionDefinitionType Class

PremiumSubscriptionDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► PremiumSubscriptionDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PremiumSubscriptionDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PremiumSubscriptionDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PremiumSubscriptionDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PremiumSubscriptionDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PremiumSubscriptionDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PremiumSubscriptionDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PremiumSubscriptionDefinitionType Constructor

PremiumSubscriptionDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► PremiumSubscriptionDefinitionType ► PremiumSubscriptionDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PremiumSubscriptionDefinitionType()
Public Sub New
public:
PremiumSubscriptionDefinitionType()


PricingTreatmentCodeType Enumeration

PricingTreatmentCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PricingTreatmentCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PricingTreatmentCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PricingTreatmentCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PricingTreatmentCodeType
Members
Member | Description
STP |
MAP |
None |
MFO |
CustomCode |
Remarks


ProductCreationEnabledCodeType Enumeration

ProductCreationEnabledCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ProductCreationEnabledCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ProductCreationEnabledCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ProductCreationEnabledCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ProductCreationEnabledCodeType
Members
Member | Description
Disabled |
Enabled |
Required |
CustomCode |
Remarks


ProductCreationEnabledDefinitionType Class

ProductCreationEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ProductCreationEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ProductCreationEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ProductCreationEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ProductCreationEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProductCreationEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ProductCreationEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ProductCreationEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ProductCreationEnabledDefinitionType Constructor

ProductCreationEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ProductCreationEnabledDefinitionType ► ProductCreationEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProductCreationEnabledDefinitionType()
Public Sub New
public:
ProductCreationEnabledDefinitionType()


ProductDetailsType Class

ProductDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ProductDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ProductDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ProductDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ProductDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProductDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProductIdentifierUnavailableText |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ProductDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ProductDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ProductDetailsType Constructor

ProductDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ProductDetailsType ► ProductDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProductDetailsType()
Public Sub New
public:
ProductDetailsType()


ProductIdentifierUnavailableText Property

ProductIdentifierUnavailableText Property
Namespaces ► eBay.Service.Core.Soap ► ProductDetailsType ► ProductIdentifierUnavailableText
Declaration Syntax
C# Visual Basic Visual C++
public string ProductIdentifierUnavailableText { get; set; }
Public Property ProductIdentifierUnavailableText As String
    Get
    Set
public:
property String^ ProductIdentifierUnavailableText {
    String^ get ();
    void set (String^ value);
}


ProductIdentiferEnabledCodeType Enumeration

ProductIdentiferEnabledCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ProductIdentiferEnabledCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ProductIdentiferEnabledCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ProductIdentiferEnabledCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ProductIdentiferEnabledCodeType
Members
Member | Description
Disabled |
Enabled |
Required |
CustomCode |
Remarks


ProductListingDetailsType Class

ProductListingDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ProductListingDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ProductListingDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ProductListingDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProductListingDetailsType()()()() |
 | Any |
 | BrandMPN |
 | Copyright |
 | DetailsURL |
 | EAN |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeeBayProductDetails |
 | IncludeeBayProductDetailsSpecified |
 | IncludeStockPhotoURL |
 | IncludeStockPhotoURLSpecified |
 | ISBN |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProductDetailsURL |
 | ProductReferenceID |
 | ReturnSearchResultOnDuplicates |
 | ReturnSearchResultOnDuplicatesSpecified |
 | StockPhotoURL |
 | TicketListingDetails |
 | ToString()()()() | (Inherited from Object.)
 | UPC |
 | UseFirstProduct |
 | UseFirstProductSpecified |
 | UseStockPhotoURLAsGallery |
 | UseStockPhotoURLAsGallerySpecified |
Remarks
Inheritance Hierarchy
Object
ProductListingDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BrandMPN Property

BrandMPN Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► BrandMPN
Declaration Syntax
C# Visual Basic Visual C++
public BrandMPNType BrandMPN { get; set; }
Public Property BrandMPN As BrandMPNType
    Get
    Set
public:
property BrandMPNType^ BrandMPN {
    BrandMPNType^ get ();
    void set (BrandMPNType^ value);
}


Copyright Property

Copyright Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► Copyright
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection Copyright { get; set; }
Public Property Copyright As StringCollection
    Get
    Set
public:
property StringCollection^ Copyright {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


DetailsURL Property

DetailsURL Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► DetailsURL
Declaration Syntax
C# Visual Basic Visual C++
public string DetailsURL { get; set; }
Public Property DetailsURL As String
    Get
    Set
public:
property String^ DetailsURL {
    String^ get ();
    void set (String^ value);
}


EAN Property

EAN Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► EAN
Declaration Syntax
C# Visual Basic Visual C++
public string EAN { get; set; }
Public Property EAN As String
    Get
    Set
public:
property String^ EAN {
    String^ get ();
    void set (String^ value);
}


IncludeeBayProductDetails Property

IncludeeBayProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► IncludeeBayProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeeBayProductDetails { get; set; }
Public Property IncludeeBayProductDetails As Boolean
    Get
    Set
public:
property bool IncludeeBayProductDetails {
    bool get ();
    void set (bool value);
}


IncludeeBayProductDetailsSpecified Property

IncludeeBayProductDetailsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► IncludeeBayProductDetailsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeeBayProductDetailsSpecified { get; set; }
Public Property IncludeeBayProductDetailsSpecified As Boolean
    Get
    Set
public:
property bool IncludeeBayProductDetailsSpecified {
    bool get ();
    void set (bool value);
}


IncludeStockPhotoURL Property

IncludeStockPhotoURL Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► IncludeStockPhotoURL
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeStockPhotoURL { get; set; }
Public Property IncludeStockPhotoURL As Boolean
    Get
    Set
public:
property bool IncludeStockPhotoURL {
    bool get ();
    void set (bool value);
}


IncludeStockPhotoURLSpecified Property

IncludeStockPhotoURLSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► IncludeStockPhotoURLSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeStockPhotoURLSpecified { get; set; }
Public Property IncludeStockPhotoURLSpecified As Boolean
    Get
    Set
public:
property bool IncludeStockPhotoURLSpecified {
    bool get ();
    void set (bool value);
}


ISBN Property

ISBN Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► ISBN
Declaration Syntax
C# Visual Basic Visual C++
public string ISBN { get; set; }
Public Property ISBN As String
    Get
    Set
public:
property String^ ISBN {
    String^ get ();
    void set (String^ value);
}


ProductDetailsURL Property

ProductDetailsURL Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► ProductDetailsURL
Declaration Syntax
C# Visual Basic Visual C++
public string ProductDetailsURL { get; set; }
Public Property ProductDetailsURL As String
    Get
    Set
public:
property String^ ProductDetailsURL {
    String^ get ();
    void set (String^ value);
}


ProductListingDetailsType Constructor

ProductListingDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► ProductListingDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProductListingDetailsType()
Public Sub New
public:
ProductListingDetailsType()


ProductReferenceID Property

ProductReferenceID Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► ProductReferenceID
Declaration Syntax
C# Visual Basic Visual C++
public string ProductReferenceID { get; set; }
Public Property ProductReferenceID As String
    Get
    Set
public:
property String^ ProductReferenceID {
    String^ get ();
    void set (String^ value);
}


ReturnSearchResultOnDuplicates Property

ReturnSearchResultOnDuplicates Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► ReturnSearchResultOnDuplicates
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnSearchResultOnDuplicates { get; set; }
Public Property ReturnSearchResultOnDuplicates As Boolean
    Get
    Set
public:
property bool ReturnSearchResultOnDuplicates {
    bool get ();
    void set (bool value);
}


ReturnSearchResultOnDuplicatesSpecified Property

ReturnSearchResultOnDuplicatesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► ReturnSearchResultOnDuplicatesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnSearchResultOnDuplicatesSpecified { get; set; }
Public Property ReturnSearchResultOnDuplicatesSpecified As Boolean
    Get
    Set
public:
property bool ReturnSearchResultOnDuplicatesSpecified {
    bool get ();
    void set (bool value);
}


StockPhotoURL Property

StockPhotoURL Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► StockPhotoURL
Declaration Syntax
C# Visual Basic Visual C++
public string StockPhotoURL { get; set; }
Public Property StockPhotoURL As String
    Get
    Set
public:
property String^ StockPhotoURL {
    String^ get ();
    void set (String^ value);
}


TicketListingDetails Property

TicketListingDetails Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► TicketListingDetails
Declaration Syntax
C# Visual Basic Visual C++
public TicketListingDetailsType TicketListingDetails { get; set; }
Public Property TicketListingDetails As TicketListingDetailsType
    Get
    Set
public:
property TicketListingDetailsType^ TicketListingDetails {
    TicketListingDetailsType^ get ();
    void set (TicketListingDetailsType^ value);
}


UPC Property

UPC Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► UPC
Declaration Syntax
C# Visual Basic Visual C++
public string UPC { get; set; }
Public Property UPC As String
    Get
    Set
public:
property String^ UPC {
    String^ get ();
    void set (String^ value);
}


UseFirstProduct Property

UseFirstProduct Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► UseFirstProduct
Declaration Syntax
C# Visual Basic Visual C++
public bool UseFirstProduct { get; set; }
Public Property UseFirstProduct As Boolean
    Get
    Set
public:
property bool UseFirstProduct {
    bool get ();
    void set (bool value);
}


UseFirstProductSpecified Property

UseFirstProductSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► UseFirstProductSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UseFirstProductSpecified { get; set; }
Public Property UseFirstProductSpecified As Boolean
    Get
    Set
public:
property bool UseFirstProductSpecified {
    bool get ();
    void set (bool value);
}


UseStockPhotoURLAsGallery Property

UseStockPhotoURLAsGallery Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► UseStockPhotoURLAsGallery
Declaration Syntax
C# Visual Basic Visual C++
public bool UseStockPhotoURLAsGallery { get; set; }
Public Property UseStockPhotoURLAsGallery As Boolean
    Get
    Set
public:
property bool UseStockPhotoURLAsGallery {
    bool get ();
    void set (bool value);
}


UseStockPhotoURLAsGallerySpecified Property

UseStockPhotoURLAsGallerySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ProductListingDetailsType ► UseStockPhotoURLAsGallerySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UseStockPhotoURLAsGallerySpecified { get; set; }
Public Property UseStockPhotoURLAsGallerySpecified As Boolean
    Get
    Set
public:
property bool UseStockPhotoURLAsGallerySpecified {
    bool get ();
    void set (bool value);
}


ProductSuggestionsType Class

ProductSuggestionsType Class
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ProductSuggestionsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ProductSuggestionsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ProductSuggestionsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProductSuggestionsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProductSuggestion |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ProductSuggestionsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ProductSuggestion Property

ProductSuggestion Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionsType ► ProductSuggestion
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionTypeCollection ProductSuggestion { get; set; }
Public Property ProductSuggestion As ProductSuggestionTypeCollection
    Get
    Set
public:
property ProductSuggestionTypeCollection^ ProductSuggestion {
    ProductSuggestionTypeCollection^ get ();
    void set (ProductSuggestionTypeCollection^ value);
}


ProductSuggestionsType Constructor

ProductSuggestionsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionsType ► ProductSuggestionsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType()
Public Sub New
public:
ProductSuggestionsType()


ProductSuggestionType Class

ProductSuggestionType Class
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ProductSuggestionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ProductSuggestionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ProductSuggestionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProductSuggestionType()()()() |
 | Any |
 | EPID |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Recommended |
 | RecommendedSpecified |
 | StockPhoto |
 | Title |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ProductSuggestionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EPID Property

EPID Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionType ► EPID
Declaration Syntax
C# Visual Basic Visual C++
public string EPID { get; set; }
Public Property EPID As String
    Get
    Set
public:
property String^ EPID {
    String^ get ();
    void set (String^ value);
}


ProductSuggestionType Constructor

ProductSuggestionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionType ► ProductSuggestionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionType()
Public Sub New
public:
ProductSuggestionType()


Recommended Property

Recommended Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionType ► Recommended
Declaration Syntax
C# Visual Basic Visual C++
public bool Recommended { get; set; }
Public Property Recommended As Boolean
    Get
    Set
public:
property bool Recommended {
    bool get ();
    void set (bool value);
}


RecommendedSpecified Property

RecommendedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionType ► RecommendedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RecommendedSpecified { get; set; }
Public Property RecommendedSpecified As Boolean
    Get
    Set
public:
property bool RecommendedSpecified {
    bool get ();
    void set (bool value);
}


StockPhoto Property

StockPhoto Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionType ► StockPhoto
Declaration Syntax
C# Visual Basic Visual C++
public string StockPhoto { get; set; }
Public Property StockPhoto As String
    Get
    Set
public:
property String^ StockPhoto {
    String^ get ();
    void set (String^ value);
}


Title Property

Title Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionType ► Title
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}


ProductSuggestionTypeCollection Class

ProductSuggestionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ProductSuggestionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ProductSuggestionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ProductSuggestionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProductSuggestionTypeCollection()()()() |
 | ProductSuggestionTypeCollection(array<ProductSuggestionType>[]()[][]) |
 | ProductSuggestionTypeCollection(ProductSuggestionTypeCollection) |
 | Add(ProductSuggestionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ProductSuggestionType>[]()[][]) |
 | AddRange(ProductSuggestionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ProductSuggestionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ProductSuggestionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ProductSuggestionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ProductSuggestionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ProductSuggestionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ProductSuggestionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► Add(ProductSuggestionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ProductSuggestionType item
)
Public Function Add ( _
    item As ProductSuggestionType _
) As Integer
public:
int Add(
    ProductSuggestionType^ item
)
Parameters
item (ProductSuggestionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ProductSuggestionType>[]()[][]) |
 | AddRange(ProductSuggestionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► AddRange(array<ProductSuggestionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ProductSuggestionType[] items
)
Public Sub AddRange ( _
    items As ProductSuggestionType() _
)
public:
void AddRange(
    array<ProductSuggestionType^>^ items
)
Parameters
items (array< ProductSuggestionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► AddRange(ProductSuggestionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ProductSuggestionTypeCollection items
)
Public Sub AddRange ( _
    items As ProductSuggestionTypeCollection _
)
public:
void AddRange(
    ProductSuggestionTypeCollection^ items
)
Parameters
items (ProductSuggestionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► Contains(ProductSuggestionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ProductSuggestionType item
)
Public Function Contains ( _
    item As ProductSuggestionType _
) As Boolean
public:
bool Contains(
    ProductSuggestionType^ item
)
Parameters
item (ProductSuggestionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► CopyTo(array<ProductSuggestionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ProductSuggestionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ProductSuggestionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ProductSuggestionType^>^ items,
    int index
)
Parameters
items (array< ProductSuggestionType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► IndexOf(ProductSuggestionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ProductSuggestionType item
)
Public Function IndexOf ( _
    item As ProductSuggestionType _
) As Integer
public:
int IndexOf(
    ProductSuggestionType^ item
)
Parameters
item (ProductSuggestionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► Insert(Int32, ProductSuggestionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ProductSuggestionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ProductSuggestionType _
)
public:
void Insert(
    int index,
    ProductSuggestionType^ item
)
Parameters
index (Int32)
item (ProductSuggestionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ProductSuggestionType
    Get
    Set
public:
property ProductSuggestionType^ default[int index] {
    ProductSuggestionType^ get (int index);
    void set (int index, ProductSuggestionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ProductSuggestionType
public:
ProductSuggestionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ProductSuggestionTypeCollection Constructor

ProductSuggestionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► ProductSuggestionTypeCollection()()()()
Members
Icon | Member | Description
 | ProductSuggestionTypeCollection()()()() |
 | ProductSuggestionTypeCollection(array<ProductSuggestionType>[]()[][]) |
 | ProductSuggestionTypeCollection(ProductSuggestionTypeCollection) |


ProductSuggestionTypeCollection Constructor

ProductSuggestionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► ProductSuggestionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionTypeCollection()
Public Sub New
public:
ProductSuggestionTypeCollection()


ProductSuggestionTypeCollection Constructor (items)

ProductSuggestionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► ProductSuggestionTypeCollection(array<ProductSuggestionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionTypeCollection(
    ProductSuggestionType[] items
)
Public Sub New ( _
    items As ProductSuggestionType() _
)
public:
ProductSuggestionTypeCollection(
    array<ProductSuggestionType^>^ items
)
Parameters
items (array< ProductSuggestionType >[]()[][])


ProductSuggestionTypeCollection Constructor (items)

ProductSuggestionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► ProductSuggestionTypeCollection(ProductSuggestionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionTypeCollection(
    ProductSuggestionTypeCollection items
)
Public Sub New ( _
    items As ProductSuggestionTypeCollection _
)
public:
ProductSuggestionTypeCollection(
    ProductSuggestionTypeCollection^ items
)
Parameters
items (ProductSuggestionTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► Remove(ProductSuggestionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ProductSuggestionType item
)
Public Sub Remove ( _
    item As ProductSuggestionType _
)
public:
void Remove(
    ProductSuggestionType^ item
)
Parameters
item (ProductSuggestionType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionType[] ToArray()
Public Function ToArray As ProductSuggestionType()
public:
array<ProductSuggestionType^>^ ToArray()
Return Value


ProductType Class

ProductType Class
Namespaces ► eBay.Service.Core.Soap ► ProductType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ProductType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ProductType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ProductType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProductType()()()() |
 | Any |
 | CharacteristicsSet |
 | DetailsURL |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MaxPrice |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinPrice |
 | NumItems |
 | NumItemsSpecified |
 | productID |
 | ProductReferenceID |
 | stockPhotoURL |
 | title |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ProductType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ProductType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CharacteristicsSet Property

CharacteristicsSet Property
Namespaces ► eBay.Service.Core.Soap ► ProductType ► CharacteristicsSet
Declaration Syntax
C# Visual Basic Visual C++
public CharacteristicsSetType CharacteristicsSet { get; set; }
Public Property CharacteristicsSet As CharacteristicsSetType
    Get
    Set
public:
property CharacteristicsSetType^ CharacteristicsSet {
    CharacteristicsSetType^ get ();
    void set (CharacteristicsSetType^ value);
}


DetailsURL Property

DetailsURL Property
Namespaces ► eBay.Service.Core.Soap ► ProductType ► DetailsURL
Declaration Syntax
C# Visual Basic Visual C++
public string DetailsURL { get; set; }
Public Property DetailsURL As String
    Get
    Set
public:
property String^ DetailsURL {
    String^ get ();
    void set (String^ value);
}


MaxPrice Property

MaxPrice Property
Namespaces ► eBay.Service.Core.Soap ► ProductType ► MaxPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MaxPrice { get; set; }
Public Property MaxPrice As AmountType
    Get
    Set
public:
property AmountType^ MaxPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


MinPrice Property

MinPrice Property
Namespaces ► eBay.Service.Core.Soap ► ProductType ► MinPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MinPrice { get; set; }
Public Property MinPrice As AmountType
    Get
    Set
public:
property AmountType^ MinPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


NumItems Property

NumItems Property
Namespaces ► eBay.Service.Core.Soap ► ProductType ► NumItems
Declaration Syntax
C# Visual Basic Visual C++
public int NumItems { get; set; }
Public Property NumItems As Integer
    Get
    Set
public:
property int NumItems {
    int get ();
    void set (int value);
}


NumItemsSpecified Property

NumItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ProductType ► NumItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NumItemsSpecified { get; set; }
Public Property NumItemsSpecified As Boolean
    Get
    Set
public:
property bool NumItemsSpecified {
    bool get ();
    void set (bool value);
}


productID Property

productID Property
Namespaces ► eBay.Service.Core.Soap ► ProductType ► productID
Declaration Syntax
C# Visual Basic Visual C++
public string productID { get; set; }
Public Property productID As String
    Get
    Set
public:
property String^ productID {
    String^ get ();
    void set (String^ value);
}


ProductReferenceID Property

ProductReferenceID Property
Namespaces ► eBay.Service.Core.Soap ► ProductType ► ProductReferenceID
Declaration Syntax
C# Visual Basic Visual C++
public string ProductReferenceID { get; set; }
Public Property ProductReferenceID As String
    Get
    Set
public:
property String^ ProductReferenceID {
    String^ get ();
    void set (String^ value);
}


ProductType Constructor

ProductType Constructor
Namespaces ► eBay.Service.Core.Soap ► ProductType ► ProductType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProductType()
Public Sub New
public:
ProductType()


stockPhotoURL Property

stockPhotoURL Property
Namespaces ► eBay.Service.Core.Soap ► ProductType ► stockPhotoURL
Declaration Syntax
C# Visual Basic Visual C++
public string stockPhotoURL { get; set; }
Public Property stockPhotoURL As String
    Get
    Set
public:
property String^ stockPhotoURL {
    String^ get ();
    void set (String^ value);
}


title Property

title Property
Namespaces ► eBay.Service.Core.Soap ► ProductType ► title
Declaration Syntax
C# Visual Basic Visual C++
public string title { get; set; }
Public Property title As String
    Get
    Set
public:
property String^ title {
    String^ get ();
    void set (String^ value);
}


ProductTypeCollection Class

ProductTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ProductTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ProductTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ProductTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProductTypeCollection()()()() |
 | ProductTypeCollection(array<ProductType>[]()[][]) |
 | ProductTypeCollection(ProductTypeCollection) |
 | Add(ProductType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ProductType>[]()[][]) |
 | AddRange(ProductTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ProductType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ProductType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ProductType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ProductType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ProductType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ProductTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► Add(ProductType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ProductType item
)
Public Function Add ( _
    item As ProductType _
) As Integer
public:
int Add(
    ProductType^ item
)
Parameters
item (ProductType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ProductType>[]()[][]) |
 | AddRange(ProductTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► AddRange(array<ProductType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ProductType[] items
)
Public Sub AddRange ( _
    items As ProductType() _
)
public:
void AddRange(
    array<ProductType^>^ items
)
Parameters
items (array< ProductType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► AddRange(ProductTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ProductTypeCollection items
)
Public Sub AddRange ( _
    items As ProductTypeCollection _
)
public:
void AddRange(
    ProductTypeCollection^ items
)
Parameters
items (ProductTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► Contains(ProductType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ProductType item
)
Public Function Contains ( _
    item As ProductType _
) As Boolean
public:
bool Contains(
    ProductType^ item
)
Parameters
item (ProductType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► CopyTo(array<ProductType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ProductType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ProductType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ProductType^>^ items,
    int index
)
Parameters
items (array< ProductType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► IndexOf(ProductType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ProductType item
)
Public Function IndexOf ( _
    item As ProductType _
) As Integer
public:
int IndexOf(
    ProductType^ item
)
Parameters
item (ProductType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► Insert(Int32, ProductType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ProductType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ProductType _
)
public:
void Insert(
    int index,
    ProductType^ item
)
Parameters
index (Int32)
item (ProductType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ProductType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ProductType
    Get
    Set
public:
property ProductType^ default[int index] {
    ProductType^ get (int index);
    void set (int index, ProductType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ProductType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ProductType
public:
ProductType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ProductTypeCollection Constructor

ProductTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► ProductTypeCollection()()()()
Members
Icon | Member | Description
 | ProductTypeCollection()()()() |
 | ProductTypeCollection(array<ProductType>[]()[][]) |
 | ProductTypeCollection(ProductTypeCollection) |


ProductTypeCollection Constructor

ProductTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► ProductTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProductTypeCollection()
Public Sub New
public:
ProductTypeCollection()


ProductTypeCollection Constructor (items)

ProductTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► ProductTypeCollection(array<ProductType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ProductTypeCollection(
    ProductType[] items
)
Public Sub New ( _
    items As ProductType() _
)
public:
ProductTypeCollection(
    array<ProductType^>^ items
)
Parameters
items (array< ProductType >[]()[][])


ProductTypeCollection Constructor (items)

ProductTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► ProductTypeCollection(ProductTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ProductTypeCollection(
    ProductTypeCollection items
)
Public Sub New ( _
    items As ProductTypeCollection _
)
public:
ProductTypeCollection(
    ProductTypeCollection^ items
)
Parameters
items (ProductTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► Remove(ProductType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ProductType item
)
Public Sub Remove ( _
    item As ProductType _
)
public:
void Remove(
    ProductType^ item
)
Parameters
item (ProductType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProductType[] ToArray()
Public Function ToArray As ProductType()
public:
array<ProductType^>^ ToArray()
Return Value


ProductUseCaseCodeType Enumeration

ProductUseCaseCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ProductUseCaseCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ProductUseCaseCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ProductUseCaseCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ProductUseCaseCodeType
Members
Member | Description
AddItem |
ReviseItem |
RelistItem |
CustomCode |
Remarks


ProfileCategoryGroupCodeType Enumeration

ProfileCategoryGroupCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ProfileCategoryGroupCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ProfileCategoryGroupCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ProfileCategoryGroupCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ProfileCategoryGroupCodeType
Members
Member | Description
Inherit |
None |
ALL |
MOTORS_VEHICLE |
Remarks


ProfileCategoryGroupDefinitionType Class

ProfileCategoryGroupDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ProfileCategoryGroupDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ProfileCategoryGroupDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ProfileCategoryGroupDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ProfileCategoryGroupDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileCategoryGroupDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ProfileCategoryGroupDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ProfileCategoryGroupDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ProfileCategoryGroupDefinitionType Constructor

ProfileCategoryGroupDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ProfileCategoryGroupDefinitionType ► ProfileCategoryGroupDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProfileCategoryGroupDefinitionType()
Public Sub New
public:
ProfileCategoryGroupDefinitionType()


PromotedItemType Class

PromotedItemType Class
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PromotedItemType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PromotedItemType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PromotedItemType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromotedItemType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | ListingType |
 | ListingTypeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PictureURL |
 | Position |
 | PositionSpecified |
 | PromotionDetails |
 | SelectionType |
 | SelectionTypeSpecified |
 | TimeLeft |
 | Title |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PromotedItemType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingType Property

ListingType Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► ListingType
Declaration Syntax
C# Visual Basic Visual C++
public ListingTypeCodeType ListingType { get; set; }
Public Property ListingType As ListingTypeCodeType
    Get
    Set
public:
property ListingTypeCodeType ListingType {
    ListingTypeCodeType get ();
    void set (ListingTypeCodeType value);
}


ListingTypeSpecified Property

ListingTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► ListingTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingTypeSpecified { get; set; }
Public Property ListingTypeSpecified As Boolean
    Get
    Set
public:
property bool ListingTypeSpecified {
    bool get ();
    void set (bool value);
}


PictureURL Property

PictureURL Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► PictureURL
Declaration Syntax
C# Visual Basic Visual C++
public string PictureURL { get; set; }
Public Property PictureURL As String
    Get
    Set
public:
property String^ PictureURL {
    String^ get ();
    void set (String^ value);
}


Position Property

Position Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► Position
Declaration Syntax
C# Visual Basic Visual C++
public int Position { get; set; }
Public Property Position As Integer
    Get
    Set
public:
property int Position {
    int get ();
    void set (int value);
}


PositionSpecified Property

PositionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► PositionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PositionSpecified { get; set; }
Public Property PositionSpecified As Boolean
    Get
    Set
public:
property bool PositionSpecified {
    bool get ();
    void set (bool value);
}


PromotedItemType Constructor

PromotedItemType Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► PromotedItemType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotedItemType()
Public Sub New
public:
PromotedItemType()


PromotionDetails Property

PromotionDetails Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► PromotionDetails
Declaration Syntax
C# Visual Basic Visual C++
public PromotionDetailsTypeCollection PromotionDetails { get; set; }
Public Property PromotionDetails As PromotionDetailsTypeCollection
    Get
    Set
public:
property PromotionDetailsTypeCollection^ PromotionDetails {
    PromotionDetailsTypeCollection^ get ();
    void set (PromotionDetailsTypeCollection^ value);
}


SelectionType Property

SelectionType Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► SelectionType
Declaration Syntax
C# Visual Basic Visual C++
public PromotionItemSelectionCodeType SelectionType { get; set; }
Public Property SelectionType As PromotionItemSelectionCodeType
    Get
    Set
public:
property PromotionItemSelectionCodeType SelectionType {
    PromotionItemSelectionCodeType get ();
    void set (PromotionItemSelectionCodeType value);
}


SelectionTypeSpecified Property

SelectionTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► SelectionTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SelectionTypeSpecified { get; set; }
Public Property SelectionTypeSpecified As Boolean
    Get
    Set
public:
property bool SelectionTypeSpecified {
    bool get ();
    void set (bool value);
}


TimeLeft Property

TimeLeft Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► TimeLeft
Declaration Syntax
C# Visual Basic Visual C++
public string TimeLeft { get; set; }
Public Property TimeLeft As String
    Get
    Set
public:
property String^ TimeLeft {
    String^ get ();
    void set (String^ value);
}


Title Property

Title Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemType ► Title
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}


PromotedItemTypeCollection Class

PromotedItemTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PromotedItemTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PromotedItemTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PromotedItemTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromotedItemTypeCollection()()()() |
 | PromotedItemTypeCollection(array<PromotedItemType>[]()[][]) |
 | PromotedItemTypeCollection(PromotedItemTypeCollection) |
 | Add(PromotedItemType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PromotedItemType>[]()[][]) |
 | AddRange(PromotedItemTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PromotedItemType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PromotedItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PromotedItemType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PromotedItemType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PromotedItemType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PromotedItemTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► Add(PromotedItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PromotedItemType item
)
Public Function Add ( _
    item As PromotedItemType _
) As Integer
public:
int Add(
    PromotedItemType^ item
)
Parameters
item (PromotedItemType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PromotedItemType>[]()[][]) |
 | AddRange(PromotedItemTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► AddRange(array<PromotedItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PromotedItemType[] items
)
Public Sub AddRange ( _
    items As PromotedItemType() _
)
public:
void AddRange(
    array<PromotedItemType^>^ items
)
Parameters
items (array< PromotedItemType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► AddRange(PromotedItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PromotedItemTypeCollection items
)
Public Sub AddRange ( _
    items As PromotedItemTypeCollection _
)
public:
void AddRange(
    PromotedItemTypeCollection^ items
)
Parameters
items (PromotedItemTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► Contains(PromotedItemType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PromotedItemType item
)
Public Function Contains ( _
    item As PromotedItemType _
) As Boolean
public:
bool Contains(
    PromotedItemType^ item
)
Parameters
item (PromotedItemType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► CopyTo(array<PromotedItemType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PromotedItemType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PromotedItemType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PromotedItemType^>^ items,
    int index
)
Parameters
items (array< PromotedItemType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► IndexOf(PromotedItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PromotedItemType item
)
Public Function IndexOf ( _
    item As PromotedItemType _
) As Integer
public:
int IndexOf(
    PromotedItemType^ item
)
Parameters
item (PromotedItemType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► Insert(Int32, PromotedItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PromotedItemType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PromotedItemType _
)
public:
void Insert(
    int index,
    PromotedItemType^ item
)
Parameters
index (Int32)
item (PromotedItemType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PromotedItemType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PromotedItemType
    Get
    Set
public:
property PromotedItemType^ default[int index] {
    PromotedItemType^ get (int index);
    void set (int index, PromotedItemType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PromotedItemType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PromotedItemType
public:
PromotedItemType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PromotedItemTypeCollection Constructor

PromotedItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► PromotedItemTypeCollection()()()()
Members
Icon | Member | Description
 | PromotedItemTypeCollection()()()() |
 | PromotedItemTypeCollection(array<PromotedItemType>[]()[][]) |
 | PromotedItemTypeCollection(PromotedItemTypeCollection) |


PromotedItemTypeCollection Constructor

PromotedItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► PromotedItemTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotedItemTypeCollection()
Public Sub New
public:
PromotedItemTypeCollection()


PromotedItemTypeCollection Constructor (items)

PromotedItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► PromotedItemTypeCollection(array<PromotedItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PromotedItemTypeCollection(
    PromotedItemType[] items
)
Public Sub New ( _
    items As PromotedItemType() _
)
public:
PromotedItemTypeCollection(
    array<PromotedItemType^>^ items
)
Parameters
items (array< PromotedItemType >[]()[][])


PromotedItemTypeCollection Constructor (items)

PromotedItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► PromotedItemTypeCollection(PromotedItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PromotedItemTypeCollection(
    PromotedItemTypeCollection items
)
Public Sub New ( _
    items As PromotedItemTypeCollection _
)
public:
PromotedItemTypeCollection(
    PromotedItemTypeCollection^ items
)
Parameters
items (PromotedItemTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► Remove(PromotedItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PromotedItemType item
)
Public Sub Remove ( _
    item As PromotedItemType _
)
public:
void Remove(
    PromotedItemType^ item
)
Parameters
item (PromotedItemType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotedItemType[] ToArray()
Public Function ToArray As PromotedItemType()
public:
array<PromotedItemType^>^ ToArray()
Return Value


PromotionalSaleDetailsType Class

PromotionalSaleDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PromotionalSaleDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PromotionalSaleDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PromotionalSaleDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromotionalSaleDetailsType()()()() |
 | Any |
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OriginalPrice |
 | StartTime |
 | StartTimeSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PromotionalSaleDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleDetailsType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleDetailsType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


OriginalPrice Property

OriginalPrice Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleDetailsType ► OriginalPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType OriginalPrice { get; set; }
Public Property OriginalPrice As AmountType
    Get
    Set
public:
property AmountType^ OriginalPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


PromotionalSaleDetailsType Constructor

PromotionalSaleDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleDetailsType ► PromotionalSaleDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleDetailsType()
Public Sub New
public:
PromotionalSaleDetailsType()


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleDetailsType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleDetailsType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


PromotionalSaleStatusCodeType Enumeration

PromotionalSaleStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PromotionalSaleStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PromotionalSaleStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PromotionalSaleStatusCodeType
Members
Member | Description
Active |
Scheduled |
Processing |
Inactive |
Deleted |
CustomCode |
Remarks


PromotionalSaleStatusCodeTypeCollection Class

PromotionalSaleStatusCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PromotionalSaleStatusCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PromotionalSaleStatusCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PromotionalSaleStatusCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromotionalSaleStatusCodeTypeCollection()()()() |
 | PromotionalSaleStatusCodeTypeCollection(array<PromotionalSaleStatusCodeType>[]()[][]) |
 | PromotionalSaleStatusCodeTypeCollection(PromotionalSaleStatusCodeTypeCollection) |
 | Add(PromotionalSaleStatusCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PromotionalSaleStatusCodeType>[]()[][]) |
 | AddRange(PromotionalSaleStatusCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PromotionalSaleStatusCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PromotionalSaleStatusCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PromotionalSaleStatusCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PromotionalSaleStatusCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PromotionalSaleStatusCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PromotionalSaleStatusCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► Add(PromotionalSaleStatusCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PromotionalSaleStatusCodeType item
)
Public Function Add ( _
    item As PromotionalSaleStatusCodeType _
) As Integer
public:
int Add(
    PromotionalSaleStatusCodeType item
)
Parameters
item (PromotionalSaleStatusCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PromotionalSaleStatusCodeType>[]()[][]) |
 | AddRange(PromotionalSaleStatusCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► AddRange(array<PromotionalSaleStatusCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PromotionalSaleStatusCodeType[] items
)
Public Sub AddRange ( _
    items As PromotionalSaleStatusCodeType() _
)
public:
void AddRange(
    array<PromotionalSaleStatusCodeType>^ items
)
Parameters
items (array< PromotionalSaleStatusCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► AddRange(PromotionalSaleStatusCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PromotionalSaleStatusCodeTypeCollection items
)
Public Sub AddRange ( _
    items As PromotionalSaleStatusCodeTypeCollection _
)
public:
void AddRange(
    PromotionalSaleStatusCodeTypeCollection^ items
)
Parameters
items (PromotionalSaleStatusCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► Contains(PromotionalSaleStatusCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PromotionalSaleStatusCodeType item
)
Public Function Contains ( _
    item As PromotionalSaleStatusCodeType _
) As Boolean
public:
bool Contains(
    PromotionalSaleStatusCodeType item
)
Parameters
item (PromotionalSaleStatusCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► CopyTo(array<PromotionalSaleStatusCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PromotionalSaleStatusCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PromotionalSaleStatusCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PromotionalSaleStatusCodeType>^ items,
    int index
)
Parameters
items (array< PromotionalSaleStatusCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► IndexOf(PromotionalSaleStatusCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PromotionalSaleStatusCodeType item
)
Public Function IndexOf ( _
    item As PromotionalSaleStatusCodeType _
) As Integer
public:
int IndexOf(
    PromotionalSaleStatusCodeType item
)
Parameters
item (PromotionalSaleStatusCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► Insert(Int32, PromotionalSaleStatusCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PromotionalSaleStatusCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PromotionalSaleStatusCodeType _
)
public:
void Insert(
    int index,
    PromotionalSaleStatusCodeType item
)
Parameters
index (Int32)
item (PromotionalSaleStatusCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PromotionalSaleStatusCodeType
    Get
    Set
public:
property PromotionalSaleStatusCodeType default[int index] {
    PromotionalSaleStatusCodeType get (int index);
    void set (int index, PromotionalSaleStatusCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PromotionalSaleStatusCodeType
public:
PromotionalSaleStatusCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PromotionalSaleStatusCodeTypeCollection Constructor

PromotionalSaleStatusCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► PromotionalSaleStatusCodeTypeCollection()()()()
Members
Icon | Member | Description
 | PromotionalSaleStatusCodeTypeCollection()()()() |
 | PromotionalSaleStatusCodeTypeCollection(array<PromotionalSaleStatusCodeType>[]()[][]) |
 | PromotionalSaleStatusCodeTypeCollection(PromotionalSaleStatusCodeTypeCollection) |


PromotionalSaleStatusCodeTypeCollection Constructor

PromotionalSaleStatusCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► PromotionalSaleStatusCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeTypeCollection()
Public Sub New
public:
PromotionalSaleStatusCodeTypeCollection()


PromotionalSaleStatusCodeTypeCollection Constructor (items)

PromotionalSaleStatusCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► PromotionalSaleStatusCodeTypeCollection(array<PromotionalSaleStatusCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeTypeCollection(
    PromotionalSaleStatusCodeType[] items
)
Public Sub New ( _
    items As PromotionalSaleStatusCodeType() _
)
public:
PromotionalSaleStatusCodeTypeCollection(
    array<PromotionalSaleStatusCodeType>^ items
)
Parameters
items (array< PromotionalSaleStatusCodeType >[]()[][])


PromotionalSaleStatusCodeTypeCollection Constructor (items)

PromotionalSaleStatusCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► PromotionalSaleStatusCodeTypeCollection(PromotionalSaleStatusCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeTypeCollection(
    PromotionalSaleStatusCodeTypeCollection items
)
Public Sub New ( _
    items As PromotionalSaleStatusCodeTypeCollection _
)
public:
PromotionalSaleStatusCodeTypeCollection(
    PromotionalSaleStatusCodeTypeCollection^ items
)
Parameters
items (PromotionalSaleStatusCodeTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► Remove(PromotionalSaleStatusCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PromotionalSaleStatusCodeType item
)
Public Sub Remove ( _
    item As PromotionalSaleStatusCodeType _
)
public:
void Remove(
    PromotionalSaleStatusCodeType item
)
Parameters
item (PromotionalSaleStatusCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeType[] ToArray()
Public Function ToArray As PromotionalSaleStatusCodeType()
public:
array<PromotionalSaleStatusCodeType>^ ToArray()
Return Value


PromotionalSaleType Class

PromotionalSaleType Class
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PromotionalSaleType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PromotionalSaleType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PromotionalSaleType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromotionalSaleType()()()() |
 | Any |
 | DiscountType |
 | DiscountTypeSpecified |
 | DiscountValue |
 | DiscountValueSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PromotionalSaleEndTime |
 | PromotionalSaleEndTimeSpecified |
 | PromotionalSaleID |
 | PromotionalSaleIDSpecified |
 | PromotionalSaleItemIDArray |
 | PromotionalSaleName |
 | PromotionalSaleStartTime |
 | PromotionalSaleStartTimeSpecified |
 | PromotionalSaleType1 |
 | PromotionalSaleType1Specified |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PromotionalSaleType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DiscountType Property

DiscountType Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► DiscountType
Declaration Syntax
C# Visual Basic Visual C++
public DiscountCodeType DiscountType { get; set; }
Public Property DiscountType As DiscountCodeType
    Get
    Set
public:
property DiscountCodeType DiscountType {
    DiscountCodeType get ();
    void set (DiscountCodeType value);
}


DiscountTypeSpecified Property

DiscountTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► DiscountTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DiscountTypeSpecified { get; set; }
Public Property DiscountTypeSpecified As Boolean
    Get
    Set
public:
property bool DiscountTypeSpecified {
    bool get ();
    void set (bool value);
}


DiscountValue Property

DiscountValue Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► DiscountValue
Declaration Syntax
C# Visual Basic Visual C++
public double DiscountValue { get; set; }
Public Property DiscountValue As Double
    Get
    Set
public:
property double DiscountValue {
    double get ();
    void set (double value);
}


DiscountValueSpecified Property

DiscountValueSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► DiscountValueSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DiscountValueSpecified { get; set; }
Public Property DiscountValueSpecified As Boolean
    Get
    Set
public:
property bool DiscountValueSpecified {
    bool get ();
    void set (bool value);
}


PromotionalSaleEndTime Property

PromotionalSaleEndTime Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► PromotionalSaleEndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PromotionalSaleEndTime { get; set; }
Public Property PromotionalSaleEndTime As DateTime
    Get
    Set
public:
property DateTime PromotionalSaleEndTime {
    DateTime get ();
    void set (DateTime value);
}


PromotionalSaleEndTimeSpecified Property

PromotionalSaleEndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► PromotionalSaleEndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalSaleEndTimeSpecified { get; set; }
Public Property PromotionalSaleEndTimeSpecified As Boolean
    Get
    Set
public:
property bool PromotionalSaleEndTimeSpecified {
    bool get ();
    void set (bool value);
}


PromotionalSaleID Property

PromotionalSaleID Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► PromotionalSaleID
Declaration Syntax
C# Visual Basic Visual C++
public long PromotionalSaleID { get; set; }
Public Property PromotionalSaleID As Long
    Get
    Set
public:
property long long PromotionalSaleID {
    long long get ();
    void set (long long value);
}


PromotionalSaleIDSpecified Property

PromotionalSaleIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► PromotionalSaleIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalSaleIDSpecified { get; set; }
Public Property PromotionalSaleIDSpecified As Boolean
    Get
    Set
public:
property bool PromotionalSaleIDSpecified {
    bool get ();
    void set (bool value);
}


PromotionalSaleItemIDArray Property

PromotionalSaleItemIDArray Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► PromotionalSaleItemIDArray
Declaration Syntax
C# Visual Basic Visual C++
public ItemIDArrayType PromotionalSaleItemIDArray { get; set; }
Public Property PromotionalSaleItemIDArray As ItemIDArrayType
    Get
    Set
public:
property ItemIDArrayType^ PromotionalSaleItemIDArray {
    ItemIDArrayType^ get ();
    void set (ItemIDArrayType^ value);
}


PromotionalSaleName Property

PromotionalSaleName Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► PromotionalSaleName
Declaration Syntax
C# Visual Basic Visual C++
public string PromotionalSaleName { get; set; }
Public Property PromotionalSaleName As String
    Get
    Set
public:
property String^ PromotionalSaleName {
    String^ get ();
    void set (String^ value);
}


PromotionalSaleStartTime Property

PromotionalSaleStartTime Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► PromotionalSaleStartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PromotionalSaleStartTime { get; set; }
Public Property PromotionalSaleStartTime As DateTime
    Get
    Set
public:
property DateTime PromotionalSaleStartTime {
    DateTime get ();
    void set (DateTime value);
}


PromotionalSaleStartTimeSpecified Property

PromotionalSaleStartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► PromotionalSaleStartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalSaleStartTimeSpecified { get; set; }
Public Property PromotionalSaleStartTimeSpecified As Boolean
    Get
    Set
public:
property bool PromotionalSaleStartTimeSpecified {
    bool get ();
    void set (bool value);
}


PromotionalSaleType Constructor

PromotionalSaleType Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► PromotionalSaleType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleType()
Public Sub New
public:
PromotionalSaleType()


PromotionalSaleType1 Property

PromotionalSaleType1 Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► PromotionalSaleType1
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleTypeCodeType PromotionalSaleType1 { get; set; }
Public Property PromotionalSaleType1 As PromotionalSaleTypeCodeType
    Get
    Set
public:
property PromotionalSaleTypeCodeType PromotionalSaleType1 {
    PromotionalSaleTypeCodeType get ();
    void set (PromotionalSaleTypeCodeType value);
}


PromotionalSaleType1Specified Property

PromotionalSaleType1Specified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► PromotionalSaleType1Specified
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalSaleType1Specified { get; set; }
Public Property PromotionalSaleType1Specified As Boolean
    Get
    Set
public:
property bool PromotionalSaleType1Specified {
    bool get ();
    void set (bool value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeType Status { get; set; }
Public Property Status As PromotionalSaleStatusCodeType
    Get
    Set
public:
property PromotionalSaleStatusCodeType Status {
    PromotionalSaleStatusCodeType get ();
    void set (PromotionalSaleStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


PromotionalSaleTypeCodeType Enumeration

PromotionalSaleTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PromotionalSaleTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PromotionalSaleTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PromotionalSaleTypeCodeType
Members
Member | Description
PriceDiscountOnly |
FreeShippingOnly |
PriceDiscountAndFreeShipping |
CustomCode |
Remarks


PromotionalSaleTypeCollection Class

PromotionalSaleTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PromotionalSaleTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PromotionalSaleTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PromotionalSaleTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromotionalSaleTypeCollection()()()() |
 | PromotionalSaleTypeCollection(array<PromotionalSaleType>[]()[][]) |
 | PromotionalSaleTypeCollection(PromotionalSaleTypeCollection) |
 | Add(PromotionalSaleType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PromotionalSaleType>[]()[][]) |
 | AddRange(PromotionalSaleTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PromotionalSaleType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PromotionalSaleType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PromotionalSaleType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PromotionalSaleType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PromotionalSaleType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PromotionalSaleTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► Add(PromotionalSaleType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PromotionalSaleType item
)
Public Function Add ( _
    item As PromotionalSaleType _
) As Integer
public:
int Add(
    PromotionalSaleType^ item
)
Parameters
item (PromotionalSaleType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PromotionalSaleType>[]()[][]) |
 | AddRange(PromotionalSaleTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► AddRange(array<PromotionalSaleType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PromotionalSaleType[] items
)
Public Sub AddRange ( _
    items As PromotionalSaleType() _
)
public:
void AddRange(
    array<PromotionalSaleType^>^ items
)
Parameters
items (array< PromotionalSaleType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► AddRange(PromotionalSaleTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PromotionalSaleTypeCollection items
)
Public Sub AddRange ( _
    items As PromotionalSaleTypeCollection _
)
public:
void AddRange(
    PromotionalSaleTypeCollection^ items
)
Parameters
items (PromotionalSaleTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► Contains(PromotionalSaleType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PromotionalSaleType item
)
Public Function Contains ( _
    item As PromotionalSaleType _
) As Boolean
public:
bool Contains(
    PromotionalSaleType^ item
)
Parameters
item (PromotionalSaleType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► CopyTo(array<PromotionalSaleType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PromotionalSaleType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PromotionalSaleType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PromotionalSaleType^>^ items,
    int index
)
Parameters
items (array< PromotionalSaleType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► IndexOf(PromotionalSaleType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PromotionalSaleType item
)
Public Function IndexOf ( _
    item As PromotionalSaleType _
) As Integer
public:
int IndexOf(
    PromotionalSaleType^ item
)
Parameters
item (PromotionalSaleType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► Insert(Int32, PromotionalSaleType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PromotionalSaleType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PromotionalSaleType _
)
public:
void Insert(
    int index,
    PromotionalSaleType^ item
)
Parameters
index (Int32)
item (PromotionalSaleType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PromotionalSaleType
    Get
    Set
public:
property PromotionalSaleType^ default[int index] {
    PromotionalSaleType^ get (int index);
    void set (int index, PromotionalSaleType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PromotionalSaleType
public:
PromotionalSaleType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PromotionalSaleTypeCollection Constructor

PromotionalSaleTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► PromotionalSaleTypeCollection()()()()
Members
Icon | Member | Description
 | PromotionalSaleTypeCollection()()()() |
 | PromotionalSaleTypeCollection(array<PromotionalSaleType>[]()[][]) |
 | PromotionalSaleTypeCollection(PromotionalSaleTypeCollection) |


PromotionalSaleTypeCollection Constructor

PromotionalSaleTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► PromotionalSaleTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleTypeCollection()
Public Sub New
public:
PromotionalSaleTypeCollection()


PromotionalSaleTypeCollection Constructor (items)

PromotionalSaleTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► PromotionalSaleTypeCollection(array<PromotionalSaleType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleTypeCollection(
    PromotionalSaleType[] items
)
Public Sub New ( _
    items As PromotionalSaleType() _
)
public:
PromotionalSaleTypeCollection(
    array<PromotionalSaleType^>^ items
)
Parameters
items (array< PromotionalSaleType >[]()[][])


PromotionalSaleTypeCollection Constructor (items)

PromotionalSaleTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► PromotionalSaleTypeCollection(PromotionalSaleTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleTypeCollection(
    PromotionalSaleTypeCollection items
)
Public Sub New ( _
    items As PromotionalSaleTypeCollection _
)
public:
PromotionalSaleTypeCollection(
    PromotionalSaleTypeCollection^ items
)
Parameters
items (PromotionalSaleTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► Remove(PromotionalSaleType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PromotionalSaleType item
)
Public Sub Remove ( _
    item As PromotionalSaleType _
)
public:
void Remove(
    PromotionalSaleType^ item
)
Parameters
item (PromotionalSaleType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleType[] ToArray()
Public Function ToArray As PromotionalSaleType()
public:
array<PromotionalSaleType^>^ ToArray()
Return Value


PromotionalShippingDiscountDetailsType Class

PromotionalShippingDiscountDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► PromotionalShippingDiscountDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PromotionalShippingDiscountDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PromotionalShippingDiscountDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PromotionalShippingDiscountDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromotionalShippingDiscountDetailsType()()()() |
 | Any |
 | DiscountName |
 | DiscountNameSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemCount |
 | ItemCountSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderAmount |
 | ShippingCost |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PromotionalShippingDiscountDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalShippingDiscountDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DiscountName Property

DiscountName Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalShippingDiscountDetailsType ► DiscountName
Declaration Syntax
C# Visual Basic Visual C++
public DiscountNameCodeType DiscountName { get; set; }
Public Property DiscountName As DiscountNameCodeType
    Get
    Set
public:
property DiscountNameCodeType DiscountName {
    DiscountNameCodeType get ();
    void set (DiscountNameCodeType value);
}


DiscountNameSpecified Property

DiscountNameSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalShippingDiscountDetailsType ► DiscountNameSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DiscountNameSpecified { get; set; }
Public Property DiscountNameSpecified As Boolean
    Get
    Set
public:
property bool DiscountNameSpecified {
    bool get ();
    void set (bool value);
}


ItemCount Property

ItemCount Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalShippingDiscountDetailsType ► ItemCount
Declaration Syntax
C# Visual Basic Visual C++
public int ItemCount { get; set; }
Public Property ItemCount As Integer
    Get
    Set
public:
property int ItemCount {
    int get ();
    void set (int value);
}


ItemCountSpecified Property

ItemCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalShippingDiscountDetailsType ► ItemCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemCountSpecified { get; set; }
Public Property ItemCountSpecified As Boolean
    Get
    Set
public:
property bool ItemCountSpecified {
    bool get ();
    void set (bool value);
}


OrderAmount Property

OrderAmount Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalShippingDiscountDetailsType ► OrderAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType OrderAmount { get; set; }
Public Property OrderAmount As AmountType
    Get
    Set
public:
property AmountType^ OrderAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


PromotionalShippingDiscountDetailsType Constructor

PromotionalShippingDiscountDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotionalShippingDiscountDetailsType ► PromotionalShippingDiscountDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalShippingDiscountDetailsType()
Public Sub New
public:
PromotionalShippingDiscountDetailsType()


ShippingCost Property

ShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalShippingDiscountDetailsType ► ShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingCost { get; set; }
Public Property ShippingCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


PromotionDetailsType Class

PromotionDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PromotionDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PromotionDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PromotionDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromotionDetailsType()()()() |
 | Any |
 | BidCount |
 | BidCountSpecified |
 | ConvertedPromotionPrice |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PromotionPrice |
 | PromotionPriceType |
 | PromotionPriceTypeSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PromotionDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidCount Property

BidCount Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsType ► BidCount
Declaration Syntax
C# Visual Basic Visual C++
public int BidCount { get; set; }
Public Property BidCount As Integer
    Get
    Set
public:
property int BidCount {
    int get ();
    void set (int value);
}


BidCountSpecified Property

BidCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsType ► BidCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidCountSpecified { get; set; }
Public Property BidCountSpecified As Boolean
    Get
    Set
public:
property bool BidCountSpecified {
    bool get ();
    void set (bool value);
}


ConvertedPromotionPrice Property

ConvertedPromotionPrice Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsType ► ConvertedPromotionPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ConvertedPromotionPrice { get; set; }
Public Property ConvertedPromotionPrice As AmountType
    Get
    Set
public:
property AmountType^ ConvertedPromotionPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


PromotionDetailsType Constructor

PromotionDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsType ► PromotionDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotionDetailsType()
Public Sub New
public:
PromotionDetailsType()


PromotionPrice Property

PromotionPrice Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsType ► PromotionPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType PromotionPrice { get; set; }
Public Property PromotionPrice As AmountType
    Get
    Set
public:
property AmountType^ PromotionPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


PromotionPriceType Property

PromotionPriceType Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsType ► PromotionPriceType
Declaration Syntax
C# Visual Basic Visual C++
public PromotionItemPriceTypeCodeType PromotionPriceType { get; set; }
Public Property PromotionPriceType As PromotionItemPriceTypeCodeType
    Get
    Set
public:
property PromotionItemPriceTypeCodeType PromotionPriceType {
    PromotionItemPriceTypeCodeType get ();
    void set (PromotionItemPriceTypeCodeType value);
}


PromotionPriceTypeSpecified Property

PromotionPriceTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsType ► PromotionPriceTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionPriceTypeSpecified { get; set; }
Public Property PromotionPriceTypeSpecified As Boolean
    Get
    Set
public:
property bool PromotionPriceTypeSpecified {
    bool get ();
    void set (bool value);
}


PromotionDetailsTypeCollection Class

PromotionDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class PromotionDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class PromotionDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class PromotionDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PromotionDetailsTypeCollection()()()() |
 | PromotionDetailsTypeCollection(array<PromotionDetailsType>[]()[][]) |
 | PromotionDetailsTypeCollection(PromotionDetailsTypeCollection) |
 | Add(PromotionDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<PromotionDetailsType>[]()[][]) |
 | AddRange(PromotionDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(PromotionDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<PromotionDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(PromotionDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, PromotionDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(PromotionDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | PromotionDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► Add(PromotionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PromotionDetailsType item
)
Public Function Add ( _
    item As PromotionDetailsType _
) As Integer
public:
int Add(
    PromotionDetailsType^ item
)
Parameters
item (PromotionDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<PromotionDetailsType>[]()[][]) |
 | AddRange(PromotionDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► AddRange(array<PromotionDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PromotionDetailsType[] items
)
Public Sub AddRange ( _
    items As PromotionDetailsType() _
)
public:
void AddRange(
    array<PromotionDetailsType^>^ items
)
Parameters
items (array< PromotionDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► AddRange(PromotionDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    PromotionDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As PromotionDetailsTypeCollection _
)
public:
void AddRange(
    PromotionDetailsTypeCollection^ items
)
Parameters
items (PromotionDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► Contains(PromotionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    PromotionDetailsType item
)
Public Function Contains ( _
    item As PromotionDetailsType _
) As Boolean
public:
bool Contains(
    PromotionDetailsType^ item
)
Parameters
item (PromotionDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► CopyTo(array<PromotionDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    PromotionDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As PromotionDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<PromotionDetailsType^>^ items,
    int index
)
Parameters
items (array< PromotionDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► IndexOf(PromotionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    PromotionDetailsType item
)
Public Function IndexOf ( _
    item As PromotionDetailsType _
) As Integer
public:
int IndexOf(
    PromotionDetailsType^ item
)
Parameters
item (PromotionDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► Insert(Int32, PromotionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PromotionDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As PromotionDetailsType _
)
public:
void Insert(
    int index,
    PromotionDetailsType^ item
)
Parameters
index (Int32)
item (PromotionDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public PromotionDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As PromotionDetailsType
    Get
    Set
public:
property PromotionDetailsType^ default[int index] {
    PromotionDetailsType^ get (int index);
    void set (int index, PromotionDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public PromotionDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As PromotionDetailsType
public:
PromotionDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


PromotionDetailsTypeCollection Constructor

PromotionDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► PromotionDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | PromotionDetailsTypeCollection()()()() |
 | PromotionDetailsTypeCollection(array<PromotionDetailsType>[]()[][]) |
 | PromotionDetailsTypeCollection(PromotionDetailsTypeCollection) |


PromotionDetailsTypeCollection Constructor

PromotionDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► PromotionDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotionDetailsTypeCollection()
Public Sub New
public:
PromotionDetailsTypeCollection()


PromotionDetailsTypeCollection Constructor (items)

PromotionDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► PromotionDetailsTypeCollection(array<PromotionDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public PromotionDetailsTypeCollection(
    PromotionDetailsType[] items
)
Public Sub New ( _
    items As PromotionDetailsType() _
)
public:
PromotionDetailsTypeCollection(
    array<PromotionDetailsType^>^ items
)
Parameters
items (array< PromotionDetailsType >[]()[][])


PromotionDetailsTypeCollection Constructor (items)

PromotionDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► PromotionDetailsTypeCollection(PromotionDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public PromotionDetailsTypeCollection(
    PromotionDetailsTypeCollection items
)
Public Sub New ( _
    items As PromotionDetailsTypeCollection _
)
public:
PromotionDetailsTypeCollection(
    PromotionDetailsTypeCollection^ items
)
Parameters
items (PromotionDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► Remove(PromotionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PromotionDetailsType item
)
Public Sub Remove ( _
    item As PromotionDetailsType _
)
public:
void Remove(
    PromotionDetailsType^ item
)
Parameters
item (PromotionDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PromotionDetailsType[] ToArray()
Public Function ToArray As PromotionDetailsType()
public:
array<PromotionDetailsType^>^ ToArray()
Return Value


PromotionItemPriceTypeCodeType Enumeration

PromotionItemPriceTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PromotionItemPriceTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PromotionItemPriceTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PromotionItemPriceTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PromotionItemPriceTypeCodeType
Members
Member | Description
AuctionPrice |
BuyItNowPrice |
BestOfferOnlyPrice |
ClassifiedAdPrice |
CustomCode |
Remarks


PromotionItemSelectionCodeType Enumeration

PromotionItemSelectionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PromotionItemSelectionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PromotionItemSelectionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PromotionItemSelectionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PromotionItemSelectionCodeType
Members
Member | Description
Manual |
Automatic |
CustomCode |
Remarks


PromotionMethodCodeType Enumeration

PromotionMethodCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PromotionMethodCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PromotionMethodCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PromotionMethodCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PromotionMethodCodeType
Members
Member | Description
CrossSell |
UpSell |
CustomCode |
Remarks


PromotionSchemeCodeType Enumeration

PromotionSchemeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► PromotionSchemeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum PromotionSchemeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration PromotionSchemeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class PromotionSchemeCodeType
Members
Member | Description
ItemToItem |
ItemToStoreCat |
StoreToStoreCat |
ItemToDefaultRule |
DefaultRule |
CategoryProximity |
RelatedCategoryRule |
DefaultUpSellLogic |
DefaultCrossSellLogic |
CustomCode |
Remarks


ProPackCodeType Enumeration

ProPackCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ProPackCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ProPackCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ProPackCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ProPackCodeType
Members
Member | Description
Enabled |
Disabled |
PowerSellerOnly |
TopRatedSellerOnly |
CustomCode |
Remarks


ProPackEnabledDefinitionType Class

ProPackEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ProPackEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ProPackEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ProPackEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ProPackEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProPackEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ProPackEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ProPackEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ProPackEnabledDefinitionType Constructor

ProPackEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ProPackEnabledDefinitionType ► ProPackEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProPackEnabledDefinitionType()
Public Sub New
public:
ProPackEnabledDefinitionType()


ProPackPlusEnabledDefinitionType Class

ProPackPlusEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ProPackPlusEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ProPackPlusEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ProPackPlusEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ProPackPlusEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProPackPlusEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ProPackPlusEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ProPackPlusEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ProPackPlusEnabledDefinitionType Constructor

ProPackPlusEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ProPackPlusEnabledDefinitionType ► ProPackPlusEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProPackPlusEnabledDefinitionType()
Public Sub New
public:
ProPackPlusEnabledDefinitionType()


ProStoresCheckoutPreferenceType Class

ProStoresCheckoutPreferenceType Class
Namespaces ► eBay.Service.Core.Soap ► ProStoresCheckoutPreferenceType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ProStoresCheckoutPreferenceType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ProStoresCheckoutPreferenceType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ProStoresCheckoutPreferenceType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProStoresCheckoutPreferenceType()()()() |
 | Any |
 | CheckoutRedirectProStores |
 | CheckoutRedirectProStoresSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProStoresDetails |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ProStoresCheckoutPreferenceType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ProStoresCheckoutPreferenceType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CheckoutRedirectProStores Property

CheckoutRedirectProStores Property
Namespaces ► eBay.Service.Core.Soap ► ProStoresCheckoutPreferenceType ► CheckoutRedirectProStores
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckoutRedirectProStores { get; set; }
Public Property CheckoutRedirectProStores As Boolean
    Get
    Set
public:
property bool CheckoutRedirectProStores {
    bool get ();
    void set (bool value);
}


CheckoutRedirectProStoresSpecified Property

CheckoutRedirectProStoresSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ProStoresCheckoutPreferenceType ► CheckoutRedirectProStoresSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckoutRedirectProStoresSpecified { get; set; }
Public Property CheckoutRedirectProStoresSpecified As Boolean
    Get
    Set
public:
property bool CheckoutRedirectProStoresSpecified {
    bool get ();
    void set (bool value);
}


ProStoresCheckoutPreferenceType Constructor

ProStoresCheckoutPreferenceType Constructor
Namespaces ► eBay.Service.Core.Soap ► ProStoresCheckoutPreferenceType ► ProStoresCheckoutPreferenceType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProStoresCheckoutPreferenceType()
Public Sub New
public:
ProStoresCheckoutPreferenceType()


ProStoresDetails Property

ProStoresDetails Property
Namespaces ► eBay.Service.Core.Soap ► ProStoresCheckoutPreferenceType ► ProStoresDetails
Declaration Syntax
C# Visual Basic Visual C++
public ProStoresDetailsType ProStoresDetails { get; set; }
Public Property ProStoresDetails As ProStoresDetailsType
    Get
    Set
public:
property ProStoresDetailsType^ ProStoresDetails {
    ProStoresDetailsType^ get ();
    void set (ProStoresDetailsType^ value);
}


ProStoresDetailsType Class

ProStoresDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ProStoresDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ProStoresDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ProStoresDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ProStoresDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProStoresDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SellerThirdPartyUsername |
 | Status |
 | StatusSpecified |
 | StoreName |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ProStoresDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ProStoresDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ProStoresDetailsType Constructor

ProStoresDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ProStoresDetailsType ► ProStoresDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ProStoresDetailsType()
Public Sub New
public:
ProStoresDetailsType()


SellerThirdPartyUsername Property

SellerThirdPartyUsername Property
Namespaces ► eBay.Service.Core.Soap ► ProStoresDetailsType ► SellerThirdPartyUsername
Declaration Syntax
C# Visual Basic Visual C++
public string SellerThirdPartyUsername { get; set; }
Public Property SellerThirdPartyUsername As String
    Get
    Set
public:
property String^ SellerThirdPartyUsername {
    String^ get ();
    void set (String^ value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► ProStoresDetailsType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public EnableCodeType Status { get; set; }
Public Property Status As EnableCodeType
    Get
    Set
public:
property EnableCodeType Status {
    EnableCodeType get ();
    void set (EnableCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ProStoresDetailsType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


StoreName Property

StoreName Property
Namespaces ► eBay.Service.Core.Soap ► ProStoresDetailsType ► StoreName
Declaration Syntax
C# Visual Basic Visual C++
public string StoreName { get; set; }
Public Property StoreName As String
    Get
    Set
public:
property String^ StoreName {
    String^ get ();
    void set (String^ value);
}


PurchaseReminderEmailPreferencesType Class

PurchaseReminderEmailPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► PurchaseReminderEmailPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class PurchaseReminderEmailPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class PurchaseReminderEmailPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class PurchaseReminderEmailPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PurchaseReminderEmailPreferencesType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PurchaseReminderEmailPreferences |
 | PurchaseReminderEmailPreferencesSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PurchaseReminderEmailPreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► PurchaseReminderEmailPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PurchaseReminderEmailPreferences Property

PurchaseReminderEmailPreferences Property
Namespaces ► eBay.Service.Core.Soap ► PurchaseReminderEmailPreferencesType ► PurchaseReminderEmailPreferences
Declaration Syntax
C# Visual Basic Visual C++
public bool PurchaseReminderEmailPreferences { get; set; }
Public Property PurchaseReminderEmailPreferences As Boolean
    Get
    Set
public:
property bool PurchaseReminderEmailPreferences {
    bool get ();
    void set (bool value);
}


PurchaseReminderEmailPreferencesSpecified Property

PurchaseReminderEmailPreferencesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► PurchaseReminderEmailPreferencesType ► PurchaseReminderEmailPreferencesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PurchaseReminderEmailPreferencesSpecified { get; set; }
Public Property PurchaseReminderEmailPreferencesSpecified As Boolean
    Get
    Set
public:
property bool PurchaseReminderEmailPreferencesSpecified {
    bool get ();
    void set (bool value);
}


PurchaseReminderEmailPreferencesType Constructor

PurchaseReminderEmailPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► PurchaseReminderEmailPreferencesType ► PurchaseReminderEmailPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public PurchaseReminderEmailPreferencesType()
Public Sub New
public:
PurchaseReminderEmailPreferencesType()


QuantityAvailableHintCodeType Enumeration

QuantityAvailableHintCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► QuantityAvailableHintCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum QuantityAvailableHintCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration QuantityAvailableHintCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class QuantityAvailableHintCodeType
Members
Member | Description
Limited |
MoreThan |
CustomCode |
Remarks


QuantityInfoType Class

QuantityInfoType Class
Namespaces ► eBay.Service.Core.Soap ► QuantityInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class QuantityInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class QuantityInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class QuantityInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QuantityInfoType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumRemnantSet |
 | MinimumRemnantSetSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
QuantityInfoType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► QuantityInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MinimumRemnantSet Property

MinimumRemnantSet Property
Namespaces ► eBay.Service.Core.Soap ► QuantityInfoType ► MinimumRemnantSet
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumRemnantSet { get; set; }
Public Property MinimumRemnantSet As Integer
    Get
    Set
public:
property int MinimumRemnantSet {
    int get ();
    void set (int value);
}


MinimumRemnantSetSpecified Property

MinimumRemnantSetSpecified Property
Namespaces ► eBay.Service.Core.Soap ► QuantityInfoType ► MinimumRemnantSetSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinimumRemnantSetSpecified { get; set; }
Public Property MinimumRemnantSetSpecified As Boolean
    Get
    Set
public:
property bool MinimumRemnantSetSpecified {
    bool get ();
    void set (bool value);
}


QuantityInfoType Constructor

QuantityInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► QuantityInfoType ► QuantityInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public QuantityInfoType()
Public Sub New
public:
QuantityInfoType()


QuantityOperatorCodeType Enumeration

QuantityOperatorCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► QuantityOperatorCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum QuantityOperatorCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration QuantityOperatorCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class QuantityOperatorCodeType
Members
Member | Description
LessThan |
LessThanOrEqual |
Equal |
GreaterThan |
GreaterThanOrEqual |
CustomCode |
Remarks


QuantityRestrictionPerBuyerInfoType Class

QuantityRestrictionPerBuyerInfoType Class
Namespaces ► eBay.Service.Core.Soap ► QuantityRestrictionPerBuyerInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class QuantityRestrictionPerBuyerInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class QuantityRestrictionPerBuyerInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class QuantityRestrictionPerBuyerInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QuantityRestrictionPerBuyerInfoType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MaximumQuantity |
 | MaximumQuantitySpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
QuantityRestrictionPerBuyerInfoType


MaximumQuantity Property

MaximumQuantity Property
Namespaces ► eBay.Service.Core.Soap ► QuantityRestrictionPerBuyerInfoType ► MaximumQuantity
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumQuantity { get; set; }
Public Property MaximumQuantity As Integer
    Get
    Set
public:
property int MaximumQuantity {
    int get ();
    void set (int value);
}


MaximumQuantitySpecified Property

MaximumQuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► QuantityRestrictionPerBuyerInfoType ► MaximumQuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaximumQuantitySpecified { get; set; }
Public Property MaximumQuantitySpecified As Boolean
    Get
    Set
public:
property bool MaximumQuantitySpecified {
    bool get ();
    void set (bool value);
}


QuantityRestrictionPerBuyerInfoType Constructor

QuantityRestrictionPerBuyerInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► QuantityRestrictionPerBuyerInfoType ► QuantityRestrictionPerBuyerInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public QuantityRestrictionPerBuyerInfoType()
Public Sub New
public:
QuantityRestrictionPerBuyerInfoType()


QuestionTypeCodeType Enumeration

QuestionTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► QuestionTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum QuestionTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration QuestionTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class QuestionTypeCodeType
Members
Member | Description
General |
Shipping |
Payment |
MultipleItemShipping |
CustomizedSubject |
None |
CustomCode |
Remarks


RateTableDetailsType Class

RateTableDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► RateTableDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RateTableDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RateTableDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RateTableDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RateTableDetailsType()()()() |
 | Any |
 | DomesticRateTable |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InternationalRateTable |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RateTableDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RateTableDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DomesticRateTable Property

DomesticRateTable Property
Namespaces ► eBay.Service.Core.Soap ► RateTableDetailsType ► DomesticRateTable
Declaration Syntax
C# Visual Basic Visual C++
public string DomesticRateTable { get; set; }
Public Property DomesticRateTable As String
    Get
    Set
public:
property String^ DomesticRateTable {
    String^ get ();
    void set (String^ value);
}


InternationalRateTable Property

InternationalRateTable Property
Namespaces ► eBay.Service.Core.Soap ► RateTableDetailsType ► InternationalRateTable
Declaration Syntax
C# Visual Basic Visual C++
public string InternationalRateTable { get; set; }
Public Property InternationalRateTable As String
    Get
    Set
public:
property String^ InternationalRateTable {
    String^ get ();
    void set (String^ value);
}


RateTableDetailsType Constructor

RateTableDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► RateTableDetailsType ► RateTableDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RateTableDetailsType()
Public Sub New
public:
RateTableDetailsType()


RCSPaymentStatusCodeType Enumeration

RCSPaymentStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► RCSPaymentStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum RCSPaymentStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration RCSPaymentStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class RCSPaymentStatusCodeType
Members
Member | Description
Canceled |
Paid |
Pending |
CustomCode |
Remarks


ReasonCodeDetailType Class

ReasonCodeDetailType Class
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReasonCodeDetailType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReasonCodeDetailType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReasonCodeDetailType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReasonCodeDetailType()()()() |
 | Any |
 | BriefText |
 | codeID |
 | codeIDSpecified |
 | DetailedText |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ReasonCodeDetailType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BriefText Property

BriefText Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailType ► BriefText
Declaration Syntax
C# Visual Basic Visual C++
public string BriefText { get; set; }
Public Property BriefText As String
    Get
    Set
public:
property String^ BriefText {
    String^ get ();
    void set (String^ value);
}


codeID Property

codeID Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailType ► codeID
Declaration Syntax
C# Visual Basic Visual C++
public long codeID { get; set; }
Public Property codeID As Long
    Get
    Set
public:
property long long codeID {
    long long get ();
    void set (long long value);
}


codeIDSpecified Property

codeIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailType ► codeIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool codeIDSpecified { get; set; }
Public Property codeIDSpecified As Boolean
    Get
    Set
public:
property bool codeIDSpecified {
    bool get ();
    void set (bool value);
}


DetailedText Property

DetailedText Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailType ► DetailedText
Declaration Syntax
C# Visual Basic Visual C++
public string DetailedText { get; set; }
Public Property DetailedText As String
    Get
    Set
public:
property String^ DetailedText {
    String^ get ();
    void set (String^ value);
}


ReasonCodeDetailType Constructor

ReasonCodeDetailType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailType ► ReasonCodeDetailType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReasonCodeDetailType()
Public Sub New
public:
ReasonCodeDetailType()


ReasonCodeDetailTypeCollection Class

ReasonCodeDetailTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ReasonCodeDetailTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ReasonCodeDetailTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ReasonCodeDetailTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReasonCodeDetailTypeCollection()()()() |
 | ReasonCodeDetailTypeCollection(array<ReasonCodeDetailType>[]()[][]) |
 | ReasonCodeDetailTypeCollection(ReasonCodeDetailTypeCollection) |
 | Add(ReasonCodeDetailType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ReasonCodeDetailType>[]()[][]) |
 | AddRange(ReasonCodeDetailTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ReasonCodeDetailType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ReasonCodeDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ReasonCodeDetailType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ReasonCodeDetailType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ReasonCodeDetailType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ReasonCodeDetailTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► Add(ReasonCodeDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ReasonCodeDetailType item
)
Public Function Add ( _
    item As ReasonCodeDetailType _
) As Integer
public:
int Add(
    ReasonCodeDetailType^ item
)
Parameters
item (ReasonCodeDetailType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ReasonCodeDetailType>[]()[][]) |
 | AddRange(ReasonCodeDetailTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► AddRange(array<ReasonCodeDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ReasonCodeDetailType[] items
)
Public Sub AddRange ( _
    items As ReasonCodeDetailType() _
)
public:
void AddRange(
    array<ReasonCodeDetailType^>^ items
)
Parameters
items (array< ReasonCodeDetailType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► AddRange(ReasonCodeDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ReasonCodeDetailTypeCollection items
)
Public Sub AddRange ( _
    items As ReasonCodeDetailTypeCollection _
)
public:
void AddRange(
    ReasonCodeDetailTypeCollection^ items
)
Parameters
items (ReasonCodeDetailTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► Contains(ReasonCodeDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ReasonCodeDetailType item
)
Public Function Contains ( _
    item As ReasonCodeDetailType _
) As Boolean
public:
bool Contains(
    ReasonCodeDetailType^ item
)
Parameters
item (ReasonCodeDetailType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► CopyTo(array<ReasonCodeDetailType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ReasonCodeDetailType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ReasonCodeDetailType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ReasonCodeDetailType^>^ items,
    int index
)
Parameters
items (array< ReasonCodeDetailType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► IndexOf(ReasonCodeDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ReasonCodeDetailType item
)
Public Function IndexOf ( _
    item As ReasonCodeDetailType _
) As Integer
public:
int IndexOf(
    ReasonCodeDetailType^ item
)
Parameters
item (ReasonCodeDetailType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► Insert(Int32, ReasonCodeDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ReasonCodeDetailType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ReasonCodeDetailType _
)
public:
void Insert(
    int index,
    ReasonCodeDetailType^ item
)
Parameters
index (Int32)
item (ReasonCodeDetailType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ReasonCodeDetailType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ReasonCodeDetailType
    Get
    Set
public:
property ReasonCodeDetailType^ default[int index] {
    ReasonCodeDetailType^ get (int index);
    void set (int index, ReasonCodeDetailType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ReasonCodeDetailType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ReasonCodeDetailType
public:
ReasonCodeDetailType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


ReasonCodeDetailTypeCollection Constructor

ReasonCodeDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► ReasonCodeDetailTypeCollection()()()()
Members
Icon | Member | Description
 | ReasonCodeDetailTypeCollection()()()() |
 | ReasonCodeDetailTypeCollection(array<ReasonCodeDetailType>[]()[][]) |
 | ReasonCodeDetailTypeCollection(ReasonCodeDetailTypeCollection) |


ReasonCodeDetailTypeCollection Constructor

ReasonCodeDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► ReasonCodeDetailTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReasonCodeDetailTypeCollection()
Public Sub New
public:
ReasonCodeDetailTypeCollection()


ReasonCodeDetailTypeCollection Constructor (items)

ReasonCodeDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► ReasonCodeDetailTypeCollection(array<ReasonCodeDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ReasonCodeDetailTypeCollection(
    ReasonCodeDetailType[] items
)
Public Sub New ( _
    items As ReasonCodeDetailType() _
)
public:
ReasonCodeDetailTypeCollection(
    array<ReasonCodeDetailType^>^ items
)
Parameters
items (array< ReasonCodeDetailType >[]()[][])


ReasonCodeDetailTypeCollection Constructor (items)

ReasonCodeDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► ReasonCodeDetailTypeCollection(ReasonCodeDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ReasonCodeDetailTypeCollection(
    ReasonCodeDetailTypeCollection items
)
Public Sub New ( _
    items As ReasonCodeDetailTypeCollection _
)
public:
ReasonCodeDetailTypeCollection(
    ReasonCodeDetailTypeCollection^ items
)
Parameters
items (ReasonCodeDetailTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► Remove(ReasonCodeDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ReasonCodeDetailType item
)
Public Sub Remove ( _
    item As ReasonCodeDetailType _
)
public:
void Remove(
    ReasonCodeDetailType^ item
)
Parameters
item (ReasonCodeDetailType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReasonCodeDetailType[] ToArray()
Public Function ToArray As ReasonCodeDetailType()
public:
array<ReasonCodeDetailType^>^ ToArray()
Return Value


ReasonHideFromSearchCodeType Enumeration

ReasonHideFromSearchCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ReasonHideFromSearchCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ReasonHideFromSearchCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ReasonHideFromSearchCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ReasonHideFromSearchCodeType
Members
Member | Description
DuplicateListing |
OutOfStock |
Remarks


RecipientRelationCodeType Enumeration

RecipientRelationCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► RecipientRelationCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum RecipientRelationCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration RecipientRelationCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class RecipientRelationCodeType
Members
Member | Description
Item1 |
Item2 |
Item3 |
Item4 |
CustomCode |
Remarks


RecommendationsType Class

RecommendationsType Class
Namespaces ► eBay.Service.Core.Soap ► RecommendationsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RecommendationsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RecommendationsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RecommendationsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecommendationsType()()()() |
 | Any |
 | CategoryID |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NameRecommendation |
 | ToString()()()() | (Inherited from Object.)
 | Updated |
 | UpdatedSpecified |
Remarks
Inheritance Hierarchy
Object
RecommendationsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


NameRecommendation Property

NameRecommendation Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsType ► NameRecommendation
Declaration Syntax
C# Visual Basic Visual C++
public NameRecommendationTypeCollection NameRecommendation { get; set; }
Public Property NameRecommendation As NameRecommendationTypeCollection
    Get
    Set
public:
property NameRecommendationTypeCollection^ NameRecommendation {
    NameRecommendationTypeCollection^ get ();
    void set (NameRecommendationTypeCollection^ value);
}


RecommendationsType Constructor

RecommendationsType Constructor
Namespaces ► eBay.Service.Core.Soap ► RecommendationsType ► RecommendationsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationsType()
Public Sub New
public:
RecommendationsType()


Updated Property

Updated Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsType ► Updated
Declaration Syntax
C# Visual Basic Visual C++
public bool Updated { get; set; }
Public Property Updated As Boolean
    Get
    Set
public:
property bool Updated {
    bool get ();
    void set (bool value);
}


UpdatedSpecified Property

UpdatedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsType ► UpdatedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdatedSpecified { get; set; }
Public Property UpdatedSpecified As Boolean
    Get
    Set
public:
property bool UpdatedSpecified {
    bool get ();
    void set (bool value);
}


RecommendationsTypeCollection Class

RecommendationsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RecommendationsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RecommendationsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RecommendationsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecommendationsTypeCollection()()()() |
 | RecommendationsTypeCollection(array<RecommendationsType>[]()[][]) |
 | RecommendationsTypeCollection(RecommendationsTypeCollection) |
 | Add(RecommendationsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RecommendationsType>[]()[][]) |
 | AddRange(RecommendationsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RecommendationsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RecommendationsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RecommendationsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RecommendationsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RecommendationsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RecommendationsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► Add(RecommendationsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RecommendationsType item
)
Public Function Add ( _
    item As RecommendationsType _
) As Integer
public:
int Add(
    RecommendationsType^ item
)
Parameters
item (RecommendationsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RecommendationsType>[]()[][]) |
 | AddRange(RecommendationsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► AddRange(array<RecommendationsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RecommendationsType[] items
)
Public Sub AddRange ( _
    items As RecommendationsType() _
)
public:
void AddRange(
    array<RecommendationsType^>^ items
)
Parameters
items (array< RecommendationsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► AddRange(RecommendationsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RecommendationsTypeCollection items
)
Public Sub AddRange ( _
    items As RecommendationsTypeCollection _
)
public:
void AddRange(
    RecommendationsTypeCollection^ items
)
Parameters
items (RecommendationsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► Contains(RecommendationsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RecommendationsType item
)
Public Function Contains ( _
    item As RecommendationsType _
) As Boolean
public:
bool Contains(
    RecommendationsType^ item
)
Parameters
item (RecommendationsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► CopyTo(array<RecommendationsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RecommendationsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RecommendationsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RecommendationsType^>^ items,
    int index
)
Parameters
items (array< RecommendationsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► IndexOf(RecommendationsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RecommendationsType item
)
Public Function IndexOf ( _
    item As RecommendationsType _
) As Integer
public:
int IndexOf(
    RecommendationsType^ item
)
Parameters
item (RecommendationsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► Insert(Int32, RecommendationsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RecommendationsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RecommendationsType _
)
public:
void Insert(
    int index,
    RecommendationsType^ item
)
Parameters
index (Int32)
item (RecommendationsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RecommendationsType
    Get
    Set
public:
property RecommendationsType^ default[int index] {
    RecommendationsType^ get (int index);
    void set (int index, RecommendationsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RecommendationsType
public:
RecommendationsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


RecommendationsTypeCollection Constructor

RecommendationsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► RecommendationsTypeCollection()()()()
Members
Icon | Member | Description
 | RecommendationsTypeCollection()()()() |
 | RecommendationsTypeCollection(array<RecommendationsType>[]()[][]) |
 | RecommendationsTypeCollection(RecommendationsTypeCollection) |


RecommendationsTypeCollection Constructor

RecommendationsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► RecommendationsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationsTypeCollection()
Public Sub New
public:
RecommendationsTypeCollection()


RecommendationsTypeCollection Constructor (items)

RecommendationsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► RecommendationsTypeCollection(array<RecommendationsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationsTypeCollection(
    RecommendationsType[] items
)
Public Sub New ( _
    items As RecommendationsType() _
)
public:
RecommendationsTypeCollection(
    array<RecommendationsType^>^ items
)
Parameters
items (array< RecommendationsType >[]()[][])


RecommendationsTypeCollection Constructor (items)

RecommendationsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► RecommendationsTypeCollection(RecommendationsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationsTypeCollection(
    RecommendationsTypeCollection items
)
Public Sub New ( _
    items As RecommendationsTypeCollection _
)
public:
RecommendationsTypeCollection(
    RecommendationsTypeCollection^ items
)
Parameters
items (RecommendationsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► Remove(RecommendationsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RecommendationsType item
)
Public Sub Remove ( _
    item As RecommendationsType _
)
public:
void Remove(
    RecommendationsType^ item
)
Parameters
item (RecommendationsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationsType[] ToArray()
Public Function ToArray As RecommendationsType()
public:
array<RecommendationsType^>^ ToArray()
Return Value


RecommendationValidationRulesType Class

RecommendationValidationRulesType Class
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RecommendationValidationRulesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RecommendationValidationRulesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RecommendationValidationRulesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecommendationValidationRulesType()()()() |
 | Any |
 | Confidence |
 | ConfidenceSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MaxValues |
 | MaxValuesSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinValues |
 | MinValuesSpecified |
 | Relationship |
 | SelectionMode |
 | SelectionModeSpecified |
 | ToString()()()() | (Inherited from Object.)
 | ValueFormat |
 | ValueFormatSpecified |
 | ValueType |
 | ValueTypeSpecified |
 | VariationPicture |
 | VariationPictureSpecified |
 | VariationSpecifics |
 | VariationSpecificsSpecified |
Remarks
Inheritance Hierarchy
Object
RecommendationValidationRulesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Confidence Property

Confidence Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► Confidence
Declaration Syntax
C# Visual Basic Visual C++
public int Confidence { get; set; }
Public Property Confidence As Integer
    Get
    Set
public:
property int Confidence {
    int get ();
    void set (int value);
}


ConfidenceSpecified Property

ConfidenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► ConfidenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ConfidenceSpecified { get; set; }
Public Property ConfidenceSpecified As Boolean
    Get
    Set
public:
property bool ConfidenceSpecified {
    bool get ();
    void set (bool value);
}


MaxValues Property

MaxValues Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► MaxValues
Declaration Syntax
C# Visual Basic Visual C++
public int MaxValues { get; set; }
Public Property MaxValues As Integer
    Get
    Set
public:
property int MaxValues {
    int get ();
    void set (int value);
}


MaxValuesSpecified Property

MaxValuesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► MaxValuesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxValuesSpecified { get; set; }
Public Property MaxValuesSpecified As Boolean
    Get
    Set
public:
property bool MaxValuesSpecified {
    bool get ();
    void set (bool value);
}


MinValues Property

MinValues Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► MinValues
Declaration Syntax
C# Visual Basic Visual C++
public int MinValues { get; set; }
Public Property MinValues As Integer
    Get
    Set
public:
property int MinValues {
    int get ();
    void set (int value);
}


MinValuesSpecified Property

MinValuesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► MinValuesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinValuesSpecified { get; set; }
Public Property MinValuesSpecified As Boolean
    Get
    Set
public:
property bool MinValuesSpecified {
    bool get ();
    void set (bool value);
}


RecommendationValidationRulesType Constructor

RecommendationValidationRulesType Constructor
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► RecommendationValidationRulesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationValidationRulesType()
Public Sub New
public:
RecommendationValidationRulesType()


Relationship Property

Relationship Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► Relationship
Declaration Syntax
C# Visual Basic Visual C++
public NameValueRelationshipTypeCollection Relationship { get; set; }
Public Property Relationship As NameValueRelationshipTypeCollection
    Get
    Set
public:
property NameValueRelationshipTypeCollection^ Relationship {
    NameValueRelationshipTypeCollection^ get ();
    void set (NameValueRelationshipTypeCollection^ value);
}


SelectionMode Property

SelectionMode Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► SelectionMode
Declaration Syntax
C# Visual Basic Visual C++
public SelectionModeCodeType SelectionMode { get; set; }
Public Property SelectionMode As SelectionModeCodeType
    Get
    Set
public:
property SelectionModeCodeType SelectionMode {
    SelectionModeCodeType get ();
    void set (SelectionModeCodeType value);
}


SelectionModeSpecified Property

SelectionModeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► SelectionModeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SelectionModeSpecified { get; set; }
Public Property SelectionModeSpecified As Boolean
    Get
    Set
public:
property bool SelectionModeSpecified {
    bool get ();
    void set (bool value);
}


ValueFormat Property

ValueFormat Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► ValueFormat
Declaration Syntax
C# Visual Basic Visual C++
public ValueFormatCodeType ValueFormat { get; set; }
Public Property ValueFormat As ValueFormatCodeType
    Get
    Set
public:
property ValueFormatCodeType ValueFormat {
    ValueFormatCodeType get ();
    void set (ValueFormatCodeType value);
}


ValueFormatSpecified Property

ValueFormatSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► ValueFormatSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ValueFormatSpecified { get; set; }
Public Property ValueFormatSpecified As Boolean
    Get
    Set
public:
property bool ValueFormatSpecified {
    bool get ();
    void set (bool value);
}


ValueType Property

ValueType Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► ValueType
Declaration Syntax
C# Visual Basic Visual C++
public ValueTypeCodeType ValueType { get; set; }
Public Property ValueType As ValueTypeCodeType
    Get
    Set
public:
property ValueTypeCodeType ValueType {
    ValueTypeCodeType get ();
    void set (ValueTypeCodeType value);
}


ValueTypeSpecified Property

ValueTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► ValueTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ValueTypeSpecified { get; set; }
Public Property ValueTypeSpecified As Boolean
    Get
    Set
public:
property bool ValueTypeSpecified {
    bool get ();
    void set (bool value);
}


VariationPicture Property

VariationPicture Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► VariationPicture
Declaration Syntax
C# Visual Basic Visual C++
public VariationPictureRuleCodeType VariationPicture { get; set; }
Public Property VariationPicture As VariationPictureRuleCodeType
    Get
    Set
public:
property VariationPictureRuleCodeType VariationPicture {
    VariationPictureRuleCodeType get ();
    void set (VariationPictureRuleCodeType value);
}


VariationPictureSpecified Property

VariationPictureSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► VariationPictureSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VariationPictureSpecified { get; set; }
Public Property VariationPictureSpecified As Boolean
    Get
    Set
public:
property bool VariationPictureSpecified {
    bool get ();
    void set (bool value);
}


VariationSpecifics Property

VariationSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► VariationSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public VariationSpecificsRuleCodeType VariationSpecifics { get; set; }
Public Property VariationSpecifics As VariationSpecificsRuleCodeType
    Get
    Set
public:
property VariationSpecificsRuleCodeType VariationSpecifics {
    VariationSpecificsRuleCodeType get ();
    void set (VariationSpecificsRuleCodeType value);
}


VariationSpecificsSpecified Property

VariationSpecificsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationValidationRulesType ► VariationSpecificsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VariationSpecificsSpecified { get; set; }
Public Property VariationSpecificsSpecified As Boolean
    Get
    Set
public:
property bool VariationSpecificsSpecified {
    bool get ();
    void set (bool value);
}


RecoupmentPolicyConsentType Class

RecoupmentPolicyConsentType Class
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyConsentType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RecoupmentPolicyConsentType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RecoupmentPolicyConsentType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RecoupmentPolicyConsentType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecoupmentPolicyConsentType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Site |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RecoupmentPolicyConsentType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyConsentType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


RecoupmentPolicyConsentType Constructor

RecoupmentPolicyConsentType Constructor
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyConsentType ► RecoupmentPolicyConsentType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RecoupmentPolicyConsentType()
Public Sub New
public:
RecoupmentPolicyConsentType()


Site Property

Site Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyConsentType ► Site
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeTypeCollection Site { get; set; }
Public Property Site As SiteCodeTypeCollection
    Get
    Set
public:
property SiteCodeTypeCollection^ Site {
    SiteCodeTypeCollection^ get ();
    void set (SiteCodeTypeCollection^ value);
}


RecoupmentPolicyDetailsType Class

RecoupmentPolicyDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RecoupmentPolicyDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RecoupmentPolicyDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RecoupmentPolicyDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecoupmentPolicyDetailsType()()()() |
 | Any |
 | DetailVersion |
 | EnforcedOnListingSite |
 | EnforcedOnListingSiteSpecified |
 | EnforcedOnRegistrationSite |
 | EnforcedOnRegistrationSiteSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
RecoupmentPolicyDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


EnforcedOnListingSite Property

EnforcedOnListingSite Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsType ► EnforcedOnListingSite
Declaration Syntax
C# Visual Basic Visual C++
public bool EnforcedOnListingSite { get; set; }
Public Property EnforcedOnListingSite As Boolean
    Get
    Set
public:
property bool EnforcedOnListingSite {
    bool get ();
    void set (bool value);
}


EnforcedOnListingSiteSpecified Property

EnforcedOnListingSiteSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsType ► EnforcedOnListingSiteSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EnforcedOnListingSiteSpecified { get; set; }
Public Property EnforcedOnListingSiteSpecified As Boolean
    Get
    Set
public:
property bool EnforcedOnListingSiteSpecified {
    bool get ();
    void set (bool value);
}


EnforcedOnRegistrationSite Property

EnforcedOnRegistrationSite Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsType ► EnforcedOnRegistrationSite
Declaration Syntax
C# Visual Basic Visual C++
public bool EnforcedOnRegistrationSite { get; set; }
Public Property EnforcedOnRegistrationSite As Boolean
    Get
    Set
public:
property bool EnforcedOnRegistrationSite {
    bool get ();
    void set (bool value);
}


EnforcedOnRegistrationSiteSpecified Property

EnforcedOnRegistrationSiteSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsType ► EnforcedOnRegistrationSiteSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EnforcedOnRegistrationSiteSpecified { get; set; }
Public Property EnforcedOnRegistrationSiteSpecified As Boolean
    Get
    Set
public:
property bool EnforcedOnRegistrationSiteSpecified {
    bool get ();
    void set (bool value);
}


RecoupmentPolicyDetailsType Constructor

RecoupmentPolicyDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsType ► RecoupmentPolicyDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RecoupmentPolicyDetailsType()
Public Sub New
public:
RecoupmentPolicyDetailsType()


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


RecoupmentPolicyDetailsTypeCollection Class

RecoupmentPolicyDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RecoupmentPolicyDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RecoupmentPolicyDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RecoupmentPolicyDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RecoupmentPolicyDetailsTypeCollection()()()() |
 | RecoupmentPolicyDetailsTypeCollection(array<RecoupmentPolicyDetailsType>[]()[][]) |
 | RecoupmentPolicyDetailsTypeCollection(RecoupmentPolicyDetailsTypeCollection) |
 | Add(RecoupmentPolicyDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RecoupmentPolicyDetailsType>[]()[][]) |
 | AddRange(RecoupmentPolicyDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RecoupmentPolicyDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RecoupmentPolicyDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RecoupmentPolicyDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RecoupmentPolicyDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RecoupmentPolicyDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RecoupmentPolicyDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► Add(RecoupmentPolicyDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RecoupmentPolicyDetailsType item
)
Public Function Add ( _
    item As RecoupmentPolicyDetailsType _
) As Integer
public:
int Add(
    RecoupmentPolicyDetailsType^ item
)
Parameters
item (RecoupmentPolicyDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RecoupmentPolicyDetailsType>[]()[][]) |
 | AddRange(RecoupmentPolicyDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► AddRange(array<RecoupmentPolicyDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RecoupmentPolicyDetailsType[] items
)
Public Sub AddRange ( _
    items As RecoupmentPolicyDetailsType() _
)
public:
void AddRange(
    array<RecoupmentPolicyDetailsType^>^ items
)
Parameters
items (array< RecoupmentPolicyDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► AddRange(RecoupmentPolicyDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RecoupmentPolicyDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As RecoupmentPolicyDetailsTypeCollection _
)
public:
void AddRange(
    RecoupmentPolicyDetailsTypeCollection^ items
)
Parameters
items (RecoupmentPolicyDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► Contains(RecoupmentPolicyDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RecoupmentPolicyDetailsType item
)
Public Function Contains ( _
    item As RecoupmentPolicyDetailsType _
) As Boolean
public:
bool Contains(
    RecoupmentPolicyDetailsType^ item
)
Parameters
item (RecoupmentPolicyDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► CopyTo(array<RecoupmentPolicyDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RecoupmentPolicyDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RecoupmentPolicyDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RecoupmentPolicyDetailsType^>^ items,
    int index
)
Parameters
items (array< RecoupmentPolicyDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► IndexOf(RecoupmentPolicyDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RecoupmentPolicyDetailsType item
)
Public Function IndexOf ( _
    item As RecoupmentPolicyDetailsType _
) As Integer
public:
int IndexOf(
    RecoupmentPolicyDetailsType^ item
)
Parameters
item (RecoupmentPolicyDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► Insert(Int32, RecoupmentPolicyDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RecoupmentPolicyDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RecoupmentPolicyDetailsType _
)
public:
void Insert(
    int index,
    RecoupmentPolicyDetailsType^ item
)
Parameters
index (Int32)
item (RecoupmentPolicyDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RecoupmentPolicyDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RecoupmentPolicyDetailsType
    Get
    Set
public:
property RecoupmentPolicyDetailsType^ default[int index] {
    RecoupmentPolicyDetailsType^ get (int index);
    void set (int index, RecoupmentPolicyDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RecoupmentPolicyDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RecoupmentPolicyDetailsType
public:
RecoupmentPolicyDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


RecoupmentPolicyDetailsTypeCollection Constructor

RecoupmentPolicyDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► RecoupmentPolicyDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | RecoupmentPolicyDetailsTypeCollection()()()() |
 | RecoupmentPolicyDetailsTypeCollection(array<RecoupmentPolicyDetailsType>[]()[][]) |
 | RecoupmentPolicyDetailsTypeCollection(RecoupmentPolicyDetailsTypeCollection) |


RecoupmentPolicyDetailsTypeCollection Constructor

RecoupmentPolicyDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► RecoupmentPolicyDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RecoupmentPolicyDetailsTypeCollection()
Public Sub New
public:
RecoupmentPolicyDetailsTypeCollection()


RecoupmentPolicyDetailsTypeCollection Constructor (items)

RecoupmentPolicyDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► RecoupmentPolicyDetailsTypeCollection(array<RecoupmentPolicyDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RecoupmentPolicyDetailsTypeCollection(
    RecoupmentPolicyDetailsType[] items
)
Public Sub New ( _
    items As RecoupmentPolicyDetailsType() _
)
public:
RecoupmentPolicyDetailsTypeCollection(
    array<RecoupmentPolicyDetailsType^>^ items
)
Parameters
items (array< RecoupmentPolicyDetailsType >[]()[][])


RecoupmentPolicyDetailsTypeCollection Constructor (items)

RecoupmentPolicyDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► RecoupmentPolicyDetailsTypeCollection(RecoupmentPolicyDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RecoupmentPolicyDetailsTypeCollection(
    RecoupmentPolicyDetailsTypeCollection items
)
Public Sub New ( _
    items As RecoupmentPolicyDetailsTypeCollection _
)
public:
RecoupmentPolicyDetailsTypeCollection(
    RecoupmentPolicyDetailsTypeCollection^ items
)
Parameters
items (RecoupmentPolicyDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► Remove(RecoupmentPolicyDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RecoupmentPolicyDetailsType item
)
Public Sub Remove ( _
    item As RecoupmentPolicyDetailsType _
)
public:
void Remove(
    RecoupmentPolicyDetailsType^ item
)
Parameters
item (RecoupmentPolicyDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RecoupmentPolicyDetailsType[] ToArray()
Public Function ToArray As RecoupmentPolicyDetailsType()
public:
array<RecoupmentPolicyDetailsType^>^ ToArray()
Return Value


RefundDetailsType Class

RefundDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RefundDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RefundDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RefundDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundDetailsType()()()() |
 | Any |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RefundOption |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RefundDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


RefundDetailsType Constructor

RefundDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsType ► RefundDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundDetailsType()
Public Sub New
public:
RefundDetailsType()


RefundOption Property

RefundOption Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsType ► RefundOption
Declaration Syntax
C# Visual Basic Visual C++
public string RefundOption { get; set; }
Public Property RefundOption As String
    Get
    Set
public:
property String^ RefundOption {
    String^ get ();
    void set (String^ value);
}


RefundDetailsTypeCollection Class

RefundDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RefundDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RefundDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RefundDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundDetailsTypeCollection()()()() |
 | RefundDetailsTypeCollection(array<RefundDetailsType>[]()[][]) |
 | RefundDetailsTypeCollection(RefundDetailsTypeCollection) |
 | Add(RefundDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RefundDetailsType>[]()[][]) |
 | AddRange(RefundDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RefundDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RefundDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RefundDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RefundDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RefundDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RefundDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► Add(RefundDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RefundDetailsType item
)
Public Function Add ( _
    item As RefundDetailsType _
) As Integer
public:
int Add(
    RefundDetailsType^ item
)
Parameters
item (RefundDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RefundDetailsType>[]()[][]) |
 | AddRange(RefundDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► AddRange(array<RefundDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundDetailsType[] items
)
Public Sub AddRange ( _
    items As RefundDetailsType() _
)
public:
void AddRange(
    array<RefundDetailsType^>^ items
)
Parameters
items (array< RefundDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► AddRange(RefundDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As RefundDetailsTypeCollection _
)
public:
void AddRange(
    RefundDetailsTypeCollection^ items
)
Parameters
items (RefundDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► Contains(RefundDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RefundDetailsType item
)
Public Function Contains ( _
    item As RefundDetailsType _
) As Boolean
public:
bool Contains(
    RefundDetailsType^ item
)
Parameters
item (RefundDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► CopyTo(array<RefundDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RefundDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RefundDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RefundDetailsType^>^ items,
    int index
)
Parameters
items (array< RefundDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► IndexOf(RefundDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RefundDetailsType item
)
Public Function IndexOf ( _
    item As RefundDetailsType _
) As Integer
public:
int IndexOf(
    RefundDetailsType^ item
)
Parameters
item (RefundDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► Insert(Int32, RefundDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RefundDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RefundDetailsType _
)
public:
void Insert(
    int index,
    RefundDetailsType^ item
)
Parameters
index (Int32)
item (RefundDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RefundDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RefundDetailsType
    Get
    Set
public:
property RefundDetailsType^ default[int index] {
    RefundDetailsType^ get (int index);
    void set (int index, RefundDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RefundDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RefundDetailsType
public:
RefundDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


RefundDetailsTypeCollection Constructor

RefundDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► RefundDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | RefundDetailsTypeCollection()()()() |
 | RefundDetailsTypeCollection(array<RefundDetailsType>[]()[][]) |
 | RefundDetailsTypeCollection(RefundDetailsTypeCollection) |


RefundDetailsTypeCollection Constructor

RefundDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► RefundDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundDetailsTypeCollection()
Public Sub New
public:
RefundDetailsTypeCollection()


RefundDetailsTypeCollection Constructor (items)

RefundDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► RefundDetailsTypeCollection(array<RefundDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RefundDetailsTypeCollection(
    RefundDetailsType[] items
)
Public Sub New ( _
    items As RefundDetailsType() _
)
public:
RefundDetailsTypeCollection(
    array<RefundDetailsType^>^ items
)
Parameters
items (array< RefundDetailsType >[]()[][])


RefundDetailsTypeCollection Constructor (items)

RefundDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► RefundDetailsTypeCollection(RefundDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RefundDetailsTypeCollection(
    RefundDetailsTypeCollection items
)
Public Sub New ( _
    items As RefundDetailsTypeCollection _
)
public:
RefundDetailsTypeCollection(
    RefundDetailsTypeCollection^ items
)
Parameters
items (RefundDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► Remove(RefundDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RefundDetailsType item
)
Public Sub Remove ( _
    item As RefundDetailsType _
)
public:
void Remove(
    RefundDetailsType^ item
)
Parameters
item (RefundDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundDetailsType[] ToArray()
Public Function ToArray As RefundDetailsType()
public:
array<RefundDetailsType^>^ ToArray()
Return Value


RefundFailureCodeType Enumeration

RefundFailureCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► RefundFailureCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum RefundFailureCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration RefundFailureCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class RefundFailureCodeType
Members
Member | Description
PaypalBillingAgreementCanceled |
PaypalRiskDeclinesTransaction |
CustomCode |
Remarks


RefundFailureReasonType Class

RefundFailureReasonType Class
Namespaces ► eBay.Service.Core.Soap ► RefundFailureReasonType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RefundFailureReasonType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RefundFailureReasonType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RefundFailureReasonType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundFailureReasonType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RefundFailureCode |
 | RefundFailureCodeSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RefundFailureReasonType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RefundFailureReasonType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


RefundFailureCode Property

RefundFailureCode Property
Namespaces ► eBay.Service.Core.Soap ► RefundFailureReasonType ► RefundFailureCode
Declaration Syntax
C# Visual Basic Visual C++
public RefundFailureCodeType RefundFailureCode { get; set; }
Public Property RefundFailureCode As RefundFailureCodeType
    Get
    Set
public:
property RefundFailureCodeType RefundFailureCode {
    RefundFailureCodeType get ();
    void set (RefundFailureCodeType value);
}


RefundFailureCodeSpecified Property

RefundFailureCodeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RefundFailureReasonType ► RefundFailureCodeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundFailureCodeSpecified { get; set; }
Public Property RefundFailureCodeSpecified As Boolean
    Get
    Set
public:
property bool RefundFailureCodeSpecified {
    bool get ();
    void set (bool value);
}


RefundFailureReasonType Constructor

RefundFailureReasonType Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundFailureReasonType ► RefundFailureReasonType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundFailureReasonType()
Public Sub New
public:
RefundFailureReasonType()


RefundFundingSourceArrayType Class

RefundFundingSourceArrayType Class
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceArrayType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RefundFundingSourceArrayType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RefundFundingSourceArrayType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RefundFundingSourceArrayType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundFundingSourceArrayType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RefundFundingSource |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RefundFundingSourceArrayType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceArrayType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


RefundFundingSource Property

RefundFundingSource Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceArrayType ► RefundFundingSource
Declaration Syntax
C# Visual Basic Visual C++
public RefundFundingSourceTypeCollection RefundFundingSource { get; set; }
Public Property RefundFundingSource As RefundFundingSourceTypeCollection
    Get
    Set
public:
property RefundFundingSourceTypeCollection^ RefundFundingSource {
    RefundFundingSourceTypeCollection^ get ();
    void set (RefundFundingSourceTypeCollection^ value);
}


RefundFundingSourceArrayType Constructor

RefundFundingSourceArrayType Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceArrayType ► RefundFundingSourceArrayType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundFundingSourceArrayType()
Public Sub New
public:
RefundFundingSourceArrayType()


RefundFundingSourceType Class

RefundFundingSourceType Class
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RefundFundingSourceType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RefundFundingSourceType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RefundFundingSourceType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundFundingSourceType()()()() |
 | AccountNumber |
 | Any |
 | BuyerExternalTransactionID |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RefundAmount |
 | RefundingSourceType |
 | RefundingSourceTypeSpecified |
 | SellerExternalTransactionID |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RefundFundingSourceType


AccountNumber Property

AccountNumber Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceType ► AccountNumber
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber { get; set; }
Public Property AccountNumber As String
    Get
    Set
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyerExternalTransactionID Property

BuyerExternalTransactionID Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceType ► BuyerExternalTransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string BuyerExternalTransactionID { get; set; }
Public Property BuyerExternalTransactionID As String
    Get
    Set
public:
property String^ BuyerExternalTransactionID {
    String^ get ();
    void set (String^ value);
}


RefundAmount Property

RefundAmount Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceType ► RefundAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType RefundAmount { get; set; }
Public Property RefundAmount As AmountType
    Get
    Set
public:
property AmountType^ RefundAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


RefundFundingSourceType Constructor

RefundFundingSourceType Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceType ► RefundFundingSourceType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundFundingSourceType()
Public Sub New
public:
RefundFundingSourceType()


RefundingSourceType Property

RefundingSourceType Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceType ► RefundingSourceType
Declaration Syntax
C# Visual Basic Visual C++
public RefundingSourceTypeCodeType RefundingSourceType { get; set; }
Public Property RefundingSourceType As RefundingSourceTypeCodeType
    Get
    Set
public:
property RefundingSourceTypeCodeType RefundingSourceType {
    RefundingSourceTypeCodeType get ();
    void set (RefundingSourceTypeCodeType value);
}


RefundingSourceTypeSpecified Property

RefundingSourceTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceType ► RefundingSourceTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundingSourceTypeSpecified { get; set; }
Public Property RefundingSourceTypeSpecified As Boolean
    Get
    Set
public:
property bool RefundingSourceTypeSpecified {
    bool get ();
    void set (bool value);
}


SellerExternalTransactionID Property

SellerExternalTransactionID Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceType ► SellerExternalTransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string SellerExternalTransactionID { get; set; }
Public Property SellerExternalTransactionID As String
    Get
    Set
public:
property String^ SellerExternalTransactionID {
    String^ get ();
    void set (String^ value);
}


RefundFundingSourceTypeCollection Class

RefundFundingSourceTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RefundFundingSourceTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RefundFundingSourceTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RefundFundingSourceTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundFundingSourceTypeCollection()()()() |
 | RefundFundingSourceTypeCollection(array<RefundFundingSourceType>[]()[][]) |
 | RefundFundingSourceTypeCollection(RefundFundingSourceTypeCollection) |
 | Add(RefundFundingSourceType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RefundFundingSourceType>[]()[][]) |
 | AddRange(RefundFundingSourceTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RefundFundingSourceType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RefundFundingSourceType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RefundFundingSourceType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RefundFundingSourceType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RefundFundingSourceType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RefundFundingSourceTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► Add(RefundFundingSourceType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RefundFundingSourceType item
)
Public Function Add ( _
    item As RefundFundingSourceType _
) As Integer
public:
int Add(
    RefundFundingSourceType^ item
)
Parameters
item (RefundFundingSourceType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RefundFundingSourceType>[]()[][]) |
 | AddRange(RefundFundingSourceTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► AddRange(array<RefundFundingSourceType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundFundingSourceType[] items
)
Public Sub AddRange ( _
    items As RefundFundingSourceType() _
)
public:
void AddRange(
    array<RefundFundingSourceType^>^ items
)
Parameters
items (array< RefundFundingSourceType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► AddRange(RefundFundingSourceTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundFundingSourceTypeCollection items
)
Public Sub AddRange ( _
    items As RefundFundingSourceTypeCollection _
)
public:
void AddRange(
    RefundFundingSourceTypeCollection^ items
)
Parameters
items (RefundFundingSourceTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► Contains(RefundFundingSourceType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RefundFundingSourceType item
)
Public Function Contains ( _
    item As RefundFundingSourceType _
) As Boolean
public:
bool Contains(
    RefundFundingSourceType^ item
)
Parameters
item (RefundFundingSourceType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► CopyTo(array<RefundFundingSourceType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RefundFundingSourceType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RefundFundingSourceType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RefundFundingSourceType^>^ items,
    int index
)
Parameters
items (array< RefundFundingSourceType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► IndexOf(RefundFundingSourceType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RefundFundingSourceType item
)
Public Function IndexOf ( _
    item As RefundFundingSourceType _
) As Integer
public:
int IndexOf(
    RefundFundingSourceType^ item
)
Parameters
item (RefundFundingSourceType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► Insert(Int32, RefundFundingSourceType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RefundFundingSourceType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RefundFundingSourceType _
)
public:
void Insert(
    int index,
    RefundFundingSourceType^ item
)
Parameters
index (Int32)
item (RefundFundingSourceType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RefundFundingSourceType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RefundFundingSourceType
    Get
    Set
public:
property RefundFundingSourceType^ default[int index] {
    RefundFundingSourceType^ get (int index);
    void set (int index, RefundFundingSourceType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RefundFundingSourceType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RefundFundingSourceType
public:
RefundFundingSourceType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


RefundFundingSourceTypeCollection Constructor

RefundFundingSourceTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► RefundFundingSourceTypeCollection()()()()
Members
Icon | Member | Description
 | RefundFundingSourceTypeCollection()()()() |
 | RefundFundingSourceTypeCollection(array<RefundFundingSourceType>[]()[][]) |
 | RefundFundingSourceTypeCollection(RefundFundingSourceTypeCollection) |


RefundFundingSourceTypeCollection Constructor

RefundFundingSourceTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► RefundFundingSourceTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundFundingSourceTypeCollection()
Public Sub New
public:
RefundFundingSourceTypeCollection()


RefundFundingSourceTypeCollection Constructor (items)

RefundFundingSourceTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► RefundFundingSourceTypeCollection(array<RefundFundingSourceType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RefundFundingSourceTypeCollection(
    RefundFundingSourceType[] items
)
Public Sub New ( _
    items As RefundFundingSourceType() _
)
public:
RefundFundingSourceTypeCollection(
    array<RefundFundingSourceType^>^ items
)
Parameters
items (array< RefundFundingSourceType >[]()[][])


RefundFundingSourceTypeCollection Constructor (items)

RefundFundingSourceTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► RefundFundingSourceTypeCollection(RefundFundingSourceTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RefundFundingSourceTypeCollection(
    RefundFundingSourceTypeCollection items
)
Public Sub New ( _
    items As RefundFundingSourceTypeCollection _
)
public:
RefundFundingSourceTypeCollection(
    RefundFundingSourceTypeCollection^ items
)
Parameters
items (RefundFundingSourceTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► Remove(RefundFundingSourceType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RefundFundingSourceType item
)
Public Sub Remove ( _
    item As RefundFundingSourceType _
)
public:
void Remove(
    RefundFundingSourceType^ item
)
Parameters
item (RefundFundingSourceType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundFundingSourceType[] ToArray()
Public Function ToArray As RefundFundingSourceType()
public:
array<RefundFundingSourceType^>^ ToArray()
Return Value


RefundInformationType Class

RefundInformationType Class
Namespaces ► eBay.Service.Core.Soap ► RefundInformationType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RefundInformationType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RefundInformationType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RefundInformationType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundInformationType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Refund |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RefundInformationType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RefundInformationType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Refund Property

Refund Property
Namespaces ► eBay.Service.Core.Soap ► RefundInformationType ► Refund
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionInfoTypeCollection Refund { get; set; }
Public Property Refund As RefundTransactionInfoTypeCollection
    Get
    Set
public:
property RefundTransactionInfoTypeCollection^ Refund {
    RefundTransactionInfoTypeCollection^ get ();
    void set (RefundTransactionInfoTypeCollection^ value);
}


RefundInformationType Constructor

RefundInformationType Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundInformationType ► RefundInformationType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundInformationType()
Public Sub New
public:
RefundInformationType()


RefundingSourceTypeCodeType Enumeration

RefundingSourceTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► RefundingSourceTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum RefundingSourceTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration RefundingSourceTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class RefundingSourceTypeCodeType
Members
Member | Description
ScheduledPayout |
Paypal |
BankAccount |
CustomCode |
Remarks


RefundLineArrayType Class

RefundLineArrayType Class
Namespaces ► eBay.Service.Core.Soap ► RefundLineArrayType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RefundLineArrayType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RefundLineArrayType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RefundLineArrayType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundLineArrayType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RefundLine |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RefundLineArrayType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineArrayType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


RefundLine Property

RefundLine Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineArrayType ► RefundLine
Declaration Syntax
C# Visual Basic Visual C++
public RefundLineTypeCollection RefundLine { get; set; }
Public Property RefundLine As RefundLineTypeCollection
    Get
    Set
public:
property RefundLineTypeCollection^ RefundLine {
    RefundLineTypeCollection^ get ();
    void set (RefundLineTypeCollection^ value);
}


RefundLineArrayType Constructor

RefundLineArrayType Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundLineArrayType ► RefundLineArrayType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundLineArrayType()
Public Sub New
public:
RefundLineArrayType()


RefundLineType Class

RefundLineType Class
Namespaces ► eBay.Service.Core.Soap ► RefundLineType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RefundLineType : AmountType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RefundLineType _
    Inherits AmountType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RefundLineType : public AmountType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundLineType()()()() |
 | currencyID | (Inherited from AmountType.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | type |
 | typeSpecified |
 | Value | (Inherited from AmountType.)
Remarks
Inheritance Hierarchy
Object
 | AmountType
 |  | RefundLineType


RefundLineType Constructor

RefundLineType Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundLineType ► RefundLineType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundLineType()
Public Sub New
public:
RefundLineType()


type Property

type Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineType ► type
Declaration Syntax
C# Visual Basic Visual C++
public RefundLineTypeCodeType type { get; set; }
Public Property type As RefundLineTypeCodeType
    Get
    Set
public:
property RefundLineTypeCodeType type {
    RefundLineTypeCodeType get ();
    void set (RefundLineTypeCodeType value);
}


typeSpecified Property

typeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineType ► typeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool typeSpecified { get; set; }
Public Property typeSpecified As Boolean
    Get
    Set
public:
property bool typeSpecified {
    bool get ();
    void set (bool value);
}


RefundLineTypeCodeType Enumeration

RefundLineTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum RefundLineTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration RefundLineTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class RefundLineTypeCodeType
Members
Member | Description
PurchasePrice |
ShippingPrice |
Additional |
CustomCode |
Remarks


RefundLineTypeCollection Class

RefundLineTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RefundLineTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RefundLineTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RefundLineTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundLineTypeCollection()()()() |
 | RefundLineTypeCollection(array<RefundLineType>[]()[][]) |
 | RefundLineTypeCollection(RefundLineTypeCollection) |
 | Add(RefundLineType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RefundLineType>[]()[][]) |
 | AddRange(RefundLineTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RefundLineType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RefundLineType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RefundLineType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RefundLineType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RefundLineType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RefundLineTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► Add(RefundLineType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RefundLineType item
)
Public Function Add ( _
    item As RefundLineType _
) As Integer
public:
int Add(
    RefundLineType^ item
)
Parameters
item (RefundLineType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RefundLineType>[]()[][]) |
 | AddRange(RefundLineTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► AddRange(array<RefundLineType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundLineType[] items
)
Public Sub AddRange ( _
    items As RefundLineType() _
)
public:
void AddRange(
    array<RefundLineType^>^ items
)
Parameters
items (array< RefundLineType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► AddRange(RefundLineTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundLineTypeCollection items
)
Public Sub AddRange ( _
    items As RefundLineTypeCollection _
)
public:
void AddRange(
    RefundLineTypeCollection^ items
)
Parameters
items (RefundLineTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► Contains(RefundLineType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RefundLineType item
)
Public Function Contains ( _
    item As RefundLineType _
) As Boolean
public:
bool Contains(
    RefundLineType^ item
)
Parameters
item (RefundLineType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► CopyTo(array<RefundLineType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RefundLineType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RefundLineType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RefundLineType^>^ items,
    int index
)
Parameters
items (array< RefundLineType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► IndexOf(RefundLineType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RefundLineType item
)
Public Function IndexOf ( _
    item As RefundLineType _
) As Integer
public:
int IndexOf(
    RefundLineType^ item
)
Parameters
item (RefundLineType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► Insert(Int32, RefundLineType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RefundLineType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RefundLineType _
)
public:
void Insert(
    int index,
    RefundLineType^ item
)
Parameters
index (Int32)
item (RefundLineType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RefundLineType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RefundLineType
    Get
    Set
public:
property RefundLineType^ default[int index] {
    RefundLineType^ get (int index);
    void set (int index, RefundLineType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RefundLineType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RefundLineType
public:
RefundLineType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


RefundLineTypeCollection Constructor

RefundLineTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► RefundLineTypeCollection()()()()
Members
Icon | Member | Description
 | RefundLineTypeCollection()()()() |
 | RefundLineTypeCollection(array<RefundLineType>[]()[][]) |
 | RefundLineTypeCollection(RefundLineTypeCollection) |


RefundLineTypeCollection Constructor

RefundLineTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► RefundLineTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundLineTypeCollection()
Public Sub New
public:
RefundLineTypeCollection()


RefundLineTypeCollection Constructor (items)

RefundLineTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► RefundLineTypeCollection(array<RefundLineType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RefundLineTypeCollection(
    RefundLineType[] items
)
Public Sub New ( _
    items As RefundLineType() _
)
public:
RefundLineTypeCollection(
    array<RefundLineType^>^ items
)
Parameters
items (array< RefundLineType >[]()[][])


RefundLineTypeCollection Constructor (items)

RefundLineTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► RefundLineTypeCollection(RefundLineTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RefundLineTypeCollection(
    RefundLineTypeCollection items
)
Public Sub New ( _
    items As RefundLineTypeCollection _
)
public:
RefundLineTypeCollection(
    RefundLineTypeCollection^ items
)
Parameters
items (RefundLineTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► Remove(RefundLineType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RefundLineType item
)
Public Sub Remove ( _
    item As RefundLineType _
)
public:
void Remove(
    RefundLineType^ item
)
Parameters
item (RefundLineType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundLineType[] ToArray()
Public Function ToArray As RefundLineType()
public:
array<RefundLineType^>^ ToArray()
Return Value


RefundReasonCodeType Enumeration

RefundReasonCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► RefundReasonCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum RefundReasonCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration RefundReasonCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class RefundReasonCodeType
Members
Member | Description
CannotShipProduct |
WrongItemShipped |
ItemBadQuality |
ItemDamaged |
BuyerRemorse |
Other |
CustomCode |
Remarks


RefundSourceTypeCodeType Enumeration

RefundSourceTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► RefundSourceTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum RefundSourceTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration RefundSourceTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class RefundSourceTypeCodeType
Members
Member | Description
StoreCredit |
PaymentRefund |
CustomCode |
Remarks


RefundStatusCodeType Enumeration

RefundStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► RefundStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum RefundStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration RefundStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class RefundStatusCodeType
Members
Member | Description
Successful |
Pending |
Failed |
CustomCode |
Remarks


RefundTransactionArrayType Class

RefundTransactionArrayType Class
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionArrayType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RefundTransactionArrayType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RefundTransactionArrayType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RefundTransactionArrayType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundTransactionArrayType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RefundTransaction |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RefundTransactionArrayType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionArrayType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


RefundTransaction Property

RefundTransaction Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionArrayType ► RefundTransaction
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionTypeCollection RefundTransaction { get; set; }
Public Property RefundTransaction As RefundTransactionTypeCollection
    Get
    Set
public:
property RefundTransactionTypeCollection^ RefundTransaction {
    RefundTransactionTypeCollection^ get ();
    void set (RefundTransactionTypeCollection^ value);
}


RefundTransactionArrayType Constructor

RefundTransactionArrayType Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionArrayType ► RefundTransactionArrayType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionArrayType()
Public Sub New
public:
RefundTransactionArrayType()


RefundTransactionInfoType Class

RefundTransactionInfoType Class
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RefundTransactionInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RefundTransactionInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RefundTransactionInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundTransactionInfoType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | FeeOrCreditAmount |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReferenceID |
 | RefundAmount |
 | RefundStatus |
 | RefundStatusSpecified |
 | RefundTime |
 | RefundTimeSpecified |
 | RefundTo |
 | RefundType |
 | RefundTypeSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RefundTransactionInfoType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FeeOrCreditAmount Property

FeeOrCreditAmount Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► FeeOrCreditAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType FeeOrCreditAmount { get; set; }
Public Property FeeOrCreditAmount As AmountType
    Get
    Set
public:
property AmountType^ FeeOrCreditAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


ReferenceID Property

ReferenceID Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► ReferenceID
Declaration Syntax
C# Visual Basic Visual C++
public TransactionReferenceType ReferenceID { get; set; }
Public Property ReferenceID As TransactionReferenceType
    Get
    Set
public:
property TransactionReferenceType^ ReferenceID {
    TransactionReferenceType^ get ();
    void set (TransactionReferenceType^ value);
}


RefundAmount Property

RefundAmount Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► RefundAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType RefundAmount { get; set; }
Public Property RefundAmount As AmountType
    Get
    Set
public:
property AmountType^ RefundAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


RefundStatus Property

RefundStatus Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► RefundStatus
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTransactionStatusCodeType RefundStatus { get; set; }
Public Property RefundStatus As PaymentTransactionStatusCodeType
    Get
    Set
public:
property PaymentTransactionStatusCodeType RefundStatus {
    PaymentTransactionStatusCodeType get ();
    void set (PaymentTransactionStatusCodeType value);
}


RefundStatusSpecified Property

RefundStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► RefundStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundStatusSpecified { get; set; }
Public Property RefundStatusSpecified As Boolean
    Get
    Set
public:
property bool RefundStatusSpecified {
    bool get ();
    void set (bool value);
}


RefundTime Property

RefundTime Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► RefundTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RefundTime { get; set; }
Public Property RefundTime As DateTime
    Get
    Set
public:
property DateTime RefundTime {
    DateTime get ();
    void set (DateTime value);
}


RefundTimeSpecified Property

RefundTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► RefundTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundTimeSpecified { get; set; }
Public Property RefundTimeSpecified As Boolean
    Get
    Set
public:
property bool RefundTimeSpecified {
    bool get ();
    void set (bool value);
}


RefundTo Property

RefundTo Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► RefundTo
Declaration Syntax
C# Visual Basic Visual C++
public UserIdentityType RefundTo { get; set; }
Public Property RefundTo As UserIdentityType
    Get
    Set
public:
property UserIdentityType^ RefundTo {
    UserIdentityType^ get ();
    void set (UserIdentityType^ value);
}


RefundTransactionInfoType Constructor

RefundTransactionInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► RefundTransactionInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionInfoType()
Public Sub New
public:
RefundTransactionInfoType()


RefundType Property

RefundType Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► RefundType
Declaration Syntax
C# Visual Basic Visual C++
public RefundSourceTypeCodeType RefundType { get; set; }
Public Property RefundType As RefundSourceTypeCodeType
    Get
    Set
public:
property RefundSourceTypeCodeType RefundType {
    RefundSourceTypeCodeType get ();
    void set (RefundSourceTypeCodeType value);
}


RefundTypeSpecified Property

RefundTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoType ► RefundTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundTypeSpecified { get; set; }
Public Property RefundTypeSpecified As Boolean
    Get
    Set
public:
property bool RefundTypeSpecified {
    bool get ();
    void set (bool value);
}


RefundTransactionInfoTypeCollection Class

RefundTransactionInfoTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RefundTransactionInfoTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RefundTransactionInfoTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RefundTransactionInfoTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundTransactionInfoTypeCollection()()()() |
 | RefundTransactionInfoTypeCollection(array<RefundTransactionInfoType>[]()[][]) |
 | RefundTransactionInfoTypeCollection(RefundTransactionInfoTypeCollection) |
 | Add(RefundTransactionInfoType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RefundTransactionInfoType>[]()[][]) |
 | AddRange(RefundTransactionInfoTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RefundTransactionInfoType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RefundTransactionInfoType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RefundTransactionInfoType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RefundTransactionInfoType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RefundTransactionInfoType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RefundTransactionInfoTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► Add(RefundTransactionInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RefundTransactionInfoType item
)
Public Function Add ( _
    item As RefundTransactionInfoType _
) As Integer
public:
int Add(
    RefundTransactionInfoType^ item
)
Parameters
item (RefundTransactionInfoType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RefundTransactionInfoType>[]()[][]) |
 | AddRange(RefundTransactionInfoTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► AddRange(array<RefundTransactionInfoType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundTransactionInfoType[] items
)
Public Sub AddRange ( _
    items As RefundTransactionInfoType() _
)
public:
void AddRange(
    array<RefundTransactionInfoType^>^ items
)
Parameters
items (array< RefundTransactionInfoType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► AddRange(RefundTransactionInfoTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundTransactionInfoTypeCollection items
)
Public Sub AddRange ( _
    items As RefundTransactionInfoTypeCollection _
)
public:
void AddRange(
    RefundTransactionInfoTypeCollection^ items
)
Parameters
items (RefundTransactionInfoTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► Contains(RefundTransactionInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RefundTransactionInfoType item
)
Public Function Contains ( _
    item As RefundTransactionInfoType _
) As Boolean
public:
bool Contains(
    RefundTransactionInfoType^ item
)
Parameters
item (RefundTransactionInfoType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► CopyTo(array<RefundTransactionInfoType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RefundTransactionInfoType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RefundTransactionInfoType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RefundTransactionInfoType^>^ items,
    int index
)
Parameters
items (array< RefundTransactionInfoType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► IndexOf(RefundTransactionInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RefundTransactionInfoType item
)
Public Function IndexOf ( _
    item As RefundTransactionInfoType _
) As Integer
public:
int IndexOf(
    RefundTransactionInfoType^ item
)
Parameters
item (RefundTransactionInfoType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► Insert(Int32, RefundTransactionInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RefundTransactionInfoType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RefundTransactionInfoType _
)
public:
void Insert(
    int index,
    RefundTransactionInfoType^ item
)
Parameters
index (Int32)
item (RefundTransactionInfoType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionInfoType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RefundTransactionInfoType
    Get
    Set
public:
property RefundTransactionInfoType^ default[int index] {
    RefundTransactionInfoType^ get (int index);
    void set (int index, RefundTransactionInfoType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionInfoType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RefundTransactionInfoType
public:
RefundTransactionInfoType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


RefundTransactionInfoTypeCollection Constructor

RefundTransactionInfoTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► RefundTransactionInfoTypeCollection()()()()
Members
Icon | Member | Description
 | RefundTransactionInfoTypeCollection()()()() |
 | RefundTransactionInfoTypeCollection(array<RefundTransactionInfoType>[]()[][]) |
 | RefundTransactionInfoTypeCollection(RefundTransactionInfoTypeCollection) |


RefundTransactionInfoTypeCollection Constructor

RefundTransactionInfoTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► RefundTransactionInfoTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionInfoTypeCollection()
Public Sub New
public:
RefundTransactionInfoTypeCollection()


RefundTransactionInfoTypeCollection Constructor (items)

RefundTransactionInfoTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► RefundTransactionInfoTypeCollection(array<RefundTransactionInfoType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionInfoTypeCollection(
    RefundTransactionInfoType[] items
)
Public Sub New ( _
    items As RefundTransactionInfoType() _
)
public:
RefundTransactionInfoTypeCollection(
    array<RefundTransactionInfoType^>^ items
)
Parameters
items (array< RefundTransactionInfoType >[]()[][])


RefundTransactionInfoTypeCollection Constructor (items)

RefundTransactionInfoTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► RefundTransactionInfoTypeCollection(RefundTransactionInfoTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionInfoTypeCollection(
    RefundTransactionInfoTypeCollection items
)
Public Sub New ( _
    items As RefundTransactionInfoTypeCollection _
)
public:
RefundTransactionInfoTypeCollection(
    RefundTransactionInfoTypeCollection^ items
)
Parameters
items (RefundTransactionInfoTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► Remove(RefundTransactionInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RefundTransactionInfoType item
)
Public Sub Remove ( _
    item As RefundTransactionInfoType _
)
public:
void Remove(
    RefundTransactionInfoType^ item
)
Parameters
item (RefundTransactionInfoType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionInfoType[] ToArray()
Public Function ToArray As RefundTransactionInfoType()
public:
array<RefundTransactionInfoType^>^ ToArray()
Return Value


RefundTransactionType Class

RefundTransactionType Class
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RefundTransactionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RefundTransactionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RefundTransactionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundTransactionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderID |
 | RefundLineArray |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
Remarks
Inheritance Hierarchy
Object
RefundTransactionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionType ► OrderID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


RefundLineArray Property

RefundLineArray Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionType ► RefundLineArray
Declaration Syntax
C# Visual Basic Visual C++
public RefundLineArrayType RefundLineArray { get; set; }
Public Property RefundLineArray As RefundLineArrayType
    Get
    Set
public:
property RefundLineArrayType^ RefundLineArray {
    RefundLineArrayType^ get ();
    void set (RefundLineArrayType^ value);
}


RefundTransactionType Constructor

RefundTransactionType Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionType ► RefundTransactionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionType()
Public Sub New
public:
RefundTransactionType()


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


RefundTransactionTypeCollection Class

RefundTransactionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RefundTransactionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RefundTransactionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RefundTransactionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundTransactionTypeCollection()()()() |
 | RefundTransactionTypeCollection(array<RefundTransactionType>[]()[][]) |
 | RefundTransactionTypeCollection(RefundTransactionTypeCollection) |
 | Add(RefundTransactionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RefundTransactionType>[]()[][]) |
 | AddRange(RefundTransactionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RefundTransactionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RefundTransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RefundTransactionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RefundTransactionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RefundTransactionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RefundTransactionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► Add(RefundTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RefundTransactionType item
)
Public Function Add ( _
    item As RefundTransactionType _
) As Integer
public:
int Add(
    RefundTransactionType^ item
)
Parameters
item (RefundTransactionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RefundTransactionType>[]()[][]) |
 | AddRange(RefundTransactionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► AddRange(array<RefundTransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundTransactionType[] items
)
Public Sub AddRange ( _
    items As RefundTransactionType() _
)
public:
void AddRange(
    array<RefundTransactionType^>^ items
)
Parameters
items (array< RefundTransactionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► AddRange(RefundTransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundTransactionTypeCollection items
)
Public Sub AddRange ( _
    items As RefundTransactionTypeCollection _
)
public:
void AddRange(
    RefundTransactionTypeCollection^ items
)
Parameters
items (RefundTransactionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► Contains(RefundTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RefundTransactionType item
)
Public Function Contains ( _
    item As RefundTransactionType _
) As Boolean
public:
bool Contains(
    RefundTransactionType^ item
)
Parameters
item (RefundTransactionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► CopyTo(array<RefundTransactionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RefundTransactionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RefundTransactionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RefundTransactionType^>^ items,
    int index
)
Parameters
items (array< RefundTransactionType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► IndexOf(RefundTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RefundTransactionType item
)
Public Function IndexOf ( _
    item As RefundTransactionType _
) As Integer
public:
int IndexOf(
    RefundTransactionType^ item
)
Parameters
item (RefundTransactionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► Insert(Int32, RefundTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RefundTransactionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RefundTransactionType _
)
public:
void Insert(
    int index,
    RefundTransactionType^ item
)
Parameters
index (Int32)
item (RefundTransactionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RefundTransactionType
    Get
    Set
public:
property RefundTransactionType^ default[int index] {
    RefundTransactionType^ get (int index);
    void set (int index, RefundTransactionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RefundTransactionType
public:
RefundTransactionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


RefundTransactionTypeCollection Constructor

RefundTransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► RefundTransactionTypeCollection()()()()
Members
Icon | Member | Description
 | RefundTransactionTypeCollection()()()() |
 | RefundTransactionTypeCollection(array<RefundTransactionType>[]()[][]) |
 | RefundTransactionTypeCollection(RefundTransactionTypeCollection) |


RefundTransactionTypeCollection Constructor

RefundTransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► RefundTransactionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionTypeCollection()
Public Sub New
public:
RefundTransactionTypeCollection()


RefundTransactionTypeCollection Constructor (items)

RefundTransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► RefundTransactionTypeCollection(array<RefundTransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionTypeCollection(
    RefundTransactionType[] items
)
Public Sub New ( _
    items As RefundTransactionType() _
)
public:
RefundTransactionTypeCollection(
    array<RefundTransactionType^>^ items
)
Parameters
items (array< RefundTransactionType >[]()[][])


RefundTransactionTypeCollection Constructor (items)

RefundTransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► RefundTransactionTypeCollection(RefundTransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionTypeCollection(
    RefundTransactionTypeCollection items
)
Public Sub New ( _
    items As RefundTransactionTypeCollection _
)
public:
RefundTransactionTypeCollection(
    RefundTransactionTypeCollection^ items
)
Parameters
items (RefundTransactionTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► Remove(RefundTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RefundTransactionType item
)
Public Sub Remove ( _
    item As RefundTransactionType _
)
public:
void Remove(
    RefundTransactionType^ item
)
Parameters
item (RefundTransactionType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionType[] ToArray()
Public Function ToArray As RefundTransactionType()
public:
array<RefundTransactionType^>^ ToArray()
Return Value


RefundType Class

RefundType Class
Namespaces ► eBay.Service.Core.Soap ► RefundType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RefundType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RefundType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RefundType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | EstimatedRefundCompletionTime |
 | EstimatedRefundCompletionTimeSpecified |
 | ExternalReferenceID |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RefundAmount |
 | RefundCompletionTime |
 | RefundCompletionTimeSpecified |
 | RefundFailureReason |
 | RefundFromSeller |
 | RefundFundingSourceArray |
 | RefundID |
 | RefundRequestedTime |
 | RefundRequestedTimeSpecified |
 | RefundStatus |
 | RefundStatusSpecified |
 | RefundTime |
 | RefundTimeSpecified |
 | RefundTransactionArray |
 | SellerNoteToBuyer |
 | ToString()()()() | (Inherited from Object.)
 | TotalRefundToBuyer |
Remarks
Inheritance Hierarchy
Object
RefundType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EstimatedRefundCompletionTime Property

EstimatedRefundCompletionTime Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► EstimatedRefundCompletionTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EstimatedRefundCompletionTime { get; set; }
Public Property EstimatedRefundCompletionTime As DateTime
    Get
    Set
public:
property DateTime EstimatedRefundCompletionTime {
    DateTime get ();
    void set (DateTime value);
}


EstimatedRefundCompletionTimeSpecified Property

EstimatedRefundCompletionTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► EstimatedRefundCompletionTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EstimatedRefundCompletionTimeSpecified { get; set; }
Public Property EstimatedRefundCompletionTimeSpecified As Boolean
    Get
    Set
public:
property bool EstimatedRefundCompletionTimeSpecified {
    bool get ();
    void set (bool value);
}


ExternalReferenceID Property

ExternalReferenceID Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► ExternalReferenceID
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalReferenceID { get; set; }
Public Property ExternalReferenceID As String
    Get
    Set
public:
property String^ ExternalReferenceID {
    String^ get ();
    void set (String^ value);
}


RefundAmount Property

RefundAmount Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType RefundAmount { get; set; }
Public Property RefundAmount As AmountType
    Get
    Set
public:
property AmountType^ RefundAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


RefundCompletionTime Property

RefundCompletionTime Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundCompletionTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RefundCompletionTime { get; set; }
Public Property RefundCompletionTime As DateTime
    Get
    Set
public:
property DateTime RefundCompletionTime {
    DateTime get ();
    void set (DateTime value);
}


RefundCompletionTimeSpecified Property

RefundCompletionTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundCompletionTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundCompletionTimeSpecified { get; set; }
Public Property RefundCompletionTimeSpecified As Boolean
    Get
    Set
public:
property bool RefundCompletionTimeSpecified {
    bool get ();
    void set (bool value);
}


RefundFailureReason Property

RefundFailureReason Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundFailureReason
Declaration Syntax
C# Visual Basic Visual C++
public RefundFailureReasonType RefundFailureReason { get; set; }
Public Property RefundFailureReason As RefundFailureReasonType
    Get
    Set
public:
property RefundFailureReasonType^ RefundFailureReason {
    RefundFailureReasonType^ get ();
    void set (RefundFailureReasonType^ value);
}


RefundFromSeller Property

RefundFromSeller Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundFromSeller
Declaration Syntax
C# Visual Basic Visual C++
public AmountType RefundFromSeller { get; set; }
Public Property RefundFromSeller As AmountType
    Get
    Set
public:
property AmountType^ RefundFromSeller {
    AmountType^ get ();
    void set (AmountType^ value);
}


RefundFundingSourceArray Property

RefundFundingSourceArray Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundFundingSourceArray
Declaration Syntax
C# Visual Basic Visual C++
public RefundFundingSourceArrayType RefundFundingSourceArray { get; set; }
Public Property RefundFundingSourceArray As RefundFundingSourceArrayType
    Get
    Set
public:
property RefundFundingSourceArrayType^ RefundFundingSourceArray {
    RefundFundingSourceArrayType^ get ();
    void set (RefundFundingSourceArrayType^ value);
}


RefundID Property

RefundID Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundID
Declaration Syntax
C# Visual Basic Visual C++
public string RefundID { get; set; }
Public Property RefundID As String
    Get
    Set
public:
property String^ RefundID {
    String^ get ();
    void set (String^ value);
}


RefundRequestedTime Property

RefundRequestedTime Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundRequestedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RefundRequestedTime { get; set; }
Public Property RefundRequestedTime As DateTime
    Get
    Set
public:
property DateTime RefundRequestedTime {
    DateTime get ();
    void set (DateTime value);
}


RefundRequestedTimeSpecified Property

RefundRequestedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundRequestedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundRequestedTimeSpecified { get; set; }
Public Property RefundRequestedTimeSpecified As Boolean
    Get
    Set
public:
property bool RefundRequestedTimeSpecified {
    bool get ();
    void set (bool value);
}


RefundStatus Property

RefundStatus Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundStatus
Declaration Syntax
C# Visual Basic Visual C++
public RefundStatusCodeType RefundStatus { get; set; }
Public Property RefundStatus As RefundStatusCodeType
    Get
    Set
public:
property RefundStatusCodeType RefundStatus {
    RefundStatusCodeType get ();
    void set (RefundStatusCodeType value);
}


RefundStatusSpecified Property

RefundStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundStatusSpecified { get; set; }
Public Property RefundStatusSpecified As Boolean
    Get
    Set
public:
property bool RefundStatusSpecified {
    bool get ();
    void set (bool value);
}


RefundTime Property

RefundTime Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RefundTime { get; set; }
Public Property RefundTime As DateTime
    Get
    Set
public:
property DateTime RefundTime {
    DateTime get ();
    void set (DateTime value);
}


RefundTimeSpecified Property

RefundTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundTimeSpecified { get; set; }
Public Property RefundTimeSpecified As Boolean
    Get
    Set
public:
property bool RefundTimeSpecified {
    bool get ();
    void set (bool value);
}


RefundTransactionArray Property

RefundTransactionArray Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundTransactionArray
Declaration Syntax
C# Visual Basic Visual C++
public RefundTransactionArrayType RefundTransactionArray { get; set; }
Public Property RefundTransactionArray As RefundTransactionArrayType
    Get
    Set
public:
property RefundTransactionArrayType^ RefundTransactionArray {
    RefundTransactionArrayType^ get ();
    void set (RefundTransactionArrayType^ value);
}


RefundType Constructor

RefundType Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundType ► RefundType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundType()
Public Sub New
public:
RefundType()


SellerNoteToBuyer Property

SellerNoteToBuyer Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► SellerNoteToBuyer
Declaration Syntax
C# Visual Basic Visual C++
public string SellerNoteToBuyer { get; set; }
Public Property SellerNoteToBuyer As String
    Get
    Set
public:
property String^ SellerNoteToBuyer {
    String^ get ();
    void set (String^ value);
}


TotalRefundToBuyer Property

TotalRefundToBuyer Property
Namespaces ► eBay.Service.Core.Soap ► RefundType ► TotalRefundToBuyer
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalRefundToBuyer { get; set; }
Public Property TotalRefundToBuyer As AmountType
    Get
    Set
public:
property AmountType^ TotalRefundToBuyer {
    AmountType^ get ();
    void set (AmountType^ value);
}


RefundTypeCodeType Enumeration

RefundTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum RefundTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration RefundTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class RefundTypeCodeType
Members
Member | Description
Full |
FullPlusShipping |
CustomOrPartial |
CustomCode |
Remarks


RefundTypeCollection Class

RefundTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RefundTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RefundTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RefundTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RefundTypeCollection()()()() |
 | RefundTypeCollection(array<RefundType>[]()[][]) |
 | RefundTypeCollection(RefundTypeCollection) |
 | Add(RefundType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RefundType>[]()[][]) |
 | AddRange(RefundTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RefundType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RefundType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RefundType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RefundType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RefundType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RefundTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► Add(RefundType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RefundType item
)
Public Function Add ( _
    item As RefundType _
) As Integer
public:
int Add(
    RefundType^ item
)
Parameters
item (RefundType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RefundType>[]()[][]) |
 | AddRange(RefundTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► AddRange(array<RefundType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundType[] items
)
Public Sub AddRange ( _
    items As RefundType() _
)
public:
void AddRange(
    array<RefundType^>^ items
)
Parameters
items (array< RefundType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► AddRange(RefundTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RefundTypeCollection items
)
Public Sub AddRange ( _
    items As RefundTypeCollection _
)
public:
void AddRange(
    RefundTypeCollection^ items
)
Parameters
items (RefundTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► Contains(RefundType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RefundType item
)
Public Function Contains ( _
    item As RefundType _
) As Boolean
public:
bool Contains(
    RefundType^ item
)
Parameters
item (RefundType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► CopyTo(array<RefundType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RefundType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RefundType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RefundType^>^ items,
    int index
)
Parameters
items (array< RefundType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► IndexOf(RefundType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RefundType item
)
Public Function IndexOf ( _
    item As RefundType _
) As Integer
public:
int IndexOf(
    RefundType^ item
)
Parameters
item (RefundType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► Insert(Int32, RefundType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RefundType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RefundType _
)
public:
void Insert(
    int index,
    RefundType^ item
)
Parameters
index (Int32)
item (RefundType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RefundType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RefundType
    Get
    Set
public:
property RefundType^ default[int index] {
    RefundType^ get (int index);
    void set (int index, RefundType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RefundType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RefundType
public:
RefundType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


RefundTypeCollection Constructor

RefundTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► RefundTypeCollection()()()()
Members
Icon | Member | Description
 | RefundTypeCollection()()()() |
 | RefundTypeCollection(array<RefundType>[]()[][]) |
 | RefundTypeCollection(RefundTypeCollection) |


RefundTypeCollection Constructor

RefundTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► RefundTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundTypeCollection()
Public Sub New
public:
RefundTypeCollection()


RefundTypeCollection Constructor (items)

RefundTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► RefundTypeCollection(array<RefundType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RefundTypeCollection(
    RefundType[] items
)
Public Sub New ( _
    items As RefundType() _
)
public:
RefundTypeCollection(
    array<RefundType^>^ items
)
Parameters
items (array< RefundType >[]()[][])


RefundTypeCollection Constructor (items)

RefundTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► RefundTypeCollection(RefundTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RefundTypeCollection(
    RefundTypeCollection items
)
Public Sub New ( _
    items As RefundTypeCollection _
)
public:
RefundTypeCollection(
    RefundTypeCollection^ items
)
Parameters
items (RefundTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► Remove(RefundType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RefundType item
)
Public Sub Remove ( _
    item As RefundType _
)
public:
void Remove(
    RefundType^ item
)
Parameters
item (RefundType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RefundType[] ToArray()
Public Function ToArray As RefundType()
public:
array<RefundType^>^ ToArray()
Return Value


RegionDetailsType Class

RegionDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RegionDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RegionDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RegionDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegionDetailsType()()()() |
 | Any |
 | Description |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RegionID |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
RegionDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


RegionDetailsType Constructor

RegionDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsType ► RegionDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RegionDetailsType()
Public Sub New
public:
RegionDetailsType()


RegionID Property

RegionID Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsType ► RegionID
Declaration Syntax
C# Visual Basic Visual C++
public string RegionID { get; set; }
Public Property RegionID As String
    Get
    Set
public:
property String^ RegionID {
    String^ get ();
    void set (String^ value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


RegionDetailsTypeCollection Class

RegionDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RegionDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RegionDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RegionDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegionDetailsTypeCollection()()()() |
 | RegionDetailsTypeCollection(array<RegionDetailsType>[]()[][]) |
 | RegionDetailsTypeCollection(RegionDetailsTypeCollection) |
 | Add(RegionDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RegionDetailsType>[]()[][]) |
 | AddRange(RegionDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RegionDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RegionDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RegionDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RegionDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RegionDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RegionDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► Add(RegionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RegionDetailsType item
)
Public Function Add ( _
    item As RegionDetailsType _
) As Integer
public:
int Add(
    RegionDetailsType^ item
)
Parameters
item (RegionDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RegionDetailsType>[]()[][]) |
 | AddRange(RegionDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► AddRange(array<RegionDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RegionDetailsType[] items
)
Public Sub AddRange ( _
    items As RegionDetailsType() _
)
public:
void AddRange(
    array<RegionDetailsType^>^ items
)
Parameters
items (array< RegionDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► AddRange(RegionDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RegionDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As RegionDetailsTypeCollection _
)
public:
void AddRange(
    RegionDetailsTypeCollection^ items
)
Parameters
items (RegionDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► Contains(RegionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RegionDetailsType item
)
Public Function Contains ( _
    item As RegionDetailsType _
) As Boolean
public:
bool Contains(
    RegionDetailsType^ item
)
Parameters
item (RegionDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► CopyTo(array<RegionDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RegionDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RegionDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RegionDetailsType^>^ items,
    int index
)
Parameters
items (array< RegionDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► IndexOf(RegionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RegionDetailsType item
)
Public Function IndexOf ( _
    item As RegionDetailsType _
) As Integer
public:
int IndexOf(
    RegionDetailsType^ item
)
Parameters
item (RegionDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► Insert(Int32, RegionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RegionDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RegionDetailsType _
)
public:
void Insert(
    int index,
    RegionDetailsType^ item
)
Parameters
index (Int32)
item (RegionDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RegionDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RegionDetailsType
    Get
    Set
public:
property RegionDetailsType^ default[int index] {
    RegionDetailsType^ get (int index);
    void set (int index, RegionDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RegionDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RegionDetailsType
public:
RegionDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


RegionDetailsTypeCollection Constructor

RegionDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► RegionDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | RegionDetailsTypeCollection()()()() |
 | RegionDetailsTypeCollection(array<RegionDetailsType>[]()[][]) |
 | RegionDetailsTypeCollection(RegionDetailsTypeCollection) |


RegionDetailsTypeCollection Constructor

RegionDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► RegionDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RegionDetailsTypeCollection()
Public Sub New
public:
RegionDetailsTypeCollection()


RegionDetailsTypeCollection Constructor (items)

RegionDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► RegionDetailsTypeCollection(array<RegionDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RegionDetailsTypeCollection(
    RegionDetailsType[] items
)
Public Sub New ( _
    items As RegionDetailsType() _
)
public:
RegionDetailsTypeCollection(
    array<RegionDetailsType^>^ items
)
Parameters
items (array< RegionDetailsType >[]()[][])


RegionDetailsTypeCollection Constructor (items)

RegionDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► RegionDetailsTypeCollection(RegionDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RegionDetailsTypeCollection(
    RegionDetailsTypeCollection items
)
Public Sub New ( _
    items As RegionDetailsTypeCollection _
)
public:
RegionDetailsTypeCollection(
    RegionDetailsTypeCollection^ items
)
Parameters
items (RegionDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► Remove(RegionDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RegionDetailsType item
)
Public Sub Remove ( _
    item As RegionDetailsType _
)
public:
void Remove(
    RegionDetailsType^ item
)
Parameters
item (RegionDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RegionDetailsType[] ToArray()
Public Function ToArray As RegionDetailsType()
public:
array<RegionDetailsType^>^ ToArray()
Return Value


RegionOfOriginDetailsType Class

RegionOfOriginDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RegionOfOriginDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RegionOfOriginDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RegionOfOriginDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegionOfOriginDetailsType()()()() |
 | Any |
 | Description |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RegionOfOrigin |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
RegionOfOriginDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


RegionOfOrigin Property

RegionOfOrigin Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsType ► RegionOfOrigin
Declaration Syntax
C# Visual Basic Visual C++
public string RegionOfOrigin { get; set; }
Public Property RegionOfOrigin As String
    Get
    Set
public:
property String^ RegionOfOrigin {
    String^ get ();
    void set (String^ value);
}


RegionOfOriginDetailsType Constructor

RegionOfOriginDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsType ► RegionOfOriginDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RegionOfOriginDetailsType()
Public Sub New
public:
RegionOfOriginDetailsType()


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public StatusCodeType Status { get; set; }
Public Property Status As StatusCodeType
    Get
    Set
public:
property StatusCodeType Status {
    StatusCodeType get ();
    void set (StatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


RegionOfOriginDetailsTypeCollection Class

RegionOfOriginDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RegionOfOriginDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RegionOfOriginDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RegionOfOriginDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegionOfOriginDetailsTypeCollection()()()() |
 | RegionOfOriginDetailsTypeCollection(array<RegionOfOriginDetailsType>[]()[][]) |
 | RegionOfOriginDetailsTypeCollection(RegionOfOriginDetailsTypeCollection) |
 | Add(RegionOfOriginDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RegionOfOriginDetailsType>[]()[][]) |
 | AddRange(RegionOfOriginDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RegionOfOriginDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RegionOfOriginDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RegionOfOriginDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RegionOfOriginDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RegionOfOriginDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RegionOfOriginDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► Add(RegionOfOriginDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RegionOfOriginDetailsType item
)
Public Function Add ( _
    item As RegionOfOriginDetailsType _
) As Integer
public:
int Add(
    RegionOfOriginDetailsType^ item
)
Parameters
item (RegionOfOriginDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RegionOfOriginDetailsType>[]()[][]) |
 | AddRange(RegionOfOriginDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► AddRange(array<RegionOfOriginDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RegionOfOriginDetailsType[] items
)
Public Sub AddRange ( _
    items As RegionOfOriginDetailsType() _
)
public:
void AddRange(
    array<RegionOfOriginDetailsType^>^ items
)
Parameters
items (array< RegionOfOriginDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► AddRange(RegionOfOriginDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RegionOfOriginDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As RegionOfOriginDetailsTypeCollection _
)
public:
void AddRange(
    RegionOfOriginDetailsTypeCollection^ items
)
Parameters
items (RegionOfOriginDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► Contains(RegionOfOriginDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RegionOfOriginDetailsType item
)
Public Function Contains ( _
    item As RegionOfOriginDetailsType _
) As Boolean
public:
bool Contains(
    RegionOfOriginDetailsType^ item
)
Parameters
item (RegionOfOriginDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► CopyTo(array<RegionOfOriginDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RegionOfOriginDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RegionOfOriginDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RegionOfOriginDetailsType^>^ items,
    int index
)
Parameters
items (array< RegionOfOriginDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► IndexOf(RegionOfOriginDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RegionOfOriginDetailsType item
)
Public Function IndexOf ( _
    item As RegionOfOriginDetailsType _
) As Integer
public:
int IndexOf(
    RegionOfOriginDetailsType^ item
)
Parameters
item (RegionOfOriginDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► Insert(Int32, RegionOfOriginDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RegionOfOriginDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RegionOfOriginDetailsType _
)
public:
void Insert(
    int index,
    RegionOfOriginDetailsType^ item
)
Parameters
index (Int32)
item (RegionOfOriginDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RegionOfOriginDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RegionOfOriginDetailsType
    Get
    Set
public:
property RegionOfOriginDetailsType^ default[int index] {
    RegionOfOriginDetailsType^ get (int index);
    void set (int index, RegionOfOriginDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RegionOfOriginDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RegionOfOriginDetailsType
public:
RegionOfOriginDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


RegionOfOriginDetailsTypeCollection Constructor

RegionOfOriginDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► RegionOfOriginDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | RegionOfOriginDetailsTypeCollection()()()() |
 | RegionOfOriginDetailsTypeCollection(array<RegionOfOriginDetailsType>[]()[][]) |
 | RegionOfOriginDetailsTypeCollection(RegionOfOriginDetailsTypeCollection) |


RegionOfOriginDetailsTypeCollection Constructor

RegionOfOriginDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► RegionOfOriginDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RegionOfOriginDetailsTypeCollection()
Public Sub New
public:
RegionOfOriginDetailsTypeCollection()


RegionOfOriginDetailsTypeCollection Constructor (items)

RegionOfOriginDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► RegionOfOriginDetailsTypeCollection(array<RegionOfOriginDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RegionOfOriginDetailsTypeCollection(
    RegionOfOriginDetailsType[] items
)
Public Sub New ( _
    items As RegionOfOriginDetailsType() _
)
public:
RegionOfOriginDetailsTypeCollection(
    array<RegionOfOriginDetailsType^>^ items
)
Parameters
items (array< RegionOfOriginDetailsType >[]()[][])


RegionOfOriginDetailsTypeCollection Constructor (items)

RegionOfOriginDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► RegionOfOriginDetailsTypeCollection(RegionOfOriginDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RegionOfOriginDetailsTypeCollection(
    RegionOfOriginDetailsTypeCollection items
)
Public Sub New ( _
    items As RegionOfOriginDetailsTypeCollection _
)
public:
RegionOfOriginDetailsTypeCollection(
    RegionOfOriginDetailsTypeCollection^ items
)
Parameters
items (RegionOfOriginDetailsTypeCollection)


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► Remove(RegionOfOriginDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RegionOfOriginDetailsType item
)
Public Sub Remove ( _
    item As RegionOfOriginDetailsType _
)
public:
void Remove(
    RegionOfOriginDetailsType^ item
)
Parameters
item (RegionOfOriginDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RegionOfOriginDetailsType[] ToArray()
Public Function ToArray As RegionOfOriginDetailsType()
public:
array<RegionOfOriginDetailsType^>^ ToArray()
Return Value


RegularSubscriptionDefinitionType Class

RegularSubscriptionDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► RegularSubscriptionDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RegularSubscriptionDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RegularSubscriptionDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RegularSubscriptionDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegularSubscriptionDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RegularSubscriptionDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RegularSubscriptionDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


RegularSubscriptionDefinitionType Constructor

RegularSubscriptionDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► RegularSubscriptionDefinitionType ► RegularSubscriptionDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RegularSubscriptionDefinitionType()
Public Sub New
public:
RegularSubscriptionDefinitionType()


RelistFixedPriceItemRequestType Class

RelistFixedPriceItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RelistFixedPriceItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RelistFixedPriceItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RelistFixedPriceItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RelistFixedPriceItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DeletedField |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | RelistFixedPriceItemRequestType


DeletedField Property

DeletedField Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemRequestType ► DeletedField
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedField { get; set; }
Public Property DeletedField As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedField {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


RelistFixedPriceItemRequestType Constructor

RelistFixedPriceItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemRequestType ► RelistFixedPriceItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RelistFixedPriceItemRequestType()
Public Sub New
public:
RelistFixedPriceItemRequestType()


RelistFixedPriceItemResponseType Class

RelistFixedPriceItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RelistFixedPriceItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RelistFixedPriceItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RelistFixedPriceItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RelistFixedPriceItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category2ID |
 | CategoryID |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DiscountReason |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | ListingRecommendations |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | ProductSuggestions |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SKU |
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | RelistFixedPriceItemResponseType


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; set; }
Public Property Category2ID As String
    Get
    Set
public:
property String^ Category2ID {
    String^ get ();
    void set (String^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


DiscountReason Property

DiscountReason Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► DiscountReason
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReason { get; set; }
Public Property DiscountReason As DiscountReasonCodeTypeCollection
    Get
    Set
public:
property DiscountReasonCodeTypeCollection^ DiscountReason {
    DiscountReasonCodeTypeCollection^ get ();
    void set (DiscountReasonCodeTypeCollection^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► ListingRecommendations
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; set; }
Public Property ListingRecommendations As ListingRecommendationsType
    Get
    Set
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
    void set (ListingRecommendationsType^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► ProductSuggestions
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; set; }
Public Property ProductSuggestions As ProductSuggestionsType
    Get
    Set
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
    void set (ProductSuggestionsType^ value);
}


RelistFixedPriceItemResponseType Constructor

RelistFixedPriceItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► RelistFixedPriceItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RelistFixedPriceItemResponseType()
Public Sub New
public:
RelistFixedPriceItemResponseType()


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RelistFixedPriceItemResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


RelistItemRequestType Class

RelistItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► RelistItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RelistItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RelistItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RelistItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RelistItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DeletedField |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | RelistItemRequestType


DeletedField Property

DeletedField Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemRequestType ► DeletedField
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedField { get; set; }
Public Property DeletedField As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedField {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


RelistItemRequestType Constructor

RelistItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► RelistItemRequestType ► RelistItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RelistItemRequestType()
Public Sub New
public:
RelistItemRequestType()


RelistItemResponseType Class

RelistItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RelistItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RelistItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RelistItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RelistItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category2ID |
 | CategoryID |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DiscountReason |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | ListingRecommendations |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | ProductSuggestions |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | RelistItemResponseType


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; set; }
Public Property Category2ID As String
    Get
    Set
public:
property String^ Category2ID {
    String^ get ();
    void set (String^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


DiscountReason Property

DiscountReason Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► DiscountReason
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReason { get; set; }
Public Property DiscountReason As DiscountReasonCodeTypeCollection
    Get
    Set
public:
property DiscountReasonCodeTypeCollection^ DiscountReason {
    DiscountReasonCodeTypeCollection^ get ();
    void set (DiscountReasonCodeTypeCollection^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► ListingRecommendations
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; set; }
Public Property ListingRecommendations As ListingRecommendationsType
    Get
    Set
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
    void set (ListingRecommendationsType^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► ProductSuggestions
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; set; }
Public Property ProductSuggestions As ProductSuggestionsType
    Get
    Set
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
    void set (ProductSuggestionsType^ value);
}


RelistItemResponseType Constructor

RelistItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► RelistItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RelistItemResponseType()
Public Sub New
public:
RelistItemResponseType()


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RelistItemResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


ReminderCustomizationType Class

ReminderCustomizationType Class
Namespaces ► eBay.Service.Core.Soap ► ReminderCustomizationType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReminderCustomizationType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReminderCustomizationType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReminderCustomizationType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReminderCustomizationType()()()() |
 | DurationInDays |
 | DurationInDaysSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Include |
 | IncludeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ReminderCustomizationType


DurationInDays Property

DurationInDays Property
Namespaces ► eBay.Service.Core.Soap ► ReminderCustomizationType ► DurationInDays
Declaration Syntax
C# Visual Basic Visual C++
public int DurationInDays { get; set; }
Public Property DurationInDays As Integer
    Get
    Set
public:
property int DurationInDays {
    int get ();
    void set (int value);
}


DurationInDaysSpecified Property

DurationInDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReminderCustomizationType ► DurationInDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DurationInDaysSpecified { get; set; }
Public Property DurationInDaysSpecified As Boolean
    Get
    Set
public:
property bool DurationInDaysSpecified {
    bool get ();
    void set (bool value);
}


Include Property

Include Property
Namespaces ► eBay.Service.Core.Soap ► ReminderCustomizationType ► Include
Declaration Syntax
C# Visual Basic Visual C++
public bool Include { get; set; }
Public Property Include As Boolean
    Get
    Set
public:
property bool Include {
    bool get ();
    void set (bool value);
}


IncludeSpecified Property

IncludeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReminderCustomizationType ► IncludeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeSpecified { get; set; }
Public Property IncludeSpecified As Boolean
    Get
    Set
public:
property bool IncludeSpecified {
    bool get ();
    void set (bool value);
}


ReminderCustomizationType Constructor

ReminderCustomizationType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReminderCustomizationType ► ReminderCustomizationType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReminderCustomizationType()
Public Sub New
public:
ReminderCustomizationType()


RemindersType Class

RemindersType Class
Namespaces ► eBay.Service.Core.Soap ► RemindersType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RemindersType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RemindersType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RemindersType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RemindersType()()()() |
 | Any |
 | DeclinedRTERequestCount |
 | DeclinedRTERequestCountSpecified |
 | DocsForCCProcessingToSendCount |
 | DocsForCCProcessingToSendCountSpecified |
 | Equals(Object) | (Inherited from Object.)
 | FeedbackToReceiveCount |
 | FeedbackToReceiveCountSpecified |
 | FeedbackToSendCount |
 | FeedbackToSendCountSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemReceiptConfirmationToReceiveCount |
 | ItemReceiptConfirmationToReceiveCountSpecified |
 | ItemReceiptToConfirmCount |
 | ItemReceiptToConfirmCountSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OutbidCount |
 | OutbidCountSpecified |
 | PaymentToReceiveCount |
 | PaymentToReceiveCountSpecified |
 | PaymentToSendCount |
 | PaymentToSendCountSpecified |
 | PendingRTERequestCount |
 | PendingRTERequestCountSpecified |
 | RefundCancelledCount |
 | RefundCancelledCountSpecified |
 | RefundInitiatedCount |
 | RefundInitiatedCountSpecified |
 | RefundOnHoldCount |
 | RefundOnHoldCountSpecified |
 | RelistingNeededCount |
 | RelistingNeededCountSpecified |
 | RTEToProcessCount |
 | RTEToProcessCountSpecified |
 | SecondChanceOfferCount |
 | SecondChanceOfferCountSpecified |
 | ShippingDetailsToBeProvidedCount |
 | ShippingDetailsToBeProvidedCountSpecified |
 | ShippingNeededCount |
 | ShippingNeededCountSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TotalNewLeadsCount |
 | TotalNewLeadsCountSpecified |
Remarks
Inheritance Hierarchy
Object
RemindersType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DeclinedRTERequestCount Property

DeclinedRTERequestCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► DeclinedRTERequestCount
Declaration Syntax
C# Visual Basic Visual C++
public int DeclinedRTERequestCount { get; set; }
Public Property DeclinedRTERequestCount As Integer
    Get
    Set
public:
property int DeclinedRTERequestCount {
    int get ();
    void set (int value);
}


DeclinedRTERequestCountSpecified Property

DeclinedRTERequestCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► DeclinedRTERequestCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeclinedRTERequestCountSpecified { get; set; }
Public Property DeclinedRTERequestCountSpecified As Boolean
    Get
    Set
public:
property bool DeclinedRTERequestCountSpecified {
    bool get ();
    void set (bool value);
}


DocsForCCProcessingToSendCount Property

DocsForCCProcessingToSendCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► DocsForCCProcessingToSendCount
Declaration Syntax
C# Visual Basic Visual C++
public int DocsForCCProcessingToSendCount { get; set; }
Public Property DocsForCCProcessingToSendCount As Integer
    Get
    Set
public:
property int DocsForCCProcessingToSendCount {
    int get ();
    void set (int value);
}


DocsForCCProcessingToSendCountSpecified Property

DocsForCCProcessingToSendCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► DocsForCCProcessingToSendCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DocsForCCProcessingToSendCountSpecified { get; set; }
Public Property DocsForCCProcessingToSendCountSpecified As Boolean
    Get
    Set
public:
property bool DocsForCCProcessingToSendCountSpecified {
    bool get ();
    void set (bool value);
}


FeedbackToReceiveCount Property

FeedbackToReceiveCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► FeedbackToReceiveCount
Declaration Syntax
C# Visual Basic Visual C++
public int FeedbackToReceiveCount { get; set; }
Public Property FeedbackToReceiveCount As Integer
    Get
    Set
public:
property int FeedbackToReceiveCount {
    int get ();
    void set (int value);
}


FeedbackToReceiveCountSpecified Property

FeedbackToReceiveCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► FeedbackToReceiveCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackToReceiveCountSpecified { get; set; }
Public Property FeedbackToReceiveCountSpecified As Boolean
    Get
    Set
public:
property bool FeedbackToReceiveCountSpecified {
    bool get ();
    void set (bool value);
}


FeedbackToSendCount Property

FeedbackToSendCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► FeedbackToSendCount
Declaration Syntax
C# Visual Basic Visual C++
public int FeedbackToSendCount { get; set; }
Public Property FeedbackToSendCount As Integer
    Get
    Set
public:
property int FeedbackToSendCount {
    int get ();
    void set (int value);
}


FeedbackToSendCountSpecified Property

FeedbackToSendCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► FeedbackToSendCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackToSendCountSpecified { get; set; }
Public Property FeedbackToSendCountSpecified As Boolean
    Get
    Set
public:
property bool FeedbackToSendCountSpecified {
    bool get ();
    void set (bool value);
}


ItemReceiptConfirmationToReceiveCount Property

ItemReceiptConfirmationToReceiveCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► ItemReceiptConfirmationToReceiveCount
Declaration Syntax
C# Visual Basic Visual C++
public int ItemReceiptConfirmationToReceiveCount { get; set; }
Public Property ItemReceiptConfirmationToReceiveCount As Integer
    Get
    Set
public:
property int ItemReceiptConfirmationToReceiveCount {
    int get ();
    void set (int value);
}


ItemReceiptConfirmationToReceiveCountSpecified Property

ItemReceiptConfirmationToReceiveCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► ItemReceiptConfirmationToReceiveCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemReceiptConfirmationToReceiveCountSpecified { get; set; }
Public Property ItemReceiptConfirmationToReceiveCountSpecified As Boolean
    Get
    Set
public:
property bool ItemReceiptConfirmationToReceiveCountSpecified {
    bool get ();
    void set (bool value);
}


ItemReceiptToConfirmCount Property

ItemReceiptToConfirmCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► ItemReceiptToConfirmCount
Declaration Syntax
C# Visual Basic Visual C++
public int ItemReceiptToConfirmCount { get; set; }
Public Property ItemReceiptToConfirmCount As Integer
    Get
    Set
public:
property int ItemReceiptToConfirmCount {
    int get ();
    void set (int value);
}


ItemReceiptToConfirmCountSpecified Property

ItemReceiptToConfirmCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► ItemReceiptToConfirmCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemReceiptToConfirmCountSpecified { get; set; }
Public Property ItemReceiptToConfirmCountSpecified As Boolean
    Get
    Set
public:
property bool ItemReceiptToConfirmCountSpecified {
    bool get ();
    void set (bool value);
}


OutbidCount Property

OutbidCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► OutbidCount
Declaration Syntax
C# Visual Basic Visual C++
public int OutbidCount { get; set; }
Public Property OutbidCount As Integer
    Get
    Set
public:
property int OutbidCount {
    int get ();
    void set (int value);
}


OutbidCountSpecified Property

OutbidCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► OutbidCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OutbidCountSpecified { get; set; }
Public Property OutbidCountSpecified As Boolean
    Get
    Set
public:
property bool OutbidCountSpecified {
    bool get ();
    void set (bool value);
}


PaymentToReceiveCount Property

PaymentToReceiveCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► PaymentToReceiveCount
Declaration Syntax
C# Visual Basic Visual C++
public int PaymentToReceiveCount { get; set; }
Public Property PaymentToReceiveCount As Integer
    Get
    Set
public:
property int PaymentToReceiveCount {
    int get ();
    void set (int value);
}


PaymentToReceiveCountSpecified Property

PaymentToReceiveCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► PaymentToReceiveCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentToReceiveCountSpecified { get; set; }
Public Property PaymentToReceiveCountSpecified As Boolean
    Get
    Set
public:
property bool PaymentToReceiveCountSpecified {
    bool get ();
    void set (bool value);
}


PaymentToSendCount Property

PaymentToSendCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► PaymentToSendCount
Declaration Syntax
C# Visual Basic Visual C++
public int PaymentToSendCount { get; set; }
Public Property PaymentToSendCount As Integer
    Get
    Set
public:
property int PaymentToSendCount {
    int get ();
    void set (int value);
}


PaymentToSendCountSpecified Property

PaymentToSendCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► PaymentToSendCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentToSendCountSpecified { get; set; }
Public Property PaymentToSendCountSpecified As Boolean
    Get
    Set
public:
property bool PaymentToSendCountSpecified {
    bool get ();
    void set (bool value);
}


PendingRTERequestCount Property

PendingRTERequestCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► PendingRTERequestCount
Declaration Syntax
C# Visual Basic Visual C++
public int PendingRTERequestCount { get; set; }
Public Property PendingRTERequestCount As Integer
    Get
    Set
public:
property int PendingRTERequestCount {
    int get ();
    void set (int value);
}


PendingRTERequestCountSpecified Property

PendingRTERequestCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► PendingRTERequestCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PendingRTERequestCountSpecified { get; set; }
Public Property PendingRTERequestCountSpecified As Boolean
    Get
    Set
public:
property bool PendingRTERequestCountSpecified {
    bool get ();
    void set (bool value);
}


RefundCancelledCount Property

RefundCancelledCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► RefundCancelledCount
Declaration Syntax
C# Visual Basic Visual C++
public int RefundCancelledCount { get; set; }
Public Property RefundCancelledCount As Integer
    Get
    Set
public:
property int RefundCancelledCount {
    int get ();
    void set (int value);
}


RefundCancelledCountSpecified Property

RefundCancelledCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► RefundCancelledCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundCancelledCountSpecified { get; set; }
Public Property RefundCancelledCountSpecified As Boolean
    Get
    Set
public:
property bool RefundCancelledCountSpecified {
    bool get ();
    void set (bool value);
}


RefundInitiatedCount Property

RefundInitiatedCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► RefundInitiatedCount
Declaration Syntax
C# Visual Basic Visual C++
public int RefundInitiatedCount { get; set; }
Public Property RefundInitiatedCount As Integer
    Get
    Set
public:
property int RefundInitiatedCount {
    int get ();
    void set (int value);
}


RefundInitiatedCountSpecified Property

RefundInitiatedCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► RefundInitiatedCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundInitiatedCountSpecified { get; set; }
Public Property RefundInitiatedCountSpecified As Boolean
    Get
    Set
public:
property bool RefundInitiatedCountSpecified {
    bool get ();
    void set (bool value);
}


RefundOnHoldCount Property

RefundOnHoldCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► RefundOnHoldCount
Declaration Syntax
C# Visual Basic Visual C++
public int RefundOnHoldCount { get; set; }
Public Property RefundOnHoldCount As Integer
    Get
    Set
public:
property int RefundOnHoldCount {
    int get ();
    void set (int value);
}


RefundOnHoldCountSpecified Property

RefundOnHoldCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► RefundOnHoldCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundOnHoldCountSpecified { get; set; }
Public Property RefundOnHoldCountSpecified As Boolean
    Get
    Set
public:
property bool RefundOnHoldCountSpecified {
    bool get ();
    void set (bool value);
}


RelistingNeededCount Property

RelistingNeededCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► RelistingNeededCount
Declaration Syntax
C# Visual Basic Visual C++
public int RelistingNeededCount { get; set; }
Public Property RelistingNeededCount As Integer
    Get
    Set
public:
property int RelistingNeededCount {
    int get ();
    void set (int value);
}


RelistingNeededCountSpecified Property

RelistingNeededCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► RelistingNeededCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RelistingNeededCountSpecified { get; set; }
Public Property RelistingNeededCountSpecified As Boolean
    Get
    Set
public:
property bool RelistingNeededCountSpecified {
    bool get ();
    void set (bool value);
}


RemindersType Constructor

RemindersType Constructor
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► RemindersType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RemindersType()
Public Sub New
public:
RemindersType()


RTEToProcessCount Property

RTEToProcessCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► RTEToProcessCount
Declaration Syntax
C# Visual Basic Visual C++
public int RTEToProcessCount { get; set; }
Public Property RTEToProcessCount As Integer
    Get
    Set
public:
property int RTEToProcessCount {
    int get ();
    void set (int value);
}


RTEToProcessCountSpecified Property

RTEToProcessCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► RTEToProcessCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RTEToProcessCountSpecified { get; set; }
Public Property RTEToProcessCountSpecified As Boolean
    Get
    Set
public:
property bool RTEToProcessCountSpecified {
    bool get ();
    void set (bool value);
}


SecondChanceOfferCount Property

SecondChanceOfferCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► SecondChanceOfferCount
Declaration Syntax
C# Visual Basic Visual C++
public int SecondChanceOfferCount { get; set; }
Public Property SecondChanceOfferCount As Integer
    Get
    Set
public:
property int SecondChanceOfferCount {
    int get ();
    void set (int value);
}


SecondChanceOfferCountSpecified Property

SecondChanceOfferCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► SecondChanceOfferCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SecondChanceOfferCountSpecified { get; set; }
Public Property SecondChanceOfferCountSpecified As Boolean
    Get
    Set
public:
property bool SecondChanceOfferCountSpecified {
    bool get ();
    void set (bool value);
}


ShippingDetailsToBeProvidedCount Property

ShippingDetailsToBeProvidedCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► ShippingDetailsToBeProvidedCount
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingDetailsToBeProvidedCount { get; set; }
Public Property ShippingDetailsToBeProvidedCount As Integer
    Get
    Set
public:
property int ShippingDetailsToBeProvidedCount {
    int get ();
    void set (int value);
}


ShippingDetailsToBeProvidedCountSpecified Property

ShippingDetailsToBeProvidedCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► ShippingDetailsToBeProvidedCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingDetailsToBeProvidedCountSpecified { get; set; }
Public Property ShippingDetailsToBeProvidedCountSpecified As Boolean
    Get
    Set
public:
property bool ShippingDetailsToBeProvidedCountSpecified {
    bool get ();
    void set (bool value);
}


ShippingNeededCount Property

ShippingNeededCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► ShippingNeededCount
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingNeededCount { get; set; }
Public Property ShippingNeededCount As Integer
    Get
    Set
public:
property int ShippingNeededCount {
    int get ();
    void set (int value);
}


ShippingNeededCountSpecified Property

ShippingNeededCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► ShippingNeededCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingNeededCountSpecified { get; set; }
Public Property ShippingNeededCountSpecified As Boolean
    Get
    Set
public:
property bool ShippingNeededCountSpecified {
    bool get ();
    void set (bool value);
}


TotalNewLeadsCount Property

TotalNewLeadsCount Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► TotalNewLeadsCount
Declaration Syntax
C# Visual Basic Visual C++
public int TotalNewLeadsCount { get; set; }
Public Property TotalNewLeadsCount As Integer
    Get
    Set
public:
property int TotalNewLeadsCount {
    int get ();
    void set (int value);
}


TotalNewLeadsCountSpecified Property

TotalNewLeadsCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemindersType ► TotalNewLeadsCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalNewLeadsCountSpecified { get; set; }
Public Property TotalNewLeadsCountSpecified As Boolean
    Get
    Set
public:
property bool TotalNewLeadsCountSpecified {
    bool get ();
    void set (bool value);
}


RemoveFromWatchListRequestType Class

RemoveFromWatchListRequestType Class
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RemoveFromWatchListRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RemoveFromWatchListRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RemoveFromWatchListRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RemoveFromWatchListRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | RemoveAllItems |
 | RemoveAllItemsSpecified |
 | ToString()()()() | (Inherited from Object.)
 | VariationKey |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | RemoveFromWatchListRequestType


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ItemID { get; set; }
Public Property ItemID As StringCollection
    Get
    Set
public:
property StringCollection^ ItemID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


RemoveAllItems Property

RemoveAllItems Property
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListRequestType ► RemoveAllItems
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveAllItems { get; set; }
Public Property RemoveAllItems As Boolean
    Get
    Set
public:
property bool RemoveAllItems {
    bool get ();
    void set (bool value);
}


RemoveAllItemsSpecified Property

RemoveAllItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListRequestType ► RemoveAllItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveAllItemsSpecified { get; set; }
Public Property RemoveAllItemsSpecified As Boolean
    Get
    Set
public:
property bool RemoveAllItemsSpecified {
    bool get ();
    void set (bool value);
}


RemoveFromWatchListRequestType Constructor

RemoveFromWatchListRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListRequestType ► RemoveFromWatchListRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RemoveFromWatchListRequestType()
Public Sub New
public:
RemoveFromWatchListRequestType()


VariationKey Property

VariationKey Property
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListRequestType ► VariationKey
Declaration Syntax
C# Visual Basic Visual C++
public VariationKeyTypeCollection VariationKey { get; set; }
Public Property VariationKey As VariationKeyTypeCollection
    Get
    Set
public:
property VariationKeyTypeCollection^ VariationKey {
    VariationKeyTypeCollection^ get ();
    void set (VariationKeyTypeCollection^ value);
}


RemoveFromWatchListResponseType Class

RemoveFromWatchListResponseType Class
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RemoveFromWatchListResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RemoveFromWatchListResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RemoveFromWatchListResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RemoveFromWatchListResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
 | WatchListCount |
 | WatchListCountSpecified |
 | WatchListMaximum |
 | WatchListMaximumSpecified |
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | RemoveFromWatchListResponseType


RemoveFromWatchListResponseType Constructor

RemoveFromWatchListResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListResponseType ► RemoveFromWatchListResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RemoveFromWatchListResponseType()
Public Sub New
public:
RemoveFromWatchListResponseType()


WatchListCount Property

WatchListCount Property
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListResponseType ► WatchListCount
Declaration Syntax
C# Visual Basic Visual C++
public int WatchListCount { get; set; }
Public Property WatchListCount As Integer
    Get
    Set
public:
property int WatchListCount {
    int get ();
    void set (int value);
}


WatchListCountSpecified Property

WatchListCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListResponseType ► WatchListCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WatchListCountSpecified { get; set; }
Public Property WatchListCountSpecified As Boolean
    Get
    Set
public:
property bool WatchListCountSpecified {
    bool get ();
    void set (bool value);
}


WatchListMaximum Property

WatchListMaximum Property
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListResponseType ► WatchListMaximum
Declaration Syntax
C# Visual Basic Visual C++
public int WatchListMaximum { get; set; }
Public Property WatchListMaximum As Integer
    Get
    Set
public:
property int WatchListMaximum {
    int get ();
    void set (int value);
}


WatchListMaximumSpecified Property

WatchListMaximumSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RemoveFromWatchListResponseType ► WatchListMaximumSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WatchListMaximumSpecified { get; set; }
Public Property WatchListMaximumSpecified As Boolean
    Get
    Set
public:
property bool WatchListMaximumSpecified {
    bool get ();
    void set (bool value);
}


RequiredSellerActionCodeType Enumeration

RequiredSellerActionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum RequiredSellerActionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration RequiredSellerActionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class RequiredSellerActionCodeType
Members
Member | Description
ResolveeBPCase |
MarkAsShipped |
ContacteBayCS |
ResolvePPPIcase |
SetupPayoutMethod |
UpdatePayoutMethod |
None |
UploadTrackingInfo |
ResolveBuyerMessageInr |
ResolveBuyerMessageSnad |
CustomCode |
ResolveReturn |
Remarks


RequiredSellerActionCodeTypeCollection Class

RequiredSellerActionCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RequiredSellerActionCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RequiredSellerActionCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RequiredSellerActionCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RequiredSellerActionCodeTypeCollection()()()() |
 | RequiredSellerActionCodeTypeCollection(array<RequiredSellerActionCodeType>[]()[][]) |
 | RequiredSellerActionCodeTypeCollection(RequiredSellerActionCodeTypeCollection) |
 | Add(RequiredSellerActionCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RequiredSellerActionCodeType>[]()[][]) |
 | AddRange(RequiredSellerActionCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RequiredSellerActionCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RequiredSellerActionCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RequiredSellerActionCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RequiredSellerActionCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RequiredSellerActionCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RequiredSellerActionCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► Add(RequiredSellerActionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RequiredSellerActionCodeType item
)
Public Function Add ( _
    item As RequiredSellerActionCodeType _
) As Integer
public:
int Add(
    RequiredSellerActionCodeType item
)
Parameters
item (RequiredSellerActionCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RequiredSellerActionCodeType>[]()[][]) |
 | AddRange(RequiredSellerActionCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► AddRange(array<RequiredSellerActionCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RequiredSellerActionCodeType[] items
)
Public Sub AddRange ( _
    items As RequiredSellerActionCodeType() _
)
public:
void AddRange(
    array<RequiredSellerActionCodeType>^ items
)
Parameters
items (array< RequiredSellerActionCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► AddRange(RequiredSellerActionCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RequiredSellerActionCodeTypeCollection items
)
Public Sub AddRange ( _
    items As RequiredSellerActionCodeTypeCollection _
)
public:
void AddRange(
    RequiredSellerActionCodeTypeCollection^ items
)
Parameters
items (RequiredSellerActionCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► Contains(RequiredSellerActionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RequiredSellerActionCodeType item
)
Public Function Contains ( _
    item As RequiredSellerActionCodeType _
) As Boolean
public:
bool Contains(
    RequiredSellerActionCodeType item
)
Parameters
item (RequiredSellerActionCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► CopyTo(array<RequiredSellerActionCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RequiredSellerActionCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RequiredSellerActionCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RequiredSellerActionCodeType>^ items,
    int index
)
Parameters
items (array< RequiredSellerActionCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► IndexOf(RequiredSellerActionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RequiredSellerActionCodeType item
)
Public Function IndexOf ( _
    item As RequiredSellerActionCodeType _
) As Integer
public:
int IndexOf(
    RequiredSellerActionCodeType item
)
Parameters
item (RequiredSellerActionCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► Insert(Int32, RequiredSellerActionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RequiredSellerActionCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RequiredSellerActionCodeType _
)
public:
void Insert(
    int index,
    RequiredSellerActionCodeType item
)
Parameters
index (Int32)
item (RequiredSellerActionCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RequiredSellerActionCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RequiredSellerActionCodeType
    Get
    Set
public:
property RequiredSellerActionCodeType default[int index] {
    RequiredSellerActionCodeType get (int index);
    void set (int index, RequiredSellerActionCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RequiredSellerActionCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RequiredSellerActionCodeType
public:
RequiredSellerActionCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► Remove(RequiredSellerActionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RequiredSellerActionCodeType item
)
Public Sub Remove ( _
    item As RequiredSellerActionCodeType _
)
public:
void Remove(
    RequiredSellerActionCodeType item
)
Parameters
item (RequiredSellerActionCodeType)


RequiredSellerActionCodeTypeCollection Constructor

RequiredSellerActionCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► RequiredSellerActionCodeTypeCollection()()()()
Members
Icon | Member | Description
 | RequiredSellerActionCodeTypeCollection()()()() |
 | RequiredSellerActionCodeTypeCollection(array<RequiredSellerActionCodeType>[]()[][]) |
 | RequiredSellerActionCodeTypeCollection(RequiredSellerActionCodeTypeCollection) |


RequiredSellerActionCodeTypeCollection Constructor

RequiredSellerActionCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► RequiredSellerActionCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RequiredSellerActionCodeTypeCollection()
Public Sub New
public:
RequiredSellerActionCodeTypeCollection()


RequiredSellerActionCodeTypeCollection Constructor (items)

RequiredSellerActionCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► RequiredSellerActionCodeTypeCollection(array<RequiredSellerActionCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RequiredSellerActionCodeTypeCollection(
    RequiredSellerActionCodeType[] items
)
Public Sub New ( _
    items As RequiredSellerActionCodeType() _
)
public:
RequiredSellerActionCodeTypeCollection(
    array<RequiredSellerActionCodeType>^ items
)
Parameters
items (array< RequiredSellerActionCodeType >[]()[][])


RequiredSellerActionCodeTypeCollection Constructor (items)

RequiredSellerActionCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► RequiredSellerActionCodeTypeCollection(RequiredSellerActionCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RequiredSellerActionCodeTypeCollection(
    RequiredSellerActionCodeTypeCollection items
)
Public Sub New ( _
    items As RequiredSellerActionCodeTypeCollection _
)
public:
RequiredSellerActionCodeTypeCollection(
    RequiredSellerActionCodeTypeCollection^ items
)
Parameters
items (RequiredSellerActionCodeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RequiredSellerActionCodeType[] ToArray()
Public Function ToArray As RequiredSellerActionCodeType()
public:
array<RequiredSellerActionCodeType>^ ToArray()
Return Value


RespondToBestOfferRequestType Class

RespondToBestOfferRequestType Class
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RespondToBestOfferRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RespondToBestOfferRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RespondToBestOfferRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RespondToBestOfferRequestType()()()() |
 | Action |
 | ActionSpecified |
 | Any | (Inherited from AbstractRequestType.)
 | BestOfferID |
 | BotBlock | (Inherited from AbstractRequestType.)
 | CounterOfferPrice |
 | CounterOfferQuantity |
 | CounterOfferQuantitySpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SellerResponse |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | RespondToBestOfferRequestType


Action Property

Action Property
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferRequestType ► Action
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferActionCodeType Action { get; set; }
Public Property Action As BestOfferActionCodeType
    Get
    Set
public:
property BestOfferActionCodeType Action {
    BestOfferActionCodeType get ();
    void set (BestOfferActionCodeType value);
}


ActionSpecified Property

ActionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferRequestType ► ActionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ActionSpecified { get; set; }
Public Property ActionSpecified As Boolean
    Get
    Set
public:
property bool ActionSpecified {
    bool get ();
    void set (bool value);
}


BestOfferID Property

BestOfferID Property
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferRequestType ► BestOfferID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection BestOfferID { get; set; }
Public Property BestOfferID As StringCollection
    Get
    Set
public:
property StringCollection^ BestOfferID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


CounterOfferPrice Property

CounterOfferPrice Property
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferRequestType ► CounterOfferPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CounterOfferPrice { get; set; }
Public Property CounterOfferPrice As AmountType
    Get
    Set
public:
property AmountType^ CounterOfferPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


CounterOfferQuantity Property

CounterOfferQuantity Property
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferRequestType ► CounterOfferQuantity
Declaration Syntax
C# Visual Basic Visual C++
public int CounterOfferQuantity { get; set; }
Public Property CounterOfferQuantity As Integer
    Get
    Set
public:
property int CounterOfferQuantity {
    int get ();
    void set (int value);
}


CounterOfferQuantitySpecified Property

CounterOfferQuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferRequestType ► CounterOfferQuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CounterOfferQuantitySpecified { get; set; }
Public Property CounterOfferQuantitySpecified As Boolean
    Get
    Set
public:
property bool CounterOfferQuantitySpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


RespondToBestOfferRequestType Constructor

RespondToBestOfferRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferRequestType ► RespondToBestOfferRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RespondToBestOfferRequestType()
Public Sub New
public:
RespondToBestOfferRequestType()


SellerResponse Property

SellerResponse Property
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferRequestType ► SellerResponse
Declaration Syntax
C# Visual Basic Visual C++
public string SellerResponse { get; set; }
Public Property SellerResponse As String
    Get
    Set
public:
property String^ SellerResponse {
    String^ get ();
    void set (String^ value);
}


RespondToBestOfferResponseType Class

RespondToBestOfferResponseType Class
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RespondToBestOfferResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RespondToBestOfferResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RespondToBestOfferResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RespondToBestOfferResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | RespondToBestOffer |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | RespondToBestOfferResponseType


RespondToBestOffer Property

RespondToBestOffer Property
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferResponseType ► RespondToBestOffer
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferTypeCollection RespondToBestOffer { get; set; }
Public Property RespondToBestOffer As BestOfferTypeCollection
    Get
    Set
public:
property BestOfferTypeCollection^ RespondToBestOffer {
    BestOfferTypeCollection^ get ();
    void set (BestOfferTypeCollection^ value);
}


RespondToBestOfferResponseType Constructor

RespondToBestOfferResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► RespondToBestOfferResponseType ► RespondToBestOfferResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RespondToBestOfferResponseType()
Public Sub New
public:
RespondToBestOfferResponseType()


RespondToFeedbackRequestType Class

RespondToFeedbackRequestType Class
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RespondToFeedbackRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RespondToFeedbackRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RespondToFeedbackRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RespondToFeedbackRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | FeedbackID |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ResponseText |
 | ResponseType |
 | ResponseTypeSpecified |
 | TargetUserID |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | RespondToFeedbackRequestType


FeedbackID Property

FeedbackID Property
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackRequestType ► FeedbackID
Declaration Syntax
C# Visual Basic Visual C++
public string FeedbackID { get; set; }
Public Property FeedbackID As String
    Get
    Set
public:
property String^ FeedbackID {
    String^ get ();
    void set (String^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


RespondToFeedbackRequestType Constructor

RespondToFeedbackRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackRequestType ► RespondToFeedbackRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RespondToFeedbackRequestType()
Public Sub New
public:
RespondToFeedbackRequestType()


ResponseText Property

ResponseText Property
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackRequestType ► ResponseText
Declaration Syntax
C# Visual Basic Visual C++
public string ResponseText { get; set; }
Public Property ResponseText As String
    Get
    Set
public:
property String^ ResponseText {
    String^ get ();
    void set (String^ value);
}


ResponseType Property

ResponseType Property
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackRequestType ► ResponseType
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackResponseCodeType ResponseType { get; set; }
Public Property ResponseType As FeedbackResponseCodeType
    Get
    Set
public:
property FeedbackResponseCodeType ResponseType {
    FeedbackResponseCodeType get ();
    void set (FeedbackResponseCodeType value);
}


ResponseTypeSpecified Property

ResponseTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackRequestType ► ResponseTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ResponseTypeSpecified { get; set; }
Public Property ResponseTypeSpecified As Boolean
    Get
    Set
public:
property bool ResponseTypeSpecified {
    bool get ();
    void set (bool value);
}


TargetUserID Property

TargetUserID Property
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackRequestType ► TargetUserID
Declaration Syntax
C# Visual Basic Visual C++
public string TargetUserID { get; set; }
Public Property TargetUserID As String
    Get
    Set
public:
property String^ TargetUserID {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


RespondToFeedbackResponseType Class

RespondToFeedbackResponseType Class
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RespondToFeedbackResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RespondToFeedbackResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RespondToFeedbackResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RespondToFeedbackResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | RespondToFeedbackResponseType


RespondToFeedbackResponseType Constructor

RespondToFeedbackResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► RespondToFeedbackResponseType ► RespondToFeedbackResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RespondToFeedbackResponseType()
Public Sub New
public:
RespondToFeedbackResponseType()


RestockingFeeValueDetailsType Class

RestockingFeeValueDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RestockingFeeValueDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RestockingFeeValueDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RestockingFeeValueDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RestockingFeeValueDetailsType()()()() |
 | Any |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RestockingFeeValueOption |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RestockingFeeValueDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


RestockingFeeValueDetailsType Constructor

RestockingFeeValueDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsType ► RestockingFeeValueDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RestockingFeeValueDetailsType()
Public Sub New
public:
RestockingFeeValueDetailsType()


RestockingFeeValueOption Property

RestockingFeeValueOption Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsType ► RestockingFeeValueOption
Declaration Syntax
C# Visual Basic Visual C++
public string RestockingFeeValueOption { get; set; }
Public Property RestockingFeeValueOption As String
    Get
    Set
public:
property String^ RestockingFeeValueOption {
    String^ get ();
    void set (String^ value);
}


RestockingFeeValueDetailsTypeCollection Class

RestockingFeeValueDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class RestockingFeeValueDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class RestockingFeeValueDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class RestockingFeeValueDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RestockingFeeValueDetailsTypeCollection()()()() |
 | RestockingFeeValueDetailsTypeCollection(array<RestockingFeeValueDetailsType>[]()[][]) |
 | RestockingFeeValueDetailsTypeCollection(RestockingFeeValueDetailsTypeCollection) |
 | Add(RestockingFeeValueDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<RestockingFeeValueDetailsType>[]()[][]) |
 | AddRange(RestockingFeeValueDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(RestockingFeeValueDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<RestockingFeeValueDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(RestockingFeeValueDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, RestockingFeeValueDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(RestockingFeeValueDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | RestockingFeeValueDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► Add(RestockingFeeValueDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    RestockingFeeValueDetailsType item
)
Public Function Add ( _
    item As RestockingFeeValueDetailsType _
) As Integer
public:
int Add(
    RestockingFeeValueDetailsType^ item
)
Parameters
item (RestockingFeeValueDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<RestockingFeeValueDetailsType>[]()[][]) |
 | AddRange(RestockingFeeValueDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► AddRange(array<RestockingFeeValueDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RestockingFeeValueDetailsType[] items
)
Public Sub AddRange ( _
    items As RestockingFeeValueDetailsType() _
)
public:
void AddRange(
    array<RestockingFeeValueDetailsType^>^ items
)
Parameters
items (array< RestockingFeeValueDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► AddRange(RestockingFeeValueDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    RestockingFeeValueDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As RestockingFeeValueDetailsTypeCollection _
)
public:
void AddRange(
    RestockingFeeValueDetailsTypeCollection^ items
)
Parameters
items (RestockingFeeValueDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► Contains(RestockingFeeValueDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    RestockingFeeValueDetailsType item
)
Public Function Contains ( _
    item As RestockingFeeValueDetailsType _
) As Boolean
public:
bool Contains(
    RestockingFeeValueDetailsType^ item
)
Parameters
item (RestockingFeeValueDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► CopyTo(array<RestockingFeeValueDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    RestockingFeeValueDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As RestockingFeeValueDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<RestockingFeeValueDetailsType^>^ items,
    int index
)
Parameters
items (array< RestockingFeeValueDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► IndexOf(RestockingFeeValueDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    RestockingFeeValueDetailsType item
)
Public Function IndexOf ( _
    item As RestockingFeeValueDetailsType _
) As Integer
public:
int IndexOf(
    RestockingFeeValueDetailsType^ item
)
Parameters
item (RestockingFeeValueDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► Insert(Int32, RestockingFeeValueDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    RestockingFeeValueDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As RestockingFeeValueDetailsType _
)
public:
void Insert(
    int index,
    RestockingFeeValueDetailsType^ item
)
Parameters
index (Int32)
item (RestockingFeeValueDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public RestockingFeeValueDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As RestockingFeeValueDetailsType
    Get
    Set
public:
property RestockingFeeValueDetailsType^ default[int index] {
    RestockingFeeValueDetailsType^ get (int index);
    void set (int index, RestockingFeeValueDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public RestockingFeeValueDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As RestockingFeeValueDetailsType
public:
RestockingFeeValueDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► Remove(RestockingFeeValueDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    RestockingFeeValueDetailsType item
)
Public Sub Remove ( _
    item As RestockingFeeValueDetailsType _
)
public:
void Remove(
    RestockingFeeValueDetailsType^ item
)
Parameters
item (RestockingFeeValueDetailsType)


RestockingFeeValueDetailsTypeCollection Constructor

RestockingFeeValueDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► RestockingFeeValueDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | RestockingFeeValueDetailsTypeCollection()()()() |
 | RestockingFeeValueDetailsTypeCollection(array<RestockingFeeValueDetailsType>[]()[][]) |
 | RestockingFeeValueDetailsTypeCollection(RestockingFeeValueDetailsTypeCollection) |


RestockingFeeValueDetailsTypeCollection Constructor

RestockingFeeValueDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► RestockingFeeValueDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RestockingFeeValueDetailsTypeCollection()
Public Sub New
public:
RestockingFeeValueDetailsTypeCollection()


RestockingFeeValueDetailsTypeCollection Constructor (items)

RestockingFeeValueDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► RestockingFeeValueDetailsTypeCollection(array<RestockingFeeValueDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public RestockingFeeValueDetailsTypeCollection(
    RestockingFeeValueDetailsType[] items
)
Public Sub New ( _
    items As RestockingFeeValueDetailsType() _
)
public:
RestockingFeeValueDetailsTypeCollection(
    array<RestockingFeeValueDetailsType^>^ items
)
Parameters
items (array< RestockingFeeValueDetailsType >[]()[][])


RestockingFeeValueDetailsTypeCollection Constructor (items)

RestockingFeeValueDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► RestockingFeeValueDetailsTypeCollection(RestockingFeeValueDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public RestockingFeeValueDetailsTypeCollection(
    RestockingFeeValueDetailsTypeCollection items
)
Public Sub New ( _
    items As RestockingFeeValueDetailsTypeCollection _
)
public:
RestockingFeeValueDetailsTypeCollection(
    RestockingFeeValueDetailsTypeCollection^ items
)
Parameters
items (RestockingFeeValueDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RestockingFeeValueDetailsType[] ToArray()
Public Function ToArray As RestockingFeeValueDetailsType()
public:
array<RestockingFeeValueDetailsType^>^ ToArray()
Return Value


ReturnPolicyDetailsType Class

ReturnPolicyDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReturnPolicyDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReturnPolicyDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReturnPolicyDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReturnPolicyDetailsType()()()() |
 | Any |
 | Description |
 | DescriptionSpecified |
 | DetailVersion |
 | EAN |
 | EANSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Refund |
 | RestockingFeeValue |
 | ReturnsAccepted |
 | ReturnsWithin |
 | ShippingCostPaidBy |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
 | WarrantyDuration |
 | WarrantyOffered |
 | WarrantyType |
Remarks
Inheritance Hierarchy
Object
ReturnPolicyDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public bool Description { get; set; }
Public Property Description As Boolean
    Get
    Set
public:
property bool Description {
    bool get ();
    void set (bool value);
}


DescriptionSpecified Property

DescriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► DescriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DescriptionSpecified { get; set; }
Public Property DescriptionSpecified As Boolean
    Get
    Set
public:
property bool DescriptionSpecified {
    bool get ();
    void set (bool value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


EAN Property

EAN Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► EAN
Declaration Syntax
C# Visual Basic Visual C++
public bool EAN { get; set; }
Public Property EAN As Boolean
    Get
    Set
public:
property bool EAN {
    bool get ();
    void set (bool value);
}


EANSpecified Property

EANSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► EANSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EANSpecified { get; set; }
Public Property EANSpecified As Boolean
    Get
    Set
public:
property bool EANSpecified {
    bool get ();
    void set (bool value);
}


Refund Property

Refund Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► Refund
Declaration Syntax
C# Visual Basic Visual C++
public RefundDetailsTypeCollection Refund { get; set; }
Public Property Refund As RefundDetailsTypeCollection
    Get
    Set
public:
property RefundDetailsTypeCollection^ Refund {
    RefundDetailsTypeCollection^ get ();
    void set (RefundDetailsTypeCollection^ value);
}


RestockingFeeValue Property

RestockingFeeValue Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► RestockingFeeValue
Declaration Syntax
C# Visual Basic Visual C++
public RestockingFeeValueDetailsTypeCollection RestockingFeeValue { get; set; }
Public Property RestockingFeeValue As RestockingFeeValueDetailsTypeCollection
    Get
    Set
public:
property RestockingFeeValueDetailsTypeCollection^ RestockingFeeValue {
    RestockingFeeValueDetailsTypeCollection^ get ();
    void set (RestockingFeeValueDetailsTypeCollection^ value);
}


ReturnPolicyDetailsType Constructor

ReturnPolicyDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► ReturnPolicyDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReturnPolicyDetailsType()
Public Sub New
public:
ReturnPolicyDetailsType()


ReturnsAccepted Property

ReturnsAccepted Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► ReturnsAccepted
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsAcceptedDetailsTypeCollection ReturnsAccepted { get; set; }
Public Property ReturnsAccepted As ReturnsAcceptedDetailsTypeCollection
    Get
    Set
public:
property ReturnsAcceptedDetailsTypeCollection^ ReturnsAccepted {
    ReturnsAcceptedDetailsTypeCollection^ get ();
    void set (ReturnsAcceptedDetailsTypeCollection^ value);
}


ReturnsWithin Property

ReturnsWithin Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► ReturnsWithin
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsWithinDetailsTypeCollection ReturnsWithin { get; set; }
Public Property ReturnsWithin As ReturnsWithinDetailsTypeCollection
    Get
    Set
public:
property ReturnsWithinDetailsTypeCollection^ ReturnsWithin {
    ReturnsWithinDetailsTypeCollection^ get ();
    void set (ReturnsWithinDetailsTypeCollection^ value);
}


ShippingCostPaidBy Property

ShippingCostPaidBy Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► ShippingCostPaidBy
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCostPaidByDetailsTypeCollection ShippingCostPaidBy { get; set; }
Public Property ShippingCostPaidBy As ShippingCostPaidByDetailsTypeCollection
    Get
    Set
public:
property ShippingCostPaidByDetailsTypeCollection^ ShippingCostPaidBy {
    ShippingCostPaidByDetailsTypeCollection^ get ();
    void set (ShippingCostPaidByDetailsTypeCollection^ value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


WarrantyDuration Property

WarrantyDuration Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► WarrantyDuration
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyDurationDetailsTypeCollection WarrantyDuration { get; set; }
Public Property WarrantyDuration As WarrantyDurationDetailsTypeCollection
    Get
    Set
public:
property WarrantyDurationDetailsTypeCollection^ WarrantyDuration {
    WarrantyDurationDetailsTypeCollection^ get ();
    void set (WarrantyDurationDetailsTypeCollection^ value);
}


WarrantyOffered Property

WarrantyOffered Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► WarrantyOffered
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyOfferedDetailsTypeCollection WarrantyOffered { get; set; }
Public Property WarrantyOffered As WarrantyOfferedDetailsTypeCollection
    Get
    Set
public:
property WarrantyOfferedDetailsTypeCollection^ WarrantyOffered {
    WarrantyOfferedDetailsTypeCollection^ get ();
    void set (WarrantyOfferedDetailsTypeCollection^ value);
}


WarrantyType Property

WarrantyType Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyDetailsType ► WarrantyType
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyTypeDetailsTypeCollection WarrantyType { get; set; }
Public Property WarrantyType As WarrantyTypeDetailsTypeCollection
    Get
    Set
public:
property WarrantyTypeDetailsTypeCollection^ WarrantyType {
    WarrantyTypeDetailsTypeCollection^ get ();
    void set (WarrantyTypeDetailsTypeCollection^ value);
}


ReturnPolicyEnabledDefinitionType Class

ReturnPolicyEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReturnPolicyEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReturnPolicyEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReturnPolicyEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReturnPolicyEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ReturnPolicyEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ReturnPolicyEnabledDefinitionType Constructor

ReturnPolicyEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyEnabledDefinitionType ► ReturnPolicyEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReturnPolicyEnabledDefinitionType()
Public Sub New
public:
ReturnPolicyEnabledDefinitionType()


ReturnPolicyType Class

ReturnPolicyType Class
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReturnPolicyType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReturnPolicyType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReturnPolicyType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReturnPolicyType()()()() |
 | Any |
 | Description |
 | EAN |
 | Equals(Object) | (Inherited from Object.)
 | ExtendedHolidayReturns |
 | ExtendedHolidayReturnsSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Refund |
 | RefundOption |
 | RestockingFeeValue |
 | RestockingFeeValueOption |
 | ReturnsAccepted |
 | ReturnsAcceptedOption |
 | ReturnsWithin |
 | ReturnsWithinOption |
 | ShippingCostPaidBy |
 | ShippingCostPaidByOption |
 | ToString()()()() | (Inherited from Object.)
 | WarrantyDuration |
 | WarrantyDurationOption |
 | WarrantyOffered |
 | WarrantyOfferedOption |
 | WarrantyType |
 | WarrantyTypeOption |
Remarks
Inheritance Hierarchy
Object
ReturnPolicyType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


EAN Property

EAN Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► EAN
Declaration Syntax
C# Visual Basic Visual C++
public string EAN { get; set; }
Public Property EAN As String
    Get
    Set
public:
property String^ EAN {
    String^ get ();
    void set (String^ value);
}


ExtendedHolidayReturns Property

ExtendedHolidayReturns Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► ExtendedHolidayReturns
Declaration Syntax
C# Visual Basic Visual C++
public bool ExtendedHolidayReturns { get; set; }
Public Property ExtendedHolidayReturns As Boolean
    Get
    Set
public:
property bool ExtendedHolidayReturns {
    bool get ();
    void set (bool value);
}


ExtendedHolidayReturnsSpecified Property

ExtendedHolidayReturnsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► ExtendedHolidayReturnsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExtendedHolidayReturnsSpecified { get; set; }
Public Property ExtendedHolidayReturnsSpecified As Boolean
    Get
    Set
public:
property bool ExtendedHolidayReturnsSpecified {
    bool get ();
    void set (bool value);
}


Refund Property

Refund Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► Refund
Declaration Syntax
C# Visual Basic Visual C++
public string Refund { get; set; }
Public Property Refund As String
    Get
    Set
public:
property String^ Refund {
    String^ get ();
    void set (String^ value);
}


RefundOption Property

RefundOption Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► RefundOption
Declaration Syntax
C# Visual Basic Visual C++
public string RefundOption { get; set; }
Public Property RefundOption As String
    Get
    Set
public:
property String^ RefundOption {
    String^ get ();
    void set (String^ value);
}


RestockingFeeValue Property

RestockingFeeValue Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► RestockingFeeValue
Declaration Syntax
C# Visual Basic Visual C++
public string RestockingFeeValue { get; set; }
Public Property RestockingFeeValue As String
    Get
    Set
public:
property String^ RestockingFeeValue {
    String^ get ();
    void set (String^ value);
}


RestockingFeeValueOption Property

RestockingFeeValueOption Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► RestockingFeeValueOption
Declaration Syntax
C# Visual Basic Visual C++
public string RestockingFeeValueOption { get; set; }
Public Property RestockingFeeValueOption As String
    Get
    Set
public:
property String^ RestockingFeeValueOption {
    String^ get ();
    void set (String^ value);
}


ReturnPolicyType Constructor

ReturnPolicyType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► ReturnPolicyType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReturnPolicyType()
Public Sub New
public:
ReturnPolicyType()


ReturnsAccepted Property

ReturnsAccepted Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► ReturnsAccepted
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnsAccepted { get; set; }
Public Property ReturnsAccepted As String
    Get
    Set
public:
property String^ ReturnsAccepted {
    String^ get ();
    void set (String^ value);
}


ReturnsAcceptedOption Property

ReturnsAcceptedOption Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► ReturnsAcceptedOption
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnsAcceptedOption { get; set; }
Public Property ReturnsAcceptedOption As String
    Get
    Set
public:
property String^ ReturnsAcceptedOption {
    String^ get ();
    void set (String^ value);
}


ReturnsWithin Property

ReturnsWithin Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► ReturnsWithin
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnsWithin { get; set; }
Public Property ReturnsWithin As String
    Get
    Set
public:
property String^ ReturnsWithin {
    String^ get ();
    void set (String^ value);
}


ReturnsWithinOption Property

ReturnsWithinOption Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► ReturnsWithinOption
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnsWithinOption { get; set; }
Public Property ReturnsWithinOption As String
    Get
    Set
public:
property String^ ReturnsWithinOption {
    String^ get ();
    void set (String^ value);
}


ShippingCostPaidBy Property

ShippingCostPaidBy Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► ShippingCostPaidBy
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingCostPaidBy { get; set; }
Public Property ShippingCostPaidBy As String
    Get
    Set
public:
property String^ ShippingCostPaidBy {
    String^ get ();
    void set (String^ value);
}


ShippingCostPaidByOption Property

ShippingCostPaidByOption Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► ShippingCostPaidByOption
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingCostPaidByOption { get; set; }
Public Property ShippingCostPaidByOption As String
    Get
    Set
public:
property String^ ShippingCostPaidByOption {
    String^ get ();
    void set (String^ value);
}


WarrantyDuration Property

WarrantyDuration Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► WarrantyDuration
Declaration Syntax
C# Visual Basic Visual C++
public string WarrantyDuration { get; set; }
Public Property WarrantyDuration As String
    Get
    Set
public:
property String^ WarrantyDuration {
    String^ get ();
    void set (String^ value);
}


WarrantyDurationOption Property

WarrantyDurationOption Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► WarrantyDurationOption
Declaration Syntax
C# Visual Basic Visual C++
public string WarrantyDurationOption { get; set; }
Public Property WarrantyDurationOption As String
    Get
    Set
public:
property String^ WarrantyDurationOption {
    String^ get ();
    void set (String^ value);
}


WarrantyOffered Property

WarrantyOffered Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► WarrantyOffered
Declaration Syntax
C# Visual Basic Visual C++
public string WarrantyOffered { get; set; }
Public Property WarrantyOffered As String
    Get
    Set
public:
property String^ WarrantyOffered {
    String^ get ();
    void set (String^ value);
}


WarrantyOfferedOption Property

WarrantyOfferedOption Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► WarrantyOfferedOption
Declaration Syntax
C# Visual Basic Visual C++
public string WarrantyOfferedOption { get; set; }
Public Property WarrantyOfferedOption As String
    Get
    Set
public:
property String^ WarrantyOfferedOption {
    String^ get ();
    void set (String^ value);
}


WarrantyType Property

WarrantyType Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► WarrantyType
Declaration Syntax
C# Visual Basic Visual C++
public string WarrantyType { get; set; }
Public Property WarrantyType As String
    Get
    Set
public:
property String^ WarrantyType {
    String^ get ();
    void set (String^ value);
}


WarrantyTypeOption Property

WarrantyTypeOption Property
Namespaces ► eBay.Service.Core.Soap ► ReturnPolicyType ► WarrantyTypeOption
Declaration Syntax
C# Visual Basic Visual C++
public string WarrantyTypeOption { get; set; }
Public Property WarrantyTypeOption As String
    Get
    Set
public:
property String^ WarrantyTypeOption {
    String^ get ();
    void set (String^ value);
}


ReturnsAcceptedDetailsType Class

ReturnsAcceptedDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReturnsAcceptedDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReturnsAcceptedDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReturnsAcceptedDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReturnsAcceptedDetailsType()()()() |
 | Any |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReturnsAcceptedOption |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ReturnsAcceptedDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ReturnsAcceptedDetailsType Constructor

ReturnsAcceptedDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsType ► ReturnsAcceptedDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsAcceptedDetailsType()
Public Sub New
public:
ReturnsAcceptedDetailsType()


ReturnsAcceptedOption Property

ReturnsAcceptedOption Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsType ► ReturnsAcceptedOption
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnsAcceptedOption { get; set; }
Public Property ReturnsAcceptedOption As String
    Get
    Set
public:
property String^ ReturnsAcceptedOption {
    String^ get ();
    void set (String^ value);
}


ReturnsAcceptedDetailsTypeCollection Class

ReturnsAcceptedDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ReturnsAcceptedDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ReturnsAcceptedDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ReturnsAcceptedDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReturnsAcceptedDetailsTypeCollection()()()() |
 | ReturnsAcceptedDetailsTypeCollection(array<ReturnsAcceptedDetailsType>[]()[][]) |
 | ReturnsAcceptedDetailsTypeCollection(ReturnsAcceptedDetailsTypeCollection) |
 | Add(ReturnsAcceptedDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ReturnsAcceptedDetailsType>[]()[][]) |
 | AddRange(ReturnsAcceptedDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ReturnsAcceptedDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ReturnsAcceptedDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ReturnsAcceptedDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ReturnsAcceptedDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ReturnsAcceptedDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ReturnsAcceptedDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► Add(ReturnsAcceptedDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ReturnsAcceptedDetailsType item
)
Public Function Add ( _
    item As ReturnsAcceptedDetailsType _
) As Integer
public:
int Add(
    ReturnsAcceptedDetailsType^ item
)
Parameters
item (ReturnsAcceptedDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ReturnsAcceptedDetailsType>[]()[][]) |
 | AddRange(ReturnsAcceptedDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► AddRange(array<ReturnsAcceptedDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ReturnsAcceptedDetailsType[] items
)
Public Sub AddRange ( _
    items As ReturnsAcceptedDetailsType() _
)
public:
void AddRange(
    array<ReturnsAcceptedDetailsType^>^ items
)
Parameters
items (array< ReturnsAcceptedDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► AddRange(ReturnsAcceptedDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ReturnsAcceptedDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ReturnsAcceptedDetailsTypeCollection _
)
public:
void AddRange(
    ReturnsAcceptedDetailsTypeCollection^ items
)
Parameters
items (ReturnsAcceptedDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► Contains(ReturnsAcceptedDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ReturnsAcceptedDetailsType item
)
Public Function Contains ( _
    item As ReturnsAcceptedDetailsType _
) As Boolean
public:
bool Contains(
    ReturnsAcceptedDetailsType^ item
)
Parameters
item (ReturnsAcceptedDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► CopyTo(array<ReturnsAcceptedDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ReturnsAcceptedDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ReturnsAcceptedDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ReturnsAcceptedDetailsType^>^ items,
    int index
)
Parameters
items (array< ReturnsAcceptedDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► IndexOf(ReturnsAcceptedDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ReturnsAcceptedDetailsType item
)
Public Function IndexOf ( _
    item As ReturnsAcceptedDetailsType _
) As Integer
public:
int IndexOf(
    ReturnsAcceptedDetailsType^ item
)
Parameters
item (ReturnsAcceptedDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► Insert(Int32, ReturnsAcceptedDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ReturnsAcceptedDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ReturnsAcceptedDetailsType _
)
public:
void Insert(
    int index,
    ReturnsAcceptedDetailsType^ item
)
Parameters
index (Int32)
item (ReturnsAcceptedDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsAcceptedDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ReturnsAcceptedDetailsType
    Get
    Set
public:
property ReturnsAcceptedDetailsType^ default[int index] {
    ReturnsAcceptedDetailsType^ get (int index);
    void set (int index, ReturnsAcceptedDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsAcceptedDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ReturnsAcceptedDetailsType
public:
ReturnsAcceptedDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► Remove(ReturnsAcceptedDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ReturnsAcceptedDetailsType item
)
Public Sub Remove ( _
    item As ReturnsAcceptedDetailsType _
)
public:
void Remove(
    ReturnsAcceptedDetailsType^ item
)
Parameters
item (ReturnsAcceptedDetailsType)


ReturnsAcceptedDetailsTypeCollection Constructor

ReturnsAcceptedDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► ReturnsAcceptedDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ReturnsAcceptedDetailsTypeCollection()()()() |
 | ReturnsAcceptedDetailsTypeCollection(array<ReturnsAcceptedDetailsType>[]()[][]) |
 | ReturnsAcceptedDetailsTypeCollection(ReturnsAcceptedDetailsTypeCollection) |


ReturnsAcceptedDetailsTypeCollection Constructor

ReturnsAcceptedDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► ReturnsAcceptedDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsAcceptedDetailsTypeCollection()
Public Sub New
public:
ReturnsAcceptedDetailsTypeCollection()


ReturnsAcceptedDetailsTypeCollection Constructor (items)

ReturnsAcceptedDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► ReturnsAcceptedDetailsTypeCollection(array<ReturnsAcceptedDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsAcceptedDetailsTypeCollection(
    ReturnsAcceptedDetailsType[] items
)
Public Sub New ( _
    items As ReturnsAcceptedDetailsType() _
)
public:
ReturnsAcceptedDetailsTypeCollection(
    array<ReturnsAcceptedDetailsType^>^ items
)
Parameters
items (array< ReturnsAcceptedDetailsType >[]()[][])


ReturnsAcceptedDetailsTypeCollection Constructor (items)

ReturnsAcceptedDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► ReturnsAcceptedDetailsTypeCollection(ReturnsAcceptedDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsAcceptedDetailsTypeCollection(
    ReturnsAcceptedDetailsTypeCollection items
)
Public Sub New ( _
    items As ReturnsAcceptedDetailsTypeCollection _
)
public:
ReturnsAcceptedDetailsTypeCollection(
    ReturnsAcceptedDetailsTypeCollection^ items
)
Parameters
items (ReturnsAcceptedDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsAcceptedDetailsType[] ToArray()
Public Function ToArray As ReturnsAcceptedDetailsType()
public:
array<ReturnsAcceptedDetailsType^>^ ToArray()
Return Value


ReturnStatusCodeType Enumeration

ReturnStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ReturnStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ReturnStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ReturnStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ReturnStatusCodeType
Members
Member | Description
Invalid |
NotApplicable |
ReturnRequestPendingApproval |
ReturnRequestRejected |
ReturnOpen |
ReturnShipped |
ReturnDelivered |
ReturnClosedWithRefund |
ReturnClosedEscalated |
ReturnClosedNoRefund |
ReturnEscalatedPendingBuyer |
ReturnEscalatedPendingSeller |
ReturnEscalatedPendingCS |
ReturnEscalatedClosedWithRefund |
ReturnEscalatedClosedNoRefund |
ReturnEscalated |
ReturnRequestPending |
ReturnRequestClosedWithRefund |
ReturnRequestClosedNoRefund |
CustomCode |
Remarks


ReturnsWithinDetailsType Class

ReturnsWithinDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReturnsWithinDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReturnsWithinDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReturnsWithinDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReturnsWithinDetailsType()()()() |
 | Any |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReturnsWithinOption |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ReturnsWithinDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ReturnsWithinDetailsType Constructor

ReturnsWithinDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsType ► ReturnsWithinDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsWithinDetailsType()
Public Sub New
public:
ReturnsWithinDetailsType()


ReturnsWithinOption Property

ReturnsWithinOption Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsType ► ReturnsWithinOption
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnsWithinOption { get; set; }
Public Property ReturnsWithinOption As String
    Get
    Set
public:
property String^ ReturnsWithinOption {
    String^ get ();
    void set (String^ value);
}


ReturnsWithinDetailsTypeCollection Class

ReturnsWithinDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ReturnsWithinDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ReturnsWithinDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ReturnsWithinDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReturnsWithinDetailsTypeCollection()()()() |
 | ReturnsWithinDetailsTypeCollection(array<ReturnsWithinDetailsType>[]()[][]) |
 | ReturnsWithinDetailsTypeCollection(ReturnsWithinDetailsTypeCollection) |
 | Add(ReturnsWithinDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ReturnsWithinDetailsType>[]()[][]) |
 | AddRange(ReturnsWithinDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ReturnsWithinDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ReturnsWithinDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ReturnsWithinDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ReturnsWithinDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ReturnsWithinDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ReturnsWithinDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► Add(ReturnsWithinDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ReturnsWithinDetailsType item
)
Public Function Add ( _
    item As ReturnsWithinDetailsType _
) As Integer
public:
int Add(
    ReturnsWithinDetailsType^ item
)
Parameters
item (ReturnsWithinDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ReturnsWithinDetailsType>[]()[][]) |
 | AddRange(ReturnsWithinDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► AddRange(array<ReturnsWithinDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ReturnsWithinDetailsType[] items
)
Public Sub AddRange ( _
    items As ReturnsWithinDetailsType() _
)
public:
void AddRange(
    array<ReturnsWithinDetailsType^>^ items
)
Parameters
items (array< ReturnsWithinDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► AddRange(ReturnsWithinDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ReturnsWithinDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ReturnsWithinDetailsTypeCollection _
)
public:
void AddRange(
    ReturnsWithinDetailsTypeCollection^ items
)
Parameters
items (ReturnsWithinDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► Contains(ReturnsWithinDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ReturnsWithinDetailsType item
)
Public Function Contains ( _
    item As ReturnsWithinDetailsType _
) As Boolean
public:
bool Contains(
    ReturnsWithinDetailsType^ item
)
Parameters
item (ReturnsWithinDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► CopyTo(array<ReturnsWithinDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ReturnsWithinDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ReturnsWithinDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ReturnsWithinDetailsType^>^ items,
    int index
)
Parameters
items (array< ReturnsWithinDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► IndexOf(ReturnsWithinDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ReturnsWithinDetailsType item
)
Public Function IndexOf ( _
    item As ReturnsWithinDetailsType _
) As Integer
public:
int IndexOf(
    ReturnsWithinDetailsType^ item
)
Parameters
item (ReturnsWithinDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► Insert(Int32, ReturnsWithinDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ReturnsWithinDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ReturnsWithinDetailsType _
)
public:
void Insert(
    int index,
    ReturnsWithinDetailsType^ item
)
Parameters
index (Int32)
item (ReturnsWithinDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsWithinDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ReturnsWithinDetailsType
    Get
    Set
public:
property ReturnsWithinDetailsType^ default[int index] {
    ReturnsWithinDetailsType^ get (int index);
    void set (int index, ReturnsWithinDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsWithinDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ReturnsWithinDetailsType
public:
ReturnsWithinDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► Remove(ReturnsWithinDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ReturnsWithinDetailsType item
)
Public Sub Remove ( _
    item As ReturnsWithinDetailsType _
)
public:
void Remove(
    ReturnsWithinDetailsType^ item
)
Parameters
item (ReturnsWithinDetailsType)


ReturnsWithinDetailsTypeCollection Constructor

ReturnsWithinDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► ReturnsWithinDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ReturnsWithinDetailsTypeCollection()()()() |
 | ReturnsWithinDetailsTypeCollection(array<ReturnsWithinDetailsType>[]()[][]) |
 | ReturnsWithinDetailsTypeCollection(ReturnsWithinDetailsTypeCollection) |


ReturnsWithinDetailsTypeCollection Constructor

ReturnsWithinDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► ReturnsWithinDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsWithinDetailsTypeCollection()
Public Sub New
public:
ReturnsWithinDetailsTypeCollection()


ReturnsWithinDetailsTypeCollection Constructor (items)

ReturnsWithinDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► ReturnsWithinDetailsTypeCollection(array<ReturnsWithinDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsWithinDetailsTypeCollection(
    ReturnsWithinDetailsType[] items
)
Public Sub New ( _
    items As ReturnsWithinDetailsType() _
)
public:
ReturnsWithinDetailsTypeCollection(
    array<ReturnsWithinDetailsType^>^ items
)
Parameters
items (array< ReturnsWithinDetailsType >[]()[][])


ReturnsWithinDetailsTypeCollection Constructor (items)

ReturnsWithinDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► ReturnsWithinDetailsTypeCollection(ReturnsWithinDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsWithinDetailsTypeCollection(
    ReturnsWithinDetailsTypeCollection items
)
Public Sub New ( _
    items As ReturnsWithinDetailsTypeCollection _
)
public:
ReturnsWithinDetailsTypeCollection(
    ReturnsWithinDetailsTypeCollection^ items
)
Parameters
items (ReturnsWithinDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReturnsWithinDetailsType[] ToArray()
Public Function ToArray As ReturnsWithinDetailsType()
public:
array<ReturnsWithinDetailsType^>^ ToArray()
Return Value


ReviseCheckoutStatusRequestType Class

ReviseCheckoutStatusRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseCheckoutStatusRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseCheckoutStatusRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseCheckoutStatusRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseCheckoutStatusRequestType()()()() |
 | AdjustmentAmount |
 | AmountPaid |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | BuyerID |
 | CheckoutMethod |
 | CheckoutMethodSpecified |
 | CheckoutStatus |
 | CheckoutStatusSpecified |
 | CODCost |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EncryptedID |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | ExternalTransaction |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InsuranceType |
 | InsuranceTypeSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | MultipleSellerPaymentID |
 | OrderID |
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | PaymentMethodUsed |
 | PaymentMethodUsedSpecified |
 | PaymentStatus |
 | PaymentStatusSpecified |
 | SalesTax |
 | ShippingAddress |
 | ShippingCost |
 | ShippingIncludedInTax |
 | ShippingIncludedInTaxSpecified |
 | ShippingInsuranceCost |
 | ShippingService |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ReviseCheckoutStatusRequestType


AdjustmentAmount Property

AdjustmentAmount Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► AdjustmentAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AdjustmentAmount { get; set; }
Public Property AdjustmentAmount As AmountType
    Get
    Set
public:
property AmountType^ AdjustmentAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


AmountPaid Property

AmountPaid Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► AmountPaid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AmountPaid { get; set; }
Public Property AmountPaid As AmountType
    Get
    Set
public:
property AmountType^ AmountPaid {
    AmountType^ get ();
    void set (AmountType^ value);
}


BuyerID Property

BuyerID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► BuyerID
Declaration Syntax
C# Visual Basic Visual C++
public string BuyerID { get; set; }
Public Property BuyerID As String
    Get
    Set
public:
property String^ BuyerID {
    String^ get ();
    void set (String^ value);
}


CheckoutMethod Property

CheckoutMethod Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► CheckoutMethod
Declaration Syntax
C# Visual Basic Visual C++
public CheckoutMethodCodeType CheckoutMethod { get; set; }
Public Property CheckoutMethod As CheckoutMethodCodeType
    Get
    Set
public:
property CheckoutMethodCodeType CheckoutMethod {
    CheckoutMethodCodeType get ();
    void set (CheckoutMethodCodeType value);
}


CheckoutMethodSpecified Property

CheckoutMethodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► CheckoutMethodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckoutMethodSpecified { get; set; }
Public Property CheckoutMethodSpecified As Boolean
    Get
    Set
public:
property bool CheckoutMethodSpecified {
    bool get ();
    void set (bool value);
}


CheckoutStatus Property

CheckoutStatus Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► CheckoutStatus
Declaration Syntax
C# Visual Basic Visual C++
public CompleteStatusCodeType CheckoutStatus { get; set; }
Public Property CheckoutStatus As CompleteStatusCodeType
    Get
    Set
public:
property CompleteStatusCodeType CheckoutStatus {
    CompleteStatusCodeType get ();
    void set (CompleteStatusCodeType value);
}


CheckoutStatusSpecified Property

CheckoutStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► CheckoutStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckoutStatusSpecified { get; set; }
Public Property CheckoutStatusSpecified As Boolean
    Get
    Set
public:
property bool CheckoutStatusSpecified {
    bool get ();
    void set (bool value);
}


CODCost Property

CODCost Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► CODCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CODCost { get; set; }
Public Property CODCost As AmountType
    Get
    Set
public:
property AmountType^ CODCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


EncryptedID Property

EncryptedID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► EncryptedID
Declaration Syntax
C# Visual Basic Visual C++
public string EncryptedID { get; set; }
Public Property EncryptedID As String
    Get
    Set
public:
property String^ EncryptedID {
    String^ get ();
    void set (String^ value);
}


ExternalTransaction Property

ExternalTransaction Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► ExternalTransaction
Declaration Syntax
C# Visual Basic Visual C++
public ExternalTransactionType ExternalTransaction { get; set; }
Public Property ExternalTransaction As ExternalTransactionType
    Get
    Set
public:
property ExternalTransactionType^ ExternalTransaction {
    ExternalTransactionType^ get ();
    void set (ExternalTransactionType^ value);
}


InsuranceType Property

InsuranceType Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► InsuranceType
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceSelectedCodeType InsuranceType { get; set; }
Public Property InsuranceType As InsuranceSelectedCodeType
    Get
    Set
public:
property InsuranceSelectedCodeType InsuranceType {
    InsuranceSelectedCodeType get ();
    void set (InsuranceSelectedCodeType value);
}


InsuranceTypeSpecified Property

InsuranceTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► InsuranceTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InsuranceTypeSpecified { get; set; }
Public Property InsuranceTypeSpecified As Boolean
    Get
    Set
public:
property bool InsuranceTypeSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MultipleSellerPaymentID Property

MultipleSellerPaymentID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► MultipleSellerPaymentID
Declaration Syntax
C# Visual Basic Visual C++
public string MultipleSellerPaymentID { get; set; }
Public Property MultipleSellerPaymentID As String
    Get
    Set
public:
property String^ MultipleSellerPaymentID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► OrderID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


PaymentMethodUsed Property

PaymentMethodUsed Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► PaymentMethodUsed
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeType PaymentMethodUsed { get; set; }
Public Property PaymentMethodUsed As BuyerPaymentMethodCodeType
    Get
    Set
public:
property BuyerPaymentMethodCodeType PaymentMethodUsed {
    BuyerPaymentMethodCodeType get ();
    void set (BuyerPaymentMethodCodeType value);
}


PaymentMethodUsedSpecified Property

PaymentMethodUsedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► PaymentMethodUsedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentMethodUsedSpecified { get; set; }
Public Property PaymentMethodUsedSpecified As Boolean
    Get
    Set
public:
property bool PaymentMethodUsedSpecified {
    bool get ();
    void set (bool value);
}


PaymentStatus Property

PaymentStatus Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► PaymentStatus
Declaration Syntax
C# Visual Basic Visual C++
public RCSPaymentStatusCodeType PaymentStatus { get; set; }
Public Property PaymentStatus As RCSPaymentStatusCodeType
    Get
    Set
public:
property RCSPaymentStatusCodeType PaymentStatus {
    RCSPaymentStatusCodeType get ();
    void set (RCSPaymentStatusCodeType value);
}


PaymentStatusSpecified Property

PaymentStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► PaymentStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentStatusSpecified { get; set; }
Public Property PaymentStatusSpecified As Boolean
    Get
    Set
public:
property bool PaymentStatusSpecified {
    bool get ();
    void set (bool value);
}


ReviseCheckoutStatusRequestType Constructor

ReviseCheckoutStatusRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► ReviseCheckoutStatusRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseCheckoutStatusRequestType()
Public Sub New
public:
ReviseCheckoutStatusRequestType()


SalesTax Property

SalesTax Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► SalesTax
Declaration Syntax
C# Visual Basic Visual C++
public AmountType SalesTax { get; set; }
Public Property SalesTax As AmountType
    Get
    Set
public:
property AmountType^ SalesTax {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingAddress Property

ShippingAddress Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► ShippingAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType ShippingAddress { get; set; }
Public Property ShippingAddress As AddressType
    Get
    Set
public:
property AddressType^ ShippingAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


ShippingCost Property

ShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► ShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingCost { get; set; }
Public Property ShippingCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingIncludedInTax Property

ShippingIncludedInTax Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► ShippingIncludedInTax
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingIncludedInTax { get; set; }
Public Property ShippingIncludedInTax As Boolean
    Get
    Set
public:
property bool ShippingIncludedInTax {
    bool get ();
    void set (bool value);
}


ShippingIncludedInTaxSpecified Property

ShippingIncludedInTaxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► ShippingIncludedInTaxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingIncludedInTaxSpecified { get; set; }
Public Property ShippingIncludedInTaxSpecified As Boolean
    Get
    Set
public:
property bool ShippingIncludedInTaxSpecified {
    bool get ();
    void set (bool value);
}


ShippingInsuranceCost Property

ShippingInsuranceCost Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► ShippingInsuranceCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingInsuranceCost { get; set; }
Public Property ShippingInsuranceCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingInsuranceCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingService Property

ShippingService Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► ShippingService
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingService { get; set; }
Public Property ShippingService As String
    Get
    Set
public:
property String^ ShippingService {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


ReviseCheckoutStatusResponseType Class

ReviseCheckoutStatusResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseCheckoutStatusResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseCheckoutStatusResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseCheckoutStatusResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseCheckoutStatusResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ReviseCheckoutStatusResponseType


ReviseCheckoutStatusResponseType Constructor

ReviseCheckoutStatusResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseCheckoutStatusResponseType ► ReviseCheckoutStatusResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseCheckoutStatusResponseType()
Public Sub New
public:
ReviseCheckoutStatusResponseType()


ReviseFixedPriceItemRequestType Class

ReviseFixedPriceItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseFixedPriceItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseFixedPriceItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseFixedPriceItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseFixedPriceItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DeletedField |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ReviseFixedPriceItemRequestType


DeletedField Property

DeletedField Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemRequestType ► DeletedField
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedField { get; set; }
Public Property DeletedField As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedField {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ReviseFixedPriceItemRequestType Constructor

ReviseFixedPriceItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemRequestType ► ReviseFixedPriceItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseFixedPriceItemRequestType()
Public Sub New
public:
ReviseFixedPriceItemRequestType()


ReviseFixedPriceItemResponseType Class

ReviseFixedPriceItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseFixedPriceItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseFixedPriceItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseFixedPriceItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseFixedPriceItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category2ID |
 | CategoryID |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DiscountReason |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | ListingRecommendations |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | ProductSuggestions |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SKU |
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ReviseFixedPriceItemResponseType


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; set; }
Public Property Category2ID As String
    Get
    Set
public:
property String^ Category2ID {
    String^ get ();
    void set (String^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


DiscountReason Property

DiscountReason Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► DiscountReason
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReason { get; set; }
Public Property DiscountReason As DiscountReasonCodeTypeCollection
    Get
    Set
public:
property DiscountReasonCodeTypeCollection^ DiscountReason {
    DiscountReasonCodeTypeCollection^ get ();
    void set (DiscountReasonCodeTypeCollection^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► ListingRecommendations
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; set; }
Public Property ListingRecommendations As ListingRecommendationsType
    Get
    Set
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
    void set (ListingRecommendationsType^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► ProductSuggestions
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; set; }
Public Property ProductSuggestions As ProductSuggestionsType
    Get
    Set
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
    void set (ProductSuggestionsType^ value);
}


ReviseFixedPriceItemResponseType Constructor

ReviseFixedPriceItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► ReviseFixedPriceItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseFixedPriceItemResponseType()
Public Sub New
public:
ReviseFixedPriceItemResponseType()


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseFixedPriceItemResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


ReviseInventoryStatusRequestType Class

ReviseInventoryStatusRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseInventoryStatusRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseInventoryStatusRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseInventoryStatusRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseInventoryStatusRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseInventoryStatusRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | Any1 |
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InventoryStatus |
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ReviseInventoryStatusRequestType


Any1 Property

Any1 Property
Namespaces ► eBay.Service.Core.Soap ► ReviseInventoryStatusRequestType ► Any1
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any1 { get; set; }
Public Property Any1 As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any1 {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


InventoryStatus Property

InventoryStatus Property
Namespaces ► eBay.Service.Core.Soap ► ReviseInventoryStatusRequestType ► InventoryStatus
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusTypeCollection InventoryStatus { get; set; }
Public Property InventoryStatus As InventoryStatusTypeCollection
    Get
    Set
public:
property InventoryStatusTypeCollection^ InventoryStatus {
    InventoryStatusTypeCollection^ get ();
    void set (InventoryStatusTypeCollection^ value);
}


ReviseInventoryStatusRequestType Constructor

ReviseInventoryStatusRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseInventoryStatusRequestType ► ReviseInventoryStatusRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseInventoryStatusRequestType()
Public Sub New
public:
ReviseInventoryStatusRequestType()


ReviseInventoryStatusResponseType Class

ReviseInventoryStatusResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseInventoryStatusResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseInventoryStatusResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseInventoryStatusResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseInventoryStatusResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseInventoryStatusResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | InventoryStatus |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ReviseInventoryStatusResponseType


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► ReviseInventoryStatusResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public InventoryFeesTypeCollection Fees { get; set; }
Public Property Fees As InventoryFeesTypeCollection
    Get
    Set
public:
property InventoryFeesTypeCollection^ Fees {
    InventoryFeesTypeCollection^ get ();
    void set (InventoryFeesTypeCollection^ value);
}


InventoryStatus Property

InventoryStatus Property
Namespaces ► eBay.Service.Core.Soap ► ReviseInventoryStatusResponseType ► InventoryStatus
Declaration Syntax
C# Visual Basic Visual C++
public InventoryStatusTypeCollection InventoryStatus { get; set; }
Public Property InventoryStatus As InventoryStatusTypeCollection
    Get
    Set
public:
property InventoryStatusTypeCollection^ InventoryStatus {
    InventoryStatusTypeCollection^ get ();
    void set (InventoryStatusTypeCollection^ value);
}


ReviseInventoryStatusResponseType Constructor

ReviseInventoryStatusResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseInventoryStatusResponseType ► ReviseInventoryStatusResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseInventoryStatusResponseType()
Public Sub New
public:
ReviseInventoryStatusResponseType()


ReviseItemRequestType Class

ReviseItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DeletedField |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | VerifyOnly |
 | VerifyOnlySpecified |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ReviseItemRequestType


DeletedField Property

DeletedField Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemRequestType ► DeletedField
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedField { get; set; }
Public Property DeletedField As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedField {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ReviseItemRequestType Constructor

ReviseItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseItemRequestType ► ReviseItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseItemRequestType()
Public Sub New
public:
ReviseItemRequestType()


VerifyOnly Property

VerifyOnly Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemRequestType ► VerifyOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnly { get; set; }
Public Property VerifyOnly As Boolean
    Get
    Set
public:
property bool VerifyOnly {
    bool get ();
    void set (bool value);
}


VerifyOnlySpecified Property

VerifyOnlySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemRequestType ► VerifyOnlySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnlySpecified { get; set; }
Public Property VerifyOnlySpecified As Boolean
    Get
    Set
public:
property bool VerifyOnlySpecified {
    bool get ();
    void set (bool value);
}


ReviseItemResponseType Class

ReviseItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category2ID |
 | CategoryID |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DiscountReason |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | ListingRecommendations |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | ProductSuggestions |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | VerifyOnly |
 | VerifyOnlySpecified |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ReviseItemResponseType


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; set; }
Public Property Category2ID As String
    Get
    Set
public:
property String^ Category2ID {
    String^ get ();
    void set (String^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


DiscountReason Property

DiscountReason Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► DiscountReason
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReason { get; set; }
Public Property DiscountReason As DiscountReasonCodeTypeCollection
    Get
    Set
public:
property DiscountReasonCodeTypeCollection^ DiscountReason {
    DiscountReasonCodeTypeCollection^ get ();
    void set (DiscountReasonCodeTypeCollection^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► ListingRecommendations
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; set; }
Public Property ListingRecommendations As ListingRecommendationsType
    Get
    Set
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
    void set (ListingRecommendationsType^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► ProductSuggestions
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; set; }
Public Property ProductSuggestions As ProductSuggestionsType
    Get
    Set
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
    void set (ProductSuggestionsType^ value);
}


ReviseItemResponseType Constructor

ReviseItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► ReviseItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseItemResponseType()
Public Sub New
public:
ReviseItemResponseType()


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


VerifyOnly Property

VerifyOnly Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► VerifyOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnly { get; set; }
Public Property VerifyOnly As Boolean
    Get
    Set
public:
property bool VerifyOnly {
    bool get ();
    void set (bool value);
}


VerifyOnlySpecified Property

VerifyOnlySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseItemResponseType ► VerifyOnlySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnlySpecified { get; set; }
Public Property VerifyOnlySpecified As Boolean
    Get
    Set
public:
property bool VerifyOnlySpecified {
    bool get ();
    void set (bool value);
}


ReviseMyMessagesFoldersRequestType Class

ReviseMyMessagesFoldersRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesFoldersRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseMyMessagesFoldersRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseMyMessagesFoldersRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseMyMessagesFoldersRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseMyMessagesFoldersRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID |
 | FolderName |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | Operation |
 | OperationSpecified |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ReviseMyMessagesFoldersRequestType


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesFoldersRequestType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public Int64Collection FolderID { get; set; }
Public Property FolderID As Int64Collection
    Get
    Set
public:
property Int64Collection^ FolderID {
    Int64Collection^ get ();
    void set (Int64Collection^ value);
}


FolderName Property

FolderName Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesFoldersRequestType ► FolderName
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection FolderName { get; set; }
Public Property FolderName As StringCollection
    Get
    Set
public:
property StringCollection^ FolderName {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Operation Property

Operation Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesFoldersRequestType ► Operation
Declaration Syntax
C# Visual Basic Visual C++
public MyMessagesFolderOperationCodeType Operation { get; set; }
Public Property Operation As MyMessagesFolderOperationCodeType
    Get
    Set
public:
property MyMessagesFolderOperationCodeType Operation {
    MyMessagesFolderOperationCodeType get ();
    void set (MyMessagesFolderOperationCodeType value);
}


OperationSpecified Property

OperationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesFoldersRequestType ► OperationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OperationSpecified { get; set; }
Public Property OperationSpecified As Boolean
    Get
    Set
public:
property bool OperationSpecified {
    bool get ();
    void set (bool value);
}


ReviseMyMessagesFoldersRequestType Constructor

ReviseMyMessagesFoldersRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesFoldersRequestType ► ReviseMyMessagesFoldersRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesFoldersRequestType()
Public Sub New
public:
ReviseMyMessagesFoldersRequestType()


ReviseMyMessagesFoldersResponseType Class

ReviseMyMessagesFoldersResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesFoldersResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseMyMessagesFoldersResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseMyMessagesFoldersResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseMyMessagesFoldersResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseMyMessagesFoldersResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ReviseMyMessagesFoldersResponseType


ReviseMyMessagesFoldersResponseType Constructor

ReviseMyMessagesFoldersResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesFoldersResponseType ► ReviseMyMessagesFoldersResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesFoldersResponseType()
Public Sub New
public:
ReviseMyMessagesFoldersResponseType()


ReviseMyMessagesRequestType Class

ReviseMyMessagesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseMyMessagesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseMyMessagesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseMyMessagesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseMyMessagesRequestType()()()() |
 | AlertIDs |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | Flagged |
 | FlaggedSpecified |
 | FolderID |
 | FolderIDSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | MessageIDs |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Read |
 | ReadSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ReviseMyMessagesRequestType


AlertIDs Property

AlertIDs Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesRequestType ► AlertIDs
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection AlertIDs { get; set; }
Public Property AlertIDs As StringCollection
    Get
    Set
public:
property StringCollection^ AlertIDs {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Flagged Property

Flagged Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesRequestType ► Flagged
Declaration Syntax
C# Visual Basic Visual C++
public bool Flagged { get; set; }
Public Property Flagged As Boolean
    Get
    Set
public:
property bool Flagged {
    bool get ();
    void set (bool value);
}


FlaggedSpecified Property

FlaggedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesRequestType ► FlaggedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FlaggedSpecified { get; set; }
Public Property FlaggedSpecified As Boolean
    Get
    Set
public:
property bool FlaggedSpecified {
    bool get ();
    void set (bool value);
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesRequestType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesRequestType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


MessageIDs Property

MessageIDs Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesRequestType ► MessageIDs
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection MessageIDs { get; set; }
Public Property MessageIDs As StringCollection
    Get
    Set
public:
property StringCollection^ MessageIDs {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Read Property

Read Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesRequestType ► Read
Declaration Syntax
C# Visual Basic Visual C++
public bool Read { get; set; }
Public Property Read As Boolean
    Get
    Set
public:
property bool Read {
    bool get ();
    void set (bool value);
}


ReadSpecified Property

ReadSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesRequestType ► ReadSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReadSpecified { get; set; }
Public Property ReadSpecified As Boolean
    Get
    Set
public:
property bool ReadSpecified {
    bool get ();
    void set (bool value);
}


ReviseMyMessagesRequestType Constructor

ReviseMyMessagesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesRequestType ► ReviseMyMessagesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesRequestType()
Public Sub New
public:
ReviseMyMessagesRequestType()


ReviseMyMessagesResponseType Class

ReviseMyMessagesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseMyMessagesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseMyMessagesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseMyMessagesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseMyMessagesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ReviseMyMessagesResponseType


ReviseMyMessagesResponseType Constructor

ReviseMyMessagesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseMyMessagesResponseType ► ReviseMyMessagesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseMyMessagesResponseType()
Public Sub New
public:
ReviseMyMessagesResponseType()


RevisePriceAllowedDefinitionType Class

RevisePriceAllowedDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► RevisePriceAllowedDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RevisePriceAllowedDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RevisePriceAllowedDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RevisePriceAllowedDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RevisePriceAllowedDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
RevisePriceAllowedDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► RevisePriceAllowedDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


RevisePriceAllowedDefinitionType Constructor

RevisePriceAllowedDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► RevisePriceAllowedDefinitionType ► RevisePriceAllowedDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RevisePriceAllowedDefinitionType()
Public Sub New
public:
RevisePriceAllowedDefinitionType()


ReviseQuantityAllowedDefinitionType Class

ReviseQuantityAllowedDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseQuantityAllowedDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseQuantityAllowedDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseQuantityAllowedDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseQuantityAllowedDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseQuantityAllowedDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ReviseQuantityAllowedDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ReviseQuantityAllowedDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ReviseQuantityAllowedDefinitionType Constructor

ReviseQuantityAllowedDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseQuantityAllowedDefinitionType ► ReviseQuantityAllowedDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseQuantityAllowedDefinitionType()
Public Sub New
public:
ReviseQuantityAllowedDefinitionType()


ReviseSellingManagerInventoryFolderRequestType Class

ReviseSellingManagerInventoryFolderRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerInventoryFolderRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseSellingManagerInventoryFolderRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseSellingManagerInventoryFolderRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseSellingManagerInventoryFolderRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerInventoryFolderRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | Folder |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ReviseSellingManagerInventoryFolderRequestType


Folder Property

Folder Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerInventoryFolderRequestType ► Folder
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType Folder { get; set; }
Public Property Folder As SellingManagerFolderDetailsType
    Get
    Set
public:
property SellingManagerFolderDetailsType^ Folder {
    SellingManagerFolderDetailsType^ get ();
    void set (SellingManagerFolderDetailsType^ value);
}


ReviseSellingManagerInventoryFolderRequestType Constructor

ReviseSellingManagerInventoryFolderRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerInventoryFolderRequestType ► ReviseSellingManagerInventoryFolderRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerInventoryFolderRequestType()
Public Sub New
public:
ReviseSellingManagerInventoryFolderRequestType()


ReviseSellingManagerInventoryFolderResponseType Class

ReviseSellingManagerInventoryFolderResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerInventoryFolderResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseSellingManagerInventoryFolderResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseSellingManagerInventoryFolderResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseSellingManagerInventoryFolderResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerInventoryFolderResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | Folder |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ReviseSellingManagerInventoryFolderResponseType


Folder Property

Folder Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerInventoryFolderResponseType ► Folder
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType Folder { get; set; }
Public Property Folder As SellingManagerFolderDetailsType
    Get
    Set
public:
property SellingManagerFolderDetailsType^ Folder {
    SellingManagerFolderDetailsType^ get ();
    void set (SellingManagerFolderDetailsType^ value);
}


ReviseSellingManagerInventoryFolderResponseType Constructor

ReviseSellingManagerInventoryFolderResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerInventoryFolderResponseType ► ReviseSellingManagerInventoryFolderResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerInventoryFolderResponseType()
Public Sub New
public:
ReviseSellingManagerInventoryFolderResponseType()


ReviseSellingManagerProductRequestType Class

ReviseSellingManagerProductRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerProductRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseSellingManagerProductRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseSellingManagerProductRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseSellingManagerProductRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerProductRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DeletedField |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SellingManagerFolderDetails |
 | SellingManagerProductDetails |
 | SellingManagerProductSpecifics |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ReviseSellingManagerProductRequestType


DeletedField Property

DeletedField Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerProductRequestType ► DeletedField
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedField { get; set; }
Public Property DeletedField As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedField {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ReviseSellingManagerProductRequestType Constructor

ReviseSellingManagerProductRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerProductRequestType ► ReviseSellingManagerProductRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerProductRequestType()
Public Sub New
public:
ReviseSellingManagerProductRequestType()


SellingManagerFolderDetails Property

SellingManagerFolderDetails Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerProductRequestType ► SellingManagerFolderDetails
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType SellingManagerFolderDetails { get; set; }
Public Property SellingManagerFolderDetails As SellingManagerFolderDetailsType
    Get
    Set
public:
property SellingManagerFolderDetailsType^ SellingManagerFolderDetails {
    SellingManagerFolderDetailsType^ get ();
    void set (SellingManagerFolderDetailsType^ value);
}


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerProductRequestType ► SellingManagerProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; set; }
Public Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


SellingManagerProductSpecifics Property

SellingManagerProductSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerProductRequestType ► SellingManagerProductSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductSpecificsType SellingManagerProductSpecifics { get; set; }
Public Property SellingManagerProductSpecifics As SellingManagerProductSpecificsType
    Get
    Set
public:
property SellingManagerProductSpecificsType^ SellingManagerProductSpecifics {
    SellingManagerProductSpecificsType^ get ();
    void set (SellingManagerProductSpecificsType^ value);
}


ReviseSellingManagerProductResponseType Class

ReviseSellingManagerProductResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerProductResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseSellingManagerProductResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseSellingManagerProductResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseSellingManagerProductResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerProductResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SellingManagerProductDetails |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ReviseSellingManagerProductResponseType


ReviseSellingManagerProductResponseType Constructor

ReviseSellingManagerProductResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerProductResponseType ► ReviseSellingManagerProductResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerProductResponseType()
Public Sub New
public:
ReviseSellingManagerProductResponseType()


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerProductResponseType ► SellingManagerProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; set; }
Public Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


ReviseSellingManagerSaleRecordRequestType Class

ReviseSellingManagerSaleRecordRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerSaleRecordRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseSellingManagerSaleRecordRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseSellingManagerSaleRecordRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseSellingManagerSaleRecordRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerSaleRecordRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderID |
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SellingManagerSoldOrder |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ReviseSellingManagerSaleRecordRequestType


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerSaleRecordRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerSaleRecordRequestType ► OrderID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerSaleRecordRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


ReviseSellingManagerSaleRecordRequestType Constructor

ReviseSellingManagerSaleRecordRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerSaleRecordRequestType ► ReviseSellingManagerSaleRecordRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerSaleRecordRequestType()
Public Sub New
public:
ReviseSellingManagerSaleRecordRequestType()


SellingManagerSoldOrder Property

SellingManagerSoldOrder Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerSaleRecordRequestType ► SellingManagerSoldOrder
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderType SellingManagerSoldOrder { get; set; }
Public Property SellingManagerSoldOrder As SellingManagerSoldOrderType
    Get
    Set
public:
property SellingManagerSoldOrderType^ SellingManagerSoldOrder {
    SellingManagerSoldOrderType^ get ();
    void set (SellingManagerSoldOrderType^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerSaleRecordRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


ReviseSellingManagerSaleRecordResponseType Class

ReviseSellingManagerSaleRecordResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerSaleRecordResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseSellingManagerSaleRecordResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseSellingManagerSaleRecordResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseSellingManagerSaleRecordResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerSaleRecordResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ReviseSellingManagerSaleRecordResponseType


ReviseSellingManagerSaleRecordResponseType Constructor

ReviseSellingManagerSaleRecordResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerSaleRecordResponseType ► ReviseSellingManagerSaleRecordResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerSaleRecordResponseType()
Public Sub New
public:
ReviseSellingManagerSaleRecordResponseType()


ReviseSellingManagerTemplateRequestType Class

ReviseSellingManagerTemplateRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseSellingManagerTemplateRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseSellingManagerTemplateRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseSellingManagerTemplateRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerTemplateRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DeletedField |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ProductID |
 | ProductIDSpecified |
 | SaleTemplateID |
 | SaleTemplateIDSpecified |
 | SaleTemplateName |
 | ToString()()()() | (Inherited from Object.)
 | VerifyOnly |
 | VerifyOnlySpecified |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ReviseSellingManagerTemplateRequestType


DeletedField Property

DeletedField Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateRequestType ► DeletedField
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedField { get; set; }
Public Property DeletedField As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedField {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ProductID Property

ProductID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateRequestType ► ProductID
Declaration Syntax
C# Visual Basic Visual C++
public long ProductID { get; set; }
Public Property ProductID As Long
    Get
    Set
public:
property long long ProductID {
    long long get ();
    void set (long long value);
}


ProductIDSpecified Property

ProductIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateRequestType ► ProductIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductIDSpecified { get; set; }
Public Property ProductIDSpecified As Boolean
    Get
    Set
public:
property bool ProductIDSpecified {
    bool get ();
    void set (bool value);
}


ReviseSellingManagerTemplateRequestType Constructor

ReviseSellingManagerTemplateRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateRequestType ► ReviseSellingManagerTemplateRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerTemplateRequestType()
Public Sub New
public:
ReviseSellingManagerTemplateRequestType()


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateRequestType ► SaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


SaleTemplateIDSpecified Property

SaleTemplateIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateRequestType ► SaleTemplateIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SaleTemplateIDSpecified { get; set; }
Public Property SaleTemplateIDSpecified As Boolean
    Get
    Set
public:
property bool SaleTemplateIDSpecified {
    bool get ();
    void set (bool value);
}


SaleTemplateName Property

SaleTemplateName Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateRequestType ► SaleTemplateName
Declaration Syntax
C# Visual Basic Visual C++
public string SaleTemplateName { get; set; }
Public Property SaleTemplateName As String
    Get
    Set
public:
property String^ SaleTemplateName {
    String^ get ();
    void set (String^ value);
}


VerifyOnly Property

VerifyOnly Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateRequestType ► VerifyOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnly { get; set; }
Public Property VerifyOnly As Boolean
    Get
    Set
public:
property bool VerifyOnly {
    bool get ();
    void set (bool value);
}


VerifyOnlySpecified Property

VerifyOnlySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateRequestType ► VerifyOnlySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnlySpecified { get; set; }
Public Property VerifyOnlySpecified As Boolean
    Get
    Set
public:
property bool VerifyOnlySpecified {
    bool get ();
    void set (bool value);
}


ReviseSellingManagerTemplateResponseType Class

ReviseSellingManagerTemplateResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseSellingManagerTemplateResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseSellingManagerTemplateResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseSellingManagerTemplateResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseSellingManagerTemplateResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category2ID |
 | CategoryID |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SaleTemplateID |
 | SaleTemplateIDSpecified |
 | SaleTemplateName |
 | SellingManagerProductDetails |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | VerifyOnly |
 | VerifyOnlySpecified |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ReviseSellingManagerTemplateResponseType


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateResponseType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; set; }
Public Property Category2ID As String
    Get
    Set
public:
property String^ Category2ID {
    String^ get ();
    void set (String^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateResponseType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ReviseSellingManagerTemplateResponseType Constructor

ReviseSellingManagerTemplateResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateResponseType ► ReviseSellingManagerTemplateResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseSellingManagerTemplateResponseType()
Public Sub New
public:
ReviseSellingManagerTemplateResponseType()


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateResponseType ► SaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


SaleTemplateIDSpecified Property

SaleTemplateIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateResponseType ► SaleTemplateIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SaleTemplateIDSpecified { get; set; }
Public Property SaleTemplateIDSpecified As Boolean
    Get
    Set
public:
property bool SaleTemplateIDSpecified {
    bool get ();
    void set (bool value);
}


SaleTemplateName Property

SaleTemplateName Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateResponseType ► SaleTemplateName
Declaration Syntax
C# Visual Basic Visual C++
public string SaleTemplateName { get; set; }
Public Property SaleTemplateName As String
    Get
    Set
public:
property String^ SaleTemplateName {
    String^ get ();
    void set (String^ value);
}


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateResponseType ► SellingManagerProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; set; }
Public Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


VerifyOnly Property

VerifyOnly Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateResponseType ► VerifyOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnly { get; set; }
Public Property VerifyOnly As Boolean
    Get
    Set
public:
property bool VerifyOnly {
    bool get ();
    void set (bool value);
}


VerifyOnlySpecified Property

VerifyOnlySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseSellingManagerTemplateResponseType ► VerifyOnlySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifyOnlySpecified { get; set; }
Public Property VerifyOnlySpecified As Boolean
    Get
    Set
public:
property bool VerifyOnlySpecified {
    bool get ();
    void set (bool value);
}


ReviseStatusType Class

ReviseStatusType Class
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ReviseStatusType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ReviseStatusType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ReviseStatusType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReviseStatusType()()()() |
 | Any |
 | BuyItNowAdded |
 | BuyItNowAddedSpecified |
 | BuyItNowLowered |
 | BuyItNowLoweredSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemRevised |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReserveLowered |
 | ReserveLoweredSpecified |
 | ReserveRemoved |
 | ReserveRemovedSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ReviseStatusType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyItNowAdded Property

BuyItNowAdded Property
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType ► BuyItNowAdded
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyItNowAdded { get; set; }
Public Property BuyItNowAdded As Boolean
    Get
    Set
public:
property bool BuyItNowAdded {
    bool get ();
    void set (bool value);
}


BuyItNowAddedSpecified Property

BuyItNowAddedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType ► BuyItNowAddedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyItNowAddedSpecified { get; set; }
Public Property BuyItNowAddedSpecified As Boolean
    Get
    Set
public:
property bool BuyItNowAddedSpecified {
    bool get ();
    void set (bool value);
}


BuyItNowLowered Property

BuyItNowLowered Property
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType ► BuyItNowLowered
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyItNowLowered { get; set; }
Public Property BuyItNowLowered As Boolean
    Get
    Set
public:
property bool BuyItNowLowered {
    bool get ();
    void set (bool value);
}


BuyItNowLoweredSpecified Property

BuyItNowLoweredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType ► BuyItNowLoweredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyItNowLoweredSpecified { get; set; }
Public Property BuyItNowLoweredSpecified As Boolean
    Get
    Set
public:
property bool BuyItNowLoweredSpecified {
    bool get ();
    void set (bool value);
}


ItemRevised Property

ItemRevised Property
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType ► ItemRevised
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemRevised { get; set; }
Public Property ItemRevised As Boolean
    Get
    Set
public:
property bool ItemRevised {
    bool get ();
    void set (bool value);
}


ReserveLowered Property

ReserveLowered Property
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType ► ReserveLowered
Declaration Syntax
C# Visual Basic Visual C++
public bool ReserveLowered { get; set; }
Public Property ReserveLowered As Boolean
    Get
    Set
public:
property bool ReserveLowered {
    bool get ();
    void set (bool value);
}


ReserveLoweredSpecified Property

ReserveLoweredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType ► ReserveLoweredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReserveLoweredSpecified { get; set; }
Public Property ReserveLoweredSpecified As Boolean
    Get
    Set
public:
property bool ReserveLoweredSpecified {
    bool get ();
    void set (bool value);
}


ReserveRemoved Property

ReserveRemoved Property
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType ► ReserveRemoved
Declaration Syntax
C# Visual Basic Visual C++
public bool ReserveRemoved { get; set; }
Public Property ReserveRemoved As Boolean
    Get
    Set
public:
property bool ReserveRemoved {
    bool get ();
    void set (bool value);
}


ReserveRemovedSpecified Property

ReserveRemovedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType ► ReserveRemovedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReserveRemovedSpecified { get; set; }
Public Property ReserveRemovedSpecified As Boolean
    Get
    Set
public:
property bool ReserveRemovedSpecified {
    bool get ();
    void set (bool value);
}


ReviseStatusType Constructor

ReviseStatusType Constructor
Namespaces ► eBay.Service.Core.Soap ► ReviseStatusType ► ReviseStatusType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ReviseStatusType()
Public Sub New
public:
ReviseStatusType()


RevokeTokenRequestType Class

RevokeTokenRequestType Class
Namespaces ► eBay.Service.Core.Soap ► RevokeTokenRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RevokeTokenRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RevokeTokenRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RevokeTokenRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RevokeTokenRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | UnsubscribeNotification |
 | UnsubscribeNotificationSpecified |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | RevokeTokenRequestType


RevokeTokenRequestType Constructor

RevokeTokenRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► RevokeTokenRequestType ► RevokeTokenRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RevokeTokenRequestType()
Public Sub New
public:
RevokeTokenRequestType()


UnsubscribeNotification Property

UnsubscribeNotification Property
Namespaces ► eBay.Service.Core.Soap ► RevokeTokenRequestType ► UnsubscribeNotification
Declaration Syntax
C# Visual Basic Visual C++
public bool UnsubscribeNotification { get; set; }
Public Property UnsubscribeNotification As Boolean
    Get
    Set
public:
property bool UnsubscribeNotification {
    bool get ();
    void set (bool value);
}


UnsubscribeNotificationSpecified Property

UnsubscribeNotificationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► RevokeTokenRequestType ► UnsubscribeNotificationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UnsubscribeNotificationSpecified { get; set; }
Public Property UnsubscribeNotificationSpecified As Boolean
    Get
    Set
public:
property bool UnsubscribeNotificationSpecified {
    bool get ();
    void set (bool value);
}


RevokeTokenResponseType Class

RevokeTokenResponseType Class
Namespaces ► eBay.Service.Core.Soap ► RevokeTokenResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class RevokeTokenResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class RevokeTokenResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class RevokeTokenResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RevokeTokenResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | RevokeTokenResponseType


RevokeTokenResponseType Constructor

RevokeTokenResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► RevokeTokenResponseType ► RevokeTokenResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public RevokeTokenResponseType()
Public Sub New
public:
RevokeTokenResponseType()


SafePaymentRequiredDefinitionType Class

SafePaymentRequiredDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► SafePaymentRequiredDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SafePaymentRequiredDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SafePaymentRequiredDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SafePaymentRequiredDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SafePaymentRequiredDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SafePaymentRequiredDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SafePaymentRequiredDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SafePaymentRequiredDefinitionType Constructor

SafePaymentRequiredDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► SafePaymentRequiredDefinitionType ► SafePaymentRequiredDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SafePaymentRequiredDefinitionType()
Public Sub New
public:
SafePaymentRequiredDefinitionType()


SalesTaxType Class

SalesTaxType Class
Namespaces ► eBay.Service.Core.Soap ► SalesTaxType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SalesTaxType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SalesTaxType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SalesTaxType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SalesTaxType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SalesTaxAmount |
 | SalesTaxPercent |
 | SalesTaxPercentSpecified |
 | SalesTaxState |
 | ShippingIncludedInTax |
 | ShippingIncludedInTaxSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SalesTaxType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SalesTaxType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SalesTaxAmount Property

SalesTaxAmount Property
Namespaces ► eBay.Service.Core.Soap ► SalesTaxType ► SalesTaxAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType SalesTaxAmount { get; set; }
Public Property SalesTaxAmount As AmountType
    Get
    Set
public:
property AmountType^ SalesTaxAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


SalesTaxPercent Property

SalesTaxPercent Property
Namespaces ► eBay.Service.Core.Soap ► SalesTaxType ► SalesTaxPercent
Declaration Syntax
C# Visual Basic Visual C++
public float SalesTaxPercent { get; set; }
Public Property SalesTaxPercent As Single
    Get
    Set
public:
property float SalesTaxPercent {
    float get ();
    void set (float value);
}


SalesTaxPercentSpecified Property

SalesTaxPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SalesTaxType ► SalesTaxPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SalesTaxPercentSpecified { get; set; }
Public Property SalesTaxPercentSpecified As Boolean
    Get
    Set
public:
property bool SalesTaxPercentSpecified {
    bool get ();
    void set (bool value);
}


SalesTaxState Property

SalesTaxState Property
Namespaces ► eBay.Service.Core.Soap ► SalesTaxType ► SalesTaxState
Declaration Syntax
C# Visual Basic Visual C++
public string SalesTaxState { get; set; }
Public Property SalesTaxState As String
    Get
    Set
public:
property String^ SalesTaxState {
    String^ get ();
    void set (String^ value);
}


SalesTaxType Constructor

SalesTaxType Constructor
Namespaces ► eBay.Service.Core.Soap ► SalesTaxType ► SalesTaxType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SalesTaxType()
Public Sub New
public:
SalesTaxType()


ShippingIncludedInTax Property

ShippingIncludedInTax Property
Namespaces ► eBay.Service.Core.Soap ► SalesTaxType ► ShippingIncludedInTax
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingIncludedInTax { get; set; }
Public Property ShippingIncludedInTax As Boolean
    Get
    Set
public:
property bool ShippingIncludedInTax {
    bool get ();
    void set (bool value);
}


ShippingIncludedInTaxSpecified Property

ShippingIncludedInTaxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SalesTaxType ► ShippingIncludedInTaxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingIncludedInTaxSpecified { get; set; }
Public Property ShippingIncludedInTaxSpecified As Boolean
    Get
    Set
public:
property bool ShippingIncludedInTaxSpecified {
    bool get ();
    void set (bool value);
}


SaveItemToSellingManagerTemplateRequestType Class

SaveItemToSellingManagerTemplateRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SaveItemToSellingManagerTemplateRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SaveItemToSellingManagerTemplateRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SaveItemToSellingManagerTemplateRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SaveItemToSellingManagerTemplateRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveItemToSellingManagerTemplateRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ProductID |
 | ProductIDSpecified |
 | TemplateName |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SaveItemToSellingManagerTemplateRequestType


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► SaveItemToSellingManagerTemplateRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ProductID Property

ProductID Property
Namespaces ► eBay.Service.Core.Soap ► SaveItemToSellingManagerTemplateRequestType ► ProductID
Declaration Syntax
C# Visual Basic Visual C++
public long ProductID { get; set; }
Public Property ProductID As Long
    Get
    Set
public:
property long long ProductID {
    long long get ();
    void set (long long value);
}


ProductIDSpecified Property

ProductIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SaveItemToSellingManagerTemplateRequestType ► ProductIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductIDSpecified { get; set; }
Public Property ProductIDSpecified As Boolean
    Get
    Set
public:
property bool ProductIDSpecified {
    bool get ();
    void set (bool value);
}


SaveItemToSellingManagerTemplateRequestType Constructor

SaveItemToSellingManagerTemplateRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SaveItemToSellingManagerTemplateRequestType ► SaveItemToSellingManagerTemplateRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SaveItemToSellingManagerTemplateRequestType()
Public Sub New
public:
SaveItemToSellingManagerTemplateRequestType()


TemplateName Property

TemplateName Property
Namespaces ► eBay.Service.Core.Soap ► SaveItemToSellingManagerTemplateRequestType ► TemplateName
Declaration Syntax
C# Visual Basic Visual C++
public string TemplateName { get; set; }
Public Property TemplateName As String
    Get
    Set
public:
property String^ TemplateName {
    String^ get ();
    void set (String^ value);
}


SaveItemToSellingManagerTemplateResponseType Class

SaveItemToSellingManagerTemplateResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SaveItemToSellingManagerTemplateResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SaveItemToSellingManagerTemplateResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SaveItemToSellingManagerTemplateResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SaveItemToSellingManagerTemplateResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SaveItemToSellingManagerTemplateResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | TemplateID |
 | TemplateIDSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SaveItemToSellingManagerTemplateResponseType


SaveItemToSellingManagerTemplateResponseType Constructor

SaveItemToSellingManagerTemplateResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SaveItemToSellingManagerTemplateResponseType ► SaveItemToSellingManagerTemplateResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SaveItemToSellingManagerTemplateResponseType()
Public Sub New
public:
SaveItemToSellingManagerTemplateResponseType()


TemplateID Property

TemplateID Property
Namespaces ► eBay.Service.Core.Soap ► SaveItemToSellingManagerTemplateResponseType ► TemplateID
Declaration Syntax
C# Visual Basic Visual C++
public long TemplateID { get; set; }
Public Property TemplateID As Long
    Get
    Set
public:
property long long TemplateID {
    long long get ();
    void set (long long value);
}


TemplateIDSpecified Property

TemplateIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SaveItemToSellingManagerTemplateResponseType ► TemplateIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TemplateIDSpecified { get; set; }
Public Property TemplateIDSpecified As Boolean
    Get
    Set
public:
property bool TemplateIDSpecified {
    bool get ();
    void set (bool value);
}


SchedulingInfoType Class

SchedulingInfoType Class
Namespaces ► eBay.Service.Core.Soap ► SchedulingInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SchedulingInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SchedulingInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SchedulingInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SchedulingInfoType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MaxScheduledItems |
 | MaxScheduledItemsSpecified |
 | MaxScheduledMinutes |
 | MaxScheduledMinutesSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinScheduledMinutes |
 | MinScheduledMinutesSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SchedulingInfoType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SchedulingInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MaxScheduledItems Property

MaxScheduledItems Property
Namespaces ► eBay.Service.Core.Soap ► SchedulingInfoType ► MaxScheduledItems
Declaration Syntax
C# Visual Basic Visual C++
public int MaxScheduledItems { get; set; }
Public Property MaxScheduledItems As Integer
    Get
    Set
public:
property int MaxScheduledItems {
    int get ();
    void set (int value);
}


MaxScheduledItemsSpecified Property

MaxScheduledItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SchedulingInfoType ► MaxScheduledItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxScheduledItemsSpecified { get; set; }
Public Property MaxScheduledItemsSpecified As Boolean
    Get
    Set
public:
property bool MaxScheduledItemsSpecified {
    bool get ();
    void set (bool value);
}


MaxScheduledMinutes Property

MaxScheduledMinutes Property
Namespaces ► eBay.Service.Core.Soap ► SchedulingInfoType ► MaxScheduledMinutes
Declaration Syntax
C# Visual Basic Visual C++
public int MaxScheduledMinutes { get; set; }
Public Property MaxScheduledMinutes As Integer
    Get
    Set
public:
property int MaxScheduledMinutes {
    int get ();
    void set (int value);
}


MaxScheduledMinutesSpecified Property

MaxScheduledMinutesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SchedulingInfoType ► MaxScheduledMinutesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxScheduledMinutesSpecified { get; set; }
Public Property MaxScheduledMinutesSpecified As Boolean
    Get
    Set
public:
property bool MaxScheduledMinutesSpecified {
    bool get ();
    void set (bool value);
}


MinScheduledMinutes Property

MinScheduledMinutes Property
Namespaces ► eBay.Service.Core.Soap ► SchedulingInfoType ► MinScheduledMinutes
Declaration Syntax
C# Visual Basic Visual C++
public int MinScheduledMinutes { get; set; }
Public Property MinScheduledMinutes As Integer
    Get
    Set
public:
property int MinScheduledMinutes {
    int get ();
    void set (int value);
}


MinScheduledMinutesSpecified Property

MinScheduledMinutesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SchedulingInfoType ► MinScheduledMinutesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinScheduledMinutesSpecified { get; set; }
Public Property MinScheduledMinutesSpecified As Boolean
    Get
    Set
public:
property bool MinScheduledMinutesSpecified {
    bool get ();
    void set (bool value);
}


SchedulingInfoType Constructor

SchedulingInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► SchedulingInfoType ► SchedulingInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SchedulingInfoType()
Public Sub New
public:
SchedulingInfoType()


SearchDetailsType Class

SearchDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► SearchDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SearchDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SearchDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SearchDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchDetailsType()()()() |
 | Any |
 | BuyItNowEnabled |
 | BuyItNowEnabledSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Picture |
 | PictureSpecified |
 | RecentListing |
 | RecentListingSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SearchDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SearchDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyItNowEnabled Property

BuyItNowEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SearchDetailsType ► BuyItNowEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyItNowEnabled { get; set; }
Public Property BuyItNowEnabled As Boolean
    Get
    Set
public:
property bool BuyItNowEnabled {
    bool get ();
    void set (bool value);
}


BuyItNowEnabledSpecified Property

BuyItNowEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SearchDetailsType ► BuyItNowEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyItNowEnabledSpecified { get; set; }
Public Property BuyItNowEnabledSpecified As Boolean
    Get
    Set
public:
property bool BuyItNowEnabledSpecified {
    bool get ();
    void set (bool value);
}


Picture Property

Picture Property
Namespaces ► eBay.Service.Core.Soap ► SearchDetailsType ► Picture
Declaration Syntax
C# Visual Basic Visual C++
public bool Picture { get; set; }
Public Property Picture As Boolean
    Get
    Set
public:
property bool Picture {
    bool get ();
    void set (bool value);
}


PictureSpecified Property

PictureSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SearchDetailsType ► PictureSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PictureSpecified { get; set; }
Public Property PictureSpecified As Boolean
    Get
    Set
public:
property bool PictureSpecified {
    bool get ();
    void set (bool value);
}


RecentListing Property

RecentListing Property
Namespaces ► eBay.Service.Core.Soap ► SearchDetailsType ► RecentListing
Declaration Syntax
C# Visual Basic Visual C++
public bool RecentListing { get; set; }
Public Property RecentListing As Boolean
    Get
    Set
public:
property bool RecentListing {
    bool get ();
    void set (bool value);
}


RecentListingSpecified Property

RecentListingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SearchDetailsType ► RecentListingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RecentListingSpecified { get; set; }
Public Property RecentListingSpecified As Boolean
    Get
    Set
public:
property bool RecentListingSpecified {
    bool get ();
    void set (bool value);
}


SearchDetailsType Constructor

SearchDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SearchDetailsType ► SearchDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SearchDetailsType()
Public Sub New
public:
SearchDetailsType()


SearchFlagCodeType Enumeration

SearchFlagCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SearchFlagCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SearchFlagCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SearchFlagCodeType
Members
Member | Description
Charity |
Gift |
NowAndNew |
LocalSearch |
FreeShipping |
Gallery |
Picture |
GetItFast |
Lot |
GermanMotorsSearchable |
WorldOfGood |
DigitalDelivery |
CustomCode |
Remarks


SearchFlagCodeTypeCollection Class

SearchFlagCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SearchFlagCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SearchFlagCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SearchFlagCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchFlagCodeTypeCollection()()()() |
 | SearchFlagCodeTypeCollection(array<SearchFlagCodeType>[]()[][]) |
 | SearchFlagCodeTypeCollection(SearchFlagCodeTypeCollection) |
 | Add(SearchFlagCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SearchFlagCodeType>[]()[][]) |
 | AddRange(SearchFlagCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SearchFlagCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SearchFlagCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SearchFlagCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SearchFlagCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SearchFlagCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SearchFlagCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► Add(SearchFlagCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SearchFlagCodeType item
)
Public Function Add ( _
    item As SearchFlagCodeType _
) As Integer
public:
int Add(
    SearchFlagCodeType item
)
Parameters
item (SearchFlagCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SearchFlagCodeType>[]()[][]) |
 | AddRange(SearchFlagCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► AddRange(array<SearchFlagCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SearchFlagCodeType[] items
)
Public Sub AddRange ( _
    items As SearchFlagCodeType() _
)
public:
void AddRange(
    array<SearchFlagCodeType>^ items
)
Parameters
items (array< SearchFlagCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► AddRange(SearchFlagCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SearchFlagCodeTypeCollection items
)
Public Sub AddRange ( _
    items As SearchFlagCodeTypeCollection _
)
public:
void AddRange(
    SearchFlagCodeTypeCollection^ items
)
Parameters
items (SearchFlagCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► Contains(SearchFlagCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SearchFlagCodeType item
)
Public Function Contains ( _
    item As SearchFlagCodeType _
) As Boolean
public:
bool Contains(
    SearchFlagCodeType item
)
Parameters
item (SearchFlagCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► CopyTo(array<SearchFlagCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SearchFlagCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SearchFlagCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SearchFlagCodeType>^ items,
    int index
)
Parameters
items (array< SearchFlagCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► IndexOf(SearchFlagCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SearchFlagCodeType item
)
Public Function IndexOf ( _
    item As SearchFlagCodeType _
) As Integer
public:
int IndexOf(
    SearchFlagCodeType item
)
Parameters
item (SearchFlagCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► Insert(Int32, SearchFlagCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SearchFlagCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SearchFlagCodeType _
)
public:
void Insert(
    int index,
    SearchFlagCodeType item
)
Parameters
index (Int32)
item (SearchFlagCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SearchFlagCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SearchFlagCodeType
    Get
    Set
public:
property SearchFlagCodeType default[int index] {
    SearchFlagCodeType get (int index);
    void set (int index, SearchFlagCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SearchFlagCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SearchFlagCodeType
public:
SearchFlagCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► Remove(SearchFlagCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SearchFlagCodeType item
)
Public Sub Remove ( _
    item As SearchFlagCodeType _
)
public:
void Remove(
    SearchFlagCodeType item
)
Parameters
item (SearchFlagCodeType)


SearchFlagCodeTypeCollection Constructor

SearchFlagCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► SearchFlagCodeTypeCollection()()()()
Members
Icon | Member | Description
 | SearchFlagCodeTypeCollection()()()() |
 | SearchFlagCodeTypeCollection(array<SearchFlagCodeType>[]()[][]) |
 | SearchFlagCodeTypeCollection(SearchFlagCodeTypeCollection) |


SearchFlagCodeTypeCollection Constructor

SearchFlagCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► SearchFlagCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SearchFlagCodeTypeCollection()
Public Sub New
public:
SearchFlagCodeTypeCollection()


SearchFlagCodeTypeCollection Constructor (items)

SearchFlagCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► SearchFlagCodeTypeCollection(array<SearchFlagCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SearchFlagCodeTypeCollection(
    SearchFlagCodeType[] items
)
Public Sub New ( _
    items As SearchFlagCodeType() _
)
public:
SearchFlagCodeTypeCollection(
    array<SearchFlagCodeType>^ items
)
Parameters
items (array< SearchFlagCodeType >[]()[][])


SearchFlagCodeTypeCollection Constructor (items)

SearchFlagCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► SearchFlagCodeTypeCollection(SearchFlagCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SearchFlagCodeTypeCollection(
    SearchFlagCodeTypeCollection items
)
Public Sub New ( _
    items As SearchFlagCodeTypeCollection _
)
public:
SearchFlagCodeTypeCollection(
    SearchFlagCodeTypeCollection^ items
)
Parameters
items (SearchFlagCodeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SearchFlagCodeType[] ToArray()
Public Function ToArray As SearchFlagCodeType()
public:
array<SearchFlagCodeType>^ ToArray()
Return Value


SearchStandingDashboardType Class

SearchStandingDashboardType Class
Namespaces ► eBay.Service.Core.Soap ► SearchStandingDashboardType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SearchStandingDashboardType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SearchStandingDashboardType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SearchStandingDashboardType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SearchStandingDashboardType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SearchStandingDashboardType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SearchStandingDashboardType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SearchStandingDashboardType Constructor

SearchStandingDashboardType Constructor
Namespaces ► eBay.Service.Core.Soap ► SearchStandingDashboardType ► SearchStandingDashboardType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SearchStandingDashboardType()
Public Sub New
public:
SearchStandingDashboardType()


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► SearchStandingDashboardType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public SearchStandingStatusCodeType Status { get; set; }
Public Property Status As SearchStandingStatusCodeType
    Get
    Set
public:
property SearchStandingStatusCodeType Status {
    SearchStandingStatusCodeType get ();
    void set (SearchStandingStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SearchStandingDashboardType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


SearchStandingStatusCodeType Enumeration

SearchStandingStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SearchStandingStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SearchStandingStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SearchStandingStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SearchStandingStatusCodeType
Members
Member | Description
Raised |
Standard |
Lowered |
CustomCode |
Remarks


SecondChanceOfferDurationCodeType Enumeration

SecondChanceOfferDurationCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SecondChanceOfferDurationCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SecondChanceOfferDurationCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SecondChanceOfferDurationCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SecondChanceOfferDurationCodeType
Members
Member | Description
Days_1 |
Days_3 |
Days_5 |
Days_7 |
CustomCode |
Remarks


SelectionModeCodeType Enumeration

SelectionModeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SelectionModeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SelectionModeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SelectionModeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SelectionModeCodeType
Members
Member | Description
Automatic |
Manual |
Prefilled |
SelectionOnly |
FreeText |
CustomCode |
Remarks


SellerAccountDashboardType Class

SellerAccountDashboardType Class
Namespaces ► eBay.Service.Core.Soap ► SellerAccountDashboardType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerAccountDashboardType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerAccountDashboardType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerAccountDashboardType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerAccountDashboardType()()()() |
 | Alert |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerAccountDashboardType


Alert Property

Alert Property
Namespaces ► eBay.Service.Core.Soap ► SellerAccountDashboardType ► Alert
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertTypeCollection Alert { get; set; }
Public Property Alert As SellerDashboardAlertTypeCollection
    Get
    Set
public:
property SellerDashboardAlertTypeCollection^ Alert {
    SellerDashboardAlertTypeCollection^ get ();
    void set (SellerDashboardAlertTypeCollection^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerAccountDashboardType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SellerAccountDashboardType Constructor

SellerAccountDashboardType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerAccountDashboardType ► SellerAccountDashboardType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerAccountDashboardType()
Public Sub New
public:
SellerAccountDashboardType()


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► SellerAccountDashboardType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public SellerAccountStatusCodeType Status { get; set; }
Public Property Status As SellerAccountStatusCodeType
    Get
    Set
public:
property SellerAccountStatusCodeType Status {
    SellerAccountStatusCodeType get ();
    void set (SellerAccountStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerAccountDashboardType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


SellerAccountStatusCodeType Enumeration

SellerAccountStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellerAccountStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellerAccountStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellerAccountStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellerAccountStatusCodeType
Members
Member | Description
Current |
PastDue |
OnHold |
CustomCode |
Remarks


SellerBusinessCodeType Enumeration

SellerBusinessCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellerBusinessCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellerBusinessCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellerBusinessCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellerBusinessCodeType
Members
Member | Description
Undefined |
Private |
Commercial |
CustomCode |
Remarks


SellerContactDetailsEnabledDefinitionType Class

SellerContactDetailsEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► SellerContactDetailsEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerContactDetailsEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerContactDetailsEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerContactDetailsEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerContactDetailsEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerContactDetailsEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerContactDetailsEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SellerContactDetailsEnabledDefinitionType Constructor

SellerContactDetailsEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerContactDetailsEnabledDefinitionType ► SellerContactDetailsEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerContactDetailsEnabledDefinitionType()
Public Sub New
public:
SellerContactDetailsEnabledDefinitionType()


SellerDashboardAlertSeverityCodeType Enumeration

SellerDashboardAlertSeverityCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertSeverityCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellerDashboardAlertSeverityCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellerDashboardAlertSeverityCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellerDashboardAlertSeverityCodeType
Members
Member | Description
Informational |
Warning |
StrongWarning |
CustomCode |
Remarks


SellerDashboardAlertType Class

SellerDashboardAlertType Class
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerDashboardAlertType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerDashboardAlertType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerDashboardAlertType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerDashboardAlertType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Severity |
 | SeveritySpecified |
 | Text |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerDashboardAlertType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SellerDashboardAlertType Constructor

SellerDashboardAlertType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertType ► SellerDashboardAlertType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertType()
Public Sub New
public:
SellerDashboardAlertType()


Severity Property

Severity Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertType ► Severity
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertSeverityCodeType Severity { get; set; }
Public Property Severity As SellerDashboardAlertSeverityCodeType
    Get
    Set
public:
property SellerDashboardAlertSeverityCodeType Severity {
    SellerDashboardAlertSeverityCodeType get ();
    void set (SellerDashboardAlertSeverityCodeType value);
}


SeveritySpecified Property

SeveritySpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertType ► SeveritySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SeveritySpecified { get; set; }
Public Property SeveritySpecified As Boolean
    Get
    Set
public:
property bool SeveritySpecified {
    bool get ();
    void set (bool value);
}


Text Property

Text Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertType ► Text
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}


SellerDashboardAlertTypeCollection Class

SellerDashboardAlertTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellerDashboardAlertTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellerDashboardAlertTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellerDashboardAlertTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerDashboardAlertTypeCollection()()()() |
 | SellerDashboardAlertTypeCollection(array<SellerDashboardAlertType>[]()[][]) |
 | SellerDashboardAlertTypeCollection(SellerDashboardAlertTypeCollection) |
 | Add(SellerDashboardAlertType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellerDashboardAlertType>[]()[][]) |
 | AddRange(SellerDashboardAlertTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellerDashboardAlertType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellerDashboardAlertType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellerDashboardAlertType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellerDashboardAlertType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellerDashboardAlertType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellerDashboardAlertTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► Add(SellerDashboardAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellerDashboardAlertType item
)
Public Function Add ( _
    item As SellerDashboardAlertType _
) As Integer
public:
int Add(
    SellerDashboardAlertType^ item
)
Parameters
item (SellerDashboardAlertType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellerDashboardAlertType>[]()[][]) |
 | AddRange(SellerDashboardAlertTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► AddRange(array<SellerDashboardAlertType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellerDashboardAlertType[] items
)
Public Sub AddRange ( _
    items As SellerDashboardAlertType() _
)
public:
void AddRange(
    array<SellerDashboardAlertType^>^ items
)
Parameters
items (array< SellerDashboardAlertType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► AddRange(SellerDashboardAlertTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellerDashboardAlertTypeCollection items
)
Public Sub AddRange ( _
    items As SellerDashboardAlertTypeCollection _
)
public:
void AddRange(
    SellerDashboardAlertTypeCollection^ items
)
Parameters
items (SellerDashboardAlertTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► Contains(SellerDashboardAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellerDashboardAlertType item
)
Public Function Contains ( _
    item As SellerDashboardAlertType _
) As Boolean
public:
bool Contains(
    SellerDashboardAlertType^ item
)
Parameters
item (SellerDashboardAlertType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► CopyTo(array<SellerDashboardAlertType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellerDashboardAlertType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellerDashboardAlertType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellerDashboardAlertType^>^ items,
    int index
)
Parameters
items (array< SellerDashboardAlertType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► IndexOf(SellerDashboardAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellerDashboardAlertType item
)
Public Function IndexOf ( _
    item As SellerDashboardAlertType _
) As Integer
public:
int IndexOf(
    SellerDashboardAlertType^ item
)
Parameters
item (SellerDashboardAlertType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► Insert(Int32, SellerDashboardAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellerDashboardAlertType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellerDashboardAlertType _
)
public:
void Insert(
    int index,
    SellerDashboardAlertType^ item
)
Parameters
index (Int32)
item (SellerDashboardAlertType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellerDashboardAlertType
    Get
    Set
public:
property SellerDashboardAlertType^ default[int index] {
    SellerDashboardAlertType^ get (int index);
    void set (int index, SellerDashboardAlertType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellerDashboardAlertType
public:
SellerDashboardAlertType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► Remove(SellerDashboardAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellerDashboardAlertType item
)
Public Sub Remove ( _
    item As SellerDashboardAlertType _
)
public:
void Remove(
    SellerDashboardAlertType^ item
)
Parameters
item (SellerDashboardAlertType)


SellerDashboardAlertTypeCollection Constructor

SellerDashboardAlertTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► SellerDashboardAlertTypeCollection()()()()
Members
Icon | Member | Description
 | SellerDashboardAlertTypeCollection()()()() |
 | SellerDashboardAlertTypeCollection(array<SellerDashboardAlertType>[]()[][]) |
 | SellerDashboardAlertTypeCollection(SellerDashboardAlertTypeCollection) |


SellerDashboardAlertTypeCollection Constructor

SellerDashboardAlertTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► SellerDashboardAlertTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertTypeCollection()
Public Sub New
public:
SellerDashboardAlertTypeCollection()


SellerDashboardAlertTypeCollection Constructor (items)

SellerDashboardAlertTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► SellerDashboardAlertTypeCollection(array<SellerDashboardAlertType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertTypeCollection(
    SellerDashboardAlertType[] items
)
Public Sub New ( _
    items As SellerDashboardAlertType() _
)
public:
SellerDashboardAlertTypeCollection(
    array<SellerDashboardAlertType^>^ items
)
Parameters
items (array< SellerDashboardAlertType >[]()[][])


SellerDashboardAlertTypeCollection Constructor (items)

SellerDashboardAlertTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► SellerDashboardAlertTypeCollection(SellerDashboardAlertTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertTypeCollection(
    SellerDashboardAlertTypeCollection items
)
Public Sub New ( _
    items As SellerDashboardAlertTypeCollection _
)
public:
SellerDashboardAlertTypeCollection(
    SellerDashboardAlertTypeCollection^ items
)
Parameters
items (SellerDashboardAlertTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerDashboardAlertType[] ToArray()
Public Function ToArray As SellerDashboardAlertType()
public:
array<SellerDashboardAlertType^>^ ToArray()
Return Value


SellerDiscountsType Class

SellerDiscountsType Class
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerDiscountsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerDiscountsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerDiscountsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerDiscountsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OriginalItemPrice |
 | OriginalItemShippingCost |
 | OriginalShippingService |
 | SellerDiscount |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerDiscountsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


OriginalItemPrice Property

OriginalItemPrice Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountsType ► OriginalItemPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType OriginalItemPrice { get; set; }
Public Property OriginalItemPrice As AmountType
    Get
    Set
public:
property AmountType^ OriginalItemPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


OriginalItemShippingCost Property

OriginalItemShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountsType ► OriginalItemShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType OriginalItemShippingCost { get; set; }
Public Property OriginalItemShippingCost As AmountType
    Get
    Set
public:
property AmountType^ OriginalItemShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


OriginalShippingService Property

OriginalShippingService Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountsType ► OriginalShippingService
Declaration Syntax
C# Visual Basic Visual C++
public string OriginalShippingService { get; set; }
Public Property OriginalShippingService As String
    Get
    Set
public:
property String^ OriginalShippingService {
    String^ get ();
    void set (String^ value);
}


SellerDiscount Property

SellerDiscount Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountsType ► SellerDiscount
Declaration Syntax
C# Visual Basic Visual C++
public SellerDiscountTypeCollection SellerDiscount { get; set; }
Public Property SellerDiscount As SellerDiscountTypeCollection
    Get
    Set
public:
property SellerDiscountTypeCollection^ SellerDiscount {
    SellerDiscountTypeCollection^ get ();
    void set (SellerDiscountTypeCollection^ value);
}


SellerDiscountsType Constructor

SellerDiscountsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountsType ► SellerDiscountsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerDiscountsType()
Public Sub New
public:
SellerDiscountsType()


SellerDiscountType Class

SellerDiscountType Class
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerDiscountType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerDiscountType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerDiscountType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerDiscountType()()()() |
 | Any |
 | CampaignDisplayName |
 | CampaignID |
 | CampaignIDSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemDiscountAmount |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingDiscountAmount |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerDiscountType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CampaignDisplayName Property

CampaignDisplayName Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountType ► CampaignDisplayName
Declaration Syntax
C# Visual Basic Visual C++
public string CampaignDisplayName { get; set; }
Public Property CampaignDisplayName As String
    Get
    Set
public:
property String^ CampaignDisplayName {
    String^ get ();
    void set (String^ value);
}


CampaignID Property

CampaignID Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountType ► CampaignID
Declaration Syntax
C# Visual Basic Visual C++
public long CampaignID { get; set; }
Public Property CampaignID As Long
    Get
    Set
public:
property long long CampaignID {
    long long get ();
    void set (long long value);
}


CampaignIDSpecified Property

CampaignIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountType ► CampaignIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CampaignIDSpecified { get; set; }
Public Property CampaignIDSpecified As Boolean
    Get
    Set
public:
property bool CampaignIDSpecified {
    bool get ();
    void set (bool value);
}


ItemDiscountAmount Property

ItemDiscountAmount Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountType ► ItemDiscountAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ItemDiscountAmount { get; set; }
Public Property ItemDiscountAmount As AmountType
    Get
    Set
public:
property AmountType^ ItemDiscountAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


SellerDiscountType Constructor

SellerDiscountType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountType ► SellerDiscountType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerDiscountType()
Public Sub New
public:
SellerDiscountType()


ShippingDiscountAmount Property

ShippingDiscountAmount Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountType ► ShippingDiscountAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingDiscountAmount { get; set; }
Public Property ShippingDiscountAmount As AmountType
    Get
    Set
public:
property AmountType^ ShippingDiscountAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


SellerDiscountTypeCollection Class

SellerDiscountTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellerDiscountTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellerDiscountTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellerDiscountTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerDiscountTypeCollection()()()() |
 | SellerDiscountTypeCollection(array<SellerDiscountType>[]()[][]) |
 | SellerDiscountTypeCollection(SellerDiscountTypeCollection) |
 | Add(SellerDiscountType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellerDiscountType>[]()[][]) |
 | AddRange(SellerDiscountTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellerDiscountType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellerDiscountType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellerDiscountType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellerDiscountType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellerDiscountType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellerDiscountTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► Add(SellerDiscountType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellerDiscountType item
)
Public Function Add ( _
    item As SellerDiscountType _
) As Integer
public:
int Add(
    SellerDiscountType^ item
)
Parameters
item (SellerDiscountType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellerDiscountType>[]()[][]) |
 | AddRange(SellerDiscountTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► AddRange(array<SellerDiscountType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellerDiscountType[] items
)
Public Sub AddRange ( _
    items As SellerDiscountType() _
)
public:
void AddRange(
    array<SellerDiscountType^>^ items
)
Parameters
items (array< SellerDiscountType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► AddRange(SellerDiscountTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellerDiscountTypeCollection items
)
Public Sub AddRange ( _
    items As SellerDiscountTypeCollection _
)
public:
void AddRange(
    SellerDiscountTypeCollection^ items
)
Parameters
items (SellerDiscountTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► Contains(SellerDiscountType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellerDiscountType item
)
Public Function Contains ( _
    item As SellerDiscountType _
) As Boolean
public:
bool Contains(
    SellerDiscountType^ item
)
Parameters
item (SellerDiscountType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► CopyTo(array<SellerDiscountType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellerDiscountType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellerDiscountType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellerDiscountType^>^ items,
    int index
)
Parameters
items (array< SellerDiscountType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► IndexOf(SellerDiscountType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellerDiscountType item
)
Public Function IndexOf ( _
    item As SellerDiscountType _
) As Integer
public:
int IndexOf(
    SellerDiscountType^ item
)
Parameters
item (SellerDiscountType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► Insert(Int32, SellerDiscountType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellerDiscountType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellerDiscountType _
)
public:
void Insert(
    int index,
    SellerDiscountType^ item
)
Parameters
index (Int32)
item (SellerDiscountType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellerDiscountType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellerDiscountType
    Get
    Set
public:
property SellerDiscountType^ default[int index] {
    SellerDiscountType^ get (int index);
    void set (int index, SellerDiscountType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellerDiscountType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellerDiscountType
public:
SellerDiscountType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► Remove(SellerDiscountType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellerDiscountType item
)
Public Sub Remove ( _
    item As SellerDiscountType _
)
public:
void Remove(
    SellerDiscountType^ item
)
Parameters
item (SellerDiscountType)


SellerDiscountTypeCollection Constructor

SellerDiscountTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► SellerDiscountTypeCollection()()()()
Members
Icon | Member | Description
 | SellerDiscountTypeCollection()()()() |
 | SellerDiscountTypeCollection(array<SellerDiscountType>[]()[][]) |
 | SellerDiscountTypeCollection(SellerDiscountTypeCollection) |


SellerDiscountTypeCollection Constructor

SellerDiscountTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► SellerDiscountTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerDiscountTypeCollection()
Public Sub New
public:
SellerDiscountTypeCollection()


SellerDiscountTypeCollection Constructor (items)

SellerDiscountTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► SellerDiscountTypeCollection(array<SellerDiscountType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellerDiscountTypeCollection(
    SellerDiscountType[] items
)
Public Sub New ( _
    items As SellerDiscountType() _
)
public:
SellerDiscountTypeCollection(
    array<SellerDiscountType^>^ items
)
Parameters
items (array< SellerDiscountType >[]()[][])


SellerDiscountTypeCollection Constructor (items)

SellerDiscountTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► SellerDiscountTypeCollection(SellerDiscountTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellerDiscountTypeCollection(
    SellerDiscountTypeCollection items
)
Public Sub New ( _
    items As SellerDiscountTypeCollection _
)
public:
SellerDiscountTypeCollection(
    SellerDiscountTypeCollection^ items
)
Parameters
items (SellerDiscountTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerDiscountType[] ToArray()
Public Function ToArray As SellerDiscountType()
public:
array<SellerDiscountType^>^ ToArray()
Return Value


SellereBayPaymentProcessConsentCodeType Class

SellereBayPaymentProcessConsentCodeType Class
Namespaces ► eBay.Service.Core.Soap ► SellereBayPaymentProcessConsentCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellereBayPaymentProcessConsentCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellereBayPaymentProcessConsentCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellereBayPaymentProcessConsentCodeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellereBayPaymentProcessConsentCodeType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PayoutMethod |
 | PayoutMethodSet |
 | PayoutMethodSetSpecified |
 | PayoutMethodSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UserAgreementInfo |
Remarks
Inheritance Hierarchy
Object
SellereBayPaymentProcessConsentCodeType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellereBayPaymentProcessConsentCodeType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PayoutMethod Property

PayoutMethod Property
Namespaces ► eBay.Service.Core.Soap ► SellereBayPaymentProcessConsentCodeType ► PayoutMethod
Declaration Syntax
C# Visual Basic Visual C++
public PayoutMethodType PayoutMethod { get; set; }
Public Property PayoutMethod As PayoutMethodType
    Get
    Set
public:
property PayoutMethodType PayoutMethod {
    PayoutMethodType get ();
    void set (PayoutMethodType value);
}


PayoutMethodSet Property

PayoutMethodSet Property
Namespaces ► eBay.Service.Core.Soap ► SellereBayPaymentProcessConsentCodeType ► PayoutMethodSet
Declaration Syntax
C# Visual Basic Visual C++
public bool PayoutMethodSet { get; set; }
Public Property PayoutMethodSet As Boolean
    Get
    Set
public:
property bool PayoutMethodSet {
    bool get ();
    void set (bool value);
}


PayoutMethodSetSpecified Property

PayoutMethodSetSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellereBayPaymentProcessConsentCodeType ► PayoutMethodSetSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayoutMethodSetSpecified { get; set; }
Public Property PayoutMethodSetSpecified As Boolean
    Get
    Set
public:
property bool PayoutMethodSetSpecified {
    bool get ();
    void set (bool value);
}


PayoutMethodSpecified Property

PayoutMethodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellereBayPaymentProcessConsentCodeType ► PayoutMethodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayoutMethodSpecified { get; set; }
Public Property PayoutMethodSpecified As Boolean
    Get
    Set
public:
property bool PayoutMethodSpecified {
    bool get ();
    void set (bool value);
}


SellereBayPaymentProcessConsentCodeType Constructor

SellereBayPaymentProcessConsentCodeType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellereBayPaymentProcessConsentCodeType ► SellereBayPaymentProcessConsentCodeType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellereBayPaymentProcessConsentCodeType()
Public Sub New
public:
SellereBayPaymentProcessConsentCodeType()


UserAgreementInfo Property

UserAgreementInfo Property
Namespaces ► eBay.Service.Core.Soap ► SellereBayPaymentProcessConsentCodeType ► UserAgreementInfo
Declaration Syntax
C# Visual Basic Visual C++
public UserAgreementInfoTypeCollection UserAgreementInfo { get; set; }
Public Property UserAgreementInfo As UserAgreementInfoTypeCollection
    Get
    Set
public:
property UserAgreementInfoTypeCollection^ UserAgreementInfo {
    UserAgreementInfoTypeCollection^ get ();
    void set (UserAgreementInfoTypeCollection^ value);
}


SellereBayPaymentProcessStatusCodeType Enumeration

SellereBayPaymentProcessStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellereBayPaymentProcessStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellereBayPaymentProcessStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellereBayPaymentProcessStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellereBayPaymentProcessStatusCodeType
Members
Member | Description
AcceptedUA |
MustAcceptUA |
eBayPaymentProcessEnabled |
CustomCode |
Remarks


SellerExcludeShipToLocationPreferencesType Class

SellerExcludeShipToLocationPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► SellerExcludeShipToLocationPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerExcludeShipToLocationPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerExcludeShipToLocationPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerExcludeShipToLocationPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerExcludeShipToLocationPreferencesType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | ExcludeShipToLocation |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerExcludeShipToLocationPreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerExcludeShipToLocationPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExcludeShipToLocation Property

ExcludeShipToLocation Property
Namespaces ► eBay.Service.Core.Soap ► SellerExcludeShipToLocationPreferencesType ► ExcludeShipToLocation
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ExcludeShipToLocation { get; set; }
Public Property ExcludeShipToLocation As StringCollection
    Get
    Set
public:
property StringCollection^ ExcludeShipToLocation {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


SellerExcludeShipToLocationPreferencesType Constructor

SellerExcludeShipToLocationPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerExcludeShipToLocationPreferencesType ► SellerExcludeShipToLocationPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerExcludeShipToLocationPreferencesType()
Public Sub New
public:
SellerExcludeShipToLocationPreferencesType()


SellerFavoriteItemPreferencesType Class

SellerFavoriteItemPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerFavoriteItemPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerFavoriteItemPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerFavoriteItemPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerFavoriteItemPreferencesType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | FavoriteItemID |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ListingType |
 | ListingTypeSpecified |
 | MaxPrice |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinPrice |
 | SearchKeywords |
 | SearchSortOrder |
 | SearchSortOrderSpecified |
 | StoreCategoryID |
 | StoreCategoryIDSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerFavoriteItemPreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FavoriteItemID Property

FavoriteItemID Property
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► FavoriteItemID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection FavoriteItemID { get; set; }
Public Property FavoriteItemID As StringCollection
    Get
    Set
public:
property StringCollection^ FavoriteItemID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ListingType Property

ListingType Property
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► ListingType
Declaration Syntax
C# Visual Basic Visual C++
public ListingTypeCodeType ListingType { get; set; }
Public Property ListingType As ListingTypeCodeType
    Get
    Set
public:
property ListingTypeCodeType ListingType {
    ListingTypeCodeType get ();
    void set (ListingTypeCodeType value);
}


ListingTypeSpecified Property

ListingTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► ListingTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingTypeSpecified { get; set; }
Public Property ListingTypeSpecified As Boolean
    Get
    Set
public:
property bool ListingTypeSpecified {
    bool get ();
    void set (bool value);
}


MaxPrice Property

MaxPrice Property
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► MaxPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MaxPrice { get; set; }
Public Property MaxPrice As AmountType
    Get
    Set
public:
property AmountType^ MaxPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


MinPrice Property

MinPrice Property
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► MinPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MinPrice { get; set; }
Public Property MinPrice As AmountType
    Get
    Set
public:
property AmountType^ MinPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


SearchKeywords Property

SearchKeywords Property
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► SearchKeywords
Declaration Syntax
C# Visual Basic Visual C++
public string SearchKeywords { get; set; }
Public Property SearchKeywords As String
    Get
    Set
public:
property String^ SearchKeywords {
    String^ get ();
    void set (String^ value);
}


SearchSortOrder Property

SearchSortOrder Property
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► SearchSortOrder
Declaration Syntax
C# Visual Basic Visual C++
public StoreItemListSortOrderCodeType SearchSortOrder { get; set; }
Public Property SearchSortOrder As StoreItemListSortOrderCodeType
    Get
    Set
public:
property StoreItemListSortOrderCodeType SearchSortOrder {
    StoreItemListSortOrderCodeType get ();
    void set (StoreItemListSortOrderCodeType value);
}


SearchSortOrderSpecified Property

SearchSortOrderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► SearchSortOrderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SearchSortOrderSpecified { get; set; }
Public Property SearchSortOrderSpecified As Boolean
    Get
    Set
public:
property bool SearchSortOrderSpecified {
    bool get ();
    void set (bool value);
}


SellerFavoriteItemPreferencesType Constructor

SellerFavoriteItemPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► SellerFavoriteItemPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerFavoriteItemPreferencesType()
Public Sub New
public:
SellerFavoriteItemPreferencesType()


StoreCategoryID Property

StoreCategoryID Property
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► StoreCategoryID
Declaration Syntax
C# Visual Basic Visual C++
public long StoreCategoryID { get; set; }
Public Property StoreCategoryID As Long
    Get
    Set
public:
property long long StoreCategoryID {
    long long get ();
    void set (long long value);
}


StoreCategoryIDSpecified Property

StoreCategoryIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerFavoriteItemPreferencesType ► StoreCategoryIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreCategoryIDSpecified { get; set; }
Public Property StoreCategoryIDSpecified As Boolean
    Get
    Set
public:
property bool StoreCategoryIDSpecified {
    bool get ();
    void set (bool value);
}


SellerFeeDiscountDashboardType Class

SellerFeeDiscountDashboardType Class
Namespaces ► eBay.Service.Core.Soap ► SellerFeeDiscountDashboardType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerFeeDiscountDashboardType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerFeeDiscountDashboardType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerFeeDiscountDashboardType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerFeeDiscountDashboardType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Percent |
 | PercentSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerFeeDiscountDashboardType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerFeeDiscountDashboardType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Percent Property

Percent Property
Namespaces ► eBay.Service.Core.Soap ► SellerFeeDiscountDashboardType ► Percent
Declaration Syntax
C# Visual Basic Visual C++
public float Percent { get; set; }
Public Property Percent As Single
    Get
    Set
public:
property float Percent {
    float get ();
    void set (float value);
}


PercentSpecified Property

PercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerFeeDiscountDashboardType ► PercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PercentSpecified { get; set; }
Public Property PercentSpecified As Boolean
    Get
    Set
public:
property bool PercentSpecified {
    bool get ();
    void set (bool value);
}


SellerFeeDiscountDashboardType Constructor

SellerFeeDiscountDashboardType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerFeeDiscountDashboardType ► SellerFeeDiscountDashboardType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerFeeDiscountDashboardType()
Public Sub New
public:
SellerFeeDiscountDashboardType()


SellerGuaranteeLevelCodeType Enumeration

SellerGuaranteeLevelCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellerGuaranteeLevelCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellerGuaranteeLevelCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellerGuaranteeLevelCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellerGuaranteeLevelCodeType
Members
Member | Description
NotEligible |
Regular |
Premium |
Ultra |
CustomCode |
Remarks


SellerLevelCodeType Enumeration

SellerLevelCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellerLevelCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellerLevelCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellerLevelCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellerLevelCodeType
Members
Member | Description
Bronze |
Silver |
Gold |
Platinum |
Titanium |
None |
CustomCode |
Remarks


SellerPaymentMethodCodeType Enumeration

SellerPaymentMethodCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentMethodCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellerPaymentMethodCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellerPaymentMethodCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellerPaymentMethodCodeType
Members
Member | Description
NothingOnFile |
CreditCard |
PayPal |
DirectDebit |
DirectDebitPendingSignatureMandate |
eBayDirectPay |
CustomCode |
DirectDebitPendingVerification |
Remarks


SellerPaymentPreferencesType Class

SellerPaymentPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerPaymentPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerPaymentPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerPaymentPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerPaymentPreferencesType()()()() |
 | AlwaysUseThisPaymentAddress |
 | AlwaysUseThisPaymentAddressSpecified |
 | Any |
 | DefaultPayPalEmailAddress |
 | DisplayPayNowButton |
 | DisplayPayNowButtonSpecified |
 | Equals(Object) | (Inherited from Object.)
 | FedExRateOption |
 | FedExRateOptionSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PayPalAlwaysOn |
 | PayPalAlwaysOnSpecified |
 | PayPalPreferred |
 | PayPalPreferredSpecified |
 | SellerPaymentAddress |
 | ToString()()()() | (Inherited from Object.)
 | UPSRateOption |
 | UPSRateOptionSpecified |
 | USPSRateOption |
 | USPSRateOptionSpecified |
Remarks
Inheritance Hierarchy
Object
SellerPaymentPreferencesType


AlwaysUseThisPaymentAddress Property

AlwaysUseThisPaymentAddress Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► AlwaysUseThisPaymentAddress
Declaration Syntax
C# Visual Basic Visual C++
public bool AlwaysUseThisPaymentAddress { get; set; }
Public Property AlwaysUseThisPaymentAddress As Boolean
    Get
    Set
public:
property bool AlwaysUseThisPaymentAddress {
    bool get ();
    void set (bool value);
}


AlwaysUseThisPaymentAddressSpecified Property

AlwaysUseThisPaymentAddressSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► AlwaysUseThisPaymentAddressSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AlwaysUseThisPaymentAddressSpecified { get; set; }
Public Property AlwaysUseThisPaymentAddressSpecified As Boolean
    Get
    Set
public:
property bool AlwaysUseThisPaymentAddressSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DefaultPayPalEmailAddress Property

DefaultPayPalEmailAddress Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► DefaultPayPalEmailAddress
Declaration Syntax
C# Visual Basic Visual C++
public string DefaultPayPalEmailAddress { get; set; }
Public Property DefaultPayPalEmailAddress As String
    Get
    Set
public:
property String^ DefaultPayPalEmailAddress {
    String^ get ();
    void set (String^ value);
}


DisplayPayNowButton Property

DisplayPayNowButton Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► DisplayPayNowButton
Declaration Syntax
C# Visual Basic Visual C++
public DisplayPayNowButtonCodeType DisplayPayNowButton { get; set; }
Public Property DisplayPayNowButton As DisplayPayNowButtonCodeType
    Get
    Set
public:
property DisplayPayNowButtonCodeType DisplayPayNowButton {
    DisplayPayNowButtonCodeType get ();
    void set (DisplayPayNowButtonCodeType value);
}


DisplayPayNowButtonSpecified Property

DisplayPayNowButtonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► DisplayPayNowButtonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayPayNowButtonSpecified { get; set; }
Public Property DisplayPayNowButtonSpecified As Boolean
    Get
    Set
public:
property bool DisplayPayNowButtonSpecified {
    bool get ();
    void set (bool value);
}


FedExRateOption Property

FedExRateOption Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► FedExRateOption
Declaration Syntax
C# Visual Basic Visual C++
public FedExRateOptionCodeType FedExRateOption { get; set; }
Public Property FedExRateOption As FedExRateOptionCodeType
    Get
    Set
public:
property FedExRateOptionCodeType FedExRateOption {
    FedExRateOptionCodeType get ();
    void set (FedExRateOptionCodeType value);
}


FedExRateOptionSpecified Property

FedExRateOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► FedExRateOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FedExRateOptionSpecified { get; set; }
Public Property FedExRateOptionSpecified As Boolean
    Get
    Set
public:
property bool FedExRateOptionSpecified {
    bool get ();
    void set (bool value);
}


PayPalAlwaysOn Property

PayPalAlwaysOn Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► PayPalAlwaysOn
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalAlwaysOn { get; set; }
Public Property PayPalAlwaysOn As Boolean
    Get
    Set
public:
property bool PayPalAlwaysOn {
    bool get ();
    void set (bool value);
}


PayPalAlwaysOnSpecified Property

PayPalAlwaysOnSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► PayPalAlwaysOnSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalAlwaysOnSpecified { get; set; }
Public Property PayPalAlwaysOnSpecified As Boolean
    Get
    Set
public:
property bool PayPalAlwaysOnSpecified {
    bool get ();
    void set (bool value);
}


PayPalPreferred Property

PayPalPreferred Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► PayPalPreferred
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalPreferred { get; set; }
Public Property PayPalPreferred As Boolean
    Get
    Set
public:
property bool PayPalPreferred {
    bool get ();
    void set (bool value);
}


PayPalPreferredSpecified Property

PayPalPreferredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► PayPalPreferredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalPreferredSpecified { get; set; }
Public Property PayPalPreferredSpecified As Boolean
    Get
    Set
public:
property bool PayPalPreferredSpecified {
    bool get ();
    void set (bool value);
}


SellerPaymentAddress Property

SellerPaymentAddress Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► SellerPaymentAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType SellerPaymentAddress { get; set; }
Public Property SellerPaymentAddress As AddressType
    Get
    Set
public:
property AddressType^ SellerPaymentAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


SellerPaymentPreferencesType Constructor

SellerPaymentPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► SellerPaymentPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentPreferencesType()
Public Sub New
public:
SellerPaymentPreferencesType()


UPSRateOption Property

UPSRateOption Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► UPSRateOption
Declaration Syntax
C# Visual Basic Visual C++
public UPSRateOptionCodeType UPSRateOption { get; set; }
Public Property UPSRateOption As UPSRateOptionCodeType
    Get
    Set
public:
property UPSRateOptionCodeType UPSRateOption {
    UPSRateOptionCodeType get ();
    void set (UPSRateOptionCodeType value);
}


UPSRateOptionSpecified Property

UPSRateOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► UPSRateOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UPSRateOptionSpecified { get; set; }
Public Property UPSRateOptionSpecified As Boolean
    Get
    Set
public:
property bool UPSRateOptionSpecified {
    bool get ();
    void set (bool value);
}


USPSRateOption Property

USPSRateOption Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► USPSRateOption
Declaration Syntax
C# Visual Basic Visual C++
public USPSRateOptionCodeType USPSRateOption { get; set; }
Public Property USPSRateOption As USPSRateOptionCodeType
    Get
    Set
public:
property USPSRateOptionCodeType USPSRateOption {
    USPSRateOptionCodeType get ();
    void set (USPSRateOptionCodeType value);
}


USPSRateOptionSpecified Property

USPSRateOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentPreferencesType ► USPSRateOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool USPSRateOptionSpecified { get; set; }
Public Property USPSRateOptionSpecified As Boolean
    Get
    Set
public:
property bool USPSRateOptionSpecified {
    bool get ();
    void set (bool value);
}


SellerPaymentProfileType Class

SellerPaymentProfileType Class
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentProfileType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerPaymentProfileType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerPaymentProfileType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerPaymentProfileType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerPaymentProfileType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PaymentProfileID |
 | PaymentProfileIDSpecified |
 | PaymentProfileName |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerPaymentProfileType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentProfileType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


PaymentProfileID Property

PaymentProfileID Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentProfileType ► PaymentProfileID
Declaration Syntax
C# Visual Basic Visual C++
public long PaymentProfileID { get; set; }
Public Property PaymentProfileID As Long
    Get
    Set
public:
property long long PaymentProfileID {
    long long get ();
    void set (long long value);
}


PaymentProfileIDSpecified Property

PaymentProfileIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentProfileType ► PaymentProfileIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentProfileIDSpecified { get; set; }
Public Property PaymentProfileIDSpecified As Boolean
    Get
    Set
public:
property bool PaymentProfileIDSpecified {
    bool get ();
    void set (bool value);
}


PaymentProfileName Property

PaymentProfileName Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentProfileType ► PaymentProfileName
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentProfileName { get; set; }
Public Property PaymentProfileName As String
    Get
    Set
public:
property String^ PaymentProfileName {
    String^ get ();
    void set (String^ value);
}


SellerPaymentProfileType Constructor

SellerPaymentProfileType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentProfileType ► SellerPaymentProfileType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentProfileType()
Public Sub New
public:
SellerPaymentProfileType()


SellerPaymentType Class

SellerPaymentType Class
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerPaymentType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerPaymentType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerPaymentType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerPaymentType()()()() |
 | AmountPaid |
 | Any |
 | Commission |
 | Equals(Object) | (Inherited from Object.)
 | ExternalProductID |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderID |
 | OrderLineItemID |
 | PaidTime |
 | PaidTimeSpecified |
 | PaymentType |
 | PaymentTypeSpecified |
 | PrivateNotes |
 | SellerInventoryID |
 | ShippingReimbursement |
 | Title |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | TransactionPrice |
Remarks
Inheritance Hierarchy
Object
SellerPaymentType


AmountPaid Property

AmountPaid Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► AmountPaid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AmountPaid { get; set; }
Public Property AmountPaid As AmountType
    Get
    Set
public:
property AmountType^ AmountPaid {
    AmountType^ get ();
    void set (AmountType^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Commission Property

Commission Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► Commission
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Commission { get; set; }
Public Property Commission As AmountType
    Get
    Set
public:
property AmountType^ Commission {
    AmountType^ get ();
    void set (AmountType^ value);
}


ExternalProductID Property

ExternalProductID Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► ExternalProductID
Declaration Syntax
C# Visual Basic Visual C++
public ExternalProductIDType ExternalProductID { get; set; }
Public Property ExternalProductID As ExternalProductIDType
    Get
    Set
public:
property ExternalProductIDType^ ExternalProductID {
    ExternalProductIDType^ get ();
    void set (ExternalProductIDType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► OrderID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


PaidTime Property

PaidTime Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► PaidTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PaidTime { get; set; }
Public Property PaidTime As DateTime
    Get
    Set
public:
property DateTime PaidTime {
    DateTime get ();
    void set (DateTime value);
}


PaidTimeSpecified Property

PaidTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► PaidTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaidTimeSpecified { get; set; }
Public Property PaidTimeSpecified As Boolean
    Get
    Set
public:
property bool PaidTimeSpecified {
    bool get ();
    void set (bool value);
}


PaymentType Property

PaymentType Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► PaymentType
Declaration Syntax
C# Visual Basic Visual C++
public PaymentTypeCodeType PaymentType { get; set; }
Public Property PaymentType As PaymentTypeCodeType
    Get
    Set
public:
property PaymentTypeCodeType PaymentType {
    PaymentTypeCodeType get ();
    void set (PaymentTypeCodeType value);
}


PaymentTypeSpecified Property

PaymentTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► PaymentTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentTypeSpecified { get; set; }
Public Property PaymentTypeSpecified As Boolean
    Get
    Set
public:
property bool PaymentTypeSpecified {
    bool get ();
    void set (bool value);
}


PrivateNotes Property

PrivateNotes Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► PrivateNotes
Declaration Syntax
C# Visual Basic Visual C++
public string PrivateNotes { get; set; }
Public Property PrivateNotes As String
    Get
    Set
public:
property String^ PrivateNotes {
    String^ get ();
    void set (String^ value);
}


SellerInventoryID Property

SellerInventoryID Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► SellerInventoryID
Declaration Syntax
C# Visual Basic Visual C++
public string SellerInventoryID { get; set; }
Public Property SellerInventoryID As String
    Get
    Set
public:
property String^ SellerInventoryID {
    String^ get ();
    void set (String^ value);
}


SellerPaymentType Constructor

SellerPaymentType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► SellerPaymentType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentType()
Public Sub New
public:
SellerPaymentType()


ShippingReimbursement Property

ShippingReimbursement Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► ShippingReimbursement
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingReimbursement { get; set; }
Public Property ShippingReimbursement As AmountType
    Get
    Set
public:
property AmountType^ ShippingReimbursement {
    AmountType^ get ();
    void set (AmountType^ value);
}


Title Property

Title Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► Title
Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


TransactionPrice Property

TransactionPrice Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentType ► TransactionPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TransactionPrice { get; set; }
Public Property TransactionPrice As AmountType
    Get
    Set
public:
property AmountType^ TransactionPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


SellerPaymentTypeCollection Class

SellerPaymentTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellerPaymentTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellerPaymentTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellerPaymentTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerPaymentTypeCollection()()()() |
 | SellerPaymentTypeCollection(array<SellerPaymentType>[]()[][]) |
 | SellerPaymentTypeCollection(SellerPaymentTypeCollection) |
 | Add(SellerPaymentType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellerPaymentType>[]()[][]) |
 | AddRange(SellerPaymentTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellerPaymentType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellerPaymentType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellerPaymentType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellerPaymentType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellerPaymentType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellerPaymentTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► Add(SellerPaymentType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellerPaymentType item
)
Public Function Add ( _
    item As SellerPaymentType _
) As Integer
public:
int Add(
    SellerPaymentType^ item
)
Parameters
item (SellerPaymentType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellerPaymentType>[]()[][]) |
 | AddRange(SellerPaymentTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► AddRange(array<SellerPaymentType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellerPaymentType[] items
)
Public Sub AddRange ( _
    items As SellerPaymentType() _
)
public:
void AddRange(
    array<SellerPaymentType^>^ items
)
Parameters
items (array< SellerPaymentType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► AddRange(SellerPaymentTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellerPaymentTypeCollection items
)
Public Sub AddRange ( _
    items As SellerPaymentTypeCollection _
)
public:
void AddRange(
    SellerPaymentTypeCollection^ items
)
Parameters
items (SellerPaymentTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► Contains(SellerPaymentType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellerPaymentType item
)
Public Function Contains ( _
    item As SellerPaymentType _
) As Boolean
public:
bool Contains(
    SellerPaymentType^ item
)
Parameters
item (SellerPaymentType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► CopyTo(array<SellerPaymentType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellerPaymentType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellerPaymentType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellerPaymentType^>^ items,
    int index
)
Parameters
items (array< SellerPaymentType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► IndexOf(SellerPaymentType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellerPaymentType item
)
Public Function IndexOf ( _
    item As SellerPaymentType _
) As Integer
public:
int IndexOf(
    SellerPaymentType^ item
)
Parameters
item (SellerPaymentType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► Insert(Int32, SellerPaymentType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellerPaymentType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellerPaymentType _
)
public:
void Insert(
    int index,
    SellerPaymentType^ item
)
Parameters
index (Int32)
item (SellerPaymentType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellerPaymentType
    Get
    Set
public:
property SellerPaymentType^ default[int index] {
    SellerPaymentType^ get (int index);
    void set (int index, SellerPaymentType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellerPaymentType
public:
SellerPaymentType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► Remove(SellerPaymentType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellerPaymentType item
)
Public Sub Remove ( _
    item As SellerPaymentType _
)
public:
void Remove(
    SellerPaymentType^ item
)
Parameters
item (SellerPaymentType)


SellerPaymentTypeCollection Constructor

SellerPaymentTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► SellerPaymentTypeCollection()()()()
Members
Icon | Member | Description
 | SellerPaymentTypeCollection()()()() |
 | SellerPaymentTypeCollection(array<SellerPaymentType>[]()[][]) |
 | SellerPaymentTypeCollection(SellerPaymentTypeCollection) |


SellerPaymentTypeCollection Constructor

SellerPaymentTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► SellerPaymentTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentTypeCollection()
Public Sub New
public:
SellerPaymentTypeCollection()


SellerPaymentTypeCollection Constructor (items)

SellerPaymentTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► SellerPaymentTypeCollection(array<SellerPaymentType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentTypeCollection(
    SellerPaymentType[] items
)
Public Sub New ( _
    items As SellerPaymentType() _
)
public:
SellerPaymentTypeCollection(
    array<SellerPaymentType^>^ items
)
Parameters
items (array< SellerPaymentType >[]()[][])


SellerPaymentTypeCollection Constructor (items)

SellerPaymentTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► SellerPaymentTypeCollection(SellerPaymentTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentTypeCollection(
    SellerPaymentTypeCollection items
)
Public Sub New ( _
    items As SellerPaymentTypeCollection _
)
public:
SellerPaymentTypeCollection(
    SellerPaymentTypeCollection^ items
)
Parameters
items (SellerPaymentTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentType[] ToArray()
Public Function ToArray As SellerPaymentType()
public:
array<SellerPaymentType^>^ ToArray()
Return Value


SellerProfilePreferencesType Class

SellerProfilePreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► SellerProfilePreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerProfilePreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerProfilePreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerProfilePreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerProfilePreferencesType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SellerProfileOptedIn |
 | SellerProfileOptedInSpecified |
 | SupportedSellerProfiles |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerProfilePreferencesType


SellerProfileOptedIn Property

SellerProfileOptedIn Property
Namespaces ► eBay.Service.Core.Soap ► SellerProfilePreferencesType ► SellerProfileOptedIn
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerProfileOptedIn { get; set; }
Public Property SellerProfileOptedIn As Boolean
    Get
    Set
public:
property bool SellerProfileOptedIn {
    bool get ();
    void set (bool value);
}


SellerProfileOptedInSpecified Property

SellerProfileOptedInSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerProfilePreferencesType ► SellerProfileOptedInSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerProfileOptedInSpecified { get; set; }
Public Property SellerProfileOptedInSpecified As Boolean
    Get
    Set
public:
property bool SellerProfileOptedInSpecified {
    bool get ();
    void set (bool value);
}


SellerProfilePreferencesType Constructor

SellerProfilePreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerProfilePreferencesType ► SellerProfilePreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerProfilePreferencesType()
Public Sub New
public:
SellerProfilePreferencesType()


SupportedSellerProfiles Property

SupportedSellerProfiles Property
Namespaces ► eBay.Service.Core.Soap ► SellerProfilePreferencesType ► SupportedSellerProfiles
Declaration Syntax
C# Visual Basic Visual C++
public SupportedSellerProfileTypeCollection SupportedSellerProfiles { get; set; }
Public Property SupportedSellerProfiles As SupportedSellerProfileTypeCollection
    Get
    Set
public:
property SupportedSellerProfileTypeCollection^ SupportedSellerProfiles {
    SupportedSellerProfileTypeCollection^ get ();
    void set (SupportedSellerProfileTypeCollection^ value);
}


SellerProfilesType Class

SellerProfilesType Class
Namespaces ► eBay.Service.Core.Soap ► SellerProfilesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerProfilesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerProfilesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerProfilesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerProfilesType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SellerPaymentProfile |
 | SellerReturnProfile |
 | SellerShippingProfile |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerProfilesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerProfilesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SellerPaymentProfile Property

SellerPaymentProfile Property
Namespaces ► eBay.Service.Core.Soap ► SellerProfilesType ► SellerPaymentProfile
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentProfileType SellerPaymentProfile { get; set; }
Public Property SellerPaymentProfile As SellerPaymentProfileType
    Get
    Set
public:
property SellerPaymentProfileType^ SellerPaymentProfile {
    SellerPaymentProfileType^ get ();
    void set (SellerPaymentProfileType^ value);
}


SellerProfilesType Constructor

SellerProfilesType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerProfilesType ► SellerProfilesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerProfilesType()
Public Sub New
public:
SellerProfilesType()


SellerReturnProfile Property

SellerReturnProfile Property
Namespaces ► eBay.Service.Core.Soap ► SellerProfilesType ► SellerReturnProfile
Declaration Syntax
C# Visual Basic Visual C++
public SellerReturnProfileType SellerReturnProfile { get; set; }
Public Property SellerReturnProfile As SellerReturnProfileType
    Get
    Set
public:
property SellerReturnProfileType^ SellerReturnProfile {
    SellerReturnProfileType^ get ();
    void set (SellerReturnProfileType^ value);
}


SellerShippingProfile Property

SellerShippingProfile Property
Namespaces ► eBay.Service.Core.Soap ► SellerProfilesType ► SellerShippingProfile
Declaration Syntax
C# Visual Basic Visual C++
public SellerShippingProfileType SellerShippingProfile { get; set; }
Public Property SellerShippingProfile As SellerShippingProfileType
    Get
    Set
public:
property SellerShippingProfileType^ SellerShippingProfile {
    SellerShippingProfileType^ get ();
    void set (SellerShippingProfileType^ value);
}


SellerProvidedTitleSupportedDefinitionType Class

SellerProvidedTitleSupportedDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► SellerProvidedTitleSupportedDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerProvidedTitleSupportedDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerProvidedTitleSupportedDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerProvidedTitleSupportedDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerProvidedTitleSupportedDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerProvidedTitleSupportedDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerProvidedTitleSupportedDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SellerProvidedTitleSupportedDefinitionType Constructor

SellerProvidedTitleSupportedDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerProvidedTitleSupportedDefinitionType ► SellerProvidedTitleSupportedDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerProvidedTitleSupportedDefinitionType()
Public Sub New
public:
SellerProvidedTitleSupportedDefinitionType()


SellerReturnPreferencesType Class

SellerReturnPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► SellerReturnPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerReturnPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerReturnPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerReturnPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerReturnPreferencesType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OptedIn |
 | OptedInSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerReturnPreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerReturnPreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


OptedIn Property

OptedIn Property
Namespaces ► eBay.Service.Core.Soap ► SellerReturnPreferencesType ► OptedIn
Declaration Syntax
C# Visual Basic Visual C++
public bool OptedIn { get; set; }
Public Property OptedIn As Boolean
    Get
    Set
public:
property bool OptedIn {
    bool get ();
    void set (bool value);
}


OptedInSpecified Property

OptedInSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerReturnPreferencesType ► OptedInSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OptedInSpecified { get; set; }
Public Property OptedInSpecified As Boolean
    Get
    Set
public:
property bool OptedInSpecified {
    bool get ();
    void set (bool value);
}


SellerReturnPreferencesType Constructor

SellerReturnPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerReturnPreferencesType ► SellerReturnPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerReturnPreferencesType()
Public Sub New
public:
SellerReturnPreferencesType()


SellerReturnProfileType Class

SellerReturnProfileType Class
Namespaces ► eBay.Service.Core.Soap ► SellerReturnProfileType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerReturnProfileType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerReturnProfileType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerReturnProfileType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerReturnProfileType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReturnProfileID |
 | ReturnProfileIDSpecified |
 | ReturnProfileName |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerReturnProfileType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerReturnProfileType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ReturnProfileID Property

ReturnProfileID Property
Namespaces ► eBay.Service.Core.Soap ► SellerReturnProfileType ► ReturnProfileID
Declaration Syntax
C# Visual Basic Visual C++
public long ReturnProfileID { get; set; }
Public Property ReturnProfileID As Long
    Get
    Set
public:
property long long ReturnProfileID {
    long long get ();
    void set (long long value);
}


ReturnProfileIDSpecified Property

ReturnProfileIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerReturnProfileType ► ReturnProfileIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnProfileIDSpecified { get; set; }
Public Property ReturnProfileIDSpecified As Boolean
    Get
    Set
public:
property bool ReturnProfileIDSpecified {
    bool get ();
    void set (bool value);
}


ReturnProfileName Property

ReturnProfileName Property
Namespaces ► eBay.Service.Core.Soap ► SellerReturnProfileType ► ReturnProfileName
Declaration Syntax
C# Visual Basic Visual C++
public string ReturnProfileName { get; set; }
Public Property ReturnProfileName As String
    Get
    Set
public:
property String^ ReturnProfileName {
    String^ get ();
    void set (String^ value);
}


SellerReturnProfileType Constructor

SellerReturnProfileType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerReturnProfileType ► SellerReturnProfileType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerReturnProfileType()
Public Sub New
public:
SellerReturnProfileType()


SellerReverseDisputeRequestType Class

SellerReverseDisputeRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SellerReverseDisputeRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerReverseDisputeRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerReverseDisputeRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerReverseDisputeRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerReverseDisputeRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | DisputeID |
 | DisputeResolutionReason |
 | DisputeResolutionReasonSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SellerReverseDisputeRequestType


DisputeID Property

DisputeID Property
Namespaces ► eBay.Service.Core.Soap ► SellerReverseDisputeRequestType ► DisputeID
Declaration Syntax
C# Visual Basic Visual C++
public string DisputeID { get; set; }
Public Property DisputeID As String
    Get
    Set
public:
property String^ DisputeID {
    String^ get ();
    void set (String^ value);
}


DisputeResolutionReason Property

DisputeResolutionReason Property
Namespaces ► eBay.Service.Core.Soap ► SellerReverseDisputeRequestType ► DisputeResolutionReason
Declaration Syntax
C# Visual Basic Visual C++
public DisputeResolutionReasonCodeType DisputeResolutionReason { get; set; }
Public Property DisputeResolutionReason As DisputeResolutionReasonCodeType
    Get
    Set
public:
property DisputeResolutionReasonCodeType DisputeResolutionReason {
    DisputeResolutionReasonCodeType get ();
    void set (DisputeResolutionReasonCodeType value);
}


DisputeResolutionReasonSpecified Property

DisputeResolutionReasonSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerReverseDisputeRequestType ► DisputeResolutionReasonSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisputeResolutionReasonSpecified { get; set; }
Public Property DisputeResolutionReasonSpecified As Boolean
    Get
    Set
public:
property bool DisputeResolutionReasonSpecified {
    bool get ();
    void set (bool value);
}


SellerReverseDisputeRequestType Constructor

SellerReverseDisputeRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerReverseDisputeRequestType ► SellerReverseDisputeRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerReverseDisputeRequestType()
Public Sub New
public:
SellerReverseDisputeRequestType()


SellerReverseDisputeResponseType Class

SellerReverseDisputeResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SellerReverseDisputeResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerReverseDisputeResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerReverseDisputeResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerReverseDisputeResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerReverseDisputeResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SellerReverseDisputeResponseType


SellerReverseDisputeResponseType Constructor

SellerReverseDisputeResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerReverseDisputeResponseType ► SellerReverseDisputeResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerReverseDisputeResponseType()
Public Sub New
public:
SellerReverseDisputeResponseType()


SellerRoleMetricsType Class

SellerRoleMetricsType Class
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerRoleMetricsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerRoleMetricsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerRoleMetricsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerRoleMetricsType()()()() |
 | Any |
 | CrossBorderTransactionCount |
 | CrossBorderTransactionCountSpecified |
 | CrossBorderTransactionPercent |
 | CrossBorderTransactionPercentSpecified |
 | Equals(Object) | (Inherited from Object.)
 | FeedbackLeftPercent |
 | FeedbackLeftPercentSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NegativeFeedbackLeftCount |
 | NegativeFeedbackLeftCountSpecified |
 | NeutralFeedbackLeftCount |
 | NeutralFeedbackLeftCountSpecified |
 | PositiveFeedbackLeftCount |
 | PositiveFeedbackLeftCountSpecified |
 | RepeatBuyerCount |
 | RepeatBuyerCountSpecified |
 | RepeatBuyerPercent |
 | RepeatBuyerPercentSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TransactionPercent |
 | TransactionPercentSpecified |
 | UniqueBuyerCount |
 | UniqueBuyerCountSpecified |
Remarks
Inheritance Hierarchy
Object
SellerRoleMetricsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CrossBorderTransactionCount Property

CrossBorderTransactionCount Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► CrossBorderTransactionCount
Declaration Syntax
C# Visual Basic Visual C++
public int CrossBorderTransactionCount { get; set; }
Public Property CrossBorderTransactionCount As Integer
    Get
    Set
public:
property int CrossBorderTransactionCount {
    int get ();
    void set (int value);
}


CrossBorderTransactionCountSpecified Property

CrossBorderTransactionCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► CrossBorderTransactionCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTransactionCountSpecified { get; set; }
Public Property CrossBorderTransactionCountSpecified As Boolean
    Get
    Set
public:
property bool CrossBorderTransactionCountSpecified {
    bool get ();
    void set (bool value);
}


CrossBorderTransactionPercent Property

CrossBorderTransactionPercent Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► CrossBorderTransactionPercent
Declaration Syntax
C# Visual Basic Visual C++
public float CrossBorderTransactionPercent { get; set; }
Public Property CrossBorderTransactionPercent As Single
    Get
    Set
public:
property float CrossBorderTransactionPercent {
    float get ();
    void set (float value);
}


CrossBorderTransactionPercentSpecified Property

CrossBorderTransactionPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► CrossBorderTransactionPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTransactionPercentSpecified { get; set; }
Public Property CrossBorderTransactionPercentSpecified As Boolean
    Get
    Set
public:
property bool CrossBorderTransactionPercentSpecified {
    bool get ();
    void set (bool value);
}


FeedbackLeftPercent Property

FeedbackLeftPercent Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► FeedbackLeftPercent
Declaration Syntax
C# Visual Basic Visual C++
public float FeedbackLeftPercent { get; set; }
Public Property FeedbackLeftPercent As Single
    Get
    Set
public:
property float FeedbackLeftPercent {
    float get ();
    void set (float value);
}


FeedbackLeftPercentSpecified Property

FeedbackLeftPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► FeedbackLeftPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackLeftPercentSpecified { get; set; }
Public Property FeedbackLeftPercentSpecified As Boolean
    Get
    Set
public:
property bool FeedbackLeftPercentSpecified {
    bool get ();
    void set (bool value);
}


NegativeFeedbackLeftCount Property

NegativeFeedbackLeftCount Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► NegativeFeedbackLeftCount
Declaration Syntax
C# Visual Basic Visual C++
public int NegativeFeedbackLeftCount { get; set; }
Public Property NegativeFeedbackLeftCount As Integer
    Get
    Set
public:
property int NegativeFeedbackLeftCount {
    int get ();
    void set (int value);
}


NegativeFeedbackLeftCountSpecified Property

NegativeFeedbackLeftCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► NegativeFeedbackLeftCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NegativeFeedbackLeftCountSpecified { get; set; }
Public Property NegativeFeedbackLeftCountSpecified As Boolean
    Get
    Set
public:
property bool NegativeFeedbackLeftCountSpecified {
    bool get ();
    void set (bool value);
}


NeutralFeedbackLeftCount Property

NeutralFeedbackLeftCount Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► NeutralFeedbackLeftCount
Declaration Syntax
C# Visual Basic Visual C++
public int NeutralFeedbackLeftCount { get; set; }
Public Property NeutralFeedbackLeftCount As Integer
    Get
    Set
public:
property int NeutralFeedbackLeftCount {
    int get ();
    void set (int value);
}


NeutralFeedbackLeftCountSpecified Property

NeutralFeedbackLeftCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► NeutralFeedbackLeftCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NeutralFeedbackLeftCountSpecified { get; set; }
Public Property NeutralFeedbackLeftCountSpecified As Boolean
    Get
    Set
public:
property bool NeutralFeedbackLeftCountSpecified {
    bool get ();
    void set (bool value);
}


PositiveFeedbackLeftCount Property

PositiveFeedbackLeftCount Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► PositiveFeedbackLeftCount
Declaration Syntax
C# Visual Basic Visual C++
public int PositiveFeedbackLeftCount { get; set; }
Public Property PositiveFeedbackLeftCount As Integer
    Get
    Set
public:
property int PositiveFeedbackLeftCount {
    int get ();
    void set (int value);
}


PositiveFeedbackLeftCountSpecified Property

PositiveFeedbackLeftCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► PositiveFeedbackLeftCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PositiveFeedbackLeftCountSpecified { get; set; }
Public Property PositiveFeedbackLeftCountSpecified As Boolean
    Get
    Set
public:
property bool PositiveFeedbackLeftCountSpecified {
    bool get ();
    void set (bool value);
}


RepeatBuyerCount Property

RepeatBuyerCount Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► RepeatBuyerCount
Declaration Syntax
C# Visual Basic Visual C++
public int RepeatBuyerCount { get; set; }
Public Property RepeatBuyerCount As Integer
    Get
    Set
public:
property int RepeatBuyerCount {
    int get ();
    void set (int value);
}


RepeatBuyerCountSpecified Property

RepeatBuyerCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► RepeatBuyerCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RepeatBuyerCountSpecified { get; set; }
Public Property RepeatBuyerCountSpecified As Boolean
    Get
    Set
public:
property bool RepeatBuyerCountSpecified {
    bool get ();
    void set (bool value);
}


RepeatBuyerPercent Property

RepeatBuyerPercent Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► RepeatBuyerPercent
Declaration Syntax
C# Visual Basic Visual C++
public float RepeatBuyerPercent { get; set; }
Public Property RepeatBuyerPercent As Single
    Get
    Set
public:
property float RepeatBuyerPercent {
    float get ();
    void set (float value);
}


RepeatBuyerPercentSpecified Property

RepeatBuyerPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► RepeatBuyerPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RepeatBuyerPercentSpecified { get; set; }
Public Property RepeatBuyerPercentSpecified As Boolean
    Get
    Set
public:
property bool RepeatBuyerPercentSpecified {
    bool get ();
    void set (bool value);
}


SellerRoleMetricsType Constructor

SellerRoleMetricsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► SellerRoleMetricsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerRoleMetricsType()
Public Sub New
public:
SellerRoleMetricsType()


TransactionPercent Property

TransactionPercent Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► TransactionPercent
Declaration Syntax
C# Visual Basic Visual C++
public float TransactionPercent { get; set; }
Public Property TransactionPercent As Single
    Get
    Set
public:
property float TransactionPercent {
    float get ();
    void set (float value);
}


TransactionPercentSpecified Property

TransactionPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► TransactionPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TransactionPercentSpecified { get; set; }
Public Property TransactionPercentSpecified As Boolean
    Get
    Set
public:
property bool TransactionPercentSpecified {
    bool get ();
    void set (bool value);
}


UniqueBuyerCount Property

UniqueBuyerCount Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► UniqueBuyerCount
Declaration Syntax
C# Visual Basic Visual C++
public int UniqueBuyerCount { get; set; }
Public Property UniqueBuyerCount As Integer
    Get
    Set
public:
property int UniqueBuyerCount {
    int get ();
    void set (int value);
}


UniqueBuyerCountSpecified Property

UniqueBuyerCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerRoleMetricsType ► UniqueBuyerCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UniqueBuyerCountSpecified { get; set; }
Public Property UniqueBuyerCountSpecified As Boolean
    Get
    Set
public:
property bool UniqueBuyerCountSpecified {
    bool get ();
    void set (bool value);
}


SellerShippingProfileType Class

SellerShippingProfileType Class
Namespaces ► eBay.Service.Core.Soap ► SellerShippingProfileType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerShippingProfileType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerShippingProfileType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerShippingProfileType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerShippingProfileType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingProfileID |
 | ShippingProfileIDSpecified |
 | ShippingProfileName |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellerShippingProfileType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerShippingProfileType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SellerShippingProfileType Constructor

SellerShippingProfileType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerShippingProfileType ► SellerShippingProfileType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerShippingProfileType()
Public Sub New
public:
SellerShippingProfileType()


ShippingProfileID Property

ShippingProfileID Property
Namespaces ► eBay.Service.Core.Soap ► SellerShippingProfileType ► ShippingProfileID
Declaration Syntax
C# Visual Basic Visual C++
public long ShippingProfileID { get; set; }
Public Property ShippingProfileID As Long
    Get
    Set
public:
property long long ShippingProfileID {
    long long get ();
    void set (long long value);
}


ShippingProfileIDSpecified Property

ShippingProfileIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerShippingProfileType ► ShippingProfileIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingProfileIDSpecified { get; set; }
Public Property ShippingProfileIDSpecified As Boolean
    Get
    Set
public:
property bool ShippingProfileIDSpecified {
    bool get ();
    void set (bool value);
}


ShippingProfileName Property

ShippingProfileName Property
Namespaces ► eBay.Service.Core.Soap ► SellerShippingProfileType ► ShippingProfileName
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingProfileName { get; set; }
Public Property ShippingProfileName As String
    Get
    Set
public:
property String^ ShippingProfileName {
    String^ get ();
    void set (String^ value);
}


SellerType Class

SellerType Class
Namespaces ► eBay.Service.Core.Soap ► SellerType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellerType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellerType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellerType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellerType()()()() |
 | AllowPaymentEdit |
 | Any |
 | BillingCurrency |
 | BillingCurrencySpecified |
 | CharityAffiliationDetails |
 | CharityRegistered |
 | CharityRegisteredSpecified |
 | CheckoutEnabled |
 | CIPBankAccountStored |
 | DomesticRateTable |
 | DomesticRateTableSpecified |
 | Equals(Object) | (Inherited from Object.)
 | FeatureEligibility |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GoodStanding |
 | IntegratedMerchantCreditCardInfo |
 | InternationalRateTable |
 | InternationalRateTableSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MerchandizingPref |
 | MerchandizingPrefSpecified |
 | PaisaPayEscrowEMIStatus |
 | PaisaPayEscrowEMIStatusSpecified |
 | PaisaPayStatus |
 | PaisaPayStatusSpecified |
 | PaymentMethod |
 | PaymentMethodSpecified |
 | ProStoresPreference |
 | QualifiesForB2BVAT |
 | RecoupmentPolicyConsent |
 | RegisteredBusinessSeller |
 | RegisteredBusinessSellerSpecified |
 | SafePaymentExempt |
 | SafePaymentExemptSpecified |
 | SchedulingInfo |
 | SellerBusinessType |
 | SellerBusinessTypeSpecified |
 | SellereBayPaymentProcessConsent |
 | SellereBayPaymentProcessStatus |
 | SellereBayPaymentProcessStatusSpecified |
 | SellerGuaranteeLevel |
 | SellerGuaranteeLevelSpecified |
 | SellerLevel |
 | SellerLevelSpecified |
 | SellerPaymentAddress |
 | StoreOwner |
 | StoreSite |
 | StoreSiteSpecified |
 | StoreURL |
 | TopRatedSeller |
 | TopRatedSellerDetails |
 | TopRatedSellerSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TransactionPercent |
 | TransactionPercentSpecified |
Remarks
Inheritance Hierarchy
Object
SellerType


AllowPaymentEdit Property

AllowPaymentEdit Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► AllowPaymentEdit
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowPaymentEdit { get; set; }
Public Property AllowPaymentEdit As Boolean
    Get
    Set
public:
property bool AllowPaymentEdit {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BillingCurrency Property

BillingCurrency Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► BillingCurrency
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType BillingCurrency { get; set; }
Public Property BillingCurrency As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType BillingCurrency {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


BillingCurrencySpecified Property

BillingCurrencySpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► BillingCurrencySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BillingCurrencySpecified { get; set; }
Public Property BillingCurrencySpecified As Boolean
    Get
    Set
public:
property bool BillingCurrencySpecified {
    bool get ();
    void set (bool value);
}


CharityAffiliationDetails Property

CharityAffiliationDetails Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► CharityAffiliationDetails
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationDetailTypeCollection CharityAffiliationDetails { get; set; }
Public Property CharityAffiliationDetails As CharityAffiliationDetailTypeCollection
    Get
    Set
public:
property CharityAffiliationDetailTypeCollection^ CharityAffiliationDetails {
    CharityAffiliationDetailTypeCollection^ get ();
    void set (CharityAffiliationDetailTypeCollection^ value);
}


CharityRegistered Property

CharityRegistered Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► CharityRegistered
Declaration Syntax
C# Visual Basic Visual C++
public bool CharityRegistered { get; set; }
Public Property CharityRegistered As Boolean
    Get
    Set
public:
property bool CharityRegistered {
    bool get ();
    void set (bool value);
}


CharityRegisteredSpecified Property

CharityRegisteredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► CharityRegisteredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CharityRegisteredSpecified { get; set; }
Public Property CharityRegisteredSpecified As Boolean
    Get
    Set
public:
property bool CharityRegisteredSpecified {
    bool get ();
    void set (bool value);
}


CheckoutEnabled Property

CheckoutEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► CheckoutEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckoutEnabled { get; set; }
Public Property CheckoutEnabled As Boolean
    Get
    Set
public:
property bool CheckoutEnabled {
    bool get ();
    void set (bool value);
}


CIPBankAccountStored Property

CIPBankAccountStored Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► CIPBankAccountStored
Declaration Syntax
C# Visual Basic Visual C++
public bool CIPBankAccountStored { get; set; }
Public Property CIPBankAccountStored As Boolean
    Get
    Set
public:
property bool CIPBankAccountStored {
    bool get ();
    void set (bool value);
}


DomesticRateTable Property

DomesticRateTable Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► DomesticRateTable
Declaration Syntax
C# Visual Basic Visual C++
public bool DomesticRateTable { get; set; }
Public Property DomesticRateTable As Boolean
    Get
    Set
public:
property bool DomesticRateTable {
    bool get ();
    void set (bool value);
}


DomesticRateTableSpecified Property

DomesticRateTableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► DomesticRateTableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DomesticRateTableSpecified { get; set; }
Public Property DomesticRateTableSpecified As Boolean
    Get
    Set
public:
property bool DomesticRateTableSpecified {
    bool get ();
    void set (bool value);
}


FeatureEligibility Property

FeatureEligibility Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► FeatureEligibility
Declaration Syntax
C# Visual Basic Visual C++
public FeatureEligibilityType FeatureEligibility { get; set; }
Public Property FeatureEligibility As FeatureEligibilityType
    Get
    Set
public:
property FeatureEligibilityType^ FeatureEligibility {
    FeatureEligibilityType^ get ();
    void set (FeatureEligibilityType^ value);
}


GoodStanding Property

GoodStanding Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► GoodStanding
Declaration Syntax
C# Visual Basic Visual C++
public bool GoodStanding { get; set; }
Public Property GoodStanding As Boolean
    Get
    Set
public:
property bool GoodStanding {
    bool get ();
    void set (bool value);
}


IntegratedMerchantCreditCardInfo Property

IntegratedMerchantCreditCardInfo Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► IntegratedMerchantCreditCardInfo
Declaration Syntax
C# Visual Basic Visual C++
public IntegratedMerchantCreditCardInfoType IntegratedMerchantCreditCardInfo { get; set; }
Public Property IntegratedMerchantCreditCardInfo As IntegratedMerchantCreditCardInfoType
    Get
    Set
public:
property IntegratedMerchantCreditCardInfoType^ IntegratedMerchantCreditCardInfo {
    IntegratedMerchantCreditCardInfoType^ get ();
    void set (IntegratedMerchantCreditCardInfoType^ value);
}


InternationalRateTable Property

InternationalRateTable Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► InternationalRateTable
Declaration Syntax
C# Visual Basic Visual C++
public bool InternationalRateTable { get; set; }
Public Property InternationalRateTable As Boolean
    Get
    Set
public:
property bool InternationalRateTable {
    bool get ();
    void set (bool value);
}


InternationalRateTableSpecified Property

InternationalRateTableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► InternationalRateTableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InternationalRateTableSpecified { get; set; }
Public Property InternationalRateTableSpecified As Boolean
    Get
    Set
public:
property bool InternationalRateTableSpecified {
    bool get ();
    void set (bool value);
}


MerchandizingPref Property

MerchandizingPref Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► MerchandizingPref
Declaration Syntax
C# Visual Basic Visual C++
public MerchandizingPrefCodeType MerchandizingPref { get; set; }
Public Property MerchandizingPref As MerchandizingPrefCodeType
    Get
    Set
public:
property MerchandizingPrefCodeType MerchandizingPref {
    MerchandizingPrefCodeType get ();
    void set (MerchandizingPrefCodeType value);
}


MerchandizingPrefSpecified Property

MerchandizingPrefSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► MerchandizingPrefSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MerchandizingPrefSpecified { get; set; }
Public Property MerchandizingPrefSpecified As Boolean
    Get
    Set
public:
property bool MerchandizingPrefSpecified {
    bool get ();
    void set (bool value);
}


PaisaPayEscrowEMIStatus Property

PaisaPayEscrowEMIStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► PaisaPayEscrowEMIStatus
Declaration Syntax
C# Visual Basic Visual C++
public int PaisaPayEscrowEMIStatus { get; set; }
Public Property PaisaPayEscrowEMIStatus As Integer
    Get
    Set
public:
property int PaisaPayEscrowEMIStatus {
    int get ();
    void set (int value);
}


PaisaPayEscrowEMIStatusSpecified Property

PaisaPayEscrowEMIStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► PaisaPayEscrowEMIStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaisaPayEscrowEMIStatusSpecified { get; set; }
Public Property PaisaPayEscrowEMIStatusSpecified As Boolean
    Get
    Set
public:
property bool PaisaPayEscrowEMIStatusSpecified {
    bool get ();
    void set (bool value);
}


PaisaPayStatus Property

PaisaPayStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► PaisaPayStatus
Declaration Syntax
C# Visual Basic Visual C++
public int PaisaPayStatus { get; set; }
Public Property PaisaPayStatus As Integer
    Get
    Set
public:
property int PaisaPayStatus {
    int get ();
    void set (int value);
}


PaisaPayStatusSpecified Property

PaisaPayStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► PaisaPayStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaisaPayStatusSpecified { get; set; }
Public Property PaisaPayStatusSpecified As Boolean
    Get
    Set
public:
property bool PaisaPayStatusSpecified {
    bool get ();
    void set (bool value);
}


PaymentMethod Property

PaymentMethod Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► PaymentMethod
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentMethodCodeType PaymentMethod { get; set; }
Public Property PaymentMethod As SellerPaymentMethodCodeType
    Get
    Set
public:
property SellerPaymentMethodCodeType PaymentMethod {
    SellerPaymentMethodCodeType get ();
    void set (SellerPaymentMethodCodeType value);
}


PaymentMethodSpecified Property

PaymentMethodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► PaymentMethodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentMethodSpecified { get; set; }
Public Property PaymentMethodSpecified As Boolean
    Get
    Set
public:
property bool PaymentMethodSpecified {
    bool get ();
    void set (bool value);
}


ProStoresPreference Property

ProStoresPreference Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► ProStoresPreference
Declaration Syntax
C# Visual Basic Visual C++
public ProStoresCheckoutPreferenceType ProStoresPreference { get; set; }
Public Property ProStoresPreference As ProStoresCheckoutPreferenceType
    Get
    Set
public:
property ProStoresCheckoutPreferenceType^ ProStoresPreference {
    ProStoresCheckoutPreferenceType^ get ();
    void set (ProStoresCheckoutPreferenceType^ value);
}


QualifiesForB2BVAT Property

QualifiesForB2BVAT Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► QualifiesForB2BVAT
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiesForB2BVAT { get; set; }
Public Property QualifiesForB2BVAT As Boolean
    Get
    Set
public:
property bool QualifiesForB2BVAT {
    bool get ();
    void set (bool value);
}


RecoupmentPolicyConsent Property

RecoupmentPolicyConsent Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► RecoupmentPolicyConsent
Declaration Syntax
C# Visual Basic Visual C++
public RecoupmentPolicyConsentType RecoupmentPolicyConsent { get; set; }
Public Property RecoupmentPolicyConsent As RecoupmentPolicyConsentType
    Get
    Set
public:
property RecoupmentPolicyConsentType^ RecoupmentPolicyConsent {
    RecoupmentPolicyConsentType^ get ();
    void set (RecoupmentPolicyConsentType^ value);
}


RegisteredBusinessSeller Property

RegisteredBusinessSeller Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► RegisteredBusinessSeller
Declaration Syntax
C# Visual Basic Visual C++
public bool RegisteredBusinessSeller { get; set; }
Public Property RegisteredBusinessSeller As Boolean
    Get
    Set
public:
property bool RegisteredBusinessSeller {
    bool get ();
    void set (bool value);
}


RegisteredBusinessSellerSpecified Property

RegisteredBusinessSellerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► RegisteredBusinessSellerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RegisteredBusinessSellerSpecified { get; set; }
Public Property RegisteredBusinessSellerSpecified As Boolean
    Get
    Set
public:
property bool RegisteredBusinessSellerSpecified {
    bool get ();
    void set (bool value);
}


SafePaymentExempt Property

SafePaymentExempt Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SafePaymentExempt
Declaration Syntax
C# Visual Basic Visual C++
public bool SafePaymentExempt { get; set; }
Public Property SafePaymentExempt As Boolean
    Get
    Set
public:
property bool SafePaymentExempt {
    bool get ();
    void set (bool value);
}


SafePaymentExemptSpecified Property

SafePaymentExemptSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SafePaymentExemptSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SafePaymentExemptSpecified { get; set; }
Public Property SafePaymentExemptSpecified As Boolean
    Get
    Set
public:
property bool SafePaymentExemptSpecified {
    bool get ();
    void set (bool value);
}


SchedulingInfo Property

SchedulingInfo Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SchedulingInfo
Declaration Syntax
C# Visual Basic Visual C++
public SchedulingInfoType SchedulingInfo { get; set; }
Public Property SchedulingInfo As SchedulingInfoType
    Get
    Set
public:
property SchedulingInfoType^ SchedulingInfo {
    SchedulingInfoType^ get ();
    void set (SchedulingInfoType^ value);
}


SellerBusinessType Property

SellerBusinessType Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SellerBusinessType
Declaration Syntax
C# Visual Basic Visual C++
public SellerBusinessCodeType SellerBusinessType { get; set; }
Public Property SellerBusinessType As SellerBusinessCodeType
    Get
    Set
public:
property SellerBusinessCodeType SellerBusinessType {
    SellerBusinessCodeType get ();
    void set (SellerBusinessCodeType value);
}


SellerBusinessTypeSpecified Property

SellerBusinessTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SellerBusinessTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerBusinessTypeSpecified { get; set; }
Public Property SellerBusinessTypeSpecified As Boolean
    Get
    Set
public:
property bool SellerBusinessTypeSpecified {
    bool get ();
    void set (bool value);
}


SellereBayPaymentProcessConsent Property

SellereBayPaymentProcessConsent Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SellereBayPaymentProcessConsent
Declaration Syntax
C# Visual Basic Visual C++
public SellereBayPaymentProcessConsentCodeType SellereBayPaymentProcessConsent { get; set; }
Public Property SellereBayPaymentProcessConsent As SellereBayPaymentProcessConsentCodeType
    Get
    Set
public:
property SellereBayPaymentProcessConsentCodeType^ SellereBayPaymentProcessConsent {
    SellereBayPaymentProcessConsentCodeType^ get ();
    void set (SellereBayPaymentProcessConsentCodeType^ value);
}


SellereBayPaymentProcessStatus Property

SellereBayPaymentProcessStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SellereBayPaymentProcessStatus
Declaration Syntax
C# Visual Basic Visual C++
public SellereBayPaymentProcessStatusCodeType SellereBayPaymentProcessStatus { get; set; }
Public Property SellereBayPaymentProcessStatus As SellereBayPaymentProcessStatusCodeType
    Get
    Set
public:
property SellereBayPaymentProcessStatusCodeType SellereBayPaymentProcessStatus {
    SellereBayPaymentProcessStatusCodeType get ();
    void set (SellereBayPaymentProcessStatusCodeType value);
}


SellereBayPaymentProcessStatusSpecified Property

SellereBayPaymentProcessStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SellereBayPaymentProcessStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellereBayPaymentProcessStatusSpecified { get; set; }
Public Property SellereBayPaymentProcessStatusSpecified As Boolean
    Get
    Set
public:
property bool SellereBayPaymentProcessStatusSpecified {
    bool get ();
    void set (bool value);
}


SellerGuaranteeLevel Property

SellerGuaranteeLevel Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SellerGuaranteeLevel
Declaration Syntax
C# Visual Basic Visual C++
public SellerGuaranteeLevelCodeType SellerGuaranteeLevel { get; set; }
Public Property SellerGuaranteeLevel As SellerGuaranteeLevelCodeType
    Get
    Set
public:
property SellerGuaranteeLevelCodeType SellerGuaranteeLevel {
    SellerGuaranteeLevelCodeType get ();
    void set (SellerGuaranteeLevelCodeType value);
}


SellerGuaranteeLevelSpecified Property

SellerGuaranteeLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SellerGuaranteeLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerGuaranteeLevelSpecified { get; set; }
Public Property SellerGuaranteeLevelSpecified As Boolean
    Get
    Set
public:
property bool SellerGuaranteeLevelSpecified {
    bool get ();
    void set (bool value);
}


SellerLevel Property

SellerLevel Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SellerLevel
Declaration Syntax
C# Visual Basic Visual C++
public SellerLevelCodeType SellerLevel { get; set; }
Public Property SellerLevel As SellerLevelCodeType
    Get
    Set
public:
property SellerLevelCodeType SellerLevel {
    SellerLevelCodeType get ();
    void set (SellerLevelCodeType value);
}


SellerLevelSpecified Property

SellerLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SellerLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerLevelSpecified { get; set; }
Public Property SellerLevelSpecified As Boolean
    Get
    Set
public:
property bool SellerLevelSpecified {
    bool get ();
    void set (bool value);
}


SellerPaymentAddress Property

SellerPaymentAddress Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SellerPaymentAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType SellerPaymentAddress { get; set; }
Public Property SellerPaymentAddress As AddressType
    Get
    Set
public:
property AddressType^ SellerPaymentAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


SellerType Constructor

SellerType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellerType ► SellerType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellerType()
Public Sub New
public:
SellerType()


StoreOwner Property

StoreOwner Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► StoreOwner
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreOwner { get; set; }
Public Property StoreOwner As Boolean
    Get
    Set
public:
property bool StoreOwner {
    bool get ();
    void set (bool value);
}


StoreSite Property

StoreSite Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► StoreSite
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType StoreSite { get; set; }
Public Property StoreSite As SiteCodeType
    Get
    Set
public:
property SiteCodeType StoreSite {
    SiteCodeType get ();
    void set (SiteCodeType value);
}


StoreSiteSpecified Property

StoreSiteSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► StoreSiteSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreSiteSpecified { get; set; }
Public Property StoreSiteSpecified As Boolean
    Get
    Set
public:
property bool StoreSiteSpecified {
    bool get ();
    void set (bool value);
}


StoreURL Property

StoreURL Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► StoreURL
Declaration Syntax
C# Visual Basic Visual C++
public string StoreURL { get; set; }
Public Property StoreURL As String
    Get
    Set
public:
property String^ StoreURL {
    String^ get ();
    void set (String^ value);
}


TopRatedSeller Property

TopRatedSeller Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► TopRatedSeller
Declaration Syntax
C# Visual Basic Visual C++
public bool TopRatedSeller { get; set; }
Public Property TopRatedSeller As Boolean
    Get
    Set
public:
property bool TopRatedSeller {
    bool get ();
    void set (bool value);
}


TopRatedSellerDetails Property

TopRatedSellerDetails Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► TopRatedSellerDetails
Declaration Syntax
C# Visual Basic Visual C++
public TopRatedSellerDetailsType TopRatedSellerDetails { get; set; }
Public Property TopRatedSellerDetails As TopRatedSellerDetailsType
    Get
    Set
public:
property TopRatedSellerDetailsType^ TopRatedSellerDetails {
    TopRatedSellerDetailsType^ get ();
    void set (TopRatedSellerDetailsType^ value);
}


TopRatedSellerSpecified Property

TopRatedSellerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► TopRatedSellerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TopRatedSellerSpecified { get; set; }
Public Property TopRatedSellerSpecified As Boolean
    Get
    Set
public:
property bool TopRatedSellerSpecified {
    bool get ();
    void set (bool value);
}


TransactionPercent Property

TransactionPercent Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► TransactionPercent
Declaration Syntax
C# Visual Basic Visual C++
public float TransactionPercent { get; set; }
Public Property TransactionPercent As Single
    Get
    Set
public:
property float TransactionPercent {
    float get ();
    void set (float value);
}


TransactionPercentSpecified Property

TransactionPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellerType ► TransactionPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TransactionPercentSpecified { get; set; }
Public Property TransactionPercentSpecified As Boolean
    Get
    Set
public:
property bool TransactionPercentSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerAlertType Class

SellingManagerAlertType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerAlertType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerAlertType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerAlertType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerAlertType()()()() |
 | AlertType |
 | AlertTypeSpecified |
 | Any |
 | AutomationAlert |
 | AutomationAlertSpecified |
 | Count |
 | CountSpecified |
 | DurationInDays |
 | DurationInDaysSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GeneralAlert |
 | GeneralAlertSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InventoryAlert |
 | InventoryAlertSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PaisaPayAlert |
 | PaisaPayAlertSpecified |
 | SoldAlert |
 | SoldAlertSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingManagerAlertType


AlertType Property

AlertType Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► AlertType
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAlertTypeCodeType AlertType { get; set; }
Public Property AlertType As SellingManagerAlertTypeCodeType
    Get
    Set
public:
property SellingManagerAlertTypeCodeType AlertType {
    SellingManagerAlertTypeCodeType get ();
    void set (SellingManagerAlertTypeCodeType value);
}


AlertTypeSpecified Property

AlertTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► AlertTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AlertTypeSpecified { get; set; }
Public Property AlertTypeSpecified As Boolean
    Get
    Set
public:
property bool AlertTypeSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AutomationAlert Property

AutomationAlert Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► AutomationAlert
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutomationPropertyTypeCodeType AutomationAlert { get; set; }
Public Property AutomationAlert As SellingManagerAutomationPropertyTypeCodeType
    Get
    Set
public:
property SellingManagerAutomationPropertyTypeCodeType AutomationAlert {
    SellingManagerAutomationPropertyTypeCodeType get ();
    void set (SellingManagerAutomationPropertyTypeCodeType value);
}


AutomationAlertSpecified Property

AutomationAlertSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► AutomationAlertSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AutomationAlertSpecified { get; set; }
Public Property AutomationAlertSpecified As Boolean
    Get
    Set
public:
property bool AutomationAlertSpecified {
    bool get ();
    void set (bool value);
}


Count Property

Count Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► Count
Declaration Syntax
C# Visual Basic Visual C++
public long Count { get; set; }
Public Property Count As Long
    Get
    Set
public:
property long long Count {
    long long get ();
    void set (long long value);
}


CountSpecified Property

CountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► CountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CountSpecified { get; set; }
Public Property CountSpecified As Boolean
    Get
    Set
public:
property bool CountSpecified {
    bool get ();
    void set (bool value);
}


DurationInDays Property

DurationInDays Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► DurationInDays
Declaration Syntax
C# Visual Basic Visual C++
public int DurationInDays { get; set; }
Public Property DurationInDays As Integer
    Get
    Set
public:
property int DurationInDays {
    int get ();
    void set (int value);
}


DurationInDaysSpecified Property

DurationInDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► DurationInDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DurationInDaysSpecified { get; set; }
Public Property DurationInDaysSpecified As Boolean
    Get
    Set
public:
property bool DurationInDaysSpecified {
    bool get ();
    void set (bool value);
}


GeneralAlert Property

GeneralAlert Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► GeneralAlert
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerGeneralPropertyTypeCodeType GeneralAlert { get; set; }
Public Property GeneralAlert As SellingManagerGeneralPropertyTypeCodeType
    Get
    Set
public:
property SellingManagerGeneralPropertyTypeCodeType GeneralAlert {
    SellingManagerGeneralPropertyTypeCodeType get ();
    void set (SellingManagerGeneralPropertyTypeCodeType value);
}


GeneralAlertSpecified Property

GeneralAlertSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► GeneralAlertSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GeneralAlertSpecified { get; set; }
Public Property GeneralAlertSpecified As Boolean
    Get
    Set
public:
property bool GeneralAlertSpecified {
    bool get ();
    void set (bool value);
}


InventoryAlert Property

InventoryAlert Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► InventoryAlert
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerInventoryPropertyTypeCodeType InventoryAlert { get; set; }
Public Property InventoryAlert As SellingManagerInventoryPropertyTypeCodeType
    Get
    Set
public:
property SellingManagerInventoryPropertyTypeCodeType InventoryAlert {
    SellingManagerInventoryPropertyTypeCodeType get ();
    void set (SellingManagerInventoryPropertyTypeCodeType value);
}


InventoryAlertSpecified Property

InventoryAlertSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► InventoryAlertSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InventoryAlertSpecified { get; set; }
Public Property InventoryAlertSpecified As Boolean
    Get
    Set
public:
property bool InventoryAlertSpecified {
    bool get ();
    void set (bool value);
}


PaisaPayAlert Property

PaisaPayAlert Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► PaisaPayAlert
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerPaisaPayPropertyTypeCodeType PaisaPayAlert { get; set; }
Public Property PaisaPayAlert As SellingManagerPaisaPayPropertyTypeCodeType
    Get
    Set
public:
property SellingManagerPaisaPayPropertyTypeCodeType PaisaPayAlert {
    SellingManagerPaisaPayPropertyTypeCodeType get ();
    void set (SellingManagerPaisaPayPropertyTypeCodeType value);
}


PaisaPayAlertSpecified Property

PaisaPayAlertSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► PaisaPayAlertSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaisaPayAlertSpecified { get; set; }
Public Property PaisaPayAlertSpecified As Boolean
    Get
    Set
public:
property bool PaisaPayAlertSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerAlertType Constructor

SellingManagerAlertType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► SellingManagerAlertType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAlertType()
Public Sub New
public:
SellingManagerAlertType()


SoldAlert Property

SoldAlert Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► SoldAlert
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldListingsPropertyTypeCodeType SoldAlert { get; set; }
Public Property SoldAlert As SellingManagerSoldListingsPropertyTypeCodeType
    Get
    Set
public:
property SellingManagerSoldListingsPropertyTypeCodeType SoldAlert {
    SellingManagerSoldListingsPropertyTypeCodeType get ();
    void set (SellingManagerSoldListingsPropertyTypeCodeType value);
}


SoldAlertSpecified Property

SoldAlertSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertType ► SoldAlertSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SoldAlertSpecified { get; set; }
Public Property SoldAlertSpecified As Boolean
    Get
    Set
public:
property bool SoldAlertSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerAlertTypeCodeType Enumeration

SellingManagerAlertTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerAlertTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerAlertTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerAlertTypeCodeType
Members
Member | Description
Sold |
Inventory |
Automation |
PaisaPay |
General |
CustomCode |
Remarks


SellingManagerAlertTypeCollection Class

SellingManagerAlertTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellingManagerAlertTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellingManagerAlertTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellingManagerAlertTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerAlertTypeCollection()()()() |
 | SellingManagerAlertTypeCollection(array<SellingManagerAlertType>[]()[][]) |
 | SellingManagerAlertTypeCollection(SellingManagerAlertTypeCollection) |
 | Add(SellingManagerAlertType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellingManagerAlertType>[]()[][]) |
 | AddRange(SellingManagerAlertTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellingManagerAlertType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellingManagerAlertType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellingManagerAlertType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellingManagerAlertType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellingManagerAlertType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellingManagerAlertTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► Add(SellingManagerAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellingManagerAlertType item
)
Public Function Add ( _
    item As SellingManagerAlertType _
) As Integer
public:
int Add(
    SellingManagerAlertType^ item
)
Parameters
item (SellingManagerAlertType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellingManagerAlertType>[]()[][]) |
 | AddRange(SellingManagerAlertTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► AddRange(array<SellingManagerAlertType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerAlertType[] items
)
Public Sub AddRange ( _
    items As SellingManagerAlertType() _
)
public:
void AddRange(
    array<SellingManagerAlertType^>^ items
)
Parameters
items (array< SellingManagerAlertType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► AddRange(SellingManagerAlertTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerAlertTypeCollection items
)
Public Sub AddRange ( _
    items As SellingManagerAlertTypeCollection _
)
public:
void AddRange(
    SellingManagerAlertTypeCollection^ items
)
Parameters
items (SellingManagerAlertTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► Contains(SellingManagerAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellingManagerAlertType item
)
Public Function Contains ( _
    item As SellingManagerAlertType _
) As Boolean
public:
bool Contains(
    SellingManagerAlertType^ item
)
Parameters
item (SellingManagerAlertType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► CopyTo(array<SellingManagerAlertType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellingManagerAlertType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellingManagerAlertType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellingManagerAlertType^>^ items,
    int index
)
Parameters
items (array< SellingManagerAlertType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► IndexOf(SellingManagerAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellingManagerAlertType item
)
Public Function IndexOf ( _
    item As SellingManagerAlertType _
) As Integer
public:
int IndexOf(
    SellingManagerAlertType^ item
)
Parameters
item (SellingManagerAlertType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► Insert(Int32, SellingManagerAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellingManagerAlertType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellingManagerAlertType _
)
public:
void Insert(
    int index,
    SellingManagerAlertType^ item
)
Parameters
index (Int32)
item (SellingManagerAlertType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAlertType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellingManagerAlertType
    Get
    Set
public:
property SellingManagerAlertType^ default[int index] {
    SellingManagerAlertType^ get (int index);
    void set (int index, SellingManagerAlertType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAlertType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellingManagerAlertType
public:
SellingManagerAlertType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► Remove(SellingManagerAlertType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellingManagerAlertType item
)
Public Sub Remove ( _
    item As SellingManagerAlertType _
)
public:
void Remove(
    SellingManagerAlertType^ item
)
Parameters
item (SellingManagerAlertType)


SellingManagerAlertTypeCollection Constructor

SellingManagerAlertTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► SellingManagerAlertTypeCollection()()()()
Members
Icon | Member | Description
 | SellingManagerAlertTypeCollection()()()() |
 | SellingManagerAlertTypeCollection(array<SellingManagerAlertType>[]()[][]) |
 | SellingManagerAlertTypeCollection(SellingManagerAlertTypeCollection) |


SellingManagerAlertTypeCollection Constructor

SellingManagerAlertTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► SellingManagerAlertTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAlertTypeCollection()
Public Sub New
public:
SellingManagerAlertTypeCollection()


SellingManagerAlertTypeCollection Constructor (items)

SellingManagerAlertTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► SellingManagerAlertTypeCollection(array<SellingManagerAlertType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAlertTypeCollection(
    SellingManagerAlertType[] items
)
Public Sub New ( _
    items As SellingManagerAlertType() _
)
public:
SellingManagerAlertTypeCollection(
    array<SellingManagerAlertType^>^ items
)
Parameters
items (array< SellingManagerAlertType >[]()[][])


SellingManagerAlertTypeCollection Constructor (items)

SellingManagerAlertTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► SellingManagerAlertTypeCollection(SellingManagerAlertTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAlertTypeCollection(
    SellingManagerAlertTypeCollection items
)
Public Sub New ( _
    items As SellingManagerAlertTypeCollection _
)
public:
SellingManagerAlertTypeCollection(
    SellingManagerAlertTypeCollection^ items
)
Parameters
items (SellingManagerAlertTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAlertType[] ToArray()
Public Function ToArray As SellingManagerAlertType()
public:
array<SellingManagerAlertType^>^ ToArray()
Return Value


SellingManagerAutoListAccordingToScheduleType Class

SellingManagerAutoListAccordingToScheduleType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerAutoListAccordingToScheduleType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerAutoListAccordingToScheduleType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerAutoListAccordingToScheduleType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerAutoListAccordingToScheduleType()()()() |
 | Any |
 | DayOfWeek |
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ListAtSpecificTimeOfDay |
 | ListAtSpecificTimeOfDaySpecified |
 | ListingHoldInventoryLevel |
 | ListingHoldInventoryLevelSpecified |
 | ListingPeriodInWeeks |
 | ListingPeriodInWeeksSpecified |
 | MaxActiveItemCount |
 | MaxActiveItemCountSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | StartTime |
 | StartTimeSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingManagerAutoListAccordingToScheduleType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DayOfWeek Property

DayOfWeek Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► DayOfWeek
Declaration Syntax
C# Visual Basic Visual C++
public DayOfWeekCodeTypeCollection DayOfWeek { get; set; }
Public Property DayOfWeek As DayOfWeekCodeTypeCollection
    Get
    Set
public:
property DayOfWeekCodeTypeCollection^ DayOfWeek {
    DayOfWeekCodeTypeCollection^ get ();
    void set (DayOfWeekCodeTypeCollection^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


ListAtSpecificTimeOfDay Property

ListAtSpecificTimeOfDay Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► ListAtSpecificTimeOfDay
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ListAtSpecificTimeOfDay { get; set; }
Public Property ListAtSpecificTimeOfDay As DateTime
    Get
    Set
public:
property DateTime ListAtSpecificTimeOfDay {
    DateTime get ();
    void set (DateTime value);
}


ListAtSpecificTimeOfDaySpecified Property

ListAtSpecificTimeOfDaySpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► ListAtSpecificTimeOfDaySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListAtSpecificTimeOfDaySpecified { get; set; }
Public Property ListAtSpecificTimeOfDaySpecified As Boolean
    Get
    Set
public:
property bool ListAtSpecificTimeOfDaySpecified {
    bool get ();
    void set (bool value);
}


ListingHoldInventoryLevel Property

ListingHoldInventoryLevel Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► ListingHoldInventoryLevel
Declaration Syntax
C# Visual Basic Visual C++
public int ListingHoldInventoryLevel { get; set; }
Public Property ListingHoldInventoryLevel As Integer
    Get
    Set
public:
property int ListingHoldInventoryLevel {
    int get ();
    void set (int value);
}


ListingHoldInventoryLevelSpecified Property

ListingHoldInventoryLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► ListingHoldInventoryLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingHoldInventoryLevelSpecified { get; set; }
Public Property ListingHoldInventoryLevelSpecified As Boolean
    Get
    Set
public:
property bool ListingHoldInventoryLevelSpecified {
    bool get ();
    void set (bool value);
}


ListingPeriodInWeeks Property

ListingPeriodInWeeks Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► ListingPeriodInWeeks
Declaration Syntax
C# Visual Basic Visual C++
public int ListingPeriodInWeeks { get; set; }
Public Property ListingPeriodInWeeks As Integer
    Get
    Set
public:
property int ListingPeriodInWeeks {
    int get ();
    void set (int value);
}


ListingPeriodInWeeksSpecified Property

ListingPeriodInWeeksSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► ListingPeriodInWeeksSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingPeriodInWeeksSpecified { get; set; }
Public Property ListingPeriodInWeeksSpecified As Boolean
    Get
    Set
public:
property bool ListingPeriodInWeeksSpecified {
    bool get ();
    void set (bool value);
}


MaxActiveItemCount Property

MaxActiveItemCount Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► MaxActiveItemCount
Declaration Syntax
C# Visual Basic Visual C++
public int MaxActiveItemCount { get; set; }
Public Property MaxActiveItemCount As Integer
    Get
    Set
public:
property int MaxActiveItemCount {
    int get ();
    void set (int value);
}


MaxActiveItemCountSpecified Property

MaxActiveItemCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► MaxActiveItemCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxActiveItemCountSpecified { get; set; }
Public Property MaxActiveItemCountSpecified As Boolean
    Get
    Set
public:
property bool MaxActiveItemCountSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerAutoListAccordingToScheduleType Constructor

SellingManagerAutoListAccordingToScheduleType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► SellingManagerAutoListAccordingToScheduleType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListAccordingToScheduleType()
Public Sub New
public:
SellingManagerAutoListAccordingToScheduleType()


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListAccordingToScheduleType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerAutoListMinActiveItemsType Class

SellingManagerAutoListMinActiveItemsType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerAutoListMinActiveItemsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerAutoListMinActiveItemsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerAutoListMinActiveItemsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerAutoListMinActiveItemsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ListingHoldInventoryLevel |
 | ListingHoldInventoryLevelSpecified |
 | ListTimeFrom |
 | ListTimeFromSpecified |
 | ListTimeTo |
 | ListTimeToSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinActiveItemCount |
 | MinActiveItemCountSpecified |
 | SpacingIntervalInMinutes |
 | SpacingIntervalInMinutesSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingManagerAutoListMinActiveItemsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ListingHoldInventoryLevel Property

ListingHoldInventoryLevel Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► ListingHoldInventoryLevel
Declaration Syntax
C# Visual Basic Visual C++
public int ListingHoldInventoryLevel { get; set; }
Public Property ListingHoldInventoryLevel As Integer
    Get
    Set
public:
property int ListingHoldInventoryLevel {
    int get ();
    void set (int value);
}


ListingHoldInventoryLevelSpecified Property

ListingHoldInventoryLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► ListingHoldInventoryLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingHoldInventoryLevelSpecified { get; set; }
Public Property ListingHoldInventoryLevelSpecified As Boolean
    Get
    Set
public:
property bool ListingHoldInventoryLevelSpecified {
    bool get ();
    void set (bool value);
}


ListTimeFrom Property

ListTimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► ListTimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ListTimeFrom { get; set; }
Public Property ListTimeFrom As DateTime
    Get
    Set
public:
property DateTime ListTimeFrom {
    DateTime get ();
    void set (DateTime value);
}


ListTimeFromSpecified Property

ListTimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► ListTimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListTimeFromSpecified { get; set; }
Public Property ListTimeFromSpecified As Boolean
    Get
    Set
public:
property bool ListTimeFromSpecified {
    bool get ();
    void set (bool value);
}


ListTimeTo Property

ListTimeTo Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► ListTimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ListTimeTo { get; set; }
Public Property ListTimeTo As DateTime
    Get
    Set
public:
property DateTime ListTimeTo {
    DateTime get ();
    void set (DateTime value);
}


ListTimeToSpecified Property

ListTimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► ListTimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListTimeToSpecified { get; set; }
Public Property ListTimeToSpecified As Boolean
    Get
    Set
public:
property bool ListTimeToSpecified {
    bool get ();
    void set (bool value);
}


MinActiveItemCount Property

MinActiveItemCount Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► MinActiveItemCount
Declaration Syntax
C# Visual Basic Visual C++
public int MinActiveItemCount { get; set; }
Public Property MinActiveItemCount As Integer
    Get
    Set
public:
property int MinActiveItemCount {
    int get ();
    void set (int value);
}


MinActiveItemCountSpecified Property

MinActiveItemCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► MinActiveItemCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinActiveItemCountSpecified { get; set; }
Public Property MinActiveItemCountSpecified As Boolean
    Get
    Set
public:
property bool MinActiveItemCountSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerAutoListMinActiveItemsType Constructor

SellingManagerAutoListMinActiveItemsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► SellingManagerAutoListMinActiveItemsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListMinActiveItemsType()
Public Sub New
public:
SellingManagerAutoListMinActiveItemsType()


SpacingIntervalInMinutes Property

SpacingIntervalInMinutes Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► SpacingIntervalInMinutes
Declaration Syntax
C# Visual Basic Visual C++
public int SpacingIntervalInMinutes { get; set; }
Public Property SpacingIntervalInMinutes As Integer
    Get
    Set
public:
property int SpacingIntervalInMinutes {
    int get ();
    void set (int value);
}


SpacingIntervalInMinutesSpecified Property

SpacingIntervalInMinutesSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListMinActiveItemsType ► SpacingIntervalInMinutesSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SpacingIntervalInMinutesSpecified { get; set; }
Public Property SpacingIntervalInMinutesSpecified As Boolean
    Get
    Set
public:
property bool SpacingIntervalInMinutesSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerAutoListType Class

SellingManagerAutoListType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerAutoListType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerAutoListType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerAutoListType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerAutoListType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | KeepMinActive |
 | ListAccordingToSchedule |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SourceSaleTemplateID |
 | SourceSaleTemplateIDSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingManagerAutoListType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


KeepMinActive Property

KeepMinActive Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListType ► KeepMinActive
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListMinActiveItemsType KeepMinActive { get; set; }
Public Property KeepMinActive As SellingManagerAutoListMinActiveItemsType
    Get
    Set
public:
property SellingManagerAutoListMinActiveItemsType^ KeepMinActive {
    SellingManagerAutoListMinActiveItemsType^ get ();
    void set (SellingManagerAutoListMinActiveItemsType^ value);
}


ListAccordingToSchedule Property

ListAccordingToSchedule Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListType ► ListAccordingToSchedule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListAccordingToScheduleType ListAccordingToSchedule { get; set; }
Public Property ListAccordingToSchedule As SellingManagerAutoListAccordingToScheduleType
    Get
    Set
public:
property SellingManagerAutoListAccordingToScheduleType^ ListAccordingToSchedule {
    SellingManagerAutoListAccordingToScheduleType^ get ();
    void set (SellingManagerAutoListAccordingToScheduleType^ value);
}


SellingManagerAutoListType Constructor

SellingManagerAutoListType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListType ► SellingManagerAutoListType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType()
Public Sub New
public:
SellingManagerAutoListType()


SourceSaleTemplateID Property

SourceSaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListType ► SourceSaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public long SourceSaleTemplateID { get; set; }
Public Property SourceSaleTemplateID As Long
    Get
    Set
public:
property long long SourceSaleTemplateID {
    long long get ();
    void set (long long value);
}


SourceSaleTemplateIDSpecified Property

SourceSaleTemplateIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoListType ► SourceSaleTemplateIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SourceSaleTemplateIDSpecified { get; set; }
Public Property SourceSaleTemplateIDSpecified As Boolean
    Get
    Set
public:
property bool SourceSaleTemplateIDSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerAutomationPropertyTypeCodeType Enumeration

SellingManagerAutomationPropertyTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutomationPropertyTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerAutomationPropertyTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerAutomationPropertyTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerAutomationPropertyTypeCodeType
Members
Member | Description
ItemListFailedAutomationRules |
ItemRelistFailedAutomationRules |
ItemListFailedSecondChanceOfferAutoRules |
CustomCode |
Remarks


SellingManagerAutoRelistOptionCodeType Enumeration

SellingManagerAutoRelistOptionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistOptionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerAutoRelistOptionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerAutoRelistOptionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerAutoRelistOptionCodeType
Members
Member | Description
RelistImmediately |
RelistAfterDaysHours |
RelistAtSpecificTimeOfDay |
CustomCode |
Remarks


SellingManagerAutoRelistType Class

SellingManagerAutoRelistType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerAutoRelistType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerAutoRelistType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerAutoRelistType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerAutoRelistType()()()() |
 | Any |
 | BestOfferDetails |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ListingHoldInventoryLevel |
 | ListingHoldInventoryLevelSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RelistAfterDays |
 | RelistAfterDaysSpecified |
 | RelistAfterHours |
 | RelistAfterHoursSpecified |
 | RelistAtSpecificTimeOfDay |
 | RelistAtSpecificTimeOfDaySpecified |
 | RelistCondition |
 | RelistConditionSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | TypeSpecified |
Remarks
Inheritance Hierarchy
Object
SellingManagerAutoRelistType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestOfferDetails Property

BestOfferDetails Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► BestOfferDetails
Declaration Syntax
C# Visual Basic Visual C++
public BestOfferDetailsType BestOfferDetails { get; set; }
Public Property BestOfferDetails As BestOfferDetailsType
    Get
    Set
public:
property BestOfferDetailsType^ BestOfferDetails {
    BestOfferDetailsType^ get ();
    void set (BestOfferDetailsType^ value);
}


ListingHoldInventoryLevel Property

ListingHoldInventoryLevel Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► ListingHoldInventoryLevel
Declaration Syntax
C# Visual Basic Visual C++
public int ListingHoldInventoryLevel { get; set; }
Public Property ListingHoldInventoryLevel As Integer
    Get
    Set
public:
property int ListingHoldInventoryLevel {
    int get ();
    void set (int value);
}


ListingHoldInventoryLevelSpecified Property

ListingHoldInventoryLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► ListingHoldInventoryLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingHoldInventoryLevelSpecified { get; set; }
Public Property ListingHoldInventoryLevelSpecified As Boolean
    Get
    Set
public:
property bool ListingHoldInventoryLevelSpecified {
    bool get ();
    void set (bool value);
}


RelistAfterDays Property

RelistAfterDays Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► RelistAfterDays
Declaration Syntax
C# Visual Basic Visual C++
public int RelistAfterDays { get; set; }
Public Property RelistAfterDays As Integer
    Get
    Set
public:
property int RelistAfterDays {
    int get ();
    void set (int value);
}


RelistAfterDaysSpecified Property

RelistAfterDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► RelistAfterDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RelistAfterDaysSpecified { get; set; }
Public Property RelistAfterDaysSpecified As Boolean
    Get
    Set
public:
property bool RelistAfterDaysSpecified {
    bool get ();
    void set (bool value);
}


RelistAfterHours Property

RelistAfterHours Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► RelistAfterHours
Declaration Syntax
C# Visual Basic Visual C++
public int RelistAfterHours { get; set; }
Public Property RelistAfterHours As Integer
    Get
    Set
public:
property int RelistAfterHours {
    int get ();
    void set (int value);
}


RelistAfterHoursSpecified Property

RelistAfterHoursSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► RelistAfterHoursSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RelistAfterHoursSpecified { get; set; }
Public Property RelistAfterHoursSpecified As Boolean
    Get
    Set
public:
property bool RelistAfterHoursSpecified {
    bool get ();
    void set (bool value);
}


RelistAtSpecificTimeOfDay Property

RelistAtSpecificTimeOfDay Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► RelistAtSpecificTimeOfDay
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RelistAtSpecificTimeOfDay { get; set; }
Public Property RelistAtSpecificTimeOfDay As DateTime
    Get
    Set
public:
property DateTime RelistAtSpecificTimeOfDay {
    DateTime get ();
    void set (DateTime value);
}


RelistAtSpecificTimeOfDaySpecified Property

RelistAtSpecificTimeOfDaySpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► RelistAtSpecificTimeOfDaySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RelistAtSpecificTimeOfDaySpecified { get; set; }
Public Property RelistAtSpecificTimeOfDaySpecified As Boolean
    Get
    Set
public:
property bool RelistAtSpecificTimeOfDaySpecified {
    bool get ();
    void set (bool value);
}


RelistCondition Property

RelistCondition Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► RelistCondition
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistOptionCodeType RelistCondition { get; set; }
Public Property RelistCondition As SellingManagerAutoRelistOptionCodeType
    Get
    Set
public:
property SellingManagerAutoRelistOptionCodeType RelistCondition {
    SellingManagerAutoRelistOptionCodeType get ();
    void set (SellingManagerAutoRelistOptionCodeType value);
}


RelistConditionSpecified Property

RelistConditionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► RelistConditionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RelistConditionSpecified { get; set; }
Public Property RelistConditionSpecified As Boolean
    Get
    Set
public:
property bool RelistConditionSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerAutoRelistType Constructor

SellingManagerAutoRelistType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► SellingManagerAutoRelistType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType()
Public Sub New
public:
SellingManagerAutoRelistType()


Type Property

Type Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► Type
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistTypeCodeType Type { get; set; }
Public Property Type As SellingManagerAutoRelistTypeCodeType
    Get
    Set
public:
property SellingManagerAutoRelistTypeCodeType Type {
    SellingManagerAutoRelistTypeCodeType get ();
    void set (SellingManagerAutoRelistTypeCodeType value);
}


TypeSpecified Property

TypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistType ► TypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TypeSpecified { get; set; }
Public Property TypeSpecified As Boolean
    Get
    Set
public:
property bool TypeSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerAutoRelistTypeCodeType Enumeration

SellingManagerAutoRelistTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoRelistTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerAutoRelistTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerAutoRelistTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerAutoRelistTypeCodeType
Members
Member | Description
RelistOnceIfNotSold |
RelistContinuouslyUntilSold |
RelistContinuously |
CustomCode |
Remarks


SellingManagerAutoSecondChanceOfferType Class

SellingManagerAutoSecondChanceOfferType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerAutoSecondChanceOfferType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerAutoSecondChanceOfferType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerAutoSecondChanceOfferType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerAutoSecondChanceOfferType()()()() |
 | Amount |
 | Any |
 | Duration |
 | DurationSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ListingHoldInventoryLevel |
 | ListingHoldInventoryLevelSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProfitPercent |
 | ProfitPercentSpecified |
 | SecondChanceOfferCondition |
 | SecondChanceOfferConditionSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingManagerAutoSecondChanceOfferType


Amount Property

Amount Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType ► Amount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Amount { get; set; }
Public Property Amount As AmountType
    Get
    Set
public:
property AmountType^ Amount {
    AmountType^ get ();
    void set (AmountType^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Duration Property

Duration Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType ► Duration
Declaration Syntax
C# Visual Basic Visual C++
public SecondChanceOfferDurationCodeType Duration { get; set; }
Public Property Duration As SecondChanceOfferDurationCodeType
    Get
    Set
public:
property SecondChanceOfferDurationCodeType Duration {
    SecondChanceOfferDurationCodeType get ();
    void set (SecondChanceOfferDurationCodeType value);
}


DurationSpecified Property

DurationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType ► DurationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DurationSpecified { get; set; }
Public Property DurationSpecified As Boolean
    Get
    Set
public:
property bool DurationSpecified {
    bool get ();
    void set (bool value);
}


ListingHoldInventoryLevel Property

ListingHoldInventoryLevel Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType ► ListingHoldInventoryLevel
Declaration Syntax
C# Visual Basic Visual C++
public int ListingHoldInventoryLevel { get; set; }
Public Property ListingHoldInventoryLevel As Integer
    Get
    Set
public:
property int ListingHoldInventoryLevel {
    int get ();
    void set (int value);
}


ListingHoldInventoryLevelSpecified Property

ListingHoldInventoryLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType ► ListingHoldInventoryLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingHoldInventoryLevelSpecified { get; set; }
Public Property ListingHoldInventoryLevelSpecified As Boolean
    Get
    Set
public:
property bool ListingHoldInventoryLevelSpecified {
    bool get ();
    void set (bool value);
}


ProfitPercent Property

ProfitPercent Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType ► ProfitPercent
Declaration Syntax
C# Visual Basic Visual C++
public float ProfitPercent { get; set; }
Public Property ProfitPercent As Single
    Get
    Set
public:
property float ProfitPercent {
    float get ();
    void set (float value);
}


ProfitPercentSpecified Property

ProfitPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType ► ProfitPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProfitPercentSpecified { get; set; }
Public Property ProfitPercentSpecified As Boolean
    Get
    Set
public:
property bool ProfitPercentSpecified {
    bool get ();
    void set (bool value);
}


SecondChanceOfferCondition Property

SecondChanceOfferCondition Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType ► SecondChanceOfferCondition
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferTypeCodeType SecondChanceOfferCondition { get; set; }
Public Property SecondChanceOfferCondition As SellingManagerAutoSecondChanceOfferTypeCodeType
    Get
    Set
public:
property SellingManagerAutoSecondChanceOfferTypeCodeType SecondChanceOfferCondition {
    SellingManagerAutoSecondChanceOfferTypeCodeType get ();
    void set (SellingManagerAutoSecondChanceOfferTypeCodeType value);
}


SecondChanceOfferConditionSpecified Property

SecondChanceOfferConditionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType ► SecondChanceOfferConditionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SecondChanceOfferConditionSpecified { get; set; }
Public Property SecondChanceOfferConditionSpecified As Boolean
    Get
    Set
public:
property bool SecondChanceOfferConditionSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerAutoSecondChanceOfferType Constructor

SellingManagerAutoSecondChanceOfferType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferType ► SellingManagerAutoSecondChanceOfferType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType()
Public Sub New
public:
SellingManagerAutoSecondChanceOfferType()


SellingManagerAutoSecondChanceOfferTypeCodeType Enumeration

SellingManagerAutoSecondChanceOfferTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAutoSecondChanceOfferTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerAutoSecondChanceOfferTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerAutoSecondChanceOfferTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerAutoSecondChanceOfferTypeCodeType
Members
Member | Description
BidsGreaterThanAmount |
BidsGreaterThanCostPlusAmount |
BidsGreaterThanCostPlusPercentage |
CustomCode |
Remarks


SellingManagerEmailLogType Class

SellingManagerEmailLogType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerEmailLogType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerEmailLogType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerEmailLogType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerEmailLogType()()()() |
 | Any |
 | CustomEmailName |
 | EmailState |
 | EmailStateSpecified |
 | EmailType |
 | EmailTypeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | EventTime |
 | EventTimeSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingManagerEmailLogType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CustomEmailName Property

CustomEmailName Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogType ► CustomEmailName
Declaration Syntax
C# Visual Basic Visual C++
public string CustomEmailName { get; set; }
Public Property CustomEmailName As String
    Get
    Set
public:
property String^ CustomEmailName {
    String^ get ();
    void set (String^ value);
}


EmailState Property

EmailState Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogType ► EmailState
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailSentStatusCodeType EmailState { get; set; }
Public Property EmailState As SellingManagerEmailSentStatusCodeType
    Get
    Set
public:
property SellingManagerEmailSentStatusCodeType EmailState {
    SellingManagerEmailSentStatusCodeType get ();
    void set (SellingManagerEmailSentStatusCodeType value);
}


EmailStateSpecified Property

EmailStateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogType ► EmailStateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailStateSpecified { get; set; }
Public Property EmailStateSpecified As Boolean
    Get
    Set
public:
property bool EmailStateSpecified {
    bool get ();
    void set (bool value);
}


EmailType Property

EmailType Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogType ► EmailType
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailTypeCodeType EmailType { get; set; }
Public Property EmailType As SellingManagerEmailTypeCodeType
    Get
    Set
public:
property SellingManagerEmailTypeCodeType EmailType {
    SellingManagerEmailTypeCodeType get ();
    void set (SellingManagerEmailTypeCodeType value);
}


EmailTypeSpecified Property

EmailTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogType ► EmailTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailTypeSpecified { get; set; }
Public Property EmailTypeSpecified As Boolean
    Get
    Set
public:
property bool EmailTypeSpecified {
    bool get ();
    void set (bool value);
}


EventTime Property

EventTime Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogType ► EventTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EventTime { get; set; }
Public Property EventTime As DateTime
    Get
    Set
public:
property DateTime EventTime {
    DateTime get ();
    void set (DateTime value);
}


EventTimeSpecified Property

EventTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogType ► EventTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EventTimeSpecified { get; set; }
Public Property EventTimeSpecified As Boolean
    Get
    Set
public:
property bool EventTimeSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerEmailLogType Constructor

SellingManagerEmailLogType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogType ► SellingManagerEmailLogType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailLogType()
Public Sub New
public:
SellingManagerEmailLogType()


SellingManagerEmailLogTypeCollection Class

SellingManagerEmailLogTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellingManagerEmailLogTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellingManagerEmailLogTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellingManagerEmailLogTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerEmailLogTypeCollection()()()() |
 | SellingManagerEmailLogTypeCollection(array<SellingManagerEmailLogType>[]()[][]) |
 | SellingManagerEmailLogTypeCollection(SellingManagerEmailLogTypeCollection) |
 | Add(SellingManagerEmailLogType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellingManagerEmailLogType>[]()[][]) |
 | AddRange(SellingManagerEmailLogTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellingManagerEmailLogType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellingManagerEmailLogType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellingManagerEmailLogType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellingManagerEmailLogType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellingManagerEmailLogType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellingManagerEmailLogTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► Add(SellingManagerEmailLogType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellingManagerEmailLogType item
)
Public Function Add ( _
    item As SellingManagerEmailLogType _
) As Integer
public:
int Add(
    SellingManagerEmailLogType^ item
)
Parameters
item (SellingManagerEmailLogType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellingManagerEmailLogType>[]()[][]) |
 | AddRange(SellingManagerEmailLogTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► AddRange(array<SellingManagerEmailLogType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerEmailLogType[] items
)
Public Sub AddRange ( _
    items As SellingManagerEmailLogType() _
)
public:
void AddRange(
    array<SellingManagerEmailLogType^>^ items
)
Parameters
items (array< SellingManagerEmailLogType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► AddRange(SellingManagerEmailLogTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerEmailLogTypeCollection items
)
Public Sub AddRange ( _
    items As SellingManagerEmailLogTypeCollection _
)
public:
void AddRange(
    SellingManagerEmailLogTypeCollection^ items
)
Parameters
items (SellingManagerEmailLogTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► Contains(SellingManagerEmailLogType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellingManagerEmailLogType item
)
Public Function Contains ( _
    item As SellingManagerEmailLogType _
) As Boolean
public:
bool Contains(
    SellingManagerEmailLogType^ item
)
Parameters
item (SellingManagerEmailLogType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► CopyTo(array<SellingManagerEmailLogType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellingManagerEmailLogType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellingManagerEmailLogType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellingManagerEmailLogType^>^ items,
    int index
)
Parameters
items (array< SellingManagerEmailLogType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► IndexOf(SellingManagerEmailLogType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellingManagerEmailLogType item
)
Public Function IndexOf ( _
    item As SellingManagerEmailLogType _
) As Integer
public:
int IndexOf(
    SellingManagerEmailLogType^ item
)
Parameters
item (SellingManagerEmailLogType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► Insert(Int32, SellingManagerEmailLogType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellingManagerEmailLogType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellingManagerEmailLogType _
)
public:
void Insert(
    int index,
    SellingManagerEmailLogType^ item
)
Parameters
index (Int32)
item (SellingManagerEmailLogType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailLogType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellingManagerEmailLogType
    Get
    Set
public:
property SellingManagerEmailLogType^ default[int index] {
    SellingManagerEmailLogType^ get (int index);
    void set (int index, SellingManagerEmailLogType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailLogType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellingManagerEmailLogType
public:
SellingManagerEmailLogType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► Remove(SellingManagerEmailLogType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellingManagerEmailLogType item
)
Public Sub Remove ( _
    item As SellingManagerEmailLogType _
)
public:
void Remove(
    SellingManagerEmailLogType^ item
)
Parameters
item (SellingManagerEmailLogType)


SellingManagerEmailLogTypeCollection Constructor

SellingManagerEmailLogTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► SellingManagerEmailLogTypeCollection()()()()
Members
Icon | Member | Description
 | SellingManagerEmailLogTypeCollection()()()() |
 | SellingManagerEmailLogTypeCollection(array<SellingManagerEmailLogType>[]()[][]) |
 | SellingManagerEmailLogTypeCollection(SellingManagerEmailLogTypeCollection) |


SellingManagerEmailLogTypeCollection Constructor

SellingManagerEmailLogTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► SellingManagerEmailLogTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailLogTypeCollection()
Public Sub New
public:
SellingManagerEmailLogTypeCollection()


SellingManagerEmailLogTypeCollection Constructor (items)

SellingManagerEmailLogTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► SellingManagerEmailLogTypeCollection(array<SellingManagerEmailLogType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailLogTypeCollection(
    SellingManagerEmailLogType[] items
)
Public Sub New ( _
    items As SellingManagerEmailLogType() _
)
public:
SellingManagerEmailLogTypeCollection(
    array<SellingManagerEmailLogType^>^ items
)
Parameters
items (array< SellingManagerEmailLogType >[]()[][])


SellingManagerEmailLogTypeCollection Constructor (items)

SellingManagerEmailLogTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► SellingManagerEmailLogTypeCollection(SellingManagerEmailLogTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailLogTypeCollection(
    SellingManagerEmailLogTypeCollection items
)
Public Sub New ( _
    items As SellingManagerEmailLogTypeCollection _
)
public:
SellingManagerEmailLogTypeCollection(
    SellingManagerEmailLogTypeCollection^ items
)
Parameters
items (SellingManagerEmailLogTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerEmailLogType[] ToArray()
Public Function ToArray As SellingManagerEmailLogType()
public:
array<SellingManagerEmailLogType^>^ ToArray()
Return Value


SellingManagerEmailSentStatusCodeType Enumeration

SellingManagerEmailSentStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailSentStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerEmailSentStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerEmailSentStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerEmailSentStatusCodeType
Members
Member | Description
Successful |
Failed |
Pending |
CustomCode |
Remarks


SellingManagerEmailTypeCodeType Enumeration

SellingManagerEmailTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerEmailTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerEmailTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerEmailTypeCodeType
Members
Member | Description
ManualEntry |
WinningBuyerEmail |
PaymentReminderEmail |
PaymentReceivedEmail |
RequestForShippingAddressEmail |
FeedbackReminderEmail |
ShipmentSentEmail |
PersonalizedEmail |
InvoiceNotification |
CustomEmailTemplate1 |
CustomEmailTemplate2 |
CustomEmailTemplate3 |
CustomEmailTemplate4 |
CustomEmailTemplate5 |
CustomEmailTemplate6 |
CustomEmailTemplate7 |
CustomEmailTemplate8 |
CustomEmailTemplate9 |
CustomEmailTemplate10 |
CustomEmailTemplate11 |
CustomEmailTemplate12 |
CustomEmailTemplate13 |
CustomEmailTemplate14 |
CustomEmailTemplate15 |
CustomEmailTemplate16 |
CustomEmailTemplate17 |
CustomEmailTemplate18 |
CustomEmailTemplate19 |
CustomEmailTemplate20 |
CustomCode |
Remarks


SellingManagerFolderDetailsType Class

SellingManagerFolderDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerFolderDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerFolderDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerFolderDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerFolderDetailsType()()()() |
 | Any |
 | ChildFolder |
 | CreationTime |
 | CreationTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderComment |
 | FolderID |
 | FolderIDSpecified |
 | FolderLevel |
 | FolderLevelSpecified |
 | FolderName |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ParentFolderID |
 | ParentFolderIDSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingManagerFolderDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ChildFolder Property

ChildFolder Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► ChildFolder
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsTypeCollection ChildFolder { get; set; }
Public Property ChildFolder As SellingManagerFolderDetailsTypeCollection
    Get
    Set
public:
property SellingManagerFolderDetailsTypeCollection^ ChildFolder {
    SellingManagerFolderDetailsTypeCollection^ get ();
    void set (SellingManagerFolderDetailsTypeCollection^ value);
}


CreationTime Property

CreationTime Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► CreationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreationTime { get; set; }
Public Property CreationTime As DateTime
    Get
    Set
public:
property DateTime CreationTime {
    DateTime get ();
    void set (DateTime value);
}


CreationTimeSpecified Property

CreationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► CreationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreationTimeSpecified { get; set; }
Public Property CreationTimeSpecified As Boolean
    Get
    Set
public:
property bool CreationTimeSpecified {
    bool get ();
    void set (bool value);
}


FolderComment Property

FolderComment Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► FolderComment
Declaration Syntax
C# Visual Basic Visual C++
public string FolderComment { get; set; }
Public Property FolderComment As String
    Get
    Set
public:
property String^ FolderComment {
    String^ get ();
    void set (String^ value);
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


FolderLevel Property

FolderLevel Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► FolderLevel
Declaration Syntax
C# Visual Basic Visual C++
public long FolderLevel { get; set; }
Public Property FolderLevel As Long
    Get
    Set
public:
property long long FolderLevel {
    long long get ();
    void set (long long value);
}


FolderLevelSpecified Property

FolderLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► FolderLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderLevelSpecified { get; set; }
Public Property FolderLevelSpecified As Boolean
    Get
    Set
public:
property bool FolderLevelSpecified {
    bool get ();
    void set (bool value);
}


FolderName Property

FolderName Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► FolderName
Declaration Syntax
C# Visual Basic Visual C++
public string FolderName { get; set; }
Public Property FolderName As String
    Get
    Set
public:
property String^ FolderName {
    String^ get ();
    void set (String^ value);
}


ParentFolderID Property

ParentFolderID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► ParentFolderID
Declaration Syntax
C# Visual Basic Visual C++
public long ParentFolderID { get; set; }
Public Property ParentFolderID As Long
    Get
    Set
public:
property long long ParentFolderID {
    long long get ();
    void set (long long value);
}


ParentFolderIDSpecified Property

ParentFolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► ParentFolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ParentFolderIDSpecified { get; set; }
Public Property ParentFolderIDSpecified As Boolean
    Get
    Set
public:
property bool ParentFolderIDSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerFolderDetailsType Constructor

SellingManagerFolderDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsType ► SellingManagerFolderDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType()
Public Sub New
public:
SellingManagerFolderDetailsType()


SellingManagerFolderDetailsTypeCollection Class

SellingManagerFolderDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellingManagerFolderDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellingManagerFolderDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellingManagerFolderDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerFolderDetailsTypeCollection()()()() |
 | SellingManagerFolderDetailsTypeCollection(array<SellingManagerFolderDetailsType>[]()[][]) |
 | SellingManagerFolderDetailsTypeCollection(SellingManagerFolderDetailsTypeCollection) |
 | Add(SellingManagerFolderDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellingManagerFolderDetailsType>[]()[][]) |
 | AddRange(SellingManagerFolderDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellingManagerFolderDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellingManagerFolderDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellingManagerFolderDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellingManagerFolderDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellingManagerFolderDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellingManagerFolderDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► Add(SellingManagerFolderDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellingManagerFolderDetailsType item
)
Public Function Add ( _
    item As SellingManagerFolderDetailsType _
) As Integer
public:
int Add(
    SellingManagerFolderDetailsType^ item
)
Parameters
item (SellingManagerFolderDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellingManagerFolderDetailsType>[]()[][]) |
 | AddRange(SellingManagerFolderDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► AddRange(array<SellingManagerFolderDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerFolderDetailsType[] items
)
Public Sub AddRange ( _
    items As SellingManagerFolderDetailsType() _
)
public:
void AddRange(
    array<SellingManagerFolderDetailsType^>^ items
)
Parameters
items (array< SellingManagerFolderDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► AddRange(SellingManagerFolderDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerFolderDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As SellingManagerFolderDetailsTypeCollection _
)
public:
void AddRange(
    SellingManagerFolderDetailsTypeCollection^ items
)
Parameters
items (SellingManagerFolderDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► Contains(SellingManagerFolderDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellingManagerFolderDetailsType item
)
Public Function Contains ( _
    item As SellingManagerFolderDetailsType _
) As Boolean
public:
bool Contains(
    SellingManagerFolderDetailsType^ item
)
Parameters
item (SellingManagerFolderDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► CopyTo(array<SellingManagerFolderDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellingManagerFolderDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellingManagerFolderDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellingManagerFolderDetailsType^>^ items,
    int index
)
Parameters
items (array< SellingManagerFolderDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► IndexOf(SellingManagerFolderDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellingManagerFolderDetailsType item
)
Public Function IndexOf ( _
    item As SellingManagerFolderDetailsType _
) As Integer
public:
int IndexOf(
    SellingManagerFolderDetailsType^ item
)
Parameters
item (SellingManagerFolderDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► Insert(Int32, SellingManagerFolderDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellingManagerFolderDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellingManagerFolderDetailsType _
)
public:
void Insert(
    int index,
    SellingManagerFolderDetailsType^ item
)
Parameters
index (Int32)
item (SellingManagerFolderDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellingManagerFolderDetailsType
    Get
    Set
public:
property SellingManagerFolderDetailsType^ default[int index] {
    SellingManagerFolderDetailsType^ get (int index);
    void set (int index, SellingManagerFolderDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellingManagerFolderDetailsType
public:
SellingManagerFolderDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► Remove(SellingManagerFolderDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellingManagerFolderDetailsType item
)
Public Sub Remove ( _
    item As SellingManagerFolderDetailsType _
)
public:
void Remove(
    SellingManagerFolderDetailsType^ item
)
Parameters
item (SellingManagerFolderDetailsType)


SellingManagerFolderDetailsTypeCollection Constructor

SellingManagerFolderDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► SellingManagerFolderDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | SellingManagerFolderDetailsTypeCollection()()()() |
 | SellingManagerFolderDetailsTypeCollection(array<SellingManagerFolderDetailsType>[]()[][]) |
 | SellingManagerFolderDetailsTypeCollection(SellingManagerFolderDetailsTypeCollection) |


SellingManagerFolderDetailsTypeCollection Constructor

SellingManagerFolderDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► SellingManagerFolderDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsTypeCollection()
Public Sub New
public:
SellingManagerFolderDetailsTypeCollection()


SellingManagerFolderDetailsTypeCollection Constructor (items)

SellingManagerFolderDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► SellingManagerFolderDetailsTypeCollection(array<SellingManagerFolderDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsTypeCollection(
    SellingManagerFolderDetailsType[] items
)
Public Sub New ( _
    items As SellingManagerFolderDetailsType() _
)
public:
SellingManagerFolderDetailsTypeCollection(
    array<SellingManagerFolderDetailsType^>^ items
)
Parameters
items (array< SellingManagerFolderDetailsType >[]()[][])


SellingManagerFolderDetailsTypeCollection Constructor (items)

SellingManagerFolderDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► SellingManagerFolderDetailsTypeCollection(SellingManagerFolderDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsTypeCollection(
    SellingManagerFolderDetailsTypeCollection items
)
Public Sub New ( _
    items As SellingManagerFolderDetailsTypeCollection _
)
public:
SellingManagerFolderDetailsTypeCollection(
    SellingManagerFolderDetailsTypeCollection^ items
)
Parameters
items (SellingManagerFolderDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerFolderDetailsType[] ToArray()
Public Function ToArray As SellingManagerFolderDetailsType()
public:
array<SellingManagerFolderDetailsType^>^ ToArray()
Return Value


SellingManagerGeneralPropertyTypeCodeType Enumeration

SellingManagerGeneralPropertyTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerGeneralPropertyTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerGeneralPropertyTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerGeneralPropertyTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerGeneralPropertyTypeCodeType
Members
Member | Description
NegativeFeedbackReceived |
UnpaidItemDispute |
BadEmailTemplate |
CustomCode |
Remarks


SellingManagerInventoryPropertyTypeCodeType Enumeration

SellingManagerInventoryPropertyTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerInventoryPropertyTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerInventoryPropertyTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerInventoryPropertyTypeCodeType
Members
Member | Description
ProductsOutOfStock |
Active |
InActive |
LowStock |
WithListings |
WithoutListings |
CustomCode |
Remarks


SellingManagerInventoryPropertyTypeCodeTypeCollection Class

SellingManagerInventoryPropertyTypeCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellingManagerInventoryPropertyTypeCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellingManagerInventoryPropertyTypeCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellingManagerInventoryPropertyTypeCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerInventoryPropertyTypeCodeTypeCollection()()()() |
 | SellingManagerInventoryPropertyTypeCodeTypeCollection(array<SellingManagerInventoryPropertyTypeCodeType>[]()[][]) |
 | SellingManagerInventoryPropertyTypeCodeTypeCollection(SellingManagerInventoryPropertyTypeCodeTypeCollection) |
 | Add(SellingManagerInventoryPropertyTypeCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellingManagerInventoryPropertyTypeCodeType>[]()[][]) |
 | AddRange(SellingManagerInventoryPropertyTypeCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellingManagerInventoryPropertyTypeCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellingManagerInventoryPropertyTypeCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellingManagerInventoryPropertyTypeCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellingManagerInventoryPropertyTypeCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellingManagerInventoryPropertyTypeCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellingManagerInventoryPropertyTypeCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► Add(SellingManagerInventoryPropertyTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellingManagerInventoryPropertyTypeCodeType item
)
Public Function Add ( _
    item As SellingManagerInventoryPropertyTypeCodeType _
) As Integer
public:
int Add(
    SellingManagerInventoryPropertyTypeCodeType item
)
Parameters
item (SellingManagerInventoryPropertyTypeCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellingManagerInventoryPropertyTypeCodeType>[]()[][]) |
 | AddRange(SellingManagerInventoryPropertyTypeCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► AddRange(array<SellingManagerInventoryPropertyTypeCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerInventoryPropertyTypeCodeType[] items
)
Public Sub AddRange ( _
    items As SellingManagerInventoryPropertyTypeCodeType() _
)
public:
void AddRange(
    array<SellingManagerInventoryPropertyTypeCodeType>^ items
)
Parameters
items (array< SellingManagerInventoryPropertyTypeCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► AddRange(SellingManagerInventoryPropertyTypeCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerInventoryPropertyTypeCodeTypeCollection items
)
Public Sub AddRange ( _
    items As SellingManagerInventoryPropertyTypeCodeTypeCollection _
)
public:
void AddRange(
    SellingManagerInventoryPropertyTypeCodeTypeCollection^ items
)
Parameters
items (SellingManagerInventoryPropertyTypeCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► Contains(SellingManagerInventoryPropertyTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellingManagerInventoryPropertyTypeCodeType item
)
Public Function Contains ( _
    item As SellingManagerInventoryPropertyTypeCodeType _
) As Boolean
public:
bool Contains(
    SellingManagerInventoryPropertyTypeCodeType item
)
Parameters
item (SellingManagerInventoryPropertyTypeCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► CopyTo(array<SellingManagerInventoryPropertyTypeCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellingManagerInventoryPropertyTypeCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellingManagerInventoryPropertyTypeCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellingManagerInventoryPropertyTypeCodeType>^ items,
    int index
)
Parameters
items (array< SellingManagerInventoryPropertyTypeCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► IndexOf(SellingManagerInventoryPropertyTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellingManagerInventoryPropertyTypeCodeType item
)
Public Function IndexOf ( _
    item As SellingManagerInventoryPropertyTypeCodeType _
) As Integer
public:
int IndexOf(
    SellingManagerInventoryPropertyTypeCodeType item
)
Parameters
item (SellingManagerInventoryPropertyTypeCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► Insert(Int32, SellingManagerInventoryPropertyTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellingManagerInventoryPropertyTypeCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellingManagerInventoryPropertyTypeCodeType _
)
public:
void Insert(
    int index,
    SellingManagerInventoryPropertyTypeCodeType item
)
Parameters
index (Int32)
item (SellingManagerInventoryPropertyTypeCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerInventoryPropertyTypeCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellingManagerInventoryPropertyTypeCodeType
    Get
    Set
public:
property SellingManagerInventoryPropertyTypeCodeType default[int index] {
    SellingManagerInventoryPropertyTypeCodeType get (int index);
    void set (int index, SellingManagerInventoryPropertyTypeCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerInventoryPropertyTypeCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellingManagerInventoryPropertyTypeCodeType
public:
SellingManagerInventoryPropertyTypeCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► Remove(SellingManagerInventoryPropertyTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellingManagerInventoryPropertyTypeCodeType item
)
Public Sub Remove ( _
    item As SellingManagerInventoryPropertyTypeCodeType _
)
public:
void Remove(
    SellingManagerInventoryPropertyTypeCodeType item
)
Parameters
item (SellingManagerInventoryPropertyTypeCodeType)


SellingManagerInventoryPropertyTypeCodeTypeCollection Constructor

SellingManagerInventoryPropertyTypeCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► SellingManagerInventoryPropertyTypeCodeTypeCollection()()()()
Members
Icon | Member | Description
 | SellingManagerInventoryPropertyTypeCodeTypeCollection()()()() |
 | SellingManagerInventoryPropertyTypeCodeTypeCollection(array<SellingManagerInventoryPropertyTypeCodeType>[]()[][]) |
 | SellingManagerInventoryPropertyTypeCodeTypeCollection(SellingManagerInventoryPropertyTypeCodeTypeCollection) |


SellingManagerInventoryPropertyTypeCodeTypeCollection Constructor

SellingManagerInventoryPropertyTypeCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► SellingManagerInventoryPropertyTypeCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerInventoryPropertyTypeCodeTypeCollection()
Public Sub New
public:
SellingManagerInventoryPropertyTypeCodeTypeCollection()


SellingManagerInventoryPropertyTypeCodeTypeCollection Constructor (items)

SellingManagerInventoryPropertyTypeCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► SellingManagerInventoryPropertyTypeCodeTypeCollection(array<SellingManagerInventoryPropertyTypeCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerInventoryPropertyTypeCodeTypeCollection(
    SellingManagerInventoryPropertyTypeCodeType[] items
)
Public Sub New ( _
    items As SellingManagerInventoryPropertyTypeCodeType() _
)
public:
SellingManagerInventoryPropertyTypeCodeTypeCollection(
    array<SellingManagerInventoryPropertyTypeCodeType>^ items
)
Parameters
items (array< SellingManagerInventoryPropertyTypeCodeType >[]()[][])


SellingManagerInventoryPropertyTypeCodeTypeCollection Constructor (items)

SellingManagerInventoryPropertyTypeCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► SellingManagerInventoryPropertyTypeCodeTypeCollection(SellingManagerInventoryPropertyTypeCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerInventoryPropertyTypeCodeTypeCollection(
    SellingManagerInventoryPropertyTypeCodeTypeCollection items
)
Public Sub New ( _
    items As SellingManagerInventoryPropertyTypeCodeTypeCollection _
)
public:
SellingManagerInventoryPropertyTypeCodeTypeCollection(
    SellingManagerInventoryPropertyTypeCodeTypeCollection^ items
)
Parameters
items (SellingManagerInventoryPropertyTypeCodeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerInventoryPropertyTypeCodeType[] ToArray()
Public Function ToArray As SellingManagerInventoryPropertyTypeCodeType()
public:
array<SellingManagerInventoryPropertyTypeCodeType>^ ToArray()
Return Value


SellingManagerOrderStatusType Class

SellingManagerOrderStatusType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerOrderStatusType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerOrderStatusType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerOrderStatusType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerOrderStatusType()()()() |
 | Any |
 | CheckoutStatus |
 | CheckoutStatusSpecified |
 | eBayPaymentStatus |
 | eBayPaymentStatusSpecified |
 | Equals(Object) | (Inherited from Object.)
 | FeedbackReceived |
 | FeedbackReceivedSpecified |
 | FeedbackSent |
 | FeedbackSentSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IntegratedMerchantCreditCardEnabled |
 | IntegratedMerchantCreditCardEnabledSpecified |
 | LastEmailSentTime |
 | LastEmailSentTimeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PaidStatus |
 | PaidStatusSpecified |
 | PaidTime |
 | PaidTimeSpecified |
 | PaymentHoldStatus |
 | PaymentHoldStatusSpecified |
 | PaymentMethodUsed |
 | PaymentMethodUsedSpecified |
 | PayPalTransactionID |
 | SellerInvoiceNumber |
 | SellerInvoiceTime |
 | SellerInvoiceTimeSpecified |
 | ShippedStatus |
 | ShippedStatusSpecified |
 | ShippedTime |
 | ShippedTimeSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TotalEmailsSent |
 | TotalEmailsSentSpecified |
Remarks
Inheritance Hierarchy
Object
SellingManagerOrderStatusType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CheckoutStatus Property

CheckoutStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► CheckoutStatus
Declaration Syntax
C# Visual Basic Visual C++
public CheckoutStatusCodeType CheckoutStatus { get; set; }
Public Property CheckoutStatus As CheckoutStatusCodeType
    Get
    Set
public:
property CheckoutStatusCodeType CheckoutStatus {
    CheckoutStatusCodeType get ();
    void set (CheckoutStatusCodeType value);
}


CheckoutStatusSpecified Property

CheckoutStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► CheckoutStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckoutStatusSpecified { get; set; }
Public Property CheckoutStatusSpecified As Boolean
    Get
    Set
public:
property bool CheckoutStatusSpecified {
    bool get ();
    void set (bool value);
}


eBayPaymentStatus Property

eBayPaymentStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► eBayPaymentStatus
Declaration Syntax
C# Visual Basic Visual C++
public PaymentStatusCodeType eBayPaymentStatus { get; set; }
Public Property eBayPaymentStatus As PaymentStatusCodeType
    Get
    Set
public:
property PaymentStatusCodeType eBayPaymentStatus {
    PaymentStatusCodeType get ();
    void set (PaymentStatusCodeType value);
}


eBayPaymentStatusSpecified Property

eBayPaymentStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► eBayPaymentStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayPaymentStatusSpecified { get; set; }
Public Property eBayPaymentStatusSpecified As Boolean
    Get
    Set
public:
property bool eBayPaymentStatusSpecified {
    bool get ();
    void set (bool value);
}


FeedbackReceived Property

FeedbackReceived Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► FeedbackReceived
Declaration Syntax
C# Visual Basic Visual C++
public CommentTypeCodeType FeedbackReceived { get; set; }
Public Property FeedbackReceived As CommentTypeCodeType
    Get
    Set
public:
property CommentTypeCodeType FeedbackReceived {
    CommentTypeCodeType get ();
    void set (CommentTypeCodeType value);
}


FeedbackReceivedSpecified Property

FeedbackReceivedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► FeedbackReceivedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackReceivedSpecified { get; set; }
Public Property FeedbackReceivedSpecified As Boolean
    Get
    Set
public:
property bool FeedbackReceivedSpecified {
    bool get ();
    void set (bool value);
}


FeedbackSent Property

FeedbackSent Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► FeedbackSent
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackSent { get; set; }
Public Property FeedbackSent As Boolean
    Get
    Set
public:
property bool FeedbackSent {
    bool get ();
    void set (bool value);
}


FeedbackSentSpecified Property

FeedbackSentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► FeedbackSentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackSentSpecified { get; set; }
Public Property FeedbackSentSpecified As Boolean
    Get
    Set
public:
property bool FeedbackSentSpecified {
    bool get ();
    void set (bool value);
}


IntegratedMerchantCreditCardEnabled Property

IntegratedMerchantCreditCardEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► IntegratedMerchantCreditCardEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool IntegratedMerchantCreditCardEnabled { get; set; }
Public Property IntegratedMerchantCreditCardEnabled As Boolean
    Get
    Set
public:
property bool IntegratedMerchantCreditCardEnabled {
    bool get ();
    void set (bool value);
}


IntegratedMerchantCreditCardEnabledSpecified Property

IntegratedMerchantCreditCardEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► IntegratedMerchantCreditCardEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IntegratedMerchantCreditCardEnabledSpecified { get; set; }
Public Property IntegratedMerchantCreditCardEnabledSpecified As Boolean
    Get
    Set
public:
property bool IntegratedMerchantCreditCardEnabledSpecified {
    bool get ();
    void set (bool value);
}


LastEmailSentTime Property

LastEmailSentTime Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► LastEmailSentTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastEmailSentTime { get; set; }
Public Property LastEmailSentTime As DateTime
    Get
    Set
public:
property DateTime LastEmailSentTime {
    DateTime get ();
    void set (DateTime value);
}


LastEmailSentTimeSpecified Property

LastEmailSentTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► LastEmailSentTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastEmailSentTimeSpecified { get; set; }
Public Property LastEmailSentTimeSpecified As Boolean
    Get
    Set
public:
property bool LastEmailSentTimeSpecified {
    bool get ();
    void set (bool value);
}


PaidStatus Property

PaidStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► PaidStatus
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerPaidStatusCodeType PaidStatus { get; set; }
Public Property PaidStatus As SellingManagerPaidStatusCodeType
    Get
    Set
public:
property SellingManagerPaidStatusCodeType PaidStatus {
    SellingManagerPaidStatusCodeType get ();
    void set (SellingManagerPaidStatusCodeType value);
}


PaidStatusSpecified Property

PaidStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► PaidStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaidStatusSpecified { get; set; }
Public Property PaidStatusSpecified As Boolean
    Get
    Set
public:
property bool PaidStatusSpecified {
    bool get ();
    void set (bool value);
}


PaidTime Property

PaidTime Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► PaidTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PaidTime { get; set; }
Public Property PaidTime As DateTime
    Get
    Set
public:
property DateTime PaidTime {
    DateTime get ();
    void set (DateTime value);
}


PaidTimeSpecified Property

PaidTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► PaidTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaidTimeSpecified { get; set; }
Public Property PaidTimeSpecified As Boolean
    Get
    Set
public:
property bool PaidTimeSpecified {
    bool get ();
    void set (bool value);
}


PaymentHoldStatus Property

PaymentHoldStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► PaymentHoldStatus
Declaration Syntax
C# Visual Basic Visual C++
public PaymentHoldStatusCodeType PaymentHoldStatus { get; set; }
Public Property PaymentHoldStatus As PaymentHoldStatusCodeType
    Get
    Set
public:
property PaymentHoldStatusCodeType PaymentHoldStatus {
    PaymentHoldStatusCodeType get ();
    void set (PaymentHoldStatusCodeType value);
}


PaymentHoldStatusSpecified Property

PaymentHoldStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► PaymentHoldStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentHoldStatusSpecified { get; set; }
Public Property PaymentHoldStatusSpecified As Boolean
    Get
    Set
public:
property bool PaymentHoldStatusSpecified {
    bool get ();
    void set (bool value);
}


PaymentMethodUsed Property

PaymentMethodUsed Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► PaymentMethodUsed
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeType PaymentMethodUsed { get; set; }
Public Property PaymentMethodUsed As BuyerPaymentMethodCodeType
    Get
    Set
public:
property BuyerPaymentMethodCodeType PaymentMethodUsed {
    BuyerPaymentMethodCodeType get ();
    void set (BuyerPaymentMethodCodeType value);
}


PaymentMethodUsedSpecified Property

PaymentMethodUsedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► PaymentMethodUsedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentMethodUsedSpecified { get; set; }
Public Property PaymentMethodUsedSpecified As Boolean
    Get
    Set
public:
property bool PaymentMethodUsedSpecified {
    bool get ();
    void set (bool value);
}


PayPalTransactionID Property

PayPalTransactionID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► PayPalTransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string PayPalTransactionID { get; set; }
Public Property PayPalTransactionID As String
    Get
    Set
public:
property String^ PayPalTransactionID {
    String^ get ();
    void set (String^ value);
}


SellerInvoiceNumber Property

SellerInvoiceNumber Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► SellerInvoiceNumber
Declaration Syntax
C# Visual Basic Visual C++
public string SellerInvoiceNumber { get; set; }
Public Property SellerInvoiceNumber As String
    Get
    Set
public:
property String^ SellerInvoiceNumber {
    String^ get ();
    void set (String^ value);
}


SellerInvoiceTime Property

SellerInvoiceTime Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► SellerInvoiceTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime SellerInvoiceTime { get; set; }
Public Property SellerInvoiceTime As DateTime
    Get
    Set
public:
property DateTime SellerInvoiceTime {
    DateTime get ();
    void set (DateTime value);
}


SellerInvoiceTimeSpecified Property

SellerInvoiceTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► SellerInvoiceTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerInvoiceTimeSpecified { get; set; }
Public Property SellerInvoiceTimeSpecified As Boolean
    Get
    Set
public:
property bool SellerInvoiceTimeSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerOrderStatusType Constructor

SellingManagerOrderStatusType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► SellingManagerOrderStatusType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerOrderStatusType()
Public Sub New
public:
SellingManagerOrderStatusType()


ShippedStatus Property

ShippedStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► ShippedStatus
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerShippedStatusCodeType ShippedStatus { get; set; }
Public Property ShippedStatus As SellingManagerShippedStatusCodeType
    Get
    Set
public:
property SellingManagerShippedStatusCodeType ShippedStatus {
    SellingManagerShippedStatusCodeType get ();
    void set (SellingManagerShippedStatusCodeType value);
}


ShippedStatusSpecified Property

ShippedStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► ShippedStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippedStatusSpecified { get; set; }
Public Property ShippedStatusSpecified As Boolean
    Get
    Set
public:
property bool ShippedStatusSpecified {
    bool get ();
    void set (bool value);
}


ShippedTime Property

ShippedTime Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► ShippedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ShippedTime { get; set; }
Public Property ShippedTime As DateTime
    Get
    Set
public:
property DateTime ShippedTime {
    DateTime get ();
    void set (DateTime value);
}


ShippedTimeSpecified Property

ShippedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► ShippedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippedTimeSpecified { get; set; }
Public Property ShippedTimeSpecified As Boolean
    Get
    Set
public:
property bool ShippedTimeSpecified {
    bool get ();
    void set (bool value);
}


TotalEmailsSent Property

TotalEmailsSent Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► TotalEmailsSent
Declaration Syntax
C# Visual Basic Visual C++
public int TotalEmailsSent { get; set; }
Public Property TotalEmailsSent As Integer
    Get
    Set
public:
property int TotalEmailsSent {
    int get ();
    void set (int value);
}


TotalEmailsSentSpecified Property

TotalEmailsSentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerOrderStatusType ► TotalEmailsSentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalEmailsSentSpecified { get; set; }
Public Property TotalEmailsSentSpecified As Boolean
    Get
    Set
public:
property bool TotalEmailsSentSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerPaidStatusCodeType Enumeration

SellingManagerPaidStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerPaidStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerPaidStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerPaidStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerPaidStatusCodeType
Members
Member | Description
Paid |
PartiallyPaid |
Unpaid |
Pending |
Refunded |
CustomCode |
Remarks


SellingManagerPaisaPayPropertyTypeCodeType Enumeration

SellingManagerPaisaPayPropertyTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerPaisaPayPropertyTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerPaisaPayPropertyTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerPaisaPayPropertyTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerPaisaPayPropertyTypeCodeType
Members
Member | Description
PaisaPayAwaitingShipment |
PaisaPayTimeExtensionRequestDeclined |
PaisaPayPendingReceived |
PaisaPayRefundInitiated |
PaisaPayTimeExtensionRequested |
CustomCode |
Remarks


SellingManagerProductDetailsType Class

SellingManagerProductDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerProductDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerProductDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerProductDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerProductDetailsType()()()() |
 | Any |
 | CustomLabel |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FolderID |
 | FolderIDSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Note |
 | ProductID |
 | ProductIDSpecified |
 | ProductName |
 | QuantityAvailable |
 | QuantityAvailableSpecified |
 | RestockAlert |
 | RestockAlertSpecified |
 | RestockThreshold |
 | RestockThresholdSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UnitCost |
 | VendorInfo |
Remarks
Inheritance Hierarchy
Object
SellingManagerProductDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CustomLabel Property

CustomLabel Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► CustomLabel
Declaration Syntax
C# Visual Basic Visual C++
public string CustomLabel { get; set; }
Public Property CustomLabel As String
    Get
    Set
public:
property String^ CustomLabel {
    String^ get ();
    void set (String^ value);
}


FolderID Property

FolderID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► FolderID
Declaration Syntax
C# Visual Basic Visual C++
public long FolderID { get; set; }
Public Property FolderID As Long
    Get
    Set
public:
property long long FolderID {
    long long get ();
    void set (long long value);
}


FolderIDSpecified Property

FolderIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► FolderIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FolderIDSpecified { get; set; }
Public Property FolderIDSpecified As Boolean
    Get
    Set
public:
property bool FolderIDSpecified {
    bool get ();
    void set (bool value);
}


Note Property

Note Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► Note
Declaration Syntax
C# Visual Basic Visual C++
public string Note { get; set; }
Public Property Note As String
    Get
    Set
public:
property String^ Note {
    String^ get ();
    void set (String^ value);
}


ProductID Property

ProductID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► ProductID
Declaration Syntax
C# Visual Basic Visual C++
public long ProductID { get; set; }
Public Property ProductID As Long
    Get
    Set
public:
property long long ProductID {
    long long get ();
    void set (long long value);
}


ProductIDSpecified Property

ProductIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► ProductIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductIDSpecified { get; set; }
Public Property ProductIDSpecified As Boolean
    Get
    Set
public:
property bool ProductIDSpecified {
    bool get ();
    void set (bool value);
}


ProductName Property

ProductName Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► ProductName
Declaration Syntax
C# Visual Basic Visual C++
public string ProductName { get; set; }
Public Property ProductName As String
    Get
    Set
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}


QuantityAvailable Property

QuantityAvailable Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► QuantityAvailable
Declaration Syntax
C# Visual Basic Visual C++
public int QuantityAvailable { get; set; }
Public Property QuantityAvailable As Integer
    Get
    Set
public:
property int QuantityAvailable {
    int get ();
    void set (int value);
}


QuantityAvailableSpecified Property

QuantityAvailableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► QuantityAvailableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityAvailableSpecified { get; set; }
Public Property QuantityAvailableSpecified As Boolean
    Get
    Set
public:
property bool QuantityAvailableSpecified {
    bool get ();
    void set (bool value);
}


RestockAlert Property

RestockAlert Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► RestockAlert
Declaration Syntax
C# Visual Basic Visual C++
public bool RestockAlert { get; set; }
Public Property RestockAlert As Boolean
    Get
    Set
public:
property bool RestockAlert {
    bool get ();
    void set (bool value);
}


RestockAlertSpecified Property

RestockAlertSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► RestockAlertSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RestockAlertSpecified { get; set; }
Public Property RestockAlertSpecified As Boolean
    Get
    Set
public:
property bool RestockAlertSpecified {
    bool get ();
    void set (bool value);
}


RestockThreshold Property

RestockThreshold Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► RestockThreshold
Declaration Syntax
C# Visual Basic Visual C++
public int RestockThreshold { get; set; }
Public Property RestockThreshold As Integer
    Get
    Set
public:
property int RestockThreshold {
    int get ();
    void set (int value);
}


RestockThresholdSpecified Property

RestockThresholdSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► RestockThresholdSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RestockThresholdSpecified { get; set; }
Public Property RestockThresholdSpecified As Boolean
    Get
    Set
public:
property bool RestockThresholdSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerProductDetailsType Constructor

SellingManagerProductDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► SellingManagerProductDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType()
Public Sub New
public:
SellingManagerProductDetailsType()


UnitCost Property

UnitCost Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► UnitCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType UnitCost { get; set; }
Public Property UnitCost As AmountType
    Get
    Set
public:
property AmountType^ UnitCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


VendorInfo Property

VendorInfo Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductDetailsType ► VendorInfo
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerVendorDetailsType VendorInfo { get; set; }
Public Property VendorInfo As SellingManagerVendorDetailsType
    Get
    Set
public:
property SellingManagerVendorDetailsType^ VendorInfo {
    SellingManagerVendorDetailsType^ get ();
    void set (SellingManagerVendorDetailsType^ value);
}


SellingManagerProductInventoryStatusType Class

SellingManagerProductInventoryStatusType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerProductInventoryStatusType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerProductInventoryStatusType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerProductInventoryStatusType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerProductInventoryStatusType()()()() |
 | Any |
 | AverageSellingPrice |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | QuantityActive |
 | QuantityActiveSpecified |
 | QuantityScheduled |
 | QuantityScheduledSpecified |
 | QuantitySold |
 | QuantitySoldSpecified |
 | QuantityUnsold |
 | QuantityUnsoldSpecified |
 | SuccessPercent |
 | SuccessPercentSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingManagerProductInventoryStatusType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AverageSellingPrice Property

AverageSellingPrice Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► AverageSellingPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AverageSellingPrice { get; set; }
Public Property AverageSellingPrice As AmountType
    Get
    Set
public:
property AmountType^ AverageSellingPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


QuantityActive Property

QuantityActive Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► QuantityActive
Declaration Syntax
C# Visual Basic Visual C++
public int QuantityActive { get; set; }
Public Property QuantityActive As Integer
    Get
    Set
public:
property int QuantityActive {
    int get ();
    void set (int value);
}


QuantityActiveSpecified Property

QuantityActiveSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► QuantityActiveSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityActiveSpecified { get; set; }
Public Property QuantityActiveSpecified As Boolean
    Get
    Set
public:
property bool QuantityActiveSpecified {
    bool get ();
    void set (bool value);
}


QuantityScheduled Property

QuantityScheduled Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► QuantityScheduled
Declaration Syntax
C# Visual Basic Visual C++
public int QuantityScheduled { get; set; }
Public Property QuantityScheduled As Integer
    Get
    Set
public:
property int QuantityScheduled {
    int get ();
    void set (int value);
}


QuantityScheduledSpecified Property

QuantityScheduledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► QuantityScheduledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityScheduledSpecified { get; set; }
Public Property QuantityScheduledSpecified As Boolean
    Get
    Set
public:
property bool QuantityScheduledSpecified {
    bool get ();
    void set (bool value);
}


QuantitySold Property

QuantitySold Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► QuantitySold
Declaration Syntax
C# Visual Basic Visual C++
public int QuantitySold { get; set; }
Public Property QuantitySold As Integer
    Get
    Set
public:
property int QuantitySold {
    int get ();
    void set (int value);
}


QuantitySoldSpecified Property

QuantitySoldSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► QuantitySoldSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySoldSpecified { get; set; }
Public Property QuantitySoldSpecified As Boolean
    Get
    Set
public:
property bool QuantitySoldSpecified {
    bool get ();
    void set (bool value);
}


QuantityUnsold Property

QuantityUnsold Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► QuantityUnsold
Declaration Syntax
C# Visual Basic Visual C++
public int QuantityUnsold { get; set; }
Public Property QuantityUnsold As Integer
    Get
    Set
public:
property int QuantityUnsold {
    int get ();
    void set (int value);
}


QuantityUnsoldSpecified Property

QuantityUnsoldSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► QuantityUnsoldSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityUnsoldSpecified { get; set; }
Public Property QuantityUnsoldSpecified As Boolean
    Get
    Set
public:
property bool QuantityUnsoldSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerProductInventoryStatusType Constructor

SellingManagerProductInventoryStatusType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► SellingManagerProductInventoryStatusType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductInventoryStatusType()
Public Sub New
public:
SellingManagerProductInventoryStatusType()


SuccessPercent Property

SuccessPercent Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► SuccessPercent
Declaration Syntax
C# Visual Basic Visual C++
public float SuccessPercent { get; set; }
Public Property SuccessPercent As Single
    Get
    Set
public:
property float SuccessPercent {
    float get ();
    void set (float value);
}


SuccessPercentSpecified Property

SuccessPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductInventoryStatusType ► SuccessPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SuccessPercentSpecified { get; set; }
Public Property SuccessPercentSpecified As Boolean
    Get
    Set
public:
property bool SuccessPercentSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerProductSortCodeType Enumeration

SellingManagerProductSortCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductSortCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerProductSortCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerProductSortCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerProductSortCodeType
Members
Member | Description
ActiveQuantity |
AvailableToList |
AveragePrice |
AverageUnitCost |
CustomLabel |
ProductName |
LastSubmittedDate |
ScheduledQuantity |
SoldQuantity |
SuccessPercent |
UnsoldQuantity |
FolderName |
CustomCode |
Remarks


SellingManagerProductSpecificsType Class

SellingManagerProductSpecificsType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductSpecificsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerProductSpecificsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerProductSpecificsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerProductSpecificsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerProductSpecificsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemSpecifics |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PrimaryCategoryID |
 | ToString()()()() | (Inherited from Object.)
 | Variations |
Remarks
Inheritance Hierarchy
Object
SellingManagerProductSpecificsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductSpecificsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemSpecifics Property

ItemSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductSpecificsType ► ItemSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection ItemSpecifics { get; set; }
Public Property ItemSpecifics As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ ItemSpecifics {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


PrimaryCategoryID Property

PrimaryCategoryID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductSpecificsType ► PrimaryCategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string PrimaryCategoryID { get; set; }
Public Property PrimaryCategoryID As String
    Get
    Set
public:
property String^ PrimaryCategoryID {
    String^ get ();
    void set (String^ value);
}


SellingManagerProductSpecificsType Constructor

SellingManagerProductSpecificsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductSpecificsType ► SellingManagerProductSpecificsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductSpecificsType()
Public Sub New
public:
SellingManagerProductSpecificsType()


Variations Property

Variations Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductSpecificsType ► Variations
Declaration Syntax
C# Visual Basic Visual C++
public VariationsType Variations { get; set; }
Public Property Variations As VariationsType
    Get
    Set
public:
property VariationsType^ Variations {
    VariationsType^ get ();
    void set (VariationsType^ value);
}


SellingManagerProductType Class

SellingManagerProductType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerProductType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerProductType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerProductType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerProductType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SellingManagerProductDetails |
 | SellingManagerProductInventoryStatus |
 | SellingManagerProductSpecifics |
 | SellingManagerTemplateDetailsArray |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingManagerProductType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductType ► SellingManagerProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; set; }
Public Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


SellingManagerProductInventoryStatus Property

SellingManagerProductInventoryStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductType ► SellingManagerProductInventoryStatus
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductInventoryStatusType SellingManagerProductInventoryStatus { get; set; }
Public Property SellingManagerProductInventoryStatus As SellingManagerProductInventoryStatusType
    Get
    Set
public:
property SellingManagerProductInventoryStatusType^ SellingManagerProductInventoryStatus {
    SellingManagerProductInventoryStatusType^ get ();
    void set (SellingManagerProductInventoryStatusType^ value);
}


SellingManagerProductSpecifics Property

SellingManagerProductSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductType ► SellingManagerProductSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductSpecificsType SellingManagerProductSpecifics { get; set; }
Public Property SellingManagerProductSpecifics As SellingManagerProductSpecificsType
    Get
    Set
public:
property SellingManagerProductSpecificsType^ SellingManagerProductSpecifics {
    SellingManagerProductSpecificsType^ get ();
    void set (SellingManagerProductSpecificsType^ value);
}


SellingManagerProductType Constructor

SellingManagerProductType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductType ► SellingManagerProductType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductType()
Public Sub New
public:
SellingManagerProductType()


SellingManagerTemplateDetailsArray Property

SellingManagerTemplateDetailsArray Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductType ► SellingManagerTemplateDetailsArray
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerTemplateDetailsTypeCollection SellingManagerTemplateDetailsArray { get; set; }
Public Property SellingManagerTemplateDetailsArray As SellingManagerTemplateDetailsTypeCollection
    Get
    Set
public:
property SellingManagerTemplateDetailsTypeCollection^ SellingManagerTemplateDetailsArray {
    SellingManagerTemplateDetailsTypeCollection^ get ();
    void set (SellingManagerTemplateDetailsTypeCollection^ value);
}


SellingManagerProductTypeCollection Class

SellingManagerProductTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellingManagerProductTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellingManagerProductTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellingManagerProductTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerProductTypeCollection()()()() |
 | SellingManagerProductTypeCollection(array<SellingManagerProductType>[]()[][]) |
 | SellingManagerProductTypeCollection(SellingManagerProductTypeCollection) |
 | Add(SellingManagerProductType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellingManagerProductType>[]()[][]) |
 | AddRange(SellingManagerProductTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellingManagerProductType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellingManagerProductType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellingManagerProductType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellingManagerProductType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellingManagerProductType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellingManagerProductTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► Add(SellingManagerProductType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellingManagerProductType item
)
Public Function Add ( _
    item As SellingManagerProductType _
) As Integer
public:
int Add(
    SellingManagerProductType^ item
)
Parameters
item (SellingManagerProductType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellingManagerProductType>[]()[][]) |
 | AddRange(SellingManagerProductTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► AddRange(array<SellingManagerProductType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerProductType[] items
)
Public Sub AddRange ( _
    items As SellingManagerProductType() _
)
public:
void AddRange(
    array<SellingManagerProductType^>^ items
)
Parameters
items (array< SellingManagerProductType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► AddRange(SellingManagerProductTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerProductTypeCollection items
)
Public Sub AddRange ( _
    items As SellingManagerProductTypeCollection _
)
public:
void AddRange(
    SellingManagerProductTypeCollection^ items
)
Parameters
items (SellingManagerProductTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► Contains(SellingManagerProductType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellingManagerProductType item
)
Public Function Contains ( _
    item As SellingManagerProductType _
) As Boolean
public:
bool Contains(
    SellingManagerProductType^ item
)
Parameters
item (SellingManagerProductType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► CopyTo(array<SellingManagerProductType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellingManagerProductType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellingManagerProductType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellingManagerProductType^>^ items,
    int index
)
Parameters
items (array< SellingManagerProductType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► IndexOf(SellingManagerProductType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellingManagerProductType item
)
Public Function IndexOf ( _
    item As SellingManagerProductType _
) As Integer
public:
int IndexOf(
    SellingManagerProductType^ item
)
Parameters
item (SellingManagerProductType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► Insert(Int32, SellingManagerProductType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellingManagerProductType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellingManagerProductType _
)
public:
void Insert(
    int index,
    SellingManagerProductType^ item
)
Parameters
index (Int32)
item (SellingManagerProductType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellingManagerProductType
    Get
    Set
public:
property SellingManagerProductType^ default[int index] {
    SellingManagerProductType^ get (int index);
    void set (int index, SellingManagerProductType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellingManagerProductType
public:
SellingManagerProductType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► Remove(SellingManagerProductType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellingManagerProductType item
)
Public Sub Remove ( _
    item As SellingManagerProductType _
)
public:
void Remove(
    SellingManagerProductType^ item
)
Parameters
item (SellingManagerProductType)


SellingManagerProductTypeCollection Constructor

SellingManagerProductTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► SellingManagerProductTypeCollection()()()()
Members
Icon | Member | Description
 | SellingManagerProductTypeCollection()()()() |
 | SellingManagerProductTypeCollection(array<SellingManagerProductType>[]()[][]) |
 | SellingManagerProductTypeCollection(SellingManagerProductTypeCollection) |


SellingManagerProductTypeCollection Constructor

SellingManagerProductTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► SellingManagerProductTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductTypeCollection()
Public Sub New
public:
SellingManagerProductTypeCollection()


SellingManagerProductTypeCollection Constructor (items)

SellingManagerProductTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► SellingManagerProductTypeCollection(array<SellingManagerProductType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductTypeCollection(
    SellingManagerProductType[] items
)
Public Sub New ( _
    items As SellingManagerProductType() _
)
public:
SellingManagerProductTypeCollection(
    array<SellingManagerProductType^>^ items
)
Parameters
items (array< SellingManagerProductType >[]()[][])


SellingManagerProductTypeCollection Constructor (items)

SellingManagerProductTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► SellingManagerProductTypeCollection(SellingManagerProductTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductTypeCollection(
    SellingManagerProductTypeCollection items
)
Public Sub New ( _
    items As SellingManagerProductTypeCollection _
)
public:
SellingManagerProductTypeCollection(
    SellingManagerProductTypeCollection^ items
)
Parameters
items (SellingManagerProductTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductType[] ToArray()
Public Function ToArray As SellingManagerProductType()
public:
array<SellingManagerProductType^>^ ToArray()
Return Value


SellingManagerSearchType Class

SellingManagerSearchType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSearchType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerSearchType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerSearchType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerSearchType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerSearchType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SearchType |
 | SearchTypeSpecified |
 | SearchValue |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingManagerSearchType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSearchType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SearchType Property

SearchType Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSearchType ► SearchType
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSearchTypeCodeType SearchType { get; set; }
Public Property SearchType As SellingManagerSearchTypeCodeType
    Get
    Set
public:
property SellingManagerSearchTypeCodeType SearchType {
    SellingManagerSearchTypeCodeType get ();
    void set (SellingManagerSearchTypeCodeType value);
}


SearchTypeSpecified Property

SearchTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSearchType ► SearchTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SearchTypeSpecified { get; set; }
Public Property SearchTypeSpecified As Boolean
    Get
    Set
public:
property bool SearchTypeSpecified {
    bool get ();
    void set (bool value);
}


SearchValue Property

SearchValue Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSearchType ► SearchValue
Declaration Syntax
C# Visual Basic Visual C++
public string SearchValue { get; set; }
Public Property SearchValue As String
    Get
    Set
public:
property String^ SearchValue {
    String^ get ();
    void set (String^ value);
}


SellingManagerSearchType Constructor

SellingManagerSearchType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSearchType ► SellingManagerSearchType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSearchType()
Public Sub New
public:
SellingManagerSearchType()


SellingManagerSearchTypeCodeType Enumeration

SellingManagerSearchTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSearchTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerSearchTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerSearchTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerSearchTypeCodeType
Members
Member | Description
BuyerUserID |
BuyerEmail |
BuyerFullName |
ItemID |
Title |
ProductID |
ProductName |
CustomLabel |
SaleRecordID |
CustomCode |
Remarks


SellingManagerShippedStatusCodeType Enumeration

SellingManagerShippedStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerShippedStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerShippedStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerShippedStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerShippedStatusCodeType
Members
Member | Description
Shipped |
Unshipped |
CustomCode |
Remarks


SellingManagerSoldListingsPropertyTypeCodeType Enumeration

SellingManagerSoldListingsPropertyTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerSoldListingsPropertyTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerSoldListingsPropertyTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerSoldListingsPropertyTypeCodeType
Members
Member | Description
NotPaidNotShipped |
PaidNotShipped |
PrintShippingLabel |
PaidShipped |
PaidNoFeedback |
PaymentReminderSendError |
PaymentReceivedNotificationSendError |
RequestForShippingAddressSendError |
ShippingNotificationSendError |
PersonalizedEmailsSendError |
WinningBuyerNotificationSendError |
FeeCreditRequest |
PayPalPayment |
FeedbackMessageNotSent |
FeedbackReminderSendError |
NotShipped |
UnpaidItemReminder |
EscrowCancelled |
EscrowCompleted |
EscrowInitiated |
EscrowManageRefund |
EscrowReleasePayment |
EscrowShipToBuyer |
EscrowSoldAll |
ShippedAndAwaitingFeedback |
InternationalSale |
eBayGivingWorksDonationOwed |
PaymentOverDue |
PadiWithPaisaPayEscrow |
CustomEmailTemplate1SendError |
CustomEmailTemplate2SendError |
CustomEmailTemplate3SendError |
CustomEmailTemplate4SendError |
CustomEmailTemplate5SendError |
CustomEmailTemplate6SendError |
CustomEmailTemplate7SendError |
CustomEmailTemplate8SendError |
CustomEmailTemplate9SendError |
CustomEmailTemplate10SendError |
CustomEmailTemplate11SendError |
CustomEmailTemplate12SendError |
CustomEmailTemplate13SendError |
CustomEmailTemplate14SendError |
CustomEmailTemplate15SendError |
CustomEmailTemplate16SendError |
CustomEmailTemplate17SendError |
CustomEmailTemplate18SendError |
CustomEmailTemplate19SendError |
CustomEmailTemplate20SendError |
ResponseRequiredForReturnCase |
CustomCode |
Remarks


SellingManagerSoldListingsPropertyTypeCodeTypeCollection Class

SellingManagerSoldListingsPropertyTypeCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellingManagerSoldListingsPropertyTypeCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellingManagerSoldListingsPropertyTypeCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellingManagerSoldListingsPropertyTypeCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerSoldListingsPropertyTypeCodeTypeCollection()()()() |
 | SellingManagerSoldListingsPropertyTypeCodeTypeCollection(array<SellingManagerSoldListingsPropertyTypeCodeType>[]()[][]) |
 | SellingManagerSoldListingsPropertyTypeCodeTypeCollection(SellingManagerSoldListingsPropertyTypeCodeTypeCollection) |
 | Add(SellingManagerSoldListingsPropertyTypeCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellingManagerSoldListingsPropertyTypeCodeType>[]()[][]) |
 | AddRange(SellingManagerSoldListingsPropertyTypeCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellingManagerSoldListingsPropertyTypeCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellingManagerSoldListingsPropertyTypeCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellingManagerSoldListingsPropertyTypeCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellingManagerSoldListingsPropertyTypeCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellingManagerSoldListingsPropertyTypeCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellingManagerSoldListingsPropertyTypeCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► Add(SellingManagerSoldListingsPropertyTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellingManagerSoldListingsPropertyTypeCodeType item
)
Public Function Add ( _
    item As SellingManagerSoldListingsPropertyTypeCodeType _
) As Integer
public:
int Add(
    SellingManagerSoldListingsPropertyTypeCodeType item
)
Parameters
item (SellingManagerSoldListingsPropertyTypeCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellingManagerSoldListingsPropertyTypeCodeType>[]()[][]) |
 | AddRange(SellingManagerSoldListingsPropertyTypeCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► AddRange(array<SellingManagerSoldListingsPropertyTypeCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerSoldListingsPropertyTypeCodeType[] items
)
Public Sub AddRange ( _
    items As SellingManagerSoldListingsPropertyTypeCodeType() _
)
public:
void AddRange(
    array<SellingManagerSoldListingsPropertyTypeCodeType>^ items
)
Parameters
items (array< SellingManagerSoldListingsPropertyTypeCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► AddRange(SellingManagerSoldListingsPropertyTypeCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerSoldListingsPropertyTypeCodeTypeCollection items
)
Public Sub AddRange ( _
    items As SellingManagerSoldListingsPropertyTypeCodeTypeCollection _
)
public:
void AddRange(
    SellingManagerSoldListingsPropertyTypeCodeTypeCollection^ items
)
Parameters
items (SellingManagerSoldListingsPropertyTypeCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► Contains(SellingManagerSoldListingsPropertyTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellingManagerSoldListingsPropertyTypeCodeType item
)
Public Function Contains ( _
    item As SellingManagerSoldListingsPropertyTypeCodeType _
) As Boolean
public:
bool Contains(
    SellingManagerSoldListingsPropertyTypeCodeType item
)
Parameters
item (SellingManagerSoldListingsPropertyTypeCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► CopyTo(array<SellingManagerSoldListingsPropertyTypeCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellingManagerSoldListingsPropertyTypeCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellingManagerSoldListingsPropertyTypeCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellingManagerSoldListingsPropertyTypeCodeType>^ items,
    int index
)
Parameters
items (array< SellingManagerSoldListingsPropertyTypeCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► IndexOf(SellingManagerSoldListingsPropertyTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellingManagerSoldListingsPropertyTypeCodeType item
)
Public Function IndexOf ( _
    item As SellingManagerSoldListingsPropertyTypeCodeType _
) As Integer
public:
int IndexOf(
    SellingManagerSoldListingsPropertyTypeCodeType item
)
Parameters
item (SellingManagerSoldListingsPropertyTypeCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► Insert(Int32, SellingManagerSoldListingsPropertyTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellingManagerSoldListingsPropertyTypeCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellingManagerSoldListingsPropertyTypeCodeType _
)
public:
void Insert(
    int index,
    SellingManagerSoldListingsPropertyTypeCodeType item
)
Parameters
index (Int32)
item (SellingManagerSoldListingsPropertyTypeCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldListingsPropertyTypeCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellingManagerSoldListingsPropertyTypeCodeType
    Get
    Set
public:
property SellingManagerSoldListingsPropertyTypeCodeType default[int index] {
    SellingManagerSoldListingsPropertyTypeCodeType get (int index);
    void set (int index, SellingManagerSoldListingsPropertyTypeCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldListingsPropertyTypeCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellingManagerSoldListingsPropertyTypeCodeType
public:
SellingManagerSoldListingsPropertyTypeCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► Remove(SellingManagerSoldListingsPropertyTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellingManagerSoldListingsPropertyTypeCodeType item
)
Public Sub Remove ( _
    item As SellingManagerSoldListingsPropertyTypeCodeType _
)
public:
void Remove(
    SellingManagerSoldListingsPropertyTypeCodeType item
)
Parameters
item (SellingManagerSoldListingsPropertyTypeCodeType)


SellingManagerSoldListingsPropertyTypeCodeTypeCollection Constructor

SellingManagerSoldListingsPropertyTypeCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection()()()()
Members
Icon | Member | Description
 | SellingManagerSoldListingsPropertyTypeCodeTypeCollection()()()() |
 | SellingManagerSoldListingsPropertyTypeCodeTypeCollection(array<SellingManagerSoldListingsPropertyTypeCodeType>[]()[][]) |
 | SellingManagerSoldListingsPropertyTypeCodeTypeCollection(SellingManagerSoldListingsPropertyTypeCodeTypeCollection) |


SellingManagerSoldListingsPropertyTypeCodeTypeCollection Constructor

SellingManagerSoldListingsPropertyTypeCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldListingsPropertyTypeCodeTypeCollection()
Public Sub New
public:
SellingManagerSoldListingsPropertyTypeCodeTypeCollection()


SellingManagerSoldListingsPropertyTypeCodeTypeCollection Constructor (items)

SellingManagerSoldListingsPropertyTypeCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection(array<SellingManagerSoldListingsPropertyTypeCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldListingsPropertyTypeCodeTypeCollection(
    SellingManagerSoldListingsPropertyTypeCodeType[] items
)
Public Sub New ( _
    items As SellingManagerSoldListingsPropertyTypeCodeType() _
)
public:
SellingManagerSoldListingsPropertyTypeCodeTypeCollection(
    array<SellingManagerSoldListingsPropertyTypeCodeType>^ items
)
Parameters
items (array< SellingManagerSoldListingsPropertyTypeCodeType >[]()[][])


SellingManagerSoldListingsPropertyTypeCodeTypeCollection Constructor (items)

SellingManagerSoldListingsPropertyTypeCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection(SellingManagerSoldListingsPropertyTypeCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldListingsPropertyTypeCodeTypeCollection(
    SellingManagerSoldListingsPropertyTypeCodeTypeCollection items
)
Public Sub New ( _
    items As SellingManagerSoldListingsPropertyTypeCodeTypeCollection _
)
public:
SellingManagerSoldListingsPropertyTypeCodeTypeCollection(
    SellingManagerSoldListingsPropertyTypeCodeTypeCollection^ items
)
Parameters
items (SellingManagerSoldListingsPropertyTypeCodeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldListingsPropertyTypeCodeType[] ToArray()
Public Function ToArray As SellingManagerSoldListingsPropertyTypeCodeType()
public:
array<SellingManagerSoldListingsPropertyTypeCodeType>^ ToArray()
Return Value


SellingManagerSoldListingsSortTypeCodeType Enumeration

SellingManagerSoldListingsSortTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsSortTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SellingManagerSoldListingsSortTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SellingManagerSoldListingsSortTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SellingManagerSoldListingsSortTypeCodeType
Members
Member | Description
SalesRecordID |
BuyerEmail |
SaleFormat |
CustomLabel |
TotalPrice |
SaleDate |
PaidDate |
EmailsSent |
CheckoutState |
PaidState |
ShippedState |
FeedbackLeft |
FeedbackReceived |
ShippedDate |
BuyerPostalCode |
DaysSinceSale |
StartPrice |
ReservePrice |
SoldOn |
ShippingCost |
ListedOn |
CustomCode |
Remarks


SellingManagerSoldOrderType Class

SellingManagerSoldOrderType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerSoldOrderType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerSoldOrderType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerSoldOrderType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerSoldOrderType()()()() |
 | ActualShippingCost |
 | AdjustmentAmount |
 | Any |
 | BuyerEmail |
 | BuyerID |
 | CashOnDeliveryCost |
 | CreationTime |
 | CreationTimeSpecified |
 | DaysSinceSale |
 | DaysSinceSaleSpecified |
 | EmailsSent |
 | EmailsSentSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemCost |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NetInsuranceFee |
 | NetShippingFee |
 | NetTotalAmount |
 | NotesFromBuyer |
 | NotesToBuyer |
 | NotesToSeller |
 | OrderStatus |
 | RefundAmount |
 | RefundStatus |
 | SalePrice |
 | SaleRecordID |
 | SaleRecordIDSpecified |
 | SellingManagerSoldTransaction |
 | ShippingAddress |
 | ShippingDetails |
 | ToString()()()() | (Inherited from Object.)
 | TotalAmount |
 | TotalQuantity |
 | TotalQuantitySpecified |
 | UnpaidItemStatus |
 | UnpaidItemStatusSpecified |
 | VATInsuranceFee |
 | VATRate |
 | VATShippingFee |
 | VATTotalAmount |
Remarks
Inheritance Hierarchy
Object
SellingManagerSoldOrderType


ActualShippingCost Property

ActualShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► ActualShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ActualShippingCost { get; set; }
Public Property ActualShippingCost As AmountType
    Get
    Set
public:
property AmountType^ ActualShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


AdjustmentAmount Property

AdjustmentAmount Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► AdjustmentAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AdjustmentAmount { get; set; }
Public Property AdjustmentAmount As AmountType
    Get
    Set
public:
property AmountType^ AdjustmentAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyerEmail Property

BuyerEmail Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► BuyerEmail
Declaration Syntax
C# Visual Basic Visual C++
public string BuyerEmail { get; set; }
Public Property BuyerEmail As String
    Get
    Set
public:
property String^ BuyerEmail {
    String^ get ();
    void set (String^ value);
}


BuyerID Property

BuyerID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► BuyerID
Declaration Syntax
C# Visual Basic Visual C++
public string BuyerID { get; set; }
Public Property BuyerID As String
    Get
    Set
public:
property String^ BuyerID {
    String^ get ();
    void set (String^ value);
}


CashOnDeliveryCost Property

CashOnDeliveryCost Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► CashOnDeliveryCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CashOnDeliveryCost { get; set; }
Public Property CashOnDeliveryCost As AmountType
    Get
    Set
public:
property AmountType^ CashOnDeliveryCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


CreationTime Property

CreationTime Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► CreationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreationTime { get; set; }
Public Property CreationTime As DateTime
    Get
    Set
public:
property DateTime CreationTime {
    DateTime get ();
    void set (DateTime value);
}


CreationTimeSpecified Property

CreationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► CreationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreationTimeSpecified { get; set; }
Public Property CreationTimeSpecified As Boolean
    Get
    Set
public:
property bool CreationTimeSpecified {
    bool get ();
    void set (bool value);
}


DaysSinceSale Property

DaysSinceSale Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► DaysSinceSale
Declaration Syntax
C# Visual Basic Visual C++
public int DaysSinceSale { get; set; }
Public Property DaysSinceSale As Integer
    Get
    Set
public:
property int DaysSinceSale {
    int get ();
    void set (int value);
}


DaysSinceSaleSpecified Property

DaysSinceSaleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► DaysSinceSaleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DaysSinceSaleSpecified { get; set; }
Public Property DaysSinceSaleSpecified As Boolean
    Get
    Set
public:
property bool DaysSinceSaleSpecified {
    bool get ();
    void set (bool value);
}


EmailsSent Property

EmailsSent Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► EmailsSent
Declaration Syntax
C# Visual Basic Visual C++
public int EmailsSent { get; set; }
Public Property EmailsSent As Integer
    Get
    Set
public:
property int EmailsSent {
    int get ();
    void set (int value);
}


EmailsSentSpecified Property

EmailsSentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► EmailsSentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailsSentSpecified { get; set; }
Public Property EmailsSentSpecified As Boolean
    Get
    Set
public:
property bool EmailsSentSpecified {
    bool get ();
    void set (bool value);
}


ItemCost Property

ItemCost Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► ItemCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ItemCost { get; set; }
Public Property ItemCost As AmountType
    Get
    Set
public:
property AmountType^ ItemCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


NetInsuranceFee Property

NetInsuranceFee Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► NetInsuranceFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType NetInsuranceFee { get; set; }
Public Property NetInsuranceFee As AmountType
    Get
    Set
public:
property AmountType^ NetInsuranceFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


NetShippingFee Property

NetShippingFee Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► NetShippingFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType NetShippingFee { get; set; }
Public Property NetShippingFee As AmountType
    Get
    Set
public:
property AmountType^ NetShippingFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


NetTotalAmount Property

NetTotalAmount Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► NetTotalAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType NetTotalAmount { get; set; }
Public Property NetTotalAmount As AmountType
    Get
    Set
public:
property AmountType^ NetTotalAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


NotesFromBuyer Property

NotesFromBuyer Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► NotesFromBuyer
Declaration Syntax
C# Visual Basic Visual C++
public string NotesFromBuyer { get; set; }
Public Property NotesFromBuyer As String
    Get
    Set
public:
property String^ NotesFromBuyer {
    String^ get ();
    void set (String^ value);
}


NotesToBuyer Property

NotesToBuyer Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► NotesToBuyer
Declaration Syntax
C# Visual Basic Visual C++
public string NotesToBuyer { get; set; }
Public Property NotesToBuyer As String
    Get
    Set
public:
property String^ NotesToBuyer {
    String^ get ();
    void set (String^ value);
}


NotesToSeller Property

NotesToSeller Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► NotesToSeller
Declaration Syntax
C# Visual Basic Visual C++
public string NotesToSeller { get; set; }
Public Property NotesToSeller As String
    Get
    Set
public:
property String^ NotesToSeller {
    String^ get ();
    void set (String^ value);
}


OrderStatus Property

OrderStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► OrderStatus
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerOrderStatusType OrderStatus { get; set; }
Public Property OrderStatus As SellingManagerOrderStatusType
    Get
    Set
public:
property SellingManagerOrderStatusType^ OrderStatus {
    SellingManagerOrderStatusType^ get ();
    void set (SellingManagerOrderStatusType^ value);
}


RefundAmount Property

RefundAmount Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► RefundAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType RefundAmount { get; set; }
Public Property RefundAmount As AmountType
    Get
    Set
public:
property AmountType^ RefundAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


RefundStatus Property

RefundStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► RefundStatus
Declaration Syntax
C# Visual Basic Visual C++
public string RefundStatus { get; set; }
Public Property RefundStatus As String
    Get
    Set
public:
property String^ RefundStatus {
    String^ get ();
    void set (String^ value);
}


SalePrice Property

SalePrice Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► SalePrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType SalePrice { get; set; }
Public Property SalePrice As AmountType
    Get
    Set
public:
property AmountType^ SalePrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


SaleRecordID Property

SaleRecordID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► SaleRecordID
Declaration Syntax
C# Visual Basic Visual C++
public long SaleRecordID { get; set; }
Public Property SaleRecordID As Long
    Get
    Set
public:
property long long SaleRecordID {
    long long get ();
    void set (long long value);
}


SaleRecordIDSpecified Property

SaleRecordIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► SaleRecordIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SaleRecordIDSpecified { get; set; }
Public Property SaleRecordIDSpecified As Boolean
    Get
    Set
public:
property bool SaleRecordIDSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerSoldOrderType Constructor

SellingManagerSoldOrderType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► SellingManagerSoldOrderType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderType()
Public Sub New
public:
SellingManagerSoldOrderType()


SellingManagerSoldTransaction Property

SellingManagerSoldTransaction Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► SellingManagerSoldTransaction
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldTransactionTypeCollection SellingManagerSoldTransaction { get; set; }
Public Property SellingManagerSoldTransaction As SellingManagerSoldTransactionTypeCollection
    Get
    Set
public:
property SellingManagerSoldTransactionTypeCollection^ SellingManagerSoldTransaction {
    SellingManagerSoldTransactionTypeCollection^ get ();
    void set (SellingManagerSoldTransactionTypeCollection^ value);
}


ShippingAddress Property

ShippingAddress Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► ShippingAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType ShippingAddress { get; set; }
Public Property ShippingAddress As AddressType
    Get
    Set
public:
property AddressType^ ShippingAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


ShippingDetails Property

ShippingDetails Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► ShippingDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShippingDetailsType ShippingDetails { get; set; }
Public Property ShippingDetails As ShippingDetailsType
    Get
    Set
public:
property ShippingDetailsType^ ShippingDetails {
    ShippingDetailsType^ get ();
    void set (ShippingDetailsType^ value);
}


TotalAmount Property

TotalAmount Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► TotalAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalAmount { get; set; }
Public Property TotalAmount As AmountType
    Get
    Set
public:
property AmountType^ TotalAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


TotalQuantity Property

TotalQuantity Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► TotalQuantity
Declaration Syntax
C# Visual Basic Visual C++
public int TotalQuantity { get; set; }
Public Property TotalQuantity As Integer
    Get
    Set
public:
property int TotalQuantity {
    int get ();
    void set (int value);
}


TotalQuantitySpecified Property

TotalQuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► TotalQuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalQuantitySpecified { get; set; }
Public Property TotalQuantitySpecified As Boolean
    Get
    Set
public:
property bool TotalQuantitySpecified {
    bool get ();
    void set (bool value);
}


UnpaidItemStatus Property

UnpaidItemStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► UnpaidItemStatus
Declaration Syntax
C# Visual Basic Visual C++
public UnpaidItemStatusTypeCodeType UnpaidItemStatus { get; set; }
Public Property UnpaidItemStatus As UnpaidItemStatusTypeCodeType
    Get
    Set
public:
property UnpaidItemStatusTypeCodeType UnpaidItemStatus {
    UnpaidItemStatusTypeCodeType get ();
    void set (UnpaidItemStatusTypeCodeType value);
}


UnpaidItemStatusSpecified Property

UnpaidItemStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► UnpaidItemStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UnpaidItemStatusSpecified { get; set; }
Public Property UnpaidItemStatusSpecified As Boolean
    Get
    Set
public:
property bool UnpaidItemStatusSpecified {
    bool get ();
    void set (bool value);
}


VATInsuranceFee Property

VATInsuranceFee Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► VATInsuranceFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType VATInsuranceFee { get; set; }
Public Property VATInsuranceFee As AmountType
    Get
    Set
public:
property AmountType^ VATInsuranceFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


VATRate Property

VATRate Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► VATRate
Declaration Syntax
C# Visual Basic Visual C++
public VATRateTypeCollection VATRate { get; set; }
Public Property VATRate As VATRateTypeCollection
    Get
    Set
public:
property VATRateTypeCollection^ VATRate {
    VATRateTypeCollection^ get ();
    void set (VATRateTypeCollection^ value);
}


VATShippingFee Property

VATShippingFee Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► VATShippingFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType VATShippingFee { get; set; }
Public Property VATShippingFee As AmountType
    Get
    Set
public:
property AmountType^ VATShippingFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


VATTotalAmount Property

VATTotalAmount Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderType ► VATTotalAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType VATTotalAmount { get; set; }
Public Property VATTotalAmount As AmountType
    Get
    Set
public:
property AmountType^ VATTotalAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


SellingManagerSoldOrderTypeCollection Class

SellingManagerSoldOrderTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellingManagerSoldOrderTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellingManagerSoldOrderTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellingManagerSoldOrderTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerSoldOrderTypeCollection()()()() |
 | SellingManagerSoldOrderTypeCollection(array<SellingManagerSoldOrderType>[]()[][]) |
 | SellingManagerSoldOrderTypeCollection(SellingManagerSoldOrderTypeCollection) |
 | Add(SellingManagerSoldOrderType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellingManagerSoldOrderType>[]()[][]) |
 | AddRange(SellingManagerSoldOrderTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellingManagerSoldOrderType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellingManagerSoldOrderType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellingManagerSoldOrderType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellingManagerSoldOrderType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellingManagerSoldOrderType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellingManagerSoldOrderTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► Add(SellingManagerSoldOrderType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellingManagerSoldOrderType item
)
Public Function Add ( _
    item As SellingManagerSoldOrderType _
) As Integer
public:
int Add(
    SellingManagerSoldOrderType^ item
)
Parameters
item (SellingManagerSoldOrderType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellingManagerSoldOrderType>[]()[][]) |
 | AddRange(SellingManagerSoldOrderTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► AddRange(array<SellingManagerSoldOrderType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerSoldOrderType[] items
)
Public Sub AddRange ( _
    items As SellingManagerSoldOrderType() _
)
public:
void AddRange(
    array<SellingManagerSoldOrderType^>^ items
)
Parameters
items (array< SellingManagerSoldOrderType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► AddRange(SellingManagerSoldOrderTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerSoldOrderTypeCollection items
)
Public Sub AddRange ( _
    items As SellingManagerSoldOrderTypeCollection _
)
public:
void AddRange(
    SellingManagerSoldOrderTypeCollection^ items
)
Parameters
items (SellingManagerSoldOrderTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► Contains(SellingManagerSoldOrderType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellingManagerSoldOrderType item
)
Public Function Contains ( _
    item As SellingManagerSoldOrderType _
) As Boolean
public:
bool Contains(
    SellingManagerSoldOrderType^ item
)
Parameters
item (SellingManagerSoldOrderType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► CopyTo(array<SellingManagerSoldOrderType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellingManagerSoldOrderType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellingManagerSoldOrderType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellingManagerSoldOrderType^>^ items,
    int index
)
Parameters
items (array< SellingManagerSoldOrderType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► IndexOf(SellingManagerSoldOrderType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellingManagerSoldOrderType item
)
Public Function IndexOf ( _
    item As SellingManagerSoldOrderType _
) As Integer
public:
int IndexOf(
    SellingManagerSoldOrderType^ item
)
Parameters
item (SellingManagerSoldOrderType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► Insert(Int32, SellingManagerSoldOrderType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellingManagerSoldOrderType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellingManagerSoldOrderType _
)
public:
void Insert(
    int index,
    SellingManagerSoldOrderType^ item
)
Parameters
index (Int32)
item (SellingManagerSoldOrderType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellingManagerSoldOrderType
    Get
    Set
public:
property SellingManagerSoldOrderType^ default[int index] {
    SellingManagerSoldOrderType^ get (int index);
    void set (int index, SellingManagerSoldOrderType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellingManagerSoldOrderType
public:
SellingManagerSoldOrderType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► Remove(SellingManagerSoldOrderType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellingManagerSoldOrderType item
)
Public Sub Remove ( _
    item As SellingManagerSoldOrderType _
)
public:
void Remove(
    SellingManagerSoldOrderType^ item
)
Parameters
item (SellingManagerSoldOrderType)


SellingManagerSoldOrderTypeCollection Constructor

SellingManagerSoldOrderTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► SellingManagerSoldOrderTypeCollection()()()()
Members
Icon | Member | Description
 | SellingManagerSoldOrderTypeCollection()()()() |
 | SellingManagerSoldOrderTypeCollection(array<SellingManagerSoldOrderType>[]()[][]) |
 | SellingManagerSoldOrderTypeCollection(SellingManagerSoldOrderTypeCollection) |


SellingManagerSoldOrderTypeCollection Constructor

SellingManagerSoldOrderTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► SellingManagerSoldOrderTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderTypeCollection()
Public Sub New
public:
SellingManagerSoldOrderTypeCollection()


SellingManagerSoldOrderTypeCollection Constructor (items)

SellingManagerSoldOrderTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► SellingManagerSoldOrderTypeCollection(array<SellingManagerSoldOrderType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderTypeCollection(
    SellingManagerSoldOrderType[] items
)
Public Sub New ( _
    items As SellingManagerSoldOrderType() _
)
public:
SellingManagerSoldOrderTypeCollection(
    array<SellingManagerSoldOrderType^>^ items
)
Parameters
items (array< SellingManagerSoldOrderType >[]()[][])


SellingManagerSoldOrderTypeCollection Constructor (items)

SellingManagerSoldOrderTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► SellingManagerSoldOrderTypeCollection(SellingManagerSoldOrderTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderTypeCollection(
    SellingManagerSoldOrderTypeCollection items
)
Public Sub New ( _
    items As SellingManagerSoldOrderTypeCollection _
)
public:
SellingManagerSoldOrderTypeCollection(
    SellingManagerSoldOrderTypeCollection^ items
)
Parameters
items (SellingManagerSoldOrderTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldOrderType[] ToArray()
Public Function ToArray As SellingManagerSoldOrderType()
public:
array<SellingManagerSoldOrderType^>^ ToArray()
Return Value


SellingManagerSoldTransactionType Class

SellingManagerSoldTransactionType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerSoldTransactionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerSoldTransactionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerSoldTransactionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerSoldTransactionType()()()() |
 | Any |
 | CharityListing |
 | CharityListingSpecified |
 | CustomLabel |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvoiceNumber |
 | ItemID |
 | ItemPrice |
 | ItemTitle |
 | ListedOn |
 | ListingType |
 | ListingTypeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderLineItemID |
 | QuantitySold |
 | QuantitySoldSpecified |
 | Relisted |
 | RelistedSpecified |
 | ReservePrice |
 | SaleRecordID |
 | SaleRecordIDSpecified |
 | SecondChanceOfferSent |
 | SecondChanceOfferSentSpecified |
 | Shipment |
 | SoldOn |
 | SoldOnSpecified |
 | StartPrice |
 | SubtotalAmount |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | TransactionIDSpecified |
 | Variation |
 | WatchCount |
 | WatchCountSpecified |
Remarks
Inheritance Hierarchy
Object
SellingManagerSoldTransactionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CharityListing Property

CharityListing Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► CharityListing
Declaration Syntax
C# Visual Basic Visual C++
public bool CharityListing { get; set; }
Public Property CharityListing As Boolean
    Get
    Set
public:
property bool CharityListing {
    bool get ();
    void set (bool value);
}


CharityListingSpecified Property

CharityListingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► CharityListingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CharityListingSpecified { get; set; }
Public Property CharityListingSpecified As Boolean
    Get
    Set
public:
property bool CharityListingSpecified {
    bool get ();
    void set (bool value);
}


CustomLabel Property

CustomLabel Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► CustomLabel
Declaration Syntax
C# Visual Basic Visual C++
public string CustomLabel { get; set; }
Public Property CustomLabel As String
    Get
    Set
public:
property String^ CustomLabel {
    String^ get ();
    void set (String^ value);
}


InvoiceNumber Property

InvoiceNumber Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► InvoiceNumber
Declaration Syntax
C# Visual Basic Visual C++
public string InvoiceNumber { get; set; }
Public Property InvoiceNumber As String
    Get
    Set
public:
property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ItemPrice Property

ItemPrice Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► ItemPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ItemPrice { get; set; }
Public Property ItemPrice As AmountType
    Get
    Set
public:
property AmountType^ ItemPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


ItemTitle Property

ItemTitle Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► ItemTitle
Declaration Syntax
C# Visual Basic Visual C++
public string ItemTitle { get; set; }
Public Property ItemTitle As String
    Get
    Set
public:
property String^ ItemTitle {
    String^ get ();
    void set (String^ value);
}


ListedOn Property

ListedOn Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► ListedOn
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeTypeCollection ListedOn { get; set; }
Public Property ListedOn As TransactionPlatformCodeTypeCollection
    Get
    Set
public:
property TransactionPlatformCodeTypeCollection^ ListedOn {
    TransactionPlatformCodeTypeCollection^ get ();
    void set (TransactionPlatformCodeTypeCollection^ value);
}


ListingType Property

ListingType Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► ListingType
Declaration Syntax
C# Visual Basic Visual C++
public ListingTypeCodeType ListingType { get; set; }
Public Property ListingType As ListingTypeCodeType
    Get
    Set
public:
property ListingTypeCodeType ListingType {
    ListingTypeCodeType get ();
    void set (ListingTypeCodeType value);
}


ListingTypeSpecified Property

ListingTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► ListingTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingTypeSpecified { get; set; }
Public Property ListingTypeSpecified As Boolean
    Get
    Set
public:
property bool ListingTypeSpecified {
    bool get ();
    void set (bool value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


QuantitySold Property

QuantitySold Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► QuantitySold
Declaration Syntax
C# Visual Basic Visual C++
public int QuantitySold { get; set; }
Public Property QuantitySold As Integer
    Get
    Set
public:
property int QuantitySold {
    int get ();
    void set (int value);
}


QuantitySoldSpecified Property

QuantitySoldSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► QuantitySoldSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySoldSpecified { get; set; }
Public Property QuantitySoldSpecified As Boolean
    Get
    Set
public:
property bool QuantitySoldSpecified {
    bool get ();
    void set (bool value);
}


Relisted Property

Relisted Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► Relisted
Declaration Syntax
C# Visual Basic Visual C++
public bool Relisted { get; set; }
Public Property Relisted As Boolean
    Get
    Set
public:
property bool Relisted {
    bool get ();
    void set (bool value);
}


RelistedSpecified Property

RelistedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► RelistedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RelistedSpecified { get; set; }
Public Property RelistedSpecified As Boolean
    Get
    Set
public:
property bool RelistedSpecified {
    bool get ();
    void set (bool value);
}


ReservePrice Property

ReservePrice Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► ReservePrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ReservePrice { get; set; }
Public Property ReservePrice As AmountType
    Get
    Set
public:
property AmountType^ ReservePrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


SaleRecordID Property

SaleRecordID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► SaleRecordID
Declaration Syntax
C# Visual Basic Visual C++
public long SaleRecordID { get; set; }
Public Property SaleRecordID As Long
    Get
    Set
public:
property long long SaleRecordID {
    long long get ();
    void set (long long value);
}


SaleRecordIDSpecified Property

SaleRecordIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► SaleRecordIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SaleRecordIDSpecified { get; set; }
Public Property SaleRecordIDSpecified As Boolean
    Get
    Set
public:
property bool SaleRecordIDSpecified {
    bool get ();
    void set (bool value);
}


SecondChanceOfferSent Property

SecondChanceOfferSent Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► SecondChanceOfferSent
Declaration Syntax
C# Visual Basic Visual C++
public bool SecondChanceOfferSent { get; set; }
Public Property SecondChanceOfferSent As Boolean
    Get
    Set
public:
property bool SecondChanceOfferSent {
    bool get ();
    void set (bool value);
}


SecondChanceOfferSentSpecified Property

SecondChanceOfferSentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► SecondChanceOfferSentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SecondChanceOfferSentSpecified { get; set; }
Public Property SecondChanceOfferSentSpecified As Boolean
    Get
    Set
public:
property bool SecondChanceOfferSentSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerSoldTransactionType Constructor

SellingManagerSoldTransactionType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► SellingManagerSoldTransactionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldTransactionType()
Public Sub New
public:
SellingManagerSoldTransactionType()


Shipment Property

Shipment Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► Shipment
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentType Shipment { get; set; }
Public Property Shipment As ShipmentType
    Get
    Set
public:
property ShipmentType^ Shipment {
    ShipmentType^ get ();
    void set (ShipmentType^ value);
}


SoldOn Property

SoldOn Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► SoldOn
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeType SoldOn { get; set; }
Public Property SoldOn As TransactionPlatformCodeType
    Get
    Set
public:
property TransactionPlatformCodeType SoldOn {
    TransactionPlatformCodeType get ();
    void set (TransactionPlatformCodeType value);
}


SoldOnSpecified Property

SoldOnSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► SoldOnSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SoldOnSpecified { get; set; }
Public Property SoldOnSpecified As Boolean
    Get
    Set
public:
property bool SoldOnSpecified {
    bool get ();
    void set (bool value);
}


StartPrice Property

StartPrice Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► StartPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType StartPrice { get; set; }
Public Property StartPrice As AmountType
    Get
    Set
public:
property AmountType^ StartPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


SubtotalAmount Property

SubtotalAmount Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► SubtotalAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType SubtotalAmount { get; set; }
Public Property SubtotalAmount As AmountType
    Get
    Set
public:
property AmountType^ SubtotalAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public long TransactionID { get; set; }
Public Property TransactionID As Long
    Get
    Set
public:
property long long TransactionID {
    long long get ();
    void set (long long value);
}


TransactionIDSpecified Property

TransactionIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► TransactionIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TransactionIDSpecified { get; set; }
Public Property TransactionIDSpecified As Boolean
    Get
    Set
public:
property bool TransactionIDSpecified {
    bool get ();
    void set (bool value);
}


Variation Property

Variation Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► Variation
Declaration Syntax
C# Visual Basic Visual C++
public VariationType Variation { get; set; }
Public Property Variation As VariationType
    Get
    Set
public:
property VariationType^ Variation {
    VariationType^ get ();
    void set (VariationType^ value);
}


WatchCount Property

WatchCount Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► WatchCount
Declaration Syntax
C# Visual Basic Visual C++
public int WatchCount { get; set; }
Public Property WatchCount As Integer
    Get
    Set
public:
property int WatchCount {
    int get ();
    void set (int value);
}


WatchCountSpecified Property

WatchCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionType ► WatchCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WatchCountSpecified { get; set; }
Public Property WatchCountSpecified As Boolean
    Get
    Set
public:
property bool WatchCountSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerSoldTransactionTypeCollection Class

SellingManagerSoldTransactionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellingManagerSoldTransactionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellingManagerSoldTransactionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellingManagerSoldTransactionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerSoldTransactionTypeCollection()()()() |
 | SellingManagerSoldTransactionTypeCollection(array<SellingManagerSoldTransactionType>[]()[][]) |
 | SellingManagerSoldTransactionTypeCollection(SellingManagerSoldTransactionTypeCollection) |
 | Add(SellingManagerSoldTransactionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellingManagerSoldTransactionType>[]()[][]) |
 | AddRange(SellingManagerSoldTransactionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellingManagerSoldTransactionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellingManagerSoldTransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellingManagerSoldTransactionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellingManagerSoldTransactionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellingManagerSoldTransactionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellingManagerSoldTransactionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► Add(SellingManagerSoldTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellingManagerSoldTransactionType item
)
Public Function Add ( _
    item As SellingManagerSoldTransactionType _
) As Integer
public:
int Add(
    SellingManagerSoldTransactionType^ item
)
Parameters
item (SellingManagerSoldTransactionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellingManagerSoldTransactionType>[]()[][]) |
 | AddRange(SellingManagerSoldTransactionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► AddRange(array<SellingManagerSoldTransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerSoldTransactionType[] items
)
Public Sub AddRange ( _
    items As SellingManagerSoldTransactionType() _
)
public:
void AddRange(
    array<SellingManagerSoldTransactionType^>^ items
)
Parameters
items (array< SellingManagerSoldTransactionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► AddRange(SellingManagerSoldTransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerSoldTransactionTypeCollection items
)
Public Sub AddRange ( _
    items As SellingManagerSoldTransactionTypeCollection _
)
public:
void AddRange(
    SellingManagerSoldTransactionTypeCollection^ items
)
Parameters
items (SellingManagerSoldTransactionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► Contains(SellingManagerSoldTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellingManagerSoldTransactionType item
)
Public Function Contains ( _
    item As SellingManagerSoldTransactionType _
) As Boolean
public:
bool Contains(
    SellingManagerSoldTransactionType^ item
)
Parameters
item (SellingManagerSoldTransactionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► CopyTo(array<SellingManagerSoldTransactionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellingManagerSoldTransactionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellingManagerSoldTransactionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellingManagerSoldTransactionType^>^ items,
    int index
)
Parameters
items (array< SellingManagerSoldTransactionType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► IndexOf(SellingManagerSoldTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellingManagerSoldTransactionType item
)
Public Function IndexOf ( _
    item As SellingManagerSoldTransactionType _
) As Integer
public:
int IndexOf(
    SellingManagerSoldTransactionType^ item
)
Parameters
item (SellingManagerSoldTransactionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► Insert(Int32, SellingManagerSoldTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellingManagerSoldTransactionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellingManagerSoldTransactionType _
)
public:
void Insert(
    int index,
    SellingManagerSoldTransactionType^ item
)
Parameters
index (Int32)
item (SellingManagerSoldTransactionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldTransactionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellingManagerSoldTransactionType
    Get
    Set
public:
property SellingManagerSoldTransactionType^ default[int index] {
    SellingManagerSoldTransactionType^ get (int index);
    void set (int index, SellingManagerSoldTransactionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldTransactionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellingManagerSoldTransactionType
public:
SellingManagerSoldTransactionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► Remove(SellingManagerSoldTransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellingManagerSoldTransactionType item
)
Public Sub Remove ( _
    item As SellingManagerSoldTransactionType _
)
public:
void Remove(
    SellingManagerSoldTransactionType^ item
)
Parameters
item (SellingManagerSoldTransactionType)


SellingManagerSoldTransactionTypeCollection Constructor

SellingManagerSoldTransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► SellingManagerSoldTransactionTypeCollection()()()()
Members
Icon | Member | Description
 | SellingManagerSoldTransactionTypeCollection()()()() |
 | SellingManagerSoldTransactionTypeCollection(array<SellingManagerSoldTransactionType>[]()[][]) |
 | SellingManagerSoldTransactionTypeCollection(SellingManagerSoldTransactionTypeCollection) |


SellingManagerSoldTransactionTypeCollection Constructor

SellingManagerSoldTransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► SellingManagerSoldTransactionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldTransactionTypeCollection()
Public Sub New
public:
SellingManagerSoldTransactionTypeCollection()


SellingManagerSoldTransactionTypeCollection Constructor (items)

SellingManagerSoldTransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► SellingManagerSoldTransactionTypeCollection(array<SellingManagerSoldTransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldTransactionTypeCollection(
    SellingManagerSoldTransactionType[] items
)
Public Sub New ( _
    items As SellingManagerSoldTransactionType() _
)
public:
SellingManagerSoldTransactionTypeCollection(
    array<SellingManagerSoldTransactionType^>^ items
)
Parameters
items (array< SellingManagerSoldTransactionType >[]()[][])


SellingManagerSoldTransactionTypeCollection Constructor (items)

SellingManagerSoldTransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► SellingManagerSoldTransactionTypeCollection(SellingManagerSoldTransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldTransactionTypeCollection(
    SellingManagerSoldTransactionTypeCollection items
)
Public Sub New ( _
    items As SellingManagerSoldTransactionTypeCollection _
)
public:
SellingManagerSoldTransactionTypeCollection(
    SellingManagerSoldTransactionTypeCollection^ items
)
Parameters
items (SellingManagerSoldTransactionTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerSoldTransactionType[] ToArray()
Public Function ToArray As SellingManagerSoldTransactionType()
public:
array<SellingManagerSoldTransactionType^>^ ToArray()
Return Value


SellingManagerTemplateDetailsType Class

SellingManagerTemplateDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerTemplateDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerTemplateDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerTemplateDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerTemplateDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SaleTemplateID |
 | SaleTemplateName |
 | SellingManagerProductDetails |
 | SuccessPercent |
 | SuccessPercentSpecified |
 | Template |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingManagerTemplateDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsType ► SaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public string SaleTemplateID { get; set; }
Public Property SaleTemplateID As String
    Get
    Set
public:
property String^ SaleTemplateID {
    String^ get ();
    void set (String^ value);
}


SaleTemplateName Property

SaleTemplateName Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsType ► SaleTemplateName
Declaration Syntax
C# Visual Basic Visual C++
public string SaleTemplateName { get; set; }
Public Property SaleTemplateName As String
    Get
    Set
public:
property String^ SaleTemplateName {
    String^ get ();
    void set (String^ value);
}


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsType ► SellingManagerProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; set; }
Public Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


SellingManagerTemplateDetailsType Constructor

SellingManagerTemplateDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsType ► SellingManagerTemplateDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerTemplateDetailsType()
Public Sub New
public:
SellingManagerTemplateDetailsType()


SuccessPercent Property

SuccessPercent Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsType ► SuccessPercent
Declaration Syntax
C# Visual Basic Visual C++
public float SuccessPercent { get; set; }
Public Property SuccessPercent As Single
    Get
    Set
public:
property float SuccessPercent {
    float get ();
    void set (float value);
}


SuccessPercentSpecified Property

SuccessPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsType ► SuccessPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SuccessPercentSpecified { get; set; }
Public Property SuccessPercentSpecified As Boolean
    Get
    Set
public:
property bool SuccessPercentSpecified {
    bool get ();
    void set (bool value);
}


Template Property

Template Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsType ► Template
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Template { get; set; }
Public Property Template As ItemType
    Get
    Set
public:
property ItemType^ Template {
    ItemType^ get ();
    void set (ItemType^ value);
}


SellingManagerTemplateDetailsTypeCollection Class

SellingManagerTemplateDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SellingManagerTemplateDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SellingManagerTemplateDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SellingManagerTemplateDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerTemplateDetailsTypeCollection()()()() |
 | SellingManagerTemplateDetailsTypeCollection(array<SellingManagerTemplateDetailsType>[]()[][]) |
 | SellingManagerTemplateDetailsTypeCollection(SellingManagerTemplateDetailsTypeCollection) |
 | Add(SellingManagerTemplateDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SellingManagerTemplateDetailsType>[]()[][]) |
 | AddRange(SellingManagerTemplateDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SellingManagerTemplateDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SellingManagerTemplateDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SellingManagerTemplateDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SellingManagerTemplateDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SellingManagerTemplateDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SellingManagerTemplateDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► Add(SellingManagerTemplateDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SellingManagerTemplateDetailsType item
)
Public Function Add ( _
    item As SellingManagerTemplateDetailsType _
) As Integer
public:
int Add(
    SellingManagerTemplateDetailsType^ item
)
Parameters
item (SellingManagerTemplateDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SellingManagerTemplateDetailsType>[]()[][]) |
 | AddRange(SellingManagerTemplateDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► AddRange(array<SellingManagerTemplateDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerTemplateDetailsType[] items
)
Public Sub AddRange ( _
    items As SellingManagerTemplateDetailsType() _
)
public:
void AddRange(
    array<SellingManagerTemplateDetailsType^>^ items
)
Parameters
items (array< SellingManagerTemplateDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► AddRange(SellingManagerTemplateDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SellingManagerTemplateDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As SellingManagerTemplateDetailsTypeCollection _
)
public:
void AddRange(
    SellingManagerTemplateDetailsTypeCollection^ items
)
Parameters
items (SellingManagerTemplateDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► Contains(SellingManagerTemplateDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SellingManagerTemplateDetailsType item
)
Public Function Contains ( _
    item As SellingManagerTemplateDetailsType _
) As Boolean
public:
bool Contains(
    SellingManagerTemplateDetailsType^ item
)
Parameters
item (SellingManagerTemplateDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► CopyTo(array<SellingManagerTemplateDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SellingManagerTemplateDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SellingManagerTemplateDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SellingManagerTemplateDetailsType^>^ items,
    int index
)
Parameters
items (array< SellingManagerTemplateDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► IndexOf(SellingManagerTemplateDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SellingManagerTemplateDetailsType item
)
Public Function IndexOf ( _
    item As SellingManagerTemplateDetailsType _
) As Integer
public:
int IndexOf(
    SellingManagerTemplateDetailsType^ item
)
Parameters
item (SellingManagerTemplateDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► Insert(Int32, SellingManagerTemplateDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SellingManagerTemplateDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SellingManagerTemplateDetailsType _
)
public:
void Insert(
    int index,
    SellingManagerTemplateDetailsType^ item
)
Parameters
index (Int32)
item (SellingManagerTemplateDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerTemplateDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SellingManagerTemplateDetailsType
    Get
    Set
public:
property SellingManagerTemplateDetailsType^ default[int index] {
    SellingManagerTemplateDetailsType^ get (int index);
    void set (int index, SellingManagerTemplateDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerTemplateDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SellingManagerTemplateDetailsType
public:
SellingManagerTemplateDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► Remove(SellingManagerTemplateDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SellingManagerTemplateDetailsType item
)
Public Sub Remove ( _
    item As SellingManagerTemplateDetailsType _
)
public:
void Remove(
    SellingManagerTemplateDetailsType^ item
)
Parameters
item (SellingManagerTemplateDetailsType)


SellingManagerTemplateDetailsTypeCollection Constructor

SellingManagerTemplateDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► SellingManagerTemplateDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | SellingManagerTemplateDetailsTypeCollection()()()() |
 | SellingManagerTemplateDetailsTypeCollection(array<SellingManagerTemplateDetailsType>[]()[][]) |
 | SellingManagerTemplateDetailsTypeCollection(SellingManagerTemplateDetailsTypeCollection) |


SellingManagerTemplateDetailsTypeCollection Constructor

SellingManagerTemplateDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► SellingManagerTemplateDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerTemplateDetailsTypeCollection()
Public Sub New
public:
SellingManagerTemplateDetailsTypeCollection()


SellingManagerTemplateDetailsTypeCollection Constructor (items)

SellingManagerTemplateDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► SellingManagerTemplateDetailsTypeCollection(array<SellingManagerTemplateDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerTemplateDetailsTypeCollection(
    SellingManagerTemplateDetailsType[] items
)
Public Sub New ( _
    items As SellingManagerTemplateDetailsType() _
)
public:
SellingManagerTemplateDetailsTypeCollection(
    array<SellingManagerTemplateDetailsType^>^ items
)
Parameters
items (array< SellingManagerTemplateDetailsType >[]()[][])


SellingManagerTemplateDetailsTypeCollection Constructor (items)

SellingManagerTemplateDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► SellingManagerTemplateDetailsTypeCollection(SellingManagerTemplateDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerTemplateDetailsTypeCollection(
    SellingManagerTemplateDetailsTypeCollection items
)
Public Sub New ( _
    items As SellingManagerTemplateDetailsTypeCollection _
)
public:
SellingManagerTemplateDetailsTypeCollection(
    SellingManagerTemplateDetailsTypeCollection^ items
)
Parameters
items (SellingManagerTemplateDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerTemplateDetailsType[] ToArray()
Public Function ToArray As SellingManagerTemplateDetailsType()
public:
array<SellingManagerTemplateDetailsType^>^ ToArray()
Return Value


SellingManagerVendorDetailsType Class

SellingManagerVendorDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► SellingManagerVendorDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingManagerVendorDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingManagerVendorDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingManagerVendorDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingManagerVendorDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | VendorContactInfo |
 | VendorName |
Remarks
Inheritance Hierarchy
Object
SellingManagerVendorDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerVendorDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SellingManagerVendorDetailsType Constructor

SellingManagerVendorDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingManagerVendorDetailsType ► SellingManagerVendorDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerVendorDetailsType()
Public Sub New
public:
SellingManagerVendorDetailsType()


VendorContactInfo Property

VendorContactInfo Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerVendorDetailsType ► VendorContactInfo
Declaration Syntax
C# Visual Basic Visual C++
public string VendorContactInfo { get; set; }
Public Property VendorContactInfo As String
    Get
    Set
public:
property String^ VendorContactInfo {
    String^ get ();
    void set (String^ value);
}


VendorName Property

VendorName Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerVendorDetailsType ► VendorName
Declaration Syntax
C# Visual Basic Visual C++
public string VendorName { get; set; }
Public Property VendorName As String
    Get
    Set
public:
property String^ VendorName {
    String^ get ();
    void set (String^ value);
}


SellingStatusType Class

SellingStatusType Class
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingStatusType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingStatusType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingStatusType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingStatusType()()()() |
 | AdminEnded |
 | AdminEndedSpecified |
 | Any |
 | BidCount |
 | BidCountSpecified |
 | BidderCount |
 | BidderCountSpecified |
 | BidIncrement |
 | ConvertedCurrentPrice |
 | CurrentPrice |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FinalValueFee |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HighBidder |
 | LeadCount |
 | LeadCountSpecified |
 | ListingStatus |
 | ListingStatusSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumToBid |
 | PromotionalSaleDetails |
 | QuantitySold |
 | QuantitySoldByPickupInStore |
 | QuantitySoldByPickupInStoreSpecified |
 | QuantitySoldSpecified |
 | ReserveMet |
 | ReserveMetSpecified |
 | SecondChanceEligible |
 | SecondChanceEligibleSpecified |
 | SoldAsBin |
 | SoldAsBinSpecified |
 | SuggestedBidValues |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SellingStatusType


AdminEnded Property

AdminEnded Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► AdminEnded
Declaration Syntax
C# Visual Basic Visual C++
public bool AdminEnded { get; set; }
Public Property AdminEnded As Boolean
    Get
    Set
public:
property bool AdminEnded {
    bool get ();
    void set (bool value);
}


AdminEndedSpecified Property

AdminEndedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► AdminEndedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AdminEndedSpecified { get; set; }
Public Property AdminEndedSpecified As Boolean
    Get
    Set
public:
property bool AdminEndedSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidCount Property

BidCount Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► BidCount
Declaration Syntax
C# Visual Basic Visual C++
public int BidCount { get; set; }
Public Property BidCount As Integer
    Get
    Set
public:
property int BidCount {
    int get ();
    void set (int value);
}


BidCountSpecified Property

BidCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► BidCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidCountSpecified { get; set; }
Public Property BidCountSpecified As Boolean
    Get
    Set
public:
property bool BidCountSpecified {
    bool get ();
    void set (bool value);
}


BidderCount Property

BidderCount Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► BidderCount
Declaration Syntax
C# Visual Basic Visual C++
public long BidderCount { get; set; }
Public Property BidderCount As Long
    Get
    Set
public:
property long long BidderCount {
    long long get ();
    void set (long long value);
}


BidderCountSpecified Property

BidderCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► BidderCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BidderCountSpecified { get; set; }
Public Property BidderCountSpecified As Boolean
    Get
    Set
public:
property bool BidderCountSpecified {
    bool get ();
    void set (bool value);
}


BidIncrement Property

BidIncrement Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► BidIncrement
Declaration Syntax
C# Visual Basic Visual C++
public AmountType BidIncrement { get; set; }
Public Property BidIncrement As AmountType
    Get
    Set
public:
property AmountType^ BidIncrement {
    AmountType^ get ();
    void set (AmountType^ value);
}


ConvertedCurrentPrice Property

ConvertedCurrentPrice Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► ConvertedCurrentPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ConvertedCurrentPrice { get; set; }
Public Property ConvertedCurrentPrice As AmountType
    Get
    Set
public:
property AmountType^ ConvertedCurrentPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


CurrentPrice Property

CurrentPrice Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► CurrentPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CurrentPrice { get; set; }
Public Property CurrentPrice As AmountType
    Get
    Set
public:
property AmountType^ CurrentPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


FinalValueFee Property

FinalValueFee Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► FinalValueFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType FinalValueFee { get; set; }
Public Property FinalValueFee As AmountType
    Get
    Set
public:
property AmountType^ FinalValueFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


HighBidder Property

HighBidder Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► HighBidder
Declaration Syntax
C# Visual Basic Visual C++
public UserType HighBidder { get; set; }
Public Property HighBidder As UserType
    Get
    Set
public:
property UserType^ HighBidder {
    UserType^ get ();
    void set (UserType^ value);
}


LeadCount Property

LeadCount Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► LeadCount
Declaration Syntax
C# Visual Basic Visual C++
public int LeadCount { get; set; }
Public Property LeadCount As Integer
    Get
    Set
public:
property int LeadCount {
    int get ();
    void set (int value);
}


LeadCountSpecified Property

LeadCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► LeadCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LeadCountSpecified { get; set; }
Public Property LeadCountSpecified As Boolean
    Get
    Set
public:
property bool LeadCountSpecified {
    bool get ();
    void set (bool value);
}


ListingStatus Property

ListingStatus Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► ListingStatus
Declaration Syntax
C# Visual Basic Visual C++
public ListingStatusCodeType ListingStatus { get; set; }
Public Property ListingStatus As ListingStatusCodeType
    Get
    Set
public:
property ListingStatusCodeType ListingStatus {
    ListingStatusCodeType get ();
    void set (ListingStatusCodeType value);
}


ListingStatusSpecified Property

ListingStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► ListingStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ListingStatusSpecified { get; set; }
Public Property ListingStatusSpecified As Boolean
    Get
    Set
public:
property bool ListingStatusSpecified {
    bool get ();
    void set (bool value);
}


MinimumToBid Property

MinimumToBid Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► MinimumToBid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MinimumToBid { get; set; }
Public Property MinimumToBid As AmountType
    Get
    Set
public:
property AmountType^ MinimumToBid {
    AmountType^ get ();
    void set (AmountType^ value);
}


PromotionalSaleDetails Property

PromotionalSaleDetails Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► PromotionalSaleDetails
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleDetailsType PromotionalSaleDetails { get; set; }
Public Property PromotionalSaleDetails As PromotionalSaleDetailsType
    Get
    Set
public:
property PromotionalSaleDetailsType^ PromotionalSaleDetails {
    PromotionalSaleDetailsType^ get ();
    void set (PromotionalSaleDetailsType^ value);
}


QuantitySold Property

QuantitySold Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► QuantitySold
Declaration Syntax
C# Visual Basic Visual C++
public int QuantitySold { get; set; }
Public Property QuantitySold As Integer
    Get
    Set
public:
property int QuantitySold {
    int get ();
    void set (int value);
}


QuantitySoldByPickupInStore Property

QuantitySoldByPickupInStore Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► QuantitySoldByPickupInStore
Declaration Syntax
C# Visual Basic Visual C++
public int QuantitySoldByPickupInStore { get; set; }
Public Property QuantitySoldByPickupInStore As Integer
    Get
    Set
public:
property int QuantitySoldByPickupInStore {
    int get ();
    void set (int value);
}


QuantitySoldByPickupInStoreSpecified Property

QuantitySoldByPickupInStoreSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► QuantitySoldByPickupInStoreSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySoldByPickupInStoreSpecified { get; set; }
Public Property QuantitySoldByPickupInStoreSpecified As Boolean
    Get
    Set
public:
property bool QuantitySoldByPickupInStoreSpecified {
    bool get ();
    void set (bool value);
}


QuantitySoldSpecified Property

QuantitySoldSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► QuantitySoldSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySoldSpecified { get; set; }
Public Property QuantitySoldSpecified As Boolean
    Get
    Set
public:
property bool QuantitySoldSpecified {
    bool get ();
    void set (bool value);
}


ReserveMet Property

ReserveMet Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► ReserveMet
Declaration Syntax
C# Visual Basic Visual C++
public bool ReserveMet { get; set; }
Public Property ReserveMet As Boolean
    Get
    Set
public:
property bool ReserveMet {
    bool get ();
    void set (bool value);
}


ReserveMetSpecified Property

ReserveMetSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► ReserveMetSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReserveMetSpecified { get; set; }
Public Property ReserveMetSpecified As Boolean
    Get
    Set
public:
property bool ReserveMetSpecified {
    bool get ();
    void set (bool value);
}


SecondChanceEligible Property

SecondChanceEligible Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► SecondChanceEligible
Declaration Syntax
C# Visual Basic Visual C++
public bool SecondChanceEligible { get; set; }
Public Property SecondChanceEligible As Boolean
    Get
    Set
public:
property bool SecondChanceEligible {
    bool get ();
    void set (bool value);
}


SecondChanceEligibleSpecified Property

SecondChanceEligibleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► SecondChanceEligibleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SecondChanceEligibleSpecified { get; set; }
Public Property SecondChanceEligibleSpecified As Boolean
    Get
    Set
public:
property bool SecondChanceEligibleSpecified {
    bool get ();
    void set (bool value);
}


SellingStatusType Constructor

SellingStatusType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► SellingStatusType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingStatusType()
Public Sub New
public:
SellingStatusType()


SoldAsBin Property

SoldAsBin Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► SoldAsBin
Declaration Syntax
C# Visual Basic Visual C++
public bool SoldAsBin { get; set; }
Public Property SoldAsBin As Boolean
    Get
    Set
public:
property bool SoldAsBin {
    bool get ();
    void set (bool value);
}


SoldAsBinSpecified Property

SoldAsBinSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► SoldAsBinSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SoldAsBinSpecified { get; set; }
Public Property SoldAsBinSpecified As Boolean
    Get
    Set
public:
property bool SoldAsBinSpecified {
    bool get ();
    void set (bool value);
}


SuggestedBidValues Property

SuggestedBidValues Property
Namespaces ► eBay.Service.Core.Soap ► SellingStatusType ► SuggestedBidValues
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedBidValueType SuggestedBidValues { get; set; }
Public Property SuggestedBidValues As SuggestedBidValueType
    Get
    Set
public:
property SuggestedBidValueType^ SuggestedBidValues {
    SuggestedBidValueType^ get ();
    void set (SuggestedBidValueType^ value);
}


SellingSummaryType Class

SellingSummaryType Class
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SellingSummaryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SellingSummaryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SellingSummaryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SellingSummaryType()()()() |
 | ActiveAuctionCount |
 | ActiveAuctionCountSpecified |
 | AuctionBidCount |
 | AuctionBidCountSpecified |
 | AuctionSellingCount |
 | AuctionSellingCountSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SoldDurationInDays |
 | SoldDurationInDaysSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TotalAuctionSellingValue |
 | TotalSoldCount |
 | TotalSoldCountSpecified |
 | TotalSoldValue |
Remarks
Inheritance Hierarchy
Object
SellingSummaryType


ActiveAuctionCount Property

ActiveAuctionCount Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► ActiveAuctionCount
Declaration Syntax
C# Visual Basic Visual C++
public int ActiveAuctionCount { get; set; }
Public Property ActiveAuctionCount As Integer
    Get
    Set
public:
property int ActiveAuctionCount {
    int get ();
    void set (int value);
}


ActiveAuctionCountSpecified Property

ActiveAuctionCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► ActiveAuctionCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ActiveAuctionCountSpecified { get; set; }
Public Property ActiveAuctionCountSpecified As Boolean
    Get
    Set
public:
property bool ActiveAuctionCountSpecified {
    bool get ();
    void set (bool value);
}


AuctionBidCount Property

AuctionBidCount Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► AuctionBidCount
Declaration Syntax
C# Visual Basic Visual C++
public int AuctionBidCount { get; set; }
Public Property AuctionBidCount As Integer
    Get
    Set
public:
property int AuctionBidCount {
    int get ();
    void set (int value);
}


AuctionBidCountSpecified Property

AuctionBidCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► AuctionBidCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AuctionBidCountSpecified { get; set; }
Public Property AuctionBidCountSpecified As Boolean
    Get
    Set
public:
property bool AuctionBidCountSpecified {
    bool get ();
    void set (bool value);
}


AuctionSellingCount Property

AuctionSellingCount Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► AuctionSellingCount
Declaration Syntax
C# Visual Basic Visual C++
public int AuctionSellingCount { get; set; }
Public Property AuctionSellingCount As Integer
    Get
    Set
public:
property int AuctionSellingCount {
    int get ();
    void set (int value);
}


AuctionSellingCountSpecified Property

AuctionSellingCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► AuctionSellingCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AuctionSellingCountSpecified { get; set; }
Public Property AuctionSellingCountSpecified As Boolean
    Get
    Set
public:
property bool AuctionSellingCountSpecified {
    bool get ();
    void set (bool value);
}


SellingSummaryType Constructor

SellingSummaryType Constructor
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► SellingSummaryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SellingSummaryType()
Public Sub New
public:
SellingSummaryType()


SoldDurationInDays Property

SoldDurationInDays Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► SoldDurationInDays
Declaration Syntax
C# Visual Basic Visual C++
public int SoldDurationInDays { get; set; }
Public Property SoldDurationInDays As Integer
    Get
    Set
public:
property int SoldDurationInDays {
    int get ();
    void set (int value);
}


SoldDurationInDaysSpecified Property

SoldDurationInDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► SoldDurationInDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SoldDurationInDaysSpecified { get; set; }
Public Property SoldDurationInDaysSpecified As Boolean
    Get
    Set
public:
property bool SoldDurationInDaysSpecified {
    bool get ();
    void set (bool value);
}


TotalAuctionSellingValue Property

TotalAuctionSellingValue Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► TotalAuctionSellingValue
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalAuctionSellingValue { get; set; }
Public Property TotalAuctionSellingValue As AmountType
    Get
    Set
public:
property AmountType^ TotalAuctionSellingValue {
    AmountType^ get ();
    void set (AmountType^ value);
}


TotalSoldCount Property

TotalSoldCount Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► TotalSoldCount
Declaration Syntax
C# Visual Basic Visual C++
public int TotalSoldCount { get; set; }
Public Property TotalSoldCount As Integer
    Get
    Set
public:
property int TotalSoldCount {
    int get ();
    void set (int value);
}


TotalSoldCountSpecified Property

TotalSoldCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► TotalSoldCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TotalSoldCountSpecified { get; set; }
Public Property TotalSoldCountSpecified As Boolean
    Get
    Set
public:
property bool TotalSoldCountSpecified {
    bool get ();
    void set (bool value);
}


TotalSoldValue Property

TotalSoldValue Property
Namespaces ► eBay.Service.Core.Soap ► SellingSummaryType ► TotalSoldValue
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalSoldValue { get; set; }
Public Property TotalSoldValue As AmountType
    Get
    Set
public:
property AmountType^ TotalSoldValue {
    AmountType^ get ();
    void set (AmountType^ value);
}


SendInvoiceRequestType Class

SendInvoiceRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SendInvoiceRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SendInvoiceRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SendInvoiceRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SendInvoiceRequestType()()()() |
 | AdjustmentAmount |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CheckoutInstructions |
 | CODCost |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EmailCopyToSeller |
 | EmailCopyToSellerSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InsuranceFee |
 | InsuranceOption |
 | InsuranceOptionSpecified |
 | InternationalShippingServiceOptions |
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OrderID |
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | PaymentMethods |
 | PayPalEmailAddress |
 | SalesTax |
 | ShippingServiceOptions |
 | SKU |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SendInvoiceRequestType


AdjustmentAmount Property

AdjustmentAmount Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► AdjustmentAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AdjustmentAmount { get; set; }
Public Property AdjustmentAmount As AmountType
    Get
    Set
public:
property AmountType^ AdjustmentAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


CheckoutInstructions Property

CheckoutInstructions Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► CheckoutInstructions
Declaration Syntax
C# Visual Basic Visual C++
public string CheckoutInstructions { get; set; }
Public Property CheckoutInstructions As String
    Get
    Set
public:
property String^ CheckoutInstructions {
    String^ get ();
    void set (String^ value);
}


CODCost Property

CODCost Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► CODCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CODCost { get; set; }
Public Property CODCost As AmountType
    Get
    Set
public:
property AmountType^ CODCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


EmailCopyToSeller Property

EmailCopyToSeller Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► EmailCopyToSeller
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailCopyToSeller { get; set; }
Public Property EmailCopyToSeller As Boolean
    Get
    Set
public:
property bool EmailCopyToSeller {
    bool get ();
    void set (bool value);
}


EmailCopyToSellerSpecified Property

EmailCopyToSellerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► EmailCopyToSellerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailCopyToSellerSpecified { get; set; }
Public Property EmailCopyToSellerSpecified As Boolean
    Get
    Set
public:
property bool EmailCopyToSellerSpecified {
    bool get ();
    void set (bool value);
}


InsuranceFee Property

InsuranceFee Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► InsuranceFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType InsuranceFee { get; set; }
Public Property InsuranceFee As AmountType
    Get
    Set
public:
property AmountType^ InsuranceFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


InsuranceOption Property

InsuranceOption Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► InsuranceOption
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceOptionCodeType InsuranceOption { get; set; }
Public Property InsuranceOption As InsuranceOptionCodeType
    Get
    Set
public:
property InsuranceOptionCodeType InsuranceOption {
    InsuranceOptionCodeType get ();
    void set (InsuranceOptionCodeType value);
}


InsuranceOptionSpecified Property

InsuranceOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► InsuranceOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InsuranceOptionSpecified { get; set; }
Public Property InsuranceOptionSpecified As Boolean
    Get
    Set
public:
property bool InsuranceOptionSpecified {
    bool get ();
    void set (bool value);
}


InternationalShippingServiceOptions Property

InternationalShippingServiceOptions Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► InternationalShippingServiceOptions
Declaration Syntax
C# Visual Basic Visual C++
public InternationalShippingServiceOptionsTypeCollection InternationalShippingServiceOptions { get; set; }
Public Property InternationalShippingServiceOptions As InternationalShippingServiceOptionsTypeCollection
    Get
    Set
public:
property InternationalShippingServiceOptionsTypeCollection^ InternationalShippingServiceOptions {
    InternationalShippingServiceOptionsTypeCollection^ get ();
    void set (InternationalShippingServiceOptionsTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderID Property

OrderID Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► OrderID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderID { get; set; }
Public Property OrderID As String
    Get
    Set
public:
property String^ OrderID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


PaymentMethods Property

PaymentMethods Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► PaymentMethods
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeTypeCollection PaymentMethods { get; set; }
Public Property PaymentMethods As BuyerPaymentMethodCodeTypeCollection
    Get
    Set
public:
property BuyerPaymentMethodCodeTypeCollection^ PaymentMethods {
    BuyerPaymentMethodCodeTypeCollection^ get ();
    void set (BuyerPaymentMethodCodeTypeCollection^ value);
}


PayPalEmailAddress Property

PayPalEmailAddress Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► PayPalEmailAddress
Declaration Syntax
C# Visual Basic Visual C++
public string PayPalEmailAddress { get; set; }
Public Property PayPalEmailAddress As String
    Get
    Set
public:
property String^ PayPalEmailAddress {
    String^ get ();
    void set (String^ value);
}


SalesTax Property

SalesTax Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► SalesTax
Declaration Syntax
C# Visual Basic Visual C++
public SalesTaxType SalesTax { get; set; }
Public Property SalesTax As SalesTaxType
    Get
    Set
public:
property SalesTaxType^ SalesTax {
    SalesTaxType^ get ();
    void set (SalesTaxType^ value);
}


SendInvoiceRequestType Constructor

SendInvoiceRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► SendInvoiceRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SendInvoiceRequestType()
Public Sub New
public:
SendInvoiceRequestType()


ShippingServiceOptions Property

ShippingServiceOptions Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► ShippingServiceOptions
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsTypeCollection ShippingServiceOptions { get; set; }
Public Property ShippingServiceOptions As ShippingServiceOptionsTypeCollection
    Get
    Set
public:
property ShippingServiceOptionsTypeCollection^ ShippingServiceOptions {
    ShippingServiceOptionsTypeCollection^ get ();
    void set (ShippingServiceOptionsTypeCollection^ value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


SendInvoiceResponseType Class

SendInvoiceResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SendInvoiceResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SendInvoiceResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SendInvoiceResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SendInvoiceResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SendInvoiceResponseType


SendInvoiceResponseType Constructor

SendInvoiceResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SendInvoiceResponseType ► SendInvoiceResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SendInvoiceResponseType()
Public Sub New
public:
SendInvoiceResponseType()


SetMessagePreferencesRequestType Class

SetMessagePreferencesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetMessagePreferencesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetMessagePreferencesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetMessagePreferencesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetMessagePreferencesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetMessagePreferencesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | ASQPreferences |
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetMessagePreferencesRequestType


ASQPreferences Property

ASQPreferences Property
Namespaces ► eBay.Service.Core.Soap ► SetMessagePreferencesRequestType ► ASQPreferences
Declaration Syntax
C# Visual Basic Visual C++
public ASQPreferencesType ASQPreferences { get; set; }
Public Property ASQPreferences As ASQPreferencesType
    Get
    Set
public:
property ASQPreferencesType^ ASQPreferences {
    ASQPreferencesType^ get ();
    void set (ASQPreferencesType^ value);
}


SetMessagePreferencesRequestType Constructor

SetMessagePreferencesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetMessagePreferencesRequestType ► SetMessagePreferencesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetMessagePreferencesRequestType()
Public Sub New
public:
SetMessagePreferencesRequestType()


SetMessagePreferencesResponseType Class

SetMessagePreferencesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetMessagePreferencesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetMessagePreferencesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetMessagePreferencesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetMessagePreferencesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetMessagePreferencesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetMessagePreferencesResponseType


SetMessagePreferencesResponseType Constructor

SetMessagePreferencesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetMessagePreferencesResponseType ► SetMessagePreferencesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetMessagePreferencesResponseType()
Public Sub New
public:
SetMessagePreferencesResponseType()


SetNotificationPreferencesRequestType Class

SetNotificationPreferencesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetNotificationPreferencesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetNotificationPreferencesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetNotificationPreferencesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetNotificationPreferencesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetNotificationPreferencesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | ApplicationDeliveryPreferences |
 | BotBlock | (Inherited from AbstractRequestType.)
 | DeliveryURLName |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | EventProperty |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | UserData |
 | UserDeliveryPreferenceArray |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetNotificationPreferencesRequestType


ApplicationDeliveryPreferences Property

ApplicationDeliveryPreferences Property
Namespaces ► eBay.Service.Core.Soap ► SetNotificationPreferencesRequestType ► ApplicationDeliveryPreferences
Declaration Syntax
C# Visual Basic Visual C++
public ApplicationDeliveryPreferencesType ApplicationDeliveryPreferences { get; set; }
Public Property ApplicationDeliveryPreferences As ApplicationDeliveryPreferencesType
    Get
    Set
public:
property ApplicationDeliveryPreferencesType^ ApplicationDeliveryPreferences {
    ApplicationDeliveryPreferencesType^ get ();
    void set (ApplicationDeliveryPreferencesType^ value);
}


DeliveryURLName Property

DeliveryURLName Property
Namespaces ► eBay.Service.Core.Soap ► SetNotificationPreferencesRequestType ► DeliveryURLName
Declaration Syntax
C# Visual Basic Visual C++
public string DeliveryURLName { get; set; }
Public Property DeliveryURLName As String
    Get
    Set
public:
property String^ DeliveryURLName {
    String^ get ();
    void set (String^ value);
}


EventProperty Property

EventProperty Property
Namespaces ► eBay.Service.Core.Soap ► SetNotificationPreferencesRequestType ► EventProperty
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventPropertyTypeCollection EventProperty { get; set; }
Public Property EventProperty As NotificationEventPropertyTypeCollection
    Get
    Set
public:
property NotificationEventPropertyTypeCollection^ EventProperty {
    NotificationEventPropertyTypeCollection^ get ();
    void set (NotificationEventPropertyTypeCollection^ value);
}


SetNotificationPreferencesRequestType Constructor

SetNotificationPreferencesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetNotificationPreferencesRequestType ► SetNotificationPreferencesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetNotificationPreferencesRequestType()
Public Sub New
public:
SetNotificationPreferencesRequestType()


UserData Property

UserData Property
Namespaces ► eBay.Service.Core.Soap ► SetNotificationPreferencesRequestType ► UserData
Declaration Syntax
C# Visual Basic Visual C++
public NotificationUserDataType UserData { get; set; }
Public Property UserData As NotificationUserDataType
    Get
    Set
public:
property NotificationUserDataType^ UserData {
    NotificationUserDataType^ get ();
    void set (NotificationUserDataType^ value);
}


UserDeliveryPreferenceArray Property

UserDeliveryPreferenceArray Property
Namespaces ► eBay.Service.Core.Soap ► SetNotificationPreferencesRequestType ► UserDeliveryPreferenceArray
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEnableTypeCollection UserDeliveryPreferenceArray { get; set; }
Public Property UserDeliveryPreferenceArray As NotificationEnableTypeCollection
    Get
    Set
public:
property NotificationEnableTypeCollection^ UserDeliveryPreferenceArray {
    NotificationEnableTypeCollection^ get ();
    void set (NotificationEnableTypeCollection^ value);
}


SetNotificationPreferencesResponseType Class

SetNotificationPreferencesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetNotificationPreferencesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetNotificationPreferencesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetNotificationPreferencesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetNotificationPreferencesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetNotificationPreferencesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetNotificationPreferencesResponseType


SetNotificationPreferencesResponseType Constructor

SetNotificationPreferencesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetNotificationPreferencesResponseType ► SetNotificationPreferencesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetNotificationPreferencesResponseType()
Public Sub New
public:
SetNotificationPreferencesResponseType()


SetPromotionalSaleListingsRequestType Class

SetPromotionalSaleListingsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetPromotionalSaleListingsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetPromotionalSaleListingsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetPromotionalSaleListingsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetPromotionalSaleListingsRequestType()()()() |
 | Action |
 | ActionSpecified |
 | AllAuctionItems |
 | AllAuctionItemsSpecified |
 | AllFixedPriceItems |
 | AllFixedPriceItemsSpecified |
 | AllStoreInventoryItems |
 | AllStoreInventoryItemsSpecified |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CategoryID |
 | CategoryIDSpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | PromotionalSaleID |
 | PromotionalSaleIDSpecified |
 | PromotionalSaleItemIDArray |
 | StoreCategoryID |
 | StoreCategoryIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetPromotionalSaleListingsRequestType


Action Property

Action Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► Action
Declaration Syntax
C# Visual Basic Visual C++
public ModifyActionCodeType Action { get; set; }
Public Property Action As ModifyActionCodeType
    Get
    Set
public:
property ModifyActionCodeType Action {
    ModifyActionCodeType get ();
    void set (ModifyActionCodeType value);
}


ActionSpecified Property

ActionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► ActionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ActionSpecified { get; set; }
Public Property ActionSpecified As Boolean
    Get
    Set
public:
property bool ActionSpecified {
    bool get ();
    void set (bool value);
}


AllAuctionItems Property

AllAuctionItems Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► AllAuctionItems
Declaration Syntax
C# Visual Basic Visual C++
public bool AllAuctionItems { get; set; }
Public Property AllAuctionItems As Boolean
    Get
    Set
public:
property bool AllAuctionItems {
    bool get ();
    void set (bool value);
}


AllAuctionItemsSpecified Property

AllAuctionItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► AllAuctionItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AllAuctionItemsSpecified { get; set; }
Public Property AllAuctionItemsSpecified As Boolean
    Get
    Set
public:
property bool AllAuctionItemsSpecified {
    bool get ();
    void set (bool value);
}


AllFixedPriceItems Property

AllFixedPriceItems Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► AllFixedPriceItems
Declaration Syntax
C# Visual Basic Visual C++
public bool AllFixedPriceItems { get; set; }
Public Property AllFixedPriceItems As Boolean
    Get
    Set
public:
property bool AllFixedPriceItems {
    bool get ();
    void set (bool value);
}


AllFixedPriceItemsSpecified Property

AllFixedPriceItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► AllFixedPriceItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AllFixedPriceItemsSpecified { get; set; }
Public Property AllFixedPriceItemsSpecified As Boolean
    Get
    Set
public:
property bool AllFixedPriceItemsSpecified {
    bool get ();
    void set (bool value);
}


AllStoreInventoryItems Property

AllStoreInventoryItems Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► AllStoreInventoryItems
Declaration Syntax
C# Visual Basic Visual C++
public bool AllStoreInventoryItems { get; set; }
Public Property AllStoreInventoryItems As Boolean
    Get
    Set
public:
property bool AllStoreInventoryItems {
    bool get ();
    void set (bool value);
}


AllStoreInventoryItemsSpecified Property

AllStoreInventoryItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► AllStoreInventoryItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AllStoreInventoryItemsSpecified { get; set; }
Public Property AllStoreInventoryItemsSpecified As Boolean
    Get
    Set
public:
property bool AllStoreInventoryItemsSpecified {
    bool get ();
    void set (bool value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public long CategoryID { get; set; }
Public Property CategoryID As Long
    Get
    Set
public:
property long long CategoryID {
    long long get ();
    void set (long long value);
}


CategoryIDSpecified Property

CategoryIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► CategoryIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CategoryIDSpecified { get; set; }
Public Property CategoryIDSpecified As Boolean
    Get
    Set
public:
property bool CategoryIDSpecified {
    bool get ();
    void set (bool value);
}


PromotionalSaleID Property

PromotionalSaleID Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► PromotionalSaleID
Declaration Syntax
C# Visual Basic Visual C++
public long PromotionalSaleID { get; set; }
Public Property PromotionalSaleID As Long
    Get
    Set
public:
property long long PromotionalSaleID {
    long long get ();
    void set (long long value);
}


PromotionalSaleIDSpecified Property

PromotionalSaleIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► PromotionalSaleIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalSaleIDSpecified { get; set; }
Public Property PromotionalSaleIDSpecified As Boolean
    Get
    Set
public:
property bool PromotionalSaleIDSpecified {
    bool get ();
    void set (bool value);
}


PromotionalSaleItemIDArray Property

PromotionalSaleItemIDArray Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► PromotionalSaleItemIDArray
Declaration Syntax
C# Visual Basic Visual C++
public ItemIDArrayType PromotionalSaleItemIDArray { get; set; }
Public Property PromotionalSaleItemIDArray As ItemIDArrayType
    Get
    Set
public:
property ItemIDArrayType^ PromotionalSaleItemIDArray {
    ItemIDArrayType^ get ();
    void set (ItemIDArrayType^ value);
}


SetPromotionalSaleListingsRequestType Constructor

SetPromotionalSaleListingsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► SetPromotionalSaleListingsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleListingsRequestType()
Public Sub New
public:
SetPromotionalSaleListingsRequestType()


StoreCategoryID Property

StoreCategoryID Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► StoreCategoryID
Declaration Syntax
C# Visual Basic Visual C++
public long StoreCategoryID { get; set; }
Public Property StoreCategoryID As Long
    Get
    Set
public:
property long long StoreCategoryID {
    long long get ();
    void set (long long value);
}


StoreCategoryIDSpecified Property

StoreCategoryIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsRequestType ► StoreCategoryIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreCategoryIDSpecified { get; set; }
Public Property StoreCategoryIDSpecified As Boolean
    Get
    Set
public:
property bool StoreCategoryIDSpecified {
    bool get ();
    void set (bool value);
}


SetPromotionalSaleListingsResponseType Class

SetPromotionalSaleListingsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetPromotionalSaleListingsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetPromotionalSaleListingsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetPromotionalSaleListingsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetPromotionalSaleListingsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Status |
 | StatusSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetPromotionalSaleListingsResponseType


SetPromotionalSaleListingsResponseType Constructor

SetPromotionalSaleListingsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsResponseType ► SetPromotionalSaleListingsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleListingsResponseType()
Public Sub New
public:
SetPromotionalSaleListingsResponseType()


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsResponseType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeType Status { get; set; }
Public Property Status As PromotionalSaleStatusCodeType
    Get
    Set
public:
property PromotionalSaleStatusCodeType Status {
    PromotionalSaleStatusCodeType get ();
    void set (PromotionalSaleStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleListingsResponseType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


SetPromotionalSaleRequestType Class

SetPromotionalSaleRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetPromotionalSaleRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetPromotionalSaleRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetPromotionalSaleRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetPromotionalSaleRequestType()()()() |
 | Action |
 | ActionSpecified |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | PromotionalSaleDetails |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetPromotionalSaleRequestType


Action Property

Action Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleRequestType ► Action
Declaration Syntax
C# Visual Basic Visual C++
public ModifyActionCodeType Action { get; set; }
Public Property Action As ModifyActionCodeType
    Get
    Set
public:
property ModifyActionCodeType Action {
    ModifyActionCodeType get ();
    void set (ModifyActionCodeType value);
}


ActionSpecified Property

ActionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleRequestType ► ActionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ActionSpecified { get; set; }
Public Property ActionSpecified As Boolean
    Get
    Set
public:
property bool ActionSpecified {
    bool get ();
    void set (bool value);
}


PromotionalSaleDetails Property

PromotionalSaleDetails Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleRequestType ► PromotionalSaleDetails
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleType PromotionalSaleDetails { get; set; }
Public Property PromotionalSaleDetails As PromotionalSaleType
    Get
    Set
public:
property PromotionalSaleType^ PromotionalSaleDetails {
    PromotionalSaleType^ get ();
    void set (PromotionalSaleType^ value);
}


SetPromotionalSaleRequestType Constructor

SetPromotionalSaleRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleRequestType ► SetPromotionalSaleRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleRequestType()
Public Sub New
public:
SetPromotionalSaleRequestType()


SetPromotionalSaleResponseType Class

SetPromotionalSaleResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetPromotionalSaleResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetPromotionalSaleResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetPromotionalSaleResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetPromotionalSaleResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PromotionalSaleID |
 | PromotionalSaleIDSpecified |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Status |
 | StatusSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetPromotionalSaleResponseType


PromotionalSaleID Property

PromotionalSaleID Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleResponseType ► PromotionalSaleID
Declaration Syntax
C# Visual Basic Visual C++
public long PromotionalSaleID { get; set; }
Public Property PromotionalSaleID As Long
    Get
    Set
public:
property long long PromotionalSaleID {
    long long get ();
    void set (long long value);
}


PromotionalSaleIDSpecified Property

PromotionalSaleIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleResponseType ► PromotionalSaleIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalSaleIDSpecified { get; set; }
Public Property PromotionalSaleIDSpecified As Boolean
    Get
    Set
public:
property bool PromotionalSaleIDSpecified {
    bool get ();
    void set (bool value);
}


SetPromotionalSaleResponseType Constructor

SetPromotionalSaleResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleResponseType ► SetPromotionalSaleResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetPromotionalSaleResponseType()
Public Sub New
public:
SetPromotionalSaleResponseType()


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleResponseType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalSaleStatusCodeType Status { get; set; }
Public Property Status As PromotionalSaleStatusCodeType
    Get
    Set
public:
property PromotionalSaleStatusCodeType Status {
    PromotionalSaleStatusCodeType get ();
    void set (PromotionalSaleStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetPromotionalSaleResponseType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


SetSellingManagerFeedbackOptionsRequestType Class

SetSellingManagerFeedbackOptionsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerFeedbackOptionsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetSellingManagerFeedbackOptionsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetSellingManagerFeedbackOptionsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetSellingManagerFeedbackOptionsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetSellingManagerFeedbackOptionsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | AutomatedLeaveFeedbackEvent |
 | AutomatedLeaveFeedbackEventSpecified |
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | StoredComments |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetSellingManagerFeedbackOptionsRequestType


AutomatedLeaveFeedbackEvent Property

AutomatedLeaveFeedbackEvent Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerFeedbackOptionsRequestType ► AutomatedLeaveFeedbackEvent
Declaration Syntax
C# Visual Basic Visual C++
public AutomatedLeaveFeedbackEventCodeType AutomatedLeaveFeedbackEvent { get; set; }
Public Property AutomatedLeaveFeedbackEvent As AutomatedLeaveFeedbackEventCodeType
    Get
    Set
public:
property AutomatedLeaveFeedbackEventCodeType AutomatedLeaveFeedbackEvent {
    AutomatedLeaveFeedbackEventCodeType get ();
    void set (AutomatedLeaveFeedbackEventCodeType value);
}


AutomatedLeaveFeedbackEventSpecified Property

AutomatedLeaveFeedbackEventSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerFeedbackOptionsRequestType ► AutomatedLeaveFeedbackEventSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AutomatedLeaveFeedbackEventSpecified { get; set; }
Public Property AutomatedLeaveFeedbackEventSpecified As Boolean
    Get
    Set
public:
property bool AutomatedLeaveFeedbackEventSpecified {
    bool get ();
    void set (bool value);
}


SetSellingManagerFeedbackOptionsRequestType Constructor

SetSellingManagerFeedbackOptionsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerFeedbackOptionsRequestType ► SetSellingManagerFeedbackOptionsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerFeedbackOptionsRequestType()
Public Sub New
public:
SetSellingManagerFeedbackOptionsRequestType()


StoredComments Property

StoredComments Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerFeedbackOptionsRequestType ► StoredComments
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection StoredComments { get; set; }
Public Property StoredComments As StringCollection
    Get
    Set
public:
property StringCollection^ StoredComments {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


SetSellingManagerFeedbackOptionsResponseType Class

SetSellingManagerFeedbackOptionsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerFeedbackOptionsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetSellingManagerFeedbackOptionsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetSellingManagerFeedbackOptionsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetSellingManagerFeedbackOptionsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetSellingManagerFeedbackOptionsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetSellingManagerFeedbackOptionsResponseType


SetSellingManagerFeedbackOptionsResponseType Constructor

SetSellingManagerFeedbackOptionsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerFeedbackOptionsResponseType ► SetSellingManagerFeedbackOptionsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerFeedbackOptionsResponseType()
Public Sub New
public:
SetSellingManagerFeedbackOptionsResponseType()


SetSellingManagerItemAutomationRuleRequestType Class

SetSellingManagerItemAutomationRuleRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerItemAutomationRuleRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetSellingManagerItemAutomationRuleRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetSellingManagerItemAutomationRuleRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetSellingManagerItemAutomationRuleRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetSellingManagerItemAutomationRuleRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | AutomatedRelistingRule |
 | AutomatedSecondChanceOfferRule |
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetSellingManagerItemAutomationRuleRequestType


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerItemAutomationRuleRequestType ► AutomatedRelistingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; set; }
Public Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
    Set
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
    void set (SellingManagerAutoRelistType^ value);
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerItemAutomationRuleRequestType ► AutomatedSecondChanceOfferRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; set; }
Public Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
    Set
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
    void set (SellingManagerAutoSecondChanceOfferType^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerItemAutomationRuleRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


SetSellingManagerItemAutomationRuleRequestType Constructor

SetSellingManagerItemAutomationRuleRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerItemAutomationRuleRequestType ► SetSellingManagerItemAutomationRuleRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerItemAutomationRuleRequestType()
Public Sub New
public:
SetSellingManagerItemAutomationRuleRequestType()


SetSellingManagerItemAutomationRuleResponseType Class

SetSellingManagerItemAutomationRuleResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerItemAutomationRuleResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetSellingManagerItemAutomationRuleResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetSellingManagerItemAutomationRuleResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetSellingManagerItemAutomationRuleResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetSellingManagerItemAutomationRuleResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | AutomatedListingRule |
 | AutomatedRelistingRule |
 | AutomatedSecondChanceOfferRule |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetSellingManagerItemAutomationRuleResponseType


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerItemAutomationRuleResponseType ► AutomatedListingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; set; }
Public Property AutomatedListingRule As SellingManagerAutoListType
    Get
    Set
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
    void set (SellingManagerAutoListType^ value);
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerItemAutomationRuleResponseType ► AutomatedRelistingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; set; }
Public Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
    Set
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
    void set (SellingManagerAutoRelistType^ value);
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerItemAutomationRuleResponseType ► AutomatedSecondChanceOfferRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; set; }
Public Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
    Set
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
    void set (SellingManagerAutoSecondChanceOfferType^ value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerItemAutomationRuleResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


SetSellingManagerItemAutomationRuleResponseType Constructor

SetSellingManagerItemAutomationRuleResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerItemAutomationRuleResponseType ► SetSellingManagerItemAutomationRuleResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerItemAutomationRuleResponseType()
Public Sub New
public:
SetSellingManagerItemAutomationRuleResponseType()


SetSellingManagerTemplateAutomationRuleRequestType Class

SetSellingManagerTemplateAutomationRuleRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetSellingManagerTemplateAutomationRuleRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetSellingManagerTemplateAutomationRuleRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetSellingManagerTemplateAutomationRuleRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetSellingManagerTemplateAutomationRuleRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | AutomatedListingRule |
 | AutomatedRelistingRule |
 | AutomatedSecondChanceOfferRule |
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SaleTemplateID |
 | SaleTemplateIDSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetSellingManagerTemplateAutomationRuleRequestType


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleRequestType ► AutomatedListingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; set; }
Public Property AutomatedListingRule As SellingManagerAutoListType
    Get
    Set
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
    void set (SellingManagerAutoListType^ value);
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleRequestType ► AutomatedRelistingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; set; }
Public Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
    Set
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
    void set (SellingManagerAutoRelistType^ value);
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleRequestType ► AutomatedSecondChanceOfferRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; set; }
Public Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
    Set
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
    void set (SellingManagerAutoSecondChanceOfferType^ value);
}


SaleTemplateID Property

SaleTemplateID Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleRequestType ► SaleTemplateID
Declaration Syntax
C# Visual Basic Visual C++
public long SaleTemplateID { get; set; }
Public Property SaleTemplateID As Long
    Get
    Set
public:
property long long SaleTemplateID {
    long long get ();
    void set (long long value);
}


SaleTemplateIDSpecified Property

SaleTemplateIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleRequestType ► SaleTemplateIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SaleTemplateIDSpecified { get; set; }
Public Property SaleTemplateIDSpecified As Boolean
    Get
    Set
public:
property bool SaleTemplateIDSpecified {
    bool get ();
    void set (bool value);
}


SetSellingManagerTemplateAutomationRuleRequestType Constructor

SetSellingManagerTemplateAutomationRuleRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleRequestType ► SetSellingManagerTemplateAutomationRuleRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerTemplateAutomationRuleRequestType()
Public Sub New
public:
SetSellingManagerTemplateAutomationRuleRequestType()


SetSellingManagerTemplateAutomationRuleResponseType Class

SetSellingManagerTemplateAutomationRuleResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetSellingManagerTemplateAutomationRuleResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetSellingManagerTemplateAutomationRuleResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetSellingManagerTemplateAutomationRuleResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetSellingManagerTemplateAutomationRuleResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | AutomatedListingRule |
 | AutomatedRelistingRule |
 | AutomatedSecondChanceOfferRule |
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetSellingManagerTemplateAutomationRuleResponseType


AutomatedListingRule Property

AutomatedListingRule Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleResponseType ► AutomatedListingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoListType AutomatedListingRule { get; set; }
Public Property AutomatedListingRule As SellingManagerAutoListType
    Get
    Set
public:
property SellingManagerAutoListType^ AutomatedListingRule {
    SellingManagerAutoListType^ get ();
    void set (SellingManagerAutoListType^ value);
}


AutomatedRelistingRule Property

AutomatedRelistingRule Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleResponseType ► AutomatedRelistingRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoRelistType AutomatedRelistingRule { get; set; }
Public Property AutomatedRelistingRule As SellingManagerAutoRelistType
    Get
    Set
public:
property SellingManagerAutoRelistType^ AutomatedRelistingRule {
    SellingManagerAutoRelistType^ get ();
    void set (SellingManagerAutoRelistType^ value);
}


AutomatedSecondChanceOfferRule Property

AutomatedSecondChanceOfferRule Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleResponseType ► AutomatedSecondChanceOfferRule
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerAutoSecondChanceOfferType AutomatedSecondChanceOfferRule { get; set; }
Public Property AutomatedSecondChanceOfferRule As SellingManagerAutoSecondChanceOfferType
    Get
    Set
public:
property SellingManagerAutoSecondChanceOfferType^ AutomatedSecondChanceOfferRule {
    SellingManagerAutoSecondChanceOfferType^ get ();
    void set (SellingManagerAutoSecondChanceOfferType^ value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


SetSellingManagerTemplateAutomationRuleResponseType Constructor

SetSellingManagerTemplateAutomationRuleResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetSellingManagerTemplateAutomationRuleResponseType ► SetSellingManagerTemplateAutomationRuleResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetSellingManagerTemplateAutomationRuleResponseType()
Public Sub New
public:
SetSellingManagerTemplateAutomationRuleResponseType()


SetShippingDiscountProfilesRequestType Class

SetShippingDiscountProfilesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetShippingDiscountProfilesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetShippingDiscountProfilesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetShippingDiscountProfilesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetShippingDiscountProfilesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CalculatedHandlingDiscount |
 | CalculatedShippingDiscount |
 | CombinedDuration |
 | CombinedDurationSpecified |
 | CurrencyID |
 | CurrencyIDSpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | FlatShippingDiscount |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InternationalShippingInsurance |
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | ModifyActionCode |
 | ModifyActionCodeSpecified |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | PromotionalShippingDiscountDetails |
 | ShippingInsurance |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetShippingDiscountProfilesRequestType


CalculatedHandlingDiscount Property

CalculatedHandlingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► CalculatedHandlingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedHandlingDiscountType CalculatedHandlingDiscount { get; set; }
Public Property CalculatedHandlingDiscount As CalculatedHandlingDiscountType
    Get
    Set
public:
property CalculatedHandlingDiscountType^ CalculatedHandlingDiscount {
    CalculatedHandlingDiscountType^ get ();
    void set (CalculatedHandlingDiscountType^ value);
}


CalculatedShippingDiscount Property

CalculatedShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► CalculatedShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingDiscountType CalculatedShippingDiscount { get; set; }
Public Property CalculatedShippingDiscount As CalculatedShippingDiscountType
    Get
    Set
public:
property CalculatedShippingDiscountType^ CalculatedShippingDiscount {
    CalculatedShippingDiscountType^ get ();
    void set (CalculatedShippingDiscountType^ value);
}


CombinedDuration Property

CombinedDuration Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► CombinedDuration
Declaration Syntax
C# Visual Basic Visual C++
public CombinedPaymentPeriodCodeType CombinedDuration { get; set; }
Public Property CombinedDuration As CombinedPaymentPeriodCodeType
    Get
    Set
public:
property CombinedPaymentPeriodCodeType CombinedDuration {
    CombinedPaymentPeriodCodeType get ();
    void set (CombinedPaymentPeriodCodeType value);
}


CombinedDurationSpecified Property

CombinedDurationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► CombinedDurationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CombinedDurationSpecified { get; set; }
Public Property CombinedDurationSpecified As Boolean
    Get
    Set
public:
property bool CombinedDurationSpecified {
    bool get ();
    void set (bool value);
}


CurrencyID Property

CurrencyID Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► CurrencyID
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyCodeType CurrencyID { get; set; }
Public Property CurrencyID As CurrencyCodeType
    Get
    Set
public:
property CurrencyCodeType CurrencyID {
    CurrencyCodeType get ();
    void set (CurrencyCodeType value);
}


CurrencyIDSpecified Property

CurrencyIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► CurrencyIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CurrencyIDSpecified { get; set; }
Public Property CurrencyIDSpecified As Boolean
    Get
    Set
public:
property bool CurrencyIDSpecified {
    bool get ();
    void set (bool value);
}


FlatShippingDiscount Property

FlatShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► FlatShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public FlatShippingDiscountType FlatShippingDiscount { get; set; }
Public Property FlatShippingDiscount As FlatShippingDiscountType
    Get
    Set
public:
property FlatShippingDiscountType^ FlatShippingDiscount {
    FlatShippingDiscountType^ get ();
    void set (FlatShippingDiscountType^ value);
}


InternationalShippingInsurance Property

InternationalShippingInsurance Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► InternationalShippingInsurance
Declaration Syntax
C# Visual Basic Visual C++
public ShippingInsuranceType InternationalShippingInsurance { get; set; }
Public Property InternationalShippingInsurance As ShippingInsuranceType
    Get
    Set
public:
property ShippingInsuranceType^ InternationalShippingInsurance {
    ShippingInsuranceType^ get ();
    void set (ShippingInsuranceType^ value);
}


ModifyActionCode Property

ModifyActionCode Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► ModifyActionCode
Declaration Syntax
C# Visual Basic Visual C++
public ModifyActionCodeType ModifyActionCode { get; set; }
Public Property ModifyActionCode As ModifyActionCodeType
    Get
    Set
public:
property ModifyActionCodeType ModifyActionCode {
    ModifyActionCodeType get ();
    void set (ModifyActionCodeType value);
}


ModifyActionCodeSpecified Property

ModifyActionCodeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► ModifyActionCodeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ModifyActionCodeSpecified { get; set; }
Public Property ModifyActionCodeSpecified As Boolean
    Get
    Set
public:
property bool ModifyActionCodeSpecified {
    bool get ();
    void set (bool value);
}


PromotionalShippingDiscountDetails Property

PromotionalShippingDiscountDetails Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► PromotionalShippingDiscountDetails
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalShippingDiscountDetailsType PromotionalShippingDiscountDetails { get; set; }
Public Property PromotionalShippingDiscountDetails As PromotionalShippingDiscountDetailsType
    Get
    Set
public:
property PromotionalShippingDiscountDetailsType^ PromotionalShippingDiscountDetails {
    PromotionalShippingDiscountDetailsType^ get ();
    void set (PromotionalShippingDiscountDetailsType^ value);
}


SetShippingDiscountProfilesRequestType Constructor

SetShippingDiscountProfilesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► SetShippingDiscountProfilesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetShippingDiscountProfilesRequestType()
Public Sub New
public:
SetShippingDiscountProfilesRequestType()


ShippingInsurance Property

ShippingInsurance Property
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesRequestType ► ShippingInsurance
Declaration Syntax
C# Visual Basic Visual C++
public ShippingInsuranceType ShippingInsurance { get; set; }
Public Property ShippingInsurance As ShippingInsuranceType
    Get
    Set
public:
property ShippingInsuranceType^ ShippingInsurance {
    ShippingInsuranceType^ get ();
    void set (ShippingInsuranceType^ value);
}


SetShippingDiscountProfilesResponseType Class

SetShippingDiscountProfilesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetShippingDiscountProfilesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetShippingDiscountProfilesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetShippingDiscountProfilesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetShippingDiscountProfilesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetShippingDiscountProfilesResponseType


SetShippingDiscountProfilesResponseType Constructor

SetShippingDiscountProfilesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetShippingDiscountProfilesResponseType ► SetShippingDiscountProfilesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetShippingDiscountProfilesResponseType()
Public Sub New
public:
SetShippingDiscountProfilesResponseType()


SetStoreCategoriesRequestType Class

SetStoreCategoriesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetStoreCategoriesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetStoreCategoriesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetStoreCategoriesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStoreCategoriesRequestType()()()() |
 | Action |
 | ActionSpecified |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DestinationParentCategoryID |
 | DestinationParentCategoryIDSpecified |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemDestinationCategoryID |
 | ItemDestinationCategoryIDSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | StoreCategories |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetStoreCategoriesRequestType


Action Property

Action Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesRequestType ► Action
Declaration Syntax
C# Visual Basic Visual C++
public StoreCategoryUpdateActionCodeType Action { get; set; }
Public Property Action As StoreCategoryUpdateActionCodeType
    Get
    Set
public:
property StoreCategoryUpdateActionCodeType Action {
    StoreCategoryUpdateActionCodeType get ();
    void set (StoreCategoryUpdateActionCodeType value);
}


ActionSpecified Property

ActionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesRequestType ► ActionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ActionSpecified { get; set; }
Public Property ActionSpecified As Boolean
    Get
    Set
public:
property bool ActionSpecified {
    bool get ();
    void set (bool value);
}


DestinationParentCategoryID Property

DestinationParentCategoryID Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesRequestType ► DestinationParentCategoryID
Declaration Syntax
C# Visual Basic Visual C++
public long DestinationParentCategoryID { get; set; }
Public Property DestinationParentCategoryID As Long
    Get
    Set
public:
property long long DestinationParentCategoryID {
    long long get ();
    void set (long long value);
}


DestinationParentCategoryIDSpecified Property

DestinationParentCategoryIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesRequestType ► DestinationParentCategoryIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DestinationParentCategoryIDSpecified { get; set; }
Public Property DestinationParentCategoryIDSpecified As Boolean
    Get
    Set
public:
property bool DestinationParentCategoryIDSpecified {
    bool get ();
    void set (bool value);
}


ItemDestinationCategoryID Property

ItemDestinationCategoryID Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesRequestType ► ItemDestinationCategoryID
Declaration Syntax
C# Visual Basic Visual C++
public long ItemDestinationCategoryID { get; set; }
Public Property ItemDestinationCategoryID As Long
    Get
    Set
public:
property long long ItemDestinationCategoryID {
    long long get ();
    void set (long long value);
}


ItemDestinationCategoryIDSpecified Property

ItemDestinationCategoryIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesRequestType ► ItemDestinationCategoryIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemDestinationCategoryIDSpecified { get; set; }
Public Property ItemDestinationCategoryIDSpecified As Boolean
    Get
    Set
public:
property bool ItemDestinationCategoryIDSpecified {
    bool get ();
    void set (bool value);
}


SetStoreCategoriesRequestType Constructor

SetStoreCategoriesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesRequestType ► SetStoreCategoriesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCategoriesRequestType()
Public Sub New
public:
SetStoreCategoriesRequestType()


StoreCategories Property

StoreCategories Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesRequestType ► StoreCategories
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryTypeCollection StoreCategories { get; set; }
Public Property StoreCategories As StoreCustomCategoryTypeCollection
    Get
    Set
public:
property StoreCustomCategoryTypeCollection^ StoreCategories {
    StoreCustomCategoryTypeCollection^ get ();
    void set (StoreCustomCategoryTypeCollection^ value);
}


SetStoreCategoriesResponseType Class

SetStoreCategoriesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetStoreCategoriesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetStoreCategoriesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetStoreCategoriesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStoreCategoriesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | CustomCategory |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Status |
 | StatusSpecified |
 | TaskID |
 | TaskIDSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetStoreCategoriesResponseType


CustomCategory Property

CustomCategory Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesResponseType ► CustomCategory
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryTypeCollection CustomCategory { get; set; }
Public Property CustomCategory As StoreCustomCategoryTypeCollection
    Get
    Set
public:
property StoreCustomCategoryTypeCollection^ CustomCategory {
    StoreCustomCategoryTypeCollection^ get ();
    void set (StoreCustomCategoryTypeCollection^ value);
}


SetStoreCategoriesResponseType Constructor

SetStoreCategoriesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesResponseType ► SetStoreCategoriesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCategoriesResponseType()
Public Sub New
public:
SetStoreCategoriesResponseType()


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesResponseType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public TaskStatusCodeType Status { get; set; }
Public Property Status As TaskStatusCodeType
    Get
    Set
public:
property TaskStatusCodeType Status {
    TaskStatusCodeType get ();
    void set (TaskStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesResponseType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


TaskID Property

TaskID Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesResponseType ► TaskID
Declaration Syntax
C# Visual Basic Visual C++
public long TaskID { get; set; }
Public Property TaskID As Long
    Get
    Set
public:
property long long TaskID {
    long long get ();
    void set (long long value);
}


TaskIDSpecified Property

TaskIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCategoriesResponseType ► TaskIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TaskIDSpecified { get; set; }
Public Property TaskIDSpecified As Boolean
    Get
    Set
public:
property bool TaskIDSpecified {
    bool get ();
    void set (bool value);
}


SetStoreCustomPageRequestType Class

SetStoreCustomPageRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetStoreCustomPageRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetStoreCustomPageRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetStoreCustomPageRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetStoreCustomPageRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStoreCustomPageRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | CustomPage |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetStoreCustomPageRequestType


CustomPage Property

CustomPage Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCustomPageRequestType ► CustomPage
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageType CustomPage { get; set; }
Public Property CustomPage As StoreCustomPageType
    Get
    Set
public:
property StoreCustomPageType^ CustomPage {
    StoreCustomPageType^ get ();
    void set (StoreCustomPageType^ value);
}


SetStoreCustomPageRequestType Constructor

SetStoreCustomPageRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetStoreCustomPageRequestType ► SetStoreCustomPageRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCustomPageRequestType()
Public Sub New
public:
SetStoreCustomPageRequestType()


SetStoreCustomPageResponseType Class

SetStoreCustomPageResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetStoreCustomPageResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetStoreCustomPageResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetStoreCustomPageResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetStoreCustomPageResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStoreCustomPageResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | CustomPage |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetStoreCustomPageResponseType


CustomPage Property

CustomPage Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreCustomPageResponseType ► CustomPage
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageType CustomPage { get; set; }
Public Property CustomPage As StoreCustomPageType
    Get
    Set
public:
property StoreCustomPageType^ CustomPage {
    StoreCustomPageType^ get ();
    void set (StoreCustomPageType^ value);
}


SetStoreCustomPageResponseType Constructor

SetStoreCustomPageResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetStoreCustomPageResponseType ► SetStoreCustomPageResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreCustomPageResponseType()
Public Sub New
public:
SetStoreCustomPageResponseType()


SetStorePreferencesRequestType Class

SetStorePreferencesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetStorePreferencesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetStorePreferencesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetStorePreferencesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetStorePreferencesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStorePreferencesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | StorePreferences |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetStorePreferencesRequestType


SetStorePreferencesRequestType Constructor

SetStorePreferencesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetStorePreferencesRequestType ► SetStorePreferencesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStorePreferencesRequestType()
Public Sub New
public:
SetStorePreferencesRequestType()


StorePreferences Property

StorePreferences Property
Namespaces ► eBay.Service.Core.Soap ► SetStorePreferencesRequestType ► StorePreferences
Declaration Syntax
C# Visual Basic Visual C++
public StorePreferencesType StorePreferences { get; set; }
Public Property StorePreferences As StorePreferencesType
    Get
    Set
public:
property StorePreferencesType^ StorePreferences {
    StorePreferencesType^ get ();
    void set (StorePreferencesType^ value);
}


SetStorePreferencesResponseType Class

SetStorePreferencesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetStorePreferencesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetStorePreferencesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetStorePreferencesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetStorePreferencesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStorePreferencesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetStorePreferencesResponseType


SetStorePreferencesResponseType Constructor

SetStorePreferencesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetStorePreferencesResponseType ► SetStorePreferencesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStorePreferencesResponseType()
Public Sub New
public:
SetStorePreferencesResponseType()


SetStoreRequestType Class

SetStoreRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetStoreRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetStoreRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetStoreRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetStoreRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStoreRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | Store |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetStoreRequestType


SetStoreRequestType Constructor

SetStoreRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetStoreRequestType ► SetStoreRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreRequestType()
Public Sub New
public:
SetStoreRequestType()


Store Property

Store Property
Namespaces ► eBay.Service.Core.Soap ► SetStoreRequestType ► Store
Declaration Syntax
C# Visual Basic Visual C++
public StoreType Store { get; set; }
Public Property Store As StoreType
    Get
    Set
public:
property StoreType^ Store {
    StoreType^ get ();
    void set (StoreType^ value);
}


SetStoreResponseType Class

SetStoreResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetStoreResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetStoreResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetStoreResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetStoreResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetStoreResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetStoreResponseType


SetStoreResponseType Constructor

SetStoreResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetStoreResponseType ► SetStoreResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetStoreResponseType()
Public Sub New
public:
SetStoreResponseType()


SetTaxTableRequestType Class

SetTaxTableRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetTaxTableRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetTaxTableRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetTaxTableRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetTaxTableRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetTaxTableRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | TaxTable |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetTaxTableRequestType


SetTaxTableRequestType Constructor

SetTaxTableRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetTaxTableRequestType ► SetTaxTableRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetTaxTableRequestType()
Public Sub New
public:
SetTaxTableRequestType()


TaxTable Property

TaxTable Property
Namespaces ► eBay.Service.Core.Soap ► SetTaxTableRequestType ► TaxTable
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection TaxTable { get; set; }
Public Property TaxTable As TaxJurisdictionTypeCollection
    Get
    Set
public:
property TaxJurisdictionTypeCollection^ TaxTable {
    TaxJurisdictionTypeCollection^ get ();
    void set (TaxJurisdictionTypeCollection^ value);
}


SetTaxTableResponseType Class

SetTaxTableResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetTaxTableResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetTaxTableResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetTaxTableResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetTaxTableResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetTaxTableResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetTaxTableResponseType


SetTaxTableResponseType Constructor

SetTaxTableResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetTaxTableResponseType ► SetTaxTableResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetTaxTableResponseType()
Public Sub New
public:
SetTaxTableResponseType()


SetUserNotesActionCodeType Enumeration

SetUserNotesActionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesActionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SetUserNotesActionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SetUserNotesActionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SetUserNotesActionCodeType
Members
Member | Description
AddOrUpdate |
Delete |
CustomCode |
Remarks


SetUserNotesRequestType Class

SetUserNotesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetUserNotesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetUserNotesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetUserNotesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetUserNotesRequestType()()()() |
 | Action |
 | ActionSpecified |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | NoteText |
 | OrderLineItemID |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | SKU |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | VariationSpecifics |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetUserNotesRequestType


Action Property

Action Property
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesRequestType ► Action
Declaration Syntax
C# Visual Basic Visual C++
public SetUserNotesActionCodeType Action { get; set; }
Public Property Action As SetUserNotesActionCodeType
    Get
    Set
public:
property SetUserNotesActionCodeType Action {
    SetUserNotesActionCodeType get ();
    void set (SetUserNotesActionCodeType value);
}


ActionSpecified Property

ActionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesRequestType ► ActionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ActionSpecified { get; set; }
Public Property ActionSpecified As Boolean
    Get
    Set
public:
property bool ActionSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


NoteText Property

NoteText Property
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesRequestType ► NoteText
Declaration Syntax
C# Visual Basic Visual C++
public string NoteText { get; set; }
Public Property NoteText As String
    Get
    Set
public:
property String^ NoteText {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesRequestType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


SetUserNotesRequestType Constructor

SetUserNotesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesRequestType ► SetUserNotesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetUserNotesRequestType()
Public Sub New
public:
SetUserNotesRequestType()


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesRequestType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesRequestType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


VariationSpecifics Property

VariationSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesRequestType ► VariationSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection VariationSpecifics { get; set; }
Public Property VariationSpecifics As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ VariationSpecifics {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


SetUserNotesResponseType Class

SetUserNotesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetUserNotesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetUserNotesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetUserNotesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetUserNotesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetUserNotesResponseType


SetUserNotesResponseType Constructor

SetUserNotesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetUserNotesResponseType ► SetUserNotesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetUserNotesResponseType()
Public Sub New
public:
SetUserNotesResponseType()


SetUserPreferencesRequestType Class

SetUserPreferencesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetUserPreferencesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetUserPreferencesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetUserPreferencesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetUserPreferencesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BidderNoticePreferences |
 | BotBlock | (Inherited from AbstractRequestType.)
 | CombinedPaymentPreferences |
 | CrossPromotionPreferences |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | DispatchCutoffTimePreference |
 | EmailShipmentTrackingNumberPreference |
 | EmailShipmentTrackingNumberPreferenceSpecified |
 | EndOfAuctionEmailPreferences |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalShippingProgramListingPreference |
 | GlobalShippingProgramListingPreferenceSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutOfStockControlPreference |
 | OutOfStockControlPreferenceSpecified |
 | OutputSelector | (Inherited from AbstractRequestType.)
 | OverrideGSPserviceWithIntlService |
 | OverrideGSPserviceWithIntlServiceSpecified |
 | PurchaseReminderEmailPreferences |
 | RequiredShipPhoneNumberPreference |
 | RequiredShipPhoneNumberPreferenceSpecified |
 | SellerFavoriteItemPreferences |
 | SellerPaymentPreferences |
 | SellerThirdPartyCheckoutDisabled |
 | SellerThirdPartyCheckoutDisabledSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UnpaidItemAssistancePreferences |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | SetUserPreferencesRequestType


BidderNoticePreferences Property

BidderNoticePreferences Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► BidderNoticePreferences
Declaration Syntax
C# Visual Basic Visual C++
public BidderNoticePreferencesType BidderNoticePreferences { get; set; }
Public Property BidderNoticePreferences As BidderNoticePreferencesType
    Get
    Set
public:
property BidderNoticePreferencesType^ BidderNoticePreferences {
    BidderNoticePreferencesType^ get ();
    void set (BidderNoticePreferencesType^ value);
}


CombinedPaymentPreferences Property

CombinedPaymentPreferences Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► CombinedPaymentPreferences
Declaration Syntax
C# Visual Basic Visual C++
public CombinedPaymentPreferencesType CombinedPaymentPreferences { get; set; }
Public Property CombinedPaymentPreferences As CombinedPaymentPreferencesType
    Get
    Set
public:
property CombinedPaymentPreferencesType^ CombinedPaymentPreferences {
    CombinedPaymentPreferencesType^ get ();
    void set (CombinedPaymentPreferencesType^ value);
}


CrossPromotionPreferences Property

CrossPromotionPreferences Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► CrossPromotionPreferences
Declaration Syntax
C# Visual Basic Visual C++
public CrossPromotionPreferencesType CrossPromotionPreferences { get; set; }
Public Property CrossPromotionPreferences As CrossPromotionPreferencesType
    Get
    Set
public:
property CrossPromotionPreferencesType^ CrossPromotionPreferences {
    CrossPromotionPreferencesType^ get ();
    void set (CrossPromotionPreferencesType^ value);
}


DispatchCutoffTimePreference Property

DispatchCutoffTimePreference Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► DispatchCutoffTimePreference
Declaration Syntax
C# Visual Basic Visual C++
public DispatchCutoffTimePreferencesType DispatchCutoffTimePreference { get; set; }
Public Property DispatchCutoffTimePreference As DispatchCutoffTimePreferencesType
    Get
    Set
public:
property DispatchCutoffTimePreferencesType^ DispatchCutoffTimePreference {
    DispatchCutoffTimePreferencesType^ get ();
    void set (DispatchCutoffTimePreferencesType^ value);
}


EmailShipmentTrackingNumberPreference Property

EmailShipmentTrackingNumberPreference Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► EmailShipmentTrackingNumberPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailShipmentTrackingNumberPreference { get; set; }
Public Property EmailShipmentTrackingNumberPreference As Boolean
    Get
    Set
public:
property bool EmailShipmentTrackingNumberPreference {
    bool get ();
    void set (bool value);
}


EmailShipmentTrackingNumberPreferenceSpecified Property

EmailShipmentTrackingNumberPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► EmailShipmentTrackingNumberPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EmailShipmentTrackingNumberPreferenceSpecified { get; set; }
Public Property EmailShipmentTrackingNumberPreferenceSpecified As Boolean
    Get
    Set
public:
property bool EmailShipmentTrackingNumberPreferenceSpecified {
    bool get ();
    void set (bool value);
}


EndOfAuctionEmailPreferences Property

EndOfAuctionEmailPreferences Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► EndOfAuctionEmailPreferences
Declaration Syntax
C# Visual Basic Visual C++
public EndOfAuctionEmailPreferencesType EndOfAuctionEmailPreferences { get; set; }
Public Property EndOfAuctionEmailPreferences As EndOfAuctionEmailPreferencesType
    Get
    Set
public:
property EndOfAuctionEmailPreferencesType^ EndOfAuctionEmailPreferences {
    EndOfAuctionEmailPreferencesType^ get ();
    void set (EndOfAuctionEmailPreferencesType^ value);
}


GlobalShippingProgramListingPreference Property

GlobalShippingProgramListingPreference Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► GlobalShippingProgramListingPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShippingProgramListingPreference { get; set; }
Public Property GlobalShippingProgramListingPreference As Boolean
    Get
    Set
public:
property bool GlobalShippingProgramListingPreference {
    bool get ();
    void set (bool value);
}


GlobalShippingProgramListingPreferenceSpecified Property

GlobalShippingProgramListingPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► GlobalShippingProgramListingPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShippingProgramListingPreferenceSpecified { get; set; }
Public Property GlobalShippingProgramListingPreferenceSpecified As Boolean
    Get
    Set
public:
property bool GlobalShippingProgramListingPreferenceSpecified {
    bool get ();
    void set (bool value);
}


OutOfStockControlPreference Property

OutOfStockControlPreference Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► OutOfStockControlPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool OutOfStockControlPreference { get; set; }
Public Property OutOfStockControlPreference As Boolean
    Get
    Set
public:
property bool OutOfStockControlPreference {
    bool get ();
    void set (bool value);
}


OutOfStockControlPreferenceSpecified Property

OutOfStockControlPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► OutOfStockControlPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OutOfStockControlPreferenceSpecified { get; set; }
Public Property OutOfStockControlPreferenceSpecified As Boolean
    Get
    Set
public:
property bool OutOfStockControlPreferenceSpecified {
    bool get ();
    void set (bool value);
}


OverrideGSPserviceWithIntlService Property

OverrideGSPserviceWithIntlService Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► OverrideGSPserviceWithIntlService
Declaration Syntax
C# Visual Basic Visual C++
public bool OverrideGSPserviceWithIntlService { get; set; }
Public Property OverrideGSPserviceWithIntlService As Boolean
    Get
    Set
public:
property bool OverrideGSPserviceWithIntlService {
    bool get ();
    void set (bool value);
}


OverrideGSPserviceWithIntlServiceSpecified Property

OverrideGSPserviceWithIntlServiceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► OverrideGSPserviceWithIntlServiceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OverrideGSPserviceWithIntlServiceSpecified { get; set; }
Public Property OverrideGSPserviceWithIntlServiceSpecified As Boolean
    Get
    Set
public:
property bool OverrideGSPserviceWithIntlServiceSpecified {
    bool get ();
    void set (bool value);
}


PurchaseReminderEmailPreferences Property

PurchaseReminderEmailPreferences Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► PurchaseReminderEmailPreferences
Declaration Syntax
C# Visual Basic Visual C++
public PurchaseReminderEmailPreferencesType PurchaseReminderEmailPreferences { get; set; }
Public Property PurchaseReminderEmailPreferences As PurchaseReminderEmailPreferencesType
    Get
    Set
public:
property PurchaseReminderEmailPreferencesType^ PurchaseReminderEmailPreferences {
    PurchaseReminderEmailPreferencesType^ get ();
    void set (PurchaseReminderEmailPreferencesType^ value);
}


RequiredShipPhoneNumberPreference Property

RequiredShipPhoneNumberPreference Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► RequiredShipPhoneNumberPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool RequiredShipPhoneNumberPreference { get; set; }
Public Property RequiredShipPhoneNumberPreference As Boolean
    Get
    Set
public:
property bool RequiredShipPhoneNumberPreference {
    bool get ();
    void set (bool value);
}


RequiredShipPhoneNumberPreferenceSpecified Property

RequiredShipPhoneNumberPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► RequiredShipPhoneNumberPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RequiredShipPhoneNumberPreferenceSpecified { get; set; }
Public Property RequiredShipPhoneNumberPreferenceSpecified As Boolean
    Get
    Set
public:
property bool RequiredShipPhoneNumberPreferenceSpecified {
    bool get ();
    void set (bool value);
}


SellerFavoriteItemPreferences Property

SellerFavoriteItemPreferences Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► SellerFavoriteItemPreferences
Declaration Syntax
C# Visual Basic Visual C++
public SellerFavoriteItemPreferencesType SellerFavoriteItemPreferences { get; set; }
Public Property SellerFavoriteItemPreferences As SellerFavoriteItemPreferencesType
    Get
    Set
public:
property SellerFavoriteItemPreferencesType^ SellerFavoriteItemPreferences {
    SellerFavoriteItemPreferencesType^ get ();
    void set (SellerFavoriteItemPreferencesType^ value);
}


SellerPaymentPreferences Property

SellerPaymentPreferences Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► SellerPaymentPreferences
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentPreferencesType SellerPaymentPreferences { get; set; }
Public Property SellerPaymentPreferences As SellerPaymentPreferencesType
    Get
    Set
public:
property SellerPaymentPreferencesType^ SellerPaymentPreferences {
    SellerPaymentPreferencesType^ get ();
    void set (SellerPaymentPreferencesType^ value);
}


SellerThirdPartyCheckoutDisabled Property

SellerThirdPartyCheckoutDisabled Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► SellerThirdPartyCheckoutDisabled
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerThirdPartyCheckoutDisabled { get; set; }
Public Property SellerThirdPartyCheckoutDisabled As Boolean
    Get
    Set
public:
property bool SellerThirdPartyCheckoutDisabled {
    bool get ();
    void set (bool value);
}


SellerThirdPartyCheckoutDisabledSpecified Property

SellerThirdPartyCheckoutDisabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► SellerThirdPartyCheckoutDisabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerThirdPartyCheckoutDisabledSpecified { get; set; }
Public Property SellerThirdPartyCheckoutDisabledSpecified As Boolean
    Get
    Set
public:
property bool SellerThirdPartyCheckoutDisabledSpecified {
    bool get ();
    void set (bool value);
}


SetUserPreferencesRequestType Constructor

SetUserPreferencesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► SetUserPreferencesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetUserPreferencesRequestType()
Public Sub New
public:
SetUserPreferencesRequestType()


UnpaidItemAssistancePreferences Property

UnpaidItemAssistancePreferences Property
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesRequestType ► UnpaidItemAssistancePreferences
Declaration Syntax
C# Visual Basic Visual C++
public UnpaidItemAssistancePreferencesType UnpaidItemAssistancePreferences { get; set; }
Public Property UnpaidItemAssistancePreferences As UnpaidItemAssistancePreferencesType
    Get
    Set
public:
property UnpaidItemAssistancePreferencesType^ UnpaidItemAssistancePreferences {
    UnpaidItemAssistancePreferencesType^ get ();
    void set (UnpaidItemAssistancePreferencesType^ value);
}


SetUserPreferencesResponseType Class

SetUserPreferencesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SetUserPreferencesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SetUserPreferencesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SetUserPreferencesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetUserPreferencesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | SetUserPreferencesResponseType


SetUserPreferencesResponseType Constructor

SetUserPreferencesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► SetUserPreferencesResponseType ► SetUserPreferencesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SetUserPreferencesResponseType()
Public Sub New
public:
SetUserPreferencesResponseType()


SeverityCodeType Enumeration

SeverityCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SeverityCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SeverityCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SeverityCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SeverityCodeType
Members
Member | Description
Warning |
Error |
CustomCode |
Remarks


ShipmentDeliveryStatusCodeType Enumeration

ShipmentDeliveryStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ShipmentDeliveryStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ShipmentDeliveryStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ShipmentDeliveryStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ShipmentDeliveryStatusCodeType
Members
Member | Description
Created |
DroppedOff |
InTransit |
Delivered |
Returned |
Canceled |
LabelPrinted |
Unconfirmed |
Unknown |
Error |
CustomCode |
Remarks


ShipmentLineItemType Class

ShipmentLineItemType Class
Namespaces ► eBay.Service.Core.Soap ► ShipmentLineItemType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShipmentLineItemType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShipmentLineItemType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShipmentLineItemType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShipmentLineItemType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LineItem |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShipmentLineItemType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentLineItemType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LineItem Property

LineItem Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentLineItemType ► LineItem
Declaration Syntax
C# Visual Basic Visual C++
public LineItemTypeCollection LineItem { get; set; }
Public Property LineItem As LineItemTypeCollection
    Get
    Set
public:
property LineItemTypeCollection^ LineItem {
    LineItemTypeCollection^ get ();
    void set (LineItemTypeCollection^ value);
}


ShipmentLineItemType Constructor

ShipmentLineItemType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShipmentLineItemType ► ShipmentLineItemType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentLineItemType()
Public Sub New
public:
ShipmentLineItemType()


ShipmentStatusCodeType Enumeration

ShipmentStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ShipmentStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ShipmentStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ShipmentStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ShipmentStatusCodeType
Members
Member | Description
Active |
Canceled |
CustomCode |
Remarks


ShipmentTrackingDetailsType Class

ShipmentTrackingDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShipmentTrackingDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShipmentTrackingDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShipmentTrackingDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShipmentTrackingDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShipmentLineItem |
 | ShipmentTrackingNumber |
 | ShippingCarrierUsed |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShipmentTrackingDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ShipmentLineItem Property

ShipmentLineItem Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsType ► ShipmentLineItem
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentLineItemType ShipmentLineItem { get; set; }
Public Property ShipmentLineItem As ShipmentLineItemType
    Get
    Set
public:
property ShipmentLineItemType^ ShipmentLineItem {
    ShipmentLineItemType^ get ();
    void set (ShipmentLineItemType^ value);
}


ShipmentTrackingDetailsType Constructor

ShipmentTrackingDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsType ► ShipmentTrackingDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentTrackingDetailsType()
Public Sub New
public:
ShipmentTrackingDetailsType()


ShipmentTrackingNumber Property

ShipmentTrackingNumber Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsType ► ShipmentTrackingNumber
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentTrackingNumber { get; set; }
Public Property ShipmentTrackingNumber As String
    Get
    Set
public:
property String^ ShipmentTrackingNumber {
    String^ get ();
    void set (String^ value);
}


ShippingCarrierUsed Property

ShippingCarrierUsed Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsType ► ShippingCarrierUsed
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingCarrierUsed { get; set; }
Public Property ShippingCarrierUsed As String
    Get
    Set
public:
property String^ ShippingCarrierUsed {
    String^ get ();
    void set (String^ value);
}


ShipmentTrackingDetailsTypeCollection Class

ShipmentTrackingDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShipmentTrackingDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShipmentTrackingDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShipmentTrackingDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShipmentTrackingDetailsTypeCollection()()()() |
 | ShipmentTrackingDetailsTypeCollection(array<ShipmentTrackingDetailsType>[]()[][]) |
 | ShipmentTrackingDetailsTypeCollection(ShipmentTrackingDetailsTypeCollection) |
 | Add(ShipmentTrackingDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShipmentTrackingDetailsType>[]()[][]) |
 | AddRange(ShipmentTrackingDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShipmentTrackingDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShipmentTrackingDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShipmentTrackingDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShipmentTrackingDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShipmentTrackingDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShipmentTrackingDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► Add(ShipmentTrackingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShipmentTrackingDetailsType item
)
Public Function Add ( _
    item As ShipmentTrackingDetailsType _
) As Integer
public:
int Add(
    ShipmentTrackingDetailsType^ item
)
Parameters
item (ShipmentTrackingDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShipmentTrackingDetailsType>[]()[][]) |
 | AddRange(ShipmentTrackingDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► AddRange(array<ShipmentTrackingDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShipmentTrackingDetailsType[] items
)
Public Sub AddRange ( _
    items As ShipmentTrackingDetailsType() _
)
public:
void AddRange(
    array<ShipmentTrackingDetailsType^>^ items
)
Parameters
items (array< ShipmentTrackingDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► AddRange(ShipmentTrackingDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShipmentTrackingDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ShipmentTrackingDetailsTypeCollection _
)
public:
void AddRange(
    ShipmentTrackingDetailsTypeCollection^ items
)
Parameters
items (ShipmentTrackingDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► Contains(ShipmentTrackingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShipmentTrackingDetailsType item
)
Public Function Contains ( _
    item As ShipmentTrackingDetailsType _
) As Boolean
public:
bool Contains(
    ShipmentTrackingDetailsType^ item
)
Parameters
item (ShipmentTrackingDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► CopyTo(array<ShipmentTrackingDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShipmentTrackingDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShipmentTrackingDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShipmentTrackingDetailsType^>^ items,
    int index
)
Parameters
items (array< ShipmentTrackingDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► IndexOf(ShipmentTrackingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShipmentTrackingDetailsType item
)
Public Function IndexOf ( _
    item As ShipmentTrackingDetailsType _
) As Integer
public:
int IndexOf(
    ShipmentTrackingDetailsType^ item
)
Parameters
item (ShipmentTrackingDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► Insert(Int32, ShipmentTrackingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShipmentTrackingDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShipmentTrackingDetailsType _
)
public:
void Insert(
    int index,
    ShipmentTrackingDetailsType^ item
)
Parameters
index (Int32)
item (ShipmentTrackingDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentTrackingDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShipmentTrackingDetailsType
    Get
    Set
public:
property ShipmentTrackingDetailsType^ default[int index] {
    ShipmentTrackingDetailsType^ get (int index);
    void set (int index, ShipmentTrackingDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentTrackingDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShipmentTrackingDetailsType
public:
ShipmentTrackingDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► Remove(ShipmentTrackingDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShipmentTrackingDetailsType item
)
Public Sub Remove ( _
    item As ShipmentTrackingDetailsType _
)
public:
void Remove(
    ShipmentTrackingDetailsType^ item
)
Parameters
item (ShipmentTrackingDetailsType)


ShipmentTrackingDetailsTypeCollection Constructor

ShipmentTrackingDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► ShipmentTrackingDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ShipmentTrackingDetailsTypeCollection()()()() |
 | ShipmentTrackingDetailsTypeCollection(array<ShipmentTrackingDetailsType>[]()[][]) |
 | ShipmentTrackingDetailsTypeCollection(ShipmentTrackingDetailsTypeCollection) |


ShipmentTrackingDetailsTypeCollection Constructor

ShipmentTrackingDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► ShipmentTrackingDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentTrackingDetailsTypeCollection()
Public Sub New
public:
ShipmentTrackingDetailsTypeCollection()


ShipmentTrackingDetailsTypeCollection Constructor (items)

ShipmentTrackingDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► ShipmentTrackingDetailsTypeCollection(array<ShipmentTrackingDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentTrackingDetailsTypeCollection(
    ShipmentTrackingDetailsType[] items
)
Public Sub New ( _
    items As ShipmentTrackingDetailsType() _
)
public:
ShipmentTrackingDetailsTypeCollection(
    array<ShipmentTrackingDetailsType^>^ items
)
Parameters
items (array< ShipmentTrackingDetailsType >[]()[][])


ShipmentTrackingDetailsTypeCollection Constructor (items)

ShipmentTrackingDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► ShipmentTrackingDetailsTypeCollection(ShipmentTrackingDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentTrackingDetailsTypeCollection(
    ShipmentTrackingDetailsTypeCollection items
)
Public Sub New ( _
    items As ShipmentTrackingDetailsTypeCollection _
)
public:
ShipmentTrackingDetailsTypeCollection(
    ShipmentTrackingDetailsTypeCollection^ items
)
Parameters
items (ShipmentTrackingDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentTrackingDetailsType[] ToArray()
Public Function ToArray As ShipmentTrackingDetailsType()
public:
array<ShipmentTrackingDetailsType^>^ ToArray()
Return Value


ShipmentType Class

ShipmentType Class
Namespaces ► eBay.Service.Core.Soap ► ShipmentType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShipmentType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShipmentType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShipmentType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShipmentType()()()() |
 | Any |
 | DeliveryDate |
 | DeliveryDateSpecified |
 | DeliveryStatus |
 | DeliveryStatusSpecified |
 | Equals(Object) | (Inherited from Object.)
 | EstimatedDeliveryDate |
 | EstimatedDeliveryDateSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InsuredValue |
 | ItemTransactionID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Notes |
 | PackageDepth |
 | PackageLength |
 | PackageWidth |
 | PayPalShipmentID |
 | PostageTotal |
 | PrintedTime |
 | PrintedTimeSpecified |
 | RefundGrantedTime |
 | RefundGrantedTimeSpecified |
 | RefundRequestedTime |
 | RefundRequestedTimeSpecified |
 | ShipFromAddress |
 | ShipmentID |
 | ShipmentIDSpecified |
 | ShipmentLineItem |
 | ShipmentTrackingDetails |
 | ShipmentTrackingNumber |
 | ShippedTime |
 | ShippedTimeSpecified |
 | ShippingAddress |
 | ShippingCarrierUsed |
 | ShippingFeature |
 | ShippingPackage |
 | ShippingPackageSpecified |
 | ShippingServiceUsed |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
 | WeightMajor |
 | WeightMinor |
Remarks
Inheritance Hierarchy
Object
ShipmentType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DeliveryDate Property

DeliveryDate Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► DeliveryDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DeliveryDate { get; set; }
Public Property DeliveryDate As DateTime
    Get
    Set
public:
property DateTime DeliveryDate {
    DateTime get ();
    void set (DateTime value);
}


DeliveryDateSpecified Property

DeliveryDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► DeliveryDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeliveryDateSpecified { get; set; }
Public Property DeliveryDateSpecified As Boolean
    Get
    Set
public:
property bool DeliveryDateSpecified {
    bool get ();
    void set (bool value);
}


DeliveryStatus Property

DeliveryStatus Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► DeliveryStatus
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentDeliveryStatusCodeType DeliveryStatus { get; set; }
Public Property DeliveryStatus As ShipmentDeliveryStatusCodeType
    Get
    Set
public:
property ShipmentDeliveryStatusCodeType DeliveryStatus {
    ShipmentDeliveryStatusCodeType get ();
    void set (ShipmentDeliveryStatusCodeType value);
}


DeliveryStatusSpecified Property

DeliveryStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► DeliveryStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DeliveryStatusSpecified { get; set; }
Public Property DeliveryStatusSpecified As Boolean
    Get
    Set
public:
property bool DeliveryStatusSpecified {
    bool get ();
    void set (bool value);
}


EstimatedDeliveryDate Property

EstimatedDeliveryDate Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► EstimatedDeliveryDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EstimatedDeliveryDate { get; set; }
Public Property EstimatedDeliveryDate As DateTime
    Get
    Set
public:
property DateTime EstimatedDeliveryDate {
    DateTime get ();
    void set (DateTime value);
}


EstimatedDeliveryDateSpecified Property

EstimatedDeliveryDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► EstimatedDeliveryDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EstimatedDeliveryDateSpecified { get; set; }
Public Property EstimatedDeliveryDateSpecified As Boolean
    Get
    Set
public:
property bool EstimatedDeliveryDateSpecified {
    bool get ();
    void set (bool value);
}


InsuredValue Property

InsuredValue Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► InsuredValue
Declaration Syntax
C# Visual Basic Visual C++
public AmountType InsuredValue { get; set; }
Public Property InsuredValue As AmountType
    Get
    Set
public:
property AmountType^ InsuredValue {
    AmountType^ get ();
    void set (AmountType^ value);
}


ItemTransactionID Property

ItemTransactionID Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ItemTransactionID
Declaration Syntax
C# Visual Basic Visual C++
public ItemTransactionIDTypeCollection ItemTransactionID { get; set; }
Public Property ItemTransactionID As ItemTransactionIDTypeCollection
    Get
    Set
public:
property ItemTransactionIDTypeCollection^ ItemTransactionID {
    ItemTransactionIDTypeCollection^ get ();
    void set (ItemTransactionIDTypeCollection^ value);
}


Notes Property

Notes Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► Notes
Declaration Syntax
C# Visual Basic Visual C++
public string Notes { get; set; }
Public Property Notes As String
    Get
    Set
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}


PackageDepth Property

PackageDepth Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► PackageDepth
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType PackageDepth { get; set; }
Public Property PackageDepth As MeasureType
    Get
    Set
public:
property MeasureType^ PackageDepth {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


PackageLength Property

PackageLength Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► PackageLength
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType PackageLength { get; set; }
Public Property PackageLength As MeasureType
    Get
    Set
public:
property MeasureType^ PackageLength {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


PackageWidth Property

PackageWidth Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► PackageWidth
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType PackageWidth { get; set; }
Public Property PackageWidth As MeasureType
    Get
    Set
public:
property MeasureType^ PackageWidth {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


PayPalShipmentID Property

PayPalShipmentID Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► PayPalShipmentID
Declaration Syntax
C# Visual Basic Visual C++
public string PayPalShipmentID { get; set; }
Public Property PayPalShipmentID As String
    Get
    Set
public:
property String^ PayPalShipmentID {
    String^ get ();
    void set (String^ value);
}


PostageTotal Property

PostageTotal Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► PostageTotal
Declaration Syntax
C# Visual Basic Visual C++
public AmountType PostageTotal { get; set; }
Public Property PostageTotal As AmountType
    Get
    Set
public:
property AmountType^ PostageTotal {
    AmountType^ get ();
    void set (AmountType^ value);
}


PrintedTime Property

PrintedTime Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► PrintedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PrintedTime { get; set; }
Public Property PrintedTime As DateTime
    Get
    Set
public:
property DateTime PrintedTime {
    DateTime get ();
    void set (DateTime value);
}


PrintedTimeSpecified Property

PrintedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► PrintedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PrintedTimeSpecified { get; set; }
Public Property PrintedTimeSpecified As Boolean
    Get
    Set
public:
property bool PrintedTimeSpecified {
    bool get ();
    void set (bool value);
}


RefundGrantedTime Property

RefundGrantedTime Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► RefundGrantedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RefundGrantedTime { get; set; }
Public Property RefundGrantedTime As DateTime
    Get
    Set
public:
property DateTime RefundGrantedTime {
    DateTime get ();
    void set (DateTime value);
}


RefundGrantedTimeSpecified Property

RefundGrantedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► RefundGrantedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundGrantedTimeSpecified { get; set; }
Public Property RefundGrantedTimeSpecified As Boolean
    Get
    Set
public:
property bool RefundGrantedTimeSpecified {
    bool get ();
    void set (bool value);
}


RefundRequestedTime Property

RefundRequestedTime Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► RefundRequestedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RefundRequestedTime { get; set; }
Public Property RefundRequestedTime As DateTime
    Get
    Set
public:
property DateTime RefundRequestedTime {
    DateTime get ();
    void set (DateTime value);
}


RefundRequestedTimeSpecified Property

RefundRequestedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► RefundRequestedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RefundRequestedTimeSpecified { get; set; }
Public Property RefundRequestedTimeSpecified As Boolean
    Get
    Set
public:
property bool RefundRequestedTimeSpecified {
    bool get ();
    void set (bool value);
}


ShipFromAddress Property

ShipFromAddress Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShipFromAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType ShipFromAddress { get; set; }
Public Property ShipFromAddress As AddressType
    Get
    Set
public:
property AddressType^ ShipFromAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


ShipmentID Property

ShipmentID Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShipmentID
Declaration Syntax
C# Visual Basic Visual C++
public long ShipmentID { get; set; }
Public Property ShipmentID As Long
    Get
    Set
public:
property long long ShipmentID {
    long long get ();
    void set (long long value);
}


ShipmentIDSpecified Property

ShipmentIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShipmentIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShipmentIDSpecified { get; set; }
Public Property ShipmentIDSpecified As Boolean
    Get
    Set
public:
property bool ShipmentIDSpecified {
    bool get ();
    void set (bool value);
}


ShipmentLineItem Property

ShipmentLineItem Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShipmentLineItem
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentLineItemType ShipmentLineItem { get; set; }
Public Property ShipmentLineItem As ShipmentLineItemType
    Get
    Set
public:
property ShipmentLineItemType^ ShipmentLineItem {
    ShipmentLineItemType^ get ();
    void set (ShipmentLineItemType^ value);
}


ShipmentTrackingDetails Property

ShipmentTrackingDetails Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShipmentTrackingDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentTrackingDetailsTypeCollection ShipmentTrackingDetails { get; set; }
Public Property ShipmentTrackingDetails As ShipmentTrackingDetailsTypeCollection
    Get
    Set
public:
property ShipmentTrackingDetailsTypeCollection^ ShipmentTrackingDetails {
    ShipmentTrackingDetailsTypeCollection^ get ();
    void set (ShipmentTrackingDetailsTypeCollection^ value);
}


ShipmentTrackingNumber Property

ShipmentTrackingNumber Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShipmentTrackingNumber
Declaration Syntax
C# Visual Basic Visual C++
public string ShipmentTrackingNumber { get; set; }
Public Property ShipmentTrackingNumber As String
    Get
    Set
public:
property String^ ShipmentTrackingNumber {
    String^ get ();
    void set (String^ value);
}


ShipmentType Constructor

ShipmentType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShipmentType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentType()
Public Sub New
public:
ShipmentType()


ShippedTime Property

ShippedTime Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShippedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ShippedTime { get; set; }
Public Property ShippedTime As DateTime
    Get
    Set
public:
property DateTime ShippedTime {
    DateTime get ();
    void set (DateTime value);
}


ShippedTimeSpecified Property

ShippedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShippedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippedTimeSpecified { get; set; }
Public Property ShippedTimeSpecified As Boolean
    Get
    Set
public:
property bool ShippedTimeSpecified {
    bool get ();
    void set (bool value);
}


ShippingAddress Property

ShippingAddress Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShippingAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType ShippingAddress { get; set; }
Public Property ShippingAddress As AddressType
    Get
    Set
public:
property AddressType^ ShippingAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


ShippingCarrierUsed Property

ShippingCarrierUsed Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShippingCarrierUsed
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingCarrierUsed { get; set; }
Public Property ShippingCarrierUsed As String
    Get
    Set
public:
property String^ ShippingCarrierUsed {
    String^ get ();
    void set (String^ value);
}


ShippingFeature Property

ShippingFeature Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShippingFeature
Declaration Syntax
C# Visual Basic Visual C++
public ShippingFeatureCodeTypeCollection ShippingFeature { get; set; }
Public Property ShippingFeature As ShippingFeatureCodeTypeCollection
    Get
    Set
public:
property ShippingFeatureCodeTypeCollection^ ShippingFeature {
    ShippingFeatureCodeTypeCollection^ get ();
    void set (ShippingFeatureCodeTypeCollection^ value);
}


ShippingPackage Property

ShippingPackage Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShippingPackage
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeType ShippingPackage { get; set; }
Public Property ShippingPackage As ShippingPackageCodeType
    Get
    Set
public:
property ShippingPackageCodeType ShippingPackage {
    ShippingPackageCodeType get ();
    void set (ShippingPackageCodeType value);
}


ShippingPackageSpecified Property

ShippingPackageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShippingPackageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingPackageSpecified { get; set; }
Public Property ShippingPackageSpecified As Boolean
    Get
    Set
public:
property bool ShippingPackageSpecified {
    bool get ();
    void set (bool value);
}


ShippingServiceUsed Property

ShippingServiceUsed Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► ShippingServiceUsed
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingServiceUsed { get; set; }
Public Property ShippingServiceUsed As String
    Get
    Set
public:
property String^ ShippingServiceUsed {
    String^ get ();
    void set (String^ value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentStatusCodeType Status { get; set; }
Public Property Status As ShipmentStatusCodeType
    Get
    Set
public:
property ShipmentStatusCodeType Status {
    ShipmentStatusCodeType get ();
    void set (ShipmentStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


WeightMajor Property

WeightMajor Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► WeightMajor
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType WeightMajor { get; set; }
Public Property WeightMajor As MeasureType
    Get
    Set
public:
property MeasureType^ WeightMajor {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


WeightMinor Property

WeightMinor Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentType ► WeightMinor
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType WeightMinor { get; set; }
Public Property WeightMinor As MeasureType
    Get
    Set
public:
property MeasureType^ WeightMinor {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


ShipPackageDetailsType Class

ShipPackageDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShipPackageDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShipPackageDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShipPackageDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShipPackageDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MeasurementUnit |
 | MeasurementUnitSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PackageDepth |
 | PackageLength |
 | PackageWidth |
 | ShippingIrregular |
 | ShippingIrregularSpecified |
 | ShippingPackage |
 | ShippingPackageSpecified |
 | ToString()()()() | (Inherited from Object.)
 | WeightMajor |
 | WeightMinor |
Remarks
Inheritance Hierarchy
Object
ShipPackageDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


MeasurementUnit Property

MeasurementUnit Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► MeasurementUnit
Declaration Syntax
C# Visual Basic Visual C++
public MeasurementSystemCodeType MeasurementUnit { get; set; }
Public Property MeasurementUnit As MeasurementSystemCodeType
    Get
    Set
public:
property MeasurementSystemCodeType MeasurementUnit {
    MeasurementSystemCodeType get ();
    void set (MeasurementSystemCodeType value);
}


MeasurementUnitSpecified Property

MeasurementUnitSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► MeasurementUnitSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MeasurementUnitSpecified { get; set; }
Public Property MeasurementUnitSpecified As Boolean
    Get
    Set
public:
property bool MeasurementUnitSpecified {
    bool get ();
    void set (bool value);
}


PackageDepth Property

PackageDepth Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► PackageDepth
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType PackageDepth { get; set; }
Public Property PackageDepth As MeasureType
    Get
    Set
public:
property MeasureType^ PackageDepth {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


PackageLength Property

PackageLength Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► PackageLength
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType PackageLength { get; set; }
Public Property PackageLength As MeasureType
    Get
    Set
public:
property MeasureType^ PackageLength {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


PackageWidth Property

PackageWidth Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► PackageWidth
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType PackageWidth { get; set; }
Public Property PackageWidth As MeasureType
    Get
    Set
public:
property MeasureType^ PackageWidth {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


ShipPackageDetailsType Constructor

ShipPackageDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► ShipPackageDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShipPackageDetailsType()
Public Sub New
public:
ShipPackageDetailsType()


ShippingIrregular Property

ShippingIrregular Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► ShippingIrregular
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingIrregular { get; set; }
Public Property ShippingIrregular As Boolean
    Get
    Set
public:
property bool ShippingIrregular {
    bool get ();
    void set (bool value);
}


ShippingIrregularSpecified Property

ShippingIrregularSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► ShippingIrregularSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingIrregularSpecified { get; set; }
Public Property ShippingIrregularSpecified As Boolean
    Get
    Set
public:
property bool ShippingIrregularSpecified {
    bool get ();
    void set (bool value);
}


ShippingPackage Property

ShippingPackage Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► ShippingPackage
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeType ShippingPackage { get; set; }
Public Property ShippingPackage As ShippingPackageCodeType
    Get
    Set
public:
property ShippingPackageCodeType ShippingPackage {
    ShippingPackageCodeType get ();
    void set (ShippingPackageCodeType value);
}


ShippingPackageSpecified Property

ShippingPackageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► ShippingPackageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingPackageSpecified { get; set; }
Public Property ShippingPackageSpecified As Boolean
    Get
    Set
public:
property bool ShippingPackageSpecified {
    bool get ();
    void set (bool value);
}


WeightMajor Property

WeightMajor Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► WeightMajor
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType WeightMajor { get; set; }
Public Property WeightMajor As MeasureType
    Get
    Set
public:
property MeasureType^ WeightMajor {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


WeightMinor Property

WeightMinor Property
Namespaces ► eBay.Service.Core.Soap ► ShipPackageDetailsType ► WeightMinor
Declaration Syntax
C# Visual Basic Visual C++
public MeasureType WeightMinor { get; set; }
Public Property WeightMinor As MeasureType
    Get
    Set
public:
property MeasureType^ WeightMinor {
    MeasureType^ get ();
    void set (MeasureType^ value);
}


ShippingCarrierCodeType Enumeration

ShippingCarrierCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ShippingCarrierCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ShippingCarrierCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ShippingCarrierCodeType
Members
Member | Description
UPS |
USPS |
FedEx |
DeutschePost |
DHL |
Hermes |
iLoxx |
Other |
ColiposteDomestic |
ColiposteInternational |
Chronopost |
Correos |
Seur |
Nacex |
FourPX |
FourPXCHINA |
FourPXExpress |
FourPXLTD |
SevenLSP |
A1CourierServices |
ABF |
AeroPost |
ALLIEDEXPRESS |
AMWST |
AnPost |
APC |
ARAMEX |
ARVATO |
ASM |
AustraliaPost |
AustralianAirExpress |
AVRT |
BPost |
Bartolini |
BELGIANPOST |
BKNS |
BluePackage |
BusinessPost |
CanPar |
CENF |
CEVA |
ChinaPost |
Chronoexpres |
CHUKOU1 |
ChunghwaPost |
CitiPost |
CityLink |
ClickandQuick |
CNWY |
Colissimo |
CollectPlus |
CPC |
DAIPost |
DayandRoss |
DBSchenker |
DHLEXPRESS |
DHLGlobalMail |
DHLEKB |
DHLG |
DieSchweizerischePost |
DPD |
DPXThailand |
Ducros |
EGO |
EMF |
Exapaq |
Fastway |
FASTWAYCOURIERS |
FedExSmartPost |
FLYT |
FLYTExpress |
FlytExpressUSDirectline |
FTFT |
FulfilExpressAccStation |
FulfilExpresseForCity |
FulfilExpressEverydaySource |
FulfilExpressiTrimming |
GLS |
HDUSA |
HomeDeliveryNetwork |
HongKongPost |
HUNTEREXPRESS |
IndiaPost |
IndonesiaPost |
Interlink |
InterPost |
IoInvio |
Iparcel |
IsraelPost |
JapanPost |
KIALA |
KoreaPost |
LAPOSTE |
Landmark |
LDSO |
LTL |
MALAYSIAPOST |
MannaFreight |
Metapack |
MNGTurkey |
MondialRelay |
MRW |
MSI |
NEMF |
ODFL |
OFFD |
ONTRACK |
OsterreichischePostAG |
OVNT |
ParcelPool |
Parcelforce |
Philpost |
Pilot |
PITD |
PocztaPolska |
Pocztex |
POSTITALIANO |
PostNL |
PostNordNorway |
PosteItaliane |
Prestige |
Quantium |
RETL |
RoyalMail |
RRUN |
SAIA |
SDA |
SFC |
SFCExpress |
SINGAPOREPOST |
Siodemka |
SioliandFontana |
SkynetMalaysia |
SMARTSEND |
Sogetras |
Spediamo |
SpeeDee |
StarTrack |
SuntekExpressLTD |
SwissPost |
TELE |
TEMANDO |
THAILANDPOST |
TNT |
TNTEXPRESS |
TNTPost |
Toll |
TPG |
TWW |
UBI |
UKMail |
UPSMailInnovations |
UPSC |
USFG |
USPSCeP |
USPSPMI |
VietnamPost |
VITR |
WATKINS |
Winit |
Wise |
WNdirect |
WPX |
YANWEN |
Yodel |
YRC |
CustomCode |
Remarks


ShippingCarrierCodeTypeCollection Class

ShippingCarrierCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingCarrierCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingCarrierCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingCarrierCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingCarrierCodeTypeCollection()()()() |
 | ShippingCarrierCodeTypeCollection(array<ShippingCarrierCodeType>[]()[][]) |
 | ShippingCarrierCodeTypeCollection(ShippingCarrierCodeTypeCollection) |
 | Add(ShippingCarrierCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingCarrierCodeType>[]()[][]) |
 | AddRange(ShippingCarrierCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingCarrierCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingCarrierCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingCarrierCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingCarrierCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingCarrierCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingCarrierCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► Add(ShippingCarrierCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingCarrierCodeType item
)
Public Function Add ( _
    item As ShippingCarrierCodeType _
) As Integer
public:
int Add(
    ShippingCarrierCodeType item
)
Parameters
item (ShippingCarrierCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingCarrierCodeType>[]()[][]) |
 | AddRange(ShippingCarrierCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► AddRange(array<ShippingCarrierCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingCarrierCodeType[] items
)
Public Sub AddRange ( _
    items As ShippingCarrierCodeType() _
)
public:
void AddRange(
    array<ShippingCarrierCodeType>^ items
)
Parameters
items (array< ShippingCarrierCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► AddRange(ShippingCarrierCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingCarrierCodeTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingCarrierCodeTypeCollection _
)
public:
void AddRange(
    ShippingCarrierCodeTypeCollection^ items
)
Parameters
items (ShippingCarrierCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► Contains(ShippingCarrierCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingCarrierCodeType item
)
Public Function Contains ( _
    item As ShippingCarrierCodeType _
) As Boolean
public:
bool Contains(
    ShippingCarrierCodeType item
)
Parameters
item (ShippingCarrierCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► CopyTo(array<ShippingCarrierCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingCarrierCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingCarrierCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingCarrierCodeType>^ items,
    int index
)
Parameters
items (array< ShippingCarrierCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► IndexOf(ShippingCarrierCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingCarrierCodeType item
)
Public Function IndexOf ( _
    item As ShippingCarrierCodeType _
) As Integer
public:
int IndexOf(
    ShippingCarrierCodeType item
)
Parameters
item (ShippingCarrierCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► Insert(Int32, ShippingCarrierCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingCarrierCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingCarrierCodeType _
)
public:
void Insert(
    int index,
    ShippingCarrierCodeType item
)
Parameters
index (Int32)
item (ShippingCarrierCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingCarrierCodeType
    Get
    Set
public:
property ShippingCarrierCodeType default[int index] {
    ShippingCarrierCodeType get (int index);
    void set (int index, ShippingCarrierCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingCarrierCodeType
public:
ShippingCarrierCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► Remove(ShippingCarrierCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingCarrierCodeType item
)
Public Sub Remove ( _
    item As ShippingCarrierCodeType _
)
public:
void Remove(
    ShippingCarrierCodeType item
)
Parameters
item (ShippingCarrierCodeType)


ShippingCarrierCodeTypeCollection Constructor

ShippingCarrierCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► ShippingCarrierCodeTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingCarrierCodeTypeCollection()()()() |
 | ShippingCarrierCodeTypeCollection(array<ShippingCarrierCodeType>[]()[][]) |
 | ShippingCarrierCodeTypeCollection(ShippingCarrierCodeTypeCollection) |


ShippingCarrierCodeTypeCollection Constructor

ShippingCarrierCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► ShippingCarrierCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierCodeTypeCollection()
Public Sub New
public:
ShippingCarrierCodeTypeCollection()


ShippingCarrierCodeTypeCollection Constructor (items)

ShippingCarrierCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► ShippingCarrierCodeTypeCollection(array<ShippingCarrierCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierCodeTypeCollection(
    ShippingCarrierCodeType[] items
)
Public Sub New ( _
    items As ShippingCarrierCodeType() _
)
public:
ShippingCarrierCodeTypeCollection(
    array<ShippingCarrierCodeType>^ items
)
Parameters
items (array< ShippingCarrierCodeType >[]()[][])


ShippingCarrierCodeTypeCollection Constructor (items)

ShippingCarrierCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► ShippingCarrierCodeTypeCollection(ShippingCarrierCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierCodeTypeCollection(
    ShippingCarrierCodeTypeCollection items
)
Public Sub New ( _
    items As ShippingCarrierCodeTypeCollection _
)
public:
ShippingCarrierCodeTypeCollection(
    ShippingCarrierCodeTypeCollection^ items
)
Parameters
items (ShippingCarrierCodeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierCodeType[] ToArray()
Public Function ToArray As ShippingCarrierCodeType()
public:
array<ShippingCarrierCodeType>^ ToArray()
Return Value


ShippingCarrierDetailsType Class

ShippingCarrierDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingCarrierDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingCarrierDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingCarrierDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingCarrierDetailsType()()()() |
 | Any |
 | Description |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingCarrier |
 | ShippingCarrierID |
 | ShippingCarrierIDSpecified |
 | ShippingCarrierSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
ShippingCarrierDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


ShippingCarrier Property

ShippingCarrier Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsType ► ShippingCarrier
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierCodeType ShippingCarrier { get; set; }
Public Property ShippingCarrier As ShippingCarrierCodeType
    Get
    Set
public:
property ShippingCarrierCodeType ShippingCarrier {
    ShippingCarrierCodeType get ();
    void set (ShippingCarrierCodeType value);
}


ShippingCarrierDetailsType Constructor

ShippingCarrierDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsType ► ShippingCarrierDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierDetailsType()
Public Sub New
public:
ShippingCarrierDetailsType()


ShippingCarrierID Property

ShippingCarrierID Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsType ► ShippingCarrierID
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingCarrierID { get; set; }
Public Property ShippingCarrierID As Integer
    Get
    Set
public:
property int ShippingCarrierID {
    int get ();
    void set (int value);
}


ShippingCarrierIDSpecified Property

ShippingCarrierIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsType ► ShippingCarrierIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingCarrierIDSpecified { get; set; }
Public Property ShippingCarrierIDSpecified As Boolean
    Get
    Set
public:
property bool ShippingCarrierIDSpecified {
    bool get ();
    void set (bool value);
}


ShippingCarrierSpecified Property

ShippingCarrierSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsType ► ShippingCarrierSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingCarrierSpecified { get; set; }
Public Property ShippingCarrierSpecified As Boolean
    Get
    Set
public:
property bool ShippingCarrierSpecified {
    bool get ();
    void set (bool value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


ShippingCarrierDetailsTypeCollection Class

ShippingCarrierDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingCarrierDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingCarrierDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingCarrierDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingCarrierDetailsTypeCollection()()()() |
 | ShippingCarrierDetailsTypeCollection(array<ShippingCarrierDetailsType>[]()[][]) |
 | ShippingCarrierDetailsTypeCollection(ShippingCarrierDetailsTypeCollection) |
 | Add(ShippingCarrierDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingCarrierDetailsType>[]()[][]) |
 | AddRange(ShippingCarrierDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingCarrierDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingCarrierDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingCarrierDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingCarrierDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingCarrierDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingCarrierDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► Add(ShippingCarrierDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingCarrierDetailsType item
)
Public Function Add ( _
    item As ShippingCarrierDetailsType _
) As Integer
public:
int Add(
    ShippingCarrierDetailsType^ item
)
Parameters
item (ShippingCarrierDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingCarrierDetailsType>[]()[][]) |
 | AddRange(ShippingCarrierDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► AddRange(array<ShippingCarrierDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingCarrierDetailsType[] items
)
Public Sub AddRange ( _
    items As ShippingCarrierDetailsType() _
)
public:
void AddRange(
    array<ShippingCarrierDetailsType^>^ items
)
Parameters
items (array< ShippingCarrierDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► AddRange(ShippingCarrierDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingCarrierDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingCarrierDetailsTypeCollection _
)
public:
void AddRange(
    ShippingCarrierDetailsTypeCollection^ items
)
Parameters
items (ShippingCarrierDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► Contains(ShippingCarrierDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingCarrierDetailsType item
)
Public Function Contains ( _
    item As ShippingCarrierDetailsType _
) As Boolean
public:
bool Contains(
    ShippingCarrierDetailsType^ item
)
Parameters
item (ShippingCarrierDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► CopyTo(array<ShippingCarrierDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingCarrierDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingCarrierDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingCarrierDetailsType^>^ items,
    int index
)
Parameters
items (array< ShippingCarrierDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► IndexOf(ShippingCarrierDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingCarrierDetailsType item
)
Public Function IndexOf ( _
    item As ShippingCarrierDetailsType _
) As Integer
public:
int IndexOf(
    ShippingCarrierDetailsType^ item
)
Parameters
item (ShippingCarrierDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► Insert(Int32, ShippingCarrierDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingCarrierDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingCarrierDetailsType _
)
public:
void Insert(
    int index,
    ShippingCarrierDetailsType^ item
)
Parameters
index (Int32)
item (ShippingCarrierDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingCarrierDetailsType
    Get
    Set
public:
property ShippingCarrierDetailsType^ default[int index] {
    ShippingCarrierDetailsType^ get (int index);
    void set (int index, ShippingCarrierDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingCarrierDetailsType
public:
ShippingCarrierDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► Remove(ShippingCarrierDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingCarrierDetailsType item
)
Public Sub Remove ( _
    item As ShippingCarrierDetailsType _
)
public:
void Remove(
    ShippingCarrierDetailsType^ item
)
Parameters
item (ShippingCarrierDetailsType)


ShippingCarrierDetailsTypeCollection Constructor

ShippingCarrierDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► ShippingCarrierDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingCarrierDetailsTypeCollection()()()() |
 | ShippingCarrierDetailsTypeCollection(array<ShippingCarrierDetailsType>[]()[][]) |
 | ShippingCarrierDetailsTypeCollection(ShippingCarrierDetailsTypeCollection) |


ShippingCarrierDetailsTypeCollection Constructor

ShippingCarrierDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► ShippingCarrierDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierDetailsTypeCollection()
Public Sub New
public:
ShippingCarrierDetailsTypeCollection()


ShippingCarrierDetailsTypeCollection Constructor (items)

ShippingCarrierDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► ShippingCarrierDetailsTypeCollection(array<ShippingCarrierDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierDetailsTypeCollection(
    ShippingCarrierDetailsType[] items
)
Public Sub New ( _
    items As ShippingCarrierDetailsType() _
)
public:
ShippingCarrierDetailsTypeCollection(
    array<ShippingCarrierDetailsType^>^ items
)
Parameters
items (array< ShippingCarrierDetailsType >[]()[][])


ShippingCarrierDetailsTypeCollection Constructor (items)

ShippingCarrierDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► ShippingCarrierDetailsTypeCollection(ShippingCarrierDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierDetailsTypeCollection(
    ShippingCarrierDetailsTypeCollection items
)
Public Sub New ( _
    items As ShippingCarrierDetailsTypeCollection _
)
public:
ShippingCarrierDetailsTypeCollection(
    ShippingCarrierDetailsTypeCollection^ items
)
Parameters
items (ShippingCarrierDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierDetailsType[] ToArray()
Public Function ToArray As ShippingCarrierDetailsType()
public:
array<ShippingCarrierDetailsType^>^ ToArray()
Return Value


ShippingCategoryDetailsType Class

ShippingCategoryDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingCategoryDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingCategoryDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingCategoryDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingCategoryDetailsType()()()() |
 | Any |
 | Description |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingCategory |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
ShippingCategoryDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


ShippingCategory Property

ShippingCategory Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsType ► ShippingCategory
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingCategory { get; set; }
Public Property ShippingCategory As String
    Get
    Set
public:
property String^ ShippingCategory {
    String^ get ();
    void set (String^ value);
}


ShippingCategoryDetailsType Constructor

ShippingCategoryDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsType ► ShippingCategoryDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCategoryDetailsType()
Public Sub New
public:
ShippingCategoryDetailsType()


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


ShippingCategoryDetailsTypeCollection Class

ShippingCategoryDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingCategoryDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingCategoryDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingCategoryDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingCategoryDetailsTypeCollection()()()() |
 | ShippingCategoryDetailsTypeCollection(array<ShippingCategoryDetailsType>[]()[][]) |
 | ShippingCategoryDetailsTypeCollection(ShippingCategoryDetailsTypeCollection) |
 | Add(ShippingCategoryDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingCategoryDetailsType>[]()[][]) |
 | AddRange(ShippingCategoryDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingCategoryDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingCategoryDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingCategoryDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingCategoryDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingCategoryDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingCategoryDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► Add(ShippingCategoryDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingCategoryDetailsType item
)
Public Function Add ( _
    item As ShippingCategoryDetailsType _
) As Integer
public:
int Add(
    ShippingCategoryDetailsType^ item
)
Parameters
item (ShippingCategoryDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingCategoryDetailsType>[]()[][]) |
 | AddRange(ShippingCategoryDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► AddRange(array<ShippingCategoryDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingCategoryDetailsType[] items
)
Public Sub AddRange ( _
    items As ShippingCategoryDetailsType() _
)
public:
void AddRange(
    array<ShippingCategoryDetailsType^>^ items
)
Parameters
items (array< ShippingCategoryDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► AddRange(ShippingCategoryDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingCategoryDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingCategoryDetailsTypeCollection _
)
public:
void AddRange(
    ShippingCategoryDetailsTypeCollection^ items
)
Parameters
items (ShippingCategoryDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► Contains(ShippingCategoryDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingCategoryDetailsType item
)
Public Function Contains ( _
    item As ShippingCategoryDetailsType _
) As Boolean
public:
bool Contains(
    ShippingCategoryDetailsType^ item
)
Parameters
item (ShippingCategoryDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► CopyTo(array<ShippingCategoryDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingCategoryDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingCategoryDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingCategoryDetailsType^>^ items,
    int index
)
Parameters
items (array< ShippingCategoryDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► IndexOf(ShippingCategoryDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingCategoryDetailsType item
)
Public Function IndexOf ( _
    item As ShippingCategoryDetailsType _
) As Integer
public:
int IndexOf(
    ShippingCategoryDetailsType^ item
)
Parameters
item (ShippingCategoryDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► Insert(Int32, ShippingCategoryDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingCategoryDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingCategoryDetailsType _
)
public:
void Insert(
    int index,
    ShippingCategoryDetailsType^ item
)
Parameters
index (Int32)
item (ShippingCategoryDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCategoryDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingCategoryDetailsType
    Get
    Set
public:
property ShippingCategoryDetailsType^ default[int index] {
    ShippingCategoryDetailsType^ get (int index);
    void set (int index, ShippingCategoryDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCategoryDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingCategoryDetailsType
public:
ShippingCategoryDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► Remove(ShippingCategoryDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingCategoryDetailsType item
)
Public Sub Remove ( _
    item As ShippingCategoryDetailsType _
)
public:
void Remove(
    ShippingCategoryDetailsType^ item
)
Parameters
item (ShippingCategoryDetailsType)


ShippingCategoryDetailsTypeCollection Constructor

ShippingCategoryDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► ShippingCategoryDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingCategoryDetailsTypeCollection()()()() |
 | ShippingCategoryDetailsTypeCollection(array<ShippingCategoryDetailsType>[]()[][]) |
 | ShippingCategoryDetailsTypeCollection(ShippingCategoryDetailsTypeCollection) |


ShippingCategoryDetailsTypeCollection Constructor

ShippingCategoryDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► ShippingCategoryDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCategoryDetailsTypeCollection()
Public Sub New
public:
ShippingCategoryDetailsTypeCollection()


ShippingCategoryDetailsTypeCollection Constructor (items)

ShippingCategoryDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► ShippingCategoryDetailsTypeCollection(array<ShippingCategoryDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCategoryDetailsTypeCollection(
    ShippingCategoryDetailsType[] items
)
Public Sub New ( _
    items As ShippingCategoryDetailsType() _
)
public:
ShippingCategoryDetailsTypeCollection(
    array<ShippingCategoryDetailsType^>^ items
)
Parameters
items (array< ShippingCategoryDetailsType >[]()[][])


ShippingCategoryDetailsTypeCollection Constructor (items)

ShippingCategoryDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► ShippingCategoryDetailsTypeCollection(ShippingCategoryDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCategoryDetailsTypeCollection(
    ShippingCategoryDetailsTypeCollection items
)
Public Sub New ( _
    items As ShippingCategoryDetailsTypeCollection _
)
public:
ShippingCategoryDetailsTypeCollection(
    ShippingCategoryDetailsTypeCollection^ items
)
Parameters
items (ShippingCategoryDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCategoryDetailsType[] ToArray()
Public Function ToArray As ShippingCategoryDetailsType()
public:
array<ShippingCategoryDetailsType^>^ ToArray()
Return Value


ShippingCostPaidByDetailsType Class

ShippingCostPaidByDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingCostPaidByDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingCostPaidByDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingCostPaidByDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingCostPaidByDetailsType()()()() |
 | Any |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingCostPaidByOption |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShippingCostPaidByDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ShippingCostPaidByDetailsType Constructor

ShippingCostPaidByDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsType ► ShippingCostPaidByDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCostPaidByDetailsType()
Public Sub New
public:
ShippingCostPaidByDetailsType()


ShippingCostPaidByOption Property

ShippingCostPaidByOption Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsType ► ShippingCostPaidByOption
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingCostPaidByOption { get; set; }
Public Property ShippingCostPaidByOption As String
    Get
    Set
public:
property String^ ShippingCostPaidByOption {
    String^ get ();
    void set (String^ value);
}


ShippingCostPaidByDetailsTypeCollection Class

ShippingCostPaidByDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingCostPaidByDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingCostPaidByDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingCostPaidByDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingCostPaidByDetailsTypeCollection()()()() |
 | ShippingCostPaidByDetailsTypeCollection(array<ShippingCostPaidByDetailsType>[]()[][]) |
 | ShippingCostPaidByDetailsTypeCollection(ShippingCostPaidByDetailsTypeCollection) |
 | Add(ShippingCostPaidByDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingCostPaidByDetailsType>[]()[][]) |
 | AddRange(ShippingCostPaidByDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingCostPaidByDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingCostPaidByDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingCostPaidByDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingCostPaidByDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingCostPaidByDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingCostPaidByDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► Add(ShippingCostPaidByDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingCostPaidByDetailsType item
)
Public Function Add ( _
    item As ShippingCostPaidByDetailsType _
) As Integer
public:
int Add(
    ShippingCostPaidByDetailsType^ item
)
Parameters
item (ShippingCostPaidByDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingCostPaidByDetailsType>[]()[][]) |
 | AddRange(ShippingCostPaidByDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► AddRange(array<ShippingCostPaidByDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingCostPaidByDetailsType[] items
)
Public Sub AddRange ( _
    items As ShippingCostPaidByDetailsType() _
)
public:
void AddRange(
    array<ShippingCostPaidByDetailsType^>^ items
)
Parameters
items (array< ShippingCostPaidByDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► AddRange(ShippingCostPaidByDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingCostPaidByDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingCostPaidByDetailsTypeCollection _
)
public:
void AddRange(
    ShippingCostPaidByDetailsTypeCollection^ items
)
Parameters
items (ShippingCostPaidByDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► Contains(ShippingCostPaidByDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingCostPaidByDetailsType item
)
Public Function Contains ( _
    item As ShippingCostPaidByDetailsType _
) As Boolean
public:
bool Contains(
    ShippingCostPaidByDetailsType^ item
)
Parameters
item (ShippingCostPaidByDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► CopyTo(array<ShippingCostPaidByDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingCostPaidByDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingCostPaidByDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingCostPaidByDetailsType^>^ items,
    int index
)
Parameters
items (array< ShippingCostPaidByDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► IndexOf(ShippingCostPaidByDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingCostPaidByDetailsType item
)
Public Function IndexOf ( _
    item As ShippingCostPaidByDetailsType _
) As Integer
public:
int IndexOf(
    ShippingCostPaidByDetailsType^ item
)
Parameters
item (ShippingCostPaidByDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► Insert(Int32, ShippingCostPaidByDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingCostPaidByDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingCostPaidByDetailsType _
)
public:
void Insert(
    int index,
    ShippingCostPaidByDetailsType^ item
)
Parameters
index (Int32)
item (ShippingCostPaidByDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCostPaidByDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingCostPaidByDetailsType
    Get
    Set
public:
property ShippingCostPaidByDetailsType^ default[int index] {
    ShippingCostPaidByDetailsType^ get (int index);
    void set (int index, ShippingCostPaidByDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCostPaidByDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingCostPaidByDetailsType
public:
ShippingCostPaidByDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► Remove(ShippingCostPaidByDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingCostPaidByDetailsType item
)
Public Sub Remove ( _
    item As ShippingCostPaidByDetailsType _
)
public:
void Remove(
    ShippingCostPaidByDetailsType^ item
)
Parameters
item (ShippingCostPaidByDetailsType)


ShippingCostPaidByDetailsTypeCollection Constructor

ShippingCostPaidByDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► ShippingCostPaidByDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingCostPaidByDetailsTypeCollection()()()() |
 | ShippingCostPaidByDetailsTypeCollection(array<ShippingCostPaidByDetailsType>[]()[][]) |
 | ShippingCostPaidByDetailsTypeCollection(ShippingCostPaidByDetailsTypeCollection) |


ShippingCostPaidByDetailsTypeCollection Constructor

ShippingCostPaidByDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► ShippingCostPaidByDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCostPaidByDetailsTypeCollection()
Public Sub New
public:
ShippingCostPaidByDetailsTypeCollection()


ShippingCostPaidByDetailsTypeCollection Constructor (items)

ShippingCostPaidByDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► ShippingCostPaidByDetailsTypeCollection(array<ShippingCostPaidByDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCostPaidByDetailsTypeCollection(
    ShippingCostPaidByDetailsType[] items
)
Public Sub New ( _
    items As ShippingCostPaidByDetailsType() _
)
public:
ShippingCostPaidByDetailsTypeCollection(
    array<ShippingCostPaidByDetailsType^>^ items
)
Parameters
items (array< ShippingCostPaidByDetailsType >[]()[][])


ShippingCostPaidByDetailsTypeCollection Constructor (items)

ShippingCostPaidByDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► ShippingCostPaidByDetailsTypeCollection(ShippingCostPaidByDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCostPaidByDetailsTypeCollection(
    ShippingCostPaidByDetailsTypeCollection items
)
Public Sub New ( _
    items As ShippingCostPaidByDetailsTypeCollection _
)
public:
ShippingCostPaidByDetailsTypeCollection(
    ShippingCostPaidByDetailsTypeCollection^ items
)
Parameters
items (ShippingCostPaidByDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCostPaidByDetailsType[] ToArray()
Public Function ToArray As ShippingCostPaidByDetailsType()
public:
array<ShippingCostPaidByDetailsType^>^ ToArray()
Return Value


ShippingDetailsType Class

ShippingDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingDetailsType()()()() |
 | AllowPaymentEdit |
 | AllowPaymentEditSpecified |
 | Any |
 | ApplyShippingDiscount |
 | ApplyShippingDiscountSpecified |
 | CalculatedShippingDiscount |
 | CalculatedShippingRate |
 | ChangePaymentInstructions |
 | ChangePaymentInstructionsSpecified |
 | CODCost |
 | DefaultShippingCost |
 | Equals(Object) | (Inherited from Object.)
 | ExcludeShipToLocation |
 | Finalize()()()() | (Inherited from Object.)
 | FlatShippingDiscount |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItFast |
 | GetItFastSpecified |
 | GetType()()()() | (Inherited from Object.)
 | GlobalShipping |
 | GlobalShippingSpecified |
 | InsuranceDetails |
 | InsuranceFee |
 | InsuranceOption |
 | InsuranceOptionSpecified |
 | InsuranceWanted |
 | InsuranceWantedSpecified |
 | InternationalCalculatedShippingDiscount |
 | InternationalFlatShippingDiscount |
 | InternationalInsuranceDetails |
 | InternationalPromotionalShippingDiscount |
 | InternationalPromotionalShippingDiscountSpecified |
 | InternationalShippingDiscountProfileID |
 | InternationalShippingServiceOption |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PaymentEdited |
 | PaymentEditedSpecified |
 | PaymentInstructions |
 | PromotionalShippingDiscount |
 | PromotionalShippingDiscountDetails |
 | PromotionalShippingDiscountSpecified |
 | RateTableDetails |
 | SalesTax |
 | SellerExcludeShipToLocationsPreference |
 | SellerExcludeShipToLocationsPreferenceSpecified |
 | SellingManagerSalesRecordNumber |
 | SellingManagerSalesRecordNumberSpecified |
 | ShipmentTrackingDetails |
 | ShippingDiscountProfileID |
 | ShippingRateErrorMessage |
 | ShippingRateType |
 | ShippingRateTypeSpecified |
 | ShippingServiceOptions |
 | ShippingServiceUsed |
 | ShippingType |
 | ShippingTypeSpecified |
 | TaxTable |
 | ThirdPartyCheckout |
 | ThirdPartyCheckoutSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShippingDetailsType


AllowPaymentEdit Property

AllowPaymentEdit Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► AllowPaymentEdit
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowPaymentEdit { get; set; }
Public Property AllowPaymentEdit As Boolean
    Get
    Set
public:
property bool AllowPaymentEdit {
    bool get ();
    void set (bool value);
}


AllowPaymentEditSpecified Property

AllowPaymentEditSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► AllowPaymentEditSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowPaymentEditSpecified { get; set; }
Public Property AllowPaymentEditSpecified As Boolean
    Get
    Set
public:
property bool AllowPaymentEditSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ApplyShippingDiscount Property

ApplyShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ApplyShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public bool ApplyShippingDiscount { get; set; }
Public Property ApplyShippingDiscount As Boolean
    Get
    Set
public:
property bool ApplyShippingDiscount {
    bool get ();
    void set (bool value);
}


ApplyShippingDiscountSpecified Property

ApplyShippingDiscountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ApplyShippingDiscountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ApplyShippingDiscountSpecified { get; set; }
Public Property ApplyShippingDiscountSpecified As Boolean
    Get
    Set
public:
property bool ApplyShippingDiscountSpecified {
    bool get ();
    void set (bool value);
}


CalculatedShippingDiscount Property

CalculatedShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► CalculatedShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingDiscountType CalculatedShippingDiscount { get; set; }
Public Property CalculatedShippingDiscount As CalculatedShippingDiscountType
    Get
    Set
public:
property CalculatedShippingDiscountType^ CalculatedShippingDiscount {
    CalculatedShippingDiscountType^ get ();
    void set (CalculatedShippingDiscountType^ value);
}


CalculatedShippingRate Property

CalculatedShippingRate Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► CalculatedShippingRate
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingRateType CalculatedShippingRate { get; set; }
Public Property CalculatedShippingRate As CalculatedShippingRateType
    Get
    Set
public:
property CalculatedShippingRateType^ CalculatedShippingRate {
    CalculatedShippingRateType^ get ();
    void set (CalculatedShippingRateType^ value);
}


ChangePaymentInstructions Property

ChangePaymentInstructions Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ChangePaymentInstructions
Declaration Syntax
C# Visual Basic Visual C++
public bool ChangePaymentInstructions { get; set; }
Public Property ChangePaymentInstructions As Boolean
    Get
    Set
public:
property bool ChangePaymentInstructions {
    bool get ();
    void set (bool value);
}


ChangePaymentInstructionsSpecified Property

ChangePaymentInstructionsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ChangePaymentInstructionsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ChangePaymentInstructionsSpecified { get; set; }
Public Property ChangePaymentInstructionsSpecified As Boolean
    Get
    Set
public:
property bool ChangePaymentInstructionsSpecified {
    bool get ();
    void set (bool value);
}


CODCost Property

CODCost Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► CODCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType CODCost { get; set; }
Public Property CODCost As AmountType
    Get
    Set
public:
property AmountType^ CODCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


DefaultShippingCost Property

DefaultShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► DefaultShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType DefaultShippingCost { get; set; }
Public Property DefaultShippingCost As AmountType
    Get
    Set
public:
property AmountType^ DefaultShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ExcludeShipToLocation Property

ExcludeShipToLocation Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ExcludeShipToLocation
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ExcludeShipToLocation { get; set; }
Public Property ExcludeShipToLocation As StringCollection
    Get
    Set
public:
property StringCollection^ ExcludeShipToLocation {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


FlatShippingDiscount Property

FlatShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► FlatShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public FlatShippingDiscountType FlatShippingDiscount { get; set; }
Public Property FlatShippingDiscount As FlatShippingDiscountType
    Get
    Set
public:
property FlatShippingDiscountType^ FlatShippingDiscount {
    FlatShippingDiscountType^ get ();
    void set (FlatShippingDiscountType^ value);
}


GetItFast Property

GetItFast Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► GetItFast
Declaration Syntax
C# Visual Basic Visual C++
public bool GetItFast { get; set; }
Public Property GetItFast As Boolean
    Get
    Set
public:
property bool GetItFast {
    bool get ();
    void set (bool value);
}


GetItFastSpecified Property

GetItFastSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► GetItFastSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GetItFastSpecified { get; set; }
Public Property GetItFastSpecified As Boolean
    Get
    Set
public:
property bool GetItFastSpecified {
    bool get ();
    void set (bool value);
}


GlobalShipping Property

GlobalShipping Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► GlobalShipping
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShipping { get; set; }
Public Property GlobalShipping As Boolean
    Get
    Set
public:
property bool GlobalShipping {
    bool get ();
    void set (bool value);
}


GlobalShippingSpecified Property

GlobalShippingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► GlobalShippingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShippingSpecified { get; set; }
Public Property GlobalShippingSpecified As Boolean
    Get
    Set
public:
property bool GlobalShippingSpecified {
    bool get ();
    void set (bool value);
}


InsuranceDetails Property

InsuranceDetails Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InsuranceDetails
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceDetailsType InsuranceDetails { get; set; }
Public Property InsuranceDetails As InsuranceDetailsType
    Get
    Set
public:
property InsuranceDetailsType^ InsuranceDetails {
    InsuranceDetailsType^ get ();
    void set (InsuranceDetailsType^ value);
}


InsuranceFee Property

InsuranceFee Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InsuranceFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType InsuranceFee { get; set; }
Public Property InsuranceFee As AmountType
    Get
    Set
public:
property AmountType^ InsuranceFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


InsuranceOption Property

InsuranceOption Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InsuranceOption
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceOptionCodeType InsuranceOption { get; set; }
Public Property InsuranceOption As InsuranceOptionCodeType
    Get
    Set
public:
property InsuranceOptionCodeType InsuranceOption {
    InsuranceOptionCodeType get ();
    void set (InsuranceOptionCodeType value);
}


InsuranceOptionSpecified Property

InsuranceOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InsuranceOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InsuranceOptionSpecified { get; set; }
Public Property InsuranceOptionSpecified As Boolean
    Get
    Set
public:
property bool InsuranceOptionSpecified {
    bool get ();
    void set (bool value);
}


InsuranceWanted Property

InsuranceWanted Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InsuranceWanted
Declaration Syntax
C# Visual Basic Visual C++
public bool InsuranceWanted { get; set; }
Public Property InsuranceWanted As Boolean
    Get
    Set
public:
property bool InsuranceWanted {
    bool get ();
    void set (bool value);
}


InsuranceWantedSpecified Property

InsuranceWantedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InsuranceWantedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InsuranceWantedSpecified { get; set; }
Public Property InsuranceWantedSpecified As Boolean
    Get
    Set
public:
property bool InsuranceWantedSpecified {
    bool get ();
    void set (bool value);
}


InternationalCalculatedShippingDiscount Property

InternationalCalculatedShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InternationalCalculatedShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public CalculatedShippingDiscountType InternationalCalculatedShippingDiscount { get; set; }
Public Property InternationalCalculatedShippingDiscount As CalculatedShippingDiscountType
    Get
    Set
public:
property CalculatedShippingDiscountType^ InternationalCalculatedShippingDiscount {
    CalculatedShippingDiscountType^ get ();
    void set (CalculatedShippingDiscountType^ value);
}


InternationalFlatShippingDiscount Property

InternationalFlatShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InternationalFlatShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public FlatShippingDiscountType InternationalFlatShippingDiscount { get; set; }
Public Property InternationalFlatShippingDiscount As FlatShippingDiscountType
    Get
    Set
public:
property FlatShippingDiscountType^ InternationalFlatShippingDiscount {
    FlatShippingDiscountType^ get ();
    void set (FlatShippingDiscountType^ value);
}


InternationalInsuranceDetails Property

InternationalInsuranceDetails Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InternationalInsuranceDetails
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceDetailsType InternationalInsuranceDetails { get; set; }
Public Property InternationalInsuranceDetails As InsuranceDetailsType
    Get
    Set
public:
property InsuranceDetailsType^ InternationalInsuranceDetails {
    InsuranceDetailsType^ get ();
    void set (InsuranceDetailsType^ value);
}


InternationalPromotionalShippingDiscount Property

InternationalPromotionalShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InternationalPromotionalShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public bool InternationalPromotionalShippingDiscount { get; set; }
Public Property InternationalPromotionalShippingDiscount As Boolean
    Get
    Set
public:
property bool InternationalPromotionalShippingDiscount {
    bool get ();
    void set (bool value);
}


InternationalPromotionalShippingDiscountSpecified Property

InternationalPromotionalShippingDiscountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InternationalPromotionalShippingDiscountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InternationalPromotionalShippingDiscountSpecified { get; set; }
Public Property InternationalPromotionalShippingDiscountSpecified As Boolean
    Get
    Set
public:
property bool InternationalPromotionalShippingDiscountSpecified {
    bool get ();
    void set (bool value);
}


InternationalShippingDiscountProfileID Property

InternationalShippingDiscountProfileID Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InternationalShippingDiscountProfileID
Declaration Syntax
C# Visual Basic Visual C++
public string InternationalShippingDiscountProfileID { get; set; }
Public Property InternationalShippingDiscountProfileID As String
    Get
    Set
public:
property String^ InternationalShippingDiscountProfileID {
    String^ get ();
    void set (String^ value);
}


InternationalShippingServiceOption Property

InternationalShippingServiceOption Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► InternationalShippingServiceOption
Declaration Syntax
C# Visual Basic Visual C++
public InternationalShippingServiceOptionsTypeCollection InternationalShippingServiceOption { get; set; }
Public Property InternationalShippingServiceOption As InternationalShippingServiceOptionsTypeCollection
    Get
    Set
public:
property InternationalShippingServiceOptionsTypeCollection^ InternationalShippingServiceOption {
    InternationalShippingServiceOptionsTypeCollection^ get ();
    void set (InternationalShippingServiceOptionsTypeCollection^ value);
}


PaymentEdited Property

PaymentEdited Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► PaymentEdited
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentEdited { get; set; }
Public Property PaymentEdited As Boolean
    Get
    Set
public:
property bool PaymentEdited {
    bool get ();
    void set (bool value);
}


PaymentEditedSpecified Property

PaymentEditedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► PaymentEditedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentEditedSpecified { get; set; }
Public Property PaymentEditedSpecified As Boolean
    Get
    Set
public:
property bool PaymentEditedSpecified {
    bool get ();
    void set (bool value);
}


PaymentInstructions Property

PaymentInstructions Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► PaymentInstructions
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentInstructions { get; set; }
Public Property PaymentInstructions As String
    Get
    Set
public:
property String^ PaymentInstructions {
    String^ get ();
    void set (String^ value);
}


PromotionalShippingDiscount Property

PromotionalShippingDiscount Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► PromotionalShippingDiscount
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalShippingDiscount { get; set; }
Public Property PromotionalShippingDiscount As Boolean
    Get
    Set
public:
property bool PromotionalShippingDiscount {
    bool get ();
    void set (bool value);
}


PromotionalShippingDiscountDetails Property

PromotionalShippingDiscountDetails Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► PromotionalShippingDiscountDetails
Declaration Syntax
C# Visual Basic Visual C++
public PromotionalShippingDiscountDetailsType PromotionalShippingDiscountDetails { get; set; }
Public Property PromotionalShippingDiscountDetails As PromotionalShippingDiscountDetailsType
    Get
    Set
public:
property PromotionalShippingDiscountDetailsType^ PromotionalShippingDiscountDetails {
    PromotionalShippingDiscountDetailsType^ get ();
    void set (PromotionalShippingDiscountDetailsType^ value);
}


PromotionalShippingDiscountSpecified Property

PromotionalShippingDiscountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► PromotionalShippingDiscountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PromotionalShippingDiscountSpecified { get; set; }
Public Property PromotionalShippingDiscountSpecified As Boolean
    Get
    Set
public:
property bool PromotionalShippingDiscountSpecified {
    bool get ();
    void set (bool value);
}


RateTableDetails Property

RateTableDetails Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► RateTableDetails
Declaration Syntax
C# Visual Basic Visual C++
public RateTableDetailsType RateTableDetails { get; set; }
Public Property RateTableDetails As RateTableDetailsType
    Get
    Set
public:
property RateTableDetailsType^ RateTableDetails {
    RateTableDetailsType^ get ();
    void set (RateTableDetailsType^ value);
}


SalesTax Property

SalesTax Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► SalesTax
Declaration Syntax
C# Visual Basic Visual C++
public SalesTaxType SalesTax { get; set; }
Public Property SalesTax As SalesTaxType
    Get
    Set
public:
property SalesTaxType^ SalesTax {
    SalesTaxType^ get ();
    void set (SalesTaxType^ value);
}


SellerExcludeShipToLocationsPreference Property

SellerExcludeShipToLocationsPreference Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► SellerExcludeShipToLocationsPreference
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerExcludeShipToLocationsPreference { get; set; }
Public Property SellerExcludeShipToLocationsPreference As Boolean
    Get
    Set
public:
property bool SellerExcludeShipToLocationsPreference {
    bool get ();
    void set (bool value);
}


SellerExcludeShipToLocationsPreferenceSpecified Property

SellerExcludeShipToLocationsPreferenceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► SellerExcludeShipToLocationsPreferenceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerExcludeShipToLocationsPreferenceSpecified { get; set; }
Public Property SellerExcludeShipToLocationsPreferenceSpecified As Boolean
    Get
    Set
public:
property bool SellerExcludeShipToLocationsPreferenceSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerSalesRecordNumber Property

SellingManagerSalesRecordNumber Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► SellingManagerSalesRecordNumber
Declaration Syntax
C# Visual Basic Visual C++
public int SellingManagerSalesRecordNumber { get; set; }
Public Property SellingManagerSalesRecordNumber As Integer
    Get
    Set
public:
property int SellingManagerSalesRecordNumber {
    int get ();
    void set (int value);
}


SellingManagerSalesRecordNumberSpecified Property

SellingManagerSalesRecordNumberSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► SellingManagerSalesRecordNumberSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellingManagerSalesRecordNumberSpecified { get; set; }
Public Property SellingManagerSalesRecordNumberSpecified As Boolean
    Get
    Set
public:
property bool SellingManagerSalesRecordNumberSpecified {
    bool get ();
    void set (bool value);
}


ShipmentTrackingDetails Property

ShipmentTrackingDetails Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ShipmentTrackingDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShipmentTrackingDetailsTypeCollection ShipmentTrackingDetails { get; set; }
Public Property ShipmentTrackingDetails As ShipmentTrackingDetailsTypeCollection
    Get
    Set
public:
property ShipmentTrackingDetailsTypeCollection^ ShipmentTrackingDetails {
    ShipmentTrackingDetailsTypeCollection^ get ();
    void set (ShipmentTrackingDetailsTypeCollection^ value);
}


ShippingDetailsType Constructor

ShippingDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ShippingDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingDetailsType()
Public Sub New
public:
ShippingDetailsType()


ShippingDiscountProfileID Property

ShippingDiscountProfileID Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ShippingDiscountProfileID
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingDiscountProfileID { get; set; }
Public Property ShippingDiscountProfileID As String
    Get
    Set
public:
property String^ ShippingDiscountProfileID {
    String^ get ();
    void set (String^ value);
}


ShippingRateErrorMessage Property

ShippingRateErrorMessage Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ShippingRateErrorMessage
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingRateErrorMessage { get; set; }
Public Property ShippingRateErrorMessage As String
    Get
    Set
public:
property String^ ShippingRateErrorMessage {
    String^ get ();
    void set (String^ value);
}


ShippingRateType Property

ShippingRateType Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ShippingRateType
Declaration Syntax
C# Visual Basic Visual C++
public ShippingRateTypeCodeType ShippingRateType { get; set; }
Public Property ShippingRateType As ShippingRateTypeCodeType
    Get
    Set
public:
property ShippingRateTypeCodeType ShippingRateType {
    ShippingRateTypeCodeType get ();
    void set (ShippingRateTypeCodeType value);
}


ShippingRateTypeSpecified Property

ShippingRateTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ShippingRateTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingRateTypeSpecified { get; set; }
Public Property ShippingRateTypeSpecified As Boolean
    Get
    Set
public:
property bool ShippingRateTypeSpecified {
    bool get ();
    void set (bool value);
}


ShippingServiceOptions Property

ShippingServiceOptions Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ShippingServiceOptions
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsTypeCollection ShippingServiceOptions { get; set; }
Public Property ShippingServiceOptions As ShippingServiceOptionsTypeCollection
    Get
    Set
public:
property ShippingServiceOptionsTypeCollection^ ShippingServiceOptions {
    ShippingServiceOptionsTypeCollection^ get ();
    void set (ShippingServiceOptionsTypeCollection^ value);
}


ShippingServiceUsed Property

ShippingServiceUsed Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ShippingServiceUsed
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingServiceUsed { get; set; }
Public Property ShippingServiceUsed As String
    Get
    Set
public:
property String^ ShippingServiceUsed {
    String^ get ();
    void set (String^ value);
}


ShippingType Property

ShippingType Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ShippingType
Declaration Syntax
C# Visual Basic Visual C++
public ShippingTypeCodeType ShippingType { get; set; }
Public Property ShippingType As ShippingTypeCodeType
    Get
    Set
public:
property ShippingTypeCodeType ShippingType {
    ShippingTypeCodeType get ();
    void set (ShippingTypeCodeType value);
}


ShippingTypeSpecified Property

ShippingTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ShippingTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTypeSpecified { get; set; }
Public Property ShippingTypeSpecified As Boolean
    Get
    Set
public:
property bool ShippingTypeSpecified {
    bool get ();
    void set (bool value);
}


TaxTable Property

TaxTable Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► TaxTable
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection TaxTable { get; set; }
Public Property TaxTable As TaxJurisdictionTypeCollection
    Get
    Set
public:
property TaxJurisdictionTypeCollection^ TaxTable {
    TaxJurisdictionTypeCollection^ get ();
    void set (TaxJurisdictionTypeCollection^ value);
}


ThirdPartyCheckout Property

ThirdPartyCheckout Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ThirdPartyCheckout
Declaration Syntax
C# Visual Basic Visual C++
public bool ThirdPartyCheckout { get; set; }
Public Property ThirdPartyCheckout As Boolean
    Get
    Set
public:
property bool ThirdPartyCheckout {
    bool get ();
    void set (bool value);
}


ThirdPartyCheckoutSpecified Property

ThirdPartyCheckoutSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingDetailsType ► ThirdPartyCheckoutSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ThirdPartyCheckoutSpecified { get; set; }
Public Property ThirdPartyCheckoutSpecified As Boolean
    Get
    Set
public:
property bool ThirdPartyCheckoutSpecified {
    bool get ();
    void set (bool value);
}


ShippingFeatureCodeType Enumeration

ShippingFeatureCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ShippingFeatureCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ShippingFeatureCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ShippingFeatureCodeType
Members
Member | Description
DeliveryConfirmation |
SignatureConfirmation |
StealthPostage |
SaturdayDelivery |
Other |
NotDefined |
CustomCode |
Remarks


ShippingFeatureCodeTypeCollection Class

ShippingFeatureCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingFeatureCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingFeatureCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingFeatureCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingFeatureCodeTypeCollection()()()() |
 | ShippingFeatureCodeTypeCollection(array<ShippingFeatureCodeType>[]()[][]) |
 | ShippingFeatureCodeTypeCollection(ShippingFeatureCodeTypeCollection) |
 | Add(ShippingFeatureCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingFeatureCodeType>[]()[][]) |
 | AddRange(ShippingFeatureCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingFeatureCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingFeatureCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingFeatureCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingFeatureCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingFeatureCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingFeatureCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► Add(ShippingFeatureCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingFeatureCodeType item
)
Public Function Add ( _
    item As ShippingFeatureCodeType _
) As Integer
public:
int Add(
    ShippingFeatureCodeType item
)
Parameters
item (ShippingFeatureCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingFeatureCodeType>[]()[][]) |
 | AddRange(ShippingFeatureCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► AddRange(array<ShippingFeatureCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingFeatureCodeType[] items
)
Public Sub AddRange ( _
    items As ShippingFeatureCodeType() _
)
public:
void AddRange(
    array<ShippingFeatureCodeType>^ items
)
Parameters
items (array< ShippingFeatureCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► AddRange(ShippingFeatureCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingFeatureCodeTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingFeatureCodeTypeCollection _
)
public:
void AddRange(
    ShippingFeatureCodeTypeCollection^ items
)
Parameters
items (ShippingFeatureCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► Contains(ShippingFeatureCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingFeatureCodeType item
)
Public Function Contains ( _
    item As ShippingFeatureCodeType _
) As Boolean
public:
bool Contains(
    ShippingFeatureCodeType item
)
Parameters
item (ShippingFeatureCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► CopyTo(array<ShippingFeatureCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingFeatureCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingFeatureCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingFeatureCodeType>^ items,
    int index
)
Parameters
items (array< ShippingFeatureCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► IndexOf(ShippingFeatureCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingFeatureCodeType item
)
Public Function IndexOf ( _
    item As ShippingFeatureCodeType _
) As Integer
public:
int IndexOf(
    ShippingFeatureCodeType item
)
Parameters
item (ShippingFeatureCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► Insert(Int32, ShippingFeatureCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingFeatureCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingFeatureCodeType _
)
public:
void Insert(
    int index,
    ShippingFeatureCodeType item
)
Parameters
index (Int32)
item (ShippingFeatureCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingFeatureCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingFeatureCodeType
    Get
    Set
public:
property ShippingFeatureCodeType default[int index] {
    ShippingFeatureCodeType get (int index);
    void set (int index, ShippingFeatureCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingFeatureCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingFeatureCodeType
public:
ShippingFeatureCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► Remove(ShippingFeatureCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingFeatureCodeType item
)
Public Sub Remove ( _
    item As ShippingFeatureCodeType _
)
public:
void Remove(
    ShippingFeatureCodeType item
)
Parameters
item (ShippingFeatureCodeType)


ShippingFeatureCodeTypeCollection Constructor

ShippingFeatureCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► ShippingFeatureCodeTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingFeatureCodeTypeCollection()()()() |
 | ShippingFeatureCodeTypeCollection(array<ShippingFeatureCodeType>[]()[][]) |
 | ShippingFeatureCodeTypeCollection(ShippingFeatureCodeTypeCollection) |


ShippingFeatureCodeTypeCollection Constructor

ShippingFeatureCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► ShippingFeatureCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingFeatureCodeTypeCollection()
Public Sub New
public:
ShippingFeatureCodeTypeCollection()


ShippingFeatureCodeTypeCollection Constructor (items)

ShippingFeatureCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► ShippingFeatureCodeTypeCollection(array<ShippingFeatureCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingFeatureCodeTypeCollection(
    ShippingFeatureCodeType[] items
)
Public Sub New ( _
    items As ShippingFeatureCodeType() _
)
public:
ShippingFeatureCodeTypeCollection(
    array<ShippingFeatureCodeType>^ items
)
Parameters
items (array< ShippingFeatureCodeType >[]()[][])


ShippingFeatureCodeTypeCollection Constructor (items)

ShippingFeatureCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► ShippingFeatureCodeTypeCollection(ShippingFeatureCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingFeatureCodeTypeCollection(
    ShippingFeatureCodeTypeCollection items
)
Public Sub New ( _
    items As ShippingFeatureCodeTypeCollection _
)
public:
ShippingFeatureCodeTypeCollection(
    ShippingFeatureCodeTypeCollection^ items
)
Parameters
items (ShippingFeatureCodeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingFeatureCodeType[] ToArray()
Public Function ToArray As ShippingFeatureCodeType()
public:
array<ShippingFeatureCodeType>^ ToArray()
Return Value


ShippingInsuranceType Class

ShippingInsuranceType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingInsuranceType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingInsuranceType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingInsuranceType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingInsuranceType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingInsuranceType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FlatRateInsuranceRangeCost |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InsuranceOption |
 | InsuranceOptionSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShippingInsuranceType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingInsuranceType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FlatRateInsuranceRangeCost Property

FlatRateInsuranceRangeCost Property
Namespaces ► eBay.Service.Core.Soap ► ShippingInsuranceType ► FlatRateInsuranceRangeCost
Declaration Syntax
C# Visual Basic Visual C++
public FlatRateInsuranceRangeCostTypeCollection FlatRateInsuranceRangeCost { get; set; }
Public Property FlatRateInsuranceRangeCost As FlatRateInsuranceRangeCostTypeCollection
    Get
    Set
public:
property FlatRateInsuranceRangeCostTypeCollection^ FlatRateInsuranceRangeCost {
    FlatRateInsuranceRangeCostTypeCollection^ get ();
    void set (FlatRateInsuranceRangeCostTypeCollection^ value);
}


InsuranceOption Property

InsuranceOption Property
Namespaces ► eBay.Service.Core.Soap ► ShippingInsuranceType ► InsuranceOption
Declaration Syntax
C# Visual Basic Visual C++
public InsuranceOptionCodeType InsuranceOption { get; set; }
Public Property InsuranceOption As InsuranceOptionCodeType
    Get
    Set
public:
property InsuranceOptionCodeType InsuranceOption {
    InsuranceOptionCodeType get ();
    void set (InsuranceOptionCodeType value);
}


InsuranceOptionSpecified Property

InsuranceOptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingInsuranceType ► InsuranceOptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InsuranceOptionSpecified { get; set; }
Public Property InsuranceOptionSpecified As Boolean
    Get
    Set
public:
property bool InsuranceOptionSpecified {
    bool get ();
    void set (bool value);
}


ShippingInsuranceType Constructor

ShippingInsuranceType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingInsuranceType ► ShippingInsuranceType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingInsuranceType()
Public Sub New
public:
ShippingInsuranceType()


ShippingLocationDetailsType Class

ShippingLocationDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingLocationDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingLocationDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingLocationDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingLocationDetailsType()()()() |
 | Any |
 | Description |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingLocation |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
ShippingLocationDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


ShippingLocation Property

ShippingLocation Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsType ► ShippingLocation
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingLocation { get; set; }
Public Property ShippingLocation As String
    Get
    Set
public:
property String^ ShippingLocation {
    String^ get ();
    void set (String^ value);
}


ShippingLocationDetailsType Constructor

ShippingLocationDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsType ► ShippingLocationDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingLocationDetailsType()
Public Sub New
public:
ShippingLocationDetailsType()


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


ShippingLocationDetailsTypeCollection Class

ShippingLocationDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingLocationDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingLocationDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingLocationDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingLocationDetailsTypeCollection()()()() |
 | ShippingLocationDetailsTypeCollection(array<ShippingLocationDetailsType>[]()[][]) |
 | ShippingLocationDetailsTypeCollection(ShippingLocationDetailsTypeCollection) |
 | Add(ShippingLocationDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingLocationDetailsType>[]()[][]) |
 | AddRange(ShippingLocationDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingLocationDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingLocationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingLocationDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingLocationDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingLocationDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingLocationDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► Add(ShippingLocationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingLocationDetailsType item
)
Public Function Add ( _
    item As ShippingLocationDetailsType _
) As Integer
public:
int Add(
    ShippingLocationDetailsType^ item
)
Parameters
item (ShippingLocationDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingLocationDetailsType>[]()[][]) |
 | AddRange(ShippingLocationDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► AddRange(array<ShippingLocationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingLocationDetailsType[] items
)
Public Sub AddRange ( _
    items As ShippingLocationDetailsType() _
)
public:
void AddRange(
    array<ShippingLocationDetailsType^>^ items
)
Parameters
items (array< ShippingLocationDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► AddRange(ShippingLocationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingLocationDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingLocationDetailsTypeCollection _
)
public:
void AddRange(
    ShippingLocationDetailsTypeCollection^ items
)
Parameters
items (ShippingLocationDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► Contains(ShippingLocationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingLocationDetailsType item
)
Public Function Contains ( _
    item As ShippingLocationDetailsType _
) As Boolean
public:
bool Contains(
    ShippingLocationDetailsType^ item
)
Parameters
item (ShippingLocationDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► CopyTo(array<ShippingLocationDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingLocationDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingLocationDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingLocationDetailsType^>^ items,
    int index
)
Parameters
items (array< ShippingLocationDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► IndexOf(ShippingLocationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingLocationDetailsType item
)
Public Function IndexOf ( _
    item As ShippingLocationDetailsType _
) As Integer
public:
int IndexOf(
    ShippingLocationDetailsType^ item
)
Parameters
item (ShippingLocationDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► Insert(Int32, ShippingLocationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingLocationDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingLocationDetailsType _
)
public:
void Insert(
    int index,
    ShippingLocationDetailsType^ item
)
Parameters
index (Int32)
item (ShippingLocationDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingLocationDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingLocationDetailsType
    Get
    Set
public:
property ShippingLocationDetailsType^ default[int index] {
    ShippingLocationDetailsType^ get (int index);
    void set (int index, ShippingLocationDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingLocationDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingLocationDetailsType
public:
ShippingLocationDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► Remove(ShippingLocationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingLocationDetailsType item
)
Public Sub Remove ( _
    item As ShippingLocationDetailsType _
)
public:
void Remove(
    ShippingLocationDetailsType^ item
)
Parameters
item (ShippingLocationDetailsType)


ShippingLocationDetailsTypeCollection Constructor

ShippingLocationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► ShippingLocationDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingLocationDetailsTypeCollection()()()() |
 | ShippingLocationDetailsTypeCollection(array<ShippingLocationDetailsType>[]()[][]) |
 | ShippingLocationDetailsTypeCollection(ShippingLocationDetailsTypeCollection) |


ShippingLocationDetailsTypeCollection Constructor

ShippingLocationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► ShippingLocationDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingLocationDetailsTypeCollection()
Public Sub New
public:
ShippingLocationDetailsTypeCollection()


ShippingLocationDetailsTypeCollection Constructor (items)

ShippingLocationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► ShippingLocationDetailsTypeCollection(array<ShippingLocationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingLocationDetailsTypeCollection(
    ShippingLocationDetailsType[] items
)
Public Sub New ( _
    items As ShippingLocationDetailsType() _
)
public:
ShippingLocationDetailsTypeCollection(
    array<ShippingLocationDetailsType^>^ items
)
Parameters
items (array< ShippingLocationDetailsType >[]()[][])


ShippingLocationDetailsTypeCollection Constructor (items)

ShippingLocationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► ShippingLocationDetailsTypeCollection(ShippingLocationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingLocationDetailsTypeCollection(
    ShippingLocationDetailsTypeCollection items
)
Public Sub New ( _
    items As ShippingLocationDetailsTypeCollection _
)
public:
ShippingLocationDetailsTypeCollection(
    ShippingLocationDetailsTypeCollection^ items
)
Parameters
items (ShippingLocationDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingLocationDetailsType[] ToArray()
Public Function ToArray As ShippingLocationDetailsType()
public:
array<ShippingLocationDetailsType^>^ ToArray()
Return Value


ShippingOverrideType Class

ShippingOverrideType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingOverrideType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingOverrideType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingOverrideType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingOverrideType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingOverrideType()()()() |
 | DispatchTimeMaxOverride |
 | DispatchTimeMaxOverrideSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingServiceCostOverrideList |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShippingOverrideType


DispatchTimeMaxOverride Property

DispatchTimeMaxOverride Property
Namespaces ► eBay.Service.Core.Soap ► ShippingOverrideType ► DispatchTimeMaxOverride
Declaration Syntax
C# Visual Basic Visual C++
public int DispatchTimeMaxOverride { get; set; }
Public Property DispatchTimeMaxOverride As Integer
    Get
    Set
public:
property int DispatchTimeMaxOverride {
    int get ();
    void set (int value);
}


DispatchTimeMaxOverrideSpecified Property

DispatchTimeMaxOverrideSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingOverrideType ► DispatchTimeMaxOverrideSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DispatchTimeMaxOverrideSpecified { get; set; }
Public Property DispatchTimeMaxOverrideSpecified As Boolean
    Get
    Set
public:
property bool DispatchTimeMaxOverrideSpecified {
    bool get ();
    void set (bool value);
}


ShippingOverrideType Constructor

ShippingOverrideType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingOverrideType ► ShippingOverrideType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingOverrideType()
Public Sub New
public:
ShippingOverrideType()


ShippingServiceCostOverrideList Property

ShippingServiceCostOverrideList Property
Namespaces ► eBay.Service.Core.Soap ► ShippingOverrideType ► ShippingServiceCostOverrideList
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCostOverrideListType ShippingServiceCostOverrideList { get; set; }
Public Property ShippingServiceCostOverrideList As ShippingServiceCostOverrideListType
    Get
    Set
public:
property ShippingServiceCostOverrideListType^ ShippingServiceCostOverrideList {
    ShippingServiceCostOverrideListType^ get ();
    void set (ShippingServiceCostOverrideListType^ value);
}


ShippingPackageCodeType Enumeration

ShippingPackageCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ShippingPackageCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ShippingPackageCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ShippingPackageCodeType
Members
Member | Description
None |
Letter |
LargeEnvelope |
USPSLargePack |
VeryLargePack |
ExtraLargePack |
UPSLetter |
USPSFlatRateEnvelope |
PackageThickEnvelope |
Roll |
Europallet |
OneWayPallet |
BulkyGoods |
Furniture |
Cars |
Motorbikes |
Caravan |
IndustryVehicles |
ParcelOrPaddedEnvelope |
SmallCanadaPostBox |
MediumCanadaPostBox |
LargeCanadaPostBox |
SmallCanadaPostBubbleMailer |
MediumCanadaPostBubbleMailer |
LargeCanadaPostBubbleMailer |
PaddedBags |
ToughBags |
ExpandableToughBags |
MailingBoxes |
Winepak |
CustomCode |
Remarks


ShippingPackageCodeTypeCollection Class

ShippingPackageCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingPackageCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingPackageCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingPackageCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingPackageCodeTypeCollection()()()() |
 | ShippingPackageCodeTypeCollection(array<ShippingPackageCodeType>[]()[][]) |
 | ShippingPackageCodeTypeCollection(ShippingPackageCodeTypeCollection) |
 | Add(ShippingPackageCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingPackageCodeType>[]()[][]) |
 | AddRange(ShippingPackageCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingPackageCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingPackageCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingPackageCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingPackageCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingPackageCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingPackageCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► Add(ShippingPackageCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingPackageCodeType item
)
Public Function Add ( _
    item As ShippingPackageCodeType _
) As Integer
public:
int Add(
    ShippingPackageCodeType item
)
Parameters
item (ShippingPackageCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingPackageCodeType>[]()[][]) |
 | AddRange(ShippingPackageCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► AddRange(array<ShippingPackageCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingPackageCodeType[] items
)
Public Sub AddRange ( _
    items As ShippingPackageCodeType() _
)
public:
void AddRange(
    array<ShippingPackageCodeType>^ items
)
Parameters
items (array< ShippingPackageCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► AddRange(ShippingPackageCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingPackageCodeTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingPackageCodeTypeCollection _
)
public:
void AddRange(
    ShippingPackageCodeTypeCollection^ items
)
Parameters
items (ShippingPackageCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► Contains(ShippingPackageCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingPackageCodeType item
)
Public Function Contains ( _
    item As ShippingPackageCodeType _
) As Boolean
public:
bool Contains(
    ShippingPackageCodeType item
)
Parameters
item (ShippingPackageCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► CopyTo(array<ShippingPackageCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingPackageCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingPackageCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingPackageCodeType>^ items,
    int index
)
Parameters
items (array< ShippingPackageCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► IndexOf(ShippingPackageCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingPackageCodeType item
)
Public Function IndexOf ( _
    item As ShippingPackageCodeType _
) As Integer
public:
int IndexOf(
    ShippingPackageCodeType item
)
Parameters
item (ShippingPackageCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► Insert(Int32, ShippingPackageCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingPackageCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingPackageCodeType _
)
public:
void Insert(
    int index,
    ShippingPackageCodeType item
)
Parameters
index (Int32)
item (ShippingPackageCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingPackageCodeType
    Get
    Set
public:
property ShippingPackageCodeType default[int index] {
    ShippingPackageCodeType get (int index);
    void set (int index, ShippingPackageCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingPackageCodeType
public:
ShippingPackageCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► Remove(ShippingPackageCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingPackageCodeType item
)
Public Sub Remove ( _
    item As ShippingPackageCodeType _
)
public:
void Remove(
    ShippingPackageCodeType item
)
Parameters
item (ShippingPackageCodeType)


ShippingPackageCodeTypeCollection Constructor

ShippingPackageCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► ShippingPackageCodeTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingPackageCodeTypeCollection()()()() |
 | ShippingPackageCodeTypeCollection(array<ShippingPackageCodeType>[]()[][]) |
 | ShippingPackageCodeTypeCollection(ShippingPackageCodeTypeCollection) |


ShippingPackageCodeTypeCollection Constructor

ShippingPackageCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► ShippingPackageCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeTypeCollection()
Public Sub New
public:
ShippingPackageCodeTypeCollection()


ShippingPackageCodeTypeCollection Constructor (items)

ShippingPackageCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► ShippingPackageCodeTypeCollection(array<ShippingPackageCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeTypeCollection(
    ShippingPackageCodeType[] items
)
Public Sub New ( _
    items As ShippingPackageCodeType() _
)
public:
ShippingPackageCodeTypeCollection(
    array<ShippingPackageCodeType>^ items
)
Parameters
items (array< ShippingPackageCodeType >[]()[][])


ShippingPackageCodeTypeCollection Constructor (items)

ShippingPackageCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► ShippingPackageCodeTypeCollection(ShippingPackageCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeTypeCollection(
    ShippingPackageCodeTypeCollection items
)
Public Sub New ( _
    items As ShippingPackageCodeTypeCollection _
)
public:
ShippingPackageCodeTypeCollection(
    ShippingPackageCodeTypeCollection^ items
)
Parameters
items (ShippingPackageCodeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeType[] ToArray()
Public Function ToArray As ShippingPackageCodeType()
public:
array<ShippingPackageCodeType>^ ToArray()
Return Value


ShippingPackageDetailsType Class

ShippingPackageDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingPackageDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingPackageDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingPackageDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingPackageDetailsType()()()() |
 | Any |
 | DefaultValue |
 | DefaultValueSpecified |
 | Description |
 | DetailVersion |
 | DimensionsSupported |
 | DimensionsSupportedSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PackageID |
 | PackageIDSpecified |
 | ShippingPackage |
 | ShippingPackageSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
ShippingPackageDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DefaultValue Property

DefaultValue Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► DefaultValue
Declaration Syntax
C# Visual Basic Visual C++
public bool DefaultValue { get; set; }
Public Property DefaultValue As Boolean
    Get
    Set
public:
property bool DefaultValue {
    bool get ();
    void set (bool value);
}


DefaultValueSpecified Property

DefaultValueSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► DefaultValueSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DefaultValueSpecified { get; set; }
Public Property DefaultValueSpecified As Boolean
    Get
    Set
public:
property bool DefaultValueSpecified {
    bool get ();
    void set (bool value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


DimensionsSupported Property

DimensionsSupported Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► DimensionsSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool DimensionsSupported { get; set; }
Public Property DimensionsSupported As Boolean
    Get
    Set
public:
property bool DimensionsSupported {
    bool get ();
    void set (bool value);
}


DimensionsSupportedSpecified Property

DimensionsSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► DimensionsSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DimensionsSupportedSpecified { get; set; }
Public Property DimensionsSupportedSpecified As Boolean
    Get
    Set
public:
property bool DimensionsSupportedSpecified {
    bool get ();
    void set (bool value);
}


PackageID Property

PackageID Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► PackageID
Declaration Syntax
C# Visual Basic Visual C++
public int PackageID { get; set; }
Public Property PackageID As Integer
    Get
    Set
public:
property int PackageID {
    int get ();
    void set (int value);
}


PackageIDSpecified Property

PackageIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► PackageIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PackageIDSpecified { get; set; }
Public Property PackageIDSpecified As Boolean
    Get
    Set
public:
property bool PackageIDSpecified {
    bool get ();
    void set (bool value);
}


ShippingPackage Property

ShippingPackage Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► ShippingPackage
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeType ShippingPackage { get; set; }
Public Property ShippingPackage As ShippingPackageCodeType
    Get
    Set
public:
property ShippingPackageCodeType ShippingPackage {
    ShippingPackageCodeType get ();
    void set (ShippingPackageCodeType value);
}


ShippingPackageDetailsType Constructor

ShippingPackageDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► ShippingPackageDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageDetailsType()
Public Sub New
public:
ShippingPackageDetailsType()


ShippingPackageSpecified Property

ShippingPackageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► ShippingPackageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingPackageSpecified { get; set; }
Public Property ShippingPackageSpecified As Boolean
    Get
    Set
public:
property bool ShippingPackageSpecified {
    bool get ();
    void set (bool value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


ShippingPackageDetailsTypeCollection Class

ShippingPackageDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingPackageDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingPackageDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingPackageDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingPackageDetailsTypeCollection()()()() |
 | ShippingPackageDetailsTypeCollection(array<ShippingPackageDetailsType>[]()[][]) |
 | ShippingPackageDetailsTypeCollection(ShippingPackageDetailsTypeCollection) |
 | Add(ShippingPackageDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingPackageDetailsType>[]()[][]) |
 | AddRange(ShippingPackageDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingPackageDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingPackageDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingPackageDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingPackageDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingPackageDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingPackageDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► Add(ShippingPackageDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingPackageDetailsType item
)
Public Function Add ( _
    item As ShippingPackageDetailsType _
) As Integer
public:
int Add(
    ShippingPackageDetailsType^ item
)
Parameters
item (ShippingPackageDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingPackageDetailsType>[]()[][]) |
 | AddRange(ShippingPackageDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► AddRange(array<ShippingPackageDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingPackageDetailsType[] items
)
Public Sub AddRange ( _
    items As ShippingPackageDetailsType() _
)
public:
void AddRange(
    array<ShippingPackageDetailsType^>^ items
)
Parameters
items (array< ShippingPackageDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► AddRange(ShippingPackageDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingPackageDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingPackageDetailsTypeCollection _
)
public:
void AddRange(
    ShippingPackageDetailsTypeCollection^ items
)
Parameters
items (ShippingPackageDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► Contains(ShippingPackageDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingPackageDetailsType item
)
Public Function Contains ( _
    item As ShippingPackageDetailsType _
) As Boolean
public:
bool Contains(
    ShippingPackageDetailsType^ item
)
Parameters
item (ShippingPackageDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► CopyTo(array<ShippingPackageDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingPackageDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingPackageDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingPackageDetailsType^>^ items,
    int index
)
Parameters
items (array< ShippingPackageDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► IndexOf(ShippingPackageDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingPackageDetailsType item
)
Public Function IndexOf ( _
    item As ShippingPackageDetailsType _
) As Integer
public:
int IndexOf(
    ShippingPackageDetailsType^ item
)
Parameters
item (ShippingPackageDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► Insert(Int32, ShippingPackageDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingPackageDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingPackageDetailsType _
)
public:
void Insert(
    int index,
    ShippingPackageDetailsType^ item
)
Parameters
index (Int32)
item (ShippingPackageDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingPackageDetailsType
    Get
    Set
public:
property ShippingPackageDetailsType^ default[int index] {
    ShippingPackageDetailsType^ get (int index);
    void set (int index, ShippingPackageDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingPackageDetailsType
public:
ShippingPackageDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► Remove(ShippingPackageDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingPackageDetailsType item
)
Public Sub Remove ( _
    item As ShippingPackageDetailsType _
)
public:
void Remove(
    ShippingPackageDetailsType^ item
)
Parameters
item (ShippingPackageDetailsType)


ShippingPackageDetailsTypeCollection Constructor

ShippingPackageDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► ShippingPackageDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingPackageDetailsTypeCollection()()()() |
 | ShippingPackageDetailsTypeCollection(array<ShippingPackageDetailsType>[]()[][]) |
 | ShippingPackageDetailsTypeCollection(ShippingPackageDetailsTypeCollection) |


ShippingPackageDetailsTypeCollection Constructor

ShippingPackageDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► ShippingPackageDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageDetailsTypeCollection()
Public Sub New
public:
ShippingPackageDetailsTypeCollection()


ShippingPackageDetailsTypeCollection Constructor (items)

ShippingPackageDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► ShippingPackageDetailsTypeCollection(array<ShippingPackageDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageDetailsTypeCollection(
    ShippingPackageDetailsType[] items
)
Public Sub New ( _
    items As ShippingPackageDetailsType() _
)
public:
ShippingPackageDetailsTypeCollection(
    array<ShippingPackageDetailsType^>^ items
)
Parameters
items (array< ShippingPackageDetailsType >[]()[][])


ShippingPackageDetailsTypeCollection Constructor (items)

ShippingPackageDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► ShippingPackageDetailsTypeCollection(ShippingPackageDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageDetailsTypeCollection(
    ShippingPackageDetailsTypeCollection items
)
Public Sub New ( _
    items As ShippingPackageDetailsTypeCollection _
)
public:
ShippingPackageDetailsTypeCollection(
    ShippingPackageDetailsTypeCollection^ items
)
Parameters
items (ShippingPackageDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageDetailsType[] ToArray()
Public Function ToArray As ShippingPackageDetailsType()
public:
array<ShippingPackageDetailsType^>^ ToArray()
Return Value


ShippingPackageInfoType Class

ShippingPackageInfoType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingPackageInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingPackageInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingPackageInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingPackageInfoType()()()() |
 | ActualDeliveryTime |
 | ActualDeliveryTimeSpecified |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | EstimatedDeliveryTimeMax |
 | EstimatedDeliveryTimeMaxSpecified |
 | EstimatedDeliveryTimeMin |
 | EstimatedDeliveryTimeMinSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ScheduledDeliveryTimeMax |
 | ScheduledDeliveryTimeMaxSpecified |
 | ScheduledDeliveryTimeMin |
 | ScheduledDeliveryTimeMinSpecified |
 | ShippingTrackingEvent |
 | StoreID |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShippingPackageInfoType


ActualDeliveryTime Property

ActualDeliveryTime Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► ActualDeliveryTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ActualDeliveryTime { get; set; }
Public Property ActualDeliveryTime As DateTime
    Get
    Set
public:
property DateTime ActualDeliveryTime {
    DateTime get ();
    void set (DateTime value);
}


ActualDeliveryTimeSpecified Property

ActualDeliveryTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► ActualDeliveryTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ActualDeliveryTimeSpecified { get; set; }
Public Property ActualDeliveryTimeSpecified As Boolean
    Get
    Set
public:
property bool ActualDeliveryTimeSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EstimatedDeliveryTimeMax Property

EstimatedDeliveryTimeMax Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► EstimatedDeliveryTimeMax
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EstimatedDeliveryTimeMax { get; set; }
Public Property EstimatedDeliveryTimeMax As DateTime
    Get
    Set
public:
property DateTime EstimatedDeliveryTimeMax {
    DateTime get ();
    void set (DateTime value);
}


EstimatedDeliveryTimeMaxSpecified Property

EstimatedDeliveryTimeMaxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► EstimatedDeliveryTimeMaxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EstimatedDeliveryTimeMaxSpecified { get; set; }
Public Property EstimatedDeliveryTimeMaxSpecified As Boolean
    Get
    Set
public:
property bool EstimatedDeliveryTimeMaxSpecified {
    bool get ();
    void set (bool value);
}


EstimatedDeliveryTimeMin Property

EstimatedDeliveryTimeMin Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► EstimatedDeliveryTimeMin
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EstimatedDeliveryTimeMin { get; set; }
Public Property EstimatedDeliveryTimeMin As DateTime
    Get
    Set
public:
property DateTime EstimatedDeliveryTimeMin {
    DateTime get ();
    void set (DateTime value);
}


EstimatedDeliveryTimeMinSpecified Property

EstimatedDeliveryTimeMinSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► EstimatedDeliveryTimeMinSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EstimatedDeliveryTimeMinSpecified { get; set; }
Public Property EstimatedDeliveryTimeMinSpecified As Boolean
    Get
    Set
public:
property bool EstimatedDeliveryTimeMinSpecified {
    bool get ();
    void set (bool value);
}


ScheduledDeliveryTimeMax Property

ScheduledDeliveryTimeMax Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► ScheduledDeliveryTimeMax
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ScheduledDeliveryTimeMax { get; set; }
Public Property ScheduledDeliveryTimeMax As DateTime
    Get
    Set
public:
property DateTime ScheduledDeliveryTimeMax {
    DateTime get ();
    void set (DateTime value);
}


ScheduledDeliveryTimeMaxSpecified Property

ScheduledDeliveryTimeMaxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► ScheduledDeliveryTimeMaxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ScheduledDeliveryTimeMaxSpecified { get; set; }
Public Property ScheduledDeliveryTimeMaxSpecified As Boolean
    Get
    Set
public:
property bool ScheduledDeliveryTimeMaxSpecified {
    bool get ();
    void set (bool value);
}


ScheduledDeliveryTimeMin Property

ScheduledDeliveryTimeMin Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► ScheduledDeliveryTimeMin
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ScheduledDeliveryTimeMin { get; set; }
Public Property ScheduledDeliveryTimeMin As DateTime
    Get
    Set
public:
property DateTime ScheduledDeliveryTimeMin {
    DateTime get ();
    void set (DateTime value);
}


ScheduledDeliveryTimeMinSpecified Property

ScheduledDeliveryTimeMinSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► ScheduledDeliveryTimeMinSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ScheduledDeliveryTimeMinSpecified { get; set; }
Public Property ScheduledDeliveryTimeMinSpecified As Boolean
    Get
    Set
public:
property bool ScheduledDeliveryTimeMinSpecified {
    bool get ();
    void set (bool value);
}


ShippingPackageInfoType Constructor

ShippingPackageInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► ShippingPackageInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageInfoType()
Public Sub New
public:
ShippingPackageInfoType()


ShippingTrackingEvent Property

ShippingTrackingEvent Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► ShippingTrackingEvent
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingTrackingEvent { get; set; }
Public Property ShippingTrackingEvent As String
    Get
    Set
public:
property String^ ShippingTrackingEvent {
    String^ get ();
    void set (String^ value);
}


StoreID Property

StoreID Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoType ► StoreID
Declaration Syntax
C# Visual Basic Visual C++
public string StoreID { get; set; }
Public Property StoreID As String
    Get
    Set
public:
property String^ StoreID {
    String^ get ();
    void set (String^ value);
}


ShippingPackageInfoTypeCollection Class

ShippingPackageInfoTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingPackageInfoTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingPackageInfoTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingPackageInfoTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingPackageInfoTypeCollection()()()() |
 | ShippingPackageInfoTypeCollection(array<ShippingPackageInfoType>[]()[][]) |
 | ShippingPackageInfoTypeCollection(ShippingPackageInfoTypeCollection) |
 | Add(ShippingPackageInfoType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingPackageInfoType>[]()[][]) |
 | AddRange(ShippingPackageInfoTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingPackageInfoType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingPackageInfoType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingPackageInfoType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingPackageInfoType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingPackageInfoType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingPackageInfoTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► Add(ShippingPackageInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingPackageInfoType item
)
Public Function Add ( _
    item As ShippingPackageInfoType _
) As Integer
public:
int Add(
    ShippingPackageInfoType^ item
)
Parameters
item (ShippingPackageInfoType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingPackageInfoType>[]()[][]) |
 | AddRange(ShippingPackageInfoTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► AddRange(array<ShippingPackageInfoType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingPackageInfoType[] items
)
Public Sub AddRange ( _
    items As ShippingPackageInfoType() _
)
public:
void AddRange(
    array<ShippingPackageInfoType^>^ items
)
Parameters
items (array< ShippingPackageInfoType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► AddRange(ShippingPackageInfoTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingPackageInfoTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingPackageInfoTypeCollection _
)
public:
void AddRange(
    ShippingPackageInfoTypeCollection^ items
)
Parameters
items (ShippingPackageInfoTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► Contains(ShippingPackageInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingPackageInfoType item
)
Public Function Contains ( _
    item As ShippingPackageInfoType _
) As Boolean
public:
bool Contains(
    ShippingPackageInfoType^ item
)
Parameters
item (ShippingPackageInfoType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► CopyTo(array<ShippingPackageInfoType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingPackageInfoType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingPackageInfoType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingPackageInfoType^>^ items,
    int index
)
Parameters
items (array< ShippingPackageInfoType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► IndexOf(ShippingPackageInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingPackageInfoType item
)
Public Function IndexOf ( _
    item As ShippingPackageInfoType _
) As Integer
public:
int IndexOf(
    ShippingPackageInfoType^ item
)
Parameters
item (ShippingPackageInfoType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► Insert(Int32, ShippingPackageInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingPackageInfoType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingPackageInfoType _
)
public:
void Insert(
    int index,
    ShippingPackageInfoType^ item
)
Parameters
index (Int32)
item (ShippingPackageInfoType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageInfoType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingPackageInfoType
    Get
    Set
public:
property ShippingPackageInfoType^ default[int index] {
    ShippingPackageInfoType^ get (int index);
    void set (int index, ShippingPackageInfoType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageInfoType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingPackageInfoType
public:
ShippingPackageInfoType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► Remove(ShippingPackageInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingPackageInfoType item
)
Public Sub Remove ( _
    item As ShippingPackageInfoType _
)
public:
void Remove(
    ShippingPackageInfoType^ item
)
Parameters
item (ShippingPackageInfoType)


ShippingPackageInfoTypeCollection Constructor

ShippingPackageInfoTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► ShippingPackageInfoTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingPackageInfoTypeCollection()()()() |
 | ShippingPackageInfoTypeCollection(array<ShippingPackageInfoType>[]()[][]) |
 | ShippingPackageInfoTypeCollection(ShippingPackageInfoTypeCollection) |


ShippingPackageInfoTypeCollection Constructor

ShippingPackageInfoTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► ShippingPackageInfoTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageInfoTypeCollection()
Public Sub New
public:
ShippingPackageInfoTypeCollection()


ShippingPackageInfoTypeCollection Constructor (items)

ShippingPackageInfoTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► ShippingPackageInfoTypeCollection(array<ShippingPackageInfoType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageInfoTypeCollection(
    ShippingPackageInfoType[] items
)
Public Sub New ( _
    items As ShippingPackageInfoType() _
)
public:
ShippingPackageInfoTypeCollection(
    array<ShippingPackageInfoType^>^ items
)
Parameters
items (array< ShippingPackageInfoType >[]()[][])


ShippingPackageInfoTypeCollection Constructor (items)

ShippingPackageInfoTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► ShippingPackageInfoTypeCollection(ShippingPackageInfoTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageInfoTypeCollection(
    ShippingPackageInfoTypeCollection items
)
Public Sub New ( _
    items As ShippingPackageInfoTypeCollection _
)
public:
ShippingPackageInfoTypeCollection(
    ShippingPackageInfoTypeCollection^ items
)
Parameters
items (ShippingPackageInfoTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageInfoType[] ToArray()
Public Function ToArray As ShippingPackageInfoType()
public:
array<ShippingPackageInfoType^>^ ToArray()
Return Value


ShippingRateTypeCodeType Enumeration

ShippingRateTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ShippingRateTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ShippingRateTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ShippingRateTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ShippingRateTypeCodeType
Members
Member | Description
OnDemand |
DailyPickup |
StandardList |
Counter |
Discounted |
CommercialPlus |
GoldSilver |
PlatTitanium |
CustomCode |
Remarks


ShippingRegionCodeType Enumeration

ShippingRegionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ShippingRegionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ShippingRegionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ShippingRegionCodeType
Members
Member | Description
Africa |
Asia |
Caribbean |
Europe |
LatinAmerica |
MiddleEast |
NorthAmerica |
Oceania |
SouthAmerica |
EuropeanUnion |
WillNotShip |
Worldwide |
Americas |
None |
CustomCode |
Remarks


ShippingRegionCodeTypeCollection Class

ShippingRegionCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingRegionCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingRegionCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingRegionCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingRegionCodeTypeCollection()()()() |
 | ShippingRegionCodeTypeCollection(array<ShippingRegionCodeType>[]()[][]) |
 | ShippingRegionCodeTypeCollection(ShippingRegionCodeTypeCollection) |
 | Add(ShippingRegionCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingRegionCodeType>[]()[][]) |
 | AddRange(ShippingRegionCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingRegionCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingRegionCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingRegionCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingRegionCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingRegionCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingRegionCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► Add(ShippingRegionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingRegionCodeType item
)
Public Function Add ( _
    item As ShippingRegionCodeType _
) As Integer
public:
int Add(
    ShippingRegionCodeType item
)
Parameters
item (ShippingRegionCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingRegionCodeType>[]()[][]) |
 | AddRange(ShippingRegionCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► AddRange(array<ShippingRegionCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingRegionCodeType[] items
)
Public Sub AddRange ( _
    items As ShippingRegionCodeType() _
)
public:
void AddRange(
    array<ShippingRegionCodeType>^ items
)
Parameters
items (array< ShippingRegionCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► AddRange(ShippingRegionCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingRegionCodeTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingRegionCodeTypeCollection _
)
public:
void AddRange(
    ShippingRegionCodeTypeCollection^ items
)
Parameters
items (ShippingRegionCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► Contains(ShippingRegionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingRegionCodeType item
)
Public Function Contains ( _
    item As ShippingRegionCodeType _
) As Boolean
public:
bool Contains(
    ShippingRegionCodeType item
)
Parameters
item (ShippingRegionCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► CopyTo(array<ShippingRegionCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingRegionCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingRegionCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingRegionCodeType>^ items,
    int index
)
Parameters
items (array< ShippingRegionCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► IndexOf(ShippingRegionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingRegionCodeType item
)
Public Function IndexOf ( _
    item As ShippingRegionCodeType _
) As Integer
public:
int IndexOf(
    ShippingRegionCodeType item
)
Parameters
item (ShippingRegionCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► Insert(Int32, ShippingRegionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingRegionCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingRegionCodeType _
)
public:
void Insert(
    int index,
    ShippingRegionCodeType item
)
Parameters
index (Int32)
item (ShippingRegionCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingRegionCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingRegionCodeType
    Get
    Set
public:
property ShippingRegionCodeType default[int index] {
    ShippingRegionCodeType get (int index);
    void set (int index, ShippingRegionCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingRegionCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingRegionCodeType
public:
ShippingRegionCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► Remove(ShippingRegionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingRegionCodeType item
)
Public Sub Remove ( _
    item As ShippingRegionCodeType _
)
public:
void Remove(
    ShippingRegionCodeType item
)
Parameters
item (ShippingRegionCodeType)


ShippingRegionCodeTypeCollection Constructor

ShippingRegionCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► ShippingRegionCodeTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingRegionCodeTypeCollection()()()() |
 | ShippingRegionCodeTypeCollection(array<ShippingRegionCodeType>[]()[][]) |
 | ShippingRegionCodeTypeCollection(ShippingRegionCodeTypeCollection) |


ShippingRegionCodeTypeCollection Constructor

ShippingRegionCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► ShippingRegionCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingRegionCodeTypeCollection()
Public Sub New
public:
ShippingRegionCodeTypeCollection()


ShippingRegionCodeTypeCollection Constructor (items)

ShippingRegionCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► ShippingRegionCodeTypeCollection(array<ShippingRegionCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingRegionCodeTypeCollection(
    ShippingRegionCodeType[] items
)
Public Sub New ( _
    items As ShippingRegionCodeType() _
)
public:
ShippingRegionCodeTypeCollection(
    array<ShippingRegionCodeType>^ items
)
Parameters
items (array< ShippingRegionCodeType >[]()[][])


ShippingRegionCodeTypeCollection Constructor (items)

ShippingRegionCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► ShippingRegionCodeTypeCollection(ShippingRegionCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingRegionCodeTypeCollection(
    ShippingRegionCodeTypeCollection items
)
Public Sub New ( _
    items As ShippingRegionCodeTypeCollection _
)
public:
ShippingRegionCodeTypeCollection(
    ShippingRegionCodeTypeCollection^ items
)
Parameters
items (ShippingRegionCodeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingRegionCodeType[] ToArray()
Public Function ToArray As ShippingRegionCodeType()
public:
array<ShippingRegionCodeType>^ ToArray()
Return Value


ShippingServiceCodeType Enumeration

ShippingServiceCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ShippingServiceCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ShippingServiceCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ShippingServiceCodeType
Members
Member | Description
UPSGround |
UPS3rdDay |
UPS2ndDay |
UPSNextDay |
USPSPriority |
USPSParcel |
USPSStandardPost |
USPSMedia |
USPSFirstClass |
ShippingMethodStandard |
ShippingMethodExpress |
USPSExpressMail |
UPSNextDayAir |
UPS2DayAirAM |
USPSExpressMailFlatRateEnvelope |
USPSExpressMailPaddedFlatRateEnvelope |
USPSPriorityMailFlatRateEnvelope |
USPSPriorityMailSmallFlatRateBox |
USPSPriorityMailFlatRateBox |
USPSPriorityMailLargeFlatRateBox |
USPSPriorityMailPaddedFlatRateEnvelope |
USPSPriorityMailLegalFlatRateEnvelope |
USPSExpressMailLegalFlatRateEnvelope |
USPSPriorityMailRegionalBoxA |
USPSPriorityMailRegionalBoxB |
USPSPriorityMailRegionalBoxC |
USPSExpressMailFlatRateBox |
Other |
LocalDelivery |
NotSelected |
InternationalNotSelected |
StandardInternational |
ExpeditedInternational |
USPSGlobalExpress |
USPSGlobalPriority |
USPSEconomyParcel |
USPSEconomyLetter |
USPSAirmailLetter |
USPSAirmailParcel |
UPSWorldWideExpressPlus |
UPSWorldWideExpress |
UPSWorldWideExpedited |
UPSWorldwideSaver |
UPSStandardToCanada |
USPSExpressMailInternationalFlatRateEnvelope |
USPSExpressMailInternationalPaddedFlatRateEnvelope |
USPSPriorityMailInternationalFlatRateEnvelope |
USPSPriorityMailInternationalSmallFlatRateBox |
USPSPriorityMailInternationalFlatRateBox |
USPSPriorityMailInternationalLargeFlatRateBox |
USPSPriorityMailInternationalPaddedFlatRateEnvelope |
USPSPriorityMailInternationalLegalFlatRateEnvelope |
USPSExpressMailInternationalLegalFlatRateEnvelope |
USPSExpressMailInternationalFlatRateBox |
OtherInternational |
AT_StandardDispatch |
AT_InsuredDispatch |
AT_Writing |
AT_COD |
AT_ExpressOrCourier |
AT_InsuredExpressOrCourier |
AT_SpecialDispatch |
AT_InsuredSpecialDispatch |
AT_Sonstige |
AT_UnversicherterVersandInternational |
AT_VersicherterVersandInternational |
AT_SonstigerVersandInternational |
AT_UnversicherterExpressVersandInternational |
AT_VersicherterExpressVersandInternational |
AT_EconomyDeliveryFromAbroad |
AT_StandardDeliveryFromAbroad |
AT_ExpressDeliveryFromAbroad |
AT_TrackedDeliveryFromAbroad |
AU_Regular |
AU_Express |
AU_Registered |
AU_Courier |
AU_Other |
AU_EMSInternationalCourierParcels |
AU_EMSInternationalCourierDocuments |
AU_ExpressPostInternationalDocuments |
AU_AirMailInternational |
AU_EconomyAirInternational |
AU_SeaMailInternational |
AU_StandardInternational |
AU_ExpeditedInternational |
AU_OtherInternational |
AU_AusPostRegisteredPostInternationalPaddedBag1kg |
AU_AusPostRegisteredPostInternationalPaddedBag500g |
AU_AusPostRegisteredPostInternationalParcel |
AU_ExpeditedDeliveryFromOutsideAU |
AU_EconomyDeliveryFromOutsideAU |
AU_StandardDeliveryFromOutsideAU |
AU_AustralianAirExpressMetro15kg |
AU_AustralianAirExpressFlatRate5kg |
AU_AustralianAirExpressFlatRate3kg |
AU_AustralianAirExpressFlatRate1kg |
AU_ExpressDelivery |
AU_StandardDelivery |
AU_eBayAusPost3kgFlatRateSatchel |
AU_eBayAusPost500gFlatRateSatchel |
AU_Freight |
BEFR_StandardDelivery |
BEFR_PriorityDelivery |
BEFR_ParcelPost |
BEFR_RegisteredMail |
BEFR_Other |
BEFR_DePostInternational |
BEFR_UPSInternational |
BEFR_FedExInternational |
BEFR_DHLInternational |
BEFR_TPGPostTNTInternational |
BEFR_StandardInternational |
BEFR_ExpeditedInternational |
BEFR_OtherInternational |
BEFR_LaPosteInternational |
BEFR_LaPosteStandardShipping |
BEFR_LaPosteCertifiedShipping |
BEFR_LaPosteTaxipostLLS |
BEFR_LaPosteTaxipost24h |
BEFR_LaPosteTaxipostSecur |
BEFR_PostInternationalStandard |
BEFR_PostInternationalRegistered |
BEFR_TNTInternational |
BEFR_EconomyDeliveryFromAbroad |
BEFR_StandardDeliveryFromAbroad |
BEFR_ExpressDeliveryFromAbroad |
BEFR_TrackedDeliveryFromAbroad |
BENL_StandardDelivery |
BENL_PriorityDelivery |
BENL_ParcelPost |
BENL_RegisteredMail |
BENL_Other |
BENL_DePostInternational |
BENL_UPSInternational |
BENL_FedExInternational |
BENL_DHLInternational |
BENL_TPGPostTNTInternational |
BENL_StandardInternational |
BENL_ExpeditedInternational |
BENL_OtherInternational |
BENL_LaPosteInternational |
BENL_DePostStandardShipping |
BENL_DePostCertifiedShipping |
BENL_DePostTaxipostLLS |
BENL_DePostTaxipost24h |
BENL_DePostTaxipostSecur |
BENL_OtherShippingMethods |
BENL_PostInternationalStandard |
BENL_PostInternationalRegistered |
BENL_TNTInternational |
BENL_EconomyDeliveryFromAbroad |
BENL_StandardDeliveryFromAbroad |
BENL_ExpressDeliveryFromAbroad |
BENL_TrackedDeliveryFromAbroad |
CA_StandardDelivery |
CA_ExpeditedDelivery |
CA_PostLettermail |
CA_PostRegularParcel |
CA_PostExpeditedParcel |
CA_PostXpresspost |
CA_PostPriorityCourier |
CanadaPostExpeditedFlatRateBox |
CA_PostExpeditedFlatRateBox |
CA_StandardInternational |
CA_ExpeditedInternational |
CA_OtherInternational |
CA_PostExpeditedParcelUSA |
CA_PostSmallPacketsUSA |
CA_PostXpresspostUSA |
CA_PostXpresspostInternational |
CA_PostInternationalParcelSurface |
CA_PostInternationalParcelAir |
CA_SmallPacketsInternational |
CA_PurolatorInternational |
CA_PostSmallPacketsUSAGround |
CA_PostSmallPacketsUSAAir |
CA_SmallPacketsInternationalGround |
CA_SmallPacketsInternationalAir |
CA_PostUSALetterPost |
CA_PostInternationalLetterPost |
CA_PostExpeditedFlatRateBoxUSA |
CA_UPSExpressCanada |
CA_UPSExpressSaverCanada |
CA_UPSExpeditedCanada |
CA_UPSStandardCanada |
CA_UPSExpressUnitedStates |
CA_UPSExpeditedUnitedStates |
CA_UPS3DaySelectUnitedStates |
CA_UPSStandardUnitedStates |
CA_UPSWorldWideExpress |
CA_UPSWorldWideExpedited |
CA_PriorityWorldwide |
CanadaPostExpeditedFlatRateBoxUSA |
CA_PostTrackedPacketsUSA |
CA_PostTrackedPacketsInternational |
CA_Freight |
CH_StandardDispatchAPost |
CH_StandardDispatchBPost |
CH_InsuredDispatch |
CH_Writing |
CH_COD |
CH_ExpressOrCourier |
CH_InsuredExpressOrCourier |
CH_SpecialDispatch |
CH_InsuredSpecialDispatch |
CH_Sonstige |
CH_SonstigerVersandInternational |
CH_EconomySendungenInternational |
CH_PrioritySendungenInternational |
CH_UrgentSendungenInternational |
CH_EconomyDeliveryFromAbroad |
CH_StandardDeliveryFromAbroad |
CH_ExpressDeliveryFromAbroad |
CH_TrackedDeliveryFromAbroad |
CN_PersonalDelivery |
CN_RegularPackage |
CN_DeliveryCompanyExpress |
CN_PostOfficeExpress |
CN_Others |
CN_FastPostOffice |
CN_ExpressDeliverySameCity |
CN_ExpressDeliveryOtherCities |
CN_StandardInternational |
CN_ExpeditedInternational |
CN_OtherInternational |
CN_CODInternational |
CN_StandardMailingInternational |
CN_RegularLogisticsInternational |
CN_EMSInternational |
CN_OthersInternational |
DE_StandardDispatch |
DE_InsuredDispatch |
DE_Writing |
DE_COD |
DE_ExpressOrCourier |
DE_InsuredExpressOrCourier |
DE_SpecialDispatch |
DE_InsuredSpecialDispatch |
DE_UnversicherterVersand |
DE_DeutschePostBrief |
DE_eBayDHLPaket24x7 |
DE_DHLPostpaket |
DE_DHLPackchen |
DE_DeutschePostWarensendung |
DE_DeutschePostBuchersendung |
DE_HermesPaketUnversichert |
DE_HermesPaketVersichert |
DE_IloxxTransportXXL |
DE_IloxxUbernachtExpress |
DE_IloxxStandard |
DE_Sonstige |
DE_UnversicherterVersandInternational |
DE_VersicherterVersandInternational |
DE_DHLPostpaketInternational |
DE_DHLPackchenInternational |
DE_SonstigerVersandInternational |
DE_UnversicherterExpressVersandInternational |
DE_VersicherterExpressVersandInternational |
DE_DeutschePostBriefLandInternational |
DE_DeutschePostBriefLuftInternational |
DE_IloxxEuropaInternational |
DE_IloxxWorldWideInternational |
DE_Paket |
DE_Express |
DE_DHLPaket |
DE_DPBuecherWarensendung |
DE_HermesPaket |
DE_IloxxTransport |
DE_SonstigeDomestic |
DE_Einschreiben |
DE_Nachname |
DE_SpecialDelivery |
DE_UPS |
DE_DPD |
DE_GLS |
DE_PaketInternational |
DE_DHLPaketInternational |
DE_DHLPaketIntlExpress |
DE_SonstigeInternational |
DE_ExpressInternational |
DE_DPBriefInternational |
DE_IloxxTransportInternational |
DE_HermesPaketInternational |
DE_UPSInternational |
DE_DPDInternational |
DE_GLSInternational |
DE_eBayHermesPaketShop2ShopKaeufer |
DE_HermesPaketShop2ShopKaeufer |
DE_eBayHermesPaketShop2Shop |
DE_HermesPaketShop2Shop |
DE_HermesPaketSperrgut |
DE_eBayHermesPaketSperrgutShop2Shop |
DE_DHLPaeckchenPackstation |
DE_DHLPaketPackstation |
DE_eBayDHLPaeckchen |
DE_DHLStarPaeckchen |
DE_TrackedDeliveryFromAbroad |
ES_CartasNacionalesHasta20 |
ES_CartasNacionalesDeMas20 |
ES_CartasInternacionalesHasta20 |
ES_CartasInternacionalesDeMas20 |
ES_PaqueteAzulHasta2kg |
ES_PaqueteAzulDeMas2kg |
ES_PaqueteInternacionalEconomico |
ES_Urgente |
ES_Otros |
ES_StandardInternational |
ES_ExpeditedInternational |
ES_OtherInternational |
ES_CartasPostalInternational |
ES_EmsPostalExpressInternational |
ES_EconomyPacketInternational |
ES_EconomyDeliveryFromAbroad |
ES_StandardDeliveryFromAbroad |
ES_ExpressDeliveryFromAbroad |
ES_TrackedDeliveryFromAbroad |
ES_ENTREGA_KIALA_8KG |
FR_ChronoposteInternationalClassic |
FR_ColiposteColissimoDirect |
FR_DHLExpressEuropack |
FR_UPSStandard |
FR_PostOfficeLetter |
FR_PostOfficeLetterFollowed |
FR_PostOfficeLetterRecommended |
FR_ColiposteColissimo |
FR_ColiposteColissimoRecommended |
FR_UPSStandardAgainstRefund |
FR_Autre |
FR_Ecopli |
FR_Colieco |
FR_AuteModeDenvoiDeColis |
FR_RemiseEnMainPropre |
FR_StandardInternational |
FR_ExpeditedInternational |
FR_OtherInternational |
FR_LaPosteInternationalPriorityCourier |
FR_LaPosteInternationalEconomyCourier |
FR_LaPosteColissimoInternational |
FR_LaPosteColisEconomiqueInternational |
FR_LaPosteColissimoEmballageInternational |
FR_ChronopostClassicInternational |
FR_ChronopostPremiumInternational |
FR_UPSStandardInternational |
FR_UPSExpressInternational |
FR_DHLInternational |
FR_LaPosteLetterMax |
FR_KIALA_DELIVERY |
FR_TrackedDeliveryFromAbroad |
IN_Regular |
IN_Express |
IN_NationalCOD |
IN_Courier |
IN_LocalCOD |
IN_StandardInternational |
IN_ExpeditedInternational |
IN_OtherInternational |
IN_FlatRateCOD |
IN_BuyerPicksUpAndPays |
IT_RegularMail |
IT_PriorityMail |
IT_MailRegisteredLetter |
IT_MailRegisteredLetterWithMark |
IT_InsuredMail |
IT_QuickMail |
IT_RegularPackage |
IT_QuickPackage1 |
IT_QuickPackage3 |
IT_ExpressCourier |
IT_ExpressPackageMaxi |
IT_StandardInternational |
IT_ExpeditedInternational |
IT_OtherInternational |
IT_TrackedDeliveryFromAbroad |
NL_StandardDelivery |
NL_ParcelPost |
NL_RegisteredMail |
NL_Other |
NL_TPGPostTNTInternational |
NL_UPSInternational |
NL_FedExInternational |
NL_DHLInternational |
NL_DPDGBRInternational |
NL_GLSBusinessInternational |
NL_StandardInternational |
NL_ExpeditedInternational |
NL_OtherInternational |
NL_EconomyDeliveryFromAbroad |
NL_StandardDeliveryFromAbroad |
NL_ExpressDeliveryFromAbroad |
NL_TrackedDeliveryFromAbroad |
TW_RegisteredMail |
TW_UnregisteredMail |
TW_COD |
TW_DwellingMatchPost |
TW_DwellingMatchCOD |
TW_SelfPickup |
TW_ParcelPost |
TW_ExpressMail |
TW_Other |
TW_CPInternationalLetterPost |
TW_CPInternationalParcelPost |
TW_CPInternationalRegisteredLetterPost |
TW_CPInternationalRegisteredParcelPost |
TW_CPInternationalEMS |
TW_CPInternationalOceanShippingParcel |
TW_FedExInternationalPriority |
TW_FedExInternationalEconomy |
TW_UPSWorldwideExpedited |
TW_UPSWorldwideExpress |
TW_UPSWorldwideExpressPlus |
TW_OtherInternational |
UK_RoyalMailFirstClassStandard |
UK_RoyalMailSecondClassStandard |
UK_RoyalMailFirstClassRecorded |
UK_RoyalMailSecondClassRecorded |
UK_RoyalMailSpecialDelivery |
UK_RoyalMailStandardParcel |
UK_Parcelforce24 |
UK_Parcelforce48 |
UK_OtherCourier |
UK_myHermesDoorToDoorService |
UK_CollectDropAtStoreDeliveryToDoor |
UK_SellersStandardRate |
UK_CollectInPerson |
UK_SellersStandardInternationalRate |
UK_RoyalMailAirmailInternational |
UK_RoyalMailAirsureInternational |
UK_RoyalMailSurfaceMailInternational |
UK_RoyalMailInternationalSignedFor |
UK_RoyalMailHMForcesMailInternational |
UK_ParcelForceInternationalDatapost |
UK_ParcelForceIreland24International |
UK_ParcelForceEuro48International |
UK_ParcelForceInternationalScheduled |
UK_OtherCourierOrDeliveryInternational |
UK_CollectInPersonInternational |
UK_ParcelForceIntlExpress |
UK_ParcelForceIntlValue |
UK_ParcelForceIntlEconomy |
UK_TrackedDeliveryFromAbroad |
UK_IntlTrackedPostage |
IE_SellersStandardRate |
IE_FirstClassLetterService |
IE_SwiftPostNational |
IE_RegisteredPost |
IE_EMSSDSCourier |
IE_EconomySDSCourier |
IE_OtherCourier |
IE_CollectionInPerson |
IE_SellersStandardRateInternational |
IE_InternationalEconomyService |
IE_InternationalPriorityService |
IE_SwiftPostExpressInternational |
IE_SwiftPostInternational |
IE_EMSSDSCourierInternational |
IE_EconomySDSCourierInternational |
IE_OtherCourierInternational |
IE_CollectionInPersonInternational |
IE_EconomyDeliveryFromAbroad |
IE_StandardDeliveryFromAbroad |
IE_ExpressDeliveryFromAbroad |
IE_TrackedDeliveryFromAbroad |
PL_DomesticRegular |
PL_DomesticSpecial |
PL_EconomyDeliveryFromAbroad |
PL_StandardDeliveryFromAbroad |
PL_ExpressDeliveryFromAbroad |
PL_TrackedDeliveryFromAbroad |
FreightShipping |
FreightOtherShipping |
Freight |
FreightShippingInternational |
USPSGround |
ShippingMethodOvernight |
CustomCode |
USPSPriorityFlatRateEnvelope |
USPSPriorityFlatRateBox |
USPSGlobalPrioritySmallEnvelope |
USPSGlobalPriorityLargeEnvelope |
USPSExpressFlatRateEnvelope |
UPSWorldWideExpressBox10kg |
UPSWorldWideExpressBox25kg |
UPSWorldWideExpressPlusBox10kg |
UPSWorldWideExpressPlusBox25kg |
HK_LocalPickUpOnly |
HK_LocalCourier |
HK_DomesticRegularShipping |
HK_DomesticSpecialShipping |
HK_InternationalRegularShipping |
HK_InternationalSpecialShipping |
SG_LocalPickUpOnly |
SG_LocalCourier |
SG_DomesticStandardMail |
SG_DomesticNonStandardMail |
SG_DomesticSpeedpostIslandwide |
SG_InternationalStandardMail |
SG_InternationalExpressMailService |
SG_InternationalCourier |
BENL_DePostZendingNONPRIOR |
BENL_DePostZendingPRIOR |
BENL_DePostZendingAangetekend |
BENL_KilopostPakje |
BENL_Taxipost |
BENL_KialaAfhaalpunt |
BENL_VasteKostenStandaardVerzending |
BENL_VasteKostenVersneldeVerzending |
BENL_VerzekerdeVerzending |
BEFR_LaPosteEnvoiNONPRIOR |
BEFR_LaPosteEnvoiPRIOR |
BEFR_LaPosteEnvoiRecommande |
BEFR_PaquetKilopost |
BEFR_Taxipost |
BEFR_PointRetraitKiala |
BEFR_LivraisonStandardPrixforFaitaire |
BEFR_LivraisonExpressPrixforFaitaire |
BEFR_LivraisonSecurise |
BENL_DePostZendingPRIORInternational |
BENL_DePostZendingNONPRIORInternational |
BENL_DePostZendingAangetekendInternational |
BENL_KilopostPakjeInternational |
BENL_TaxipostExpressverzending |
BENL_VerzekerdeVerzendingInternational |
BEFR_LaPosteenvoiePRIOR |
BEFR_LaPosteenvoieNONPRIOR |
BEFR_LaPosteenvoieRecommande |
BEFR_PaquetKilopostInternationale |
BEFR_ExpressTaxipost |
BEFR_LivraisonStandardInternationalePrixforFaitaire |
BEFR_LivraisonExpressInternationalePrixforFaitaire |
BEFR_LivraisonSecuriseInternational |
FR_Chronopost |
UK_RoyalMailSpecialDeliveryNextDay |
CA_PostLightPacketInternational |
CA_PostLightPacketUSA |
PL_DHLInternational |
PL_InternationalRegular |
PL_InternationalSpecial |
PL_UPSInternational |
CAFR_StandardDelivery |
CAFR_ExpeditedDelivery |
CAFR_PostLettermail |
CAFR_PostRegularParcel |
CAFR_PostExpeditedParcel |
CAFR_PostXpresspost |
CAFR_PostPriorityCourier |
CAFR_StandardInternational |
CAFR_ExpeditedInternational |
CAFR_OtherInternational |
CAFR_PostExpeditedParcelUSA |
CAFR_PostSmallPacketsUSA |
CAFR_PostXpresspostUSA |
CAFR_PostXpresspostInternational |
CAFR_PostInternationalParcelSurface |
CAFR_PostInternationalParcelAir |
CAFR_SmallPacketsInternational |
CAFR_PurolatorInternational |
CAFR_PostSmallPacketsUSAGround |
CAFR_PostSmallPacketsUSAAir |
CAFR_SmallPacketsInternationalGround |
CAFR_SmallPacketsInternationalAir |
CAFR_PostUSALetterPost |
CAFR_PostInternationalLetterPost |
CAFR_UPSExpressCanada |
CAFR_UPSExpressSaverCanada |
CAFR_UPSExpeditedCanada |
CAFR_UPSStandardCanada |
CAFR_UPSExpressUnitedStates |
CAFR_UPSExpeditedUnitedStates |
CAFR_UPS3DaySelectUnitedStates |
CAFR_UPSStandardUnitedStates |
CAFR_UPSWorldWideExpress |
CAFR_UPSWorldWideExpedited |
UK_RoyalMailSpecialDelivery9am |
USPSFirstClassMailInternational |
USPSPriorityMailInternational |
USPSExpressMailInternational |
CH_StandardInternational |
CH_ExpeditedInternational |
CH_SonstigerVersandSieheArtikelbeschreibung |
TW_StandardInternationalFixedRate |
TW_ExpeditedInternationalFixedRate |
USPSGlobalExpressGuaranteed |
AU_RegularWithInsurance |
AU_ExpressWithInsurance |
DE_DeutschePostWarensendungInternational |
DE_DeutschePostByendung |
DE_HermesPaketUnversichertInternational |
DE_HermesPaketVersichertInternational |
DE_iLoxxTransportXXLInternational |
DE_iLoxxUbernachtExpressInternational |
DE_iLoxxStandardInternational |
DE_StandardInternational |
DE_ExpeditedInternational |
DE_DeutschePostBriefIntlEcon |
DE_DeutschePostBriefIntlPri |
AT_BitteTreffenSieEineAuswahl |
AT_EinschreibenVersandInklEinschreibengebuhr |
AT_NachnahmeVersandInklNachnahmegebuhr |
AT_ExpressOrCourierInternational |
AT_InsuredExpressOrCourierInternational |
AT_SpecialDispatchInternational |
AT_InsuredSpecialDispatchInternational |
AT_StandardInternational |
AT_ExpeditedInternational |
AT_OtherInternationalShipping |
CH_BitteTreffenSieEineAuswahl |
CH_UnversicherterVersand |
CH_VersicherterVersand |
CH_EinschreibenVersandInklEinschreibengebuhr |
CH_NachnahmeVersandInklNachnahmegebuhr |
CH_ExpressOrCourierInternational |
CH_InsuredExpressOrCourierInternational |
CH_SonderversandZBSperrgutKFZ |
CH_VersicherterSonderversandZBSperrgutKFZ |
CH_StandardversandAPostPriority |
CH_StandardversandBPostEconomy |
DE_BitteTreffenSieEineAuswahl |
DE_EinschreibenVersandInklEinschreibengebuhr |
DE_NachnahmeVersandInklNachnahmegebuhr |
DE_ExpressOrCourierInternational |
DE_InsuredExpressOrCourierInternational |
DE_SonderversandZBMobelKFZ |
DE_VersicherterSonderversandZBMobelKFZ |
DE_DeutschePostBriefInternational |
IE_StandardInternationalFlatRatePostage |
IE_ExpeditedInternationalFlatRatePostage |
IE_OtherInternationalPostage |
UK_StandardInternationalFlatRatePostage |
UK_ExpeditedInternationalFlatRatePostage |
UK_OtherInternationalPostage |
FR_ChronopostChronoRelais |
FR_Chrono10 |
FR_Chrono13 |
FR_Chrono18 |
FR_ChronopostExpressInternational |
Pickup |
Delivery |
CA_Pickup |
DE_Pickup |
AU_Pickup |
AU_SmallParcels |
AU_SmallParcelWithTracking |
AU_SmallParcelWithTrackingAndSignature |
AU_RegularParcelWithTracking |
AU_RegularParcelWithTrackingAndSignature |
AU_PrePaidExpressPostSatchel5kg |
AU_PrePaidParcelPostSatchels500g |
AU_PrePaidParcelPostSatchels3kg |
AU_PrePaidParcelPostSatchels5kg |
AU_PrePaidExpressPostSatchel500g |
AU_PrePaidExpressPostSatchel3kg |
AU_PrePaidExpressPostPlatinum500g |
AU_PrePaidExpressPostPlatinum3kg |
AU_ExpressCourierInternational |
AU_ExpressPostInternational |
AU_PrePaidExpressPostInternationalEnvelopeC5 |
AU_PrePaidExpressPostInternationalEnvelopeB4 |
AU_PrePaidExpressPostInternationalSatchels2kg |
AU_PrePaidExpressPostInternationalSatchels3kg |
AU_PrePaidExpressPostInternationalBox5kg |
AU_PrePaidExpressPostInternationalBox10kg |
AU_PrePaidExpressPostInternationalBox20kg |
AU_RegisteredParcelPost |
AU_RegisteredSmallParcel |
AU_RegisteredParcelPostPrepaidSatchel500g |
AU_RegisteredParcelPostPrepaidSatchel3kg |
AU_RegisteredParcelPostPrepaidSatchel5kg |
AU_ExpressPostSatchel500g |
AU_ExpressPostSatchel3kg |
FR_Pickup |
AT_Pickup |
BENL_Pickup |
BEFR_Pickup |
CH_Pickup |
IT_Pickup |
NL_Pickup |
PL_Pickup |
ES_Pickup |
SG_Delivery |
UK_OtherCourier24 |
UK_OtherCourier48 |
UK_OtherCourier3Days |
UK_OtherCourier5Days |
Courier |
FedExPriorityOvernight |
FedExStandardOvernight |
FedEx2Day |
FedExGround |
FedExHomeDelivery |
FedExExpressSaver |
FedExGroundDisabled |
FedExHomeDeliveryDisabled |
FedExInternationalFirst |
FedExInternationalPriority |
FedExInternationalEconomy |
FedExInternationalGround |
EconomyShippingFromOutsideUS |
ExpeditedShippingFromOutsideUS |
StandardShippingFromOutsideUS |
UK_EconomyShippingFromOutside |
UK_ExpeditedShippingFromOutside |
UK_StandardShippingFromOutside |
DE_SparversandAusDemAusland |
DE_StandardversandAusDemAusland |
DE_ExpressversandAusDemAusland |
DE_DHL2KGPaket |
InternationalPriorityShipping |
SameDayShipping |
UK_RoyalMailNextDay |
UK_RoyalMailTracked |
eBayNowImmediateDelivery |
Remarks


ShippingServiceCostOverrideListType Class

ShippingServiceCostOverrideListType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideListType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingServiceCostOverrideListType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingServiceCostOverrideListType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingServiceCostOverrideListType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingServiceCostOverrideListType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingServiceCostOverride |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShippingServiceCostOverrideListType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideListType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ShippingServiceCostOverride Property

ShippingServiceCostOverride Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideListType ► ShippingServiceCostOverride
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCostOverrideTypeCollection ShippingServiceCostOverride { get; set; }
Public Property ShippingServiceCostOverride As ShippingServiceCostOverrideTypeCollection
    Get
    Set
public:
property ShippingServiceCostOverrideTypeCollection^ ShippingServiceCostOverride {
    ShippingServiceCostOverrideTypeCollection^ get ();
    void set (ShippingServiceCostOverrideTypeCollection^ value);
}


ShippingServiceCostOverrideListType Constructor

ShippingServiceCostOverrideListType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideListType ► ShippingServiceCostOverrideListType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCostOverrideListType()
Public Sub New
public:
ShippingServiceCostOverrideListType()


ShippingServiceCostOverrideType Class

ShippingServiceCostOverrideType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingServiceCostOverrideType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingServiceCostOverrideType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingServiceCostOverrideType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingServiceCostOverrideType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingServiceAdditionalCost |
 | ShippingServiceCost |
 | ShippingServicePriority |
 | ShippingServicePrioritySpecified |
 | ShippingServiceType |
 | ShippingServiceTypeSpecified |
 | ShippingSurcharge |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShippingServiceCostOverrideType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ShippingServiceAdditionalCost Property

ShippingServiceAdditionalCost Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideType ► ShippingServiceAdditionalCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingServiceAdditionalCost { get; set; }
Public Property ShippingServiceAdditionalCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingServiceAdditionalCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingServiceCost Property

ShippingServiceCost Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideType ► ShippingServiceCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingServiceCost { get; set; }
Public Property ShippingServiceCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingServiceCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingServiceCostOverrideType Constructor

ShippingServiceCostOverrideType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideType ► ShippingServiceCostOverrideType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCostOverrideType()
Public Sub New
public:
ShippingServiceCostOverrideType()


ShippingServicePriority Property

ShippingServicePriority Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideType ► ShippingServicePriority
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingServicePriority { get; set; }
Public Property ShippingServicePriority As Integer
    Get
    Set
public:
property int ShippingServicePriority {
    int get ();
    void set (int value);
}


ShippingServicePrioritySpecified Property

ShippingServicePrioritySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideType ► ShippingServicePrioritySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingServicePrioritySpecified { get; set; }
Public Property ShippingServicePrioritySpecified As Boolean
    Get
    Set
public:
property bool ShippingServicePrioritySpecified {
    bool get ();
    void set (bool value);
}


ShippingServiceType Property

ShippingServiceType Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideType ► ShippingServiceType
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceType ShippingServiceType { get; set; }
Public Property ShippingServiceType As ShippingServiceType
    Get
    Set
public:
property ShippingServiceType ShippingServiceType {
    ShippingServiceType get ();
    void set (ShippingServiceType value);
}


ShippingServiceTypeSpecified Property

ShippingServiceTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideType ► ShippingServiceTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingServiceTypeSpecified { get; set; }
Public Property ShippingServiceTypeSpecified As Boolean
    Get
    Set
public:
property bool ShippingServiceTypeSpecified {
    bool get ();
    void set (bool value);
}


ShippingSurcharge Property

ShippingSurcharge Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideType ► ShippingSurcharge
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingSurcharge { get; set; }
Public Property ShippingSurcharge As AmountType
    Get
    Set
public:
property AmountType^ ShippingSurcharge {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingServiceCostOverrideTypeCollection Class

ShippingServiceCostOverrideTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingServiceCostOverrideTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingServiceCostOverrideTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingServiceCostOverrideTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingServiceCostOverrideTypeCollection()()()() |
 | ShippingServiceCostOverrideTypeCollection(array<ShippingServiceCostOverrideType>[]()[][]) |
 | ShippingServiceCostOverrideTypeCollection(ShippingServiceCostOverrideTypeCollection) |
 | Add(ShippingServiceCostOverrideType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingServiceCostOverrideType>[]()[][]) |
 | AddRange(ShippingServiceCostOverrideTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingServiceCostOverrideType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingServiceCostOverrideType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingServiceCostOverrideType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingServiceCostOverrideType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingServiceCostOverrideType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingServiceCostOverrideTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► Add(ShippingServiceCostOverrideType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingServiceCostOverrideType item
)
Public Function Add ( _
    item As ShippingServiceCostOverrideType _
) As Integer
public:
int Add(
    ShippingServiceCostOverrideType^ item
)
Parameters
item (ShippingServiceCostOverrideType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingServiceCostOverrideType>[]()[][]) |
 | AddRange(ShippingServiceCostOverrideTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► AddRange(array<ShippingServiceCostOverrideType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingServiceCostOverrideType[] items
)
Public Sub AddRange ( _
    items As ShippingServiceCostOverrideType() _
)
public:
void AddRange(
    array<ShippingServiceCostOverrideType^>^ items
)
Parameters
items (array< ShippingServiceCostOverrideType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► AddRange(ShippingServiceCostOverrideTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingServiceCostOverrideTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingServiceCostOverrideTypeCollection _
)
public:
void AddRange(
    ShippingServiceCostOverrideTypeCollection^ items
)
Parameters
items (ShippingServiceCostOverrideTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► Contains(ShippingServiceCostOverrideType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingServiceCostOverrideType item
)
Public Function Contains ( _
    item As ShippingServiceCostOverrideType _
) As Boolean
public:
bool Contains(
    ShippingServiceCostOverrideType^ item
)
Parameters
item (ShippingServiceCostOverrideType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► CopyTo(array<ShippingServiceCostOverrideType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingServiceCostOverrideType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingServiceCostOverrideType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingServiceCostOverrideType^>^ items,
    int index
)
Parameters
items (array< ShippingServiceCostOverrideType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► IndexOf(ShippingServiceCostOverrideType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingServiceCostOverrideType item
)
Public Function IndexOf ( _
    item As ShippingServiceCostOverrideType _
) As Integer
public:
int IndexOf(
    ShippingServiceCostOverrideType^ item
)
Parameters
item (ShippingServiceCostOverrideType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► Insert(Int32, ShippingServiceCostOverrideType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingServiceCostOverrideType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingServiceCostOverrideType _
)
public:
void Insert(
    int index,
    ShippingServiceCostOverrideType^ item
)
Parameters
index (Int32)
item (ShippingServiceCostOverrideType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCostOverrideType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingServiceCostOverrideType
    Get
    Set
public:
property ShippingServiceCostOverrideType^ default[int index] {
    ShippingServiceCostOverrideType^ get (int index);
    void set (int index, ShippingServiceCostOverrideType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCostOverrideType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingServiceCostOverrideType
public:
ShippingServiceCostOverrideType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► Remove(ShippingServiceCostOverrideType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingServiceCostOverrideType item
)
Public Sub Remove ( _
    item As ShippingServiceCostOverrideType _
)
public:
void Remove(
    ShippingServiceCostOverrideType^ item
)
Parameters
item (ShippingServiceCostOverrideType)


ShippingServiceCostOverrideTypeCollection Constructor

ShippingServiceCostOverrideTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► ShippingServiceCostOverrideTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingServiceCostOverrideTypeCollection()()()() |
 | ShippingServiceCostOverrideTypeCollection(array<ShippingServiceCostOverrideType>[]()[][]) |
 | ShippingServiceCostOverrideTypeCollection(ShippingServiceCostOverrideTypeCollection) |


ShippingServiceCostOverrideTypeCollection Constructor

ShippingServiceCostOverrideTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► ShippingServiceCostOverrideTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCostOverrideTypeCollection()
Public Sub New
public:
ShippingServiceCostOverrideTypeCollection()


ShippingServiceCostOverrideTypeCollection Constructor (items)

ShippingServiceCostOverrideTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► ShippingServiceCostOverrideTypeCollection(array<ShippingServiceCostOverrideType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCostOverrideTypeCollection(
    ShippingServiceCostOverrideType[] items
)
Public Sub New ( _
    items As ShippingServiceCostOverrideType() _
)
public:
ShippingServiceCostOverrideTypeCollection(
    array<ShippingServiceCostOverrideType^>^ items
)
Parameters
items (array< ShippingServiceCostOverrideType >[]()[][])


ShippingServiceCostOverrideTypeCollection Constructor (items)

ShippingServiceCostOverrideTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► ShippingServiceCostOverrideTypeCollection(ShippingServiceCostOverrideTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCostOverrideTypeCollection(
    ShippingServiceCostOverrideTypeCollection items
)
Public Sub New ( _
    items As ShippingServiceCostOverrideTypeCollection _
)
public:
ShippingServiceCostOverrideTypeCollection(
    ShippingServiceCostOverrideTypeCollection^ items
)
Parameters
items (ShippingServiceCostOverrideTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCostOverrideType[] ToArray()
Public Function ToArray As ShippingServiceCostOverrideType()
public:
array<ShippingServiceCostOverrideType^>^ ToArray()
Return Value


ShippingServiceDetailsType Class

ShippingServiceDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingServiceDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingServiceDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingServiceDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingServiceDetailsType()()()() |
 | Any |
 | CODService |
 | CODServiceSpecified |
 | CostGroupFlat |
 | DeprecationDetails |
 | Description |
 | DetailVersion |
 | DimensionsRequired |
 | DimensionsRequiredSpecified |
 | Equals(Object) | (Inherited from Object.)
 | ExpeditedService |
 | ExpeditedServiceSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InternationalService |
 | InternationalServiceSpecified |
 | MappedToShippingServiceID |
 | MappedToShippingServiceIDSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ServiceType |
 | ShippingCarrier |
 | ShippingCategory |
 | ShippingPackage |
 | ShippingService |
 | ShippingServiceCode |
 | ShippingServiceCodeSpecified |
 | ShippingServiceID |
 | ShippingServiceIDSpecified |
 | ShippingServicePackageDetails |
 | ShippingTimeMax |
 | ShippingTimeMaxSpecified |
 | ShippingTimeMin |
 | ShippingTimeMinSpecified |
 | SurchargeApplicable |
 | SurchargeApplicableSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
 | ValidForSellingFlow |
 | ValidForSellingFlowSpecified |
 | WeightRequired |
 | WeightRequiredSpecified |
Remarks
Inheritance Hierarchy
Object
ShippingServiceDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CODService Property

CODService Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► CODService
Declaration Syntax
C# Visual Basic Visual C++
public bool CODService { get; set; }
Public Property CODService As Boolean
    Get
    Set
public:
property bool CODService {
    bool get ();
    void set (bool value);
}


CODServiceSpecified Property

CODServiceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► CODServiceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CODServiceSpecified { get; set; }
Public Property CODServiceSpecified As Boolean
    Get
    Set
public:
property bool CODServiceSpecified {
    bool get ();
    void set (bool value);
}


CostGroupFlat Property

CostGroupFlat Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► CostGroupFlat
Declaration Syntax
C# Visual Basic Visual C++
public string CostGroupFlat { get; set; }
Public Property CostGroupFlat As String
    Get
    Set
public:
property String^ CostGroupFlat {
    String^ get ();
    void set (String^ value);
}


DeprecationDetails Property

DeprecationDetails Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► DeprecationDetails
Declaration Syntax
C# Visual Basic Visual C++
public AnnouncementMessageTypeCollection DeprecationDetails { get; set; }
Public Property DeprecationDetails As AnnouncementMessageTypeCollection
    Get
    Set
public:
property AnnouncementMessageTypeCollection^ DeprecationDetails {
    AnnouncementMessageTypeCollection^ get ();
    void set (AnnouncementMessageTypeCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


DimensionsRequired Property

DimensionsRequired Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► DimensionsRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool DimensionsRequired { get; set; }
Public Property DimensionsRequired As Boolean
    Get
    Set
public:
property bool DimensionsRequired {
    bool get ();
    void set (bool value);
}


DimensionsRequiredSpecified Property

DimensionsRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► DimensionsRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DimensionsRequiredSpecified { get; set; }
Public Property DimensionsRequiredSpecified As Boolean
    Get
    Set
public:
property bool DimensionsRequiredSpecified {
    bool get ();
    void set (bool value);
}


ExpeditedService Property

ExpeditedService Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ExpeditedService
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpeditedService { get; set; }
Public Property ExpeditedService As Boolean
    Get
    Set
public:
property bool ExpeditedService {
    bool get ();
    void set (bool value);
}


ExpeditedServiceSpecified Property

ExpeditedServiceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ExpeditedServiceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpeditedServiceSpecified { get; set; }
Public Property ExpeditedServiceSpecified As Boolean
    Get
    Set
public:
property bool ExpeditedServiceSpecified {
    bool get ();
    void set (bool value);
}


InternationalService Property

InternationalService Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► InternationalService
Declaration Syntax
C# Visual Basic Visual C++
public bool InternationalService { get; set; }
Public Property InternationalService As Boolean
    Get
    Set
public:
property bool InternationalService {
    bool get ();
    void set (bool value);
}


InternationalServiceSpecified Property

InternationalServiceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► InternationalServiceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InternationalServiceSpecified { get; set; }
Public Property InternationalServiceSpecified As Boolean
    Get
    Set
public:
property bool InternationalServiceSpecified {
    bool get ();
    void set (bool value);
}


MappedToShippingServiceID Property

MappedToShippingServiceID Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► MappedToShippingServiceID
Declaration Syntax
C# Visual Basic Visual C++
public int MappedToShippingServiceID { get; set; }
Public Property MappedToShippingServiceID As Integer
    Get
    Set
public:
property int MappedToShippingServiceID {
    int get ();
    void set (int value);
}


MappedToShippingServiceIDSpecified Property

MappedToShippingServiceIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► MappedToShippingServiceIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MappedToShippingServiceIDSpecified { get; set; }
Public Property MappedToShippingServiceIDSpecified As Boolean
    Get
    Set
public:
property bool MappedToShippingServiceIDSpecified {
    bool get ();
    void set (bool value);
}


ServiceType Property

ServiceType Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ServiceType
Declaration Syntax
C# Visual Basic Visual C++
public ShippingTypeCodeTypeCollection ServiceType { get; set; }
Public Property ServiceType As ShippingTypeCodeTypeCollection
    Get
    Set
public:
property ShippingTypeCodeTypeCollection^ ServiceType {
    ShippingTypeCodeTypeCollection^ get ();
    void set (ShippingTypeCodeTypeCollection^ value);
}


ShippingCarrier Property

ShippingCarrier Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingCarrier
Declaration Syntax
C# Visual Basic Visual C++
public ShippingCarrierCodeTypeCollection ShippingCarrier { get; set; }
Public Property ShippingCarrier As ShippingCarrierCodeTypeCollection
    Get
    Set
public:
property ShippingCarrierCodeTypeCollection^ ShippingCarrier {
    ShippingCarrierCodeTypeCollection^ get ();
    void set (ShippingCarrierCodeTypeCollection^ value);
}


ShippingCategory Property

ShippingCategory Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingCategory
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingCategory { get; set; }
Public Property ShippingCategory As String
    Get
    Set
public:
property String^ ShippingCategory {
    String^ get ();
    void set (String^ value);
}


ShippingPackage Property

ShippingPackage Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingPackage
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeTypeCollection ShippingPackage { get; set; }
Public Property ShippingPackage As ShippingPackageCodeTypeCollection
    Get
    Set
public:
property ShippingPackageCodeTypeCollection^ ShippingPackage {
    ShippingPackageCodeTypeCollection^ get ();
    void set (ShippingPackageCodeTypeCollection^ value);
}


ShippingService Property

ShippingService Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingService
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingService { get; set; }
Public Property ShippingService As String
    Get
    Set
public:
property String^ ShippingService {
    String^ get ();
    void set (String^ value);
}


ShippingServiceCode Property

ShippingServiceCode Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingServiceCode
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceCodeType ShippingServiceCode { get; set; }
Public Property ShippingServiceCode As ShippingServiceCodeType
    Get
    Set
public:
property ShippingServiceCodeType ShippingServiceCode {
    ShippingServiceCodeType get ();
    void set (ShippingServiceCodeType value);
}


ShippingServiceCodeSpecified Property

ShippingServiceCodeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingServiceCodeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingServiceCodeSpecified { get; set; }
Public Property ShippingServiceCodeSpecified As Boolean
    Get
    Set
public:
property bool ShippingServiceCodeSpecified {
    bool get ();
    void set (bool value);
}


ShippingServiceDetailsType Constructor

ShippingServiceDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingServiceDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceDetailsType()
Public Sub New
public:
ShippingServiceDetailsType()


ShippingServiceID Property

ShippingServiceID Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingServiceID
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingServiceID { get; set; }
Public Property ShippingServiceID As Integer
    Get
    Set
public:
property int ShippingServiceID {
    int get ();
    void set (int value);
}


ShippingServiceIDSpecified Property

ShippingServiceIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingServiceIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingServiceIDSpecified { get; set; }
Public Property ShippingServiceIDSpecified As Boolean
    Get
    Set
public:
property bool ShippingServiceIDSpecified {
    bool get ();
    void set (bool value);
}


ShippingServicePackageDetails Property

ShippingServicePackageDetails Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingServicePackageDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServicePackageDetailsTypeCollection ShippingServicePackageDetails { get; set; }
Public Property ShippingServicePackageDetails As ShippingServicePackageDetailsTypeCollection
    Get
    Set
public:
property ShippingServicePackageDetailsTypeCollection^ ShippingServicePackageDetails {
    ShippingServicePackageDetailsTypeCollection^ get ();
    void set (ShippingServicePackageDetailsTypeCollection^ value);
}


ShippingTimeMax Property

ShippingTimeMax Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingTimeMax
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingTimeMax { get; set; }
Public Property ShippingTimeMax As Integer
    Get
    Set
public:
property int ShippingTimeMax {
    int get ();
    void set (int value);
}


ShippingTimeMaxSpecified Property

ShippingTimeMaxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingTimeMaxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTimeMaxSpecified { get; set; }
Public Property ShippingTimeMaxSpecified As Boolean
    Get
    Set
public:
property bool ShippingTimeMaxSpecified {
    bool get ();
    void set (bool value);
}


ShippingTimeMin Property

ShippingTimeMin Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingTimeMin
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingTimeMin { get; set; }
Public Property ShippingTimeMin As Integer
    Get
    Set
public:
property int ShippingTimeMin {
    int get ();
    void set (int value);
}


ShippingTimeMinSpecified Property

ShippingTimeMinSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ShippingTimeMinSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTimeMinSpecified { get; set; }
Public Property ShippingTimeMinSpecified As Boolean
    Get
    Set
public:
property bool ShippingTimeMinSpecified {
    bool get ();
    void set (bool value);
}


SurchargeApplicable Property

SurchargeApplicable Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► SurchargeApplicable
Declaration Syntax
C# Visual Basic Visual C++
public bool SurchargeApplicable { get; set; }
Public Property SurchargeApplicable As Boolean
    Get
    Set
public:
property bool SurchargeApplicable {
    bool get ();
    void set (bool value);
}


SurchargeApplicableSpecified Property

SurchargeApplicableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► SurchargeApplicableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SurchargeApplicableSpecified { get; set; }
Public Property SurchargeApplicableSpecified As Boolean
    Get
    Set
public:
property bool SurchargeApplicableSpecified {
    bool get ();
    void set (bool value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


ValidForSellingFlow Property

ValidForSellingFlow Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ValidForSellingFlow
Declaration Syntax
C# Visual Basic Visual C++
public bool ValidForSellingFlow { get; set; }
Public Property ValidForSellingFlow As Boolean
    Get
    Set
public:
property bool ValidForSellingFlow {
    bool get ();
    void set (bool value);
}


ValidForSellingFlowSpecified Property

ValidForSellingFlowSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► ValidForSellingFlowSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ValidForSellingFlowSpecified { get; set; }
Public Property ValidForSellingFlowSpecified As Boolean
    Get
    Set
public:
property bool ValidForSellingFlowSpecified {
    bool get ();
    void set (bool value);
}


WeightRequired Property

WeightRequired Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► WeightRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool WeightRequired { get; set; }
Public Property WeightRequired As Boolean
    Get
    Set
public:
property bool WeightRequired {
    bool get ();
    void set (bool value);
}


WeightRequiredSpecified Property

WeightRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsType ► WeightRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WeightRequiredSpecified { get; set; }
Public Property WeightRequiredSpecified As Boolean
    Get
    Set
public:
property bool WeightRequiredSpecified {
    bool get ();
    void set (bool value);
}


ShippingServiceDetailsTypeCollection Class

ShippingServiceDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingServiceDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingServiceDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingServiceDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingServiceDetailsTypeCollection()()()() |
 | ShippingServiceDetailsTypeCollection(array<ShippingServiceDetailsType>[]()[][]) |
 | ShippingServiceDetailsTypeCollection(ShippingServiceDetailsTypeCollection) |
 | Add(ShippingServiceDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingServiceDetailsType>[]()[][]) |
 | AddRange(ShippingServiceDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingServiceDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingServiceDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingServiceDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingServiceDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingServiceDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingServiceDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► Add(ShippingServiceDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingServiceDetailsType item
)
Public Function Add ( _
    item As ShippingServiceDetailsType _
) As Integer
public:
int Add(
    ShippingServiceDetailsType^ item
)
Parameters
item (ShippingServiceDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingServiceDetailsType>[]()[][]) |
 | AddRange(ShippingServiceDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► AddRange(array<ShippingServiceDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingServiceDetailsType[] items
)
Public Sub AddRange ( _
    items As ShippingServiceDetailsType() _
)
public:
void AddRange(
    array<ShippingServiceDetailsType^>^ items
)
Parameters
items (array< ShippingServiceDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► AddRange(ShippingServiceDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingServiceDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingServiceDetailsTypeCollection _
)
public:
void AddRange(
    ShippingServiceDetailsTypeCollection^ items
)
Parameters
items (ShippingServiceDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► Contains(ShippingServiceDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingServiceDetailsType item
)
Public Function Contains ( _
    item As ShippingServiceDetailsType _
) As Boolean
public:
bool Contains(
    ShippingServiceDetailsType^ item
)
Parameters
item (ShippingServiceDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► CopyTo(array<ShippingServiceDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingServiceDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingServiceDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingServiceDetailsType^>^ items,
    int index
)
Parameters
items (array< ShippingServiceDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► IndexOf(ShippingServiceDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingServiceDetailsType item
)
Public Function IndexOf ( _
    item As ShippingServiceDetailsType _
) As Integer
public:
int IndexOf(
    ShippingServiceDetailsType^ item
)
Parameters
item (ShippingServiceDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► Insert(Int32, ShippingServiceDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingServiceDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingServiceDetailsType _
)
public:
void Insert(
    int index,
    ShippingServiceDetailsType^ item
)
Parameters
index (Int32)
item (ShippingServiceDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingServiceDetailsType
    Get
    Set
public:
property ShippingServiceDetailsType^ default[int index] {
    ShippingServiceDetailsType^ get (int index);
    void set (int index, ShippingServiceDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingServiceDetailsType
public:
ShippingServiceDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► Remove(ShippingServiceDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingServiceDetailsType item
)
Public Sub Remove ( _
    item As ShippingServiceDetailsType _
)
public:
void Remove(
    ShippingServiceDetailsType^ item
)
Parameters
item (ShippingServiceDetailsType)


ShippingServiceDetailsTypeCollection Constructor

ShippingServiceDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► ShippingServiceDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingServiceDetailsTypeCollection()()()() |
 | ShippingServiceDetailsTypeCollection(array<ShippingServiceDetailsType>[]()[][]) |
 | ShippingServiceDetailsTypeCollection(ShippingServiceDetailsTypeCollection) |


ShippingServiceDetailsTypeCollection Constructor

ShippingServiceDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► ShippingServiceDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceDetailsTypeCollection()
Public Sub New
public:
ShippingServiceDetailsTypeCollection()


ShippingServiceDetailsTypeCollection Constructor (items)

ShippingServiceDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► ShippingServiceDetailsTypeCollection(array<ShippingServiceDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceDetailsTypeCollection(
    ShippingServiceDetailsType[] items
)
Public Sub New ( _
    items As ShippingServiceDetailsType() _
)
public:
ShippingServiceDetailsTypeCollection(
    array<ShippingServiceDetailsType^>^ items
)
Parameters
items (array< ShippingServiceDetailsType >[]()[][])


ShippingServiceDetailsTypeCollection Constructor (items)

ShippingServiceDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► ShippingServiceDetailsTypeCollection(ShippingServiceDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceDetailsTypeCollection(
    ShippingServiceDetailsTypeCollection items
)
Public Sub New ( _
    items As ShippingServiceDetailsTypeCollection _
)
public:
ShippingServiceDetailsTypeCollection(
    ShippingServiceDetailsTypeCollection^ items
)
Parameters
items (ShippingServiceDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceDetailsType[] ToArray()
Public Function ToArray As ShippingServiceDetailsType()
public:
array<ShippingServiceDetailsType^>^ ToArray()
Return Value


ShippingServiceOptionsType Class

ShippingServiceOptionsType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingServiceOptionsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingServiceOptionsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingServiceOptionsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingServiceOptionsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | ExpeditedService |
 | ExpeditedServiceSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | FreeShipping |
 | FreeShippingSpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ImportCharge |
 | LocalPickup |
 | LocalPickupSpecified |
 | LogisticPlanType |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ShippingInsuranceCost |
 | ShippingPackageInfo |
 | ShippingService |
 | ShippingServiceAdditionalCost |
 | ShippingServiceCost |
 | ShippingServiceCutOffTime |
 | ShippingServiceCutOffTimeSpecified |
 | ShippingServicePriority |
 | ShippingServicePrioritySpecified |
 | ShippingSurcharge |
 | ShippingTimeMax |
 | ShippingTimeMaxSpecified |
 | ShippingTimeMin |
 | ShippingTimeMinSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShippingServiceOptionsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExpeditedService Property

ExpeditedService Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ExpeditedService
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpeditedService { get; set; }
Public Property ExpeditedService As Boolean
    Get
    Set
public:
property bool ExpeditedService {
    bool get ();
    void set (bool value);
}


ExpeditedServiceSpecified Property

ExpeditedServiceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ExpeditedServiceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpeditedServiceSpecified { get; set; }
Public Property ExpeditedServiceSpecified As Boolean
    Get
    Set
public:
property bool ExpeditedServiceSpecified {
    bool get ();
    void set (bool value);
}


FreeShipping Property

FreeShipping Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► FreeShipping
Declaration Syntax
C# Visual Basic Visual C++
public bool FreeShipping { get; set; }
Public Property FreeShipping As Boolean
    Get
    Set
public:
property bool FreeShipping {
    bool get ();
    void set (bool value);
}


FreeShippingSpecified Property

FreeShippingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► FreeShippingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FreeShippingSpecified { get; set; }
Public Property FreeShippingSpecified As Boolean
    Get
    Set
public:
property bool FreeShippingSpecified {
    bool get ();
    void set (bool value);
}


ImportCharge Property

ImportCharge Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ImportCharge
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ImportCharge { get; set; }
Public Property ImportCharge As AmountType
    Get
    Set
public:
property AmountType^ ImportCharge {
    AmountType^ get ();
    void set (AmountType^ value);
}


LocalPickup Property

LocalPickup Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► LocalPickup
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalPickup { get; set; }
Public Property LocalPickup As Boolean
    Get
    Set
public:
property bool LocalPickup {
    bool get ();
    void set (bool value);
}


LocalPickupSpecified Property

LocalPickupSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► LocalPickupSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalPickupSpecified { get; set; }
Public Property LocalPickupSpecified As Boolean
    Get
    Set
public:
property bool LocalPickupSpecified {
    bool get ();
    void set (bool value);
}


LogisticPlanType Property

LogisticPlanType Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► LogisticPlanType
Declaration Syntax
C# Visual Basic Visual C++
public string LogisticPlanType { get; set; }
Public Property LogisticPlanType As String
    Get
    Set
public:
property String^ LogisticPlanType {
    String^ get ();
    void set (String^ value);
}


ShippingInsuranceCost Property

ShippingInsuranceCost Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingInsuranceCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingInsuranceCost { get; set; }
Public Property ShippingInsuranceCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingInsuranceCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingPackageInfo Property

ShippingPackageInfo Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingPackageInfo
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageInfoTypeCollection ShippingPackageInfo { get; set; }
Public Property ShippingPackageInfo As ShippingPackageInfoTypeCollection
    Get
    Set
public:
property ShippingPackageInfoTypeCollection^ ShippingPackageInfo {
    ShippingPackageInfoTypeCollection^ get ();
    void set (ShippingPackageInfoTypeCollection^ value);
}


ShippingService Property

ShippingService Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingService
Declaration Syntax
C# Visual Basic Visual C++
public string ShippingService { get; set; }
Public Property ShippingService As String
    Get
    Set
public:
property String^ ShippingService {
    String^ get ();
    void set (String^ value);
}


ShippingServiceAdditionalCost Property

ShippingServiceAdditionalCost Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingServiceAdditionalCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingServiceAdditionalCost { get; set; }
Public Property ShippingServiceAdditionalCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingServiceAdditionalCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingServiceCost Property

ShippingServiceCost Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingServiceCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingServiceCost { get; set; }
Public Property ShippingServiceCost As AmountType
    Get
    Set
public:
property AmountType^ ShippingServiceCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingServiceCutOffTime Property

ShippingServiceCutOffTime Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingServiceCutOffTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ShippingServiceCutOffTime { get; set; }
Public Property ShippingServiceCutOffTime As DateTime
    Get
    Set
public:
property DateTime ShippingServiceCutOffTime {
    DateTime get ();
    void set (DateTime value);
}


ShippingServiceCutOffTimeSpecified Property

ShippingServiceCutOffTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingServiceCutOffTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingServiceCutOffTimeSpecified { get; set; }
Public Property ShippingServiceCutOffTimeSpecified As Boolean
    Get
    Set
public:
property bool ShippingServiceCutOffTimeSpecified {
    bool get ();
    void set (bool value);
}


ShippingServiceOptionsType Constructor

ShippingServiceOptionsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingServiceOptionsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsType()
Public Sub New
public:
ShippingServiceOptionsType()


ShippingServicePriority Property

ShippingServicePriority Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingServicePriority
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingServicePriority { get; set; }
Public Property ShippingServicePriority As Integer
    Get
    Set
public:
property int ShippingServicePriority {
    int get ();
    void set (int value);
}


ShippingServicePrioritySpecified Property

ShippingServicePrioritySpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingServicePrioritySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingServicePrioritySpecified { get; set; }
Public Property ShippingServicePrioritySpecified As Boolean
    Get
    Set
public:
property bool ShippingServicePrioritySpecified {
    bool get ();
    void set (bool value);
}


ShippingSurcharge Property

ShippingSurcharge Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingSurcharge
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingSurcharge { get; set; }
Public Property ShippingSurcharge As AmountType
    Get
    Set
public:
property AmountType^ ShippingSurcharge {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingTimeMax Property

ShippingTimeMax Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingTimeMax
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingTimeMax { get; set; }
Public Property ShippingTimeMax As Integer
    Get
    Set
public:
property int ShippingTimeMax {
    int get ();
    void set (int value);
}


ShippingTimeMaxSpecified Property

ShippingTimeMaxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingTimeMaxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTimeMaxSpecified { get; set; }
Public Property ShippingTimeMaxSpecified As Boolean
    Get
    Set
public:
property bool ShippingTimeMaxSpecified {
    bool get ();
    void set (bool value);
}


ShippingTimeMin Property

ShippingTimeMin Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingTimeMin
Declaration Syntax
C# Visual Basic Visual C++
public int ShippingTimeMin { get; set; }
Public Property ShippingTimeMin As Integer
    Get
    Set
public:
property int ShippingTimeMin {
    int get ();
    void set (int value);
}


ShippingTimeMinSpecified Property

ShippingTimeMinSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsType ► ShippingTimeMinSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTimeMinSpecified { get; set; }
Public Property ShippingTimeMinSpecified As Boolean
    Get
    Set
public:
property bool ShippingTimeMinSpecified {
    bool get ();
    void set (bool value);
}


ShippingServiceOptionsTypeCollection Class

ShippingServiceOptionsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingServiceOptionsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingServiceOptionsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingServiceOptionsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingServiceOptionsTypeCollection()()()() |
 | ShippingServiceOptionsTypeCollection(array<ShippingServiceOptionsType>[]()[][]) |
 | ShippingServiceOptionsTypeCollection(ShippingServiceOptionsTypeCollection) |
 | Add(ShippingServiceOptionsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingServiceOptionsType>[]()[][]) |
 | AddRange(ShippingServiceOptionsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingServiceOptionsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingServiceOptionsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingServiceOptionsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingServiceOptionsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingServiceOptionsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingServiceOptionsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► Add(ShippingServiceOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingServiceOptionsType item
)
Public Function Add ( _
    item As ShippingServiceOptionsType _
) As Integer
public:
int Add(
    ShippingServiceOptionsType^ item
)
Parameters
item (ShippingServiceOptionsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingServiceOptionsType>[]()[][]) |
 | AddRange(ShippingServiceOptionsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► AddRange(array<ShippingServiceOptionsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingServiceOptionsType[] items
)
Public Sub AddRange ( _
    items As ShippingServiceOptionsType() _
)
public:
void AddRange(
    array<ShippingServiceOptionsType^>^ items
)
Parameters
items (array< ShippingServiceOptionsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► AddRange(ShippingServiceOptionsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingServiceOptionsTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingServiceOptionsTypeCollection _
)
public:
void AddRange(
    ShippingServiceOptionsTypeCollection^ items
)
Parameters
items (ShippingServiceOptionsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► Contains(ShippingServiceOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingServiceOptionsType item
)
Public Function Contains ( _
    item As ShippingServiceOptionsType _
) As Boolean
public:
bool Contains(
    ShippingServiceOptionsType^ item
)
Parameters
item (ShippingServiceOptionsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► CopyTo(array<ShippingServiceOptionsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingServiceOptionsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingServiceOptionsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingServiceOptionsType^>^ items,
    int index
)
Parameters
items (array< ShippingServiceOptionsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► IndexOf(ShippingServiceOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingServiceOptionsType item
)
Public Function IndexOf ( _
    item As ShippingServiceOptionsType _
) As Integer
public:
int IndexOf(
    ShippingServiceOptionsType^ item
)
Parameters
item (ShippingServiceOptionsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► Insert(Int32, ShippingServiceOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingServiceOptionsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingServiceOptionsType _
)
public:
void Insert(
    int index,
    ShippingServiceOptionsType^ item
)
Parameters
index (Int32)
item (ShippingServiceOptionsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingServiceOptionsType
    Get
    Set
public:
property ShippingServiceOptionsType^ default[int index] {
    ShippingServiceOptionsType^ get (int index);
    void set (int index, ShippingServiceOptionsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingServiceOptionsType
public:
ShippingServiceOptionsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► Remove(ShippingServiceOptionsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingServiceOptionsType item
)
Public Sub Remove ( _
    item As ShippingServiceOptionsType _
)
public:
void Remove(
    ShippingServiceOptionsType^ item
)
Parameters
item (ShippingServiceOptionsType)


ShippingServiceOptionsTypeCollection Constructor

ShippingServiceOptionsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► ShippingServiceOptionsTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingServiceOptionsTypeCollection()()()() |
 | ShippingServiceOptionsTypeCollection(array<ShippingServiceOptionsType>[]()[][]) |
 | ShippingServiceOptionsTypeCollection(ShippingServiceOptionsTypeCollection) |


ShippingServiceOptionsTypeCollection Constructor

ShippingServiceOptionsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► ShippingServiceOptionsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsTypeCollection()
Public Sub New
public:
ShippingServiceOptionsTypeCollection()


ShippingServiceOptionsTypeCollection Constructor (items)

ShippingServiceOptionsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► ShippingServiceOptionsTypeCollection(array<ShippingServiceOptionsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsTypeCollection(
    ShippingServiceOptionsType[] items
)
Public Sub New ( _
    items As ShippingServiceOptionsType() _
)
public:
ShippingServiceOptionsTypeCollection(
    array<ShippingServiceOptionsType^>^ items
)
Parameters
items (array< ShippingServiceOptionsType >[]()[][])


ShippingServiceOptionsTypeCollection Constructor (items)

ShippingServiceOptionsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► ShippingServiceOptionsTypeCollection(ShippingServiceOptionsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsTypeCollection(
    ShippingServiceOptionsTypeCollection items
)
Public Sub New ( _
    items As ShippingServiceOptionsTypeCollection _
)
public:
ShippingServiceOptionsTypeCollection(
    ShippingServiceOptionsTypeCollection^ items
)
Parameters
items (ShippingServiceOptionsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsType[] ToArray()
Public Function ToArray As ShippingServiceOptionsType()
public:
array<ShippingServiceOptionsType^>^ ToArray()
Return Value


ShippingServicePackageDetailsType Class

ShippingServicePackageDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingServicePackageDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingServicePackageDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingServicePackageDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingServicePackageDetailsType()()()() |
 | Any |
 | DimensionsRequired |
 | DimensionsRequiredSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | NameSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShippingServicePackageDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DimensionsRequired Property

DimensionsRequired Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsType ► DimensionsRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool DimensionsRequired { get; set; }
Public Property DimensionsRequired As Boolean
    Get
    Set
public:
property bool DimensionsRequired {
    bool get ();
    void set (bool value);
}


DimensionsRequiredSpecified Property

DimensionsRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsType ► DimensionsRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DimensionsRequiredSpecified { get; set; }
Public Property DimensionsRequiredSpecified As Boolean
    Get
    Set
public:
property bool DimensionsRequiredSpecified {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public ShippingPackageCodeType Name { get; set; }
Public Property Name As ShippingPackageCodeType
    Get
    Set
public:
property ShippingPackageCodeType Name {
    ShippingPackageCodeType get ();
    void set (ShippingPackageCodeType value);
}


NameSpecified Property

NameSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsType ► NameSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NameSpecified { get; set; }
Public Property NameSpecified As Boolean
    Get
    Set
public:
property bool NameSpecified {
    bool get ();
    void set (bool value);
}


ShippingServicePackageDetailsType Constructor

ShippingServicePackageDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsType ► ShippingServicePackageDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServicePackageDetailsType()
Public Sub New
public:
ShippingServicePackageDetailsType()


ShippingServicePackageDetailsTypeCollection Class

ShippingServicePackageDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingServicePackageDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingServicePackageDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingServicePackageDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingServicePackageDetailsTypeCollection()()()() |
 | ShippingServicePackageDetailsTypeCollection(array<ShippingServicePackageDetailsType>[]()[][]) |
 | ShippingServicePackageDetailsTypeCollection(ShippingServicePackageDetailsTypeCollection) |
 | Add(ShippingServicePackageDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingServicePackageDetailsType>[]()[][]) |
 | AddRange(ShippingServicePackageDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingServicePackageDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingServicePackageDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingServicePackageDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingServicePackageDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingServicePackageDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingServicePackageDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► Add(ShippingServicePackageDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingServicePackageDetailsType item
)
Public Function Add ( _
    item As ShippingServicePackageDetailsType _
) As Integer
public:
int Add(
    ShippingServicePackageDetailsType^ item
)
Parameters
item (ShippingServicePackageDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingServicePackageDetailsType>[]()[][]) |
 | AddRange(ShippingServicePackageDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► AddRange(array<ShippingServicePackageDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingServicePackageDetailsType[] items
)
Public Sub AddRange ( _
    items As ShippingServicePackageDetailsType() _
)
public:
void AddRange(
    array<ShippingServicePackageDetailsType^>^ items
)
Parameters
items (array< ShippingServicePackageDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► AddRange(ShippingServicePackageDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingServicePackageDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingServicePackageDetailsTypeCollection _
)
public:
void AddRange(
    ShippingServicePackageDetailsTypeCollection^ items
)
Parameters
items (ShippingServicePackageDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► Contains(ShippingServicePackageDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingServicePackageDetailsType item
)
Public Function Contains ( _
    item As ShippingServicePackageDetailsType _
) As Boolean
public:
bool Contains(
    ShippingServicePackageDetailsType^ item
)
Parameters
item (ShippingServicePackageDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► CopyTo(array<ShippingServicePackageDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingServicePackageDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingServicePackageDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingServicePackageDetailsType^>^ items,
    int index
)
Parameters
items (array< ShippingServicePackageDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► IndexOf(ShippingServicePackageDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingServicePackageDetailsType item
)
Public Function IndexOf ( _
    item As ShippingServicePackageDetailsType _
) As Integer
public:
int IndexOf(
    ShippingServicePackageDetailsType^ item
)
Parameters
item (ShippingServicePackageDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► Insert(Int32, ShippingServicePackageDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingServicePackageDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingServicePackageDetailsType _
)
public:
void Insert(
    int index,
    ShippingServicePackageDetailsType^ item
)
Parameters
index (Int32)
item (ShippingServicePackageDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServicePackageDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingServicePackageDetailsType
    Get
    Set
public:
property ShippingServicePackageDetailsType^ default[int index] {
    ShippingServicePackageDetailsType^ get (int index);
    void set (int index, ShippingServicePackageDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServicePackageDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingServicePackageDetailsType
public:
ShippingServicePackageDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► Remove(ShippingServicePackageDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingServicePackageDetailsType item
)
Public Sub Remove ( _
    item As ShippingServicePackageDetailsType _
)
public:
void Remove(
    ShippingServicePackageDetailsType^ item
)
Parameters
item (ShippingServicePackageDetailsType)


ShippingServicePackageDetailsTypeCollection Constructor

ShippingServicePackageDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► ShippingServicePackageDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingServicePackageDetailsTypeCollection()()()() |
 | ShippingServicePackageDetailsTypeCollection(array<ShippingServicePackageDetailsType>[]()[][]) |
 | ShippingServicePackageDetailsTypeCollection(ShippingServicePackageDetailsTypeCollection) |


ShippingServicePackageDetailsTypeCollection Constructor

ShippingServicePackageDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► ShippingServicePackageDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServicePackageDetailsTypeCollection()
Public Sub New
public:
ShippingServicePackageDetailsTypeCollection()


ShippingServicePackageDetailsTypeCollection Constructor (items)

ShippingServicePackageDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► ShippingServicePackageDetailsTypeCollection(array<ShippingServicePackageDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServicePackageDetailsTypeCollection(
    ShippingServicePackageDetailsType[] items
)
Public Sub New ( _
    items As ShippingServicePackageDetailsType() _
)
public:
ShippingServicePackageDetailsTypeCollection(
    array<ShippingServicePackageDetailsType^>^ items
)
Parameters
items (array< ShippingServicePackageDetailsType >[]()[][])


ShippingServicePackageDetailsTypeCollection Constructor (items)

ShippingServicePackageDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► ShippingServicePackageDetailsTypeCollection(ShippingServicePackageDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServicePackageDetailsTypeCollection(
    ShippingServicePackageDetailsTypeCollection items
)
Public Sub New ( _
    items As ShippingServicePackageDetailsTypeCollection _
)
public:
ShippingServicePackageDetailsTypeCollection(
    ShippingServicePackageDetailsTypeCollection^ items
)
Parameters
items (ShippingServicePackageDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServicePackageDetailsType[] ToArray()
Public Function ToArray As ShippingServicePackageDetailsType()
public:
array<ShippingServicePackageDetailsType^>^ ToArray()
Return Value


ShippingServiceType Enumeration

ShippingServiceType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ShippingServiceType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ShippingServiceType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ShippingServiceType
Members
Member | Description
Domestic |
International |
Remarks


ShippingTermRequiredDefinitionType Class

ShippingTermRequiredDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ShippingTermRequiredDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ShippingTermRequiredDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ShippingTermRequiredDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ShippingTermRequiredDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingTermRequiredDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ShippingTermRequiredDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ShippingTermRequiredDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ShippingTermRequiredDefinitionType Constructor

ShippingTermRequiredDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingTermRequiredDefinitionType ► ShippingTermRequiredDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingTermRequiredDefinitionType()
Public Sub New
public:
ShippingTermRequiredDefinitionType()


ShippingTypeCodeType Enumeration

ShippingTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ShippingTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ShippingTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ShippingTypeCodeType
Members
Member | Description
Flat |
Calculated |
Freight |
Free |
NotSpecified |
FlatDomesticCalculatedInternational |
CalculatedDomesticFlatInternational |
FreightFlat |
CustomCode |
Remarks


ShippingTypeCodeTypeCollection Class

ShippingTypeCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ShippingTypeCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ShippingTypeCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ShippingTypeCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingTypeCodeTypeCollection()()()() |
 | ShippingTypeCodeTypeCollection(array<ShippingTypeCodeType>[]()[][]) |
 | ShippingTypeCodeTypeCollection(ShippingTypeCodeTypeCollection) |
 | Add(ShippingTypeCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ShippingTypeCodeType>[]()[][]) |
 | AddRange(ShippingTypeCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ShippingTypeCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ShippingTypeCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ShippingTypeCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ShippingTypeCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ShippingTypeCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ShippingTypeCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► Add(ShippingTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ShippingTypeCodeType item
)
Public Function Add ( _
    item As ShippingTypeCodeType _
) As Integer
public:
int Add(
    ShippingTypeCodeType item
)
Parameters
item (ShippingTypeCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ShippingTypeCodeType>[]()[][]) |
 | AddRange(ShippingTypeCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► AddRange(array<ShippingTypeCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingTypeCodeType[] items
)
Public Sub AddRange ( _
    items As ShippingTypeCodeType() _
)
public:
void AddRange(
    array<ShippingTypeCodeType>^ items
)
Parameters
items (array< ShippingTypeCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► AddRange(ShippingTypeCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ShippingTypeCodeTypeCollection items
)
Public Sub AddRange ( _
    items As ShippingTypeCodeTypeCollection _
)
public:
void AddRange(
    ShippingTypeCodeTypeCollection^ items
)
Parameters
items (ShippingTypeCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► Contains(ShippingTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ShippingTypeCodeType item
)
Public Function Contains ( _
    item As ShippingTypeCodeType _
) As Boolean
public:
bool Contains(
    ShippingTypeCodeType item
)
Parameters
item (ShippingTypeCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► CopyTo(array<ShippingTypeCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ShippingTypeCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ShippingTypeCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ShippingTypeCodeType>^ items,
    int index
)
Parameters
items (array< ShippingTypeCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► IndexOf(ShippingTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ShippingTypeCodeType item
)
Public Function IndexOf ( _
    item As ShippingTypeCodeType _
) As Integer
public:
int IndexOf(
    ShippingTypeCodeType item
)
Parameters
item (ShippingTypeCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► Insert(Int32, ShippingTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ShippingTypeCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ShippingTypeCodeType _
)
public:
void Insert(
    int index,
    ShippingTypeCodeType item
)
Parameters
index (Int32)
item (ShippingTypeCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingTypeCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ShippingTypeCodeType
    Get
    Set
public:
property ShippingTypeCodeType default[int index] {
    ShippingTypeCodeType get (int index);
    void set (int index, ShippingTypeCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingTypeCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ShippingTypeCodeType
public:
ShippingTypeCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► Remove(ShippingTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ShippingTypeCodeType item
)
Public Sub Remove ( _
    item As ShippingTypeCodeType _
)
public:
void Remove(
    ShippingTypeCodeType item
)
Parameters
item (ShippingTypeCodeType)


ShippingTypeCodeTypeCollection Constructor

ShippingTypeCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► ShippingTypeCodeTypeCollection()()()()
Members
Icon | Member | Description
 | ShippingTypeCodeTypeCollection()()()() |
 | ShippingTypeCodeTypeCollection(array<ShippingTypeCodeType>[]()[][]) |
 | ShippingTypeCodeTypeCollection(ShippingTypeCodeTypeCollection) |


ShippingTypeCodeTypeCollection Constructor

ShippingTypeCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► ShippingTypeCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingTypeCodeTypeCollection()
Public Sub New
public:
ShippingTypeCodeTypeCollection()


ShippingTypeCodeTypeCollection Constructor (items)

ShippingTypeCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► ShippingTypeCodeTypeCollection(array<ShippingTypeCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ShippingTypeCodeTypeCollection(
    ShippingTypeCodeType[] items
)
Public Sub New ( _
    items As ShippingTypeCodeType() _
)
public:
ShippingTypeCodeTypeCollection(
    array<ShippingTypeCodeType>^ items
)
Parameters
items (array< ShippingTypeCodeType >[]()[][])


ShippingTypeCodeTypeCollection Constructor (items)

ShippingTypeCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► ShippingTypeCodeTypeCollection(ShippingTypeCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingTypeCodeTypeCollection(
    ShippingTypeCodeTypeCollection items
)
Public Sub New ( _
    items As ShippingTypeCodeTypeCollection _
)
public:
ShippingTypeCodeTypeCollection(
    ShippingTypeCodeTypeCollection^ items
)
Parameters
items (ShippingTypeCodeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingTypeCodeType[] ToArray()
Public Function ToArray As ShippingTypeCodeType()
public:
array<ShippingTypeCodeType>^ ToArray()
Return Value


SimpleItemSortCodeType Enumeration

SimpleItemSortCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SimpleItemSortCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SimpleItemSortCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SimpleItemSortCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SimpleItemSortCodeType
Members
Member | Description
BestMatch |
CustomCode |
EndTime |
BidCount |
Country |
CurrentBid |
Distance |
StartDate |
BestMatchCategoryGroup |
PricePlusShipping |
Remarks


SiteBuyerRequirementDetailsType Class

SiteBuyerRequirementDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SiteBuyerRequirementDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SiteBuyerRequirementDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SiteBuyerRequirementDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteBuyerRequirementDetailsType()()()() |
 | Any |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LinkedPayPalAccount |
 | LinkedPayPalAccountSpecified |
 | MaximumBuyerPolicyViolations |
 | MaximumItemRequirements |
 | MaximumUnpaidItemStrikesInfo |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumFeedbackScore |
 | ShipToRegistrationCountry |
 | ShipToRegistrationCountrySpecified |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
 | VerifiedUserRequirements |
Remarks
Inheritance Hierarchy
Object
SiteBuyerRequirementDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


LinkedPayPalAccount Property

LinkedPayPalAccount Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► LinkedPayPalAccount
Declaration Syntax
C# Visual Basic Visual C++
public bool LinkedPayPalAccount { get; set; }
Public Property LinkedPayPalAccount As Boolean
    Get
    Set
public:
property bool LinkedPayPalAccount {
    bool get ();
    void set (bool value);
}


LinkedPayPalAccountSpecified Property

LinkedPayPalAccountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► LinkedPayPalAccountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LinkedPayPalAccountSpecified { get; set; }
Public Property LinkedPayPalAccountSpecified As Boolean
    Get
    Set
public:
property bool LinkedPayPalAccountSpecified {
    bool get ();
    void set (bool value);
}


MaximumBuyerPolicyViolations Property

MaximumBuyerPolicyViolations Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► MaximumBuyerPolicyViolations
Declaration Syntax
C# Visual Basic Visual C++
public MaximumBuyerPolicyViolationsDetailsType MaximumBuyerPolicyViolations { get; set; }
Public Property MaximumBuyerPolicyViolations As MaximumBuyerPolicyViolationsDetailsType
    Get
    Set
public:
property MaximumBuyerPolicyViolationsDetailsType^ MaximumBuyerPolicyViolations {
    MaximumBuyerPolicyViolationsDetailsType^ get ();
    void set (MaximumBuyerPolicyViolationsDetailsType^ value);
}


MaximumItemRequirements Property

MaximumItemRequirements Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► MaximumItemRequirements
Declaration Syntax
C# Visual Basic Visual C++
public MaximumItemRequirementsDetailsType MaximumItemRequirements { get; set; }
Public Property MaximumItemRequirements As MaximumItemRequirementsDetailsType
    Get
    Set
public:
property MaximumItemRequirementsDetailsType^ MaximumItemRequirements {
    MaximumItemRequirementsDetailsType^ get ();
    void set (MaximumItemRequirementsDetailsType^ value);
}


MaximumUnpaidItemStrikesInfo Property

MaximumUnpaidItemStrikesInfo Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► MaximumUnpaidItemStrikesInfo
Declaration Syntax
C# Visual Basic Visual C++
public MaximumUnpaidItemStrikesInfoDetailsType MaximumUnpaidItemStrikesInfo { get; set; }
Public Property MaximumUnpaidItemStrikesInfo As MaximumUnpaidItemStrikesInfoDetailsType
    Get
    Set
public:
property MaximumUnpaidItemStrikesInfoDetailsType^ MaximumUnpaidItemStrikesInfo {
    MaximumUnpaidItemStrikesInfoDetailsType^ get ();
    void set (MaximumUnpaidItemStrikesInfoDetailsType^ value);
}


MinimumFeedbackScore Property

MinimumFeedbackScore Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► MinimumFeedbackScore
Declaration Syntax
C# Visual Basic Visual C++
public MinimumFeedbackScoreDetailsType MinimumFeedbackScore { get; set; }
Public Property MinimumFeedbackScore As MinimumFeedbackScoreDetailsType
    Get
    Set
public:
property MinimumFeedbackScoreDetailsType^ MinimumFeedbackScore {
    MinimumFeedbackScoreDetailsType^ get ();
    void set (MinimumFeedbackScoreDetailsType^ value);
}


ShipToRegistrationCountry Property

ShipToRegistrationCountry Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► ShipToRegistrationCountry
Declaration Syntax
C# Visual Basic Visual C++
public bool ShipToRegistrationCountry { get; set; }
Public Property ShipToRegistrationCountry As Boolean
    Get
    Set
public:
property bool ShipToRegistrationCountry {
    bool get ();
    void set (bool value);
}


ShipToRegistrationCountrySpecified Property

ShipToRegistrationCountrySpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► ShipToRegistrationCountrySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShipToRegistrationCountrySpecified { get; set; }
Public Property ShipToRegistrationCountrySpecified As Boolean
    Get
    Set
public:
property bool ShipToRegistrationCountrySpecified {
    bool get ();
    void set (bool value);
}


SiteBuyerRequirementDetailsType Constructor

SiteBuyerRequirementDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► SiteBuyerRequirementDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteBuyerRequirementDetailsType()
Public Sub New
public:
SiteBuyerRequirementDetailsType()


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


VerifiedUserRequirements Property

VerifiedUserRequirements Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsType ► VerifiedUserRequirements
Declaration Syntax
C# Visual Basic Visual C++
public VerifiedUserRequirementsDetailsType VerifiedUserRequirements { get; set; }
Public Property VerifiedUserRequirements As VerifiedUserRequirementsDetailsType
    Get
    Set
public:
property VerifiedUserRequirementsDetailsType^ VerifiedUserRequirements {
    VerifiedUserRequirementsDetailsType^ get ();
    void set (VerifiedUserRequirementsDetailsType^ value);
}


SiteBuyerRequirementDetailsTypeCollection Class

SiteBuyerRequirementDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SiteBuyerRequirementDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SiteBuyerRequirementDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SiteBuyerRequirementDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteBuyerRequirementDetailsTypeCollection()()()() |
 | SiteBuyerRequirementDetailsTypeCollection(array<SiteBuyerRequirementDetailsType>[]()[][]) |
 | SiteBuyerRequirementDetailsTypeCollection(SiteBuyerRequirementDetailsTypeCollection) |
 | Add(SiteBuyerRequirementDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SiteBuyerRequirementDetailsType>[]()[][]) |
 | AddRange(SiteBuyerRequirementDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SiteBuyerRequirementDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SiteBuyerRequirementDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SiteBuyerRequirementDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SiteBuyerRequirementDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SiteBuyerRequirementDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SiteBuyerRequirementDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► Add(SiteBuyerRequirementDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SiteBuyerRequirementDetailsType item
)
Public Function Add ( _
    item As SiteBuyerRequirementDetailsType _
) As Integer
public:
int Add(
    SiteBuyerRequirementDetailsType^ item
)
Parameters
item (SiteBuyerRequirementDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SiteBuyerRequirementDetailsType>[]()[][]) |
 | AddRange(SiteBuyerRequirementDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► AddRange(array<SiteBuyerRequirementDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SiteBuyerRequirementDetailsType[] items
)
Public Sub AddRange ( _
    items As SiteBuyerRequirementDetailsType() _
)
public:
void AddRange(
    array<SiteBuyerRequirementDetailsType^>^ items
)
Parameters
items (array< SiteBuyerRequirementDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► AddRange(SiteBuyerRequirementDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SiteBuyerRequirementDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As SiteBuyerRequirementDetailsTypeCollection _
)
public:
void AddRange(
    SiteBuyerRequirementDetailsTypeCollection^ items
)
Parameters
items (SiteBuyerRequirementDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► Contains(SiteBuyerRequirementDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SiteBuyerRequirementDetailsType item
)
Public Function Contains ( _
    item As SiteBuyerRequirementDetailsType _
) As Boolean
public:
bool Contains(
    SiteBuyerRequirementDetailsType^ item
)
Parameters
item (SiteBuyerRequirementDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► CopyTo(array<SiteBuyerRequirementDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SiteBuyerRequirementDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SiteBuyerRequirementDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SiteBuyerRequirementDetailsType^>^ items,
    int index
)
Parameters
items (array< SiteBuyerRequirementDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► IndexOf(SiteBuyerRequirementDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SiteBuyerRequirementDetailsType item
)
Public Function IndexOf ( _
    item As SiteBuyerRequirementDetailsType _
) As Integer
public:
int IndexOf(
    SiteBuyerRequirementDetailsType^ item
)
Parameters
item (SiteBuyerRequirementDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► Insert(Int32, SiteBuyerRequirementDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SiteBuyerRequirementDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SiteBuyerRequirementDetailsType _
)
public:
void Insert(
    int index,
    SiteBuyerRequirementDetailsType^ item
)
Parameters
index (Int32)
item (SiteBuyerRequirementDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SiteBuyerRequirementDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SiteBuyerRequirementDetailsType
    Get
    Set
public:
property SiteBuyerRequirementDetailsType^ default[int index] {
    SiteBuyerRequirementDetailsType^ get (int index);
    void set (int index, SiteBuyerRequirementDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SiteBuyerRequirementDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SiteBuyerRequirementDetailsType
public:
SiteBuyerRequirementDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► Remove(SiteBuyerRequirementDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SiteBuyerRequirementDetailsType item
)
Public Sub Remove ( _
    item As SiteBuyerRequirementDetailsType _
)
public:
void Remove(
    SiteBuyerRequirementDetailsType^ item
)
Parameters
item (SiteBuyerRequirementDetailsType)


SiteBuyerRequirementDetailsTypeCollection Constructor

SiteBuyerRequirementDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► SiteBuyerRequirementDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | SiteBuyerRequirementDetailsTypeCollection()()()() |
 | SiteBuyerRequirementDetailsTypeCollection(array<SiteBuyerRequirementDetailsType>[]()[][]) |
 | SiteBuyerRequirementDetailsTypeCollection(SiteBuyerRequirementDetailsTypeCollection) |


SiteBuyerRequirementDetailsTypeCollection Constructor

SiteBuyerRequirementDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► SiteBuyerRequirementDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteBuyerRequirementDetailsTypeCollection()
Public Sub New
public:
SiteBuyerRequirementDetailsTypeCollection()


SiteBuyerRequirementDetailsTypeCollection Constructor (items)

SiteBuyerRequirementDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► SiteBuyerRequirementDetailsTypeCollection(array<SiteBuyerRequirementDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SiteBuyerRequirementDetailsTypeCollection(
    SiteBuyerRequirementDetailsType[] items
)
Public Sub New ( _
    items As SiteBuyerRequirementDetailsType() _
)
public:
SiteBuyerRequirementDetailsTypeCollection(
    array<SiteBuyerRequirementDetailsType^>^ items
)
Parameters
items (array< SiteBuyerRequirementDetailsType >[]()[][])


SiteBuyerRequirementDetailsTypeCollection Constructor (items)

SiteBuyerRequirementDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► SiteBuyerRequirementDetailsTypeCollection(SiteBuyerRequirementDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SiteBuyerRequirementDetailsTypeCollection(
    SiteBuyerRequirementDetailsTypeCollection items
)
Public Sub New ( _
    items As SiteBuyerRequirementDetailsTypeCollection _
)
public:
SiteBuyerRequirementDetailsTypeCollection(
    SiteBuyerRequirementDetailsTypeCollection^ items
)
Parameters
items (SiteBuyerRequirementDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteBuyerRequirementDetailsType[] ToArray()
Public Function ToArray As SiteBuyerRequirementDetailsType()
public:
array<SiteBuyerRequirementDetailsType^>^ ToArray()
Return Value


SiteCodeType Enumeration

SiteCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SiteCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SiteCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SiteCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SiteCodeType
Members
Member | Description
US |
Canada |
UK |
Australia |
Austria |
Belgium_French |
France |
Germany |
Italy |
Belgium_Dutch |
Netherlands |
Spain |
Switzerland |
Taiwan |
eBayMotors |
HongKong |
Singapore |
India |
China |
Ireland |
Malaysia |
Philippines |
Poland |
Sweden |
CustomCode |
CanadaFrench |
Russia |
Remarks


SiteCodeTypeCollection Class

SiteCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SiteCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SiteCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SiteCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteCodeTypeCollection()()()() |
 | SiteCodeTypeCollection(array<SiteCodeType>[]()[][]) |
 | SiteCodeTypeCollection(SiteCodeTypeCollection) |
 | Add(SiteCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SiteCodeType>[]()[][]) |
 | AddRange(SiteCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SiteCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SiteCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SiteCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SiteCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SiteCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SiteCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► Add(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SiteCodeType item
)
Public Function Add ( _
    item As SiteCodeType _
) As Integer
public:
int Add(
    SiteCodeType item
)
Parameters
item (SiteCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SiteCodeType>[]()[][]) |
 | AddRange(SiteCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► AddRange(array<SiteCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SiteCodeType[] items
)
Public Sub AddRange ( _
    items As SiteCodeType() _
)
public:
void AddRange(
    array<SiteCodeType>^ items
)
Parameters
items (array< SiteCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► AddRange(SiteCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SiteCodeTypeCollection items
)
Public Sub AddRange ( _
    items As SiteCodeTypeCollection _
)
public:
void AddRange(
    SiteCodeTypeCollection^ items
)
Parameters
items (SiteCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► Contains(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SiteCodeType item
)
Public Function Contains ( _
    item As SiteCodeType _
) As Boolean
public:
bool Contains(
    SiteCodeType item
)
Parameters
item (SiteCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► CopyTo(array<SiteCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SiteCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SiteCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SiteCodeType>^ items,
    int index
)
Parameters
items (array< SiteCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► IndexOf(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SiteCodeType item
)
Public Function IndexOf ( _
    item As SiteCodeType _
) As Integer
public:
int IndexOf(
    SiteCodeType item
)
Parameters
item (SiteCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► Insert(Int32, SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SiteCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SiteCodeType _
)
public:
void Insert(
    int index,
    SiteCodeType item
)
Parameters
index (Int32)
item (SiteCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SiteCodeType
    Get
    Set
public:
property SiteCodeType default[int index] {
    SiteCodeType get (int index);
    void set (int index, SiteCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SiteCodeType
public:
SiteCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► Remove(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SiteCodeType item
)
Public Sub Remove ( _
    item As SiteCodeType _
)
public:
void Remove(
    SiteCodeType item
)
Parameters
item (SiteCodeType)


SiteCodeTypeCollection Constructor

SiteCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► SiteCodeTypeCollection()()()()
Members
Icon | Member | Description
 | SiteCodeTypeCollection()()()() |
 | SiteCodeTypeCollection(array<SiteCodeType>[]()[][]) |
 | SiteCodeTypeCollection(SiteCodeTypeCollection) |


SiteCodeTypeCollection Constructor

SiteCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► SiteCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeTypeCollection()
Public Sub New
public:
SiteCodeTypeCollection()


SiteCodeTypeCollection Constructor (items)

SiteCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► SiteCodeTypeCollection(array<SiteCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeTypeCollection(
    SiteCodeType[] items
)
Public Sub New ( _
    items As SiteCodeType() _
)
public:
SiteCodeTypeCollection(
    array<SiteCodeType>^ items
)
Parameters
items (array< SiteCodeType >[]()[][])


SiteCodeTypeCollection Constructor (items)

SiteCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► SiteCodeTypeCollection(SiteCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeTypeCollection(
    SiteCodeTypeCollection items
)
Public Sub New ( _
    items As SiteCodeTypeCollection _
)
public:
SiteCodeTypeCollection(
    SiteCodeTypeCollection^ items
)
Parameters
items (SiteCodeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType[] ToArray()
Public Function ToArray As SiteCodeType()
public:
array<SiteCodeType>^ ToArray()
Return Value


SiteDefaultsType Class

SiteDefaultsType Class
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SiteDefaultsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SiteDefaultsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SiteDefaultsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteDefaultsType()()()() |
 | AdditionalCompatibilityEnabled |
 | AdditionalCompatibilityEnabledSpecified |
 | AdFormatEnabled |
 | AdFormatEnabledSpecified |
 | Any |
 | AttributeConversionEnabled |
 | AttributeConversionEnabledSpecified |
 | BasicUpgradePackEnabled |
 | BasicUpgradePackEnabledSpecified |
 | BestOfferAutoAcceptEnabled |
 | BestOfferAutoAcceptEnabledSpecified |
 | BestOfferAutoDeclineEnabled |
 | BestOfferAutoDeclineEnabledSpecified |
 | BestOfferCounterEnabled |
 | BestOfferCounterEnabledSpecified |
 | BestOfferEnabled |
 | BestOfferEnabledSpecified |
 | BrandMPNIdentifierEnabled |
 | BrandMPNIdentifierEnabledSpecified |
 | BuyerGuaranteeEnabled |
 | BuyerGuaranteeEnabledSpecified |
 | ClassifiedAdAutoAcceptEnabled |
 | ClassifiedAdAutoAcceptEnabledSpecified |
 | ClassifiedAdAutoDeclineEnabled |
 | ClassifiedAdAutoDeclineEnabledSpecified |
 | ClassifiedAdBestOfferEnabled |
 | ClassifiedAdBestOfferEnabledSpecified |
 | ClassifiedAdCompanyNameEnabled |
 | ClassifiedAdCompanyNameEnabledSpecified |
 | ClassifiedAdContactByAddressEnabled |
 | ClassifiedAdContactByAddressEnabledSpecified |
 | ClassifiedAdContactByEmailEnabled |
 | ClassifiedAdContactByEmailEnabledSpecified |
 | ClassifiedAdContactByPhoneEnabled |
 | ClassifiedAdContactByPhoneEnabledSpecified |
 | ClassifiedAdCounterOfferEnabled |
 | ClassifiedAdCounterOfferEnabledSpecified |
 | ClassifiedAdPaymentMethodEnabled |
 | ClassifiedAdPaymentMethodEnabledSpecified |
 | ClassifiedAdPayPerLeadEnabled |
 | ClassifiedAdPayPerLeadEnabledSpecified |
 | ClassifiedAdPhoneCount |
 | ClassifiedAdPhoneCountSpecified |
 | ClassifiedAdShippingMethodEnabled |
 | ClassifiedAdShippingMethodEnabledSpecified |
 | ClassifiedAdStreetCount |
 | ClassifiedAdStreetCountSpecified |
 | CombinedFixedPriceTreatmentEnabled |
 | CombinedFixedPriceTreatmentEnabledSpecified |
 | CompatibleVehicleType |
 | ConditionEnabled |
 | ConditionEnabledSpecified |
 | ConditionValues |
 | CrossBorderTradeAustraliaEnabled |
 | CrossBorderTradeAustraliaEnabledSpecified |
 | CrossBorderTradeGBEnabled |
 | CrossBorderTradeGBEnabledSpecified |
 | CrossBorderTradeNorthAmericaEnabled |
 | CrossBorderTradeNorthAmericaEnabledSpecified |
 | DepositSupported |
 | DepositSupportedSpecified |
 | DigitalGoodDeliveryEnabled |
 | DigitalGoodDeliveryEnabledSpecified |
 | DutchBINEnabled |
 | DutchBINEnabledSpecified |
 | EANEnabled |
 | EANEnabledSpecified |
 | EANIdentifierEnabled |
 | EANIdentifierEnabledSpecified |
 | eBayMotorsProAdFormatEnabled |
 | eBayMotorsProAdFormatEnabledSpecified |
 | eBayMotorsProAutoAcceptEnabled |
 | eBayMotorsProAutoAcceptEnabledSpecified |
 | eBayMotorsProAutoDeclineEnabled |
 | eBayMotorsProAutoDeclineEnabledSpecified |
 | eBayMotorsProBestOfferEnabled |
 | eBayMotorsProBestOfferEnabledSpecified |
 | eBayMotorsProCompanyNameEnabled |
 | eBayMotorsProCompanyNameEnabledSpecified |
 | eBayMotorsProContactByAddressEnabled |
 | eBayMotorsProContactByAddressEnabledSpecified |
 | eBayMotorsProContactByEmailEnabled |
 | eBayMotorsProContactByEmailEnabledSpecified |
 | eBayMotorsProContactByPhoneEnabled |
 | eBayMotorsProContactByPhoneEnabledSpecified |
 | eBayMotorsProCounterOfferEnabled |
 | eBayMotorsProCounterOfferEnabledSpecified |
 | eBayMotorsProPaymentMethodCheckOutEnabled |
 | eBayMotorsProPaymentMethodCheckOutEnabledSpecified |
 | eBayMotorsProPhoneCount |
 | eBayMotorsProPhoneCountSpecified |
 | eBayMotorsProSellerContactDetailsEnabled |
 | eBayMotorsProSellerContactDetailsEnabledSpecified |
 | eBayMotorsProShippingMethodEnabled |
 | eBayMotorsProShippingMethodEnabledSpecified |
 | eBayMotorsProStreetCount |
 | eBayMotorsProStreetCountSpecified |
 | EpidSupported |
 | EpidSupportedSpecified |
 | Equals(Object) | (Inherited from Object.)
 | ExpressConditionRequired |
 | ExpressConditionRequiredSpecified |
 | ExpressEnabled |
 | ExpressEnabledSpecified |
 | ExpressPicturesRequired |
 | ExpressPicturesRequiredSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | FreeGalleryPlusEnabled |
 | FreeGalleryPlusEnabledSpecified |
 | FreePicturePackEnabled |
 | FreePicturePackEnabledSpecified |
 | GalleryFeaturedDurations |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GlobalShippingEnabled |
 | GlobalShippingEnabledSpecified |
 | Group1MaxFlatShippingCost |
 | Group2MaxFlatShippingCost |
 | Group3MaxFlatShippingCost |
 | HandlingTimeEnabled |
 | HandlingTimeEnabledSpecified |
 | HomePageFeaturedEnabled |
 | HomePageFeaturedEnabledSpecified |
 | INEscrowWorkflowTimeline |
 | INEscrowWorkflowTimelineSpecified |
 | ISBNEnabled |
 | ISBNEnabledSpecified |
 | ISBNIdentifierEnabled |
 | ISBNIdentifierEnabledSpecified |
 | ItemCompatibilityEnabled |
 | ItemCompatibilityEnabledSpecified |
 | ItemSpecificsEnabled |
 | ItemSpecificsEnabledSpecified |
 | KTypeSupported |
 | KTypeSupportedSpecified |
 | ListingDuration |
 | LocalListingDistancesNonSubscription |
 | LocalListingDistancesRegular |
 | LocalListingDistancesSpecialty |
 | LocalMarketAdFormatEnabled |
 | LocalMarketAdFormatEnabledSpecified |
 | LocalMarketAutoAcceptEnabled |
 | LocalMarketAutoAcceptEnabledSpecified |
 | LocalMarketAutoDeclineEnabled |
 | LocalMarketAutoDeclineEnabledSpecified |
 | LocalMarketBestOfferEnabled |
 | LocalMarketBestOfferEnabledSpecified |
 | LocalMarketCompanyNameEnabled |
 | LocalMarketCompanyNameEnabledSpecified |
 | LocalMarketContactByAddressEnabled |
 | LocalMarketContactByAddressEnabledSpecified |
 | LocalMarketContactByEmailEnabled |
 | LocalMarketContactByEmailEnabledSpecified |
 | LocalMarketContactByPhoneEnabled |
 | LocalMarketContactByPhoneEnabledSpecified |
 | LocalMarketCounterOfferEnabled |
 | LocalMarketCounterOfferEnabledSpecified |
 | LocalMarketNonSubscription |
 | LocalMarketNonSubscriptionSpecified |
 | LocalMarketPaymentMethodCheckOutEnabled |
 | LocalMarketPaymentMethodCheckOutEnabledSpecified |
 | LocalMarketPhoneCount |
 | LocalMarketPhoneCountSpecified |
 | LocalMarketPremiumSubscription |
 | LocalMarketPremiumSubscriptionSpecified |
 | LocalMarketRegularSubscription |
 | LocalMarketRegularSubscriptionSpecified |
 | LocalMarketSellerContactDetailsEnabled |
 | LocalMarketSellerContactDetailsEnabledSpecified |
 | LocalMarketShippingMethodEnabled |
 | LocalMarketShippingMethodEnabledSpecified |
 | LocalMarketSpecialitySubscription |
 | LocalMarketSpecialitySubscriptionSpecified |
 | LocalMarketStreetCount |
 | LocalMarketStreetCountSpecified |
 | MaxFlatShippingCost |
 | MaxFlatShippingCostCBTExempt |
 | MaxFlatShippingCostCBTExemptSpecified |
 | MaxGranularFitmentCount |
 | MaxGranularFitmentCountSpecified |
 | MaxItemCompatibility |
 | MaxItemCompatibilitySpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumReservePrice |
 | MinimumReservePriceSpecified |
 | MinItemCompatibility |
 | MinItemCompatibilitySpecified |
 | NonSubscription |
 | NonSubscriptionSpecified |
 | PaisaPayFullEscrowEnabled |
 | PaisaPayFullEscrowEnabledSpecified |
 | PaymentMethod |
 | PaymentOptionsGroup |
 | PaymentOptionsGroupSpecified |
 | PaymentProfileCategoryGroup |
 | PaymentProfileCategoryGroupSpecified |
 | PayPalBuyerProtectionEnabled |
 | PayPalBuyerProtectionEnabledSpecified |
 | PayPalRequired |
 | PayPalRequiredForStoreOwner |
 | PayPalRequiredForStoreOwnerSpecified |
 | PayPalRequiredSpecified |
 | PickupDropOffEnabled |
 | PickupDropOffEnabledSpecified |
 | PremiumSubscription |
 | PremiumSubscriptionSpecified |
 | ProductCreationEnabled |
 | ProductCreationEnabledSpecified |
 | ProPackEnabled |
 | ProPackEnabledSpecified |
 | ProPackPlusEnabled |
 | ProPackPlusEnabledSpecified |
 | RegularSubscription |
 | RegularSubscriptionSpecified |
 | ReturnPolicyEnabled |
 | ReturnPolicyEnabledSpecified |
 | ReturnPolicyProfileCategoryGroup |
 | ReturnPolicyProfileCategoryGroupSpecified |
 | RevisePriceAllowed |
 | RevisePriceAllowedSpecified |
 | ReviseQuantityAllowed |
 | ReviseQuantityAllowedSpecified |
 | SafePaymentRequired |
 | SafePaymentRequiredSpecified |
 | SellerContactDetailsEnabled |
 | SellerContactDetailsEnabledSpecified |
 | SellerProvidedTitleSupported |
 | SellerProvidedTitleSupportedSpecified |
 | ShippingProfileCategoryGroup |
 | ShippingProfileCategoryGroupSpecified |
 | ShippingTermsRequired |
 | ShippingTermsRequiredSpecified |
 | SkypeMeNonTransactionalEnabled |
 | SkypeMeNonTransactionalEnabledSpecified |
 | SkypeMeTransactionalEnabled |
 | SkypeMeTransactionalEnabledSpecified |
 | SpecialitySubscription |
 | SpecialitySubscriptionSpecified |
 | StoreInventoryEnabled |
 | StoreInventoryEnabledSpecified |
 | StoreOwnerExtendedListingDurations |
 | StoreOwnerExtendedListingDurationsEnabled |
 | StoreOwnerExtendedListingDurationsEnabledSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TransactionConfirmationRequestEnabled |
 | TransactionConfirmationRequestEnabledSpecified |
 | UPCEnabled |
 | UPCEnabledSpecified |
 | UPCIdentifierEnabled |
 | UPCIdentifierEnabledSpecified |
 | UserConsentRequired |
 | UserConsentRequiredSpecified |
 | ValueCategory |
 | ValueCategorySpecified |
 | ValuePackEnabled |
 | ValuePackEnabledSpecified |
 | VariationsEnabled |
 | VariationsEnabledSpecified |
 | VINSupported |
 | VINSupportedSpecified |
 | VRMSupported |
 | VRMSupportedSpecified |
Remarks
Inheritance Hierarchy
Object
SiteDefaultsType


AdditionalCompatibilityEnabled Property

AdditionalCompatibilityEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► AdditionalCompatibilityEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool AdditionalCompatibilityEnabled { get; set; }
Public Property AdditionalCompatibilityEnabled As Boolean
    Get
    Set
public:
property bool AdditionalCompatibilityEnabled {
    bool get ();
    void set (bool value);
}


AdditionalCompatibilityEnabledSpecified Property

AdditionalCompatibilityEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► AdditionalCompatibilityEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AdditionalCompatibilityEnabledSpecified { get; set; }
Public Property AdditionalCompatibilityEnabledSpecified As Boolean
    Get
    Set
public:
property bool AdditionalCompatibilityEnabledSpecified {
    bool get ();
    void set (bool value);
}


AdFormatEnabled Property

AdFormatEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► AdFormatEnabled
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatEnabledCodeType AdFormatEnabled { get; set; }
Public Property AdFormatEnabled As AdFormatEnabledCodeType
    Get
    Set
public:
property AdFormatEnabledCodeType AdFormatEnabled {
    AdFormatEnabledCodeType get ();
    void set (AdFormatEnabledCodeType value);
}


AdFormatEnabledSpecified Property

AdFormatEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► AdFormatEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AdFormatEnabledSpecified { get; set; }
Public Property AdFormatEnabledSpecified As Boolean
    Get
    Set
public:
property bool AdFormatEnabledSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AttributeConversionEnabled Property

AttributeConversionEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► AttributeConversionEnabled
Declaration Syntax
C# Visual Basic Visual C++
public AttributeConversionEnabledCodeType AttributeConversionEnabled { get; set; }
Public Property AttributeConversionEnabled As AttributeConversionEnabledCodeType
    Get
    Set
public:
property AttributeConversionEnabledCodeType AttributeConversionEnabled {
    AttributeConversionEnabledCodeType get ();
    void set (AttributeConversionEnabledCodeType value);
}


AttributeConversionEnabledSpecified Property

AttributeConversionEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► AttributeConversionEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AttributeConversionEnabledSpecified { get; set; }
Public Property AttributeConversionEnabledSpecified As Boolean
    Get
    Set
public:
property bool AttributeConversionEnabledSpecified {
    bool get ();
    void set (bool value);
}


BasicUpgradePackEnabled Property

BasicUpgradePackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BasicUpgradePackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BasicUpgradePackEnabled { get; set; }
Public Property BasicUpgradePackEnabled As Boolean
    Get
    Set
public:
property bool BasicUpgradePackEnabled {
    bool get ();
    void set (bool value);
}


BasicUpgradePackEnabledSpecified Property

BasicUpgradePackEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BasicUpgradePackEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BasicUpgradePackEnabledSpecified { get; set; }
Public Property BasicUpgradePackEnabledSpecified As Boolean
    Get
    Set
public:
property bool BasicUpgradePackEnabledSpecified {
    bool get ();
    void set (bool value);
}


BestOfferAutoAcceptEnabled Property

BestOfferAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BestOfferAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferAutoAcceptEnabled { get; set; }
Public Property BestOfferAutoAcceptEnabled As Boolean
    Get
    Set
public:
property bool BestOfferAutoAcceptEnabled {
    bool get ();
    void set (bool value);
}


BestOfferAutoAcceptEnabledSpecified Property

BestOfferAutoAcceptEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BestOfferAutoAcceptEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferAutoAcceptEnabledSpecified { get; set; }
Public Property BestOfferAutoAcceptEnabledSpecified As Boolean
    Get
    Set
public:
property bool BestOfferAutoAcceptEnabledSpecified {
    bool get ();
    void set (bool value);
}


BestOfferAutoDeclineEnabled Property

BestOfferAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BestOfferAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferAutoDeclineEnabled { get; set; }
Public Property BestOfferAutoDeclineEnabled As Boolean
    Get
    Set
public:
property bool BestOfferAutoDeclineEnabled {
    bool get ();
    void set (bool value);
}


BestOfferAutoDeclineEnabledSpecified Property

BestOfferAutoDeclineEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BestOfferAutoDeclineEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferAutoDeclineEnabledSpecified { get; set; }
Public Property BestOfferAutoDeclineEnabledSpecified As Boolean
    Get
    Set
public:
property bool BestOfferAutoDeclineEnabledSpecified {
    bool get ();
    void set (bool value);
}


BestOfferCounterEnabled Property

BestOfferCounterEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BestOfferCounterEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferCounterEnabled { get; set; }
Public Property BestOfferCounterEnabled As Boolean
    Get
    Set
public:
property bool BestOfferCounterEnabled {
    bool get ();
    void set (bool value);
}


BestOfferCounterEnabledSpecified Property

BestOfferCounterEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BestOfferCounterEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferCounterEnabledSpecified { get; set; }
Public Property BestOfferCounterEnabledSpecified As Boolean
    Get
    Set
public:
property bool BestOfferCounterEnabledSpecified {
    bool get ();
    void set (bool value);
}


BestOfferEnabled Property

BestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferEnabled { get; set; }
Public Property BestOfferEnabled As Boolean
    Get
    Set
public:
property bool BestOfferEnabled {
    bool get ();
    void set (bool value);
}


BestOfferEnabledSpecified Property

BestOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BestOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferEnabledSpecified { get; set; }
Public Property BestOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool BestOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


BrandMPNIdentifierEnabled Property

BrandMPNIdentifierEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BrandMPNIdentifierEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BrandMPNIdentifierEnabled { get; set; }
Public Property BrandMPNIdentifierEnabled As Boolean
    Get
    Set
public:
property bool BrandMPNIdentifierEnabled {
    bool get ();
    void set (bool value);
}


BrandMPNIdentifierEnabledSpecified Property

BrandMPNIdentifierEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BrandMPNIdentifierEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BrandMPNIdentifierEnabledSpecified { get; set; }
Public Property BrandMPNIdentifierEnabledSpecified As Boolean
    Get
    Set
public:
property bool BrandMPNIdentifierEnabledSpecified {
    bool get ();
    void set (bool value);
}


BuyerGuaranteeEnabled Property

BuyerGuaranteeEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BuyerGuaranteeEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerGuaranteeEnabled { get; set; }
Public Property BuyerGuaranteeEnabled As Boolean
    Get
    Set
public:
property bool BuyerGuaranteeEnabled {
    bool get ();
    void set (bool value);
}


BuyerGuaranteeEnabledSpecified Property

BuyerGuaranteeEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► BuyerGuaranteeEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerGuaranteeEnabledSpecified { get; set; }
Public Property BuyerGuaranteeEnabledSpecified As Boolean
    Get
    Set
public:
property bool BuyerGuaranteeEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdAutoAcceptEnabled Property

ClassifiedAdAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdAutoAcceptEnabled { get; set; }
Public Property ClassifiedAdAutoAcceptEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdAutoAcceptEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdAutoAcceptEnabledSpecified Property

ClassifiedAdAutoAcceptEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdAutoAcceptEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdAutoAcceptEnabledSpecified { get; set; }
Public Property ClassifiedAdAutoAcceptEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdAutoAcceptEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdAutoDeclineEnabled Property

ClassifiedAdAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdAutoDeclineEnabled { get; set; }
Public Property ClassifiedAdAutoDeclineEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdAutoDeclineEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdAutoDeclineEnabledSpecified Property

ClassifiedAdAutoDeclineEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdAutoDeclineEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdAutoDeclineEnabledSpecified { get; set; }
Public Property ClassifiedAdAutoDeclineEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdAutoDeclineEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdBestOfferEnabled Property

ClassifiedAdBestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdBestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdBestOfferEnabledCodeType ClassifiedAdBestOfferEnabled { get; set; }
Public Property ClassifiedAdBestOfferEnabled As ClassifiedAdBestOfferEnabledCodeType
    Get
    Set
public:
property ClassifiedAdBestOfferEnabledCodeType ClassifiedAdBestOfferEnabled {
    ClassifiedAdBestOfferEnabledCodeType get ();
    void set (ClassifiedAdBestOfferEnabledCodeType value);
}


ClassifiedAdBestOfferEnabledSpecified Property

ClassifiedAdBestOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdBestOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdBestOfferEnabledSpecified { get; set; }
Public Property ClassifiedAdBestOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdBestOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdCompanyNameEnabled Property

ClassifiedAdCompanyNameEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdCompanyNameEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdCompanyNameEnabled { get; set; }
Public Property ClassifiedAdCompanyNameEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdCompanyNameEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdCompanyNameEnabledSpecified Property

ClassifiedAdCompanyNameEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdCompanyNameEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdCompanyNameEnabledSpecified { get; set; }
Public Property ClassifiedAdCompanyNameEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdCompanyNameEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByAddressEnabled Property

ClassifiedAdContactByAddressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdContactByAddressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByAddressEnabled { get; set; }
Public Property ClassifiedAdContactByAddressEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByAddressEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByAddressEnabledSpecified Property

ClassifiedAdContactByAddressEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdContactByAddressEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByAddressEnabledSpecified { get; set; }
Public Property ClassifiedAdContactByAddressEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByAddressEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByEmailEnabled Property

ClassifiedAdContactByEmailEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdContactByEmailEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByEmailEnabled { get; set; }
Public Property ClassifiedAdContactByEmailEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByEmailEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByEmailEnabledSpecified Property

ClassifiedAdContactByEmailEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdContactByEmailEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByEmailEnabledSpecified { get; set; }
Public Property ClassifiedAdContactByEmailEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByEmailEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByPhoneEnabled Property

ClassifiedAdContactByPhoneEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdContactByPhoneEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByPhoneEnabled { get; set; }
Public Property ClassifiedAdContactByPhoneEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByPhoneEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdContactByPhoneEnabledSpecified Property

ClassifiedAdContactByPhoneEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdContactByPhoneEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdContactByPhoneEnabledSpecified { get; set; }
Public Property ClassifiedAdContactByPhoneEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdContactByPhoneEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdCounterOfferEnabled Property

ClassifiedAdCounterOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdCounterOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdCounterOfferEnabled { get; set; }
Public Property ClassifiedAdCounterOfferEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdCounterOfferEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdCounterOfferEnabledSpecified Property

ClassifiedAdCounterOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdCounterOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdCounterOfferEnabledSpecified { get; set; }
Public Property ClassifiedAdCounterOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdCounterOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdPaymentMethodEnabled Property

ClassifiedAdPaymentMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdPaymentMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPaymentMethodEnabledCodeType ClassifiedAdPaymentMethodEnabled { get; set; }
Public Property ClassifiedAdPaymentMethodEnabled As ClassifiedAdPaymentMethodEnabledCodeType
    Get
    Set
public:
property ClassifiedAdPaymentMethodEnabledCodeType ClassifiedAdPaymentMethodEnabled {
    ClassifiedAdPaymentMethodEnabledCodeType get ();
    void set (ClassifiedAdPaymentMethodEnabledCodeType value);
}


ClassifiedAdPaymentMethodEnabledSpecified Property

ClassifiedAdPaymentMethodEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdPaymentMethodEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdPaymentMethodEnabledSpecified { get; set; }
Public Property ClassifiedAdPaymentMethodEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdPaymentMethodEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdPayPerLeadEnabled Property

ClassifiedAdPayPerLeadEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdPayPerLeadEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdPayPerLeadEnabled { get; set; }
Public Property ClassifiedAdPayPerLeadEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdPayPerLeadEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdPayPerLeadEnabledSpecified Property

ClassifiedAdPayPerLeadEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdPayPerLeadEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdPayPerLeadEnabledSpecified { get; set; }
Public Property ClassifiedAdPayPerLeadEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdPayPerLeadEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdPhoneCount Property

ClassifiedAdPhoneCount Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdPhoneCount
Declaration Syntax
C# Visual Basic Visual C++
public int ClassifiedAdPhoneCount { get; set; }
Public Property ClassifiedAdPhoneCount As Integer
    Get
    Set
public:
property int ClassifiedAdPhoneCount {
    int get ();
    void set (int value);
}


ClassifiedAdPhoneCountSpecified Property

ClassifiedAdPhoneCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdPhoneCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdPhoneCountSpecified { get; set; }
Public Property ClassifiedAdPhoneCountSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdPhoneCountSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdShippingMethodEnabled Property

ClassifiedAdShippingMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdShippingMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdShippingMethodEnabled { get; set; }
Public Property ClassifiedAdShippingMethodEnabled As Boolean
    Get
    Set
public:
property bool ClassifiedAdShippingMethodEnabled {
    bool get ();
    void set (bool value);
}


ClassifiedAdShippingMethodEnabledSpecified Property

ClassifiedAdShippingMethodEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdShippingMethodEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdShippingMethodEnabledSpecified { get; set; }
Public Property ClassifiedAdShippingMethodEnabledSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdShippingMethodEnabledSpecified {
    bool get ();
    void set (bool value);
}


ClassifiedAdStreetCount Property

ClassifiedAdStreetCount Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdStreetCount
Declaration Syntax
C# Visual Basic Visual C++
public int ClassifiedAdStreetCount { get; set; }
Public Property ClassifiedAdStreetCount As Integer
    Get
    Set
public:
property int ClassifiedAdStreetCount {
    int get ();
    void set (int value);
}


ClassifiedAdStreetCountSpecified Property

ClassifiedAdStreetCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ClassifiedAdStreetCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ClassifiedAdStreetCountSpecified { get; set; }
Public Property ClassifiedAdStreetCountSpecified As Boolean
    Get
    Set
public:
property bool ClassifiedAdStreetCountSpecified {
    bool get ();
    void set (bool value);
}


CombinedFixedPriceTreatmentEnabled Property

CombinedFixedPriceTreatmentEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► CombinedFixedPriceTreatmentEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CombinedFixedPriceTreatmentEnabled { get; set; }
Public Property CombinedFixedPriceTreatmentEnabled As Boolean
    Get
    Set
public:
property bool CombinedFixedPriceTreatmentEnabled {
    bool get ();
    void set (bool value);
}


CombinedFixedPriceTreatmentEnabledSpecified Property

CombinedFixedPriceTreatmentEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► CombinedFixedPriceTreatmentEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CombinedFixedPriceTreatmentEnabledSpecified { get; set; }
Public Property CombinedFixedPriceTreatmentEnabledSpecified As Boolean
    Get
    Set
public:
property bool CombinedFixedPriceTreatmentEnabledSpecified {
    bool get ();
    void set (bool value);
}


CompatibleVehicleType Property

CompatibleVehicleType Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► CompatibleVehicleType
Declaration Syntax
C# Visual Basic Visual C++
public string CompatibleVehicleType { get; set; }
Public Property CompatibleVehicleType As String
    Get
    Set
public:
property String^ CompatibleVehicleType {
    String^ get ();
    void set (String^ value);
}


ConditionEnabled Property

ConditionEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ConditionEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ConditionEnabledCodeType ConditionEnabled { get; set; }
Public Property ConditionEnabled As ConditionEnabledCodeType
    Get
    Set
public:
property ConditionEnabledCodeType ConditionEnabled {
    ConditionEnabledCodeType get ();
    void set (ConditionEnabledCodeType value);
}


ConditionEnabledSpecified Property

ConditionEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ConditionEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ConditionEnabledSpecified { get; set; }
Public Property ConditionEnabledSpecified As Boolean
    Get
    Set
public:
property bool ConditionEnabledSpecified {
    bool get ();
    void set (bool value);
}


ConditionValues Property

ConditionValues Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ConditionValues
Declaration Syntax
C# Visual Basic Visual C++
public ConditionValuesType ConditionValues { get; set; }
Public Property ConditionValues As ConditionValuesType
    Get
    Set
public:
property ConditionValuesType^ ConditionValues {
    ConditionValuesType^ get ();
    void set (ConditionValuesType^ value);
}


CrossBorderTradeAustraliaEnabled Property

CrossBorderTradeAustraliaEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► CrossBorderTradeAustraliaEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeAustraliaEnabled { get; set; }
Public Property CrossBorderTradeAustraliaEnabled As Boolean
    Get
    Set
public:
property bool CrossBorderTradeAustraliaEnabled {
    bool get ();
    void set (bool value);
}


CrossBorderTradeAustraliaEnabledSpecified Property

CrossBorderTradeAustraliaEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► CrossBorderTradeAustraliaEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeAustraliaEnabledSpecified { get; set; }
Public Property CrossBorderTradeAustraliaEnabledSpecified As Boolean
    Get
    Set
public:
property bool CrossBorderTradeAustraliaEnabledSpecified {
    bool get ();
    void set (bool value);
}


CrossBorderTradeGBEnabled Property

CrossBorderTradeGBEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► CrossBorderTradeGBEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeGBEnabled { get; set; }
Public Property CrossBorderTradeGBEnabled As Boolean
    Get
    Set
public:
property bool CrossBorderTradeGBEnabled {
    bool get ();
    void set (bool value);
}


CrossBorderTradeGBEnabledSpecified Property

CrossBorderTradeGBEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► CrossBorderTradeGBEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeGBEnabledSpecified { get; set; }
Public Property CrossBorderTradeGBEnabledSpecified As Boolean
    Get
    Set
public:
property bool CrossBorderTradeGBEnabledSpecified {
    bool get ();
    void set (bool value);
}


CrossBorderTradeNorthAmericaEnabled Property

CrossBorderTradeNorthAmericaEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► CrossBorderTradeNorthAmericaEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeNorthAmericaEnabled { get; set; }
Public Property CrossBorderTradeNorthAmericaEnabled As Boolean
    Get
    Set
public:
property bool CrossBorderTradeNorthAmericaEnabled {
    bool get ();
    void set (bool value);
}


CrossBorderTradeNorthAmericaEnabledSpecified Property

CrossBorderTradeNorthAmericaEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► CrossBorderTradeNorthAmericaEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossBorderTradeNorthAmericaEnabledSpecified { get; set; }
Public Property CrossBorderTradeNorthAmericaEnabledSpecified As Boolean
    Get
    Set
public:
property bool CrossBorderTradeNorthAmericaEnabledSpecified {
    bool get ();
    void set (bool value);
}


DepositSupported Property

DepositSupported Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► DepositSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool DepositSupported { get; set; }
Public Property DepositSupported As Boolean
    Get
    Set
public:
property bool DepositSupported {
    bool get ();
    void set (bool value);
}


DepositSupportedSpecified Property

DepositSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► DepositSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DepositSupportedSpecified { get; set; }
Public Property DepositSupportedSpecified As Boolean
    Get
    Set
public:
property bool DepositSupportedSpecified {
    bool get ();
    void set (bool value);
}


DigitalGoodDeliveryEnabled Property

DigitalGoodDeliveryEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► DigitalGoodDeliveryEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool DigitalGoodDeliveryEnabled { get; set; }
Public Property DigitalGoodDeliveryEnabled As Boolean
    Get
    Set
public:
property bool DigitalGoodDeliveryEnabled {
    bool get ();
    void set (bool value);
}


DigitalGoodDeliveryEnabledSpecified Property

DigitalGoodDeliveryEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► DigitalGoodDeliveryEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DigitalGoodDeliveryEnabledSpecified { get; set; }
Public Property DigitalGoodDeliveryEnabledSpecified As Boolean
    Get
    Set
public:
property bool DigitalGoodDeliveryEnabledSpecified {
    bool get ();
    void set (bool value);
}


DutchBINEnabled Property

DutchBINEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► DutchBINEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool DutchBINEnabled { get; set; }
Public Property DutchBINEnabled As Boolean
    Get
    Set
public:
property bool DutchBINEnabled {
    bool get ();
    void set (bool value);
}


DutchBINEnabledSpecified Property

DutchBINEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► DutchBINEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DutchBINEnabledSpecified { get; set; }
Public Property DutchBINEnabledSpecified As Boolean
    Get
    Set
public:
property bool DutchBINEnabledSpecified {
    bool get ();
    void set (bool value);
}


EANEnabled Property

EANEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► EANEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ProductIdentiferEnabledCodeType EANEnabled { get; set; }
Public Property EANEnabled As ProductIdentiferEnabledCodeType
    Get
    Set
public:
property ProductIdentiferEnabledCodeType EANEnabled {
    ProductIdentiferEnabledCodeType get ();
    void set (ProductIdentiferEnabledCodeType value);
}


EANEnabledSpecified Property

EANEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► EANEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EANEnabledSpecified { get; set; }
Public Property EANEnabledSpecified As Boolean
    Get
    Set
public:
property bool EANEnabledSpecified {
    bool get ();
    void set (bool value);
}


EANIdentifierEnabled Property

EANIdentifierEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► EANIdentifierEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool EANIdentifierEnabled { get; set; }
Public Property EANIdentifierEnabled As Boolean
    Get
    Set
public:
property bool EANIdentifierEnabled {
    bool get ();
    void set (bool value);
}


EANIdentifierEnabledSpecified Property

EANIdentifierEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► EANIdentifierEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EANIdentifierEnabledSpecified { get; set; }
Public Property EANIdentifierEnabledSpecified As Boolean
    Get
    Set
public:
property bool EANIdentifierEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProAdFormatEnabled Property

eBayMotorsProAdFormatEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProAdFormatEnabled
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatEnabledCodeType eBayMotorsProAdFormatEnabled { get; set; }
Public Property eBayMotorsProAdFormatEnabled As AdFormatEnabledCodeType
    Get
    Set
public:
property AdFormatEnabledCodeType eBayMotorsProAdFormatEnabled {
    AdFormatEnabledCodeType get ();
    void set (AdFormatEnabledCodeType value);
}


eBayMotorsProAdFormatEnabledSpecified Property

eBayMotorsProAdFormatEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProAdFormatEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProAdFormatEnabledSpecified { get; set; }
Public Property eBayMotorsProAdFormatEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProAdFormatEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProAutoAcceptEnabled Property

eBayMotorsProAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProAutoAcceptEnabled { get; set; }
Public Property eBayMotorsProAutoAcceptEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProAutoAcceptEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProAutoAcceptEnabledSpecified Property

eBayMotorsProAutoAcceptEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProAutoAcceptEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProAutoAcceptEnabledSpecified { get; set; }
Public Property eBayMotorsProAutoAcceptEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProAutoAcceptEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProAutoDeclineEnabled Property

eBayMotorsProAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProAutoDeclineEnabled { get; set; }
Public Property eBayMotorsProAutoDeclineEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProAutoDeclineEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProAutoDeclineEnabledSpecified Property

eBayMotorsProAutoDeclineEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProAutoDeclineEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProAutoDeclineEnabledSpecified { get; set; }
Public Property eBayMotorsProAutoDeclineEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProAutoDeclineEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProBestOfferEnabled Property

eBayMotorsProBestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProBestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdBestOfferEnabledCodeType eBayMotorsProBestOfferEnabled { get; set; }
Public Property eBayMotorsProBestOfferEnabled As ClassifiedAdBestOfferEnabledCodeType
    Get
    Set
public:
property ClassifiedAdBestOfferEnabledCodeType eBayMotorsProBestOfferEnabled {
    ClassifiedAdBestOfferEnabledCodeType get ();
    void set (ClassifiedAdBestOfferEnabledCodeType value);
}


eBayMotorsProBestOfferEnabledSpecified Property

eBayMotorsProBestOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProBestOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProBestOfferEnabledSpecified { get; set; }
Public Property eBayMotorsProBestOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProBestOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProCompanyNameEnabled Property

eBayMotorsProCompanyNameEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProCompanyNameEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProCompanyNameEnabled { get; set; }
Public Property eBayMotorsProCompanyNameEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProCompanyNameEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProCompanyNameEnabledSpecified Property

eBayMotorsProCompanyNameEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProCompanyNameEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProCompanyNameEnabledSpecified { get; set; }
Public Property eBayMotorsProCompanyNameEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProCompanyNameEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByAddressEnabled Property

eBayMotorsProContactByAddressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProContactByAddressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByAddressEnabled { get; set; }
Public Property eBayMotorsProContactByAddressEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByAddressEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByAddressEnabledSpecified Property

eBayMotorsProContactByAddressEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProContactByAddressEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByAddressEnabledSpecified { get; set; }
Public Property eBayMotorsProContactByAddressEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByAddressEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByEmailEnabled Property

eBayMotorsProContactByEmailEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProContactByEmailEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByEmailEnabled { get; set; }
Public Property eBayMotorsProContactByEmailEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByEmailEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByEmailEnabledSpecified Property

eBayMotorsProContactByEmailEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProContactByEmailEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByEmailEnabledSpecified { get; set; }
Public Property eBayMotorsProContactByEmailEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByEmailEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByPhoneEnabled Property

eBayMotorsProContactByPhoneEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProContactByPhoneEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByPhoneEnabled { get; set; }
Public Property eBayMotorsProContactByPhoneEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByPhoneEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProContactByPhoneEnabledSpecified Property

eBayMotorsProContactByPhoneEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProContactByPhoneEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProContactByPhoneEnabledSpecified { get; set; }
Public Property eBayMotorsProContactByPhoneEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProContactByPhoneEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProCounterOfferEnabled Property

eBayMotorsProCounterOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProCounterOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProCounterOfferEnabled { get; set; }
Public Property eBayMotorsProCounterOfferEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProCounterOfferEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProCounterOfferEnabledSpecified Property

eBayMotorsProCounterOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProCounterOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProCounterOfferEnabledSpecified { get; set; }
Public Property eBayMotorsProCounterOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProCounterOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProPaymentMethodCheckOutEnabled Property

eBayMotorsProPaymentMethodCheckOutEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProPaymentMethodCheckOutEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPaymentMethodEnabledCodeType eBayMotorsProPaymentMethodCheckOutEnabled { get; set; }
Public Property eBayMotorsProPaymentMethodCheckOutEnabled As ClassifiedAdPaymentMethodEnabledCodeType
    Get
    Set
public:
property ClassifiedAdPaymentMethodEnabledCodeType eBayMotorsProPaymentMethodCheckOutEnabled {
    ClassifiedAdPaymentMethodEnabledCodeType get ();
    void set (ClassifiedAdPaymentMethodEnabledCodeType value);
}


eBayMotorsProPaymentMethodCheckOutEnabledSpecified Property

eBayMotorsProPaymentMethodCheckOutEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProPaymentMethodCheckOutEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProPaymentMethodCheckOutEnabledSpecified { get; set; }
Public Property eBayMotorsProPaymentMethodCheckOutEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProPaymentMethodCheckOutEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProPhoneCount Property

eBayMotorsProPhoneCount Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProPhoneCount
Declaration Syntax
C# Visual Basic Visual C++
public int eBayMotorsProPhoneCount { get; set; }
Public Property eBayMotorsProPhoneCount As Integer
    Get
    Set
public:
property int eBayMotorsProPhoneCount {
    int get ();
    void set (int value);
}


eBayMotorsProPhoneCountSpecified Property

eBayMotorsProPhoneCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProPhoneCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProPhoneCountSpecified { get; set; }
Public Property eBayMotorsProPhoneCountSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProPhoneCountSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProSellerContactDetailsEnabled Property

eBayMotorsProSellerContactDetailsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProSellerContactDetailsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProSellerContactDetailsEnabled { get; set; }
Public Property eBayMotorsProSellerContactDetailsEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProSellerContactDetailsEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProSellerContactDetailsEnabledSpecified Property

eBayMotorsProSellerContactDetailsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProSellerContactDetailsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProSellerContactDetailsEnabledSpecified { get; set; }
Public Property eBayMotorsProSellerContactDetailsEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProSellerContactDetailsEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProShippingMethodEnabled Property

eBayMotorsProShippingMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProShippingMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProShippingMethodEnabled { get; set; }
Public Property eBayMotorsProShippingMethodEnabled As Boolean
    Get
    Set
public:
property bool eBayMotorsProShippingMethodEnabled {
    bool get ();
    void set (bool value);
}


eBayMotorsProShippingMethodEnabledSpecified Property

eBayMotorsProShippingMethodEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProShippingMethodEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProShippingMethodEnabledSpecified { get; set; }
Public Property eBayMotorsProShippingMethodEnabledSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProShippingMethodEnabledSpecified {
    bool get ();
    void set (bool value);
}


eBayMotorsProStreetCount Property

eBayMotorsProStreetCount Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProStreetCount
Declaration Syntax
C# Visual Basic Visual C++
public int eBayMotorsProStreetCount { get; set; }
Public Property eBayMotorsProStreetCount As Integer
    Get
    Set
public:
property int eBayMotorsProStreetCount {
    int get ();
    void set (int value);
}


eBayMotorsProStreetCountSpecified Property

eBayMotorsProStreetCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► eBayMotorsProStreetCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayMotorsProStreetCountSpecified { get; set; }
Public Property eBayMotorsProStreetCountSpecified As Boolean
    Get
    Set
public:
property bool eBayMotorsProStreetCountSpecified {
    bool get ();
    void set (bool value);
}


EpidSupported Property

EpidSupported Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► EpidSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool EpidSupported { get; set; }
Public Property EpidSupported As Boolean
    Get
    Set
public:
property bool EpidSupported {
    bool get ();
    void set (bool value);
}


EpidSupportedSpecified Property

EpidSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► EpidSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EpidSupportedSpecified { get; set; }
Public Property EpidSupportedSpecified As Boolean
    Get
    Set
public:
property bool EpidSupportedSpecified {
    bool get ();
    void set (bool value);
}


ExpressConditionRequired Property

ExpressConditionRequired Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ExpressConditionRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressConditionRequired { get; set; }
Public Property ExpressConditionRequired As Boolean
    Get
    Set
public:
property bool ExpressConditionRequired {
    bool get ();
    void set (bool value);
}


ExpressConditionRequiredSpecified Property

ExpressConditionRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ExpressConditionRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressConditionRequiredSpecified { get; set; }
Public Property ExpressConditionRequiredSpecified As Boolean
    Get
    Set
public:
property bool ExpressConditionRequiredSpecified {
    bool get ();
    void set (bool value);
}


ExpressEnabled Property

ExpressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ExpressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressEnabled { get; set; }
Public Property ExpressEnabled As Boolean
    Get
    Set
public:
property bool ExpressEnabled {
    bool get ();
    void set (bool value);
}


ExpressEnabledSpecified Property

ExpressEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ExpressEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressEnabledSpecified { get; set; }
Public Property ExpressEnabledSpecified As Boolean
    Get
    Set
public:
property bool ExpressEnabledSpecified {
    bool get ();
    void set (bool value);
}


ExpressPicturesRequired Property

ExpressPicturesRequired Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ExpressPicturesRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressPicturesRequired { get; set; }
Public Property ExpressPicturesRequired As Boolean
    Get
    Set
public:
property bool ExpressPicturesRequired {
    bool get ();
    void set (bool value);
}


ExpressPicturesRequiredSpecified Property

ExpressPicturesRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ExpressPicturesRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressPicturesRequiredSpecified { get; set; }
Public Property ExpressPicturesRequiredSpecified As Boolean
    Get
    Set
public:
property bool ExpressPicturesRequiredSpecified {
    bool get ();
    void set (bool value);
}


FreeGalleryPlusEnabled Property

FreeGalleryPlusEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► FreeGalleryPlusEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool FreeGalleryPlusEnabled { get; set; }
Public Property FreeGalleryPlusEnabled As Boolean
    Get
    Set
public:
property bool FreeGalleryPlusEnabled {
    bool get ();
    void set (bool value);
}


FreeGalleryPlusEnabledSpecified Property

FreeGalleryPlusEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► FreeGalleryPlusEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FreeGalleryPlusEnabledSpecified { get; set; }
Public Property FreeGalleryPlusEnabledSpecified As Boolean
    Get
    Set
public:
property bool FreeGalleryPlusEnabledSpecified {
    bool get ();
    void set (bool value);
}


FreePicturePackEnabled Property

FreePicturePackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► FreePicturePackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool FreePicturePackEnabled { get; set; }
Public Property FreePicturePackEnabled As Boolean
    Get
    Set
public:
property bool FreePicturePackEnabled {
    bool get ();
    void set (bool value);
}


FreePicturePackEnabledSpecified Property

FreePicturePackEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► FreePicturePackEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FreePicturePackEnabledSpecified { get; set; }
Public Property FreePicturePackEnabledSpecified As Boolean
    Get
    Set
public:
property bool FreePicturePackEnabledSpecified {
    bool get ();
    void set (bool value);
}


GalleryFeaturedDurations Property

GalleryFeaturedDurations Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► GalleryFeaturedDurations
Declaration Syntax
C# Visual Basic Visual C++
public ListingEnhancementDurationReferenceType GalleryFeaturedDurations { get; set; }
Public Property GalleryFeaturedDurations As ListingEnhancementDurationReferenceType
    Get
    Set
public:
property ListingEnhancementDurationReferenceType^ GalleryFeaturedDurations {
    ListingEnhancementDurationReferenceType^ get ();
    void set (ListingEnhancementDurationReferenceType^ value);
}


GlobalShippingEnabled Property

GlobalShippingEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► GlobalShippingEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShippingEnabled { get; set; }
Public Property GlobalShippingEnabled As Boolean
    Get
    Set
public:
property bool GlobalShippingEnabled {
    bool get ();
    void set (bool value);
}


GlobalShippingEnabledSpecified Property

GlobalShippingEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► GlobalShippingEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GlobalShippingEnabledSpecified { get; set; }
Public Property GlobalShippingEnabledSpecified As Boolean
    Get
    Set
public:
property bool GlobalShippingEnabledSpecified {
    bool get ();
    void set (bool value);
}


Group1MaxFlatShippingCost Property

Group1MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► Group1MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Group1MaxFlatShippingCost { get; set; }
Public Property Group1MaxFlatShippingCost As AmountType
    Get
    Set
public:
property AmountType^ Group1MaxFlatShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


Group2MaxFlatShippingCost Property

Group2MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► Group2MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Group2MaxFlatShippingCost { get; set; }
Public Property Group2MaxFlatShippingCost As AmountType
    Get
    Set
public:
property AmountType^ Group2MaxFlatShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


Group3MaxFlatShippingCost Property

Group3MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► Group3MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Group3MaxFlatShippingCost { get; set; }
Public Property Group3MaxFlatShippingCost As AmountType
    Get
    Set
public:
property AmountType^ Group3MaxFlatShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


HandlingTimeEnabled Property

HandlingTimeEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► HandlingTimeEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool HandlingTimeEnabled { get; set; }
Public Property HandlingTimeEnabled As Boolean
    Get
    Set
public:
property bool HandlingTimeEnabled {
    bool get ();
    void set (bool value);
}


HandlingTimeEnabledSpecified Property

HandlingTimeEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► HandlingTimeEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HandlingTimeEnabledSpecified { get; set; }
Public Property HandlingTimeEnabledSpecified As Boolean
    Get
    Set
public:
property bool HandlingTimeEnabledSpecified {
    bool get ();
    void set (bool value);
}


HomePageFeaturedEnabled Property

HomePageFeaturedEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► HomePageFeaturedEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool HomePageFeaturedEnabled { get; set; }
Public Property HomePageFeaturedEnabled As Boolean
    Get
    Set
public:
property bool HomePageFeaturedEnabled {
    bool get ();
    void set (bool value);
}


HomePageFeaturedEnabledSpecified Property

HomePageFeaturedEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► HomePageFeaturedEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HomePageFeaturedEnabledSpecified { get; set; }
Public Property HomePageFeaturedEnabledSpecified As Boolean
    Get
    Set
public:
property bool HomePageFeaturedEnabledSpecified {
    bool get ();
    void set (bool value);
}


INEscrowWorkflowTimeline Property

INEscrowWorkflowTimeline Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► INEscrowWorkflowTimeline
Declaration Syntax
C# Visual Basic Visual C++
public INEscrowWorkflowTimelineCodeType INEscrowWorkflowTimeline { get; set; }
Public Property INEscrowWorkflowTimeline As INEscrowWorkflowTimelineCodeType
    Get
    Set
public:
property INEscrowWorkflowTimelineCodeType INEscrowWorkflowTimeline {
    INEscrowWorkflowTimelineCodeType get ();
    void set (INEscrowWorkflowTimelineCodeType value);
}


INEscrowWorkflowTimelineSpecified Property

INEscrowWorkflowTimelineSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► INEscrowWorkflowTimelineSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool INEscrowWorkflowTimelineSpecified { get; set; }
Public Property INEscrowWorkflowTimelineSpecified As Boolean
    Get
    Set
public:
property bool INEscrowWorkflowTimelineSpecified {
    bool get ();
    void set (bool value);
}


ISBNEnabled Property

ISBNEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ISBNEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ProductIdentiferEnabledCodeType ISBNEnabled { get; set; }
Public Property ISBNEnabled As ProductIdentiferEnabledCodeType
    Get
    Set
public:
property ProductIdentiferEnabledCodeType ISBNEnabled {
    ProductIdentiferEnabledCodeType get ();
    void set (ProductIdentiferEnabledCodeType value);
}


ISBNEnabledSpecified Property

ISBNEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ISBNEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ISBNEnabledSpecified { get; set; }
Public Property ISBNEnabledSpecified As Boolean
    Get
    Set
public:
property bool ISBNEnabledSpecified {
    bool get ();
    void set (bool value);
}


ISBNIdentifierEnabled Property

ISBNIdentifierEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ISBNIdentifierEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ISBNIdentifierEnabled { get; set; }
Public Property ISBNIdentifierEnabled As Boolean
    Get
    Set
public:
property bool ISBNIdentifierEnabled {
    bool get ();
    void set (bool value);
}


ISBNIdentifierEnabledSpecified Property

ISBNIdentifierEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ISBNIdentifierEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ISBNIdentifierEnabledSpecified { get; set; }
Public Property ISBNIdentifierEnabledSpecified As Boolean
    Get
    Set
public:
property bool ISBNIdentifierEnabledSpecified {
    bool get ();
    void set (bool value);
}


ItemCompatibilityEnabled Property

ItemCompatibilityEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ItemCompatibilityEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ItemCompatibilityEnabledCodeType ItemCompatibilityEnabled { get; set; }
Public Property ItemCompatibilityEnabled As ItemCompatibilityEnabledCodeType
    Get
    Set
public:
property ItemCompatibilityEnabledCodeType ItemCompatibilityEnabled {
    ItemCompatibilityEnabledCodeType get ();
    void set (ItemCompatibilityEnabledCodeType value);
}


ItemCompatibilityEnabledSpecified Property

ItemCompatibilityEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ItemCompatibilityEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemCompatibilityEnabledSpecified { get; set; }
Public Property ItemCompatibilityEnabledSpecified As Boolean
    Get
    Set
public:
property bool ItemCompatibilityEnabledSpecified {
    bool get ();
    void set (bool value);
}


ItemSpecificsEnabled Property

ItemSpecificsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ItemSpecificsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ItemSpecificsEnabledCodeType ItemSpecificsEnabled { get; set; }
Public Property ItemSpecificsEnabled As ItemSpecificsEnabledCodeType
    Get
    Set
public:
property ItemSpecificsEnabledCodeType ItemSpecificsEnabled {
    ItemSpecificsEnabledCodeType get ();
    void set (ItemSpecificsEnabledCodeType value);
}


ItemSpecificsEnabledSpecified Property

ItemSpecificsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ItemSpecificsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemSpecificsEnabledSpecified { get; set; }
Public Property ItemSpecificsEnabledSpecified As Boolean
    Get
    Set
public:
property bool ItemSpecificsEnabledSpecified {
    bool get ();
    void set (bool value);
}


KTypeSupported Property

KTypeSupported Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► KTypeSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool KTypeSupported { get; set; }
Public Property KTypeSupported As Boolean
    Get
    Set
public:
property bool KTypeSupported {
    bool get ();
    void set (bool value);
}


KTypeSupportedSpecified Property

KTypeSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► KTypeSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool KTypeSupportedSpecified { get; set; }
Public Property KTypeSupportedSpecified As Boolean
    Get
    Set
public:
property bool KTypeSupportedSpecified {
    bool get ();
    void set (bool value);
}


ListingDuration Property

ListingDuration Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ListingDuration
Declaration Syntax
C# Visual Basic Visual C++
public ListingDurationReferenceTypeCollection ListingDuration { get; set; }
Public Property ListingDuration As ListingDurationReferenceTypeCollection
    Get
    Set
public:
property ListingDurationReferenceTypeCollection^ ListingDuration {
    ListingDurationReferenceTypeCollection^ get ();
    void set (ListingDurationReferenceTypeCollection^ value);
}


LocalListingDistancesNonSubscription Property

LocalListingDistancesNonSubscription Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalListingDistancesNonSubscription
Declaration Syntax
C# Visual Basic Visual C++
public string LocalListingDistancesNonSubscription { get; set; }
Public Property LocalListingDistancesNonSubscription As String
    Get
    Set
public:
property String^ LocalListingDistancesNonSubscription {
    String^ get ();
    void set (String^ value);
}


LocalListingDistancesRegular Property

LocalListingDistancesRegular Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalListingDistancesRegular
Declaration Syntax
C# Visual Basic Visual C++
public string LocalListingDistancesRegular { get; set; }
Public Property LocalListingDistancesRegular As String
    Get
    Set
public:
property String^ LocalListingDistancesRegular {
    String^ get ();
    void set (String^ value);
}


LocalListingDistancesSpecialty Property

LocalListingDistancesSpecialty Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalListingDistancesSpecialty
Declaration Syntax
C# Visual Basic Visual C++
public string LocalListingDistancesSpecialty { get; set; }
Public Property LocalListingDistancesSpecialty As String
    Get
    Set
public:
property String^ LocalListingDistancesSpecialty {
    String^ get ();
    void set (String^ value);
}


LocalMarketAdFormatEnabled Property

LocalMarketAdFormatEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketAdFormatEnabled
Declaration Syntax
C# Visual Basic Visual C++
public AdFormatEnabledCodeType LocalMarketAdFormatEnabled { get; set; }
Public Property LocalMarketAdFormatEnabled As AdFormatEnabledCodeType
    Get
    Set
public:
property AdFormatEnabledCodeType LocalMarketAdFormatEnabled {
    AdFormatEnabledCodeType get ();
    void set (AdFormatEnabledCodeType value);
}


LocalMarketAdFormatEnabledSpecified Property

LocalMarketAdFormatEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketAdFormatEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketAdFormatEnabledSpecified { get; set; }
Public Property LocalMarketAdFormatEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketAdFormatEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketAutoAcceptEnabled Property

LocalMarketAutoAcceptEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketAutoAcceptEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketAutoAcceptEnabled { get; set; }
Public Property LocalMarketAutoAcceptEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketAutoAcceptEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketAutoAcceptEnabledSpecified Property

LocalMarketAutoAcceptEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketAutoAcceptEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketAutoAcceptEnabledSpecified { get; set; }
Public Property LocalMarketAutoAcceptEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketAutoAcceptEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketAutoDeclineEnabled Property

LocalMarketAutoDeclineEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketAutoDeclineEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketAutoDeclineEnabled { get; set; }
Public Property LocalMarketAutoDeclineEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketAutoDeclineEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketAutoDeclineEnabledSpecified Property

LocalMarketAutoDeclineEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketAutoDeclineEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketAutoDeclineEnabledSpecified { get; set; }
Public Property LocalMarketAutoDeclineEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketAutoDeclineEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketBestOfferEnabled Property

LocalMarketBestOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketBestOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdBestOfferEnabledCodeType LocalMarketBestOfferEnabled { get; set; }
Public Property LocalMarketBestOfferEnabled As ClassifiedAdBestOfferEnabledCodeType
    Get
    Set
public:
property ClassifiedAdBestOfferEnabledCodeType LocalMarketBestOfferEnabled {
    ClassifiedAdBestOfferEnabledCodeType get ();
    void set (ClassifiedAdBestOfferEnabledCodeType value);
}


LocalMarketBestOfferEnabledSpecified Property

LocalMarketBestOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketBestOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketBestOfferEnabledSpecified { get; set; }
Public Property LocalMarketBestOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketBestOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketCompanyNameEnabled Property

LocalMarketCompanyNameEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketCompanyNameEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketCompanyNameEnabled { get; set; }
Public Property LocalMarketCompanyNameEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketCompanyNameEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketCompanyNameEnabledSpecified Property

LocalMarketCompanyNameEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketCompanyNameEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketCompanyNameEnabledSpecified { get; set; }
Public Property LocalMarketCompanyNameEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketCompanyNameEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketContactByAddressEnabled Property

LocalMarketContactByAddressEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketContactByAddressEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByAddressEnabled { get; set; }
Public Property LocalMarketContactByAddressEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketContactByAddressEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketContactByAddressEnabledSpecified Property

LocalMarketContactByAddressEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketContactByAddressEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByAddressEnabledSpecified { get; set; }
Public Property LocalMarketContactByAddressEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketContactByAddressEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketContactByEmailEnabled Property

LocalMarketContactByEmailEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketContactByEmailEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByEmailEnabled { get; set; }
Public Property LocalMarketContactByEmailEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketContactByEmailEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketContactByEmailEnabledSpecified Property

LocalMarketContactByEmailEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketContactByEmailEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByEmailEnabledSpecified { get; set; }
Public Property LocalMarketContactByEmailEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketContactByEmailEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketContactByPhoneEnabled Property

LocalMarketContactByPhoneEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketContactByPhoneEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByPhoneEnabled { get; set; }
Public Property LocalMarketContactByPhoneEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketContactByPhoneEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketContactByPhoneEnabledSpecified Property

LocalMarketContactByPhoneEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketContactByPhoneEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketContactByPhoneEnabledSpecified { get; set; }
Public Property LocalMarketContactByPhoneEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketContactByPhoneEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketCounterOfferEnabled Property

LocalMarketCounterOfferEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketCounterOfferEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketCounterOfferEnabled { get; set; }
Public Property LocalMarketCounterOfferEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketCounterOfferEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketCounterOfferEnabledSpecified Property

LocalMarketCounterOfferEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketCounterOfferEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketCounterOfferEnabledSpecified { get; set; }
Public Property LocalMarketCounterOfferEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketCounterOfferEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketNonSubscription Property

LocalMarketNonSubscription Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketNonSubscription
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketNonSubscription { get; set; }
Public Property LocalMarketNonSubscription As Boolean
    Get
    Set
public:
property bool LocalMarketNonSubscription {
    bool get ();
    void set (bool value);
}


LocalMarketNonSubscriptionSpecified Property

LocalMarketNonSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketNonSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketNonSubscriptionSpecified { get; set; }
Public Property LocalMarketNonSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketNonSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketPaymentMethodCheckOutEnabled Property

LocalMarketPaymentMethodCheckOutEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketPaymentMethodCheckOutEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ClassifiedAdPaymentMethodEnabledCodeType LocalMarketPaymentMethodCheckOutEnabled { get; set; }
Public Property LocalMarketPaymentMethodCheckOutEnabled As ClassifiedAdPaymentMethodEnabledCodeType
    Get
    Set
public:
property ClassifiedAdPaymentMethodEnabledCodeType LocalMarketPaymentMethodCheckOutEnabled {
    ClassifiedAdPaymentMethodEnabledCodeType get ();
    void set (ClassifiedAdPaymentMethodEnabledCodeType value);
}


LocalMarketPaymentMethodCheckOutEnabledSpecified Property

LocalMarketPaymentMethodCheckOutEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketPaymentMethodCheckOutEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketPaymentMethodCheckOutEnabledSpecified { get; set; }
Public Property LocalMarketPaymentMethodCheckOutEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketPaymentMethodCheckOutEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketPhoneCount Property

LocalMarketPhoneCount Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketPhoneCount
Declaration Syntax
C# Visual Basic Visual C++
public int LocalMarketPhoneCount { get; set; }
Public Property LocalMarketPhoneCount As Integer
    Get
    Set
public:
property int LocalMarketPhoneCount {
    int get ();
    void set (int value);
}


LocalMarketPhoneCountSpecified Property

LocalMarketPhoneCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketPhoneCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketPhoneCountSpecified { get; set; }
Public Property LocalMarketPhoneCountSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketPhoneCountSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketPremiumSubscription Property

LocalMarketPremiumSubscription Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketPremiumSubscription
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketPremiumSubscription { get; set; }
Public Property LocalMarketPremiumSubscription As Boolean
    Get
    Set
public:
property bool LocalMarketPremiumSubscription {
    bool get ();
    void set (bool value);
}


LocalMarketPremiumSubscriptionSpecified Property

LocalMarketPremiumSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketPremiumSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketPremiumSubscriptionSpecified { get; set; }
Public Property LocalMarketPremiumSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketPremiumSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketRegularSubscription Property

LocalMarketRegularSubscription Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketRegularSubscription
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketRegularSubscription { get; set; }
Public Property LocalMarketRegularSubscription As Boolean
    Get
    Set
public:
property bool LocalMarketRegularSubscription {
    bool get ();
    void set (bool value);
}


LocalMarketRegularSubscriptionSpecified Property

LocalMarketRegularSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketRegularSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketRegularSubscriptionSpecified { get; set; }
Public Property LocalMarketRegularSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketRegularSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketSellerContactDetailsEnabled Property

LocalMarketSellerContactDetailsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketSellerContactDetailsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketSellerContactDetailsEnabled { get; set; }
Public Property LocalMarketSellerContactDetailsEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketSellerContactDetailsEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketSellerContactDetailsEnabledSpecified Property

LocalMarketSellerContactDetailsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketSellerContactDetailsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketSellerContactDetailsEnabledSpecified { get; set; }
Public Property LocalMarketSellerContactDetailsEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketSellerContactDetailsEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketShippingMethodEnabled Property

LocalMarketShippingMethodEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketShippingMethodEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketShippingMethodEnabled { get; set; }
Public Property LocalMarketShippingMethodEnabled As Boolean
    Get
    Set
public:
property bool LocalMarketShippingMethodEnabled {
    bool get ();
    void set (bool value);
}


LocalMarketShippingMethodEnabledSpecified Property

LocalMarketShippingMethodEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketShippingMethodEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketShippingMethodEnabledSpecified { get; set; }
Public Property LocalMarketShippingMethodEnabledSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketShippingMethodEnabledSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketSpecialitySubscription Property

LocalMarketSpecialitySubscription Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketSpecialitySubscription
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketSpecialitySubscription { get; set; }
Public Property LocalMarketSpecialitySubscription As Boolean
    Get
    Set
public:
property bool LocalMarketSpecialitySubscription {
    bool get ();
    void set (bool value);
}


LocalMarketSpecialitySubscriptionSpecified Property

LocalMarketSpecialitySubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketSpecialitySubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketSpecialitySubscriptionSpecified { get; set; }
Public Property LocalMarketSpecialitySubscriptionSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketSpecialitySubscriptionSpecified {
    bool get ();
    void set (bool value);
}


LocalMarketStreetCount Property

LocalMarketStreetCount Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketStreetCount
Declaration Syntax
C# Visual Basic Visual C++
public int LocalMarketStreetCount { get; set; }
Public Property LocalMarketStreetCount As Integer
    Get
    Set
public:
property int LocalMarketStreetCount {
    int get ();
    void set (int value);
}


LocalMarketStreetCountSpecified Property

LocalMarketStreetCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► LocalMarketStreetCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LocalMarketStreetCountSpecified { get; set; }
Public Property LocalMarketStreetCountSpecified As Boolean
    Get
    Set
public:
property bool LocalMarketStreetCountSpecified {
    bool get ();
    void set (bool value);
}


MaxFlatShippingCost Property

MaxFlatShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► MaxFlatShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType MaxFlatShippingCost { get; set; }
Public Property MaxFlatShippingCost As AmountType
    Get
    Set
public:
property AmountType^ MaxFlatShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


MaxFlatShippingCostCBTExempt Property

MaxFlatShippingCostCBTExempt Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► MaxFlatShippingCostCBTExempt
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxFlatShippingCostCBTExempt { get; set; }
Public Property MaxFlatShippingCostCBTExempt As Boolean
    Get
    Set
public:
property bool MaxFlatShippingCostCBTExempt {
    bool get ();
    void set (bool value);
}


MaxFlatShippingCostCBTExemptSpecified Property

MaxFlatShippingCostCBTExemptSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► MaxFlatShippingCostCBTExemptSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxFlatShippingCostCBTExemptSpecified { get; set; }
Public Property MaxFlatShippingCostCBTExemptSpecified As Boolean
    Get
    Set
public:
property bool MaxFlatShippingCostCBTExemptSpecified {
    bool get ();
    void set (bool value);
}


MaxGranularFitmentCount Property

MaxGranularFitmentCount Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► MaxGranularFitmentCount
Declaration Syntax
C# Visual Basic Visual C++
public int MaxGranularFitmentCount { get; set; }
Public Property MaxGranularFitmentCount As Integer
    Get
    Set
public:
property int MaxGranularFitmentCount {
    int get ();
    void set (int value);
}


MaxGranularFitmentCountSpecified Property

MaxGranularFitmentCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► MaxGranularFitmentCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxGranularFitmentCountSpecified { get; set; }
Public Property MaxGranularFitmentCountSpecified As Boolean
    Get
    Set
public:
property bool MaxGranularFitmentCountSpecified {
    bool get ();
    void set (bool value);
}


MaxItemCompatibility Property

MaxItemCompatibility Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► MaxItemCompatibility
Declaration Syntax
C# Visual Basic Visual C++
public int MaxItemCompatibility { get; set; }
Public Property MaxItemCompatibility As Integer
    Get
    Set
public:
property int MaxItemCompatibility {
    int get ();
    void set (int value);
}


MaxItemCompatibilitySpecified Property

MaxItemCompatibilitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► MaxItemCompatibilitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxItemCompatibilitySpecified { get; set; }
Public Property MaxItemCompatibilitySpecified As Boolean
    Get
    Set
public:
property bool MaxItemCompatibilitySpecified {
    bool get ();
    void set (bool value);
}


MinimumReservePrice Property

MinimumReservePrice Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► MinimumReservePrice
Declaration Syntax
C# Visual Basic Visual C++
public double MinimumReservePrice { get; set; }
Public Property MinimumReservePrice As Double
    Get
    Set
public:
property double MinimumReservePrice {
    double get ();
    void set (double value);
}


MinimumReservePriceSpecified Property

MinimumReservePriceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► MinimumReservePriceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinimumReservePriceSpecified { get; set; }
Public Property MinimumReservePriceSpecified As Boolean
    Get
    Set
public:
property bool MinimumReservePriceSpecified {
    bool get ();
    void set (bool value);
}


MinItemCompatibility Property

MinItemCompatibility Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► MinItemCompatibility
Declaration Syntax
C# Visual Basic Visual C++
public int MinItemCompatibility { get; set; }
Public Property MinItemCompatibility As Integer
    Get
    Set
public:
property int MinItemCompatibility {
    int get ();
    void set (int value);
}


MinItemCompatibilitySpecified Property

MinItemCompatibilitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► MinItemCompatibilitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinItemCompatibilitySpecified { get; set; }
Public Property MinItemCompatibilitySpecified As Boolean
    Get
    Set
public:
property bool MinItemCompatibilitySpecified {
    bool get ();
    void set (bool value);
}


NonSubscription Property

NonSubscription Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► NonSubscription
Declaration Syntax
C# Visual Basic Visual C++
public GeographicExposureCodeType NonSubscription { get; set; }
Public Property NonSubscription As GeographicExposureCodeType
    Get
    Set
public:
property GeographicExposureCodeType NonSubscription {
    GeographicExposureCodeType get ();
    void set (GeographicExposureCodeType value);
}


NonSubscriptionSpecified Property

NonSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► NonSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NonSubscriptionSpecified { get; set; }
Public Property NonSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool NonSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


PaisaPayFullEscrowEnabled Property

PaisaPayFullEscrowEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PaisaPayFullEscrowEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool PaisaPayFullEscrowEnabled { get; set; }
Public Property PaisaPayFullEscrowEnabled As Boolean
    Get
    Set
public:
property bool PaisaPayFullEscrowEnabled {
    bool get ();
    void set (bool value);
}


PaisaPayFullEscrowEnabledSpecified Property

PaisaPayFullEscrowEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PaisaPayFullEscrowEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaisaPayFullEscrowEnabledSpecified { get; set; }
Public Property PaisaPayFullEscrowEnabledSpecified As Boolean
    Get
    Set
public:
property bool PaisaPayFullEscrowEnabledSpecified {
    bool get ();
    void set (bool value);
}


PaymentMethod Property

PaymentMethod Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PaymentMethod
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeTypeCollection PaymentMethod { get; set; }
Public Property PaymentMethod As BuyerPaymentMethodCodeTypeCollection
    Get
    Set
public:
property BuyerPaymentMethodCodeTypeCollection^ PaymentMethod {
    BuyerPaymentMethodCodeTypeCollection^ get ();
    void set (BuyerPaymentMethodCodeTypeCollection^ value);
}


PaymentOptionsGroup Property

PaymentOptionsGroup Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PaymentOptionsGroup
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionsGroupEnabledCodeType PaymentOptionsGroup { get; set; }
Public Property PaymentOptionsGroup As PaymentOptionsGroupEnabledCodeType
    Get
    Set
public:
property PaymentOptionsGroupEnabledCodeType PaymentOptionsGroup {
    PaymentOptionsGroupEnabledCodeType get ();
    void set (PaymentOptionsGroupEnabledCodeType value);
}


PaymentOptionsGroupSpecified Property

PaymentOptionsGroupSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PaymentOptionsGroupSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentOptionsGroupSpecified { get; set; }
Public Property PaymentOptionsGroupSpecified As Boolean
    Get
    Set
public:
property bool PaymentOptionsGroupSpecified {
    bool get ();
    void set (bool value);
}


PaymentProfileCategoryGroup Property

PaymentProfileCategoryGroup Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PaymentProfileCategoryGroup
Declaration Syntax
C# Visual Basic Visual C++
public ProfileCategoryGroupCodeType PaymentProfileCategoryGroup { get; set; }
Public Property PaymentProfileCategoryGroup As ProfileCategoryGroupCodeType
    Get
    Set
public:
property ProfileCategoryGroupCodeType PaymentProfileCategoryGroup {
    ProfileCategoryGroupCodeType get ();
    void set (ProfileCategoryGroupCodeType value);
}


PaymentProfileCategoryGroupSpecified Property

PaymentProfileCategoryGroupSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PaymentProfileCategoryGroupSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentProfileCategoryGroupSpecified { get; set; }
Public Property PaymentProfileCategoryGroupSpecified As Boolean
    Get
    Set
public:
property bool PaymentProfileCategoryGroupSpecified {
    bool get ();
    void set (bool value);
}


PayPalBuyerProtectionEnabled Property

PayPalBuyerProtectionEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PayPalBuyerProtectionEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalBuyerProtectionEnabled { get; set; }
Public Property PayPalBuyerProtectionEnabled As Boolean
    Get
    Set
public:
property bool PayPalBuyerProtectionEnabled {
    bool get ();
    void set (bool value);
}


PayPalBuyerProtectionEnabledSpecified Property

PayPalBuyerProtectionEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PayPalBuyerProtectionEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalBuyerProtectionEnabledSpecified { get; set; }
Public Property PayPalBuyerProtectionEnabledSpecified As Boolean
    Get
    Set
public:
property bool PayPalBuyerProtectionEnabledSpecified {
    bool get ();
    void set (bool value);
}


PayPalRequired Property

PayPalRequired Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PayPalRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalRequired { get; set; }
Public Property PayPalRequired As Boolean
    Get
    Set
public:
property bool PayPalRequired {
    bool get ();
    void set (bool value);
}


PayPalRequiredForStoreOwner Property

PayPalRequiredForStoreOwner Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PayPalRequiredForStoreOwner
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalRequiredForStoreOwner { get; set; }
Public Property PayPalRequiredForStoreOwner As Boolean
    Get
    Set
public:
property bool PayPalRequiredForStoreOwner {
    bool get ();
    void set (bool value);
}


PayPalRequiredForStoreOwnerSpecified Property

PayPalRequiredForStoreOwnerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PayPalRequiredForStoreOwnerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalRequiredForStoreOwnerSpecified { get; set; }
Public Property PayPalRequiredForStoreOwnerSpecified As Boolean
    Get
    Set
public:
property bool PayPalRequiredForStoreOwnerSpecified {
    bool get ();
    void set (bool value);
}


PayPalRequiredSpecified Property

PayPalRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PayPalRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalRequiredSpecified { get; set; }
Public Property PayPalRequiredSpecified As Boolean
    Get
    Set
public:
property bool PayPalRequiredSpecified {
    bool get ();
    void set (bool value);
}


PickupDropOffEnabled Property

PickupDropOffEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PickupDropOffEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool PickupDropOffEnabled { get; set; }
Public Property PickupDropOffEnabled As Boolean
    Get
    Set
public:
property bool PickupDropOffEnabled {
    bool get ();
    void set (bool value);
}


PickupDropOffEnabledSpecified Property

PickupDropOffEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PickupDropOffEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PickupDropOffEnabledSpecified { get; set; }
Public Property PickupDropOffEnabledSpecified As Boolean
    Get
    Set
public:
property bool PickupDropOffEnabledSpecified {
    bool get ();
    void set (bool value);
}


PremiumSubscription Property

PremiumSubscription Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PremiumSubscription
Declaration Syntax
C# Visual Basic Visual C++
public GeographicExposureCodeType PremiumSubscription { get; set; }
Public Property PremiumSubscription As GeographicExposureCodeType
    Get
    Set
public:
property GeographicExposureCodeType PremiumSubscription {
    GeographicExposureCodeType get ();
    void set (GeographicExposureCodeType value);
}


PremiumSubscriptionSpecified Property

PremiumSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► PremiumSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PremiumSubscriptionSpecified { get; set; }
Public Property PremiumSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool PremiumSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


ProductCreationEnabled Property

ProductCreationEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ProductCreationEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ProductCreationEnabledCodeType ProductCreationEnabled { get; set; }
Public Property ProductCreationEnabled As ProductCreationEnabledCodeType
    Get
    Set
public:
property ProductCreationEnabledCodeType ProductCreationEnabled {
    ProductCreationEnabledCodeType get ();
    void set (ProductCreationEnabledCodeType value);
}


ProductCreationEnabledSpecified Property

ProductCreationEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ProductCreationEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProductCreationEnabledSpecified { get; set; }
Public Property ProductCreationEnabledSpecified As Boolean
    Get
    Set
public:
property bool ProductCreationEnabledSpecified {
    bool get ();
    void set (bool value);
}


ProPackEnabled Property

ProPackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ProPackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ProPackEnabled { get; set; }
Public Property ProPackEnabled As Boolean
    Get
    Set
public:
property bool ProPackEnabled {
    bool get ();
    void set (bool value);
}


ProPackEnabledSpecified Property

ProPackEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ProPackEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProPackEnabledSpecified { get; set; }
Public Property ProPackEnabledSpecified As Boolean
    Get
    Set
public:
property bool ProPackEnabledSpecified {
    bool get ();
    void set (bool value);
}


ProPackPlusEnabled Property

ProPackPlusEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ProPackPlusEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ProPackPlusEnabled { get; set; }
Public Property ProPackPlusEnabled As Boolean
    Get
    Set
public:
property bool ProPackPlusEnabled {
    bool get ();
    void set (bool value);
}


ProPackPlusEnabledSpecified Property

ProPackPlusEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ProPackPlusEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProPackPlusEnabledSpecified { get; set; }
Public Property ProPackPlusEnabledSpecified As Boolean
    Get
    Set
public:
property bool ProPackPlusEnabledSpecified {
    bool get ();
    void set (bool value);
}


RegularSubscription Property

RegularSubscription Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► RegularSubscription
Declaration Syntax
C# Visual Basic Visual C++
public GeographicExposureCodeType RegularSubscription { get; set; }
Public Property RegularSubscription As GeographicExposureCodeType
    Get
    Set
public:
property GeographicExposureCodeType RegularSubscription {
    GeographicExposureCodeType get ();
    void set (GeographicExposureCodeType value);
}


RegularSubscriptionSpecified Property

RegularSubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► RegularSubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RegularSubscriptionSpecified { get; set; }
Public Property RegularSubscriptionSpecified As Boolean
    Get
    Set
public:
property bool RegularSubscriptionSpecified {
    bool get ();
    void set (bool value);
}


ReturnPolicyEnabled Property

ReturnPolicyEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ReturnPolicyEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnPolicyEnabled { get; set; }
Public Property ReturnPolicyEnabled As Boolean
    Get
    Set
public:
property bool ReturnPolicyEnabled {
    bool get ();
    void set (bool value);
}


ReturnPolicyEnabledSpecified Property

ReturnPolicyEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ReturnPolicyEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnPolicyEnabledSpecified { get; set; }
Public Property ReturnPolicyEnabledSpecified As Boolean
    Get
    Set
public:
property bool ReturnPolicyEnabledSpecified {
    bool get ();
    void set (bool value);
}


ReturnPolicyProfileCategoryGroup Property

ReturnPolicyProfileCategoryGroup Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ReturnPolicyProfileCategoryGroup
Declaration Syntax
C# Visual Basic Visual C++
public ProfileCategoryGroupCodeType ReturnPolicyProfileCategoryGroup { get; set; }
Public Property ReturnPolicyProfileCategoryGroup As ProfileCategoryGroupCodeType
    Get
    Set
public:
property ProfileCategoryGroupCodeType ReturnPolicyProfileCategoryGroup {
    ProfileCategoryGroupCodeType get ();
    void set (ProfileCategoryGroupCodeType value);
}


ReturnPolicyProfileCategoryGroupSpecified Property

ReturnPolicyProfileCategoryGroupSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ReturnPolicyProfileCategoryGroupSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnPolicyProfileCategoryGroupSpecified { get; set; }
Public Property ReturnPolicyProfileCategoryGroupSpecified As Boolean
    Get
    Set
public:
property bool ReturnPolicyProfileCategoryGroupSpecified {
    bool get ();
    void set (bool value);
}


RevisePriceAllowed Property

RevisePriceAllowed Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► RevisePriceAllowed
Declaration Syntax
C# Visual Basic Visual C++
public bool RevisePriceAllowed { get; set; }
Public Property RevisePriceAllowed As Boolean
    Get
    Set
public:
property bool RevisePriceAllowed {
    bool get ();
    void set (bool value);
}


RevisePriceAllowedSpecified Property

RevisePriceAllowedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► RevisePriceAllowedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RevisePriceAllowedSpecified { get; set; }
Public Property RevisePriceAllowedSpecified As Boolean
    Get
    Set
public:
property bool RevisePriceAllowedSpecified {
    bool get ();
    void set (bool value);
}


ReviseQuantityAllowed Property

ReviseQuantityAllowed Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ReviseQuantityAllowed
Declaration Syntax
C# Visual Basic Visual C++
public bool ReviseQuantityAllowed { get; set; }
Public Property ReviseQuantityAllowed As Boolean
    Get
    Set
public:
property bool ReviseQuantityAllowed {
    bool get ();
    void set (bool value);
}


ReviseQuantityAllowedSpecified Property

ReviseQuantityAllowedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ReviseQuantityAllowedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReviseQuantityAllowedSpecified { get; set; }
Public Property ReviseQuantityAllowedSpecified As Boolean
    Get
    Set
public:
property bool ReviseQuantityAllowedSpecified {
    bool get ();
    void set (bool value);
}


SafePaymentRequired Property

SafePaymentRequired Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SafePaymentRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool SafePaymentRequired { get; set; }
Public Property SafePaymentRequired As Boolean
    Get
    Set
public:
property bool SafePaymentRequired {
    bool get ();
    void set (bool value);
}


SafePaymentRequiredSpecified Property

SafePaymentRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SafePaymentRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SafePaymentRequiredSpecified { get; set; }
Public Property SafePaymentRequiredSpecified As Boolean
    Get
    Set
public:
property bool SafePaymentRequiredSpecified {
    bool get ();
    void set (bool value);
}


SellerContactDetailsEnabled Property

SellerContactDetailsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SellerContactDetailsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerContactDetailsEnabled { get; set; }
Public Property SellerContactDetailsEnabled As Boolean
    Get
    Set
public:
property bool SellerContactDetailsEnabled {
    bool get ();
    void set (bool value);
}


SellerContactDetailsEnabledSpecified Property

SellerContactDetailsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SellerContactDetailsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerContactDetailsEnabledSpecified { get; set; }
Public Property SellerContactDetailsEnabledSpecified As Boolean
    Get
    Set
public:
property bool SellerContactDetailsEnabledSpecified {
    bool get ();
    void set (bool value);
}


SellerProvidedTitleSupported Property

SellerProvidedTitleSupported Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SellerProvidedTitleSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerProvidedTitleSupported { get; set; }
Public Property SellerProvidedTitleSupported As Boolean
    Get
    Set
public:
property bool SellerProvidedTitleSupported {
    bool get ();
    void set (bool value);
}


SellerProvidedTitleSupportedSpecified Property

SellerProvidedTitleSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SellerProvidedTitleSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerProvidedTitleSupportedSpecified { get; set; }
Public Property SellerProvidedTitleSupportedSpecified As Boolean
    Get
    Set
public:
property bool SellerProvidedTitleSupportedSpecified {
    bool get ();
    void set (bool value);
}


ShippingProfileCategoryGroup Property

ShippingProfileCategoryGroup Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ShippingProfileCategoryGroup
Declaration Syntax
C# Visual Basic Visual C++
public ProfileCategoryGroupCodeType ShippingProfileCategoryGroup { get; set; }
Public Property ShippingProfileCategoryGroup As ProfileCategoryGroupCodeType
    Get
    Set
public:
property ProfileCategoryGroupCodeType ShippingProfileCategoryGroup {
    ProfileCategoryGroupCodeType get ();
    void set (ProfileCategoryGroupCodeType value);
}


ShippingProfileCategoryGroupSpecified Property

ShippingProfileCategoryGroupSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ShippingProfileCategoryGroupSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingProfileCategoryGroupSpecified { get; set; }
Public Property ShippingProfileCategoryGroupSpecified As Boolean
    Get
    Set
public:
property bool ShippingProfileCategoryGroupSpecified {
    bool get ();
    void set (bool value);
}


ShippingTermsRequired Property

ShippingTermsRequired Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ShippingTermsRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTermsRequired { get; set; }
Public Property ShippingTermsRequired As Boolean
    Get
    Set
public:
property bool ShippingTermsRequired {
    bool get ();
    void set (bool value);
}


ShippingTermsRequiredSpecified Property

ShippingTermsRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ShippingTermsRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingTermsRequiredSpecified { get; set; }
Public Property ShippingTermsRequiredSpecified As Boolean
    Get
    Set
public:
property bool ShippingTermsRequiredSpecified {
    bool get ();
    void set (bool value);
}


SiteDefaultsType Constructor

SiteDefaultsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SiteDefaultsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteDefaultsType()
Public Sub New
public:
SiteDefaultsType()


SkypeMeNonTransactionalEnabled Property

SkypeMeNonTransactionalEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SkypeMeNonTransactionalEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool SkypeMeNonTransactionalEnabled { get; set; }
Public Property SkypeMeNonTransactionalEnabled As Boolean
    Get
    Set
public:
property bool SkypeMeNonTransactionalEnabled {
    bool get ();
    void set (bool value);
}


SkypeMeNonTransactionalEnabledSpecified Property

SkypeMeNonTransactionalEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SkypeMeNonTransactionalEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SkypeMeNonTransactionalEnabledSpecified { get; set; }
Public Property SkypeMeNonTransactionalEnabledSpecified As Boolean
    Get
    Set
public:
property bool SkypeMeNonTransactionalEnabledSpecified {
    bool get ();
    void set (bool value);
}


SkypeMeTransactionalEnabled Property

SkypeMeTransactionalEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SkypeMeTransactionalEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool SkypeMeTransactionalEnabled { get; set; }
Public Property SkypeMeTransactionalEnabled As Boolean
    Get
    Set
public:
property bool SkypeMeTransactionalEnabled {
    bool get ();
    void set (bool value);
}


SkypeMeTransactionalEnabledSpecified Property

SkypeMeTransactionalEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SkypeMeTransactionalEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SkypeMeTransactionalEnabledSpecified { get; set; }
Public Property SkypeMeTransactionalEnabledSpecified As Boolean
    Get
    Set
public:
property bool SkypeMeTransactionalEnabledSpecified {
    bool get ();
    void set (bool value);
}


SpecialitySubscription Property

SpecialitySubscription Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SpecialitySubscription
Declaration Syntax
C# Visual Basic Visual C++
public GeographicExposureCodeType SpecialitySubscription { get; set; }
Public Property SpecialitySubscription As GeographicExposureCodeType
    Get
    Set
public:
property GeographicExposureCodeType SpecialitySubscription {
    GeographicExposureCodeType get ();
    void set (GeographicExposureCodeType value);
}


SpecialitySubscriptionSpecified Property

SpecialitySubscriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► SpecialitySubscriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SpecialitySubscriptionSpecified { get; set; }
Public Property SpecialitySubscriptionSpecified As Boolean
    Get
    Set
public:
property bool SpecialitySubscriptionSpecified {
    bool get ();
    void set (bool value);
}


StoreInventoryEnabled Property

StoreInventoryEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► StoreInventoryEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreInventoryEnabled { get; set; }
Public Property StoreInventoryEnabled As Boolean
    Get
    Set
public:
property bool StoreInventoryEnabled {
    bool get ();
    void set (bool value);
}


StoreInventoryEnabledSpecified Property

StoreInventoryEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► StoreInventoryEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreInventoryEnabledSpecified { get; set; }
Public Property StoreInventoryEnabledSpecified As Boolean
    Get
    Set
public:
property bool StoreInventoryEnabledSpecified {
    bool get ();
    void set (bool value);
}


StoreOwnerExtendedListingDurations Property

StoreOwnerExtendedListingDurations Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► StoreOwnerExtendedListingDurations
Declaration Syntax
C# Visual Basic Visual C++
public StoreOwnerExtendedListingDurationsType StoreOwnerExtendedListingDurations { get; set; }
Public Property StoreOwnerExtendedListingDurations As StoreOwnerExtendedListingDurationsType
    Get
    Set
public:
property StoreOwnerExtendedListingDurationsType^ StoreOwnerExtendedListingDurations {
    StoreOwnerExtendedListingDurationsType^ get ();
    void set (StoreOwnerExtendedListingDurationsType^ value);
}


StoreOwnerExtendedListingDurationsEnabled Property

StoreOwnerExtendedListingDurationsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► StoreOwnerExtendedListingDurationsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreOwnerExtendedListingDurationsEnabled { get; set; }
Public Property StoreOwnerExtendedListingDurationsEnabled As Boolean
    Get
    Set
public:
property bool StoreOwnerExtendedListingDurationsEnabled {
    bool get ();
    void set (bool value);
}


StoreOwnerExtendedListingDurationsEnabledSpecified Property

StoreOwnerExtendedListingDurationsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► StoreOwnerExtendedListingDurationsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreOwnerExtendedListingDurationsEnabledSpecified { get; set; }
Public Property StoreOwnerExtendedListingDurationsEnabledSpecified As Boolean
    Get
    Set
public:
property bool StoreOwnerExtendedListingDurationsEnabledSpecified {
    bool get ();
    void set (bool value);
}


TransactionConfirmationRequestEnabled Property

TransactionConfirmationRequestEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► TransactionConfirmationRequestEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool TransactionConfirmationRequestEnabled { get; set; }
Public Property TransactionConfirmationRequestEnabled As Boolean
    Get
    Set
public:
property bool TransactionConfirmationRequestEnabled {
    bool get ();
    void set (bool value);
}


TransactionConfirmationRequestEnabledSpecified Property

TransactionConfirmationRequestEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► TransactionConfirmationRequestEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TransactionConfirmationRequestEnabledSpecified { get; set; }
Public Property TransactionConfirmationRequestEnabledSpecified As Boolean
    Get
    Set
public:
property bool TransactionConfirmationRequestEnabledSpecified {
    bool get ();
    void set (bool value);
}


UPCEnabled Property

UPCEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► UPCEnabled
Declaration Syntax
C# Visual Basic Visual C++
public ProductIdentiferEnabledCodeType UPCEnabled { get; set; }
Public Property UPCEnabled As ProductIdentiferEnabledCodeType
    Get
    Set
public:
property ProductIdentiferEnabledCodeType UPCEnabled {
    ProductIdentiferEnabledCodeType get ();
    void set (ProductIdentiferEnabledCodeType value);
}


UPCEnabledSpecified Property

UPCEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► UPCEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UPCEnabledSpecified { get; set; }
Public Property UPCEnabledSpecified As Boolean
    Get
    Set
public:
property bool UPCEnabledSpecified {
    bool get ();
    void set (bool value);
}


UPCIdentifierEnabled Property

UPCIdentifierEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► UPCIdentifierEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool UPCIdentifierEnabled { get; set; }
Public Property UPCIdentifierEnabled As Boolean
    Get
    Set
public:
property bool UPCIdentifierEnabled {
    bool get ();
    void set (bool value);
}


UPCIdentifierEnabledSpecified Property

UPCIdentifierEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► UPCIdentifierEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UPCIdentifierEnabledSpecified { get; set; }
Public Property UPCIdentifierEnabledSpecified As Boolean
    Get
    Set
public:
property bool UPCIdentifierEnabledSpecified {
    bool get ();
    void set (bool value);
}


UserConsentRequired Property

UserConsentRequired Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► UserConsentRequired
Declaration Syntax
C# Visual Basic Visual C++
public bool UserConsentRequired { get; set; }
Public Property UserConsentRequired As Boolean
    Get
    Set
public:
property bool UserConsentRequired {
    bool get ();
    void set (bool value);
}


UserConsentRequiredSpecified Property

UserConsentRequiredSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► UserConsentRequiredSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UserConsentRequiredSpecified { get; set; }
Public Property UserConsentRequiredSpecified As Boolean
    Get
    Set
public:
property bool UserConsentRequiredSpecified {
    bool get ();
    void set (bool value);
}


ValueCategory Property

ValueCategory Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ValueCategory
Declaration Syntax
C# Visual Basic Visual C++
public bool ValueCategory { get; set; }
Public Property ValueCategory As Boolean
    Get
    Set
public:
property bool ValueCategory {
    bool get ();
    void set (bool value);
}


ValueCategorySpecified Property

ValueCategorySpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ValueCategorySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ValueCategorySpecified { get; set; }
Public Property ValueCategorySpecified As Boolean
    Get
    Set
public:
property bool ValueCategorySpecified {
    bool get ();
    void set (bool value);
}


ValuePackEnabled Property

ValuePackEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ValuePackEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool ValuePackEnabled { get; set; }
Public Property ValuePackEnabled As Boolean
    Get
    Set
public:
property bool ValuePackEnabled {
    bool get ();
    void set (bool value);
}


ValuePackEnabledSpecified Property

ValuePackEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► ValuePackEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ValuePackEnabledSpecified { get; set; }
Public Property ValuePackEnabledSpecified As Boolean
    Get
    Set
public:
property bool ValuePackEnabledSpecified {
    bool get ();
    void set (bool value);
}


VariationsEnabled Property

VariationsEnabled Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► VariationsEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool VariationsEnabled { get; set; }
Public Property VariationsEnabled As Boolean
    Get
    Set
public:
property bool VariationsEnabled {
    bool get ();
    void set (bool value);
}


VariationsEnabledSpecified Property

VariationsEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► VariationsEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VariationsEnabledSpecified { get; set; }
Public Property VariationsEnabledSpecified As Boolean
    Get
    Set
public:
property bool VariationsEnabledSpecified {
    bool get ();
    void set (bool value);
}


VINSupported Property

VINSupported Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► VINSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool VINSupported { get; set; }
Public Property VINSupported As Boolean
    Get
    Set
public:
property bool VINSupported {
    bool get ();
    void set (bool value);
}


VINSupportedSpecified Property

VINSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► VINSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VINSupportedSpecified { get; set; }
Public Property VINSupportedSpecified As Boolean
    Get
    Set
public:
property bool VINSupportedSpecified {
    bool get ();
    void set (bool value);
}


VRMSupported Property

VRMSupported Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► VRMSupported
Declaration Syntax
C# Visual Basic Visual C++
public bool VRMSupported { get; set; }
Public Property VRMSupported As Boolean
    Get
    Set
public:
property bool VRMSupported {
    bool get ();
    void set (bool value);
}


VRMSupportedSpecified Property

VRMSupportedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDefaultsType ► VRMSupportedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VRMSupportedSpecified { get; set; }
Public Property VRMSupportedSpecified As Boolean
    Get
    Set
public:
property bool VRMSupportedSpecified {
    bool get ();
    void set (bool value);
}


SiteDetailsType Class

SiteDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SiteDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SiteDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SiteDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteDetailsType()()()() |
 | Any |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Site |
 | SiteID |
 | SiteIDSpecified |
 | SiteSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
SiteDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


Site Property

Site Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsType ► Site
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType Site { get; set; }
Public Property Site As SiteCodeType
    Get
    Set
public:
property SiteCodeType Site {
    SiteCodeType get ();
    void set (SiteCodeType value);
}


SiteDetailsType Constructor

SiteDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsType ► SiteDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteDetailsType()
Public Sub New
public:
SiteDetailsType()


SiteID Property

SiteID Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsType ► SiteID
Declaration Syntax
C# Visual Basic Visual C++
public int SiteID { get; set; }
Public Property SiteID As Integer
    Get
    Set
public:
property int SiteID {
    int get ();
    void set (int value);
}


SiteIDSpecified Property

SiteIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsType ► SiteIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SiteIDSpecified { get; set; }
Public Property SiteIDSpecified As Boolean
    Get
    Set
public:
property bool SiteIDSpecified {
    bool get ();
    void set (bool value);
}


SiteSpecified Property

SiteSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsType ► SiteSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SiteSpecified { get; set; }
Public Property SiteSpecified As Boolean
    Get
    Set
public:
property bool SiteSpecified {
    bool get ();
    void set (bool value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


SiteDetailsTypeCollection Class

SiteDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SiteDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SiteDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SiteDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteDetailsTypeCollection()()()() |
 | SiteDetailsTypeCollection(array<SiteDetailsType>[]()[][]) |
 | SiteDetailsTypeCollection(SiteDetailsTypeCollection) |
 | Add(SiteDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SiteDetailsType>[]()[][]) |
 | AddRange(SiteDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SiteDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SiteDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SiteDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SiteDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SiteDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SiteDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► Add(SiteDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SiteDetailsType item
)
Public Function Add ( _
    item As SiteDetailsType _
) As Integer
public:
int Add(
    SiteDetailsType^ item
)
Parameters
item (SiteDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SiteDetailsType>[]()[][]) |
 | AddRange(SiteDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► AddRange(array<SiteDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SiteDetailsType[] items
)
Public Sub AddRange ( _
    items As SiteDetailsType() _
)
public:
void AddRange(
    array<SiteDetailsType^>^ items
)
Parameters
items (array< SiteDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► AddRange(SiteDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SiteDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As SiteDetailsTypeCollection _
)
public:
void AddRange(
    SiteDetailsTypeCollection^ items
)
Parameters
items (SiteDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► Contains(SiteDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SiteDetailsType item
)
Public Function Contains ( _
    item As SiteDetailsType _
) As Boolean
public:
bool Contains(
    SiteDetailsType^ item
)
Parameters
item (SiteDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► CopyTo(array<SiteDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SiteDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SiteDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SiteDetailsType^>^ items,
    int index
)
Parameters
items (array< SiteDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► IndexOf(SiteDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SiteDetailsType item
)
Public Function IndexOf ( _
    item As SiteDetailsType _
) As Integer
public:
int IndexOf(
    SiteDetailsType^ item
)
Parameters
item (SiteDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► Insert(Int32, SiteDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SiteDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SiteDetailsType _
)
public:
void Insert(
    int index,
    SiteDetailsType^ item
)
Parameters
index (Int32)
item (SiteDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SiteDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SiteDetailsType
    Get
    Set
public:
property SiteDetailsType^ default[int index] {
    SiteDetailsType^ get (int index);
    void set (int index, SiteDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SiteDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SiteDetailsType
public:
SiteDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► Remove(SiteDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SiteDetailsType item
)
Public Sub Remove ( _
    item As SiteDetailsType _
)
public:
void Remove(
    SiteDetailsType^ item
)
Parameters
item (SiteDetailsType)


SiteDetailsTypeCollection Constructor

SiteDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► SiteDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | SiteDetailsTypeCollection()()()() |
 | SiteDetailsTypeCollection(array<SiteDetailsType>[]()[][]) |
 | SiteDetailsTypeCollection(SiteDetailsTypeCollection) |


SiteDetailsTypeCollection Constructor

SiteDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► SiteDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteDetailsTypeCollection()
Public Sub New
public:
SiteDetailsTypeCollection()


SiteDetailsTypeCollection Constructor (items)

SiteDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► SiteDetailsTypeCollection(array<SiteDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SiteDetailsTypeCollection(
    SiteDetailsType[] items
)
Public Sub New ( _
    items As SiteDetailsType() _
)
public:
SiteDetailsTypeCollection(
    array<SiteDetailsType^>^ items
)
Parameters
items (array< SiteDetailsType >[]()[][])


SiteDetailsTypeCollection Constructor (items)

SiteDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► SiteDetailsTypeCollection(SiteDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SiteDetailsTypeCollection(
    SiteDetailsTypeCollection items
)
Public Sub New ( _
    items As SiteDetailsTypeCollection _
)
public:
SiteDetailsTypeCollection(
    SiteDetailsTypeCollection^ items
)
Parameters
items (SiteDetailsTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteDetailsType[] ToArray()
Public Function ToArray As SiteDetailsType()
public:
array<SiteDetailsType^>^ ToArray()
Return Value


SiteHostedPictureDetailsType Class

SiteHostedPictureDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SiteHostedPictureDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SiteHostedPictureDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SiteHostedPictureDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SiteHostedPictureDetailsType()()()() |
 | Any |
 | BaseURL |
 | Equals(Object) | (Inherited from Object.)
 | ExternalPictureURL |
 | Finalize()()()() | (Inherited from Object.)
 | FullURL |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PictureFormat |
 | PictureFormatSpecified |
 | PictureName |
 | PictureSet |
 | PictureSetMember |
 | PictureSetSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UseByDate |
 | UseByDateSpecified |
Remarks
Inheritance Hierarchy
Object
SiteHostedPictureDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BaseURL Property

BaseURL Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► BaseURL
Declaration Syntax
C# Visual Basic Visual C++
public string BaseURL { get; set; }
Public Property BaseURL As String
    Get
    Set
public:
property String^ BaseURL {
    String^ get ();
    void set (String^ value);
}


ExternalPictureURL Property

ExternalPictureURL Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► ExternalPictureURL
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalPictureURL { get; set; }
Public Property ExternalPictureURL As String
    Get
    Set
public:
property String^ ExternalPictureURL {
    String^ get ();
    void set (String^ value);
}


FullURL Property

FullURL Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► FullURL
Declaration Syntax
C# Visual Basic Visual C++
public string FullURL { get; set; }
Public Property FullURL As String
    Get
    Set
public:
property String^ FullURL {
    String^ get ();
    void set (String^ value);
}


PictureFormat Property

PictureFormat Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► PictureFormat
Declaration Syntax
C# Visual Basic Visual C++
public PictureFormatCodeType PictureFormat { get; set; }
Public Property PictureFormat As PictureFormatCodeType
    Get
    Set
public:
property PictureFormatCodeType PictureFormat {
    PictureFormatCodeType get ();
    void set (PictureFormatCodeType value);
}


PictureFormatSpecified Property

PictureFormatSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► PictureFormatSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PictureFormatSpecified { get; set; }
Public Property PictureFormatSpecified As Boolean
    Get
    Set
public:
property bool PictureFormatSpecified {
    bool get ();
    void set (bool value);
}


PictureName Property

PictureName Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► PictureName
Declaration Syntax
C# Visual Basic Visual C++
public string PictureName { get; set; }
Public Property PictureName As String
    Get
    Set
public:
property String^ PictureName {
    String^ get ();
    void set (String^ value);
}


PictureSet Property

PictureSet Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► PictureSet
Declaration Syntax
C# Visual Basic Visual C++
public PictureSetCodeType PictureSet { get; set; }
Public Property PictureSet As PictureSetCodeType
    Get
    Set
public:
property PictureSetCodeType PictureSet {
    PictureSetCodeType get ();
    void set (PictureSetCodeType value);
}


PictureSetMember Property

PictureSetMember Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► PictureSetMember
Declaration Syntax
C# Visual Basic Visual C++
public PictureSetMemberTypeCollection PictureSetMember { get; set; }
Public Property PictureSetMember As PictureSetMemberTypeCollection
    Get
    Set
public:
property PictureSetMemberTypeCollection^ PictureSetMember {
    PictureSetMemberTypeCollection^ get ();
    void set (PictureSetMemberTypeCollection^ value);
}


PictureSetSpecified Property

PictureSetSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► PictureSetSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PictureSetSpecified { get; set; }
Public Property PictureSetSpecified As Boolean
    Get
    Set
public:
property bool PictureSetSpecified {
    bool get ();
    void set (bool value);
}


SiteHostedPictureDetailsType Constructor

SiteHostedPictureDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► SiteHostedPictureDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteHostedPictureDetailsType()
Public Sub New
public:
SiteHostedPictureDetailsType()


UseByDate Property

UseByDate Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► UseByDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UseByDate { get; set; }
Public Property UseByDate As DateTime
    Get
    Set
public:
property DateTime UseByDate {
    DateTime get ();
    void set (DateTime value);
}


UseByDateSpecified Property

UseByDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SiteHostedPictureDetailsType ► UseByDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UseByDateSpecified { get; set; }
Public Property UseByDateSpecified As Boolean
    Get
    Set
public:
property bool UseByDateSpecified {
    bool get ();
    void set (bool value);
}


SkypeContactOptionCodeType Enumeration

SkypeContactOptionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SkypeContactOptionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SkypeContactOptionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SkypeContactOptionCodeType
Members
Member | Description
Chat |
Voice |
CustomCode |
Remarks


SkypeContactOptionCodeTypeCollection Class

SkypeContactOptionCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SkypeContactOptionCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SkypeContactOptionCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SkypeContactOptionCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SkypeContactOptionCodeTypeCollection()()()() |
 | SkypeContactOptionCodeTypeCollection(array<SkypeContactOptionCodeType>[]()[][]) |
 | SkypeContactOptionCodeTypeCollection(SkypeContactOptionCodeTypeCollection) |
 | Add(SkypeContactOptionCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SkypeContactOptionCodeType>[]()[][]) |
 | AddRange(SkypeContactOptionCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SkypeContactOptionCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SkypeContactOptionCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SkypeContactOptionCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SkypeContactOptionCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SkypeContactOptionCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SkypeContactOptionCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► Add(SkypeContactOptionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SkypeContactOptionCodeType item
)
Public Function Add ( _
    item As SkypeContactOptionCodeType _
) As Integer
public:
int Add(
    SkypeContactOptionCodeType item
)
Parameters
item (SkypeContactOptionCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SkypeContactOptionCodeType>[]()[][]) |
 | AddRange(SkypeContactOptionCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► AddRange(array<SkypeContactOptionCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SkypeContactOptionCodeType[] items
)
Public Sub AddRange ( _
    items As SkypeContactOptionCodeType() _
)
public:
void AddRange(
    array<SkypeContactOptionCodeType>^ items
)
Parameters
items (array< SkypeContactOptionCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► AddRange(SkypeContactOptionCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SkypeContactOptionCodeTypeCollection items
)
Public Sub AddRange ( _
    items As SkypeContactOptionCodeTypeCollection _
)
public:
void AddRange(
    SkypeContactOptionCodeTypeCollection^ items
)
Parameters
items (SkypeContactOptionCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► Contains(SkypeContactOptionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SkypeContactOptionCodeType item
)
Public Function Contains ( _
    item As SkypeContactOptionCodeType _
) As Boolean
public:
bool Contains(
    SkypeContactOptionCodeType item
)
Parameters
item (SkypeContactOptionCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► CopyTo(array<SkypeContactOptionCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SkypeContactOptionCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SkypeContactOptionCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SkypeContactOptionCodeType>^ items,
    int index
)
Parameters
items (array< SkypeContactOptionCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► IndexOf(SkypeContactOptionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SkypeContactOptionCodeType item
)
Public Function IndexOf ( _
    item As SkypeContactOptionCodeType _
) As Integer
public:
int IndexOf(
    SkypeContactOptionCodeType item
)
Parameters
item (SkypeContactOptionCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► Insert(Int32, SkypeContactOptionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SkypeContactOptionCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SkypeContactOptionCodeType _
)
public:
void Insert(
    int index,
    SkypeContactOptionCodeType item
)
Parameters
index (Int32)
item (SkypeContactOptionCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SkypeContactOptionCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SkypeContactOptionCodeType
    Get
    Set
public:
property SkypeContactOptionCodeType default[int index] {
    SkypeContactOptionCodeType get (int index);
    void set (int index, SkypeContactOptionCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SkypeContactOptionCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SkypeContactOptionCodeType
public:
SkypeContactOptionCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► Remove(SkypeContactOptionCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SkypeContactOptionCodeType item
)
Public Sub Remove ( _
    item As SkypeContactOptionCodeType _
)
public:
void Remove(
    SkypeContactOptionCodeType item
)
Parameters
item (SkypeContactOptionCodeType)


SkypeContactOptionCodeTypeCollection Constructor

SkypeContactOptionCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► SkypeContactOptionCodeTypeCollection()()()()
Members
Icon | Member | Description
 | SkypeContactOptionCodeTypeCollection()()()() |
 | SkypeContactOptionCodeTypeCollection(array<SkypeContactOptionCodeType>[]()[][]) |
 | SkypeContactOptionCodeTypeCollection(SkypeContactOptionCodeTypeCollection) |


SkypeContactOptionCodeTypeCollection Constructor

SkypeContactOptionCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► SkypeContactOptionCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SkypeContactOptionCodeTypeCollection()
Public Sub New
public:
SkypeContactOptionCodeTypeCollection()


SkypeContactOptionCodeTypeCollection Constructor (items)

SkypeContactOptionCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► SkypeContactOptionCodeTypeCollection(array<SkypeContactOptionCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SkypeContactOptionCodeTypeCollection(
    SkypeContactOptionCodeType[] items
)
Public Sub New ( _
    items As SkypeContactOptionCodeType() _
)
public:
SkypeContactOptionCodeTypeCollection(
    array<SkypeContactOptionCodeType>^ items
)
Parameters
items (array< SkypeContactOptionCodeType >[]()[][])


SkypeContactOptionCodeTypeCollection Constructor (items)

SkypeContactOptionCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► SkypeContactOptionCodeTypeCollection(SkypeContactOptionCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SkypeContactOptionCodeTypeCollection(
    SkypeContactOptionCodeTypeCollection items
)
Public Sub New ( _
    items As SkypeContactOptionCodeTypeCollection _
)
public:
SkypeContactOptionCodeTypeCollection(
    SkypeContactOptionCodeTypeCollection^ items
)
Parameters
items (SkypeContactOptionCodeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SkypeContactOptionCodeType[] ToArray()
Public Function ToArray As SkypeContactOptionCodeType()
public:
array<SkypeContactOptionCodeType>^ ToArray()
Return Value


SkypeMeNonTransactionalEnabledDefinitionType Class

SkypeMeNonTransactionalEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► SkypeMeNonTransactionalEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SkypeMeNonTransactionalEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SkypeMeNonTransactionalEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SkypeMeNonTransactionalEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SkypeMeNonTransactionalEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SkypeMeNonTransactionalEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SkypeMeNonTransactionalEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SkypeMeNonTransactionalEnabledDefinitionType Constructor

SkypeMeNonTransactionalEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► SkypeMeNonTransactionalEnabledDefinitionType ► SkypeMeNonTransactionalEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SkypeMeNonTransactionalEnabledDefinitionType()
Public Sub New
public:
SkypeMeNonTransactionalEnabledDefinitionType()


SkypeMeTransactionalEnabledDefinitionType Class

SkypeMeTransactionalEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► SkypeMeTransactionalEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SkypeMeTransactionalEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SkypeMeTransactionalEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SkypeMeTransactionalEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SkypeMeTransactionalEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SkypeMeTransactionalEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SkypeMeTransactionalEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SkypeMeTransactionalEnabledDefinitionType Constructor

SkypeMeTransactionalEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► SkypeMeTransactionalEnabledDefinitionType ► SkypeMeTransactionalEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SkypeMeTransactionalEnabledDefinitionType()
Public Sub New
public:
SkypeMeTransactionalEnabledDefinitionType()


SMSSubscriptionErrorCodeCodeType Enumeration

SMSSubscriptionErrorCodeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionErrorCodeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SMSSubscriptionErrorCodeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SMSSubscriptionErrorCodeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SMSSubscriptionErrorCodeCodeType
Members
Member | Description
SMSAggregatorNotAvailable |
PhoneNumberInvalid |
PhoneNumberChanged |
PhoneNumberCarrierChanged |
UserRequestedUnregistration |
CustomCode |
Remarks


SMSSubscriptionType Class

SMSSubscriptionType Class
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SMSSubscriptionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SMSSubscriptionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SMSSubscriptionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SMSSubscriptionType()()()() |
 | Any |
 | CarrierID |
 | CarrierIDSpecified |
 | Equals(Object) | (Inherited from Object.)
 | ErrorCode |
 | ErrorCodeSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemToUnsubscribe |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SMSPhone |
 | ToString()()()() | (Inherited from Object.)
 | UserStatus |
 | UserStatusSpecified |
Remarks
Inheritance Hierarchy
Object
SMSSubscriptionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CarrierID Property

CarrierID Property
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionType ► CarrierID
Declaration Syntax
C# Visual Basic Visual C++
public WirelessCarrierIDCodeType CarrierID { get; set; }
Public Property CarrierID As WirelessCarrierIDCodeType
    Get
    Set
public:
property WirelessCarrierIDCodeType CarrierID {
    WirelessCarrierIDCodeType get ();
    void set (WirelessCarrierIDCodeType value);
}


CarrierIDSpecified Property

CarrierIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionType ► CarrierIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CarrierIDSpecified { get; set; }
Public Property CarrierIDSpecified As Boolean
    Get
    Set
public:
property bool CarrierIDSpecified {
    bool get ();
    void set (bool value);
}


ErrorCode Property

ErrorCode Property
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionType ► ErrorCode
Declaration Syntax
C# Visual Basic Visual C++
public SMSSubscriptionErrorCodeCodeType ErrorCode { get; set; }
Public Property ErrorCode As SMSSubscriptionErrorCodeCodeType
    Get
    Set
public:
property SMSSubscriptionErrorCodeCodeType ErrorCode {
    SMSSubscriptionErrorCodeCodeType get ();
    void set (SMSSubscriptionErrorCodeCodeType value);
}


ErrorCodeSpecified Property

ErrorCodeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionType ► ErrorCodeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ErrorCodeSpecified { get; set; }
Public Property ErrorCodeSpecified As Boolean
    Get
    Set
public:
property bool ErrorCodeSpecified {
    bool get ();
    void set (bool value);
}


ItemToUnsubscribe Property

ItemToUnsubscribe Property
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionType ► ItemToUnsubscribe
Declaration Syntax
C# Visual Basic Visual C++
public string ItemToUnsubscribe { get; set; }
Public Property ItemToUnsubscribe As String
    Get
    Set
public:
property String^ ItemToUnsubscribe {
    String^ get ();
    void set (String^ value);
}


SMSPhone Property

SMSPhone Property
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionType ► SMSPhone
Declaration Syntax
C# Visual Basic Visual C++
public string SMSPhone { get; set; }
Public Property SMSPhone As String
    Get
    Set
public:
property String^ SMSPhone {
    String^ get ();
    void set (String^ value);
}


SMSSubscriptionType Constructor

SMSSubscriptionType Constructor
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionType ► SMSSubscriptionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SMSSubscriptionType()
Public Sub New
public:
SMSSubscriptionType()


UserStatus Property

UserStatus Property
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionType ► UserStatus
Declaration Syntax
C# Visual Basic Visual C++
public SMSSubscriptionUserStatusCodeType UserStatus { get; set; }
Public Property UserStatus As SMSSubscriptionUserStatusCodeType
    Get
    Set
public:
property SMSSubscriptionUserStatusCodeType UserStatus {
    SMSSubscriptionUserStatusCodeType get ();
    void set (SMSSubscriptionUserStatusCodeType value);
}


UserStatusSpecified Property

UserStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionType ► UserStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UserStatusSpecified { get; set; }
Public Property UserStatusSpecified As Boolean
    Get
    Set
public:
property bool UserStatusSpecified {
    bool get ();
    void set (bool value);
}


SMSSubscriptionUserStatusCodeType Enumeration

SMSSubscriptionUserStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SMSSubscriptionUserStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SMSSubscriptionUserStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SMSSubscriptionUserStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SMSSubscriptionUserStatusCodeType
Members
Member | Description
Registered |
Unregistered |
Pending |
Failed |
CustomCode |
Remarks


SoapExtensionEx Class

SoapExtensionEx Class
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionEx
Declaration Syntax
C# Visual Basic Visual C++
public class SoapExtensionEx : SoapExtension
Public Class SoapExtensionEx _
    Inherits SoapExtension
public ref class SoapExtensionEx : public SoapExtension
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SoapExtensionEx()()()() |
 | ChainStream(Stream) | (Overrides SoapExtension.ChainStream(Stream).)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetInitializer(LogicalMethodInfo, SoapExtensionAttribute) | (Overrides SoapExtension.GetInitializer(LogicalMethodInfo, SoapExtensionAttribute).)
 | GetInitializer(Type) | (Overrides SoapExtension.GetInitializer(Type).)
 | GetType()()()() | (Inherited from Object.)
 | Initialize(Object) | (Overrides SoapExtension.Initialize(Object).)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProcessMessage(SoapMessage) | (Overrides SoapExtension.ProcessMessage(SoapMessage).)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | SoapExtension
 |  | SoapExtensionEx


ChainStream Method (StrFrom)

ChainStream Method (StrFrom)
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionEx ► ChainStream(Stream)
Declaration Syntax
C# Visual Basic Visual C++
public override Stream ChainStream(
    Stream StrFrom
)
Public Overrides Function ChainStream ( _
    StrFrom As Stream _
) As Stream
public:
virtual Stream^ ChainStream(
    Stream^ StrFrom
) override
Parameters
StrFrom (Stream)


GetInitializer Method

GetInitializer Method
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionEx ► GetInitializer()()()()
Members
Icon | Member | Description
 | GetInitializer(LogicalMethodInfo, SoapExtensionAttribute) | (Overrides SoapExtension.GetInitializer(LogicalMethodInfo, SoapExtensionAttribute).)
 | GetInitializer(Type) | (Overrides SoapExtension.GetInitializer(Type).)


GetInitializer Method (MethodInfo, Attribute)

GetInitializer Method (MethodInfo, Attribute)
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionEx ► GetInitializer(LogicalMethodInfo, SoapExtensionAttribute)
Declaration Syntax
C# Visual Basic Visual C++
public override Object GetInitializer(
    LogicalMethodInfo MethodInfo,
    SoapExtensionAttribute Attribute
)
Public Overrides Function GetInitializer ( _
    MethodInfo As LogicalMethodInfo, _
    Attribute As SoapExtensionAttribute _
) As Object
public:
virtual Object^ GetInitializer(
    LogicalMethodInfo^ MethodInfo,
    SoapExtensionAttribute^ Attribute
) override
Parameters
MethodInfo (LogicalMethodInfo)
Attribute (SoapExtensionAttribute)
Return Value


GetInitializer Method (ServiceType)

GetInitializer Method (ServiceType)
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionEx ► GetInitializer(Type)
Declaration Syntax
C# Visual Basic Visual C++
public override Object GetInitializer(
    Type ServiceType
)
Public Overrides Function GetInitializer ( _
    ServiceType As Type _
) As Object
public:
virtual Object^ GetInitializer(
    Type^ ServiceType
) override
Parameters
ServiceType (Type)
Return Value


Initialize Method (Initializer)

Initialize Method (Initializer)
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionEx ► Initialize(Object)
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize(
    Object Initializer
)
Public Overrides Sub Initialize ( _
    Initializer As Object _
)
public:
virtual void Initialize(
    Object^ Initializer
) override
Parameters
Initializer (Object)


ProcessMessage Method (Message)

ProcessMessage Method (Message)
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionEx ► ProcessMessage(SoapMessage)
Declaration Syntax
C# Visual Basic Visual C++
public override void ProcessMessage(
    SoapMessage Message
)
Public Overrides Sub ProcessMessage ( _
    Message As SoapMessage _
)
public:
virtual void ProcessMessage(
    SoapMessage^ Message
) override
Parameters
Message (SoapMessage)


SoapExtensionEx Constructor

SoapExtensionEx Constructor
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionEx ► SoapExtensionEx()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SoapExtensionEx()
Public Sub New
public:
SoapExtensionEx()


SoapExtensionExAttribute Class

SoapExtensionExAttribute Class
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionExAttribute
Declaration Syntax
C# Visual Basic Visual C++
[AttributeUsageAttribute(AttributeTargets.Method)]
public sealed class SoapExtensionExAttribute : SoapExtensionAttribute
<AttributeUsageAttribute(AttributeTargets.Method)> _
Public NotInheritable Class SoapExtensionExAttribute _
    Inherits SoapExtensionAttribute
[AttributeUsageAttribute(AttributeTargets::Method)]
public ref class SoapExtensionExAttribute sealed : public SoapExtensionAttribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SoapExtensionExAttribute()()()() |
 | Equals(Object) | (Inherited from Attribute.)
 | ExtensionType | (Overrides SoapExtensionAttribute.ExtensionType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Attribute.)
 | _Attribute..::..GetIDsOfNames(Guid%, IntPtr, UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | GetType()()()() | (Inherited from Object.)
 | _Attribute..::..GetTypeInfo(UInt32, UInt32, IntPtr) | (Inherited from Attribute.)
 | _Attribute..::..GetTypeInfoCount(UInt32%) | (Inherited from Attribute.)
 | _Attribute..::..Invoke(UInt32, Guid%, UInt32, Int16, IntPtr, IntPtr, IntPtr, IntPtr) | (Inherited from Attribute.)
 | IsDefaultAttribute()()()() | (Inherited from Attribute.)
 | Match(Object) | (Inherited from Attribute.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Priority | (Overrides SoapExtensionAttribute.Priority.)
 | ToString()()()() | (Inherited from Object.)
 | TypeId | (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | SoapExtensionAttribute
 |  |  | SoapExtensionExAttribute


ExtensionType Property

ExtensionType Property
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionExAttribute ► ExtensionType
Declaration Syntax
C# Visual Basic Visual C++
public override Type ExtensionType { get; }
Public Overrides ReadOnly Property ExtensionType As Type
    Get
public:
virtual property Type^ ExtensionType {
    Type^ get () override;
}


Priority Property

Priority Property
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionExAttribute ► Priority
Declaration Syntax
C# Visual Basic Visual C++
public override int Priority { get; set; }
Public Overrides Property Priority As Integer
    Get
    Set
public:
virtual property int Priority {
    int get () override;
    void set (int value) override;
}


SoapExtensionExAttribute Constructor

SoapExtensionExAttribute Constructor
Namespaces ► eBay.Service.Core.Soap ► SoapExtensionExAttribute ► SoapExtensionExAttribute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SoapExtensionExAttribute()
Public Sub New
public:
SoapExtensionExAttribute()


SoapHttpClientProtocolEx Class

SoapHttpClientProtocolEx Class
Namespaces ► eBay.Service.Core.Soap ► SoapHttpClientProtocolEx
Declaration Syntax
C# Visual Basic Visual C++
public class SoapHttpClientProtocolEx : SoapHttpClientProtocol
Public Class SoapHttpClientProtocolEx _
    Inherits SoapHttpClientProtocol
public ref class SoapHttpClientProtocolEx : public SoapHttpClientProtocol
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SoapHttpClientProtocolEx()()()() |
 | Abort()()()() | (Inherited from WebClientProtocol.)
 | AllowAutoRedirect | (Inherited from HttpWebClientProtocol.)
 | BeginInvoke(String, array<Object>[]()[][], AsyncCallback, Object) | (Inherited from SoapHttpClientProtocol.)
 | CancelAsync(Object) | (Inherited from HttpWebClientProtocol.)
 | CanRaiseEvents | (Inherited from Component.)
 | ClientCertificates | (Inherited from HttpWebClientProtocol.)
 | ConnectionGroupName | (Inherited from WebClientProtocol.)
 | Container | (Inherited from Component.)
 | CookieContainer | (Inherited from HttpWebClientProtocol.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | Credentials | (Inherited from WebClientProtocol.)
 | DesignMode | (Inherited from Component.)
 | Discover()()()() | (Inherited from SoapHttpClientProtocol.)
 | Dispose()()()() | (Inherited from Component.)
 | Dispose(Boolean) | (Inherited from Component.)
 | Disposed | (Inherited from Component.)
 | EnableDecompression | (Inherited from HttpWebClientProtocol.)
 | EndInvoke(IAsyncResult) | (Inherited from SoapHttpClientProtocol.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Component.)
 | Finalize()()()() | (Inherited from Component.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetReaderForMessage(SoapClientMessage, Int32) | (Inherited from SoapHttpClientProtocol.)
 | GetService(Type) | (Inherited from Component.)
 | GetType()()()() | (Inherited from Object.)
 | GetWebRequest(Uri) | (Inherited from SoapHttpClientProtocol.)
 | GetWebResponse(WebRequest) | (Inherited from HttpWebClientProtocol.)
 | GetWebResponse(WebRequest, IAsyncResult) | (Inherited from HttpWebClientProtocol.)
 | GetWriterForMessage(SoapClientMessage, Int32) | (Inherited from SoapHttpClientProtocol.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | Invoke(String, array<Object>[]()[][]) | (Inherited from SoapHttpClientProtocol.)
 | InvokeAsync(String, array<Object>[]()[][], SendOrPostCallback) | (Inherited from SoapHttpClientProtocol.)
 | InvokeAsync(String, array<Object>[]()[][], SendOrPostCallback, Object) | (Inherited from SoapHttpClientProtocol.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PreAuthenticate | (Inherited from WebClientProtocol.)
 | Proxy | (Inherited from HttpWebClientProtocol.)
 | RequestEncoding | (Inherited from WebClientProtocol.)
 | Site | (Inherited from Component.)
 | SoapRequest |
 | SoapResponse |
 | SoapVersion | (Inherited from SoapHttpClientProtocol.)
 | Timeout | (Inherited from WebClientProtocol.)
 | ToString()()()() | (Inherited from Component.)
 | UnsafeAuthenticatedConnectionSharing | (Inherited from HttpWebClientProtocol.)
 | Url | (Inherited from WebClientProtocol.)
 | UseDefaultCredentials | (Inherited from WebClientProtocol.)
 | UserAgent | (Inherited from HttpWebClientProtocol.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | WebClientProtocol
 |  |  |  | HttpWebClientProtocol
 |  |  |  |  | SoapHttpClientProtocol
 |  |  |  |  |  | SoapHttpClientProtocolEx
 |  |  |  |  |  |  | eBayAPIInterfaceService


SoapHttpClientProtocolEx Constructor

SoapHttpClientProtocolEx Constructor
Namespaces ► eBay.Service.Core.Soap ► SoapHttpClientProtocolEx ► SoapHttpClientProtocolEx()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SoapHttpClientProtocolEx()
Public Sub New
public:
SoapHttpClientProtocolEx()


SoapRequest Property

SoapRequest Property
Namespaces ► eBay.Service.Core.Soap ► SoapHttpClientProtocolEx ► SoapRequest
Declaration Syntax
C# Visual Basic Visual C++
public string SoapRequest { get; set; }
Public Property SoapRequest As String
    Get
    Set
public:
property String^ SoapRequest {
    String^ get ();
    void set (String^ value);
}


SoapResponse Property

SoapResponse Property
Namespaces ► eBay.Service.Core.Soap ► SoapHttpClientProtocolEx ► SoapResponse
Declaration Syntax
C# Visual Basic Visual C++
public string SoapResponse { get; set; }
Public Property SoapResponse As String
    Get
    Set
public:
property String^ SoapResponse {
    String^ get ();
    void set (String^ value);
}


SocialAddressTypeCodeType Enumeration

SocialAddressTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SocialAddressTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SocialAddressTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SocialAddressTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SocialAddressTypeCodeType
Members
Member | Description
Facebook |
Twitter |
Linkedin |
GooglePlus |
Myspace |
Orkut |
CustomCode |
Remarks


SortOrderCodeType Enumeration

SortOrderCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SortOrderCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SortOrderCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SortOrderCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SortOrderCodeType
Members
Member | Description
Ascending |
Descending |
CustomCode |
Remarks


SpecialitySubscriptionDefinitionType Class

SpecialitySubscriptionDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► SpecialitySubscriptionDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SpecialitySubscriptionDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SpecialitySubscriptionDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SpecialitySubscriptionDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpecialitySubscriptionDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SpecialitySubscriptionDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SpecialitySubscriptionDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SpecialitySubscriptionDefinitionType Constructor

SpecialitySubscriptionDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► SpecialitySubscriptionDefinitionType ► SpecialitySubscriptionDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SpecialitySubscriptionDefinitionType()
Public Sub New
public:
SpecialitySubscriptionDefinitionType()


StatusCodeType Enumeration

StatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StatusCodeType
Members
Member | Description
Active |
Inactive |
CustomCode |
Remarks


StoreCategoryUpdateActionCodeType Enumeration

StoreCategoryUpdateActionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StoreCategoryUpdateActionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StoreCategoryUpdateActionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StoreCategoryUpdateActionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StoreCategoryUpdateActionCodeType
Members
Member | Description
Add |
Delete |
Move |
Rename |
CustomCode |
Remarks


StoreColorSchemeType Class

StoreColorSchemeType Class
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreColorSchemeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreColorSchemeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreColorSchemeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreColorSchemeType()()()() |
 | Any |
 | Color |
 | ColorSchemeID |
 | ColorSchemeIDSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | Font |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreColorSchemeType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Color Property

Color Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeType ► Color
Declaration Syntax
C# Visual Basic Visual C++
public StoreColorType Color { get; set; }
Public Property Color As StoreColorType
    Get
    Set
public:
property StoreColorType^ Color {
    StoreColorType^ get ();
    void set (StoreColorType^ value);
}


ColorSchemeID Property

ColorSchemeID Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeType ► ColorSchemeID
Declaration Syntax
C# Visual Basic Visual C++
public int ColorSchemeID { get; set; }
Public Property ColorSchemeID As Integer
    Get
    Set
public:
property int ColorSchemeID {
    int get ();
    void set (int value);
}


ColorSchemeIDSpecified Property

ColorSchemeIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeType ► ColorSchemeIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ColorSchemeIDSpecified { get; set; }
Public Property ColorSchemeIDSpecified As Boolean
    Get
    Set
public:
property bool ColorSchemeIDSpecified {
    bool get ();
    void set (bool value);
}


Font Property

Font Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeType ► Font
Declaration Syntax
C# Visual Basic Visual C++
public StoreFontType Font { get; set; }
Public Property Font As StoreFontType
    Get
    Set
public:
property StoreFontType^ Font {
    StoreFontType^ get ();
    void set (StoreFontType^ value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


StoreColorSchemeType Constructor

StoreColorSchemeType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeType ► StoreColorSchemeType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreColorSchemeType()
Public Sub New
public:
StoreColorSchemeType()


StoreColorSchemeTypeCollection Class

StoreColorSchemeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class StoreColorSchemeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class StoreColorSchemeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class StoreColorSchemeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreColorSchemeTypeCollection()()()() |
 | StoreColorSchemeTypeCollection(array<StoreColorSchemeType>[]()[][]) |
 | StoreColorSchemeTypeCollection(StoreColorSchemeTypeCollection) |
 | Add(StoreColorSchemeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<StoreColorSchemeType>[]()[][]) |
 | AddRange(StoreColorSchemeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(StoreColorSchemeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<StoreColorSchemeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(StoreColorSchemeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, StoreColorSchemeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(StoreColorSchemeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | StoreColorSchemeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► Add(StoreColorSchemeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    StoreColorSchemeType item
)
Public Function Add ( _
    item As StoreColorSchemeType _
) As Integer
public:
int Add(
    StoreColorSchemeType^ item
)
Parameters
item (StoreColorSchemeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<StoreColorSchemeType>[]()[][]) |
 | AddRange(StoreColorSchemeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► AddRange(array<StoreColorSchemeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreColorSchemeType[] items
)
Public Sub AddRange ( _
    items As StoreColorSchemeType() _
)
public:
void AddRange(
    array<StoreColorSchemeType^>^ items
)
Parameters
items (array< StoreColorSchemeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► AddRange(StoreColorSchemeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreColorSchemeTypeCollection items
)
Public Sub AddRange ( _
    items As StoreColorSchemeTypeCollection _
)
public:
void AddRange(
    StoreColorSchemeTypeCollection^ items
)
Parameters
items (StoreColorSchemeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► Contains(StoreColorSchemeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    StoreColorSchemeType item
)
Public Function Contains ( _
    item As StoreColorSchemeType _
) As Boolean
public:
bool Contains(
    StoreColorSchemeType^ item
)
Parameters
item (StoreColorSchemeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► CopyTo(array<StoreColorSchemeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    StoreColorSchemeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As StoreColorSchemeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<StoreColorSchemeType^>^ items,
    int index
)
Parameters
items (array< StoreColorSchemeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► IndexOf(StoreColorSchemeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    StoreColorSchemeType item
)
Public Function IndexOf ( _
    item As StoreColorSchemeType _
) As Integer
public:
int IndexOf(
    StoreColorSchemeType^ item
)
Parameters
item (StoreColorSchemeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► Insert(Int32, StoreColorSchemeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    StoreColorSchemeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As StoreColorSchemeType _
)
public:
void Insert(
    int index,
    StoreColorSchemeType^ item
)
Parameters
index (Int32)
item (StoreColorSchemeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public StoreColorSchemeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As StoreColorSchemeType
    Get
    Set
public:
property StoreColorSchemeType^ default[int index] {
    StoreColorSchemeType^ get (int index);
    void set (int index, StoreColorSchemeType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public StoreColorSchemeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As StoreColorSchemeType
public:
StoreColorSchemeType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► Remove(StoreColorSchemeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    StoreColorSchemeType item
)
Public Sub Remove ( _
    item As StoreColorSchemeType _
)
public:
void Remove(
    StoreColorSchemeType^ item
)
Parameters
item (StoreColorSchemeType)


StoreColorSchemeTypeCollection Constructor

StoreColorSchemeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► StoreColorSchemeTypeCollection()()()()
Members
Icon | Member | Description
 | StoreColorSchemeTypeCollection()()()() |
 | StoreColorSchemeTypeCollection(array<StoreColorSchemeType>[]()[][]) |
 | StoreColorSchemeTypeCollection(StoreColorSchemeTypeCollection) |


StoreColorSchemeTypeCollection Constructor

StoreColorSchemeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► StoreColorSchemeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreColorSchemeTypeCollection()
Public Sub New
public:
StoreColorSchemeTypeCollection()


StoreColorSchemeTypeCollection Constructor (items)

StoreColorSchemeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► StoreColorSchemeTypeCollection(array<StoreColorSchemeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public StoreColorSchemeTypeCollection(
    StoreColorSchemeType[] items
)
Public Sub New ( _
    items As StoreColorSchemeType() _
)
public:
StoreColorSchemeTypeCollection(
    array<StoreColorSchemeType^>^ items
)
Parameters
items (array< StoreColorSchemeType >[]()[][])


StoreColorSchemeTypeCollection Constructor (items)

StoreColorSchemeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► StoreColorSchemeTypeCollection(StoreColorSchemeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public StoreColorSchemeTypeCollection(
    StoreColorSchemeTypeCollection items
)
Public Sub New ( _
    items As StoreColorSchemeTypeCollection _
)
public:
StoreColorSchemeTypeCollection(
    StoreColorSchemeTypeCollection^ items
)
Parameters
items (StoreColorSchemeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreColorSchemeType[] ToArray()
Public Function ToArray As StoreColorSchemeType()
public:
array<StoreColorSchemeType^>^ ToArray()
Return Value


StoreColorType Class

StoreColorType Class
Namespaces ► eBay.Service.Core.Soap ► StoreColorType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreColorType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreColorType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreColorType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreColorType()()()() |
 | Accent |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Primary |
 | Secondary |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreColorType


Accent Property

Accent Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorType ► Accent
Declaration Syntax
C# Visual Basic Visual C++
public string Accent { get; set; }
Public Property Accent As String
    Get
    Set
public:
property String^ Accent {
    String^ get ();
    void set (String^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Primary Property

Primary Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorType ► Primary
Declaration Syntax
C# Visual Basic Visual C++
public string Primary { get; set; }
Public Property Primary As String
    Get
    Set
public:
property String^ Primary {
    String^ get ();
    void set (String^ value);
}


Secondary Property

Secondary Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorType ► Secondary
Declaration Syntax
C# Visual Basic Visual C++
public string Secondary { get; set; }
Public Property Secondary As String
    Get
    Set
public:
property String^ Secondary {
    String^ get ();
    void set (String^ value);
}


StoreColorType Constructor

StoreColorType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreColorType ► StoreColorType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreColorType()
Public Sub New
public:
StoreColorType()


StoreCustomCategoryType Class

StoreCustomCategoryType Class
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreCustomCategoryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreCustomCategoryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreCustomCategoryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreCustomCategoryType()()()() |
 | Any |
 | CategoryID |
 | ChildCategory |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | Order |
 | OrderSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreCustomCategoryType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public long CategoryID { get; set; }
Public Property CategoryID As Long
    Get
    Set
public:
property long long CategoryID {
    long long get ();
    void set (long long value);
}


ChildCategory Property

ChildCategory Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryType ► ChildCategory
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryTypeCollection ChildCategory { get; set; }
Public Property ChildCategory As StoreCustomCategoryTypeCollection
    Get
    Set
public:
property StoreCustomCategoryTypeCollection^ ChildCategory {
    StoreCustomCategoryTypeCollection^ get ();
    void set (StoreCustomCategoryTypeCollection^ value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Order Property

Order Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryType ► Order
Declaration Syntax
C# Visual Basic Visual C++
public int Order { get; set; }
Public Property Order As Integer
    Get
    Set
public:
property int Order {
    int get ();
    void set (int value);
}


OrderSpecified Property

OrderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryType ► OrderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OrderSpecified { get; set; }
Public Property OrderSpecified As Boolean
    Get
    Set
public:
property bool OrderSpecified {
    bool get ();
    void set (bool value);
}


StoreCustomCategoryType Constructor

StoreCustomCategoryType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryType ► StoreCustomCategoryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryType()
Public Sub New
public:
StoreCustomCategoryType()


StoreCustomCategoryTypeCollection Class

StoreCustomCategoryTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class StoreCustomCategoryTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class StoreCustomCategoryTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class StoreCustomCategoryTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreCustomCategoryTypeCollection()()()() |
 | StoreCustomCategoryTypeCollection(array<StoreCustomCategoryType>[]()[][]) |
 | StoreCustomCategoryTypeCollection(StoreCustomCategoryTypeCollection) |
 | Add(StoreCustomCategoryType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<StoreCustomCategoryType>[]()[][]) |
 | AddRange(StoreCustomCategoryTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(StoreCustomCategoryType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<StoreCustomCategoryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(StoreCustomCategoryType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, StoreCustomCategoryType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(StoreCustomCategoryType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | StoreCustomCategoryTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► Add(StoreCustomCategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    StoreCustomCategoryType item
)
Public Function Add ( _
    item As StoreCustomCategoryType _
) As Integer
public:
int Add(
    StoreCustomCategoryType^ item
)
Parameters
item (StoreCustomCategoryType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<StoreCustomCategoryType>[]()[][]) |
 | AddRange(StoreCustomCategoryTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► AddRange(array<StoreCustomCategoryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreCustomCategoryType[] items
)
Public Sub AddRange ( _
    items As StoreCustomCategoryType() _
)
public:
void AddRange(
    array<StoreCustomCategoryType^>^ items
)
Parameters
items (array< StoreCustomCategoryType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► AddRange(StoreCustomCategoryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreCustomCategoryTypeCollection items
)
Public Sub AddRange ( _
    items As StoreCustomCategoryTypeCollection _
)
public:
void AddRange(
    StoreCustomCategoryTypeCollection^ items
)
Parameters
items (StoreCustomCategoryTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► Contains(StoreCustomCategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    StoreCustomCategoryType item
)
Public Function Contains ( _
    item As StoreCustomCategoryType _
) As Boolean
public:
bool Contains(
    StoreCustomCategoryType^ item
)
Parameters
item (StoreCustomCategoryType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► CopyTo(array<StoreCustomCategoryType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    StoreCustomCategoryType[] items,
    int index
)
Public Sub CopyTo ( _
    items As StoreCustomCategoryType(), _
    index As Integer _
)
public:
void CopyTo(
    array<StoreCustomCategoryType^>^ items,
    int index
)
Parameters
items (array< StoreCustomCategoryType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► IndexOf(StoreCustomCategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    StoreCustomCategoryType item
)
Public Function IndexOf ( _
    item As StoreCustomCategoryType _
) As Integer
public:
int IndexOf(
    StoreCustomCategoryType^ item
)
Parameters
item (StoreCustomCategoryType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► Insert(Int32, StoreCustomCategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    StoreCustomCategoryType item
)
Public Sub Insert ( _
    index As Integer, _
    item As StoreCustomCategoryType _
)
public:
void Insert(
    int index,
    StoreCustomCategoryType^ item
)
Parameters
index (Int32)
item (StoreCustomCategoryType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As StoreCustomCategoryType
    Get
    Set
public:
property StoreCustomCategoryType^ default[int index] {
    StoreCustomCategoryType^ get (int index);
    void set (int index, StoreCustomCategoryType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As StoreCustomCategoryType
public:
StoreCustomCategoryType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► Remove(StoreCustomCategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    StoreCustomCategoryType item
)
Public Sub Remove ( _
    item As StoreCustomCategoryType _
)
public:
void Remove(
    StoreCustomCategoryType^ item
)
Parameters
item (StoreCustomCategoryType)


StoreCustomCategoryTypeCollection Constructor

StoreCustomCategoryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► StoreCustomCategoryTypeCollection()()()()
Members
Icon | Member | Description
 | StoreCustomCategoryTypeCollection()()()() |
 | StoreCustomCategoryTypeCollection(array<StoreCustomCategoryType>[]()[][]) |
 | StoreCustomCategoryTypeCollection(StoreCustomCategoryTypeCollection) |


StoreCustomCategoryTypeCollection Constructor

StoreCustomCategoryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► StoreCustomCategoryTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryTypeCollection()
Public Sub New
public:
StoreCustomCategoryTypeCollection()


StoreCustomCategoryTypeCollection Constructor (items)

StoreCustomCategoryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► StoreCustomCategoryTypeCollection(array<StoreCustomCategoryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryTypeCollection(
    StoreCustomCategoryType[] items
)
Public Sub New ( _
    items As StoreCustomCategoryType() _
)
public:
StoreCustomCategoryTypeCollection(
    array<StoreCustomCategoryType^>^ items
)
Parameters
items (array< StoreCustomCategoryType >[]()[][])


StoreCustomCategoryTypeCollection Constructor (items)

StoreCustomCategoryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► StoreCustomCategoryTypeCollection(StoreCustomCategoryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryTypeCollection(
    StoreCustomCategoryTypeCollection items
)
Public Sub New ( _
    items As StoreCustomCategoryTypeCollection _
)
public:
StoreCustomCategoryTypeCollection(
    StoreCustomCategoryTypeCollection^ items
)
Parameters
items (StoreCustomCategoryTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryType[] ToArray()
Public Function ToArray As StoreCustomCategoryType()
public:
array<StoreCustomCategoryType^>^ ToArray()
Return Value


StoreCustomHeaderLayoutCodeType Enumeration

StoreCustomHeaderLayoutCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StoreCustomHeaderLayoutCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StoreCustomHeaderLayoutCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StoreCustomHeaderLayoutCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StoreCustomHeaderLayoutCodeType
Members
Member | Description
NoHeader |
CustomHeaderShown |
CustomCode |
Remarks


StoreCustomListingHeaderDisplayCodeType Enumeration

StoreCustomListingHeaderDisplayCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderDisplayCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StoreCustomListingHeaderDisplayCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StoreCustomListingHeaderDisplayCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StoreCustomListingHeaderDisplayCodeType
Members
Member | Description
None |
Full |
FullAndLeftNavigationBar |
CustomCode |
Remarks


StoreCustomListingHeaderLinkCodeType Enumeration

StoreCustomListingHeaderLinkCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StoreCustomListingHeaderLinkCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StoreCustomListingHeaderLinkCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StoreCustomListingHeaderLinkCodeType
Members
Member | Description
None |
AboutMePage |
CustomPage |
CustomCategory |
CustomCode |
Remarks


StoreCustomListingHeaderLinkType Class

StoreCustomListingHeaderLinkType Class
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreCustomListingHeaderLinkType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreCustomListingHeaderLinkType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreCustomListingHeaderLinkType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreCustomListingHeaderLinkType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LinkID |
 | LinkType |
 | LinkTypeSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Order |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreCustomListingHeaderLinkType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LinkID Property

LinkID Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkType ► LinkID
Declaration Syntax
C# Visual Basic Visual C++
public int LinkID { get; set; }
Public Property LinkID As Integer
    Get
    Set
public:
property int LinkID {
    int get ();
    void set (int value);
}


LinkType Property

LinkType Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkType ► LinkType
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderLinkCodeType LinkType { get; set; }
Public Property LinkType As StoreCustomListingHeaderLinkCodeType
    Get
    Set
public:
property StoreCustomListingHeaderLinkCodeType LinkType {
    StoreCustomListingHeaderLinkCodeType get ();
    void set (StoreCustomListingHeaderLinkCodeType value);
}


LinkTypeSpecified Property

LinkTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkType ► LinkTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LinkTypeSpecified { get; set; }
Public Property LinkTypeSpecified As Boolean
    Get
    Set
public:
property bool LinkTypeSpecified {
    bool get ();
    void set (bool value);
}


Order Property

Order Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkType ► Order
Declaration Syntax
C# Visual Basic Visual C++
public int Order { get; set; }
Public Property Order As Integer
    Get
    Set
public:
property int Order {
    int get ();
    void set (int value);
}


StoreCustomListingHeaderLinkType Constructor

StoreCustomListingHeaderLinkType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkType ► StoreCustomListingHeaderLinkType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderLinkType()
Public Sub New
public:
StoreCustomListingHeaderLinkType()


StoreCustomListingHeaderLinkTypeCollection Class

StoreCustomListingHeaderLinkTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class StoreCustomListingHeaderLinkTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class StoreCustomListingHeaderLinkTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class StoreCustomListingHeaderLinkTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreCustomListingHeaderLinkTypeCollection()()()() |
 | StoreCustomListingHeaderLinkTypeCollection(array<StoreCustomListingHeaderLinkType>[]()[][]) |
 | StoreCustomListingHeaderLinkTypeCollection(StoreCustomListingHeaderLinkTypeCollection) |
 | Add(StoreCustomListingHeaderLinkType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<StoreCustomListingHeaderLinkType>[]()[][]) |
 | AddRange(StoreCustomListingHeaderLinkTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(StoreCustomListingHeaderLinkType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<StoreCustomListingHeaderLinkType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(StoreCustomListingHeaderLinkType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, StoreCustomListingHeaderLinkType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(StoreCustomListingHeaderLinkType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | StoreCustomListingHeaderLinkTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► Add(StoreCustomListingHeaderLinkType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    StoreCustomListingHeaderLinkType item
)
Public Function Add ( _
    item As StoreCustomListingHeaderLinkType _
) As Integer
public:
int Add(
    StoreCustomListingHeaderLinkType^ item
)
Parameters
item (StoreCustomListingHeaderLinkType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<StoreCustomListingHeaderLinkType>[]()[][]) |
 | AddRange(StoreCustomListingHeaderLinkTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► AddRange(array<StoreCustomListingHeaderLinkType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreCustomListingHeaderLinkType[] items
)
Public Sub AddRange ( _
    items As StoreCustomListingHeaderLinkType() _
)
public:
void AddRange(
    array<StoreCustomListingHeaderLinkType^>^ items
)
Parameters
items (array< StoreCustomListingHeaderLinkType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► AddRange(StoreCustomListingHeaderLinkTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreCustomListingHeaderLinkTypeCollection items
)
Public Sub AddRange ( _
    items As StoreCustomListingHeaderLinkTypeCollection _
)
public:
void AddRange(
    StoreCustomListingHeaderLinkTypeCollection^ items
)
Parameters
items (StoreCustomListingHeaderLinkTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► Contains(StoreCustomListingHeaderLinkType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    StoreCustomListingHeaderLinkType item
)
Public Function Contains ( _
    item As StoreCustomListingHeaderLinkType _
) As Boolean
public:
bool Contains(
    StoreCustomListingHeaderLinkType^ item
)
Parameters
item (StoreCustomListingHeaderLinkType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► CopyTo(array<StoreCustomListingHeaderLinkType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    StoreCustomListingHeaderLinkType[] items,
    int index
)
Public Sub CopyTo ( _
    items As StoreCustomListingHeaderLinkType(), _
    index As Integer _
)
public:
void CopyTo(
    array<StoreCustomListingHeaderLinkType^>^ items,
    int index
)
Parameters
items (array< StoreCustomListingHeaderLinkType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► IndexOf(StoreCustomListingHeaderLinkType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    StoreCustomListingHeaderLinkType item
)
Public Function IndexOf ( _
    item As StoreCustomListingHeaderLinkType _
) As Integer
public:
int IndexOf(
    StoreCustomListingHeaderLinkType^ item
)
Parameters
item (StoreCustomListingHeaderLinkType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► Insert(Int32, StoreCustomListingHeaderLinkType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    StoreCustomListingHeaderLinkType item
)
Public Sub Insert ( _
    index As Integer, _
    item As StoreCustomListingHeaderLinkType _
)
public:
void Insert(
    int index,
    StoreCustomListingHeaderLinkType^ item
)
Parameters
index (Int32)
item (StoreCustomListingHeaderLinkType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderLinkType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As StoreCustomListingHeaderLinkType
    Get
    Set
public:
property StoreCustomListingHeaderLinkType^ default[int index] {
    StoreCustomListingHeaderLinkType^ get (int index);
    void set (int index, StoreCustomListingHeaderLinkType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderLinkType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As StoreCustomListingHeaderLinkType
public:
StoreCustomListingHeaderLinkType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► Remove(StoreCustomListingHeaderLinkType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    StoreCustomListingHeaderLinkType item
)
Public Sub Remove ( _
    item As StoreCustomListingHeaderLinkType _
)
public:
void Remove(
    StoreCustomListingHeaderLinkType^ item
)
Parameters
item (StoreCustomListingHeaderLinkType)


StoreCustomListingHeaderLinkTypeCollection Constructor

StoreCustomListingHeaderLinkTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► StoreCustomListingHeaderLinkTypeCollection()()()()
Members
Icon | Member | Description
 | StoreCustomListingHeaderLinkTypeCollection()()()() |
 | StoreCustomListingHeaderLinkTypeCollection(array<StoreCustomListingHeaderLinkType>[]()[][]) |
 | StoreCustomListingHeaderLinkTypeCollection(StoreCustomListingHeaderLinkTypeCollection) |


StoreCustomListingHeaderLinkTypeCollection Constructor

StoreCustomListingHeaderLinkTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► StoreCustomListingHeaderLinkTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderLinkTypeCollection()
Public Sub New
public:
StoreCustomListingHeaderLinkTypeCollection()


StoreCustomListingHeaderLinkTypeCollection Constructor (items)

StoreCustomListingHeaderLinkTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► StoreCustomListingHeaderLinkTypeCollection(array<StoreCustomListingHeaderLinkType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderLinkTypeCollection(
    StoreCustomListingHeaderLinkType[] items
)
Public Sub New ( _
    items As StoreCustomListingHeaderLinkType() _
)
public:
StoreCustomListingHeaderLinkTypeCollection(
    array<StoreCustomListingHeaderLinkType^>^ items
)
Parameters
items (array< StoreCustomListingHeaderLinkType >[]()[][])


StoreCustomListingHeaderLinkTypeCollection Constructor (items)

StoreCustomListingHeaderLinkTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► StoreCustomListingHeaderLinkTypeCollection(StoreCustomListingHeaderLinkTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderLinkTypeCollection(
    StoreCustomListingHeaderLinkTypeCollection items
)
Public Sub New ( _
    items As StoreCustomListingHeaderLinkTypeCollection _
)
public:
StoreCustomListingHeaderLinkTypeCollection(
    StoreCustomListingHeaderLinkTypeCollection^ items
)
Parameters
items (StoreCustomListingHeaderLinkTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderLinkType[] ToArray()
Public Function ToArray As StoreCustomListingHeaderLinkType()
public:
array<StoreCustomListingHeaderLinkType^>^ ToArray()
Return Value


StoreCustomListingHeaderType Class

StoreCustomListingHeaderType Class
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreCustomListingHeaderType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreCustomListingHeaderType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreCustomListingHeaderType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreCustomListingHeaderType()()()() |
 | AddToFavoriteStores |
 | AddToFavoriteStoresSpecified |
 | Any |
 | DisplayType |
 | DisplayTypeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LinkToInclude |
 | Logo |
 | LogoSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SearchBox |
 | SearchBoxSpecified |
 | SignUpForStoreNewsletter |
 | SignUpForStoreNewsletterSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreCustomListingHeaderType


AddToFavoriteStores Property

AddToFavoriteStores Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► AddToFavoriteStores
Declaration Syntax
C# Visual Basic Visual C++
public bool AddToFavoriteStores { get; set; }
Public Property AddToFavoriteStores As Boolean
    Get
    Set
public:
property bool AddToFavoriteStores {
    bool get ();
    void set (bool value);
}


AddToFavoriteStoresSpecified Property

AddToFavoriteStoresSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► AddToFavoriteStoresSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AddToFavoriteStoresSpecified { get; set; }
Public Property AddToFavoriteStoresSpecified As Boolean
    Get
    Set
public:
property bool AddToFavoriteStoresSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DisplayType Property

DisplayType Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► DisplayType
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderDisplayCodeType DisplayType { get; set; }
Public Property DisplayType As StoreCustomListingHeaderDisplayCodeType
    Get
    Set
public:
property StoreCustomListingHeaderDisplayCodeType DisplayType {
    StoreCustomListingHeaderDisplayCodeType get ();
    void set (StoreCustomListingHeaderDisplayCodeType value);
}


DisplayTypeSpecified Property

DisplayTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► DisplayTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayTypeSpecified { get; set; }
Public Property DisplayTypeSpecified As Boolean
    Get
    Set
public:
property bool DisplayTypeSpecified {
    bool get ();
    void set (bool value);
}


LinkToInclude Property

LinkToInclude Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► LinkToInclude
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderLinkTypeCollection LinkToInclude { get; set; }
Public Property LinkToInclude As StoreCustomListingHeaderLinkTypeCollection
    Get
    Set
public:
property StoreCustomListingHeaderLinkTypeCollection^ LinkToInclude {
    StoreCustomListingHeaderLinkTypeCollection^ get ();
    void set (StoreCustomListingHeaderLinkTypeCollection^ value);
}


Logo Property

Logo Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► Logo
Declaration Syntax
C# Visual Basic Visual C++
public bool Logo { get; set; }
Public Property Logo As Boolean
    Get
    Set
public:
property bool Logo {
    bool get ();
    void set (bool value);
}


LogoSpecified Property

LogoSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► LogoSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LogoSpecified { get; set; }
Public Property LogoSpecified As Boolean
    Get
    Set
public:
property bool LogoSpecified {
    bool get ();
    void set (bool value);
}


SearchBox Property

SearchBox Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► SearchBox
Declaration Syntax
C# Visual Basic Visual C++
public bool SearchBox { get; set; }
Public Property SearchBox As Boolean
    Get
    Set
public:
property bool SearchBox {
    bool get ();
    void set (bool value);
}


SearchBoxSpecified Property

SearchBoxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► SearchBoxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SearchBoxSpecified { get; set; }
Public Property SearchBoxSpecified As Boolean
    Get
    Set
public:
property bool SearchBoxSpecified {
    bool get ();
    void set (bool value);
}


SignUpForStoreNewsletter Property

SignUpForStoreNewsletter Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► SignUpForStoreNewsletter
Declaration Syntax
C# Visual Basic Visual C++
public bool SignUpForStoreNewsletter { get; set; }
Public Property SignUpForStoreNewsletter As Boolean
    Get
    Set
public:
property bool SignUpForStoreNewsletter {
    bool get ();
    void set (bool value);
}


SignUpForStoreNewsletterSpecified Property

SignUpForStoreNewsletterSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► SignUpForStoreNewsletterSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SignUpForStoreNewsletterSpecified { get; set; }
Public Property SignUpForStoreNewsletterSpecified As Boolean
    Get
    Set
public:
property bool SignUpForStoreNewsletterSpecified {
    bool get ();
    void set (bool value);
}


StoreCustomListingHeaderType Constructor

StoreCustomListingHeaderType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderType ► StoreCustomListingHeaderType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderType()
Public Sub New
public:
StoreCustomListingHeaderType()


StoreCustomPageStatusCodeType Enumeration

StoreCustomPageStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StoreCustomPageStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StoreCustomPageStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StoreCustomPageStatusCodeType
Members
Member | Description
Active |
Delete |
Inactive |
CustomCode |
Remarks


StoreCustomPageType Class

StoreCustomPageType Class
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreCustomPageType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreCustomPageType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreCustomPageType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreCustomPageType()()()() |
 | Any |
 | Content |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LeftNav |
 | LeftNavSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | Order |
 | OrderSpecified |
 | PageID |
 | PageIDSpecified |
 | PreviewEnabled |
 | PreviewEnabledSpecified |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
 | URL |
 | URLPath |
Remarks
Inheritance Hierarchy
Object
StoreCustomPageType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Content Property

Content Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► Content
Declaration Syntax
C# Visual Basic Visual C++
public string Content { get; set; }
Public Property Content As String
    Get
    Set
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}


LeftNav Property

LeftNav Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► LeftNav
Declaration Syntax
C# Visual Basic Visual C++
public bool LeftNav { get; set; }
Public Property LeftNav As Boolean
    Get
    Set
public:
property bool LeftNav {
    bool get ();
    void set (bool value);
}


LeftNavSpecified Property

LeftNavSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► LeftNavSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LeftNavSpecified { get; set; }
Public Property LeftNavSpecified As Boolean
    Get
    Set
public:
property bool LeftNavSpecified {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Order Property

Order Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► Order
Declaration Syntax
C# Visual Basic Visual C++
public int Order { get; set; }
Public Property Order As Integer
    Get
    Set
public:
property int Order {
    int get ();
    void set (int value);
}


OrderSpecified Property

OrderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► OrderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OrderSpecified { get; set; }
Public Property OrderSpecified As Boolean
    Get
    Set
public:
property bool OrderSpecified {
    bool get ();
    void set (bool value);
}


PageID Property

PageID Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► PageID
Declaration Syntax
C# Visual Basic Visual C++
public long PageID { get; set; }
Public Property PageID As Long
    Get
    Set
public:
property long long PageID {
    long long get ();
    void set (long long value);
}


PageIDSpecified Property

PageIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► PageIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PageIDSpecified { get; set; }
Public Property PageIDSpecified As Boolean
    Get
    Set
public:
property bool PageIDSpecified {
    bool get ();
    void set (bool value);
}


PreviewEnabled Property

PreviewEnabled Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► PreviewEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool PreviewEnabled { get; set; }
Public Property PreviewEnabled As Boolean
    Get
    Set
public:
property bool PreviewEnabled {
    bool get ();
    void set (bool value);
}


PreviewEnabledSpecified Property

PreviewEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► PreviewEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PreviewEnabledSpecified { get; set; }
Public Property PreviewEnabledSpecified As Boolean
    Get
    Set
public:
property bool PreviewEnabledSpecified {
    bool get ();
    void set (bool value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageStatusCodeType Status { get; set; }
Public Property Status As StoreCustomPageStatusCodeType
    Get
    Set
public:
property StoreCustomPageStatusCodeType Status {
    StoreCustomPageStatusCodeType get ();
    void set (StoreCustomPageStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


StoreCustomPageType Constructor

StoreCustomPageType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► StoreCustomPageType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageType()
Public Sub New
public:
StoreCustomPageType()


URL Property

URL Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► URL
Declaration Syntax
C# Visual Basic Visual C++
public string URL { get; set; }
Public Property URL As String
    Get
    Set
public:
property String^ URL {
    String^ get ();
    void set (String^ value);
}


URLPath Property

URLPath Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageType ► URLPath
Declaration Syntax
C# Visual Basic Visual C++
public string URLPath { get; set; }
Public Property URLPath As String
    Get
    Set
public:
property String^ URLPath {
    String^ get ();
    void set (String^ value);
}


StoreCustomPageTypeCollection Class

StoreCustomPageTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class StoreCustomPageTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class StoreCustomPageTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class StoreCustomPageTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreCustomPageTypeCollection()()()() |
 | StoreCustomPageTypeCollection(array<StoreCustomPageType>[]()[][]) |
 | StoreCustomPageTypeCollection(StoreCustomPageTypeCollection) |
 | Add(StoreCustomPageType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<StoreCustomPageType>[]()[][]) |
 | AddRange(StoreCustomPageTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(StoreCustomPageType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<StoreCustomPageType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(StoreCustomPageType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, StoreCustomPageType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(StoreCustomPageType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | StoreCustomPageTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► Add(StoreCustomPageType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    StoreCustomPageType item
)
Public Function Add ( _
    item As StoreCustomPageType _
) As Integer
public:
int Add(
    StoreCustomPageType^ item
)
Parameters
item (StoreCustomPageType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<StoreCustomPageType>[]()[][]) |
 | AddRange(StoreCustomPageTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► AddRange(array<StoreCustomPageType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreCustomPageType[] items
)
Public Sub AddRange ( _
    items As StoreCustomPageType() _
)
public:
void AddRange(
    array<StoreCustomPageType^>^ items
)
Parameters
items (array< StoreCustomPageType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► AddRange(StoreCustomPageTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreCustomPageTypeCollection items
)
Public Sub AddRange ( _
    items As StoreCustomPageTypeCollection _
)
public:
void AddRange(
    StoreCustomPageTypeCollection^ items
)
Parameters
items (StoreCustomPageTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► Contains(StoreCustomPageType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    StoreCustomPageType item
)
Public Function Contains ( _
    item As StoreCustomPageType _
) As Boolean
public:
bool Contains(
    StoreCustomPageType^ item
)
Parameters
item (StoreCustomPageType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► CopyTo(array<StoreCustomPageType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    StoreCustomPageType[] items,
    int index
)
Public Sub CopyTo ( _
    items As StoreCustomPageType(), _
    index As Integer _
)
public:
void CopyTo(
    array<StoreCustomPageType^>^ items,
    int index
)
Parameters
items (array< StoreCustomPageType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► IndexOf(StoreCustomPageType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    StoreCustomPageType item
)
Public Function IndexOf ( _
    item As StoreCustomPageType _
) As Integer
public:
int IndexOf(
    StoreCustomPageType^ item
)
Parameters
item (StoreCustomPageType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► Insert(Int32, StoreCustomPageType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    StoreCustomPageType item
)
Public Sub Insert ( _
    index As Integer, _
    item As StoreCustomPageType _
)
public:
void Insert(
    int index,
    StoreCustomPageType^ item
)
Parameters
index (Int32)
item (StoreCustomPageType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As StoreCustomPageType
    Get
    Set
public:
property StoreCustomPageType^ default[int index] {
    StoreCustomPageType^ get (int index);
    void set (int index, StoreCustomPageType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As StoreCustomPageType
public:
StoreCustomPageType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► Remove(StoreCustomPageType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    StoreCustomPageType item
)
Public Sub Remove ( _
    item As StoreCustomPageType _
)
public:
void Remove(
    StoreCustomPageType^ item
)
Parameters
item (StoreCustomPageType)


StoreCustomPageTypeCollection Constructor

StoreCustomPageTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► StoreCustomPageTypeCollection()()()()
Members
Icon | Member | Description
 | StoreCustomPageTypeCollection()()()() |
 | StoreCustomPageTypeCollection(array<StoreCustomPageType>[]()[][]) |
 | StoreCustomPageTypeCollection(StoreCustomPageTypeCollection) |


StoreCustomPageTypeCollection Constructor

StoreCustomPageTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► StoreCustomPageTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageTypeCollection()
Public Sub New
public:
StoreCustomPageTypeCollection()


StoreCustomPageTypeCollection Constructor (items)

StoreCustomPageTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► StoreCustomPageTypeCollection(array<StoreCustomPageType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageTypeCollection(
    StoreCustomPageType[] items
)
Public Sub New ( _
    items As StoreCustomPageType() _
)
public:
StoreCustomPageTypeCollection(
    array<StoreCustomPageType^>^ items
)
Parameters
items (array< StoreCustomPageType >[]()[][])


StoreCustomPageTypeCollection Constructor (items)

StoreCustomPageTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► StoreCustomPageTypeCollection(StoreCustomPageTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageTypeCollection(
    StoreCustomPageTypeCollection items
)
Public Sub New ( _
    items As StoreCustomPageTypeCollection _
)
public:
StoreCustomPageTypeCollection(
    StoreCustomPageTypeCollection^ items
)
Parameters
items (StoreCustomPageTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomPageType[] ToArray()
Public Function ToArray As StoreCustomPageType()
public:
array<StoreCustomPageType^>^ ToArray()
Return Value


StoreFontFaceCodeType Enumeration

StoreFontFaceCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StoreFontFaceCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StoreFontFaceCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StoreFontFaceCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StoreFontFaceCodeType
Members
Member | Description
Arial |
Courier |
Times |
Verdana |
CustomCode |
Remarks


StoreFontSizeCodeType Enumeration

StoreFontSizeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StoreFontSizeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StoreFontSizeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StoreFontSizeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StoreFontSizeCodeType
Members
Member | Description
XXS |
XS |
S |
M |
L |
XL |
XXL |
CustomCode |
Remarks


StoreFontType Class

StoreFontType Class
Namespaces ► eBay.Service.Core.Soap ► StoreFontType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreFontType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreFontType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreFontType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreFontType()()()() |
 | Any |
 | DescColor |
 | DescFace |
 | DescFaceSpecified |
 | DescSize |
 | DescSizeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NameColor |
 | NameFace |
 | NameFaceSpecified |
 | NameSize |
 | NameSizeSpecified |
 | TitleColor |
 | TitleFace |
 | TitleFaceSpecified |
 | TitleSize |
 | TitleSizeSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreFontType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DescColor Property

DescColor Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► DescColor
Declaration Syntax
C# Visual Basic Visual C++
public string DescColor { get; set; }
Public Property DescColor As String
    Get
    Set
public:
property String^ DescColor {
    String^ get ();
    void set (String^ value);
}


DescFace Property

DescFace Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► DescFace
Declaration Syntax
C# Visual Basic Visual C++
public StoreFontFaceCodeType DescFace { get; set; }
Public Property DescFace As StoreFontFaceCodeType
    Get
    Set
public:
property StoreFontFaceCodeType DescFace {
    StoreFontFaceCodeType get ();
    void set (StoreFontFaceCodeType value);
}


DescFaceSpecified Property

DescFaceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► DescFaceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DescFaceSpecified { get; set; }
Public Property DescFaceSpecified As Boolean
    Get
    Set
public:
property bool DescFaceSpecified {
    bool get ();
    void set (bool value);
}


DescSize Property

DescSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► DescSize
Declaration Syntax
C# Visual Basic Visual C++
public StoreFontSizeCodeType DescSize { get; set; }
Public Property DescSize As StoreFontSizeCodeType
    Get
    Set
public:
property StoreFontSizeCodeType DescSize {
    StoreFontSizeCodeType get ();
    void set (StoreFontSizeCodeType value);
}


DescSizeSpecified Property

DescSizeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► DescSizeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DescSizeSpecified { get; set; }
Public Property DescSizeSpecified As Boolean
    Get
    Set
public:
property bool DescSizeSpecified {
    bool get ();
    void set (bool value);
}


NameColor Property

NameColor Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► NameColor
Declaration Syntax
C# Visual Basic Visual C++
public string NameColor { get; set; }
Public Property NameColor As String
    Get
    Set
public:
property String^ NameColor {
    String^ get ();
    void set (String^ value);
}


NameFace Property

NameFace Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► NameFace
Declaration Syntax
C# Visual Basic Visual C++
public StoreFontFaceCodeType NameFace { get; set; }
Public Property NameFace As StoreFontFaceCodeType
    Get
    Set
public:
property StoreFontFaceCodeType NameFace {
    StoreFontFaceCodeType get ();
    void set (StoreFontFaceCodeType value);
}


NameFaceSpecified Property

NameFaceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► NameFaceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NameFaceSpecified { get; set; }
Public Property NameFaceSpecified As Boolean
    Get
    Set
public:
property bool NameFaceSpecified {
    bool get ();
    void set (bool value);
}


NameSize Property

NameSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► NameSize
Declaration Syntax
C# Visual Basic Visual C++
public StoreFontSizeCodeType NameSize { get; set; }
Public Property NameSize As StoreFontSizeCodeType
    Get
    Set
public:
property StoreFontSizeCodeType NameSize {
    StoreFontSizeCodeType get ();
    void set (StoreFontSizeCodeType value);
}


NameSizeSpecified Property

NameSizeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► NameSizeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NameSizeSpecified { get; set; }
Public Property NameSizeSpecified As Boolean
    Get
    Set
public:
property bool NameSizeSpecified {
    bool get ();
    void set (bool value);
}


StoreFontType Constructor

StoreFontType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► StoreFontType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreFontType()
Public Sub New
public:
StoreFontType()


TitleColor Property

TitleColor Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► TitleColor
Declaration Syntax
C# Visual Basic Visual C++
public string TitleColor { get; set; }
Public Property TitleColor As String
    Get
    Set
public:
property String^ TitleColor {
    String^ get ();
    void set (String^ value);
}


TitleFace Property

TitleFace Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► TitleFace
Declaration Syntax
C# Visual Basic Visual C++
public StoreFontFaceCodeType TitleFace { get; set; }
Public Property TitleFace As StoreFontFaceCodeType
    Get
    Set
public:
property StoreFontFaceCodeType TitleFace {
    StoreFontFaceCodeType get ();
    void set (StoreFontFaceCodeType value);
}


TitleFaceSpecified Property

TitleFaceSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► TitleFaceSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TitleFaceSpecified { get; set; }
Public Property TitleFaceSpecified As Boolean
    Get
    Set
public:
property bool TitleFaceSpecified {
    bool get ();
    void set (bool value);
}


TitleSize Property

TitleSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► TitleSize
Declaration Syntax
C# Visual Basic Visual C++
public StoreFontSizeCodeType TitleSize { get; set; }
Public Property TitleSize As StoreFontSizeCodeType
    Get
    Set
public:
property StoreFontSizeCodeType TitleSize {
    StoreFontSizeCodeType get ();
    void set (StoreFontSizeCodeType value);
}


TitleSizeSpecified Property

TitleSizeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreFontType ► TitleSizeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TitleSizeSpecified { get; set; }
Public Property TitleSizeSpecified As Boolean
    Get
    Set
public:
property bool TitleSizeSpecified {
    bool get ();
    void set (bool value);
}


StorefrontType Class

StorefrontType Class
Namespaces ► eBay.Service.Core.Soap ► StorefrontType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StorefrontType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StorefrontType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StorefrontType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StorefrontType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | StoreCategory2ID |
 | StoreCategory2Name |
 | StoreCategoryID |
 | StoreCategoryName |
 | StoreName |
 | StoreURL |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StorefrontType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StorefrontType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


StoreCategory2ID Property

StoreCategory2ID Property
Namespaces ► eBay.Service.Core.Soap ► StorefrontType ► StoreCategory2ID
Declaration Syntax
C# Visual Basic Visual C++
public long StoreCategory2ID { get; set; }
Public Property StoreCategory2ID As Long
    Get
    Set
public:
property long long StoreCategory2ID {
    long long get ();
    void set (long long value);
}


StoreCategory2Name Property

StoreCategory2Name Property
Namespaces ► eBay.Service.Core.Soap ► StorefrontType ► StoreCategory2Name
Declaration Syntax
C# Visual Basic Visual C++
public string StoreCategory2Name { get; set; }
Public Property StoreCategory2Name As String
    Get
    Set
public:
property String^ StoreCategory2Name {
    String^ get ();
    void set (String^ value);
}


StoreCategoryID Property

StoreCategoryID Property
Namespaces ► eBay.Service.Core.Soap ► StorefrontType ► StoreCategoryID
Declaration Syntax
C# Visual Basic Visual C++
public long StoreCategoryID { get; set; }
Public Property StoreCategoryID As Long
    Get
    Set
public:
property long long StoreCategoryID {
    long long get ();
    void set (long long value);
}


StoreCategoryName Property

StoreCategoryName Property
Namespaces ► eBay.Service.Core.Soap ► StorefrontType ► StoreCategoryName
Declaration Syntax
C# Visual Basic Visual C++
public string StoreCategoryName { get; set; }
Public Property StoreCategoryName As String
    Get
    Set
public:
property String^ StoreCategoryName {
    String^ get ();
    void set (String^ value);
}


StorefrontType Constructor

StorefrontType Constructor
Namespaces ► eBay.Service.Core.Soap ► StorefrontType ► StorefrontType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StorefrontType()
Public Sub New
public:
StorefrontType()


StoreName Property

StoreName Property
Namespaces ► eBay.Service.Core.Soap ► StorefrontType ► StoreName
Declaration Syntax
C# Visual Basic Visual C++
public string StoreName { get; set; }
Public Property StoreName As String
    Get
    Set
public:
property String^ StoreName {
    String^ get ();
    void set (String^ value);
}


StoreURL Property

StoreURL Property
Namespaces ► eBay.Service.Core.Soap ► StorefrontType ► StoreURL
Declaration Syntax
C# Visual Basic Visual C++
public string StoreURL { get; set; }
Public Property StoreURL As String
    Get
    Set
public:
property String^ StoreURL {
    String^ get ();
    void set (String^ value);
}


StoreHeaderStyleCodeType Enumeration

StoreHeaderStyleCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StoreHeaderStyleCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StoreHeaderStyleCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StoreHeaderStyleCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StoreHeaderStyleCodeType
Members
Member | Description
Full |
Minimized |
CustomCode |
Remarks


StoreInventoryEnabledDefinitionType Class

StoreInventoryEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► StoreInventoryEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreInventoryEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreInventoryEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreInventoryEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreInventoryEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreInventoryEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreInventoryEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


StoreInventoryEnabledDefinitionType Constructor

StoreInventoryEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreInventoryEnabledDefinitionType ► StoreInventoryEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreInventoryEnabledDefinitionType()
Public Sub New
public:
StoreInventoryEnabledDefinitionType()


StoreItemListLayoutCodeType Enumeration

StoreItemListLayoutCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StoreItemListLayoutCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StoreItemListLayoutCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StoreItemListLayoutCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StoreItemListLayoutCodeType
Members
Member | Description
ListView |
GalleryView |
CustomCode |
Remarks


StoreItemListSortOrderCodeType Enumeration

StoreItemListSortOrderCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StoreItemListSortOrderCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StoreItemListSortOrderCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StoreItemListSortOrderCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StoreItemListSortOrderCodeType
Members
Member | Description
EndingFirst |
NewlyListed |
LowestPriced |
HighestPriced |
LowestPricedPlusShipping |
HighestPricedPlusShipping |
CustomCode |
Remarks


StoreLogoType Class

StoreLogoType Class
Namespaces ► eBay.Service.Core.Soap ► StoreLogoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreLogoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreLogoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreLogoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreLogoType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LogoID |
 | LogoIDSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
 | URL |
Remarks
Inheritance Hierarchy
Object
StoreLogoType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


LogoID Property

LogoID Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoType ► LogoID
Declaration Syntax
C# Visual Basic Visual C++
public int LogoID { get; set; }
Public Property LogoID As Integer
    Get
    Set
public:
property int LogoID {
    int get ();
    void set (int value);
}


LogoIDSpecified Property

LogoIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoType ► LogoIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LogoIDSpecified { get; set; }
Public Property LogoIDSpecified As Boolean
    Get
    Set
public:
property bool LogoIDSpecified {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


StoreLogoType Constructor

StoreLogoType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreLogoType ► StoreLogoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreLogoType()
Public Sub New
public:
StoreLogoType()


URL Property

URL Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoType ► URL
Declaration Syntax
C# Visual Basic Visual C++
public string URL { get; set; }
Public Property URL As String
    Get
    Set
public:
property String^ URL {
    String^ get ();
    void set (String^ value);
}


StoreLogoTypeCollection Class

StoreLogoTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class StoreLogoTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class StoreLogoTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class StoreLogoTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreLogoTypeCollection()()()() |
 | StoreLogoTypeCollection(array<StoreLogoType>[]()[][]) |
 | StoreLogoTypeCollection(StoreLogoTypeCollection) |
 | Add(StoreLogoType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<StoreLogoType>[]()[][]) |
 | AddRange(StoreLogoTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(StoreLogoType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<StoreLogoType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(StoreLogoType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, StoreLogoType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(StoreLogoType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | StoreLogoTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► Add(StoreLogoType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    StoreLogoType item
)
Public Function Add ( _
    item As StoreLogoType _
) As Integer
public:
int Add(
    StoreLogoType^ item
)
Parameters
item (StoreLogoType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<StoreLogoType>[]()[][]) |
 | AddRange(StoreLogoTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► AddRange(array<StoreLogoType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreLogoType[] items
)
Public Sub AddRange ( _
    items As StoreLogoType() _
)
public:
void AddRange(
    array<StoreLogoType^>^ items
)
Parameters
items (array< StoreLogoType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► AddRange(StoreLogoTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreLogoTypeCollection items
)
Public Sub AddRange ( _
    items As StoreLogoTypeCollection _
)
public:
void AddRange(
    StoreLogoTypeCollection^ items
)
Parameters
items (StoreLogoTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► Contains(StoreLogoType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    StoreLogoType item
)
Public Function Contains ( _
    item As StoreLogoType _
) As Boolean
public:
bool Contains(
    StoreLogoType^ item
)
Parameters
item (StoreLogoType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► CopyTo(array<StoreLogoType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    StoreLogoType[] items,
    int index
)
Public Sub CopyTo ( _
    items As StoreLogoType(), _
    index As Integer _
)
public:
void CopyTo(
    array<StoreLogoType^>^ items,
    int index
)
Parameters
items (array< StoreLogoType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► IndexOf(StoreLogoType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    StoreLogoType item
)
Public Function IndexOf ( _
    item As StoreLogoType _
) As Integer
public:
int IndexOf(
    StoreLogoType^ item
)
Parameters
item (StoreLogoType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► Insert(Int32, StoreLogoType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    StoreLogoType item
)
Public Sub Insert ( _
    index As Integer, _
    item As StoreLogoType _
)
public:
void Insert(
    int index,
    StoreLogoType^ item
)
Parameters
index (Int32)
item (StoreLogoType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public StoreLogoType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As StoreLogoType
    Get
    Set
public:
property StoreLogoType^ default[int index] {
    StoreLogoType^ get (int index);
    void set (int index, StoreLogoType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public StoreLogoType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As StoreLogoType
public:
StoreLogoType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► Remove(StoreLogoType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    StoreLogoType item
)
Public Sub Remove ( _
    item As StoreLogoType _
)
public:
void Remove(
    StoreLogoType^ item
)
Parameters
item (StoreLogoType)


StoreLogoTypeCollection Constructor

StoreLogoTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► StoreLogoTypeCollection()()()()
Members
Icon | Member | Description
 | StoreLogoTypeCollection()()()() |
 | StoreLogoTypeCollection(array<StoreLogoType>[]()[][]) |
 | StoreLogoTypeCollection(StoreLogoTypeCollection) |


StoreLogoTypeCollection Constructor

StoreLogoTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► StoreLogoTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreLogoTypeCollection()
Public Sub New
public:
StoreLogoTypeCollection()


StoreLogoTypeCollection Constructor (items)

StoreLogoTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► StoreLogoTypeCollection(array<StoreLogoType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public StoreLogoTypeCollection(
    StoreLogoType[] items
)
Public Sub New ( _
    items As StoreLogoType() _
)
public:
StoreLogoTypeCollection(
    array<StoreLogoType^>^ items
)
Parameters
items (array< StoreLogoType >[]()[][])


StoreLogoTypeCollection Constructor (items)

StoreLogoTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► StoreLogoTypeCollection(StoreLogoTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public StoreLogoTypeCollection(
    StoreLogoTypeCollection items
)
Public Sub New ( _
    items As StoreLogoTypeCollection _
)
public:
StoreLogoTypeCollection(
    StoreLogoTypeCollection^ items
)
Parameters
items (StoreLogoTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreLogoType[] ToArray()
Public Function ToArray As StoreLogoType()
public:
array<StoreLogoType^>^ ToArray()
Return Value


StoreOwnerExtendedListingDurationsDefinitionType Class

StoreOwnerExtendedListingDurationsDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► StoreOwnerExtendedListingDurationsDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreOwnerExtendedListingDurationsDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreOwnerExtendedListingDurationsDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreOwnerExtendedListingDurationsDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreOwnerExtendedListingDurationsDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreOwnerExtendedListingDurationsDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreOwnerExtendedListingDurationsDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


StoreOwnerExtendedListingDurationsDefinitionType Constructor

StoreOwnerExtendedListingDurationsDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreOwnerExtendedListingDurationsDefinitionType ► StoreOwnerExtendedListingDurationsDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreOwnerExtendedListingDurationsDefinitionType()
Public Sub New
public:
StoreOwnerExtendedListingDurationsDefinitionType()


StoreOwnerExtendedListingDurationsEnabledDefinitionType Class

StoreOwnerExtendedListingDurationsEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► StoreOwnerExtendedListingDurationsEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreOwnerExtendedListingDurationsEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreOwnerExtendedListingDurationsEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreOwnerExtendedListingDurationsEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreOwnerExtendedListingDurationsEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreOwnerExtendedListingDurationsEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreOwnerExtendedListingDurationsEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


StoreOwnerExtendedListingDurationsEnabledDefinitionType Constructor

StoreOwnerExtendedListingDurationsEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreOwnerExtendedListingDurationsEnabledDefinitionType ► StoreOwnerExtendedListingDurationsEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreOwnerExtendedListingDurationsEnabledDefinitionType()
Public Sub New
public:
StoreOwnerExtendedListingDurationsEnabledDefinitionType()


StoreOwnerExtendedListingDurationsType Class

StoreOwnerExtendedListingDurationsType Class
Namespaces ► eBay.Service.Core.Soap ► StoreOwnerExtendedListingDurationsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreOwnerExtendedListingDurationsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreOwnerExtendedListingDurationsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreOwnerExtendedListingDurationsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreOwnerExtendedListingDurationsType()()()() |
 | Any |
 | Duration |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreOwnerExtendedListingDurationsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreOwnerExtendedListingDurationsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Duration Property

Duration Property
Namespaces ► eBay.Service.Core.Soap ► StoreOwnerExtendedListingDurationsType ► Duration
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection Duration { get; set; }
Public Property Duration As StringCollection
    Get
    Set
public:
property StringCollection^ Duration {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


StoreOwnerExtendedListingDurationsType Constructor

StoreOwnerExtendedListingDurationsType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreOwnerExtendedListingDurationsType ► StoreOwnerExtendedListingDurationsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreOwnerExtendedListingDurationsType()
Public Sub New
public:
StoreOwnerExtendedListingDurationsType()


StorePreferencesType Class

StorePreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► StorePreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StorePreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StorePreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StorePreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StorePreferencesType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | VacationPreferences |
Remarks
Inheritance Hierarchy
Object
StorePreferencesType


StorePreferencesType Constructor

StorePreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► StorePreferencesType ► StorePreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StorePreferencesType()
Public Sub New
public:
StorePreferencesType()


VacationPreferences Property

VacationPreferences Property
Namespaces ► eBay.Service.Core.Soap ► StorePreferencesType ► VacationPreferences
Declaration Syntax
C# Visual Basic Visual C++
public StoreVacationPreferencesType VacationPreferences { get; set; }
Public Property VacationPreferences As StoreVacationPreferencesType
    Get
    Set
public:
property StoreVacationPreferencesType^ VacationPreferences {
    StoreVacationPreferencesType^ get ();
    void set (StoreVacationPreferencesType^ value);
}


StoreSubscriptionLevelCodeType Enumeration

StoreSubscriptionLevelCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionLevelCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StoreSubscriptionLevelCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StoreSubscriptionLevelCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StoreSubscriptionLevelCodeType
Members
Member | Description
Close |
Basic |
Featured |
Anchor |
CustomCode |
Remarks


StoreSubscriptionType Class

StoreSubscriptionType Class
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreSubscriptionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreSubscriptionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreSubscriptionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreSubscriptionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Fee |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Level |
 | LevelSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreSubscriptionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Fee Property

Fee Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionType ► Fee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType Fee { get; set; }
Public Property Fee As AmountType
    Get
    Set
public:
property AmountType^ Fee {
    AmountType^ get ();
    void set (AmountType^ value);
}


Level Property

Level Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionType ► Level
Declaration Syntax
C# Visual Basic Visual C++
public StoreSubscriptionLevelCodeType Level { get; set; }
Public Property Level As StoreSubscriptionLevelCodeType
    Get
    Set
public:
property StoreSubscriptionLevelCodeType Level {
    StoreSubscriptionLevelCodeType get ();
    void set (StoreSubscriptionLevelCodeType value);
}


LevelSpecified Property

LevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionType ► LevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LevelSpecified { get; set; }
Public Property LevelSpecified As Boolean
    Get
    Set
public:
property bool LevelSpecified {
    bool get ();
    void set (bool value);
}


StoreSubscriptionType Constructor

StoreSubscriptionType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionType ► StoreSubscriptionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreSubscriptionType()
Public Sub New
public:
StoreSubscriptionType()


StoreSubscriptionTypeCollection Class

StoreSubscriptionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class StoreSubscriptionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class StoreSubscriptionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class StoreSubscriptionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreSubscriptionTypeCollection()()()() |
 | StoreSubscriptionTypeCollection(array<StoreSubscriptionType>[]()[][]) |
 | StoreSubscriptionTypeCollection(StoreSubscriptionTypeCollection) |
 | Add(StoreSubscriptionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<StoreSubscriptionType>[]()[][]) |
 | AddRange(StoreSubscriptionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(StoreSubscriptionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<StoreSubscriptionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(StoreSubscriptionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, StoreSubscriptionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(StoreSubscriptionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | StoreSubscriptionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► Add(StoreSubscriptionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    StoreSubscriptionType item
)
Public Function Add ( _
    item As StoreSubscriptionType _
) As Integer
public:
int Add(
    StoreSubscriptionType^ item
)
Parameters
item (StoreSubscriptionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<StoreSubscriptionType>[]()[][]) |
 | AddRange(StoreSubscriptionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► AddRange(array<StoreSubscriptionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreSubscriptionType[] items
)
Public Sub AddRange ( _
    items As StoreSubscriptionType() _
)
public:
void AddRange(
    array<StoreSubscriptionType^>^ items
)
Parameters
items (array< StoreSubscriptionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► AddRange(StoreSubscriptionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreSubscriptionTypeCollection items
)
Public Sub AddRange ( _
    items As StoreSubscriptionTypeCollection _
)
public:
void AddRange(
    StoreSubscriptionTypeCollection^ items
)
Parameters
items (StoreSubscriptionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► Contains(StoreSubscriptionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    StoreSubscriptionType item
)
Public Function Contains ( _
    item As StoreSubscriptionType _
) As Boolean
public:
bool Contains(
    StoreSubscriptionType^ item
)
Parameters
item (StoreSubscriptionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► CopyTo(array<StoreSubscriptionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    StoreSubscriptionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As StoreSubscriptionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<StoreSubscriptionType^>^ items,
    int index
)
Parameters
items (array< StoreSubscriptionType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► IndexOf(StoreSubscriptionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    StoreSubscriptionType item
)
Public Function IndexOf ( _
    item As StoreSubscriptionType _
) As Integer
public:
int IndexOf(
    StoreSubscriptionType^ item
)
Parameters
item (StoreSubscriptionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► Insert(Int32, StoreSubscriptionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    StoreSubscriptionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As StoreSubscriptionType _
)
public:
void Insert(
    int index,
    StoreSubscriptionType^ item
)
Parameters
index (Int32)
item (StoreSubscriptionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public StoreSubscriptionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As StoreSubscriptionType
    Get
    Set
public:
property StoreSubscriptionType^ default[int index] {
    StoreSubscriptionType^ get (int index);
    void set (int index, StoreSubscriptionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public StoreSubscriptionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As StoreSubscriptionType
public:
StoreSubscriptionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► Remove(StoreSubscriptionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    StoreSubscriptionType item
)
Public Sub Remove ( _
    item As StoreSubscriptionType _
)
public:
void Remove(
    StoreSubscriptionType^ item
)
Parameters
item (StoreSubscriptionType)


StoreSubscriptionTypeCollection Constructor

StoreSubscriptionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► StoreSubscriptionTypeCollection()()()()
Members
Icon | Member | Description
 | StoreSubscriptionTypeCollection()()()() |
 | StoreSubscriptionTypeCollection(array<StoreSubscriptionType>[]()[][]) |
 | StoreSubscriptionTypeCollection(StoreSubscriptionTypeCollection) |


StoreSubscriptionTypeCollection Constructor

StoreSubscriptionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► StoreSubscriptionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreSubscriptionTypeCollection()
Public Sub New
public:
StoreSubscriptionTypeCollection()


StoreSubscriptionTypeCollection Constructor (items)

StoreSubscriptionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► StoreSubscriptionTypeCollection(array<StoreSubscriptionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public StoreSubscriptionTypeCollection(
    StoreSubscriptionType[] items
)
Public Sub New ( _
    items As StoreSubscriptionType() _
)
public:
StoreSubscriptionTypeCollection(
    array<StoreSubscriptionType^>^ items
)
Parameters
items (array< StoreSubscriptionType >[]()[][])


StoreSubscriptionTypeCollection Constructor (items)

StoreSubscriptionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► StoreSubscriptionTypeCollection(StoreSubscriptionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public StoreSubscriptionTypeCollection(
    StoreSubscriptionTypeCollection items
)
Public Sub New ( _
    items As StoreSubscriptionTypeCollection _
)
public:
StoreSubscriptionTypeCollection(
    StoreSubscriptionTypeCollection^ items
)
Parameters
items (StoreSubscriptionTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreSubscriptionType[] ToArray()
Public Function ToArray As StoreSubscriptionType()
public:
array<StoreSubscriptionType^>^ ToArray()
Return Value


StoreThemeArrayType Class

StoreThemeArrayType Class
Namespaces ► eBay.Service.Core.Soap ► StoreThemeArrayType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreThemeArrayType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreThemeArrayType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreThemeArrayType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreThemeArrayType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GenericColorSchemeArray |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Theme |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreThemeArrayType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeArrayType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


GenericColorSchemeArray Property

GenericColorSchemeArray Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeArrayType ► GenericColorSchemeArray
Declaration Syntax
C# Visual Basic Visual C++
public StoreColorSchemeTypeCollection GenericColorSchemeArray { get; set; }
Public Property GenericColorSchemeArray As StoreColorSchemeTypeCollection
    Get
    Set
public:
property StoreColorSchemeTypeCollection^ GenericColorSchemeArray {
    StoreColorSchemeTypeCollection^ get ();
    void set (StoreColorSchemeTypeCollection^ value);
}


StoreThemeArrayType Constructor

StoreThemeArrayType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreThemeArrayType ► StoreThemeArrayType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeArrayType()
Public Sub New
public:
StoreThemeArrayType()


Theme Property

Theme Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeArrayType ► Theme
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeTypeCollection Theme { get; set; }
Public Property Theme As StoreThemeTypeCollection
    Get
    Set
public:
property StoreThemeTypeCollection^ Theme {
    StoreThemeTypeCollection^ get ();
    void set (StoreThemeTypeCollection^ value);
}


StoreThemeType Class

StoreThemeType Class
Namespaces ► eBay.Service.Core.Soap ► StoreThemeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreThemeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreThemeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreThemeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreThemeType()()()() |
 | Any |
 | ColorScheme |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ThemeID |
 | ThemeIDSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreThemeType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ColorScheme Property

ColorScheme Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeType ► ColorScheme
Declaration Syntax
C# Visual Basic Visual C++
public StoreColorSchemeType ColorScheme { get; set; }
Public Property ColorScheme As StoreColorSchemeType
    Get
    Set
public:
property StoreColorSchemeType^ ColorScheme {
    StoreColorSchemeType^ get ();
    void set (StoreColorSchemeType^ value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


StoreThemeType Constructor

StoreThemeType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreThemeType ► StoreThemeType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeType()
Public Sub New
public:
StoreThemeType()


ThemeID Property

ThemeID Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeType ► ThemeID
Declaration Syntax
C# Visual Basic Visual C++
public int ThemeID { get; set; }
Public Property ThemeID As Integer
    Get
    Set
public:
property int ThemeID {
    int get ();
    void set (int value);
}


ThemeIDSpecified Property

ThemeIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeType ► ThemeIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ThemeIDSpecified { get; set; }
Public Property ThemeIDSpecified As Boolean
    Get
    Set
public:
property bool ThemeIDSpecified {
    bool get ();
    void set (bool value);
}


StoreThemeTypeCollection Class

StoreThemeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class StoreThemeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class StoreThemeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class StoreThemeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreThemeTypeCollection()()()() |
 | StoreThemeTypeCollection(array<StoreThemeType>[]()[][]) |
 | StoreThemeTypeCollection(StoreThemeTypeCollection) |
 | Add(StoreThemeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<StoreThemeType>[]()[][]) |
 | AddRange(StoreThemeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(StoreThemeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<StoreThemeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(StoreThemeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, StoreThemeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(StoreThemeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | StoreThemeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► Add(StoreThemeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    StoreThemeType item
)
Public Function Add ( _
    item As StoreThemeType _
) As Integer
public:
int Add(
    StoreThemeType^ item
)
Parameters
item (StoreThemeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<StoreThemeType>[]()[][]) |
 | AddRange(StoreThemeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► AddRange(array<StoreThemeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreThemeType[] items
)
Public Sub AddRange ( _
    items As StoreThemeType() _
)
public:
void AddRange(
    array<StoreThemeType^>^ items
)
Parameters
items (array< StoreThemeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► AddRange(StoreThemeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StoreThemeTypeCollection items
)
Public Sub AddRange ( _
    items As StoreThemeTypeCollection _
)
public:
void AddRange(
    StoreThemeTypeCollection^ items
)
Parameters
items (StoreThemeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► Contains(StoreThemeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    StoreThemeType item
)
Public Function Contains ( _
    item As StoreThemeType _
) As Boolean
public:
bool Contains(
    StoreThemeType^ item
)
Parameters
item (StoreThemeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► CopyTo(array<StoreThemeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    StoreThemeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As StoreThemeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<StoreThemeType^>^ items,
    int index
)
Parameters
items (array< StoreThemeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► IndexOf(StoreThemeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    StoreThemeType item
)
Public Function IndexOf ( _
    item As StoreThemeType _
) As Integer
public:
int IndexOf(
    StoreThemeType^ item
)
Parameters
item (StoreThemeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► Insert(Int32, StoreThemeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    StoreThemeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As StoreThemeType _
)
public:
void Insert(
    int index,
    StoreThemeType^ item
)
Parameters
index (Int32)
item (StoreThemeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As StoreThemeType
    Get
    Set
public:
property StoreThemeType^ default[int index] {
    StoreThemeType^ get (int index);
    void set (int index, StoreThemeType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As StoreThemeType
public:
StoreThemeType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► Remove(StoreThemeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    StoreThemeType item
)
Public Sub Remove ( _
    item As StoreThemeType _
)
public:
void Remove(
    StoreThemeType^ item
)
Parameters
item (StoreThemeType)


StoreThemeTypeCollection Constructor

StoreThemeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► StoreThemeTypeCollection()()()()
Members
Icon | Member | Description
 | StoreThemeTypeCollection()()()() |
 | StoreThemeTypeCollection(array<StoreThemeType>[]()[][]) |
 | StoreThemeTypeCollection(StoreThemeTypeCollection) |


StoreThemeTypeCollection Constructor

StoreThemeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► StoreThemeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeTypeCollection()
Public Sub New
public:
StoreThemeTypeCollection()


StoreThemeTypeCollection Constructor (items)

StoreThemeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► StoreThemeTypeCollection(array<StoreThemeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeTypeCollection(
    StoreThemeType[] items
)
Public Sub New ( _
    items As StoreThemeType() _
)
public:
StoreThemeTypeCollection(
    array<StoreThemeType^>^ items
)
Parameters
items (array< StoreThemeType >[]()[][])


StoreThemeTypeCollection Constructor (items)

StoreThemeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► StoreThemeTypeCollection(StoreThemeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeTypeCollection(
    StoreThemeTypeCollection items
)
Public Sub New ( _
    items As StoreThemeTypeCollection _
)
public:
StoreThemeTypeCollection(
    StoreThemeTypeCollection^ items
)
Parameters
items (StoreThemeTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeType[] ToArray()
Public Function ToArray As StoreThemeType()
public:
array<StoreThemeType^>^ ToArray()
Return Value


StoreType Class

StoreType Class
Namespaces ► eBay.Service.Core.Soap ► StoreType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreType()()()() |
 | Any |
 | CustomCategories |
 | CustomHeader |
 | CustomHeaderLayout |
 | CustomHeaderLayoutSpecified |
 | CustomListingHeader |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | ExportListings |
 | ExportListingsSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HeaderStyle |
 | HeaderStyleSpecified |
 | HomePage |
 | HomePageSpecified |
 | ItemListLayout |
 | ItemListLayoutSpecified |
 | ItemListSortOrder |
 | ItemListSortOrderSpecified |
 | LastOpenedTime |
 | LastOpenedTimeSpecified |
 | Logo |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MerchDisplay |
 | MerchDisplaySpecified |
 | Name |
 | SubscriptionLevel |
 | SubscriptionLevelSpecified |
 | Theme |
 | TitleWithCompatibility |
 | TitleWithCompatibilitySpecified |
 | ToString()()()() | (Inherited from Object.)
 | URL |
 | URLPath |
Remarks
Inheritance Hierarchy
Object
StoreType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CustomCategories Property

CustomCategories Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► CustomCategories
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomCategoryTypeCollection CustomCategories { get; set; }
Public Property CustomCategories As StoreCustomCategoryTypeCollection
    Get
    Set
public:
property StoreCustomCategoryTypeCollection^ CustomCategories {
    StoreCustomCategoryTypeCollection^ get ();
    void set (StoreCustomCategoryTypeCollection^ value);
}


CustomHeader Property

CustomHeader Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► CustomHeader
Declaration Syntax
C# Visual Basic Visual C++
public string CustomHeader { get; set; }
Public Property CustomHeader As String
    Get
    Set
public:
property String^ CustomHeader {
    String^ get ();
    void set (String^ value);
}


CustomHeaderLayout Property

CustomHeaderLayout Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► CustomHeaderLayout
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomHeaderLayoutCodeType CustomHeaderLayout { get; set; }
Public Property CustomHeaderLayout As StoreCustomHeaderLayoutCodeType
    Get
    Set
public:
property StoreCustomHeaderLayoutCodeType CustomHeaderLayout {
    StoreCustomHeaderLayoutCodeType get ();
    void set (StoreCustomHeaderLayoutCodeType value);
}


CustomHeaderLayoutSpecified Property

CustomHeaderLayoutSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► CustomHeaderLayoutSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CustomHeaderLayoutSpecified { get; set; }
Public Property CustomHeaderLayoutSpecified As Boolean
    Get
    Set
public:
property bool CustomHeaderLayoutSpecified {
    bool get ();
    void set (bool value);
}


CustomListingHeader Property

CustomListingHeader Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► CustomListingHeader
Declaration Syntax
C# Visual Basic Visual C++
public StoreCustomListingHeaderType CustomListingHeader { get; set; }
Public Property CustomListingHeader As StoreCustomListingHeaderType
    Get
    Set
public:
property StoreCustomListingHeaderType^ CustomListingHeader {
    StoreCustomListingHeaderType^ get ();
    void set (StoreCustomListingHeaderType^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ExportListings Property

ExportListings Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► ExportListings
Declaration Syntax
C# Visual Basic Visual C++
public bool ExportListings { get; set; }
Public Property ExportListings As Boolean
    Get
    Set
public:
property bool ExportListings {
    bool get ();
    void set (bool value);
}


ExportListingsSpecified Property

ExportListingsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► ExportListingsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExportListingsSpecified { get; set; }
Public Property ExportListingsSpecified As Boolean
    Get
    Set
public:
property bool ExportListingsSpecified {
    bool get ();
    void set (bool value);
}


HeaderStyle Property

HeaderStyle Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► HeaderStyle
Declaration Syntax
C# Visual Basic Visual C++
public StoreHeaderStyleCodeType HeaderStyle { get; set; }
Public Property HeaderStyle As StoreHeaderStyleCodeType
    Get
    Set
public:
property StoreHeaderStyleCodeType HeaderStyle {
    StoreHeaderStyleCodeType get ();
    void set (StoreHeaderStyleCodeType value);
}


HeaderStyleSpecified Property

HeaderStyleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► HeaderStyleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HeaderStyleSpecified { get; set; }
Public Property HeaderStyleSpecified As Boolean
    Get
    Set
public:
property bool HeaderStyleSpecified {
    bool get ();
    void set (bool value);
}


HomePage Property

HomePage Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► HomePage
Declaration Syntax
C# Visual Basic Visual C++
public long HomePage { get; set; }
Public Property HomePage As Long
    Get
    Set
public:
property long long HomePage {
    long long get ();
    void set (long long value);
}


HomePageSpecified Property

HomePageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► HomePageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HomePageSpecified { get; set; }
Public Property HomePageSpecified As Boolean
    Get
    Set
public:
property bool HomePageSpecified {
    bool get ();
    void set (bool value);
}


ItemListLayout Property

ItemListLayout Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► ItemListLayout
Declaration Syntax
C# Visual Basic Visual C++
public StoreItemListLayoutCodeType ItemListLayout { get; set; }
Public Property ItemListLayout As StoreItemListLayoutCodeType
    Get
    Set
public:
property StoreItemListLayoutCodeType ItemListLayout {
    StoreItemListLayoutCodeType get ();
    void set (StoreItemListLayoutCodeType value);
}


ItemListLayoutSpecified Property

ItemListLayoutSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► ItemListLayoutSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemListLayoutSpecified { get; set; }
Public Property ItemListLayoutSpecified As Boolean
    Get
    Set
public:
property bool ItemListLayoutSpecified {
    bool get ();
    void set (bool value);
}


ItemListSortOrder Property

ItemListSortOrder Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► ItemListSortOrder
Declaration Syntax
C# Visual Basic Visual C++
public StoreItemListSortOrderCodeType ItemListSortOrder { get; set; }
Public Property ItemListSortOrder As StoreItemListSortOrderCodeType
    Get
    Set
public:
property StoreItemListSortOrderCodeType ItemListSortOrder {
    StoreItemListSortOrderCodeType get ();
    void set (StoreItemListSortOrderCodeType value);
}


ItemListSortOrderSpecified Property

ItemListSortOrderSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► ItemListSortOrderSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemListSortOrderSpecified { get; set; }
Public Property ItemListSortOrderSpecified As Boolean
    Get
    Set
public:
property bool ItemListSortOrderSpecified {
    bool get ();
    void set (bool value);
}


LastOpenedTime Property

LastOpenedTime Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► LastOpenedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastOpenedTime { get; set; }
Public Property LastOpenedTime As DateTime
    Get
    Set
public:
property DateTime LastOpenedTime {
    DateTime get ();
    void set (DateTime value);
}


LastOpenedTimeSpecified Property

LastOpenedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► LastOpenedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastOpenedTimeSpecified { get; set; }
Public Property LastOpenedTimeSpecified As Boolean
    Get
    Set
public:
property bool LastOpenedTimeSpecified {
    bool get ();
    void set (bool value);
}


Logo Property

Logo Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► Logo
Declaration Syntax
C# Visual Basic Visual C++
public StoreLogoType Logo { get; set; }
Public Property Logo As StoreLogoType
    Get
    Set
public:
property StoreLogoType^ Logo {
    StoreLogoType^ get ();
    void set (StoreLogoType^ value);
}


MerchDisplay Property

MerchDisplay Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► MerchDisplay
Declaration Syntax
C# Visual Basic Visual C++
public MerchDisplayCodeType MerchDisplay { get; set; }
Public Property MerchDisplay As MerchDisplayCodeType
    Get
    Set
public:
property MerchDisplayCodeType MerchDisplay {
    MerchDisplayCodeType get ();
    void set (MerchDisplayCodeType value);
}


MerchDisplaySpecified Property

MerchDisplaySpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► MerchDisplaySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MerchDisplaySpecified { get; set; }
Public Property MerchDisplaySpecified As Boolean
    Get
    Set
public:
property bool MerchDisplaySpecified {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


StoreType Constructor

StoreType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreType ► StoreType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreType()
Public Sub New
public:
StoreType()


SubscriptionLevel Property

SubscriptionLevel Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► SubscriptionLevel
Declaration Syntax
C# Visual Basic Visual C++
public StoreSubscriptionLevelCodeType SubscriptionLevel { get; set; }
Public Property SubscriptionLevel As StoreSubscriptionLevelCodeType
    Get
    Set
public:
property StoreSubscriptionLevelCodeType SubscriptionLevel {
    StoreSubscriptionLevelCodeType get ();
    void set (StoreSubscriptionLevelCodeType value);
}


SubscriptionLevelSpecified Property

SubscriptionLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► SubscriptionLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscriptionLevelSpecified { get; set; }
Public Property SubscriptionLevelSpecified As Boolean
    Get
    Set
public:
property bool SubscriptionLevelSpecified {
    bool get ();
    void set (bool value);
}


Theme Property

Theme Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► Theme
Declaration Syntax
C# Visual Basic Visual C++
public StoreThemeType Theme { get; set; }
Public Property Theme As StoreThemeType
    Get
    Set
public:
property StoreThemeType^ Theme {
    StoreThemeType^ get ();
    void set (StoreThemeType^ value);
}


TitleWithCompatibility Property

TitleWithCompatibility Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► TitleWithCompatibility
Declaration Syntax
C# Visual Basic Visual C++
public bool TitleWithCompatibility { get; set; }
Public Property TitleWithCompatibility As Boolean
    Get
    Set
public:
property bool TitleWithCompatibility {
    bool get ();
    void set (bool value);
}


TitleWithCompatibilitySpecified Property

TitleWithCompatibilitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► TitleWithCompatibilitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TitleWithCompatibilitySpecified { get; set; }
Public Property TitleWithCompatibilitySpecified As Boolean
    Get
    Set
public:
property bool TitleWithCompatibilitySpecified {
    bool get ();
    void set (bool value);
}


URL Property

URL Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► URL
Declaration Syntax
C# Visual Basic Visual C++
public string URL { get; set; }
Public Property URL As String
    Get
    Set
public:
property String^ URL {
    String^ get ();
    void set (String^ value);
}


URLPath Property

URLPath Property
Namespaces ► eBay.Service.Core.Soap ► StoreType ► URLPath
Declaration Syntax
C# Visual Basic Visual C++
public string URLPath { get; set; }
Public Property URLPath As String
    Get
    Set
public:
property String^ URLPath {
    String^ get ();
    void set (String^ value);
}


StoreVacationPreferencesType Class

StoreVacationPreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class StoreVacationPreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class StoreVacationPreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class StoreVacationPreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StoreVacationPreferencesType()()()() |
 | DisplayMessageStoreCustomText |
 | DisplayMessageStoreCustomTextSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HideFixedPriceStoreItems |
 | HideFixedPriceStoreItemsSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageItem |
 | MessageItemSpecified |
 | MessageStore |
 | MessageStoreCustomText |
 | MessageStoreSpecified |
 | OnVacation |
 | OnVacationSpecified |
 | ReturnDate |
 | ReturnDateSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
StoreVacationPreferencesType


DisplayMessageStoreCustomText Property

DisplayMessageStoreCustomText Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► DisplayMessageStoreCustomText
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayMessageStoreCustomText { get; set; }
Public Property DisplayMessageStoreCustomText As Boolean
    Get
    Set
public:
property bool DisplayMessageStoreCustomText {
    bool get ();
    void set (bool value);
}


DisplayMessageStoreCustomTextSpecified Property

DisplayMessageStoreCustomTextSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► DisplayMessageStoreCustomTextSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DisplayMessageStoreCustomTextSpecified { get; set; }
Public Property DisplayMessageStoreCustomTextSpecified As Boolean
    Get
    Set
public:
property bool DisplayMessageStoreCustomTextSpecified {
    bool get ();
    void set (bool value);
}


HideFixedPriceStoreItems Property

HideFixedPriceStoreItems Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► HideFixedPriceStoreItems
Declaration Syntax
C# Visual Basic Visual C++
public bool HideFixedPriceStoreItems { get; set; }
Public Property HideFixedPriceStoreItems As Boolean
    Get
    Set
public:
property bool HideFixedPriceStoreItems {
    bool get ();
    void set (bool value);
}


HideFixedPriceStoreItemsSpecified Property

HideFixedPriceStoreItemsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► HideFixedPriceStoreItemsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool HideFixedPriceStoreItemsSpecified { get; set; }
Public Property HideFixedPriceStoreItemsSpecified As Boolean
    Get
    Set
public:
property bool HideFixedPriceStoreItemsSpecified {
    bool get ();
    void set (bool value);
}


MessageItem Property

MessageItem Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► MessageItem
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageItem { get; set; }
Public Property MessageItem As Boolean
    Get
    Set
public:
property bool MessageItem {
    bool get ();
    void set (bool value);
}


MessageItemSpecified Property

MessageItemSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► MessageItemSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageItemSpecified { get; set; }
Public Property MessageItemSpecified As Boolean
    Get
    Set
public:
property bool MessageItemSpecified {
    bool get ();
    void set (bool value);
}


MessageStore Property

MessageStore Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► MessageStore
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageStore { get; set; }
Public Property MessageStore As Boolean
    Get
    Set
public:
property bool MessageStore {
    bool get ();
    void set (bool value);
}


MessageStoreCustomText Property

MessageStoreCustomText Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► MessageStoreCustomText
Declaration Syntax
C# Visual Basic Visual C++
public string MessageStoreCustomText { get; set; }
Public Property MessageStoreCustomText As String
    Get
    Set
public:
property String^ MessageStoreCustomText {
    String^ get ();
    void set (String^ value);
}


MessageStoreSpecified Property

MessageStoreSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► MessageStoreSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MessageStoreSpecified { get; set; }
Public Property MessageStoreSpecified As Boolean
    Get
    Set
public:
property bool MessageStoreSpecified {
    bool get ();
    void set (bool value);
}


OnVacation Property

OnVacation Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► OnVacation
Declaration Syntax
C# Visual Basic Visual C++
public bool OnVacation { get; set; }
Public Property OnVacation As Boolean
    Get
    Set
public:
property bool OnVacation {
    bool get ();
    void set (bool value);
}


OnVacationSpecified Property

OnVacationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► OnVacationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OnVacationSpecified { get; set; }
Public Property OnVacationSpecified As Boolean
    Get
    Set
public:
property bool OnVacationSpecified {
    bool get ();
    void set (bool value);
}


ReturnDate Property

ReturnDate Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► ReturnDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ReturnDate { get; set; }
Public Property ReturnDate As DateTime
    Get
    Set
public:
property DateTime ReturnDate {
    DateTime get ();
    void set (DateTime value);
}


ReturnDateSpecified Property

ReturnDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► ReturnDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnDateSpecified { get; set; }
Public Property ReturnDateSpecified As Boolean
    Get
    Set
public:
property bool ReturnDateSpecified {
    bool get ();
    void set (bool value);
}


StoreVacationPreferencesType Constructor

StoreVacationPreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► StoreVacationPreferencesType ► StoreVacationPreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StoreVacationPreferencesType()
Public Sub New
public:
StoreVacationPreferencesType()


StringCollection Class

StringCollection Class
Namespaces ► eBay.Service.Core.Soap ► StringCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class StringCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class StringCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class StringCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringCollection()()()() |
 | StringCollection(array<String>[]()[][]) |
 | StringCollection(StringCollection) |
 | Add(String) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<String>[]()[][]) |
 | AddRange(StringCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(String) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<String>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(String) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, String) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(String) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | StringCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► Add(String)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    string item
)
Public Function Add ( _
    item As String _
) As Integer
public:
int Add(
    String^ item
)
Parameters
item (String)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<String>[]()[][]) |
 | AddRange(StringCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► AddRange(StringCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    StringCollection items
)
Public Sub AddRange ( _
    items As StringCollection _
)
public:
void AddRange(
    StringCollection^ items
)
Parameters
items (StringCollection)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► AddRange(array<String>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    string[] items
)
Public Sub AddRange ( _
    items As String() _
)
public:
void AddRange(
    array<String^>^ items
)
Parameters
items (array< String >[]()[][])


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► Contains(String)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string item
)
Public Function Contains ( _
    item As String _
) As Boolean
public:
bool Contains(
    String^ item
)
Parameters
item (String)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► CopyTo(array<String>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    string[] items,
    int index
)
Public Sub CopyTo ( _
    items As String(), _
    index As Integer _
)
public:
void CopyTo(
    array<String^>^ items,
    int index
)
Parameters
items (array< String >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► IndexOf(String)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    string item
)
Public Function IndexOf ( _
    item As String _
) As Integer
public:
int IndexOf(
    String^ item
)
Parameters
item (String)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► Insert(Int32, String)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    string item
)
Public Sub Insert ( _
    index As Integer, _
    item As String _
)
public:
void Insert(
    int index,
    String^ item
)
Parameters
index (Int32)
item (String)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public string this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As String
    Get
    Set
public:
property String^ default[int index] {
    String^ get (int index);
    void set (int index, String^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public string ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As String
public:
String^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► Remove(String)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    string item
)
Public Sub Remove ( _
    item As String _
)
public:
void Remove(
    String^ item
)
Parameters
item (String)


StringCollection Constructor

StringCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► StringCollection()()()()
Members
Icon | Member | Description
 | StringCollection()()()() |
 | StringCollection(array<String>[]()[][]) |
 | StringCollection(StringCollection) |


StringCollection Constructor

StringCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► StringCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection()
Public Sub New
public:
StringCollection()


StringCollection Constructor (items)

StringCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► StringCollection(StringCollection)
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection(
    StringCollection items
)
Public Sub New ( _
    items As StringCollection _
)
public:
StringCollection(
    StringCollection^ items
)
Parameters
items (StringCollection)


StringCollection Constructor (items)

StringCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► StringCollection(array<String>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection(
    string[] items
)
Public Sub New ( _
    items As String() _
)
public:
StringCollection(
    array<String^>^ items
)
Parameters
items (array< String >[]()[][])


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public string[] ToArray()
Public Function ToArray As String()
public:
array<String^>^ ToArray()
Return Value


StringMatchCodeType Enumeration

StringMatchCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► StringMatchCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum StringMatchCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration StringMatchCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class StringMatchCodeType
Members
Member | Description
CustomCode |
StartsWith |
Contains |
Remarks


SuggestedBidValueType Class

SuggestedBidValueType Class
Namespaces ► eBay.Service.Core.Soap ► SuggestedBidValueType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SuggestedBidValueType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SuggestedBidValueType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SuggestedBidValueType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SuggestedBidValueType()()()() |
 | Any |
 | BidValue |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SuggestedBidValueType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedBidValueType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BidValue Property

BidValue Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedBidValueType ► BidValue
Declaration Syntax
C# Visual Basic Visual C++
public AmountTypeCollection BidValue { get; set; }
Public Property BidValue As AmountTypeCollection
    Get
    Set
public:
property AmountTypeCollection^ BidValue {
    AmountTypeCollection^ get ();
    void set (AmountTypeCollection^ value);
}


SuggestedBidValueType Constructor

SuggestedBidValueType Constructor
Namespaces ► eBay.Service.Core.Soap ► SuggestedBidValueType ► SuggestedBidValueType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedBidValueType()
Public Sub New
public:
SuggestedBidValueType()


SuggestedCategoryArrayType Class

SuggestedCategoryArrayType Class
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryArrayType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SuggestedCategoryArrayType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SuggestedCategoryArrayType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SuggestedCategoryArrayType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SuggestedCategoryArrayType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SuggestedCategory |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SuggestedCategoryArrayType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryArrayType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SuggestedCategory Property

SuggestedCategory Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryArrayType ► SuggestedCategory
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryTypeCollection SuggestedCategory { get; set; }
Public Property SuggestedCategory As SuggestedCategoryTypeCollection
    Get
    Set
public:
property SuggestedCategoryTypeCollection^ SuggestedCategory {
    SuggestedCategoryTypeCollection^ get ();
    void set (SuggestedCategoryTypeCollection^ value);
}


SuggestedCategoryArrayType Constructor

SuggestedCategoryArrayType Constructor
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryArrayType ► SuggestedCategoryArrayType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryArrayType()
Public Sub New
public:
SuggestedCategoryArrayType()


SuggestedCategoryType Class

SuggestedCategoryType Class
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SuggestedCategoryType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SuggestedCategoryType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SuggestedCategoryType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SuggestedCategoryType()()()() |
 | Any |
 | Category |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PercentItemFound |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SuggestedCategoryType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Category Property

Category Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryType ► Category
Declaration Syntax
C# Visual Basic Visual C++
public CategoryType Category { get; set; }
Public Property Category As CategoryType
    Get
    Set
public:
property CategoryType^ Category {
    CategoryType^ get ();
    void set (CategoryType^ value);
}


PercentItemFound Property

PercentItemFound Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryType ► PercentItemFound
Declaration Syntax
C# Visual Basic Visual C++
public int PercentItemFound { get; set; }
Public Property PercentItemFound As Integer
    Get
    Set
public:
property int PercentItemFound {
    int get ();
    void set (int value);
}


SuggestedCategoryType Constructor

SuggestedCategoryType Constructor
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryType ► SuggestedCategoryType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryType()
Public Sub New
public:
SuggestedCategoryType()


SuggestedCategoryTypeCollection Class

SuggestedCategoryTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SuggestedCategoryTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SuggestedCategoryTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SuggestedCategoryTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SuggestedCategoryTypeCollection()()()() |
 | SuggestedCategoryTypeCollection(array<SuggestedCategoryType>[]()[][]) |
 | SuggestedCategoryTypeCollection(SuggestedCategoryTypeCollection) |
 | Add(SuggestedCategoryType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SuggestedCategoryType>[]()[][]) |
 | AddRange(SuggestedCategoryTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SuggestedCategoryType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SuggestedCategoryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SuggestedCategoryType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SuggestedCategoryType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SuggestedCategoryType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SuggestedCategoryTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► Add(SuggestedCategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SuggestedCategoryType item
)
Public Function Add ( _
    item As SuggestedCategoryType _
) As Integer
public:
int Add(
    SuggestedCategoryType^ item
)
Parameters
item (SuggestedCategoryType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SuggestedCategoryType>[]()[][]) |
 | AddRange(SuggestedCategoryTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► AddRange(array<SuggestedCategoryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SuggestedCategoryType[] items
)
Public Sub AddRange ( _
    items As SuggestedCategoryType() _
)
public:
void AddRange(
    array<SuggestedCategoryType^>^ items
)
Parameters
items (array< SuggestedCategoryType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► AddRange(SuggestedCategoryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SuggestedCategoryTypeCollection items
)
Public Sub AddRange ( _
    items As SuggestedCategoryTypeCollection _
)
public:
void AddRange(
    SuggestedCategoryTypeCollection^ items
)
Parameters
items (SuggestedCategoryTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► Contains(SuggestedCategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SuggestedCategoryType item
)
Public Function Contains ( _
    item As SuggestedCategoryType _
) As Boolean
public:
bool Contains(
    SuggestedCategoryType^ item
)
Parameters
item (SuggestedCategoryType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► CopyTo(array<SuggestedCategoryType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SuggestedCategoryType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SuggestedCategoryType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SuggestedCategoryType^>^ items,
    int index
)
Parameters
items (array< SuggestedCategoryType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► IndexOf(SuggestedCategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SuggestedCategoryType item
)
Public Function IndexOf ( _
    item As SuggestedCategoryType _
) As Integer
public:
int IndexOf(
    SuggestedCategoryType^ item
)
Parameters
item (SuggestedCategoryType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► Insert(Int32, SuggestedCategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SuggestedCategoryType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SuggestedCategoryType _
)
public:
void Insert(
    int index,
    SuggestedCategoryType^ item
)
Parameters
index (Int32)
item (SuggestedCategoryType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SuggestedCategoryType
    Get
    Set
public:
property SuggestedCategoryType^ default[int index] {
    SuggestedCategoryType^ get (int index);
    void set (int index, SuggestedCategoryType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SuggestedCategoryType
public:
SuggestedCategoryType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► Remove(SuggestedCategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SuggestedCategoryType item
)
Public Sub Remove ( _
    item As SuggestedCategoryType _
)
public:
void Remove(
    SuggestedCategoryType^ item
)
Parameters
item (SuggestedCategoryType)


SuggestedCategoryTypeCollection Constructor

SuggestedCategoryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► SuggestedCategoryTypeCollection()()()()
Members
Icon | Member | Description
 | SuggestedCategoryTypeCollection()()()() |
 | SuggestedCategoryTypeCollection(array<SuggestedCategoryType>[]()[][]) |
 | SuggestedCategoryTypeCollection(SuggestedCategoryTypeCollection) |


SuggestedCategoryTypeCollection Constructor

SuggestedCategoryTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► SuggestedCategoryTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryTypeCollection()
Public Sub New
public:
SuggestedCategoryTypeCollection()


SuggestedCategoryTypeCollection Constructor (items)

SuggestedCategoryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► SuggestedCategoryTypeCollection(array<SuggestedCategoryType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryTypeCollection(
    SuggestedCategoryType[] items
)
Public Sub New ( _
    items As SuggestedCategoryType() _
)
public:
SuggestedCategoryTypeCollection(
    array<SuggestedCategoryType^>^ items
)
Parameters
items (array< SuggestedCategoryType >[]()[][])


SuggestedCategoryTypeCollection Constructor (items)

SuggestedCategoryTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► SuggestedCategoryTypeCollection(SuggestedCategoryTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryTypeCollection(
    SuggestedCategoryTypeCollection items
)
Public Sub New ( _
    items As SuggestedCategoryTypeCollection _
)
public:
SuggestedCategoryTypeCollection(
    SuggestedCategoryTypeCollection^ items
)
Parameters
items (SuggestedCategoryTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SuggestedCategoryType[] ToArray()
Public Function ToArray As SuggestedCategoryType()
public:
array<SuggestedCategoryType^>^ ToArray()
Return Value


SummaryEventScheduleType Class

SummaryEventScheduleType Class
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SummaryEventScheduleType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SummaryEventScheduleType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SummaryEventScheduleType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SummaryEventScheduleType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | EventType |
 | EventTypeSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | Frequency |
 | FrequencySpecified |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SummaryPeriod |
 | SummaryPeriodSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SummaryEventScheduleType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EventType Property

EventType Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleType ► EventType
Declaration Syntax
C# Visual Basic Visual C++
public NotificationEventTypeCodeType EventType { get; set; }
Public Property EventType As NotificationEventTypeCodeType
    Get
    Set
public:
property NotificationEventTypeCodeType EventType {
    NotificationEventTypeCodeType get ();
    void set (NotificationEventTypeCodeType value);
}


EventTypeSpecified Property

EventTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleType ► EventTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EventTypeSpecified { get; set; }
Public Property EventTypeSpecified As Boolean
    Get
    Set
public:
property bool EventTypeSpecified {
    bool get ();
    void set (bool value);
}


Frequency Property

Frequency Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleType ► Frequency
Declaration Syntax
C# Visual Basic Visual C++
public SummaryFrequencyCodeType Frequency { get; set; }
Public Property Frequency As SummaryFrequencyCodeType
    Get
    Set
public:
property SummaryFrequencyCodeType Frequency {
    SummaryFrequencyCodeType get ();
    void set (SummaryFrequencyCodeType value);
}


FrequencySpecified Property

FrequencySpecified Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleType ► FrequencySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FrequencySpecified { get; set; }
Public Property FrequencySpecified As Boolean
    Get
    Set
public:
property bool FrequencySpecified {
    bool get ();
    void set (bool value);
}


SummaryEventScheduleType Constructor

SummaryEventScheduleType Constructor
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleType ► SummaryEventScheduleType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SummaryEventScheduleType()
Public Sub New
public:
SummaryEventScheduleType()


SummaryPeriod Property

SummaryPeriod Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleType ► SummaryPeriod
Declaration Syntax
C# Visual Basic Visual C++
public SummaryWindowPeriodCodeType SummaryPeriod { get; set; }
Public Property SummaryPeriod As SummaryWindowPeriodCodeType
    Get
    Set
public:
property SummaryWindowPeriodCodeType SummaryPeriod {
    SummaryWindowPeriodCodeType get ();
    void set (SummaryWindowPeriodCodeType value);
}


SummaryPeriodSpecified Property

SummaryPeriodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleType ► SummaryPeriodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SummaryPeriodSpecified { get; set; }
Public Property SummaryPeriodSpecified As Boolean
    Get
    Set
public:
property bool SummaryPeriodSpecified {
    bool get ();
    void set (bool value);
}


SummaryEventScheduleTypeCollection Class

SummaryEventScheduleTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SummaryEventScheduleTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SummaryEventScheduleTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SummaryEventScheduleTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SummaryEventScheduleTypeCollection()()()() |
 | SummaryEventScheduleTypeCollection(array<SummaryEventScheduleType>[]()[][]) |
 | SummaryEventScheduleTypeCollection(SummaryEventScheduleTypeCollection) |
 | Add(SummaryEventScheduleType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SummaryEventScheduleType>[]()[][]) |
 | AddRange(SummaryEventScheduleTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SummaryEventScheduleType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SummaryEventScheduleType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SummaryEventScheduleType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SummaryEventScheduleType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SummaryEventScheduleType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SummaryEventScheduleTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► Add(SummaryEventScheduleType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SummaryEventScheduleType item
)
Public Function Add ( _
    item As SummaryEventScheduleType _
) As Integer
public:
int Add(
    SummaryEventScheduleType^ item
)
Parameters
item (SummaryEventScheduleType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SummaryEventScheduleType>[]()[][]) |
 | AddRange(SummaryEventScheduleTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► AddRange(array<SummaryEventScheduleType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SummaryEventScheduleType[] items
)
Public Sub AddRange ( _
    items As SummaryEventScheduleType() _
)
public:
void AddRange(
    array<SummaryEventScheduleType^>^ items
)
Parameters
items (array< SummaryEventScheduleType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► AddRange(SummaryEventScheduleTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SummaryEventScheduleTypeCollection items
)
Public Sub AddRange ( _
    items As SummaryEventScheduleTypeCollection _
)
public:
void AddRange(
    SummaryEventScheduleTypeCollection^ items
)
Parameters
items (SummaryEventScheduleTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► Contains(SummaryEventScheduleType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SummaryEventScheduleType item
)
Public Function Contains ( _
    item As SummaryEventScheduleType _
) As Boolean
public:
bool Contains(
    SummaryEventScheduleType^ item
)
Parameters
item (SummaryEventScheduleType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► CopyTo(array<SummaryEventScheduleType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SummaryEventScheduleType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SummaryEventScheduleType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SummaryEventScheduleType^>^ items,
    int index
)
Parameters
items (array< SummaryEventScheduleType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► IndexOf(SummaryEventScheduleType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SummaryEventScheduleType item
)
Public Function IndexOf ( _
    item As SummaryEventScheduleType _
) As Integer
public:
int IndexOf(
    SummaryEventScheduleType^ item
)
Parameters
item (SummaryEventScheduleType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► Insert(Int32, SummaryEventScheduleType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SummaryEventScheduleType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SummaryEventScheduleType _
)
public:
void Insert(
    int index,
    SummaryEventScheduleType^ item
)
Parameters
index (Int32)
item (SummaryEventScheduleType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SummaryEventScheduleType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SummaryEventScheduleType
    Get
    Set
public:
property SummaryEventScheduleType^ default[int index] {
    SummaryEventScheduleType^ get (int index);
    void set (int index, SummaryEventScheduleType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SummaryEventScheduleType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SummaryEventScheduleType
public:
SummaryEventScheduleType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► Remove(SummaryEventScheduleType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SummaryEventScheduleType item
)
Public Sub Remove ( _
    item As SummaryEventScheduleType _
)
public:
void Remove(
    SummaryEventScheduleType^ item
)
Parameters
item (SummaryEventScheduleType)


SummaryEventScheduleTypeCollection Constructor

SummaryEventScheduleTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► SummaryEventScheduleTypeCollection()()()()
Members
Icon | Member | Description
 | SummaryEventScheduleTypeCollection()()()() |
 | SummaryEventScheduleTypeCollection(array<SummaryEventScheduleType>[]()[][]) |
 | SummaryEventScheduleTypeCollection(SummaryEventScheduleTypeCollection) |


SummaryEventScheduleTypeCollection Constructor

SummaryEventScheduleTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► SummaryEventScheduleTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SummaryEventScheduleTypeCollection()
Public Sub New
public:
SummaryEventScheduleTypeCollection()


SummaryEventScheduleTypeCollection Constructor (items)

SummaryEventScheduleTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► SummaryEventScheduleTypeCollection(array<SummaryEventScheduleType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SummaryEventScheduleTypeCollection(
    SummaryEventScheduleType[] items
)
Public Sub New ( _
    items As SummaryEventScheduleType() _
)
public:
SummaryEventScheduleTypeCollection(
    array<SummaryEventScheduleType^>^ items
)
Parameters
items (array< SummaryEventScheduleType >[]()[][])


SummaryEventScheduleTypeCollection Constructor (items)

SummaryEventScheduleTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► SummaryEventScheduleTypeCollection(SummaryEventScheduleTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SummaryEventScheduleTypeCollection(
    SummaryEventScheduleTypeCollection items
)
Public Sub New ( _
    items As SummaryEventScheduleTypeCollection _
)
public:
SummaryEventScheduleTypeCollection(
    SummaryEventScheduleTypeCollection^ items
)
Parameters
items (SummaryEventScheduleTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SummaryEventScheduleType[] ToArray()
Public Function ToArray As SummaryEventScheduleType()
public:
array<SummaryEventScheduleType^>^ ToArray()
Return Value


SummaryFrequencyCodeType Enumeration

SummaryFrequencyCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SummaryFrequencyCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SummaryFrequencyCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SummaryFrequencyCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SummaryFrequencyCodeType
Members
Member | Description
EverySunday |
EveryMonday |
EveryTuesday |
EveryWednesday |
EveryThursday |
EveryFriday |
EverySaturday |
MonthlyOn1st |
MonthlyOn2nd |
MonthlyOn3rd |
MonthlyOn4th |
MonthlyOn5th |
MonthlyOn6th |
MonthlyOn7th |
MonthlyOn8th |
MonthlyOn9th |
MonthlyOn10th |
MonthlyOn11th |
MonthlyOn12th |
MonthlyOn13th |
MonthlyOn14th |
MonthlyOn15th |
MonthlyOn16th |
MonthlyOn17th |
MonthlyOn18th |
MonthlyOn19th |
MonthlyOn20th |
MonthlyOn21st |
MonthlyOn22nd |
MonthlyOn23rd |
MonthlyOn24th |
MonthlyOn25th |
MonthlyOn26th |
MonthlyOn27th |
MonthlyOn28th |
MonthlyOn29th |
MonthlyOn30th |
MonthlyOn31st |
Every31Days |
Every60Days |
CustomCode |
Remarks


SummaryWindowPeriodCodeType Enumeration

SummaryWindowPeriodCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► SummaryWindowPeriodCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum SummaryWindowPeriodCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration SummaryWindowPeriodCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class SummaryWindowPeriodCodeType
Members
Member | Description
Last24Hours |
Last7Days |
Last31Days |
CurrentWeek |
LastWeek |
CurrentMonth |
LastMonth |
Last60Days |
CustomCode |
Remarks


SupportedSellerProfileType Class

SupportedSellerProfileType Class
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class SupportedSellerProfileType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class SupportedSellerProfileType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class SupportedSellerProfileType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SupportedSellerProfileType()()()() |
 | CategoryGroup |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ProfileID |
 | ProfileIDSpecified |
 | ProfileName |
 | ProfileType |
 | ShortSummary |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
SupportedSellerProfileType


CategoryGroup Property

CategoryGroup Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileType ► CategoryGroup
Declaration Syntax
C# Visual Basic Visual C++
public CategoryGroupType CategoryGroup { get; set; }
Public Property CategoryGroup As CategoryGroupType
    Get
    Set
public:
property CategoryGroupType^ CategoryGroup {
    CategoryGroupType^ get ();
    void set (CategoryGroupType^ value);
}


ProfileID Property

ProfileID Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileType ► ProfileID
Declaration Syntax
C# Visual Basic Visual C++
public long ProfileID { get; set; }
Public Property ProfileID As Long
    Get
    Set
public:
property long long ProfileID {
    long long get ();
    void set (long long value);
}


ProfileIDSpecified Property

ProfileIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileType ► ProfileIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ProfileIDSpecified { get; set; }
Public Property ProfileIDSpecified As Boolean
    Get
    Set
public:
property bool ProfileIDSpecified {
    bool get ();
    void set (bool value);
}


ProfileName Property

ProfileName Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileType ► ProfileName
Declaration Syntax
C# Visual Basic Visual C++
public string ProfileName { get; set; }
Public Property ProfileName As String
    Get
    Set
public:
property String^ ProfileName {
    String^ get ();
    void set (String^ value);
}


ProfileType Property

ProfileType Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileType ► ProfileType
Declaration Syntax
C# Visual Basic Visual C++
public string ProfileType { get; set; }
Public Property ProfileType As String
    Get
    Set
public:
property String^ ProfileType {
    String^ get ();
    void set (String^ value);
}


ShortSummary Property

ShortSummary Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileType ► ShortSummary
Declaration Syntax
C# Visual Basic Visual C++
public string ShortSummary { get; set; }
Public Property ShortSummary As String
    Get
    Set
public:
property String^ ShortSummary {
    String^ get ();
    void set (String^ value);
}


SupportedSellerProfileType Constructor

SupportedSellerProfileType Constructor
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileType ► SupportedSellerProfileType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SupportedSellerProfileType()
Public Sub New
public:
SupportedSellerProfileType()


SupportedSellerProfileTypeCollection Class

SupportedSellerProfileTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class SupportedSellerProfileTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class SupportedSellerProfileTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class SupportedSellerProfileTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SupportedSellerProfileTypeCollection()()()() |
 | SupportedSellerProfileTypeCollection(array<SupportedSellerProfileType>[]()[][]) |
 | SupportedSellerProfileTypeCollection(SupportedSellerProfileTypeCollection) |
 | Add(SupportedSellerProfileType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<SupportedSellerProfileType>[]()[][]) |
 | AddRange(SupportedSellerProfileTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(SupportedSellerProfileType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<SupportedSellerProfileType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(SupportedSellerProfileType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, SupportedSellerProfileType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(SupportedSellerProfileType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | SupportedSellerProfileTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► Add(SupportedSellerProfileType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    SupportedSellerProfileType item
)
Public Function Add ( _
    item As SupportedSellerProfileType _
) As Integer
public:
int Add(
    SupportedSellerProfileType^ item
)
Parameters
item (SupportedSellerProfileType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<SupportedSellerProfileType>[]()[][]) |
 | AddRange(SupportedSellerProfileTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► AddRange(array<SupportedSellerProfileType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SupportedSellerProfileType[] items
)
Public Sub AddRange ( _
    items As SupportedSellerProfileType() _
)
public:
void AddRange(
    array<SupportedSellerProfileType^>^ items
)
Parameters
items (array< SupportedSellerProfileType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► AddRange(SupportedSellerProfileTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    SupportedSellerProfileTypeCollection items
)
Public Sub AddRange ( _
    items As SupportedSellerProfileTypeCollection _
)
public:
void AddRange(
    SupportedSellerProfileTypeCollection^ items
)
Parameters
items (SupportedSellerProfileTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► Contains(SupportedSellerProfileType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    SupportedSellerProfileType item
)
Public Function Contains ( _
    item As SupportedSellerProfileType _
) As Boolean
public:
bool Contains(
    SupportedSellerProfileType^ item
)
Parameters
item (SupportedSellerProfileType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► CopyTo(array<SupportedSellerProfileType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    SupportedSellerProfileType[] items,
    int index
)
Public Sub CopyTo ( _
    items As SupportedSellerProfileType(), _
    index As Integer _
)
public:
void CopyTo(
    array<SupportedSellerProfileType^>^ items,
    int index
)
Parameters
items (array< SupportedSellerProfileType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► IndexOf(SupportedSellerProfileType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    SupportedSellerProfileType item
)
Public Function IndexOf ( _
    item As SupportedSellerProfileType _
) As Integer
public:
int IndexOf(
    SupportedSellerProfileType^ item
)
Parameters
item (SupportedSellerProfileType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► Insert(Int32, SupportedSellerProfileType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    SupportedSellerProfileType item
)
Public Sub Insert ( _
    index As Integer, _
    item As SupportedSellerProfileType _
)
public:
void Insert(
    int index,
    SupportedSellerProfileType^ item
)
Parameters
index (Int32)
item (SupportedSellerProfileType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public SupportedSellerProfileType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As SupportedSellerProfileType
    Get
    Set
public:
property SupportedSellerProfileType^ default[int index] {
    SupportedSellerProfileType^ get (int index);
    void set (int index, SupportedSellerProfileType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public SupportedSellerProfileType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As SupportedSellerProfileType
public:
SupportedSellerProfileType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► Remove(SupportedSellerProfileType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    SupportedSellerProfileType item
)
Public Sub Remove ( _
    item As SupportedSellerProfileType _
)
public:
void Remove(
    SupportedSellerProfileType^ item
)
Parameters
item (SupportedSellerProfileType)


SupportedSellerProfileTypeCollection Constructor

SupportedSellerProfileTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► SupportedSellerProfileTypeCollection()()()()
Members
Icon | Member | Description
 | SupportedSellerProfileTypeCollection()()()() |
 | SupportedSellerProfileTypeCollection(array<SupportedSellerProfileType>[]()[][]) |
 | SupportedSellerProfileTypeCollection(SupportedSellerProfileTypeCollection) |


SupportedSellerProfileTypeCollection Constructor

SupportedSellerProfileTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► SupportedSellerProfileTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SupportedSellerProfileTypeCollection()
Public Sub New
public:
SupportedSellerProfileTypeCollection()


SupportedSellerProfileTypeCollection Constructor (items)

SupportedSellerProfileTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► SupportedSellerProfileTypeCollection(array<SupportedSellerProfileType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public SupportedSellerProfileTypeCollection(
    SupportedSellerProfileType[] items
)
Public Sub New ( _
    items As SupportedSellerProfileType() _
)
public:
SupportedSellerProfileTypeCollection(
    array<SupportedSellerProfileType^>^ items
)
Parameters
items (array< SupportedSellerProfileType >[]()[][])


SupportedSellerProfileTypeCollection Constructor (items)

SupportedSellerProfileTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► SupportedSellerProfileTypeCollection(SupportedSellerProfileTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public SupportedSellerProfileTypeCollection(
    SupportedSellerProfileTypeCollection items
)
Public Sub New ( _
    items As SupportedSellerProfileTypeCollection _
)
public:
SupportedSellerProfileTypeCollection(
    SupportedSellerProfileTypeCollection^ items
)
Parameters
items (SupportedSellerProfileTypeCollection)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SupportedSellerProfileType[] ToArray()
Public Function ToArray As SupportedSellerProfileType()
public:
array<SupportedSellerProfileType^>^ ToArray()
Return Value


TaskStatusCodeType Enumeration

TaskStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► TaskStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum TaskStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration TaskStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class TaskStatusCodeType
Members
Member | Description
Pending |
InProgress |
Complete |
Failed |
CustomCode |
Remarks


TaxDescriptionCodeType Enumeration

TaxDescriptionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► TaxDescriptionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum TaxDescriptionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration TaxDescriptionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class TaxDescriptionCodeType
Members
Member | Description
SalesTax |
ElectronicWasteRecyclingFee |
TireRecyclingFee |
CustomCode |
Remarks


TaxDetailsType Class

TaxDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TaxDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TaxDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TaxDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaxDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Imposition |
 | ImpositionSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | TaxAmount |
 | TaxCode |
 | TaxDescription |
 | TaxDescriptionSpecified |
 | TaxOnHandlingAmount |
 | TaxOnShippingAmount |
 | TaxOnSubtotalAmount |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaxDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Imposition Property

Imposition Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType ► Imposition
Declaration Syntax
C# Visual Basic Visual C++
public TaxTypeCodeType Imposition { get; set; }
Public Property Imposition As TaxTypeCodeType
    Get
    Set
public:
property TaxTypeCodeType Imposition {
    TaxTypeCodeType get ();
    void set (TaxTypeCodeType value);
}


ImpositionSpecified Property

ImpositionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType ► ImpositionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ImpositionSpecified { get; set; }
Public Property ImpositionSpecified As Boolean
    Get
    Set
public:
property bool ImpositionSpecified {
    bool get ();
    void set (bool value);
}


TaxAmount Property

TaxAmount Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType ► TaxAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TaxAmount { get; set; }
Public Property TaxAmount As AmountType
    Get
    Set
public:
property AmountType^ TaxAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


TaxCode Property

TaxCode Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType ► TaxCode
Declaration Syntax
C# Visual Basic Visual C++
public string TaxCode { get; set; }
Public Property TaxCode As String
    Get
    Set
public:
property String^ TaxCode {
    String^ get ();
    void set (String^ value);
}


TaxDescription Property

TaxDescription Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType ► TaxDescription
Declaration Syntax
C# Visual Basic Visual C++
public TaxDescriptionCodeType TaxDescription { get; set; }
Public Property TaxDescription As TaxDescriptionCodeType
    Get
    Set
public:
property TaxDescriptionCodeType TaxDescription {
    TaxDescriptionCodeType get ();
    void set (TaxDescriptionCodeType value);
}


TaxDescriptionSpecified Property

TaxDescriptionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType ► TaxDescriptionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TaxDescriptionSpecified { get; set; }
Public Property TaxDescriptionSpecified As Boolean
    Get
    Set
public:
property bool TaxDescriptionSpecified {
    bool get ();
    void set (bool value);
}


TaxDetailsType Constructor

TaxDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType ► TaxDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxDetailsType()
Public Sub New
public:
TaxDetailsType()


TaxOnHandlingAmount Property

TaxOnHandlingAmount Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType ► TaxOnHandlingAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TaxOnHandlingAmount { get; set; }
Public Property TaxOnHandlingAmount As AmountType
    Get
    Set
public:
property AmountType^ TaxOnHandlingAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


TaxOnShippingAmount Property

TaxOnShippingAmount Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType ► TaxOnShippingAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TaxOnShippingAmount { get; set; }
Public Property TaxOnShippingAmount As AmountType
    Get
    Set
public:
property AmountType^ TaxOnShippingAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


TaxOnSubtotalAmount Property

TaxOnSubtotalAmount Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsType ► TaxOnSubtotalAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TaxOnSubtotalAmount { get; set; }
Public Property TaxOnSubtotalAmount As AmountType
    Get
    Set
public:
property AmountType^ TaxOnSubtotalAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


TaxDetailsTypeCollection Class

TaxDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class TaxDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class TaxDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class TaxDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaxDetailsTypeCollection()()()() |
 | TaxDetailsTypeCollection(array<TaxDetailsType>[]()[][]) |
 | TaxDetailsTypeCollection(TaxDetailsTypeCollection) |
 | Add(TaxDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<TaxDetailsType>[]()[][]) |
 | AddRange(TaxDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(TaxDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<TaxDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(TaxDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, TaxDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(TaxDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | TaxDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► Add(TaxDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    TaxDetailsType item
)
Public Function Add ( _
    item As TaxDetailsType _
) As Integer
public:
int Add(
    TaxDetailsType^ item
)
Parameters
item (TaxDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<TaxDetailsType>[]()[][]) |
 | AddRange(TaxDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► AddRange(array<TaxDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TaxDetailsType[] items
)
Public Sub AddRange ( _
    items As TaxDetailsType() _
)
public:
void AddRange(
    array<TaxDetailsType^>^ items
)
Parameters
items (array< TaxDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► AddRange(TaxDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TaxDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As TaxDetailsTypeCollection _
)
public:
void AddRange(
    TaxDetailsTypeCollection^ items
)
Parameters
items (TaxDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► Contains(TaxDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    TaxDetailsType item
)
Public Function Contains ( _
    item As TaxDetailsType _
) As Boolean
public:
bool Contains(
    TaxDetailsType^ item
)
Parameters
item (TaxDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► CopyTo(array<TaxDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    TaxDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As TaxDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<TaxDetailsType^>^ items,
    int index
)
Parameters
items (array< TaxDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► IndexOf(TaxDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    TaxDetailsType item
)
Public Function IndexOf ( _
    item As TaxDetailsType _
) As Integer
public:
int IndexOf(
    TaxDetailsType^ item
)
Parameters
item (TaxDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► Insert(Int32, TaxDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    TaxDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As TaxDetailsType _
)
public:
void Insert(
    int index,
    TaxDetailsType^ item
)
Parameters
index (Int32)
item (TaxDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public TaxDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As TaxDetailsType
    Get
    Set
public:
property TaxDetailsType^ default[int index] {
    TaxDetailsType^ get (int index);
    void set (int index, TaxDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public TaxDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As TaxDetailsType
public:
TaxDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► Remove(TaxDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    TaxDetailsType item
)
Public Sub Remove ( _
    item As TaxDetailsType _
)
public:
void Remove(
    TaxDetailsType^ item
)
Parameters
item (TaxDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


TaxDetailsTypeCollection Constructor

TaxDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► TaxDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | TaxDetailsTypeCollection()()()() |
 | TaxDetailsTypeCollection(array<TaxDetailsType>[]()[][]) |
 | TaxDetailsTypeCollection(TaxDetailsTypeCollection) |


TaxDetailsTypeCollection Constructor

TaxDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► TaxDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxDetailsTypeCollection()
Public Sub New
public:
TaxDetailsTypeCollection()


TaxDetailsTypeCollection Constructor (items)

TaxDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► TaxDetailsTypeCollection(array<TaxDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public TaxDetailsTypeCollection(
    TaxDetailsType[] items
)
Public Sub New ( _
    items As TaxDetailsType() _
)
public:
TaxDetailsTypeCollection(
    array<TaxDetailsType^>^ items
)
Parameters
items (array< TaxDetailsType >[]()[][])


TaxDetailsTypeCollection Constructor (items)

TaxDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► TaxDetailsTypeCollection(TaxDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public TaxDetailsTypeCollection(
    TaxDetailsTypeCollection items
)
Public Sub New ( _
    items As TaxDetailsTypeCollection _
)
public:
TaxDetailsTypeCollection(
    TaxDetailsTypeCollection^ items
)
Parameters
items (TaxDetailsTypeCollection)


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxDetailsType[] ToArray()
Public Function ToArray As TaxDetailsType()
public:
array<TaxDetailsType^>^ ToArray()
Return Value


TaxesType Class

TaxesType Class
Namespaces ► eBay.Service.Core.Soap ► TaxesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TaxesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TaxesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TaxesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaxesType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | TaxDetails |
 | ToString()()()() | (Inherited from Object.)
 | TotalTaxAmount |
Remarks
Inheritance Hierarchy
Object
TaxesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TaxesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


TaxDetails Property

TaxDetails Property
Namespaces ► eBay.Service.Core.Soap ► TaxesType ► TaxDetails
Declaration Syntax
C# Visual Basic Visual C++
public TaxDetailsTypeCollection TaxDetails { get; set; }
Public Property TaxDetails As TaxDetailsTypeCollection
    Get
    Set
public:
property TaxDetailsTypeCollection^ TaxDetails {
    TaxDetailsTypeCollection^ get ();
    void set (TaxDetailsTypeCollection^ value);
}


TaxesType Constructor

TaxesType Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxesType ► TaxesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxesType()
Public Sub New
public:
TaxesType()


TotalTaxAmount Property

TotalTaxAmount Property
Namespaces ► eBay.Service.Core.Soap ► TaxesType ► TotalTaxAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalTaxAmount { get; set; }
Public Property TotalTaxAmount As AmountType
    Get
    Set
public:
property AmountType^ TotalTaxAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


TaxIdentifierAttributeCodeType Enumeration

TaxIdentifierAttributeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum TaxIdentifierAttributeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration TaxIdentifierAttributeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class TaxIdentifierAttributeCodeType
Members
Member | Description
IssuingCountry |
CustomCode |
Remarks


TaxIdentifierAttributeType Class

TaxIdentifierAttributeType Class
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TaxIdentifierAttributeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TaxIdentifierAttributeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TaxIdentifierAttributeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaxIdentifierAttributeType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | name |
 | nameSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Value |
Remarks
Inheritance Hierarchy
Object
TaxIdentifierAttributeType


name Property

name Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeType ► name
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierAttributeCodeType name { get; set; }
Public Property name As TaxIdentifierAttributeCodeType
    Get
    Set
public:
property TaxIdentifierAttributeCodeType name {
    TaxIdentifierAttributeCodeType get ();
    void set (TaxIdentifierAttributeCodeType value);
}


nameSpecified Property

nameSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeType ► nameSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool nameSpecified { get; set; }
Public Property nameSpecified As Boolean
    Get
    Set
public:
property bool nameSpecified {
    bool get ();
    void set (bool value);
}


TaxIdentifierAttributeType Constructor

TaxIdentifierAttributeType Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeType ► TaxIdentifierAttributeType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierAttributeType()
Public Sub New
public:
TaxIdentifierAttributeType()


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


TaxIdentifierAttributeTypeCollection Class

TaxIdentifierAttributeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class TaxIdentifierAttributeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class TaxIdentifierAttributeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class TaxIdentifierAttributeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaxIdentifierAttributeTypeCollection()()()() |
 | TaxIdentifierAttributeTypeCollection(array<TaxIdentifierAttributeType>[]()[][]) |
 | TaxIdentifierAttributeTypeCollection(TaxIdentifierAttributeTypeCollection) |
 | Add(TaxIdentifierAttributeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<TaxIdentifierAttributeType>[]()[][]) |
 | AddRange(TaxIdentifierAttributeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(TaxIdentifierAttributeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<TaxIdentifierAttributeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(TaxIdentifierAttributeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, TaxIdentifierAttributeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(TaxIdentifierAttributeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | TaxIdentifierAttributeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► Add(TaxIdentifierAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    TaxIdentifierAttributeType item
)
Public Function Add ( _
    item As TaxIdentifierAttributeType _
) As Integer
public:
int Add(
    TaxIdentifierAttributeType^ item
)
Parameters
item (TaxIdentifierAttributeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<TaxIdentifierAttributeType>[]()[][]) |
 | AddRange(TaxIdentifierAttributeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► AddRange(array<TaxIdentifierAttributeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TaxIdentifierAttributeType[] items
)
Public Sub AddRange ( _
    items As TaxIdentifierAttributeType() _
)
public:
void AddRange(
    array<TaxIdentifierAttributeType^>^ items
)
Parameters
items (array< TaxIdentifierAttributeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► AddRange(TaxIdentifierAttributeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TaxIdentifierAttributeTypeCollection items
)
Public Sub AddRange ( _
    items As TaxIdentifierAttributeTypeCollection _
)
public:
void AddRange(
    TaxIdentifierAttributeTypeCollection^ items
)
Parameters
items (TaxIdentifierAttributeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► Contains(TaxIdentifierAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    TaxIdentifierAttributeType item
)
Public Function Contains ( _
    item As TaxIdentifierAttributeType _
) As Boolean
public:
bool Contains(
    TaxIdentifierAttributeType^ item
)
Parameters
item (TaxIdentifierAttributeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► CopyTo(array<TaxIdentifierAttributeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    TaxIdentifierAttributeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As TaxIdentifierAttributeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<TaxIdentifierAttributeType^>^ items,
    int index
)
Parameters
items (array< TaxIdentifierAttributeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► IndexOf(TaxIdentifierAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    TaxIdentifierAttributeType item
)
Public Function IndexOf ( _
    item As TaxIdentifierAttributeType _
) As Integer
public:
int IndexOf(
    TaxIdentifierAttributeType^ item
)
Parameters
item (TaxIdentifierAttributeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► Insert(Int32, TaxIdentifierAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    TaxIdentifierAttributeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As TaxIdentifierAttributeType _
)
public:
void Insert(
    int index,
    TaxIdentifierAttributeType^ item
)
Parameters
index (Int32)
item (TaxIdentifierAttributeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierAttributeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As TaxIdentifierAttributeType
    Get
    Set
public:
property TaxIdentifierAttributeType^ default[int index] {
    TaxIdentifierAttributeType^ get (int index);
    void set (int index, TaxIdentifierAttributeType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierAttributeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As TaxIdentifierAttributeType
public:
TaxIdentifierAttributeType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► Remove(TaxIdentifierAttributeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    TaxIdentifierAttributeType item
)
Public Sub Remove ( _
    item As TaxIdentifierAttributeType _
)
public:
void Remove(
    TaxIdentifierAttributeType^ item
)
Parameters
item (TaxIdentifierAttributeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


TaxIdentifierAttributeTypeCollection Constructor

TaxIdentifierAttributeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► TaxIdentifierAttributeTypeCollection()()()()
Members
Icon | Member | Description
 | TaxIdentifierAttributeTypeCollection()()()() |
 | TaxIdentifierAttributeTypeCollection(array<TaxIdentifierAttributeType>[]()[][]) |
 | TaxIdentifierAttributeTypeCollection(TaxIdentifierAttributeTypeCollection) |


TaxIdentifierAttributeTypeCollection Constructor

TaxIdentifierAttributeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► TaxIdentifierAttributeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierAttributeTypeCollection()
Public Sub New
public:
TaxIdentifierAttributeTypeCollection()


TaxIdentifierAttributeTypeCollection Constructor (items)

TaxIdentifierAttributeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► TaxIdentifierAttributeTypeCollection(array<TaxIdentifierAttributeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierAttributeTypeCollection(
    TaxIdentifierAttributeType[] items
)
Public Sub New ( _
    items As TaxIdentifierAttributeType() _
)
public:
TaxIdentifierAttributeTypeCollection(
    array<TaxIdentifierAttributeType^>^ items
)
Parameters
items (array< TaxIdentifierAttributeType >[]()[][])


TaxIdentifierAttributeTypeCollection Constructor (items)

TaxIdentifierAttributeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► TaxIdentifierAttributeTypeCollection(TaxIdentifierAttributeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierAttributeTypeCollection(
    TaxIdentifierAttributeTypeCollection items
)
Public Sub New ( _
    items As TaxIdentifierAttributeTypeCollection _
)
public:
TaxIdentifierAttributeTypeCollection(
    TaxIdentifierAttributeTypeCollection^ items
)
Parameters
items (TaxIdentifierAttributeTypeCollection)


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierAttributeType[] ToArray()
Public Function ToArray As TaxIdentifierAttributeType()
public:
array<TaxIdentifierAttributeType^>^ ToArray()
Return Value


TaxIdentifierType Class

TaxIdentifierType Class
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TaxIdentifierType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TaxIdentifierType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TaxIdentifierType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaxIdentifierType()()()() |
 | Any |
 | Attribute |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | TypeSpecified |
Remarks
Inheritance Hierarchy
Object
TaxIdentifierType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Attribute Property

Attribute Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierType ► Attribute
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierAttributeTypeCollection Attribute { get; set; }
Public Property Attribute As TaxIdentifierAttributeTypeCollection
    Get
    Set
public:
property TaxIdentifierAttributeTypeCollection^ Attribute {
    TaxIdentifierAttributeTypeCollection^ get ();
    void set (TaxIdentifierAttributeTypeCollection^ value);
}


ID Property

ID Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierType ► ID
Declaration Syntax
C# Visual Basic Visual C++
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}


TaxIdentifierType Constructor

TaxIdentifierType Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierType ► TaxIdentifierType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierType()
Public Sub New
public:
TaxIdentifierType()


Type Property

Type Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierType ► Type
Declaration Syntax
C# Visual Basic Visual C++
public ValueTypeCodeType Type { get; set; }
Public Property Type As ValueTypeCodeType
    Get
    Set
public:
property ValueTypeCodeType Type {
    ValueTypeCodeType get ();
    void set (ValueTypeCodeType value);
}


TypeSpecified Property

TypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierType ► TypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TypeSpecified { get; set; }
Public Property TypeSpecified As Boolean
    Get
    Set
public:
property bool TypeSpecified {
    bool get ();
    void set (bool value);
}


TaxIdentifierTypeCollection Class

TaxIdentifierTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class TaxIdentifierTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class TaxIdentifierTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class TaxIdentifierTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaxIdentifierTypeCollection()()()() |
 | TaxIdentifierTypeCollection(array<TaxIdentifierType>[]()[][]) |
 | TaxIdentifierTypeCollection(TaxIdentifierTypeCollection) |
 | Add(TaxIdentifierType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<TaxIdentifierType>[]()[][]) |
 | AddRange(TaxIdentifierTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(TaxIdentifierType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<TaxIdentifierType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(TaxIdentifierType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, TaxIdentifierType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(TaxIdentifierType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | TaxIdentifierTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► Add(TaxIdentifierType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    TaxIdentifierType item
)
Public Function Add ( _
    item As TaxIdentifierType _
) As Integer
public:
int Add(
    TaxIdentifierType^ item
)
Parameters
item (TaxIdentifierType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<TaxIdentifierType>[]()[][]) |
 | AddRange(TaxIdentifierTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► AddRange(array<TaxIdentifierType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TaxIdentifierType[] items
)
Public Sub AddRange ( _
    items As TaxIdentifierType() _
)
public:
void AddRange(
    array<TaxIdentifierType^>^ items
)
Parameters
items (array< TaxIdentifierType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► AddRange(TaxIdentifierTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TaxIdentifierTypeCollection items
)
Public Sub AddRange ( _
    items As TaxIdentifierTypeCollection _
)
public:
void AddRange(
    TaxIdentifierTypeCollection^ items
)
Parameters
items (TaxIdentifierTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► Contains(TaxIdentifierType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    TaxIdentifierType item
)
Public Function Contains ( _
    item As TaxIdentifierType _
) As Boolean
public:
bool Contains(
    TaxIdentifierType^ item
)
Parameters
item (TaxIdentifierType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► CopyTo(array<TaxIdentifierType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    TaxIdentifierType[] items,
    int index
)
Public Sub CopyTo ( _
    items As TaxIdentifierType(), _
    index As Integer _
)
public:
void CopyTo(
    array<TaxIdentifierType^>^ items,
    int index
)
Parameters
items (array< TaxIdentifierType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► IndexOf(TaxIdentifierType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    TaxIdentifierType item
)
Public Function IndexOf ( _
    item As TaxIdentifierType _
) As Integer
public:
int IndexOf(
    TaxIdentifierType^ item
)
Parameters
item (TaxIdentifierType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► Insert(Int32, TaxIdentifierType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    TaxIdentifierType item
)
Public Sub Insert ( _
    index As Integer, _
    item As TaxIdentifierType _
)
public:
void Insert(
    int index,
    TaxIdentifierType^ item
)
Parameters
index (Int32)
item (TaxIdentifierType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As TaxIdentifierType
    Get
    Set
public:
property TaxIdentifierType^ default[int index] {
    TaxIdentifierType^ get (int index);
    void set (int index, TaxIdentifierType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As TaxIdentifierType
public:
TaxIdentifierType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► Remove(TaxIdentifierType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    TaxIdentifierType item
)
Public Sub Remove ( _
    item As TaxIdentifierType _
)
public:
void Remove(
    TaxIdentifierType^ item
)
Parameters
item (TaxIdentifierType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


TaxIdentifierTypeCollection Constructor

TaxIdentifierTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► TaxIdentifierTypeCollection()()()()
Members
Icon | Member | Description
 | TaxIdentifierTypeCollection()()()() |
 | TaxIdentifierTypeCollection(array<TaxIdentifierType>[]()[][]) |
 | TaxIdentifierTypeCollection(TaxIdentifierTypeCollection) |


TaxIdentifierTypeCollection Constructor

TaxIdentifierTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► TaxIdentifierTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierTypeCollection()
Public Sub New
public:
TaxIdentifierTypeCollection()


TaxIdentifierTypeCollection Constructor (items)

TaxIdentifierTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► TaxIdentifierTypeCollection(array<TaxIdentifierType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierTypeCollection(
    TaxIdentifierType[] items
)
Public Sub New ( _
    items As TaxIdentifierType() _
)
public:
TaxIdentifierTypeCollection(
    array<TaxIdentifierType^>^ items
)
Parameters
items (array< TaxIdentifierType >[]()[][])


TaxIdentifierTypeCollection Constructor (items)

TaxIdentifierTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► TaxIdentifierTypeCollection(TaxIdentifierTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierTypeCollection(
    TaxIdentifierTypeCollection items
)
Public Sub New ( _
    items As TaxIdentifierTypeCollection _
)
public:
TaxIdentifierTypeCollection(
    TaxIdentifierTypeCollection^ items
)
Parameters
items (TaxIdentifierTypeCollection)


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxIdentifierType[] ToArray()
Public Function ToArray As TaxIdentifierType()
public:
array<TaxIdentifierType^>^ ToArray()
Return Value


TaxJurisdictionType Class

TaxJurisdictionType Class
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TaxJurisdictionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TaxJurisdictionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TaxJurisdictionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaxJurisdictionType()()()() |
 | Any |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | JurisdictionID |
 | JurisdictionName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SalesTaxPercent |
 | SalesTaxPercentSpecified |
 | ShippingIncludedInTax |
 | ShippingIncludedInTaxSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
TaxJurisdictionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


JurisdictionID Property

JurisdictionID Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType ► JurisdictionID
Declaration Syntax
C# Visual Basic Visual C++
public string JurisdictionID { get; set; }
Public Property JurisdictionID As String
    Get
    Set
public:
property String^ JurisdictionID {
    String^ get ();
    void set (String^ value);
}


JurisdictionName Property

JurisdictionName Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType ► JurisdictionName
Declaration Syntax
C# Visual Basic Visual C++
public string JurisdictionName { get; set; }
Public Property JurisdictionName As String
    Get
    Set
public:
property String^ JurisdictionName {
    String^ get ();
    void set (String^ value);
}


SalesTaxPercent Property

SalesTaxPercent Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType ► SalesTaxPercent
Declaration Syntax
C# Visual Basic Visual C++
public float SalesTaxPercent { get; set; }
Public Property SalesTaxPercent As Single
    Get
    Set
public:
property float SalesTaxPercent {
    float get ();
    void set (float value);
}


SalesTaxPercentSpecified Property

SalesTaxPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType ► SalesTaxPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SalesTaxPercentSpecified { get; set; }
Public Property SalesTaxPercentSpecified As Boolean
    Get
    Set
public:
property bool SalesTaxPercentSpecified {
    bool get ();
    void set (bool value);
}


ShippingIncludedInTax Property

ShippingIncludedInTax Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType ► ShippingIncludedInTax
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingIncludedInTax { get; set; }
Public Property ShippingIncludedInTax As Boolean
    Get
    Set
public:
property bool ShippingIncludedInTax {
    bool get ();
    void set (bool value);
}


ShippingIncludedInTaxSpecified Property

ShippingIncludedInTaxSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType ► ShippingIncludedInTaxSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippingIncludedInTaxSpecified { get; set; }
Public Property ShippingIncludedInTaxSpecified As Boolean
    Get
    Set
public:
property bool ShippingIncludedInTaxSpecified {
    bool get ();
    void set (bool value);
}


TaxJurisdictionType Constructor

TaxJurisdictionType Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType ► TaxJurisdictionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionType()
Public Sub New
public:
TaxJurisdictionType()


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


TaxJurisdictionTypeCollection Class

TaxJurisdictionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class TaxJurisdictionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class TaxJurisdictionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class TaxJurisdictionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaxJurisdictionTypeCollection()()()() |
 | TaxJurisdictionTypeCollection(array<TaxJurisdictionType>[]()[][]) |
 | TaxJurisdictionTypeCollection(TaxJurisdictionTypeCollection) |
 | Add(TaxJurisdictionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<TaxJurisdictionType>[]()[][]) |
 | AddRange(TaxJurisdictionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(TaxJurisdictionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<TaxJurisdictionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(TaxJurisdictionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, TaxJurisdictionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(TaxJurisdictionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | TaxJurisdictionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► Add(TaxJurisdictionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    TaxJurisdictionType item
)
Public Function Add ( _
    item As TaxJurisdictionType _
) As Integer
public:
int Add(
    TaxJurisdictionType^ item
)
Parameters
item (TaxJurisdictionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<TaxJurisdictionType>[]()[][]) |
 | AddRange(TaxJurisdictionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► AddRange(array<TaxJurisdictionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TaxJurisdictionType[] items
)
Public Sub AddRange ( _
    items As TaxJurisdictionType() _
)
public:
void AddRange(
    array<TaxJurisdictionType^>^ items
)
Parameters
items (array< TaxJurisdictionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► AddRange(TaxJurisdictionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TaxJurisdictionTypeCollection items
)
Public Sub AddRange ( _
    items As TaxJurisdictionTypeCollection _
)
public:
void AddRange(
    TaxJurisdictionTypeCollection^ items
)
Parameters
items (TaxJurisdictionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► Contains(TaxJurisdictionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    TaxJurisdictionType item
)
Public Function Contains ( _
    item As TaxJurisdictionType _
) As Boolean
public:
bool Contains(
    TaxJurisdictionType^ item
)
Parameters
item (TaxJurisdictionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► CopyTo(array<TaxJurisdictionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    TaxJurisdictionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As TaxJurisdictionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<TaxJurisdictionType^>^ items,
    int index
)
Parameters
items (array< TaxJurisdictionType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► IndexOf(TaxJurisdictionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    TaxJurisdictionType item
)
Public Function IndexOf ( _
    item As TaxJurisdictionType _
) As Integer
public:
int IndexOf(
    TaxJurisdictionType^ item
)
Parameters
item (TaxJurisdictionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► Insert(Int32, TaxJurisdictionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    TaxJurisdictionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As TaxJurisdictionType _
)
public:
void Insert(
    int index,
    TaxJurisdictionType^ item
)
Parameters
index (Int32)
item (TaxJurisdictionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As TaxJurisdictionType
    Get
    Set
public:
property TaxJurisdictionType^ default[int index] {
    TaxJurisdictionType^ get (int index);
    void set (int index, TaxJurisdictionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As TaxJurisdictionType
public:
TaxJurisdictionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► Remove(TaxJurisdictionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    TaxJurisdictionType item
)
Public Sub Remove ( _
    item As TaxJurisdictionType _
)
public:
void Remove(
    TaxJurisdictionType^ item
)
Parameters
item (TaxJurisdictionType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


TaxJurisdictionTypeCollection Constructor

TaxJurisdictionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► TaxJurisdictionTypeCollection()()()()
Members
Icon | Member | Description
 | TaxJurisdictionTypeCollection()()()() |
 | TaxJurisdictionTypeCollection(array<TaxJurisdictionType>[]()[][]) |
 | TaxJurisdictionTypeCollection(TaxJurisdictionTypeCollection) |


TaxJurisdictionTypeCollection Constructor

TaxJurisdictionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► TaxJurisdictionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection()
Public Sub New
public:
TaxJurisdictionTypeCollection()


TaxJurisdictionTypeCollection Constructor (items)

TaxJurisdictionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► TaxJurisdictionTypeCollection(array<TaxJurisdictionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection(
    TaxJurisdictionType[] items
)
Public Sub New ( _
    items As TaxJurisdictionType() _
)
public:
TaxJurisdictionTypeCollection(
    array<TaxJurisdictionType^>^ items
)
Parameters
items (array< TaxJurisdictionType >[]()[][])


TaxJurisdictionTypeCollection Constructor (items)

TaxJurisdictionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► TaxJurisdictionTypeCollection(TaxJurisdictionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection(
    TaxJurisdictionTypeCollection items
)
Public Sub New ( _
    items As TaxJurisdictionTypeCollection _
)
public:
TaxJurisdictionTypeCollection(
    TaxJurisdictionTypeCollection^ items
)
Parameters
items (TaxJurisdictionTypeCollection)


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionType[] ToArray()
Public Function ToArray As TaxJurisdictionType()
public:
array<TaxJurisdictionType^>^ ToArray()
Return Value


TaxTypeCodeType Enumeration

TaxTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► TaxTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum TaxTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration TaxTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class TaxTypeCodeType
Members
Member | Description
SalesTax |
WasteRecyclingFee |
CustomCode |
Remarks


TCREnabledDefinitionType Class

TCREnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► TCREnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TCREnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TCREnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TCREnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TCREnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TCREnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TCREnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


TCREnabledDefinitionType Constructor

TCREnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► TCREnabledDefinitionType ► TCREnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TCREnabledDefinitionType()
Public Sub New
public:
TCREnabledDefinitionType()


ThemeGroupType Class

ThemeGroupType Class
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ThemeGroupType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ThemeGroupType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ThemeGroupType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ThemeGroupType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GroupID |
 | GroupIDSpecified |
 | GroupName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ThemeID |
 | ThemeTotal |
 | ThemeTotalSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ThemeGroupType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


GroupID Property

GroupID Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupType ► GroupID
Declaration Syntax
C# Visual Basic Visual C++
public int GroupID { get; set; }
Public Property GroupID As Integer
    Get
    Set
public:
property int GroupID {
    int get ();
    void set (int value);
}


GroupIDSpecified Property

GroupIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupType ► GroupIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GroupIDSpecified { get; set; }
Public Property GroupIDSpecified As Boolean
    Get
    Set
public:
property bool GroupIDSpecified {
    bool get ();
    void set (bool value);
}


GroupName Property

GroupName Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupType ► GroupName
Declaration Syntax
C# Visual Basic Visual C++
public string GroupName { get; set; }
Public Property GroupName As String
    Get
    Set
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}


ThemeGroupType Constructor

ThemeGroupType Constructor
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupType ► ThemeGroupType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ThemeGroupType()
Public Sub New
public:
ThemeGroupType()


ThemeID Property

ThemeID Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupType ► ThemeID
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection ThemeID { get; set; }
Public Property ThemeID As Int32Collection
    Get
    Set
public:
property Int32Collection^ ThemeID {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


ThemeTotal Property

ThemeTotal Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupType ► ThemeTotal
Declaration Syntax
C# Visual Basic Visual C++
public int ThemeTotal { get; set; }
Public Property ThemeTotal As Integer
    Get
    Set
public:
property int ThemeTotal {
    int get ();
    void set (int value);
}


ThemeTotalSpecified Property

ThemeTotalSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupType ► ThemeTotalSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ThemeTotalSpecified { get; set; }
Public Property ThemeTotalSpecified As Boolean
    Get
    Set
public:
property bool ThemeTotalSpecified {
    bool get ();
    void set (bool value);
}


ThemeGroupTypeCollection Class

ThemeGroupTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ThemeGroupTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ThemeGroupTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ThemeGroupTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ThemeGroupTypeCollection()()()() |
 | ThemeGroupTypeCollection(array<ThemeGroupType>[]()[][]) |
 | ThemeGroupTypeCollection(ThemeGroupTypeCollection) |
 | Add(ThemeGroupType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ThemeGroupType>[]()[][]) |
 | AddRange(ThemeGroupTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ThemeGroupType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ThemeGroupType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ThemeGroupType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ThemeGroupType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ThemeGroupType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ThemeGroupTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► Add(ThemeGroupType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ThemeGroupType item
)
Public Function Add ( _
    item As ThemeGroupType _
) As Integer
public:
int Add(
    ThemeGroupType^ item
)
Parameters
item (ThemeGroupType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ThemeGroupType>[]()[][]) |
 | AddRange(ThemeGroupTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► AddRange(array<ThemeGroupType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ThemeGroupType[] items
)
Public Sub AddRange ( _
    items As ThemeGroupType() _
)
public:
void AddRange(
    array<ThemeGroupType^>^ items
)
Parameters
items (array< ThemeGroupType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► AddRange(ThemeGroupTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ThemeGroupTypeCollection items
)
Public Sub AddRange ( _
    items As ThemeGroupTypeCollection _
)
public:
void AddRange(
    ThemeGroupTypeCollection^ items
)
Parameters
items (ThemeGroupTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► Contains(ThemeGroupType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ThemeGroupType item
)
Public Function Contains ( _
    item As ThemeGroupType _
) As Boolean
public:
bool Contains(
    ThemeGroupType^ item
)
Parameters
item (ThemeGroupType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► CopyTo(array<ThemeGroupType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ThemeGroupType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ThemeGroupType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ThemeGroupType^>^ items,
    int index
)
Parameters
items (array< ThemeGroupType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► IndexOf(ThemeGroupType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ThemeGroupType item
)
Public Function IndexOf ( _
    item As ThemeGroupType _
) As Integer
public:
int IndexOf(
    ThemeGroupType^ item
)
Parameters
item (ThemeGroupType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► Insert(Int32, ThemeGroupType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ThemeGroupType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ThemeGroupType _
)
public:
void Insert(
    int index,
    ThemeGroupType^ item
)
Parameters
index (Int32)
item (ThemeGroupType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ThemeGroupType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ThemeGroupType
    Get
    Set
public:
property ThemeGroupType^ default[int index] {
    ThemeGroupType^ get (int index);
    void set (int index, ThemeGroupType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ThemeGroupType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ThemeGroupType
public:
ThemeGroupType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► Remove(ThemeGroupType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ThemeGroupType item
)
Public Sub Remove ( _
    item As ThemeGroupType _
)
public:
void Remove(
    ThemeGroupType^ item
)
Parameters
item (ThemeGroupType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ThemeGroupTypeCollection Constructor

ThemeGroupTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► ThemeGroupTypeCollection()()()()
Members
Icon | Member | Description
 | ThemeGroupTypeCollection()()()() |
 | ThemeGroupTypeCollection(array<ThemeGroupType>[]()[][]) |
 | ThemeGroupTypeCollection(ThemeGroupTypeCollection) |


ThemeGroupTypeCollection Constructor

ThemeGroupTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► ThemeGroupTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ThemeGroupTypeCollection()
Public Sub New
public:
ThemeGroupTypeCollection()


ThemeGroupTypeCollection Constructor (items)

ThemeGroupTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► ThemeGroupTypeCollection(array<ThemeGroupType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ThemeGroupTypeCollection(
    ThemeGroupType[] items
)
Public Sub New ( _
    items As ThemeGroupType() _
)
public:
ThemeGroupTypeCollection(
    array<ThemeGroupType^>^ items
)
Parameters
items (array< ThemeGroupType >[]()[][])


ThemeGroupTypeCollection Constructor (items)

ThemeGroupTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► ThemeGroupTypeCollection(ThemeGroupTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ThemeGroupTypeCollection(
    ThemeGroupTypeCollection items
)
Public Sub New ( _
    items As ThemeGroupTypeCollection _
)
public:
ThemeGroupTypeCollection(
    ThemeGroupTypeCollection^ items
)
Parameters
items (ThemeGroupTypeCollection)


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ThemeGroupType[] ToArray()
Public Function ToArray As ThemeGroupType()
public:
array<ThemeGroupType^>^ ToArray()
Return Value


TicketListingDetailsType Class

TicketListingDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► TicketListingDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TicketListingDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TicketListingDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TicketListingDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TicketListingDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | EventTitle |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PrintedDate |
 | PrintedTime |
 | ToString()()()() | (Inherited from Object.)
 | Venue |
Remarks
Inheritance Hierarchy
Object
TicketListingDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TicketListingDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EventTitle Property

EventTitle Property
Namespaces ► eBay.Service.Core.Soap ► TicketListingDetailsType ► EventTitle
Declaration Syntax
C# Visual Basic Visual C++
public string EventTitle { get; set; }
Public Property EventTitle As String
    Get
    Set
public:
property String^ EventTitle {
    String^ get ();
    void set (String^ value);
}


PrintedDate Property

PrintedDate Property
Namespaces ► eBay.Service.Core.Soap ► TicketListingDetailsType ► PrintedDate
Declaration Syntax
C# Visual Basic Visual C++
public string PrintedDate { get; set; }
Public Property PrintedDate As String
    Get
    Set
public:
property String^ PrintedDate {
    String^ get ();
    void set (String^ value);
}


PrintedTime Property

PrintedTime Property
Namespaces ► eBay.Service.Core.Soap ► TicketListingDetailsType ► PrintedTime
Declaration Syntax
C# Visual Basic Visual C++
public string PrintedTime { get; set; }
Public Property PrintedTime As String
    Get
    Set
public:
property String^ PrintedTime {
    String^ get ();
    void set (String^ value);
}


TicketListingDetailsType Constructor

TicketListingDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► TicketListingDetailsType ► TicketListingDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TicketListingDetailsType()
Public Sub New
public:
TicketListingDetailsType()


Venue Property

Venue Property
Namespaces ► eBay.Service.Core.Soap ► TicketListingDetailsType ► Venue
Declaration Syntax
C# Visual Basic Visual C++
public string Venue { get; set; }
Public Property Venue As String
    Get
    Set
public:
property String^ Venue {
    String^ get ();
    void set (String^ value);
}


TimeFilter Class

TimeFilter Class
Namespaces ► eBay.Service.Core.Soap ► TimeFilter
This class enables specification of time values for DateTime fields. Information and tips about DateTime objects are available in the MSDN library. This class contains properties for both local and GMT (UTC) time. If you use such properties of this class interchangably, the last property that is set overwrites the previous one. Note that if only the properties for local time are used, then the following can occur with an application: A local time (for example, 10 a.m.) is emitted by an application, and the API changes that time to GMT (for example, to 5 p.m.). And a GMT time from the API (for example, 1 p.m.) received by an application is converted to local time (for example, to 6 a.m.).
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class TimeFilter
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class TimeFilter
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class TimeFilter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeFilter()()()() |
 | TimeFilter(DateTime, DateTime) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | TimeFrom | Specifies a "time from" value that uses local computer time, regardless of the .NET Framework version used by the client.
 | TimeFromUTC | Specifies a "time from" value that uses UTC (GMT) time, regardless of the .NET Framework version used by the client.
 | TimeTo | Specifies a "time to" value that uses local computer time, regardless of the .NET Framework version used by the client.
 | TimeToUTC | Specifies a "time to" value that uses UTC (GMT) time, regardless of the .NET Framework version used by the client.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
TimeFilter


TimeFilter Constructor

TimeFilter Constructor
Namespaces ► eBay.Service.Core.Soap ► TimeFilter ► TimeFilter()()()()
Members
Icon | Member | Description
 | TimeFilter()()()() |
 | TimeFilter(DateTime, DateTime) |


TimeFilter Constructor

TimeFilter Constructor
Namespaces ► eBay.Service.Core.Soap ► TimeFilter ► TimeFilter()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter()
Public Sub New
public:
TimeFilter()


TimeFilter Constructor (TimeFrom, TimeTo)

TimeFilter Constructor (TimeFrom, TimeTo)
Namespaces ► eBay.Service.Core.Soap ► TimeFilter ► TimeFilter(DateTime, DateTime)
Declaration Syntax
C# Visual Basic Visual C++
public TimeFilter(
    DateTime TimeFrom,
    DateTime TimeTo
)
Public Sub New ( _
    TimeFrom As DateTime, _
    TimeTo As DateTime _
)
public:
TimeFilter(
    DateTime TimeFrom,
    DateTime TimeTo
)
Parameters
TimeFrom (DateTime)
TimeTo (DateTime)


TimeFrom Property

TimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► TimeFilter ► TimeFrom
Specifies a "time from" value that uses local computer time, regardless of the .NET Framework version used by the client.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeFrom { get; set; }
Public Property TimeFrom As DateTime
    Get
    Set
public:
property DateTime TimeFrom {
    DateTime get ();
    void set (DateTime value);
}


TimeFromUTC Property

TimeFromUTC Property
Namespaces ► eBay.Service.Core.Soap ► TimeFilter ► TimeFromUTC
Specifies a "time from" value that uses UTC (GMT) time, regardless of the .NET Framework version used by the client.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeFromUTC { get; set; }
Public Property TimeFromUTC As DateTime
    Get
    Set
public:
property DateTime TimeFromUTC {
    DateTime get ();
    void set (DateTime value);
}


TimeTo Property

TimeTo Property
Namespaces ► eBay.Service.Core.Soap ► TimeFilter ► TimeTo
Specifies a "time to" value that uses local computer time, regardless of the .NET Framework version used by the client.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeTo { get; set; }
Public Property TimeTo As DateTime
    Get
    Set
public:
property DateTime TimeTo {
    DateTime get ();
    void set (DateTime value);
}


TimeToUTC Property

TimeToUTC Property
Namespaces ► eBay.Service.Core.Soap ► TimeFilter ► TimeToUTC
Specifies a "time to" value that uses UTC (GMT) time, regardless of the .NET Framework version used by the client.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeToUTC { get; set; }
Public Property TimeToUTC As DateTime
    Get
    Set
public:
property DateTime TimeToUTC {
    DateTime get ();
    void set (DateTime value);
}


TimeRangeType Class

TimeRangeType Class
Namespaces ► eBay.Service.Core.Soap ► TimeRangeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TimeRangeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TimeRangeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TimeRangeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeRangeType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | TimeFrom |
 | TimeFromSpecified |
 | TimeTo |
 | TimeToSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TimeRangeType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TimeRangeType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


TimeFrom Property

TimeFrom Property
Namespaces ► eBay.Service.Core.Soap ► TimeRangeType ► TimeFrom
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeFrom { get; set; }
Public Property TimeFrom As DateTime
    Get
    Set
public:
property DateTime TimeFrom {
    DateTime get ();
    void set (DateTime value);
}


TimeFromSpecified Property

TimeFromSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TimeRangeType ► TimeFromSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TimeFromSpecified { get; set; }
Public Property TimeFromSpecified As Boolean
    Get
    Set
public:
property bool TimeFromSpecified {
    bool get ();
    void set (bool value);
}


TimeRangeType Constructor

TimeRangeType Constructor
Namespaces ► eBay.Service.Core.Soap ► TimeRangeType ► TimeRangeType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TimeRangeType()
Public Sub New
public:
TimeRangeType()


TimeTo Property

TimeTo Property
Namespaces ► eBay.Service.Core.Soap ► TimeRangeType ► TimeTo
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeTo { get; set; }
Public Property TimeTo As DateTime
    Get
    Set
public:
property DateTime TimeTo {
    DateTime get ();
    void set (DateTime value);
}


TimeToSpecified Property

TimeToSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TimeRangeType ► TimeToSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TimeToSpecified { get; set; }
Public Property TimeToSpecified As Boolean
    Get
    Set
public:
property bool TimeToSpecified {
    bool get ();
    void set (bool value);
}


TimeZoneDetailsType Class

TimeZoneDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TimeZoneDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TimeZoneDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TimeZoneDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeZoneDetailsType()()()() |
 | Any |
 | DaylightSavingsInEffect |
 | DaylightSavingsInEffectSpecified |
 | DaylightSavingsLabel |
 | DaylightSavingsOffset |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | StandardLabel |
 | StandardOffset |
 | TimeZoneID |
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
TimeZoneDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DaylightSavingsInEffect Property

DaylightSavingsInEffect Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► DaylightSavingsInEffect
Declaration Syntax
C# Visual Basic Visual C++
public bool DaylightSavingsInEffect { get; set; }
Public Property DaylightSavingsInEffect As Boolean
    Get
    Set
public:
property bool DaylightSavingsInEffect {
    bool get ();
    void set (bool value);
}


DaylightSavingsInEffectSpecified Property

DaylightSavingsInEffectSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► DaylightSavingsInEffectSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DaylightSavingsInEffectSpecified { get; set; }
Public Property DaylightSavingsInEffectSpecified As Boolean
    Get
    Set
public:
property bool DaylightSavingsInEffectSpecified {
    bool get ();
    void set (bool value);
}


DaylightSavingsLabel Property

DaylightSavingsLabel Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► DaylightSavingsLabel
Declaration Syntax
C# Visual Basic Visual C++
public string DaylightSavingsLabel { get; set; }
Public Property DaylightSavingsLabel As String
    Get
    Set
public:
property String^ DaylightSavingsLabel {
    String^ get ();
    void set (String^ value);
}


DaylightSavingsOffset Property

DaylightSavingsOffset Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► DaylightSavingsOffset
Declaration Syntax
C# Visual Basic Visual C++
public string DaylightSavingsOffset { get; set; }
Public Property DaylightSavingsOffset As String
    Get
    Set
public:
property String^ DaylightSavingsOffset {
    String^ get ();
    void set (String^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


StandardLabel Property

StandardLabel Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► StandardLabel
Declaration Syntax
C# Visual Basic Visual C++
public string StandardLabel { get; set; }
Public Property StandardLabel As String
    Get
    Set
public:
property String^ StandardLabel {
    String^ get ();
    void set (String^ value);
}


StandardOffset Property

StandardOffset Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► StandardOffset
Declaration Syntax
C# Visual Basic Visual C++
public string StandardOffset { get; set; }
Public Property StandardOffset As String
    Get
    Set
public:
property String^ StandardOffset {
    String^ get ();
    void set (String^ value);
}


TimeZoneDetailsType Constructor

TimeZoneDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► TimeZoneDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TimeZoneDetailsType()
Public Sub New
public:
TimeZoneDetailsType()


TimeZoneID Property

TimeZoneID Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► TimeZoneID
Declaration Syntax
C# Visual Basic Visual C++
public string TimeZoneID { get; set; }
Public Property TimeZoneID As String
    Get
    Set
public:
property String^ TimeZoneID {
    String^ get ();
    void set (String^ value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


TimeZoneDetailsTypeCollection Class

TimeZoneDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class TimeZoneDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class TimeZoneDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class TimeZoneDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeZoneDetailsTypeCollection()()()() |
 | TimeZoneDetailsTypeCollection(array<TimeZoneDetailsType>[]()[][]) |
 | TimeZoneDetailsTypeCollection(TimeZoneDetailsTypeCollection) |
 | Add(TimeZoneDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<TimeZoneDetailsType>[]()[][]) |
 | AddRange(TimeZoneDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(TimeZoneDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<TimeZoneDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(TimeZoneDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, TimeZoneDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(TimeZoneDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | TimeZoneDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► Add(TimeZoneDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    TimeZoneDetailsType item
)
Public Function Add ( _
    item As TimeZoneDetailsType _
) As Integer
public:
int Add(
    TimeZoneDetailsType^ item
)
Parameters
item (TimeZoneDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<TimeZoneDetailsType>[]()[][]) |
 | AddRange(TimeZoneDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► AddRange(array<TimeZoneDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TimeZoneDetailsType[] items
)
Public Sub AddRange ( _
    items As TimeZoneDetailsType() _
)
public:
void AddRange(
    array<TimeZoneDetailsType^>^ items
)
Parameters
items (array< TimeZoneDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► AddRange(TimeZoneDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TimeZoneDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As TimeZoneDetailsTypeCollection _
)
public:
void AddRange(
    TimeZoneDetailsTypeCollection^ items
)
Parameters
items (TimeZoneDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► Contains(TimeZoneDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    TimeZoneDetailsType item
)
Public Function Contains ( _
    item As TimeZoneDetailsType _
) As Boolean
public:
bool Contains(
    TimeZoneDetailsType^ item
)
Parameters
item (TimeZoneDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► CopyTo(array<TimeZoneDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    TimeZoneDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As TimeZoneDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<TimeZoneDetailsType^>^ items,
    int index
)
Parameters
items (array< TimeZoneDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► IndexOf(TimeZoneDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    TimeZoneDetailsType item
)
Public Function IndexOf ( _
    item As TimeZoneDetailsType _
) As Integer
public:
int IndexOf(
    TimeZoneDetailsType^ item
)
Parameters
item (TimeZoneDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► Insert(Int32, TimeZoneDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    TimeZoneDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As TimeZoneDetailsType _
)
public:
void Insert(
    int index,
    TimeZoneDetailsType^ item
)
Parameters
index (Int32)
item (TimeZoneDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public TimeZoneDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As TimeZoneDetailsType
    Get
    Set
public:
property TimeZoneDetailsType^ default[int index] {
    TimeZoneDetailsType^ get (int index);
    void set (int index, TimeZoneDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public TimeZoneDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As TimeZoneDetailsType
public:
TimeZoneDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► Remove(TimeZoneDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    TimeZoneDetailsType item
)
Public Sub Remove ( _
    item As TimeZoneDetailsType _
)
public:
void Remove(
    TimeZoneDetailsType^ item
)
Parameters
item (TimeZoneDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


TimeZoneDetailsTypeCollection Constructor

TimeZoneDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► TimeZoneDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | TimeZoneDetailsTypeCollection()()()() |
 | TimeZoneDetailsTypeCollection(array<TimeZoneDetailsType>[]()[][]) |
 | TimeZoneDetailsTypeCollection(TimeZoneDetailsTypeCollection) |


TimeZoneDetailsTypeCollection Constructor

TimeZoneDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► TimeZoneDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TimeZoneDetailsTypeCollection()
Public Sub New
public:
TimeZoneDetailsTypeCollection()


TimeZoneDetailsTypeCollection Constructor (items)

TimeZoneDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► TimeZoneDetailsTypeCollection(array<TimeZoneDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public TimeZoneDetailsTypeCollection(
    TimeZoneDetailsType[] items
)
Public Sub New ( _
    items As TimeZoneDetailsType() _
)
public:
TimeZoneDetailsTypeCollection(
    array<TimeZoneDetailsType^>^ items
)
Parameters
items (array< TimeZoneDetailsType >[]()[][])


TimeZoneDetailsTypeCollection Constructor (items)

TimeZoneDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► TimeZoneDetailsTypeCollection(TimeZoneDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public TimeZoneDetailsTypeCollection(
    TimeZoneDetailsTypeCollection items
)
Public Sub New ( _
    items As TimeZoneDetailsTypeCollection _
)
public:
TimeZoneDetailsTypeCollection(
    TimeZoneDetailsTypeCollection^ items
)
Parameters
items (TimeZoneDetailsTypeCollection)


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TimeZoneDetailsType[] ToArray()
Public Function ToArray As TimeZoneDetailsType()
public:
array<TimeZoneDetailsType^>^ ToArray()
Return Value


TokenStatusCodeType Enumeration

TokenStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► TokenStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum TokenStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration TokenStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class TokenStatusCodeType
Members
Member | Description
Active |
Expired |
RevokedByeBay |
RevokedByUser |
RevokedByApp |
Invalid |
CustomCode |
Remarks


TokenStatusType Class

TokenStatusType Class
Namespaces ► eBay.Service.Core.Soap ► TokenStatusType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TokenStatusType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TokenStatusType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TokenStatusType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TokenStatusType()()()() |
 | Any |
 | EIASToken |
 | Equals(Object) | (Inherited from Object.)
 | ExpirationTime |
 | ExpirationTimeSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RevocationTime |
 | RevocationTimeSpecified |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TokenStatusType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TokenStatusType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EIASToken Property

EIASToken Property
Namespaces ► eBay.Service.Core.Soap ► TokenStatusType ► EIASToken
Declaration Syntax
C# Visual Basic Visual C++
public string EIASToken { get; set; }
Public Property EIASToken As String
    Get
    Set
public:
property String^ EIASToken {
    String^ get ();
    void set (String^ value);
}


ExpirationTime Property

ExpirationTime Property
Namespaces ► eBay.Service.Core.Soap ► TokenStatusType ► ExpirationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ExpirationTime { get; set; }
Public Property ExpirationTime As DateTime
    Get
    Set
public:
property DateTime ExpirationTime {
    DateTime get ();
    void set (DateTime value);
}


ExpirationTimeSpecified Property

ExpirationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TokenStatusType ► ExpirationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpirationTimeSpecified { get; set; }
Public Property ExpirationTimeSpecified As Boolean
    Get
    Set
public:
property bool ExpirationTimeSpecified {
    bool get ();
    void set (bool value);
}


RevocationTime Property

RevocationTime Property
Namespaces ► eBay.Service.Core.Soap ► TokenStatusType ► RevocationTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RevocationTime { get; set; }
Public Property RevocationTime As DateTime
    Get
    Set
public:
property DateTime RevocationTime {
    DateTime get ();
    void set (DateTime value);
}


RevocationTimeSpecified Property

RevocationTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TokenStatusType ► RevocationTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RevocationTimeSpecified { get; set; }
Public Property RevocationTimeSpecified As Boolean
    Get
    Set
public:
property bool RevocationTimeSpecified {
    bool get ();
    void set (bool value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► TokenStatusType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public TokenStatusCodeType Status { get; set; }
Public Property Status As TokenStatusCodeType
    Get
    Set
public:
property TokenStatusCodeType Status {
    TokenStatusCodeType get ();
    void set (TokenStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TokenStatusType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


TokenStatusType Constructor

TokenStatusType Constructor
Namespaces ► eBay.Service.Core.Soap ► TokenStatusType ► TokenStatusType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TokenStatusType()
Public Sub New
public:
TokenStatusType()


TopRatedProgramCodeType Enumeration

TopRatedProgramCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum TopRatedProgramCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration TopRatedProgramCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class TopRatedProgramCodeType
Members
Member | Description
US |
UK |
DE |
Global |
CustomCode |
Remarks


TopRatedProgramCodeTypeCollection Class

TopRatedProgramCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class TopRatedProgramCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class TopRatedProgramCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class TopRatedProgramCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TopRatedProgramCodeTypeCollection()()()() |
 | TopRatedProgramCodeTypeCollection(array<TopRatedProgramCodeType>[]()[][]) |
 | TopRatedProgramCodeTypeCollection(TopRatedProgramCodeTypeCollection) |
 | Add(TopRatedProgramCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<TopRatedProgramCodeType>[]()[][]) |
 | AddRange(TopRatedProgramCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(TopRatedProgramCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<TopRatedProgramCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(TopRatedProgramCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, TopRatedProgramCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(TopRatedProgramCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | TopRatedProgramCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► Add(TopRatedProgramCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    TopRatedProgramCodeType item
)
Public Function Add ( _
    item As TopRatedProgramCodeType _
) As Integer
public:
int Add(
    TopRatedProgramCodeType item
)
Parameters
item (TopRatedProgramCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<TopRatedProgramCodeType>[]()[][]) |
 | AddRange(TopRatedProgramCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► AddRange(array<TopRatedProgramCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TopRatedProgramCodeType[] items
)
Public Sub AddRange ( _
    items As TopRatedProgramCodeType() _
)
public:
void AddRange(
    array<TopRatedProgramCodeType>^ items
)
Parameters
items (array< TopRatedProgramCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► AddRange(TopRatedProgramCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TopRatedProgramCodeTypeCollection items
)
Public Sub AddRange ( _
    items As TopRatedProgramCodeTypeCollection _
)
public:
void AddRange(
    TopRatedProgramCodeTypeCollection^ items
)
Parameters
items (TopRatedProgramCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► Contains(TopRatedProgramCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    TopRatedProgramCodeType item
)
Public Function Contains ( _
    item As TopRatedProgramCodeType _
) As Boolean
public:
bool Contains(
    TopRatedProgramCodeType item
)
Parameters
item (TopRatedProgramCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► CopyTo(array<TopRatedProgramCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    TopRatedProgramCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As TopRatedProgramCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<TopRatedProgramCodeType>^ items,
    int index
)
Parameters
items (array< TopRatedProgramCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► IndexOf(TopRatedProgramCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    TopRatedProgramCodeType item
)
Public Function IndexOf ( _
    item As TopRatedProgramCodeType _
) As Integer
public:
int IndexOf(
    TopRatedProgramCodeType item
)
Parameters
item (TopRatedProgramCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► Insert(Int32, TopRatedProgramCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    TopRatedProgramCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As TopRatedProgramCodeType _
)
public:
void Insert(
    int index,
    TopRatedProgramCodeType item
)
Parameters
index (Int32)
item (TopRatedProgramCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public TopRatedProgramCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As TopRatedProgramCodeType
    Get
    Set
public:
property TopRatedProgramCodeType default[int index] {
    TopRatedProgramCodeType get (int index);
    void set (int index, TopRatedProgramCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public TopRatedProgramCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As TopRatedProgramCodeType
public:
TopRatedProgramCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► Remove(TopRatedProgramCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    TopRatedProgramCodeType item
)
Public Sub Remove ( _
    item As TopRatedProgramCodeType _
)
public:
void Remove(
    TopRatedProgramCodeType item
)
Parameters
item (TopRatedProgramCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TopRatedProgramCodeType[] ToArray()
Public Function ToArray As TopRatedProgramCodeType()
public:
array<TopRatedProgramCodeType>^ ToArray()
Return Value


TopRatedProgramCodeTypeCollection Constructor

TopRatedProgramCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► TopRatedProgramCodeTypeCollection()()()()
Members
Icon | Member | Description
 | TopRatedProgramCodeTypeCollection()()()() |
 | TopRatedProgramCodeTypeCollection(array<TopRatedProgramCodeType>[]()[][]) |
 | TopRatedProgramCodeTypeCollection(TopRatedProgramCodeTypeCollection) |


TopRatedProgramCodeTypeCollection Constructor

TopRatedProgramCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► TopRatedProgramCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TopRatedProgramCodeTypeCollection()
Public Sub New
public:
TopRatedProgramCodeTypeCollection()


TopRatedProgramCodeTypeCollection Constructor (items)

TopRatedProgramCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► TopRatedProgramCodeTypeCollection(array<TopRatedProgramCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public TopRatedProgramCodeTypeCollection(
    TopRatedProgramCodeType[] items
)
Public Sub New ( _
    items As TopRatedProgramCodeType() _
)
public:
TopRatedProgramCodeTypeCollection(
    array<TopRatedProgramCodeType>^ items
)
Parameters
items (array< TopRatedProgramCodeType >[]()[][])


TopRatedProgramCodeTypeCollection Constructor (items)

TopRatedProgramCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► TopRatedProgramCodeTypeCollection(TopRatedProgramCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public TopRatedProgramCodeTypeCollection(
    TopRatedProgramCodeTypeCollection items
)
Public Sub New ( _
    items As TopRatedProgramCodeTypeCollection _
)
public:
TopRatedProgramCodeTypeCollection(
    TopRatedProgramCodeTypeCollection^ items
)
Parameters
items (TopRatedProgramCodeTypeCollection)


TopRatedSellerDetailsType Class

TopRatedSellerDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► TopRatedSellerDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TopRatedSellerDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TopRatedSellerDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TopRatedSellerDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TopRatedSellerDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | TopRatedProgram |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TopRatedSellerDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TopRatedSellerDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


TopRatedProgram Property

TopRatedProgram Property
Namespaces ► eBay.Service.Core.Soap ► TopRatedSellerDetailsType ► TopRatedProgram
Declaration Syntax
C# Visual Basic Visual C++
public TopRatedProgramCodeTypeCollection TopRatedProgram { get; set; }
Public Property TopRatedProgram As TopRatedProgramCodeTypeCollection
    Get
    Set
public:
property TopRatedProgramCodeTypeCollection^ TopRatedProgram {
    TopRatedProgramCodeTypeCollection^ get ();
    void set (TopRatedProgramCodeTypeCollection^ value);
}


TopRatedSellerDetailsType Constructor

TopRatedSellerDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► TopRatedSellerDetailsType ► TopRatedSellerDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TopRatedSellerDetailsType()
Public Sub New
public:
TopRatedSellerDetailsType()


TradingRoleCodeType Enumeration

TradingRoleCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► TradingRoleCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum TradingRoleCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration TradingRoleCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class TradingRoleCodeType
Members
Member | Description
Buyer |
Seller |
CustomCode |
Remarks


TransactionPlatformCodeType Enumeration

TransactionPlatformCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum TransactionPlatformCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration TransactionPlatformCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class TransactionPlatformCodeType
Members
Member | Description
eBay |
Express |
Half |
Shopping |
WorldOfGood |
CustomCode |
Remarks


TransactionPlatformCodeTypeCollection Class

TransactionPlatformCodeTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class TransactionPlatformCodeTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class TransactionPlatformCodeTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class TransactionPlatformCodeTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransactionPlatformCodeTypeCollection()()()() |
 | TransactionPlatformCodeTypeCollection(array<TransactionPlatformCodeType>[]()[][]) |
 | TransactionPlatformCodeTypeCollection(TransactionPlatformCodeTypeCollection) |
 | Add(TransactionPlatformCodeType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<TransactionPlatformCodeType>[]()[][]) |
 | AddRange(TransactionPlatformCodeTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(TransactionPlatformCodeType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<TransactionPlatformCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(TransactionPlatformCodeType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, TransactionPlatformCodeType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(TransactionPlatformCodeType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | TransactionPlatformCodeTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► Add(TransactionPlatformCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    TransactionPlatformCodeType item
)
Public Function Add ( _
    item As TransactionPlatformCodeType _
) As Integer
public:
int Add(
    TransactionPlatformCodeType item
)
Parameters
item (TransactionPlatformCodeType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<TransactionPlatformCodeType>[]()[][]) |
 | AddRange(TransactionPlatformCodeTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► AddRange(array<TransactionPlatformCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TransactionPlatformCodeType[] items
)
Public Sub AddRange ( _
    items As TransactionPlatformCodeType() _
)
public:
void AddRange(
    array<TransactionPlatformCodeType>^ items
)
Parameters
items (array< TransactionPlatformCodeType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► AddRange(TransactionPlatformCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TransactionPlatformCodeTypeCollection items
)
Public Sub AddRange ( _
    items As TransactionPlatformCodeTypeCollection _
)
public:
void AddRange(
    TransactionPlatformCodeTypeCollection^ items
)
Parameters
items (TransactionPlatformCodeTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► Contains(TransactionPlatformCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    TransactionPlatformCodeType item
)
Public Function Contains ( _
    item As TransactionPlatformCodeType _
) As Boolean
public:
bool Contains(
    TransactionPlatformCodeType item
)
Parameters
item (TransactionPlatformCodeType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► CopyTo(array<TransactionPlatformCodeType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    TransactionPlatformCodeType[] items,
    int index
)
Public Sub CopyTo ( _
    items As TransactionPlatformCodeType(), _
    index As Integer _
)
public:
void CopyTo(
    array<TransactionPlatformCodeType>^ items,
    int index
)
Parameters
items (array< TransactionPlatformCodeType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► IndexOf(TransactionPlatformCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    TransactionPlatformCodeType item
)
Public Function IndexOf ( _
    item As TransactionPlatformCodeType _
) As Integer
public:
int IndexOf(
    TransactionPlatformCodeType item
)
Parameters
item (TransactionPlatformCodeType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► Insert(Int32, TransactionPlatformCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    TransactionPlatformCodeType item
)
Public Sub Insert ( _
    index As Integer, _
    item As TransactionPlatformCodeType _
)
public:
void Insert(
    int index,
    TransactionPlatformCodeType item
)
Parameters
index (Int32)
item (TransactionPlatformCodeType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As TransactionPlatformCodeType
    Get
    Set
public:
property TransactionPlatformCodeType default[int index] {
    TransactionPlatformCodeType get (int index);
    void set (int index, TransactionPlatformCodeType value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As TransactionPlatformCodeType
public:
TransactionPlatformCodeType ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► Remove(TransactionPlatformCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    TransactionPlatformCodeType item
)
Public Sub Remove ( _
    item As TransactionPlatformCodeType _
)
public:
void Remove(
    TransactionPlatformCodeType item
)
Parameters
item (TransactionPlatformCodeType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeType[] ToArray()
Public Function ToArray As TransactionPlatformCodeType()
public:
array<TransactionPlatformCodeType>^ ToArray()
Return Value


TransactionPlatformCodeTypeCollection Constructor

TransactionPlatformCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► TransactionPlatformCodeTypeCollection()()()()
Members
Icon | Member | Description
 | TransactionPlatformCodeTypeCollection()()()() |
 | TransactionPlatformCodeTypeCollection(array<TransactionPlatformCodeType>[]()[][]) |
 | TransactionPlatformCodeTypeCollection(TransactionPlatformCodeTypeCollection) |


TransactionPlatformCodeTypeCollection Constructor

TransactionPlatformCodeTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► TransactionPlatformCodeTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeTypeCollection()
Public Sub New
public:
TransactionPlatformCodeTypeCollection()


TransactionPlatformCodeTypeCollection Constructor (items)

TransactionPlatformCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► TransactionPlatformCodeTypeCollection(array<TransactionPlatformCodeType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeTypeCollection(
    TransactionPlatformCodeType[] items
)
Public Sub New ( _
    items As TransactionPlatformCodeType() _
)
public:
TransactionPlatformCodeTypeCollection(
    array<TransactionPlatformCodeType>^ items
)
Parameters
items (array< TransactionPlatformCodeType >[]()[][])


TransactionPlatformCodeTypeCollection Constructor (items)

TransactionPlatformCodeTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► TransactionPlatformCodeTypeCollection(TransactionPlatformCodeTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeTypeCollection(
    TransactionPlatformCodeTypeCollection items
)
Public Sub New ( _
    items As TransactionPlatformCodeTypeCollection _
)
public:
TransactionPlatformCodeTypeCollection(
    TransactionPlatformCodeTypeCollection^ items
)
Parameters
items (TransactionPlatformCodeTypeCollection)


TransactionReferenceCodeType Enumeration

TransactionReferenceCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum TransactionReferenceCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration TransactionReferenceCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class TransactionReferenceCodeType
Members
Member | Description
ExternalTransactionID |
MandateReferenceNumber |
CustomCode |
Remarks


TransactionReferenceType Class

TransactionReferenceType Class
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TransactionReferenceType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TransactionReferenceType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TransactionReferenceType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransactionReferenceType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | type |
 | typeSpecified |
 | Value |
Remarks
Inheritance Hierarchy
Object
TransactionReferenceType


TransactionReferenceType Constructor

TransactionReferenceType Constructor
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceType ► TransactionReferenceType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TransactionReferenceType()
Public Sub New
public:
TransactionReferenceType()


type Property

type Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceType ► type
Declaration Syntax
C# Visual Basic Visual C++
public TransactionReferenceCodeType type { get; set; }
Public Property type As TransactionReferenceCodeType
    Get
    Set
public:
property TransactionReferenceCodeType type {
    TransactionReferenceCodeType get ();
    void set (TransactionReferenceCodeType value);
}


typeSpecified Property

typeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceType ► typeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool typeSpecified { get; set; }
Public Property typeSpecified As Boolean
    Get
    Set
public:
property bool typeSpecified {
    bool get ();
    void set (bool value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


TransactionReferenceTypeCollection Class

TransactionReferenceTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class TransactionReferenceTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class TransactionReferenceTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class TransactionReferenceTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransactionReferenceTypeCollection()()()() |
 | TransactionReferenceTypeCollection(array<TransactionReferenceType>[]()[][]) |
 | TransactionReferenceTypeCollection(TransactionReferenceTypeCollection) |
 | Add(TransactionReferenceType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<TransactionReferenceType>[]()[][]) |
 | AddRange(TransactionReferenceTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(TransactionReferenceType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<TransactionReferenceType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(TransactionReferenceType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, TransactionReferenceType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(TransactionReferenceType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | TransactionReferenceTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► Add(TransactionReferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    TransactionReferenceType item
)
Public Function Add ( _
    item As TransactionReferenceType _
) As Integer
public:
int Add(
    TransactionReferenceType^ item
)
Parameters
item (TransactionReferenceType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<TransactionReferenceType>[]()[][]) |
 | AddRange(TransactionReferenceTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► AddRange(array<TransactionReferenceType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TransactionReferenceType[] items
)
Public Sub AddRange ( _
    items As TransactionReferenceType() _
)
public:
void AddRange(
    array<TransactionReferenceType^>^ items
)
Parameters
items (array< TransactionReferenceType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► AddRange(TransactionReferenceTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TransactionReferenceTypeCollection items
)
Public Sub AddRange ( _
    items As TransactionReferenceTypeCollection _
)
public:
void AddRange(
    TransactionReferenceTypeCollection^ items
)
Parameters
items (TransactionReferenceTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► Contains(TransactionReferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    TransactionReferenceType item
)
Public Function Contains ( _
    item As TransactionReferenceType _
) As Boolean
public:
bool Contains(
    TransactionReferenceType^ item
)
Parameters
item (TransactionReferenceType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► CopyTo(array<TransactionReferenceType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    TransactionReferenceType[] items,
    int index
)
Public Sub CopyTo ( _
    items As TransactionReferenceType(), _
    index As Integer _
)
public:
void CopyTo(
    array<TransactionReferenceType^>^ items,
    int index
)
Parameters
items (array< TransactionReferenceType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► IndexOf(TransactionReferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    TransactionReferenceType item
)
Public Function IndexOf ( _
    item As TransactionReferenceType _
) As Integer
public:
int IndexOf(
    TransactionReferenceType^ item
)
Parameters
item (TransactionReferenceType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► Insert(Int32, TransactionReferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    TransactionReferenceType item
)
Public Sub Insert ( _
    index As Integer, _
    item As TransactionReferenceType _
)
public:
void Insert(
    int index,
    TransactionReferenceType^ item
)
Parameters
index (Int32)
item (TransactionReferenceType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public TransactionReferenceType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As TransactionReferenceType
    Get
    Set
public:
property TransactionReferenceType^ default[int index] {
    TransactionReferenceType^ get (int index);
    void set (int index, TransactionReferenceType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public TransactionReferenceType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As TransactionReferenceType
public:
TransactionReferenceType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► Remove(TransactionReferenceType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    TransactionReferenceType item
)
Public Sub Remove ( _
    item As TransactionReferenceType _
)
public:
void Remove(
    TransactionReferenceType^ item
)
Parameters
item (TransactionReferenceType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TransactionReferenceType[] ToArray()
Public Function ToArray As TransactionReferenceType()
public:
array<TransactionReferenceType^>^ ToArray()
Return Value


TransactionReferenceTypeCollection Constructor

TransactionReferenceTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► TransactionReferenceTypeCollection()()()()
Members
Icon | Member | Description
 | TransactionReferenceTypeCollection()()()() |
 | TransactionReferenceTypeCollection(array<TransactionReferenceType>[]()[][]) |
 | TransactionReferenceTypeCollection(TransactionReferenceTypeCollection) |


TransactionReferenceTypeCollection Constructor

TransactionReferenceTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► TransactionReferenceTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TransactionReferenceTypeCollection()
Public Sub New
public:
TransactionReferenceTypeCollection()


TransactionReferenceTypeCollection Constructor (items)

TransactionReferenceTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► TransactionReferenceTypeCollection(array<TransactionReferenceType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public TransactionReferenceTypeCollection(
    TransactionReferenceType[] items
)
Public Sub New ( _
    items As TransactionReferenceType() _
)
public:
TransactionReferenceTypeCollection(
    array<TransactionReferenceType^>^ items
)
Parameters
items (array< TransactionReferenceType >[]()[][])


TransactionReferenceTypeCollection Constructor (items)

TransactionReferenceTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► TransactionReferenceTypeCollection(TransactionReferenceTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public TransactionReferenceTypeCollection(
    TransactionReferenceTypeCollection items
)
Public Sub New ( _
    items As TransactionReferenceTypeCollection _
)
public:
TransactionReferenceTypeCollection(
    TransactionReferenceTypeCollection^ items
)
Parameters
items (TransactionReferenceTypeCollection)


TransactionStatusType Class

TransactionStatusType Class
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TransactionStatusType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TransactionStatusType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TransactionStatusType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransactionStatusType()()()() |
 | Any |
 | BuyerSelectedShipping |
 | BuyerSelectedShippingSpecified |
 | CancelStatus |
 | CancelStatusSpecified |
 | CheckoutStatus |
 | CheckoutStatusSpecified |
 | CompleteStatus |
 | CompleteStatusSpecified |
 | DigitalStatus |
 | DigitalStatusSpecified |
 | eBayPaymentMismatchDetails |
 | eBayPaymentStatus |
 | eBayPaymentStatusSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InquiryStatus |
 | InquiryStatusSpecified |
 | IntegratedMerchantCreditCardEnabled |
 | IntegratedMerchantCreditCardEnabledSpecified |
 | LastTimeModified |
 | LastTimeModifiedSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PaymentHoldStatus |
 | PaymentHoldStatusSpecified |
 | PaymentInstrument |
 | PaymentInstrumentSpecified |
 | PaymentMethodUsed |
 | PaymentMethodUsedSpecified |
 | ReturnStatus |
 | ReturnStatusSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TransactionStatusType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BuyerSelectedShipping Property

BuyerSelectedShipping Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► BuyerSelectedShipping
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerSelectedShipping { get; set; }
Public Property BuyerSelectedShipping As Boolean
    Get
    Set
public:
property bool BuyerSelectedShipping {
    bool get ();
    void set (bool value);
}


BuyerSelectedShippingSpecified Property

BuyerSelectedShippingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► BuyerSelectedShippingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerSelectedShippingSpecified { get; set; }
Public Property BuyerSelectedShippingSpecified As Boolean
    Get
    Set
public:
property bool BuyerSelectedShippingSpecified {
    bool get ();
    void set (bool value);
}


CancelStatus Property

CancelStatus Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► CancelStatus
Declaration Syntax
C# Visual Basic Visual C++
public CancelStatusCodeType CancelStatus { get; set; }
Public Property CancelStatus As CancelStatusCodeType
    Get
    Set
public:
property CancelStatusCodeType CancelStatus {
    CancelStatusCodeType get ();
    void set (CancelStatusCodeType value);
}


CancelStatusSpecified Property

CancelStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► CancelStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CancelStatusSpecified { get; set; }
Public Property CancelStatusSpecified As Boolean
    Get
    Set
public:
property bool CancelStatusSpecified {
    bool get ();
    void set (bool value);
}


CheckoutStatus Property

CheckoutStatus Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► CheckoutStatus
Declaration Syntax
C# Visual Basic Visual C++
public CheckoutStatusCodeType CheckoutStatus { get; set; }
Public Property CheckoutStatus As CheckoutStatusCodeType
    Get
    Set
public:
property CheckoutStatusCodeType CheckoutStatus {
    CheckoutStatusCodeType get ();
    void set (CheckoutStatusCodeType value);
}


CheckoutStatusSpecified Property

CheckoutStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► CheckoutStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckoutStatusSpecified { get; set; }
Public Property CheckoutStatusSpecified As Boolean
    Get
    Set
public:
property bool CheckoutStatusSpecified {
    bool get ();
    void set (bool value);
}


CompleteStatus Property

CompleteStatus Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► CompleteStatus
Declaration Syntax
C# Visual Basic Visual C++
public CompleteStatusCodeType CompleteStatus { get; set; }
Public Property CompleteStatus As CompleteStatusCodeType
    Get
    Set
public:
property CompleteStatusCodeType CompleteStatus {
    CompleteStatusCodeType get ();
    void set (CompleteStatusCodeType value);
}


CompleteStatusSpecified Property

CompleteStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► CompleteStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CompleteStatusSpecified { get; set; }
Public Property CompleteStatusSpecified As Boolean
    Get
    Set
public:
property bool CompleteStatusSpecified {
    bool get ();
    void set (bool value);
}


DigitalStatus Property

DigitalStatus Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► DigitalStatus
Declaration Syntax
C# Visual Basic Visual C++
public DigitalStatusCodeType DigitalStatus { get; set; }
Public Property DigitalStatus As DigitalStatusCodeType
    Get
    Set
public:
property DigitalStatusCodeType DigitalStatus {
    DigitalStatusCodeType get ();
    void set (DigitalStatusCodeType value);
}


DigitalStatusSpecified Property

DigitalStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► DigitalStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DigitalStatusSpecified { get; set; }
Public Property DigitalStatusSpecified As Boolean
    Get
    Set
public:
property bool DigitalStatusSpecified {
    bool get ();
    void set (bool value);
}


eBayPaymentMismatchDetails Property

eBayPaymentMismatchDetails Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► eBayPaymentMismatchDetails
Declaration Syntax
C# Visual Basic Visual C++
public eBayPaymentMismatchDetailsType eBayPaymentMismatchDetails { get; set; }
Public Property eBayPaymentMismatchDetails As eBayPaymentMismatchDetailsType
    Get
    Set
public:
property eBayPaymentMismatchDetailsType^ eBayPaymentMismatchDetails {
    eBayPaymentMismatchDetailsType^ get ();
    void set (eBayPaymentMismatchDetailsType^ value);
}


eBayPaymentStatus Property

eBayPaymentStatus Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► eBayPaymentStatus
Declaration Syntax
C# Visual Basic Visual C++
public PaymentStatusCodeType eBayPaymentStatus { get; set; }
Public Property eBayPaymentStatus As PaymentStatusCodeType
    Get
    Set
public:
property PaymentStatusCodeType eBayPaymentStatus {
    PaymentStatusCodeType get ();
    void set (PaymentStatusCodeType value);
}


eBayPaymentStatusSpecified Property

eBayPaymentStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► eBayPaymentStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayPaymentStatusSpecified { get; set; }
Public Property eBayPaymentStatusSpecified As Boolean
    Get
    Set
public:
property bool eBayPaymentStatusSpecified {
    bool get ();
    void set (bool value);
}


InquiryStatus Property

InquiryStatus Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► InquiryStatus
Declaration Syntax
C# Visual Basic Visual C++
public InquiryStatusCodeType InquiryStatus { get; set; }
Public Property InquiryStatus As InquiryStatusCodeType
    Get
    Set
public:
property InquiryStatusCodeType InquiryStatus {
    InquiryStatusCodeType get ();
    void set (InquiryStatusCodeType value);
}


InquiryStatusSpecified Property

InquiryStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► InquiryStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InquiryStatusSpecified { get; set; }
Public Property InquiryStatusSpecified As Boolean
    Get
    Set
public:
property bool InquiryStatusSpecified {
    bool get ();
    void set (bool value);
}


IntegratedMerchantCreditCardEnabled Property

IntegratedMerchantCreditCardEnabled Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► IntegratedMerchantCreditCardEnabled
Declaration Syntax
C# Visual Basic Visual C++
public bool IntegratedMerchantCreditCardEnabled { get; set; }
Public Property IntegratedMerchantCreditCardEnabled As Boolean
    Get
    Set
public:
property bool IntegratedMerchantCreditCardEnabled {
    bool get ();
    void set (bool value);
}


IntegratedMerchantCreditCardEnabledSpecified Property

IntegratedMerchantCreditCardEnabledSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► IntegratedMerchantCreditCardEnabledSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IntegratedMerchantCreditCardEnabledSpecified { get; set; }
Public Property IntegratedMerchantCreditCardEnabledSpecified As Boolean
    Get
    Set
public:
property bool IntegratedMerchantCreditCardEnabledSpecified {
    bool get ();
    void set (bool value);
}


LastTimeModified Property

LastTimeModified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► LastTimeModified
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastTimeModified { get; set; }
Public Property LastTimeModified As DateTime
    Get
    Set
public:
property DateTime LastTimeModified {
    DateTime get ();
    void set (DateTime value);
}


LastTimeModifiedSpecified Property

LastTimeModifiedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► LastTimeModifiedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool LastTimeModifiedSpecified { get; set; }
Public Property LastTimeModifiedSpecified As Boolean
    Get
    Set
public:
property bool LastTimeModifiedSpecified {
    bool get ();
    void set (bool value);
}


PaymentHoldStatus Property

PaymentHoldStatus Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► PaymentHoldStatus
Declaration Syntax
C# Visual Basic Visual C++
public PaymentHoldStatusCodeType PaymentHoldStatus { get; set; }
Public Property PaymentHoldStatus As PaymentHoldStatusCodeType
    Get
    Set
public:
property PaymentHoldStatusCodeType PaymentHoldStatus {
    PaymentHoldStatusCodeType get ();
    void set (PaymentHoldStatusCodeType value);
}


PaymentHoldStatusSpecified Property

PaymentHoldStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► PaymentHoldStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentHoldStatusSpecified { get; set; }
Public Property PaymentHoldStatusSpecified As Boolean
    Get
    Set
public:
property bool PaymentHoldStatusSpecified {
    bool get ();
    void set (bool value);
}


PaymentInstrument Property

PaymentInstrument Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► PaymentInstrument
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentInstrumentCodeType PaymentInstrument { get; set; }
Public Property PaymentInstrument As BuyerPaymentInstrumentCodeType
    Get
    Set
public:
property BuyerPaymentInstrumentCodeType PaymentInstrument {
    BuyerPaymentInstrumentCodeType get ();
    void set (BuyerPaymentInstrumentCodeType value);
}


PaymentInstrumentSpecified Property

PaymentInstrumentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► PaymentInstrumentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentInstrumentSpecified { get; set; }
Public Property PaymentInstrumentSpecified As Boolean
    Get
    Set
public:
property bool PaymentInstrumentSpecified {
    bool get ();
    void set (bool value);
}


PaymentMethodUsed Property

PaymentMethodUsed Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► PaymentMethodUsed
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPaymentMethodCodeType PaymentMethodUsed { get; set; }
Public Property PaymentMethodUsed As BuyerPaymentMethodCodeType
    Get
    Set
public:
property BuyerPaymentMethodCodeType PaymentMethodUsed {
    BuyerPaymentMethodCodeType get ();
    void set (BuyerPaymentMethodCodeType value);
}


PaymentMethodUsedSpecified Property

PaymentMethodUsedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► PaymentMethodUsedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaymentMethodUsedSpecified { get; set; }
Public Property PaymentMethodUsedSpecified As Boolean
    Get
    Set
public:
property bool PaymentMethodUsedSpecified {
    bool get ();
    void set (bool value);
}


ReturnStatus Property

ReturnStatus Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► ReturnStatus
Declaration Syntax
C# Visual Basic Visual C++
public ReturnStatusCodeType ReturnStatus { get; set; }
Public Property ReturnStatus As ReturnStatusCodeType
    Get
    Set
public:
property ReturnStatusCodeType ReturnStatus {
    ReturnStatusCodeType get ();
    void set (ReturnStatusCodeType value);
}


ReturnStatusSpecified Property

ReturnStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► ReturnStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ReturnStatusSpecified { get; set; }
Public Property ReturnStatusSpecified As Boolean
    Get
    Set
public:
property bool ReturnStatusSpecified {
    bool get ();
    void set (bool value);
}


TransactionStatusType Constructor

TransactionStatusType Constructor
Namespaces ► eBay.Service.Core.Soap ► TransactionStatusType ► TransactionStatusType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TransactionStatusType()
Public Sub New
public:
TransactionStatusType()


TransactionType Class

TransactionType Class
Namespaces ► eBay.Service.Core.Soap ► TransactionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class TransactionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class TransactionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class TransactionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransactionType()()()() |
 | ActualHandlingCost |
 | ActualShippingCost |
 | AdjustmentAmount |
 | AmountPaid |
 | Any |
 | BestOfferSale |
 | BestOfferSaleSpecified |
 | BundlePurchase |
 | BundlePurchaseSpecified |
 | Buyer |
 | BuyerCheckoutMessage |
 | BuyerGuaranteePrice |
 | BuyerMessage |
 | BuyerPackageEnclosures |
 | BuyerPaidStatus |
 | BuyerPaidStatusSpecified |
 | CartID |
 | CodiceFiscale |
 | ContainingOrder |
 | ConvertedAdjustmentAmount |
 | ConvertedAmountPaid |
 | ConvertedTransactionPrice |
 | CreatedDate |
 | CreatedDateSpecified |
 | DepositType |
 | DepositTypeSpecified |
 | DigitalDeliverySelected |
 | DutchAuctionBid |
 | eBayPaymentID |
 | eBayPlusTransaction |
 | eBayPlusTransactionSpecified |
 | Equals(Object) | (Inherited from Object.)
 | ExtendedOrderID |
 | ExternalTransaction |
 | FeedbackLeft |
 | FeedbackReceived |
 | Finalize()()()() | (Inherited from Object.)
 | FinalValueFee |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Gift |
 | GiftSpecified |
 | GiftSummary |
 | GuaranteedShipping |
 | GuaranteedShippingSpecified |
 | IntangibleItem |
 | IntangibleItemSpecified |
 | InventoryReservationID |
 | InvoiceSentTime |
 | InvoiceSentTimeSpecified |
 | IsMultiLegShipping |
 | IsMultiLegShippingSpecified |
 | Item |
 | ListingCheckoutRedirectPreference |
 | LogisticsPlanType |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MonetaryDetails |
 | MultiLegShippingDetails |
 | OrderLineItemID |
 | PaidTime |
 | PaidTimeSpecified |
 | PaisaPayID |
 | PaymentHoldDetails |
 | PayPalEmailAddress |
 | PickupDetails |
 | PickupMethodSelected |
 | Platform |
 | PlatformSpecified |
 | QuantityPurchased |
 | QuantityPurchasedSpecified |
 | RefundAmount |
 | RefundArray |
 | RefundStatus |
 | SellerContactBuyerByEmail |
 | SellerContactBuyerByEmailSpecified |
 | SellerDiscounts |
 | SellerPaidStatus |
 | SellerPaidStatusSpecified |
 | SellingManagerProductDetails |
 | ShippedTime |
 | ShippedTimeSpecified |
 | ShippingConvenienceCharge |
 | ShippingDetails |
 | ShippingServiceSelected |
 | Status |
 | Taxes |
 | ToString()()()() | (Inherited from Object.)
 | TotalPrice |
 | TransactionID |
 | TransactionPrice |
 | TransactionSiteID |
 | TransactionSiteIDSpecified |
 | UnpaidItem |
 | Variation |
 | VATPercent |
 | VATPercentSpecified |
Remarks
Inheritance Hierarchy
Object
TransactionType


ActualHandlingCost Property

ActualHandlingCost Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ActualHandlingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ActualHandlingCost { get; set; }
Public Property ActualHandlingCost As AmountType
    Get
    Set
public:
property AmountType^ ActualHandlingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


ActualShippingCost Property

ActualShippingCost Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ActualShippingCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ActualShippingCost { get; set; }
Public Property ActualShippingCost As AmountType
    Get
    Set
public:
property AmountType^ ActualShippingCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


AdjustmentAmount Property

AdjustmentAmount Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► AdjustmentAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AdjustmentAmount { get; set; }
Public Property AdjustmentAmount As AmountType
    Get
    Set
public:
property AmountType^ AdjustmentAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


AmountPaid Property

AmountPaid Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► AmountPaid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType AmountPaid { get; set; }
Public Property AmountPaid As AmountType
    Get
    Set
public:
property AmountType^ AmountPaid {
    AmountType^ get ();
    void set (AmountType^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BestOfferSale Property

BestOfferSale Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► BestOfferSale
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferSale { get; set; }
Public Property BestOfferSale As Boolean
    Get
    Set
public:
property bool BestOfferSale {
    bool get ();
    void set (bool value);
}


BestOfferSaleSpecified Property

BestOfferSaleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► BestOfferSaleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BestOfferSaleSpecified { get; set; }
Public Property BestOfferSaleSpecified As Boolean
    Get
    Set
public:
property bool BestOfferSaleSpecified {
    bool get ();
    void set (bool value);
}


BundlePurchase Property

BundlePurchase Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► BundlePurchase
Declaration Syntax
C# Visual Basic Visual C++
public bool BundlePurchase { get; set; }
Public Property BundlePurchase As Boolean
    Get
    Set
public:
property bool BundlePurchase {
    bool get ();
    void set (bool value);
}


BundlePurchaseSpecified Property

BundlePurchaseSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► BundlePurchaseSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BundlePurchaseSpecified { get; set; }
Public Property BundlePurchaseSpecified As Boolean
    Get
    Set
public:
property bool BundlePurchaseSpecified {
    bool get ();
    void set (bool value);
}


Buyer Property

Buyer Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► Buyer
Declaration Syntax
C# Visual Basic Visual C++
public UserType Buyer { get; set; }
Public Property Buyer As UserType
    Get
    Set
public:
property UserType^ Buyer {
    UserType^ get ();
    void set (UserType^ value);
}


BuyerCheckoutMessage Property

BuyerCheckoutMessage Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► BuyerCheckoutMessage
Declaration Syntax
C# Visual Basic Visual C++
public string BuyerCheckoutMessage { get; set; }
Public Property BuyerCheckoutMessage As String
    Get
    Set
public:
property String^ BuyerCheckoutMessage {
    String^ get ();
    void set (String^ value);
}


BuyerGuaranteePrice Property

BuyerGuaranteePrice Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► BuyerGuaranteePrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType BuyerGuaranteePrice { get; set; }
Public Property BuyerGuaranteePrice As AmountType
    Get
    Set
public:
property AmountType^ BuyerGuaranteePrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


BuyerMessage Property

BuyerMessage Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► BuyerMessage
Declaration Syntax
C# Visual Basic Visual C++
public string BuyerMessage { get; set; }
Public Property BuyerMessage As String
    Get
    Set
public:
property String^ BuyerMessage {
    String^ get ();
    void set (String^ value);
}


BuyerPackageEnclosures Property

BuyerPackageEnclosures Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► BuyerPackageEnclosures
Declaration Syntax
C# Visual Basic Visual C++
public BuyerPackageEnclosuresType BuyerPackageEnclosures { get; set; }
Public Property BuyerPackageEnclosures As BuyerPackageEnclosuresType
    Get
    Set
public:
property BuyerPackageEnclosuresType^ BuyerPackageEnclosures {
    BuyerPackageEnclosuresType^ get ();
    void set (BuyerPackageEnclosuresType^ value);
}


BuyerPaidStatus Property

BuyerPaidStatus Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► BuyerPaidStatus
Declaration Syntax
C# Visual Basic Visual C++
public PaidStatusCodeType BuyerPaidStatus { get; set; }
Public Property BuyerPaidStatus As PaidStatusCodeType
    Get
    Set
public:
property PaidStatusCodeType BuyerPaidStatus {
    PaidStatusCodeType get ();
    void set (PaidStatusCodeType value);
}


BuyerPaidStatusSpecified Property

BuyerPaidStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► BuyerPaidStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BuyerPaidStatusSpecified { get; set; }
Public Property BuyerPaidStatusSpecified As Boolean
    Get
    Set
public:
property bool BuyerPaidStatusSpecified {
    bool get ();
    void set (bool value);
}


CartID Property

CartID Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► CartID
Declaration Syntax
C# Visual Basic Visual C++
public string CartID { get; set; }
Public Property CartID As String
    Get
    Set
public:
property String^ CartID {
    String^ get ();
    void set (String^ value);
}


CodiceFiscale Property

CodiceFiscale Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► CodiceFiscale
Declaration Syntax
C# Visual Basic Visual C++
public string CodiceFiscale { get; set; }
Public Property CodiceFiscale As String
    Get
    Set
public:
property String^ CodiceFiscale {
    String^ get ();
    void set (String^ value);
}


ContainingOrder Property

ContainingOrder Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ContainingOrder
Declaration Syntax
C# Visual Basic Visual C++
public OrderType ContainingOrder { get; set; }
Public Property ContainingOrder As OrderType
    Get
    Set
public:
property OrderType^ ContainingOrder {
    OrderType^ get ();
    void set (OrderType^ value);
}


ConvertedAdjustmentAmount Property

ConvertedAdjustmentAmount Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ConvertedAdjustmentAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ConvertedAdjustmentAmount { get; set; }
Public Property ConvertedAdjustmentAmount As AmountType
    Get
    Set
public:
property AmountType^ ConvertedAdjustmentAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


ConvertedAmountPaid Property

ConvertedAmountPaid Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ConvertedAmountPaid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ConvertedAmountPaid { get; set; }
Public Property ConvertedAmountPaid As AmountType
    Get
    Set
public:
property AmountType^ ConvertedAmountPaid {
    AmountType^ get ();
    void set (AmountType^ value);
}


ConvertedTransactionPrice Property

ConvertedTransactionPrice Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ConvertedTransactionPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ConvertedTransactionPrice { get; set; }
Public Property ConvertedTransactionPrice As AmountType
    Get
    Set
public:
property AmountType^ ConvertedTransactionPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


CreatedDate Property

CreatedDate Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► CreatedDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreatedDate { get; set; }
Public Property CreatedDate As DateTime
    Get
    Set
public:
property DateTime CreatedDate {
    DateTime get ();
    void set (DateTime value);
}


CreatedDateSpecified Property

CreatedDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► CreatedDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CreatedDateSpecified { get; set; }
Public Property CreatedDateSpecified As Boolean
    Get
    Set
public:
property bool CreatedDateSpecified {
    bool get ();
    void set (bool value);
}


DepositType Property

DepositType Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► DepositType
Declaration Syntax
C# Visual Basic Visual C++
public DepositTypeCodeType DepositType { get; set; }
Public Property DepositType As DepositTypeCodeType
    Get
    Set
public:
property DepositTypeCodeType DepositType {
    DepositTypeCodeType get ();
    void set (DepositTypeCodeType value);
}


DepositTypeSpecified Property

DepositTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► DepositTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DepositTypeSpecified { get; set; }
Public Property DepositTypeSpecified As Boolean
    Get
    Set
public:
property bool DepositTypeSpecified {
    bool get ();
    void set (bool value);
}


DigitalDeliverySelected Property

DigitalDeliverySelected Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► DigitalDeliverySelected
Declaration Syntax
C# Visual Basic Visual C++
public DigitalDeliverySelectedType DigitalDeliverySelected { get; set; }
Public Property DigitalDeliverySelected As DigitalDeliverySelectedType
    Get
    Set
public:
property DigitalDeliverySelectedType^ DigitalDeliverySelected {
    DigitalDeliverySelectedType^ get ();
    void set (DigitalDeliverySelectedType^ value);
}


DutchAuctionBid Property

DutchAuctionBid Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► DutchAuctionBid
Declaration Syntax
C# Visual Basic Visual C++
public AmountType DutchAuctionBid { get; set; }
Public Property DutchAuctionBid As AmountType
    Get
    Set
public:
property AmountType^ DutchAuctionBid {
    AmountType^ get ();
    void set (AmountType^ value);
}


eBayPaymentID Property

eBayPaymentID Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► eBayPaymentID
Declaration Syntax
C# Visual Basic Visual C++
public string eBayPaymentID { get; set; }
Public Property eBayPaymentID As String
    Get
    Set
public:
property String^ eBayPaymentID {
    String^ get ();
    void set (String^ value);
}


eBayPlusTransaction Property

eBayPlusTransaction Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► eBayPlusTransaction
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayPlusTransaction { get; set; }
Public Property eBayPlusTransaction As Boolean
    Get
    Set
public:
property bool eBayPlusTransaction {
    bool get ();
    void set (bool value);
}


eBayPlusTransactionSpecified Property

eBayPlusTransactionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► eBayPlusTransactionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayPlusTransactionSpecified { get; set; }
Public Property eBayPlusTransactionSpecified As Boolean
    Get
    Set
public:
property bool eBayPlusTransactionSpecified {
    bool get ();
    void set (bool value);
}


ExtendedOrderID Property

ExtendedOrderID Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ExtendedOrderID
Declaration Syntax
C# Visual Basic Visual C++
public string ExtendedOrderID { get; set; }
Public Property ExtendedOrderID As String
    Get
    Set
public:
property String^ ExtendedOrderID {
    String^ get ();
    void set (String^ value);
}


ExternalTransaction Property

ExternalTransaction Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ExternalTransaction
Declaration Syntax
C# Visual Basic Visual C++
public ExternalTransactionTypeCollection ExternalTransaction { get; set; }
Public Property ExternalTransaction As ExternalTransactionTypeCollection
    Get
    Set
public:
property ExternalTransactionTypeCollection^ ExternalTransaction {
    ExternalTransactionTypeCollection^ get ();
    void set (ExternalTransactionTypeCollection^ value);
}


FeedbackLeft Property

FeedbackLeft Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► FeedbackLeft
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackInfoType FeedbackLeft { get; set; }
Public Property FeedbackLeft As FeedbackInfoType
    Get
    Set
public:
property FeedbackInfoType^ FeedbackLeft {
    FeedbackInfoType^ get ();
    void set (FeedbackInfoType^ value);
}


FeedbackReceived Property

FeedbackReceived Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► FeedbackReceived
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackInfoType FeedbackReceived { get; set; }
Public Property FeedbackReceived As FeedbackInfoType
    Get
    Set
public:
property FeedbackInfoType^ FeedbackReceived {
    FeedbackInfoType^ get ();
    void set (FeedbackInfoType^ value);
}


FinalValueFee Property

FinalValueFee Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► FinalValueFee
Declaration Syntax
C# Visual Basic Visual C++
public AmountType FinalValueFee { get; set; }
Public Property FinalValueFee As AmountType
    Get
    Set
public:
property AmountType^ FinalValueFee {
    AmountType^ get ();
    void set (AmountType^ value);
}


Gift Property

Gift Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► Gift
Declaration Syntax
C# Visual Basic Visual C++
public bool Gift { get; set; }
Public Property Gift As Boolean
    Get
    Set
public:
property bool Gift {
    bool get ();
    void set (bool value);
}


GiftSpecified Property

GiftSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► GiftSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GiftSpecified { get; set; }
Public Property GiftSpecified As Boolean
    Get
    Set
public:
property bool GiftSpecified {
    bool get ();
    void set (bool value);
}


GiftSummary Property

GiftSummary Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► GiftSummary
Declaration Syntax
C# Visual Basic Visual C++
public GiftSummaryType GiftSummary { get; set; }
Public Property GiftSummary As GiftSummaryType
    Get
    Set
public:
property GiftSummaryType^ GiftSummary {
    GiftSummaryType^ get ();
    void set (GiftSummaryType^ value);
}


GuaranteedShipping Property

GuaranteedShipping Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► GuaranteedShipping
Declaration Syntax
C# Visual Basic Visual C++
public bool GuaranteedShipping { get; set; }
Public Property GuaranteedShipping As Boolean
    Get
    Set
public:
property bool GuaranteedShipping {
    bool get ();
    void set (bool value);
}


GuaranteedShippingSpecified Property

GuaranteedShippingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► GuaranteedShippingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool GuaranteedShippingSpecified { get; set; }
Public Property GuaranteedShippingSpecified As Boolean
    Get
    Set
public:
property bool GuaranteedShippingSpecified {
    bool get ();
    void set (bool value);
}


IntangibleItem Property

IntangibleItem Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► IntangibleItem
Declaration Syntax
C# Visual Basic Visual C++
public bool IntangibleItem { get; set; }
Public Property IntangibleItem As Boolean
    Get
    Set
public:
property bool IntangibleItem {
    bool get ();
    void set (bool value);
}


IntangibleItemSpecified Property

IntangibleItemSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► IntangibleItemSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IntangibleItemSpecified { get; set; }
Public Property IntangibleItemSpecified As Boolean
    Get
    Set
public:
property bool IntangibleItemSpecified {
    bool get ();
    void set (bool value);
}


InventoryReservationID Property

InventoryReservationID Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► InventoryReservationID
Declaration Syntax
C# Visual Basic Visual C++
public string InventoryReservationID { get; set; }
Public Property InventoryReservationID As String
    Get
    Set
public:
property String^ InventoryReservationID {
    String^ get ();
    void set (String^ value);
}


InvoiceSentTime Property

InvoiceSentTime Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► InvoiceSentTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime InvoiceSentTime { get; set; }
Public Property InvoiceSentTime As DateTime
    Get
    Set
public:
property DateTime InvoiceSentTime {
    DateTime get ();
    void set (DateTime value);
}


InvoiceSentTimeSpecified Property

InvoiceSentTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► InvoiceSentTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool InvoiceSentTimeSpecified { get; set; }
Public Property InvoiceSentTimeSpecified As Boolean
    Get
    Set
public:
property bool InvoiceSentTimeSpecified {
    bool get ();
    void set (bool value);
}


IsMultiLegShipping Property

IsMultiLegShipping Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► IsMultiLegShipping
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMultiLegShipping { get; set; }
Public Property IsMultiLegShipping As Boolean
    Get
    Set
public:
property bool IsMultiLegShipping {
    bool get ();
    void set (bool value);
}


IsMultiLegShippingSpecified Property

IsMultiLegShippingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► IsMultiLegShippingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMultiLegShippingSpecified { get; set; }
Public Property IsMultiLegShippingSpecified As Boolean
    Get
    Set
public:
property bool IsMultiLegShippingSpecified {
    bool get ();
    void set (bool value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


ListingCheckoutRedirectPreference Property

ListingCheckoutRedirectPreference Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ListingCheckoutRedirectPreference
Declaration Syntax
C# Visual Basic Visual C++
public ListingCheckoutRedirectPreferenceType ListingCheckoutRedirectPreference { get; set; }
Public Property ListingCheckoutRedirectPreference As ListingCheckoutRedirectPreferenceType
    Get
    Set
public:
property ListingCheckoutRedirectPreferenceType^ ListingCheckoutRedirectPreference {
    ListingCheckoutRedirectPreferenceType^ get ();
    void set (ListingCheckoutRedirectPreferenceType^ value);
}


LogisticsPlanType Property

LogisticsPlanType Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► LogisticsPlanType
Declaration Syntax
C# Visual Basic Visual C++
public string LogisticsPlanType { get; set; }
Public Property LogisticsPlanType As String
    Get
    Set
public:
property String^ LogisticsPlanType {
    String^ get ();
    void set (String^ value);
}


MonetaryDetails Property

MonetaryDetails Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► MonetaryDetails
Declaration Syntax
C# Visual Basic Visual C++
public PaymentsInformationType MonetaryDetails { get; set; }
Public Property MonetaryDetails As PaymentsInformationType
    Get
    Set
public:
property PaymentsInformationType^ MonetaryDetails {
    PaymentsInformationType^ get ();
    void set (PaymentsInformationType^ value);
}


MultiLegShippingDetails Property

MultiLegShippingDetails Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► MultiLegShippingDetails
Declaration Syntax
C# Visual Basic Visual C++
public MultiLegShippingDetailsType MultiLegShippingDetails { get; set; }
Public Property MultiLegShippingDetails As MultiLegShippingDetailsType
    Get
    Set
public:
property MultiLegShippingDetailsType^ MultiLegShippingDetails {
    MultiLegShippingDetailsType^ get ();
    void set (MultiLegShippingDetailsType^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


PaidTime Property

PaidTime Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► PaidTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime PaidTime { get; set; }
Public Property PaidTime As DateTime
    Get
    Set
public:
property DateTime PaidTime {
    DateTime get ();
    void set (DateTime value);
}


PaidTimeSpecified Property

PaidTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► PaidTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PaidTimeSpecified { get; set; }
Public Property PaidTimeSpecified As Boolean
    Get
    Set
public:
property bool PaidTimeSpecified {
    bool get ();
    void set (bool value);
}


PaisaPayID Property

PaisaPayID Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► PaisaPayID
Declaration Syntax
C# Visual Basic Visual C++
public string PaisaPayID { get; set; }
Public Property PaisaPayID As String
    Get
    Set
public:
property String^ PaisaPayID {
    String^ get ();
    void set (String^ value);
}


PaymentHoldDetails Property

PaymentHoldDetails Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► PaymentHoldDetails
Declaration Syntax
C# Visual Basic Visual C++
public PaymentHoldDetailType PaymentHoldDetails { get; set; }
Public Property PaymentHoldDetails As PaymentHoldDetailType
    Get
    Set
public:
property PaymentHoldDetailType^ PaymentHoldDetails {
    PaymentHoldDetailType^ get ();
    void set (PaymentHoldDetailType^ value);
}


PayPalEmailAddress Property

PayPalEmailAddress Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► PayPalEmailAddress
Declaration Syntax
C# Visual Basic Visual C++
public string PayPalEmailAddress { get; set; }
Public Property PayPalEmailAddress As String
    Get
    Set
public:
property String^ PayPalEmailAddress {
    String^ get ();
    void set (String^ value);
}


PickupDetails Property

PickupDetails Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► PickupDetails
Declaration Syntax
C# Visual Basic Visual C++
public PickupDetailsType PickupDetails { get; set; }
Public Property PickupDetails As PickupDetailsType
    Get
    Set
public:
property PickupDetailsType^ PickupDetails {
    PickupDetailsType^ get ();
    void set (PickupDetailsType^ value);
}


PickupMethodSelected Property

PickupMethodSelected Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► PickupMethodSelected
Declaration Syntax
C# Visual Basic Visual C++
public PickupMethodSelectedType PickupMethodSelected { get; set; }
Public Property PickupMethodSelected As PickupMethodSelectedType
    Get
    Set
public:
property PickupMethodSelectedType^ PickupMethodSelected {
    PickupMethodSelectedType^ get ();
    void set (PickupMethodSelectedType^ value);
}


Platform Property

Platform Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► Platform
Declaration Syntax
C# Visual Basic Visual C++
public TransactionPlatformCodeType Platform { get; set; }
Public Property Platform As TransactionPlatformCodeType
    Get
    Set
public:
property TransactionPlatformCodeType Platform {
    TransactionPlatformCodeType get ();
    void set (TransactionPlatformCodeType value);
}


PlatformSpecified Property

PlatformSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► PlatformSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PlatformSpecified { get; set; }
Public Property PlatformSpecified As Boolean
    Get
    Set
public:
property bool PlatformSpecified {
    bool get ();
    void set (bool value);
}


QuantityPurchased Property

QuantityPurchased Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► QuantityPurchased
Declaration Syntax
C# Visual Basic Visual C++
public int QuantityPurchased { get; set; }
Public Property QuantityPurchased As Integer
    Get
    Set
public:
property int QuantityPurchased {
    int get ();
    void set (int value);
}


QuantityPurchasedSpecified Property

QuantityPurchasedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► QuantityPurchasedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantityPurchasedSpecified { get; set; }
Public Property QuantityPurchasedSpecified As Boolean
    Get
    Set
public:
property bool QuantityPurchasedSpecified {
    bool get ();
    void set (bool value);
}


RefundAmount Property

RefundAmount Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► RefundAmount
Declaration Syntax
C# Visual Basic Visual C++
public AmountType RefundAmount { get; set; }
Public Property RefundAmount As AmountType
    Get
    Set
public:
property AmountType^ RefundAmount {
    AmountType^ get ();
    void set (AmountType^ value);
}


RefundArray Property

RefundArray Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► RefundArray
Declaration Syntax
C# Visual Basic Visual C++
public RefundTypeCollection RefundArray { get; set; }
Public Property RefundArray As RefundTypeCollection
    Get
    Set
public:
property RefundTypeCollection^ RefundArray {
    RefundTypeCollection^ get ();
    void set (RefundTypeCollection^ value);
}


RefundStatus Property

RefundStatus Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► RefundStatus
Declaration Syntax
C# Visual Basic Visual C++
public string RefundStatus { get; set; }
Public Property RefundStatus As String
    Get
    Set
public:
property String^ RefundStatus {
    String^ get ();
    void set (String^ value);
}


SellerContactBuyerByEmail Property

SellerContactBuyerByEmail Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► SellerContactBuyerByEmail
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerContactBuyerByEmail { get; set; }
Public Property SellerContactBuyerByEmail As Boolean
    Get
    Set
public:
property bool SellerContactBuyerByEmail {
    bool get ();
    void set (bool value);
}


SellerContactBuyerByEmailSpecified Property

SellerContactBuyerByEmailSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► SellerContactBuyerByEmailSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerContactBuyerByEmailSpecified { get; set; }
Public Property SellerContactBuyerByEmailSpecified As Boolean
    Get
    Set
public:
property bool SellerContactBuyerByEmailSpecified {
    bool get ();
    void set (bool value);
}


SellerDiscounts Property

SellerDiscounts Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► SellerDiscounts
Declaration Syntax
C# Visual Basic Visual C++
public SellerDiscountsType SellerDiscounts { get; set; }
Public Property SellerDiscounts As SellerDiscountsType
    Get
    Set
public:
property SellerDiscountsType^ SellerDiscounts {
    SellerDiscountsType^ get ();
    void set (SellerDiscountsType^ value);
}


SellerPaidStatus Property

SellerPaidStatus Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► SellerPaidStatus
Declaration Syntax
C# Visual Basic Visual C++
public PaidStatusCodeType SellerPaidStatus { get; set; }
Public Property SellerPaidStatus As PaidStatusCodeType
    Get
    Set
public:
property PaidStatusCodeType SellerPaidStatus {
    PaidStatusCodeType get ();
    void set (PaidStatusCodeType value);
}


SellerPaidStatusSpecified Property

SellerPaidStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► SellerPaidStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerPaidStatusSpecified { get; set; }
Public Property SellerPaidStatusSpecified As Boolean
    Get
    Set
public:
property bool SellerPaidStatusSpecified {
    bool get ();
    void set (bool value);
}


SellingManagerProductDetails Property

SellingManagerProductDetails Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► SellingManagerProductDetails
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductDetailsType SellingManagerProductDetails { get; set; }
Public Property SellingManagerProductDetails As SellingManagerProductDetailsType
    Get
    Set
public:
property SellingManagerProductDetailsType^ SellingManagerProductDetails {
    SellingManagerProductDetailsType^ get ();
    void set (SellingManagerProductDetailsType^ value);
}


ShippedTime Property

ShippedTime Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ShippedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ShippedTime { get; set; }
Public Property ShippedTime As DateTime
    Get
    Set
public:
property DateTime ShippedTime {
    DateTime get ();
    void set (DateTime value);
}


ShippedTimeSpecified Property

ShippedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ShippedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ShippedTimeSpecified { get; set; }
Public Property ShippedTimeSpecified As Boolean
    Get
    Set
public:
property bool ShippedTimeSpecified {
    bool get ();
    void set (bool value);
}


ShippingConvenienceCharge Property

ShippingConvenienceCharge Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ShippingConvenienceCharge
Declaration Syntax
C# Visual Basic Visual C++
public AmountType ShippingConvenienceCharge { get; set; }
Public Property ShippingConvenienceCharge As AmountType
    Get
    Set
public:
property AmountType^ ShippingConvenienceCharge {
    AmountType^ get ();
    void set (AmountType^ value);
}


ShippingDetails Property

ShippingDetails Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ShippingDetails
Declaration Syntax
C# Visual Basic Visual C++
public ShippingDetailsType ShippingDetails { get; set; }
Public Property ShippingDetails As ShippingDetailsType
    Get
    Set
public:
property ShippingDetailsType^ ShippingDetails {
    ShippingDetailsType^ get ();
    void set (ShippingDetailsType^ value);
}


ShippingServiceSelected Property

ShippingServiceSelected Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► ShippingServiceSelected
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceOptionsType ShippingServiceSelected { get; set; }
Public Property ShippingServiceSelected As ShippingServiceOptionsType
    Get
    Set
public:
property ShippingServiceOptionsType^ ShippingServiceSelected {
    ShippingServiceOptionsType^ get ();
    void set (ShippingServiceOptionsType^ value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public TransactionStatusType Status { get; set; }
Public Property Status As TransactionStatusType
    Get
    Set
public:
property TransactionStatusType^ Status {
    TransactionStatusType^ get ();
    void set (TransactionStatusType^ value);
}


Taxes Property

Taxes Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► Taxes
Declaration Syntax
C# Visual Basic Visual C++
public TaxesType Taxes { get; set; }
Public Property Taxes As TaxesType
    Get
    Set
public:
property TaxesType^ Taxes {
    TaxesType^ get ();
    void set (TaxesType^ value);
}


TotalPrice Property

TotalPrice Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► TotalPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TotalPrice { get; set; }
Public Property TotalPrice As AmountType
    Get
    Set
public:
property AmountType^ TotalPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


TransactionPrice Property

TransactionPrice Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► TransactionPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType TransactionPrice { get; set; }
Public Property TransactionPrice As AmountType
    Get
    Set
public:
property AmountType^ TransactionPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


TransactionSiteID Property

TransactionSiteID Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► TransactionSiteID
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType TransactionSiteID { get; set; }
Public Property TransactionSiteID As SiteCodeType
    Get
    Set
public:
property SiteCodeType TransactionSiteID {
    SiteCodeType get ();
    void set (SiteCodeType value);
}


TransactionSiteIDSpecified Property

TransactionSiteIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► TransactionSiteIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TransactionSiteIDSpecified { get; set; }
Public Property TransactionSiteIDSpecified As Boolean
    Get
    Set
public:
property bool TransactionSiteIDSpecified {
    bool get ();
    void set (bool value);
}


TransactionType Constructor

TransactionType Constructor
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► TransactionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TransactionType()
Public Sub New
public:
TransactionType()


UnpaidItem Property

UnpaidItem Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► UnpaidItem
Declaration Syntax
C# Visual Basic Visual C++
public UnpaidItemType UnpaidItem { get; set; }
Public Property UnpaidItem As UnpaidItemType
    Get
    Set
public:
property UnpaidItemType^ UnpaidItem {
    UnpaidItemType^ get ();
    void set (UnpaidItemType^ value);
}


Variation Property

Variation Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► Variation
Declaration Syntax
C# Visual Basic Visual C++
public VariationType Variation { get; set; }
Public Property Variation As VariationType
    Get
    Set
public:
property VariationType^ Variation {
    VariationType^ get ();
    void set (VariationType^ value);
}


VATPercent Property

VATPercent Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► VATPercent
Declaration Syntax
C# Visual Basic Visual C++
public decimal VATPercent { get; set; }
Public Property VATPercent As Decimal
    Get
    Set
public:
property Decimal VATPercent {
    Decimal get ();
    void set (Decimal value);
}


VATPercentSpecified Property

VATPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► TransactionType ► VATPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VATPercentSpecified { get; set; }
Public Property VATPercentSpecified As Boolean
    Get
    Set
public:
property bool VATPercentSpecified {
    bool get ();
    void set (bool value);
}


TransactionTypeCollection Class

TransactionTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class TransactionTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class TransactionTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class TransactionTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TransactionTypeCollection()()()() |
 | TransactionTypeCollection(array<TransactionType>[]()[][]) |
 | TransactionTypeCollection(TransactionTypeCollection) |
 | Add(TransactionType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<TransactionType>[]()[][]) |
 | AddRange(TransactionTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(TransactionType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<TransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(TransactionType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, TransactionType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(TransactionType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | TransactionTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► Add(TransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    TransactionType item
)
Public Function Add ( _
    item As TransactionType _
) As Integer
public:
int Add(
    TransactionType^ item
)
Parameters
item (TransactionType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<TransactionType>[]()[][]) |
 | AddRange(TransactionTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► AddRange(array<TransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TransactionType[] items
)
Public Sub AddRange ( _
    items As TransactionType() _
)
public:
void AddRange(
    array<TransactionType^>^ items
)
Parameters
items (array< TransactionType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► AddRange(TransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TransactionTypeCollection items
)
Public Sub AddRange ( _
    items As TransactionTypeCollection _
)
public:
void AddRange(
    TransactionTypeCollection^ items
)
Parameters
items (TransactionTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► Contains(TransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    TransactionType item
)
Public Function Contains ( _
    item As TransactionType _
) As Boolean
public:
bool Contains(
    TransactionType^ item
)
Parameters
item (TransactionType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► CopyTo(array<TransactionType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    TransactionType[] items,
    int index
)
Public Sub CopyTo ( _
    items As TransactionType(), _
    index As Integer _
)
public:
void CopyTo(
    array<TransactionType^>^ items,
    int index
)
Parameters
items (array< TransactionType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► IndexOf(TransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    TransactionType item
)
Public Function IndexOf ( _
    item As TransactionType _
) As Integer
public:
int IndexOf(
    TransactionType^ item
)
Parameters
item (TransactionType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► Insert(Int32, TransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    TransactionType item
)
Public Sub Insert ( _
    index As Integer, _
    item As TransactionType _
)
public:
void Insert(
    int index,
    TransactionType^ item
)
Parameters
index (Int32)
item (TransactionType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public TransactionType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As TransactionType
    Get
    Set
public:
property TransactionType^ default[int index] {
    TransactionType^ get (int index);
    void set (int index, TransactionType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public TransactionType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As TransactionType
public:
TransactionType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► Remove(TransactionType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    TransactionType item
)
Public Sub Remove ( _
    item As TransactionType _
)
public:
void Remove(
    TransactionType^ item
)
Parameters
item (TransactionType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TransactionType[] ToArray()
Public Function ToArray As TransactionType()
public:
array<TransactionType^>^ ToArray()
Return Value


TransactionTypeCollection Constructor

TransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► TransactionTypeCollection()()()()
Members
Icon | Member | Description
 | TransactionTypeCollection()()()() |
 | TransactionTypeCollection(array<TransactionType>[]()[][]) |
 | TransactionTypeCollection(TransactionTypeCollection) |


TransactionTypeCollection Constructor

TransactionTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► TransactionTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection()
Public Sub New
public:
TransactionTypeCollection()


TransactionTypeCollection Constructor (items)

TransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► TransactionTypeCollection(array<TransactionType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection(
    TransactionType[] items
)
Public Sub New ( _
    items As TransactionType() _
)
public:
TransactionTypeCollection(
    array<TransactionType^>^ items
)
Parameters
items (array< TransactionType >[]()[][])


TransactionTypeCollection Constructor (items)

TransactionTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► TransactionTypeCollection(TransactionTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public TransactionTypeCollection(
    TransactionTypeCollection items
)
Public Sub New ( _
    items As TransactionTypeCollection _
)
public:
TransactionTypeCollection(
    TransactionTypeCollection^ items
)
Parameters
items (TransactionTypeCollection)


TypeCollection Class

TypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► TypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class TypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class TypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class TypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TypeCollection()()()() |
 | TypeCollection(array<Type>[]()[][]) |
 | TypeCollection(TypeCollection) |
 | Add(Type) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<Type>[]()[][]) |
 | AddRange(TypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(Type) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<Type>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(Type) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, Type) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(Type) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | TypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► Add(Type)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Type item
)
Public Function Add ( _
    item As Type _
) As Integer
public:
int Add(
    Type^ item
)
Parameters
item (Type)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<Type>[]()[][]) |
 | AddRange(TypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► AddRange(TypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    TypeCollection items
)
Public Sub AddRange ( _
    items As TypeCollection _
)
public:
void AddRange(
    TypeCollection^ items
)
Parameters
items (TypeCollection)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► AddRange(array<Type>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    Type[] items
)
Public Sub AddRange ( _
    items As Type() _
)
public:
void AddRange(
    array<Type^>^ items
)
Parameters
items (array< Type >[]()[][])


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► Contains(Type)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Type item
)
Public Function Contains ( _
    item As Type _
) As Boolean
public:
bool Contains(
    Type^ item
)
Parameters
item (Type)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► CopyTo(array<Type>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Type[] items,
    int index
)
Public Sub CopyTo ( _
    items As Type(), _
    index As Integer _
)
public:
void CopyTo(
    array<Type^>^ items,
    int index
)
Parameters
items (array< Type >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► IndexOf(Type)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Type item
)
Public Function IndexOf ( _
    item As Type _
) As Integer
public:
int IndexOf(
    Type^ item
)
Parameters
item (Type)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► Insert(Int32, Type)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    Type item
)
Public Sub Insert ( _
    index As Integer, _
    item As Type _
)
public:
void Insert(
    int index,
    Type^ item
)
Parameters
index (Int32)
item (Type)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public Type this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Type
    Get
    Set
public:
property Type^ default[int index] {
    Type^ get (int index);
    void set (int index, Type^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public Type ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As Type
public:
Type^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► Remove(Type)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Type item
)
Public Sub Remove ( _
    item As Type _
)
public:
void Remove(
    Type^ item
)
Parameters
item (Type)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Type[] ToArray()
Public Function ToArray As Type()
public:
array<Type^>^ ToArray()
Return Value


TypeCollection Constructor

TypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► TypeCollection()()()()
Members
Icon | Member | Description
 | TypeCollection()()()() |
 | TypeCollection(array<Type>[]()[][]) |
 | TypeCollection(TypeCollection) |


TypeCollection Constructor

TypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► TypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TypeCollection()
Public Sub New
public:
TypeCollection()


TypeCollection Constructor (items)

TypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► TypeCollection(TypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public TypeCollection(
    TypeCollection items
)
Public Sub New ( _
    items As TypeCollection _
)
public:
TypeCollection(
    TypeCollection^ items
)
Parameters
items (TypeCollection)


TypeCollection Constructor (items)

TypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► TypeCollection(array<Type>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public TypeCollection(
    Type[] items
)
Public Sub New ( _
    items As Type() _
)
public:
TypeCollection(
    array<Type^>^ items
)
Parameters
items (array< Type >[]()[][])


UnitInfoType Class

UnitInfoType Class
Namespaces ► eBay.Service.Core.Soap ► UnitInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UnitInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UnitInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UnitInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnitInfoType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UnitQuantity |
 | UnitQuantitySpecified |
 | UnitType |
Remarks
Inheritance Hierarchy
Object
UnitInfoType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UnitInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


UnitInfoType Constructor

UnitInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► UnitInfoType ► UnitInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UnitInfoType()
Public Sub New
public:
UnitInfoType()


UnitQuantity Property

UnitQuantity Property
Namespaces ► eBay.Service.Core.Soap ► UnitInfoType ► UnitQuantity
Declaration Syntax
C# Visual Basic Visual C++
public double UnitQuantity { get; set; }
Public Property UnitQuantity As Double
    Get
    Set
public:
property double UnitQuantity {
    double get ();
    void set (double value);
}


UnitQuantitySpecified Property

UnitQuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► UnitInfoType ► UnitQuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UnitQuantitySpecified { get; set; }
Public Property UnitQuantitySpecified As Boolean
    Get
    Set
public:
property bool UnitQuantitySpecified {
    bool get ();
    void set (bool value);
}


UnitType Property

UnitType Property
Namespaces ► eBay.Service.Core.Soap ► UnitInfoType ► UnitType
Declaration Syntax
C# Visual Basic Visual C++
public string UnitType { get; set; }
Public Property UnitType As String
    Get
    Set
public:
property String^ UnitType {
    String^ get ();
    void set (String^ value);
}


UnitOfMeasurementDetailsType Class

UnitOfMeasurementDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UnitOfMeasurementDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UnitOfMeasurementDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UnitOfMeasurementDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnitOfMeasurementDetailsType()()()() |
 | Any |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UnitOfMeasurement |
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
UnitOfMeasurementDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


UnitOfMeasurement Property

UnitOfMeasurement Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsType ► UnitOfMeasurement
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementTypeCollection UnitOfMeasurement { get; set; }
Public Property UnitOfMeasurement As UnitOfMeasurementTypeCollection
    Get
    Set
public:
property UnitOfMeasurementTypeCollection^ UnitOfMeasurement {
    UnitOfMeasurementTypeCollection^ get ();
    void set (UnitOfMeasurementTypeCollection^ value);
}


UnitOfMeasurementDetailsType Constructor

UnitOfMeasurementDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsType ► UnitOfMeasurementDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementDetailsType()
Public Sub New
public:
UnitOfMeasurementDetailsType()


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


UnitOfMeasurementDetailsTypeCollection Class

UnitOfMeasurementDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class UnitOfMeasurementDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class UnitOfMeasurementDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class UnitOfMeasurementDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnitOfMeasurementDetailsTypeCollection()()()() |
 | UnitOfMeasurementDetailsTypeCollection(array<UnitOfMeasurementDetailsType>[]()[][]) |
 | UnitOfMeasurementDetailsTypeCollection(UnitOfMeasurementDetailsTypeCollection) |
 | Add(UnitOfMeasurementDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<UnitOfMeasurementDetailsType>[]()[][]) |
 | AddRange(UnitOfMeasurementDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(UnitOfMeasurementDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<UnitOfMeasurementDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(UnitOfMeasurementDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, UnitOfMeasurementDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(UnitOfMeasurementDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | UnitOfMeasurementDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► Add(UnitOfMeasurementDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    UnitOfMeasurementDetailsType item
)
Public Function Add ( _
    item As UnitOfMeasurementDetailsType _
) As Integer
public:
int Add(
    UnitOfMeasurementDetailsType^ item
)
Parameters
item (UnitOfMeasurementDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<UnitOfMeasurementDetailsType>[]()[][]) |
 | AddRange(UnitOfMeasurementDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► AddRange(array<UnitOfMeasurementDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    UnitOfMeasurementDetailsType[] items
)
Public Sub AddRange ( _
    items As UnitOfMeasurementDetailsType() _
)
public:
void AddRange(
    array<UnitOfMeasurementDetailsType^>^ items
)
Parameters
items (array< UnitOfMeasurementDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► AddRange(UnitOfMeasurementDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    UnitOfMeasurementDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As UnitOfMeasurementDetailsTypeCollection _
)
public:
void AddRange(
    UnitOfMeasurementDetailsTypeCollection^ items
)
Parameters
items (UnitOfMeasurementDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► Contains(UnitOfMeasurementDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    UnitOfMeasurementDetailsType item
)
Public Function Contains ( _
    item As UnitOfMeasurementDetailsType _
) As Boolean
public:
bool Contains(
    UnitOfMeasurementDetailsType^ item
)
Parameters
item (UnitOfMeasurementDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► CopyTo(array<UnitOfMeasurementDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    UnitOfMeasurementDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As UnitOfMeasurementDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<UnitOfMeasurementDetailsType^>^ items,
    int index
)
Parameters
items (array< UnitOfMeasurementDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► IndexOf(UnitOfMeasurementDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    UnitOfMeasurementDetailsType item
)
Public Function IndexOf ( _
    item As UnitOfMeasurementDetailsType _
) As Integer
public:
int IndexOf(
    UnitOfMeasurementDetailsType^ item
)
Parameters
item (UnitOfMeasurementDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► Insert(Int32, UnitOfMeasurementDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    UnitOfMeasurementDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As UnitOfMeasurementDetailsType _
)
public:
void Insert(
    int index,
    UnitOfMeasurementDetailsType^ item
)
Parameters
index (Int32)
item (UnitOfMeasurementDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As UnitOfMeasurementDetailsType
    Get
    Set
public:
property UnitOfMeasurementDetailsType^ default[int index] {
    UnitOfMeasurementDetailsType^ get (int index);
    void set (int index, UnitOfMeasurementDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As UnitOfMeasurementDetailsType
public:
UnitOfMeasurementDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► Remove(UnitOfMeasurementDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    UnitOfMeasurementDetailsType item
)
Public Sub Remove ( _
    item As UnitOfMeasurementDetailsType _
)
public:
void Remove(
    UnitOfMeasurementDetailsType^ item
)
Parameters
item (UnitOfMeasurementDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementDetailsType[] ToArray()
Public Function ToArray As UnitOfMeasurementDetailsType()
public:
array<UnitOfMeasurementDetailsType^>^ ToArray()
Return Value


UnitOfMeasurementDetailsTypeCollection Constructor

UnitOfMeasurementDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► UnitOfMeasurementDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | UnitOfMeasurementDetailsTypeCollection()()()() |
 | UnitOfMeasurementDetailsTypeCollection(array<UnitOfMeasurementDetailsType>[]()[][]) |
 | UnitOfMeasurementDetailsTypeCollection(UnitOfMeasurementDetailsTypeCollection) |


UnitOfMeasurementDetailsTypeCollection Constructor

UnitOfMeasurementDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► UnitOfMeasurementDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementDetailsTypeCollection()
Public Sub New
public:
UnitOfMeasurementDetailsTypeCollection()


UnitOfMeasurementDetailsTypeCollection Constructor (items)

UnitOfMeasurementDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► UnitOfMeasurementDetailsTypeCollection(array<UnitOfMeasurementDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementDetailsTypeCollection(
    UnitOfMeasurementDetailsType[] items
)
Public Sub New ( _
    items As UnitOfMeasurementDetailsType() _
)
public:
UnitOfMeasurementDetailsTypeCollection(
    array<UnitOfMeasurementDetailsType^>^ items
)
Parameters
items (array< UnitOfMeasurementDetailsType >[]()[][])


UnitOfMeasurementDetailsTypeCollection Constructor (items)

UnitOfMeasurementDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► UnitOfMeasurementDetailsTypeCollection(UnitOfMeasurementDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementDetailsTypeCollection(
    UnitOfMeasurementDetailsTypeCollection items
)
Public Sub New ( _
    items As UnitOfMeasurementDetailsTypeCollection _
)
public:
UnitOfMeasurementDetailsTypeCollection(
    UnitOfMeasurementDetailsTypeCollection^ items
)
Parameters
items (UnitOfMeasurementDetailsTypeCollection)


UnitOfMeasurementType Class

UnitOfMeasurementType Class
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UnitOfMeasurementType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UnitOfMeasurementType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UnitOfMeasurementType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnitOfMeasurementType()()()() |
 | AlternateText |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SuggestedText |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
UnitOfMeasurementType


AlternateText Property

AlternateText Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementType ► AlternateText
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection AlternateText { get; set; }
Public Property AlternateText As StringCollection
    Get
    Set
public:
property StringCollection^ AlternateText {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SuggestedText Property

SuggestedText Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementType ► SuggestedText
Declaration Syntax
C# Visual Basic Visual C++
public string SuggestedText { get; set; }
Public Property SuggestedText As String
    Get
    Set
public:
property String^ SuggestedText {
    String^ get ();
    void set (String^ value);
}


UnitOfMeasurementType Constructor

UnitOfMeasurementType Constructor
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementType ► UnitOfMeasurementType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementType()
Public Sub New
public:
UnitOfMeasurementType()


UnitOfMeasurementTypeCollection Class

UnitOfMeasurementTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class UnitOfMeasurementTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class UnitOfMeasurementTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class UnitOfMeasurementTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnitOfMeasurementTypeCollection()()()() |
 | UnitOfMeasurementTypeCollection(array<UnitOfMeasurementType>[]()[][]) |
 | UnitOfMeasurementTypeCollection(UnitOfMeasurementTypeCollection) |
 | Add(UnitOfMeasurementType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<UnitOfMeasurementType>[]()[][]) |
 | AddRange(UnitOfMeasurementTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(UnitOfMeasurementType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<UnitOfMeasurementType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(UnitOfMeasurementType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, UnitOfMeasurementType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(UnitOfMeasurementType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | UnitOfMeasurementTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► Add(UnitOfMeasurementType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    UnitOfMeasurementType item
)
Public Function Add ( _
    item As UnitOfMeasurementType _
) As Integer
public:
int Add(
    UnitOfMeasurementType^ item
)
Parameters
item (UnitOfMeasurementType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<UnitOfMeasurementType>[]()[][]) |
 | AddRange(UnitOfMeasurementTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► AddRange(array<UnitOfMeasurementType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    UnitOfMeasurementType[] items
)
Public Sub AddRange ( _
    items As UnitOfMeasurementType() _
)
public:
void AddRange(
    array<UnitOfMeasurementType^>^ items
)
Parameters
items (array< UnitOfMeasurementType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► AddRange(UnitOfMeasurementTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    UnitOfMeasurementTypeCollection items
)
Public Sub AddRange ( _
    items As UnitOfMeasurementTypeCollection _
)
public:
void AddRange(
    UnitOfMeasurementTypeCollection^ items
)
Parameters
items (UnitOfMeasurementTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► Contains(UnitOfMeasurementType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    UnitOfMeasurementType item
)
Public Function Contains ( _
    item As UnitOfMeasurementType _
) As Boolean
public:
bool Contains(
    UnitOfMeasurementType^ item
)
Parameters
item (UnitOfMeasurementType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► CopyTo(array<UnitOfMeasurementType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    UnitOfMeasurementType[] items,
    int index
)
Public Sub CopyTo ( _
    items As UnitOfMeasurementType(), _
    index As Integer _
)
public:
void CopyTo(
    array<UnitOfMeasurementType^>^ items,
    int index
)
Parameters
items (array< UnitOfMeasurementType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► IndexOf(UnitOfMeasurementType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    UnitOfMeasurementType item
)
Public Function IndexOf ( _
    item As UnitOfMeasurementType _
) As Integer
public:
int IndexOf(
    UnitOfMeasurementType^ item
)
Parameters
item (UnitOfMeasurementType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► Insert(Int32, UnitOfMeasurementType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    UnitOfMeasurementType item
)
Public Sub Insert ( _
    index As Integer, _
    item As UnitOfMeasurementType _
)
public:
void Insert(
    int index,
    UnitOfMeasurementType^ item
)
Parameters
index (Int32)
item (UnitOfMeasurementType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As UnitOfMeasurementType
    Get
    Set
public:
property UnitOfMeasurementType^ default[int index] {
    UnitOfMeasurementType^ get (int index);
    void set (int index, UnitOfMeasurementType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As UnitOfMeasurementType
public:
UnitOfMeasurementType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► Remove(UnitOfMeasurementType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    UnitOfMeasurementType item
)
Public Sub Remove ( _
    item As UnitOfMeasurementType _
)
public:
void Remove(
    UnitOfMeasurementType^ item
)
Parameters
item (UnitOfMeasurementType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementType[] ToArray()
Public Function ToArray As UnitOfMeasurementType()
public:
array<UnitOfMeasurementType^>^ ToArray()
Return Value


UnitOfMeasurementTypeCollection Constructor

UnitOfMeasurementTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► UnitOfMeasurementTypeCollection()()()()
Members
Icon | Member | Description
 | UnitOfMeasurementTypeCollection()()()() |
 | UnitOfMeasurementTypeCollection(array<UnitOfMeasurementType>[]()[][]) |
 | UnitOfMeasurementTypeCollection(UnitOfMeasurementTypeCollection) |


UnitOfMeasurementTypeCollection Constructor

UnitOfMeasurementTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► UnitOfMeasurementTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementTypeCollection()
Public Sub New
public:
UnitOfMeasurementTypeCollection()


UnitOfMeasurementTypeCollection Constructor (items)

UnitOfMeasurementTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► UnitOfMeasurementTypeCollection(array<UnitOfMeasurementType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementTypeCollection(
    UnitOfMeasurementType[] items
)
Public Sub New ( _
    items As UnitOfMeasurementType() _
)
public:
UnitOfMeasurementTypeCollection(
    array<UnitOfMeasurementType^>^ items
)
Parameters
items (array< UnitOfMeasurementType >[]()[][])


UnitOfMeasurementTypeCollection Constructor (items)

UnitOfMeasurementTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► UnitOfMeasurementTypeCollection(UnitOfMeasurementTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public UnitOfMeasurementTypeCollection(
    UnitOfMeasurementTypeCollection items
)
Public Sub New ( _
    items As UnitOfMeasurementTypeCollection _
)
public:
UnitOfMeasurementTypeCollection(
    UnitOfMeasurementTypeCollection^ items
)
Parameters
items (UnitOfMeasurementTypeCollection)


UnpaidItemAssistancePreferencesType Class

UnpaidItemAssistancePreferencesType Class
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UnpaidItemAssistancePreferencesType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UnpaidItemAssistancePreferencesType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UnpaidItemAssistancePreferencesType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnpaidItemAssistancePreferencesType()()()() |
 | Any |
 | AutoOptDonationRefund |
 | AutoOptDonationRefundSpecified |
 | AutoRelist |
 | DelayBeforeOpeningDispute |
 | DelayBeforeOpeningDisputeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | ExcludedUser |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OptInStatus |
 | OptInStatusSpecified |
 | RemoveAllExcludedUsers |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
UnpaidItemAssistancePreferencesType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AutoOptDonationRefund Property

AutoOptDonationRefund Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType ► AutoOptDonationRefund
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoOptDonationRefund { get; set; }
Public Property AutoOptDonationRefund As Boolean
    Get
    Set
public:
property bool AutoOptDonationRefund {
    bool get ();
    void set (bool value);
}


AutoOptDonationRefundSpecified Property

AutoOptDonationRefundSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType ► AutoOptDonationRefundSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoOptDonationRefundSpecified { get; set; }
Public Property AutoOptDonationRefundSpecified As Boolean
    Get
    Set
public:
property bool AutoOptDonationRefundSpecified {
    bool get ();
    void set (bool value);
}


AutoRelist Property

AutoRelist Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType ► AutoRelist
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoRelist { get; set; }
Public Property AutoRelist As Boolean
    Get
    Set
public:
property bool AutoRelist {
    bool get ();
    void set (bool value);
}


DelayBeforeOpeningDispute Property

DelayBeforeOpeningDispute Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType ► DelayBeforeOpeningDispute
Declaration Syntax
C# Visual Basic Visual C++
public int DelayBeforeOpeningDispute { get; set; }
Public Property DelayBeforeOpeningDispute As Integer
    Get
    Set
public:
property int DelayBeforeOpeningDispute {
    int get ();
    void set (int value);
}


DelayBeforeOpeningDisputeSpecified Property

DelayBeforeOpeningDisputeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType ► DelayBeforeOpeningDisputeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DelayBeforeOpeningDisputeSpecified { get; set; }
Public Property DelayBeforeOpeningDisputeSpecified As Boolean
    Get
    Set
public:
property bool DelayBeforeOpeningDisputeSpecified {
    bool get ();
    void set (bool value);
}


ExcludedUser Property

ExcludedUser Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType ► ExcludedUser
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ExcludedUser { get; set; }
Public Property ExcludedUser As StringCollection
    Get
    Set
public:
property StringCollection^ ExcludedUser {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


OptInStatus Property

OptInStatus Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType ► OptInStatus
Declaration Syntax
C# Visual Basic Visual C++
public bool OptInStatus { get; set; }
Public Property OptInStatus As Boolean
    Get
    Set
public:
property bool OptInStatus {
    bool get ();
    void set (bool value);
}


OptInStatusSpecified Property

OptInStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType ► OptInStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool OptInStatusSpecified { get; set; }
Public Property OptInStatusSpecified As Boolean
    Get
    Set
public:
property bool OptInStatusSpecified {
    bool get ();
    void set (bool value);
}


RemoveAllExcludedUsers Property

RemoveAllExcludedUsers Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType ► RemoveAllExcludedUsers
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveAllExcludedUsers { get; set; }
Public Property RemoveAllExcludedUsers As Boolean
    Get
    Set
public:
property bool RemoveAllExcludedUsers {
    bool get ();
    void set (bool value);
}


UnpaidItemAssistancePreferencesType Constructor

UnpaidItemAssistancePreferencesType Constructor
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemAssistancePreferencesType ► UnpaidItemAssistancePreferencesType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UnpaidItemAssistancePreferencesType()
Public Sub New
public:
UnpaidItemAssistancePreferencesType()


UnpaidItemCaseOpenTypeCodeType Enumeration

UnpaidItemCaseOpenTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemCaseOpenTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum UnpaidItemCaseOpenTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration UnpaidItemCaseOpenTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class UnpaidItemCaseOpenTypeCodeType
Members
Member | Description
Auto |
Manual |
CustomCode |
Remarks


UnpaidItemCaseStatusTypeCodeType Enumeration

UnpaidItemCaseStatusTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemCaseStatusTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum UnpaidItemCaseStatusTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration UnpaidItemCaseStatusTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class UnpaidItemCaseStatusTypeCodeType
Members
Member | Description
Open |
ClosedWithPayment |
ClosedWithoutPayment |
CustomCode |
Remarks


UnpaidItemStatusTypeCodeType Enumeration

UnpaidItemStatusTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemStatusTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum UnpaidItemStatusTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration UnpaidItemStatusTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class UnpaidItemStatusTypeCodeType
Members
Member | Description
FinalValueFeeDenied |
FinalValueFeeCredited |
FinalValueFeeEligible |
AwaitingSellerResponse |
AwaitingBuyerResponse |
UnpaidItemFiled |
UnpaidItemEligible |
CustomCode |
Remarks


UnpaidItemType Class

UnpaidItemType Class
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UnpaidItemType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UnpaidItemType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UnpaidItemType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UnpaidItemType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Type |
 | TypeSpecified |
Remarks
Inheritance Hierarchy
Object
UnpaidItemType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public UnpaidItemCaseStatusTypeCodeType Status { get; set; }
Public Property Status As UnpaidItemCaseStatusTypeCodeType
    Get
    Set
public:
property UnpaidItemCaseStatusTypeCodeType Status {
    UnpaidItemCaseStatusTypeCodeType get ();
    void set (UnpaidItemCaseStatusTypeCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


Type Property

Type Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemType ► Type
Declaration Syntax
C# Visual Basic Visual C++
public UnpaidItemCaseOpenTypeCodeType Type { get; set; }
Public Property Type As UnpaidItemCaseOpenTypeCodeType
    Get
    Set
public:
property UnpaidItemCaseOpenTypeCodeType Type {
    UnpaidItemCaseOpenTypeCodeType get ();
    void set (UnpaidItemCaseOpenTypeCodeType value);
}


TypeSpecified Property

TypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemType ► TypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TypeSpecified { get; set; }
Public Property TypeSpecified As Boolean
    Get
    Set
public:
property bool TypeSpecified {
    bool get ();
    void set (bool value);
}


UnpaidItemType Constructor

UnpaidItemType Constructor
Namespaces ► eBay.Service.Core.Soap ► UnpaidItemType ► UnpaidItemType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UnpaidItemType()
Public Sub New
public:
UnpaidItemType()


UPCEnabledDefinitionType Class

UPCEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► UPCEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UPCEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UPCEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UPCEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UPCEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
UPCEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UPCEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


UPCEnabledDefinitionType Constructor

UPCEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► UPCEnabledDefinitionType ► UPCEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UPCEnabledDefinitionType()
Public Sub New
public:
UPCEnabledDefinitionType()


UPCIdentifierEnabledDefinitionType Class

UPCIdentifierEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► UPCIdentifierEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UPCIdentifierEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UPCIdentifierEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UPCIdentifierEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UPCIdentifierEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
UPCIdentifierEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UPCIdentifierEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


UPCIdentifierEnabledDefinitionType Constructor

UPCIdentifierEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► UPCIdentifierEnabledDefinitionType ► UPCIdentifierEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UPCIdentifierEnabledDefinitionType()
Public Sub New
public:
UPCIdentifierEnabledDefinitionType()


UploadSiteHostedPicturesRequestType Class

UploadSiteHostedPicturesRequestType Class
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UploadSiteHostedPicturesRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UploadSiteHostedPicturesRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UploadSiteHostedPicturesRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UploadSiteHostedPicturesRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | ExtensionInDays |
 | ExtensionInDaysSpecified |
 | ExternalPictureURL |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | PictureData |
 | PictureName |
 | PictureSet |
 | PictureSetSpecified |
 | PictureSystemVersion |
 | PictureSystemVersionSpecified |
 | PictureUploadPolicy |
 | PictureUploadPolicySpecified |
 | PictureWatermark |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | UploadSiteHostedPicturesRequestType


ExtensionInDays Property

ExtensionInDays Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► ExtensionInDays
Declaration Syntax
C# Visual Basic Visual C++
public int ExtensionInDays { get; set; }
Public Property ExtensionInDays As Integer
    Get
    Set
public:
property int ExtensionInDays {
    int get ();
    void set (int value);
}


ExtensionInDaysSpecified Property

ExtensionInDaysSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► ExtensionInDaysSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExtensionInDaysSpecified { get; set; }
Public Property ExtensionInDaysSpecified As Boolean
    Get
    Set
public:
property bool ExtensionInDaysSpecified {
    bool get ();
    void set (bool value);
}


ExternalPictureURL Property

ExternalPictureURL Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► ExternalPictureURL
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ExternalPictureURL { get; set; }
Public Property ExternalPictureURL As StringCollection
    Get
    Set
public:
property StringCollection^ ExternalPictureURL {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


PictureData Property

PictureData Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► PictureData
Declaration Syntax
C# Visual Basic Visual C++
public Base64BinaryType PictureData { get; set; }
Public Property PictureData As Base64BinaryType
    Get
    Set
public:
property Base64BinaryType^ PictureData {
    Base64BinaryType^ get ();
    void set (Base64BinaryType^ value);
}


PictureName Property

PictureName Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► PictureName
Declaration Syntax
C# Visual Basic Visual C++
public string PictureName { get; set; }
Public Property PictureName As String
    Get
    Set
public:
property String^ PictureName {
    String^ get ();
    void set (String^ value);
}


PictureSet Property

PictureSet Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► PictureSet
Declaration Syntax
C# Visual Basic Visual C++
public PictureSetCodeType PictureSet { get; set; }
Public Property PictureSet As PictureSetCodeType
    Get
    Set
public:
property PictureSetCodeType PictureSet {
    PictureSetCodeType get ();
    void set (PictureSetCodeType value);
}


PictureSetSpecified Property

PictureSetSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► PictureSetSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PictureSetSpecified { get; set; }
Public Property PictureSetSpecified As Boolean
    Get
    Set
public:
property bool PictureSetSpecified {
    bool get ();
    void set (bool value);
}


PictureSystemVersion Property

PictureSystemVersion Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► PictureSystemVersion
Declaration Syntax
C# Visual Basic Visual C++
public int PictureSystemVersion { get; set; }
Public Property PictureSystemVersion As Integer
    Get
    Set
public:
property int PictureSystemVersion {
    int get ();
    void set (int value);
}


PictureSystemVersionSpecified Property

PictureSystemVersionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► PictureSystemVersionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PictureSystemVersionSpecified { get; set; }
Public Property PictureSystemVersionSpecified As Boolean
    Get
    Set
public:
property bool PictureSystemVersionSpecified {
    bool get ();
    void set (bool value);
}


PictureUploadPolicy Property

PictureUploadPolicy Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► PictureUploadPolicy
Declaration Syntax
C# Visual Basic Visual C++
public PictureUploadPolicyCodeType PictureUploadPolicy { get; set; }
Public Property PictureUploadPolicy As PictureUploadPolicyCodeType
    Get
    Set
public:
property PictureUploadPolicyCodeType PictureUploadPolicy {
    PictureUploadPolicyCodeType get ();
    void set (PictureUploadPolicyCodeType value);
}


PictureUploadPolicySpecified Property

PictureUploadPolicySpecified Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► PictureUploadPolicySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PictureUploadPolicySpecified { get; set; }
Public Property PictureUploadPolicySpecified As Boolean
    Get
    Set
public:
property bool PictureUploadPolicySpecified {
    bool get ();
    void set (bool value);
}


PictureWatermark Property

PictureWatermark Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► PictureWatermark
Declaration Syntax
C# Visual Basic Visual C++
public PictureWatermarkCodeTypeCollection PictureWatermark { get; set; }
Public Property PictureWatermark As PictureWatermarkCodeTypeCollection
    Get
    Set
public:
property PictureWatermarkCodeTypeCollection^ PictureWatermark {
    PictureWatermarkCodeTypeCollection^ get ();
    void set (PictureWatermarkCodeTypeCollection^ value);
}


UploadSiteHostedPicturesRequestType Constructor

UploadSiteHostedPicturesRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesRequestType ► UploadSiteHostedPicturesRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UploadSiteHostedPicturesRequestType()
Public Sub New
public:
UploadSiteHostedPicturesRequestType()


UploadSiteHostedPicturesResponseType Class

UploadSiteHostedPicturesResponseType Class
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UploadSiteHostedPicturesResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UploadSiteHostedPicturesResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UploadSiteHostedPicturesResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UploadSiteHostedPicturesResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | PictureSystemVersion |
 | PictureSystemVersionSpecified |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SiteHostedPictureDetails |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | UploadSiteHostedPicturesResponseType


PictureSystemVersion Property

PictureSystemVersion Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesResponseType ► PictureSystemVersion
Declaration Syntax
C# Visual Basic Visual C++
public int PictureSystemVersion { get; set; }
Public Property PictureSystemVersion As Integer
    Get
    Set
public:
property int PictureSystemVersion {
    int get ();
    void set (int value);
}


PictureSystemVersionSpecified Property

PictureSystemVersionSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesResponseType ► PictureSystemVersionSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PictureSystemVersionSpecified { get; set; }
Public Property PictureSystemVersionSpecified As Boolean
    Get
    Set
public:
property bool PictureSystemVersionSpecified {
    bool get ();
    void set (bool value);
}


SiteHostedPictureDetails Property

SiteHostedPictureDetails Property
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesResponseType ► SiteHostedPictureDetails
Declaration Syntax
C# Visual Basic Visual C++
public SiteHostedPictureDetailsType SiteHostedPictureDetails { get; set; }
Public Property SiteHostedPictureDetails As SiteHostedPictureDetailsType
    Get
    Set
public:
property SiteHostedPictureDetailsType^ SiteHostedPictureDetails {
    SiteHostedPictureDetailsType^ get ();
    void set (SiteHostedPictureDetailsType^ value);
}


UploadSiteHostedPicturesResponseType Constructor

UploadSiteHostedPicturesResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► UploadSiteHostedPicturesResponseType ► UploadSiteHostedPicturesResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UploadSiteHostedPicturesResponseType()
Public Sub New
public:
UploadSiteHostedPicturesResponseType()


UPSRateOptionCodeType Enumeration

UPSRateOptionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► UPSRateOptionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum UPSRateOptionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration UPSRateOptionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class UPSRateOptionCodeType
Members
Member | Description
UPSDailyRates |
UPSOnDemandRates |
CustomCode |
Remarks


URLDetailsType Class

URLDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► URLDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class URLDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class URLDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class URLDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | URLDetailsType()()()() |
 | Any |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
 | URL |
 | URLType |
 | URLTypeSpecified |
Remarks
Inheritance Hierarchy
Object
URLDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


URL Property

URL Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsType ► URL
Declaration Syntax
C# Visual Basic Visual C++
public string URL { get; set; }
Public Property URL As String
    Get
    Set
public:
property String^ URL {
    String^ get ();
    void set (String^ value);
}


URLDetailsType Constructor

URLDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► URLDetailsType ► URLDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public URLDetailsType()
Public Sub New
public:
URLDetailsType()


URLType Property

URLType Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsType ► URLType
Declaration Syntax
C# Visual Basic Visual C++
public URLTypeCodeType URLType { get; set; }
Public Property URLType As URLTypeCodeType
    Get
    Set
public:
property URLTypeCodeType URLType {
    URLTypeCodeType get ();
    void set (URLTypeCodeType value);
}


URLTypeSpecified Property

URLTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsType ► URLTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool URLTypeSpecified { get; set; }
Public Property URLTypeSpecified As Boolean
    Get
    Set
public:
property bool URLTypeSpecified {
    bool get ();
    void set (bool value);
}


URLDetailsTypeCollection Class

URLDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class URLDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class URLDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class URLDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | URLDetailsTypeCollection()()()() |
 | URLDetailsTypeCollection(array<URLDetailsType>[]()[][]) |
 | URLDetailsTypeCollection(URLDetailsTypeCollection) |
 | Add(URLDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<URLDetailsType>[]()[][]) |
 | AddRange(URLDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(URLDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<URLDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(URLDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, URLDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(URLDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | URLDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► Add(URLDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    URLDetailsType item
)
Public Function Add ( _
    item As URLDetailsType _
) As Integer
public:
int Add(
    URLDetailsType^ item
)
Parameters
item (URLDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<URLDetailsType>[]()[][]) |
 | AddRange(URLDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► AddRange(array<URLDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    URLDetailsType[] items
)
Public Sub AddRange ( _
    items As URLDetailsType() _
)
public:
void AddRange(
    array<URLDetailsType^>^ items
)
Parameters
items (array< URLDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► AddRange(URLDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    URLDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As URLDetailsTypeCollection _
)
public:
void AddRange(
    URLDetailsTypeCollection^ items
)
Parameters
items (URLDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► Contains(URLDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    URLDetailsType item
)
Public Function Contains ( _
    item As URLDetailsType _
) As Boolean
public:
bool Contains(
    URLDetailsType^ item
)
Parameters
item (URLDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► CopyTo(array<URLDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    URLDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As URLDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<URLDetailsType^>^ items,
    int index
)
Parameters
items (array< URLDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► IndexOf(URLDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    URLDetailsType item
)
Public Function IndexOf ( _
    item As URLDetailsType _
) As Integer
public:
int IndexOf(
    URLDetailsType^ item
)
Parameters
item (URLDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► Insert(Int32, URLDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    URLDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As URLDetailsType _
)
public:
void Insert(
    int index,
    URLDetailsType^ item
)
Parameters
index (Int32)
item (URLDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public URLDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As URLDetailsType
    Get
    Set
public:
property URLDetailsType^ default[int index] {
    URLDetailsType^ get (int index);
    void set (int index, URLDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public URLDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As URLDetailsType
public:
URLDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► Remove(URLDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    URLDetailsType item
)
Public Sub Remove ( _
    item As URLDetailsType _
)
public:
void Remove(
    URLDetailsType^ item
)
Parameters
item (URLDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public URLDetailsType[] ToArray()
Public Function ToArray As URLDetailsType()
public:
array<URLDetailsType^>^ ToArray()
Return Value


URLDetailsTypeCollection Constructor

URLDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► URLDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | URLDetailsTypeCollection()()()() |
 | URLDetailsTypeCollection(array<URLDetailsType>[]()[][]) |
 | URLDetailsTypeCollection(URLDetailsTypeCollection) |


URLDetailsTypeCollection Constructor

URLDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► URLDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public URLDetailsTypeCollection()
Public Sub New
public:
URLDetailsTypeCollection()


URLDetailsTypeCollection Constructor (items)

URLDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► URLDetailsTypeCollection(array<URLDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public URLDetailsTypeCollection(
    URLDetailsType[] items
)
Public Sub New ( _
    items As URLDetailsType() _
)
public:
URLDetailsTypeCollection(
    array<URLDetailsType^>^ items
)
Parameters
items (array< URLDetailsType >[]()[][])


URLDetailsTypeCollection Constructor (items)

URLDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► URLDetailsTypeCollection(URLDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public URLDetailsTypeCollection(
    URLDetailsTypeCollection items
)
Public Sub New ( _
    items As URLDetailsTypeCollection _
)
public:
URLDetailsTypeCollection(
    URLDetailsTypeCollection^ items
)
Parameters
items (URLDetailsTypeCollection)


URLTypeCodeType Enumeration

URLTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► URLTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum URLTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration URLTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class URLTypeCodeType
Members
Member | Description
ViewItemURL |
ViewUserURL |
MyeBayURL |
MyeBayBiddingURL |
MyeBayNotWonURL |
MyeBayWonURL |
MyeBayWatchingURL |
eBayStoreURL |
SmallLogoURL |
MediumLogoURL |
LargeLogoURL |
CustomCode |
Remarks


UserAgreementInfoType Class

UserAgreementInfoType Class
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UserAgreementInfoType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UserAgreementInfoType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UserAgreementInfoType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserAgreementInfoType()()()() |
 | AcceptedTime |
 | AcceptedTimeSpecified |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SellereBayPaymentProcessEnableTime |
 | SellereBayPaymentProcessEnableTimeSpecified |
 | SellereBayPaymentProcessStatus |
 | SellereBayPaymentProcessStatusSpecified |
 | Site |
 | SiteSpecified |
 | ToString()()()() | (Inherited from Object.)
 | UserAgreementURL |
Remarks
Inheritance Hierarchy
Object
UserAgreementInfoType


AcceptedTime Property

AcceptedTime Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType ► AcceptedTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime AcceptedTime { get; set; }
Public Property AcceptedTime As DateTime
    Get
    Set
public:
property DateTime AcceptedTime {
    DateTime get ();
    void set (DateTime value);
}


AcceptedTimeSpecified Property

AcceptedTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType ► AcceptedTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AcceptedTimeSpecified { get; set; }
Public Property AcceptedTimeSpecified As Boolean
    Get
    Set
public:
property bool AcceptedTimeSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SellereBayPaymentProcessEnableTime Property

SellereBayPaymentProcessEnableTime Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType ► SellereBayPaymentProcessEnableTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime SellereBayPaymentProcessEnableTime { get; set; }
Public Property SellereBayPaymentProcessEnableTime As DateTime
    Get
    Set
public:
property DateTime SellereBayPaymentProcessEnableTime {
    DateTime get ();
    void set (DateTime value);
}


SellereBayPaymentProcessEnableTimeSpecified Property

SellereBayPaymentProcessEnableTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType ► SellereBayPaymentProcessEnableTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellereBayPaymentProcessEnableTimeSpecified { get; set; }
Public Property SellereBayPaymentProcessEnableTimeSpecified As Boolean
    Get
    Set
public:
property bool SellereBayPaymentProcessEnableTimeSpecified {
    bool get ();
    void set (bool value);
}


SellereBayPaymentProcessStatus Property

SellereBayPaymentProcessStatus Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType ► SellereBayPaymentProcessStatus
Declaration Syntax
C# Visual Basic Visual C++
public SellereBayPaymentProcessStatusCodeType SellereBayPaymentProcessStatus { get; set; }
Public Property SellereBayPaymentProcessStatus As SellereBayPaymentProcessStatusCodeType
    Get
    Set
public:
property SellereBayPaymentProcessStatusCodeType SellereBayPaymentProcessStatus {
    SellereBayPaymentProcessStatusCodeType get ();
    void set (SellereBayPaymentProcessStatusCodeType value);
}


SellereBayPaymentProcessStatusSpecified Property

SellereBayPaymentProcessStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType ► SellereBayPaymentProcessStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellereBayPaymentProcessStatusSpecified { get; set; }
Public Property SellereBayPaymentProcessStatusSpecified As Boolean
    Get
    Set
public:
property bool SellereBayPaymentProcessStatusSpecified {
    bool get ();
    void set (bool value);
}


Site Property

Site Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType ► Site
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType Site { get; set; }
Public Property Site As SiteCodeType
    Get
    Set
public:
property SiteCodeType Site {
    SiteCodeType get ();
    void set (SiteCodeType value);
}


SiteSpecified Property

SiteSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType ► SiteSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SiteSpecified { get; set; }
Public Property SiteSpecified As Boolean
    Get
    Set
public:
property bool SiteSpecified {
    bool get ();
    void set (bool value);
}


UserAgreementInfoType Constructor

UserAgreementInfoType Constructor
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType ► UserAgreementInfoType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UserAgreementInfoType()
Public Sub New
public:
UserAgreementInfoType()


UserAgreementURL Property

UserAgreementURL Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoType ► UserAgreementURL
Declaration Syntax
C# Visual Basic Visual C++
public string UserAgreementURL { get; set; }
Public Property UserAgreementURL As String
    Get
    Set
public:
property String^ UserAgreementURL {
    String^ get ();
    void set (String^ value);
}


UserAgreementInfoTypeCollection Class

UserAgreementInfoTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class UserAgreementInfoTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class UserAgreementInfoTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class UserAgreementInfoTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserAgreementInfoTypeCollection()()()() |
 | UserAgreementInfoTypeCollection(array<UserAgreementInfoType>[]()[][]) |
 | UserAgreementInfoTypeCollection(UserAgreementInfoTypeCollection) |
 | Add(UserAgreementInfoType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<UserAgreementInfoType>[]()[][]) |
 | AddRange(UserAgreementInfoTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(UserAgreementInfoType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<UserAgreementInfoType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(UserAgreementInfoType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, UserAgreementInfoType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(UserAgreementInfoType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | UserAgreementInfoTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► Add(UserAgreementInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    UserAgreementInfoType item
)
Public Function Add ( _
    item As UserAgreementInfoType _
) As Integer
public:
int Add(
    UserAgreementInfoType^ item
)
Parameters
item (UserAgreementInfoType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<UserAgreementInfoType>[]()[][]) |
 | AddRange(UserAgreementInfoTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► AddRange(array<UserAgreementInfoType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    UserAgreementInfoType[] items
)
Public Sub AddRange ( _
    items As UserAgreementInfoType() _
)
public:
void AddRange(
    array<UserAgreementInfoType^>^ items
)
Parameters
items (array< UserAgreementInfoType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► AddRange(UserAgreementInfoTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    UserAgreementInfoTypeCollection items
)
Public Sub AddRange ( _
    items As UserAgreementInfoTypeCollection _
)
public:
void AddRange(
    UserAgreementInfoTypeCollection^ items
)
Parameters
items (UserAgreementInfoTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► Contains(UserAgreementInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    UserAgreementInfoType item
)
Public Function Contains ( _
    item As UserAgreementInfoType _
) As Boolean
public:
bool Contains(
    UserAgreementInfoType^ item
)
Parameters
item (UserAgreementInfoType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► CopyTo(array<UserAgreementInfoType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    UserAgreementInfoType[] items,
    int index
)
Public Sub CopyTo ( _
    items As UserAgreementInfoType(), _
    index As Integer _
)
public:
void CopyTo(
    array<UserAgreementInfoType^>^ items,
    int index
)
Parameters
items (array< UserAgreementInfoType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► IndexOf(UserAgreementInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    UserAgreementInfoType item
)
Public Function IndexOf ( _
    item As UserAgreementInfoType _
) As Integer
public:
int IndexOf(
    UserAgreementInfoType^ item
)
Parameters
item (UserAgreementInfoType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► Insert(Int32, UserAgreementInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    UserAgreementInfoType item
)
Public Sub Insert ( _
    index As Integer, _
    item As UserAgreementInfoType _
)
public:
void Insert(
    int index,
    UserAgreementInfoType^ item
)
Parameters
index (Int32)
item (UserAgreementInfoType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public UserAgreementInfoType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As UserAgreementInfoType
    Get
    Set
public:
property UserAgreementInfoType^ default[int index] {
    UserAgreementInfoType^ get (int index);
    void set (int index, UserAgreementInfoType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public UserAgreementInfoType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As UserAgreementInfoType
public:
UserAgreementInfoType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► Remove(UserAgreementInfoType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    UserAgreementInfoType item
)
Public Sub Remove ( _
    item As UserAgreementInfoType _
)
public:
void Remove(
    UserAgreementInfoType^ item
)
Parameters
item (UserAgreementInfoType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UserAgreementInfoType[] ToArray()
Public Function ToArray As UserAgreementInfoType()
public:
array<UserAgreementInfoType^>^ ToArray()
Return Value


UserAgreementInfoTypeCollection Constructor

UserAgreementInfoTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► UserAgreementInfoTypeCollection()()()()
Members
Icon | Member | Description
 | UserAgreementInfoTypeCollection()()()() |
 | UserAgreementInfoTypeCollection(array<UserAgreementInfoType>[]()[][]) |
 | UserAgreementInfoTypeCollection(UserAgreementInfoTypeCollection) |


UserAgreementInfoTypeCollection Constructor

UserAgreementInfoTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► UserAgreementInfoTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UserAgreementInfoTypeCollection()
Public Sub New
public:
UserAgreementInfoTypeCollection()


UserAgreementInfoTypeCollection Constructor (items)

UserAgreementInfoTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► UserAgreementInfoTypeCollection(array<UserAgreementInfoType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public UserAgreementInfoTypeCollection(
    UserAgreementInfoType[] items
)
Public Sub New ( _
    items As UserAgreementInfoType() _
)
public:
UserAgreementInfoTypeCollection(
    array<UserAgreementInfoType^>^ items
)
Parameters
items (array< UserAgreementInfoType >[]()[][])


UserAgreementInfoTypeCollection Constructor (items)

UserAgreementInfoTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► UserAgreementInfoTypeCollection(UserAgreementInfoTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public UserAgreementInfoTypeCollection(
    UserAgreementInfoTypeCollection items
)
Public Sub New ( _
    items As UserAgreementInfoTypeCollection _
)
public:
UserAgreementInfoTypeCollection(
    UserAgreementInfoTypeCollection^ items
)
Parameters
items (UserAgreementInfoTypeCollection)


UserConsentRequiredDefinitionType Class

UserConsentRequiredDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► UserConsentRequiredDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UserConsentRequiredDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UserConsentRequiredDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UserConsentRequiredDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserConsentRequiredDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
UserConsentRequiredDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UserConsentRequiredDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


UserConsentRequiredDefinitionType Constructor

UserConsentRequiredDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► UserConsentRequiredDefinitionType ► UserConsentRequiredDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UserConsentRequiredDefinitionType()
Public Sub New
public:
UserConsentRequiredDefinitionType()


UserDefinedListType Class

UserDefinedListType Class
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UserDefinedListType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UserDefinedListType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UserDefinedListType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDefinedListType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | FavoriteSearcheCount |
 | FavoriteSearcheCountSpecified |
 | FavoriteSearches |
 | FavoriteSellerCount |
 | FavoriteSellerCountSpecified |
 | FavoriteSellers |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemArray |
 | ItemCount |
 | ItemCountSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
UserDefinedListType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FavoriteSearcheCount Property

FavoriteSearcheCount Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► FavoriteSearcheCount
Declaration Syntax
C# Visual Basic Visual C++
public int FavoriteSearcheCount { get; set; }
Public Property FavoriteSearcheCount As Integer
    Get
    Set
public:
property int FavoriteSearcheCount {
    int get ();
    void set (int value);
}


FavoriteSearcheCountSpecified Property

FavoriteSearcheCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► FavoriteSearcheCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FavoriteSearcheCountSpecified { get; set; }
Public Property FavoriteSearcheCountSpecified As Boolean
    Get
    Set
public:
property bool FavoriteSearcheCountSpecified {
    bool get ();
    void set (bool value);
}


FavoriteSearches Property

FavoriteSearches Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► FavoriteSearches
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSearchListType FavoriteSearches { get; set; }
Public Property FavoriteSearches As MyeBayFavoriteSearchListType
    Get
    Set
public:
property MyeBayFavoriteSearchListType^ FavoriteSearches {
    MyeBayFavoriteSearchListType^ get ();
    void set (MyeBayFavoriteSearchListType^ value);
}


FavoriteSellerCount Property

FavoriteSellerCount Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► FavoriteSellerCount
Declaration Syntax
C# Visual Basic Visual C++
public int FavoriteSellerCount { get; set; }
Public Property FavoriteSellerCount As Integer
    Get
    Set
public:
property int FavoriteSellerCount {
    int get ();
    void set (int value);
}


FavoriteSellerCountSpecified Property

FavoriteSellerCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► FavoriteSellerCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FavoriteSellerCountSpecified { get; set; }
Public Property FavoriteSellerCountSpecified As Boolean
    Get
    Set
public:
property bool FavoriteSellerCountSpecified {
    bool get ();
    void set (bool value);
}


FavoriteSellers Property

FavoriteSellers Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► FavoriteSellers
Declaration Syntax
C# Visual Basic Visual C++
public MyeBayFavoriteSellerListType FavoriteSellers { get; set; }
Public Property FavoriteSellers As MyeBayFavoriteSellerListType
    Get
    Set
public:
property MyeBayFavoriteSellerListType^ FavoriteSellers {
    MyeBayFavoriteSellerListType^ get ();
    void set (MyeBayFavoriteSellerListType^ value);
}


ItemArray Property

ItemArray Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► ItemArray
Declaration Syntax
C# Visual Basic Visual C++
public ItemTypeCollection ItemArray { get; set; }
Public Property ItemArray As ItemTypeCollection
    Get
    Set
public:
property ItemTypeCollection^ ItemArray {
    ItemTypeCollection^ get ();
    void set (ItemTypeCollection^ value);
}


ItemCount Property

ItemCount Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► ItemCount
Declaration Syntax
C# Visual Basic Visual C++
public int ItemCount { get; set; }
Public Property ItemCount As Integer
    Get
    Set
public:
property int ItemCount {
    int get ();
    void set (int value);
}


ItemCountSpecified Property

ItemCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► ItemCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemCountSpecified { get; set; }
Public Property ItemCountSpecified As Boolean
    Get
    Set
public:
property bool ItemCountSpecified {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


UserDefinedListType Constructor

UserDefinedListType Constructor
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListType ► UserDefinedListType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UserDefinedListType()
Public Sub New
public:
UserDefinedListType()


UserDefinedListTypeCollection Class

UserDefinedListTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class UserDefinedListTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class UserDefinedListTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class UserDefinedListTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDefinedListTypeCollection()()()() |
 | UserDefinedListTypeCollection(array<UserDefinedListType>[]()[][]) |
 | UserDefinedListTypeCollection(UserDefinedListTypeCollection) |
 | Add(UserDefinedListType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<UserDefinedListType>[]()[][]) |
 | AddRange(UserDefinedListTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(UserDefinedListType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<UserDefinedListType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(UserDefinedListType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, UserDefinedListType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(UserDefinedListType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | UserDefinedListTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► Add(UserDefinedListType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    UserDefinedListType item
)
Public Function Add ( _
    item As UserDefinedListType _
) As Integer
public:
int Add(
    UserDefinedListType^ item
)
Parameters
item (UserDefinedListType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<UserDefinedListType>[]()[][]) |
 | AddRange(UserDefinedListTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► AddRange(array<UserDefinedListType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    UserDefinedListType[] items
)
Public Sub AddRange ( _
    items As UserDefinedListType() _
)
public:
void AddRange(
    array<UserDefinedListType^>^ items
)
Parameters
items (array< UserDefinedListType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► AddRange(UserDefinedListTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    UserDefinedListTypeCollection items
)
Public Sub AddRange ( _
    items As UserDefinedListTypeCollection _
)
public:
void AddRange(
    UserDefinedListTypeCollection^ items
)
Parameters
items (UserDefinedListTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► Contains(UserDefinedListType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    UserDefinedListType item
)
Public Function Contains ( _
    item As UserDefinedListType _
) As Boolean
public:
bool Contains(
    UserDefinedListType^ item
)
Parameters
item (UserDefinedListType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► CopyTo(array<UserDefinedListType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    UserDefinedListType[] items,
    int index
)
Public Sub CopyTo ( _
    items As UserDefinedListType(), _
    index As Integer _
)
public:
void CopyTo(
    array<UserDefinedListType^>^ items,
    int index
)
Parameters
items (array< UserDefinedListType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► IndexOf(UserDefinedListType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    UserDefinedListType item
)
Public Function IndexOf ( _
    item As UserDefinedListType _
) As Integer
public:
int IndexOf(
    UserDefinedListType^ item
)
Parameters
item (UserDefinedListType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► Insert(Int32, UserDefinedListType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    UserDefinedListType item
)
Public Sub Insert ( _
    index As Integer, _
    item As UserDefinedListType _
)
public:
void Insert(
    int index,
    UserDefinedListType^ item
)
Parameters
index (Int32)
item (UserDefinedListType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public UserDefinedListType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As UserDefinedListType
    Get
    Set
public:
property UserDefinedListType^ default[int index] {
    UserDefinedListType^ get (int index);
    void set (int index, UserDefinedListType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public UserDefinedListType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As UserDefinedListType
public:
UserDefinedListType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► Remove(UserDefinedListType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    UserDefinedListType item
)
Public Sub Remove ( _
    item As UserDefinedListType _
)
public:
void Remove(
    UserDefinedListType^ item
)
Parameters
item (UserDefinedListType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UserDefinedListType[] ToArray()
Public Function ToArray As UserDefinedListType()
public:
array<UserDefinedListType^>^ ToArray()
Return Value


UserDefinedListTypeCollection Constructor

UserDefinedListTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► UserDefinedListTypeCollection()()()()
Members
Icon | Member | Description
 | UserDefinedListTypeCollection()()()() |
 | UserDefinedListTypeCollection(array<UserDefinedListType>[]()[][]) |
 | UserDefinedListTypeCollection(UserDefinedListTypeCollection) |


UserDefinedListTypeCollection Constructor

UserDefinedListTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► UserDefinedListTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UserDefinedListTypeCollection()
Public Sub New
public:
UserDefinedListTypeCollection()


UserDefinedListTypeCollection Constructor (items)

UserDefinedListTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► UserDefinedListTypeCollection(array<UserDefinedListType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public UserDefinedListTypeCollection(
    UserDefinedListType[] items
)
Public Sub New ( _
    items As UserDefinedListType() _
)
public:
UserDefinedListTypeCollection(
    array<UserDefinedListType^>^ items
)
Parameters
items (array< UserDefinedListType >[]()[][])


UserDefinedListTypeCollection Constructor (items)

UserDefinedListTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► UserDefinedListTypeCollection(UserDefinedListTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public UserDefinedListTypeCollection(
    UserDefinedListTypeCollection items
)
Public Sub New ( _
    items As UserDefinedListTypeCollection _
)
public:
UserDefinedListTypeCollection(
    UserDefinedListTypeCollection^ items
)
Parameters
items (UserDefinedListTypeCollection)


UserIDArrayType Class

UserIDArrayType Class
Namespaces ► eBay.Service.Core.Soap ► UserIDArrayType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UserIDArrayType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UserIDArrayType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UserIDArrayType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserIDArrayType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UserID |
Remarks
Inheritance Hierarchy
Object
UserIDArrayType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UserIDArrayType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► UserIDArrayType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection UserID { get; set; }
Public Property UserID As StringCollection
    Get
    Set
public:
property StringCollection^ UserID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


UserIDArrayType Constructor

UserIDArrayType Constructor
Namespaces ► eBay.Service.Core.Soap ► UserIDArrayType ► UserIDArrayType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UserIDArrayType()
Public Sub New
public:
UserIDArrayType()


UserIdentityCodeType Enumeration

UserIdentityCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► UserIdentityCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum UserIdentityCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration UserIdentityCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class UserIdentityCodeType
Members
Member | Description
eBayUser |
eBayPartner |
CustomCode |
Remarks


UserIdentityType Class

UserIdentityType Class
Namespaces ► eBay.Service.Core.Soap ► UserIdentityType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UserIdentityType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UserIdentityType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UserIdentityType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserIdentityType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | type |
 | typeSpecified |
 | Value |
Remarks
Inheritance Hierarchy
Object
UserIdentityType


type Property

type Property
Namespaces ► eBay.Service.Core.Soap ► UserIdentityType ► type
Declaration Syntax
C# Visual Basic Visual C++
public UserIdentityCodeType type { get; set; }
Public Property type As UserIdentityCodeType
    Get
    Set
public:
property UserIdentityCodeType type {
    UserIdentityCodeType get ();
    void set (UserIdentityCodeType value);
}


typeSpecified Property

typeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserIdentityType ► typeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool typeSpecified { get; set; }
Public Property typeSpecified As Boolean
    Get
    Set
public:
property bool typeSpecified {
    bool get ();
    void set (bool value);
}


UserIdentityType Constructor

UserIdentityType Constructor
Namespaces ► eBay.Service.Core.Soap ► UserIdentityType ► UserIdentityType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UserIdentityType()
Public Sub New
public:
UserIdentityType()


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► UserIdentityType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


UserIdPasswordType Class

UserIdPasswordType Class
Namespaces ► eBay.Service.Core.Soap ► UserIdPasswordType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UserIdPasswordType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UserIdPasswordType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UserIdPasswordType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserIdPasswordType()()()() |
 | Any |
 | AppId |
 | AuthCert |
 | DevId |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Password |
 | ToString()()()() | (Inherited from Object.)
 | Username |
Remarks
Inheritance Hierarchy
Object
UserIdPasswordType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UserIdPasswordType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


AppId Property

AppId Property
Namespaces ► eBay.Service.Core.Soap ► UserIdPasswordType ► AppId
Declaration Syntax
C# Visual Basic Visual C++
public string AppId { get; set; }
Public Property AppId As String
    Get
    Set
public:
property String^ AppId {
    String^ get ();
    void set (String^ value);
}


AuthCert Property

AuthCert Property
Namespaces ► eBay.Service.Core.Soap ► UserIdPasswordType ► AuthCert
Declaration Syntax
C# Visual Basic Visual C++
public string AuthCert { get; set; }
Public Property AuthCert As String
    Get
    Set
public:
property String^ AuthCert {
    String^ get ();
    void set (String^ value);
}


DevId Property

DevId Property
Namespaces ► eBay.Service.Core.Soap ► UserIdPasswordType ► DevId
Declaration Syntax
C# Visual Basic Visual C++
public string DevId { get; set; }
Public Property DevId As String
    Get
    Set
public:
property String^ DevId {
    String^ get ();
    void set (String^ value);
}


Password Property

Password Property
Namespaces ► eBay.Service.Core.Soap ► UserIdPasswordType ► Password
Declaration Syntax
C# Visual Basic Visual C++
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}


UserIdPasswordType Constructor

UserIdPasswordType Constructor
Namespaces ► eBay.Service.Core.Soap ► UserIdPasswordType ► UserIdPasswordType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UserIdPasswordType()
Public Sub New
public:
UserIdPasswordType()


Username Property

Username Property
Namespaces ► eBay.Service.Core.Soap ► UserIdPasswordType ► Username
Declaration Syntax
C# Visual Basic Visual C++
public string Username { get; set; }
Public Property Username As String
    Get
    Set
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}


UserStatusCodeType Enumeration

UserStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► UserStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum UserStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration UserStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class UserStatusCodeType
Members
Member | Description
Unknown |
Suspended |
Confirmed |
Unconfirmed |
Ghost |
InMaintenance |
Deleted |
CreditCardVerify |
AccountOnHold |
Merged |
RegistrationCodeMailOut |
TermPending |
UnconfirmedHalfOptIn |
CreditCardVerifyHalfOptIn |
UnconfirmedPassport |
CreditCardVerifyPassport |
UnconfirmedExpress |
Guest |
CustomCode |
Remarks


UserType Class

UserType Class
Namespaces ► eBay.Service.Core.Soap ► UserType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class UserType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class UserType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class UserType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserType()()()() |
 | AboutMePage |
 | AboutMePageSpecified |
 | Any |
 | BiddingSummary |
 | BillingEmail |
 | BusinessRole |
 | BusinessRoleSpecified |
 | BuyerInfo |
 | CharityAffiliations |
 | eBayGoodStanding |
 | eBayGoodStandingSpecified |
 | eBayWikiReadOnly |
 | eBayWikiReadOnlySpecified |
 | EIASToken |
 | Email |
 | EnterpriseSeller |
 | EnterpriseSellerSpecified |
 | Equals(Object) | (Inherited from Object.)
 | FeedbackPrivate |
 | FeedbackPrivateSpecified |
 | FeedbackRatingStar |
 | FeedbackRatingStarSpecified |
 | FeedbackScore |
 | FeedbackScoreSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IDVerified |
 | IDVerifiedSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MotorsDealer |
 | MotorsDealerSpecified |
 | NewUser |
 | NewUserSpecified |
 | PayPalAccountLevel |
 | PayPalAccountLevelSpecified |
 | PayPalAccountStatus |
 | PayPalAccountStatusSpecified |
 | PayPalAccountType |
 | PayPalAccountTypeSpecified |
 | PositiveFeedbackPercent |
 | PositiveFeedbackPercentSpecified |
 | QualifiesForSelling |
 | QualifiesForSellingSpecified |
 | RegistrationAddress |
 | RegistrationDate |
 | RegistrationDateSpecified |
 | SellerInfo |
 | SellerPaymentMethod |
 | SellerPaymentMethodSpecified |
 | ShippingAddress |
 | Site |
 | SiteSpecified |
 | SiteVerified |
 | SiteVerifiedSpecified |
 | SkypeID |
 | StaticAlias |
 | Status |
 | StatusSpecified |
 | ToString()()()() | (Inherited from Object.)
 | TUVLevel |
 | TUVLevelSpecified |
 | UniqueNegativeFeedbackCount |
 | UniqueNegativeFeedbackCountSpecified |
 | UniqueNeutralFeedbackCount |
 | UniqueNeutralFeedbackCountSpecified |
 | UniquePositiveFeedbackCount |
 | UniquePositiveFeedbackCountSpecified |
 | UserAnonymized |
 | UserAnonymizedSpecified |
 | UserFirstName |
 | UserID |
 | UserIDChanged |
 | UserIDChangedSpecified |
 | UserIDLastChanged |
 | UserIDLastChangedSpecified |
 | UserLastName |
 | UserSubscription |
 | VATID |
 | VATStatus |
 | VATStatusSpecified |
Remarks
Inheritance Hierarchy
Object
UserType


AboutMePage Property

AboutMePage Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► AboutMePage
Declaration Syntax
C# Visual Basic Visual C++
public bool AboutMePage { get; set; }
Public Property AboutMePage As Boolean
    Get
    Set
public:
property bool AboutMePage {
    bool get ();
    void set (bool value);
}


AboutMePageSpecified Property

AboutMePageSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► AboutMePageSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool AboutMePageSpecified { get; set; }
Public Property AboutMePageSpecified As Boolean
    Get
    Set
public:
property bool AboutMePageSpecified {
    bool get ();
    void set (bool value);
}


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BiddingSummary Property

BiddingSummary Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► BiddingSummary
Declaration Syntax
C# Visual Basic Visual C++
public BiddingSummaryType BiddingSummary { get; set; }
Public Property BiddingSummary As BiddingSummaryType
    Get
    Set
public:
property BiddingSummaryType^ BiddingSummary {
    BiddingSummaryType^ get ();
    void set (BiddingSummaryType^ value);
}


BillingEmail Property

BillingEmail Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► BillingEmail
Declaration Syntax
C# Visual Basic Visual C++
public string BillingEmail { get; set; }
Public Property BillingEmail As String
    Get
    Set
public:
property String^ BillingEmail {
    String^ get ();
    void set (String^ value);
}


BusinessRole Property

BusinessRole Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► BusinessRole
Declaration Syntax
C# Visual Basic Visual C++
public BusinessRoleType BusinessRole { get; set; }
Public Property BusinessRole As BusinessRoleType
    Get
    Set
public:
property BusinessRoleType BusinessRole {
    BusinessRoleType get ();
    void set (BusinessRoleType value);
}


BusinessRoleSpecified Property

BusinessRoleSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► BusinessRoleSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BusinessRoleSpecified { get; set; }
Public Property BusinessRoleSpecified As Boolean
    Get
    Set
public:
property bool BusinessRoleSpecified {
    bool get ();
    void set (bool value);
}


BuyerInfo Property

BuyerInfo Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► BuyerInfo
Declaration Syntax
C# Visual Basic Visual C++
public BuyerType BuyerInfo { get; set; }
Public Property BuyerInfo As BuyerType
    Get
    Set
public:
property BuyerType^ BuyerInfo {
    BuyerType^ get ();
    void set (BuyerType^ value);
}


CharityAffiliations Property

CharityAffiliations Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► CharityAffiliations
Declaration Syntax
C# Visual Basic Visual C++
public CharityAffiliationsType CharityAffiliations { get; set; }
Public Property CharityAffiliations As CharityAffiliationsType
    Get
    Set
public:
property CharityAffiliationsType^ CharityAffiliations {
    CharityAffiliationsType^ get ();
    void set (CharityAffiliationsType^ value);
}


eBayGoodStanding Property

eBayGoodStanding Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► eBayGoodStanding
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayGoodStanding { get; set; }
Public Property eBayGoodStanding As Boolean
    Get
    Set
public:
property bool eBayGoodStanding {
    bool get ();
    void set (bool value);
}


eBayGoodStandingSpecified Property

eBayGoodStandingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► eBayGoodStandingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayGoodStandingSpecified { get; set; }
Public Property eBayGoodStandingSpecified As Boolean
    Get
    Set
public:
property bool eBayGoodStandingSpecified {
    bool get ();
    void set (bool value);
}


eBayWikiReadOnly Property

eBayWikiReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► eBayWikiReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayWikiReadOnly { get; set; }
Public Property eBayWikiReadOnly As Boolean
    Get
    Set
public:
property bool eBayWikiReadOnly {
    bool get ();
    void set (bool value);
}


eBayWikiReadOnlySpecified Property

eBayWikiReadOnlySpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► eBayWikiReadOnlySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool eBayWikiReadOnlySpecified { get; set; }
Public Property eBayWikiReadOnlySpecified As Boolean
    Get
    Set
public:
property bool eBayWikiReadOnlySpecified {
    bool get ();
    void set (bool value);
}


EIASToken Property

EIASToken Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► EIASToken
Declaration Syntax
C# Visual Basic Visual C++
public string EIASToken { get; set; }
Public Property EIASToken As String
    Get
    Set
public:
property String^ EIASToken {
    String^ get ();
    void set (String^ value);
}


Email Property

Email Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► Email
Declaration Syntax
C# Visual Basic Visual C++
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}


EnterpriseSeller Property

EnterpriseSeller Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► EnterpriseSeller
Declaration Syntax
C# Visual Basic Visual C++
public bool EnterpriseSeller { get; set; }
Public Property EnterpriseSeller As Boolean
    Get
    Set
public:
property bool EnterpriseSeller {
    bool get ();
    void set (bool value);
}


EnterpriseSellerSpecified Property

EnterpriseSellerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► EnterpriseSellerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EnterpriseSellerSpecified { get; set; }
Public Property EnterpriseSellerSpecified As Boolean
    Get
    Set
public:
property bool EnterpriseSellerSpecified {
    bool get ();
    void set (bool value);
}


FeedbackPrivate Property

FeedbackPrivate Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► FeedbackPrivate
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackPrivate { get; set; }
Public Property FeedbackPrivate As Boolean
    Get
    Set
public:
property bool FeedbackPrivate {
    bool get ();
    void set (bool value);
}


FeedbackPrivateSpecified Property

FeedbackPrivateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► FeedbackPrivateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackPrivateSpecified { get; set; }
Public Property FeedbackPrivateSpecified As Boolean
    Get
    Set
public:
property bool FeedbackPrivateSpecified {
    bool get ();
    void set (bool value);
}


FeedbackRatingStar Property

FeedbackRatingStar Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► FeedbackRatingStar
Declaration Syntax
C# Visual Basic Visual C++
public FeedbackRatingStarCodeType FeedbackRatingStar { get; set; }
Public Property FeedbackRatingStar As FeedbackRatingStarCodeType
    Get
    Set
public:
property FeedbackRatingStarCodeType FeedbackRatingStar {
    FeedbackRatingStarCodeType get ();
    void set (FeedbackRatingStarCodeType value);
}


FeedbackRatingStarSpecified Property

FeedbackRatingStarSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► FeedbackRatingStarSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackRatingStarSpecified { get; set; }
Public Property FeedbackRatingStarSpecified As Boolean
    Get
    Set
public:
property bool FeedbackRatingStarSpecified {
    bool get ();
    void set (bool value);
}


FeedbackScore Property

FeedbackScore Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► FeedbackScore
Declaration Syntax
C# Visual Basic Visual C++
public int FeedbackScore { get; set; }
Public Property FeedbackScore As Integer
    Get
    Set
public:
property int FeedbackScore {
    int get ();
    void set (int value);
}


FeedbackScoreSpecified Property

FeedbackScoreSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► FeedbackScoreSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackScoreSpecified { get; set; }
Public Property FeedbackScoreSpecified As Boolean
    Get
    Set
public:
property bool FeedbackScoreSpecified {
    bool get ();
    void set (bool value);
}


IDVerified Property

IDVerified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► IDVerified
Declaration Syntax
C# Visual Basic Visual C++
public bool IDVerified { get; set; }
Public Property IDVerified As Boolean
    Get
    Set
public:
property bool IDVerified {
    bool get ();
    void set (bool value);
}


IDVerifiedSpecified Property

IDVerifiedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► IDVerifiedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IDVerifiedSpecified { get; set; }
Public Property IDVerifiedSpecified As Boolean
    Get
    Set
public:
property bool IDVerifiedSpecified {
    bool get ();
    void set (bool value);
}


MotorsDealer Property

MotorsDealer Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► MotorsDealer
Declaration Syntax
C# Visual Basic Visual C++
public bool MotorsDealer { get; set; }
Public Property MotorsDealer As Boolean
    Get
    Set
public:
property bool MotorsDealer {
    bool get ();
    void set (bool value);
}


MotorsDealerSpecified Property

MotorsDealerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► MotorsDealerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MotorsDealerSpecified { get; set; }
Public Property MotorsDealerSpecified As Boolean
    Get
    Set
public:
property bool MotorsDealerSpecified {
    bool get ();
    void set (bool value);
}


NewUser Property

NewUser Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► NewUser
Declaration Syntax
C# Visual Basic Visual C++
public bool NewUser { get; set; }
Public Property NewUser As Boolean
    Get
    Set
public:
property bool NewUser {
    bool get ();
    void set (bool value);
}


NewUserSpecified Property

NewUserSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► NewUserSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool NewUserSpecified { get; set; }
Public Property NewUserSpecified As Boolean
    Get
    Set
public:
property bool NewUserSpecified {
    bool get ();
    void set (bool value);
}


PayPalAccountLevel Property

PayPalAccountLevel Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► PayPalAccountLevel
Declaration Syntax
C# Visual Basic Visual C++
public PayPalAccountLevelCodeType PayPalAccountLevel { get; set; }
Public Property PayPalAccountLevel As PayPalAccountLevelCodeType
    Get
    Set
public:
property PayPalAccountLevelCodeType PayPalAccountLevel {
    PayPalAccountLevelCodeType get ();
    void set (PayPalAccountLevelCodeType value);
}


PayPalAccountLevelSpecified Property

PayPalAccountLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► PayPalAccountLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalAccountLevelSpecified { get; set; }
Public Property PayPalAccountLevelSpecified As Boolean
    Get
    Set
public:
property bool PayPalAccountLevelSpecified {
    bool get ();
    void set (bool value);
}


PayPalAccountStatus Property

PayPalAccountStatus Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► PayPalAccountStatus
Declaration Syntax
C# Visual Basic Visual C++
public PayPalAccountStatusCodeType PayPalAccountStatus { get; set; }
Public Property PayPalAccountStatus As PayPalAccountStatusCodeType
    Get
    Set
public:
property PayPalAccountStatusCodeType PayPalAccountStatus {
    PayPalAccountStatusCodeType get ();
    void set (PayPalAccountStatusCodeType value);
}


PayPalAccountStatusSpecified Property

PayPalAccountStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► PayPalAccountStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalAccountStatusSpecified { get; set; }
Public Property PayPalAccountStatusSpecified As Boolean
    Get
    Set
public:
property bool PayPalAccountStatusSpecified {
    bool get ();
    void set (bool value);
}


PayPalAccountType Property

PayPalAccountType Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► PayPalAccountType
Declaration Syntax
C# Visual Basic Visual C++
public PayPalAccountTypeCodeType PayPalAccountType { get; set; }
Public Property PayPalAccountType As PayPalAccountTypeCodeType
    Get
    Set
public:
property PayPalAccountTypeCodeType PayPalAccountType {
    PayPalAccountTypeCodeType get ();
    void set (PayPalAccountTypeCodeType value);
}


PayPalAccountTypeSpecified Property

PayPalAccountTypeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► PayPalAccountTypeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PayPalAccountTypeSpecified { get; set; }
Public Property PayPalAccountTypeSpecified As Boolean
    Get
    Set
public:
property bool PayPalAccountTypeSpecified {
    bool get ();
    void set (bool value);
}


PositiveFeedbackPercent Property

PositiveFeedbackPercent Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► PositiveFeedbackPercent
Declaration Syntax
C# Visual Basic Visual C++
public float PositiveFeedbackPercent { get; set; }
Public Property PositiveFeedbackPercent As Single
    Get
    Set
public:
property float PositiveFeedbackPercent {
    float get ();
    void set (float value);
}


PositiveFeedbackPercentSpecified Property

PositiveFeedbackPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► PositiveFeedbackPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool PositiveFeedbackPercentSpecified { get; set; }
Public Property PositiveFeedbackPercentSpecified As Boolean
    Get
    Set
public:
property bool PositiveFeedbackPercentSpecified {
    bool get ();
    void set (bool value);
}


QualifiesForSelling Property

QualifiesForSelling Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► QualifiesForSelling
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiesForSelling { get; set; }
Public Property QualifiesForSelling As Boolean
    Get
    Set
public:
property bool QualifiesForSelling {
    bool get ();
    void set (bool value);
}


QualifiesForSellingSpecified Property

QualifiesForSellingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► QualifiesForSellingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QualifiesForSellingSpecified { get; set; }
Public Property QualifiesForSellingSpecified As Boolean
    Get
    Set
public:
property bool QualifiesForSellingSpecified {
    bool get ();
    void set (bool value);
}


RegistrationAddress Property

RegistrationAddress Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► RegistrationAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType RegistrationAddress { get; set; }
Public Property RegistrationAddress As AddressType
    Get
    Set
public:
property AddressType^ RegistrationAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


RegistrationDate Property

RegistrationDate Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► RegistrationDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RegistrationDate { get; set; }
Public Property RegistrationDate As DateTime
    Get
    Set
public:
property DateTime RegistrationDate {
    DateTime get ();
    void set (DateTime value);
}


RegistrationDateSpecified Property

RegistrationDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► RegistrationDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RegistrationDateSpecified { get; set; }
Public Property RegistrationDateSpecified As Boolean
    Get
    Set
public:
property bool RegistrationDateSpecified {
    bool get ();
    void set (bool value);
}


SellerInfo Property

SellerInfo Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► SellerInfo
Declaration Syntax
C# Visual Basic Visual C++
public SellerType SellerInfo { get; set; }
Public Property SellerInfo As SellerType
    Get
    Set
public:
property SellerType^ SellerInfo {
    SellerType^ get ();
    void set (SellerType^ value);
}


SellerPaymentMethod Property

SellerPaymentMethod Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► SellerPaymentMethod
Declaration Syntax
C# Visual Basic Visual C++
public SellerPaymentMethodCodeType SellerPaymentMethod { get; set; }
Public Property SellerPaymentMethod As SellerPaymentMethodCodeType
    Get
    Set
public:
property SellerPaymentMethodCodeType SellerPaymentMethod {
    SellerPaymentMethodCodeType get ();
    void set (SellerPaymentMethodCodeType value);
}


SellerPaymentMethodSpecified Property

SellerPaymentMethodSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► SellerPaymentMethodSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SellerPaymentMethodSpecified { get; set; }
Public Property SellerPaymentMethodSpecified As Boolean
    Get
    Set
public:
property bool SellerPaymentMethodSpecified {
    bool get ();
    void set (bool value);
}


ShippingAddress Property

ShippingAddress Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► ShippingAddress
Declaration Syntax
C# Visual Basic Visual C++
public AddressType ShippingAddress { get; set; }
Public Property ShippingAddress As AddressType
    Get
    Set
public:
property AddressType^ ShippingAddress {
    AddressType^ get ();
    void set (AddressType^ value);
}


Site Property

Site Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► Site
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType Site { get; set; }
Public Property Site As SiteCodeType
    Get
    Set
public:
property SiteCodeType Site {
    SiteCodeType get ();
    void set (SiteCodeType value);
}


SiteSpecified Property

SiteSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► SiteSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SiteSpecified { get; set; }
Public Property SiteSpecified As Boolean
    Get
    Set
public:
property bool SiteSpecified {
    bool get ();
    void set (bool value);
}


SiteVerified Property

SiteVerified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► SiteVerified
Declaration Syntax
C# Visual Basic Visual C++
public bool SiteVerified { get; set; }
Public Property SiteVerified As Boolean
    Get
    Set
public:
property bool SiteVerified {
    bool get ();
    void set (bool value);
}


SiteVerifiedSpecified Property

SiteVerifiedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► SiteVerifiedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SiteVerifiedSpecified { get; set; }
Public Property SiteVerifiedSpecified As Boolean
    Get
    Set
public:
property bool SiteVerifiedSpecified {
    bool get ();
    void set (bool value);
}


SkypeID Property

SkypeID Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► SkypeID
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection SkypeID { get; set; }
Public Property SkypeID As StringCollection
    Get
    Set
public:
property StringCollection^ SkypeID {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


StaticAlias Property

StaticAlias Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► StaticAlias
Declaration Syntax
C# Visual Basic Visual C++
public string StaticAlias { get; set; }
Public Property StaticAlias As String
    Get
    Set
public:
property String^ StaticAlias {
    String^ get ();
    void set (String^ value);
}


Status Property

Status Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► Status
Declaration Syntax
C# Visual Basic Visual C++
public UserStatusCodeType Status { get; set; }
Public Property Status As UserStatusCodeType
    Get
    Set
public:
property UserStatusCodeType Status {
    UserStatusCodeType get ();
    void set (UserStatusCodeType value);
}


StatusSpecified Property

StatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► StatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StatusSpecified { get; set; }
Public Property StatusSpecified As Boolean
    Get
    Set
public:
property bool StatusSpecified {
    bool get ();
    void set (bool value);
}


TUVLevel Property

TUVLevel Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► TUVLevel
Declaration Syntax
C# Visual Basic Visual C++
public int TUVLevel { get; set; }
Public Property TUVLevel As Integer
    Get
    Set
public:
property int TUVLevel {
    int get ();
    void set (int value);
}


TUVLevelSpecified Property

TUVLevelSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► TUVLevelSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool TUVLevelSpecified { get; set; }
Public Property TUVLevelSpecified As Boolean
    Get
    Set
public:
property bool TUVLevelSpecified {
    bool get ();
    void set (bool value);
}


UniqueNegativeFeedbackCount Property

UniqueNegativeFeedbackCount Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UniqueNegativeFeedbackCount
Declaration Syntax
C# Visual Basic Visual C++
public int UniqueNegativeFeedbackCount { get; set; }
Public Property UniqueNegativeFeedbackCount As Integer
    Get
    Set
public:
property int UniqueNegativeFeedbackCount {
    int get ();
    void set (int value);
}


UniqueNegativeFeedbackCountSpecified Property

UniqueNegativeFeedbackCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UniqueNegativeFeedbackCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UniqueNegativeFeedbackCountSpecified { get; set; }
Public Property UniqueNegativeFeedbackCountSpecified As Boolean
    Get
    Set
public:
property bool UniqueNegativeFeedbackCountSpecified {
    bool get ();
    void set (bool value);
}


UniqueNeutralFeedbackCount Property

UniqueNeutralFeedbackCount Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UniqueNeutralFeedbackCount
Declaration Syntax
C# Visual Basic Visual C++
public int UniqueNeutralFeedbackCount { get; set; }
Public Property UniqueNeutralFeedbackCount As Integer
    Get
    Set
public:
property int UniqueNeutralFeedbackCount {
    int get ();
    void set (int value);
}


UniqueNeutralFeedbackCountSpecified Property

UniqueNeutralFeedbackCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UniqueNeutralFeedbackCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UniqueNeutralFeedbackCountSpecified { get; set; }
Public Property UniqueNeutralFeedbackCountSpecified As Boolean
    Get
    Set
public:
property bool UniqueNeutralFeedbackCountSpecified {
    bool get ();
    void set (bool value);
}


UniquePositiveFeedbackCount Property

UniquePositiveFeedbackCount Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UniquePositiveFeedbackCount
Declaration Syntax
C# Visual Basic Visual C++
public int UniquePositiveFeedbackCount { get; set; }
Public Property UniquePositiveFeedbackCount As Integer
    Get
    Set
public:
property int UniquePositiveFeedbackCount {
    int get ();
    void set (int value);
}


UniquePositiveFeedbackCountSpecified Property

UniquePositiveFeedbackCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UniquePositiveFeedbackCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UniquePositiveFeedbackCountSpecified { get; set; }
Public Property UniquePositiveFeedbackCountSpecified As Boolean
    Get
    Set
public:
property bool UniquePositiveFeedbackCountSpecified {
    bool get ();
    void set (bool value);
}


UserAnonymized Property

UserAnonymized Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UserAnonymized
Declaration Syntax
C# Visual Basic Visual C++
public bool UserAnonymized { get; set; }
Public Property UserAnonymized As Boolean
    Get
    Set
public:
property bool UserAnonymized {
    bool get ();
    void set (bool value);
}


UserAnonymizedSpecified Property

UserAnonymizedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UserAnonymizedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UserAnonymizedSpecified { get; set; }
Public Property UserAnonymizedSpecified As Boolean
    Get
    Set
public:
property bool UserAnonymizedSpecified {
    bool get ();
    void set (bool value);
}


UserFirstName Property

UserFirstName Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UserFirstName
Declaration Syntax
C# Visual Basic Visual C++
public string UserFirstName { get; set; }
Public Property UserFirstName As String
    Get
    Set
public:
property String^ UserFirstName {
    String^ get ();
    void set (String^ value);
}


UserID Property

UserID Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UserID
Declaration Syntax
C# Visual Basic Visual C++
public string UserID { get; set; }
Public Property UserID As String
    Get
    Set
public:
property String^ UserID {
    String^ get ();
    void set (String^ value);
}


UserIDChanged Property

UserIDChanged Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UserIDChanged
Declaration Syntax
C# Visual Basic Visual C++
public bool UserIDChanged { get; set; }
Public Property UserIDChanged As Boolean
    Get
    Set
public:
property bool UserIDChanged {
    bool get ();
    void set (bool value);
}


UserIDChangedSpecified Property

UserIDChangedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UserIDChangedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UserIDChangedSpecified { get; set; }
Public Property UserIDChangedSpecified As Boolean
    Get
    Set
public:
property bool UserIDChangedSpecified {
    bool get ();
    void set (bool value);
}


UserIDLastChanged Property

UserIDLastChanged Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UserIDLastChanged
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UserIDLastChanged { get; set; }
Public Property UserIDLastChanged As DateTime
    Get
    Set
public:
property DateTime UserIDLastChanged {
    DateTime get ();
    void set (DateTime value);
}


UserIDLastChangedSpecified Property

UserIDLastChangedSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UserIDLastChangedSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UserIDLastChangedSpecified { get; set; }
Public Property UserIDLastChangedSpecified As Boolean
    Get
    Set
public:
property bool UserIDLastChangedSpecified {
    bool get ();
    void set (bool value);
}


UserLastName Property

UserLastName Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UserLastName
Declaration Syntax
C# Visual Basic Visual C++
public string UserLastName { get; set; }
Public Property UserLastName As String
    Get
    Set
public:
property String^ UserLastName {
    String^ get ();
    void set (String^ value);
}


UserSubscription Property

UserSubscription Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► UserSubscription
Declaration Syntax
C# Visual Basic Visual C++
public EBaySubscriptionTypeCodeTypeCollection UserSubscription { get; set; }
Public Property UserSubscription As EBaySubscriptionTypeCodeTypeCollection
    Get
    Set
public:
property EBaySubscriptionTypeCodeTypeCollection^ UserSubscription {
    EBaySubscriptionTypeCodeTypeCollection^ get ();
    void set (EBaySubscriptionTypeCodeTypeCollection^ value);
}


UserType Constructor

UserType Constructor
Namespaces ► eBay.Service.Core.Soap ► UserType ► UserType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public UserType()
Public Sub New
public:
UserType()


VATID Property

VATID Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► VATID
Declaration Syntax
C# Visual Basic Visual C++
public string VATID { get; set; }
Public Property VATID As String
    Get
    Set
public:
property String^ VATID {
    String^ get ();
    void set (String^ value);
}


VATStatus Property

VATStatus Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► VATStatus
Declaration Syntax
C# Visual Basic Visual C++
public VATStatusCodeType VATStatus { get; set; }
Public Property VATStatus As VATStatusCodeType
    Get
    Set
public:
property VATStatusCodeType VATStatus {
    VATStatusCodeType get ();
    void set (VATStatusCodeType value);
}


VATStatusSpecified Property

VATStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► UserType ► VATStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VATStatusSpecified { get; set; }
Public Property VATStatusSpecified As Boolean
    Get
    Set
public:
property bool VATStatusSpecified {
    bool get ();
    void set (bool value);
}


USPSRateOptionCodeType Enumeration

USPSRateOptionCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► USPSRateOptionCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum USPSRateOptionCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration USPSRateOptionCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class USPSRateOptionCodeType
Members
Member | Description
USPSDiscounted |
USPSRetail |
CustomCode |
Remarks


ValidateChallengeInputRequestType Class

ValidateChallengeInputRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ValidateChallengeInputRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ValidateChallengeInputRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ValidateChallengeInputRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ValidateChallengeInputRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidateChallengeInputRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | ChallengeToken |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | KeepTokenValid |
 | KeepTokenValidSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | UserInput |
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ValidateChallengeInputRequestType


ChallengeToken Property

ChallengeToken Property
Namespaces ► eBay.Service.Core.Soap ► ValidateChallengeInputRequestType ► ChallengeToken
Declaration Syntax
C# Visual Basic Visual C++
public string ChallengeToken { get; set; }
Public Property ChallengeToken As String
    Get
    Set
public:
property String^ ChallengeToken {
    String^ get ();
    void set (String^ value);
}


KeepTokenValid Property

KeepTokenValid Property
Namespaces ► eBay.Service.Core.Soap ► ValidateChallengeInputRequestType ► KeepTokenValid
Declaration Syntax
C# Visual Basic Visual C++
public bool KeepTokenValid { get; set; }
Public Property KeepTokenValid As Boolean
    Get
    Set
public:
property bool KeepTokenValid {
    bool get ();
    void set (bool value);
}


KeepTokenValidSpecified Property

KeepTokenValidSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ValidateChallengeInputRequestType ► KeepTokenValidSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool KeepTokenValidSpecified { get; set; }
Public Property KeepTokenValidSpecified As Boolean
    Get
    Set
public:
property bool KeepTokenValidSpecified {
    bool get ();
    void set (bool value);
}


UserInput Property

UserInput Property
Namespaces ► eBay.Service.Core.Soap ► ValidateChallengeInputRequestType ► UserInput
Declaration Syntax
C# Visual Basic Visual C++
public string UserInput { get; set; }
Public Property UserInput As String
    Get
    Set
public:
property String^ UserInput {
    String^ get ();
    void set (String^ value);
}


ValidateChallengeInputRequestType Constructor

ValidateChallengeInputRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ValidateChallengeInputRequestType ► ValidateChallengeInputRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValidateChallengeInputRequestType()
Public Sub New
public:
ValidateChallengeInputRequestType()


ValidateChallengeInputResponseType Class

ValidateChallengeInputResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ValidateChallengeInputResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ValidateChallengeInputResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ValidateChallengeInputResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ValidateChallengeInputResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidateChallengeInputResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | ValidToken |
 | ValidTokenSpecified |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ValidateChallengeInputResponseType


ValidateChallengeInputResponseType Constructor

ValidateChallengeInputResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ValidateChallengeInputResponseType ► ValidateChallengeInputResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValidateChallengeInputResponseType()
Public Sub New
public:
ValidateChallengeInputResponseType()


ValidToken Property

ValidToken Property
Namespaces ► eBay.Service.Core.Soap ► ValidateChallengeInputResponseType ► ValidToken
Declaration Syntax
C# Visual Basic Visual C++
public bool ValidToken { get; set; }
Public Property ValidToken As Boolean
    Get
    Set
public:
property bool ValidToken {
    bool get ();
    void set (bool value);
}


ValidTokenSpecified Property

ValidTokenSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ValidateChallengeInputResponseType ► ValidTokenSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ValidTokenSpecified { get; set; }
Public Property ValidTokenSpecified As Boolean
    Get
    Set
public:
property bool ValidTokenSpecified {
    bool get ();
    void set (bool value);
}


ValidateTestUserRegistrationRequestType Class

ValidateTestUserRegistrationRequestType Class
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ValidateTestUserRegistrationRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ValidateTestUserRegistrationRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ValidateTestUserRegistrationRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidateTestUserRegistrationRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | FeedbackScore |
 | FeedbackScoreSpecified |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | RegistrationDate |
 | RegistrationDateSpecified |
 | SubscribeSA |
 | SubscribeSAPro |
 | SubscribeSAProSpecified |
 | SubscribeSASpecified |
 | SubscribeSM |
 | SubscribeSMPro |
 | SubscribeSMProSpecified |
 | SubscribeSMSpecified |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | ValidateTestUserRegistrationRequestType


FeedbackScore Property

FeedbackScore Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► FeedbackScore
Declaration Syntax
C# Visual Basic Visual C++
public int FeedbackScore { get; set; }
Public Property FeedbackScore As Integer
    Get
    Set
public:
property int FeedbackScore {
    int get ();
    void set (int value);
}


FeedbackScoreSpecified Property

FeedbackScoreSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► FeedbackScoreSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool FeedbackScoreSpecified { get; set; }
Public Property FeedbackScoreSpecified As Boolean
    Get
    Set
public:
property bool FeedbackScoreSpecified {
    bool get ();
    void set (bool value);
}


RegistrationDate Property

RegistrationDate Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► RegistrationDate
Declaration Syntax
C# Visual Basic Visual C++
public DateTime RegistrationDate { get; set; }
Public Property RegistrationDate As DateTime
    Get
    Set
public:
property DateTime RegistrationDate {
    DateTime get ();
    void set (DateTime value);
}


RegistrationDateSpecified Property

RegistrationDateSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► RegistrationDateSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RegistrationDateSpecified { get; set; }
Public Property RegistrationDateSpecified As Boolean
    Get
    Set
public:
property bool RegistrationDateSpecified {
    bool get ();
    void set (bool value);
}


SubscribeSA Property

SubscribeSA Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► SubscribeSA
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSA { get; set; }
Public Property SubscribeSA As Boolean
    Get
    Set
public:
property bool SubscribeSA {
    bool get ();
    void set (bool value);
}


SubscribeSAPro Property

SubscribeSAPro Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► SubscribeSAPro
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSAPro { get; set; }
Public Property SubscribeSAPro As Boolean
    Get
    Set
public:
property bool SubscribeSAPro {
    bool get ();
    void set (bool value);
}


SubscribeSAProSpecified Property

SubscribeSAProSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► SubscribeSAProSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSAProSpecified { get; set; }
Public Property SubscribeSAProSpecified As Boolean
    Get
    Set
public:
property bool SubscribeSAProSpecified {
    bool get ();
    void set (bool value);
}


SubscribeSASpecified Property

SubscribeSASpecified Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► SubscribeSASpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSASpecified { get; set; }
Public Property SubscribeSASpecified As Boolean
    Get
    Set
public:
property bool SubscribeSASpecified {
    bool get ();
    void set (bool value);
}


SubscribeSM Property

SubscribeSM Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► SubscribeSM
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSM { get; set; }
Public Property SubscribeSM As Boolean
    Get
    Set
public:
property bool SubscribeSM {
    bool get ();
    void set (bool value);
}


SubscribeSMPro Property

SubscribeSMPro Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► SubscribeSMPro
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSMPro { get; set; }
Public Property SubscribeSMPro As Boolean
    Get
    Set
public:
property bool SubscribeSMPro {
    bool get ();
    void set (bool value);
}


SubscribeSMProSpecified Property

SubscribeSMProSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► SubscribeSMProSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSMProSpecified { get; set; }
Public Property SubscribeSMProSpecified As Boolean
    Get
    Set
public:
property bool SubscribeSMProSpecified {
    bool get ();
    void set (bool value);
}


SubscribeSMSpecified Property

SubscribeSMSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► SubscribeSMSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SubscribeSMSpecified { get; set; }
Public Property SubscribeSMSpecified As Boolean
    Get
    Set
public:
property bool SubscribeSMSpecified {
    bool get ();
    void set (bool value);
}


ValidateTestUserRegistrationRequestType Constructor

ValidateTestUserRegistrationRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationRequestType ► ValidateTestUserRegistrationRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValidateTestUserRegistrationRequestType()
Public Sub New
public:
ValidateTestUserRegistrationRequestType()


ValidateTestUserRegistrationResponseType Class

ValidateTestUserRegistrationResponseType Class
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ValidateTestUserRegistrationResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ValidateTestUserRegistrationResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ValidateTestUserRegistrationResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidateTestUserRegistrationResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | ValidateTestUserRegistrationResponseType


ValidateTestUserRegistrationResponseType Constructor

ValidateTestUserRegistrationResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► ValidateTestUserRegistrationResponseType ► ValidateTestUserRegistrationResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValidateTestUserRegistrationResponseType()
Public Sub New
public:
ValidateTestUserRegistrationResponseType()


ValType Class

ValType Class
Namespaces ► eBay.Service.Core.Soap ► ValType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ValType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ValType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ValType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SuggestedValueLiteral |
 | ToString()()()() | (Inherited from Object.)
 | ValueID |
 | ValueIDSpecified |
 | ValueLiteral |
Remarks
Inheritance Hierarchy
Object
 | ValType
 |  | Value


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ValType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


SuggestedValueLiteral Property

SuggestedValueLiteral Property
Namespaces ► eBay.Service.Core.Soap ► ValType ► SuggestedValueLiteral
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection SuggestedValueLiteral { get; set; }
Public Property SuggestedValueLiteral As StringCollection
    Get
    Set
public:
property StringCollection^ SuggestedValueLiteral {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


ValType Constructor

ValType Constructor
Namespaces ► eBay.Service.Core.Soap ► ValType ► ValType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValType()
Public Sub New
public:
ValType()


ValueID Property

ValueID Property
Namespaces ► eBay.Service.Core.Soap ► ValType ► ValueID
Declaration Syntax
C# Visual Basic Visual C++
public int ValueID { get; set; }
Public Property ValueID As Integer
    Get
    Set
public:
property int ValueID {
    int get ();
    void set (int value);
}


ValueIDSpecified Property

ValueIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► ValType ► ValueIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ValueIDSpecified { get; set; }
Public Property ValueIDSpecified As Boolean
    Get
    Set
public:
property bool ValueIDSpecified {
    bool get ();
    void set (bool value);
}


ValueLiteral Property

ValueLiteral Property
Namespaces ► eBay.Service.Core.Soap ► ValType ► ValueLiteral
Declaration Syntax
C# Visual Basic Visual C++
public string ValueLiteral { get; set; }
Public Property ValueLiteral As String
    Get
    Set
public:
property String^ ValueLiteral {
    String^ get ();
    void set (String^ value);
}


ValTypeCollection Class

ValTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ValTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ValTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ValTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValTypeCollection()()()() |
 | ValTypeCollection(array<ValType>[]()[][]) |
 | ValTypeCollection(ValTypeCollection) |
 | Add(ValType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ValType>[]()[][]) |
 | AddRange(ValTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ValType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ValType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ValType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ValType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ValType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ValTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► Add(ValType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ValType item
)
Public Function Add ( _
    item As ValType _
) As Integer
public:
int Add(
    ValType^ item
)
Parameters
item (ValType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ValType>[]()[][]) |
 | AddRange(ValTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► AddRange(array<ValType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ValType[] items
)
Public Sub AddRange ( _
    items As ValType() _
)
public:
void AddRange(
    array<ValType^>^ items
)
Parameters
items (array< ValType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► AddRange(ValTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ValTypeCollection items
)
Public Sub AddRange ( _
    items As ValTypeCollection _
)
public:
void AddRange(
    ValTypeCollection^ items
)
Parameters
items (ValTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► Contains(ValType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ValType item
)
Public Function Contains ( _
    item As ValType _
) As Boolean
public:
bool Contains(
    ValType^ item
)
Parameters
item (ValType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► CopyTo(array<ValType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ValType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ValType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ValType^>^ items,
    int index
)
Parameters
items (array< ValType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► IndexOf(ValType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ValType item
)
Public Function IndexOf ( _
    item As ValType _
) As Integer
public:
int IndexOf(
    ValType^ item
)
Parameters
item (ValType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► Insert(Int32, ValType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ValType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ValType _
)
public:
void Insert(
    int index,
    ValType^ item
)
Parameters
index (Int32)
item (ValType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ValType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ValType
    Get
    Set
public:
property ValType^ default[int index] {
    ValType^ get (int index);
    void set (int index, ValType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ValType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ValType
public:
ValType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► Remove(ValType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ValType item
)
Public Sub Remove ( _
    item As ValType _
)
public:
void Remove(
    ValType^ item
)
Parameters
item (ValType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValType[] ToArray()
Public Function ToArray As ValType()
public:
array<ValType^>^ ToArray()
Return Value


ValTypeCollection Constructor

ValTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► ValTypeCollection()()()()
Members
Icon | Member | Description
 | ValTypeCollection()()()() |
 | ValTypeCollection(array<ValType>[]()[][]) |
 | ValTypeCollection(ValTypeCollection) |


ValTypeCollection Constructor

ValTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► ValTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValTypeCollection()
Public Sub New
public:
ValTypeCollection()


ValTypeCollection Constructor (items)

ValTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► ValTypeCollection(array<ValType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ValTypeCollection(
    ValType[] items
)
Public Sub New ( _
    items As ValType() _
)
public:
ValTypeCollection(
    array<ValType^>^ items
)
Parameters
items (array< ValType >[]()[][])


ValTypeCollection Constructor (items)

ValTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► ValTypeCollection(ValTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ValTypeCollection(
    ValTypeCollection items
)
Public Sub New ( _
    items As ValTypeCollection _
)
public:
ValTypeCollection(
    ValTypeCollection^ items
)
Parameters
items (ValTypeCollection)


ValueCategoryDefinitionType Class

ValueCategoryDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ValueCategoryDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ValueCategoryDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ValueCategoryDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ValueCategoryDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValueCategoryDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ValueCategoryDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ValueCategoryDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ValueCategoryDefinitionType Constructor

ValueCategoryDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ValueCategoryDefinitionType ► ValueCategoryDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValueCategoryDefinitionType()
Public Sub New
public:
ValueCategoryDefinitionType()


ValueFormatCodeType Enumeration

ValueFormatCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ValueFormatCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ValueFormatCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ValueFormatCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ValueFormatCodeType
Members
Member | Description
FullDate |
PartialDate |
Year |
CustomCode |
Remarks


ValuePackEnabledDefinitionType Class

ValuePackEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► ValuePackEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ValuePackEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ValuePackEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ValuePackEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValuePackEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ValuePackEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ValuePackEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ValuePackEnabledDefinitionType Constructor

ValuePackEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► ValuePackEnabledDefinitionType ► ValuePackEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValuePackEnabledDefinitionType()
Public Sub New
public:
ValuePackEnabledDefinitionType()


ValueRecommendationType Class

ValueRecommendationType Class
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class ValueRecommendationType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class ValueRecommendationType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class ValueRecommendationType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValueRecommendationType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | ValidationRules |
 | Value |
Remarks
Inheritance Hierarchy
Object
ValueRecommendationType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ValidationRules Property

ValidationRules Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationType ► ValidationRules
Declaration Syntax
C# Visual Basic Visual C++
public RecommendationValidationRulesType ValidationRules { get; set; }
Public Property ValidationRules As RecommendationValidationRulesType
    Get
    Set
public:
property RecommendationValidationRulesType^ ValidationRules {
    RecommendationValidationRulesType^ get ();
    void set (RecommendationValidationRulesType^ value);
}


Value Property

Value Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationType ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


ValueRecommendationType Constructor

ValueRecommendationType Constructor
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationType ► ValueRecommendationType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValueRecommendationType()
Public Sub New
public:
ValueRecommendationType()


ValueRecommendationTypeCollection Class

ValueRecommendationTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ValueRecommendationTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ValueRecommendationTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ValueRecommendationTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValueRecommendationTypeCollection()()()() |
 | ValueRecommendationTypeCollection(array<ValueRecommendationType>[]()[][]) |
 | ValueRecommendationTypeCollection(ValueRecommendationTypeCollection) |
 | Add(ValueRecommendationType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ValueRecommendationType>[]()[][]) |
 | AddRange(ValueRecommendationTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ValueRecommendationType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ValueRecommendationType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ValueRecommendationType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ValueRecommendationType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ValueRecommendationType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ValueRecommendationTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► Add(ValueRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ValueRecommendationType item
)
Public Function Add ( _
    item As ValueRecommendationType _
) As Integer
public:
int Add(
    ValueRecommendationType^ item
)
Parameters
item (ValueRecommendationType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ValueRecommendationType>[]()[][]) |
 | AddRange(ValueRecommendationTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► AddRange(array<ValueRecommendationType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ValueRecommendationType[] items
)
Public Sub AddRange ( _
    items As ValueRecommendationType() _
)
public:
void AddRange(
    array<ValueRecommendationType^>^ items
)
Parameters
items (array< ValueRecommendationType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► AddRange(ValueRecommendationTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ValueRecommendationTypeCollection items
)
Public Sub AddRange ( _
    items As ValueRecommendationTypeCollection _
)
public:
void AddRange(
    ValueRecommendationTypeCollection^ items
)
Parameters
items (ValueRecommendationTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► Contains(ValueRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ValueRecommendationType item
)
Public Function Contains ( _
    item As ValueRecommendationType _
) As Boolean
public:
bool Contains(
    ValueRecommendationType^ item
)
Parameters
item (ValueRecommendationType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► CopyTo(array<ValueRecommendationType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ValueRecommendationType[] items,
    int index
)
Public Sub CopyTo ( _
    items As ValueRecommendationType(), _
    index As Integer _
)
public:
void CopyTo(
    array<ValueRecommendationType^>^ items,
    int index
)
Parameters
items (array< ValueRecommendationType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► IndexOf(ValueRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ValueRecommendationType item
)
Public Function IndexOf ( _
    item As ValueRecommendationType _
) As Integer
public:
int IndexOf(
    ValueRecommendationType^ item
)
Parameters
item (ValueRecommendationType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► Insert(Int32, ValueRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ValueRecommendationType item
)
Public Sub Insert ( _
    index As Integer, _
    item As ValueRecommendationType _
)
public:
void Insert(
    int index,
    ValueRecommendationType^ item
)
Parameters
index (Int32)
item (ValueRecommendationType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ValueRecommendationType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ValueRecommendationType
    Get
    Set
public:
property ValueRecommendationType^ default[int index] {
    ValueRecommendationType^ get (int index);
    void set (int index, ValueRecommendationType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ValueRecommendationType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ValueRecommendationType
public:
ValueRecommendationType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► Remove(ValueRecommendationType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ValueRecommendationType item
)
Public Sub Remove ( _
    item As ValueRecommendationType _
)
public:
void Remove(
    ValueRecommendationType^ item
)
Parameters
item (ValueRecommendationType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValueRecommendationType[] ToArray()
Public Function ToArray As ValueRecommendationType()
public:
array<ValueRecommendationType^>^ ToArray()
Return Value


ValueRecommendationTypeCollection Constructor

ValueRecommendationTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► ValueRecommendationTypeCollection()()()()
Members
Icon | Member | Description
 | ValueRecommendationTypeCollection()()()() |
 | ValueRecommendationTypeCollection(array<ValueRecommendationType>[]()[][]) |
 | ValueRecommendationTypeCollection(ValueRecommendationTypeCollection) |


ValueRecommendationTypeCollection Constructor

ValueRecommendationTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► ValueRecommendationTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ValueRecommendationTypeCollection()
Public Sub New
public:
ValueRecommendationTypeCollection()


ValueRecommendationTypeCollection Constructor (items)

ValueRecommendationTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► ValueRecommendationTypeCollection(array<ValueRecommendationType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ValueRecommendationTypeCollection(
    ValueRecommendationType[] items
)
Public Sub New ( _
    items As ValueRecommendationType() _
)
public:
ValueRecommendationTypeCollection(
    array<ValueRecommendationType^>^ items
)
Parameters
items (array< ValueRecommendationType >[]()[][])


ValueRecommendationTypeCollection Constructor (items)

ValueRecommendationTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► ValueRecommendationTypeCollection(ValueRecommendationTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ValueRecommendationTypeCollection(
    ValueRecommendationTypeCollection items
)
Public Sub New ( _
    items As ValueRecommendationTypeCollection _
)
public:
ValueRecommendationTypeCollection(
    ValueRecommendationTypeCollection^ items
)
Parameters
items (ValueRecommendationTypeCollection)


ValueTypeCodeType Enumeration

ValueTypeCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► ValueTypeCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum ValueTypeCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration ValueTypeCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class ValueTypeCodeType
Members
Member | Description
Decimal |
Numeric |
Text |
ISBN |
UPC |
EAN |
Date |
CodiceFiscale |
DNI |
RussianPassport |
CPFTaxID |
TurkeyID |
NIE |
NIF |
CEDULA |
NIT |
DriverLicense |
CNPJ |
CustomCode |
Remarks


VariationDetailsType Class

VariationDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VariationDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VariationDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VariationDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariationDetailsType()()()() |
 | Any |
 | DetailVersion |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MaxNamesPerVariationSpecificsSet |
 | MaxNamesPerVariationSpecificsSetSpecified |
 | MaxValuesPerVariationSpecificsSetName |
 | MaxValuesPerVariationSpecificsSetNameSpecified |
 | MaxVariationsPerItem |
 | MaxVariationsPerItemSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UpdateTime |
 | UpdateTimeSpecified |
Remarks
Inheritance Hierarchy
Object
VariationDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


DetailVersion Property

DetailVersion Property
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType ► DetailVersion
Declaration Syntax
C# Visual Basic Visual C++
public string DetailVersion { get; set; }
Public Property DetailVersion As String
    Get
    Set
public:
property String^ DetailVersion {
    String^ get ();
    void set (String^ value);
}


MaxNamesPerVariationSpecificsSet Property

MaxNamesPerVariationSpecificsSet Property
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType ► MaxNamesPerVariationSpecificsSet
Declaration Syntax
C# Visual Basic Visual C++
public int MaxNamesPerVariationSpecificsSet { get; set; }
Public Property MaxNamesPerVariationSpecificsSet As Integer
    Get
    Set
public:
property int MaxNamesPerVariationSpecificsSet {
    int get ();
    void set (int value);
}


MaxNamesPerVariationSpecificsSetSpecified Property

MaxNamesPerVariationSpecificsSetSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType ► MaxNamesPerVariationSpecificsSetSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxNamesPerVariationSpecificsSetSpecified { get; set; }
Public Property MaxNamesPerVariationSpecificsSetSpecified As Boolean
    Get
    Set
public:
property bool MaxNamesPerVariationSpecificsSetSpecified {
    bool get ();
    void set (bool value);
}


MaxValuesPerVariationSpecificsSetName Property

MaxValuesPerVariationSpecificsSetName Property
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType ► MaxValuesPerVariationSpecificsSetName
Declaration Syntax
C# Visual Basic Visual C++
public int MaxValuesPerVariationSpecificsSetName { get; set; }
Public Property MaxValuesPerVariationSpecificsSetName As Integer
    Get
    Set
public:
property int MaxValuesPerVariationSpecificsSetName {
    int get ();
    void set (int value);
}


MaxValuesPerVariationSpecificsSetNameSpecified Property

MaxValuesPerVariationSpecificsSetNameSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType ► MaxValuesPerVariationSpecificsSetNameSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxValuesPerVariationSpecificsSetNameSpecified { get; set; }
Public Property MaxValuesPerVariationSpecificsSetNameSpecified As Boolean
    Get
    Set
public:
property bool MaxValuesPerVariationSpecificsSetNameSpecified {
    bool get ();
    void set (bool value);
}


MaxVariationsPerItem Property

MaxVariationsPerItem Property
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType ► MaxVariationsPerItem
Declaration Syntax
C# Visual Basic Visual C++
public int MaxVariationsPerItem { get; set; }
Public Property MaxVariationsPerItem As Integer
    Get
    Set
public:
property int MaxVariationsPerItem {
    int get ();
    void set (int value);
}


MaxVariationsPerItemSpecified Property

MaxVariationsPerItemSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType ► MaxVariationsPerItemSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxVariationsPerItemSpecified { get; set; }
Public Property MaxVariationsPerItemSpecified As Boolean
    Get
    Set
public:
property bool MaxVariationsPerItemSpecified {
    bool get ();
    void set (bool value);
}


UpdateTime Property

UpdateTime Property
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType ► UpdateTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime UpdateTime { get; set; }
Public Property UpdateTime As DateTime
    Get
    Set
public:
property DateTime UpdateTime {
    DateTime get ();
    void set (DateTime value);
}


UpdateTimeSpecified Property

UpdateTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType ► UpdateTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateTimeSpecified { get; set; }
Public Property UpdateTimeSpecified As Boolean
    Get
    Set
public:
property bool UpdateTimeSpecified {
    bool get ();
    void set (bool value);
}


VariationDetailsType Constructor

VariationDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationDetailsType ► VariationDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationDetailsType()
Public Sub New
public:
VariationDetailsType()


VariationKeyType Class

VariationKeyType Class
Namespaces ► eBay.Service.Core.Soap ► VariationKeyType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VariationKeyType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VariationKeyType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VariationKeyType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariationKeyType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | VariationSpecifics |
Remarks
Inheritance Hierarchy
Object
VariationKeyType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


VariationKeyType Constructor

VariationKeyType Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationKeyType ► VariationKeyType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationKeyType()
Public Sub New
public:
VariationKeyType()


VariationSpecifics Property

VariationSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyType ► VariationSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection VariationSpecifics { get; set; }
Public Property VariationSpecifics As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ VariationSpecifics {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


VariationKeyTypeCollection Class

VariationKeyTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class VariationKeyTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class VariationKeyTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class VariationKeyTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariationKeyTypeCollection()()()() |
 | VariationKeyTypeCollection(array<VariationKeyType>[]()[][]) |
 | VariationKeyTypeCollection(VariationKeyTypeCollection) |
 | Add(VariationKeyType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<VariationKeyType>[]()[][]) |
 | AddRange(VariationKeyTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(VariationKeyType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<VariationKeyType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(VariationKeyType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, VariationKeyType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(VariationKeyType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | VariationKeyTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► Add(VariationKeyType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    VariationKeyType item
)
Public Function Add ( _
    item As VariationKeyType _
) As Integer
public:
int Add(
    VariationKeyType^ item
)
Parameters
item (VariationKeyType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<VariationKeyType>[]()[][]) |
 | AddRange(VariationKeyTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► AddRange(array<VariationKeyType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VariationKeyType[] items
)
Public Sub AddRange ( _
    items As VariationKeyType() _
)
public:
void AddRange(
    array<VariationKeyType^>^ items
)
Parameters
items (array< VariationKeyType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► AddRange(VariationKeyTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VariationKeyTypeCollection items
)
Public Sub AddRange ( _
    items As VariationKeyTypeCollection _
)
public:
void AddRange(
    VariationKeyTypeCollection^ items
)
Parameters
items (VariationKeyTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► Contains(VariationKeyType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    VariationKeyType item
)
Public Function Contains ( _
    item As VariationKeyType _
) As Boolean
public:
bool Contains(
    VariationKeyType^ item
)
Parameters
item (VariationKeyType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► CopyTo(array<VariationKeyType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    VariationKeyType[] items,
    int index
)
Public Sub CopyTo ( _
    items As VariationKeyType(), _
    index As Integer _
)
public:
void CopyTo(
    array<VariationKeyType^>^ items,
    int index
)
Parameters
items (array< VariationKeyType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► IndexOf(VariationKeyType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    VariationKeyType item
)
Public Function IndexOf ( _
    item As VariationKeyType _
) As Integer
public:
int IndexOf(
    VariationKeyType^ item
)
Parameters
item (VariationKeyType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► Insert(Int32, VariationKeyType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    VariationKeyType item
)
Public Sub Insert ( _
    index As Integer, _
    item As VariationKeyType _
)
public:
void Insert(
    int index,
    VariationKeyType^ item
)
Parameters
index (Int32)
item (VariationKeyType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public VariationKeyType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As VariationKeyType
    Get
    Set
public:
property VariationKeyType^ default[int index] {
    VariationKeyType^ get (int index);
    void set (int index, VariationKeyType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public VariationKeyType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As VariationKeyType
public:
VariationKeyType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► Remove(VariationKeyType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    VariationKeyType item
)
Public Sub Remove ( _
    item As VariationKeyType _
)
public:
void Remove(
    VariationKeyType^ item
)
Parameters
item (VariationKeyType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationKeyType[] ToArray()
Public Function ToArray As VariationKeyType()
public:
array<VariationKeyType^>^ ToArray()
Return Value


VariationKeyTypeCollection Constructor

VariationKeyTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► VariationKeyTypeCollection()()()()
Members
Icon | Member | Description
 | VariationKeyTypeCollection()()()() |
 | VariationKeyTypeCollection(array<VariationKeyType>[]()[][]) |
 | VariationKeyTypeCollection(VariationKeyTypeCollection) |


VariationKeyTypeCollection Constructor

VariationKeyTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► VariationKeyTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationKeyTypeCollection()
Public Sub New
public:
VariationKeyTypeCollection()


VariationKeyTypeCollection Constructor (items)

VariationKeyTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► VariationKeyTypeCollection(array<VariationKeyType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public VariationKeyTypeCollection(
    VariationKeyType[] items
)
Public Sub New ( _
    items As VariationKeyType() _
)
public:
VariationKeyTypeCollection(
    array<VariationKeyType^>^ items
)
Parameters
items (array< VariationKeyType >[]()[][])


VariationKeyTypeCollection Constructor (items)

VariationKeyTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► VariationKeyTypeCollection(VariationKeyTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public VariationKeyTypeCollection(
    VariationKeyTypeCollection items
)
Public Sub New ( _
    items As VariationKeyTypeCollection _
)
public:
VariationKeyTypeCollection(
    VariationKeyTypeCollection^ items
)
Parameters
items (VariationKeyTypeCollection)


VariationPictureRuleCodeType Enumeration

VariationPictureRuleCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► VariationPictureRuleCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum VariationPictureRuleCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration VariationPictureRuleCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class VariationPictureRuleCodeType
Members
Member | Description
Required |
Enabled |
Disabled |
CustomCode |
Remarks


VariationProductListingDetailsType Class

VariationProductListingDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► VariationProductListingDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VariationProductListingDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VariationProductListingDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VariationProductListingDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariationProductListingDetailsType()()()() |
 | Any |
 | EAN |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ISBN |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UPC |
Remarks
Inheritance Hierarchy
Object
VariationProductListingDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VariationProductListingDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


EAN Property

EAN Property
Namespaces ► eBay.Service.Core.Soap ► VariationProductListingDetailsType ► EAN
Declaration Syntax
C# Visual Basic Visual C++
public string EAN { get; set; }
Public Property EAN As String
    Get
    Set
public:
property String^ EAN {
    String^ get ();
    void set (String^ value);
}


ISBN Property

ISBN Property
Namespaces ► eBay.Service.Core.Soap ► VariationProductListingDetailsType ► ISBN
Declaration Syntax
C# Visual Basic Visual C++
public string ISBN { get; set; }
Public Property ISBN As String
    Get
    Set
public:
property String^ ISBN {
    String^ get ();
    void set (String^ value);
}


UPC Property

UPC Property
Namespaces ► eBay.Service.Core.Soap ► VariationProductListingDetailsType ► UPC
Declaration Syntax
C# Visual Basic Visual C++
public string UPC { get; set; }
Public Property UPC As String
    Get
    Set
public:
property String^ UPC {
    String^ get ();
    void set (String^ value);
}


VariationProductListingDetailsType Constructor

VariationProductListingDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationProductListingDetailsType ► VariationProductListingDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationProductListingDetailsType()
Public Sub New
public:
VariationProductListingDetailsType()


VariationsEnabledDefinitionType Class

VariationsEnabledDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► VariationsEnabledDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VariationsEnabledDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VariationsEnabledDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VariationsEnabledDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariationsEnabledDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
VariationsEnabledDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VariationsEnabledDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


VariationsEnabledDefinitionType Constructor

VariationsEnabledDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationsEnabledDefinitionType ► VariationsEnabledDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationsEnabledDefinitionType()
Public Sub New
public:
VariationsEnabledDefinitionType()


VariationSpecificPictureSetType Class

VariationSpecificPictureSetType Class
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VariationSpecificPictureSetType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VariationSpecificPictureSetType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VariationSpecificPictureSetType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariationSpecificPictureSetType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | ExtendedPictureDetails |
 | ExternalPictureURL |
 | Finalize()()()() | (Inherited from Object.)
 | GalleryURL |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PictureURL |
 | ToString()()()() | (Inherited from Object.)
 | VariationSpecificValue |
Remarks
Inheritance Hierarchy
Object
VariationSpecificPictureSetType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ExtendedPictureDetails Property

ExtendedPictureDetails Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetType ► ExtendedPictureDetails
Declaration Syntax
C# Visual Basic Visual C++
public ExtendedPictureDetailsType ExtendedPictureDetails { get; set; }
Public Property ExtendedPictureDetails As ExtendedPictureDetailsType
    Get
    Set
public:
property ExtendedPictureDetailsType^ ExtendedPictureDetails {
    ExtendedPictureDetailsType^ get ();
    void set (ExtendedPictureDetailsType^ value);
}


ExternalPictureURL Property

ExternalPictureURL Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetType ► ExternalPictureURL
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection ExternalPictureURL { get; set; }
Public Property ExternalPictureURL As StringCollection
    Get
    Set
public:
property StringCollection^ ExternalPictureURL {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


GalleryURL Property

GalleryURL Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetType ► GalleryURL
Declaration Syntax
C# Visual Basic Visual C++
public string GalleryURL { get; set; }
Public Property GalleryURL As String
    Get
    Set
public:
property String^ GalleryURL {
    String^ get ();
    void set (String^ value);
}


PictureURL Property

PictureURL Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetType ► PictureURL
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection PictureURL { get; set; }
Public Property PictureURL As StringCollection
    Get
    Set
public:
property StringCollection^ PictureURL {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


VariationSpecificPictureSetType Constructor

VariationSpecificPictureSetType Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetType ► VariationSpecificPictureSetType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationSpecificPictureSetType()
Public Sub New
public:
VariationSpecificPictureSetType()


VariationSpecificValue Property

VariationSpecificValue Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetType ► VariationSpecificValue
Declaration Syntax
C# Visual Basic Visual C++
public string VariationSpecificValue { get; set; }
Public Property VariationSpecificValue As String
    Get
    Set
public:
property String^ VariationSpecificValue {
    String^ get ();
    void set (String^ value);
}


VariationSpecificPictureSetTypeCollection Class

VariationSpecificPictureSetTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class VariationSpecificPictureSetTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class VariationSpecificPictureSetTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class VariationSpecificPictureSetTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariationSpecificPictureSetTypeCollection()()()() |
 | VariationSpecificPictureSetTypeCollection(array<VariationSpecificPictureSetType>[]()[][]) |
 | VariationSpecificPictureSetTypeCollection(VariationSpecificPictureSetTypeCollection) |
 | Add(VariationSpecificPictureSetType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<VariationSpecificPictureSetType>[]()[][]) |
 | AddRange(VariationSpecificPictureSetTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(VariationSpecificPictureSetType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<VariationSpecificPictureSetType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(VariationSpecificPictureSetType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, VariationSpecificPictureSetType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(VariationSpecificPictureSetType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | VariationSpecificPictureSetTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► Add(VariationSpecificPictureSetType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    VariationSpecificPictureSetType item
)
Public Function Add ( _
    item As VariationSpecificPictureSetType _
) As Integer
public:
int Add(
    VariationSpecificPictureSetType^ item
)
Parameters
item (VariationSpecificPictureSetType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<VariationSpecificPictureSetType>[]()[][]) |
 | AddRange(VariationSpecificPictureSetTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► AddRange(array<VariationSpecificPictureSetType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VariationSpecificPictureSetType[] items
)
Public Sub AddRange ( _
    items As VariationSpecificPictureSetType() _
)
public:
void AddRange(
    array<VariationSpecificPictureSetType^>^ items
)
Parameters
items (array< VariationSpecificPictureSetType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► AddRange(VariationSpecificPictureSetTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VariationSpecificPictureSetTypeCollection items
)
Public Sub AddRange ( _
    items As VariationSpecificPictureSetTypeCollection _
)
public:
void AddRange(
    VariationSpecificPictureSetTypeCollection^ items
)
Parameters
items (VariationSpecificPictureSetTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► Contains(VariationSpecificPictureSetType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    VariationSpecificPictureSetType item
)
Public Function Contains ( _
    item As VariationSpecificPictureSetType _
) As Boolean
public:
bool Contains(
    VariationSpecificPictureSetType^ item
)
Parameters
item (VariationSpecificPictureSetType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► CopyTo(array<VariationSpecificPictureSetType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    VariationSpecificPictureSetType[] items,
    int index
)
Public Sub CopyTo ( _
    items As VariationSpecificPictureSetType(), _
    index As Integer _
)
public:
void CopyTo(
    array<VariationSpecificPictureSetType^>^ items,
    int index
)
Parameters
items (array< VariationSpecificPictureSetType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► IndexOf(VariationSpecificPictureSetType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    VariationSpecificPictureSetType item
)
Public Function IndexOf ( _
    item As VariationSpecificPictureSetType _
) As Integer
public:
int IndexOf(
    VariationSpecificPictureSetType^ item
)
Parameters
item (VariationSpecificPictureSetType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► Insert(Int32, VariationSpecificPictureSetType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    VariationSpecificPictureSetType item
)
Public Sub Insert ( _
    index As Integer, _
    item As VariationSpecificPictureSetType _
)
public:
void Insert(
    int index,
    VariationSpecificPictureSetType^ item
)
Parameters
index (Int32)
item (VariationSpecificPictureSetType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public VariationSpecificPictureSetType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As VariationSpecificPictureSetType
    Get
    Set
public:
property VariationSpecificPictureSetType^ default[int index] {
    VariationSpecificPictureSetType^ get (int index);
    void set (int index, VariationSpecificPictureSetType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public VariationSpecificPictureSetType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As VariationSpecificPictureSetType
public:
VariationSpecificPictureSetType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► Remove(VariationSpecificPictureSetType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    VariationSpecificPictureSetType item
)
Public Sub Remove ( _
    item As VariationSpecificPictureSetType _
)
public:
void Remove(
    VariationSpecificPictureSetType^ item
)
Parameters
item (VariationSpecificPictureSetType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationSpecificPictureSetType[] ToArray()
Public Function ToArray As VariationSpecificPictureSetType()
public:
array<VariationSpecificPictureSetType^>^ ToArray()
Return Value


VariationSpecificPictureSetTypeCollection Constructor

VariationSpecificPictureSetTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► VariationSpecificPictureSetTypeCollection()()()()
Members
Icon | Member | Description
 | VariationSpecificPictureSetTypeCollection()()()() |
 | VariationSpecificPictureSetTypeCollection(array<VariationSpecificPictureSetType>[]()[][]) |
 | VariationSpecificPictureSetTypeCollection(VariationSpecificPictureSetTypeCollection) |


VariationSpecificPictureSetTypeCollection Constructor

VariationSpecificPictureSetTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► VariationSpecificPictureSetTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationSpecificPictureSetTypeCollection()
Public Sub New
public:
VariationSpecificPictureSetTypeCollection()


VariationSpecificPictureSetTypeCollection Constructor (items)

VariationSpecificPictureSetTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► VariationSpecificPictureSetTypeCollection(array<VariationSpecificPictureSetType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public VariationSpecificPictureSetTypeCollection(
    VariationSpecificPictureSetType[] items
)
Public Sub New ( _
    items As VariationSpecificPictureSetType() _
)
public:
VariationSpecificPictureSetTypeCollection(
    array<VariationSpecificPictureSetType^>^ items
)
Parameters
items (array< VariationSpecificPictureSetType >[]()[][])


VariationSpecificPictureSetTypeCollection Constructor (items)

VariationSpecificPictureSetTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► VariationSpecificPictureSetTypeCollection(VariationSpecificPictureSetTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public VariationSpecificPictureSetTypeCollection(
    VariationSpecificPictureSetTypeCollection items
)
Public Sub New ( _
    items As VariationSpecificPictureSetTypeCollection _
)
public:
VariationSpecificPictureSetTypeCollection(
    VariationSpecificPictureSetTypeCollection^ items
)
Parameters
items (VariationSpecificPictureSetTypeCollection)


VariationSpecificsRuleCodeType Enumeration

VariationSpecificsRuleCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificsRuleCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum VariationSpecificsRuleCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration VariationSpecificsRuleCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class VariationSpecificsRuleCodeType
Members
Member | Description
Enabled |
Disabled |
CustomCode |
Remarks


VariationsType Class

VariationsType Class
Namespaces ► eBay.Service.Core.Soap ► VariationsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VariationsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VariationsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VariationsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariationsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ModifyNameList |
 | Pictures |
 | ToString()()()() | (Inherited from Object.)
 | Variation |
 | VariationSpecificsSet |
Remarks
Inheritance Hierarchy
Object
VariationsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VariationsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ModifyNameList Property

ModifyNameList Property
Namespaces ► eBay.Service.Core.Soap ► VariationsType ► ModifyNameList
Declaration Syntax
C# Visual Basic Visual C++
public ModifyNameTypeCollection ModifyNameList { get; set; }
Public Property ModifyNameList As ModifyNameTypeCollection
    Get
    Set
public:
property ModifyNameTypeCollection^ ModifyNameList {
    ModifyNameTypeCollection^ get ();
    void set (ModifyNameTypeCollection^ value);
}


Pictures Property

Pictures Property
Namespaces ► eBay.Service.Core.Soap ► VariationsType ► Pictures
Declaration Syntax
C# Visual Basic Visual C++
public PicturesTypeCollection Pictures { get; set; }
Public Property Pictures As PicturesTypeCollection
    Get
    Set
public:
property PicturesTypeCollection^ Pictures {
    PicturesTypeCollection^ get ();
    void set (PicturesTypeCollection^ value);
}


Variation Property

Variation Property
Namespaces ► eBay.Service.Core.Soap ► VariationsType ► Variation
Declaration Syntax
C# Visual Basic Visual C++
public VariationTypeCollection Variation { get; set; }
Public Property Variation As VariationTypeCollection
    Get
    Set
public:
property VariationTypeCollection^ Variation {
    VariationTypeCollection^ get ();
    void set (VariationTypeCollection^ value);
}


VariationSpecificsSet Property

VariationSpecificsSet Property
Namespaces ► eBay.Service.Core.Soap ► VariationsType ► VariationSpecificsSet
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection VariationSpecificsSet { get; set; }
Public Property VariationSpecificsSet As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ VariationSpecificsSet {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


VariationsType Constructor

VariationsType Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationsType ► VariationsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationsType()
Public Sub New
public:
VariationsType()


VariationType Class

VariationType Class
Namespaces ► eBay.Service.Core.Soap ► VariationType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VariationType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VariationType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VariationType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariationType()()()() |
 | Any |
 | Delete |
 | DiscountPriceInfo |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | PrivateNotes |
 | Quantity |
 | QuantitySpecified |
 | SellingManagerProductInventoryStatus |
 | SellingStatus |
 | SKU |
 | StartPrice |
 | ToString()()()() | (Inherited from Object.)
 | UnitCost |
 | UnitsAvailable |
 | UnitsAvailableSpecified |
 | VariationProductListingDetails |
 | VariationSpecifics |
 | VariationTitle |
 | VariationViewItemURL |
 | WatchCount |
 | WatchCountSpecified |
Remarks
Inheritance Hierarchy
Object
VariationType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Delete Property

Delete Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► Delete
Declaration Syntax
C# Visual Basic Visual C++
public bool Delete { get; set; }
Public Property Delete As Boolean
    Get
    Set
public:
property bool Delete {
    bool get ();
    void set (bool value);
}


DiscountPriceInfo Property

DiscountPriceInfo Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► DiscountPriceInfo
Declaration Syntax
C# Visual Basic Visual C++
public DiscountPriceInfoType DiscountPriceInfo { get; set; }
Public Property DiscountPriceInfo As DiscountPriceInfoType
    Get
    Set
public:
property DiscountPriceInfoType^ DiscountPriceInfo {
    DiscountPriceInfoType^ get ();
    void set (DiscountPriceInfoType^ value);
}


PrivateNotes Property

PrivateNotes Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► PrivateNotes
Declaration Syntax
C# Visual Basic Visual C++
public string PrivateNotes { get; set; }
Public Property PrivateNotes As String
    Get
    Set
public:
property String^ PrivateNotes {
    String^ get ();
    void set (String^ value);
}


Quantity Property

Quantity Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public int Quantity { get; set; }
Public Property Quantity As Integer
    Get
    Set
public:
property int Quantity {
    int get ();
    void set (int value);
}


QuantitySpecified Property

QuantitySpecified Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► QuantitySpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool QuantitySpecified { get; set; }
Public Property QuantitySpecified As Boolean
    Get
    Set
public:
property bool QuantitySpecified {
    bool get ();
    void set (bool value);
}


SellingManagerProductInventoryStatus Property

SellingManagerProductInventoryStatus Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► SellingManagerProductInventoryStatus
Declaration Syntax
C# Visual Basic Visual C++
public SellingManagerProductInventoryStatusType SellingManagerProductInventoryStatus { get; set; }
Public Property SellingManagerProductInventoryStatus As SellingManagerProductInventoryStatusType
    Get
    Set
public:
property SellingManagerProductInventoryStatusType^ SellingManagerProductInventoryStatus {
    SellingManagerProductInventoryStatusType^ get ();
    void set (SellingManagerProductInventoryStatusType^ value);
}


SellingStatus Property

SellingStatus Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► SellingStatus
Declaration Syntax
C# Visual Basic Visual C++
public SellingStatusType SellingStatus { get; set; }
Public Property SellingStatus As SellingStatusType
    Get
    Set
public:
property SellingStatusType^ SellingStatus {
    SellingStatusType^ get ();
    void set (SellingStatusType^ value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


StartPrice Property

StartPrice Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► StartPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType StartPrice { get; set; }
Public Property StartPrice As AmountType
    Get
    Set
public:
property AmountType^ StartPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


UnitCost Property

UnitCost Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► UnitCost
Declaration Syntax
C# Visual Basic Visual C++
public AmountType UnitCost { get; set; }
Public Property UnitCost As AmountType
    Get
    Set
public:
property AmountType^ UnitCost {
    AmountType^ get ();
    void set (AmountType^ value);
}


UnitsAvailable Property

UnitsAvailable Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► UnitsAvailable
Declaration Syntax
C# Visual Basic Visual C++
public int UnitsAvailable { get; set; }
Public Property UnitsAvailable As Integer
    Get
    Set
public:
property int UnitsAvailable {
    int get ();
    void set (int value);
}


UnitsAvailableSpecified Property

UnitsAvailableSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► UnitsAvailableSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool UnitsAvailableSpecified { get; set; }
Public Property UnitsAvailableSpecified As Boolean
    Get
    Set
public:
property bool UnitsAvailableSpecified {
    bool get ();
    void set (bool value);
}


VariationProductListingDetails Property

VariationProductListingDetails Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► VariationProductListingDetails
Declaration Syntax
C# Visual Basic Visual C++
public VariationProductListingDetailsType VariationProductListingDetails { get; set; }
Public Property VariationProductListingDetails As VariationProductListingDetailsType
    Get
    Set
public:
property VariationProductListingDetailsType^ VariationProductListingDetails {
    VariationProductListingDetailsType^ get ();
    void set (VariationProductListingDetailsType^ value);
}


VariationSpecifics Property

VariationSpecifics Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► VariationSpecifics
Declaration Syntax
C# Visual Basic Visual C++
public NameValueListTypeCollection VariationSpecifics { get; set; }
Public Property VariationSpecifics As NameValueListTypeCollection
    Get
    Set
public:
property NameValueListTypeCollection^ VariationSpecifics {
    NameValueListTypeCollection^ get ();
    void set (NameValueListTypeCollection^ value);
}


VariationTitle Property

VariationTitle Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► VariationTitle
Declaration Syntax
C# Visual Basic Visual C++
public string VariationTitle { get; set; }
Public Property VariationTitle As String
    Get
    Set
public:
property String^ VariationTitle {
    String^ get ();
    void set (String^ value);
}


VariationType Constructor

VariationType Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationType ► VariationType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationType()
Public Sub New
public:
VariationType()


VariationViewItemURL Property

VariationViewItemURL Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► VariationViewItemURL
Declaration Syntax
C# Visual Basic Visual C++
public string VariationViewItemURL { get; set; }
Public Property VariationViewItemURL As String
    Get
    Set
public:
property String^ VariationViewItemURL {
    String^ get ();
    void set (String^ value);
}


WatchCount Property

WatchCount Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► WatchCount
Declaration Syntax
C# Visual Basic Visual C++
public long WatchCount { get; set; }
Public Property WatchCount As Long
    Get
    Set
public:
property long long WatchCount {
    long long get ();
    void set (long long value);
}


WatchCountSpecified Property

WatchCountSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VariationType ► WatchCountSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool WatchCountSpecified { get; set; }
Public Property WatchCountSpecified As Boolean
    Get
    Set
public:
property bool WatchCountSpecified {
    bool get ();
    void set (bool value);
}


VariationTypeCollection Class

VariationTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class VariationTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class VariationTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class VariationTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariationTypeCollection()()()() |
 | VariationTypeCollection(array<VariationType>[]()[][]) |
 | VariationTypeCollection(VariationTypeCollection) |
 | Add(VariationType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<VariationType>[]()[][]) |
 | AddRange(VariationTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(VariationType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<VariationType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(VariationType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, VariationType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(VariationType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | VariationTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► Add(VariationType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    VariationType item
)
Public Function Add ( _
    item As VariationType _
) As Integer
public:
int Add(
    VariationType^ item
)
Parameters
item (VariationType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<VariationType>[]()[][]) |
 | AddRange(VariationTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► AddRange(array<VariationType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VariationType[] items
)
Public Sub AddRange ( _
    items As VariationType() _
)
public:
void AddRange(
    array<VariationType^>^ items
)
Parameters
items (array< VariationType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► AddRange(VariationTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VariationTypeCollection items
)
Public Sub AddRange ( _
    items As VariationTypeCollection _
)
public:
void AddRange(
    VariationTypeCollection^ items
)
Parameters
items (VariationTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► Contains(VariationType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    VariationType item
)
Public Function Contains ( _
    item As VariationType _
) As Boolean
public:
bool Contains(
    VariationType^ item
)
Parameters
item (VariationType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► CopyTo(array<VariationType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    VariationType[] items,
    int index
)
Public Sub CopyTo ( _
    items As VariationType(), _
    index As Integer _
)
public:
void CopyTo(
    array<VariationType^>^ items,
    int index
)
Parameters
items (array< VariationType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► IndexOf(VariationType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    VariationType item
)
Public Function IndexOf ( _
    item As VariationType _
) As Integer
public:
int IndexOf(
    VariationType^ item
)
Parameters
item (VariationType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► Insert(Int32, VariationType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    VariationType item
)
Public Sub Insert ( _
    index As Integer, _
    item As VariationType _
)
public:
void Insert(
    int index,
    VariationType^ item
)
Parameters
index (Int32)
item (VariationType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public VariationType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As VariationType
    Get
    Set
public:
property VariationType^ default[int index] {
    VariationType^ get (int index);
    void set (int index, VariationType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public VariationType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As VariationType
public:
VariationType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► Remove(VariationType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    VariationType item
)
Public Sub Remove ( _
    item As VariationType _
)
public:
void Remove(
    VariationType^ item
)
Parameters
item (VariationType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationType[] ToArray()
Public Function ToArray As VariationType()
public:
array<VariationType^>^ ToArray()
Return Value


VariationTypeCollection Constructor

VariationTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► VariationTypeCollection()()()()
Members
Icon | Member | Description
 | VariationTypeCollection()()()() |
 | VariationTypeCollection(array<VariationType>[]()[][]) |
 | VariationTypeCollection(VariationTypeCollection) |


VariationTypeCollection Constructor

VariationTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► VariationTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VariationTypeCollection()
Public Sub New
public:
VariationTypeCollection()


VariationTypeCollection Constructor (items)

VariationTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► VariationTypeCollection(array<VariationType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public VariationTypeCollection(
    VariationType[] items
)
Public Sub New ( _
    items As VariationType() _
)
public:
VariationTypeCollection(
    array<VariationType^>^ items
)
Parameters
items (array< VariationType >[]()[][])


VariationTypeCollection Constructor (items)

VariationTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► VariationTypeCollection(VariationTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public VariationTypeCollection(
    VariationTypeCollection items
)
Public Sub New ( _
    items As VariationTypeCollection _
)
public:
VariationTypeCollection(
    VariationTypeCollection^ items
)
Parameters
items (VariationTypeCollection)


VATDetailsType Class

VATDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► VATDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VATDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VATDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VATDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VATDetailsType()()()() |
 | Any |
 | BusinessSeller |
 | BusinessSellerSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RestrictedToBusiness |
 | RestrictedToBusinessSpecified |
 | ToString()()()() | (Inherited from Object.)
 | VATID |
 | VATPercent |
 | VATPercentSpecified |
 | VATSite |
Remarks
Inheritance Hierarchy
Object
VATDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VATDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


BusinessSeller Property

BusinessSeller Property
Namespaces ► eBay.Service.Core.Soap ► VATDetailsType ► BusinessSeller
Declaration Syntax
C# Visual Basic Visual C++
public bool BusinessSeller { get; set; }
Public Property BusinessSeller As Boolean
    Get
    Set
public:
property bool BusinessSeller {
    bool get ();
    void set (bool value);
}


BusinessSellerSpecified Property

BusinessSellerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VATDetailsType ► BusinessSellerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool BusinessSellerSpecified { get; set; }
Public Property BusinessSellerSpecified As Boolean
    Get
    Set
public:
property bool BusinessSellerSpecified {
    bool get ();
    void set (bool value);
}


RestrictedToBusiness Property

RestrictedToBusiness Property
Namespaces ► eBay.Service.Core.Soap ► VATDetailsType ► RestrictedToBusiness
Declaration Syntax
C# Visual Basic Visual C++
public bool RestrictedToBusiness { get; set; }
Public Property RestrictedToBusiness As Boolean
    Get
    Set
public:
property bool RestrictedToBusiness {
    bool get ();
    void set (bool value);
}


RestrictedToBusinessSpecified Property

RestrictedToBusinessSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VATDetailsType ► RestrictedToBusinessSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool RestrictedToBusinessSpecified { get; set; }
Public Property RestrictedToBusinessSpecified As Boolean
    Get
    Set
public:
property bool RestrictedToBusinessSpecified {
    bool get ();
    void set (bool value);
}


VATDetailsType Constructor

VATDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► VATDetailsType ► VATDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VATDetailsType()
Public Sub New
public:
VATDetailsType()


VATID Property

VATID Property
Namespaces ► eBay.Service.Core.Soap ► VATDetailsType ► VATID
Declaration Syntax
C# Visual Basic Visual C++
public string VATID { get; set; }
Public Property VATID As String
    Get
    Set
public:
property String^ VATID {
    String^ get ();
    void set (String^ value);
}


VATPercent Property

VATPercent Property
Namespaces ► eBay.Service.Core.Soap ► VATDetailsType ► VATPercent
Declaration Syntax
C# Visual Basic Visual C++
public float VATPercent { get; set; }
Public Property VATPercent As Single
    Get
    Set
public:
property float VATPercent {
    float get ();
    void set (float value);
}


VATPercentSpecified Property

VATPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VATDetailsType ► VATPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VATPercentSpecified { get; set; }
Public Property VATPercentSpecified As Boolean
    Get
    Set
public:
property bool VATPercentSpecified {
    bool get ();
    void set (bool value);
}


VATSite Property

VATSite Property
Namespaces ► eBay.Service.Core.Soap ► VATDetailsType ► VATSite
Declaration Syntax
C# Visual Basic Visual C++
public string VATSite { get; set; }
Public Property VATSite As String
    Get
    Set
public:
property String^ VATSite {
    String^ get ();
    void set (String^ value);
}


VATRateType Class

VATRateType Class
Namespaces ► eBay.Service.Core.Soap ► VATRateType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VATRateType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VATRateType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VATRateType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VATRateType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OrderLineItemID |
 | ToString()()()() | (Inherited from Object.)
 | TransactionID |
 | VATPercent |
 | VATPercentSpecified |
Remarks
Inheritance Hierarchy
Object
VATRateType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VATRateType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► VATRateType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


OrderLineItemID Property

OrderLineItemID Property
Namespaces ► eBay.Service.Core.Soap ► VATRateType ► OrderLineItemID
Declaration Syntax
C# Visual Basic Visual C++
public string OrderLineItemID { get; set; }
Public Property OrderLineItemID As String
    Get
    Set
public:
property String^ OrderLineItemID {
    String^ get ();
    void set (String^ value);
}


TransactionID Property

TransactionID Property
Namespaces ► eBay.Service.Core.Soap ► VATRateType ► TransactionID
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionID { get; set; }
Public Property TransactionID As String
    Get
    Set
public:
property String^ TransactionID {
    String^ get ();
    void set (String^ value);
}


VATPercent Property

VATPercent Property
Namespaces ► eBay.Service.Core.Soap ► VATRateType ► VATPercent
Declaration Syntax
C# Visual Basic Visual C++
public float VATPercent { get; set; }
Public Property VATPercent As Single
    Get
    Set
public:
property float VATPercent {
    float get ();
    void set (float value);
}


VATPercentSpecified Property

VATPercentSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VATRateType ► VATPercentSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VATPercentSpecified { get; set; }
Public Property VATPercentSpecified As Boolean
    Get
    Set
public:
property bool VATPercentSpecified {
    bool get ();
    void set (bool value);
}


VATRateType Constructor

VATRateType Constructor
Namespaces ► eBay.Service.Core.Soap ► VATRateType ► VATRateType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VATRateType()
Public Sub New
public:
VATRateType()


VATRateTypeCollection Class

VATRateTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class VATRateTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class VATRateTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class VATRateTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VATRateTypeCollection()()()() |
 | VATRateTypeCollection(array<VATRateType>[]()[][]) |
 | VATRateTypeCollection(VATRateTypeCollection) |
 | Add(VATRateType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<VATRateType>[]()[][]) |
 | AddRange(VATRateTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(VATRateType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<VATRateType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(VATRateType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, VATRateType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(VATRateType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | VATRateTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► Add(VATRateType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    VATRateType item
)
Public Function Add ( _
    item As VATRateType _
) As Integer
public:
int Add(
    VATRateType^ item
)
Parameters
item (VATRateType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<VATRateType>[]()[][]) |
 | AddRange(VATRateTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► AddRange(array<VATRateType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VATRateType[] items
)
Public Sub AddRange ( _
    items As VATRateType() _
)
public:
void AddRange(
    array<VATRateType^>^ items
)
Parameters
items (array< VATRateType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► AddRange(VATRateTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VATRateTypeCollection items
)
Public Sub AddRange ( _
    items As VATRateTypeCollection _
)
public:
void AddRange(
    VATRateTypeCollection^ items
)
Parameters
items (VATRateTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► Contains(VATRateType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    VATRateType item
)
Public Function Contains ( _
    item As VATRateType _
) As Boolean
public:
bool Contains(
    VATRateType^ item
)
Parameters
item (VATRateType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► CopyTo(array<VATRateType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    VATRateType[] items,
    int index
)
Public Sub CopyTo ( _
    items As VATRateType(), _
    index As Integer _
)
public:
void CopyTo(
    array<VATRateType^>^ items,
    int index
)
Parameters
items (array< VATRateType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► IndexOf(VATRateType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    VATRateType item
)
Public Function IndexOf ( _
    item As VATRateType _
) As Integer
public:
int IndexOf(
    VATRateType^ item
)
Parameters
item (VATRateType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► Insert(Int32, VATRateType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    VATRateType item
)
Public Sub Insert ( _
    index As Integer, _
    item As VATRateType _
)
public:
void Insert(
    int index,
    VATRateType^ item
)
Parameters
index (Int32)
item (VATRateType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public VATRateType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As VATRateType
    Get
    Set
public:
property VATRateType^ default[int index] {
    VATRateType^ get (int index);
    void set (int index, VATRateType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public VATRateType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As VATRateType
public:
VATRateType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► Remove(VATRateType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    VATRateType item
)
Public Sub Remove ( _
    item As VATRateType _
)
public:
void Remove(
    VATRateType^ item
)
Parameters
item (VATRateType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VATRateType[] ToArray()
Public Function ToArray As VATRateType()
public:
array<VATRateType^>^ ToArray()
Return Value


VATRateTypeCollection Constructor

VATRateTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► VATRateTypeCollection()()()()
Members
Icon | Member | Description
 | VATRateTypeCollection()()()() |
 | VATRateTypeCollection(array<VATRateType>[]()[][]) |
 | VATRateTypeCollection(VATRateTypeCollection) |


VATRateTypeCollection Constructor

VATRateTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► VATRateTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VATRateTypeCollection()
Public Sub New
public:
VATRateTypeCollection()


VATRateTypeCollection Constructor (items)

VATRateTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► VATRateTypeCollection(array<VATRateType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public VATRateTypeCollection(
    VATRateType[] items
)
Public Sub New ( _
    items As VATRateType() _
)
public:
VATRateTypeCollection(
    array<VATRateType^>^ items
)
Parameters
items (array< VATRateType >[]()[][])


VATRateTypeCollection Constructor (items)

VATRateTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► VATRateTypeCollection(VATRateTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public VATRateTypeCollection(
    VATRateTypeCollection items
)
Public Sub New ( _
    items As VATRateTypeCollection _
)
public:
VATRateTypeCollection(
    VATRateTypeCollection^ items
)
Parameters
items (VATRateTypeCollection)


VATStatusCodeType Enumeration

VATStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► VATStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum VATStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration VATStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class VATStatusCodeType
Members
Member | Description
NoVATTax |
VATTax |
VATExempt |
CustomCode |
Remarks


VerifiedUserRequirementsDetailsType Class

VerifiedUserRequirementsDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VerifiedUserRequirementsDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VerifiedUserRequirementsDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VerifiedUserRequirementsDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifiedUserRequirementsDetailsType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | FeedbackScore |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | VerifiedUser |
 | VerifiedUserSpecified |
Remarks
Inheritance Hierarchy
Object
VerifiedUserRequirementsDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


FeedbackScore Property

FeedbackScore Property
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsDetailsType ► FeedbackScore
Declaration Syntax
C# Visual Basic Visual C++
public Int32Collection FeedbackScore { get; set; }
Public Property FeedbackScore As Int32Collection
    Get
    Set
public:
property Int32Collection^ FeedbackScore {
    Int32Collection^ get ();
    void set (Int32Collection^ value);
}


VerifiedUser Property

VerifiedUser Property
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsDetailsType ► VerifiedUser
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifiedUser { get; set; }
Public Property VerifiedUser As Boolean
    Get
    Set
public:
property bool VerifiedUser {
    bool get ();
    void set (bool value);
}


VerifiedUserRequirementsDetailsType Constructor

VerifiedUserRequirementsDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsDetailsType ► VerifiedUserRequirementsDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifiedUserRequirementsDetailsType()
Public Sub New
public:
VerifiedUserRequirementsDetailsType()


VerifiedUserSpecified Property

VerifiedUserSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsDetailsType ► VerifiedUserSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifiedUserSpecified { get; set; }
Public Property VerifiedUserSpecified As Boolean
    Get
    Set
public:
property bool VerifiedUserSpecified {
    bool get ();
    void set (bool value);
}


VerifiedUserRequirementsType Class

VerifiedUserRequirementsType Class
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VerifiedUserRequirementsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VerifiedUserRequirementsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VerifiedUserRequirementsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifiedUserRequirementsType()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumFeedbackScore |
 | MinimumFeedbackScoreSpecified |
 | ToString()()()() | (Inherited from Object.)
 | VerifiedUser |
 | VerifiedUserSpecified |
Remarks
Inheritance Hierarchy
Object
VerifiedUserRequirementsType


MinimumFeedbackScore Property

MinimumFeedbackScore Property
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsType ► MinimumFeedbackScore
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumFeedbackScore { get; set; }
Public Property MinimumFeedbackScore As Integer
    Get
    Set
public:
property int MinimumFeedbackScore {
    int get ();
    void set (int value);
}


MinimumFeedbackScoreSpecified Property

MinimumFeedbackScoreSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsType ► MinimumFeedbackScoreSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool MinimumFeedbackScoreSpecified { get; set; }
Public Property MinimumFeedbackScoreSpecified As Boolean
    Get
    Set
public:
property bool MinimumFeedbackScoreSpecified {
    bool get ();
    void set (bool value);
}


VerifiedUser Property

VerifiedUser Property
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsType ► VerifiedUser
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifiedUser { get; set; }
Public Property VerifiedUser As Boolean
    Get
    Set
public:
property bool VerifiedUser {
    bool get ();
    void set (bool value);
}


VerifiedUserRequirementsType Constructor

VerifiedUserRequirementsType Constructor
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsType ► VerifiedUserRequirementsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifiedUserRequirementsType()
Public Sub New
public:
VerifiedUserRequirementsType()


VerifiedUserSpecified Property

VerifiedUserSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VerifiedUserRequirementsType ► VerifiedUserSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VerifiedUserSpecified { get; set; }
Public Property VerifiedUserSpecified As Boolean
    Get
    Set
public:
property bool VerifiedUserSpecified {
    bool get ();
    void set (bool value);
}


VerifyAddFixedPriceItemRequestType Class

VerifyAddFixedPriceItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VerifyAddFixedPriceItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VerifyAddFixedPriceItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VerifyAddFixedPriceItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyAddFixedPriceItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | VerifyAddFixedPriceItemRequestType


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


VerifyAddFixedPriceItemRequestType Constructor

VerifyAddFixedPriceItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemRequestType ► VerifyAddFixedPriceItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddFixedPriceItemRequestType()
Public Sub New
public:
VerifyAddFixedPriceItemRequestType()


VerifyAddFixedPriceItemResponseType Class

VerifyAddFixedPriceItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VerifyAddFixedPriceItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VerifyAddFixedPriceItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VerifyAddFixedPriceItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyAddFixedPriceItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category2ID |
 | CategoryID |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DiscountReason |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExpressItemRequirements |
 | ExpressListing |
 | ExpressListingSpecified |
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | ListingRecommendations |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | SKU |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | VerifyAddFixedPriceItemResponseType


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; set; }
Public Property Category2ID As String
    Get
    Set
public:
property String^ Category2ID {
    String^ get ();
    void set (String^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


DiscountReason Property

DiscountReason Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType ► DiscountReason
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReason { get; set; }
Public Property DiscountReason As DiscountReasonCodeTypeCollection
    Get
    Set
public:
property DiscountReasonCodeTypeCollection^ DiscountReason {
    DiscountReasonCodeTypeCollection^ get ();
    void set (DiscountReasonCodeTypeCollection^ value);
}


ExpressItemRequirements Property

ExpressItemRequirements Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType ► ExpressItemRequirements
Declaration Syntax
C# Visual Basic Visual C++
public ExpressItemRequirementsType ExpressItemRequirements { get; set; }
Public Property ExpressItemRequirements As ExpressItemRequirementsType
    Get
    Set
public:
property ExpressItemRequirementsType^ ExpressItemRequirements {
    ExpressItemRequirementsType^ get ();
    void set (ExpressItemRequirementsType^ value);
}


ExpressListing Property

ExpressListing Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType ► ExpressListing
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressListing { get; set; }
Public Property ExpressListing As Boolean
    Get
    Set
public:
property bool ExpressListing {
    bool get ();
    void set (bool value);
}


ExpressListingSpecified Property

ExpressListingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType ► ExpressListingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressListingSpecified { get; set; }
Public Property ExpressListingSpecified As Boolean
    Get
    Set
public:
property bool ExpressListingSpecified {
    bool get ();
    void set (bool value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType ► ListingRecommendations
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; set; }
Public Property ListingRecommendations As ListingRecommendationsType
    Get
    Set
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
    void set (ListingRecommendationsType^ value);
}


SKU Property

SKU Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType ► SKU
Declaration Syntax
C# Visual Basic Visual C++
public string SKU { get; set; }
Public Property SKU As String
    Get
    Set
public:
property String^ SKU {
    String^ get ();
    void set (String^ value);
}


VerifyAddFixedPriceItemResponseType Constructor

VerifyAddFixedPriceItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► VerifyAddFixedPriceItemResponseType ► VerifyAddFixedPriceItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddFixedPriceItemResponseType()
Public Sub New
public:
VerifyAddFixedPriceItemResponseType()


VerifyAddItemRequestType Class

VerifyAddItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VerifyAddItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VerifyAddItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VerifyAddItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyAddItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | ExternalProductID |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IncludeExpressRequirements |
 | IncludeExpressRequirementsSpecified |
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | VerifyAddItemRequestType


ExternalProductID Property

ExternalProductID Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemRequestType ► ExternalProductID
Declaration Syntax
C# Visual Basic Visual C++
public ExternalProductIDType ExternalProductID { get; set; }
Public Property ExternalProductID As ExternalProductIDType
    Get
    Set
public:
property ExternalProductIDType^ ExternalProductID {
    ExternalProductIDType^ get ();
    void set (ExternalProductIDType^ value);
}


IncludeExpressRequirements Property

IncludeExpressRequirements Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemRequestType ► IncludeExpressRequirements
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeExpressRequirements { get; set; }
Public Property IncludeExpressRequirements As Boolean
    Get
    Set
public:
property bool IncludeExpressRequirements {
    bool get ();
    void set (bool value);
}


IncludeExpressRequirementsSpecified Property

IncludeExpressRequirementsSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemRequestType ► IncludeExpressRequirementsSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeExpressRequirementsSpecified { get; set; }
Public Property IncludeExpressRequirementsSpecified As Boolean
    Get
    Set
public:
property bool IncludeExpressRequirementsSpecified {
    bool get ();
    void set (bool value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


VerifyAddItemRequestType Constructor

VerifyAddItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemRequestType ► VerifyAddItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddItemRequestType()
Public Sub New
public:
VerifyAddItemRequestType()


VerifyAddItemResponseType Class

VerifyAddItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VerifyAddItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VerifyAddItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VerifyAddItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyAddItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | Category2ID |
 | CategoryID |
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DiscountReason |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExpressItemRequirements |
 | ExpressListing |
 | ExpressListingSpecified |
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | ListingRecommendations |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | ProductSuggestions |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | VerifyAddItemResponseType


Category2ID Property

Category2ID Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType ► Category2ID
Declaration Syntax
C# Visual Basic Visual C++
public string Category2ID { get; set; }
Public Property Category2ID As String
    Get
    Set
public:
property String^ Category2ID {
    String^ get ();
    void set (String^ value);
}


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType ► CategoryID
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryID { get; set; }
Public Property CategoryID As String
    Get
    Set
public:
property String^ CategoryID {
    String^ get ();
    void set (String^ value);
}


DiscountReason Property

DiscountReason Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType ► DiscountReason
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReason { get; set; }
Public Property DiscountReason As DiscountReasonCodeTypeCollection
    Get
    Set
public:
property DiscountReasonCodeTypeCollection^ DiscountReason {
    DiscountReasonCodeTypeCollection^ get ();
    void set (DiscountReasonCodeTypeCollection^ value);
}


ExpressItemRequirements Property

ExpressItemRequirements Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType ► ExpressItemRequirements
Declaration Syntax
C# Visual Basic Visual C++
public ExpressItemRequirementsType ExpressItemRequirements { get; set; }
Public Property ExpressItemRequirements As ExpressItemRequirementsType
    Get
    Set
public:
property ExpressItemRequirementsType^ ExpressItemRequirements {
    ExpressItemRequirementsType^ get ();
    void set (ExpressItemRequirementsType^ value);
}


ExpressListing Property

ExpressListing Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType ► ExpressListing
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressListing { get; set; }
Public Property ExpressListing As Boolean
    Get
    Set
public:
property bool ExpressListing {
    bool get ();
    void set (bool value);
}


ExpressListingSpecified Property

ExpressListingSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType ► ExpressListingSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpressListingSpecified { get; set; }
Public Property ExpressListingSpecified As Boolean
    Get
    Set
public:
property bool ExpressListingSpecified {
    bool get ();
    void set (bool value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType ► ListingRecommendations
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; set; }
Public Property ListingRecommendations As ListingRecommendationsType
    Get
    Set
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
    void set (ListingRecommendationsType^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType ► ProductSuggestions
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; set; }
Public Property ProductSuggestions As ProductSuggestionsType
    Get
    Set
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
    void set (ProductSuggestionsType^ value);
}


VerifyAddItemResponseType Constructor

VerifyAddItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► VerifyAddItemResponseType ► VerifyAddItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddItemResponseType()
Public Sub New
public:
VerifyAddItemResponseType()


VerifyAddSecondChanceItemRequestType Class

VerifyAddSecondChanceItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VerifyAddSecondChanceItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VerifyAddSecondChanceItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VerifyAddSecondChanceItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyAddSecondChanceItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | BuyItNowPrice |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | Duration |
 | DurationSpecified |
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | RecipientBidderUserID |
 | SellerMessage |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | VerifyAddSecondChanceItemRequestType


BuyItNowPrice Property

BuyItNowPrice Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemRequestType ► BuyItNowPrice
Declaration Syntax
C# Visual Basic Visual C++
public AmountType BuyItNowPrice { get; set; }
Public Property BuyItNowPrice As AmountType
    Get
    Set
public:
property AmountType^ BuyItNowPrice {
    AmountType^ get ();
    void set (AmountType^ value);
}


Duration Property

Duration Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemRequestType ► Duration
Declaration Syntax
C# Visual Basic Visual C++
public SecondChanceOfferDurationCodeType Duration { get; set; }
Public Property Duration As SecondChanceOfferDurationCodeType
    Get
    Set
public:
property SecondChanceOfferDurationCodeType Duration {
    SecondChanceOfferDurationCodeType get ();
    void set (SecondChanceOfferDurationCodeType value);
}


DurationSpecified Property

DurationSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemRequestType ► DurationSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool DurationSpecified { get; set; }
Public Property DurationSpecified As Boolean
    Get
    Set
public:
property bool DurationSpecified {
    bool get ();
    void set (bool value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemRequestType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


RecipientBidderUserID Property

RecipientBidderUserID Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemRequestType ► RecipientBidderUserID
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientBidderUserID { get; set; }
Public Property RecipientBidderUserID As String
    Get
    Set
public:
property String^ RecipientBidderUserID {
    String^ get ();
    void set (String^ value);
}


SellerMessage Property

SellerMessage Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemRequestType ► SellerMessage
Declaration Syntax
C# Visual Basic Visual C++
public string SellerMessage { get; set; }
Public Property SellerMessage As String
    Get
    Set
public:
property String^ SellerMessage {
    String^ get ();
    void set (String^ value);
}


VerifyAddSecondChanceItemRequestType Constructor

VerifyAddSecondChanceItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemRequestType ► VerifyAddSecondChanceItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddSecondChanceItemRequestType()
Public Sub New
public:
VerifyAddSecondChanceItemRequestType()


VerifyAddSecondChanceItemResponseType Class

VerifyAddSecondChanceItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VerifyAddSecondChanceItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VerifyAddSecondChanceItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VerifyAddSecondChanceItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyAddSecondChanceItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | VerifyAddSecondChanceItemResponseType


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


VerifyAddSecondChanceItemResponseType Constructor

VerifyAddSecondChanceItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► VerifyAddSecondChanceItemResponseType ► VerifyAddSecondChanceItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyAddSecondChanceItemResponseType()
Public Sub New
public:
VerifyAddSecondChanceItemResponseType()


VerifyRelistItemRequestType Class

VerifyRelistItemRequestType Class
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VerifyRelistItemRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VerifyRelistItemRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VerifyRelistItemRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyRelistItemRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DeletedField |
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | Item |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | VerifyRelistItemRequestType


DeletedField Property

DeletedField Property
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemRequestType ► DeletedField
Declaration Syntax
C# Visual Basic Visual C++
public StringCollection DeletedField { get; set; }
Public Property DeletedField As StringCollection
    Get
    Set
public:
property StringCollection^ DeletedField {
    StringCollection^ get ();
    void set (StringCollection^ value);
}


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemRequestType ► Item
Declaration Syntax
C# Visual Basic Visual C++
public ItemType Item { get; set; }
Public Property Item As ItemType
    Get
    Set
public:
property ItemType^ Item {
    ItemType^ get ();
    void set (ItemType^ value);
}


VerifyRelistItemRequestType Constructor

VerifyRelistItemRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemRequestType ► VerifyRelistItemRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyRelistItemRequestType()
Public Sub New
public:
VerifyRelistItemRequestType()


VerifyRelistItemResponseType Class

VerifyRelistItemResponseType Class
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VerifyRelistItemResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VerifyRelistItemResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VerifyRelistItemResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VerifyRelistItemResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DiscountReason |
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | EndTime |
 | EndTimeSpecified |
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Fees |
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | ItemID |
 | ListingRecommendations |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | ProductSuggestions |
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | StartTime |
 | StartTimeSpecified |
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | VerifyRelistItemResponseType


DiscountReason Property

DiscountReason Property
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemResponseType ► DiscountReason
Declaration Syntax
C# Visual Basic Visual C++
public DiscountReasonCodeTypeCollection DiscountReason { get; set; }
Public Property DiscountReason As DiscountReasonCodeTypeCollection
    Get
    Set
public:
property DiscountReasonCodeTypeCollection^ DiscountReason {
    DiscountReasonCodeTypeCollection^ get ();
    void set (DiscountReasonCodeTypeCollection^ value);
}


EndTime Property

EndTime Property
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemResponseType ► EndTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}


EndTimeSpecified Property

EndTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemResponseType ► EndTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool EndTimeSpecified { get; set; }
Public Property EndTimeSpecified As Boolean
    Get
    Set
public:
property bool EndTimeSpecified {
    bool get ();
    void set (bool value);
}


Fees Property

Fees Property
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemResponseType ► Fees
Declaration Syntax
C# Visual Basic Visual C++
public FeeTypeCollection Fees { get; set; }
Public Property Fees As FeeTypeCollection
    Get
    Set
public:
property FeeTypeCollection^ Fees {
    FeeTypeCollection^ get ();
    void set (FeeTypeCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemResponseType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ListingRecommendations Property

ListingRecommendations Property
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemResponseType ► ListingRecommendations
Declaration Syntax
C# Visual Basic Visual C++
public ListingRecommendationsType ListingRecommendations { get; set; }
Public Property ListingRecommendations As ListingRecommendationsType
    Get
    Set
public:
property ListingRecommendationsType^ ListingRecommendations {
    ListingRecommendationsType^ get ();
    void set (ListingRecommendationsType^ value);
}


ProductSuggestions Property

ProductSuggestions Property
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemResponseType ► ProductSuggestions
Declaration Syntax
C# Visual Basic Visual C++
public ProductSuggestionsType ProductSuggestions { get; set; }
Public Property ProductSuggestions As ProductSuggestionsType
    Get
    Set
public:
property ProductSuggestionsType^ ProductSuggestions {
    ProductSuggestionsType^ get ();
    void set (ProductSuggestionsType^ value);
}


StartTime Property

StartTime Property
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemResponseType ► StartTime
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}


StartTimeSpecified Property

StartTimeSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemResponseType ► StartTimeSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool StartTimeSpecified { get; set; }
Public Property StartTimeSpecified As Boolean
    Get
    Set
public:
property bool StartTimeSpecified {
    bool get ();
    void set (bool value);
}


VerifyRelistItemResponseType Constructor

VerifyRelistItemResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► VerifyRelistItemResponseType ► VerifyRelistItemResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VerifyRelistItemResponseType()
Public Sub New
public:
VerifyRelistItemResponseType()


VeROItemStatusCodeType Enumeration

VeROItemStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► VeROItemStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum VeROItemStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration VeROItemStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class VeROItemStatusCodeType
Members
Member | Description
Received |
Submitted |
Removed |
SubmissionFailed |
ClarificationRequired |
CustomCode |
Remarks


VeROReportedItemType Class

VeROReportedItemType Class
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VeROReportedItemType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VeROReportedItemType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VeROReportedItemType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VeROReportedItemType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | ItemReasonForFailure |
 | ItemStatus |
 | ItemStatusSpecified |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
VeROReportedItemType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


ItemReasonForFailure Property

ItemReasonForFailure Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemType ► ItemReasonForFailure
Declaration Syntax
C# Visual Basic Visual C++
public string ItemReasonForFailure { get; set; }
Public Property ItemReasonForFailure As String
    Get
    Set
public:
property String^ ItemReasonForFailure {
    String^ get ();
    void set (String^ value);
}


ItemStatus Property

ItemStatus Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemType ► ItemStatus
Declaration Syntax
C# Visual Basic Visual C++
public VeROItemStatusCodeType ItemStatus { get; set; }
Public Property ItemStatus As VeROItemStatusCodeType
    Get
    Set
public:
property VeROItemStatusCodeType ItemStatus {
    VeROItemStatusCodeType get ();
    void set (VeROItemStatusCodeType value);
}


ItemStatusSpecified Property

ItemStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemType ► ItemStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool ItemStatusSpecified { get; set; }
Public Property ItemStatusSpecified As Boolean
    Get
    Set
public:
property bool ItemStatusSpecified {
    bool get ();
    void set (bool value);
}


VeROReportedItemType Constructor

VeROReportedItemType Constructor
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemType ► VeROReportedItemType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportedItemType()
Public Sub New
public:
VeROReportedItemType()


VeROReportedItemTypeCollection Class

VeROReportedItemTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class VeROReportedItemTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class VeROReportedItemTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class VeROReportedItemTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VeROReportedItemTypeCollection()()()() |
 | VeROReportedItemTypeCollection(array<VeROReportedItemType>[]()[][]) |
 | VeROReportedItemTypeCollection(VeROReportedItemTypeCollection) |
 | Add(VeROReportedItemType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<VeROReportedItemType>[]()[][]) |
 | AddRange(VeROReportedItemTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(VeROReportedItemType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<VeROReportedItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(VeROReportedItemType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, VeROReportedItemType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(VeROReportedItemType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | VeROReportedItemTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► Add(VeROReportedItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    VeROReportedItemType item
)
Public Function Add ( _
    item As VeROReportedItemType _
) As Integer
public:
int Add(
    VeROReportedItemType^ item
)
Parameters
item (VeROReportedItemType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<VeROReportedItemType>[]()[][]) |
 | AddRange(VeROReportedItemTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► AddRange(array<VeROReportedItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VeROReportedItemType[] items
)
Public Sub AddRange ( _
    items As VeROReportedItemType() _
)
public:
void AddRange(
    array<VeROReportedItemType^>^ items
)
Parameters
items (array< VeROReportedItemType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► AddRange(VeROReportedItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VeROReportedItemTypeCollection items
)
Public Sub AddRange ( _
    items As VeROReportedItemTypeCollection _
)
public:
void AddRange(
    VeROReportedItemTypeCollection^ items
)
Parameters
items (VeROReportedItemTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► Contains(VeROReportedItemType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    VeROReportedItemType item
)
Public Function Contains ( _
    item As VeROReportedItemType _
) As Boolean
public:
bool Contains(
    VeROReportedItemType^ item
)
Parameters
item (VeROReportedItemType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► CopyTo(array<VeROReportedItemType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    VeROReportedItemType[] items,
    int index
)
Public Sub CopyTo ( _
    items As VeROReportedItemType(), _
    index As Integer _
)
public:
void CopyTo(
    array<VeROReportedItemType^>^ items,
    int index
)
Parameters
items (array< VeROReportedItemType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► IndexOf(VeROReportedItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    VeROReportedItemType item
)
Public Function IndexOf ( _
    item As VeROReportedItemType _
) As Integer
public:
int IndexOf(
    VeROReportedItemType^ item
)
Parameters
item (VeROReportedItemType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► Insert(Int32, VeROReportedItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    VeROReportedItemType item
)
Public Sub Insert ( _
    index As Integer, _
    item As VeROReportedItemType _
)
public:
void Insert(
    int index,
    VeROReportedItemType^ item
)
Parameters
index (Int32)
item (VeROReportedItemType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportedItemType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As VeROReportedItemType
    Get
    Set
public:
property VeROReportedItemType^ default[int index] {
    VeROReportedItemType^ get (int index);
    void set (int index, VeROReportedItemType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportedItemType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As VeROReportedItemType
public:
VeROReportedItemType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► Remove(VeROReportedItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    VeROReportedItemType item
)
Public Sub Remove ( _
    item As VeROReportedItemType _
)
public:
void Remove(
    VeROReportedItemType^ item
)
Parameters
item (VeROReportedItemType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportedItemType[] ToArray()
Public Function ToArray As VeROReportedItemType()
public:
array<VeROReportedItemType^>^ ToArray()
Return Value


VeROReportedItemTypeCollection Constructor

VeROReportedItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► VeROReportedItemTypeCollection()()()()
Members
Icon | Member | Description
 | VeROReportedItemTypeCollection()()()() |
 | VeROReportedItemTypeCollection(array<VeROReportedItemType>[]()[][]) |
 | VeROReportedItemTypeCollection(VeROReportedItemTypeCollection) |


VeROReportedItemTypeCollection Constructor

VeROReportedItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► VeROReportedItemTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportedItemTypeCollection()
Public Sub New
public:
VeROReportedItemTypeCollection()


VeROReportedItemTypeCollection Constructor (items)

VeROReportedItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► VeROReportedItemTypeCollection(array<VeROReportedItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportedItemTypeCollection(
    VeROReportedItemType[] items
)
Public Sub New ( _
    items As VeROReportedItemType() _
)
public:
VeROReportedItemTypeCollection(
    array<VeROReportedItemType^>^ items
)
Parameters
items (array< VeROReportedItemType >[]()[][])


VeROReportedItemTypeCollection Constructor (items)

VeROReportedItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► VeROReportedItemTypeCollection(VeROReportedItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportedItemTypeCollection(
    VeROReportedItemTypeCollection items
)
Public Sub New ( _
    items As VeROReportedItemTypeCollection _
)
public:
VeROReportedItemTypeCollection(
    VeROReportedItemTypeCollection^ items
)
Parameters
items (VeROReportedItemTypeCollection)


VeROReportItemsRequestType Class

VeROReportItemsRequestType Class
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemsRequestType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VeROReportItemsRequestType : AbstractRequestType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VeROReportItemsRequestType _
    Inherits AbstractRequestType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VeROReportItemsRequestType : public AbstractRequestType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VeROReportItemsRequestType()()()() |
 | Any | (Inherited from AbstractRequestType.)
 | BotBlock | (Inherited from AbstractRequestType.)
 | DetailLevel | (Inherited from AbstractRequestType.)
 | EndUserIP | (Inherited from AbstractRequestType.)
 | Equals(Object) | (Inherited from Object.)
 | ErrorHandling | (Inherited from AbstractRequestType.)
 | ErrorHandlingSpecified | (Inherited from AbstractRequestType.)
 | ErrorLanguage | (Inherited from AbstractRequestType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | InvocationID | (Inherited from AbstractRequestType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageID | (Inherited from AbstractRequestType.)
 | OutputSelector | (Inherited from AbstractRequestType.)
 | ReportItems |
 | RightsOwnerID |
 | ToString()()()() | (Inherited from Object.)
 | Version | (Inherited from AbstractRequestType.)
 | WarningLevel | (Inherited from AbstractRequestType.)
 | WarningLevelSpecified | (Inherited from AbstractRequestType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractRequestType
 |  | VeROReportItemsRequestType


ReportItems Property

ReportItems Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemsRequestType ► ReportItems
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemTypeCollection ReportItems { get; set; }
Public Property ReportItems As VeROReportItemTypeCollection
    Get
    Set
public:
property VeROReportItemTypeCollection^ ReportItems {
    VeROReportItemTypeCollection^ get ();
    void set (VeROReportItemTypeCollection^ value);
}


RightsOwnerID Property

RightsOwnerID Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemsRequestType ► RightsOwnerID
Declaration Syntax
C# Visual Basic Visual C++
public string RightsOwnerID { get; set; }
Public Property RightsOwnerID As String
    Get
    Set
public:
property String^ RightsOwnerID {
    String^ get ();
    void set (String^ value);
}


VeROReportItemsRequestType Constructor

VeROReportItemsRequestType Constructor
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemsRequestType ► VeROReportItemsRequestType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemsRequestType()
Public Sub New
public:
VeROReportItemsRequestType()


VeROReportItemsResponseType Class

VeROReportItemsResponseType Class
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemsResponseType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VeROReportItemsResponseType : AbstractResponseType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VeROReportItemsResponseType _
    Inherits AbstractResponseType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VeROReportItemsResponseType : public AbstractResponseType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VeROReportItemsResponseType()()()() |
 | Ack | (Inherited from AbstractResponseType.)
 | AckSpecified | (Inherited from AbstractResponseType.)
 | Any | (Inherited from AbstractResponseType.)
 | BotBlock | (Inherited from AbstractResponseType.)
 | Build | (Inherited from AbstractResponseType.)
 | CorrelationID | (Inherited from AbstractResponseType.)
 | DuplicateInvocationDetails | (Inherited from AbstractResponseType.)
 | EIASToken | (Inherited from AbstractResponseType.)
 | Equals(Object) | (Inherited from Object.)
 | Errors | (Inherited from AbstractResponseType.)
 | ExternalUserData | (Inherited from AbstractResponseType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | HardExpirationWarning | (Inherited from AbstractResponseType.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Message | (Inherited from AbstractResponseType.)
 | NotificationEventName | (Inherited from AbstractResponseType.)
 | NotificationSignature | (Inherited from AbstractResponseType.)
 | RecipientUserID | (Inherited from AbstractResponseType.)
 | Timestamp | (Inherited from AbstractResponseType.)
 | TimestampSpecified | (Inherited from AbstractResponseType.)
 | ToString()()()() | (Inherited from Object.)
 | VeROReportPacketID |
 | VeROReportPacketIDSpecified |
 | VeROReportPacketStatus |
 | VeROReportPacketStatusSpecified |
 | Version | (Inherited from AbstractResponseType.)
Remarks
Inheritance Hierarchy
Object
 | AbstractResponseType
 |  | VeROReportItemsResponseType


VeROReportItemsResponseType Constructor

VeROReportItemsResponseType Constructor
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemsResponseType ► VeROReportItemsResponseType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemsResponseType()
Public Sub New
public:
VeROReportItemsResponseType()


VeROReportPacketID Property

VeROReportPacketID Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemsResponseType ► VeROReportPacketID
Declaration Syntax
C# Visual Basic Visual C++
public long VeROReportPacketID { get; set; }
Public Property VeROReportPacketID As Long
    Get
    Set
public:
property long long VeROReportPacketID {
    long long get ();
    void set (long long value);
}


VeROReportPacketIDSpecified Property

VeROReportPacketIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemsResponseType ► VeROReportPacketIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VeROReportPacketIDSpecified { get; set; }
Public Property VeROReportPacketIDSpecified As Boolean
    Get
    Set
public:
property bool VeROReportPacketIDSpecified {
    bool get ();
    void set (bool value);
}


VeROReportPacketStatus Property

VeROReportPacketStatus Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemsResponseType ► VeROReportPacketStatus
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportPacketStatusCodeType VeROReportPacketStatus { get; set; }
Public Property VeROReportPacketStatus As VeROReportPacketStatusCodeType
    Get
    Set
public:
property VeROReportPacketStatusCodeType VeROReportPacketStatus {
    VeROReportPacketStatusCodeType get ();
    void set (VeROReportPacketStatusCodeType value);
}


VeROReportPacketStatusSpecified Property

VeROReportPacketStatusSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemsResponseType ► VeROReportPacketStatusSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VeROReportPacketStatusSpecified { get; set; }
Public Property VeROReportPacketStatusSpecified As Boolean
    Get
    Set
public:
property bool VeROReportPacketStatusSpecified {
    bool get ();
    void set (bool value);
}


VeROReportItemType Class

VeROReportItemType Class
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VeROReportItemType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VeROReportItemType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VeROReportItemType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VeROReportItemType()()()() |
 | Any |
 | CopyEmailToRightsOwner |
 | CopyEmailToRightsOwnerSpecified |
 | Country |
 | DetailedMessage |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ItemID |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MessageToSeller |
 | Patent |
 | Region |
 | ToString()()()() | (Inherited from Object.)
 | VeROReasonCodeID |
 | VeROReasonCodeIDSpecified |
Remarks
Inheritance Hierarchy
Object
VeROReportItemType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


CopyEmailToRightsOwner Property

CopyEmailToRightsOwner Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► CopyEmailToRightsOwner
Declaration Syntax
C# Visual Basic Visual C++
public bool CopyEmailToRightsOwner { get; set; }
Public Property CopyEmailToRightsOwner As Boolean
    Get
    Set
public:
property bool CopyEmailToRightsOwner {
    bool get ();
    void set (bool value);
}


CopyEmailToRightsOwnerSpecified Property

CopyEmailToRightsOwnerSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► CopyEmailToRightsOwnerSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool CopyEmailToRightsOwnerSpecified { get; set; }
Public Property CopyEmailToRightsOwnerSpecified As Boolean
    Get
    Set
public:
property bool CopyEmailToRightsOwnerSpecified {
    bool get ();
    void set (bool value);
}


Country Property

Country Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► Country
Declaration Syntax
C# Visual Basic Visual C++
public CountryCodeTypeCollection Country { get; set; }
Public Property Country As CountryCodeTypeCollection
    Get
    Set
public:
property CountryCodeTypeCollection^ Country {
    CountryCodeTypeCollection^ get ();
    void set (CountryCodeTypeCollection^ value);
}


DetailedMessage Property

DetailedMessage Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► DetailedMessage
Declaration Syntax
C# Visual Basic Visual C++
public string DetailedMessage { get; set; }
Public Property DetailedMessage As String
    Get
    Set
public:
property String^ DetailedMessage {
    String^ get ();
    void set (String^ value);
}


ItemID Property

ItemID Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► ItemID
Declaration Syntax
C# Visual Basic Visual C++
public string ItemID { get; set; }
Public Property ItemID As String
    Get
    Set
public:
property String^ ItemID {
    String^ get ();
    void set (String^ value);
}


MessageToSeller Property

MessageToSeller Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► MessageToSeller
Declaration Syntax
C# Visual Basic Visual C++
public string MessageToSeller { get; set; }
Public Property MessageToSeller As String
    Get
    Set
public:
property String^ MessageToSeller {
    String^ get ();
    void set (String^ value);
}


Patent Property

Patent Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► Patent
Declaration Syntax
C# Visual Basic Visual C++
public string Patent { get; set; }
Public Property Patent As String
    Get
    Set
public:
property String^ Patent {
    String^ get ();
    void set (String^ value);
}


Region Property

Region Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► Region
Declaration Syntax
C# Visual Basic Visual C++
public ShippingRegionCodeTypeCollection Region { get; set; }
Public Property Region As ShippingRegionCodeTypeCollection
    Get
    Set
public:
property ShippingRegionCodeTypeCollection^ Region {
    ShippingRegionCodeTypeCollection^ get ();
    void set (ShippingRegionCodeTypeCollection^ value);
}


VeROReasonCodeID Property

VeROReasonCodeID Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► VeROReasonCodeID
Declaration Syntax
C# Visual Basic Visual C++
public long VeROReasonCodeID { get; set; }
Public Property VeROReasonCodeID As Long
    Get
    Set
public:
property long long VeROReasonCodeID {
    long long get ();
    void set (long long value);
}


VeROReasonCodeIDSpecified Property

VeROReasonCodeIDSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► VeROReasonCodeIDSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool VeROReasonCodeIDSpecified { get; set; }
Public Property VeROReasonCodeIDSpecified As Boolean
    Get
    Set
public:
property bool VeROReasonCodeIDSpecified {
    bool get ();
    void set (bool value);
}


VeROReportItemType Constructor

VeROReportItemType Constructor
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemType ► VeROReportItemType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemType()
Public Sub New
public:
VeROReportItemType()


VeROReportItemTypeCollection Class

VeROReportItemTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class VeROReportItemTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class VeROReportItemTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class VeROReportItemTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VeROReportItemTypeCollection()()()() |
 | VeROReportItemTypeCollection(array<VeROReportItemType>[]()[][]) |
 | VeROReportItemTypeCollection(VeROReportItemTypeCollection) |
 | Add(VeROReportItemType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<VeROReportItemType>[]()[][]) |
 | AddRange(VeROReportItemTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(VeROReportItemType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<VeROReportItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(VeROReportItemType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, VeROReportItemType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(VeROReportItemType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | VeROReportItemTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► Add(VeROReportItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    VeROReportItemType item
)
Public Function Add ( _
    item As VeROReportItemType _
) As Integer
public:
int Add(
    VeROReportItemType^ item
)
Parameters
item (VeROReportItemType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<VeROReportItemType>[]()[][]) |
 | AddRange(VeROReportItemTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► AddRange(array<VeROReportItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VeROReportItemType[] items
)
Public Sub AddRange ( _
    items As VeROReportItemType() _
)
public:
void AddRange(
    array<VeROReportItemType^>^ items
)
Parameters
items (array< VeROReportItemType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► AddRange(VeROReportItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VeROReportItemTypeCollection items
)
Public Sub AddRange ( _
    items As VeROReportItemTypeCollection _
)
public:
void AddRange(
    VeROReportItemTypeCollection^ items
)
Parameters
items (VeROReportItemTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► Contains(VeROReportItemType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    VeROReportItemType item
)
Public Function Contains ( _
    item As VeROReportItemType _
) As Boolean
public:
bool Contains(
    VeROReportItemType^ item
)
Parameters
item (VeROReportItemType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► CopyTo(array<VeROReportItemType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    VeROReportItemType[] items,
    int index
)
Public Sub CopyTo ( _
    items As VeROReportItemType(), _
    index As Integer _
)
public:
void CopyTo(
    array<VeROReportItemType^>^ items,
    int index
)
Parameters
items (array< VeROReportItemType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► IndexOf(VeROReportItemType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    VeROReportItemType item
)
Public Function IndexOf ( _
    item As VeROReportItemType _
) As Integer
public:
int IndexOf(
    VeROReportItemType^ item
)
Parameters
item (VeROReportItemType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► Insert(Int32, VeROReportItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    VeROReportItemType item
)
Public Sub Insert ( _
    index As Integer, _
    item As VeROReportItemType _
)
public:
void Insert(
    int index,
    VeROReportItemType^ item
)
Parameters
index (Int32)
item (VeROReportItemType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As VeROReportItemType
    Get
    Set
public:
property VeROReportItemType^ default[int index] {
    VeROReportItemType^ get (int index);
    void set (int index, VeROReportItemType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As VeROReportItemType
public:
VeROReportItemType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► Remove(VeROReportItemType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    VeROReportItemType item
)
Public Sub Remove ( _
    item As VeROReportItemType _
)
public:
void Remove(
    VeROReportItemType^ item
)
Parameters
item (VeROReportItemType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemType[] ToArray()
Public Function ToArray As VeROReportItemType()
public:
array<VeROReportItemType^>^ ToArray()
Return Value


VeROReportItemTypeCollection Constructor

VeROReportItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► VeROReportItemTypeCollection()()()()
Members
Icon | Member | Description
 | VeROReportItemTypeCollection()()()() |
 | VeROReportItemTypeCollection(array<VeROReportItemType>[]()[][]) |
 | VeROReportItemTypeCollection(VeROReportItemTypeCollection) |


VeROReportItemTypeCollection Constructor

VeROReportItemTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► VeROReportItemTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemTypeCollection()
Public Sub New
public:
VeROReportItemTypeCollection()


VeROReportItemTypeCollection Constructor (items)

VeROReportItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► VeROReportItemTypeCollection(array<VeROReportItemType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemTypeCollection(
    VeROReportItemType[] items
)
Public Sub New ( _
    items As VeROReportItemType() _
)
public:
VeROReportItemTypeCollection(
    array<VeROReportItemType^>^ items
)
Parameters
items (array< VeROReportItemType >[]()[][])


VeROReportItemTypeCollection Constructor (items)

VeROReportItemTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► VeROReportItemTypeCollection(VeROReportItemTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public VeROReportItemTypeCollection(
    VeROReportItemTypeCollection items
)
Public Sub New ( _
    items As VeROReportItemTypeCollection _
)
public:
VeROReportItemTypeCollection(
    VeROReportItemTypeCollection^ items
)
Parameters
items (VeROReportItemTypeCollection)


VeROReportPacketStatusCodeType Enumeration

VeROReportPacketStatusCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► VeROReportPacketStatusCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum VeROReportPacketStatusCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration VeROReportPacketStatusCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class VeROReportPacketStatusCodeType
Members
Member | Description
Received |
InProcess |
Processed |
CustomCode |
Remarks


VeROSiteDetailType Class

VeROSiteDetailType Class
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VeROSiteDetailType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VeROSiteDetailType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VeROSiteDetailType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VeROSiteDetailType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ReasonCodeDetail |
 | Site |
 | SiteSpecified |
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
VeROSiteDetailType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


ReasonCodeDetail Property

ReasonCodeDetail Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailType ► ReasonCodeDetail
Declaration Syntax
C# Visual Basic Visual C++
public ReasonCodeDetailTypeCollection ReasonCodeDetail { get; set; }
Public Property ReasonCodeDetail As ReasonCodeDetailTypeCollection
    Get
    Set
public:
property ReasonCodeDetailTypeCollection^ ReasonCodeDetail {
    ReasonCodeDetailTypeCollection^ get ();
    void set (ReasonCodeDetailTypeCollection^ value);
}


Site Property

Site Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailType ► Site
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType Site { get; set; }
Public Property Site As SiteCodeType
    Get
    Set
public:
property SiteCodeType Site {
    SiteCodeType get ();
    void set (SiteCodeType value);
}


SiteSpecified Property

SiteSpecified Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailType ► SiteSpecified
Declaration Syntax
C# Visual Basic Visual C++
public bool SiteSpecified { get; set; }
Public Property SiteSpecified As Boolean
    Get
    Set
public:
property bool SiteSpecified {
    bool get ();
    void set (bool value);
}


VeROSiteDetailType Constructor

VeROSiteDetailType Constructor
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailType ► VeROSiteDetailType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROSiteDetailType()
Public Sub New
public:
VeROSiteDetailType()


VeROSiteDetailTypeCollection Class

VeROSiteDetailTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class VeROSiteDetailTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class VeROSiteDetailTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class VeROSiteDetailTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VeROSiteDetailTypeCollection()()()() |
 | VeROSiteDetailTypeCollection(array<VeROSiteDetailType>[]()[][]) |
 | VeROSiteDetailTypeCollection(VeROSiteDetailTypeCollection) |
 | Add(VeROSiteDetailType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<VeROSiteDetailType>[]()[][]) |
 | AddRange(VeROSiteDetailTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(VeROSiteDetailType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<VeROSiteDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(VeROSiteDetailType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, VeROSiteDetailType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(VeROSiteDetailType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | VeROSiteDetailTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► Add(VeROSiteDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    VeROSiteDetailType item
)
Public Function Add ( _
    item As VeROSiteDetailType _
) As Integer
public:
int Add(
    VeROSiteDetailType^ item
)
Parameters
item (VeROSiteDetailType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<VeROSiteDetailType>[]()[][]) |
 | AddRange(VeROSiteDetailTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► AddRange(array<VeROSiteDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VeROSiteDetailType[] items
)
Public Sub AddRange ( _
    items As VeROSiteDetailType() _
)
public:
void AddRange(
    array<VeROSiteDetailType^>^ items
)
Parameters
items (array< VeROSiteDetailType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► AddRange(VeROSiteDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    VeROSiteDetailTypeCollection items
)
Public Sub AddRange ( _
    items As VeROSiteDetailTypeCollection _
)
public:
void AddRange(
    VeROSiteDetailTypeCollection^ items
)
Parameters
items (VeROSiteDetailTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► Contains(VeROSiteDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    VeROSiteDetailType item
)
Public Function Contains ( _
    item As VeROSiteDetailType _
) As Boolean
public:
bool Contains(
    VeROSiteDetailType^ item
)
Parameters
item (VeROSiteDetailType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► CopyTo(array<VeROSiteDetailType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    VeROSiteDetailType[] items,
    int index
)
Public Sub CopyTo ( _
    items As VeROSiteDetailType(), _
    index As Integer _
)
public:
void CopyTo(
    array<VeROSiteDetailType^>^ items,
    int index
)
Parameters
items (array< VeROSiteDetailType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► IndexOf(VeROSiteDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    VeROSiteDetailType item
)
Public Function IndexOf ( _
    item As VeROSiteDetailType _
) As Integer
public:
int IndexOf(
    VeROSiteDetailType^ item
)
Parameters
item (VeROSiteDetailType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► Insert(Int32, VeROSiteDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    VeROSiteDetailType item
)
Public Sub Insert ( _
    index As Integer, _
    item As VeROSiteDetailType _
)
public:
void Insert(
    int index,
    VeROSiteDetailType^ item
)
Parameters
index (Int32)
item (VeROSiteDetailType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public VeROSiteDetailType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As VeROSiteDetailType
    Get
    Set
public:
property VeROSiteDetailType^ default[int index] {
    VeROSiteDetailType^ get (int index);
    void set (int index, VeROSiteDetailType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public VeROSiteDetailType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As VeROSiteDetailType
public:
VeROSiteDetailType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► Remove(VeROSiteDetailType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    VeROSiteDetailType item
)
Public Sub Remove ( _
    item As VeROSiteDetailType _
)
public:
void Remove(
    VeROSiteDetailType^ item
)
Parameters
item (VeROSiteDetailType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROSiteDetailType[] ToArray()
Public Function ToArray As VeROSiteDetailType()
public:
array<VeROSiteDetailType^>^ ToArray()
Return Value


VeROSiteDetailTypeCollection Constructor

VeROSiteDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► VeROSiteDetailTypeCollection()()()()
Members
Icon | Member | Description
 | VeROSiteDetailTypeCollection()()()() |
 | VeROSiteDetailTypeCollection(array<VeROSiteDetailType>[]()[][]) |
 | VeROSiteDetailTypeCollection(VeROSiteDetailTypeCollection) |


VeROSiteDetailTypeCollection Constructor

VeROSiteDetailTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► VeROSiteDetailTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VeROSiteDetailTypeCollection()
Public Sub New
public:
VeROSiteDetailTypeCollection()


VeROSiteDetailTypeCollection Constructor (items)

VeROSiteDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► VeROSiteDetailTypeCollection(array<VeROSiteDetailType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public VeROSiteDetailTypeCollection(
    VeROSiteDetailType[] items
)
Public Sub New ( _
    items As VeROSiteDetailType() _
)
public:
VeROSiteDetailTypeCollection(
    array<VeROSiteDetailType^>^ items
)
Parameters
items (array< VeROSiteDetailType >[]()[][])


VeROSiteDetailTypeCollection Constructor (items)

VeROSiteDetailTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► VeROSiteDetailTypeCollection(VeROSiteDetailTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public VeROSiteDetailTypeCollection(
    VeROSiteDetailTypeCollection items
)
Public Sub New ( _
    items As VeROSiteDetailTypeCollection _
)
public:
VeROSiteDetailTypeCollection(
    VeROSiteDetailTypeCollection^ items
)
Parameters
items (VeROSiteDetailTypeCollection)


VINSupportedDefinitionType Class

VINSupportedDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► VINSupportedDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VINSupportedDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VINSupportedDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VINSupportedDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VINSupportedDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
VINSupportedDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VINSupportedDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


VINSupportedDefinitionType Constructor

VINSupportedDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► VINSupportedDefinitionType ► VINSupportedDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VINSupportedDefinitionType()
Public Sub New
public:
VINSupportedDefinitionType()


VRMSupportedDefinitionType Class

VRMSupportedDefinitionType Class
Namespaces ► eBay.Service.Core.Soap ► VRMSupportedDefinitionType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class VRMSupportedDefinitionType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class VRMSupportedDefinitionType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class VRMSupportedDefinitionType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VRMSupportedDefinitionType()()()() |
 | Any |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
VRMSupportedDefinitionType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► VRMSupportedDefinitionType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


VRMSupportedDefinitionType Constructor

VRMSupportedDefinitionType Constructor
Namespaces ► eBay.Service.Core.Soap ► VRMSupportedDefinitionType ► VRMSupportedDefinitionType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public VRMSupportedDefinitionType()
Public Sub New
public:
VRMSupportedDefinitionType()


WarningLevelCodeType Enumeration

WarningLevelCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► WarningLevelCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum WarningLevelCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration WarningLevelCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class WarningLevelCodeType
Members
Member | Description
Low |
High |
Remarks


WarrantyDurationDetailsType Class

WarrantyDurationDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class WarrantyDurationDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class WarrantyDurationDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class WarrantyDurationDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WarrantyDurationDetailsType()()()() |
 | Any |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | WarrantyDurationOption |
Remarks
Inheritance Hierarchy
Object
WarrantyDurationDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


WarrantyDurationDetailsType Constructor

WarrantyDurationDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsType ► WarrantyDurationDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyDurationDetailsType()
Public Sub New
public:
WarrantyDurationDetailsType()


WarrantyDurationOption Property

WarrantyDurationOption Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsType ► WarrantyDurationOption
Declaration Syntax
C# Visual Basic Visual C++
public string WarrantyDurationOption { get; set; }
Public Property WarrantyDurationOption As String
    Get
    Set
public:
property String^ WarrantyDurationOption {
    String^ get ();
    void set (String^ value);
}


WarrantyDurationDetailsTypeCollection Class

WarrantyDurationDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class WarrantyDurationDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class WarrantyDurationDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class WarrantyDurationDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WarrantyDurationDetailsTypeCollection()()()() |
 | WarrantyDurationDetailsTypeCollection(array<WarrantyDurationDetailsType>[]()[][]) |
 | WarrantyDurationDetailsTypeCollection(WarrantyDurationDetailsTypeCollection) |
 | Add(WarrantyDurationDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<WarrantyDurationDetailsType>[]()[][]) |
 | AddRange(WarrantyDurationDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(WarrantyDurationDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<WarrantyDurationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(WarrantyDurationDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, WarrantyDurationDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(WarrantyDurationDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | WarrantyDurationDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► Add(WarrantyDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    WarrantyDurationDetailsType item
)
Public Function Add ( _
    item As WarrantyDurationDetailsType _
) As Integer
public:
int Add(
    WarrantyDurationDetailsType^ item
)
Parameters
item (WarrantyDurationDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<WarrantyDurationDetailsType>[]()[][]) |
 | AddRange(WarrantyDurationDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► AddRange(array<WarrantyDurationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    WarrantyDurationDetailsType[] items
)
Public Sub AddRange ( _
    items As WarrantyDurationDetailsType() _
)
public:
void AddRange(
    array<WarrantyDurationDetailsType^>^ items
)
Parameters
items (array< WarrantyDurationDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► AddRange(WarrantyDurationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    WarrantyDurationDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As WarrantyDurationDetailsTypeCollection _
)
public:
void AddRange(
    WarrantyDurationDetailsTypeCollection^ items
)
Parameters
items (WarrantyDurationDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► Contains(WarrantyDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    WarrantyDurationDetailsType item
)
Public Function Contains ( _
    item As WarrantyDurationDetailsType _
) As Boolean
public:
bool Contains(
    WarrantyDurationDetailsType^ item
)
Parameters
item (WarrantyDurationDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► CopyTo(array<WarrantyDurationDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    WarrantyDurationDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As WarrantyDurationDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<WarrantyDurationDetailsType^>^ items,
    int index
)
Parameters
items (array< WarrantyDurationDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► IndexOf(WarrantyDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    WarrantyDurationDetailsType item
)
Public Function IndexOf ( _
    item As WarrantyDurationDetailsType _
) As Integer
public:
int IndexOf(
    WarrantyDurationDetailsType^ item
)
Parameters
item (WarrantyDurationDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► Insert(Int32, WarrantyDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    WarrantyDurationDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As WarrantyDurationDetailsType _
)
public:
void Insert(
    int index,
    WarrantyDurationDetailsType^ item
)
Parameters
index (Int32)
item (WarrantyDurationDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyDurationDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As WarrantyDurationDetailsType
    Get
    Set
public:
property WarrantyDurationDetailsType^ default[int index] {
    WarrantyDurationDetailsType^ get (int index);
    void set (int index, WarrantyDurationDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyDurationDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As WarrantyDurationDetailsType
public:
WarrantyDurationDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► Remove(WarrantyDurationDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    WarrantyDurationDetailsType item
)
Public Sub Remove ( _
    item As WarrantyDurationDetailsType _
)
public:
void Remove(
    WarrantyDurationDetailsType^ item
)
Parameters
item (WarrantyDurationDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyDurationDetailsType[] ToArray()
Public Function ToArray As WarrantyDurationDetailsType()
public:
array<WarrantyDurationDetailsType^>^ ToArray()
Return Value


WarrantyDurationDetailsTypeCollection Constructor

WarrantyDurationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► WarrantyDurationDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | WarrantyDurationDetailsTypeCollection()()()() |
 | WarrantyDurationDetailsTypeCollection(array<WarrantyDurationDetailsType>[]()[][]) |
 | WarrantyDurationDetailsTypeCollection(WarrantyDurationDetailsTypeCollection) |


WarrantyDurationDetailsTypeCollection Constructor

WarrantyDurationDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► WarrantyDurationDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyDurationDetailsTypeCollection()
Public Sub New
public:
WarrantyDurationDetailsTypeCollection()


WarrantyDurationDetailsTypeCollection Constructor (items)

WarrantyDurationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► WarrantyDurationDetailsTypeCollection(array<WarrantyDurationDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyDurationDetailsTypeCollection(
    WarrantyDurationDetailsType[] items
)
Public Sub New ( _
    items As WarrantyDurationDetailsType() _
)
public:
WarrantyDurationDetailsTypeCollection(
    array<WarrantyDurationDetailsType^>^ items
)
Parameters
items (array< WarrantyDurationDetailsType >[]()[][])


WarrantyDurationDetailsTypeCollection Constructor (items)

WarrantyDurationDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► WarrantyDurationDetailsTypeCollection(WarrantyDurationDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyDurationDetailsTypeCollection(
    WarrantyDurationDetailsTypeCollection items
)
Public Sub New ( _
    items As WarrantyDurationDetailsTypeCollection _
)
public:
WarrantyDurationDetailsTypeCollection(
    WarrantyDurationDetailsTypeCollection^ items
)
Parameters
items (WarrantyDurationDetailsTypeCollection)


WarrantyOfferedDetailsType Class

WarrantyOfferedDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class WarrantyOfferedDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class WarrantyOfferedDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class WarrantyOfferedDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WarrantyOfferedDetailsType()()()() |
 | Any |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | WarrantyOfferedOption |
Remarks
Inheritance Hierarchy
Object
WarrantyOfferedDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


WarrantyOfferedDetailsType Constructor

WarrantyOfferedDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsType ► WarrantyOfferedDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyOfferedDetailsType()
Public Sub New
public:
WarrantyOfferedDetailsType()


WarrantyOfferedOption Property

WarrantyOfferedOption Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsType ► WarrantyOfferedOption
Declaration Syntax
C# Visual Basic Visual C++
public string WarrantyOfferedOption { get; set; }
Public Property WarrantyOfferedOption As String
    Get
    Set
public:
property String^ WarrantyOfferedOption {
    String^ get ();
    void set (String^ value);
}


WarrantyOfferedDetailsTypeCollection Class

WarrantyOfferedDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class WarrantyOfferedDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class WarrantyOfferedDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class WarrantyOfferedDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WarrantyOfferedDetailsTypeCollection()()()() |
 | WarrantyOfferedDetailsTypeCollection(array<WarrantyOfferedDetailsType>[]()[][]) |
 | WarrantyOfferedDetailsTypeCollection(WarrantyOfferedDetailsTypeCollection) |
 | Add(WarrantyOfferedDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<WarrantyOfferedDetailsType>[]()[][]) |
 | AddRange(WarrantyOfferedDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(WarrantyOfferedDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<WarrantyOfferedDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(WarrantyOfferedDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, WarrantyOfferedDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(WarrantyOfferedDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | WarrantyOfferedDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► Add(WarrantyOfferedDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    WarrantyOfferedDetailsType item
)
Public Function Add ( _
    item As WarrantyOfferedDetailsType _
) As Integer
public:
int Add(
    WarrantyOfferedDetailsType^ item
)
Parameters
item (WarrantyOfferedDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<WarrantyOfferedDetailsType>[]()[][]) |
 | AddRange(WarrantyOfferedDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► AddRange(array<WarrantyOfferedDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    WarrantyOfferedDetailsType[] items
)
Public Sub AddRange ( _
    items As WarrantyOfferedDetailsType() _
)
public:
void AddRange(
    array<WarrantyOfferedDetailsType^>^ items
)
Parameters
items (array< WarrantyOfferedDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► AddRange(WarrantyOfferedDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    WarrantyOfferedDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As WarrantyOfferedDetailsTypeCollection _
)
public:
void AddRange(
    WarrantyOfferedDetailsTypeCollection^ items
)
Parameters
items (WarrantyOfferedDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► Contains(WarrantyOfferedDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    WarrantyOfferedDetailsType item
)
Public Function Contains ( _
    item As WarrantyOfferedDetailsType _
) As Boolean
public:
bool Contains(
    WarrantyOfferedDetailsType^ item
)
Parameters
item (WarrantyOfferedDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► CopyTo(array<WarrantyOfferedDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    WarrantyOfferedDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As WarrantyOfferedDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<WarrantyOfferedDetailsType^>^ items,
    int index
)
Parameters
items (array< WarrantyOfferedDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► IndexOf(WarrantyOfferedDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    WarrantyOfferedDetailsType item
)
Public Function IndexOf ( _
    item As WarrantyOfferedDetailsType _
) As Integer
public:
int IndexOf(
    WarrantyOfferedDetailsType^ item
)
Parameters
item (WarrantyOfferedDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► Insert(Int32, WarrantyOfferedDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    WarrantyOfferedDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As WarrantyOfferedDetailsType _
)
public:
void Insert(
    int index,
    WarrantyOfferedDetailsType^ item
)
Parameters
index (Int32)
item (WarrantyOfferedDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyOfferedDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As WarrantyOfferedDetailsType
    Get
    Set
public:
property WarrantyOfferedDetailsType^ default[int index] {
    WarrantyOfferedDetailsType^ get (int index);
    void set (int index, WarrantyOfferedDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyOfferedDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As WarrantyOfferedDetailsType
public:
WarrantyOfferedDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► Remove(WarrantyOfferedDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    WarrantyOfferedDetailsType item
)
Public Sub Remove ( _
    item As WarrantyOfferedDetailsType _
)
public:
void Remove(
    WarrantyOfferedDetailsType^ item
)
Parameters
item (WarrantyOfferedDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyOfferedDetailsType[] ToArray()
Public Function ToArray As WarrantyOfferedDetailsType()
public:
array<WarrantyOfferedDetailsType^>^ ToArray()
Return Value


WarrantyOfferedDetailsTypeCollection Constructor

WarrantyOfferedDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► WarrantyOfferedDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | WarrantyOfferedDetailsTypeCollection()()()() |
 | WarrantyOfferedDetailsTypeCollection(array<WarrantyOfferedDetailsType>[]()[][]) |
 | WarrantyOfferedDetailsTypeCollection(WarrantyOfferedDetailsTypeCollection) |


WarrantyOfferedDetailsTypeCollection Constructor

WarrantyOfferedDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► WarrantyOfferedDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyOfferedDetailsTypeCollection()
Public Sub New
public:
WarrantyOfferedDetailsTypeCollection()


WarrantyOfferedDetailsTypeCollection Constructor (items)

WarrantyOfferedDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► WarrantyOfferedDetailsTypeCollection(array<WarrantyOfferedDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyOfferedDetailsTypeCollection(
    WarrantyOfferedDetailsType[] items
)
Public Sub New ( _
    items As WarrantyOfferedDetailsType() _
)
public:
WarrantyOfferedDetailsTypeCollection(
    array<WarrantyOfferedDetailsType^>^ items
)
Parameters
items (array< WarrantyOfferedDetailsType >[]()[][])


WarrantyOfferedDetailsTypeCollection Constructor (items)

WarrantyOfferedDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► WarrantyOfferedDetailsTypeCollection(WarrantyOfferedDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyOfferedDetailsTypeCollection(
    WarrantyOfferedDetailsTypeCollection items
)
Public Sub New ( _
    items As WarrantyOfferedDetailsTypeCollection _
)
public:
WarrantyOfferedDetailsTypeCollection(
    WarrantyOfferedDetailsTypeCollection^ items
)
Parameters
items (WarrantyOfferedDetailsTypeCollection)


WarrantyTypeDetailsType Class

WarrantyTypeDetailsType Class
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public class WarrantyTypeDetailsType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Class WarrantyTypeDetailsType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public ref class WarrantyTypeDetailsType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WarrantyTypeDetailsType()()()() |
 | Any |
 | Description |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | WarrantyTypeOption |
Remarks
Inheritance Hierarchy
Object
WarrantyTypeDetailsType


Any Property

Any Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsType ► Any
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection Any { get; set; }
Public Property Any As XmlElementCollection
    Get
    Set
public:
property XmlElementCollection^ Any {
    XmlElementCollection^ get ();
    void set (XmlElementCollection^ value);
}


Description Property

Description Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsType ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


WarrantyTypeDetailsType Constructor

WarrantyTypeDetailsType Constructor
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsType ► WarrantyTypeDetailsType()()()()
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyTypeDetailsType()
Public Sub New
public:
WarrantyTypeDetailsType()


WarrantyTypeOption Property

WarrantyTypeOption Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsType ► WarrantyTypeOption
Declaration Syntax
C# Visual Basic Visual C++
public string WarrantyTypeOption { get; set; }
Public Property WarrantyTypeOption As String
    Get
    Set
public:
property String^ WarrantyTypeOption {
    String^ get ();
    void set (String^ value);
}


WarrantyTypeDetailsTypeCollection Class

WarrantyTypeDetailsTypeCollection Class
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class WarrantyTypeDetailsTypeCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class WarrantyTypeDetailsTypeCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class WarrantyTypeDetailsTypeCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WarrantyTypeDetailsTypeCollection()()()() |
 | WarrantyTypeDetailsTypeCollection(array<WarrantyTypeDetailsType>[]()[][]) |
 | WarrantyTypeDetailsTypeCollection(WarrantyTypeDetailsTypeCollection) |
 | Add(WarrantyTypeDetailsType) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<WarrantyTypeDetailsType>[]()[][]) |
 | AddRange(WarrantyTypeDetailsTypeCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(WarrantyTypeDetailsType) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<WarrantyTypeDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(WarrantyTypeDetailsType) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, WarrantyTypeDetailsType) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(WarrantyTypeDetailsType) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | WarrantyTypeDetailsTypeCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► Add(WarrantyTypeDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    WarrantyTypeDetailsType item
)
Public Function Add ( _
    item As WarrantyTypeDetailsType _
) As Integer
public:
int Add(
    WarrantyTypeDetailsType^ item
)
Parameters
item (WarrantyTypeDetailsType)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<WarrantyTypeDetailsType>[]()[][]) |
 | AddRange(WarrantyTypeDetailsTypeCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► AddRange(array<WarrantyTypeDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    WarrantyTypeDetailsType[] items
)
Public Sub AddRange ( _
    items As WarrantyTypeDetailsType() _
)
public:
void AddRange(
    array<WarrantyTypeDetailsType^>^ items
)
Parameters
items (array< WarrantyTypeDetailsType >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► AddRange(WarrantyTypeDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    WarrantyTypeDetailsTypeCollection items
)
Public Sub AddRange ( _
    items As WarrantyTypeDetailsTypeCollection _
)
public:
void AddRange(
    WarrantyTypeDetailsTypeCollection^ items
)
Parameters
items (WarrantyTypeDetailsTypeCollection)


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► Contains(WarrantyTypeDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    WarrantyTypeDetailsType item
)
Public Function Contains ( _
    item As WarrantyTypeDetailsType _
) As Boolean
public:
bool Contains(
    WarrantyTypeDetailsType^ item
)
Parameters
item (WarrantyTypeDetailsType)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► CopyTo(array<WarrantyTypeDetailsType>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    WarrantyTypeDetailsType[] items,
    int index
)
Public Sub CopyTo ( _
    items As WarrantyTypeDetailsType(), _
    index As Integer _
)
public:
void CopyTo(
    array<WarrantyTypeDetailsType^>^ items,
    int index
)
Parameters
items (array< WarrantyTypeDetailsType >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► IndexOf(WarrantyTypeDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    WarrantyTypeDetailsType item
)
Public Function IndexOf ( _
    item As WarrantyTypeDetailsType _
) As Integer
public:
int IndexOf(
    WarrantyTypeDetailsType^ item
)
Parameters
item (WarrantyTypeDetailsType)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► Insert(Int32, WarrantyTypeDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    WarrantyTypeDetailsType item
)
Public Sub Insert ( _
    index As Integer, _
    item As WarrantyTypeDetailsType _
)
public:
void Insert(
    int index,
    WarrantyTypeDetailsType^ item
)
Parameters
index (Int32)
item (WarrantyTypeDetailsType)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyTypeDetailsType this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As WarrantyTypeDetailsType
    Get
    Set
public:
property WarrantyTypeDetailsType^ default[int index] {
    WarrantyTypeDetailsType^ get (int index);
    void set (int index, WarrantyTypeDetailsType^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyTypeDetailsType ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As WarrantyTypeDetailsType
public:
WarrantyTypeDetailsType^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► Remove(WarrantyTypeDetailsType)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    WarrantyTypeDetailsType item
)
Public Sub Remove ( _
    item As WarrantyTypeDetailsType _
)
public:
void Remove(
    WarrantyTypeDetailsType^ item
)
Parameters
item (WarrantyTypeDetailsType)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyTypeDetailsType[] ToArray()
Public Function ToArray As WarrantyTypeDetailsType()
public:
array<WarrantyTypeDetailsType^>^ ToArray()
Return Value


WarrantyTypeDetailsTypeCollection Constructor

WarrantyTypeDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► WarrantyTypeDetailsTypeCollection()()()()
Members
Icon | Member | Description
 | WarrantyTypeDetailsTypeCollection()()()() |
 | WarrantyTypeDetailsTypeCollection(array<WarrantyTypeDetailsType>[]()[][]) |
 | WarrantyTypeDetailsTypeCollection(WarrantyTypeDetailsTypeCollection) |


WarrantyTypeDetailsTypeCollection Constructor

WarrantyTypeDetailsTypeCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► WarrantyTypeDetailsTypeCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyTypeDetailsTypeCollection()
Public Sub New
public:
WarrantyTypeDetailsTypeCollection()


WarrantyTypeDetailsTypeCollection Constructor (items)

WarrantyTypeDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► WarrantyTypeDetailsTypeCollection(array<WarrantyTypeDetailsType>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyTypeDetailsTypeCollection(
    WarrantyTypeDetailsType[] items
)
Public Sub New ( _
    items As WarrantyTypeDetailsType() _
)
public:
WarrantyTypeDetailsTypeCollection(
    array<WarrantyTypeDetailsType^>^ items
)
Parameters
items (array< WarrantyTypeDetailsType >[]()[][])


WarrantyTypeDetailsTypeCollection Constructor (items)

WarrantyTypeDetailsTypeCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► WarrantyTypeDetailsTypeCollection(WarrantyTypeDetailsTypeCollection)
Declaration Syntax
C# Visual Basic Visual C++
public WarrantyTypeDetailsTypeCollection(
    WarrantyTypeDetailsTypeCollection items
)
Public Sub New ( _
    items As WarrantyTypeDetailsTypeCollection _
)
public:
WarrantyTypeDetailsTypeCollection(
    WarrantyTypeDetailsTypeCollection^ items
)
Parameters
items (WarrantyTypeDetailsTypeCollection)


WirelessCarrierIDCodeType Enumeration

WirelessCarrierIDCodeType Enumeration
Namespaces ► eBay.Service.Core.Soap ► WirelessCarrierIDCodeType
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")]
public enum WirelessCarrierIDCodeType
<SerializableAttribute> _
<GeneratedCodeAttribute("CodeGen05", "1.0.6032.36126")> _
Public Enumeration WirelessCarrierIDCodeType
[SerializableAttribute]
[GeneratedCodeAttribute(L"CodeGen05", L"1.0.6032.36126")]
public enum class WirelessCarrierIDCodeType
Members
Member | Description
Cingular |
TMobile |
Sprint |
Nextel |
Verizon |
CincinnatiBell |
Dobson |
Alltel |
Leap |
USCellular |
Movistar |
Amena |
Vodafone |
ATT |
CustomCode |
Remarks


XmlElementCollection Class

XmlElementCollection Class
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class XmlElementCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class XmlElementCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class XmlElementCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlElementCollection()()()() |
 | XmlElementCollection(array<XmlElement>[]()[][]) |
 | XmlElementCollection(XmlElementCollection) |
 | Add(XmlElement) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<XmlElement>[]()[][]) |
 | AddRange(XmlElementCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(XmlElement) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<XmlElement>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(XmlElement) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, XmlElement) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(XmlElement) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | XmlElementCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► Add(XmlElement)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    XmlElement item
)
Public Function Add ( _
    item As XmlElement _
) As Integer
public:
int Add(
    XmlElement^ item
)
Parameters
item (XmlElement)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<XmlElement>[]()[][]) |
 | AddRange(XmlElementCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► AddRange(XmlElementCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    XmlElementCollection items
)
Public Sub AddRange ( _
    items As XmlElementCollection _
)
public:
void AddRange(
    XmlElementCollection^ items
)
Parameters
items (XmlElementCollection)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► AddRange(array<XmlElement>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    XmlElement[] items
)
Public Sub AddRange ( _
    items As XmlElement() _
)
public:
void AddRange(
    array<XmlElement^>^ items
)
Parameters
items (array< XmlElement >[]()[][])


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► Contains(XmlElement)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    XmlElement item
)
Public Function Contains ( _
    item As XmlElement _
) As Boolean
public:
bool Contains(
    XmlElement^ item
)
Parameters
item (XmlElement)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► CopyTo(array<XmlElement>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    XmlElement[] items,
    int index
)
Public Sub CopyTo ( _
    items As XmlElement(), _
    index As Integer _
)
public:
void CopyTo(
    array<XmlElement^>^ items,
    int index
)
Parameters
items (array< XmlElement >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► IndexOf(XmlElement)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    XmlElement item
)
Public Function IndexOf ( _
    item As XmlElement _
) As Integer
public:
int IndexOf(
    XmlElement^ item
)
Parameters
item (XmlElement)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► Insert(Int32, XmlElement)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    XmlElement item
)
Public Sub Insert ( _
    index As Integer, _
    item As XmlElement _
)
public:
void Insert(
    int index,
    XmlElement^ item
)
Parameters
index (Int32)
item (XmlElement)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public XmlElement this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As XmlElement
    Get
    Set
public:
property XmlElement^ default[int index] {
    XmlElement^ get (int index);
    void set (int index, XmlElement^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public XmlElement ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As XmlElement
public:
XmlElement^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► Remove(XmlElement)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    XmlElement item
)
Public Sub Remove ( _
    item As XmlElement _
)
public:
void Remove(
    XmlElement^ item
)
Parameters
item (XmlElement)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public XmlElement[] ToArray()
Public Function ToArray As XmlElement()
public:
array<XmlElement^>^ ToArray()
Return Value


XmlElementCollection Constructor

XmlElementCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► XmlElementCollection()()()()
Members
Icon | Member | Description
 | XmlElementCollection()()()() |
 | XmlElementCollection(array<XmlElement>[]()[][]) |
 | XmlElementCollection(XmlElementCollection) |


XmlElementCollection Constructor

XmlElementCollection Constructor
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► XmlElementCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection()
Public Sub New
public:
XmlElementCollection()


XmlElementCollection Constructor (items)

XmlElementCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► XmlElementCollection(XmlElementCollection)
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection(
    XmlElementCollection items
)
Public Sub New ( _
    items As XmlElementCollection _
)
public:
XmlElementCollection(
    XmlElementCollection^ items
)
Parameters
items (XmlElementCollection)


XmlElementCollection Constructor (items)

XmlElementCollection Constructor (items)
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► XmlElementCollection(array<XmlElement>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public XmlElementCollection(
    XmlElement[] items
)
Public Sub New ( _
    items As XmlElement() _
)
public:
XmlElementCollection(
    array<XmlElement^>^ items
)
Parameters
items (array< XmlElement >[]()[][])


eBay.Service.EPS Namespace

eBay.Service.EPS Namespace
Namespaces ► eBay.Service.EPS
Declaration Syntax
C# Visual Basic Visual C++
namespace eBay.Service.EPS
Namespace eBay.Service.EPS
namespace eBay.Service.EPS
Types
All Types Classes
Icon | Type | Description
 | eBayPictureService | Class to upload picture with schema xml call. EpsServerUrl: for production, use: http://api.ebay.com/ws/api.dll for sandbox, use: http://api.sandbox.ebay.com/ws/api.dll


eBayPictureService Class

eBayPictureService Class
Namespaces ► eBay.Service.EPS ► eBayPictureService
Class to upload picture with schema xml call. EpsServerUrl: for production, use: http://api.ebay.com/ws/api.dll for sandbox, use: http://api.sandbox.ebay.com/ws/api.dll
Declaration Syntax
C# Visual Basic Visual C++
public class eBayPictureService
Public Class eBayPictureService
public ref class eBayPictureService
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | eBayPictureService(ApiContext) |
 | ApiContext | Gets or sets the ApiContext of the call of type ApiContext.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | UpLoadPictureFile(PhotoDisplayCodeType, String) | Method to upload one picture to eBay picture server
 | UpLoadPictureFiles(PhotoDisplayCodeType, array<String>[]()[][]) | Method to upload list of pictures to eBay picture server
 | UpLoadSiteHostedPicture(UploadSiteHostedPicturesRequestType, String) | Method to upload one picture to eBay picture server, use this method if you want to operate on UploadSiteHostedPicture request/response directly
Inheritance Hierarchy
Object
eBayPictureService


ApiContext Property

ApiContext Property
Namespaces ► eBay.Service.EPS ► eBayPictureService ► ApiContext
Gets or sets the ApiContext of the call of type ApiContext.
Declaration Syntax
C# Visual Basic Visual C++
public ApiContext ApiContext { get; set; }
Public Property ApiContext As ApiContext
    Get
    Set
public:
property ApiContext^ ApiContext {
    ApiContext^ get ();
    void set (ApiContext^ value);
}


eBayPictureService Constructor (apiContext)

eBayPictureService Constructor (apiContext)
Namespaces ► eBay.Service.EPS ► eBayPictureService ► eBayPictureService(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public eBayPictureService(
    ApiContext apiContext
)
Public Sub New ( _
    apiContext As ApiContext _
)
public:
eBayPictureService(
    ApiContext^ apiContext
)
Parameters
apiContext (ApiContext)


UpLoadPictureFile Method (photoDisplay, pictureFile)

UpLoadPictureFile Method (photoDisplay, pictureFile)
Namespaces ► eBay.Service.EPS ► eBayPictureService ► UpLoadPictureFile(PhotoDisplayCodeType, String)
Method to upload one picture to eBay picture server
Declaration Syntax
C# Visual Basic Visual C++
public string UpLoadPictureFile(
    PhotoDisplayCodeType photoDisplay,
    string pictureFile
)
Public Function UpLoadPictureFile ( _
    photoDisplay As PhotoDisplayCodeType, _
    pictureFile As String _
) As String
public:
String^ UpLoadPictureFile(
    PhotoDisplayCodeType photoDisplay,
    String^ pictureFile
)
Parameters
photoDisplay (PhotoDisplayCodeType)
PhotoDisplayCodeType
pictureFile (String)
string
Return Value
string


UpLoadPictureFiles Method (photoDisplay, pictureFileList)

UpLoadPictureFiles Method (photoDisplay, pictureFileList)
Namespaces ► eBay.Service.EPS ► eBayPictureService ► UpLoadPictureFiles(PhotoDisplayCodeType, array<String>[]()[][])
Method to upload list of pictures to eBay picture server
Declaration Syntax
C# Visual Basic Visual C++
public string[] UpLoadPictureFiles(
    PhotoDisplayCodeType photoDisplay,
    string[] pictureFileList
)
Public Function UpLoadPictureFiles ( _
    photoDisplay As PhotoDisplayCodeType, _
    pictureFileList As String() _
) As String()
public:
array<String^>^ UpLoadPictureFiles(
    PhotoDisplayCodeType photoDisplay,
    array<String^>^ pictureFileList
)
Parameters
photoDisplay (PhotoDisplayCodeType)
PhotoDisplayCodeType
pictureFileList (array< String >[]()[][])
picture file list
Return Value
string[]


UpLoadSiteHostedPicture Method (request, fileName)

UpLoadSiteHostedPicture Method (request, fileName)
Namespaces ► eBay.Service.EPS ► eBayPictureService ► UpLoadSiteHostedPicture(UploadSiteHostedPicturesRequestType, String)
Method to upload one picture to eBay picture server, use this method if you want to operate on UploadSiteHostedPicture request/response directly
Declaration Syntax
C# Visual Basic Visual C++
public UploadSiteHostedPicturesResponseType UpLoadSiteHostedPicture(
    UploadSiteHostedPicturesRequestType request,
    string fileName
)
Public Function UpLoadSiteHostedPicture ( _
    request As UploadSiteHostedPicturesRequestType, _
    fileName As String _
) As UploadSiteHostedPicturesResponseType
public:
UploadSiteHostedPicturesResponseType^ UpLoadSiteHostedPicture(
    UploadSiteHostedPicturesRequestType^ request,
    String^ fileName
)
Parameters
request (UploadSiteHostedPicturesRequestType)
UploadSiteHostedPicturesRequestType
fileName (String)
full path of the picture file
Return Value
UploadSiteHostedPicturesResponseType


eBay.Service.SDK.Attribute Namespace

eBay.Service.SDK.Attribute Namespace
Namespaces ► eBay.Service.SDK.Attribute
Declaration Syntax
C# Visual Basic Visual C++
namespace eBay.Service.SDK.Attribute
Namespace eBay.Service.SDK.Attribute
namespace eBay.Service.SDK.Attribute
Types
All Types Classes Interfaces Enumerations
Icon | Type | Description
 | Attribute | Wraper class for SOAP AttributeType.
 | AttributeSet | Wrapper class for AttributeSetType.
 | AttributeSetCollection | Strong typed AttributeSet collection
 | AttributesHelper | The helper class to host attributes related functions.
 | AttributesMaster | Implements interface IAttributesMaster.
 | AttributesXmlDownloader | Implements IAttributesXmlProvider. It gets CS xml data by calling eBay API. This implementation does not support catalog.
 | AttributesXslDownloader | Implements IAttributesXslProvider. It gets XSL data by calling eBay API.
 | AttributeTypes | Enumerates attribute type.
 | ErrorSetCollection | Strong typed IErrorSet collection
 | IAttributeSetCollection | AttributeSet collection.
 | IAttributesMaster | Defines object to assist developers to easily integrate eBay attributes feature.
 | IAttributesXmlProvider | Supplies attributes XML for IAttributesMaster. The implementation of IAttributeXmlProvider should handle AttributeSet objects that has valid AttributeSet.ProductId nd return attributes with pre-filled product information for them.
 | IAttributesXslProvider | Supplies attributes XSL for IAttributesMaster.
 | ICategoryCSProvider | Supplies categoryId to CSId convertion service for IAttributesMaster.
 | IError | Defines attribute error object.
 | IErrorSet | IError collection.
 | IErrorSetCollection | IErrorSet collection.
 | Value | Wrapper class for SOAP ValType.
 | ValueIds | Predefined ValueIds.
 | ValueTypes | Enumerates types of attribute value.


Attribute Class

Attribute Class
Namespaces ► eBay.Service.SDK.Attribute ► Attribute
Wraper class for SOAP AttributeType.
Declaration Syntax
C# Visual Basic Visual C++
public class Attribute : AttributeType
Public Class Attribute _
    Inherits AttributeType
public ref class Attribute : public AttributeType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Attribute()()()() |
 | Attribute(AttributeTypes) |
 | Any | (Inherited from AttributeType.)
 | attributeID | (Inherited from AttributeType.)
 | attributeIDSpecified | (Inherited from AttributeType.)
 | attributeLabel | (Inherited from AttributeType.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Type | Type of the attribute.
 | Value | (Inherited from AttributeType.)
Inheritance Hierarchy
Object
 | AttributeType
 |  | Attribute

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Attribute Constructor

Attribute Constructor
Namespaces ► eBay.Service.SDK.Attribute ► Attribute ► Attribute()()()()
Members
Icon | Member | Description
 | Attribute()()()() |
 | Attribute(AttributeTypes) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Attribute Constructor

Attribute Constructor
Namespaces ► eBay.Service.SDK.Attribute ► Attribute ► Attribute()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Attribute()
Public Sub New
public:
Attribute()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Attribute Constructor (type)

Attribute Constructor (type)
Namespaces ► eBay.Service.SDK.Attribute ► Attribute ► Attribute(AttributeTypes)
Declaration Syntax
C# Visual Basic Visual C++
public Attribute(
    AttributeTypes type
)
Public Sub New ( _
    type As AttributeTypes _
)
public:
Attribute(
    AttributeTypes type
)
Parameters
type (AttributeTypes)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Type Property

Type Property
Namespaces ► eBay.Service.SDK.Attribute ► Attribute ► Type
Type of the attribute.
Declaration Syntax
C# Visual Basic Visual C++
public AttributeTypes Type { get; set; }
Public Property Type As AttributeTypes
    Get
    Set
public:
property AttributeTypes Type {
    AttributeTypes get ();
    void set (AttributeTypes value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributeSet Class

AttributeSet Class
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSet
Wrapper class for AttributeSetType.
Declaration Syntax
C# Visual Basic Visual C++
public class AttributeSet : AttributeSetType
Public Class AttributeSet _
    Inherits AttributeSetType
public ref class AttributeSet : public AttributeSetType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributeSet()()()() | Constructor.
 | Any | (Inherited from AttributeSetType.)
 | Attribute | (Inherited from AttributeSetType.)
 | attributeSetID | (Inherited from AttributeSetType.)
 | attributeSetIDSpecified | (Inherited from AttributeSetType.)
 | attributeSetVersion | (Inherited from AttributeSetType.)
 | CategoryID | Gets/Sets the category ID of the AttributeSet (CS).
 | CategoryOrdinal | Ordinal number of the category.
 | Clone()()()() | Clone the object.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Name | Gets/Sets the name that is associated with the AttributeSet object.
 | ProductFinderID | Gets/Sets the product finder that is associated with the AttributeSet object.
 | ProductID | Gets/Sets the product ID that is used by IAttributesMaster to idenfity the catalog product that is associated with the attributes data.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | AttributeSetType
 |  | AttributeSet

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributeSet Constructor

AttributeSet Constructor
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSet ► AttributeSet()()()()
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSet()
Public Sub New
public:
AttributeSet()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CategoryID Property

CategoryID Property
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSet ► CategoryID
Gets/Sets the category ID of the AttributeSet (CS).
Declaration Syntax
C# Visual Basic Visual C++
public int CategoryID { get; set; }
Public Property CategoryID As Integer
    Get
    Set
public:
property int CategoryID {
    int get ();
    void set (int value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CategoryOrdinal Property

CategoryOrdinal Property
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSet ► CategoryOrdinal
Ordinal number of the category.
Declaration Syntax
C# Visual Basic Visual C++
public int CategoryOrdinal { get; set; }
Public Property CategoryOrdinal As Integer
    Get
    Set
public:
property int CategoryOrdinal {
    int get ();
    void set (int value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Clone Method

Clone Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSet ► Clone()()()()
Clone the object.
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSet Clone()
Public Function Clone As AttributeSet
public:
AttributeSet^ Clone()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Name Property

Name Property
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSet ► Name
Gets/Sets the name that is associated with the AttributeSet object.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ProductFinderID Property

ProductFinderID Property
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSet ► ProductFinderID
Gets/Sets the product finder that is associated with the AttributeSet object.
Declaration Syntax
C# Visual Basic Visual C++
public string ProductFinderID { get; set; }
Public Property ProductFinderID As String
    Get
    Set
public:
property String^ ProductFinderID {
    String^ get ();
    void set (String^ value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ProductID Property

ProductID Property
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSet ► ProductID
Gets/Sets the product ID that is used by IAttributesMaster to idenfity the catalog product that is associated with the attributes data.
Declaration Syntax
C# Visual Basic Visual C++
public string ProductID { get; set; }
Public Property ProductID As String
    Get
    Set
public:
property String^ ProductID {
    String^ get ();
    void set (String^ value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributeSetCollection Class

AttributeSetCollection Class
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection
Strong typed AttributeSet collection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public sealed class AttributeSetCollection : CollectionBase,
    IAttributeSetCollection, IList, ICollection, IEnumerable
<SerializableAttribute> _
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public NotInheritable Class AttributeSetCollection _
    Inherits CollectionBase _
    Implements IAttributeSetCollection, IList, ICollection, IEnumerable
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class AttributeSetCollection sealed : public CollectionBase,
    IAttributeSetCollection, IList, ICollection, IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributeSetCollection()()()() | Default constructor.
 | AttributeSetCollection(array<AttributeSet>[]()[][]) | Initializes a new instance containing the specified array of AttributeSet objects
 | AttributeSetCollection(IAttributeSetCollection) | Initializes a new instance containing the elements of the specified source collection.
 | Add(AttributeSet) | Add element.
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<AttributeSet>[]()[][]) | Add an array of AttributeSet.
 | AddRange(IAttributeSetCollection) | Adds the contents of the specified IAttributeSetCollection to the end of the collection.
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Clone()()()() | Clone the object.
 | Contains(AttributeSet) | Indicates whether a specified object is contained in the list.
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<AttributeSet>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(AttributeSet) | Get index of an element.
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, AttributeSet) | Insert element to list.
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) | Returns item by index.
 | ItemCount()()()() | Returns number of items in the collection.
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(AttributeSet) | Remove element from list.
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | AttributeSetCollection

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method (value)

Add Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► Add(AttributeSet)
Add element.
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    AttributeSet value
)
Public Function Add ( _
    value As AttributeSet _
) As Integer
public:
virtual int Add(
    AttributeSet^ value
) sealed
Parameters
value (AttributeSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AttributeSet>[]()[][]) | Add an array of AttributeSet.
 | AddRange(IAttributeSetCollection) | Adds the contents of the specified IAttributeSetCollection to the end of the collection.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► AddRange(array<AttributeSet>[]()[][])
Add an array of AttributeSet.
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    AttributeSet[] items
)
Public Sub AddRange ( _
    items As AttributeSet() _
)
public:
virtual void AddRange(
    array<AttributeSet^>^ items
) sealed
Parameters
items (array< AttributeSet >[]()[][])

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► AddRange(IAttributeSetCollection)
Adds the contents of the specified IAttributeSetCollection to the end of the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    IAttributeSetCollection items
)
Public Sub AddRange ( _
    items As IAttributeSetCollection _
)
public:
virtual void AddRange(
    IAttributeSetCollection^ items
) sealed
Parameters
items (IAttributeSetCollection)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributeSetCollection Constructor

AttributeSetCollection Constructor
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► AttributeSetCollection()()()()
Members
Icon | Member | Description
 | AttributeSetCollection()()()() | Default constructor.
 | AttributeSetCollection(array<AttributeSet>[]()[][]) | Initializes a new instance containing the specified array of AttributeSet objects
 | AttributeSetCollection(IAttributeSetCollection) | Initializes a new instance containing the elements of the specified source collection.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributeSetCollection Constructor

AttributeSetCollection Constructor
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► AttributeSetCollection()()()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetCollection()
Public Sub New
public:
AttributeSetCollection()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributeSetCollection Constructor (value)

AttributeSetCollection Constructor (value)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► AttributeSetCollection(array<AttributeSet>[]()[][])
Initializes a new instance containing the specified array of AttributeSet objects
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetCollection(
    AttributeSet[] value
)
Public Sub New ( _
    value As AttributeSet() _
)
public:
AttributeSetCollection(
    array<AttributeSet^>^ value
)
Parameters
value (array< AttributeSet >[]()[][])

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributeSetCollection Constructor (value)

AttributeSetCollection Constructor (value)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► AttributeSetCollection(IAttributeSetCollection)
Initializes a new instance containing the elements of the specified source collection.
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetCollection(
    IAttributeSetCollection value
)
Public Sub New ( _
    value As IAttributeSetCollection _
)
public:
AttributeSetCollection(
    IAttributeSetCollection^ value
)
Parameters
value (IAttributeSetCollection)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Clone Method

Clone Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► Clone()()()()
Clone the object.
Declaration Syntax
C# Visual Basic Visual C++
public IAttributeSetCollection Clone()
Public Function Clone As IAttributeSetCollection
public:
virtual IAttributeSetCollection^ Clone() sealed

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method (value)

Contains Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► Contains(AttributeSet)
Indicates whether a specified object is contained in the list.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    AttributeSet value
)
Public Function Contains ( _
    value As AttributeSet _
) As Boolean
public:
virtual bool Contains(
    AttributeSet^ value
) sealed
Parameters
value (AttributeSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► CopyTo(array<AttributeSet>[]()[][], Int32)
Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    AttributeSet[] array,
    int index
)
Public Sub CopyTo ( _
    array As AttributeSet(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<AttributeSet^>^ array,
    int index
) sealed
Parameters
array (array< AttributeSet >[]()[][])
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method (value)

IndexOf Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► IndexOf(AttributeSet)
Get index of an element.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    AttributeSet value
)
Public Function IndexOf ( _
    value As AttributeSet _
) As Integer
public:
virtual int IndexOf(
    AttributeSet^ value
) sealed
Parameters
value (AttributeSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Insert Method (index, value)

Insert Method (index, value)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► Insert(Int32, AttributeSet)
Insert element to list.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    AttributeSet value
)
Public Sub Insert ( _
    index As Integer, _
    value As AttributeSet _
)
public:
virtual void Insert(
    int index,
    AttributeSet^ value
) sealed
Parameters
index (Int32)
value (AttributeSet)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► Item[([( Int32])])
Gets an element at the specified index in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSet this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As AttributeSet
    Get
    Set
public:
virtual property AttributeSet^ default[int index] {
    AttributeSet^ get (int index) sealed;
    void set (int index, AttributeSet^ value) sealed;
}
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► ItemAt(Int32)
Returns item by index.
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSet ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As AttributeSet
public:
virtual AttributeSet^ ItemAt(
    int index
) sealed
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemCount Method

ItemCount Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► ItemCount()()()()
Returns number of items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int ItemCount()
Public Function ItemCount As Integer
public:
virtual int ItemCount() sealed
Return Value
Number of items.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method (value)

Remove Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► Remove(AttributeSet)
Remove element from list.
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    AttributeSet value
)
Public Sub Remove ( _
    value As AttributeSet _
)
public:
virtual void Remove(
    AttributeSet^ value
) sealed
Parameters
value (AttributeSet)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesHelper Class

AttributesHelper Class
Namespaces ► eBay.Service.SDK.Attribute ► AttributesHelper
The helper class to host attributes related functions.
Declaration Syntax
C# Visual Basic Visual C++
[ComVisibleAttribute(false)]
public class AttributesHelper
<ComVisibleAttribute(False)> _
Public Class AttributesHelper
[ComVisibleAttribute(false)]
public ref class AttributesHelper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AttributesHelper()()()() |
 | ConvertFromNameValues(NameValueCollection) | Convert NameValueCollection to IKeyValueCollection.
 | ConvertToNameValues(IKeyValueCollection) | Convert IKeyValueCollection to NameValueCollection.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
AttributesHelper

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesHelper Constructor

AttributesHelper Constructor
Namespaces ► eBay.Service.SDK.Attribute ► AttributesHelper ► AttributesHelper()()()()
Declaration Syntax
C# Visual Basic Visual C++
public AttributesHelper()
Public Sub New
public:
AttributesHelper()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ConvertFromNameValues Method (nvc)

ConvertFromNameValues Method (nvc)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesHelper ► ConvertFromNameValues(NameValueCollection)
Convert NameValueCollection to IKeyValueCollection.
Declaration Syntax
C# Visual Basic Visual C++
public static IKeyValueCollection ConvertFromNameValues(
    NameValueCollection nvc
)
Public Shared Function ConvertFromNameValues ( _
    nvc As NameValueCollection _
) As IKeyValueCollection
public:
static IKeyValueCollection^ ConvertFromNameValues(
    NameValueCollection^ nvc
)
Parameters
nvc (NameValueCollection)
the NameValueCollection object.
Return Value
The generated IKeyValueCollection object.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ConvertToNameValues Method (kvc)

ConvertToNameValues Method (kvc)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesHelper ► ConvertToNameValues(IKeyValueCollection)
Convert IKeyValueCollection to NameValueCollection.
Declaration Syntax
C# Visual Basic Visual C++
public static NameValueCollection ConvertToNameValues(
    IKeyValueCollection kvc
)
Public Shared Function ConvertToNameValues ( _
    kvc As IKeyValueCollection _
) As NameValueCollection
public:
static NameValueCollection^ ConvertToNameValues(
    IKeyValueCollection^ kvc
)
Parameters
kvc (IKeyValueCollection)
The IKeyValueCollection object.
Return Value
The generated NameValueCollection object.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesMaster Class

AttributesMaster Class
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster
Implements interface IAttributesMaster.
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class AttributesMaster : IAttributesMaster
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public Class AttributesMaster _
    Implements IAttributesMaster
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class AttributesMaster : IAttributesMaster
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributesMaster()()()() | Constructor.
 | CategoryCSProvider | The Attributes CategoryCS provider. You only need to set this property if you are going to call RenderHtmlForCategories method.
 | ConvertAttributeSetArray(IAttributeSetCollection) | Convert attribute set array to the format of ItemType for AddItemCall.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItemSpecificAttributeSetsForCategories(Int32Collection) | Returns collection of item specific AttributeSet objects for an array category Ids. Each element of the array contains a VCS Id, if it exists for a given category Id.
 | GetReturnPolicyAttributeSet(IAttributeSetCollection) | Extracts AttributeSet object for Return Policy from site wide attribute sets.
 | GetSiteWideAttributeSetsForCategories(Int32Collection) | Returns collection of Site Wide AttributeSet objects for a given array category Ids. Each element of the array contains a VCS Id, if it exists for a given category Id.
 | GetType()()()() | (Inherited from Object.)
 | getXmlToRenderDoc()()()() | get the Xml to render
 | JoinItemSpecificAndSiteWideAttributeSets(IAttributeSetCollection, IAttributeSetCollection) | Creates an array AttributeSet objects which contains item specific attribute sets and site wide attribute sets with the exception of the attribute set for return policy.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NameValuesToAttributeSets(IKeyValueCollection) | Extract IAttributeSetCollection object from IKeyValueCollection object.
 | RenderHtml(IAttributeSetCollection, IErrorSetCollection) | Render HTML text by specifying list of AttributeSet.
 | RenderHtml(IAttributeSetCollection, DOMDocument30, IErrorSetCollection) | Render HTML text by specifying list of AttributeSet and xsl Document.
 | RenderHtmlForPostback(IKeyValueCollection, IErrorSetCollection) | Render HTML text by raw name-value pairs that you got during HTML submit.
 | ToString()()()() | (Inherited from Object.)
 | Validate(IAttributeSetCollection) | Validate IAttributeSetCollection object against eBay Attributes rules. IErrorSetCollection.Count == 0 means validation succeeded. Otherwise means failure and you have to call the above RenderHtml... methods and pass in the IErrorSetCollection object to re-generate Attributes HTML text that contains all the error messages.
 | XmlProvider | The Attributes XML provider.
 | XslProvider | The Attributes XSL provider.
Inheritance Hierarchy
Object
AttributesMaster

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesMaster Constructor

AttributesMaster Constructor
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► AttributesMaster()()()()
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public AttributesMaster()
Public Sub New
public:
AttributesMaster()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CategoryCSProvider Property

CategoryCSProvider Property
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► CategoryCSProvider
The Attributes CategoryCS provider. You only need to set this property if you are going to call RenderHtmlForCategories method.
Declaration Syntax
C# Visual Basic Visual C++
public ICategoryCSProvider CategoryCSProvider { get; set; }
Public Property CategoryCSProvider As ICategoryCSProvider
    Get
    Set
public:
virtual property ICategoryCSProvider^ CategoryCSProvider {
    ICategoryCSProvider^ get () sealed;
    void set (ICategoryCSProvider^ value) sealed;
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ConvertAttributeSetArray Method (attrSets)

ConvertAttributeSetArray Method (attrSets)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► ConvertAttributeSetArray(IAttributeSetCollection)
Convert attribute set array to the format of ItemType for AddItemCall.
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSetTypeCollection ConvertAttributeSetArray(
    IAttributeSetCollection attrSets
)
Public Function ConvertAttributeSetArray ( _
    attrSets As IAttributeSetCollection _
) As AttributeSetTypeCollection
public:
virtual AttributeSetTypeCollection^ ConvertAttributeSetArray(
    IAttributeSetCollection^ attrSets
) sealed
Parameters
attrSets (IAttributeSetCollection)
The attribute set list generated by AttributeMaster.
Return Value
The converted array that is compatible with ItemType in AddItemCall.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetItemSpecificAttributeSetsForCategories Method (catIds)

GetItemSpecificAttributeSetsForCategories Method (catIds)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► GetItemSpecificAttributeSetsForCategories(Int32Collection)
Returns collection of item specific AttributeSet objects for an array category Ids. Each element of the array contains a VCS Id, if it exists for a given category Id.
Declaration Syntax
C# Visual Basic Visual C++
public IAttributeSetCollection GetItemSpecificAttributeSetsForCategories(
    Int32Collection catIds
)
Public Function GetItemSpecificAttributeSetsForCategories ( _
    catIds As Int32Collection _
) As IAttributeSetCollection
public:
virtual IAttributeSetCollection^ GetItemSpecificAttributeSetsForCategories(
    Int32Collection^ catIds
) sealed
Parameters
catIds (Int32Collection)
int[]
Return Value
Collection of item specific AttributeSet objects

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetReturnPolicyAttributeSet Method (siteWideAttrSets)

GetReturnPolicyAttributeSet Method (siteWideAttrSets)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► GetReturnPolicyAttributeSet(IAttributeSetCollection)
Extracts AttributeSet object for Return Policy from site wide attribute sets.
Declaration Syntax
C# Visual Basic Visual C++
public AttributeSet GetReturnPolicyAttributeSet(
    IAttributeSetCollection siteWideAttrSets
)
Public Function GetReturnPolicyAttributeSet ( _
    siteWideAttrSets As IAttributeSetCollection _
) As AttributeSet
public:
virtual AttributeSet^ GetReturnPolicyAttributeSet(
    IAttributeSetCollection^ siteWideAttrSets
) sealed
Parameters
siteWideAttrSets (IAttributeSetCollection)
IAttributeSetCollection
Return Value
Return Policy AttributeSet object

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetSiteWideAttributeSetsForCategories Method (catIds)

GetSiteWideAttributeSetsForCategories Method (catIds)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► GetSiteWideAttributeSetsForCategories(Int32Collection)
Returns collection of Site Wide AttributeSet objects for a given array category Ids. Each element of the array contains a VCS Id, if it exists for a given category Id.
Declaration Syntax
C# Visual Basic Visual C++
public IAttributeSetCollection GetSiteWideAttributeSetsForCategories(
    Int32Collection catIds
)
Public Function GetSiteWideAttributeSetsForCategories ( _
    catIds As Int32Collection _
) As IAttributeSetCollection
public:
virtual IAttributeSetCollection^ GetSiteWideAttributeSetsForCategories(
    Int32Collection^ catIds
) sealed
Parameters
catIds (Int32Collection)
int[]
Return Value
Collection of site wide AttributeSet objects

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


getXmlToRenderDoc Method

getXmlToRenderDoc Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► getXmlToRenderDoc()()()()
get the Xml to render
Declaration Syntax
C# Visual Basic Visual C++
public DOMDocument30 getXmlToRenderDoc()
Public Function getXmlToRenderDoc As DOMDocument30
public:
DOMDocument30^ getXmlToRenderDoc()
Return Value
DOMDocument30

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


JoinItemSpecificAndSiteWideAttributeSets Method (itemSpecAttrSets, swAttrSets)

JoinItemSpecificAndSiteWideAttributeSets Method (itemSpecAttrSets, swAttrSets)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► JoinItemSpecificAndSiteWideAttributeSets(IAttributeSetCollection, IAttributeSetCollection)
Creates an array AttributeSet objects which contains item specific attribute sets and site wide attribute sets with the exception of the attribute set for return policy.
Declaration Syntax
C# Visual Basic Visual C++
public IAttributeSetCollection JoinItemSpecificAndSiteWideAttributeSets(
    IAttributeSetCollection itemSpecAttrSets,
    IAttributeSetCollection swAttrSets
)
Public Function JoinItemSpecificAndSiteWideAttributeSets ( _
    itemSpecAttrSets As IAttributeSetCollection, _
    swAttrSets As IAttributeSetCollection _
) As IAttributeSetCollection
public:
virtual IAttributeSetCollection^ JoinItemSpecificAndSiteWideAttributeSets(
    IAttributeSetCollection^ itemSpecAttrSets,
    IAttributeSetCollection^ swAttrSets
) sealed
Parameters
itemSpecAttrSets (IAttributeSetCollection)
IAttributeSetCollection
swAttrSets (IAttributeSetCollection)
IAttributeSetCollection
Return Value
Joined collection of of item specific attributes sets and site wide attribute sets, except Return Policy

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


NameValuesToAttributeSets Method (nameValues)

NameValuesToAttributeSets Method (nameValues)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► NameValuesToAttributeSets(IKeyValueCollection)
Extract IAttributeSetCollection object from IKeyValueCollection object.
Declaration Syntax
C# Visual Basic Visual C++
public IAttributeSetCollection NameValuesToAttributeSets(
    IKeyValueCollection nameValues
)
Public Function NameValuesToAttributeSets ( _
    nameValues As IKeyValueCollection _
) As IAttributeSetCollection
public:
virtual IAttributeSetCollection^ NameValuesToAttributeSets(
    IKeyValueCollection^ nameValues
) sealed
Parameters
nameValues (IKeyValueCollection)
The IKeyValueCollection to be converted.
Return Value
The extracted IAttributeSetCollection object.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


RenderHtml Method

RenderHtml Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► RenderHtml()()()()
Members
Icon | Member | Description
 | RenderHtml(IAttributeSetCollection, IErrorSetCollection) | Render HTML text by specifying list of AttributeSet.
 | RenderHtml(IAttributeSetCollection, DOMDocument30, IErrorSetCollection) | Render HTML text by specifying list of AttributeSet and xsl Document.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


RenderHtml Method (attrSets, errorList)

RenderHtml Method (attrSets, errorList)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► RenderHtml(IAttributeSetCollection, IErrorSetCollection)
Render HTML text by specifying list of AttributeSet.
Declaration Syntax
C# Visual Basic Visual C++
public string RenderHtml(
    IAttributeSetCollection attrSets,
    IErrorSetCollection errorList
)
Public Function RenderHtml ( _
    attrSets As IAttributeSetCollection, _
    errorList As IErrorSetCollection _
) As String
public:
virtual String^ RenderHtml(
    IAttributeSetCollection^ attrSets,
    IErrorSetCollection^ errorList
) sealed
Parameters
attrSets (IAttributeSetCollection)
List of AttributeSet objects.
errorList (IErrorSetCollection)
The IErrorSetCollection object returned by Validate method. Set null if you don't have one.
Return Value
The generated HTML text that is encapsulated in HTML table element.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


RenderHtml Method (attrSets, xslDoc, errorList)

RenderHtml Method (attrSets, xslDoc, errorList)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► RenderHtml(IAttributeSetCollection, DOMDocument30, IErrorSetCollection)
Render HTML text by specifying list of AttributeSet and xsl Document.
Declaration Syntax
C# Visual Basic Visual C++
public string RenderHtml(
    IAttributeSetCollection attrSets,
    DOMDocument30 xslDoc,
    IErrorSetCollection errorList
)
Public Function RenderHtml ( _
    attrSets As IAttributeSetCollection, _
    xslDoc As DOMDocument30, _
    errorList As IErrorSetCollection _
) As String
public:
virtual String^ RenderHtml(
    IAttributeSetCollection^ attrSets,
    DOMDocument30^ xslDoc,
    IErrorSetCollection^ errorList
) sealed
Parameters
attrSets (IAttributeSetCollection)
List of AttributeSet objects.
xslDoc (DOMDocument30)
Xsl Document
errorList (IErrorSetCollection)
The IErrorSetCollection object returned by Validate method. Set null if you don't have one.
Return Value
The generated HTML text that is encapsulated in HTML table element.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


RenderHtmlForPostback Method (nameValues, errorList)

RenderHtmlForPostback Method (nameValues, errorList)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► RenderHtmlForPostback(IKeyValueCollection, IErrorSetCollection)
Render HTML text by raw name-value pairs that you got during HTML submit.
Declaration Syntax
C# Visual Basic Visual C++
public string RenderHtmlForPostback(
    IKeyValueCollection nameValues,
    IErrorSetCollection errorList
)
Public Function RenderHtmlForPostback ( _
    nameValues As IKeyValueCollection, _
    errorList As IErrorSetCollection _
) As String
public:
virtual String^ RenderHtmlForPostback(
    IKeyValueCollection^ nameValues,
    IErrorSetCollection^ errorList
) sealed
Parameters
nameValues (IKeyValueCollection)
List of name-value pairs from submit of attributes HTML form generated by all these RenderHtml methods.
errorList (IErrorSetCollection)
The IErrorSetCollection object returned by Validate method. Set null if you don't have one.
Return Value
The generated HTML text that is encapsulated in HTML table element.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Validate Method (attrSets)

Validate Method (attrSets)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► Validate(IAttributeSetCollection)
Validate IAttributeSetCollection object against eBay Attributes rules. IErrorSetCollection.Count == 0 means validation succeeded. Otherwise means failure and you have to call the above RenderHtml... methods and pass in the IErrorSetCollection object to re-generate Attributes HTML text that contains all the error messages.
Declaration Syntax
C# Visual Basic Visual C++
public IErrorSetCollection Validate(
    IAttributeSetCollection attrSets
)
Public Function Validate ( _
    attrSets As IAttributeSetCollection _
) As IErrorSetCollection
public:
virtual IErrorSetCollection^ Validate(
    IAttributeSetCollection^ attrSets
) sealed
Parameters
attrSets (IAttributeSetCollection)
The IAttributeSetCollection object which you want to validate.
Return Value
The returned IAttributeSetCollection object. IAttributeSetCollection == 0 means validation succeeded.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


XmlProvider Property

XmlProvider Property
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► XmlProvider
The Attributes XML provider.
Declaration Syntax
C# Visual Basic Visual C++
public IAttributesXmlProvider XmlProvider { get; set; }
Public Property XmlProvider As IAttributesXmlProvider
    Get
    Set
public:
virtual property IAttributesXmlProvider^ XmlProvider {
    IAttributesXmlProvider^ get () sealed;
    void set (IAttributesXmlProvider^ value) sealed;
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


XslProvider Property

XslProvider Property
Namespaces ► eBay.Service.SDK.Attribute ► AttributesMaster ► XslProvider
The Attributes XSL provider.
Declaration Syntax
C# Visual Basic Visual C++
public IAttributesXslProvider XslProvider { get; set; }
Public Property XslProvider As IAttributesXslProvider
    Get
    Set
public:
virtual property IAttributesXslProvider^ XslProvider {
    IAttributesXslProvider^ get () sealed;
    void set (IAttributesXslProvider^ value) sealed;
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesXmlDownloader Class

AttributesXmlDownloader Class
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader
Implements IAttributesXmlProvider. It gets CS xml data by calling eBay API. This implementation does not support catalog.
Declaration Syntax
C# Visual Basic Visual C++
public class AttributesXmlDownloader : IAttributesXmlProvider
Public Class AttributesXmlDownloader _
    Implements IAttributesXmlProvider
public ref class AttributesXmlDownloader : IAttributesXmlProvider
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttributesXmlDownloader()()()() | Constructor.
 | AttributesXmlDownloader(ApiContext) | Constructor.
 | DownloadXml()()()() | Get CS xml data by calling eBay API.
 | DownloadXml(ApiContext) | Get CS xml data by calling eBay API.
 | Equals(Object) | (Inherited from Object.)
 | ExtractCSFromXml(XmlDocument, Int32, Boolean) | Extract CS xml by CSId from combined CS Xml document.
 | ExtractMultiCSFromXml(XmlDocument, Int32Collection, Boolean) | Extract CS xml by list of CSId from combined CS Xml document.
 | Finalize()()()() | (Inherited from Object.)
 | GetCSIDs()()()() | Get all the CS IDs.
 | GetCSXmlText(AttributeSet) | Get CharacteristicSet(CS) xml. This implementation does not support catalog, i.e., csInfo.ProductId will be ignored.
 | GetDefaultStyleXsl()()()() | Get the default Style XSL.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetMultipleCSXml(IAttributeSetCollection) | Get xml that contains multiple CSs. Only set AttributeSet.CSId and AttributeSet.ProductId (optional).
 | GetMultipleCSXmlText(IAttributeSetCollection) | Get xml that contains multiple CSs. Only set AttributeSet.CSId and AttributeSet.ProductId (optional).
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SELECT_ALL_CS | XPath of all CharacteristicsSet nodes.
 | SELECT_AS | XPath of AttributeSet node.
 | SELECT_CS | XPath of CharacteristicsSet node.
 | SELECT_GLOBALSETTINGS | XPath of GlobalSettings node.
 | SELECT_OVERRIDES | XPath of overrides node.
 | SELECT_VERSION | XPath of version node.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
AttributesXmlDownloader

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesXmlDownloader Constructor

AttributesXmlDownloader Constructor
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► AttributesXmlDownloader()()()()
Members
Icon | Member | Description
 | AttributesXmlDownloader()()()() | Constructor.
 | AttributesXmlDownloader(ApiContext) | Constructor.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesXmlDownloader Constructor

AttributesXmlDownloader Constructor
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► AttributesXmlDownloader()()()()
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public AttributesXmlDownloader()
Public Sub New
public:
AttributesXmlDownloader()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesXmlDownloader Constructor (context)

AttributesXmlDownloader Constructor (context)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► AttributesXmlDownloader(ApiContext)
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public AttributesXmlDownloader(
    ApiContext context
)
Public Sub New ( _
    context As ApiContext _
)
public:
AttributesXmlDownloader(
    ApiContext^ context
)
Parameters
context (ApiContext)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXml Method

DownloadXml Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► DownloadXml()()()()
Members
Icon | Member | Description
 | DownloadXml()()()() | Get CS xml data by calling eBay API.
 | DownloadXml(ApiContext) | Get CS xml data by calling eBay API.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXml Method

DownloadXml Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► DownloadXml()()()()
Get CS xml data by calling eBay API.
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument DownloadXml()
Public Function DownloadXml As XmlDocument
public:
virtual XmlDocument^ DownloadXml() sealed

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXml Method (asn)

DownloadXml Method (asn)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► DownloadXml(ApiContext)
Get CS xml data by calling eBay API.
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument DownloadXml(
    ApiContext asn
)
Public Function DownloadXml ( _
    asn As ApiContext _
) As XmlDocument
public:
virtual XmlDocument^ DownloadXml(
    ApiContext^ asn
) sealed
Parameters
asn (ApiContext)
The ApiContext object to make API call.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ExtractCSFromXml Method (allCSXml, csId, copyOverrides)

ExtractCSFromXml Method (allCSXml, csId, copyOverrides)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► ExtractCSFromXml(XmlDocument, Int32, Boolean)
Extract CS xml by CSId from combined CS Xml document.
Declaration Syntax
C# Visual Basic Visual C++
public static XmlDocument ExtractCSFromXml(
    XmlDocument allCSXml,
    int csId,
    bool copyOverrides
)
Public Shared Function ExtractCSFromXml ( _
    allCSXml As XmlDocument, _
    csId As Integer, _
    copyOverrides As Boolean _
) As XmlDocument
public:
static XmlDocument^ ExtractCSFromXml(
    XmlDocument^ allCSXml,
    int csId,
    bool copyOverrides
)
Parameters
allCSXml (XmlDocument)
The CS Xml document that contains multiple CS Xml.
csId (Int32)
Id of the CS that you want to get Xml for. Set to null to return xml for all CS.
copyOverrides (Boolean)
Copy Overrides node or not..
Return Value
The new generated Xml document that contains the specified CS Xml.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ExtractMultiCSFromXml Method (allCSXml, csIds, copyOverrides)

ExtractMultiCSFromXml Method (allCSXml, csIds, copyOverrides)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► ExtractMultiCSFromXml(XmlDocument, Int32Collection, Boolean)
Extract CS xml by list of CSId from combined CS Xml document.
Declaration Syntax
C# Visual Basic Visual C++
public static XmlDocument ExtractMultiCSFromXml(
    XmlDocument allCSXml,
    Int32Collection csIds,
    bool copyOverrides
)
Public Shared Function ExtractMultiCSFromXml ( _
    allCSXml As XmlDocument, _
    csIds As Int32Collection, _
    copyOverrides As Boolean _
) As XmlDocument
public:
static XmlDocument^ ExtractMultiCSFromXml(
    XmlDocument^ allCSXml,
    Int32Collection^ csIds,
    bool copyOverrides
)
Parameters
allCSXml (XmlDocument)
The CS Xml document that contains multiple CS Xml.
csIds (Int32Collection)
List of CSIDs that you want to get Xml for. Set to null to return xml for all CS.
copyOverrides (Boolean)
Copy Overrides node or not..
Return Value
The new generated Xml document that contains the specified CS Xml.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetCSIDs Method

GetCSIDs Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► GetCSIDs()()()()
Get all the CS IDs.
Declaration Syntax
C# Visual Basic Visual C++
public int[] GetCSIDs()
Public Function GetCSIDs As Integer()
public:
virtual array<int>^ GetCSIDs() sealed
Return Value
Array of CSIDs.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetCSXmlText Method (csInfo)

GetCSXmlText Method (csInfo)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► GetCSXmlText(AttributeSet)
Get CharacteristicSet(CS) xml. This implementation does not support catalog, i.e., csInfo.ProductId will be ignored.
Declaration Syntax
C# Visual Basic Visual C++
public string GetCSXmlText(
    AttributeSet csInfo
)
Public Function GetCSXmlText ( _
    csInfo As AttributeSet _
) As String
public:
virtual String^ GetCSXmlText(
    AttributeSet^ csInfo
) sealed
Parameters
csInfo (AttributeSet)
Identification information about the CS for which you want to get CSXml. You only need to set CS.CSId and, optionally, you can set CS.ProductId if you want to get the CSXml that is associated with specific product information. Set CS.CSId to 0 to get entire CharacteristicSet xml for all CSs.
Return Value
The xml text of the CS.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetDefaultStyleXsl Method

GetDefaultStyleXsl Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► GetDefaultStyleXsl()()()()
Get the default Style XSL.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetDefaultStyleXsl()
Public Shared Function GetDefaultStyleXsl As String
public:
static String^ GetDefaultStyleXsl()
Return Value
The default Style Xsl text.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetMultipleCSXml Method (asList)

GetMultipleCSXml Method (asList)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► GetMultipleCSXml(IAttributeSetCollection)
Get xml that contains multiple CSs. Only set AttributeSet.CSId and AttributeSet.ProductId (optional).
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument GetMultipleCSXml(
    IAttributeSetCollection asList
)
Public Function GetMultipleCSXml ( _
    asList As IAttributeSetCollection _
) As XmlDocument
public:
virtual XmlDocument^ GetMultipleCSXml(
    IAttributeSetCollection^ asList
) sealed
Parameters
asList (IAttributeSetCollection)
List of AttributeSet objects for which you want to get CSXml.
Return Value
The CS xml for specified CSs.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetMultipleCSXmlText Method (asList)

GetMultipleCSXmlText Method (asList)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► GetMultipleCSXmlText(IAttributeSetCollection)
Get xml that contains multiple CSs. Only set AttributeSet.CSId and AttributeSet.ProductId (optional).
Declaration Syntax
C# Visual Basic Visual C++
public string GetMultipleCSXmlText(
    IAttributeSetCollection asList
)
Public Function GetMultipleCSXmlText ( _
    asList As IAttributeSetCollection _
) As String
public:
virtual String^ GetMultipleCSXmlText(
    IAttributeSetCollection^ asList
) sealed
Parameters
asList (IAttributeSetCollection)
List of AttributeSet objects for which you want to get CSXml.
Return Value
The CS xml text for specified CSs.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SELECT_ALL_CS Field

SELECT_ALL_CS Field
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► SELECT_ALL_CS
XPath of all CharacteristicsSet nodes.
Declaration Syntax
C# Visual Basic Visual C++
public const string SELECT_ALL_CS
Public Const SELECT_ALL_CS As String
public:
literal String^ SELECT_ALL_CS

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SELECT_AS Field

SELECT_AS Field
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► SELECT_AS
XPath of AttributeSet node.
Declaration Syntax
C# Visual Basic Visual C++
public const string SELECT_AS
Public Const SELECT_AS As String
public:
literal String^ SELECT_AS

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SELECT_CS Field

SELECT_CS Field
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► SELECT_CS
XPath of CharacteristicsSet node.
Declaration Syntax
C# Visual Basic Visual C++
public const string SELECT_CS
Public Const SELECT_CS As String
public:
literal String^ SELECT_CS

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SELECT_GLOBALSETTINGS Field

SELECT_GLOBALSETTINGS Field
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► SELECT_GLOBALSETTINGS
XPath of GlobalSettings node.
Declaration Syntax
C# Visual Basic Visual C++
public const string SELECT_GLOBALSETTINGS
Public Const SELECT_GLOBALSETTINGS As String
public:
literal String^ SELECT_GLOBALSETTINGS

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SELECT_OVERRIDES Field

SELECT_OVERRIDES Field
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► SELECT_OVERRIDES
XPath of overrides node.
Declaration Syntax
C# Visual Basic Visual C++
public const string SELECT_OVERRIDES
Public Const SELECT_OVERRIDES As String
public:
literal String^ SELECT_OVERRIDES

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SELECT_VERSION Field

SELECT_VERSION Field
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXmlDownloader ► SELECT_VERSION
XPath of version node.
Declaration Syntax
C# Visual Basic Visual C++
public const string SELECT_VERSION
Public Const SELECT_VERSION As String
public:
literal String^ SELECT_VERSION

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesXslDownloader Class

AttributesXslDownloader Class
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXslDownloader
Implements IAttributesXslProvider. It gets XSL data by calling eBay API.
Declaration Syntax
C# Visual Basic Visual C++
public class AttributesXslDownloader : IAttributesXslProvider
Public Class AttributesXslDownloader _
    Implements IAttributesXslProvider
public ref class AttributesXslDownloader : IAttributesXslProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AttributesXslDownloader()()()() | Constructor.
 | AttributesXslDownloader(ApiContext) | Constructor.
 | DownloadXsl()()()() | Download XSL text from eBay by calling eBay API.
 | DownloadXsl(ApiContext) | Download XSL text from eBay by calling eBay API.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GetXslFileName()()()() | The XSL file name.
 | GetXslText()()()() | The XSL text.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
AttributesXslDownloader

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesXslDownloader Constructor

AttributesXslDownloader Constructor
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXslDownloader ► AttributesXslDownloader()()()()
Members
Icon | Member | Description
 | AttributesXslDownloader()()()() | Constructor.
 | AttributesXslDownloader(ApiContext) | Constructor.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesXslDownloader Constructor

AttributesXslDownloader Constructor
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXslDownloader ► AttributesXslDownloader()()()()
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public AttributesXslDownloader()
Public Sub New
public:
AttributesXslDownloader()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributesXslDownloader Constructor (apiContext)

AttributesXslDownloader Constructor (apiContext)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXslDownloader ► AttributesXslDownloader(ApiContext)
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public AttributesXslDownloader(
    ApiContext apiContext
)
Public Sub New ( _
    apiContext As ApiContext _
)
public:
AttributesXslDownloader(
    ApiContext^ apiContext
)
Parameters
apiContext (ApiContext)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXsl Method

DownloadXsl Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXslDownloader ► DownloadXsl()()()()
Members
Icon | Member | Description
 | DownloadXsl()()()() | Download XSL text from eBay by calling eBay API.
 | DownloadXsl(ApiContext) | Download XSL text from eBay by calling eBay API.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXsl Method

DownloadXsl Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXslDownloader ► DownloadXsl()()()()
Download XSL text from eBay by calling eBay API.
Declaration Syntax
C# Visual Basic Visual C++
public string DownloadXsl()
Public Function DownloadXsl As String
public:
virtual String^ DownloadXsl() sealed

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXsl Method (asn)

DownloadXsl Method (asn)
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXslDownloader ► DownloadXsl(ApiContext)
Download XSL text from eBay by calling eBay API.
Declaration Syntax
C# Visual Basic Visual C++
public string DownloadXsl(
    ApiContext asn
)
Public Function DownloadXsl ( _
    asn As ApiContext _
) As String
public:
virtual String^ DownloadXsl(
    ApiContext^ asn
) sealed
Parameters
asn (ApiContext)
The ApiContext object to make API call.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetXslFileName Method

GetXslFileName Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXslDownloader ► GetXslFileName()()()()
The XSL file name.
Declaration Syntax
C# Visual Basic Visual C++
public string GetXslFileName()
Public Function GetXslFileName As String
public:
virtual String^ GetXslFileName() sealed

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetXslText Method

GetXslText Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributesXslDownloader ► GetXslText()()()()
The XSL text.
Declaration Syntax
C# Visual Basic Visual C++
public string GetXslText()
Public Function GetXslText As String
public:
virtual String^ GetXslText() sealed

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttributeTypes Enumeration

AttributeTypes Enumeration
Namespaces ► eBay.Service.SDK.Attribute ► AttributeTypes
Enumerates attribute type.
Declaration Syntax
C# Visual Basic Visual C++
public enum AttributeTypes
Public Enumeration AttributeTypes
public enum class AttributeTypes
Members
Member | Description
ATTR_ID |
ATTR_IDS |
ATTR_TEXT |
ATTR_TEXT_DATE |
ATTR_TEXT_DATE_ONE |
ATTR_DATE |
ATTR_DATE_D |
ATTR_DATE_M |
ATTR_DATE_Y |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ErrorSetCollection Class

ErrorSetCollection Class
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection
Strong typed IErrorSet collection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public sealed class ErrorSetCollection : CollectionBase,
    IErrorSetCollection, IList, ICollection, IEnumerable
<SerializableAttribute> _
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public NotInheritable Class ErrorSetCollection _
    Inherits CollectionBase _
    Implements IErrorSetCollection, IList, ICollection, IEnumerable
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class ErrorSetCollection sealed : public CollectionBase,
    IErrorSetCollection, IList, ICollection, IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorSetCollection()()()() | Default constructor.
 | ErrorSetCollection(array<IErrorSet>[]()[][]) | Initializes a new instance containing the specified array of IErrorSet objects
 | ErrorSetCollection(IErrorSetCollection) | Initializes a new instance containing the elements of the specified source collection.
 | Add(IErrorSet) | Add element.
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<IErrorSet>[]()[][]) | Add an array of IErrorSet.
 | AddRange(IErrorSetCollection) | Adds the contents of the specified IErrorSetCollection to the end of the collection.
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(IErrorSet) | Indicates whether a specified object is contained in the list.
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<IErrorSet>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(IErrorSet) | Get index of an element.
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, IErrorSet) | Insert element to list.
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) | Returns item by index.
 | ItemCount()()()() | Returns number of items in the collection.
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(IErrorSet) | Remove element from list.
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ErrorSetCollection

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method (value)

Add Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► Add(IErrorSet)
Add element.
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    IErrorSet value
)
Public Function Add ( _
    value As IErrorSet _
) As Integer
public:
virtual int Add(
    IErrorSet^ value
) sealed
Parameters
value (IErrorSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<IErrorSet>[]()[][]) | Add an array of IErrorSet.
 | AddRange(IErrorSetCollection) | Adds the contents of the specified IErrorSetCollection to the end of the collection.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► AddRange(array<IErrorSet>[]()[][])
Add an array of IErrorSet.
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    IErrorSet[] items
)
Public Sub AddRange ( _
    items As IErrorSet() _
)
public:
virtual void AddRange(
    array<IErrorSet^>^ items
) sealed
Parameters
items (array< IErrorSet >[]()[][])

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► AddRange(IErrorSetCollection)
Adds the contents of the specified IErrorSetCollection to the end of the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    IErrorSetCollection items
)
Public Sub AddRange ( _
    items As IErrorSetCollection _
)
public:
virtual void AddRange(
    IErrorSetCollection^ items
) sealed
Parameters
items (IErrorSetCollection)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method (value)

Contains Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► Contains(IErrorSet)
Indicates whether a specified object is contained in the list.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    IErrorSet value
)
Public Function Contains ( _
    value As IErrorSet _
) As Boolean
public:
virtual bool Contains(
    IErrorSet^ value
) sealed
Parameters
value (IErrorSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► CopyTo(array<IErrorSet>[]()[][], Int32)
Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    IErrorSet[] array,
    int index
)
Public Sub CopyTo ( _
    array As IErrorSet(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<IErrorSet^>^ array,
    int index
) sealed
Parameters
array (array< IErrorSet >[]()[][])
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ErrorSetCollection Constructor

ErrorSetCollection Constructor
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► ErrorSetCollection()()()()
Members
Icon | Member | Description
 | ErrorSetCollection()()()() | Default constructor.
 | ErrorSetCollection(array<IErrorSet>[]()[][]) | Initializes a new instance containing the specified array of IErrorSet objects
 | ErrorSetCollection(IErrorSetCollection) | Initializes a new instance containing the elements of the specified source collection.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ErrorSetCollection Constructor

ErrorSetCollection Constructor
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► ErrorSetCollection()()()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorSetCollection()
Public Sub New
public:
ErrorSetCollection()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ErrorSetCollection Constructor (value)

ErrorSetCollection Constructor (value)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► ErrorSetCollection(array<IErrorSet>[]()[][])
Initializes a new instance containing the specified array of IErrorSet objects
Declaration Syntax
C# Visual Basic Visual C++
public ErrorSetCollection(
    IErrorSet[] value
)
Public Sub New ( _
    value As IErrorSet() _
)
public:
ErrorSetCollection(
    array<IErrorSet^>^ value
)
Parameters
value (array< IErrorSet >[]()[][])

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ErrorSetCollection Constructor (value)

ErrorSetCollection Constructor (value)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► ErrorSetCollection(IErrorSetCollection)
Initializes a new instance containing the elements of the specified source collection.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorSetCollection(
    IErrorSetCollection value
)
Public Sub New ( _
    value As IErrorSetCollection _
)
public:
ErrorSetCollection(
    IErrorSetCollection^ value
)
Parameters
value (IErrorSetCollection)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method (value)

IndexOf Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► IndexOf(IErrorSet)
Get index of an element.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    IErrorSet value
)
Public Function IndexOf ( _
    value As IErrorSet _
) As Integer
public:
virtual int IndexOf(
    IErrorSet^ value
) sealed
Parameters
value (IErrorSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Insert Method (index, value)

Insert Method (index, value)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► Insert(Int32, IErrorSet)
Insert element to list.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    IErrorSet value
)
Public Sub Insert ( _
    index As Integer, _
    value As IErrorSet _
)
public:
virtual void Insert(
    int index,
    IErrorSet^ value
) sealed
Parameters
index (Int32)
value (IErrorSet)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► Item[([( Int32])])
Gets an element at the specified index in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IErrorSet this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As IErrorSet
    Get
    Set
public:
virtual property IErrorSet^ default[int index] {
    IErrorSet^ get (int index) sealed;
    void set (int index, IErrorSet^ value) sealed;
}
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► ItemAt(Int32)
Returns item by index.
Declaration Syntax
C# Visual Basic Visual C++
public IErrorSet ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As IErrorSet
public:
virtual IErrorSet^ ItemAt(
    int index
) sealed
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemCount Method

ItemCount Method
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► ItemCount()()()()
Returns number of items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int ItemCount()
Public Function ItemCount As Integer
public:
virtual int ItemCount() sealed
Return Value
Number of items.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method (value)

Remove Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► Remove(IErrorSet)
Remove element from list.
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    IErrorSet value
)
Public Sub Remove ( _
    value As IErrorSet _
)
public:
virtual void Remove(
    IErrorSet^ value
) sealed
Parameters
value (IErrorSet)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IAttributeSetCollection Interface

IAttributeSetCollection Interface
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection
AttributeSet collection.
Declaration Syntax
C# Visual Basic Visual C++
public interface IAttributeSetCollection : IList,
    ICollection, IEnumerable
Public Interface IAttributeSetCollection _
    Inherits IList, ICollection, IEnumerable
public interface class IAttributeSetCollection : IList,
    ICollection, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(AttributeSet) | Add element.
 | Add(Object) | (Inherited from IList.)
 | AddRange(array<AttributeSet>[]()[][]) | Add an array of AttributeSet.
 | AddRange(IAttributeSetCollection) | Adds the contents of the specified IAttributeSetCollection to the end of the collection.
 | Clear()()()() | (Inherited from IList.)
 | Clone()()()() | Clone the object.
 | Contains(AttributeSet) | Indicates whether a specified object is contained in the list.
 | Contains(Object) | (Inherited from IList.)
 | CopyTo(array<AttributeSet>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | CopyTo(Array, Int32) | (Inherited from ICollection.)
 | Count | (Inherited from ICollection.)
 | GetEnumerator()()()() | (Inherited from IEnumerable.)
 | IndexOf(AttributeSet) | Get index of an element.
 | IndexOf(Object) | (Inherited from IList.)
 | Insert(Int32, AttributeSet) | Insert element to list.
 | Insert(Int32, Object) | (Inherited from IList.)
 | IsFixedSize | (Inherited from IList.)
 | IsReadOnly | (Inherited from IList.)
 | IsSynchronized | (Inherited from ICollection.)
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | Item[([( Int32])]) | (Inherited from IList.)
 | ItemAt(Int32) | Returns item by index.
 | ItemCount()()()() | Returns number of items in the collection.
 | Remove(AttributeSet) | Remove element from list.
 | Remove(Object) | (Inherited from IList.)
 | RemoveAt(Int32) | (Inherited from IList.)
 | SyncRoot | (Inherited from ICollection.)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method (value)

Add Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► Add(AttributeSet)
Add element.
Declaration Syntax
C# Visual Basic Visual C++
int Add(
    AttributeSet value
)
Function Add ( _
    value As AttributeSet _
) As Integer
int Add(
    AttributeSet^ value
)
Parameters
value (AttributeSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<AttributeSet>[]()[][]) | Add an array of AttributeSet.
 | AddRange(IAttributeSetCollection) | Adds the contents of the specified IAttributeSetCollection to the end of the collection.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► AddRange(array<AttributeSet>[]()[][])
Add an array of AttributeSet.
Declaration Syntax
C# Visual Basic Visual C++
void AddRange(
    AttributeSet[] items
)
Sub AddRange ( _
    items As AttributeSet() _
)
void AddRange(
    array<AttributeSet^>^ items
)
Parameters
items (array< AttributeSet >[]()[][])

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► AddRange(IAttributeSetCollection)
Adds the contents of the specified IAttributeSetCollection to the end of the collection.
Declaration Syntax
C# Visual Basic Visual C++
void AddRange(
    IAttributeSetCollection items
)
Sub AddRange ( _
    items As IAttributeSetCollection _
)
void AddRange(
    IAttributeSetCollection^ items
)
Parameters
items (IAttributeSetCollection)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Clone Method

Clone Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► Clone()()()()
Clone the object.
Declaration Syntax
C# Visual Basic Visual C++
IAttributeSetCollection Clone()
Function Clone As IAttributeSetCollection
IAttributeSetCollection^ Clone()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method (value)

Contains Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► Contains(AttributeSet)
Indicates whether a specified object is contained in the list.
Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    AttributeSet value
)
Function Contains ( _
    value As AttributeSet _
) As Boolean
bool Contains(
    AttributeSet^ value
)
Parameters
value (AttributeSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► CopyTo(array<AttributeSet>[]()[][], Int32)
Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
void CopyTo(
    AttributeSet[] array,
    int index
)
Sub CopyTo ( _
    array As AttributeSet(), _
    index As Integer _
)
void CopyTo(
    array<AttributeSet^>^ array,
    int index
)
Parameters
array (array< AttributeSet >[]()[][])
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method (value)

IndexOf Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► IndexOf(AttributeSet)
Get index of an element.
Declaration Syntax
C# Visual Basic Visual C++
int IndexOf(
    AttributeSet value
)
Function IndexOf ( _
    value As AttributeSet _
) As Integer
int IndexOf(
    AttributeSet^ value
)
Parameters
value (AttributeSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Insert Method (index, value)

Insert Method (index, value)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► Insert(Int32, AttributeSet)
Insert element to list.
Declaration Syntax
C# Visual Basic Visual C++
void Insert(
    int index,
    AttributeSet value
)
Sub Insert ( _
    index As Integer, _
    value As AttributeSet _
)
void Insert(
    int index,
    AttributeSet^ value
)
Parameters
index (Int32)
value (AttributeSet)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► Item[([( Int32])])
Gets an element at the specified index in the collection.
Declaration Syntax
C# Visual Basic Visual C++
AttributeSet this[
    int index
] { get; set; }
Default Property Item ( _
    index As Integer _
) As AttributeSet
    Get
    Set
property AttributeSet^ default[int index] {
    AttributeSet^ get (int index);
    void set (int index, AttributeSet^ value);
}
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► ItemAt(Int32)
Returns item by index.
Declaration Syntax
C# Visual Basic Visual C++
AttributeSet ItemAt(
    int index
)
Function ItemAt ( _
    index As Integer _
) As AttributeSet
AttributeSet^ ItemAt(
    int index
)
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemCount Method

ItemCount Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► ItemCount()()()()
Returns number of items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
int ItemCount()
Function ItemCount As Integer
int ItemCount()
Return Value
Number of items.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method (value)

Remove Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► Remove(AttributeSet)
Remove element from list.
Declaration Syntax
C# Visual Basic Visual C++
void Remove(
    AttributeSet value
)
Sub Remove ( _
    value As AttributeSet _
)
void Remove(
    AttributeSet^ value
)
Parameters
value (AttributeSet)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IAttributesMaster Interface

IAttributesMaster Interface
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster
Defines object to assist developers to easily integrate eBay attributes feature.
Declaration Syntax
C# Visual Basic Visual C++
public interface IAttributesMaster
Public Interface IAttributesMaster
public interface class IAttributesMaster
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CategoryCSProvider | The Attributes CategoryCS provider. You only need to set this property if you are going to call RenderHtmlForCategories method.
 | ConvertAttributeSetArray(IAttributeSetCollection) | Convert attribute set array to the format of ItemType for AddItemCall.
 | GetItemSpecificAttributeSetsForCategories(Int32Collection) | Returns collection of item specific AttributeSet objects for an array category Ids. Each element of the array contains a VCS Id, if it exists for a given category Id.
 | GetReturnPolicyAttributeSet(IAttributeSetCollection) | Extracts AttributeSet object for Return Policy from site wide attribute sets.
 | GetSiteWideAttributeSetsForCategories(Int32Collection) | Returns collection of Site Wide AttributeSet objects for a given array category Ids. Each element of the array contains a VCS Id, if it exists for a given category Id.
 | JoinItemSpecificAndSiteWideAttributeSets(IAttributeSetCollection, IAttributeSetCollection) | Creates an array of AttributeSet objects which contains item specific attribute sets and site wide attribute sets with the exception of the attribute set for return policy.
 | NameValuesToAttributeSets(IKeyValueCollection) | Extract IAttributeSetCollection object from IKeyValueCollection object.
 | RenderHtml(IAttributeSetCollection, IErrorSetCollection) | Render HTML text by specifying list of AttributeSet.
 | RenderHtml(IAttributeSetCollection, DOMDocument30, IErrorSetCollection) | Render HTML text by specifying list of AttributeSet and xsl Document.
 | RenderHtmlForPostback(IKeyValueCollection, IErrorSetCollection) | Render HTML text by raw name-value pairs that you got during HTML submit.
 | Validate(IAttributeSetCollection) | Validate IAttributeSetCollection object against eBay Attributes rules. IErrorSetCollection.Count == 0 means validation succeeded. Otherwise means failure and you have to call the above RenderHtml... methods and pass in the IErrorSetCollection object to re-generate Attributes HTML text that contains all the error messages.
 | XmlProvider | The Attributes XML provider.
 | XslProvider | The Attributes XSL provider.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CategoryCSProvider Property

CategoryCSProvider Property
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► CategoryCSProvider
The Attributes CategoryCS provider. You only need to set this property if you are going to call RenderHtmlForCategories method.
Declaration Syntax
C# Visual Basic Visual C++
ICategoryCSProvider CategoryCSProvider { get; set; }
Property CategoryCSProvider As ICategoryCSProvider
    Get
    Set
property ICategoryCSProvider^ CategoryCSProvider {
    ICategoryCSProvider^ get ();
    void set (ICategoryCSProvider^ value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ConvertAttributeSetArray Method (attrSets)

ConvertAttributeSetArray Method (attrSets)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► ConvertAttributeSetArray(IAttributeSetCollection)
Convert attribute set array to the format of ItemType for AddItemCall.
Declaration Syntax
C# Visual Basic Visual C++
AttributeSetTypeCollection ConvertAttributeSetArray(
    IAttributeSetCollection attrSets
)
Function ConvertAttributeSetArray ( _
    attrSets As IAttributeSetCollection _
) As AttributeSetTypeCollection
AttributeSetTypeCollection^ ConvertAttributeSetArray(
    IAttributeSetCollection^ attrSets
)
Parameters
attrSets (IAttributeSetCollection)
The attribute set list generated by AttributeMaster.
Return Value
The converted array that is compatible with ItemType in AddItemCall.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetItemSpecificAttributeSetsForCategories Method (catIds)

GetItemSpecificAttributeSetsForCategories Method (catIds)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► GetItemSpecificAttributeSetsForCategories(Int32Collection)
Returns collection of item specific AttributeSet objects for an array category Ids. Each element of the array contains a VCS Id, if it exists for a given category Id.
Declaration Syntax
C# Visual Basic Visual C++
IAttributeSetCollection GetItemSpecificAttributeSetsForCategories(
    Int32Collection catIds
)
Function GetItemSpecificAttributeSetsForCategories ( _
    catIds As Int32Collection _
) As IAttributeSetCollection
IAttributeSetCollection^ GetItemSpecificAttributeSetsForCategories(
    Int32Collection^ catIds
)
Parameters
catIds (Int32Collection)
int[]
Return Value
Collection of item specific AttributeSet objects

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetReturnPolicyAttributeSet Method (siteWideAttrSets)

GetReturnPolicyAttributeSet Method (siteWideAttrSets)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► GetReturnPolicyAttributeSet(IAttributeSetCollection)
Extracts AttributeSet object for Return Policy from site wide attribute sets.
Declaration Syntax
C# Visual Basic Visual C++
AttributeSet GetReturnPolicyAttributeSet(
    IAttributeSetCollection siteWideAttrSets
)
Function GetReturnPolicyAttributeSet ( _
    siteWideAttrSets As IAttributeSetCollection _
) As AttributeSet
AttributeSet^ GetReturnPolicyAttributeSet(
    IAttributeSetCollection^ siteWideAttrSets
)
Parameters
siteWideAttrSets (IAttributeSetCollection)
IAttributeSetCollection
Return Value
Return Policy AttributeSet object

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetSiteWideAttributeSetsForCategories Method (catIds)

GetSiteWideAttributeSetsForCategories Method (catIds)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► GetSiteWideAttributeSetsForCategories(Int32Collection)
Returns collection of Site Wide AttributeSet objects for a given array category Ids. Each element of the array contains a VCS Id, if it exists for a given category Id.
Declaration Syntax
C# Visual Basic Visual C++
IAttributeSetCollection GetSiteWideAttributeSetsForCategories(
    Int32Collection catIds
)
Function GetSiteWideAttributeSetsForCategories ( _
    catIds As Int32Collection _
) As IAttributeSetCollection
IAttributeSetCollection^ GetSiteWideAttributeSetsForCategories(
    Int32Collection^ catIds
)
Parameters
catIds (Int32Collection)
int[]
Return Value
Collection of site wide AttributeSet objects

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


JoinItemSpecificAndSiteWideAttributeSets Method (itemSpecAttrSets, swAttrSets)

JoinItemSpecificAndSiteWideAttributeSets Method (itemSpecAttrSets, swAttrSets)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► JoinItemSpecificAndSiteWideAttributeSets(IAttributeSetCollection, IAttributeSetCollection)
Creates an array of AttributeSet objects which contains item specific attribute sets and site wide attribute sets with the exception of the attribute set for return policy.
Declaration Syntax
C# Visual Basic Visual C++
IAttributeSetCollection JoinItemSpecificAndSiteWideAttributeSets(
    IAttributeSetCollection itemSpecAttrSets,
    IAttributeSetCollection swAttrSets
)
Function JoinItemSpecificAndSiteWideAttributeSets ( _
    itemSpecAttrSets As IAttributeSetCollection, _
    swAttrSets As IAttributeSetCollection _
) As IAttributeSetCollection
IAttributeSetCollection^ JoinItemSpecificAndSiteWideAttributeSets(
    IAttributeSetCollection^ itemSpecAttrSets,
    IAttributeSetCollection^ swAttrSets
)
Parameters
itemSpecAttrSets (IAttributeSetCollection)
IAttributeSetCollection
swAttrSets (IAttributeSetCollection)
IAttributeSetCollection
Return Value
Joined collection of of item specific attributes sets and site wide attribute sets, except Return Policy

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


NameValuesToAttributeSets Method (nameValues)

NameValuesToAttributeSets Method (nameValues)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► NameValuesToAttributeSets(IKeyValueCollection)
Extract IAttributeSetCollection object from IKeyValueCollection object.
Declaration Syntax
C# Visual Basic Visual C++
IAttributeSetCollection NameValuesToAttributeSets(
    IKeyValueCollection nameValues
)
Function NameValuesToAttributeSets ( _
    nameValues As IKeyValueCollection _
) As IAttributeSetCollection
IAttributeSetCollection^ NameValuesToAttributeSets(
    IKeyValueCollection^ nameValues
)
Parameters
nameValues (IKeyValueCollection)
The IKeyValueCollection to be converted.
Return Value
The extracted IAttributeSetCollection object.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


RenderHtml Method

RenderHtml Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► RenderHtml()()()()
Members
Icon | Member | Description
 | RenderHtml(IAttributeSetCollection, IErrorSetCollection) | Render HTML text by specifying list of AttributeSet.
 | RenderHtml(IAttributeSetCollection, DOMDocument30, IErrorSetCollection) | Render HTML text by specifying list of AttributeSet and xsl Document.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


RenderHtml Method (attrSets, errorList)

RenderHtml Method (attrSets, errorList)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► RenderHtml(IAttributeSetCollection, IErrorSetCollection)
Render HTML text by specifying list of AttributeSet.
Declaration Syntax
C# Visual Basic Visual C++
string RenderHtml(
    IAttributeSetCollection attrSets,
    IErrorSetCollection errorList
)
Function RenderHtml ( _
    attrSets As IAttributeSetCollection, _
    errorList As IErrorSetCollection _
) As String
String^ RenderHtml(
    IAttributeSetCollection^ attrSets,
    IErrorSetCollection^ errorList
)
Parameters
attrSets (IAttributeSetCollection)
List of AttributeSet objects.
errorList (IErrorSetCollection)
The IErrorSetCollection object returned by Validate method. Set to null if you don't have one.
Return Value
The generated HTML text that is encapsulated in HTML table element.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


RenderHtml Method (attrSets, xslDoc, errorList)

RenderHtml Method (attrSets, xslDoc, errorList)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► RenderHtml(IAttributeSetCollection, DOMDocument30, IErrorSetCollection)
Render HTML text by specifying list of AttributeSet and xsl Document.
Declaration Syntax
C# Visual Basic Visual C++
string RenderHtml(
    IAttributeSetCollection attrSets,
    DOMDocument30 xslDoc,
    IErrorSetCollection errorList
)
Function RenderHtml ( _
    attrSets As IAttributeSetCollection, _
    xslDoc As DOMDocument30, _
    errorList As IErrorSetCollection _
) As String
String^ RenderHtml(
    IAttributeSetCollection^ attrSets,
    DOMDocument30^ xslDoc,
    IErrorSetCollection^ errorList
)
Parameters
attrSets (IAttributeSetCollection)
List of AttributeSet objects.
xslDoc (DOMDocument30)
Xsl Document
errorList (IErrorSetCollection)
The IErrorSetCollection object returned by Validate method. Set to null if you don't have one.
Return Value
The generated HTML text that is encapsulated in HTML table element.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


RenderHtmlForPostback Method (nameValues, errorList)

RenderHtmlForPostback Method (nameValues, errorList)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► RenderHtmlForPostback(IKeyValueCollection, IErrorSetCollection)
Render HTML text by raw name-value pairs that you got during HTML submit.
Declaration Syntax
C# Visual Basic Visual C++
string RenderHtmlForPostback(
    IKeyValueCollection nameValues,
    IErrorSetCollection errorList
)
Function RenderHtmlForPostback ( _
    nameValues As IKeyValueCollection, _
    errorList As IErrorSetCollection _
) As String
String^ RenderHtmlForPostback(
    IKeyValueCollection^ nameValues,
    IErrorSetCollection^ errorList
)
Parameters
nameValues (IKeyValueCollection)
List of name-value pairs from submit of attributes HTML form generated by all these RenderHtml methods.
errorList (IErrorSetCollection)
The IErrorSetCollection object returned by Validate method. Set null if you don't have one.
Return Value
The generated HTML text that is encapsulated in HTML table element.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Validate Method (attrSets)

Validate Method (attrSets)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► Validate(IAttributeSetCollection)
Validate IAttributeSetCollection object against eBay Attributes rules. IErrorSetCollection.Count == 0 means validation succeeded. Otherwise means failure and you have to call the above RenderHtml... methods and pass in the IErrorSetCollection object to re-generate Attributes HTML text that contains all the error messages.
Declaration Syntax
C# Visual Basic Visual C++
IErrorSetCollection Validate(
    IAttributeSetCollection attrSets
)
Function Validate ( _
    attrSets As IAttributeSetCollection _
) As IErrorSetCollection
IErrorSetCollection^ Validate(
    IAttributeSetCollection^ attrSets
)
Parameters
attrSets (IAttributeSetCollection)
The IAttributeSetCollection object which you want to validate.
Return Value
The returned IAttributeSetCollection object. IAttributeSetCollection == 0 means validation succeeded.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


XmlProvider Property

XmlProvider Property
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► XmlProvider
The Attributes XML provider.
Declaration Syntax
C# Visual Basic Visual C++
IAttributesXmlProvider XmlProvider { get; set; }
Property XmlProvider As IAttributesXmlProvider
    Get
    Set
property IAttributesXmlProvider^ XmlProvider {
    IAttributesXmlProvider^ get ();
    void set (IAttributesXmlProvider^ value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


XslProvider Property

XslProvider Property
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesMaster ► XslProvider
The Attributes XSL provider.
Declaration Syntax
C# Visual Basic Visual C++
IAttributesXslProvider XslProvider { get; set; }
Property XslProvider As IAttributesXslProvider
    Get
    Set
property IAttributesXslProvider^ XslProvider {
    IAttributesXslProvider^ get ();
    void set (IAttributesXslProvider^ value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IAttributesXmlProvider Interface

IAttributesXmlProvider Interface
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXmlProvider
Supplies attributes XML for IAttributesMaster. The implementation of IAttributeXmlProvider should handle AttributeSet objects that has valid AttributeSet.ProductId nd return attributes with pre-filled product information for them.
Declaration Syntax
C# Visual Basic Visual C++
public interface IAttributesXmlProvider
Public Interface IAttributesXmlProvider
public interface class IAttributesXmlProvider
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DownloadXml()()()() | Get CS xml data by calling eBay API.
 | DownloadXml(ApiContext) | Get CS xml data by calling eBay API.
 | GetCSIDs()()()() | Get all the CS IDs.
 | GetCSXmlText(AttributeSet) | Get CharacteristicSet(CS) xml. Set AttributeSet.ProductId to retrieve CSXml with pre-filled product information.
 | GetMultipleCSXml(IAttributeSetCollection) | Get xml that contains multiple CSs. Only set AttributeSet.CSId and AttributeSet.ProductId (optional). Set AttributeSet.ProductId to retrieve CSXml with pre-filled product information.
 | GetMultipleCSXmlText(IAttributeSetCollection) | Get xml that contains multiple CSs. Only set AttributeSet.CSId and AttributeSet.ProductId (optional). Set AttributeSet.ProductId to retrieve CSXml with pre-filled product information.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXml Method

DownloadXml Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXmlProvider ► DownloadXml()()()()
Members
Icon | Member | Description
 | DownloadXml()()()() | Get CS xml data by calling eBay API.
 | DownloadXml(ApiContext) | Get CS xml data by calling eBay API.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXml Method

DownloadXml Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXmlProvider ► DownloadXml()()()()
Get CS xml data by calling eBay API.
Declaration Syntax
C# Visual Basic Visual C++
XmlDocument DownloadXml()
Function DownloadXml As XmlDocument
XmlDocument^ DownloadXml()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXml Method (asn)

DownloadXml Method (asn)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXmlProvider ► DownloadXml(ApiContext)
Get CS xml data by calling eBay API.
Declaration Syntax
C# Visual Basic Visual C++
XmlDocument DownloadXml(
    ApiContext asn
)
Function DownloadXml ( _
    asn As ApiContext _
) As XmlDocument
XmlDocument^ DownloadXml(
    ApiContext^ asn
)
Parameters
asn (ApiContext)
The ApiContext object to make API call.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetCSIDs Method

GetCSIDs Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXmlProvider ► GetCSIDs()()()()
Get all the CS IDs.
Declaration Syntax
C# Visual Basic Visual C++
int[] GetCSIDs()
Function GetCSIDs As Integer()
array<int>^ GetCSIDs()
Return Value
Array of CSIDs.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetCSXmlText Method (csInfo)

GetCSXmlText Method (csInfo)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXmlProvider ► GetCSXmlText(AttributeSet)
Get CharacteristicSet(CS) xml. Set AttributeSet.ProductId to retrieve CSXml with pre-filled product information.
Declaration Syntax
C# Visual Basic Visual C++
string GetCSXmlText(
    AttributeSet csInfo
)
Function GetCSXmlText ( _
    csInfo As AttributeSet _
) As String
String^ GetCSXmlText(
    AttributeSet^ csInfo
)
Parameters
csInfo (AttributeSet)
Identification information about the CS for which you want to get CSXml. You only need to set CS.CSId and, optionally, you can set CS.ProductId if you want to get the CSXml that is associated with specific product information. Set CS.CSId to 0 to get entire CharacteristicSet xml for all CSs.
Return Value
The xml text of the CS.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetMultipleCSXml Method (asList)

GetMultipleCSXml Method (asList)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXmlProvider ► GetMultipleCSXml(IAttributeSetCollection)
Get xml that contains multiple CSs. Only set AttributeSet.CSId and AttributeSet.ProductId (optional). Set AttributeSet.ProductId to retrieve CSXml with pre-filled product information.
Declaration Syntax
C# Visual Basic Visual C++
XmlDocument GetMultipleCSXml(
    IAttributeSetCollection asList
)
Function GetMultipleCSXml ( _
    asList As IAttributeSetCollection _
) As XmlDocument
XmlDocument^ GetMultipleCSXml(
    IAttributeSetCollection^ asList
)
Parameters
asList (IAttributeSetCollection)
List of AttributeSet objects for which you want to get CSXml.
Return Value
The CS xml for specified CSs.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetMultipleCSXmlText Method (asList)

GetMultipleCSXmlText Method (asList)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXmlProvider ► GetMultipleCSXmlText(IAttributeSetCollection)
Get xml that contains multiple CSs. Only set AttributeSet.CSId and AttributeSet.ProductId (optional). Set AttributeSet.ProductId to retrieve CSXml with pre-filled product information.
Declaration Syntax
C# Visual Basic Visual C++
string GetMultipleCSXmlText(
    IAttributeSetCollection asList
)
Function GetMultipleCSXmlText ( _
    asList As IAttributeSetCollection _
) As String
String^ GetMultipleCSXmlText(
    IAttributeSetCollection^ asList
)
Parameters
asList (IAttributeSetCollection)
List of AttributeSet objects for which you want to get CSXml.
Return Value
The CS xml text for specified CSs.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IAttributesXslProvider Interface

IAttributesXslProvider Interface
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXslProvider
Supplies attributes XSL for IAttributesMaster.
Declaration Syntax
C# Visual Basic Visual C++
public interface IAttributesXslProvider
Public Interface IAttributesXslProvider
public interface class IAttributesXslProvider
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DownloadXsl(ApiContext) | Downloads XSL file.
 | DownloadXsl()()()() | Downloads XSL file.
 | GetXslFileName()()()() | The XSL file name.
 | GetXslText()()()() | The XSL text.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXsl Method

DownloadXsl Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXslProvider ► DownloadXsl()()()()
Members
Icon | Member | Description
 | DownloadXsl(ApiContext) | Downloads XSL file.
 | DownloadXsl()()()() | Downloads XSL file.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXsl Method

DownloadXsl Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXslProvider ► DownloadXsl()()()()
Downloads XSL file.
Declaration Syntax
C# Visual Basic Visual C++
string DownloadXsl()
Function DownloadXsl As String
String^ DownloadXsl()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadXsl Method (asn)

DownloadXsl Method (asn)
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXslProvider ► DownloadXsl(ApiContext)
Downloads XSL file.
Declaration Syntax
C# Visual Basic Visual C++
string DownloadXsl(
    ApiContext asn
)
Function DownloadXsl ( _
    asn As ApiContext _
) As String
String^ DownloadXsl(
    ApiContext^ asn
)
Parameters
asn (ApiContext)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetXslFileName Method

GetXslFileName Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXslProvider ► GetXslFileName()()()()
The XSL file name.
Declaration Syntax
C# Visual Basic Visual C++
string GetXslFileName()
Function GetXslFileName As String
String^ GetXslFileName()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetXslText Method

GetXslText Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributesXslProvider ► GetXslText()()()()
The XSL text.
Declaration Syntax
C# Visual Basic Visual C++
string GetXslText()
Function GetXslText As String
String^ GetXslText()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ICategoryCSProvider Interface

ICategoryCSProvider Interface
Namespaces ► eBay.Service.SDK.Attribute ► ICategoryCSProvider
Supplies categoryId to CSId convertion service for IAttributesMaster.
Declaration Syntax
C# Visual Basic Visual C++
public interface ICategoryCSProvider
Public Interface ICategoryCSProvider
public interface class ICategoryCSProvider
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DownloadCategoryCS(String) | Get CategoryCS data by calling eBay API.
 | DownloadCategoryCS(ApiContext, String) | Get CategoryCS data by calling eBay API. Special version for fast example usage.
 | GetCategoriesCS()()()() | Get the categories data that it's using for conversion.
 | GetCategoriesCS(String) | Get the categories data that it's using for conversion.
 | GetSiteWideCharSetsAttrIds(String) | Get Site-Wide characteristic sets ids by category ID.
 | GetVCSId(Int32) | Get CSId by categoryId.
 | GetVCSIdArray(Int32) | Get CSIdArray by categoryId.
 | GetVCSIdMap(Int32) | Get getVCSIdMap by categoryId.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadCategoryCS Method

DownloadCategoryCS Method
Namespaces ► eBay.Service.SDK.Attribute ► ICategoryCSProvider ► DownloadCategoryCS()()()()
Members
Icon | Member | Description
 | DownloadCategoryCS(String) | Get CategoryCS data by calling eBay API.
 | DownloadCategoryCS(ApiContext, String) | Get CategoryCS data by calling eBay API. Special version for fast example usage.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadCategoryCS Method (asn, categoryId)

DownloadCategoryCS Method (asn, categoryId)
Namespaces ► eBay.Service.SDK.Attribute ► ICategoryCSProvider ► DownloadCategoryCS(ApiContext, String)
Get CategoryCS data by calling eBay API. Special version for fast example usage.
Declaration Syntax
C# Visual Basic Visual C++
CategoryTypeCollection DownloadCategoryCS(
    ApiContext asn,
    string categoryId
)
Function DownloadCategoryCS ( _
    asn As ApiContext, _
    categoryId As String _
) As CategoryTypeCollection
CategoryTypeCollection^ DownloadCategoryCS(
    ApiContext^ asn,
    String^ categoryId
)
Parameters
asn (ApiContext)
The ApiContext object to make API call.
categoryId (String)
A specific category ID for which to download CategoryCS data.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


DownloadCategoryCS Method (categoryId)

DownloadCategoryCS Method (categoryId)
Namespaces ► eBay.Service.SDK.Attribute ► ICategoryCSProvider ► DownloadCategoryCS(String)
Get CategoryCS data by calling eBay API.
Declaration Syntax
C# Visual Basic Visual C++
CategoryTypeCollection DownloadCategoryCS(
    string categoryId
)
Function DownloadCategoryCS ( _
    categoryId As String _
) As CategoryTypeCollection
CategoryTypeCollection^ DownloadCategoryCS(
    String^ categoryId
)
Parameters
categoryId (String)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetCategoriesCS Method

GetCategoriesCS Method
Namespaces ► eBay.Service.SDK.Attribute ► ICategoryCSProvider ► GetCategoriesCS()()()()
Members
Icon | Member | Description
 | GetCategoriesCS()()()() | Get the categories data that it's using for conversion.
 | GetCategoriesCS(String) | Get the categories data that it's using for conversion.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetCategoriesCS Method

GetCategoriesCS Method
Namespaces ► eBay.Service.SDK.Attribute ► ICategoryCSProvider ► GetCategoriesCS()()()()
Get the categories data that it's using for conversion.
Declaration Syntax
C# Visual Basic Visual C++
CategoryTypeCollection GetCategoriesCS()
Function GetCategoriesCS As CategoryTypeCollection
CategoryTypeCollection^ GetCategoriesCS()
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetCategoriesCS Method (categoryId)

GetCategoriesCS Method (categoryId)
Namespaces ► eBay.Service.SDK.Attribute ► ICategoryCSProvider ► GetCategoriesCS(String)
Get the categories data that it's using for conversion.
Declaration Syntax
C# Visual Basic Visual C++
CategoryTypeCollection GetCategoriesCS(
    string categoryId
)
Function GetCategoriesCS ( _
    categoryId As String _
) As CategoryTypeCollection
CategoryTypeCollection^ GetCategoriesCS(
    String^ categoryId
)
Parameters
categoryId (String)
The categoryId for which you want to get CSId.
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetSiteWideCharSetsAttrIds Method (categoryId)

GetSiteWideCharSetsAttrIds Method (categoryId)
Namespaces ► eBay.Service.SDK.Attribute ► ICategoryCSProvider ► GetSiteWideCharSetsAttrIds(String)
Get Site-Wide characteristic sets ids by category ID.
Declaration Syntax
C# Visual Basic Visual C++
int[] GetSiteWideCharSetsAttrIds(
    string categoryId
)
Function GetSiteWideCharSetsAttrIds ( _
    categoryId As String _
) As Integer()
array<int>^ GetSiteWideCharSetsAttrIds(
    String^ categoryId
)
Parameters
categoryId (String)
A specific category ID for which fetch Site-Wide CategoryCS data.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetVCSId Method (categoryId)

GetVCSId Method (categoryId)
Namespaces ► eBay.Service.SDK.Attribute ► ICategoryCSProvider ► GetVCSId(Int32)
Get CSId by categoryId.
Declaration Syntax
C# Visual Basic Visual C++
int GetVCSId(
    int categoryId
)
Function GetVCSId ( _
    categoryId As Integer _
) As Integer
int GetVCSId(
    int categoryId
)
Parameters
categoryId (Int32)
The categoryId for which you want to get CSId.
Return Value
The CSId.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetVCSIdArray Method (categoryId)

GetVCSIdArray Method (categoryId)
Namespaces ► eBay.Service.SDK.Attribute ► ICategoryCSProvider ► GetVCSIdArray(Int32)
Get CSIdArray by categoryId.
Declaration Syntax
C# Visual Basic Visual C++
int[] GetVCSIdArray(
    int categoryId
)
Function GetVCSIdArray ( _
    categoryId As Integer _
) As Integer()
array<int>^ GetVCSIdArray(
    int categoryId
)
Parameters
categoryId (Int32)
The categoryId for which you want to get CSId array

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetVCSIdMap Method (categoryId)

GetVCSIdMap Method (categoryId)
Namespaces ► eBay.Service.SDK.Attribute ► ICategoryCSProvider ► GetVCSIdMap(Int32)
Get getVCSIdMap by categoryId.
Declaration Syntax
C# Visual Basic Visual C++
Hashtable GetVCSIdMap(
    int categoryId
)
Function GetVCSIdMap ( _
    categoryId As Integer _
) As Hashtable
Hashtable^ GetVCSIdMap(
    int categoryId
)
Parameters
categoryId (Int32)
The categoryId for which you want to get CSId map.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IError Interface

IError Interface
Namespaces ► eBay.Service.SDK.Attribute ► IError
Defines attribute error object.
Declaration Syntax
C# Visual Basic Visual C++
public interface IError
Public Interface IError
public interface class IError
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AttrId | Attribute Id.
 | Message | Error message.
 | RuleName | Rule name.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AttrId Property

AttrId Property
Namespaces ► eBay.Service.SDK.Attribute ► IError ► AttrId
Attribute Id.
Declaration Syntax
C# Visual Basic Visual C++
int AttrId { get; set; }
Property AttrId As Integer
    Get
    Set
property int AttrId {
    int get ();
    void set (int value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Message Property

Message Property
Namespaces ► eBay.Service.SDK.Attribute ► IError ► Message
Error message.
Declaration Syntax
C# Visual Basic Visual C++
string Message { get; set; }
Property Message As String
    Get
    Set
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


RuleName Property

RuleName Property
Namespaces ► eBay.Service.SDK.Attribute ► IError ► RuleName
Rule name.
Declaration Syntax
C# Visual Basic Visual C++
string RuleName { get; set; }
Property RuleName As String
    Get
    Set
property String^ RuleName {
    String^ get ();
    void set (String^ value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IErrorSet Interface

IErrorSet Interface
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet
IError collection.
Declaration Syntax
C# Visual Basic Visual C++
public interface IErrorSet : IList,
    ICollection, IEnumerable
Public Interface IErrorSet _
    Inherits IList, ICollection, IEnumerable
public interface class IErrorSet : IList,
    ICollection, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(IError) | Add element.
 | Add(Object) | (Inherited from IList.)
 | AddRange(array<IError>[]()[][]) | Add an array of IError.
 | AddRange(IErrorSet) | Adds the contents of the specified IErrorSet to the end of the collection.
 | Clear()()()() | (Inherited from IList.)
 | Contains(IError) | Indicates whether a specified object is contained in the list.
 | Contains(Object) | (Inherited from IList.)
 | CopyTo(array<IError>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | CopyTo(Array, Int32) | (Inherited from ICollection.)
 | Count | (Inherited from ICollection.)
 | CSId | CSId of the AttributeSet that is associated with the error set.
 | GetEnumerator()()()() | (Inherited from IEnumerable.)
 | IndexOf(IError) | Get index of an element.
 | IndexOf(Object) | (Inherited from IList.)
 | Insert(Int32, IError) | Insert element to list.
 | Insert(Int32, Object) | (Inherited from IList.)
 | IsFixedSize | (Inherited from IList.)
 | IsReadOnly | (Inherited from IList.)
 | IsSynchronized | (Inherited from ICollection.)
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | Item[([( Int32])]) | (Inherited from IList.)
 | ItemAt(Int32) | Returns item by index.
 | ItemCount()()()() | Returns number of items in the collection.
 | Remove(IError) | Remove element from list.
 | Remove(Object) | (Inherited from IList.)
 | RemoveAt(Int32) | (Inherited from IList.)
 | SyncRoot | (Inherited from ICollection.)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method (value)

Add Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► Add(IError)
Add element.
Declaration Syntax
C# Visual Basic Visual C++
int Add(
    IError value
)
Function Add ( _
    value As IError _
) As Integer
int Add(
    IError^ value
)
Parameters
value (IError)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<IError>[]()[][]) | Add an array of IError.
 | AddRange(IErrorSet) | Adds the contents of the specified IErrorSet to the end of the collection.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► AddRange(array<IError>[]()[][])
Add an array of IError.
Declaration Syntax
C# Visual Basic Visual C++
void AddRange(
    IError[] items
)
Sub AddRange ( _
    items As IError() _
)
void AddRange(
    array<IError^>^ items
)
Parameters
items (array< IError >[]()[][])

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► AddRange(IErrorSet)
Adds the contents of the specified IErrorSet to the end of the collection.
Declaration Syntax
C# Visual Basic Visual C++
void AddRange(
    IErrorSet items
)
Sub AddRange ( _
    items As IErrorSet _
)
void AddRange(
    IErrorSet^ items
)
Parameters
items (IErrorSet)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method (value)

Contains Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► Contains(IError)
Indicates whether a specified object is contained in the list.
Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    IError value
)
Function Contains ( _
    value As IError _
) As Boolean
bool Contains(
    IError^ value
)
Parameters
value (IError)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► CopyTo(array<IError>[]()[][], Int32)
Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
void CopyTo(
    IError[] array,
    int index
)
Sub CopyTo ( _
    array As IError(), _
    index As Integer _
)
void CopyTo(
    array<IError^>^ array,
    int index
)
Parameters
array (array< IError >[]()[][])
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CSId Property

CSId Property
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► CSId
CSId of the AttributeSet that is associated with the error set.
Declaration Syntax
C# Visual Basic Visual C++
int CSId { get; set; }
Property CSId As Integer
    Get
    Set
property int CSId {
    int get ();
    void set (int value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method (value)

IndexOf Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► IndexOf(IError)
Get index of an element.
Declaration Syntax
C# Visual Basic Visual C++
int IndexOf(
    IError value
)
Function IndexOf ( _
    value As IError _
) As Integer
int IndexOf(
    IError^ value
)
Parameters
value (IError)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Insert Method (index, value)

Insert Method (index, value)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► Insert(Int32, IError)
Insert element to list.
Declaration Syntax
C# Visual Basic Visual C++
void Insert(
    int index,
    IError value
)
Sub Insert ( _
    index As Integer, _
    value As IError _
)
void Insert(
    int index,
    IError^ value
)
Parameters
index (Int32)
value (IError)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► Item[([( Int32])])
Gets an element at the specified index in the collection.
Declaration Syntax
C# Visual Basic Visual C++
IError this[
    int index
] { get; set; }
Default Property Item ( _
    index As Integer _
) As IError
    Get
    Set
property IError^ default[int index] {
    IError^ get (int index);
    void set (int index, IError^ value);
}
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► ItemAt(Int32)
Returns item by index.
Declaration Syntax
C# Visual Basic Visual C++
IError ItemAt(
    int index
)
Function ItemAt ( _
    index As Integer _
) As IError
IError^ ItemAt(
    int index
)
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemCount Method

ItemCount Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► ItemCount()()()()
Returns number of items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
int ItemCount()
Function ItemCount As Integer
int ItemCount()
Return Value
Number of items.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method (value)

Remove Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► Remove(IError)
Remove element from list.
Declaration Syntax
C# Visual Basic Visual C++
void Remove(
    IError value
)
Sub Remove ( _
    value As IError _
)
void Remove(
    IError^ value
)
Parameters
value (IError)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IErrorSetCollection Interface

IErrorSetCollection Interface
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection
IErrorSet collection.
Declaration Syntax
C# Visual Basic Visual C++
public interface IErrorSetCollection : IList,
    ICollection, IEnumerable
Public Interface IErrorSetCollection _
    Inherits IList, ICollection, IEnumerable
public interface class IErrorSetCollection : IList,
    ICollection, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(IErrorSet) | Add element.
 | Add(Object) | (Inherited from IList.)
 | AddRange(array<IErrorSet>[]()[][]) | Add an array of IErrorSet.
 | AddRange(IErrorSetCollection) | Adds the contents of the specified IErrorSetCollection to the end of the collection.
 | Clear()()()() | (Inherited from IList.)
 | Contains(IErrorSet) | Indicates whether a specified object is contained in the list.
 | Contains(Object) | (Inherited from IList.)
 | CopyTo(array<IErrorSet>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | CopyTo(Array, Int32) | (Inherited from ICollection.)
 | Count | (Inherited from ICollection.)
 | GetEnumerator()()()() | (Inherited from IEnumerable.)
 | IndexOf(IErrorSet) | Get index of an element.
 | IndexOf(Object) | (Inherited from IList.)
 | Insert(Int32, IErrorSet) | Insert element to list.
 | Insert(Int32, Object) | (Inherited from IList.)
 | IsFixedSize | (Inherited from IList.)
 | IsReadOnly | (Inherited from IList.)
 | IsSynchronized | (Inherited from ICollection.)
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | Item[([( Int32])]) | (Inherited from IList.)
 | ItemAt(Int32) | Returns item by index.
 | ItemCount()()()() | Returns number of items in the collection.
 | Remove(IErrorSet) | Remove element from list.
 | Remove(Object) | (Inherited from IList.)
 | RemoveAt(Int32) | (Inherited from IList.)
 | SyncRoot | (Inherited from ICollection.)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method (value)

Add Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► Add(IErrorSet)
Add element.
Declaration Syntax
C# Visual Basic Visual C++
int Add(
    IErrorSet value
)
Function Add ( _
    value As IErrorSet _
) As Integer
int Add(
    IErrorSet^ value
)
Parameters
value (IErrorSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<IErrorSet>[]()[][]) | Add an array of IErrorSet.
 | AddRange(IErrorSetCollection) | Adds the contents of the specified IErrorSetCollection to the end of the collection.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► AddRange(array<IErrorSet>[]()[][])
Add an array of IErrorSet.
Declaration Syntax
C# Visual Basic Visual C++
void AddRange(
    IErrorSet[] items
)
Sub AddRange ( _
    items As IErrorSet() _
)
void AddRange(
    array<IErrorSet^>^ items
)
Parameters
items (array< IErrorSet >[]()[][])

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► AddRange(IErrorSetCollection)
Adds the contents of the specified IErrorSetCollection to the end of the collection.
Declaration Syntax
C# Visual Basic Visual C++
void AddRange(
    IErrorSetCollection items
)
Sub AddRange ( _
    items As IErrorSetCollection _
)
void AddRange(
    IErrorSetCollection^ items
)
Parameters
items (IErrorSetCollection)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method (value)

Contains Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► Contains(IErrorSet)
Indicates whether a specified object is contained in the list.
Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    IErrorSet value
)
Function Contains ( _
    value As IErrorSet _
) As Boolean
bool Contains(
    IErrorSet^ value
)
Parameters
value (IErrorSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► CopyTo(array<IErrorSet>[]()[][], Int32)
Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
void CopyTo(
    IErrorSet[] array,
    int index
)
Sub CopyTo ( _
    array As IErrorSet(), _
    index As Integer _
)
void CopyTo(
    array<IErrorSet^>^ array,
    int index
)
Parameters
array (array< IErrorSet >[]()[][])
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method (value)

IndexOf Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► IndexOf(IErrorSet)
Get index of an element.
Declaration Syntax
C# Visual Basic Visual C++
int IndexOf(
    IErrorSet value
)
Function IndexOf ( _
    value As IErrorSet _
) As Integer
int IndexOf(
    IErrorSet^ value
)
Parameters
value (IErrorSet)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Insert Method (index, value)

Insert Method (index, value)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► Insert(Int32, IErrorSet)
Insert element to list.
Declaration Syntax
C# Visual Basic Visual C++
void Insert(
    int index,
    IErrorSet value
)
Sub Insert ( _
    index As Integer, _
    value As IErrorSet _
)
void Insert(
    int index,
    IErrorSet^ value
)
Parameters
index (Int32)
value (IErrorSet)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► Item[([( Int32])])
Gets an element at the specified index in the collection.
Declaration Syntax
C# Visual Basic Visual C++
IErrorSet this[
    int index
] { get; set; }
Default Property Item ( _
    index As Integer _
) As IErrorSet
    Get
    Set
property IErrorSet^ default[int index] {
    IErrorSet^ get (int index);
    void set (int index, IErrorSet^ value);
}
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► ItemAt(Int32)
Returns item by index.
Declaration Syntax
C# Visual Basic Visual C++
IErrorSet ItemAt(
    int index
)
Function ItemAt ( _
    index As Integer _
) As IErrorSet
IErrorSet^ ItemAt(
    int index
)
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemCount Method

ItemCount Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► ItemCount()()()()
Returns number of items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
int ItemCount()
Function ItemCount As Integer
int ItemCount()
Return Value
Number of items.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method (value)

Remove Method (value)
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► Remove(IErrorSet)
Remove element from list.
Declaration Syntax
C# Visual Basic Visual C++
void Remove(
    IErrorSet value
)
Sub Remove ( _
    value As IErrorSet _
)
void Remove(
    IErrorSet^ value
)
Parameters
value (IErrorSet)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Value Class

Value Class
Namespaces ► eBay.Service.SDK.Attribute ► Value
Wrapper class for SOAP ValType.
Declaration Syntax
C# Visual Basic Visual C++
public class Value : ValType
Public Class Value _
    Inherits ValType
public ref class Value : public ValType
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Value()()()() |
 | Value(ValueTypes) |
 | Any | (Inherited from ValType.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | SuggestedValueLiteral | (Inherited from ValType.)
 | ToString()()()() | (Inherited from Object.)
 | Type | Type of a attribute value.
 | ValueID | (Inherited from ValType.)
 | ValueIDSpecified | (Inherited from ValType.)
 | ValueLiteral | (Inherited from ValType.)
Inheritance Hierarchy
Object
 | ValType
 |  | Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Type Property

Type Property
Namespaces ► eBay.Service.SDK.Attribute ► Value ► Type
Type of a attribute value.
Declaration Syntax
C# Visual Basic Visual C++
public ValueTypes Type { get; set; }
Public Property Type As ValueTypes
    Get
    Set
public:
property ValueTypes Type {
    ValueTypes get ();
    void set (ValueTypes value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Value Constructor

Value Constructor
Namespaces ► eBay.Service.SDK.Attribute ► Value ► Value()()()()
Members
Icon | Member | Description
 | Value()()()() |
 | Value(ValueTypes) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Value Constructor

Value Constructor
Namespaces ► eBay.Service.SDK.Attribute ► Value ► Value()()()()
Declaration Syntax
C# Visual Basic Visual C++
public Value()
Public Sub New
public:
Value()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Value Constructor (type)

Value Constructor (type)
Namespaces ► eBay.Service.SDK.Attribute ► Value ► Value(ValueTypes)
Declaration Syntax
C# Visual Basic Visual C++
public Value(
    ValueTypes type
)
Public Sub New ( _
    type As ValueTypes _
)
public:
Value(
    ValueTypes type
)
Parameters
type (ValueTypes)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ValueIds Enumeration

ValueIds Enumeration
Namespaces ► eBay.Service.SDK.Attribute ► ValueIds
Predefined ValueIds.
Declaration Syntax
C# Visual Basic Visual C++
public enum ValueIds
Public Enumeration ValueIds
public enum class ValueIds
Members
Member | Description
PARTIAL_TEXT_DATE_ONE | Incomplete Single-Text-Date.
COMPLETE_TEXT_DATE_ONE | Complete Single-Text-Date.
TEXT | Localized string.
PARTIAL_TEXT_DATE | Incomplete Text-Date.
COMPLETE_TEXT_DATE | Complete Text-Date.
OTHER | Other.
NONE | None or initial value.
NOT_SPECIFIED | Not specified.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ValueTypes Enumeration

ValueTypes Enumeration
Namespaces ► eBay.Service.SDK.Attribute ► ValueTypes
Enumerates types of attribute value.
Declaration Syntax
C# Visual Basic Visual C++
public enum ValueTypes
Public Enumeration ValueTypes
public enum class ValueTypes
Members
Member | Description
ValueId | Uses IValue.ValueId to get value data.
Text | IValue.ValueLiteral is the value data.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


eBay.Service.SDK.Util Namespace

eBay.Service.SDK.Util Namespace
Namespaces ► eBay.Service.SDK.Util
Declaration Syntax
C# Visual Basic Visual C++
namespace eBay.Service.SDK.Util
Namespace eBay.Service.SDK.Util
namespace eBay.Service.SDK.Util
Types
All Types Classes Interfaces
Icon | Type | Description
 | IKeyValue | Defines key/value string pair object.
 | IKeyValueCollection | IKeyValue collection. This interface simulates System.Collectionis.Specialized.NameValueCollection but it's COM-friendly that can be called from any language.
 | KeyValue | Implements IKeyValue.
 | KeyValueCollection | Strong typed IKeyValue collection
 | SDKUtil | Contains utility functions for SDK.


IKeyValue Interface

IKeyValue Interface
Namespaces ► eBay.Service.SDK.Util ► IKeyValue
Defines key/value string pair object.
Declaration Syntax
C# Visual Basic Visual C++
public interface IKeyValue
Public Interface IKeyValue
public interface class IKeyValue
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Key | Name of the key.
 | Value | Value for the key.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Key Property

Key Property
Namespaces ► eBay.Service.SDK.Util ► IKeyValue ► Key
Name of the key.
Declaration Syntax
C# Visual Basic Visual C++
string Key { get; set; }
Property Key As String
    Get
    Set
property String^ Key {
    String^ get ();
    void set (String^ value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Value Property

Value Property
Namespaces ► eBay.Service.SDK.Util ► IKeyValue ► Value
Value for the key.
Declaration Syntax
C# Visual Basic Visual C++
string Value { get; set; }
Property Value As String
    Get
    Set
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IKeyValueCollection Interface

IKeyValueCollection Interface
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection
IKeyValue collection. This interface simulates System.Collectionis.Specialized.NameValueCollection but it's COM-friendly that can be called from any language.
Declaration Syntax
C# Visual Basic Visual C++
public interface IKeyValueCollection : IList,
    ICollection, IEnumerable
Public Interface IKeyValueCollection _
    Inherits IList, ICollection, IEnumerable
public interface class IKeyValueCollection : IList,
    ICollection, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(IKeyValue) | Add element.
 | Add(Object) | (Inherited from IList.)
 | AddRange(array<IKeyValue>[]()[][]) | Add an array of IKeyValue.
 | AddRange(IKeyValueCollection) | Adds the contents of the specified IKeyValueCollection to the end of the collection.
 | Clear()()()() | (Inherited from IList.)
 | Contains(IKeyValue) | Indicates whether a specified object is contained in the list.
 | Contains(Object) | (Inherited from IList.)
 | CopyTo(array<IKeyValue>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | CopyTo(Array, Int32) | (Inherited from ICollection.)
 | Count | (Inherited from ICollection.)
 | Find(String) | Search node by key.
 | GetEnumerator()()()() | (Inherited from IEnumerable.)
 | IndexOf(IKeyValue) | Get index of an element.
 | IndexOf(Object) | (Inherited from IList.)
 | Insert(Int32, IKeyValue) | Insert element to list.
 | Insert(Int32, Object) | (Inherited from IList.)
 | IsFixedSize | (Inherited from IList.)
 | IsReadOnly | (Inherited from IList.)
 | IsSynchronized | (Inherited from ICollection.)
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | Item[([( Int32])]) | (Inherited from IList.)
 | ItemAt(Int32) | Returns item by index.
 | ItemCount()()()() | Returns number of items in the collection.
 | Remove(IKeyValue) | Remove element from list.
 | Remove(Object) | (Inherited from IList.)
 | RemoveAt(Int32) | (Inherited from IList.)
 | SyncRoot | (Inherited from ICollection.)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method (value)

Add Method (value)
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► Add(IKeyValue)
Add element.
Declaration Syntax
C# Visual Basic Visual C++
int Add(
    IKeyValue value
)
Function Add ( _
    value As IKeyValue _
) As Integer
int Add(
    IKeyValue^ value
)
Parameters
value (IKeyValue)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<IKeyValue>[]()[][]) | Add an array of IKeyValue.
 | AddRange(IKeyValueCollection) | Adds the contents of the specified IKeyValueCollection to the end of the collection.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► AddRange(array<IKeyValue>[]()[][])
Add an array of IKeyValue.
Declaration Syntax
C# Visual Basic Visual C++
void AddRange(
    IKeyValue[] items
)
Sub AddRange ( _
    items As IKeyValue() _
)
void AddRange(
    array<IKeyValue^>^ items
)
Parameters
items (array< IKeyValue >[]()[][])

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► AddRange(IKeyValueCollection)
Adds the contents of the specified IKeyValueCollection to the end of the collection.
Declaration Syntax
C# Visual Basic Visual C++
void AddRange(
    IKeyValueCollection items
)
Sub AddRange ( _
    items As IKeyValueCollection _
)
void AddRange(
    IKeyValueCollection^ items
)
Parameters
items (IKeyValueCollection)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method (value)

Contains Method (value)
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► Contains(IKeyValue)
Indicates whether a specified object is contained in the list.
Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    IKeyValue value
)
Function Contains ( _
    value As IKeyValue _
) As Boolean
bool Contains(
    IKeyValue^ value
)
Parameters
value (IKeyValue)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► CopyTo(array<IKeyValue>[]()[][], Int32)
Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
void CopyTo(
    IKeyValue[] array,
    int index
)
Sub CopyTo ( _
    array As IKeyValue(), _
    index As Integer _
)
void CopyTo(
    array<IKeyValue^>^ array,
    int index
)
Parameters
array (array< IKeyValue >[]()[][])
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Find Method (key)

Find Method (key)
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► Find(String)
Search node by key.
Declaration Syntax
C# Visual Basic Visual C++
IKeyValue Find(
    string key
)
Function Find ( _
    key As String _
) As IKeyValue
IKeyValue^ Find(
    String^ key
)
Parameters
key (String)
The key string to search.
Return Value
null means not found.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method (value)

IndexOf Method (value)
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► IndexOf(IKeyValue)
Get index of an element.
Declaration Syntax
C# Visual Basic Visual C++
int IndexOf(
    IKeyValue value
)
Function IndexOf ( _
    value As IKeyValue _
) As Integer
int IndexOf(
    IKeyValue^ value
)
Parameters
value (IKeyValue)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Insert Method (index, value)

Insert Method (index, value)
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► Insert(Int32, IKeyValue)
Insert element to list.
Declaration Syntax
C# Visual Basic Visual C++
void Insert(
    int index,
    IKeyValue value
)
Sub Insert ( _
    index As Integer, _
    value As IKeyValue _
)
void Insert(
    int index,
    IKeyValue^ value
)
Parameters
index (Int32)
value (IKeyValue)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► Item[([( Int32])])
Gets an element at the specified index in the collection.
Declaration Syntax
C# Visual Basic Visual C++
IKeyValue this[
    int index
] { get; set; }
Default Property Item ( _
    index As Integer _
) As IKeyValue
    Get
    Set
property IKeyValue^ default[int index] {
    IKeyValue^ get (int index);
    void set (int index, IKeyValue^ value);
}
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► ItemAt(Int32)
Returns item by index.
Declaration Syntax
C# Visual Basic Visual C++
IKeyValue ItemAt(
    int index
)
Function ItemAt ( _
    index As Integer _
) As IKeyValue
IKeyValue^ ItemAt(
    int index
)
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemCount Method

ItemCount Method
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► ItemCount()()()()
Returns number of items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
int ItemCount()
Function ItemCount As Integer
int ItemCount()
Return Value
Number of items.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method (value)

Remove Method (value)
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► Remove(IKeyValue)
Remove element from list.
Declaration Syntax
C# Visual Basic Visual C++
void Remove(
    IKeyValue value
)
Sub Remove ( _
    value As IKeyValue _
)
void Remove(
    IKeyValue^ value
)
Parameters
value (IKeyValue)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


KeyValue Class

KeyValue Class
Namespaces ► eBay.Service.SDK.Util ► KeyValue
Implements IKeyValue.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class KeyValue : IKeyValue
<SerializableAttribute> _
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public Class KeyValue _
    Implements IKeyValue
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class KeyValue : IKeyValue
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeyValue()()()() | Constructor.
 | KeyValue(String, String) | Constructor.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | Key | Name of the key.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
 | Value | Value for the key.
Inheritance Hierarchy
Object
KeyValue

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Key Property

Key Property
Namespaces ► eBay.Service.SDK.Util ► KeyValue ► Key
Name of the key.
Declaration Syntax
C# Visual Basic Visual C++
public string Key { get; set; }
Public Property Key As String
    Get
    Set
public:
virtual property String^ Key {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


KeyValue Constructor

KeyValue Constructor
Namespaces ► eBay.Service.SDK.Util ► KeyValue ► KeyValue()()()()
Members
Icon | Member | Description
 | KeyValue()()()() | Constructor.
 | KeyValue(String, String) | Constructor.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


KeyValue Constructor

KeyValue Constructor
Namespaces ► eBay.Service.SDK.Util ► KeyValue ► KeyValue()()()()
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public KeyValue()
Public Sub New
public:
KeyValue()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


KeyValue Constructor (key, val)

KeyValue Constructor (key, val)
Namespaces ► eBay.Service.SDK.Util ► KeyValue ► KeyValue(String, String)
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public KeyValue(
    string key,
    string val
)
Public Sub New ( _
    key As String, _
    val As String _
)
public:
KeyValue(
    String^ key,
    String^ val
)
Parameters
key (String)
Name of the key.
val (String)
Value for the key.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Value Property

Value Property
Namespaces ► eBay.Service.SDK.Util ► KeyValue ► Value
Value for the key.
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


KeyValueCollection Class

KeyValueCollection Class
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection
Strong typed IKeyValue collection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public sealed class KeyValueCollection : CollectionBase,
    IKeyValueCollection, IList, ICollection, IEnumerable
<SerializableAttribute> _
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public NotInheritable Class KeyValueCollection _
    Inherits CollectionBase _
    Implements IKeyValueCollection, IList, ICollection, IEnumerable
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class KeyValueCollection sealed : public CollectionBase,
    IKeyValueCollection, IList, ICollection, IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeyValueCollection()()()() | Default constructor.
 | KeyValueCollection(array<IKeyValue>[]()[][]) | Initializes a new instance containing the specified array of IKeyValue objects
 | KeyValueCollection(IKeyValueCollection) | Initializes a new instance containing the elements of the specified source collection.
 | Add(IKeyValue) | Add element.
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<IKeyValue>[]()[][]) | Add an array of IKeyValue.
 | AddRange(IKeyValueCollection) | Adds the contents of the specified IKeyValueCollection to the end of the collection.
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(IKeyValue) | Indicates whether a specified object is contained in the list.
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<IKeyValue>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | Find(String) | Search node by key.
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(IKeyValue) | Get index of an element.
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, IKeyValue) | Insert element to list.
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) | Returns item by index.
 | ItemCount()()()() | Returns number of items in the collection.
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(IKeyValue) | Remove element from list.
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | KeyValueCollection

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method (value)

Add Method (value)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► Add(IKeyValue)
Add element.
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    IKeyValue value
)
Public Function Add ( _
    value As IKeyValue _
) As Integer
public:
virtual int Add(
    IKeyValue^ value
) sealed
Parameters
value (IKeyValue)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method

AddRange Method
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<IKeyValue>[]()[][]) | Add an array of IKeyValue.
 | AddRange(IKeyValueCollection) | Adds the contents of the specified IKeyValueCollection to the end of the collection.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► AddRange(array<IKeyValue>[]()[][])
Add an array of IKeyValue.
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    IKeyValue[] items
)
Public Sub AddRange ( _
    items As IKeyValue() _
)
public:
virtual void AddRange(
    array<IKeyValue^>^ items
) sealed
Parameters
items (array< IKeyValue >[]()[][])

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► AddRange(IKeyValueCollection)
Adds the contents of the specified IKeyValueCollection to the end of the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    IKeyValueCollection items
)
Public Sub AddRange ( _
    items As IKeyValueCollection _
)
public:
virtual void AddRange(
    IKeyValueCollection^ items
) sealed
Parameters
items (IKeyValueCollection)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method (value)

Contains Method (value)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► Contains(IKeyValue)
Indicates whether a specified object is contained in the list.
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    IKeyValue value
)
Public Function Contains ( _
    value As IKeyValue _
) As Boolean
public:
virtual bool Contains(
    IKeyValue^ value
) sealed
Parameters
value (IKeyValue)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► CopyTo(array<IKeyValue>[]()[][], Int32)
Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    IKeyValue[] array,
    int index
)
Public Sub CopyTo ( _
    array As IKeyValue(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<IKeyValue^>^ array,
    int index
) sealed
Parameters
array (array< IKeyValue >[]()[][])
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Find Method (key)

Find Method (key)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► Find(String)
Search node by key.
Declaration Syntax
C# Visual Basic Visual C++
public IKeyValue Find(
    string key
)
Public Function Find ( _
    key As String _
) As IKeyValue
public:
virtual IKeyValue^ Find(
    String^ key
) sealed
Parameters
key (String)
The key string to search.
Return Value
null means not found.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method (value)

IndexOf Method (value)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► IndexOf(IKeyValue)
Get index of an element.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    IKeyValue value
)
Public Function IndexOf ( _
    value As IKeyValue _
) As Integer
public:
virtual int IndexOf(
    IKeyValue^ value
) sealed
Parameters
value (IKeyValue)
Return Value

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Insert Method (index, value)

Insert Method (index, value)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► Insert(Int32, IKeyValue)
Insert element to list.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    IKeyValue value
)
Public Sub Insert ( _
    index As Integer, _
    value As IKeyValue _
)
public:
virtual void Insert(
    int index,
    IKeyValue^ value
) sealed
Parameters
index (Int32)
value (IKeyValue)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► Item[([( Int32])])
Gets an element at the specified index in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public IKeyValue this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As IKeyValue
    Get
    Set
public:
virtual property IKeyValue^ default[int index] {
    IKeyValue^ get (int index) sealed;
    void set (int index, IKeyValue^ value) sealed;
}
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► ItemAt(Int32)
Returns item by index.
Declaration Syntax
C# Visual Basic Visual C++
public IKeyValue ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As IKeyValue
public:
virtual IKeyValue^ ItemAt(
    int index
) sealed
Parameters
index (Int32)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ItemCount Method

ItemCount Method
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► ItemCount()()()()
Returns number of items in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int ItemCount()
Public Function ItemCount As Integer
public:
virtual int ItemCount() sealed
Return Value
Number of items.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


KeyValueCollection Constructor

KeyValueCollection Constructor
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► KeyValueCollection()()()()
Members
Icon | Member | Description
 | KeyValueCollection()()()() | Default constructor.
 | KeyValueCollection(array<IKeyValue>[]()[][]) | Initializes a new instance containing the specified array of IKeyValue objects
 | KeyValueCollection(IKeyValueCollection) | Initializes a new instance containing the elements of the specified source collection.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


KeyValueCollection Constructor

KeyValueCollection Constructor
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► KeyValueCollection()()()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public KeyValueCollection()
Public Sub New
public:
KeyValueCollection()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


KeyValueCollection Constructor (value)

KeyValueCollection Constructor (value)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► KeyValueCollection(array<IKeyValue>[]()[][])
Initializes a new instance containing the specified array of IKeyValue objects
Declaration Syntax
C# Visual Basic Visual C++
public KeyValueCollection(
    IKeyValue[] value
)
Public Sub New ( _
    value As IKeyValue() _
)
public:
KeyValueCollection(
    array<IKeyValue^>^ value
)
Parameters
value (array< IKeyValue >[]()[][])

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


KeyValueCollection Constructor (value)

KeyValueCollection Constructor (value)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► KeyValueCollection(IKeyValueCollection)
Initializes a new instance containing the elements of the specified source collection.
Declaration Syntax
C# Visual Basic Visual C++
public KeyValueCollection(
    IKeyValueCollection value
)
Public Sub New ( _
    value As IKeyValueCollection _
)
public:
KeyValueCollection(
    IKeyValueCollection^ value
)
Parameters
value (IKeyValueCollection)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method (value)

Remove Method (value)
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► Remove(IKeyValue)
Remove element from list.
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    IKeyValue value
)
Public Sub Remove ( _
    value As IKeyValue _
)
public:
virtual void Remove(
    IKeyValue^ value
) sealed
Parameters
value (IKeyValue)

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SDKUtil Class

SDKUtil Class
Namespaces ► eBay.Service.SDK.Util ► SDKUtil
Contains utility functions for SDK.
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SDKUtil
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public Class SDKUtil
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class SDKUtil
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SDKUtil()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetStringDigest(String) | Compute the MD5 digest of input string then encode the results.
 | GetType()()()() | (Inherited from Object.)
 | IsNonZeroString(String) | Determines if the length of a string is greater than 0.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NULL_TIME | DateTime value that represents NULL.
 | ParseEBayDate(String) | Convert an eBay date string to DateTime object.
 | ParseEBayTime(String) | Convert an eBay date time string to DateTime object.
 | ToEBayDate(DateTime) | Convert DateTime object to eBay date string (yyyy-mm-dd).
 | ToEBayTime(DateTime) | Convert DateTime object to eBay time string.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SDKUtil

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


GetStringDigest Method (strData)

GetStringDigest Method (strData)
Namespaces ► eBay.Service.SDK.Util ► SDKUtil ► GetStringDigest(String)
Compute the MD5 digest of input string then encode the results.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetStringDigest(
    string strData
)
Public Shared Function GetStringDigest ( _
    strData As String _
) As String
public:
static String^ GetStringDigest(
    String^ strData
)
Parameters
strData (String)
The input string.
Return Value
The result string.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IsNonZeroString Method (str)

IsNonZeroString Method (str)
Namespaces ► eBay.Service.SDK.Util ► SDKUtil ► IsNonZeroString(String)
Determines if the length of a string is greater than 0.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsNonZeroString(
    string str
)
Public Shared Function IsNonZeroString ( _
    str As String _
) As Boolean
public:
static bool IsNonZeroString(
    String^ str
)
Parameters
str (String)
The string object.
Return Value
true means the input string is not null and its size > 0.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


NULL_TIME Field

NULL_TIME Field
Namespaces ► eBay.Service.SDK.Util ► SDKUtil ► NULL_TIME
DateTime value that represents NULL.
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime NULL_TIME
Public Shared NULL_TIME As DateTime
public:
static DateTime NULL_TIME

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ParseEBayDate Method (date)

ParseEBayDate Method (date)
Namespaces ► eBay.Service.SDK.Util ► SDKUtil ► ParseEBayDate(String)
Convert an eBay date string to DateTime object.
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime ParseEBayDate(
    string date
)
Public Shared Function ParseEBayDate ( _
    date As String _
) As DateTime
public:
static DateTime ParseEBayDate(
    String^ date
)
Parameters
date (String)
The date string to be converted.
Return Value
The DateTime object

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ParseEBayTime Method (dt)

ParseEBayTime Method (dt)
Namespaces ► eBay.Service.SDK.Util ► SDKUtil ► ParseEBayTime(String)
Convert an eBay date time string to DateTime object.
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime ParseEBayTime(
    string dt
)
Public Shared Function ParseEBayTime ( _
    dt As String _
) As DateTime
public:
static DateTime ParseEBayTime(
    String^ dt
)
Parameters
dt (String)
The string to be converted.
Return Value
The DateTime object

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SDKUtil Constructor

SDKUtil Constructor
Namespaces ► eBay.Service.SDK.Util ► SDKUtil ► SDKUtil()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SDKUtil()
Public Sub New
public:
SDKUtil()

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ToEBayDate Method (date)

ToEBayDate Method (date)
Namespaces ► eBay.Service.SDK.Util ► SDKUtil ► ToEBayDate(DateTime)
Convert DateTime object to eBay date string (yyyy-mm-dd).
Declaration Syntax
C# Visual Basic Visual C++
public static string ToEBayDate(
    DateTime date
)
Public Shared Function ToEBayDate ( _
    date As DateTime _
) As String
public:
static String^ ToEBayDate(
    DateTime date
)
Parameters
date (DateTime)
The DateTime object.
Return Value
The converted date string.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


ToEBayTime Method (dt)

ToEBayTime Method (dt)
Namespaces ► eBay.Service.SDK.Util ► SDKUtil ► ToEBayTime(DateTime)
Convert DateTime object to eBay time string.
Declaration Syntax
C# Visual Basic Visual C++
public static string ToEBayTime(
    DateTime dt
)
Public Shared Function ToEBayTime ( _
    dt As DateTime _
) As String
public:
static String^ ToEBayTime(
    DateTime dt
)
Parameters
dt (DateTime)
The DateTime object.
Return Value
The converted string.

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


eBay.Service.Util Namespace

eBay.Service.Util Namespace
Namespaces ► eBay.Service.Util
Declaration Syntax
C# Visual Basic Visual C++
namespace eBay.Service.Util
Namespace eBay.Service.Util
namespace eBay.Service.Util
Types
All Types Classes Enumerations
Icon | Type | Description
 | ApiLogger | Base class of the FileLogger, EventLogger, and ConsoleLogger classes. Typically, the individual classes that inherit from ApiLogger are used in the ApiLoggerList to specify which loggers are to be used for logging.
 | ApiLoggerCollection |
 | AttributeHelper | Helper class for attributes.
 | ConsoleLogger |
 | CurrencyUtility |
 | EBayDetailsHelper | Summary description for EBayDetailsHelper.
 | ErrorLanguageUtility | The default error language is the one used on the site being accessed in the API call. You can change the default to any language, so that the error messages are displayed in the language of your choice.
 | EventLogger |
 | FileLogger |
 | GetCategoryFeaturesHelper | Summary description for GetCategoryFeaturesHelper.
 | MessageSeverity |
 | MessageType |
 | MotorAttributeHelper | Helper class to work on motor attributes.
 | SdkUtility |
 | SiteUtility |
 | XmlUtility |


ApiLogger Class

ApiLogger Class
Namespaces ► eBay.Service.Util ► ApiLogger
Base class of the FileLogger, EventLogger, and ConsoleLogger classes. Typically, the individual classes that inherit from ApiLogger are used in the ApiLoggerList to specify which loggers are to be used for logging.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ApiLogger
Public MustInherit Class ApiLogger
public ref class ApiLogger abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApiLogger()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetGetExecutingAssemblyDirectory()()()() | get directory path of eBay.Service.dll
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LogApiMessages | Gets or sets a property that determines if the API Call payloads should be logged.
 | LogExceptions | Gets or sets a property that determines if the exceptions should be logged.
 | LogInformations | Gets or sets a property that determines if informational messages should be logged.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RecordMessage(String, MessageSeverity) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ApiLogger
 |  | ConsoleLogger
 |  | EventLogger
 |  | FileLogger


ApiLogger Constructor

ApiLogger Constructor
Namespaces ► eBay.Service.Util ► ApiLogger ► ApiLogger()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected ApiLogger()
Protected Sub New
protected:
ApiLogger()


GetGetExecutingAssemblyDirectory Method

GetGetExecutingAssemblyDirectory Method
Namespaces ► eBay.Service.Util ► ApiLogger ► GetGetExecutingAssemblyDirectory()()()()
get directory path of eBay.Service.dll
Declaration Syntax
C# Visual Basic Visual C++
protected string GetGetExecutingAssemblyDirectory()
Protected Function GetGetExecutingAssemblyDirectory As String
protected:
String^ GetGetExecutingAssemblyDirectory()
Return Value


LogApiMessages Property

LogApiMessages Property
Namespaces ► eBay.Service.Util ► ApiLogger ► LogApiMessages
Gets or sets a property that determines if the API Call payloads should be logged.
Declaration Syntax
C# Visual Basic Visual C++
public bool LogApiMessages { get; set; }
Public Property LogApiMessages As Boolean
    Get
    Set
public:
property bool LogApiMessages {
    bool get ();
    void set (bool value);
}


LogExceptions Property

LogExceptions Property
Namespaces ► eBay.Service.Util ► ApiLogger ► LogExceptions
Gets or sets a property that determines if the exceptions should be logged.
Declaration Syntax
C# Visual Basic Visual C++
public bool LogExceptions { get; set; }
Public Property LogExceptions As Boolean
    Get
    Set
public:
property bool LogExceptions {
    bool get ();
    void set (bool value);
}


LogInformations Property

LogInformations Property
Namespaces ► eBay.Service.Util ► ApiLogger ► LogInformations
Gets or sets a property that determines if informational messages should be logged.
Declaration Syntax
C# Visual Basic Visual C++
public bool LogInformations { get; set; }
Public Property LogInformations As Boolean
    Get
    Set
public:
property bool LogInformations {
    bool get ();
    void set (bool value);
}


RecordMessage Method (Message, Severity)

RecordMessage Method (Message, Severity)
Namespaces ► eBay.Service.Util ► ApiLogger ► RecordMessage(String, MessageSeverity)
Declaration Syntax
C# Visual Basic Visual C++
public abstract void RecordMessage(
    string Message,
    MessageSeverity Severity
)
Public MustOverride Sub RecordMessage ( _
    Message As String, _
    Severity As MessageSeverity _
)
public:
virtual void RecordMessage(
    String^ Message,
    MessageSeverity Severity
) abstract
Parameters
Message (String)
The message to log of type String.
Severity (MessageSeverity)
The severity of the message to log of type MessageSeverity.


ApiLoggerCollection Class

ApiLoggerCollection Class
Namespaces ► eBay.Service.Util ► ApiLoggerCollection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public sealed class ApiLoggerCollection : CollectionBase
<SerializableAttribute> _
Public NotInheritable Class ApiLoggerCollection _
    Inherits CollectionBase
[SerializableAttribute]
public ref class ApiLoggerCollection sealed : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApiLoggerCollection()()()() |
 | ApiLoggerCollection(array<ApiLogger>[]()[][]) |
 | ApiLoggerCollection(ApiLoggerCollection) |
 | Add(ApiLogger) |
 | IList..::..Add(Object) | (Inherited from CollectionBase.)
 | AddRange(array<ApiLogger>[]()[][]) |
 | AddRange(ApiLoggerCollection) |
 | Capacity | (Inherited from CollectionBase.)
 | Clear()()()() | (Inherited from CollectionBase.)
 | Contains(ApiLogger) |
 | IList..::..Contains(Object) | (Inherited from CollectionBase.)
 | CopyTo(array<ApiLogger>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | Count | (Inherited from CollectionBase.)
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetEnumerator()()()() | (Inherited from CollectionBase.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | IndexOf(ApiLogger) |
 | IList..::..IndexOf(Object) | (Inherited from CollectionBase.)
 | InnerList | (Inherited from CollectionBase.)
 | Insert(Int32, ApiLogger) |
 | IList..::..Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IsFixedSize |
 | IList..::..IsFixedSize | (Inherited from CollectionBase.)
 | IsReadOnly |
 | IList..::..IsReadOnly | (Inherited from CollectionBase.)
 | IsSynchronized |
 | ICollection..::..IsSynchronized | (Inherited from CollectionBase.)
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) | (Inherited from CollectionBase.)
 | ItemAt(Int32) |
 | List | (Inherited from CollectionBase.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | OnClear()()()() | (Inherited from CollectionBase.)
 | OnClearComplete()()()() | (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | (Inherited from CollectionBase.)
 | OnValidate(Object) | (Inherited from CollectionBase.)
 | Remove(ApiLogger) |
 | IList..::..Remove(Object) | (Inherited from CollectionBase.)
 | RemoveAt(Int32) | (Inherited from CollectionBase.)
 | SyncRoot |
 | ICollection..::..SyncRoot | (Inherited from CollectionBase.)
 | ToArray()()()() |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | CollectionBase
 |  | ApiLoggerCollection


Add Method (item)

Add Method (item)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► Add(ApiLogger)
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    ApiLogger item
)
Public Function Add ( _
    item As ApiLogger _
) As Integer
public:
int Add(
    ApiLogger^ item
)
Parameters
item (ApiLogger)
Return Value


AddRange Method

AddRange Method
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► AddRange()()()()
Members
Icon | Member | Description
 | AddRange(array<ApiLogger>[]()[][]) |
 | AddRange(ApiLoggerCollection) |


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► AddRange(array<ApiLogger>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ApiLogger[] items
)
Public Sub AddRange ( _
    items As ApiLogger() _
)
public:
void AddRange(
    array<ApiLogger^>^ items
)
Parameters
items (array< ApiLogger >[]()[][])


AddRange Method (items)

AddRange Method (items)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► AddRange(ApiLoggerCollection)
Declaration Syntax
C# Visual Basic Visual C++
public void AddRange(
    ApiLoggerCollection items
)
Public Sub AddRange ( _
    items As ApiLoggerCollection _
)
public:
void AddRange(
    ApiLoggerCollection^ items
)
Parameters
items (ApiLoggerCollection)


ApiLoggerCollection Constructor

ApiLoggerCollection Constructor
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► ApiLoggerCollection()()()()
Members
Icon | Member | Description
 | ApiLoggerCollection()()()() |
 | ApiLoggerCollection(array<ApiLogger>[]()[][]) |
 | ApiLoggerCollection(ApiLoggerCollection) |


ApiLoggerCollection Constructor

ApiLoggerCollection Constructor
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► ApiLoggerCollection()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ApiLoggerCollection()
Public Sub New
public:
ApiLoggerCollection()


ApiLoggerCollection Constructor (items)

ApiLoggerCollection Constructor (items)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► ApiLoggerCollection(array<ApiLogger>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public ApiLoggerCollection(
    ApiLogger[] items
)
Public Sub New ( _
    items As ApiLogger() _
)
public:
ApiLoggerCollection(
    array<ApiLogger^>^ items
)
Parameters
items (array< ApiLogger >[]()[][])
An array of loggers to log to of type ApiLogger.


ApiLoggerCollection Constructor (items)

ApiLoggerCollection Constructor (items)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► ApiLoggerCollection(ApiLoggerCollection)
Declaration Syntax
C# Visual Basic Visual C++
public ApiLoggerCollection(
    ApiLoggerCollection items
)
Public Sub New ( _
    items As ApiLoggerCollection _
)
public:
ApiLoggerCollection(
    ApiLoggerCollection^ items
)
Parameters
items (ApiLoggerCollection)
A collection of loggers to log to of type ApiLoggerCollection.


Contains Method (item)

Contains Method (item)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► Contains(ApiLogger)
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    ApiLogger item
)
Public Function Contains ( _
    item As ApiLogger _
) As Boolean
public:
bool Contains(
    ApiLogger^ item
)
Parameters
item (ApiLogger)
Return Value


CopyTo Method (items, index)

CopyTo Method (items, index)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► CopyTo(array<ApiLogger>[]()[][], Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    ApiLogger[] items,
    int index
)
Public Sub CopyTo ( _
    items As ApiLogger(), _
    index As Integer _
)
public:
void CopyTo(
    array<ApiLogger^>^ items,
    int index
)
Parameters
items (array< ApiLogger >[]()[][])
index (Int32)


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► IndexOf(ApiLogger)
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    ApiLogger item
)
Public Function IndexOf ( _
    item As ApiLogger _
) As Integer
public:
int IndexOf(
    ApiLogger^ item
)
Parameters
item (ApiLogger)
Return Value


Insert Method (index, item)

Insert Method (index, item)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► Insert(Int32, ApiLogger)
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    ApiLogger item
)
Public Sub Insert ( _
    index As Integer, _
    item As ApiLogger _
)
public:
void Insert(
    int index,
    ApiLogger^ item
)
Parameters
index (Int32)
item (ApiLogger)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFixedSize { get; }
Public ReadOnly Property IsFixedSize As Boolean
    Get
public:
property bool IsFixedSize {
    bool get ();
}


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
public:
property bool IsSynchronized {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► Item[([( Int32])])
Declaration Syntax
C# Visual Basic Visual C++
public ApiLogger this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As ApiLogger
    Get
    Set
public:
property ApiLogger^ default[int index] {
    ApiLogger^ get (int index);
    void set (int index, ApiLogger^ value);
}
Parameters
index (Int32)


ItemAt Method (index)

ItemAt Method (index)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► ItemAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ApiLogger ItemAt(
    int index
)
Public Function ItemAt ( _
    index As Integer _
) As ApiLogger
public:
ApiLogger^ ItemAt(
    int index
)
Parameters
index (Int32)
Return Value


Remove Method (item)

Remove Method (item)
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► Remove(ApiLogger)
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    ApiLogger item
)
Public Sub Remove ( _
    item As ApiLogger _
)
public:
void Remove(
    ApiLogger^ item
)
Parameters
item (ApiLogger)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
public:
property Object^ SyncRoot {
    Object^ get ();
}


ToArray Method

ToArray Method
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► ToArray()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ApiLogger[] ToArray()
Public Function ToArray As ApiLogger()
public:
array<ApiLogger^>^ ToArray()
Return Value


AttributeHelper Class

AttributeHelper Class
Namespaces ► eBay.Service.Util ► AttributeHelper
Helper class for attributes.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class AttributeHelper
Public MustInherit Class AttributeHelper
public ref class AttributeHelper abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AttributeHelper()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FindAttribute(AttributeSetType, Int32) | Find an attribute node.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | GetValueID(AttributeSetType, Int32) | Get the first ValueID of an attribute node.
 | GetValueLiteral(AttributeSetType, Int32) | Get the first ValueLiteral of an attribute node.
 | InsertToAttributeSet(AttributeSetType, Int32, Int32, String) | Insert an attribute node to AttributeSetType or update the existing attribute node.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RemoveAttribute(AttributeSetType, Int32) | Remove an attribute from the AttributeSetType object.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
AttributeHelper


AttributeHelper Constructor

AttributeHelper Constructor
Namespaces ► eBay.Service.Util ► AttributeHelper ► AttributeHelper()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected AttributeHelper()
Protected Sub New
protected:
AttributeHelper()


FindAttribute Method (ast, attributeID)

FindAttribute Method (ast, attributeID)
Namespaces ► eBay.Service.Util ► AttributeHelper ► FindAttribute(AttributeSetType, Int32)
Find an attribute node.
Declaration Syntax
C# Visual Basic Visual C++
public static AttributeType FindAttribute(
    AttributeSetType ast,
    int attributeID
)
Public Shared Function FindAttribute ( _
    ast As AttributeSetType, _
    attributeID As Integer _
) As AttributeType
public:
static AttributeType^ FindAttribute(
    AttributeSetType^ ast,
    int attributeID
)
Parameters
ast (AttributeSetType)
attributeID (Int32)
Return Value


GetValueID Method (ast, attributeID)

GetValueID Method (ast, attributeID)
Namespaces ► eBay.Service.Util ► AttributeHelper ► GetValueID(AttributeSetType, Int32)
Get the first ValueID of an attribute node.
Declaration Syntax
C# Visual Basic Visual C++
public static int GetValueID(
    AttributeSetType ast,
    int attributeID
)
Public Shared Function GetValueID ( _
    ast As AttributeSetType, _
    attributeID As Integer _
) As Integer
public:
static int GetValueID(
    AttributeSetType^ ast,
    int attributeID
)
Parameters
ast (AttributeSetType)
attributeID (Int32)
Return Value


GetValueLiteral Method (ast, attributeID)

GetValueLiteral Method (ast, attributeID)
Namespaces ► eBay.Service.Util ► AttributeHelper ► GetValueLiteral(AttributeSetType, Int32)
Get the first ValueLiteral of an attribute node.
Declaration Syntax
C# Visual Basic Visual C++
public static string GetValueLiteral(
    AttributeSetType ast,
    int attributeID
)
Public Shared Function GetValueLiteral ( _
    ast As AttributeSetType, _
    attributeID As Integer _
) As String
public:
static String^ GetValueLiteral(
    AttributeSetType^ ast,
    int attributeID
)
Parameters
ast (AttributeSetType)
attributeID (Int32)
Return Value


InsertToAttributeSet Method (ast, attributeID, valueID, valStr)

InsertToAttributeSet Method (ast, attributeID, valueID, valStr)
Namespaces ► eBay.Service.Util ► AttributeHelper ► InsertToAttributeSet(AttributeSetType, Int32, Int32, String)
Insert an attribute node to AttributeSetType or update the existing attribute node.
Declaration Syntax
C# Visual Basic Visual C++
public static void InsertToAttributeSet(
    AttributeSetType ast,
    int attributeID,
    int valueID,
    string valStr
)
Public Shared Sub InsertToAttributeSet ( _
    ast As AttributeSetType, _
    attributeID As Integer, _
    valueID As Integer, _
    valStr As String _
)
public:
static void InsertToAttributeSet(
    AttributeSetType^ ast,
    int attributeID,
    int valueID,
    String^ valStr
)
Parameters
ast (AttributeSetType)
attributeID (Int32)
valueID (Int32)
valStr (String)


RemoveAttribute Method (ast, attributeID)

RemoveAttribute Method (ast, attributeID)
Namespaces ► eBay.Service.Util ► AttributeHelper ► RemoveAttribute(AttributeSetType, Int32)
Remove an attribute from the AttributeSetType object.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RemoveAttribute(
    AttributeSetType ast,
    int attributeID
)
Public Shared Function RemoveAttribute ( _
    ast As AttributeSetType, _
    attributeID As Integer _
) As Boolean
public:
static bool RemoveAttribute(
    AttributeSetType^ ast,
    int attributeID
)
Parameters
ast (AttributeSetType)
attributeID (Int32)
Return Value
True means the attribute has been found and removed.


ConsoleLogger Class

ConsoleLogger Class
Namespaces ► eBay.Service.Util ► ConsoleLogger
Declaration Syntax
C# Visual Basic Visual C++
public class ConsoleLogger : ApiLogger
Public Class ConsoleLogger _
    Inherits ApiLogger
public ref class ConsoleLogger : public ApiLogger
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConsoleLogger()()()() |
 | ConsoleLogger(Boolean, Boolean, Boolean) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetGetExecutingAssemblyDirectory()()()() | get directory path of eBay.Service.dll (Inherited from ApiLogger.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LogApiMessages | Gets or sets a property that determines if the API Call payloads should be logged. (Inherited from ApiLogger.)
 | LogExceptions | Gets or sets a property that determines if the exceptions should be logged. (Inherited from ApiLogger.)
 | LogInformations | Gets or sets a property that determines if informational messages should be logged. (Inherited from ApiLogger.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RecordMessage(String, MessageSeverity) | (Overrides ApiLogger.RecordMessage(String, MessageSeverity).)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ApiLogger
 |  | ConsoleLogger


ConsoleLogger Constructor

ConsoleLogger Constructor
Namespaces ► eBay.Service.Util ► ConsoleLogger ► ConsoleLogger()()()()
Members
Icon | Member | Description
 | ConsoleLogger()()()() |
 | ConsoleLogger(Boolean, Boolean, Boolean) |


ConsoleLogger Constructor

ConsoleLogger Constructor
Namespaces ► eBay.Service.Util ► ConsoleLogger ► ConsoleLogger()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ConsoleLogger()
Public Sub New
public:
ConsoleLogger()


ConsoleLogger Constructor (LogInformations, LogApiMessages, LogExceptions)

ConsoleLogger Constructor (LogInformations, LogApiMessages, LogExceptions)
Namespaces ► eBay.Service.Util ► ConsoleLogger ► ConsoleLogger(Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public ConsoleLogger(
    bool LogInformations,
    bool LogApiMessages,
    bool LogExceptions
)
Public Sub New ( _
    LogInformations As Boolean, _
    LogApiMessages As Boolean, _
    LogExceptions As Boolean _
)
public:
ConsoleLogger(
    bool LogInformations,
    bool LogApiMessages,
    bool LogExceptions
)
Parameters
LogInformations (Boolean)
LogApiMessages (Boolean)
LogExceptions (Boolean)


RecordMessage Method (Message, Severity)

RecordMessage Method (Message, Severity)
Namespaces ► eBay.Service.Util ► ConsoleLogger ► RecordMessage(String, MessageSeverity)
Declaration Syntax
C# Visual Basic Visual C++
public override void RecordMessage(
    string Message,
    MessageSeverity Severity
)
Public Overrides Sub RecordMessage ( _
    Message As String, _
    Severity As MessageSeverity _
)
public:
virtual void RecordMessage(
    String^ Message,
    MessageSeverity Severity
) override
Parameters
Message (String)
Severity (MessageSeverity)


CurrencyUtility Class

CurrencyUtility Class
Namespaces ► eBay.Service.Util ► CurrencyUtility
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class CurrencyUtility
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class CurrencyUtility
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class CurrencyUtility
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CurrencyUtility()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAmountString(AmountType) | return the string representation of the AmountType
 | GetAmountType(String) | return the AmountType object from an amount string in following format: $amt or (LBP)amt
 | GetCurrencyCodeType(Int32) | Gets the CurrencyCodeType associated with a numeric currency id.
 | GetCurrencyID(CurrencyCodeType) | Gets the numeric currency id of a CurrencyCodeType.
 | GetCurrencySymbol(CurrencyCodeType) | Gets the currency symbol from the CurrencyCodeType
 | GetDefaultCurrencyCodeType(SiteCodeType) | Gets the default CurrencyCodeType associated with a site.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CurrencyUtility


CurrencyUtility Constructor

CurrencyUtility Constructor
Namespaces ► eBay.Service.Util ► CurrencyUtility ► CurrencyUtility()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyUtility()
Public Sub New
public:
CurrencyUtility()


GetAmountString Method (amt)

GetAmountString Method (amt)
Namespaces ► eBay.Service.Util ► CurrencyUtility ► GetAmountString(AmountType)
return the string representation of the AmountType
Declaration Syntax
C# Visual Basic Visual C++
public static string GetAmountString(
    AmountType amt
)
Public Shared Function GetAmountString ( _
    amt As AmountType _
) As String
public:
static String^ GetAmountString(
    AmountType^ amt
)
Parameters
amt (AmountType)
amount
Return Value
string representation of the amount


GetAmountType Method (amtStr)

GetAmountType Method (amtStr)
Namespaces ► eBay.Service.Util ► CurrencyUtility ► GetAmountType(String)
return the AmountType object from an amount string in following format: $amt or (LBP)amt
Declaration Syntax
C# Visual Basic Visual C++
public static AmountType GetAmountType(
    string amtStr
)
Public Shared Function GetAmountType ( _
    amtStr As String _
) As AmountType
public:
static AmountType^ GetAmountType(
    String^ amtStr
)
Parameters
amtStr (String)
an amount string
Return Value
an AmountType


GetCurrencyCodeType Method (CurrencyID)

GetCurrencyCodeType Method (CurrencyID)
Namespaces ► eBay.Service.Util ► CurrencyUtility ► GetCurrencyCodeType(Int32)
Gets the CurrencyCodeType associated with a numeric currency id.
Declaration Syntax
C# Visual Basic Visual C++
public static CurrencyCodeType GetCurrencyCodeType(
    int CurrencyID
)
Public Shared Function GetCurrencyCodeType ( _
    CurrencyID As Integer _
) As CurrencyCodeType
public:
static CurrencyCodeType GetCurrencyCodeType(
    int CurrencyID
)
Parameters
CurrencyID (Int32)
The numeric currency id.
Return Value
The CurrencyCodeType.


GetCurrencyID Method (CurrencyCodeType)

GetCurrencyID Method (CurrencyCodeType)
Namespaces ► eBay.Service.Util ► CurrencyUtility ► GetCurrencyID(CurrencyCodeType)
Gets the numeric currency id of a CurrencyCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public static int GetCurrencyID(
    CurrencyCodeType CurrencyCodeType
)
Public Shared Function GetCurrencyID ( _
    CurrencyCodeType As CurrencyCodeType _
) As Integer
public:
static int GetCurrencyID(
    CurrencyCodeType CurrencyCodeType
)
Parameters
CurrencyCodeType (CurrencyCodeType)
The CurrencyCodeType.
Return Value
The numeric id associated with the CurrencyCodeType.


GetCurrencySymbol Method (currency)

GetCurrencySymbol Method (currency)
Namespaces ► eBay.Service.Util ► CurrencyUtility ► GetCurrencySymbol(CurrencyCodeType)
Gets the currency symbol from the CurrencyCodeType
Declaration Syntax
C# Visual Basic Visual C++
public static string GetCurrencySymbol(
    CurrencyCodeType currency
)
Public Shared Function GetCurrencySymbol ( _
    currency As CurrencyCodeType _
) As String
public:
static String^ GetCurrencySymbol(
    CurrencyCodeType currency
)
Parameters
currency (CurrencyCodeType)
a CurrencyCodeType to get symbol from
Return Value
a currency symbol


GetDefaultCurrencyCodeType Method (SiteCodeType)

GetDefaultCurrencyCodeType Method (SiteCodeType)
Namespaces ► eBay.Service.Util ► CurrencyUtility ► GetDefaultCurrencyCodeType(SiteCodeType)
Gets the default CurrencyCodeType associated with a site.
Declaration Syntax
C# Visual Basic Visual C++
public static CurrencyCodeType GetDefaultCurrencyCodeType(
    SiteCodeType SiteCodeType
)
Public Shared Function GetDefaultCurrencyCodeType ( _
    SiteCodeType As SiteCodeType _
) As CurrencyCodeType
public:
static CurrencyCodeType GetDefaultCurrencyCodeType(
    SiteCodeType SiteCodeType
)
Parameters
SiteCodeType (SiteCodeType)
The SiteCodeType.
Return Value
The CurrencyCodeType.


EBayDetailsHelper Class

EBayDetailsHelper Class
Namespaces ► eBay.Service.Util ► EBayDetailsHelper
Summary description for EBayDetailsHelper.
Declaration Syntax
C# Visual Basic Visual C++
public class EBayDetailsHelper
Public Class EBayDetailsHelper
public ref class EBayDetailsHelper
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | getCountryDetails()()()() |
 | getCountryDetailsByCountryCode(CountryCodeType) |
 | getCurrencyDetails()()()() |
 | getCurrencyDetailsByCurrencyCode(CurrencyCodeType) |
 | getDispatchTimeMaxDetails()()()() |
 | getDispatchTimeMaxDetailsByDispatchTimeMax(Int32) |
 | GetHashCode()()()() | (Inherited from Object.)
 | getInstance(ApiContext) |
 | getPaymentOptionDetailsBySiteAndPaymentMethod(SiteCodeType, BuyerPaymentMethodCodeType) |
 | getPaymentOptionDetailsForSite(SiteCodeType) |
 | getRegionDetailsBySiteAndRegionID(SiteCodeType, String) |
 | getRegionDetailsForSite(SiteCodeType) |
 | getShippingLocationDetails()()()() |
 | getShippingLocationDetailsByShipingLocation(String) |
 | getShippingServiceDetailsBySiteAndShippingServiceID(SiteCodeType, Int32) |
 | getShippingServiceDetailsForSite(SiteCodeType) |
 | getSiteDetails()()()() |
 | getSiteDetailsBySite(SiteCodeType) |
 | getTaxJurisdictionDetailsBySiteAndJurisdictionID(SiteCodeType, String) |
 | getTaxJurisdictionDetailsForSite(SiteCodeType) |
 | getTimeZoneDetails()()()() |
 | getTimeZoneDetailsByZone(String) |
 | GetType()()()() | (Inherited from Object.)
 | getURLDetailsBySiteAndURLType(SiteCodeType, URLTypeCodeType) |
 | getURLDetailsForSite(SiteCodeType) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
EBayDetailsHelper


getCountryDetails Method

getCountryDetails Method
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getCountryDetails()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsTypeCollection getCountryDetails()
Public Function getCountryDetails As CountryDetailsTypeCollection
public:
CountryDetailsTypeCollection^ getCountryDetails()


getCountryDetailsByCountryCode Method (countryCode)

getCountryDetailsByCountryCode Method (countryCode)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getCountryDetailsByCountryCode(CountryCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsType getCountryDetailsByCountryCode(
    CountryCodeType countryCode
)
Public Function getCountryDetailsByCountryCode ( _
    countryCode As CountryCodeType _
) As CountryDetailsType
public:
CountryDetailsType^ getCountryDetailsByCountryCode(
    CountryCodeType countryCode
)
Parameters
countryCode (CountryCodeType)


getCurrencyDetails Method

getCurrencyDetails Method
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getCurrencyDetails()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyDetailsTypeCollection getCurrencyDetails()
Public Function getCurrencyDetails As CurrencyDetailsTypeCollection
public:
CurrencyDetailsTypeCollection^ getCurrencyDetails()


getCurrencyDetailsByCurrencyCode Method (currencyCode)

getCurrencyDetailsByCurrencyCode Method (currencyCode)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getCurrencyDetailsByCurrencyCode(CurrencyCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public CurrencyDetailsType getCurrencyDetailsByCurrencyCode(
    CurrencyCodeType currencyCode
)
Public Function getCurrencyDetailsByCurrencyCode ( _
    currencyCode As CurrencyCodeType _
) As CurrencyDetailsType
public:
CurrencyDetailsType^ getCurrencyDetailsByCurrencyCode(
    CurrencyCodeType currencyCode
)
Parameters
currencyCode (CurrencyCodeType)


getDispatchTimeMaxDetails Method

getDispatchTimeMaxDetails Method
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getDispatchTimeMaxDetails()()()()
Declaration Syntax
C# Visual Basic Visual C++
public DispatchTimeMaxDetailsTypeCollection getDispatchTimeMaxDetails()
Public Function getDispatchTimeMaxDetails As DispatchTimeMaxDetailsTypeCollection
public:
DispatchTimeMaxDetailsTypeCollection^ getDispatchTimeMaxDetails()


getDispatchTimeMaxDetailsByDispatchTimeMax Method (dispatchTimeMax)

getDispatchTimeMaxDetailsByDispatchTimeMax Method (dispatchTimeMax)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getDispatchTimeMaxDetailsByDispatchTimeMax(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public DispatchTimeMaxDetailsType getDispatchTimeMaxDetailsByDispatchTimeMax(
    int dispatchTimeMax
)
Public Function getDispatchTimeMaxDetailsByDispatchTimeMax ( _
    dispatchTimeMax As Integer _
) As DispatchTimeMaxDetailsType
public:
DispatchTimeMaxDetailsType^ getDispatchTimeMaxDetailsByDispatchTimeMax(
    int dispatchTimeMax
)
Parameters
dispatchTimeMax (Int32)


getInstance Method (context)

getInstance Method (context)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getInstance(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public static EBayDetailsHelper getInstance(
    ApiContext context
)
Public Shared Function getInstance ( _
    context As ApiContext _
) As EBayDetailsHelper
public:
static EBayDetailsHelper^ getInstance(
    ApiContext^ context
)
Parameters
context (ApiContext)


getPaymentOptionDetailsBySiteAndPaymentMethod Method (site, paymentMethod)

getPaymentOptionDetailsBySiteAndPaymentMethod Method (site, paymentMethod)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getPaymentOptionDetailsBySiteAndPaymentMethod(SiteCodeType, BuyerPaymentMethodCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionDetailsType getPaymentOptionDetailsBySiteAndPaymentMethod(
    SiteCodeType site,
    BuyerPaymentMethodCodeType paymentMethod
)
Public Function getPaymentOptionDetailsBySiteAndPaymentMethod ( _
    site As SiteCodeType, _
    paymentMethod As BuyerPaymentMethodCodeType _
) As PaymentOptionDetailsType
public:
PaymentOptionDetailsType^ getPaymentOptionDetailsBySiteAndPaymentMethod(
    SiteCodeType site,
    BuyerPaymentMethodCodeType paymentMethod
)
Parameters
site (SiteCodeType)
paymentMethod (BuyerPaymentMethodCodeType)


getPaymentOptionDetailsForSite Method (site)

getPaymentOptionDetailsForSite Method (site)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getPaymentOptionDetailsForSite(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public PaymentOptionDetailsTypeCollection getPaymentOptionDetailsForSite(
    SiteCodeType site
)
Public Function getPaymentOptionDetailsForSite ( _
    site As SiteCodeType _
) As PaymentOptionDetailsTypeCollection
public:
PaymentOptionDetailsTypeCollection^ getPaymentOptionDetailsForSite(
    SiteCodeType site
)
Parameters
site (SiteCodeType)


getRegionDetailsBySiteAndRegionID Method (site, regionId)

getRegionDetailsBySiteAndRegionID Method (site, regionId)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getRegionDetailsBySiteAndRegionID(SiteCodeType, String)
Declaration Syntax
C# Visual Basic Visual C++
public RegionDetailsType getRegionDetailsBySiteAndRegionID(
    SiteCodeType site,
    string regionId
)
Public Function getRegionDetailsBySiteAndRegionID ( _
    site As SiteCodeType, _
    regionId As String _
) As RegionDetailsType
public:
RegionDetailsType^ getRegionDetailsBySiteAndRegionID(
    SiteCodeType site,
    String^ regionId
)
Parameters
site (SiteCodeType)
regionId (String)


getRegionDetailsForSite Method (site)

getRegionDetailsForSite Method (site)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getRegionDetailsForSite(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public RegionDetailsTypeCollection getRegionDetailsForSite(
    SiteCodeType site
)
Public Function getRegionDetailsForSite ( _
    site As SiteCodeType _
) As RegionDetailsTypeCollection
public:
RegionDetailsTypeCollection^ getRegionDetailsForSite(
    SiteCodeType site
)
Parameters
site (SiteCodeType)


getShippingLocationDetails Method

getShippingLocationDetails Method
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getShippingLocationDetails()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingLocationDetailsTypeCollection getShippingLocationDetails()
Public Function getShippingLocationDetails As ShippingLocationDetailsTypeCollection
public:
ShippingLocationDetailsTypeCollection^ getShippingLocationDetails()


getShippingLocationDetailsByShipingLocation Method (shippingLocation)

getShippingLocationDetailsByShipingLocation Method (shippingLocation)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getShippingLocationDetailsByShipingLocation(String)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingLocationDetailsType getShippingLocationDetailsByShipingLocation(
    string shippingLocation
)
Public Function getShippingLocationDetailsByShipingLocation ( _
    shippingLocation As String _
) As ShippingLocationDetailsType
public:
ShippingLocationDetailsType^ getShippingLocationDetailsByShipingLocation(
    String^ shippingLocation
)
Parameters
shippingLocation (String)


getShippingServiceDetailsBySiteAndShippingServiceID Method (site, shippingServiceID)

getShippingServiceDetailsBySiteAndShippingServiceID Method (site, shippingServiceID)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getShippingServiceDetailsBySiteAndShippingServiceID(SiteCodeType, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceDetailsType getShippingServiceDetailsBySiteAndShippingServiceID(
    SiteCodeType site,
    int shippingServiceID
)
Public Function getShippingServiceDetailsBySiteAndShippingServiceID ( _
    site As SiteCodeType, _
    shippingServiceID As Integer _
) As ShippingServiceDetailsType
public:
ShippingServiceDetailsType^ getShippingServiceDetailsBySiteAndShippingServiceID(
    SiteCodeType site,
    int shippingServiceID
)
Parameters
site (SiteCodeType)
shippingServiceID (Int32)


getShippingServiceDetailsForSite Method (site)

getShippingServiceDetailsForSite Method (site)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getShippingServiceDetailsForSite(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceDetailsTypeCollection getShippingServiceDetailsForSite(
    SiteCodeType site
)
Public Function getShippingServiceDetailsForSite ( _
    site As SiteCodeType _
) As ShippingServiceDetailsTypeCollection
public:
ShippingServiceDetailsTypeCollection^ getShippingServiceDetailsForSite(
    SiteCodeType site
)
Parameters
site (SiteCodeType)


getSiteDetails Method

getSiteDetails Method
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getSiteDetails()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteDetailsTypeCollection getSiteDetails()
Public Function getSiteDetails As SiteDetailsTypeCollection
public:
SiteDetailsTypeCollection^ getSiteDetails()


getSiteDetailsBySite Method (site)

getSiteDetailsBySite Method (site)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getSiteDetailsBySite(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public SiteDetailsType getSiteDetailsBySite(
    SiteCodeType site
)
Public Function getSiteDetailsBySite ( _
    site As SiteCodeType _
) As SiteDetailsType
public:
SiteDetailsType^ getSiteDetailsBySite(
    SiteCodeType site
)
Parameters
site (SiteCodeType)


getTaxJurisdictionDetailsBySiteAndJurisdictionID Method (site, jurisdictionID)

getTaxJurisdictionDetailsBySiteAndJurisdictionID Method (site, jurisdictionID)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getTaxJurisdictionDetailsBySiteAndJurisdictionID(SiteCodeType, String)
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionType getTaxJurisdictionDetailsBySiteAndJurisdictionID(
    SiteCodeType site,
    string jurisdictionID
)
Public Function getTaxJurisdictionDetailsBySiteAndJurisdictionID ( _
    site As SiteCodeType, _
    jurisdictionID As String _
) As TaxJurisdictionType
public:
TaxJurisdictionType^ getTaxJurisdictionDetailsBySiteAndJurisdictionID(
    SiteCodeType site,
    String^ jurisdictionID
)
Parameters
site (SiteCodeType)
jurisdictionID (String)


getTaxJurisdictionDetailsForSite Method (site)

getTaxJurisdictionDetailsForSite Method (site)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getTaxJurisdictionDetailsForSite(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public TaxJurisdictionTypeCollection getTaxJurisdictionDetailsForSite(
    SiteCodeType site
)
Public Function getTaxJurisdictionDetailsForSite ( _
    site As SiteCodeType _
) As TaxJurisdictionTypeCollection
public:
TaxJurisdictionTypeCollection^ getTaxJurisdictionDetailsForSite(
    SiteCodeType site
)
Parameters
site (SiteCodeType)


getTimeZoneDetails Method

getTimeZoneDetails Method
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getTimeZoneDetails()()()()
Declaration Syntax
C# Visual Basic Visual C++
public TimeZoneDetailsTypeCollection getTimeZoneDetails()
Public Function getTimeZoneDetails As TimeZoneDetailsTypeCollection
public:
TimeZoneDetailsTypeCollection^ getTimeZoneDetails()


getTimeZoneDetailsByZone Method (zoneId)

getTimeZoneDetailsByZone Method (zoneId)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getTimeZoneDetailsByZone(String)
Declaration Syntax
C# Visual Basic Visual C++
public CountryDetailsType getTimeZoneDetailsByZone(
    string zoneId
)
Public Function getTimeZoneDetailsByZone ( _
    zoneId As String _
) As CountryDetailsType
public:
CountryDetailsType^ getTimeZoneDetailsByZone(
    String^ zoneId
)
Parameters
zoneId (String)


getURLDetailsBySiteAndURLType Method (site, URLType)

getURLDetailsBySiteAndURLType Method (site, URLType)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getURLDetailsBySiteAndURLType(SiteCodeType, URLTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public URLDetailsType getURLDetailsBySiteAndURLType(
    SiteCodeType site,
    URLTypeCodeType URLType
)
Public Function getURLDetailsBySiteAndURLType ( _
    site As SiteCodeType, _
    URLType As URLTypeCodeType _
) As URLDetailsType
public:
URLDetailsType^ getURLDetailsBySiteAndURLType(
    SiteCodeType site,
    URLTypeCodeType URLType
)
Parameters
site (SiteCodeType)
URLType (URLTypeCodeType)


getURLDetailsForSite Method (site)

getURLDetailsForSite Method (site)
Namespaces ► eBay.Service.Util ► EBayDetailsHelper ► getURLDetailsForSite(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public URLDetailsTypeCollection getURLDetailsForSite(
    SiteCodeType site
)
Public Function getURLDetailsForSite ( _
    site As SiteCodeType _
) As URLDetailsTypeCollection
public:
URLDetailsTypeCollection^ getURLDetailsForSite(
    SiteCodeType site
)
Parameters
site (SiteCodeType)


ErrorLanguageUtility Class

ErrorLanguageUtility Class
Namespaces ► eBay.Service.Util ► ErrorLanguageUtility
The default error language is the one used on the site being accessed in the API call. You can change the default to any language, so that the error messages are displayed in the language of your choice.
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class ErrorLanguageUtility
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class ErrorLanguageUtility
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class ErrorLanguageUtility
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ErrorLanguageUtility()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetDefaultErrorLanguageCodeType(SiteCodeType) | Gets the ErrorLanguageCodeType associated with a SiteCodeType.
 | GetDefaultErrorLanguageID(SiteCodeType) | Gets the default numeric error language id associated with a SiteCodeType.
 | GetErrorLanguageCodeType(Int32) | Gets the ErrorLanguageCodeType associated with the numeric error language id.
 | GetErrorLanguageID(ErrorLanguageCodeType) | Gets the numeric error language id from the ErrorLanguageCodeType.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ErrorLanguageUtility


ErrorLanguageUtility Constructor

ErrorLanguageUtility Constructor
Namespaces ► eBay.Service.Util ► ErrorLanguageUtility ► ErrorLanguageUtility()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ErrorLanguageUtility()
Public Sub New
public:
ErrorLanguageUtility()


GetDefaultErrorLanguageCodeType Method (SiteCodeType)

GetDefaultErrorLanguageCodeType Method (SiteCodeType)
Namespaces ► eBay.Service.Util ► ErrorLanguageUtility ► GetDefaultErrorLanguageCodeType(SiteCodeType)
Gets the ErrorLanguageCodeType associated with a SiteCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public static ErrorLanguageCodeType GetDefaultErrorLanguageCodeType(
    SiteCodeType SiteCodeType
)
Public Shared Function GetDefaultErrorLanguageCodeType ( _
    SiteCodeType As SiteCodeType _
) As ErrorLanguageCodeType
public:
static ErrorLanguageCodeType GetDefaultErrorLanguageCodeType(
    SiteCodeType SiteCodeType
)
Parameters
SiteCodeType (SiteCodeType)
The SiteCodeType to resolve.
Return Value
The ErrorLanguageCodeType.


GetDefaultErrorLanguageID Method (SiteCodeType)

GetDefaultErrorLanguageID Method (SiteCodeType)
Namespaces ► eBay.Service.Util ► ErrorLanguageUtility ► GetDefaultErrorLanguageID(SiteCodeType)
Gets the default numeric error language id associated with a SiteCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public static int GetDefaultErrorLanguageID(
    SiteCodeType SiteCodeType
)
Public Shared Function GetDefaultErrorLanguageID ( _
    SiteCodeType As SiteCodeType _
) As Integer
public:
static int GetDefaultErrorLanguageID(
    SiteCodeType SiteCodeType
)
Parameters
SiteCodeType (SiteCodeType)
The SiteCodeType to resolve.
Return Value
The numeric language id.


GetErrorLanguageCodeType Method (ErrorLanguageID)

GetErrorLanguageCodeType Method (ErrorLanguageID)
Namespaces ► eBay.Service.Util ► ErrorLanguageUtility ► GetErrorLanguageCodeType(Int32)
Gets the ErrorLanguageCodeType associated with the numeric error language id.
Declaration Syntax
C# Visual Basic Visual C++
public static ErrorLanguageCodeType GetErrorLanguageCodeType(
    int ErrorLanguageID
)
Public Shared Function GetErrorLanguageCodeType ( _
    ErrorLanguageID As Integer _
) As ErrorLanguageCodeType
public:
static ErrorLanguageCodeType GetErrorLanguageCodeType(
    int ErrorLanguageID
)
Parameters
ErrorLanguageID (Int32)
The numeric language id to resolve.
Return Value
The ErrorLanguageCodeType.


GetErrorLanguageID Method (ErrorLanguageCodeType)

GetErrorLanguageID Method (ErrorLanguageCodeType)
Namespaces ► eBay.Service.Util ► ErrorLanguageUtility ► GetErrorLanguageID(ErrorLanguageCodeType)
Gets the numeric error language id from the ErrorLanguageCodeType.
Declaration Syntax
C# Visual Basic Visual C++
public static int GetErrorLanguageID(
    ErrorLanguageCodeType ErrorLanguageCodeType
)
Public Shared Function GetErrorLanguageID ( _
    ErrorLanguageCodeType As ErrorLanguageCodeType _
) As Integer
public:
static int GetErrorLanguageID(
    ErrorLanguageCodeType ErrorLanguageCodeType
)
Parameters
ErrorLanguageCodeType (ErrorLanguageCodeType)
The ErrorLanguageCodeType to resolve.
Return Value
The numeric error language id.


EventLogger Class

EventLogger Class
Namespaces ► eBay.Service.Util ► EventLogger
Declaration Syntax
C# Visual Basic Visual C++
public class EventLogger : ApiLogger
Public Class EventLogger _
    Inherits ApiLogger
public ref class EventLogger : public ApiLogger
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventLogger()()()() |
 | EventLogger(String, String, String) |
 | EventLogger(String, String, String, Boolean, Boolean, Boolean) |
 | Equals(Object) | (Inherited from Object.)
 | EventLogName |
 | EventLogSource |
 | Finalize()()()() | (Inherited from Object.)
 | GetGetExecutingAssemblyDirectory()()()() | get directory path of eBay.Service.dll (Inherited from ApiLogger.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LogApiMessages | Gets or sets a property that determines if the API Call payloads should be logged. (Inherited from ApiLogger.)
 | LogExceptions | Gets or sets a property that determines if the exceptions should be logged. (Inherited from ApiLogger.)
 | LogInformations | Gets or sets a property that determines if informational messages should be logged. (Inherited from ApiLogger.)
 | MachineName |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RecordMessage(String, MessageSeverity) | (Overrides ApiLogger.RecordMessage(String, MessageSeverity).)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ApiLogger
 |  | EventLogger


EventLogger Constructor

EventLogger Constructor
Namespaces ► eBay.Service.Util ► EventLogger ► EventLogger()()()()
Members
Icon | Member | Description
 | EventLogger()()()() |
 | EventLogger(String, String, String) |
 | EventLogger(String, String, String, Boolean, Boolean, Boolean) |


EventLogger Constructor

EventLogger Constructor
Namespaces ► eBay.Service.Util ► EventLogger ► EventLogger()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EventLogger()
Public Sub New
public:
EventLogger()


EventLogger Constructor (EventLogName, EventLogSource, MachineName)

EventLogger Constructor (EventLogName, EventLogSource, MachineName)
Namespaces ► eBay.Service.Util ► EventLogger ► EventLogger(String, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public EventLogger(
    string EventLogName,
    string EventLogSource,
    string MachineName
)
Public Sub New ( _
    EventLogName As String, _
    EventLogSource As String, _
    MachineName As String _
)
public:
EventLogger(
    String^ EventLogName,
    String^ EventLogSource,
    String^ MachineName
)
Parameters
EventLogName (String)
EventLogSource (String)
MachineName (String)


EventLogger Constructor (EventLogName, EventLogSource, MachineName, LogInformations, LogApiMessages, LogExceptions)

EventLogger Constructor (EventLogName, EventLogSource, MachineName, LogInformations, LogApiMessages, LogExceptions)
Namespaces ► eBay.Service.Util ► EventLogger ► EventLogger(String, String, String, Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public EventLogger(
    string EventLogName,
    string EventLogSource,
    string MachineName,
    bool LogInformations,
    bool LogApiMessages,
    bool LogExceptions
)
Public Sub New ( _
    EventLogName As String, _
    EventLogSource As String, _
    MachineName As String, _
    LogInformations As Boolean, _
    LogApiMessages As Boolean, _
    LogExceptions As Boolean _
)
public:
EventLogger(
    String^ EventLogName,
    String^ EventLogSource,
    String^ MachineName,
    bool LogInformations,
    bool LogApiMessages,
    bool LogExceptions
)
Parameters
EventLogName (String)
EventLogSource (String)
MachineName (String)
LogInformations (Boolean)
LogApiMessages (Boolean)
LogExceptions (Boolean)


EventLogName Property

EventLogName Property
Namespaces ► eBay.Service.Util ► EventLogger ► EventLogName
Declaration Syntax
C# Visual Basic Visual C++
public string EventLogName { get; set; }
Public Property EventLogName As String
    Get
    Set
public:
property String^ EventLogName {
    String^ get ();
    void set (String^ value);
}


EventLogSource Property

EventLogSource Property
Namespaces ► eBay.Service.Util ► EventLogger ► EventLogSource
Declaration Syntax
C# Visual Basic Visual C++
public string EventLogSource { get; set; }
Public Property EventLogSource As String
    Get
    Set
public:
property String^ EventLogSource {
    String^ get ();
    void set (String^ value);
}


MachineName Property

MachineName Property
Namespaces ► eBay.Service.Util ► EventLogger ► MachineName
Declaration Syntax
C# Visual Basic Visual C++
public string MachineName { get; set; }
Public Property MachineName As String
    Get
    Set
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}


RecordMessage Method (Message, Severity)

RecordMessage Method (Message, Severity)
Namespaces ► eBay.Service.Util ► EventLogger ► RecordMessage(String, MessageSeverity)
Declaration Syntax
C# Visual Basic Visual C++
public override void RecordMessage(
    string Message,
    MessageSeverity Severity
)
Public Overrides Sub RecordMessage ( _
    Message As String, _
    Severity As MessageSeverity _
)
public:
virtual void RecordMessage(
    String^ Message,
    MessageSeverity Severity
) override
Parameters
Message (String)
Severity (MessageSeverity)


FileLogger Class

FileLogger Class
Namespaces ► eBay.Service.Util ► FileLogger
Declaration Syntax
C# Visual Basic Visual C++
public class FileLogger : ApiLogger
Public Class FileLogger _
    Inherits ApiLogger
public ref class FileLogger : public ApiLogger
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileLogger()()()() |
 | FileLogger(String) |
 | FileLogger(String, Boolean, Boolean, Boolean) |
 | Close()()()() |
 | Equals(Object) | (Inherited from Object.)
 | FileName |
 | Finalize()()()() | (Inherited from Object.)
 | GetGetExecutingAssemblyDirectory()()()() | get directory path of eBay.Service.dll (Inherited from ApiLogger.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | isAbsolutePath(String) | Gets whether the specified path is a valid absolute file path.
 | LogApiMessages | Gets or sets a property that determines if the API Call payloads should be logged. (Inherited from ApiLogger.)
 | LogExceptions | Gets or sets a property that determines if the exceptions should be logged. (Inherited from ApiLogger.)
 | LogInformations | Gets or sets a property that determines if informational messages should be logged. (Inherited from ApiLogger.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RecordMessage(String, MessageSeverity) | (Overrides ApiLogger.RecordMessage(String, MessageSeverity).)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | ApiLogger
 |  | FileLogger


Close Method

Close Method
Namespaces ► eBay.Service.Util ► FileLogger ► Close()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void Close()
Public Sub Close
public:
void Close()


FileLogger Constructor

FileLogger Constructor
Namespaces ► eBay.Service.Util ► FileLogger ► FileLogger()()()()
Members
Icon | Member | Description
 | FileLogger()()()() |
 | FileLogger(String) |
 | FileLogger(String, Boolean, Boolean, Boolean) |


FileLogger Constructor

FileLogger Constructor
Namespaces ► eBay.Service.Util ► FileLogger ► FileLogger()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FileLogger()
Public Sub New
public:
FileLogger()


FileLogger Constructor (FileName)

FileLogger Constructor (FileName)
Namespaces ► eBay.Service.Util ► FileLogger ► FileLogger(String)
Declaration Syntax
C# Visual Basic Visual C++
public FileLogger(
    string FileName
)
Public Sub New ( _
    FileName As String _
)
public:
FileLogger(
    String^ FileName
)
Parameters
FileName (String)


FileLogger Constructor (FileName, LogInformations, LogApiMessages, LogExceptions)

FileLogger Constructor (FileName, LogInformations, LogApiMessages, LogExceptions)
Namespaces ► eBay.Service.Util ► FileLogger ► FileLogger(String, Boolean, Boolean, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public FileLogger(
    string FileName,
    bool LogInformations,
    bool LogApiMessages,
    bool LogExceptions
)
Public Sub New ( _
    FileName As String, _
    LogInformations As Boolean, _
    LogApiMessages As Boolean, _
    LogExceptions As Boolean _
)
public:
FileLogger(
    String^ FileName,
    bool LogInformations,
    bool LogApiMessages,
    bool LogExceptions
)
Parameters
FileName (String)
LogInformations (Boolean)
LogApiMessages (Boolean)
LogExceptions (Boolean)


FileName Property

FileName Property
Namespaces ► eBay.Service.Util ► FileLogger ► FileName
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}


isAbsolutePath Method (path)

isAbsolutePath Method (path)
Namespaces ► eBay.Service.Util ► FileLogger ► isAbsolutePath(String)
Gets whether the specified path is a valid absolute file path.
Declaration Syntax
C# Visual Basic Visual C++
public bool isAbsolutePath(
    string path
)
Public Function isAbsolutePath ( _
    path As String _
) As Boolean
public:
bool isAbsolutePath(
    String^ path
)
Parameters
path (String)
Any path. OK if null or empty.


RecordMessage Method (Message, Severity)

RecordMessage Method (Message, Severity)
Namespaces ► eBay.Service.Util ► FileLogger ► RecordMessage(String, MessageSeverity)
Declaration Syntax
C# Visual Basic Visual C++
public override void RecordMessage(
    string Message,
    MessageSeverity Severity
)
Public Overrides Sub RecordMessage ( _
    Message As String, _
    Severity As MessageSeverity _
)
public:
virtual void RecordMessage(
    String^ Message,
    MessageSeverity Severity
) override
Parameters
Message (String)
Severity (MessageSeverity)


GetCategoryFeaturesHelper Class

GetCategoryFeaturesHelper Class
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper
Summary description for GetCategoryFeaturesHelper.
Declaration Syntax
C# Visual Basic Visual C++
public class GetCategoryFeaturesHelper
Public Class GetCategoryFeaturesHelper
public ref class GetCategoryFeaturesHelper
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetCategoryFeaturesHelper(ApiContext) |
 | GetCategoryFeaturesHelper(ApiContext, String, Int32, Boolean, FeatureIDCodeTypeCollection, Boolean) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | getCategoryFeature(SiteCodeType, CategoryType) |
 | getCategoryFeature(CategoryType) |
 | getCategoryVersion(SiteCodeType) |
 | getCategoryVersion()()()() |
 | getCurrentSite()()()() |
 | GetHashCode()()()() | (Inherited from Object.)
 | getSiteDefaults(SiteCodeType) |
 | getSiteDefaults()()()() |
 | getSiteFeatures(SiteCodeType) |
 | getSiteFeatures()()()() |
 | GetType()()()() | (Inherited from Object.)
 | hasCategoryFeatures(SiteCodeType) |
 | loadCategoryFeatures(SiteCodeType) |
 | loadCategoryFeatures(ApiContext) |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
GetCategoryFeaturesHelper


getCategoryFeature Method

getCategoryFeature Method
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getCategoryFeature()()()()
Members
Icon | Member | Description
 | getCategoryFeature(SiteCodeType, CategoryType) |
 | getCategoryFeature(CategoryType) |


getCategoryFeature Method (category)

getCategoryFeature Method (category)
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getCategoryFeature(CategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureType getCategoryFeature(
    CategoryType category
)
Public Function getCategoryFeature ( _
    category As CategoryType _
) As CategoryFeatureType
public:
CategoryFeatureType^ getCategoryFeature(
    CategoryType^ category
)
Parameters
category (CategoryType)


getCategoryFeature Method (site, category)

getCategoryFeature Method (site, category)
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getCategoryFeature(SiteCodeType, CategoryType)
Declaration Syntax
C# Visual Basic Visual C++
public CategoryFeatureType getCategoryFeature(
    SiteCodeType site,
    CategoryType category
)
Public Function getCategoryFeature ( _
    site As SiteCodeType, _
    category As CategoryType _
) As CategoryFeatureType
public:
CategoryFeatureType^ getCategoryFeature(
    SiteCodeType site,
    CategoryType^ category
)
Parameters
site (SiteCodeType)
category (CategoryType)


GetCategoryFeaturesHelper Constructor

GetCategoryFeaturesHelper Constructor
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► GetCategoryFeaturesHelper()()()()
Members
Icon | Member | Description
 | GetCategoryFeaturesHelper(ApiContext) |
 | GetCategoryFeaturesHelper(ApiContext, String, Int32, Boolean, FeatureIDCodeTypeCollection, Boolean) |


GetCategoryFeaturesHelper Constructor (ApiContext)

GetCategoryFeaturesHelper Constructor (ApiContext)
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► GetCategoryFeaturesHelper(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryFeaturesHelper(
    ApiContext ApiContext
)
Public Sub New ( _
    ApiContext As ApiContext _
)
public:
GetCategoryFeaturesHelper(
    ApiContext^ ApiContext
)
Parameters
ApiContext (ApiContext)


GetCategoryFeaturesHelper Constructor (ApiContext, CategoryID, LevelLimit, ViewAllNodes, FeatureIDList, AllFeaturesForCategory)

GetCategoryFeaturesHelper Constructor (ApiContext, CategoryID, LevelLimit, ViewAllNodes, FeatureIDList, AllFeaturesForCategory)
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► GetCategoryFeaturesHelper(ApiContext, String, Int32, Boolean, FeatureIDCodeTypeCollection, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryFeaturesHelper(
    ApiContext ApiContext,
    string CategoryID,
    int LevelLimit,
    bool ViewAllNodes,
    FeatureIDCodeTypeCollection FeatureIDList,
    bool AllFeaturesForCategory
)
Public Sub New ( _
    ApiContext As ApiContext, _
    CategoryID As String, _
    LevelLimit As Integer, _
    ViewAllNodes As Boolean, _
    FeatureIDList As FeatureIDCodeTypeCollection, _
    AllFeaturesForCategory As Boolean _
)
public:
GetCategoryFeaturesHelper(
    ApiContext^ ApiContext,
    String^ CategoryID,
    int LevelLimit,
    bool ViewAllNodes,
    FeatureIDCodeTypeCollection^ FeatureIDList,
    bool AllFeaturesForCategory
)
Parameters
ApiContext (ApiContext)
CategoryID (String)
LevelLimit (Int32)
ViewAllNodes (Boolean)
FeatureIDList (FeatureIDCodeTypeCollection)
AllFeaturesForCategory (Boolean)


getCategoryVersion Method

getCategoryVersion Method
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getCategoryVersion()()()()
Members
Icon | Member | Description
 | getCategoryVersion(SiteCodeType) |
 | getCategoryVersion()()()() |


getCategoryVersion Method

getCategoryVersion Method
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getCategoryVersion()()()()
Declaration Syntax
C# Visual Basic Visual C++
public string getCategoryVersion()
Public Function getCategoryVersion As String
public:
String^ getCategoryVersion()


getCategoryVersion Method (site)

getCategoryVersion Method (site)
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getCategoryVersion(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public string getCategoryVersion(
    SiteCodeType site
)
Public Function getCategoryVersion ( _
    site As SiteCodeType _
) As String
public:
String^ getCategoryVersion(
    SiteCodeType site
)
Parameters
site (SiteCodeType)


getCurrentSite Method

getCurrentSite Method
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getCurrentSite()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteCodeType getCurrentSite()
Public Function getCurrentSite As SiteCodeType
public:
SiteCodeType getCurrentSite()


getSiteDefaults Method

getSiteDefaults Method
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getSiteDefaults()()()()
Members
Icon | Member | Description
 | getSiteDefaults(SiteCodeType) |
 | getSiteDefaults()()()() |


getSiteDefaults Method

getSiteDefaults Method
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getSiteDefaults()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteDefaultsType getSiteDefaults()
Public Function getSiteDefaults As SiteDefaultsType
public:
SiteDefaultsType^ getSiteDefaults()


getSiteDefaults Method (site)

getSiteDefaults Method (site)
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getSiteDefaults(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public SiteDefaultsType getSiteDefaults(
    SiteCodeType site
)
Public Function getSiteDefaults ( _
    site As SiteCodeType _
) As SiteDefaultsType
public:
SiteDefaultsType^ getSiteDefaults(
    SiteCodeType site
)
Parameters
site (SiteCodeType)


getSiteFeatures Method

getSiteFeatures Method
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getSiteFeatures()()()()
Members
Icon | Member | Description
 | getSiteFeatures(SiteCodeType) |
 | getSiteFeatures()()()() |


getSiteFeatures Method

getSiteFeatures Method
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getSiteFeatures()()()()
Declaration Syntax
C# Visual Basic Visual C++
public FeatureDefinitionsType getSiteFeatures()
Public Function getSiteFeatures As FeatureDefinitionsType
public:
FeatureDefinitionsType^ getSiteFeatures()


getSiteFeatures Method (site)

getSiteFeatures Method (site)
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► getSiteFeatures(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public FeatureDefinitionsType getSiteFeatures(
    SiteCodeType site
)
Public Function getSiteFeatures ( _
    site As SiteCodeType _
) As FeatureDefinitionsType
public:
FeatureDefinitionsType^ getSiteFeatures(
    SiteCodeType site
)
Parameters
site (SiteCodeType)


hasCategoryFeatures Method (site)

hasCategoryFeatures Method (site)
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► hasCategoryFeatures(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public bool hasCategoryFeatures(
    SiteCodeType site
)
Public Function hasCategoryFeatures ( _
    site As SiteCodeType _
) As Boolean
public:
bool hasCategoryFeatures(
    SiteCodeType site
)
Parameters
site (SiteCodeType)


loadCategoryFeatures Method

loadCategoryFeatures Method
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► loadCategoryFeatures()()()()
Members
Icon | Member | Description
 | loadCategoryFeatures(SiteCodeType) |
 | loadCategoryFeatures(ApiContext) |


loadCategoryFeatures Method (apiContext)

loadCategoryFeatures Method (apiContext)
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► loadCategoryFeatures(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public void loadCategoryFeatures(
    ApiContext apiContext
)
Public Sub loadCategoryFeatures ( _
    apiContext As ApiContext _
)
public:
void loadCategoryFeatures(
    ApiContext^ apiContext
)
Parameters
apiContext (ApiContext)


loadCategoryFeatures Method (site)

loadCategoryFeatures Method (site)
Namespaces ► eBay.Service.Util ► GetCategoryFeaturesHelper ► loadCategoryFeatures(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public void loadCategoryFeatures(
    SiteCodeType site
)
Public Sub loadCategoryFeatures ( _
    site As SiteCodeType _
)
public:
void loadCategoryFeatures(
    SiteCodeType site
)
Parameters
site (SiteCodeType)


MessageSeverity Enumeration

MessageSeverity Enumeration
Namespaces ► eBay.Service.Util ► MessageSeverity
Declaration Syntax
C# Visual Basic Visual C++
public enum MessageSeverity
Public Enumeration MessageSeverity
public enum class MessageSeverity
Members
Member | Description
Informational |
Failure |
Warning |
Error |


MessageType Enumeration

MessageType Enumeration
Namespaces ► eBay.Service.Util ► MessageType
Declaration Syntax
C# Visual Basic Visual C++
public enum MessageType
Public Enumeration MessageType
public enum class MessageType
Members
Member | Description
ApiMessage |
Exception |
Information |


MotorAttributeHelper Class

MotorAttributeHelper Class
Namespaces ► eBay.Service.Util ► MotorAttributeHelper
Helper class to work on motor attributes.
Declaration Syntax
C# Visual Basic Visual C++
public class MotorAttributeHelper
Public Class MotorAttributeHelper
public ref class MotorAttributeHelper
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MotorAttributeHelper(AttributeSetType) | Constructor.
 | DepositAmount | Get or set DepositAmount. Setting 0.0m will remove DepositType and DepositAmount from the attribute list.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | ID_DEPOSITAMOUNT | ID of DepositAmount attribute.
 | ID_DEPOSITTYPE | ID of DepositType attribute.
 | ID_SUBTITLE | ID of Subtitle attribute.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Subtitle | Get or set subtitle. Setting null string will remove Subtitle from the attribute list.
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
MotorAttributeHelper


DepositAmount Property

DepositAmount Property
Namespaces ► eBay.Service.Util ► MotorAttributeHelper ► DepositAmount
Get or set DepositAmount. Setting 0.0m will remove DepositType and DepositAmount from the attribute list.
Declaration Syntax
C# Visual Basic Visual C++
public decimal DepositAmount { get; set; }
Public Property DepositAmount As Decimal
    Get
    Set
public:
property Decimal DepositAmount {
    Decimal get ();
    void set (Decimal value);
}


ID_DEPOSITAMOUNT Field

ID_DEPOSITAMOUNT Field
Namespaces ► eBay.Service.Util ► MotorAttributeHelper ► ID_DEPOSITAMOUNT
ID of DepositAmount attribute.
Declaration Syntax
C# Visual Basic Visual C++
public const int ID_DEPOSITAMOUNT
Public Const ID_DEPOSITAMOUNT As Integer
public:
literal int ID_DEPOSITAMOUNT


ID_DEPOSITTYPE Field

ID_DEPOSITTYPE Field
Namespaces ► eBay.Service.Util ► MotorAttributeHelper ► ID_DEPOSITTYPE
ID of DepositType attribute.
Declaration Syntax
C# Visual Basic Visual C++
public const int ID_DEPOSITTYPE
Public Const ID_DEPOSITTYPE As Integer
public:
literal int ID_DEPOSITTYPE


ID_SUBTITLE Field

ID_SUBTITLE Field
Namespaces ► eBay.Service.Util ► MotorAttributeHelper ► ID_SUBTITLE
ID of Subtitle attribute.
Declaration Syntax
C# Visual Basic Visual C++
public const int ID_SUBTITLE
Public Const ID_SUBTITLE As Integer
public:
literal int ID_SUBTITLE


MotorAttributeHelper Constructor (ast)

MotorAttributeHelper Constructor (ast)
Namespaces ► eBay.Service.Util ► MotorAttributeHelper ► MotorAttributeHelper(AttributeSetType)
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public MotorAttributeHelper(
    AttributeSetType ast
)
Public Sub New ( _
    ast As AttributeSetType _
)
public:
MotorAttributeHelper(
    AttributeSetType^ ast
)
Parameters
ast (AttributeSetType)
The object that contains the motor attributes that you want to access.


Subtitle Property

Subtitle Property
Namespaces ► eBay.Service.Util ► MotorAttributeHelper ► Subtitle
Get or set subtitle. Setting null string will remove Subtitle from the attribute list.
Declaration Syntax
C# Visual Basic Visual C++
public string Subtitle { get; set; }
Public Property Subtitle As String
    Get
    Set
public:
property String^ Subtitle {
    String^ get ();
    void set (String^ value);
}


SdkUtility Class

SdkUtility Class
Namespaces ► eBay.Service.Util ► SdkUtility
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SdkUtility
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SdkUtility
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SdkUtility
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SdkUtility()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LaunchSignInPage(ApiContext, String) | Launches the sign in page for using the Authentication & Authorization feature.
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SdkUtility


LaunchSignInPage Method (Context, SessionID)

LaunchSignInPage Method (Context, SessionID)
Namespaces ► eBay.Service.Util ► SdkUtility ► LaunchSignInPage(ApiContext, String)
Launches the sign in page for using the Authentication & Authorization feature.
Declaration Syntax
C# Visual Basic Visual C++
public static void LaunchSignInPage(
    ApiContext Context,
    string SessionID
)
Public Shared Sub LaunchSignInPage ( _
    Context As ApiContext, _
    SessionID As String _
)
public:
static void LaunchSignInPage(
    ApiContext^ Context,
    String^ SessionID
)
Parameters
Context (ApiContext)
The ApiContext which defines the SignInUrl and RuName.
SessionID (String)
The SessionID which is used by FetchTokenCall to retrieve the token.


SdkUtility Constructor

SdkUtility Constructor
Namespaces ► eBay.Service.Util ► SdkUtility ► SdkUtility()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SdkUtility()
Public Sub New
public:
SdkUtility()


SiteUtility Class

SiteUtility Class
Namespaces ► eBay.Service.Util ► SiteUtility
Declaration Syntax
C# Visual Basic Visual C++
[ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)]
public class SiteUtility
<ClassInterfaceAttribute(ClassInterfaceType.AutoDispatch)> _
Public Class SiteUtility
[ClassInterfaceAttribute(ClassInterfaceType::AutoDispatch)]
public ref class SiteUtility
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SiteUtility()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetCountryCodeType(SiteCodeType) | Gets the CountryCodeType associated with a site.
 | GetHashCode()()()() | (Inherited from Object.)
 | GetSiteCodeType(Int32) | Gets the Site associated with the numeric site id.
 | GetSiteID(SiteCodeType) | Gets the numeric id associated with a site.
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
SiteUtility


GetCountryCodeType Method (SiteCodeType)

GetCountryCodeType Method (SiteCodeType)
Namespaces ► eBay.Service.Util ► SiteUtility ► GetCountryCodeType(SiteCodeType)
Gets the CountryCodeType associated with a site.
Declaration Syntax
C# Visual Basic Visual C++
public static CountryCodeType GetCountryCodeType(
    SiteCodeType SiteCodeType
)
Public Shared Function GetCountryCodeType ( _
    SiteCodeType As SiteCodeType _
) As CountryCodeType
public:
static CountryCodeType GetCountryCodeType(
    SiteCodeType SiteCodeType
)
Parameters
SiteCodeType (SiteCodeType)
The SiteCodeType.
Return Value
CountryCodeType associted with the SiteCodeType.


GetSiteCodeType Method (SiteID)

GetSiteCodeType Method (SiteID)
Namespaces ► eBay.Service.Util ► SiteUtility ► GetSiteCodeType(Int32)
Gets the Site associated with the numeric site id.
Declaration Syntax
C# Visual Basic Visual C++
public static SiteCodeType GetSiteCodeType(
    int SiteID
)
Public Shared Function GetSiteCodeType ( _
    SiteID As Integer _
) As SiteCodeType
public:
static SiteCodeType GetSiteCodeType(
    int SiteID
)
Parameters
SiteID (Int32)
The numeric site id.
Return Value
The SiteCodeType.


GetSiteID Method (SiteCodeType)

GetSiteID Method (SiteCodeType)
Namespaces ► eBay.Service.Util ► SiteUtility ► GetSiteID(SiteCodeType)
Gets the numeric id associated with a site.
Declaration Syntax
C# Visual Basic Visual C++
public static int GetSiteID(
    SiteCodeType SiteCodeType
)
Public Shared Function GetSiteID ( _
    SiteCodeType As SiteCodeType _
) As Integer
public:
static int GetSiteID(
    SiteCodeType SiteCodeType
)
Parameters
SiteCodeType (SiteCodeType)
The SiteCodeType.
Return Value
The numeric id associated with the SiteCodeType.


SiteUtility Constructor

SiteUtility Constructor
Namespaces ► eBay.Service.Util ► SiteUtility ► SiteUtility()()()()
Declaration Syntax
C# Visual Basic Visual C++
public SiteUtility()
Public Sub New
public:
SiteUtility()


XmlUtility Class

XmlUtility Class
Namespaces ► eBay.Service.Util ► XmlUtility
Declaration Syntax
C# Visual Basic Visual C++
[ComVisibleAttribute(false)]
public class XmlUtility
<ComVisibleAttribute(False)> _
Public Class XmlUtility
[ComVisibleAttribute(false)]
public ref class XmlUtility
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | XmlUtility()()()() |
 | AddAttributeNode(XmlDocument, XmlNode, String, Object) |
 | AddChild(XmlDocument, XmlNode, String) |
 | AddChild(XmlDocument, XmlNode, String, String) |
 | AddChild(XmlDocument, XmlNode, String, String, Boolean) |
 | AddChild(XmlDocument, XmlNode, String, Boolean) |
 | AddChild(XmlDocument, XmlNode, String, DateTime, Boolean) |
 | AddChild(XmlDocument, XmlNode, String, Decimal) |
 | AddChild(XmlDocument, XmlNode, String, Double) |
 | AddChild(XmlDocument, XmlNode, String, Int64) |
 | Display(XmlDocument, TextWriter) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | FormatXml(String) | Returns formatted xml string (indent and newlines) from unformatted XML
 | GetBoolean(XPathNavigator, String) |
 | GetBoolean(XPathNavigator, XPathExpression) |
 | GetBoolean(XmlNode, String) |
 | GetChildNode(XPathNavigator, String) |
 | GetChildNode(XPathNavigator, XPathExpression) |
 | GetChildNode(XmlNode, String) |
 | GetDateTime(XPathNavigator, String) |
 | GetDateTime(XPathNavigator, XPathExpression) |
 | GetDateTime(XmlNode, String) |
 | GetDecimal(XPathNavigator, String) |
 | GetDecimal(XPathNavigator, XPathExpression) |
 | GetDecimal(XmlNode, String) |
 | GetDouble(XPathNavigator, String) |
 | GetDouble(XPathNavigator, XPathExpression) |
 | GetDouble(XmlNode, String) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetInteger(XPathNavigator, String) |
 | GetInteger(XPathNavigator, XPathExpression) |
 | GetInteger(XmlNode, String) |
 | GetString(XPathNavigator, String) |
 | GetString(XPathNavigator, XPathExpression) |
 | GetString(XmlNode, String) |
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | NodeExists(XPathNavigator, String) |
 | NodeExists(XPathNavigator, XPathExpression) |
 | NodeExists(XmlNode, String) |
 | ParseEBayDate(String) |
 | ParseEBayTime(String) |
 | ToEBayDate(DateTime) |
 | ToEBayTime(DateTime) |
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
XmlUtility


AddAttributeNode Method (Document, Parent, AttributeName, AttributeValue)

AddAttributeNode Method (Document, Parent, AttributeName, AttributeValue)
Namespaces ► eBay.Service.Util ► XmlUtility ► AddAttributeNode(XmlDocument, XmlNode, String, Object)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode AddAttributeNode(
    XmlDocument Document,
    XmlNode Parent,
    string AttributeName,
    Object AttributeValue
)
Public Shared Function AddAttributeNode ( _
    Document As XmlDocument, _
    Parent As XmlNode, _
    AttributeName As String, _
    AttributeValue As Object _
) As XmlNode
public:
static XmlNode^ AddAttributeNode(
    XmlDocument^ Document,
    XmlNode^ Parent,
    String^ AttributeName,
    Object^ AttributeValue
)
Parameters
Document (XmlDocument)
Parent (XmlNode)
AttributeName (String)
AttributeValue (Object)
Return Value


AddChild Method

AddChild Method
Namespaces ► eBay.Service.Util ► XmlUtility ► AddChild()()()()
Members
Icon | Member | Description
 | AddChild(XmlDocument, XmlNode, String) |
 | AddChild(XmlDocument, XmlNode, String, String) |
 | AddChild(XmlDocument, XmlNode, String, String, Boolean) |
 | AddChild(XmlDocument, XmlNode, String, Boolean) |
 | AddChild(XmlDocument, XmlNode, String, DateTime, Boolean) |
 | AddChild(XmlDocument, XmlNode, String, Decimal) |
 | AddChild(XmlDocument, XmlNode, String, Double) |
 | AddChild(XmlDocument, XmlNode, String, Int64) |


AddChild Method (Document, Parent, NodeName)

AddChild Method (Document, Parent, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► AddChild(XmlDocument, XmlNode, String)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode AddChild(
    XmlDocument Document,
    XmlNode Parent,
    string NodeName
)
Public Shared Function AddChild ( _
    Document As XmlDocument, _
    Parent As XmlNode, _
    NodeName As String _
) As XmlNode
public:
static XmlNode^ AddChild(
    XmlDocument^ Document,
    XmlNode^ Parent,
    String^ NodeName
)
Parameters
Document (XmlDocument)
Parent (XmlNode)
NodeName (String)
Return Value


AddChild Method (Document, Parent, NodeName, Data)

AddChild Method (Document, Parent, NodeName, Data)
Namespaces ► eBay.Service.Util ► XmlUtility ► AddChild(XmlDocument, XmlNode, String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode AddChild(
    XmlDocument Document,
    XmlNode Parent,
    string NodeName,
    bool Data
)
Public Shared Function AddChild ( _
    Document As XmlDocument, _
    Parent As XmlNode, _
    NodeName As String, _
    Data As Boolean _
) As XmlNode
public:
static XmlNode^ AddChild(
    XmlDocument^ Document,
    XmlNode^ Parent,
    String^ NodeName,
    bool Data
)
Parameters
Document (XmlDocument)
Parent (XmlNode)
NodeName (String)
Data (Boolean)
Return Value


AddChild Method (Document, Parent, NodeName, Data)

AddChild Method (Document, Parent, NodeName, Data)
Namespaces ► eBay.Service.Util ► XmlUtility ► AddChild(XmlDocument, XmlNode, String, Decimal)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode AddChild(
    XmlDocument Document,
    XmlNode Parent,
    string NodeName,
    decimal Data
)
Public Shared Function AddChild ( _
    Document As XmlDocument, _
    Parent As XmlNode, _
    NodeName As String, _
    Data As Decimal _
) As XmlNode
public:
static XmlNode^ AddChild(
    XmlDocument^ Document,
    XmlNode^ Parent,
    String^ NodeName,
    Decimal Data
)
Parameters
Document (XmlDocument)
Parent (XmlNode)
NodeName (String)
Data (Decimal)
Return Value


AddChild Method (Document, Parent, NodeName, Data)

AddChild Method (Document, Parent, NodeName, Data)
Namespaces ► eBay.Service.Util ► XmlUtility ► AddChild(XmlDocument, XmlNode, String, Double)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode AddChild(
    XmlDocument Document,
    XmlNode Parent,
    string NodeName,
    double Data
)
Public Shared Function AddChild ( _
    Document As XmlDocument, _
    Parent As XmlNode, _
    NodeName As String, _
    Data As Double _
) As XmlNode
public:
static XmlNode^ AddChild(
    XmlDocument^ Document,
    XmlNode^ Parent,
    String^ NodeName,
    double Data
)
Parameters
Document (XmlDocument)
Parent (XmlNode)
NodeName (String)
Data (Double)
Return Value


AddChild Method (Document, Parent, NodeName, Data)

AddChild Method (Document, Parent, NodeName, Data)
Namespaces ► eBay.Service.Util ► XmlUtility ► AddChild(XmlDocument, XmlNode, String, Int64)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode AddChild(
    XmlDocument Document,
    XmlNode Parent,
    string NodeName,
    long Data
)
Public Shared Function AddChild ( _
    Document As XmlDocument, _
    Parent As XmlNode, _
    NodeName As String, _
    Data As Long _
) As XmlNode
public:
static XmlNode^ AddChild(
    XmlDocument^ Document,
    XmlNode^ Parent,
    String^ NodeName,
    long long Data
)
Parameters
Document (XmlDocument)
Parent (XmlNode)
NodeName (String)
Data (Int64)
Return Value


AddChild Method (Document, Parent, NodeName, Data)

AddChild Method (Document, Parent, NodeName, Data)
Namespaces ► eBay.Service.Util ► XmlUtility ► AddChild(XmlDocument, XmlNode, String, String)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode AddChild(
    XmlDocument Document,
    XmlNode Parent,
    string NodeName,
    string Data
)
Public Shared Function AddChild ( _
    Document As XmlDocument, _
    Parent As XmlNode, _
    NodeName As String, _
    Data As String _
) As XmlNode
public:
static XmlNode^ AddChild(
    XmlDocument^ Document,
    XmlNode^ Parent,
    String^ NodeName,
    String^ Data
)
Parameters
Document (XmlDocument)
Parent (XmlNode)
NodeName (String)
Data (String)
Return Value


AddChild Method (Document, Parent, NodeName, Data, UseCData)

AddChild Method (Document, Parent, NodeName, Data, UseCData)
Namespaces ► eBay.Service.Util ► XmlUtility ► AddChild(XmlDocument, XmlNode, String, String, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode AddChild(
    XmlDocument Document,
    XmlNode Parent,
    string NodeName,
    string Data,
    bool UseCData
)
Public Shared Function AddChild ( _
    Document As XmlDocument, _
    Parent As XmlNode, _
    NodeName As String, _
    Data As String, _
    UseCData As Boolean _
) As XmlNode
public:
static XmlNode^ AddChild(
    XmlDocument^ Document,
    XmlNode^ Parent,
    String^ NodeName,
    String^ Data,
    bool UseCData
)
Parameters
Document (XmlDocument)
Parent (XmlNode)
NodeName (String)
Data (String)
UseCData (Boolean)
Return Value


AddChild Method (Document, Parent, NodeName, Data, UseDateOnly)

AddChild Method (Document, Parent, NodeName, Data, UseDateOnly)
Namespaces ► eBay.Service.Util ► XmlUtility ► AddChild(XmlDocument, XmlNode, String, DateTime, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode AddChild(
    XmlDocument Document,
    XmlNode Parent,
    string NodeName,
    DateTime Data,
    bool UseDateOnly
)
Public Shared Function AddChild ( _
    Document As XmlDocument, _
    Parent As XmlNode, _
    NodeName As String, _
    Data As DateTime, _
    UseDateOnly As Boolean _
) As XmlNode
public:
static XmlNode^ AddChild(
    XmlDocument^ Document,
    XmlNode^ Parent,
    String^ NodeName,
    DateTime Data,
    bool UseDateOnly
)
Parameters
Document (XmlDocument)
Parent (XmlNode)
NodeName (String)
Data (DateTime)
UseDateOnly (Boolean)
Return Value


Display Method (Document, writer)

Display Method (Document, writer)
Namespaces ► eBay.Service.Util ► XmlUtility ► Display(XmlDocument, TextWriter)
Declaration Syntax
C# Visual Basic Visual C++
public static void Display(
    XmlDocument Document,
    TextWriter writer
)
Public Shared Sub Display ( _
    Document As XmlDocument, _
    writer As TextWriter _
)
public:
static void Display(
    XmlDocument^ Document,
    TextWriter^ writer
)
Parameters
Document (XmlDocument)
writer (TextWriter)


FormatXml Method (sUnformattedXml)

FormatXml Method (sUnformattedXml)
Namespaces ► eBay.Service.Util ► XmlUtility ► FormatXml(String)
Returns formatted xml string (indent and newlines) from unformatted XML
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatXml(
    string sUnformattedXml
)
Public Shared Function FormatXml ( _
    sUnformattedXml As String _
) As String
public:
static String^ FormatXml(
    String^ sUnformattedXml
)
Parameters
sUnformattedXml (String)
Unformatted xml string.
Return Value
Formatted xml string and any exceptions that occur.


GetBoolean Method

GetBoolean Method
Namespaces ► eBay.Service.Util ► XmlUtility ► GetBoolean()()()()
Members
Icon | Member | Description
 | GetBoolean(XPathNavigator, String) |
 | GetBoolean(XPathNavigator, XPathExpression) |
 | GetBoolean(XmlNode, String) |


GetBoolean Method (Navigator, NodeName)

GetBoolean Method (Navigator, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetBoolean(XPathNavigator, String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool GetBoolean(
    XPathNavigator Navigator,
    string NodeName
)
Public Shared Function GetBoolean ( _
    Navigator As XPathNavigator, _
    NodeName As String _
) As Boolean
public:
static bool GetBoolean(
    XPathNavigator^ Navigator,
    String^ NodeName
)
Parameters
Navigator (XPathNavigator)
NodeName (String)
Return Value


GetBoolean Method (Navigator, XPath)

GetBoolean Method (Navigator, XPath)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetBoolean(XPathNavigator, XPathExpression)
Declaration Syntax
C# Visual Basic Visual C++
public static bool GetBoolean(
    XPathNavigator Navigator,
    XPathExpression XPath
)
Public Shared Function GetBoolean ( _
    Navigator As XPathNavigator, _
    XPath As XPathExpression _
) As Boolean
public:
static bool GetBoolean(
    XPathNavigator^ Navigator,
    XPathExpression^ XPath
)
Parameters
Navigator (XPathNavigator)
XPath (XPathExpression)
Return Value


GetBoolean Method (Node, NodeName)

GetBoolean Method (Node, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetBoolean(XmlNode, String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool GetBoolean(
    XmlNode Node,
    string NodeName
)
Public Shared Function GetBoolean ( _
    Node As XmlNode, _
    NodeName As String _
) As Boolean
public:
static bool GetBoolean(
    XmlNode^ Node,
    String^ NodeName
)
Parameters
Node (XmlNode)
NodeName (String)
Return Value


GetChildNode Method

GetChildNode Method
Namespaces ► eBay.Service.Util ► XmlUtility ► GetChildNode()()()()
Members
Icon | Member | Description
 | GetChildNode(XPathNavigator, String) |
 | GetChildNode(XPathNavigator, XPathExpression) |
 | GetChildNode(XmlNode, String) |


GetChildNode Method (Navigator, NodeName)

GetChildNode Method (Navigator, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetChildNode(XPathNavigator, String)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode GetChildNode(
    XPathNavigator Navigator,
    string NodeName
)
Public Shared Function GetChildNode ( _
    Navigator As XPathNavigator, _
    NodeName As String _
) As XmlNode
public:
static XmlNode^ GetChildNode(
    XPathNavigator^ Navigator,
    String^ NodeName
)
Parameters
Navigator (XPathNavigator)
NodeName (String)
Return Value


GetChildNode Method (Navigator, XPath)

GetChildNode Method (Navigator, XPath)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetChildNode(XPathNavigator, XPathExpression)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode GetChildNode(
    XPathNavigator Navigator,
    XPathExpression XPath
)
Public Shared Function GetChildNode ( _
    Navigator As XPathNavigator, _
    XPath As XPathExpression _
) As XmlNode
public:
static XmlNode^ GetChildNode(
    XPathNavigator^ Navigator,
    XPathExpression^ XPath
)
Parameters
Navigator (XPathNavigator)
XPath (XPathExpression)
Return Value


GetChildNode Method (Node, NodeName)

GetChildNode Method (Node, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetChildNode(XmlNode, String)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlNode GetChildNode(
    XmlNode Node,
    string NodeName
)
Public Shared Function GetChildNode ( _
    Node As XmlNode, _
    NodeName As String _
) As XmlNode
public:
static XmlNode^ GetChildNode(
    XmlNode^ Node,
    String^ NodeName
)
Parameters
Node (XmlNode)
NodeName (String)
Return Value


GetDateTime Method

GetDateTime Method
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDateTime()()()()
Members
Icon | Member | Description
 | GetDateTime(XPathNavigator, String) |
 | GetDateTime(XPathNavigator, XPathExpression) |
 | GetDateTime(XmlNode, String) |


GetDateTime Method (Navigator, NodeName)

GetDateTime Method (Navigator, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDateTime(XPathNavigator, String)
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime GetDateTime(
    XPathNavigator Navigator,
    string NodeName
)
Public Shared Function GetDateTime ( _
    Navigator As XPathNavigator, _
    NodeName As String _
) As DateTime
public:
static DateTime GetDateTime(
    XPathNavigator^ Navigator,
    String^ NodeName
)
Parameters
Navigator (XPathNavigator)
NodeName (String)
Return Value


GetDateTime Method (Navigator, XPath)

GetDateTime Method (Navigator, XPath)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDateTime(XPathNavigator, XPathExpression)
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime GetDateTime(
    XPathNavigator Navigator,
    XPathExpression XPath
)
Public Shared Function GetDateTime ( _
    Navigator As XPathNavigator, _
    XPath As XPathExpression _
) As DateTime
public:
static DateTime GetDateTime(
    XPathNavigator^ Navigator,
    XPathExpression^ XPath
)
Parameters
Navigator (XPathNavigator)
XPath (XPathExpression)
Return Value


GetDateTime Method (Node, NodeName)

GetDateTime Method (Node, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDateTime(XmlNode, String)
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime GetDateTime(
    XmlNode Node,
    string NodeName
)
Public Shared Function GetDateTime ( _
    Node As XmlNode, _
    NodeName As String _
) As DateTime
public:
static DateTime GetDateTime(
    XmlNode^ Node,
    String^ NodeName
)
Parameters
Node (XmlNode)
NodeName (String)
Return Value


GetDecimal Method

GetDecimal Method
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDecimal()()()()
Members
Icon | Member | Description
 | GetDecimal(XPathNavigator, String) |
 | GetDecimal(XPathNavigator, XPathExpression) |
 | GetDecimal(XmlNode, String) |


GetDecimal Method (Navigator, NodeName)

GetDecimal Method (Navigator, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDecimal(XPathNavigator, String)
Declaration Syntax
C# Visual Basic Visual C++
public static decimal GetDecimal(
    XPathNavigator Navigator,
    string NodeName
)
Public Shared Function GetDecimal ( _
    Navigator As XPathNavigator, _
    NodeName As String _
) As Decimal
public:
static Decimal GetDecimal(
    XPathNavigator^ Navigator,
    String^ NodeName
)
Parameters
Navigator (XPathNavigator)
NodeName (String)
Return Value


GetDecimal Method (Navigator, XPath)

GetDecimal Method (Navigator, XPath)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDecimal(XPathNavigator, XPathExpression)
Declaration Syntax
C# Visual Basic Visual C++
public static decimal GetDecimal(
    XPathNavigator Navigator,
    XPathExpression XPath
)
Public Shared Function GetDecimal ( _
    Navigator As XPathNavigator, _
    XPath As XPathExpression _
) As Decimal
public:
static Decimal GetDecimal(
    XPathNavigator^ Navigator,
    XPathExpression^ XPath
)
Parameters
Navigator (XPathNavigator)
XPath (XPathExpression)
Return Value


GetDecimal Method (Node, NodeName)

GetDecimal Method (Node, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDecimal(XmlNode, String)
Declaration Syntax
C# Visual Basic Visual C++
public static decimal GetDecimal(
    XmlNode Node,
    string NodeName
)
Public Shared Function GetDecimal ( _
    Node As XmlNode, _
    NodeName As String _
) As Decimal
public:
static Decimal GetDecimal(
    XmlNode^ Node,
    String^ NodeName
)
Parameters
Node (XmlNode)
NodeName (String)
Return Value


GetDouble Method

GetDouble Method
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDouble()()()()
Members
Icon | Member | Description
 | GetDouble(XPathNavigator, String) |
 | GetDouble(XPathNavigator, XPathExpression) |
 | GetDouble(XmlNode, String) |


GetDouble Method (Navigator, NodeName)

GetDouble Method (Navigator, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDouble(XPathNavigator, String)
Declaration Syntax
C# Visual Basic Visual C++
public static double GetDouble(
    XPathNavigator Navigator,
    string NodeName
)
Public Shared Function GetDouble ( _
    Navigator As XPathNavigator, _
    NodeName As String _
) As Double
public:
static double GetDouble(
    XPathNavigator^ Navigator,
    String^ NodeName
)
Parameters
Navigator (XPathNavigator)
NodeName (String)
Return Value


GetDouble Method (Navigator, XPath)

GetDouble Method (Navigator, XPath)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDouble(XPathNavigator, XPathExpression)
Declaration Syntax
C# Visual Basic Visual C++
public static double GetDouble(
    XPathNavigator Navigator,
    XPathExpression XPath
)
Public Shared Function GetDouble ( _
    Navigator As XPathNavigator, _
    XPath As XPathExpression _
) As Double
public:
static double GetDouble(
    XPathNavigator^ Navigator,
    XPathExpression^ XPath
)
Parameters
Navigator (XPathNavigator)
XPath (XPathExpression)
Return Value


GetDouble Method (Node, NodeName)

GetDouble Method (Node, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetDouble(XmlNode, String)
Declaration Syntax
C# Visual Basic Visual C++
public static double GetDouble(
    XmlNode Node,
    string NodeName
)
Public Shared Function GetDouble ( _
    Node As XmlNode, _
    NodeName As String _
) As Double
public:
static double GetDouble(
    XmlNode^ Node,
    String^ NodeName
)
Parameters
Node (XmlNode)
NodeName (String)
Return Value


GetInteger Method

GetInteger Method
Namespaces ► eBay.Service.Util ► XmlUtility ► GetInteger()()()()
Members
Icon | Member | Description
 | GetInteger(XPathNavigator, String) |
 | GetInteger(XPathNavigator, XPathExpression) |
 | GetInteger(XmlNode, String) |


GetInteger Method (Navigator, NodeName)

GetInteger Method (Navigator, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetInteger(XPathNavigator, String)
Declaration Syntax
C# Visual Basic Visual C++
public static int GetInteger(
    XPathNavigator Navigator,
    string NodeName
)
Public Shared Function GetInteger ( _
    Navigator As XPathNavigator, _
    NodeName As String _
) As Integer
public:
static int GetInteger(
    XPathNavigator^ Navigator,
    String^ NodeName
)
Parameters
Navigator (XPathNavigator)
NodeName (String)
Return Value


GetInteger Method (Navigator, XPath)

GetInteger Method (Navigator, XPath)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetInteger(XPathNavigator, XPathExpression)
Declaration Syntax
C# Visual Basic Visual C++
public static int GetInteger(
    XPathNavigator Navigator,
    XPathExpression XPath
)
Public Shared Function GetInteger ( _
    Navigator As XPathNavigator, _
    XPath As XPathExpression _
) As Integer
public:
static int GetInteger(
    XPathNavigator^ Navigator,
    XPathExpression^ XPath
)
Parameters
Navigator (XPathNavigator)
XPath (XPathExpression)
Return Value


GetInteger Method (Node, NodeName)

GetInteger Method (Node, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetInteger(XmlNode, String)
Declaration Syntax
C# Visual Basic Visual C++
public static int GetInteger(
    XmlNode Node,
    string NodeName
)
Public Shared Function GetInteger ( _
    Node As XmlNode, _
    NodeName As String _
) As Integer
public:
static int GetInteger(
    XmlNode^ Node,
    String^ NodeName
)
Parameters
Node (XmlNode)
NodeName (String)
Return Value


GetString Method

GetString Method
Namespaces ► eBay.Service.Util ► XmlUtility ► GetString()()()()
Members
Icon | Member | Description
 | GetString(XPathNavigator, String) |
 | GetString(XPathNavigator, XPathExpression) |
 | GetString(XmlNode, String) |


GetString Method (Navigator, NodeName)

GetString Method (Navigator, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetString(XPathNavigator, String)
Declaration Syntax
C# Visual Basic Visual C++
public static string GetString(
    XPathNavigator Navigator,
    string NodeName
)
Public Shared Function GetString ( _
    Navigator As XPathNavigator, _
    NodeName As String _
) As String
public:
static String^ GetString(
    XPathNavigator^ Navigator,
    String^ NodeName
)
Parameters
Navigator (XPathNavigator)
NodeName (String)
Return Value


GetString Method (Navigator, XPath)

GetString Method (Navigator, XPath)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetString(XPathNavigator, XPathExpression)
Declaration Syntax
C# Visual Basic Visual C++
public static string GetString(
    XPathNavigator Navigator,
    XPathExpression XPath
)
Public Shared Function GetString ( _
    Navigator As XPathNavigator, _
    XPath As XPathExpression _
) As String
public:
static String^ GetString(
    XPathNavigator^ Navigator,
    XPathExpression^ XPath
)
Parameters
Navigator (XPathNavigator)
XPath (XPathExpression)
Return Value


GetString Method (Node, NodeName)

GetString Method (Node, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► GetString(XmlNode, String)
Declaration Syntax
C# Visual Basic Visual C++
public static string GetString(
    XmlNode Node,
    string NodeName
)
Public Shared Function GetString ( _
    Node As XmlNode, _
    NodeName As String _
) As String
public:
static String^ GetString(
    XmlNode^ Node,
    String^ NodeName
)
Parameters
Node (XmlNode)
NodeName (String)
Return Value


NodeExists Method

NodeExists Method
Namespaces ► eBay.Service.Util ► XmlUtility ► NodeExists()()()()
Members
Icon | Member | Description
 | NodeExists(XPathNavigator, String) |
 | NodeExists(XPathNavigator, XPathExpression) |
 | NodeExists(XmlNode, String) |


NodeExists Method (Navigator, NodeName)

NodeExists Method (Navigator, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► NodeExists(XPathNavigator, String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool NodeExists(
    XPathNavigator Navigator,
    string NodeName
)
Public Shared Function NodeExists ( _
    Navigator As XPathNavigator, _
    NodeName As String _
) As Boolean
public:
static bool NodeExists(
    XPathNavigator^ Navigator,
    String^ NodeName
)
Parameters
Navigator (XPathNavigator)
NodeName (String)
Return Value


NodeExists Method (Navigator, XPath)

NodeExists Method (Navigator, XPath)
Namespaces ► eBay.Service.Util ► XmlUtility ► NodeExists(XPathNavigator, XPathExpression)
Declaration Syntax
C# Visual Basic Visual C++
public static bool NodeExists(
    XPathNavigator Navigator,
    XPathExpression XPath
)
Public Shared Function NodeExists ( _
    Navigator As XPathNavigator, _
    XPath As XPathExpression _
) As Boolean
public:
static bool NodeExists(
    XPathNavigator^ Navigator,
    XPathExpression^ XPath
)
Parameters
Navigator (XPathNavigator)
XPath (XPathExpression)
Return Value


NodeExists Method (Node, NodeName)

NodeExists Method (Node, NodeName)
Namespaces ► eBay.Service.Util ► XmlUtility ► NodeExists(XmlNode, String)
Declaration Syntax
C# Visual Basic Visual C++
public static bool NodeExists(
    XmlNode Node,
    string NodeName
)
Public Shared Function NodeExists ( _
    Node As XmlNode, _
    NodeName As String _
) As Boolean
public:
static bool NodeExists(
    XmlNode^ Node,
    String^ NodeName
)
Parameters
Node (XmlNode)
NodeName (String)
Return Value


ParseEBayDate Method (Date)

ParseEBayDate Method (Date)
Namespaces ► eBay.Service.Util ► XmlUtility ► ParseEBayDate(String)
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime ParseEBayDate(
    string Date
)
Public Shared Function ParseEBayDate ( _
    Date As String _
) As DateTime
public:
static DateTime ParseEBayDate(
    String^ Date
)
Parameters
Date (String)
Return Value


ParseEBayTime Method (Time)

ParseEBayTime Method (Time)
Namespaces ► eBay.Service.Util ► XmlUtility ► ParseEBayTime(String)
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime ParseEBayTime(
    string Time
)
Public Shared Function ParseEBayTime ( _
    Time As String _
) As DateTime
public:
static DateTime ParseEBayTime(
    String^ Time
)
Parameters
Time (String)
Return Value


ToEBayDate Method (Date)

ToEBayDate Method (Date)
Namespaces ► eBay.Service.Util ► XmlUtility ► ToEBayDate(DateTime)
Declaration Syntax
C# Visual Basic Visual C++
public static string ToEBayDate(
    DateTime Date
)
Public Shared Function ToEBayDate ( _
    Date As DateTime _
) As String
public:
static String^ ToEBayDate(
    DateTime Date
)
Parameters
Date (DateTime)
Return Value


ToEBayTime Method (Time)

ToEBayTime Method (Time)
Namespaces ► eBay.Service.Util ► XmlUtility ► ToEBayTime(DateTime)
Declaration Syntax
C# Visual Basic Visual C++
public static string ToEBayTime(
    DateTime Time
)
Public Shared Function ToEBayTime ( _
    Time As DateTime _
) As String
public:
static String^ ToEBayTime(
    DateTime Time
)
Parameters
Time (DateTime)
Return Value


XmlUtility Constructor

XmlUtility Constructor
Namespaces ► eBay.Service.Util ► XmlUtility ► XmlUtility()()()()
Declaration Syntax
C# Visual Basic Visual C++
public XmlUtility()
Public Sub New
public:
XmlUtility()


Samples.Helper Namespace

Samples.Helper Namespace
Namespaces ► Samples.Helper
Declaration Syntax
C# Visual Basic Visual C++
namespace Samples.Helper
Namespace Samples.Helper
namespace Samples.Helper
Types
All Types Classes
Icon | Type | Description
 | AppSettingHelper | Summary description for ConfigurationSettingHelper.
 | LoggingProperties |
 | PaymentServiceHelper | Summary description for PaymentServiceHelper.
 | ShippingServiceHelper | Summary description for ShippingServiceHelper.


AppSettingHelper Class

AppSettingHelper Class
Namespaces ► Samples.Helper ► AppSettingHelper
Summary description for ConfigurationSettingHelper.
Declaration Syntax
C# Visual Basic Visual C++
public class AppSettingHelper
Public Class AppSettingHelper
public ref class AppSettingHelper
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | API_SERVER_URL |
 | API_TOKEN |
 | API_TOKEN_CREATION_DATE |
 | API_TOKEN_EXP_DATE |
 | API_TOKEN_SECRET |
 | API_TOKEN_SECRET_CREATION_DATE |
 | API_TOKEN2 |
 | APP_ID |
 | CERT_ID |
 | DB_CONNECTION |
 | DEMO_ENV |
 | DEMO_USER |
 | DEV_ID |
 | EBAY_PASSWORD |
 | EBAY_PASSWORD2 |
 | EBAY_USER |
 | EBAY_USER_SITE_ID |
 | EBAY_USER2 |
 | ENABLE_METRICS |
 | ENV_DESC |
 | ENV_NAME |
 | EPS_SERVER_URL |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetApiContext()()()() |
 | GetConfiguration()()()() |
 | GetConfiguration(String) |
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLoggingProperties()()()() |
 | GetType()()()() | (Inherited from Object.)
 | GetUser2ApiContext()()()() |
 | LOG_FILE_NAME |
 | LOG_PAYLOAD_ERROR_CODES |
 | LOG_PAYLOAD_EXCEPTIONS |
 | LOG_PAYLOAD_HTTP_STATUS_CODES |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | RULE_NAME |
 | SaveAppSetting(String, String) |
 | SaveAppSettings()()()() |
 | SaveAppSettings(String) |
 | SaveAppSettings(XmlDocument) |
 | SaveAppSettings(String, XmlDocument) |
 | SetApiContext(ApiContext) |
 | SetAppSetting(String, String) |
 | SIGNIN_URL |
 | TIME_OUT |
 | ToString()()()() | (Inherited from Object.)
 | USER_AUTH_TYPE |
 | USER_DESC |
 | VERSION |
Inheritance Hierarchy
Object
AppSettingHelper

Assembly: Samples.Helper (Module: Samples.Helper)


API_SERVER_URL Field

API_SERVER_URL Field
Namespaces ► Samples.Helper ► AppSettingHelper ► API_SERVER_URL
Declaration Syntax
C# Visual Basic Visual C++
public const string API_SERVER_URL
Public Const API_SERVER_URL As String
public:
literal String^ API_SERVER_URL

Assembly: Samples.Helper (Module: Samples.Helper)


API_TOKEN Field

API_TOKEN Field
Namespaces ► Samples.Helper ► AppSettingHelper ► API_TOKEN
Declaration Syntax
C# Visual Basic Visual C++
public const string API_TOKEN
Public Const API_TOKEN As String
public:
literal String^ API_TOKEN

Assembly: Samples.Helper (Module: Samples.Helper)


API_TOKEN_CREATION_DATE Field

API_TOKEN_CREATION_DATE Field
Namespaces ► Samples.Helper ► AppSettingHelper ► API_TOKEN_CREATION_DATE
Declaration Syntax
C# Visual Basic Visual C++
public const string API_TOKEN_CREATION_DATE
Public Const API_TOKEN_CREATION_DATE As String
public:
literal String^ API_TOKEN_CREATION_DATE

Assembly: Samples.Helper (Module: Samples.Helper)


API_TOKEN_EXP_DATE Field

API_TOKEN_EXP_DATE Field
Namespaces ► Samples.Helper ► AppSettingHelper ► API_TOKEN_EXP_DATE
Declaration Syntax
C# Visual Basic Visual C++
public const string API_TOKEN_EXP_DATE
Public Const API_TOKEN_EXP_DATE As String
public:
literal String^ API_TOKEN_EXP_DATE

Assembly: Samples.Helper (Module: Samples.Helper)


API_TOKEN_SECRET Field

API_TOKEN_SECRET Field
Namespaces ► Samples.Helper ► AppSettingHelper ► API_TOKEN_SECRET
Declaration Syntax
C# Visual Basic Visual C++
public const string API_TOKEN_SECRET
Public Const API_TOKEN_SECRET As String
public:
literal String^ API_TOKEN_SECRET

Assembly: Samples.Helper (Module: Samples.Helper)


API_TOKEN_SECRET_CREATION_DATE Field

API_TOKEN_SECRET_CREATION_DATE Field
Namespaces ► Samples.Helper ► AppSettingHelper ► API_TOKEN_SECRET_CREATION_DATE
Declaration Syntax
C# Visual Basic Visual C++
public const string API_TOKEN_SECRET_CREATION_DATE
Public Const API_TOKEN_SECRET_CREATION_DATE As String
public:
literal String^ API_TOKEN_SECRET_CREATION_DATE

Assembly: Samples.Helper (Module: Samples.Helper)


API_TOKEN2 Field

API_TOKEN2 Field
Namespaces ► Samples.Helper ► AppSettingHelper ► API_TOKEN2
Declaration Syntax
C# Visual Basic Visual C++
public const string API_TOKEN2
Public Const API_TOKEN2 As String
public:
literal String^ API_TOKEN2

Assembly: Samples.Helper (Module: Samples.Helper)


APP_ID Field

APP_ID Field
Namespaces ► Samples.Helper ► AppSettingHelper ► APP_ID
Declaration Syntax
C# Visual Basic Visual C++
public const string APP_ID
Public Const APP_ID As String
public:
literal String^ APP_ID

Assembly: Samples.Helper (Module: Samples.Helper)


CERT_ID Field

CERT_ID Field
Namespaces ► Samples.Helper ► AppSettingHelper ► CERT_ID
Declaration Syntax
C# Visual Basic Visual C++
public const string CERT_ID
Public Const CERT_ID As String
public:
literal String^ CERT_ID

Assembly: Samples.Helper (Module: Samples.Helper)


DB_CONNECTION Field

DB_CONNECTION Field
Namespaces ► Samples.Helper ► AppSettingHelper ► DB_CONNECTION
Declaration Syntax
C# Visual Basic Visual C++
public const string DB_CONNECTION
Public Const DB_CONNECTION As String
public:
literal String^ DB_CONNECTION

Assembly: Samples.Helper (Module: Samples.Helper)


DEMO_ENV Field

DEMO_ENV Field
Namespaces ► Samples.Helper ► AppSettingHelper ► DEMO_ENV
Declaration Syntax
C# Visual Basic Visual C++
public const string DEMO_ENV
Public Const DEMO_ENV As String
public:
literal String^ DEMO_ENV

Assembly: Samples.Helper (Module: Samples.Helper)


DEMO_USER Field

DEMO_USER Field
Namespaces ► Samples.Helper ► AppSettingHelper ► DEMO_USER
Declaration Syntax
C# Visual Basic Visual C++
public const string DEMO_USER
Public Const DEMO_USER As String
public:
literal String^ DEMO_USER

Assembly: Samples.Helper (Module: Samples.Helper)


DEV_ID Field

DEV_ID Field
Namespaces ► Samples.Helper ► AppSettingHelper ► DEV_ID
Declaration Syntax
C# Visual Basic Visual C++
public const string DEV_ID
Public Const DEV_ID As String
public:
literal String^ DEV_ID

Assembly: Samples.Helper (Module: Samples.Helper)


EBAY_PASSWORD Field

EBAY_PASSWORD Field
Namespaces ► Samples.Helper ► AppSettingHelper ► EBAY_PASSWORD
Declaration Syntax
C# Visual Basic Visual C++
public const string EBAY_PASSWORD
Public Const EBAY_PASSWORD As String
public:
literal String^ EBAY_PASSWORD

Assembly: Samples.Helper (Module: Samples.Helper)


EBAY_PASSWORD2 Field

EBAY_PASSWORD2 Field
Namespaces ► Samples.Helper ► AppSettingHelper ► EBAY_PASSWORD2
Declaration Syntax
C# Visual Basic Visual C++
public const string EBAY_PASSWORD2
Public Const EBAY_PASSWORD2 As String
public:
literal String^ EBAY_PASSWORD2

Assembly: Samples.Helper (Module: Samples.Helper)


EBAY_USER Field

EBAY_USER Field
Namespaces ► Samples.Helper ► AppSettingHelper ► EBAY_USER
Declaration Syntax
C# Visual Basic Visual C++
public const string EBAY_USER
Public Const EBAY_USER As String
public:
literal String^ EBAY_USER

Assembly: Samples.Helper (Module: Samples.Helper)


EBAY_USER_SITE_ID Field

EBAY_USER_SITE_ID Field
Namespaces ► Samples.Helper ► AppSettingHelper ► EBAY_USER_SITE_ID
Declaration Syntax
C# Visual Basic Visual C++
public const string EBAY_USER_SITE_ID
Public Const EBAY_USER_SITE_ID As String
public:
literal String^ EBAY_USER_SITE_ID

Assembly: Samples.Helper (Module: Samples.Helper)


EBAY_USER2 Field

EBAY_USER2 Field
Namespaces ► Samples.Helper ► AppSettingHelper ► EBAY_USER2
Declaration Syntax
C# Visual Basic Visual C++
public const string EBAY_USER2
Public Const EBAY_USER2 As String
public:
literal String^ EBAY_USER2

Assembly: Samples.Helper (Module: Samples.Helper)


ENABLE_METRICS Field

ENABLE_METRICS Field
Namespaces ► Samples.Helper ► AppSettingHelper ► ENABLE_METRICS
Declaration Syntax
C# Visual Basic Visual C++
public const string ENABLE_METRICS
Public Const ENABLE_METRICS As String
public:
literal String^ ENABLE_METRICS

Assembly: Samples.Helper (Module: Samples.Helper)


ENV_DESC Field

ENV_DESC Field
Namespaces ► Samples.Helper ► AppSettingHelper ► ENV_DESC
Declaration Syntax
C# Visual Basic Visual C++
public const string ENV_DESC
Public Const ENV_DESC As String
public:
literal String^ ENV_DESC

Assembly: Samples.Helper (Module: Samples.Helper)


ENV_NAME Field

ENV_NAME Field
Namespaces ► Samples.Helper ► AppSettingHelper ► ENV_NAME
Declaration Syntax
C# Visual Basic Visual C++
public const string ENV_NAME
Public Const ENV_NAME As String
public:
literal String^ ENV_NAME

Assembly: Samples.Helper (Module: Samples.Helper)


EPS_SERVER_URL Field

EPS_SERVER_URL Field
Namespaces ► Samples.Helper ► AppSettingHelper ► EPS_SERVER_URL
Declaration Syntax
C# Visual Basic Visual C++
public const string EPS_SERVER_URL
Public Const EPS_SERVER_URL As String
public:
literal String^ EPS_SERVER_URL

Assembly: Samples.Helper (Module: Samples.Helper)


GetApiContext Method

GetApiContext Method
Namespaces ► Samples.Helper ► AppSettingHelper ► GetApiContext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static ApiContext GetApiContext()
Public Shared Function GetApiContext As ApiContext
public:
static ApiContext^ GetApiContext()
Return Value
the API context for the default user

Assembly: Samples.Helper (Module: Samples.Helper)


GetConfiguration Method

GetConfiguration Method
Namespaces ► Samples.Helper ► AppSettingHelper ► GetConfiguration()()()()
Members
Icon | Member | Description
 | GetConfiguration()()()() |
 | GetConfiguration(String) |

Assembly: Samples.Helper (Module: Samples.Helper)


GetConfiguration Method

GetConfiguration Method
Namespaces ► Samples.Helper ► AppSettingHelper ► GetConfiguration()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static XmlDocument GetConfiguration()
Public Shared Function GetConfiguration As XmlDocument
public:
static XmlDocument^ GetConfiguration()
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


GetConfiguration Method (fileName)

GetConfiguration Method (fileName)
Namespaces ► Samples.Helper ► AppSettingHelper ► GetConfiguration(String)
Declaration Syntax
C# Visual Basic Visual C++
public static XmlDocument GetConfiguration(
    string fileName
)
Public Shared Function GetConfiguration ( _
    fileName As String _
) As XmlDocument
public:
static XmlDocument^ GetConfiguration(
    String^ fileName
)
Parameters
fileName (String)
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


GetLoggingProperties Method

GetLoggingProperties Method
Namespaces ► Samples.Helper ► AppSettingHelper ► GetLoggingProperties()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static LoggingProperties GetLoggingProperties()
Public Shared Function GetLoggingProperties As LoggingProperties
public:
static LoggingProperties^ GetLoggingProperties()
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


GetUser2ApiContext Method

GetUser2ApiContext Method
Namespaces ► Samples.Helper ► AppSettingHelper ► GetUser2ApiContext()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static ApiContext GetUser2ApiContext()
Public Shared Function GetUser2ApiContext As ApiContext
public:
static ApiContext^ GetUser2ApiContext()
Return Value
the API context for the second user

Assembly: Samples.Helper (Module: Samples.Helper)


LOG_FILE_NAME Field

LOG_FILE_NAME Field
Namespaces ► Samples.Helper ► AppSettingHelper ► LOG_FILE_NAME
Declaration Syntax
C# Visual Basic Visual C++
public const string LOG_FILE_NAME
Public Const LOG_FILE_NAME As String
public:
literal String^ LOG_FILE_NAME

Assembly: Samples.Helper (Module: Samples.Helper)


LOG_PAYLOAD_ERROR_CODES Field

LOG_PAYLOAD_ERROR_CODES Field
Namespaces ► Samples.Helper ► AppSettingHelper ► LOG_PAYLOAD_ERROR_CODES
Declaration Syntax
C# Visual Basic Visual C++
public const string LOG_PAYLOAD_ERROR_CODES
Public Const LOG_PAYLOAD_ERROR_CODES As String
public:
literal String^ LOG_PAYLOAD_ERROR_CODES

Assembly: Samples.Helper (Module: Samples.Helper)


LOG_PAYLOAD_EXCEPTIONS Field

LOG_PAYLOAD_EXCEPTIONS Field
Namespaces ► Samples.Helper ► AppSettingHelper ► LOG_PAYLOAD_EXCEPTIONS
Declaration Syntax
C# Visual Basic Visual C++
public const string LOG_PAYLOAD_EXCEPTIONS
Public Const LOG_PAYLOAD_EXCEPTIONS As String
public:
literal String^ LOG_PAYLOAD_EXCEPTIONS

Assembly: Samples.Helper (Module: Samples.Helper)


LOG_PAYLOAD_HTTP_STATUS_CODES Field

LOG_PAYLOAD_HTTP_STATUS_CODES Field
Namespaces ► Samples.Helper ► AppSettingHelper ► LOG_PAYLOAD_HTTP_STATUS_CODES
Declaration Syntax
C# Visual Basic Visual C++
public const string LOG_PAYLOAD_HTTP_STATUS_CODES
Public Const LOG_PAYLOAD_HTTP_STATUS_CODES As String
public:
literal String^ LOG_PAYLOAD_HTTP_STATUS_CODES

Assembly: Samples.Helper (Module: Samples.Helper)


RULE_NAME Field

RULE_NAME Field
Namespaces ► Samples.Helper ► AppSettingHelper ► RULE_NAME
Declaration Syntax
C# Visual Basic Visual C++
public const string RULE_NAME
Public Const RULE_NAME As String
public:
literal String^ RULE_NAME

Assembly: Samples.Helper (Module: Samples.Helper)


SaveAppSetting Method (key, val)

SaveAppSetting Method (key, val)
Namespaces ► Samples.Helper ► AppSettingHelper ► SaveAppSetting(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public static void SaveAppSetting(
    string key,
    string val
)
Public Shared Sub SaveAppSetting ( _
    key As String, _
    val As String _
)
public:
static void SaveAppSetting(
    String^ key,
    String^ val
)
Parameters
key (String)
val (String)

Assembly: Samples.Helper (Module: Samples.Helper)


SaveAppSettings Method

SaveAppSettings Method
Namespaces ► Samples.Helper ► AppSettingHelper ► SaveAppSettings()()()()
Members
Icon | Member | Description
 | SaveAppSettings()()()() |
 | SaveAppSettings(String) |
 | SaveAppSettings(XmlDocument) |
 | SaveAppSettings(String, XmlDocument) |

Assembly: Samples.Helper (Module: Samples.Helper)


SaveAppSettings Method

SaveAppSettings Method
Namespaces ► Samples.Helper ► AppSettingHelper ► SaveAppSettings()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static void SaveAppSettings()
Public Shared Sub SaveAppSettings
public:
static void SaveAppSettings()

Assembly: Samples.Helper (Module: Samples.Helper)


SaveAppSettings Method (doc)

SaveAppSettings Method (doc)
Namespaces ► Samples.Helper ► AppSettingHelper ► SaveAppSettings(XmlDocument)
Declaration Syntax
C# Visual Basic Visual C++
public static void SaveAppSettings(
    XmlDocument doc
)
Public Shared Sub SaveAppSettings ( _
    doc As XmlDocument _
)
public:
static void SaveAppSettings(
    XmlDocument^ doc
)
Parameters
doc (XmlDocument)

Assembly: Samples.Helper (Module: Samples.Helper)


SaveAppSettings Method (fileName)

SaveAppSettings Method (fileName)
Namespaces ► Samples.Helper ► AppSettingHelper ► SaveAppSettings(String)
Declaration Syntax
C# Visual Basic Visual C++
public static void SaveAppSettings(
    string fileName
)
Public Shared Sub SaveAppSettings ( _
    fileName As String _
)
public:
static void SaveAppSettings(
    String^ fileName
)
Parameters
fileName (String)

Assembly: Samples.Helper (Module: Samples.Helper)


SaveAppSettings Method (fileName, doc)

SaveAppSettings Method (fileName, doc)
Namespaces ► Samples.Helper ► AppSettingHelper ► SaveAppSettings(String, XmlDocument)
Declaration Syntax
C# Visual Basic Visual C++
public static void SaveAppSettings(
    string fileName,
    XmlDocument doc
)
Public Shared Sub SaveAppSettings ( _
    fileName As String, _
    doc As XmlDocument _
)
public:
static void SaveAppSettings(
    String^ fileName,
    XmlDocument^ doc
)
Parameters
fileName (String)
doc (XmlDocument)

Assembly: Samples.Helper (Module: Samples.Helper)


SetApiContext Method (apiContext)

SetApiContext Method (apiContext)
Namespaces ► Samples.Helper ► AppSettingHelper ► SetApiContext(ApiContext)
Declaration Syntax
C# Visual Basic Visual C++
public static void SetApiContext(
    ApiContext apiContext
)
Public Shared Sub SetApiContext ( _
    apiContext As ApiContext _
)
public:
static void SetApiContext(
    ApiContext^ apiContext
)
Parameters
apiContext (ApiContext)

Assembly: Samples.Helper (Module: Samples.Helper)


SetAppSetting Method (key, val)

SetAppSetting Method (key, val)
Namespaces ► Samples.Helper ► AppSettingHelper ► SetAppSetting(String, String)
Declaration Syntax
C# Visual Basic Visual C++
public static void SetAppSetting(
    string key,
    string val
)
Public Shared Sub SetAppSetting ( _
    key As String, _
    val As String _
)
public:
static void SetAppSetting(
    String^ key,
    String^ val
)
Parameters
key (String)
val (String)

Assembly: Samples.Helper (Module: Samples.Helper)


SIGNIN_URL Field

SIGNIN_URL Field
Namespaces ► Samples.Helper ► AppSettingHelper ► SIGNIN_URL
Declaration Syntax
C# Visual Basic Visual C++
public const string SIGNIN_URL
Public Const SIGNIN_URL As String
public:
literal String^ SIGNIN_URL

Assembly: Samples.Helper (Module: Samples.Helper)


TIME_OUT Field

TIME_OUT Field
Namespaces ► Samples.Helper ► AppSettingHelper ► TIME_OUT
Declaration Syntax
C# Visual Basic Visual C++
public const string TIME_OUT
Public Const TIME_OUT As String
public:
literal String^ TIME_OUT

Assembly: Samples.Helper (Module: Samples.Helper)


USER_AUTH_TYPE Field

USER_AUTH_TYPE Field
Namespaces ► Samples.Helper ► AppSettingHelper ► USER_AUTH_TYPE
Declaration Syntax
C# Visual Basic Visual C++
public const string USER_AUTH_TYPE
Public Const USER_AUTH_TYPE As String
public:
literal String^ USER_AUTH_TYPE

Assembly: Samples.Helper (Module: Samples.Helper)


USER_DESC Field

USER_DESC Field
Namespaces ► Samples.Helper ► AppSettingHelper ► USER_DESC
Declaration Syntax
C# Visual Basic Visual C++
public const string USER_DESC
Public Const USER_DESC As String
public:
literal String^ USER_DESC

Assembly: Samples.Helper (Module: Samples.Helper)


VERSION Field

VERSION Field
Namespaces ► Samples.Helper ► AppSettingHelper ► VERSION
Declaration Syntax
C# Visual Basic Visual C++
public const string VERSION
Public Const VERSION As String
public:
literal String^ VERSION

Assembly: Samples.Helper (Module: Samples.Helper)


LoggingProperties Class

LoggingProperties Class
Namespaces ► Samples.Helper ► LoggingProperties
Declaration Syntax
C# Visual Basic Visual C++
public class LoggingProperties
Public Class LoggingProperties
public ref class LoggingProperties
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoggingProperties()()()() |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | LogFileName |
 | LogPayloadErrorCodes |
 | LogPayloadExceptions |
 | LogPayloadHttpStatusCodes |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
LoggingProperties

Assembly: Samples.Helper (Module: Samples.Helper)


LogFileName Property

LogFileName Property
Namespaces ► Samples.Helper ► LoggingProperties ► LogFileName
Declaration Syntax
C# Visual Basic Visual C++
public string LogFileName { get; set; }
Public Property LogFileName As String
    Get
    Set
public:
property String^ LogFileName {
    String^ get ();
    void set (String^ value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


LoggingProperties Constructor

LoggingProperties Constructor
Namespaces ► Samples.Helper ► LoggingProperties ► LoggingProperties()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LoggingProperties()
Public Sub New
public:
LoggingProperties()

Assembly: Samples.Helper (Module: Samples.Helper)


LogPayloadErrorCodes Property

LogPayloadErrorCodes Property
Namespaces ► Samples.Helper ► LoggingProperties ► LogPayloadErrorCodes
Declaration Syntax
C# Visual Basic Visual C++
public string LogPayloadErrorCodes { get; set; }
Public Property LogPayloadErrorCodes As String
    Get
    Set
public:
property String^ LogPayloadErrorCodes {
    String^ get ();
    void set (String^ value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


LogPayloadExceptions Property

LogPayloadExceptions Property
Namespaces ► Samples.Helper ► LoggingProperties ► LogPayloadExceptions
Declaration Syntax
C# Visual Basic Visual C++
public string LogPayloadExceptions { get; set; }
Public Property LogPayloadExceptions As String
    Get
    Set
public:
property String^ LogPayloadExceptions {
    String^ get ();
    void set (String^ value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


LogPayloadHttpStatusCodes Property

LogPayloadHttpStatusCodes Property
Namespaces ► Samples.Helper ► LoggingProperties ► LogPayloadHttpStatusCodes
Declaration Syntax
C# Visual Basic Visual C++
public string LogPayloadHttpStatusCodes { get; set; }
Public Property LogPayloadHttpStatusCodes As String
    Get
    Set
public:
property String^ LogPayloadHttpStatusCodes {
    String^ get ();
    void set (String^ value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


PaymentServiceHelper Class

PaymentServiceHelper Class
Namespaces ► Samples.Helper ► PaymentServiceHelper
Summary description for PaymentServiceHelper.
Declaration Syntax
C# Visual Basic Visual C++
public class PaymentServiceHelper
Public Class PaymentServiceHelper
public ref class PaymentServiceHelper
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetInstance()()()() |
 | GetPaymentMethods(SiteCodeType) |
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
PaymentServiceHelper

Assembly: Samples.Helper (Module: Samples.Helper)


GetInstance Method

GetInstance Method
Namespaces ► Samples.Helper ► PaymentServiceHelper ► GetInstance()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static PaymentServiceHelper GetInstance()
Public Shared Function GetInstance As PaymentServiceHelper
public:
static PaymentServiceHelper^ GetInstance()
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


GetPaymentMethods Method (site)

GetPaymentMethods Method (site)
Namespaces ► Samples.Helper ► PaymentServiceHelper ► GetPaymentMethods(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem[] GetPaymentMethods(
    SiteCodeType site
)
Public Function GetPaymentMethods ( _
    site As SiteCodeType _
) As ControlTagItem()
public:
array<ControlTagItem^>^ GetPaymentMethods(
    SiteCodeType site
)
Parameters
site (SiteCodeType)
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


ShippingServiceHelper Class

ShippingServiceHelper Class
Namespaces ► Samples.Helper ► ShippingServiceHelper
Summary description for ShippingServiceHelper.
Declaration Syntax
C# Visual Basic Visual C++
public class ShippingServiceHelper
Public Class ShippingServiceHelper
public ref class ShippingServiceHelper
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetInstance()()()() |
 | GetInsuranceOptionControlTagItems(SiteCodeType) |
 | GetInternationalShippingServiceControlTagItems(SiteCodeType) |
 | GetItemShipToLocationControlTagItems(SiteCodeType) |
 | GetServiceShipToLocationControlTagItems(SiteCodeType) |
 | GetShippingPackSizeControlTagItems(SiteCodeType) |
 | GetShippingServiceControlTagItems(SiteCodeType, ShippingTypeCodeType) |
 | GetStateControlTagItems(SiteCodeType) |
 | GetType()()()() | (Inherited from Object.)
 | InitShipToLocations()()()() |
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
ShippingServiceHelper

Assembly: Samples.Helper (Module: Samples.Helper)


GetInstance Method

GetInstance Method
Namespaces ► Samples.Helper ► ShippingServiceHelper ► GetInstance()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static ShippingServiceHelper GetInstance()
Public Shared Function GetInstance As ShippingServiceHelper
public:
static ShippingServiceHelper^ GetInstance()
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


GetInsuranceOptionControlTagItems Method (site)

GetInsuranceOptionControlTagItems Method (site)
Namespaces ► Samples.Helper ► ShippingServiceHelper ► GetInsuranceOptionControlTagItems(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem[] GetInsuranceOptionControlTagItems(
    SiteCodeType site
)
Public Function GetInsuranceOptionControlTagItems ( _
    site As SiteCodeType _
) As ControlTagItem()
public:
array<ControlTagItem^>^ GetInsuranceOptionControlTagItems(
    SiteCodeType site
)
Parameters
site (SiteCodeType)
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


GetInternationalShippingServiceControlTagItems Method (site)

GetInternationalShippingServiceControlTagItems Method (site)
Namespaces ► Samples.Helper ► ShippingServiceHelper ► GetInternationalShippingServiceControlTagItems(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem[] GetInternationalShippingServiceControlTagItems(
    SiteCodeType site
)
Public Function GetInternationalShippingServiceControlTagItems ( _
    site As SiteCodeType _
) As ControlTagItem()
public:
array<ControlTagItem^>^ GetInternationalShippingServiceControlTagItems(
    SiteCodeType site
)
Parameters
site (SiteCodeType)
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


GetItemShipToLocationControlTagItems Method (site)

GetItemShipToLocationControlTagItems Method (site)
Namespaces ► Samples.Helper ► ShippingServiceHelper ► GetItemShipToLocationControlTagItems(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem[] GetItemShipToLocationControlTagItems(
    SiteCodeType site
)
Public Function GetItemShipToLocationControlTagItems ( _
    site As SiteCodeType _
) As ControlTagItem()
public:
array<ControlTagItem^>^ GetItemShipToLocationControlTagItems(
    SiteCodeType site
)
Parameters
site (SiteCodeType)
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


GetServiceShipToLocationControlTagItems Method (site)

GetServiceShipToLocationControlTagItems Method (site)
Namespaces ► Samples.Helper ► ShippingServiceHelper ► GetServiceShipToLocationControlTagItems(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem[] GetServiceShipToLocationControlTagItems(
    SiteCodeType site
)
Public Function GetServiceShipToLocationControlTagItems ( _
    site As SiteCodeType _
) As ControlTagItem()
public:
array<ControlTagItem^>^ GetServiceShipToLocationControlTagItems(
    SiteCodeType site
)
Parameters
site (SiteCodeType)
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


GetShippingPackSizeControlTagItems Method (site)

GetShippingPackSizeControlTagItems Method (site)
Namespaces ► Samples.Helper ► ShippingServiceHelper ► GetShippingPackSizeControlTagItems(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem[] GetShippingPackSizeControlTagItems(
    SiteCodeType site
)
Public Function GetShippingPackSizeControlTagItems ( _
    site As SiteCodeType _
) As ControlTagItem()
public:
array<ControlTagItem^>^ GetShippingPackSizeControlTagItems(
    SiteCodeType site
)
Parameters
site (SiteCodeType)
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


GetShippingServiceControlTagItems Method (site, type)

GetShippingServiceControlTagItems Method (site, type)
Namespaces ► Samples.Helper ► ShippingServiceHelper ► GetShippingServiceControlTagItems(SiteCodeType, ShippingTypeCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem[] GetShippingServiceControlTagItems(
    SiteCodeType site,
    ShippingTypeCodeType type
)
Public Function GetShippingServiceControlTagItems ( _
    site As SiteCodeType, _
    type As ShippingTypeCodeType _
) As ControlTagItem()
public:
array<ControlTagItem^>^ GetShippingServiceControlTagItems(
    SiteCodeType site,
    ShippingTypeCodeType type
)
Parameters
site (SiteCodeType)
type (ShippingTypeCodeType)
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


GetStateControlTagItems Method (site)

GetStateControlTagItems Method (site)
Namespaces ► Samples.Helper ► ShippingServiceHelper ► GetStateControlTagItems(SiteCodeType)
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem[] GetStateControlTagItems(
    SiteCodeType site
)
Public Function GetStateControlTagItems ( _
    site As SiteCodeType _
) As ControlTagItem()
public:
array<ControlTagItem^>^ GetStateControlTagItems(
    SiteCodeType site
)
Parameters
site (SiteCodeType)
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


InitShipToLocations Method

InitShipToLocations Method
Namespaces ► Samples.Helper ► ShippingServiceHelper ► InitShipToLocations()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void InitShipToLocations()
Public Sub InitShipToLocations
public:
void InitShipToLocations()

Assembly: Samples.Helper (Module: Samples.Helper)


Samples.Helper.Cache Namespace

Samples.Helper.Cache Namespace
Namespaces ► Samples.Helper.Cache
Declaration Syntax
C# Visual Basic Visual C++
namespace Samples.Helper.Cache
Namespace Samples.Helper.Cache
namespace Samples.Helper.Cache
Types
All Types Classes
Icon | Type | Description
 | BaseDownloader | Base class for meta-data cache
 | CategoriesDownloader | Helper class with cache function for GetCategories call
 | DetailsDownloader | Helper class with cache function for GeteBayDetails call
 | FeaturesDownloader | Helper class with cache function for GetCategoryFeatures call


BaseDownloader Class

BaseDownloader Class
Namespaces ► Samples.Helper.Cache ► BaseDownloader
Base class for meta-data cache
Declaration Syntax
C# Visual Basic Visual C++
public abstract class BaseDownloader
Public MustInherit Class BaseDownloader
public ref class BaseDownloader abstract
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BaseDownloader()()()() |
 | callApi()()()() | subclass should implement specific API call
 | context | ApiContext object
 | Equals(Object) | (Inherited from Object.)
 | filePrefix | cached file prefix, must be explicitly set by subclass.
 | fileSuffix | cached file suffix, must be explicitly set by subclass.
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | getLastUpdateTime()()()() | ssubclass should implement specific API call to get last update time
 | getObject()()()() | get object from xml data
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | objType | object type of the cached data, must be explicitly set by subclass
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseDownloader
 |  | CategoriesDownloader
 |  | DetailsDownloader
 |  | FeaturesDownloader

Assembly: Samples.Helper (Module: Samples.Helper)


BaseDownloader Constructor

BaseDownloader Constructor
Namespaces ► Samples.Helper.Cache ► BaseDownloader ► BaseDownloader()()()()
Declaration Syntax
C# Visual Basic Visual C++
protected BaseDownloader()
Protected Sub New
protected:
BaseDownloader()

Assembly: Samples.Helper (Module: Samples.Helper)


callApi Method

callApi Method
Namespaces ► Samples.Helper.Cache ► BaseDownloader ► callApi()()()()
subclass should implement specific API call
Declaration Syntax
C# Visual Basic Visual C++
protected abstract Object callApi()
Protected MustOverride Function callApi As Object
protected:
virtual Object^ callApi() abstract

Assembly: Samples.Helper (Module: Samples.Helper)


context Field

context Field
Namespaces ► Samples.Helper.Cache ► BaseDownloader ► context
ApiContext object
Declaration Syntax
C# Visual Basic Visual C++
protected ApiContext context
Protected context As ApiContext
protected:
ApiContext^ context

Assembly: Samples.Helper (Module: Samples.Helper)


filePrefix Field

filePrefix Field
Namespaces ► Samples.Helper.Cache ► BaseDownloader ► filePrefix
cached file prefix, must be explicitly set by subclass.
Declaration Syntax
C# Visual Basic Visual C++
protected string filePrefix
Protected filePrefix As String
protected:
String^ filePrefix

Assembly: Samples.Helper (Module: Samples.Helper)


fileSuffix Field

fileSuffix Field
Namespaces ► Samples.Helper.Cache ► BaseDownloader ► fileSuffix
cached file suffix, must be explicitly set by subclass.
Declaration Syntax
C# Visual Basic Visual C++
protected string fileSuffix
Protected fileSuffix As String
protected:
String^ fileSuffix

Assembly: Samples.Helper (Module: Samples.Helper)


getLastUpdateTime Method

getLastUpdateTime Method
Namespaces ► Samples.Helper.Cache ► BaseDownloader ► getLastUpdateTime()()()()
ssubclass should implement specific API call to get last update time
Declaration Syntax
C# Visual Basic Visual C++
protected abstract string getLastUpdateTime()
Protected MustOverride Function getLastUpdateTime As String
protected:
virtual String^ getLastUpdateTime() abstract

Assembly: Samples.Helper (Module: Samples.Helper)


getObject Method

getObject Method
Namespaces ► Samples.Helper.Cache ► BaseDownloader ► getObject()()()()
get object from xml data
Declaration Syntax
C# Visual Basic Visual C++
protected Object getObject()
Protected Function getObject As Object
protected:
Object^ getObject()
Return Value
generic object

Assembly: Samples.Helper (Module: Samples.Helper)


objType Field

objType Field
Namespaces ► Samples.Helper.Cache ► BaseDownloader ► objType
object type of the cached data, must be explicitly set by subclass
Declaration Syntax
C# Visual Basic Visual C++
protected Type objType
Protected objType As Type
protected:
Type^ objType

Assembly: Samples.Helper (Module: Samples.Helper)


CategoriesDownloader Class

CategoriesDownloader Class
Namespaces ► Samples.Helper.Cache ► CategoriesDownloader
Helper class with cache function for GetCategories call
Declaration Syntax
C# Visual Basic Visual C++
public class CategoriesDownloader : BaseDownloader
Public Class CategoriesDownloader _
    Inherits BaseDownloader
public ref class CategoriesDownloader : public BaseDownloader
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CategoriesDownloader(ApiContext) | Constructor
 | callApi()()()() | call GetCategories to get all categories for a given site (Overrides BaseDownloader.callApi()()()().)
 | context | ApiContext object (Inherited from BaseDownloader.)
 | Equals(Object) | (Inherited from Object.)
 | filePrefix | cached file prefix, must be explicitly set by subclass. (Inherited from BaseDownloader.)
 | fileSuffix | cached file suffix, must be explicitly set by subclass. (Inherited from BaseDownloader.)
 | Finalize()()()() | (Inherited from Object.)
 | GetAllCategories()()()() | Get all categories for a given site
 | GetHashCode()()()() | (Inherited from Object.)
 | getLastUpdateTime()()()() | get last update time from site (Overrides BaseDownloader.getLastUpdateTime()()()().)
 | getObject()()()() | get object from xml data (Inherited from BaseDownloader.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | objType | object type of the cached data, must be explicitly set by subclass (Inherited from BaseDownloader.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseDownloader
 |  | CategoriesDownloader

Assembly: Samples.Helper (Module: Samples.Helper)


callApi Method

callApi Method
Namespaces ► Samples.Helper.Cache ► CategoriesDownloader ► callApi()()()()
call GetCategories to get all categories for a given site
Declaration Syntax
C# Visual Basic Visual C++
protected override Object callApi()
Protected Overrides Function callApi As Object
protected:
virtual Object^ callApi() override
Return Value
generic object

Assembly: Samples.Helper (Module: Samples.Helper)


CategoriesDownloader Constructor (context)

CategoriesDownloader Constructor (context)
Namespaces ► Samples.Helper.Cache ► CategoriesDownloader ► CategoriesDownloader(ApiContext)
Constructor
Declaration Syntax
C# Visual Basic Visual C++
public CategoriesDownloader(
    ApiContext context
)
Public Sub New ( _
    context As ApiContext _
)
public:
CategoriesDownloader(
    ApiContext^ context
)
Parameters
context (ApiContext)

Assembly: Samples.Helper (Module: Samples.Helper)


GetAllCategories Method

GetAllCategories Method
Namespaces ► Samples.Helper.Cache ► CategoriesDownloader ► GetAllCategories()()()()
Get all categories for a given site
Declaration Syntax
C# Visual Basic Visual C++
public CategoryTypeCollection GetAllCategories()
Public Function GetAllCategories As CategoryTypeCollection
public:
CategoryTypeCollection^ GetAllCategories()

Assembly: Samples.Helper (Module: Samples.Helper)


getLastUpdateTime Method

getLastUpdateTime Method
Namespaces ► Samples.Helper.Cache ► CategoriesDownloader ► getLastUpdateTime()()()()
get last update time from site
Declaration Syntax
C# Visual Basic Visual C++
protected override string getLastUpdateTime()
Protected Overrides Function getLastUpdateTime As String
protected:
virtual String^ getLastUpdateTime() override
Return Value
string

Assembly: Samples.Helper (Module: Samples.Helper)


DetailsDownloader Class

DetailsDownloader Class
Namespaces ► Samples.Helper.Cache ► DetailsDownloader
Helper class with cache function for GeteBayDetails call
Declaration Syntax
C# Visual Basic Visual C++
public class DetailsDownloader : BaseDownloader
Public Class DetailsDownloader _
    Inherits BaseDownloader
public ref class DetailsDownloader : public BaseDownloader
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DetailsDownloader(ApiContext) | Constructor
 | callApi()()()() | call GeteBayDetails to get eBay details for a given site (Overrides BaseDownloader.callApi()()()().)
 | context | ApiContext object (Inherited from BaseDownloader.)
 | Equals(Object) | (Inherited from Object.)
 | filePrefix | cached file prefix, must be explicitly set by subclass. (Inherited from BaseDownloader.)
 | fileSuffix | cached file suffix, must be explicitly set by subclass. (Inherited from BaseDownloader.)
 | Finalize()()()() | (Inherited from Object.)
 | GeteBayDetails()()()() | Get eBay details
 | GetHashCode()()()() | (Inherited from Object.)
 | getLastUpdateTime()()()() | get last update time from site (Overrides BaseDownloader.getLastUpdateTime()()()().)
 | getObject()()()() | get object from xml data (Inherited from BaseDownloader.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | objType | object type of the cached data, must be explicitly set by subclass (Inherited from BaseDownloader.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseDownloader
 |  | DetailsDownloader

Assembly: Samples.Helper (Module: Samples.Helper)


callApi Method

callApi Method
Namespaces ► Samples.Helper.Cache ► DetailsDownloader ► callApi()()()()
call GeteBayDetails to get eBay details for a given site
Declaration Syntax
C# Visual Basic Visual C++
protected override Object callApi()
Protected Overrides Function callApi As Object
protected:
virtual Object^ callApi() override
Return Value
generic object

Assembly: Samples.Helper (Module: Samples.Helper)


DetailsDownloader Constructor (context)

DetailsDownloader Constructor (context)
Namespaces ► Samples.Helper.Cache ► DetailsDownloader ► DetailsDownloader(ApiContext)
Constructor
Declaration Syntax
C# Visual Basic Visual C++
public DetailsDownloader(
    ApiContext context
)
Public Sub New ( _
    context As ApiContext _
)
public:
DetailsDownloader(
    ApiContext^ context
)
Parameters
context (ApiContext)

Assembly: Samples.Helper (Module: Samples.Helper)


GeteBayDetails Method

GeteBayDetails Method
Namespaces ► Samples.Helper.Cache ► DetailsDownloader ► GeteBayDetails()()()()
Get eBay details
Declaration Syntax
C# Visual Basic Visual C++
public GeteBayDetailsResponseType GeteBayDetails()
Public Function GeteBayDetails As GeteBayDetailsResponseType
public:
GeteBayDetailsResponseType^ GeteBayDetails()

Assembly: Samples.Helper (Module: Samples.Helper)


getLastUpdateTime Method

getLastUpdateTime Method
Namespaces ► Samples.Helper.Cache ► DetailsDownloader ► getLastUpdateTime()()()()
get last update time from site
Declaration Syntax
C# Visual Basic Visual C++
protected override string getLastUpdateTime()
Protected Overrides Function getLastUpdateTime As String
protected:
virtual String^ getLastUpdateTime() override
Return Value
string

Assembly: Samples.Helper (Module: Samples.Helper)


FeaturesDownloader Class

FeaturesDownloader Class
Namespaces ► Samples.Helper.Cache ► FeaturesDownloader
Helper class with cache function for GetCategoryFeatures call
Declaration Syntax
C# Visual Basic Visual C++
public class FeaturesDownloader : BaseDownloader
Public Class FeaturesDownloader _
    Inherits BaseDownloader
public ref class FeaturesDownloader : public BaseDownloader
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FeaturesDownloader(ApiContext) | Constructor
 | callApi()()()() | call GetCategories to get all categories for a given site (Overrides BaseDownloader.callApi()()()().)
 | context | ApiContext object (Inherited from BaseDownloader.)
 | Equals(Object) | (Inherited from Object.)
 | filePrefix | cached file prefix, must be explicitly set by subclass. (Inherited from BaseDownloader.)
 | fileSuffix | cached file suffix, must be explicitly set by subclass. (Inherited from BaseDownloader.)
 | Finalize()()()() | (Inherited from Object.)
 | GetCategoryFeatures()()()() | Get all features for a given category
 | GetHashCode()()()() | (Inherited from Object.)
 | getLastUpdateTime()()()() | get last update time from site (Overrides BaseDownloader.getLastUpdateTime()()()().)
 | getObject()()()() | get object from xml data (Inherited from BaseDownloader.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | objType | object type of the cached data, must be explicitly set by subclass (Inherited from BaseDownloader.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
 | BaseDownloader
 |  | FeaturesDownloader

Assembly: Samples.Helper (Module: Samples.Helper)


callApi Method

callApi Method
Namespaces ► Samples.Helper.Cache ► FeaturesDownloader ► callApi()()()()
call GetCategories to get all categories for a given site
Declaration Syntax
C# Visual Basic Visual C++
protected override Object callApi()
Protected Overrides Function callApi As Object
protected:
virtual Object^ callApi() override
Return Value
generic object

Assembly: Samples.Helper (Module: Samples.Helper)


FeaturesDownloader Constructor (context)

FeaturesDownloader Constructor (context)
Namespaces ► Samples.Helper.Cache ► FeaturesDownloader ► FeaturesDownloader(ApiContext)
Constructor
Declaration Syntax
C# Visual Basic Visual C++
public FeaturesDownloader(
    ApiContext context
)
Public Sub New ( _
    context As ApiContext _
)
public:
FeaturesDownloader(
    ApiContext^ context
)
Parameters
context (ApiContext)

Assembly: Samples.Helper (Module: Samples.Helper)


GetCategoryFeatures Method

GetCategoryFeatures Method
Namespaces ► Samples.Helper.Cache ► FeaturesDownloader ► GetCategoryFeatures()()()()
Get all features for a given category
Declaration Syntax
C# Visual Basic Visual C++
public GetCategoryFeaturesResponseType GetCategoryFeatures()
Public Function GetCategoryFeatures As GetCategoryFeaturesResponseType
public:
GetCategoryFeaturesResponseType^ GetCategoryFeatures()

Assembly: Samples.Helper (Module: Samples.Helper)


getLastUpdateTime Method

getLastUpdateTime Method
Namespaces ► Samples.Helper.Cache ► FeaturesDownloader ► getLastUpdateTime()()()()
get last update time from site
Declaration Syntax
C# Visual Basic Visual C++
protected override string getLastUpdateTime()
Protected Overrides Function getLastUpdateTime As String
protected:
virtual String^ getLastUpdateTime() override
Return Value
string

Assembly: Samples.Helper (Module: Samples.Helper)


Samples.Helper.UI Namespace

Samples.Helper.UI Namespace
Namespaces ► Samples.Helper.UI
Declaration Syntax
C# Visual Basic Visual C++
namespace Samples.Helper.UI
Namespace Samples.Helper.UI
namespace Samples.Helper.UI
Types
All Types Classes Structures Interfaces
Icon | Type | Description
 | CheckBoxControlBuilder | Summary description for CheckBoxControlBuilder.
 | CheckBoxGroupControl | Summary description for UserControl1.
 | ControlTagItem | A helper class for associate string with an object.
 | EditListView |
 | HeaderInfo |
 | IControlTagItem | Defines object to associate object with string.
 | InternationalShippingServiceControl | Summary description for InternationalShippingServiceControl.
 | IntlShippingServiceListView | Summary description for ShippingServiceListView.
 | ShippingServiceControl | Summary description for ShippingServiceControl.
 | ShippingServiceListView | Summary description for ShippingServiceListView.


CheckBoxControlBuilder Class

CheckBoxControlBuilder Class
Namespaces ► Samples.Helper.UI ► CheckBoxControlBuilder
Summary description for CheckBoxControlBuilder.
Declaration Syntax
C# Visual Basic Visual C++
public class CheckBoxControlBuilder
Public Class CheckBoxControlBuilder
public ref class CheckBoxControlBuilder
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CreateCheckBoxControls(Panel, array<String>[]()[][], Int32, Int32, Int32, Int32) |
 | CreateCheckBoxControls(Panel, array<ControlTagItem>[]()[][], Int32, Int32, Int32, Int32) |
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | ToString()()()() | (Inherited from Object.)
Inheritance Hierarchy
Object
CheckBoxControlBuilder

Assembly: Samples.Helper (Module: Samples.Helper)


CreateCheckBoxControls Method

CreateCheckBoxControls Method
Namespaces ► Samples.Helper.UI ► CheckBoxControlBuilder ► CreateCheckBoxControls()()()()
Members
Icon | Member | Description
 | CreateCheckBoxControls(Panel, array<String>[]()[][], Int32, Int32, Int32, Int32) |
 | CreateCheckBoxControls(Panel, array<ControlTagItem>[]()[][], Int32, Int32, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


CreateCheckBoxControls Method (panel, items, xOffset, yOffset, height, widthFactor)

CreateCheckBoxControls Method (panel, items, xOffset, yOffset, height, widthFactor)
Namespaces ► Samples.Helper.UI ► CheckBoxControlBuilder ► CreateCheckBoxControls(Panel, array<ControlTagItem>[]()[][], Int32, Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static CheckBox[] CreateCheckBoxControls(
    Panel panel,
    ControlTagItem[] items,
    int xOffset,
    int yOffset,
    int height,
    int widthFactor
)
Public Shared Function CreateCheckBoxControls ( _
    panel As Panel, _
    items As ControlTagItem(), _
    xOffset As Integer, _
    yOffset As Integer, _
    height As Integer, _
    widthFactor As Integer _
) As CheckBox()
public:
static array<CheckBox^>^ CreateCheckBoxControls(
    Panel^ panel,
    array<ControlTagItem^>^ items,
    int xOffset,
    int yOffset,
    int height,
    int widthFactor
)
Parameters
panel (Panel)
items (array< ControlTagItem >[]()[][])
xOffset (Int32)
yOffset (Int32)
height (Int32)
widthFactor (Int32)
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


CreateCheckBoxControls Method (panel, labels, xOffset, yOffset, height, widthFactor)

CreateCheckBoxControls Method (panel, labels, xOffset, yOffset, height, widthFactor)
Namespaces ► Samples.Helper.UI ► CheckBoxControlBuilder ► CreateCheckBoxControls(Panel, array<String>[]()[][], Int32, Int32, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public static CheckBox[] CreateCheckBoxControls(
    Panel panel,
    string[] labels,
    int xOffset,
    int yOffset,
    int height,
    int widthFactor
)
Public Shared Function CreateCheckBoxControls ( _
    panel As Panel, _
    labels As String(), _
    xOffset As Integer, _
    yOffset As Integer, _
    height As Integer, _
    widthFactor As Integer _
) As CheckBox()
public:
static array<CheckBox^>^ CreateCheckBoxControls(
    Panel^ panel,
    array<String^>^ labels,
    int xOffset,
    int yOffset,
    int height,
    int widthFactor
)
Parameters
panel (Panel)
labels (array< String >[]()[][])
xOffset (Int32)
yOffset (Int32)
height (Int32)
widthFactor (Int32)
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


CheckBoxGroupControl Class

CheckBoxGroupControl Class
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl
Summary description for UserControl1.
Declaration Syntax
C# Visual Basic Visual C++
public class CheckBoxGroupControl : UserControl
Public Class CheckBoxGroupControl _
    Inherits UserControl
public ref class CheckBoxGroupControl : public UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckBoxGroupControl()()()() |
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
 | AccessibilityObject | (Inherited from Control.)
 | AccessibleDefaultActionDescription | (Inherited from Control.)
 | AccessibleDescription | (Inherited from Control.)
 | AccessibleName | (Inherited from Control.)
 | AccessibleRole | (Inherited from Control.)
 | IContainerControl..::..ActivateControl(Control) | (Inherited from ContainerControl.)
 | ActiveControl | (Inherited from ContainerControl.)
 | AdjustFormScrollbars(Boolean) | (Inherited from ContainerControl.)
 | AllowDrop | (Inherited from Control.)
 | Anchor | (Inherited from Control.)
 | AutoScaleDimensions | (Inherited from ContainerControl.)
 | AutoScaleFactor | (Inherited from ContainerControl.)
 | AutoScaleMode | (Inherited from ContainerControl.)
 | AutoScroll | (Inherited from ScrollableControl.)
 | AutoScrollMargin | (Inherited from ScrollableControl.)
 | AutoScrollMinSize | (Inherited from ScrollableControl.)
 | AutoScrollOffset | (Inherited from Control.)
 | AutoScrollPosition | (Inherited from ScrollableControl.)
 | AutoSize | (Inherited from UserControl.)
 | AutoSizeChanged | (Inherited from UserControl.)
 | AutoSizeMode | (Inherited from UserControl.)
 | AutoValidate | (Inherited from UserControl.)
 | AutoValidateChanged | (Inherited from UserControl.)
 | BackColor | (Inherited from Control.)
 | BackColorChanged | (Inherited from Control.)
 | BackgroundImage | (Inherited from Control.)
 | BackgroundImageChanged | (Inherited from Control.)
 | BackgroundImageLayout | (Inherited from Control.)
 | BackgroundImageLayoutChanged | (Inherited from Control.)
 | BeginInvoke(Delegate) | (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | (Inherited from Control.)
 | BorderStyle | (Inherited from UserControl.)
 | Bottom | (Inherited from Control.)
 | Bounds | (Inherited from Control.)
 | BringToFront()()()() | (Inherited from Control.)
 | CanEnableIme | (Inherited from ContainerControl.)
 | CanFocus | (Inherited from Control.)
 | CanRaiseEvents | (Inherited from Control.)
 | CanSelect | (Inherited from Control.)
 | Capture | (Inherited from Control.)
 | CausesValidation | (Inherited from Control.)
 | CausesValidationChanged | (Inherited from Control.)
 | ChangeUICues | (Inherited from Control.)
 | CheckBoxes |
 | CheckedCheckBoxes |
 | Click | (Inherited from Control.)
 | ClientRectangle | (Inherited from Control.)
 | ClientSize | (Inherited from Control.)
 | ClientSizeChanged | (Inherited from Control.)
 | CompanyName | (Inherited from Control.)
 | Container | (Inherited from Component.)
 | Contains(Control) | (Inherited from Control.)
 | ContainsFocus | (Inherited from Control.)
 | ContextMenu | (Inherited from Control.)
 | ContextMenuChanged | (Inherited from Control.)
 | ContextMenuStrip | (Inherited from Control.)
 | ContextMenuStripChanged | (Inherited from Control.)
 | ControlAdded | (Inherited from Control.)
 | ControlRemoved | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | (Inherited from Control.)
 | CreateControl()()()() | (Inherited from Control.)
 | CreateControlsInstance()()()() | (Inherited from Control.)
 | Created | (Inherited from Control.)
 | CreateGraphics()()()() | (Inherited from Control.)
 | CreateHandle()()()() | (Inherited from Control.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from UserControl.)
 | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
 | Cursor | (Inherited from Control.)
 | CursorChanged | (Inherited from Control.)
 | DataBindings | (Inherited from Control.)
 | DefaultCursor | (Inherited from Control.)
 | DefaultImeMode | (Inherited from Control.)
 | DefaultMargin | (Inherited from Control.)
 | DefaultMaximumSize | (Inherited from Control.)
 | DefaultMinimumSize | (Inherited from Control.)
 | DefaultPadding | (Inherited from Control.)
 | DefaultSize | (Inherited from UserControl.)
 | DefWndProc(Message%) | (Inherited from Control.)
 | DesignMode | (Inherited from Component.)
 | DestroyHandle()()()() | (Inherited from Control.)
 | DisplayRectangle | (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from Component.)
 | Disposed | (Inherited from Component.)
 | Disposing | (Inherited from Control.)
 | Dock | (Inherited from Control.)
 | DockChanged | (Inherited from Control.)
 | DockPadding | (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | (Inherited from Control.)
 | DoubleBuffered | (Inherited from Control.)
 | DoubleClick | (Inherited from Control.)
 | DragDrop | (Inherited from Control.)
 | DragEnter | (Inherited from Control.)
 | DragLeave | (Inherited from Control.)
 | DragOver | (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | (Inherited from Control.)
 | Enabled | (Inherited from Control.)
 | EnabledChanged | (Inherited from Control.)
 | EndInvoke(IAsyncResult) | (Inherited from Control.)
 | Enter | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Component.)
 | Finalize()()()() | (Inherited from Component.)
 | FindForm()()()() | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Focused | (Inherited from Control.)
 | Font | (Inherited from Control.)
 | FontChanged | (Inherited from Control.)
 | FontHeight | (Inherited from Control.)
 | ForeColor | (Inherited from Control.)
 | ForeColorChanged | (Inherited from Control.)
 | GetAccessibilityObjectById(Int32) | (Inherited from Control.)
 | GetAutoSizeMode()()()() | (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
 | GetChildAtPoint(Point) | (Inherited from Control.)
 | GetContainerControl()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | (Inherited from Control.)
 | GetPreferredSize(Size) | (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Control.)
 | GetScrollState(Int32) | (Inherited from ScrollableControl.)
 | GetService(Type) | (Inherited from Component.)
 | GetStyle(ControlStyles) | (Inherited from Control.)
 | GetTopLevel()()()() | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GiveFeedback | (Inherited from Control.)
 | GotFocus | (Inherited from Control.)
 | Handle | (Inherited from Control.)
 | HandleCreated | (Inherited from Control.)
 | HandleDestroyed | (Inherited from Control.)
 | HasChildren | (Inherited from Control.)
 | Height | (Inherited from Control.)
 | HelpRequested | (Inherited from Control.)
 | Hide()()()() | (Inherited from Control.)
 | HorizontalScroll | (Inherited from ScrollableControl.)
 | HScroll | (Inherited from ScrollableControl.)
 | ImeMode | (Inherited from Control.)
 | ImeModeBase | (Inherited from Control.)
 | ImeModeChanged | (Inherited from Control.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | (Inherited from Control.)
 | Invalidate(Region) | (Inherited from Control.)
 | Invalidate(Region, Boolean) | (Inherited from Control.)
 | Invalidate()()()() | (Inherited from Control.)
 | Invalidate(Boolean) | (Inherited from Control.)
 | Invalidate(Rectangle) | (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
 | Invalidated | (Inherited from Control.)
 | Invoke(Delegate) | (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokeRequired | (Inherited from Control.)
 | IsAccessible | (Inherited from Control.)
 | IsDisposed | (Inherited from Control.)
 | IsHandleCreated | (Inherited from Control.)
 | IsInputChar(Char) | (Inherited from Control.)
 | IsInputKey(Keys) | (Inherited from Control.)
 | IsMirrored | (Inherited from Control.)
 | ItemHeight |
 | KeyDown | (Inherited from Control.)
 | KeyPress | (Inherited from Control.)
 | KeyUp | (Inherited from Control.)
 | Layout | (Inherited from Control.)
 | LayoutEngine | (Inherited from Control.)
 | Leave | (Inherited from Control.)
 | Left | (Inherited from Control.)
 | Load | (Inherited from UserControl.)
 | Location | (Inherited from Control.)
 | LocationChanged | (Inherited from Control.)
 | LostFocus | (Inherited from Control.)
 | Margin | (Inherited from Control.)
 | MarginChanged | (Inherited from Control.)
 | MaximumSize | (Inherited from Control.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumSize | (Inherited from Control.)
 | MouseCaptureChanged | (Inherited from Control.)
 | MouseClick | (Inherited from Control.)
 | MouseDoubleClick | (Inherited from Control.)
 | MouseDown | (Inherited from Control.)
 | MouseEnter | (Inherited from Control.)
 | MouseHover | (Inherited from Control.)
 | MouseLeave | (Inherited from Control.)
 | MouseMove | (Inherited from Control.)
 | MouseUp | (Inherited from Control.)
 | MouseWheel | (Inherited from Control.)
 | Move | (Inherited from Control.)
 | Name | (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | (Inherited from Control.)
 | OnAutoSizeChanged(EventArgs) | (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | (Inherited from Control.)
 | OnClick(EventArgs) | (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | (Inherited from Control.)
 | OnCreateControl()()()() | (Inherited from UserControl.)
 | OnCursorChanged(EventArgs) | (Inherited from Control.)
 | OnDockChanged(EventArgs) | (Inherited from Control.)
 | OnDoubleClick(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | OnDragLeave(EventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragLeave(EventArgs) | (Inherited from Control.)
 | OnDragOver(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragOver(DragEventArgs) | (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnEnter(EventArgs) | (Inherited from Control.)
 | OnFontChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from Control.)
 | OnGotFocus(EventArgs) | (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from Control.)
 | OnHandleDestroyed(EventArgs) | (Inherited from Control.)
 | OnHelpRequested(HelpEventArgs) | (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from ContainerControl.)
 | OnLeave(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from UserControl.)
 | OnLocationChanged(EventArgs) | (Inherited from Control.)
 | OnLostFocus(EventArgs) | (Inherited from Control.)
 | OnMarginChanged(EventArgs) | (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from UserControl.)
 | OnMouseEnter(EventArgs) | (Inherited from Control.)
 | OnMouseHover(EventArgs) | (Inherited from Control.)
 | OnMouseLeave(EventArgs) | (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | (Inherited from Control.)
 | OnNotifyMessage(Message) | (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | (Inherited from Control.)
 | OnPrint(PaintEventArgs) | (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from Control.)
 | OnRegionChanged(EventArgs) | (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from UserControl.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnScroll(ScrollEventArgs) | (Inherited from ScrollableControl.)
 | OnSizeChanged(EventArgs) | (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Control.)
 | OnValidated(EventArgs) | (Inherited from Control.)
 | OnValidating(CancelEventArgs) | (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | (Inherited from ScrollableControl.)
 | Padding | (Inherited from Control.)
 | PaddingChanged | (Inherited from Control.)
 | Paint | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | ParentChanged | (Inherited from Control.)
 | ParentForm | (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | (Inherited from ContainerControl.)
 | PerformLayout()()()() | (Inherited from Control.)
 | PerformLayout(Control, String) | (Inherited from Control.)
 | PointToClient(Point) | (Inherited from Control.)
 | PointToScreen(Point) | (Inherited from Control.)
 | PreferredSize | (Inherited from Control.)
 | PreProcessControlMessage(Message%) | (Inherited from Control.)
 | PreProcessMessage(Message%) | (Inherited from Control.)
 | PreviewKeyDown | (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from ContainerControl.)
 | ProcessDialogChar(Char) | (Inherited from ContainerControl.)
 | ProcessDialogKey(Keys) | (Inherited from ContainerControl.)
 | ProcessKeyEventArgs(Message%) | (Inherited from Control.)
 | ProcessKeyMessage(Message%) | (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from ContainerControl.)
 | ProcessTabKey(Boolean) | (Inherited from ContainerControl.)
 | ProductName | (Inherited from Control.)
 | ProductVersion | (Inherited from Control.)
 | QueryAccessibilityHelp | (Inherited from Control.)
 | QueryContinueDrag | (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | (Inherited from Control.)
 | RecreateHandle()()()() | (Inherited from Control.)
 | RecreatingHandle | (Inherited from Control.)
 | RectangleToClient(Rectangle) | (Inherited from Control.)
 | RectangleToScreen(Rectangle) | (Inherited from Control.)
 | Refresh()()()() | (Inherited from Control.)
 | Region | (Inherited from Control.)
 | RegionChanged | (Inherited from Control.)
 | RenderRightToLeft | Obsolete. (Inherited from Control.)
 | ResetBackColor()()()() | (Inherited from Control.)
 | ResetBindings()()()() | (Inherited from Control.)
 | ResetCursor()()()() | (Inherited from Control.)
 | ResetFont()()()() | (Inherited from Control.)
 | ResetForeColor()()()() | (Inherited from Control.)
 | ResetImeMode()()()() | (Inherited from Control.)
 | ResetMouseEventArgs()()()() | (Inherited from Control.)
 | ResetRightToLeft()()()() | (Inherited from Control.)
 | ResetText()()()() | (Inherited from Control.)
 | Resize | (Inherited from Control.)
 | ResizeRedraw | (Inherited from Control.)
 | ResumeLayout()()()() | (Inherited from Control.)
 | ResumeLayout(Boolean) | (Inherited from Control.)
 | Right | (Inherited from Control.)
 | RightToLeft | (Inherited from Control.)
 | RightToLeftChanged | (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | (Inherited from Control.)
 | Scale(Single) | Obsolete. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. (Inherited from Control.)
 | Scale(SizeF) | (Inherited from Control.)
 | ScaleChildren | (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from ScrollableControl.)
 | ScaleCore(Single, Single) | (Inherited from ScrollableControl.)
 | Scroll | (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
 | Select()()()() | (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | (Inherited from Control.)
 | SendToBack()()()() | (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetCheckBoxControls(array<String>[]()[][]) |
 | SetCheckBoxControls(array<ControlTagItem>[]()[][]) |
 | SetClientSizeCore(Int32, Int32) | (Inherited from Control.)
 | SetDisplayRectLocation(Int32, Int32) | (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | (Inherited from Control.)
 | SetTopLevel(Boolean) | (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Control.)
 | Show()()()() | (Inherited from Control.)
 | ShowFocusCues | (Inherited from Control.)
 | ShowKeyboardCues | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | Size | (Inherited from Control.)
 | SizeChanged | (Inherited from Control.)
 | SizeFromClientSize(Size) | (Inherited from Control.)
 | StyleChanged | (Inherited from Control.)
 | SuspendLayout()()()() | (Inherited from Control.)
 | SystemColorsChanged | (Inherited from Control.)
 | TabIndex | (Inherited from Control.)
 | TabIndexChanged | (Inherited from Control.)
 | TabStop | (Inherited from Control.)
 | TabStopChanged | (Inherited from Control.)
 | Tag | (Inherited from Control.)
 | Text | (Inherited from UserControl.)
 | TextChanged | (Inherited from UserControl.)
 | Top | (Inherited from Control.)
 | TopLevelControl | (Inherited from Control.)
 | ToString()()()() | (Inherited from Component.)
 | Update()()()() | (Inherited from Control.)
 | UpdateBounds()()()() | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateDefaultButton()()()() | (Inherited from ContainerControl.)
 | UpdateStyles()()()() | (Inherited from Control.)
 | UpdateZOrder()()()() | (Inherited from Control.)
 | UseWaitCursor | (Inherited from Control.)
 | Validate()()()() | (Inherited from ContainerControl.)
 | Validate(Boolean) | (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from UserControl.)
 | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
 | Validated | (Inherited from Control.)
 | Validating | (Inherited from Control.)
 | VerticalScroll | (Inherited from ScrollableControl.)
 | Visible | (Inherited from Control.)
 | VisibleChanged | (Inherited from Control.)
 | VScroll | (Inherited from ScrollableControl.)
 | Width | (Inherited from Control.)
 | WidthFactor |
 | WindowTarget | (Inherited from Control.)
 | WndProc(Message%) | (Inherited from UserControl.)
 | XOffset |
 | YOffset |
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | UserControl
 |  |  |  |  |  |  | CheckBoxGroupControl

Assembly: Samples.Helper (Module: Samples.Helper)


CheckBoxes Property

CheckBoxes Property
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► CheckBoxes
Declaration Syntax
C# Visual Basic Visual C++
public CheckBox[] CheckBoxes { get; }
Public ReadOnly Property CheckBoxes As CheckBox()
    Get
public:
property array<CheckBox^>^ CheckBoxes {
    array<CheckBox^>^ get ();
}

Assembly: Samples.Helper (Module: Samples.Helper)


CheckBoxGroupControl Constructor

CheckBoxGroupControl Constructor
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► CheckBoxGroupControl()()()()
Declaration Syntax
C# Visual Basic Visual C++
public CheckBoxGroupControl()
Public Sub New
public:
CheckBoxGroupControl()

Assembly: Samples.Helper (Module: Samples.Helper)


CheckedCheckBoxes Property

CheckedCheckBoxes Property
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► CheckedCheckBoxes
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList CheckedCheckBoxes { get; }
Public ReadOnly Property CheckedCheckBoxes As ArrayList
    Get
public:
property ArrayList^ CheckedCheckBoxes {
    ArrayList^ get ();
}

Assembly: Samples.Helper (Module: Samples.Helper)


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)

Assembly: Samples.Helper (Module: Samples.Helper)


ItemHeight Property

ItemHeight Property
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► ItemHeight
Declaration Syntax
C# Visual Basic Visual C++
public int ItemHeight { get; set; }
Public Property ItemHeight As Integer
    Get
    Set
public:
property int ItemHeight {
    int get ();
    void set (int value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


SetCheckBoxControls Method

SetCheckBoxControls Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► SetCheckBoxControls()()()()
Members
Icon | Member | Description
 | SetCheckBoxControls(array<String>[]()[][]) |
 | SetCheckBoxControls(array<ControlTagItem>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


SetCheckBoxControls Method (items)

SetCheckBoxControls Method (items)
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► SetCheckBoxControls(array<ControlTagItem>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetCheckBoxControls(
    ControlTagItem[] items
)
Public Sub SetCheckBoxControls ( _
    items As ControlTagItem() _
)
public:
void SetCheckBoxControls(
    array<ControlTagItem^>^ items
)
Parameters
items (array< ControlTagItem >[]()[][])

Assembly: Samples.Helper (Module: Samples.Helper)


SetCheckBoxControls Method (names)

SetCheckBoxControls Method (names)
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► SetCheckBoxControls(array<String>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetCheckBoxControls(
    string[] names
)
Public Sub SetCheckBoxControls ( _
    names As String() _
)
public:
void SetCheckBoxControls(
    array<String^>^ names
)
Parameters
names (array< String >[]()[][])

Assembly: Samples.Helper (Module: Samples.Helper)


WidthFactor Property

WidthFactor Property
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► WidthFactor
Declaration Syntax
C# Visual Basic Visual C++
public int WidthFactor { get; set; }
Public Property WidthFactor As Integer
    Get
    Set
public:
property int WidthFactor {
    int get ();
    void set (int value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


XOffset Property

XOffset Property
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► XOffset
Declaration Syntax
C# Visual Basic Visual C++
public int XOffset { get; set; }
Public Property XOffset As Integer
    Get
    Set
public:
property int XOffset {
    int get ();
    void set (int value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


YOffset Property

YOffset Property
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► YOffset
Declaration Syntax
C# Visual Basic Visual C++
public int YOffset { get; set; }
Public Property YOffset As Integer
    Get
    Set
public:
property int YOffset {
    int get ();
    void set (int value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


ControlTagItem Class

ControlTagItem Class
Namespaces ► Samples.Helper.UI ► ControlTagItem
A helper class for associate string with an object.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ControlTagItem : IControlTagItem
<SerializableAttribute> _
<ClassInterfaceAttribute(ClassInterfaceType.None)> _
Public Class ControlTagItem _
    Implements IControlTagItem
[SerializableAttribute]
[ClassInterfaceAttribute(ClassInterfaceType::None)]
public ref class ControlTagItem : IControlTagItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ControlTagItem()()()() | Constructor.
 | ControlTagItem(String, Object) | Constructor.
 | Equals(Object) | (Inherited from Object.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | Tag | The object that is associated with the string.
 | Text | The string.
 | ToString()()()() | Overrided ToString(). (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
ControlTagItem

Assembly: Samples.Helper (Module: Samples.Helper)


ControlTagItem Constructor

ControlTagItem Constructor
Namespaces ► Samples.Helper.UI ► ControlTagItem ► ControlTagItem()()()()
Members
Icon | Member | Description
 | ControlTagItem()()()() | Constructor.
 | ControlTagItem(String, Object) | Constructor.

Assembly: Samples.Helper (Module: Samples.Helper)


ControlTagItem Constructor

ControlTagItem Constructor
Namespaces ► Samples.Helper.UI ► ControlTagItem ► ControlTagItem()()()()
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem()
Public Sub New
public:
ControlTagItem()

Assembly: Samples.Helper (Module: Samples.Helper)


ControlTagItem Constructor (text, tag)

ControlTagItem Constructor (text, tag)
Namespaces ► Samples.Helper.UI ► ControlTagItem ► ControlTagItem(String, Object)
Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem(
    string text,
    Object tag
)
Public Sub New ( _
    text As String, _
    tag As Object _
)
public:
ControlTagItem(
    String^ text,
    Object^ tag
)
Parameters
text (String)
tag (Object)

Assembly: Samples.Helper (Module: Samples.Helper)


Tag Property

Tag Property
Namespaces ► Samples.Helper.UI ► ControlTagItem ► Tag
The object that is associated with the string.
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
virtual property Object^ Tag {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Assembly: Samples.Helper (Module: Samples.Helper)


Text Property

Text Property
Namespaces ► Samples.Helper.UI ► ControlTagItem ► Text
The string.
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Assembly: Samples.Helper (Module: Samples.Helper)


ToString Method

ToString Method
Namespaces ► Samples.Helper.UI ► ControlTagItem ► ToString()()()()
Overrided ToString().
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


EditListView Class

EditListView Class
Namespaces ► Samples.Helper.UI ► EditListView
Declaration Syntax
C# Visual Basic Visual C++
public class EditListView : ListView
Public Class EditListView _
    Inherits ListView
public ref class EditListView : public ListView
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EditListView()()()() |
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
 | AccessibilityObject | (Inherited from Control.)
 | AccessibleDefaultActionDescription | (Inherited from Control.)
 | AccessibleDescription | (Inherited from Control.)
 | AccessibleName | (Inherited from Control.)
 | AccessibleRole | (Inherited from Control.)
 | Activation | (Inherited from ListView.)
 | AfterLabelEdit | (Inherited from ListView.)
 | Alignment | (Inherited from ListView.)
 | AllowColumnReorder | (Inherited from ListView.)
 | AllowDrop | (Inherited from Control.)
 | Anchor | (Inherited from Control.)
 | ArrangeIcons(ListViewAlignment) | (Inherited from ListView.)
 | ArrangeIcons()()()() | (Inherited from ListView.)
 | AutoArrange | (Inherited from ListView.)
 | AutoResizeColumn(Int32, ColumnHeaderAutoResizeStyle) | (Inherited from ListView.)
 | AutoResizeColumns(ColumnHeaderAutoResizeStyle) | (Inherited from ListView.)
 | AutoScrollOffset | (Inherited from Control.)
 | AutoSize | (Inherited from Control.)
 | AutoSizeChanged | (Inherited from Control.)
 | BackColor | (Inherited from ListView.)
 | BackColorChanged | (Inherited from Control.)
 | BackgroundImage | (Inherited from Control.)
 | BackgroundImageChanged | (Inherited from Control.)
 | BackgroundImageLayout | (Inherited from ListView.)
 | BackgroundImageLayoutChanged | (Inherited from ListView.)
 | BackgroundImageTiled | (Inherited from ListView.)
 | BeforeLabelEdit | (Inherited from ListView.)
 | BeginInvoke(Delegate) | (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | BeginUpdate()()()() | (Inherited from ListView.)
 | BindingContext | (Inherited from Control.)
 | BindingContextChanged | (Inherited from Control.)
 | BorderStyle | (Inherited from ListView.)
 | Bottom | (Inherited from Control.)
 | Bounds | (Inherited from Control.)
 | BringToFront()()()() | (Inherited from Control.)
 | CacheVirtualItems | (Inherited from ListView.)
 | CanEnableIme | (Inherited from Control.)
 | CanFocus | (Inherited from Control.)
 | CanRaiseEvents | (Inherited from Control.)
 | CanSelect | (Inherited from Control.)
 | Capture | (Inherited from Control.)
 | CausesValidation | (Inherited from Control.)
 | CausesValidationChanged | (Inherited from Control.)
 | ChangeUICues | (Inherited from Control.)
 | CheckBoxes | (Inherited from ListView.)
 | CheckedIndices | (Inherited from ListView.)
 | CheckedItems | (Inherited from ListView.)
 | Clear()()()() | (Inherited from ListView.)
 | Click | (Inherited from Control.)
 | ClientRectangle | (Inherited from Control.)
 | ClientSize | (Inherited from Control.)
 | ClientSizeChanged | (Inherited from Control.)
 | ColumnClick | (Inherited from ListView.)
 | ColumnReordered | (Inherited from ListView.)
 | Columns | (Inherited from ListView.)
 | ColumnWidthChanged | (Inherited from ListView.)
 | ColumnWidthChanging | (Inherited from ListView.)
 | CompanyName | (Inherited from Control.)
 | Container | (Inherited from Component.)
 | Contains(Control) | (Inherited from Control.)
 | ContainsFocus | (Inherited from Control.)
 | ContextMenu | (Inherited from Control.)
 | ContextMenuChanged | (Inherited from Control.)
 | ContextMenuStrip | (Inherited from Control.)
 | ContextMenuStripChanged | (Inherited from Control.)
 | ControlAdded | (Inherited from Control.)
 | ControlRemoved | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | (Inherited from Control.)
 | CreateControl()()()() | (Inherited from Control.)
 | CreateControlsInstance()()()() | (Inherited from Control.)
 | Created | (Inherited from Control.)
 | CreateGraphics()()()() | (Inherited from Control.)
 | CreateHandle()()()() | (Inherited from ListView.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from ListView.)
 | Cursor | (Inherited from Control.)
 | CursorChanged | (Inherited from Control.)
 | DataBindings | (Inherited from Control.)
 | DefaultCursor | (Inherited from Control.)
 | DefaultImeMode | (Inherited from Control.)
 | DefaultMargin | (Inherited from Control.)
 | DefaultMaximumSize | (Inherited from Control.)
 | DefaultMinimumSize | (Inherited from Control.)
 | DefaultPadding | (Inherited from Control.)
 | DefaultSize | (Inherited from ListView.)
 | DefWndProc(Message%) | (Inherited from Control.)
 | DesignMode | (Inherited from Component.)
 | DestroyHandle()()()() | (Inherited from Control.)
 | DisplayRectangle | (Inherited from Control.)
 | Dispose(Boolean) | (Inherited from ListView.)
 | Dispose()()()() | (Inherited from Component.)
 | Disposed | (Inherited from Component.)
 | Disposing | (Inherited from Control.)
 | Dock | (Inherited from Control.)
 | DockChanged | (Inherited from Control.)
 | DoDragDrop(Object, DragDropEffects) | (Inherited from Control.)
 | DoubleBuffered | (Inherited from ListView.)
 | DoubleClick | (Inherited from Control.)
 | DragDrop | (Inherited from Control.)
 | DragEnter | (Inherited from Control.)
 | DragLeave | (Inherited from Control.)
 | DragOver | (Inherited from Control.)
 | DrawColumnHeader | (Inherited from ListView.)
 | DrawItem | (Inherited from ListView.)
 | DrawSubItem | (Inherited from ListView.)
 | DrawToBitmap(Bitmap, Rectangle) | (Inherited from Control.)
 | editBox |
 | ELVDoubleClick(Object, EventArgs) |
 | ELVKeyDown(Object, KeyEventArgs) |
 | ELVMouseDown(Object, MouseEventArgs) |
 | Enabled | (Inherited from Control.)
 | EnabledChanged | (Inherited from Control.)
 | EndInvoke(IAsyncResult) | (Inherited from Control.)
 | EndUpdate()()()() | (Inherited from ListView.)
 | EnsureVisible(Int32) | (Inherited from ListView.)
 | Enter | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Component.)
 | Finalize()()()() | (Inherited from Component.)
 | FindForm()()()() | (Inherited from Control.)
 | FindItemWithText(String) | (Inherited from ListView.)
 | FindItemWithText(String, Boolean, Int32) | (Inherited from ListView.)
 | FindItemWithText(String, Boolean, Int32, Boolean) | (Inherited from ListView.)
 | FindNearestItem(SearchDirectionHint, Point) | (Inherited from ListView.)
 | FindNearestItem(SearchDirectionHint, Int32, Int32) | (Inherited from ListView.)
 | Focus()()()() | (Inherited from Control.)
 | Focused | (Inherited from Control.)
 | FocusedItem | (Inherited from ListView.)
 | Font | (Inherited from Control.)
 | FontChanged | (Inherited from Control.)
 | FontHeight | (Inherited from Control.)
 | ForeColor | (Inherited from ListView.)
 | ForeColorChanged | (Inherited from Control.)
 | FullRowSelect | (Inherited from ListView.)
 | GetAccessibilityObjectById(Int32) | (Inherited from Control.)
 | GetAutoSizeMode()()()() | (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
 | GetChildAtPoint(Point) | (Inherited from Control.)
 | GetContainerControl()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItemAt(Int32, Int32) | (Inherited from ListView.)
 | GetItemRect(Int32) | (Inherited from ListView.)
 | GetItemRect(Int32, ItemBoundsPortion) | (Inherited from ListView.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | (Inherited from Control.)
 | GetPreferredSize(Size) | (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Control.)
 | GetService(Type) | (Inherited from Component.)
 | GetStyle(ControlStyles) | (Inherited from Control.)
 | GetTopLevel()()()() | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GiveFeedback | (Inherited from Control.)
 | GotFocus | (Inherited from Control.)
 | GridLines | (Inherited from ListView.)
 | Groups | (Inherited from ListView.)
 | Handle | (Inherited from Control.)
 | HandleCreated | (Inherited from Control.)
 | HandleDestroyed | (Inherited from Control.)
 | HasChildren | (Inherited from Control.)
 | HeaderStyle | (Inherited from ListView.)
 | Height | (Inherited from Control.)
 | HelpRequested | (Inherited from Control.)
 | Hide()()()() | (Inherited from Control.)
 | HideSelection | (Inherited from ListView.)
 | HitTest(Point) | (Inherited from ListView.)
 | HitTest(Int32, Int32) | (Inherited from ListView.)
 | HotTracking | (Inherited from ListView.)
 | HoverSelection | (Inherited from ListView.)
 | ImeMode | (Inherited from Control.)
 | ImeModeBase | (Inherited from Control.)
 | ImeModeChanged | (Inherited from Control.)
 | InitHeaderInfo(array<HeaderInfo>[]()[][]) |
 | Initialize(array<HeaderInfo>[]()[][]) | This method must be called to iniitialize the ListView.
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | (Inherited from Control.)
 | InitListView(array<HeaderInfo>[]()[][]) |
 | InsertionMark | (Inherited from ListView.)
 | Invalidate(Region) | (Inherited from Control.)
 | Invalidate(Region, Boolean) | (Inherited from Control.)
 | Invalidate()()()() | (Inherited from Control.)
 | Invalidate(Boolean) | (Inherited from Control.)
 | Invalidate(Rectangle) | (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
 | Invalidated | (Inherited from Control.)
 | Invoke(Delegate) | (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokeRequired | (Inherited from Control.)
 | IsAccessible | (Inherited from Control.)
 | IsDisposed | (Inherited from Control.)
 | IsHandleCreated | (Inherited from Control.)
 | IsInputChar(Char) | (Inherited from Control.)
 | IsInputKey(Keys) | (Inherited from ListView.)
 | IsMirrored | (Inherited from Control.)
 | ItemActivate | (Inherited from ListView.)
 | ItemCheck | (Inherited from ListView.)
 | ItemChecked | (Inherited from ListView.)
 | ItemDrag | (Inherited from ListView.)
 | ItemMouseHover | (Inherited from ListView.)
 | Items | (Inherited from ListView.)
 | ItemSelectionChanged | (Inherited from ListView.)
 | KeyDown | (Inherited from Control.)
 | KeyPress | (Inherited from Control.)
 | KeyUp | (Inherited from Control.)
 | LabelEdit | (Inherited from ListView.)
 | LabelWrap | (Inherited from ListView.)
 | LargeImageList | (Inherited from ListView.)
 | Layout | (Inherited from Control.)
 | LayoutEngine | (Inherited from Control.)
 | Leave | (Inherited from Control.)
 | Left | (Inherited from Control.)
 | ListViewItemSelected |
 | ListViewItemSorter | (Inherited from ListView.)
 | Location | (Inherited from Control.)
 | LocationChanged | (Inherited from Control.)
 | LostFocus | (Inherited from Control.)
 | Margin | (Inherited from Control.)
 | MarginChanged | (Inherited from Control.)
 | MaximumSize | (Inherited from Control.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumSize | (Inherited from Control.)
 | MouseCaptureChanged | (Inherited from Control.)
 | MouseClick | (Inherited from Control.)
 | MouseDoubleClick | (Inherited from Control.)
 | MouseDown | (Inherited from Control.)
 | MouseEnter | (Inherited from Control.)
 | MouseHover | (Inherited from Control.)
 | MouseLeave | (Inherited from Control.)
 | MouseMove | (Inherited from Control.)
 | MouseUp | (Inherited from Control.)
 | MouseWheel | (Inherited from Control.)
 | Move | (Inherited from Control.)
 | MultiSelect | (Inherited from ListView.)
 | Name | (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | (Inherited from Control.)
 | OnAfterLabelEdit(LabelEditEventArgs) | (Inherited from ListView.)
 | OnAutoSizeChanged(EventArgs) | (Inherited from Control.)
 | OnBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | (Inherited from ListView.)
 | OnBackgroundImageLayoutChanged(EventArgs) | (Inherited from Control.)
 | OnBeforeLabelEdit(LabelEditEventArgs) | (Inherited from ListView.)
 | OnBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnCacheVirtualItems(CacheVirtualItemsEventArgs) | (Inherited from ListView.)
 | OnCausesValidationChanged(EventArgs) | (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | (Inherited from Control.)
 | OnClick(EventArgs) | (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | (Inherited from Control.)
 | OnColumnClick(ColumnClickEventArgs) | (Inherited from ListView.)
 | OnColumnReordered(ColumnReorderedEventArgs) | (Inherited from ListView.)
 | OnColumnWidthChanged(ColumnWidthChangedEventArgs) | (Inherited from ListView.)
 | OnColumnWidthChanging(ColumnWidthChangingEventArgs) | (Inherited from ListView.)
 | OnContextMenuChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | (Inherited from Control.)
 | OnCreateControl()()()() | (Inherited from Control.)
 | OnCursorChanged(EventArgs) | (Inherited from Control.)
 | OnDockChanged(EventArgs) | (Inherited from Control.)
 | OnDoubleClick(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | OnDragLeave(EventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragLeave(EventArgs) | (Inherited from Control.)
 | OnDragOver(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragOver(DragEventArgs) | (Inherited from Control.)
 | OnDrawColumnHeader(DrawListViewColumnHeaderEventArgs) | (Inherited from ListView.)
 | OnDrawItem(DrawListViewItemEventArgs) | (Inherited from ListView.)
 | OnDrawSubItem(DrawListViewSubItemEventArgs) | (Inherited from ListView.)
 | OnEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnEnter(EventArgs) | (Inherited from Control.)
 | OnFontChanged(EventArgs) | (Inherited from ListView.)
 | OnForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from Control.)
 | OnGotFocus(EventArgs) | (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from ListView.)
 | OnHandleDestroyed(EventArgs) | (Inherited from ListView.)
 | OnHelpRequested(HelpEventArgs) | (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | (Inherited from Control.)
 | OnItemActivate(EventArgs) | (Inherited from ListView.)
 | OnItemCheck(ItemCheckEventArgs) | (Inherited from ListView.)
 | OnItemChecked(ItemCheckedEventArgs) | (Inherited from ListView.)
 | OnItemDrag(ItemDragEventArgs) | (Inherited from ListView.)
 | OnItemMouseHover(ListViewItemMouseHoverEventArgs) | (Inherited from ListView.)
 | OnItemSelectionChanged(ListViewItemSelectionChangedEventArgs) | (Inherited from ListView.)
 | OnKeyDown(KeyEventArgs) | (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from Control.)
 | OnLeave(EventArgs) | (Inherited from Control.)
 | OnLocationChanged(EventArgs) | (Inherited from Control.)
 | OnLostFocus(EventArgs) | (Inherited from Control.)
 | OnMarginChanged(EventArgs) | (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from Control.)
 | OnMouseEnter(EventArgs) | (Inherited from Control.)
 | OnMouseHover(EventArgs) | (Inherited from ListView.)
 | OnMouseLeave(EventArgs) | (Inherited from ListView.)
 | OnMouseMove(MouseEventArgs) | (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | (Inherited from Control.)
 | OnMove(EventArgs) | (Inherited from Control.)
 | OnNotifyMessage(Message) | (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | (Inherited from Control.)
 | OnPaint(PaintEventArgs) | (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | (Inherited from Control.)
 | OnParentBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ListView.)
 | OnParentCursorChanged(EventArgs) | (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | (Inherited from Control.)
 | OnPrint(PaintEventArgs) | (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from Control.)
 | OnRegionChanged(EventArgs) | (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from ListView.)
 | OnRetrieveVirtualItem(RetrieveVirtualItemEventArgs) | (Inherited from ListView.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from Control.)
 | OnRightToLeftLayoutChanged(EventArgs) | (Inherited from ListView.)
 | OnSearchForVirtualItem(SearchForVirtualItemEventArgs) | (Inherited from ListView.)
 | OnSelectedIndexChanged(EventArgs) | (Inherited from ListView.)
 | OnSizeChanged(EventArgs) | (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | (Inherited from ListView.)
 | OnTabIndexChanged(EventArgs) | (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Control.)
 | OnValidated(EventArgs) | (Inherited from Control.)
 | OnValidating(CancelEventArgs) | (Inherited from Control.)
 | OnVirtualItemsSelectionRangeChanged(ListViewVirtualItemsSelectionRangeChangedEventArgs) | (Inherited from ListView.)
 | OnVisibleChanged(EventArgs) | (Inherited from Control.)
 | OwnerDraw | (Inherited from ListView.)
 | Padding | (Inherited from ListView.)
 | PaddingChanged | (Inherited from ListView.)
 | Paint | (Inherited from ListView.)
 | Parent | (Inherited from Control.)
 | ParentChanged | (Inherited from Control.)
 | PerformLayout()()()() | (Inherited from Control.)
 | PerformLayout(Control, String) | (Inherited from Control.)
 | PointToClient(Point) | (Inherited from Control.)
 | PointToScreen(Point) | (Inherited from Control.)
 | PreferredSize | (Inherited from Control.)
 | PreProcessControlMessage(Message%) | (Inherited from Control.)
 | PreProcessMessage(Message%) | (Inherited from Control.)
 | PreviewKeyDown | (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from Control.)
 | ProcessDialogChar(Char) | (Inherited from Control.)
 | ProcessDialogKey(Keys) | (Inherited from Control.)
 | ProcessDoubleClick(String, Int32, Int32) |
 | ProcessKeyEventArgs(Message%) | (Inherited from Control.)
 | ProcessKeyMessage(Message%) | (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from Control.)
 | ProductName | (Inherited from Control.)
 | ProductVersion | (Inherited from Control.)
 | QueryAccessibilityHelp | (Inherited from Control.)
 | QueryContinueDrag | (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | (Inherited from Control.)
 | RealizeProperties()()()() | (Inherited from ListView.)
 | RecreateHandle()()()() | (Inherited from Control.)
 | RecreatingHandle | (Inherited from Control.)
 | RectangleToClient(Rectangle) | (Inherited from Control.)
 | RectangleToScreen(Rectangle) | (Inherited from Control.)
 | RedrawItems(Int32, Int32, Boolean) | (Inherited from ListView.)
 | Refresh()()()() | (Inherited from Control.)
 | Region | (Inherited from Control.)
 | RegionChanged | (Inherited from Control.)
 | RenderRightToLeft | Obsolete. (Inherited from Control.)
 | ResetBackColor()()()() | (Inherited from Control.)
 | ResetBindings()()()() | (Inherited from Control.)
 | ResetCursor()()()() | (Inherited from Control.)
 | ResetFont()()()() | (Inherited from Control.)
 | ResetForeColor()()()() | (Inherited from Control.)
 | ResetImeMode()()()() | (Inherited from Control.)
 | ResetMouseEventArgs()()()() | (Inherited from Control.)
 | ResetRightToLeft()()()() | (Inherited from Control.)
 | ResetText()()()() | (Inherited from Control.)
 | Resize | (Inherited from Control.)
 | ResizeRedraw | (Inherited from Control.)
 | ResumeLayout()()()() | (Inherited from Control.)
 | ResumeLayout(Boolean) | (Inherited from Control.)
 | RetrieveVirtualItem | (Inherited from ListView.)
 | Right | (Inherited from Control.)
 | RightToLeft | (Inherited from Control.)
 | RightToLeftChanged | (Inherited from Control.)
 | RightToLeftLayout | (Inherited from ListView.)
 | RightToLeftLayoutChanged | (Inherited from ListView.)
 | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | (Inherited from Control.)
 | Scale(Single) | Obsolete. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. (Inherited from Control.)
 | Scale(SizeF) | (Inherited from Control.)
 | ScaleChildren | (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from Control.)
 | ScaleCore(Single, Single) | (Inherited from Control.)
 | Scrollable | (Inherited from ListView.)
 | SearchForVirtualItem | (Inherited from ListView.)
 | Select()()()() | (Inherited from Control.)
 | Select(Boolean, Boolean) | (Inherited from Control.)
 | SelectedIndexChanged | (Inherited from ListView.)
 | SelectedIndices | (Inherited from ListView.)
 | SelectedItems | (Inherited from ListView.)
 | SelectedListViewItem |
 | SelectedListViewSubItem |
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | (Inherited from Control.)
 | SendToBack()()()() | (Inherited from Control.)
 | SetAutoSizeMode(AutoSizeMode) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | (Inherited from Control.)
 | SetStyle(ControlStyles, Boolean) | (Inherited from Control.)
 | SetTopLevel(Boolean) | (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Control.)
 | Show()()()() | (Inherited from Control.)
 | ShowFocusCues | (Inherited from Control.)
 | ShowGroups | (Inherited from ListView.)
 | ShowItemToolTips | (Inherited from ListView.)
 | ShowKeyboardCues | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | Size | (Inherited from Control.)
 | SizeChanged | (Inherited from Control.)
 | SizeFromClientSize(Size) | (Inherited from Control.)
 | SmallImageList | (Inherited from ListView.)
 | Sort()()()() | (Inherited from ListView.)
 | Sorting | (Inherited from ListView.)
 | StateImageList | (Inherited from ListView.)
 | StyleChanged | (Inherited from Control.)
 | SubItemSelectedIndex |
 | SubItemSelectedText |
 | SuspendLayout()()()() | (Inherited from Control.)
 | SystemColorsChanged | (Inherited from Control.)
 | TabIndex | (Inherited from Control.)
 | TabIndexChanged | (Inherited from Control.)
 | TabStop | (Inherited from Control.)
 | TabStopChanged | (Inherited from Control.)
 | Tag | (Inherited from Control.)
 | Text | (Inherited from ListView.)
 | TextChanged | (Inherited from ListView.)
 | TileSize | (Inherited from ListView.)
 | Top | (Inherited from Control.)
 | TopItem | (Inherited from ListView.)
 | TopLevelControl | (Inherited from Control.)
 | ToString()()()() | (Inherited from ListView.)
 | Update()()()() | (Inherited from Control.)
 | UpdateBounds()()()() | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateExtendedStyles()()()() | (Inherited from ListView.)
 | UpdateStyles()()()() | (Inherited from Control.)
 | UpdateZOrder()()()() | (Inherited from Control.)
 | UseCompatibleStateImageBehavior | (Inherited from ListView.)
 | UseWaitCursor | (Inherited from Control.)
 | Validated | (Inherited from Control.)
 | Validating | (Inherited from Control.)
 | View | (Inherited from ListView.)
 | VirtualItemsSelectionRangeChanged | (Inherited from ListView.)
 | VirtualListSize | (Inherited from ListView.)
 | VirtualMode | (Inherited from ListView.)
 | Visible | (Inherited from Control.)
 | VisibleChanged | (Inherited from Control.)
 | Width | (Inherited from Control.)
 | WindowTarget | (Inherited from Control.)
 | WndProc(Message%) | (Inherited from ListView.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ListView
 |  |  |  |  | EditListView
 |  |  |  |  |  | ShippingServiceListView

Assembly: Samples.Helper (Module: Samples.Helper)


editBox Field

editBox Field
Namespaces ► Samples.Helper.UI ► EditListView ► editBox
Declaration Syntax
C# Visual Basic Visual C++
protected TextBox editBox
Protected editBox As TextBox
protected:
TextBox^ editBox

Assembly: Samples.Helper (Module: Samples.Helper)


EditListView Constructor

EditListView Constructor
Namespaces ► Samples.Helper.UI ► EditListView ► EditListView()()()()
Declaration Syntax
C# Visual Basic Visual C++
public EditListView()
Public Sub New
public:
EditListView()

Assembly: Samples.Helper (Module: Samples.Helper)


ELVDoubleClick Method (sender, e)

ELVDoubleClick Method (sender, e)
Namespaces ► Samples.Helper.UI ► EditListView ► ELVDoubleClick(Object, EventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void ELVDoubleClick(
    Object sender,
    EventArgs e
)
Public Sub ELVDoubleClick ( _
    sender As Object, _
    e As EventArgs _
)
public:
void ELVDoubleClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)

Assembly: Samples.Helper (Module: Samples.Helper)


ELVKeyDown Method (sender, e)

ELVKeyDown Method (sender, e)
Namespaces ► Samples.Helper.UI ► EditListView ► ELVKeyDown(Object, KeyEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void ELVKeyDown(
    Object sender,
    KeyEventArgs e
)
Public Sub ELVKeyDown ( _
    sender As Object, _
    e As KeyEventArgs _
)
public:
void ELVKeyDown(
    Object^ sender,
    KeyEventArgs^ e
)
Parameters
sender (Object)
e (KeyEventArgs)

Assembly: Samples.Helper (Module: Samples.Helper)


ELVMouseDown Method (sender, e)

ELVMouseDown Method (sender, e)
Namespaces ► Samples.Helper.UI ► EditListView ► ELVMouseDown(Object, MouseEventArgs)
Declaration Syntax
C# Visual Basic Visual C++
public void ELVMouseDown(
    Object sender,
    MouseEventArgs e
)
Public Sub ELVMouseDown ( _
    sender As Object, _
    e As MouseEventArgs _
)
public:
void ELVMouseDown(
    Object^ sender,
    MouseEventArgs^ e
)
Parameters
sender (Object)
e (MouseEventArgs)

Assembly: Samples.Helper (Module: Samples.Helper)


InitHeaderInfo Method (headerInfos)

InitHeaderInfo Method (headerInfos)
Namespaces ► Samples.Helper.UI ► EditListView ► InitHeaderInfo(array<HeaderInfo>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
protected void InitHeaderInfo(
    HeaderInfo[] headerInfos
)
Protected Sub InitHeaderInfo ( _
    headerInfos As HeaderInfo() _
)
protected:
void InitHeaderInfo(
    array<HeaderInfo>^ headerInfos
)
Parameters
headerInfos (array< HeaderInfo >[]()[][])

Assembly: Samples.Helper (Module: Samples.Helper)


Initialize Method (infos)

Initialize Method (infos)
Namespaces ► Samples.Helper.UI ► EditListView ► Initialize(array<HeaderInfo>[]()[][])
This method must be called to iniitialize the ListView.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Initialize(
    HeaderInfo[] infos
)
Public Overridable Sub Initialize ( _
    infos As HeaderInfo() _
)
public:
virtual void Initialize(
    array<HeaderInfo>^ infos
)
Parameters
infos (array< HeaderInfo >[]()[][])

Assembly: Samples.Helper (Module: Samples.Helper)


InitListView Method (headerInfos)

InitListView Method (headerInfos)
Namespaces ► Samples.Helper.UI ► EditListView ► InitListView(array<HeaderInfo>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void InitListView(
    HeaderInfo[] headerInfos
)
Protected Overridable Sub InitListView ( _
    headerInfos As HeaderInfo() _
)
protected:
virtual void InitListView(
    array<HeaderInfo>^ headerInfos
)
Parameters
headerInfos (array< HeaderInfo >[]()[][])

Assembly: Samples.Helper (Module: Samples.Helper)


ListViewItemSelected Property

ListViewItemSelected Property
Namespaces ► Samples.Helper.UI ► EditListView ► ListViewItemSelected
Declaration Syntax
C# Visual Basic Visual C++
public ListViewItem ListViewItemSelected { get; }
Public ReadOnly Property ListViewItemSelected As ListViewItem
    Get
public:
property ListViewItem^ ListViewItemSelected {
    ListViewItem^ get ();
}

Assembly: Samples.Helper (Module: Samples.Helper)


ProcessDoubleClick Method (action, spos, epos)

ProcessDoubleClick Method (action, spos, epos)
Namespaces ► Samples.Helper.UI ► EditListView ► ProcessDoubleClick(String, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void ProcessDoubleClick(
    string action,
    int spos,
    int epos
)
Protected Overridable Sub ProcessDoubleClick ( _
    action As String, _
    spos As Integer, _
    epos As Integer _
)
protected:
virtual void ProcessDoubleClick(
    String^ action,
    int spos,
    int epos
)
Parameters
action (String)
spos (Int32)
epos (Int32)

Assembly: Samples.Helper (Module: Samples.Helper)


SelectedListViewItem Property

SelectedListViewItem Property
Namespaces ► Samples.Helper.UI ► EditListView ► SelectedListViewItem
Declaration Syntax
C# Visual Basic Visual C++
public ListViewItem SelectedListViewItem { get; }
Public ReadOnly Property SelectedListViewItem As ListViewItem
    Get
public:
property ListViewItem^ SelectedListViewItem {
    ListViewItem^ get ();
}

Assembly: Samples.Helper (Module: Samples.Helper)


SelectedListViewSubItem Property

SelectedListViewSubItem Property
Namespaces ► Samples.Helper.UI ► EditListView ► SelectedListViewSubItem
Declaration Syntax
C# Visual Basic Visual C++
public ListViewItem..::..ListViewSubItem SelectedListViewSubItem { get; }
Public ReadOnly Property SelectedListViewSubItem As ListViewItem..::..ListViewSubItem
    Get
public:
property ListViewItem..::..ListViewSubItem^ SelectedListViewSubItem {
    ListViewItem..::..ListViewSubItem^ get ();
}

Assembly: Samples.Helper (Module: Samples.Helper)


SubItemSelectedIndex Property

SubItemSelectedIndex Property
Namespaces ► Samples.Helper.UI ► EditListView ► SubItemSelectedIndex
Declaration Syntax
C# Visual Basic Visual C++
public int SubItemSelectedIndex { get; }
Public ReadOnly Property SubItemSelectedIndex As Integer
    Get
public:
property int SubItemSelectedIndex {
    int get ();
}

Assembly: Samples.Helper (Module: Samples.Helper)


SubItemSelectedText Property

SubItemSelectedText Property
Namespaces ► Samples.Helper.UI ► EditListView ► SubItemSelectedText
Declaration Syntax
C# Visual Basic Visual C++
public string SubItemSelectedText { get; }
Public ReadOnly Property SubItemSelectedText As String
    Get
public:
property String^ SubItemSelectedText {
    String^ get ();
}

Assembly: Samples.Helper (Module: Samples.Helper)


HeaderInfo Structure

HeaderInfo Structure
Namespaces ► Samples.Helper.UI ► HeaderInfo
Declaration Syntax
C# Visual Basic Visual C++
public struct HeaderInfo
Public Structure HeaderInfo
public value class HeaderInfo
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | (Inherited from ValueType.)
 | Finalize()()()() | (Inherited from Object.)
 | GetHashCode()()()() | (Inherited from ValueType.)
 | GetType()()()() | (Inherited from Object.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | name |
 | ToString()()()() | (Inherited from ValueType.)
 | width |

Assembly: Samples.Helper (Module: Samples.Helper)


name Field

name Field
Namespaces ► Samples.Helper.UI ► HeaderInfo ► name
Declaration Syntax
C# Visual Basic Visual C++
public string name
Public name As String
public:
String^ name

Assembly: Samples.Helper (Module: Samples.Helper)


width Field

width Field
Namespaces ► Samples.Helper.UI ► HeaderInfo ► width
Declaration Syntax
C# Visual Basic Visual C++
public int width
Public width As Integer
public:
int width

Assembly: Samples.Helper (Module: Samples.Helper)


IControlTagItem Interface

IControlTagItem Interface
Namespaces ► Samples.Helper.UI ► IControlTagItem
Defines object to associate object with string.
Declaration Syntax
C# Visual Basic Visual C++
public interface IControlTagItem
Public Interface IControlTagItem
public interface class IControlTagItem
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Tag | The object that is associated with the string.
 | Text | The string.

Assembly: Samples.Helper (Module: Samples.Helper)


Tag Property

Tag Property
Namespaces ► Samples.Helper.UI ► IControlTagItem ► Tag
The object that is associated with the string.
Declaration Syntax
C# Visual Basic Visual C++
Object Tag { get; set; }
Property Tag As Object
    Get
    Set
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


Text Property

Text Property
Namespaces ► Samples.Helper.UI ► IControlTagItem ► Text
The string.
Declaration Syntax
C# Visual Basic Visual C++
string Text { get; set; }
Property Text As String
    Get
    Set
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


InternationalShippingServiceControl Class

InternationalShippingServiceControl Class
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl
Summary description for InternationalShippingServiceControl.
Declaration Syntax
C# Visual Basic Visual C++
public class InternationalShippingServiceControl : UserControl
Public Class InternationalShippingServiceControl _
    Inherits UserControl
public ref class InternationalShippingServiceControl : public UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InternationalShippingServiceControl()()()() |
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
 | AccessibilityObject | (Inherited from Control.)
 | AccessibleDefaultActionDescription | (Inherited from Control.)
 | AccessibleDescription | (Inherited from Control.)
 | AccessibleName | (Inherited from Control.)
 | AccessibleRole | (Inherited from Control.)
 | IContainerControl..::..ActivateControl(Control) | (Inherited from ContainerControl.)
 | ActiveControl | (Inherited from ContainerControl.)
 | AdjustFormScrollbars(Boolean) | (Inherited from ContainerControl.)
 | AllowDrop | (Inherited from Control.)
 | Anchor | (Inherited from Control.)
 | AutoScaleDimensions | (Inherited from ContainerControl.)
 | AutoScaleFactor | (Inherited from ContainerControl.)
 | AutoScaleMode | (Inherited from ContainerControl.)
 | AutoScroll | (Inherited from ScrollableControl.)
 | AutoScrollMargin | (Inherited from ScrollableControl.)
 | AutoScrollMinSize | (Inherited from ScrollableControl.)
 | AutoScrollOffset | (Inherited from Control.)
 | AutoScrollPosition | (Inherited from ScrollableControl.)
 | AutoSize | (Inherited from UserControl.)
 | AutoSizeChanged | (Inherited from UserControl.)
 | AutoSizeMode | (Inherited from UserControl.)
 | AutoValidate | (Inherited from UserControl.)
 | AutoValidateChanged | (Inherited from UserControl.)
 | BackColor | (Inherited from Control.)
 | BackColorChanged | (Inherited from Control.)
 | BackgroundImage | (Inherited from Control.)
 | BackgroundImageChanged | (Inherited from Control.)
 | BackgroundImageLayout | (Inherited from Control.)
 | BackgroundImageLayoutChanged | (Inherited from Control.)
 | BeginInvoke(Delegate) | (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | (Inherited from Control.)
 | BorderStyle | (Inherited from UserControl.)
 | Bottom | (Inherited from Control.)
 | Bounds | (Inherited from Control.)
 | BringToFront()()()() | (Inherited from Control.)
 | CanEnableIme | (Inherited from ContainerControl.)
 | CanFocus | (Inherited from Control.)
 | CanRaiseEvents | (Inherited from Control.)
 | CanSelect | (Inherited from Control.)
 | Capture | (Inherited from Control.)
 | CausesValidation | (Inherited from Control.)
 | CausesValidationChanged | (Inherited from Control.)
 | ChangeUICues | (Inherited from Control.)
 | Click | (Inherited from Control.)
 | ClientRectangle | (Inherited from Control.)
 | ClientSize | (Inherited from Control.)
 | ClientSizeChanged | (Inherited from Control.)
 | CompanyName | (Inherited from Control.)
 | Container | (Inherited from Component.)
 | Contains(Control) | (Inherited from Control.)
 | ContainsFocus | (Inherited from Control.)
 | ContextMenu | (Inherited from Control.)
 | ContextMenuChanged | (Inherited from Control.)
 | ContextMenuStrip | (Inherited from Control.)
 | ContextMenuStripChanged | (Inherited from Control.)
 | ControlAdded | (Inherited from Control.)
 | ControlRemoved | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | (Inherited from Control.)
 | CreateControl()()()() | (Inherited from Control.)
 | CreateControlsInstance()()()() | (Inherited from Control.)
 | Created | (Inherited from Control.)
 | CreateGraphics()()()() | (Inherited from Control.)
 | CreateHandle()()()() | (Inherited from Control.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from UserControl.)
 | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
 | Cursor | (Inherited from Control.)
 | CursorChanged | (Inherited from Control.)
 | DataBindings | (Inherited from Control.)
 | DefaultCursor | (Inherited from Control.)
 | DefaultImeMode | (Inherited from Control.)
 | DefaultMargin | (Inherited from Control.)
 | DefaultMaximumSize | (Inherited from Control.)
 | DefaultMinimumSize | (Inherited from Control.)
 | DefaultPadding | (Inherited from Control.)
 | DefaultSize | (Inherited from UserControl.)
 | DefWndProc(Message%) | (Inherited from Control.)
 | DesignMode | (Inherited from Component.)
 | DestroyHandle()()()() | (Inherited from Control.)
 | DisplayRectangle | (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from Component.)
 | Disposed | (Inherited from Component.)
 | Disposing | (Inherited from Control.)
 | Dock | (Inherited from Control.)
 | DockChanged | (Inherited from Control.)
 | DockPadding | (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | (Inherited from Control.)
 | DoubleBuffered | (Inherited from Control.)
 | DoubleClick | (Inherited from Control.)
 | DragDrop | (Inherited from Control.)
 | DragEnter | (Inherited from Control.)
 | DragLeave | (Inherited from Control.)
 | DragOver | (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | (Inherited from Control.)
 | EditListView |
 | Enabled | (Inherited from Control.)
 | EnabledChanged | (Inherited from Control.)
 | EndInvoke(IAsyncResult) | (Inherited from Control.)
 | Enter | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Component.)
 | Finalize()()()() | (Inherited from Component.)
 | FindForm()()()() | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Focused | (Inherited from Control.)
 | Font | (Inherited from Control.)
 | FontChanged | (Inherited from Control.)
 | FontHeight | (Inherited from Control.)
 | ForeColor | (Inherited from Control.)
 | ForeColorChanged | (Inherited from Control.)
 | GetAccessibilityObjectById(Int32) | (Inherited from Control.)
 | GetAutoSizeMode()()()() | (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
 | GetChildAtPoint(Point) | (Inherited from Control.)
 | GetContainerControl()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | (Inherited from Control.)
 | GetPreferredSize(Size) | (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Control.)
 | GetScrollState(Int32) | (Inherited from ScrollableControl.)
 | GetService(Type) | (Inherited from Component.)
 | GetStyle(ControlStyles) | (Inherited from Control.)
 | GetTopLevel()()()() | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GiveFeedback | (Inherited from Control.)
 | GotFocus | (Inherited from Control.)
 | Handle | (Inherited from Control.)
 | HandleCreated | (Inherited from Control.)
 | HandleDestroyed | (Inherited from Control.)
 | HasChildren | (Inherited from Control.)
 | Height | (Inherited from Control.)
 | HelpRequested | (Inherited from Control.)
 | Hide()()()() | (Inherited from Control.)
 | HorizontalScroll | (Inherited from ScrollableControl.)
 | HScroll | (Inherited from ScrollableControl.)
 | ImeMode | (Inherited from Control.)
 | ImeModeBase | (Inherited from Control.)
 | ImeModeChanged | (Inherited from Control.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | (Inherited from Control.)
 | Invalidate(Region) | (Inherited from Control.)
 | Invalidate(Region, Boolean) | (Inherited from Control.)
 | Invalidate()()()() | (Inherited from Control.)
 | Invalidate(Boolean) | (Inherited from Control.)
 | Invalidate(Rectangle) | (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
 | Invalidated | (Inherited from Control.)
 | Invoke(Delegate) | (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokeRequired | (Inherited from Control.)
 | IsAccessible | (Inherited from Control.)
 | IsDisposed | (Inherited from Control.)
 | IsHandleCreated | (Inherited from Control.)
 | IsInputChar(Char) | (Inherited from Control.)
 | IsInputKey(Keys) | (Inherited from Control.)
 | IsMirrored | (Inherited from Control.)
 | KeyDown | (Inherited from Control.)
 | KeyPress | (Inherited from Control.)
 | KeyUp | (Inherited from Control.)
 | Layout | (Inherited from Control.)
 | LayoutEngine | (Inherited from Control.)
 | Leave | (Inherited from Control.)
 | Left | (Inherited from Control.)
 | Load | (Inherited from UserControl.)
 | Location | (Inherited from Control.)
 | LocationChanged | (Inherited from Control.)
 | LostFocus | (Inherited from Control.)
 | Margin | (Inherited from Control.)
 | MarginChanged | (Inherited from Control.)
 | MaximumSize | (Inherited from Control.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumSize | (Inherited from Control.)
 | MouseCaptureChanged | (Inherited from Control.)
 | MouseClick | (Inherited from Control.)
 | MouseDoubleClick | (Inherited from Control.)
 | MouseDown | (Inherited from Control.)
 | MouseEnter | (Inherited from Control.)
 | MouseHover | (Inherited from Control.)
 | MouseLeave | (Inherited from Control.)
 | MouseMove | (Inherited from Control.)
 | MouseUp | (Inherited from Control.)
 | MouseWheel | (Inherited from Control.)
 | Move | (Inherited from Control.)
 | Name | (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | (Inherited from Control.)
 | OnAutoSizeChanged(EventArgs) | (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | (Inherited from Control.)
 | OnClick(EventArgs) | (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | (Inherited from Control.)
 | OnCreateControl()()()() | (Inherited from UserControl.)
 | OnCursorChanged(EventArgs) | (Inherited from Control.)
 | OnDockChanged(EventArgs) | (Inherited from Control.)
 | OnDoubleClick(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | OnDragLeave(EventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragLeave(EventArgs) | (Inherited from Control.)
 | OnDragOver(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragOver(DragEventArgs) | (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnEnter(EventArgs) | (Inherited from Control.)
 | OnFontChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from Control.)
 | OnGotFocus(EventArgs) | (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from Control.)
 | OnHandleDestroyed(EventArgs) | (Inherited from Control.)
 | OnHelpRequested(HelpEventArgs) | (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from ContainerControl.)
 | OnLeave(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from UserControl.)
 | OnLocationChanged(EventArgs) | (Inherited from Control.)
 | OnLostFocus(EventArgs) | (Inherited from Control.)
 | OnMarginChanged(EventArgs) | (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from UserControl.)
 | OnMouseEnter(EventArgs) | (Inherited from Control.)
 | OnMouseHover(EventArgs) | (Inherited from Control.)
 | OnMouseLeave(EventArgs) | (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | (Inherited from Control.)
 | OnNotifyMessage(Message) | (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | (Inherited from Control.)
 | OnPrint(PaintEventArgs) | (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from Control.)
 | OnRegionChanged(EventArgs) | (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from UserControl.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnScroll(ScrollEventArgs) | (Inherited from ScrollableControl.)
 | OnSizeChanged(EventArgs) | (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Control.)
 | OnValidated(EventArgs) | (Inherited from Control.)
 | OnValidating(CancelEventArgs) | (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | (Inherited from ScrollableControl.)
 | Padding | (Inherited from Control.)
 | PaddingChanged | (Inherited from Control.)
 | Paint | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | ParentChanged | (Inherited from Control.)
 | ParentForm | (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | (Inherited from ContainerControl.)
 | PerformLayout()()()() | (Inherited from Control.)
 | PerformLayout(Control, String) | (Inherited from Control.)
 | PointToClient(Point) | (Inherited from Control.)
 | PointToScreen(Point) | (Inherited from Control.)
 | PreferredSize | (Inherited from Control.)
 | PreProcessControlMessage(Message%) | (Inherited from Control.)
 | PreProcessMessage(Message%) | (Inherited from Control.)
 | PreviewKeyDown | (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from ContainerControl.)
 | ProcessDialogChar(Char) | (Inherited from ContainerControl.)
 | ProcessDialogKey(Keys) | (Inherited from ContainerControl.)
 | ProcessKeyEventArgs(Message%) | (Inherited from Control.)
 | ProcessKeyMessage(Message%) | (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from ContainerControl.)
 | ProcessTabKey(Boolean) | (Inherited from ContainerControl.)
 | ProductName | (Inherited from Control.)
 | ProductVersion | (Inherited from Control.)
 | QueryAccessibilityHelp | (Inherited from Control.)
 | QueryContinueDrag | (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | (Inherited from Control.)
 | RecreateHandle()()()() | (Inherited from Control.)
 | RecreatingHandle | (Inherited from Control.)
 | RectangleToClient(Rectangle) | (Inherited from Control.)
 | RectangleToScreen(Rectangle) | (Inherited from Control.)
 | Refresh()()()() | (Inherited from Control.)
 | Region | (Inherited from Control.)
 | RegionChanged | (Inherited from Control.)
 | RenderRightToLeft | Obsolete. (Inherited from Control.)
 | ResetBackColor()()()() | (Inherited from Control.)
 | ResetBindings()()()() | (Inherited from Control.)
 | ResetCursor()()()() | (Inherited from Control.)
 | ResetFont()()()() | (Inherited from Control.)
 | ResetForeColor()()()() | (Inherited from Control.)
 | ResetImeMode()()()() | (Inherited from Control.)
 | ResetMouseEventArgs()()()() | (Inherited from Control.)
 | ResetRightToLeft()()()() | (Inherited from Control.)
 | ResetText()()()() | (Inherited from Control.)
 | Resize | (Inherited from Control.)
 | ResizeRedraw | (Inherited from Control.)
 | ResumeLayout()()()() | (Inherited from Control.)
 | ResumeLayout(Boolean) | (Inherited from Control.)
 | Right | (Inherited from Control.)
 | RightToLeft | (Inherited from Control.)
 | RightToLeftChanged | (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | (Inherited from Control.)
 | Scale(Single) | Obsolete. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. (Inherited from Control.)
 | Scale(SizeF) | (Inherited from Control.)
 | ScaleChildren | (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from ScrollableControl.)
 | ScaleCore(Single, Single) | (Inherited from ScrollableControl.)
 | Scroll | (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
 | Select()()()() | (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | (Inherited from Control.)
 | SendToBack()()()() | (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | (Inherited from Control.)
 | SetDisplayRectLocation(Int32, Int32) | (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | (Inherited from Control.)
 | SetTopLevel(Boolean) | (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Control.)
 | Show()()()() | (Inherited from Control.)
 | ShowFocusCues | (Inherited from Control.)
 | ShowKeyboardCues | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | Size | (Inherited from Control.)
 | SizeChanged | (Inherited from Control.)
 | SizeFromClientSize(Size) | (Inherited from Control.)
 | StyleChanged | (Inherited from Control.)
 | SuspendLayout()()()() | (Inherited from Control.)
 | SystemColorsChanged | (Inherited from Control.)
 | TabIndex | (Inherited from Control.)
 | TabIndexChanged | (Inherited from Control.)
 | TabStop | (Inherited from Control.)
 | TabStopChanged | (Inherited from Control.)
 | Tag | (Inherited from Control.)
 | Text | (Inherited from UserControl.)
 | TextChanged | (Inherited from UserControl.)
 | Top | (Inherited from Control.)
 | TopLevelControl | (Inherited from Control.)
 | ToString()()()() | (Inherited from Component.)
 | Update()()()() | (Inherited from Control.)
 | UpdateBounds()()()() | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateDefaultButton()()()() | (Inherited from ContainerControl.)
 | UpdateStyles()()()() | (Inherited from Control.)
 | UpdateZOrder()()()() | (Inherited from Control.)
 | UseWaitCursor | (Inherited from Control.)
 | Validate()()()() | (Inherited from ContainerControl.)
 | Validate(Boolean) | (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from UserControl.)
 | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
 | Validated | (Inherited from Control.)
 | Validating | (Inherited from Control.)
 | VerticalScroll | (Inherited from ScrollableControl.)
 | Visible | (Inherited from Control.)
 | VisibleChanged | (Inherited from Control.)
 | VScroll | (Inherited from ScrollableControl.)
 | Width | (Inherited from Control.)
 | WindowTarget | (Inherited from Control.)
 | WndProc(Message%) | (Inherited from UserControl.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | UserControl
 |  |  |  |  |  |  | InternationalShippingServiceControl

Assembly: Samples.Helper (Module: Samples.Helper)


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)

Assembly: Samples.Helper (Module: Samples.Helper)


EditListView Property

EditListView Property
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► EditListView
Declaration Syntax
C# Visual Basic Visual C++
public IntlShippingServiceListView EditListView { get; }
Public ReadOnly Property EditListView As IntlShippingServiceListView
    Get
public:
property IntlShippingServiceListView^ EditListView {
    IntlShippingServiceListView^ get ();
}

Assembly: Samples.Helper (Module: Samples.Helper)


InternationalShippingServiceControl Constructor

InternationalShippingServiceControl Constructor
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► InternationalShippingServiceControl()()()()
Declaration Syntax
C# Visual Basic Visual C++
public InternationalShippingServiceControl()
Public Sub New
public:
InternationalShippingServiceControl()

Assembly: Samples.Helper (Module: Samples.Helper)


IntlShippingServiceListView Class

IntlShippingServiceListView Class
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView
Summary description for ShippingServiceListView.
Declaration Syntax
C# Visual Basic Visual C++
public class IntlShippingServiceListView : ShippingServiceListView
Public Class IntlShippingServiceListView _
    Inherits ShippingServiceListView
public ref class IntlShippingServiceListView : public ShippingServiceListView
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntlShippingServiceListView()()()() |
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
 | AccessibilityObject | (Inherited from Control.)
 | AccessibleDefaultActionDescription | (Inherited from Control.)
 | AccessibleDescription | (Inherited from Control.)
 | AccessibleName | (Inherited from Control.)
 | AccessibleRole | (Inherited from Control.)
 | Activation | (Inherited from ListView.)
 | AfterLabelEdit | (Inherited from ListView.)
 | Alignment | (Inherited from ListView.)
 | AllowColumnReorder | (Inherited from ListView.)
 | AllowDrop | (Inherited from Control.)
 | Anchor | (Inherited from Control.)
 | ArrangeIcons(ListViewAlignment) | (Inherited from ListView.)
 | ArrangeIcons()()()() | (Inherited from ListView.)
 | AutoArrange | (Inherited from ListView.)
 | AutoResizeColumn(Int32, ColumnHeaderAutoResizeStyle) | (Inherited from ListView.)
 | AutoResizeColumns(ColumnHeaderAutoResizeStyle) | (Inherited from ListView.)
 | AutoScrollOffset | (Inherited from Control.)
 | AutoSize | (Inherited from Control.)
 | AutoSizeChanged | (Inherited from Control.)
 | BackColor | (Inherited from ListView.)
 | BackColorChanged | (Inherited from Control.)
 | BackgroundImage | (Inherited from Control.)
 | BackgroundImageChanged | (Inherited from Control.)
 | BackgroundImageLayout | (Inherited from ListView.)
 | BackgroundImageLayoutChanged | (Inherited from ListView.)
 | BackgroundImageTiled | (Inherited from ListView.)
 | BeforeLabelEdit | (Inherited from ListView.)
 | BeginInvoke(Delegate) | (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | BeginUpdate()()()() | (Inherited from ListView.)
 | BindingContext | (Inherited from Control.)
 | BindingContextChanged | (Inherited from Control.)
 | BorderStyle | (Inherited from ListView.)
 | Bottom | (Inherited from Control.)
 | Bounds | (Inherited from Control.)
 | BringToFront()()()() | (Inherited from Control.)
 | CacheVirtualItems | (Inherited from ListView.)
 | CanEnableIme | (Inherited from Control.)
 | CanFocus | (Inherited from Control.)
 | CanRaiseEvents | (Inherited from Control.)
 | CanSelect | (Inherited from Control.)
 | Capture | (Inherited from Control.)
 | CausesValidation | (Inherited from Control.)
 | CausesValidationChanged | (Inherited from Control.)
 | ChangeUICues | (Inherited from Control.)
 | CheckBoxes | (Inherited from ListView.)
 | CheckedIndices | (Inherited from ListView.)
 | CheckedItems | (Inherited from ListView.)
 | Clear()()()() | (Inherited from ListView.)
 | Click | (Inherited from Control.)
 | ClientRectangle | (Inherited from Control.)
 | ClientSize | (Inherited from Control.)
 | ClientSizeChanged | (Inherited from Control.)
 | cmbBox | (Inherited from ShippingServiceListView.)
 | ColumnClick | (Inherited from ListView.)
 | ColumnReordered | (Inherited from ListView.)
 | Columns | (Inherited from ListView.)
 | ColumnWidthChanged | (Inherited from ListView.)
 | ColumnWidthChanging | (Inherited from ListView.)
 | ComboBoxColumnName | (Inherited from ShippingServiceListView.)
 | ComboColumnName | (Inherited from ShippingServiceListView.)
 | CompanyName | (Inherited from Control.)
 | Container | (Inherited from Component.)
 | Contains(Control) | (Inherited from Control.)
 | ContainsFocus | (Inherited from Control.)
 | ContextMenu | (Inherited from Control.)
 | ContextMenuChanged | (Inherited from Control.)
 | ContextMenuStrip | (Inherited from Control.)
 | ContextMenuStripChanged | (Inherited from Control.)
 | ControlAdded | (Inherited from Control.)
 | ControlRemoved | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | (Inherited from Control.)
 | CreateControl()()()() | (Inherited from Control.)
 | CreateControlsInstance()()()() | (Inherited from Control.)
 | Created | (Inherited from Control.)
 | CreateGraphics()()()() | (Inherited from Control.)
 | CreateHandle()()()() | (Inherited from ListView.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from ListView.)
 | Cursor | (Inherited from Control.)
 | CursorChanged | (Inherited from Control.)
 | DataBindings | (Inherited from Control.)
 | DefaultCursor | (Inherited from Control.)
 | DefaultImeMode | (Inherited from Control.)
 | DefaultMargin | (Inherited from Control.)
 | DefaultMaximumSize | (Inherited from Control.)
 | DefaultMinimumSize | (Inherited from Control.)
 | DefaultPadding | (Inherited from Control.)
 | DefaultSize | (Inherited from ListView.)
 | DefWndProc(Message%) | (Inherited from Control.)
 | DELIMITER |
 | DesignMode | (Inherited from Component.)
 | DestroyHandle()()()() | (Inherited from Control.)
 | DisplayRectangle | (Inherited from Control.)
 | Dispose(Boolean) | (Inherited from ListView.)
 | Dispose()()()() | (Inherited from Component.)
 | Disposed | (Inherited from Component.)
 | Disposing | (Inherited from Control.)
 | Dock | (Inherited from Control.)
 | DockChanged | (Inherited from Control.)
 | DoDragDrop(Object, DragDropEffects) | (Inherited from Control.)
 | DoubleBuffered | (Inherited from ListView.)
 | DoubleClick | (Inherited from Control.)
 | DragDrop | (Inherited from Control.)
 | DragEnter | (Inherited from Control.)
 | DragLeave | (Inherited from Control.)
 | DragOver | (Inherited from Control.)
 | DrawColumnHeader | (Inherited from ListView.)
 | DrawItem | (Inherited from ListView.)
 | DrawSubItem | (Inherited from ListView.)
 | DrawToBitmap(Bitmap, Rectangle) | (Inherited from Control.)
 | editBox | (Inherited from EditListView.)
 | ELVDoubleClick(Object, EventArgs) | (Inherited from EditListView.)
 | ELVKeyDown(Object, KeyEventArgs) | (Inherited from EditListView.)
 | ELVMouseDown(Object, MouseEventArgs) | (Inherited from EditListView.)
 | Enabled | (Inherited from Control.)
 | EnabledChanged | (Inherited from Control.)
 | EndInvoke(IAsyncResult) | (Inherited from Control.)
 | EndUpdate()()()() | (Inherited from ListView.)
 | EnsureVisible(Int32) | (Inherited from ListView.)
 | Enter | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Component.)
 | Finalize()()()() | (Inherited from Component.)
 | FindForm()()()() | (Inherited from Control.)
 | FindItemWithText(String) | (Inherited from ListView.)
 | FindItemWithText(String, Boolean, Int32) | (Inherited from ListView.)
 | FindItemWithText(String, Boolean, Int32, Boolean) | (Inherited from ListView.)
 | FindNearestItem(SearchDirectionHint, Point) | (Inherited from ListView.)
 | FindNearestItem(SearchDirectionHint, Int32, Int32) | (Inherited from ListView.)
 | Focus()()()() | (Inherited from Control.)
 | Focused | (Inherited from Control.)
 | FocusedItem | (Inherited from ListView.)
 | Font | (Inherited from Control.)
 | FontChanged | (Inherited from Control.)
 | FontHeight | (Inherited from Control.)
 | ForeColor | (Inherited from ListView.)
 | ForeColorChanged | (Inherited from Control.)
 | FullRowSelect | (Inherited from ListView.)
 | GetAccessibilityObjectById(Int32) | (Inherited from Control.)
 | GetAutoSizeMode()()()() | (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
 | GetChildAtPoint(Point) | (Inherited from Control.)
 | GetContainerControl()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItemAt(Int32, Int32) | (Inherited from ListView.)
 | GetItemRect(Int32) | (Inherited from ListView.)
 | GetItemRect(Int32, ItemBoundsPortion) | (Inherited from ListView.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | (Inherited from Control.)
 | GetPreferredSize(Size) | (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Control.)
 | GetService(Type) | (Inherited from Component.)
 | GetShippingServiceOptions()()()() | (Overrides ShippingServiceListView.GetShippingServiceOptions()()()().)
 | GetStyle(ControlStyles) | (Inherited from Control.)
 | GetTopLevel()()()() | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GiveFeedback | (Inherited from Control.)
 | GotFocus | (Inherited from Control.)
 | GridLines | (Inherited from ListView.)
 | Groups | (Inherited from ListView.)
 | Handle | (Inherited from Control.)
 | HandleCreated | (Inherited from Control.)
 | HandleDestroyed | (Inherited from Control.)
 | HasChildren | (Inherited from Control.)
 | HeaderStyle | (Inherited from ListView.)
 | Height | (Inherited from Control.)
 | HelpRequested | (Inherited from Control.)
 | Hide()()()() | (Inherited from Control.)
 | HideSelection | (Inherited from ListView.)
 | HitTest(Point) | (Inherited from ListView.)
 | HitTest(Int32, Int32) | (Inherited from ListView.)
 | HotTracking | (Inherited from ListView.)
 | HoverSelection | (Inherited from ListView.)
 | ImeMode | (Inherited from Control.)
 | ImeModeBase | (Inherited from Control.)
 | ImeModeChanged | (Inherited from Control.)
 | InitHeaderInfo(array<HeaderInfo>[]()[][]) | (Inherited from EditListView.)
 | Initialize(array<HeaderInfo>[]()[][]) | This method must be called to iniitialize the ListView. (Overrides ShippingServiceListView.Initialize(array<HeaderInfo>[]()[][]).)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | (Inherited from Control.)
 | InitListView(array<HeaderInfo>[]()[][]) | (Overrides ShippingServiceListView.InitListView(array<HeaderInfo>[]()[][]).)
 | InsertionMark | (Inherited from ListView.)
 | Invalidate(Region) | (Inherited from Control.)
 | Invalidate(Region, Boolean) | (Inherited from Control.)
 | Invalidate()()()() | (Inherited from Control.)
 | Invalidate(Boolean) | (Inherited from Control.)
 | Invalidate(Rectangle) | (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
 | Invalidated | (Inherited from Control.)
 | Invoke(Delegate) | (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokeRequired | (Inherited from Control.)
 | IsAccessible | (Inherited from Control.)
 | IsDisposed | (Inherited from Control.)
 | IsHandleCreated | (Inherited from Control.)
 | IsInputChar(Char) | (Inherited from Control.)
 | IsInputKey(Keys) | (Inherited from ListView.)
 | IsMirrored | (Inherited from Control.)
 | ItemActivate | (Inherited from ListView.)
 | ItemCheck | (Inherited from ListView.)
 | ItemChecked | (Inherited from ListView.)
 | ItemDrag | (Inherited from ListView.)
 | ItemMouseHover | (Inherited from ListView.)
 | Items | (Inherited from ListView.)
 | ItemSelectionChanged | (Inherited from ListView.)
 | KeyDown | (Inherited from Control.)
 | KeyPress | (Inherited from Control.)
 | KeyUp | (Inherited from Control.)
 | LabelEdit | (Inherited from ListView.)
 | LabelWrap | (Inherited from ListView.)
 | LargeImageList | (Inherited from ListView.)
 | Layout | (Inherited from Control.)
 | LayoutEngine | (Inherited from Control.)
 | Leave | (Inherited from Control.)
 | Left | (Inherited from Control.)
 | listBox |
 | ListViewItemSelected | (Inherited from EditListView.)
 | ListViewItemSorter | (Inherited from ListView.)
 | Location | (Inherited from Control.)
 | LocationChanged | (Inherited from Control.)
 | LostFocus | (Inherited from Control.)
 | Margin | (Inherited from Control.)
 | MarginChanged | (Inherited from Control.)
 | MaximumSize | (Inherited from Control.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumSize | (Inherited from Control.)
 | MouseCaptureChanged | (Inherited from Control.)
 | MouseClick | (Inherited from Control.)
 | MouseDoubleClick | (Inherited from Control.)
 | MouseDown | (Inherited from Control.)
 | MouseEnter | (Inherited from Control.)
 | MouseHover | (Inherited from Control.)
 | MouseLeave | (Inherited from Control.)
 | MouseMove | (Inherited from Control.)
 | MouseUp | (Inherited from Control.)
 | MouseWheel | (Inherited from Control.)
 | Move | (Inherited from Control.)
 | MultiSelect | (Inherited from ListView.)
 | Name | (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | (Inherited from Control.)
 | OnAfterLabelEdit(LabelEditEventArgs) | (Inherited from ListView.)
 | OnAutoSizeChanged(EventArgs) | (Inherited from Control.)
 | OnBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | (Inherited from ListView.)
 | OnBackgroundImageLayoutChanged(EventArgs) | (Inherited from Control.)
 | OnBeforeLabelEdit(LabelEditEventArgs) | (Inherited from ListView.)
 | OnBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnCacheVirtualItems(CacheVirtualItemsEventArgs) | (Inherited from ListView.)
 | OnCausesValidationChanged(EventArgs) | (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | (Inherited from Control.)
 | OnClick(EventArgs) | (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | (Inherited from Control.)
 | OnColumnClick(ColumnClickEventArgs) | (Inherited from ListView.)
 | OnColumnReordered(ColumnReorderedEventArgs) | (Inherited from ListView.)
 | OnColumnWidthChanged(ColumnWidthChangedEventArgs) | (Inherited from ListView.)
 | OnColumnWidthChanging(ColumnWidthChangingEventArgs) | (Inherited from ListView.)
 | OnContextMenuChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | (Inherited from Control.)
 | OnCreateControl()()()() | (Inherited from Control.)
 | OnCursorChanged(EventArgs) | (Inherited from Control.)
 | OnDockChanged(EventArgs) | (Inherited from Control.)
 | OnDoubleClick(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | OnDragLeave(EventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragLeave(EventArgs) | (Inherited from Control.)
 | OnDragOver(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragOver(DragEventArgs) | (Inherited from Control.)
 | OnDrawColumnHeader(DrawListViewColumnHeaderEventArgs) | (Inherited from ListView.)
 | OnDrawItem(DrawListViewItemEventArgs) | (Inherited from ListView.)
 | OnDrawSubItem(DrawListViewSubItemEventArgs) | (Inherited from ListView.)
 | OnEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnEnter(EventArgs) | (Inherited from Control.)
 | OnFontChanged(EventArgs) | (Inherited from ListView.)
 | OnForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from Control.)
 | OnGotFocus(EventArgs) | (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from ListView.)
 | OnHandleDestroyed(EventArgs) | (Inherited from ListView.)
 | OnHelpRequested(HelpEventArgs) | (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | (Inherited from Control.)
 | OnItemActivate(EventArgs) | (Inherited from ListView.)
 | OnItemCheck(ItemCheckEventArgs) | (Inherited from ListView.)
 | OnItemChecked(ItemCheckedEventArgs) | (Inherited from ListView.)
 | OnItemDrag(ItemDragEventArgs) | (Inherited from ListView.)
 | OnItemMouseHover(ListViewItemMouseHoverEventArgs) | (Inherited from ListView.)
 | OnItemSelectionChanged(ListViewItemSelectionChangedEventArgs) | (Inherited from ListView.)
 | OnKeyDown(KeyEventArgs) | (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from Control.)
 | OnLeave(EventArgs) | (Inherited from Control.)
 | OnLocationChanged(EventArgs) | (Inherited from Control.)
 | OnLostFocus(EventArgs) | (Inherited from Control.)
 | OnMarginChanged(EventArgs) | (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from Control.)
 | OnMouseEnter(EventArgs) | (Inherited from Control.)
 | OnMouseHover(EventArgs) | (Inherited from ListView.)
 | OnMouseLeave(EventArgs) | (Inherited from ListView.)
 | OnMouseMove(MouseEventArgs) | (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | (Inherited from Control.)
 | OnMove(EventArgs) | (Inherited from Control.)
 | OnNotifyMessage(Message) | (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | (Inherited from Control.)
 | OnPaint(PaintEventArgs) | (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | (Inherited from Control.)
 | OnParentBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ListView.)
 | OnParentCursorChanged(EventArgs) | (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | (Inherited from Control.)
 | OnPrint(PaintEventArgs) | (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from Control.)
 | OnRegionChanged(EventArgs) | (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from ListView.)
 | OnRetrieveVirtualItem(RetrieveVirtualItemEventArgs) | (Inherited from ListView.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from Control.)
 | OnRightToLeftLayoutChanged(EventArgs) | (Inherited from ListView.)
 | OnSearchForVirtualItem(SearchForVirtualItemEventArgs) | (Inherited from ListView.)
 | OnSelectedIndexChanged(EventArgs) | (Inherited from ListView.)
 | OnSizeChanged(EventArgs) | (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | (Inherited from ListView.)
 | OnTabIndexChanged(EventArgs) | (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Control.)
 | OnValidated(EventArgs) | (Inherited from Control.)
 | OnValidating(CancelEventArgs) | (Inherited from Control.)
 | OnVirtualItemsSelectionRangeChanged(ListViewVirtualItemsSelectionRangeChangedEventArgs) | (Inherited from ListView.)
 | OnVisibleChanged(EventArgs) | (Inherited from Control.)
 | OwnerDraw | (Inherited from ListView.)
 | Padding | (Inherited from ListView.)
 | PaddingChanged | (Inherited from ListView.)
 | Paint | (Inherited from ListView.)
 | Parent | (Inherited from Control.)
 | ParentChanged | (Inherited from Control.)
 | PerformLayout()()()() | (Inherited from Control.)
 | PerformLayout(Control, String) | (Inherited from Control.)
 | PointToClient(Point) | (Inherited from Control.)
 | PointToScreen(Point) | (Inherited from Control.)
 | PreferredSize | (Inherited from Control.)
 | PreProcessControlMessage(Message%) | (Inherited from Control.)
 | PreProcessMessage(Message%) | (Inherited from Control.)
 | PreviewKeyDown | (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from Control.)
 | ProcessDialogChar(Char) | (Inherited from Control.)
 | ProcessDialogKey(Keys) | (Inherited from Control.)
 | ProcessDoubleClick(String, Int32, Int32) | (Overrides ShippingServiceListView.ProcessDoubleClick(String, Int32, Int32).)
 | ProcessKeyEventArgs(Message%) | (Inherited from Control.)
 | ProcessKeyMessage(Message%) | (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from Control.)
 | ProductName | (Inherited from Control.)
 | ProductVersion | (Inherited from Control.)
 | QueryAccessibilityHelp | (Inherited from Control.)
 | QueryContinueDrag | (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | (Inherited from Control.)
 | RealizeProperties()()()() | (Inherited from ListView.)
 | RecreateHandle()()()() | (Inherited from Control.)
 | RecreatingHandle | (Inherited from Control.)
 | RectangleToClient(Rectangle) | (Inherited from Control.)
 | RectangleToScreen(Rectangle) | (Inherited from Control.)
 | RedrawItems(Int32, Int32, Boolean) | (Inherited from ListView.)
 | Refresh()()()() | (Inherited from Control.)
 | Region | (Inherited from Control.)
 | RegionChanged | (Inherited from Control.)
 | RenderRightToLeft | Obsolete. (Inherited from Control.)
 | ResetBackColor()()()() | (Inherited from Control.)
 | ResetBindings()()()() | (Inherited from Control.)
 | ResetCursor()()()() | (Inherited from Control.)
 | ResetFont()()()() | (Inherited from Control.)
 | ResetForeColor()()()() | (Inherited from Control.)
 | ResetImeMode()()()() | (Inherited from Control.)
 | ResetMouseEventArgs()()()() | (Inherited from Control.)
 | ResetRightToLeft()()()() | (Inherited from Control.)
 | ResetText()()()() | (Inherited from Control.)
 | Resize | (Inherited from Control.)
 | ResizeRedraw | (Inherited from Control.)
 | ResumeLayout()()()() | (Inherited from Control.)
 | ResumeLayout(Boolean) | (Inherited from Control.)
 | RetrieveVirtualItem | (Inherited from ListView.)
 | Right | (Inherited from Control.)
 | RightToLeft | (Inherited from Control.)
 | RightToLeftChanged | (Inherited from Control.)
 | RightToLeftLayout | (Inherited from ListView.)
 | RightToLeftLayoutChanged | (Inherited from ListView.)
 | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | (Inherited from Control.)
 | Scale(Single) | Obsolete. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. (Inherited from Control.)
 | Scale(SizeF) | (Inherited from Control.)
 | ScaleChildren | (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from Control.)
 | ScaleCore(Single, Single) | (Inherited from Control.)
 | Scrollable | (Inherited from ListView.)
 | SearchForVirtualItem | (Inherited from ListView.)
 | Select()()()() | (Inherited from Control.)
 | Select(Boolean, Boolean) | (Inherited from Control.)
 | SelectedIndexChanged | (Inherited from ListView.)
 | SelectedIndices | (Inherited from ListView.)
 | SelectedItems | (Inherited from ListView.)
 | SelectedListViewItem | (Inherited from EditListView.)
 | SelectedListViewSubItem | (Inherited from EditListView.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | (Inherited from Control.)
 | SendToBack()()()() | (Inherited from Control.)
 | SetAutoSizeMode(AutoSizeMode) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | (Inherited from Control.)
 | SetComboBoxOptions()()()() | (Inherited from ShippingServiceListView.)
 | SetComboBoxOptions(array<ControlTagItem>[]()[][]) | (Inherited from ShippingServiceListView.)
 | SetStyle(ControlStyles, Boolean) | (Inherited from Control.)
 | SetTopLevel(Boolean) | (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Control.)
 | ShipToLocationControlTagItems |
 | ShipToLocations |
 | Show()()()() | (Inherited from Control.)
 | ShowFocusCues | (Inherited from Control.)
 | ShowGroups | (Inherited from ListView.)
 | ShowItemToolTips | (Inherited from ListView.)
 | ShowKeyboardCues | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | Size | (Inherited from Control.)
 | SizeChanged | (Inherited from Control.)
 | SizeFromClientSize(Size) | (Inherited from Control.)
 | SmallImageList | (Inherited from ListView.)
 | Sort()()()() | (Inherited from ListView.)
 | Sorting | (Inherited from ListView.)
 | StateImageList | (Inherited from ListView.)
 | StringOptions | (Inherited from ShippingServiceListView.)
 | StyleChanged | (Inherited from Control.)
 | SubItemSelectedIndex | (Inherited from EditListView.)
 | SubItemSelectedText | (Inherited from EditListView.)
 | SuspendLayout()()()() | (Inherited from Control.)
 | SystemColorsChanged | (Inherited from Control.)
 | TabIndex | (Inherited from Control.)
 | TabIndexChanged | (Inherited from Control.)
 | TabStop | (Inherited from Control.)
 | TabStopChanged | (Inherited from Control.)
 | Tag | (Inherited from Control.)
 | TagItemOptions | (Inherited from ShippingServiceListView.)
 | Text | (Inherited from ListView.)
 | TextChanged | (Inherited from ListView.)
 | TileSize | (Inherited from ListView.)
 | Top | (Inherited from Control.)
 | TopItem | (Inherited from ListView.)
 | TopLevelControl | (Inherited from Control.)
 | ToString()()()() | (Inherited from ListView.)
 | Update()()()() | (Inherited from Control.)
 | UpdateBounds()()()() | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateExtendedStyles()()()() | (Inherited from ListView.)
 | UpdateStyles()()()() | (Inherited from Control.)
 | UpdateZOrder()()()() | (Inherited from Control.)
 | UseCompatibleStateImageBehavior | (Inherited from ListView.)
 | UseWaitCursor | (Inherited from Control.)
 | Validated | (Inherited from Control.)
 | Validating | (Inherited from Control.)
 | View | (Inherited from ListView.)
 | VirtualItemsSelectionRangeChanged | (Inherited from ListView.)
 | VirtualListSize | (Inherited from ListView.)
 | VirtualMode | (Inherited from ListView.)
 | Visible | (Inherited from Control.)
 | VisibleChanged | (Inherited from Control.)
 | Width | (Inherited from Control.)
 | WindowTarget | (Inherited from Control.)
 | WndProc(Message%) | (Inherited from ListView.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ListView
 |  |  |  |  | EditListView
 |  |  |  |  |  | ShippingServiceListView
 |  |  |  |  |  |  | IntlShippingServiceListView

Assembly: Samples.Helper (Module: Samples.Helper)


DELIMITER Field

DELIMITER Field
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► DELIMITER
Declaration Syntax
C# Visual Basic Visual C++
public static string DELIMITER
Public Shared DELIMITER As String
public:
static String^ DELIMITER

Assembly: Samples.Helper (Module: Samples.Helper)


GetShippingServiceOptions Method

GetShippingServiceOptions Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► GetShippingServiceOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override ICollection GetShippingServiceOptions()
Public Overrides Function GetShippingServiceOptions As ICollection
public:
virtual ICollection^ GetShippingServiceOptions() override
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


Initialize Method (headerInfos)

Initialize Method (headerInfos)
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► Initialize(array<HeaderInfo>[]()[][])
This method must be called to iniitialize the ListView.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize(
    HeaderInfo[] headerInfos
)
Public Overrides Sub Initialize ( _
    headerInfos As HeaderInfo() _
)
public:
virtual void Initialize(
    array<HeaderInfo>^ headerInfos
) override
Parameters
headerInfos (array< HeaderInfo >[]()[][])

Assembly: Samples.Helper (Module: Samples.Helper)


InitListView Method (headerInfos)

InitListView Method (headerInfos)
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► InitListView(array<HeaderInfo>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
protected override void InitListView(
    HeaderInfo[] headerInfos
)
Protected Overrides Sub InitListView ( _
    headerInfos As HeaderInfo() _
)
protected:
virtual void InitListView(
    array<HeaderInfo>^ headerInfos
) override
Parameters
headerInfos (array< HeaderInfo >[]()[][])

Assembly: Samples.Helper (Module: Samples.Helper)


IntlShippingServiceListView Constructor

IntlShippingServiceListView Constructor
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► IntlShippingServiceListView()()()()
Declaration Syntax
C# Visual Basic Visual C++
public IntlShippingServiceListView()
Public Sub New
public:
IntlShippingServiceListView()

Assembly: Samples.Helper (Module: Samples.Helper)


listBox Field

listBox Field
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► listBox
Declaration Syntax
C# Visual Basic Visual C++
protected ListBox listBox
Protected listBox As ListBox
protected:
ListBox^ listBox

Assembly: Samples.Helper (Module: Samples.Helper)


ProcessDoubleClick Method (action, spos, epos)

ProcessDoubleClick Method (action, spos, epos)
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► ProcessDoubleClick(String, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
protected override void ProcessDoubleClick(
    string action,
    int spos,
    int epos
)
Protected Overrides Sub ProcessDoubleClick ( _
    action As String, _
    spos As Integer, _
    epos As Integer _
)
protected:
virtual void ProcessDoubleClick(
    String^ action,
    int spos,
    int epos
) override
Parameters
action (String)
spos (Int32)
epos (Int32)

Assembly: Samples.Helper (Module: Samples.Helper)


ShipToLocationControlTagItems Property

ShipToLocationControlTagItems Property
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► ShipToLocationControlTagItems
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem[] ShipToLocationControlTagItems { set; }
Public WriteOnly Property ShipToLocationControlTagItems As ControlTagItem()
    Set
public:
property array<ControlTagItem^>^ ShipToLocationControlTagItems {
    void set (array<ControlTagItem^>^ value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


ShipToLocations Property

ShipToLocations Property
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► ShipToLocations
Declaration Syntax
C# Visual Basic Visual C++
public string[] ShipToLocations { set; }
Public WriteOnly Property ShipToLocations As String()
    Set
public:
property array<String^>^ ShipToLocations {
    void set (array<String^>^ value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


ShippingServiceControl Class

ShippingServiceControl Class
Namespaces ► Samples.Helper.UI ► ShippingServiceControl
Summary description for ShippingServiceControl.
Declaration Syntax
C# Visual Basic Visual C++
public class ShippingServiceControl : UserControl
Public Class ShippingServiceControl _
    Inherits UserControl
public ref class ShippingServiceControl : public UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingServiceControl()()()() |
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
 | AccessibilityObject | (Inherited from Control.)
 | AccessibleDefaultActionDescription | (Inherited from Control.)
 | AccessibleDescription | (Inherited from Control.)
 | AccessibleName | (Inherited from Control.)
 | AccessibleRole | (Inherited from Control.)
 | IContainerControl..::..ActivateControl(Control) | (Inherited from ContainerControl.)
 | ActiveControl | (Inherited from ContainerControl.)
 | AdjustFormScrollbars(Boolean) | (Inherited from ContainerControl.)
 | AllowDrop | (Inherited from Control.)
 | Anchor | (Inherited from Control.)
 | AutoScaleDimensions | (Inherited from ContainerControl.)
 | AutoScaleFactor | (Inherited from ContainerControl.)
 | AutoScaleMode | (Inherited from ContainerControl.)
 | AutoScroll | (Inherited from ScrollableControl.)
 | AutoScrollMargin | (Inherited from ScrollableControl.)
 | AutoScrollMinSize | (Inherited from ScrollableControl.)
 | AutoScrollOffset | (Inherited from Control.)
 | AutoScrollPosition | (Inherited from ScrollableControl.)
 | AutoSize | (Inherited from UserControl.)
 | AutoSizeChanged | (Inherited from UserControl.)
 | AutoSizeMode | (Inherited from UserControl.)
 | AutoValidate | (Inherited from UserControl.)
 | AutoValidateChanged | (Inherited from UserControl.)
 | BackColor | (Inherited from Control.)
 | BackColorChanged | (Inherited from Control.)
 | BackgroundImage | (Inherited from Control.)
 | BackgroundImageChanged | (Inherited from Control.)
 | BackgroundImageLayout | (Inherited from Control.)
 | BackgroundImageLayoutChanged | (Inherited from Control.)
 | BeginInvoke(Delegate) | (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | (Inherited from Control.)
 | BorderStyle | (Inherited from UserControl.)
 | Bottom | (Inherited from Control.)
 | Bounds | (Inherited from Control.)
 | BringToFront()()()() | (Inherited from Control.)
 | CanEnableIme | (Inherited from ContainerControl.)
 | CanFocus | (Inherited from Control.)
 | CanRaiseEvents | (Inherited from Control.)
 | CanSelect | (Inherited from Control.)
 | Capture | (Inherited from Control.)
 | CausesValidation | (Inherited from Control.)
 | CausesValidationChanged | (Inherited from Control.)
 | ChangeUICues | (Inherited from Control.)
 | Click | (Inherited from Control.)
 | ClientRectangle | (Inherited from Control.)
 | ClientSize | (Inherited from Control.)
 | ClientSizeChanged | (Inherited from Control.)
 | CompanyName | (Inherited from Control.)
 | Container | (Inherited from Component.)
 | Contains(Control) | (Inherited from Control.)
 | ContainsFocus | (Inherited from Control.)
 | ContextMenu | (Inherited from Control.)
 | ContextMenuChanged | (Inherited from Control.)
 | ContextMenuStrip | (Inherited from Control.)
 | ContextMenuStripChanged | (Inherited from Control.)
 | ControlAdded | (Inherited from Control.)
 | ControlRemoved | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | (Inherited from Control.)
 | CreateControl()()()() | (Inherited from Control.)
 | CreateControlsInstance()()()() | (Inherited from Control.)
 | Created | (Inherited from Control.)
 | CreateGraphics()()()() | (Inherited from Control.)
 | CreateHandle()()()() | (Inherited from Control.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from UserControl.)
 | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
 | Cursor | (Inherited from Control.)
 | CursorChanged | (Inherited from Control.)
 | DataBindings | (Inherited from Control.)
 | DefaultCursor | (Inherited from Control.)
 | DefaultImeMode | (Inherited from Control.)
 | DefaultMargin | (Inherited from Control.)
 | DefaultMaximumSize | (Inherited from Control.)
 | DefaultMinimumSize | (Inherited from Control.)
 | DefaultPadding | (Inherited from Control.)
 | DefaultSize | (Inherited from UserControl.)
 | DefWndProc(Message%) | (Inherited from Control.)
 | DesignMode | (Inherited from Component.)
 | DestroyHandle()()()() | (Inherited from Control.)
 | DisplayRectangle | (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() | (Inherited from Component.)
 | Disposed | (Inherited from Component.)
 | Disposing | (Inherited from Control.)
 | Dock | (Inherited from Control.)
 | DockChanged | (Inherited from Control.)
 | DockPadding | (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | (Inherited from Control.)
 | DoubleBuffered | (Inherited from Control.)
 | DoubleClick | (Inherited from Control.)
 | DragDrop | (Inherited from Control.)
 | DragEnter | (Inherited from Control.)
 | DragLeave | (Inherited from Control.)
 | DragOver | (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | (Inherited from Control.)
 | EditListView |
 | Enabled | (Inherited from Control.)
 | EnabledChanged | (Inherited from Control.)
 | EndInvoke(IAsyncResult) | (Inherited from Control.)
 | Enter | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Component.)
 | Finalize()()()() | (Inherited from Component.)
 | FindForm()()()() | (Inherited from Control.)
 | Focus()()()() | (Inherited from Control.)
 | Focused | (Inherited from Control.)
 | Font | (Inherited from Control.)
 | FontChanged | (Inherited from Control.)
 | FontHeight | (Inherited from Control.)
 | ForeColor | (Inherited from Control.)
 | ForeColorChanged | (Inherited from Control.)
 | GetAccessibilityObjectById(Int32) | (Inherited from Control.)
 | GetAutoSizeMode()()()() | (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
 | GetChildAtPoint(Point) | (Inherited from Control.)
 | GetContainerControl()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | (Inherited from Control.)
 | GetPreferredSize(Size) | (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Control.)
 | GetScrollState(Int32) | (Inherited from ScrollableControl.)
 | GetService(Type) | (Inherited from Component.)
 | GetStyle(ControlStyles) | (Inherited from Control.)
 | GetTopLevel()()()() | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GiveFeedback | (Inherited from Control.)
 | GotFocus | (Inherited from Control.)
 | Handle | (Inherited from Control.)
 | HandleCreated | (Inherited from Control.)
 | HandleDestroyed | (Inherited from Control.)
 | HasChildren | (Inherited from Control.)
 | Height | (Inherited from Control.)
 | HelpRequested | (Inherited from Control.)
 | Hide()()()() | (Inherited from Control.)
 | HorizontalScroll | (Inherited from ScrollableControl.)
 | HScroll | (Inherited from ScrollableControl.)
 | ImeMode | (Inherited from Control.)
 | ImeModeBase | (Inherited from Control.)
 | ImeModeChanged | (Inherited from Control.)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | (Inherited from Control.)
 | Invalidate(Region) | (Inherited from Control.)
 | Invalidate(Region, Boolean) | (Inherited from Control.)
 | Invalidate()()()() | (Inherited from Control.)
 | Invalidate(Boolean) | (Inherited from Control.)
 | Invalidate(Rectangle) | (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
 | Invalidated | (Inherited from Control.)
 | Invoke(Delegate) | (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokeRequired | (Inherited from Control.)
 | IsAccessible | (Inherited from Control.)
 | IsDisposed | (Inherited from Control.)
 | IsHandleCreated | (Inherited from Control.)
 | IsInputChar(Char) | (Inherited from Control.)
 | IsInputKey(Keys) | (Inherited from Control.)
 | IsMirrored | (Inherited from Control.)
 | KeyDown | (Inherited from Control.)
 | KeyPress | (Inherited from Control.)
 | KeyUp | (Inherited from Control.)
 | Layout | (Inherited from Control.)
 | LayoutEngine | (Inherited from Control.)
 | Leave | (Inherited from Control.)
 | Left | (Inherited from Control.)
 | Load | (Inherited from UserControl.)
 | Location | (Inherited from Control.)
 | LocationChanged | (Inherited from Control.)
 | LostFocus | (Inherited from Control.)
 | Margin | (Inherited from Control.)
 | MarginChanged | (Inherited from Control.)
 | MaximumSize | (Inherited from Control.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumSize | (Inherited from Control.)
 | MouseCaptureChanged | (Inherited from Control.)
 | MouseClick | (Inherited from Control.)
 | MouseDoubleClick | (Inherited from Control.)
 | MouseDown | (Inherited from Control.)
 | MouseEnter | (Inherited from Control.)
 | MouseHover | (Inherited from Control.)
 | MouseLeave | (Inherited from Control.)
 | MouseMove | (Inherited from Control.)
 | MouseUp | (Inherited from Control.)
 | MouseWheel | (Inherited from Control.)
 | Move | (Inherited from Control.)
 | Name | (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | (Inherited from Control.)
 | OnAutoSizeChanged(EventArgs) | (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | (Inherited from Control.)
 | OnClick(EventArgs) | (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | (Inherited from Control.)
 | OnCreateControl()()()() | (Inherited from UserControl.)
 | OnCursorChanged(EventArgs) | (Inherited from Control.)
 | OnDockChanged(EventArgs) | (Inherited from Control.)
 | OnDoubleClick(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | OnDragLeave(EventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragLeave(EventArgs) | (Inherited from Control.)
 | OnDragOver(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragOver(DragEventArgs) | (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnEnter(EventArgs) | (Inherited from Control.)
 | OnFontChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from Control.)
 | OnGotFocus(EventArgs) | (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from Control.)
 | OnHandleDestroyed(EventArgs) | (Inherited from Control.)
 | OnHelpRequested(HelpEventArgs) | (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from ContainerControl.)
 | OnLeave(EventArgs) | (Inherited from Control.)
 | OnLoad(EventArgs) | (Inherited from UserControl.)
 | OnLocationChanged(EventArgs) | (Inherited from Control.)
 | OnLostFocus(EventArgs) | (Inherited from Control.)
 | OnMarginChanged(EventArgs) | (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from UserControl.)
 | OnMouseEnter(EventArgs) | (Inherited from Control.)
 | OnMouseHover(EventArgs) | (Inherited from Control.)
 | OnMouseLeave(EventArgs) | (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | (Inherited from Control.)
 | OnNotifyMessage(Message) | (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | (Inherited from Control.)
 | OnPrint(PaintEventArgs) | (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from Control.)
 | OnRegionChanged(EventArgs) | (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from UserControl.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnScroll(ScrollEventArgs) | (Inherited from ScrollableControl.)
 | OnSizeChanged(EventArgs) | (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Control.)
 | OnValidated(EventArgs) | (Inherited from Control.)
 | OnValidating(CancelEventArgs) | (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | (Inherited from ScrollableControl.)
 | Padding | (Inherited from Control.)
 | PaddingChanged | (Inherited from Control.)
 | Paint | (Inherited from Control.)
 | Parent | (Inherited from Control.)
 | ParentChanged | (Inherited from Control.)
 | ParentForm | (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | (Inherited from ContainerControl.)
 | PerformLayout()()()() | (Inherited from Control.)
 | PerformLayout(Control, String) | (Inherited from Control.)
 | PointToClient(Point) | (Inherited from Control.)
 | PointToScreen(Point) | (Inherited from Control.)
 | PreferredSize | (Inherited from Control.)
 | PreProcessControlMessage(Message%) | (Inherited from Control.)
 | PreProcessMessage(Message%) | (Inherited from Control.)
 | PreviewKeyDown | (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from ContainerControl.)
 | ProcessDialogChar(Char) | (Inherited from ContainerControl.)
 | ProcessDialogKey(Keys) | (Inherited from ContainerControl.)
 | ProcessKeyEventArgs(Message%) | (Inherited from Control.)
 | ProcessKeyMessage(Message%) | (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from ContainerControl.)
 | ProcessTabKey(Boolean) | (Inherited from ContainerControl.)
 | ProductName | (Inherited from Control.)
 | ProductVersion | (Inherited from Control.)
 | QueryAccessibilityHelp | (Inherited from Control.)
 | QueryContinueDrag | (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | (Inherited from Control.)
 | RecreateHandle()()()() | (Inherited from Control.)
 | RecreatingHandle | (Inherited from Control.)
 | RectangleToClient(Rectangle) | (Inherited from Control.)
 | RectangleToScreen(Rectangle) | (Inherited from Control.)
 | Refresh()()()() | (Inherited from Control.)
 | Region | (Inherited from Control.)
 | RegionChanged | (Inherited from Control.)
 | RenderRightToLeft | Obsolete. (Inherited from Control.)
 | ResetBackColor()()()() | (Inherited from Control.)
 | ResetBindings()()()() | (Inherited from Control.)
 | ResetCursor()()()() | (Inherited from Control.)
 | ResetFont()()()() | (Inherited from Control.)
 | ResetForeColor()()()() | (Inherited from Control.)
 | ResetImeMode()()()() | (Inherited from Control.)
 | ResetMouseEventArgs()()()() | (Inherited from Control.)
 | ResetRightToLeft()()()() | (Inherited from Control.)
 | ResetText()()()() | (Inherited from Control.)
 | Resize | (Inherited from Control.)
 | ResizeRedraw | (Inherited from Control.)
 | ResumeLayout()()()() | (Inherited from Control.)
 | ResumeLayout(Boolean) | (Inherited from Control.)
 | Right | (Inherited from Control.)
 | RightToLeft | (Inherited from Control.)
 | RightToLeftChanged | (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | (Inherited from Control.)
 | Scale(Single) | Obsolete. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. (Inherited from Control.)
 | Scale(SizeF) | (Inherited from Control.)
 | ScaleChildren | (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from ScrollableControl.)
 | ScaleCore(Single, Single) | (Inherited from ScrollableControl.)
 | Scroll | (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
 | Select()()()() | (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | (Inherited from Control.)
 | SendToBack()()()() | (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | (Inherited from Control.)
 | SetDisplayRectLocation(Int32, Int32) | (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | (Inherited from Control.)
 | SetTopLevel(Boolean) | (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Control.)
 | Show()()()() | (Inherited from Control.)
 | ShowFocusCues | (Inherited from Control.)
 | ShowKeyboardCues | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | Size | (Inherited from Control.)
 | SizeChanged | (Inherited from Control.)
 | SizeFromClientSize(Size) | (Inherited from Control.)
 | StyleChanged | (Inherited from Control.)
 | SuspendLayout()()()() | (Inherited from Control.)
 | SystemColorsChanged | (Inherited from Control.)
 | TabIndex | (Inherited from Control.)
 | TabIndexChanged | (Inherited from Control.)
 | TabStop | (Inherited from Control.)
 | TabStopChanged | (Inherited from Control.)
 | Tag | (Inherited from Control.)
 | Text | (Inherited from UserControl.)
 | TextChanged | (Inherited from UserControl.)
 | Top | (Inherited from Control.)
 | TopLevelControl | (Inherited from Control.)
 | ToString()()()() | (Inherited from Component.)
 | Update()()()() | (Inherited from Control.)
 | UpdateBounds()()()() | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateDefaultButton()()()() | (Inherited from ContainerControl.)
 | UpdateStyles()()()() | (Inherited from Control.)
 | UpdateZOrder()()()() | (Inherited from Control.)
 | UseWaitCursor | (Inherited from Control.)
 | Validate()()()() | (Inherited from ContainerControl.)
 | Validate(Boolean) | (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from UserControl.)
 | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
 | Validated | (Inherited from Control.)
 | Validating | (Inherited from Control.)
 | VerticalScroll | (Inherited from ScrollableControl.)
 | Visible | (Inherited from Control.)
 | VisibleChanged | (Inherited from Control.)
 | VScroll | (Inherited from ScrollableControl.)
 | Width | (Inherited from Control.)
 | WindowTarget | (Inherited from Control.)
 | WndProc(Message%) | (Inherited from UserControl.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | UserControl
 |  |  |  |  |  |  | ShippingServiceControl

Assembly: Samples.Helper (Module: Samples.Helper)


Dispose Method (disposing)

Dispose Method (disposing)
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)

Assembly: Samples.Helper (Module: Samples.Helper)


EditListView Property

EditListView Property
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► EditListView
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceListView EditListView { get; }
Public ReadOnly Property EditListView As ShippingServiceListView
    Get
public:
property ShippingServiceListView^ EditListView {
    ShippingServiceListView^ get ();
}

Assembly: Samples.Helper (Module: Samples.Helper)


ShippingServiceControl Constructor

ShippingServiceControl Constructor
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► ShippingServiceControl()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceControl()
Public Sub New
public:
ShippingServiceControl()

Assembly: Samples.Helper (Module: Samples.Helper)


ShippingServiceListView Class

ShippingServiceListView Class
Namespaces ► Samples.Helper.UI ► ShippingServiceListView
Summary description for ShippingServiceListView.
Declaration Syntax
C# Visual Basic Visual C++
public class ShippingServiceListView : EditListView
Public Class ShippingServiceListView _
    Inherits EditListView
public ref class ShippingServiceListView : public EditListView
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ShippingServiceListView()()()() |
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
 | AccessibilityObject | (Inherited from Control.)
 | AccessibleDefaultActionDescription | (Inherited from Control.)
 | AccessibleDescription | (Inherited from Control.)
 | AccessibleName | (Inherited from Control.)
 | AccessibleRole | (Inherited from Control.)
 | Activation | (Inherited from ListView.)
 | AfterLabelEdit | (Inherited from ListView.)
 | Alignment | (Inherited from ListView.)
 | AllowColumnReorder | (Inherited from ListView.)
 | AllowDrop | (Inherited from Control.)
 | Anchor | (Inherited from Control.)
 | ArrangeIcons(ListViewAlignment) | (Inherited from ListView.)
 | ArrangeIcons()()()() | (Inherited from ListView.)
 | AutoArrange | (Inherited from ListView.)
 | AutoResizeColumn(Int32, ColumnHeaderAutoResizeStyle) | (Inherited from ListView.)
 | AutoResizeColumns(ColumnHeaderAutoResizeStyle) | (Inherited from ListView.)
 | AutoScrollOffset | (Inherited from Control.)
 | AutoSize | (Inherited from Control.)
 | AutoSizeChanged | (Inherited from Control.)
 | BackColor | (Inherited from ListView.)
 | BackColorChanged | (Inherited from Control.)
 | BackgroundImage | (Inherited from Control.)
 | BackgroundImageChanged | (Inherited from Control.)
 | BackgroundImageLayout | (Inherited from ListView.)
 | BackgroundImageLayoutChanged | (Inherited from ListView.)
 | BackgroundImageTiled | (Inherited from ListView.)
 | BeforeLabelEdit | (Inherited from ListView.)
 | BeginInvoke(Delegate) | (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | BeginUpdate()()()() | (Inherited from ListView.)
 | BindingContext | (Inherited from Control.)
 | BindingContextChanged | (Inherited from Control.)
 | BorderStyle | (Inherited from ListView.)
 | Bottom | (Inherited from Control.)
 | Bounds | (Inherited from Control.)
 | BringToFront()()()() | (Inherited from Control.)
 | CacheVirtualItems | (Inherited from ListView.)
 | CanEnableIme | (Inherited from Control.)
 | CanFocus | (Inherited from Control.)
 | CanRaiseEvents | (Inherited from Control.)
 | CanSelect | (Inherited from Control.)
 | Capture | (Inherited from Control.)
 | CausesValidation | (Inherited from Control.)
 | CausesValidationChanged | (Inherited from Control.)
 | ChangeUICues | (Inherited from Control.)
 | CheckBoxes | (Inherited from ListView.)
 | CheckedIndices | (Inherited from ListView.)
 | CheckedItems | (Inherited from ListView.)
 | Clear()()()() | (Inherited from ListView.)
 | Click | (Inherited from Control.)
 | ClientRectangle | (Inherited from Control.)
 | ClientSize | (Inherited from Control.)
 | ClientSizeChanged | (Inherited from Control.)
 | cmbBox |
 | ColumnClick | (Inherited from ListView.)
 | ColumnReordered | (Inherited from ListView.)
 | Columns | (Inherited from ListView.)
 | ColumnWidthChanged | (Inherited from ListView.)
 | ColumnWidthChanging | (Inherited from ListView.)
 | ComboBoxColumnName |
 | ComboColumnName |
 | CompanyName | (Inherited from Control.)
 | Container | (Inherited from Component.)
 | Contains(Control) | (Inherited from Control.)
 | ContainsFocus | (Inherited from Control.)
 | ContextMenu | (Inherited from Control.)
 | ContextMenuChanged | (Inherited from Control.)
 | ContextMenuStrip | (Inherited from Control.)
 | ContextMenuStripChanged | (Inherited from Control.)
 | ControlAdded | (Inherited from Control.)
 | ControlRemoved | (Inherited from Control.)
 | Controls | (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | (Inherited from Control.)
 | CreateControl()()()() | (Inherited from Control.)
 | CreateControlsInstance()()()() | (Inherited from Control.)
 | Created | (Inherited from Control.)
 | CreateGraphics()()()() | (Inherited from Control.)
 | CreateHandle()()()() | (Inherited from ListView.)
 | CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from ListView.)
 | Cursor | (Inherited from Control.)
 | CursorChanged | (Inherited from Control.)
 | DataBindings | (Inherited from Control.)
 | DefaultCursor | (Inherited from Control.)
 | DefaultImeMode | (Inherited from Control.)
 | DefaultMargin | (Inherited from Control.)
 | DefaultMaximumSize | (Inherited from Control.)
 | DefaultMinimumSize | (Inherited from Control.)
 | DefaultPadding | (Inherited from Control.)
 | DefaultSize | (Inherited from ListView.)
 | DefWndProc(Message%) | (Inherited from Control.)
 | DesignMode | (Inherited from Component.)
 | DestroyHandle()()()() | (Inherited from Control.)
 | DisplayRectangle | (Inherited from Control.)
 | Dispose(Boolean) | (Inherited from ListView.)
 | Dispose()()()() | (Inherited from Component.)
 | Disposed | (Inherited from Component.)
 | Disposing | (Inherited from Control.)
 | Dock | (Inherited from Control.)
 | DockChanged | (Inherited from Control.)
 | DoDragDrop(Object, DragDropEffects) | (Inherited from Control.)
 | DoubleBuffered | (Inherited from ListView.)
 | DoubleClick | (Inherited from Control.)
 | DragDrop | (Inherited from Control.)
 | DragEnter | (Inherited from Control.)
 | DragLeave | (Inherited from Control.)
 | DragOver | (Inherited from Control.)
 | DrawColumnHeader | (Inherited from ListView.)
 | DrawItem | (Inherited from ListView.)
 | DrawSubItem | (Inherited from ListView.)
 | DrawToBitmap(Bitmap, Rectangle) | (Inherited from Control.)
 | editBox | (Inherited from EditListView.)
 | ELVDoubleClick(Object, EventArgs) | (Inherited from EditListView.)
 | ELVKeyDown(Object, KeyEventArgs) | (Inherited from EditListView.)
 | ELVMouseDown(Object, MouseEventArgs) | (Inherited from EditListView.)
 | Enabled | (Inherited from Control.)
 | EnabledChanged | (Inherited from Control.)
 | EndInvoke(IAsyncResult) | (Inherited from Control.)
 | EndUpdate()()()() | (Inherited from ListView.)
 | EnsureVisible(Int32) | (Inherited from ListView.)
 | Enter | (Inherited from Control.)
 | Equals(Object) | (Inherited from Object.)
 | Events | (Inherited from Component.)
 | Finalize()()()() | (Inherited from Component.)
 | FindForm()()()() | (Inherited from Control.)
 | FindItemWithText(String) | (Inherited from ListView.)
 | FindItemWithText(String, Boolean, Int32) | (Inherited from ListView.)
 | FindItemWithText(String, Boolean, Int32, Boolean) | (Inherited from ListView.)
 | FindNearestItem(SearchDirectionHint, Point) | (Inherited from ListView.)
 | FindNearestItem(SearchDirectionHint, Int32, Int32) | (Inherited from ListView.)
 | Focus()()()() | (Inherited from Control.)
 | Focused | (Inherited from Control.)
 | FocusedItem | (Inherited from ListView.)
 | Font | (Inherited from Control.)
 | FontChanged | (Inherited from Control.)
 | FontHeight | (Inherited from Control.)
 | ForeColor | (Inherited from ListView.)
 | ForeColorChanged | (Inherited from Control.)
 | FullRowSelect | (Inherited from ListView.)
 | GetAccessibilityObjectById(Int32) | (Inherited from Control.)
 | GetAutoSizeMode()()()() | (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
 | GetChildAtPoint(Point) | (Inherited from Control.)
 | GetContainerControl()()()() | (Inherited from Control.)
 | GetHashCode()()()() | (Inherited from Object.)
 | GetItemAt(Int32, Int32) | (Inherited from ListView.)
 | GetItemRect(Int32) | (Inherited from ListView.)
 | GetItemRect(Int32, ItemBoundsPortion) | (Inherited from ListView.)
 | GetLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | (Inherited from Control.)
 | GetPreferredSize(Size) | (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Control.)
 | GetService(Type) | (Inherited from Component.)
 | GetShippingServiceOptions()()()() |
 | GetStyle(ControlStyles) | (Inherited from Control.)
 | GetTopLevel()()()() | (Inherited from Control.)
 | GetType()()()() | (Inherited from Object.)
 | GiveFeedback | (Inherited from Control.)
 | GotFocus | (Inherited from Control.)
 | GridLines | (Inherited from ListView.)
 | Groups | (Inherited from ListView.)
 | Handle | (Inherited from Control.)
 | HandleCreated | (Inherited from Control.)
 | HandleDestroyed | (Inherited from Control.)
 | HasChildren | (Inherited from Control.)
 | HeaderStyle | (Inherited from ListView.)
 | Height | (Inherited from Control.)
 | HelpRequested | (Inherited from Control.)
 | Hide()()()() | (Inherited from Control.)
 | HideSelection | (Inherited from ListView.)
 | HitTest(Point) | (Inherited from ListView.)
 | HitTest(Int32, Int32) | (Inherited from ListView.)
 | HotTracking | (Inherited from ListView.)
 | HoverSelection | (Inherited from ListView.)
 | ImeMode | (Inherited from Control.)
 | ImeModeBase | (Inherited from Control.)
 | ImeModeChanged | (Inherited from Control.)
 | InitHeaderInfo(array<HeaderInfo>[]()[][]) | (Inherited from EditListView.)
 | Initialize(array<HeaderInfo>[]()[][]) | This method must be called to iniitialize the ListView. (Overrides EditListView.Initialize(array<HeaderInfo>[]()[][]).)
 | InitializeLifetimeService()()()() | (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | (Inherited from Control.)
 | InitListView(array<HeaderInfo>[]()[][]) | (Overrides EditListView.InitListView(array<HeaderInfo>[]()[][]).)
 | InsertionMark | (Inherited from ListView.)
 | Invalidate(Region) | (Inherited from Control.)
 | Invalidate(Region, Boolean) | (Inherited from Control.)
 | Invalidate()()()() | (Inherited from Control.)
 | Invalidate(Boolean) | (Inherited from Control.)
 | Invalidate(Rectangle) | (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
 | Invalidated | (Inherited from Control.)
 | Invoke(Delegate) | (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | (Inherited from Control.)
 | InvokeRequired | (Inherited from Control.)
 | IsAccessible | (Inherited from Control.)
 | IsDisposed | (Inherited from Control.)
 | IsHandleCreated | (Inherited from Control.)
 | IsInputChar(Char) | (Inherited from Control.)
 | IsInputKey(Keys) | (Inherited from ListView.)
 | IsMirrored | (Inherited from Control.)
 | ItemActivate | (Inherited from ListView.)
 | ItemCheck | (Inherited from ListView.)
 | ItemChecked | (Inherited from ListView.)
 | ItemDrag | (Inherited from ListView.)
 | ItemMouseHover | (Inherited from ListView.)
 | Items | (Inherited from ListView.)
 | ItemSelectionChanged | (Inherited from ListView.)
 | KeyDown | (Inherited from Control.)
 | KeyPress | (Inherited from Control.)
 | KeyUp | (Inherited from Control.)
 | LabelEdit | (Inherited from ListView.)
 | LabelWrap | (Inherited from ListView.)
 | LargeImageList | (Inherited from ListView.)
 | Layout | (Inherited from Control.)
 | LayoutEngine | (Inherited from Control.)
 | Leave | (Inherited from Control.)
 | Left | (Inherited from Control.)
 | ListViewItemSelected | (Inherited from EditListView.)
 | ListViewItemSorter | (Inherited from ListView.)
 | Location | (Inherited from Control.)
 | LocationChanged | (Inherited from Control.)
 | LostFocus | (Inherited from Control.)
 | Margin | (Inherited from Control.)
 | MarginChanged | (Inherited from Control.)
 | MaximumSize | (Inherited from Control.)
 | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | (Inherited from Object.)
 | MinimumSize | (Inherited from Control.)
 | MouseCaptureChanged | (Inherited from Control.)
 | MouseClick | (Inherited from Control.)
 | MouseDoubleClick | (Inherited from Control.)
 | MouseDown | (Inherited from Control.)
 | MouseEnter | (Inherited from Control.)
 | MouseHover | (Inherited from Control.)
 | MouseLeave | (Inherited from Control.)
 | MouseMove | (Inherited from Control.)
 | MouseUp | (Inherited from Control.)
 | MouseWheel | (Inherited from Control.)
 | Move | (Inherited from Control.)
 | MultiSelect | (Inherited from ListView.)
 | Name | (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | (Inherited from Control.)
 | OnAfterLabelEdit(LabelEditEventArgs) | (Inherited from ListView.)
 | OnAutoSizeChanged(EventArgs) | (Inherited from Control.)
 | OnBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | (Inherited from ListView.)
 | OnBackgroundImageLayoutChanged(EventArgs) | (Inherited from Control.)
 | OnBeforeLabelEdit(LabelEditEventArgs) | (Inherited from ListView.)
 | OnBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnCacheVirtualItems(CacheVirtualItemsEventArgs) | (Inherited from ListView.)
 | OnCausesValidationChanged(EventArgs) | (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | (Inherited from Control.)
 | OnClick(EventArgs) | (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | (Inherited from Control.)
 | OnColumnClick(ColumnClickEventArgs) | (Inherited from ListView.)
 | OnColumnReordered(ColumnReorderedEventArgs) | (Inherited from ListView.)
 | OnColumnWidthChanged(ColumnWidthChangedEventArgs) | (Inherited from ListView.)
 | OnColumnWidthChanging(ColumnWidthChangingEventArgs) | (Inherited from ListView.)
 | OnContextMenuChanged(EventArgs) | (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | (Inherited from Control.)
 | OnCreateControl()()()() | (Inherited from Control.)
 | OnCursorChanged(EventArgs) | (Inherited from Control.)
 | OnDockChanged(EventArgs) | (Inherited from Control.)
 | OnDoubleClick(EventArgs) | (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | OnDragLeave(EventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragLeave(EventArgs) | (Inherited from Control.)
 | OnDragOver(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::..OnDragOver(DragEventArgs) | (Inherited from Control.)
 | OnDrawColumnHeader(DrawListViewColumnHeaderEventArgs) | (Inherited from ListView.)
 | OnDrawItem(DrawListViewItemEventArgs) | (Inherited from ListView.)
 | OnDrawSubItem(DrawListViewSubItemEventArgs) | (Inherited from ListView.)
 | OnEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnEnter(EventArgs) | (Inherited from Control.)
 | OnFontChanged(EventArgs) | (Inherited from ListView.)
 | OnForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from Control.)
 | OnGotFocus(EventArgs) | (Inherited from Control.)
 | OnHandleCreated(EventArgs) | (Inherited from ListView.)
 | OnHandleDestroyed(EventArgs) | (Inherited from ListView.)
 | OnHelpRequested(HelpEventArgs) | (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | (Inherited from Control.)
 | OnItemActivate(EventArgs) | (Inherited from ListView.)
 | OnItemCheck(ItemCheckEventArgs) | (Inherited from ListView.)
 | OnItemChecked(ItemCheckedEventArgs) | (Inherited from ListView.)
 | OnItemDrag(ItemDragEventArgs) | (Inherited from ListView.)
 | OnItemMouseHover(ListViewItemMouseHoverEventArgs) | (Inherited from ListView.)
 | OnItemSelectionChanged(ListViewItemSelectionChangedEventArgs) | (Inherited from ListView.)
 | OnKeyDown(KeyEventArgs) | (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from Control.)
 | OnLeave(EventArgs) | (Inherited from Control.)
 | OnLocationChanged(EventArgs) | (Inherited from Control.)
 | OnLostFocus(EventArgs) | (Inherited from Control.)
 | OnMarginChanged(EventArgs) | (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from Control.)
 | OnMouseEnter(EventArgs) | (Inherited from Control.)
 | OnMouseHover(EventArgs) | (Inherited from ListView.)
 | OnMouseLeave(EventArgs) | (Inherited from ListView.)
 | OnMouseMove(MouseEventArgs) | (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | (Inherited from Control.)
 | OnMove(EventArgs) | (Inherited from Control.)
 | OnNotifyMessage(Message) | (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | (Inherited from Control.)
 | OnPaint(PaintEventArgs) | (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | (Inherited from Control.)
 | OnParentBackColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ListView.)
 | OnParentCursorChanged(EventArgs) | (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | (Inherited from Control.)
 | OnPrint(PaintEventArgs) | (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from Control.)
 | OnRegionChanged(EventArgs) | (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from ListView.)
 | OnRetrieveVirtualItem(RetrieveVirtualItemEventArgs) | (Inherited from ListView.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from Control.)
 | OnRightToLeftLayoutChanged(EventArgs) | (Inherited from ListView.)
 | OnSearchForVirtualItem(SearchForVirtualItemEventArgs) | (Inherited from ListView.)
 | OnSelectedIndexChanged(EventArgs) | (Inherited from ListView.)
 | OnSizeChanged(EventArgs) | (Inherited from Control.)
 | OnStyleChanged(EventArgs) | (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | (Inherited from ListView.)
 | OnTabIndexChanged(EventArgs) | (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | (Inherited from Control.)
 | OnTextChanged(EventArgs) | (Inherited from Control.)
 | OnValidated(EventArgs) | (Inherited from Control.)
 | OnValidating(CancelEventArgs) | (Inherited from Control.)
 | OnVirtualItemsSelectionRangeChanged(ListViewVirtualItemsSelectionRangeChangedEventArgs) | (Inherited from ListView.)
 | OnVisibleChanged(EventArgs) | (Inherited from Control.)
 | OwnerDraw | (Inherited from ListView.)
 | Padding | (Inherited from ListView.)
 | PaddingChanged | (Inherited from ListView.)
 | Paint | (Inherited from ListView.)
 | Parent | (Inherited from Control.)
 | ParentChanged | (Inherited from Control.)
 | PerformLayout()()()() | (Inherited from Control.)
 | PerformLayout(Control, String) | (Inherited from Control.)
 | PointToClient(Point) | (Inherited from Control.)
 | PointToScreen(Point) | (Inherited from Control.)
 | PreferredSize | (Inherited from Control.)
 | PreProcessControlMessage(Message%) | (Inherited from Control.)
 | PreProcessMessage(Message%) | (Inherited from Control.)
 | PreviewKeyDown | (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from Control.)
 | ProcessDialogChar(Char) | (Inherited from Control.)
 | ProcessDialogKey(Keys) | (Inherited from Control.)
 | ProcessDoubleClick(String, Int32, Int32) | (Overrides EditListView.ProcessDoubleClick(String, Int32, Int32).)
 | ProcessKeyEventArgs(Message%) | (Inherited from Control.)
 | ProcessKeyMessage(Message%) | (Inherited from Control.)
 | ProcessKeyPreview(Message%) | (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from Control.)
 | ProductName | (Inherited from Control.)
 | ProductVersion | (Inherited from Control.)
 | QueryAccessibilityHelp | (Inherited from Control.)
 | QueryContinueDrag | (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | (Inherited from Control.)
 | RealizeProperties()()()() | (Inherited from ListView.)
 | RecreateHandle()()()() | (Inherited from Control.)
 | RecreatingHandle | (Inherited from Control.)
 | RectangleToClient(Rectangle) | (Inherited from Control.)
 | RectangleToScreen(Rectangle) | (Inherited from Control.)
 | RedrawItems(Int32, Int32, Boolean) | (Inherited from ListView.)
 | Refresh()()()() | (Inherited from Control.)
 | Region | (Inherited from Control.)
 | RegionChanged | (Inherited from Control.)
 | RenderRightToLeft | Obsolete. (Inherited from Control.)
 | ResetBackColor()()()() | (Inherited from Control.)
 | ResetBindings()()()() | (Inherited from Control.)
 | ResetCursor()()()() | (Inherited from Control.)
 | ResetFont()()()() | (Inherited from Control.)
 | ResetForeColor()()()() | (Inherited from Control.)
 | ResetImeMode()()()() | (Inherited from Control.)
 | ResetMouseEventArgs()()()() | (Inherited from Control.)
 | ResetRightToLeft()()()() | (Inherited from Control.)
 | ResetText()()()() | (Inherited from Control.)
 | Resize | (Inherited from Control.)
 | ResizeRedraw | (Inherited from Control.)
 | ResumeLayout()()()() | (Inherited from Control.)
 | ResumeLayout(Boolean) | (Inherited from Control.)
 | RetrieveVirtualItem | (Inherited from ListView.)
 | Right | (Inherited from Control.)
 | RightToLeft | (Inherited from Control.)
 | RightToLeftChanged | (Inherited from Control.)
 | RightToLeftLayout | (Inherited from ListView.)
 | RightToLeftLayoutChanged | (Inherited from ListView.)
 | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | (Inherited from Control.)
 | Scale(Single) | Obsolete. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. (Inherited from Control.)
 | Scale(SizeF) | (Inherited from Control.)
 | ScaleChildren | (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from Control.)
 | ScaleCore(Single, Single) | (Inherited from Control.)
 | Scrollable | (Inherited from ListView.)
 | SearchForVirtualItem | (Inherited from ListView.)
 | Select()()()() | (Inherited from Control.)
 | Select(Boolean, Boolean) | (Inherited from Control.)
 | SelectedIndexChanged | (Inherited from ListView.)
 | SelectedIndices | (Inherited from ListView.)
 | SelectedItems | (Inherited from ListView.)
 | SelectedListViewItem | (Inherited from EditListView.)
 | SelectedListViewSubItem | (Inherited from EditListView.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | (Inherited from Control.)
 | SendToBack()()()() | (Inherited from Control.)
 | SetAutoSizeMode(AutoSizeMode) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | (Inherited from Control.)
 | SetComboBoxOptions()()()() |
 | SetComboBoxOptions(array<ControlTagItem>[]()[][]) |
 | SetStyle(ControlStyles, Boolean) | (Inherited from Control.)
 | SetTopLevel(Boolean) | (Inherited from Control.)
 | SetVisibleCore(Boolean) | (Inherited from Control.)
 | Show()()()() | (Inherited from Control.)
 | ShowFocusCues | (Inherited from Control.)
 | ShowGroups | (Inherited from ListView.)
 | ShowItemToolTips | (Inherited from ListView.)
 | ShowKeyboardCues | (Inherited from Control.)
 | Site | (Inherited from Control.)
 | Size | (Inherited from Control.)
 | SizeChanged | (Inherited from Control.)
 | SizeFromClientSize(Size) | (Inherited from Control.)
 | SmallImageList | (Inherited from ListView.)
 | Sort()()()() | (Inherited from ListView.)
 | Sorting | (Inherited from ListView.)
 | StateImageList | (Inherited from ListView.)
 | StringOptions |
 | StyleChanged | (Inherited from Control.)
 | SubItemSelectedIndex | (Inherited from EditListView.)
 | SubItemSelectedText | (Inherited from EditListView.)
 | SuspendLayout()()()() | (Inherited from Control.)
 | SystemColorsChanged | (Inherited from Control.)
 | TabIndex | (Inherited from Control.)
 | TabIndexChanged | (Inherited from Control.)
 | TabStop | (Inherited from Control.)
 | TabStopChanged | (Inherited from Control.)
 | Tag | (Inherited from Control.)
 | TagItemOptions |
 | Text | (Inherited from ListView.)
 | TextChanged | (Inherited from ListView.)
 | TileSize | (Inherited from ListView.)
 | Top | (Inherited from Control.)
 | TopItem | (Inherited from ListView.)
 | TopLevelControl | (Inherited from Control.)
 | ToString()()()() | (Inherited from ListView.)
 | Update()()()() | (Inherited from Control.)
 | UpdateBounds()()()() | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
 | UpdateExtendedStyles()()()() | (Inherited from ListView.)
 | UpdateStyles()()()() | (Inherited from Control.)
 | UpdateZOrder()()()() | (Inherited from Control.)
 | UseCompatibleStateImageBehavior | (Inherited from ListView.)
 | UseWaitCursor | (Inherited from Control.)
 | Validated | (Inherited from Control.)
 | Validating | (Inherited from Control.)
 | View | (Inherited from ListView.)
 | VirtualItemsSelectionRangeChanged | (Inherited from ListView.)
 | VirtualListSize | (Inherited from ListView.)
 | VirtualMode | (Inherited from ListView.)
 | Visible | (Inherited from Control.)
 | VisibleChanged | (Inherited from Control.)
 | Width | (Inherited from Control.)
 | WindowTarget | (Inherited from Control.)
 | WndProc(Message%) | (Inherited from ListView.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ListView
 |  |  |  |  | EditListView
 |  |  |  |  |  | ShippingServiceListView
 |  |  |  |  |  |  | IntlShippingServiceListView

Assembly: Samples.Helper (Module: Samples.Helper)


cmbBox Field

cmbBox Field
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► cmbBox
Declaration Syntax
C# Visual Basic Visual C++
protected ComboBox cmbBox
Protected cmbBox As ComboBox
protected:
ComboBox^ cmbBox

Assembly: Samples.Helper (Module: Samples.Helper)


ComboBoxColumnName Property

ComboBoxColumnName Property
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► ComboBoxColumnName
Declaration Syntax
C# Visual Basic Visual C++
public string ComboBoxColumnName { set; }
Public WriteOnly Property ComboBoxColumnName As String
    Set
public:
property String^ ComboBoxColumnName {
    void set (String^ value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


ComboColumnName Property

ComboColumnName Property
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► ComboColumnName
Declaration Syntax
C# Visual Basic Visual C++
public string ComboColumnName { get; }
Public ReadOnly Property ComboColumnName As String
    Get
public:
property String^ ComboColumnName {
    String^ get ();
}

Assembly: Samples.Helper (Module: Samples.Helper)


GetShippingServiceOptions Method

GetShippingServiceOptions Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► GetShippingServiceOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual ICollection GetShippingServiceOptions()
Public Overridable Function GetShippingServiceOptions As ICollection
public:
virtual ICollection^ GetShippingServiceOptions()
Return Value

Assembly: Samples.Helper (Module: Samples.Helper)


Initialize Method (headerInfos)

Initialize Method (headerInfos)
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► Initialize(array<HeaderInfo>[]()[][])
This method must be called to iniitialize the ListView.
Declaration Syntax
C# Visual Basic Visual C++
public override void Initialize(
    HeaderInfo[] headerInfos
)
Public Overrides Sub Initialize ( _
    headerInfos As HeaderInfo() _
)
public:
virtual void Initialize(
    array<HeaderInfo>^ headerInfos
) override
Parameters
headerInfos (array< HeaderInfo >[]()[][])

Assembly: Samples.Helper (Module: Samples.Helper)


InitListView Method (headerInfos)

InitListView Method (headerInfos)
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► InitListView(array<HeaderInfo>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
protected override void InitListView(
    HeaderInfo[] headerInfos
)
Protected Overrides Sub InitListView ( _
    headerInfos As HeaderInfo() _
)
protected:
virtual void InitListView(
    array<HeaderInfo>^ headerInfos
) override
Parameters
headerInfos (array< HeaderInfo >[]()[][])

Assembly: Samples.Helper (Module: Samples.Helper)


ProcessDoubleClick Method (action, spos, epos)

ProcessDoubleClick Method (action, spos, epos)
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► ProcessDoubleClick(String, Int32, Int32)
Declaration Syntax
C# Visual Basic Visual C++
protected override void ProcessDoubleClick(
    string action,
    int spos,
    int epos
)
Protected Overrides Sub ProcessDoubleClick ( _
    action As String, _
    spos As Integer, _
    epos As Integer _
)
protected:
virtual void ProcessDoubleClick(
    String^ action,
    int spos,
    int epos
) override
Parameters
action (String)
spos (Int32)
epos (Int32)

Assembly: Samples.Helper (Module: Samples.Helper)


SetComboBoxOptions Method

SetComboBoxOptions Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► SetComboBoxOptions()()()()
Members
Icon | Member | Description
 | SetComboBoxOptions()()()() |
 | SetComboBoxOptions(array<ControlTagItem>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


SetComboBoxOptions Method

SetComboBoxOptions Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► SetComboBoxOptions()()()()
Declaration Syntax
C# Visual Basic Visual C++
public void SetComboBoxOptions()
Public Sub SetComboBoxOptions
public:
void SetComboBoxOptions()

Assembly: Samples.Helper (Module: Samples.Helper)


SetComboBoxOptions Method (options)

SetComboBoxOptions Method (options)
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► SetComboBoxOptions(array<ControlTagItem>[]()[][])
Declaration Syntax
C# Visual Basic Visual C++
public void SetComboBoxOptions(
    ControlTagItem[] options
)
Public Sub SetComboBoxOptions ( _
    options As ControlTagItem() _
)
public:
void SetComboBoxOptions(
    array<ControlTagItem^>^ options
)
Parameters
options (array< ControlTagItem >[]()[][])

Assembly: Samples.Helper (Module: Samples.Helper)


ShippingServiceListView Constructor

ShippingServiceListView Constructor
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► ShippingServiceListView()()()()
Declaration Syntax
C# Visual Basic Visual C++
public ShippingServiceListView()
Public Sub New
public:
ShippingServiceListView()

Assembly: Samples.Helper (Module: Samples.Helper)


StringOptions Property

StringOptions Property
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► StringOptions
Declaration Syntax
C# Visual Basic Visual C++
public string[] StringOptions { set; }
Public WriteOnly Property StringOptions As String()
    Set
public:
property array<String^>^ StringOptions {
    void set (array<String^>^ value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


TagItemOptions Property

TagItemOptions Property
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► TagItemOptions
Declaration Syntax
C# Visual Basic Visual C++
public ControlTagItem[] TagItemOptions { set; }
Public WriteOnly Property TagItemOptions As ControlTagItem()
    Set
public:
property array<ControlTagItem^>^ TagItemOptions {
    void set (array<ControlTagItem^>^ value);
}

Assembly: Samples.Helper (Module: Samples.Helper)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PictureSetMemberType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AttributeSetType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Dispose Method

Dispose Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(StoreColorSchemeType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RecoupmentPolicyDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ErrorType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, MetadataType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ListingEnhancementsCodeType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<MetadataType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PromotionDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, EBaySubscriptionTypeCodeType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ProductType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(IKeyValue) | Add element.
 | Add(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(NonProfitSocialAddressType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingServiceCostOverrideType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellerDashboardAlertType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<StoreLogoType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, StoreCustomListingHeaderLinkType) |
 | IList..::..Insert(Int32, Object) |


Scale Method

Scale Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► Scale()()()()
Members
Icon | Member | Description
 | Scale(Single) | Obsolete.
 | Scale(Single, Single) | Obsolete.
 | Scale(SizeF) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PerformanceDashboardType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Invoke Method

Invoke Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► Invoke()()()()
Members
Icon | Member | Description
 | Invoke(Delegate) |
 | Invoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AddressAttributeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PromotedItemType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, StoreColorSchemeType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► Contains()()()()
Members
Icon | Member | Description
 | Contains(IError) | Indicates whether a specified object is contained in the list.
 | Contains(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingCarrierCodeType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ListingStartPriceDetailsType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(MaximumUnpaidItemStrikesDurationDetailsType) |
 | IList..::..IndexOf(Object) |


Scale Method

Scale Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► Scale()()()()
Members
Icon | Member | Description
 | Scale(Single) | Obsolete.
 | Scale(Single, Single) | Obsolete.
 | Scale(SizeF) |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(LineItemType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AddItemRequestContainerType) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<TaxIdentifierAttributeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(TaxIdentifierAttributeType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellingManagerEmailLogType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(NotificationDetailsType) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(NonProfitAddressType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DescriptionTemplateType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, VeROReportItemType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(InternationalShippingServiceOptionsType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingRegionCodeType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, eBayPLUSPreferenceType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(String) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DetailLevelCodeType) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PictureURLsType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(UserDefinedListType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(FeeType) |
 | IList..::..IndexOf(Object) |


Invalidate Method

Invalidate Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(Region) |
 | Invalidate(Region, Boolean) |
 | Invalidate()()()() |
 | Invalidate(Boolean) |
 | Invalidate(Rectangle) |
 | Invalidate(Rectangle, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellingManagerFolderDetailsType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(IKeyValue) | Get index of an element.
 | IList..::..IndexOf(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RecommendationsType) |
 | IList..::..Remove(Object) |


OnDragOver Method

OnDragOver Method
Namespaces ► Samples.Helper.UI ► EditListView ► OnDragOver()()()()
Members
Icon | Member | Description
 | OnDragOver(DragEventArgs) |
 | IDropTarget..::..OnDragOver(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CharacteristicsSetType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ValueRecommendationType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RefundFundingSourceType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(EndItemRequestContainerType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(WarrantyTypeDetailsType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CountryDetailsType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(VariationSpecificPictureSetType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RefundDetailsType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, TopRatedProgramCodeType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellingManagerFolderDetailsType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PicturesType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DetailNameCodeType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(NonProfitSocialAddressType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PicturesType) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CategoryItemSpecificsType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CharacteristicType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CharacteristicsSetType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AccountEntryType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ContextSearchAssetType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingServiceDetailsType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingServicePackageDetailsType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CurrencyDetailsType) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RecoupmentPolicyDetailsType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingServiceOptionsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AttributeType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(TaxJurisdictionType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SkypeContactOptionCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


OnDragDrop Method

OnDragDrop Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► OnDragDrop()()()()
Members
Icon | Member | Description
 | OnDragDrop(DragEventArgs) |
 | IDropTarget..::..OnDragDrop(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CharityInfoType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ListingDurationDefinitionType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(UserAgreementInfoType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(IErrorSet) | Remove element from list.
 | IList..::..Remove(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DayOfWeekCodeType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RefundFundingSourceType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PromotedItemType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, TimeZoneDetailsType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CancelDetailType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(UnitOfMeasurementType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


OnDragOver Method

OnDragOver Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► OnDragOver()()()()
Members
Icon | Member | Description
 | OnDragOver(DragEventArgs) |
 | IDropTarget..::..OnDragOver(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ExternalTransactionType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DisputeType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ProductType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<IErrorSet>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | CopyTo(Array, Int32) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CancelDetailType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(TimeZoneDetailsType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RequiredSellerActionCodeType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(TaxJurisdictionType) |
 | IList..::..Contains(Object) |


OnDragEnter Method

OnDragEnter Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► OnDragEnter()()()()
Members
Icon | Member | Description
 | OnDragEnter(DragEventArgs) |
 | IDropTarget..::..OnDragEnter(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ModifyNameType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PictureWatermarkCodeType) |
 | IList..::..Add(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, VATRateType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


OnDragDrop Method

OnDragDrop Method
Namespaces ► Samples.Helper.UI ► EditListView ► OnDragDrop()()()()
Members
Icon | Member | Description
 | OnDragDrop(DragEventArgs) |
 | IDropTarget..::..OnDragDrop(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellingManagerSoldTransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, Type) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RegionOfOriginDetailsType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RefundFundingSourceType) |
 | IList..::..Remove(Object) |


Dispose Method

Dispose Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides Control.Dispose(Boolean).)
 | Dispose()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(Type) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ItemSpecificDetailsType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, MyMessagesFolderSummaryType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(Int64) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellingManagerSoldListingsPropertyTypeCodeType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, TaxIdentifierType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(MarkUpMarkDownEventType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DiscountProfileType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(BestOfferType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellingManagerEmailLogType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(UserDefinedListType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RecommendationsType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<StoreThemeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, OfferType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ReturnsWithinDetailsType) |
 | IList..::..Insert(Int32, Object) |


RtlTranslateAlignment Method

RtlTranslateAlignment Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► RtlTranslateAlignment()()()()
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) |
 | RtlTranslateAlignment(LeftRightAlignment) |
 | RtlTranslateAlignment(ContentAlignment) |

Assembly: Samples.Helper (Module: Samples.Helper)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingCarrierCodeType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ListingRecommendationType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RegionOfOriginDetailsType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CharityIDType) |
 | IList..::..IndexOf(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(FlatRateInsuranceRangeCostType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SiteDetailsType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CancelDetailType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(TopRatedProgramCodeType) |
 | IList..::..Add(Object) |


OnDragDrop Method

OnDragDrop Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► OnDragDrop()()()()
Members
Icon | Member | Description
 | OnDragDrop(DragEventArgs) |
 | IDropTarget..::..OnDragDrop(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


FindNearestItem Method

FindNearestItem Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► FindNearestItem()()()()
Members
Icon | Member | Description
 | FindNearestItem(SearchDirectionHint, Point) |
 | FindNearestItem(SearchDirectionHint, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingServicePackageDetailsType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(VeROSiteDetailType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(WarrantyDurationDetailsType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellingManagerTemplateDetailsType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<String>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(StoreCustomPageType) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(TransactionType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DispatchTimeMaxDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(MarkUpMarkDownEventType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<MyeBayFavoriteSellerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellingManagerSoldOrderType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RestockingFeeValueDetailsType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SkypeContactOptionCodeType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AddItemRequestContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellingManagerProductType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(MessageMediaType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ApiLogger) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CharityIDType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AddMemberMessagesAAQToBidderResponseContainerType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(EndItemRequestContainerType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(StoreLogoType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(String) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DisputeFilterCountType) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PictureURLsType) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Add()()()()
Members
Icon | Member | Description
 | Add(Int32) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(Int64) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingCostPaidByDetailsType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingRegionCodeType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PictureSetMemberType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingFeatureCodeType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ApiLogger) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, BidGroupType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, String) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ThemeGroupType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ItemType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(VariationKeyType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(TransactionReferenceType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CategoryItemSpecificsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CountryDetailsType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RefundDetailsType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(EndItemRequestContainerType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SkypeContactOptionCodeType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ListingRecommendationType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ReturnsAcceptedDetailsType) |
 | IList..::..Remove(Object) |


FindItemWithText Method

FindItemWithText Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► FindItemWithText()()()()
Members
Icon | Member | Description
 | FindItemWithText(String) |
 | FindItemWithText(String, Boolean, Int32) |
 | FindItemWithText(String, Boolean, Int32, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ValType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<GiftServicesCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingPackageDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


ArrangeIcons Method

ArrangeIcons Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► ArrangeIcons()()()()
Members
Icon | Member | Description
 | ArrangeIcons(ListViewAlignment) |
 | ArrangeIcons()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingPackageInfoType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RegionDetailsType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SiteCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DeliveryURLDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingCategoryDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RestockingFeeValueDetailsType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellingManagerSoldTransactionType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(MarkUpMarkDownEventType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ItemSpecificDetailsType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, WarrantyDurationDetailsType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CountryCodeType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<FeeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RequiredSellerActionCodeType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AmountType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DisputeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, LookupAttributeType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CountryDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(MyMessagesMessageType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingCarrierDetailsType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DisputeResolutionType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<Type>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellingManagerTemplateDetailsType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PaymentTransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(MessageMediaType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellingManagerAlertType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<MyMessagesMessageType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ErrorParameterType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(StoreCustomPageType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(NameRecommendationType) |
 | IList..::..Contains(Object) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DeliveryURLDetailType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ProductSuggestionType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(MyMessagesMessageType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(eBayPLUSPreferenceType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DetailLevelCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AddItemResponseContainerType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


ResumeLayout Method

ResumeLayout Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► ResumeLayout()()()()
Members
Icon | Member | Description
 | ResumeLayout()()()() |
 | ResumeLayout(Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingServiceDetailsType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, NotificationDetailsType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<WarrantyDurationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ApiAccessRuleType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RefundTransactionType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ContextSearchAssetType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(UserAgreementInfoType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ReasonCodeDetailType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingRegionCodeType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<BestOfferType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(TransactionType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PromotionalSaleStatusCodeType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PromotedItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SiteDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<EndItemRequestContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, VeROReportedItemType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(TopRatedProgramCodeType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellingManagerAlertType) |
 | IList..::..Contains(Object) |


Select Method

Select Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► Select()()()()
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | (Overrides Control.Select(Boolean, Boolean).)
 | Select()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(VariationType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CountryDetailsType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShipmentTrackingDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CountryCodeType) |
 | IList..::..IndexOf(Object) |


Select Method

Select Method
Namespaces ► Samples.Helper.UI ► EditListView ► Select()()()()
Members
Icon | Member | Description
 | Select()()()() |
 | Select(Boolean, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


BeginInvoke Method

BeginInvoke Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► BeginInvoke()()()()
Members
Icon | Member | Description
 | BeginInvoke(Delegate) |
 | BeginInvoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PromotionalSaleType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AnnouncementMessageType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CategoryFeatureType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(BestOfferType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(MemberMessageExchangeType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ReturnsWithinDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(WarrantyTypeDetailsType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AverageRatingDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellingManagerTemplateDetailsType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PromotionalSaleType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SiteBuyerRequirementDetailsType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CountryCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ExcludeShippingLocationDetailsType) |
 | IList..::..Insert(Int32, Object) |


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► AccessibilityNotifyClients()()()()
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) |
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | Item[([( Int32])]) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellerDiscountType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(BuyerPaymentMethodCodeType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


PerformLayout Method

PerformLayout Method
Namespaces ► Samples.Helper.UI ► EditListView ► PerformLayout()()()()
Members
Icon | Member | Description
 | PerformLayout()()()() |
 | PerformLayout(Control, String) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(InternationalShippingServiceOptionsType) |
 | IList..::..Remove(Object) |


Scale Method

Scale Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► Scale()()()()
Members
Icon | Member | Description
 | Scale(Single) | Obsolete.
 | Scale(Single, Single) | Obsolete.
 | Scale(SizeF) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, Int64) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<MaximumUnpaidItemStrikesDurationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(URLDetailsType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DetailNameCodeType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(NotificationEventPropertyType) |
 | IList..::..Remove(Object) |


BeginInvoke Method

BeginInvoke Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► BeginInvoke()()()()
Members
Icon | Member | Description
 | BeginInvoke(Delegate) |
 | BeginInvoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(MetadataType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ValueRecommendationType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingCostPaidByDetailsType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ListingFeatureDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CategoryType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, StoreThemeType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(VeROReportedItemType) |
 | IList..::..IndexOf(Object) |


ResumeLayout Method

ResumeLayout Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► ResumeLayout()()()()
Members
Icon | Member | Description
 | ResumeLayout()()()() |
 | ResumeLayout(Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ExtendedProductFinderIDType) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CharacteristicType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ErrorType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ItemCompatibilityType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CategoryItemSpecificsType) |
 | IList..::..Remove(Object) |


ValidateChildren Method

ValidateChildren Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► ValidateChildren()()()()
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


OnDragLeave Method

OnDragLeave Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► OnDragLeave()()()()
Members
Icon | Member | Description
 | OnDragLeave(EventArgs) |
 | IDropTarget..::..OnDragLeave(EventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(StoreCustomCategoryType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(WarrantyOfferedDetailsType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellerDiscountType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(NotificationDetailsType) |
 | IList..::..IndexOf(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ValueRecommendationType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<VATRateType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DetailNameCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ListingStartPriceDetailsType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(VariationSpecificPictureSetType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(FeedbackPeriodType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(StoreThemeType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CommentTypeCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RegionOfOriginDetailsType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


GetChildAtPoint Method

GetChildAtPoint Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► GetChildAtPoint()()()()
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) |
 | GetChildAtPoint(Point) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DiscountProfileType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(BuyerPackageEnclosureType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RegionOfOriginDetailsType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(IErrorSet) | Indicates whether a specified object is contained in the list.
 | Contains(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingPackageInfoType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(MemberMessageExchangeType) |
 | IList..::..IndexOf(Object) |


Invalidate Method

Invalidate Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(Region) |
 | Invalidate(Region, Boolean) |
 | Invalidate()()()() |
 | Invalidate(Boolean) |
 | Invalidate(Rectangle) |
 | Invalidate(Rectangle, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PictureWatermarkCodeType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CategoryItemSpecificsType) |
 | IList..::..Add(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ApiAccessRuleType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingLocationDetailsType) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ListingDurationReferenceType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DiscountReasonCodeType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellingManagerSoldOrderType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(NonProfitAddressType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, TransactionType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(VeROReportItemType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(NameValueListType) |
 | IList..::..Add(Object) |


Validate Method

Validate Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► Validate()()()()
Members
Icon | Member | Description
 | Validate()()()() |
 | Validate(Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


PerformLayout Method

PerformLayout Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► PerformLayout()()()()
Members
Icon | Member | Description
 | PerformLayout()()()() |
 | PerformLayout(Control, String) |

Assembly: Samples.Helper (Module: Samples.Helper)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ProductType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingTypeCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingRegionCodeType) |
 | IList..::..Add(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingPackageInfoType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CategoryType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RefundTransactionInfoType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AttributeSetType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(MyeBayFavoriteSearchType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(NonProfitAddressType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Scale Method

Scale Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► Scale()()()()
Members
Icon | Member | Description
 | Scale(Single) | Obsolete.
 | Scale(Single, Single) | Obsolete.
 | Scale(SizeF) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, InternationalShippingServiceOptionsType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AmountType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SupportedSellerProfileType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ValType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ProductType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CancelDetailType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, GiftServicesCodeType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, LineItemType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(NameRecommendationType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<VariationType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ApiLogger>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ReasonCodeDetailType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(StoreLogoType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<WarrantyTypeDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(FeeType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellerDashboardAlertType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingCarrierCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ApiLogger) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AccountEntryType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(MaximumUnpaidItemStrikesDurationDetailsType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AmountType) |
 | IList..::..Insert(Int32, Object) |


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► AccessibilityNotifyClients()()()()
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) |
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(BidGroupType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Dispose Method

Dispose Method
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, VariationSpecificPictureSetType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AverageRatingDetailsType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ReturnsWithinDetailsType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(FeeType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(TransactionPlatformCodeType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(InventoryStatusType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ListingFeatureDetailsType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<UnitOfMeasurementDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<XmlElement>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ReasonCodeDetailType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, UnitOfMeasurementDetailsType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ItemTransactionIDType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(StoreSubscriptionType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<MessageMediaType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, XmlElement) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RefundTransactionType) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(FeedbackDetailType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingCarrierDetailsType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CharacteristicsSetType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PaymentOptionDetailsType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellingManagerSoldTransactionType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(StoreCustomCategoryType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingServiceDetailsType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(MyeBayFavoriteSellerType) |
 | IList..::..Remove(Object) |


InvokeAsync Method

InvokeAsync Method
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► InvokeAsync()()()()
Members
Icon | Member | Description
 | InvokeAsync(String, array<Object>[]()[][], SendOrPostCallback) |
 | InvokeAsync(String, array<Object>[]()[][], SendOrPostCallback, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellingManagerProductType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RefundFundingSourceType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ItemRatingDetailsType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AddItemResponseContainerType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RegionDetailsType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ThemeGroupType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellerDashboardAlertType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingServicePackageDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ConditionType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<MarkUpMarkDownEventType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SiteDetailsType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ItemCompatibilityType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SupportedSellerProfileType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<FeatureIDCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(MyMessagesMessageType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<VariationSpecificPictureSetType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RegionDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(StoreColorSchemeType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CommentTypeCodeType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SummaryEventScheduleType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CharityInfoType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DetailLevelCodeType) |
 | IList..::..Remove(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(MaximumUnpaidItemStrikesDurationDetailsType) |
 | IList..::..Remove(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PictureURLsType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SuggestedCategoryType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ConditionType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellingManagerFolderDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(WarrantyTypeDetailsType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ListingFeatureDetailsType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PromotionDetailsType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


OnDragEnter Method

OnDragEnter Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► OnDragEnter()()()()
Members
Icon | Member | Description
 | OnDragEnter(DragEventArgs) |
 | IDropTarget..::..OnDragEnter(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(Int32) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RecommendationsType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PolicyViolationDurationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ProductSuggestionType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PromotionalSaleType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RecommendationsType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AddItemResponseContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingPackageDetailsType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ItemBestOffersType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RecoupmentPolicyDetailsType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(IErrorSet) | Add element.
 | Add(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Validate Method

Validate Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► Validate()()()()
Members
Icon | Member | Description
 | Validate()()()() |
 | Validate(Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, TransactionPlatformCodeType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PromotionalSaleType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellerDiscountType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellingManagerSoldOrderType) |
 | IList..::..Remove(Object) |


GetChildAtPoint Method

GetChildAtPoint Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► GetChildAtPoint()()()()
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) |
 | GetChildAtPoint(Point) |

Assembly: Samples.Helper (Module: Samples.Helper)


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CharacteristicType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CharityIDType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CommentTypeCodeType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingCategoryDetailsType) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(StoreLogoType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(LineItemType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingRegionCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ListingStartPriceDetailsType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


OnDragDrop Method

OnDragDrop Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► OnDragDrop()()()()
Members
Icon | Member | Description
 | OnDragDrop(DragEventArgs) |
 | IDropTarget..::..OnDragDrop(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ListingDurationDefinitionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CurrencyDetailsType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(TransactionPlatformCodeType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellerDashboardAlertType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ItemCompatibilityType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DiscountReasonCodeType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PictureWatermarkCodeType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DetailNameCodeType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(Type) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


HitTest Method

HitTest Method
Namespaces ► Samples.Helper.UI ► EditListView ► HitTest()()()()
Members
Icon | Member | Description
 | HitTest(Point) |
 | HitTest(Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


Add Method

Add Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AttributeSet) | Add element.
 | Add(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingTypeCodeType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DayOfWeekCodeType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(WarrantyDurationDetailsType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingServicePackageDetailsType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, NameValueListType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellingManagerSoldListingsPropertyTypeCodeType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<BuyerPaymentMethodCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(WarrantyTypeDetailsType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(StoreThemeType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(StoreThemeType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, MarkUpMarkDownEventType) |
 | IList..::..Insert(Int32, Object) |


Dispose Method

Dispose Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AttributeType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(WarrantyDurationDetailsType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DisputeResolutionType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CategoryFeatureType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Invoke Method

Invoke Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► Invoke()()()()
Members
Icon | Member | Description
 | Invoke(Delegate) |
 | Invoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AddMemberMessagesAAQToBidderResponseContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


FindItemWithText Method

FindItemWithText Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► FindItemWithText()()()()
Members
Icon | Member | Description
 | FindItemWithText(String) |
 | FindItemWithText(String, Boolean, Int32) |
 | FindItemWithText(String, Boolean, Int32, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ListingDurationDefinitionType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SiteCodeType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(UserAgreementInfoType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellingManagerSoldListingsPropertyTypeCodeType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DisputeResolutionType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ExternalTransactionType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(XmlElement) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<VeROSiteDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, NotificationEnableType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PromotionDetailsType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AddMemberMessagesAAQToBidderRequestContainerType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ValType) |
 | IList..::..Contains(Object) |


BeginInvoke Method

BeginInvoke Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► BeginInvoke()()()()
Members
Icon | Member | Description
 | BeginInvoke(Delegate) |
 | BeginInvoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(EBaySubscriptionTypeCodeType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RefundLineType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ListingDurationReferenceType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Dispose Method

Dispose Method
Namespaces ► Samples.Helper.UI ► EditListView ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides Control.Dispose(Boolean).)
 | Dispose()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


OnDragLeave Method

OnDragLeave Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► OnDragLeave()()()()
Members
Icon | Member | Description
 | OnDragLeave(EventArgs) |
 | IDropTarget..::..OnDragLeave(EventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


Invoke Method

Invoke Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► Invoke()()()()
Members
Icon | Member | Description
 | Invoke(Delegate) |
 | Invoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RecommendationsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(StoreSubscriptionType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


OnDragOver Method

OnDragOver Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► OnDragOver()()()()
Members
Icon | Member | Description
 | OnDragOver(DragEventArgs) |
 | IDropTarget..::..OnDragOver(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(MyeBayFavoriteSearchType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(FeedbackDetailType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<StoreColorSchemeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(VATRateType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AddMemberMessagesAAQToBidderRequestContainerType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AttributeType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, InventoryStatusType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Invoke Method

Invoke Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► Invoke()()()()
Members
Icon | Member | Description
 | Invoke(Delegate) |
 | Invoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(UnitOfMeasurementDetailsType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, StoreCustomPageType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<OfferType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CharityAffiliationDetailType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RestockingFeeValueDetailsType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DescriptionTemplateType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RefundFundingSourceType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<MemberMessageExchangeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<FeedbackDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ExcludeShippingLocationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(LookupAttributeType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, BuyerPackageEnclosureType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RefundDetailsType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(StoreCustomListingHeaderLinkType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CategoryMappingType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PictureWatermarkCodeType) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AttributeSet) | Indicates whether a specified object is contained in the list.
 | Contains(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CharityInfoType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Validate Method

Validate Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► Validate()()()()
Members
Icon | Member | Description
 | Validate()()()() |
 | Validate(Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ListingEnhancementsCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


BeginInvoke Method

BeginInvoke Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► BeginInvoke()()()()
Members
Icon | Member | Description
 | BeginInvoke(Delegate) |
 | BeginInvoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


GetItemRect Method

GetItemRect Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► GetItemRect()()()()
Members
Icon | Member | Description
 | GetItemRect(Int32) |
 | GetItemRect(Int32, ItemBoundsPortion) |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ThemeGroupType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SearchFlagCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(VariationKeyType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(VeROReportedItemType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(XmlElement) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(TaxDetailsType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CategoryType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellerPaymentType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(NonProfitSocialAddressType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellingManagerEmailLogType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<WarrantyOfferedDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, MyeBayFavoriteSearchType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PictureWatermarkCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AddItemRequestContainerType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


UpdateBounds Method

UpdateBounds Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► UpdateBounds()()()()
Members
Icon | Member | Description
 | UpdateBounds()()()() |
 | UpdateBounds(Int32, Int32, Int32, Int32) |
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(InternationalShippingServiceOptionsType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PickupOptionsType) |
 | IList..::..Contains(Object) |


Dispose Method

Dispose Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | (Overrides Control.Dispose(Boolean).)
 | Dispose()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AddMemberMessagesAAQToBidderRequestContainerType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingServiceCostOverrideType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellerPaymentType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DescriptionTemplateType) |
 | IList..::..IndexOf(Object) |


RtlTranslateAlignment Method

RtlTranslateAlignment Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► RtlTranslateAlignment()()()()
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) |
 | RtlTranslateAlignment(LeftRightAlignment) |
 | RtlTranslateAlignment(ContentAlignment) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<StoreCustomPageType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ItemSpecificDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
Namespaces ► Samples.Helper.UI ► EditListView ► AccessibilityNotifyClients()()()()
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) |
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<TaxJurisdictionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(BidGroupItemType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingServiceCostOverrideType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DiscountReasonCodeType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(NameRecommendationType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ItemCompatibilityType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ExternalTransactionType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingServiceDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ApiAccessRuleType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingCostPaidByDetailsType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Scale Method

Scale Method
Namespaces ► Samples.Helper.UI ► EditListView ► Scale()()()()
Members
Icon | Member | Description
 | Scale(Single) | Obsolete.
 | Scale(Single, Single) | Obsolete.
 | Scale(SizeF) |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(OrderTransactionType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CharacteristicsSetType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(Int64) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<StoreSubscriptionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Invoke Method

Invoke Method
Namespaces ► Samples.Helper.UI ► EditListView ► Invoke()()()()
Members
Icon | Member | Description
 | Invoke(Delegate) |
 | Invoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SearchFlagCodeType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, TaxIdentifierAttributeType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PictureURLsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DisputeType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(InventoryStatusType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(StoreColorSchemeType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(MyeBayFavoriteSellerType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, IKeyValue) | Insert element to list.
 | IList..::..Insert(Int32, Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DayOfWeekCodeType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ListingDurationReferenceType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(String) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingPackageDetailsType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, MemberMessageExchangeType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RefundTransactionInfoType) |
 | IList..::..Remove(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PictureWatermarkCodeType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ThemeGroupType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(VariationSpecificPictureSetType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SiteBuyerRequirementDetailsType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(StoreLogoType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SkypeContactOptionCodeType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(StoreCustomCategoryType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellingManagerProductType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AmountType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ItemRatingDetailsType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellingManagerAlertType) |
 | IList..::..IndexOf(Object) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► eBay.Service.Core.Soap ► SoapHttpClientProtocolEx ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, NonProfitAddressType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ItemBidDetailsType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


OnDragOver Method

OnDragOver Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► OnDragOver()()()()
Members
Icon | Member | Description
 | OnDragOver(DragEventArgs) |
 | IDropTarget..::..OnDragOver(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellingManagerInventoryPropertyTypeCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AddItemResponseContainerType) |
 | IList..::..IndexOf(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CharacteristicType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


UpdateBounds Method

UpdateBounds Method
Namespaces ► Samples.Helper.UI ► EditListView ► UpdateBounds()()()()
Members
Icon | Member | Description
 | UpdateBounds()()()() |
 | UpdateBounds(Int32, Int32, Int32, Int32) |
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PromotionalSaleStatusCodeType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellingManagerSoldOrderType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ContextSearchAssetType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ExternalTransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PolicyViolationDurationDetailsType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(OrderTransactionType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, IErrorSet) | Insert element to list.
 | IList..::..Insert(Int32, Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ListingStartPriceDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AddItemResponseContainerType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingLocationDetailsType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, VeROSiteDetailType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(MarkUpMarkDownEventType) |
 | IList..::..IndexOf(Object) |


Dispose Method

Dispose Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ErrorParameterType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CategoryType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, MyeBayFavoriteSellerType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AttributeSet) | Insert element to list.
 | IList..::..Insert(Int32, Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellingManagerTemplateDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DisputeResolutionType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<MyMessagesFolderSummaryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, OrderTransactionType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(InventoryFeesType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DispatchTimeMaxDetailsType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RefundDetailsType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CommentTypeCodeType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(BuyerPaymentMethodCodeType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(MaximumUnpaidItemStrikesDurationDetailsType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RequiredSellerActionCodeType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(FlatRateInsuranceRangeCostType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(VariationType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PaymentOptionDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AverageRatingSummaryType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ExcludeShippingLocationDetailsType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PromotionalSaleStatusCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ReasonCodeDetailType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(VariationType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SummaryEventScheduleType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CategoryFeatureType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ProductSuggestionType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CharityIDType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<NonProfitAddressType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(String) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(NotificationEventPropertyType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingServicePackageDetailsType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, FeatureIDCodeType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(LookupAttributeType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, FlatRateInsuranceRangeCostType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, BuyerPaymentMethodCodeType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SetBounds Method

SetBounds Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► SetBounds()()()()
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) |
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AttributeSet) | Remove element from list.
 | IList..::..Remove(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ReturnsWithinDetailsType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ItemBestOffersType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(MemberMessageExchangeType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CharityAffiliationDetailType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


GetItemRect Method

GetItemRect Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► GetItemRect()()()()
Members
Icon | Member | Description
 | GetItemRect(Int32) |
 | GetItemRect(Int32, ItemBoundsPortion) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RegionOfOriginDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingFeatureCodeType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SetBounds Method

SetBounds Method
Namespaces ► Samples.Helper.UI ► EditListView ► SetBounds()()()()
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) |
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellingManagerInventoryPropertyTypeCodeType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PicturesType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(OrderTransactionType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AccountEntryType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ConditionType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingLocationDetailsType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ApiAccessRuleType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CategoryMappingType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


GetChildAtPoint Method

GetChildAtPoint Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► GetChildAtPoint()()()()
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) |
 | GetChildAtPoint(Point) |

Assembly: Samples.Helper (Module: Samples.Helper)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(StoreColorSchemeType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SiteCodeType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellerDashboardAlertType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ItemTransactionIDType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DisputeType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(OfferType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AmountType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ItemSpecificDetailsType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ThemeGroupType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PickupOptionsType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AverageRatingSummaryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


GetChildAtPoint Method

GetChildAtPoint Method
Namespaces ► Samples.Helper.UI ► EditListView ► GetChildAtPoint()()()()
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) |
 | GetChildAtPoint(Point) |

Assembly: Samples.Helper (Module: Samples.Helper)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(NotificationEnableType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CountryCodeType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AccountEntryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RefundType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellingManagerProductType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PictureSetMemberType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingFeatureCodeType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellingManagerInventoryPropertyTypeCodeType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, EndItemResponseContainerType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShipmentTrackingDetailsType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RefundTransactionInfoType) |
 | IList..::..Contains(Object) |


ResumeLayout Method

ResumeLayout Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► ResumeLayout()()()()
Members
Icon | Member | Description
 | ResumeLayout()()()() |
 | ResumeLayout(Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


BeginInvoke Method

BeginInvoke Method
Namespaces ► Samples.Helper.UI ► EditListView ► BeginInvoke()()()()
Members
Icon | Member | Description
 | BeginInvoke(Delegate) |
 | BeginInvoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(TransactionReferenceType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ErrorParameterType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(FeatureIDCodeType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<NameRecommendationType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(EBaySubscriptionTypeCodeType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(MemberMessageExchangeType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingCarrierCodeType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(MyMessagesAlertType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DetailLevelCodeType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(MyeBayFavoriteSearchType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingPackageCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SupportedSellerProfileType) |
 | IList..::..IndexOf(Object) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AttributeSet>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | CopyTo(Array, Int32) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(BuyerPackageEnclosureType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(TopRatedProgramCodeType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | IList..::..Item[([( Int32])]) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, VariationKeyType) |
 | IList..::..Insert(Int32, Object) |


SetBounds Method

SetBounds Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► SetBounds()()()()
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) |
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingFeatureCodeType) |
 | IList..::..Add(Object) |


RtlTranslateAlignment Method

RtlTranslateAlignment Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► RtlTranslateAlignment()()()()
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) |
 | RtlTranslateAlignment(LeftRightAlignment) |
 | RtlTranslateAlignment(ContentAlignment) |

Assembly: Samples.Helper (Module: Samples.Helper)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DispatchTimeMaxDetailsType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AttributeSetType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PromotedItemType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DiscountProfileType) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(OrderTransactionType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AdFormatLeadType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(TransactionPlatformCodeType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AnnouncementMessageType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(MyMessagesAlertType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AdditionalAccountType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SummaryEventScheduleType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(NotificationEnableType) |
 | IList..::..IndexOf(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(StoreThemeType) |
 | IList..::..Add(Object) |


OnDragLeave Method

OnDragLeave Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► OnDragLeave()()()()
Members
Icon | Member | Description
 | OnDragLeave(EventArgs) |
 | IDropTarget..::..OnDragLeave(EventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AnnouncementMessageType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ItemCompatibilityType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DispatchTimeMaxDetailsType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(OfferType) |
 | IList..::..IndexOf(Object) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingCategoryDetailsType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(MyMessagesAlertType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StringCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellingManagerFolderDetailsType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ExternalTransactionType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, TransactionReferenceType) |
 | IList..::..Insert(Int32, Object) |


OnDragLeave Method

OnDragLeave Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► OnDragLeave()()()()
Members
Icon | Member | Description
 | OnDragLeave(EventArgs) |
 | IDropTarget..::..OnDragLeave(EventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShipmentTrackingDetailsType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PictureSetMemberType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RegionDetailsType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingServicePackageDetailsType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingCarrierDetailsType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DeliveryURLDetailType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CharityInfoType) |
 | IList..::..IndexOf(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(MessageMediaType) |
 | IList..::..Add(Object) |


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► AccessibilityNotifyClients()()()()
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) |
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(GiftServicesCodeType) |
 | IList..::..IndexOf(Object) |


GetObjectData Method

GetObjectData Method
Namespaces ► eBay.Service.Core.Sdk ► HttpWebResponseDecompressed ► GetObjectData()()()()
Members
Icon | Member | Description
 | ISerializable..::..GetObjectData(SerializationInfo, StreamingContext) |
 | GetObjectData(SerializationInfo, StreamingContext) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ListingStartPriceDetailsType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingLocationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingPackageDetailsType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SuggestedCategoryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(VATRateType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ConditionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PaymentOptionDetailsType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CategoryItemSpecificsType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(MyMessagesMessageType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PerformanceDashboardType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, WarrantyTypeDetailsType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PromotionalSaleType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AddMemberMessagesAAQToBidderRequestContainerType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(WarrantyOfferedDetailsType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, NameRecommendationType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CountryDetailsType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(TaxDetailsType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ItemBidDetailsType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<TaxIdentifierType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ConditionType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SupportedSellerProfileType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ItemSpecificDetailsType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PaymentTransactionType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, UserAgreementInfoType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellerPaymentType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellerDiscountType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DisputeResolutionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ReturnsWithinDetailsType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CategoryMappingType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<URLDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ListingDurationReferenceType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RefundLineType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(IKeyValue) | Remove element from list.
 | Remove(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DisputeFilterCountType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(LookupAttributeType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DayOfWeekCodeType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<eBayPLUSPreferenceType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ErrorType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PerformanceDashboardType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(VariationType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(OfferType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CancelDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RefundType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DescriptionTemplateType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ItemBidDetailsType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingServiceOptionsType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


OnDragOver Method

OnDragOver Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► OnDragOver()()()()
Members
Icon | Member | Description
 | OnDragOver(DragEventArgs) |
 | IDropTarget..::..OnDragOver(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ModifyNameType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ApiAccessRuleType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AverageRatingDetailsType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(NonProfitAddressType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► StoreColorSchemeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SuggestedCategoryType) |
 | IList..::..Add(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DisputeMessageType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SummaryEventScheduleType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DiscountReasonCodeType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(FeedbackPeriodType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ExtendedProductFinderIDType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RefundTransactionType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellingManagerSoldTransactionType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DisputeMessageType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(OrderType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellingManagerInventoryPropertyTypeCodeType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AdFormatLeadType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(NameValueRelationshipType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RegionDetailsType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ListingDurationDefinitionType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RequiredSellerActionCodeType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ReasonCodeDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(IKeyValue) | Get index of an element.
 | IndexOf(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AnnouncementMessageType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DetailNameCodeType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ListingRecommendationType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DisputeMessageType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingPackageCodeType) |
 | IList..::..Add(Object) |


UpdateBounds Method

UpdateBounds Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► UpdateBounds()()()()
Members
Icon | Member | Description
 | UpdateBounds()()()() |
 | UpdateBounds(Int32, Int32, Int32, Int32) |
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, UnitOfMeasurementType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingCategoryDetailsType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, IError) | Insert element to list.
 | Insert(Int32, Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(TaxIdentifierType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(BuyerPaymentMethodCodeType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SiteDetailsType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(MyMessagesFolderSummaryType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<FeedbackPeriodType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<TaxDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ContextSearchAssetType) |
 | IList..::..IndexOf(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(TransactionType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(BidGroupType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SuggestedCategoryType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(MyMessagesFolderSummaryType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PromotionalSaleStatusCodeType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(OfferType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<NotificationDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellerPaymentType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(TimeZoneDetailsType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(VeROSiteDetailType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(BuyerPackageEnclosureType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellingManagerEmailLogType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<IErrorSet>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | ICollection..::..CopyTo(Array, Int32) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(OrderType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ItemRatingDetailsType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(TaxDetailsType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SiteDetailsType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<BuyerPackageEnclosureType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, FeeType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SupportedSellerProfileType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ExtendedProductFinderIDType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AverageRatingDetailsType) |
 | IList..::..IndexOf(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(IErrorSet) | Add element.
 | IList..::..Add(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PicturesType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ListingDurationDefinitionType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<EBaySubscriptionTypeCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ItemRatingDetailsType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ListingRecommendationType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(UnitOfMeasurementDetailsType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SkypeContactOptionCodeType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(TaxIdentifierType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DiscountProfileType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CountryCodeType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingTypeCodeType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<IError>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | CopyTo(Array, Int32) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<EndItemResponseContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<LookupAttributeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SuggestedCategoryType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ErrorType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RequiredSellerActionCodeType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(Type) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AttributeSet) | Indicates whether a specified object is contained in the list.
 | IList..::..Contains(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PerformanceDashboardType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ExternalTransactionType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | IList..::..Item[([( Int32])]) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<StoreCustomCategoryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DiscountProfileType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► MarkUpMarkDownEventTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ItemBestOffersType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SiteCodeType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(BidGroupType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<Int32>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<UserDefinedListType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Scale Method

Scale Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► Scale()()()()
Members
Icon | Member | Description
 | Scale(Single) | Obsolete.
 | Scale(Single, Single) | Obsolete.
 | Scale(SizeF) |

Assembly: Samples.Helper (Module: Samples.Helper)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ItemBestOffersType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CharityAffiliationDetailType) |
 | IList..::..Add(Object) |


OnDragLeave Method

OnDragLeave Method
Namespaces ► Samples.Helper.UI ► EditListView ► OnDragLeave()()()()
Members
Icon | Member | Description
 | OnDragLeave(EventArgs) |
 | IDropTarget..::..OnDragLeave(EventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(NonProfitSocialAddressType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AttributeSet) | Insert element to list.
 | Insert(Int32, Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(BestOfferType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, UserDefinedListType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CurrencyDetailsType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(NotificationDetailsType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AverageRatingSummaryType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PickupOptionsType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, StoreCustomCategoryType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(VATRateType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(VeROReportItemType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(XmlElement) |
 | IList..::..Contains(Object) |


Invalidate Method

Invalidate Method
Namespaces ► Samples.Helper.UI ► EditListView ► Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(Region) |
 | Invalidate(Region, Boolean) |
 | Invalidate()()()() |
 | Invalidate(Boolean) |
 | Invalidate(Rectangle) |
 | Invalidate(Rectangle, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AverageRatingSummaryType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingCarrierCodeType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ItemType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AddressAttributeType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(IErrorSet) | Remove element from list.
 | Remove(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DeliveryURLDetailType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | Item[([( Int32])]) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingServiceDetailsType) |
 | IList..::..Contains(Object) |


ResumeLayout Method

ResumeLayout Method
Namespaces ► Samples.Helper.UI ► EditListView ► ResumeLayout()()()()
Members
Icon | Member | Description
 | ResumeLayout()()()() |
 | ResumeLayout(Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DetailLevelCodeType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RefundTransactionInfoType) |
 | IList..::..Insert(Int32, Object) |


FindNearestItem Method

FindNearestItem Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► FindNearestItem()()()()
Members
Icon | Member | Description
 | FindNearestItem(SearchDirectionHint, Point) |
 | FindNearestItem(SearchDirectionHint, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CommentTypeCodeType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DescriptionTemplateType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(IKeyValue) | Indicates whether a specified object is contained in the list.
 | IList..::..Contains(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CharityIDType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(MyMessagesFolderSummaryType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


ResumeLayout Method

ResumeLayout Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► ResumeLayout()()()()
Members
Icon | Member | Description
 | ResumeLayout()()()() |
 | ResumeLayout(Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AttributeSetType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SearchFlagCodeType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingPackageInfoType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(InventoryFeesType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, StoreSubscriptionType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(UnitOfMeasurementType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<VeROReportItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ReturnsAcceptedDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AttributeSet) | Get index of an element.
 | IndexOf(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


GetChildAtPoint Method

GetChildAtPoint Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► GetChildAtPoint()()()()
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) |
 | GetChildAtPoint(Point) |

Assembly: Samples.Helper (Module: Samples.Helper)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AddMemberMessagesAAQToBidderResponseContainerType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingFeatureCodeType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(EndItemResponseContainerType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(MyMessagesFolderSummaryType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(URLDetailsType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DescriptionTemplateType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ListingRecommendationType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellingManagerInventoryPropertyTypeCodeType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


PerformLayout Method

PerformLayout Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► PerformLayout()()()()
Members
Icon | Member | Description
 | PerformLayout()()()() |
 | PerformLayout(Control, String) |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ErrorType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(OrderType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PaymentOptionDetailsType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DisputeType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellingManagerAlertType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ListingStartPriceDetailsType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingRegionCodeType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingCarrierDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(VeROReportedItemType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CategoryFeatureType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(VeROSiteDetailType) |
 | IList..::..Add(Object) |


GetChildAtPoint Method

GetChildAtPoint Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► GetChildAtPoint()()()()
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) |
 | GetChildAtPoint(Point) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(MessageMediaType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, MyMessagesAlertType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CharacteristicsSetType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<VariationKeyType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ListingFeatureDetailsType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AdditionalAccountType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(IKeyValue) | Remove element from list.
 | IList..::..Remove(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(NameValueRelationshipType) |
 | IList..::..Contains(Object) |


HitTest Method

HitTest Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► HitTest()()()()
Members
Icon | Member | Description
 | HitTest(Point) |
 | HitTest(Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PromotionDetailsType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RefundDetailsType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<NotificationEnableType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, Int32) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellingManagerAlertType) |
 | IList..::..Remove(Object) |


GetItemRect Method

GetItemRect Method
Namespaces ► Samples.Helper.UI ► EditListView ► GetItemRect()()()()
Members
Icon | Member | Description
 | GetItemRect(Int32) |
 | GetItemRect(Int32, ItemBoundsPortion) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(InventoryFeesType) |
 | IList..::..Contains(Object) |


GetWebResponse Method

GetWebResponse Method
Namespaces ► eBay.Service.Core.Soap ► eBayAPIInterfaceService ► GetWebResponse()()()()
Members
Icon | Member | Description
 | GetWebResponse(WebRequest) | (Overrides WebClientProtocol.GetWebResponse(WebRequest).)
 | GetWebResponse(WebRequest, IAsyncResult) | (Overrides WebClientProtocol.GetWebResponse(WebRequest, IAsyncResult).)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellingManagerSoldTransactionType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CharityAffiliationDetailType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AddMemberMessagesAAQToBidderResponseContainerType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellingManagerInventoryPropertyTypeCodeType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(FeedbackPeriodType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(NameValueListType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RecommendationsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RecommendationsType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingTypeCodeType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPackageEnclosureTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(BuyerPackageEnclosureType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyTypeDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CharityAffiliationDetailType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(UnitOfMeasurementType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AddMemberMessagesAAQToBidderResponseContainerType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, NotificationEventPropertyType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AddMemberMessagesAAQToBidderRequestContainerType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<BidGroupItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ErrorParameterType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ValType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(EBaySubscriptionTypeCodeType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(InternationalShippingServiceOptionsType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(IKeyValue) | Indicates whether a specified object is contained in the list.
 | Contains(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AnnouncementMessageType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ItemRatingDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, NonProfitSocialAddressType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RefundLineType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(FlatRateInsuranceRangeCostType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(TaxIdentifierAttributeType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ItemCompatibilityType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DispatchTimeMaxDetailsType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(eBayPLUSPreferenceType) |
 | IList..::..Add(Object) |


Invalidate Method

Invalidate Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(Region) |
 | Invalidate(Region, Boolean) |
 | Invalidate()()()() |
 | Invalidate(Boolean) |
 | Invalidate(Rectangle) |
 | Invalidate(Rectangle, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<BidGroupType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ApiAccessRuleType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellingManagerFolderDetailsType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SkypeContactOptionCodeType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ListingEnhancementsCodeType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PromotionDetailsType) |
 | IList..::..Contains(Object) |


BeginInvoke Method

BeginInvoke Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► BeginInvoke()()()()
Members
Icon | Member | Description
 | BeginInvoke(Delegate) |
 | BeginInvoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PaymentTransactionType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<TransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PickupOptionsType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, BestOfferType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(VeROReportItemType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Select Method

Select Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► Select()()()()
Members
Icon | Member | Description
 | Select()()()() |
 | Select(Boolean, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CharacteristicsSetType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingLocationDetailsType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DispatchTimeMaxDetailsType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(FeatureIDCodeType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SearchFlagCodeType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(BidGroupItemType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(eBayPLUSPreferenceType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


PerformLayout Method

PerformLayout Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► PerformLayout()()()()
Members
Icon | Member | Description
 | PerformLayout()()()() |
 | PerformLayout(Control, String) |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AttributeSet) | Get index of an element.
 | IList..::..IndexOf(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(FeedbackDetailType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CharityAffiliationDetailType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | Item[([( Int32])]) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RefundLineType) |
 | IList..::..IndexOf(Object) |


Invoke Method

Invoke Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► Invoke()()()()
Members
Icon | Member | Description
 | Invoke(Delegate) |
 | Invoke(Delegate, array<Object>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(IErrorSet) | Indicates whether a specified object is contained in the list.
 | IList..::..Contains(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AddItemResponseContainerType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(Int32) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CommentTypeCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CommentTypeCodeType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellerDiscountType) |
 | IList..::..Contains(Object) |


ArrangeIcons Method

ArrangeIcons Method
Namespaces ► Samples.Helper.UI ► EditListView ► ArrangeIcons()()()()
Members
Icon | Member | Description
 | ArrangeIcons(ListViewAlignment) |
 | ArrangeIcons()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PickupOptionsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | Item[([( Int32])]) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RecoupmentPolicyDetailsType) |
 | IList..::..Insert(Int32, Object) |


OnDragOver Method

OnDragOver Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► OnDragOver()()()()
Members
Icon | Member | Description
 | OnDragOver(DragEventArgs) |
 | IDropTarget..::..OnDragOver(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


Contains Method

Contains Method
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ApiLogger) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<MyeBayFavoriteSearchType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ItemTransactionIDType) |
 | IList..::..Remove(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellerDashboardAlertType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(VATRateType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(LineItemType) |
 | IList..::..Add(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


InvokeAsync Method

InvokeAsync Method
Namespaces ► eBay.Service.Core.Soap ► SoapHttpClientProtocolEx ► InvokeAsync()()()()
Members
Icon | Member | Description
 | InvokeAsync(String, array<Object>[]()[][], SendOrPostCallback) |
 | InvokeAsync(String, array<Object>[]()[][], SendOrPostCallback, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellingManagerProductType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitAddressTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


RtlTranslateAlignment Method

RtlTranslateAlignment Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► RtlTranslateAlignment()()()()
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) |
 | RtlTranslateAlignment(LeftRightAlignment) |
 | RtlTranslateAlignment(ContentAlignment) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(IError) | Get index of an element.
 | IndexOf(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ValType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, IKeyValue) | Insert element to list.
 | Insert(Int32, Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(BidGroupItemType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AttributeSet) | Add element.
 | IList..::..Add(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RefundType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ItemBidDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(FeedbackDetailType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AddressAttributeType) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ItemBidDetailsType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ItemTransactionIDType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ConditionType) |
 | IList..::..IndexOf(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ProductType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PromotionDetailsType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(NotificationDetailsType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ExternalTransactionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(StoreCustomListingHeaderLinkType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, FeedbackPeriodType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PaymentTransactionType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, NameValueRelationshipType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ExtendedProductFinderIDType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, BidGroupItemType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SiteBuyerRequirementDetailsType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(TaxIdentifierType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(NotificationEventPropertyType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(MetadataType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AddMemberMessagesAAQToBidderResponseContainerType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ModifyNameType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DayOfWeekCodeType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingCarrierDetailsType) |
 | IList..::..Add(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(TimeZoneDetailsType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<InventoryFeesType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<InternationalShippingServiceOptionsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PromotionalSaleStatusCodeType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<UserAgreementInfoType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SummaryEventScheduleType) |
 | IList..::..Contains(Object) |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DisputeMessageType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ListingEnhancementsCodeType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MemberMessageExchangeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(BidGroupItemType) |
 | IList..::..IndexOf(Object) |


OnDragDrop Method

OnDragDrop Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► OnDragDrop()()()()
Members
Icon | Member | Description
 | OnDragDrop(DragEventArgs) |
 | IDropTarget..::..OnDragDrop(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(TransactionType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ListingEnhancementsCodeType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellingManagerSoldOrderType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DisputeFilterCountType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PromotionDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingCostPaidByDetailsType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingLocationDetailsType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► AccessibilityNotifyClients()()()()
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) |
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(Int32) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AddItemRequestContainerType) |
 | IList..::..Add(Object) |


SetBounds Method

SetBounds Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► SetBounds()()()()
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) |
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) |

Assembly: Samples.Helper (Module: Samples.Helper)


OnDragLeave Method

OnDragLeave Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► OnDragLeave()()()()
Members
Icon | Member | Description
 | OnDragLeave(EventArgs) |
 | IDropTarget..::..OnDragLeave(EventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(NotificationEnableType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RefundType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(NameValueListType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellingManagerSoldListingsPropertyTypeCodeType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellingManagerEmailLogType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ExcludeShippingLocationDetailsType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RefundFundingSourceType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► FeeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(FeeType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RefundDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, TaxDetailsType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DayOfWeekCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DayOfWeekCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingTypeCodeType) |
 | IList..::..IndexOf(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(MyeBayFavoriteSellerType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Invalidate Method

Invalidate Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(Region) |
 | Invalidate(Region, Boolean) |
 | Invalidate()()()() |
 | Invalidate(Boolean) |
 | Invalidate(Rectangle) |
 | Invalidate(Rectangle, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


FindItemWithText Method

FindItemWithText Method
Namespaces ► Samples.Helper.UI ► EditListView ► FindItemWithText()()()()
Members
Icon | Member | Description
 | FindItemWithText(String) |
 | FindItemWithText(String, Boolean, Int32) |
 | FindItemWithText(String, Boolean, Int32, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


OnDragEnter Method

OnDragEnter Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► OnDragEnter()()()()
Members
Icon | Member | Description
 | OnDragEnter(DragEventArgs) |
 | IDropTarget..::..OnDragEnter(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(StoreCustomListingHeaderLinkType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<VeROReportedItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PerformanceDashboardType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ListingFeatureDetailsType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(InventoryFeesType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(URLDetailsType) |
 | IList..::..IndexOf(Object) |


OnDragEnter Method

OnDragEnter Method
Namespaces ► Samples.Helper.UI ► EditListView ► OnDragEnter()()()()
Members
Icon | Member | Description
 | OnDragEnter(DragEventArgs) |
 | IDropTarget..::..OnDragEnter(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CountryDetailsType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RequiredSellerActionCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AddressAttributeType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PromotionalSaleStatusCodeType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SiteBuyerRequirementDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, FeedbackDetailType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ItemTransactionIDType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DisputeType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ItemTransactionIDType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<LineItemType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(IErrorSet) | Get index of an element.
 | IndexOf(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RefundType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, URLDetailsType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellerDiscountType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ErrorType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(TaxIdentifierType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DeliveryURLDetailType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DiscountProfileType) |
 | IList..::..Add(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SetBounds Method

SetBounds Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► SetBounds()()()()
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) |
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(InventoryStatusType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AttributeType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DisputeFilterCountType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AverageRatingDetailsType) |
 | IList..::..Remove(Object) |


UpdateBounds Method

UpdateBounds Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► UpdateBounds()()()()
Members
Icon | Member | Description
 | UpdateBounds()()()() |
 | UpdateBounds(Int32, Int32, Int32, Int32) |
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CharityInfoType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingServiceCostOverrideType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<NameValueListType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(TaxIdentifierAttributeType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSetCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, IErrorSet) | Insert element to list.
 | Insert(Int32, Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ItemBestOffersType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(EndItemResponseContainerType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ItemSpecificDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ItemSpecificDetailsType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SiteCodeType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(eBayPLUSPreferenceType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DisputeFilterCountType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


OnDragDrop Method

OnDragDrop Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► OnDragDrop()()()()
Members
Icon | Member | Description
 | OnDragDrop(DragEventArgs) |
 | IDropTarget..::..OnDragDrop(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(VariationSpecificPictureSetType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingPackageDetailsType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<DiscountReasonCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<TimeZoneDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CategoryType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SiteBuyerRequirementDetailsType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingPackageCodeType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CategoryFeatureType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ContextSearchAssetType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CountryCodeType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(MyeBayFavoriteSellerType) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AddItemRequestContainerType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AdFormatLeadType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► InventoryFeesTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, InventoryFeesType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(GiftServicesCodeType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(SellingManagerTemplateDetailsType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(StoreSubscriptionType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerFolderDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellingManagerFolderDetailsType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(TopRatedProgramCodeType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RefundTransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RefundLineType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingServiceOptionsType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AdditionalAccountType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ExcludeShippingLocationDetailsType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(VeROSiteDetailType) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingRegionCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


UpdateBounds Method

UpdateBounds Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► UpdateBounds()()()()
Members
Icon | Member | Description
 | UpdateBounds()()()() |
 | UpdateBounds(Int32, Int32, Int32, Int32) |
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SuggestedCategoryType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RegionOfOriginDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RegionOfOriginDetailsType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellingManagerSoldListingsPropertyTypeCodeType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► Add()()()()
Members
Icon | Member | Description
 | Add(IError) | Add element.
 | Add(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.SDK.Util ► IKeyValueCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<IKeyValue>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | CopyTo(Array, Int32) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DispatchTimeMaxDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ExtendedProductFinderIDType) |
 | IList..::..Remove(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(StoreCustomPageType) |
 | IList..::..Remove(Object) |


ArrangeIcons Method

ArrangeIcons Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► ArrangeIcons()()()()
Members
Icon | Member | Description
 | ArrangeIcons(ListViewAlignment) |
 | ArrangeIcons()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ListingDurationReferenceType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AverageRatingSummaryType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PickupOptionsType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(NotificationEnableType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CharacteristicType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PaymentOptionDetailsType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingFeatureCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CountryCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PicturesType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AnnouncementMessageType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellerPaymentType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingPackageDetailsType) |
 | IList..::..Remove(Object) |


HitTest Method

HitTest Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► HitTest()()()()
Members
Icon | Member | Description
 | HitTest(Point) |
 | HitTest(Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ShippingServicePackageDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(MyeBayFavoriteSearchType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(StoreCustomListingHeaderLinkType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(NameRecommendationType) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PolicyViolationDurationDetailsType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(UnitOfMeasurementDetailsType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PolicyViolationDurationDetailsType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(Type) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SellingManagerSoldTransactionType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(NotificationEventPropertyType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(TaxIdentifierAttributeType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CancelDetailType) |
 | IList..::..Add(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(RegionDetailsType) |
 | IList..::..Contains(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<NotificationEventPropertyType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ApiLogger) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PromotionalSaleType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► Samples.Helper.UI ► EditListView ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► TimeZoneDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(TimeZoneDetailsType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ListingEnhancementsCodeType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VeROSiteDetailTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ItemType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AddItemResponseContainerTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingCarrierDetailsType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellingManagerProductType) |
 | IList..::..IndexOf(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(MyMessagesAlertType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SiteDetailsType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PerformanceDashboardType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellerPaymentType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RefundTransactionType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingPackageCodeType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingCostPaidByDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CharacteristicsSetTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ListingRecommendationType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerInventoryPropertyTypeCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NotificationDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► LookupAttributeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(LookupAttributeType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DiscountReasonCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DiscountReasonCodeType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RestockingFeeValueDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ReturnsAcceptedDetailsType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AttributeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Namespaces

Namespaces overview
Namespaces
Namespaces
Namespace | Description
eBay.Service.Call |
eBay.Service.Core.Sdk |
eBay.Service.Core.Soap |
eBay.Service.EPS |
eBay.Service.SDK.Attribute |
eBay.Service.SDK.Util |
eBay.Service.Util |
Samples.Helper |
Samples.Helper.Cache |
Samples.Helper.UI |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PerformanceDashboardTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ExtendedProductFinderIDType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ListingFeatureDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ListingFeatureDetailsType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(TaxDetailsType) |
 | IList..::..IndexOf(Object) |


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► AccessibilityNotifyClients()()()()
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) |
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(VeROReportItemType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) |
 | MemberwiseClone()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ProductSuggestionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupItemTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AdditionalAccountType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingServiceOptionsType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AdFormatLeadType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<NonProfitSocialAddressType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ValueRecommendationType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► DeliveryURLDetailTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, DeliveryURLDetailType) |
 | IList..::..Insert(Int32, Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AdFormatLeadType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AverageRatingDetailsType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationReferenceTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ListingDurationReferenceType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ErrorParameterType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.SDK.Attribute ► IAttributeSetCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AttributeSet) | Remove element from list.
 | Remove(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Select Method

Select Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► Select()()()()
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | (Overrides Control.Select(Boolean, Boolean).)
 | Select()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SiteCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SiteCodeType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, EndItemRequestContainerType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(GiftServicesCodeType) |
 | IList..::..Contains(Object) |


PerformLayout Method

PerformLayout Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► PerformLayout()()()()
Members
Icon | Member | Description
 | PerformLayout()()()() |
 | PerformLayout(Control, String) |

Assembly: Samples.Helper (Module: Samples.Helper)


Add Method

Add Method
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(IKeyValue) | Add element.
 | IList..::..Add(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► LineItemTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(LineItemType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SearchFlagCodeType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackDetailTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► VariationTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, VariationType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ListingEnhancementsCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PictureURLsType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(FeedbackPeriodType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ModifyNameType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(WarrantyDurationDetailsType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<PicturesType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ProductType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEventPropertyTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AddressAttributeType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) | Gets an element at the specified index in the collection.
 | IList..::..Item[([( Int32])]) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(RefundTransactionInfoType) |
 | IList..::..IndexOf(Object) |


Select Method

Select Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► Select()()()()
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | (Overrides Control.Select(Boolean, Boolean).)
 | Select()()()() |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ValTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ValType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VATRateTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RefundDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► BestOfferTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(BestOfferType) |
 | IList..::..IndexOf(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► AmountTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AmountType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DescriptionTemplateTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ErrorTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RestockingFeeValueDetailsType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► NameRecommendationTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<Int64>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


ValidateChildren Method

ValidateChildren Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► ValidateChildren()()()()
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)

Assembly: Samples.Helper (Module: Samples.Helper)


OnDragEnter Method

OnDragEnter Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► OnDragEnter()()()()
Members
Icon | Member | Description
 | OnDragEnter(DragEventArgs) |
 | IDropTarget..::..OnDragEnter(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DisputeMessageType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RefundLineTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RefundLineType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(NameValueRelationshipType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Select Method

Select Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► Select()()()()
Members
Icon | Member | Description
 | Select()()()() |
 | Select(Boolean, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingCategoryDetailsType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CategoryMappingType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellingManagerEmailLogType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AddressAttributeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AddressAttributeType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CharityAffiliationDetailTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SupportedSellerProfileType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(FlatRateInsuranceRangeCostType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► StoreLogoTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, StoreLogoType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TaxDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(BuyerPaymentMethodCodeType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingPackageCodeType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(TransactionReferenceType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CharityInfoTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CharityInfoType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(TaxJurisdictionType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderRequestContainerTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(AddMemberMessagesAAQToBidderRequestContainerType) |
 | IList..::..Remove(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShippingCarrierCodeType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SupportedSellerProfileTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingServiceCostOverrideType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► DetailNameCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(DetailNameCodeType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleStatusCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(MetadataType) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► StoreThemeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<MyMessagesAlertType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemTransactionIDTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► OrderTransactionTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<OrderTransactionType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingServiceOptionsType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(VariationKeyType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AttributeSetType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, CurrencyDetailsType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PaymentTransactionType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ProductTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


FindNearestItem Method

FindNearestItem Method
Namespaces ► Samples.Helper.UI ► EditListView ► FindNearestItem()()()()
Members
Icon | Member | Description
 | FindNearestItem(SearchDirectionHint, Point) |
 | FindNearestItem(SearchDirectionHint, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ShipmentTrackingDetailsType) |
 | IList..::..Remove(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShipmentTrackingDetailsType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ItemBestOffersTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ItemBestOffersType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingTypeCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingTypeCodeType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CharityIDType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► NotificationEnableTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<UnitOfMeasurementType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(PaymentTransactionType) |
 | IList..::..IndexOf(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(XmlElement) |
 | IList..::..IndexOf(Object) |


RtlTranslateAlignment Method

RtlTranslateAlignment Method
Namespaces ► Samples.Helper.UI ► EditListView ► RtlTranslateAlignment()()()()
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) |
 | RtlTranslateAlignment(LeftRightAlignment) |
 | RtlTranslateAlignment(ContentAlignment) |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DisputeMessageTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DisputeMessageType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ListingDurationDefinitionType) |
 | IList..::..Insert(Int32, Object) |


SetComboBoxOptions Method

SetComboBoxOptions Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► SetComboBoxOptions()()()()
Members
Icon | Member | Description
 | SetComboBoxOptions()()()() |
 | SetComboBoxOptions(array<ControlTagItem>[]()[][]) |

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► FeedbackPeriodTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Dispose Method

Dispose Method
Namespaces ► eBay.Service.Core.Soap ► SoapHttpClientProtocolEx ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose()()()() |
 | Dispose(Boolean) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ReturnsWithinDetailsType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ExtendedProductFinderIDTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ItemRatingDetailsType) |
 | IList..::..IndexOf(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SummaryEventScheduleTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SummaryEventScheduleType) |
 | IList..::..Add(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ReturnsWithinDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingCostPaidByDetailsType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Invalidate Method

Invalidate Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(Region) |
 | Invalidate(Region, Boolean) |
 | Invalidate()()()() |
 | Invalidate(Boolean) |
 | Invalidate(Rectangle) |
 | Invalidate(Rectangle, Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AddMemberMessagesAAQToBidderResponseContainerTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(UserAgreementInfoType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceOptionsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShippingServiceOptionsType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CategoryTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CategoryType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► UserAgreementInfoTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.SDK.Util ► KeyValueCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<IKeyValue>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | ICollection..::..CopyTo(Array, Int32) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(UnitOfMeasurementType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CategoryItemSpecificsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CategoryItemSpecificsType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSearchTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ReturnsAcceptedDetailsType) |
 | IList..::..Add(Object) |


PerformLayout Method

PerformLayout Method
Namespaces ► Samples.Helper.UI ► ShippingServiceListView ► PerformLayout()()()()
Members
Icon | Member | Description
 | PerformLayout()()()() |
 | PerformLayout(Control, String) |

Assembly: Samples.Helper (Module: Samples.Helper)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(CurrencyDetailsType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AccountEntryType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► Int32Collection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<StoreCustomListingHeaderLinkType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<TransactionPlatformCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► SellerDiscountTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► CurrencyDetailsTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<CurrencyDetailsType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ReturnsAcceptedDetailsType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ContextSearchAssetTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ContextSearchAssetType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerTemplateDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(SellingManagerTemplateDetailsType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ShippingLocationDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RestockingFeeValueDetailsType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► NonProfitSocialAddressTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ShippingPackageCodeType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesAlertTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(RecoupmentPolicyDetailsType) |
 | IList..::..Add(Object) |


ValidateChildren Method

ValidateChildren Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► ValidateChildren()()()()
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)

Assembly: Samples.Helper (Module: Samples.Helper)


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.SDK.Attribute ► IErrorSet ► Remove()()()()
Members
Icon | Member | Description
 | Remove(IError) | Remove element from list.
 | Remove(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ReasonCodeDetailTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ReasonCodeDetailType) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


GetWebResponse Method

GetWebResponse Method
Namespaces ► eBay.Service.Core.Soap ► SoapHttpClientProtocolEx ► GetWebResponse()()()()
Members
Icon | Member | Description
 | GetWebResponse(WebRequest) | (Overrides WebClientProtocol.GetWebResponse(WebRequest).)
 | GetWebResponse(WebRequest, IAsyncResult) | (Overrides WebClientProtocol.GetWebResponse(WebRequest, IAsyncResult).)


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► MaximumUnpaidItemStrikesDurationDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, MaximumUnpaidItemStrikesDurationDetailsType) |
 | IList..::..Insert(Int32, Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AdFormatLeadType) |
 | IList..::..Insert(Int32, Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ShippingPackageInfoType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► DetailLevelCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(DetailLevelCodeType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► AnnouncementMessageTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(CategoryFeatureType) |
 | IList..::..Remove(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(FeatureIDCodeType) |
 | IList..::..Remove(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PromotedItemType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SearchFlagCodeTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SearchFlagCodeType) |
 | IList..::..IndexOf(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ConditionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceCostOverrideTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingServiceCostOverrideType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► BidGroupTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(BidGroupType) |
 | IList..::..Remove(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► TopRatedProgramCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<TopRatedProgramCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyDurationDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SiteDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► VariationKeyTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(VariationKeyType) |
 | IList..::..Add(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► SiteBuyerRequirementDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(SiteBuyerRequirementDetailsType) |
 | IList..::..Remove(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ModifyNameType) |
 | IList..::..Remove(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ReturnsAcceptedDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ReturnsAcceptedDetailsType) |
 | IList..::..IndexOf(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CharacteristicTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CharacteristicType) |
 | IList..::..Contains(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(PolicyViolationDurationDetailsType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(TaxJurisdictionType) |
 | IList..::..Remove(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► Int64Collection ► Add()()()()
Members
Icon | Member | Description
 | Add(Int64) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.SDK.Attribute ► AttributeSetCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<AttributeSet>[]()[][], Int32) | Copies the collection objects to a one-dimensional Array instance beginning at the specified index.
 | ICollection..::..CopyTo(Array, Int32) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


SetBounds Method

SetBounds Method
Namespaces ► Samples.Helper.UI ► IntlShippingServiceListView ► SetBounds()()()()
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) |
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) |

Assembly: Samples.Helper (Module: Samples.Helper)


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Util ► ApiLoggerCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ItemType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellerPaymentTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCostPaidByDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(EndItemRequestContainerType) |
 | IList..::..Remove(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(InventoryStatusType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellerDashboardAlertTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► DiscountProfileTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AdditionalAccountType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► URLDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(URLDetailsType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ValueRecommendationType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ItemCompatibilityTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<OrderType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RefundTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RefundType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AverageRatingSummaryTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AverageRatingSummaryType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► RefundFundingSourceTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<NameValueRelationshipType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► BuyerPaymentMethodCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(UserDefinedListType) |
 | IList..::..Contains(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldTransactionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ShippingServiceDetailsTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ShippingServiceDetailsType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► EndItemRequestContainerTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(EndItemResponseContainerType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomPageTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(StoreCustomPageType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► DisputeFilterCountTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(DisputeFilterCountType) |
 | IList..::..IndexOf(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PaymentOptionDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PaymentOptionDetailsType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MyeBayFavoriteSellerTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► CategoryFeatureTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerEmailLogTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingCategoryDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingCategoryDetailsType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<TransactionReferenceType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ExcludeShippingLocationDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ExcludeShippingLocationDetailsType) |
 | IList..::..Add(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► TaxIdentifierAttributeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► AccountEntryTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, AccountEntryType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<SellingManagerSoldListingsPropertyTypeCodeType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► EndItemResponseContainerTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(EndItemResponseContainerType) |
 | IList..::..Contains(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldOrderTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(SellingManagerSoldOrderType) |
 | IList..::..IndexOf(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► PaymentTransactionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► AddItemRequestContainerTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(AddItemRequestContainerType) |
 | IList..::..Contains(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► InternationalShippingServiceOptionsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, RefundTransactionType) |
 | IList..::..Insert(Int32, Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(NameValueRelationshipType) |
 | IList..::..Add(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► RestockingFeeValueDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PromotionalSaleTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


RtlTranslateAlignment Method

RtlTranslateAlignment Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► RtlTranslateAlignment()()()()
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) |
 | RtlTranslateAlignment(LeftRightAlignment) |
 | RtlTranslateAlignment(ContentAlignment) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<FlatRateInsuranceRangeCostType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PolicyViolationDurationDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PolicyViolationDurationDetailsType) |
 | IList..::..Add(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PictureURLsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PictureURLsType) |
 | IList..::..Insert(Int32, Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► GiftServicesCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(GiftServicesCodeType) |
 | IList..::..Remove(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ShippingCarrierCodeTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, OrderType) |
 | IList..::..Insert(Int32, Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ModifyNameTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ModifyNameType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► MyMessagesMessageTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, MyMessagesMessageType) |
 | IList..::..Insert(Int32, Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ItemRatingDetailsTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► RefundTransactionInfoTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<RefundTransactionInfoType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► EBaySubscriptionTypeCodeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(EBaySubscriptionTypeCodeType) |
 | IList..::..Add(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerProductTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


UpdateBounds Method

UpdateBounds Method
Namespaces ► Samples.Helper.UI ► CheckBoxGroupControl ► UpdateBounds()()()()
Members
Icon | Member | Description
 | UpdateBounds()()()() |
 | UpdateBounds(Int32, Int32, Int32, Int32) |
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) |

Assembly: Samples.Helper (Module: Samples.Helper)


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► ErrorParameterTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<ErrorParameterType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► OrderTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(OrderType) |
 | IList..::..Contains(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► RegionDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(WarrantyOfferedDetailsType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► SuggestedCategoryTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► RequiredSellerActionCodeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► ShippingPackageInfoTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, ShippingPackageInfoType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► StoreCustomListingHeaderLinkTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(PictureSetMemberType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► eBayPLUSPreferenceTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► FlatRateInsuranceRangeCostTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► SkypeContactOptionCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► PictureSetMemberTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, PictureSetMemberType) |
 | IList..::..Insert(Int32, Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► UserDefinedListTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(UserDefinedListType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CountryDetailsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, WarrantyOfferedDetailsType) |
 | IList..::..Insert(Int32, Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ShippingFeatureCodeTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► CharityIDTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► XmlElementCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VeROReportItemTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► OfferTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ProductSuggestionType) |
 | IList..::..Contains(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► PromotedItemTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(PromotedItemType) |
 | IList..::..Add(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► DisputeTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► StoreSubscriptionTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(StoreSubscriptionType) |
 | IList..::..Remove(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► ListingDurationDefinitionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(CategoryMappingType) |
 | IList..::..Add(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ShipmentTrackingDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ShipmentTrackingDetailsType) |
 | IList..::..Add(Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► CategoryMappingTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(CategoryMappingType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► TransactionPlatformCodeTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(TransactionPlatformCodeType) |
 | IList..::..Remove(Object) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► ValueRecommendationTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(ValueRecommendationType) |
 | IList..::..Contains(Object) |


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► MyMessagesFolderSummaryTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► SellingManagerAlertTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, SellingManagerAlertType) |
 | IList..::..Insert(Int32, Object) |


ResumeLayout Method

ResumeLayout Method
Namespaces ► Samples.Helper.UI ► ShippingServiceControl ► ResumeLayout()()()()
Members
Icon | Member | Description
 | ResumeLayout()()()() |
 | ResumeLayout(Boolean) |

Assembly: Samples.Helper (Module: Samples.Helper)


SyncRoot Property

SyncRoot Property
Namespaces ► eBay.Service.Core.Soap ► ListingRecommendationTypeCollection ► SyncRoot
Members
Icon | Member | Description
 | SyncRoot |
 | ICollection..::..SyncRoot |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► FeatureIDCodeTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(FeatureIDCodeType) |
 | IList..::..Contains(Object) |


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, TaxJurisdictionType) |
 | IList..::..Insert(Int32, Object) |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► UnitOfMeasurementDetailsTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(UnitOfMeasurementDetailsType) |
 | IList..::..Contains(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ItemBidDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ItemBidDetailsType) |
 | IList..::..Remove(Object) |


OnDragEnter Method

OnDragEnter Method
Namespaces ► Samples.Helper.UI ► InternationalShippingServiceControl ► OnDragEnter()()()()
Members
Icon | Member | Description
 | OnDragEnter(DragEventArgs) |
 | IDropTarget..::..OnDragEnter(DragEventArgs) |

Assembly: Samples.Helper (Module: Samples.Helper)


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► ItemTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(ItemType) |
 | IList..::..Remove(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TransactionTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► ProductSuggestionTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(ProductSuggestionType) |
 | IList..::..IndexOf(Object) |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► RecoupmentPolicyDetailsTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(RecoupmentPolicyDetailsType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► VeROReportedItemTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(VeROReportedItemType) |
 | IList..::..Add(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PicturesTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► ApiAccessRuleTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► CancelDetailTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Remove Method

Remove Method
Namespaces ► eBay.Service.Core.Soap ► MetadataTypeCollection ► Remove()()()()
Members
Icon | Member | Description
 | Remove(MetadataType) |
 | IList..::..Remove(Object) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► AttributeTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(AttributeType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AdditionalAccountTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AdditionalAccountType) |
 | IList..::..IndexOf(Object) |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(WarrantyOfferedDetailsType) |
 | IList..::..Add(Object) |


CopyTo Method

CopyTo Method
Namespaces ► eBay.Service.Core.Soap ► InventoryStatusTypeCollection ► CopyTo()()()()
Members
Icon | Member | Description
 | CopyTo(array<InventoryStatusType>[]()[][], Int32) |
 | ICollection..::..CopyTo(Array, Int32) |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► DisputeResolutionTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(DisputeResolutionType) |
 | IList..::..Add(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► AttributeSetTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(AttributeSetType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► WarrantyOfferedDetailsTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


Item Property

Item Property
Namespaces ► eBay.Service.Core.Soap ► ListingStartPriceDetailsTypeCollection ► Item
Members
Icon | Member | Description
 | Item[([( Int32])]) |
 | IList..::..Item[([( Int32])]) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.SDK.Attribute ► ErrorSetCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(IErrorSet) | Get index of an element.
 | IList..::..IndexOf(Object) |

Assembly: eBay.Service.SDK.Attribute (Module: eBay.Service.SDK.Attribute)


Insert Method

Insert Method
Namespaces ► eBay.Service.Core.Soap ► MessageMediaTypeCollection ► Insert()()()()
Members
Icon | Member | Description
 | Insert(Int32, MessageMediaType) |
 | IList..::..Insert(Int32, Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► VariationSpecificPictureSetTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► PictureWatermarkCodeTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Add Method

Add Method
Namespaces ► eBay.Service.Core.Soap ► ThemeGroupTypeCollection ► Add()()()()
Members
Icon | Member | Description
 | Add(ThemeGroupType) |
 | IList..::..Add(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► SellingManagerSoldListingsPropertyTypeCodeTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IsSynchronized Property

IsSynchronized Property
Namespaces ► eBay.Service.Core.Soap ► PickupOptionsTypeCollection ► IsSynchronized
Members
Icon | Member | Description
 | IsSynchronized |
 | ICollection..::..IsSynchronized |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► TaxJurisdictionTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


Contains Method

Contains Method
Namespaces ► eBay.Service.Core.Soap ► StoreCustomCategoryTypeCollection ► Contains()()()()
Members
Icon | Member | Description
 | Contains(StoreCustomCategoryType) |
 | IList..::..Contains(Object) |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► NameValueListTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(NameValueListType) |
 | IList..::..IndexOf(Object) |


IsReadOnly Property

IsReadOnly Property
Namespaces ► eBay.Service.Core.Soap ► AdFormatLeadTypeCollection ► IsReadOnly
Members
Icon | Member | Description
 | IsReadOnly |
 | IList..::..IsReadOnly |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► NameValueRelationshipTypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


IndexOf Method

IndexOf Method
Namespaces ► eBay.Service.Core.Soap ► TransactionReferenceTypeCollection ► IndexOf()()()()
Members
Icon | Member | Description
 | IndexOf(TransactionReferenceType) |
 | IList..::..IndexOf(Object) |


IsFixedSize Property

IsFixedSize Property
Namespaces ► eBay.Service.Core.Soap ► TypeCollection ► IsFixedSize
Members
Icon | Member | Description
 | IsFixedSize |
 | IList..::..IsFixedSize |


eBay.Service.Call Namespace

eBay.Service.Call Namespace
Namespaces ► eBay.Service.Call
Declaration Syntax
C# Visual Basic Visual C++
namespace eBay.Service.Call
Namespace eBay.Service.Call
namespace eBay.Service.Call
Types
All Types Classes
Icon | Type | Description
 | AddDisputeCall |
 | AddDisputeResponseCall |
 | AddFixedPriceItemCall |
 | AddItemCall |
 | AddItemFromSellingManagerTemplateCall |
 | AddItemsCall |
 | AddMemberMessageAAQToPartnerCall |
 | AddMemberMessageRTQCall |
 | AddMemberMessagesAAQToBidderCall |
 | AddOrderCall |
 | AddSecondChanceItemCall |
 | AddSellingManagerInventoryFolderCall |
 | AddSellingManagerProductCall |
 | AddSellingManagerTemplateCall |
 | AddToItemDescriptionCall |
 | AddToWatchListCall |
 | AddTransactionConfirmationItemCall |
 | CompleteSaleCall |
 | ConfirmIdentityCall |
 | DeleteMyMessagesCall |
 | DeleteSellingManagerInventoryFolderCall |
 | DeleteSellingManagerItemAutomationRuleCall |
 | DeleteSellingManagerProductCall |
 | DeleteSellingManagerTemplateAutomationRuleCall |
 | DeleteSellingManagerTemplateCall |
 | DisableUnpaidItemAssistanceCall |
 | EndFixedPriceItemCall |
 | EndItemCall |
 | EndItemsCall |
 | ExtendSiteHostedPicturesCall |
 | FetchTokenCall |
 | GetAccountCall |
 | GetAdFormatLeadsCall |
 | GetAllBiddersCall |
 | GetApiAccessRulesCall |
 | GetBestOffersCall |
 | GetBidderListCall |
 | GetCategoriesCall |
 | GetCategoryFeaturesCall |
 | GetCategoryMappingsCall |
 | GetCategorySpecificsCall |
 | GetChallengeTokenCall |
 | GetCharitiesCall |
 | GetClientAlertsAuthTokenCall |
 | GetContextualKeywordsCall |
 | GetDescriptionTemplatesCall |
 | GetDisputeCall |
 | GeteBayDetailsCall |
 | GeteBayOfficialTimeCall |
 | GetFeedbackCall |
 | GetItemCall |
 | GetItemsAwaitingFeedbackCall |
 | GetItemShippingCall |
 | GetItemTransactionsCall |
 | GetMemberMessagesCall |
 | GetMessagePreferencesCall |
 | GetMyeBayBuyingCall |
 | GetMyeBayRemindersCall |
 | GetMyeBaySellingCall |
 | GetMyMessagesCall |
 | GetNotificationPreferencesCall |
 | GetNotificationsUsageCall |
 | GetOrdersCall |
 | GetOrderTransactionsCall |
 | GetPromotionalSaleDetailsCall |
 | GetSellerDashboardCall |
 | GetSellerEventsCall |
 | GetSellerListCall |
 | GetSellerPaymentsCall |
 | GetSellerTransactionsCall |
 | GetSellingManagerAlertsCall |
 | GetSellingManagerEmailLogCall |
 | GetSellingManagerInventoryCall |
 | GetSellingManagerInventoryFolderCall |
 | GetSellingManagerItemAutomationRuleCall |
 | GetSellingManagerSaleRecordCall |
 | GetSellingManagerSoldListingsCall |
 | GetSellingManagerTemplateAutomationRuleCall |
 | GetSellingManagerTemplatesCall |
 | GetSessionIDCall |
 | GetShippingDiscountProfilesCall |
 | GetStoreCall |
 | GetStoreCategoryUpdateStatusCall |
 | GetStoreCustomPageCall |
 | GetStoreOptionsCall |
 | GetStorePreferencesCall |
 | GetSuggestedCategoriesCall |
 | GetTaxTableCall |
 | GetTokenStatusCall |
 | GetUserCall |
 | GetUserContactDetailsCall |
 | GetUserDisputesCall |
 | GetUserPreferencesCall |
 | GetVeROReasonCodeDetailsCall |
 | GetVeROReportStatusCall |
 | IssueRefundCall |
 | LeaveFeedbackCall |
 | MoveSellingManagerInventoryFolderCall |
 | PlaceOfferCall |
 | RelistFixedPriceItemCall |
 | RelistItemCall |
 | RemoveFromWatchListCall |
 | RespondToBestOfferCall |
 | RespondToFeedbackCall |
 | ReviseCheckoutStatusCall |
 | ReviseFixedPriceItemCall |
 | ReviseInventoryStatusCall |
 | ReviseItemCall |
 | ReviseMyMessagesCall |
 | ReviseMyMessagesFoldersCall |
 | ReviseSellingManagerInventoryFolderCall |
 | ReviseSellingManagerProductCall |
 | ReviseSellingManagerSaleRecordCall |
 | ReviseSellingManagerTemplateCall |
 | RevokeTokenCall |
 | SaveItemToSellingManagerTemplateCall |
 | SellerReverseDisputeCall |
 | SendInvoiceCall |
 | SetMessagePreferencesCall |
 | SetNotificationPreferencesCall |
 | SetPromotionalSaleCall |
 | SetPromotionalSaleListingsCall |
 | SetSellingManagerFeedbackOptionsCall |
 | SetSellingManagerItemAutomationRuleCall |
 | SetSellingManagerTemplateAutomationRuleCall |
 | SetShippingDiscountProfilesCall |
 | SetStoreCall |
 | SetStoreCategoriesCall |
 | SetStoreCustomPageCall |
 | SetStorePreferencesCall |
 | SetTaxTableCall |
 | SetUserNotesCall |
 | SetUserPreferencesCall |
 | ValidateChallengeInputCall |
 | ValidateTestUserRegistrationCall |
 | VerifyAddFixedPriceItemCall |
 | VerifyAddItemCall |
 | VerifyAddSecondChanceItemCall |
 | VerifyRelistItemCall |
 | VeROReportItemsCall |